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Overview of WebSeeker
WebSeeker 2.0 is a meta-searcher. It resides above search engines, such as Yahoo, Lycos, Webcrawler, etc. WebSeeker 2.0 
performs a comprehensive search of numerous different search engines by creating individual keyword searches for each engine. 
WebSeeker 2.0 then brings back the results, sorts them, removes duplicates, collates them, and presents the results to the user. 
The user can then view the results in an HTML Web page.

In WebSeeker 2.0 you can create a WebSeeker 2.0 file (.WSK file) containing your search, and the Results for the search. A WSK 
file can be named after a user, a broad subject, or anything that the user chooses. Each .WSK file contains a keyword search for 
each search engine loaded in WebSeeker 2.0. Each search returns results. All of the results are listed together in the display 
window.

Click Search NOW! for a step by step tutorial on how to perform an Internet search, or click Quick Tutorial to choose from all the 
tutorial lessons on using WebSeeker 2.0.



What's New In WebSeeker 2.0?
 Refine - A new Refine process lets you distill the results of FilterFind searches, fine-tuning your results with multiple filters that let 
you include only results with complete phrases, NOT conditions, and more!

 New User Interface - A new, more intuitive interface improves usability: 
¨ Informative visual feedback in the status and display windows
¨ Intuitive menus
¨ Graphic display of search progress
¨ Streamlined dialog boxes to make product features accessible

 Improved Searching - More robust parallel searching speeds up the process by conducting searches on multiple engines at once.

 InstantUpdate - Automatic program updates via the Internet.

 HTML - Enhanced Web page output of search results for one-click browsing



Enter the title for the subject of the search(es) here.



Chapter One Lessons

Lesson 1: Creating a New Search
Lesson 2: Opening an Existing Search
Lesson 3: Expanding a Search
Lesson 4: Renewing a Search
Lesson 5: Customizing a Search
Lesson 6: Stopping a Search
Lesson 7: Boolean Operators



For better results keep each search narrow and create more searches.



Use the Boolean operators AND and Or to restrict, or expand searches.



Enter keywords for your search here.



This tab is not used in customizing a search. Please select another tab.



Click OK to accept current configuration and launch search.



AND is a search option that links keywords together for the search. When AND is selected WebSeeker looks for documents 
containing all of the keywords listed.



Click here to create additional Searches with new Keywords.



Click Cancel to discard any changes and abort current search.



Click the Help button at any time to open the WebSeeker help file.



Click Finish to accept current changes and begin search without proceeding to the next step.



Click Next > to accept changes and proceed to the next step. 



Brings up a dialog box specific to the selected Search Engine. 

Enter subject title and keywords for the new search.



Enter a Title for the search here.



Select one of the radio buttons to qualify the search.



Select as many of these options as desired to expand or restrict the search base.



Select this option to restrict the results to only those which match the case of the keywords.



This option restricts the number of results WebSeeker retrieves.



This option to restrict the search to a specified domain. For example, enter com to restrict the search to URLs with a .com extension.
Some other possible domains are:
org (organizations); edu (educational);Countries - UK (United Kingdom), US (United States), IT (Italy); etc.



Use this option restricts the search to a specified domain. For example, enter com to restrict the search to URLs with a .com 
extension. Some other possible domains are:
org (organizations); edu (educational);Countries - UK (United Kingdom), US (United States), IT (Italy); etc.



This option restricts the number of results WebSeeker retrieves.



Select this option to restrict the results to only those which match the case of the keywords.



This option restricts the Search Result to a specific range of Dates.





This option allows you set the Minimum Rating allowable for Search Results. Rating criteria is specific to each search engine.







This option restricts the area WebSeeker searches.









This field lists the available Search Modules.



After you have selected a Search Module click Create Search to enter keywords and options for the new search.



This field describes the selected Search Module.



Searches all of the existing subjects.



This field lists all of the available Search Engines. You may customize your search by selecting only the desired search engines. 
Search Engines are highlighted when selected.
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Click Find Now to accept any changes made and launch a search of the active subject and keywords immediately. 



Click Find Later to launch the search at a later time.



Use the WebSeeker Internet Scheduler to automate your searches at night or off-peak hours.
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Menu Options

    File Menu       Results Menu

 Edit Menu     Tools Menu

 View Menu     Help Menu

 Search Menu



File Menu
The file menu deals specifically with WebSeeker (.WSK) files. A .WSK file is the file created by WebSeeker containing all of the 
search results, and configuration information for a search.

Click on the graphic below to learn more about each option.



File Menu
The file menu deals specifically with WebSeeker (.WSK) files. A .WSK file is the file created by WebSeeker containing all of the 
search results, and configuration information for a search.

Click on the graphic below to learn more about each option.



Edit Menu
From the Edit menu, you can access the standard Windows actions for manipulating individual items. In the context of WebSeeker, 
items generally refer to individual search results or search engines.

Most of these commands are grayed out and unavailable unless you have selected one or more specific items. Conversely, Paste is
available only when you have recently cut or copied an item.

Click on the graphic below to learn more about each option.

 You can rename a Search Result by right clicking on the Search Result and selecting Properties. Enter the title for the 
desired name in the Title field of the search module dialog box.



 View Menu
The View menu is used to display specific tools and results. To learn more about each option click on the menu below.



View Menu
The View menu is used to display specific tools and results. To learn more about each option click on the menu below.



Search Menu
The search menu is used to configure and launch searches. Click on the menu below to learn more about each option.



Results Menu
The Results menu is used to manage search results. Click on the dialog box below to learn more about each option.



Results Menu
The Results menu is used to manage search results. Click on the dialog box below to learn more about each option.



Tools Menu
The Tools menu is used to access WebSeeker search tools and the Preferences dialog. Click on the dialog box below to learn 
more about each option.



File Menu
Edit Menu
View Menu
Search Menu
Results Menu
Tools Menu
Help Menu



Help Menu
The Help Menu is used to receive information about WebSeeker. Click on the menu below to learn more about each option.



Register
Enter requested information in this dialog to register on-line!



Advanced Features

    Setting Preferences       Command Line Functions

    Time Out Settings     Search Engine Specific Options

    Search Scheduler



Time Out Settings
You can set the length of time that WebSeeker waits for Reading information, Connecting to a search engine, and Requesting 
information.

1.        After you have completed the information in the Start New Search Dialog box, select .

2.        From the Tools Menu select Preferences. The following dialog box appears.

3.       Select the Network Tab.

4.        Set the Time Out Settings to the desired length of time.

5.        Press OK to accept settings and close the Preferences dialog box. Or, select another tab to set other preferences.



 
Time Out Settings
You can set the length of time that WebSeeker waits for Reading information, Connecting to a search engine, and Requesting 
information.

1.        After you have completed the information in the Start New Search Dialog box, select .

2.        From the Tools Menu select Preferences. The following dialog box appears.

3.        Select the Network Tab.
4.        Set the Time Out Settings to the desired length of time.



Preferences (View Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

From the View tab on the Preferences dialog box you can choose which results you want included in, or excluded from, the display 
window. You can also change the orientation of the screen layout.

To set Preferences:

1.        From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed.

2.        In the Include section, place a check in the box before each type of result you want to include in the display of 
search results. You can choose to include any combination of the following: New, Old, Changed, or Rejected 
results.

3.        In the Exclude section, place a check in the box before each type of result you want to exclude from the display of 
search results. You can choose to exclude up to four of the following: Duplicate URLs, Duplicate Titles, Monitored 
results, or Not Monitored results, Browsed results or Not Browsed results. When one result type is the exact 
opposite of another result type you must choose between the two types.

4.       In the Layout section, you can choose between Horizontal and Vertical layout preferences. The layout preference 
affects the orientation of the two panes (Search Engines and Titles/URLs) in the main WebSeeker window.

5.        When you have finished configuring your View preferences, click OK to accept the current configuration and close 
the Preferences dialog box, or click another tab to configure more preferences.



Select the Network tab!



Search Scheduler
Schedule is a powerful utility that automatically launches any action that has been scheduled. It can be used to perform completely 
unattended searches. Schedule can be accessed by selecting Schedule from the Search menu.

To learn more about Schedule and scheduling unattended searches, click on one of the options below.

    More about   Schedule      Perform an unattended search



Perform an Unattended Search
Creating an unattended search requires you to coordinate a number of different settings, particularly if you are connecting to the 
Internet through a modem as most people do. In addition to setting up the search in the main WebSeeker window, you must:

¨ Create a standard Windows 95 Dial-Up Connection to your Internet Service Provider.
¨ Schedule Don’t Stop to press the Connect button on your Windows 95 Dial-Up Connection and handle busy 

signals.
¨ Schedule Grab-a-Dial to run your Windows 95 Dial-Up Connection.
¨ Schedule your search.
¨ Schedule Hang-It-Up to disconnect your modem at the end of the search. 

Your Internet Service Provider should be able to tell you how to create a Dial-Up Connection for their particular setup.

To perform an unattended WebSeeker search follow these steps:

1.        Configure your search.

2.        Select Tools, Preferences.

The Preferences dialog box appears, open to the View tab.

3.        Select the Schedule tab.

¨ Select the Run After check box.
¨ Press enter, or browse for the directory and file name for hangitup.exe. This program automatically disconnects 

your computer from the Internet as soon as the search is completed. (If you are running with a T1 or other direct
connectivity, you do not need to use hangitup.exe).

¨ Make any other desired modifications and press OK.

4.        From the File menu select Save As.

The Save As dialog box appears.



5.       Enter the desired name for the WSK file and press OK.

6.        After you have saved the search, select Schedule from the Search menu. The Schedule window appears.

The active, saved search is listed in the display window followed by the word “unattended.”

7.          Select the action (search) in the Schedule display window, and then select Configure , Edit. The Add/Edit dialog 
box appears.

Click on the dialog box below to learn more about each option



8.          Set the time you would like the unattended search to run, and change any other settings desired. Press OK.
The Schedule main window returns.

If you have a T1 connection you may minimize (not exit) Schedule now. If you are using a modem you must complete the following 
steps.

9.          From the Configure menu select Add.
The Add\Edit dialog appears.

10.          In the command line field enter directory and file name, or, browse for Grab-a-Dial.
Grab-a-Dial launches any Windows dial up programs. If you prefer another program to Grab-a-Dial, you may enter 
it instead.

By default Grab-a-Dial is installed to: C:\Program Files\ForeFront\WebSeeker.

11.          In the Command Line field add the name of your dial up connection in quotes. The full command line should look 
like this:

C:\Program Files\ForeFront\WebSeeker\Grabdial.exe “my Internet connection”

    NOTE: The name of your dial up connection varies depending your individual account, and naming preferences. Make sure you use the 
correct name for your dial up connection.

12.          Set the time for Grab-a-Dial to launch a few minutes before the search is scheduled.

¨ This insures that a connection is made before the search is launched.
¨ When you have finished configuring the action press OK.

The Schedule window reappears.

13.          Following the above procedure, add Don’t Stop to the SQD file.
Don’t Stop totally automates your dial up program by pressing OK¸ Yes, Connect?, etc. on any dialogs in your dial
up program that may require a response.

¨ Set Don’t Stop to run before Grab-a-Dial, or other similar program.

The Schedule window should now have three actions listed. The result looks like this:



14.          From the File menu select Save As. The Save As dialog box appears.

¨ Enter a name for the SQD file and press OK.

15.          You may now minimize (not exit) Schedule.

    NOTE: Schedule must be running in order to launch scheduled actions.

    More about Schedule



Perform an Unattended Search
Creating an unattended search requires you to coordinate a number of different settings, particularly if you are connecting to the 
Internet through a modem as most people do. In addition to setting up the search in the main WebSeeker window, you must:

¨ Create a standard Windows 95 Dial-Up Connection to your Internet Service Provider.
¨ Schedule Don’t Stop to press the Connect button on your Windows 95 Dial-Up Connection and handle busy 

signals.
¨ Schedule Grab-a-Dial to run your Windows 95 Dial-Up Connection.
¨ Schedule your search.
¨ Schedule Hang-It-Up to disconnect your modem at the end of the search.

Your Internet Service Provider should be able to tell you how to create a Dial-Up Connection for their particular setup.

To perform an unattended WebSeeker search follow these steps:

1.          Configure your search.

2.          Select Tools, Preferences.

The Preferences dialog box appears, open to the View tab.

3.        Select the Schedule tab.

¨ Select the Run After check box.
¨ Enter, or browse for, the directory and file name for hangitup.exe. This program automatically disconnects your 

computer from the Internet as soon as the search is completed. (If you are running with a T1 or other direct 
connectivity, you do not need to use hangitup.exe).

¨ Make any other desired modifications and press OK.

4.        From the File menu select Save As.

The Save As dialog box appears.



5.          Enter the desired name for the WSK file and press OK.

6.          After you have saved the search, select Search, Schedule from the Search Menu. The Schedule window 
appears.

The active, saved search is listed in the display window followed by the word “unattended.”

7.          Select the action (search) in the Schedule display window, and then select Configure, Edit. The Add/Edit dialog 
box appears.

Click on the dialog box below to learn more about each option

8.        Set the time you would like the unattended search to run, and change any other settings desired. Press OK.
The Schedule main window returns.

If you have a T1 connection you may minimize (not exit) Schedule now. If you are using a modem you must complete the following 
steps.

9.        From the Configure menu select Add.
The Add\Edit dialog appears.

10.        In the command line field enter directory and file name, or, browse for Grab-a-Dial.
Grab-a-Dial launches any Windows dial up programs. If you prefer another program to Grab-a-Dial, you may enter 
it instead.

By default Grab-a-Dial is installed to: C:\Program Files\ForeFront\WebSeeker.

11.          In the Command Line field add the name of your dial up connection in quotes. The full command line should look 
like this:

C:\Program Files\ForeFront\WebSeeker\Grabdial.exe “my Internet connection”

    NOTE: The name of your dial up connection varies depending your individual account, and naming preferences. Make sure you use the 
correct name for your dial up connection.

12.        Set the time for Grab-a-Dial to launch a few minutes before the search is scheduled.

¨ This insures that a connection has been made before the search is launched.
¨ When you have finished configuring the action press OK.

The Schedule window reappears.

13.          Following the above procedure, add Don’t Stop to the SQD file.
Don’t Stop totally automates your dial up program by pressing OK¸ Yes, Connect?, etc. on any dialogs in your dial
up program that may require a response.

¨ Set Don’t Stop to run before Grab-a-Dial, or other similar program.

The Schedule window should now have three actions listed. The result looks like this:

14.          From the File menu select Save As. The Save As dialog box appears.

¨ Enter a name for the SQD file and press OK.

15.          You may now minimize (not exit) Schedule.



    NOTE: Schedule must be running in order to launch scheduled actions.

    More about Schedule



Select the Scheduling tab.



Command Line Functions
Search Engine Specific Options
Time Out Settings



Command Line Functions
Command Line Functions are available when using the Schedule utility. The Command line field is accessed by selecting Add or 
Edit from the Configure menu in the Schedule window. In addition to the path and file name, the Command line text box can take 
the following options:

Command Function

/e Exit upon completion

/u Unattended search.

 These command line functions are for WebSeeker scheduling only! They do not work with other applications.



Search Engine Specific Options
Each Search Engine is configured with a specific set of options. You can customize your search for each specific search engine 
depending on the available options. To view a search engine’s options highlight the search engine and from the menu select Edit, 
Properties. 

Some helpful search engine configuration options are:

 Number of Hits

    Restrict search to ___ domain

    Case Sensitive

    Dates

    Minimum Rating

    Search Area



Search Engine Specific Options
Time Out Settings
Search Scheduler



Time Out Settings
Search Scheduler
Command Line Functions



Command Line Functions
Search Engine Specific Options
Time Out Settings



Enter your E-mail address here. This field is optional. E-mail information is used to inform the search engine who is querying.



Enter the name of your browser here. This is an optional field.



Set the maximum number of simultaneous connections here.



Set the maximum number of Reposts here.



Set the maximum time for Reading here.



Set the maximum time to wait for Connection.



Set the maximum amount of time for Requesting information here.



Enter the name of your Proxy Server (if applicable) here.



Enter Proxy Port (if applicable) here.



Click here to Browse for your Internet Browser.



Search Scheduler
Command Line Functions
Search Engine Specific Options



Command Line Functions
Search Engine Specific Options
Time Out Settings



AND is a search option that links keywords together for the search. When you are searching for a particular pair or larger group of 
keywords, use the AND Boolean Operator to restrict your search. For example, a search could be launched for “computer 
animation.” In the keywords field the keywords "computer" and "animation" are entered. Click the AND radio button to select it. 
WebSeeker now searches for documents including both keywords, “computer” AND “animation.” Selecting the AND box 
automatically removes any search engines that do not support AND searches. 



AS A PHRASE is a search option that searches for all of the keywords entered, in the exact order they are entered.



OR Operator
Boolean Operators
AS A PHRASE
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The OR operator is often used to include two different phrases of a Boolean search. For example, using the keywords "plane" and 
"airplane,” select OR as the Boolean Operator. WebSeeker now searches for all documents containing either the word "plane,” OR 
the word "airplane,” OR both. This expands your search to include documents that might not otherwise be found. An article that only
uses the word "plane" would not be found while searching for just "airplane."



Boolean Operators
AND Operator



Brings up the WebSeeker search dialog box.



Adds a single keyword query of one Search Engine to the selected Subject.



Manually add a Search Result to the selected Search.



Adds a keyword query of all the loaded Search Engines to the selected Subject.



Deletes the selected Subject, Search, or Search Result.



Inserts a Subject, Search, or Search Result above the selected one.



Modifies the selected Subject, Search, or Search Result.



Launches your Web Browser with the URL for the selected Search Result.



Displays database statistics on current search.



Compact Database results.



Displays Search Results excluding Duplicate Titles.



Displays Search Results excluding Duplicate URLs.



Displays Search Results excluding Monitored results.



Displays Search Results excluding Non-Monitored results.



Displays Search Results excluding those that have been tagged as Browsed.



Displays Search Results excluding Non-Browsed results.



Displays Search Results that are New since the last search on the current keywords.



Displays Search Results that have been Changed since the last search on the current keywords.



Displays Old Search Results



Displays Search Results which were previously Rejected.



Exits WebSeeker.



File Menu
Edit Menu
View Menu
Search Menu
Results Menu
Tools Menu
Help Menu



Brings up the WebSeeker Start New Search dialog box to create a new search.



Opens an already existing WSK file. The Open File dialog box appears.



Saves the active search subject to a WSK file named by the user.



Deletes the active WSK file and all of its Search Results.



Imports the hot links (URLs) from HTM and HTML files into the current Search Results where they can be monitored, browsed, or 
rejected the same as any other Search Result. For more information on this feature see Import Files.



Import File
You can import all of the links (URL’s) from any HTM or HTML file using the Import function on the file menu. WebSeeker adds the 
URL’s to the results list of the active file. The word “Import” appears in the Search Engines pane of the results window. Select 
Import to view the imported results.

To import HTM/HTML links into a search’s results:

1.      Open the search you want to import the HTM/HTML links into.

2.      From the File menu select Import. 

The Import dialog box appears.

3.      Enter the file you want to import.

¨ If you know the file name and directory of the HTM or HTML file containing the links you want to import, you can
enter it in the file name field.

¨ Or, navigate to the to the correct directory and select the desired file by clicking on it.
¨ Press OK or Enter.

4.      WebSeeker imports the file’s links (URL’s) into the current search results.

You can view the imported URL’s in the Results window. If the Search Engines pane is not visible, select View, Search Engines. 
The Search Engines pane appears. Select the entry entitled “Import” in the Search Engines pane. The imported URL’s are 
displayed in the Title pane.

If you import the links of multiple HTM/HTML files into a search’s result, the new results will be added to the current Import” entry.



Creates a file which logs the errors for each search.



Creates a file for each subject which logs any details of the subject. Additions are made to this file each time a search is run on the 
subject.



Keeps the source of the result including all links. This enables you to double click on an individual Search Result and go directly to 
that results’ web page.



This area displays recently used files. If the user selects one of these files WebSeeker automatically opens the file.



File Menu
Edit Menu
View Menu
Search Menu
Results Menu
Tools Menu
Help Menu



Cuts the selection and puts it on the clipboard. This option is only enabled in Refine mode.



Copies the selection and puts it on the clipboard. This option is only enabled in Refine mode.



Inserts the clipboard contents at the    point of insertion. This option is only enabled in Refine mode.



Deletes the selection from the active file. A Warning dialog box appears to verify you want to delete the item.



Selects all Results.



Launches your browser to the selected results web page. The page can either be located on the World Wide Web, or on your hard 
drive if a FilterFind search is performed.



Launches your web browser to the Web page created by WebSeeker containing all results of the current search and their links.



Displays statistics on current results.



Select this option to turn refiner on/off.



Select this option to refine results. Brings up the Refine dialog box.



Launches the Internet Scheduler. The Schedule window appears.

See Advanced Features to learn more about the schedule function.





Sets the results of the Scheduled search to one of the listed options.



Brings up the Preferences dialog box.



The Preferences dialog box



Launches InstantUpdate.



Compact Database, any items that have been deleted or cleared are permanently removed from the database.



If a Search Engine is selected this brings up the dialog box specific to that Search Engine. If a URL is selected the Add/Edit URL 
dialog box appears.



Runs a program before the search begins.



Browse for programs to run before search begins.



Press OK to accept any changes made to Preferences and close the Preferences dialog box.



Press Cancel to discard any changes made to Preferences and close the Preferences dialog box.



Enter desired delay time before search begins.



Click here to configure results to be written to HTML file.



Select the write out option that best represents the file type you prefer. You may only choose one.



Enter the name for the HTML file here. You may choose a new file name, or you may have results added to an existing file. If you 
choose not to enter a name, WebSeeker creates the default file CURRENT.HTM.



Browse to select an HTM file for current search.



Enter the name for the Text file here. You may choose a new file name, or you may have results added to an existing file. If you 
choose not to enter a name, WebSeeker creates the default file URLLIST.TXT.



Browse to select a TXT file for current search.



Runs a program after the search has finished.



Runs a program after the search has finished. Enter the name of the program you want to run.



Browse for a program to run after the search is completed.



Click OK to accept the current configurations and close the Preferences dialog box.



Click Apply to accept the current configuration and leave the Preferences dialog box open to allow additional changes.



Click here to have WebSeeker alert you when the search is complete.



Preferences (Browser Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Browser Preferences tell WebSeeker which Web browser to use for displaying the results of a search. If nothing is entered, 
WebSeeker uses your default browser. If you have more than one Web browser on your computer and you don’t know which is 
your default browser, double-click an HTM or HTML file from Windows Explorer. The Web browser that launches with the selected 
file is your default browser.

To set Preferences:

1.         From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Browser tab to switch to the Browser Preferences page.

2.        Enter the complete path of the Web browser you want WebSeeker to use when browsing search results.

¨ If you want to use your system’s default Web browser, leave the text box blank.
¨ If you know the file name and location of the Web browser you want to use, type it in the Web Browser text box.
¨ If you do not know the name and location of your preferred Web browser, click the Browse button to open a 

Windows File Open dialog box.

Locate the name and directory of the browser you want to use, and click Open. The Browser tab of the 
Preferences dialog box returns with the selected browser name entered in the Web Browser text box.

3.        When you have finished configuring your Browser preferences, click OK to accept the current configuration and 
close the Preferences dialog box, or click another tab to configure more preferences.





Preferences (Writing Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Writing Preferences let you decide whether WebSeeker should notify you when a search is complete; what files, if any, to write 
out with the URLs and HTML of the search; and whether to run a program after the search is complete.

To set preferences:

1.        From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Writing tab to switch to the Writing Preferences page.

2.        If you want WebSeeker to prompt you when it completes a non-scheduled search, select Notify when complete.

3.        The next four radio buttons allow you to choose your writing options for non-scheduled searches. You can make any
one of the following choices:

¨ Choose Write out nothing if you do not want WebSeeker to write search results to a file of any sort.
¨ Choose Write out URLs to if you want WebSeeker to write the URLs of its search results to a text file. Type the

full name and path for the file in the text box. If you do not include a path, WebSeeker saves the file in its own 
directory (WebSeeker) by default. If you want to save the URLs to an existing file, click Browse-1, navigate to 
the desired file, and click Open to save your file choice and return to the Writing preferences page.

¨ Choose Write out HTML to if you want WebSeeker to write its search results to an HTML file that you can view
in your Web browser. Type the full name and path for the file in the text box. If you do not include a path, 
WebSeeker saves the file in its own directory (WebSeeker) by default. If you want to save the results to an 
existing file, click Browse-2, navigate to the desired file, and click Open to save your file choice and return to the
Writing preferences page.

¨ Choose Write out <date>.HTM file if you want WebSeeker to write its search results to an HTML file named 
<today’s date>.HTM. You will then be able to browse your search results through your Web browser.

¨ If you want to adjust the format of the HTML file, click HTML Format. Choose which results you want to include 



or exclude and whether you want results sorted by Title, URL, or Type. Click OK to save your file choice and 
return to the Writing preferences page.

4.        If you want WebSeeker to automatically run a program when the search is complete, select Run Program. Type the
full name and path for the file in the text box. If you do not know the full path, click Browse-3, navigate to the desired 
file, and click Open to save your choice and return to the Writing preferences page.

5.        When you have finished configuring your Writing preferences, click OK to accept the current configuration and 
close the Preferences dialog box, or click another tab to configure more preferences.



Preferences (Writing Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Writing Preferences let you decide whether WebSeeker should notify you when a search is complete; what files, if any, to write 
out with the URLs and HTML of the search; and whether to run a program after the search is complete.

To set preferences:

1.          From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Writing tab to switch to the Writing Preferences page.

2.          If you want WebSeeker to prompt you when it completes a non-scheduled search, select Notify when complete.

3.          The next four radio buttons allow you to choose your writing options for non-scheduled searches. You can make 
any one of the following choices:

¨ Choose Write out nothing if you do not want WebSeeker to write search results to a file of any sort.
¨ Choose Write out URLs to if you want WebSeeker to write the URLs of its search results to a text file. Type the

full name and path for the file in the text box. If you do not include a path, WebSeeker saves the file in its own 
directory (WebSeeker) by default. If you want to save the URLs to an existing file, click Browse-1, navigate to 
the desired file, and click Open to save your file choice and return to the Writing preferences page.

¨ Choose Write out HTML to if you want WebSeeker to write its search results to an HTML file that you can view
in your Web browser. Type the full name and path for the file in the text box. If you do not include a path, 
WebSeeker saves the file in its own directory (WebSeeker) by default. If you want to save the results to an 
existing file, click Browse-2, navigate to the desired file, and click Open to save your file choice and return to the
Writing preferences page.

¨ Choose Write out <date>.HTM file if you want WebSeeker to write its search results to an HTML file named 
<today’s date>.HTM. You will then be able to browse your search results through your Web browser.

¨ If you want to adjust the format of the HTML file, click HTML Format. Choose which results you want to include 



or exclude and whether you want results sorted by Title, URL, or Type. Click OK to save your file choice and 
return to the Writing preferences page.

4.          If you want WebSeeker to automatically run a program when the search is complete, select Run Program. Type 
the full name and path for the file in the text box. If you do not know the full path, click Browse-3, navigate to the 
desired file, and click Open to save your choice and return to the Writing preferences page.

5.          When you have finished configuring your Writing preferences, click OK to accept the current configuration and 
close the Preferences dialog box, or click another tab to configure more preferences.



Preferences (Scheduling Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Scheduling Preferences tab sets basic preferences for an unattended search. You can decide whether WebSeeker should 
notify you when a search is complete; what files, if any, to write out with the URLs and HTML of the search; and whether to run a 
program after the search is complete.

To set preferences:

1.          From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Scheduling tab to switch to the Scheduling Preferences page.

2.          If you want WebSeeker to automatically run a program before beginning a scheduled search, select Run Program
in the Before Search Begins section. For example, you may need to run a dialing program in order to make your 
Internet connection. Type the full name and path for the program file in the text box. If you do not know the full name 
and path, click Browse-1, navigate to the desired file, and click Open to save your choice and return to the 
Scheduling preferences page.

If you want WebSeeker to delay between running the program and starting the search, select Delay and then enter 
the number of seconds in the seconds text box.

3.          The first four radio buttons in the After Search Is Complete section let you choose your writing options for 
scheduled searches. You can make any of the following choices.

¨ Choose Write out nothing if you do not want WebSeeker to write search results to a file of any sort.
¨ Choose Write out URLs to if you want WebSeeker to write the URLs of its search results to a text file. Type the

full name and path for the file in the text box. If you do not include a path, WebSeeker saves the file in its own 
directory (WebSeeker) by default. If you want to save the URLs to an existing file, click Browse-2, navigate to 



the desired file, and click Open to save your file choice and return to the Scheduling preferences page.
¨ Choose Write out HTML to if you want WebSeeker to write its search results to an HTML file that you can view

in your Web browser. Type the full name and path for the file in the text box. If you do not include a path, 
WebSeeker saves the file in its own directory (WebSeeker) by default. If you want to save the results to an 
existing file, click Browse-3, navigate to the desired file, and click Open to save your file choice and return to the
Scheduling preferences page.

¨ Choose Write out <date>.HTM file if you want WebSeeker to write its search results to an HTML file named 
<today’s date>.HTM. You will then be able to browse your search results through your Web browser.

¨ If you want to adjust the format of the HTML file, click HTML Format. Choose which results you want to include 
or exclude and whether you want results sorted by Title, URL, or Type. Click OK to save your file choice and 
return to the Scheduling preferences page.

4.          If you want WebSeeker to automatically run a program when the scheduled search is complete, select Run 
Program. Type the full name and path for the program file in the text box. If you do not know the full path, click 
Browse-4, navigate to the desired program file, and click Open to save your choice and return to the Scheduling 
preferences page.

5.          When you have finished configuring your Scheduling preferences, click OK to accept the current configuration and
close the Preferences dialog box, or click another tab to configure more preferences.



Preferences (Scheduling Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Scheduling Preferences tab sets basic preferences for an unattended search. You can decide whether WebSeeker should 
notify you when a search is complete; what files, if any, to write out with the URLs and HTML of the search; and whether to run a 
program after the search is complete.

To set preferences:

1.          From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Scheduling tab to switch to the Scheduling Preferences page.

2.          If you want WebSeeker to automatically run a program before beginning a scheduled search, select Run Program
in the Before Search Begins section. For example, you may need to run a dialing program in order to make your 
Internet connection. Type the full name and path for the program file in the text box. If you do not know the full name 
and path, click Browse-1, navigate to the desired file, and click Open to save your choice and return to the 
Scheduling preferences page.

If you want WebSeeker to delay between running the program and starting the search, select Delay and then enter 
the number of seconds in the seconds text box.

3.          The first four radio buttons in the After Search Is Complete section let you choose your writing options for 
scheduled searches. You can make any of the following choices.

¨ Choose Write out nothing if you do not want WebSeeker to write search results to a file of any sort.
¨ Choose Write out URLs to if you want WebSeeker to write the URLs of its search results to a text file. Type the

full name and path for the file in the text box. If you do not include a path, WebSeeker saves the file in its own 
directory (WebSeeker) by default. If you want to save the URLs to an existing file, click Browse-2, navigate to 



the desired file, and click Open to save your file choice and return to the Scheduling preferences page.
¨ Choose Write out HTML to if you want WebSeeker to write its search results to an HTML file that you can view

in your Web browser. Type the full name and path for the file in the text box. If you do not include a path, 
WebSeeker saves the file in its own directory (WebSeeker) by default. If you want to save the results to an 
existing file, click Browse-3, navigate to the desired file, and click Open to save your file choice and return to the
Scheduling preferences page.

¨ Choose Write out <date>.HTM file if you want WebSeeker to write its search results to an HTML file named 
<today’s date>.HTM. You will then be able to browse your search results through your Web browser.

¨ If you want to adjust the format of the HTML file, click HTML Format. Choose which results you want to include 
or exclude and whether you want results sorted by Title, URL, or Type. Click OK to save your file choice and 
return to the Scheduling preferences page.

4.          If you want WebSeeker to automatically run a program when the scheduled search is complete, select Run 
Program. Type the full name and path for the program file in the text box. If you do not know the full path, click 
Browse-4, navigate to the desired program file, and click Open to save your choice and return to the Scheduling 
preferences page.

5.          When you have finished configuring your Scheduling preferences, click OK to accept the current configuration and
close the Preferences dialog box, or click another tab to configure more preferences.



Preferences (InstantUpdate Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The InstantUpdate Preferences determine how you obtain your free automatic updates to WebSeeker. (Purchasing and registering 
WebSeeker entitles you to free interim upgrades.) The built-in InstantUpdate utility automatically downloads any WebSeeker 
updates directly from the ForeFront Web site.

To set preferences:

1.       From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the InstantUpdate tab to switch to the InstantUpdate Preferences page.

2.        If you want WebSeeker to update only when you manually request it (by choosing InstantUpdate from the Tools 
menu), select Manual Update Only.

If you want WebSeeker to check for update but ask you before updating, select Always Ask Before Updating.

If you want WebSeeker to take care of the updating without any intervention on your part, select Update Without 
Asking.

The default settings is Always Ask Before Updating.

3.        When you have finished configuring your InstantUpdate preferences, click OK to accept the current configuration 
and close the Preferences dialog box, or click another tab to configure more preferences.





Preferences (Network Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Network preferences configure maximum values for connections and result requests. You can also configure your timeout 
settings here.

To set preferences:

1.        From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Network tab to switch to the Network Preferences page.

2.        In the Maximum Values section, set the following options:

¨ Simultaneous Connections determine the maximum number of connections WebSeeker makes at one time. 
You may enter any number up to 255; however, if you are using a modem, we recommend a maximum value of 
64.

The default number of simultaneous connections is 8.

¨ Requests for Next Results limits the number of times WebSeeker requests additional results from search 
engines. Many engines deliver results in groups of ten or so. To obtain additional results, WebSeeker must 
continue to request the next set of results. There is no maximum limit for requests.

The default number of requests is 10.

3.          Set the following options in the Timeout Settings section.

¨ Connecting determines the number of seconds WebSeeker waits for a connection to each server before timing 
out. There is no maximum length of time.



The default timeout for connecting is 60 seconds.

¨ Reading determines the number of seconds WebSeeker waits to read the data from each server. There is no 
maximum length of time.

The default timeout for the reading field is 60 seconds.

4.          When you have finished configuring your Network preferences, click OK to accept the current configuration and 
close the Preferences dialog box, or click another tab to configure more preferences.



Preferences (Proxy Server Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Proxy Server Preferences define any applicable proxy information. If you are going through a firewall, it is important to enter this
information before you attempt to conduct a search. Once the information is configured, WebSeeker automatically enters the 
information to the proxy and bypasses the firewall.

To set preferences:

1.          From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Proxy Server tab to switch to the Proxy Server Preferences page.

2.          Enter the name or address of your proxy in the HTTP Proxy text box.

3.          Enter the number of your proxy port in the Port text box.

4.          When you have finished configuring your Proxy Server Preferences, click OK to accept the current configuration 
and close the Preferences dialog box, or click another tab to configure more preferences.



Choose the types of results you would like included in your HTML file.



Choose the types of results you would like excluded in your HTML file.



Choose one of these radio buttons to define the way results are sorted in the HTML file.



Click OK to accept the HTML Format configuration and return to Scheduling Preferences.



Click OK to accept the HTML Format configuration and return to Writing Preferences.



Click Cancel to disregard any changed made to HTML Format and return to Scheduling Preferences.



Click Cancel to disregard any changed made to HTML Format and return to Writing Preferences.



Preferences (Logging Tab)
WebSeeker’s Preferences dialogs allow you to configure many different aspects of the program to suit your personal search 
preferences. You can set preferences defining how your search results are displayed; what results are included or excluded; the 
Web browser you want to use to browse search results; and how WebSeeker writes its search results to your hard drive. You can 
even set up personal preferences for unattended searches, as well as settings dictated by your network setup. In this chapter you 
will learn about each of the preferences options, what they can do, and where to locate each option.

The Logging Preferences determine the log files WebSeeker creates for each search. These files can be found in the search 
directory, <file name>.dir. The error log has the same name as the search file, with a .LOG extension. The detail log is untitled.LOG 
unless you rename it. These file can be viewed in Microsoft Notepad, Wordpad, or any text editor.

To set preferences:

1.          From the Tools menu, select Preferences. The Preferences dialog box appears with the View tab displayed. 
Select the Logging tab to switch to the Logging Preferences page.

2.          If you want WebSeeker to create an file listing the errors encountered in each search, select Keep Log of Errors. 
The default setting is to keep this log.

3.          If you want WebSeeker to maintain a detailed listing of all transactions, select Keep Detailed Transaction Log. 
The default setting is not to keep this log.

4.          When you have finished configuring your Logging Preferences, click OK to accept the current configuration and 
close the Preferences dialog box, or click another tab to configure more preferences.



Brings up the WebSeeker Options dialog box.



Enter the name of your browser here.



Sets the selected result(s) to Monitored.



Sets the selected result(s) to Non-Monitored.



Sets the selected result(s) to New.



Sets the selected result(s) to Old.



Sets the selected result(s) to Changed.



Sets the selected result(s) to Rejected.



Sets the selected result(s) to Browsed.



Sets the selected result(s) to Not Browsed.



New
A result is considered new if it has not been included in the results of a search on the current keywords. A search can be New for 
several reasons:

¨ The web page is new.
¨ The web page has been modified so that it now matches the criteria of the search.
¨ The search engine has been updated to include any changes.



Old
Results are considered old if they have previously been included in the results of a search, and have not been tagged as browsed or
monitored.



Changed
Results are considered modified if they have been altered since the last search of the current keywords.



Rejects
You can discard a Search Result by setting it to rejected. If a previously rejected result appears it is automatically discarded in a new
search. It is possible to include a previously rejected result by selecting Include, Rejects from the View menu.



Browsed
Results of a search that have been read can be set to browsed as a way to control the results of future searches. You can restrict a 
search to only browsed results, or you can exclude browsed results to filter out information you have already seen.



File Menu
Edit Menu
View Menu
Search Menu
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Tools Menu
Help Menu



Launches a search of all the keywords in the selected subject.



Launches a search on the keywords of all the selected searches.



Launches the active search.



Launches the active search with only the selected search engines.



Launches your browser to the page of results that the selected search engine returned.



Launches    WebSeeker Scheduler. The Schedule Window    appears.



Launches a search of all of the keywords in all of the existing subjects.



Renews a search of all of the searches results that have been set to Monitored.



Stops the active Search. WebSeeker returns any results that were collected before the search was stopped.



Brings up the Start New Search dialog. Enter keywords to add to the active search.



File Menu
Edit Menu
View Menu
Search Menu
Results Menu
Tools Menu
Help Menu



Writes only the selected results to a text or HTML file, according to your preferences setting. To set file preferences, select 
Preferences from the Tools menu. For more information on Write options go to Writing Preferences, Writing tab.



Writes All results to a text or HTML file, according to your preferences settings. To set file preferences, select Preferences from the 
Tools menu. For more information on Write options go to Writing Preferences, Writing tab.



File Menu
Edit Menu
View Menu
Search Menu
Results Menu
Tools Menu
Help Menu



Displays the Toolbar.



Displays available search engines.



Sorts and displays results by URL.



Sorts and displays results by Title.



Sorts and displays results by statusType.





Toolbar
Click on the Toolbar to learn the function of each button.

Click individual buttons for a description of the action launched by each button.

      New

      Open

      Expand

      Start/Renew

      Stop

      Browsed

      Reject

      Monitor

      Refiner ON/Off

      Refine



Creates a new document. The Start New Search dialog box appears.



Opens an existing file. The Open File dialog box appears.



Copies selected data to the global clipboard





Use this dialog box to view, and change the properties of the selected URL.



This area lists the name of the current Search.



This area list the Title of the selected URL.



This area lists the URL (Uniform Resource Locator).



This are displays action specific Dates.



You may select a radio button to change the current WebSeeker setting for the selected URL.



Select check boxes to set current URL to Browsed, and, or, Monitored.



Press Help button to receive help specific to the current action.



Deletes selected items. A Warning dialog box appears to verify items to delete.



Writes the selected result(s) to an HTM file. The following dialog box appears.



Displays version and copyright information.





Creates a New document.



Opens an existing document.



Copies the selection to the global clipboard.



Inserts item into the selected list.



Delete an item from the selected list/



Edits an item in the selected list.



Starts, or renews, the active search.



Stops the search.



Set the selected result(s) to Monitored.



Set the selected result(s) to Rejected.



Set the selected result(s) to Browsed.



Turns the Refiner on and off.



Refines results. The Refine dialog box appears.





Write out results based on write preferences.



Launch browser with selected result or selected search.



Launch browser with ForeFront home page.



Display program information, version number and copyright.



Opens the WebSeeker help file.



Displays the Status Bar. The Status Bar lists the current action.





Changes the display setting to Vertical Layout when selected. Layout changes are not effective until the next WebSeeker session.



Changes the display setting to Horizontal Layout when selected. Layout changes are not effective until the next WebSeeker 
session.



This sorts and displays the Search Results according to their dates.



This sorts and displays the Search Results Alphabetically.



Displays the URLs for the active search.



Expands the search. The Start New Search dialog box appears.





File Menu
Edit Menu
View Menu
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Help Menu



This option launches the WebSeeker help file. Use this file to learn how to use WebSeeker, or to answer specific questions on 
WebSeeker functions.



This option launches the Windows help file. Use this file to learn how to use Winhelp.



This option displays version and copyright information about WebSeeker.



This option launches your browser to the ForeFront home page.



Enter personal registration information.



Check this box to receive information on all of ForeFront’s new products and upgrades.



Click Send to register on-line when you have completed the registration form.



Click Just Save to save registration information to send at a later time.



Click Cancel to abort on-line registration without saving changes.



These are registration options. Register Demo, Purchase the product, or use your ForeFront VIP number. You may select only one 
option.



Use this field to let ForeFront know how you heard about WebSeeker. This field is optional



Chapter Two Lessons

Lesson 8: Standard Refining
Lesson 9: Advanced Refining
Lesson 10: Constructing Valid Search Expressions
Lesson 11: Add Result(s) URL
Lesson 12: Changing Results Settings



Chapter Two Lessons

Lesson 8: Standard Refining
Lesson 9:Advanced Refining
Lesson 10: Constructing Valid Search Expressions
Lesson 11: Add Result(s) URL
Lesson 12: Changing Results Settings



Troubleshooting

Can you add more search modules to   WebSeeker   so that more search engines can be utilized?  

I receive a lot of results I don  ’  t want with only a few that I do. How can I get only the results that I want?  

Why don  ’  t I get search results from all the search engines all the time?  

Why does a new copy of Netscape launch every time I double click a search result?

Why do I receive results that don’t contain any keywords from the search?



At ForeFront we are always developing additional search modules for search engines. If you have any suggestions for additional 
search modules that you would like to see added, or any other suggestions or questions, please let us know. Your input is important 
to us.

We can be reached by E-mail at:

info@ffg.com



You will receive better search results by selecting keywords that are unique (if possible) to the subject you are searching for. To 
further narrow your search you can AND words together. By checking the AND words together radio button, WebSeeker 
automatically removes any search engines that do not support AND searches. Using multiple, unique words ensures better search 
results.



Some search engines become slowed down as more and more people use them. This can usually be remedied by performing a 
new search using only that search engine. If the problem persists, verify that the search engine is operating, then contact 
ForeFront.



When you double click on a search result you are telling Netscape that you want to browse the Internet. Netscape, like many other 
applications, is unaware that you may already have another copy running, and launches a new copy to fulfill the task.



Sometimes results appear that don’t seem to have any reference to the search. This can be due to several reasons.

¨ The web page previously contained the referenced information, but has since been changed.
¨ The page no longer exists. 
¨ The server has not been updated since modifications were made.
¨ The keywords can be found in the source. You can check this by selecting View Source on your browser.



Customer Support
The first line of support should be this Help file and the user manual. If you cannot find the information you need here, contact us at 
our Web site. All of the online help options are detailed on our Customer Support home page:

(http://www.ffg.com/support.html) ,

which you can access directly by clicking on the Web icon below :



Known Problems and Limitations
WebSeeker and the WebSeeker utilities have the following Known Problems and Limitations:

1.    In order to perform an unattended WebSeeker search using Schedule you must:

¨ Use the standard Windows 95 Dial-Up Connection to connect to the Internet, and your Web connection must 
not require you to type your name and password into the dial-up window. If your Internet Service Provider (ISP) 
requires you to enter your name and password manually each time (rather than with a script or remembered 
password), you can not perform scheduled, unattended searches.

¨ Or, use a LAN network internet connection, that does not require you to type your name and password in order 
to connect to the Internet.

2.    If you are using a Windows NT operating system, you must double right click wherever a right click is used.



System Requirements
Upgrading
Uninstalling   WebSeeker  



System Requirements
In order for WebSeeker to install and run properly, the following are required:

¨ 486 or higher class machine
¨ Windows 95, or Windows NTª 3.5 or higher
¨ 8 Megabytes of RAM
¨ 10 Megabytes of free disk space on your hard drive
¨ An Active Internet connection with a Winsock - compliant network product
¨ TCP/IP connection with SLIP, PPP, or direct connectivity
¨ A Web Browser including :

Internet Explorererª version 2.0 or higher
Netscape Navigatorª version 2.0 or higher
Enhanced Mosaicª version 2.0 or higher
or other Spy-Glass SDI standard-compliant Web browser

In order to run an unattended search using the Schedule utility, the following are required:

¨ Correctly configured Windows 95 Dial-Up networking setup, or direct connectivity.
¨ Or, a LAN internet connection that does not require you to type in your user name and password to login.



Installing WebSeeker
1.      Click the Start button  and select Settings, Control Panel from the Start Menu.

2.        Double click the Add/Remove Programs icon .

The Windows Add/Remove Programs Properties dialog box appears.



2.      Click the Install button . Follow the directions on your screen, Windows prepares the Setup 
program.

3.      When the Welcome dialog box appears, select Install to continue with the WebSeeker installation. 

4.      The Enter Directory dialog box appears.



5.      Enter the drive and directory where you want WebSeeker installed, or click OK to accept default settings. The 
following dialog box reports the status of the installation.

6.      The Setup program informs you when the installation is complete.

Click OK. WebSeeker is now installed on your system.

7.      Click the Windows Start button  and select Find, On the Internet to begin WebSeeker.



Uninstalling WebSeeker
To uninstall WebSeeker press the Windows Start button and select Programs, ForeFront, Uninstall WebSeeker, as shown in the 
following example.

The Freeman Uninstaller dialog box appears, with WebSeeker selected.



Click the Start button to uninstall WebSeeker. For a full uninstall you are required to press Yes to dialog boxes questioning whether 
to remove all items.

    WARNING: uninstalling permanently removes WebSeeker from your system. To use WebSeeker you need to run the Setup program again.



Upgrading
Purchasing WebSeeker 2.0 entitles you to any interim upgrades (version 2.x). InstantUpdate automatically upgrades to the newest 
version of WebSeeker.

Major upgrades are available for purchase from ForeFront.

Drop by our Web site to find out about new products and upgrades:

www.ffg.com

Or just select the Notify Me of New Products and Upgrades check box when you register.
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Tips and Tricks

Accessing Recently Used Files

Adding a URL

Automatically Launching Another Program

Automatically Launching   WebSeeker   with a WSK File  

Automating Searches

Customizing Individual Searches

Decreasing Database Size and Increasing Performance

Deleting Results

Importing Link References

Keeping Track of Browsed Results

Manually Adding Results

Monitoring Web Pages

Ranking Search Results

Refining Searches

Rejecting Unwanted Results

Renaming Search Results

Stopping a Search in Progress

Troubleshooting Unattended Problems

Using the Write Options

Using xBase Compatible Products



A Tip For:

Accessing Recently Used Files

Your most recently used WSK files appear at the bottom of the File menu for quick access.



A Tip For:

Automating Searches

Use Schedule to automate your searches at night or off-peak hours. To access Schedule select Search, Schedule.



A Tip For:

Using xBase Compatible Products

WebSeeker uses a standard xBase database format to allow you to create your own reports with FoxPro, Access, or other popular 
xBase database programs.



A Tip For:

Renaming Search Results

You can rename search results to better reflect the content, or what the results mean to you.



A Tip For:

Ranking Search Results

You can add letters or numbers to the beginning of search results to rank them.



A Tip For:

Refining Searches

Use the Boolean operators AND and OR, or the AS A PHRASE option to refine your search.



A Tip For:

Monitoring Web Pages

Have WebSeeker automatically monitor web pages for changes by setting the search result to Monitor.



A Tip For:

Manually Adding Results

If you come across an interesting web site , you can manually add it to your search results by selecting Add Result from the 
Results menu, and entering the URL in the Add Results dialog box.



A Tip For:

Automatically Launching WebSeeker with a WSK File

You can double click on a WSK file from Windows Explorer or File Manager to automatically launch WebSeeker with the selected 
WSK file.



A Tip For

Displaying Search Engines
Display available search engines by selecting Search Engines from the View menu.



A Tip For:

Troubleshooting Unattended Problems

Troubleshoot problems occurring during unattended operation by logging detail and errors on the Logging tab of the Preferences 
dialog box.



A Tip For:

Importing Link References

You can import link references from any HTML file by selecting Import from the File menu.



A Tip For:

Customizing Individual Searches

Each individual search can be customized to use the specific options available from that search engine by right clicking on the 
displayed search engine and selecting Properties from the drop down menu.



A Tip For:

Decreasing Database Size and Increasing Performance

If you delete many search results you should pack and reindex the results database by selecting    Compact Database from the 
Tools.



A Tip For:

Keeping Track of Browsed Results

Set a search result’s status to Browsed after you have looked it over. Use this option to separate those search results which you 
have already seen from those you haven’t.



A Tip For:

Rejecting Unwanted Results

Be sure to set the status of a search result to Rejected if you don’t want it to appear iin future search results.



A Tip For:

Stopping a Search in Progress

To stop a search that is in progress, select Stop from the Search menu, or press the Stop button     on the Toolbar.



A Tip For:

Adding a URL

If you come across a URL on your own that you would like to add it to your search results, select Add Result from the Results 
menu.



A Tip For:

Deleting Results

Deleting a result removes it entirely from the database, unlike Reject which keeps the search result in the database, but marks it as 
Rejected so it doesn’t show up in your search results when you search.



A Tip For:

Using the Write Options

Select Write Web Page from the File menu to Write all results, or selected results to a web page.



A Tip For:

Automatically Launching Another Program

You can select to automatically run another program after WebSeeker has completed a search from the Preferences dialog box on 
the Schedule tab. You can also schedule programs to automatically run after WebSeeker has finished writing the results of the 
active search from the Preferences dialog box on the Writing tab.
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Chapter One:
Searching the Internet

 Lesson 1: Creating a New Search  Lesson 5: Customizing a Search
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Searching the Internet
Lesson 1: Creating a New Search

Use the Start New Search dialog box to create a new search.

1.        Start WebSeeker

¨ Click the Windows Start button ™ to display the Start Menu.
¨ On the Start Menu go to Find, On the Internet.
¨ Or you can double click a WSK file from Program Manager or Windows Explorer.

The WebSeeker Start New Search box appears.



2.        Configure the search

¨ On the Key words tab you can enter the keywords for your new search.
¨ Choose the AND or OR Boolean Operators, or search multiple keywords AS A PHRASE. 
¨ Select the type of search desired:

InstantFind - is the fastest type of search. It removes any duplicate URLs or duplicate Titles (as defined in 
Preferences) from the search results.
CleanFind - is the next fastest type of search. it removes duplicates, and any URLs that are unavailable.
FilterFind - is the most robust search. FilterFind is not quite as fast as InstantFind or CleanFind. It removes 
duplicates, unavailable sites, and download search results to your hard drive for Refining.

3.        Select Search Engines

¨ When you have finished entering your keyword information, you can select the Search engines tab to select specific 
Search Engines. If no changes are made on the Search Engines tab, it defaults to Select All Engines.

4.        Launch the search

¨ Choose          to have WebSeeker perform the search immediately.
¨ Choose        to postpone the search until a later time.

Now that you have created a search, you may want to return to that search at another time. See lesson 2 to learn how to open an 
existing search.

To learn how to program WebSeeker to automatically run searches at a later time:

 See Also 

 For best results use descriptive keywords that are unique (if possible) to the search topic.





Searching the Internet
Lesson 1: Creating a New Search

Use the Start New Search dialog box to create a new search.

1.        Start WebSeeker

¨ Click the Windows Start button ™ to display the Start Menu.
¨ On the Start Menu go to Find, On the Internet.
¨ Or you can double click a WSK file from Program Manager or Windows Explorer.

The WebSeeker Start New Search box appears.

2.        Configure the search

¨ On the Key words tab you can enter the keywords for your new search.
¨ Choose the AND or OR Boolean Operators, or search multiple keywords AS A PHRASE. 
¨ Select the type of search desired:

InstantFind - is the fastest type of search. It removes any duplicate URLs or duplicate Titles (as defined in 
Preferences) from the search results.
CleanFind - is the next fastest type of search. it removes duplicates, and any URLs that are unavailable.
FilterFind - is the most robust search. FilterFind is not quite as fast as InstantFind or CleanFind. It removes 
duplicates, unavailable sites, and download search results to your hard drive for Refining.

3.        Select Search Engines

¨ When you have finished entering your keyword information, you can select the Search engines tab to select specific 
Search Engines. If no changes are made on the Search Engines tab, it defaults to Select All Engines.

4.        Launch the search

¨ Choose          to have WebSeeker perform the search immediately.
¨ Choose        to postpone the search until a later time.

Now that you have created a search, you may want to return to that search at another time. See lesson 2 to learn how to open an 
existing search.



To learn how to program WebSeeker to automatically run searches at a later time:

 See Also 

 For best results use descriptive keywords that are unique (if possible) to the search topic.



Searching the Internet
Lesson 2: Opening an Existing Search
You may want to return to a previously saved search to browse results, or to update the search. You can open an existing WSK file 
several ways.

1.        Open a file from within WebSeeker

¨ Select Open from the File menu and select the file you wish to open. Or press the Open  button on the toolbar.
¨ Recently used files are listed at the bottom of the File menu. Select a file to open it.

2.        Open a file from Windows Explorer, or Program Manager

¨ Start Windows Explorer, or Program Manager.
¨ Locate the file you wish to open.
¨ Double click the file. WebSeeker launches, open to the current file.

Now that you are comfortable working with existing files, go to lesson 3 to learn how to expand a search to improve search results.
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Searching the Internet
Lesson 3: Expanding a Search
Once a search is complete, you may find that different keywords might improve it, or maybe you want to add more search engines. 
Using the Expand Search function, you can easily add keywords and search engines to receive different results. You can expand 
your search by adding one or more Search Engines, or by adding keywords to the search. You can add more Search Engines to a 
new search before it has been run, or add more keywords, and more search engines to a completed search. Both of these functions
can be accessed by selecting Expand Search from the Search menu.

To expand a search:

1.        Perform a Search

¨ First you must perform a regular WebSeeker search.
¨ Or, open an existing search.

2.        Expand the Search

¨ From the Results window    select Search, Expand Search. The Start New Search dialog box appears.

3.        Add Keywords

¨ Enter the keywords you would like to add to the current search.
¨ You may select the AND or OR Boolean Operator, or search the expanded keywords AS A PHRASE.

4.      Add or delete search engines.

¨ Select the Search Engines tab.
¨ Select/deselect the search engines you want to use.
¨ Select Find Now, or Find Later.

If Find Now is selected, WebSeeker performs the search with the expanded keyword list, and the original keywords 
separately. For example, if you had previously searched for "alligators" and then expanded the search to include 
"crocodiles," WebSeeker runs one search for "alligators," and a separate search for "crocodiles." If you wanted 
search results to include both "alligators" and "crocodiles," you would have to enter both keywords "alligators 
crocodiles" and use the AND Boolean operator.

By default, WebSeeker also searches all of the search engines from the original search, and from the expanded 
search engines.

To execute only the expanded keywords (from step 3):



¨ Select Find Later.
¨ If the search engines pane is not visible, select View, Search Engines. The Search Engines pane appears, 

with each search engine listed twice, once with the original keywords, and again with the expanded keywords. 
Select the search engines you would like to use. Make sure that any selected engines are listed with the 
expanded keywords rather than the original keywords.

¨ Select Search, Renew Selected Engines.

WebSeeker runs a search with the selected engines and expanded keywords.

In lesson 4, you will learn different ways to renew a search.



Searching the Internet
Lesson 4: Renewing a Search
You can use WebSeeker’s Renew function to launch a previously completed search again, with the same configuration and 
keywords to keep track of any changes made to resulting sites. Or, you can renew an expanded search to reduce or expand your 
search results.

To renew a previously completed search with the current configuration:

1.      Open or run desired search.

¨ Run a WebSeeker search.
¨ Or, open an existing, saved search.

2.      Renew the search.

¨ From the Results window select Search, Start/Renew.

WebSeeker renews the search.

To renew the search on expanded keywords and specific search engines only:

1.      Expand the search by following steps 1-3 in Lesson 3 Expanding a Search, and select Find Later.

2.      Select desired search engines.

¨ If the search engines pane is not visible, select View, Search Engines. The Search Engines pane appears, with 
each search engine listed twice, once with the original keywords, and again with the expanded keywords.

¨ Select desired search engines. Make sure that any selected engines are listed with the expanded keywords rather 
than the original keywords.

3.      Renew the search.

¨ From the Search menu select Renew Selected Engines.

WebSeeker renews the search with only the selected search engines and keywords.

In lesson 5, you will learn to configure personal preferences to customize your search.
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Searching the Internet
Lesson 3: Expanding a Search
Once a search is complete, you may find that different keywords might improve it, or maybe you want to add more search engines. 
Using the Expand Search function, you can easily add keywords and search engines to receive different results. You can expand 
your search by adding one or more Search Engines, or by adding keywords to the search. You can add more Search Engines to a 
new search before it has been run, or add more keywords, and more search engines to a completed search. Both of these functions
can be accessed by selecting Expand Search from the Search menu.

1.        Perform a Search

¨ First you must perform a regular WebSeeker search.
¨ Or, open an existing search.

2.        Expand the Search

¨ From the Results window    select Search, Expand Search. The Start New Search dialog box appears.

3.        Add Keywords

¨ Enter the keywords you would like to add to the current search. 
¨ You may select the AND or OR Boolean Operators, or search the expanded keywords    AS A PHRASE.
¨ Select Find Now, or Find Later.
¨ That’s all you need to do! WebSeeker performs the search with the expanded keyword list, and renews the search 

of the original keywords.

WebSeeker performs the search with the expanded keyword list, and the original keywords separately. For example, if 
you had previously searched for “alligators” and had expanded the search to include “crocodiles,” WebSeeker runs 
one search for “alligators” and a separate on for “crocodiles.” If you wanted search results to include both “alligators” 
and “crocodiles,” you would have to enter both keywords “alligators crocodiles” and use the AND Boolean operator.

WebSeeker also searches all of the search engines from the original keyword search and from the expanded search 
engines. If you want to only search certain engines, select Search Engines from the View menu. Select the search 
engines that you would like to WebSeeker query, and go to Search, Renew Selected Engines.

In lesson 4, you will learn different ways to renew a search.
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Searching the Internet
Lesson 5: Customizing a Search (Browser Tab)
You can further customize your searches by using the Preferences dialog box, accessed from the Tools menu. Separate tabbed 
dialog pages allow you to configure the following aspects of your searches

Use the Browser tab to tell WebSeeker which browser you want it to use.

Click on the dialog box below to learn more about each option.

Once a search is configured and launched, you may decide to stop the search. To learn how to stop a search, go to lesson 6.

    See Also



Searching the Internet
Lesson 5: Customizing a Search (Writing Tab)
You can further customize your searches by using the Preferences dialog box, accessed from the Tools menu. Separate tabbed 
dialog pages allow you to configure the following aspects of your searches

From the Writing tab, you can program WebSeeker to notify you when the search is complete, have WebSeeker create an HTML 
file with a name you specify; or automatically launch a program or macro upon completion of the search. Preferences defined on this
tab govern all of your searches except those made through the Scheduling utility.

Click on the dialog box below to learn more about each option.

To learn how to stop a search, go to lesson 6.

    See Also



Searching the Internet
Lesson 5: Customizing a Search (Scheduling Tab)
You can further customize your searches by using the Preferences dialog box, accessed from the Tools menu. Separate tabbed 
dialog pages allow you to configure the following aspects of your searches

From the Scheduling tab, you can set configurations for an unattended search; specify programs to run before and after the search; 
or specify your Write Preferences for searches conducted through the Scheduling utility.

Click on the dialog box below to learn more about each option.

To learn how to stop a search, go to lesson 6.

    See Also



Searching the Internet
Lesson 5: Customizing Search (Network Tab)
You can further customize your searches by using the Preferences dialog box, accessed from the Tools menu. Separate tabbed 
dialog pages allow you to configure the following aspects of your searches

From the Network tab, you can set the maximum number of simultaneous connections and requests for next results. You can also 
define timeout settings.

Click on the dialog box below to learn more about each option.

To learn how to stop a search, go to lesson 6.

    See Also



Searching the Internet
Lesson 5: Customizing a Search (Proxy Server Tab)
You can further customize your searches by using the Preferences dialog box, accessed from the Tools menu. Separate tabbed 
dialog pages allow you to configure the following aspects of your searches

Use the Proxy Server tab to define the Proxy Server and Proxy port for WebSeeker to use (if applicable).

Click on the dialog box below to learn more about each option.

To learn how to stop a search, go to lesson 6.

    See Also



Searching the Internet
Lesson 5: Customizing a Search (Logging Tab)
You can further customize your searches by using the Preferences dialog box, accessed from the Tools menu. Separate tabbed 
dialog pages allow you to configure the following aspects of your searches

Use the Logging tab to define which log types you want kept for searches.

Click on the dialog box below to learn more about each option.

To learn how to stop a search, go to lesson 6.

    See Also



Advanced Features



Searching the Internet
Lesson 6: Stopping a Search
Sometimes you may want to stop a search because you realize that you input the wrong search parameters or simply because the 
search parameters were so wide that the search will take a very long time.

¨ To stop a search before it has been launched, press the Cancel button. 

¨ To stop a search that is already in progress, you can press the Stop button  , or select Stop Search, from the 
Search menu, at any time. WebSeeker reports any results that were found before the search was aborted.

To learn about Boolean Operators, go to lesson 7.



Searching the Internet
Lesson 7: Boolean Operators
When adding Searches, you have the option to choose a Boolean Operator. The WebSeeker Start New Search dialog allows you 
to select the AND operator by checking the AND words together radio button. If you don't use the AND operator, you are using the 
OR operator by default. Some Search Engines have additional operators or other search options. To use the specific options for 
each individual Search Engine, right-click on the Search and select Properties. A dialog box specific to the selected search appears. 
To learn more about these individual Search Engine options, go to the Home page for the Search Engine.



AND
AND is a search option that links keywords together for the search. When you are searching for a particular pair or larger group of 
keywords, use the AND Boolean Operator to restrict your search. For example, a search could be launched for “computer 
animation.” In the keywords field the keywords "computer" and "animation" are entered. Click the AND radio button to select it. 
WebSeeker now searches for documents including both keywords, “computer” AND “animation.” Selecting the AND box 
automatically removes any search engines that do not support AND searches. 



OR
The OR operator is often used to include two different phrases of a Boolean search. For example, using the keywords "plane" and 
"airplane,” select OR as the Boolean operator. WebSeeker now searches for all documents containing either the word "plane,” OR 
the word "airplane,” OR both. This expands your search to include documents that might not otherwise be found. An article that only
uses the word "plane" would not be found while searching for just "airplane."
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Managing Search Results
Lesson 8: Standard Refining
After a FilterFind search has been performed, you can use the refiner to search the current, downloaded, results for more detailed 
information. With the WebSeeker Refiner you can easily search the resulting documents for any words or phrases in those 
documents. The WebSeeker Refiner utilizes a left to right precedent. Basically, a left-to-right precedent is what most Western 
languages use when they write sentences from left to right; i.e., items written further left (in a sentence or a search list) are 
processed before items written further to the right and are, therefore, given precedence over any following items.

If you need to adjust the precedent beyond this level of left-to-right sorting, you may add parentheses to group specific keywords 
and operators together.

    NOTE:    Refine is only enabled when a FilterFind search has been performed.

1.        First have WebSeeker perform a FilterFind search.

¨ All available results are downloaded to your hard drive for refining.

2.        Refine

¨ From the Results menu select Refine.
¨ The Refine dialog box appears.

Click on the dialog box below to learn more about each option.

3.        Review your current query. Each line of the dialog box includes a drop-down box containing the available logical
operators and a text box for your search term or terms. The logical operator you choose in each line applies only 
to the terms in the adjacent text box.

¨ AND adds the adjacent terms to the list of terms which must be found in every search result document. A document 
must include all of the query’s AND terms to be included in the search results.

¨ OR adds the adjacent terms to the list of terms which may be found in any of the search result documents. A 
document need include only one of the query’s OR terms to be included in the search results.

¨ BUT NOT adds the adjacent terms to the list of terms which must not be found in any of the search result document. 
A document may not include any of the query’s BUT NOT terms if it is to be included in the search results.

¨ FOLLOWED BY specifies that the adjacent terms must be found in every search result document immediately after 
the keywords in the text box immediately above.

¨ NEAR specifies that the terms in the adjacent text box must be found in every search result document within 20 
words of one another. (You can override the 20-word default; see Proximity Searches for details).

4.        Add words and options.

¨ Enter any additional keywords desired, and select desired option for each word.

4.        Apply Refine configuration

¨ When you have finished making desired changes in the Refine dialog, click the OK button to apply current 
configuration and close the refine dialog box.

WebSeeker automatically reduces current results to represent Refine configuration.

    NOTE: Refine returns to its most recently used mode. If you press the OK or Cancel button from the Standard Refine dialog box, the 



Standard Refine dialog box appears the next time Refine is used. If you press OK or Cancel from the Advanced refine dialog box, the 
Advanced Refine dialog box appears the next time Refine is used.

To learn about the Advanced features of the Refiner go to lesson 9, Advanced Refining.
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Standard Refining
After a FilterFind search has been performed, you can use the refiner to search the current, downloaded, results for more detailed 
information. With the WebSeeker Refiner you can easily search the resulting documents for any words or phrases in those 
documents. The WebSeeker Refiner utilizes a left to right precedent. Basically, a left-to-right precedent is what most Western 
languages use when they write sentences from left to right; i.e., items written further left (in a sentence or a search list) are 
processed before items written further to the right and are, therefore, given precedence over any following items.

If you need to adjust the precedent beyond this level of left-to-right sorting, you may add parentheses to group specific keywords 
and operators together.

 NOTE:    Refine is only enabled when a FilterFind search has been performed.

1.        First have WebSeeker perform a FilterFind search.

¨ All available results are downloaded to your hard drive for refining.

2.        Refine

¨ From the Results menu select Refine, or click the Refine button on the Toolbar.
¨ The Refine dialog box appears, displaying your current query, ready for editing. The first time you use Refine, 

your query is displayed in the Standard graphical mode, ready for editing.

Click on the dialog box below to learn more about each option.

3.        Review your current query. Each line of the dialog box includes a drop-down box containing the available 
logical operators and a text box for your search term or terms. The logical operator you choose in each line 
applies only to the terms in the adjacent text box.

¨ AND adds the adjacent terms to the list of terms which must be found in every search result document. A 
document must include all of the query’s AND terms to be included in the search results.

¨ OR adds the adjacent terms to the list of terms which may be found in any of the search result documents. A 
document need include only one of the query’s OR terms to be included in the search results.

¨ BUT NOT adds the adjacent terms to the list of terms which must not be found in any of the search result 
document. A document may not include any of the query’s BUT NOT terms if it is to be included in the search 
results.

¨ FOLLOWED BY specifies that the adjacent terms must be found in every search result document immediately 
after the keywords in the text box immediately above.

¨ NEAR specifies that the terms in the adjacent text box must be found in every search result document within 20
words of one another. (You can override the 20-word default; see Proximity Searches for details).

4.        Edit any of the current keywords and/or their logical operators.

5.        Enter any additional keywords together with their appropriate logical operators.

6.        When you have finished making changes in the Refine dialog, you can:

¨ Click OK to close the Refine dialog box and apply the current configuration to your search results.
¨ Click Apply to apply the current configuration to your search results while keeping the Refine dialog open for 

further editing.

7.        WebSeeker runs through your search results to determine which conform to your new search query and 
displays the reduced set of results in the main WebSeeker window.

You can use the Refine On/Off button on the Toolbar to toggle your display between the complete search results and the refined 
search results.

 NOTE: Refine returns to it’s most recently used mode. If you press the OK or Cancel button from the standard Refine dialog box, the Standard



Refine dialog box appears the next time Refine is used. If you press OK or Cancel from the Advanced refine dialog box, Advanced Refine 
dialog box appears the next time Refine is used.

To learn about the Advanced features of the Refiner go to lesson 9, Advanced Refining.



Press OK to accept current refine configuration and close the Refine dialog box. The Refine configuration is automatically applied 
to the current search, and only results that match the Refine expression are displayed.



Press the Cancel button to discard any changes and close the Refine dialog box.



Managing Search Results
Lesson 9: Advanced Refining

Power users familiar with the syntax of Boolean logic can use the Refine command’s Advanced mode to enter their filtering queries 
directly. The text box of this mode presents a “command-line” style of working.

NOTE: The Refine command works only on FilterFind searches. A FilterFind search is basically the same as a CleanFind search, but it takes a 
moment longer to index the full text of the search results, making it possible for you to search the full text of found Web pages.

The Refine command accesses both the Standard and Advanced Refine dialog boxes, returning you to the most recently used 
mode. If you find yourself in the wrong dialog box, simply click Standard or Advanced to switch to the desired setup.

WebSeeker’s Refine command uses a left-to-right precedent . Basically, a left-to-right precedent is what most Western languages 
use when they write sentences from left to right; i.e., items written further left (in a sentence or a search list) are processed before 
items written further to the right and are, therefore, given precedence over any following items.
If you need to adjust the precedent beyond this level of left-to-right sorting, you may add parentheses to group specific keywords 
and operators together.

1.    You must begin with a FilterFind search

¨ Perform a new FilterFind search or open the results of an existing, saved FilterFind search.

2.    Open the Refine dialog box

¨ From the Results menu select Refine. The Refine dialog box appears.
¨ Click the Refine button on the Toolbar.

The Refine dialog box appears, open to the most recently used mode.

3.    Go to Advanced mode

¨ From the Refine dialog box press the Advanced button, if necessary. The Advanced dialog box appears.

WebSeeker displays your current query in the syntax of Boolean logic. Edit the expression to meet your new criteria.

4.    Enter refine expression

¨ Enter the desired refine expression and press OK to apply changes and close the dialog box
¨ or press Apply to change the current refine configuration and keep the dialog box open to make additional changes.

5      When you have finished making changes in the Refine dialog, you can:

¨ Click OK to close the Refine dialog box and apply the current configuration to your search results.
¨ Click Apply to apply the current configuration to your search results while keeping the Refine dialog open for further 



editing.

WebSeeker runs through your search results to determine which conform to your new search query and displays the reduced set of 
results in the main WebSeeker window.

You can use the Refine On/Off button on the Toolbar to toggle your display between the complete search results and the refined 
search results.

For examples of valid search expressions see lesson 10, Constructing Valid Search Expressions.



Constructing Valid Search Expressions
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Advanced Refining
Power users familiar with the syntax of Boolean logic can use the Refine command’s Advanced mode to enter their filtering queries 
directly. The text box of this mode presents a “command-line” style of working.

The Refine command works only on FilterFind searches. A FilterFind search is basically the same as a CleanFind search, but it 
takes a moment longer to index the full text of the search results, making it possible for you to search the full text of found Web 
pages.

The Refine command accesses both the Standard and Advanced Refine dialog boxes, returning you to the most recently used 
mode. If you find yourself in the wrong dialog box, simply click Standard or Advanced to switch to the desired setup.

WebSeeker’s Refine command uses a left-to-right precedent . Basically, a left-to-right precedent is what most Western languages 
use when they write sentences from left to right; i.e., items written further left (in a sentence or a search list) are processed before 
items written further to the right and are, therefore, given precedence over any following items.
If you need to adjust the precedent beyond this level of left-to-right sorting, you may add parentheses to group specific keywords 
and operators together.

1.    You must begin with a FilterFind search

¨ Perform a new FilterFind search, or open the results of an existing, saved FilterFind search.

2.    Open the Refine dialog box

¨ From the Results menu select Refine. The Refine dialog box appears.

3.    Go to Advanced mode

¨ From the Refine dialog box press the Advanced button. The Advanced dialog box appears.

WebSeeker displays your current query in the syntax of Boolean logic. Edit the expression to meet your new criteria.

4.    Enter refine expression

¨ Enter the desired refine expression and press OK to apply changes and close the dialog box
¨ or press Apply to change the current refine configuration and keep the dialog box open to make additional 

changes.

5      When you have finished making changes in the Refine dialog, you can:

¨ Click OK to close the Refine dialog box and apply the current configuration to your search results.
¨ Click Apply to apply the current configuration to your search results while keeping the Refine dialog open for 

further editing.

WebSeeker runs through your search results to determine which conform to your new search query and displays the reduced set of 
results in the main WebSeeker window.

You can use the Refine On/Off button on the Toolbar to toggle your display between the complete search results and the refined 
search results.

For examples of valid search expressions see lesson 10, Constructing Valid Search Expressions.

    See Also





Managing Search Results
Lesson 10: Constructing Valid Search Expressions

Boolean and other search logic are rich and complex topics which often take up a full semester of a college-level course. Obviously, 
a full explanation is beyond the scope of this tutorial. However, most Web searches do not require a full range of Boolean 
expressions but rely on a limited subset of the possible queries.

In this section, we present some examples of valid expressions in both standard English and their search syntax counterparts. The 
syntax examples given here could be all or part of an expression entered in the Query text box of WebSeeker’s Advanced Refine 
dialog.

Individual Word Searches

To search for the word "shark,” simply enter it as is:

shark

Phrase Searches

To search for the phrase "great white shark,” use parenthesis and quotes:

("great white shark")

That last search looks for all three words in the order shown with no intervening words. Sometimes you would like to maintain the 
specified ordering but are willing to accept intervening words. To find "men are attacked by the great white shark,” you could type 
the following which allows 3 words between each pair of words:

("men attacked shark :3")

Of course, the above phrase would also find something like "men are attacking and killing sharks."

Sometimes, because you're unsure of all of the words in a phrase, you may wish to specify that one or more of the words in the 
phrase are "expendable.” For example, the following example specifies that any two of the words specified may be missing and still 
cause a match:

("men and women are attacked and killed by sharks :3:2") 

If the default span of zero is desired, the previous expression could be entered as:

("men and women are attacked and killed by sharks ::2")

Proximity Searches

To find two or more words "near" each other but in any order, use a proximity search. For example enter:

[taxes deductions]

This find .”.taxes after all the deductions.." as well as .”.deductions figured from state taxes...”
The brackets indicate that you want to find the words within a certain span or range. The default width of the span is 20 words. You 
may override the default:    For example, here we make the span 10:

[federal deductions taxes :10]

You may also specify an expendable count. In the following example, we allow two words to be missing from those specified:

[federal and state deductions taxes :10:2]

Boolean Searches

To find all documents containing "shark,” "whale" or "dolphin" (or any combination thereof), use the vertical bar character:

shark | whale | dolphin

To find all documents containing both "sea" and "ocean,” use the ampersand character:



weather & climate

Nested Expressions

Any place that you can use a single word in an expression, you may also use a phrase, proximity, or OR ("|") sub-expression. Here 
are some examples:

failed | "gave up"
("deep sea diving | scuba")                    or equivalently                    ("deep sea (diving | scuba)")
["cookies and cream" sweets]
(" ("Mother Theresa") ("India") :20")

Notice that phrases within phrases require parentheses.

Parentheses

Parentheses may be used to specify the order in which you want the expression to be evaluated. In the following example, we want 
the AND (&) to be evaluated before the OR (|):

(fast & cars) | racing

In the next example, we want the OR (|) to be evaluated before the AND (&):

Indy 500 & (fast | cars)

    NOTE: Refine returns to it’s most recently used mode. If you press the OK or Cancel button from the Standard Refine dialog box, the 
Standard  dialog box appears the next time Refine is used. If you press OK or Cancel from the Advanced Refine dialog box, the Advanced 
dialog box appears the next time Refine is used.

To learn how to add results (URLs) go, to lesson 11.
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Managing Search Results
Lesson 11: Add Result(s) URL
If you come across and interesting URL on your own, you can add it to your results list, where it can be monitored, browsed, etc. 

To manually add a result:

¨ Select Add Result from the Results menu.
¨ The Add/Edit URL dialog box appears.

¨ Enter the Title and URL for the result you wish to add, and press OK.
The URL has been added to your active results.

NOTE: You can not Add Results to a FilterFind search. This option is only available following a InstantFind or CleanFind Search.

To learn how to set a search result to Monitored/Not Monitored go to lesson 12.



Add Result(s) URL
If you come across and interesting URL on your own, you can add it to your results list, where it can be monitored, browsed, etc. 

To manually add a result:

¨ Select Add Result from the Results menu.
¨ The Add/Edit URL dialog box appears.

¨ Enter the Title and URL for the result you wish to add, and press OK.
The URL has been added to your active results.

NOTE: You can not Add Results to a FilterFind search. This option is only available following a InstantFind or CleanFind Search.

To learn how to change a results settings go to lesson 12.



Managing Search Results
Lesson 12: Changing Results Settings

WebSeeker uses a variety of Results settings to help you manage your search results. Some of the settings are changed by the 
program; all of the settings allow you to manually adjust them for your specific purposes. The first time a site appears as the result of
a search, WebSeeker automatically sets its status to New and displays the New icon with a yellow background next to them in the 
display window. The New icon also appears for results that have not appeared previously in a search of the current keywords or if 
the result is considered new for any of the following reasons:

¨ The Web page is new.
¨ Modifications to the Web page now make it match the search criteria.
¨ The search engine has been updated to include any changes.

To manually change results setting:

1.    Make the WSK file you want to work with the active file.

2.    Select the result you would like to modify

¨ In the Title column of the Display Window select the results you wish to modify. To select multiple results hold down 
the Ctrl key while clicking on each result.

¨ Selected result is highlighted, that is WebSeeker displays it in inverse video (usually light text on dark background).

For quick access you can use the toolbar buttons for Browsed, Rejected and Monitored settings.

3.    On the Results menu select Set Selected Results to

4.    On the submenu which appears, select the setting you want to assign to the selected result(s):

¨ Monitored/Not Monitored tells WebSeeker whether to watch and report changes to the site on the next search. The
next time you run the search you can select to Renew Monitored, and only those results you have set to monitored 

are searched. If their has been a change in the Monitored result the monitored icon  is displayed. The monitored 
icon looks like the new icon with a green background. 

¨ New/Old adds or removes the yellow new icon and is useful for filtering purposes.

¨ Changed marks results that have been modified since the last search. When the content or design of a site is 
modified, you may want to set that result to Changed in order to track it more closely.

¨ Rejected automatically excludes the results from any new searches. Results that are Rejected are excluded from 
the results list. If the same search is run again, WebSeeker excludes any previously rejected results by default. If 
you want a previously rejected result to be listed in a new search, choose to include Rejects on the View tab of the 
Preferences dialog box. You may want to set a result to Rejected if you don’t want to see it again.



¨ Browsed/Not Browsed can be used to filter out viewed results on future searches. Set results to Browsed when 
you have already seen them, but you don’t want to reject or monitor them. This feature can be used to filter out 
viewed results on future searches. The Browse feature also comes in handy when you have more results than you 
have time to survey at one time. Use this feature to set results you have already looked over to Browsed. When you 
come back to the search, select to display only Non-Browsed results. This way you can go back and finish looking 
at those results you have not already surveyed.

5.    WebSeeker changes the results setting.
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Enter the desired refine expression here. The expression listed searches for the phrase “great white shark” AND the word 
“dolphins” but NOT the word “whales”.



Press the Standard button to return to the standard Refine dialog box.



Click the Apply button to apply the current refine configuration to the current results, and leave the Advanced dialog box open for 
additional changes.



Reject

Results that are Rejected are deleted from the results list. If the same search is run again, WebSeeker excludes any previously 
rejected results by default. If you want a previously rejected result to be listed in a new search, choose Include, Rejects from the 
View Menu.

 If you delete many Search Results you should pack and re-index the results database by selecting Compact Database 
from the Tools menu. This decreases the size of the database and increase performance.



Includes and displays all New results in results column.



Includes and displays all Old results in results column.



Includes and displays all Changed results in results column.



Includes and displays all Rejected results in results column.



If you find a URL without WebSeeker you can manually add it your Search Results by selecting Action, Add Result 
(URL).



Select the type of search desired



Enter words to find in results documents.



Select the refine option desired for each word. Refine options are: AND, OR , But NOT, Followed by, and Near.



Select the But Not option for words that you would like excluded from the refined results.



Select the Followed by option when you would like to find the current keyword and the following keyword immediately after on 
another.



Click the Apply button to apply the current refine configuration to the current results, and leave the Refine dialog box open for 
additional changes.



Select the Near option for words that you would like to find within 20 words of the following keyword.



Press the Advanced button to configure advanced refine options. The Advanced dialog box appears.



Use InstantUpdate to automatically download any WebSeeker upgrades which you are entitled to. Select Manual Update Only to 
turn off auto update, and update files manually.



Use InstantUpdate to automatically download any WebSeeker upgrades which you are entitled to. Select Always Ask Before 
Updating to have WebSeeker prompt you before updating files.



Use InstantUpdate to automatically download any WebSeeker upgrades which you are entitled to. Select Update Without Asking 
to have WebSeeker automatically update files without prompting you.



Choose Select All to select all of the available search engines.



Choose Clear All to deselect any currently selected Search engines.



Set the maximum number of Simultaneous Connections desired here.



Set the maximum number of times WebSeeker requests the next set of results here.



Set the maximum amount of time for Reading results here. Once this time has lapsed WebSeeker times out.



Set the maximum amount of time for Connecting here. Once this time has lapsed, WebSeeker times out.



Enter the name of your Proxy Server (if applicable) here.



Enter your Proxy Port (if applicable) here.



Writes the selected results to an HTML web page.



Writes all results of the active search to an HTML web page.



Select month, day, and year to begin the action here.



Select the time to begin the action here.



Select the frequency for the action to be performed here.



Select month, day, and year to end the action here. This option is only enabled if the frequency has been set for more than once.



Select the time to end the action here. This option is only enabled if the frequency has been set for more than Once.



Enter the description of the action to be scheduled here. This field is optional.



Enter the directory and file to be scheduled here.



Enter the directory to save file to (if applicable). This is an optional field.



Select the Run Mode desired here: Normal; Minimized; Maximized.



Check here to have Schedule print the SQD file upon completion.



Check this box to have Schedule execute the scheduled program in the background. This option is not available if run mode is set 
to Maximize.



Click here to   browse   for file to execute.
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Acceptable Use Policy (AUP)
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Anonymous FTP
Application
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Archive
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Cracker
Cyberspace

D

Data Encryption Key (DEK)
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FAQ (Frequently Asked Questions)
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 Acceptable Use Policy (AUP)
This refers to policies restricting the ways in which a network may be used. It is usually the network administrator who makes 
and enforces decisions dealing with acceptable use.



 Address
See either IP Address or Email Address. 



 Alias
A nickname (usually short and easy to remember) that is used in place of a type of network resource. Aliases are used so you 
won't have to remember the long and difficult names typically associated with network resources.



 Anonymous FTP
Most FTP sites offer limited access by using the word "anonymous" as your user ID, and your E-mail address as the password 
when you login This way you can bypass local security checks and access to public files on the remote computer.



 Application
Often referred to as a client or an "app," it is a program that performs a specific function. The most common examples of Internet
applications    are, FTP, Mail, Gopher, Mosaic, and Telnet clients.



 Archie
The term “Archie” is often heard as an “Archie search”. Archie is a way of automatically collecting, indexing and sometimes even 
retrieving files on the Internet. Once you have located the information you are looking for, a good Archie client is able to FTP the 
files. 



 Archive
An archive is a collection of files stored on an Internet machine. FTP sites are known as archives.



 InstantUpdate
A ForeFront program which automatically upgrades to the newest version of WebSeeker.



 Authentication
A security process that ensures that users are who they say they are. When you type your name and password, you are 
authenticated and allowed access.



 Bounce
Bouncing occurs when you send an E-mail message and it doesn’t make it to the intended recipient, for any reason. The 
message “bounces” back to you. A bounced message usually begins with something like: “Undeliverable Mail” or “Message 
Undeliverable.”



 Bulletin Board System (BBS)
A computer which typically provides E-mail services, file archives, and announcements of interest to the bulletin board system's 
operator (known as a sysop). BBS's started out as hobbies for computer enthusiasts, and were mostly accessible by modem. 
Recently, however, more and more BBS's are being connected to the Internet. 



 Chat
An acronym meaning "Conversational Hypertext Access Technology." Another term for IRC.



 Client
An application that performs a specific function, such as Telnet or FTP. In more general terms, a client is an application that 
request the service of another computer, or application. A workstation requesting the contents of a file from a server is known as 
“Client Server Architecture”.



 Cracker
Unlike the benign “hackers,” crackers are usually malicious in their intentions. They are users who try to gain illegal access to 
computers.



 Cyberspace
William Gibson referred to Cyberspace in his fantasy novel “Neuromancer” as the “world of computers and the society that 
gathers around them,” Cyberspace has become a loose term for the on-line world, and sometimes the Internet.



 Data Encryption Key (DEK)
DEK’s are used like an actual key, to lock and re-open doors. They are used for the encryption and decoding of message text to 
limit access to those with the DEK.



 Data Encryption Standard (DES)
The standard Internet encryption method.



 Datagram

A block of data carrying enough information to travel from one Internet site to another ”non-stop”. In simple terms, it is “smart” 
enough to move around multiple sites without having to rely an earlier exchanges between source computers nad destination 
computers.



 Dedicated Line
A communications line that is used solely for computer connections. If you buy an additional phone line for your modem, that's a 
dedicated line. There are other types of dedicated lines (such as T3s and T1s) that are used for larger network entities. 



 Dialup
A widely-used method of accessing the Internet. A dialup connection uses regular phone lines to connect one computer to 
another via modem.



 Domain
Technically, the alphanumeric part of the DNS naming system; it is usually identifiable as a series of words separated by periods 
(called dots). For example, ffg.com is pronounced ffg-dot-com. In general terms, a domain is a logical region of the Internet and is 
commonly referred to as a site.



 Domain Name System (DNS)
Database system used to map the meaningful names humans use to refer to machines on the Internet (such as, The ForeFront 
Group) onto the IP addresses that the computers use to access one another. DNS allows the user to type in a simple, 
memorable company name which the computer converts into a unique series of numbers.



 Electronic Mail (Email)
A common way in which    computer users can exchange messages with each other over a network, or the internet. In fact E-mail
is probably the most widely used communication tool used on the Internet. E-mail has it’s own quirky language, but most 
conventions entail “To:”, “From:”, and “Subject:” lines. One of e-mails advantages is its ability to be forwarded and replied to 
easily.



 Email Address
An E-mail address has several different elements. Conventionally, addresses use lovercase letters with no spaces in between 
letters. The first part of the address is the username, which identifies a unique user on a specific server. Nest there is generally 
an “@”, (pronounced "at"). The “@” separates the username from the host name. The last part of an E-mail address is the Host 
name which uniquely identifies the server computer. For example, my E-mail address is:

sharone@ffg.com

Larger servers like those used at most universities, or large companies, often contain multiple parts, called subdomains. The 
subdomains and the host name are separated by a “.” (pronounced “dot”). The subdomain follows the host name. A two or three-
letter suffix represents the subdomain, and identifies the kind of organization operating the server. Some common suffixes 
are: .com (commercial) .edu (educational) .gov (government) .mil (military) .net (networking) .org (non-commercial). Two-letter 
suffixes are often used outside the U.S. to identify the country in which the server is located. Some examples are: .jp (Japan) .nl 
(The Netherlands) .uk (United Kingdom) .ca (Canada) .tw (Taiwan).



 Encryption
The basis of network security. Encryption encodes network packets to prevent anyone except the intended recipient from 
accessing the data.



 Ethernet
A standard and widely used connection type for Local Area Networks (LANs). Ethernet can transfer information at speeds of up 
to 10 Megabit-per-second (Mb/s).



 FAQ (Frequently Asked Questions)
Acronym for “Frequently Asked Questions.” FAQs are widely available on the Internet, usually in the form of large text files. 
FAQ’s can be written on any subject. they are frequently used in software documentation to resolve common problems. FAQ’s 
often provide the up to date, and easily accessible information on a their spcific subjects.



 File Transfer Protocol (FTP)
(File Transfer Protocol) TCP/IP protocol for transferring (copying) from one machine on the Internet to another. Basically, it is the 
Internet version of the File Copy functions on most desktop platforms. Since FTP evolved on the UNIX platform, its commands 
for making and changing directories, transferring, copying, moving, and deleting files were originally rather arcane text-based 
commands typed at a prompt. Fortunately, many graphical applications are now available that make FTP commands as easy as 
dragging and dropping.

 



 Gateway
A kind of "go-between" device or program that passes information between networks that normally couldn't communicate. What 
used to be called a gateway is now called a router. Not to be confused with a protocol converter. 



 Gopher
A gopher is an Internet information search and retrieval tool, used widely for research. The information that gopher retrieves is 
stored hierarchically on computers across the Internet. It uses a simple protocol that allows clients to access information from a 
multiple Gopher servers at once, creating what's known as "gopher space." Jughead and Veronica are the most common search 
tools used in gopher. Gopher clients exist on most platforms. 



 Hacker
A computer user who interested in gaining a complete understanding of the "ins and outs" of computers, networks, and the 
Internet in general. The term is meant to imply a tedious hacking away in bits and bytes. Hackers are usually benign, unlike their 
counterparts, crackers. 



 Host
A central computer or server that is attached to a network or the Internet. Hosts machines are set up for information sharing and 
file transfers. Individual users communicate with host machines by using client application programs. A Host can be a large 
server, or a mainframe, or even a desktop PC that is set up to share information to it’s peripherals.



 Host Address
The E-mail address of a host computer on the Internet. 



 Host Name
The name given a host computer connected to the Internet.



 Hypermedia
Hypermedia combines the elements of hypertext and media in one document. 



 Hypertext
A type of text containing “hot” or embedded "links" to other documents, or other pages within the same document. Clicking on or 
selecting a hypertext link “jumps” to display another page in another document or document section. Most World Wide Web 
documents contain hypertext.



 Hypertext Markup Language (HTML)
The standardized    way of marking text documents for publishing on the World Wide Web. HTML is marked-up using "tags", or 
context strings, surrounded by brackets. 



 Integrated Services Digital Network (ISDN)
A fairly new technology combining voice and digital network services. ISDN allows communications carriers to offer their 
customers digital data services and voice connections through a single line.



 Internet
A large computer network consisting of other smaller networks across the world. There are over 40,000 interconnected networks 
spanning at least 70 different countries. The Internet, which was originally created for military purposes, has become a highly 
commercialized information highway.



 Internet Protocol (IP)
A connectionless industry standard packet switching protocol used as the network layer in the TCP/IP Protocol Suite.



 Internet Protocol Address (IP Address)
The 32-bit address defined by the Internet Protocol. Every resource on the Internet has a unique numerical IP address, 
represented in dotted decimal notation. IP addresses are the closest thing the Internet has to phone numbers. When you "call" 
that number (using any number of connection methods such as FTP, HTTP, Gopher, etc.) you get connected to the computer 
that "owns" that IP address.



 Internet Service Provider (ISP)
An ISP is a company that maintains a network that is linked to the Internet through a T1 or other dedicated line. Individuals can 
purchase access to the Internet from the service provider.



 IRC
An acronym for Internet Relay Chat. It is Internet computer conferencing. There are hundreds of different IRC channels on 
almost every imaginable subject, from over 60 countries. You can join a chat group and enter messages that are broadcast to all 
members of that group.



 LAN
Acronym for "Local Area Network." A LAN is a communications network serving people within a certain area, such as a business.
LANs allow users to send E-mail and share resources such as files, printers, modems, etc. Many large companies now connect 
their LAN’s to the Internet so that they can access resources from outside their own network.



 Leased Line
A private, dedicated, full-time, communications channel used to link a user, or network to an Internet Service Provider or another 
network.



 Lurking
Lurking is non active participation in an IRC or Internet newsgroup. Essentially it is eavesdropping on the active participants. 
Lurking around a discussion group is a good way to catch up with the discussion, and also the acceptable behavior of the group.



 Mailing List
A list of E-mail addresses you can use to send “bulk” E-mail, instead of writing the same message over and over. You can also 
subscribe to an Internet mailing list on many subjects. After you have subscribed to a mailing list, you receive all mail sent to that 
list. 



 Mirror Site
Many Web and FTP sites have become so popular that they have acquired “mirror sites” to alleviate congestion. Mirror sites are 
areas on another computer that “mirror” or contain an exact replica of the directory structure of the files on the overly popular 
site’s computer. If you have trouble getting connected to an FTP site, for example, because of the high amount of traffic, you can 
usually connect to a mirror site that contains the same information on a different computer. Mirror sites are usually updated once 
a day.



 Netiquette
Netiquette is a combination of the words “network” and “etiquette”. Netiquette defines appropriate behavior on a network, or the 
Internet. It was developed to remind users that there are real people on the other end of the connection, and that certain 
comments are considered unacceptable.



 Network File Systems (NFS)
A distributed file system developed by Sun Microsystems. NFS allows information and file sharing across multiple platforms. This
de facto UNIX standard makes remote files appear as if they are on a local machine.



 Network News Transfer Protocol (NNTP)
A standard protocol used for Usenet groups on the Internet. NNTP regulates    the distribution, inquiry, retrieval, and posting of 
news articles. NNTP is supported Usenet newsreaders.



 Open System Interconnection (OSI)
A standard developed by the International Standards Organization for worldwide communications. OSI defines a framework for 
implementing protocol in seven layers, designed to be the international standard computer network architecture. 



 Packet
The common term for a block of data transmitted across the Internet. 



 Packet Internet Groper (PING)
Ping is an Internet utility used to    test or, time the response of an Internet connection. After the message , or PING, is sent out, 
you wait for a response (or PONG).



 Point of Presence (POP)
POP is the point at which a long distance carrier and a local carrier, or user, connect. 



 Point to Point Protocol
A datalink protocol providing dial up access over serial lines. It encapsulates other standard protocols (such as IPX, TCP/IP, and 
Netbeui) over a standard telephone connection, but it can also be used for LAN connections.



 Post Office Protocol (POP)
A protocol commonly used by E-mail programs to transfer messages to and from file servers via the Internet. When E-mail is 
sent to you, it is stored on the server until accessed by you. Once you have logged in and your password is verified, the POP 
transmits the stored mail from the server to your local mailbox on your computer.



 Posting
The sending of an article to a Usenet newsgroup or the placing of a message on a BBS.



 Protocol
Language spoken between computers to exchange information. More technically, a protocol is the formal description of formats 
and rules followed by machines to exchange information. Different protocols are used to exchange different sorts of messages, 
such as news for newsgroups and FTP for file transfers.



 Router
A device that forwards traffic between networks. Forwarding decisions are made based on network layer information and routing 
tables, often constructed by routing protocols. 



 Serial Line Internet Protocol (SLIP)
Similar to PPP, SLIP is another standard protocol used to run TCP/IP over serial lines, such as telephone circuits or RS-232 
cables. Unlike PPP, however, SLIP does not work on a LAN connections. SLIP is probably the most popular way for dialup users 
to access the Internet.
Standard protocol (similar to PPP) which is used to run TCP/IP over serial lines, such as telephone circuits or RS-232 cables. 
SLIP, unlike PPP, does not work on LAN connections. SLIP is one of the most popular ways for dial-up users to access the 
Internet. In general, Web access requires a SLIP or PPP connection.



 Server
Simply, a computer that provides resources, such as files or other information, to multiple users. Servers act like a remote disk 
driver.



 Signature
A unique number, or identifier in ASCII format that can be embedded in to a piece of E-mail or newsgroup posting that identifies 
the sender.



 Simple Mail Transfer Protocol (SMTP)
A simple messaging protocol used to transfer E-mail. SMTP is used in TCP/IP networks to transfer mail from server to server.



 Simple Network Management Protocol (SNMP)
A commonly used protocol for network monitoring and control. It can be used to manage wiring hubs, CD ROM jukeboxes, and 
many other devices.



 T1
Two terms coined by AT&T to describe the types of high-speed connections of hosts to the Internet. A T1connection transmits a 
DS-1 formatted digital signal at 1.544 megabits per second. A T3 connection transmits a DS-3 formatted digital signal at 44.746 
megabits per second.



 TCP/IP Stack
To properly implement TCP/IP protocol, PCs require a TCP/IP stack. This type of network architecture is designed in layers (OSI 
and SNA are also considered stacks).



 Telnet
The Internet standard protocol used to connect to remote terminals. Telnet allows users to log onto a remote terminal or    
computer and run a program, as if it were local. Telnet clients are available for most platforms.



 Token Ring
A type of LAN in which allows up to 255 network computers (nodes) to be wired into a "ring." Each computer is in constant 
contact with the next node in the ring. If one node in the ring loses it’s connection, each following link in the network is disabled.



 Transmission Control Protocol/Internet Protocol (TCP/IP)
TCP/IP is the standard communications protocol created under contract from the U.S. department of defense. Originally created 
to internetwork dissimilar systems, TCP/IP is now required for Internet computers. Everey computer attaching to the internet 
needs a set of software components call a TCP/IP stack.



 Veronica
A search engine (similar to Archie) that is embedded into Gopher. Veronica allows searches of all gopher sites for files, 
directories and other resources. 



 Universal Resource Locator (URL)
Standard address format used to identify and locate sites on the Internet. World Wide Web site URLs begin with the prefix http:// 
(HyperText Transfer Protocol), generally followed by www (World Wide Web). After the standard prefixes, URLs use identifiers for
different domains and subsections of domains, each separated by a period (.). The various levels of a site are separated by a 
forward slash (/); individual home pages are often preceded by a tilde (~).



 White Pages
Similar to a telephone book, White Pages referes to a database containing E-mail addresses, telephone numbers, and postal 
addresses of Internet users. You can search the Internet White Pages for information about particular users.



 Winsocks
A combination of the words "Windows” and “Sockets." Winsocks is a common programming interface between the TCP/IP 
protocol and a Windows application.



 World Wide Web (WWW or W3)
The "Web" is a collection of online documents interconnected through hypertext links on Internet. These hypertext/hypermedia 
documents, or Web pages, reside on different servers all around the world. On the WWW you can “jump” from one document to 
the next no matter where it is located in the world. In order to access these documents, you must use a Web browser, such as 
Netscape, Microsoft Internet Explorer, or Mosaic.



 Browser
A program that lets the user look through data. Examples of common Internet browsers are: Netscape, Microsoft Internet 
Explorer, Mosaic, etc.



 Browse

1- To view a group of files or the content of a single file. A browser program allows you to scroll through documents or databases.

2- Browse buttons allow you to view the file names in your disk directories.    Clicking on the name of a drive or directory 
automatically switches you to those locations



 Home Page
Point of entry into a company’s, individual’s, or institution’s set of HTML pages on the World Wide Web. This foundation page is 
often used as an index with links to other resources on the Web or to other Internet servers.



 Search
To look for specific of data or text.



 Search Result
The findings returned on a Search.



 Search Module 
A Search Module is what allows WebSeeker to interface with the Search Engines.



 Web Page
A page of a document on the World Wide Web.



 Webmaster
The person responsible for creating a Web Page, and keeping it updated. A Webmaster would be the equivalent to a system 
administrator on the World Wide Web.



 Jughead
An Internet utility which will perform a keyword search on all levels of a Gopher menu. Using Jughead you do not have to jump 
from one level of the menu to the next.



 Kermit
Kermit is an asynchronous file transfer protocol which was developed at Columbia University. Kermit is known for it’s accuracy 
across noisy lines.



 Launch
To load and run a program.



 Log-On
To sign on, or gain access to a computer system. Some systems may require user identification and a password.



 Log-Off
To sign off, or disconnect from a computer system.



 Quit
To exit an active application.



 Radio Buttons
Circular on-screen buttons that are used to select one out of several responses. A small black spot will appear in a radio button 
when it is selected. A radio button becomes de-selected when another within the same “box” or section, is selected.



 Realtime
An immediate response. Any electronic response system fast enough to keep up with it’s real world counter parts.



 Renew
Launches a search of a previously completed search.



 X-Axis
This refers to the horizontal rows in an X-Y Matrix.



 Y-Axis
Y-Axis refers to the vertical columns in an X-Y matrix.



X-Y-Matrix
A group of rows and columns. The reference framework for 2 dimensional structures.



Login
Same as log-on.



Firewall
Network node used as a boundary, or security device, to prevent Internet traffic from crossing over from one side to another. A 
firewall may be implemented in a router protecting a company’s or institution’s server, or it may be a specialized device used for 
such purposes.



Proxy Server
Application which passes information between a browser and the Internet. A proxy server is used to get through a firewall. A 
proxy can only be used one way through the firewall. If your server has a firewall a proxy server is used to get through the 
firewall out to the Internet. 



Port
A pathway or opening into and out of a computer. 



Reposts
Each search engine has a maximum number of results it can display at a time. If you want to see more information you can 
repost and the next set of results will be displayed.



Compact Database
Deletes items that have been tagged for deletion and recompiles data.



Boolean Operator

Boolean logic, named for 19th century English mathematician George Boole, uses AND, OR, and NOT as its primary operations,
just as add, subtract, multiply, and divide are primary operations of arithmetic.

A Boolean search requires that specific conditions must be met. For example, using the keywords “tropical fruits,” the AND 
Boolean operator requires that both words “tropical” and “fruits” be contained in the data of a matching result.



Whack

Downloads the web page where the keyword was found to the computers hard drive so results can be viewed later. Grab copies 
the results in HTML format so that you can surf the results on your hard drive.



NOT is a Boolean operator available using the Refine tool. Using NOT as the search operator will exclude any words listed in 
parallel with NOT from the document. For example, using the keywords “fruit” but NOT “tropical” would exclude any documents 
that contain the word “tropical”.



Proxy

Special kind of application which serves as an interface between the Web browser and the actual connection to the Internet. 
WebWhacker is a proxy (or proxy server) which serves up information from the WebSeeker User’s Manual database to your Web
browser.




