
Symmetrica™
Using the latest in object-oriented programming techniques, Symmetrica™ has been designed to be a fast and 
easy, yet powerful, architectural drawing program. Its state-of-the-art interface allows total control over your 
drawings and the elements that make up the drawings. We at Software Engineering, Inc. hope you find 
Symmetrica™ as enjoyable to use as we did designing it.

For information on some of the key features of Symmetrica™, click the Help Topics button above or choose one 
of the topics below.

What is Software Engineering, Inc.? 

How do I import AutoCAD drawings? 

What is an element? 

How do I use the Input Box? 

What are Snaps? 

What is the Detail Gallery? 

Useful Key Commands

How can I improve the performance of Symmetrica? 



Importing
One important feature of Symmetrica is its ability to easily convert drawings from AutoCAD to Symmetrica. The 
conversion process is simple and by checking the status of the import, you can get a good feel for how well the 
drawing was converted.

The Import Status box shows the element conversion statistics of the import.

n Drawing Elements Created - These are the elements which were created from recognized elements in the 
AutoCAD drawing.

n Drawing Elements Spawned - When AutoCAD elements are recognized by Symmetrica as being made up of 
more than one element, it will spawn the additional elements. These are extra elements which AutoCAD 
recognized as only one element but Symmetrica recognizes as being made up of two or more.

n AutoCAD Elements Absorbed - When Symmetrica recognizes two or more elements from AutoCAD that can be 
treated as one element, it absorbs the extra elements. These are elements that Symmetrica recognizes as one
element but AutoCAD recognized as two or more.

n AutoCAD Elements Ignored - Certain elements in AutoCAD have no relevancy in Symmetrica. These elements 
are simply ignored.

n Total Elements Processed - This is the total number of elements created, spawned, absorbed and ignored.
n AutoCAD Blocks Converted To Symbols - AutoCAD blocks are converted into Symmetrica symbols.

Step By Step

Importing AutoCAD drawings    



Exporting

Symmetrica does an excellent job of exporting drawings into AutoCAD format.

The Export Status box shows the element conversion statistics of the export.

n AutoCAD Elements Created - These are the elements which were created from recognized elements in the 
Symmetrica drawing.

n AutoCAD Elements Spawned - When Symmetrica elements are recognized by AutoCAD as being made up of 
more than one element, it will spawn the additional elements. These are extra elements which Symmetrica 
recognized as only one element but AutoCAD recognizes as being made up of two or more.

n Symmetrica Elements Absorbed - When AutoCAD recognizes two or more elements from Symmetrica that can 
be treated as one element, it absorbs the extra elements. These are elements that AutoCAD recognizes as one
element but Symmetrica recognized as two or more.

n Symmetrica Elements Ignored - Certain elements in Symmetrica have no relevancy in AutoCAD. These 
elements are simply ignored.

n Total Elements Processed - This is the total number of elements created, spawned, absorbed and ignored.
n Symbols Converted To AutoCAD Blocks - Symmetrica symbols are converted into AutoCAD blocks.

Step By Step

Exporting drawings to AutoCAD



Print Setup
The print setup configuration is largely dependent upon the type of printer you have connected to your 
computer. Refer to the documentation that came with your printer for the proper setup parameters.



Page Setup
The Page Setup box is used for defining how Symmetrica is going to send the drawing to the printer.

Options

If a black and white printout is desired or your printer doesn’t support color, choose this option.

Scaling

Scaling determines the size of the drawing as it relates to the paper size. By default, the drawing will 
automatically be scaled to the size of the paper specified in Printer Setup.

Positioning

If printing at drawing scale or custom specified scale, you can specify whether the drawing will be positioned in 
the upper left corner of the paper when printed or centered according to the position of the benchmark.

Margins

The margins can individually be set. They are measured in paper distances.

Step By Step

n Changing the Page Setup.



Optimizing Recommendations

The following are a few helpful tips that may help improve the overall performance of Symmetrica.

n Get more RAM to improve overall performance.
n Turn off snaps that are not necessary. This will improve cursor performance.
n Save your work periodically. This releases memory allocated for
n Undo/Redo objects. This is especially important after importing an AutoCAD drawing, which creates an 

enormous amount of Undo data.
n Use Windows NT instead of Windows 95.
n Close other applications.
n Layer Management - turn off unneeded layers.



Useful Key Commands

The following is a list of useful key commands that either perform certain actions or modify others.

Alt
n When you select a group of elements by dragging, it creates a rectangular selection cursor. By default, any 

elements which have locations in the area will be partially selected, if the element supports partial selection. If
the Alt key is held down when the selection is made, only elements that are completely within the area will be 
selected; elements partially in the area will not be selected.

Ctrl
n When dragging an element or a point of an element, the Ctrl key will perform a copy function rather than a 

move function.

Esc
n Clears the text from the text input box, if there's any there.
n Stops the current command if there is no text in the input box.

Space
n Stops the current command if there is no text in the input box.
n Restarts the last command if no command is currently running.



Elements

Symmetrica is truly an object-oriented program. The most basic object definition is called an element. This can 
be illustrated by viewing the properties of a single line element.

Each element is stored with a unique ID in a database created with each new document. Layers can be created 
in the document and elements assigned to the different layers. You can also make the color of the element 
assume the color of the layer it is assigned to.

From there, you move up in the hierarchy and find there are different types of elements: line, arc, stretch-box, 
etc. Different types of elements can additionally have further tiers of properties. For instance, a text box is at its 
most basic, an element as all objects are. Further, it is a stretch-box element and assumes all the properties of 
that type of element. More specifically, it is a text stretch box element.



For more information on the different types of elements, click on the element type listed below.

Arc
Circle
Groups
Line Dimension
Line Segment
Point
Polyline
Rectangle
Stretch Box
Symbol
Text Box

Step By Step

Defining Element Properties
Defining Default Element Properties 



Benchmark

The benchmark  is the current point of reference from which all other measurements are defined. It defines 
the current location 0’-0”, 0’-0” on the X-Y axis. The benchmark is also used when using perpendicular snaps  or 
orthographic snaps. 

You can define both the color and the diameter of the benchmark.

Step By Step

Moving the Benchmark
Defining Element Properties
Defining Default Element Properties



Arc
Arcs are segments of circles defined by three points.
n The Center Point is the point around which the arc curves.
n The Start Point is the first end point.
n The Sweep Angle determines the direction of the arc from the start point. A positive sweep angle indicates a 

counter-clockwise arc while a negative sweep angle indicates a clockwise arc.
n The Point In The Plane is a third point in space used for defining 3 dimensional arcs.
 

All point positions are relative to the current position of the benchmark. The Line Weight and Color are definable 
properties. 

Step By Step

Creating an Arc
Defining Element Properties
Defining Default Element Properties



Circle
Circles are defined by two points.
n The Center Point is the point around which the circle rotates.
n The Radius Point defines the radius of the circle.
n The Point In The Plane is a third point in space used for defining 3 dimensional circles.

All point positions are relative to the current position of the benchmark. The Line Weight and Color are definable 
properties. 

Step By Step

Creating a Circle
Defining Element Properties
Defining Default Element Properties



Groups
A group is a collection of elements treated as a single stretch box element. 

Step By Step

Creating a Group
Defining Element Properties
Defining Default Element Properties



Line Dimension
Line Dimensions are dimension lines defined by two points.
n The start point.
n The end point.

Once a dimension lines points have been defined. Symmetrica automatically calculates all other information 
concerning the dimension line. (i.e. terminators, witness line extensions, etc.)

The Dimension Line Location determines



Line Segment
Line Segments are defined by two points.
n The start point.
n The end point. 

All point positions are relative to the position of the benchmark. The Line Weight and Color are definable properties. 

Step By Step

Creating a Line Segment
Defining Element Properties
Defining Default Element Properties



Point
(New topic text goes here.)



Polyline
Polylines are defined by as many points as needed.
n The Insertion Point is the starting point of the polyline.
n As many other vertices as needed..

Polylines have the added ability to automatically close the boundary. This eliminates redundant end points.

All point positions are relative to the position of the benchmark. The Line Weight and Color are definable properties. 

Step By Step

Creating a Polyline
Defining Element Properties
Defining Default Element Properties



Rectangle
A rectangle is not an element type in and of itself. It is actually a polyline group.

Step By Step

Creating a Rectangle
Defining Element Properties
Defining Default Element Properties



Stretch Box
Stretch boxes are defined by three points which are three of the corners of the box.

All point positions are relative to the position of the benchmark The border color can be determined by clicking in 
the Border Color box.

Step By Step

Creating a Stretch Box
Defining Element Properties



Symbols
Symbols are elements that have been grouped together and identified in a database as a separate element.

Step By Step

Creating a Symbol
Placing a Defined Symbol
Defining Element Properties



Text Box
Text Boxes are a type of stretch box element. 

The large box at the top shows the text in the box. Theoretically, there is no limit to the amount of characters that 
can be input into this box.

The font, size and other attributes can be defined by clicking the Choose Font button. The fonts available to you are 
determined by whatever fonts are currently installed in Windows. 

If you want to import a text file into a text box, use the Read Text File button.

Text color allows you to change the color of the text. Click in the box to bring up a palette of colors.

The Fill Background check box determines whether the text box will be opaque or not. If it is checked, the 
background color will then be determined by the Background Color box. Click on the box and choose the color 
from the palette displayed.

Finally, the left, right or centered alignment of the text within the text box can be selected with the Horizontal 
Alignment buttons.

Step By Step

Creating a Text Box



Line Weight
The line weight is the thickness of the line(s) defining the element.



Line Color
The line color determines the color of the line(s) defining the element.



Default Element Properties
(New topic text goes here.)

Step By Step

Defining Default Element Properties 



Choose Font
(New topic text goes here.)



Read Text File
(New topic text goes here.)



Changing the Page Setup
(New topic text goes here.)



Snaps
Snaps are tools that help place points on the drawing. Each snap will act as a magnet to different types of points 
in the drawing (i.e. center points, perpendicular points, etc.). When a point is being snapped, the mouse cursor 
has a circle around it and the element being snapped to has a dotted line bordering it.

Example shown with a line being drawn to the center of a rectangle with Center Point snap enabled.

By using snaps and the grid, very precise drawings can be sketched in a short time. To learn more about the 
different types of snaps and the grid, go to one of the following topics:

Rounding
Visible Grid
Benchmark
Autobenchmark
Orthographic
Center Point
Locations
Perpendicular
Intersection
Nearest Point



Visible Grid
The grid is a measuring tool which determines the rounding scale.



Orthographic Snap
Orthographic snaps are snaps at angles of 45. The Alt key will toggle orthographic snap while drawing.



Perpendicular Snap
Perpendicular snaps are snaps at right angles to other elements.



Rounding
Rounding determines whether points will snap to the nearest current rounding increment. When rounding is 
turned off, strange values can be stored for points entered.



Center Point Snap
Center Point snap will find the center of an element.



Location Snap
Location snap will snap to the points that define other elements.



Intersection Snap
Intersection snap will snap to intersections of lines.



Nearest Point Snap
Nearest Point snap will snap along the lines of the element.



Autobenchmark
Autobenchmark forces the benchmark to follow you as you draw elements. It will move from point to point as 
you draw an element.



Hide/View Benchmark
The benchmark can be hidden from view.

Step By Step

Hiding/Viewing the Benchmark



Mouse Command Detail
The following table summarizes the basic mouse interface, including selection and direct manipulation (drag and
drop).

Table A. Interaction Guidelines for Common Unmodified Mouse Actions 
Action Target Effect on 

current 
selection 
state

Effect on 
anchor point
location

Resulting 
operation 
using button
1

Resulting 
operation 
using button
2

Press Unselected 
element

Clears the 
active 
selection.

Resets the 
anchor point 
to the 
element.

Selects the 
element.

Selects the 
element.

Selected 
element

None None None None

White space 
(background)

Clears the 
active 
selection.

Resets the 
anchor point 
to the button.

Initiates a 
region 
(marquee) 
selection.

Initiates a 
region 
(marquee 
selection)

Click Unselected 
element

Clears the 
active 
selection.

Resets the 
anchor point 
to the 
element.

Selects the 
element.

Selects the 
element and 
displays its 
pop-up menu.

Selected 
element

None None Selects the 
element.

Selects the 
element and 
displays the 
selection’s 
pop-up menu.

White space 
(background)

Clears the 
active 
selection.

None None Displays the 
pop-up menu 
for the white 
space.

Drag Unselected 
element

Clears the 
active 
selection.

Resets the 
anchor point 
to the 
element.

 Selects the 
element and 
carries out 
the default 
transfer 
operation 
upon the 
button release
at the 
destination.

Selects the 
element and 
displays the 
non-default 
transfer pop-
up menu upon
the button 
release at the 
destination.

Selected 
element

None None Carries out 
the default 
transfer 
operation on 
the selection 
upon the 
button release
at the 
d3estination.

Displays the 
non-default 
transfer pop-
up menu upon
the button 
release at the 
destination.

White space 
(background)

Clears the 
active 
selection.

None Selects 
everything 
logically 
included from 
anchor point 
to active end.

Selects 
everything 
logically 
included from 
anchor point 
to active end 
and displays 
pop-up menu 
for the 
resulting 
selection.

Double-
Click

Unselected 
element

Clears the 
active 
selection.

Resets the 
anchor point 
to the 

Selects the 
element and 
carries out 

Selects the 
element.



element. the default 
operation.

Selected 
element

None None Carries out 
the selection’s
default 
operation.

Selects the 
element.

White space 
(background)

Clears the 
active 
selection.

None Carries out 
the default 
operation for 
the white 
space.

None



Splitting

It may be desirable to split groups or symbols into their component elements. This can be accomplished by using
the split action. Polylines can also be split into component line segments.

Step By Step

n Splitting Groups
n Splitting Polylines
n Splitting Symbols



Arrays
Using arrays makes it easy to duplicate elements across a large area of the drawing.

With the previous settings, an object was duplicated in the following manner:

Step By Step

n Duplicating Elements Across An Array



Clean Up Intersections
Use Cleaning Up Intersections to divide intersections into separate points on the drawing.

In the example above, Step 1 shows two crossed lines. Step 2 shows the lines after being cleaned up. Step 3 shows 
how the lines were separated at the intersection and are separate elements.

Not only does it break lines and walls at intersections, it also fuses similar collinear line segments and walls into a 
single segment. Lines need only overlap to fuse. Walls will only fuse if they share a common end point location and 
are collinear and the same width etc. Basically they have to look alike on the screen and they will fuse. This 
capability has not been extended to other elements yet, only to lines and walls. Basically, anything that knows how 
to break itself also knows how to fuse itself.

Step By Step

n Cleaning Up Intersections



Round
The Round action will round all the selected elements insertion point to the nearest grid point according to the 
current rounding increment. 

In the example above, Step 1 shows two lines drawn without the Rounding option on. Step 2 shows the lines after 
being rounded. Notice each end point snapped to the nearest grid point according to the rounding increment. This 
action should be used with caution.

Step By Step

Rounding



Global Properties
Global properties define properties for everything currently being drawn.



Input Box Tool Bar
The input box is used for entering specific points on the x,y,z axis.

When creating an element, the points for the element can be entered manually. Any combination of units can be 
used and will be understood. If no units are entered, the output units for this drawing will be used.

The input box is always active when drawing window is active. To clear text from the input box, press the Esc key.

prefix/qualifier/input codes:

a - absolute.
This specifies coordinates relative to the origin of the database. This would not be relative to the benchmark but 
rather from the starting point of the drawing.    Example: a5,10 would be right 5 units, up10 units from the origin.

r - relative.
This is to help Arris users who are used to using the prefix. It will be ignored.

@ - relative.
This is to help users of AutoCAD who are used to using the prefix. It will be ignored.

p - polar.
This specifies that the numbers entered are distance,angle,angle of inclination. Angles are degree values with 0 
being to the right. The value entered is relative to benchmark.

Prefixes can be combined. Example: ap20,30 would be polar coordinates absolute to the origin of the database.

Values
The default units of the values entered are determined by the Units In Which To Display Values (output units) 
setting in the Number Format Settings for Lengths.

The default is not always the desired units however. Any unit in either standard or metric can be specified on the
value entered and any combination of values can be used. For instance the value 6m,10’ would be properly 
interpreted. Keep in mind however, that the base units specified in the drawing settings is the unit in which 
every value is stored in the database. Therefore, if the base unit is in feet, Symmetrica will convert the 6m into 
the standard value of 19’-8 ¼”. The value is rounded in the drawing according to the ?

If no value is entered, the assumed value is 0. Ex: 5,,12 is interpreted as 5,0,12.

Fractional amounts can be entered as well. Ex: 6-3/4,5-1/2. If the output units are set to feet, this would be 
interpreted as six and three quarters feet by five and one half feet. It could also be input as 6 9,5 6.

Other examples of proper input values would include:
6m 5cm,10’ or 13km,12m 3”. While these examples may seem impractical and perhaps a bit odd, they do 
illustrate the flexibility of the values that can be entered.

When you enter points using the mouse cursor, they are entered in the plane that is parallel to the XY plane 
(top) which passes through the benchmark. In other words, they are entered at the Z height of the benchmark.

Sometimes, the XY plane is only a line in the view, such as when viewing from various side angles. In this case, 



the point is entered in the plane that is parallel to the XZ plane (front) which passes through the benchmark.

In two views, "Left" and "Right", the XZ plane is a line also. In this case, the point is entered in the plane that is 
parallel to the YZ plane (side) which passes through the benchmark.

The use of the benchmark is important here because it allows you to establish the "Z-level" in the view at which 
you will draw.



Snap Tool Bar



View Tool Bar



View Tools

Click the button on the tool bar or one of the topics below to see more information on the different view tools.

Redraw
Zoom Rectangle
Zoom All
Last View
Zoom In
Zoom Out
Isometric View
Top View
Back View
Left Side View
Front View
Right Side View
Roll Left
Pitch Up
Roll Right
Yaw Left
Look At Benchmark
Yaw Right
Rotate Left
Pitch Down
Rotate Right



Redraw
There are times when you may need to have Symmetrica redraw the screen. Keep in mind that with very large 
drawings, this could take a moment.



Zoom Rectangle
The Zoom Rectangle tool allows you to zoom in on a selected area of your drawing.



Zoom All
The Zoom All tool will show the entire drawing on the screen.



Last View
Use Last View to use the last view level you were at.



Zoom In
Zoom In takes you in one increment.



Zoom Out
Zoom Out takes you out one increment.



Isometric View
The Isometric View is a stand off view rotated in three dimensional space.



Top View
The top view of the drawing.



Back View
The back view of the drawing.



Left Side View
The left side view of the drawing.



Front View
The front view of the drawing.



Right Side View
The right side view of the drawing.



Roll Left
(New topic text goes here.)



Pitch Up
(New topic text goes here.)



Roll Right
(New topic text goes here.)



Yaw Left
(New topic text goes here.)



Look At Benchmark
(New topic text goes here.)



Yaw Right
(New topic text goes here.)



Rotate Left
(New topic text goes here.)



Pitch Down
(New topic text goes here.)



Rotate Right
(New topic text goes here.)



Drawing Settings

By default, the description of the drawing is the date and time the document was created. The description is 
optional but can be used for entering a detailed description of the drawing. Theoretically, there is no limit to the 
amount of text that can be typed into the description box.

The Drawing Scale establishes the proportion between values expressed in paper units and those expressed in 
drawing units. You should select the scale at which you plan to print so that your font size selections and etc. 
produce the correct result. Note that you can print at any scale, regardless of the scale you choose here.

All drawing values are stored in a common Base Unit. You should select the units which are used most frequently 
in your work to minimize rounding anomalies.

The Status section displays the total number of elements, symbols, etc. in the current document.



Drawing Scale
(New topic text goes here.)



View Settings
(New topic text goes here.)



Rounding Settings
(New topic text goes here.)



Number Format Settings
The Numbers Format Settings deal with the way Symmetrica displays values that are in real world lengths.    as 
determined by the Drawing and View Settings and the way actual paper distances are scaled to your drawing.

The output units are the default used in the input box and property sheets and anywhere else you enter a value 
that is in database space. Exception is line weight., font size, .

Paper distances determines how to display units that are known to be paper distances. 72 point text is 1 inch tall
this is paper distance.    Look for the words “on paper”.
For instance the margins on the page or arrow heads.

Look at line dimensioning properties for examples of all.



Software Engineering, Incorporated

"Excellence By Design"
Software Engineering, Inc. is a company dedicated to creating excellent quality software for Microsoft Windows. 
We have established a high standard of excellence for our organization and we are committed to achieving that 
goal through skill, honesty, integrity, relentless determination, and a meticulous attention to detail. 

Specializing in C and C++ object oriented design, our highly skilled team of developers has many years of 
experience writing software. The experience base at Software Engineering spans many hardware platforms 
(including mainframes) and operating systems, including Apple, Unix, DOS, and Windows (since version 1.0). We 
have extensive combined experience in many specialized genres of programming such as Computer Aided 
Design, network communications, diagnostic tools, monitoring systems, games, client/server applications, SQL, 
and image processing. 

We have developed a powerful new CAD program for Microsoft Windows called Symmetrica™. The extensible 
nature of its object oriented design allows us to easily derive new custom CAD applications from the Symmetrica 
CAD engine. The Symmetrica engine can be readily molded to accommodate any specialized CAD application. 
We would like to develop a new CAD application for you. 

If you have software development needs, we would like to talk with you. 

For more information about custom software development for Windows, please contact Software Engineering, 
Inc. 

Software Engineering, Inc. 
8352 S. Sunnyside Place 

Highlands Ranch, CO 80126 
Voice: 303-470-7142 
Fax: 303-470-1156 
sei@freehome.com 

Send us a note via e-mail or visit us at www.datapype.net/~sei



Licensing
Proper licensing is vital to the operation of Symmetrica™. Licensing involves a hardware key, license number and
password. All of these are available to registered users through Software Engineering, Inc.
Registered users are bound by the enclosed Software License Agreement.

Symmetrica™ is a trademark of Software Engineering, Inc.



Hardware Key
The hardware key is a device which plugs into any standard parallel port. When a valid hardware key is attached,
a key symbol will show here. Symmetrica will run without a valid hardware key but will have limited capabilities. 
A hardware key is available from Software Engineering, Inc. 



License & Password
When a valid license number and password is entered, the lock will appear unlocked. Symmetrica will run 
without a valid license number and password but will have limited capabilities. A license number and password 
are available from Software Engineering, Inc. 



Layers
Layers can best be described as having multiple transparencies with different parts of the drawing on each one. 
Properties can be changed for each layer or multiple layers can be changed simultaneously.

The first section of the layers box shows the different layers currently defined. It lists names of the layers, the colors
assigned to each layer, a count of the number of elements in each layer and the current status options assigned to 
each layer.

The Status section shows the different options that can quickly be assigned to a layer or layers. These options can 
also be set through the properties button or by double-clicking on the layer.

n Read Only - Elements on this layer cannot be selected or modified directly.
n Snap - Elements on this layer will be located by various cursor snapping methods.
n Temporary - This layer will not be saved by save or save as
n Visible - Elements on this layer will be visible when drawing or printing.



Layer Properties
(New topic text goes here.)



Select All Layers
This button will select all layers currently defined.



Creating a new layer

1 On the Settings menu, click Layers. (or click on the Layers button  located on the Global properties tool 
bar.)

2 Click the create button.
3 In the properties box, type in a name and modify the settings as needed for the new layer.
4 Click the OK button.

Tip

n A new layer can be created on the fly by editing the element properties of any element or group of elements, 
then typing in a new layer name.



Changing the current layer.

1 On the Settings menu, click Layers. (or click on the Default Layer pull down menu  located on 
the Global Properties tool bar.)

2 Select the layer you want to work with.
3 Click the OK button.



Deleting layers
1 On the Settings menu, click Layers. (or click on the Layers button

 located on the Global 
Properties tool bar.)

2 Click the delete button.
3 Click the OK button.

Tip

n This will delete all elements associated with the layer.



Software License Agreement

SOFTWARE ENGINEERING, INC.

Symmetrica™
Copyright - 1996 by Software Engineering, Inc.
All Rights Reserved

NOTICE: Symmetrica is NOT public domain or free software. All rights to and in Symmetrica, including but not 
limited to, copyrights and trade secret rights, belong to Software Engineering, Inc., which retains and holds title 
to each copy of Symmetrica.

READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY BEFORE USING Symmetrica. ANY USE OF 
Symmetrica INDICATES YOUR FULL ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN THIS LICENSE 
AGREEMENT.

In this license agreement (“License Agreement”), you, the customer and holder of the license rights granted by 
this Agreement, are referred to as “Licensee” or “You”; Software Engineering, Inc., the Licensor Corporation, is 
referred to as “SEI”.

1.1 Non-Registered (Demonstration) License

1.1 Evaluation and Registration. In accordance with the terms and conditions of this License Agreement, you are 
hereby licensed by SEI to use Symmetrica in its non-registered, Demonstration version without charge for 
evaluation purposes. The non-registered, Demonstration version of this software contains certain limitations 
on its features and functions. In order to obtain a fully functional version of this software, a registration fee is 
required. Payments must be in U.S. dollars drawn on a U.S. bank. Payments should be sent to:

Software Engineering, Inc.
8352 S. Sunnyside Place
Highlands Ranch, Colorado 80126
303-470-7142
303-470-1156 Fax
SEi@freehome.com

When an order and payment arrangements have been received by SEI, Customer will be sent a License 
Number and Password to be entered at the start of the software. This will turn your copy of Symmetrica into 
the licensed Registered version with all the features and functions.

1.1 Distribution. Provided that you verify that you are distributing the entire non-registered, Demonstration 
version, (which shall include this License Agreement), you are hereby licensed to make as many copies of 
Symmetrica as you wish, provided further that you conspicuously and appropriately publish on each such 
copy file a valid copyright notice as follows: “Copyright - 1996 Software Engineering, Inc.”; you are further 
licensed to give such exact copies of the non-registered, Demonstration version to anyone; and, to distribute 
the non-registered, Demonstration version of Symmetrica in its unmodified form via electronic means. There 
is no charge for any of the above.

You are specifically prohibited from charging, or requesting donations, for any such copies, however made. 
You are specifically prohibited from distributing the software and/or documentation with other products 
(commercial or otherwise) without prior written permission from SEI.

2.1 Registered License

Upon attainment of a License Number and Password as provided in paragraph 1.1, above, and subject to the 
terms and conditions set forth in this License Agreement, SEI grants to Licensee a non-exclusive, non-
transferable license to use and install Symmetrica and related materials described herein, including License 
Number and Password, on the number of central processing units specified for use with the License Number.

Licensee may copy the Registered version of Symmetrica, including License Number and Password, for back-up 



purposes only, for use as a replacement in the event the original is destroyed. Licensee may make any number 
of copies for such back-up purposes, provided that Licensee conspicuously and appropriately publishes on each 
such copy file a valid copyright notice as follows: “Copyright - 1996 Software Engineering, Inc.”

Licensee shall not distribute, assign, sublicense or otherwise transfer the registered License Number and 
Password to others, and this License Agreement shall automatically terminate in the event of any such transfer.

3.1 Description of Other Rights and Limitations

3.1 Licensee may not modify, reverse engineer, decompile, or disassemble Symmetrica, except and only to the 
extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

3.1 Symmetrica is licensed as a single product. Its component parts may not be separated for use on more than 
one computer.

3.1 Licensee may not copy, sublicense, assign, distribute or transfer Symmetrica, or any rights granted herein, 
except as expressly provided under this License Agreement. Any attempt otherwise to copy, sublicense, 
assign, distribute or transfer Symmetrica or such rights is void and your license to use Symmetrica under this 
License Agreement shall be automatically terminated. However, parties who have received Symmetrica from 
you with this License Agreement will not have their licenses terminated so long as such parties remain in full 
compliance with this License Agreement.

3.1 This License Agreement is effective until terminated, which Licensee may do at any time. This License 
Agreement will terminate if Licensee fails to fully comply with any of the terms and conditions of the License 
Agreement. Upon termination of this License Agreement for any reason, Licensee shall destroy the 
Symmetrica Program together with all copies, modifications and merged portions in any form. All provisions of
this License Agreement relating to disclaimers of warranties, limitation of liability, remedies, or damages, and 
SEI’s proprietary rights shall survive termination.

4.1 Copyright

All title and copyrights in and to Symmetrica (including but not limited to any images, photographs, animations, 
video, audio, music, text, and applets, incorporated into Symmetrica), the accompanying printed materials, if 
any, and all copies of Symmetrica, are owned exclusively by SEI.

5.1 U.S. Government Restricted Rights

Symmetrica and documentation is provided with RESTRICTED RIGHTS. The use, duplication, or disclosure by the 
Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and 
Computer Software clause at DFARS 52.227-7013, or subparagraphs (c)(1) and (2) of the Commercial Computer 
Software Restricted Rights at 48 CFR 52.227-19, as applicable. Manufacturer of Symmetrica is Software 
Engineering, Inc., 8352 S. Sunnyside Pl., Highlands Ranch, CO 80126

6.1 Disclaimer of Warranty

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY OR ANY 
WARRANTY AS TO PERFORMANCE. Because of the various hardware and software environments into which 
Symmetrica may be put, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. TO THE 
MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, SEI DISCLAIMS ALL WARRANTIES, EITHER EXPRESSED OR 
IMPLIED, WITH REGARD TO Symmetrica.

7.1 Limitation of Remedies

Because it is impossible for SEI to know the purposes for which you acquired Symmetrica or the uses to which 
you will put Symmetrica, Licensee assumes full responsibility for the selection of Symmetrica, and for its 
installation and use and the results of that use. ANY LIABILITY OF SEI WILL BE LIMITED EXCLUSIVELY TO PRODUCT
REPLACEMENT OR REFUND OF PURCHASE PRICE.

THESE ARE YOUR SOLE AND EXCLUSIVE REMEDIES for any and all claims that you may have against SEI arising 



out of or in connection with Symmetrica, whether made or suffered by you or a third party.

IN NO EVENT WILL SEI BE LIABLE TO YOU OR ANY OTHER PARTY FOR DIRECT, INDIRECT, GENERAL, SPECIAL, 
INCIDENTAL, CONSEQUENTIAL, EXEMPLARY OR OTHER DAMAGES ARISING FROM THE USE OF OR INABILITY TO 
USE Symmetrica, EVEN IF SEI HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. (Some states do not 
allow the exclusion or limitation of incidental or consequential damages, so the foregoing exclusion or limitation 
may not apply to you.) In no event shall SEI’s total liability exceed the amount you paid in license or registration 
fees for the right to use a single copy of Symmetrica. SEI’s software pricing reflects the allocation of risk and 
limitations on liability contained in this License Agreement.

8.1 General

8.1 This License Agreement is governed by the laws of the State of Colorado.

8.1 This License Agreement constitutes the parties’ entire Agreement, and a complete merger of all antecedent 
offers, counteroffers, negotiations and agreements.

8.1 This Agreement shall not be amended, except in writing signed by all parties or their authorized 
representatives.

8.1 In the event that a Court of competent jurisdiction enters judgment declaring any material provision or 
portion thereof of this Agreement invalid or unenforceable, the remainder of this Agreement shall remain in 
full force and effect.

8.1 In the event of a dispute concerning this License Agreement, the prevailing party in any litigation or 
arbitration arising out of or relating to this License Agreement shall be entitled to an award of its reasonable 
attorneys’ fees and costs.

LICENSEE ACKNOWLEDGES THAT IT HAS READ AND UNDERSTANDS THIS LICENSE AGREEMENT AND AGREES TO 
BE BOUND BY ITS TERMS. LICENSEE FURTHER AGREES THAT THIS LICENSE AGREEMENT IS THE COMPLETE AND 
EXCLUSIVE STATEMENT OF THE AGREEMENT BETWEEN LICENSEE AND SEI, AND SUPERSEDES ANY PROPOSAL OR 
PRIOR AGREEMENT, ORAL OR WRITTEN, AND ANY OTHER COMMUNICATIONS RELATING TO THE SUBJECT MATTER 
OF THIS AGREEMENT.

Symmetrica™ is a trademark of Software Engineering, Inc.



New Window
This menu item will make a new duplicate of the current window.



Cascade
This will cascade all windows currently opened.



Tile
This will tile all windows currently opened.



Arrange Icons
This will arrange the icons of the desktop.



Clean House
Cleaning house is way to free up system resources should you run short.

Resetting the Undo/Redo database information will eliminate all Undo and Redo references up to the current point. 
This does not turn the Undo/Redo function off, it simply clears out the current log and starts a new one. The 
information will continue to accumulate.

Discarding unreferenced symbols will clear from the symbol table all the extra symbol information that isn’t used in 
the current drawing. 

 By removing illogical elements, you clear the drawing of oddball pieces that get left behind by such things as 
accidental mouse clicks, etc.



Detail Gallery
The Detail Gallery is an area where you can store pieces of drawings for use at a later time. When Symmetrica 
loads, the Detail Gallery is hidden from view as seen below.

By clicking and dragging the bar to the right of the Tools tool bar, the Detail Gallery will be revealed.



Creating a new document

1 On the File menu, click New. (or click on the New button  located on the tool bar.)

Tip

n To name the new file, click the File menu, and then click Save As.



Opening a document

1 On the File menu, click Open. (or click on the Open button  located on the tool bar.)
2 In the Look In box, click the drive that contains the document you want to open.
3 Below the Look In box, click the folder that contains the document you want to open.
4 Click the document's name, or type it in the File Name box.

Tips

n If you don't see what you're looking for, click a different file type in the Files Of Type list.
n To open a document you opened recently, click its name at the bottom of the File menu.



Closing the current document

1 On the File menu, click Close.

Tip

n If the document has not been saved, Symmetrica will ask whether you wish to save the document or not.



Saving a document for the first time.

1 On the File menu, click Save or Save As. (or click on the Save button  located on the tool bar.)
2 Type in a file name.
3 Select the location where you want to save this file.
4 Click the Save button.



Saving changes to a document

1 On the File menu, click Save. (or click on the Save button

 on the tool bar.)

Tip

n To save an existing document with a new name, click Save As, and then type a new name in the File Name 
box.



Printing a document

1 On the File menu, click Print. (or click on the Print button  located on the tool bar.)
2 Select the desired printer, number of copies, etc. and click the OK button. 



Print Preview

To see how your document will look before you print it

1 On the File menu, click Print Preview.
2 Zoom in on sections of the drawing by clicking on the desired area.

Tip

n To return to the previous view from Print Preview, click the Close button.



Undoing/Redoing an action

Undo:

On the Edit menu, click Undo to back up one action. (or click on the Undo button  located on the tool bar.)
n The Undo file is kept for every action since the session began. 

Redo:

On the Edit menu, click Redo to move forward one action that was undone. (or click on the Redo button  
located on the tool bar.)



Copying information between documents

1 In the document that contains the information you want to copy, select the information by highlighting it.

2 On the Edit menu, click Copy. (or click on the Copy button  located on the tool bar.)
3 In the document where you want the information to appear, click the place where you want to put the 
information.

4 On the Edit menu, click Paste. (or click on the Paste button  located on the tool bar.)

Tips

n You can paste the information multiple times.
n Elements from Symmetrica will appear in scale in any other program.
n Paste places elements relative to the benchmark.



Deleting Elements

1 Select the element(s) you want to delete.
2 To remove elements so that you can place it in another part of the document, click Edit, and then click Cut. (or 

click on the Cut button  located on the tool bar.) 
3 To remove elements entirely from the document, press the DEL (Delete) key.

Tips

n To cancel a selection, click anywhere in the document.
n To undo a deletion, click Edit, and then click Undo.
n To select all the elements in a document, click Select, and then click All.



Creating an Arc

1 On the Tools menu, click Arc. (or click on the Arc button  located on the tool bar.)
2 Click the point on the drawing where you want the center of the arc to be located.
3 Click the point on the drawing where you want the starting point of the arc to be located.
4 Click the point on the drawing where you want the ending point of the arc to be located.

Tip

n Holding down the Alt key while clicking will enable Orthographic snap.
n Use the Input Box Tool Bar to enter specific points.



Creating a Circle

1 On the Tools menu, click Circle. (or click on the Circle button  located on the tool bar.)
2 Click the point on the drawing where you want the center of the circle to be located.
3 Click the point on the drawing where you want the perimeter of the circle to be located.



Creating a Line Segment

1 On the Tools menu, click Line Segment. (or click on the Line Segment button  located on the tool bar.)
2 Click the point on the drawing where you want the starting point to be located.
3 Click the point on the drawing where you want the ending point to be located.

Tip
n Holding down the Alt key while choosing the end point will enable Orthographic snap.



Creating a Polyline

1 On the Tools menu, click Polyline. (or click on the Polyline button  located on the tool bar.)
2 Click the point on the drawing where you want the starting point to be located.
3 Click the point on the drawing to place each successive point.

Tip

n Holding down the Alt key while choosing each point will enable Orthographic snap.



Creating a Rectangle

1 On the Tools menu, click Rectangle. (or click on the Rectangle button  located on the tool bar.)
2 Click the point on the drawing where you want the first corner of the rectangle to be located.
3 Click the point on the drawing where you want the opposite corner of the rectangle to be located.

Tip

n To create a square, hold down the Alt key while placing the opposite corner.



Moving the Benchmark

1 On the Tools menu, click Benchmark. (or click on the Benchmark button  located on the tool bar.)
2 Click the point on the drawing where you want to place the benchmark.



Creating a Group

1 Select the elements you want to make part of the group.

2 On the Actions menu, click Group. (or click on the Group The Selection button  located on the Actions 
Toolbar.)

Tip

n Right click on an element for a pop-up menu of actions.



Defining Element Properties

1 Click on the element in the drawing you want to check properties on.
2 On the Settings menu, click Properties.

Or

1 Double click on the element.

Or

1 Right click on the element.
2 Click on Properties from the menu that pops up.

Related Topics

n Global Properties
n Default Element Properties
n Elements



Defining Default Element Properties

1 On the settings menu, click Default Properties.
2 From the pop down menu, click on the element whose properties you want to set.
3 Enter the values desired.
4 Click the OK button.

Related Topics

What are Default Element Properties? 



Creating a Symbol

1 Select the elements you want to make part of the symbol.

2 On the Actions menu, click Create Symbol. (or click on the Create Symbol button  located on the Actions 
Toolbar)

4 On the Create Symbol dialog box that appears, type in a name for this symbol or choose from the list of 
default names.

5 Click the OK button.

Tips

n Be sure to have the benchmark placed correctly. It will become the insertion point for the new symbol.
n Right click on an element for a pop-up menu of actions.



Importing AutoCAD drawings

1 On the File menu, click Import.
2 In the Look In box, click the drive that contains the drawing you want to import.
3 Below the Look In box, click the folder that contains the drawing you want to import.
4 Click the drawing's name, or type it in the File Name box.
5 When the drawing is finished importing, click OK on the Import Status box.

Tip

n For a detailed description of the Import Status box, see Importing.



Exporting drawings to AutoCAD

1 On the File menu, click Export.
2 Type in a file name for this AutoCAD drawing.
3 Select the location where you want to save this file.
4 Click the Save button.

Tip

n For a detailed description of the Export Status box, see Exporting.



Creating a Text Box

1 On the Tools menu, click Text. (or click on the Text button  located on the Tools tool bar.)
2 Locate the first corner of the Text box.
3 Locate the second corner of the Text box.
4 In the Text Box Properties box, type in the text you want in the Text Box and define it’s properties.
5 Click the OK button.



Placing a Defined Symbol

1 On the Tools menu, click Symbol. (or click on the Symbol button  located on the Tools tool bar.)
2 Place the insertion point of the symbol by clicking the point on the drawing.
3 Edit the properties of the symbol and selected the name from the drop down list.

Tip

n Manually enter the coordinates in the input box to more accurately place the insertion point on the drawing.



Splitting Symbols

To split a symbol into it’s original elements

1 Select the symbol you want to split.
2 On the Actions menu, click on split and select symbol from the pop-up menu.



Splitting Polylines

To split a polyline into individual lines

1 Select the polyline you want to split.
2 On the Actions menu, click on split and select polyline from the pop-up menu.

Or

1 Right click on the polyline and select Split Polylines from the pop-up menu.



Splitting Groups

To split a group into it’s original elements

1 Select the group you want to split.
2 On the Actions menu, click on split and select Group from the pop-up menu. 

Or

1 Right click on the group and select Ungroup from the pop-up menu.



Duplicating Elements Across An Array
(New topic text goes here.)



Cleaning Up Intersections
(New topic text goes here.)



Selecting groups of elements
There are numerous ways of selecting various groups of elements. Select from the methods below:



All

To select all elements in a document

On the Select menu, click on All.

Tip

n The shortcut key is ‘F4’.



Every

To select every element of a specific type

1 On the Select menu, click on Every
2 From the pop-up menu, click on the type you want to select.



Line Crossing

To select line elements crossing a defined path

1 On the Select menu, click on Line Crossing
2 Click on the point of the drawing you want to have as the starting point, then on the point you want to have as

the ending point.
3 All line elements crossing the defined line are then selected.



Rectangular Crossing

To select all rectangular elements crossing a defined path

1 On the Select menu, click on Rectangular Crossing
2 Click on the point of the drawing you want to have as the starting point, then on the point you want to have as

the ending point.
3 All rectangles crossing your defined line are then selected.



Invert Selection

To deselect all currently selected elements and select all other elements

On the Select menu, click on Invert Selection



Deselect All

To deselect all elements

On the Select menu, click on Deselect All




