
Edit Grid - The grid area is a zoomed view of the image being edited, and the area where all drawing takes place.



Blend Color - Double clicking on any color inside the 256 color Palette window activates the Blend Color dialog.    
There is a slide scale for the RGB values, or numbers can be directly entered as text.



Tool Panel - Contains a powerful tool set for Microangelo GIFted.    The drawing tools color pixels based on the 
current dither setting, and are located left of the edit grid.



Global Palette - Used to select drawing colors when creating or editing an image. The palette is a pop up window that
can be moved anywhere on your desktop.    The palette offers a full range of colors for the image being edited.    To 
edit a color, double click on any ink well, and make changes in the Blend Color dialog.



Color A - Assigned to your left mouse button.    Choose a new color A by positioning the cursor over an ink well in the 
palette and clicking the left mouse button.



Color B - Assigned to your right mouse button.    Choose a new color B by positioning the cursor over an ink well in 
the palette and clicking the right mouse button. The 'B' (background) color is also used when the selection frame is 
used to cut or drag a selection to a new location.    The desired 'B' color must be chosen before making the selection.



Status Bar – At the bottom of the program window, it displays information and messages that provide feedback as 
you work.    It displays information about tool buttons and menu selections, and also provides information on the 
cursor location and movement during drawing operations.



Transparent Ink - It is standard for the 256 color palette.    When this ink is used, all pixels will display as transparent, 
for the image.    If transparent ink is not in a palette you open, just double click on any ink well, and set This color is 
transparent from the Blend Color dialog.



Paste Special - This will scale a GIF or bitmap image from the Clipboard (if an image is present).    You will also have 
the option of pasting into the grid as a New Selection, or paste into the grid in the current selection, an area defined 
by the selection frame.



New Selection – GIFted will paste the GIF or bitmap image into the grid area, without altering the size of the bitmap 
image.



Current Selection - Only available, if pixels hve been defined in the edit grid, by the selection frame tool.    
Microangelo will scale the size of the current image, into the area defined by the selection frame.



Selection Frame - Defines an area of the graphic that you can cut, copy, clear, or move.



Display and Stop Animation - The Preview window will display the GIF in action.    To cease the action click the stop 
button, then the Preview window will display the currently selected frame.    While the GIF is in action, frames cannot 
be added or deleted.



Global Speed Adjustment - The speed of the animation will increase if the global speed adjustment is moved to the 
right, and decrease if moved to the left.    All frames are affected by the global speed adjustment setting.    It is located 
directly below the Display and Stop Animation buttons, in the Preview window.



Preview Window (actual size) – The will display the file you are editing in real size.    When the Display button is 
clicked, the GIF will animate.    When the Stop button is clicked, the active frame in the edit grid will be displayed.



Nudge Left – The entire contents of the grid area will move one pixel to the left.    If a portion of the graphic is 
selected, then only that area will be nudged left.



Nudge Right – The entire contents of the grid area will move one pixel to the right.    If a portion of the graphic is 
selected, then only that area will be nudged right.



Nudge Up – The entire contents of the grid area will move one pixel up.    If a portion of the graphic is selected, then 
only that area will be nudged up.



Nudge Down – The entire contents of the grid area will move one pixel down.    If a portion of the graphic is selected, 
then only that area will be nudged down.



Flip Horizontal – The entire contents of the grid area will flip horizontally.    If a portion of the graphic is selected, then 
only that area will flip horizontally.



Flip Vertical – The entire contents of the grid area will flip vertically.    If a portion of the graphic is selected, then only 
that area will flip vertically.



Paint All – The tool currently selected will paint all pixels, when the mouse button is pressed.



Paint Odd – The tool currently selected will paint only odd numbered pixels, when the mouse button is pressed.



Paint Every Other – The tool currently selected will paint every other pixel, dependent on the pixel first painted when 
the mouse button is pressed.



Paint Even – The tool currently selected will paint only even numbered pixels, when the mouse button is pressed.



Preview window - A window that can be moved anywhere on your desktop.    You can choose whether you would like 
it displayed from the View menu.    It displays an actual size view of the image being edited.    When the Display 
button is clicked, the image will animate, when the Stop button is clicked, the currently selected frame will be 
displayed.



Zoom Level - When the Zoom Toggle is turned on, the edit grid will zoom to the level indicated.    The number 
corresponds to the size of the pixels in the edit grid.    (Example: when level is set at 9, each pixel represented in the 
grid, is actually 9 pixels in width and height).    The edit grid will not display, even if feature is turned on under the View
menu, when the zoom level is set at 5 or lower.



Zoom Toggle - When the Zoom Toggle is turned on, the edit grid will zoom to the level indicated.    If turned off, the 
image will display in the edit grid in actual size.    If zoom level is set to 5 or lower, the edit grid will not be displayed.



Frame Selector - Displays the active frame.    Control will appear when there is more than one frame in the file.



Frame Duration - It displays the speed for the currently selected frame.    Each frame can have a different speed, set 
with this control.    To set the speed for the entire file, use the Global Speed Adjustment button, located in the Preview 
window.    The duration unit is measured at 1/100 of a second.    (Example: a frame with a speed of 15, will run for 
15/100 of a second).



New Frame - Creates a new frame.



Color Pipette – It is used to select a color from the grid, or from the active palette.    Once selecting a color, the tool 
previously used before the color pipette will automatically be selected.    If you have a drawing tool selected and 
placed over the grid area, just press the SHIFT key, and the cursor will become the color pipette for choosing a new 
color.    Once a new color is chosen, the cursor will revert back to the drawing tool.



Color Eraser – It is used to easily switch pixels from one color to another.    If you hold down the button in the tool 
panel, a tool pan will be extended out over the grid area.    There will be various sizes to choose from.



Undo - GIFted will undo the last action taken in the grid area.



Redo - GIFted will redo the last undo action.



Select All - The entire grid will be selected with frame, regardless if the Zoom Level is on.



Select Edit Grid - The selection frame will appear only around the image active in the grid, based on the current zoom
setting.



Motion - A drop down control that allows you to choose from four selections to determine the direction your finished 
kiosk will rotate.



Range - A set of radio buttons that will create the rotating kiosk from the current frame to the next frame, or from all 
frames available in the file.



Transition - The number of frames to be inserted, between the current frames, to give the rotating kiosk effect.    Also 
here, is where the duration for the frames to be inserted is set.



Effect – A drop down combo control that allows you to choose from five different kiosk effects: Rotate Solid, Rotate 
Blinds, Slide, Cue Card, and Wipe.



Cut – The currently selected graphic will be cut to the Clipboard.    The current Color B selection will painted in the 
pixels left vacant by the cut action.



Copy – The currently selected graphic will be copied to the Clipboard.



Paste – The graphic currently on the Clipboard will be pasted into the edit grid.    If you would like to paste into a 
selected area, then use Paste Special from the Edit menu.



Save – This will save the file you are currently working with.



New – This will start a new file, where you can specify the width and height of the frame.



Open – This will open a saved GIF file.



Brush Tool Pan – When the mouse button is held down after selecting the tool, the tool pan will extend out with 
choices for the size brush to be used.



Color Eraser Tool Pan – When the mouse button is held down after selecting the tool, the tool pan will extend out with
choices for the size eraser to be used.



New Selection - The graphic will be pasted into the current frame.    If the source graphic is larger in size than the 
active frame, you will be prompted to scale the image down to a size that will fit in the edit grid.



Current Selection - The graphic will be scaled down to the size of the area selected in the edit grid.



From Image File - You may choose a specific GIF or bitmap file to be pasted into the edit grid.



From Clipboard - The graphic currently on the clipboard will be used for the paste action.



Optimizing Files with Microangelo GIFted

GIF File Optimization
One of the goals of the GIF (Graphics Interchange Format) file specification is to allow    image information to be 
stored in a compressed form.    This is extremely beneficial to GIF images and animations that are posted on web 
pages.    The smaller the file size, the quicker the web page will download and display to the user.

The GIF file specification, however, only supplies a “toolkit” for producing compact files.    The degree to which the
overall file size is minimized is completely dependent on the way that the toolkit is used.    Programs that are able 
to save single image GIF files are quite common, and the degree of compression that they achieve is quite close 
if not equal.    Utilities that save GIF animations are newer, less common, and quite often require the user to take 
manual actions to achieve any reductions in file size.

Microangelo GIFted performs many different optimization techniques automatically. It is able to consistently save 
GIF animations in smaller file sizes than any other utility that we are aware of.

“It’s Out of Your Hands, Now”
Microangelo GIFted does not provide any type of interface for the user to crop frames or select their disposal 
methods.    It is much easier for GIFted to find the smallest update rectangle and to analyze the changes 
throughout the animation and select the best disposal methods between frames.    Those are just a few of the 
steps that are performed to produce an ultra-compact file as a final result.    Frames are compared pixel by pixel, 
not just from one frame to the next, but throughout the entire animation.    Algorithms determine the best disposal 
methods to produce the smallest update areas.    And even when an animation does not define any transparent 
pixels, GIFted can use transparency within each frame’s update area to achieve higher levels of compression 
than that of conventional methods.    The result?    The artist is freed from the normal burdens of file optimization 
and allowed to concentrate on the artwork of the animation.    GIFted produces a more efficient and compact file 
than can be achieved by the user – even more compact than other GIF utilities.

How to Optimize
Optimizing GIF files with Microangelo GIFted is easy.    Simply select the “Save Optimized” command from the 
File menu, or select “Save As…” and choose the Optimized GIF option as the File Type.

When to Optimize
GIFted saves GIF animations in full frame by frame format unless directed to perform optimization.    This method 
takes much less time than the thorough analysis required for optimization.    We recommend using GIFted’s 
special optimization only when necessary to check an animation’s size during development and as the last step 
when publishing the animation.
_________________________________________________
{button ,AL(`relate_gifted_saving_files',0,"",)} Related Topics



Pencil Tool

1 Click the Pencil tool in the tool panel; or on the Tools menu select Drawing Tools.Pencil.
2 Move the Pencil to the place on the edit grid where you want to start drawing.
3 Click the left mouse button (for Color ‘A’) or the right button (for Color ‘B), and hold it down as you draw.
4 Release the mouse button.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Pencil tool to the current row or 

column.    If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
________________________________________
{button ,AL(`gifted_pencil_tool',0,"",)} Other Tools



Brush Tool

1 Click the Brush tool in the tool panel; or on the Tools menu select Drawing Tools.Brush.
2 From the tool pan that extends out over the edit grid, when tool button is held down with mouse cursor, select a 

shape representing the brush you want to draw with.    A highlight appears around the shape you have selected.
3 Move the cursor to the place on the edit grid where you want to start drawing.
4 Click the left mouse button (for Color ‘A’) or the right button (for Color ‘B’), and hold it down as you draw.
5 Release the mouse button.

Tip:
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_brush_tool',0,"",)} Other Tools



Flood Tool

1 Click the Flood tool in the tool panel; or on the Tools menu select Drawing Tools.Flood.
2 Move the cursor to the area you want to fill.
3 Click the left or right mouse button to flood with Color A or Color B, respectively.
________________________________________
{button ,AL(`gifted_flood_tool',0,"",)} Other Tools



Color Eraser

1 Click the Color Eraser in the tool panel; or on the Tools menu select Drawing Tools.Color Eraser.
2 From the tool pan that extends out over the grid area, when tool button is held down with mouse cursor, select a

shape representing the eraser you want to use.    A highlight appears around the shape you have selected.
3 Move the Eraser to the place on the image where you want to start editing.
4 Click the left mouse button to replace Color A with Color B.    Click the right mouse button to replace Color B with

Color A.

Tip:
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_color_eraser',0,"",)} Other Tools



Straight Line Tool

1 Click the Straight Line tool in the tool panel; or on the Tools menu select Drawing Tools.Straight Line.
2 Place the cursor at the starting point for the line.
3 Drag the cursor to where the line will end.    The origin and the X and Y components of the line will be displayed 

in the status bar
4 Release the mouse button to complete the drawing operation. 

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Straight Line tool to 45 degree 

angles.    If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
________________________________________
{button ,AL(`gifted_straight_line_tool',0,"",)} Other Tools



Rectangle Tool

1 Click the Rectangle tool in the tool panel; or on the Tools menu select Drawing Tools.Rectangle.
2 If not the active tool in the tool panel, left click on the tool button and hold down.    A tool pan will extend out over 

the edit grid, select the Rectangle tool.
3 Move the cursor to one corner of the rectangle.
4 Drag diagonally to the opposite corner.    The origin and size of the rectangle will be displayed at the far right of 

the status bar.
5 Release the mouse button to complete the drawing operation.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Rectangle tool to drawing perfect 

squares.    If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_rectangle_tool',0,"",)} Other Tools



Rectangle Tool (Filled)

1 Click the Rectangle (filled) tool in the tool panel; or on the Tools menu select Drawing Tools.Rectangle (Filled).
2 If not the active tool in the tool panel, left click on the tool button and hold down.    A tool pan will extend out over 

the edit grid, select the Rectangle (filled) tool.
3 Move the cursor to one corner of the rectangle.
4 Drag the cursor diagonally to the opposite corner.    The size of the rectangle will be displayed at the far right of 

the status bar.    (When the left mouse button is used to drag, the rectangle will be framed with Color A and filled 
with Color B.    Using the right mouse button reverses this operation - the rectangle will be framed with Color B 
and filled with Color A).

5 Release the mouse button to complete the drawing operation.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Rectangle tool to drawing perfect 

squares.    If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_rectangle_filled_tool',0,"",)} Other Tools



Rectangle Tool (Solid)

1 Click the Rectangle (solid) tool in the tool panel; or on the Tools menu select Drawing Tools.Rectangle (Solid).
2 If not the active tool in the tool panel, left click on the tool button and hold down.    A tool pan will extend out over 

the edit grid, select the Rectangle (solid) tool.
3 Move the cursor to one corner of the rectangle.
4 Drag the cursor diagonally to the opposite corner. The size of the rectangle will be displayed at the far right of 

the status bar.    (When the left mouse button is used to drag, the rectangle will be drawn with Color A.    Using 
the right mouse button draws the rectangle using Color B).

5 Release the mouse button.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Rectangle tool to drawing perfect 

squares.    If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_rectangle_solid_tool',0,"",)} Other Tools



Color Pipette

1 Click the Color pipette tool in the tool panel; or on the Tools menu select Drawing Tools.Color Pipette 
2 Move the cursor over the pixel which contains the desired Color A or Color B.
3 Click the left mouse button to replace Color A or the right mouse button to replace Color B.    The color is 

updated and the cursor returns to the prior drawing tool.

Tip:
· Press the SHIFT key anytime before starting to draw with any tool, and cursor will become the color pipette, until

key is released.
________________________________________
{button ,AL(`gifted_color_pipette',0,"",)} Other Tools



Selection Frame

1 Click the Selection tool in the tool panel; or on the Tools menu select Drawing Tools.Selection Frame.
2 Move the cursor to one corner of the area that you want to select.
3 Drag the cursor to the opposite corner of the area you want to select. A rectangle shows which pixels will be 

selected. All pixels within the rectangle, including those "under the rectangle," are included in the selection.    
The size of the area selected will be displayed at the far right of the status bar.

4 Release the mouse button to complete the select operation. A highlighted border will enclose the selected area. 
This area may now be dragged to any other location in the edit grid.    It may also be operated on using the Cut 
or Copy editing commands, or the Nudge/Flip commands.

________________________________________
{button ,AL(`gifted_selection_frame',0,"",)} Other Tools

{button ,JI(`Muagif.hlp>GIFstu',`gifted_selection_frame_info')} Selection Frame Information



Ellipse Tool

1 Click the Ellipse tool in the tool panel; or on the Tools menu select Drawing Tools.Ellipse.
2 If not the active tool in the tool panel, left click on the tool button and hold down.    A tool pan will extend out over 

the edit grid, select the Ellipse tool.
3 Move the cursor to one corner of the bounding rectangular area that will contain the ellipse.
4 Drag diagonally to the opposite corner.
5 Release the mouse button to complete the drawing operation.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Ellipse tool to drawing perfect circles. 

If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_ellipse_tool',0,"",)} Other Tools



Ellipse Tool (Filled)

1 Click the Ellipse tool in the tool panel; or on the Tools menu select Drawing Tools.Ellipse (Filled).
2 If not the active tool in the tool panel, left click on the tool button and hold down.    A tool pan will extend out over 

the edit grid, select the Ellipse (filled) tool.
3 Move the cursor to one corner of the bounding rectangular area that will contain the ellipse.
4 Drag diagonally to the opposite corner.    (When the left mouse button is used to drag, the ellipse will be framed 

with Color A and filled with Color B.    When the right mouse button is used this operation is reversed - the ellipse
will be framed with Color B, and filled with Color A).

5 Release the mouse button to complete the drawing operation.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Ellipse tool to drawing perfect circles. 

If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_ellipse_filled_tool',0,"",)} Other Tools



Ellipse Tool (Solid)

1 Click the Ellipse tool in the tool panel; or on the Tools menu select Drawing Tools.Ellipse (Solid).
2 If not the active tool in the tool panel, left click on the tool button and hold down.    A tool pan will extend out over 

the edit grid, select the Ellipse (solid) tool.
3 Move the cursor to one corner of the bounding rectangular area that will contain the ellipse.
4 Drag the cursor diagonally to the opposite corner.    (When the left mouse button is used to drag, the ellipse will 

be drawn using Color A.    When the right mouse button is used, it will be drawn with Color B).
5 Release the mouse button to complete the drawing operation.

Tip:
· Once you have started drawing, pressing either SHIFT key will restrict the Ellipse tool to drawing perfect circles. 

If you press the SHIFT key before drawing begins, the cursor will change to the color pipette tool.
· Any tool that has an arrow, in the top right corner of its button, signifies that there is either a choice of shape or 

size.    Hold the left mouse button down, and the tool pan will extend out with choices.
________________________________________
{button ,AL(`gifted_ ellipse_solid_tool',0,"",)} Other Tools



Color Locator

1 Click the Color locator tool in the tool panel; or on the Tools menu select Drawing Tools.Color Locator.
2 Click a cell in the grid area or the color well in the color box that contains the color to be located.    The ink well 

will blink in the palette and in all cells in the edit grid area that contain the color.
________________________________________
{button ,AL(`gifted_ color_locator',0,"",)} Other Tools



Text Tool

1 Click the Text tool button in the tool panel; or on the Tools menu select Drawing Tools.Text.
2 The cursor will be placed in the Add Text dialog (see Note: below).
3 Type the characters to be added to the frame.    As each character is typed, the text block in the edit grid will be 

updated.    The text block will have the same properties as a pasted graphic.
4 To change the font used, click the Font button.    You may choose the font, style, and size.    Click the Apply 

button in the Font dialog, and the text block in the edit grid will be updated with new selections.
5 Once typing is complete, you can place the cursor over the edit grid to move the text block to the desired spot in

the frame.
6 Once a new tool is selected, the Add Text dialog will no longer appear, and the text block will become anchored 

in the frame.

Note:
· The currently selected Color A will be used for the color of the text.    The currently selected Color B will be the 

color of the background the text is added to.
________________________________________
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Color B Information



Microangelo GIFted Basics
To help you get more familiar with Microangelo GIFted, just click on a topic listed below.

Tool Bar 
Tool Panel and Preview Window 
Initializing the Color Palette
Color B    The Color B selection has bearing on how different features and tools operate.
Selection Frame Information    
_______________________________________________________________
{button ,AL(`relate_gifted_introduction',0,"",)} Related Topics



General Rules for Operating the Tools

Microangelo GIFted will initialize its program window, based on a minimum size for a New file, and will adjust itself in 
size by adding horizontal/vertical scroll bars, if the saved file is larger than the present grid area.    Click the View 
menu to control the display of features including the tool and status bar.

Freehand tools

Pressing the left or right button in the edit area performs drawing with freehand tools (Pencil, Brush, and Color 
Eraser).    Drawing continues as the mouse is moved until the mouse button is released.

Precision tools

Pressing the left or right mouse button and dragging the mouse with the button depressed performs drawing with 
precision tools (Line, Rectangle, and Ellipse tools).    A line image of the potential figure is displayed in the grid area 
and in the actual size image in the preview window as the drawing action is performed.    Releasing the mouse button 
completes the paint operation and updates the frame image.

Flood tool

To paint using the flood tool, press the left or right mouse button over a color cell in the grid area.    The pixels and all 
adjacent pixels of the same color will be filled.    The operation continues until the flood is completely bounded by 
different color pixels.

Selection frame

The selection frame works very much like the rectangle tool.    Press the left mouse button and drag to select areas of
the image.    A selected area can be cut, copied or moved to a different location.    You can also paste into the selected
area using the Paste Special selection on the Edit menu.    
Under the Edit menu there is Select Grid and Select All menu items.    When Select All is chosen, the entire grid will 
be selected with frame, regardless if the Zoom Level is on.    When Select Edit Grid is chosen, the selection frame will
appear only around the image active in the grid, based on the current zoom setting.
_______________________________________________________________
{button ,AL(`gifted_tools_rules',0,"",)} Related Topics



Microangelo GIFted Toolbar Basics

Click on an area of the graphic and either a definition, step by step, or important information about a feature will be 
displayed.    To show or hide the tool bar, on the View menu, click Tool Bar.

_______________________________________________________________
{button ,AL(`gifted_toolbar_basics',0,"",)} Related Topics



GIFted Tool Panel and Preview Window Basics

Click on an area of the graphic and either a definition, step by step, or important information about a feature will be 
displayed.

_______________________________________________________________
{button ,AL(`gifted_tools_preview',0,"",)} Related Topics



Step 1: Selecting grid size of frame

1 Click New button, or select New from the File menu.
2 From the New File dialog, make the width and height 50.
3 Grid will reset with new size.    Turn on the Zoom Toggle control, and set Zoom Level to 6.

________________________________________
Step 2



Step 2: Importing a GIF or bitmap as a frame

1 From the Edit menu select Import.
2 Change the Files of Type field to Bitmap Images.
3 From the directory where the program is installed, select Tutorial 1.bmp.
4 From the tool bar, click the New Frame button, or select New Frame from the Edit menu.
5 From the Insert New Frames dialog, click OK (default settings for dialog do not need to be changed).    Frame 2 

will be created, and the contents of Frame 1 will be displayed.
6 From the Edit menu, select Import Bitmap.
7 From the directory where the program is installed, select Tutorial 2.bmp.

________________________________________
Step 3



Step 3: Changing colors of areas inside a frame

1 From the Frame Selector, choose Frame 1.
2 From the Tool Panel, click the Color Pipette tool.
3 With the left mouse button, click on the orange color, in the grid, used as background.
4 From the palette, click with the right mouse button on the transparent ink well.
5 From the Tool Panel, click the Color Eraser tool and hold down the button, choose the largest size (last 

selection).
6 The cursor will change to a viewport.    Move the cursor over the grid area, and hold down the left mouse button 

and drag over the grid until the orange color is changed to the transparent color.
7 Select Frame 2, and repeat steps 3-6.

________________________________________
Step 4



Step 4: Moving a graphic in a frame

1 Select Frame 2.
2 Click the Flip Horizontal button from the tool bar (entire frame will be flipped horizontally).
3 Click the Nudge Down button from the tool bar once (entire frame will get moved one pixel down).
4 Click the Nudge Left button from the tool bar once (entire frame will get moved to the left one pixel).

Note:

· Nudge buttons affect entire frame, unless a portion is selected with the selection frame from the tool panel.
· When pasting in a graphic from the Clipboard, the Nudge buttons will only affect the area within the selection 

frame.
· When nudging a graphic, the area vacated by the nudge will be replaced by the current Color B.
________________________________________
Step 5



Step 5: Set duration of playing speed, and save file

1 In the Preview window, click the Display Animation button (if Preview window is not visible, select Preview 
window from the View menu).

2 In the Preview window, click and drag the Global Speed Adjustment to the right to shorten the length of playing 
time; or move it to the left to increase the length of playing time for all frames in the file.

3 Once speed is set, click the Stop Animation button.
4 From the File menu select Save As, name file and click Save.

Tip:

· You can adjust the speed of each frame individually by selecting the frame, then editing the number in the 
Frame Duration control.

________________________________________
Back to Step 1



Microangelo GIFted Colors and Color Palettes

Colors and Color Palettes

The tables that contain the actual red, green, and blue intensities of colors used in computer graphics are often 
referred to as palettes.    Microangelo GIFted displays the current color table in its Palette window in 256 different 
ink wells of colors that can be used to paint and draw with.

Colors and color palettes play a significant role in the development of an animated GIF.    Selecting a palette of 
colors that is most appropriate for your work BEFORE you begin developing an animation is crucial to both the 
quality of your results and the level of effort you will expend editing new colors.    GIFted allows several options 
that you can use to initialize the palette of colors for an animation.    These are described below in, “Initializing the 
Color Palette”.

To develop high-quality animations, it’s important to understand a few limitations that are imposed on the use of 
color by the Graphics Interchange Format (GIF) file specification and also by GIFted itself.

The GIF specification allows for a maximum of 256 colors to appear within any single image.    It allows one of the 
256 color entries to be designated as being “transparent”.    Greater color depths, often referred to as “high color” 
or “true color”, are not possible within a GIF image.

The GIF specification allows a file that contains multiple images (such as a GIF animation) to contain more than 
one color palette.    The first color palette that appears in the file is the global palette.    The colors defined in the 
global palette are used for every image in the GIF file.    The exception to this is called a local palette.    Any image 
in a GIF file may be preceded by a color table of its own.    This color palette overrides the global palette and is 
used only for the frame that immediately follows.

Going Global

Microangelo GIFted is not designed to incorporate multiple color palettes within GIF animations.    For this reason,
animations produced by GIFted are limited to a maximum of 256 different colors.    One of the primary goals of 
GIFted is to produce animations that provide maximum performance, optimized update areas and reduced file 
sizes.    Local color palettes are in direct conflict with maximized performance and reduced file size.    Another 
significant and somewhat related goal of GIFted is to provide painting tools to allow users to create animations 
within the program itself.    In most instances, 256 colors should provide an adequate availability of color for this 
purpose.

Animations that require multiple color palettes are often composed of imported photos or graphics.    In these 
instances we recommend using the graphics utility of your choice together with a GIF engineering tool such as 
Microsoft® GIF Animator.

In most cases, we recommend that you reserve one of these entries to be defined as transparent, even when an 
animation does not use transparency.    The reason for this is because GIFted can achieve higher levels of 
compression between frames of the animation when allowed to substitute transparent color values across areas 
of the update area that do not change between frames.    The exception to this, when it isn’t important to reserve a
color entry for transparent, is when the pixels in the animation always change color between each frame.    An 
example of this would be the presentation of still image “photos” that contain various different color patterns by 
nature.

Browsers and Color Palettes

It is important to be aware that other users’ software and hardware may cause your animation to appear 
differently to them than as you designed it.    Some computer video displays are limited to 256 colors.    Some 
video display drivers are limited to 256 colors.    If either of these cases is true, the software that is displaying the 
animation (perhaps a web browser) will be limited to 256 colors.    It will not be possible to provide the animation 
with all 256 specific colors that it desires.

Complicating matters further, if a computer’s hardware or software does not allow it to achieve full 24-bit color 
depth (8 pixels each for red, green and blue), it will probably not be able to display the exact RGB values that are 
defined in an image’s color table.



Due to anomalies like these, an overwhelming majority of browsers always include a standard 236 colors in their 
active color palette.    These color values are often referred to as the “non-dithering” browser color values because
they are guaranteed to be available across all popular hardware and software platforms.    This means that the 
software will never attempt to translate an area of an unavailable color into patterns of two or more different colors
to approximate the original.    When you use non-dithering color values you can be assured that the image will 
appear to everyone else exactly as it was designed.

How significant these factors are to your animations depend on several criteria.    Who will be your audience?    If 
you are developing a web site to attract as wide an audience as possible, then the non-dithering color values may
play a significant role in your artwork.    

Another item you may want to consider is that almost all new hardware and software are able to support high 
color depths very well.    If you’re creating web content for a clip art retailer on the Internet, you may be able to 
depend on your audience’s ability to display good color depth.

Initializing the Color Palette

Always initialize the color palette with an available array of colors most appropriate for your work whenever you 
begin a new animation.    GIFted initializes the color palette to the default palette file (stored in “muagif.pal”) 
whenever the program starts and when a new file is opened.    You can initialize the palette to a different set of 
colors from another palette (*.pal) file, or from a GIF or bitmap image on your computer.    Select Open from the 
Palette menu and choose the Palette or Image in the file type to locate the source you want to use.
If you plan on importing an image into your animation that you want to appear in the highest possible quality, you 
may want to consider initializing the palette using the image file you will be importing.    However if you plan to 
create the animation with the drawing tools within GIFted, choosing the Balanced or Non-dithering palettes 
provided with GIFted may be good choices.

The Non-dithering Color Palette

GIFted includes a color palette that contains all 236 non-dithering colors organized by color hue and intensity.    
Some colors such as pure red, blue, cyan, and others are duplicated along with the four non-dithering grays at the
end of the palette for easy access.    The colors in this palette file are always available on all hardware and 
software platforms capable of displaying at least 256 colors. 

Editing the Color Palette

You can change the color of ink in any well of the Palette window by double clicking on the color in the well 
(unless the Color Locator tool is active).    Each ink well represents an entry in the global color palette.    Changing 
the color in any ink well will also change the color of all pixels previously painted with ink from that well.

Any ink well may be designated as a transparent color.    Transparency can be used to show through the 
background that the animation is displayed on top of.    Only one ink well may be designated as transparent.    To 
select a different well as transparent, first reset the color in the current transparent well to a normal color.
_______________________________________________________________
{button ,AL(`relate_gifted_color_palette',0,`',`')} Related Topics 



How Colors are used by the Drawing Tools

Drawing

The left mouse button is used with most of the drawing tools to paint using the primary Color A, and the right 
mouse button is used to paint using the secondary Color B.    The Pencil, Line, Brush, Flood, Rectangle, and 
Ellipse functions operate in this manner.

Color Eraser

The 'A' and 'B' colors are used to specify the foreground and background colors for the color eraser.    The tool will
change the 'A' (foreground) color to the 'B' (background) color.    Using the right mouse button instead of the left 
will reverse this operation, changing any 'B' color under the Eraser to the 'A' color.

Selection frame

The 'B' (background) color is also used when the selection frame is used to cut or drag a selection to a new 
location.    The desired 'B' color must be chosen before making the selection.
When a cut operation is performed, or the selection is dragged to a new location, the area the image previously 
occupied is filled with the 'B' color.
Select either the Transparent or Opaque color ‘B’ option from the Tools menu when a paste or drag operation 
takes place.    When a selection is dragged and the Transparent Color B option is in effect, any area in the 
selection that matches the 'B' color will be treated as a transparent area during the drag.
_______________________________________________________________
{button ,AL(`relate_gifted_affect',0,"",)} Related Topics



Initializing the Color Palette

Always initialize the color palette with an available array of colors most appropriate for your work whenever you 
begin a new animation.    GIFted initializes the color palette to the default palette file (stored in “muagif.pal”) 
whenever the program starts and when a new file is opened.    You can initialize the palette to a different set of 
colors from another palette (*.pal) file, or from a GIF or bitmap image on your computer.    Select Open from the 
Palette menu and choose the Palette or Image in the file type to locate the source you want to use.
If you plan on importing an image into your animation that you want to appear in the highest possible quality, you 
may want to consider initializing the palette using the image file you will be importing.    However if you plan to 
create the animation with the drawing tools within GIFted, choosing the Balanced or Non-dithering palettes 
provided with GIFted may be good choices.
_______________________________________________________________
{button ,AL(`relate_gifted_initializing_basics',0,"",)} More Basics        
{button ,JI(`Muagif.hlp>GIFstu',`gifted_colors_color_palette')} More on Palettes



Open and Edit an Animated GIF file

1 Select Open from the File menu, or click the Open button from the tool bar.
2 Browse to the folder that contains the file, and double click on it.
3 Microangelo GIFted will open the image, and place it in the edit grid area.

Tip:
· If you plan on importing an image into your animation that you want to appear in the highest possible quality, you

may want to consider initializing the palette using the image file you will be importing.    
· If you plan to create the animation with the drawing tools within GIFted, choosing the Balanced or Non-dithering 

palettes provided with GIFted may be good choices.
· You can drag and drop a GIF or bitmap onto the grid area (from Windows Explorer or your desktop), and GIFted

will treat the file if you had used the Import function from the Edit menu.
________________________________________
{button ,AL(`gifted_open_and_edit_gif',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Insert a New Frame

1 Select New Frame from the Edit menu, or click the New Frame button from the tool bar.
2 You will be prompted to choose the number of frames, the order, and contents of the new frame.
3 Microangelo GIFted will paste selections into the new frame for editing.

________________________________________
{button ,AL(`gifted_insert_new_frame',0,"",)} Related Topics



Remove a Frame

1 Select Remove Frame from the Edit menu, or click the Remove Frame button from the tool bar.
2 The active frame will be removed from file.

________________________________________
{button ,AL(`gifted_remove_frame',0,"",)} Related Topics



Import GIF or Bitmap Image to Create Frame

1 Select Open Palette from the Palette menu (see first Tip: below).
2 Select Import... from the Edit menu.
3 The Files of Type field defaults to GIF Images (you may change it to Bitmap Images if necessary).
4 Browse to the folder that contains the GIF or Bitmap image.
5 Select the file, and click Open.
6 The GIF or Bitmap image will be pasted into the current frame.

Tip:
· When importing an image into your animation that you want to appear in the highest possible quality, you may 

want to consider initializing the palette using the image file you will be importing.    
· You can drag and drop a GIF or bitmap onto the grid area, and GIFted will treat the file if you had used the 

Import function from the Edit menu.
· You may also convert a GIF or Bitmap file into a frame, by pasting it to the Clipboard, and using the Paste 

Special selection from the Edit menu.
_______________________________________
{button ,AL(`gifted_frame_from_bitmap',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Open a Color Palette

1 Click Open Palette from the Palette menu.
2 Browse to the folder where the palette or image file is stored.
3 Select the palette or file and click Open.
4 If an image file was selected, the palette will be reset to the colors used in that file.

Note:
· An ink well in the palette that is designated as transparent will have a computer screen filled with a bluish color.   

Only one ink well at a time may be set to transparent ink.
· Changing the color in any ink well will also change the color of all pixels previously painted with ink from that 

well.
________________________________________
{button ,AL(`gifted_open_palette',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Save a Color Palette

1 Edit colors in the active palette, until all changes to colors are complete.
2 Select Save Palette from the Palette menu.
3 Name the palette, and choose the folder in which it is to be saved.

Note:
· If a transparent color is already defined in the palette, the selection will be grayed out in the Blend Color dialog.   

The transparent ink well will have a computer screen filled with a bluish color.
· Changing the color in any ink well will also change the color of all pixels previously painted with ink from that 

well.
________________________________________
{button ,AL(`gifted_save_palette',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Edit a Color in the Palette

1 Double click on the color in the palette to be edited.
2 From the Blend Color dialog, make desired changes.    Changing the color in any ink well will also change the 

color of all pixels previously painted with ink from that well.
3 Click OK to return to editing the active frame.

Note:
· If a transparent color is already defined in the palette, the selection will be grayed out in the Blend Color dialog.   

The transparent ink well will have a computer screen filled with a bluish color.
· When the Color Locator tool is active, editing a color is not possible.

________________________________________
{button ,AL(`gifted_edit_color',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Create an Animated GIF File

1 Select New from the File menu, or click the New button from the tool bar, then choose the size of file (Select the 
Palette Information button at the bottom of the window for important information about starting a new file).

2 Microangelo GIFted will open with a blank grid area to start creating a new animated GIF.
3 Once drawing has been completed, click Save As from the File menu.

Tip:
· You can drag and drop a GIF or bitmap onto the grid area, and GIFted will treat the file if you had used the 

Import function from the Edit menu.
________________________________________
{button ,AL(`gifted_create_gif',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Create Transparent Color in Palette

1 Double click on an unused color in palette (if you choose a color used in current frame, those pixels will change 
to transparent).

2 From the Blend Color dialog select, This color is transparent.
3 Palette will display ink well with a computer screen filled in blue.    When this ink is used, the transparent 

property is applied.

Note:
· If a transparent color is already defined in the palette, the selection will be grayed out in the Blend Color dialog.   

The transparent ink well will have a computer screen filled with a bluish color.
· Only one ink well may be designated as transparent.    To select a different well as transparent, first reset the 

color in the current transparent well to a normal color.
· Changing the color in any ink well will also change the color of all pixels previously painted with ink from that 

well.
________________________________________
{button ,AL(`gifted_transparent_color',0,"",)} Related Topics

{button ,JI(`Muagif.hlp>GIFstu',`gifted_initializing_color_palette')} Palette Information



Edit the Speed of a Frame

1 Select frame from the Frame Selector control with your mouse.
2 Select the text in the Frame Duration control.
3 Change the speed by typing a new number.

Note:
· Using the Global Speed Adjustment will adjust the speed of all frames in the file.

_______________________________________
{button ,AL(`gifted_edit_speed',0,"",)} Related Topics



Create Animated Kiosk Transitions
Microangelo GIFted can create animated transitions between existing frames of your workspace.    These are 
referred to as Kiosk transitions because they are often used as tools to convey multiple messages to the viewer.

1 Create a file that has at least two frames.
2 Select Save from File menu.    This will give you a place to start from again, when experimenting with the 

different kiosk effects (see Note: below).
3 From the Tools menu select Kiosk Transition.
4 From the Kiosk Transition dialog, choose the Effect,    Motion, Range, and Transition.
5 Select OK, and GIFted will begin to create the proper frames to be added for the Kiosk effect.
6 Once Transition is complete, click the Display and Stop Animation buttons to preview the Kiosk.    Once editing is

complete, select Save As from the File menu.

Note:
· There is no Undo capability for a Kiosk transition once it is performed.    To avoid having to manually delete 

frames generated by an undesired transition, it is highly recommended that you save any changes to your work 
before experimenting with transitions.

________________________________________
{button ,AL(`gifted_create_rotating_kiosk',0,"",)} Related Topics



      Color B Information

The current settings of Color A and Color B are displayed at the right edge of the program window just above the 
edit grid.    In the graphic above, Color A is set to black ink and Color B is set to transparent.    Color B is assigned 
to your right mouse button when GIFted’s drawing tools are used.

Selection Frame
The 'B' (background) color is also used when the selection frame is used to cut or drag a selection to a new 
location.    The desired Color B must be chosen before making the selection.
When a cut operation is performed, or the selection is dragged to a new location, the area the image previously 
occupied is filled with Color B.

Text Tool
Text is created using Color A as the text color and Color B as the background.

Color A and B can be changed at any time while text is being created.    Once typing is complete, place the cursor 
over the edit grid to move the text block to the desired place in the frame.    For more information on the paste and
drag operation of a graphic, and its relation to Color B, please see the paragraph below.

Color Eraser
Color A and Color B are used to specify the foreground and background colors for the color eraser.    The tool will 
change the 'A' (foreground) color to the 'B' (background) color.    Using the right mouse button instead of the left 
will reverse this operation, changing any 'B' color under the Eraser to the 'A' color.

Paste and Drag
Select either the Transparent or Opaque color ‘B’ option from the Paste and Drag selection on the Tools menu.    
When a selection is dragged and the Color B Is Transparent option is in effect, any area in the selection that 
matches the 'B' color will be treated as a transparent area during the drag.

________________________________________
{button ,AL(`gifted_color_b',0,"",)} More Basics



Selection Frame Information

Color B
The 'B' (background) color is also used when the selection frame is used to cut or drag a selection to a new 
location.    The desired 'B' color must be chosen before making the selection.
When a cut operation is performed, or the selection is dragged to a new location, the area the image previously 
occupied is filled with the 'B' color.

Paste Special
Select an area in the edit grid with the selection frame.    Select Paste Special from the Edit menu, and choose to 
paste into the current selection.    You can choose to paste from an image file, or from a graphic already on the 
Clipboard.    This procedure will scale the size of the graphic, into the area defined by the selection frame.

Text Tool
As characters are updated in the text block in the edit grid, the selection frame will bound it.    Once typing is 
complete, the text block can be moved to the desired place in the frame.    In this operation the selection frame 
around the text block will signify that it will be treated as if it were a pasted graphic.    Once a new tool is selected, 
the selection frame will no longer appear, as the graphic will be anchored in the edit grid.

Nudge/Flip Buttons
If an area is selected, the nudge and flip buttons will only affect the area within the selection.    If the selection 
frame is not used the nudge and flip buttons will affect the entire edit grid.

________________________________________
{button ,AL(`gifted_selection_frame_link',0,"",)} More Basics  

{button ,JI(`Muagif.hlp>Proceed',`gifted_tools_selection_frame')} Selection Frame (step-by-step)



Using Paste Special
The Paste Special operation provides flexibility when pasting.    The paste source can be the clipboard or an 
image file, and can be pasted as a new selection or resized into the current select area.

1 Use selection frame, to select an area on the edit grid (see Tip: below).
2 From the Edit menu select Paste Special.
3 In the Paste Control Panel dialog you will be prompted to choose either pasting a graphic From Clipboard, or 

From Image File (GIF or bitmap).
4 You will also be prompted to choose to paste Into Current Selection, or as a New Selection.

Tip:
· You can automatically select areas by using Select All or Select Edit Grid from the Edit menu.
· You can import graphics from a GIF or bitmap file.    Select “Import GIF or Bitmap image to create frame” 

from Related Topics.
________________________________________
{button ,AL(`gifted_paste_special_relate',0,"",)} Related Topics




