Pattern Renamer

Pattern Renamer 1.2.4

Purpose

Pattern renamer is a mass renaming plugin suitable to P3dO Explorer 1.7.2 and above.

Transformations apply in the same order as the screen: Replacement, croping, insertion.

Features

Selected files | All files Status of files which the plugin should ask from P3dO's current file list.
(pro) P3dO returns all files, in the free version it doesn't take subfolders files into account.
Filter A user defined filter to reduce the renaming to matching files. The filter can contain wildcard characters (* and ?). In the pattern string * matches any sequence of characters (zero or more), ? matches any single character.
Poser tip: wildcar filters will automatically rename attached .RSR and/or .PNG to a Poser library file. On the contrary an extension filter - i.e *.RSR - will have no effect on Poser library parent files. .RSR are considered attached to Poser library files but not the contrary.

Replace String to be replaced followed by replacing string (with). If the same string is encountered twice in the file name, only the first one is replaced.
The replace with filed can be empty in which case replacement is an erasement.
Loop replacement Replace all occurences of the replace string in file name.
Left crop Number of characters to crop on the left side of the replaced string.
Right crop Number of characters to crop on the right side of the replaced string.
Insert before A string added at the beginning of the replaced string.
Insert after A string added at the end of the replaced string.

Name | Extension | Whole The part of the file name to rename.
nota: Be carefull when renaming an extension. Windows heavily relies on extensions and changing a file extension is generaly a mistake. But changing an extension from i.e. .jpeg to .jpg is not because those two extensions have the same internal file format. The rename extension of Pattern Renamer was designed with this in mind.

Reset Restore all settings to default (empties the screen fields).