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Welcome to Dr. DivX 
The Dr. will see you now. 
 

Brought to you by the same people that created the revolutionary DivX video codec, Dr. DivX™ is the first and 

only official DivX Encoding application. Just as DivX and DivX Pro have enabled anyone, anywhere to watch and 

distribute great looking digital video, Dr. DivX now makes the act of creating DivX video as easy as the act of 

watching it. 

How is that possible, you ask? Well, as the only encoding application built specifically for DivX video, Dr. DivX 

lets you create an awesome DivX video from almost any source right on your computer in just three easy steps. 

So now you can take that great video of your wedding, birthday party, field trip, choral recital, whatever, encode 

into DivX in a matter of seconds and instantly post it online, burn it to a CD or e-mail it to all your friends who’ve 

just been dying to see what color sweater you wore on your last birthday.  

Dr. DivX was designed to enable anyone, from the most grizzled encoding veteran to the freshest-faced video 

newbie, to create great-looking DivX video without breaking a sweat or furrowing a brow. Thanks to Dr. DivX, 

what was once a complicated and time-consuming process for compressing and creating high quality video can 

now be completed with a few simple steps that take only a matter of seconds.  

Perhaps the most important breakthrough achieved by Dr. DivX is its remarkable ease of use. Unlike other 

encoding applications that require hands -on knowledge of video encoding techniques and video technology, Dr. 

DivX was designed to allow the average user to dive right into the act of video encoding with no prior experience 

or expertise. Dr. DivX is so easy to use in large part because it was created by the same team that built the 

original DivX video compression technology. The encoding application is tightly integrated with the codec at 

every level, allowing you to simply plug in a video file and let the Dr. DivX workflow wizard take care of the rest.  

Many complicated video encoding applications were built only for video professionals and therefore focus on 

video editing functionality at the expense of superior compression, video quality and ease-of-use. With Dr. DivX, 

compression and ease-of-use were the driving factors behind the product at every stage of development.  

 
The end result is a lean, mean encoding application that lets anyone create great-looking DivX video without 

getting lost in a maze of configuration options and complex functionality. Dr. DivX intuitively selects and saves 



the best settings and features for each encode, allowing the user to create the best possible DivX video file 

without lifting a finger. (OK, you do actually have to lift a finger to click your mouse, but that’s pretty much it.) This 

allows  the professional and non-professional user alike to quickly and easily create DivX video files without 

sacrificing the great visual quality for which DivX is justly famous. 

 
Some features of Dr. DivX : 

 
•  Various input Video formats: Dr. DivX encodes multiple popular video formats - It also supports script 

files  such as .AviSynth format files 

•  Various Audio inputs: Choice to multiplex audio tracks from an external video or .mp3 or .wav audio 

file into the output video file 

• Modify Video Properties: Video settings such as aspect ratio, resize and bit rate can be easily 

modified using Dr. DivX 

• Modify Audio Properties: Ability to change the bit rate (in Kbps) and sampling rate (in KHz) 

• Apply Filter effects: Ability to apply third-party filters to get the desired visual effects for a video file 

•  Batch Encoding: Multiple jobs can be encoded using Dr. DivX - Simply choose the input video source, 

chose your output profile and output file name and sit back and relax while Dr. DivX encodes one video 

after the next in the queue 

Introduction 
 

Dr. DivX is an encoding application able to convert popular video formats to the high quality DivX format by 

following a simple wizard-based flow. Dr. DivX is simple and intuitive, catering to any new user’s basic needs 

while still powerful enough to allow a professional to use its advanced features like editing, resizing, multiplexing, 

manual bit rate allocation, and ability to use third party filters required in a professional environment. 

About This Manual 
This document is a detailed manual containing step-by-step instructions on the usage and features of Dr. DivX 



and complements the online support and help built into Dr. DivX. This manual contains  chapters that are 

systematically organized to enable new users to work comfortably with Dr. DivX. This manual assumes that you 

are comfortable using the “Windows XP / 2000 / ME / 98SE” operating systems. 

 
This manual covers the following: 

•  Installation and getting started with Dr. DivX 
•  Using Dr. DivX to encode video using basic settings 
•  Encoding video files from various sources to high quality DivX format 
•  Using basic features to optimize quality of the output file 
•  Using advanced features to optimize quality of the output file 
•  Using Dr. DivX Profile Editor 
•  Using Dr. DivX EKG 
•  

This document also contains an Appendix with a detailed glossary of definitions for the technical terms used in 
this document, and an index to use as a quick reference. 

Contacting Support 
In addition to this user manual you can get further instructions and help from these online resources. 

Contact our Online Support Team by visiting the following links. 

Dr. DivX Main page: http://www.divx.com/drdivx 
Dr. DivX Support page: http://www.divx.com/support/drdivx  
Dr. DivX FAQ: http://www.divx.com/drdivx/faq 
Dr. DivX Interactive User Guide: http://www.divx.com/drdivx/guide 
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Installing and Setting Up Dr. DivX 
Installing and setting up Dr. DivX is a very simple task. After downloading Dr. DivX from www.divx.com, you will 

have to follow a few simple steps to set up Dr. DivX. Before installing Dr. DivX, please ensure that your system is  

configured with the necessary hardware and software required to meet the minimum requirements. The minimum 

as well as the recommended system requirements are listed in Table 1.0. 



Hardware Requirements: 
 
Table 1: Minimum and Recommended Requirements 

Component Minimum Recommended 
Processor Intel Pentium II 450 or equivalent  Pentium IV 3 GHZ or higher 
Hard Disk Space 50 MB hard disk space (for installation)* 20 GB and higher 
Memory(RAM) 64 MB RAM 256 MB RAM and higher 
Video Card 8 MB video card 128 MB Video Card and higher 
Sound Card Any standard sound card 5.1 Channel sound card 
DirectX 8.0 9.0b 

Fire Wire Card Any standard fire wire card/port or similar interface for digital video input from a 
Digital MiniDV camcorder 

Video Capture Card A standard video capture card with latest drivers 
 
* User will need a considerable amount of free hard drive space for converting or capturing large files. 10GB or more is 

recommended. 

Software Requirements 
• Operating System – Windows XP / 2000 / ME / 98SE 

• Libraries and Components 

o DirectX 8.0 and above 
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Installing 

To install Dr. DivX on your computer: 

• Double-click Dr.DivX105.exe to begin the installation process 

• Follow the onscreen instructions  

• If prompted, restart your computer to complete the installation process 

 

The following components will be installed during the installation process: 

 

• Dr. DivX Encoding Application 

• Dr. DivX Profile Editor 

• Dr. DivX EKG 

• DivX Pro Codec® 

• A detailed User’s Manual for Dr. DivX in PDF format 

Starting Dr. DivX 
To start Dr. DivX from the Start Menu: 

1. Click the Start button on the Windows taskbar 

2. From the Start Menu, choose Programs > DivX > Dr. DivX > Dr. DivX 

 

From Windows Explorer, open the folder where Dr. DivX was installed and double click Dr. DivX.exe. 

 

Getting Help 
From within Dr. DivX, access help by clicking Help > Help Topics or you can open the help file by pressing the 

<F1> key on your keyboard. 



Exiting Dr. DivX 
To exit Dr. DivX perform either of the following: 

• Click the Dr. DivX window close button at the upper right hand corner of your Dr. DivX screen 

• Press the Key Combination <Alt > + <F4> 

Uninstalling 

To uninstall Dr. DivX from your computer 

• Close Dr. DivX 

• Click on the Start menu 

• Choose Settings > Control Panel 

• Double-click the Add/Remove programs icon 

• Select Dr. DivX from the list 

• Click the Change/Remove button to start the uninstall process 

• Follow the on-screen prompts  

• If prompted, restart your computer to complete the uninstall process 
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Begin Encoding Video 
Encoding video using DivX technology is now a simple process thanks to Dr. DivX. You have to simply follow the 

wizard instructions that appear on the screen, and Dr. DivX will take care of the settings automatically. All you 

have to do is 1) select a source that you want to encode 2) choose a profile to encode to or select a size you 

would like for your output file and 3)assign a name for the output file and the rest is taken care of by Dr. DivX. In 

the following sections, we will show you how easily you can encode video in a step-by-step fashion using Dr. 

DivX. 

Selecting a source file 

The first step in using Dr. DivX is selecting a video source to be encoded. Dr. DivX can encode different input 

source file formats (including from a live capture device such as a TV capture card or web cam. Depending on 

the source you wish to select as your input, click the corresponding button on the first screen. See Figure 2.1. 

                 Figure 2.1: Start Screen 



Select Video File 
You can select a video file for encoding by clicking the Video File icon from the start screen (see Figure 2.1). 

Dr. DivX can encode the most popular video format files including AVI, MPEG1, MPEG2, MPEG4, TS, WMV, 

MOV and AviSynth scripts. 

To select a video file, for encoding: 

• Click the Video File icon on the start screen 

• Browse to the folder where you have the video file you wish to encode 

• Select the file you want to encode 

NOTE: You can select only one file at a time for encoding. You can, however, select multiple files if they are 

VOB files originating from a single source in sequential order and reside on a local hard disk. 

 

   

Figure 2.2: 
Choose Video 
input 



Selecting Multiple Files (MPEG2 VOB only) 

Dr. DivX includes a special feature that enables you to select multiple files for encoding to a single output file. 

This feature is enabled only if you are encoding MPEG2 VOB files that are in a sequential order having 

originated from a single source and reside on a local hard drive. Simply select the first .VOB file for encoding and 

a dialog box (listing all the other files in the sequence of the selected .VOB file) will pop up and allow you to 

choose which files  you want to encode. You can select either all of the files listed or you can choose certain 

.VOB files to encode. The Remove button can be used to remove unwanted files before encoding. 

 

NOTE: VOB files must be in sequential order to guarantee a good output file. 

              

 Remove button can be used to 

remove unwanted files during 

encoding. 

Figure2.3: Select VOB Files 



Selecting Digital Video (DV)  Input 

This section describes how to select Digital Video (DV) video from a camcorder or DV deck as input for Dr. DivX. 

It also explains how to adjust the picture quality by modifying the color, contrast and brightness of the input video 

from the digital video camera15 

Please ensure the following before encoding from a digital video (DV) input: 

• A digital MiniDV camcorder working properly and is connected to your system through the fire wire port 

• The system recognizes the Digital MiniDV Camcorder 

• The digital MiniDV camcorder contains a MiniDV cassette or memory stick with video on it 

 

For choosing a video to encode from the digital video camcorder: 

• Open Dr. DivX 

• Click the Digital Video button from the first screen 

• The “Select DV Device” window will pop up displaying the available DV devices - See figure 2.4 

• Choose the DV device and click OK to continue 

The Digital Video screen will appear as shown in figure 2.4. 

 
 

Figure 2.4: Select DV Device 
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• Use the Preview Window and Player Controls to view the digital video file and to select the portion 

you want to encode 

• Use the Mark In and Mark Out buttons to select the video from the tape that you want to encode 

Adjust Picture Quality 

• Use the Color Contrast and Brightness control panel as shown in figure 2.5 to adjust the color, 

contrast, and brightness settings of the digital video 

NOTE: This feature is available only if the digital video camera supports this feature. 

Figure 2.5: Adjust Picture Quality 

Adjust picture quality using 
these controls. 



Encoding From Live Capture Input 

Please ensure the following before encoding from a Live Capture source: 

• A working video capture card is installed on your computer with latest drivers 

• A video source is connected to the correct input on the capture card 

• An audio source is connected to the correct input on the capture card or line-in on the sound card 

• The system recognizes the capture card 

For choosing a video to encode from a live capture source. 

• Open Dr. DivX 

• Click the Live Capture button. 

• The “Select Live Capture Device” window will pop up as shown in figure 2.6 

 

• Select the Live Capture Device and click OK to continue 

• The Live Capture screen appears as shown in the figure 2.718 

Figure 2.6: Select Live  
Capture Source 



 
 

• Enter the length of video you want to capture in the “Capture Time Limit” field 

 

NOTE: The duration will be taken into consideration from the time you click the Encode button. 

Adjust Picture Quality 

Similar to the Digital Video input, you can adjust the color, contrast and brightness for the Live Capture input. 

This will again depend on the live capture device you are using and if it supports this feature. If you need to make 

further adjustments, you can click the Capture Card Settings button to access the controls for your capture 

card. 

Capture time limit 
 
 
Adjust picture quality using 
these controls 
 
 
Capture card settings 
 

Figure 2.7: Live Capture Screen / 
Adjust Picture Quality 



Playback controls for audio 

preview 

Options for selecting track in 
audio source 

Figure 2.8: Select / Preview Audio input 

19Selecting Audio Input 

Dr. DivX provides you with options to choose an audio input for encoding. The audio can be the existing audio 

track within the video input, or it can be a .wav or .mp3 file stored on your computer. You can also choose to 

encode the video without any audio. The selection process for audio input is consistent across various video file 

inputs. Once you select a video source for encoding, you will be prompted to choose an audio source. 

The audio input options are: 

• Encode the video using the existing audio track by clicking the Track in Video Input radio button 

o You can select Keep AC3 to preserve the AC3 track if present in the input file. 

• or Select an audio track for encoding 

A. Click the “Other, select a different audio source“ radio button 

B. Click the “Select“ button - A dialog box appears  

C. Browse to the location where you have stored audio files (.mp3, .wav, .ac3) on your system  

D. Select the audio you want to encode the video with and click OK 

• or Select “No Audio“ radio button - No audio will be encoded into the output video 

 
 



You can preview the selected audio track before encoding by using the Play button on the “choose audio” 

screen. 

 

When AC3 audio to MP3 audio you have the option to Boost audio.  This will be checked by default.  This feature 

increases the volume on AC3 audio tracks where the levels have a wider dynamic. 

 

 
 

After you are satisfied with the selection, click the “Next“ button. See Figure 2.8. 



Figure 2.9: Choose output size 

Select Output 

This section describes the options available when choosing an encoding profile. There are a range of profiles 

designed to help you reach a specific file size or target quality level. 

 
 

 



Choosing Output File Size 

You can choose from the following options: 

• Specify number of file(s) and file size, or 

• Make file by choosing Quality of file 

A. High quality 

B. Medium quality 

C. Low quality 

• Make a file using a Dr. DivX Profile 

• Make a file using Personal Profile - This is a saved profile, created either in the profile editor or after 

modifying the settings from a default profile 

 

 

 

NOTE: You may choose to set a profile as the “Default Profile” by selecting that profile and clicking the Set 

Default Profile button. You may not set the X files of Y size profile as the default profile. 

 

To add encoding profiles to your selection, copy the encoding profile file (profile.dip) into the Custom folder under 

the Dr. DivX install directory. 

 



Figure 2.10: Encode Video Screen 

Encode Your Video 

Once you have chosen your video input, selected the corresponding audio source and have chosen the output 

profile, you need to give your output file a name and you are ready to encode. If you have chosen a file input, Dr. 

DivX will automatically name the output file for you. You are free to change the output file name before encoding.  

You can also choose to encode the video at a later time by checking the box for batch encoding and then click 

encode.2 

The details about the input video, audio, length of the input file and the encoding settings based on the profile 

chosen for output will be displayed here for your approval. If you find these settings unacceptable, you may 

adjust these settings by clicking the Modify Settings button before you begin the encoding process. Modifying 

these settings will affect the quality of the output file depending on the settings that you choose. It is advised that 

unless you are aware of what you are doing, do not make any modifications to the profile settings. 



Figure 2.11: Encoding  

Statistics 

View Encoding Statistics 
The encoding statistics screen will display the status of the encoding that is in progress. See Figure 2.11. 

 
 

This information details: 

1. A progress bar, which gives the percentage of file encoded 

2. The bit rate display that indicates the bit rate and frame information for each frame as it is encoded 

• Key frames are displayed in red 

• Delta frames are displayed in blue 

3. The frame information display that gives details of the encoding status: 

• Time elapsed since encoding began 



Figure 2.12: Encoding Report 

• Time remaining to complete the encoding 

• Frame rate in frames per second 

• Current frame, the frame number that is being encoded 

 

After the successful completion of encoding, the Report screen appears. See Figure 2.12.  

 
 

The encoded file can be played directly from here by clicking the Play the file button or, click the EKG button to 

launch Dr. DivX EKG to make manual adjustments to the bit rate of the video 
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Figure 3.1: Batch Encoding 

Batch Encoding 
Batch encoding is a key feature in Dr. DivX that enables you to queue up multiple jobs and encode them in 

succession. After selecting the video input, choose an encoding profile and an output file and you can add it to 

the queue for batch encoding by clicking the batch encoding check box before clicking encode. There is no limit 

on the number of jobs that you can include in a job list, thus making it very convenient for encoding large number 

of files with minimum efforts. Combining batch encoding with such tools as custom profiles and the assigning of 

default profiles, it becomes a powerful way to encode hundreds of files to the same output profile with minimal 

clicks. 

It is very easy to add a new job or to delete a job from the queue, to change the priority of the job in the queue or 

to defer the encoding for a specific encoding job. 

 

NOTE: The batch encoding feature should be used only if you are encoding files that are saved on your system. 

 



Queue a File for Batch Encoding 

Begin the batch encoding process by following the same process you would to encode any normal file input (See 

Chapter 2). When you reach the encode screen, simply check the box that says “Click here to defer the job for 

batch encoding” and click the Encode button. 

 

NOTE: As soon as you queue a job for batch encoding, the batch encoding link gets activated on the lower left 

hand corner. This link is an easy way to see if there are any jobs queued up for batch encoding. 

Promote Job 

From the batch encoding screen, you can set the priority for each job in terms of the order in which the jobs 

encode. 

Promoting a job will cause the job to gain priority over the other jobs. You can choose to promote a job to any 

level you want, despite the fact that there may be other jobs ahead of that particular job. This is done by 

selecting the job you want to promote and by clicking the Promote button. You cannot promote a job if it is the 

first job in the queue. 

Demote Job 

You can downgrade the priority of a job in the queue by demoting it. The procedure is similar to that of promoting 

a job. You will use the Demote button to demote a job to the desired position in the queue. You cannot demote a 

job if it is the last job in the queue. 



Delete Job 

You can use the Delete option to remove a particular job from the queue. Use the delete function to remove jobs  

from the list once they have successful finished encoding. 

 

NOTE: The Delete Job action cannot be undone. If you delete a job from the queue and want to encode that job 

list again, you will have to go through the process of setting up that job for encoding again (See Chapter 2). 

Postpone Job 

Postponing a job will defer the job in the queue. The job will remain postponed until the job is un-postponed. 

When you select a job in queue, if it is not postponed, the Postpone button will be active. If a job has already 

been postponed and you want to schedule it, then the Postpone button will change to an Unpostpone button 

and you can schedule the job for encoding. 



Figure 3.3: Batch Encoding complete 

 

Encoding Batch Jobs 

After queuing up the jobs for batch encoding, click the Start button to begin the batch encoding process. See 

figure 

3.2. Unless a job is postponed, the jobs in the queue will get encoded sequentially till every job in the queue is  

complete. You can, however, choose to stop the batch encoding by clicking the Stop button at any time you 

want.  After completion of all jobs, you will be allowed to preview the encoded job’s output file, or you can open 

the EKG to make changes to the bit rate allocation settings. 

 

 



Other Encoding tricks: 

Right-Click Encoding 

When you have an encoding profile set as the default profile, you can speed up the encoding process by 

skipping the first two steps and going straight to the output with right-click encoding. Simply right click on any file 

input and select “Encode with Dr. DivX". This will take you straight to the encoding video screen and you just 

have to add it to the batch list or encode the video at that time. 

 
 

 

Drag & Drop Encoding 

You can Drag and Drop video files onto the Dr. DivX application for encoding.  This process will scan the file you 

drop on the application, load the default encoding profile and take you directly to the encode screen. 
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Figure 4.1: Modify basic settings 

Modify Basic Settings 

By modifying the basic settings, you will be able to change the video properties by cropping, resizing, 

changing the aspect ratio, etc. You can also change the audio encoding settings such as bit rate and 

sampling rate. 

These settings have a direct impact on the quality of the video file. Based on the settings you change, the quality 

can improve or deteriorate. 

 

Cropping 

Cropping allows you to cut away portions of the video file area from the top, bottom and sides. When you crop a 

video file, you will be losing the cropped area and only the remaining area of the video file will be encoded. The 

crop settings can be modified by clicking the Modify Settings button before you encode a video. Cropping is 



a. Enter desired values or use the up and down buttons to set the crop area for 

all 4 or any number of sides. 

b. Use the Reset button to reset the values to zero and enter new values. 

c. Check the “Remove Black Bar” button to remove letterboxing. 

Figure 4.2: Crop Video 

Figure 4.3: Adjust Aspect Ratio 

different from resize, which keeps the entire picture intact and only changes the resolution of the output video. 

NOTE: The Dr. DivX has an Auto-Crop option that is enabled by default and is particularly useful if the video has  

letterboxing. 

              

Aspect Ratio 

Aspect Ratio of a video file is the ratio between the width and height of a video file. You can change the Aspect 

Ratio of a video file before encoding. It is advised that the Aspect Ratio should not be changed unless you are 

aware of the changes you are making. 

 

If you are unsure, please encode the video in its existing Aspect Ratio. If you need to, changing the Aspect Ratio 

of the output file is easy. Simply choose from one of the options available to you. See figure 4.3. 

 



Figure 4.4: Resize resolution of video 

Use the Slider to set the visible area 
size according to your requirement. 

Figure 4.5: Adjust Audio Bit Rate 

Resize 

The resolution of a video file in terms of pixel length by pixel width can be altered to meet your encoding needs. 

Resizing a video will have an effect on the quality of the video. To resize, check the “Enable Resize” option and 

use the slider to set the desired file size. As you move the slider, you can see the value displayed at the bottom  

left hand corner as shown in figure 4.4. 

  
 

NOTE: It is generally not good practice to resize larger than the input file resolution. 

MP3 Settings 
Changing Audio settings is another option you can utilize when you are encoding with Dr. DivX. You can control 

these settings to fine-tune your audio output. Based on the settings you choose, the audio quality will vary. Do 

not modify these settings if you are unsure of the effect it will have. 

 
 

You can change the Audio Bit rate and Sampling Rate from here and you can choose to encode the audio as  

VBR, CBR, Stereo or Mono channels. Increasing the Audio Bit rate and Sampling Rate will result in increase in 

Audio quality as well as the size of the output file (encoded video file), and decreasing these values will cause 

both the Audio quality and the output file size to decrease. 



Figure 4.6: Add Filters 

Details about the filter effect. 
Helps you choose the right filter 
for your job 

Apply Filter Effects 
Various filter effects can be applied to the output video by using the Add Filter feature. External filtering effects 

like adjusting the brightness, sharpen, blur, and adding a logo can be applied to the output video file.  
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NOTE: Dr. DivX does not come with built-in filters but can use third-party filters like those used with VirtualDub. 

These filters have to be downloaded from an internet source that supplies these filters. One such URL from 

where you can download some of these filters is: http://shelob.mordor.net/draft/ 

 
To Add Filters to the list, 

• Click the Add Filters button on the Basic Settings screen 

• Click Add Filters button 

• Choose the filter(s) from the list of filters as displayed in figure 4.6 

• After choosing the filter(s), click Add to add the filter(s) to the list of filters 



Figure 4.7: Apply Filters 
 

 

 

• Select the filter of your choice and click the Configure button to modify the filer settings. See figure 4.7 

• Select the filter of your choice and click the Apply button to apply the filter effect and encode the video  

(See preview window for video quality changes after applying the filter effect) 

• To remove filter, select the filter and click the Delete button 

• Use the Move Up and Move Down buttons to adjust the order of filters  

•  

NOTE: Dr. DivX features an open API for all third party filters. We have done the initial work to allow VirtualDub 

filters to be used within Dr. DivX. All third party filters that work with such programs as Adobe Premiere could be 

modified to work with Dr. DivX. See the Dr. DivX website for more information on the filter API and how to modify 

filters and to work with Dr. DivX. 
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Figure 5.1: Advanced Settings 

Modify Advanced Settings 
The Advanced settings will have a direct impact on the quality of the encoded video and its ability to be played 

on DivX Certified hardware devices. By choosing to adjust the advanced settings, you will be changing the DivX 

encoder settings. 

 

Resize Filter 
Resize allows your video to be encoded at a specified resolution. Resize is done on the basic settings page, but 

here you can choose the resize filter to be used. Each filter has an effect on the quality of the resize. Select the 

Resize filter of your choice from the following options by clicking the respective radio button. 

• Bilinear (Very Soft) – Good quality, with soft finish, good for low resolution, low bit rate encoding 

• Bicubic (Soft) - Good quality, with soft finish 

• Bicubic (Neutral) - Good quality, with neutral finish 



• Bicubic (Sharp) - Good quality, with sharp finish, good for high resolution high bit rate encoding 
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Variable Bit rate 
Modifying or selecting a Bit rate will affect the quality and size of the output video. You can choose from one of 

the four different Bit rate modes available. Please note that the Variable Bit rate modes are applicable only to 

the Video Stream and not to the audio stream in the final output file. The Audio Bit rate can be modified by 

adjusting the MP3 Settings as discussed in Chapter 4. 

 

The available Bit rate modes and their function are listed below: 

 

• 1-Pass Variable Bit rate Mode – Focus on file size. Quality is dependant on Bit rate 

• 1-Pass Quality Based Mode – Focus on quality. Constant quality will be applied to each frame 

• 2-Pass (Variable Bit rate Mode) – Encoding is done using 2 passes, where during the 1st pass the 

source video is analyzed to gather vital information which is used by the encoder to perform better 

compression during the 2nd pass 

• Nth-Pass (Expert) – Focus on quality and estimated file size. Best quality and best control over Bit rate 

allocation. 2-Pass encoding with better control over fine tuning the output video using log files 

generated. 

 

NOTE: Nth-Pass can only be enabled after a successful 2-Pass encode or after using the EKG. 

 

Enter a value for Bit rate in the Bit rate field provided. The quality and the file size is directly proportional to the 

Bit rate value; higher the Bit rate, higher the quality and file size. (When you choose a file size in the Choose 

Output screen, the Bit rate is assigned automatically by Dr. DivX. You can still change this value, but if you do, 

the output file size will also change accordingly). 



MPEG4 Tools 
The MPEG4 tools are used to enhance the quality of the encoded video. Select the MPEG4 tool(s) by checking 

the respective check boxes. 

• B-frames/Bi-directional encoding – Using B-frames reduces the amount of data needed to code a 

frame and improves quality more specifically in areas where moving objects reveal hidden areas  

o Adaptive B-frames – Selecting adaptive B-frames will allow the codec to include multiple B-

frames in succession when necessary to increase compression. 

• Global Motion Compensation – Global Motion Compensation (GMC) helps to improve complex 

scenes  where zooming and panning are present. The ability to reduce the required data from one frame 

to the next can be reduced since there is a commonality within panning and zooming that can be used 

to more efficiently compensate for what is more normally a group of blocks in such scenes  

• Quarter Pixel – This option will allow the motions of objects in images to be reproduced more 

realistically. Quarter Pel performs a specific filtering on each block to produce a virtual block that should 

represent how the original block should appear if it is moved a ¼ of a pixel unit 

 

You can check one or all of these options to enhance the quality of your output video. 
 
NOTE: DivX certification levels may restrict some of these options. 

 

De-interlacing 
Determining the frame mode requirement and encoding the video appropriately is a vital aspect of video 

encoding. 

Dr. DivX allows you to choose from three de-interlace modes. 

• Output progressive – Use this option to make the output video progressive. 

• Output interlaced – Use this option to make the output video interlaced (input must be interlaced to 

use this option). 



• De-interlace all frames – Use this option if the input source is interlaced, and the desired output is 

progressive frame. 

NOTE: Dr. DivX will auto-detect the frame type when possible and set this option for you. 

Pre-Processing 
The Pre-Processing filter uses digital signal processing techniques to remove the noise from the source material 

prior to encoding. 

Select the Pre-Processing option from the following options using the slider. As you move the slider, the Pre- 

Processing mode selected will be displayed alongside the button bar 

• Light – Slightly removes noise from the source material, improves quality 

• Normal – No visual degradation of the source material, improves quality 

• Strong – Slight wash out of the source material, slightly deteriorates quality 

• Extreme – Greater wash out of the source material, slightly deteriorates quality 

NOTE: “Strong” and “Extreme” settings will wash the source a little and it should only be used when input 

source is extremely noisy or when file size is more important than quality. 

Psychovisual Enhancement 
Psychovisual Enhancement is based on the theory that the Human Visual System (HVS) is capable of 

perceiving certain characteristics in an image, and incapable of perceiving certain other characteristics in an 

image; particularly when the images are moving at a speed of 30 frames per second. Psychovisual 

Enhancement technique efficiently reallocates more video data to the location where the HVS perception is 

greater. The Psychovisual enhancements are applied to both a frame and macro block basis. The end result 

leads to better video quality. 

 

To select Psychovisual Enhancement option: 

• Check the Psychovisual Enhancement check box 

• Select Fast or Slow 



Key Frame Interval 
Advanced users can choose to insert key frames at desired intervals in the event the intervals between scene 

changes are very long. The DivX encoder will automatically insert a key frame every time it detects a scene 

change. 

However, it is possible to insert key frames if there is a long interval between scene changes. In Dr. DivX, you 

can specify the interval at which the key frame (I frame) will be inserted. Reducing the key frame interval can 

also improve delays and the quality of streaming content. 

Enter a value to indicate the interval at which a key frame has to be inserted. This value will be used only if the 

interval between scene changes exceeds the value specified. If the scene changes earlier than the specified 

frames, the encoder will insert a key frame regardless of the value specified. 
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Scene Change Threshold 
The Scene Change Threshold determines what is and what isn’t considered a scene change at which the 

encoder will insert a key frame. Dr. DivX provides an option to manually change these settings. Use the slider to 

change the Scene Change Threshold settings. This is indicated in percentage adjacent to the slider. 

 

NOTE: If you are not familiar with the concept of key frames, please do not make any changes in the settings. 

 

Performance/Quality Drop Down Menu 

The encoding performance control the balance between speed and motion estimation.  The new 5.2 codec uses 

standard as its defaults (not slowest).  The fastest mode does no motion estimation and can be used to create a 

large high quality file for live capture or DV capture to then re-encode with Dr. DivX. 
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Dr. DivX Profile Editor 
Dr. DivX Profile Editor is a useful utility that is installed with Dr. DivX. Using the Dr. DivX Profile Editor you can 

create, modify and save profiles that you use to encode your video. 

NOTE: Dr. DivX comes with built-in default profiles for video encoding. The Dr. DivX Profile Editor is to further 

enable you to modify the encoder settings to obtain results specific to your encoding needs. Please remember 

that the settings in a profile will have a direct impact on the quality and size of the output video. Unless you are 

aware of these settings and their effects, please don’t modify them. 

Features 
Using Dr. DivX Profile Editor, you can adjust or modify properties like Bit rate, File Size, Variable Bit rate 

mode, 

Frame Rate, De-interlacing, Key frame Interval, Psychovisual Enhancement, Pre-Processing level, 

Performance/Quality, and Bit rate and Sampling rate of the MP3 audio encoding. 

Create a New Profile 
To create a new profile, 

• Launch Dr. DivX Profile Editor 

• Make the necessary selections and settings (All the different parameters have been discussed in detail 

under the Modifying Advanced Settings chapter. Please read Modifying Advanced Settings for details  

about modifying each parameter) 

• After you are done, click File > Save or File > Save As to save the new profile file 

• Click File > Exit to exit from Dr. DivX Profile Editor, or click File > New to create a new profile. 



Figure 6.1: Profile  
Editor Screen 
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Saving a profile file 
After making the necessary settings in the Profile Editor, Click File > Save or Save As to save the changes as 

an encoding profile. You can assign a file name for the profile file. The profile file will be saved as a ‘ .dip’ file. 

This file can be used as an encoding profile file to encode a video using Dr. DivX. This file can be modified using 

the Dr. DivX 

Profile Editor as needed. 



Modify Existing Profile 
• In the Profile Editor window, click File > Open. 

• Navigate to the location where you have your profile files saved. Select the profile file (.dip file) from the 

browser window. 

• Make modifications (All the different parameters have been discussed in detail under the Modifying 

Advanced Settings section of help. Please read Modifying Advanced Settings for details about 

modifying each parameter) 

• After you are done, click File > Save to save the modifications to the profile file (Read Create a Profile) 

• Or click File > Save As to save the modified as a new file by assigning it a new name and specifying a 

location 

• Click File > Exit to exit from Dr. DivX Profile Editor, or click File > New to create a new profile or click    

File > Open to modify an existing profile file 

 

Tips and Tricks with Profile editor 
• Custom Resolutions – By entering only the height or width into the profile editor Dr. DivX will 

automatically calculate the other value for you based on the aspect ratio of the input video.  If you want 

to create a profile where the width is always 640 you would set the width to 640 and leave the height 

blank.  Dr. DivX will then automatically calculate and enter in the correct height for the input video when 

that profile is selected. 

 



 



Figure 7.1: EKG Start Screen 

EKG Features 
Dr. DivX EKG (electrokompressiongraph) is a useful utility that is included with Dr. DivX. The EKG enables an 

advanced video compressionist to reallocate data to specific scenes within a video clip. although the Rate 

Control 

Algorithm within the DivX Codec is very good, there is not a “Perfect” rate control since quality is very subjective. 

The EKG will allow a compressionist the ability to change or reallocate data to specific areas within a DivX 

Encoded video that may need more or less data. 

 
 

Dr. DivX generates a Log file recording the decision made by the Rate Control Algorithm. During 2-Pass 

encoding, this data is further analyzed so that bits may be more accurately distributed during the second pass of 

encoding. 

In the first pass, the rate control module looks complete through the whole video sequences  and records the 

overall complexity level of the video. In the second pass, the rate control module then adjusts the quantizer for 



each individual frame based on its complexity and the overall averages, which were obtained during the first 

pass of encoding. 

How It Works 
If you select 2-Pass Variable Bit rate mode from Advanced Settings, before encoding the video, a log file will be 

generated. This log will contain details of each frame, and helps the codec make decisions in the second pass as  

to how to encode that file. After the second pass, you can run the EKG and make adjustments to each frame 

based on the quality you would like for that frame or group of frames. You can choose to enhance or 

compromise on quality at various sections of the video to derive desired results. 

 

The EKG has built-in features that will enable you to fine tune your output video to get the desired output. Using 

EKG, you will be able to 

• Adjust the ‘Modulation’ level of each frame in the video 

• Adjust the ‘Modulation’ level for a section of the video 

• Adjust the ‘Modulation’ level for the entire video 

• Preview the video before encoding it finally 

Using the EKG 
When a two pass encoding is done you will be presented with the option to use the EKG. Simply press the EKG 

button and the EKG will launch with the appropriate video and the log file loaded. Once the file is open, you will 

immediately see your video along with a graph plotting the required information as follows: 

• Coding Type (I-P-B) 

• Motion Complexity 

• Texture Complexity 

• Frame Size 

• Modulation Parameter 

 



Figure 7.2: Video Loaded Screen 

The thin vertical black line represents the frame you are currently viewing. See figure 7.2. 
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You can go to a specific and see how data was allocated by using either the slider, play button, or by using the 

hand icon to grab frames  and slide along the graph. Determine a frame or sequence of frames where you want 

to increase or decrease the quality. You can do this in the default screen or if you like to see the data more 

prominently select the “Swap“ button from the toolbar. 

 



Figure 7.4: Adjust Modulation 
Parameter 

Editing Using EKG 
Select the Edit icon from the Menu bar. See Figure 7.3. 

  Figure 7.3: Select Edit 
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After deciding which frames or sequence of frames you like to modify, use your mouse pointer to select a frame 

or a sequence of frames. To select multiple frames or a sequence of frames, hold down the Shift button. Once 



selected, the frames will turn light blue in color, and you will see a thick blue horizontal line representing the 

modulation parameter.  See Figure 7.4. 

 

Increase or decrease the quality for the selected frame(s) by moving the Modulation Parameter, represented by 

a thick horizontal bar. At any instance, 100% represents the file’s current quality level. Moving the Modulation to 

150% will increase the quality by 50% of the original value and moving it down to 50% will decrease the quality to 

50% of its original value. After changing the Modulation Parameter, the horizontal thin beige line will represent 

your new Modulation Parameter. See Figure 7.4 

 

Once satisfied with your changes, go to EKG Menu, and select File > Save and encode. This will put the saved 

job in the Batch Encode area ready to be encoded. To start the job, click Batch Encoding in Dr. DivX, and follow 

the encoding process as described in Chapter 3 for Batch Encoding. 



Figure 7.5: EKG Visualization options 

EKG Visualization 
Dr. DivX EKG offers different visualization options to make the interface more intrinsic. The Dr. DivX EKG 

visualization is limited to the Editing Window. You can choose your visualization options by clicking the Graph 

Menu button and choosing from  its options  

 

For various visualization options: 

• Click Graph > and the required option or sub options. See Figure 7.5 
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Glossary 

 
3:2 Pull down 

The converting of 24 fps film to 30 fps video wherein every other frame of film is held for 3 fields of video. The 

resulting video has a repeating sequence of 3 fields followed by 2 fields. 

 

AC3 
Also known as Dolby Digital, it’s a digital audio format from Dolby Labs™. It can support up to 6 channels of  

audio. 

 

AVI 
Audio Video Interleave: The video format most commonly used on Windows PCs. It defines how video and audio  

are attached to each other, without specifying a codec. 

 

B-frames/Bi-directional Encoding 
There are three types of frames that are possible within a DivX video stream. These frames are called "I-frames" 

(Intra), "P-frames" (Predicted) and "B-frames" (Bi-directional). Prior to DivX 5.0 the only frame types were I and 

P. 

I-frames are encoded only using information from within its own frame. It does not use any information from other 

frames (temporal compression). An I-frame is similar in concept to encoding a single frame using JPEG. P-

frames  

(Predicted) are forward predicted and may refer to either an I-frame or P-frame. They are encoded from the 

frame that precedes  it. In any video sequence a group of frames will have many of the same images. For 

example, if you were to watch a news anchorperson you'll notice they barely move and the background would 



stay almost identical for every frame. (Remember that there are commonly up to 30 frames in a single second). 

So instead of encoding each one of those 30 frames independently as you would in an image file such as a 

JPEG you can exploit the redundancy of each frame by the use of P-frames. Essentially a P-frame is a future 

frame that determines where a block in the previous frame has moved to in it's current P-frame. So instead of 

spatially encoding (JPEG) the frame the P-frame just says "Hey the block in the previous frame has moved to 

location (X,Y) which requires much less data then encoding each frame spatially. Essentially we transmit the 

difference between frames which is more efficient than transmitting the original I-frame. 

DivX Pro 5.0 introduces the ability to also use "B-frames". B-frames allow the DivX codec to predict frames from  

the future, choosing the best prediction match among 2 prediction frames instead of only one. B-frames are not 

only codec by using forward predicted frames but also from backward predicted frames which can be an I or P 

frame. Using B-frames reduces the amount of data needed to code a frame and improves quality more 

specifically in areas where moving objects reveal hidden areas. 

 

Bit rate 
In a bit stream, the number of bits occurring per unit time usually expressed in bits per second. 

 

Brightness 
The intensity of a color as determined on a scale from black (no brightness) to white (maximum brightness). 

 

CBR/VBR 
Constant Bit rate / Variable Bit rate. Constant bit rate gives equal bits to each frame of a movie. Variable Bit rate 

gauges  which frames need more bits to maintain a better image. Note: high motion scenes require more bits 

than low motions scenes. 

 

 



Codec 
COder/DECoder: A codec is a piece of software that lets you encode something - usually audio or video - to a 

specific format, and can decode media encoded in this specific format again. Popular Codecs: MPEG-1, MPEG-

2, MPEG-4, Indeo, etc. AVI, ASF, etc, is not a codec but a format - and can be encoded using different codecs. 

Composite Video 
A signal in which the luminance, chrominance, and sync information are combined into one signal using one of 

the coding standards  

 

De-blocking 
The filter operates along the 8x8 block edges, on both the luminance and chrominance color planes. It helps to 

reduce the blocking artifacts caused by the DCT spatial compression algorithm used by the codec. 

Blocking is the most noticeable artifact, so this is the first algorithm to be applied. 

 

De-ringing 
The de-ringing filter is used to eliminate noise near sharp edges caused by the quantization process (the so-

called Gibbs effect). The noise is more noticeable in animations, where there are higher frequency coefficients. 

The deringing on the luminance plane is activated at post-processing level 6. Due to high CPU requirements and 

relatively low impact of the filter, it is only turned on for Pentium -III or newer processors. 

 

Decoding 
Decoding refers to the process of converting a compressed file to a viewable image. 

 

Deinterlace 
To remove artifacts that result from the nature of two-fields -per-frame (interlaced) video. 
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Demultiplexing 
The opposite of multiplexing. In this process, a combined audio/video stream will be separated into the number 

of streams it consists of (a video stream, at least one audio stream, and a navigational stream). Every VOB 

encoder demultiplexes the VOB files before encoding (FlaskMPEG, MPEG-2avi, DVD2MPG, ReMPEG-2) and 

every DVD player does the same (audio and video are being treated by different circuits, or decoded by different 

filters on a PC). 

 

Digital Video 
Digital video is usually compressed because it takes Terabytes (thousands of Gigabytes or for the 

mathematicians  among you: 1012 Bytes) to store an uncompressed movie. Because standard lossless 

compression is insufficient for video, the video codecs have to get rid of irrelevant information - stuff the human 

eye won't see or is unlikely to see. Since that is still not enough modern compression, algorithms use key frames  

and I and P frames to save space. 

 

DirectX 
DirectX is an application program interface developed by Microsoft, first for Windows 95, for creating and 

managing graphic images and multimedia effects in applications such as games and active Web pages. It 

includes the Direct- 

Draw API for direct access to video memory. 

 

DivX™ 

DivX™ is a video technology that compresses digital video so it can be downloaded over DSL or cable modems 

in a relatively short time with no reduced visual quality. 

 



Encoding 
The process of taking a raw uncompressed file and compressing it to an encoded form while maintaining the 

quality. 

FilmFX 
The film fx post-processing algorithm adds warmth to video for those who like the warmth behind film versus the 

crispness of digital video. The FilmFx filter is great at not only adding warmth to video but reducing perceived 

"blocking" in digital video and very little cpu overhead for decoding. 

 

Frame 
The basic source of a movie; one frame represents one image. A movie usually runs at 24 frames per second, 

equaling 24 different images per second. Imagine 24 images with a bird on it. In the first image, the bird is on the 

left, gradually moving to the right. On the 24th frame the bird is on the right end of the image. When these 24 

images  are played in sequence fast enough, the human eye sees a bird flying from left to right. 

 

Frame serving 
Frame serving is using one utility to decode or read a video file and after it has been decoded, sending it straight 

to any other video editing or encoding application. 

 

 

Global Motion Compensation 
Global Motion Compensation (GMC) helps to improve complex scenes where zooming and panning are present. 

The ability to reduce the required data from one frame to the next can be reduced since there is a commonality 

within panning and zooming scenes that can be used to more efficiently compensate for what is more normally a 

group of blocks in such scenes. 



 

Hue 
Hue is the overall gradation of color. 
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I and P Frames 
Frame describing only the differences to the frame before (this is less than accurate but I think you'll get the 

picture that way). Say we have a key frame with a bird before a cloudy sky. Then we can use I frames which say 

something like this: Move the bird an inch to the left and one inch to the bottom. 

 

Inverse Telecine 
The inverse of Telecine. This process is performed to extract the original 24fps of a 29.97fps source. 

 

Key frame 
A complete frame but heavily compressed. 

 

 

 

Letterbox 
The aspect ratio of motion pictures is wider than those of standard televisions. To preserve the original aspect 

ratio of a motion picture, a motion picture includes black bars at the top and bottom of the screen when played on 

television. 

Mark In 
To select the first frame of a clip. 



 

 

Mark Out 
To select the last frame of a clip. 

MP3 
MP3 (MPEG-1 Audio Layer-3) is a standard technology and format for compression a sound sequence into a 

very small file (about one-twelfth the size of the original file) while preserving the original level of sound quality 

when it is played. MP3 technology uses psycho-acoustic modeling to reduce the file size of an audio file while 

retaining the highest level of quality. 

 

MPEG 
MPEG means Motion Picture Expert Group and it's THE resource for video formats in general. This group 

defines  standards in digital video, among it the MPEG-1 standard (used in Video CDs), the MPEG-2 standard 

(used on 

DVDs and SVCDs), the MPEG-4 standard (used in DivX video technology) and several audio standards – 

among them MP3 and AAC. 

 

 

MPEG-4 
MPEG-4 is a standard defined by the Working Group 11 (Moving Picture Expert Group) of ISO (International 

Standard Organization) in October 1998 (date of the first draft of the standard). It is the standard for the mature 

digital era. With its added features, MPEG-4 offers better compression, interactivity, and universal 

Internet/wireless access to the medium. 

Multipass encoding 



True multipass encoding is currently available only for WM8 and MPEG-2 (SVCD & MiniDV). An encoder 

supporting multipass will, in a first pass, analyze the video stream to be encoded and write down a log about 

everything it encounters. Let's assume we have a short clip that starts out in a dialog scene where we have few 

cuts and the camera remains static. Then it leads over to a karate fight with lots of fast cuts and a lot of action 

(people flying through the air, kicking, punching, etc.). In regular CBR, encoding every second gets more or less 

bit rate (it's hard to stay 100% CBR but that's a detail) whereas in multipass VBR mode the encoder will use the 

bit rate according to his knowledge about the video stream, i.e. the dialog part gets the available bit rate and the 

fighting scene gets  allotted more bit rate. The more passes, the more refined the bit rate distribution will be. In 

single pass VBR, the encoder has to base his decisions on where to use how much bit rate solely on the 

knowledge of the stuff it previously has encoded. 
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Multiplexing 
Video and audio are usually encoded separately. You have to join them to make a movie you can play (you can 

play audio and video separately in two players but to get synch would be rather hard). During multiplexing, the 

audio and video tracks are combined into one audio/video stream. The audio and video stream will be woven 

together and navigational information will be added so that the player can, for example fast forward/backward 

and still retain synch audio/video. 

 

 

PCM 
Pulse Code Modulation is the most simple binary representation for digital audio. The audio signal is converted in 

samples according to the frequency of the signal. Every sample is then written in the stream without using any 

smart compression techniques. 

 

Quarter Pel 



As explained in the "B-frames" summary, data is reduced when the difference between two frames (prediction 

error) is transmitted instead of the entire image being sent. The difference in a successive frames composition is 

generally computed on a macroblock-by-macroblock basis (16x16 pels) or on a block by block basis (8x8 pels). 

For example, a part of an image located in a block at grid location (1,1) may move to grid location (1,2) in the 

next frame. As you may realize an image in one block will likely need more accuracy than just the ability to move 

on a limited block by block basis with an accuracy that is limited to an integer pixel unit (1,1). DivX has increased 

the previous accuracy of using a half pel (1.5, 1.5) to include the ability of using "Quarter Pel" (1.25, 1.75) 

accuracy with the Codec release. 

Quarter Pel performs a specific filtering on each block to produce a virtual block that should represent how the 

original block should appear if it is moved a 1/4 of a pixel unit 

 

Telecine 
A process to bring a 24fps source (usually a movie is shot at that speed) to 29.97fps or 29.97x2 interlaced fields  

per second. 

 
 
 

Credits: 

 
Moonlight-Elecard MPEG-2 video decoder is included under license from Moonlight Cordless Ltd. 
All rights reserved www.moonlight.co.il 
 
MP3 encoder based off of the lame mp3 project: www.mp3dev.org and used under the LGPL license 
 
AC3 decoder based off the AC3filter project: http://ac3filter.sourceforge.net/ and used under the GPL license 
 
 


