Добро пожаловать в Справку по Reg Organizer!

Что такое Reg Organizer?

Reg Organizer - это многофункциональный менеджер реестра и конфигурационных файлов. Позволяет просматривать и редактировать системный реестр, осуществлять предварительный просмотр импортируемых reg-файлов (в том числе и из Проводника). Предоставляет возможность чистить реестр, производя глубокий поиск и находя все ключи реестра, относящиеся к данному приложению. Поддерживает функции управления конфигурационными файлами различных типов. Открывает доступ к некоторым недокументированным возможностям операционной системы Windows.

Возможности Reg Organizer
Программа Reg Organizer имеет много возможностей, которые позволяют вам производить эффективную работу с системным реестром, производить чистку реестра и управлять конфигурационными файлами.

Как использовать Reg Organizer
В этом разделе рассмотрены основные вопросы использования программы Reg Organizer.

Дополнительная информация
Если вы хотите узнать о лицензии на программу Reg Organizer, о том, как связаться с разработчиками и т.д., вы можете воспользоваться этим разделом.


Основные возможности Reg Organizer

Возможности, касающиеся работы с реестром
Возможности работы с файлами конфигурации
Расширение возможностей оболочки

(Наверх)

Основные возможности
  • Просмотр и редактирование системного реестра, возможность производить различные операции c ключами и значениями системного реестра, экспортировать и импортировать значения ключей и т.д.
  • Возможность получения информации о любом выбранном ключе реестра, возможность отслеживать изменения, произошедшие в том или ином ключе.
  • Предварительный просмотр файлов реестра (*.reg) перед объединением (импортом) их содержимого, в том числе и непосредственно из Проводника. При просмотре импортируемого reg-файла его содержимое представляется в виде древовидной структуры, что позволяет представить в наглядной форме все ключи, которые будут импортированы в реестр.
  • Возможность производить очистку реестра. Reg Organizer ищет ключи, относящиеся к интересующему вас приложению, и удаляет их при необходимости. Это полезно, например, в случае, когда какое-либо приложение не имеет программы деинсталляции и после его удаления "вручную" в реестре остаются ненужные записи, которые могут приводить к некорректному функционированию других приложений. В то же время, Reg Organizer производит более глубокий поиск и позволяет зачастую найти даже те ключи, связанные с данным приложением, которые не будут найдены другими аналогичными программами.
  • Режим просмотра реестра на наличие ссылок на несуществующие файлы и каталоги, проверка зарегистрированных в реестре библиотек, поиск устаревших расширений файлов и исправление или корректное удаление этих ссылок в случае необходимости.
(Наверх)

Возможности работы с файлами конфигурации
  • Управление конфигурационными файлами. С программой Reg Organizer вы можете открывать и редактировать, т.е. добавлять, удалять, изменять ключи/секции INI-файлов различных программ.
  • Импортирование в программу новых типов конфигурационных файлов, ранее неизвестных программе. С помощью Панели импорта вы можете описать новый тип конфигурационного файла, после чего загружать файлы этого типа и работать с ними, как с файлами известного формата, что позволяет применять к ним операции редактирования и изменения.
(Наверх)

Расширение возможностей оболочки
  • С программой Reg Organizer вы можете осуществлять просмотр reg-файлов (файлов реестра), содержимое которых вы хотите объединить (импортировать в реестр). Для этого нужно всего лишь воспользоваться пунктом контекстного меню, соответствующего reg-файлу прямо из Проводника.
  • Просмотр и редактирование INI-файлов может осуществляться с помощью программы Reg Organizer также из Проводника.


Работа с программой Reg Organizer

Режимы работы Reg Organizer
Основная функциональность программы Reg Organizer организована посредствам трех основных страниц, которые можно переключать с помощью панели Reg Organizer или из Главного меню, пользуясь пунктом меню "Режим".

Каждая из страниц отображает определенный режим работы программы. Вы можете переключаться между страницами и, соответственно, режимами:

  • Режим редактирования реестра
    Мощный редактор системного реестра, обладающий расширенным набором функций, таких, как клонирование ключей реестра, получение информации о любом выбранном ключе и др. Как и стандартный RegEdit, позволяет создавать, удалять, редактировать ключи, изменять значения параметров, сохранять ключи в файлы реестра (.reg).

  • Режим чистки реестра
    С помощью этого режима вы можете производить тщательную чистку реестра и настройку функциональности операционной системы. В частности, имеется возможность указывать программы, которые будут запускаться при загрузке Windows, исследовать общие (shared) библиотеки динамической компоновки (DLL) и многое другое. С помощью этого режима вы можете также произвести поиск ссылок на несуществующие файлы и папки в реестре, удаляя эти ссылки при необходимости и тем самым освобождая ваш реестр от ненужного "хлама". Здесь же вам доступны некоторые недокументированные опции оболочки.

  • Режим редактирования файлов
    С помощью этого режима работы программы вы можете без труда осуществлять контроль за интересующими вас файлами настройки, в частности INI-файлами, широко использующимися различными программами, а также самой Windows для хранения своих настроек. Программа Reg Organizer позволяет также работать с другими типами конфигурационных файлов. Для этого интересующий вас тип файла нужно описать с помощью Панели импорта, после чего файлы данного типа можно будет открывать и редактировать с помощью Reg Organizer.


Режимы работы Reg Organizer

Режим чистки реестра
Окно этого режима разделено на закладки со страницами, каждая из которых позволяет вносить изменения в различные аспекты функционирования Windows:
  • Деинсталляция
  • Программы
  • Автозагрузка
  • Типы файлов
  • Расширения оболочки
  • Меню "Создать"
  • Меню "Открыть с помощью..."
  • Системные папки
  • Общие DLL

Помимо этого здесь доступны дополнительные возможности, которые можно активизировать, нажав соответствующую кнопку на панели инструментов "Дополнительно".

Ниже представлены страницы Режима чистки реестра:

  • Деинсталляция
    Здесь представлены все программы, которые доступны в меню "Установка и удаление программ" Windows. Вы можете удалить упоминание о ней из окна "Установка и удаление программ" Windows с помощью кнопки "Удалить отмеченные" или попытаться деинсталлировать отмеченные программы стандартным образом, используя кнопку "Деинсталлировать отмеченные".

  • Программы
    Одна из ключевых страниц режима чистки реестра. Содержит список всех программ, зарегистрированных в реестре. При выборе команды "Информация" контекстного меню программа производит поиск по реестру и выводит cписок ключей, имеющих отношение к выбранной программе, найденных в различных частях реестра. Вы можете удалить все ключи, относящиеся к отмеченным программам, нажав кнопку "Удалить отмеченные". Если же Вы не уверены, что программа удалит именно те ключи, которые соответствуют именно выбранному приложению, то Вы можете указать какие из найденных ключей следует удалять, а какие оставить. Для этого вызовите контекстное меню "Информация о..." на интересующем приложении и в появившемся списке ключей отметьте галочкой только те их них, которые следует удалить, после чего нажмите кнопку "Удалить отмеченные". Все не отмеченные галочкой ключи останутся в реестре.

    Примечание: бывают ситуации, когда приложения не совсем корректно записывают свои данные в реестр и в столбце "Автор" оказывается название приложения. В таком случае для поиска ключей, ассоциированных с этим приложением, следует воспользоваться опцией контекстного меню "Дополнительные возможности поиска" -> "Искать <текст, стоящий в столбце Автор> (как название программы)".

  • Автозагрузка
    На этой странице представлены все приложения, автоматически запускаемые после загрузки Windows. Здесь указаны приложения, ссылки на которые находятся в отвечающих за автозагрузку ключах реестра, и ярлыки, присутствующие в папке "Автозагрузка" Главного меню Windows. Вы можете удалить любую из ссылок, используя кнопку "Удалить отмеченные".
    Кроме того, на этой же странице можно создать новый элемент автозагрузки посредствам кнопки "Новый элемент". При создании нового элемента Вам будет предложено указать, в какой из четырех ключей реестра, ответственных за автозагрузку, он будет помещен. Учтите, что при помещении его в ключ "HKEY_CURRENT_USER\...\RunOnce" или "HKEY_LOCAL_MACHINE\...\RunOnce" соответствующая программа будет запущена только один раз.

  • Типы файлов
    Здесь представлены все типы файлов, зарегистрированные в системе. Если в столбце "Описание типа файлов" указано "нет данных", то, вероятнее всего, этот тип файлов больше не нужен в системе и Вы, пометив, можете удалить его с помощью кнопки "Удалить отмеченные". Дополнительную информацию о ключах реестра, относящихся к выбранному типу (типам) файлов, можно узнать, используя команду "Информация" контекстного меню.

  • Расширения оболочки
    Каждый из зарегистрированных в Windows типов файлов имеет определенное количество команд контекстного меню Проводника. Например, текстовый файл, как правило, имеет такие команды контекстного меню, как "Открыть" и "Печать". Здесь представлены все эти команды для каждого из зарегистрированных в системе типов файлов, а также командная строка, которая будет выполняться при выборе в контекстном меню Проводника соответствующей команды. Вы можете как удалять некоторые из записей (следует удалять те записи, в столбце "Расположение программы" у которых ничего нет), так и изменять их.

  • Меню "Создать"
    Здесь содержится список документов (файлов), которые присутствуют в меню "Создать" Проводника Windows. Вы можете удалять ненужные типы документов из этого меню, используя кнопку "Удалить отмеченные" на этой странице.

  • Меню "Открыть с помощью..."
    Когда Вы пытаетесь открыть файл неизвестного формата, Windows предлагает программы для его открытия в меню "Открыть с помощью...". На этой странице представлены все предлагаемые программы. Вы можете удалять ненужные программы из меню "Открыть с помощью...", используя кнопку "Удалить отмеченные".

  • Системные папки
    Здесь представлены пути к ключевым папкам системы Windows таким, как Мои документы, Автозагрузка и т.д.
    Эта страница разделена на две дополнительные:

    • Папки текущего пользователя
      Системные папки, относящиеся к текущему пользователю. Если в столбце "Статус" указано, что папка не существует, то следует указать путь к ней, пометив ее и нажав кнопку "Изменить отмеченные".
    • Шаблоны папок произвольного пользователя
      Шаблоны, в соответствии с которыми Windows создает пути к системным папкам пользователей.

  • Общие DLL
    На странице представлены совместно используемые библиотеки динамической компоновки (DLL) и другие общие файлы с указанием количества программ, использующих ту или иную DLL (столбец "Используется приложениями"). То, что в столбце "Используется приложениями" указан ноль, не означает, что эту DLL следует удалять, так как в некоторых случаях это может привести к неверной работе.
    Удалять с этой страницы следует те записи, которые ссылаются на несуществующие файлы и, соответственно, в столбце "Статус" которых указано "Не существует".
    Примечание: помните, что при пользовании кнопкой "Удалить отмеченные" на этой странице, удаляется не сам файл, а только ссылка на него.

Дополнительные возможности
Дополнительные возможности включают в себя автоматическую чистку реестра и опции оболочки.


Режимы работы Reg Organizer

Режим редактирования реестра
Reg Organizer при работе в этом режиме представляет собой мощный редактор реестра, работа в котором аналогична работе в стандартном Regedit'е.

Вы можете создавать, удалять, переименовывать ключи и параметры реестра посредствам соответствующих кнопок на панели инструментов (или с помощью их аналогов из меню "Реестр").

Кнопка "Экспорт" позволяет экспортировать отмеченный ключ в файл реестра (reg-файл). Дополнительные команды экспорта доступны в меню "Файл".

При просмотре реестра дополнительную информацию о каждом ключе можно узнать, выбрав команду контекстного меню "Подробнее о <имя ключа>".

Вы можете добавлять интересующие ключи к Избранному посредствам соответствующей команды контекстного меню и при необходимости открывать ключи из Избранного.


Режимы работы Reg Organizer

Режим редактирования конфигурационных файлов
Этот режим программы Reg Organizer позволяет редактировать INI-файлы и прочие файлы конфигурации различных приложений (в том числе и самой Windows).
Работа с INI-файлами
Работа с файлами произвольного формата

(Наверх)

Работа с INI-файлами
Многие программы сохраняют свои настройки в стандартных INI-Файлах. Файлы этого типа представляют из себя текстовые файлы, состоящие из разделов, которые начинаются с символа "[" и заканчиваются символом "]", между которыми указывается имя раздела. Разделы INI-файлов в свою очередь подразделяются на ключи, в которых хранятся различные значения. Ключи INI-Файла имеют следующий вид:

Имя=Значение

где Имя - это имя ключа, а Значение - значение параметра, соответствующее этому ключу.

Таким образом, структуру INI-Файла можно представить следующим образом:

[Раздел1]
Ключ1=значение1
Ключ2=значение2
Ключ3=значение3
...
[Раздел2]
Ключ1=значение1
Ключ2=значение2
Ключ3=значение3
...

Такие файлы можно редактировать в программе Reg Organizer. Открыть INI-Файл в Reg Organizer, находясь в режиме редактирования файлов, можно следующими способами:

  • Нажать на кнопку открытой папки справа от поля ввода имени файла и в появившемся диалоговом окне указать путь к файлу.
  • В поле ввода имени файла указать полный путь и имя интересующего файла, после чего нажать кнопку "Открыть" на панели инструментов вверху.

После того, как файл открыт, все его разделы и ключи отображаются в соответствующей иерархии на панели слева и доступны для редактирования.

Вы можете просмотреть редактируемый файл как текст, воспользовавшись закладкой "В виде текста".

Сохранить сделанные изменения можно, нажав кнопку "Сохранить".

(Наверх)

Работа с файлами произвольного формата
Помимо работы с INI-файлами, программа Reg Organizer позволяет открывать конфигурационные файлы других форматов. Перед тем, как файлы определенного формата можно будет открыть, Вам необходимо описать этот формат, пользуясь Панелью импорта.

Для того чтобы открыть конфигурационный файл произвольного (не INI) типа, следует нажать кнопку "Импорт" в окне Редактирование файлов, после чего указать путь и имя файла и тип открываемого файла.


Работа с программой Reg Organizer

Чистка реестра в автоматическом режиме
Наряду с возможностью очистки реестра от ненужных записей вручную, Reg Organizer предоставляет возможность воспользоваться режимом автоматического просмотра реестра и поиска неверных или устаревших ссылок и записей.

Чтобы воспользоваться данной возможностью, необходимо выбрать пункт меню Чистка реестра, находящийся в меню Команды главного меню. Окно чистки реестра можно также открыть, воспользовавшись соответствующей кнопкой на панели инструментов Дополнительно.

Для того чтобы программа начала поиск в реестре, необходимо нажать кнопку Начать внизу окна, но прежде следует задать условия, в соответствии с которыми Reg Organizer будет сканировать реестр компьютера. В левой части окна в разделе Что искать находится список операций, которые программе следует произвести. Итак, программа позволит Вам найти в реестре:

  • Неверные расширения
    Поиск неверных расширений файлов и классов, зарегистрированных в реестре. Эти записи могут остаться от некорректно удаленных программ.

  • Ссылки на несуществующие файлы и папки
    Программа будет искать в реестре ссылки на несуществующие файлы и папки. Подробнее об этом наиболее эффективном средстве очистки реестра читайте здесь.

  • Неверную деинсталляционную информацию
    Осуществляет проверку ключей реестра, предназначенных для хранения информации об удалении приложений.

  • Неверные ссылки на DLL
    Проверяются библиотеки динамической компоновки (DLL), зарегистрированные в реестре. С помощью этого режима можно отыскать DLL, не используемые системой а также ссылки на несуществующие DLL.

Под разделом "Что искать" находится другой раздел: "Просматривать ключи". Здесь следует указать корневые ключи, которые нужно проверить. Этот раздел влияет только на работу поиска ссылок на несуществующие файлы и папки и не влияет на работу других режимов. То же самое относится и к первым двум опциям, нахоящимся в Дополнительных опциях в правом нижнем углу окна. Третья опция Автоматически закрывать окно по окончании позволяет произвести автоматическое закрытие окна после завершения всех выбранных операций.

После завершения операций поиска все неверные ссылки, найденные в Вашем реестра, будут отображены в таблице. В колонке "Комментарий" указан тип неверной ссылки. Все ссылки, отмеченные галочкой, можно удалить из реестра, нажав кнопку "Удалить отмеченные". Помните, что после удаления ссылок их можно восстановить при надобности, используя пункт меню Команды -> Резервные копии главного меню.


Работа с программой Reg Organizer

Поиск ссылок на несуществующие файлы
Эта функция программы Reg Organizer производит тщательный поиск по реестру и находит все ссылки на несуществующие файлы и папки в нем.
Вызвать эту функцию можно из Главного меню программы (Команды -> Поиск ссылок на несуществующие файлы) или нажав кнопку "Несуществующие файлы в реестре" в окне режима чистки реестра.

Поиск производится в тех корневых ключах, которые указаны в опциях программы (на странице опций "Чистка реестра").

Поиск может занимать определенное время, что зависит от количества информации, записанной в реестре. Результаты поиска выводятся в таблицу, по результатам которой пользователь может принять окончательное решение, отметив ключи, которые следует удалить из реестра. В таблице результатов поиска в столбце "Комментарий" указана информация о каждой найденной неверной ссылке. Комментарий может иметь следующий вид:

  • Несуществующий файл
    Программа обнаружила ссылку на несуществующий файл. Эта ссылка может быть удалена из реестра, так как она является бесполезной.

  • Несуществующая папка
    Программа обнаружила ссылку на несуществующую папку. Эта ссылка может быть удалена из реестра, так как она является бесполезной.

  • Внимание: возможно, эта запись ссылается на <имя файла>
    Программа не может точно установить является ли эта ссылка неверной (то есть указывающей на несуществующий файл) или нет. К примеру, если программа обнаружила в реестре ссылку C:\dir\file1 и хотя файл (или папка) C:\dir\file1 не существует, но существует файл C:\dir\file1.exe. В этом случае Reg Organizer относит найденную ссылку именно к этой категории и окончательное решение о том, нужно ли удалять ее из реестра или оставить следует принять пользователю. Как правило, такие ссылки удалять не следует.
    Примечание: по умолчанию программа не показывает ссылки такого типа. Для того чтобы программа отображала их, следует включить опцию "Отображать сомнительные записи" в опциях.

Все ссылки, отмеченные галочкой, можно удалить из реестра, нажав кнопку "Удалить отмеченные". Помните, что после удаления ссылок их можно восстановить при надобности, используя пункт меню Команды -> Резервные копии главного меню.


Установка и запуск Reg Organizer

Для того, чтобы запустить программу Reg Organizer, необходимо:

Загрузить Reg Organizer

Последнюю версию программы можно всегда загрузить с официального сайта www.chemtable.com.
Reg Organizer поставляется в виде zip-архива с названием regon.zip, который содержит установочный исполняемый файл regon.exe.

Установить Reg Organizer

Запустите установочный файл, распаковав его из zip-архива. Следуйте инструкциям.

Запустить Reg Organizer

Запустить программу Reg Organizer можно двойным нажатием на ее иконку на Рабочем cтоле или воспользовавшись меню Пуск.


Обратная связь

Если у Вас есть комментарии относительно этой программы, Вы нашли ошибку или хотите предложить какую-либо новую функцию, которой нет в текущей версии программы, обращайтесь по e-mail: support@chemtable.com.

Ваши пожелания, комментарии, сообщения об ошибках очень важны для совершенствования программы. Множество идей, воплощенных в программе, были взяты из писем пользователей. Поэтому если у вас есть мысли относительно улучшения этого программного продукта, пожалуйста, изложите их, связавшись с нами по указанному адресу.

Последняя версия программы Reg Organizer всегда доступна на сайте www.chemtable.com.


Работа с программой Reg Organizer

Опции оболочки
Эта функция программы Reg Organizer открывает доступ к некоторым дополнительным (недокументированным) опциям оболочки Windows.