Seznámení se systémem OptimAccess®

Desktop Management System OptimAccess® představuje novou generaci komplexního řešení problematiky správy koncových pracovních stanic. Řeší veškeré problémy, se kterými se potýkají technická oddělení zaměřená na správu koncových stanic v organizacích s desítkami až tisícovkami počítačů. S jeho pomocí lze provádět sledování a evidenci softwarového a hardwarového vybavení, monitorování uživatelských aktivit, vzdálenou distribuci software a převzetí obrazovky vzdálené stanice. Pomocí restriktivních a obnovovacích akcí lze efektivně prosazovat dodržování bezpečnostní politiky organizace a snížit počet servisních zásahů administrátorů.

Systém OptimAccess® se skládá ze šesti na sobě nezávislých modulů. Ovládací prostředí modulů je ve všech podporovaných operačních systémech jednotné, kompaktní a celistvé. Jestliže organizace není aktuálně nucena řešit všechny problémy související s Desktop Managementem, je možné díky modulární koncepci systému OptimAccess® nasadit pouze vybrané moduly a získat tak cenově optimální řešení a připravenost řešit v budoucnosti další problémy se správou koncových pracovních stanic.

Systém OptimAccess® slouží k zabezpečení pracovních stanic i notebooků proti neodbornému, neúmyslnému, či zcela záměrnému poškození již instalovaného software. Chrání nastavení instalovaných programů, operačního systému, komunikačních prostředků a nastavení Windows na pevných discích jednotlivých počítačů. Umožňuje rovněž sledovat využití počítače a monitorovat konkrétní události.

Jedná se o samostatný, komplexní a modulární systém. Díky široké škále ochranných metod si dokáže poradit jak s počítačovými viry, tak se zásahy laických či sofistikovaných uživatelů. Počítač má pro všechny uživatele jednotný vzhled, tytéž aplikace a stejné nastavení. Díky reportům generovaným systémem je možné mít dokonalý přehled o využití počítačů a programového vybavení v rámci organizace.

Využívání funkcí systému OptimAccess® zabezpečí správcům a administrátorům počítačových systémů značnou nejen časovou, ale i materiální úsporu. OptimAccess® nalezne uplatnění při ochraně jednotlivých počítačů nebo celých rozsáhlých informačních systémů, kde je velice obtížné udržet bezchybný provozuschopný stav.

Bezpečnost bez šifrování?

Při nastavování restrikcí je důležité si uvědomit, že program OptimAccess® je „pouze ochranným systémem“. Systém přímo nechrání fyzicky uložená data na pevném disku pomocí kryptografického algoritmu. Dále je třeba vzít v úvahu obecný bezpečnostní fakt, že bez použití šifrovacího algoritmu nemá vůbec smysl o zabezpečení dat hovořit. Je-li tedy jedním z vašich požadavků také fyzická ochrana dat, je třeba skombinovat nasazení programu OptimAccess® spolu s některým programovým balíkem pro šifrování dat.

Nejvíce bezpečné a transparentní vůči uživateli jsou balíky pro on-line šifrování pracující přímo na úrovni fyzického uložení dat na pevném disku či výměnném médiu. Více informací o nabídce a možnostech konkrétních produktů naleznete na www stránkách výrobce nebo je můžete telefonicky získat na obchodním a technickém oddělení.

Provoz systému

Nespornou předností systému OptimAccess® je jeho nenápadný provoz. Uživatel pracuje v naprosto standardním prostředí, které je mu důvěrně známo, přičemž neregistruje žádný rozdíl. Výjimkou jsou situace, kdy jeho aktivity směřují k potencionálně nebezpečným situacím.

Podrobnější informace o návrhu, funkcích programu, nasazení systému v jednotlivých operačních systémech a počítačových sítích naleznete pod hesly:

  • Koncepce systému OptimAccess®;
  • Specifika jednotlivých operačních systémů;
  • Nasazení v síti.


Koncepce systému OptimAccess®

Systém OptimAccess® lze instalovat na stanice s operačním systémem MS-DOS, Windows 3.x, 9x, NT, 2000 a XP. Díky zavádění na úrovni systémových ovladaču dosahuje vysokého stupně stability, bezpečnosti a běžnému uživateli je znemožněno nelegálně deaktivovat ochranný systém.

Prvotní instalace systému OptimAccess® je snadná, časově nenáročná a výhodou je možnost jeho zavedení do již nakonfigurované stanice. Lze jej instalovat také hromadně prostřednictvím sítě. Není zde třeba provádět žádné úpravy, reinstalovat operační systém ani již instalovaný software. Aktivaci respektive deaktivaci je možno provést kdykoli během práce systému OptimAccess®. Uživatel počítače při své práci není nijak omezován a přítomnost systému OptimAccess® ani nezaregistruje.

Modulární pojetí systému

Jednotlivé funkční vlastnosti systému OptimAccess® jsou rozloženy do samostatných modulů. Díky této koncepci máte možnost si plně přizpůsobit systém OptimAccess® na základě vašich specifických požadavků. Lze volit mezi těmito moduly:

  • OptimAccess® Standard – slouží pro základní zabezpečení programů a operačního systému instalovaného na pracovní stanici.
  • OptimAccess® Extension – rozšiřuje ochranné funkce modulu Standard v oblastech operačního systému Windows.
  • OptimAccess® Remote Control – je nástroj pro administraci, konfiguraci a centrální správu systému OptimAccess®.
  • OptimAccess® Computer Audit – umožňuje evidenci a sledování programového a harwarového vybavení počítače.
  • OptimAccess® WorkSpy - eviduje a sleduje využití počítače a pracovního času stráveného u počítače.
  • OptimAccess® NetHand - umožňuje prohlížení a převzetí vzdálené stanice a možnost vzdálené distribuce software.

Podrobnější informace o jednotlivých modulech naleznete pod hesly Moduly ochranného systému, OptimAccess® Standard, OptimAccess® Extension, OptimAccess® Remote Control, OptimAccess® Computer Audit, OptimAccess® WorkSpy a OptimAccess® NetHand.


Specifika jednotlivých operačních systémů

Tato nápověda je společná pro operační systémy Windows 9x, Windows ME, Windows NT, Windows 2000 a Windows XP. Příslušnost jednotlivých hesel k danému operačnímu systému je v pravém horním rohu jednotlivých hesel a témat vyznačena následujícími ikonami:

Informace uvedené pod daným heslem se vztahují k operačnímu systému Windows 9x a Windows ME
Informace uvedené pod daným heslem se vztahují k operačnímu systému Windows NT, Windows 2000 a Windows XP

Systém OptimAccess® je určen pro operační systémy MS-DOS, Windows 3.x, Windows 9x, Windows ME, Windows NT, Windows 2000 a Windows XP. V dalších operačních systémech je použitelný s jistým omezením. S jeho specifiky pro jednotlivé operační systémy vás seznámí následující hesla:

  • MS-DOS, MS Windows 3.1x;
  • MS Windows 9x a ME;
  • MS Windows NT, 2000 a XP.

Podrobnější informace o možnostech síťového nasazení produktu naleznete pod heslem Nasazení v síti.


MS-DOS, MS Windows 3.1x

U počítačů, které mají instalovaný pouze Operační systém MS-DOS, Windows 3x, například technologie Tenkých klientů, které podporuje Windows 2000 Server, se může OptimAccess® ovládat a kompletně spravovat pomocí DOSového Ovládacího prostředí. Pro tuto platformu jsou dostupné pouze funkce modulu OptimAccess® Standard dle níže popsaných omezení.

Ovládací prostředí systému se spouští souborem Oa16.exe z adresáře, kde je aplikace nainstalována (pokud jste při instalaci neurčili jiný adresář, aplikace je instalována v adresáři C:\Program Files\OAx, kde x je číslo verze systému OptimAccess®).

Ovládání systému

Po zadání hesla se hlavní nabídka systému ovládá klávesou F10. V levé části modrého okna je adresářová struktura, ve které se správce může pohybovat pomocí kurzorových kláves. Příznak adresáře se mění kombinací kláves Ctrl a Enter. Pomocí klávesy Tab se přepíná kurzor mezi adresářovou a souborovou částí okna. Příznaky jednotlivých souborů se mění klávesou Enter. Všechny funkce systému jsou identické s modulem OptimAccess® Standard s výjimkou funkcí:

  • komplexní ochrany Registrační databáze;
  • ochrany Ovládacích panelů.

Podrobnější informace o možném nastavení jednotlivých funkcí systému OptimAccess® získáte pod heslem Ovládání aplikace ve Windows 9x/ME.


MS Windows 9x a ME

Pro platformu operačního systému Windows 9x jsou bez jakýchkoliv omezení ekvivalentní následující verze (jak česká, tak i anglická mutace):

  • Microsoft Windows 95;
  • Microsoft Windows 95 OSR2;
  • Microsoft Windows 98;
  • Microsoft Windows 98 SE;
  • Microsoft Windows ME.

Nápověda obsahuje kompletní popis průvodce, ovládacího prostředí a funkcí systému, modulů, doporučení a rad pro optimální nastavení. Podrobnější informace o jednotlivých tématech naleznete pod hesly:

  • Popis instalace systému plus další informace týkající se technické podpory a omezení systému naleznete pod heslem Začínáme s programem OptimAccess®.
  • Popis ovládacího rozhraní systému a konfigurace jeho funkcí naleznete pod heslem Ovládání aplikace ve Windows 9x/ME.
  • Popis ovládání a konfigurace jednotlivých modulů systému je obsažen pod heslem Moduly systému OptimAccess®.
  • Rady a doporučení výrobce pro optimální konfiguraci a vyladění systému naleznete pod heslem Doporučený postup konfigurace.
  • Informace o kolizích a řešení případných možných problémů jsou umístěny pod heslem Odstraňování problémů.
  • Vysvětlení základních pojmů s nimiž tato nápověda pracuje nalezne pod heslem Slovníček.


MS Windows NT, 2000 a XP

Pro platformu operačního systému Windows NT/2000/XP jsou bez jakýchkoliv omezení ekvivalentní následující verze (jak česká, tak i anglická mutace):

  • Microsoft Windows NT Workstation 4.0 s aktualizací Windows NT Service Pack 4 nebo vyšší (build 2195);
  • Microsoft Windows NT Server 4.0 s aktualizací Windows NT Service Pack 4 nebo vyšší (build 2195);
  • Microsoft Windows 2000 Professional;
  • Microsoft Windows 2000 Server;
  • Microsoft Windows 2000 Advanced Server;
  • Microsoft Windows XP Home Edition;
  • Microsoft Windows XP Professional.

Nápověda obsahuje kompletní popis průvodce, ovládacího prostředí a funkcí systému, modulů, doporučení a rad pro optimální nastavení. Podrobnější informace o jednotlivých tématech naleznete pod hesly:

  • Popis instalace systému plus další informace týkající se technické podpory a omezení systému naleznete pod heslem Začínáme s programem OptimAccess®.
  • Popis ovládacího rozhraní systému a konfigurace jeho funkcí naleznete pod heslem Ovládání aplikace ve Windows NT/2000/XP.
  • Popis ovládání a konfigurace jednotlivých modulů systému je obsažen pod heslem Moduly systému OptimAccess®.
  • Rady a doporučení výrobce pro optimální konfiguraci a vyladění systému OptimAccess® naleznete pod heslem Doporučený postup konfigurace.
  • Informace o kolizích a řešení případných možných problémů jsou umístěny pod heslem Odstraňování problémů.
  • Vysvětlení základních pojmů s nimiž tato nápověda pracuje nalezne pod heslem Slovníček.


Nasazení v síti

Systém OptimAccess® spolu s klienty pro vzdálenou správu podporují síťové prostředí postavené na protokolech TCP/IP.

Hromadná instalace

OptimAccess® podporuje vzdálenou hromadnou síťovou instalaci. Nakopírujete soubory na server a do přihlašovacího skriptu uživatelů zadáte patřičnou síťovou cestu k instalačním souborům. Snadno tak instalujete ochranný systém na jednotlivé pracovní stanice a aktivujete na stanicích klienta pro vzdálenou správu. Následně pak můžete jednotlivé stanice obejít, aktivovat a nakonfigurovat systém OptimAccess®. Mnohem pohodlnější je ovšem použití modulu OptimAccess Remote Control, který je určený pro vzdálenou správu.

Celý proces síťové instalace lze velmi detailně nakonfigurovat. Podrobný popis postupu síťové instalace systému naleznete pod heslem Síťová instalace.

Vzdálená správa

Pro plné využití síťových schopností systému OptimAccess® je třeba mít instalován modul OptimAccess® Remote Control, určený pro vzdálenou správu. Modul rozlišuje dvě platformy v závislosti na použitém operačním systému spravovaných počítačů, na kterých běží klient ochranného systému.

Detailní informace o možnostech a funkcích vzdálené správy systému OptimAccess® naleznete pod heslem OptimAccess® Remote Control.


Začínáme s programem OptimAccess®

Dříve než použijete systém OptimAccess® si pečlivě prostudujte Licenční ujednání. Naleznete jej na Registrační kartě a nebo jako přílohu příručky Začínáme se systémem OptimAccess®. Nesouhlasíte-li s ustanoveními tohoto ujednání, můžete produkt do 10-ti dnů od koupě vrátit oproti úhradě jeho ceny ze strany dodavatele.

Balení

Základním médiem pro distribuci systému OptimAccess® je disk CD-ROM. Distribuční balení produktu obsahuje:

  • disk CD-ROM s programem a elektronickou dokumentací;
  • Registrační kartu a Návratku registrační karty, obsahující licenční číslo, počet licencí produktu, informace o zakoupených nadstavbách ochranného systému a aktivační kód;
  • příručku Začínáme se systémem OptimAccess®, dodávanou ve formě bookletu.

Systémové požadavky

Po stránce hardwarových požadavků se nároky systému OptimAccess® nijak neliší od doporučených systémových požadavků pro daný operační systém. Základní instalace systému bez nadstavbových modulů vyžaduje 2,5 MB diskového prostoru. Plná instalace systému včetně všech nadstavbových modulů zabírá na pevném disku místo 10 MB.

Pokyny pro:

  • instalaci systému OptimAccess® naleznete pod heslem Instalace;
  • upgrade ze starší verze ochranného systému naleznete pod heslem Upgrade ze starších verzí;
  • informace o možnostech získání odborné pomoci a rady jak kontaktovat výrobce naleznete pod heslem Odborná pomoc.


Instalace

Systém OptimAccess® se instaluje také do systémových oblastí pevného disku a pro svou práci vyžaduje bezchybně funkční operační systém Windows. Z tohoto důvodu je nutné před započetím vlastní instalace sytému OptimAccess® provést následující kroky:

  • antivirovou kontrolu zvláště s ohledem na viry napadající zaváděcí oblast pevného disku (též označované jako Boot-viry);
  • kontrolu chyb povrchu disku, souborů a složek programem ScanDisk (spustíte jej tak, že klepnete na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Příslušenství, položku Systémové nástroje a klepnete na položku ScanDisk);
  • případně můžete optimalizovat rychlost načítání a spouštění programů pomocí programu Defragmentace disku (spustíte jej tak, že klepnete na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Příslušenství, položku Systémové nástroje a klepnete na položku Defragmentace disku);
  • zkontrolovat celkovou funkčnost operačního a Windows (systém je možné spustit, je v něm možné spouštět aplikace atd.);
  • zkontrolovat, zda všechny ovladače a zařízení pracují bez konfliktu a ve 32bitovém režimu (dialogové okno Systém můžete otevřít také tak, že klepnete na tlačítko Start, přejdete na příkaz Nastavení, zvolíte položku Ovládací panely a poklepete na ikonu Systém; informace o jednotlivých ovladačích zkontrolujete na kartě Správce zařízení);
  • v BIOSu zrušit detekci virů (nastavit položku Virus Warning na hodnotu Disabled);
  • po dobu instalace je rovněž doporučeno deaktivovat rezidentní části antivirů; je možné je znova aktivovat jakmile je systém OptimAccess® aktivní a jejich funkce nebudou nijak omezeny (postupujte dle dokumentace dodané výrobcem vámi používaného antivirového programu);
  • v případě že hodláte u ochranného systému používat funkci Komplexní ochrana Registrační databáze, nastavte rovněž operační systém podle vzoru na nějž se bude obnovovat při každém restartu.
  • Instalujete-li OptimAccess® do Windows 9x, musíte mít v systému nainstalovánu aplikaci Microsoft Internet Explorer 4.0 nebo vyšší. Jinak nebude možné spustit instalátor ochranného systému.

  • Instalujete-li OptimAccess® do Windows NT, Windows 2000 nebo Windows XP je nutné být přihlášen jako Administrátor.
  • Používáte-li Windows NT je potřeba mít instalovánu aktualizaci Windows NT Service Pack 4 nebo vyšší.

Po provedení výše uvedených kroků je váš operační systém připraven na korektní instalaci systému OptimAccess®. Pokyny pro vlastní instalaci systému na samostatný počítač jsou uvedeny pod heslem Instalace na samostatné PC. Tyto pokyny si přečtěte i v případě, hodláte-li instalovat systém OptimAccess® v rámci počítačové sítě. Další instalační pokyny specifické pro síťovou instalaci jsou uvedeny pod heslem Síťová instalace.


Instalace na samostatné PC

Po vložení CD-ROM disku s distribucí systému OptimAccess® se automaticky spustí Instalační program. Ten nakopíruje soubory potřebné pro systém OptimAccess® na pevný disk vašeho počítače a povede veškeré úpravy nutné pro jeho korektní funkci.

Nedojde-li po vložení disku k automatickému spuštění instalačního programu, máte na systému vypnutou funkci Automatické přehrávání disků CD po vložení do jednotky. Tuto funkci operačního systému můžete aktivovat následujícím postupem:

  1. Dialogové okno Systém - vlastnosti otevřete tak, že klepnete na tlačítko Start, přejdete na příkaz Nastavení, zvolíte položku Ovládací panely a poklepete na ikonu Systém.
  2. Klepněte na znaménko plus vedle složky CDROM, klepněte pravým tlačítkem myši na ikonu mechaniky u níž chcete funkci nastavit, a zvolte příkaz Vlastnosti.
  3. Klepněte na kartu Nastavení a zaškrtněte políčko Automatické oznámení.

Automatickému přehrávání CD-ROM disků můžete naopak zabránit tak, že při jejich vkládání stisknete klávesu SHIFT.

Obsah distribučního disku

Soubory potřebné pro instalaci systému OptimAccess® jsou v kořenovém adresáři distribučního média. Soubor s nápovědou je spolu s ostatními soubory tvořícími dokumentaci umístěn v adresáři DOC. Programy sloužící k podrobnější úpravě systému OptimAccess® jsou umístěny v adresáři UTIL. Nemáte-li absolutní jistotu o funkcích jednotlivých souborů, nespouštějte je. Vyhnete se tak případným problémům ve funkci ochranného systému.

Soubory z distribučního média je při dodržení Licenčního ujednání možné kopírovat na pevný disk počítače a instalaci pak následně provádět z pevného disku. Lze je zkopírovat i prostřednictvím počítačové sítě, například v případech, kdy je třeba instalovat systém na počítač bez CD-ROM mechaniky.

Manuální spuštění instalace

Manuálně lze instalaci spustit souborem Setup.exe z kořenového adresáře distribučního média.

Postup instalace

  1. Před vlastní instalací systému OptimAccess® je doporučeno ukončit všechny běžící aplikace.
  2. Po spuštění instalačního programu se zobrazí úvodní dialog se základními informacemi. Po jeho přečtení pokračujte v instalaci stiskem tlačítka Další >.
  3. Nyní se vás instalační program táže na souhlas s Licenčním ujednáním. Jeho tištěnou podobu můžete nalézt na Registrační kartě a nebo jako přílohu příručky Začínáme se systémem OptimAccess®. Po důkladném přečtení svůj souhlas můžete vyjádřit označením volby S licenčním ujednáním souhlasím a v instalaci pokračovat stiskem tlačítka Další >. Nesouhlasíte-li s ustanoveními Licenčního ujednání, ukončete instalaci stiskem tlačítka Storno. Tento krok povede k ukončení instalace.
  4. V dalším kroku instalace program zobrazí licenční číslo vámi zakoupené instalace produktu a vyžaduje od vás zadání aktivačního kódu. Jedná se o čtyři čtveřice složené z číslic 0 až 9 a znaku A až F. Spolu s licenčním číslem jej naleznete na Registrační kartě. Máte-li zakoupeno více různých licencí produktu (reprezentovaných více různými licenčními čísly), uvádějte vždy patřičný aktivační kód příslušející k danému licenčnímu číslu zobrazenému instalačním programem. V případě nesrovnalostí či rozhodnete-li se rozšířit svou stávající licenci o další nadstavby, kontaktujte výrobce dle pokynu uvedených pod heslem Odborná pomoc. Po vyplnění aktivačního kódu pokračujte v instalaci stiskem tlačítka Další >.
  5. V dalším kroku instalace se zobrazí seznam veškerých částí, které OptimAccess® má a jste oprávněni je na základě zakoupené licence instalovat. Jednotlivé části systému OptimAccess® k instalaci určíte označením patřičné volby. Vždy můžete instalovat jádro systému OptimAccess® označením volby OptimAccess® – ovládací aplikace. Dle vámi zakoupené licence je možné dále instalovat nadstavbové moduly systému představované volbami OptimAccess® Standard, OptimAccess® Extension, OptimAccess® Remote Control, OptimAccess® Computer Audit, OptimAccess® WorkSpy a OptimAccess® NetHand.

    • Modul Remote Control je nutné instalovat na všechny počítače a stanice, které mají být vzdáleně spravovány. Není-li tento modul na počítači instalován, není možné jej vzdáleně spravovat.

    Dále máte možnost zvolit adresář, kam bude systém OptimAccess® instalován. Můžete tak učinit přímo vypsáním do textového pole vedle tlačítka Nalistuj (přednastaven je adresář C:\Program Files\OAx, kde x představuje číslo verze ochranného systému OptimAccess®) či po stisku na tomto tlačítku vybrat zvolený adresář pomocí grafického dialogu.
  6. Dříve než začnete vlastní instalaci je vhodné provést zálohu zaváděcích sektoru pevného disku. Instalační program vám nabídne možnost vytvořit spouštěcí disketu a tuto zálohou. V případě nouze můžete s pomocí této diskety spustit operační systém a nouzově odinstalovat. Nehodláte-li tuto disketu vytvářet, postupujte dle kroku č. 8.
  7. Dialog Záložní disketa vám nyní nabízí možnost zálohovat systémové oblasti zaváděcích sektoru pevného disku a vytvořit spouštěcí disketu pro ochranný systém OptimAccess. Po označení volby Vytvořit záložní soubor máte možnost do textového pole pod touto volbou zadat název souboru se záložními daty. Neprovedete-li žádné úpravy, je přednastaveno jméno souboru BACKUP.000. Zálohu si můžete pojmenovat libovolně, doporučuje se však použít konvence max. 8 znaku pro jméno souboru a 3 pro příponu. Spouštěcí disketu vytvoříte označením volby Vygenerovat speciální bootovací disketu systému OptimAccess®. Označte tedy obě volby, vložte do mechaniky disketu a stiskněte tlačítko Provést.
  8. Nyní dochází ke zkopírování souborů systému OptimAccess® na pevný disk počítače dle dříve provedených nastavení.
  9. V závěrečné fázi instalace vás instalační program vyzve k zadání hesla pro přístup do ovládací aplikace systému. Heslo je nutné zadat a není možné použít prázdné heslo. Podrobnosti a náležitosti hesla naleznete v části Náležitosti a pravidla pro volbu hesla.
  10. Na závěrečném dialogu instalace vám instalační program oznámí, že celý proces kopírování souboru ochranného systému a jeho nastavení pro váš počítač proběhl úspěšně. Ukončete jej stiskem na tlačítko Dokončit.

Od tohoto okamžiku se proces instalace považuje za ukončený. Nyní jsou na pevném disku počítače nakopírovány všechny soubory potřebné pro korektní funkci systému OptimAccess®. Rovněž je nastaveno vstupní heslo pro spuštění ovládací aplikace systému OptimAccess®.

I přesto, že není po korektní instalaci systém aktivní, je v paměti počítače spuštěn klient pro vzdálenou správu. Klient se spouští a zavádí do paměti počítače při každém startu operačního systému. Tedy ihned po instalaci lze na počítači systém aktivovat vzdáleně, restartovat počítač a následně provést všechny požadované úpravy nastavení ochranného systému. Přirozeně se znalostí nastaveného hesla lze všechny tyto operace provést i na počítači samotném.
  • Instalujete-li OptimAccess® do Windows 9x, instalační program při svém ukončení automaticky spustí ovládací aplikaci OptimAccess® (soubor OaGUI.exe). Po zadání správného hesla pro přístup do ovládací aplikace zobrazí dialog oznamující, že systém je momentálně deaktivován. Stiskem tlačítka Ne můžete aktivaci odložit do okamžiku následujícího spuštění ovládací aplikace. Označením volby Příště tento dialog již nezobrazovat a stiskem tlačítka Ne odložíte aktivaci systému na později. Podrobnější informace o aktivaci systému OptimAccess® naleznete v následující sekci Aktivace systému.

Aktivace systému

Aby mohl systém OptimAccess® plnit svou funkci, je třeba jej aktivovat (at již vzdáleně s pomocí nadstavbového modulu Remote Control či přímo). Učiníte tak při prvním spuštění ovládací aplikace OptimAccess®. Naleznete ji mezi programy v nabídce Start ve skupině OptimAccess®. Je označena ikonou [image]. Systém aktivujete následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jejich vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. Systém není aktivní a ovládací aplikace to dá najevo dialogem oznamující, že systém OptimAccess® je momentálně deaktivován.
    Detailní nastavení speciálních funkcí systému můžete upravit po stisku tlačítka Rozšířené volby aktivace …; jedná se o technicky specifické nastavení ochranného systému, které je detailně popsáno v elektronické nápovědě systému OptimAccess®.
    Stiskem tlačítka Aktivuj systém OptimAccess® navoleným způsobem aktivujete. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  4. Systém provede svou aktivaci zápisem do konfiguračních souboru operačního systému a systémových oblastí pevného disku. Po úspěšné aktivaci se spustí ovládací aplikace OptimAccess®. Její popis naleznete v elektronické nápovědě.

Popis jednotlivých funkcí a prvků ovládací aplikace systému OptimAccess® je uveden pod heslem Ovládání aplikace ve Windows 9x/ME. V případě systému Windows NT, Windows 2000 a Windows XP naleznete popis funkcí systému a ovládací aplikace pod heslem Ovládání aplikace ve Windows NT/2000/XP.

Při nastavování jednotlivých funkcí samozřejmě můžete také vycházet z výrobcem doporučené optimální konfigurace. Rady pro optimální nastavení systému naleznete v odstavcích Doporučený postup konfigurace.


Síťová instalace

V prostředí počítačové sítě postavené na rodině síťových protokolu TCP/IP můžete hromadnou síťovou instalaci provést podle následujícího postupu (proměnná <localhost> představuje síťové jméno počítače z nějž hodláte instalovat). S výjimkou cílového adresáře musíte pro daný typ instalace vytvořit všechny zmiňované adresáře. Jejich pojmenování plně záleží na vaší benevolenci.

  1. Nejprve připravte adresář s instalačními soubory. Máte možnost instalovat:
    • z distribučního CD-ROM: vložte jej do mechaniky počítače z nějž hodláte instalovat a nasdílejte jej (například \\<localhost>\cd).
    • ze síťového adresáře: na počítači z nějž hodláte instalovat vytvořte sdílený adresář s právem pouze pro čtení. Do tohoto adresáře pak po síti nakopírujte obsah instalačního CD (například \\<localhost>\install_oa).
  2. Dále připravte adresář pro soubor protokolu a konfigurační soubory. Nezapomeňte jej nasdílet i pro zápis, jestliže do něj budete ukládat soubor protokolu. V případě, kdy instalujete ze síťového adresáře, je vhodné umístit jej jako podadresář (například \\<localhost>\install_oa\log).
  3. Instalujte systém OptimAccess® na jeden počítač a nastavte při instalaci vstupní heslo pro ovládací aplikaci systému OptimAccess®. Pokyny a postup pro instalaci naleznete pod heslem Instalace na samostatné PC v sekci Postup instalace. Nezapomeňte rovněž nastavit heslo pro klienta vzdálené správy, jestliže jej chcete používat.
  4. Do adresáře připraveného pro soubor protokolu a konfigurační soubory podle kroku č. 2 nakopírujte soubor s heslem pro ovládací aplikaci Oa9.dat. Tento soubor naleznete v adresáři, kam jste instalovali systém dle pokynů v bodu č. 3 tohoto postupu.
  5. Upravte konfigurační soubor Setup.ini. Jeho zdrojovou podobu naleznete na distribučním CD-ROM. Upravený soubor uložte do adresáře pro soubor protokolu a konfigurační soubory - tj. \\<localhost>\install_oa\log\setup.ini.

    Soubor Setup.ini je velmi dobře komentován. Řádky začínající středníkem jsou považovány za komentáře. V původním souboru Setup.ini jsou všechny záznamy se vzorovým nastavením (s výjimkou označení konfigurační sekce) zakomentovány. Nezapomeňte proto mimo správné nastavení jednotlivých konfiguračních voleb ze začátku příslušných řádků středníky odstranit.

    Po úpravě by soubor Setup.ini měl mít přibližně následující podobu:

    ;Konfigurační soubor pro vzdálenou instalaci ochranného systému OptimAccess verze 9.0
;
;Pokud chcete provést automatickou instalaci podle parametrů nastavených v tomto souboru
;spusťte program SETUP.EXE se jménem tohoto souboru. Pokud se soubor nenachází
;v adresáři, ze kterého se spouští program SETUP.EXE, pak uveďte celou cestu k tomuto
;INI souboru.
;

;Všechny parametry se nastavují v části [remote], nemusíte dodržovat velká a malá písmena.
[remote]

;AC - Aktivační kód, vložte kód z licenční karty
AC=879E5BA9C21DEC4

;DestPath - Cesta, do které se bude instalovat ochranný systém. implicitně je nastavena
;na C:\OA9. Cesta musí být na disk C a doporučujeme  ponechat adresář přímo v C:\
DestPath=C:\OA9

;SourcePath - z této cesty se budou kopírovat soubory ochranného systému
SourcePath=\\<localhost>\install_oa

;LogFile - plná cesta k souboru, do kterého se budou ukládat informace o provedených
;operacích. Soubor se ukládá v CSV formátu pro možnost prohlížení např. v MS-EXCEL.
;Doporučujeme ponechat příponu CSV.
LogFile=\\<localhost>\install_oa\log\oalog.csv

;OADAT - cesta k souboru OA9.DAT, ve kterém se nachází heslo pro použití programu OAGUI.EXE,
;což je lokální ovládací prostředí ochranného systému.
OADAT=\\<localhost>\install_oa\log\oa9.dat

;StartMenu - pokud se rovná 1, pak se vytvoří v Nabídce Start odkaz na ochranný systém
;OptimAccess
StartMenu=1
  6. Síťovou hromadnou instalaci provedete na jednotlivých stanicích spuštěním souboru Setp.exe z adresáře s instalačními soubory, kterému zadáte jako parametr soubor Setup.ini.

    Instalujete-li podle tohoto postupu z jednotky CD-ROM, spustíte instalaci příkazem:
    \\<localhost>\cd\setup.exe \\<localhost>\install_oa\log\setup.ini
    Instalujete-li ze síťového adresáře, spustíte instalaci příkazem:
    \\<localhost>\install_oa\setup.exe \\<localhost>\install_oa\log\setup.ini
  7. Instalátor nyní nakopíruje na stanici všechny soubory systému OptimAccess®, upraví konfiguraci stanice podle nastavení vzorové instalace a spustí na stanici klienta pro vzdálenou správu. Následně tedy můžete nastavovat systém OptimAccess® přímo na stanici či prostřednictvím aplikace pro vzdálenou správu.


Upgrade ze starších verzí

Pro upgrade ze systému OptimAccess® verze 8.0 je možné spustit instalační program a postupovat podle návodu a doporučení instalačního programu.

Pro upgrade z verzí systému OptimAccess® starších než je verze 8.0 výrobce doporučuje použít následující postup:

  1. Deaktivovat ochranný systém.
  2. Odinstalovat starou verzi ochranného systému.
  3. Instalovat novou verzi systému dle postupů uvedených pod heslem Instalace.
  4. Případně můžete vyladit konfiguraci systému dle rad a doporučení uvedených pod heslem Doporučený postup konfigurace.


Odborná pomoc

Zakoupením licence k používání aplikace OptimAccess® získáváte rovněž nárok na odbornou pomoc od společnosti SODAT software spol. s r. o. Tato se vztahuje na dotazy a řešení problémů spojených s používáním systému OptimAccess®.

Dříve než kontaktujete výrobce ...

Odpovědi na základní a běžné uživatelské otázky jsou uvedeny rovněž v této nápovědě. Prostředky vynaložené na telefon můžete ušetřit, jestliže se pokusíte odpověď na své otázky nejprve najít v heslech nápovědy.

  • Význam a nastavení jednotlivých funkcí systému je vysvětlen v heslech Ovládání aplikace ve Windows 9x/ME, Ovládání aplikace ve Windows NT/2000/XP a Nadstavbové moduly systému OptimAccess®.
  • Rady a doporučení pro základní nastavení systému OptimAccess® obsahuje heslo Doporučený postup konfigurace.
  • Informace o kolizích a řešení případných možných známých problémů jsou umístěny pod heslem Odstraňování problémů.

Jak získat odbornou pomoc?

Odbornou pomoc od společnosti SODAT software spol. s r. o. lze získat následujícími způsoby:

  • Základní odborné informace lze získat prostřednictvím WWW stránek věnovaných systému OptimAccess® na adrese http://www.optimaccess.cz/.
  • Svůj dotaz na oddělení technické podpory můžete zaslat prostřednictvím elektronické pošty na adresu support@optimaccess.cz.
  • Odpověď na své dotazy můžete také získat prostřednictvím telefonu přímo od pracovníka technické podpory a to na čísle +420 - 543 236 177 až 8; standardní bezplatná technická pomoc je výrobcem poskytována v pracovní dny (tj. v pondělí až pátek s výjimkou svátků) a to vždy od 8:00 do 16:30.
  • V případě zákazníků, kteří mají s výrobcem uzavřenu dodatečnou Servisní smlouvu o odborné pomoci a technické podpoře platí dále veškerá ustanovení v ní uvedená.

Jak kontaktovat výrobce?

S dalšími dotazy a náměty v souvislosti se systémem OptimAccess® můžete společnost SODAT software spol. s r. o. kontaktovat následujícími způsoby:

  • Písemně na adresu: SODAT software spol. s r. o., Sedlákova 33, 602 00 BRNO.
  • Elektronickou poštou na adresu info@optimaccess.cz.
  • Telefonicky na čísle +420 - 543 236 177 až 8; v pracovní dny (tj. v pondělí až pátek s výjimkou svátků) a to vždy od 8:00 do 16:30.


Ovládání aplikace ve Windows 9x/ME

Ovládací aplikace se v operačním systému Windows 9x či Windows ME spouští prostřednictvím souboru OAGUI.exe z adresáře, kde je instalován systém OptimAccess® (základní nastavení pro instalaci je C:\Program Files\OAx, kde x je číslo verze systému OptimAccess®). Při instalaci je v nabídce Start systému Windows vytvořen odpovídající zástupce pojmenovaný OptimAccess®. Ovládací aplikaci lze tedy spustit i následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.

Ovládání funkcí systému OptimAccess® prostřednictvím aplikace

  • Postup pro aktivaci a deaktivaci systému naleznete pod heslem Aktivace a deaktivace systému OptimAccess®.
  • Rady a postupy potřebné pro zálohu nastavení systému a následný import zálohy naleznete pod heslem Zálohování a obnova nastavení systému OptimAccess®.
  • Popis náležitostí a požadavků pro správně zvolené heslo a postup pro jeho nastavení naleznete pod heslem Změna hesla pro přístup do systému OptimAccess®.
  • Popis skupin uživatelů systému OptimAccess® a postup pro vytváření a editaci nových uživatelů systému OptimAccess® naleznete pod heslem Uživatelé systému OptimAccess®.
  • Popis funkcí a ovládacích prvků pro jednotlivé moduly systému OptimAccess® naleznete pod heslem Moduly systému OptimAccess®.


Aktivace a deaktivace systému OptimAccess®

Při aktivaci ovladačů se modifikuje zavaděč pevného disku tak, aby se v okamžiku spuštění počítače automaticky aktivovaly všechny nastavené ochranné funkce. Je-li systém OptimAccess aktivní, máte možnost jeho jednotlivé ochranné funkce přizpůsobovat vašim aktuálním požadavkům na ochranu počítače. Vzhledem k tomu, že systém pracuje se zavaděčem pevného disku, je pro aktivaci systému nutný restart počítače. Ten provedete stiskem tlačítka OK v dialogu zakončujícím aktivační proceduru.

V případě, že nejsou ve vnitřní paměti (RAM) počítače zavedeny ovladače nebo je ochranný systém právě nainstalován, se aktivační procedura vyvolá při každém spuštění aplikace OptimAccess (souborem OAGUI.exe).

Aktivace ochranného systému při spuštění ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. Po zadání správného hesla pro přístup do ovládací aplikace zobrazí dialog oznamující, že systém OptimAccess® je momentálně deaktivován. Stiskem tlačítka Ne můžete aktivaci odložit do okamžiku následujícího spuštění ovládací aplikace. Označením volby Příště tento dialog již nezobrazovat a stiskem tlačítka Ne odložíte aktivaci systému OptimAccess® na později.
  4. Systém OptimAccess® provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Aktivace systému z ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Systém OptimAccess® aktivujete stiskem na tlačítko Aktivovat systém OptimAccess®... v oblasti Stav systému OptimAccess®.
  5. Při aktivaci máte možnost načíst nastavení funkcí systému OptimAccess® ze souboru. V dialogu Aktivace systému OptimAccess® označte stiskem myši volbu Načíst nastavení systému OptimAccess® ze souboru. V dialogu Otevřít vylistujte příslušný soubor s nastavením.
  6. Systém OptimAccess® provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Deaktivace systému OptimAccess®

Deaktivace systému OptimAccess® má za následek odstranění aktivních ovladačů z vnitřní paměti (RAM) počítače. Výsledkem je vypnutí všech ochran realizovaných systémem OptimAccess®. Funkce opět vyvolá dialog s informací o nutnosti provedení restartu počítače. Po restartu je váš systém zcela bez ochrany.

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Systém OptimAccess® deaktivujete stiskem na tlačítko Deaktivovat systém OptimAccess®... v oblasti Stav systému OptimAccess®.
  5. Hodláte-li opravdu systém OptimAccess® deaktivovat potvrďte to v dialogu stiskem tlačítka Ano. Stiskem tlačítka Ne ukončíte plánovanou deaktivaci a systém zůstane aktivní.
  6. Při deaktivaci máte možnost uložit nastavení funkcí systému do souboru. V dialogu Deaktivace systému OptimAccess® označte stiskem myši volbu Uložit nastavení systému OptimAccess® do souboru. Do dialogu Uložit zadejte jméno příslušného souboru s nastavením.
  7. Systém OptimAccess® provede svou deaktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou deaktivaci je nutný restart počítače. Ovládací aplikace informuje o úspěšné deaktivaci systému dialogem Deaktivace systému. Stiskem tlačítka OK provedete restart počítače.

Příkaz je vhodný použít zejména při plánovaných rozsáhlých instalacích programového vybavení, které s sebou nesou nutnost větších zásahů do konfigurace operačního systému a aktualizovaných aplikací.


Zálohování a obnova nastavení systému OptimAccess®

Záloha čerstvě instalovaného systému

Ihned po instalaci systému OptimAccess® si proveďte zálohu základního nastavení. Využijete je například v případě rozsáhlejších instalací či případných updatů operačního systému. Více informací naleznete pod heslem Doporučený postup konfigurace.

Export nastavení do souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Exportovat nastavení do souboru ... pod oblastí Stav systému OptimAccess®.
  5. V dialogu Export nastavení systému OptimAccess® stiskněte tlačítko Nalistovat a v dialogu Otevřít vylistujte příslušný soubor pro uložení nastavením. V oblasti Soubor s nastavením bude obsahovat tyto části zvolte nastavení kterých modulů má být exportováno. Rovněž lze vyexportovat nastavení pro adresářovou strukturu.
  6. Po volbě souboru a nastavení exportu zahájíte export dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.

Import nastavení ze souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Importovat nastavení ze souboru ... pod oblastí Stav systému OptimAccess®.
  5. V dialogu Otevřít vylistujte soubor s nastavením ochranného systému, které chcete importovat. Složku se souborem můžete vylistovat pomocí rozvíracího seznamu Oblast hledání či ji poklepáním v oblasti dialogu. Rovněž můžete jméno souboru včetně cesty zadat do pole Název souboru. V případě komplikací si neopomeňte zkontrolovat, zdali máte v seznamu Soubory typu: nastavený správný typ souboru.
  6. Po volbě souboru zahájíte import dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.


Změna hesla pro přístup do systému OptimAccess®

Heslo nastavené pro ovládací aplikaci systému OptimAccess® je vyžadováno při jeho každém spuštění. Bez jeho znalosti nelze ovládací aplikaci spustit.

Nastavení hesla pro spouštění ovládací aplikace

Se znalostí stávajícího hesla můžete nové heslo nastavit tímto způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. Z nabídky Správce zvolte příkaz Změna vstupního hesla ....
  4. V dialogu Změna hesla zadejte do textových polí Původní heslo, Nové heslo a Potvrzení nového hesla původní a vámi požadované heslo a stiskněte tlačítko OK.
  5. Zadali-li jste do obou polí s novým heslem stejný alfanumerický řetězec, systém změní přístupové heslo a informuje vás o tom dialogem Přístupové heslo OptimAccess® s textem Heslo bylo změněno. Ukončete jej stiskem tlačítka OK. V případě, kdy se vámi zadané řetězce liší, informuje vás o této situaci systém dialogem Přístupové heslo OptimAccess® s textem Potvrzené heslo je odlišné od hesla nového. Zadejte heslo znovu. Stiskněte tlačítko OK a pokračujte podle bodu č. 4.

Náležitosti a pravidla pro volbu hesla

Pro zadávání hesla platí následující omezení:

  • heslo se skládá z alfanumerických znaků;
  • heslo rozlišuje malá a velká písmena (vlastnost nazývaná též case-sensitivity);
  • nelze použít prázdné heslo, je nutné zadat minimálně jeden znak;
  • maximální délka hesla je omezena na 20 znaků.

Je vhodné volit heslo tak, aby jej potenciální útočnici nemohli snadno hádáním odhalit. Tudíž za heslo nevolte své křestní jméno, název firmy či jiné potenciálním útočníkům známé skutečnosti. Rovněž není vhodné používat hesla, která jsou snadno odhalitelné pomocí „slovníkového útoku“. Správné heslo by se mělo skládat přibližně z osmi náhodně zkombinovaných alfanumerických znaků.


Uživatelé systému OptimAccess®

Systém OptimAccess® rozeznává čtyři možné skupiny uživatelů ovládacího prostředí OptimAccess®:

  • Správce ochranného systému OptimAccess® - představuje roli administrátora systému OptimAccess® (v praxi ideálně reprezentovanou bezpečnostním administrátorem). Tento uživatel je schopen provádět veškeré akce se systémem OptimAccess® bez jakéhokoliv omezení.
  • Správce nastavení počítačů (R1) - uživatel je schopen provádět všechny akce co Správce ochranného systému OptimAccess® kromě správy uživatelů systému OptimAccess®
  • Správce lokální stanice (R2) - uživatel je schopen provádět všechny akce co Správce nastavení počítačů kromě správy okolních stanic.
  • Správce nasbíraných dat (R3) - uživatel je schopen pouze číst nasbíraná logovaná data z lokální ale i z okolních stanic a z nich vytvářet reporty, grafy a provádět jiné databázové operace.

Pro manipulaci s uživateli systému OptimAccess® použijte následující postup:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jejich vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V hlavním menu aplikace zvolte možnosti Správce->Správa uživatelů.

Zobrazí se okno se seznamem uživatelů. Seznam uživatelů systému OptimAccess® lze měnit pomocí tlačítek :

  • Přidat - zobrazí se dialog pro nastavení vlastností vybraného uživatele. Je nutné zadat uživatelovo jméno a jeho zařazení do skupiny. Po tomto dialogu následuje dialog pro nastavení hesla, kterým se bude daný uživatel hlásit do systému.
  • Odebrat - odebere vybraného uživatele ze seznamu.
  • Vlastnost - zobrazí se dialog pro změnu vlastností vybraného uživatele. Můžete změnit uživatelovo jméno a jeho zařazení do skupiny.
  • Změnit heslo - zobrazí se dialog pro změnu hesla vybraného uživatele.

Přihlášení vytvořeného uživatele systému OptimAccess®

Se znalostí správného jména a hesla je možné přihlásit se do ovládajícího prostředí systému OptimAccess® tímto způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Odtrhněte volbu Správce OptimAccess® a do textového pole Uživatelské jméno napište jméno uživatele OptimAccess® pod kterým se chcete přihlásit.
  3. Do textového pole Heslo napište heslo přiřazené tomuto uživateli a stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  4. Pokud jste zadali správnou kombinaci uživatelské jméno/ heslo zobrazí se vám ovládací aplikace s možnostmi a ikonami ke kterým máte v rámci uživatelovi skupiny přístup.


Ovládání aplikace ve Windows NT/2000/XP

Ovládací aplikace se v operačním systému Windows 2000 a Windows NT spouští prostřednictvím souboru OAGUI.exe z adresáře, kde je instalován systém OptimAccess® (základní nastavení pro instalaci je C:\Program Files\OAx, kde x je číslo verze systému OptimAccess®). Při instalaci je v nabídce Start systému Windows vytvořen odpovídající zástupce pojmenovaný OptimAccess®. Ovládací aplikaci lze tedy spustit i následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.

Ovládání funkcí systému OptimAccess® prostřednictvím aplikace

  • Postup pro aktivaci a deaktivaci systému OptimAccess® naleznete pod heslem Aktivace a deaktivace systému OptimAccess®.
  • S principem logiky ochrany systémů Windows 2000 a Windows NT založeném na uživatelských účtech a jeho ovládání se seznámíte pod heslem Koncepce uživatelů.
  • Rady a postupy potřebné pro zálohu nastavení systému OptimAccess® a následný import zálohy naleznete pod heslem Export a import nastavení systému OptimAccess®.
  • Popis náležitostí a požadavků pro správně zvolené heslo a postup pro jeho nastavení naleznete pod heslem Změna hesla pro přístup do ovládacího prostředí.
  • Popis skupin uživatelů systému OptimAccess® a postup pro vytváření a editaci nových uživatelů systému OptimAccess® naleznete pod heslem Uživatelé systému OptimAccess®.
  • Popis funkcí a ovládacích prvků pro jednotlivé moduly systému OptimAccess® naleznete pod heslem Moduly systému OptimAccess®.


Aktivace a deaktivace systému OptimAccess®

Při aktivaci ovladačů se modifikuje zavaděč pevného disku tak, aby se v okamžiku spuštění počítače se automaticky aktivovaly všechny nastavené ochranné funkce. Je-li systém OptimAccess aktivní, máte možnost jeho jednotlivé funkce přizpůsobovat vašim aktuálním požadavkům na nastavení počítače. Vzhledem k tomu, že systém pracuje se zavaděčem pevného disku, je pro aktivaci systému nutný restart počítače. Ten provedete stiskem tlačítka OK v dialogu zakončujícím aktivační proceduru.

V případě, že nejsou ve vnitřní paměti (RAM) počítače zavedeny ovladače nebo je ochranný systém právě nainstalován, se aktivační procedura vyvolá při každém spuštění aplikace OptimAccess (souborem OAGUI.exe).

Aktivace systému OptimAccess® při spuštění ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. Po zadání správného hesla pro přístup do ovládací aplikace zobrazí dialog oznamující, že systém je momentálně deaktivován. Stiskem tlačítka Ne můžete aktivaci odložit do okamžiku následujícího spuštění ovládací aplikace. Označením volby Příště tento dialog již nezobrazovat a stiskem tlačítka Ne odložíte aktivaci systému OptimAccess® na později.
  4. Systém OptimAccess® provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Aktivace systému OptimAccess® z ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Systém OptimAccess® aktivujete stiskem na tlačítko Aktivovat systém OptimAccess®... v oblasti Stav systému OptimAccess®.
  5. Při aktivaci máte možnost načíst nastavení funkcí systému OptimAccess® ze souboru. V dialogu Aktivace systému OptimAccess® označte stiskem myši volbu Načíst nastavení systému OptimAccess® ze souboru. V dialogu Otevřít vylistujte příslušný soubor s nastavením.
  6. Systém OptimAccess® provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Deaktivace systému OptimAccess®

Deaktivace systému OptimAccess® má za následek odstranění aktivních ovladačů z vnitřní paměti (RAM) počítače. Výsledkem je vypnutí všech ochran realizovaných systémem OptimAccess®. Funkce opět vyvolá dialog s informací o nutnosti provedení restartu počítače. Po restartu je váš systém zcela bez ochrany.

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Systém OptimAccess® deaktivujete stiskem na tlačítko Deaktivovat systém OptimAccess®... v oblasti Stav systému OptimAccess®.
  5. Hodláte-li opravdu systém OptimAccess® deaktivovat potvrďte to v dialogu stiskem tlačítka Ano. Stiskem tlačítka Ne ukončíte plánovanou deaktivaci a systém zůstane aktivní.
  6. Při deaktivaci máte možnost uložit nastavení funkcí systému OptimAccess® do souboru. V dialogu Deaktivace systému OptimAccess® označte stiskem myši volbu Uložit nastavení systému OptimAccess® do souboru. Do dialogu Uložit zadejte jméno příslušného souboru s nastavením.
  7. Systém OptimAccess® provede svou deaktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou deaktivaci je nutný restart počítače. Ovládací aplikace informuje o úspěšné deaktivaci systému dialogem Deaktivace systému. Stiskem tlačítka OK provedete restart počítače.

Příkaz je vhodný použít zejména při plánovaných rozsáhlých instalacích programového vybavení, které s sebou nesou nutnost větších zásahů do konfigurace operačního systému a aktualizovaných aplikací.


Koncepce uživatelů

S použitím bezpečnostní politiky operačních systémů Windows NT, Windows 2000 a Windows XP máte možnost nastavovat jednotlivé funkce systému OptimAccess® na úrovni globálního nastavení stanice a nastavení jednotlivých uživatelských účtů. V tomto uvedeném pořadí se aplikuje nastavení jednotlivých funkcí systému OptimAccess®.

Po spuštění ovládací aplikace tedy poklepáním na ikonu plus vedle síťového jména počítače ( [image]) vylistujete globálního nastavení stanice, seznam všech skupin a seznam všech uživatelských účtů. Jednotlivé typy nastavení jsou graficky odlišeny:

  • Globální nastavení stanice – je obecně platná sada nastavení funkcí systému OptimAccess® pro konkrétní počítač či pracovní stanici. Toto nastavení je platné pro všechny skupiny a uživatele, pokud nemají své vlastní individuální nastavení.
  • Individuální nastavení uživatelů – obsahuje všechny uživatelské účty dostupné na počítači či pracovní stanici. Jsou zde rovněž obsaženy všechny doménové účty, pro něž jsou na stanici vytvořeny profily.

Stiskem na ikonu plus vedle příslušné volby vylistujete seznam modulů, které máte možnost nastavovat. Příslušné ovládací prvky pro nastavování jednotlivých voleb naleznete v pravém okně ovládací aplikace.

Chcete-li nastavovat funkce na úrovni jednotlivých skupin či uživatelských účtů, je vždy třeba v pravém okně ovládací aplikace po vylistování příslušného účtu označit volbu Individuální nastavení. Není-li tato volba označena, jsou všechny ovládací prvky v pravém okně dočasně nepřístupné.

Specifika účtu „Nový uživatel“ či „Default user“

Ačkoliv je účet „Nový uživatel“ (či „Default user“ na anglických mutacích systému) vedený jako běžný uživatelský účet, vyznačuje se jednou specifickou vlastností. Vytváříte-li v systému nového uživatele, základní nastavení nového uživatelského účtu bude okopírováno dle nastavení tohoto účtu.


Export a import nastavení systému OptimAccess®

Záloha čerstvě instalovaného systému

Ihned po instalaci systému OptimAccess® si proveďte zálohu základního nastavení. Využijete je například v případě rozsáhlejších instalací či případných updatů operačního systému. Více informací naleznete pod heslem Doporučený postup konfigurace.

Export nastavení do souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Exportovat nastavení do souboru ... pod oblastí Stav systému OptimAccess®.
  5. V dialogu Export nastavení systému OptimAccess® stiskněte tlačítko Nalistovat a v dialogu Otevřít vylistujte příslušný soubor pro uložení nastavením. V oblasti Soubor s nastavením bude obsahovat tyto části zvolte nastavení kterých modulů má být exportováno.
  6. Po volbě souboru a nastavení exportu zahájíte export dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.

Import nastavení ze souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Importovat nastavení ze souboru ... pod oblastí Stav systému OptimAccess®.
  5. V dialogu Otevřít vylistujte soubor s nastavením systému OptimAccess®, které chcete importovat. Složku se souborem můžete vylistovat pomocí rozvíracího seznamu Oblast hledání či ji poklepáním v oblasti dialogu. Rovněž můžete jméno souboru včetně cesty zadat do pole Název souboru. V případě komplikací si neopomeňte zkontrolovat, zdali máte v seznamu Soubory typu: nastavený správný typ souboru.
  6. Po volbě souboru zahájíte import dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.


Změna hesla pro přístup do ovládacího prostředí

Heslo nastavené pro ovládací aplikaci systému OptimAccess® je vyžadováno při jeho každém spuštění. Bez jeho znalosti nelze ovládací aplikaci spustit.

Nastavení hesla pro spouštění ovládací aplikace

Se znalostí stávajícího hesla můžete nové heslo nastavit tímto způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. Z nabídky Správce zvolte příkaz Změna vstupního hesla ....
  4. V dialogu Změna hesla zadejte do textových polí Původní heslo, Nové heslo a Potvrzení nového hesla původní a vámi požadované heslo a stiskněte tlačítko OK.
  5. Zadali-li jste do obou polí s novým heslem stejný alfanumerický řetězec, systém změní přístupové heslo a informuje vás o tom dialogem Přístupové heslo OptimAccess® s textem Heslo bylo změněno. Ukončete jej stiskem tlačítka OK. V případě, kdy se vámi zadané řetězce liší, informuje vás o této situaci systém dialogem Přístupové heslo OptimAccess® s textem Potvrzené heslo je odlišné od hesla nového. Zadejte heslo znovu. Stiskněte tlačítko OK a pokračujte podle bodu č. 4.

Náležitosti a pravidla pro volbu hesla

Pro zadávání hesla platí následující omezení:

  • heslo se skládá z alfanumerických znaků;
  • heslo rozlišuje malá a velká písmena (vlastnost nazývaná též case-sensitivity);
  • nelze použít prázdné heslo, je nutné zadat minimálně jeden znak;
  • maximální délka hesla je omezena na 20 znaků.

Je vhodné volit heslo tak, aby jej potenciální útočnici nemohli snadno hádáním odhalit. Tudíž za heslo nevolte své křestní jméno, název firmy či jiné potenciálním útočníkům známé skutečnosti. Rovněž není vhodné používat hesla, která jsou snadno odhalitelné pomocí „slovníkového útoku“. Správné heslo by se mělo skládat přibližně z osmi náhodně zkombinovaných alfanumerických znaků.


Moduly systému OptimAccess®

V rámci modulárního pojetí systému OptimAccess® je možné zvolit si funkce na míru dle vašich konkrétních požadavků. Máte možnost využít modulů:

  • OptimAccess® Standard - slouží pro základní zabezpečení programů a operačního systému instalovaného na pracovní stanici. Nabízí funkce pro ochranu adresářové struktury, ochranu nastavení operačního systému Windows, zamezení instalace programů a přístupu k souborům, zákaz manipulace a vytváření konkrétních souborů či typů a kontrolu manipulace s výměnnými médii. Uplatnění modulu je všude tam, kde počítače sdílí více uživatelů či jsou nutné jejich časté reinstalace z důvodu neautorizovaných zásahů do nastavení a úprav programového vybavení.
  • OptimAccess® Extension - rozšiřuje ochranné funkce modulu Standard v oblastech operačního systému Windows (Ovládací panely, Průzkumník a složky, nastavení uživatelských aplikací a bezpečnostní funkce). Nabízí pokročilé ochranné funkce i pro aplikační vybavení počítače a zohledňuje bezpečnostní rozměr kontroly správného využívání hesel.
  • OptimAccess® Remote Control - je nástroj pro administraci, konfiguraci a centrální správu ochranného systému. Umožňuje vzdáleně sledovat a upravovat nastavení jednotlivých koncových stanic i celých skupin počítačů. Kopíruje topologii sítě a nabízí možnost řazení počítačů do skupin v Databázi okolních počítačů. Prostřednictvím přehledného grafického rozhraní lze rychle a efektivně sledovat i nastavovat desítky, stovky či tisíce instalací systému na koncových stanicích. Přínosem je také možnost časového plánování těchto akcí.
  • OptimAccess® Computer Audit - Modul OptimAccess® Computer Audit představuje účinný nástroj pro evidenci a sledování stavu programového a hardwarového vybavení počítačů a počtu instalovaných licencí vybraného software v organizaci. Předností je transparentnost řešení a možnost získat informace o stanicích v každém okamžiku a provést jejich porovnání s kterýmkoliv z předchozích nebo výchozích stavů. OptimAccess® Computer Audit je významným pomocníkem pro pracovníky starající se o licenční podmínky nabytého softwaru a o hardwarové vybavení stanic organizace. Způsob provádění softwarového a hardwarového auditu je certifikován a je ve shodě s pravidly, zásady a způsobem zabezpečení kontroly užívání počítačových programů dle usnesení vlády č. 624.
  • OptimAccess® WorkSpy - Modul OptimAccess® WorkSpy má za úkol monitorovat veškeré aktivity spojené s prací uživatelů na pracovních stanicích. Pomocí svých nastavení je schopen nejen činnosti monitorovat, archivovat a vyhodnotit, ale v případě nutnosti na ně i patřičně reagovat. Reakcí může být např. zaslání e-mailu nebo jiného mechanismu s upozorněním správci systému v případě výskytu definovaných akcí provedených uživatelem nebo aplikací na pracovních stanicích. OptimAccess® WorkSpy má v rámci svých funkcí dva druhy uplatnění. Předně jej využije management organizace, který je schopen z nasbíraných dat získávat tiskové sestavy o využitelnosti pracovních stanic a tím efektivně plánovat rozdělení firemních zdrojů, popř. rozhodnutí o nákupu dalšího vybavení. Naproti tomu je možné využít funkce modulu WorkSpy k detekci potenciálně nebezpečných aktivit, kterou využijí především správci bezpečnostní politiky a vnitřní kontroly.
  • OptimAccess® NetHand - je určen pro vzdálenou administraci stanic pomocí převzetí obrazovky a dávkovou distribuci software. OptimAccess® NetHand najde uplatnění především u pracovníků oddělení HelpDesku řešících technické problémy na vzdálených stanicích, kde je nutný přímý zásah na stanici. Takto jsou schopni vyřešit problém bez nutnosti dojezdu na místo. Správci softwarového vybavení starající se o instalaci nového softwaru a udržování updatů jednotlivých softwarů zužitkují možnost hromadně distribuovat a instalovat software nebo jejich aktualizace na všechny pracovní stanice v organizaci bez nutné přítomnosti u takovéto pracovní stanice.


OptimAccess® Standard

Modul slouží pro základní zabezpečení programů a operačního systému instalovaného na pracovní stanici. Nabízí tyto funkce:

  • Ochrana adresářové struktury – jednotlivé složky lze nastavit jako neporušitelné (vždy se uvádějí do původního stavu) či s právem pouze ke čtení.
  • Ochrana nastavení operačního systému Windows – uživateli lze znepřístupnit jednotlivé Ovládací panely.
  • Komplexní ochrana registrační databáze – při restartu počítače se veškerá nastavení uvádí zpět do předem definovaného stavu.
  • Zamezení instalace programů a přístupu k instalačním souborům – není možné spuštění instalačních programů.
  • Zákaz manipulace a vytváření konkrétních souborů či typů (*.exe, *.com, *.bat, *.vbs, *.dll)
  • Kontrola manipulace s výměnnými médii – lze definovat které výměnné disky (CD, ZIP, FDD,...) se mohou na počítači použít.

Uplatnění modulu OptimAccess® Standard je všude tam, kde počítače sdílí více uživatelů či jsou nutné jejich časté reinstalace z důvodu neautorizovaných zásahů do nastavení a úprav programového vybavení.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul Standard ovládá prostřednictvím aplikace OptimAccess® následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Standard vylistujete jednotlivé volby a nastavení modulu OptimAccess® Standard.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul Standard pro konkrétního uživatele ovládá pomocí nabídky Standard v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce systému OptimAccess® nastavovat – globální nastavení stanice a seznam uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu Standard. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem Standard.

Volby modulu Standard

  • Výměnná média
  • Obnova souborů a adresářů
  • Obnova registračních položek
  • Omezení přístupu k souborům
  • Omezení přístupu k adresářům
  • Ovládací panely
  • Administrátorská nastavení
  • Komplexní ochrana nastavení
  • Adresářová struktura


Manipulace s výměnnými médii

Systém OptimAccess® nabízí zákaz používání jednotlivých typů výměnných zařízení. Prostřednictvím volby Zakázat použití máte možnost zakázat používat:

  • disketové mechaniky;
  • CD-ROM mechaniky;
  • jiná výměnná média (pouze platforma NT/2000/XP);
  • systém souborů FAT (pouze platforma NT/2000/XP).

Dále můžete uživateli povolit přístup pouze k vybraným CD-ROM diskům prostřednictvím jejich identifikace na základě názvu.

Na platformě NT/2000/XP lze také zakázat zápis na všechna výměnná média a tím zamezit úniku informací z organizace právě těmito prostředky.

Na platformě 9x/ME lze kontrolovat, aby byly v mechanice počítače používány pouze autorizované diskety. Pokud disketa není autorizována je její použití vyloučeno. Nelze z ní číst ani na ni ukládat data. Tímto způsobem lze omezit pohyb disket na pracovišti. Lze takto chránit počítač i před boot viry, ale to pouze za předpokladu, kdy má správce dokonalý přehled a kontrolu nad pohybem autorizovaných disket. Do jisté míry lze tuto funkci přirovnat jako ekvivalent zámků na disketových mechanikách nebo fyzického odpojení disketových mechanik. Funkci je vhodné aktivovat zejména v případě školských zařízeních, kdy chce správce sítě maximálně uplatnit restrikce platné na daných počítačích.

Zákaz používání určitého typu výměnných zařízení

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace máte možnost prostřednictvím volby Zakázat použití znemožnit uživateli práci s vybranými druhy výměnných médií.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se systém OptimAccess® bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Povolení CD-ROM s určitými názvy

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace máte možnost prostřednictvím tlačítek Přidat a Odebrat upravovat seznam názvu CD-ROM médiím které má uživatel právo používat. Stiskem tlačítka Přidat vyvoláte dialog Povolení CD podle názvu, kam můžete zadat patřičné jméno a potvrdit je stiskem tlačítka OK.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se systém OptimAccess® bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Autorizace disket a její rušení

Autorizace disket probíhá speciálním záznamem mimo běžnou datovou oblast. Proto nelze autorizaci kopírovat. Rovněž ji nelze zrušit formátováním. S disketou lze pracovat bez jakýchkoliv omezení – lze z ní číst, zapisovat, mazat, formátovat, měnit její jméno a podobně. Proces autorizace i její následné rušení se nijak nedotýká datové oblasti diskety. Proto lze autorizovat i rušit autorizaci disket, aniž by se to jakkoliv dotýkalo dat na ní uložených.

Autorizace diskety pro použití

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace stiskněte tlačítko Autorizovat disketu A:.
  3. O průběhu autorizace vás bude systém informovat dialogem Probíhá autorizace....
  4. O úspěšném ukončení procesu autorizace vás systém informuje dialogem Autorizace s textem Disketa byla autorizována!. Proces autorizace dokončíte stiskem tlačítka OK.

Rušení autorizace diskety pro použití

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace stiskněte tlačítko Zrušit autorizaci na disketě A:.
  3. O průběhu autorizace vás bude systém informovat dialogem Probíhá rušení autorizace....
  4. O úspěšném ukončení procesu autorizace vás systém informuje dialogem Zrušení autorizace s textem Disketě byla zrušena autorizace!. Proces rušení autorizace dokončíte stiskem tlačítka OK.


Koncepce obnovy souborů dle vzoru

Obnova souborů a adresářů funguje na principu záložních kopií vzorového nastavení. Při startu systému jsou vždy smazány chráněné adresáře a soubory a jsou nahrazeny ze záložních kopií. Tuto funkci je vhodné používat obzvláště pro pracovní adresáře aplikací, které ukládají uživatelská data a měly by vždy mít stejné základní nastavení.

Obnova adresářů

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Obnova souborů.
  2. Pro nastavení obnovy adresářů slouží horní polovina pravého ovládacího okna. Nastavení pro adresáře se týká části Chráněné adresáře. Pro manipulaci s chráněnými adresáři slouží tlačítka:
    • Přidat pro zadávání nových chráněných adresářů;
    • Odebrat pro odstraňování adresářů ze seznamu;
    • Upravit pro změny ve stávajícím nastavení.
    Stiskem tlačítek Přidat a Upravit zobrazíte dialog Obnova adresářů. V něm máte možnost prostřednictvím tlačítka Změnit nadefinovat Chráněný adresář a jemu příslušející Vzorový adresář.

    Dále můžete prostřednictvím volby Vytvořit obraz již existujícího adresáře nakopírovat aktuální stav chráněného adresáře do záložního vzorového adresáře. V případě adresářů máte dále možnost obnovovat i vnořené podadresáře označením volby Obnovovat i podadresáře.

    Nastavené změny aktivujete stiskem tlačítka OK.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se systém OptimAccess® bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Obnova souborů

Obnova souborů se provádí analogicky k výše uvedenému postupu s tím rozdílem, že pracujete s ovládacími prvky ve spodní části pravého okna.


Koncepce obnovy registračních položek

Obnova registračních položek funguje na principu záložních kopií vzorového nastavení. Při startu systému jsou vždy smazány chráněné registrační položky a jsou nahrazeny ze záložních kopií.

Obnova registračních složek

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Obnova registračních položek.
  2. Pro nastavení obnovy registračních složek slouží horní polovina pravého ovládacího okna. Nastavení pro registrační složky se týká části Chráněné registrační složky. Pro manipulaci s chráněnými registračními složkami slouží tlačítka:
    • Přidat pro zadávání nových chráněných složek;
    • Odebrat pro odstraňování složek ze seznamu;
    • Upravit pro změny ve stávajícím nastavení.
    Stiskem tlačítek Přidat a Upravit zobrazíte dialog Specifikace registrů. V něm máte možnost prostřednictvím editačního okna nadefinovat Chráněnou registrační složku.

    Nastavené změny aktivujete stiskem tlačítka OK.

  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Obnova registračních hodnot

Obnova registračních hodnot se provádí analogicky k výše uvedenému postupu s tím rozdílem, že pracujete s ovládacími prvky ve spodní části pravého okna.


Omezení přístupu k souborům

Máte možnost zakázat jednotlivým uživatelům manipulovat s vybranými typy souborů, instalování nových programů a povolit spouštění pouze těch souborů, které jsou umístěny v definovaných složkách.

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Omezení přístupu k souborům.
  2. V pravém okně ovládací aplikace máte možnost voleb:
    • Základní ochrana před instalací nových aplikací – zabraňuje uživateli v manipulaci se soubory, jejichž názvy obsahují klíčová slova setup či install. Uživatel nemá oprávnění ani ke čtení takto pojmenovaných souborů, tudíž je nemůže přejmenovat a spustit pod jiným názvem.
    • Ochrana přístupu k souborům – soubory lze chránit na dvou úrovních. Jednak je možno zamezit čtení souboru na základě rozlišení typu na úrovni přípony. Seznam přípon souborů k nimž nemá uživatel právo přístupu je vylistován v okně Znemožnit přístup k souborům s těmito názvy. Rovněž je možno zamezit zápisu do souboru na základě rozlišení typu na úrovni přípony. Seznam přípon souborů k nimž nemá uživatel právo zápisu je vylistován v okně Znemožnit změnu obsahu a vytváření souborů s těmito názvy. Oba seznamy lze upravovat po stisku příslušného tlačítka Změnit ....
    • Povolit přístup k .exe a .dll souborům pouze z adresáře Program Files a systémového adresáře – lze zakázat spouštění souborů z jiných než vymezených složek. Seznam uživatelských složek z nichž je možno spouštět programy je obsažen v okně Povolit přístup také v těchto adresářích. Lze jej upravovat po stisku tlačítka Změnit ....
    • Zakázat přístup k .exe a .dll souborům na výměnných médiích (Platformy Windows NT/2000/XP) - lze zakázat spouštění (a kopírování) spustitelných souborů z výměnných médií a tím zamezit přísunu nežádaného softwaru na pracovní stanice, prostřednictvím právě těchto médií.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se systém OptimAccess® bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.


Omezení přístupu k adresářům

Máte možnost zakázat jednotlivým uživatelům manipulovat s vybranými složkami.

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Omezení přístupu k adresářům.
  2. Pro nastavení omezení přístupu k systémovým adresářům slouží horní polovina pravého okna ovládací aplikace. Lze zakázat přístup k těmto složkám:
    • Program Files – základní adresář pro instalaci programů, obsažený v kořenovém adresáři disku s instalací systému Windows.
    • Nabídka Start – adresář s položkami nabídky Start, obsažený ve složce systému Windows a uživatelském profilu.
    • Windows 2000 (WINNT) – základní adresář s instalací operačního systému, obsažený v kořenovém adresáři disku s instalací systému Windows.
    • Pracovní plocha – adresář s položkami Pracovní plochy, obsažený ve složce systému Windows a uživatelském profilu.
    Pro nastavení omezení přístupu k uživatelským složkám slouží volba vybrané adresáře v dolní polovině pravého okna ovládací aplikace. Je zde vylistován seznam složek, k nimž je aktuálně zakázán přístup. Změnu nastavení v rámci uživatelských složek lze provádět po stisku tlačítka Změnit ....
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se systém OptimAccess® bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.


Ovládací panely

Máte možnost zakázat jednotlivým uživatelům manipulovat s vybranými Ovládacími panely následujícím postupem:

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Ovládací panely.
  2. V pravém okně ovládací aplikace máte možnost prostřednictvím oken Povoleno a Zakázáno nastavovat oprávnění k použití jednotlivých Ovládacích panelů. Označte stiskem myši zvolený Ovládací panel a stiskem tlačítek Zakázat >> respektive Povolit >> (v závislosti na tom, zdali se panel momentálně vyskytuje v okně Povoleno respektive Zakázáno) nastavte příslušné oprávnění.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se systém OptimAccess® bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.


Administrátorská omezení

Systém OptimAccess® nabízí omezení, která lze nastavit uživatelům s právy Administrátor, a tím dosáhnout důslednější prosazení interní bezpečnostní politiky. Je možné zvolit mezi následujícími omezeními:

  • Uživatel nemůže měnit přístupové heslo - Uživatel není schopen heslo žádnému z lokálních uživatelů.
  • Uživatel nemůže přebírat vlastnictví k cizím objektům - díky této volby je možné administrátorovi znepřístupnit soubory a adresáře ke kterým nemá přiřazeno vlastnictví.
  • Uživatel není schopen měnit přístupová práva k objektům - volba slouží k celkovému zamezení nastavování přístupových práv k souborům a adresářům daným uživatelem.


Komplexní ochrana nastavení

Při každém startování Windows se přepíše registrační databáze v adresáři Windows původní zálohovanou databází bezpečně uloženou v adresáři do, kterého jste instalovali systém OptimAccess. Jedná se konkrétně o soubory system.dat a user.dat.

Funkce využijete v případě, kdy je potřeba zajistit absolutní neměnnost nastavení Windows a to včetně nastavení ikon, tapety, komunikačních prostředků, driverů a dalších nastavení. Ideální řešení v učebnách firem, školských zařízeních, internetových kavárnách. Všeobecně na místech s přístupem mnoha těžko neidentifikovatelných lidí k jednomu nedefinovanému počítači.

Nastavení ochrany Registrační databáze

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Komplexní ochrana nastavení.
  2. V pravém okně ovládací aplikace označte volbu Komplexní ochrana Registrační databáze a stiskněte tlačítko Použít.
  3. Systém vám úspěšnou aktivaci ochrany oznámí dialogem Ochrana registrační databáze byla instalována. Ukončete jej stiskem tlačítka OK.

Zrušení ochrany Registrační databáze

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Komplexní ochrana nastavení.
  2. V pravém okně ovládací aplikace zrušte označení volby Komplexní ochrana Registrační databáze a stiskněte tlačítko Použít.
  3. Systém vám úspěšnou deaktivaci ochrany oznámí dialogem Ochrana registrační databáze byla odinstalována. Ukončete jej stiskem tlačítka OK.

Aktualizace Registrační databáze

Příkaz Aktualizace Registrační databáze v podstatě zkopíruje soubory user.dat a system.dat do adresáře kam jste instalovali OptimAccess, čímž přepíše soubory s dřívější zálohou. Aktualizuje jejich podobu dle nejnovějších změn provedených ve Windows. Funkce může vyžadovat RESTART z důvodu načtení posledních modifikací provedených v Registrační databázi.

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Komplexní ochrana nastavení.
  2. V pravém okně ovládací aplikace stiskněte tlačítko Aktualizovat.
  3. Systém vám úspěšnou deaktivaci ochrany oznámí dialogem Aktualizace proběhla úspěšně. Ukončete jej stiskem tlačítka OK.
Jedná se o řešení k aktualizaci minoritních změn v Registrační databázi v rámci Windows. V případě provedení rozsáhlejších změn (rozsáhlé instalace, update operačního systému a podobně) je vhodnější deaktivovat systém OptimAccess®.


Adresářová struktura

Pro systémy Windows 9x a Windows ME máte možnost pro jednotlivé složky a soubory na disku nastavovat přístupová práva obdobně jako v systémech na platformě NT/2000/XP.

Manipulace s ochranou složek

Ochranu složek adresářové struktury lze nastavovat pouze v levém okně aplikace OptimAccess. V pravém okně aplikace se při označení složky stisknutím myši vylistuje pouze v ní obsažené soubory, nikoliv adresáře. Ty vylistujete v levém okně stiskem na ikonu plus ( [image]) příslušející k dané složce.

Příznak ochrany složky nastavíte pomocí dialogu Nastavení příznaku složky. Ten pro danou složku vyvoláte poklepáním na její ikonu. Ochrana všech souborů a složek nacházející se na pevném disku počítače s parametrem může mít následující úrovně dle nastavených příznaků:

  • RW (složka pro čtení a zápis)
    Se složkou je možné běžně pracovat bez jakýchkoliv omezení
  • RO (složka pouze pro čtení)
    Ze složky lze pouze číst data. Nelze ji žádným způsobem smazat ani upravit (přejmenovat, změnit její příznaky a podobně).
  • HI (skryté složky resp. zakázané k použití)
    Do takto označené složky bude zakázán přístup. POZOR! Přístup je zakázán i na systémové úrovni a proto s takto zabezpečenou složkou nebude možné žádným způsobem pracovat. Vhodné pro nastavení složek s obsahem instalačních souborů, které systémový správce využívá spíše příležitostně a v delším časovém horizontu.

Mimo příznak složky lze v dialogu Nastavení příznaku složky prostřednictvím voleb dále nastavit:

  • totožnou ochranu pro všechny podsložky označením volby Podsložky dědí příznak;
  • totožnou ochranu pro všechny soubory dané složky označením volby Soubory dědí příznak složky.

Manipulace s ochranou souborů

Ochranu souborů lze mimo výše popsaný případ, kdy soubory dědí nastavení složky nastavovat výlučně v pravém okně. Nastavení lze provádět dvěma způsoby:

  • poklepáním na daný soubor lze střídavě přepínat mezi nastavením příznaku RW a RO;
  • hromadně pomocí masky - stiskem pravého tlačítka myši na jménu souboru vyvoláte dialog Maska příznaku souborů, do textového pole pomocí hvězdičkové konvence uvedete vámi požadovaný výběr jmen souborů a stiskem tlačítek Nastav RO respektive Nastav RW nastavíte požadovaný příznak.


OptimAccess® Extension

Modul OptimAccess® Extension rozšiřuje funkce modulu OptimAccess® Standard v těchto oblastech operačního systému Windows:

  • Ovládací panely – je možné uživateli zakázat manipulaci s jednotlivými volbami v rámci Ovládacích panelů Síť, Hesla, Tiskárny, Systém, Obrazovka.
  • Průzkumník a složky – lze omezit používání jednotlivých voleb v rámci nabídky Start, Plochy, Průzkumníka, nastavení vlastností složek a používaných logických diskových jednotek.
  • Nastavení uživatelských aplikací – funkce umožňují zachovat klíčové volby pro aplikace MS Internet Explorer, MS Word, MS Excel, MS Outlook a MS Outlook Express. Dále je možné zakázat přístup k přílohám v elektronické poště a řídit aplikace přístupné pro uživatele.
  • Bezpečnost – lze zamezit úpravám registrační databáze, softwarovému vypnutí počítače a kontrolovat parametry a využívání hesel v rámci Windows.

Přínosem modulu OptimAccess® Extension jsou pokročilé ochranné funkce. Rozšiřuje ochranu i na aplikační vybavení počítače a zohledňuje bezpečnostní rozměr kontroly správného využívání hesel.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul Extension ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Extension vylistujete jednotlivé volby a nastavení modulu OptimAccess® Extension.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul Extension pro konkrétního uživatele ovládá pomocí nabídky Extension v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice a seznam uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu Extension. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem Extension.

Volby modulu Extension

  • Ovládací panely
  • Průzkumník a složky
  • Nastavení aplikací
  • Bezpečnost


Ovládací panely

Karta Síť

  • označením volby Odstranit složku "Celá síť" z menu okolní počítače skryjete ikonu Celá síť z dialogového okna Okolní počítače
  • označením volby Skryj záložku Identifikace v Ovládacích panelech -> Síť skryjete kartu Identifikace v dialogovém okně Síť
  • označením volby Skryj ikonu okolní počítače (Ikona okolní počítače je automaticky instalována při instalaci sítě) skryje ikonu Okolní počítače z pracovní plochy
  • označením volby Uživatel nemůže vytvářet, rušit a měnit sdílení souborů a tiskáren zakážete uživateli měnit nastavení sdílení souborů a tiskáren prostřednictvím dialogu Sdílení souborů a tiskáren (tedy uživatel nemůže zasahovat do konkrétního správcem provedeného nastavení)
  • označením volby Skryj záložku Řízení přístupu v Ovládacích panelech -> Síť skryjete kartu Řízení přístupu v dialogovém okně Síť

Karta Hesla

  • označením volby Záložka Vzdálená správa skryjete kartu Vzdálená správa v dialogovém okně Hesla - vlastnosti
  • označením volby Záložka Změnit hesla skryjete kartu Změnit hesla v dialogovém okně Hesla - vlastnosti
  • označením volby Záložka Profily uživatelů skryjete kartu Profily uživatelů v dialogovém okně Hesla - vlastnosti

Karta Tiskárny

  • označením volby Přidání tiskárny znemožníte uživateli přidat tiskárnu do systému
  • označením volby Odebrání tiskárny znemožníte uživateli odebrat tiskárnu ze systému
  • označením volby Záložka Podrobnosti tiskárny znemožníte uživateli nastavovat systémové parametry tiskárny prostřednictvím dialogu <jméno tiskárny> - vlastnosti (tj. uživatel nemůže měnit systémové nastavení tiskárny jako jsou port tiskárny, ovladač, řazení tiskových úloh a podobně)

Karta Systém

  • označením volby Virtuální paměť skryjete tlačítko Virtuální paměť... na kartě Výkon v dialogovém okně Systém - vlastnosti
  • označením volby Hardwarové profily skryjete kartu Hardwarové profily v dialogovém okně Systém - vlastnosti
  • označením volby Systém souborů skryjete tlačítko Systém souborů... na kartě Výkon v dialogovém okně Systém - vlastnosti
  • označením volby Správce zařízení skryje kartu Správce zařízení v dialogovém okně Systém - vlastnosti

Karta Obrazovka

První volba se týká nastavení závislého na hardwarové konfiguraci počítače, ostatní tři volby jsou pouze možnosti uživatelského přizpůsobení operačního systému.

  • označením volby Skryj záložku nastavení skryjete kartu Nastavení v dialogovém okně Obrazovka - vlastnosti (uživatel nebude moci měnit nastavení, která vyžadují případné opravy od správce; jako například nastavení ovladače grafické karty, typ monitoru, obnovovací frekvenci monitoru a podobně)
  • označením volby Skryj záložku Pozadí skryjete kartu Pozadí v dialogovém okně Obrazovka - vlastnosti
  • označením volby Skryj záložku Šetřič obrazovky skryjete kartu Šetřič obrazovky v dialogovém okně Obrazovka - vlastnosti
  • označením volby Skryj záložku Vzhled skryjete kartu Vzhled v dialogovém okně Obrazovka - vlastnosti


Průzkumník a složky

Karta Nabídka Start

  • označením volby Ovládací panely a tiskárny odeberete příkazy Tiskárny a Ovládací panely z nabídky Nastavení v hlavní nabídce Start systému Windows
  • označením volby Příkaz spustit odeberete příkaz Spustit z nabídky Start systému Windows
  • označením volby Příkaz najít odeberete příkaz Najít z nabídky Start systému Windows

Karta Diskové jednotky

V rámci karty Diskové jednotky máte možnost zakázat na počítači použití stanovených logických jednotek. Zákaz použití pro vybrané logické jednotky nastavíte označením voleb v rozsahu A až Z. Ochrannému systému je úplně jedno, zdali se jedná o disketovou jednotku, pevný disk, síťový disk, CD-ROM, ZIP , JAZZ nebo jiné diskové médium.

Nastavení jsou platná pouze pro ovládací rozhraní operačního systému a jim příslušné aplikace (Průzkumník, MS Internet Explorer). V souborových manažerech (například Windows Commander) jsou tyto jednotky přístupné. Rovněž nelze skrývat jednotku, která je sdílena (případně jejíž část je sdílena).

Karta Plocha

  • označením volby Skryj všechny ikony na ploše skryjete všechny ikony na pracovní ploše
  • označením volby Zakázat změnu nastavení Active Desktop zakážete změnu nastavení v rámci Systému Active Desktop
  • po označení volby Obnovit nastavení Tapety plochy po restartu počítače se po každém restartu Windows se obnoví vaše původní nastavení tapety Windows, které bylo použito v okamžiku aktivace této volby (nastavení tapety nelze měnit ani z jiných aplikací či nabídek)
  • po označení volby Obnovit nastavení Vzhledu po restartu počítače se po každém restartu obnoví původní nastavení vzhledu Průzkumníka (vzhledu oken - jako například barvy oken, použité fonty v oknech), které bylo použito v okamžiku aktivace této volby

Karta Průzkumník

  • označením volby Zakázat volbu možnosti úplně znemožníte vstup do nastavování vzhledu aplikace Průzkumník
  • označením volby Zobrazení ikony "připojení síťové jednotky" zakážete uživatelům připojovat síťové disky, čímž znemožní provádět nepovolené akce na síti (obzvláště v sítích bez centralizované správy)
  • označením volby Chránit nastavení "Panelů nástrojů" chráníte celý panel proti editaci v aplikaci Průzkumník
  • označením volby Při ukončení Průzkumníku se nebude ukládat nastavení (rozestavění oken na ploše při vypnutí počítače, vzhled Průzkumníku při jeho ukončení) chráníte nastavení oken (jejich pozici na monitoru a vzhled, včetně zobrazení a seřazení)

Karta Vlastnosti Složky

  • označením volby Zobrazení skrytých a systémových souborů chráníte neměnnost nastavení aktuálního zobrazení skrytých a systémových souborů
  • označením volby Zobrazení známých přípon chráníte neměnnost zobrazení známých přípon
  • označením volby Globální nastavení zobrazení Složek chráníte před efektivním použitím tlačítka „Jako aktuální složka“, které se nachází na kartě Zobrazit dialogu Možnosti složky (dostupný v aplikaci Průzkumník a Internet Explorer prostřednictvím nabídky Zobrazit po klepnutí na příkaz Možnosti složky...).


Nastavení aplikací

Karta Internet

  • označení volby Znemožnit Download zakáže stahování souborů ze sítě Internet
  • označení volby Prostřednictvím Internet Exploreru lze stáhnout pouze vybrané soubory umožní uživateli stahovat soubory příslušející pouze do konkrétní povolené množiny na základě použité přípony; seznam povolených přípon je obsažen v okně Povolené soubory a jeho obsah lze editovat po stisku tlačítka Změnit
  • označení volby Znepřístupnit kontextové menu zakáže uživateli pracovat s kontextovou nabídkou na pravém tlačítku myši
  • označení volby Chránit nastavení domovské stránky zakáže změnu vámi původně nastavené domovské www stránky a to ani klávesovou zkratkou CTRL+D
  • označením volby Chránit nastavení ovládacích panelů chráníte nestavení a vzhled jednotlivých panelů a ovládacích prvků aplikace Internet Explorer
  • označení volby Skrýt volbu Oblíbené skryje nabídku Oblíbené z hlavní nabídkové lišty aplikace Internet Explorer
  • označení volby Chránit nastavení Připojení k internetu zakáže měnit nastavení na kartě připojení v dialogovém okně Internet - vlastnosti (volba rovněž chrání nastavení Telefonických připojení sítě - tj. nelze měnit čísla a nastavení stávajících telefonních účtů)

Karta Word

Aplikace sice uživateli dovolí změnit její vzhled a nastavení, avšak při jejím opětovném spuštění je obnoveno původní nastavení.

  • označení volby Uchovávat nastavení a pozici Ovládacích panelů zakáže přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Word
  • po označení volby Hlídat celkové nastavení aplikace Microsoft Word nelze provádět jakékoliv změny nastavení aplikace Microsoft Word prostřednictvím příkazu Možnosti z nabídky Nástroje
  • označení volby Ochrana základní šablony pro tvorbu dokumentů chrání proti změně šablonu Normal.dot

Karta Excel

Aplikace sice uživateli dovolí změnit její vzhled a nastavení, avšak při jejím opětovném spuštění je obnoveno původní nastavení.

  • označení volby Uchovávat nastavení a pozici Ovládacích panelů zakáže přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Excel
  • po označení volby Hlídat celkové nastavení aplikace Microsoft Excel nelze provádět jakékoliv změny nastavení aplikace Microsoft Excel prostřednictvím příkazu Možnosti z nabídky Nástroje
  • označení volby Zachovat pozici a velikost hlavního okna při spuštění aplikace zachová aktuální rozmístění okna aplikace Microsoft Excel

Karta Outlook

S výjimkou přidávání a odebírání informačních služeb sice aplikace uživateli dovolí změnit její vzhled a nastavení, avšak při jejím opětovném spuštění je obnoveno původní nastavení.

  • označení volby Zachovat pozici a velikost okna při spuštění zachová aktuální rozmístění okna aplikace Microsoft Outlook
  • označení volby Uchovávat nastavení a pozici Ovládacích panelů zakáže přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Outlook
  • označení volby Zakázat rušení již instalovaných a přidávání nových Informačních služeb zakáže provádět změny nastavení v rámci dialogu Účty sítě Internet

Následující volby slouží k omezení možnosti provádět změny nastavení programu Microsoft Outlook prostřednictvím příkazu Možnosti z nabídky Nástroje:

  • označením volby Úkoly a poznámky ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, karta Předvolby v částech Úkoly a Poznámky
  • označením volby Kontrola pravopisu ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, karta Kontrola pravopisu
  • označením volby Připomenutí ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, karta Předvolby, část Kalendář
  • označením volby Kalendář ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, Karta Předvolby, část Kalendář
  • označením volby Kompletní ochrana menu Možnosti celkově zabezpečí program Microsoft Outlook tak, aby nikdo nemohl prostřednictvím příkazu Možnosti z nabídky Nástroje udělat jakékoliv změny nastavení
  • označením volby Možnosti kontaktů (MS Outlook 2000) ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, panel Předvolby, část Kontakty
  • označením volby Možnosti el. pošty (MS Outlook 2000) ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, panel Předvolby, část Kalendář

Karta Outlook Express

  • označením volby Chránit nastavení účtů zakážete uživateli měnit nastavení účtů elektronické pošty a dalších adresářových služeb
  • označením volby Chránit nastavení vzhledu Outlook Express zakážete uživateli přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Outlook
  • označením volby Kompletně chránit nastavení Outlook Express zakážete uživateli provést jakoukoliv změnu v nastavení aplikace Microsoft Outlook Express

Karta E-mail

  • označením volby Zakázat otevírat dopisy programem Microsoft Outlook s vybranými soubory máte možnost zakázat uživateli manipulovat se soubory příslušejícími do konkrétní povolené množiny na základě použité přípony; seznam zakázaných přípon je obsažen v okně Zakázané soubory a jeho obsah lze editovat po stisku tlačítka Změnit

Karta WWW

  • označením voleb Použít omezení přístupu k www stránkám a Zakázat vybrané www domény máte možnost definovat www domény ke kterým nebude uživateli umožněn přístup. Seznam zakázaných www stránek je obsažen v okně pod volbou Zakázat vybrané www domény a jeho obsah lze editovat po stisku tlačítka Změnit.
  • označením voleb Použít omezení přístupu k www stránkám a Povolit pouze vybrané www domény máte možnost definovat www domény ke kterým bude uživateli umožněn přístup. Seznam povolených www stránek je obsažen v okně pod volbou Povolit pouze vybrané www domény a jeho obsah lze editovat po stisku tlačítka Změnit. Pokud se uživatel pokusí o přístup k www stránce která nevyhovuje ani jedné ze zadaných masek, nebude mu k ní povolen přístup.
  • Domény je možné (a v některých případech i nutné) psát s využitím hvězdičkové notace (např. „*www.OptimAccess.cz*“ ).

Karta Povolené aplikace

  • označení volby Příkazová řádka znemožní spouštění aplikace Příkazový řádek z nabídky Start (obecně zamezí spouštění interpretru příkazové řádky systému MS-DOS programem Command.com). Tudíž nelze používat aplikace systému MS-DOS.
  • označení volby Spouštění programů znemožní uživateli spustit jakýkoliv jiný program než explicitně povolený správcem systému; toto omezení se netýká programu OptimAccess, který je možné spustit kdykoliv. Pro jednotlivé programy se oprávnění k jejich spouštění nastavuje pomocí tlačítka Nalistovat aplikaci .... Naopak zrušení oprávnění se provádí označením programu v okně v pravé části karty Povolené aplikace dialogu Ochrana nastavení aplikací a následným stiskem tlačítka Odeber aplikaci. Prostřednictvím tlačítka Vybrat ze seznamu dostupných aplikací ... máte možnost v rámci dialogu Výběr spustitelného souboru volit z přehledu spustitelných souborů obsažených na disku počítače.


Bezpečnost

Karta Bezpečnost

  • označením volby Vypnutí počítače zakážete příkaz Vypnout v hlavní nabídce Start systému Windows
  • označením volby Nástroje pro editaci registrů zakážete spuštění standardních aplikací umožňujících měnit obsah registrů systému Windows
  • po označení volby Vyžadovat platné uživatelské jméno a heslo při vstupu do systému systém Windows vždy zobrazí přihlašovací dialog do operačního systému, který nelze obejít stisknutím tlačítka Storno; tuto volbu aktivujte pouze v případě, že máte v rámci vaší sítě server ověřující přihlašovací hesla domény Windows NT. Systém vyžaduje ověření zadaného uživatelského hesla vůči doméně Windows NT! Jinak se do systému Windows nebudete moci přihlásit a bude jej nutné reinstalovat.
  • po označení volby Při zadávání nového hesla vyžadovat alfanumerické heslo bude systém Windows při zadávání hesla nového uživatele vyžadovat zadání řetězce znaků skládající se z kombinace písmen a číslic
  • po označení volby Vyžadovat heslo, které je delší než minimální velikost bude systém Windows při zadávání hesla nového uživatele vyžadovat zadání řetězce znaků, který je stejně dlouhý nebo delší než udaná hodnota čísla uvedená v části minimální velikost na kartě Bezpečnost

Karta Registry

  • označením volby Znemožnit změnu obsahu vybraných registračních složek máte možnost definovat registrační složky ke kterým nebude uživateli umožněn přístup pro zápis. Seznam takto chráněných složek je obsažen v okně pod volbou Znemožnit změnu obsahu vybraných registračních složek a jeho obsah lze editovat prostřednictvím následujících tlačítek.
    • Přidat pro zadávání nových chráněných registračních složek;
    • Odebrat pro odstraňování chráněných registračních složek ze seznamu;
    • Upravit pro změny ve stávajícím nastavení.
  • označením volbyZnemožnit změnu obsahu vybraných registračních hodnot máte možnost definovat registrační hodnoty ke kterým nebude uživateli umožněn přístup pro zápis. Seznam takto chráněných hodnot je obsažen v okně pod volbou Znemožnit změnu obsahu vybraných registračních hodnot a jeho obsah lze editovat prostřednictvím následujících tlačítek.
    • Přidat pro zadávání nových chráněných registračních hodnot;
    • Odebrat pro odstraňování chráněných registračních hodnot ze seznamu;
    • Upravitpro změny ve stávajícím nastavení.
  • Stiskem tlačítek Přidat a Upravit zobrazíte dialog Specifikace registrů. V něm máte možnost prostřednictvím editačního okna nadefinovat registrační složku případně i hodnotu.


OptimAccess® Remote Control

Modul Remote Control slouží k dálkové a hromadné správě jednotlivých instalací systému OptimAccess® na počítačích a pracovních stanicích v rámci počítačové sítě. Funkčnost není závislá na serveru sítě, přístup je možný z kterékoli stanice kde je modul instalován. Pro jednotlivou symboliku stavu spravovaných počítačů a stanic jsou použity tyto ikony:

  • Je třeba načíst aktuální stav počítače.
  • Systém OptimAccess® není aktivní, je možno jej pouze aktivovat.
  • Systém OptimAccess® je aktivní a lze měnit nastavení ochranného systému.
  • Na počítači není instalovaný klient vzdálené správy nebo počítač není na síti přístupný.

Ovládání ve Windows 9x, ME, NT, 2000 a XP

V prostředí Windows se modul Remote Control ovládá prostřednictvím aplikace OptimAccess® následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace rozbalte ikonu Okolní stanice.
  4. V levém okně ovládací aplikace poklepáním myši označte počítač nebo skupinu pomocí rozbalení ikon Síťové okolí, Databáze okolních počítačů a Nalezené počítače
  5. V levém okně ovládací aplikace rozbalte ikonu počítače počítače nebo skupiny a rozbalte ikonu Remote Control.

Volby modulu Remote Control v prostředí Okolní stanice

  • Síťové okolí
  • Databáze okolních počítačů
  • Nalezené počítače

Volby modulu Remote Control v prostředí lokální nebo vzdálené stanice

  • Základní nastavení
  • Dynamické nastavení
  • Manager naplánovaných akcí

Volby modulu Remote Control v prostředí síťové skupiny

  • Základní nastavení
  • Dynamické nastavení


Síťové okolí

Volba Síťové okolí slouží k průchodu všech okolních počítačích (obdobně jako v případě použití ikony Okolní počítače na ploše systému Windows). Přitom systém respektuje topologii vaší sítě. Po vylistování obsahu položky Síťové okolí stiskem na ikonu plus se vám zobrazí všechny přístupné pracovní skupiny a domény. Po vylistování obsahu skupiny či domény se vám zobrazí všechny přístupné počítače.

Zobrazené počítače mají ikonu počítače se světle šedým monitorem (protože není známo, které počítače obsahují klienta vzdálené správy a je možné je ovládat). Kliknutím na počítač se u počítače zobrazí příslušná ikona stavu klienta vzdálené správy. V pravé části ikony je indikována použitá platforma - 9x či NT. Je-li na daném počítači aktivní systém OptimAccess®, lze u něj stiskem ikony plus vylistovat příslušné moduly. Nastavování a ovládání jednotlivých voleb je totožné jako v případě práce s ikonou Lokální stanice.

Roletová nabídka na ikoně počítače

  • Znovu načíst - nastaví počítač do výchozího stavu. Při rozbalení se znovu zjišťuje aktivita klienta vzdálené správy a načítá se struktura disků a adresářů.
  • Restartovat - restartuje označený počítač.
  • Vymazat - smaže ikonu označeného počítače. Po opětovném načtení obsahu skupiny (například klávesou F5 či ukončením a spuštěním ovládací aplikace) na základě síťové topologie bude smazaný počítač opět zobrazen.


Databáze okolních počítačů

Databáze okolních počítačů představuje uživatelskou databázi. Administrátor má možnost vytvoření skupin počítačů nebo vložení jmen jednotlivých počítačů, na kterých je instalovaný klient vzdálené správy. Počítače a skupiny lze přidávat a ubírat pomocí kontextové nabídky, která se vyvolá stiskem pravého tlačítka myši na příslušné položce. Většina základních funkcí aplikace pro vzdálenou správu je dostupná prostřednictvím roletových nabídek.

Nastavení funkcí systému OptimAccess® lze provádět pro všechny počítače současně prostřednictvím ikony Nastavení skupiny. Nastavení funkcí pro konkrétní počítač v rámci skupiny (či samostatně stojící mimo skupinu) lze prostřednictvím jemu příslušející ikony.

Jednotlivé počítače a skupiny počítačů lze v rámci Databáze okolních počítačů libovolně přemísťovat a vzájemně zanořovat do hierarchické struktury prostřednictvím uchopení a tažení myší.

Roletová nabídka na ikoně Databáze okolních počítačů

  • Nový objekt - umožní vložení nového počítače nebo skupiny do Databáze okolních počítačů. Do databáze je možné vkládat samostatně stojící počítače a skupiny počítačů s nastavením pro platformu Windows 9x a Windows NT.

Roletová nabídka na ikoně skupiny

  • Nový objekt - umožní vložení nového počítače nebo skupiny do Databáze okolních počítačů. Do databáze je možné vkládat samostatně stojící počítače a skupiny počítačů s nastavením pro platformu Windows 9x a Windows NT.
  • Vymazat - umožní vymazání obsahu skupiny nebo celé skupiny z Databáze okolních počítačů.
  • Restartovat - restartuje všechny počítače náležející do příslušné skupiny.

Roletová nabídka na ikoně počítače

  • Znovu načíst - nastaví počítač do výchozího stavu. Při rozbalení se znovu zjišťuje aktivita klienta vzdálené správy a načítá se struktura disků a adresářů.
  • Restartovat - restartuje vzdálený počítač.
  • Vymazat - umožní počítač z Databáze odstranit.


Práce se skupinou počítačů

Všechny akce pro skupinu počítačů lze plánovat dle pokynů pod heslem Plánování akcí pro skupinu počítačů.

Aktivace a deaktivace systému OptimAccess®

Po vylistování skupiny počítačů v levém okně ovládací aplikace lze ochranný systém aktivovat prostřednictvím tlačítka Aktivace systému ... a deaktivovat prostřednictvím tlačítka Deaktivace systému ... Obě tyto volby prostřednictvím příslušných dialogů další nastavení jako v případě práce s lokální stanicí.

Nastavení skupiny

Při manipulaci s nastavením skupiny máte možnost používat tlačítka Aplikovat nastavení všem stanicím ..., Exportovat nastavení do souboru ... a Importovat nastavení ze souboru .... Volby pro import a export nastavení vyžadují prostřednictvím příslušných dialogů další nastavení jako v případě práce s lokální stanicí.

Distribuce software

Funkce pro distribuci software funguje na principu jednoduchých *.ini souborů. V rámci této funkce lze na vzdálenou stanici nakopírovat stanovené soubory a spustit stanovený soubor. Tímto způsobem lze například provádět aktualizaci programového vybavení jednotlivých klientských stanic. V rámci složky Update adresáře s instalací ochranného systému je třeba vytvořit *.ini soubor s následující strukturou.

; Ukázkový inicializační soubor
; pro distribuci software pod Win9x.

[init]
fileType = rcSofwareDistribution

; Název distribuce. Zobrazí se při
; výběru v okně Remote Control
packName = Distribuce software XY

; Adresář který bude jako aktuální
; při čtení souboru (relativně
; k inicializačnímu souboru).
dir = .

[file]
; Seznam všech souborů, které mají
; být překopírovány (počet souborů
; není omezen).
file0 = setup.exe
file1 = readme.txt
file2 = ...

[run]
; Soubor který je po překopírování
; všech souborů spuštěn.
run = setup.exe

V rámci distribuce software není nutné kopírovat celou instalaci. Může být kopírován a spuštěn pouze *.bat soubor, který provede vzdálenou instalaci z adresářů sdílených na serveru.


Plánování akcí pro skupinu počítačů

Všechny akce pro skupinu počítačů lze provést buďto ihned nebo je naplánovat v rámci časového intervalu od či od/do s přesností na vteřiny. U plánovaných úloh lze nastavit periodické opakování zasílaní úlohy v rámci daného intervalu. Je-li akce provedena ihned, její výsledek se projeví pouze na počítačích které jsou v daném okamžiku dostupné. Pro plánování je třeba mít některou ze stanic určených pro ovládání systému OptimAccess® nastavenou jako server. Každý klient se při spuštění vyhledává aktivní servery či se přímo přihlásí k nastavenému serveru a provede připravené úkoly. Jednotlivé úkoly pro klientské stanice můžete buďto plánovat dvojím způsobem:

  • časově omezené - v rámci určitého časového intervalu od/do;
  • časově neomezené - stále platné od stanoveného počátečného časového okamžiku.

Nastavení vzdáleného serveru

  1. V rámci Databáze okolních počítačů v levé části okna ovládací aplikace vylistujte počítač, který bude fungovat jako server. Z nabídky dostupných modulů vylistujte položku Základní nastavení v modulu Remote Control.
  2. Úlohu stanice v podobě serveru aktivujete prostřednictvím volby Nastavit stanici jako server s databází pro plánované úlohy.
  3. Pro všechny stanice je vhodné označit volbu Při startu informovat vzdálenou stanici a do pole Vzdálená stanice: vepsat síťové jméno zvoleného serveru. Aktivace této volby pro jednotlivé stanice není nutná, avšak pro server eliminuje čas nutný k hledání všech klientů na síti.
  • Jeden počítač určený jako server postačuje pro obsluhu minimálně 50 klientských stanic.

Plánování časově omezené akce

  1. V rámci Databáze okolních počítačů v levé části okna ovládací aplikace vylistujte skupinu počítačů. Stiskem myši na příslušné tlačítko v pravé části ovládací aplikace označte požadovanou funkci, pro niž chcete naplánovat úkol.
  2. Vyžaduje-li příslušná akce nějaké další parametry, budete nejprve dotázáni dialogem na jejich nastavení.
  3. V dialogu Nastavené akce pro skupinu vzdálených stanic označte položku Akci plánovat a nastavte požadované intervalové časové omezení. Při zadávání datumové i časové části intervalu označte volby Od a Do.
  4. U položky Akci uložit na server vylistujte ze seznamu příslušný server, do nějž se má plánovaná akce uložit. Seznam vzdálených serverů můžete modifikovat prostřednictvím položky Vzdálené servery z nabídky Správce v ovládací aplikaci.
  5. Všechny provedené změny aktivujete stiskem tlačítka OK.

Plánování časově neomezené akce

  1. V rámci Databáze okolních počítačů v levé části okna ovládací aplikace vylistujte skupinu počítačů. Stiskem myši na příslušné tlačítko v pravé části ovládací aplikace označte požadovanou funkci, pro niž chcete naplánovat úkol.
  2. Vyžaduje-li příslušná akce nějaké další parametry, budete nejprve dotázáni dialogem na jejich nastavení.
  3. V dialogu Nastavené akce pro skupinu vzdálených stanic označte položku Akci plánovat a nastavte požadované intervalové časové omezení. Při zadávání datumové i časové části intervalu označte pouze volbu Od.
  4. U položky Akci uložit na server vylistujte ze seznamu příslušný server, do nějž se má plánovaná akce uložit. Seznam vzdálených serverů můžete modifikovat prostřednictvím položky Vzdálené servery z nabídky Správce v ovládací aplikaci.
  5. Všechny provedené změny aktivujete stiskem tlačítka OK.


Nalezené počítače

Ikona Nalezené počítače představuje seznam výsledků hledání počítačů na základě jména či IP adresy. Vyhledávání počítačů lze provádět tímto postupem:

  1. Z nabídky Správce zvolte příkaz Najít počítač.
  2. V dialogu Najít počítač můžete vyhledávat prostřednictvím síťového jména nebo IP adresy. Zvolte požadovaný způsob vyhledávání, do příslušného pole zadejte jméno či IP adresu a stiskněte tlačítko Najít.
  3. Nalezený počítač se formou ikony s indikací stavu a platformy zobrazí v rámci ikony Nalezené počítače.

Nalezený počítač lze uchopením a tažením myši umístit do Databáze okolních počítačů.

Roletová nabídka na ikoně počítače

  • Znovu načíst - nastaví počítač do výchozího stavu. Při rozbalení se znovu zjišťuje aktivita klienta vzdálené správy a načítá se struktura disků a adresářů.
  • Restartovat - restartuje označený počítač.
  • Vymazat - smaže ikonu označeného počítače.


Základní nastavení

Volba Základní nastavení modulu OptimAccess® Remote Control nabízí následující možnosti:

  • Nastavit stanici jako server s databází pro plánované úlohy - stanice lze používat jako uložiště naplánovaných úloh. viz Plánování akcí pro skupinu počítačů
    • Jeden počítač určený jako server postačuje pro obsluhu minimálně 50 klientských stanic.

  • Při startu informovat vzdálenou stanici - zatržením této volby a vyplněním kolonky Vzdálená stanice se při každém startu operačního systému pokusí stanice spojit se zvolenou vzdálenou stanicí a informovat ji, že je již nastartována. Tato akce urychlí samotný proces plánování a předávání plánovaných úloh na vzdálené stanici.


Dynamické nastavení

O dynamickém nastavení se v terminologii systému OptimAccess® hovoří pokud nastavení jednotlivých objektů ( jako jsou například Globální nastavení stanice nebo Lokální uživatel ) není přesně dáno, ale je vždy stahováno z definovaného souboru, který může být například prostřednictvím služby Sdílení nasdílen na serveru organizace. Jméno souboru ze kterého je nastavení načítáno pak může být odvozeno například od jména uživatele, nebo skupiny ke které uživatel náleží. Například pro uživatele jménem Jan, který je členem skupiny Technici se systém pokusí stáhnout nastavení ze souboru Jan.oaSNt nebo Technici.oaSNt (podrobnější vysvětlení nastavení priorit při načítání nastavení naleznete níže).

V prostředí Windows 9x, Windows NT, Windows 2000 a Windows XP se modul Dynamická nastavení definují prostřednictvím aplikace OptimAccess® následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače - například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Remote Control vylistujete jednotlivé volby a nastavení modulu OptimAccess® Remote Control.
  5. Zvýrazněte ikonu Dynamická nastavení a v pravé části ovládací aplikace systému OptimAccess® se zobrazí možností této metody stahování nastavení.

Dynamická nastavení lze definovat na dva druhy objektů

  • Globální nastavení stanice.
  • Lokální uživatel

Dynamické nastavení Globálního nastavení stanice

Pokud chcete dynamicky nastavovat Globální nastavení stanice zatrhněte v kartě Dynamické nastavení položku Vzdálené nastavení globálního nastavení stanice. Poté máte na výběr ze dvou typů určení souboru ze kterého budou načítána nastavení systému OptimAccess®:

  • Dynamické - odvozené od jména počítače. Pro tuto volbu zatrhněte Jméno souboru je odvozeno od jména počítače a vyplňte název adresáře ve kterém máte uloženy soubory s nastavením v kolonce Globální nastavení stanice stahovat z adresáře. Pokud systém OptimAccess® v tomto adresáři nenalezne příslušný soubor s nastavením, pokusí se načíst soubor definovaný pomocí statického určení jména souboru (viz níže).
  • Statické - přesně definovaná pozice a jméno souboru. Pro tuto volbu stačí vyplnit editační okno V ostatních případech se použije soubor.

    Pokud se systému OptimAccess® nepodaří načíst nastavení z žádného z definovaných typů (například při výpadku sítě), bude použito nastavení, které bylo nastaveno při posledním úspěšném pokusu.

Dynamické nastavení uživatele

Pokud chcete dynamicky nastavovat nastavení jednotlivých uživatelů zatrhněte v kartě Dynamické nastavení položku Vzdálené načítání nastavení uživatele. Poté máte na výběr ze dvou typů určení souboru ze kterého budou načítána nastavení systému OptimAccess® pro jednotlivé uživatele:

  • Dynamické - jméno bude generováno v závislosti na jméně objektu který si zvolíte. Máte možnost mezi následujícími objekty:
    • Jméno uživatele - zatrhněte volbu Jméno souboru je odvozeno od jména uživatele.
    • Jméno skupiny - zatrhněte volbu Jméno souboru je odvozeno od skupiny uživatele.
    • Jméno organizační jednotky - zatrhněte volbu Jméno souboru je odvozeno od jména organizační jednotky.
    Zvolte si podle předcházejícího výběru podle čeho bude generováno souboru s nastavením a vyplňte název adresáře ve kterém máte uloženy soubory s nastavením v kolonce Nastavení uživatele stahovat z adresáře. Priorita pokusů o načtení nastavení ze souboru se řídi následujícími pravidly
    1. Jméno uživatele - Je-li zatržena volba Jméno souboru je odvozeno od jména uživatele vytvoří se jméno souboru podle jména uživatele a soubor je hledán v adresáři uvedeném v kolonce Nastavení uživatele stahovat z adresáře. Není-li soubor na této pozici nalezen, nebo nepodaří-li se import nastavení přechází se k následujícímu bodu.
    2. Jméno skupiny - Je-li zatržena volba Jméno souboru je odvozeno od skupiny uživatele vytvoří se jméno souboru podle jména skupiny ke které uživatele náleží a soubor je hledán v adresáři uvedeném v kolonce Nastavení uživatele stahovat z adresáře. Je-li uživatel členem více skupin, pokusí se systém načíst soubor pro každou skupinu zvlášť, přičemž při prvním úspěšném pokusu nastavení importuje a pro další skupiny už import neprovádí. Není-li ani jeden soubor na této pozici nalezen, nebo nepodaří-li se import nastavení přechází se k následujícímu bodu.
    3. Organizační jednoky - Je-li zatržena volba Jméno souboru je odvozeno od organizační jednotky uživatele vytvoří se jméno souboru podle jména organizační jednotky ke které uživatele náleží a soubor je hledán v adresáři uvedeném v kolonce Nastavení uživatele stahovat z adresáře. Je-li uživatel členem více organizačních jednotek, pokusí se systém načíst soubor pro každou jednotku zvlášť, přičemž při prvním úspěšném pokusu nastavení importuje a pro další jednotky už import neprovádí. Není-li ani jeden soubor na této pozici nalezen, nebo nepodaří-li se import nastavení přechází se k následujícímu bodu.
    4. Systém OptimAccess® se pokusí načíst soubor definovaný pomocí statického určení jména souboru (viz níže).
  • Statické - přesně definovaná pozice a jméno souboru. Pro tuto volbu stačí vyplnit editační okno V ostatních případech se použije soubor.

Pokud se systému OptimAccess® nepodaří načíst nastavení z žádného z definovaných typů (například při výpadku sítě), bude použito nastavení, které bylo nastaveno při posledním úspěšném pokusu.


Manager naplánovaných akcí

Veškeré naplánované akce si lze prohlížet a editovat pomocí následujícího postupu:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace rozbalte ikonu Okolní stanice.
  4. V levém okně ovládací aplikace poklepáním myši označte vybraný počítač (který vám slouží jako server pro naplánované úlohy) pomocí rozbalení ikon Síťové okolí, Databáze okolních počítačů nebo Nalezené počítače. Viz kapitola OptimAccess® Remote Control
  5. Rozbalte ikonu Remote Control.
  6. Jedná-li se o počítač platforem Windows NT, Windows 2000 a nebo Windows XP rozbalte ikonu Globální nastavení stanice, jinak pokračujte následujícím bodem.
  7. Rozbalte ikonu Remote Control a označte ikonu Manager naplánovaných úloh.

V pravé části ovládací aplikace se objeví seznam úloh který je uložen na této stanici a je připraven ke zpracování. Tento seznam lze editovat pomocí následujících tlačítek :

  • Pozastavit - vybraná úloha je pozastavena.
  • Spustit - pozastavená úloha je opět spuštěna.
  • Odebrat - úloha je odebrána ze seznamu.


OptimAccess Computer Audit

Modul OptimAccess® Computer Audit slouží k evidenci a sledování programového a hardwarového vybavení počítače. Umožňuje monitorovat a sestavovat:

  • Okamžitý stav počítače – je možné provést okamžitý audit počítače či jej plánovat formou časových intervalů.
  • Softwarové balíky – nabízí možnost ručně vydefinovat či automaticky vygenerovat šablonu obsahující záznamy o podobě vzorové instalace pracovní stanice. Detailní vysvětlení pojmu naleznete pod heslem Softwarový balík.
  • Tiskové sestavy – výstupy z jednotlivých monitorovacích funkcí lze prohlížet, exportovat do souboru či generovat ve formě tiskových sestav v rámci daných časových období.

Velmi snadno lze identifikovat chybějící a přebývající aplikace a části operačního systému. Modul OptimAccess® Computer Audit představuje účinný nástroj pro kontrolu stavu programového a hardwarového vybavení počítačů a počtu instalovaných licencí vybraného software v organizaci.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul Computer Audit ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Computer Audit vylistujete jednotlivé volby a nastavení modulu OptimAccess Computer Audit.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul Computer Audit pro konkrétního uživatele ovládá pomocí nabídky Computer Audit v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice, seznam skupin a uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu Computer Audit. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem Computer Audit.

Volby modulu Computer Audit

  • Informace o stanici
  • Plánování
  • Softwarové balíky
  • Prohlížení


OptimAccess Computer Audit - Informace o stanici

Informace o stanici

Pro pohodlnou práci se získanými informacemi je doporučeno vyplnit údaje o jednotlivých stanicích. Tyto zadané údaje lze pak později zobrazovat v tiskových sestavách a práci s pořízenými údaji. Pro zadání jednotlivých položek je možné využít již existujícího mechanizmu v systémových proměnných, jméno položky je pak uzavřeno znaky '%' ( viz. obrázek ) a představuje jméno příslušné systémové proměnné.

Identifikátor stanice - pokud není vyplněno je implicitně použito jméno počítače.Tímto identifikátorem je pak pořízený scan identifikován během dalšího zpracování, vyhodnocení, ... .

Osoba zodpovědná za stanici - pokud není vyplněno je implicitně použito jméno aktuálně přihlášeného uživatele v době kdy byl scan pořízen. Pokud během provádění scanu není nikdo přihlášen nebo není možno zjistit jméno přihlášeného uživatele je použit textový řetězec "SYSTEM".

Aktuální nastavení - představuje zobrazení stěžejních informací, které se budou ukládat při pořízení scanu.

Příklad nastavení:
Identifikátorem stanice je implicitně použito jméno počítače.


Plánování

Prostřednictvím volby Plánování lze naplánovat skenování instalovaného programového a hardwarové vybavení na stanicích a automatické zálohování souborů s výsledky skenování.

Plánování scanu

Lze naplánovat s přesností na minuty v rozmezí dne, týdne, měsíce či jakýkoliv jiný interval. Mimo nastavení plánování, je zde volba zjistit stav prováděných auditů na stanicích. Volby prováděných a plánovaných scanů jsou následující:

  • Softwarový scan - při provádění softwarových scanů jsou nabízený 2 možnosti. První z nich je možnost sledovat jen spustitelné soubory (exe, com) s možností rozšířit toto scanování o uživatelem definované koncovky souborů. Druhou opačnou volbou je kontrolovat všechny soubory vyjma definovaných typů souborů, tento druh scanu je nazýván kompletní otisk počítače.
  • Hardwarový scan - zatržením volby provádět hardwarový scan bude prováděn audit hardwarového vybavení dané stanice.

Při stisku tlačítka "Zjistit stav ...", je možné dotázat se vzdálených stanic, jaká je aktuální situace s jejich scany. Je možné monitorovat průběh provádění scanů anebo zjistit aktuální datum scanu. který je na stanici k dispozici.

Plánování přenosů

Prostřednictvím volby Plánování přenosů lze naplánovat automatické zálohování s přehledem provedených auditů. Plánování je možné provádět v intervalu dne, týdne či měsíce s přesností na minuty. V danou dobu lze provést přesun provedeného auditu na vzdálenou stanici či přesunout logový soubor do zadaného adresáře. Pro přenos lze využít dva typy přenosů.
  1. Přenos na vzdálenou stanici - využívá pro kopírování souborů funkce modulu OptimAccess Remote Control. Pomocí tohoto typu lze tedy přenést soubor jen na stanice kde je nainstalován. Pro zadání přenosu stačí zadat jméno stanice. Soubor je na vzdálené stanici uložen v případě softwarového scanu do adresáře ..\OA9\LogFiles\coScanScoBackUp a pro hardwarové scany do adresáře ..\OA9\LogFiles\coScanShwBackUp. Pro specifikaci určitého adresáře využijte následujícího příkladu.

    "server|c:\CAData\pc01" - v tomto případě se logový soubor přenese na stanici server a tam se uloží do adresáře c:\CAData\pc01.
  2. Přenos do zadaného adresáře - pro přenos je použito standartního systémového kopírování operačního systému windows. Pokud se jedná o přenos na síťový disk je nuné mít na vzdálené stanici tento adresář vysdílený s právem pro zápis.

Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Plánování vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


OptimAccess Computer Audit - Softwarový balík - rozpoznávací kritéria

Softwarový balík

Softwarový balík představuje databázi známého a rozpoznatelného softwaru. Každý balík obsahuje seznam souborů vyjadřující příslušnost k danému softwaru, tyto soubory jsou nezaměnitelné a jakákoliv jejich modifikace je ihned hlášena. Balík obsahuje informace evidenčního typu o způsobu nabytí software, použitých faktur, ... . Správně vytvořená databáze softwarových balíků je klíčem k úspěchu celého principu rozpoznávání software. Pokud nainstalovaný software je chybně nebo není rozpoznán, je s největší pravděpodobnoostí chyba ve špatných rozpoznávacích podmínkách.

Vytvoření softwarového balíku

Na příslušné skupině balíků nebo na správci softwarových balíků klikněte pravým tlačítkem myši [image] a v kontextovém menu veberte příslušnou možnost. Jméno softwarového balíku musí být v celé databázi unikátní a může obsahovat jen znaky platné pro daný souborový systém (tzn. nesmí obsahovat znaky jako \, *, ...).

Přejmenování softwarového balíku

Klikněte pravým tlačítkem myši [image] na softwarový balík a vyberte příslušnou možnost.

Smazání softwarového balíku

Klikněte pravým tlačítkem myši [image] na softwarový balík a vyberte příslušnou možnost nebo vyberte daný balík a stiskněte klávesu Delete.

Informace o balíčku

Zde je možné vyplnit dodatečné informace o používaném softwaru. Jeho způsobu licencování a informace o fakturách, které byly pořízeny při nabytí softwaru.

Příklad nastavení

Rozpoznávací kritéria

Pro účely správného rozpoznávání softwarového balíku je nutné definovat pravidla rozpoznávání jednotlivých softwarů. Rozpoznávacích podmínek může být libovolný počet a softwarový balík je rozpoznán v momentě kdy je splněna alespoň jedna z nich.

  • Integritní podmínka - tato podmínka se váže na obraz souboru uloženém v softwarovém balíku. Tento obraz je nezaměnitelný a rozpoznání je tím pádem nastaveno přímo na konkrétní verzi souborů.
  • Rozpoznání podle definovaného vzoru - většina souborů obsahuje informace o své příslušnosti k produktu. Definováním pravidel jak má daný popis vypadat, lze dostatečně přesně identifikovat rozpoznání daného softwaru.
  • Rozpoznání podle vzoru s upřesněním verze - během rozpoznávání softwarového balíku je možnost upřesňovat název balíků o verzi jednotlivých souborů. V tiskových sestavách pak může mít softwarový balík název OptimAccess 9.0 (oaservernt.exe = 9.0.2.4)

Příklad nastavení

Soubory v balíku

Představuje seznam všech souborů, které náleží k danému softwaru. Informace o těchto souborech jsou použity při vyhledávání nerozlišitelných souborů. Nerozlišitelný soubor je pak soubor, který nevyhovuje žádnému rozpoznávacímu pravidlu a zároveň není obsažen v žádném softwarovém balíku.

Příklad nastavení

Přidělení na stanici

Umožňuje uložit informace o tom kde a kým byl software nainstalován (přidělen k užívání) a s jakým licenčním číslem. Tyto vyplněné údaje pak lze později využít při vyhodnocování v tiskových sestavách.

Příklad nastavení

Podbalíčky

Pokud se některý produkt skládá ze samostatných programů, je možné definovat seznam software z kterého se softwaroý balíček skládá. Tento balíček pak nemusí mít žádnou podmínku pro rozpoznání a jeho rozpoznání je založeno na substituci, kdy pokud jsou na stanici nalezeny všechny softwarové balíčky uvedené v seznamu, je tento seznam nahrazen za jméno softwarového balíku.

Příklad nastavení

Historie

Všechny operace provedené se softwarovým balíkem jsou zaznamenávány do logového souboru. V tomto dialogovém okně je možné zobrazit si informace o změnách provedených v danému softwarovém balíku.


OptimAccess Computer Audit - Generování softwarových balíků

Generování softwarových balíků

Na základě pořízených softwarových scanů, lze z těchto nabytých informací generovat softwarové balíky.

    Možnosti generování:
  • Generování podle adresáře - při generování se sestavuje adresářová struktura podle toho zda zdresář obsahuje nějaké soubory. Soubory obsažené ve vybraném adresáři zobrazíte dvojklikem na daný adresář. Softwarový balík pak je možné uložit označením příslušného adresáře a stiskem tlačítka Uložit vybrané balíky pod společným názvem.
  • Generování podle jména produktu - většina souborů obsahuje informaci o názvu produktu k němuž patří. Generování pak probíhá podle těchto informací a soubory mající příslušnost k stejnému produktu jsou sdružovány do skupiny s příslušným názvem. Soubory, které neobsahují informaci o produktu jsou zařazeny do skupiny Nerozlišené soubory.
      Možnosti uložení balíku
    • Uložit vybrané balíky - pokusí se uložit softwarové balíky pod originálním názvem, který obsahují soubory uložené v softwarovém scanu.
    • Uložit vybrané balíky pod společným názvem - umožní uložit více softwarových balíků pod společným názvem.

Poznámka: Název softwarového balíku musí obsahovat jen znaky platné pro souborový systém. Tzn. nesmí obsahovat znaky jako \,*, ... .

Ukázka generování podle adresářů

Ukázka generování podle jména produktu


OptimAccess Computer Audit - Správce softwarových balíků

Správce softwarových balíků

Test na korenktnost databáze softwarových balíků

K rozpoznání softwarového vybavení jsou určena rozpoznávací kritéria. Jedním jejich možným typem je podmínka na intergritu. V tomto případě k rozpoznání softwarového balíku musí souhlasit obraz souboru na disku a v balíku. Pokud by se stejná podmínka na soubor vyskytovala ve více softwarových balících pak může dojít k nekorektnímu rozpoznání. Za tímto účelem je dobré čas od času zkontrolovat jedinečnost těchto podmínek.

Co dělat při výskytu duplicitních podmínek
Při výskytu duplicity jsou vypsány duplicitní soubory a softwarové balíky v kterých se nacházejí. Při stisku tlačítka opravit se odstraní podmínky integrity na zatržených souborech a v zatržených softwarových balících.

Ukázka špatně vytvořené databáze balíků

Ovládání manageru softwarových balíků se provádí prostřednictvím kontextového menu, které se zobrazí po stisku pravého tlačítka myši na ikoně Správce softwarových balíků, kterékoliv ikoně softwarového balíku nebo skupiny softwarových balíků.

Neviditelná skupina

Při vyhledávání nainstalovaných softwarových balíků a generování tiskových sestav, můžete občas potřebovat, aby se informace o určitém softwarovém vybavení nebrali v potaz. K tomuto účelu slouží funkce zneviditelnění skupiny softwarových balíků. Softwatové balíky obsažené v této skupině pak budou pro potřeby dalšího vyhodnocení neviditelné.


OptimAccess Computer Audit - Porovnání softwarových scanů

Porovnání softwarových scanů

Umožňuje vizuálně zobrazit rozdíly mezi referenčním a kontrolním auditem softwarového vybavení. Zobrazená data lze exportovat do souboru typu csv pro pozdější zpracování nebo uložit výsledek jako softwarový balík.

    Typy jednotlivých dat:
  • Soubory navíc - soubory z kontrolovaného scanu se nenacházejí v referenčním scanu
  • Soubory chybějící - soubory z referenčního scanu se nenacházejí v kontrolovaném scanu
  • Soubory modifikované - soubor v jednotlivých scanech byl modifikován (tzn. nesouhlasí intergrita souboru)
    Možnosti nastavení
  • Využívat informace v balících - při zatržení této volby se při zobrazení informací o souboru pokusí systém nalézt, zda tento soubor nepatří do některého softwarového balíčku.
  • Vyhledávat jen podle rozpoznávacích kritérií - tato volba je v návaznosti na zatržení první volby. Při zatržení se vyhledávají informace o příslušnosti k softwarovému balíčku jen podle rozpoznávacích kritérií. Pokud volba zatržena není, pak se rozpoznává podle čehokoliv, ať soubory patří do balíčku a jsou v rozpoznávacích kritériích nebo jen do balíčku patří a nerozpoznává se podle nich.
    Příklad využití:
  • Porovnání scanů -
  • Zjištění nerozlišitelných souborů -
  • Zjistění jaký software je na stanici -
Příklad:


OptimAccess Computer Audit - Porovnání hardwarových scanů

Porovnání hardwarových scanů

Umožňuje vizuálně zobrazit rozdíly mezi referenčním a kontrolním auditem hardwarového vybavení. Zobrazená data lze exportovat do souboru typu csv pro pozdější zpracování.

    Typy jednotlivých dat:
  • Zařízení navíc - zařízení se nevyskytuje v referenčním scanu
  • Chybějící zařízení - zařízení se nevyskytuje z kontrolovaném scanu
Příklad:


Untitled

 OptimAccess Computer Audit - Prohlížení hardwarových scanů scanů

Prohlížení hardwarových scanů

Umožňuje rychle zobrazit nasbírané informace o hardwarovém vybavení stanice v přehledné grafické podobě.

Příklad:


OptimAccess Computer Audit - Tiskové sestavy

Tiskové sestavy

Za účelem vyhodnocení poskytuje modul ComputerAudit několik tiskových sestav. Ty jsou generovány ve formátu RTF a poskytují sumarizační údaje.

Vybavení stanice

Zajistí vygenerování tiskové sestavy s přehledně zobrazeným softwarovým nebo hardwarovým vybavení stanic.
    Možnosti
  • Kontrolovat počet licencí - zobrazí sumarizační tabulku s počtem zjištěných licencí a počtu evidovaných licencí.
  • Vypisovat nerozlišené soubory - zobrazí soubory, které ještě nejsou obsaženy v databázi softwarových balíků a tudíž se podle nich nemohlo provést správné rozpoznání.
  • Zobrazovat osobu jenž balík nainstalovala - pokud je v databázi softwarových balíků uvedeno přidělení na software na stanici, je ve výsledné sestavě zobrazeno jméno osoby, která toto přidělení provedla.

Přehled licencí

Výsledkem tiskové sestavy je přehledná tabulka o aktuálním stavu zjištěných licencí,vzhledem k stavu uvedeném v evidenci. Tato sestava se pořizuje v situaci kdy je nutné zjistit celkový počet využitých licencí ve společnosti.

Detailní dotaz

Sestava poskytuje informace o tom, kde je daný software fyzicky nainstalován nebo naopak kde nainstalován není.

Předávací protokol

Z informací o softwarovém a hardwarovém vybavení lze vytvářet předávací protokoly softwarového nebo hardwarového vybavení jednotlivých stanic uživatelům, kteří zodpovídají za jejich stav.

Porovnání SW (HW)

Sestava umožní zobrazit výsledky porovnání jednotlivých auditních souborů a tím získat přehled o změnách ve vybavení stanic vzhledem ke stanovenému vzoru. Sestava umožní rozlišit software navíc či chybějící a v případě HW auditů rozdílnost předaného vybavení a současného stavu.

Hlavička a patička reportu

Pro generovaní tiskových sestavy lze definovat vlastní hlavičky a patičky vygenerovaných dokumentů. Pro toto použití se v adresáři ..\OA\module musí vyskytovat soubory formátu RTF:
- reportFooter.rtf pro patičku
- reportHeader.rtf pro hlavičku
Pokud tyto soubory existují, pokusí se systém při každém vygenerování tiskových sestav nastavit obsah těchto souborů jako hlavičku a patičku dokumentu.


OptimAccess WorkSpy

Modul WorkSpy má za úkol monitorovat veškeré aktivity spojené s prací uživatelů na pracovních stanicích. Pomocí svých nastavení je schopen nejen činnosti monitorovat, archivovat a vyhodnotit, ale v případě nutnosti na ně i patřičně reagovat. Reakcí na akci je myšlena funkce okamžitého upozornění správce systému v případě výskytu definovaných akcí provedených uživatelem nebo aplikací na pracovních stanicích.
Význam modulu WorkSpy spočívá v získaní přehledu o činnosti uživatelů a aplikací na pracovních stanicích organizace a možnosti okamžitě reagovat při porušení bezpečnostní politiky.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul WorkSpy ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce WorkSpy vylistujete jednotlivé volby a nastavení modulu OptimAccess WorkSpy.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul WorkSpy pro konkrétního uživatele ovládá pomocí nabídky WorkSpy v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice, seznam skupin a uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu WorkSpy. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem WorkSpy.

Volby modulu WorkSpy

  • Nastavení
  • Rozšířené nastavení
  • Plánování
  • Prohlížení


Nastavení

Prostřednictvím volby Nastavení máte možnost zvolit události, které mají být modulem WorkSpy monitorovány.

Základní monitorování

  • Zapnutí a vypnutí PC
  • Přihlašování uživatelů
  • Pauzy - monitorují se intervaly kdy uživatel neprojevil aktivitu na stanici (psaní na klávesnici, pohyb myši)
  • Spuštěné aplikace - jsou zaznamenávány informace o aplikacích vyskytujících se na popředí.

Internet

  • Přístup k www stránkám - monitoruje přístupy k www stránkam prostřednictvím aplikací využívající jádro Internet Exploreru verze vyšší než 4.0.
  • Stažené soubory z internetu - jsou monitorovány soubory stažené pomocí prohlížeče Internet Exploreru. Jsou monitorovány jen soubory určitých koncovek.

    Vyčet koncovek: exe, com, zip, rar, gzip, tar, ace, gz, cab, doc, xls, pdf, pps, ps, mpeg, avi, mov, mp3, mpg, wav, bin, iso, ccd, cue

  • Mail přílohy - monitorovány přijaté a odeslané přílohy prostřednictvím programu Microsoft Oulook.
  • Traffic síťové karty - zaznamenává příchozí a odchozí objem dat v definovaných intervalech.

Souborový systém

  • Sledování výměnných medií – zaznamenává pohyb souborů na výměnných mediích.
  • Sledovat operaci formát - pokud se vyskytne v systému operace formát na médiu je zapsána do logového souboru.
  • Podmínky pro sledování – sledování operací na souborovém systému obecně lze zabezpečit definicí podmínek pro sledování. Podmínka pro sledování může nabýt příznaku inverzní, tzn. pokud je splněna nebude se daná operace monitorovat. Ve výsledku jsou pak monitorovány ty operace, které vyhovují alespoň jedné podmínce pro sledování a nevyhovují ani jedné inverzní podmínce. Pro sledování operací na síťových discích zadejte v podmínce položku adresář UNC cestu (např. \\server\c).

Operační systém

  • Použití ovládacích panelů – přístup k ovládacím panelům je založen na monitorování souborů s příponami cpl.
  • Tisknuté soubory - jsou monitorovány tiskové úlohy směrující na připojené tiskárný dané stanice.
  • Úprava registrů – zaznamenávány veškeré zásahy v registrační databázi způsobené programy regedit.exe nebo regedt32.exe.
  • Připojení, odpojení USB zařízení - monitoruje události jako připojení a odpojení USB zařízení.

Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Nastavení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Plánování

Prostřednictvím volby Plánování lze naplánovat automatické zálohování či odstraňování logových souborů s přehledem sledovaných událostí. Plánování je možné provádět v intervalu dne, týdne či měsíce s přesností na minuty. V danou dobu lze provést přesun logového souboru na vzdálenou stanici, smazat logový soubor či přesunout logový soubor do zadaného adresáře. Pro přenos lze využít dva typy přenosů.
  1. Přenos na vzdálenou stanici - využívá pro kopírování souborů funkce modulu OptimAccess Remote Control. Pomocí tohoto typu lze přenést soubor jen na stanice, kde je RemoteControl nainstalován. Pro zadání přenosu stačí zadat jméno stanice. Soubor je na vzdálené stanici pak uložen do adresáře ..\OA9\LogFiles\WorkSpyBackUp. Pro specifikaci určitého adresáře využijte následujícího příkladu.

    "server|c:\WspData\pc01" - v tomto případě se logový soubor přenese na stanici server a tam se uloží do adresáře c:\WspData\pc01.
  2. Přenos do zadaného adresáře - pro přenos je použito standartního systémového kopírování operačního systému windows.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Plánování vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


OptimAccess WorkSpy - Nastavení alertů

Nastavení alertů

Představuje nastavení akcí, které se provedou při výskytu alertu.

    Možnosti
  • Zaslání emailu - na vydefinovaný seznam se pošle upozornění ve formě emailu. Emaily se zasílají přes smtp server a je tedy nutné nastavit vlastnosti zasílání.
  • Spuštění procesu - při výskytu alertu se spustí definovaný proces s parametrem zprávy

Ukázka nastavení


OptimAccess WorkSpy - Alerty

Alerty

Alerty představují možnost vydefinovat z monitorovaných akcí určité vzory a pokud během monitorování bude splňovat nějaký záznam definovaný vzor, bude vyvolána akce definovaná v Nastavení alertů.

Schéma akcí při výskytu monitorované akce

Při výskytu monitorované události projde záznam monitorované události před zaznamenáním do logového souboru filtrovací a alertovou vrstvou. Filtrovací vrstva určí zda dále pokračovat ve zpracování a je pro nás záznam hodnotný nebo se jednoduše zahodí a dál se s ním nepracuje. Pokud záznam vyhovuje filtrování je zpracován alertovou vrstvou, která otestuje zda se má vyvolat alert .
Ze schématu vyplývá, že alerty souvisí s nastaveným monitorováním. Definice alertu nezapíná sledování, ale jen přidává podmínky do alertové vrsty!

Definování alertů

Alerty lze definovat pro jakékoliv monitorované akce (viz. Nastavení monitorování). Definovaný alert představuje vzor jak má vypadat monitorovaný záznam, aby se vyvolala definovaná akce.
Každá monitorovaná akce má určité nastavitelné vlastnosti, ty mohou být typu číslo, text nebo datum. Jednotlivé vlastnosti jsou definovány s operátory. Porovnání pak probíhá podle rovnice:

(ne)dělat alert jestliže hodnota vlastnosti v monitorovaném záznamu je <,>,= než hodnota definované akce v alertu

Návod

Postup jak vytvořit upozornění na uživatele, kteří surfují po internetu v pracovní době na jiných stránkách, než které jsou z domény www.centrum.cz.

Po stisku tlačítka přidat vyberte příslušný alert, v našem případě v sekci Internet a položka Přístup k www stránkám.

V okně s nastavení vydefinujeme, že chceme upozornění pokud se vyskytne jakýkoliv záznam o internetové aktivitě v době od 8:00 do 16:30.

Nyní musíme vydefinovat inverzní alert, který vymezí z alertového systému doménu centrum.cz. Klikněte na vytvořený alert a zvolte volbu kopírovat.

Vytvoříme alert, který říká nespouštěj se pokud se jedná o záznam návštěvy www stránky z domény centrum.cz

Výsledný zápis pak vypadá následovně. Nenechte se zmást, v tomto ilustrativním případě je ještě definován alert reagující na vytvoření souboru s koncovkou avi.


OptimAccess WorkSpy - Speciální alerty

Speciální alerty

Speciální alerty nesouvisí s monitorováním přímo, ale doplňují alertový systém o bezpečnostní alerty modulu OptimAccess WorkSpy. Speciální alerty mají možnost definovat individuální nastavení pro vyvolanou akci.

    Dostupné speciální alerty
  • Mimořádný zápis záznamů do logového souboru - postupem času využívání monitorování lze vypozorovat průměrný počet záznamů zapisovaných do logového souborů. Tuto hodnotu pak brát jako prahovou pro rozpoznání neobvyklé aktivity na stanici a vyvolat příslušný alert.
  • Mimořádný přenos dat přes síť - lze definovat alert na příchozí, odchozí nebo celkový objem dat přenesených přes počítačovou síť za určitý interval.

Ukázka nastavení


OptimAccess WorkSpy - Filtrování

Filtrování

Funkce filtrování upřesňuje možnosti monitorování a zajistí monitorování jen podstatných akcí. Každý filtr přestavuje definovaný vzor, jak má vypadat zapisovaný záznam do logového souboru. Zaznamenání záznamu do logového souborů dojde v případě, jestliže záznam vyhovuje alespoň jednomu filtru a nevyhovuje ani jednomu inverznímu filtru.

  • Filtrová podmínka - v případě, že existuje tato podmínka, zaznamenávají se jenom záznamy, které vyhovují této podmínkce
  • Inverzní filtrová podmínka - monitorované záznamy, které splňují tuto podmínku se nezaznamenávají do logového souboru

Ukázka nastavení, ve které se nemonitoruje návštěna www stránek z domény centrum.cz


Prohlížení

S použitím funkce Prohlížení máte možnost generovat tiskové sestavy za vymezený časový interval formou od/do s přesností na vteřiny a detailně prohlížet logové soubory se záznamem sledovaných událostí.

Detailní prohlížení

Volba nabízí možnost prohlížení logových souborů se sledovanými událostmi v grafickém prostředí. Umožňuje filtrovat jednotlivé událostí na základě typu a časového intervalu s přesností na vteřiny.

Tiskové sestavy

Nabídka obsahuje generování tiskových sestav.
  • Aplikace na popředí – seznam všech aplikací spuštěných na počítači v definovaném časovém intervalu. Ve výsledné sestavě je možno zanedbat aplikace, které se na popředí vyskytovaly kratší dobu než zadaná hodnota v sekundách.
  • Využitelnost PC – výpis skutečného využití stanice v době jejího běhu očištěný o prodlevy. V sestavě je možno pominout záznamy s menším zastoupením než udaná procentuelní hodnota. Sestavu je možno generovat v rámci periody dne, týdne, měsíce či bez časového omezení.
  • Četnost WWW stránek – přehled navštívených internetových stránek v zadaném časovém intervalu s přesností na dny. Sestavu je možno generovat v rámci periody dne, týdne, měsíce či bez časového omezení.
  • Aktivity na internetu - umožňuje zobrazit četnost navštěvnosti jednotlivých internetových stránek, výčet stažených souborů z internetu nebo celkový objem přenesených dat skrz internetový prohlížeč. Sestavu je možno generovat v rámci periody dne, týdne, měsíce či bez časového omezení.

Pro generovaní tiskových sestavy lze definovat vlastní hlavičku a patičku dokumentů. Pro toto použití se v adresáři ..\OA\module musí vyskytovat soubory formátu RTF:
- reportFooter.rtf pro patičku
- reportHeader.rtf pro hlavičku
Pokud tyto soubory existují, pokusí se systém při každém vygenerování tiskových sestav nastavit obsah těchto souborů jako hlavičku a patičku dokumentu.

Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Prohlížení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Chcete-li pracovat s jednotlivými tiskovými sestavami, musíte je nejprve vylistovat stiskem myši na ikoně Tiskové sestavy v levém okně ovládací aplikace. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


OptimAccess® NetHand

Modul OptimAccess® NetHand je určen pro vzdálenou administraci stanic pomocí převzetí obrazovky a dávkovou distribuci software.

Ovládání a výběr stanice nebo skupiny se kterou se bude prostřednictvím modulu OptimAccess® NetHand manipulovat je shodný s ovládáním modulu OptimAccess® Remote Control a to pomocí rozbalení ikony Okolní počítače v levé části hlavní ovládací aplikace.

Ovládání ve Windows 9x, NT, 2000 a XP

V prostředí Windows 9x, Windows NT, Windows 2000 a Windows XP se modul Extension ovládá prostřednictvím aplikace OptimAccess® následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jejich vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace rozbalte ikonu Okolní stanice.
  4. V levém okně ovládací aplikace poklepáním myši označte počítač nebo skupinu pomocí rozbalení ikon Síťové okolí, Databáze okolních počítačů a Nalezené počítače
  5. V levém okně ovládací aplikace rozbalte ikonu NetHand.

Volby modulu OptimAccess® NetHand

V rámci modulu OptimAccess® NetHand lze se vzdálenou stanicí provádět následující akce:

  • Prohlížení/převzetí vzdálené stanice - a to ve dvou módech :
    • GUI_single - obraz vzdálené stanice je zobrazován v hlavní ovládaví aplikaci. V tomto módu lze provádět pouze prohlížení vzdálené stanice.
    • Win_single - obraz vzdálené stanice je zobrazován v samostatném okně. V tomto módu lze provádět prohlížení i převzetí vzdálené stanice.
  • Distribuce software


Prohlížení vzdálené stanice z ovládací aplikace (mód GUI_single)

Zvolením volby Prohlížení stanice v oblasti modulu OptimAccess® NetHand se v pravé části ovládací aplikace zobrazí dialogové okno umožňující připojení a prohlížení stavu obrazovky vzdálené stanice. V editovacím okně Stanice si můžete zvolit stanici, kterou chcete prohlížet (v případě že ovládáte skupinu počítačů). Po stisku tlačítka Spojit se aplikace pokusí navázat spojení se vzdálenou stanicí. V případě úspěchu se zobrazí obsah obrazovky vzdálené stanice ve vyhrazené části obrazovky.

Chcete-li zobrazit obsah obrazovky vzdálené stanice ve vyšším rozlišení, nebo pokud požadujete převzetí stanice, je nutné stisknout tlačítko Přepnout do samostatného okna, které automaticky vytvoří nové na aplikaci nezávislé okno, ve kterém je zobrazován obsah vzdálené stanici. Spojení s hlavní aplikací se v tomto okamžiku ukončí a obraz je zobrazován pouze v samostatném okně (viz mód Win_single).


Prohlížení a převzetí stanice ze samostatného okna (mód Win_single)

Do módu prohlížení vzdálené stanice ze samostatného okna (mód Win_single) se dostanete následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte složku OptimAccess® a klepněte na položku OptimAccess®.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového jména a hesla. Po jejich vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess®.
  3. V levém okně ovládací aplikace rozbalte ikonu Okolní stanice.
  4. V levém okně ovládací aplikace poklepáním myši označte počítač nebo skupinu pomocí rozbalení ikon Síťové okolí, Databáze okolních počítačů a Nalezené počítače
  5. V levém okně ovládací aplikace rozbalte ikonu NetHand a označte ikonu Prohlížení stanice.
  6. V pravé části ovládací aplikace zvolte v části Stanice stanici kterou chcete prohlížet.
  7. Stiskněte tlačítko Přepnout do samostatného okna.

Po dodržení tohoto postupu se v případě, že zvolená stanice je spuštěna a systém OptimAccess® je na této stanici aktivní, vytvoří samostatné okno ve kterém se bude zobrazovat aktuální stav požadované obrazovky.

Ovládací menu nově vzniklého okna nabízí tyto možnosti :

  • Zobrazit - je možné zvolit rozlišení ve kterém bude obraz přenášen a zobrazován. V případě zvolení volby 1:1 bude zobrazována obrazovka vzdálené stanice v aktuálním rozlišení.
  • Správce -> Převzít - dojde k převzetí kontroly ovládacími prvky vzdálené stanice (myš, klávesnice). Díky této volby můžete ovládat vzdálenou stanici. Pokud chcete přepnout zpět do módu prohlížení zvolte nově vzniklou volbu v menu Správce -> Vrátit.
  • Správce -> Zaslat obsah schránky - zašle aktuální obsah schránky (clipboardu) na vzdálenou stanici. Tato možnost je aktivní pouze v případě, že je převzata kontrola na ovládacími prvky vzdálené stanice (viz Správce -> Převzít).
  • Správce -> Přebrat obsah schránky - zašle aktuální obsah schránky (clipboardu) ze vzdálené stanice na lokální stanici. Tato možnost je aktivní pouze v případě, že je převzata kontrola na ovládacími prvky vzdálené stanice (viz Správce -> Převzít).
  • Konec - ukončí prohlížení / převzetí vzdálené stanice.


Distribuce software

Volba Distribuce software modulu OptimAccess® Standard nabízí následující možnosti:

  • Kopírování adresáře před provedením akce - kopírování se provádí ze zadaného zdrojového adresáře do adresáře cílového. Zdrojová i cílová cesat musí být viditelná ze stanice na které je distribuce software prováděna.
  • Provést akci - lze definovat soubor, který se spustí po dokončení kopírování souborů zadaných souborů
  • Kopírování adresáře po provedené akci - kopírování se provádí ze zadaného zdrojového adresáře do adresáře cílového a to po dokončení akce definované v předchozí volbě. Zdrojová i cílová cesta musí být viditelná ze stanice na které je distribuce software prováděna.
  • Mazání adresáře po provedené akci - lze definovat adresář který se po provedení všech výše definovaných akcí vyčistí.
  • Exportovat do souboru - vytvořený distribuční balíček lze exportovat do souboru.
  • Importovat ze souboru - již dříve vytvořený distribuční balíček lze prostřednictvím tohoto tlačítka zpětně ze souboru importovat.
  • Aplikovat distribuční balíček - po stisku tohoto tlačítka je distribuční balíček zaslán vybrané vzdálené stanici nebo skupině stanic a je aplikován.


OptimAccess Centrální správa

Centrální správa

Centrální správa je vytvořena za účelem globální správy monitorovacích a auditních záznamů. Její funkce jsou součástí ovládací aplikace a představují efektivní nástroj pro zpětné vyhodnocení nasbíraných dat z kterékoliv stanice a přístup k požadovaným datům.

    Základní charakteristiky:
  • Skupinování - základní myšlenkou fungování centrální správy je, že sbíraná data jsou tříděna do skupin podle oddělení, pracovních stanic nebo jednotlivých uživatelů, kteří se stanicemi pracují. Nad touto vybudovanou adresářovou strukturou jsou pak vystaveny organizační skupiny. Tyto skupiny se spojují do vyhodnocovacího stromu a tím je možné cílit dotazy na jednotlivá oddělení nebo celou společnost.
  • Individuální nastavení - každá skupina má možnost definovat své nastavení nebo převzít nastavení svého předchůdce.

Organizační skupina

Organizační skupina představuje seznam skupin a uživatelů, pro které se v rámci dané skupiny bude provádět vyhodnocování. Obsahuje-li skupina podskupiny pak vyhodnocování je prováděno automaticky i pro podskupiny. S tímto faktem souvisí klást důraz na vytváření menších skupin a ty pak skupinovat ve větší s cílem později efektivně provést jakýkoliv dotaz.

Uživatele je možné zadávat včetně domény, vzor uživatel/doména.

Příklad nastavení

Vytváření skupin

  • Převzetí z databáze okolních počítačů z modulu OptimAccess RemoteControl - pokud již máte vytvořenou databázi okolních počítačů můžete tuto databázi využít a to způsobem drag&drop, kdy přetáhnete myši skupiny z okolních počítačů do databáze organizačních skupin.
  • Ruční vytváření - klikněte pravým tlačítkem [image] na Databázi organizačních skupin nebo na již vytvořenou organizační skupinu a z kontextového menu vyberte příslušnou volbu.

Nastavení centrální správy

Nastavení centrální správy se týká nastavení adresářových cest k logovým souborů, kam je lokální stanice v průběhu odkládají. Každý modul má své vlastní nastavení.

Globální nastavení

Aby nebylo potřeba neustále vyplňovat již jednou zadané údaje, je nastavení aktuální skupiny vždy děděno od jeho předchůdce. Globální nastavení v tomto směru funguje jako implicitní nastavení pro skupiny vytvořené na nejvyšším stupni vyhodnocovacího stromu organizačních skupin.

Příklad přebírání nastavení:

Individuální nastavení organizační skupiny

Každá skupina má možnost upřesnit nastavení, které zdědila od svého předchůdce a tím omezit neustálé nastavování.

Celkový postup

Celkový přístup ve finále vypadá tak, že lokální stanice odevzdávají logové soubory do definovaných adresářů, který simulují jednotlivá oddělení nebo skupiny. Tyto adresáře jsou pak spojeny s organizačními skupinami pro vyhodnocavání a v průběhu času pak stačí provádět jednotlivé dotazy na vyhodnocení.

Důvod proč členit data do adresářů a nemít jen jeden adresář s logy je velmi jednoduchý, rychlejší nalezení příslušného logového souboru a tím zrychlení celého procesu vyhodnocení.


OptimAccess Centrální správa - Computer Audit

Centrální správa a Computer Audit

Nastavení centrální správy z hlediska modulu Computer Audit zahrnuje nastavit cestu k adresáři, kde je umístěna databáze softwarových balíků, adresář s kontrolovanými a referenčními scany. Toto nastavení pak při vyhodnocování přebírají tiskové sestavy pro vygenerování příslušných reportů.

Z nastavení organizační skupiny se bere v potaz pouze nastavení stanic a nastavení uživatelů se ignoruje. Pro danou organizační skupinu je prováděno vyhodnocení , pokud v zadaném adresáři byl nalezen požadovaný soubor s patřičným jménem stanice uvedeným v definici organizační skupiny.

Formát logového souboru - logový soubor se skládá z prefix.JMENO STANICE.DATUM POŘÍZENÍ.suffix
Softwarový scan - coscan.UCTARNA01.03.09.03 08.00.30.sco
Hardwarový scan - coscan.UCTARNA01.03.09.03 08.00.30.hco

  • Adresář referenčních scanů - do vyhodnocování jsou zařazeny soubory s nejstarším datem.
  • Adresář kontrolovaných scanů - do vyhodnocování jsou zařazeny nejnovější auditní soubory.

Příklad nastavení


OptimAccess Centrální správa - WorkSpy

Centrální správa a WorkSpy

Nastavení centrální správy z hlediska modulu WorkSpy zahrnuje nastavit cestu k adresáři, kde se nacházejí logové soubory z jednotlivých pracovních stanic.

Z nastavení organizační struktury se bere v potaz jak nastavení stanic tak uživatelů.

    Kombinace nastavení organizační skupiny
  • Zadány pouze stanice - vyhledají se soubory pro dané stanice a v nich se hledají potřebné informace
  • Zadány stanice a uživatelé - vyhledají se soubory pro dané stanice a v nich se hledají informace co definovaní uživatelé dělali
  • Zadáni pouze uživatelé - vyhledají se všechny dosažitelné logové soubory bez omezení z které stanice pocházejí a hledají se informace o daných uživatelích.

Formát logového souboru - logový soubor se skládá z prefix.JMENO STANICE.DATUM POŘÍZENÍ.suffix
Logový soubor - wsp.UCTARNA01.03.09.03 08.00.30.csv

Příklad nastavení


Doporučený postup konfigurace

  1. Vyexportovat základní nastavení systému OptimAccess® do datového souboru. Je vhodné uložit si základní nastavení bez jakýchkoliv změn. V případě instalace systému OptimAccess® pod Windows 9x proto ukončete průvodce stiskem tlačítka Storno a vyexportujte základní nastavení systému (bez případných změn). Určitě toto základní nastavení budete potřebovat v případě rozsáhlých aktualizací programového vybavení počítače či samotného operačního systému (podrobnosti naleznete pod heslem Jak postupovat v případě změny konfigurace OS?).
  2. Zakázat instalaci nových programů. Je vhodné použít pro jména instalačních souborů obecnou masku *setup* a *install* (některé programy totiž v názvu souboru instalátoru obsahují rovněž i číslo verze či jazykovou mutaci).
  3. Nemáte-li instalován nadstavbový modul Extension, je vhodné aktivovat kompletní ochranu Registrační databáze. Dále pokračujte v tomto postupu podle bodu č. 6.
  4. Máte-li instalován nadstavbový modul Extension případně nepoužijete-li funkci pro kompletní ochranu Registrační databáze, je vhodné chránit následující Ovládací panely: Systém, Síť, Možnosti sítě Internet, Pošta, Modemy.
  5. V modulu Extension použijte toto nastavení:
    • Nastavení vlastností Ovládacích panelů
      • karta Síť: označit volbu Sdílení souborů a tiskáren
      • karta Hesla: označit volby Zákožka Vzdálená správa a Záložka Profily uživatelů
      • karta Tiskárny: označit volby Přidání tiskárny a Záložka Podrobnosti tiskárny
      • karta Obrazovka: označit volbu Skryj záložku Nastavení
    • Nastavení vlastností Průzkumníka a Složky
      • karta Průzkumník: s výjimkou volby Zobrazení ikony Připojení síťové jednotky označit všechny ostatní volby
      • karta Vlastnosti Složky: označit všechny volby
    • Ochrana nastavení aplikací
      • karta Internet Explorer: označit volby Chránit nastavení domovské stránky a Chránit nastavení Připojení k internetu
      • karta Word: označit všechny volby
      • karta Excel: označit všechny volby
      • karta Outlook: označit všechny volby
    • Bezpečnost
      • karta Bezpečnost: označit volbu Nástroje pro editaci registrů
  6. V modulu Computer Audit použijte postup s ohledem na instalované programové vybavení.
    • Mají-li mít všechny stanice stejnou konfiguraci programového vybavení (například jednotlivé stanice v počítačové učebně):
      1. Nainstalujte a nakonfigurujte počítač dle požadované specifikace.
      2. Vytvořte referenční scan vzorového počítače.
      3. V rámci Databáze okolních počítačů si vytvořte skupinu a začleňte do ní všechny počítače.
      4. V rámci skupiny vylistujte Plánování scanu nastavte plánování pro všechny počítače na požadovaný interval.
      5. V rámci skupiny porovnejte scany jednotlivých stanic vůči referenčnímu scanu prostřednictvím voleb Prohlížení – je třeba mít zatrženou volbu Referenční scan a vylistovaný příslušný soubor se scanem vzorového počítače.
    • Mají-li mít stanice individuální konfiguraci programového vybavení s ohledem na pracovní zařazení (například pracovní stanice pro skupiny typu sekretariát, techničtí pracovníci, vedení, atd.):
      1. V rámci Databáze okolních počítačů si vytvořte skupinu a začleňte do ní odpovídající počítače.
      2. V rámci nastavení příslušné skupiny vylistujte Plánování přenosů, označte volby Ihned po provedení scanu, provést danou akci a Posílat softwarové scany na vzdálenou stanici a do pole Název stanice vyplňte počítač z nějž je systém OptimAccess® administrován. Nezapomeňte tuto změnu aplikovat stiskem tlačítka Použít a rozeslat tak nastavení všem počítačům ve skupině.
      3. V nastavení skupiny vylistujte Plánování scanu a pomocí tlačítka Provést ihned ... proveďte oskenování všech počítačů. V tomto okamžiku budete mít na ovládací stanici pro všechny stanice ve skupině jim příslušející referenční scany.
      4. Pro skupinu vylistujte Plánování scanu nastavte plánování pro všechny počítače na požadovaný interval.
      5. V rámci skupiny porovnejte scany jednotlivých stanic vůči referenčnímu scanu prostřednictvím voleb Prohlížení – je třeba mít zatrženou volbu Adresář referenčních scanů a vylistovanou příslušnou složku se scany jednotlivých počítačů ve skupině.
    • Provádění kompletního otisku stanice může mnohdy díky velkým diskům trvat i desítky minut a v jeho průběhu jsou generovány nemalé objemy dat. Budete-li používat volbu Provádět kompletní otisk počítače je vhodné omezit sledované soubory jen na nutné minimum formou přípon.

  7. V modulu WorkSpy je s ohledem na účely archivace a auditu vhodné logy ukládat na server (například ovládací stanici). Pro skupinu vylistujte Plánování přenosu nastavte jej s použitím volby Přesouvat logový soubor na vzdálenou stanici a Název stanice.

    Výhody přesunu logů na server:

    • nezabírají místo na disku lokální stanice;
    • jsou chráněny proti poškození či úmyslné modifikaci.

  8. Nastavit následující ochranu adresářové struktury:
    • složce WINDOWS nastavit příznak RO, souborům v ní ponechat základní nastavení příznaků
    • složkám COMMAND, INF, FONTS a SYSTEM, včetně souborů v nich obsažených, ve složce WINDOWS nastavit příznak RO
    • složce SYSBACKUP ve složce WINDOWS nastavit příznak WR, souborům v ní obsaženým nastavit příznak RO s výjimkou souborů Rb001.cab až Rb005.cab (ponechat nastavený příznak WR)
    • nastavit příznak WR pro všechny soubory *.ini a *.txt ve složce WINDOWS
    • nastavit příznak WR souboru Win386.swp ve složce WINDOWS
    • máte-li instalován program Microsoft Office, nastavte pro všechny jeho složky příznak RO, u souborů ponechejte původní nastavení příznaků (základní složka pro instalaci programu Microsoft Office je C:\Program Files\Microsoft Office)
    • složkám C:\Program Files\Internet Explorer a C:\Program Files\Outlook Express nastavit příznak RO bez aplikace na soubory v nich obsažené
    • nastavit příznak RO pro systémové soubory v kořenovém adresáři disku C (tj. soubory C:\Config.sod, C:\Io.sys, C:\Msdos.sys a podobně)
    • nastavit příznak RO na složku s instalací programu OptimAccess a to včetně souborů v ní obsažených (základní složka pro instalaci je C:\Program files\OA9)
  9. Exportovat vlastní nastavení systému OptimAccess® do datového souboru.

Jak konfigurovat síťové instalace?

Při konfiguraci síťové instalace lze samozřejmě postupovat mnoha způsoby. Jednoznačně nelze některý z možných postupů označit jako nevhodný. Jsou pouze více a méně pracné postupy. Jako obecně nejrychlejší a nejméně pracný lze považovat následující způsob:

  1. Instalovat kompletní systém OptimAccess® na jednom počítači. Následující kroky lze provádět buďto přímo na konkrétním počítači nebo vzdáleně prostřednictvím nadstavbového modulu Remote Control.
  2. Aktivovat ovladače systému OptimAccess®.
  3. Uložit základní konfiguraci systému OptimAccess® do souboru.
  4. Nastavit vlastní konfiguraci systému OptimAccess® v závislosti na konkrétních podmínkách a požadavcích. Mimo specifických požadavků souvisejících s konkrétní instalací je vhodné použít výše popsaný doporučený způsob konfigurace.
  5. Uložit vlastní konfiguraci systému OptimAccess® do souboru.
  6. Na ostatních počítačích instalovat systém OptimAccess® a importovat jeho nastavení ze souboru vytvořeného dle bodu č. 5.


Jak postupovat v případě změny konfigurace OS?

Plánujete-li na chráněnou stanici rozsáhlejší instalaci nového programového vybavení, rozsáhlejší aktualizaci stávajících aplikací nebo aktualizaci části operačního systému proveďte zamýšlené úpravy následujícím způsobem (odkazy na hesla uváděná v postupu přísluší k ovládací aplikaci pro Windows 9x, ekvivalentní hesla pro Windows NT a 2000 naleznete v Ovládání aplikace ve Windows NT/2000):

  1. Prostřednictvím příkazu Export nastavení do souboru zálohujte stávající nastavení systému. Postup pro export nastavení do datového souboru naleznete pod heslem Export nastavení do souboru.
  2. Obnovte základní nastavení systému OptimAccess®, které jste zálohovali ihned po instalaci systému OptimAccess® prostřednictvím příkazu Import nastavení ze souboru. Postup pro import nastavení z datového souboru naleznete pod heslem Import nastavení ze souboru.
  3. Prostřednictvím příkazu Deaktivace systému deaktivujte systém OptimAccess®. Postup pro deaktivaci systému OptimAccess® naleznete pod heslem Aktivace a deaktivace systému OptimAccess®.
  4. Restartuje počítač a proveďte plánované úpravy programového vybavení počítače.
  5. Aktivujte systém OptimAccess® a restartujte počítač. Postup pro aktivaci systému OptimAccess® naleznete pod heslem Aktivace a deaktivace systému OptimAccess®.
  6. Obnovte vaše nastavení systému OptimAccess®, které jste zálohovali před úpravami programového vybavení počítače (dle kroku č. 1 tohoto postupu) prostřednictvím příkazu Import nastavení ze souboru. Postup pro import nastavení z datového souboru naleznete pod heslem Import nastavení ze souboru. Případně proveďte další požadované úpravy v nastavení funkcí systému OptimAccess®.


Odstraňování problémů

V následující sekci jsou popsána řešení pro všeobecně známé situace, které mohou při práci se systémem OptimAccess nastat.

  • Tvorba záchranné diskety
  • Nouzová deinstalace systému
  • Nelze zavést operační systém
  • Nelze provést aktivaci systému OptimAccess®
  • Zavedení systému se ukončí chybou zápisu na disk
  • Při zavedení systému hlásí výjimku Plánovač úloh
  • Zavedení systému se ukončí chybou porušení ochrany Registrační databáze
  • Operační systém hlásí nedostatek paměti
  • Systém není aktivní a nelze používat disketovou případně CD-ROM mechaniku
  • Problémy s tiskem
  • Operační systém se samovolně restartuje
  • Zastavování aplikací pro MS-DOS
  • Zapomenuté heslo pro ovládací aplikaci
  • V ovládací aplikaci nejsou vidět klienti
  • V ovládací aplikaci nelze nalézt funkčního klienta
  • Chyba porušení konfiguračního souboru
  • Nelze autorizovat disketa
  • Podezření na virovou nákazu
  • Uživatel se není schopen přihlásit v nouzovém režimu

V případě jakýchkoliv jiných problémů kontaktujte výrobce dle pokynů uvedených pod heslem Odborná pomoc.


Tvorba záchranné diskety

Vlastní systémovou disketu můžete ve Windows 9x či ME na příkazovém řádku vytvořit prostřednictvím příkazu format <jednotka>: /s. V grafickém rozhraní Windows použijte následující postup:

  1. V okně Tento počítač nebo v pravém podokně programu Průzkumník klepněte na ikonu diskety, kterou chcete formátovat.
  2. V nabídce Soubor klepněte na příkaz Naformátovat.
  3. V dialogu Formátovat nastavte odpovídající kapacitu diskety, nastavte Typ formátování na Úplné, označte volbu Zkopírovat systémové soubory a stiskněte na tlačítko spustit.

Vytvořenou systémovou disketu dále upravte následujícím způsobem:

  1. Z distribučního CD-ROM spusťte soubor Initdisk.exe.
  2. Z distribučního CD-ROM nakopírujte na disketu soubory Repair.exe a Backup.exe.
  3. Zkopírujte na ni soubory Fdisk.exe, Format.com a Sys.com z adresáře Windows\Command.


Nouzová deinstalace systému

Pokud se po instalaci a následném restartu proces zavádění systému zastaví nebo vůbec není zahájen, došlo ke konfliktu, který může být způsoben:
  • aktivní rezidentní částí antivirového programu,
  • přítomností viru,
  • poškozeným operačním systémem,
  • vadným pevným diskem
  • nebo přítomností neznámého nestandardního kódu.

V závislosti na provozovaném operačním systému pokračujte dle postupu:

  • Nouzová deinstalace systému OptimAccess® na platformě Windows 9x/ME,
  • Nouzová deinstalace systému OptimAccess® na platformě Windows NT/2000/XP.


Nouzová deinstalace systému OptimAccess® na platformě Windows 9x/ME

Pro úspěšnou deinstalaci je nutné vědět zda jste instalovali systém OptimAccess® do zavaděče pevného disku či nikoliv. Nejste-li si jisti vyzkoušejte zavést operační systém ze standardní záchranné diskety Windows (neupravené dle postupu Tvorba záchranné diskety). Zdaří-li se vám systém zavést z této diskety, můžete přeskočit následující odstavce Nouzová deinstalace ze zaváděcí oblasti disku.

Nouzová deinstalace ze zaváděcí oblasti disku

  1. Pokuste se zavést operační systém s pomocí Záchranné diskety, kterou jste vytvořili v průběhu instalace nebo dle postupu pod heslem Tvorba záchranné diskety.
  2. Ze Startovací nabídky systému Windows zvolte položku Jen systém MS-DOS a stiskněte klávesu ENTER.
  3. Spusťte z diskety nouzovou opravnou utilitu repair.exe. Můžete tak nouzově odinstalovat první část systému OptimAccess ze zavaděčů a to klasicky, nebo s využitím záložního souboru, který se generuje při prvotní instalaci.
  4. Spusťte z diskety příkaz fdisk /mbr.
  5. Pokuste se restartovat počítač, zavést operační systém z pevného disku a opět aktivovat systém OptimAccess®.

Disk s nimž manipulujete musí být zapojen jako PRIMARY MASTER. V případě, kdy nedojde k odstranění problému je příčinou nekompatibilní BIOS vašeho počítače. Kontaktujte oddělení technické podpory výrobce dle pokynů uvedených pod heslem Odborná pomoc.

Nouzová deinstalace v prostředí Windows

Restartujte počítač a zaveďte pouze systém MS-DOS. V průběhu zavádění operačního systému stiskněte klávesu F8. Ze Startovací nabídky systému Windows zvolte položku Jen systém MS-DOS a stiskněte klávesu ENTER. V případě, kdy jsou některé zmiňované soubory určeny pouze pro čtení, změňte nastavení jejich příznaků pomocí příkazu attrib.

Následně je třeba ručně odstavit všechny části systému OptimAccess, například souborovým manažerem:

  • přejmenovat soubor Config.sod na Config.sys (není-li záložní soubor Config.sod přítomen, odstraňte ze stávajícího souboru Config.sys řádek device=C:\Oa9\Oa16.sys);
  • v souboru Autoexec.bat smazat řádek, ve kterém se zavádí program Recovreg.exe (pokud se zavádí Komplexní ochrana registrační databáze);
  • přejmenovat v adresáři Windows soubor System.sod na System.ini (není-li záložní soubor System.sod přítomen, ze stávajícího souboru System.ini v sekci [386ENH] odstraňte řádky device=C:\Oa9\Oafile.vxd a pro případ nadstavbových modulů rovněž device=C:\Oa9\Oareg.vxd);
  • v adresáři Windows\System\Iosubsys smazat soubor Sios.vxd.
Po odstranění výše uvedených součástí restartujte počítač a operační systém by se měl zavést bez problémů klasickým způsobem. Zkontrolujte nastavení operačního systému a proveďte úkony, které jsou popsány v nápovědě pod heslem Instalace.


Nouzová deinstalace systému OptimAccess® na platformě Windows NT/2000/XP

Používáte-li jako souborový systém FAT či FAT32, můžete následující úpravy provést z prostředí interpretru příkazové řádky systému MS-DOS. Máte-li operační systém instalován na souborovém systému NTFS, je k provedení následujících úprav třeba systém schopný manipulovat s použitým souborovým systémem. Můžete využít například záchrannou disketu NT Admin Boot Disk, manipulovat si diskem vzdáleně po síti (pokud to stav počítače dovoluje) či disk vyjmout a připojit jej do jiného počítače, který je schopen se souborovým systémem NTFS operovat (například s instalací Windows NT, 2000 či XP).

V rámci adresářové struktury Windows je potřeba odstranit (popř. přejmenovat) tyto soubory:

<WINDOWS>\system32\drivers\oafile.sys
<WINDOWS>\system32\drivers\oaregmgr.sys
<WINDOWS>\system32\oakelNT.dll

Následně restartujte počítač, odinstalujte systém OptimAccess® a zkuste jej nainstalovat znovu.


Nelze zavést operační systém

Problém: Proces zavádění operačního se zastaví za výpisem informace o instalaci ochranného systému.

Řešení:

V závislosti na provozovaném operačním systému odstraňte systém OptimAccess® dle postupu:

  • Nouzová deinstalace systému OptimAccess® na platformě Windows 9x/ME,
  • Nouzová deinstalace systému OptimAccess® na platformě Windows NT/2000/XP.


Nelze provést aktivaci systému OptimAccess®

Problém: Proces aktivace systému OptimAccess® neproběhne korektně či vůbec a ukončí se chybovým hlášením. Případně systém OptimAccess® není možné instalovat.

Řešení:

Jednou z příčin tohoto problému může být předchozí instalace starší verze systému OptimAccess®. Deaktivujte a odinstalujte předchozí verze.

Není-li problém odstraněn, zkontrolujte zda nemáte v kořenovém adresáři disku soubor oasys.set. Je-li přítomen, tak jej smažte. Rovněž smažte z registrační databáze klíč HKEY_LOCAL_MACHINE\SOFTWARE\SODAT software.

Dále mohou být na vině 16bitové ovladače jednotlivých hardwarových komponent. Kontrolu jejich stavu a funkce provedete prostřednictvím Ovládacího panelu Systém.


Zavedení systému se ukončí chybou zápisu na disk

Problém: Proces zavádění operačního systému Windows se ukončí chybou zápisu na disk a operační systém se ukončí.

Řešení:

Příčinou je nezavedení ovladače Oa16.sys prostřednictvím konfiguračních souborů. V paměti je aktivní pouze ovladač ze zaváděcího sektoru a celý disk je možné pouze číst.

  1. Pokuste se zavést operační systém s pomocí Záchranné diskety, kterou jste vytvořili v průběhu instalace nebo dle postupu pod heslem Tvorba záchranné diskety.
  2. Nouzově odstavte systém OptimAccess® dle postupu pod heslem Nouzová deinstalace systému.
  3. Pokuste se restartovat počítač, zavést operační systém z pevného disku, a opět aktivovat ochranný systém.


Při zavedení systému hlásí výjimku Plánovač úloh

Problém: Proces zavádění operačního systému Windows je přerušen výjimkou programu Plánovač úloh.

Řešení:

Příčinou je chybné nastavení příznaků pro soubor protokolu programu Plánovač úloh. V adresáři Windows nastavte pro soubor Shedlog.txt příznak WR namísto stávajícího RO.


Zavedení systému se ukončí chybou porušení ochrany Registrační databáze

Problém: Proces zavádění operačního systému Windows se ukončí chybou porušení ochrany Registrační databáze a systém je možné pouze restartovat.

Řešení:

Příčinou je chybné nastavení příznaků pro adresář Windows\Sysbckup nebo některý z *.cab souborů se zálohou Registrační databáze. Tyto záložní soubory musejí být přístupné pro zápis. Podrobnosti naleznete pod heslem Doporučený postup konfigurace.


Operační systém hlásí nedostatek paměti

Problém: Proces zavádění operačního systému Windows je přerušován chybovým hlášením Nedostatek paměti.

Řešení:

Příčinou je chybné nastavení příznaků pro soubor virtuální paměti Win36.swp v adresáři Windows. Tento soubor musí být přístupný pro zápis. Podrobnosti naleznete pod heslem Doporučený postup konfigurace.


Systém není aktivní a nelze používat disketovou případně CD-ROM mechaniku

Problém: Nelze pracovat s disketovou případně CD-ROM mechanikou ačkoliv není systém OptimAccess® aktivní.

Řešení:

Příčinou je neúplná deaktivace systému OptimAccess®. Tento problém odstraníte smazání souboru Sios.vxd z adresáře Windows\System\Iosubsys.


Problémy s tiskem

Problém: Do operačního systému nelze přidat novou tiskárnu, případně přidaná tiskárna netiskne. Odstraňování tiskárny se ukončí chybou.

Řešení:

Příčinou je chybné nastavení příznaků pro adresář s tiskovou frontou a konfigurační soubory operačního systému. Při manipulaci s tiskárnou je třeba dodržet následující pravidla:

  • při přidávání a odstraňování tiskárny je třeba mít pro zápis přístupný soubor Win.ini z adresáře Windows;
  • při tisku musí mít uživatel pro zápis přístupný adresář Spool, tvořící pro příslušnou tiskárnu její tiskovou frontu.


Operační systém se samovolně restartuje

Problém: V průběhu práce operační systém samovolně provede restart, aniž by se opakovala stejná situace či operace.

Řešení:

Příčinu je třeba hledat v ovladačích hardwarových komponent, které jsou spolu v konfliktu. Hardwarové problémy můžete řešit za pomocí hesla Poradce při potížích v případě konfliktu hardwaru systému Windows ze standardní nápovědy operačního systému, případně konfliktní hardwarové prvky a ovladače z počítače odstranit.

Restartuje-li se samovolně systém Windows 2000 či XP, lze tomuto procesu zabránit prostřednictvím volby Automaticky restartovat. V ovládacím panelu Systém zvolte záložku Upřesnit, stiskněte tlačítko Nastavit v oblasti Spouštění a zotavení systému a zrušte označení volby Automaticky restartovat v oblasti Selhání systému. Operační systém namísto pokračování zobrazí obrazovku s výraznou zprávou, informující o chybě způsobující zastavení. S výpisem této chyby můžete následně kontaktovat technickou podporu.


Zastavování aplikací pro MS-DOS

Problém: Při práci s aplikací v režimu MS-DOS přestane počítač odpovídat.

Řešení:

Příčinu je třeba hledat v automatickém přidělování paměti pro aplikace. Přidělování paměti pro jednotlivé aplikace je třeba nastavit ručně. Ve vlastnostech konkrétní aplikace se přepněte na kartu Paměť a nastavené hodnoty automaticky změňte dle systémových požadavků konkrétní aplikace.


Zapomenuté heslo pro ovládací aplikaci

Problém: Ovládací aplikaci systému OptimAccess® nelze spustit, protože jste zapomněli nastavené vstupní heslo.

Řešení:

Systém OptimAccess® je bohužel třeba přeinstalovat. Nouzově jej deaktivujte dle postupu uvedeného pod heslem Nouzová deinstalace systému a instalujte jej znovu.


V ovládací aplikaci nejsou vidět klienti

Problém: V ovládací aplikaci systému OptimAccess® nelze vylistovat či najít konkrétní počítač.

Řešení:

Na spravovaných počítačích musí být pro korektní chování systému vzdálené správy aktivní klient (program Rcclient). Zkontrolujte jeho přítomnost v paměti prostřednictvím programu Správce úloh. Není-li v paměti aktivní, lze jej spustit prostřednictvím souborů Rcclient.exe. V případě potíží se spouštěním klienta reinstalujte systém OptimAccess®.

Je-li klient v paměti spravované stanice aktivní a daný počítač stále nelze v ovládací aplikaci systému OptimAccess® nalistovat či najít, je třeba zkontrolovat nastavení použitého komunikačního protokolu. Dále je pro korektní chování mít třeba instalovány síťové služky Klient sítě Microsoft a Sdílení souborů a tiskáren v sítích Microsoft.


V ovládací aplikaci nelze nalézt funkčního klienta

Problém: V ovládací aplikaci systému OptimAccess® nelze vylistovat či najít konkrétní počítač, kde je v paměti aktivní klient pro vzdálenou správu.

Řešení:

Problém může být na straně síťové kabeláže či připojení počítače k síti. Zkontrolujte kabeláž a vyzkoušejte zdali je možno na počítači pracovat se sdílenými síťovými prostředky. V případě problémů na straně systému OptimAccess® kontaktujte výrobce dle pokynů pod heslem Odborná pomoc.


Chyba porušení konfiguračního souboru

Problém: Po instalaci a aktivaci hlásí systém OptimAccess® chybu, kdy došlo k porušení konfiguračního souboru.

Řešení:

Smažte porušený konfigurační soubor Oasys.set v kořenovém adresáři disku C.


Nelze autorizovat disketa

Problém: Proces autorizace diskety při použití ochrany disketové mechaniky neproběhne korektně a disketa není autorizována.

Řešení:

V případě některých značkových počítačů je znemožněno provádění nestandardních operací s hardwarovými komponentami na úrovni mikrokódu. Disketu je třeba autorizovat v disketové mechanice jiného počítače.


Podezření na virovou nákazu

Problém: Antivirový program hlásí při kontrole pevného disku případně autorizovaných disket podezření na virovou nákazu.

Řešení:

Upravené zaváděcí sektory se při běžné kontrole antivirovým programem mohou zdát jako napadené virem. Jistotu, že se jedná o planý poplach můžete získat jestliže:

  1. bezprostředně před instalací systému OptimAccess® provedete antivirovou kontrolu zaváděcího sektoru pevného disku;
  2. instalujete systém OptimAccess® a ihned poté si v antivirovém programu vytvoříte záložní kopii zaváděcího sektoru pevného disku.

Srovnáním podoby záložní kopie a s aktuálním stavem zaváděcího sektoru tak kdykoliv v budoucnu snadno odhalíte virovou nákazu.


Uživatel se není schopen přihlásit v nouzovém režimu

Přihlašování v nouzovém režimu

Problém: Uživatel se není schopen přihlásit v nouzovém režimu.

Řešení:

Pokud je aktivován systém OptimAccess® v operačních systémech platformy NT je implicitně zakázáno přihlašování uživatelů v nouzovém režimu. Toto omezení se netýká systémového účtu Administrator. Pokud je z nějakého důvodu nutné, aby měli uživatelé přístup i do nouzového režimu je možné nastavit systém OptimAccess® podle následujícího postupu :

  1. Vložte do CD mechaniky instalační CD systému OptimAccess®.
  2. Pomocí průzkumníka nalistujte na tomto CD adresář util\.
  3. Naimportujte obsah souboru oaServerNt_SafeMode.reg provedeným dvojklikem nad tímto souborem. Na otázku odpovězte ANO.

Po provedení tohoto výše uvedeného postupu, jsou uživatelé schopni přihlašovat se a pracovat s operačním systémem i v nouzovém režimu.


Slovníček

V rámci sekce slovníček naleznete vysvětlení těchto pojmů:

  • Aktivace
  • Alokační tabulka souborů
  • BIOS
  • Instalace
  • Registrační databáze
  • Softwarový balík
  • Zaváděcí sektor
  • Zavaděč


Aktivace

Pojmem aktivace se v případě systému OptimAccess® rozumí zavedení ovladačů potřebných pro korektní funkci systému. Při aktivaci ovladačů se modifikuje rovněž zaváděcí oblast pevného disku. Pro korektní aktivaci ochranného systému je tudíž nutný restart počítače.

Klient pro vzdálenou správu je spuštěn v závěrečné fázi instalace a je v paměti počítače aktivní bez ohledu na to, zdali je současně aktivní také systém OptimAccess®. Aktivaci systému lze tedy provést kdykoliv po instalaci systému a to i prostřednictvím ovládací aplikace.


Alokační tabulka souborů

Pojmem alokační tabulka souborů (angl. file allocation table, zkráceně též FAT) se označuje speciální oblast zformátovaného datového média, kde jsou uloženy informace o adresářové struktuře a v ní obsažených souborech. Alokační tabulka souborů je vytvořena operačním systémem při formátování média. Data v ní obsažená nejsou pro uživatele přímo dostupná. Manipuluje s ní operační systém a provádí v ní změny na základě uživatelských operací nad adresáři a soubory.


BIOS

Pojmem BIOS (angl. basic input/output system, zkráceně též BIOS) se rozumí základní programové vybavení počítače uložené v čipu na základní desce. Obsahuje instrukce pro zavedení operačního systému z vnější paměti (rozuměj pevného disku) do vnitřní paměti (rozuměj fyzickou RAM) počítače. Jeho prostřednictvím lze rovněž nakonfigurovat základní parametry systému (typ procesoru, velikost paměti, informace o pevných discích a podobně).


Instalace

Pojmem instalace (angl. install) se rozumí proces přípravy programu k běhu, který se sestává z fyzického překopírování potřebných souborů na pevný disk počítače, jejich rozmístění na odpovídající pozice adresářové struktury, propojení s ostatním programovým vybavením a s tím nutně související úprava nastavení jednotlivých programových částí.


Registrační databáze

Pojmem registrační databáze (angl. registry) se rozumí centrální databáze informací operačního systému Windows. Slouží k ukládání informací o hardwarovém a programovém vybavení počítače, informací o uživatelských konfiguracích a podobně. Eliminuje se tak potřeba dodatečných informačních souborů pro jednotlivé aplikace a periférie počítače. Pro manipulaci s touto centrální databází obsahuje operační systém Windows program Editor registru.


Softwarový balík

Pojmem softwarový balík se v případě ochranného systému OptimAccess rozumí označení skupiny souborů příslušejících konkrétnímu programu či skupině programů – například aplikaci Microsoft Word.

Prostřednictvím softwarových balíků nadefinovaných dle zakoupených licencí programů lze hlídat a sledovat příslušné počty instalovaných licencí konkrétních produktů.


Zaváděcí sektor

Pojmem zaváděcí sektor (angl. boot sector) se označuje speciální oblast zformátovaného datového média, kde je umístěn zavaděč operačního systému. Zavaděč umístěný v zaváděcím sektoru lze spustit pouze tím způsobem, kdy datové médium umístíte do počítače a určíte jej jako „bootovací“.


Zavaděč

Pojmem zavaděč (angl. loader) se rozumí krátký jednoúčelový program určený pro zavedení operačního systému z vnější paměti (rozuměj pevného disku) do vnitřní paměti (rozuměj fyzickou RAM) počítače. Je umístěn na disku ve speciální části označované jako zaváděcí sektor. Zavaděč zkopíruje jádro operačního systému z vnější do vnitřní paměti počítače a předá mu řízení.


Softwarové balíky

Prostřednictvím funkce Softwarové balíky si lze jednotlivé balíky obsahující informace o programech instalovaných na počítači vytvářet ručně či si je nechat systémem OptimAccess automaticky vygenerovat. Detailní vysvětlení pojmu naleznete pod heslem Softwarový balík.
  • Ruční vytváření – při ručním vytváření balíků lze začít buďto s prázdným balíkem anebo jako základ použít jiný dříve vytvořený balík. V rámci takto zvoleného základu je možno přidávat a odebírat jednotlivé spustitelné aplikace nebo dávkově přidat všechny spustitelné soubory ze zadané složky. Vytvořený balík lze uložit případně smazat.
  • Generování balíků – na základě provedeného skenování instalovaného programového vybavení na stanicích lze programové balíky generovat dle identifikace obsažené v jednotlivých spustitelných souborech. Ve výpisu provedeného skenování jsou jednotlivé spustitelné soubory seskupeny podle obsažené identifikace. Na základě označení je lze ukládat jako samostatné programové balíky či jako jeden balík pod společným názvem. Jeden programový balík může obsahovat i více různých aplikací.
  • Správce softwarových balíků - umožňuje přehledně a pohodlně zobrazovat a evidovat informace o pořízeném softwaru. Eviduje informace jako dodavatel softwaru, typ licenčního ujednání, počet zakoupených licencí, čísla faktur, licenční čísla, kam je software nainstalován a kým, … .Veškeré operace s touto databází jsou zaznamenávána do historie akcí.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Softwarové balíky vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Prohlížení

S použitím funkce Prohlížení máte možnost vizualizovat výsledky skenování programového vybavení počítaču a pracovních stanic pomocí srovnávání scanů a tiskových sestav.
  • Porovnávání scanů – nabízí možnost vizualizace rozdílů při srovnání původního referenčního a provedeného kontrolního skenování programového vybavení. Při srovnávání lze využívat informace z předem připravených softwarových balíků. V případě rozdílných souborů je zobrazováno jméno souboru, absolutní cesta od kořenového adresáře a čas modifikace. Zjištěné rozdíly je možné uložit jako softwarový balík a vytvářet tak hierarchii - například pro aktualizované verze programů.
  • Porovnání HW scanů - umožňuje vizuálně zobrazit rozdíly mezi referenčním a kontrolním auditem hardwarového vybavení. Zobrazená data lze exportovat pro prohlížení v externím prohlížeči.
  • Prohlížení HW scanů - poskytuje zobrazovat nasbírané informace o hardwarovém vybavení stanice v přehledné grafické podobě.
  • Tiskové sestavy – nabídka obsahuje generování tiskových sestav:
    • Vybavení stanice - na základě vytvořených výsledků skenování programového a hardwarového vybavení lze generovat přehlednou tiskovou sestavu softwarového a hardwarového vybavení. V softwarovém vybavení lze navíc kontrolovat počet licencí s aktuálním stavem, nebo osoby jenž provedly konkrétní instalace. Rovněž lze kontrolovat datum posledního provedení skenování.
    • Porovnávání SW výsledků - lze srovnávat provedené skenování programového vybavení počítačů s referenčním scanem. Při hledání rozdílů je možné vyloučit informace na základě sestavených softwarových balíků. V případě že se jedná o kompletní otisky, je možné srovnávat i nespustitelné soubory. Rovněž lze kontrolovat datum posledního provedení skenování programového vybavení počítačů.
    • Porovnání HW výsledků - generuje sestavu jako výsledek porovnání provedených skenování hardwarového vybavení stanic. Lze kontrolovat datum posledního provedeného skenování na stanicích a tím zajistit aktuálnost generovaných dat.
    • Předávací protokoly - z informací o softwarovém a hardwarovém vybavení lze vytvářet předávací protokoly softwarového nebo hardwarového vybavení jednotlivých stanic uživatelům, kteří zodpovídají za jejich stav.
    • Detailní dotazy - touto sestavou se získá přehled o rozmístění jednotlivých softwarových balíků na stanicích s informací zda je na stanici nainstalován legálně či nikoliv.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Prohlížení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Chcete-li pracovat s jednotlivými tiskovými sestavami, musíte je nejprve vylistovat stiskem myši na ikoně Tiskové sestavy v levém okně ovládací aplikace. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Plánování

Informace o stanici

Volba tohoto nastavení představuje informace jenž budou uloženy při pořízení auditů na stanicích. Tím je možné v historii pořízených auditů dohledat kdo za stanici v dané době zodpovídal a jaký byl její identifikátor.

Implicitně jsou používány hodnoty jméno stanice a jméno aktuálního přihlášeného uživatele v době provádění auditu. Pro konfiguraci je možné využít informace ze systémových proměnných ( např.%USERNAME% a %COMPUTERNAME% reprezentuje jméno aktuálního uživatele a jméno stanice ).

Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Informace o stanici.


Prohlížení

Rozšířené nastavení

Prostřednictvím volby Rozšířené nastavení máte možnost zjemnit sledování jednotlivých monitorovacích akcí a vytvořit alertový systém, který bude reagovat na definované akce.

Nastavení alertů

Zde se definuje akce, která se provede vyskytne-li se některý z definovaných alertů. Každý definovaný alert(kromě speciálních alertů) používá toto nastavení. Není-li tedy správně nastaveno je celý systém upozornění nefunkční.

  • Zaslat email - Je-li zvolena možnost zasílat upozornění pomocí emailu je nutné vyplnit nastavení pro zasílání emailů. Emaily se jsou standartně zasílány pomocí smtp. Je tedy nutné specifikovat smtp server přes který se budou posílat a mail adresu odesílatele, pod kterým budou zprávy odesílány. Po vyplnění způsobu odesílání stačí definovat seznam mail adres kam se budou upozornění zasílat.
  • Spustit proces - při vyvolání alertu se systém pokusí spustit proces s daným parametrem. Přikladem může být v operačních systémech NT4/2000/XP zadání: c:\windows\system32\net.exe admin %1. Tím se uporoznění pošle na počítač se jménem admin a %1 značí obsah zprávy.

Standartní alerty

Standartní alerty se vztahují přímo k nastaveným monitorovaným akcím. Na každou sledovanou akcí se dá nastavit neomezené množství alertů. Alert představuje množinu vlastností, které jsou při monitorování ukládány do logového souboru. Na tyto vlastnosti se při definování alertu váže podmínka. Vlastnosti mohou být trojího typu.

  • Čas - tuto položku má každá monitorovaná akce, představuje čas kdy doslo k dané akci. Ja možno definovat kompletní datum nebo jen hodinu kdy se má akce vyskytnout.
  • Text - zastupuje textový řetězec. Při zadávání je podporována hvězdičková notace. Operace větší ">" a menší "<" lze využít pro vymezení intervalu. Například je-li alert nastaven na přihlašování uživatele, a vlastnost uživatel nastavena na operaci větší=a a menší=Z bude hlásit alert pokud jméno přihlašovaného uživatele začíná písmenem a-Z.
  • Číslo - vyjadřuje číselnou hodnotu, jednotky jsou vždy uvedeny u jména vlastnosti (BYTE, počet stránek, ...).
Každý standartní alert může nabýt vlastnosti inverzní. Upozornění je pak vyvoláno v případě, že monitorovaná data vyhovují alespoň jednomu pozitivnímu alertu a nevyhovují ani jednomu alertu inverznímu.

Speciální alerty

Tato záložka nabízí definovat alerty, které nesouvisí přímo s monitorovanými akcemi. Je možno definovat upozornění související s mimořádnou aktivitou na síti nebo mimořádnou aktivitou na stanici.

  • Mimořádný zápis záznamů do souboru - určuje kolik záznamů do lokálního logového souboru může být zapsáno v určitém časovém okamžiku bez vyvolání upozornění.
  • Mimořádný přenos dat přes síť - specifikuje zda se jedná o příchozí, odchozí nebo celkový objem dat přenesených přes síť a časový interval působící jako mezní pro kontrolu údajů.

Při definici speciálních alertu není nutné používat implicitní nastavení ze záložky Nastavení alertů, ale může použít při výskytu akce vlastní nastavení.

Filtrace

Veškeré monitorované akce je možné zjemnit definicí filtrů. Každý definovaný filtr představuje skupinu položek jež jsou zapisovány do logového souboru s možností nastavit vzor těchto položek jak mají vypadat a pokud vyhovují této definici jsou monitorovány. Definované filtry mohou být určeny jako inverzní. Monitorované hodnoty jsou pak zapsány do logového soubory v případě, že vyhovují alespoň jednomu pozitivnímu filtru a nevyhovují ani jednomu inverznímu filtru. V případě neexistence filtru k danému typu monitorované akce, je automaticky případná akce zapsána do logového souboru.

Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Rozšířené nastavení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Záloha uživatelského nastavení Databáze

Problém: Jak zachovat nastavení uživatelsky definované Databáze ovládací aplikace systému OptimAccess® při případné reinstalaci systému.

Řešení:

Uživatelské nastavení databáze se ukládá do souboru Database.dat v základním adresáři s instalovaným systémem OptimAccess® (základní nastavení je C:\Program Files\OAx, kde x představuje číslo verze systému OptimAccess®). Před případnou reinstalací si zálohujte tento soubor a po reinstalaci přepište nový soubor původní zálohou.