はじめに

AddTabEx AddTabEx for SDI

■　はじめに

  AddTabExは、おもにSDI形式のソフトをタブ等で一元表示管理するものです。 簡易MDI表示や、タブ化したソフトの一括終了、および、起動中のソフトを タブ化して取り込むなど、ディスクトップの整理にお役立てください。

  以前公開した「AddTab」から、キーボードによる操作を全て削除し、 ほとんどマウスのみで操作できるよう改良、また、本体デザインを一新し、 よりコンパクトにしました。設定など操作性、使用感も向上しています。

  なお、ご使用前に、「■　タブ化について」、 「■　その他」【 注意事項 】をご一読下さい。


■　インストール等

【 ファイル構成 】

  ・AddTabEx.exe　：　ソフト本体
  ・AddTabEx.chm　：　ヘルプ
  ・readme.txt　　：　説明書

【 インストール 】

AddTabEx xxx .lzhを解凍後、同じディレクトリに、上記ファイルを入れてください （xxxはバージョン）。

なお、AddTabExを初期起動すると、設定ファイル（AddTabEx.ini）が インストールしたディレクトリに自動生成されます。

【 バージョンアップ 】

AddTabEx xxx .lzhを解凍後、全て上書きしてください。

【 アンインストール 】

レジストリは使用していないので、ディレクトリごと削除するだけです。


■　開発内容

【 開発環境 】

  ・Borland C++ Compiler 5.5.1 （Ｃ言語コンパイラ）
  ・BCC Developer （ソフト作成）
  ・ヘルプましん （ヘルプ作成）
  ・dotwork （アイコン作成）

【 動作環境 】

WindowsMe、Internet Explorer 6 上で開発、動作確認を行っています。

【 著作権等 】

本ソフトの著作権は作者である「サクラ」にあります。
本ソフトはフリーソフトです。転載は自由に行ってください。
本ソフトの使用によって発生した問題について作者は一切の責任を負いません。
作者はバージョンアップ、バグ修正を行う義務を持ちませんが、 バグについては、出来る限り対応したいと思います。

【 謝辞 】

このソフトは、三浦淳氏公開のBorland C++ Compiler 5.5専用簡易開発環境 「BCC Developer」、うな氏公開のヘルプ作成ソフト「ヘルプましん」、 及び、suuta氏公開のアイコン作成ソフト「dotwork」等で作成されています。 この様な素晴らしいソフトをフリーで公開されている方々に深く感謝いたします。

【 連絡先 】

ご質問等は下記アドレス「サクラ」まで、よろしくお願いいたします。
ご感想、バグ報告いただければ幸いです。

mail : sakura_bbi2@yahoo.co.jp


■　更新履歴

【 Ver.1.04 】

  ・入力データに、"<"">"",（カンマ）" が使用できないことを明示。
  （タブ項目設定データの場合入力エラーとした）
  ・最小化ウィンドウのタブ化精度の向上。
  （”サブ・ウィンドウ”で動作するソフトに対応）
  ・その他

【 Ver.1.03 】

  ・メイン表示がオーナー・ウィンドウでないソフトに対応
  ・その他

【 Ver.1.02 】

  ・設定画面のデザイン変更
  ・その他

【 Ver.1.01 】

  ・ソフトのウィンドウサイズ制御を各ソフト毎に行うように変更
  ・タブ化実行時、最小化ウィンドウも表示されるように変更
  ・タブ非表示モード追加
  ・終了確認モード追加
  ・システムメニュー項目名変更
  ・その他

【 Ver.1.00 】

  ・新規公開


■　動作概要

  AddTabExでソフトをタブにまとめる（タブ化する）場合、当該ソフトのタブ化登録が 必要です。「■　タブ化について」 「■　動作設定」を参考にして、タブ化したいソフト を登録してください。起動中のソフトも登録可能です。

  実際にタブ化を実行するタイミングは、本体の起動、”更新”操作の実行、および、 本体によるランチャ登録ソフトの実行です。 （Windows標準の）メモ帳がインストールされている環境の方は、メモ帳を起動して AddTabExを実行してください。あるいは、付属のreadme.txtを本体へドロップしてください （起動前のアイコンでも、起動後の本体でも結構です）。 初期設定では、メモ帳がタブ化する設定になっているので、タブ化動作が確認できると思います。 タブ化されたソフト（ウィンドウ）は、それぞれ単体で移動すればAddTabEx本体と切り離す ことが可能で、ウィンドウサイズ変更等も自由に行えます。また、”更新”操作やAddTabEx本体を移動すること により、再び全体をタブ化してひとつにまとめることが可能です（下図参照）。 また、”CTRL＋左クリック”でタブ（または、移動ボタン）を選択すれば、当該ウィンドウを終了することが可能です。 タブにより制御できるウィンドウは最大２０までです。

  本体はディスクトップアイコンと同サイズで非常にコンパクトなため、 起動中も邪魔にならず、さらに、タブそのものを非表示にすることも可能ですので、 ディスクトップ上、AddTabExの存在をあまり意識せずに利用できます。
また、ほとんど、CTRLキーとマウスのみで操作可能ですので 操作も簡単です。システムメニューは本体”右クリック”で表示します。

  本体へは２０個のソフトを登録可能（ランチャ機能）で、単体起動も、ファイルを転送して 起動（本体へドロップ）も可能です。このとき、タブ化登録済みソフトであれば、直ちにタブ化を 実行します。ランチャメニューは、本体を”CTRL＋右クリック”で表示します。

  その他、本体ウィンドウ色、選択タブの文字色や、タブ化するウィンドウのサイズ制御 などが設定可能です。

※詳細は、 「■　メニュー」 「■　動作設定」 「■　マウスによる操作」を参照。
動作画面

メモ帳でテキストを２つ開きタブ化した様子

メモ帳の左上部にあるアイコンがAddTabEx本体で、
この図では本体ウィンドウ（アイコンの透過部分）
がディスクトップ色に設定してあります。
この状態でAddTabEx本体を移動するか、”更新”
操作を行えば、メモ帳は重ねて表示されます。


■　タブ化について

  AddTabExは、「キャプションを持つウィンドウ・ソフト」のうち、 タブ化登録したものを全てタブ化実行します。 また、起動中のソフトをタブ化登録できるようにするため、 設定画面内の[起動中ソフト]一覧に、前記述に該当する起動中のソフトを表示していますが、 これらの全てが正常に機能するとは限りませんのでご了承ください。

  ウィンドウサイズが固定のソフトについては、”サイズ統一”しない設定でご利用ください。 ただし、このソフトについては、簡易MDI表示から除外されます （”サイズ統一”有無ソフトが混在する場合は、それぞれ別々に動作します）。

  AddTabExには、ランチャ機能がありますが、これにより起動したソフトは タブ化登録されていれば、直ちにタブ化されます。ただし、そのタイミングや ソフトの性質によっては、タブ化されないことがありますので、その場合は ”更新”操作（「■　メニュー」 「■　マウスによる操作」参照）を行ってください。
また、AddTabExによりソフトを終了させた場合も、直ちにタブに反映されるよう 作成されていますが、反映されない場合は、同様に”更新”操作を行ってください。

  いずれにしても、各ソフトとの相性がありますので、ご確認の上ご利用ください。

※　AddTabExでは、タブ化を行う場合、通常、当該ソフトの オーナー・ウィンドウを対象に実行します。しかし、 オーナー・ウィンドウが不可視で、そのサブ・ウィンドウを メイン表示として動作するものについては、操作対象をサブ・ウィンドウに移します。 これにより、タブ形式ソフトなども取り込むことができます。 ただしこの場合、タブ化実行時に表示されている、他のサブ・ウィンドウ（メッセージ・ダイアログ、設定画面など）もタブ化されます。
なお、ウィンドウが不可視とは、ウィンドウ・サイズがゼロであることで認識します。


■　メニュー

  「システムメニュー」、「ランチャメニュー」があります。
【 システムメニュー 】

本体を右クリックすると、ポップアップ表示されます。
なお、設定内容の詳細については、次の「■　動作設定」を 参照してください。
[ 更新 ] | 設定された内容によりタブ化実行。 起動後「適用」により設定された内容も含みます。
[ サイズ更新 ] | 当該ウィンドウのサイズをマウス等で変更し、 この項目を選択すると、以降の更新時の サイズとして、この値が設定されます。 設定方法は「適用」にあたります。 設定ファイルは更新しません。 ※当該ウィンドウとは、 AddTabExにより最後に選択したウィンドウを指します。 最前面ウィンドウとは限りません。 ※”サイズ統一”設定されているソフトのみ、 対象とします。
[ 初期化 ] | 全てが設定ファイルに基づいてタブ化。 「適用」によって設定された内容は、破棄されます。
[ 開く ] | 設定されている（本体にアイコン表示されている）ソフトで、ファイルを開きます。 （複数ファイル選択可）
[ ソフト起動 ] | 設定されているソフトを、単体で起動。
[ 選択ウィンドウ終了 ] | 選択されているタブ上の（AddTabExにより最後に選択した）ウィンドウを終了。 （最前面にあるとは限りません。「■ 動作設定」内[ 終了確認 ]参照。）
[ 全てのウィンドウ終了 ] | 全てのタブ上のウィンドウを終了。
[ 重ねて表示 ] | 重ねて表示。
[ 横に並べて表示 ] | 横に並べて表示。 ※現在の設定横サイズ内で等分割して表示されますが、 １ソフトの表示サイズがタブ横幅サイズを下まわる場合は、 タブ横幅サイズに等分割表示します。 ※”サイズ統一”設定されているソフトのみ、 対象とします。
[ 縦に並べて表示 ] | 縦に並べて表示 。 ※現在の設定縦サイズ内で等分割して表示されますが、 １ソフトの表示サイズがタブ横幅サイズを下まわる場合は、 タブ横幅サイズに等分割表示します。 ※”サイズ統一”設定されているソフトのみ、 対象とします。
[ 最前面に表示 ] | 本体を最前面に表示する／しないの切替。 ※デフォルトで最前面になっています
[ タブ非表示 ] | タブを非表示にする／しないの切替。 詳細は「■ 動作設定」内＜タブ非表示＞を参照。 ※設定ファイルの更新は行いません。
[ 終了確認 ] | 終了確認する／しないの切替。 「■ 動作設定」内[ 終了確認 ]設定の切替。 ※設定ファイルの更新は行いません。
[ 最小化 ] | タブ化したウィンドウを含めて本体を最小化します。
[ 設定 ] | 設定画面を表示。
[ 取り込み ] | 設定画面の「タブ化設定」を開き、起動中ソフトを検出します。 この時、[タスクチェック]の設定が、”更新ボタン”の場合でも、 起動中ソフトの検出を実行します。
[ ヘルプ ] | このヘルプを開きます。
[ readmeを開く ] | readme表示用設定ソフトでreadme.txtを開く。
[ バージョン情報 ] | バージョン情報表示。
[ AddTabEx終了 ] | AddTabExのみ終了。
[ 全て終了 ] | 全タブ上のウィンドウ、及び、AddTabExの終了。
[ キャンセル ] | メニューのキャンセル

【 ランチャメニュー 】

ランチャ登録されているソフト一覧をポップアップ表示します。

[ 本体をCTRL + 右クリック ]
ソフトを選択すると、単体でソフトを起動します。

[ 本体にCTRL + ファイルをドロップ ]
選択したソフトで、ドロップしたファイル（フォルダ）を開きます。
複数ファイル（フォルダ）もＯＫ。

※どちらの場合も、メニュー選択の際に、 CTRLキーを押下すると、現在の設定ソフトを選択したソフトに変更します（本体のアイコン表示が切り替わります）。 このとき、ドロップしたファイルは選択したソフトで開きますが、 単体ソフトの起動は行いません。


■　動作設定

  ３ページの設定画面があります。「システムメニュー」（本体”右クリック） 内の[ 設定 ]より設定画面を表示してください。

（１）　共通ボタン
後述する各ページ共通のボタンです。
[ 設定 ] | 各設定画面で設定した内容を、設定ファイルに書き込み、 その内容を本体へ反映します。 次回の起動からこの内容で動作します。
[ 適用 ] | 各設定画面で設定した内容を、本体へ反映します。 この場合、設定ファイルを更新しませんので、現在起動中のみの設定となります。
[ キャンセル ] | 今回設定した内容をキャンセルします。

（２）　基本設定
全体の外観等を設定します。
[ ウィンドウ ] | 「位置x」、「位置y」 起動時の本体表示位置です。 [０ ～ ディスクトップの最大値] まで指定できます。 「サイズx」、「サイズy」 タブ化した場合の、”サイズ統一”設定されたソフトのウィンドウサイズ。 表示されている値は設定ファイル内の値で、起動後にサイズ更新で 設定した値ではありません。 [タブの横幅 ～ ディスクトップの最大値]まで指定できます。 「取得」ボタン 現在の本体の位置と、ソフトのウィンドウサイズを取得します。 取得するウィンドウサイズは、AddTabExにより最後に選択したウィンドウの 大きさです。 ※スライドバーと両端の間をクリックすると５０刻みで値が変化します。
[ カラー ] | ＜ウィンドウ＞．．．本体（アイコンの透過部分）の色 「システム」 タスクバー等に使用されている色（この設定画面の色） 「ディスクトップ」 ディスクトップ色（壁紙等を使用していない場合） 「タイトルバー」 アクティブウィンドウのタイトルバーの色 「カスタム」 カラーボックスをクリックして自由に色を設定 ＜選択タブ＞．．．選択タブの文字色 カラーボックスをクリックして自由に色を設定 ＜タブ非表示＞．．．タブの非表示モード設定 非表示にした場合、本体下部に移動ボタンが表示されますので、 これにより表示ウィンドウを選択してください。 また、”CTRL＋移動ボタン”で当該ウィンドウを終了可能です。ただし、 当該ウィンドウとは、AddTabExにより最後に選択したウィンドウを指します。 最前面表示ウィンドウとは限りません（下記[ 終了確認 ]参照）。
[ エディター ] | readme.txtを開くエディタ この設定画面全体がドロップエリアになっているので、 ここにドロップすれば設定できます。 また、表示部分をクリックすれば、ダイアログより登録できます。
[ タスクチェック ] | 現在起動中のソフトを検出するタイミング 「更新ボタン」 タブ化設定画面内の更新ボタンにより検出 「画面表示」 タブ化設定画面を開く毎に検出 ※登録済みチェックなどにより、検出に時間がかかる場合があるので、「更新ボタン」推奨
[ 終了確認 ] | 本体、および、タブ化したウィンドウの終了確認 「問い合わせする」 メッセージボックスにより終了確認します。 ※選択ウィンドウを終了する場合、 当該ウィンドウを最前面に表示し、ソフト名称、および、キャプションの内容を表示するので、 終了ウィンドウを確認できます。

（３）　タブ化設定
タブ化するソフトの登録などを設定します。
[ タブ化登録 ] AddTabExでソフトをタブ化する場合、２通りの登録方法があります。
設定ファイルに登録しておき、常にタブ化する方法（常設タブ化）と、 起動後に登録して、今回の起動中のみタブ化する方法（非常設タブ化）です。
それぞれ左右のリストビューに設定してください。最大２０まで登録可能です。

「ファイル選択ダイアログによる登録」
それぞれリストビューのヘッダ部分（名称表示のある部分）をクリックすると、 ファイル選択ダイアログが表示されるので登録してください。
「起動中のソフトを登録」
起動中ソフトのコンボボックスからソフトを選択して、それぞれの「追加」 ボタンを押下して登録してください。
表示されていない場合は、「更新」ボタンを押下してください。 最新の起動中ソフトの一覧が表示されます （一覧の内容については、「■　タブ化について」 を参照してください）。
「ファイルをドロップして登録」
常設タブ化ソフトについては、当設定画面にファイルをドロップして 登録することが可能です。

※設定時に「適用」を選択した場合は、常設、非常設の区別は ありません。
[ 削除 ] リストビューよりファイルを選択して、それぞれの「削除」 ボタンを押下してください。
[ 項目設定 ] タブに表示する文字（当該ウィンドウのキャプションから選択、 または、ソフト名称）、および、ウィンドウサイズ制御の有無を設定します。
リストビューよりファイルを選択して、それぞれの「項目設定」ボタンを押下するか、 リスト上の項目をダブルクリックしてください。登録ダイアログにより設定可能です。

①　タブ表示文字設定
「先頭から半角１６文字分表示」
登録ダイアログの「なし」を選択
「キャプションの先頭にあるパスよりファイル名選択」
登録ダイアログの「先頭」を選択し、表示パスの直後の文字、または、 文字列を入力
”c:\windows\ABCDE.txt - メモ帳”の場合、
  「先頭」を選択し、”□-□”（□は半角スペース）と設定すると、
タブに”ABCDE.txt”と表示します。
 この場合”□”でも表示できますが、パスにスペースがある場合、正しく 表示されませんので、なるべくパスを特定できる文字列を設定してください。
なお、パスが確認できない場合は、先頭から半角１６文字分表示します。
「キャプションの後部にあるパスよりファイル名選択」
登録ダイアログの「後部」を選択し、表示パスの直前の文字、または、 文字列を入力
”メモ帳 - c:\windows\ABCDE.txt”の場合、
  「後部」を選択し、”□-□”と設定すると、
タブに”ABCDE.txt”と表示します。
 こちらの場合も、パスを特定できる文字列を設定してください。
なお、パスが確認できない場合は、設定した文字列から半角１６文字分表示します。
文字列自体確認できない場合は、先頭から半角１６文字分表示します。
「ソフト名称」
登録ダイアログの「名称」を選択

※上記でパスを特定する際、パスが” ”、 ［ ］、（ ）等で括られている場合でもＯＫです。
  （前後半角１文字削除して検索します。）

②　ウィンドウサイズ制御
”サイズ統一”をチェックした場合、タブ化実行時に、設定したウィンドウサイズに 統一します。また、このモードで簡易MDI表示を行うことができます。
ウィンドウのサイズ変更ができないソフトについては、”サイズ統一”しない設定で ご利用ください。
なお、設定したウィンドウサイズとは、基本設定画面で設定したサイズ、または、 その後、サイズ更新操作で設定したサイズを指します。

③　リスト表示
リストに表示されている「Ｔ」、「Ｗ」について。
「Ｔ」　：　タブ表示文字設定
  ブランク　．．．なし
  Ｆ　　　　　．．．先頭
  Ｂ　　　　　．．．後部
  Ｎ　　　　　．．．名称
「Ｗ」　：　ウィンドウサイズ制御設定
  ブランク　．．．サイズ統一なし
  ＊　　　 　．．．サイズ統一あり

※登録ダイアログの”≪”、”≫”ボタンは、 現在表示中の内容を設定した上で、前、後の項目へ移動します。

※ソフト登録時点では、デフォルトの設定として、 ”キャプションの先頭にあるパスよりファイル名選択”、”□-□”、 ”サイズ統一”なしを設定します。

（４）　ランチャ設定
AddTabExから起動するソフトを登録します。
[ 登録 ] | リストビューのヘッダ部分をクリックすると、ファイル選択ダイアログが 表示されるので、登録してください。また、当設定画面にドロップしても 登録可能です。最大２０まで登録できます。 ソフト名称（メニュー表示用）の設定は、設定したい項目を選択し、さらに左クリックすれば可能です （エクスプローラーでファイル名を変更する方法と同様です）。 なお、起動時ウィンドウにアイコン表示されるソフト（【 起動オプション 】で、 ファイルを開くソフト）は、リストの最上段です。 後述の移動により、決定してください。
[ 削除 ] | リストビューからソフトを選択して、「※」ボタンを 押下してください。
[ 移動 ] | リストビューからソフトを選択して、「▲」「▼」ボタンを 押下してください。ひとつずつ移動します。 また、「△」を押下すると、先頭へ移動します。


■　マウスによる操作

【 本体に対するマウスによる操作 】
左ボタン押下 ＋ マウス移動 | 本体の移動。
左ボタン押下 ＋ 右クリック | ランチャ設定の切り替え。 ランチャの登録順に、ソフト（本体のアイコン表示）が 切り替わります。
CTRL ＋ 左ボタン押下 ＋ 右クリック | 上記操作の逆方向へ、切り替わります。
左ダブルクリック | システムメニュー内”更新”と同様。
CTRL ＋ 左ダブルクリック | システムメニュー内”サイズ更新”と同様。
右クリック | システムメニュー表示。
CTRL ＋ 右クリック | ランチャメニュー表示。
ファイルをドロップ （フォルダ可） （複数可） | 設定ソフト（アイコン表示されているソフト）で、ファイル（フォルダ）を開く。
CTRL ＋ ファイルをドロップ （フォルダ可） （複数可） | ランチャメニュー表示。
メニュー表示後の操作内容については、 「■ メニュー」を参照してください。

【 タブに対するマウスによる操作 】
左クリック | 当該ウィンドウの選択。
CTRL ＋ 左クリック | 当該ウィンドウの終了。

【 移動ボタンのマウスによる操作 】
＜ ＞ ボタン押下 | それぞれ逆方向へ選択ウィンドウの移動。
CTRL ＋ ＜ ＞ ボタン押下 | 当該ウィンドウの終了。 （「■ 動作設定」内＜タブ非表示＞参照。）


■　その他

【 起動オプション 】

「デフォルトの設定ソフト（ランチャ登録ソフトのリスト最上段）」で開きます。
（ブランク区切りで複数指定可能　：　アイコンに複数ドロップでも同じ）

    AddTabEx.exe フルパス１ フルパス２．．．．．

直接コマンドラインで指定する場合に、パスにブランクが含まれる 場合は、パスを""で囲む必要があります。

【 注意事項 】

本体移動時、タブ表示等が乱れることがあります。
（タブ化ウィンドウ数が多くなると、移動動作が重くなります）

タブに表示する文字が、当該ウィンドウのキャプションの内容と一致しない （設定どおりに表示されない）場合があります。

各処理後のフォーカスは、AddTabExにより最後に選択したウィンドウへ 移動するように作成されていますが、ヘルプ終了時には、 ヘルプ終了直前にアクティブだったウィンドウにフォーカスが移動します。

「設定ファイルエラー」等で起動できなくなった場合は、 設定ファイル（AddTabEx.ini）を削除し、起動後再設定してください。

AddTabEx自体の重複起動は、チェックしていません。

設定（ランチャ登録）ソフトが起動できない場合「起動異常」のエラーメッセージが出る 可能性があります。

登録データ（タブ項目設定データ、ランチャ登録ソフト名称等）に、 "<"">"",（カンマ）" は使用できません。また、各種登録ソフトのパスに、",（カンマ）"が含まれている場合、 正しく動作しません。

※「最前面表示ウィンドウとは限りません」という表現について

  AddTabExでタブ化したウィンドウはそれぞれ独立して操作可能なため、AddTabExで記憶 している「最前面表示ウィンドウ」と実際のアクティブな「最前面表示ウィンドウ」が 違う場合があります。したがって、AddTabExによりウィンドウを終了する場合などの操作には注意が必要です。

※　Ver.1.00からのバージョンアップについて

  Ver.1.01よりウィンドウサイズの制御が、各ソフト単位に変更になったため、 Ver.1.00で”サイズ変更なし”設定で使用中の場合、Ver.1.01以降へのバージョンアップ直後には、 全てのタブ化登録ソフトは”サイズ統一”なしに、逆に、”サイズ変更なし”でない 場合は全て”サイズ統一”ありに設定されます。
  また、「終了確認」モードについては、”問い合わせする”でないに設定されます。