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LIMITED WARRANTY AND DISCLAIMER, LIMITATION OF REMEDIES AND DAMAGES

 

YOU ACKNOWLEDGE THAT THE SOFTWARE MAY

NOT SATISFY ALL YOUR REQUIREMENTS OR BE FREE FROM DEFECTS.  CLARIS WARRANTS THE DISKETTES ON WHICH THE

SOFTWARE IS RECORDED TO BE FREE FROM DEFECTS IN MATERIALS AND WORKMANSHIP UNDER NORMAL USE FOR 90 DAYS

FROM PURCHASE, BUT THE SOFTWARE AND ACCOMPANYING WRITTEN MATERIALS ARE LICENSED "AS IS."  ALL IMPLIED

WARRANTIES AND CONDITIONS (INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY OR FITNESS FOR A

PARTICULAR PURPOSE) ARE DISCLAIMED AS TO THE SOFTWARE AND ACCOMPANYING WRITTEN MATERIALS AND LIMITED

TO 90 DAYS AS TO THE DISKETTES.  YOUR EXCLUSIVE REMEDY FOR BREACH OF WARRANTY WILL BE THE REPLACEMENT OF

THE DISKETTES OR REFUND OF THE PURCHASE PRICE.  IN NO EVENT WILL CLARIS OR ITS DEVELOPERS, DIRECTORS,

OFFICERS, EMPLOYEES OR AFFILIATES BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR INDIRECT DAMAGES

(INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND

THE LIKE), WHETHER FORESEEABLE OR UNFORESEEABLE, ARISING OUT OF THE USE OF OR INABILITY TO USE THE

SOFTWARE OR ACCOMPANYING WRITTEN MATERIALS, REGARDLESS OF THE BASIS OF THE CLAIM AND EVEN IF CLARIS OR

AN AUTHORIZED CLARIS REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  

Claris' liability to you for actual damages for any cause whatsoever, and regardless of the form of the action, will be limited to the greater of $500 or

the money paid for the Software that caused the damages.  

THE ABOVE LIMITATIONS WILL NOT APPLY IN CASE OF PERSONAL INJURY ONLY WHERE AND TO THE EXTENT THAT

APPLICABLE LAW REQUIRES SUCH LIABILITY.  BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR

LIMITATION OF IMPLIED WARRANTIES OR LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE

LIMITATIONS MAY NOT APPLY TO YOU.  
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 Customer Assistance is available to 
answer your questions about product 
availability, upgrades, features, customer 
registration, policies, procedures, and other 
nontechnical topics. We will also look into 
any problems you may encounter while doing 
business with Claris.

The following services are available to 
registered Claris customers:

 

Telephone Service

 

You can call Customer Assistance from 
8 AM to 5 PM, Monday through Thursday; 
8 AM to 2 PM on Friday (Pacific Time). The 
number is 408-727-8227.

 

Registration Status

 

Customer Assistance can answer questions 
regarding your registration status. Please 
have your product serial number handy 
when you call.

 

Change of Address

 

Customer Assistance handles customer 
address changes. Send a letter that includes 
both your old and new addresses to:

 

 

Customer Assistance
Claris Corporation
MS C-71
Box 58168
Santa Clara, CA 95052-8168

ATTN: CHANGE OF ADDRESS

Claris Customer Assistance

Defective or Damaged Products
Contact Customer Assistance if your product 
is damaged or defective. Be sure to have your 
product serial number handy when you call. 
Defective disks will be replaced free of charge 
during the 90-day limited warranty period. 
After the warranty period, replacement disks 
are available to registered customers at a cost 
of $10 each. 

Send the defective disk, a brief explanation, 
and payment (if necessary) to:

Product Upgrades and Updates
For warranty, upgrades, registration, change 
of address, and nontechnical questions, call 
Customer Assistance at the number above.

Local Claris Dealers
Contact Customer Assistance for the name of 
a Claris dealer near you.

Or Contact Customer Assistance 
via:
AppleLink: CLARIS.CR
America Online: Claris CR
FAX (408) 987-3932
Automated Faxline: (800) 800-8954

 

Customer Assistance
Claris Corporation 
MS C-70
Box 58168
Santa Clara, CA 95052-8168

ATTN: REPLACEMENT MEDIA
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Claris Technical Support

 

Please take the time to complete and mail 
your postage-paid product registration card 
to us. Technical Support and other Claris 
benefits such as product update notices are 
available only to registered users.

 

24-hour Voice AnswerLine

 

800-735-7393 (for pre-recorded answers to 
the most commonly asked questions)

 

24-hour Fax AnswerLine

 

800-800-8954 (for technical documents and 
other information sent to your fax machine). 
Please use a touch tone phone and follow the 
menu-driven instructions.

 

24-hour Claris BBS

 

408-987-7421 (for posting messages and 
downloading technical notes)

 

Online Services

 

Claris Technical Support maintains a full 
forum on America Online and CompuServe. 
These forums include product ordering and 
technical information, message boards, live 
conferences, and more.

 

America Online:

 

 keyword CLARIS
Full forum includes product ordering and 
technical information, message boards, live 
conferences, and more.

 

CompuServe:

 

 Go CLARIS
Full forum includes product ordering and 
technical information, message boards, live 
conferences, and more.

 

AppleLink: 

 

Third Parties: Claris Icon
Product information folders, Technical 
Support message board and more.

 

Technical Support by Telephone

 

For Microsoft Windows applications

 

408-727-9004

 

For Apple Macintosh applications

 

408-727-9054

Monday through Thursday, 6 

 

AM

 

 to 6 

 

PM;

 

 
Friday, 6 

 

AM

 

 to 2 

 

PM

 

 (Pacific Time)

 

Other Support Services

 

The Claris Solutions Alliance 

 

Serves consultants, custom developers, and
trainers who provide solutions using Claris
software.

For further details or for a Claris Solutions
Alliance application kit, call 408-727-8227,
or fax your request to 408-987-3932.

You may also download the application kit
from our forums on America Online or 
CompuServe.
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 Developer Hotline

 

Please call 408-987-7422 if you have a 
new product that you wish to propose for 
publication.

 

Mailing address:

 

Technical Support
Claris Corporation; MS C-12
5201 Patrick Henry Drive, Box 58168
Santa Clara, CA 95052-8168
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Claris Customer Support

 

Thank you for purchasing this Claris software 
product. Claris is dedicated to ensuring that 
you gain the greatest possible value from our 
products. Please take a minute to learn about 
the support and services we provide. Note that 
the benefits and services offered by Claris are 
subject to change without notice.

 

Complete and Mail Your 
Registration Card right now!

 

In order to serve you better, we need to know 
who you are. Please take the time to complete 
and mail the product registration card that is 
included in the box. No postage is necessary. 
We also would like to know where you 
bought your Claris product and how you plan 
to use it. Thank you for responding.

 

Technical Publications

 

We’ve worked hard to prepare complete, 
accurate documentation to help you learn and 
use the full capabilities of our products. Claris 
manuals and onscreen help systems have won 
many awards for excellence. We urge you to 
become familiar with this material and use it as 
your primary source of information. 

 

Training

 

Claris Training works with professional 
instructors throughout the world to develop 
high-quality training programs for Claris 
customers. Introductory training is provided 
with the software. In addition, Claris Solutions 
Alliance members offer more advanced 
courses that can be customized to meet the 
specialized needs of individual organizations. 

Call Claris Customer Assistance at 
408-727-8227 for information about the 
Claris Solutions Alliance and the location 
of members nearest you.

 

Claris is a registered trademark, and Claris Clear Choice is a trademark of Claris Corporation.

AppleLink and Apple Macintosh are registered trademarks of Apple Computer, Inc.
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Welcome

 

Welcome to ClarisWorks

 

Welcome to the ClarisWorks

 



 

 application from Claris Corporation. ClarisWorks 
is an integrated software package designed to give you everything you need to 
be productive: a natural computing environment and the right tools for the job.

ClarisWorks documents share many functions and features with other 
Claris

 



 

 products for Windows and the Apple Macintosh. If you’ve used the 
MacWrite

 



 

 

 

Pro, FileMaker

 



 

 Pro, or MacDraw

 



 

 Pro applications, you’ll find 
many similarities.

If you plan to use specialized Claris products later, such as the FileMaker Pro 
application, you can apply what you learn with ClarisWorks to those products.
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Quick Guide to ClarisWorks Publications

 

This book, 

 

ClarisWorks Getting Started, 

 

is one of several Claris publications 
designed to help you learn and use ClarisWorks. 

ClarisWorks publications give you a choice of learning from a book or from 
a help system on your computer—or both. You’ll find what you need in the 
comprehensive publications listed here. 

 

ClarisWorks Getting Started

 

ClarisWorks Getting Started

 

 shows you how to install and start the application 
and provides a step-by-step tutorial. The tutorial introduces you to significant 
features and explains how ClarisWorks documents work.

 

ClarisWorks Help 

 

ClarisWorks Help

 

 gives you onscreen instructions and reference information 
you can use while you’re working with ClarisWorks documents. Because the 
system is computer based, you can easily search for topics and move quickly 
from one topic to another. The help system covers selected topics, including 
spreadsheet and database functions, used in most ClarisWorks environments. 

 

ClarisWorks Handbook 

 

The 

 

ClarisWorks Handbook

 

 gives concise, step-by-step instructions for 
doing work in ClarisWorks documents. The handbook also provides reference 
information you need for power work, such as complex database searches and 
macro-building.

 

ClarisWorks Quick Reference Card

 

The 

 

ClarisWorks Quick Reference Card

 

 lists keyboard shortcuts, identifies 
icons and tools, and includes a menu map.
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Conventions Used in This Book

 

This book uses certain formatting conventions to aide your learning of 
ClarisWorks.

 

Instructions

 

Step-by-step instructions are introduced with a “To Do” heading. Numbered 
directions follow these special headings. For example:

To delete a record:

 

1. Click a record to select it.

2. Choose Clear or Cut from the Edit menu.

 

Single-step instructions are preceded by a triangle symbol so that you can 
distinguish them from other text. For example:

 

.

 

To show the graphics rulers, choose Show Rulers from the Window menu.

 

Notes

 

Notes contain handy tips and other useful information. A diamond symbol 
precedes these notes. For example:

 

◆

 

Different starting number

 

You can change the starting number for footnotes. 
For information, see the 

 

ClarisWorks Handbook

 

.

 

Special Terms

 

You may occasionally encounter a specialized term you don’t recognize. You 
can look up most of these terms in the glossary, which comes just before the 
index at the back of the book. Words that appear in 

 

boldface

 

 in this book are 
listed in the glossary.

 

Where to Go from Here

 

For instructions on installing ClarisWorks and an introduction to the tutorial, 
turn to chapter 1 now. If you’re an experienced user, you can go directly to 
chapter 2, the beginning of the tutorial.



 

Installing ClarisWorks

 

What’s on the ClarisWorks Disks 1-3

What You Need 1-3

Before You Begin 1-3

Installing ClarisWorks 1-4

Where Everything Goes on Your 
Hard Drive 1-12

Learning ClarisWorks 1-14

Chapter

 

1
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Chapter

 

1

 

Installing ClarisWorks 

 

This chapter provides step-by-step instructions for installing ClarisWorks for 
Windows and associated files on your PC.

 

◆

 

Important

 

The instructions given here assume you’ve looked at the 
Microsoft Windows Tutorial, which covers standard mouse techniques 
such as clicking and dragging. 

The instructions also assume you’ve reviewed the 

 

Microsoft Windows User’s 
Guide

 

. If you find you need more information about mouse techniques, 
working with disks, or making copies of documents and disks, use that guide

 

 

 

as a reference

 

.
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What’s on the ClarisWorks Disks

 

Your ClarisWorks disks contain files and software in the following categories:

 

■

 

Setup

 

—the software you need to install the ClarisWorks  application and 
to open and save documents in different formats

 

■

 

ClarisWorks

 

—the application.

 

■

 

Help

 

—the ClarisWorks Help file that runs under the Windows help system

 

■

 

References

 

—the dictionaries used for the spelling checker and thesaurus

 

■

 

Samples

 

 and 

 

Tutorial—

 

the directories that contain sample files, templates, 
and the files used for the Getting Started tutorial

For information on where these files go when you install them, see “Where 
Everything Goes on Your Hard Drive” on page 1-12.

 

What You Need

 

To install and use ClarisWorks for Windows, you need the following 
equipment and software:

 

■

 

any IBM-PC or equivalent with an 80386 microprocessor or higher

 

■

 

at least 2 megabytes of RAM (random-access memory), but 4 megabytes or 
more provides optimum performance 

 

■

 

Windows system software version 3.0, or higher, and MS-DOS version 3.1, 
or higher, already installed on your PC’s hard disk drive. Windows version 
3.1 and MS-DOS version 5.0 is recommended.

 

■

 

a hard drive, internal or external

 

Before You Begin

 

Before you begin the installation process, take a moment to copy and register 
your new software.
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Making Backup Copies

 

To protect your software, make backup copies of all the ClarisWorks disks 
before you start the installation procedure. If you need information on copying 
disks, see the

 

 Microsoft Windows User’s Guide.

 

After you’ve made backup copies, store the original disks in a safe place and 
use the copies for installation.

 

Registering Your Software

 

As a registered ClarisWorks owner, you’re eligible for special benefits:

 

■

 

technical support

 

■

 

software updates

 

■

 

specially priced upgrades

 

■

 

Claris product news

You also receive announcements of special promotions for future purchases 
of Claris products.

To register your software, complete and mail the owner registration card that 
comes with ClarisWorks.

 

Installing ClarisWorks

 

Follow these steps to install ClarisWorks and associated software on your 
hard drive. You have the choice of performing a full or partial installation. The 
latter is called a 

 

custom installation.

 

◆

 

Important

 

You must use the setup program to install ClarisWorks for 
Windows. You can’t copy the files to your hard drive using the DOS 
copy command because the files are compressed to fit on fewer disks. 
The setup program decompresses them during installation. 

 

1. Protect all your ClarisWorks disks. 

 

You can lock 3-1/2 inch disks by sliding the locking tab on each disk to 
reveal the hole.
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2. Start Microsoft Windows and make sure the Program Manager window is open.

3. Insert the Installer disk into a floppy disk drive (usually drive A).

4. Choose Run from the Program Manager’s File menu.

 

The Run dialog box appears.

 

5. Depending on the drive you inserted the installer disk in, type 

 

a:setup

 

 or 

 

b:setup

 

 
in the command line box and click OK.

 

The setup program starts and displays the ClarisWorks Setup dialog box. 

 

6. Click either Full Install or Custom Install.

 

If you clicked Full Install, the Personal Information dialog box appears. Go 
to step 7.

If you clicked Custom Install to do a partial installation, go to the section 
“Doing a Custom Installation” on page 1-8.
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7. Personalize your copy of ClarisWorks.

 

A blinking insertion point in the Name box indicates you can type your 
name there. Type your name and press Tab to move to the next box. 

Typing your company name and serial number is optional; however, Claris 
recommends typing the serial number here in case you lose your registration 
card. You need the serial number if you call Claris Customer Support.

Please note that after leaving this dialog box you can’t change the 
information typed here unless you reinstall ClarisWorks. To make 
corrections, press the Tab and arrow keys to position the insertion point, 
and press Backspace or Delete to erase the mistake. You can now retype 
the information.
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8. Click Continue.

 

The Destination for ClarisWorks dialog box appears. This box displays the 

 

path

 

—a sequence of one or more directories—that leads to the directory 
where the setup program installs ClarisWorks.

 

9. Click Continue to accept the preset path, or type a new path and click Continue.

 

The setup program begins moving files onto your hard drive. A dialog box 
informs you of progress.

 

10. Insert the other disks as you are asked for them.

 

The setup program displays a dialog box telling you which disk to insert. 
Click Cancel if you want to cancel the installation process.

After the installer copies all the files, it creates a program group for 
ClarisWorks that appears on your desktop. Then a message confirms that 
setup was successful.

 

Path name of directory where 
installation takes place
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11. Click OK to return to the Program Manager.

 

The ClarisWorks program group, which contains the application, is now 
in the Program Manager window.

After the custom installation section, the rest of this chapter describes the files 
installed on your hard drive and summarizes the content of the ClarisWorks 
tutorial. If you’re well-versed in ClarisWorks for the Macintosh, you can start 
up ClarisWorks for Windows now or scan the tutorial to see if you need it. If 
you’ve never used ClarisWorks, read on for further instructions.

 

Doing a Custom Installation

 

If you want to save space or avoid installing translators or other files you don’t 
need, you can install a subset of ClarisWorks files by following these steps. 
Later, should you need to, you can install any of the files you omitted by 
running the setup program again. Be sure to install the tutorial files if you are 
planning to use the tutorial.
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To do a custom installation:

 

1. If you haven’t already, follow steps 1 through 6 starting on page 1-4.

 

When you click the Custom Install button, the Custom Installation dialog 
box appears. 

 

2. Click the checkbox for each group of files you want to install and click Continue.

 

The Personal Information dialog box, shown in step 3, appears.

 

3. Personalize your copy of ClarisWorks.

 

A blinking insertion point in the Name box indicates you can type your 
name there. Type your name and press Tab to move to the next box. 
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Typing your company name and serial number is optional; however, 
Claris recommends recording the serial number here in case you lose 
your registration card. You need the serial number if you call Claris 
Customer Support.

Please note that after leaving this dialog box you can’t change the 
information typed here unless you reinstall ClarisWorks. To make 
corrections, press the Tab and arrow keys to position the insertion point, 
press Backspace or Delete to erase the mistake, and retype the 
information.

 

4. Click Continue.

 

The Destination for ClarisWorks dialog box appears. This box displays the 

 

path

 

—a sequence of one or more directories—that leads to the directory 
where the setup program installs ClarisWorks.

 

Path name of directory where 
installation takes place
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5. Click Continue to accept the preset path, or type a new path and click Continue.

 

The Destination for Claris Directory dialog box appears. This box displays 
the path to the directory where the Claris utility files are installed. All Claris 
applications share these files. The setup program replaces any older 
versions of these files found in the directory.

 

◆

 

Important

 

Don’t change your pathname if you already have Claris 
applications installed or these applications will not work.

 

6. Click Continue to accept the preset path, or type a new path and click Continue.

 

The setup program begins moving files onto your hard drive. A dialog box 
informs you of progress.

 

7. Insert the other disks as you are asked for them.

 

The setup program displays a dialog box telling you which disk to insert. 
Click Cancel if you want to cancel the installation process.

 

Path name of directory where 
installation takes place
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After the installer copies all the files, it creates a program group for 
ClarisWorks that appears on your desktop. Then a message confirms that 
setup was successful. 

 

8. Click OK to return to the Program Manager.

 

The ClarisWorks program group, which contains the application, is now 
in the Program Manager window. See page 1-7 for an illustration.

The rest of this chapter describes the files installed on your hard drive and 
summarizes the content of the ClarisWorks tutorial. If you’re well-versed in 
ClarisWorks for the Macintosh, you can start up ClarisWorks for Windows 
now or scan the tutorial to see if you need it. If you’ve never used ClarisWorks, 
read on for further instructions.

 

Where Everything Goes on Your Hard Drive

 

When you install ClarisWorks files on a hard drive, the setup program places 
the files in two different directories: CLWORKS and  CLARIS. As you work 
in ClarisWorks, the application always knows where to look for the various 
files when they’re needed. 

It’s best to leave files where the setup program places them. That way, 
ClarisWorks can’t lose track of the files it needs.
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What Goes in the CLWORKS Directory

 

The ClarisWorks setup program creates a CLWORKS directory for you on 
your hard drive. After installation, the CLWORKS directory contains the 
following items: 

 

■

 

CLWORKS.EXE—ClarisWorks application

 

■

 

CLWORKS.HLP— ClarisWorks Help

 

■

 

Tutorial directory (contains files used for the tutorial)

 

■

 

Samples directory (contains sample documents)

 

■

 

Read Me file (contains information about last-minute changes to 
the product)

 

What Goes in the Claris Directory

 

ClarisWorks uses special files to import documents from other applications, 
save ClarisWorks documents in different formats, and run the spelling checker 
and thesaurus. These files go into a directory called “Claris.” 

The ClarisWorks setup program creates a Claris directory for you if one 
hasn’t already been installed by another Claris application. Unless you 
specify otherwise during installation, ClarisWorks creates the Claris 
directory in the Windows directory. The following files are placed in the 
Claris directory at installation:

 

■

 

USENG.NDX—main dictionary (the primary dictionary used by the 
spelling checker) 

 

■

 

USERD.SPL—user dictionary (a custom dictionary you use for your 
own specialized terms)

 

■

 

UTHES.MTH—US English Thesaurus 

 

■

 

Claris XTND translators (software that allows you to open and save 
documents in various formats) 

 

Translators

 

 are programs that allow you to open documents created 
in applications other than ClarisWorks, such as FileMaker Pro and 
Microsoft Works.
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Learning ClarisWorks

 

The rest of the chapters in this book are in tutorial form. These chapters 
introduce you step by step to the basic skills you’ll need to work with 
ClarisWorks.

If you haven’t used ClarisWorks before, Claris strongly recommends that 
you work through the examples in the tutorial. 

 

Working Through the Tutorial

 

In the tutorial, you’ll work through a series of examples that give you practical 
experience using ClarisWorks documents and features. The tutorial does more 
than teach you about software features. For example:

 

■

 

Working through the tutorial gives you a chance to get comfortable with the 
application before you tackle major jobs on your own.

 

■

 

The tutorial demonstrates a routine process of working with ClarisWorks 
documents: how to start a project, how to proceed, and how to finish 
the job.

 

■

 

Through the various examples, the tutorial shows you how much you 
can accomplish, and the variety of work you can do, when you use 
ClarisWorks.

Don’t worry if you’ve never used a computer before. You’ll soon find yourself 
as comfortable with the PC—and ClarisWorks—as you are with pencil 
and paper.
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Guide to the Tutorial

 

The tutorial is broken up into six sessions (chapters 2 through 7). Each session 
is designed to help you become familiar with a certain aspect of ClarisWorks. 
In most sessions, you can either start work on your own project or use the 
sample information provided.

 

■

 

Chapter 2

 

 explains how to start up ClarisWorks and introduces concepts 
and terms you’ll need for the remaining sessions. You’ll also learn how to 
open and use the ClarisWorks onscreen help system.

 

■

 

Chapter 3

 

 takes you through the process of creating and working with a 
word processing document, using a typical memo as a starting point.

 

■

 

Chapter 4 

 

uses a graphics document to show you how to create a letterhead 
and save the letterhead as ClarisWorks stationery.

 

■

 

Chapter 5

 

 introduces you to a spreadsheet document, using a simplified 
quarterly business report as an example.

 

■

 

Chapter 6

 

 introduces you to a database document, using an invoice form 
and mailing list as examples.

 

■

 

Chapter 7

 

 introduces you to advanced ClarisWorks features, including 
linked text frames and spreadsheet frames, using a newsletter as an 
example. If you’re not yet familiar with frames, see the glossary for a 
brief definition.

 

◆

 

Different monitors

 

If you have a high-resolution small- or large-screen 
monitor, your view of documents may be different from the view shown in 
the illustrations in this book. You can adjust the size of the ClarisWorks 
window to match the screen size shown in the figures. Some tutorial steps, 
such as scrolling through a document, won’t be necessary if you have a 
large screen and don’t adjust the window size.
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Chapter

 

2

 

A First Look at ClarisWorks

 

This chapter begins the tutorial by orienting you to basic concepts, introducing 
you to ClarisWorks Help, and giving you some direct experience working with 
onscreen elements such as objects and windows. 

In this chapter you’ll learn how to:

 

■

 

start ClarisWorks and open an existing document

 

■

 

create and manipulate objects

 

■

 

use the ClarisWorks onscreen help system

 

■

 

create new documents of different types

 

■

 

change your view of a document and stack windows for easy access

 

■

 

save and close a document
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Starting ClarisWorks

 

To get started on the tutorial, you’ll first start the application and then open a 
sample document.

To start ClarisWorks for Windows:

 

1. Start Windows and open the ClarisWorks group window on the desktop.

2. Double-click the ClarisWorks application icon.

 

The ClarisWorks start-up screen appears briefly followed by the New 
Document dialog box appears. Click the Cancel button and go to the next 
section, “Beginning the Tutorial.”
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Beginning the Tutorial

 

To open the first tutorial document:

 

1. Choose Open from the File menu.

 

The Open dialog box appears.

Change directories until the Tutorial directory is current. (For help 
changing directories, see the

 

 Microsoft Windows User’s Guide.

 

)

 

2. Select the Smplobjs.cwk file name and click OK (or double-click the name).

 

The Smplobjs.cwk file, a ClarisWorks document, opens on the screen.

 

About the Sample Document

 

A 

 

document

 

 is a file you create with an application to record the work that you 
do. The Smplobjs.cwk file is a ClarisWorks graphics document meant for 
graphics work (you’ll learn more about different types of documents a little 
later in this chapter). 

 

 
Current directory

Current drive
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A document appears in a 

 

window

 

 that provides various tools, menus,
and controls you use to work with and move around in the document itself.

Take a moment to look at this illustration and compare it with the document on 
your screen. The scroll bars, menu bar, and the title bar of the document should 
be familiar to you from your review of the

 

 Microsoft Windows User’s Guide. 

 

On the left you see something a little different. This is the ClarisWorks tool 
palette, which contains the tools you use to work with graphics elements—
elements like the shapes shown in the sample document.

 

Tool palette

Title bar

Graphics document

Scroll bar

Menu bar
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Understanding Objects

 

The sample document is made up of different kinds of 

 

objects

 

—elements 
you can draw, select, and move about within a document.

You’ll notice the objects don’t all look the same. Some of them contain text, 
some are simple graphic shapes, and one of them has text and numbers 
arranged in columns and rows.

Objects are the building blocks you use to create imaginative pages and to 
present different types of information in different ways. You’ll learn more 
about objects in chapter 4. 

For now, you may find it helpful to practice a few basic maneuvers.

 

Objects



 

A First Look at ClarisWorks

 

2-7

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

Selecting an Object

 

Because you select objects with the arrow pointer, make sure the graphics tool 
(the arrow) is selected if you’ve been experimenting with the tool palette. 

To select an object:

 

1. Click the white rectangle.

 

The rectangle should now have 

 

handles

 

—black squares at the edges of 
the object’s boundary. Handles indicate an object is selected. The 
rectangle is an opaque object, so you can click anywhere on the object 
to select it.

 

2. Click the edge of the transparent circle.

 

If you don’t see any handles, try clicking again. The circle is a transparent 
object—you can see the grid behind it—so you must click the edge or 
outline of the object to select it

 

.

 

The other objects in the file—the spreadsheet frame, the text frame, and the 
stars—are opaque objects because they are filled with patterns, cells, 
or information.

You must select an object before you can do anything with it, such as move 
it or change its size.

 

Selected object

Handles
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Moving an Object

 

You use the arrow pointer to move an object, too. If you want to reverse the 
move, choose Undo Move from the Edit menu. 

To move an object:

 

1. Position the pointer over the selected object. 

 

If the object is transparent, place the pointer on the object’s outline.

 

2. Drag the object to a different spot in the document.

 

Don’t drag a handle or you’ll resize the object. If you moved the circle, 
you’ll notice the text inside didn’t move with it. That’s because the text 
is a separate object. 

If you don’t understand the concept of dragging by using the mouse, see the

 

 
Microsoft Windows User’s Guide.

 

Changing the Size of an Object

 

To change an object’s size, drag one of the handles outward from the object 
with the arrow pointer.

The object becomes larger as you drag. If you drag the handle toward the 
middle of the object, the object gets smaller.

If you want to reverse your last change, choose Undo Resize from the 
Edit menu.

 

Handles Drag a handle to 
change the size.
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Drawing Objects

 

The objects in the sample document were drawn using the tools in the 
ClarisWorks tool palette shown here. Because objects are so important to 
understanding ClarisWorks, now is a good time to learn how to create them. 

As you try out the next few steps, don’t worry about ruining the sample 
document. It’s here to give you a chance to practice.

To draw a rectangle:

 

1. Click the rectangle tool.

 

The pointer changes to a crosshair.

 

2. Drag the pointer to draw a rectangle of any size.

 

Handles appear around the new object to show that it’s selected. You can 
move the rectangle or resize it.

To draw a text object:

 

1. Click the text tool and drag the I-beam pointer to draw a rectangle.

 

This object is different—it has no handles. Something else is also different: 
A blinking bar appears in the upper-left corner of the object. This is the text 
insertion point.

 

Graphics tool
Text tool
Spreadsheet tool

Rectangle tool
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2. Type your name or any other text.

 

The text appears in the object as you type.

 

3. Press the Enter key on the numeric keypad or click outside the object.

 

Now handles appear on the object, showing that it’s selected. The object 
has shrunk vertically to just the size of the text. 

To draw a spreadsheet object:

 

1. Click the spreadsheet tool, and drag it to draw a rectangle.

 

This object, called a 

 

frame

 

, is different from the other two you drew. It 
contains columns and rows.

 

Text in an object

 

The object shrinks 
to fit the text.
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One box at the upper-left corner of the frame has a heavy border. The 
border indicates a selected cell. Notice also that a new panel was added to 
the top of the document. This is the 

 

data entry bar

 

 for the spreadsheet.

 

2. Type the year 1993.

 

The number appears in the data entry bar as you type.

 

3. Press Tab.

 

The number now appears in the box, and the heavy border has moved to 
the next box. 

In a later chapter, you’ll learn more about spreadsheets. For now it’s 
enough to know that an object can contain a spreadsheet. You can move 
or resize the spreadsheet object just as you can any other object.

 

Data entry bar

Box with heavy border 
(a selected spreadsheet cell)

Spreadsheet object (frame)

Spreadsheet menus

 

Data in spreadsheet object 
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Using Help as You Work

 

Now that you’re about midway through this session of the tutorial, take a 
moment to become familiar with the comprehensive onscreen help system that 
comes with ClarisWorks. ClarisWorks Help is based on the Windows Help 
application, so the information within it is organized by topics. The system is 
referred to as 

 

onscreen

 

 

 

help

 

 because you can open and view the help system 
while you’re working with a ClarisWorks document.

To open the help system:

 

1. Choose Contents from the Help menu or press the F1 key. 

 

The ClarisWorks Help Contents window opens. Displayed in this window 
is a list of underlined entries. (If you have a color monitor, the entries are 
in color.) You can click one of these entries to move to a topic. 

 

 

 

Topics are actually buttons

Click About Help to learn 
how to use the system.
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2. Click About Help and follow the instructions on the About Help screen. 

 

Click an underlined entry to get information about a topic. To return to the 
About Help screen, click the Back button.

 

◆

 

More about Windows Help

 

To learn more about using Windows Help, 
choose “How to Use Help” from the ClarisWorks Help window.

You can leave the ClarisWorks help system open as you work. You may find, 
though, that you want to place the window in a different spot on the screen for 
easier access or better visibility. The Windows environment provides several 
ways to display and conceal the help window so that it doesn’t interfere with 
your work, but it is still handy when you need some information. These options 
are especially useful when you are working on a small screen.

Here are some techniques for handling the help window. For more information 
about these techniques, read your 

 

Microsoft Windows User’s Guide.

 

■

 

To move the help window, drag its title bar.

On a large screen, you can usually place the window side by side with a 
ClarisWorks document. On a smaller screen, try “stacking” the windows so 
you can always find an edge to click to activate the help system or your 
documents (see illustration on page 2-14).

 

■

 

To reduce the help window to an icon, click the Minimize button.

 

■

 

To expand the help window to a full-screen view, click the Maximize button.

 

■

 

To keep the help window on top of other windows, open ClarisWorks Help 
and choose Always On Top from the Help menu.

 

Icon for ClarisWorks 
Help window
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■

 

To stack the help window for quick access, resize the help window, if 
necessary, and drag it so that the help window partially overlaps the 
document you are working on.     

 

Zooming In and Out

 

When you left the Smplobjs.cwk document, you had just finished drawing 
several objects. As you drew them, you probably noticed that you could see 
only part of the document. The document is larger than the screen. 

 

Arranging windows for 
quick access to Help

 

Overlapping edges
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To get an idea of how the whole document looks, you can use the view controls 
at the bottom of the window to zoom out for an overview. 

(To see the zoom controls, you may need to move the help window.)

To zoom out:

 

1. Click the zoom-out control once.

 

ClarisWorks reduces the document by 66.7%. You can now see much more 
of the drawing. If you have a 14-inch monitor, your screen should now look 
like this illustration (with the additional objects you drew).

 

Zoom percentage box
Zoom-out control
Zoom-in control
Hide/show tools



 

2-16

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

To the left of the zoom controls, the zoom percentage box now reads 
“66.7,” indicating that the document is at a 66.7% reduction.

 

2. Click the zoom-out control again.

 

ClarisWorks further reduces your view of the document, giving you a 
bird’s-eye view. 

 

.

 

To zoom in, click the zoom-in control. 

ClarisWorks enlarges the view in stages each time you click.

 

.

 

To return to actual view (100%), click the zoom percentage box once.

ClarisWorks automatically returns to a 100% view, regardless of the 
percentage stages you’ve gone through. Click the box again to return to 
the previous view. The zoom percentage box alternates between 100 
percent and the previous zoom level in effect.

 

Practice Moves 

 

Try reducing the view and scrolling up and down through the document. You’ll 
find the scroll bars work the same way in any view. For information on 
scrolling, see the

 

 Microsoft Windows User’s Guide.

 

Hiding the Tools

 

In a graphics document such as Smplobjs.cwk, the tool palette is present 
when you open the document. In other types of ClarisWorks documents, the 
tool palette may or may not show, but you can bring it into view when you 
need it to draw an object. If you work on a small-screen PC, hiding the tools 
gives you more room to work with the contents of a document.

In a document where the tools are hidden, you can always bring them into view 
when needed by clicking the hide/show tools control.
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To hide ClarisWorks tools, choose one of these methods:

 

■

 

Click the hide/show tools control (shown on page 2-15). 

The tools disappear, but return if you click the control again.

 

■

 

Choose Show Tools or Hide Tools from the Window menu if you prefer 
to use a menu. 

The commands have the same effect as the hide/show tools control.

 

Undoing a Change

 

As you work with ClarisWorks, you can move an object, revise some text, or 
take some other action you’d prefer to undo. It’s easy to cancel an action, as 
long as you don’t do something else before you change your mind. 

To reverse an action:

 

1. Resize any object in the document.

2. Before you make any other changes, choose Undo Resize from the Edit menu. 

 

ClarisWorks restores the object to its original size.

In general, the Undo command reverses your latest action. 

The Undo command changes to Redo after you choose it, so you can 
restore a change if you wish. Also, Undo recognizes what you just did. 
If you change text, for example, the command becomes Undo Typing.

 

Understanding Document Types

 

In ClarisWorks you can create documents of four different types. Each type 
is specifically designed for a certain primary function. 

Near the end of this chapter, you’ll learn how to create new documents of 
different types. Before you move on, however, take a moment to become 
familiar with what each document type does best.
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Word Processing

 

A word processing document—also called a text document—is primarily for 
text. The text can take the form of memos, letters, reports, book manuscripts, 
or anything else you can type. 

For a professional look, you can use multiple columns, add footnotes, and add 
a header and footer. You’re not limited just to text. For example, you can paste 
pictures, draw graphic shapes such as boxes or borders, add frames, or add 
charts created from data in a spreadsheet. 

 

Customer letter in a word 
processing document
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Graphics

 

A graphics document is an electronic drawing pad, and it’s also much more. 
You can use a graphics document to lay out pages, such as those for a 
newsletter or brochure. You do this by drawing objects that contain text, 
drawings, or numbers.

 

Spreadsheet

 

A spreadsheet document is like a columnar pad of paper, but much more 
versatile. You can transform numbers into pie, bar, and scatter charts that show 
financial or scientific trends and relationships in a way that figures can’t. 

 

Newsletter in a graphics 
document
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Most people use a spreadsheet to tally numbers and compute formulas, but you 
can use one to organize any information you want to present in columns (for 
example, a schedule).

 

Database

 

You use a database document to store, sort, organize, and find information, 
whether you need a mailing list, catalog, or an invoice/sales tracking system. 

Using a database layout, you can design different ways to present the same 
data. For example, you can organize the names and addresses you enter in a 
sales record for use in a layout for mailing labels.

 

Data and chart in a 
spreadsheet document

 

Information in a database 
document
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Communications

 

When you create a new communications document, ClarisWorks actually 
opens the Windows Terminal application for you. For more information on 
using Terminal, see your 

 

Microsoft Windows User’s Guide. 

 

Here is what a 
new Terminal document looks like.

A communications document conducts a communications session between you 
and an online information service or another computer. Depending on the service 
you choose, you can join online discussion groups, look up business or technical 
topics, send and receive electronic mail, shop, and book travel reservations.

 

Creating a New Document

 

Now that you’re familiar with the different types of documents available, you’re 
ready to practice creating a few new ones. You’ll need to know how to do this to 
work through the remainder of the tutorial.
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To create a new document:

 

1. Choose New from the File menu.

 

The New Document dialog box appears. 

 

2. Double-click the Word Processor button (you can also click the button and then click OK).

 

A new word processing document opens.

For now, don’t do anything with the document.

 

3. Again choose New from the File menu.

4. In the New Document dialog box, double-click the Graphics button.

 

A new graphics document opens on top of the word processing document. 
You can open as many documents as your computer memory accommodates.

That’s all you need to know for now about creating new documents. In each 
chapter of the tutorial you’ll repeat this process as you open and explore 
each type of ClarisWorks document.

 

Closing the Practice Documents

 

You’re near the end of chapter 2, so you can now close the Smplobjs.cwk 
document, any other documents you created, and the help system.
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To close the practice documents:

 

1. Make sure the document is active (the title bar is not dimmed).

2. Choose Close from the File menu.    

 

If you’ve made any changes, ClarisWorks asks if you want to save them.

 

◆

 

Tip

 

You can also double-click the Control-menu box of the top-most 
document to close it.

 

3. If you see the Save Changes message, click No.

 

ClarisWorks closes the top document. You’ll learn to name and save your 
documents in the next session of the tutorial.

 

4. Close all the documents the same way, until only the ClarisWorks application window is left 
on the screen.

 

Documents from other applications can remain open.

 

5. If you plan to go immediately to chapter 3, skip the next step.

6. Press Ctrl+Q.

 

You exit from ClarisWorks and return to the Windows desktop.

 

Wrapping Up Chapter 2

 

You’ve now explored some basic ClarisWorks activities and concepts. You’ve 
opened and closed a document, reviewed the help system, drawn a few objects, 
changed the view of a document, and learned to create new documents. 

What’s nice about ClarisWorks is that you can apply the concepts explored in 
this chapter to different types of documents. 

If you’re ready for a break, this is a good spot for one. If not, go on to 
chapter 3 now.

 

Control-menu box
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Writing a Trip Report

 

This chapter of the tutorial introduces you to ClarisWorks word processing 
(text) documents. 

In this chapter you’ll learn how to:

 

■

 

open a text document and write a report

 

■

 

revise the text you write and change the text format

 

■

 

insert a picture

 

■

 

add footnotes

 

■

 

check spelling

 

■

 

save and close a document
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Starting the Report

 

In this session of the tutorial, John Jones, a Pegasus Books International sales 
representative, is writing a trip report. John decides to use a word processing 
document for his report, because the report will contain mostly text. Each step 
in the tutorial provides information for the report.

 

◆

 

Important

 

In this session and throughout the tutorial, you can follow the 
examples or get right to work on your own documents. If you decide to 
create your own documents, use the examples as guidelines.

To start the report:

 

1. Start ClarisWorks, if necessary.

2. Create a new word processing document (see “Creating a New Document” in chapter 2 
for details).

 

In the title bar of the new document, you see the name “Untitl1.CWK 
(WP).” The .CWK extension identifies the file as a ClarisWorks document. 
The 

 

WP

 

 stands for word processing. For brevity, a word processing 
document is referred to as a text document.

Later in this chapter, you’ll give the document a different name. 

 

Working with a New Page

 

At the top of the new page you should see the text ruler (see page 3-4). You 
can ignore the ruler for now and simply focus on writing, which you’ll begin 
in a moment. 
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Notice the vertical bar, the 

 

text insertion point,

 

 blinking in the upper-left 
corner of the page. To its left, and above it, you see light gray lines. These are 
the 

 

page guides,

 

 which indicate the boundaries of a text page. The 

 

I-beam 
pointer

 

 moves when you move the mouse. After you’ve typed some text, 
you’ll use the I-beam pointer to set the insertion point somewhere else.

 

Writing in the Document

 

To write in the document, type a few lines of text, but don’t press the Enter key 
at the end of a line. (You can use John Jones’s report, which follows, or start 
working on your own report.)

The insertion point moves to the right as you type. When you reach the right 
margin, the next word you type automatically moves down to a new line, in a 
process called 

 

word wrap. 

 

John’s First Paragraph

 

This year’s New York Book Sales Fair turned out to be a good 

choice for promoting sales of franchise stores. To 

summarize, I have seven (yes, 7!) potential franchisees 

ready to come to London for serious screening and 

qualification interviews. That doesn’t count six others who 

were interested but clearly classifiable as dreamers, not 

entrepreneurs.

 

I-beam pointer (moves with 
the mouse)

Page guides

Left margin
Text insertion point (blinking)

Ruler
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Correcting Errors as You Type

 

To correct the errors you make as you type:

 

■

 

Press Backspace to back up over the error, and retype the word or words.

 

■

 

Press Delete to erase characters to the right of the blinking insertion point.

Backspace and Delete are repeating keys. You can hold them down to 
remove characters continuously.

 

Adding More Text

 

To add more text, type another paragraph (again, use John Jones’s words if you 
wish). First, start a new paragraph and insert a line of space by pressing the 
Enter key twice. The text insertion point moves down two lines and blinks.

 

John’s Second Paragraph

 

Margo Real has six good leads as well, but she will brief 

you in her report. There is certainly a lively interest in 

new businesses. The big U.S. chains are here, but I think 

we provoked interest because of our sliding fee structure 

for franchisees.

 

The report should now look something like this. 

 

Revising as You Write

 

John notices a typing mistake in his report. He could correct it later when he 
checks the spelling but decides to fix the error now.   
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To correct an error after you’ve typed more text:

 

1. Use the mouse to move the I-beam pointer to a position just to the right of the error and 
click once.

 

The text insertion point starts blinking where you clicked. If you don’t get 
it in exactly the right place, move the I-beam pointer and click again. (If 
your typing was perfect, with no mistakes, practice moving the insertion 
point to correct future errors.)

 

2. Press Backspace to erase the error, and retype the letter. 

 

Selecting and Deleting Text

 

To select text, move the insertion point to the beginning of the text and drag 
through the words. ClarisWorks highlights the text to show that it’s selected.

When text is selected you can change or move it. You can now delete the text 
by pressing the Backspace key, or deselect the text by clicking somewhere else 
or selecting different text.

 

Changing the Type Style

 

You can change the type style, font, and size of something you’ve written. To 
change the type style, select the text and choose a style, such as Italic, from 
the Style menu. The text changes to the style you chose. You can change the 
font and size while the text is still selected by choosing from the Font and 
Size menus.

 

 

Text insertion point placed Correction

 

Selected text Changed to italic style
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Adding New Information

 

After typing the first two paragraphs, John realizes that he needs to address
his report.

To insert more text above what you’ve already typed:

 

1. Click to the immediate left of the first character in the report.

 

The insertion point moves to that spot.

 

2. Type the additional text, pressing Enter at the end of each line.

 

The rest of the text moves downward automatically. You can add line 
spaces by pressing Enter.

 

John’s Address Lines

 

Madeleine Gifford, Vice President for Sales

Pegasus Books International

22436 Sudcliffe Lane

London E1 9LD

 

You can use the same process to insert additional text anywhere in a 
text document.

 

Writing Columnar Text

 

To impress the home office, John decides to add some details on the prospects 
he’s writing about. To do this, he types a small table and then edits it to make 
it look professional.

To create columnar text:

 

1. Move the insertion point to the end of the text and press Enter twice to insert a blank line.

2. Type “Prospect” and press Tab three times.

 

Pressing Tab inserts an invisible tab character in the text. As you press Tab, 
you notice that the text insertion point stops every half-inch. The ruler is 
preset with tabs every half-inch.

You can remove a tab just as easily as you entered them by pressing the 
Backspace key. See the steps for removing a tab on page 3-8.
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3. Type “Company” and press Enter twice to add a blank line and begin a new line.

4. Type the first prospect and press Tab until the insertion point lines up under “Company.”

5. Type the company name and press Enter. Continue typing the prospect and company names 
in columns.

 

John’s Table

 

Prospect Company

Sylvia Waler Waler Books

Mary Doe Doe Unltd.

Walker Smith Smith Books

Talia Bacherro Talia Books

Marsh Rockworth JRJ Design

Ted Uyeda National Art

Maurice Rivera Epp Book Co.

 

To make the top line bold:

 

1. Drag the pointer across the line to select it and choose Bold from the Style menu.

 

You can also triple-click the line to select it.

 

2. Choose Bold from the Style menu.

 

To remove a tab:

 

1. Move the I-beam pointer to the left of a word in the second column and click.

2. Press Backspace.

 

The word moves one tab position to the left. Press Tab again to move it 
back in line with the column. 
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Moving Text Around

 

After rereading the trip report, John decides to move a paragraph from above 
the table to below it. 

To move text:

 

1. Select the text (a line, a paragraph, or several paragraphs) you want to move.

2. Choose Cut from the Edit menu or press Ctrl+X.

 

The text is removed and a copy is placed on the Clipboard, a temporary 
storage place in the computer. The copy stays there until you cut (or copy) 
something else, or until you shut down the computer.

 

3. Place the insertion point where you want the text to go, pressing Enter to create a new line.

4. Choose Paste from the Edit menu.

 

The copy is pasted from the Clipboard into the new spot.

 

◆

 

Copying

 

You use the same technique to copy and paste text that you use to 
cut and paste text. When you copy, the original text stays where it is, and a 
copy goes on the Clipboard. You can paste the copy elsewhere or in 
another document.

 

This paragraph ...

will go here.
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Changing the Indentation

 

John decides to change the indentation of the table to give it more emphasis. 
Two indent markers on the left side of the ruler control 

 

indentation

 

, the 
distance of text from the page guide.   

To change the indentation:

 

1. Select the paragraphs whose indentation you want to change.

 

John selects the whole table.

 

2. Drag the left indent marker to the right.

 

The left indent of the selected paragraph changes as you drag.

When you dragged the indent marker, you probably noticed that both 
indent markers moved. You can separate the two markers to change only 
the first line in a paragraph.

 

Left indent marker
First-line indent 

 

Text aligns with new position 
of left indent marker

These paragraphs were 



 

Writing a Trip Report

 

3-11

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

To change the indentation of the first line:

 

1. Select the paragraphs you want to change.

 

John selects the first paragraph.

 

2. Drag the first-line indent marker, shown on page 3-10, toward the right.

 

The first line of the paragraph indents to match the new ruler setting. Be 
sure the left indent marker doesn’t move.

You can also change the right indent—the distance from the page guide of 
the text on the right margin.

To change the right indentation:

 

1. Select the paragraphs you want to change.

 

John selects the first paragraph.

 

2. Drag the right indent marker toward the left. 

 

The text lines are shortened to match the new ruler setting. If you don’t see 
the marker, use the horizontal scroll bar to bring it into view.

 

Inserting a Picture

 

John’s trip report looks fairly dull, so he decides to insert the Pegasus logo at 
the top of the page. He has a copy of the logo in a graphics document. 

 

 

Right indent marker
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To insert a picture:

 

1. Place the insertion point on the line where you want the art to go. 

 

John creates a new line at the top of the document.

 

 

2. Choose Insert from the File menu.

 

You see the Insert dialog box with a list of document names. You may need 
to change directories to find the art.

John opens the Tutorial directory.

 

Text insertion point
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3. Double-click the name of the document you want.

 

The contents of the document are placed at the insertion point. John inserts 
the art called “Pegalogo.wmf.”

Another way to add a picture is to copy the art and paste it into the 
document. Using the Insert command is much quicker.

 

Saving Your Document

 

You’re now about midway through this session of the tutorial. This is a good 
time to name and save your report. 

To name and save the practice document:

 

1. Choose Save from the File menu.

 

The Save dialog box opens.
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2. Type a name for the report in the File Name box.

 

John names his document “Trprpt3.cwk.” Be sure your file name follows 
the same format: eight characters or less, plus the .cwk file name extension. 
Case is ignored. ClarisWorks file names appear as uppercase in document 
title bars and as lowercase in windows dialog boxes, such as Open or 
Save As.

 

3. Click OK.

 

The document is saved and remains open.

 

Adding a Footnote

 

John decides he needs to add a note about one of the prospects.

To insert a footnote:

 

1. Place the insertion point just to the right of the word where you want to place the footnote.

 

Number for footnote goes here
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2. Choose Insert Footnote from the Format menu.

 

ClarisWorks inserts a number for the note and moves the insertion point 
immediately to the bottom of the page. The number is in 

 

superscript 

 

style, 
which means it’s raised above the main line of text.

 

3. Type the text of the note.

4. Click anywhere in the main text or press Enter on the numeric keypad.

 

The insertion point returns to the main text. You can continue adding notes, 
either as you type or as afterthoughts. The notes are numbered sequentially 
from 1.

 

◆

 

Different starting number

 

You can change the starting number for footnotes. 
For information, see “Customizing Your Documents” in chapter 2 of the 

 

ClarisWorks Handbook

 

 after you finish the tutorial.

 

◆

 

Deleting a footnote

 

To delete a footnote, select the note number within the 
document (not in the footnote panel), and press Backspace or Delete. 

 

ClarisWorks inserts the number ...

and moves the insertion point 
to the footnote.
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ClarisWorks deletes the note and its number and renumbers any 
remaining footnotes.

 

Adding a Footer and Date

 

The trip report looks good now, but John wants to add a few finishing touches. 
He wants to add a 

 

footer

 

—a repeating element that appears at the bottom of 
every page. If he wanted to, John could also add a 

 

header

 

 to repeat at the top 
of the page.

To add a footer:

 

1. Choose Insert Footer from the Format menu.

 

ClarisWorks immediately creates a footer box and drops the insertion point 
into the box.

 

2. Type the contents of the footer.

 

John’s Footer

 

Trip

 

 

 

Report

 

 

 

(New

 

 

 

York)

 

3. Type a few spaces, and choose Insert Date from the Edit menu.

 

The date is added automatically to the footer. The date changes 
automatically when you open the document on a different day. 

 

4. To leave the footer, click anywhere in the body of the document or press Enter on the 
numeric keypad.

 

If you want to create a header at the top of the page, use the Insert Header 
command, just as you used the Insert Footer command in step 1.

 

◆

 

Page numbers and times

 

Use the same method described for inserting a date 
to insert automatic page numbers and times. If you don’t want page 
numbers, dates, and times to be updated automatically, type the information 
rather than inserting it.
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Checking the Spelling

 

The last step John takes is to check the spelling in the trip report. The spelling 
checker checks the whole report, including the footer. If you don’t see the 
Spelling dialog box, you may not have installed the spelling-checker 
dictionaries. See chapter 1 for installation information.

To check spelling:

 

1. Choose Check Document from the Spelling submenu in the Edit menu.

 

The Spelling dialog box opens, showing the number of words checked so 
far and the first questionable word. The questionable word is selected. 

 

2. Click the chevron to open the context box.

 

The context box shows the words before and after a questionable word.

 

3. Click a suggested replacement or type the correct spelling in the Word box and click Replace.

 

ClarisWorks inserts the correction and continues the check. If one of the 
suggested replacements is correct, you can use the keyboard command 
shown to the left of the word.

In the example, you would press Alt+1 to replace “screning” 
with “screening.”

 

Possible replacements for 
selected word (keyboard 
shortcuts on the left)

Context box is open 
when chevron points up
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To use other options:

 

1. Click Check to search again for suggested replacements.

2. Click Skip if the word is spelled the way you want it.

3. Click Learn to add the term to a user dictionary. 

 

For detailed information on dictionaries, see the 

 

ClarisWorks Handbook 

 

after you’ve finished the tutorial.

When the spelling check is complete, the Replace button in the dialog box 
changes to Done.

To close the Spelling dialog box, click Done or Cancel.

 

Closing the Report

 

You’re now near the end of chapter 3 of the tutorial. In chapter 4, you’ll be 
working with a different document, so you need to save and close the trip report 
(or continue writing your own report).

To close the document:

 

1. Choose Close from the File menu.

 

If you haven’t saved changes, an alert box appears, asking if you want to 
save changes.

 

2. Click Cancel if you want to do more work in this document.

3. Click Yes if you want to save your work or No if you don’t.

 

The document closes.

 

Click chevron to close context box

 

There were numerous 
questionable words because 
of all the proper names.
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Wrapping Up Chapter 3

 

You’ve now explored some basic word processing skills. You’ve written a 
memo, changed the appearance and format of text, added a footnote and a 
picture, checked the spelling, and named and saved a document. 

In the next chapter, you’ll work with a graphics document to create a business 
or personal letterhead. If you’re ready for a break, this is a good spot for one. 
If not, go on to chapter 4 now.
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Chapter 

 

4 4

 

Creating a Letterhead

 

This chapter of the tutorial introduces you to ClarisWorks graphics documents. 

In this chapter you’ll learn how to:

 

■

 

work with ClarisWorks graphics tools and rulers

 

■

 

add color to objects you create

 

■

 

import pictures

 

■

 

transfer the letterhead design to a text document and save the document 
as stationery 

 

Starting the Letterhead

 

Margo Real is responsible for corporate communications at Pegasus Books 
International. She is preparing a mailing to franchise managers and wants to 
design special letterhead stationery for the job. She’ll then pass along a copy of 
the stationery to the managers for use in their own local mailings. 
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Follow along now as Margo develops the new letterhead. As you work through 
the tutorial, you can start work on your own graphics document or use the 
examples and sample art provided for the tutorial.

 

.

 

To start the letterhead, open a new graphics document. (You learned how 
to open a new document in chapter 2.) 

In the title bar of the new document, you see the name “Untitl1.CWK (GR).” 
The 

 

GR 

 

stands for graphics. You can rename the document when you save it.

The document resembles the sample you opened in chapter 2, except this one 
contains no objects in the drawing area. Notice the dotted lines that crisscross 
the document. These are the graphics 

 

gridlines

 

. You use them to align and size 
objects as you draw. Gridlines don’t print.

 

Setting Up the Rulers

 

Margo’s letterhead will be used in countries where the metric system is standard, 
so she decides to change the unit of measure for the ruler, and thereby change the 
spacing of the gridlines, to centimeters.

 

Graphics menus

Gridlines

Drawing area

Title bar
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.

 

To show the graphics rulers, choose Show Rulers from the Window menu.

At the top and left side of the document you now see the 

 

graphics rulers

 

. 
The rulers are preset to measure in inches, and the gridlines are spaced in 
intervals of 1 inch.

To change ruler settings:

 

1. Choose Rulers from the Format menu.

 

The Rulers dialog box appears. ClarisWorks documents use two rulers: one 
for text formatting and one for the graphics grid/autogrid. For now, you’ll 
change only the graphics ruler.

 

Graphics rulers, in inches
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2. Click Graphics. 

3. Under Units, click Centimeters.

4. In the Divisions text field, type “10.”

 

The ruler is preset for eight 

 

divisions

 

 per inch. Because the metric system 
uses ten divisions, you need to revise the number of divisions. This change 
affects the invisible grid/autogrid, which you’ll learn about later.

 

5. Click OK.

 

The rulers now measure in centimeters, and the gridlines correspond to the 
new unit of measure.

 

Starting the Artwork

 

Margo starts the artwork with a horizontal line to set off the letterhead on the 
top of the page. This illustration gives you an idea of where Margo is headed.

To draw a precise line:

 

1. Click the line tool and move the pointer into the drawing area.

 

The pointer becomes a fine crosshair.

 

2. Hold down the Shift key as you drag the crosshair to draw a line across the page.

 

Holding down the Shift key allows you to draw the line evenly in a 
horizontal or vertical direction or at a 45-degree angle.
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To make your line look like this example, start the line at a point 3 
centimeters down from the top margin of the page and 2 centimeters from 
the left. End the line at 16 centimeters. 

When you finish the line, handles appear at each end, indicating that the 
line is selected.

 

Changing Pen Width and Color

 

Margo decides she wants a thicker line, and she wants to make the line red.

To change pen width:

 

1. Make sure the line is still selected; if it isn’t, click the line to make the handles appear.

2. Choose a different width from the pen width tear-off menu.

 

Selected line

 

Pen width tear-off menu

Selected line width
Pen width tool
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As soon as you release the mouse button, the line widens.

Use the same method to change the pen width for any other object 
you draw.

 

3. While the line is still selected, choose red (or a different color) from the pen color palette.

 

◆

 

About color

 

Your color palette may look different from the one shown. On 
a grayscale monitor, the palette displays squares for each color, but the 
colors appear as shades of gray. On a black-and-white monitor, colors are 
listed by name in the palette. Depending on the color chosen, some appear 
black; others, white.

 

Pen color tool

Pen color palette
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Saving as You Work

 

It’s always a good idea to save a document as you go along. If you have an 
unexpected occurrence or a power failure, you won’t lose your work.

To save the letterhead:

 

1. Choose Save from the File menu.

 

You see the Save dialog box, as described in chapter 3.

 

2. Type a name for the document and click OK. 

 

The document is saved and left open.

 

 

 

◆

 

Use the ClarisWorks file name extension

 

When naming your document, 
be sure to add the .cwk extension so that ClarisWorks identifies your 
document as one that it can open.

 

Adding the Company Name

 

After saving her earlier work, Margo is ready to add the company name. If 
you’re creating a personal letterhead, you can use your name where Margo puts 
the company name.
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To add text:

 

1. Click the text tool.

2. Click in the document and type the name you want to use.

 

Margo types:

 

Pegasus Books International

 

When you start to type, an object is created to hold the text. 

The Pegasus line is long, so the last word wraps onto a new line. You’ll 
reshape the object after you change the font and font size.

 

Changing the Look of the Name

 

The company name looks too small for this part of the letterhead, so Margo 
decides to change the way the name looks. She’ll change the font, size, and 
style of the type. 

 

Text tool
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A

 

 font 

 

is a complete set of type (letters, numbers, and symbols) of one size and 
appearance. The preset font is Arial, which is what you see in the illustration 
for step 1. A 

 

font style

 

 modifies the basic appearance of the characters in a font. 
For example, a font can be styled as italic (slanting), bold (darker), or 
underline. 

The 

 

font size

 

 is simply a measure of how tall and wide the letters are. Font sizes 
are measured in typographic units called 

 

points.

 

 There are 72 points in an inch.

To change the font and size of text:

 

1. Click the graphics tool, if not already selected, and then click the object that contains the text. 

2. Choose a new font and size from the Format menu.

 

Margo chooses Times New Roman for the font and 36 points for the size, 
as shown here.
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To change the shape of the object so the text fits correctly:

 

1. Click the graphics tool and the object, if necessary.

2. Drag a handle to change the size and shape.

 

When you release the mouse button, you see the object in its new shape 
(see step 3).

 

3. Move the object above the line you drew.

 

To change the color of the selected text:

 

1. Select the object that contains the text, and choose Text Color from the Format menu.

 

You see a color palette attached to the Text Color command. The palette is 
similar to the one you use to change pen color, but this palette is attached 
to a menu instead of being part of the tool palette.

 

2. Click a color in the palette.

 

On a grayscale monitor, you can choose a shade of gray, if you wish. On a 
black-and-white monitor, you can choose a color by name.

 

 

Dashed line shows new size as 
you drag
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Margo chooses the same red she used for the horizontal line.

 

Adding the Company Logo

 

Margo is now ready to add the company’s logo—a graphic design that 
symbolizes the company. The art Margo wants to use is located in the Tutorial 
directory. You can use that art if you wish. If you’re working on personal 
letterhead, you can use art from another source.

 

◆

 

Inserting versus copying and pasting art

 

As you learned in chapter 3, you can 
save time by using the Insert command instead of copying and pasting. But 
copying and pasting is handy when you want to modify the art before 
copying it into your document.

 Art from other sources should be saved in a format like PCX or TIFF if you 
want to insert it in a ClarisWorks document. 

In chapter 3, you learned to copy and paste text. Copying and pasting graphics 
works the same way.

To add art:

 

1. Choose Open from the File menu.

 

The Open dialog box (shown in step 5) appears. You may need to change 
directories to find the Tutorial directory.

 

2. Click the import options chevron to display the types of import translators.

3. Click the Graphics radio button.

4. Choose Windows MetaFile from the List Files of Type box.

 

The list of available documents changes to show only .wmf files.
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5. Click the Pegasart.wmf document name and click OK.

 

The graphics document opens. 

 

6. If not already selected, click the logo art to select it.

7. Choose Copy from the Edit menu or press Ctrl+C.

8. Close the Pegasart.wmf document.
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9. Click in the letterhead document, and choose Paste from the Edit menu or press Ctrl+V.

 

ClarisWorks pastes the art and leaves the object selected. Clicking in the 
document establishes the paste point. 

 

Scaling the Art

 

The art is too big for the letterhead, so Margo decides to rescale the picture by 
60 percent. She could simply resize the object by dragging the handles, but she 
wants to get a more accurate reduction. Changing the size by dragging distorts 
pictures like the one in the Pegasart.wmf document, though it’s fine for simple 
graphics like rectangles and ovals. Using Scale Selection resizes an object in 
exact proportions.

To rescale the art proportionally:

 

1. While the object is still selected, choose Scale Selection from the Options menu.

 

The Scale Selection dialog box appears. The percentage of scaling is preset 
at 50% for both vertical and horizontal dimensions.
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2. Type a percentage in each box.

 

Percentages below 100 reduce the object, and percentages above 100 
enlarge it.

 

3. Click OK.

 

The object is scaled as you specified.

 

Practice Moves

 

Margo now rearranges the letterhead to achieve the effect shown here. Try 
moving your art into similar positions. You can drag a selected object out of the 
way while you move another, and then place the object where you want it.

 

Adding More Text

 

Now Margo is ready to add the address lines to the letterhead. She wants to be 
able to move the address lines around as she designs, so she creates new text in 
a new, independent object.

 

Identical percentages scale 
both dimensions.
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To add more text:

 

1. Click the text tool and click anywhere in the top portion of the page.

 

If you click inside the existing text, you’ll see the insertion point blinking 
next to the text enclosed in a box. In this step, though, you want to create a 
new object for the address text. Try again, clicking outside any existing 
text. You should see a new box and the blinking insertion point.

 

2. Type the address lines.

 

Margo types:

 

22436 Sudcliffe Lane

London E1 9LD

 

When you’ve finished the new text, select the graphics tool and object, just 
as you did earlier, and move the text into place in the letterhead. You may 
also need to drag a handle, as you did earlier, to stretch the text over two lines.

Here is Margo’s letterhead, now nearly complete.

 

Moving Objects Freely

 

Margo now wants to move the logo art a little to the right. She drags it toward 
the right, but it refuses to stay where she wants it.

What’s holding the object is the graphics 

 

autogrid, 

 

which automatically 
“attracts” objects and keeps them with the grid. For precise work, you can work 
with the autogrid off.

 

.

 

To turn off the autogrid, choose Turn Autogrid Off from the Options menu.

Now when you move an object, it no longer snaps into place along the 
invisible gridlines. You can move things exactly where you want them.
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Working in a Different View

 

Sometimes when you work with graphics documents you need to get an 
overview of the whole document. You can do that by zooming out from the 
picture. To work with details, you need the reverse effect—enlargement—
accomplished by zooming in on the picture.

Use the zoom controls, shown here, to change your perspective of the 
document: 

 

■

 

To reduce the size of the document, click the zoom-out control.

As you learned in chapter 2, the view is reduced each time you click the 
zoom-out control. 

 

■

 

To enlarge the size of the document, click the zoom-in control.

 

■

 

To return the view to 100 percent, click the zoom percentage box.

 

Practice Moves

 

Try moving a few objects around and then switching back to a 100% (full-size) 
view. You can see that anything you move in the reduced view stays in the new 
location in the full-size view.

 

Zoom-in control

Zoom percentage box
Zoom-out control
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Grouping All the Objects

 

You’re almost ready to move the letterhead to a text document, where you’ll 
save the text document as ClarisWorks stationery for use later. You can move 
the letterhead as one piece of art by grouping all its elements into a single object.

To group objects:

 

1. Choose Select All from the Edit menu.

 

Handles appear on all the objects you’ve created.

 

2. Choose Group from the Arrange menu.

 

The multiple objects become a single object. 

Later, if you want to revert to the individual objects to make changes, 
you can choose the reverse command, Ungroup. 

 

Using the Letterhead for Stationery

 

Margo is now ready to move the letterhead into a text document and save the 
document as stationery. Stationery can be used again and again as a basis for 
new documents.

To move the letterhead:

 

1. If necessary, select the grouped object.

2. Choose Copy from the Edit menu.

 

A copy of the letterhead is placed on the Clipboard.
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3. Open a new word processing document (for a review, see chapter 2).

 

When the document opens, you see the text insertion point blinking at 
the top left.

 

4. Choose Paste from the Edit menu.

 

The object is pasted at the location of the insertion point. You see the 
insertion point blinking at the right side of the art.

 

5 Press Enter to move the insertion point down one line.

 

Text insertion point 
after you press Return

Word processing 
document
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To save the document as stationery

 

1. Choose Save As from the File menu.

2. The Save As dialog box opens.

2. Choose ClarisWorks Stationery from the List Files of Type list box.

3. Name the stationery and click OK.

 

Margo names her stationery “Pegassta.cws.” Your file name must 
include the .cws extension so that ClarisWorks recognizes the file as 
a stationery document.

The text document with letterhead is now ready to use for memos and 
letters. For information on using stationery documents, see the 

 

ClarisWorks 
Handbook

 

 after you finish the tutorial.

 

Wrapping Up Chapter 4

 

You’ve now gained some basic graphics skills. You’ve drawn graphic objects 
and added text, changed the ruler settings, and inserted a picture 
from another source. 

In the next chapter, you’ll work with a spreadsheet document to create an 
expense report. If you’re ready for a break, this is a good spot for one. If not, 
go on to chapter 5 now.

 

Click to open the List Files of 
Type list box.
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5

 

Tracking Numbers

 

This chapter of the tutorial uses a financial report to introduce you to 
ClarisWorks spreadsheet documents.

In this chapter you’ll learn how to:

 

■

 

set up a spreadsheet

 

■

 

enter data and formulas

 

■

 

change the way data looks

 

■

 

transform numbers into charts
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Starting the Report

 

Travis McLellan manages the Pegasus Books International accounting office 
and is about to set up a quarterly report in ClarisWorks. Travis chooses a 
spreadsheet document for the report because he wants to do some calculations 
and then convert the numbers into a chart. 

As in other tutorial chapters, you can use Travis’s information or start work on 
your own project as you learn.

 

.

 

To start the report, open a new spreadsheet document. (If you need a 
refresher, see chapter 2.)

In the title bar of the new document, you see the name “Untitl1.CWK (SS).” 
The 

 

SS 

 

stands for spreadsheet. You can rename the document when you save it.

You immediately see that a grid of columns and rows is already set up . A new 
spreadsheet document is like a blank columnar pad—the type of pad used by 
accountants and scorekeepers.

 

Active (selected) cell

Title bar

Work area

 

Spreadsheet 
menus
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Understanding Data Entry

 

The boxes formed where columns intersect rows are 

 

cells

 

—the working 
elements in a spreadsheet where you enter numbers (data) and formulas. You 
can also use cells for text (another type of data). 

This illustration shows a selected cell, surrounded by a heavy border. A cell 
must be selected before you can type data, but you don’t type directly in the 
cell. Instead, you use the data entry bar. 

In chapter 2, you typed some text in an object that contained a small 
spreadsheet. Typing data in a full spreadsheet works the same way. You see 
what you type in the data entry bar, and then you confirm the entry so that it 
appears in the selected cell. 

Travis has the figures for quarterly sales and expenses handy, so he gets started 
by typing the row and column titles. You can use his titles for this example or 
start work on your own spreadsheet.

 

Elements of the data 
entry bar

 

Cancels an entry

Confirms an Cell address

Cell A1

What you type here ...

goes into the selected cell, here.
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To type column or row titles:

 

1. Click the appropriate cell to select it.

 

A heavy border indicates that the cell is selected. The text insertion point 
blinks in the data entry bar as soon as you start to type.

Travis selects cell B1.

Notice that the address box shows the column and row designation of the 
selected cell. Columns are identified by letters and rows, by numbers. The 
combination of column letter and row number is the 

 

cell address.

 

2. Type a text title.

 

Travis types “January” in cell B1 for the first month of the quarter. This 
gives him a title, or heading, for the column below.

Use the text editing methods you learned in chapter 3 to correct mistakes as 
you type. Nothing happens in the selected cell until you confirm the entry.

 

3. Press Tab to confirm the entry and move to the next cell on the right.

 

You can also click the check mark in the data entry bar to confirm. To 
cancel the entry, click the X in the data entry bar.

 

4. Type a few more titles.

 

Travis adds February and March as column titles.

 

Address of selected cell

Selected cell

 

What you type here goes into the 
selected cell when you confirm the entry.
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Adding a Row of Cells

 

After typing the months, Travis realizes that he’s forgotten to put in a title for 
the report, so he decides to add a row of cells.

To insert a row of cells:

 

1. Select a row of cells by clicking the row number.

2. Choose Insert Cells from the Calculate menu.

 

ClarisWorks inserts a blank row above the row you selected.

Travis adds the title for the report, “1993 First Quarter,” in cell A1, and tabs 
into cell B1. 

 

Row number

Selected row

 

 

Selecting a row

 

New row inserted

 

New blank row 
after insertion

 

 

Entry after tabbing to cell B1
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Making Room for Data

 

Travis sees that the new title is too wide for the cell, so he decides to enlarge 
column A to make room for the words.

To widen a column:

 

1. Move the pointer into the column header, and place it over the line between the columns.

 

The pointer becomes a vertical bar with arrows at each side, as shown 
in step 2.

 

2. Drag the column border to the right until the column is the width you want.

 

Typing Data

 

Travis is now ready to fill in some numbers for expenses. The numbers he uses 
are shown here (you can use your own if you’re building your own report).

When you finish entering data, you can resize columns to make room for 
whatever you type.

 

.

 

To type data, select a cell and follow the same process you used with text, 
this time entering numbers.

 

Pointer is a vertical bar with arrows

Dotted line shows new column 
width as you drag the pointer 
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To use keyboard shortcuts:

 

Changing the Look of Data

 

After typing the set of entries, Travis decides to improve the way the spreadsheet 
looks by making the title bold and by adding currency signs to the numbers.

To change the font, style, or size of text or numbers:

 

1. Select the cells whose contents you want to change.

 

Travis selects cell A1.

 

2. Choose the font, size, or style you want from the Font, Size, and Style submenus on the 
Format menu.

 

Travis chooses Bold from the Style submenu, but doesn’t change the 
font or size. 

 

Press To

 

Tab or Right Arrow Move one cell right

Shift+Tab or Left Arrow Move one cell left

Enter or Down Arrow Move one cell down

Shift+Enter or Up Arrow Move one cell up

 

Selected cell
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To change numerous cells at once:

 

1. Drag the pointer across a row or down a column to select several cells. 

 

A group of selected cells make up a 

 

cell range.

 

2. Change the font, style, or size as if you had selected a single cell.

 

Changing the Way Numbers Look

 

Travis now turns to the numbers to make changes. These are financial figures, 
so he wants to show currency signs.

To change the way numbers look:

 

1. Select a cell or range of cells you want to change.

 

A range of selected cells 

 

A range of selected numbers 
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2. Choose Number from the Format menu.

3. When the Number Format dialog box appears, click Currency and type 0 for Precision.

 

If you want to use decimal places, either leave the Precision box at 2 
(preset) or type the number of decimal places you want.

 

4. Click OK.

 

ClarisWorks now shows the numbers with currency signs. There are no 
decimal places because the precision was set at 0. 

 

Numbers in currency format
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Saving Your Work

 

You’re now about midway through this session of the tutorial. Your report 
should look something like this.

Take a moment now to name and save the spreadsheet document. Travis chose 
the name “Qrtlyrpt.cwk.” (If you need to refresh your memory on how to save 
a document, see chapter 3.)

 

Using a Formula

 

At this point you may be wondering when Travis (and this tutorial) will get 
to “real” spreadsheet work, such as adding formulas and doing calculations. 
Actually, much of what you’ve been doing is spreadsheet work: gathering 
data into categories, entering it in cells, and making it look good for the report.

Now Travis is ready to do some addition. In row 9 of the spreadsheet, he wants 
to show a total of all the expenses in the B, C, and D columns. To do this, he 
types a formula that instructs ClarisWorks to add the amounts in the columns.

To do simple addition:

 

1. Type a title for a new row.

 

Travis selects cell A9 and types “TOTAL EXPENSES.”

 

2. Select the cell where you want the formula, and its result, to go.

 

Travis selects cell B9, at the bottom of the first column of numbers.

 

Travis’s Report
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3. Type an equal sign (=) in the entry bar.

 

The equal sign signals ClarisWorks that a formula follows.

 

4. Click each cell in the column.

 

Travis clicks on cells B4 through B8.

As you click, ClarisWorks automatically enters the address of the cell 
you click and adds a plus (+) sign. You could click cells in other 
columns—anywhere in the spreadsheet—if you wanted to include 
them in the same formula.

 

5. Press Tab to confirm the formula.

 

ClarisWorks adds the numbers and shows the result in the selected cell. 

 

◆

 

Note

 

A formula can simply refer to another cell address. For example, if 
you wanted the data in cell B2 to be placed automatically in cell B9, you 
could type “= B2.”

 

Adding a column 
of numbers 

 

Addresses of cells you click

After you type the equal sign, 
click each cell individually.

Selected cell where formula goes

Cell address for formula
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Doing the Same Addition Faster

 

Travis decides that clicking cell by cell is a clumsy way to add a straight 
column of numbers. He decides to replace the addition formula with another 
one that uses a simple spreadsheet function. 

A function is a mathematical equation or formula built into ClarisWorks that 
you can use to do a specific kind of financial, mathematical, or scientific 
calculation. Many people think functions are somehow mysterious, or too 
complex to use, but the concept is straightforward: ClarisWorks supplies the 
built-in formula, and you supply the values. 

Travis replaces the formula in cell B9 using the following steps. Try working 
through the example to see how easy it is to use a spreadsheet function.

To insert a spreadsheet function into a formula:

 

1. Select the cell where you want the formula, and its result, to go.

 

Travis again selects cell B9, at the bottom of the first column of numbers.

 

2. Choose Paste Function from the Edit menu.

 

The Paste Function dialog box appears.

 

3. For this example, scroll down to the S’s, choose SUM (number1, number2,...), and click OK.

 

The SUM function does exactly what it says it does: It adds, or sums, 
numbers you supply. In parentheses, ClarisWorks indicates that SUM 
needs values to act on. In this case, the values are the range of numbers you 
want to add up. Values you supply for a function are known as 

 

arguments.

 

Selecting a function 
for a formula

 

Use the scroll bar to see 
more functions.
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4. If necessary, select everything within the parentheses, but not the parentheses themselves. 

 

In this spreadsheet example, the expressions “number 1” and “number 2” 
are sample arguments. ClarisWorks considers a cell range as a single 
argument. The cell range you’ll select in the next step substitutes for 
“number 1.” The sample argument “number 2” isn’t needed.

 

5. Drag the pointer to select the range of cells you want to add.

 

Cell addresses appear in the entry bar as you drag the pointer. Notice that 
the addresses are separated by two dots (..). The dots indicate a range of 
cells. You can type the range of cell addresses instead, but you won’t make 
a typing error if you select cells by dragging the pointer.

 

6. Press Tab or Enter to confirm the formula.

 

ClarisWorks adds the numbers and displays the result in the selected cell.

 

◆

 

For more information

 

For a listing of ClarisWorks functions, with examples, 
see Appendix A in the 

 

ClarisWorks Handbook 

 

or refer to the “Functions 
Reference” in the ClarisWorks Help system.

 

 

 

 

 

Selecting the argument 

 

Address of cell where formula goes

Cell range you select

Drag the pointer to 
select the range of cells.
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Filling in Formulas

 

Travis now wants to total the remaining columns the same way he did in the 
first column. To do this, he adds the formula for the first column to the rest of 
the columns by using a method called 

 

filling.

 

To fill cells with a formula:

 

1. Click the cell that contains the formula, and drag the pointer to the right to select 
additional cells.

2. Choose Fill Right from the Calculate menu.

 

ClarisWorks fills the selected cells with the formula and displays 
the results.

You can use the same method to fill a column downward by selecting the 
top cell in a column—the cell that contains a formula or a value you want 
to repeat—and selecting cells below it. You then choose Fill Down from 
the Calculate menu to fill all the cells with the same formula or value.

 

3. While the range is still selected, change the number format to currency, with 0 decimal 
precision, to match the other numbers.

 

Selecting cells to fill

 

The first cell contains
 the formula.

 

Results of filling right 

 

The formula has been 
filled in and calculated.
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Understanding Cell References

 

This is a good time to take a moment to examine a formula more closely. 

In “Doing the Same Thing Faster,” you learned to use a function in a formula. 
Then, in “Filling in Formulas,” you learned to fill different cells with a formula. 

The formula from cell B9 worked when you filled cells C9 and D9 with it. 
ClarisWorks automatically changes cell addresses when you paste or fill a 
formula into another cell. 

These changeable cell addresses are called 

 

relative cell references

 

.

 

 

When you really want a formula to refer to a specific cell, and you don’t want 
ClarisWorks to supply relative cell addresses, you can use a dollar sign ($) to 
indicate a specific row or column: $D$19.

 

Formula and its 
cell references 

 

Formula for cell B9

 

 

Same formula copied 
into another cell 

 

When copying a formula 
to a different column, 
ClarisWorks changes the 
corresponding cell 
references.
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Pasting a Value or Formula

 

Here’s a quick quiz for a change of pace. 

 

Question

 

When you copy a single cell that contains a formula, what do you 
copy? The formula or the result? 

 

Answer

 

Both, actually. You can select another cell and paste one or the other.

To paste a value or formula:

 

1. Select the cell you want to copy and choose Copy from the Edit menu or press Ctrl+C.

 

ClarisWorks places a copy of both formula and result on the Clipboard.

 

2. Select the cell where you want the formula or result to go.

3. Choose Paste Special from the Edit menu.

 

The Paste Special dialog box appears.

 

4. Click the option you want and click OK.

 

ClarisWorks pastes the formula or value in the selected cell. 

If you want ClarisWorks to switch rows to columns and columns to rows, 
click Transpose.
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Adding More Data

 

Travis adds a few more numbers and categories to the quarterly report, inserting 
the figures for net sales above the expense categories. He also changes some titles 
to bold, using the same methods used to change the look of text. The report now 
looks like this.

You can enter the same data or continue with your own.

 

Splitting the View

 

As Travis moves lower in the spreadsheet, he discovers that he can’t see the 
column titles. To bring the titles into view, he decides to split his view of the 
spreadsheet into 

 

panes

 

 to make data entry easier.

 

Quarterly Report
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To split the view of a spreadsheet:

 

1. Drag the horizontal pane control downward to keep column titles in view.

 

Travis uses the horizontal pane control to show the titles on the top of 
the spreadsheet.

 

2. To enter data, click a cell in either pane.

 

Each pane contains its own scroll arrows and scroll bars, so you can move 
around in either view of the spreadsheet to get titles or cells where you 
want them.

 

.

 

To return to a single view, drag the pane control upward until the top 
pane disappears.

 

Horizontal pane control ...

Column headings appear 
in the top pane.

Data lower down appears 
in the bottom pane.

 

is dragged to here.
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Practice Moves

 

Look at the lower-left corner of the spreadsheet window. You’ll see a vertical 
pane control to the left of the scroll arrow. Try splitting the window vertically 
to keep the row titles visible as you scroll to the right.

 

Creating a Chart

 

With all the data in place, you’re ready to create a chart. A chart presents a 
picture of your numbers. Comprehension is easier, and you can often spot 
trends and relationships in a chart that you can’t see in the numbers alone. 

Travis wants to get a clear idea of relative expenses in a certain month, so he 
decides to create a pie chart.

To turn numbers into a pie chart:

 

1. Select the row titles and columns of data you want to chart.

 

Travis selects the row titles and the first column of data (for January).

 

Selecting titles and data 
for a chart
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2. Choose Make Chart from the Options menu.

 

ClarisWorks opens the Make Chart dialog box. Across the top of the box you 
see icons that represent different types of charts: pie, bar, line, and scatter 
charts. ClarisWorks is preset to create a pie chart from the selected data.

 

3. Leave all the options as they are, and click OK.

 

ClarisWorks draws a pie chart and places it on top of the spreadsheet. 
Numbers from the spreadsheet—the 

 

data series

 

—make up the pie. The 
row titles from column A make up the 

 

legend

 

—the portion of the chart that 
names the pieces of the pie.

 

Setting chart options

 

A pie chart created from 
spreadsheet data

 

Legend (derived from the row 
titles in the cells you selected)

Chart (derived from the data 
in the series)
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◆

 

Something happened

 

Take a close look at the chart. ClarisWorks has put 
handles on the corners of the chart, showing that the chart is selected. Now 
take a look at the menu bar, where you can see the Arrange and Options 
menus. The chart is a graphic object, so you can now change the fill color 
or pattern, if you wish, using the methods you learned when you worked 
with a graphics document (chapter 4).

 

Practice Moves

 

If you’re feeling adventurous, try changing the fill pattern now. To bring the 
tool palette into view, choose Show Tools from the Window menu, or click the 
show/hide tools control at the bottom-left side of the window.

 

Adding Text to the Chart

 

Travis realizes that by inserting the sales figures above the expenses, the month 
names have been separated from the data in the chart. He needs to type 
“January” below the pie chart.

To add text:

 

1. Choose Show Tools from the Window menu.

 

The tool palette appears on the left side of the window.

 

2. Click the text tool, click somewhere in the chart, and type the text.

 

Travis types “January.” ClarisWorks creates an object to hold the text.

 

3. Click the graphics tool and select the new text object.

 

You can now move the text anywhere in the chart.

 

Text added to chart

 



 

Tracking Numbers

 

5-23

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

4. Hold down the Shift key as you select the text and the chart.

5. Choose Group from the Arrange menu.

 

You can now move or copy the grouped chart as one object. 

 

.

 

To return to the spreadsheet, click anywhere in the spreadsheet, outside 
the chart.

You may need to select and move the chart so that you can see different 
areas of the spreadsheet.

 

Copying and Pasting a Chart

 

Travis now wants to paste the sample chart into a text document. For purposes 
of the tutorial, you can follow along by pasting the chart into the text document 
you created in chapter 3 (a trip report or your own memo). 

 

◆

 

Tip

 

If you plan to update a chart frequently, you can create a spreadsheet 
frame in your document, paste the chart data into it, and conceal the frame 
under the chart you create. Each time you update the spreadsheet data, 
ClarisWorks updates the chart. Chapter 7 describes how to create a 
spreadsheet frame.

To copy and paste a chart:

 

1. If the chart is no longer selected, click it once.

 

If you chose not to group the text and chart in the previous section, select 
the text as well as the chart. Hold down Shift as you click the chart and then 
the text.

 

2. Choose Copy from the Edit menu.

3. Open the text document you want, and place the insertion point where you want the chart 
to go.

4. Choose Paste from the Edit menu.

 

When you paste the chart, you break its link to the spreadsheet data. To 
revise a pasted chart, you must return to the spreadsheet document and 
revise the data, which simultaneously updates the chart. You can then copy 
the updated chart and paste it into your text document.
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Wrapping Up Chapter 5

 

You’ve now explored a ClarisWorks spreadsheet document. You’ve built a 
financial report, created a formula, changed the way the spreadsheet looks, and 
created a chart from the numbers.

In the next chapter, you’ll work with a database document to create an invoice 
and mailing list. If you’re ready for a break, this is a good spot for one. If not, 
go on to chapter 6 now.
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Managing Information

 

This chapter of the tutorial uses an invoice record to introduce you to 
ClarisWorks database documents.

In this chapter you’ll learn how to:

 

■

 

create and define database fields

 

■

 

create new records and layouts

 

■

 

find and sort records

 

■

 

add a graphic to a report
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Starting the Invoice

 

Mary Whittington manages the Pegasus Books International telephone sales 
office. She is about to use a ClarisWorks database to set up an invoice system 
for telephone salespeople.

Follow along as Mary creates the new system. As in other tutorial sessions, you 
can use Mary’s information or start work on your own project as you learn.

 

.

 

To create the invoice, open a new database document (see chapter 2 for 
details on opening a new document).

When the document opens, you see the Define Fields dialog box shown here. 
Above the box is the name “Untitl1.CWK (DB).” The number increases as 
you open other documents during a session. The 

 

DB 

 

stands for database, a 
ClarisWorks document type. You can rename the document when you save it.

 

Work area (temporarily 
hidden by the dialog box)

Define Fields dialog box



 

6-4

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

Setting Up Fields

 

The information you collect in a database is stored in fields. A 

 

field

 

 represents 
a category of data. The fields Mary sets up hold the categories of information 
her salespeople fill in to make a sale. The process of setting up fields to hold 
information is called “defining a field.”

Different field types hold different types of information, such as text, numbers, 
dates, and times. The

 

 field type

 

 determines what kind of data you can enter and 
what kind of work you can do with the data.

Here is a list of the fields Mary plans to create:

 

◆

 

Note

 

If you plan to use your database for personalized mailings, you’ll 
want to create separate fields for first name and last name. That way, you 
can address letters or sort using either name.

 

Field Name Holds Field Type

 

Sold To Customer Name Text

Street Address Text

City City Text

State State Text

Postal Postal Code Text

Invoice No. Sequential Number Number

Date Date of Sale Date

Item Name of Item Text

Price Price per Unit Number

Quantity Number Sold Number

Total Total Sale Number

Sales Rep Salesperson’s Name Text
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To define a field:

 

1. Type a field name in the name box (see step 2).

2. Click a field type.

 

Sometimes assigning a text field type to a number field makes sense. For 
example, Mary chooses a text field type for the Postal field. She wants to 
sort addresses by postal code number, but if she makes the field a number 
field, ClarisWorks drops any leading zeroes in the code. As text, the codes 
are sorted properly and retain any leading zeroes.

 

3. Click Create.

 

ClarisWorks shows the field name and type in the list box. You can type the 
next field name while the previous one is still selected in the Name box.

 

Type a name ...

and click a field type.

List box
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4. Define the rest of the fields you want, following steps 1 through 3.

 

Mary’s Define Fields dialog box now looks like this.

 

5. When you’re finished, click Done.

 

The dialog box closes, and you see a new database record with all the new 
fields stacked vertically, in the order you created them. Field names—the 

 

field labels

 

—are to the left of the empty fields.

The screen should look similar to this.

 

 

 

Scroll to see the 
other fields.New fields

 

A new database record

 

Database book

Field labels
Empty fields

Database menus
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Take a closer look at the new record. The field at the top is already active. You 
can see the text insertion point blinking in the field. 

A field must be active before you can type data. As with a text paragraph, 
the presence of the insertion point indicates that you can type data. Also, 
ClarisWorks surrounds the active field with a solid border.

You’re almost ready to start entering data. Before you start, take a moment to 
see how you add records and navigate through them.

 

Adding More Records

 

ClarisWorks automatically creates the first record in a database. After that, you 
can create as many records as you need up to approximately 30,000 (or as many 
as memory allows).

 

.

 

To add a new record, press Ctrl+R (or choose New Record from the 
Edit menu).

Do this now to create a new, blank record. Notice that the database book on 
the left now shows the number 

 

2

 

, which corresponds to the active record. 

 

Selected field

Text insertion point

 

 

Database book

Status panel

Record number
Bookmark
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Use the 

 

database book 

 

to move through records. Click the pages of the book 
to move one record at a time, or drag the bookmark to move quickly to different 
areas of the database. The 

 

status panel

 

 below the book shows the number of 
records in the database and the sort and find status of those records (you’ll learn 
more about those topics later in this session).

 

.

 

To return to the first record, click the top page of the database book.

ClarisWorks switches you back to record 1.

 

Typing Data

 

You type entries in a database the same way you type ordinary text. After 
typing data in a field, use the Tab key to move from field to field. 

 

.

 

To activate a field, click anywhere in the field.

Did the entire record become highlighted? If so, you clicked somewhere 
outside a field and selected the whole record without activating the field. 
You must click within the field borders. Click outside the record and try 
again, or press the Tab key.

To type data:

 

1. Type an entry in the active field.

 

Use the text editing methods you learned in chapter 3 to correct mistakes as 
you type.

 

2. Press Tab.

 

The insertion point moves down to the next field. 
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3. Complete all the fields in the record.

 

When you press Tab after the final field, the insertion point returns to the 
first field, which is already filled.

Here is Mary’s first complete record.

 

4. Click in the first field of the second record and start adding entries.

 

If you’re following Mary’s example, see page 6-10.

 

.

 

To add more records, press Ctrl+R.

Keep adding records, filling them in as you go, until you have six records.
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Here are Mary’s first six records. You can use the data shown here if you’re not 
working on a project of your own. You don’t have to fill in all the fields on each 
record now; you can leave them blank or come back later. 

 

Information in Mary’s 
records
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Using a Formula

 

Mary realizes that ClarisWorks could be doing some of her arithmetic. She has 
been multiplying the amount in the Price field by the number in the Quantity 
field to arrive at a total amount. She decides to modify the Total field and let a 
formula do the multiplication for her.

If you’re creating your own database, try creating a new calculation field (using 
the steps shown in this section). If you’re following the example, you’ll need 
to modify a field definition you created earlier.

To create a calculation field:

 

1. Choose Define Fields from the Layout menu.

 

The Define Fields dialog box opens.

 

2. If you’re modifying an existing field, select the field name, click Calculation as the field type, 
and click Modify. 

 

Mary modifies a calculation field called “Total.”

As soon as you click Modify, an alert warns you that any data that cannot 
be converted to the new field type will be lost. For this example, click OK.

The Enter Formula dialog box appears (see step 4).

 

3. If you’re creating a new field, type the new name, click Calculation as the field type, and 
click Create.

 

As soon as you click Create, the Enter Formula dialog box appears (see 
step 4).
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4. Click field names and operators to enter a formula.

 

Use the scroll bar to view all the fields names. You can type the field names, 
but you must enclose each name in single quotes, and you must 
be exact (clicking field names saves you from typing errors).

Mary’s formula for the Total field multiples the amount in the Price field 
by the amount in the Quantity field.

 

5. After entering the formula, click OK to return to the Define Fields dialog box.

 

In the dialog box, you now see the formula in the list to the right of the 
field names.

 

6. Click Done to return to the document.

 

If you modified a field, ClarisWorks replaces the hand-calculated values 
with the results of the formula in all the records.

Now, when you enter a price and quantity, ClarisWorks automatically 
supplies the total amount when the two entries are confirmed.

 

◆

 

For more information

 

This part of the tutorial has given you only a brief 
introduction to database calculations. For details, see chapter 6 in the 

 

ClarisWorks Handbook.

 

 

Enter formula here
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Finding Certain Records

 

Now that your database contains a few records, you’re ready to explore one of 
the most important reasons for using a database: the ability to find information 
when you need it.

One of the salespeople tells Mary that a recent steady seller has been a high-
priced encyclopedia. Mary wants to make sure that stores ordering this item 
get a sales follow-up call. She needs to find all the invoices that contain an 
order for the encyclopedia. 

Up to now in the tutorial, you’ve been working in Browse mode, one of three 
ways you work with database documents. (You may not have known you were 
in Browse because that’s the preset option.) 

In this section you’ll switch to Find mode, which gives you a blank record 
called a 

 

find request.

 

 Use a find request to tell ClarisWorks what records you 
want to find.

To find records:

 

1. Choose Find from the Layout menu.

 

A blank record, or 

 

find request

 

, appears that resembles the data entry 
record with which you’ve been working. Notice that the status panel 
has changed. You now see two buttons, Visible and All, as well as the 
Omit checkbox.

 

New find request

 

Find status panel (different 
from the panel in browse)

Blank fields



 

6-14

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

2. Activate the field you want to search.

3. Type the characters you want to find in that field.

 

Mary wants to search all records to find the word “Encyclopedia” in the Item 
field. When she types “Encyclopedia” in the Item field, the characters in 
“Encyclopedia” become the 

 

search criteria—

 

the characters ClarisWorks 
uses to find records. 

 

4. Click All.

 

ClarisWorks searches all the records and finds any records that contain the 
search criteria in the search field. The status panel shows how many records 
were found out of the total number in the document.

In Mary’s case, ClarisWorks found two records.

 

Find request with
search criteria

 

Book now shows the number of find requests, not the number of records

Find controls

 

 

Database book after
finding records

 

 
Find status: two records were found 
out of the six records in the database.
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◆

 

Renumbering

 

ClarisWorks renumbers the records in the 

 

found set

 

, the set 
of records found. The rest of the records are temporarily omitted or hidden 
and are no longer visible.

 

.

 

To restore all the records to the set, choose Show All Records from the 
Organize menu.

ClarisWorks displays all the records in the database. 

Show all your records now so that you’re ready for the next section, where 
you’ll sort the records. You can sort the found records, if you wish, but if you’re 
following the example, the exercise is more interesting with more records to 
sort. 

 

Sorting the Records

 

One of the things databases do best is organize information. You’ve already 
learned to find certain records, so you’re ready to take the next step: sorting.

Mary wants a complete alphabetical listing of today’s customers, so, after 
showing all records, she sets up a sort order.

To sort records:

 

1. Choose Sort Records from the Organize menu.

 

ClarisWorks opens the Sort Records dialog box shown in step 4.

On the left are all field names in the database document.

 

2. Select the field name by which you want to sort.

 

Mary is sorting by Sold To (the customer’s company name).
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3. Click Ascending Order (to sort A to Z) or Descending Order (to sort Z to A).

4. Click Move (or double-click the field name).

 

The field name moves into the Sort Order list on the right.

 

5. Repeat the process to add other sort fields.

 

ClarisWorks sorts first by the top field name, then sorts records with the 
same entry in the first field by the second field, and so on through the list.

 

6. Click OK.

 

ClarisWorks sorts the records and closes the dialog box. The records are 
now in alphabetical order.

 

Setting up a sort order

 

Double-click a field 
name here ...

to move a field here.

 

After sorting

 

Records are now in alphabetical 
order based on the Sold To field



 

Managing Information

 

6-17

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

◆

 

Record numbers change

 

Take a look at the status panel. It shows the same 
number of records, but the records are now in the sorted order. What was 
record 6 may now be record 3, because ClarisWorks renumbers the records 
when you sort.

 

Saving Your Work

 

You’re now about midway through this session of the tutorial. In a moment 
you’ll begin working with layouts. This is a good time to name and save your 
database document. (If you need a refresher, see chapter 3.) 

Mary names the document “Invoice.cwk.”

 

Turning the Database into a Report

 

Mary realizes that, using the standard layout she began with, she can’t get an 
overview of the day’s sales. She decides to create a new layout for a daily 
sales report.

To create a new layout:

 

1. Choose New Layout from the Layout menu.

 

The New Layout dialog box appears (see step 2).

 

Current record number

Total number of records
Sort status
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2. Click the type of layout you want and type a name for the layout.

 

Mary decides on a columnar report and names it “Sales Report.” In a 
columnar report, ClarisWorks organizes field labels at the top of a report, 
with data in the fields placed in the columns below. 

 

3. Click OK.

 

The Set Field Order dialog box appears.

 

4. Double-click a field name in the Field list to move it into the Field Order list.

 

ClarisWorks organizes the field labels across the top of the report as 
headers. Each field, with its data, appears under its own field label. 
The first field in the Field Order list becomes the first field on the left 
of the report.

 

Creating a new layout 

 

Type a name for the layout here.

 

Setting the order of 
fields for a columnar 
report layout 

 

Double-click a field here ...
to move it here.
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5. Move the remaining fields you want and click OK.

 

ClarisWorks creates the new layout and shows the current records in the 
new arrangement.

Your report should look something like this.

 

◆

 

Switching layout

 

ClarisWorks adds the new layout to the list of commands 
at the bottom of the Layout menu. Now, to switch layouts, all you have to 
do is choose the layout you want. 

 

Understanding Layouts

 

Mary immediately notices that the item names are cut off and that the prices 
and total amounts are not in dollar figures. To adjust field sizes and add 
currency signs, she needs to work directly with the layout.

Up to this point in the tutorial, you’ve worked with records in Browse and 
Find—two of the three ways of working with a database document. The third 
way is Layout mode, in which you can make graphical changes to the database.

In the previous section, you created a columnar layout automatically, without 
leaving Browse. Now, to work directly with a layout, you switch to Layout, 
where you can move fields around, change fonts and or number formats, and 
generally shape the way you want a database to look. 

 

.

 

To switch to Layout mode, choose Layout from the Layout menu.

Do this now so you can take a closer look at a database document in Layout. 

 

Records in the new
columnar layout
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Mary’s columnar report, in Layout, is shown here. 

Several elements are different in this mode of the document. The menu has 
changed to a graphics menu, and the tool palette is now present. Also present 
are elements called 

 

layout parts

 

: a header and body. 

Fields and field labels are now represented as 

 

objects. 

 

Objects in a database 
layout behave the same way as the graphic objects you worked with in 
chapter 2 and text objects in chapter 3. For example, you can resize the objects 
and move them around.

When you change the objects in a layout, you change the way a record looks 
when you’re in Browse and when you print. For now, stay in Layout for a 
moment to learn how everything works.

 

Working in Two Views

 

In ClarisWorks, you can expand your view when you revise a layout. You can 
open another window for the document, and use one window to work in Layout 
and the other to see the effects in Browse.

 

Tool palette

Layout parts Objects
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To work in two windows:

 

1. Choose New View from the Window menu.

 

ClarisWorks opens a window that looks identical to the original. It is, 
except that the number 

 

2

 

 has been added to the title.

 

2. Hold down the Ctrl key and choose Tile from the Window menu.   

 

ClarisWorks divides the available screen space between the two windows, 
placing one window on top of the other. This arrangement, called 

 

tiling 
down

 

, occurs when you press Alt while choosing Tile.

 

3. Activate the bottom window by clicking anywhere in it.

4. Choose Browse from the Layout menu.

 

ClarisWorks switches the active window to Browse, leaving the other 
window in Layout, as shown here. 

 

Two database 
windows tiled down

 

This window is in Layout.

This window is in 
Browse.
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Fine-Tuning the Report

 

When you left Mary earlier, she was about to change the layout to enlarge the 
Item field, whose data was cut off, and change two of the number fields to show 
currency signs.

You make these changes in the Layout window. Click anywhere in the Layout 
window to activate it.

 

Resizing Fields

 

To change the size of a field or field label:

 

1. Select the graphics tool and click the field or field label to select it.

 

Everything in Layout works the way it does in a graphics document, so you 
see handles on a selected object.

Mary selects the item field.

 

2. Drag one of the handles to enlarge or shrink the field or field label.

 

Mary changes the Item field so that the complete item name appears in 
Browse. Don’t worry that the field now extends beyond the border or the 
body part (the body part is the area above the line). You’ll fix that later.

Notice that as soon as you let go of the mouse button, the Browse window 
reflects the change.

You can use all the graphics tools when you work with layouts. For 
example, if you get fields out of line, you can realign them as you realigned 
objects in chapter 4.

 

Mary’s report in Layout

 

 

 

Graphics tool

 

Resizing a field 
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Reformatting Numbers

 

You can choose among five different formats for displaying numbers in 
number fields. 

To choose a number format:

 

1. Double-click the number field you want to change.

 

Mary double-clicks the Price field and the Number Format dialog box 
opens. You can also select the field and choose Field Format from the 
Options menu.

 

2. Click the option you want.

 

Mary clicks Currency so that numbers begin with a dollar sign. She leaves 
the precision—the number of decimal places—at 2, the preset option. 
Change the 2 to a 0 if you want whole dollars. Cents are rounded to the 
nearest dollar.

 

3. Click OK.

 

ClarisWorks changes the numbers. You can see the effect in the 
Browse window.

 

Practice Moves

 

Before you go on, try changing other aspects of the layout, such as the font, 
using the methods you learned in chapter 3. Try selecting a field and adding a 
fill color (you may need to make the window larger to see the fill color palette). 
Any changes you make in Layout appear in every record in the database; you 
see these changes in Browse and when you print.
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Adding a Picture to a Layout

 

The sales report looks very plain, so Mary decides to polish up the appearance 
by adding the company logo to the layout.

 

Resizing Layout Parts

 

In Layout mode, you can move parts of the layout, such as the header and body, 
so that you can add artwork or resize fields. Before you begin, be 
sure you still have two windows open, one in Layout mode and the other in 
Browse mode.

To make room in a header for art:

 

1. Activate the window that’s in Layout mode. 

2. Choose the layout you want to change from the Layout menu.

 

Mary has chosen Sales Report.

 

3. Click the graphics tool, and drag the header part downward to make room for the art you 
plan to add.

 

The pointer changes to a double-arrow crossbar when it’s in position to 
drag a part of the layout.

 

4. Hold down Shift and click each field label to select all the field labels.

5. Drag the labels to just above the header part line.

 

All the labels move as a group.

 

Drag the header part downward.
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To make room in the body part for field text:

 

1. Click the graphics tool if it isn’t already selected.

2. Drag the body part downward (as you did earlier with the header part) to make room for 
the Item field text.

 

Adding a Picture

 

Now that you’ve enlarged the header part of your layout, you can insert a 
picture and scale it to the size you want. 

To add a picture:

 

1. Choose Insert from the File menu.

 

The Open dialog box appears, listing the names of existing graphics 
documents on the left.

 

2. Change directories, if necessary, to find the ClarisWorks Tutorial directory. 

3. Select the document name “Pegasart.wmf” and click Open (or double-click the document name).

 

ClarisWorks inserts the picture in the layout. The art has handles, indicating 
that the object is selected.

 

Art inserted in 
the layout 
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To rescale the art:

 

1. Choose Scale Selection from the Options menu.

 

The dialog box is the same one you worked with in chapter 4.

 

2. Type 50% for both dimensions, and click OK.

 

ClarisWorks reduces the art and leaves the object selected.

 

3. Drag the scaled art into the position you want. 

 

Mary puts the logo in the corner and aligns it with the first column.

 

Adding a Report Title

 

Mary’s last step is to add the title of the report to the header. She uses the text 
tool to create a text frame in which she types the name of her report.

To add text to the header:

 

1. Click the text tool.

2. Choose a font, size, and style from the Format menu.

 

Mary chooses Times New Roman, 36 point, Plain.

 

Drag the art into place in the header part.
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3. Click once in the header part and type the text.

 

A text frame appears and Mary types “Sales Report” in it.

 

4. Select the graphics tool and click the text to select it.

 

You can now move the object that contains the text. If necessary, drag a 
handle to widen the box enough to position the text on one line.

Here is Mary’s finished header. 

 

5. If you’re still working with two windows, close the window that’s in Layout.

6. Click the remaining window’s Maximize button to fill the screen with the Browse mode.

 

Window Maximize button
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You can now see the full effects of the header and the other layout work 
you did.

 

7. To see how the page appears when printed, choose Page View from the Window menu.

 

Wrapping Up Chapter 6

 

You’ve now explored a ClarisWorks database document. You’ve learned to set 
up fields, create and edit records, find and sort records, create new layouts, and 
work with basic layout parts.

In the final chapter of the tutorial, you’ll work with sample documents to create 
a simple newsletter, using advanced ClarisWorks features. If you’re ready for 
a break, this is a good spot for one. If not, go on to chapter 7 now.

 

The finished product, a
sales report
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Learning to Use Advanced Features

 

In this session of the tutorial, you’ll use frames to create a newsletter, using 
sample documents provided. 

In the earlier chapters of the tutorial, you learned about ClarisWorks concepts 
such as document types and objects and learned how to use various tools and 
view controls.

Now you’re ready to speed through some advanced features. “Advanced” 
doesn’t mean these features are difficult to learn. Instead, it means they use the 
full power of ClarisWorks.

In this section you’ll learn how to:

 

■

 

lay out a newsletter page using linked text frames

 

■

 

import text and graphics directly into a document

 

■

 

create and work with a spreadsheet frame

 

■

 

update a spreadsheet-based chart
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Creating a Newsletter

 

In this session, you’ll combine ready-made art and text documents to create a 
simple one-page newsletter for employees of Pegasus Books International, the 
sample company used in the tutorial. Sample source documents are provided.

As noted, this session moves quickly. If you’ve forgotten how to do a step 
mentioned here, go back to the appropriate session of the tutorial for a quick 
refresher. 

To start the newsletter:

 

1. Open a new graphics document.

2. Choose Show Rulers from the Window menu.

 

The graphics rulers appear at the top and sides, set in inches (the preset 
option). Newsletters require precise work, so you’ll want to leave the 
graphics rulers open in the document. 

 

◆

 

Why use a graphics document?

 

Your first thought when starting a newsletter 
is probably to open a word processing document and use columnar text. 
However, a graphics document provides a much more flexible environment 
for the page-layout process, partly because a graphics document allows 
columns of different widths and lengths on the same page.

 

Inserting the Art

 

In this step you’ll insert art from a graphics file, supplied in the Tutorial 
directory, into the newsletter to serve as a masthead.
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To add the letterhead art:

 

1. Choose Insert from the File menu.

 

When the Insert dialog box opens, change directories, if necessary, to find 
the Tutorial directory.

 

2. Double-click the document named “Ltrhdart.wmf.”

 

ClarisWorks inserts the artwork into the new graphics document you 
created, leaving the art selected.

 

3. Drag the art into a position at the top of the page.

4. When the art is in position, deselect it by clicking anywhere else in the document.

 

Selected art file

 

 

 

Art in position as 
newsletter masthead 
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Creating a Place for the Text Article

 

To create columns for the text article, you’ll work for the first time with linked 
frames—two objects you can resize and move separately without disturbing the 
contents of the objects.

You’ve actually been working with frames throughout the tutorial. In chapters 2 
and 4, when you typed text in a graphics document, you created an object that 
contained text. That’s what a frame is: an object that contains something.

The newsletter will be a two-column piece, so you’ll start by drawing two text 
frames. Then you’ll “pour” the text article into the frames.

To create linked text frames:

 

1. Choose Frame Links from the Options menu.

 

Nothing seems to happen, but you’ve let ClarisWorks know that you plan 
to draw linked frames. The Frame Links command now has a check mark 
to remind you that the link feature is on.

 

2. Click the text tool, and drag the pointer to draw a box about the size of the box shown here.

 

A crosshair on the I-beam pointer helps you draw precisely.

 

Drawing the first frame

 

Text tool

New 
frame

I-beam with crosshair
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3. Press the Enter key on the numeric keypad.

 

The link controls appear, showing the status of the frame.

 

4. Click the continue indicator and draw a second frame to the right of the first.

 

The outline of the first frame disappears when you draw the second frame 
because the first frame is no longer selected. When you finish drawing the 
second frame, you see new link control indicators—chains that indicate the 
second frame is connected to the first.

 

5. Turn off Frame Links by choosing it again from the Options menu.

 

Indicators on a linked 
frame

 

Top-of-frame indicator

Continue indicator
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6. Select both frames by holding down Shift and clicking each frame so that you can see how they 
look in the document.     

 

Inserting the Text

 

With the frames in place, you’re ready to import the text of an article.

To insert text:

 

1. Select the text tool and click the first frame.

2. Choose Insert from the File menu.

 

The Insert dialog box (shown on page 7-4) opens.

 

3. Change directories, if you need to, to make the Tutorial directory current.

 

If you want to insert text of your own, you must have the appropriate 
translator. For a full explanation, see chapter 2 in the 

 

ClarisWorks 
Handbook.

 

 

 

Second frame in place

 

Chain indicators
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4. Double-click the document named “Employmo.rtf.”

 

ClarisWorks inserts the text in the first frame and sends the overflow into 
the second frame.

 

5. Click the graphics tool.

 

If you made the text frames too small for the text, you’ll also see a text 
overflow indicator, shown here.

If you wanted to create a third linked frame, you’d click the continue 
indicator (the arrow) at the bottom of the second frame, and draw the 
third frame.

 

Text overflow indicator

Link indicator

Continue indicator
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Resizing the Columns

 

You can now use the graphics tool to resize and move the two columns to get 
them precisely where you want them.

Using this illustration as a guide, resize the columns to make room for an article 
headline over the first frame. 

 

Saving Your Work

 

You’re now about midway through this session of the tutorial. In a moment 
you’ll work with a spreadsheet frame and create a chart for the newsletter. This 
is a good time to name and save your practice document. (If you need a 
refresher, see chapter 3.) 

The example shown in this chapter is named “Newslttr.cwk.”

 

The newsletter so far 

 

Space for headline
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Adding a Spreadsheet Frame

 

To emphasize sales growth for the employee of the month, you’ll now add a 
spreadsheet frame and turn it into a chart for visual impact.

To add a spreadsheet frame:

 

1. Click the spreadsheet tool (the crossbar).

2. Near the bottom of the newsletter, draw a spreadsheet frame by dragging the spreadsheet 
pointer, as shown here.

 

When you release the mouse button, spreadsheet cells appear in the frame. 
Notice that the data entry bar and spreadsheet menus are now available in 
the document window (not shown in here) whenever the spreadsheet tool is 
active. 

 

Adjusting the Column Width

 

You now need to resize your frame so that it shows columns A through E and 
rows 1 through 6. Because the columns are wide, you’ll find it easier to work 
with your spreadsheet frame if you adjust the column width. To adjust all 
columns in the spreadsheet frame to an equal width, follow these steps.

 

 

 

Drawing a spreadsheet 
frame 
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To adjust the column width:

 

1. Click the selection box at the top-left side of the spreadsheet frame to select all the cells.

2. Choose Column Width from the Format menu.

3. Type 80 in the Column Width box and click OK.

 

Your spreadsheet frame should look similar to this one.

 

Copying Data from Another Spreadsheet

 

A source document on sales performance is available in the Tutorial directory. 
In the following steps, you’ll copy the data from the source document and paste 
it into the spreadsheet frame.

 

 

Selection box

 

 

 

Spreadsheet frame in 
the newsletter 
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To copy the data:

 

1. Without closing the newsletter, choose Open from the File menu.

2. In the Open dialog box, double-click the Salesprf.cwk document.

 

Salesprf.cwk, a spreadsheet document, opens.

 

3. Drag the pointer to select a range from cell A1 to cell E6.

 

 

The extreme right side of the spreadsheet is cut off here. 

 

4. Choose Copy from the Edit menu (or press Ctrl+C).

5. Double-click the Control-menu box to put away the Sales Performance spreadsheet.

 

To paste the data you copied:

 

1. In the newsletter, click the spreadsheet frame to activate it, and then click once in cell A1 to 
select the cell.

 

As you learned in chapter 5, a border around cell A1 indicates that the cell 
is selected.

 

2. Choose Paste from the Edit menu (or press Ctrl+V).

 

ClarisWorks pastes the data into the spreadsheet frame.

 

Selecting data for the 
spreadsheet frame
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Creating a Chart

 

You’re now ready to create a chart from the data. A chart makes the numbers 
easy to comprehend and can sometimes make a striking visual point.

To create a chart:

 

1. Select cells A3 through B4.

 

These cells contain sales summaries for the first quarter of the last 
two years.

 

2. Choose Make Chart from the Options menu.

 

The Make Chart dialog box appears.

 

3. Click the first bar chart icon, shown here, and deselect the Legend box.

 

Selecting data for 
a chart

 

Selecting a bar chart

 

Bar chart icon
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4. Click OK.

 

 ClarisWorks draws a bar chart based on the data you selected.

 

◆

 

Different environment

 

Notice that the chart has handles. The handles show 
that the chart is a selected graphic object. Notice also that the menus 
(not shown here) have changed to graphics menus, and the arrow pointer
is now present.

 

Rescaling the Chart

 

The chart is too big for its spot in the newsletter, so it needs to be reduced. You 
could resize it by dragging the handles, but you get better results if you rescale 
the chart proportionally. 

 

New chart in the 
newsletter 

 

Chart

Handle



 

Learning to Use Advanced Features

 

7-15

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

 

To rescale the chart:

 

1. While the chart is still selected, choose Scale Selection from the Options menu.

 

The Scale Selection dialog box opens.

 

2. Type the percentage reduction you want for the height and width. 

 

If you type 90, as shown in the example, the chart is reduced to 90% of its 
original size in both height and width.

 

3. Click OK if you want to rescale.

 

ClarisWorks reduces the chart (in the following section, the chart remains 
at 100%).

 

Revising the Spreadsheet and Chart

 

ClarisWorks has automatically labeled the bar chart with the legends “Sales in 
1992” and “Sales in 1993.” These legends were derived from the left-most cells 
in the range you selected to make the chart. 

For purposes of the newsletter, you want to change the legends to read “LAST 
YEAR” and “THIS YEAR.” You’d also like to change the spreadsheet while 
you’re at it. You can do both at the same time.
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To change the spreadsheet and the chart:

 

1. Click somewhere in the spreadsheet, outside the chart.

 

Notice that the menus change back to spreadsheet menus, and the crossbar 
pointer returns.

 

2. Select cell A3, which contains the “Sales in 1992” entry.

3. In the data entry bar, type “LAST YEAR,” as shown here.

4. Watch the legend on the chart as you press Tab or the Enter key on the numeric keypad.

 

ClarisWorks updates the chart to show the change you made in cell A3.

 

Changing a spreadsheet 
entry

 

New entry
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5. Now replace the contents of cell A4 with “THIS YEAR,” and press Tab or the Enter key on the 
numeric keypad.

 

Both cells are now updated in the chart and in the spreadsheet.

You could also change the numbers used for the chart or change the font or 
style used for entries. ClarisWorks updates the chart as soon as you confirm 
a new or modified entry in any cell that’s used in the chart.

 

Positioning the Chart in the Newsletter

 

You can now position the chart over the spreadsheet frame in the newsletter.

To move the chart:

 

1. Click the chart.

2. To hide the spreadsheet frame, drag the chart so that it covers the frame.

 

You may need to resize and move the spreadsheet frame, and then move 
the chart over it.

 

Adding Labels to the Chart

 

To finish the chart for the newsletter, you can add a label that identifies the 
chart by giving the name of the salesperson.

 

 

 

New label in chart 

 

Updated label
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To add a label to the chart:

 

1. Click the text tool and click somewhere near the chart.

 

It doesn’t matter where you type the label; you can move it later.

 

2. Type “Mark Smythe.”

3. Select the label and move it into place in the chart, as shown here.

 

If you want to group the chart and the text label into one object, you can select 
both the label and the chart and choose Group from the Arrange menu.

 

 

New label

 

Completed chart

 

Label in place
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Adding the Finishing Touches

 

With the graphics grid hidden, your newsletter should now look similar to this. 
All that’s needed now is a title for the lead article. (The chart shown here was 
rescaled to 100%.) 

To add a title to the article:

 

1. Click the text tool and click somewhere near the top of the text frames.

2. From the Font menu, choose Times New Roman as the font, and choose 24 points from the 
Size menu.

 

The newsletter so far
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3. Type the title, “Employee of the Month.”

 

Not all the text is visible, but you’ll fix that in step 4.

 

4. Select the graphics tool and click the text object to display the frame handles. Drag a handle 
to expand the object.

5. Drag the object into place in the newsletter, above the article.

 

 

 

Adding a title for 
the article 

 

Overflow indicator

 

Positioning the title 
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The newsletter is now complete. The finished page should look something 
like this.

If you’ve set up your printer, you may want to print the newsletter to see the 
results of your efforts.

 

Newsletter complete
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To print:

 

6. Choose Print from the File menu (or press Ctrl+P).

 

The Print dialog box appears. The print options displayed vary with the 
type of printer you are using. For now, leave all the settings as they are.

 

7. Click OK.

 

ClarisWorks prints the newsletter exactly the way it looks on the screen 
(except for the onscreen layout part).

 

Wrapping Up Chapter 7

 

In this session of the tutorial, you learned how to create linked text frames, 
import text into the frames, and use a spreadsheet frame. 

You also reviewed some skills that were covered earlier, such as adding text to 
a graphics document, creating a spreadsheet chart, and using the graphics rulers 
for precise placement of graphics elements.

 

Where to Go from Here

 

This session concludes the ClarisWorks tutorial. Although these six tutorial 
chapters have given you a good start, there’s much more to learn. Here are two 
suggestions for increasing your ClarisWorks skills.
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Keep Using Help

 

In chapter 2 you learned to open and use the ClarisWorks onscreen help system. 
The help system is a quick-access resource for those times when you want how-
to or reference information and you want it 

 

now. 

 

Many people don’t think to use onscreen publications like help, but that’s 
mostly because they’re more accustomed to printed manuals. The more you use 
help, the more you’ll rely on it as a fast way to get the instructions you need. 
For example, searching for key words in the help system is often quicker than 
looking up terms in the index.

 

Use Your Handbook

 

The 

 

ClarisWorks Handbook

 

 contains step-by-step instructions and reference 
information. Both manuals have detailed tables of contents and indexes to help 
you find what you need in the most direct way possible.

Claris recommends that you avoid using the tutorial chapters for reference. The 
tutorial is an 

 

introduction only

 

 and doesn’t contain the complete information 
you’ll want as you begin to do more advanced projects in ClarisWorks.

 

■

 

For detailed instructions and information, see the 

 

ClarisWorks Handbook

 

 
or the online help system.

 

■

 

For a quick look at commands and shortcuts, see the 

 

ClarisWorks Quick 
Reference Card.
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active window:

 

The window you are currently using 
or that is selected. A window is active when its border 
darkens or changes color. The active window appears 
on top of other open windows and responds to 
keystrokes and commands.

 

application environment:

 

In ClarisWorks, one of four 
types of software you use to work in different types 
of documents and frames. Each environment has its 
own set of menus.

 

arguments:

 

The values used by a spreadsheet or 
database function to calculate a result.

 

arrow keys:

 

The up, down, left, and right arrow keys 
on a PC keyboard.

 

arrow pointer:

 

The pointer on the screen when the 
graphics tool is selected. 

 

ascending sort order:

 

 Alphabetical sequence (A to Z) 
for words, lowest-to-highest order for numbers, and 
earliest to latest for dates and times.

 

See also

 

 sort 
order.

 

autogrid:

 

In a graphics document, a hidden control 
device that helps you create objects of precise sizes 
and keeps the objects lined up on the page.

 

bar chart:

 

A chart that represents spreadsheet data as 
bars, side by side or stacked horizontally. Often used 
to illustrate relative quantities. 

 

body:

 

In a database layout, the portion of the layout 
that holds the data in all the current records.

 

bookmark:

 

In a database document, the tab on the 
record book. You can drag the bookmark quickly from 
one record to another. 

 

See also

 

 record book.

 

 

This document was created with FrameMaker 4.0.2
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Browse:

 

A database mode in which you enter data 
as well as add, edit, and sort records. Records are 
organized in Browse according to the current layout. 

 

buttons:

 

In ClarisWorks documents, onscreen controls 
that you click to give instructions to ClarisWorks and 
the PC. In ClarisWorks Help, onscreen controls you 
click to move to a topic.

 

calculation field:

 

In a database document, a field that 
contains the results of a formula you enter when you 
define the field. 

 

See also

 

 field.

 

cell:

 

In a spreadsheet document, the box formed at the 
intersection of a column and a row.

 

cell address:

 

In a spreadsheet document, the combined 
designation of column letter and row number that 
identifies a cell. The address of a cell in column H, 
row 12, is H12. 

 

cell format:

 

In a spreadsheet document, the width of 
columns, the depth of rows, and the specifications for 
number style and text attributes.

 

cell range:

 

In a spreadsheet document, a group of 
selected cells. 

 

chart:

 

A graphic representation of the data in a 
spreadsheet, showing relationships among sets of 
data. A chart is a graphic object that can be pasted 
into another type of document.

 

chart title:

 

The name ClarisWorks uses for a 
spreadsheet chart. ClarisWorks takes the chart title 
from any text in the cell at the upper-left corner of 
the chart range.

 

Clipboard:

 

A temporary storage area in computer 
memory where ClarisWorks places the most recent 
selection you have cut or copied.

 

columnar layout:

 

 In a database document, a layout that 
shows and prints fields in columns. Each record 
appears as a row. 

 

copy:

 

To place a copy of selected text or objects on 
the Clipboard without removing the selection from 
its original location. You can paste the contents of 
the Clipboard elsewhere. 

 

See also

 

 pasting.

 

crossbar pointer:

 

The pointer on the screen when the 
spreadsheet tool is selected. 

 

cut:

 

To remove selected text or objects and place a 
copy of the selection on the Clipboard. You can paste 
the Clipboard contents elsewhere. 

 

See also

 

 pasting.

 

data entry bar:

 

In a spreadsheet document, the box 
used to enter data or formulas.

 

data series:

 

The values ClarisWorks uses to draw a 
chart from a spreadsheet. 

 

database:

 

A collection of information; also, software 
you use to collect, organize, and search for information. 

 

database book:

 

A tool used to move through records 
in a database and to check their sort or find status. 

 

date field:

 

In a database document, a field that must 
contain dates. 

 

See also

 

 field.

 

delete:

 

To remove (erase) selected text or objects from 
a document.
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descending sort order:

 

Reverse alphabetical sequence 
for words (Z to A), highest-to-lowest order for 
numbers, and latest to earliest for dates and times.

 

 

See also 

 

sort order.

 

divisions:

 

In a spreadsheet chart, the intervals or 
categories used to plot values in a data series. 
Divisions usually represent columns.

 

document:

 

A file created by an application. In 
ClarisWorks, you can create and work with four 
different types of documents, each designed primarily 
for a specific task—word processing, spreadsheet work, 
database management, or graphics.

 

editing:

 

The process of revising a computer-based 
document.

 

environment:

 

See application environment.

 

existing document:

 

A document you previously saved.

 

field:

 

In a database record, an element that holds a 
category of information.

 

 See also 

 

specific type of field: 
calculation, date, number, text, and time.

 

field definition:

 

In a database document, a field name 
and certain additional attributes, such as what type of 
data the field can contain. The data type determines 
what work you can do with the field.

 

field label:

 

A text object that contains the name of 
a field. Visible in Browse or Layout modes.

 

field (selected):

 

In a database document, the current 
(active) field.

 

field type: 

 

Indicates the kind of information you plan 
to enter in a database field, such as number, date, and 
calculation.

 

file format:

 

The way an application organizes and 
stores the contents of a document. 

 

fill tool:

 

The iconic representation of commands used 
to add or change the pattern and color of an object.

 

filling:

 

In a spreadsheet document, the process of 
filling cells with the contents of the first cell in a 
selected range. Usually expressed as filling down or 
filling right.

 

find:

 

A database feature used to search for records that 
match search criteria you enter in a find request.

 

find request:

 

In a database document, a blank view of 
the current layout, used to enter search criteria.

 

font:

 

 A complete set of type of one size and face, 
where face is the appearance or design of the type. 

 

font size:

 

The measure of type size in points. 

 

font style:

 

 The attributes of a font, such as its slant or 
thickness (weight). Italic and boldface are examples 
of font styles.

 

footer:

 

A page element that appears at the bottom of 
every printed page in a document. 

 

footer part:

 

In a database layout, a repeating element 
that appears at the bottom of each page. 

 

See also

 

 part.

 

footnote:

 

A comment or citation at the bottom of a text 
page that refers to numbers or symbols used as signals 
in the text.

 

found set:

 

The group of records that remains available 
for browsing after you execute a find request.

 

frame:

 

 An object that contains text or spreadsheet data.
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function:

 

A predefined formula that performs 
mathematical or logical calculations, acting on values 
you specify or supply.

 

graphics ruler:

 

The ruler you use to control the 
automatic grid and the spacing of gridlines in a 
graphics document.

 

graphics tool:

 

 The tool used to select, resize, and move 
objects. Also activates the graphics menus. Appears as 
the arrow icon on the tool palette. 

 

See also

 

 arrow 
pointer.

 

gridlines:

 

A matrix of dotted lines used to size and align 
objects in a graphics document.

 

grouping:

 

The process of consolidating several selected 
objects into one object.

 

handles:

 

Black squares ClarisWorks places at the 
edges of selected objects. You use handles to resize 
and reshape objects.

 

header:

 

A page element that appears at the top of every 
printed page in a document. 

 

header part:

 

In a database layout, a repeating element 
that appears at the top of each page.  

 

See also

 

 part.

 

I-beam pointer:

 

The pointer on the screen when the text 
tool is selected. 

 

See also

 

 text tool.

 

indentation:

 

The distance of text from the page guides.

 

invisible characters:

 

Format characters that you enter in 
a document by pressing keys such as Enter, Tab, or the 
Space bar.

 

justification:

 

The process of adjusting text margins so 
that the text exactly fills a line.

 

layout:

 

In a database document, a graphic 
representation of the way records will look when you 
browse or print records. You can use different layouts 
to display, organize, and print the same information 
in different ways. 

 

layout parts:

 

In a database document, the sections of 
a layout used to organize data on the page or to 
summarize data within the document.  

 

See also

 

 footer 
part and header part.

 

layout (standard):

 

In a database document, the preset 
arrangement of newly created fields: each field is on 
a separate line and the fields are stacked vertically.

 

legend:

 

In a spreadsheet chart, the labels for the data 
series and divisions on the chart.

 

line spacing:

 

The vertical distance from the base of 
one line of type to the base of the next line below. 
Line spacing defaults to one line and can be set in 
points or lines. Also called 

 

leading.

 

margins:

 

The blank space around the top, bottom, left, 
and right of document contents.

 

number field:

 

In a database document, a field that can 
contain any number you can type, including decimal 
points, if appropriate.  

 

See also

 

 field.

 

number format (currency):

 

A format that adds a currency 
symbol to a number.

 

number format (general):

 

A format that causes a number 
to fill a cell, with a floating number of decimal places 
to the right of the decimal point.

 

objects:

 

Elements that you can select, resize, and move 
around within a document. 
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omitted record:

 

In a database document, a record that 
has been temporarily removed from the active set of 
records using the Omit option of the Find command.

 

onscreen help:

 

A system of instructions to which you 
have direct access on a computer screen.

 

operators:

 

Symbols used in a formula to define the 
action to be performed.

 

order (sort):

 

See 

 

sort order.

 

page guides:

 

The dotted borders around each page that 
show where the document’s top, bottom, left, and right 
margins are set.

 

page view:

 

A view that shows you exactly how a 
document will appear when you print. Page view 
shows margins and headers and footers, if any. It is 
also the only way to see database summary 
information on the screen.

 

panes:

 

Division of a window used to display different 
parts of the same document. Panes can be horizontal 
(across the screen) or vertical (split lengthwise).

 

paragraph:

 

The basic formatting unit of a text 
document. Except for individually styled words and 
lines, text format you set applies to all of a selected 
paragraph or paragraphs.

 

paragraph (selected):

 

A highlighted paragraph. A 
paragraph is selected when the text insertion point is 
blinking anywhere in the paragraph, whether or not the 
paragraph is highlighted. 

 

pasting:

 

The process of placing the contents of the 
Clipboard in the same or a different location. 

 

See

 

 

 

also

 

 
cut and copy.

 

 See

 

 

 

also

 

 copy and cut.

 

path:

 

The sequence of directory names that the 
operating system follows to locate a file or another 
directory. On a PC, directory names in the path are 
separated by backslashes.

 

pen tool:

 

The tool used to change the width, pattern, 
and color of lines or an object’s border. Also adds 
arrowheads to lines.

 

 See

 

 

 

also

 

 tool.

 

pica:

 

A typographic measure equal to 1/6 inch 
(12 points).

 

pie chart:

 

A circular chart that represents spreadsheet 
data as “slices” of a pie. Often used to show the relative 
contribution of values to a total.

 

point:

 

A typographic measure equal to 1/72 inch.

 

record:

 

In a database document, a collection of data 
about a single activity or transaction. Corresponds to 
a printed form such as an invoice.

 

record book:

 

In a database document, the book icon 
that shows the number of the current record. 

 

See also 

 

bookmark.

 

record (selected):

 

In a database document, the current 
(active) record. A selected record is highlighted when 
you click anywhere outside a field.

 

ruler division:

 

The tick marks on a ruler.

 

search criteria:

 

Characters you enter to search for 
certain text (word processing), records (database), 
or cells (spreadsheet).

 

search field:

 

In a database document, the field or 
fields in a find request that contain the search criteria 
you type.
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selection:

 

The process of activating text, a text 
paragraph, or an object so that you can work with it. 
Handles appear on an object when it is selected.

 

shift constraint:

 

The process of holding down the Shift 
key while you manipulate an object to limit the object 
to a certain angle or shape. Often used with the line 
tool to draw straight lines.

 

smoothing:

 

The process of rounding out sharp angles in 
a polygon object.

 

sort order:

 

In a database or spreadsheet document, the 
hierarchy of fields or cells by which you want 
ClarisWorks to sort. Also, the method used to sort data 
(in ascending or descending order).

 

spacing:

 

See

 

 

 

line spacing.

 

spreadsheet:

 

A document arranged in columns and 
rows, usually used to work with numeric data. A 
spreadsheet can contain formulas that allow complex 
“what-if” analyses of data.

 

spreadsheet tool:

 

The tool you use to work in a 
spreadsheet document and to draw spreadsheet 
frames. Displays a crossbar pointer when selected.

 

 

See

 

 

 

also

 

 tool.

 

stacking order:

 

The arrangement of objects in a 
document. The most recently created object is 
placed at the front of the stack (you can rearrange 
the stacking order by moving objects to the front 
or back). 

 

stationery:

 

A document in which you save all the 
formatting of an original document.

 

status panel:

 

The area in a database window that shows 
the sort status and the status of found records.

 

superscript:

 

A number or character raised above the 
main line of text (the baseline is higher than that of the 
main line).

 

tab:

 

A character you insert to cause text to line up at a 
certain point on the text ruler when you press Tab.

 

tab marker:

 

A marker you drag into the text ruler to set 
a tab stop.

 

tabs (preset):

 

Tabs that are automatically set when 
you create a new text document. Tabs are preset at 
1/2-inch intervals.

 

text attributes:

 

The font, size, style, color, alignment, 
and line spacing assigned to text. Text attributes 
determine how text looks when you print.

 

text field:

 

In a database document, a field that can 
contain any type of characters—letters, numbers, or 
symbols.  

 

See also

 

 field.

 

text insertion point:

 

A blinking vertical line that 
indicates where the next text character you type 
will appear.

 

text ruler:

 

The ruler you use to control the left and right 
margins of a text page, the indentation of paragraphs, 
text justification, tab settings, and the spacing 
between lines. 

 

text tool:

 

 The tool, represented by an “A” on the tool 
palette, used to type text and draw text frames. 
Displays an I-beam pointer when selected.

 

thesaurus:

 

A feature you can use to find synonyms for 
a selected word or a word you specify.

 

time field:

 

In a database document, a field that must 
contain a time of day.  

 

See also

 

 field.
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tool:

 

See

 

 a specific tool name: fill, graphics, pen, 
spreadsheet, and text.

 

tool palette:

 

A collection of iconic representations of 
commands used to draw objects, fill objects with 
different patterns and colors, and change line width 
and color.

 

translator:

 

A utility application that converts 
documents from other applications to ClarisWorks 
documents, and vice versa.

 

ungrouping:

 

The process of restoring the individuality 
of objects that have been consolidated into one object.

 

unsmoothing:

 

The process of restoring angular shapes 
to a freehand graphics object that has been smoothed.

 

views (multiple):

 

Separate windows for the same 
document.

 

window:

 

A graphic frame through which you view the 
contents of a document (file).

 

windows (stacked):

 

An arrangement of windows that 
exposes a corner of each window. Stacking makes it 
more convenient to click back and forth between 
windows.

 

word wrap:

 

A method of paragraph formatting that 
carries the last word in a line to the next line below, 
without requiring you to press Return.

 

work area:

 

The part of a document that contains what 
you type or draw. 

 

WYSIWYG:

 

A method of displaying a document on the 
screen so that you see the document as it will appear 
when printed. The letters (pronounced “wizz-ee-wig”) 
stand for “What You See Is What You Get.”

 

zoom controls:

 

Two icons (large and small mountains) 
used to enlarge or reduce the view of a document.

 

zoom percentage:

 

The amount of reduction or 
enlargement of the active document. Actual size is 
100%. Percentages over 100 enlarge your view of a 
document, and percentages under 100 reduce it.

 

zoom percentage box:

 

A box that shows the current 
percentage of enlargement or reduction of document 
contents. 
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