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WinDatCon is a Windows Data Conversion program.    This Help Index lists the help topics available for 
WinDatCon.    Clicking an underlined topic will display additional information.
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File Menu
The File menu is accessed by selecting File on the menu bar.    A drop-down menu will appear containing 
the following options:

Launch "Program 1"
Launch "Program 2"
Preferences
Save Configuration
Exit



Edit Menu
The Edit menu is accessed by selecting Edit on the menu bar.    A drop-down menu will appear containing 
the following options:

Copy
Paste
Exponential/Floating Point
Turn On (Off) Drag/Drop



Conversions Menu
The Conversions menu is accessed by selecting Conversions on the menu bar.    A drop-down menu will 
appear containing the following options:

Energy
Length
Pressure/Temp/BP
Volume
Weight



Lists Menu
The Lists menu is accessed by selecting Lists on the menu bar.    A drop-down menu will appear 
containing the following options:

Density List/Calculation
Boiling Point List



Help Menu
The Help menu is accessed by selecting Help on the menu bar.    A drop-down menu will appear 
containing the following options:

WinDatCon Help Index
Help on Help
About WinDatCon



Opening Screen Buttons

The following buttons are present on the Opening screen:
Energy
Length
Pressure/Temp/BP
Volume
Weight
Exit
Move Back

These buttons are activated by clicking the mouse or pressing the <Enter> key while the button is framed.



Conversion Screen Buttons
The following buttons are present on the Conversion screens:

OK
Done
Move Back
Turn On (Off) Drag/Drop
Display Compound Groups

These buttons are activated by clicking the mouse or pressing the <Enter> key while the button is framed.



Dialog Box Buttons
WinDatCon contains the following dialog box buttons:

Cancel
Cascade Windows
Configuration 1
Configuration 2
Configuration 3
Configuration 4
Default Configuration
Done
OK
Save Configuration

These buttons are activated by clicking the mouse or pressing the <Enter> key while the button is framed.



Control Key Commands (Ctrl + Key)
The control key commands are shortcut keys for executing commands without going through menus.    To 
execute a menu option using the control key commands:

1. Hold down the Ctrl key.
2. Press the appropriate letter on the keyboard.

If a control key is available for a given option it will be listed on the menu to the right of the option.

The following control key commands are available for menu options:
Ctrl + R Preferences
Ctrl + S Save Configuration
Ctrl + X Exit
Ctrl + E Energy Conversions
Ctrl + L Length Conversions
Ctrl + P Pressure/Temp/BP Conversions
Ctrl + O Volume Conversions
Ctrl + W Weight Conversions
Ctrl + C Copy
Ctrl + V Paste
Ctrl + A About WinDatCon



Alternate Key Commands (Alt + Key)
The alternate key commands are shortcut keys for clicking buttons, activating menus, and selecting menu 
options.

Using Alternate Key commands to click buttons:
Buttons that can be clicked using the alternate key commands will have one underlined letter in the button 
name.    To click a button using an alternate key command:

1. Hold down the Alt key.
2. Press the key corresponding to the underlined letter in the button name.

The following alternate key commands are available for buttons:
Alt + N Energy Conversions
Alt + L Length Conversions
Alt + P Pressure/Temp/BPConversions
Alt + V Volume Conversions
Alt + W Weight Conversions
Alt + X Exit
Alt + T Turn On (Off) Drag/Drop
Alt + D Display Compound Groups
Alt + H Help on Compound Groups

Using Alternate Key commands to activate menus and select menu options:
All menu titles and options have one underlined letter in their name.    To select a menu or menu option 
using an alternate key command:

1. Press and release the Alt key.
2. Press and release the key corresponding to the underlined letter in the menu title(a drop-

down menu will appear).
3. Press the key corresponding to the underlined letter in the menu option.

Once a menu has been activated (steps 1 and 2), the right and left arrow keys can be used to move 
between menus.    The up and down arrow keys can be used to highlight menu options.    Once an option 
is highlighted it can be selected by pressing the <Enter> key.

The following alternate key commands are available for activating menus (the keystrokes required are 
separated by commas and are pressed in sequence):

Alt,F File
Alt,E Edit
Alt,C Conversions
Alt,L Lists
Alt,H Help

The following alternate key commands are available for selecting menu options (the keystrokes required 
are separated by commas and are pressed in sequence):

Alt,F,L Launch "Program 1"
Alt,F,A Launch "Program 2"
Alt,F,P Preferences
Alt,F,S Save Configuration
Alt,F,X Exit
Alt,E,C Copy
Alt,E,P Paste
Alt,E,E Exponential/Floating Point
Alt,E,T Turn On (Off) Drag/Drop
Alt,C,E Energy
Alt,C,L Length
Alt,C,P Pressure/Temp/BP
Alt,C,V Volume



Alt,C,W Weight
Alt,L,D Density List/Calculation
Alt,L,B Boiling Point List
Alt,H,W WinDatCon Help Index
Alt,H,H Help on Help
Alt,H,A About WinDatCon



Function Keys
The function keys are shortcut keys for executing commands without going through menus.

The following function keys are available:

F1 WinDatCon Help Index
F2 Launch "Program 1"
F3 Launch "Program 2"
F4 Exponential/Floating Point
F5 Turn On (Off) Drag/Drop
F6 Density List/Calculation
F7 Boiling Point List



Launch "Program 1"
Launch "Program 1" is an option on the File menu.    This option allows you to start another application 
without leaving WinDatCon.    The default for "Program 1" is the Windows Calculator.    The default text for 
this option (first item on the File menu) will be Launch Calculator.    When this option is selected, the 
calculator application will be started and it will be displayed in the foreground.    If a copy of the application 
is opened, a second copy will be started. 

The default Windows Calculator can be changed to a different program using the Configure Program 
Launcher option in the Preferences dialog box. 

The shortcut key for the Launch "Program 1" option is F2. 



Launch "Program 2"
Launch "Program 2" is an option on the File menu.    This option allows you to start another application 
without leaving WinDatCon.    This is an optional feature and it will not appear on the File menu unless a 
program (path and filename.EXE) is designated using the Configure Program Launcher option.    If a 
program is designated,    it will appear as the second option on the File menu.    When this option is 
selected, the application will be started and it will be displayed in the foreground.    If a copy of the 
application is opened, a second copy will be started. 

The shortcut key for the Launch "Program 2" option is F3. 



Preferences
Preferences is an option on the File menu.    This option is used to configure conversion screens.    
WinDatCon has five conversion screens.    These screens can be displayed in various configurations (i.e., 
the conversion screens can be minimized, normal, or positioned within the application area, and the 
application can be resized).    The startup configuration of WinDatCon can be selected and saved.    The 
Preferences option allows you to select from predesigned configurations, or a custom startup 
configuration can be designed and saved.

When you activate the File menu and select the Preferences option a dialog box will appear.    This dialog 
box contains buttons to display predefined configurations, cascade the windows in any configuration, 
save the selected configuration for startup, and configure the program launcher.

When one of the predefined configuration buttons is clicked, the corresponding configuration will be 
displayed in the background, and it will become the new configuration for the current session.    The 
following predefined configurations are available:

Configuration 1:
This configuration resizes the application to fill the screen of an EGA or VGA monitor with the five 
conversion screens minimized (icons appear in the lower left of the application area).

Configuration 2:
This configuration resizes the application to fill the screen of an EGA or VGA monitor with the five 
conversion screens normal (not minimized).

Configuration 3:
This configuration resizes the application to fill the screen of a super VGA monitor with the five conversion 
screens minimized (icons appear in the lower left of the application area).    This configuration is similar to 
Configuration 1 on an EGA, or VGA monitor.

Configuration 4:
This configuration resizes the application to fill the screen of a super VGA monitor with the five conversion 
screens normal (not minimized).    This configuration is similar to Configuration 2 on an EGA or VGA 
monitor.

Default Configuration:
This configuration resizes the application window to the minimum size necessary to view the text, buttons 
and input boxes on all five conversion screens.    The configuration positions all conversion windows in the 
upper left corner and provides a space at the bottom of the screen for minimized icons of other 
applications.    None of the five WinDatCon conversion screens is minimized in this configuration.

Cascade Windows:
This option can be used with any of the predefined configurations except the Default Configuration.    (The 
Default Configuration is the only predefined configuration that moves the configuration windows.)    By 
choosing Cascade Windows the five conversion screens will be cascaded within the application window. 
Selecting a predefined configuration (except for the Default Configuration) after selecting Cascade 
Windows will keep the configuration screens in their cascaded positions.    This option only works well with 
a super VGA monitor and Configuration 3 or Configuration 4.    If this option is used with Configuration 1 
or Configuration 2, portions of the conversion screens will be moved outside of the application area and 
will not be visible.

To facilitate movement between screens:
i. The name of each conversion screen appears in the title bar, and
ii. The first letter of each screen name appears in the lower left corner of the screen.

Save Configuration:



Once you have selected a startup configuration, click the Save Configuration button.    The configuration 
will be saved and it will be used on startup of WinDatCon.    The items saved are:

1. Application size and position.
2. Conversion screen positions.
3. Conversion screen states (minimized or normal).

The Save Configuration option also can be accessed from the File menu.

Modifying a Predefined Configuration:
A predefined configuration can be used as a starting point for creating a custom configuration:

1. Activate the File menu.
2. Select the Preferences option.    A dialog box will appear.
3. Click one of the Configuration boxes and the corresponding configuration will be displayed in 

the background.
4. Click the OK button and the dialog box will disappear.
5. Modify the configuration.    (The conversion screens can be minimized, normal or positioned 

within the application area, and the application can be resized.)
6. To save the configuration for use on start-up:

- Click Save Configuration on the File menu, or
- Hold down the Ctrl key and press the letter S on the keyboard, or
- Bring up the Preferences dialog box (steps 1-2) and click the Save Configuration button.

Configure Program Launcher:
The Configure Program Launcher option is used to designate applications that can be started with the 
Launch options on the Edit menu.

OK: 
When the OK button is clicked the Preferences dialog box will disappear.    If a predefined configuration 
was selected it will become the configuration for the current session.    This configuration will not be the 
startup configuration unless it was saved using the Save Configuration option.

The shortcut key for the Preferences option is Ctrl + R. 



Configure Program Launcher
The Configure Program Launcher option allows you to choose two programs that can be started by the 
Launch "Program 1" and Launch "Program 2" options on the File menu.    The "Program 1" and "Program 
2" text on the menu can be customized to reflect the names of the programs being launched.

To use the Configure Program Launcher:
1. Activate the File menu .
2. Select the Preferences option.
3. Click the Configure Program Launcher button and a dialog box will appear.
4 To Set Launch "Program 1":

i. Click the first box on the screen, or press the tab key until the cursor is positioned in this 
box (the cursor will appear in this box when the dialog screen is opened).

ii. Enter the full path and filename.EXE for the program to be launched.    (The default 
"Program 1" is the Calculator supplied with Microsoft Windows.    The path and 
filename.EXE for this program will appear in the box and can be edited.)    If a program is 
not entered in this area a menu option will not be created.

iii. Click the next box on the screen or press the Tab key until the cursor is positioned in this 
box.

iv. Enter the text that you want to appear on the menu for this program launching option.    
The first word of the command will be Launch.    This text will appear in the box and it 
cannot be edited.    (The default text is Calculator and this can be edited).    If text is not 
present in this box the default text "Program 1" will appear on the menu.

5. To Set Launch "Program 2": (Optional)
i. Click the third box on the screen, or press the tab key until the cursor is positioned in this 

box.
ii. Enter the full path and filename.EXE for the program to be launched.    If a program is not 

entered in this area a menu option will not be created.
iii. Click the next box on the screen or press the Tab key until the cursor is positioned in this 

box.
iv. Enter the text that you want to appear on the menu for this program launching option.    

The first word of the command will be Launch.    This text will appear in the box and it 
cannot be edited.    If text is not entered in this area the default text "Program 2" will 
appear on the menu.

6. When you have entered the appropriate information, click the OK button.    You will return to 
the previous screen and your selections will be saved.    The launch option(s) will appear on 
the File menu with the text you designated.



Save Configuration
Save Configuration is an option on the File menu.    This option will save the current configuration for use 
on startup.    The items saved are:

1. Application size and position.
2. Conversion screen positions.
3. Conversion screen states (minimized or normal).

The shortcut key for the Save Configuration    option is Ctrl + S.    The Save Configuration option also can 
be accessed from the Preferences dialog box.



Exit
This menu option    closes the application. 

The shortcut key for the Exit option is Ctrl + X. 



Energy Conversions

The Energy Conversions screen is accessed by selecting Energy from the Conversions menu.    This 
screen displays energy values in various units.

To display an energy value in the units available:
- Enter the known energy value in the appropriate box, or 
- Edit an existing value.

The remaining units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is changed (by clicking on, or tabbing to a different box).

Calculations are accurate to six significant figures.

The energy value is displayed in the following units:
BTUs
Calories
Ergs
Foot-pounds
Hp.-hours
Joules
Kilocalories
Kilogram-meters
Kw.-hours
Liter-atmospheres
Millijoules
Watt-hours

To clear the values in all boxes:
1. Clear the value in one box.
2. Press the <Enter> key, click the OK button, or change the focus.

The shortcut key for the Energy Conversions option is Ctrl + E. 



Length Conversions

The Length Conversions screen is accessed by selecting Length from the Conversions menu.    This 
conversion screen displays length values in various units.

To display a length value in the units available:
- Enter the known length value in the appropriate box, or 
- Edit an existing value.

The remaining units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is changed (by clicking on, or tabbing to a different box).

Calculations are accurate to six significant figures.

The length value is displayed in the following units:
Angstroms
Centimeters
Feet
Inches
Kilometers
Meters
Microns
Miles
Millimeters
Mils
Nanometers
Yards

To clear the values in all boxes:
1. Clear the value in one box.
2. Press the <Enter> key, click the OK button or change the focus.

The shortcut key for the Length Conversions option is Ctrl + L. 



Pressure/Temperature/Boiling Point Conversions

The Pressure/Temperature/Boiling Point Conversions screen is accessed by selecting Pressure/Temp/BP 
from the Conversions menu.

Pressure/Temperature Conversions
The left side of this conversion screen displays pressure and temperature values in various units.    To 
display a pressure or temperature value in the units available:

- Enter the known pressure or temperature value in the appropriate box, or 
- Edit an existing value.

The remaining units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is changed (by clicking on, or tabbing to a different box).

Calculations are accurate to six significant figures.

Negative pressure values and temperature values less than -273.16 degrees centigrade, -459.69 degrees 
Fahrenheit, or 0 degrees Kelvin are not allowed.

The pressure and temperature values are displayed in the following units:
Atmospheres
Bars
Degrees C
Degrees F
Degrees K
mmHg
Pascals
PSI

Boiling Point Conversions
The boiling point area of this conversion screen calculates the approximate boiling point of a liquid at 
various pressures based on the data represented by published nomographs (S.B. Lippincott and M.M. 
Lyman; Industrial and Engineering Chemistry, Vol. 38, p. 320, 1946).    Two of the following three values 
must be input and the third value will be calculated:

Boiling Point at 760 mmHg (Deg C)
Boiling Point (Deg C) (at specified Pressure)
Pressure (mmHg) (at specified Boiling Point)

Examples:

1. If the boiling point of a liquid at 760 mmHg, and a second boiling point value are input, the 
pressure of the system at the second boiling point will be calculated.

2. If the boiling point of a liquid and the corresponding pressure of the system at that boiling 
point are input, the boiling point at 760 mmHg will be calculated.

3. If the boiling point of a liquid at 760 mmHg and system pressure are input, the boiling point at 
the new pressure will be calculated.

When two values are input, the remaining value will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked.



Calculations are accurate to six significant figures.

The input and calculated values are designated by a title above the box so you will know which two of the 
three values were used as input for the calculation.

If values are present in all three boxes, these values can be changed using the following sequence:
1. Change an existing value.
2. Press the <Enter> key or click the OK button.
3. A dialog box will appear with an arrow to indicate which of the two remaining values will be 

recalculated.    If the arrow points to the desired value, press the <Enter> or click the Yes 
button and the dialog box will disappear and the calculation will be performed (calculations 
are accurate to six significant figures).    If the arrow points to the undesired value, click the 
No button and the arrow will point to the other value.    The No button will toggle the arrow 
between the two values.    When the arrow points to the value you want calculated, click the 
Yes button.    The dialog box will disappear, and the calculation will be performed.    (The right 
and left arrow keys can be used to toggle between the Yes and No boxes.)

To clear the values in all boxes:
1. Clear the value in one box.
2. Press the <Enter> key, click the OK button.

Compound Groups

The boiling point of a pure compound is a function of the pressure of the system and the structural 
characteristics of the compound.    The boiling point at various pressures can be estimated using the 
technique described by S.B. Lippincott and M.M. Lyman (Industrial and Engineering Chemistry, Vol. 38, p. 
320, 1946).    In this paper a variety of materials were classified into eight compound groups based on 
similar responses of their boiling points as a function of pressure.    A nomograph was generated for each 
group.    These nomographs can be used to estimate the relationship between boiling point and pressure 
for compounds not classified.    WinDatCon calculates the same boiling point and pressure values that are 
generated from the nomographs.

Choosing the correct Compound Group will give a more accurate calculation.    To determine which 
compound group should be used for the WinDatCon calculation:

- Select a group with compounds having similar physical and structural properties, or
- Calculate the values for Group 1 and Group 8 to get a range of possible values, or
- Use Group 4 (Default) to get an average value.

To select a Compound Group:
1. Edit the box containing the Compound Group number (allowed values are 1-8). 
2. Press the <Enter> key or click the OK button.    A dialog box will appear to confirm which 

value will be recalculated.
3. When the Yes button is clicked the value will be recalculated .

-or-
1. Click the Display Compound Groups button and a screen will appear displaying the specific 

compounds classified in Compound Groups 1-8 (the    current group will be highlighted in 
cyan).

2. Click the Help button if you would like more information about the Compound Groups.
3. Click a Compound Group box and it will become selected (this box will be highlighted in 

cyan).
4. When the Compound Group box you want is selected, click the OK button or press the 

<Enter> key.    You will return to the previous screen and the new Compound Group number 
will appear.    The last calculated value will be recalculated to reflect the selected Compound 
Group.



Option:
Drag/Drop

The shortcut key for the Pressure/Temp/BP Conversions option is Ctrl + P. 



Volume Conversions

The Volume Conversions screen is accessed by selecting Volume from the Conversions menu.    This 
conversion screen displays volume values in various units.

To display a volume value in the units available:
- Enter the known volume value in the appropriate box, or 
- Edit an existing value.

The remaining units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is changed (by clicking on, or tabbing to a different box).

Calculations are accurate to six significant figures.

The volume value is displayed in the following units:
Board Feet
Cubic Centimeters
Cubic Feet
Cubic Inches
Cubic Yards
Cups
Drops
Fluid ounces
Gallons
Liters
Microliters
Milliliters
Pints
Quarts
Tablespoons
Teaspoons

To clear the values in all boxes:
1. Clear the value in one box.
2. Press the <Enter> key, click the OK button, or change the focus.

The shortcut key for the Volume Conversions option is Ctrl + O. 



Weight Conversions

The Weight Conversions screen is accessed by selecting Weight from the Conversions screen.    This 
conversion screen displays weight values in various units.

To display a weight value in the units available:
- Enter the known weight value in the appropriate box, or 
- Edit an existing value.

The remaining units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is chaged (by clicking on, or tabbing to a different box).

Calculations are accurate to six significant figures.

The weight value is displayed in the following units:
Carats
Drams
Grains
Grams
Kilograms
Metric Tons
Micrograms
Milligrams
Ounces
Pounds
Stones
Tons

To clear the values in all boxes:
1. Clear the value in one box.
2. Press the <Enter> key, click the OK button, or change the focus.

The shortcut key for the Weight Conversions option is Ctrl + W. 



Density List/Calculation

The Density List/Calculation dialog box is accessed by selecting the Density List/Calculation option from 
the Lists menu.    This dialog box presents a list of densities (in g/mL units) for over 200 common solvents 
and reagents.    Also, there is an area for density calculations.

Density List:
The Density List contains over 200 common solvents and reagents in alphabetical order.    Each 
compound name is followed by a semicolon and the corresponding density.    The densities are at 20 
degrees centigrade unless followed by another temperature in parentheses.    The scroll bar can be used 
to view items not visible on the list.    The box above the Density List can be used to move quickly through 
the list.    Position the cursor in this box and type the compound name or the first few letter of the name, 
and you will move to that position on the list.    When the desired compound appears, double click the list 
entry (or single click the entry, and click the OK button or press the <Enter> key).    The density and 
compound name will be displayed in the Density box and Compound name area to the left of the Density 
List.    The compound names are listed in alphabetical order with the prefixes (numbers, ortho, iso, etc.) in 
parentheses following the name.    When the compound name is displayed in the Compound name area 
the prefixes will be in the proper location.

Density Calculation:
The left side of this dialog box is used for density calculations.    A density value is required for the 
calculation.    A weight or volume value is input and the corresponding volume or weight value will be 
calculated.    To perform a density calculation the following sequence is followed:

1. Input a density value (in g/mL units) in the Density box:
i. The density value can be input manually by positioning the cursor in the Density box and 

typing a value (no compound name will appear in the Compound name area), or
ii. The density can be selected from the Density List by double clicking an item or by 

highlighting an item and pressing the OK button, or pressing the <Enter> key.    The 
density value will appear in the Density box and the name of the compound will appear in 
the Compound name area.

2. Position the cursor in the Weight or Volume box by clicking the box or pressing the Tab key.
3. Input a weight value (in grams) or a volume value (in milliliters).
4. Click the OK button or press the <Enter> key and the corresponding volume or weight value 

will be calculated (calculations are accurate to six significant figures).    The value will not be 
calculated if the focus is changed to another box.

*Note:    Steps 1-2 and 3-4 can be reversed.

If values are present in all three boxes, these values can be edited using the following sequence:
1. Position the cursor in a box and change the existing value or select a new density from the 

Density List.
2. Press the <Enter> key, or click the OK button.    (If a density is selected from the Density List 

the last calculated weight or volume value will be recalculated automatically.)
3. The calculation will be performed (calculations are accurate to six significant figures). 

i. If a weight value is changed a new volume value will be calculated.
ii. If a volume value is changed a new weight value will be calculated.
iii. If a density value is changed, the last calculated value (either weight or volume) will be 

recalculated.

The input and calculated values are designated by titles above the boxes to indicate which value (weight 
or volume) was calculated.    The Density always will be an input value.

Copying Values to the Weight and Volume Conversion Screens:

The weight and volume values can be copied to the corresponding Weight and Volume Conversion 
screens using Method 1 or Method 2:



Method 1:
1. Place an "X" in the box(es) titled "Copy value to the Weight (and/or Volume) Conversions 

screen" (clicking the box will toggle the "X" on and off).    By default these boxes will be 
checked.    When you leave the Density dialog screen any changes to these boxes will be 
saved.

2. When these options are activated the values in the Weight and Volume boxes will be copied 
automatically to the corresponding gram and milliliter boxes on the Weight and Volume 
Conversion screens respectively. 

3. Select the Weight or Volume option from the Conversions menu.    The corresponding screen 
will appear.    The weight (or volume) value will be present in the appropriate box, the cursor 
will appear in this box, and the values in the remaining units will be displayed.

4.    When you leave the Density List/Calculation dialog box the density, weight and volume values 
will be cleared.

Method 2:
1. Highlight the value to be copied.
2. Select the Copy option from the Edit menu (or use the Ctrl +C or Ctrl + Insert shortcut keys).
3. Select the Weight or Volume option from the Conversions menu.    The corresponding screen 

will appear.    (When you leave the Density List/Calculation dialog box the density, weight and 
volume values will be cleared.)

4. Position the cursor in the appropriate box (grams on the Weight screen, or milliliters on the 
Volume screen).

5. Select the Paste option from the Edit menu (or use the Ctrl + V or Shift + Insert shortcut 
keys).

6. The remaining units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is changed (by clicking on, or tabbing to a different box).

Calculations are accurate to six significant figures.



Boiling Point List
The Boiling Point List is accessed by selecting Boiling Point List from the Lists menu.    This dialog box 
presents a list of over 200 boiling points of common solvents and reagents in alphabetical order.    Each 
compound name is followed by a semicolon and the corresponding boiling point in degree centigrade.    
The boiling points are at 760 mm Hg unless followed by another pressure in parentheses.      The scroll 
bar can be used to view items not visible on the list.    The box above the Boiling Point list can be used to 
move quickly through the list.    Position the cursor in this box and type the compound name or the first 
few letter of the name, and you will move to that position on the list.    When the desired compound 
appears, double click the list entry (or single click the entry, and click the OK button or press the <Enter> 
key).    The boiling point and compound name will be displayed in the Boiling Point box and Compound 
name area below the Boiling Point List.    The compound names are listed in alphabetical order with the 
prefixes (numbers, ortho, iso, etc.) in parentheses following the name.    When the compound name is 
displayed in the Compound name area the prefixes will be in the proper location.

A boiling point value can be copied to the Degrees C temperature box on the 
Pressure/Temperature/Boiling Point Conversion screen using Method 1 or Method 2:

Method 1
1. Place an "X" in the box titled "Copy value to the Degrees C temperature box on the 

Pressure/Temp/BP Conversions screen    (clicking the box will toggle the "X" on and off).    By 
default this box will be checked.    When you leave the Boiling Point List dialog screen any 
changes to this box will be saved.

2. When this option is activated the boiling point value in the box to the left of the checked box 
will be copied automatically to the Degrees C temperature box on the Pressure/Temp/BP 
Conversions screen.

3. Select the Pressure/Temp/BP option from the Conversions menu.    The corresponding screen 
will appear.    The boiling point value will be present in the Degrees C temperature box, the 
cursor will appear in this box, and the temperature values in the remaining units will be 
displayed.

Method 2
1. Highlight the boiling point value in the Boiling Point (Deg. C) box.
2. Select the Copy option from the Edit menu (or use the Ctrl +C or Ctrl + Insert shortcut keys).
3. Select the Pressure/Temp/BP option from the Conversions menu.    The corresponding screen 

will appear.
4. Position the cursor in the Degrees C temperature box or in one of the Boiling Point boxes.
5. Select the Paste option from the Edit menu (or use the Ctrl + V or Shift + Insert shortcut 

keys).
6. If the value is pasted into the Degrees C temperature box the temperature in the remaining 

units will be calculated if:
- The <Enter> key is pressed, or
- The OK button is clicked, or
- The focus is changed (by clicking on, or tabbing to a different box).
(Calculations are accurate to six significant figures.)

7. If the value is pasted into one of the Boiling Point boxes, and values are present in the 
remaining two boxes, the new values will be calculated if:
- The <Enter key is pressed; or
 The OK button is clicked.
(Calculations are accurate to six significant figures.)



Copy
Copy is an option on the Edit menu.    This option will copy selected text to the clipboard.

The shortcut key for the Copy option is Ctrl + C, or Ctrl + Insert. 



Paste
Paste is an option on the Edit menu.    This option will paste the contents of the clipboard at the position of 
the cursor.    If text is selected it will be replaced with the contents of the clipboard.

The shortcut key for the Paste option is Ctrl + V, or Shift + Insert. 



Exponential/Floating Point
Exponential/Floating Point is an option on the Edit menu. This option allows you to convert values from 
floating decimal point display to exponential display.    Numerical values in WinDatCon can be input and 
viewed in either display format.    Exponential display consists of the first number of the value followed by : 
i) a decimal point, ii)    a maximum of seven digits, iii) the letter "e", and iv) a maximum of three digits.    
The letter "e" precedes the number that represents the power of ten.    This number can be a positive or 
negative value (e.g. 12,415 would be represented as 1.2415e4 and 0.0034 would be represented as 
3.4e-3)

An unlimited number of characters can be input in each box; however, characters that cannot be 
accommodated in the space available will scroll out of the left side of the box.    If an input value is greater 
or equal to 1,000,000, or less than 0.000001, it will be converted to exponential display when the <Enter> 
key is pressed, the OK button is clicked, or the focus is changed.    The calculations are performed to an 
accuracy of six significant figures.

When the calculations are performed the values will be presented in exponential display if they are 
greater or equal to 1,000,000, or less than 0.00001.    The Exponential/Floating Point option allows you to 
toggle the box that contains the cursor (focus) between these two displays. 

The shortcut key for the Exponential/Floating Point option is F4. 



Turn On (Off) Drag/Drop

Turn On (Off) Drag/Drop is an option that only appears on the Edit menu in the 
Pressure/Temperature/Boiling Point Conversions screen.    This option allows you to copy Degrees C 
temperature values and mmHg pressure values to boxes containing the same units.    This option is 
activated and deactivated by clicking the "Turn On (Off) Drag/Drop" button, selecting the Turn On (Off) 
Drag Drop option from the Edit menu, pressing the T key while the <Alt> key is depressed, or pressing 
the F5 key.    When the Drag/Drop option is activated the three boxes containing degree C temperature 
values will be colored magenta and the two boxes containing mmHg values will be colored cyan.    These 
boxes will no longer accept manual input.    All other boxes will accept manual input. 

To drag (copy) a value from one box to another box containing the same units, the following sequence is 
used:

1. Activate the Drag/Drop option by:
- Clicking the "Turn On Drag/Drop" button, or
- Selecting the "Turn On Drag Drop" option    from the Edit menu, or
- Pressing the "T" key while the <Alt> key is depressed, or
- Pressing the F5 key. 
(The boxes that can be used with the Drag/Drop option will be highlighted in cyan and 

magenta.)
2. Position the cursor over the box containing the value to be dragged (copied) to another box.
3. Hold the mouse button down.    A hand icon will appear indicating the direction of the box(es) 

into which this value can be dropped.
4. While holding the mouse button down, drag the cursor to the new box.    When the cursor is 

positioned over a box that will accept the dragged value, the hand icon will point down.    (If 
the cursor is positioned over a box that will not accept the dragged value the hand ion will not 
point down.    If you release the mouse button when the hand icon is not pointing down the 
dragged value will disappear.)

5. Release the mouse button.    The dragged value will appear in the selected box, and the 
values in the corresponding boxes will be recalculated.    If all three boxes in the Boiling Point 
area are filled and a new value is dropped into one of the boxes, a dialog box will appear 
confirming which box will be recalculated.

6. The Drag/Drop option will remain active until it is deactivated by:
- Clicking the "Turn Off Drag/Drop" button, or
- Selecting the "Turn Off Drag Drop" option    from the Edit menu, or
- Pressing the "T" key while the <Alt> key is depressed, or
- Pressing the F5 key. 

The shortcut key for the Turn On (Off) Drag/Drop option is F5. 



WinDatCon Help Index
WinDatCon has extensive help available.    The Help Index can be accessed by selecting the WinDatCon 
Help Index option on the Help menu.

The shortcut key for the WinDatCon Help Index option is F1. 



Help on Help
The Help on Help option explains how to use the Microsoft Windows Help system.    WinDatCon Help 
uses this system.    This option can be accessed by selecting the Help on Help option on the Help menu.



About WinDatCon
The About WinDatCon option displays a dialog box containing version, copyright and registration 
information.    This option can be accessed by selecting the About WinDatCon option on the Help menu.

The shortcut key for the About WinDatCon option is Ctrl + A. 



Exit
This button closes the application.

The shortcut key for the Exit button is Ctrl + X. 



OK
This button executes the conversion.    Pressing the <Enter> key is equivalent to clicking the OK button.



Cancel
This button closes the Configure Program Launcher dialog box without executing or saving changes.



Done
This button closes the current conversion screen or dialog box.



Move Back
If the opening screen or one of the conversion screens has been moved to a new position within the 
application area, it can be moved back to the default position (in the top left of the application area) by 
clicking the Move Back button. 



Display Compound Groups

The Display Compound Groups Button displays a dialog box that contains eight Compound Groups.    The 
compound group number can be selected for use in the Boiling Point/Pressure calculation.

The boiling point of a pure compound is a function of the pressure of the system and the structural 
characteristics of the compound.    The boiling point at various pressures can be estimated using the 
technique described by S.B. Lippincott and M.M. Lyman (Industrial and Engineering Chemistry, Vol. 38, p. 
320, 1946).    In this paper a variety of materials were classified into eight compound groups based on 
similar responses of their boiling points as a function of pressure.    A nomograph was generated for each 
group.    These nomographs can be used to estimate the relationship between boiling point and pressure 
for compounds not classified.    WinDatCon calculates the same boiling point and pressure values that are 
generated from the nomographs. 

Choosing the correct Compound Group will give a more accurate calculation.    To determine which 
compound group should be used for the WinDatCon calculation:

- Select a group with compounds having similar physical and structural properties, or
- Calculate the values for Group 1 and Group 8 to get a range of possible values, or
- Use Group 4 (Default) to get an average value.

To select a Compound Group:
1. Edit the box containing the Compound Group number (allowed values are 1-8). 
2. Press the <Enter> key or click the OK button.    A dialog box will appear to confirm which 

value will be recalculated.
3. When the Yes button is clicked the value will be recalculated .

-or-
1. Click the Display Compound Groups button and a screen will appear displaying the specific 

compounds classified in Compound Groups 1-8 (the    current group will be highlighted in 
cyan).

2. Click the Help button if you would like more information about the Compound Groups.
3. Click a Compound Group box and it will become selected (this box will be highlighted in 

cyan).
4. When the Compound Group box you want is selected, click the OK button or press the 

<Enter> key.    You will return to the previous screen and the new Compound Group number 
will appear.    The last calculated value will be recalculated to reflect the selected Compound 
Group.



Shareware
DEFINITION OF SHAREWARE

Shareware distribution gives users a chance to try software before buying it. If you try a Shareware 
program and continue using it, you are expected to register. Individual programs differ in details -- some 
request registration while others require it, some specify a maximum trial period. With registration, you get 
anything from the simple right to continue using the software to an updated program with a printed 
manual.

Copyright laws apply to both Shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below. Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality. (In both cases, 
there are good programs and bad ones!) The main difference is the method of distribution. Vogel 
Scientific Software specifically grants the right to copy and distribute the software, either to all and sundry 
or to a specific group. For example, some authors require written permission before a commercial disk 
vendor may copy their Shareware.

Shareware is a distribution method, not a type of software. You should find software that suits your needs 
and pocketbook, whether it is commercial or Shareware. The Shareware system makes fitting your needs 
easier, because you can try before you buy. And because the overhead is low, prices are low also. 
Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't pay for it.

WinDatCon is a "Shareware program" and it is provided at no charge to the user for evaluation.    Feel 
free to share it with your friends, but please do not give it away altered or as part of another system.    The 
essence of "user-supported" software is to provide personal computer users with quality software without 
high prices, and yet to provide incentive for programmers to continue to develop new products.    If you 
find this program useful and find that you are using WinDatCon and continue to use WinDatCon after a 30 
day trial period, you must make a registration payment of $25 to Vogel Scientific Software.    The $25 
registration fee will license one copy for use on any one computer at any one time.    You must treat this 
software just like a book.    An example is that this software may be used by any number of people and 
may be moved freely from one computer location to another, so long as there is no possibility of it being 
used at one location while it's being used at another. Just as a book cannot be read by two different 
people at the same time.

Commercial users of WinDatCon must register and pay for their copies of WinDatCon within 30 days of 
first use or their license is withdrawn.    Site-License arrangements may be made by contacting Vogel 
Scientific Software.

Anyone distributing WinDatCon for any kind of remuneration must first contact Vogel Scientific Software 
for authorization. This authorization will be granted automatically to distributors recognized by the ASP as 
adhering to its guidelines for shareware distributors, and such distributors may begin offering WinDatCon 
immediately (however, Vogel Scientific Software still must be advised so that the distributor can be kept 
up-to-date with the latest version of WinDatCon).

You are encouraged to give a copy of WinDatCon to your friends for evaluation.    Please encourage them 
to register their copy if they find that they can use it.    All registered users will receive a copy of the latest 
version of the WinDatCon program.

This definition of Shareware is based on a definition provided by the Association of Shareware 
Professionals, originally prepared by Paul Mayer.    It resides in the ASP forum on Compuserve 
as:SHAREW.PRN.



How to Register WinDatCon
The easiest method of registering WinDatCon is to edit WinDCReg.TXT electronically.    This file is located 
in the WINDC directory.    WinDCReg.TXT is one of the files distributed with WinDatCon.    After the file is 
edited, it should be printed and sent with a check drawn on a US bank or money order for $25 (if you live 
in Minnesota add 6.5% ($1.63) sales tax) to:

Vogel Scientific Software
1199 Leeward Ave.
Lake Elmo, MN    55042

If you lack this form please send your check or money order to the above address with a letter containing 
the following information:

Full Name of Purchaser
Mailing Address of Purchaser
What disk size would you like (3.5"/720K or 5.25"/360K)?
Where did you get WinDatCon?
What version of WinDatCon do you have (see the About WinDatCon option on the Help menu)?

With registration you will get:
1. The latest version of WinDatCon on either a 3.5"/720K (default) or 5.25"/360K disk.
2. A registration number.
3. Support for 90 days by US Mail to the above address or via Compuserve mailbox 

(71302,3436).
4. An ASCII file equivalent of the on-line help file.
5. Notification of future updates.

Support for registered programs is guaranteed for 90 days from the date of registration.    If your problem 
cannot be resolved to your satisfaction your money will be refunded, as long as the problem was brought 
to our attention within the 90 day period after registration.

License Agreement:

This license gives the user the right to install and use one copy of WinDatCon.    If the user of a registered 
copy of WinDatCon is the PRIMARY USER of more than one machine (for example, one at work, one at 
home, and a laptop), a single license will cover all machines that are USED PRIMARILY by the registered 
user. 



Disclaimer
DISCLAIMER - AGREEMENT

Users of WinDatCon must accept this disclaimer of warranty: "WinDatCon is supplied as is.    Vogel 
Scientific Software disclaims all warranties, expressed or implied, including, without limitation, the 
warranties of merchantability and of fitness for any purpose. Vogel Scientific Software assumes no liability 
for damages, direct or consequential, which may result from the use of WinDatCon."

This disclaimer is provided by the Association of Shareware Professionals, originally prepared by Paul 
Mayer.    It resides in the ASP forum on Compuserve as:SHAREW.PRN.



Distribution Files

WinDatCon requires Windows 3.0 or greater, an EGA or VGA monitor, and 800 KB available disk space. 
This list constitutes a complete distribution package of WinDatCon:

WinDC.EXE WinDatCon executable file (needed to run WinDatCon; usually found in WinDC 
directory).

WDCHelp.HLP WinDatCon help file (needed to run WinDatCon; usually found in WinDC directory).
MDIChild.VBX VBX file for Multiple Document Interface Control (needed to run WinDatCon; can be 

found in c:\windows or c:\windows\system directory).
VER.DL_ Renamed VER.DLL on users disk, determines windows and system    directories and 

detects the versions of files stamped with a windows version stamp (needed to run 
WinDatCon; can be found in c:\windows or c:\windows\system directory).

VBRUN100.DL_ Renamed VBRUN100.DLL on users disk, Visual Basic run time file (needed to run 
WinDatCon; can be found in c:\windows or c:\windows\system directory).

WinDCREG.TXT WinDatCon Registration form.
WDCRead.TXT Instructions for WinDatCon installation.
FILE_ID.DIZ Description of WinDatCon.
SETUP.EXE Installation executable file for WinDatCon (needed to run WinDatCon Setup program; 

can be found on setup disk or directory).
SETUP1.EXE Second installation executable file for WinDatCon (needed to run WinDatCon Setup 

program; can be found on setup disk or directory).
SETUP.LST List of files used by setup (needed to run WinDatCon Setup program; can be found 

on setup disk or directory).
SETUPKIT.DL_ Renamed SETUPKIT.DLL on users disk (needed to run WinDatCon Setup program; 

can be found on setup disk or directory).

Please feel free to distribute WinDatCon to your friends.    To prepare a distribution copy the above files 
should be copied onto floppy disks.    These files will fit on one 1.44 MB disk, or two 720 KB disks, or three 
360 KB disks.    Use the following table to determine which files should be included on each disk.

File Name 1.44 MB 720 KB 360 KB

SETUP.EXE Disk1 Disk1 Disk1
SETUP1.EXE Disk1 Disk1 Disk1
SETUP.LST Disk1 Disk1 Disk1
SETUPKIT.DL_ Disk1 Disk1 Disk1
VER.DL_ Disk1 Disk1 Disk1
VBRUN100.DL_ Disk1 Disk1 Disk1

WinDC.EXE Disk1 Disk2 Disk2

WDCHelp.HLP Disk1 Disk2 Disk3
WinDCREG.TXT Disk1 Disk2 Disk3
WDCRead.TXT Disk1 Disk2 Disk3
FILE_ID.DIZ Disk1 Disk2 Disk3
MDIChild.VBX Disk1 Disk2 Disk3

Do not distribute WinDC.INI.    This file contains registration information.    Distribution of this file 
constitutes copyright infringement.    The distribution version will generate its own WinDC.INI file.



Focus

The object or text box that is receiving input from the mouse or the keyboard is said to have the focus.



Selected Text

Selected text is indicated by reverse video.    To select text:
1. Point the cursor at the beginning of the text to be selected.
2. Hold the mouse button down.
3. Drag the mouse across the text.

- or -
1. Point the cursor at the beginning of the text to be selected.
2. Hold the shift key down.
3. Use the arrow keys to move the cursor over the text.

To select a word, place the cursor on one letter of the word and double click.



BTUs

BTU is the abbreviation for British thermal unit.    One BTU is the quantity of heat required to raise the 
temperature of one pound avoirdupois of water one degree Fahrenheit at its maximum density of 39.1 
degrees F.

1 BTU = 1.055x10^3 joules = 252 calories



Foot-Pounds

A foot -pound is a unit of work in the fps system equal to the work done by a pound-force acting through a 
distance of one foot in the direction of the force.

1 foot-pound    = 0.00128509 BTUs = 0.324048 calories = 1.35582x10^7 ergs



Hp.-Hours

Hp-Hours is the abbreviation for Horsepower-Hours.    One horsepower hour is the work performed or 
energy consumed by working at the rate of one horsepower for one hour.

1 Hp-hour = 2546.14 BTUs = 6.41616x10^5 calories = 2.68452x10^6 joules.



Calories

One calorie is the energy needed to raise one gram of water one degree centigrade at 15 degrees 
centigrade.

1 calorie = 4.184 joules = 0.00397 BTUs



Ergs

An erg is a unit of work in the cgs system.    One erg is the unit of work done by a force of one dyne acting 
through a displacement of one centimeter in the direction of the force.

1 erg =    1.0x10^-7 joules = 2.39x10^-8 calories



Millijoules

1 millijoule = 1/1000 joules.



Joules

A joule is the absolute mks system unit of work or energy.

1 joule = 9.99997x10^6 ergs = 0.239 calories



Kw.-Hours

Kw.-Hours is the abbreviation for Kilowatt-Hours.    One Kw.-hour (kilowatt-hour) is the work done by one 
kilowatt of power in one hour.

1 Kw-hour = 3.6x10^6 joules



Liter-atmospheres

1 liter-atmosphere = 101.328 joules



Watt-hours

A watt-hour is a unit of work or energy equivalent to the power of one watt operating for one hour.

1 watt-hour = 3600 joules



Kilocalories

1 kilocalorie = 1000 calories



Kilogram-meters

A kilogram-meter a unit in the mks system.    One kilogram-meter is the gravitational unit of work and 
energy equal to the work done by a kilogram force acting through a distance of one meter in the direction 
of the force.

1 kilogram-meter = 9.80665 joules



Mils

1 mil = 1/1000 inch



Inches

1 inch = 1/12 foot = 1/36 yard



Feet

1 foot = 12 inches = 1/3 yard



Yards

A yard is a unit of length in the fps system.

1 yard = 3 feet



Miles

1 mile = 5,280 feet



Kilometers

A kilometer is a metric unit of length.

1 kilometer = 1,000 meters



Centimeters

1 centimeter = 1/100 meter



Meters

A meter is the basic metric unit of length.

1 meter = 39.37 inches



Angstroms

1 angstrom = 10^-10 meters



Nanometers

1 nanometer = 10^-9 meters



Microns

1 micron = 10^-6 meters



Millimeters

A millimeter is a metric unit of length.

1 millimeter = 10^-3 meters



Degrees C

Degrees C refers to the Centigrade (or Celsius) temperature scale.    The freezing point of water is 0 
degrees centigrade, the boiling point of water is 100 degrees centigrade.    One degree centigrade is 
1/100th the difference between the temperature change from the point at which ice melts to the point at 
which water boils, under standard atmospheric pressure.



Degrees F

Degrees F refers to the Fahrenheit temperature scale.    The freezing point of water is 32 degrees 
Fahrenheit, the boiling point of water is 212 degrees Fahrenheit.    One degree Fahrenheit is 1/180th the 
difference between the temperature change from the point at which ice melts to the point at which water 
boils, under standard atmospheric pressure.



Degrees K

Degrees K refers to the Kelvin temperature scale.    It is the fundamental temperature scale (absolute 
thermodynamic).    Zero degrees Kelvin is equal to    -273.15 degrees C.    One degree Kelvin is one 
hundredth the difference between the temperature change from the point at which ice melts and water 
boils under standard atmospheric pressure.



Atmospheres

An atmosphere is a unit of pressure equal to the pressure exerted by a vertical column of mercury 76 
centimeters high, at a temperature of zero degrees centigrade, and under standard gravity.

1 atmosphere = 760 torr



mmHg

The mm Hg unit is the abbreviation for millimeters of mercury.    This unit corresponds to the pressure 
produced by a column of mercury the height of which is measured in millimeters.    This unit is equivalent 
to the torr. 

1 mmHg    = 1.0 torr = 1/760 atmospheres.



PSI

PSI is the abbreviation for pounds per square inch. 
1 PSI = 0.0680 atmospheres



Bars

1 bar = 10^6 dynes/sq cm = 10^5 newtons/sq m



Pascals

1 pascal = 1 newton/sq m



Boiling Point

This box displays the boiling point of a liquid (in degrees centigrade) at the specified pressure.



Pressure

This box displays the pressure of a system (in mm Hg) at the specified boiling point.



Boiling Point at 760 mm

This box displays the boiling point of a liquid (in degrees centigrade) at atmospheric pressure (one 
atmosphere; 760 mmHg).



Drops

Drops is an approximate measure of the number of drops in a given volume.    This calculation is based 
on 20 drops per mL.    This is an approximate value because the volume of a drop depends on the 
properties of the liquid and the dropper.



Teaspoons

1 teaspoon = 1/3 tablespoon



Tablespoons

1 tablespoon = 3 teaspoon



Cups

1 cup = 1/2 pint



Pints

1 pint = 1/2 quart



Quarts

1 quart = 1/4 gallon



Gallons

A gallon is a unit of liquid capacity used in the U.S., equivalent to the volume occupied by 8.3359 pounds 
of distilled water weighed in dry air with both water and air at 4 degrees centigrade against brass weights 
of 8.4 density with the barometer at 30 inches.

1 gallon = 231 cubic inches



Fluid ounces

A fluid ounce is a unit of volume or capacity in the U.S. Customary System, used in liquid measure.

1 fluid ounce = 1.804 cubic inches



Cubic Inches

A cubic inch is a unit of volume equal to a cube one inch long on each side.

1 cubic inch = 1/1728 cubic feet



Cubic Feet

A cubic foot is a unit of volume equal to a cube one foot long on each side.

1 cubic foot = 1728 cubic inches



Cubic Yards

A cubic yard is a unit of volume equal to a cube one yard long on each side.

1 cubic yard = 27 cubic feet



Board Feet

A board foot is a unit of lumber equal to a volume of 12x12x1 inches (144 cubic inches).



Microliters

1 microliter = 10^-6 liters



Milliliters

A milliliter is a metric unit of capacity equal to the volume occupied by one gram of water at 4 degrees 
centigrade and 760 mmHg.
.

1 milliliter = 10^-3 liters = 1.00003 cubic centimeters



Liters

A liter is the metric unit of capacity equal to the volume occupied by one kilogram of water at 4 degrees 
centigrade and 760 mmHg.

1 liter = 1000 milliliters = 1.000028 cubic decimeters



Cubic Centimeters

A cubic centimeter is a volume equal to a cube one centimeter long on each side.

1 cubic centimeter = 9.99972x10^-4 liters = 0.999972 milliliters



Drams

A dram is an avoirdupoisunit.

1 dram = 1.77185 grams



Ounces

1 ounce = 1/16 pound (avoirdupois)= 28.3495 grams



Pounds

A pound is a unit of weight in general use among English speaking peoples.    It is also called avoirdupois 
pound.

1 pound = 16 ounces



Tons

This ton unit is also known as a short ton.

1 ton = 2000 pounds



Carats

A carat is a unit of weight for precious stones.

1 carat = 0.2 grams



Grams

A gram is a metric unit of mass and weight equal to the weight of one cubic centimeter of water at its 
maximum density.

1 gram = 0.035274 ounces



Kilograms

A kilogram is the basic metric unit of mass and weight equal to 1000 cubic centimeters of water at the 
temperature of its maximum density.

1 kilogram = 1000 grams



Metric Tons

1 metric ton = 1000 kilograms = 2,204,6 pounds (avoirdupois)



Milligrams

A milligram is a metric unit of mass and weight.

1 milligram = 10^-3 grams



Stones

A stone is an official British unit.

1 stone = 14 pounds



Grains

A grain is a unit of weight based on the weight of a grain of wheat taken as an average weight of grains 
from the middle of the ear.

1 grain = 0.06479891 grams



Micrograms

1 microgram = 10^-6 grams



Avoirdupois

Avoirdupois is a system of weights and measures based on a pound containing 16 ounces or 7,000 
grains and equal to 453.59 grams.



mks system

The mks system is a system of units based on the meter as the unit of length, the kilogram as the unit of 
mass and the second as the unit of time. 



fps system

The fps system is a system of units based on the foot as the unit of length, the pound (avoirdupois) as the 
unit of mass and the second as the unit of time. 



cgs system

The cgs system is a system of units based on the centimeter as the unit of length, the gram as the unit of 
mass and the mean solar second as the unit of time.




