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WELCOME
to 

 

emagic

 

’s

Demo Version

 

This is a short introduction to LOGIC Audio, which will help you check
out and enjoy your Demo Version.

It is not ment to replace the complete manual or online help. It will,
however, let you get started quickly with LOGIC Audio, even if you are
not so familiar with MIDI and Audio recording.

We know that you will have lots of fun using LOGIC Audio!

The 

 

emagic

 

 Team

 

 

This document was created by EMAGIC GmbH



 

  

2

 

emagic

 

1.  MIDI Setup

 

This section contains some useful information for people unfamiliar
with sequencing software. If you are confident with the basic MIDI Set-
up when using computers and MIDI instruments, you can skip this and
go straight with section 2.

 

1.1 The “MIDI Thru Problem”

 

If you are using a master keyboard with no sound generation of its own
the situation is straightforward. When you select a track in the se-
quencer, either for practicing or recording, the MIDI data generated by
the master keyboard must be diverted to the MIDI input of the compu-
ter. The MIDI channel information must therefore be altered and re-
placed by the channel setting of the relevant track. This means that if
you change to another track (with a different MIDI channel setting) you
immediately hear the sound of the sound module receiving on this
channel which is the sound you eventually want to record on this track.
The problem arises when you are recording from a keyboard that has
a built-in synthesizer which you actually want to use (if you don’t want
to use the built-in synthesizer just turn the volume down).

Of course when you play such a keyboard, especially if it is not connect-
ed to a computer, you expect to hear a sound as soon as you press a
key. This is done by transmitting the MIDI information from the built-
in keyboard directly to the built-in synthesizer.

However, in our computer setup this means that when you are record-
ing you will hear not only the intended sound but also the internal syn-
thesizer. Even if you want to record the internal synthesizer on this
track this causes problems because while you are recording you will
hear the notes played double. The note information is heard once di-
rectly and once diverted through the computer. This halves the
number of voices and produces a peculiar flanging effect.
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Local Off

 

To avoid this problem practically every keyboard with a built-in synthe-
sizer has a parameter called “Local” or more fully “Local Control”(usu-
ally in the MIDI or Utility page, if in doubt consult the keyboard’s man-
ual). This parameter has two possible values: “On” or “Off” which refers
to the internal connection between the keyboard and the synthesizer.

When using an external sequencer like LOGIC you should always switch
this parameter to 

 

Off

 

. This means that the keyboard and the internal
synthesizer behave like two separate devices. On many synthesizers
this parameter is automatically set to “On” whenever you turn it on, so
unfortunately every time you turn the device on you have to switch the
“Local Control” parameter to “Off”. If you have a synthesizer which
stores the setting of this parameter, the next time you feel a spontane-
ous live gig coming on you’ll need to be able to switch “Local Control”
back on again. So before you read on, have a look where this parameter
is on your device and make sure you can remember how to find it - I’ll
just wait until you’re ready.

Incidentally, “Local Control” can be switched on and off using control-
ler #122 (value 127 = On, value 0 = Off).
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2.  MIDI Crash Course

 

Welcome to the LOGIC crash course!

The first section contains a few you tips on how to get your system “up
and running”. Once you have managed to do that the most difficult
part is over! You can then go straight to Chapter 

 

First Round Trip

 

 on
page 3 - 5.

Chapter 

 

Second Round Trip

 

 on page 3 - 23 is an extension of the crash
course which gives LOGIC beginners or “converts” from other pro-
grams more information on options and working methods. If you can’t
or won’t read the whole manual this section gives you the most con-
cise description of LOGIC’s functions plus references to sections of the
printed manual where you can get more details. Allow a few hours for
the whole course. The best approach is to read the book with the com-
puter in front of you. If you can’t do that you can also work through the
course “dry”.

 

2.1 How does it Work?

 

We are assuming that you have already made the necessary audio and
MIDI connections for your system. If not, please see the chapter deal-
ing with 

 

Installation

 

 on page 1.

In this chapter and the tutorial song it is assumed that there is a MIDI
interface connected. There should be a multitimbral sound generator
connected to this MIDI interface and if possible this should comply to
the GM standard (although it doesn’t have to!) Alternatively you can
use a properly installed sound card.

 

Loading the Tutorial Song

 

Start LOGIC and load the supplied tutorial song. You can do both
things simultaneously by double-clicking the tutorial song icon:

If LOGIC was already started you must first close the untitled song by
choosing 

 

Close

 

 from the 

 

File

 

 main menu (from now on this will be re-
ferred to as simply 

 

File > Close

 

). A dialog box appears asking you
whether you want to save the song first; answer with “Don´t Save”,
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then choose 

 

File > Open

 

. A file selection box appears where you can
open the tutorial song. 

A fundamental concept essential to working with sequencers is MIDI
Thru. Please refer to Chapter 

 

MIDI Thru Problems

 

 on page 1 - 11 and the
following section 

 

Local Off

 

 on page 12.

If you are using a keyboard switched to local off or a master keyboard
please refer to Chapter 

 

Situation

 

 on page 3 - 3.

If you are using a multitimbral keyboard, go to the MIDI menu and set
a transmit channel or TX Ch which is not being used by any of the sound
generating sub channels as a receive channel. This is equivalent to the
local off function, because you will then not be able to play the internal
sound generator directly. See Chapter 

 

Situation

 

 on page 3 - 3.

 

Switching off Midi Thru

 

If you are using a monotimbral master keyboard controller, switch it to
omni off. If it cannot be switched to local off and you want to use the
internal sound generation you need to set up LOGIC so that events will

 

not

 

 be routed through to the MIDI channel of your synthesizer.

Choose 

 

Song Settings

 

 from LOGIC’s 

 

File

 

 main menu

 

.

 

A dialog window appears where it should say 

 

MIDI Options

 

 in the
frame at the top. If it doesn’t click this frame and hold down the mouse
button. A menu appears where you can choose 

 

MIDI Options

 

.

You will then see the following window:
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The mouse pointer is on a field above which it says 

 

Instrument without
MIDI Thru function

 

. Click this field and hold down the mouse button. A
menu appears where you choose the item that corresponds to the
MIDI transmit channel of your synthesizer (1-16).

 

Situation

 

Once you have established the situation described in the next few par-
agraphs you can proceed directly to Chapter 

 

First Round Trip

 

 on page
3 - 5:

• When you play notes you should see a display of the incoming
notes in the top right of the transport window (where it says “No
In” in the diagram below).

If no notes are displayed check the MIDI connection between the
keyboard and the interface and the serial cable between the inter-
face and the computer. Is everything switched on and has every-
thing been installed correctly? Check the instructions in the
interface manual. Have you loaded the tutorial song?

• By selecting the different tracks in the track list shown in the dia-
gram by clicking the icon or using the cursor keys (arrow keys 

 

I

 

or 

 

M

 

) you should be able to play all the different sounds on your
sound generator(s).

Your sound generator must be in multi mode, which depending on the
manufacturer/device is probably called combination, “super” mode or
multitimbral mode. On some workstations the mode for the internal
sequencer must be activated. Refer to the manufacturer’s manual. The
different sounds should be set to different channels.
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2.2 First Round Trip

 

Section 1

 

Once you have loaded the tutorial song you should be able to see this
window:

If you have connected a GM sound generator all the sounds will already
be correctly set. If you haven’t, use the following sounds shown on the
channels given below:

Cha Sound Cha Sound

1 Moog bass 2 Marimba

3 Mute guitar 4 Brass or trombone

5 Synth voices 6 “Ah” choir

7 Steel drums 8 Hammond B3

9 Pizzicato violins 10 Dry drum kit

11 Cello 12 Viola
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Don’t spend too much time searching for the exact sounds. The tuto-
rial song should merely enable you to concentrate fully on learning the
program instead of writing your own music. There will plenty of time
for that later!

The Drum Sounds:

 

Start!

 

To start the song click the play button in the transport window. You
can also use the 

 

=

 

 key on the number pad of the computer keyboard.

When the song is running you will see a vertical line moving from left
to right across screen. This is the song position line.

To stop the song click the stop button in the transport window or use
the 

 

‰

 

 key in the bottom right of the number pad.

If you click the stop button again when the sequencer is stopped the
song position line is reset to the song start.

 

Sequences and Tracks

 

The grey horizontal beams with labels are s

 

equences

 

. These are where
MIDI notes were recorded as the song position line passed over them.
Each of the horizontal lines containing the sequences is called a track.

 

Selecting Tracks

 

You select a track by clicking with the mouse on the icon or on the
name of the track instrument.

Whenever you play notes on your MIDI keyboard you will hear the
sound of the selected track. Try this out on different tracks.

Note Sound Note Sound

B0 Pounding bass drum C#2 Crash cymbal

C1 Dry bass drum D#2 Ride cymbal

D1 Hard brush snare F2 Ride bell

F#1 Closed hi hat G2 Splash cymbal

G#1 Pedal hi hat A4 Woodblock

A#1 Open hi hat
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The track determines not only which sound you can currently play, but
also which sound is played by the sequences on this “line”. Click the

 

marimba 

 

sequence at the beginning of the second track and hold
down the mouse button (this is referred to throughout the manual as
“grabbing”. The mouse pointer will then turn into a little hand.) Drag
this sequence onto track 9 (the track number is shown on the far left)
whose track instrument is 

 

Steel Drums

 

.

Leave the sequencer running. You will immediately hear the difference
in the sound played by this ostinato sequence.

Don’t touch the row of gray beams with no writing on them to the right
of the sequence. These are known as loops, i.e. automatic repeats of
this sequence until the next sequence on the same track. Just click the
loop parameter in the sequence parameter box (top left).

This allows you to turn the loop function on and off. Click some of the
other sequences. You will then be able to see their respective parame-
ter boxes and change their loop parameters, if necessary.

Now move the 

 

marimba 

 

sequence back to track 2.

 

Instrument

 

You now know that the sound of a sequence depends on which track
the sequence is played on. This is because for each track there is a dif-
ferent i

 

nstrument

 

 set in the track list. This is shown in the track list by
an icon and a name, for example:

The i

 

nstrument

 

 determines which MIDI channel and MIDI output the
MIDI events on this track are sent to. In a way it therefore represents a
module (“part”) in your multitimbral sound generator. The track list
shows the Midi channel number.

The most important question now is how can the sound of an instru-
ment be changed without having to reset the program number manu-
ally on the sound generator?

 

Changing the Sound of an Instrument

 

First select a track, e.g. track 16 (instrument 

 

Organ3

 

: 

 

)

 

.
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You will now be able to see the relevant

 

 instrument parameter box 

 

in
the bottom left of the screen.

If you can’t see the whole instrument parameter box use this little
trick: click the triangle in the top left of the 

 

sequence parameter box

 

.
This is the box in the top left corner of the screen.

This closes the sequence parameter box and the elements in the pa-
rameter box below it move upwards.

If you are using a 15” (or larger) monitor you should be able to see all
the boxes on the left side simultaneously.

Now play a few notes on your master keyboard. If you can’t hear any
sound your sound module is not receiving on channel 8. Select a track
with a different instrument or set your sound generator to receive on
channel 8.

Now click the 

 

Prg

 

 line in the instrument parameter box as shown in the
diagram and hold down the mouse button. The following flip menu ap-
pears (don’t get scared and let go of the mouse button!).

Keep the mouse button held down and move the mouse up or down.
Then release the mouse button. If you have connected a GM sound
generator you should now be able to hear the corresponding sound
when you play your keyboard.

You can also use the 

 



 

 and 

 

_

 

 keys to alter the most recently changed
parameter in single units. Try this now on the sound program num-
bers!

 

Adjusting the volume of an instrument

 

You can also use the instrument parameter box to set the volume of an
instrument.
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Click the number in the 

 

Vol

 

 line and move the mouse up and down
while keeping the mouse button held down. This method of inputting
is known as “mouse as slider”. If you play the keyboard whilst doing this
you will be able to hear the difference.

There should be a cross in the checkbox. Alternatively, you can prese-
lect a value and then send it by placing a cross in the checkbox.

 

The concept of an Instrument

 

Changing the program number or volume affects the behaviour of the
entire synthesizer, (or of that particular part in a multitimbral synthe-
sizer).

It is therefore not possible to play a single channel in a sound module
using different tracks set to different sounds or volumes.

For this reason, these parameters in LOGIC are assigned not to a track,
but to an “instrument”, which is in turn assigned to a track.
Thus every LOGIC instrument is directly related to one of your sound
modules.

If you alter the instrument parameters, this affects all tracks which are
being played via that instrument.

 

Assigning an Instrument to a Track

 

To assign a different instrument to a track grab the icon or name of the
instrument in the track list. If you keep the mouse button held down a
flip menu appears where you can set a different instrument. Try this
out with instrument 

 

Choir Aahs

 

 on track 6.

Choose another item and release the mouse button. The whole of track
6 will then be played by another channel of your sound module. Chan-
nels 14 to 16 are not yet being used in the Tutorial Song.

 

Movement!

 

The transport functions (from left to right): RECORD, PAUSE, START,
STOP, REWIND and FAST FORWARD will already be familiar to you.

As with a tape deck, if you rewind or forward while in PLAY mode you
can hear the track. By grabbing these buttons with the mouse button
held down and moving it horizontally you can vary the speed and direc-
tion.
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Song Position

 

The current song position is shown to the right of the row of buttons
with the time above and the bar position below. The bar position is di-
vided into bars, beats (equivalent to the denominator of the time sig-
nature), sixteenth notes (or some other adjustable format value) and
ticks (1/3840 notes).

You can also set the song position directly by clicking the lower part of
the bar ruler:

Double-clicking it allows you to toggle between STOP and PLAY.

The names in the bar ruler (intro, part A, etc.) are called markers. If you
click the bottom part of the bar ruler with the right mouse button the
song position line is set to the start of the marker.

Try playing with some of these functions. See what happens when you
hold down the mouse button with the sequencer running and move
the mouse horizontally in the bar ruler.

 

Cycle

 

You may have already tried clicking in the top part of the bar ruler. This
is where you define the cycle region which is a section of the song that
is constantly repeated. It is very useful for composing and editing.

Suppose you want to edit the section of the song called B1. Click the
“B1” marker, hold down the mouse button and move the mouse up-
wards. Then release the mouse button.
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You don’t have to stop the sequencer to alter the cycle. Once the song
position line reaches the end of the cycle region it jumps back to the
start.

To set the cycle region without using the markers click the top part of
the bar ruler at the start or end point and drag out the region to the left
or right. Then release the mouse button.

You can alter the limits of the cycle region using the same method. Just
grab the cycle beam in the bottom half near one of the limits.

If you grab the cycle beam near the top or middle you can move the
whole region without altering its length.

Clicking anywhere in the top half of the bar ruler turns the cycle on and
off.
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You can carry out the same function using the cycle button in the
transport window.

The start and end of the cycle region is shown below the song position
display:

You can also enter or alter the positions here. The two positions are
known as the left and right locators.

Spend a bit of time experimenting with the cycle functions.

 

Selection

 

Selecting sequences means preparing them for editing by clicking
them. This has to be done before you can carry out any kind of editing. 

• “Rubber band selection” selects all sequences within a frame that
you drag out with the mouse button held down. Normally you
start dragging out the rubber band at an empty point where there
are no sequences. However, if there is no empty space in the back-
ground you can also begin dragging on a sequence by holding
down the 

 

S

 

 key.

• You can select more sequences by clicking them while holding
down the 

 

S

 

 key. In fact (as with rubber band selection) this tog-
gles the selection status.

• When you select a track all the sequences on the track are selected
too.

• There are also a few functions in the bottom part of the Edit menu
for selecting according to specific criteria. The most important is:

 

Select All

 

 (or 

 

√a

 

).

Click the background to get rid of the current selection.

 

Toolbox

 

The toolbox is located between the sequence and instrument parame-
ter boxes:
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You can select different tools by clicking them. They all have different
effects when you click sequences with them. More details will be given
later in the course.

 

Solo

 

Set the cycle around part B1. Click the solo button in the transport win-
dow.

Initially you won’t hear anything, even with the sequencer running. Se-
lect the “Bass”, “Marimba” and “MuteGit” sequences with the 

 

S

 

 but-
ton held down.

In solo status only the selected sequences are played. Click the solo
button again to switch the solo function off.

 

Mute

 

Select the mute tool from the toolbox. This allows you to mute individ-
ual sequences (or all selected sequences). Alternatively you can use a
key command (preset: 

 

√_

 

 in the numeric keypad).

To mute a whole track you have to use a special tool. Move the mouse
to the left of the track number where you can see the small monitor dis-
play. You can mute the track (or remove a mute) by clicking here with
the mouse.

Try muting track number 10 (instrument 

 

Organ3

 

) containing the “Or-
gan Solo”.

You can then play a much better solo on your keyboard.

 

Section 2

 

You are probably eager to record your vastly superior solo!

Creating a New Track
Choose Track from the Structure menu. Move the mouse pointer to
the right onto the Create item in the pulldown menu. Then click the
mouse button.

You have now been formally introduced to LOGIC’s hierarchical menus.
From now on choosing menu items like this will be referred to as
Structure > Track > Create.
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A new track with the same instrument will have been created under
the track with the old solo. The new track will already be selected so
you are ready to go. You can also create a new track by double-clicking
in the white area below the track list; this will be assigned the last se-
lected instrument.

If you want to record a section of the solo in cycle mode (or mute other
tracks so you can use a few harmonies), no problem.

Record

Press the record button or the multiplication sign key in the top right
of the number pad on the computer keyboard.

To delete an unwanted recording and simultaneously begin recording
again just press the same key.

You can go into and out of record with the sequencer running by using
the Record Toggle function (V key).

If you have recorded a few new tracks with solos on them they may
look something like this:

Some parts will be better than others. If would be nice if you could edit
the good bits together.

But first:

Saving a Song!

After a good recording or successful edit it is a good idea to save the
song.

The first time you do this choose File > Save as. You can enter a new
name under which the song is saved.

From then on you can save the song just by choosing File > Save or
pressing √s (without entering a name).

If you make a bad mistake you can call up the most recently saved ver-
sion by choosing File > Revert to Saved.
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Deleting

Use the eraser tool – or the B (backspace) key – to delete any sequenc-
es that are not required. Be careful! Clicking a selected sequence with
this tool deletes all the other selected sequences as well. To delete an
individual sequence first click in the background to deselect all the oth-
er sequences.

However, this function has its uses. For example, you can select all mut-
ed sequences by choosing Edit > Select Muted Sequences and then
delete all these sequences with a single click.

Undo

If you decide that you want to keep the deleted sequences after all, you
can reinstate them (as with any other unintentional function) with the
help of the Edit > Undo function.

Cutting

Click the scissors. The mouse pointer turns into a pair of scissors which
you can use to cut the sequences. 

Click one of the solos and hold down the mouse button. As you move
the mouse horizontally you can see its exact position in the top of the
window. The notes are also output as the mouse travels over them.

Once you have found the exact cutting position release the mouse but-
ton.

You can now cut the organ solos into several sequences. As you do so
all the selected sequences will be cut at the chosen point. If you hold
down the S key you can make multiple selections with the scissors as
well!
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Joining
To merge cut sequences, select the relevant parts and click with the
glue tool.

Copying Sequences
If you hold down the √ key while grabbing and moving sequences
the sequences will be copied instead of moved (just like copying files
in the Finder).

Altering Names
To edit the name of a selected sequence just click the top line of the
sequence parameter box. An input field appears:

Type in the name on the computer keyboard and press the R key.

Alternatively you can enter a name by directly clicking the sequences
with the text marker.

Altering the length
If you want to remove some notes from the end of a sequence, there
is an easier way of doing this rather than cutting the sequence and
muting the last part: just grab the bottom right corner of the sequence
and move the end to the left.

If you then use the same method to lengthen the sequence again, the
notes in the last part will be played again.
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Note: if you hold down √ while you adjust the length of the sequence
all events in the sequence will be time-stretched (or squashed)!

Quantizing

Quantization allows you to rhythmically correct any loosely played
notes. Select any organ riff with suspect timing. Click the small triangle
in the top left to open the sequence parameter box again.

In the second line is the Qua (quantization) parameter. Next to it you
can see off (3840). If you click this field (and hold down the mouse but-
ton) a flip menu opens (don’t be alarmed). This is where you define the
quantization grid. Experiment with it for a while. You can revert to the
original recording at any time by choosing the bottom item: off (3840).

To check the effect of the quantization function choose Functions >
Set Locators by Objects (S») and the locator points will be set so
that the cycle region matches the selected sequence (or several select-
ed sequences). Switch on cycle mode and start the sequencer.

All the key commands can be reassigned to different keys. See Chapter
Keyboard and MIDI Remote Operation on page 4 - 18.

Transposition

Another option in the sequence parameter box is transposition. First
select all sequences either by choosing Edit > Select All or by pressing
√a.

The sequence parameter box in the top left should now look like this:

Instead of showing the sequence name the top line now shows the
number of selected sequences.

You will notice asterisks next to some parameter values. This means
that these parameters are set differently in the selected sequences.

Right now we are more interested in the Transpose parameter. Click the
point shown in the diagram and use the mouse as slider.

When the number “2” appears release the mouse button. Start the se-
quencer and you will immediately hear the difference. The whole song
has been transposed down by one semitone.

It may be easier to play a solo in this key. You can always transpose the
song back again (if only it was this easy with a singer!). 
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Altering the Display
On small screens you often need more space for the actual working ar-
ea of the window. By choosing View > Hide/Show Parameter you
can remove/restore the whole parameter area on the left.

The zoom of the display can be altered using the two telescopes in the
top left corner of the window. The telescope with the downwards-
pointing arrow is for vertical zooming and the one with the right-point-
ing arrow is for horizontal zooming.

Click either telescope at the small end to shrink the display or at the
large end to enlarge the display.

Try experimenting with the telescopes for a while.

You can move the window section in the usual way using the scroll bars
on the right and lower edges of the window.

Editing Notes
LOGIC has various Editor windows for editing notes.

Matrix Editor
The display of the Matrix Editor is very similar to the Arrange window.
The difference is that individual notes are displayed instead of se-
quences.

Select the “MuteGit” sequence in song part B1. Then open the Matrix
Editor by choosing Window > Open Matrix Edit… . It should look
something like this:

On the left side you will see a vertical keyboard indicating the pitch of
the notes. At the top is the familiar bar ruler where you can also set cy-
cle regions.
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The note beams can be edited in practically the same way as the se-
quences in the Arrange window:

• Making selections,
• Moving,
• Copying (moving with the √ key held down),
• Altering the length (grab at the bottom right corner, you can use

the index finger tool to adjust just the length),
• Adding notes (with the pencil tool you can preset the length and

velocity of added notes by clicking a “model note” first).

In addition the velocity is indicated by a horizontal line and by the color.

• You can use the crosshair tool (with the mouse as slider) to alter
the velocity of the notes.

For length alteration the Functions menu also contains two special-
ized functions; Note Overlap Correction (shortens the selected
notes by enough to remove any overlaps) and Note Force Legato
(lengthens the selected notes so that each one sustains right up to the
beginning of the next, creating a legato effect).

Score Editor
The Score Editor displays notes in normal notation. It not only allows
you to edit MIDI notes but also offers many functions for preparing a
musical score.

To open the Score Editor double-click a sequence or choose Window >
Open Score Edit….

The diagram shows the “Bass” sequence from the song part “B1”.

Score Style

The basic parameters of the note display are defined by the Score Style.
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If you click the display parameter box at the point shown a flip menu
opens where you can choose from the most common styles. Bass and
Treble refer to a stave with a bass or treble clef. Piano refers to the usu-
al piano notation in two staves. You can alter the score style by double-
clicking.

When you record a sequence the score style defined in the bottom line
of the instrument parameter box will be chosen automatically:

If Auto was set here (as shown) a suitable score style will be selected
based on the recorded notes.

Key Signature
To enter the correct key signature, first click the sharp/flat sign in the
part box as shown.

Below is a selection of all the keys. Grab the correct key and drag the
mouse to the beginning of the stave.

You can alter the clef by double-clicking it.

Event List
The Event List shows all the recorded events, not just the notes.

Open the Event List by double-clicking the “Pizza” sequence in song
part B3.

This sequence contains not just notes but also control change events
with the number 7. These control the volume of the pizzicato violins.
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On the left are several buttons which allow you to remove the various
event types from the display. Click the button in the top left with the
note symbol on it:

Immediately the display of the note events is removed.

• Select all visible events by pressing √a (select all).
• Delete the controller events with the B key.

Now restore the display of the note events by clicking the note button
again. The sequence will then contain only note events.

By clicking the button with the pencil (or with the right mouse button)
you can add an event of the relevant type at the current song position.

For example, this button stands for program change events.

You can alter every detail of every recorded event in the event list (us-
ing the mouse as slider).

To select several events with the rubber band you have to begin draw-
ing out the frame in the status column, otherwise in the other columns
you will alter the parameter values instead.

You can alter the values of many selected events simultaneously with-
out loosing their relations. If you want to change further while a value
“bumps into” its range limits, push ç. To bring all parameters on the
same value hold ç and S.

To remove all selections click -Start of Event List- or -End of Event List-.
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2.3 Second Round Trip

Arranging
To alter the layout of the tracks move the mouse near to the track
number. The mouse pointer turns into a hand which you can then use
to grab the track and move it vertically to a new position in the track
list.

To remove a complete part from a song or add more (empty) bars use
the cut/insert time functions. Refer to Chapter Adding or Removing
Passages on page 6 - 53.

Alias
If you want to use the same sequence at several points in the song you
can create aliases of this sequence. When you move the sequence in-
stead of holding down just the √ key as you do with normal copying,
hold down both the √ and S keys. An alias appears in orange color.
It always follows the original sequence even if this is altered. For details
see Chapter Alias on page 6 - 26.

Folder
Turn on the solo function in the transport window. Now double-click
the beam labelled “Drums” near the front of the tutorial song.

You are now in a folder containing the bass drum, snare and hi hat se-
quences. If you start LOGIC in this song section you will be able to hear
all the drums in solo.

In this folder you can carry out practically all the same functions as in
the arrange level, such as recording.

The bar ruler shows the start and end of the folder. If the loop se-
quence parameter is switched on in a folder the repeats stretch to the
end of the folder, even if you alter the folder length at the arrange level.
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To return to the higher arrange level double-click the background.

Here you can treat the folder almost like a sequence, i.e. cut it or alter
its length, etc. Folders allow you to gather together associated groups
of sequences from any tracks to make the arrangement clearer.

For more details on folders see Chapter Folder on page 6 - 24.

Markers

Markers have already been mentioned in the crash course in conjunc-
tion with setting a cycle, but markers do far more than describe the
song section in the bar ruler. You can use them to write things at spe-
cific song positions in a specialized marker text window. 

You can also use markers as named locator positions in the marker list
window. Switch to Screenset no. 4 in the Tutorial Song (by pressing the
$ key in the main block of the computer keyboard) and start playback.

To the right of the Arrange window you will see the Marker List window.
containing the names of the markers from the bar ruler. Click one of
these markers. The song position immediately jumps to the relevant
marker.

Now switch on the cycle function. If you click the markers in the Marker
List window you will see how the markers can be used to store locator
positions.

For details on markers see Chapter Markers on page 6 - 28.

Trash

All sequences which you have deleted while editing a song are not ac-
tually thrown away but are collected in LOGIC‘s own wastebasket. You
can open this wastebasket by choosing Structure > Trash > Open
Trash. You can drag the sequences from here back into the Arrange
window. For details see Chapter Retrieving Deleted Sequences on page
6 - 8.

Quantization
You already know how to quantize a sequence and revert to the origi-
nal.

If you require different quantization grids in different sections of a se-
quence just cut the sequence and set the desired grid in each se-
quence. If you then join the parts back up again the different quantiza-
tions will be retained.
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Choosing Functions > Sequence/Instrument Parameters > Fix
Quantize fixes the quantized positions, i.e. these are stored instead of
the original positions (see Chapter Fixing the Quantization on page 6 -
21).

For details on quantizing notes see Chapter Quantization on page 6 -
19. For details on quantizing other event types see Chapter Event
Quantization on page 8 - 6.

Grooves
It is possible to define the timing of a particularly successful recording
as a quantization grid in its own right, which means you can quantize
other sequences to it (see Chapter Your Own Quantization Grid on
page 6 - 22). With LOGIC Audio it is even possible to adopt the timing
of an audio file such as a drum loop, as a quantization grid.

Recording Without a Metronome
If you don’t want to record to a metronome, e.g. because your piano
solo composition contains many tempo changes, just switch off the
metronome while recording.

However, if you want to:

• Use the quantization functions on the recording,
• Have a correct display of the bar positions in the Editors, or
• Prepare a musical score,

you need a timing reference.

In this case you can use the reclock function to create a tempo track
which fits your freely recorded sequence. This allows the timing grid to
be adapted to the recorded notes. Refer to the Chapter Setting the
Tempo After Recording on page 16 - 5.

Configuring the System
LOGIC allows you to tailor many aspects of the operation to your per-
sonal requirements and working style:

• You can activate practically all LOGIC’s functions via either a menu
command, key command or MIDI event. You can define the keys
or MIDI events yourself in the key commands window (see Chapter
Keyboard and MIDI Remote Operation on page 4 - 18).

• You can save different window assignments and call them back up
again (see Chapter Window Assignments (Screensets) on page 4 -
12).
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• You can determine the program’s basic operating modes in a mul-

ti-page dialog window called “Preferences” by choosing File >
Preferences. These settings are automatically saved and are in-
dependent of the loaded song (see Chapter Preferences on page
14 - 18).

• You should also have a look at the song-related settings by choos-
ing File > Song Settings. Like the Preferences, many of these op-
tions are self-explanatory. If in doubt refer to the Chapter Song
Settings on page 14 - 1.

Environment
As soon as you are familiar with LOGIC’s basic operation you should
read Chapter The Environment on page 7 - 1.

With LOGIC’s Environment you can:

• Give external devices a virtual user interface with knobs, sliders
(faders) and text displays

• Make note assignments for drum programming (see Chapter
Mapped Instrument on page 7 - 17)

• Create arpeggios and MIDI delays (see Chapter Arpeggiator on
page 7 - 37 and Chapter Delay Line on page 7 - 40)

The Environment also gives you control of the whole MIDI signal flow
inside your computer. This allows you to automatically change the sig-
nal path (Cable Switcher), or transform Midi events in realtime (Trans-
former).
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3.  Introduction to Audio

This chapter explains the operation and basic structure of LOGIC Audio
without going into too much detail. The following chapters contain on-
ly brief descriptions of LOGIC Audio’s extremely extensive functions.
This chapter should help you understand these shorter descriptions
more easily, and leave you ready to start work right away.

What we’ve assumed
We’ve assumed in this intro that you’re familiar with the basic opera-
tion of LOGIC and the conventions of this manual. If this is not the case,
please read the Crash Course and the first section of the Operation
Chapter of the LOGIC manual.

We recommend that first-time LOGIC users work a while with the MIDI-
only part of the program. One of the great things about an integrated
MIDI and Audio sequencing system like LOGIC Audio is that you can
manipulate MIDI and Audio recordings together. So if you can handle
MIDI sequences OK, you’ll be able to carry out many operations totally
intuitively when you move to working with Audio sequences.

One small point - from here on in, when we mention ‘Recordings’, we
always mean Audio recordings, not MIDI recordings.

3.1 How it works –
a few concepts explained

This brief overview is not about the technical side of Hard Disk Record-
ing. If that’s what you’re after, you’re reading the wrong manual! This
section explains how you go about making and managing recordings
with the help of the various parts of LOGIC Audio.

Audio Files
Any audio signals you record with LOGIC Audio (like vocals or acoustic
instruments) are stored as Audio Files on your hard disk.

Important
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You can make use of existing WAV type audio files in LOGIC Audio, in-
cluding recordings made using other programs.

Audio files normally remain unaltered on your hard drive — even if you
edit the recording so that only small snippets of it play back. As the au-
dio file on the hard drive remains unchanged, you can undo any cuts
you have made to the recording at any later stage.

This is called non-destructive editing.

Regions
When you edit non-destructively, you don’t cut the audio file itself —
you just change what we call “regions”. These are just parts of the
original audio file.

The audio file itself is not affected when you define the regions. The
“definition data” of the regions are part of the “song data”, not part of
the audio files.

When you make a new recording, LOGIC Audio automatically creates
one region for the whole of the new audio file. 

Regions can be defined in the Audio window or the Sample Edit win-
dow; they are also created automatically whenever you cut the record-
ing in the Arrange window.

You can create or destroy as many new regions for an audio file as you
like, without changing the audio file itself in any way.

In addition to the start and end points of a region there is another
important point: the anchor.

The Anchor
The anchor is a freely-movable point in a region which you can use to
mark a position in a recording, for example, a particular bar number, or
a prominent noise. This marker then acts as a useful reference point if
you’re musically arranging regions, or synchronizing them to picture.

In other words, when you position a region in the Arrangement it is not
the start point but the anchor which is aligned to a musical time point
or cue point.

In both the Audio and Sample Edit windows, the anchor appears as a
triangle under the audio waveform display. You can alter it by moving
the triangle. However, the start point of a region is always fixed.
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The location of the anchor is always displayed by the position indicator
of an audio sequence in the Event List (or, when you’re moving a se-
quence, within the Info line in the Arrange Window).

The Audio Window
The Audio window is used to manage all the audio files stored on
your hard drive.

Among other uses, you can use the Audio window to:

• decide where your recordings will be stored (which hard disk, fold-
er and file name),

• import existing audio files into the song, and
• copy, erase or rename audio files, and move them between differ-

ent hard drives (or folders).

LOGIC Audio files appear in the Windows Explorer like other ordinary
computer files, so you might think you can simply rename them here.
You can do this, of course, but it’s not recommended because if you do
rename an audio file in the Windows Explorer, LOGIC Audio will contin-
ue to look for it under the old file name, and won’t be able to find it!

Apart from the uses mentioned above, the Audio window also pro-
vides you with an overview of the number and positions of all the
regions associated with each audio file.

You can:

• change the start and end points of existing Regions;
• create and erase Regions;
• and change the Anchor for any Region. 

Audio Sequences
Regions that are put together using the Arrange Window are called
“audio sequences”. This term allows you to distinguish between;

• Midi sequences in the Arrange window, and

• Regions in the Audio window.

If you are familiar with samplers you can think of these audio
sequences as being graphically arranged samples.

Note
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For every audio sequence in the Arrange window, there’s a correspond-
ing region in the Audio window. However, not every region in the Audio
window has to be used in your arrangement!

So, the Audio window is like your catalog for all your audio sequences
(or regions, if you prefer to call them that), while the Arrange window
is used to place these audio sequences on a time axis in such a way that
makes musical sense.

You can drag regions straight from the Audio window into the Arrange
window if you wish — they then appear there as audio sequences.

You don’t have to define or alter regions using the Audio window the
whole time. For example, every time you record in the Arrange win-
dow, an audio sequence is created containing the entire audio file (the
corresponding region appears simultaneously in the Audio window ).

If you cut up an audio sequence in the Arrange window using the scis-
sor tool, you end up with two smaller sequences, as you would expect;
but doing this also automatically creates two new regions in the Audio
window.

The original region is not erased by this process, it just gets replaced in
the Arrange window display by the two new audio sequences.

Audio Tracks
When you play back MIDI sequences with LOGIC, it’s done via an Instru-
ment (or, more accurately, via an object in the Environment window )
which you assign in the relevant line of the track column of the Arrange
window.

It’s pretty much the same with audio sequences, except you choose an
Audio object as the “track instrument”.

Any track can play back audio sequences, provided an Audio Object
has been assigned to the track i n the track column.

Audio Objects
Each audio object represents one of the tracks of your hard disk re-
cording hardware. You control all the audio objects from the Environ-
ment window.

You can picture each of these tracks (which we’ll call “physical tracks“
from now on) as being rather like a single voice on a sampler. An 8-track
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system like AudioMedia III, for example, can play back up to eight au-
dio sequences at once. 

However, you can set up as many other audio tracks as you like in the
Arrange window, independent of the number of physical tracks availa-
ble to you. These other tracks are often referred to as “virtual tracks”.

Although you can assign various audio tracks to play back via the same
audio object, you can only play back one of the audio sequences on
these tracks at once!

Whenever you create a new song , LOGIC Audio automatically gener-
ates an audio object for every physical track of your audio hardware!

You also determine the following with each audio object:

• which physical output on your hardware is used to output the con-
tent of a given track, (providing the audio hardware has more than
a stereo output),

• the output level, pan position and - depending on your hardware -
possibly also the EQ and Effects settings of a given track.

Control over the last of these parameters can be automated very sim-
ply, because at the end of the day, it’s simple MIDI controller informa-
tion that governs the way audio objects work. Of course, such control-
ler-driven automation data can then be processed very easily by
LOGIC’s extensive editing facilities, giving you total control.

The Sample Edit Window

You can carry out a number of tasks in the Sample Edit window by mak-
ing use of its magnified depiction of your recorded audio waveforms.
You can also select portions of your Audio Files and destructively edit
them, or create new regions from them.

There are various editing functions available: ranging from reversing
and normalizing (maximizing the level) to the high end functions of
the Digital Factory , such as digital compression (Energizer), time
stretching or pitch shifting (Time and Pitch Machine).

You can use the Undo function for all destructive editing processes. As
a precaution, you can automatically create backups before carrying
out destructive functions.
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13.2 Going about the Basics

This section explains how to tackle some of the basic steps when work-
ing with LOGIC Audio, and points you forward to the detailed descrip-
tions of the program’s functions contained in later chapters.

Making a Recording

First connect a sound source to the audio inputs of your system (a CD
player will do for test purposes).

If you have problems, please refer to the manual supplied with your
hard disk recording hardware.

Setting the Record path

Open up the Audio window and select File > Set Record Path.

From the selection box that now appears, choose a record path and
name for all the recordings (i.e. audio files) you’re about to make.

You don’t need to repeat this procedure before all your subsequent re-
cordings as they are all automatically given the same name and num-
bered sequentially to distinguish them from one another.

You can rename audio files after recording by double-clicking on their
names in the audio window (though remember, only in the audio win-
dow, not in the Windows Explorer!).

If you forget to set a path, LOGIC Audio will let you know with a dia-
logue box. At this point you can then select the Set Path option to bring
up the record path selection box direct.

The chosen path is then stored in the Preferences – this means it will
automatically be available the next time you start the program.

Select an Audio Track

Select an audio track in the Arrange window.

X
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To change a track into an audio track, assign an audio object as an In-
strument to the track, by means of the track column.

Whenever you create a new Song by selecting File > New , you’ll find
that a track has already been generated for all available audio objects.

To enhance an existing Song with audio tracks, first set up some audio
objects in the Song’s Environment. For more on how to do this, please
read the section Audio Objects,  on page 3 - 2 .

“Arming” tracks
The tracks in a piece of hard disk recording hardware (unlike tracks in
MIDI recording) have to be manually prepared for recording before you
can actually use them, just as you have to “arm” the tracks of a multi-
track tape recorder.

Double-click on the audio object in the track column to open an envi-
ronment window. The audio objects layer should now be visible.

There’s a REC switch at the bottom of every audio object. You use this
switch to arm the track represented by any particular audio object.

Tracks can also be armed directly from the Arrange window, by Sright-
clicking on the appropriate audio object in the track column.

In both cases, several tracks can be armed at once.

Create a new screenset. Open the Arrange window plus an Environ-
ment window containing the audio objects . Set the window size so
that you can see just the audio objects, Use this screenset for recording
from now on. 

Stereo Usage
To record in stereo, click in one of the audio objects on this symbol.
This pairs two neighbouring tracks and puts them together under the
control of whichever audio object has the lower odd number. The sym-
bol then changes into a stereo symbol.

Tip
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The audio object for the even-numbered channel cannot be removed
from the Environment, as the track it represents is now being used as
the right-hand stereo channel.

Setting Levels

As soon as you arm the tracks, you should hear the input signal you are
going to record at the output of your hard disk recording hardware.

You can now adjust the level of this monitor signal using the fader on
the audio object. The fader always adjusts the playback level, not the
record level. 

You can adjust the record level with the subgroup fader on your mixer,
or by adjusting whatever you’re using as a signal source. In addition,
some hardware permits adjustment of the input level; more on this in
the section describing the various hardware extensions.

The record level of digital inputs cannot be adjusted manually (1:1
transfer).

… in AV mode

In AV mode because of the internal signal-flow structure of some sound
cards you can always hear the input signal. For details please refer to
Abschnitt Aufnahmequelle und -pegel ab Seite 11 - 5.

Starting the Recording

You start recording by clicking the record button in the Transport win-
dow or via the relevant key command.

While recording, the waveform (signal envelope) is displayed in the Ar-
range window in real time.

Keep an eye on the level meters in the audio objects. If the Clip display
(top LED) lights up, repeat the recording at a lower level. So you don’t
have to watch the level meters the whole time, the Clip LED, once acti-
vated, will remain lit until you click on the meter a second time.

Don’t forget to disarm your audio tracks after recording, either by
Sright--clicking on the track instrument or using the REC switch on the
audio objects.
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Basic Management of Your Recorded Audio
During the recording, the audio sequences should have appeared in
the Arrange window. You can now manipulate these in almost exactly
the same way as you would MIDI sequences. For example:

• you can move them by dragging and dropping them with the
mouse;

• you can cut them with the scissor tool;
• you can copy them by moving them with the √-key depressed

(this creates a new region in the Audio window);
• if you copy them by moving them with the S√-keys depressed,

this creates a new audio sequence with the same region;
• you can set loop and delay parameters for them in the sequence

parameter box.

The copy-functions are definitely the most important:

When you copy an audio sequence in the normal way (i.e.: by √-mov-
ing it) , you are effectively creating an alias, because the same region
is being played again. Any alterations you make to a region/sequence
automatically affect all the copies.

If you hold down the S-key when copying audio sequences (hold
down S√ while dragging an audio sequence), you automatically cre-
ate a new region. You can now edit and trim the new audio sequence
without changing the original audio sequence (region).

The Audio Window
To get an overview of all audio files and regions, open the Audio win-
dow, (using Window > Open Audio).

Audio files are displayed in the audio window as folders preceded by a
triangle, rather like the display in the Windows Explorer. Clicking on

X
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the triangle hides or shows the regions defined in the selected file, dis-
playing these in the lines below. The right-hand side of the window
shows the overall position of the regions in the whole file. 

Regions

You add a new region by selecting File > Add Region . The position of
the newly-added region depends on the region selected.

To hear a region play, just click on it and hold the mouse button down.

To change the position of a region, you grab it by its lower half. Grab-
bing it at the left or right end allows you to move the beginning or end,
while if you grab it in the middle, you can change the whole position of
the region in the audio file. The position of the anchor can be altered
by moving the triangle in the lower half of the region.

Changing the start and end points of the regions has an immediate ef-
fect on the regions’ corresponding audio sequences in the Arrange win-
dow!

The Sample Edit Window

You can edit regions with even greater accuracy in the Sample Edit win-
dow. This is opened by double-clicking on a region (or an audio se-
quence in the Arrange window), .

Changes made always affect the selected area of the audio file only.
Clicking on a region not only opens the Sample Edit window but also
selects that region automatically for editing when the window opens.

You make selections by clicking and dragging with the mouse, and you
can change the existing start and end points of selected regions by S-
clicking on them and dragging. Selecting the menu entry Edit >
Search Zero Crossings permits only Zero Crossing points as possible
start or end points for selections. This feature can be turned Off and On
by ticking the menu entry with the mouse.

When you’ve finished editing a selection, you make the changes to the
regions’ boundaries by selecting Edit > Selection to Region .

There are simpler editing functions in the Functions menu, and more
complex ones under the Factory menu.

X
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Automation
To automate adjustments made to level, pan and — if your hardware
supports it— EQ settings, do the following:

• select a track in the Arrange window assigned to the instrument A-
Playback;

• hit record;

• make the adjustments you want on the audio objects in the Envi-
ronment.

The adjustments are then recorded as MIDI controller data, and can be
edited using Hyper Draw or in the Hyper Editor.

Summary
So, here’s a quick summary of how to set about making a recording:

• Set the path and name for the audio file.
Open the Audio window  and choose File > Set Record Path.

• Set up an audio track in the Arrange window and select it.
Assign an audio object in the track column.

• Open the Environments audio layer:
by selecting Options > Audio Record from the Audio window or
by double-clicking on the audio object in the track column.

• “Arm“ the physical tracks:
by clicking on the REC switch on the audio objects.

• Start recording:
using RECORD, as with Midi recordings.

• “Disarm“ the physical tracks (make the tracks “safe”).

Audio files and regions can be manipulated in the Audio window; fine-
tuning and destructive editing can be performed in the Sample Edit
window.

That’s all folks
You have now covered all LOGIC’s basic functions. If you start creating
your own songs your confidence with LOGIC Audio will only increase.

We are certain that LOGIC will give you good service for many years to
come, and we wish you and your music much luck and success!
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14.  Appendix

Some general points about Audio recording with integrated software.

Tempo and Time
Digital audio recordings have a fixed relationship to Time — their sam-
pling rate. If you change the tempo of your sequencer, the length of an
audio sequence will also change relative to the rest of your (non-digital
audio-based) music. The reason is that the playback time of the audio
sequence remains the same, and its unchanging duration against dif-
ferent sequencer tempos forces it to have a different relative length. At
the end of the day, the sequencer is concerned with lengths in bars and
beats. 

For this reason, you should choose your tempo at the start of a record-
ing session with care, for without things getting really complex, you
won’t be able to change it later without your audio tracks getting out
of time with the rest of your backing.

Setting the Song Tempo to match the Recording
Let’s assume you’ve recorded a drum loop. Now you’d like to set the
Song tempo to fit the recording exactly.

• First check that the drum loop is smoothly edited.
- To do this double-click on the audio sequence to open the

sample editor, and activate the looping switch and the sample
playback monitor.

- Adjust the start and end points of the drum loop waveform
(by S-clicking and dragging the mouse), so that the drum-
loop cycles round. Then select Edit > Selection to Region.

- Close the Sample Editor (£), and OK the computer’s query
when it asks whether you want to keep the changes you’ve
made.

• In the Arrange window, move the audio sequence to the start of a
bar (e.g. Bar 1).

• Stretch the locators from the beginning of the same bar across a
region that matches the exact length of the drum loop; e.g. across
two bars (from 1.1.1.1 to 3.1.1.1).
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• Select the menu function Functions > Adjust Tempo by Object
Length and Locators.

The tempo is automatically adjusted so that the length of the Audio se-
quence matches that of the 2-bar cycle exactly.

Hit STOP, then START to hear the results.

Pressing STOP doesn’t just put the Song position line back to the start
of the 2-bar cycle, it also prepares all the audio sequences that are
timed to start there for immediate playback. Without this precaution
(for technical reasons), several seconds could pass after pressing
START before all the audio sequences were running in time with the
rest of the Song.

Changing the Recording to fit the Song

You should only attempt the opposite of the above procedure, and try
to fit an existing recording to the Song tempo, when a change to the
tempo is no longer possible, as all these edits involve altering the orig-
inal recording in some way.

With rhythmic material, you can achieve the necessary match in the
following way:

• Make the tempo match temporarily;

• Cut the audio sequence into small segments automatically with
the help of the Strip Silence function.

• adjust the original tempo again.

For more about this method, read the section Stereo Files – A Few
Points To Note,  on page 5 - 34.

You can match any recordings using the Time & Pitch Machine in the
Sample Editor. For more on this, read the section Time Machine,  on
page 7 - 3.

Data Formats: what you need to know

Regions and the WAV Data format

Audio files are stored in the (mono) WAV format. . LOGIC Audio is also
capable of storing audio files in the AIFF (Audio Interchange File For-
mat) format. 

X

Note



LOGIC AUDIO Demo Version 41

Going about the Basics

1
Regions created in LOGIC Audio are stored independently of the Song.
The reason for this lies in the principle of non-destructive editing: that
an audio file should remain unchanged by editing. 

Sample Rate and Bit Resolution
As with all other comparable multitrack HD systems, only audio files
with a single sample rate can be played back within a LOGIC Audio
Song. If you wish to integrate existing audio files with a differing sam-
ple rate, they will first need to be converted in the Sample Edit window
by selecting the function Factory > Sample Rate Convert… .

LOGIC Audio can currently only play back 16-bit audio files. The use of
lesser bit resolutions has an audible disadvantage for the quality of re-
produced sound.


