
The Plato Screen
Overview
Click on the part of the screen you want help on.

{button ,JI(`',`SCREEN_MENUBAR')} The Menu Bar
{button ,JI(`',`SCREEN_TOOLBAR')} The Toolbar
{button ,JI(`',`SCREEN_MDIEDIT')} The MDI Edit Area
{button ,JI(`',`SCREEN_MESSAGE_WINDOW')} The Message Window
{button ,JI(`',`SCREEN_STATUS_BAR')} The Status Bar



About this help file
This is PLATO.HLP the Plato Help file.

Author: Ivan Lucas
Version: 1.02 
Date: 18/10/96

{button ,Test(7)} Test mode

© Copyright Salford Software Ltd. 1996



The File Menu
Create, open, save or print source file.

The file menu contains commands that relate to source file management, from this menu source files 
can be created, opened, closed, saved, printed, inserted and renamed.    Also on this menu is a list of 
the last ten source files opened by Plato and a command to exit the application.

Click on the menu command you want help on.

{button ,KL(`Menu;Context Menus')} Related Topics



New command (File menu)
Create a new source file.
Opens a new blank Edit Window ready to begin a new source file.



Open command (File menu)
Open an existing source file.
Presents a standard ‘Open File’ dialog and prompts the user to select an existing source file.    The 
filename the user provides will then be opened in a new Edit Window.
More than one file can be opened in one action by holding down the CTRL key and clicking on several 
filenames.
Various standard file types are supported by Plato:
C/C++ Files (*.C,*.CPP,*.H,*.HPP)
Fortan Files (*.F,*.FOR,*.F90,*.INS,*.MOD)
Listing Files (*.LIS)
Resource Files (*.RC,*.RES,*.DLG)



Open Selected File command (File menu)
Open the selected source file name.
Opens a filename that has been selected in the active Edit Window.    The file will be opened in a new 
separate Edit Window.    This option is greyed when there is no filename selected.



Save command (File menu)
Save the active source file.
Saves the active source file with the current filename.    If no filename has been assigned the user is 
prompted to enter one.



Save As command (File menu)
Save the active source file under a different name.
Saves the active source file under a name other than the current filename, the user is prompted to enter 
a new filename.



Save All command (File menu)
Save all open source files.
Saves all open source files under their current filenames.    If no filename has been assigned for one or 
more source files the user is prompted for filenames.



Close command (File menu)
Close the active source file.
Closes the active source file, if the file has been modified since it was last saved the user is asked 
whether the modifications should be saved before the file is closed.



Close All command (File menu)
Close all open source files.
Closes all open source files, if one or more file has been modified since it was last saved the user is 
asked whether the modifications should be saved before each file is closed.



Insert command (File menu)
Insert file at the insertion point.
Prompts the user for a filename which will be inserted into the active source file at the current insertion 
point (ie. The cursor point)



File Properties command (File menu)
Display file information.
Opens the source manager window with the ‘Information’ tab displayed.

{button ,JI(`',`SOURCE_MGR')} Source Manager overview



Print command (File menu)
Print the active source file.
Presents a standard ‘Print’ dialog and prompts the user to select printing options, for example the 
number of copies to print.



Print Setup command (File menu)
Change printer selection or configuration.
Presents a standard ‘Print Setup’ dialog and prompt the user to select printer options, for example the 
paper size.



Most recently used files (File menu)
The most recently used files, click a filename to open it.
Displays up to ten of the most recently used filenames, these are listed near the bottom of the file menu, 
simply click a filename to open the file into a new Edit Window.



Exit command (File menu)
Exit the Plato Application.
Closes all open source files and exits the Plato application.    If one or more source files have been 
modified since they were last saved then the user is prompted to save any modifications before the 
application exits.



Edit Menu
Undo, delete, copy and search.

Most common commands for editing source files are contained within this menu.    Many of these 
commands are only available if a block of text is highlighted.

Click on the menu command you want help on.

{button ,KL(`Menu;Context Menus')} Related Topics



Undo command (Edit menu)
Undo the last action.
Reverses the last edit action performed.



Cut command (Edit menu)
Cut the selection and put it on the clipboard.
Removes the selection from the active source file and places it on the clipboard.



Copy command (Edit menu)
Copy the selection and put it on the clipboard.
Copies the selection onto the clipboard.



Paste command (Edit menu)
Insert the clipboard contents at the insertion point.
Inserts the contents of the clipboard at the insertion point replacing any selection.



Delete command (Edit menu)
Remove the selection without putting it on the clipboard.
Removes the selection from the active source file without placing it on the clipboard.



Select All command (Edit menu)
Select all text in active source file.
Selects all text in the active source file.



Delete Line command (Edit menu)
Delete current line in active source file.
Removes the current line in the active source file without placing it on the clipboard.



Find command (Edit menu)
Find Text
Searches for specified text in the active source file.



Find Next command (Edit menu)
Find next occurrence of text.
Searches for the next occurrence of the specified text in the active source file.



Find Previous command (Edit menu)
Find previous occurrence of text.
Searches for the previous occurrence of the specified text in the active source file.



Replace command (Edit menu)
Replace text.
Searches for and replaces specified text in the active source file.



Goto Line command (Edit menu)
Move cursor to specified line number.
Moves the cursor to the specified line number in the active source file.



Macro Record command (Edit menu)
Start edit macro recorder.



Macro Stop command (Edit menu)
Stop edit macro recorder.



Replay Macro
Replay last recorded macro.



The Project Menu
Create, open, close and modify project.

This menu contains commands for creating, opening, closing and compiling projects.    All of the 
functionality here is also available from the Source Manager’s Project tab, which can be displayed by 
selecting the last option on this Project menu.    The Project menu also has commands to compile and 
build a single file.

Click on the menu command you want help on.

{button ,KL(`Menu;Context Menus')} Related Topics



Compile File command (Project menu)
Compile active source file.



Build File command (Project menu)
Compile and Link active source file.



Compile Project command (Project menu)
Compile all modified source files in current project.



Build Project command (Project menu)
Compile all modified source files and link in current project.



Rebuild All command (Project menu)
Compile and link all files in current project.



Execute command (Project menu)
Run the last file or project built.



Runtime Setup command (Project menu)
View and edit current runtime parameters.



New command (Project menu)
Creates a new project.



Open command (Project menu)
Open an existing project.



Save command (Project menu)
Save the current project.



Save As command (Project menu)
Save the current project under a different name.



Close command (Project menu)
Close the current project.



Project Information command (Project menu)
Display project information.



The Tools Menu
Change Plato preferences.

This menu has commands for altering Plato preferences, the settings configurable from this menu can 
be saved for use next time by checking the last option on the menu.

Click on the menu command you want help on.

{button ,KL(`Menu;Context Menus')} Related Topics



Display Toolbar command (Tools menu)
Toggle the toolbar on and off.



Display Status Bar command (Tools menu)
Toggle the status bar on and off.



Message Window command (Tools menu)
Toggle message window display.



Source Manager command (Tools menu)
Toggle source manager window display.



Flush Messages command (Tools menu)
Clear message window.



Options command (Tools menu)
Change various categories of Salford Software Plato options.

{button ,JI(`',`OPTIONS')} Options overview



Save Settings on Exit command (Tools menu)
Save all altered settings and file database on exit.



The Window Menu
Rearrange windows or activate specified window.

This menu contains commands for arranging windows and a list of all the open source files.    The active 
source file is marked with a tick.

Click on the menu command you want help on.

{button ,KL(`Menu;Context Menus')} Related Topics



Tile Vertical command (Window menu)
Arrange windows as non-overlapping tiles vertically.



Tile Horizontal command (Window menu)
Arrange windows as non-overlapping tiles horizontally.



Cascade command (Window menu)
Arrange windows as overlapping tiles.



Minimize All command (Window menu)
Arrange all windows as icons.



Arrange Icons command (Window menu)
Arrange minimized window icons.



Next command (Window menu)
Display next window.



Close command (Window menu)
Close the active source file.



Close All command (Window menu)
Close all open source files.



List of open windows (Window menu)
Switch to the selected open window.



The Help Menu
Help on Plato or other related Salford Software Products.

This menu contains commands for providing assistance with Plato and other associated Plato products. 
The last option About Plato presents a dialog showing the Plato version number, author and copyright 
details.

Click on the menu option you want help on.

{button ,KL(`Menu;Context Menus')} Related Topics



Help Topics command (Help menu)
Displays help topics for Salford Software Plato.
(Not yet implemented)



Salford FTN77 Manual command (Help menu)
FTN77 help Manual



Salford SCC Manual command (Help menu)
SCC help Manual



Salford Clearwin+ Manual command (Help menu)
Clearwin+ help Manual



Keyword Help command (Help menu)
Show help topic for selected keyword.



About Plato command (Help menu)
Displays Salford Software Plato version information



The Main Menu Bar
This is where the most commonly used commands can be accessed.
Menu items that are “greyed” are not currently available.

Click on the menu name you want help on.

{button ,JI(`',`MENU_FILE')} The File Menu
{button ,JI(`',`MENU_EDIT')} The Edit Menu
{button ,JI(`',`MENU_PROJECT')} The Project Menu
{button ,JI(`',`MENU_TOOLS')} The Tools Menu
{button ,JI(`',`MENU_WINDOW')} The Window Menu
{button ,JI(`',`MENU_HELP')} The Help Menu

{button ,KL(`Menu;Context Menus;Screen')} Related Topics



The Toolbar
Graphic representations of some of the most commonly used commands.
To toggle the toolbar on or off select the Display Toolbar command from the Tools menu.

Click on the toolbar button you want help on.

The toolbar buttons represent: (from left to right)
{button ,PI(`',`TOOLBAR_NEW_FILE')} New File 
{button ,PI(`',`TOOLBAR_OPEN_FILE')} Open File 
{button ,PI(`',`TOOLBAR_SAVE_FILE')} Save File 
{button ,PI(`',`TOOLBAR_PRINT_FILE')} Print File

{button ,PI(`',`TOOLBAR_CUT')} Cut 
{button ,PI(`',`TOOLBAR_COPY')} Copy 
{button ,PI(`',`TOOLBAR_PASTE')} Paste
{button ,PI(`',`TOOLBAR_FIND')} Find 
{button ,PI(`',`TOOLBAR_COMPILE')} Compile File
{button ,PI(`',`TOOLBAR_BUILD_FILE')} Build File 
{button ,PI(`',`TOOLBAR_COMPILE_PROJECT')} Compile Project 
{button ,PI(`',`TOOLBAR_BUILD_PROJECT')} Build Project 
{button ,PI(`',`TOOLBAR_REBUILD_PROJECT')} Rebuild Project
{button ,PI(`',`TOOLBAR_EXECUTE')} Execute
{button ,PI(`',`TOOLBAR_FLUSH_MESSAGES')} Flush Messages 
{button ,PI(`',`TOOLBAR_TOGGLE_MESSAGES')} Toggle Messages 
{button ,PI(`',`TOOLBAR_WINDOW_LIST')} Window List 
{button ,PI(`',`TOOLBAR_SOURCE_MANAGER')} Source Manager 
{button ,PI(`',`TOOLBAR_KEYWORD_HELP')} Keyword Help 

{button ,KL(`Screen')} Related Topics



 New File (Toolbar button)
This button has the same effect as the New command on the File menu.
Opens a new blank Edit Window ready to begin a new source file.



 Open File (Toolbar button)
This button has the same effect as the Open command on the File menu.
Presents a standard ‘Open File’ dialog and prompts the user to select an existing source file.    The 
filename the user provides will then be opened in a new Edit Window.
More than one file can be opened in one action by holding down the CTRL key and clicking on several 
filenames.
Various standard file types are supported by Plato:
C/C++ Files (*.C,*.CPP,*.H,*.HPP)
Fortan Files (*.F,*.FOR,*.F90,*.INS,*.MOD)
Listing Files (*.LIS)
Resource Files (*.RC,*.RES,*.DLG)



 Save File (Toolbar button)
This button has the same effect as the Save command on the File menu.
Saves the active source file with the current filename.    If no filename has been assigned the user is 
prompted to enter one.



 Print File (Toolbar button)
This button has the same effect as the Print command on the File menu.
Presents a standard ‘Print’ dialog and prompts the user to select printing options, for example the 
number of copies to print.



 Cut (Toolbar button)
This button has the same effect as the Cut command on the Edit menu.
Removes the selection from the active source file and places it on the clipboard.



 Copy (Toolbar button)
This button has the same effect as the Copy command on the Edit menu.
Copies the selection onto the clipboard.



 Paste (Toolbar button)
This button has the same effect as the Paste command on the Edit menu.
Inserts the contents of the clipboard at the insertion point replacing any selection.



 Find (Toolbar button)
This button has the same effect as the Find command on the Edit menu.
Searches for specified text in the active source file.



 Compile File (Toolbar button)
This button has the same effect as the Compile File command on the Project menu.
Compile active source file.



 Build File (Toolbar button)
This button has the same effect as the Build File command on the Project menu.
Compile and Link active source file.



 Compile Project (Toolbar button)
This button has the same effect as the Compile Project command on the Project menu.
Compile all modified source files in current project.



 Build Project (Toolbar button)
This button has the same effect as the Build Project command on the Project menu.
Compile all modified source files and link in current project.



 Rebuild Project (Toolbar button)
This button has the same effect as the Rebuild All command on the Project menu.
Compile and link all files in current project.



 Execute (Toolbar button)
This button has the same effect as the Execute command on the Project menu.
Run the last file or project built.



 Flush Messages (Toolbar button)
This button has the same effect as the Flush Messages command on the Tools menu.
Clear message window.



 Toggle Messages (Toolbar button)
This button has the same effect as the Message Window command on the Tools menu.
Toggle message window display.



 Window List (Toolbar combo box)
A list of all the files currently open.
Select a file from the list to bring the files’ edit window to the top.



 Source Manager (Toolbar button)
This button has the same effect as the Source Manager command on the Tools menu.
Toggle source manager window display.



 Keyword Help (Toolbar button)
This button has the same effect as the Keyword Help command on the Help menu.
Show help topic for selected keyword.



The MDI Edit Area
All the source files are displayed in child windows.    The following is an example of a source file in a 
child window.

{button ,KL(`Screen')} Related Topics



The Message Window
When a compilation fails the error messages are contained here.
To toggle the message window on or off select the Message Window command from the Tools menu.

{button ,KL(`Screen')} Related Topics



The Status Bar
This displays status information and messages to guide the user.
To toggle the Status bar on or off select the Display Status Bar command from the Tools menu.

Click the part of the status bar you want help on.

{button ,KL(`Screen')} Related Topics



Command Help (Status Bar)
Displays simple help on menu items.



Line Number (Status Bar)
Displays the current line number.



Column Number (Status Bar)
Displays the current column number.



Clock (Status Bar)
Displays the current time.



Introduction
Plato is an Integrated Development Environment (IDE) that integrates all Salford Software’s current 
products into one user friendly shell.    It was written to run under Windows 95 and Windows NT 4.0 with 
Salford Software’s C/C++ compiler.

{button ,JI(`',`Contents')} An Overview of Plato

Feature Summary:
Some of Plato’s features
{button ,PI(`',`FEATURE_32BIT')} A 32bit Program
{button ,PI(`',`FEATURE_FRIENDLY')} User friendly and intuitive to use
{button ,PI(`',`FEATURE_LARGE_SOURCE')} Very large source files can be edited
{button ,PI(`',`FEATURE_MANY_FILES')} Many source files can be edited at a time
{button ,PI(`',`FEATURE_PROJECT_MANAGE')} Project management
{button ,PI(`',`FEATURE_CONTEXT_MENUS')} Context menus
{button ,PI(`',`FEATURE_SYNTAX_HIGHLIGHTING')} Syntax Highlighting
{button ,PI(`',`FEATURE_FONTS')} User definable font sizes and colours
{button ,PI(`',`FEATURE_EXECUTE')} Ability to execute compiled files or projects from within Plato
{button ,PI(`',`FEATURE_MRU')} Maintains a list of most recently used files for easy access
{button ,PI(`',`FEATURE_CONTEXT_HELP')} Context sensitive help
{button ,PI(`',`FEATURE_KEYWORD_HELP')} Ability to access keyword help from within Plato

{button ,KL(`How to;Contents')} Related Topics



A 32 Bit Program
Plato will run under Windows 95 and Windows NT 4.0 



User friendly and intuitive to use



Very large source files can be edited



Many source files can be edited at a time



Project management



Context menus
Press the right mouse button when using Plato to start a context menu.



Syntax Highlighting
Plato colours reserved words to make source files easier to read.



User definable font sizes and colours
You can configure the font size, style and colour with Plato.



Ability to execute compiled files or projects from within Plato



Maintains a list of most recently used files for easy access



Context sensitive help



Ability to access keyword help from within Plato



Context Menus
These are menus that appear on a window, control or part of a control when the right mouse button is 
clicked.    The menu groups commands from other menus that are relevant to the task in hand, for 
example when a source file edit window is clicked a context menu appears with all the edit options on it. 
There are two main context menus used by Plato, although there are many smaller ones for individual 
controls.

The main window and the MDI edit window share a common context menu, the other menu available is 
for open source files.

Main Window Context Menu
This menu appears if a right click is performed on the main window, toolbar, status bar or MDI edit area 
(not covered by an open source file).

New source files can be created or existing ones opened from this menu.    The Message Window and the 
Source Manager can both be toggled on and off.

Open Source File Context Menu
When an open source file is right clicked, a menu with many of the options from the Edit Menu is 
displayed.

{button ,KL(`Menu')} Related Topics



Options
Overview
Allows modifications to various Plato settings.

Click on the part of the screen you want help on.

{button ,JI(`',`OPTIONS_DISPLAY')} Display options.
{button ,JI(`',`OPTIONS_KEYBOARD')} Keyboard options.
{button ,JI(`',`OPTIONS_STYLE')} Style options.
{button ,JI(`',`OPTIONS_PRODUCTS')} Products options.
{button ,JI(`',`OPTIONS_DISPLAY')} Manuals options.

{button ,KL(`Setup;Options')} Related Topics



Display Options
Allows modifications to display options such as font size and style and syntax highlighting colours.

Click on the part of the screen you want help on.

{button ,KL(`Setup;Options')} Related Topics



Keyboard Options
Not implemented.

Click on the part of the screen you want help on.

{button ,KL(`Setup;Options')} Related Topics



Style Options
Allows modifications to style options such as tab indent size.

Click on the part of the screen you want help on.

{button ,KL(`Setup;Options')} Related Topics



Products Options
Allows modifications to path and filename details of Salford products.

Click on the part of the screen you want help on.

{button ,KL(`Setup;Options')} Related Topics



Manuals Options

Click on the part of the screen you want help on.

{button ,KL(`Setup;Options')} Related Topics



Font button (Display options)
Change font style and size.
Presents a standard font dialog and prompts the user to select a font style and size which will be used 
for text in the Edit window.    Only monospaced fonts are shown in the list box since proportionally 
spaced fonts are not well suited to code writing.



Background Colour button (Display options)
Change background colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used as a 
background colour to the Edit window.



Text Colour button (Display options)
Change text colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used as a text 
foreground colour to the Edit window.



Reserved Colour button (Display options)
Change reserved word colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used for syntax 
highlighting reserved words in the Edit window.



String Colour button (Display options)
Change string colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used for syntax 
highlighting strings in the Edit window.



Comment Colour button (Display options)
Change comment colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used for syntax 
highlighting comments in the Edit window.



Punctuation Colour button (Display options)
Change punctuation colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used for syntax 
highlighting punctuation in the Edit window.



Numeric Colour button (Display options)
Change numeric colour.
Presents a standard colour dialog and prompts the user to select a colour which will be used for syntax 
highlighting numerics in the Edit window.



Example source file window (Display options)
A small example source file in an Edit window to preview the display options the user has chosen before 
they are applied.



Apply button (Options)
Applies the currently selected options to Plato and closes the options dialog.



Default button (Options)
Reverses any changes that have been made and returns all options to their standard values.



Cancel button (Options)
Closes the options dialog discarding any changes that have been made to options.



Tab Indent option (Style options)
Select the number of spaces to indent each time the tab button is pressed.



Open project on startup option (Style options)
When checked the most recently used project will open automatically upon restarting plato.



Always add files to file list database option (Style options)
When checked each file that is opened will automatically be added to the list of recently used files.



Save window state on exit option (Style options)
When checked the size of the Plato application window will be saved each time you exit Plato and 
restored each time you restart.



Sticky indent option (Style options)
When checked Plato will automatically indent lines.



SCC path (Products options)
Enter the full path and filename of SCC (Salford C/C++).    If the path is not known, refer to the products’ 
installation manual.



FTN77 path (Products options)
Enter the full path and filename of FTN77 (Salford Fortran 77).    If the path is not known, refer to the 
products’ installation manual.



FTN90 path (Products options)
(Not Implemented)
Enter the full path and filename of FTN90 (Salford Fortran 90).    If the path is not known, refer to the 
products’ installation manual.



SRC path (Products options)
Enter the full path and filename of SRC (Salford Resource Compiler).    If the path is not known, refer to 
the products’ installation manual.



SLINK path (Products options)
Enter the full path and filename of SLINK (Salford Linker).    If the path is not known, refer to the 
products’ installation manual.



Browse buttons (Products options)
Allows the user to select the path and filename of a product via a browse dialog box.



SCC Manual path (Manuals options)
Enter the full path and filename of the SCC (Salford C/C++) online manual.    If the path is not known, 
refer to the products’ installation manual.



FTN77 Manual path (Manuals options)
Enter the full path and filename of the FTN77 (Salford Fortan 77) online manual.    If the path is not 
known, refer to the products’ installation manual.



FTN90 Manual path (Manuals options)
(Not Implemented)
Enter the full path and filename of the FTN90 (Salford Fortan 90) online manual.    If the path is not 
known, refer to the products’ installation manual.



Clearwin+ Manual path (Manuals options)
Enter the full path and filename of the Clearwin+ online manual.    If the path is not known, refer to the 
products’ installation manual.



Browse buttons (Manuals options)
Allows the user to select the path and filename of an online manual via a browse dialog box.



History tab (Source Manager)
The History tab maintains a list of all the files ever opened by Plato.    The files are sorted in 
alphabetical order.    A combo box at the bottom of the History tab allows the file names to be filtered by 
type.

Click on the part of the screen you want help on.

{button ,KL(`Source Manager;Project')} Related Topics



Information tab (Source Manager)
The Information tab displays all the details of the active source file.    Plato maintains Target Compiler 
Configuration details for each opened file, these details are restored when the file is opened.

Click on the part of the screen you want help on.

{button ,KL(`Source Manager;Project')} Related Topics



Project tab (Source Manager)

Click on the part of the screen you want help on.

{button ,KL(`Source Manager;Project')} Related Topics



History List (History tab)
Lists recently opened files with their filename, path and the date and time they were last modified..



File Type option (History tab)
Selects the type of files that should be displayed in the history list.    The following types may be 
selected:
C/C++
Fortran
Resource
Unknown
All



Refresh button (History tab)
Updates the history list.



Open button (History tab)
Opens the file currently selected in the history list.



Close button (Source Manager)
Closes the source manager window.



Always on top option (Source Manager)
When checked the source manager will stay on top of other windows.



The Source Manager
Overview
This is a Tab Control that can be placed anywhere on the desktop.    Use the Source Manager to 
manage your projects and to change how your source files are compiled.

Click on the part of the screen you want help on.

{button ,JI(`',`SOURCE_MGR_HISTORY')} History tab.
{button ,JI(`',`SOURCE_MGR_INFORMATION')} Information tab.
{button ,JI(`',`SOURCE_MGR_PROJECT')} Project tab.

{button ,KL(`Source Manager;Project')} Related Topics



File selection (Information tab)
Selects a file from those currently open.



Include File option (Information tab)
Check this box if the selected file is an include file.



Arguments option (Information tab)
Command line arguments that should be sent to the compiler when the selected file is compiled.



Compile options (Information tab)
Additional configuration that should be sent to the compiler when the selected file is compiled.
The options are:
Include debug information in object file.
Check for undefined pointers and arrays.
Check for references to undefined data.
Output browser information.



File type options (Information tab)
Selects the type of the currently selected file to determine how it should be compiled.    The following file 
types/target compilers may be selected:
SNC for C/C++ files
FTN77 for Fortran 77 files
SRC for Resource files
Unknown for files of unknown type.



File statistics (Information tab)
Displays statistical information about the currently selected file, such as the date and time the file was 
created.



Refresh button (Information tab)
Updates the file information for the currently selected file.



Default button (Information tab)
Reverses any changes that have been made to the target compiler configuration for the currently 
selected file and returns all options to their standard values.



Project Title option (Project tab)
A title which will be used to refer to the current project.    Press the right mouse button and select 
Rename to change the title.



New button (Project tab)
Create a new project.



Open button (Project tab)
Open an existing project.



Save button (Project tab)
Save the current project.



Save As button (Project tab)
Save the current project under a different name.



Close button (Project tab)
Close the current project.



Application window (Project tab)
Lists all the files in the current project.    Use the context menu (right mouse button) to manage the files 
in the application window.



Runtime Setup

Click on the part of the screen you want help on.

{button ,PI(`',`RUNTIME_ARGUMENTS')} Arguments
{button ,PI(`',`RUNTIME_SHELL')} Shell
{button ,PI(`',`RUNTIME_ENVIRONMENT')} Execution Environment

{button ,KL(`Execute;Execution;Options')} Related Topics



Arguments (Runtime setup)
Arguments that should be passed to the application on execution via the command line.



Shell (Runtime setup)
The shell that should be used to execute the application.



Execution Environment (Runtime setup)
Selects whether the application should be run as a Windows application or via a DOS console.



Browse button (Runtime setup)
Allows the user to select the path and filename of a shell via a browse dialog box.



OK button (Runtime setup)
Accept the current runtime setup options and close the Runtime Setup dialog box.



Cancel button (Runtime setup)
Discard the current runtime setup options and close the Runtime Setup dialog box.



How to... (Overview)
How to accomplish tasks using Plato.

Find out how to…
{button ,JI(`>how',`HOW2_CREATE_NEW_SOURCE')} Create a new source file
{button ,JI(`>how',`HOW2_OPEN_EXISTING_SOURCE')} Open an existing source file
{button ,JI(`>how',`HOW2_INSERT_EXISTING_SOURCE')} Insert an existing source file
{button ,JI(`>how',`HOW2_SAVE_SOURCE')} Save a source file to disk
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{button ,KL(`Introduction;Contents')} Related Topics



How to create a new source file
To begin a new source file.

Step 1
Select the New command from the File menu or click 

This opens a new, empty MDI Edit window in which you can type.

Step 2
Begin typing your source.
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How to open an existing source file
To begin editing an existing source file.

Step 1
Select the Open command from the File menu or click 

This presents a standard dialog similar to the File Open dialog of many windows applications.

Step 2
Use the dialog box to navigate your folders and select the file you want to edit then click the Open 
button.    The existing source file will be opened into a new MDI Edit Window.

Step 3
You can repeat steps 1 and 2 until all the source files you want to edit are open.

Tips
If you want to open more than one file in a single action you can hold down the CTRL key and click to 
select several files.

If you want to prevent accidental modification to the source file you are opening, check the Open as 
read-only in the File Open dialog.

Notes
When a file is opened the name is recorded in the Most Recently Used (MRU) list on the file menu, this 
list is saved and restored the next time Plato is started.    The file name is also appended to the Window 
menu and placed into a drop down list box on the toolbar.
This provides you with a number of ways to access the file.    Plato has been designed to open and hold 
many files at any one time.    There is a limit of 9 to the number of file names that can be appended to 
the Window menu.    The drop down list box on the toolbar, however, has no such limit and will display 
as many files as are open.

Plato supports Drag and Drop to open source files.    This enables you to drag a file from the desktop or 
from Explorer and drop it onto the Plato icon, or when Plato is running onto the Plato window.
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How to insert an existing source file
To insert an existing source file into the window that you're editing.

Step 1
Place the insertion point (text cursor) at the point where you would like the insertion to be made.

Step 2
Select the Insert command from the File menu.    This presents a standard dialog similar to the File 
Insert dialog of many windows applications.

Step 3
Use the dialog box to navigate your folders and find the find the file you want to insert and then click the 
Open button.    The file will be inserted into the active source file at the insertion point.

{button ,KL(`Insert')} Related Topics



How to save a source file to disk
To save a modified source file to disk.

Step 1
Select the Save command from the File menu or click 

If your source file has already been assigned a file name it will be saved to disk immediately.

If your source file is Untitled (That is your source file has not been assigned a file name) a Save As dialog 
box will be presented.    Proceed to step 2.

Step 2
Use the Save As dialog box to navigate your disk and find an appropriate folder to in which save the 
source file.

Step 3
Type a file name for your source file and then click the Save button.    Your source file will be saved to 
disk.

Tip
If you want to save all the files that you are working on select the Save All command from the File menu 
instead.
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How to close a source file
To close a source file when you’ve finished editing it.

Step 1
Select the Close command from the File menu.

Step 2
If you have made some modifications to the source but haven’t yet saved to disk Plato will first ask you 
whether you want to save the modifications.

Tip
If you want to close all the files that you are working on select the Close All command from the File 
menu instead.

{button ,KL(`Close')} Related Topics



How to print a source file
To print a source file.

Step 1
Select the Print command from the File menu or click 

This presents a standard dialog that is similar to the Print dialog of many windows applications.

Step 2
Select what part of the file you want to print: you can choose to print either all or part.

Step 3
Select the number of copies you want to print and then click the OK button.    Your source file will begin 
printing.

{button ,KL(`Print;Print Setup')} Related Topics



How to type text

You can type text with Plato in the same way as for any other Windows application.
Normally, everything you type appears on the screen in the active MDI Edit Window, displacing other 
characters to the right.    This is termed Insert mode.
If you prefer, you can switch to working in Overwrite mode, where a character you type will replace the 
one under the insertion point (text cursor).
Pressing the Ins key changes from one mode to the other

{button ,KL(`Editing')} Related Topics



How to Cut, Copy and Paste text
Plato uses the standard Windows clipboard for cutting, copying and pasting text.    You can cut, copy and 
paste text in one edit window; between several edit windows; or between other applications.

To cut or copy text onto the clipboard.

Step 1
Highlight the text you want to cut or copy by dragging the cursor with the mouse. 

Step 2
Select the Cut or the Copy command from the Edit menu or click  or 

When cutting the highlighted text will be removed from the active source file.    In either case the 
highlighted text will be placed on the clipboard.

To paste text from the clipboard.

Step 1
Place the insertion point (text cursor) at the point where you would like the clipboard text to be pasted.

Step 2
Select the Paste command from the Edit menu or click 

The clipboard text will be pasted at the insertion point.
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How to find text
To search for an occurrence of some text in an edit window.

Step 1
Select the Find command from the Edit menu or click 

This presents a standard Windows dialog that lets you specify what text you want to look for, and other 
details.

Step 2
Type the text you want to search for in the Find What box. 

Step 3
Set the direction of search.    The search will start from the current insertion point (text cursor) you have 
the option of searching Up to the beginning of the source file or Down to the end of the source file.

Step 4
Click the Find Next button to start the search, you can repeat step 4 until the correct text is found.

Step 5
To close the dialog, click the Cancel button.

Tip
If you want to search in another edit window, simply activate it while the Find dialog is still on screen and 
click the Find Next button again.
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How to replace text
How to search for some text and replace it with alternative text.

Step 1
Select the Replace command from the Edit menu.    This presents a standard Windows dialog that lets 
you specify what text you want to replace, and other details.

Step 2
Type the text you want to search for in the Find What box. 

Step 3
Type the text you want to replace it with in the Replace With box.

Step 4
Click the Find Next button to start the search, you can repeat step 4 until the correct text is found.

Step 5
Click the Replace button to replace the found text with the text you specified in the Replace With box.

Step 6
To close the dialog, click the Cancel button.

Tip
To replace all occurrences of the text click the Replace All button.
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How to compile a source file
To compile a single source file.

Step 1
Select the Compile File command from the Project menu or click 

A dialog box will appear while the source file is compiled.

Step 2
When the file is compiled the Compilation Status window will appear showing the number of errors, 
warnings and comments.    If the compile has been successful the Compilation Status Icon will turn 
green, if not it will turn red.

Click the part of the dialog box you want help on.

Step 3
Click the Details button to open the Message window and view any errors, warnings and comments.

Step 4
Click the OK button to close the dialog.
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Compiler label (Compilation dialog)
The name of the compiler used to compile the file.



Compilation Status icon (Compilation dialog)
Shows the status of the compilation.
White: Compiling
Green: Compilation Successful
Red: Compilation Failed



Filename (Compilation dialog)
The name of the file compiled.



Compilation Status window (Compilation dialog)
Lists errors, warnings and comments produced by the compiler.



OK button (Compilation dialog)
Closes the dialog.



Details button (Compilation dialog)
Opens the message window and displays errors, warnings and comments.



Cancel button (Compilation dialog)
Cancels the compilation and closes the dialog.



How to work with project files
Source files can be arranged into projects using the Source Manager this allows the user to easily 
manage quite large applications with many source files.

How to create a new project file.

Step 1
Open the source manager by clicking 

Step 2
Click the Project tab to view the project page of the source manager.

Step 3
Click the New button on the Project page of the source manager.
This creates a new blank project.

Step 4
Give the project a suitable title by clicking on the text box which is at the top of the window and selecting 
Rename.

Step 5
Build a list of source files.    Right click on the icon Compilation File List in the Application tree and 
select Add Item(s).    This presents a standard dialog similar to the File Open dialog of many windows 
applications.

Step 6
Use the dialog box to navigate your folders and select the source file(s) that are part of this application 
then click the Open button.    The source file(s) you have selected will be displayed in the Application 
tree.

Step 7
Create a dependency tree.    For each source file you have added, use the right mouse button to click 
it’s icon in the Application tree and select Add Item(s).    This presents a standard dialog similar to the 
File Open dialog of many windows applications.

Step 8
Use the dialog box to navigate your folders and select the include file(s) that are dependent on the 
source file then click the Open button.    The include file(s) you have selected will be displayed under the 
source file in the Application tree.

Step 9
You can further manage the project file using the context menu that is activated using the right mouse 
button when the cursor rests in the Application tree window.

Step 10



Double click a file in the Application tree to open it for editing.

Notes
When a project is built all the files in the application tree are processed and any files that do not have an 
up to date object file are compiled.

Tip
To build a whole project in one easy step click 
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How to configure Plato
Plato can be easily configured to suit your preferred working environment, the configuration setting are 
stored in the Windows registry and restored each time you start Plato.

Step 1
Select the Options command from the Tools menu.

Step 2
Select a page of options by clicking on it’s tab.    There are five tabs as listed below.

Click a button to obtain help on an individual options page.
{button ,JI(`',`OPTIONS_DISPLAY')} Display options.
{button ,JI(`',`OPTIONS_KEYBOARD')} Keyboard options.
{button ,JI(`',`OPTIONS_STYLE')} Style options.
{button ,JI(`',`OPTIONS_PRODUCTS')} Products options.
{button ,JI(`',`OPTIONS_DISPLAY')} Manuals options.

Step 3
Use the controls on the various pages of the options dialog to define your preferred settings.

Step 4
Click the Apply button.    Your settings will be applied immediately and stored for use next time you start 
Plato.

Tips
You can restore all the options settings to their default (standard) values by clicking the Default button.    
Your preferred settings will be lost.

You can specify whether you want Plato to store options settings and use them next time, or alternatively 
to use settings on a per-session basis only.    Use the Save settings on Exit command on the Tools 
menu, a check mark on the Tools menu is displayed to show the current behaviour.
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How to use this help file
This help file contains help topics for all of Plato’s commands.

{button ,HelpOn()} Click this button to view help with using the windows help system.

{button ,KL(`Help')} Related Topics








