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1

Introducing 
Vegas Pro
Welcome to Sonic Foundry Vegas Pro™

Sonic Foundry proudly introduces Vegas Pro, an innovative and technologically advanced 
multitrack media editing system. Vegas Pro was designed with one thing in mind: to create a 
more efficient audio/video production environment without sacrificing the exceptional 
quality and superior processing power professionals expect from Sonic Foundry. 

Vegas Pro removes the barriers commonly found between your creativity and sophisticated 
multitrack recording and editing. Whether it's the standard and familiar Windows 
navigation commands, or the clean and uncluttered UI throughout, you'll find Vegas Pro a 
tool that will be mastered in minutes. But don't let that fool you. Beneath the Vegas Pro 
unique and customizable interface, you'll find a product so powerful and flexible, you'll 
forget you've just completed your project in half the time. 

Below are some of the features available in Vegas Pro; the perfect multitrack media editing 
system for your studio or production environment:

Non-destructive editing Unlimited tracks 
Unlimited undo/redo Multiple file formats (.wav/.aif) on a single track
Automatic crossfade functionality EQ and compressor inserts available on every channel
Quick-edit media trimmer  with direct link to 
wav editor

Simultaneous multitrack record & play

Loop recording Plug-In manager
Real time event resampling 32 assignable DirectX FX sends 
Audio/video scrub DirectX Plug-In support
Video preview window Dual processor support
Edit detail list management Multiple I/O support
24-bit/96 kHz MIDITime Code sync
26 Aux outputs Dual monitor support
Internet streaming file authoring (Windows 
Media Technologies 4.0 and RealNetworks G2)

Ability to incorporate timeline metadata (markers/
captions) for Internet content authoring

Imports: .wav, .aif,  .avi, .mov (using Microsoft 
DirectShow), .mpg (video), .bmp

Exports: .wav, .aif, .avi, .wma, .asf, .rm, .mp3 
(with optional plug-in)
INTRODUCING VEGAS PRO
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System requirements

Your system’s components affect how well Vegas Pro performs. 

Common

• Microsoft® Windows™ 9x or NT 4.0
• CD-ROM drive
• 20 MB hard-disk space for program installation
• Windows-compatible sound card
•  Internet Explorer™ 4.0 (included on CD-ROM) or later to view Online Help 

Minimum

• 200 MHz processor
• VGA display
• 32 MB RAM
• DirectX Media 6.0 (included on CD-ROM) or later 

Recommended

• 400 MHz processor
• 128 MB RAM
• 16-bit color display

Technical Support

If you experience problems or have questions while using Vegas Pro, there are a few ways to 
get the information that you need from Sonic Foundry: Web site support, Email support, Fax 
support, and Telephone support. 

Web site support

Visit our Web site at www.sonicfoundry.com/support. You will find technical information, 
reference information, program updates, tips and tricks, and a Frequently Asked Questions 
(FAQ) archive. 

Email support

Send your questions or comments to support@sonicfoundry.com. Our Technical Support 
Department will respond to you within 36 business hours. 
INTRODUCING VEGAS PRO CHP. 1
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Fax support

Send your questions or comments via fax 24 hours a day at (608) 256-7300. You will receive 
a response within 36 business hours.

Telephone support

Our technical support representatives are available Monday-Friday from 8am to 7pm (CST) 
at (608) 256-5555.

Before You Call Support

Before you contact our technical support department, we ask that you do the following:

• Check to see if your question may be answered in the manual or online help. 
• Use a telephone that is near the computer where Vegas Pro is installed.
• Make sure you have registered the product. For more information, see Registration on page 9.

 Installing Vegas Pro

Before you install Vegas Pro, we recommend that you exit all open programs and temporarily 
disable any virus protection. 

1. Insert the Vegas Pro CD-ROM. The Vegas Pro Installation screen will appear (If CD-
ROM AutoPlay is enabled).

2. Click Install Software. The installation process will begin.

If the CD-ROM AutoPlay is disabled, click on the  button and choose Run. 

In the Run window that appears, type the CD-ROM drive’s letter and add :\setup.exe. 
Click the OK button to start the installation.

3. Follow the screen prompts and enter the necessary information when required. 

• Use the  button to continue the installation.
• Use the  button to suspend the installation and review previous screen prompts.
• Use the  button to terminate the installation process.

4. At the last screen prompt, click the  button to conclude the installation.
CHP. 1 INTRODUCING VEGAS PRO
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Starting Vegas Pro

Starting Vegas Pro is exactly the same as starting most Windows programs that you may use 
already. After Vegas Pro has been installed on your computer, there are two ways to start the 
program. 

Using the shortcut

You may have noticed a new icon on your desktop ( ) upon completion of the installation 
procedure. This icon is a shortcut to the Vegas Pro program located on your hard drive. By 
double-clicking on this icon, you will start Vegas Pro directly from the desktop.

Using the Start button

The second method to start also allows you to start Vegas Pro right from the desktop. This 
procedure is exactly the same as other Windows-based programs. 

1. Click the  button on the task bar. The Start menu appears.

2. From the Start menu, select the Programs option. The Programs list menu appears.

3. From the Programs menu, select Sonic Foundry Vegas. A sub-menu will appear.

4. From the sub-menu, click on Vegas Pro to start the program. The registration dialog 
window will appear. 

5. Enter either the serial number or the activation number and click Finish to start using 
Vegas Pro. (The serial number is located on the first page of the manual.)

This graphic displays the default location where Vegas Pro was installed.
If you specified a different directory during installation, then navigate
to that directory via this menu.

Enter either the serial or 
activation number here
INTRODUCING VEGAS PRO CHP. 1



9

Serial and activation numbers

The first time you start Vegas Pro the registration window will appear. You need to enter 
either the serial number or the activation number. Either number will start Vegas Pro so that 
you may immediately begin your first project.

The serial number is located on the first page of the manual. This number allows you to run 
Vegas Pro for 7 days. After the 7 days expire, Vegas Pro will time out. If you purchased Vegas 
Pro, you can receive your activation number by registering either online or by telephone.

Note: If you have started a project and Vegas 
Pro times out, you will not lose the project. It 
will be available when you start the program 
after you have registered, received, and entered 
your activation number.

An activation number is based on the Computer ID number where Vegas Pro is loaded. Each 
computer has a unique number, similar to a license plate. An activation number is created 
based on that unique number. When you register Vegas Pro, Sonic Foundry will generate an 
activation number for you. Once the activation number is entered Vegas Pro will not time 
out; it is yours. Because the activation number is based on the Computer ID, it is important 
that you have Vegas Pro loaded on the computer where you will be using it. 

The Computer ID is automatically detected and provided to you when you install Vegas Pro.

Registration

The registration dialog window that appears when you start Vegas Pro allows you to quickly 
and easily register to get your activation number. You may register via the Sonic Foundry 
Web site or via the telephone.

Registering online

When you register online, your activation number is sent to your email address within 
minutes after you complete and submit the online registration form. 

To register online, do the following.

1. Select the second radio button labeled I would like to register online.

2. Click the Next button. Your internet browser will automatically start (if it is not already 
running) and the Sonic Foundry online registration form will appear. 
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3. Fill in the form’s required fields, which are indicated with an asterisk (*). You will notice 
that some of the information is already inserted for you, most notably the Computer ID 
number.

4. Make sure that your email address is entered correctly. This address is where the 
activation number will be sent.

5. Submit the form to register. In a few minutes, your activation number is sent to your email 
address.

6. Copy the activation number from the email message and paste it into the registration 
field on the Vegas Pro Registration window.

7. Click the Finish button to activate Vegas Pro and become a fully registered customer.

Registering via the telephone

When you register via telephone, a Customer Service Representative will help you to obtain 
your activation number.

To register via telephone, do the following.

1. Select the third radio button labeled I would like to register over the phone.

2. Click the Next button. A new window will appear with a field where you will enter the 
activation number. Your Computer ID number appears below this field.

3. When the Customer Service Representative gives you the activation number, type it in 
the field.

4. Click the Finish button to activate Vegas Pro and become a fully registered customer.

Using the online help

Vegas Pro includes HTML online help. To view the online help, you need to have Internet 
Explorer 4.0 or higher loaded on your system (included on the Vegas Pro CD-ROM).

As you use this manual, you will see the help icon ( ) in the outside margin next to 
selected topics. This icon is to notify you that additional information is available in the 
online help. 

Enter activation number

Computer ID number
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Accessing help

The online help is available in two forms: in a Main help window or What’s This? help. 
Both forms are available via the keyboard or the Help menu.

Main help window

The Main help window is access either by choosing Contents and Index from the Help menu 
or pressing the  key. This window has three tabs with which you can use to find the 
information that you need.

The Contents tab provides a categorized listing of available help topics. Click on the book 
( ), then on the topic page ( ) you want information about.

The Index tab provides a complete listing of the help topics available. Use the scroll bar to 
scroll through the list of available topics or type a word in the text box to quickly locate 
topics related to the word. Select the topic and click the Display button.

The Search tab allows you to enter a keyword and display all of the topics in the Online Help 
that contain the keyword you have entered. Type a keyword in the text box and click on the 
List Topics button. Select the topic from the list and click the Display button.

What’s This? help

What's This? help allows you to view pop-up window descriptions for Vegas Pro menus, 
buttons, and dialog boxes. Choose What's This? from the Help menu, and then click on any 
Vegas Pro item. To use What's This? help in a dialog box, click on the question mark ( ) in 
the upper-right hand corner of the dialog box, then on an item. 

Tip of the Day

The Tip of the Day displays functional tips to increase your productivity with Vegas. To view 
and scroll through the Tip of the Day messages, choose Tip of the Day from the Help menu.

F1

Toolbar
Contents

Information
pane

Index tab

Search tab
tab
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PDF manual

There is a more current manual available on the Vegas Pro CD-ROM. The PDF manual 
contains information that written during this manual’s press time.

Help on the Web

Additional Vegas Pro help and information is available on the Sonic Foundry Web site. 
Choose Sonic Foundry on the Web from the Help menu to view a listing of Web pages 
pertaining to Vegas Pro and Sonic Foundry. If your browser is not already open, Vegas Pro 
will automatically start it for you.

Overview

Vegas Pro is designed to be an easy-to-use program with many tools that provide power and 
flexibility when creating and working with media files. As you will learn, many of the Vegas 
Pro operations, menu items, and shortcut keys are common to other popular software 
applications. 

Vegas Pro is a unique and powerful program that gives you tremendous flexibility. The 
following sections are a graphical tour of the Vegas Pro work area. Please take a moment to 
get familiar with the Vegas Pro interface. Many of the procedures in this manual use 
terminology found in these sections. 

Main window

This is the window that appears when you open Vegas Pro. The work area is primarily three 
frames: the Track List, the Track View, and the Window Docking Area. The other parts of 
the interface are tools and features used while working with your project. 

Menu Bar

Toolbar

Time Display

Track List

Scrub Control

Window
Docking 
Area

Video Ruler

Marker Bar
Ruler

Track View

Transport Bar
Explorer (shown)
Mixer (shown)
Trimmer
Video preview
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Toolbar

The Toolbar allows you to quickly access the most commonly-used functions and features in 
Vegas Pro.

Marker bar

The Marker bar is the area where informational tags may be placed, named, and positioned 
along the project’s timeline.

Create new project Redo command

Open existing project Enable snapping to grid lines

Save project Automatic crossfades

Open project properties Ripple edits

Cut selected events or time range Edit tool

Copy selected events or time range Envelope tool

Paste items from clipboard into project Selection tool

Undo command Zoom tool
CHP. 1 INTRODUCING VEGAS PRO
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Ruler

The Ruler is the timeline for your project. You may specify how the Ruler measures time: 
seconds, measures and beats, frames, etc.

Track List

This list identifies the track order in your project. Each track’s controls are also available in 
the Track List.

Right-click 
on Ruler

Track controls

Track Number
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Track View

All arranging and editing is done in the Track View. This area contains all the project’s 
events.

Transport bar controls

The Transport bar contains the playback and cursor positioning buttons frequently used 
while working on your project.

Scrub control

The Scrub control is used to play your project forward or backward for editing purposes. You 
may adjust playback speed by setting the Speed Control Marker located beneath the Scrub 
control.

Record into track Stop playback

Loop play back Move cursor to start of project

Play back from beginning of project Move cursor to end of project

Play back project from cursor position Move cursor left at grid increments

Pause project playback Move cursor right at grid increments

Track View

Set play-

Click and drag either forward

back speed

or backward for playback
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Window Docking Area

This area allows you to keep frequently-used windows available, but out of the way while you 
are working with a project. To dock a window, simply drag and drop it to the Docking Area. 
This area has three regions in which a window can be placed: right, middle, and left. As a 
result, the Docking Area can display up to three windows at a time.

When windows are docked, they will either be displayed on top of the other windows, or 
each window’s tab will appear above the task bar. Simply click the window’s tab to bring it 
the top. 

Explorer window

The Explorer window works similarly to the Windows 9x and NT file management Explorer 
included with your operating system. Use the Vegas Pro Explorer window to select media 
files to place into your projects.

One window display

Two window display

Three window display These windows are fully
scalable to suit your needs.

Click a window’s tab to 
bring it to the top.

Select drive 

Preview selected
media file before
you place it
in the project

or folder

Select media to place 
in the project by dragging
and dropping or 
double-clicking
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Video Preview window

This window displays a project’s video event during project editing and playback. If a video 
event is not a placed in the project, you will see “--No Video--” in the center of this window.

Trimmer window

The Trimmer window is a good place to edit an audio event. When an event is placed in the 
Trimmer window, you may take portions of the event and place them on separate tracks by 
dragging and dropping.

Mixer window

The Mixer window gives you access to your project’s properties, bus assignments, output 
levels, and effects chains.

Video will appear during
project playback or as
the cursor is moved 
during editing.

Right-click to 
change Video
Preview settings

Trimmer window
Transport bar

Right-click on the 
meter to change
its settings
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Keyboard command reference

Vegas Pro keyboard commands are shortcuts that you can use while working with your 
project. 

Project file commands

Window view commands

Edit commands

Create new project Ctrl+N

Open existing project or media file Ctrl+O

Save project Ctrl+S

Open project’s properties Alt+Enter

Exit Vegas Pro Alt+F4

Track view Alt+0 Edit Details Alt+4

Explorer Alt+1 Plug-ins Alt+5

Trimmer Alt+2 Video Preview Alt+6

Mixer Alt+3

Undo Ctrl+Z or 
Alt+Backspace

Restore selection Backspace

Redo Ctrl+Shift+Z Paste repeat from clipboard Ctrl+B

Cut selection Ctrl+X or 
Shift+Delete

Split event(s) S

Copy selection Ctrl+C or 
Ctrl+Insert

Trim/Crop selected events Ctrl+T

Paste from clipboard Ctrl+V or
Shift+Insert

Open in Sound Editor Ctrl+E

Select all Ctrl+A Mix to new Ctrl+M

Unselect all Ctrl+Shift+A Mix to preview Ctrl+Shift+M

Delete selection Delete
INTRODUCING VEGAS PRO CHP. 1
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Cursor placement commands

Playback commands

Event commands

Track view commands

Go to beginning of selection 
or view (if no selection)

Home or W Center in View \

Go to end of selection or view 
(if no selection)

End or E Swap on selection Num. pad 5

Go to beginning of project Ctrl+Home Move left to marker(s) Ctrl+Left (arrow)

Go to end of project Ctrl+End Move right to marker(s) Ctrl+Right (arrow)

Move left by grid marks Page Up Move left to event edit points 
including fade edges

Ctrl+Alt+Left 
(arrow)

Move right by grid marks Page Down Move right to event edit points 
including fade edges

Ctrl+Alt+Right

Go to Ctrl+G

Start/stop playback Spacebar Pause Enter

Stop playback Esc Record Ctrl+R

Looped playback L Play back from any window Ctrl+Spacebar or F12

Move selected event(s) one 
pixel

Right (arrow) 
number pad

Move selected event(s) down one 
tracktrack

Down (arrow) 
number pad

Move selected event(s) one 
pixel

Left (arrow) 
number pad

Move selected event(s) right on grid Ctrl+Right (arrow) 
number pad

Move selected event(s) up 
one track

Up (arrow) 
number pad

Move selected event(s) left on grid Ctrl+Left (arrow) 
number pad

New audio track Ctrl+Q Group selected events G

Enable/disable snapping F8 Mark in point I or [

Snap to markers Shift+F8 Mark out point O or ]

Snap to grid Ctrl+F8 Insert/Remove track-volume envelope V

Ripple edit mode Ctrl+L Insert/Remove track-panning envelope P

Auto crossfade mode X Insert Region R

Edit tool selection D Insert Marker M

Normal edit tool Ctrl+D Insert Command Marker C
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View commands

Miscellaneous commands

Increase track height Ctrl+Shift+Up 
(arrow)

Zoom out large increments or selection 
(if one exists)

Ctrl+Down 
(arrow)

Decrease track height Ctrl+Shift+Down 
(arrow)

Zoom in large increments or selection 
(if one exists)

Ctrl+Up 
(arrow)

Zoom in time (incremental) Up (arrow) Zoom in vertically Shift+Up (arrow)

Zoom out time(incremental) Down (arrow) Zoom out vertically Shift+Down (arrow)

Online help F1 Popup menu Shift+F10

What’s This? help Shift+F1 Refresh screen F5
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Vegas Pro 
Quick Start
The Vegas Pro environment is a new way of thinking in multitrack mixing. Whether you are 
experienced at mixing or brand-new to it, you will find Vegas Pro easy to use and powerful. 
As you use Vegas Pro, experiment with different features and listen to the results in real- 
time. 

This chapter was designed to help you get familiar with the interface and describe the 
essential operations for using Vegas Pro. Using this chapter will get you into the program 
quickly to begin your first project or to begin experimenting with Vegas Pro. In the next 
chapter, we take you through a sample project from start to finish, using sample media files 
included on the Vegas Pro CD-ROM. For more information, see Vegas Pro Tutorial on page 59.

Media Files

Before we get started in Vegas Pro, there are a few terms that need to be defined:  

• Media files - audio and video files that may be placed within your project.
• Events - playable portions of media files within a track. Events have fully editable starting 

and ending points. 
• Tracks - timeline containers where events are placed and arranged.

What type of media can you use?

A media file is an audio file that can be placed on a track or a video file that can be placed 
on the video ruler.

Format Name Extension Definition
Wave (Microsoft) *.wav Standard audio format used on Windows-based computers
Video for Windows *.avi Standard audio/video format used on Windows-based computers
AIFF *.aif Standard audio format used on Macintosh computers
QuickTime *.mov Standard audio/video format used on Macintosh computers (using Mircosoft DirectShow)
Bitmap *.bmp Standard graphic format used on Windows-based computers
MPEG3 *.mp3 Highly compressed media file. This file type can only be placed via plug-in.
VEGAS PRO QUICK START
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A media file is referred to as an event after you have placed it on a track. Tracks are the 
containers for audio events. Each track can contain more that one event.

You may place events on separate tracks, or place all events on the same track:

In addition, you may place a video file on the Video Ruler. If the video has audio included, 
Vegas Pro automatically creates a new track and places the video’s audio on it. 

Starting a project

When you first open Vegas Pro, it displays an empty project. You may begin finding, 
previewing, and placing media files and start building your project. Vegas Pro supports many 
types of media file formats for placement, editing, and rendering to new media formats. 

The following sections briefly explain the process of finding media files, previewing them, 
and placing them within your project. 

Finding media files to use

There are two ways to find media to place in a project: using the Explorer window or the 
File>Open option.

The Explorer Window

The media Explorer window in Vegas Pro works similarly to the Windows 9x and NT file 
management Explorer included with your operating system. You can expand and collapse 
drives and folders in the tree view. The content of selected drives and folders appears in the 
list view.

Single track with Multitrack with 
single events multiple events

Video ruler with included
audio on track below.
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Note: If you cannot see the Explorer window, 
it may be “under” another window. Click the 
Explorer tab to display the window. If you do 
not see the Explorer tab, choose Explorer from 
the View menu to display it.

Using the Vegas Pro Explorer allows you to place multiple file types into your project 
simultaneously. To find media using the Explorer window, do the following:

1. From the drop-down list or tree view, choose the drive or folder where the media is 
located. 

Note: Vegas Pro is preset to display all 
supported file types. However, you may 
change the list view to display all files within a 
selected drive or folder.

2. From the list view, you may place the file into your project by dragging and dropping or 
double-clicking it.

Change view button
Auto-preview button
Stop preview button
Play preview button
Add to favorites folder
Delete selected items
Create new folder

Refresh view
Move up tree

Vegas Pro windows are dockable. To access
a hidden window, click its tab to bring 
it forward.
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The File>Open option

An alternative to the Explorer window, you may find media in the more traditional method 
using the File>Open option. With the File>Open option, you specify the media file type 
that you want to use in the project: *.wav, *.avi, etc.

To find media using File>Open, do the following:

1. From the File menu, choose Open. The Open window appears.

Or, click the  button on the Toolbar.

2. Select the media’s location by doing one of the following:

• Specifying it from the Look in drop-down list.
• Double-clicking drives and folders in the list view.
• Typing the file’s path in the File name field.

3. Select the media format from the Files of type drop-down list.

4. Press the Open button to automatically place the file in the project.

Previewing a media file

Once you have located media files, you may preview them before placing them in your 
project. The Explorer window has a mini-transport bar with Play, Stop, and Auto Preview 
buttons( ). 

When you preview a file, its signal is sent to the Mixer window’s preview bus. This bus 
displays levels, which you can adjust with its Volume Slider. 

To preview the audio file, do the following:

1. Select an event in the list view.

2. Press the Play ( ) button to listen to the file.

3. Press the Stop ( ) button, select a different file, or place the file in the project to stop 
previewing to the file.

Note: To automatically preview selections, 
press the Auto Preview ( ) button on the 
Explorer’s Transport Bar. To turn off Auto 
Preview, press the Auto Preview button again.
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Placing a media file on a track

Audio media files may be placed in your project by either dragging and dropping or double-
clicking them. Either method places the media file in its entirety in the track window. After 
the file is placed, it becomes (and is referred to as) an event along the project’s timeline.

Dragging and dropping an event

This method controls the event’s occurrence on the track window’s timeline. You can create 
a new track by dragging an event to a blank area in the track window and dropping it in 
place. Vegas Pro tracks can contain multiple events, so you can place different events next 
to each other on a track.

In addition, you may place multiple events at the same time and control their arrangement 
in the track view. Vegas Pro is preset to place the events on separate tracks. 

To place multiple events, do the following:

1. Select a range of concurrent media files by holding down the  key and clicking files 
in the list view. 

Or, select files that are not concurrent by holding down the  key and clicking files.

2. Drag the files to the Track View.

3. Cycle through the placement options by right-clicking. As you click, Vegas Pro displays 
outlines of the selected events and the placement option. When you see the option that 
you want, drop the events in place. Below is a list of placement options: 

• Place events on separate tracks

• Place events next to each other on the same track

• Place events as takes on a track 

Shift

Ctrl

You will see one event on the track.
The other events are listed at takes “beneath” the 
the topmost event.
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Double-clicking an event 

This method creates a new track and places the event at the cursor’s position along the 
timeline. However, once the events are placed, you can move them from one track to 
another or change their position on the timeline.

Placing a event on the Video Ruler

A video media file may be placed in your project by either dragging and dropping or double-
clicking. The video is placed on the Video Ruler, located above the audio tracks. If the video 
file includes audio, the audio is placed below the Video Ruler on a newly-created audio 
track.

Dragging/dropping or double-clicking a video event

Video event placement is the same as placing an audio event; dragging and dropping 
controls timeline placement and double-clicking places the event at the cursor’s position. 

The Video Ruler supports one video event at a time. So, whether or not an event exists on 
the Video Ruler only affects what happens in your project when you place a video event. 
The following table describes placement scenarios:

Event selection basics

Vegas Pro projects are multitrack compilations of events that occur over time. As a result, 
you can work with placed events individually or as they occur over time. Vegas Pro gives you 
the flexibility to select one or more events, a time range, or events and time range. All 
selection options may be across multiple tracks. You are not limited to working on one track 
at a time. 

To select an event, simply point and click on it.

Event to place Video ruler status Placement method Result
Video only No event Drag/drop or double-click Video placed on ruler
Video with audio No event Drag/drop or double-click Video placed on ruler and audio on a new track
Video with audio event placed Drag/drop or double-click Audio on new track
Video with audio event placed Drag/drop to video ruler Video placed on ruler and audio on a new track
Video only event placed Double-click No affect (existing video is not replaced)

Selected Non-selected 
eventevent
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Selecting multiple track events

By using the  key, the  key, or the Selection Edit tool ( ), you may select 
individual or multiple events in your project. Multiple events may be selected within a track 
or across tracks. Once events are selected, you may apply any of the Edit menu commands or 
editing shortcut keys to them collectively.

Whichever method you choose, you may include or exclude events from a selection area by 
holding down the  key and clicking on an event.

Using the Ctrl key to select an event

The  key allows you to select events manually.

1. Hold down the  key.

2. Select the events by clicking on them. To deselect an event, simply click it again (this is 
called "toggling" the event selection on or off). 

Using the Shift key to select events

The  key on your keyboard allows you to select project events sequentially.

1. Hold down the  key.

2. Click the first event that you want to select. 

3. Click the last event that you want to select. All events between the first and last selected 
events are highlighted.

Using the Selection Edit tool

The Selection Edit tool ( ) allows you to select events as a block.

1. On the Toolbar, click the  button.

2. Point the cursor in a corner of the area that you want to select.

3. Press and hold the left mouse button.

4. Drag the cursor to the opposite corner of the area you want to select.

5. Release the mouse button. The events are highlighted.

Note: While using the , you may toggle 
through 3 selection modes by right-clicking.

Ctrl Shift

Ctrl

Ctrl

Ctrl

Shift

Shift
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Selecting a time range

Vegas Pro has a time selection bar that is located above the ruler. This bar displays, with a 
shaded box, the time range that you have selected. You may use the time selection bar for 
playing back a smaller portion of your project or to apply cross-track edits.

Unless an event is locked, a selected time range affects all events, or portions of events, that 
occur within the range. If you are editing the time range, only events that occur within the 
time range will be affected.

To select a time range, do the following:

1. Place the mouse pointer above the ruler (on the Marker bar). The mouse pointer includes 
a left/right arrow ( ). 

2. Click and drag to select the region. All events, or portions of events within the region are 
highlighted.

3. Place the mouse pointer over the time selection’s start or end point to increase or decrease 
your time range selection.

Note: You may move the entire selection 
range by dragging the Time selection bar.

If you want to play back the time range, press the Play button ( ) to listen to only the 
events within the time range. Press the Loop button ( ) to have Vegas Pro continually play 
back the events within the selection.

Time selection bar

Only the events within 
the time selection will be
affected by edits or be
played back.
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Selecting events and a time range

Selecting a time range does not automatically select events. It simply selects a time frame of 
the project. Excluding locked events, all items within the time range will play back and be 
affected by Edit menu commands such as cutting, pasting, etc. However, you may select 
specific events to edit or play back, and then select a time range. 

1.  Use the  key, the  key, or the Selection Edit tool  to select the events. For 
more information, see Selecting multiple track events on page 29.

2. Place the mouse pointer above the ruler (on the Marker bar). The mouse pointer includes 
a left/right arrow ( ). 

3. Click and drag to select the region. Notice that events that were not selected remain 
unselected (not highlighted).

4. Place the mouse pointer over the time selection’s start or end point to increase or decrease 
your time range selection. 

Ctrl Shift

Non-selected eventSelected event

Selected event

Selected eventNon-selected event
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Audio event basics

There are a number of ways to work with events once they have been placed in your project. 
Whether you are working to achieve a specific project goal, or experimenting with sound 
and video, the events that you placed are fully editable. The following sections describe 
basic event editing techniques. 

Moving events along the timeline

An event, by definition, is an occurrence along the project’s timeline. Events, as a result, 
may by moved along the timeline either individually or as a group. The left edge of an event 
is its starting point. Therefore, where the left edge lines up on the ruler determines when the 
event starts. 

Events may overlap each other or be placed on top of each other. You may crossfade 
overlapping events automatically or with envelopes.

Moving a single event

You can move an event along the timeline within a track or move it to a different track.

1. Select the event by clicking on it. The event is highlighted.

2. Click and drag the event along the timeline. 

If you move the event along the original track’s timeline, the event’s appearance (color) 
remains the same.

 

However, you may move the event to a different track’s timeline. If you do, the event 
appears as a simple outline and you will see its original track and position on the timeline. 
Once you release the mouse, the event will assume the new timeline position and track 
color.

3. Release the mouse to set the event’s timeline occurrence. 

4. Repeat Steps 1-3 to move more events along the timeline.

Original track position

New track and position
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Moving multiple events

You can move multiple events along the timeline within a track or move them to a different 
track, similar to the previous procedure. In addition, selected events do not need to be 
within the same track. You may select events on different tracks and move them as a group 
along the timeline.

1. Use the  key, the  key, or the Selection Edit tool  to select the events. For 
more information, see Selecting multiple track events on page 29. 

2. Place the mouse cursor over one of the selected events.

3. Click and drag the events along their respective timeline(s).

If you move the events along their original tracks’ timeline, their appearance (color) 
remains the same.

You may move the events to different track timelines. In that case, the events appear as 
simple outlines and you will see their original tracks and positions. When you release the 
mouse, Vegas Pro automatically creates new tracks as needed for events.

4. Release the mouse to set the events’ timeline occurrences.

5. Repeat Steps 1-4 to move more events collectively along the timeline.

Ctrl Shift

Moving events along 
original tracks

Moving events to
different tracks
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Copying events

Vegas Pro allows you to copy events, or portions of events, to the clipboard and paste them 
into your project. You may copy a single event or multiple events. Copying preserves the 
original event information that is being copied.

To copy events, do the following:

1.  Click on the event.

To copy multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple track events on page 29.

2. Select your time range, if applicable. Otherwise, skip to step 3.

3. Copy the event to the clipboard by doing one of the following:

• Press the  keys.
• Click the Copy button  on the Toolbar. 
• From the Edit menu, choose Copy.

The following table briefly describes copying scenarios and how the clipboard is used.

Selection Definition Events before copy Clipboard contents Events after copy
Time only Events within the time selection 

are reproduced and placed on 
the clipboard.

Also, the time information is 
placed on the clipboard. 

Time &
events

Events and portions of events 
within the time selection are 
reproduced and placed on the 
clipboard.

Also, the time information is 
placed on the clipboard.

Events only Selected events are reproduced 
and placed on the clipboard.

Also, the time information is 
placed on the clipboard.

Ctrl Shift

Ctrl + C

Original events are 
not affected and do 
not change.

Original events are 
not affected and do 
not change.

Original events are 
not affected and do 
not change.
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Pasting events 

Once information is copied to the clipboard, you may choose a variety of ways to paste the 
clipboard items into tracks. The following procedures explain pasting basics. Whichever way 
you paste into a track, Vegas Pro always pastes at the cursor’s position along the timeline.

To paste events from the clipboard, do the following.

1. Move the cursor to the desired timeline location.

2. Click either the track number or within the track where you want to paste the event.

 

If you are pasting multiple events from different tracks, Vegas Pro automatically creates 
new tracks as needed for events, or simply places events in existing tracks.

3. Paste the event into the track by doing one of the following:

• Press the  keys.
• Click the Paste button  on the Toolbar.
• From the Edit menu, choose Paste.

 The table below briefly describes pasting scenarios.

Paste method Definition Clipboard contents Events before paste Events after paste
Paste (above 
procedure)

Clipboard events are placed at 
the cursor position on the 
selected track. Existing events 
on a track are overlapped with 
newly-pasted information.

Paste repeat 
Ctrl+B

You specify how many times 
the clipboard events are placed 
at the cursor position on the 
selected track. Also, you specify 
the space between pasted 
events. 

Vegas Pro displays the 
Paste Repeat window. 
Specify the number of 
times to paste the 
clipboard events and 
their space from each 
other.

Paste insert 
Ctrl+Shift+V

Clipboard events are placed at 
the cursor position on the 
selected track. Existing events 
on a track are moved later in 
the timeline by the total length 
of pasted information.

Click either to select track

Ctrl + V

Paste
position 

Paste
position 
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Cutting events

Vegas Pro allows you to cut events, or portions of events, from your project. Cutting events 
removes them from their respective tracks, but places the cut information on the clipboard. 
Once on the clipboard, you may paste the event information into your project. You may cut 
a single event or multiple events.

To cut events, do the following:

1. Click on the event to be cut.

To cut multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple track events on page 29.

2. Select your time range, if applicable. Otherwise, skip to step 3. 

3. Cut the event to the clipboard by doing one of the following:

• Press the  keys.
• Click the Cut button  on the Toolbar. 
• From the Edit menu, choose Cut.

The following table briefly describes cutting scenarios and how the clipboard is used.

Selection Definition Events before 
cutting

Clipboard contents Events after cutting

Time only Events within the time selection 
are reproduced and placed on 
the clipboard.

Also, the time information is 
placed on the clipboard. 

Time &
events

Events and portions of events 
within the time selection are 
reproduced and placed on the 
clipboard.

Also, the time information is 
placed on the clipboard.

Events only Selected events are reproduced 
and placed on the clipboard.

Also, the time information is 
placed on the clipboard.

Ctrl Shift

Ctrl + X
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Trimming/Cropping events

Vegas Pro allows you to crop events, or portions of events, from your project. Cropping 
events removes all events outside the time selection from their respective tracks. However, 
the removed information is not placed on the clipboard. Cropping is different from cutting 
in that the events within the time selection are preserved.

To crop events, do the following:

1. Click on the event to be cropped, if applicable. Otherwise, skip to Step 2.

To crop multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple track events on page 29.

2. Select your time range.

3. Crop the event(s) by doing one of the following:

• Press the  keys.
• From the Edit menu, choose Trim/Crop.

The following table briefly describes cropping scenarios.

Selection Definition Events before crop Clipboard contents Events after crop
Time only Events outside the time 

selection are removed from the 
project.

The time information is not 
removed. 

Cropped information is 
not placed on the 
clipboard. 

Time &
events

Only selected events outside the 
time selection are removed 
from the project. Non-selected 
events remain.

The time information is not 
removed. 

Cropped information is 
not placed on the 
clipboard.

Ctrl Shift

Ctrl + T
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Deleting events

Vegas Pro allows you to delete events, or portions of events, from your project. Deleting 
events removes all events within the time selection from their respective tracks. However, 
the removed information is not placed on the clipboard.

To delete events, do the following:

1. Click on the event to be deleted.

To delete multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple track events on page 29.

2. Select your time range, if applicable. Otherwise, skip to step 3.

3. Delete the event(s) by doing one of the following:

• Press the  key.
• From the Edit menu, choose Delete.

The following table briefly describes deleting scenarios.

Selection Definition Events before 
deleting

Clipboard contents Events after 
deleting

Time only Events within the time selection 
are removed from the project.

The time information is not 
removed. 

Deleted information is 
not placed on the 
clipboard.

Time &
events

Only selected events within the 
time selection are removed 
from the project. Non-selected 
events remain.

The time information is not 
removed.

Deleted information is 
not placed on the 
clipboard.

Events only Selected events are removed 
from the project.

The time information is not 
removed.

Deleted information is 
not placed on the 
clipboard.

Ctrl Shift

Delete
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Splitting events

Vegas Pro allows you to create multiple, independently-functioning events from a single 
event by splitting them. Splitting creates a new ending point for the original event and 
creates a starting point for the newly-created event. 

Splitting an event does not delete or cut any information from the original event. The 
original event’s information is there, but omitted for playback based on where either the 
event’s starting or ending point occurs on the timeline. 

Also, when you split an event, the events abut each other so playback is unaffected on the 
timeline unless you move either of the abutting events or adjust their staring/ending points.

 

You may split single selected events, multiple selected events, or a time range of events.

To split an event, do the following.

1. Select the event to be split.

To split multiple events, use the  key, the  key, or the Selection Edit tool  to 
select the events. For more information, see Selecting multiple track events on page 29.

2. Place the cursor at the timeline position where the split will occur. 

Or, select your time range, if applicable.

3. Split the event(s) by doing one of the following:

• Press the  key.
• From the Edit menu, choose Split.

One event

Split position

Two events

Original event

Split position

Information is available, but will not play back.

Original event

Split position

Two events

Separated events

Ctrl Shift

S
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 The table below briefly describes splitting scenarios.

Selection Definition Events before 
splitting

Events after 
splitting

No events All events will be split at the 
cursor’s position (unless the 
event is locked).

The split will occur across all 
tracks.

Events only Only the selected events will be 
split at the cursor’s position.

Time only Unless locked, all events within 
the time selection will be split 
at the starting and ending 
points of the time range.

The split will occur across all 
tracks.

Time and events Only selected events within the 
time selection will be split at 
the starting and ending points 
of the time range. 
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Track navigation

Once an event is placed on a track, Vegas Pro automatically displays track controls that you 
can use to affect the event or events contained within the track. 

Track Number

This area identifies the track’s order number in a multitrack project. You may rearrange the 
track order by dragging and dropping selected tracks "up" or "down" within the Track List.

View buttons

These buttons control the track’s appearance (size) in the Track View.

Track ID
Track 

Bus
Arm for 

Effects RecordView Mute Solo

Track color
Change the color
by right-clicking
and choosing
Track Color and
then select the 
color you prefer

Minimized

Normal

Maximized
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Expanding the track 

You may resize the track by “pulling” the lower or right portion of it. Place the mouse pointer 
at the bottom or right side of the track. The pointer turns into an up/down or left/right 
arrow. Click and drag while moving the arrow up/down (height) or left/right (width). 
Release the mouse to set desired track size. 

Track Effects button

This button accesses compression and equalization (EQ) controls that can be applied to the 
track’s event(s). 

Bus assignment

This button allows you to designate and assign a track to a specific output bus. This option is 
available for projects being mixed for multiple stereo busses. (A bus is where various track 
signals are mixed together and output.)

Before

After

Before

After

Compression
Effects

Equalization
Effects

Select a bus 
for playback
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Arm for Record button

This button allows you to prepare a track for recording. You may record directly into tracks. 
A track is ready when you see the recording meter appear on it.

Mute button

This button enables you to temporarily disable playback of the track, so you can focus on 
another track’s event(s). When a track is muted, it appears “grayed out” on the track 
window.

Solo button

This button, as its name implies, isolates a track’s events for playback, while muting the 
other tracks’ events. 

Before muting the track After muting the track

Before applying Solo to the track After applying Solo to the track
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Scribble Strip

This area lets you label a track. Simply double-click in the strip and type the track’s name. 
Or, right-click anywhere in the track’s list window and select Rename from the pop-up menu 
and then type the track’s name. If you do not see the Scribble Strip, expand the track. For 
more information, see Expanding the track on page 42.

Volume slider

This slider controls the track’s loudness relative to the other tracks when it is played back. 
Vegas Pro tracks are preset at 0.0 decibel (dB). Use this slider to emphasize or de-emphasize 
a particular track. A track’s volume range is -inf. to 12 dB. 

To move the slider, do the following:

1. Place the mouse cursor on the slider.

2. Press and hold the left mouse button.

3. Move the slider left or right and release the mouse.

Note: You may also move the slider by 
clicking it and using the right or left arrow keys 
on the keyboard.

Scribble Strip

Right-click
track to display
pop-up

Double-click the slider
to reset to 0.0dB.
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Multi-purpose slider

If you do not see this slider, expand the track. This slider controls the track’s stereo panning 
and auxiliary bus volume. You may select what the slider controls by clicking its label. As 
you access the panning or auxiliary sends, Vegas Pro displays either its preset or your last 
setting preference. Each item’s slider position is independent from the others.

Panning

Vegas Pro track’s are preset to center the signal. You may move the slider and adjust the 
signal’s output left or right. As you move the slider, Vegas Pro displays the percentage of 
signal going to either the left or right channel. For example, moving the slider to 60%L 
means that 60 percent of the signal is mixed to the left channel, while 40 percent is mixed to 
the right channel.

 

Auxiliary bus

Vegas Pro projects that have multiple bus outputs enable you to send track signals to primary 
and secondary (auxiliary) busses. The primary bus is set using the Bus button on a track’s 
toolbar. For more information, see Bus assignment on page 42. The auxiliary bus enables you to 
send a signal to a separate bus independent of the primary bus. Auxiliary busses are often 
used to isolate a track or tracks from other project tracks during playback. However, auxiliary 
busses do not affect the project’s overall playback.

When you select an auxiliary bus, you need to adjust its playback volume with the slider. 
Auxiliary tracks’ volume are preset to -inf.dB (mute) for playback. 

Click label
to view menu

Double-click the slider
to reset to Center.

Double-click the slider
to set its volume at 0.0 dB.
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FX send

If you add an Effects Chain to a track, Vegas Pro adds that chain to the multi-purpose slider’s 
popup menu. You will be able to control the chain’s volume using this slider.

Track basics

Vegas Pro is a true multitrack mixing environment. Tracks are the containers for audio 
events, which you place and arrange. A track can contain different events. There are a 
number of ways to work with and manage tracks.

Adding an empty track

You can add empty (eventless) tracks to a project. These tracks can be used to directly 
record into or serve as placeholders for specific audio events that you will add later. For 
example, your project may contain a special audio event, but that event needs to be 
recorded and mixed or retrieved from another location.   

To add an empty track, do the following:

1. Place the mouse pointer in either the track window or the track list.

2. Right-click and select Insert Audio Track from the pop-up menu.

Or, select Insert from the menu bar and choose Audio Track.

3. Vegas Pro inserts an empty track at the end of the track list. 

Right-click to
view pop-up
menu

Before track is added
After track is added
VEGAS PRO QUICK START CHP. 2



47
Naming or renaming a track

Every track in your project has a Scribble Strip where you can type a name for the track. The 
track name may be up to 255 characters. You may name or rename the track at any time by 
doing the following:

1. If you do not see the Scribble Strip, expand the track to reveal it. The strip appears above 
the Volume slider. 

Note: If the track already has been named, 
you will see the name that was previously 
saved. 

2. Double-click in the Scribble Strip and type the track name. 

Or, right-click the on the track to display a popup menu. Choose Rename from the popup 
menu. Any existing name will be highlighted on the strip. Type the new track name.

3. Press the  key to save the name.

Double-click and type the name Right-click

Enter
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Reordering tracks

When you create tracks, Vegas Pro numerically arranges them in the order that they were 
added. You may reorder the tracks in the order that you prefer. Only the order of appearance 
changes in the track window; playback is unaffected. You may reorder tracks one or more at 
a time.

To move a track, do the following:

1. Place the mouse pointer on the track that you want to move.

2. Drag and drop the track to the new position in the track order.

3. Repeat Step 2, if necessary, to continue moving the track up or down.

Note: To select multiple tracks, click them 
while holding down either the  key to 
select concurrent tracks, or the  key to 
select random tracks.

Duplicating a track

You may duplicate tracks in your project and all the events contained on them. When a 
track is duplicated, the duplicated track is place directly below the original track. Other 
existing tracks are moved “down” on the track list. You may duplicate one track or choose 
multiple tracks to duplicate at a time.

To duplicate a track, do the following:

1. Place the mouse pointer over the track that you want to duplicate.

Note: To select multiple tracks, click them while 
holding down either the  key to select concurrent 
tracks, or the  key to select random tracks.

2. Right-click and choose Duplicate Track from the popup menu.

3. Repeat Steps 1-2, if necessary, to duplicate more tracks.

Shift

Ctrl

Shift

Ctrl
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Deleting a track

You may delete tracks from your project and all events contained on them. You may delete 
one track or choose multiple tracks to delete at a time.

To delete a track, do the following:

1. Place the mouse pointer over the track that you want to delete.

Note: To select multiple tracks, click them 
while holding down either the  key to 
select concurrent tracks, or the  key to 
select random tracks.

2. Right-click and choose Delete from the popup menu. 

Or, from the Edit menu, choose Delete.

3. Repeat Steps 1-2, if necessary, to delete more tracks.

Shift

Ctrl
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Video event basics

Video events are placed on the video ruler. If the video event has audio, Vegas Pro creates an 
audio track and places the video’s audio on the “top” track in the track list. For more 
information, see Placing a event on the Video Ruler on page 28.

 

Once the event is in place, you may move the video event along the timeline, delete its 
audio, and preview the event in the video preview window. You may also replace the video 
by placing a new event on the Video Ruler. For more information, see Dragging/dropping or 
double-clicking a video event on page 28.

Moving the video event

Moving a video event is identical to moving an audio event. However, a video event is 
slightly different in that it may have audio grouped with it. If a video event has audio, Vegas 
Pro is preset to group the video event with its audio when it is placed. As a result, the video 
event and its audio will always be moved together along the project’s timeline. 

To move a video event, do the following:

1. Place the mouse pointer on either the video event or its audio.

2. Click and drag the events to the desired starting point on the timeline.

3. Release the mouse when the events are in the desired location.

Note: Ungroup a video and audio by right-
clicking either event. From the popup menu, 
choose Group, and then Clear. 

Video event with frame numbers

Video’s audio event

Video ruler
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Removing the video’s audio

As mentioned earlier, video events with audio get placed together in your project. However, 
you may delete the original audio completely or replace it with new audio. This feature is 
nice for redubbing poor quality audio.

To remove the audio, do the following:

1. Right-click either the video or its audio event to display a popup menu.

2. From the popup menu, choose Group, then Clear to ungroup the video and audio. 
Otherwise, both events will be remove.

3. Click to select the video’s audio event.

4. Right-click to display the popup menu. From the popup menu, choose Delete. 

Or, from the Edit menu, choose Delete.

Playing back the project

Vegas Pro allows you to play back your project in two ways: directly within Vegas Pro, or by 
mixing the entire project to a preview file. 

Play back within Vegas Pro

Vegas Pro has a transport bar that allows you to play back your entire project or portions of 
your project based on a either a time selection or current cursor position. Only non-muted 
tracks and events are played back.

If your project includes video, make sure the Video Preview window is displayed for 
playback: from the View menu, choose Video Preview or press the  keys.

Before After

The video
remains on
the video
ruler.

Record

Loop Play from

Pause

Stop

Cursor 

Cursor 

Skip cursor

Skip cursor 

Play from 

play

start to start backward 

forwardto endcursor pos.

Alt + 6
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Play back entire project

1. Press the  button to position the cursor at the beginning of the project.

2. Press the  button to start playback. 

Or, press the  button to begin playback at the beginning of the project.

3. Press the  button to stop playback.

Play back a time selection

1. Place the mouse pointer above the ruler (on the Marker bar). The mouse arrow includes a 
left/right arrow ( ). 

2. Click and drag to select the time region. To increase or decrease the time selection, click 
and drag its start and end points.

3. Press the  button to begin playback. Only the non-muted tracks and events within the 
time selection will play back.

4. Press the  button to have Vegas Pro continually play back the events within the time 
selection.

5. Press the  button to stop playback.

Playback reference

The following table describes all the playback buttons and keyboard equivalents. You may 
use these playback functions at any time while working in your project.

Button Keyboard Function
Begin recording into record-enabled tracks

Turn on/off loop play during time selection playback

 +  + Begin playback from the start of the project

Begin playback from cursor position

Pause playback, cursor stops and holds at pause position

 or Stop playback, cursor stops and returns to prior cursor position

 + Place cursor at the beginning of project

 + Place cursor at the end of the project

Moves the cursor to the left in grid increments (if grid is displayed)

Move the cursor to the right in grid increments

Ctrl + R

L

Ctrl Shift Space

Space

Enter

Space Esc

Ctrl Home

Ctrl End

Page Up

Page Down
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Previewing to media player

A preview file is mixed according to the project’s properties that you set and is played back 
using the media player associated with the file type.

Mixing project for preview

This feature mixes all non-muted events to a file and automatically plays it back on the 
associated media player. 

1. From the Tools menu, choose Mix to Preview. The Preview dialog box appears.

2. Select the preview option from the drop-down list.

3. Click the OK button to begin the mixing process. A status bar appears in the lower left 
portion of Vegas Pro.

Note: You may cancel the Mix to Preview by 
clicking the  button on the status bar.

When mixing is completed, the associated media player appears and begins playback. 

Cancel
button

Status bar
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Working with project properties

You can view and set the project’s properties by choosing Properties from the File menu. The 
Properties window appears. 

Saving the project

The first time a project is saved you will select a Vegas Pro format to use. The format that 
you choose affects the project’s file size and its portability. There are two formats from which 
to choose:

To save the project, do the following:

1. Select one of the save methods:

• From the File menu, choose Save.
• Click on the  button. 
• Press  on the keyboard.

The first time you save a project, the Save As dialog box appears. Skip to step 2.

Format Name Extension Definition
Vegas Pro Project *.veg Saves all of the information about a single project. This file format does not contain any 

media. It saves the references to media files used in the project. Also saved is project 
information, track effects, envelopes, bus assignments, and output properties. 

Vegas Pro Project with 
External Media

*.veg All of the media that is being used in the project is copied into the same folder as the 
project file. This option makes transporting the project easy and convenient.

General project 

Audio output 

Video output 

Ruler display 
settings

settings

settings

information

Ctrl + S
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The subsequent times you save, the above window is bypassed, your existing file name is 
retained, and your project is updated to include any implemented changes.

2. Select the drive and directory where you want to store the project.

3. Type the project name in the File Name box.

4. In the Save as type box, select the format for which you want to save the project (as 
described in the previous table).

5. Click the Save button.

Renaming or rendering a project (using Save As...)

After you have been working with your project, you may use the Save As command in the 
File menu to rename the project. This option also allows you to render the project to a 
different file format. Typically rendering to a different format means that the project is 
finished and ready for distribution. 

Renaming a Vegas Pro project

You may use Save As from the File menu to save the project the first time. The only 
difference from the previous procedure is that the Save As window includes other file 
formats.

To rename a Vegas Pro project, do the following:

1. From the File menu, choose Save As. The Save As window appears. 
CHP. 2 VEGAS PRO QUICK START



56
2. Select the drive and directory where you want to store the project.

3. Type a new name in the File Name box.

4. In the Save as Type drop-down list, select Vegas Pro Project (*.veg).

 

5.  Click the Save button.

Rendering a Vegas project

Rendering refers to the process of converting the Vegas Pro project into one file and 
formatting it for the desired playback method: media player, Web streaming media, CD-
ROM, etc. The project file is not affected (overwritten, deleted, or altered) during the 
rendering process. You may return to the original project to make edits or adjustments and 
render it again. The following table describes the formats available for rendering your Vegas 
Pro project:

Format Name Extension Definition
Advanced Streaming Format *.asf The Microsoft standard used for streaming media via the Web.
Wave (Microsoft) *.wav The standard audio file format used for audio used on Windows-based 

computers. 
Video for Windows *.avi The standard video file format used on Windows-based computers. This 

option renders both audio and video into one file.
Audio Interchange File Format *.aif The standard audio file format for audio used on Macintosh computers. 
RealSystem G2 *.rm The RealNetworks standard for streaming media via the Web. This option 

renders both audio and video into one file.
Windows Media Audio *.wma The Microsoft audio-only format used to create files for streaming or 

downloading via the Web.
Vegas Pro project *.veg This option saves the references to media files used in the project. Also saved 

is project information, track effects, envelopes, bus assignments, and output 
properties.  The *.veg file does not combine events into a single file. 

Vegas Pro EDL *.txt This option creates a text version of event placements in the track view. This 
text description can then be imported into a database or text application for 
modification or other purposes.

If you want to copy
all the project’s media
into the same folder 
as the Vegas Pro file, select
this check box.
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To render a Vegas Pro project, do the following:

1. From the File menu, choose Save As. The Save As window appears. 

2. Select the drive and directory where you want to save the rendered project.

3. Type a new name in the File name box, if necessary.

4. In the Save as type drop-down list, select the desired file format for rendering.

 

5. Select any applicable check boxes, if necessary.

6. Click the Save button. A status bar appears in the lower left portion of Vegas Pro. Upon 
completion of the render, your Vegas Pro project is ready for distribution and playback.

Note: You may cancel the rendering process 
by clicking the  button on the status bar.

Copy all media with 
project

Used with Vegas Pro (*.veg) projects only. This option takes all of the media that is referenced in 
the project and copies it to the same folder to which you are saving the project.

Render entire project If you have a time selection in your project, select this option to ensure that the entire length of the 
project is rendered. If you do not select this option, only the time selection in the project will be 
rendered. 

Save project markers 
in media file

If your project contains defined markers or regions, you may save that information in the rendered 
file. Saving markers into a media file can enhance the end user’s interaction with the media file.

Select a rendering format

The check box options in the lower left of the Save As window
are available depending on the rendering format that you chose.
(They are all shown available here for display purposes only).

Cancel
button

Status bar
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3

Vegas Pro 
Tutorial
Welcome 

Welcome to the Vegas Pro tutorial. It is designed to familiarize you with the basic features 
and tools of Vegas Pro while creating a project. The following sections are primarily step 
oriented and less descriptive, although descriptions are given. If you would like to learn 
more about a particular topic in the tutorial, access the Online help. For more information, 
see Accessing help on page 11. 

This tutorial will teach you how to place media files in the project, edit them, and save them 
together into a video file. We provide you with the files you need to create this sample 
project. 

We will take a video that has poor audio quality and replace its audio with a voice-over 
recorded in a studio. The new audio will need to be synchronized with the video. The voice-
over will also require some editing and equaliztion. In addition, the video has theme music 
that we are going to replace with a new music bed. 

The video length is approximately 15 seconds. As you work, you will see how easy it is to 
master the powerful features that Vegas Pro has to offer. 

If you make a mistake during the tutorial, just undo it by pressing . 

Let’s get started!

Getting the tutorial folder

First, we need to get the sample media files copied to your hard drive.The tutorial folder is 
located on the Vegas Pro CD-ROM. 

1. Insert the CD-ROM into the disc drive.

2. Locate the Tutorial folder on the CD-ROM and copy it to your hard-drive.

3.  After the folder is copied, start Vegas Pro.

Ctrl + Z
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Using the Explorer window

The Explorer window allows you to view and access your media files without leaving the 
work area. This window works just like the Explorer you use with Microsoft Windows.

1. Locate the Tutorial folder on your hard drive.

2. Select the Tutorial folder so that its contents appear in the media list.

Once a media file is placed into the project, it is referred to as an event. 

Placing the video

In the media list you will see several files, we are going to place the Tutorial ( ).

1. Press  to place the cursor at the beginning of the project.

2. Select the Tutorial file in the media list.

3. Place it by double-clicking. This will place the video on the Video Ruler and the audio on 
the first track at the cursor’s position.

Media
list

Ctrl + Home

Video Ruler

Audio track
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Displaying the Video Preview 

We need to display the Video Preview window and move it to the docking area. This way we 
can watch the video as it is played back.

1. From the View menu, choose Video Preview. The Video Preview window will appear.

2. Place the mouse pointer on the Video Preview’s title bar and drag it to the lower right 
portion of the work area (over the Mixer window).

 

3. When the Video Preview’s title bar disappears, release the mouse. The Video Preview 
window will dock into position below the Track View.
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Play back the video

During play back, you will see and hear a number of elements: an opening and closing 
graphic with a music soundtrack, and background noise recorded along with our narrator. 

1. Press the  button on the Transport bar to start playback. Playback begins at the current 
cursor position. So, if playback starts in the middle of the project, press the  button to 
start playback from the beginning.

2. Press the  button to stop playback.

3. Press the Track’s  button to mute the video’s audio track. 

We are preparing to place and work with the new voice-over. Eventually, we will delete 
the original audio, but for now let’s use it as a reference point.

 

Placing the new voice-over

The new voice-over will replace the poor quality audio that is muted on the first track. 

1. In the media list, select the file titled Voiceover.

2. Drag the file so that its starting point is approximately when our narrator appears on the 
timeline. Drop the file and Vegas Pro will create a new track for it.

3. Press either the  or  button to play back the voice-over.

4. Press the  button to stop playback.

During playback, you will hear the narrator’s pause to review notes and cough. Below is the 
"anatomy" of the voice-over.

These errors (B and D) will be removed later. Also, during playback you probably saw the 
new voice-over and the video are out of sync. Next, we will align the voice-over with the 
video.

Transport bar

Track mute

A B C D E A-
B-
C-
D-
E-

Welcome to Sonic Foundry...

Um...

This tutorial will...

[Cough]

Found in the new...
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Aligning new voice-over with video

We will now position the voice-over so that it will be synchronized with the video. We will 
use the poor quality audio as a reference point. Since we can see the audio wave pattern, 
sychronizing is made easier. You can also refer to the video’s frames on the ruler to see when 
the narrator begins to appear in the video.

To make it easier to see the audio events, we can zoom in on the project. There are a number 
of ways to manage the project’s view. For more information, see View commands on page 20.

1. Press   so the Track View takes focus of keyboard commands.

Or, click in the Track View.

2. Press and hold the  keys

3. Press either the  or  keys. You will toggle through different Track heights. 

4. Click and drag the new voice-over’s starting point to approximately when the narrator 
begins to speak. The original audio wave pattern, although distorted, reveals the 
narrator’s voice.

5. On the timeline, click and drag the mouse to select a time region.

Alt + 0

Ctrl + Shift 

Original audio

Voice-over

Selection bar
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6. Press the  or  button to play back just the time selection. Press the  button to have 
playback loop continuously within the selection.

7. Watch the Video Preview window to see if the new voice-over is close. 

8. Press the  button to stop playback.

9. Repeat steps 3-7 until you have the starting points of the voice-over and the video 
synchronized. 

Next we will edit the "ums" from the voice-over and synchronize the remaining dialog with 
the video.

Editing the voice-over

When you played back the new voice-over, you noticed the interruption errors that it 
contained. We will remove those errors and synchronize the remaining voice-over to the 
video. Vegas Pro allows you to edit both time and events. We will use both methods to edit 
the voice-over. In addition, we will split an event to "separate" it from the parts we want to 
keep.

Lock the original audio

Time selection edits affect all tracks in the project unless a specific Track is selected. Before 
we start editing the voice-over, we will lock the original audio, which is our reference, to 
prevent it from accidently begin edited too. 

1. Click the video’s original audio to select it.

2. From the Edit menu, choose Switches and then Lock. 

Editing a time selection

By looking at the wave pattern, you will see where the "um" and cough occur. You will also 
see where the narrator is speaking. We will delete the "um" using time selection.

1. On the timeline, click and drag the mouse to make a time selection where the "um" 
occurs.
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2. Press the  button to play back the error to ensure that your time selection does not 
include part of the voice-over that we need.

3. Increase or decrease the time selection by clicking and dragging an edge of the selection.

4. Once the time selection is made, choose Delete from the Edit menu, or press the  
key to remove the "um."

Next, we will split the event that contains the narrator’s cough and then delete the error.

Splitting an event using time selection 

Splitting creates events from and existing one. We will make a time selection that contains 
the narrator’s cough and split it from the audio, then delete the cough.

1. On the timeline, click and drag the mouse to make a time selection where the cough 
occurs.

2. Press the  button to play back the error to ensure that your time selection does not 
include part of the voice-over that we need.

3. Increase or decrease the time selection by clicking and dragging an edge of the selection. 
The start and end points will be the split points.

4. Once the time selection is made, choose Split from the Edit menu, or press the  key to 
split the event.

Delete

S

One event Three events
before the split after the split
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Editing an event 

We have the cough as a new event that can now be deleted. 

1. Click the event with the cough.

2. From the Edit menu, choose Delete or press the  key to remove the cough event.

After the edits have been made, the voice-over should look something like this.

Aligning the remaining voice-over events

With the voice-over edited, we need to align the remaining audio to the video. When you 
move events, they snap to other event edges. You may extend or shorten an event’s length 
by clicking and dragging its edges, which is useful for fine tuning the alignment. Moreover, 
you may turn off snapping by choosing Enable Snapping from the Options menu.

1. Select the event that begins "This tutorial will introduce you...."

2. Click and drag the event to the approximate point where our narrator is saying this. Use 
the original audio as a reference.

3. On the timeline, click and drag the mouse to select a time region.

4. Press the  or  button to play back just the time selection. Press the  button to have 
play back loop continuously within the selection.

5. Watch the Video Preview window to see if the new voice-over is close. 

6. Press the  button to stop playback.

7. Repeat steps 2-6 until you have the voice-over and the video synchronized. 

8. Repeat the above steps for the event the begins "Found in this new...."

Next we will group the synchronized events with the video and delete the original audio 
from the project.

Delete

"Welcome to Sonic
Foundry Vegas.

This tutorial will introduce
you to the powerful editing
and post production features...

...found in this 

production environment."
new production
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Grouping the voice-over and video

The voice-over and video are synchronized and we want to make sure that they stay 
together. The Grouping feature will do that for us. However, first, we will delete the original 
audio.

1. Select the original audio’s track by clicking it.

2. Right-click and choose Delete from the pop-up menu. The entire track will be removed 
from the project and the new voice-over will become the first track.

3. Press the  key and click the video event and the three voice-over events to select 
them.

4. From the Edit menu, choose Group and then Create New to group the events. 

Next, we will place a new audio file to serve as a music bed for the video and add a 
volume envelope.

Working with the music bed

We will place an event that will play back for the entire video. We will add a volume 
envelope to lower the volume while the narrator speaks then increase the volume again for 
the remainder of the video.

Placing the music bed

1. Press the  key to move the cursor to the beginning of the project.

2. In the media list, double-click the Music bed file to place it at the beginning of the 
project.

3. Press the  button to play back the project. 

Ctrl

Ctrl + Home
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Adding a volume envelope

The music bed’s volume needs to be lowered while the narrator speaks. A volume envelope 
will automatically lower the volume and then raise it again when the narrator finishes 
speaking. We will use the voice-over’s starting and ending points as a reference for the 
envelope.

1. Select the music bed track or event.

2. From the Insert menu, choose Audio Envelopes and then choose Volume. A blue line will 
appear across the track.

3. On the music bed, place the mouse pointer slightly ahead of the voice-over’s starting 
point. The mouse pointer will appear as a hand ( ).

4. Right-click and choose Add Point from the pop-up menu. A square point will appear on 
the envelope line.

5. Repeat step 4 to add three more points on the line. You want a total of four points.

Setting the volume envelope

Now we will use the points on the envelope to lower and raise the volume so that the music 
bed does not interfere with the voice-over. When you click or hover over a point, 
information about it appears.

1. Click and drag the points so that they are positioned with two near the start of the voice-
over and two at the end.

Envelope Line
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2. Click and drag the two inner points so that their volume level is at approximately -7.0 dB.

3. Set the outer points so that their volume level is at 0.0 dB.

4. Press either  or  to play back the project to check the timing of the volume envelope.

5. Adjust the outer and inner points along the timeline as needed.

Next we will add some equalization to the voice-over.

Add EQ to the voice-over

The voice-over has a strong bass quality to it. We will adjust that quality slightly with EQ on 
the first band.

1. Click the  button on the voice-over’s track. The Track Effects window will appear. 

You can set the EQ settings by typing in the appropriate field, dragging the slider, or clicking 
the arrow buttons between the slider and the setting field.

2. Set the Frequency to 160 Hz.

3. Set the Gain to -inf.

4. Set the Rolloff to 12 (dB/oct).

5. Close the Track Effects window by clicking anywhere outside it.

6. Press either  or  to play back the project with the new EQ settings.

Next we will save the project as a Vegas project file.

You can only set one point
at a time. Two are shown
for display purposes.
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Saving a Vegas project (*.veg)

A Vegas project file contains all of the information about a single project. However, it does 
not contain any media, but maintains the references to media files used in the project. 

1. Select one of the following to save the Vegas Pro project:

• From the File menu, choose Save.
• Click on the  button. 
• Press  on the keyboard.

The first time you save a project, the Save As dialog box appears.

2. Select the drive and directory where you want to store the project.

3. Type the project name "MyTutorial" in the File Name box.

4. Click the Save button.

The subsequent times you save the project, the above Save As window is bypassed, your 
existing file name is retained, and your project is updated to include any implemented 
changes.

Ctrl + S
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Rendering the project as an *.avi

Rendering refers to the process of converting the Vegas project into one file and formatting 
if for the desired playback method: media player, Web streaming media, CD-ROM, etc. The 
Vegas project is not affected (overwritten, deleted, or altered) during the rendering process. 

The following procedure is broken into two sections: Setting the format and Applying 
compression.

Setting the format

1. From the File menu, choose Save As. The Save As dialog appears. 

2. Select the drive and directory where you want to save the rendered project.

3. Type a new name in the File name box, if necessary.

4. In the Save as type drop-down list, select Video for Windows (*.avi).
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Applying compression

To ensure that the video plays back in sync, we will set compression values.

1. On the Save As dialog, click the Custom button. The Custom Settings dialog will appear.

2. Click the Video tab, then click the Compression button. The Video Compression 
window will appear.

3. Set the compression to the following settings.

• From the Compressor drop-down list, choose Cinepak 
Codec by Radius.

• Set the key frame rate to 7 frames.
• Set the data rate to 125 KB/sec.

4. Click the OK button to set the video compression.

5. Click the OK button on the Custom Settings dialog.

6. Click the Save button on the Save As dialog. A status bar appears in the lower-left 
portion of Vegas Pro. Upon completion of the render, your new media file is ready for 
distribution and playback.

Note: You may cancel the rendering process 
by clicking the  button on the status bar.

Congratulations! You have just completed your first project using Vegas Pro.

Cancel
button

Status bar
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Vegas Pro 
Glossary
A-Law

A companded compression algorithm for voice signals defined by the Geneva 
Recommendations (G.711). The G.711 recommendation defines A-Law as a method of 
encoding 16-bit PCM signals into a non-linear 8-bit format. The algorithm is commonly 
used in United States’ telecommunications. A-Law is very similar to µ-Law, however, each 
uses a slightly different coder and decoder.

Adaptive Delta Pulse Code Modulation (ADPCM)

A method of compressing audio data. Although the theory for compression using ADPCM is 
standard, there are many different algorithms employed. For example, Microsoft’s ADPCM 
algorithm is not compatible with the International Multimedia Association’s (IMA) 
approved ADPCM.

Aliasing

A type of distortion that occurs when digitally recording high frequencies with a low sample 
rate. For example, in a motion picture, when a car’s wheels appear to slowly spin backward 
while the car is quickly moving forward, you are seeing the effects of aliasing. Similarly, 
when you try to record a frequency greater than one-half of the sampling rate (the Nyquist 
Frequency), instead of hearing a high pitch, you may hear a low-frequency rumble.

To prevent aliasing, an anti-aliasing filter is used to remove high-frequencies before 
recording. Once the sound has been recorded, aliasing distortion is impossible to remove 
without also removing other frequencies from the sound. This same anti-aliasing filter must 
be applied when resampling to a lower sample rate.

Amplitude Modulation (AM)

A process whereby the amplitude (loudness) of a sound is varied over time. When varied 
slowly, a tremolo effect occurs. If the frequency of modulation is high, many side frequencies 
are created which can strongly alter the timbre of a sound.
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Analog

When discussing audio, this term refers to a method of reproducing a sound wave with 
voltage fluctuations that are analogous to the pressure fluctuations of the sound wave. This 
is different from digital recording in that these fluctuations are infinitely varying rather than 
discrete changes at sample time (see Quantization).

Attack

The attack of a sound is the initial portion of the sound. Percussive sounds (drums, piano, 
guitar plucks) are said to have a fast attack. This means that the sound reaches its maximum 
amplitude in a very short time. Sounds that slowly swell up in volume (soft strings and wind 
sounds) are said to have a slow attack.

Audio Compression Manager (ACM)

The Audio Compression Manager, from Microsoft, is a standard interface for audio 
compression and signal processing for Windows. The ACM can be used by Windows 
programs to compress and decompress .WAV files.

Bandwidth

Refers to the EQ plug-in that is built in. Each frequency band has a width associated with it 
that determines the range of frequencies that are affected by the EQ. An EQ band with a 
wide bandwidth will affect a wider range of frequencies than one with a narrow bandwidth.

Beats Per Measure (BPM)

In music theory, the time signature of a piece of music contains two pieces of information: 
the number of beats in each measure of music, and which note value gets one beat. Vegas 
Pro uses this notion to determine the number of ticks to put on the Time ruler above the 
Track View, and to determine the spacing when the ruler is displaying Measures & Beats.

Beats Per Minute

In music theory, the tempo of a piece of music can be written as a number of beats in one 
minute. If the tempo is 60 BPM, a single beat occurs once every second. Lower BPM’s equal 
slower tempo, and vice versa.

Bit

A bit is the most elementary unit in digital systems. Its value can only be 1 or 0, 
corresponding to a voltage in an electronic circuit. Bits are used to represent values in the 
binary numbering system. As an example, the 8-bit binary number 10011010 represents the 
unsigned value of 154 in the decimal system. In digital sampling, a binary number is used to 
store individual sound levels, called samples.
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Bit Depth

The number of bits used to represent a single sample. Vegas Pro uses either 8 or 16-bit 
samples. While 8-bit samples take up less memory (and hard disk space), they are inherently 
noisier than 16-bit samples.

Byte

Refers to a set of 8 bits. An 8-bit sample requires one byte of memory to store, while a 16-bit 
sample takes two bytes of memory to store.

Clipboard

The clipboard is where data that you have cut or copied in Vegas Pro is stored. You can then 
paste the data back into Vegas Pro at a different location, or paste it into other applications, 
such as Microsoft Word, or another instance of Vegas Pro. Some data, such as audio, cannot 
be pasted into applications such as Microsoft Word or Notepad, but the text data from the 
Edit Details window can be pasted. This allows you to then print or format the data.

Clipping

Clipping is what occurs when the amplitude of a sound is above the maximum allowed 
recording level. In digital systems, clipping is seen as a clamping of the data to a maximum 
value, such as 32,767 in 16-bit data. Clipping causes sound to distort.

CODEC

An acronym for Coder/Decoder that is commonly used when working with data 
compression.

Crossfade

Mixing two pieces of audio by fading one out as the other fades in.

Cutoff frequency

The cutoff-frequency of a filter is the frequency at which the filter changes its response. For 
example, in a low-pass filter, frequencies greater than the cutoff frequency are attenuated 
while frequencies less than the cutoff frequency are not affected.

DC Offset

DC Offset occurs when hardware, such as a sound card, adds DC current to a recorded audio 
signal. This current causes the audio signal to alternate around a point above or below the 
normal -infinity dB (center) line in the sound file. To visually see if you have a DC offset 
present, you can zoom all the way into a sound file and see if it appears to be floating over 
the center line.
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Decibel (dB)

A unit used to represent a ratio between two numbers using a logarithmic scale. For 
example, when comparing the numbers 14 and 7, you could say 14 is two times greater than 
the number 7; or you could say 14 is 6 dB greater than the number 7. Where did we pull that 
6 dB from? Engineers use the equation dB = 20 x log (V1/V2) when comparing two 
instantaneous values. Decibels are commonly used when dealing with sound because the ear 
perceives loudness in a logarithmic scale.

In Vegas Pro, most measurements are given in decibels. For example, if you want to double 
the amplitude of a sound, you apply a 6 dB gain. A sample value of 32,767 (maximum 
positive sample value for 16-bit sound) can be referred to as having a value of 0 dB. 
Likewise, a sample value of 16,384 can be referred to having a value of -6 dB.

Device Driver

A program that enables Windows to connect different hardware and software. For example, 
a sound card device driver is used by Windows software to control sound card recording and 
playback.

Digital Signal Processing (DSP)

A general term describing anything that alters digital data. Signal processors have existed for 
a very long time (tone controls, distortion boxes, wah-wah pedals) in the analog (electrical) 
domain. Digital Signal Processors alter the data after it has been digitized by using a 
combination of programming and mathematical techniques. DSP techniques are used to 
perform many effects such as equalization and reverb simulation.

Since most DSP is performed with simple arithmetic operations (additions and 
multiplications), both your computer’s processor and specialized DSP chips can be used to 
perform any DSP operation. The difference is that DSP chips are optimized specifically for 
mathematical functions while your computer’s microprocessor is not. This results in a 
difference in processing speed.

Dithering

The practice of adding noise to a signal to mask quantization noise.

Drag and Drop

A quick way to perform certain operations using the mouse in Vegas Pro. To drag and drop, 
you click and hold a highlighted selection, drag it (hold the left-mouse button down and 
move the mouse) and drop it (let go of the mouse button) at another position on the screen.
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 Dynamic Range

The difference between the maximum and minimum signal levels. It can refer to a musical 
performance (high volume vs. low volume signals) or to electrical equipment (peak level 
before distortion vs. noise floor). For example, orchestral music has a wide dynamic range, 
while thrash metal has a very small (always loud) range.

Endian (Little and Big)

Little and Big Endian describe the ordering of multi-byte data that is used by a computer’s 
microprocessor. Little Endian specifies that data is stored in a low to high-byte format; this 
ordering is used by the Intel microprocessors. Big Endian specifies that data is stored in a 
high to low-byte format; this ordering is used by the Motorola microprocessors. 

Envelopes (Audio and Video)

Envelopes, as used by Vegas Pro, are a way of automating the change of a certain parameter 
over time. In the case of Volume, you can create a fade out (which requires a change over 
time) by adding an envelope and creating an extra point to the line that indicates where the 
fade starts. Next, you pull the end point of the envelope down to infinity.

Equalization (EQ)

The process by which certain frequency bands are raised or lowered in level. EQ has various 
uses. The most common use for Vegas Pro users is to simply adjust the subjective timbral 
qualities of a sound.

Event

A media file that has been placed into a Vegas Pro project. The media file is placed on a 
track or the video ruler and plays back as an audio or video "event" along the project’s 
timeline.

File Format

A file format specifies the way in which data is stored on your floppy disks or hard drive. In 
Windows, the most common file format is the Microsoft *.wav format. However, Vegas Pro 
can read and write to many other file formats so you can maintain compatibility with other 
software and hardware configurations.

Frame Rate (Audio)

Audio uses frame rates only for the purposes of synching to video or other audio. In the latter 
case, the rate of 30 non-drop is typically used. In the former case, 30 drop is usually used.
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Frame Rate (Video)

The speed at which individual images in the video are displayed on the screen. A faster 
frame rate results in smoother motion in the video. However, more times than not, frame 
rate is associated with SMPTE standard frame rates for video: 29.97, 25 or 24 for film.

Frequency Spectrum

The Frequency Spectrum of a signal refers to its range of frequencies. In audio, the frequency 
range is basically 20 Hz to 20,000 Hz. The frequency spectrum sometimes refers to the 
distribution of these frequencies. For example, bass-heavy sounds have a large frequency 
content in the low end (20 Hz - 200 Hz) of the spectrum.

Hertz (Hz)

The unit of measurement for frequency or cycles per second (CPS).

Insertion Point

The Insertion Point (also referred to as the Cursor Position) is analogous to the cursor in a 
word processor. It is where pasted data is placed or other data is inserted, depending on the 
operation. The Insertion Point appears as a vertical flashing black line and can be moved by 
clicking the left mouse button any where in the waveform display of a data window. 

Markers

Saved locations in the sound file. Markers are stored in the Regions List and can be used for 
quick navigation.

Markers can be displayed in the Trimmer window for sound files that contain them, but 
more often, markers and regions are used at the project level to mark interesting places in 
the project. 

Media Control Interface (MCI)

A standard way for Windows programs to communicate with multimedia devices like sound 
cards and CD players. If a device has a MCI device driver, it can easily be controlled by most 
multimedia Windows software.

Media Player

A Microsoft Windows program that can play digital sounds or videos using MCI devices. 
Media Player is useful for testing your sound card setup. For example, if you can’t hear sound 
when using Vegas Pro, try using Media Player. If you can’t play sound using Media Player, 
check the sound card’s manual. Please contact your sound card manufacturer before calling 
Technical Support at Sonic Foundry.
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MIDI Clock

A MIDI device specific timing reference. It is not absolute time like MIDI Time Code 
(MTC); instead, it is a tempo-dependent number of “ticks” per quarter note. MIDI Clock is 
convenient for syncing devices that need to do tempo changes mid-song. Vegas Pro supports 
MIDI Clock out, but does not support MIDI Clock in.

MIDI Port

A MIDI Port is the physical MIDI connection on a piece of MIDI gear. This port can be a 
MIDI in, out or through. Your computer must have a MIDI to output MIDI Time Code to an 
external device or to receive MIDI Time code from an external device.

MIDI Time Code (MTC)

MTC is an addendum to the MIDI 1.0 Specification and provides a way to specify absolute 
time for synchronizing MIDI capable applications. Basically, it is a MIDI representation of 
SMPTE time code.

Mix

A function Vegas Pro performs inherently by adding events to multiple audio tracks.

Multiple Stereo

A Mixer configuration that allows you to assign individual tracks to any number of stereo 
output busses. In single stereo mode, all tracks go out the same stereo bus. Multiple stereo 
configuration allows you to keep your signals from the Tracks discrete if you want them to 
be.

Musical Instrument Device Interface (MIDI)

A standard language of control messages that provides for communication between any 
MIDI compliant devices. Anything from synthesizers to lights to factory equipment can be 
controlled via MIDI. Vegas Pro utilizes MIDI for synchronization purposes.

Noise-shaping

Noise-shaping is a technique which can minimize the audibility of quantization noise by 
shifting its frequency spectrum. For example, in 44,100 Hz audio, quantization noise is 
shifted towards the Nyquist Frequency of 22,050 Hz.

Non-Destructive Editing

This type of editing involves a pointer-based system of keeping track of edits. When you 
delete a section of audio in a non-destructive system, the audio on disk is not actually 
deleted. Instead, a set of pointers is established to tell the program to skip the deleted section 
during playback.
CHP. 4 VEGAS PRO GLOSSARY



80
Normalize

Refers to raising the volume so that the highest level sample in the file reaches a user-
defined level. Use this function to make sure you are fully utilizing the dynamic range 
available to you.

Nyquist Frequency

The Nyquist Frequency (or Nyquist Rate) is one-half of the sample rate and represents the 
highest frequency that can be recorded using the sample rate without aliasing. For example, 
the Nyquist Frequency of 44,100 Hz is 22,050 Hz. Any frequencies higher than 22,050 Hz 
will produce aliasing distortion in the sample if no anti-aliasing filter is used while recording.

Pan

To place a mono or stereo sound source perceptually between 2 or more speakers.

Peak Data File

The file created by Vegas Pro when a file is opened for the first time. This file stores the 
information regarding the graphic display of the waveform, so that opening a file is almost 
instantaneous in direct edit mode. The peak data file is stored in the directory in which the 
file resides and has a .sfk extension. If the peak data file is not in the same directory as the 
file, or is deleted, it will be recalculated the next time you open the file in direct mode.

Plug-In

An effect that can be added to the product to enhance the feature set. Vegas Pro supports all 
DirectX plug-ins. The built-in EQ, Compression and Dithering effects are also considered 
plug-ins because they work in other DirectX-compatible applications.

Plug-In Chain

Plug-ins can strung together into a chain so that the output of one effect feeds into the input 
of another. This allows for complex effects that couldn’t otherwise be created.

Pre-roll/Post-roll

Pre-roll is the amount of time elapsed before an event occurs. Post-roll is the amount of time 
after the event. The time selection defines the pre- and post-roll when recording into a 
selected event.
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Preset

A snapshot of the current settings in a plug-in. Presets are created and named so that you 
can easily get back to a sound that you have previously created.

A preset calls up a bulk setting of a function in Vegas Pro. If you like the way you tweaked 
that EQ, but do not want to have to spend the time getting it back for later use, save it as a 
preset. All presets show up in the combo box on the top of most function dialogs in Vegas 
Pro.

Pulse Code Modulation (PCM)

PCM is the most common representation of uncompressed audio signals. This method of 
coding yields the highest fidelity possible when using digital storage.

Punch-In

Punching-in during recording means automatically starting and stopping recording at user-
specified times.

Quadraphonic

A mixing implementation that allows for four (4) discrete audio channels. These are usually 
routed to two (2) front speakers and two back speakers to create immersive audio mixes.

Quantization

The process by which measurements are rounded to discrete values. Specifically with respect 
to audio, quantization is a function of the analog-to-digital conversion process. The 
continuous variation of the voltages of a analog audio signal are quantized to discrete 
amplitude values represented by digital, binary numbers. The number of bits available to 
describe these values determines the resolution or accuracy of quantization. For example, if 
you have 8-bit analog-to-digital converters, the varying analog voltage must be quantized to 
1 of 256 discrete values; a 16-bit converter has 65,536 values.

Quantization Noise

A result of describing an analog signal in discrete digital terms (see Quantization). This 
noise is most easily heard in low resolution digital sounds that have low bit depths and is 
similar to a “shhhhh” type sound while the audio is playing. It becomes more apparent when 
the signal is at low levels, such as when doing a fade out.

Region

A subsection of a sound file. You can define any number of regions in a sound file which are 
stored in the Regions List.
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Resample

The act of recalculating samples in a sound file at a different rate than the file was originally 
recorded. If a sample is resampled at a lower rate, sample points are removed from the sound 
file, decreasing its size, but also decreasing its available frequency range. Resampling to a 
higher sample rate, Vegas Pro will interpolate extra sample points in the sound file. This 
increases the size of the sound file but does not increase the quality. When down-sampling, 
one must be aware of aliasing (see Aliasing). Vegas Pro automatically resamples all audio 
that is added to the project’s sample rate.

Ruler, Level

The Level Ruler is the area on a data window to the left of the waveform display. It shows 
the vertical axis units as either percents or dB’s.

Ruler Tags

Small tab-shaped controls above the Time Ruler that represent the location of markers, 
regions, and loop points in the waveform display.

Ruler, Time

The Time Ruler is the area on a data window above the tracks display window that shows 
the horizontal axis units.

Sample

The word "sample" is used in many different (and often confusing) ways when talking about 
digital sound. Here are some of the different meanings:

• A discrete point in time which a sound signal is divided into when digitizing. For 
example, an audio CD-ROM contains 44,100 samples per second. Each sample is really 
only a number which contains the amplitude value of a waveform measured over time.

• A sound which has been recorded in a digital format; used by musicians who make short 
recordings of musical instruments to be used for composition and performance of music or 
sound effects. These recordings are called samples. In this manual, we try to use sound file 
instead of sample whenever referring to a digital recording.

The act of recording sound digitally, i.e. to sample an instrument, means to digitize and store 
it.

Sample Rate

The sample rate (also referred to as the sampling rate or sampling frequency) is the number 
of samples per second used to store a sound. High sample rates, such as 44,100 Hz provide 
higher fidelity than lower sample rates, such as 11,025 Hz. However, more storage space is 
required when using higher sample rates.
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Sample Size

See Bit Depth.

Sample Value

The sample value (also referred to as sample amplitude) is the number stored by a single 
sample. In 16-bit audio, these values range from -32768 to 32767. In 8-bit audio, they range 
from -128 to 127. The maximum allowed sample value is often referred to as 100% or 0 dB.

Shortcut Menu

A context-sensitive menu which appears when you click on certain areas of the screen. The 
functions available in the shortcut menu depend on the object being clicked on as well as 
the state of the program. As with any menu, you can select an item from the shortcut menu 
to perform an operation. Shortcut menus are used frequently in Vegas Pro for quick access to 
many commands. An example of a shortcut menu can be found by right-clicking on any 
waveform display in a data window.

Sign-Bit

Data that has positive and negative values and uses zero to represent silence. Unlike the 
Signed format, two’s complement is not used. Instead, negative values are represented by 
setting the highest bit of the binary number to one without complementing all other bits. 
This is a format option when opening and saving RAW sound files.

Signal-to-Noise Ratio

The signal-to-noise ratio (SNR) is a measurement of the difference between a recorded 
signal and noise levels. A high SNR is always the goal.

The maximum signal-to-noise ratio of digital audio is determined by the number of bits per 
sample. In 16-bit audio, the signal to noise ratio is 96 dB while in 8-bit audio its 48 dB. 
However, in practice this SNR is never achieved, especially when using low-end electronics.

Signed

Data that has positive and negative two’s complement values and uses zero to represent 
silence. This is a format option when opening and saving RAW sound files.

Small Computer Systems Interface (SCSI)

A standard interface protocol for connecting devices to your computer. The SCSI bus can 
accept up to seven devices at a time including CD ROM drives, hard drives and samplers.
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Society of Motion Picture and Television Engineers (SMPTE)

SMPTE time code is used to synchronize time between devices. The time code is calculated 
in Hours:Minutes:Second:Frames, where Frames are fractions of a second based on the frame 
rate. Frame rates for SMPTE time code are 24, 25, 29.97 and 30 frames per second.

Sound Card

The sound card is the audio interface between your computer and the outside world. It is 
responsible for converting analog signals to digital and vice versa. There are many sound 
cards available on the market today covering the spectrum of quality and price. Vegas Pro 
will work with any Windows-compatible sound card.

Stereo

Mixer implementation that includes 2 discrete channels.

Surround

Mixer implementation that includes 6 discrete channels.

Tempo

Tempo is the rhythmic rate of a musical composition, usually specified in Beats Per Minute 
(BPM).

Time Format

The format by which Vegas Pro displays the Time Ruler and selection times. These include: 
Time, Seconds, Frames and all Standard SMPTE frame rates. The status format is set for 
each sound file individually.

Time Signature

See Beats per Measure.

Track

A discrete timeline for audio data. Audio events sit on audio tracks and determine when a 
sound starts and stops. Multiple audio tracks are mixed together to give you a composite 
sound that you hear through your speakers.

Trim/Crop

A function that will delete all data in a sound file outside of the current selection. 
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µ-Law

µ-Law (mu-Law) is a companded compression algorithm for voice signals defined by the 
Geneva Recommendations (G.711). The G.711 recommendation defines µ-Law as a 
method of encoding 16-bit PCM signals into a non-linear 8-bit format. The algorithm is 
commonly used in European and Asian telecommunications. µ-Law is very similar to A-Law, 
however, each uses a slightly different coder and decoder.

Undo Buffer

This is the temporary file created before you do any processing to a project. This undo buffer 
allows the ability to rewrite previous versions of the project if you decide you don’t like 
changes you’ve made to the project. This undo buffer is erased when the file is closed or the 
Clear Undo History command is invoked.

Undo/Redo

These commands allow you to change a project back to a previous state, when you don’t like 
the changes you have made, or reapply the changes after you have undone them. The ability 
to Undo/Redo is only limited by the size of your hard drive. See Undo Buffer.

Undo/Redo History

A list of all of the functions that have been performed to a file that are available to be 
undone or redone. Undo/Redo History gives you the ability to undo or redo multiple 
functions as well as preview the functions for quick A/B-ing of the processed and 
unprocessed material. To display the history list, click the down-arrow button next to the 
Undo and Redo buttons.

Unsigned

Data that has only positive values and uses half the maximum value to represent silence. 
This is a format option when opening and saving RAW sound files.

Video for Windows (AVI)

A file format of digital video for Windows. Vegas Pro allows you to open .AVI files and edit 
the audio embedded within them.

Virtual MIDI Router (VMR)

A software-only router for MIDI data between programs. Vegas Pro uses the VMR to receive 
MIDI Time Code and send MIDI Clock. No MIDI hardware or cables are required for a 
VMR, so routing can only be performed between programs running on the same PC. Sonic 
Foundry supplies a VMR with Vegas Pro called the Sonic Foundry Virtual MIDI Router.
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Waveform

A waveform is the visual representation of wave-like phenomena, such as sound or light. For 
example, when the amplitude of sound pressure is graphed over time, pressure variations 
usually form a smooth waveform.

Waveform Display

A section inside of the Trimmer window that shows a graph of the sound data waveform. 
The vertical axis corresponds to the amplitude of the wave. For 16-bit sounds, the amplitude 
range is -32,768 to +32,767. For 8-bit sounds, the range is -128 to +127. The horizontal axis 
corresponds to time, with the left-most point being the start of the waveform. In memory, 
the horizontal axis corresponds to the number of samples from the start of the sound file.

Zero-crossing

A zero-crossing is the point where a fluctuating signal crosses the zero amplitude axis. By 
making edits at zero-crossings with the same slope, the chance of creating glitches is 
minimized.

Zipper noise

Zipper noise occurs when you apply a changing gain to a signal, such as when fading out. If 
the gain does not change in small enough increments, zipper noise can become very 
noticeable. Vegas Pro fades are accomplished using 64-bit arithmetic, thereby creating no 
audible zipper noise.
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