Wave Shaper Introduction

) Wave Shaper™

Introduction

Wave Shaper Overview

Wave Shaper lets you record, play, and edit digital audio (wave) files,
and embed them into documents created by Windows applications.

What is Wave Audio?

Wave audio is recorded audio stored in digital form. When you speak
into a microphone, e.g., your voice is converted into voltage and
"sampled" (expressed as numbers representing the signal level)
thousands of times per second. These samples are stored in afile with
the WAV file extension.

Wave Shaper Controls
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Introduction Wave Shaper

Title Bar: Displaysthetitle of the currently loaded wavefile, if any.
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Wawe Shaper - CD.WAY

Menu Bar: Provides Wave Shaper functions through standard
Windows pull-down menus.

| Eile Edit Effects Options Help

Toolbar: Offers convenient push-button access to many functions also

available through the File, Edit, Effects, and Options menus.
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New File
Open File
Save File
& undo:
Cut:

Copy:
Paste:
Zoom In:
Zoom Out:
E‘ Louder:
E‘ Quieter:
Fadeln:
Fade Out:
Echo:
Reverse
View Left:
View Right:
Settings
Mixer:
Help:

Button Bar: Offers Record, Play, and Stop buttons as well as a drag-

Clears the currently loaded file.

Loads an existing wave file from disk.

Saves the current recording in awavefile.
Cancels the previous editing operation.
Deletes the selected waveform section.

Copies the selected section to the clipboard.
Copies wave audio from the clipboard.
Shrinks the Zoom Lens to cover asmaller area.
Expands the Zoom Lens to cover alarger area.
Evenly raises the amplitude of the selection.
Evenly lowers the amplitude of the selection.
Gradually raises the amplitude of the selection.
Gradually lowers the amplitude of the selection.
Adds an echo to the selected section.

Reverses the selected section.

Displays the left channel (of stereo audio).
Displays the right channel (of stereo audio).

L ets you change application settings.
Launches the mixer application, if available..
Displays the On-line User Guide.
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and-drop OLE icon for audio annotation purposes.

E Record: Starts recording from current input source.
E‘ Play:  Starts playing at the current position.
E Stop:  Stops playing the current wave file.

ﬁ OLE: OLE drag-and-drop icon (icon bitmap varies).

Position Slider: Indicates the current position in the loaded wave file.
The current position is where Wave Shaper starts playing when the
Play button is pressed.

——

Overview. The upper waveform view window displays a graphical
view of the entire currently loaded wave file.
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Zoom Lens Indicates the portion of the currently loaded wave file
that is shown in more detail in the Zoom View below.

s |

Zoom View: The lower waveform window displays a detailed view of
the portion of the wave file under the Zoom Lens.

-

Position Scale Provides a series of reference markers such as time
indicators for use in editing the wave file in the Zoom View.
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0:00.50 00:00.60  00:00.70  00:00.50 00:00.90  00:01.00  00:01.10 00:01.20 00:01.30 00:01.40

Status Bar: Reports information about the current wave file including
its length, the current position, and the length of selected portion. The
Status Bar also indicates the current Paste M ode.
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|Playing and Recording Wave Audio

Loading and Playing a Wave File
To load and play an existing wave file:
1. Click on the Open File button or select Open fwm the File menu.

2. Navigate among the subdirectories to locate the WAV file you
wishtoload. Click on OK to select the file. The name of thefile
will appear on the Title Bar.

3. Toplay thefile, click on the Play button. To stop playing, click
on the Stop button. The Position Slider moves to the right during
file playing, and indicates the current file position.

Note  You can also load a .WAY file by dragging it from File
Manager (in Windows 3.1) or Explorer (in Windows 95) and
dropping it on Wave Shaper.

Recording a Wave File

1. Make sure your audio hardware mixer application has the desired
audio input (microphone, CD, Line In, e.g.) enabled.

2. If you already have afile loaded and wish to record a new file,
click on the New File button or select New from the File menu.

If you wish to record into an existing wave file, do not select New.
Instead, click in the Zoom View window to select the point at
which you wish to record, and use the Paste M ode item under the
Options menu to select how you wish to insert your audio (refer to
the Recording or Pasting into an Existing Wave File section).

3. Click on the Record button. Then speak into the microphone (or
press the Play button on your CD or Line In player device, e.g.).

4. When finished, click on the Stop button.

Recording or Pasting Into an Existing Wave File

When you record or paste into an existing file, what happens depends
on the Option Menu Paste M ode setting:

Insert Wave Shaper inserts the audio into the current wave file at the
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current position, and moves all audio data after the current position to
the right, following the newly inserted data.

Cover: Wave Shaper inserts the audio into the current wave file at the
current position, overwriting the existing audio data from the current
position forward for the length of the inserted audio.

Mix: Wave Shaper inserts the audio into the current file at the current
position, combining it with the data that is already there. Doing this,
you can overlay one type of audio (speech, e.g.) on top of another
(recorded music, e.g.).

Saving Recorded Audio in Disk Files
1. Select Save Asfrom Wave Shaper File menu.

2. Navigate to the directory in which you want to store the file, and
specify afile name. Digital audio (wave) files are stored with a
WAV fileextension. Click on OK to save thefile.

Choosing Record Settings

Wave Shaper allows you to record audio in different data formats, for
different uses. Some data formats offer excellent sound quality, while
others sacrifice sound quality but allow file saving in less disk space.

To pick arecording data format:
1. Select the Set File Format menu item under the Options menu.

2. Choose from among the available audio data formats. The Format
pick list offersalist of available audio compression formats, while
the Attributes pick list lets you select the sample rate, sample size,
and number of channels (mono versus stereo).

3. You can add your own audio style by clicking on Save As.

Note To convert audio from one format into another, load the file
to be converted and select a new format as described above.
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Editing Wave Audio Wave Shaper
Editing Wave Audio

Viewing and Selecting Wave Files

When you have awave file loaded, Wave Shaper displays the entire
file in the Overview window, and either all or a portion of it in the
Zoom View window.

To select a portion of the wave file for editing:

1. Move or stretch the Zoom Lensto cover a portion of the wave file
that includes the section you want to edit. To move the Zoom
Lens, just drag it in the Overview (upper) window. To stretch it,
move the mouse cursor over the left or right edge of the Zoom
Lens until it becomes a double-headed arrow cursor, and then
hold down the left mouse button while dragging the lens edge.

2. Inthe Zoom View (lower) window, hold down the left mouse
button and drag the cursor to select a portion of the wave file.

Applying Audio Effects

Once you have selected a portion or all of the wave filgyou can apply
avariety of effects by selecting them from the Effects menu or clicking
on their buttons on the Toolbar.

Echo: Selecting Echo displays a sub-menu of echo effects choices.
Fade Gradually adjusts the amplitude of the selected portion.

Normalize Scales the waveform selection so that its loudest point
reaches full scale (makes it as loud as it possible without clipping).

Reverse: Reverses the selected portion, so that it "plays backwards".

Speed: Speeds up or slows down the selection. Increasing the speed
of awave file raisesits pitch and reduces its length, while decreasing
its speed has the opposite effects.

Trim: Deletes silent sections at the beginning and end of the
waveform (but not in the middle of the waveform).

Amplitude: Evenly increases or decreases the loudness of the selection.

Cut and Paste Editing
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To delete a portion of awave file, either permanently or temporarily
(so you can move it elsewhere using the Paste command):

1.
2.

Select the desired portion of the wavefile.

Select Cut from the Edit menu, or click on the scissors button.

To duplicate portions of files:

1.

2
3.
4

Select the desired portian of the wave file.
Select Copy from the Edit menu or click on the Copy button.
Click in the Zoom View window at the desired insertion point.

Select the appropriate Paste M ode from the Options menu. Refer
to Recording or Pasting into an Existing Wave File for details.

Select Paste from the Edit menu or click on the Paste button.
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|Embedding Audio in Documents

About Embedding and OLE

Wave Shaper lets you "audio annotate” documents. That is, you can
record audio using Wave Shaper, and insert it as a comment into
documents you create using most major Windows applications.
Windows does this embedding using its Object Linking and
Embedding (OLE) technique. Each message you embed in a
document is an "object".

Embedded audio objects appear asicons in the document:

= Write - XYZDEALWRI e

File Edit Find Character Paragraph Document Help
Ta: Bill I
Frarm: hlark |
Subject: Agreement at Last

#XZ Corp. has finally agree to our terms. The audio message
below is their CEO's phone mail to me last night.

DK on #YZ Deal

To play the audio messge, just double-click on the icon

Page 1l M :

Embedding Techniques

Y ou can embed all or part of arecording into a document created by
an OLE client application. To embed audio, you can often use any of
three techniques, depending on the client application:

Drag the OLE icon from the Button Bar into a document created
by an OLE client application. Theicon will appear at the current
cursor position.

Use Copy or Copy Object from the Wave Shaper Edit menu to
place some or all of the current wave file onto the Windows
clipboard, and then paste the object into the document using menu
items (Edit/Paste, e.g.) of the OLE client application.
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Wave Shaper Embedding Audio in Documents

From within the OLE client applcation, use its menu items
(Insert, e.g.) to bring up Wave Shaper and record or paste in your
audio message. When finished, exit Wave Shaper to leave the
audio object in the document.

Embedding Options

Wave Shaper lets you choose how your embedded audio will appear.
Using the Properties menu item under the File menu, you can control
the following:

Label: the text caption that will appear under your embedded object
icon (e.g., “Listen to this!™).

Set Picture the bitmap icon that represents your embedded audio in
the document (choose a lightbulb, envelope, or whatever best
represents the type of message you are leaving).

Playing Embedded Audio

Once you have embedded an audio object into a document, it stays
there until deleted. To play the object, just double-click on itsicon.
Thiswill launch Wave Shaper with the audio object playing. If you
send the document to other people who have Wave Shaper installed,
they will be able to play back embedded audio.
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Wave Shaper and Willow Pond are trademarks of Willow Pond Corporation. Microsoft,
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