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INSTALLING THE PROGRAM FROM THE CD-ROM

This CD contains a Master Installer program that provides an easy and convenient way to
install the programs on the CD. Follow these instructions to use the Master Installer.

1. Insert the program CD into the CD-ROM drive.

2. From the Windows Program Manager, click once in the File menu option to
display the File menu and select Run.

3. In the Run dialog box, type D:\INSTL L .EXE (note the spelling, no “A”), and
press Enter. If your CD-ROM drive letter is not D, substitute accordingly.

4. The Master Installer main screen is displayed and you are presented with alist of
products to choose from. Make your selections from the list and click on Install to
continue. Master Installer will launch the individual installers for each of the
products selected, and return to the Master Installer screen. Follow the on-screen
instructions to complete the installation for each program. Please note that some
installations may restart your Windows session.

If you encounter problemsinstalling several programs at once, quit the Master Installer
program, and restart it. Install one program at atime.

THE ON-LINE USER’S GUIDE

Documentation for these products have been provided in an on-line format, along with a
Viewer utility. To view the manual, you must first install the On-line Document Viewer
program from the CD. To do this, follow the instructions in the above section. The last
option shown in the Master Installer list box installs the On-line Document Viewer
program to your hard drive. Please note that this installation restarts your Windows
session.

After the installation is complete, run the On-line Document Viewer program and from
the Open File Dialog box, select the file called MANUAL .PDF which islocated in the
MANUAL S directory of the program CD (e.g. D:\\MANUALS\MANUAL.PDF). The
Viewer also contains afull and comprehensive help system to assist you in learning how
to use the documentation.



Power Album

Introduction

This manual explains how to use PowerAlbum, an innovative, easy-to-use application that helps you organize and select pictures for
documents in Windows applications.

PowerAlbum makes it easy to locate and select pictures because you can:

*  Choose a picture by its appearance, not some obscure DOS filename.

*  Access to your clip art unhindered by the usual barriers of drives and directories.

*  Organize clip art into categories that make sense to you.
PowerAlbum employs the metaphor of a picture album. Each page holds up to 12 miniature representations, “thumbnail images, “
of graphic files stored in directories on your system. The images are grouped in categories; you can see two pages of a category at a
time.

PowerAlbum can display graphics files in any of eleven formats, such as .WMF or .PCX. For more on graphic file formats, see
“About Graphic File Formats” later in this chapter. The files themselves may be stored in any directory on your hard disk.

This manual contains these sections:

e Quick Start

+  Finding Pictures

¢ Managing Pictures

*  Moving, Copying, and Rearranging Pictures

*  Using Categories

*  Working With Albums

*  Notes
Your WindowWorks installation disks include PowerAlbum, which is a completely independent application that you can use to
organize graphic files and select pictures for any Windows applications that read pictures from the Clipboard.

The WindowWorks Setup program automatically installs PowerAlbum when you install WindowWorks.

NOTE: The clip art you received with your copy of PowerAlbum may or may not match the illustrations in this manual. When you
use the Setup program to install WindowWorks, you can choose whether or not you want to install the clip art. If you choose to install
the clip art, the Setup program organizes all included pictures into categories in the album WWKSPLUS.ALB. These categories may
or may not match the categories mentioned in this manual.

Quick Start

This section outlines the basic procedure to follow when using PowerAlbum to choose clip art for a document you are creating in
another application. For more detailed instructions, consult the relevant section in section.

NOTE: This section discusses using an album that already contains pictures. If you want instructions on adding pictures to an
album, see “Adding Pictures” in the “Managing Pictures” section of this chapter.

To copy a Power Album picture for use in another program

If you are in WindowWorks, you can open PowerAlbum by selecting PowerAlbum from the Control menu. If you are not, open
PowerAlbum by double-clicking on the PowerAlbum icon.

1. Find the picture you want to use.
There are two ways you can search for a picture. The first is to flip through the pages of the album, much in the manner you would
through a real photo album. You can browse page-by-page, or jump to a different category by pressing its tab.

The second way to look for a picture is to use the Find or Find All command to search for pictures with a particular description,
filename, or file type. You can use Find to search for pictures one by one or Find All to place all the found pictures in a temporary
category called “Found”.

2. Select the picture you want to use by clicking it.
A dark border appears around the picture. Also notice that the selected picture’s description and filename appear near the bottom of
the PowerAlbum window.
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To see a picture in full size and detail, choose Display from the Picture menu. If the picture in full size and detail, choose Display
from the Picture menu. If the picture is too large to display in the window, you can either use the scroll bars to see other parts of the
picture or enlarge the display window. To return to the PowerAlbum window, click anywhere on the picture.

3.  Choose Copy from the Edit menu to copy it to the Clipboard.

NOTE: If the picture you selected disappears from the album, you accidentally selected the Cut command. To replace the picture
on that page, select Paste from the Edit menu before you continue with the next step. A copy of the picture remains on the Clipboard,
so you don’t have to use the Copy command again before proceeding to the next step.

If you plan on using more pictures, you can leave PowerAlbum open and simply minimize its window. Or, you can close PowerAlbum
altogether.

Open the application you want the image in. Place your cursor where you want the image to appear .

4. Select Edit... Paste..

NOTE: Some applications require you to have a frame to paste the image into. If the image does not appear, check your applications
documentation.

When you are all done, choose Exit from the File menu to close PowerAlbum.

Finding Pictures

Before you select a picture to use in another application, you need to find the right one. You can look for a picture two ways:
browsing through the categories or using the Find or Find All command.

Browsing through categories
You may search for pictures one page at a time or search several pages at a time by clicking a tab to view specific categories.

If PowerAlbum cannot display all of the category tabs, a “More” tab appears at the bottom of the list. Click it to display the next set
of tabs for the remaining categories.

If you are at the Contents page of your album, you can go directly to any category by double-clicking its name.
Using Find

To use the Find command to find a picture:

1. Select an image and choose Find from the Edit menu. The Find Picture dialog box appears.

2. Type the file name, filename extension, or the word you want to search for in the Find What text box.
You may enter two or more words separated by a space, Find will search for all the pictures whose descriptions contain any of these
words. Entering “birthday party” will find all pictures with “birthday” in their descriptions, as well as all the pictures with “party”
in their descriptions.

NOTE: When an image is selected, the description is displayed on the bottom left-hand side of the album. If there is no description,
click in the description box to enter one.

The Find option is not case sensitive. ~Although you can enter up to 256 characters, it is not recommended.

Using Find All

To use the Find All option:

1. Choose Find from the Edit menu and enter the words you want to search for in the Find What text box.

2. Choose Find All.
This command locates all pictures with descriptions matching the search words and copies them in a category called Found at the end
of your album.

If you would like to maintain the category using the “Found” information, it is best to rename the Category. If not, the entire “Found”
category will be replaced by the “Found” information.
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Previewing a picture’s actual size

The pictures you see in the album are all reduced to one size to fit into the frames on the album page. To examine a picture in its
actual size, select it and choose Display from the Picture menu.

Picture sizes vary greatly. If the picture is a bitmap (BMP, GIF, JPEG, PCD, PCX TIF, or WPGQG), it may be too large to fit in the
display window. In that case, either use the scroll bar to move around it, or drag the corner of the display window to enlarge it.
Enlarging the window may distort the image on some machines, but the picture will display and print correctly when you paste it into
a document. Pictures that are vector images (CGM, WMF, WPG, or DRW) are resized to fit the display window.

Click anywhere on the picture to return to the PowerAlbum main screen.

Managing Pictures

This section explains how you can add pictures to an album. It also describes how you can rearrange, move, copy, and delete pictures
within an album.

Adding pictures

You can add one or more pictures to an album in one operation. When adding pictures, you can either add them to an existing
category or create a new category and add them to it.

To add pictures to an album:

1. Choose Picture. Then click Add To Album. The Add Picture dialog box appears.

2. Choose the drive and directory where the pictures you want are located.

3. Use the List Files of Type to see only files of a particular type (PCX, TIFF, and so on) or to see all the files in the current
directory (*.*).

4.  Select the file(s) you want to add. To select adjacent files, drag the pointer down the list. To select non-adjacent files, hold
down the CTRL key as you select each file. To select every file in the list, choose Select All.

NOTE: Adding files takes time. If you try to add a large number of files at one time, it may take a considerable amount of time.

5. Choose OK. The Select Category dialog box appears.

6. Select the category you want to receive the pictures or choose the Add Category button to create a new category. If you choose
Add Category, type the name of the new category and choose OK.

7.  Choose OK. PowerAlbum adds the pictures to your album. When PowerAlbum finished, it reports how many pictures were
successfully added.

8. Choose OK once again. Be sure to save your file when you are finished.

Deleting pictures from your disk

You can delete a graphic file from your disk without leaving PowerAlbum. Be careful, as this is a permanent deletion.

To delete a picture from your disk:

1. Select the picture you want to delete and choose the Picture menu and select Delete File From Disk.
2. Choose OK to delete the file.
3. Choose File. Click on Save to save the change to your album.

NOTE: If you do not save the album, an image thumbnail of the deleted picture will appear the next time you use the album,
although the file is no longer on your disk.

Adding and editing a picture’s descriptions

Pictures you installed with the setup program probably have descriptions; you can change these or add to them if you like. Pictures
that you add to PowerAlbum later will not have descriptions, but you can add your own.

Descriptions can be useful because you can use the Find command to search for any word, or part of a word, in a description. When
entering descriptions, it is a good idea to use a variety of descriptive words, including some general concepts. For example, you might
describe a picture of a sports car as “car, transportation, speed.”
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To add or edit a picture’s description:

1. Select the picture. A heavy border will appear around the picture.

2. If the description text box does not contain a blinking line cursor, click the box.

3. Type the new word or phrase at the cursor. Separate words by spaces and/or commas. You can enter up to 64 characters.
After you have made all your changes or additions, choose Save Album from the File menu to save the descriptions.

Displaying a picture in full size

The pictures in your albums are reduced to thumbnails to fit onto the album pages.

To see a picture displayed in its actual size:
1. Select it by clicking on it once and choose Picture. Click on Display.

2. Click anywhere in the picture to close it.

If a picture is too large to fit the display window, scroll bars appear. To see the entire picture, either use the scroll bars or enlarge the
size of the display window by clicking and dragging the corner or edge of the window.

Moving, Copying, and Rearranging Pictures

To rearrange pictures on a page

Select a picture and drag it to another frame.

To move a picture to another page within the same category

1. Select the picture and choose Edit then choose Cut.
2. Move to the new page and select the frame where you want the picture to appear.
3. Choose Edit then Paste. The picture already in that frame moves to the right.

To move a picture to another category

Select the picture, hold down the SHIFT key and drag the picture over the tab of the category in which you want to place it. When the
tab is highlighted, release the mouse button. The picture will appear in the first empty frame of that category.

You can also use the Cut and Paste commands in the same way as moving a picture from page to page within a category.

To copy a picture from one category to another

Select the picture and drag it to the tab of the category to where you want to copy it. Release the mouse button when the tab is
highlighted. You can copy a picture to as many different categories as you want.

Removing pictures from a category

Removing a picture from a category deletes the thumbnail image of that picture. If the picture occurs in more than one category, you
can choose to remove it from the entire album. This does not affect the actual graphic file on your disk.

To remove a picture from a category:

1. Select the picture you want to remove and choose Picture then click Remove From Category.
2. Choose Category Only to remove the picture from the current category. If the picture appears in other categories, it remains in
them. Choose Entire Album to remove every occurrence of the selected picture from the album.
If you want to restore the picture later, you will have to add it to the album or copy it from another category.
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Using Categories
Adding categories

To add a new category:

1. Choose Category, then click Add.
2. Type a name for the new category in the Add Category dialog box.
3. Choose OK to add the category and close the dialog box, or choose Add Another to leave the dialog box open so you can add
another category.
New categories are empty. To add pictures to them, you can copy pictures from other categories or use the Add Picture command.
You can also add a new category when you are adding pictures to an album or when you are using the Find All function.

Deleting categories

Deleting a category removes both the category and the pictures displayed in it from your album. Deleting a category does not affect
the graphic files themselves; they remain in their original directories on your hard drive.

If you want to delete a category but keep the pictures it contains, copy or merge them into another category first.

To delete a category:

If you are on the Contents page, select the name of the category you want to delete. If not, make sure you are on a page in the category
you want to delete.

1. Choose Category. Click on Delete.
2. Choose OK to delete the category.

Merging categories
Merging categories copies all the pictures from one category (the Merge From category) into another (the Merge To category). The

original Merge From category remains unchanged.

1. Choose Category, then click Merge. The Merge Categories dialog box appears.
2. Choose the category from which you want to copy the pictures from the left-hand Merge From list. You can only choose one
category.
3. Choose the category to which you want to copy the pictures from the right-hand Merge Into list.
4. Choose OK.
Be sure to save your album by choosing File and selecting Save.

Renaming categories
You can either rename a category from the Contents page, or from a page in the category itself.

To rename a category from the Contents page, select it and then click the text box at the bottom of the window and type the new
name.

To rename a category from one of its pages:

1. Select Category then click Modify.
2. Edit the name in the Category Name text box or type a new name over it.
3. Choose OK.

Working with Albums

There are many additional things you can do with the PowerAlbum. You can create an entirely new album, and even merge existing
albums together. This section outlines some of the additional capabilities of PowerAlbum.
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Creating a new album

Choose File. Click on New. If you have not saved recent changes to the open album, PowerAlbum asks if you want to do so. Choose
Yes to save the changes, or No to discard them.

The new album appears. It is untitled and contains no categories or pictures. Before you can add pictures, you must first add at least
one category. Refer to the Adding Categories section of this manual for instuctions for adding new categories.

Merging albums

Merging albums copies the contents of a closed album into the currently open album.

To merge albums:

Open the album that you want to receive the pictures.

Choose File then choose Merge Albums.

Choose a drive, if necessary, and navigate through the Directories box to find the album you want.
Choose the album (ALB file) that you want to copy from the File Name list box.

Choose OK.

kb=

Navigating through an album

+  To move to the next page, click the arrow next to the page number of the right-hand page.
+  To move to the previous page, click the arrow on the left-hand page.

+  To move to another category, click its tab.

*  Choose Contents to move to the Contents page.

Opening an album

When you open another album, PowerAlbum automatically closes the currently open album. You can have only one album open at
a time.

To open an existing album:
1. Choose Open from the File menu. If you have not saved your recent changes, PowerAlbum asks if you want to do so. Choose
Yes to save the changes or No to discard them. The Open Album File dialog box appears.
2. Choose the drive and directory, if necessary.
Select the desired album name.
4.  Choose OK.

|95}

Saving an album

To save a new album, or to make a copy of the album with a different name:

1. Choose Save As from the File menu. The Save Album File dialog box appears.

2.  Type the name in the File name field. Choose a different drive and directory if you want.

3. Choose OK. The name of the album appears in the Title bar at the top of the window.
Once you have used Save As to give a new album a name, you can choose Save from the File menu to save other changes, such as
added pictures, rearranged pages, or new descriptions.

Printing a catalog

To print a catalog:

1. Choose Print Catalog from the File menu.

2. Select the categories you want to appear in your catalog from the categories list box.

3. To select adjacent categories, drag the pointer down the list. To select non-adjacent categories, press CTRL and hold it down
as you select each category. To Select All the categories displayed in the categories list box, choose the Select All button.
Choose Table of Contents if you want to print the table of contents for your entire album.

4. If you are printing the table of contents, you can suppress the printing of each picture’s complete path name by selecting the
check box below the categories list box.
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5. Choose the resolution at which you want to print your catalog. Printer resolution produces clearer images but takes more time
than printing in Draft.
6. Choose OK.

NOTE: The keyboard shortcut for printing, CTRL+P, does not work. To use the keyboard to print, press ALT+F, the P, and press
ENTER.

The resolution at which you print your catalogs affects image quality and printing speed. Printing at your printer’s resolution takes
more time because PowerAlbum has to import each picture before sending the information to the printer. When you print in draft
mode, PowerAlbum uses the thumbnail image from the album, thereby saving some time.

Printing catalogs at your printer’s resolution rather than in draft mode produces sharper images because, in most cases, your printer’s
resolution is greater than the resolution of your screen. In addition, when PowerAlubm sends the screen image of the picture to the
printer, the picture has to be slightly resized. Because the screen’s resolution does not match most printer resolutions, the result is
a picture with a slight case of the “jaggies” (stair-steps on the edges of the image).

Notes

About Graphics File Formats

There are two basic types of graphic files that you can use with PowerAlbum: bit-mapped and object-oriented vector graphics. A bit-
mapped graphic is a collection of dots that form an image, much like the pointillist technique of the Impressionist painters. Scanners
and graphic programs that create these images identify the color of each possible dot in an image, thereby creating a fixed picture of
variously colored dots. When you resize a bitmap picture, it often distorts the image; the picture looks ragged or the edges are jagged.

Vector images, on the other hand, are defined by mathematical formulas. Vector graphics are often referred to as being object-
oriented images because they are produced as a combination of various objects, such as lines, boxes and ovals, often layered one on
top of the other. When you create a vector image, your computer keeps track of the image by remembering the characteristics of all
the objects that produces it: the length of a line, its position, the width of a box, and so on. Unlike bitmaps, vector pictures can be
resized without distorting the image.

Within each of these basic types of graphic files, there are several different commonly used file types. PowerAlbum can manage
pictures in any of the following formats:

PCX and BMP- PCX and BMP are bit-mapped file formats created by paint programs, like PC Paintbrush or some screen-
capture programs. PCX is one of the oldest and most common bitmap formats available.

CGM- CGM files are a type of vector graphic that can be produced by drawing or spreadsheet programs such as Harvard
Graphics, Applause 11, Freelance Plus, Corel Draw. The CGM format was created by the American National standards
Institute, Inc. (ANSI) to provide a standard for graphical information exchange, and it is widely supported.

DRW- DRW files are a vector graphics created by MicroGrafx programs such as Designer and Draw.

EPI- Files with the EPI extension are vector graphics created by PowerUp’s Text Effects, typically used in conjunction with
Express Publisher for Windows.

GIF- GIF (Graphics Interchange format) is a file format established by CompuServe. A GIF file usually 256-color is a
bitmapped file.

JPEG / JPG- JPEG file (Joint Photographic Experts Group) is a specially compressed file in bitmapped format. The file size
of a JPEG file is much smaller than similar pictures in other formats.

PCD- PCD is a Kodak Photo CD file in bitmapped format. A PCD file actually contains five different resolutions (ranging
from low to high) of a slide or film negative.

TIFF / TIF- TIFF stands for Tagged Image File Format. files with the TIFF extension are usually created by scanners or
image processing programs. These bit-mapped files come in a number of different classes. PowerAlbum may not be able to
handle successfully every file that claims it is TIFF compatible because there are varieties of TIFF.

WMF- WMF stands for Windows MetaFile. This native Windows vector format is used by the Windows Clipboard.
WPG- WPG files (Word Perfect Graphic) can be either vector or bitmapped graphics. PowerAlbum may not read WPG files
that contain a combination of vector and bitmapped data.

Using Removable Media (CD-ROM or Floppy Disks)

You can add to an album pictures that are stored on removable media (for example, CD-ROM or floppy disks). However, when you
want to copy a picture stored on a removable disk to the Clipboard, or use the Display command, you must make sure that the correct
disk is available.

If it is not, the Picture Not Found dialog box appears (error message #530). You can use this dialog box to search for the selected
picture. Most likely, the correct disk is not in the disk drive. Insert the correct disk, and choose Search.
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NOTE: Use your own personal convention for naming albums and labeling disks to ensure that you will insert the proper disk when
loading an album.

If you require more information about the many features of PowerAlbum, consult the on-line help system in PowerAlbum.
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Common User Questions

I consistently get low-memory error messages.

PowerAlbum requires at least 2 MB of free RAM to operate. This is system memory above-and-beyond what is necessary to
run Windows, not just the amount of combined memory from RAM and virtual disk you have installed in your computer. You
can find out how much free memory is available when you are running Widows by choosing About Program Manager from the
File menu in the Program Manager window. For more information, consult your Window Manual.
I am running PowerAlbum and another application the same time. The second application often runs slowly, and sometimes doesn’t
even open.

You probably don’t have enough memory to run both applications at once. Try minimizing PowerAlbum, then open the other
application. If this doesn’t work, you may not be able to run both applications simultaneously without changing your system
configuration. Consult your Windows manual for tips on freeing up memory.

I deleted picture from my hard disk, but it reappeared when I started PowerAlbum again.

The picture has disappeared form your hard disk, but its thumbnail image remains if you haven’t saved the album since the
change. Remove the image again, then save the album.
I installed PowerAlbum and some clip art from the installation disks, but the graphic files I already had on my hard disk do not
appear in the album.

You have to add images to PowerAlbum Before they can appear. If you received clip art with PowerAlbum, you can install it
with the album. To see images of other graphic files that you may have, use the Add Picture command to add them to your
album. Read “Adding Pictures” in the “Managing Pictures” in Chapter 4.

“Error #550 - Unable to open”

This error is produced by PowerAlbum (provided with all Color ClipArt CD ROMs, and stand alone) when it is unable to locate the
album file CLIPART.ALB when PowerAlbum is started for the first time on your system. To remedy this error, complete the
following steps to load the appropriate album file for your ClipArt product.

Load the ClipArt CD ROM in your CD ROM drive.

Start PowerAlbum, if you have removed PowerAlbum, please reinstall the program and start the program before proceeding.
If you receive #550 - Unable to open... message click on OK to enter PowerAlbum.

In PowerAlbum choose File.

From the File menu choose Open.

At the bottom center of the Open menu is Drives. From this list choose your CD ROM Dirive.

Above the Drives box is a large box labeled Directories. In this box double-click on your CD ROM drive Letter found at the
top of the list.

In the Open menu, over to the left center is a large box equal in size to the Directories box. In that box you should see one or
several files (depending on the product you purchased) with the extension ALB. For example: ClipArt Library 3003 has
PC_ART.ALB, Mega ClipArt 12000 has CLIPART1.ALB, CLIPART2.ALB, CLIPART3.ALB and CLIPART4.ALB. double-
click on one file.

You will receive an hour glass while the album file loads. Please allow 2 to 3 minutes for loading. After the Album is loaded,
the thumbnail size pictures will be available for viewing.

How Power Album Uses TEMP Space

What is TEMP space?

When the PowerAlbum Setup program executes, several art library files are copied from the installation disks to the system’s hard
disk and then merged into a final album file. During this process, several temporary files are created which are stored in a particular
directory on the hard disk.

Windows and Windows applications look for a DOS “environment variable” called TEMP to determine where to write these temporary
files. Usually there is a line in the system’s AUTOEXEC.BAT file which defines the TEMP directory:

TEMP=C:\WINDOWS\TEMP

How much TEMP space does Power Album need?

To perform a complete installation of the basic PowerAlbum package (the program plus 1,000 clip art images), at least 4 megabytes
of TEMP space is required. If less than this amount is available, the installation procedure may fail, displaying an error dialog:

“Not enough TEMP space to complete the merge”
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If you subsequently install the 3-disk Imageline art bundle with 1,000 additional images, and you opt to merge it into the original
POWERALB.ALB album file, 6 megabytes of TEMP space is required. If you instead create a second album for the Imageline art
bundle, you’ll need 2 megabytes of TEMP space.

How much TEMP space is available?

First, find out which directory is designated as the TEMP directory. At a DOS prompt, type SET. If you’re running Windows, get to
a DOS prompt by choosing File, Run in the File Manager or Program Manager and typing “COMMAND” in the command line field.
Click on OK.

You’ll typically see a listing that looks something like this:

Microsoft(R) MS-DOS(R) Version 6
(C)Copyright Microsoft Corp 1981-1993.

CA\WINDOWS>
Then execute the dir command to find out how much space is available on this drive. In this example, type:

DIR CA\WINDOWS\TEMP [Enter]
If a “file not found” message appears, the directory does not exist and must be created. To do this, type:

MD CAWINDOWS\TEMP [Enter]
Normally, you’ll get a list of files in this directory (Do not delete any of these files!), followed by the amount of free space on the
drive:

~WRF0001 TMP 1536 11-10-93 4:41p

~WRF0002 TMP 0 11-17-93 8:55a

~WRF0003 TMP 1536 11-17-93 8:55a

~WRI0004 TMP 1920 11-08-93 2:37p
4 file(s) 4992 bytes

12478464 bytes free

C\WINDOWS>
If you’re running Windows, type Exit to close the DOS window.

What happens if you run out of TEMP space?

If you get the message, “Not enough TEMP space to complete the merge”, exit Windows and edit AUTOEXEC.BAT to set TEMP to
a drive with sufficient free space.

If SETUP fails due to lack of space on the target drive for program and data files (not from lack of TEMP space), a large file may be
left in the temporary directory. In this case, exit Windows, delete all temporary files that were created in your temporary directory
and run SETUP again. Ensure you do not delete any program files

NOTE: Not all computers are configured with TEMP as their temporary directory. At the DOS prompt type: SET and press
ENTER. A list of environment variables will appear. One of those variables is TEMP= your temporary directory. Go to this
directory to locate your temporary files, and delete them. If you do not have a TEMP setting, consult your MS DOS manual, or
contact Microsoft for further assistance.

Customer Support

This concludes the QuickStart tutorial. In the event you require more detailed information of the programs covered in this document
a complete manual for PFS: WindowWorks can be obtained for $10.00 directly from SoftKey International Inc. To order your
manual, contact SoftKey Customer Service at:

SoftKey Customer Service: (800) 227-5609

A SoftKey Customer Service representative will take your order and ensure proper delivery of your manual. Should you desire more
information about any of the products SoftKey offers, your Customer Service representative can arrange to have a catalog shipped to
your free of charge.

In the event you should require technical assistance for technical issues such as the program fails to start, fails to install, causes
system (produces error messages) errors, or other non-procedural (non “how to”) technical questions, SoftKey provides the following
technical support resources.
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Automated Support

Automated Technical Support is available 24 hours a day, 7 days a week

Fax On Demand Services

The Fax On Demand system is a fax back system which provides a compilation of documents with solutions for the most common
questions and technical difficulties users have encountered while using PFS: WindowWorks. The FAX ON DEMAND system is
completely menu driven by selecting number choices from your touch-tone phone.

Dial: (404) 514-6333

SoftKey BBS - Download Service

The SoftKey Download Service is provided to users for obtaining updated drivers, helpful utility programs, and informational
documents. It does not provide personal technical assistance.

Dial: (404) 514-6332

CompuServe Forum

SoftKey provides personal technical support, documentation, and updated files via the SoftKey forum on CompuServe. You must
have a CompuServe account in order to access this support medium.

On CompuServe, GO SoftKey

SoftKey Technical Support Center

If you require personal technical assistance for PFS: WindowWorks, the SoftKey Technical Support Center is available to assist you.
You can contact SoftKey Technical Support by Letter, Fax, or phone.

For all Technical issues please prepare and have available the following information before contacting Technical Support. If you are
calling to speak to a technician, please be seated at your computer.

Please have the following information prepared and available.
Machine Specifications:

*  Program name you are calling about

*  Brand name of computer

*  Type of CPU (i.e. 486DX-33, 386SX-25)

*  Amount or RAM (i.e. 4 megabytes, 8 megabytes)

*  Amount of available hard-drive space

*  Version of MS-DOS you are using

*  Version of MS Windows you are using

*  Type of video card (not to be confused with type of monitor)

*  Type and Brand of mouse (i.e. Microsoft BUS mouse, Logitech SERIAL mouse)

*  Name of the memory management software being used (i.e. QEMM, MEMMAKER)

*  The name of any Disk Doubling software being used (i.e. Double-space, Stacker)
This information will allow our technicians to more quickly diagnose and resolve your issues.

Please FAX your questions to: (404) 427-1150
Our address for correspondence is: SoftKey Product Support
Suite 100

450 Franklin Rd.

Marietta, GA 30067
To speak to a Technician please call: (404) 428-0008
Monday through Friday, 9 a.m. to 8 p.m. Eastern Standard Time

An automated menu system will route your call. Please listen carefully to the menu selections so that you may route your call to the
correct support department. Should you not have a touch-tone phone, an operator is available to help you.

Thank you for using SoftKey products.
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