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Finding Information about Eclipse

Sources of information
Your Eclipse package contains several sources of in-
formation: an Installation Guide, this Manual, a
Quick Reference card and a short Introduction.
New features and information received too late to
be included in this manual can be found in the Re-
adMe file which you find in Eclipse’s installation
folder. As you run Eclipse, you can use its online
help system to get the information in this manual.

The Eclipse Tutorials contain a set of lessons that
have been developed by an Eclipse expert with years
of experience delivering Eclipse training and work-
ing with Eclipse users. For a quick tour which shows
you Eclipes’s most exciting features, see Tutorial
1: Eclipse Round-trip.

This Manual provides in-depth information for us-
ing Eclipse to create, edit, compose and retouch im-
ages. Start with “Eclipse Basics” on page 1-1 to get a
general understanding of how to use Eclipse.

After you get going, refer to the topics that you are
most interested in. 

• For image composition, see “Working with
ShapeLayers” on page 5-1 and “Editing Shape-
Layers and Their Fills” on page 6-1 to learn how
to use Eclipse’s ShapeLayer technology to open,
edit and compose multiple images. 

• For retouching, you
“Correcting Color” on 
on page 3-1 or “Maski

• For photo imaging
“Special Effects U
page 7-1.

• For creating color s
ating Color Separatio

Notation used in this
This guide uses different
formats to draw your att
mation.

Bold text
The following types of in
face text:

• Menus or menu items 

• Commands or text tha

• Fields, buttons and op

Here are some examples 

• Choose Save from the
→ Save. This means 
click Save.”

• At the command line, 

• Select Page Dimensi
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Italic text
The following types of information appear in italic
text:

• Cross-references,

• Unique or important terms.

For example:

• See “Notation used in this Manual” on page V.

System and program prompts
File names, system and program prompts and mes-
sages appear in Monotype text like this:

Installation of this product requires ROOT
privileges.

Procedures
Procedures are marked with a headline in bold face.
If several steps are required to complete a proce-
dure, they are numbered like this:

To open an image:
1 Choose File → Open. A submenu appears.

2 From the submenu, choose Image.

Warnings
Warnings are marked in red. Warnings prevent you
from making mistakes which may interrupt your
workflow. For example:

WARNING

Be sure to give the new fi
do not replace the old file

Tips
Tips provide hints or sho

TIP

Calibrate your monitor 
see. It is a good idea to c
ery three months.

Remarks
Remarks provide interes
ments.

Getting Help
Eclipse includes online d
cess through the Help m
the menu bar.

Online Help is an electro
Help is displayed in a sep
leave open as you work.

To get online help, choos
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1. Eclipse Basics 1.1. Starting Eclipse
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1.1. Starting Eclipse 

Starting from the Desktop
Double-click the Eclipse icon in the Eclipse folder in
the Programs section of your Start menu. 

TIP

To start Eclipse, you can also double-click on a Tile
file icon or drop a Tile file icon on top of an Eclipse
icon. A Tile file is an image stored in Eclipse for-
mat.

Starting from the Command line
1 Click Start on the task bar.

2 Click Run in the menu.

3 Type <pathname>\eclipse, where <path-
name> is the name of the directory where you in-
stalled Eclipse, e. g.
C:\Program files\Eclipse\Eclipse

TIP

Starting Eclipse from the command line, lets you
open an image file at the same time by typing the
image’s pathname and filename after Eclipse. For
example, to open a file called picture in C:\myp-
ictures type:
C:\Program files\Eclipse\Eclipse
C:\Eclipse\mypictures\picture.
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it by clicking on its filena-
ress Enter. As a short-cut,

lename to open it.

age files, you can create a
ail of the image file you

GenIcon. 

d in the same directory as
 given a .pxy filename ex-

s the color space
rmines the color space in

ge sets Eclipse to an RGB

ge sets Eclipse to a CMYK

alled the canvas image to
s you place inside Shape-

of the image
s on a copy of any image
 discard unwanted chang-
 to its original version. If a

ng that you will be working
 then Original mode has
references → General.
1–4

1.2. Opening and Saving Images

Opening an image
You can open images in more than a dozen formats
using the Open command in the File menu. Simple
instructions are given here. For detailed informa-
tion see Appendix A: Managing/Translating Files.

To open an image
1 Choose File → Open.

2 From the submenu that appears, choose Image.
The standard Windows Open file dialog appears. 

Open file dialog

Choose the directory you want from the drop-down
menu at the top.

To open an image mark 
me, then click Open or p
double-click the image fi

Generating icons
To help you recognize im
small version or thumbn
want to open by clicking 

Thumbnail files are store
the parent image and are
tension.

The image determine
The image you open dete
which you work:

• Opening an RGB ima
color space.

• Opening a CMYK ima
color space.

The image you open is c
distinguish it from image
Layers.

Eclipse opens a copy 
By default, Eclipse work
you open, allowing you to
es and restore your image
dialog box appears warni
on your original image,
been selected in File → P
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alues which were used the
use those values or type in

 for the dimensions from

ht values into the respec-
 depend on the setting in

tion, type in a new value.
e setting in the Units text
 Pixel per unit. In case the
1–5

See page 9-6 for information on changing back to
Copy mode.

Opening a mask or ShapeLayer
If you save a mask or ShapeLayer with the same
name as the image, you can open them with the im-
age by choosing File → Open → All. 

Once you have opened an image, you can also open
masks and ShapeLayers on their own by choosing
File → Open → Mask or File → Open → Shape-
Layers. 

TIP

When opening an Adobe Illustrator file as a Shape-
Layer file, you may want to select Fit to Canvas
When Open in the Open ShapeLayer file dialog.

Creating a new image
To create a new image, choose File → New Image.
The New Image dialog appears. 

New Image dialog

All text boxes show the v
last time. You can either 
new ones.

1 Units: Choose a unit
the drop-down menu. 

2 Type Width and Heig
tive textbox. The units
the Units text box.

3 To change the Resolu
Its unit depends on th
box. Default setting is
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e copies of Eclipse open at
ry, minimize the copy you

rnal device
from a Twain-compatible
a connected to your com-

 from an external de-

clipse by choosing File →
ain dialog opens with a list
. 

 want to work with.

re to open the software in-
ctive device. See the de-
er instructions on how to
ctures from a digital cam-

age choose File → Print.
d Windows Print dialog.
essary settings like type of
es etc. and then start the

e without quitting Eclipse,
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unit is pixel, resolution equals 1 and can not be
changed, of course.

4 Mode: Choose a color space - RBG or CMYK.

5 To save these settings for future use, click Save.
To reuse saved settings, click Load.

As soon as you have specified width and height
for the new image, Eclipse calculates its file Size.

6 Click OK to create the new canvas.

REMARKS

Saving settings for a new image is like creating
stationery. The settings file takes much less disk
space than a real blank page.

Working with units set to pixels is easiest, especial-
ly if you are unfamiliar with resolutions in other
unit systems.

Opening another image
If you choose File → New Image or File → Open
when an image is already open, a dialog box asks
Close the current image before opening?

• Click Yes to close the current image without sav-
ing it.

• Click Cancel to close the dialog box and not open
another image.

• Click No to start a second copy of Eclipse and
open another image.

TIP

You can have two or mor
once. To conserve memo
are not using.

Import from an exte
You can import images 
scanner or digital camer
puter.

To import an image
vice
1 Connect the device to E

Select Source. A Tw
of the devices available

2 Choose the device you

3 Choose File → Acqui
stalled with the respe
vice’s manual for furth
scan or how to read pi
era.

Printing an image
To print your current im
Eclipse opens a standar
There you define the nec
printer, number of copi
printing procedure.

Closing an image
To close the current imag
choose File → Close.
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 canvas image and its relat-
er overlay with the same
 extension: 
shp for ShapeLayer files.

e the canvas image with a
. The original file is not af-

e the current mask as an
 with a .tmsk filename ex-

r: Save all ShapeLayers in
le with a .shp filename ex-

 the current effect with a

: Save the current correc-
e extension.

ode, you can save chang-
f an image without affect-
 choosing File →  Retain.

ile → Quit or Alt + F4. 

king if you really want to
t to save the image before
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A dialog box appears asking Are you sure you
want to close?

• Click Yes to close the image without saving it. 

• Click No to leave the image open and continue
working. 

• Click Save to both save and close the image.

Saving the image
To save an image with the same name and format,
choose File → Save. 

Using the Save command replaces the original file
with the saved file.

For customized saving, choose File → Save As. A
submenu appears.

Save As → All: Save the
ed mask and ShapeLay
name and an appropriate
.tmsk for mask files and .

Save As → Image: Sav
different format or name
fected.

Save As → Mask: Sav
Eclipse or Alias mask file
tension.

Save As → ShapeLaye
an Eclipse ShapeLayer fi
tension.

Save as → Effect: Save
.eff filename extension.

Save as → Correction
tion with a .corr filenam

TIP

When Eclipse is in Copy m
es to the working copy o
ing the original image by

Quitting Eclipse
To quit Eclipse, choose F

A dialog box appears as
quit and whether you wan
quitting.
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• Click Yes to quit without saving the image.

• Click No to continue working. 

• Click Save to save the image before quitting.
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ecreate a proxy because it
e.

al mode
k in either Copy mode or
mined by a setting in the
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her you work directly on
ies of the files. 

 images, we strongly sug-
rk in Copy mode!!! For

Abandoning Changes” on

orary files
s temporary files as you
 you work in Copy mode,
ach image file you open to

e. Eclipse also uses tempo-
with masks, vignettes, and
ary files have names like
ge.3 or
.2 .

 files while you are work-

orary files it creates when
However, you must have

r hard disk for Eclipse to
s you work. If you run out
you get a warning and are
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1.3. How Eclipse Handles Images

Eclipse uses a native image file format called Tile
file to display images in the main window and in
ShapeLayers. This native format organizes the im-
age data for optimal performance. 

When you open a foreign format image file, Eclipse
creates a Tile version of the image for you to work
on. This is true for Original or Copy mode. When
you save the file, Eclipse saves any changes you
made to the Tile version back to the original file.
You can also save the Tile version in one of more
than a dozen different image formats.

Eclipse creates image proxies
Eclipse creates and uses proxy versions of image
files to display them on screen or within Shape-
Layers.

Eclipse generates an image’s proxy file as it needs it.
This is normally a background process. A proxy file
has the same filename as the actual image, with a
.pxy extension. For example, for an image named
mypicture, Eclipse generates a proxy named my-
picture.pxy. Eclipse stores proxy files in the same
directory as their parent image files. After a work
session, you will find the .pxy files in the same di-
rectory as the images.

When you open an image, Eclipse looks for the
proxy in the same directory as the image. We rec-
ommend that you keep the image proxies in the
same directory as their parent image. This way

Eclipse will not have to r
can’t find the existing on

Copy mode vs. Origin
In Eclipse, you can wor
Original mode, as deter
General Preferences dia
choose determines whet
your image files or on cop

WARNING

To protect your original
gest that you always wo
more information, see “
page 1-34.

Eclipse creates temp
Eclipse creates and use
work. For example, when
Eclipse makes a copy of e
protect the original imag
rary files when you work 
warped images. Tempor
Eclipse.22852.NewIma
Eclipse.22852.Before

WARNING

Do not delete temporary
ing with Eclipse.

Eclipse deletes any temp
you exit the program. 
enough free space on you
create the files it needs a
of temporary file space, 
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 changed to inches, so the
0 inches by 5.00 inches.

 mask channel uses the
nvas image. 

n: ShapeLayer fills are
Only when you render a
vas image, the fill assumes

lution
t resolution for the output
using one of two methods:

hout changing the number
 corresponding but oppo-

imensions.

 without changing the im-

 and dimensions
tion without changing the

image dimensions also

olution, the existing pixels
nd the image dimensions
1–10

prompted to free up space. You can specify the di-
rectory in which Eclipse stores temporary files in
the General Preferences dialog. We suggest that you
store temporary files on a local hard disk for best
performance. 

For more information on temporary files, see page
9-6.

Canvas image resolution
Resolution is the number of pixels per unit of mea-
surement. When you open an image, its original
resolution is preserved. By default the resolution is
expressed in absolute pixels. For example, an image
with a dimension of 7 x 5 inches and a resolution of
100 ppi will have its dimensions expressed as
700,500 — its total number of pixels. Working in
pixels is the easiest, but if your required output is
expressed in pixels per inch (ppi) you can change
the units to inches by choosing File → Preferenc-
es → General. The dimension will then be ex-
pressed as 7.00,5.00.

The canvas image resolution is displayed in the
main window title bar.

By default, the resolution is expressed in pixels.
This image is 700 pixels wide by 500 high.

Now the units have been
resolution is given as 7.0

Mask resolution: The
same resolution as the ca

ShapeLayer resolutio
resolution independent. 
ShapeLayer fill to the can
the canvas resolution.

Changing image reso
If you require a differen
image, you can change it 

• Change resolution wit
of pixels. This makes a
site change in image d

• Change the resolution
age dimensions.

Changing resolution
If you change the resolu
number of pixels, the 
change. 

• If you decrease the res
are spread out more a
increase.
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dialog

xt box, type a new value. 

ixels/Unit is dimmed.

 without changing 

solution without changing
t render the image onto a
n you want. There are two

dalone Renderer to ren-
ifferent resolution. For di-
ing render options” on
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•  If you increase resolution, the pixels become
closer together and the image dimensions de-
crease.

REMARK

When the resolution changes, the image’s output
dimensions also change. In the example we have
been using, you decrease the resolution to 72 ppi.
The dimension of the image will increase (because
the total number of pixels are now spread out
more) to 9.72,6.94 (700 pixels /72 ppi = 9.72 and
500 pixels / 72 ppi = 6.94).

Changing the image resolution and dimensions
does not change the size in terms of pixel count or
storage size. 

When the pixel count remains constant, there is an
inverse relationship between resolution and image
dimensions. As a rule, remember that doubling
resolution cuts image size by half, and vice versa. 

To change the canvas image resolution and 
dimensions
1 Choose File → Preferences → General. 

The General Preferences dialog appears.

The General Preferences 

2 In the Pixels/Unit te

REMARK

If Units is set to pixels, P

Changing resolution
image dimensions
To change an image’s re
its dimensions, you mus
canvas with the resolutio
ways to accomplish this:

• Use the Eclipse Stan
der the image with a d
rections, see “Choos
page 11-12.
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• Create a new canvas with the resolution you want
and render the image onto it, as described next.

To change resolution without changing im-
age dimensions
1 Create a new canvas by choosing File → New

Image.

2 Specify the image resolution and dimensions you
want, then click OK.

3 Create a ShapeLayer of the same size as the can-
vas using the Rectangle tool (see “Creating or ed-
iting a rectangle” on page 5-9).

TIP

Use the ShapeLayer Geometry shelf to fit the
ShapeLayer to the canvas exactly. Set the x and y
positions as well as the offsets to 0.0.

4 Open the image you want to change as a Shape-
Layer fill.

5 Render the image to the new canvas by clicking
Render in the ShapeLayer Toolbox.

For more information on working with Shape-
Layers, see “Working with ShapeLayers” on
page 5-1 and “Editing ShapeLayers and Their Fills”
on page 6-1.
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pressure-sensitive tablet
tab™ API. For instruction
its documentation.

ivity of the tablet stylus by
rences → Stylus Pres-
essure Preferences” on
ation. For instructions on

r tablet, refer to the docu-
 it.
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1.4. Using Mouse and Tablet

Mouse basics
This guide refers to mouse buttons as left, middle,
and right and assumes that your mouse has the
standard button configuration of a three-button
mouse. If you have reversed the order of the mouse
buttons because you are left-handed or for some
other reason, a reference to the left mouse button
refers to the right button on your mouse and vice
versa.

• Use the left button for most tasks: clicking but-
tons, selecting tools, painting and so on. Unless
an instruction explicitly says to use the middle or
right mouse button, use the left mouse button.

• Use the middle button to unpaint and to delete
edit points on polygons and curves. 

• Use the right button to pan an image and to lock
a vertex when shadow casting.

If you’re using a one-button mouse or a stylus,
press Alt + right mouse button to mimic the middle
button. 

A click is a quick press and release of a mouse but-
ton. You click a mouse button to select a command
or an object on the screen.

Dragging means to press and hold the mouse but-
ton as you move the cursor across the screen. You
drag to move or scale ShapeLayers or to pan the im-
age directly.

Using a tablet
Eclipse supports any 
which supports the Win
to install your tablet, see 

You can adjust the sensit
choosing File → Prefe
sure. See “Stylus Pr
page 9-7 for more inform
setting up and using you
mentation that came with
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1.5. Choosing from Menus

In this guide, menu commands are written in this
format: File → Open. This means to choose the
Open command from the File menu.

Eclipse menus work the same as those in other ap-
plications.

File menu

Click a menu title so the menu stays open. Then
click the command you want. 

Clicking a command wit
plays a submenu. Click 
choose it.

Another way to choose a
hold the menu title so yo
down through the menu 
and release the mouse bu

Choosing a command usu
in which you can specify
cuting the action. Some c
and Ungroup in the Or
play a dialog or shelf — t
mediately. 
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1.6. Using Shelves and Dialogs

Eclipse uses shelves to display tools and editors.
You can leave shelves open as you work on your im-
age.

Eclipse uses dialogs to adjust the options for a cer-
tain action. Executing the action closes the dialog.

Shelves and dialogs use the same controls. For this
reason, the controls are described for a shelf only.

A shelf, in this case the Brush shelf

Title bar: Drag here to move the shelf.

Close button: As in any Windows program, click
to close the shelf and cancel any changes you have
made. 

Rollout (shelves only
fault configuration which
frequently used adjustm
ments of a section click o
left side.

Text box: Use these key
typing in a text box:

Pop-up slider: The arro
text box opens a pop-up s

Click Insert cu

Double-click Select al
text box

Drag Select an

Esc Clears a

Left/Right Ar-
row

Moves t
characte

Shift + Pos1 Moves th
of the te

Shift + End Moves th
text

Backspace Moves t
the char
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ces → General   and turn
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• click the button and drag the slider in one move.
The slider closes as you let go of the mouse but-
ton.

• or click the button, then move the slider. Close
the slider by clicking anywhere in the window.

Slider: Drag a slider to change a value or click next
to the slider to change its value incrementally.

Check box: Click to turn an option on or off.

Radio button: Click to choose one of two or more
options.

Push button: Click to activate.

Toggle button: Click to activate or deactivate.

Drop-down menu: Click to see the menu, then
select.

Minimize/maximize the main window
Eclipse uses standard Windows Minimize and
Maximize buttons. 

• To minimize the Eclipse window so that it ap-
pears as an icon on the desktop, click the Mini-
mize button at the right end of the title bar.

• To maximize Eclipse so that its main window fills
the screen, click the Maximize button.

Requester dialogs

Requester dialog exampl

Requester dialogs usual
tions or options by clickin
Cancel, or sometimes Y

As with shelves, clicking 
dialog and cancels the op

If you do not want confir
choose File → Preferen
off Show Requester di
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1.7. Calibrating for Good Color

Edit Inks
Use the View → Edit Inks command to choose
and edit the ink density files Eclipse uses to display
and create CMYK images. Eclipse, Eclipse I/O
(ecio), and CMYK Separator all use the current
(most recently opened) ink density file to generate
CMYK images from RGB originals.

You can use Edit Inks to calibrate both image dis-
play and image separation for your printing envi-
ronment. As you adjust the values of the current ink
density file, you see the changes in the canvas im-
age.

Eclipse includes a standard ink density file that you
can customize and save. To use the ink file specified
in Edit Inks, turn on Proof Inks as described un-
der “Proof Inks” on page 1-18. 

REMARK

Since the Edit Inks and Proof Inks commands af-
fect only CMYK images, they are dimmed and un-
available if you are working with an RGB image.

To choose or edit the ink density file:

1 Choose View → Edit Inks. The Edit Inks dia-
log appears. 

The Edit Inks dialog

2 To change the ink den
edit an existing file, cli

3 Use the Open file dial
the ink density file you
stores the ink 
C:\Program files\Ec
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lculate the image based on
OP printing inks. Proof

s if it was printed. 

r your printing require-
 ink density file or create
e file using Edit Inks, de-
 on page 1-17. 

title, and then click Proof
a check in front of Proof
ed on.

ff, click it again.
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4 To change the Dot Gain, select the text box and
type in a value or use the popup slider. The value
represents the actual dot gain, not a percentage.

5 To change the ink density for a color in a certain
channel, choose the appropriate text box and
type in a new value. You can also use the appro-
priate popup slider. Values can range from 0.00
to 2.00.

As you make changes, you see the effect on screen.

TIP

To get color value information about the canvas
image, use the Probe that is available from the
Window menu.

6 To abandon your changes and restore the ink
density file to the last saved version, click Reset.

7 To save your changes, click Save.

Type a name in the File Name text box or select
a name from the file list. If you choose an existing
filename, Eclipse overwrites that file with the
new file. You can create and save as many ink
density files as you want.

8 To close Edit Inks, click its Close button. 

Proof Inks
Turn on Proof Inks to have Eclipse use the current
ink density file to display a CMYK image. Eclipse in-
cludes a standard ink_densities file in the
C:\Program files\Eclipse\util\custom sub-

directory that it uses to ca
the characteristics of SW
Inks displays the image a

To customize Eclipse fo
ments, you can edit the
your own versions of th
scribed under “Edit Inks”

To turn on Proof Inks
1 Click the View menu 

Inks. When there is 
Inks, Proof Inks is turn

2 To turn Proof Inks o
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1.8. Viewing an Image

Zooming in and out
You can zoom in as far as 16:1 so that the image is
16 times bigger than at 1:1. You can zoom out to 1:16
so that the image is 16 times smaller. The current
zoom level is shown in the Zoom menu at the bot-
tom edge of the main window: 

If the Zoom menu shows 2:1, you are currently
zoomed in at a two-to-one ratio.

Use the Zoom buttons or the Zoom menu to zoom
in or out.

• Zooming out: The image appears smaller auto-
matically.

• Zooming in: If the new size is too large to dis-
play completely, click the point in the image that
you want in the centre of the screen.

Using the Zoom buttons

Zoom-in: Each time you click this button you zoom
in one level.

Zoom-out: Each time y
zoom out one level.

Using the Zoom me
1 To see the Zoom menu

ton displaying the curr

2 Click the level you wan

TIP

You can control whether
level or are fitted to the
Zoom option in the File 
dialog.

When zooming in, keep 
area at the right of the s
zoomed-in size is too b
Eclipse prompts you to S

Using Keyboard sho
• Use Ctrl O to fit the im

• Use Ctrl + to zoom ou

• Use Ctrl-  to zoom in.

• Use Ctrl 1 to zoom to 

Panning and scrollin
When you cannot see the
main window, you can m
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ry large image or when
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eneral Preferences dialog
displays an image as you
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t mouse button.

feedback vs. speed 
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then at higher resolution.
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• Use the Pan shelf available from the Windows
menu.

• Drag the image while holding down the right
mouse button.

Using the Pan dialog
To open the Pan dialog, choose Window → Pan.

The Pan dialog contains an icon version of your im-
age and a pan box that represents the available im-
age area.

The Pan dialog

The Pan box encloses the area visible in the main
window.

Drag the Pan box to scroll the image.

If you have zoomed out s
in the main window, the p
es the image. 

TIP

When working on a ve
zoomed in a lot, keep the
move about readily.

Panning images usin
button
You can pan the canvas i
it in any direction whil
mouse button. 

The Pan option in the G
determines how Eclipse 
pan. Show displays the 
slower than Fast, which 
until you release the righ

Subsampling: Visual 
when moving images

When you pan the canva
filled ShapeLayers, Eclip
at lower resolution first, 
This process is called sub
the subsampling level u
mand in the View menu. 

To set subsampling le
1 Choose View → Sub

pling dialog appears.
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pling level you want
g dialog box open as you
nimum and Maximum
een states.

window
rd can produce artifacts

ow, click Window → Re-
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The Subsampling dialog

2 Set the level you want for Minimum and Maxi-
mum. The following chart describes the effects
of different subsampling levels.

To specify the subsam
• Leave the Subsamplin

work and use the Mi
buttons to switch betw

Refreshing the Main 
Sometimes a graphic ca
while working. 

To refresh the Main wind
fresh.

Level Effect 

1 Subsampling is turned off. The image re-
draws as a series of chunks. This ensures 
you the fastest total redraw time but the 
longest wait for the image to appear.

2 to 9 Subsampling is turned on. As the sub-
sampling level increases, the image re-
draws more quickly and the scan chunks 
become less perceptible.
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1.9. Measuring and Aligning Tools

Showing the Rulers
You can display rulers along the top and left sides of
the image area. The rulers use the current unit of
measurement specified in the General Preferences
dialog, e. g. pixels or inches. 

• To show the rulers, click the Organize menu
and select Rulers so there is a hook beside it.

• To hide the rulers, click Rulers again.

TIP

To change the color of the rulers, press AltGr C.
Press the key repeatedly to cycle through the eight
available color options: red, yellow, green, blue,
magenta, black, white and transparent.

Using the Clone brush to measure dis-
tance
You can measure distance using the Clone brush.

1 Select a Clone brush. (Select the Brush tool in the
ShapeLayer Toolbox. Then in the Brush shelf,
choose a Clone brush from the brush menu or
press F.)

2 Click the point at which you want to start mea-
suring. This point is called the clone source.

3 Drag the pointer.

The distance the pointer is dragged is displayed
in the message area at the bottom right of the

canvas. The units use
the same as those used

As you drag, you will a
line connect the clone
This line disappears 
tool.

4 When you click anothe
tion), the distance dis
area.

5 To measure another d
return to point 2 above

Adding Guides
Guide lines help you alig
move and delete individ
clear all the guides you 
snap guides into position
guidelines. It is helpful to
when you use Guides. 

To see the Guides m
Choose Organize → Gu
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uides →=Delete.

nt to delete.
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nt to move.

ap to a ruler subdivision,

 set of Guides
uides → Save.

g that appears, type in a
 and click OK. By default,
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To add a Guide
Choose Organize → Guides → Add.

• To place a vertical guide, click on the top edge of
the image area (on the top ruler if it is visible). 

• To place a horizontal guide, click on the left edge
of the image area (on the side ruler if it is visible).

Repeat this process for each guide line you want.

To remove all the guides
Choose Clear from Organize → Guides →
Clear.

To delete a Guide
1 Choose Organize → G

2 Click the guide you wa

To move a Guide
1 Choose Organize → G

2 Drag the guide you wa

TIP

If you want guides to sn
turn on Snap.

To save and reuse a
1 Choose Organize → G

In the Open file dialo
name for the Guide file
the file is 
C:\Program files\Ec
rectory.

2 To reuse a saved set of
→ Guides → Open a

To force a Guide to 
division
Choose Organize → Gu

TIP

To change the color of th
peatedly. There is no tra
the guides cannot be hid



1. Eclipse Basics 1.9. Measuring and Aligning Tools
1–24

Using a cross hair
For accurate alignment with ruler units or with oth-
er objects in an image, you can turn the pointer into
a cross hair.

To use a cross hair
Choose Organize → Cross Hair.

To stop using the cross hair, choose Organize →
Cross Hair again.

Aligning ShapeLayers
For information on aligning ShapeLayers, see
“Aligning ShapeLayers” on page 6-6.
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1.10. Choosing a Color

Linking a tool to the Color Editor
Tool editors and shelves that affect color contain a
swatch that shows you the current color for the tool.
To change the color for the tool, you first link the
tool to the Color Editor by clicking its ColorLink
button. 

A tool dialog and its Color Editor

Clicking the ColorLink button in a tool shelf or a di-
alog opens the Color Editor (if it is not already open)
and links it to the tool. 

When you change the current color in the Color Ed-
itor, the new color also appears in the tool’s color
swatch.

The Color Editor shows the current color for the
tool to which it is linked.

For example, if you want
you click the ColorLink b
alog to link to the Mask C
Mask Color Editor to sele
you change colors in th
swatch in the Mask Color

These tool shelves and d
tons:

• Brushes: Brush Editor

• ShapeLayer Fill: Vigne

• Effects: Color Fill, Colo
or

• Mask Color, Backgrou

• Corrections: Replace 
placement

• Shadow Casting 

• CMYK Separator: Hue

Selecting colors in th
1 Open the Color Edit

swatch in a tool that u
dow → Color Editor

The Color Editor shelf ap
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The RGB Color Editor shelf

The title of the Color Editor changes to reflect the
tool to which it is linked.

The sliders available depend on whether you are
working on an RGB or a CMYK image. 

Click the Open Palette button to open the Color
Palette.

2 Choose one of four methods for selecting a color: 

• select a color using the Color wheel

• enter numeric color values

• pick colors from your i

• access the Color Palett
it.

These methods are descri

The color you select rem
the tool you are using un

For example, if you chang
remains red until you ch
Color dialog to fill a Sh
ShapeLayer fill will be re
or again.

Using the Color whe
The Color wheel lets you
Saturation and Lightness

• To select a hue, click t
drag it to the desired c

• To select saturation an
in the square and drag
tion. In the square, sat
to right and lightness
top.

• To select black, click o
the bottom right of the

• To select white, click o
the bottom right of the
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Your settings are displayed immediately as numeri-
cal values in the text boxes at the bottom of the
shelf.

To choose a new color numerically
Type in a value in a text box or use its pop-up slider.

Eclipse adjusts the current color in the swatch at the
top right of the shelf.

To pick a color from the image
1 To choose a color from your image, click the Pick

button which is on the left of the color swatch.

Eclipse prompts you to pick a color from the im-
age.

2 Drag the cursor over the image.

The color swatch, sliders and text boxes reflect
the color values at the cursor position.

3 To select the color beneath the cursor, release the
mouse button.

Using the Color Palette
You use the Color Palette to open, create, edit and
save color sets or palettes. Each palette can hold 90
different colors. You can transfer colors between
the Color Editor and the Color Palette. 

Eclipse includes a default Color Palette file that is
stored in the
C:\Program files\Eclipse\util\custom direc-

tory. You can create and 
and later open them in th

To use the Color Pal
Open it by clicking Open
tor or by choosing Win
Eclipse displays the Colo

The Color Palette

To choose a color fr
Click on of the squares. T
rent color in the Color Ed

Transferring color t
1 If the Color Editor is n

ing Window → Colo

2 To transfer a color fro
Editor and make it the
the small squares in th
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Transferring color from the Color Editor
1 To transfer the current color from the Color Edi-

tor to the Color Palette, hold down the Shift key,
point to one of the squares in the Palette, and
click.

Eclipse sets the color of the square to the current
color shown in the Color Editor.

2 To reset the Color Palette to its state when you
last saved it, click Reset.

Filling the Color Palette with colors from 
an image
1 To fill the Color Palette with colors from an im-

age, click Fill.

Eclipse prompts you to Select color fill re-
gion from image (Esc to abort).

2 Move the cursor to the part of the image from
which you want to get the colors, and drag. A
rectangular box marks the area you select.

3 When the box encloses all the colors you want,
release the mouse button.

Eclipse transfers the selected colors to the Color
Palette.

REMARK

If you select a large port
may display a warning b
area is too large. Click 
and then click Fill again
tion of the image.

Filling the Color Palette w
restricts the palette to th
the picture.

To save the Palette 
ent name
Click Save.

Use the Save File dialog th
ette. 

To open a Palette fi
Click Open.

Use the file dialog that ap
you want.

Eclipse opens the file and
ette.
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1.11. Hiding Parts of the User Interface

Hiding all shelves
Use the Hide command in the Window menu to
hide open tool shelves and dialogs to see as much of
your image as possible. 

To hide all open shelves and dialogs
Choose Window → Hide.

When you choose Hide, Eclipse clears any open
tool shelves, leaving only the main window open.
Any commands or options you selected in the hid-
den shelves remain in effect. 

To redisplay hidden shelves
Choose Hide again.

TIP

When you are showing a customer an image,
quickly hide all shelves and dialogs by pressing
Tab. 

Hiding the ShapeLayer overlay and Rul-
ers

To hide the ShapeLayer overlay and rulers, press
Ctrl H.

To make them visible again, press Ctrl H again.

Tip

TIP

If you hide the ShapeLay
note to turn it on again
also want to hide ShapeL
ShapeLayers →  Outline

Hiding the Brush cur
By default, the circumfe
lined in whatever color is
trolled by AltGr C). If yo
outline, choose File → P
and turn off Cursor: Sh

Hiding the brush curso
mance.
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color, press Change. To re-
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 → Mask Display Op-
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1.12. Set the Color of Parts of the User In-
terface

If you can not clearly see the cursor, ShapeLayer
overlay, rulers or guides, you can change their color.

To change the color of the pointer, ruler 
and ShapeLayer overlay
Press AltGr C. 

Keep pressing AltGr C to cycle through the eight
color choices. One choice hides the ShapeLayer
overlay and ruler. The pointer and guides cannot be
hidden.

In case you want to hide the ShapeLayer overlay,
press Ctrl + H.

You can also change the color that surrounds the
canvas image.The background color is stored in the
user preference file automatically.

To change the background color
1 Choose View → Background Color. 

The Background Color dialog

2 Click the ColorLink bu
itor.

3 Choose the color you w
The background color
ately. To keep the new 
set the background to
dialog.

The mask is blue by defa
color by choosing Mask
tions. For more inform
color and transparency”
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1.13. Previewing the Effects of Changes   

Previewing Corrections, Effects and 
Auto Masks

You can see a preview of a color correction, an effect
or an auto mask by turning on Preview in the
View menu. The preview remains in effect a long as
the correction, effect or mask dialog is open. You do
not have to apply the effect, correction or mask to
see what it will do to your image.

To preview Effects, Corrections, and 
Auto Masks
Choose View → Preview. 

When there is a hook beside Preview, Preview is
turned on.

You will most likely want to leave Preview turned on
while you work unless you are painting on a correc-
tion or effect and want to leave the correction or ef-
fect dialog open to make occasional adjustments. In
this case, turning off Preview hides the correction or
effect except in the areas you have painted. 

To turn Preview off
Choose View → Preview again.

REMARK

If you have ShapeLayers on your image, Eclipse
previews and applies effects and corrections
through the ShapeLayers; the effects and correc-
tions do not affect the entire image. The Shape-

Layers →  Render settin
see the Preview for all Sh
lected ShapeLayers.

Comparing Before an
If you want to evaluate th
rection, or some paint, us
mand to compare the cur
looked when you lasted s
do not like the changes, a
File → Restore. 

To compare an imag
change
Choose View → Track C

The Track Changes dialog

To see how the image loo
or retained, select View:

To see how it looks with y
modified.

Tips
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TIP

If you save an edited image, you cannot use Track
Changes to compare the original version with the
new version. If you want to compare a saved im-
age with the original, open the original image as a
canvas image and open the edited image inside a
ShapeLayer that is the same size as the canvas im-
age. Set the transparency of the ShapeLayer fill to
100 so that the edited image is invisible, then grad-
ually lower the transparency so it becomes visible
and eventually covers the original image.

Probe
To get information about specific color values in an
image, use the Probe available from the Window
menu. Using the Probe is a good way to determine
which colors you may want to correct. For example,
if someone’s face looks too red, you can probe the
face and find out how much red already exists in the
image. Then you will know which red percentages
you need to change.

You can open more than one Probe at a time so you
can evaluate different areas of the image simulta-
neously.

REMARK

When you open another Probe, the new Probe and
its dialog may appear directly on top of or close to
the last ones. Drag the Probes and their dialogs to
separate them.

To use a Probe
1 Choose Window → Probe. The Probe dialog

appears.

 

A Probe dialog 

To help you correlate a P
first Probe you open is la
labelled Probe A. 

The next Probe you open
dow is labelled Probe B

The dialog displays the P
cation as well as the colo
tion. The Before values
applying an effect or co
show the actual state of t

2 To place the Probe, cli

3 To move the Probe use

- Drag the Probe to a n
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- Type in values in the X and Y Position text
boxes and click Move or press Enter. The
Probe moves to the specified location. This is a
good way to take repeated readings at the same
position.

4 To adjust the size of the Probe, select a size from
the drop-down menu which is shown in pixels.

5 When you no longer need a Probe, close its dia-
log. 

REMARK

To get information about the full color range in an
image, see “To pick a color from the image” on
page 1-27.
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1.14. Abandoning Changes

Changes are permanent only when you 
save an image

The work you do permanently affects the canvas im-
age if you render your work and save the image. You
can undo or abandon changes in several ways: 

• When you are working in Copy mode, you can use
the Restore command in the File menu or the Re-
store brush to return the canvas its state when
you last chose Save, Save As or Retain.

• While you are working with the brushes, you can
use the middle mouse button to unpaint brush
strokes.

• When working with ShapeLayers, you can undo
an unlimited number of actions.

• ShapeLayers do not become part of the canvas
until you render them to the canvas image or
mask.

• Auto masks do not affect the image mask unless
you apply them.

• You can preview special effects and color correc-
tions, but they do not change the canvas unless
you apply them.

When you make changes, you see them interactive-
ly. If you save the changes, they affect the actual
canvas image data; there is no post-processing in-
volved.

Copy mode vs. Origin
When you work in Eclip
Copy mode or Original m

To choose the mode
1 Choose File → Prefer

2 In the Preferences dia
button labelled Copy 
nal to choose the mod

When you open an imag
the image file and you w
mode, you can:

• retain changes to the 
fecting the original im
Retain.

• restore an image to th
last saved or retained 
→ Restore.

When you open an imag
work directly on the orig
cannot use the Restore or
or discard changes. 

WARNING

We strongly suggest that
mode to protect your or
nal mode only if you ha
space or you just want to
on them. If you must wor
backup copies of your im
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Retaining changes to your working copy
When you are working in Copy mode, use the Re-
tain command to preserve changes to the working
copy. Retained changes do not affect the original
image, which is only changed if you choose File →
Save or File → Save As.

To retain changes to your working copy 
of an image
1 Choose File → Retain.

A dialog box appears asking if you are sure you
want to retain your image.

2 Click Yes to retain changes. Click No to cancel
the command.

Restoring your image
When you are working in Copy mode, use the Re-
store command in the File menu to restore an image
to its state the last time you retained or saved it. (If
you are working in Original Mode, the Restore com-
mand is greyed out and inactive.)

To return a canvas to its last saved or re-
tained state
Choose File →  Restore.

If you want to restore only part of an image, use the
Restore brush. For more information, see “Restor-
ing selectively with the Restore Brush” on
page 4-12.

Undoing and Redoing
Layers

The Undo command can
you performed on a Sha
ShapeLayer to its state be
ple, if you move a Shape
do, Eclipse restores the 
location.

The Undo command wo
ing and filling actions, i
commands you access 
Toolbox. There is no limi
or steps you can undo — y
action you performed sin
age.

To use the Undo com
Choose ShapeLayer → 

Use the Redo command
that you have undone. F
ShapeLayer and then sel
returns to its original p
Redo, the ShapeLayer m
moved it. 

The Redo command wor
ing and filling actions, i
commands you access 
Toolbox. There is no limi
or steps you can redo — 
action you have undone 
image.
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To use the Redo command
Choose ShapeLayer → Redo, or press Ctrl X.

When you are painting with the Brush tool, you can
remove paint or Unpaint by dragging with the
middle mouse button held down. For information
on unpainting, see “Painting Basics” on page 4-2. 
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1.15. Working on Color Channels or the
Mask Layer

Using the View and Active buttons
An RGB image is composed of three color channels:
Red, Green, and Blue. A CMYK image has four col-
or channels: Cyan, Magenta, Yellow, and BlacK.
You can view and work on all color channels simul-
taneously, or you can work on any combination of
color channels. 

You control the color channels you can see and work
on using the View and Active buttons in the dash-
board along the bottom of Eclipse.

View and Active buttons for an RGB image.

View and Active buttons for a CMYK image.

To view or work on an image or ShapeLayer, click its
View or Active button. To turn it off again, select
its button again.

REMARK

The Channels: Link View
General Preferences dia
you can work on a colo
without viewing it at the

If you turn on Link View
an Active button without
lecting its corresponding
this preference off, you c
nel without viewing it.

When you select a single
layer as a black and w
When you select more t
displays the layers in co
negative view options, us
ing single preference in
dialog box. For more info

Working on the mask
An image also has a mas
mask icon next to the colo
mask buttons to either v
layer. You cannot work o
mask layer at the same ti
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1.16. Canvas Modes

The Canvas Mode determines how Eclipse dis-
plays or combines paint color and the colors in filled
ShapeLayers in relation to the colors in the canvas
image. Since Eclipse is a WYSIWYG system, Canvas
Mode also determines how Eclipse renders Shape-
Layers to the canvas image; what you see on screen
is what you will get when you render your image.

Canvas Mode is most useful when you are compos-
ing multiple images, especially when your canvas
image includes color vignettes. Its also a way to
mimic masking without having to create a mask. 

The Canvas Mode menu

Use the Canvas Mode menu to change the way
Eclipse combines ShapeLayer fills and paint with
the canvas image.

You will find the Canvas Mode menu at the bottom
of Eclipse, beside the View and Active buttons.

The effects of each mode are described on the fol-
lowing pages.

REMARK

When you change the C
plays all subsequent fill
strokes in the new mod
ShapeLayers or paint str
mode does not change.

In Normal mode, Eclips
and ShapeLayer fills as th
the colors in the canvas i
a filled ShapeLayer or p
portion of the canvas ima
ply transparency to the S
wise, a filled ShapeLayer
another filled ShapeLaye
is underneath it.

In Lighten mode, Eclip
ors in a filled ShapeLaye
lighter than the colors in
beneath. As you move a 
over the canvas image, yo
ShapeLayer or the paint s
the canvas image.

In Darken mode, Eclips
ors in a filled ShapeLaye
darker than the colors in
beneath. As you move a 
over the canvas image, yo
ShapeLayer or paint stro
canvas image.

Add is used often with C
eas where a filled ShapeL
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laps the canvas image, Eclipse adds the colors in the
canvas image to the colors in the filled ShapeLayer
or the paint stroke. This produces a blending or
combining of the colors in the canvas with the
ShapeLayer or paint stroke.

Subtract is more often used with RGB images. In
those areas where a filled ShapeLayer overlaps the
canvas image, Eclipse subtracts the colors in the
canvas image from the colors in the filled Shape-
Layer or the paint stroke. The result is similar to
Add for CMYK images; it produces a blending or
combining of the colors in the canvas with Shape-
Layer or paint stroke.

In Color mode, Eclipse displays only the Hue val-
ues in filled ShapeLayer or brush stroke and com-
bines it with the canvas image. The saturation and
luminance of the canvas image are preserved.

In Texture mode, Eclipse displays only the satura-
tion and luminance values in a ShapeLayer or brush
stroke and combines it with the canvas image.



1. Eclipse Basics 1.17. Cropping, Rotating or Transforming an Image

 position and size numeri-
ing into the crop area. The
g appears.

g

the operation.

e CropPaste file at a time;
Crop command Eclipse re-
opPaste file with the new

 a cropped image 
mand to paste a cropped

 the current image. Paste
different orientations. To

st have used the Crop com-
ste file during the current
ion. 

f a image you have 
 Crop

 Crop. The following sub-
1–40

1.17. Cropping, Rotating or Transform-
ing an Image

Cropping the Canvas image using the 
Crop command

You can crop, or copy, a part of an image using the
Crop command in the File menu. Eclipse stores the
cropped portion of the image as a clipboard file
called CropPaste. You can then paste the cropped
portion into the current image or into a different
image using the Paste Crop command. If you turn
on the Use Mask button in the dashboard, the
command crops the image and its mask. 

TIP

If you want to save a cropped portion of an image
as a file, use the Crop As command described on
page 1-41.

To crop an image and save it as a clip-
board file
1 Choose File → Crop.

Eclipse prompts you to select the area to crop. 

2 Drag a rectangle on the image to enclose the por-
tion you want. If you want, you can move and size
the rectangle afterward.

-  To change the size of the crop area, drag the
corners of the rectangle.

- To move the crop area, drag it with the mouse.

- You can also set the
cally by double-click
Crop Geometry dialo

The Crop Geometry dialo

3 Press Ctrl + C to end 

Eclipse stores only on
each time you use the 
places the current Cr
one. 

Pasting and rotating
Use the Paste Crop com
portion of an image into
Crop can paste in four 
use Paste Crop, you mu
mand to create a CropPa
or a previous Eclipse sess

To paste a portion o
cropped using File →
1 Choose File → Paste

menu appears.
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2 Choose the orientation you want to use.

Eclipse displays a rectangular frame in the image
area that represents the cropped portion of an im-
age.

3 Drag the frame where you want it.

4 Press Ctrl + V to paste the cropped portion into
the image.

Saving a cropped ima
the Crop As comman

You can both copy part o
file using the Crop As co
Crop command describe
you can save the cropped
ent file format for it, and 
If you turn on the Use M
board, the command cro
After you crop a portion o
file, you can open it like a
it to fill a ShapeLayer.

REMARK

You can also use the Cro
the ShapeLayers Toolbo
save it as a file. For mor
ing only part of the can
Layer” on page 5-21.

To crop an image an
nent file
1 Choose File → Crop A

2 Drag a rectangle on th
you want to crop. You c
angle after you draw it

3 To end the operation,
file dialog appears.

4 Use this dialog to ch
which you want to save
a filename, and click S

Submenu 
choice

Rotation Orientation

0° Pastes the image at the same 
orientation at which it was 
cropped

90° Rotates the image 90 degrees

180° Rotates the image 180 degrees

270° Rotates the image 270 degrees
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Transforming the Canvas image
Rotate, scale, mirror, and transform the canvas im-
age using commands in the Canvas submenu, which
is available by choosing View → Canvas. 

The first five commands are the most commonly
used transformations.

Choosing Transform from this submenu opens
the Canvas Transform dialog. Use it to enter values
for scaling, rotation, anti-alias level and flipping di-
rection. 

The Canvas Transform di

REMARK

If the canvas has any u
they are saved in a
Eclipse_infile located
ry specified in the File P
the canvas is transform
Layers. You can find t
called Eclipse_infile.
temporary directory. Tr
vas with ShapeLayers re
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2.1. Color Corrections Overview 

Use the Correction tools in the Correct menu to
make color corrections to the canvas image. There
are 14 correction tools to choose from:

• Combo: Combines Midpoint, Contrast, Bright-
ness, Slope and Freeform.

• Contrast: Sharpen or flatten contrast.

• Dodge/Burn: Lighten or darken an image.

• Brightness: Add or subtract color evenly across
the range.

• Freeform: Move, add or delete points on the
tone curve with this sophisticated gradation tool.

• Gradation: Change the quarter and eighth
tones individually for any channel.

• Midpoint: Adjust the midtones only. 

• Modify: A gradation tool with numerical display
of color values.

• SetPoint: Adjust the color of highlights and
shadows.

• Slope: Independently adjust the start and end
points of a color curve. 

• Selective Color Replacement: Change spe-
cific hues.

• Replace Color: Chan
lect.

• HSL Replace Color:
and lightness of a spe
space.

• Color Transfer: Alt
one channel or move 
another.

You can apply color Corr

• the entire canvas imag

• selected color channel
cluding the mask chan

• specific areas of the ca
up with a Correct brus

• areas of the canvas im
Layers (or within all 
ShapeLayer → Re
ShapeLayers).

Previewing and evalu
To preview the effects of 
view with the button in
View → Preview in the

To compare an image bef
choose View → Track C
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To read before and after color values, choose Win-
dow → Probe.

TIP

Using the Probe is a good way to determine which
colors to correct. For example, if someone’s face
looks too red, probe the face and find out how much
red already exists. Then you will know which red
percentages you need to change.

For more information on using these tools, see
“Previewing the Effects of Changes” on page 1-31.

Tip
Working with Correction dialogs

When you choose a Correction from the Correct
menu, a Correction dialog appears. Only one Cor-
rection dialog can be open at a time. If you choose
another Correction, the second Correction dialog
replaces the first.

TIP

If you want to apply a number of Corrections at
once, use the Combo Correction tool described on
page 2-9.

Most Correction dialogs have the same basic ele-
ments, as illustrated in the following picture of the
Freeform Correction dialog. A typical Correction dialo

tion)

Editing the Correctio
The main portion of mo
plays a graph with a grap
use a standard (x,y) grid.
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The (horizontal) x-axis represents input values
that range from 0 to 100 percent dot. Input values
represent the image’s state prior to a Correction.

The (vertical) y-axis represents output values that
also range from 0 to 100 percent dot. The output
values are determined by the input values plus or
minus any change you make to the graph line or
curve. 

The graph line or curve represents the relationship
between the input and output values for a given
Correction. A straight 45-degree line between (0, 0)
and (100, 100) means that there is no difference be-
tween the input and output values.

To make a Correction, you move one or more points
on the line, usually in the vertical direction. As you
move a point, you distort the graph line and change
the output values along the y axis. If Preview is
turned on, you can immediately see the Correction
applied to the image.

Selecting a graph for a color channel
For most Corrections, you can make different ad-
justments to each color channel. In this case, each
channel has a separate graph line, which is the same
color as the channel: a red graph line represents the
red channel, a blue graph line represents the blue
channel, and so on. 

In this picture, the red
graph points appear on t

To work with a different 
ferent channel button. Po
channel appear on the gr
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Selecting a graph point
When Eclipse displays a Correction dialog, it high-
lights one of the points on the graph line, most often
the point nearest the origin. You can select any
point on the line.

REMARK

 Some graphs have only one point.

Moving a graph point
You make color Corrections by adjusting the posi-
tion of the graph points using one of these methods: 

• Drag the point. 

• Change from one point to the next by clicking the
Select Node arrows. Click the Modify Node
arrows to change a point’s value. You can select
the amount of movement per step in the Step
text box.

• If the Correction dialog has text boxes that con-
trol the graph points, type new values in the box-
es and then press Enter or use the text box’ popup
slider.

About values you typ
The effect of values you t
Range setting in the Ge
log box: 0-100 or 0-255.

0-100: If Color Range 
percentages. Typing 10 m
by 10 percent”. Typing -10
or by 10 percent” (providi
ative values, described be

0-255: If Color Range 
actual pixel values. In th
“increase this value by 10
means “decrease this valu

There are also two ways i
pret values: relative and 

Relative: Most Correctio
type in text boxes as relat
value of the currently sele
positive value increases 
selected graph point. Ty
creases its value.

Absolute: The Freeform
use absolute numbers, w
you type is the value tha
are set to 0 for these tool

Correcting RGB vs. C
The direction in which y
lighten an image differs fo
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Because the location of shadows and highlights on
the graph are reversed in RGB and CMYK images,
you move graph points in opposite directions to
achieve the same change.

 

To lighten an RGB image: Move graph points up-
ward.

 

To lighten a CMYK im
downward. 

Correction dialog co
tions

To apply the Correction 
rect. 
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Eclipse displays a confirmation box that asks if you
really want to apply the Correction. Click Yes to ap-
ply the Correction or click No to cancel the opera-
tion.

To retain your values and close the dialog, click
Memorize.

To undo a Correction, choose File → Restore. The
Restore command restores the image to its last re-
tained state. For more information, see “Restoring
your image” on page 1-35.

To reset a graph line to its default state, click Reset.
When working with different channels and graph
lines, you can reset the lines separately or together.
This is an easy way to start over if you decide you do
not like the changes you have made.

Saving and opening Correction files
Use the Load and Save buttons to save Correction
settings. Eclipse saves the settings in a file, which
you can open later to repeat the Correction. This is
a good way to apply consistent Corrections to many
images. 

To save a Correction file
1 Choose a Correction from the Correct menu.

The appropriate Correction dialog appears.

2 Specify the Correction settings you want and
click Save.

Use the Save File dialog 
save the Correction settin
The Correction file is giv
sion automatically.

To open a Correctio
1 Choose a Correction fr

The appropriate Corre

2 Click Load in the Corr

3 Use the File Open dia
the Correction file.

Eclipse updates the Corr
tings from the Correction

Restricting Correctio
Layers

You can preview and app
the canvas image that a
Layers.

• If you choose ShapeL
Selected ShapeLay
applies Corrections on
image surrounded by 
selected.

• If you choose ShapeL
All ShapeLayers, Ec
Corrections through a
image, whether or not
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• If you close the ShapeLayer Toolbox, the
ShapeLayers disappear and a Correction affects
the entire image.

TIP

To more easily see the changes a Correction makes,
draw a ShapeLayer over only half of the area you
want to change and compare the areas inside and
outside the ShapeLayer.

Brushing on Corrections
By brushing on a color Correction with a Correct
brush, you can touch-up only the areas you want.
Airbrushing with a low-density brush gives a soft,
natural effect.

To use the Correct brush
1 Choose a Correction from the Correct menu.

2 Set up the Correction in the Correction dialog,
but do not apply the Correction.

3 Close the Correction dialog. Or, if you want to
leave it open so you can quickly modify the Cor-
rection settings, turn off Preview.

4 Select the Correct brush from the Brush Type
menu in the Brush shelf or press N.

5 Brush on the Correction.

WARNING

If you do not open a Correction dialog, Eclipse ap-
plies the last Correction you used to the areas you
paint.

For more information, 
page 4-1.

Applying Corrections
You can apply all Correct
Correction to the mask la

• Select the Active Mas
in the dashboard so y
layer.

• For an RGB image, sel
Correction dialog befo

• For a CMYK image, se
the Correction dialog 
tion.
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2.2. Combo Correction

The Combo Correction combines the functionality
of the Midpoint, Contrast, Brightness, Highlights,
Shadows and Freeform Correction in a single oper-
ation. This allows you to preview the effects of ap-
plying these commonly used Corrections in
combination before committing them to the canvas. 

REMARK

Because of the complexity and interdependency of
the Combo Correction, you cannot adjust the
graph line by dragging points.

To use the Combo Correction
1 Choose Correct → Combo. The Combo Correc-

tion dialog appears.

The Freeform Correction has its own section as
you can choose values for each eight tone.
The Midpoint, Contrast, Brightness, Highlights
and Shadows Correction each move the whole
curve.

The Combo Correction di
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2 Select the color channel you want to correct.

3 Use the text boxes or their popup sliders to edit
the curve, or click Load to open a previously
saved Correction file. 

4 When you have defined all Corrections, click
Correct to apply them. 

5 If you want to save the Corrections to use another
time, click Save.
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2.3. Contrast Correction

The Contrast Correction is similar to adjusting the
contrast on a television. High values sharpen the
contrast; low values flatten contrast. The end points
of the graph are fixed so extreme highlights and
shadows remain constant.

To adjust contrast
1 Choose Correct → Contrast. The Contrast Cor-

rection dialog appears.

2 Select the color channel you want to work with.

3 Use any of the following methods to adjust the
contrast:

- Load a Correction file.

- Drag a point on the graph line. You can use ei-
ther point—the graph line distorts symmetri-
cally no matter which point you drag.

- Select a point and click the Modify Node ar-
rows.

- Select a point, type a positive or negative value
in the Contrast text box and click Enter. You
can also use the text box’ popup slider. 

The graph point and line move to reflect the new
value.

If you want to save your settings, click Save.

The Contrast Correction 

4 When you have defin
Correct to apply it. 
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2.4. Dodge/Burn Correction

Use the Dodge/Burn Correction to lighten or dark-
en an image. It is based on the photographers’ tech-
nique of lightening an area by obstructing light
during printing (dodging) or darkening an area by
allowing extra light to reach it (burning).

The Dodge/Burn Correction works on all color
channels simultaneously; there is no need to select
a channel.

To lighten or darken an image using 
Dodge/Burn
1 Choose Correct → Dodge/Burn.

The Dodge/Burn Correction dialog appears. The
points on the graph line represent three quarter
tones: 25, 50 and 75. The eighth tones are repre-
sented by small x’s between the quarter tone
points. Below the graph, the dialog contains a
column of text boxes that display the three quar-
ter tone values for the channels.

2 Select Dodge or Burn. Use Burn to darken the
image; use Dodge to lighten it.

When dodging (lightening), you can only move
the graph points upward. 
When burning (darkening), you can only move
the graph points downward.
The direction in which you move graph points
has the same effect on both RGB and CMYK im-
ages.

The Dodge/Burn Correct

3 Adjust the quarter an
dragging the graph po
adjusting graph poin
point” on page 2-5.

REMARK

If you enter a negative va
is set to zero.
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2.5. Brightness Correction

The Brightness Correction produces a flat addition
or subtraction of color. The same amount is added
or subtracted throughout the entire image, from the
highlights to the shadows. Brightness is useful for
removing color imbalances (commonly known as
“casts”) or for ghosting.

The Brightness Correction has only a midpoint. As
you move the point, the entire graph line moves up
or down.

REMARK

The Brightness Correction is related to the tech-
nique of chemically etching film separations,
where”choking” shrinks the dot and “spreading”
increases the dot. 

To add or subtract color using the 
Brightness Correction
1 Choose Correct → Brightness. The Brightness

Correction dialog appears.

Click Load if you want to use an existing Correc-
tion file.

2 Adjust the cast by dragging the graph point, typ-
ing a value in the text box or using the popup slid-
er. 

WARNING

As you move the graph line up or down, shadow or
highlight detail is lost.

The Brightness Correctio

REMARK

As mentioned before (“C
images” on page 2-5), t
works in opposite ways 
es. 

EXAMPLE

To remove a reddish colo
lect the red channel and 
ward. 
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To save your Correction settings, click Save.

3 When you have defined the Correction, click
Correct to apply it.
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2.6. Freeform Correction 

Freeform allows the greatest control of values along
the tone curve of an image. Since the graph line al-
lows up to 256 separate points, you can use it to iso-
late specific percentages of color that you want to
change. For example, you may need to correct only
the 25 percent to 50 percent red in an image.

Choose between a linear and a smooth curve inter-
polation:

• Linear allows sharp, precise differences in
tones. 

• Smooth produces more gradual transitions be-
tween tone points.

You can fine tune a Freeform Correction by adding
a graph point exactly where you want it on the
curve. This gives you control over all input and out-
put values. You can make subtle adjustments or ex-
treme changes for interesting creative effects.

To add a graph point to the graph
Click on the graph with the left mouse button.

To delete a graph point
Click on the point with the middle mouse button.

To open an existing Correction file, click Load.

The Freeform Correction

There are three ways to m
either:

• Click on it with the mo
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• Select a point with the Select Node arrow but-
tons and move it with the Modify Node arrow
buttons.

• Select a point either way and move it horizontally
with the In text box, vertically with the Out text
box.

TIP

With the Freeform Correction, you can shift a
graph point horizontally, making it handy for ma-
nipulating narrow ranges of color. To pinpoint a
color range you want to change, drag a tone point
from side to side to see what colors it affects in the
image. 

To save your settings, click Save.

When you have defined the Correction, click Cor-
rect to apply it.



2. Correcting Color 2.7. Gradation Correction

 dialog

ed the Correction, click
2–17

2.7. Gradation Correction 

Use Gradation to change the quarter and eighth
tones individually in all channels to lighten or dark-
en the image. The Gradation Correction dialog dis-
plays the actual dot percent of the quarter tones. 

To use the Gradation Correction
1 Choose Correct → Gradation.

Eclipse displays the Gradation Correction dialog.
The points on the graph line represent the quar-
ter tones. The eighth tones are represented by
small x’s between the quarter-tone points. Below
the graph, the dialog contains a row of text boxes
that display the quarter tone values for the chan-
nels.

To use an existing Correction file, click Load.

2 Select the color channels you want to work with.
You can select as many channels as you want at
one time.

3 Modify the quarter and eighth tones by dragging
points on the graph or by clicking the Select and
Modify Node arrow buttons. 

You can also modify the quarter tones by typing
values in the text boxes and then pressing Enter
or using a text box’ popup slider.

To save your settings, click Save.

The Gradation Correction

4 When you have defin
Correct to apply it.
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2.8. Midpoint Correction 

Modify allows numeric manipulation of each color
channel individually. The Midpoint Correction is a
variation on the gradation curve; it forces the Cor-
rection at the midpoint of the color and propagates
the Correction in a decreasing amounts to the high
and low ends of the color (100 percent to 0 percent).
Use Midpoint when you want to make the Correc-
tion to the midpoint of the color, but do not want to
affect the highlights or the shadows. 

This operation is similar to a gamma curve, as it
mainly affects the midrange of a color channel with
decreasing effect at the start and end points. A pos-
itive change increases the midpoint (50 percent
dot). A negative change decreases the midpoint. 

For example, a midpoint increase of 15 adds 15 per-
cent dot to the midrange areas and a lesser increase
to the remaining areas since the curve slopes off the
0 percent at the start and end points. 

To use the Midpoint Correction
1 Choose Correct → Midpoint. Eclipse displays

the Midpoint Correction dialog.

To open an existing Correction file, click Load.

2 Select the color channel you want to work with.

3 Adjust the midpoint by dragging the graph point,
typing a value in the text box and pressing Enter
or using the popup slider.

The Midpoint Correction

REMARK

The 100% and 0% valu
midtones can change.

To save your settings, clic

4 When you have defin
Correct to apply it.
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2.9. Modify Correction 

Modify is a type of gradation correction. Its advan-
tage is that it displays numeric values for the chan-
nels, providing accurate control and feedback. This
is a good tool to use with the Probe (see “Probe” on
page 1-32).

1 Choose Correct → Modify.

To open an existing Correction file, click Load.

Eclipse displays the Modify Correction dialog.
The points on the graph line represent the quar-
ter tones. The eighth tones are represented by
small x’s between the quarter tone points. Below,
the dialog contains five rows of text boxes that
display the quarter tone values for each layer.

2 Select the color channel you want to work with.

3 Modify the quarter and eighth tones by dragging
a graph point or clicking an arrow button.

You can also modify a quarter tone by typing a
value in the text box beneath a quarter tone
point, and then pressing Enter. The point moves
to reflect the new value.

To save your settings, click Save.

4 When you have defined all Corrections, click
Correct to apply them. The Modify Correction di
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2.10. Set Point Correction

Use the Set Point Correction to adjust the color of
highlights and shadows. For example, use it to add
color to blown-out highlights or to remove color
from shadows. Set Point is especially useful with
CMYK images, in which shadows often have too
much ink and highlights are often lost. 

To adjust highlights or shadows using 
the Set Point tool
1 Choose Correct → Set Point. The Set Point

Correction dialog appears.

To open an existing Correction file, click Load.

2 Select the color channel you want to work with.

3 From the Position dropdown menu, select either
Start (for catch lights) or End (deep shadows).

Eclipse displays two points at either the start or
the end of the graph line.

- One point represents the Set point and moves
only along the graph line—you can not move it
above or below the line. 

The Set point limits the adjustment you can
make to a specific range. If you select a Set
point of 10 percent, an adjustment increases or
decreases the dot amount between 0 percent
and 10 percent.

- The second point is
you use to make you

The Set Point Correction
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4 Adjust the Set point by dragging it along the
graph line or by typing a value in the Set text box. 

If you select a Set point of 10 percent, any adjust-
ment you make affects only catch lights or deep
shadow of 10 percent or less.

5 Use any of the following methods to adjust the
catch lights or deep shadows:

- Click and drag the Move point. Notice that you
can not move the point beyond the Set point,
although you can drag it above or below the
line.

- Select the Move point, and click the Increase
or Decrease arrows. These arrows work only
with the Move point.

- Type a positive or negative value in the Move
text box, and press Enter or use a text box’ pop-
up slider. The point moves to reflect the new
value. 

To save your settings, click Save.

6 When you have defined the Correction, click
Correct to apply it.
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2.11. Slope Correction 

Use the Slope Correction to adjust highlights and
shadows independently. With Slope you can change
contrast, make a picture crisper and more vivid, or
affect a single color channel. 

To use the Slope tool
1 Choose Correct → Slope. The Slope Correction

dialog appears.

To open an existing Correction file, click Load.

2 Click to select the color channel you want to work
on.

Eclipse displays one point at each end of the
graph line. The point at (0,0) is the start point;
the point at (100,100) is the end point.

3 Use any of the following methods to adjust the
slope:

- Click and drag the start or end point on the
graph line. Notice that the points remain an-
chored to the outer boundary of the graph.

- Select either point using the Select Node arrow,
and click the Increase or Decrease arrows.

- Type a positive or negative value in the Start or
End text boxes at the bottom of the dialog,
then press Enter. The corresponding point
moves to reflect the new value.

The Slope Correction dia

4 You can adjust both t
you want.

To save your settings, 

5 When you have defin
Correct to apply it.
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2.12. Selective Color Replacement

The Selective Color Replacement is one method for
adjusting hues in images. The Replace Color and
the HSL Replace Color Effect provide other ways of
adjusting hues. 

With the Selective Color Replacement, you can se-
lect a palette of colors to change either by picking
colors from the canvas image or by specifying a col-
or using the Color Editor or Color Palette. Then type
the amounts of RGB or CMYK you want to add or
remove from each color (use positive or negative
numbers). 

You can choose the range of a specific color that you
want Eclipse to correct.

To adjust specific hues using Selective 
Color Replacement
1 Choose Correct → Selective Color. The Selec-

tive Color Replacement dialog appears.

To open an existing Correction file, click Load.

The Selective Color Replaceme

2 Choose a color from o
the top of the Selectiv
log. To link to the Col
Link button. Then use
the chosen color. 

To choose a color from
button in the Color Ed
age to select a color.

The color swatches in 
the Selective Color Rep
color you are currentl
mouse button to select

For other ways to sele
Color” on page 1-25.

3 In the Red, Green or B
ta and Black) text boxe
you want to offset the 
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- If Color Range in the General Preferences dia-
log box is set to 0-100, type positive or negative
values for the percentage of the respective color
channels you want to add to or subtract from
the color shown in the swatch. 

- If the Color Range in the General Preferences
dialog box is set to 0-255, type positive or neg-
ative values by which you want to alter the re-
spective color channels.

REMARK

If the offset values below a color swatch are all 0,
the color is not affected by the Selective Color Re-
placement.

4 To extend the range of hues that will change, type
a positive value in the Range text box near the
bottom of the column. 

A Range of 10 means hues with values 5 percent
above or 5 percent below the target hue (the hue
in the color swatch) will change.

In either case, the values entered in the color
channel text boxes apply equally to all hues in-
cluded in the range.

5 Create a gradual tonal drop off using the
Smooth text box. A Smooth value of 20, for ex-
ample, means there will be a gradual reduction in
change to colors within 20 percent on either side
of the Range colors.

6 Repeat this procedure for up to eight colors.

To save your settings, 

7 When you have defin
Correct to apply it.
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2.13. Replace Color Correction

Use the Replace Color Correction to change or com-
bine colors you specify without having to cut a
mask. There are two ways to use the Replace Color
Correction: Relative and Absolute. 

• Relative: Adds the To color to the From color.

• Absolute: Changes the From color to the To
color.

To change or combine colors using the 
Replace Color Correction
1 Choose Correct → Replace Color. The Re-

place Color Correction dialog appears. 

The Replace Color Correc

To open an existing Co

2 Select the Color shift y
solute.

3 Click the From Color
Replace Color Editor. U
tor to specify the color
from the image, click th
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or drag on the image. For more information, see
“Choosing a Color” on page 1-25.

4 Set the To color in the same way.

TIP

You can also set the to and from colors using the
textboxes and their sliders.

5 To extend the range of the change, type a value in
the Range text box. For example, if you type 10
in this box, Eclipse changes the From color and
the ten hues on either side of it to the To color. If
you leave this text box blank, Eclipse changes
only the specific color in the From swatch.

6 To create a gradual reduction in color change on
either side of the specified range, type a value in
the Smooth text box, or use the sliders to adjust
this value.

To save your settings, click Save.

7 When you have defined the Correction, click
Correct to apply it.
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2.14. Color Transfer Correction 

Use the Color Transfer Correction to add or subtract
percentages of any combination of colors from any
color channel. For example, you can use Color
Transfer to remove Cyan, Magenta or Yellow from
shadows to create black only shadows in CMYK im-
ages. You can use it to create black only images in
CMYK with total control over how much data is
transferred from each of the Cyan, Magenta and
Yellow channels.

You can also use Color Transfer to copy and paste
color between color channels or to increase or de-
crease the amount of color in a specific channel. For
example, to increase the red channel in an RGB im-
age by 20 percent you would type 120 in the Red, red
field in the Transfer dialog.

Depending on whether you are working with a
CMYK or RGB image, the table has either three or
four rows and columns. The columns represent the
current color channel values. The rows represent
new color channel values. When you transfer colors,
the columns represent the source values, and the
rows represent the destination values.

To use the Color Transfer Correction
1 Choose Correct → Color Transfer. The Trans-

fer Correction dialog appears.

To open an existing Correction file, click Load.

The Color Transfer Corre

2 To increase or decreas

- Find the column for
change. For example

- Look down the gree
belled Green.

- In the box where th
Green row meet, ty
or less than 100. Fo
green by 20 percent,
by 20 percent, type i
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click Save.
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3 To transfer color between channels, type in pos-
itive values:

- Find the column for the color you want to
transfer from (the source layer). For example,
to transfer green to the blue channel, start at
the green column.

-  Look down the green column for the row la-
belled Blue. This row represents the destina-
tion channel.

- In the box where the green column and the
Blue row meet, type in a positive percentage
value for the amount of source color you want
to transfer to the destination channel. For ex-
ample, to transfer 20 percent of the green
channel to the blue channel, type in 20.

4 To selectively increase or decrease one color in
relation to other channels, type in positive or
negative values. For example, to increase the red
only in areas that have a high concentration of
blue:

- Find the row for the color you want to increase
or decrease. For this example, start at the Red
row.

- Look across the Red row and find the column
for the channel in which you want to increase
or decrease the red. For this example, find the
blue column. 

- In the box where th
column meet, type in
centage value. For ex
by 20 percent in are
tion of blue, type in 2
20 percent, type in -

REMARK

If Color Range in the Ge
0-255, then values you ty
tion dialog’s text boxes ar
ues, not as percentages. 
“About values you type i

To save your settings, 

5 When you have defin
Correct to apply it.
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3.1. Effects Basics

Eclipse Effects
Eclipse includes 14 built-in effects. From the Effects
menu, you can choose these effects:

• Colorize: Replace all colors with a single color. 

• Fill: Fill the canvas image or a ShapeLayer with
a single color.

• Invert: Convert color data to their negative val-
ue.

• Despeckle: Remove or reduce noise and small
flaws.

• Emboss: Create a raised effect and tint it if you
want.

• Gaussian Blur: Make an image appear out of
focus.

• Monochrome: Convert a color image to gray-
tone.

• Monochrome & Invert: Convert a color image
to a graytone negative.

• Noise: Add random texture to an image.

• Pixelize: Produce a low-resolution effect.

• Posterize: Reduce the number of colors in an
image.

• Sharpen: Increase th

• Soften: Soften or gen

• Unsharp Masking:
similar to but less pow

Applying Effects
As with color corrections

• the entire canvas imag

• selected color channel
cluding the mask),

• areas of the canvas im
Effects brush,

• areas of the canvas im
by ShapeLayers.

Working with Effects
When you choose an Effe
an Effects dialog appears
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An Effects dialog, here the Colorize Effect dialog

• If the Effect dialog has a ColorLink button, click
it to link to the Color Editor. Then use the Color
Editor to choose the color you want.

• To control the intensity of the Effect, drag the
slider. 

Alternatively, type in a value in the text box and
press Enter.

• Click the push button with the Effect’s name to
apply the Effect to the image or to image areas
within ShapeLayers.

• Click Memorize to close the Effect and retain its
settings.

REMARK

If you want to apply the Effect with a brush either
close the Effects dialog or turn off Preview. If you
do the latter, make sure to turn Preview on again
when you are finished with the Effects brush.

Previewing and evalu
• To see how an Effect 

click the Preview but

• To compare an image
fect, choose View → 
view is turned off, app
Track Changes.)

• To read before and a
Window → Probe.

For more information o
“Previewing the Effects o

Restricting Effects w
You can preview and ap
canvas image surrounded

• If you choose ShapeL
→ Selected ShapeL
and applies Effects onl
age surrounded by Sha
ed.

• If you choose ShapeL
→ All ShapeLayers
plies Effects through a
image, whether or not

• If you close the Shape
Layers disappear and 
image.
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Brushing on Effects
Brushing on an Effect with the Effects brush allows
you to touch up an image selectively and subtly. Air-
brushing with a low-density brush gives a soft, nat-
ural effect.

To use the Effects brush
1 Choose an Effect from the Effects menu.

2 Set up the Effect using the Effects dialog, but do
not apply it.

3 Either close the Effects dialog or, if you want to
leave it open so you can modify the settings, turn
off Preview.

4 Select the Effects brush from the Brush Type
menu in the Brush Editor, or press AltGr Q.

5 Brush on the Effect.

WARNING

If you do not open an Effect dialog, Eclipse applies
the last Effect you used to the areas you paint. For
more information about brushing on Effects, see
“Brushing on an Effect with the Effects Brush” on
page 4-16.

Applying Effects to a mask
You can apply all Effects to the mask layer. 

Before you apply an Effect to the mask layer, you
have to first select the Active Mask and View Mask
icons in the Eclipse dashboard.

For information on worki
ing” on page 8-1.
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3.2. Colorize Effect

Use the Colorize Effect to replace or blend all the
colors in an image with a single color. The lightness
component of colors is not affected. 

At full intensity all existing hues in the image are re-
placed with the Colorize hue. At less than full inten-
sity, a percentage of hues is replaced and blended
with the Colorize color.

The Colorize Effect is useful for adding casts or
tints, such as a sepia-tone effect, to an image. 

To use the Colorize Effect
1 Choose Effects → Colorize. The Colorize Effect

dialog appears. The Preview shows existing col-
ors replaced or blended with the current color.

 

The Colorize Effect dialog

2 To choose a different color for the Effect, click the
ColorLink button. 

This links the Colorize
or Editor. If the Color
played, it appears.

3 Use the Color Editor o
a new color. 

4 Eclipse colorizes the im

5 Adjust the percentage
replaces the current co
text box.

6 At its maximum valu
with the Colorize color

7 When you are satisfie
click Colorize to appl
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3.3.  Fill Effect

Use the Fill Effect to fill your image or a ShapeLayer
with a single color. This is helpful e. g. if you want to
change the default white canvas when you create a
new image. It is also useful for “ghosting” back an
image.

To use the Fill Effect
1 Choose Effects → Fill.

Eclipse displays the Fill Effect dialog and uses the
current color to fill the image.

The Fill Effect dialog

2 To choose a different color for the Effect, click the
ColorLink button. 

Eclipse links the Fill Effect to the Fill Color Edi-
tor.

3 Select a new color using the Color Editor or Color
Palette.

4 Eclipse fills the image 

5 To adjust the intensity
or type in a value in th

6 To apply the Effect to t
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3.4. Invert Effect

The Invert Effect converts an image’s color data to
negative color data, producing a color-negative or
X-ray effect.

REMARK

You cannot use the Invert Effect to create real color
negatives using a film recorder. It only simulates a
negative for use in paper prints.

1 Choose Effects → Invert.

Eclipse previews the image as a color negative
and displays the Invert Effect dialog.

The Invert Effect dialog

2 To adjust the intensity of the Effect, use the slider
or type in a value in the text box. 

3 To apply the Effect to the image, click Invert.
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3.5. Despeckle Effect

Use the Despeckle Effect to reduce or remove noise
and small flaws throughout an image. It can be use-
ful on images that have been poorly scanned. It is
also useful to remove banding in color gradients.

REMARKS

Since Despeckle evens out differences by changing
pixels values, it produces a softening effect on the
image. For another softening effect, see “Gaussian
Blur Effect” on page 3-10.

For another method to remove flaws from an im-
age, see “Blemish Removal” on page 7-31.

To remove specks
1 Choose Effect → Despeckle. You see the

Despeckle Effect dialog.

The Despeckle Effect dialog

2 Adjust the Radius. 

The Radius slider co
pling square used whe
replacement pixels for
value of 1 to 5. Genera
works best. At higher
come too fuzzy. At 1 D

3 Choose a Despeckle mo

- Median reduces pix
each pixel with the m
the sample square. I
erage, but may remo
to keep. This metho
age. 

- Average blurs diffe
placing each pixel w
pixels in the sampli
flaws with the backg
ing them altogether.

4 To apply the Effect, cli

TIP

The smaller the radius an
despeckling process.
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3.6. Emboss Effect

Use the Emboss Effect to produce a “raised” or “re-
lief” effect for an image. The embossed image can be
a neutral gray or tinted. The raised effect can be
made subtle or strong.

1 Choose Effects → Emboss. The Emboss Effect
dialog appears.

The Emboss Effect dialog

2 Select a type of embossing:

- Grey makes the image a neutral gray.

- Colored replaces the neutral gray with any
color you select.

3 If you select Colored, click the ColorLink button
to link to the Color Editor and select a color.

4 To change the offset, ty
text boxes to set the ho
and height (in pixels) 
greater these values, t
see in the image.

You can increase the “
the offset values. An o
embossed look. An of
embossed look.

5 To apply the Emboss 
Emboss. 

TIP

To create unusual effects
set X and Offset Y values
ferent values.



3. Adding Effects 3.7. Gaussian Blur Effect
3–10

3.7. Gaussian Blur Effect

Use the Gaussian Blur Effect to make an image ap-
pear out of focus. “Gaussian” refers to a bell-shaped
curve of color values in affected pixels.

To blur an image
1 Choose Effects → Gaussian Blur. 

The Gaussian Blur Effect dialog appears.

The Gaussian Blur Effect dialog

2 To adjust the intensity of the Effect, use the slider
or type in a value in the text box. 

3 To apply the Effect to the image, click Blur.

REMARK

The blurring process is memory intensive. If you
are blurring a large image, increase the cache size
as much as possible. (For information on deter-
mining the maximum cache size, see “Cache Size”
on page 9-7). If you run out of RAM while blurring,
lines appear in the image.
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3.8. Monochrome Effect 

Use the Monochrome Effect to produce graytone
images. A CMYK image becomes a 4-color graytone
image, while an RGB image becomes a 3-color gray-
tone image.

1 Choose Effects → Monochrome.

Eclipse previews your image as monochrome and
displays the Monochrome Effect dialog.

The Monochrome Effect dialog

2 To adjust the intensity of the Effect, use the slider
or type in a value in the text box.

A maximum Monochrome value of 100 or 255
(depending on the color range preference you se-
lect in the General Preferences) converts a color
image to black and white. Lesser values make a
partial change to monochrome, which can pro-
duce interesting effects.

3 To apply the Effect to
chrome.
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3.9. Monochrome and Invert Effect

Use the Monochrome and Invert Effect to convert a
color image to a graytone negative. A maximum Ef-
fect value of 100 or 255 (depending on the color
range mode you select in the General Preferences)
converts a color image to a monochrome negative.
Lesser values produce a partial color negative of the
image.

1 Choose Effects → Monochrome & Invert.

Eclipse previews your image as monochrome
negative and displays the Monochrome and In-
vert Effect dialog.

The Monochrome and Invert Effect dialog

2 To adjust the intensity of the Effect, use the slider
or type in a value in the text box.

3 To apply the Effect to the image, click Mono-
chrome.
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3.10. Noise Effect

The Noise Effect introduces random black and
white pixels in an image, creating a grainy or mez-
zotint-like effect. Adding Noise does not affect the
overall lightness or darkness of an image.

To add noise to an image
1 Choose Effects → Add Noise.

Eclipse previews the image with noise and dis-
plays the Noise Effect dialog.

The Noise Effect dialog

2 Adjust the amount of noise that is added using
the slider or text box. 

While the maximum value of the slider is 255,
you can type in a value as high as 999 in the text
box.

3 To apply the noise to the image, click Noise.

Tips

TIPS

You can add noise to a b
dialog, as described i
page 4-5. If Quick Dry 
noise on top of itself to m
pronounced.

To add colored noise, ap
color channel. 
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3.11. Pixelize Effect

Pixelize averages a block of pixels to produce a low-
resolution or “fat bits” effect, as if the image was
made up of fewer but much larger pixels. Low Pixel-
ize values produce a blurred or computerized effect.
Higher values produce a mosaic effect of progres-
sively larger squares.

To use the Pixelize Effect
1 Choose Effects → Pixelize. The Pixelize Effect

dialog appears.

The Pixelize Effect dialog

2 To adjust the size of the pixel blocks, use the slid-
er or type a value in the text box.

3 To apply the Effect to the image, click the Pixel-
ize button.
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3.12. Posterize Effect

Posterize creates a “paint by numbers” effect by re-
ducing the number of colors used in an image. It’s
useful at low levels for creating a cartoon-like effect,
something that looks like one of Andy Warhol’s
Marilyn Monroe silk screens. A high Posterize level
is useful for things like T-shirt films.

To use the Posterize Effect
1 Choose Effects → Posterize. Eclipse previews

the image posterized and displays the Posterize
Effect dialog.

The Posterize Effect dialog

2 To adjust the intensity of the Effect, use the slider
or type in a value in the text box.

3 To apply the Effect to the image, click Posterize.
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3.13. Sharpen Effect 

The Sharpen Effect recognizes edges or areas of
contrasting pixels and increases the difference be-
tween them to create a sharper image. Use it to im-
prove the quality of a blurry image. 

Eclipse’s Sharpen Effect is a clean effect with no
false colors. It can also produce an intriguing effect
if you use it on top of itself at high levels—try it with
a brush.

To sharpen an image
1 Choose Effects → Sharpen. The Sharpen Ef-

fect dialog appears.

The Sharpen Effect dialog

2 Adjust the degree of sharpening using the slider
or text box.

3 To apply the Effect to the image, click Sharpen.

REMARK

Sharpening adds noise t
plications of sharpening 
apply Sharpening rep
brush, the image event
white.

TIP

For a similar but less d
sharp Masking Effect d
Effect” on page 3-18.
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3.14. Soften Effect

Soften produces a mild blurry effect similar to that
produced with low levels of Gaussian Blur. The ad-
vantage of using Soften is that it gives you more
control over degrees of soft blurring—it has 255 val-
ues, whereas Gaussian Blur reaches the same blur-
riness at values of 2 or 3. 

To soften an image
1 Choose Effects → Soften.

Eclipse displays the Soften Effect dialog.

The Soften Effect dialog

2 To adjust the degree of softening, drag the slider
or type a value in the text box.

3 To apply the Effect to the image, click Soften.

Tip

TIP

To smooth edges, appl
brush. Alternatively, s
around a ShapeLayer. T
and then close the Soften
lect a ShapeLayer, choo
click Stroke in the Sha
Eclipse brushes the Soft
outside the ShapeLayer o
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3.15. Unsharp Mask Effect

Like Sharpen, Unsharp Mask increases contrast
along edges, creating a crisp image. It is most useful
on a good quality image that needs minor sharpen-
ing, whereas the Sharpen Effect gives stronger re-
sults more appropriate for a poor quality image. 

REMARK

The Unsharp Mask Effect is analogous to the
sharpening method used by traditional drum scan-
ners which identified sharp transitions in complex
images by scanning with both focused and unfo-
cused lenses.

1 Choose Effects → Unsharp Mask. The Un-
sharp Mask Effect dialog appears.

The Unsharp Mask Effect dialog

2 To adjust the range influenced by the Effect, use
the Radius slider or type a value in the text box.

3 To adjust the sharpnes
Threshold slider or typ

4 To adjust the intensity
slider or type in a valu

5 To apply the Effect to t

TIP

As with Sharpening, ap
Masking creates noise th
age.
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3.16.  HSL Replace Color Effect

The HSL Replace Color Effect is only avail-
able for RGB images!

Use the HSL Replace Color Effect to adjust the hue,
saturation and lightness of an RGB image. HSL Re-
place Color Effect is different from other Eclipse
hue correction tools because you can also adjust sat-
uration and lightness.

The HSL Replace Color Effect dialog has controls
that you use to choose the values you want to
change (the From values) and to specify how you
want to change them (the To values). You can pick
colors from an image to select From and To values. 

To use the HSL Replace Color Effect
1 Choose Effect → HSL Replace Color. The

HSL Replace Color Effect dialog appears.

To open an existing correction file, click Load.

2 To pick a color from your image to work on, click
the top ColorLink button. This links the HSL Re-
place Color dialog to the HSL From Color Editor.

3 Click the Pick button in the HSL From Color Ed-
itor, then click the image to pick the color to
change.

The upper color swatch displays the color you
picked.

The HSL Replace Color E

4 Select a type of Hue S

- Absolute changes 
color.

- Relative maintains
age.

5 Change the HSL prop
dragging the Hue, Sa
popup sliders or by typ
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es. Alternatively, you can use the HSL To Color
Editor.

The lower color swatch reflects the color changes
as you make them.

TIP

To start over, click Reset. Eclipse resets the color
swatch, sliders and text boxes to their original val-
ues.

To set the To color to the From color, click
Match Ranges.

To save your settings, click Save.

6 To apply the changes to the image, click Re-
place.

TIPS

The HSL Replace Color Effect is useful for food
photography and other instances where highly
saturated images are desirable. It does not work
well on facial tones.

Increasing saturation works well for midtones but
not for highlights and shadows.
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4.1. Painting Basics

Eclipse includes a sophisticated set of brushes for
painting, retouching, cloning images, creating and
editing masks, rendering images, restoring parts of
an image and applying special effects and color cor-
rections. You can paint on the whole image or on in-
dividual channels.

Selecting a Brush
1 Select the Brush tool from the ShapeLayer Tool-

box. 

2 Select a brush from either the Brush shelf or the
Brush Palette.

- Brush Shelf: Use the Brush Shelf to choose
a brush type such as Color, Clone, or Restore
and to specify brush attributes such as color,
profile, size and transparency. To open it,
choose Window → Brush Shelf.

The Brush shelf opens automatically when you
start Eclipse.

- Brush Palette: Use the Brush Palette to
store brushes you create. You can store a set of
brushes as a Palette file and open it later to re-

use them. To open
Brush Palette.

Brush shelf (rollouts in) 

Painting and unpain
• Drag to paint on the ca

• Paint can be unpainted
is akin to erasing or re
plied via the brush.
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• Unless Quick Dry is checked in the Brush shelf,
paint remains wet until you change the brush col-
or or transparency, switch to a different kind of
brush or switch to a different tool. If Quick Dry
is checked, paint dries after each stroke, allowing
you to build up layers.

• To unpaint “wet” paint, press the middle mouse
button and drag.

• If you want to dry wet paint, click Dry Paint in
the Brush shelf. This makes permanent every-
thing you applied before.

• To constrain brush strokes in either vertical or
horizontal direction, press the appropriate arrow
key.

• When you have finished painting, select the
brush icon in the ShapeLayer Toolbox to clear it
or select another tool from the ShapeLayer Tool-
box.
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uts out)
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4.2. Creating a Brush

Using the Brush shelf
Use the Brush shelf to choose the brush action you
want to use and the options and profile for the
brush. 

To use the Brush shelf to create a brush
1 If the Brush shelf is not open, choose Window

→ Brush Shelf.

The Brush shelf (all rollo
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e, see “Using the Brush
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ute specifies a maximum
s maximum value is 1024.
cify the resolution for the
u type a Size value higher
e, Eclipse inserts the Max.

Size text box.

blet installed, the Stylus
ecify the Brush size when

the stylus. You can control
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 same value in both text
endent of stylus pressure. 

e is active only if Profile is
ush resembles an airbrush
controls the ratio of air to
irbrush density is specified
value gives the brush more
es the brush less paint and
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2 Choose a brush type from the Brush type drop-
down menu at the top of the Brush shelf. The
menu contains ten brush types:

Brush name shows the name of the selected
brush.

The Brush preview below the name gives you an
impression of what your brush looks like.

3 Customize the brush by specifying its attributes
in the Brush shelf, as described next. 

Brush attributes
• Options: Click to display any available options

for a brush. These brushes have options: Color,
Clone, Correct, Effects, AutoMask, Pattern and
Glow. For information on options for these

brushes, see “Brush Ty
page 4-12.

• Palette: Click to disp
can also display the P
dow → Brush Palet
ing the Brush Palett
Palette” on page 4-9.

• Size: this attribute sp
rent brush.

The Max. Size attrib
size for all brushes. It
This way, you can spe
Size popup slider. If yo
than the Max. Size valu
Size value in the Max. 

REMARK

If you have a Wacom ta
Min. text box lets you sp
no pressure is applied to 
the Brush size by applyin
the tablet. If you set the
boxes, Brush size is indep

• Density: this attribut
On. In this case, the Br
(see below). Density 
paint for airbrushes. A
in percentages. A high 
paint; a lower value giv
more air. 
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REMARK

If you have installed a Wacom tablet, the Stylus
Min. text box lets you specify the Density when no
pressure is applied to the stylus. This is because
you can change the density by applying more or
less pressure on the tablet. You can control the
Density by applying more or less pressure on the
tablet. If you set the same value in both text boxes,
Density is independent of stylus pressure. 

• Transparency: this attribute sets the transpar-
ency level for the brush. At a transparency setting
of 100%, paint is completely clear. At 0%, paint is
completely opaque. 

REMARK

If you set Transparency to 100% and then paint,
you will not see any paint on your image.

• Shape: Here you can specify the shape, angle
and aspect ratio of the brush tip as well as add
anti-aliasing.

The Shape preview represents the current brush
shape. You can adjust the brush shape by clicking
on the graph and dragging or by setting values in
the Aspect and Angle text boxes.

Use the Aspect slider and text box to change the
shape of the brush. 

If you choose a round brush and set the Aspect
to 100, the brush is circular. As you decrease the
Aspect value, the brush becomes elliptical.

If you choose a square
to 100, the brush is sq
Aspect value, the brush

Use Angle to change 
Angle values can range

Click the round icon t
Click the square icon to

Select Anti-alias if yo
Anti-alias value you se
ences dialog box or th
alias command. It is u
brush.

For more information
page 9-4.

TIP

Turn Anti-aliasing on o
slows down brush perfor

To return to the origin
set. Eclipse restores th
nal settings.

• Profile: To use an a
brush, set Profile to 
combination of paint
mask. If you choose an
air-to-paint ratio with 

Eclipse’s airbrush giv
than a standard airbru
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- You can draw a Brush profile dragging the five
points in the profile graph. Whichever way you
drag, the brush profile will always be symmet-
rical.

-  You can use one of four preset profiles by click-
ing its respective buttons.

To return to the original brush profile, click Re-
set. Eclipse restores the Brush Profile values to
their original settings.

• Noise: Adding Noise to a brush introduces ran-
dom variations into brush strokes, creating a
charcoal-like effect. 

Adding Noise also removes ringing or banding
in strokes made with an airbrush with a gap.

• Spacing: check Spacing if you want Eclipse to
plot the position of the brush cursor and link
paint drops to create a continuous stroke. 

With Spacing checked you can paint quickly and
the brush will follow, although not always in real
time. If you paint quickly when Spacing is
checked, you may see skipping between paint
drops.

The Spacing attribute is computationally inten-
sive. If you are painting with short strokes, do not
select it. 

Gap represents the amount of space between
paint drops as a percentage of the brush size. The

default gap is 3o%, w
stamp or “drop of pa
spaced at a distance e
size. This should give 
the Gap value, the less
“smoother” the brush 
brush. 

REMARK

Spacing must be on for G

TIP

Giving an airbrush a hig
or banding in the strok
Profile and add Noise to

• Wet Paint: check Qu
to build up with each
strokes of semi-tran
build up to 100 percen

REMARK

When Quick Dry is check
your most recent stroke 
and released the left mou
even if you have not c
transparency, or type. 

When Quick Dry is unch
your strokes unless you
color, transparency or ty
unpaint only the most re
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Click Dry Paint to apply your brush strokes to
the canvas image. Once paint is dry, it cannot be
unpainted with the middle mouse button. 

WARNING

Paint dries automatically each time you change
brush type, color or transparency.

TIPS

If you want to remove dried paint, use the Restore
brush. It restores the image to its state when you
last saved or retained it.
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4.3. Storing Brushes on the Brush Pal-
ette

Store brushes you have created in the Brush Palette
so that you can reuse them and get at them quickly.
You can save a Brush Palette as a file for future use. 

The Brush Palette is like a storage shelf where you
keep brushes you use often. You can: 

• add brushes to a Palette

• delete brushes from a Palette

• rename brushes in a Palette

• save a Palette and reuse it later

• create as many Palette files as you want.

Default Palettes
Eclipse includes two default Palettes, def-
brush.pall and glows.pall, which are stored in
the C:\Program files\Eclipse\util\custom
directory. 

• The defbrush.pall Palette is a sampling of dif-
ferent brush types and options. It is the default
Palette. 

• The glows.pall Palette is a set of Glow brushes
that show some of the different effects you can
achieve with the brush.

When you select a brush
becomes the current bru
and Eclipse displays its 
Brush shelf. It remains t
select a different brush 
the Brush shelf.

Using the Brush Pale
1 Choose Window →=

Palette in the Brush s

The Brush Palette app
default brush Palette o
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The Brush Palette

2 To select a brush, click it.

Eclipse displays its name and attributes in the
Brush shelf. You can change the attributes or im-
mediately use it to paint.

3 To open a different Palette file, click Open.

Eclipse displays an Open file dialog.

4 Select a Palette name a

The brushes in the P
Brush Palette. 

5 To retrieve the defaul
Eclipse, click Reset.

Creating your own B
To add the current 
1 Point to a brush icon i

2 Press the Shift key an
ton.

Eclipse inserts the cur
Palette at the point you
main in the Palette. 

To delete a brush fr
1 Point to its icon and cl

ton. 

Eclipse displays a warn
sure you want to delet

2 Click Yes to delete the

To change the name
ette
1 Click in the text box 

want to change.

2 Type in a new name.
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To save the Palette file
1 Click Save.

2 Type in a name in the text box or select an exist-
ing name from the scrolling list.

3  Click OK.

A Brush Palette file is given a .pall filename ex-
tension.
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4.4. Brush Types and Their Options

Selecting a Brush type
You can choose one of 10 different brush types from
the Brush type dropdown menu located at the top of
the Brush shelf (see page 4-5). 

TIP

By varying brush attributes such as transparency,
gap, and density, you can achieve subtle and inter-
esting effects. For example, using a partially trans-
parent Render brush allows you to render a
“ghostly” ShapeLayer fill.

Accessing Brush options
The Color, Clone, Correct, Effects, AutoMask and
Glow brushes have options. The Restore, Render,
Smear and Pattern brushes have no options.

To set Brush Options
Click Options in the Brush shelf.

The following sections describe the brush types and
their options.

Brushing on paint with the Color Brush
Use the Color brush to apply the current paint color
to the image canvas or the mask color to the mask
layer.

For a Color brush, click Options to open the Brush
Color Editor to change the paint color. For direc-
tions, see “Selecting colors in the Color Editor” on
page 1-25.

Restoring selectively
Brush

Use the Restore brush t
vas image to its state the
tained it. Restoring wit
restore specific parts of a
store command in the Fil
image.

This image has been em
restored with a semi-tr
Transparency was set at 6

TIP

The Restore brush is mo
ing with the middle mou
restore anything you ha
you last saved or retain
lows you to remove wet 

You can restore a percen
a semi-transparent Res
you could colorize an im
50 percent.
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There are no options for the Restore brush.

Rendering a ShapeLayer Fill with the 
Render Brush

Use the Render brush to render ShapeLayer fill ele-
ments to the canvas image. 

While the Render button in the ShapeLayer Tool-
box renders the entire fill of a ShapeLayer to the
canvas, with the Render brush you can render spe-
cific parts of the ShapeLayer fill. You can also get in-
teresting effects by adjusting Brush transparency
and (airbrush) density when you render.

REMARK

When you select the Brush tool from the Shape-
Layer Toolbox, all fill elements in ShapeLayers dis-
appear and only the outlines remain visible. (If you
close the ShapeLayer Toolbox, the outlines also dis-
appear.) ShapeLayers or their fills do not have to
be visible for you to render them, although it is eas-
ier to know where they are. 

To render a ShapeLayer fill to the canvas
Brush over the ShapeLayer with the Render brush. 

The fill elements appear as you render them.

This ball is being rendere
floor with a Render brush
The rough edges can be re
the middle mouse button
be erased with the brush.

You can use the middle m
or unpaint with the Rend

There are no options for 

Copying part of an im
Brush

Use the Clone brush to pa
age. Cloning is particular
and other defects with a
part of the image. (Othe
touching are the Despec
Removal tool.)
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You can clone part of the current canvas image or, if
you are running two copies of Eclipse, you can clone
between two canvas images. When you clone,
Eclipse displays two brush cursors connected by a
straight line; one is the source brush, and the other
is the destination brush.

Cloning within an image
1 Select the Clone brush. 

You can select it from the Brush type menu in
the Brush shelf, from the default Brush Palette or
simply press F.

2 If necessary, adjust the brush size and other at-
tributes using the Brush shelf.

3 Click the area of the image that you want to clone
from. This is the source.

As soon as you move the mouse after clicking,
Eclipse displays a source brush cursor and a des-
tination brush cursor. The two cursors are con-
nected by a straight line that “rubber bands” as
you move the destination brush.

4 Move to the area you want to clone to, and click
to set the distance between source and clone.

5  Drag to paint the image.

As you drag, the two brushes move in parallel—
the source brush is not anchored at its original
point.

6 To clone from a differe
on the image and conti
click F to reset the clon

The right part of the imag
left part using the Clone 

Set the Clone Brush
When you click Options
dialog appears.



4. Using Brushes 4.4. Brush Types and Their Options

to place the source or des-
 Brush Options dialog dis-
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The Clone Brush Options shelf

1 To set the x and y coordinates for source or desti-
nation, click one of the Pick buttons or type val-
ues in the appropriate text boxes and press Enter.

The From text boxes show the x and y coordi-
nates of the source brush. The To text boxes
show the x and y coordinates of the destination
brush. 

2 To turn feedback on or off, click Feedback.
When Feedback is selected, the Clone brush is
able to clone paint you have just cloned. When
Feedback is not selected, the Clone brush cannot
read its own data. 

3 To change coordinates, click in a text box, type in
a value and press Enter.

TIPS

If you click on an image 
tination brush, the Clone
plays the coordinates. 
establish the initial brush
can then use the dialog 
cisely.

If cloning is creating t
Feedback off.

Brushing on a Correc
rect Brush

Use a Correct brush to 
tion to an image. For ex
trast in portions of an 
correction to set the amo
Then use the brush to co
image.

To use the Correct B
1 Choose a Correction fr

2 Set up the Correction i
do not apply it.

3 Close the Correction 
leave it open so you ca
rection settings, turn o

4 Select the Correct bru
menu in the Brush she

5 Brush on the Correctio
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WARNING

If you do not open a Correction dialog, Eclipse ap-
plies the last correction you used to the areas you
paint.

When you click Options, Eclipse opens the last
Correction dialog you used.

Brushing on an Effect with the Effects 
Brush

To brush on an Effect, select an Effects brush from
the Brush type menu or press X.

You can open an Effects dialog, set up the Effect,
and then apply it through the Brush. If you do not
open an Effects dialog, Eclipse applies the last Ef-
fect you used to the areas you paint.

To use the Effects Brush
1 Choose an Effect from the Effects menu.

2 Set up the Effect in the Effect dialog, but do not
apply it.

3 Close the Effect dialog. Or, if you want to leave it
open so you can quickly modify the correction
settings, turn off Preview.

4 Select the Effect brush from the Brush type
menu in the Brush shelf, or press X.

5 Brush on the Effect.

When you select Options, Eclipse opens the last
Effects dialog you used.

Brushing on a mask w
Brush

Use the AutoMask Bru
mask layer that fall withi
most recent settings in t
Mask or Mask Channel T

WARNING

Be sure to select the Act
icons in the dashboard 
Mask Brush. 

REMARK

If you want to leave the
you work, turn off Previe

When you select Option
mask tool dialog you use
Auto Mask, or Mask Cha

For more information, se
Brush” on page 8-11.

Smearing with a Sme
Use the Smear Brush to 
mask color. Smearing is l
of whatever is under the
around on the image.

For a soft blurry smear u
For a stop-motion effect 
fore smearing.

There are no Options fo
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 produce realistic special
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tional photography. Al-
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 Brushes
tte and then click Open
all file. It is stored in the
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e contains seven different

 clicking its icon.
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Brushing on patterns with the Pattern 
Brush

Select the Pattern Brush to copy a portion of the
image and then “rubber stamp” it onto other areas
of the canvas image. The copied portion, or pattern,
has the same size and shape as the brush. 

To use the Pattern Brush
1 Select the Pattern Brush from the Brush shelf

and then select any attributes you want from the
Brush shelf.

2 Choose a pattern to paint by clicking the image.
The Pattern brush copies whatever is under the
brush.

3 Move the brush to where you want to rubber
stamp the pattern, and click.

Eclipse puts a single copy of the pattern at the
point you click.

4 To apply multiple copies as a brush stroke, drag
over the image. The copies will look smeared.

This pattern was created from the graphic on the
left with an airbrush with the gap set at 30.

Here the gap was increa
was applied with a solid b

There are no specific Opt
but you have to click Opt

Adding sparkle with
Use the Glow Brush to
lighting effects like star 
see typically in conven
though you can paint wit
click to place a glow poin
dragging to make a paint

Samples of Glow Brushes
file called glows.pall. 

To see sample Glow
1 Open the Brush Pale

and select the glows.p
C:\Program files\Ec
rectory.

The Glow brush Palett
glow brushes. 

2 Select a Glow brush by
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3 Click on the image to paint on a glow point or star
burst. Or drag to produce a streak of glows.

Here are some samples of glow-brush effects.

No glow (left) and cosmic glow

Daisy glow (left) and prism glow

The effect of the Glow Brush depends on the set-
tings in the Glow Brush shelf. 

Glow Brushes are not as fast as other brushes as
they are produced using a complex algorithm,.

4 Click Options in the 
options. The settings i
low you to customize t

When you click Options
merous options you can u
might want to start with
glows.pall Palette and t
from there. As you chang
Eclipse updates the samp
tor so you can see its effe
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 Editor and lets you define

ensity of the brush glow.

d of brush glow. Spread is
ity is high.

rency.

w centre left or right.

w centre up or down.

 and varies intensity.

number of rays extending
ive only if Star is greater

h.

ints asymmetrical.

frequency of random star
 Random value is greater

 radial stars.

 Shatter effect (active only
 greater than 0).
4–19

The Glow Brush shelf

Glow type menu: Choose glow type: No Glow,
Linear (linear glow), Nova (exponential glow), Orb
(round ball glow), Prism (colored glow with no cen-
tre), Spectrum (colored glow with centre).

Color: links to the Color
the color of the glow.

Intensity: Varies the int

Spread: Varies the sprea
exaggerated when Intens

Strength: Adds transpa

Centre X: Moves the glo

Centre Y: Moves the glo

Star: Creates star points

Flares: Determines the 
from the star point (act
than 0).

Rotate: Rotates the brus

Random: Makes star po

Fracture: Determines 
points (active only when
than 0).

Shatter: Creates random

Smatter: Intensifies the
when the Shatter value is



4. Using Brushes 4.4. Brush Types and Their Options
4–20

Pinch: Pinches centre of shattered brush horizon-
tally or vertically (active only when Shatter value is
greater than 0).

Halo Type menu: Choose halo type: None, Lin-
ear, Nova, Orb, Rim. Adds an halo effect to the cen-
tre or rim of the brush.

Halo amount: Determines the number of star
points.

Spread: Spreads the Halo effect from the centre.
Spread is more pronounced when Halo amount is
high.
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 want to use to apply the
 Brush shelf or the Brush

 to create a ShapeLayer. In
, the Bezier tool was used.

apeLayer Toolbox. 

 around the ShapeLayer.
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4.5. Stroking along a ShapeLayer

You can apply the current brush stroke around the
perimeter of a ShapeLayer by using the Stroke op-
tion in the ShapeLayer Toolbox.

In this illustration, a Glow brush has been stroked
on around a ShapeLayer.

Here, a Correct brush has been stroked around the
same ShapeLayer to apply a shadow correction, and
then the ShapeLayer outline was deleted.

To apply a Brush stroke around the pe-
rimeter of a ShapeLayer
1 Select the Brush tool from the ShapeLayer Tool-

box.

2 Specify the Brush you
stroke using either the
Palette.

3 Use a ShapeLayer tool
the illustrations above

4 Click Stroke in the Sh

The brush stroke appears
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5.1. ShapeLayer Basics

What are ShapeLayers?
ShapeLayers are vector objects that you can fill with
images, color, vignettes and masks. Unlike raster or
bitmap data, which are based on fixed pixel values,
vector data can be easily resized and manipulated
without any resolution or location constraints. 

A ShapeLayer consists of its outline and its fill:

• The ShapeLayer outline is resolution-indepen-
dent vector data.

• The ShapeLayer fill is a representation of an ac-
tual image. It retains its original resolution until
you render it onto the canvas. Then it acquires
the canvas resolution.

A ShapeLayer appears above the canvas image on
the ShapeLayers overlay. 

The benefits of ShapeLayers
• ShapeLayers are the core of Eclipse — they give

you the means to open, edit, warp and compose
multiple images interactively and simultaneous-
ly. But ShapeLayers are more than just a way to
work with multiple images; they are also the tools
you use for a variety of retouching, composition
and special effects jobs. You use ShapeLayers to:

• create image composites,

• add color, vignettes or transparency to certain ar-
eas of the image,

• manipulate images by 
and adding perspectiv

• create special effects s
shading, luminance c
moval and warp shadi

• limit effects and corre
the canvas image,

• create and edit masks,

•  define a path along w
(see “Stroking alon
page 4-21).

Creating ShapeLayer
You create ShapeLayers 
the canvas image using t
Toolbox. You can create:

• ellipses and circles,

• squares and rectangles

• Bezier curves as well 
curves. You can close a
ing Close in the Shape

• text: Eclipse supports
and you can fill and m
way as other ShapeLay
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ward or backward within
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l is rendered, Eclipse pro-
nd redo capabilities with
 not have to worry about
ou are working. You can

s or repeat them.

e Warping
ful, object-based extension
ology for warping Shape-
ettes. Using filled Shape-
d warp multiple images

 also warp the canvas im-

e “Warping ShapeLayers”

hapeLayers
is for shadow casting, 3D
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nformation on these tech-
ts Using ShapeLayers” on
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Filling a ShapeLayer
Fill a ShapeLayer with one or more of these ele-
ments:

• Image: Use any image file type Eclipse supports.
The image’s resolution and quality are main-
tained, even after complex edits.

• Color: Fill a ShapeLayer with either solid color
or a color vignette. 

• Mask: A ShapeLayer drawn on the mask layer
automatically fills with mask color. You can also
use a saved mask file.

• Transparency: You can add transparency to
any ShapeLayer fill and also fill a ShapeLayer
with a transparency vignette.

• Operation: You can limit a correction or an ef-
fect to a ShapeLayer.

Editing and manipulating ShapeLayers
You can edit and manipulate ShapeLayers, even
once you have filled them. The ShapeLayer and its
fill can be edited together or separately. If you fill a
ShapeLayer with an image, you can edit the Shape-
Layer without affecting the image, edit the image
without affecting the ShapeLayer, or edit both the
ShapeLayer and image simultaneously. 

 You can:

• move, scale, and redefine ShapeLayers and their
fills,

• rotate, warp, skew and
their fills,

• cut, copy, paste and de
fills,

• group, combine and al

• move ShapeLayers for
the ShapeLayer overla

REMARK

Until the ShapeLayer fil
vides unlimited undo a
ShapeLayers, so you do
making mistakes while y
always cancel of change

ShapeLayer and imag
Eclipse provides a power
of its ShapeLayers techn
Layers, images and vign
Layers, you can see an
simultaneously. You can
age. 

For more information, se
on page 7-19.

Special Effects with S
ShapeLayers are the bas
shading, luminance comp
and warp shading. For i
niques, see “Special Effec
page 7-1.
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Rendering ShapeLayers
ShapeLayers and their fill elements are on an over-
lay that “floats” above the canvas image. They do
not affect the canvas or become part of it until you
render the ShapeLayers to the canvas. When you
render a ShapeLayer, the ShapeLayer fill acquires
the resolution of the canvas image. After rendering
a ShapeLayer you can not undo the ShapeLayer op-
erations you applied before.

REMARK

The Render Mode setting in the ShapeLayer
menu determines whether all ShapeLayers or se-
lected ShapeLayers only are rendered onto the
canvas image.

Saving and reusing ShapeLayers
You can save, open and reuse ShapeLayers. When
you use the File → Save As command to save the
ShapeLayers overlay, Eclipse creates a file with a
.shp filename extension. 

Importing ShapeLayers
You can import Adobe Illustrator vector data as
Eclipse ShapeLayers files. For more information,
see “Opening foreign vector data files as Shape-
Layer files” on page 11-3.
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5.2. The ShapeLayer Toolbox When you open an imag
Eclipse also opens the Sh
ate a ShapeLayer, select a
ShapeLayer on the Shape

Pointer tool: Use the P
edit a ShapeLayer and its

Hand tool: Use the Ha
Layer or to edit the Shap

Rectangle tool: Drag t
Shift while dragging to cr

Ellipse tool: Drag to d
while dragging to create a

Polygon tool: Click to
polygon.

Curve tool: Click to lay d
curve.

Bezier tool: Clicking c
Dragging creates a curve

Text tool: Create and ed
same way as other Shape

Skew tool: Skew a Shap

Rotate tool: Rotate sel
their fills.

Distort: Add perspective

Pointer

Rectangle

Polygon

Bezier

Skew

Distort

Blemish Removal

3D Shading

Hand

Ellipse

Curve

Text

Rotate

Brush

Shadow Caster

Warping

Luminance Comp.

Cutout Cropout

Stroke Render

Reset Warp Grid

Warp Options
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Brush tool: Activate the current brush and sus-
pend ShapeLayer creation. ShapeLayer fills are hid-
den.

Cutout: Put a duplicate of the last saved canvas im-
age into the selected ShapeLayer.

Cropout: Copy that part of the canvas image that is
visible into the selected ShapeLayer and save it as a
file.

Stroke: Run the current brush around the outline
of a selected ShapeLayer.

Render: Apply ShapeLayer fills to the canvas.
Render Mode, avaible from the ShapeLayer
menu, determines whether all ShapeLayers or se-
lected ShapeLayers are rendered ( see page 5-7).

Lock: Affects the way overlapping ShapeLayers are
combined.

Close: Closes or opens the selected Bezier curve, B-
spline curve or polygon.

Blemish Removal: Remove flaws within a Shape-
Layer without degrading the image.

Shadow Casting: Add shadows to areas of the
canvas image surrounded by a ShapeLayer.

3D Shading: Add a 3D look to a canvas image area
surrounded by a ShapeLayer.

Luminance Composi
nance of the canvas imag

Warp tool: Warp a Shap

Warp Reset: Return a w
fill to their original state.

Warp Options: Acces
Shading and the warping
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5.3. Viewing ShapeLayers

ShapeLayers are visible only when the ShapeLayer
Toolbox is open. If you draw ShapeLayers and then
close the ShapeLayer Toolbox, the ShapeLayers dis-
appear. When you reopen the ShapeLayer Toolbox,
the ShapeLayers reappear.

The way Eclipse displays ShapeLayer fills depends
on two settings: the ShapeLayer → Render
Mode setting and the View → ShapeLayers set-
ting.

When you choose ShapeLayer → Render Mode,
a submenu appears.

All ShapeLayers: Fil
ShapeLayers, whether or

Selected ShapeLayer
ShapeLayers are displaye

TIP

To toggle between the tw

REMARK

The Render Mode setting
affects whether renderin
or only selected ShapeLa

When you choose View
submenu appears.

Outline: Displays only 
Layer; any image or mas
not appear.



5. Working with ShapeLayers 5.3. Viewing ShapeLayers
5–8

Proxy: Displays proxies of the image and mask.
Use this view for optimal performance when you are
working with images in ShapeLayers.

Image: Displays the full image and mask within a
ShapeLayer. Use this view for high-quality display
of images in ShapeLayers.

Hiding the ShapeLayer overlay
You can hide ShapeLayers by pressing Ctrl H.
ShapeLayer fills remain visible even when the
ShapeLayers overlay is hidden.

Changing the color of the ShapeLayer 
overlay
By pressing  AltGr C  you can cycle through a series
of colors for the ShapeLayers overlay. Pick a color
that is visible against the canvas image.
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5.4. Creating ShapeLayers

Creating a rectangle or square
Use the Rectangle tool to create rectangles or
squares. You can move and size a rectangle after you
create it, but you cannot add points to or delete
points from a rectangle.

Creating or editing a rectangle
1 Select the Rectangle tool from the ShapeLayer

Toolbox.

Rectangle tool selected in the Toolbox

2 Point to where you want one corner, and drag.

To create a square, press Shift while dragging.

3 Release the mouse button. The rectangle remains
selected so you can edit it. To do so, select the
Pointer tool in the ShapeLayer Toolbox.

A rectangle with its edit p

4 To change a rectangle
edit point on one of its

5 To change both width
edit point.

To maintain the aspe
dragging.
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r circle
cle is much like creating a
own in the preceding sec-

 or circle
l in the ShapeLayer Tool-

e Toolbox

t to place one point on the
ate a circle, press the Shift

cle is the right size, release

 create an open or closed

ol in the ShapeLayer Tool-
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6 To move a rectangle or square, point inside it and
drag.

Creating an ellipse o
Creating an ellipse or cir
rectangle or square, as sh
tion.

To create an ellipse
1 Select the Ellipse too

box.

Ellipse tool selected in th

2 Point to where you wan
ellipse and drag. To cre
key as you drag.

3 When the ellipse or cir
the mouse button.

Creating a polygon
Use the Polygon tool to
polygon.

To create a polygon
1 Select the Polygon to

box.



5. Working with ShapeLayers 5.4. Creating ShapeLayers

 Toolbox
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 are joined by a curved line

lace a new edit point and
 drag a point from the pre-
ore it curves.

e or corner, place points

t points, click Close in the
To open a closed Shape-

, select the Pointer tool

olygon or Bi-spline 

ove points belonging to a
e while you are creating it
.
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Polygon tool selected in the Toolbox

2 Click on the canvas to place edit points at the cor-
ners of the polygon. Adjacent edit points are
joined by a line segment.

3 To connect the first and last edit points, select
Close in the ShapeLayer Toolbox. To open a
closed polygon, deselect Close.

To stop adding points, select the Pointer tool or
press V.

Creating a Bi-spline curve
Use the Curve tool to create an open or closed Bi-
spline curve. 

Bi-spline curves are not as versatile as Bezier curves
since you cannot directly control the curvature at
each edit point. Instead, the curvature of a segment
is controlled by the next point.

To create a Bi-spline curve
1 Select the Curve tool in the ShapeLayer Tool-

box.

Curve tool selected in the

2 Click on the canvas to 
curve. Two edit points
segment.

3 To adjust the curve, p
drag it. The further you
ceding segment, the m

TIP

To create a straight lin
close together.

4 To join the first and las
ShapeLayer Toolbox. 
Layer, deselect Close.

5 When you are finished
or press V.

Editing points in a p
curve

You can add, delete and m
polygon or B-spline curv
or once you have finished
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atile, all-purpose tool you
straight and curved seg-
 familiar with it, you may
 Curve tools anymore.

urve
ol from the ShapeLayer

e Toolbox

place the first edit point. 

ment, click to place a sec-

ght line between the two

ent, drag as you place the

the mouse button, Eclipse
oint and draws a straight
nd the last point. As you
he segment to a curve and
ttached to the edit point. 
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Selecting a polygon ShapeLayer and dis-
playing its points
If you are not currently creating a polygon or Bi-
spline curve, first select it with the Pointer tool, then
select the tool you used to create the ShapeLayer.
This displays the ShapeLayer’s edit points. If you
are still creating a ShapeLayer, the points are al-
ready visible, so you do not have to select the Shape-
Layer or the tool.

To edit points in a polygon or Bi-spline 
curve
1 To add a point, click on a line segment.

2 To delete a point, click it with the middle mouse
button.

3 To move a point, drag it. This is how you can
stretch the side of a polygon or adjust a curve.

4 When you finished editing, select the Pointer
tool or press V.

The points disappear and a bounding box sur-
rounds the ShapeLayer.

Creating a Bezier curve 
Use the Bezier tool to draw ShapeLayers that com-
bine curves and straight lines. Clicking creates
straight lines; dragging creates curves.

TIP

The Bezier tool is a vers
can use to create both 
ments. Once you become
not need the Polygon and

To create a Bezier c
1 Select the Bezier to

Toolbox.

Bezier tool selected in th

2 Click on the canvas to 

3 To draw a straight seg
ond edit point.

Eclipse draws a strai
points.

4 To draw a curve segm
edit point.

When you first press 
places another edit p
segment between it a
drag, Eclipse changes t
displays two handles a
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 a Bezier ShapeLayer
ol, and use it to select a

er appears surrounded by

l.

ounding box and displays
he ShapeLayer. 

s two handles when you

ys one handle when you

ot display any handles.
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5 To adjust the angle of the curve segment, drag
one of the handles. Both handles move as you
drag.

6 Click to place additional straight segments; drag
and click to place curved segments.

7 To join the first and last edit points, click Close
in the ShapeLayer Toolbox. 

To open a closed ShapeLayer, click Close again.

8 When you are finished creating the Bezier curve,
select the Pointer tool or press V.

Editing a Bezier curve
A Bezier curve ShapeLayer has three different kinds
of points: curve points, straight points and corner
points (the point where a curve segment meets a
straight segment). Eclipse displays all the points as
small squares. In addition to adding, deleting, and
moving edit points, you can use handles on the
curve and corner points to adjust the angle, size and
direction of the curve segments. You can also
change a curve to a straight segment or change a
straight segment to a curve.

The elements of a Bezier 

To edit the points in
1 Select the Pointer to

ShapeLayer.

The selected ShapeLay
a bounding box.

2 Select the Bezier too

Eclipse removes the b
the points that define t

A curve point display
click on it.

A corner point displa
click on it.

A straight point does n
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 the curve. Both handles
curve distorts in the direc-

, press Shift, and click the
ag it without moving the

ess Shift and click one of

t, click it so that one han-
 the handle.
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TIP

To see the points and their handles clearly, zoom in
on the ShapeLayer.

3 To change a curve to a straight segment or to
change a straight segment to a curve, press and
hold the Shift key and click the segment. 

TIP

Make sure you click the segment, not a point, when
converting a curve to a straight segment or vice
versa.

4 To adjust a curve segment, click one of its points
so two small handles appear. Then drag a handle.

When you click a curve point, two small handles ap-
pear attached it. 

Drag a handle to adjust
move in tandem and the 
tion you drag.

To move only one handle
handle. Now you can dr
other handle.
To rejoin the handles, pr
the handles.

5 To adjust a corner poin
dle appears. Then drag
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The curve segment attached to the corner point
moves in the direction you drag. The straight seg-
ment does not move.

6 You can also edit Bezier points using these stan-
dard techniques:

- To move a point, drag it. 

- To delete a point, click it with the middle
mouse button.

- To add a point, click on the line or curve be-
tween two existing points. If you add a point to
a straight segment, you add a straight point. If
you add a point to a curve, it is a curve point.

7 When you are finished, select the Pointer tool
or press V. Eclipse hides the points and displays
the bounding box around the ShapeLayer.

Adding Text
Use the Text tool to add text to an image. Eclipse
treats text like a ShapeLayer. You can edit text as
you do other ShapeLayers. You can move, size and
warp text as well as fill it with any combination of
color, image or mask. 

To add text
1 Select the Text Tool from the ShapeLayer Tool-

box.

Text tool selected in the T

2 Click approximately w
appear.

The Text Tool dialog a

The Text Tool dialog
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djust the spacing between
.

 Text
 to display the text cursor,
text. If you type to the end
 text box wraps to the next

 in the ShapeLayer, press

r it or hold down the Shift
w keys. 

press the Delete or Back-

ton to preview the text on
ntinue typing or editing af-

 typing, click Ok.

g box, draws the text, and
 text like any other Shape-

ing between specific pairs
currences of the specified
If the same letter pair oc-
kern the pair in that font
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To choose a font
Select the name of the font you want to use from the
Font list. Use the dropdown menu to see more
available fonts.

In Eclipse, you can use all fonts which are installed
in your system. Eclipse looks for fonts in the Fonts
folder of your system directory.

To specify other Text properties
In the Text dialog box you can select these text at-
tributes:

• Font size: Select the font size (in points) from
the pop-up menu, or type a font size in the text
box.

• Leading: Leading is the amount of space be-
tween lines, measured from base line to base line.
Select the leading (in points) by typing a value in
the text box. To let Eclipse choose the optimum
leading for you, select Auto.

• Tracking: Tracking is the amount of space be-
tween letters. The tighter the tracking, the less
space between letters. Type the amount of track-
ing you wish into the text box.

• Align: Use the Align menu to select left, right or
centre justified text.

• Width: The Width box increases or decreases
the horizontal size of both letters and the spaces
between letters. Type a positive or negative per-
centage value in the box.

• Kern: Click Kern to a
specific pairs of letters

To type and preview
1 Click in the Text area

and begin typing your 
of a line, the text in the
line.

2 To create a line break
Enter.

3 To select text, drag ove
key and press the arro

4 To cut selected text, 
space key.

5 Click the Update but
the canvas. You can co
ter clicking Update.

6 When you are finished

Eclipse closes the dialo
selects it. You can edit
Layer.

Kerning Text
Kerning adjusts the spac
of letters. It affects all oc
letters in the same font. 
curs in a different font, 
separately.
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1 Click Kern in the Text dialog box. 

The Kerning dialog box appears. 

The Kerning dialog

2 Type in a pair of letters to be kerned.

3 Type in the value by which you want the letter
spacing adjusted. Use negative values to reduce
spacing.

4 The effect of the current kerning values is dis-
played.

To edit existing text
1 Select the text by clicking it with the Pointer or

Hand tool so that a bounding box appears around
the text.

2 Select the Text Tool from the ShapeLayer Tool-
box.

The Text Tool dialog b
text you selected. Use
way you did to create t

TIP

To blend the text edge w
in a value in the Blend E
of the ShapeLayer Toolb
see “Blending the edge 
page 5-30.

Deleting a ShapeLaye
To delete a ShapeLa
1 Select the Pointer tool

box.

2 Select the ShapeLayer
to delete.

3 Choose ShapeLayer 
lete key.

TIP

To delete only a ShapeLa
Hand tool, and then choo
or press the Delete key.

For more information o
ShapeLayer fills see “R
ShapeLayer fill” on page
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5.5. Filling ShapeLayers

You can fill any closed ShapeLayer with solid or vi-
gnette color, an image, a mask, solid or vignette
transparency or any combination of these elements.
Use the ShapeLayer Fill shelf to select the color, im-
age or mask and to choose fill options such as trans-
parency and blending.

To fill a closed ShapeLayer
1 Select the ShapeLayer with the Pointer tool or

Hand tool so that its bounding box appears.

2 Choose Window → ShapeLayer Fill. The
ShapeLayer Fill shelf appears.

TIP

You can also open the ShapeLayer Fill shelf by dou-
ble-clicking inside a ShapeLayer with the Hand
tool.

You can leave the ShapeLayer Fill shelf open as you
work.

The ShapeLayer Fill shel
currently selected Shape

Image: Any image file ty
placed inside a ShapeLay
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ton in the Image Section at
yer Fill shelf. Use the Open
rs to select an image. The
review in the ShapeLayer

 fill check the Image: use
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Mask: Since ShapeLayers are resolution-indepen-
dent, any mask file can be placed inside a Shape-
Layer. You can manipulate an image fill and its
mask at the same time.

Color: Select Color to fill a ShapeLayer with a solid
color or with a color vignette.

Transparency: Select Transparency and Solid to
add a degree of transparency to a fill. Use the text
box or popup  slider to control the amount of trans-
parency.

You can also turn on Vignette to create a transpar-
ency vignette within a ShapeLayer.

Operation: Allows to apply an effect or correction
to the selected ShapeLayer only.

Blend Edge: Soften the edges of the fill by typing a
value in the Blend Edge text box. The higher the val-
ue, the greater the area of edge softening.

Filling a ShapeLayer with an image
1 Select a closed ShapeLayer with the Pointer tool

or the Hand tool.

2 Click the Open file but
the top of the ShapeLa
File dialog that appea
image appears as a p
Fill shelf.

3 To use the image as the
checkbox.
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ile dialog that appears to
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e from the Shape-

 checkbox.

ge from the ShapeLayer.
hapeLayer with the Hand
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and its fill elements, select
e Pointer tool, and then

mage inside a 

mage inside a ShapeLayer
n the ShapeLayer Toolbox.
ferences the entire canvas
ost useful when you want
vas image (see “Warping
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4 To fit the image to the ShapeLayer, select the
Hand tool and double-click on the magic han-
dle. The magic handle is the hollow handle at the
lower-left corner of an unrotated bounding box.

5 To fit the ShapeLayer to the image, select the
Pointer tool and double-click on the magic
handle.

To select a different
• Click the Open file but

• Then use the Open F
choose a different ima

To remove the imag
Layer
Deselect the Image: use

Eclipse removes the ima
Alternatively, select the S
tool, and then press Dele

TIP

To delete a ShapeLayer 
the ShapeLayer with th
press Delete.

Putting the Canvas i
ShapeLayer

You can put the canvas i
using the Cutout button i
The ShapeLayer then re
image. This function is m
to warp parts of the can
ShapeLayers” on page 7-



5. Working with ShapeLayers 5.5. Filling ShapeLayers

w filled with the copy of a
he canvas image. In the
he cropped image appears
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with a mask
ayer.

ton in the Mask section of
elf.

pears like the one you see
n → Mask from the File

 mask you want from the
K. The mask appears as a

ayer Fill shelf.

eated and saved the mask

with the mask you selected
checkbox.

eck Invert in the Shape-
 this has the same effect as
ert: all opaque portions of
nsparent; all transparent
ue. The mask file itself is
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1 Create a closed ShapeLayer.

2 Click the Cutout button in the ShapeLayer Tool-
box. 

In the ShapeLayer Fill shelf, the canvas image ap-
pears in the image sample box.

3 To move the canvas image around inside the
ShapeLayer, drag it using the Hand tool.

WARNING

Cutout uses the most recently saved version of the
canvas image. Modifications you make to the can-
vas image will not be picked up by the cutout im-
age.

Copying only part of the canvas image 
into a ShapeLayer
If you want to copy part of the canvas image into a
ShapeLayer, rather than making reference to the
canvas image, use the Cropout button in the
ShapeLayer Toolbox. This operation also saves the
copied portion of the canvas image as a file.

1 Select the part of the canvas image you want to
copy by enclosing it within a ShapeLayer.

2 Click the Cropout button in the ShapeLayer
Toolbox.

3 Use the Save File dialog that appears to save the
selected area as an image file.

The ShapeLayer is no
cropped portion of t
ShapeLayer Fill shelf, t
in the image sample bo

Filling a ShapeLayer 
1 Select a closed ShapeL

2 Click the Open file but
the ShapeLayer Fill sh

An Open File dialog ap
when you choose Ope
menu.

3 Select the name of the
file dialog, then click O
preview in the ShapeL

REMARK

You must have already cr
file you want to use.

4 To fill the ShapeLayer 
check the Mask: use 

5 To invert the mask, ch
Layer Fill shelf. Doing
choosing Mask → Inv
the mask become tra
portions become opaq
not affected.
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sed with text.)
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For more information on ShapeLayers and mask-
ing, see “Creating a Mask with ShapeLayers” on
page 8-13.

Filling a ShapeLayer with solid color
Check Color in the ShapeLayer Fill shelf. Then turn
on Solid.

The color swatch and the ShapeLayer are filled with
the current color and the Color Editor appears.

To change the fill color, pick a color using the Color
Editor.

You can blend the edge of the color fill or make it
partially transparent as described in “Blending the
edge of a ShapeLayer fill” on page 5-30.

Filling ShapeLayer with Color Vignettes
Use a color vignette to add gradual transitions of
color. You can choose different types of color vi-
gnette and adjust features such as color values,
spread, transparency, dithering and noise.

To fill a ShapeLayer
gnette
1 Select the ShapeLayer

Pointer or Hand too

2 Check Color and turn
Layer Fill shelf.

The Color Vignette 
ShapeLayer fills with 
default colors are black

The Color Vignette dialog

Choose from four types 
tour vignette cannot be u

Horizontal and vertical c
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olors in a Color Vignette.
rs blend, drag a marker.

f a marker, select it and
 Color Editor or Color Pal-

her click it or click the ar-
he ramp to select the next

k in the color ramp. Then
 Editor to select a color.

click it with the middle

aps to vignettes of differ-
 following table.
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Radial and Contour color vignette

There are two ways to add and adjust colors in a
Color Vignette.

• Color ramp: Use the color ramp in the Vignette
dialog. This is a quick and easy way to create a
simple color vignette.

• Vignette Profile Editor: Use the Vignette Pro-
file Editor if you want precise control over color
values and their positions.

How to adjust a Color Vignette using the 
color ramp
Using the color ramp to adjust colors and the spread
between them is a fast way to create or modify a Col-
or Vignette.

1 Red markers control c
To adjust how the colo

2 To change the color o
choose a color from the
ette.

3 To select a marker, eit
rows at either end of t
marker.

4 To add a marker, clic
use the Vignette Color

5 To delete a marker, 
mouse button.

The way the color ramp m
ent types is shown in the
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e editor
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he vertical axis represents

orresponds to a marker on
nts and markers represent
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How to adjust a Color Vignette using the 
Profile editor
For precise control over color values and positions
in a complex vignette, use the Vignette Profile Edi-
tor. The Profile Editor’s graph offers another view of
the vignette data displayed in the color ramp of the
Vignette dialog. Changes made in the Vignette Pro-
file Editor are reflected in the Vignette dialog, and
vice versa. 

To access the Vignette Profile Editor, click Pro-
file in the Vignette dialog. 

The Color Vignette Profil

The horizontal axis of 
stretch of the vignette. T
the color value.

Each point on the graph c
the color ramp. Both poi
changes in color gradatio

Vignette Type Colors on the 
left side of 
the color 
ramp map to 
this area of 
the vignette

Colors on the 
right side of 
the color 
ramp map to 
this area of 
the vignette

Horizontal Left side Right side

Vertical Bottom Top

Radial Centre Outside edge

Contour Centre Outside edge
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• Adjust each channel separately.

• To add a gradation point to the vignette, click a
point on the curve. A corresponding marker is
added to the color ramp in the Vignette dialog.

• To delete a point, click it with the middle mouse
button. 

• To adjust the gradation spread, drag a point hor-
izontally.

• To change the color value for a point, drag it up
or down on the graph.

• You can also change the color of a point via the
arrow buttons and the Color Value text boxes and
popup sliders.

Dithering a Vignette
Dithering helps eliminate color banding in the vi-
gnette colors.

To dither the vignette, select Dither. 

Adding Noise to a Vignette
Smooth the transition between colors in a vignette
by adding noise. 

To add noise, click the Noise text box, type in a pix-
el value and press Enter or use the popup slider.

REMARK

The proxy version of a v
level may look coarse. I
you render it.

Linear vs. Smooth G
Both the Vignette dialog
Editor have a pop-up me
Linear and Smooth. 

• Linear produces a m
tween colors.

• Smooth produces mo

To adjust the focal p
gnette
A small square handle m
contour vignette. When
gnette, this handle is in t

Select the pointer tool an



5. Working with ShapeLayers 5.5. Filling ShapeLayers

y to a color, image or mask
cy slider and text box near
ayer Fill shelf.
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ncy for a ShapeLayer fill,
 in the ShapeLayer Fill

ency level, type a percent-
x or use its popup slider. A
ly opaque — 100 is com-

ffect only solid transpar-
rencies have a separate

ating a transparency vi-
5–26

Tips
The focal point of a color contour vignette is in the
ShapeLayer’s centre by default.

Here the focal point has been moved to the bottom
of the ShapeLayer by dragging its inner handle.

TIPS

You can also add transparency and blending to a
Color Vignette. For directions, see page 5-26.

To edit a Color Vignette, use the Hand tool and
press the S key.

Adding Transparency
You can add transparenc
fill using the Transparen
the bottom of the ShapeL

To add transparency
1 To turn on transpare

check Transparency
shelf. 

2 Also select Solid. 

3 To adjust the transpar
age value in the text bo
value of 0 is complete
pletely transparent.

REMARK

This slider and text box a
ency. Vignette transpa
shelf.

For instructions on cre
gnette, see below.
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ext box above it to control
 of the selected marker. 

djust transparency levels
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ditor.

rency Vignette using 
mp
sparency point, click the
clipse inserts a vertical

d between transparency
rs left or right. 

ency level of a marker, se-
ider above the Profile but-
total transparency; white
y.

value from 0 to 100 in the
f the ramp. The higher the
transparency at the select-

ether, they can be hard to
case, click on one of the ar-
e ramp to select the next
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Filling a ShapeLayer with a Transparency 
Vignette

Use a transparency vignette to create gradations of
transparency and shadow around an image in a
ShapeLayer. 

1 Select a closed ShapeLayer filled with an image
or another kind of fill. 

REMARK

A transparency vignette is not visible unless you
fill the ShapeLayer with an image, color, or a
mask.

2 Select Transparency in the ShapeLayer Fill
shelf. 

3 Select Vignette.

The Transparency Vignette dialog appears.

The Transparency Vignette

The Transparency Vignette dialog works in much
the same way as the Color Vignette dialog de-
scribed on page 5-23.

The levels of grey in t
represent levels of tra
grey, the greater the tr

4 Use the slider or the t
the transparency level

There are two ways to a
and gradation: using the
ing the Vignette Profile E

Adjusting a Transpa
the transparency ra
1 To insert a new tran

transparency ramp. E
marker in the ramp. 

2 To adjust the sprea
points, drag the marke

3 To adjust the transpar
lect it and move the sl
ton. Black represents 
represents total opacit

You can also type in a 
text box to the right o
value, the greater the 
ed marker.

TIP

If markers are close tog
select by clicking. In this 
rows at either end of th
marker.
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4 To remove a marker, click it with the middle
mouse button.

5 To choose a type of vignette effect, use the drop-
down menus at the bottom of the shelf.

- Horizontal/Vertical/Radial/Contour: A
horizontal vignette produces differing levels of
transparency “side to side.” A vertical vignette
produces a “top to bottom” effect. A radial vi-
gnette produces a circular effect with transpar-
ency radiating out from the centre in
concentric circles. A contour vignette follows
the outline of the ShapeLayer. Contour vi-
gnettes are particularly useful with irregular
ShapeLayers.

- Smooth/Linear: Smooth produces more
blending between transparency levels. Linear
produces a more abrupt change between trans-
parency levels.

6 To reduce or eliminate banding in the transpar-
ency vignette, click Dither. 

7 To smooth transition steps between transparen-
cy levels in a vignette, type a pixel value in the
Noise text box and press Enter or use its popup
slider.

Adding noise mixes pixel values along the edges
of transparency steps, creating a more pleasing
vignette.

REMARK

The proxy version of a v
level may look coarse. I
you render it.

Adjusting a Transpa
the Vignette Profile
To create a complex or
gnette, use the Vignette P
graph that offers anothe
displayed in the Trans
Changes in the Profile E
Transparency Vignette d

• Click the Profile butto
gnette dialog. The Vig
appears.
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The Transparency Vignette Profile Editor

The horizontal axis of the graph represents the
stretch of the vignette. The vertical axis repre-
sents the transparency value. 0 is totally opaque,
100 is totally transparent.
Each point on the graph corresponds to a marker
on the ramp in the Vignette dialog. Both points
and markers represent changes in transparency.

• To add a transparency point to the vignette, click
on the curve. A corresponding marker is added to
the ramp in the Transparency Vignette dialog.

• To delete a graph poin
mouse button. 

• To adjust the spread b
els, move a point horiz

• To adjust a point’s tran
or down. Black repre
white represents total 

Adjusting the focal 
Transparency Vigne
A small square handle m
contour vignette. When
gnette, this handle is in t

Here a contour transpa
blend an image placed w
Layer. The vignette is tra
becomes more opaque ne
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 you want to work with.

ection dialog and adjust it

tion section.

ct or correction to the fill.
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ick Options to open the re-
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The vignette’s center has been moved to the half-
hidden eye by dragging the small square handle in
the centre of the vignette.

To adjust the focal point of a contour vi-
gnette
Select it with the Pointer tool and drag the inner
handle.

TIPS

If you change a ShapeLayer’s size, a contour vi-
gnette also changes. 

To edit a transparency vignette without affecting
other fills, use the Hand tool and press the A key.

Blending the edge of a ShapeLayer fill
Use the Blend Edge text box in the ShapeLayer Fill
shelf to soften the edge of a fill.

Type a value in the Blend Edge text box at the bot-
tom of the ShapeLayer Fill shelf and then press En-
ter or use the text box’ popup slider.

Eclipse blends the fill fro
Layer towards the middl
10, Eclipse softens the fil
ShapeLayer and moving 

Filling a ShapeLayer 
Correction

You can apply any effect 
ShapeLayer.

1 Select the ShapeLayer

2 Open any effect or corr
to your satisfaction.

3 Check use in the Opera

Eclipse applies the effe

4 If you want to adjus
again at a later time, cl
spective dialog.
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ormation, see “Stroking
page 4-21.

g a ShapeLayer fill 
shelf to remove or replace
out deleting all of them or

 For example, suppose you
olor, an image and a mask.
e the mask without affect-

 you want to work with.

helf is not displayed, open
w → ShapeLayer Fill or
ide the ShapeLayer with

helf shows you the fill ele-
 ShapeLayer. The fill types
er are selected and you see
ts in the appropriate box-

nt, simply deselect it.

nt, click its Open file but-
ditor or Open File dialog

lect a new color, image or
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Filling a ShapeLayer with more than one 
object

You  can fill any ShapeLayer with more than one ob-
ject, e. g. an image and an operation. This is what
happens for the different possible combinations:

• just an image or color: what you fill is what you
get.

• just a mask: the canvas below the ShapeLayer is
masked.

• just an operation: the operation works on the
part of the canvas which is beneath the Shape-
Layer.

• Mask plus image, color or operation: under the
mask the canvas remains unchanged.

• Image plus color: the ShapeLayer is filled with
the image.

• Image plus color plus mask: the mask area is
filled with the color, the unmasked area is filled
with the image.

• Operation plus mask: the operation works on the
unmasked part of the fill.

Finally, the Transparency blends the outcome of
your different fills with the canvas.

Stroking a Brush along a ShapeLayer
To apply the current brush along the outline of a se-
lected ShapeLayer, click Stroke in the ShapeLayer

Toolbox. For more inf
along a ShapeLayer” on 

Removing or replacin
Use the ShapeLayer Fill 
specific fill elements with
deleting the ShapeLayer.
fill a ShapeLayer with a c
You can remove or replac
ing the color and image.

1 Select the ShapeLayer

2 If the ShapeLayer Fill s
it by choosing Windo
by double-clicking ins
the Hand tool.

The ShapeLayer Fill s
ments for the selected
used for the ShapeLay
a sample of the elemen
es.

3 To remove a fill eleme

4 To replace a fill eleme
ton. The appropriate e
appears so you can se
mask. 
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REMARK

If you have scaled, warped, distorted or otherwise
manipulated a ShapeLayer fill, the replace fill as-
sumes the same aspects. These aspects are lost,
however, if you remove the ShapeLayer fill.
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ose the way you want to
ns: 

Eclipse renders all the
age, whether or not they

ers: Eclipse renders only

ers
lbox is not displayed, open
w → ShapeLayer Tool-

nder Mode → Selected
 in the ShapeLayer menu,
ayers you want to render.

hapeLayer Toolbox.

irmation box asking if you
the ShapeLayer. (This box

 requester dialogs is
al Preferences dialog.)

ick No to cancel.

the rendering progress.

Stop in the status box.

plete, copies of each ren-
ain on top of the rendered
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5.6. Rendering ShapeLayers

As you create, fill and edit ShapeLayers, you are
working on the ShapeLayer overlay. The Shape-
Layer overlay is like a layer above the canvas image.
ShapeLayer fills do not become part of the canvas
image until you render them. Once rendered, fills
acquire the resolution of the canvas image and can
no longer be edited.

You can render ShapeLayers using the Render but-
ton in the ShapeLayer Toolbox or using a Render
brush. This section describes using the Render but-
ton. For directions on using a Render brush, see
“Rendering a ShapeLayer Fill with the Render
Brush” on page 4-13.

REMARK

Rendering ShapeLayers is different from using the
Standalone renderer command in the Window
menu. The Eclipse Standalone renderer renders an
entire image, mask or ShapeLayer file to a sepa-
rate image, mask or linework output file. For more
information, see “Eclipse Standalone Renderer
(ecrender)” on page 11-11.

Using the Render button in the Shape-
Layer Toolbox

Use the Render button in the ShapeLayer Toolbox
to apply ShapeLayer fills to the canvas image. 

Eclipse can render all the ShapeLayers in the image
at once, or render only those ShapeLayers you se-
lect. You use the Render Mode option in the

ShapeLayer menu to cho
work. There are two optio

• All ShapeLayers: 
ShapeLayers in the im
are selected.

• Selected ShapeLay
selected ShapeLayers.

To render ShapeLay
1 If the ShapeLayer Too

it by choosing Windo
box.

2 If you selected the Re
ShapeLayers option
first select the ShapeL

3 Click Render in the S

Eclipse displays a conf
really want to render 
appears only if Show
turned on in the Gener

4 Click Yes to render; cl

A status box indicates 

TIP

To halt the render, click 

When the render is com
dered ShapeLayer rem
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fill elements. You can delete the copies or contin-
ue editing them.

TIPS

If you do not like the rendered images, you can re-
store the canvas image to its last saved or retained
state by choosing File →  Restore. Alternatively,
use the Restore brush to remove parts of the ren-
dered ShapeLayer fills.

For high quality image rendering, set the anti-
aliasing level to 3 or 4. For information on anti-
aliasing, see “Anti-Alias” on page 9-4.
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peLayer overlay with the
mage, you can open them
 Open →  All. 

s
eLayer file created with a
 using a different applica-
 sometimes hard to locate.
n to 1:16 makes them visi-
y are located too far from
 to find. If this happens,
nces →= General in the
 Screen in the New/Open
 ShapeLayer file again.

 or masks in a 

ayer file, Eclipse searches
tory for any image or mask
ShapeLayers. If it cannot

log appears.
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5.7. Saving and Opening ShapeLayer
Files

Saving a ShapeLayer overlay
You can save ShapeLayers and their fills and open
them later to reuse them. Eclipse saves Shape-
Layers on the ShapeLayer overlay of the current
canvas in a file with a .shp filename extension.

To save the ShapeLayers on the Shape-
Layer overlay
1 Choose File → Save As → ShapeLayers. A

Save file dialog appears.

2 Use the file dialog to name the ShapeLayer file
and specify a pathname for the file.

TIP

To automatically save the ShapeLayer overlay
along with the canvas image, choose File → Save
As →  All. The ShapeLayer file is given the same
name as the image file with a .shp filename exten-
sion.

Opening a ShapeLayer file
Before you can open a ShapeLayer file, you must
first open or create an image file.

To open a ShapeLayer file
1 Choose File= → Open → ShapeLayers. An

Open File dialog appears.

2 Use the dialog to select the ShapeLayer file you
want to open.

TIP

If you have saved a Sha
same name as a canvas i
both by choosing File → 

Locating ShapeLayer
If you are opening a Shap
different canvas image or
tion, the ShapeLayers are
Sometimes zooming dow
ble, but occasionally the
the current canvas view
open File →  Prefere
main menu, select Fit to
File section and open the

Locating lost images
ShapeLayer file

When you open a ShapeL
the ShapeLayer file direc
files you used to fill the 
find a file, a Lost File dia
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nd continue opening the
e No.

ther lost files it redisplays

open the ShapeLayer file,

ssion to open an image or
s a warning, but does not
. To use the file, you must
tus. See your system doc-

tion on determining and
r ask your system admin-
5–36

The Lost Image dialog

• To look for the lost file, select Yes.

Either the Open Image or Open Mask File dialog
appears. Use it to try to locate the file. 

TIP

Select Substitute all missing files in the Lost File
dialog box to try to locate any other lost files as you
search for the currently named file.

If you locate the file, Eclipse retrieves it and con-
tinues opening the ShapeLayer file. If Eclipse en-
counters other lost files, it redisplays the Lost
File dialog.

If you click Cancel in the Open Image or Open
Mask File dialog, Eclipse skips the lost file it is
looking for and continues trying to open the
ShapeLayer file. This is equivalent to choosing
the Look for missing files: No checkbox.

• To skip the lost file a
ShapeLayer file, choos

If Eclipse encounters o
the Lost File dialog.

• If you decide not to 
click Cancel.

REMARK

If you do not have permi
mask file, Eclipse display
let you search for the file
change its permission sta
umentation for informa
setting file permissions o
istrator.
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6.1. Editing Basics

You can move, scale, rotate and distort ShapeLayers
and fills using the Pointer and Hand tools. For pre-
cise control, you can also edit ShapeLayers and fill
elements by typing values in the ShapeLayer Geom-
etry shelf. For instructions, see “Editing Shape-
Layer Geometry” on page 6-13.

Eclipse treats ShapeLayers and their fills as distinct
entities. You can edit a ShapeLayer and its fill inde-
pendently. To choose between editing a ShapeLayer
or editing its fill, use different tools to select the
ShapeLayer:

ShapeLayer Toolbox with Pointer tool selected

• To select and edit a ShapeLayer and its fill to-
gether or to edit the ShapeLayer only:
use the Pointer tool.

• To select and edit the fill elements only:
 use the Hand tool.

Editing specific elements 
You can also limit editing to specific ShapeLayer el-
ements by using the Alt and Ctrl modifier keys, as
shown in the table below.

You can use the Shift ke
Alt and Ctrl keys. For exa
gnette fill and the transpa
while maintaining the asp
use the Hand tool and ho

REMARK

The Warp tool has its ow
which ShapeLayer eleme

Selecting a ShapeLay
To edit a ShapeLayer, yo

• To select a ShapeLaye
or the Hand tool and

Tool Modifi-
er Key

E

Pointer 
tool

None E
it

Alt E
o

Hand tool None E

Alt E

Ctrl E
fi

Pointer 
tool or 
Hand tool

Shift M
w
o
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nding box (shown in red)

 also be used to mirror or
 do this, drag one of the
he other.

sed to fit an image to the

or square the handles ap-
ners of the ShapeLayer it-
al bounding box. 

ayers
mand in the ShapeLayer
ll the ShapeLayers in your
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• To select additional ShapeLayers, hold down the
Shift key as you select.

• To deselect a ShapeLayer, click anywhere outside
the ShapeLayer.

• To select a ShapeLayer that is surrounded by an
already selected ShapeLayer, hold down the Ctrl
key and then click the ShapeLayer with the Point-
er tool.

When you select a ShapeLayer, Eclipse draws a rect-
angular bounding box around it. The bounding box
has eight handles — one on each corner and one in
the middle of each side. Use these handles to scale
and stretch the ShapeLayers.

A ShapeLayer and its bou

The Scale X handles can
flip the ShapeLayer. To
Scale X handles beyond t

The Magic handle is u
ShapeLayer.

REMARK

If you select a rectangle 
pear on the sides and cor
self; there is no addition

Selecting all ShapeL
Use the Select All com
menu or Ctrl A to select a
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same time. Press the Shift
hapeLayer’s aspect ratio.

les on to scale the Shape-
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agic Handle 
eft corner of the bounding
e. Use the magic handle to
hapeLayer, or to make the
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 an image fill, double-click
 the Pointer tool.

 ShapeLayer, double-click
 the Hand tool.

ee “Filling a ShapeLayer
5-19.

r from the centre
ontents or both using the
g dialog. Scaling from the

ng trapping for the Shape-

 → Scale from Centre.
.
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image. This is a convenient way to work on all the
ShapeLayers, even those that are not currently visi-
ble.

Moving a ShapeLayer or its fill
You can move any kind of ShapeLayer, including
text, by dragging it. You can also move a fill within
a ShapeLayer. 

1 To move the ShapeLayer and its fill simulta-
neously, select the Pointer tool.

To move the fill only, select the Hand tool.

2 Point inside the ShapeLayer and drag in the di-
rection you want the ShapeLayer or fill to move.

TIP

To move the ShapeLayer without affecting the fill,
use the Pointer tool and press the Alt key as you
drag.

Scaling a ShapeLayer or its fill
There are three different methods to scale a Shape-
Layer.

Scaling by dragging
1 To scale the ShapeLayer and its fill together, se-

lect the Pointer tool.

To scale a ShapeLayer without affecting its fill,
use the Pointer tool and press the Alt key as you
drag.

To scale the fill only, select the Hand tool.

2 Drag the handles on th
dles have different fun

- Use the corner han
and vertically at the 
key to maintain the S

- Use the middle hand
Layer either horizon

Scaling using the M
The handle at the lower l
box is the Magic handl
fit a fill image inside a S
ShapeLayer fit the fill im

• To fit a ShapeLayer to
the magic handle with

• To fit an image fill to a
the magic handle with

For more information, s
with an image” on page

Scaling a ShapeLaye
Scale a ShapeLayer, its c
ShapeLayer Centre Scalin
centre is useful for defini
Layer fill. 

1 Choose ShapeLayer
You will see this dialog
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yer using the Mirror 

 → Mirror. A submenu
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The ShapeLayer Centre Scaling dialog

2 Choose what to scale: ShapeLayer + Fill, Shape-
Layer only, Fill only.

3 Change the ShapeLayer’s width using the
Scale X setting. Change its height using the
Scale Y setting. To maintain proportions, turn
on Lock X/Y.

4 To apply the scaling, click Scale.

REMARK

You can only scale one ShapeLayer at a time in this
way.

To mirror a ShapeLayer
You can mirror a ShapeLayer horizontally or verti-
cally by dragging one side beyond the other or by
using the Mirror command in the ShapeLayer
menu. When you mirror a ShapeLayer, the fill ele-
ments also get mirrored; you cannot mirror Shape-

Layers and fills independ
to inverse scaling.

To mirror a ShapeLa
1 Use the Pointer tool

2 Drag one of the middl
dle on the opposite sid

For example, to mirror
drag the middle hand
ShapeLayer’s boundin
on the left.

To mirror a ShapeLa
command
1 Choose ShapeLayer

appears.
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s
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u select the ShapeLayers
 works: the ShapeLayers

 the first ShapeLayer you
ppose you have a square, a
at you want to align. If you
, Eclipse aligns the circle
he square.

Align. The Align Shape-

ialog

orientation: Horizontal

ent, select Left, Centre,

apeLayers along their left
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2 Choose a command from the Mirror submenu to
mirror the selected ShapeLayer and its fill.

REMARK

If the hand tool is selected, only the content of the
ShapeLayer is mirrored.

Aligning ShapeLayers
Use the Align command in the Organize menu to
align ShapeLayer vertically or horizontally. Eclipse
uses the bounding boxes around the ShapeLayers as
guides for alignment.

To align ShapeLayer
1 Select the ShapeLayer

The order in which yo
determines how Align
align themselves with
select. For example, su
circle and a triangle th
select the square first
and the triangle with t

2 Choose Organize → 
Layers dialog appears.

The Align ShapeLayers d

3 Select an alignment 
and/or Vertical. 

4 For Horizontal alignm
or Right.

- Left: Aligns the Sh
sides.
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em. You can warp com-

rs
s you want to group. Hold
hile you select the Shape-

roup.

 appears around all the se-

to a group, first select the
 Shift key, select the addi-
en choose Organize →

 together, select the first
hift key and select the sec-
e Organize → Group.

and to break up grouped
 consists of other groups,
the component groups. 

 of ShapeLayers
ant to break apart.

ngroup.
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- Centre: Aligns the ShapeLayers through their
centres.

- Right: Aligns the ShapeLayers along their
right sides.

5 For Vertical alignment, select Top, Middle or
Bottom.

- Top: Aligns the objects along their top sides.

- Middle: Aligns the objects through their mid-
dle.

- Bottom: Aligns the objects along their bottom
sides.

6 Click Align.

TIP

If you first group ShapeLayers, you can then align
the groups.

Grouping ShapeLayers
Use the Group command in the Organize menu to
group ShapeLayers together. You can work with a
group of ShapeLayers as you would with a single
ShapeLayer. You can also create hierarchies of
groups. For example, suppose you group two rect-
angles together and then group two circles together.
You could then combine the two groups into a third
group.

REMARK

While you can edit group
not warp them or fill th
bined ShapeLayers. 

To group ShapeLaye
1 Select the ShapeLayer

down the Shift key w
Layers.

2 Choose Organize → G

A single bounding box
lected ShapeLayers.

3 To add a ShapeLayer 
group. Hold down the
tional ShapeLayer, th
Group.

4 To group two groups
group, hold down the S
ond group, then choos

Use the Ungroup comm
ShapeLayers. If a group
Ungroup breaks it into 

To break up a group
1 Select the group you w

2 Choose Organize → U
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Eclipse breaks the group into its components. If
you break up a group composed of other groups,
those groups remain as groups.

Combining ShapeLayers
You use the Combine command to create new
ShapeLayers or combinations of ShapeLayers from
existing, overlapping ShapeLayers. 

A combined ShapeLayer is either a union or inter-
section of its component ShapeLayers, depending
on whether the ShapeLayers are locked or un-
locked.

• If you lock two ShapeLayers before you Combine
them, you get a union of the two ShapeLayers. 

• If one or both ShapeLayers are unlocked, you get
an intersection of the ShapeLayers. 

Using Lock and Combine is a good way to share
mask edges for adjacent portions of an image.

The following examples illustrate how Lock and
Combine work together.
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Try creating a couple of ShapeLayers, then using
different variations of Lock and Combine on them
to see how the commands work. 

REMARK

You can combine warped and distorted Shape-
Layers.

Locking a ShapeLayer
You lock and unlock ShapeLayers with the Lock
button on the ShapeLayer Toolbox.

• To see wether a ShapeLayer is locked, select it. If
Lock is selected, the ShapeLayer is locked.

• To lock a ShapeLayer, select it and then select
Lock.

• To unlock a ShapeLayer, select it and then dese-
lect Lock.

To combine ShapeLayers
1 Select the overlapping ShapeLayers you want to

combine.

2 Choose Organize → Combine.

Eclipse uses the select
new, combined Shape
ShapeLayers, you still
dividual ShapeLayer. Y
ShapeLayer of the ne
unless you fill it.

When you combine filled
only one set of fill attribu
ShapeLayer. For examp
ShapeLayers each filled w
new combined ShapeLay
ShapeLayer can only hav
gnette at a time; you can
Layer with two different 

Eclipse uses the ShapeLa
of the canvas to determi
use for the new combine
Layer in front of the c
ShapeLayer you drew, u
order of the ShapeLayer
mands (Front, Forward, 

TIP

A quick way to see fill
back order is to drag one
other. The ShapeLayer w
ShapeLayer closest to th
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apeLayer into its original
, use the Split command in

 ShapeLayer
apeLayer.

plit.

ayer breaks into its origi-

bined ShapeLayer, each
ontains the same fill as the

the preceding example are
that was used for the com-
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Tip
These letters are not yet combined. The letter B is in
front of the letter A on the ShapeLayers overlay.

When the letters are combined, they both use the fill
of the letter closest to the front—in this case, the let-
ter B.

TIP

If the ShapeLayer that has the fill you want for the
new combined ShapeLayer is not on top, choose
Organize →  Front to bring it to the front. 

To break a combined Sh
component ShapeLayers
the Organize menu. 

To split a combined
1 Select the combined Sh

2 Choose Organize → S

The combined ShapeL
nal components.

If you split a filled com
component ShapeLayer c
combined ShapeLayer.

When the letters used in 
split, they retain the fill 
bined ShapeLayer.
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 or ShapeLayers you want

enu, and then choose one
ands: Front, Forward,

 more of the ShapeLayers
nd then redraws them so

 the effects of ShapeLayer
apeLayers” on page 6-8.

 pasting Shape-

Eclipse has a clipboard on
hapeLayer information is
t or copy ShapeLayers, the
 whatever was on the clip-
Eclipse, the clipboard is

on is deleted.

Cut.

ShapeLayer in the current
age by choosing Shape-

ou can move a ShapeLayer
 another. 
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Layering ShapeLayers on the ShapeLayer 
overlay

Use the Front, Forward, Back and Backward com-
mands in the Organize menu to move ShapeLayers
forward and backward on the ShapeLayers overlay. 

Think of ShapeLayers as a deck of cards lying on the
ShapeLayers overlay above the canvas image; you
can rearrange them to change their top-to-bottom
order. When Eclipse redraws the canvas image
(when you pan or zoom in or out, for example), it
draws the ShapeLayer at “the bottom of the deck”
first and draws the remaining ShapeLayers in order
from the bottom to the top. The ShapeLayer that is
“on top of the deck” appears last.

To reorder a selected ShapeLayer
Choose a command from the Organize menu:

• Front: Bring a ShapeLayer to the top, or front,
of the ShapeLayers overlay. When you combine
overlapping filled ShapeLayers, the fill belong-
ing to the ShapeLayer closest to the front is
used for the combined ShapeLayer.

• Forward: Bring a ShapeLayer one level closer
to the front of the ShapeLayers overlay.

• Back: Push a ShapeLayer to the bottom, or
back, of the overlay. 

• Backward: Push a ShapeLayer one level closer
to the back of the ShapeLayers overlay.

To change the layer
1 Select the ShapeLayer

to move.

2 Click the Organize m
of the layering comm
Back or Backward.

Eclipse moves one or
forward or backward a
you can see the result.

For more information on
order, see “Combining Sh

Cutting, copying and
Layers

Like many applications, 
which cut and copied S
placed. Each time you cu
new information replaces
board. When you quit 
cleared and all informati

To cut a ShapeLayer
Choose ShapeLayer →=

 You can then paste this 
image or a different im
Layer →=Paste.

By using Cut and Paste, y
from one canvas image to
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To copy a ShapeLayer
Choose ShapeLayer →=Copy. 

Then paste the copy into the current image or a dif-
ferent image. 

Use the Paste command to paste cut or copied
ShapeLayers onto the ShapeLayers overlay of the
current image. 

To paste cut or copied ShapeLayers
1 Choose ShapeLayer → Paste.

A message appears in the message area saying
Click to position ShapeLayer.

2 Click where you want to paste the ShapeLayer
onto the ShapeLayers overlay.

You can paste cut or copied ShapeLayers as often as
you want. You can work with a pasted ShapeLayer
like any other ShapeLayer.
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 value you want to change,
ress Enter.

es to reflect the new value.
change the ShapeLayer’s
e ShapeLayer move to the
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s most useful if you save
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6.2. Editing ShapeLayer Geometry

Using the ShapeLayer Geometry shelf
For precise adjustments to the size, position and ro-
tation of a ShapeLayer and its fill, use the Shape-
Layer Geometry shelf. The ShapeLayer Geometry
shelf contains text boxes that display a Shape-
Layer’s current position, size and rotation. You can
type numbers in the text boxes to numerically ad-
just any of these attributes.

To edit ShapeLayer geometry
1  Select a ShapeLayer using the Pointer tool.

2 Double-click inside the ShapeLayer. The Shape-
Layer Geometry shelf appears.

The ShapeLayer Geometry shelf

3 Select a text box with a
type a new value and p

The ShapeLayer chang
For example, if you 
X Position, you see th
right or left.

To help identify a Shape
Name text box at the top
etry shelf.

TIP

Naming a ShapeLayer i
and share ShapeLayer fi

In the upper section you 
erties of the ShapeLayer 

• Position X: The ho
ShapeLayer relative to
canvas.

• Position Y: The verti
Layer relative to the b
canvas.

• Size X: The current w
defined by the ShapeL

• Size Y: The current h
defined by the ShapeL

• Rotation: The amoun
Layer in degrees.
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The lower section shows the properties of the
ShapeLayer fill:

• Offset Fill X: The horizontal position of the fill
relative to the left edge of the ShapeLayer.

• Offset Fill Y: The vertical position of the fill rel-
ative to the bottom edge of the ShapeLayer.

• Scale Fill X: The horizontal scale of the image
relative to its original size. 

• Scale Fill Y: The vertical scale of the image rel-
ative to its original size. 

• Rotate Fill: The amount of rotation of the fill in
degrees.
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peLayer. The side of the
ite the handle you drag
position.

apeLayer with the Hand
he fill — the ShapeLayer

 tool, deselect it.

ctive, it also functions like
and tool. You can use it to
yers.

s
ers and their fills using the
Layer Toolbox. When you
clipse displays a centre of
) around which the Shape-
ove the centre of rotation
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ol, then select the Shape-

 use the Hand tool to se-

l in the ShapeLayer Tool-
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6.3. Transforming ShapeLayers

Skewing ShapeLayers
When you skew a ShapeLayer, one side of its
bounding box remains fixed and you can drag the
other sides to new positions. To skew a ShapeLayer
and/or its fill, use the Skew tool in the ShapeLayer
Toolbox. 

To skew a ShapeLayer
1 Select a ShapeLayer. 

To skew the ShapeLayer and its fill, select the
ShapeLayer with the Pointer tool. 

To skew only the fill, select the ShapeLayer with
the Hand tool.

2 Select the Skew tool from the ShapeLayer Tool-
box.

Four handles appear in the middle of each side of
the ShapeLayer’s bounding box.

3 Drag one of the handles. 

Eclipse skews the Sha
bounding box oppos
maintains its size and 

If you selected the Sh
tool, Eclipse skews t
does not change.

4 To stop using the Skew

REMARK

While the Skew tool is a
the Pointer tool or the H
select and move ShapeLa

Rotating ShapeLayer
You can rotate ShapeLay
Rotate tool in the Shape
select the Rotate tool, E
rotation (a small triangle
Layer rotates. You can m
as you work.

To rotate a ShapeLa
1 Select the Pointer to

Layer. 

To rotate only the fill,
lect the ShapeLayer.

2 Select the Rotate too
box.
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otation, drag the small tri-
n. This works for both the
l. You can move the centre
you like.

rotation back to the centre
original position), press A

eLayer again later, the tri-
ost recent location, not at

, deselect the Rotate tool.

entre of rotation, but the
the ShapeLayer remains.

rs
d perspective to or distort

 

ayer

ayer and its fill, select the
ointer tool. 

ill, select the ShapeLayer

ol from the ShapeLayer
6–16

Eclipse displays a small triangle in the centre of
the ShapeLayer; the triangle is the centre of rota-
tion.

3 Drag anywhere to rotate the ShapeLayer or its
fill.

If you select the ShapeLayer with the Pointer
tool, both the ShapeLayer and its fill elements
rotate. Press and hold the Alt key to rotate only
the ShapeLayer—the fill elements maintain their
position. 

If you select the ShapeLayer with the Hand tool,
only the image fill rotates. To rotate a different
fill element, press and hold the following keys:

4 To move the centre of r
angle to a new positio
ShapeLayer and the fil
of rotation as often as 

5 To move the centre of 
of the ShapeLayer (its 
and click on it.

6 If you rotate the Shap
angle appears at its m
the center.

7 When you are finished

Eclipse removes the c
bounding box around 

Distorting ShapeLaye
Use the Distort tool to ad
a ShapeLayer and its fill.

To distort a ShapeL
1 Select a ShapeLayer. 

To distort the ShapeL
ShapeLayer with the P

To distort only the f
with the Hand tool.

2 Select the Distort to
Toolbox.

Key Effect

S Rotate only the color vignette fill

A Rotate only the transparency fill

S + A Rotate the color vignette and the trans-
parency vignette
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ee the handles and distort
as you like.

ort tool to select and move
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Four handles appear at the corners of the Shape-
Layer’s bounding box. You use the handles to dis-
tort the ShapeLayer or to anchor the corners
while you use the tool. 

The handles initially are hollow, this means they
are not anchored. Anchored handles are solid.

3 To anchor a handle, click it.

4 To free the handle, click it again so that it be-
comes hollow.

5 To distort or add perspective, drag an unan-
chored, hollow handle.

WARNING

At least one handle must be anchored.

The ShapeLayer distorts. The anchored corners
maintain their position.

If you selected the ShapeLayer with the Hand
tool, only the image fill is distorted; the Shape-
Layer does not change.

6 When you stop dragging a handle, Eclipse auto-
matically anchors (and fills) the handle.

You can anchor and fr
a ShapeLayer as often 

REMARK

You can also use the Dist
ShapeLayers.
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elf appears.
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7.1. Shadow Casting

Create the impression of lighting and depth by add-
ing a drop shadow to a ShapeLayer or to an object
you have selected with a ShapeLayer. 

Using the Shadow Casting tool, you can create a
shadow, position and scale it by adjusting the light
source, make it transparent and feather its edges.
The shadow is a servant ShapeLayer that changes
with the source ShapeLayer. You can also work with
it like any other ShapeLayer—fill it, warp it and save
it.

Creating a drop shadow
1 Create a closed ShapeLayer around the object

you want shadowed. 

The ShapeLayer surrounding the object you want
to shadow is referred to as the source Shape-
Layer.

When adding shadows to text, use the text’s
bounding box as the source ShapeLayer. There is
no need to outline the text with a Bezier tool un-
less you want a customized effect.

2 Select the Shadow Caster tool from the Shape-
Layer Toolbox. 

The Shadow Caster sh

The Shadow Caster shelf
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itioned by moving the light
nsparent and it’s edges are

 the shadow to the object. 

, use the right mouse but-
the source ShapeLayer. An
mes solid. To unlock the
ertex again with the right
omes hollow.
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3 Create the shadow by clicking Create in the
Shadow Caster shelf. The shadow ShapeLayer
is a duplicate of the source ShapeLayer except its
content is filled with a shadow. 

TIP

If you do not see the shadow clearly, enlarge it by
dragging the scale slider in the Light Source sec-
tion of the shelf.

The shadow ShapeLayer has the following proper-
ties:

• When the source ShapeLayer is modified (for ex-
ample, moved, transformed, closed, deleted), the
shadow ShapeLayer follows.

WARNING

Changing a shadow ShapeLayer does not affect the
source ShapeLayer with one exception: deleting a
shadow also deletes the source.

• The source ShapeLayer masks the shadow
ShapeLayer.

• If you have skewed the source ShapeLayer or giv-
en it perspective, the shadow conforms to the
skew or perspective. For more information, see
page 7-5.

4 Modify the shadow. Use the controls in the Shad-
ow Casting editor to adjust the shadow. These
controls are described later in this section.

The default shadow

Here the shadow is repos
source. It is also more tra
softened.

5 If you want to, anchor

To anchor a shadow
ton to click a vertex of 
anchored vertex beco
shadow, click a solid v
mouse button so it bec
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 shadow cast by the light.

ze of the shadow.

 to link to the Shadow Col-
 the color of the shadow.

rmines the transparency of

s the shadow edge with the
t inward from the Shape-

egrees of softness to the
 choose from two kinds of
 Vertical.

r softening, the edge fades
tour of the ShapeLayer. 

l softening, manually ad-
pressing the Ctrl key while
hadow with the hand tool.

 shadow ShapeLayer from
. You can move and trans-

dow, but you can no longer
trols in the Shadow Caster
7–4

For a circle or rectangle ShapeLayer, lock onto
vertices of the ShapeLayer’s bounding box, using
either a midpoint or two adjacent corners.

For a ShapeLayer created with the Polygon,
Curve or Bezier tool, you can anchor the shadow
onto either the vertices of the ShapeLayer or
those of the bounding box. 

To anchor the shadow onto the Shape-
Layer’s vertices, select the tool used to create
the ShapeLayer (for example, the Bezier tool)
and click a vertex with the right mouse button.

To anchor the shadow onto the bounding
box vertices, select the pointer tool and click a
vertex with the right mouse button.

6 Render the shadow onto the canvas. 

Click Render in the ShapeLayer Toolbox to ap-
ply the shadow to the canvas. Then delete the
shadow outline by selecting it and pressing the
Delete key.

Shadow Casting Editor controls
• Light Source: The dot represents the light cast-

ing the shadow. Drag it to position the light. 

• Zoom: Lengthens the

• Scale: Controls the si

• Shadow Color: Click
or Editor. Then change

• Transparency: Dete
the shadow.

• Blend Edge: Feather
background, moving i
Layer outline.

• Soften Edge: Adds d
shadow edge. You can
softening: Contour and

- If you select Contou
inward along the con

- If you select Vertica
just the softening by 
dragging along the s

• Detach: Detaches the
the source ShapeLayer
form the detached sha
modify it using the con
dialog.
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lipse\util\custom, but
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w Casting values to their

 render a shadow like any

 distorted Shape-

urce ShapeLayer or given
 conforms to the distorted
r to be on a plane parallel
.

er that has been distorted
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TIP

Detaching a shadow is useful for creating multiple
shadows. Once you have positioned a shadow and
set its properties, click Detach and render it down.
Then create a new shadow using the Create button
and repeat the process.

• Create: Creates a shadow ShapeLayer from the
selected ShapeLayer. A shadow can be created
only if:

- The selected ShapeLayer is not a shadow
ShapeLayer itself.

- The selected ShapeLayer does not already have
a shadow.

• Load: Loads the shadow casting parameters
from a saved file.

• Save: Saves the settings in the Shadow Casting
editor to a file that you name. By default the file
is placed in

C:\Program files\Ec
you can place it anywh

• Reset: Sets the Shado
defaults.

TIP

Position, transform, and
other ShapeLayer. 

Shadow Casting for a
Layer

If you have skewed the so
it perspective, the shadow
ShapeLayer. It will appea
to the source ShapeLayer

A shadow for a ShapeLay
appears on a parallel plan
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If this is not the effect you want, detach the shadow
and adjust it manually.
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peLayer with a depth map
 shading effect. Since the
al, we have used a horizon-
ith a half sphere profile.

sed a customized cylinder

e and other properties in
until you are satisfied with

appears in the 3D Shading

ck Preview.

review in the View menu,
view for the 3D Shading.

 with the effect, render the
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7.2. 3D Shading

Add depth to 2D images with the 3D Shading tool.
Use it to:

• give an image a three-dimensional lift by intro-
ducing depth.

• add specular highlights to an image by changing
the light source and shading properties.

Overview
The following example uses 3D shading to give a
stronger three-dimensional feel to a coffee mug.

1 Open an image of a coffee mug.

Plain mug before 3D shading.

2 Create a closed ShapeLayer around the coffee
mug.

3 Select the 3D Shading tool from the Shape-
Layer Toolbox.

4 Fill the coffee mug Sha
that gives the desired
coffee mug is cylindric
tal shading vignette w
(We could also have u
image depth map.)

5 Adjust the light sourc
the 3D Shading editor 
the effect. 

A preview of the effect 
editor.

6 To see the shading, cli

REMARK

Even if you turned on P
there is no automatic Pre

7 When you are satisfied
ShapeLayer. 
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The coffee mug after the 3D Shading tool has added
shading and specular highlights.

Two types of 3D Shading depth maps
In the 3D Shading shelf, you can choose from two
kinds of shading depth maps: vignette or image. Us-
ing a vignette depth map is faster and easier. For
customized needs, use an image depth map—a
grayscale image with the shading you want.

The 3D Shading shelf
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hading vignettes generate
th a different orientation

y a contour vignette de-
peLayer. For example, if a
s used with a Default pro-
yramid effect. 

ing with Vignette 

ayer.
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Choosing a Vignette depth map 
With a Vignette depth map, shading is generated
from a combination of a vignette (horizontal, verti-
cal, radial, or contour) and a profile (one of seven
possible side views).

Horizontal and vertical s
identical profiles but wi
(rotated 90 degrees).

The shading produced b
pends on the selected Sha
rectangular ShapeLayer i
file, Contour produces a p

Examples of 3D Shad
depth maps

Take a flat circle ShapeL

These pro-
files,...

combined with these vi-
gnettes, produce the shading 
effects shown below...

Horizontal or 
vertical 

Radial 

Default Slope Cone

Half Sphere Cylinder Torus/Dough-
nut

Quarter 
Sphere

Half Cylinder Sphere

Small Sharp Flat surface with 
small, sharp-
edged slope

Round button

Large Sharp Flat surface with 
large, sharp-
edged slope

Round button

Small Smooth Flat surface with 
small, smooth-
edged slope

Round button

Large Smooth Flat surface with 
large, smooth-
edged slope

Round button
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ofile makes the circle look

s achieved by using a large
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Make it look three dimensional using a radial vi-
gnette with a quarter sphere profile. Intensity and
Ambience are also increased in the 3D Shading con-
trols.

The surface is made shiny by adding gloss. Bright-
ness is also increased.

Using a small smooth pr
like a button or knob.

A different button effect i
smooth profile.



7. Special Effects Using ShapeLayers 7.2. 3D Shading

half sphere profile create a

d a quarter sphere profile
ed surface.

pth map profile
pth map profile using the
om the 3D Shading editor.

le from the Profile drop-
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A square button is created with a contour vignette
and a small sharp profile.

This pyramid look is created with a contour vignette
and a default profile.

A vertical vignette and a 
side view of a cylinder.

A horizontal vignette an
create the effect of a curv

Editing a Vignette de
You can modify each de
Profile editor available fr

1 Choose a default profi
down list.
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ditor

ing Vignette depth 

 curve and drag it up or
ow buttons to select and
left or right arrow buttons
t on the left or right. Use
buttons to move the point
ph.

 empty point on the curve.

 it with the middle mouse
7–12

2 To open the Profile Editor, click Edit Vi-
gnette in the 3D Shading shelf.

You see a graphical view of the profile. Points at
0 on the vertical axis are shaded; higher points
are increasingly lighter.

The 3D Shading Profile E

To edit the 3D Shad
map profile
• Select a point on the

down. Or use the arr
move a point. Use the 
to select the next poin
the up or down arrow 
up or down on the gra

• To add a point, click an

• To delete a point, click
button.
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55 represents the highest
 gives a raised effect.
epresents the lowest point

age has a low resolution
 values, noise reduction is
educe banding and pixela-

 image depth map
ShapeLayer. If you use the
ier tool, close the Shape-
e in the ShapeLayer Tool-

 tool from the ShapeLayer

255

0
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• To change the mapping of the vertical axis, use
the mapping sliders at the bottom of the 3D
Shading shelf. If 255 maps to -255, the shading
effect is inverted; in this case e. g. a button looks
pushed in instead of raised.

Saving and reusing a Vignette depth 
map

• To save a shading vignette depth map, click Save
Vignette in the 3D Shading shelf. In the file dia-
log that appears, type a pathname and a filena-
me, and then click OK. The filename extension
.prof is added to a profile file. 

• To reuse a vignette depth map, select a Shape-
Layer, and select the 3D Shading tool. In the 3D
Shading editor, choose Use and click the Open
File button. Then choose the vignette profile file
you want.

Choosing an image depth map
An image depth map is simply an image that con-
tains the 3D shading you want to apply. Only lumi-
nance values are used for shading information, so
the image can be grayscale. Luminance values range
from 0 to 255. A value of 0 is low. A value of 255 is
high.

The following picture shows as side view of a spher-
ical depth map:

A luminance value of 2
point in a depth map and
A luminance value of 0 r
in a depth map.

Because a depth map im
with only 256 luminance
applied automatically to r
tion.

To use a 3D Shading
1 Select an object with a 

Polygon, Curve or Bez
Layer by clicking Clos
box.

2 Select the 3D Shading
Toolbox.

0
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alues below 150, set the

 on but is set at 0. The en-
le.

 part of the map is masked

0

55
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3 In the 3D Shading shelf, turn on Use Image. An
Open File dialog appears.

4 Choose an image. You will find predefined image
depth maps such as cylinder, sphere and
square in the directory
C:\Program files\Eclipse\util\depthmaps

The image depth map is scaled automatically to
fit the selected ShapeLayer.

5 Adjust the controls described on the following
page if you want.

6 Render the ShapeLayer.

Image depth map controls
Smooth: Add smoothing to remove hard edges in
an image depth map.

Depth Clip: Remove luminance values from the
depth map using the depth click slider and text box.
As you drag the slider, the preview image in the 3D
Shading editor shows the effect on the image. Areas
that are black are not part of the depth map.

To remove luminance v
Depth Clip to 150.

Here depth clip is turned
tire spherical map is visib

Depth clip is set to 150, so
or removed.

150

0

2
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3D Shading settings
e 3D Shading editor, click
ialog that appears, type a
 then click OK. The saved
ding filename extension.

ings, click Load. Then use
 appears to select the set-
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Modifying the Light source
• Light source: To position the light source, drag

the white dot on the light source map.

• Radius, Angle: These controls allow you to po-
sition the light source in the plane.

• Height: This lets you adjust the third dimension
of the light source’s position. To make the light
more diffuse, increase its height.

• Intensity: Make the light source brighter by in-
creasing its intensity.

• Gloss: Make the ShapeLayer fill appear shiny or
metallic by adding a specular reflection.

• Ambience: Add ambient light to increase the
amount of atmospheric light. Ambient lights are
independent of the light source. 

Touching up the shading
• Brightness: Control the brightness of the shad-

ed image.

• Contrast: Increase or decrease contrast within
the shaded image.

• Noise: Reduce color banding by adding random
pixels to the image.

• Smooth: If you add noise, soften it by adding an
equal amount of smoothing.

Saving and reusing 
To save all settings in th
Save. In the Save file d
pathname and filename,
settings are given a .sha

To reuse 3D shading sett
the Open file dialog that
tings file you want.
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7.3. Luminance Compositing

Use the Luminance Compositing tool to transfer the
luminance of a base image to a ShapeLayer image
being rendered onto the canvas. Preserving lumi-
nance makes the ShapeLayer image appear part of
the original image rather than an obvious collage.
Possible uses include adding new labels to objects
and replacing pictures of products in a catalogue.

Overview
Here is an example that illustrates luminance com-
position: adding a label to a coffee mug.

1 Open the image of the coffee mug.

2 Create a ShapeLayer, and fill it with the label im-
age. Move the ShapeLayer onto the coffee mug.
Warp the ShapeLayer (see “Warping Shape-
Layers” on page 7-19) so it fits the curve of the
mug.

3 Select the Luminance Compositing tool from the
ShapeLayer Toolbox.

 The Luminance Compositing editor appears.

4 Adjust the controls on
ing editor until the lab
to that of the mug. (Fo
trols, see the next sect

5 Render the ShapeLaye

To adjust luminance
1 Select the image-fill

Pointer tool.

2 Choose the Luminanc
the ShapeLayer Toolbo

 The Luminance Comp
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 to the default values.

ose the dialog but preserve

ayer, click Render in the
 Delete the ShapeLayer
ed it.

uminance Composite set-
oad buttons.

nd texture when 

eful for removing midtone
e preserving the highlights

 a flat label on a patterned
transfer the highlights and
 onto the label, but not the

 patterns is localized with-
remove or reduce them us-

 patterns while pre-
nd shadows
 high. (Depending on your

her 100 or 255 into the text
 slider to its maximum.)
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The Luminance Compositing dialog

Brightness and Contrast are global controls
that affect the composition of the ShapeLayer
and canvas images. 

Use Local Range to specify a range of contrast
that you want to control independently from the
global controls. Then adjust the contrast within
this range using Local Contrast.

3 Adjust the controls if necessary. You may only
need to make adjustments if you need to remove
patterns and texture from the composite, as de-
scribed in the following section. If you do not like
your alterations, you can:

- click Revert to return to the values that were
in the dialog when you opened it.

- click Reset to return

4 Click Memorize to cl
the settings.

5 To render the ShapeL
ShapeLayer Toolbox.
when you no longer ne

If you want to reuse the L
tings, use the Save and L

Removing patterns a
Compositing

The local controls are us
patterns and texture whil
and shades.

Suppose you want to put
coffee mug. You want to 
shades of the coffee mug
patterns. 

If the luminance range of
in the midtones, you can 
ing the local controls. 

To remove or reduce
serving highlights a
1 Set Local Contrast to

range settings, type eit
field or drag the popup
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2 Specify the Local Range. Adjust the Local
Range sliders until the pattern dims or disap-
pears.

3 Adjust Local Contrast to a suitable level. Local
Contrast affects only tones with the local range.

4 Now adjust global Contrast. Global Contrast
(the one near the top of the editor) controls high-
lights and shadows outside the local range.

5 Adjust Brightness. Brightness affects the over-
all brightness of the composition.

6 Render the ShapeLayer. Click Render in the
ShapeLayer Toolbox.

REMARK

When the Luminance Compositing tool is active,
the Canvas Mode menu along the bottom of Eclipse
is disabled.
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 effect by adding shading
mation, see “Warp Shad-

 of the warping procedure.
ve methods are given later

h a filled ShapeLayer. Fill
age, a color vignette, or a

 you want to warp the can-
ith a ShapeLayer and click
 ShapeLayer Toolbox. For
utting the Canvas image

 page 5-20.
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7.4. Warping ShapeLayers

Eclipse includes a sophisticated warping technolo-
gy that you can use to warp ShapeLayers and their
fills, including a canvas image that you have cut out
into a ShapeLayer.

Warping is ShapeLayer-based; only ShapeLayer
fills can be warped. You warp a ShapeLayer, and the
ShapeLayer, in turn, warps the view of whatever is
inside of it. Think of the warped ShapeLayer as a
lens through which you view the contents of the
ShapeLayer. The warp effect is attached to the
ShapeLayer, and the effect is transferred to the
ShapeLayer’s contents. For example, if you warp
the canvas image, you can move the warped Shape-
Layer around on the canvas to warp different areas
of the image.

You can warp a ShapeLayer and its fill elements in-
dependently or in combination. For example, you
can warp an image and a color vignette in a Shape-
Layer at the same time, or warp each individually.
However, once you warp a combination of ele-
ments, you can not warp them individually any-
more. For example, if you warp an image fill and
color vignette fill together, you can not warp just the
image or just the vignette afterwards. Of course, you
can undo or reset the warp effects and start over.

As you warp a ShapeLayer and its fill, you can edit
it. You can move or scale a warped ShapeLayer, and
then warp it so more. You can warp ShapeLayers
that are behind other ShapeLayers and you can cut,
copy and paste warped ShapeLayers.

You can also create a 3D
while warping. For infor
ing” on page 7-28. 

Warping simplified
Here is a simple example
More detail and alternati
in this section.

When warping, start wit
the ShapeLayer with an im
transparency vignette. If
vas image, surround it w
Cutout or Cropout in the
more information, see “P
inside a ShapeLayer” on
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oint by double-clicking in

e the ShapeLayer to add
 grid using the Warp Op-
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Select a filled ShapeLayer. To warp part of the can-
vas image, select the area with a ShapeLayer and
click Cutout in the ShapeLayer Toolbox.

Select the Warp tool in the ShapeLayer Toolbox. 

Create a warp control p
the ShapeLayer.

You can also click outsid
grid lines or lay down a
tions.
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dragging its control points

Warp tool again to clear it.
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Click a warp control point to see its handles. Warp the ShapeLayer by 
or handles.

When finished, click the 
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ntal and one vertical grid
point you clicked. You can
ntrol points to the Shape-

ly effective for warping a
. For example, if you have
ou want to warp the nose,
ctly on the nose to define a

ual grid lines
 the ShapeLayer’s bound-
horizontal or vertical grid
yer.

 line, double-click outside
e bounding box. 

line, double-click outside
 the bounding box.

intersect are warp control

id line through an existing
 the existing line.

g the Warp Options 

tton below the Warp tool
lbox.
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Render the warped area to the canvas image using
either the Render brush or the Render button in the
ShapeLayer Toolbox.

Adding Warp control points
A warp control point is defined by the intersection
of a horizontal and vertical grid line on a Shape-
Layer.

To create a warp control point, you can double-click
on a spot you want to warp or you can create a grid
over the ShapeLayer, either by clicking outside the
ShapeLayer or by entering grid information in the
Warp Options dialog box. 

To create a single Warp control point
Double-click anywhere inside the ShapeLayer to
place a control point at a specific area of the image. 

Eclipse draws one horizo
line that intersect at the 
add as many of these co
Layer as you want.

This method is especial
specific part of an image
an image of a face and y
you can double-click dire
warp control point.

To lay down individ
Double-click just outside
ing box to place a single 
line through the ShapeLa

• To place a vertical grid
the top or bottom of th

• To place a horizontal 
the left or right side of

Points where grid lines 
points.

To add a perpendicular gr
grid line, double-click on

To create a grid usin
dialog
1 Select the Options bu

in the ShapeLayer Too
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Eclipse displays the Warp Options dialog.

You choose which parts of a ShapeLayer to warp,
how many grid lines you want and whether you
want extra handles on the control points.

2 To specify the number of rows in the grid, click in
the Rows text box and type a value.

3 To specify the number of columns in the grid,
click in the Columns text box and type a value.
Eclipse creates a symmetric grid on the Shape-

Layer with the numbe
specify. The grid looks
gular cells.

For example, if you creat
four columns, Eclipse us
teen cells. Each intersect
grid line defines a contro
a grid line and the bound
trol point.

This ShapeLayer has tw
nine at the intersecting g
Layer, three on each side 
the bounding box, and on

TIP

If you have cut out th
ShapeLayer or filled the
age, Eclipse automatica
and Image buttons in 
box, so you are ready to
ShapeLayer. If a color o
inside the ShapeLayer, y
not you want it warped
buttons in the Warp Opt

Adjusting Warp cont
To display a warp contro
intersection or a corner o

Eclipse displays five sm
control point and its han
right at the grid-line int
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farther out along the grid lines above, below, to the
left and to the right of the control point.

REMARK

A corner control point has only two handles.

• To move a warp control point and warp that por-
tion of the ShapeLayer, drag the point.

The point and its handles move, and the grid
lines bend. The portion of the image beneath the
control point warps in the direction you drag.

• To move a handle, poi

Notice that the handle
drag one vertical hand
dle moves with it. If yo
dle, the other one mov

• To break the handles a
separately, hold down 
handle. The handle is n
ner—you can now mov

• To reconnect broken
Shift key and click the

• To add an extra set of
warp control point, se
push button in the Wa

Four new handles app
corners of a rectangle
point. You can move th
ly from the others to cr

• Move multiple warp co
the same time by holdi
the control points you 

Now when you move o
all the other correspo
move in the same dire
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TIP

To select all the control points on a grid line, hold
down the Shift key and click on the line. You can
also use this method to select multiple grid lines.
This is helpful when you want to warp grid lines
symmetrically.

Adding or deleting Warp control points
Once you have started warping a ShapeLayer, you
can add or delete warp control points using two
methods:

• To add a warp control point, double-click within
the ShapeLayer or on an existing grid line.

• To delete a point, press the middle mouse button
and click it.

Resetting a warped ShapeLayer
To reset the image to its unwarped state, click Re-
set Warp Grid in the ShapeLayer Toolbox.

Eclipse hides any selected control points, displays
the grid lines in their original positions, and re-
stores the image to its condition before you warped
it. Notice also that the Rows and Columns text
boxes are active again—you can type in them to
change their values.

TIP

Use the Undo and Redo commands in the Shape-
Layer menu to undo or redo warp actions one step
at a time.

Rendering a warped 
To end warping, deselec
ShapeLayer Toolbox.

Eclipse removes the con
from the ShapeLayer a
bounding box. The Shape

As with other filled Shap
der the warped ShapeLay
ther by clicking Render i
or by using the Render b
useful for blending a war
age with the surrounding
trations below.

REMARK

Depending on the size a
you want to warp, Eclips
ber of vertical grid lines.
not have enough vertica
ror message. This messa
lines to add.

Then delete the ShapeL
paste it somewhere else 
file.

TIPS

For high-quality render
level to 4. To set the lev
Anti-alias.
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s been rendered using the

 rendered around the fin-
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Before deleting a warped ShapeLayer, take a look
at how the warping effect is attached to the Shape-
Layer. Select the Hand tool and use it to drag the
image around inside the ShapeLayer. As you move
the image, Eclipse applies the warp effect to what-
ever portion of the image is visible beneath the
warped portion of the ShapeLayer.

This is the original hand.

Here the hand has been w
gers. The warped area ha
Render brush.
Some unwanted skin was
gertips.
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The unwanted skin has now been removed using the
Restore brush.

Clean up like this is easier if you zoom in. You can
easily switch between the Render and Restore
brushes by pressing M and Q.



7. Special Effects Using ShapeLayers 7.5. Warp Shading

e ShapeLayer Toolbox. 

he Warp Options shelf

rp Options shelf, turn on
ons.

appears.
7–28

7.5. Warp Shading

Eclipse has a special Warp option — Shading. With
the Warp Shading default settings, shadows are
added to areas that are compressed during warping,
and highlights are added to areas that are expand-
ed.

You can control the way a warped image is shaded
using the Warp Shading editor. 

To add shading to a warped image
Select a filled ShapeLayer.

Select the Warp tool in th

Click Warp Options. T
appears.

At the bottom of the Wa
Shading and click Opti

The Warp Shading shelf 
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only the compression cell,
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The Warp Shading shelf

Use the Warp Shading shelf to control the way shad-
ing is applied to the warped image.

• Mode: When Applied on Both is selected, the de-
fault Shading setting (Lighten) applies highlights
to expansion cells and shadows to compression
cells. Areas that shrink during warping become
darker while areas that expand become lighter.
When Shade: Expanded or Shade: Com-
pressed is selected, you can choose to have the
specified areas darkened or lightened. 

• Type: Wrinkles have more oscillation than
Bumps and guarantee continuity at the grid line
junction. Bumps are less rugged and do not guar-
antee continuity at the grid line junction. 

• Shade: When Applied on Both is selected, all ar-
eas of a warped image are given shading. You can
also choose to have shading applied to only ex-
pansion cells or compression cells. The Shade
settings are available for Wrinkles only.

Warp shading applied to
pression cells—the defau

Warp shading applied to 
which is darkened. 
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Warp shading applied to only the expansion cell,
which is lightened. 

• Expansion, Compression: You can control
the magnitude of lightening and darkening by
modifying Expansion and/or Compression, de-
pending on the Shade setting. If you want a
stronger effect than the maximum available with
the slider, you can type in higher values in the
text boxes, to a maximum of 999.

• Shading Noise: If banding appears in the shad-
ing, remove it by adding noise. Too much noise
adds graininess. 

REMARK

In the Warp Shading shelf, options that would
have no effect are gray. For example, when you se-
lect Bumps, the Applied On settings are gray and
unavailable.
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7.6. Blemish Removal 

The Blemish Removal tool removes large blemishes
such as dust, scratches, and other imperfections
without affecting the surrounding area. It is a high-
quality touch-up tool that is far superior to the
Clone brush alone. It can be used only within a
ShapeLayer. Blemish removal does not cause soft-
ening the way the Despeckle effect does.

To remove blemishes
1 Select the blemished area with a ShapeLayer. The

ShapeLayer should be big enough to include
neighboring pixels of the desired replacement
color, but not so big that it includes elements that
might mistakenly be considered blemishes. For
example, when removing a skin blemish, include
only skin of the same color.

2 Select the Blemish Removal tool from the Shape-
Layer Toolbox.

 The Blemish Removal dialog appears.

 

The Blemish Removal dia

3 Adjust the Blemish Re

- Radius determines
region, in pixels, us
The pixels in the ar
mine the color of the
blemish. If there are
the blemish, increas
fault, 5, may make th
curate. For solid col
At 1, Blemish Rem
ShapeLayer size con
us size.

REMARK

The larger the radius, th
takes.

- Threshold controls
identification. The 
smaller the differenc
els to be considered 
tings, even slight 
removed. The highe
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erant the tool is of color variations—and the
less likely it is to detect blemishes. If no blem-
ish is detected, Blemish Removal has no effect.
The default setting is 25.

REMARK

While working with the Blemish Removal, there is
no automatic Preview, even if Preview in the View
menu is on. 

To see the result of changes you have made to
Blemish Removal values, click the Update Pre-
view button.

4 Render the ShapeLayer by clicking Render in
the ShapeLayer Toolbox. Then either delete the
ShapeLayer or use it to remove blemishes from
other areas of the image.

Electrical and telephone wires pose a common re-
touch problem.

With the Blemish Remov
Threshold 2, the lines dis
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A mask is a layer that protects portions of a canvas
image from paint, corrections and effects. Each
Eclipse canvas image has a mask layer with its own
8-bit channel, sometimes called an alpha (A) chan-
nel. Because it is 8-bit, a mask has 256 lightness (L)
values ranging from transparent to opaque. This al-
lows you to give a mask differing degrees of protec-
tion.

Once you have created a mask you can:

• sharpen or soften it using commands in the Mask
menu,

• apply effects and corrections that vary lightness
(L) values,

• invert it,

• clear parts of it using a completely transparent
brush or ShapeLayer,

• save the mask as a file and reuse it,

• combine saved masks into one mask file.

REMARK

You can sometimes skip the need for a mask by ap-
plying corrections or effects within a ShapeLayer.
Reduce or remove the ShapeLayer’s hard edges by
using Blend Edge in the ShapeLayer Toolbox.



8. Masking 8.1. Making the Mask Layer Active
8–3

8.1. Making the Mask Layer Active

To work on the mask layer, click the View Mask (up-
per button) and Active Mask icons (lower button) so
they become orange.

When the mask layer is active, all color channels be-
come inactive automatically. To turn off the mask
layer and reactivate the color layers, click the Ac-
tive Mask icon again.

TIP

Make sure that View →  Preview is turned on so
that you can see the mask as you create it.
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s dialog

color, click the ColorLink
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 mask. You can choose be-
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8.2. Creating a Mask

Once you have made the mask layer active, you can
create a mask by using any of the following tech-
niques, alone or in combination:

• mask color ranges in the canvas image with the
Auto Mask, HSL Auto Mask or Transfer Mask
tools

• mask enclosed areas of the canvas image by sur-
rounding them with filled, rendered ShapeLayers

• mask specific parts of the canvas image by paint-
ing over them with a Color brush. You can also
mask color ranges in specific areas using the Au-
toMask brush.

Mask display color and transparency
Areas on the mask layer that you fill in become solid
blue. If you want, you can change the color and
make it more transparent so you can see through it.
These controls affect only the appearance of the
mask, not how it functions. 

To change the mask display color and 
transparency
1 Choose Mask → Display Options. The Mask

Display Options dialog appears.

The Mask Display Option

2 To change the mask 
button. In the Mask C
choose a different colo

3 Select how to view the
tween the mask showi
the exposed areas.

4 To change the transp
use the Transparency p
0 the mask is displayed
the mask is displayed a

REMARK

Mask Color Transparen
ency for viewing purpos
image beneath the mask.
tual transparency of the
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TIPS

When you set a display transparency value for the
mask color, you may be unable to visually deter-
mine the actual tonal values in the mask. Return
the display transparency to 0 in the Mask Color di-
alog to view the actual tonal variations in the
mask.

If you want to make the mask invisible once it is
created, turn off the View Mask button in the dash-
board instead of setting the Mask Color Transpar-
ency to 0.

Tip
Controlling the actual transparency of 
the mask

You can also vary the actual transparency of the
mask (as opposed to its display transparency). A
semi-transparent mask is only partially protective. 

The method you use to control mask transparency
depends on the tool you are using. For example,
when painting on the mask layer with a brush, con-
trol transparency in the Brush shelf. When using a
ShapeLayer fill, give it transparency in the Shape-
Layer Fill shelf. Methods for adding transparency
are described later in this chapter.
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8.3. Using a Mask

When you have finished creating a mask and are
ready to use it, turn off Active Mask and turn on
Use Mask.

Select Use Mask to protect the canvas image as you
use other tools.

TIP

If you do not want to see the mask, click the View
Mask icon to turn it off. The mask is invisible but it
will protect your work as long as Use Mask is se-
lected.
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8.4. Masking Color Ranges 

Using Auto Mask and HSL Auto Mask 
Use Auto Mask and HSL Auto Mask to create a
mask based on a selected range of colors. You spec-
ify the color range by typing values or by picking
colors from the image. 

REMARK

If you have ShapeLayers on your image and the
ShapeLayer→  Render Mode →  All ShapeLayers
is selected, the Auto Mask and HSL Auto Mask tools
create the mask within the ShapeLayers even if
they are not selected. 

To avoid this, either select ShapeLayer → Ren-
der Mode →  Selected ShapeLayers or close
the ShapeLayer Toolbox to hide the ShapeLayers.

To create a mask by building a color 
range
1 Choose Mask → Auto Mask. The mask layer

becomes active.

The Auto Mask dialog appears. All the color
channels, RGB or CMYK, are selected and all
sliders are set to 0.

The Auto Mask dialog

2 If you want a color cha
select it.

3 Establish the core rang
of the following techni

- either pick a range
Pick button and the
in the image. If you w
the mask, press and
button and drag thro

- or specify the maxim
values you want to 
dragging the channe
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Smooth value.

alue, the softer and larger

reates a maximum transi-
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 the mask will look if you
. All opaque portions of the
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 You can apply it in its in-
n choose Mask → Invert
sk.
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over, click Reset.

e color ranges, click Apply
ecified color ranges to the
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ing the color values in the text boxes next to the
sliders. The right slider and text box control the
maximum color value. The left slider and text
box control the minimum color value.

EXAMPLE

If the Red channel has a maximum value of 60 and
a minimum value of 20 and the Green and Blue
channels are set to 0, all colors in the image that
have a red value between 60 and 20 and Green and
Blue values of 0 are captured for the mask.

4 When the core areas you want to mask are blue
(or whatever the current mask color is), switch to
using the Smooth spin buttons to soften and
blend the edges of the mask. When you use
Smooth, Eclipse builds a transition from the
mask area out to the clear areas. 

A Smooth value of 0 means that there is no transi-
tion between the clear (0) mask areas and the
opaque (100) mask areas.

In the picture above, the areas that look black have
been masked by using the Pick feature to select pix-
els.

Here the mask has been
ribbon by increasing the 

The higher the Smooth v
the transition area.

A Smooth level of 100 c
tion and replaces the cle
mask values.

5 If you want to see how
invert it, select Invert
mask become transpa
tions become opaque.
verted state, or you ca
after you apply the ma

6 If you decide you do n
or if you want to start 

7 After you have built th
Mask to apply the sp
mask layer.

A confirmation dialog 
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8 Click Yes to apply the mask, or click No to cancel
the operation. The Auto Mask dialog remains
open no matter which option you select, and the
mask layer remains active.

REMARK

The mask layer also remains active when you close
the Auto Mask or HSL Auto Mask shelves.

To create a mask by building HSL color 
ranges
When working on an RGB image, you can use HSL
Auto Mask to create a mask using hue, saturation
and lightness color properties rather than ranges of
CMYK or RGB colors. The HSL Auto Mask dialog
looks and functions just like the Auto Mask dialog
and you use it the same way. The only difference is
that you select HSL ranges rather than selecting col-
or channel ranges.

Using Auto Mask with ShapeLayers
You can use ShapeLayers to limit an Auto Mask or
HSL Auto Mask to specific areas of an image. This is
helpful because different areas of an image often
have unique color ranges; by working within a
ShapeLayer, you can capture the color ranges
unique to that area.

1 Draw and select one or more ShapeLayers. 

2 Choose either Auto Mask or HSL Auto Mask
from the Mask menu.

3 Use the tool dialog to
scribed under “To cre
color range” on page 8

Eclipse restricts the m
ShapeLayer, even if y
ShapeLayer. 

4 Click Apply Mask.

REMARK

You can apply the most 
Auto Mask color range t
AutoMask brush. For m
8-11.

Using Mask Channel 
Use the Mask → Trans
colors used on the mask 

To transfer colors to
1 Choose Mask → Chan

layer becomes active a
Channel Transfer dialo
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The Mask Channel Transfer dialog

2 To increase or decrease the amount of color in a
channel that Eclipse uses to build the mask, type
in percentages in its text boxes or use the popup
sliders. 

For example to increase the amount of red by 20
percent, type 120 in the red text box. To de-
crease red by 20 percent, type 80.

Eclipse shows you the effect on the mask layer of
your image.

3 To reset the text boxes to 0 and start over, click
Reset.

4 To apply color changes to the mask, click Trans-
fer.

5 To save Transfer mas
name the file in the Fil

A default filename Trans
images. For RGB image
TransM3c. You can type 
want. A filename extens
filename is assigned auto

6 To reuse saved Transfe

Then use the File Open d
the Transfer Mask file yo
file has a .transm4c or .
sion.
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8.5. Creating a Mask with a Brush

Using a brush to make a mask is much the same as
painting on an image’s color channels, except that
you work on the mask layer. 

You can use a Color brush, a Correct brush, an Ef-
fects brush and so on. The Brush shelf also includes
an AutoMask brush that you can use to brush on the
most recently used Auto Mask, HSL Auto Mask or
Mask Channel Transfer color ranges. Using the Au-
toMask brush is similar to brushing on effects or
corrections.

To create a mask with a brush
1 Make the mask layer visible and active by select-

ing the View and Active Mask icons.

2 Choose Brush or Brush Palette from the Win-
dow menu to choose the type of brush you want.
In general, you will want to use the Color or Au-
toMask brush, although you can use others, like
Smear or Pattern.

3 Paint on the image. To unpaint, use the middle
mouse button. 

4 To adjust the transparency of the mask paint, use
the Brush shelf’s Transparency slider or text
box before or as you paint. 

5 To use the mask:

- make the color channels active once more by
clicking the Active Mask icon to deselect it.

- click Use Mask. 

TIP

If you do not want to se
click the View Mask icon

Using the AutoMask 
Use the AutoMask brush
color ranges you select in
Mask or Mask Channel T
AutoMask brush is simila
fects brush, except you ar
than painting an effect or

To use the AutoMas
1 Make the mask layer a

2 In the Brush shelf, cho

3 The AutoMask brush 
you selected in the Aut
Mask Channel Transf
mask layer. 

4 Paint on the canvas im

Wherever the AutoMa
or range that matches
Mask, HSL Auto Mask
dialog, Eclipse applies

5 If you want to unpaint
mouse button.
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6 If you want to change the AutoMask settings,
click Options in the Brush shelf.

The last mask shelf you used (Auto Mask, HSL
Auto Mask or Mask Channel Transfer) appears.

REMARK

When you open Auto Mask, HSL Auto Mask or
Mask Channel Transfer with the Options button of
the Brush shelf, Eclipse applies mask color to the
image based on its settings. This may obscure your
paint strokes. Change the settings in the Auto
Mask, HSL Auto Mask or Mask Channel Transfer
dialog, and then close the dialog to resume Auto-
Mask brushing.

Alternatively, if you want to leave the mask dialog
open, turn off Preview in the View menu.

7 When you want to use the mask, make the color
channels active again and click Use Mask.
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8.6. Creating a Mask with ShapeLayers

You can create a mask inside any closed Shape-
Layer. When you draw a ShapeLayer on the mask
layer, it fills automatically with the mask color.

To create a mask with a ShapeLayer
1 Make the mask layer active.

2 Select the ShapeLayer tool you want from the
ShapeLayer Toolbox.

3 Draw a ShapeLayer on your image. Select Close
if necessary.

4 When you finish drawing the ShapeLayer,
Eclipse fills it with mask color.

5 To adjust the mask transparency, use the Trans-
parency slider or text box in the ShapeLayer Fill
shelf.

6 Render the ShapeLayer onto the mask layer by
clicking Render in the ShapeLayer Toolbox.

7 To use the mask, clear Active Mask and select
Use Mask. 

Masking a ShapeLayer Fill
An image used as a ShapeLayer fill cannot be
masked directly, but you can mask it by following
this procedure. 

To mask an image inside a ShapeLayer
1 Open the image as a canvas image.

2 Create the mask over t
of the techniques desc

3 Save the mask and clo

4 Open the image you w
age.

5 Create a ShapeLayer an
masked.

6 Click the Mask button
shelf to open the mask

TIP

If you distort a masked
want to replace the mas
mask in the ShapeLayer
mask. If you turn off the
cleared and the new m
proper distortion.
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introduces distortion into
 Avoid using Sharpen re-

es degraded by sharpen-
the Soften command in the

as of a mask, paint on it

d to even out differences
. The resulting effect is a
 This process is analogous

age. 

ten. The mask layer be-

 softening and click Soft-
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8.7. Mask Operations

Sharpening a mask
If you have a mask that is too soft or blurry, you can
improve its quality with the mask’s Sharpen effect.
Sharpening increases the visual differentiation of
pixels on the mask layer. This process is analogous
to sharpening a canvas image. 

REMARK

Apply color corrections to the mask before using
Sharpen.

To sharpen the mask
1 Choose Mask → Sharpen. The mask layer be-

comes active automatically.

2 Specify the amount of sharpening using the slider
or text box.

3 Click Sharpen to apply the sharpening.

Tips

TIPS

The sharpening process 
tonal areas of the mask.
peatedly. If a mask becom
ing, try restoring it with 
Mask menu.

To sharpen specific are
with an Effects brush.

Softening a mask
Use the Soften comman
among pixels in a mask
softer, even blurry mask.
to softening the canvas im

To soften a mask
1 Choose Mask → Sof

comes active.

2 Specify the amount of
en.
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tus box as it inverts the
 result when it is done.

uto Mask shelves contain
 you can use to invert a

yer
hat you have applied to the
s not been applied to the

example, a ShapeLayer fill
ed to the mask remains af-

r.

x that appears, select Yes
o to cancel the command.

py mode, you can restore
as in when you last saved
g File →  Restore.

Masks
ou can save it as a file and
e image or with other im-
e. 

→ Mask.
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Applying Effects and Corrections to a 
mask

You can apply all effects and corrections to a mask. 

To apply effects and corrections to a 
mask
Make the mask layer active by clicking on the Ac-
tive Mask icon (see page 8-3).

REMARK

When applying a correction to a mask, also make
one of these color channels active in the correction
dialog:

For an RGB image, select the Red channel in the
correction dialog before making the correction.

For a CMYK image, select the Cyan channel in the
correction dialog before making the correction.

Inverting a Mask
When you invert a mask, all opaque portions be-
come transparent, and all transparent portions be-
come opaque. 

To invert the mask
1 Choose Mask → Invert.

Eclipse displays a warning box that asks if you
want to invert the mask.

2 Select Yes to invert the mask or No to cancel the
command.

Eclipse displays a sta
mask and displays the

TIP

The AutoMask and HSL A
an Invert checkbox that
mask as you create it.

Clearing the Mask La
Use Clear to erase paint t
mask layer. Paint that ha
mask is not cleared. For 
that has not been render
ter clearing. 

To erase the mask
1 Choose Mask → Clea

2 In the confirmation bo
to clear the mask or N

TIP

If you are working in Co
the mask to the state it w
or retained it by choosin

Saving and Opening 
Once you create a mask, y
use it again with the sam
ages that are the same siz

To save a mask
Choose File → Save As 
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bine masks are (Counter-
):

se uses those parts of each
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ew mask.

ask: Eclipse adds to the
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Use the file dialog that appears to name and save
the mask file.

To open a mask file
Choose File → Open → Mask.

Use the file dialog that appears to select the mask
file you want.

Combining Masks
Use the Combine command in the Mask menu to
combine the current mask layer with a mask you
created and saved previously. The saved mask must
be the same size as the current image.

To combine a mask file with the current 
mask
1 Choose Mask →=Combine.

2 In the file dialog that appears, select the mask
you want.

A Combine Mask dialog box appears with four
icons that show four ways Eclipse can combine
the mask you selected with the current mask. 

For example, if the current mask is square and
you want to combine it with a saved circular
mask, the options in the Combine Mask would
appear as follows.

Current mask (right) and

Combine Masks dialog

The four ways to com
clockwise from top left

- Intersection: Eclip
mask that overlap, 
new mask.

- Combination: Ec
masks to create the n

- Add to Current M
current mask a nega
file.
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r with a Color brush or one
es

 the mask layer

SL Auto Mask tool to ex-

ith the same name.
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- Subtract from Current Mask: Eclipse adds
the selected mask file to a negative of the cur-
rent mask.

3 Select the icon that represents the way you want
Eclipse to combine the mask, and then click
Combine.

Eclipse opens the mask file, combines it with the
existing mask and displays the result on the im-
age.

4 To undo the combination, close the Combine di-
alog box and then choose File → Restore.

Editing a saved mask
Removing parts of a mask
You can remove parts of a mask with a brush or a
ShapeLayer by using the Transparency option in
the Brush shelf or the ShapeLayer Fill dialog. 

For example, if you set the Transparency of a Col-
or brush to 100, and then use the brush to paint
over an existing mask, you remove the mask. You
are actually making the mask color completely
transparent. You can do the same thing with a
ShapeLayer. Draw a ShapeLayer over an existing
mask, and then use set the Fill Attributes Trans-
parency to 100. 

Adding to a mask
You can add to an existing mask using any of the fol-
lowing techniques:

• paint on the mask laye
of the AutoMask brush

• apply a ShapeLayer to

• use the Auto Mask or H
tend the mask.

Then save the mask file w
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9.1. Preferences

Preferences are operating parameters that you use
to customize the way you work with Eclipse. The
preferences you choose remain in effect until you
change them and Eclipse uses them whenever you
start the program. You can select the Preferences
commands before you open or create an image in
the main window. Eclipse maintains your prefer-
ences settings in a file named .EclipsePrefs,
which is stored in your home directory.

There are two types of preferences: General and
Stylus Pressure.

• Use General preferences to affect general oper-
ating conditions for Eclipse such as the default
display size of an image, the anti-aliasing level,
the number range used for specifying color val-
ues and the separation file that is used for con-
verting an RGB image to CMYK. Also use it to
choose whether you work on images in Copy or
Original mode, to set a directory path for tempo-
rary image files and to set the cache size.

• Use Stylus Pressure preferences to adjust the
pressure sensitivity of your tablet.

WARNING

You must quit and restart Eclipse for new Prefer-
ences to take effect.
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g

ost recent settings for the
start Eclipse for the first
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gs to use Eclipse.

e Brushing: When paint-
 of the brush is outlined in
 for the overlay (controlled
ot want to see this outline,
w While Brushing.

rsor improves brush per-
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9.2. Setting Preferences

The File → Preferences submenu contains two
commands: General and Stylus Pressure. Each
command displays a dialog box. Because preferenc-
es affect the way the system works, these dialog box-
es are modal —you can not do any other work with
Eclipse until you close them. You can open only one
Preference dialog box at a time. The following sec-
tions explain what the preferences do and how to set
them.

General preferences
Choose File → Preferences → General.

Set the preferences you want in the Controls Prefer-
ences dialog that appears.

The General Preferences dialo

The dialog displays the m
preferences. When you 
time, it displays the def
have to change any settin

• Cursor - Show Whil
ing, the circumference
whatever color is used
by AltGr C). If you do n
turn off Cursor - Sho

TIP

Turning off the brush cu
formance.
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lying effects and color

ng ShapeLayers. The con-
s give you the chance to
mmand before it starts. If
ce off, the program does
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to use Eclipse it is best to
ssages turned on.

 Push the ColorLink but-
ound Color Editor.

ration if you output image
odels (for example, if you

e to CMYK). You create a
e CMYK Separator. Load a
ing the Open file button. If
ut Use Separation is on,
eparation file.

erty sets the level of Anti-
 smooths jagged edges
e rendering. Anti-aliasing
9–4

• Channels - Link View/Active: When Link
View/Active is turned on (the default condi-
tion), making a color channel visible also makes
it active, and vice versa. This means you can only
work on a color channel that you can see. 

When Link View/Active is turned off, you can
view a color channel without being able to work
on it or, alternatively, you can work on a color
channel without viewing it. 

REMARK

Link View/Active also affects the mask layer. 

• View Single Channel: Determines how
Eclipse displays a color layer of your image when
you view only one layer at a time.

• Image Pan: The Image Pan preference deter-
mines how Eclipse displays your image as you
pan with the right mouse button. 

- Slow displays the i
pan. You get visual fe
of the image but pan

- Fast does not displa
release the right mou

• Confirmation - Sho
This determines wheth
mation dialog boxes 
mands such as app
corrections or renderi
firmation dialog boxe
cancel or abandon a co
you turn this preferen
not display the confirm

TIP

While you are learning 
leave Active Confirm Me

• Background Color:
ton to open the Backgr

• Separation: Use Sepa
files to different color m
convert an RGB imag
separation file with th
separation file by click
no file is specified, b
Eclipse uses a default s

• Anti-alias: This prop
aliasing. Anti-aliasing
within images for imag
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produces an array of pixels for each pixel Eclipse
calculates. For example, an Anti-alias level of 3
produces a 3x3 array for each pixel. The higher
the value, the more processing Eclipse must per-
form. An anti-aliasing level of 0 turns anti-alias-
ing off. The anti-aliasing range is 0 to 3.

   

When anti-aliasing is set at 0 so it is turned off, ren-
dering a ShapeLayer fill with diagonal edges can re-
sult in “the jaggies.”

You can get rid of jagged edges by setting anti-alias-
ing to 3. 

Remember to turn an
to 0 when you no long

TIPS

You can also set the an
ShapeLayer →  Anti-alia

Anti-aliasing is memory 
level doubles rendering
mance, keep anti-aliasi
turn it on when render
anti-aliasing level of 1 or
age fill. Use a level of 3 w
or for any operation w
jagged. 

• Color Range: Determ
dot percentage (0-100
for numeric display of

When 0-100 is selecte
rection and effects win
are percentage values
values you type are act

• Load Range With Im
TIFF and Eclipse Tile F
information. When Lo
is turned on, color ran
an image file overrides
Eclipse.

• Range Mapping: De
per limits of the Color
values can range from 
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not be larger than the 100% value. Use this pref-
erence to adjust how Eclipse displays images
from peripheral equipment such as scanners,
which may use different color range values.

• Units: Use the Units pop-up menu to choose
the unit of measurement for Eclipse operations:
Inch, mm, cm, Point, Pica, or Pixel. Units de-
termine such things as the calibration of rulers
and the way resolution is calculated and dis-
played.

• Pixels/Unit: This gives the resolution of the im-
age.

To change the output resolution for your images,
type a value in the Resolution text box. When
Units is set to Pixel, the resolution cannot be
changed.

• Zoom: Determines the zoom level Eclipse uses
to display images when it opens them. 

1:1: Eclipse displays the image at a 1:1 zoom level. 

Fit to Screen: Eclipse adjusts the zoom level au-
tomatically so that the entire image is displayed.
This is the default.

• Work on: Use the Work on preference to
choose how you want to work with your image
files: in Copy mode or Original mode.

- Copy mode: When you open an image,
Eclipse makes a copy of the image file, and

you work on the cop
are made to the wor
Copy mode, you can 
commands in the Fil
changes you make to
affecting the origina
fect your original im
command.

- Original mode: W
you work on the or
Original mode onl
limited disk space.
cannot use the Rest
in the File menu. Y
source image. If yo
mode, make a backu
before you start.

WARNING

We strongly suggest th
Copy mode!!!

• Temp File Path: A
Eclipse makes copies o
rary files or temp files.
box indicates the path
which Eclipse stores th
By default, temporar
C:\Temp directory. 

If you want to chang
name of another direc
text box.
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You might want to create a new directory in your
home directory to use for temporary files. To op-
erate properly, Eclipse must be able to write tem-
porary files to the directory, so be sure to choose
a directory for which you have write permission. 

TIPS

Eclipse runs faster if you specify a temp file direc-
tory on a fast internal hard disk drive that has
plenty of room.

Do not specify a temporary directory where im-
age, mask or other files are stored.

• Cache Size: Eclipse uses a memory caching
scheme that automates the way it uses your com-
puter’s memory and disk space. Depending on
the size of the images you are working with,
Eclipse caches some or all of the image into mem-
ory to provide real-time, interactive manipula-
tion.

The amount of memory (RAM) that Eclipse
needs depends on how much editing or compos-
ing you do during a work session. In general, you
need approximately 35 MB of RAM for each
Eclipse main window that is running. Therefore,
if your computer has 64 MB of RAM, do not in-
crease the cache size above 29 MB (64 MB - 35
MB = 29 MB). 

If your computer has more RAM available, and if
you do not want to run other programs while you
are running Eclipse, you can increase the cache
size up to 200 MB. 

The following rule allow
size:

Total RAM - 35 MB = Ca

WARNING

If you set Cache Size too h
places some Eclipse pro
your hard disk, making 
run out of swap space, t
Eclipse.

TIPS

Do not lower Cache Size 

• Click OK to activate y
ences or Cancel to 
adopting the changes.

WARNING

You must quit and resta
ences to take effect.

Stylus Pressure Prefe
Use Stylus Pressure pref
sure sensitivity of your ta

To set Stylus Pressu
1 Choose File → Prefe

sure.

Eclipse displays a di
graph. You adjust the 
tablet stylus by reshap
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The Stylus Pressure dialog

2 Point to a graph point on the curve, then click and
drag the point. To increase sensitivity, drag the
point above the curve. To decrease sensitivity,
drag the point below the curve. To reset the
curve, click the Reset button. 

3 Click OK to close the dialog box and save the
changes. Click Cancel to abandon the changes.

TIPS

If you have a tablet with its own pressure adjust-
ment, adjust the tablet’s settings first, and then
fine-tune the pressure using the Eclipse Stylus
Pressure preferences.
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10.1. Integrated CMYK Separation

Integrated into Eclipse is a fully featured set of tools
for creating high-quality CMYK separations from
RGB images. You can use CMYK Separation with-
out making any adjustments to produce color sepa-
rations for SWOP color printing. (SWOP is an
acronym for Standard for Web Offset Publications.)

CMYK Separation features a system that uses the
density properties of process printing inks to deter-
mine the exact amounts of cyan, magenta, yellow,
and black necessary to accurately match a particu-
lar color. For customized needs such as this,
Eclipse’s CMYK Separation provides all the tools
you need to create professional-quality image sepa-
rations for print. 

CMYK Separation provides tools for color correc-
tion, black generation and on-screen proofing of the
printed piece. CMYK Separation, through Eclipse,
supports connectivity to desktop publishing soft-
ware applications for sharing image separation files
with desktop systems.

With CMYK Separation you can control:

• scaling of RGB values during conversion to
CMYK

• Gray Component Replacement (GCR)

• ink optical properties, dot coverage and dot gain

• Undercolor Removal (
dition (UCA)

• ink values according to

• highlight and shadow 

• black generation inclu
K boost and K shadow

To help you evaluate the q
CMYK you can preview th
For accurate color readi
separation probe. You ca
aration settings and use t

To open the CMYK S
Choose Window → CM

The CMYK Separation di

REMARK

The separation is availa
an RGB canvas.
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The CMYK separation dialog

The graph depicts output values for all shades of
gray (R = G = B) to give the feel of the separation. If
you want to know how a gray value of 50 percent
will be separated, look at the graph lines intersect-
ing the middle vertical line in the graph. 
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10.2. Making CMYK Color Separations

CMYK Separation’s default settings, ink densities
and dot gain compensation values yield good results
for most images using standard SWOP inks. If you
want to make custom color separations, you can
make the following adjustments.

Scaling RGB Highlights and Shadows 
RGB input values can be scaled according to the
RGB highlight and shadow values. By default, RGB
values between 0 to 100 are converted to CMYK val-
ues between 0 to 100, so no scaling occurs. 

Unless you want to re-interpret the RGB input,
there is no need to change the Highlight or Shadow
RGB values. If, however, you want to lose shadow
detail, raise Shadow to e. g. 10. Then all RGB values
below 10 would be considered 0 (solid black), all
other RGB values stay the same. Alternatively, you
can remove highlight detail by lowering Highlight
to e. g. 90. Then all RGB values above 90 would be
scaled to 100 (white, no ink).

Adjusting Gray Component Replacement 
(GCR)

The purpose of gray component replacement (GCR)
is to control ink flow, to provide better neutrality,
and to enhance contrast. During the GCR process,
CMYK Separation replaces the three-color gray
component (cyan, magenta, and yellow) with a pro-
portional amount of black ink. The gray component
is equivalent to the minimum percentage of cyan,
magenta, and yellow in any color. Eclipse automat-
ically estimates the GCR value, but you can alter it. 

To alter the GCR
1 Click Black. The Bla

pears.

The Black Generation dia
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2 Select GCR.

3 Change the Start, Max and quarter tone values
for GCR by adjusting points on the graph or by
entering values in the text boxes below the graph.
All colors having a gray component within this
range are produced with a percentage of black
and are correspondingly reduced in the other
three colors (C, M, Y).

When Start is set to 0 and Max is set to 100, the
percentage of black generated is equal to the per-
centage of the gray component. The amount of
gray component “going out” is equivalent to the
amount of black “going in.”

When Start is greater than 0 percent and Max is
less than 100 percent, the amount of black gener-
ated and the amount of three-color reduction is
proportionally less than the gray component. En-
tering a Max value of 0 percent turns off the black
film. This means the image is printed in three col-
ors instead of four. 

Using Black to control ink flow on the 
press

When you replace an image’s gray component with
black, the maximum dot coverage of that image is
reduced, which controls ink flow when printing. It
can also result in a significant reduction of ink on
the press. Replacing too much gray component re-
sults in too little ink on the press and causes a desat-
uration of color. Maximum dot coverage is the
highest total percentage of dot (combining all four
separations) anywhere on the image. You should

control the maximum do
most printing requirem
“Dot coverage and dot ga

Editing the inks’ opt
An RGB image is conver
inks’ optical properties. B
prepared based on SWOP
separation to use non-sta
Inks and Load Inks butto

To specify new ink v
1 Click Edit Ink in the

The dialog that appea
that appears when yo
Inks.
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The Edit Inks dialog

2 Type new values for Cyan, Magenta, Yellow
and Black inks. 

3 To save the new ink values, click Save. Type a
name for the new ink file, and click OK. Ink files
are saved in a directory called 
C:\Program files\Eclipse\util\custom.

To use a saved Inks 
Click Load Ink in the CM

Dot coverage and do
You can cap the maximu
pensate for dot gain usin
dialog box. If you save an
and dot gain values are a
not be printed, there is n
or dot gain values.

CMYK Separation autom
total ink values do not 
coverage value specified i
The maximum dot cover
default. The value you n
output media. 

To limit dot coverag
Set a value for Max. D
Inks dialog.

As for dot coverage, the c
dot gain varies with the t
ical dot gain value is 7. T
set Dot Gain to the perc
dot size reduced.

To compensate for d
Set Dot Gain to the perc
dot size reduced.

The dot gain compensat
size of the midtone. Its ef
ther side of the curve from



10. Creating Color Separations 10.2. Making CMYK Color Separations

ording to hue, click Hue.
ilar to the dialog that ap-
orrect → Selective Col-
or information on the
ent correction, see page

cement dialog 

hue
 

ink buttons along the top
eplacement Correction di-
lor Editor, then use it to

e image, click Pick in the

the hue altered.
10–7

Undercolor Removal and Additions 
(UCR/UCA)

Once the initial CMY values are derived, you can
further adjust inks by setting Undercolor removal
(UCR) or Undercolor addition (UCA). UCR is simi-
lar to GCR in that it changes cyan, magenta, and yel-
low levels, primarily to achieve color balance and
match ink values to those in Proof Inks. Adjusting
UCR also reduces ink coverage and neutralization.
UCA is used for media that require higher ink cov-
erage. 

The process of UCR/UCA is controlled by the four
parameters located under the Undercolor Removal
and Additions section of the CMYK Separation. 

• Start value sets a threshold for where the UCR/
UCA process will start to take effect. For exam-
ple, a Start value of 70 percent will not allow the
UCR/UCA to affect any ink value below 70 per-
cent. 

• Cyan Max. specifies the offset value to be sub-
tracted or added at the 100 percent cyan ink lev-
el. A negative value removes ink (UCR). A
positive value adds ink (UCA). The amount of
UCR/UCA is proportionally adjusted for the ink
between the start and the 100 percent level.

• Magenta Max. and Yellow Max. are the max-
imum UCR/UCA offsets for magenta and yellow
inks.

Hue Correction
To adjust ink values acc
You will see a dialog sim
pears when you choose C
or Replacement. (F
Selective Color Replacem
2-23)

The Selective Color Repla

To correct a target 
1 Select the hue to alter.

Click one of the ColorL
of the Selective Color R
alog to link to the Co
choose a hue. 

To pick a hue from th
Color editor.

2 Specify how you want 
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Type the percentage of Cyan, Magenta or Yellow
that you want to add or subtract in the text boxes
below the color swatch. 

3 Establish a target range, if desired. 

To extend the range of hues that will change, type
a value in the Range text box. A range of 10
means hues with values 5 percent above and 5
percent below the target hue will also change.
The values entered in the Cyan, Magenta and Yel-
low boxes apply equally to all hues in the target
range. 

4 Create a gradual tonal drop off using Smooth.

A Smooth value of 20 means that there will be a
gradual reduction in change to colors within 20
percent on either side of the target hue range. 

Tone Curve
You can further fine-tune Cyan, Magenta and Yel-
low inks by adjusting the tone curve. The benefit of
color correcting at this point is that the correction is
restricted by the dot coverage and compensated by
the dot gain.

To adjust the Tone Curve
Click Tone.

A correction dialog appears similar to those access-
ed from the Correct menu. 

The Tone Curve dialog

Highlight and Shado
You may also scale the r
highlight and shadow val
example, if the lightest p
ues that are too high (as 
tion probe), reduce them
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re black wherever red ap-
 swatch and type the per-
nt added. Use Range and
re hues and create a grad-

ut according to a shadow
e Black setting at the bot-
n.

tions
y necessary adjustments,

ocess for the image takes
en it is finished, the RGB
image.
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Cyan, Magenta or Yellow in the Highlight col-
umn of the CMYK Separation dialog.

Black generation
Besides adjusting GCR and UCR/UCA values, you
can affect how black is generated in three ways: K
Curve, K Boost, and K Shadow offset. 

K Curve adjustment
You can fine-tune black by adjusting the K curve—
just as you can fine-tune Cyan, Magenta and Yellow
using the Tone curve.

To adjust the K curve
1 Click Black. 

2 In the Black Generation dialog box that appears,
select K-Curve. 

3 Adjust the amount of black at each eighth tone ei-
ther by dragging a knot on the graph or by using
the arrow buttons. 

4 Click OK.

K Boost
When black replaces the gray component of an im-
age, it can enhance that image’s contrast. You can
use the CMYK Separation to increase the amount of
black generated within a particular color. Use Black
Boost to add or “boost” black ink for a specific hue.

Using Black Boost is similar to using the Selective
Color Replacement correction (described on page
10-7).

 The Black Boost dialog

For example, to print mo
pears, put red in a color
centage of black you wa
Smooth to encompass mo
ual tonal change.

K Shadow offset
Scale the black ink outp
value you specify using th
tom of the Shadow colum

Making CMYK Separa
Once you have made an
click Convert. 

The actual separation pr
place pixel by pixel. Wh
image becomes a CMYK 
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tter may view 0 percent as
t be considered 228. The
ft for other purposes.

 of the CMYK conversion,
 CMYK Separation dialog.

 parameters, changes are

preview is approximate,
re displayed in the moni-
onitor is well calibrated,

nly be very slight differ-
en image and the proofed

values that will result from
obe button in the Separa-
n the image to place the
r probe, each probe you

entially. You can move a
ere is no need to click the
 shelf.

arameters
 separation parameters in
 conversions. Using differ-
 useful for creating separa-
of output. A .sep file can
ing RGB images to CMYK

e Renderer and Eclipse I/
on from the General Pref-
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10.3. Other Separation Controls

The CMYK separation dialog

Color Range mapping
The percentage CMYK inks are mapped to physical
pixel values between 0 and 255 for storage. By de-
fault, 0 percent maps to 0 and 100 percent maps to
255. You can specify a different mapping by modify-
ing the Color Range output values in the CMYK Sep-
aration dialog.

For example, an image se
28 and 100 percent migh
out-of-range values are le

Separation Preview
To see an approximation
turn on Preview in the
As you modify separation
visible in the image.

WARNING

Keep in mind that the 
since all CMYK images a
tor’s RGB space. If your m
however, there should o
ences between your scre
output. 

Separation Probe
To find out actual CMYK 
a conversion, click the Pr
tion dialog. Then click o
probe. As for the regula
place is numbered sequ
probe by dragging it—th
Move button in the Probe

Reusing Separation p
You can save customized
a.sep file for use in other
ent separation settings is
tions for different types 
also be used when render
in the Eclipse Standalon
O, plus it can be called up
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erences dialog box. Saved separation parameters
also can be used for foreign format conversion pro-
cesses via Eclipse I/O.

To save separation parameters
Click Save. 

The current settings are saved in a file with the same
filename as the image plus the extension .sep; for
example, myimage.sep. If you want to use a differ-
ent filename, click Save As. 

To open a saved separation file
Click Load. 

Then use the Open File dialog that appears to locate
the .sep file you want.
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11.1. Overview of File Operations

Although Eclipse works with images in its own na-
tive Tile file format, it supports over 12 different in-
dustry-standard image formats. For example, you
can open a TIFF image in the main window, work
on it as a Tile file and then save it to disk as an EPS
file. 

Eclipse includes a program called Eclipse I/O
(ecio), which is installed when you install Eclipse.
The Eclipse I/O program performs the file format
conversions. When you open a foreign format file,
you will notice that Eclipse displays a status box in
the upper left corner of the screen as it converts the
file. Depending on whether the image is RGB or
CMYK, the status box displays a three or four-color
horizontal band to mark the progress of the conver-
sion.

You can use Eclipse I/O by itself to preview images
on the screen and convert files to and from any sup-
ported format. When you run Eclipse I/O by itself,
you type commands from the command line. For
more information, see page 11-7.

TIP

For basic information on file management, see
“Opening and Saving Images” on page 1-4 and
“How Eclipse Handles Images” on page 1-9.

Opening files
• Open over 12 foreign-format images in the

Eclipse main window by choosing

File → Open → Ima
“Opening Images” on 

• Open Adobe Illustrato
by choosing File=→ O
described under “Ope
files as ShapeLayer fil

• Fill ShapeLayers with
clicking the Image bu
Fill shelf. For more in
ShapeLayers” on page

Saving files
• Save an image file un

name by choosing File

• Save an image in a diff
ferent name by choosi

• Crop an image and sa
File → Crop As, as d

Translating files usin
Run the Eclipse translato
described on page 11-7.
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includes fills has to be ras-
pened in Eclipse. An Illus-
n be opened in Eclipse as

ipse recognizes
its native Eclipse format

e resolution as the image

or data files as 

eric vector data files that
nt. Native Eclipse Shape-

me extension. You can also
 vector data as Eclipse

overlay is resolution inde-
orted from another image
disproportionate size and
es zooming down to 1:16

ccasionally they are too big
e, turn on Fit to Canvas
d in the procedure below.

ustrator file as a Shape-
 guides in Illustrator and
 format.
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11.2. Opening Images

When you choose File= → Open → Image, the
Open Image dialog box displays the names of all the
files it recognizes as images, including foreign-for-
mat files. Eclipse recognizes the file formats shown
in the following tables.

Image file formats Eclipse recognizes

REMARKS

* denotes file formats that Eclipse can read but not
write. 

For Adobe Photoshop EPS and DCS files, use Save
As and Macintosh preview; binary or ASCII encod-
ing.

An Illustrator file which 
terized before it can be o
trator file without fills ca
a ShapeLayer file.

Mask file formats Ecl
Eclipse recognizes only 
masks.

REMARK

A mask must have the sam
it is masking.

Opening foreign vect
ShapeLayer files

ShapeLayer files are gen
are resolution-independe
Layers have a .shp filena
open Adobe Illustrator
ShapeLayer files. 

Because the ShapeLayer 
pendent, vector data imp
or application may be a 
hard to locate. Sometim
makes them visible but o
to find. If this is the cas
When Open as describe

REMARK

To import an Adobe Ill
Layer file, first delete its
save it in any Illustrator

Alias PIX JPEG 

Adobe Photoshop Raw RGB

Adobe Illustrator SGI RGB

DCS CMYK Softimage RGB*

Eclipse RGB and CMYK Targa RGB

EPS RGB and CMYK TIFF RGB, CMYK

Iris Graphics CMYK (Jet 
Printer)

Wavefront RGB
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To open a vector data file
1 Choose File → Open → ShapeLayer. An Open

ShapeLayer file dialog appears.

2 Select the vector data file you want.

3 To scale ShapeLayers to fit the canvas and posi-
tion them in them at (0,0) turn on Fit to Canvas
when Open.

4 Click OK. 

If you turned on Fit to Canvas When Open, the
ShapeLayers open with their lower left corner posi-
tioned at the lower left corner of the canvas image
(0,0) and scaled to fit as big as possible within the
canvas.
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le.

Desktop Color Separa-
tion

Iris Graphics printer 
image

Silicon Graphics image

Targa 24-bit

Targa 16-bit

Targa 24-bit com-
pressed

3-color TIFF

4-color TIFF

 JPEG compressed

3-color TIFF with LZW 
compression

4-color TIFF with LZW 
compression

Alias format
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11.3. Saving Images

Use the Save As command in the File menu to save
the current image in a foreign format or with a dif-
ferent name. You can also use the Save As command
to save the current mask or ShapeLayers overlay. To
save the image, mask, and ShapeLayers overlay in
files with the same name (but different extensions)
choose File → Save As → All.

To save the current file with a different 
format or filename
1 Choose File=→ Save As. The Save As submenu

appears.

2 Choose Image. A Save Image file dialog appears.

3 Choose a folder and filename.

4 Select one of the following file formats.

5 Click OK to save the fi

Eclipse CMYK Eclipse native 4-color

Eclipse RGB Eclipse native 3-color

EPS CMYK Encapsulated Post-
Script CMYK

EPS RGB Encapsulated Post-
Script RGB

Photoshop CMYK Photoshop native CMYK

Photoshop RGB Photoshop native RGB

DCS

Iris Graphics

SGI Image

Targa

Targa 16

Compressed Targa

RGB Tiff

CMYK Tiff

JPEG

RGB Tiff (LZW)

CMYK Tiff (LZW)

Alias PIX
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REMARK

Because JPEG compresses images by removing
nonessential data, there is a trade-off between im-
age quality and image storage size: the more com-
pression, the greater the likelihood of image
degradation.

Mask formats Eclipse can save
When you choose File → Save As → Mask, you
can save a mask file in Eclipse mask file format.

REMARK

When you choose File →  Save As →  ShapeLayer,
the current ShapeLayer overlay is save in Eclipse
ShapeLayers file format. This format can be read
only by Eclipse.
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 I/O to perform some spe-

f the switches and 
 use
e.

files\Eclipse\bin and
to the Eclipse install direc-

Enter. Be sure you type the
ith all lower case letters.

example of using the com-
available switches and pa-

me. You must specify both
e] and -o [filename.ext]
ge conversions.

dev sgi_image -o new-

tion in the following sec-

the output file name. You
ere to put the output file

u do not include the path,
e in the current directory.
dev [format_name] and
11–7

11.4. Eclipse I/O (ecio)

Introduction
Eclipse I/O (ecio) is an image file conversion pro-
gram that converts files to and from a wide variety
of formats or sends files to output devices. You work
with Eclipse I/O by typing commands from the
command line. 

To convert files from the command line, you type
the program name ecio, the name of the file you
want to convert, a list of any options you want to use
and the destination for the converted file. For exam-
ple, the command:

ecio mypicture.als -dev sgi_image -o new-
picture.sgi

takes the file mypicture.als in its Alias file format
(.als) and converts it to a file named newpic-
ture.sgi in the SGI image format (.sgi).

The other two statements in this command, -dev
and -o, are switches that you use to tell Eclipse I/O
that you are giving it information it needs to per-
form the conversion properly. In this example, use
the -dev switch to tell Eclipse I/O to convert the file
to SGI image format and use the -o switch to tell it
to name the output file newpicture.sgi.

Most switches include one value as a parameter. In
the example above, the -dev switch uses the
sgi_image parameter to tell Eclipse I/O what file
format to use. Some switches do not use parameters

— they simply tell Eclipse
cific action.

To see a summary o
parameters you can
1 Go to the command lin

2 Type cd C:\Program
press Enter to change 
tory.

3 Type ecio, then press 
command as shown, w

Eclipse I/O displays a 
mand and a list of all 
rameters.

File formats
-dev: Specifies the file na
the -dev [format_nam
switches when doing ima

ecio mypicture.als -
picture.sgi

See the -o switch descrip
tion.

Output control
-o: This switch specifies 
must tell Eclipse I/O wh
and what to call it. If yo
Eclipse I/O places the fil
You must specify both -



11. Appendix A: Managing/Translating Files 11.4. Eclipse I/O (ecio)

m 0.0 to 4.0. Values less
e, values greater than 1.0
akes no change). Gamma

bending the curve up or
ving pure white and pure
id-tones are affected the

pplies a color gain correc-
ending it to the output de-
ree independent switches,
n, and blue components of
to boost the amplitude of
image, you could type:

lue of all the pixels by 1.10.
fect of increasing the con-
nt of the image. The dark
d the brighter ones are
contrast of the image uni-
, specify all three channels.

-bfac 1.1

: Applies a color additive
efore sending it to the out-
switches are similar to the
ount specified is added to
 specify either a positive or
e value brightens the red,
t of each pixel; a negative
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-o [filename.ext] switches when you do an im-
age conversion. For example: 

-dev targa -o C:\files\project\vase.tga 

This command puts the image in a targa file in the
C:\files\project directory with vase.tga as the
image name.

Positioning, sizing and cropping        
-xo: Use this switch to crop an image. Specifies the
left edge relative to the original image, for cropping
or viewing. To view an image 500 pixels from the
left edge, type:

ecio imagename.ext -xo 500

-yo: Use this switch to crop an image. Specifies the
bottom edge relative to the original image.

-xc: Use this switch to crop an image. Specifies how
many pixels horizontally should be copied to the
new image.

-yc: Use this switch to crop an image. Specifies how
many pixels vertically should be copied to the new
image.

Color corrections
-gamma: Applies a gamma correction curve to the
image before sending it to the output device or file.
To apply a CRT correction gamma of .45, type:

-gamma .45

Gamma values range fro
than 1.0 darken the imag
lighten it (a value of 1.0 m
correction operates by 
down in the middle, lea
black unchanged. The m
most.

-rfac, -gfac and -bfac: A
tion to the image before s
vice or file. There are th
one each for the red, gree
an image. For example, 
the red component of an 

-rfac 1.10

This multiplies the red va
Note that this has the ef
trast of the red compone
values remain dark, an
boosted. To increase the 
formly in all components
For example, type:

-rfac 1.1 -gfac 1.1 

-radr, -gadr and -badr
correction to the image b
put device or file. These 
previous two, but the am
each pixel value. You can
negative value. A positiv
green, or blue componen
value darkens it.
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the following Prepress and

ename extension

 (currently read only)

 or .rlb

 or .rgb

 (read 16, 24, or 32 bit; 
te 24 bit)

 (to write 16 bit)

 (to write 24 bit com-
ssed)

 (raw or user data, read 
y)

 (Eclipse format)

 (Eclipse format)
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Special purpose
-sep: This switch specifies a separation parameter
file to be used for controlling the RGB to CMYK pro-
cess when converting to a four-color file format or
driving a four-color printer. The file must have been
created by Eclipse CMYK Separator. The example
below instructs Eclipse I/O to use the file abc.sep
as a separation control file:

-sep abc.sep

File formats and devices      
The Eclipse I/O program reads and writes images in
the formats listed below. Be sure to use the correct
filename extension, and type it as shown in the fol-
lowing table.

Eclipse reads and writes the following workstation
product formats:

Eclipse reads and writes 
Graphic Arts formats:

Image format Fil

alias .als

softimage .pic

wavefront .rla

sgi_image .sgi

targa .tga
wri

targa16 .tga

compressed_targa .tga
pre

raw_rgb .usr
onl

Tiff .tif

tiffb .tifb

Tiled_cmyk .tile

Tiled_rgb .tile
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gi_image -o image.sgi

he image width and height
st specify the direction and
mpted to specify whether
ge out Top-to-Bottom (T)

ou want Row Interleaving
terleaving (P). Row inter-
ch row, all the red data is
n, then all the blue. Pixel

or each row, the red, green,
el is written consecutively.

interleaving as
..B and pixel interleaving

tem what block size to use
eader information to skip
ation is present, enter a

nter 0 for block size in all
k LVT—in which case, en-

her 3 or 4 bytes per pixel.
tes. For Quantel, enter 4.

ing, and header informa-
lease refer to the instruc-
evice.    
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Eclipse reads and writes the following PostScript
formats

You can use Eclipse I/O to read and write image
files of plain RGB data with no header information
and no encoding or compression. This can be useful
if you want to exchange images with other software
systems, or for custom or experimental applica-
tions. For example, to write out the RGB pixel data
to the file cars.usr type:

ecio cars.sgi -dev user_defined -o
cars.usr

To read a .usr file, type:

ecio image.usr -dev s

Eclipse I/O prompts for t
in pixels and you also mu
interleaving. You are pro
you want to write the ima
or Bottom-to-Top (B).

Eclipse I/O then asks if y
of the data (R) or Pixel In
leaving means that for ea
written, then all the gree
interleaving means that f
and blue data for each pix
Write row 
RRR...RGGG...GBBB.
as RGBRGBRGB. 

You must also tell the sys
and how many bytes of h
over. If no header inform
header skip value of 0. E
cases, except for the Koda
ter 512.

You must also specify eit
In most cases, enter 3 by

Top to Bottom, Interleav
tion is device-specific. P
tions for your particular d

Image format Filename extension

iris_graphics .irg (for their printer)

4-color Tiff .tif (CMYK) 

3-color Tiff .tif (RGB)

1-bit Tiff .tifb 

Image format Filename extension

PostScript .ps (Monochrome, write only)

ColorPostScript .ps (Color PostScript, write 
only)
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 files you want to 

nd/or ShapeLayers.

g that appears, select the
.

put files, select the type of
. Eclipse Render can ren-

hapeLayers and masks
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11.5. Eclipse Standalone Renderer
(ecrender)

Use the Eclipse Standalone Renderer (ecrender)
to render images, masks or ShapeLayer fills. The
images you render do not have to be the ones you
are working on in Eclipse—you can render one im-
age while you are working on another. You can also
use ecrender to set up a list of images and then ren-
der them all as a batch job. ecrender includes op-
tions for manipulating an image as you render it.
You can change the resolution, size, and orienta-
tion, add width and height and flip it vertically or
horizontally.

Starting ecrender
Start ecrender using any of these methods:

• Within Eclipse, choose Window → Standal-
one Renderer.

• From the command line change to the
C:\Program files\Eclipse\bin directory,
type ecrender and press Enter.

• From the Desktop, double-click the ecrender
icon.

REMARK

If the Render dialog does not appear, it may al-
ready be open behind the Eclipse main window.
Minimize Eclipse and try to find it. 

The ecrender dialog

To choose the input
render
1 Select Image, Mask a

2 In the Open File dialo
file you want to render

After you choose your in
file you want to render to
der files as:

• Images: can contain S

• Masks
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 scaling, rotation and other

ile
 images to CMYK, you can
ave created in CMYK Sep-

choose a separation file,
ult separation parameters.

tion.

log and use it to select the
t.

les
ctions settings using the
tion tool shelves, you can
 file. See “Correcting Col-
ctions on using and saving

rrection file for the render,

log and use it to choose the
pplied to the rendered file. 
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To choose the type of file you want to 
render to
1 From the Output, Render Type dropdown menu

choose Tile Image, Tile Mask or Line Art.

2 Click the Open File button. A file dialog appears. 

3 If you want to render over an existing file, locate
and select the file. 

4 If you want to create a new file, type a name for it
in the Save Image Name text box.

5 To render the file in a different format, click the
pop-up menu at the bottom of the file dialog and
choose the file format you want. 

6 Click OK to choose the file as the render output
file. Click Cancel to close the dialog box without
selecting a file.

Eclipse Render displays the filename you select-
ed (and its directory path) below Render Type. 

Now that you have selected the input and output
files for the render, you can select options.

Choosing render options
You can specify the following options for the render
output file:

• a separation file for use when converting RGB to
CMYK images

• one or more correction files

• anti-aliasing level

• image size, resolution,
factors.

Using a separation f
If you are rendering RGB
use a separation file you h
arator. If you do not 
Eclipse Render uses defa

1 Select CMYK Separa

2 Click the Open File dia
separation file you wan

3 Click OK.

Using Corrections fi
If you have saved corre
Save button in the correc
apply them to a rendered
or” on page 2-1 for instru
color correction files.

1 If you want to use a co
select Correction.

2 Click the Open File dia
corrections you want a

3 Click OK.
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f the output file.

idth to the border of the
re rendering an image, it
 more sides of the file, but
he image larger. Choose
 from the dropdown menu
s you want add width to.

height to the border of the
re rendering an image, it
 more sides of the file, but
image larger. Choose Top,
om the dropdown menu to
ou want add height to.

rrent number of pixels per
t.

e options you want, click
e.

s box as it renders the im-

ender settings files
umber of images the same
tings in the Render dialog.

ngs files
ut files and set the Render
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Setting the anti-aliasing level
To use anti-aliasing for the render, select the Anti-
alias text box, type a value and then press Enter. 

See page 9-4 for information about anti-aliasing.

Specifying image size, resolution and 
other factors
Choose the remaining render options of the Render
dialog. Start with the transformations:

• Scale X: the horizontal scaling of the input file.

• Scale Y: the vertical scaling of the input file.

• Rotate: use this box to rotate the input image or
file. Type a percent value in the box (for example,
type 90 for 90°).

• Flip: click Vertical or Horizontal to flip the
image.

Next choose the output parameters. Since many of
the options involve changing the size and orienta-
tion of the input image, first choose the unit of mea-
surement you want to use.

1 Click the Units pop-up menu, then choose Inch,
cm, Mm, Point, Pica or Pixel.

2 To change other option settings, click the appro-
priate buttons or type values in the appropriate
text boxes. The available options are:

- Width: the width of the output file.

- Height: the height o

- Add Width: adds w
output file. If you a
adds space to one or
it does not make t
Left, Right or Both
to choose which side

- Add Height: adds 
output file. If you a
adds space to one or
it does not make the 
Bottom, or Both fr
choose which sides y

- Resolution: the cu
unit of measuremen

Starting to render
After you have chosen th
Render to render the fil

ecrender displays a statu
age.

Saving and reusing r
If you want to render a n
way, you can save the set

To save render setti
1 Specify input and outp

options you want. 
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name of a render settings
 top.

 to the Batch List, click the

from the Batch List, select
elete.

 list of files ready, click Ex-
 files in the batch list.
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2 Click Save in the Render dialog. A Save Render
file dialog appears.

3 Type or select a name for the render settings file,
then click OK.

Eclipse saves all the information in the Eclipse
Render dialog.

To use an existing render settings file
1 Click Load in the Render dialog.

An Open Render file dialog appears.

2 Select the render settings file you want and click
OK.

Eclipse fills in the Eclipse Render dialog with the
information in the file. You can change any op-
tions you want. For example, you might want to
change the names of the input and output files.

Setting up a batch list of Render files
If you save render settings files, you can set up a list
of these files and have Eclipse Render render them
all at once. For example, if you have a lot of images
you want to render, you can select the output files
and options for each image and then create a batch
list of all these files. Then you can render them all
while you work on other projects.

To set a batch list of render files
1 After you have created and saved all the render

settings files, click Batch Render in the Render
dialog. The Batch Render dialog appears. 

The Batch Render dialog

2 Locate and select the 
file from the box at the

3 To add the selected file
arrow button.

4 To remove a filename 
the name, then click D

5 When you have got the
ecute to render all the
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You will see a prompt box that informs you of
ecrender’s progress as it renders the files.

To save the Batch list
1 Click Save.

2 In the Save file dialog that appears, type or select
a name for the batch list.

3 Click OK. 

This creates a batch list file that you can reuse.

To open a Batch List you have saved
1 Click Load.

2 Use the Open file dialog that appears to select the
batch list file you want.

3 Click Okay.

In the Batch List box you will see the names of the
render settings files in the batch list you selected.

4 To render all the files in the batch list, click Exe-
cute.

A prompt box informs you of ecrender’s progress
as it renders the files.
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 refresh

to Red/Cyan channel

to Green/Magenta chan-

to Blue/Yellow channel

to Black channel

to Mask

ough color channels

 Fit

 100% (1:1 Pixels)

e Zoom Level

e Zoom Level

off

guide

uide

 guide

how Windows
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12. Appendix B: Keyboard Shortcuts
Tool Shortcuts

V Pointer Tool

H Hand Tool

R Rectangular ShapeLayer Tool 

E Ellipse Tool

Y Polygon Tool

C (Bi-Spline) Curve

Z Bezier (Curve) Tool 

T Text Tool

J Skew Tool 

O Rotate Tool

D Distort Tool

B Brush Tool

W Warp Tool

Ctrl Shift D Probe

AltGr M Brush shelf

Ctrl E Color editor

AltGr O Pick color

View Shortcuts
Ctrl W Window

F5 Switch 

F6 Switch 
nel

F7 Switch 

F8 Switch 

F9 Switch 

F10 Step thr

AltGr P Preview

Ctrl 0 Zoom to

Ctrl 1 Zoom to

Ctrl + Increas

Ctrl - Decreas

Space Pan on/

Ctrl F move a 

Ctrl D Add a g

Ctrl Alt D Delete a

Tab Hide/S
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opped

ts

le

pling on/off

ask

SL Mask

brush

 brush

rush
12–2

Shift Tab Hide/Show Windows except
Toolbox

Ctrl B Track changes

AltGr C color of ShapeLayer border

Shapelayer Shortcuts
AltGr L  Align

AltGr Q Show ShapeLayer Fill as image

AltGr W Show ShapeLayer Fill as proxy

Ctrl H hide ShapeLayers

F11 Toggle between Render modes

1,2,3...0 Shape Layer Transparency 10%,
20%...100%

Operations Shortcuts
Ctrl A Select all

AltGr D Back

AltGr F Front

Ctrl G Group

Ctrl Alt G add to group

Ctrl Shift G Ungroup

Ctrl C Copy

Ctrl V/Ctrl Ins Paste

Ctrl Shift V paste cr

Ctrl Z Undo 

Ctrl X Redo 

File/General Shortcu
Ctrl N new file

Ctrl S save file

Ctrl F4 Close fi

Ctrl Q/Alt F4 Quit

Ctrl Alt S subsam

F1 Help

Mask Shortcuts
AltGr A Auto M

AltGr H Auto H

Ctrl I Invert

Brush Shortcuts
X Effects 

Q Restore

F Clone b
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A Color brush

M Render brush

N Correct brush

+ / - In/decrement brush size

Alt + Right Mouse button
Use for middle mouse button
while brushing
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