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Welcome,
We’re glad you decided to try one of our products.    If there is anything you think we 

could do better, please feel free to contact us.    Acey Ducey Backgammon is yet another in our 
line of products we call our ‘’InterSoft Series”.    Each product looks and feel as smooth as this 
one, so keep an eye open for them. 

Sincerely,

WinGames.Inc



 Match Play 

 Starting A Match
To start a new match, from the ‘Game’ menu, click on the ‘New Match’ menu item or 

click the toolbar button. This will display the Match Play dialog box.
First, enter a name you would like to be known as (the default is Player). This is the same 

name that will appear on the Score Board, and is also the default session name used for any 
remote matches you play.

Next, select the type of match you would like to play.    There are five different kinds of 
matches for each game.    Each one is different and presents a different challenge.    Points 
matches continue until one player reaches the points specified (the default is 250 points).    The 
‘Best Of’ matches are for playing games series like 4 out of    7, or 3 out of 5.    The ‘No Match’ 
match types are for playing games.

Then select your opponent.    Selecting ‘Remote Play’ will start the sequence for 
connecting to an opponent when you actually start the match.    To play against the computer 
click any of the four skill levels.    And select ‘Two Players On This Machine’ to play with two 
people on the this computer.    When you select ‘Two Players On This Machine’ you can enter 
your opponents name.

Now you are ready to start your match.    Press the ‘Start New Match’ button and the fun 
begins.    There is no end to a match.    Match play continues until you start a new match.    To end 
a remote match that you are connected to, select a different opponent, or click on the ‘Remote 
Play’ box.

 Playing A Match
Once you’ve started a new match, match play continues until you either quit playing or 

start a new match.    At the end of every game the Score Board appears and displays the current 
match results. When someone wins a match, the Score Board starts a new match, while retaining 
the match win totals. 

 Opening A Match
To open a match, from the ‘Game’ menu, click on the ‘Open Match’ menu item or click 

the toolbar button.        The match will be loaded right at the point you saved it at.    If it is a 
remote match and you are connected, it will be loaded on your opponent’s computer also, so you 
can start right from there.

 Saving A Match
To save a match, from the ‘Game’ menu, click on the ‘Save Match’ menu item or click 

the toolbar button.        The match will be saved at the point you are at.



 Score Board
The Score Board keeps track of the games progress.    It is displayed after each game.    To 

view the scoreboard, from the ‘View’ menu, click on the ‘Score Board’ menu item or click the 
toolbar button.



 Game Play 

Starting A Game
To start a new game from the ‘Game’ menu, click on the ‘New Game’ menu item or click 

the toolbar button for the game you want to play.    A dialog box with the games initial roll will 
appear.    The one with the highest roll goes first. 

 Rules Of Acey Ducey
Game play for Acey Ducey are exactly the same as backgammon.    The only differences 

are,
1. All pieces start off the board and are entered just like a piece comming on from the bar.
2. When a player rolls a 1 and a 2 (called an Acey Ducey), they get their choice of doubles and 
then an extra roll.

 Rules Of Backgammon

Object
The object of the game is to be the first player to remove all your pieces from the board 

by moving all your    pieces to your home board and then bear them off.    You move your pieces 
counter-clockwise to the bottom right quadrant of the board which is his home board.    Your 
opponent moves pieces clockwise to the top right quadrant respectively.

Play
Each move begins with a roll of the dice. The roll of the dice indicates how many points 

(pips) you may move your pieces.    The pieces are always moved forward, to a lower-numbered 
point.

After you roll the dice, one piece may be moved for both numbers or two different pieces 
may be moved. For example, if you roll a four and a two, you may move one piece four spaces to 
an open point and another piece two spaces to an open point, or you may move one checker a 
total of six spaces to an open point. 

However, you may only make these move if the intermediate point is open (either two or 
four spaces from where you started). If two or more of an opponents pieces are on a point, that 
point is blocked and your piece may not move onto the point. 

If    doubles are rolled, you may move double the combination of the numbers shown on 
the dice as follows: 

Four pieces the number on one of the dice.    For example, if you roll double sixes you 
may move four separate pieces six points each.    Two separate pieces two times the number on 
one of the dice.    Using the same example, you may move each piece twelve points or two sixes 
each.    Two separate pieces the number on one of the dice and one piece two times the number 
on one of the dice.    One piece four times the number on one of the dice.

Again you may only make these combination moves if the intermediate points are also 



open.    You must use both numbers of a roll if possible or all four numbers of a double roll.    You 
must play as many numbers as you can.    When only one number can be moved, you must move 
that number. If either number can be moved but not both, you must play it.    If you are blocked 
from moving onto all points available from both numbers on the dice or all four numbers on a 
double roll, you lose the turn. 

Center Bar
If one of an opponents piece's is on a point available from your roll of the dice (blot), you 

may move onto the point and send the opponents piece to the center bar.    A piece on the center 
bar must reenter the board on an open point in the opponent's home quadrant corresponding to 
one of the numbers rolled on the dice.    Any time a player has one or more pieces on the bar, he 
must first enter those piece(s) into the    opposing home board

Bearing Off
When all your pieces are in your home quadrant, you may begin removing pieces from 

the board (bearing off) according to the dice thrown and the points on which your pieces are 
located.    You may either move a piece or remove a piece from the board.    When the numbers 
on the dice thrown are higher than any of the points you have pieces remaining on, a piece from 
the highest point may be removed.    If one of your pieces is sent to the center bar while bearing 
off, the piece must reenter in the usual way, move back around the board to your home quadrant, 
before you may continue removing pieces.    The first player to bear off all fifteen pieces wins the 
game.

Points
Each game of Backgammon is played for a one point stake.    While playing, if you think 

you have an advantage you may propose doubling the cube by clicking on it.    You may only do 
this at the beginning of your turn, before rolling the dice.    If offered a double you may decline, 
in which case you concede the game and lose one point, or you may accept the challenge and 
play on for double the points.    The player who accepts a double becomes the owner of the cube 
and only he may make the next double.    If you refuse a subsequent double during the game, 
your opponent gets the number of points that were at stake prior to the challenge.    Otherwise, 
you become the new owner of the cube and the game continues at twice the previous stakes.    
There is no limit to the number of doubles in a game.

Gammon
If you have lost the game and have borne off at least one piece, you lose only the value 

showing on the doubling cube.    However, if you haven't borne off any of your pieces, you've 
been gammoned and lose twice the value shown on the doubling cube. 

Backgammon
If you have lost the game and have not borne off any of your pieces and still have a piece 

on the center bar or in your opponent's home board,    you've been backgammoned and loses 
three times the value shown on the doubling cube.

Backwards A Move
To move backward a move, from the ‘Options’ menu, click on the ‘Backwards A Move’ 



menu item or click the toolbar button.    If you are playing against the computer and move 
backward into computer moves, start play again by clicking on one of the computers pieces or 
roll the computers dice again, or move forward to one of your moves.    If you are remotely 
connected and you move backward it is reflected on your opponent’s board, but remember if you 
go to far back it will be your opponents move again.

Forward A Move
To move forward after you have moved backwards, , from the ‘Options’ menu, click on 

the ‘Forward A Move’ menu item or click the toolbar button.



Remote Play

Important Note: Acey Ducey Backgammon requires Microsofts DirectX / Direct Play 
support for all remote sessions.    If you don’t have it loaded on your machine you can download 
from them at no charge.    It provides all the underlying transport support.

Acey Ducey Backgammon has support for DirectX 3.0.    If you have a newer    version of 
DirectX (5.0 or above), you must delete the file “dplayx.dll” found in the directory you installed 
this game in.(usually “C:\WinGames.Inc\ADBack”).

Starting A Remote Match
To start a remote match, from the ‘Game’ menu, click on the ‘New Match’ menu item or 

click the toolbar button. Then select ‘Remote Play’ as your opponent, and click the ‘Start New 
Match’ button.    The remote play dialog box will appear.    If the list box has no selections in it, 
then you need to load Microsofts DirectX / Direct Play.

One player then creates a session and waits for the other player to connect to that session. 
If you create the session your computer waits for a connection.    If you are connecting to a 
session, depending on the type session, you will be asked different types of connection questions.

Important Note: For Internet play you should connect to your service provider before 
starting a remote session.    Once connected to your provider, you need to get the IP address you 
are at so you can tell your opponent what address to connect to.    You can see what address you 
are connected as by running the “WinIPcfg.exe” utility found in your windows directory.    Give 
this IP Address to your opponent so that they can use it to connect to you.    This address changes 
each time you connect to your service provider.

If you are connecting to a session, select the session you want and click the Ok button.    
If no sessions are found you can rescan using the rescan button.

Once you are connected to a session, your ‘Chat Window’ will appear.    If for some 
reason you get disconnected or just quit playing by starting a new match, the ‘Chat Window’ will 
disappear.

Ending A Remote Match
To end a remote match and disconnect from an opponent, from the ‘Game’ menu, click 

on the ‘New Match’ menu item or click the toolbar button. Then select ‘Remote Play’ as your 
opponent.    This will prompt you to disconnect from the remote session you are in.



Other Features

 Board Designer
Use the board designer to design any type board you like.    There are 75 different textures 

to choose from along with every color your computer supports.    When you choose a different 
layout it is stored until you change it again.    You can also open or save a particular layout you 
like.

Chat Window
This window allows you to talk to your opponent while you are connected.    Type your 

message and hit the return key.    You can toggle this window on and off even if you are not 
connected.    To do this, from the ‘View’ menu, click on the ‘Chat Window’ menu item or click 
the toolbar button.

 Sound
To toggle sound on and off, from the ‘Options’ menu, click on the ‘Sound’ menu item or 

click the toolbar button.

 Music
To toggle music on and off, from the ‘Options’ menu, click on the ‘Music’ menu item or 

click the toolbar button.    There are seven MIDI selections included.    They play in a randomly 
started, curricular pattern.    If you want to replace any of them with your own MIDI selections, 
they are named Music1.mid - Music7.mid, and are in the installation directory of this product.



Great Gift Idea!

Additional CD’s & Disks!

WinGames.Inc Collection - All our best games on one CD!

Windows '95 Collection - Our best games on one CD.    Includes Game Chest, BIG 8 Solitaire, Botz, Penny's Arcade 
and Total Recall. A real value with over 15 fully enabled games.

Pro Backgammon  - Another ‘InterSoft’ game.    The ‘ZDNet 1997 Product Of The Year’ winner for board games.    
It has 5 levels of match play, 3 levels of computer play, Remote play over the Internet, Modem, Lan, or Serial 
connection along with sound and music.

All American Gin Rummy  - 3 great gin games including Standard Gin, Hollywood Gin, and Oklahoma Gin Rummy. 
It features 3 levels of computer play, Remote play over the Internet, Modem, Lan, or Serial connection along with 
sound and music. 

Dominion  - Another ‘InterSoft’ game.    This classic board game will challenge even the most experienced game 
player.    It features 3 levels of computer play, Remote play over the Internet, Modem, Lan, or Serial connection along 
with sound and music. 

Dominoes Deluxe  - Our fourth ‘InterSoft’ game.    This classic allows you to play Draw, Block, and Muggins on 
boneyards of 6s, 9s, 12s, 15s.    It features 3 levels of computer play, Remote play over the Internet, Modem, Lan, or 
Serial connection along with sound and music.

Big 8 Solitaire  - Eight of the greatest solitaire games of all time with full computer play.    Includes Auld Lang Syne, 
Canfield,    Flower Garden, Grannies Clock, Klondike, Little Spider, Magic Carpet and Osmosis. 

Game Chest     - A challenging collection of games including Backgammon, Yatze, and Rummy to be played with two 
players or against the computer.    Two versions of mind numbing Solitaire as well, Queen's Audience and Fortune's 
Favor. 

Total Recall  - Follow the sights and sounds without being dazzled.    A quick paced game to challenge your memory 
and reaction time.    Not a simple simon.    Truly addicting. 

Penny's Arcade  - Try your hand at a shooting gallery with a full range of skill levels and configuration options. For 
one to four players, a carnival of    prize winning fun. 

Botz  - Enter the Gardens of Zardonia and battle the Botz.    Over 60,000 exciting gardens,    with rendered graphics 
and arcade style sound. 

Board Games for 2 - Chess, Checkers, Backgammon, Goban, Pipes, Race Chase, Flag Ship and Fox & Hounds.    
Play with a friend on the same machine, on any network or using a modem. (available in 3 ½” diskette and email 
formats only) 

Solitairy Confinement - A ‘ZDNet 1996 Product Of The Year’ nominee for card games it has eight solitaire games 
which require a full range of skill, knowledge and lady luck.    Fortune's Favor, Accordion, Beleaguered Castle, 
Calculation, Quadrille, Four Season's, Queen's Audience and Chameleon. (available in 3 ½” diskette and email 
formats only) 

Super Shareware Game Collection - For those who wish to "try before they buy", the shareware versions of all 
games listed below on one CD. 

-----------------------------------------------------------------------------------------------------------------------------------
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