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Legal Notice

Design-A-Room is a copyrighted program. It may not be changed or modified in any way except 
by the authors.
.  
All warranties are disclaimed, including damage to hardware and/or software from use of this 
program.  In no event will we be liable to you for any damages, including lost profits, lost savings 
or other incidental or consequential damages arising out of your use or inability to use the 
program, or any other claim by any other party.  In any event, the extent of our liability is limited to 
amount of money received by us from you.

Every effort has been made to ensure that Design-A-Room is as clean and free of bugs as 
possible.  However, no program can ever be guaranteed to be free of all defects.

The program, Design-A-Room, including the code, appearance, documentation, organization 
and structure, is a copyrighted product, and is the sole property of Epsilon Computing and is 
protected by the Copyright laws of this country. Your use of the product consitutes a license to 
use the program under the following conditions:

You may: 

Use Design-A-Room on one computer. If at any time, you decide to change computers, you 
must delete or erase from the first computer, after copying to the second computer, any and all 
files belonging to or relating to the program Design-A-Room and the files contained herein. 
Under no circumstances may this program be used on more than one computer at a time. 

Make one copy to use as a backup or archival copy. This copy is to be used ONLY in case of 



accidental destruction of the original.

Transfer the program Design-A-Room to another person, providing that you transfer the whole of 
the product, including all files, disks, and documentation. You may NOT keep any copies of the 
program. This includes any backup or "archival" copies. This person must also agree to the 
conditions set forth by this document. 

You may not:

Transfer or rent the program Design-A-Room, or any parts thereof, or use, copy or modify the 
program, except as expressly permitted in this document. 

Decompile or reverse assemble the program, Design-A-Room, or any parts thereof.

Windows is a trademark of Microsoft Corporation.

.
WARRANTY

Design-A-Room  is supplied "AS IS."  The authors make NO warranties, either
expressed or implied, including, but not limited to, fitness for particular
purpose.  The authors assume no liability for damages, direct or indirect, from
the use of   Design-A-Room.  The user assumes full responsibility for the use of
this program.

Epsilon Computing warrants that the program, Design-A-Room, will substantially perform the 
stated in the program documentation, or generally comform to the specifications included in the 
enclosed program documentation. Also, the enclosed disk will have the stated program files on it, 
and will be free of physical defects which would cause the program not to load. If this is not the 
case, you only recourse is to return the program disk to us, and we will then send you a 
replacement disk, free of charge. 

INTRODUCTION

This is a fully functional Registered version of Design-A-Room.  This version includes 
several enhancements to this program not in the Shareware version. 

Design-A-Room was designed to take full advantage of the benefits of Microsoft Windows. 
Practically everything that you do in Design-A-Room you do with a click of a mouse - no typing in 
commands - no trying to remember strange key commands in order to do everything. About the 
only time you will need the keyboard is to type in the name of your room!

Design-A-Room lets you draw a room, put all the furniture in it, in exactly the right dimensions, 
and then move the pieces around to your heart's content-- without ever getting up from your 
chair!



Put walls wherever you want-- move them,  and resize them.  Put several rooms together on the 
same page - or put the same room on twice to see what different arrangements look like.

Design-A-Room comes loaded with 17 different wall, doors, fixtures, etc., plus 31 different 
furniture pieces.  Couches, pianos, tables, even a pool table and fireplace.! All professionally 
drawn so that you know exactly what you are looking at when you view the room. You can re-size 
each piece to the nearest inch, so you can design your room to your exact dimentions. 

The "Snap-to-Grid" option lets you quickly put your furniture and fixtures in the room. Then turn 
off "Snap-to-Grid" to let you arrange the pieces precisely where you want them. "Snap-to-Grid" 
also makes putting walls up a "snap."

The "Custom Toolbar" option lets you add up to 18 of your own icons. You can create these icons 
through the program. 

The "Add Text" option lets you add text anywhere on the screen - even on top of other icons.  Text 
can be added in any size using any font you have installed.  Effects such as bold, italics, 
underline, strikethru can bu used.  In addition, text can be placed in any color.

The screen size has been enlarged in the registered version of Design-A-Room to let you 
increase you room sizes - this is limited only by your screen resolution. 

The dotted grid and the scales can now be turned off if desired. 

Design-A-Room shows you the exact sizes of your furniture pieces, and also the exact location 
of each piece in the room to the nearest inch.  No guessing necessary!

When you are finished with your room, you can save it to disk and print it out on any  Windows 
3.1 supported printer. 

With Design-A-Room you know what your room will look like BEFORE you spend all your time 
and energy moving heavy pieces of furniture around!

Design-A-Room's intuitive interface makes rearranging furniture almost a pleasure!

Design-A-Room  comes with the following files:

SETUP.EXE - Installation program
DARSETUP.EXE - Design-A-Room Setup
DESIGN.EXE - Main program
CUSTOM.CFG - Custom Toolbar configuration file
DESIGN.HLP - Help file
DESIGN.WRI - This file
DEMO.ROM - Sample room
README.TXT - Getting started information
VBRUN300.DLL - Visual Basic DLL
COMMDLG.DLL - Visual Basic DLL
CMDIALOG.VBX - Visual Basic file
*.BMP - Furniture, fixture, and other program icons (69 files) 

Installation

To install Design-A-Room, open Windows Program Manager, and select "Run" from the



"File" menu.  When prompted for the file name, type the name of the drive and 
directory the files are in and SETUP (example: A:\SETUP).

Setup will uncompress and copy the files to the proper directory and create a 
Program Manager Group and icon.

To start a room:

Measure the actual walls and furniture pieces of the room you want to design. This is the most 
critical step. The more accurate your dimensions are, the more accurate you final room will be.

When measuring, measure the length and the width, looking down from the top. When measuring 
odd-sized pieces, such as a grand piano, or a round table, measure the longest dimensions each 
way. 

Start with the top wall. Click the left mouse button on the left/right wall icon to put it in the room. 
This will put the icon in the bottom right-hand corner of the room. Drag the wall icon close to the 
left-hand-side of the room. Let go of the mouse button. Then, by clicking the left mouse button 
just to the right of the icon, and holding the mouse mouse button down, drag the end on the wall 
icon to the right, watching the botton of the screen until you get to the correct length and let go of 
the mouse button. Then use the mouse to drag the piece exactly into place. The numbers at the 
bottom of the screen will show the exact position of the upper left-hand-corner of the icon. 

Repeat the above steps to add other walls, doors, windows, and other fixtures.

To change the size of the possible room (screen size):

The size of the room has been enlarged from the Shareware version. It is only limited to 100' by 
100', or the screen resolution of your system. 

To increase the screen resolution, it is necessary to run the Windows Setup program, and change 
your resolution from 640x480 to either 800x600 or 1024x768. You must have a monitor and video 
card capable of displaying this resolution to do this. You may also need the Windows installation 
disks, or the display drivers that cam with your video card for the desired resolutions and colors. 
See your Windows 3.1 manual and the manual for your graphics card and monitor for information 
on how to change your screen resolution. 

With the larger resolutions, you can "mazimize" the Design-A-Room window in order to see a 
larger work area. It may be necessary to use the "Windows" menu in order to see and use the 
icon bars. 

To place furniture in the room:

After you have the fixtures place, add all of your furniture following the same procedure as above. 
After a piece is in place, it can be easily moved to another location by dragging it, or re-sized by 
dragging just outside the icon.

To move a piece of furniture or fixture:

Simply drag it to the new location with the mouse.



To re-size a piece of furniture or fixture:

Move the cursor over the desired item.  Then, placing the mouse cursor just outside the furniture 
box, and holding the left button down, move until desired size is achieved.

To duplicate a piece of furniture or fixture:

Click on the piece of furniture with the RIGHT mouse button to select it. Go to the "Edit" menu 
and choose "Copy." Then choose "Paste." A duplicate of the piece of furniture will appear at the 
top corner of the room. Click on this piece of furniture and then move or resize it as necessary. 

To cut out a piece of furniture or fixture:

Click on the piece of furniture with the RIGHT mouse button to select.  Go to the "Edit" menu and 
choose "Cut."  Then the piece can be pasted in a new location with the "Paste" command.

To delete a piece of furniture or fixture:

Click on the piece with the RIGHT mouse button, then go to the "Edit" menu, and choose 
"Delete".

To turn "Snap-to-Grid" on or off:

Go to the "Options" menu, and click on "Snap to Grid."  This will turn "Snap-to-Grid" off. Clicking 
on it again turns it on.  With "Snap-to-Grid" on, furniture and fixtures automatically "snap" to the 
nearest grid line as they are moved or resized.  These lines are six inches apart.  With "Snap-to-
Grid" off, pieces can be moved to the nearest inch. 

To show pieces without outlines:

Go to the "Options" menu, and click on "Show Outlines."  Use "Show Outlines" to easily set up 
your room then turn them off to view the finished product.

Note:  It is much easier to set up your room with "Show Outlines" turned on.

To turn the grid or scales on or off:

Go to the "Options" menu, and click on "Display Grid" to turn the grid on or off, or click on 
"Display Scales" to turn the scales on or off.

To create your own icons:

Go to the "Options" menu, and choose "Custom Toolbar." Click on a blank icon, and choose 
"edit." Design-A-Room will then automatically run Windows Paintbrush, and load the icon onto the 
screen. Note: you must have Windows Paintbrush on your system for this option to work. This 
program is included with Windows 3.1, so consult your manual if it is not available.

Click on "View", then "Zoom in,"  then click on the blank icon. This will enlarge the icon to a series 
of small squares. You can then use Paintbrush to draw your icon, using the colors at the bottom 
of the screen. When you are finished editing your icon, click on "View" then "Zoom out." Then 



click on "File," then "Save," then "File," then "Exit."

To edit another icon, click on the desired icon file, then click on "Edit." Otherwise, click on "Done," 
to return to Design-A-Room. 

To change the names of the icons, click on a name in the list (e.g. "Custom #1") then type the 
new name (e.g. "Workbench") in the box labeled "Name:."  Whenever you select this icon in the 
future, it's new name will be shown on the screen.

The custom icons can be re-edited or changed as often as desired. 

The custom icons work on the screen just as the regular ones do. 

The Cutom Toolbar is not shown on the screen by default.  To show the Custom Toolbar, select 
"Custom" from the "Window" menu.

Note: Design-A-Room uses the same custom toolbar for all files.  Therefore, changing the icons 
will cause them to change in all previously saved files.  Do not attempt to change the filenames of  
any of the Design-A-Room files outside of the program, as doing this will cause errors while 
running the program. 

To add text to your rooms:

Go to the "Text" menu, then click on "Fonts..."  This will bring up the Fonts dialog box which will 
alow you to select the font, size, and color of your text.  You can also select special effects such 
as bold, underline, italics, and strikethru.

Once you have selected a font, go to the "Text" menu, then click on "Add text." This will put a 
small, blank rectangle in the bottom right-hand-corner of the screen. Move the box into place and 
enlarge it by dragging the bottom right-hand-corner to the desired size. Type in your text as 
desired. When you are finished, you can move and re-size the text box as you would a regular 
icon. You can also put the text box on top of a regular icon box, if desired.

Once a text box is on the screen, you can Cut, Copy or Delete it just like an icon.  Simply select 
the text box by clicking on it with the RIGHT mouse button.  Then you select "Cut," "Copy," or 
"Delete" from the "Edit" menu.  Once the text has been cut or copied, you can use the "Paste" 
command to place it anywhere on the screen.

Note: The "Show Outlines" command does not affect text boxes. To better see where the text box  
is, be sure to turn the grid on from the "Options" menu. 

To save a finished room:

Go to "File" menu and choose "Save" or "Save As."  "Save" will save the current room with the 
current filename. "Save As" will let you save the file under a different name.

Design-A-Room automatically adds the extension "ROM" to all saved room files. 

To load a previously made room:

Click on the "File" menu. Choose "Open."  Click on the the desired file, and then click on "OK."



Note: This version of Design-A-Room introduces a new, enhanced file format.  It will read files 
from all previous versions and, when they are saved, they will be saved in the new format.

To start a new room:

Click on the "File menu. Choose "New." 

To print the room:

From the "File" menu, choose "Print."

Note: The room will print as it appears on the screen, so to print without the outlines, grid, or 
scales, simply turn them off from the "Options" menu before printing.

To exit the program:

From the "File" menu, choose "Exit."

We can be reached for questions, comments, etc.
at the above address or: 
by calling (513) 563-4871
by calling The Epsilon Computing Board at (513) 563-6475 (our BBS)
by Netmail to Scott Mace or Bob Mace at Net/Node 006/042 on the GT Power Network
on CompuServe (user ID: 72712,2320) or 
on Internet (macers@ctrvax.vanderbilt.edu).  

Call The Epsilon Computing Board for information and new programs.

Thank you for registering Design-A-Room  !


