
1 - Contents - DesignWorkshop Guide 

 Artifice, Inc.

Contents - DesignWorkshop Guide

Guide Foyer | Guide Topics | Guide Index | Overview | Tools Reference | Techniques

1 - Guide Contents

2 - Overview

u 2.1 - Introduction to DesignWorkshop 
u 2.2 - Quick-Start Notes 
u 2.3 - Installation for Macintosh 
u 2.4 - Installation for Windows 
u 2.5 - New Features 
u 2.6 - DesignWorkshop Features 
u 2.7 - Release Notes

3 - Tools Reference

u 3.1 - Tool Palette
u 3.1.1 - Selection and Crosshair Tools 
u 3.1.2 - Creation Tools 
u 3.1.3 - Overlay Tools 
u 3.1.4 - Opening Tools 
u 3.1.5 - Color Tools 
u 3.1.6 - Special Editing Tools 
u 3.1.7 - Working Orientation Tools 
u 3.1.8 - Viewing Tools

u 3.2 - Window Functions
u 3.2.1 - Standard Document Window 
u 3.2.2 - Lights and Textures Window 
u 3.2.3 - Phases Windoid 
u 3.2.4 - Object Info Windoid 
u 3.2.5 - Views Windoid 
u 3.2.6 - Walkthrough Windoid

u 3.3 - Menu Functions
u 3.3.1 - File Menu 
u 3.3.2 - Edit Menu 
u 3.3.3 - Layout Menu 
u 3.3.4 - Arrange Menu 
u 3.3.5 - View Menu 
u 3.3.6 - Notes and Windows Menus

4 - Tutorial

u 4.1 - Start Here - Key Concepts 
u 4.2 - First Tutorial - Building a Classic House 
u 4.3 - Building A Contoured Site Model 



u 4.4 - Constructing a Spatial Dormer

5 - Techniques

u 5.1 - Materials Overview
u 5.1.1 - Overview of Material Types 
u 5.1.2 - Material Handling Sequence 
u 5.1.3 - "DW Material Prefs" File

u 5.2 - Making Your Own Tiled Textures 
u 5.3 - Making a Spotlight Shine Upwards 
u 5.4 - If Lights Don't Seem To Shine

6 - Troubleshooting

7 - Contacting Artifice

8 - Accessories (online only)

u 8.1 - 3D Libraries
u Appliances-Kitchen, Cabinets-Kitchen, Columns-Classical, Columns-Classical-Detail, Contexts-Mall 
Exterior, Contexts-Mall Interior, Doors-Exterior-Commercial, Doors-Exterior-Garage, Doors-Exterior-
Residential, Doors-Interior, Escalator, Fixtures-Bathroom, Fixtures-Commercial, Forms-Gothic Style, Forms-
Multifaceted-Cuboids, Forms-Multifaceted-Slabs, Forms-Multifaceted-Snakes, Forms-Multifaceted-
Spheroids, Forms-Pitched Roofs, Forms-Roman Style, Forms-Trusses, Furniture-Bedroom, Furniture-
Bedroom-Beds, Furniture-Chairs, Furniture-Chairs-Designer, Furniture-Chairs-Office, Furniture-Couches, 
Furniture-Couches-Designer, Furniture-Couches-Sectional, Furniture-Desks, Furniture-Desks-Special, 
Furniture-Living Room, Furniture-Outdoor, Furniture-Shelving, Furniture-Tables, Furniture-Tables-Office, 
Landscape-Accessories, Landscape-Accessories-Bollards, Landscape-Accessories-Lighting, Landscape-
Fencing, Landscape-Plants, Landscape-Street Signs, Lettering-Poly-Sans Serif, Lettering-Solid-Sans Serif, 
Lighting-Ceiling Mounted, Lighting-Exterior, Lighting-Freestanding, Lighting-Theatrical, Lighting-Wall 
Mounted, Office-Equipment, People-Block Figures, People-Silhouette, Recreational Equipment, Stairways, 
Trees-Conifer-Detail, Trees-Conifer-Massing, Trees-Deciduous-Detail, Trees-Deciduous-Massing, Trees-
Palm, Utility Room, Vehicles-Massing, Vehicles-Sedan, Vehicles-Silhouette, Vehicles-Trucks-Utility, 
Windows-Classical, Windows-Modern, Windows-Traditional,

u 8.2 - Materials
u Brick & CMU Masonry, Carpet & Flooring, Facade Textures, Fabric & Leather, Landscape, Metal, 
Miscellaneous Materials, Paint, Pavers & Paving, Roofing & Shingles, Siding & Stucco, Stone, Tiles, Wood

9 - Guide Index 

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index

© 1998 Artifice, Inc. - All Rights Reserved. 





Foyer - DesignWorkshop Guide 

    

            DesignWorkshop User Guide 

Guide Foyer | Guide Topics | Guide Index

Overview

Introduction to DesignWorkshop, Quick Start Notes, New Features, Release Notes.

Guide Topics

A Table of Contents with links organized by major topic.

Tools Reference

The Tool Palette, Menu Functions, Document and Floating Windows.

Techniques

Introductory Tutorial, Materials and Rendering Tips.

Accessories

Standard Materials Library, 3D Objects Library.

Troubleshooting

General Issues, Modeling, Lights and Textures, Translation Conflicts

Contacting Artifice

How to get in touch with Artifice for technical support, sales, or any other purpose.

Guide Index

Detailed index with links organized alphabetically.

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index



© 1998 Artifice, Inc. - All Rights Reserved





9 - Index - DesignWorkshop Guide 

 Artifice, Inc.
DesignWorkshop

Index - DesignWorkshop Guide

Guide Foyer | Guide Topics | Guide Index | Overview | Tools Reference | Techniques

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

3D Objects Catalog   (online)

A

Adjust Section Planes   3.3.3
Align Objects   3.3.4
Appliances-Kitchen   (online)
application memory   6.0
Arbitrary Working Orientation in Tool Palette   3.1.7
Arbitrary Working Orientation in Layout menu   3.3.3
Arc Tool   3.1.2
Arrange Menu   3.3.4

B

Backgrounds   3.3.1
Background Grids   3.3.3
Block Tool   3.1.2
block, moving, moving one edge, resizing, tweaking   3.1.1
Brick   (online)
Brighten Model Lights   3.3.5
Brighten Sun   3.3.5

C

Cabinets-Kitchen   (online)
Cancel Hide   3.3.4
Cancel Projection Lines   3.3.4
Carpet   (online)
Circle Faceting   3.3.3
Circle Tool   3.1.2
CMUs   (online)
Color Picker   3.1.5
Color Tools   3.1.5
Columns-Classical   (online)
Columns-Classical-Detail   (online)



Contacting Artifice   7.0
Contexts-Mall Exterior   (online)
Contexts-Mall Interior   (online)
Contour Tutorial   4.3
Contrast   3.3.5
conversion between units   3.3.3
Copy   3.3.2
Cottage Tutorial   4.2
Creation Tools   3.1.2
Credits   7.1
Cut   3.3.2

D

DesignWorkshop Features List   2.6
DesignWorkshop Technical Support   7.0
DesignWorkshop -> DXF -> MiniCAD   6.0
Dim Model Lights   3.3.5
Dim Sun   3.3.5
Doors-Exterior-Commercial   (online)
Doors-Exterior-Garage   (online)
Doors-Exterior-Residential   (online)
Doors-Interior   (online)
Dormer Tutorial   4.4
Drawings, exporting   3.3.1
Drawings, importing   3.3.1
Duplicate   3.3.2
Duplicate Linear   3.3.2
Duplicate Circular   3.3.2
Duplicate Mitered   3.3.2
Duplicate multiple   3.3.2
"DW Material Prefs" File   5.1.3
DXF drawing, exporting   3.3.1
DXF drawing, importing   3.3.1
DXF model, exporting     3.3.1
DXF model, importing   3.3.1

E

E, S, and V Fields   3.2.1
East Elevation Working Orientation   3.1.7
Edit Menu   3.3.2
Edit Views   3.2.5
Editing Tools, Special   3.1.6
Elevation View   3.3.5
Escalator     (online)
Export   3.3.1
Eye Dropper   3.1.5
Eye Point   3.1.8
Eye Tool   3.1.8

F

Fabric   (online)
Facade Textures   (online)
Faces Mode   3.1.6
Features List - Complete   2.6
Features - New   2.5
feet and inches   3.3.3
File Menu   3.3.1
Fit Objects   3.3.4
Fixtures-Bathroom   (online)



Fixtures-Commercial   (online)
floating windows   (online)
Flooring   (online)
Forms-Gothic Style   (online)
Forms-Multifaceted-Cuboids   (online)
Forms-Multifaceted-Slabs   (online)
Forms-Multifaceted-Snakes   (online)
Forms-Multifaceted-Spheroids   (online)
Forms-Pitched Roofs   (online)
Forms-Roman Style   (online)
Forms-Trusses   (online)
Furniture-Bedroom   (online)
Furniture-Bedroom-Beds   (online)
Furniture-Chairs   (online)
Furniture-Chairs-Designer   (online)
Furniture-Chairs-Office   (online)
Furniture-Couches   (online)
Furniture-Couches-Designer   (online)
Furniture-Couches-Sectional   (online)
Furniture-Desks   (online)
Furniture-Desks-Special   (online)
Furniture-Living Room   (online)
Furniture-Outdoor   (online)
Furniture-Shelving   (online)
Furniture-Tables   (online)
Furniture-Tables-Office   (online)

G

grid lines   3.3.3
Grid Tool   3.1.1
Group Objects   3.3.4

H

Hidden Line   3.3.5
Hide Objects   3.3.4

I

Import   3.3.1
Installation for Macintosh   2.3
Installation for Windows   2.4
Introductory Tutorial   4.1
Introduction to DesignWorkshop   2.1
Invert Hide   3.3.4

J

K

L

Landscape   (online)
Landscape-Accessories   (online)
Landscape-Accessories-Bollards   (online)
Landscape-Accessories-Lighting   (online)
Landscape-Fencing   (online)
Landscape-Plants   (online)
Landscape-Street Signs   (online)
layers   3.2.3
Layout Menu   3.3.3



Leather   (online)
Less Contrast   3.3.5
Lettering-Poly-Sans Serif   (online)
Lettering-Solid-Sans Serif   (online)
Library of 3D Objects   (online)
Library of Materials   (online)
Lighting-Ceiling Mounted   (online)
Lighting-Exterior   (online)
Lighting-Freestanding   (online)
Lighting-Theatrical   (online)
Lighting-Wall Mounted   (online)
Lights and Textures   3.2.2
Lights Don't Seem To Shine   5.4
LightWorks Plug-In Renderers   2.5
Line Tool   3.1.2
Location Bar   3.2.1
Look Point   3.1.8
Look Tool   3.1.8
Look Tool for interactive walkthroughs   2.5

M

Macintosh Installation   2.3
Main Window   3.2.1
Making a Spotlight Shine Upwards   5.3
Making Your Own Tiled Textures   5.2
Markup Tools   3.1.3
Masonry   (online)
Materials Overview   5.1
Material Handling Sequence   5.1.2
Materials Catalog   (online)
Material Types   5.1.1
Memory Requirements   6.0
Memory Usage   6.0
Menu Functions   3.3
Metal   (online)
MiniCAD -> DXF -> DesignWorkshop   6.0
Miscellaneous Materials   (online)
mitering   3.3.2
More Contrast   3.3.5
move a block   3.1.1
move the Eye Point   3.1.8
move the Look Point   3.1.8
multi-segment lines   3.1.2
multiple duplicate   3.3.2

N

New Features   2.5
New Model   3.3.1
New Window   3.3.6
Notes Menu   3.3.6
numerical entry into the Location Bar   3.2.1
numerical entry into the Object Info box   3.2.4

O

Object Info Windoid   3.2.4
Object PICTs   3.3.1
object rotation   3.1.6
Office-Equipment   (online)
Openings, Paste into   3.3.2



Opening Tools   3.1.4
Overlay Tools3.1.3
Overview   2.0

P

Page Setup   3.3.1
Paint   (online)
Paste   3.3.2
Paste into Opening   3.3.2
Pavers   (online)
Paving   (online)
People-Block Figures   (online)
People-Silhouette   (online)
Perspective   3.3.5
Phases Floating Window   3.2.3
PICT   3.3.1
Plan   3.3.5
Plan Working Orientation   3.1.7
Plug-In Renderers   2.5
Poly-Lines   3.1.2
Poly-Line Tool   3.1.2
Poly-Opening Tool   3.1.4
Poly-Wall Tool   3.1.2
Print   3.3.1
Printer, not selected in Chooser   6.0
Projection Lines   3.3.4

Q

Quick Start Notes   2.2
QuickDraw 3D Hardware Accelerators   2.5
QuickDraw 3D Window   3.2.2

R

Radiance, exporting   3.3.1
Recreational Equipment   (online)
Rectangle Tool   3.1.2
Rectangular Opening Tool   3.1.4
reflectivity   5.1.4
Release Notes   2.7
reshaping   3.1.6
Reshape Tool   3.1.6
resizing   3.1.1
Roofing   (online)
Rotate Tool   3.1.6
rotation   3.1.6

S

Save   3.3.1
Save As   3.3.1
Scale   3.3.2
scaling backgrounds   3.3.1
Scroll Bars   3.2.1
Section   3.3.5
section, adjust planes   3.3.3
Selection Tool   3.1.1
Set View   3.3.5
Setup Walkthrough   3.3.5
Shading   3.3.5



Shadow Casting   3.35
Shadow Casting, setting up   3.3.4
Shingles   (online)
Show Clipboard   3.3.2
Show Object Info   3.3.3
Show Phases   3.3.3
Show Projection Lines   3.3.3
Siding   (online)
Single Line Tool   3.1.2
smoothness   5.1.4
snap grid   3.3.3
Snap to Handles   3.1.1
South Elevation Working Orientation   3.1.7
specularity   5.1.4
Stairways   (online)
Stucco   (online)
Stone   (online)
Sun and Shading Settings   3.3.4
sun studies   3.3.5
Sun Study   3.3.5
Sunlight   3.3.5

T

Technical Support   7.0
Techniques   5.0
Tiles   (online)
Tool Palette   3.1
Tools Reference   3.0
Transparency - how to define   5.1.1
Transparency - troubleshooting   5.0
Trees-Conifer-Detail   (online)
Trees-Conifer-Massing   (online)
Trees-Deciduous-Detail   (online)
Trees-Deciduous-Massing   (online)
Trees-Palm   (online)
Trim Tool   3.1.6
Troubleshooting   5.0
Tutorial Introduction to DesignWorkshop   4.1
Tutorials   4.0

U

Undo   3.3.2
Ungroup Objects   3.3.4
units   3.3.3
Utility Room   (online)

V

Vehicles-Massing   (online)
Vehicles-Sedan   (online)
Vehicles-Silhouette   (online)
Vehicles-Trucks-Utility   (online)
View Menu   3.3.5
Viewing Tools   3.1.8
Views Windoid   3.2.5

W

Walkthrough, interactive   3.1.8
Walkthrough, run   3.3.5



Walkthrough, setup   3.3.5
Walkthrough Windoid   3.2.6
wall thickness   3.3.2
Wallify   3.3.2
Window, Document   3.2
Window, Floating   3.2
Window Functions   3.2
Windows Installation   2.4
Windows Menu   3.3.6
Windows-Classical   (online)
Windows-Modern   (online)
Windows-Traditional   (online)
Wood   (online)
Working Orientation, setting   3.3.3
Working Orientation Tools   3.1.7
Working Units   3.3.3

X

Y

Z

Zoom-In Tool   3.1.8
Zoom-Out Tool   3.1.8
Zoom Percentage   3.1.8

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index

© 1998 Artifice, Inc. - All Rights Reserved. 





2 - DesignWorkshop Overview 

 Artifice, Inc.
DesignWorkshop

DesignWorkshop Overview

Guide Foyer | Guide Topics | Guide Index | Overview | Tools Reference | Techniques

Introduction to DesignWorkshop 

An overall introduction to the DesignWorkshop modeling, rendering, and viewing environment. 

Quick Start Notes 

If you want to jump right in and start modeling ASAP, read this. 

Installation for Macintosh 

Instructions for installing DesignWorkshop on Power Macintosh computers. 

Installation for Windows 

Instructions for installing DesignWorkshop on Windows 95/NT computers. 

New Features 

A list of changes made to DesignWorkshop between recent released versions. 

Release Notes 

Notes about DesignWorkshop, containing basic information about the program.
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The Tool Palette

Descriptions of the functions controlled by each icon in the Tool Palette.

Menu Functions

In-depth explanation of every menu command.

Window Functions

Explanation of document and floating windows.
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DesignWorkshop Introductory Tutorial

Materials Overview

Material Types, Materials Management, The "DW Material Prefs" File.

Lights & Textures Tips

Making Your Own Tiled Textures 

This is a step by step guide to making your own Tiled_Textures for use in DesignWorkshop, working completely within 
the built-in the functions of Adobe Photoshop 3.0. 

How to Make a Spotlight Shine Upwards 

There's a simple trick to making a spotlight which shines upward in DesignWorkshop, and these notes show how to 
do it. 

If Lights Don't Seem to Shine 

Depending on how your model is constructed, light sources may be shining in the Lights and Textures window, but 
you may not see the light. Here is an explanation of what's going on, and how to get the results you want.
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A Simple Modeling Environment 

DesignWorkshop is a three-dimensional modeling program for architectural design and related endeavors. Its unique 
interface makes it more profoundly "Mac-like" than any prior modeling software. This interface allows it to support 
actual design in three dimensions, as opposed to just recording design ideas already worked out with other media.

The power and flexibility of DesignWorkshop are based on the direct manipulation of 3D objects in three-dimensional 
space. This is accomplished with a three-dimensional crosshair, controlled by the standard Macintosh mouse. 
Dragging the mouse around on the table top moves the crosshair around in a horizontal plane, and dragging the 
mouse with the Option key (the Alt key for Windows) held down (option-dragging) moves the crosshair vertically in the 
model space.

Models are built from solid objects such as blocks, which are drawn with the Block tool by dragging out a base 
rectangle, and then option-dragging up the height in continuation. Although a full range of views are available for 
editing, most work is accomplished in a realistic perspective or axonometric view. 

Maximum Power from the Minimum Number of Tools 

To adjust and create building forms, basic blocks can be built and transformed in various ways. No specific menu 
commands or tool icons are needed for most transformations in DesignWorkshop, including moving, resizing, 
reshaping, extruding most objects. Just push and pull on the objects and their handles to accurately create almost 
any building form.

Instead, these transformations are part of the DesignWorkshop environment, performed with the default selection 
cursor. For instance, a block can be resized or reshaped (in three dimensions) by dragging on object handles. Non-
quadrilateral solid objects can be created by drawing a polyline profile and then pulling the profile out into space. This 
extrusion is done by dragging up on an object handle, again with no special mode or command necessary.

To summarize, when in the default selection mode, to move a block, drag it in three dimensions from anywhere 
except on one of its handles. To resize a block, drag on a corner handle of the block (shown in solid black). To move 
one edge of a block, drag on a mid-edge handle, (shown in outline). To tweak a block, meaning move just one corner 
to distort the block out of square, command-drag on a corner handle (with the Command key (the Control key for 
Windows) held down before the mouse button for dragging). Finally, to extrude a 2D polyline into a true 3D solid, just 
drag up on a corner handle (using the Option key).

Viewing operations are also simple and direct. To move the eye-point, click on the Eye tool, and then drag in the 
model window to move your viewpoint around or over the model. To move in and out from the model, option-drag with 
the Eye tool. The center of interest is moved similarly with the Look tool (target icon). When the Eye or Look tool is 
selected, views can be nudged with the arrow keys (with option up-arrow to move in or option down-arrow to move 
out).

The "working orientation" of the crosshair can be changed with an icon click to facilitate horizontal extrusion, drawing 



in an elevation plane, and vertical rotations. More specific manipulations can be accomplished with particular tools, as 
described in the tools section. 

Design-Oriented CAD 

DesignWorkshop has been created from the ground up to provide a powerful, natural, broad-spectrum design 
environment for architects and related designers. Graphically oriented computers have become an efficient means for 
the production of construction documents, but despite large advances in computer graphics capabilities, traditional 
computer-aided drafting software has failed as a professional tool for creative design work. DesignWorkshop is 
different. Over a period of years, our research has focused on the interaction between existing design media, such as 
pencil and paper sketching, and design processes. This has provided the foundation for a new approach to design-
oriented CAD.

It is vital for any real design tool to get out of the way of the creative process. In the hands of an experienced user, 
pencil and paper certainly get out of the way. With a moderate amount of practice, the classic Macintosh 2D drawing 
interface also gets out of the way, allowing the designer to focus on images and ideas. This is possible because the 
total interface including noun-verb selection syntax, direct graphic manipulation of objects, and a minimalist iconic 
command set allows the designer to produce graphic results with a small set of fairly general functions.

This power of the Macintosh drawing interface is opposite in approach to traditional CAD software, which tends to use 
a large set of very specialized commands to produce drawings in a painstaking and linear process. But, in the 
traditional CAD environment, becoming more expert can actually make it more difficult to get back to a creative 
aesthetic or problem-solving mode, as command complexity is accumulated.

DesignWorkshop solves this contradiction by extrapolating the classic Macintosh drawing approach into three 
dimensions, building a familiar-seeming though fundamentally new interface. The interface is familiar because it 
builds directly on the standard Macintosh way to perform key operations. For instance, to move an object, the user 
can simply click on it, then drag it to a new location anywhere in the model space. To resize an object, the user 
selects and then drags on object handles. Advancing these familiar methods from the 2D Macintosh drawing world 
into 3D provides tremendous modeling flexibility using just a few commands. 

True 3D Direct Manipulation 

The DesignWorkshop interface is also fundamentally different. To allow 3D direct manipulation, interaction is based 
on a three-dimensional crosshair, easily controlled by the standard mouse. Dragging the mouse around on the table 
top moves the crosshair horizontally, in an x-y plane, while dragging with the Option key (the Alt key for Windows) 
moves the crosshair vertically. By dragging the mouse and pressing and releasing the Option key, the crosshair can 
be moved quickly anywhere in the model space. The 3D crosshair brings the design tool into the model space, 
instead of floating across the 2D window like a normal cursor. This is the foundation for a complete 3D analog of the 
classic Macintosh drawing environment.

The proof of this approach is that major 3D editing operations like moving, resizing, and reshaping objects are 
accomplished interactively in perspective or axonometric view in the default selection mode, without giving any 
commands. Poly-lines are extruded into solid objects just by pulling up on them (or sideways, if the lines were drawn 
in an elevation plane). DesignWorkshop will automatically supply a missing segment if necessary to form a solid 
when extruding, and extrusions are readily reshaped, interactively, in place, with object-global transformations in 
default mode or by local transformations when in the special reshape or faces modes. 

Feature-based Solid Modeling 

The crosshair is coupled with an underlying object-oriented geometric structure classified as feature-based solid-
modeling. This approach means, for instance, that a complete 3D window object can be put in a solid wall object just 
by clicking on the Opening tool icon, then dragging a rectangle on the face of a selected wall. The crosshair aligns to 
the wall automatically. After the opening has been drawn, it can be selected by clicking and then moved around the 
wall, and it size and proportion can adjusted by dragging on a corner handle. It is duplicated by the Duplicate menu 
function (or the standard Command-D shortcut), or deleted by hitting the Delete key (the Backspace key for 
Windows), leaving a solid healed wall.

Innovations at other levels of the program support the three-dimensional architectural design environment. Two 
innovations that support accurate working in free 3D space are Space-Jump and "projection lines". Space-Jump 
allows instant setting of the crosshair to the position of an existing object handle (for instance, to draw a roof on top of 
a wall or building mass) by converting a 2D alignment of the 2D cursor into a 3D alignment of the 3D crosshair when 



the spacebar is tapped.

Projection lines are like outline shadows cast vertically from objects down onto the ground plane. These show 
automatically for selected objects and objects being created, and for other objects as turned on and off with functions 
in the Arrange menu. The viewer's perceptual system learns to automatically and unconsciously use the projection 
lines in building a correct mental model of a 3D scene in wireframe view. For instance, without projection lines you 
might not be able to see the difference between a small block close to the view point and high above the ground 
versus a large block in the distance sitting on the ground. 

Beyond Working Planes 

The 3D crosshair makes the traditional "working planes" concept somewhat obsolete, because the 3D crosshair 
allows immediate access to all parallel planes. (This family of parallel planes includes all those perpendicular to the 
current "z" axis.) Instead, we talk about the "working orientation," which can be switched instantly from plan to an 
elevation plane or to the perpendicular elevation plane. Also, with a simple double-click on the arbitrary working 
orientation tool, the working orientation can be set to any arbitrary location, twist, and tilt in space, or matched 
instantly to the attitude of a selected object or object face.

The viewing tools are also based on 3D direct-manipulation, and from the building designer's perspective. On a 
typical hardware-graphics 3D workstation, dynamic view controls are used to move a part around on screen to see it 
from different angles. This is subtly incorrect for architectural work, because, unlike mechanical parts, buildings do not 
move. In life, to see a building from another aspect, the viewer moves rather than the building. 

Immersion-based View Controls 

Much as we move through the real world, in DesignWorkshop, dragging in the scene with the Eye tool moves the 
viewpoint around the scene in real time, pivoting around the center of interest. Holding down the Option key (the Alt 
key for Windows) while dragging up or down moves the viewpoint into or out from the scene. The Look tool is used to 
drag around the center of interest, or "look point", providing the equivalent of standing in one place and looking 
around. With simple, interactive view adjustment, shifting the view a bit to see the project differently, check a sight 
line, or inspect an alignment becomes natural, frequent, and nearly unconscious.

Fast 2D zooming functions allow the user to get into and out of detail, and 2D panning is controlled by standard Mac 
scroll bars. Multiple windows can be opened simultaneously showing a model from several views, and multiple 
models can be opened at once, with standard clipboard cut-and-paste of 3D objects between models. Particular 
views are easily saved, with the name of each saved view added to the bottom of the View menu for easy access. 
These saved views form the starting point for walkthrough scripting, with variable interpolation.

The goal of making DesignWorkshop a fast and efficient tool for architecture has driven the detailed modeling 
features as well as the fundamental interface. For instance, the Edit menu Wallify function turns multiple selected 
massing blocks into walls enclosing spaces in one menu pick. The Object Info box allows direct inspection and quick 
numerical editing of object dimensions, orientation, etc. Objects carry material information, and, optionally, object 
names and data. All coordinate information is floating point, so there are no worries about scale changes and 
rounding errors.

At any stage in its development, a model can be viewed and edited in shaded or hidden-line view for visual 
completeness, or in wireframe for speed. The shading routines include such architectural niceties as automatic poché 
of cut faces in section views. Shadowcast renderings are done in 32-bit color with an object-oriented algorithm, and 
sun angles are set by time, date, and latitude. The sun study function renders sequential time-lapse frames in parallel 
and directly saves QuickTime movies. 

The Virtual Building Toolkit 

Now with DesignWorkshop, automatic texture-mapping coupled with real-time QuickDraw 3D rendering makes 
detailed visualization easy for interiors and landscapes as well as building exteriors. With personal computer 
technology constantly improving, the combination of easy direct manipulation modeling with realistic immersion 
viewing is no longer just a dream or a promise. With DesignWorkshop, it's right at your finger tips.

Whether your work is traditional architectural design, or modeling of virtual spaces for the Internet, theatrical or exhibit 
design, interior or exterior, in rough early design sketches or in beautiful renderings for marketing a completed 
project, DesignWorkshop is probably just the fastest way to bring your creative ideas to life.
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Quick Setup

1. Please read this through.   DesignWorkshop¨ is very natural and friendly to use, but there are a few 
conceptual issues to understand as you jump in. 
2. Install DesignWorkshop and QuickDraw 3D. 

To install DesignWorkshop on Macintosh from the DesignWorkshop CD-ROM, copy the folder 
"DesignWorkshop¨ Folder" to your hard disk, by simply dragging the folder from the CD-ROM onto the hard disk. 
That's all there is to it!

(Note: Metric users should drag the "DesignWorkshop¨ Metric" folder to the hard disk, and Japanese users 
should drag the "DesignWorkshop Japan" folder to the hard disk.)

New Power Macintoshes already have QuickDraw 3D installed. To install QuickDraw 3D on a Macintosh, if it is 
not already there, open the folder "QuickDraw 3D 1.5.3" on the CD-ROM, then open the folder "QuickDrawª 3D 
Install", and then double-click on the Installer application and follow the step-by-step process.

To install DesignWorkshop on Windows 95/NT, simply double-click on the "Setup.exe" installer application on 
the CD-ROM, and then follow the step-by-step process. The standard Windows installation of DesignWorkshop 
automatically includes QuickDraw 3D. 
3. Set the monitor color depth.   Thousands of colors mode (16 bit) is the preferred color depth setting for 
DesignWorkshop on both Macintosh and Windows systems. Adjust the system color depth with the appropriate 
control panel before starting up DesignWorkshop. 
4. Check the system memory settings.   If your Macintosh computer has 32MB or less RAM, virtual memory 
should be turned on with a total memory setting of 33MB, using the Memory control panel.

Note that the memory used by QuickDraw 3D (QD3D) is allocated to the System from the free memory when 
requested by DesignWorkshop. Application memory and rendering memory are separate in DesignWorkshop, 
and giving too large a memory allocation to the application can actually cause QuickDraw 3D to run out of 
memory unneccesarily.

Part One -- Moving Around a Building

1. Start by viewing one of the sample models provided.   To quickly see DesignWorkshop in action with 
QuickDraw 3D, drag and drop the model file "Maybeck Studio.dw" onto the DesignWorkshop application. This 
will start up DesignWorkshop and open the building model.



2. When the application has started up and the model is visible on screen in wireframe perspective in the 
standard document window, give the View menu Lights & Textures command to open a QuickDraw 3D 
document rendering window.

3. When the Lights and Textures window has opened, click on the Eye tool icon in the tool palette, on the left 
near the bottom. Move around the model, by just dragging with the eye tool in the model window. Drag to the 
right to go around the model to the right, to the left to go around to the left, and up and down to go higher and 
lower around the model. Hold down the Option key to move inward and outward with the Eye tool.

4. Use the View menu Lighting > Sunlight command to toggle the sun off and on, to see night time and day 
time views.

5. You can also use the File menu Merge File... command to read in the example 3DMF model Hatchback for 
Maybeck.3dmf. Switch the Lights & Textures window to Wireframe to see the degree of detail in the models, 
and for faster navigation on slower Macs without a QuickDraw 3D accelerator board, then switch back to 
Shading for the fully rendered view.

6. Practice moving around the model with the eye tool for a couple of minutes until it feels comfortable.

7. Click to bring the standard window to the front, and try out the different preset views in the standard window, 
using the View menu. With Hidden Line or Shaded rendering, go to the Plan view, Section, the four Elevations, 
and back to Perspective. Check and uncheck the Section menu item to turn the sectioning planes on and off. (To 
adjust the location of the planes, switch to wireframe and use the Layout menu Adjust Section Planes command). 
Note that with Shadow Casting on (in the standard window), all these views can be seen without having to 
regenerate the shadows.

8. Try some of the saved views listed at the bottom of View menu.

9. When you're looking at one of the saved views that puts you "inside" the model, try out the Look tool. This is 
the target icon, found near the bottom of the tool palette, right next to the Eye tool. Dragging the Look tool in the 
model window is like turning your head to look around in different directions.

10. To move your viewing location forward and backward in 3D, go back to the eye tool. In DesignWorkshop the 
third dimension is accessed with the Option key. So to move forward, in toward the center of the model, hold 
down the Option key, then drag the Eye tool upward on the screen. To move backward, hold down the Option 
key, then drag the Eye tool downward on the screen.

11. Using first the Eye tool and then the Look tool, you can move around the space dynamically, looking from 
anywhere, to anywhere.

12. If you ever get a bit lost in space with the Eye or Look tools, just use the View menu Initial View command to 
get back to a standard perspective overview.

Part Two -- Basic Building

1. When you're ready to start building, use the File menu New Model command to open a new model file.

2. Take a look at the 3D crosshair. First use the View menu Initial View command to get back to a standard 
perspective overview. Then click on the default Arrow tool at the top of the tool palette, and look in the model 
space. You should see two horizontal colored lines and one vertical colored line that come together at a point in 
space. This point of intersection is the 3D working-point of the 3D crosshair.

As you move the mouse around, you can see the crosshair move around horizontally in the model space. If you 
push the crosshair out near the distant horizon line, you can see two of the crosshair axes get small. The 
crosshair is really "inside" the 3D perspective space of the DesignWorkshop model, not just floating across the 
surface of the computer window like a regular 2D cursor. Move the crosshair around the model space a bit until 
you get comfortable with it.

3. The first, most important thing to know about the DesignWorkshop interface is that the horizontal dimensions 
of the 3D crosshair (x and y) are controlled by simple dragging with the mouse, (as you just experienced) and 



the third dimension ("z") is controlled by option-dragging.

4. A handy shortcut to get the crosshair back to zero elevation, right on the ground plane, is to simply type the "0" 
(zero) key on your keyboard. This is useful if you ever lose track of the crosshair location in space.

5. In DesignWorkshop, the Option key (the Alt key for Windows) always accesses the third dimension. For 
instance, the third dimension of the eye tool, which moves your eye point inward or outward from the center of 
the scene, is similarly accessed by holding down the Option key as you move the mouse forward and backward.

6. Blocks are created by dragging with the 3D crosshair, in a direct 3D analog to drawing a MacDraw-style 
rectangle. To make a simple block, click on the Block tool, then move the 3D crosshair to where you want to 
start drawing the block. Then press the mouse button, and first drag horizontally to draw the plan size of the 
block, and then, still holding down the mouse button, press the Option key (the Alt key for Windows) and drag up 
the height of the block. When you see the size you want on screen, release the mouse button.

7. Objects can be moved around just by dragging them, using the 3D crosshair to move freely both horizontally 
and vertically. Object handles must be grabbed three-dimensionally, and the Space Jumpª function makes 
accurate 3D grabbing quick and easy. To Space Jump, first align the 3D crosshair so the crosshair working-point 
is visually superimposed on an object selection handle you want to grab. Then, just tap on the space bar of your 
keyboard to turn the rough 2D visual alignment of the crosshair to an exact lock on the handle in 3D.

8. Dragging on a corner handle will resize an object, and dragging on any of the white mid-edge handles will 
move just that edge around, reshaping the object. The object handles must be grabbed three-dimensionally, by 
eye or by using the Space Jump function.

9. The other most important spatial location aids in DesignWorkshop are the Projection Lines. Projection lines 
are drawn on the ground plane for selected objects, like straight-down line shadows. Projection lines let your eye 
understand how high objects are when they're not sitting right on the ground. They let you see the plan 
configuration of forms you're moving or creating, right in the perspective view. And by watching the little "foot" on 
the 3D crosshair in relation to object projection lines, you can tell just where the 3D crosshair is in space, relative 
to the objects of your model. Projection lines show automatically for any selected object, plus they can be turned 
on and off for particular objects manually using the Arrange menu.

10. Be sure to try the Opening tool. Create a wall-shaped solid block, using the Block tool, and leave it selected. 
Then choose the Opening tool from the tool palette, on the left in the middle, just above the Eye-Dropper tool. 
Position the cursor over the front side of the selected block, then press down the mouse button and drag a 
rectangle on the block. This creates a rectangular opening in the block.

11. To move an opening around the face of a block, choose the Arrow tool in the tool palette, then click in the 
opening to select it, and just drag it to move it around. The opening behaves just like a MacDraw-style rectangle, 
so to resize, it, just click select it, and then drag on a corner handle. This works in shaded views, too!

Part Three -- Detailed Building

1. For advanced users, the Faces mode and the Arbitrary Working Orientations let you tilt, rotate, and place 
the 3D crosshair alignment to match any specific object in your model. For precise 3D positioning, 3D handle-
snapping is provided for most creation and editing operations. Handle snapping is turned on and off with the top 
right icon in the tool palette. These advanced functions, plus special functions, like Paste into Openings, and 
specific techniques for creating site models, domes, stairways, various roof forms, etc., are detailed in the 
DesignWorkshop User Guide.

2. The DesignWorkshop User Guide also include an illustrated step-by-step tutorial, providing an in-depth 
introduction to DesignWorkshop as you build a complete model of a small house.

3. The tools of DesignWorkshop are clear and simple. They are also relatively deep, and with a little effort over 
several days of practice you will find a fluency developing, leading to a direct, easy modeling style that uniquely 
supports the three-dimensional design and model-making process.



For More Information...

The Techniques sections of both the printed and online User Guides provide detailed notes on a variety of more 
specialized modeling tasks. We also post the latest tips and techniques information regularly in the Artifice World-
Wide Web area (www.artifice.com).

Please feel free to call us at 541-345-7421 for help answering any technical questions, or send us e-mail at 
"support@artifice.com". Unlimited technical support is free to registered owners of DesignWorkshop.
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To Install DesignWorkshop 

To install DesignWorkshop from the distribution CD-ROM, copy the folder "DesignWorkshop® Folder" to your hard 
disk by dragging it over.

To install QuickDraw 3D, open the folder "QuickDraw 3D 1.5.3" on the CD-ROM, and then the folder "QuickDrawª 3D 
Install", and then double-click on the Installer application.

To install the complete 3D libraries, copy the folder "3D Libraries" from the CD-ROM to your hard disk by dragging it 
over. You may install all or part of the libraries as you wish. 

System Requirements 

DesignWorkshop is fully native for the Power Macintosh, and requires a Power Macintosh with QuickDraw 3D 1.5.1 
or higher, and a minimum of 24MB of total RAM. 

Memory Requirements 

If your Macintosh has 32MB or less RAM, virtual memory should be turned on with a total memory setting of 33MB, 
using the Memory control panel. Note that the memory used by QuickDraw 3D (QD3D) is allocated to the System 
from the free memory when requested by DesignWorkshop. In other words, application memory and rendering 
memory are separate in DesignWorkshop, and giving too large a memory allocation to the application can cause 
QuickDraw 3D to run out of memory unneccesarily.
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To Install DesignWorkshop 

To install DesignWorkshop from the distribution CD-ROM, open the folder "DesignWorkshop" and double-click the file 
"Setup.exe".

Setup.exe will ake you through the installation process. Default path names are provided, so in most cases you can 
just accept the paths it suggests. The installer will install all the files required for DesignWorkshop.

After instaling, the DesignWorkshop folder will be in "C:\Program Files", unless you specified another location. The 
DesignWorkshop program will also be available through the Programs item in the Start menu.

To install the complete 3D libraries, copy the folder "3D Libraries" from the CD-ROM to your hard disk by dragging it 
over. You may install all or part of the libraries as you wish. 

System Requirements 

DesignWorkshop and requires a Pentium or better processor with QuickDraw 3D 1.5.1 or higher, and a minimum of 
32MB of total RAM.
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DesignWorkshop 1.7 New Features - since 1.5 | DesignWorkshop 1.5 New Features - since 1.2

Overview

With version 1.8, DesignWorkshop provides a complete, dual platform, solution for live 3D presentations and for 
professional-quality rendering in addition to its well-established immersion modeling capabilities.

A number of breakthroughs allow DesignWorkshop 1.8 to provide real-time rendering of Lights and Textures faster, 
more easily, and with higher quality. A new ultra-fast QuickDraw 3D geometry, the trimesh, is fully supported in 
DesignWorkshop. In addition, any QuickDraw 3D accelerator card is supported. DesignWorkshop now features an 
easy to use interactive walkthrough interface, allowing you to move through your creations with full lights and textures 
in real-time. DesignWorkshop include plug-in renderers which provide such high-end features as shadows, anti-
aliasing, and transparency without the need for hardware acceleration.

u Support for QuickDraw 3D 1.5.1
u Plug-In Rendering
u Advanced Viewing Capabilities
u Interactive Walkthrough Interface
u Support for any QuickDraw 3D Hardware Accelerator
u More Flexible Spotlights
u Greater Control Over Specularity
u New Metric and Japanese Versions
u Improved DXF Importing and Exporting
u Improved Radiance Export

QuickDraw 3D 1.5.1

DesignWorkshop 1.7 has been updated to provide full support for Apple's latest version of QuickDraw 3D, version 
1.5.1. You need to have QuickDraw 3D 1.5.1 or newer properly installed to take advantage of the high-end rendering 
capabilities of DesignWorkshop. QuickDraw 3D 1.5.1 is included on the DesignWorkshop CD. As newer versions of 
QuickDraw 3D become available, they will be accessible on the world wide web at http://quickdraw3d.apple.com

QuickDraw 3D 1.5.1 introduced a new form of geometry, the trimesh, which renders several times faster than older 
geometry forms. DesignWorkshop has complete support of the trimesh. Everything in your DesignWorkshop model 
will be converted to a trimesh when you view Lights and Textures, and will save as a trmesh when you save a 3DMF 
file.



DesignWorkshop also features the ability to convert existing 3DMF geometry into trimeshes. To take advantage of 
this, simply open a 3DMF in DesignWorkshop and choose the View > menu Rendering > Optimize Model command. 
This feature works on all 3DMFs, whether created in DesignWorkshop or another program, and it can increasing 
rendering speeds by up to 4 times.

Rendering Plug-ins

DesignWorkshop now supports QuickDraw 3D plug-in renderers which provide more rendering options than the 
interactive and wireframe renderers that are provided with QuickDraw 3D.

DesignWorkshop includes two plug-in renderers which add new high-end rendering capabilities to DesignWorkshop. 
The LightWorks SuperLite plug-in makes very high quality renderings on a pixel-by-pixel level. The LightWorks 
HiddenLine plug-in adds hidden line rendering, similar to what the DesignWorkshop standard window is capable of, to 
the Lights and Textures side of things. The combination of these renderers along with the standard QuickDraw 3D 
renderers complete the suite of rendering styles familiar to longtime users of DesignWorkshop: wireframe, hidden 
line, shading, and shadow casting, now with better quality and speed than before.

In QuickDraw 3D's normal interactive renderer there are no shadows, lights must hit many object vertices to be 
visible, there is no transparency without additional hardware, and renderings are not anti-aliased. The LightWorks 
SuperLite plug-in supports all these capabilities, all without hardware acceleration. Shadows are cast from the sun 
and every other light source in your model. Since renderings are calculated one pixel at a time light sources cast 
realistic pools of light adding greatly to the rendering quality and ambience. Rendering with transparency are no 
longer only for people with a QuickDraw 3D accelerator card in their computer, the SuperLite renderer will render 
non-opaque objects with transparency. The LightWorks SuperLite renderer also supports anti-aliasing which 
eliminates the pixelated appearance of Lights and Textures renderings, especially noticeable when printing. The 
LightWorks HiddenLine renderer is comparable to hidden line renderings in the standard DesignWorkshop window. 
This line-drawing rendering style is great for use as an underlay for making a hand-rendered perspective.

The LightWorks renderers are not included with DesignWorkshop Lite, but if you have those or any other plug-in 
renderers, they will work with DesignWorkshop Lite. As other plug-in renderers become available you will be able 
simply put them in your extensions folder and they will be fully functional within DesignWorkshop and 
DesignWorkshop Lite.

Advanced Viewing Capabilities

DesignWorkshop 1.7 takes the viewing capabilities you are familiar with in the standard DesignWorkshop window and 
incorporates them into the Lights and Textures window. These capabilities have been enhanced to provide more 
viewing functionality and control than ever before.

The two-dimensional zoom tools are now fully functional in the Lights and Textures window. As in the standard 
DesignWorkshop window, with the Zoom-In tool selected, you can click once in the window and the zoom factor will 
double, or you can drag a rectangle and the view will zoom in to show the contents of the rectangle. The Zoom-out 
tool allows you to cut your two dimensional zoom factor in half with a single click on the tool icon. You can return to 
100% zoom at any time by clicking the zoom percentage number in the tool palette.

The Zoom-in tool also has some exciting new capabilities. If you drag a rectangle while holding down the Shift key the 
rectangle will draw at the proportions of the current window. This way you will know exactly what will and won't be 
visible when you release the mouse button. If you hold down the Option key (the Alt key for Windows) as you drag the 
rectangle you will be able to drag from the center of the rectangle instead of from the corner. That way if you have a 
point you want to focus in on it is easy to have that point centered and frame everything else exactly how you want it. 
If you hold the Command key (the Control key for Windows) down as you drag the rectangle you will be able to move 
the entire rectangle around on the screen. This allows you to adjust your pan and zoom to get it just right. You can 
use the Shift, Option, and Command keys in any combination (Shift, Alt, and Control for Windows) to compose 
precisely the view you want.

Views that are set in the standard DesignWorkshop window will now translate to the Lights and Textures window. You 
can also set views directly in this window. Views set in the Lights and Textures window will not only include the 



location of the eye and look points, but also your two-dimensional zoom and the brightness of the sun and other 
model lights. If you save a Lights and Textures model as a 3DMF with set views the views will also be saved and 
available next time you open the model in DesignWorkshop.

Interactive Walkthrough

DesignWorkshop adds an interactive walkthrough interface in the Lights and Textures side of things. You can easily 
navigate and walk through your model using only the Walk tool. When you have the Walk tool selected and drag or 
arrow up and down both the look and eye points move. The result is your entire view moving forward or backward. 
You can turn to the side using the left and right arrow keys or dragging the mouse to the side. To look up or down hold 
the Option key (the Alt key for Windows) down and drag the mouse vertically or use the up and down arrow keys. 
Using these sorts of movements in combination allow you to easily walk through your model, including paths such as 
walking up stairs.

QuickDraw 3D Accelerator Cards

DesignWorkshop will now automatically recognize and use any QuickDraw 3D hardware accelerator made by any 
company that you have properly installed in your computer. If you have multiple hardware accelerators you can 
specify which one to use in the View > Rendering > Graphics Engine sub-menu. You can also force the rendering to 
be done with software alone.

Most third-party QuickDraw 3D accelerator cards have a monitor port built-in which requires you to hook the monitor 
up to the card to take advantage of the acceleration. These cards will not be used when exporting a PICT image of 
the rendering from DesignWorkshop. This is a limitation of the hardware, not DesignWorkshop.

More Flexible Spotlights

In DesignWorkshop 1.7 the illuminating face a spotlight object is determined in a new way which allows greater 
flexibility and makes it easy to have a spotlight shine in any direction you choose.

The illuminating face of a spotlight object will be the face with the most vertices. If there is more than one face with 
the most number of vertices the lowest of these faces will be the illuminating face. In the case of blocks the lowest 
face will be selected, because every face has the same number of vertices.

To quickly make a spotlight that shines upwards use the circle tool to make a polyline circle. Extrude this circle so you 
have a cylindrical object. Using the trim tool make a trim which goes from the lower end of the cylinder to the side of 
the cylinder. Delete the corner of the cylinder you just trimmed off. Assign the proper spotlight material to the trimmed 
cylinder and you have a spotlight that will shine upwards. You can use the rotate tool to orient the light anyway you 
like and the illuminated face will always be the untrimmed end of the cylinder.

In the 3D libraries we provide a number of theatrical lighting objects which take advantage of this new feature. These 
lights can be aimed in any direction and the correct face will always light up.

Specularity

QuickDraw 3D 1.5.1 changed the way specularity values are interpreted and allowed us more control over 
specularity. In the previous version the only component of specularity that you could specify was the glossiness. Now 
you can specify the smoothness and the reflectivity of a material. Despite this change we have devised a way to keep 
your models with specularity defined the old way looking just as good as before.

For more information refer to the pages on material types in general, and specularity in particular.

New Metric and Japanese Versions



DesignWorkshop is now available in Metric and Japanese versions.

The Metric version sets the default working unit to Meters, as well as making other settings which are set up 
specifically for working with the metric system.

The Japanese version has been completely localized for use in Japan. All menus, dialog boxes, and other text is in 
Japanese if you have a Japanese version of the Mac OS installed on your computer.

Improved DXF Importing and Exporting

DesignWorkshop 1.7 improves importing of DXF files. DXF files will take less memory to import, the results of the 
import will render faster and require less disk space to save.

Exported DXF models will now be compatible with more software packages. Some software, such as Ray Dream 
Designer and Lightscape do not support the DXF Polyline entity and can only read the DXF 3DFace entity. 3DFace 
entities can have no more than four vertices. When DesignWorksop exports a DXF model all faces that have 3 or 4 
vertices will be exported as 3DFace entities. Faces with more than 4 vertices will be exported as Polyline entities.

Improved Radiance Export

Radiance exporting of scenes and views has been improved. The Radiance view is calculated more accurately to 
exactly match the DesignWorkshop view. DesignWorkshop also exports Radiance models so that each object is 
defined by its material assignment. This allows you to very easily use DesignWorkshop tiling textures in your 
Radiance renderings. We include all the textures in the Radiance format on the DesignWorkshop CD-ROM, along 
with documentation for setting Radiance up. For more information see the Radiance folder inside the Accessories 
folder on the DesignWorkshop CD-ROM.

Overview

DesignWorkshop 1.5 adds fast high-end rendering capabilities to the powerful user interface of previous versions. 
DesignWorkshop 1.5 supports texture-mapping and rendering of light sources using QuickDraw 3D technology from 
Apple. DesignWorkshop 1.5 is also much more stable under stress than previous versions, with sophisticated new 
internal error-handling mechanisms.

Two Kinds of Document Window

DesignWorkshop 1.5 is bimodal, with separate document windows provided for DesignWOrkshop standard viewing 
and for the new QuickDraw 3D-based rendering.

To open either a standard DesignWorkshop model file or a 3DMF file, use the File menu Open... command. DW will 
open a DW file into a standard window, and it will automatically open a 3DMF file into a Lights & Textures window.
To view a DW file using QuickDraw 3D, Open it, and then use the View menu Lights & Textures command.
To save a DW file in standard DW format, use the File menu Save or Save As... commands with the standard window 
at the front.
To save any file in 3DMF binary or text format, use the File menu Save or Save As... commands with the Lights & 
Textures window at the front. Use the radio buttons to select the format option.
The Eye and Look tools in the tool palette apply similarly to both types of windows.
Modeling tools and the 3D crosshair apply only to the DesignWorkshop standard window.

Materials, Lights, and Textures

Materials



"DW Materials Prefs" and the "Textures" folder --

Named materials are applied to objects using the Materials pop-up menu in the Object Info floating window. Named 
materials are used for both lights and textures, as outlined below. The "current material" is automatically assigned to 
any new objects created. When DW starts up, the current material is "none", but whenever any material is assigned 
with the Object Info window, DW remembers that as the new current material for any new objects.

Assigning a material to a group has the same effect as assigning that material to all the objects in the group.

There must be a "Textures" folder in the same folder as the DW 1.5 application when it starts up, and in the Textures 
folder there must be a "DW Material Prefs" file. DW will automatically create a new Textures folder and in it a new 
prefs file, using default values, if either is missing.

Lights

- Model lights in DW 1.5 are blocks which have had a light-type named material assigned to them. (This has no 
visible effect in the standard DW window.) The size of the geometric block of a given light has no effect on the 
characteristics of the light source. Point lights are placed at the center of the block and send light in all directions. 
Spot lights are placed at the center of the lowest face of the block, and send light in a direction perpendicular to the 
lowest face. Spot lights therefore typically shine straight down by default, and they can be directed either by rotating 
the whole block around one or more axes, or by just tilting the lowest face of the object by dragging on mid-edge 
handles. Upward shining spots can be made using cleverly-shaped blocks.

- An assortment of white and colored point and spot lights are defined in the default DW Materials Prefs file for 
general use.

- Expert users may also edit their DW Material Prefs to create names and definitions for new lights with any desired 
characteristics. These material parameters are stored within the DW document when it is saved, but if a material is 
defined in both places, the values in the Prefs file take precedence over saved values in the document.

Textures

- Adding Textures -- A new texture can be added to a project just by dropping an appropriate PICT file into the 
Textures folder and restarting DW. By default, the name of the PICT texture file becomes the material name shown in 
Object Info.

- Named materials already assigned to objects using DesignWorkshop PPC 1.2 will carry over into DW 1.5. However, 
the textures we are distributing follow an updated naming style. To use old style material names, duplicate and 
rename some of all of the texture PICTs to match the older names.

- The actual texture PICT for any material can be changed freely as long as the PICT file name matches the materials 
used. You can keep multiple sets of textures in different folders, and only the folder exactly named Textures will be 
accessed. To add a material to a modeling project, just drop a PICT file into the Textures folder and restart DW 1.5.

- Texture PICTs should be uncompressed PICT files smaller than 512K. We currently recommend saving textures as 
16 bit color RGB image PICTs for a good balance between file size and quality.

- Transparency effects are only rendered with an accelerator board like the Apple QuickDraw 3D Accelerator Card. If 
an accelerator is present, DW 1.5 uses it by default, but you can turn it off in the View menu.

- The Apple QuickDraw 3D Accelerator Card supports a maximum of 12 textures at a time. To view more than 12 
textures in a model, use the View menu Shading Style > Use Accelerator command to toggle off the accelerator.

- By editing the DW Material Prefs text file, expert users can set up material names which are different from the 
associated PICT file names, assign different mapping styles for textures, and adjust the opacity and glossiness for 
individual textures. Material parameters are also stored within the DW document, but when a material is defined in 
both places, the values in the Prefs file take precedence over saved values in the document.

The Lights & Textures Window



Direct manipulation of objects is not operational in DW 1.5 in the Lights & Textures rendering window. As an aid to 
scene assembly, when the Arrow tool is selected in the tool palette, the cursor keys can be used to nudge objects in 
the Lights & Textures window, as if "Select All" is in effect, . Together with the Save and Merge File functions, this 
basic object moving capability will allow 3DMF files from to diverse origins to be arranged in , although inefficiently. 
The nudge keys are mapped to move all the objects as follows:

Nudge Direction -- Left Arrow, WEST. Right Arrow, EAST. Up Arrow, NORTH. Down Arrow, SOUTH, Option-up Arrow, 
UPWARD. Option-Down Arrow, DOWNWARD.

Nudge Distance -- with Control, 0.1. Unmodified, 0.5. with Shift, 5.0. with Shift and Control, 50.

Saving Images

The File menu Export 2D >� Object PICT... command and the Export 2D >� Pixel PICT... command both support 
scaling of PICT output so you can create images with much greater than screen resolution, limited only by available 
memory and QuickDraw itself.

New Memory Issues

When using QuickDraw 3D, the Macintosh operating system needs lots for free memory. Giving too much memory to 
the DesignWorkshop application will often actually cause memory problems, because this may use up memory need 
by QuickDraw 3D. Careful reading of low-memory error messages will help you determine whether it is 
DesignWorkshop or QuickDraw 3D that is running out of memory.

Changes to Menu Commands

File Menu

Open... 
Can open DW files and 3DMF files. Now recognizes when it is opening a file format it doesn't understand and 
displays an error message instead of crashing. 

Merge File... 
Allows you to merge an existing 3DMF file into the currently open 3DMF model (only active for the Lights & 
Textures window). 

Save/Save As... 
From the standard DesignWorkshop window, saves your file as a DW file. From the Lights & Textures window, 
saves your model as a 3DMF, and provides the option of saving it as a 3DMF Binary (default) or a 3DMF Text 
file. 

Revert To Saved... 
Reverts the current 3DMF model to the last saved version of the model (only active with previously saved 3DMF 
files). 

Background >   Open 
A background PICT will now scale based on the current 2D zoom when you are in plan, elevation, or axonometric 
views, so you can trace background PICTs and zoom in to them for added detail and then return to 100% zoom 
and everything will always be lined up properly. 

Import >   Object PICT... 
Imports standard object PICTS and the new PowerCADD Scaled PICT format to import objects scaled properly 
from a PICT file, allowing simple translation between PowerCADD 3.0 and DesignWorkshop 1.5 

Export 2D >   Object PICT... 
Allows you to specify the dimensions of the PICT being exported, instead of being based on the size of the 
current window. 



Export 2D >   Pixel PICT... 
Allows you to specify the dimensions of the PICT being exported, instead of being based on the size of the 
current window. (Only active for the Lights & Textures window.) 

Export 2D >   PowerCADD Scaled PICT... 
Allows you to export your model in plan, elevation, or axonometric view in a file format that PowerCADD 3.0 will 
be able to open at the proper scale. 

Export 3D >   Radiance View... 
Exports a fully commented Radiance rif file. Can export multiple views which all use the same geometry and 
material files. 

Export 3D >   Radiance Scene... 
Exports Radiance geometry, material, and rif files.

Edit Menu

Duplicate Circular... 
Now duplicates in a clockwise direction to match the Duplicate Mitered... command. 

Duplicate Mitered... 
Allows you to duplicate mitered with the center of rotation right along an edge of the object.

Layout Menu

Background Grids 
Background grids are now a significantly lighter shade of gray, so they don't seem not so invasive to your model. 

Materials >   Set Current > 
Allows you to set the material for new objects you create. 

Materials >   Purge Materials... 
Allows you to remove unused materials from the current usable list of materials and saves only the used 
materials in the file. 

Materials >   Write Material Prefs 
Rewrites the DW Material Prefs file based on the currently available session materials.

View Menu

Lights And Textures 
Converts current DW model to a 3DMF model and renders it in QuickDraw 3D. 

Update Lights And Textures 
If you are switching between the DesignWorkshop standard and the Lights & Textures version of your model, you 
can make changes to the DesignWorkshop version, switch to the Lights & Textures window and select this menu 
item, and the Lights & Textures window will be updated to reflect the changes you made to the model. 

Lighting >   Sunlight 
Toggles the sun on and off in the Lights & Textures window. 

Lighting >   Brighten Sun 
Makes the sun one step brighter in the Lights & Textures window. 

Lighting >   Dim Sun 
Makes the sun one step dimmer in the Lights & Textures window. 

Lighting >   More Contrast 
Raises the sun contrast level one step in the Lights & Textures window. 

Lighting >   Less Contrast 
Lowers the sun contrast level one step in the Lights & Textures window. 



Lighting >   Brighten Model Lights 
Makes the lights in your model (not the sun) one step brighter in the Lights & Textures window. 

Lighting >   Dim Model Lights 
Makes the lights in your model (not the sun) one step dimmer in the Lights & Textures window. 

Shading Style >   Flat Shading 
Changes QuickDraw 3D shading style from Per Vertex to Flat Shading, for the Lights & Textures window. 

Shading Style >   Per Vertex 
Changes QuickDraw 3D shading style from Flat Shading to Per Vertex, for the Lights & Textures window. 

Shading Style >   Use Accelerator 
Uses Apple's QuickDraw 3D Accelerator card if it is present, for the Lights & Textures window.

Discontinued Features

The DesignWorkshop 1.5 release does not support Publish and Subscribe. These functions are expected to return in 
an improved form in a future release.

DesignWorkshop no longer supports import and export of ClarisCAD files.
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DesignWorkshop, the virtual building toolkitª, brings the simplicity of the classic click-and-drag drawing interface to 
design-oriented architectural modeling. Solid objects are created in immersion perspective views, using a live three-
dimensional crosshair and a minimum of commands. Moving, resizing, reshaping, and extruding 3D objects are all 
accomplished directly with the default 3D crosshair, without any need for icons or menu commands. The clear, simple 
interface leaves the designer free to concentrate on creating form.

With real-time QuickDraw 3D rendering, scaled automatic texture mapping, multiple light sources, and photo-realistic 
rendering, DesignWorkshop is built to turbo-charge your design process, from initial sketches through polished 
presentations.

Modeling

u Fully three-dimensional direct-manipulation Mac-style interface 
u Three-dimensional crosshair interface in live perspective 
u Space-jumpª function for instant and precise crosshair positioning 
u Create and reshape cuboids, cylindrical columns, extruded arches and mouldings, contour site models, etc. 
u Click-and-drag in any view to create and resize openings in solid-object walls, using feature-based solid 
modeling technology 
u Paste-into Openings function for instant and accurate placing of door and window frames 
u 3D object snapping 
u Complete texture mapping and image placement using named materials 
u Complete light sources, and separate controls for sun and artificial lighting 
u Powerful trim function for accurate cutting of objects and groups 
u Wallify function for rapidly converting from massing model to spatial model 
u Fit objects and 3D alignment functions for fast accurate modeling 
u Merge files for efficient handling of large 3DMF format models 
u Object Info box for direct display and editing of object size, position, layer, material, etc. 
u Unlimited user-named layering

Viewing

u Immersion viewing with "eye" and "look" tools for fully dynamic navigation in 3D 
u Two-dimensional and three-dimensional zoom 
u Plan, section, elevation, perspective, and axonometric views, all fully editable 
u Shaded sections without cutting model, automatic poche 
u Fast view-independent object-based shadow casting 
u Saved user-named 3D views 
u Support for multiple documents with multiple windows for each document 
u Hide Objects, Projection Lines, etc. provide fast, professional-level modeling scene control

Rendering



u QuickDraw 3D real-time rendering with multiple lights and textures 
u Available hardware acceleration and transparency 
u Resolution-independent wireframe, hidden-line, flat shaded, and shadow-cast object rendering in 32-bit color 
u Smooth shading and texture rendering with multiple light sources 
u Sun angle set by date, time and latitude 
u Point and spot lights in 32 bit color 
u Named and scaled architectural material types are built in for rapid building of realistic scenes 
u Sun studies rendered in parallel and recorded directly as QuickTime movies 
u Walkthroughs by view list with variable interpolation, saved as QuickTime movies 
u Automatically takes advantage of QuickTime 3D hardware graphics acceleration 
u Easy production of QuickTime VR scenes

Interchange

u Open, merge and save the new Apple QuickDraw 3D "3DMF" metafile format for 3D web publishing and 
seamless integration with most Macintosh 3D applications 
u Full clipboard support -- copy and paste from 3D to 3D, 3D to 2D 
u Import and export object and pixel PICT, PowerCADD, and DXF interchange formats 
u Powerful Radiance scene export with named materials 
u PowerCADD direct translator plug-in module included free

Output

u Print current window at any time with any standard Mac QuickDraw or PostScript printer 
u Save current window at any time as a 32-bit color PICT file with image resolution limited only by available 
memory.

Objects and Data

u Read and edit object dimensions, parameters, materials in Object Info floating window

General

u Built-in designer's markup pencil and eraser - markups print and save with image 
u Straightforward site modeling and contour editing 
u Reliable under stress, with sophisticated exception handling in low-memory and other error conditions. 
u 100% native accelerated code for Power Macintosh

Available

u Now Shipping 
u Direct price $595. (upgrade, mail-order, and academic pricing available.)

For more information on DesignWorkshop, contact:

Artifice, Inc.
P.O. Box 1588 * Eugene, OR 97440 * 800-203-8324
541-345-7438 fax * 541-345-7421 voice
www.artifice.com
Internet - artifice@artifice.com
America On Line - Artifice
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To Install DesignWorkshop 

To install DesignWorkshop from the distribution CD-ROM, copy the folder "DesignWorkshop¨" to your hard disk by 
dragging it over.

To install QuickDraw 3D, open the folder "QuickDraw 3D 1.5.1" on the CD-ROM, and then the folder "QuickDrawª 3D 
Install", and then double-click on the Installer application.

To install the complete 3D libraries, copy the folder "3D Libraries" from the CD-ROM to your hard disk by dragging it 
over. You may install all or part of the libraries as you wish. 

System Requirements 

DesignWorkshop is fully native for the Power Macintosh, and requires a Power Macintosh with QuickDraw 3D 1.5.1 
or higher, and a minimum of 24MB of total RAM. 

Memory Requirements 

If your Macintosh has 32MB or less RAM, virtual memory should be turned on with a total memory setting of 33MB, 
using the Memory control panel. Note that the memory used by QuickDraw 3D (QD3D) is allocated to the System 
from the free memory when requested by DesignWorkshop. In other words, application memory and rendering 
memory are separate in DW 1.5, and giving too large a memory allocation to the application can cause QuickDraw 
3D to run out of memory unneccesarily.

Contents -- DesignWorkshop

DesignWorkshop¨ 

This is the DesignWorkshop software application, in final release form. 

DW Release Notes 

The release notes provide concise general introductory information, and other notes too recent to be included in the 
standard documentation. 

Textures Folder

The "Textures" folder in the "DesignWorkshop¨" folder includes the complete default textures set for DesignWorkshop. 
The CD-ROM distribution includes this, plus some alternate texture sets, plus samplers from texture publishers.



Eight of the texture PICT files in the default Textures folder are samples provided by Artbeats Software, Inc. (2611 S. 
Myrtle Road, Myrtle Creek, OR, 97457, 541-863-4429 voice, 541-863-4547 fax, www.artbeats.com).

Listed with our name followed by the ArtBeats name, these are -- Brick-Norman-Brown (Norman 1/256.PICT), Fence-
Wood-V-Dark (Weathered Wood 3/256.PICT), Floor-Parquet (Parquet b 256/24), Floor-Tile-Marble_Inlaid (D6 Emp 
C/Bot 1 256/24), Paper-Craft (Craft 256/24), Stone_Ven-Marble-Botticino (Botticino 1 a 256/24), Stone_Wall-Ashlar 
(Random Ashlar 2/256.PICT), Stucco-Troweled-White (Troweled/256.PICT).

Addtional texture samplers are provided in the "Textures Samplers" folder courtesy of ArtBeats Software, Inc. TOTO 
Computer Graphics, Inc., and the Morisada Kosho Company, Ltd. of Nagoya, Japan. See ReadMe files in their 
folders for additional information. 

3D Libraries with Materials 

This distribution includes a substantially expanded set of 3D object libraries, with materials assigned, scaled in feet. 
The CD-ROM includes this set, plus additional sets including objects in metric dimensions, and objects without pre-
assigned materials. 

Sample Models 

Maybeck Studio.dw -- A simple texture-mapped building model with interior, exterior, and lighting. The building is 
based on the personal studio of the craftsman-style architect Bernard Maybeck. DesignWorkshop Standard format.

Hatchback for Maybeck.3dmf -- This model of a late-model Volkswagen has been pre-positioned and saved in 
DesignWorkshop so you can merge it perfectly with the Maybeck Studio model using just the File menu Merge 
command. 3DMF format.

RGB Spotlights.dw -- This very simple model of three colored spotlights demonstrates real-time rendering of multiple 
lights with accurate color mixing. DesignWorkshop Standard format. 

Documentation 

Online documentation in HTML format for use with the included HTML Viewer application, or with your favorite web 
browser. 

QuickDraw 3D Software 

The QuickDraw 3D installation will add the QuickDraw 3D system extensions to your Macintosh, and install a Simple 
Viewer application that will view 3DMF format model files from DesignWorkshop or any other QuickDraw 3D-
compatible application. 

QuickDraw 3D Sample Files 

QuickDraw 3D Sample Files -- The QuickDraw 3D Accelerator software installation CD-ROM from Apple, available 
separately, includes additional texture files in PICT format, and 3D objects in 3DMF format.
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   The Tool Palette 

The primary editing, creation, and viewing tools of DesignWorkshop are accessed by clicking the icons of the Tool 
Palette. This floating window is independent of any particular open document, so when multiple windows are open, 
the floating palette always applies to the front or "active" window. The Tool Palette can be moved around the screen 
to any convenient location by dragging on its title bar.

 Selection and Crosshair Tools 

At the top of the tool palette are four tools that affect the working environment. The most important of these is the 
Selection Arrow tool at the top left. With the default Selection Arrow tool, you can perform many fundamental 
operations just by clicking and dragging, including move, resize, reshape, and extrude. This selection tool provides 
you with the 3D crosshair for general manipulation of objects. The other three tools in the top section are Snap-to-
handles, the Snap Grid, and Tool Methods.



 Creation Tools 

The creation tools are next in the palette. These are the Single-line, Rectangle, Arc, Circle, Polyline, Text, Block, and 
Poly-wall tools. You will probably use the Block tool most often. To use any of these tools, select the tool by clicking 
on its icon, then position the 3D crosshair wherever you want to start drawing, and finally drag or click (depending on 
the tool) to create an object.

 Overlay Tools 

Just below the creation tools are the mark-up Pencil and Eraser. These let you do quick 2D paint-style mark-ups on 
top of any 3D view.

 Opening Tools 
Last in the top section of the palette are the Rectangular Opening and Poly-opening tools, which easily make 
openings in blocks and other objects, such as for building windows.

 Color Tools 

Below the opening tools are the Eye Dropper and Color Picker tools, which are used to copy and adjust the color of 
objects.

 Object Editing Tools 

The second chunk of the Tool Palette is organized into left and right columns. On the left are the Rotate, Trim, 
Reshape, and Faces tools, for editing objects.

 Working Orientation Tools 

On the right side of the second section of the Tool Palette are the default Plan Working Orientation, North/South 
Elevation Working Orientation, East/West Elevation Working Orientation, and Arbitrary Working Orientation. These 
icons control the alignment of the 3D crosshair in the modeling space, much like tilting the head on a drafting 
machine.

 Viewing Tools 

At the bottom of the tool palette are the viewing tools. The Eye tool and the Look tool are the main 3D view adjusters. 
Dragging these tools in the model window lets you move your view around the model, using option-drag for moving 
inward and outward. In the middle of the viewing tools is the Zoom Percentage tool, showing the percentage of 2D 
zoom. A click on it restores a normal 100% zoom, useful if you've zoomed way in or out. At the bottom of the viewing 
tools, Zoom-in and Zoom-out are the 2D view adjusters, allowing you to expand or shrink the display of a model 
without altering the three-dimensional characteristics of the view. When a view is zoomed in to something greater 
than 100%, the normal Macintosh scroll bars are active to allow panning.

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index



© 1998 Artifice, Inc. - All Rights Reserved. 





3.1.1 - Selection Tools 

 Artifice, Inc.
DesignWorkshop

Selection Tools

Guide Foyer | Tools Reference | Tool Palette

Selection | Creation | Overlay | Openings | Color | Editing | Orientations | Viewing

 

Selection Tool 

The top left tool in the tool palette is the selection tool.

The Selection tool in DesignWorkshop is very powerful, and it encompasses many different functions. By clicking and 
dragging with the 3D crosshair to select and manipulate objects, the Select tool allows you to choose, move, resize, 
and reshape both 2D and 3D parts of your model. 

Selecting Objects 

DesignWorkshop uses a standard Macintosh-type "noun-verb" interface, in which objects are selected to be 
manipulated. Select blocks by simply clicking on them, or by dragging a 2D selection rectangle. Selection is indicated 
by object handles appearing for simple objects, or bounding box handles appearing for complex objects and groups. 
All the objects and groups selected at a given time constitute the current "selection set."

If blocks are overlapping in the current view, a click will select the front-most block. To select one of the blocks farther 
back, click again in the same place, and the next block back (away from the eye position) will become selected. If 
necessary, keep clicking until the desired block is selected. If many objects overlap your target, try reducing the 
overlap by working from a different viewing angle or by using the Hide Object command to hide some of the intruding 
objects.

When selecting by dragging a rectangle, any object with a bounding box overlapping the selection rectangle will be 
included in the resulting selection set. This is slightly different from most 2D Macintosh drawing programs, in which 
only objects completely inside a selection rectangle are selected.

Shift-clicking on unselected objects will add them to the selection set, and shift-clicking on a selected object will 
remove it from the selection set. In other works, in standard Macintosh fashion, shift-clicking "toggles" the selection 
state of an object. 

Working on a selected object 

Many of the fundamental editing operations are performed in the selection arrow tool, using the 3D crosshair to 
manipulate objects. Exactly what happens when you drag with the crosshair is controlled by what part of an object 
you grab onto:

To move a block: Drag a block to move it in three dimensions, clicking not on a handle.



To resize a block: Drag a corner handle of the block.

To move one edge of a block: Drag a mid-edge handle to move an edge of a block to any perpendicular position.

To tweak a block: Command-drag on a corner handle to move a single vertex of a block in three dimensions, 
independent of the rest of the block. This may result in non-planar faces that shade erratically. (Note: The Command 
key (the Control key for Windows) must be down before depressing the mouse button.)

To extrude a polyline: Drag up or down on a corner handle, holding down the Option key (the Alt key for Windows) 
while moving the mouse forward, to extrude a polyline. 

Snap to Handle Tool 

The top-right tool in the tool palette is the Snap to Handle Tool.

Change object snaps to corner and turn mid-edge handles on and off. When this tool is on, clicks near a block corner 
in 3D space are adjusted automatically to be exactly at the corner location. This helps in building clean, precisely 
aligned models. Double-click to open the snap-to-handle settings dialog box to adjust the radius for jumping to 
corners (also accessed through the Layout menu Preferences section).

When this tool is on, space-jumping (by tapping the space bar) jumps the crosshair location to any block corner, not 
just to a selected handle, although it will still jump to a selected handle in preference to a non-selected one.

To move an object precisely using handle snapping, you need to turn on handle snapping, then grab the object near 
to, but not quite on, a corner handle. You should then see the crosshair snap over slightly to the exact object corner. If 
you grab the object exactly by the corner in the first place, your action will be interpreted as dragging the corner 
handle for resizing, rather than the whole object for moving. Since the handle snapping distance is measured three-
dimensionally, it works well to space-jump to the handle, then move the crosshair away slightly, then grab the object.

To end the move operation precisely with a snap to another object, the crosshair must again be close to the target 
object corner, measured three-dimensionally. While still dragging the object, align the crosshair carefully to the target 
corner, using the crosshair foot and projection lines, and then just release the mouse button. Grid Tool 

The tool in the first column and second row is the Grid Tool.

Turn snap-grid on and off. Each click on the tool will switch its state. The snap grid is used to make all crosshair-
based operations end up at round-number measurements. The snap grid is on by default, with a snap spacing of 0.5 
ft. Double-click the Grid tool to open the grid settings dialog box (also accessed through the Layout menu 
Preferences > section). The snap grid setting also controls the distance objects are moved when nudged with the 
keyboard arrow keys. 

Methods Tool 

The tool in the second column and second row is the Methods Tool.

This tool icon is always inactive in DesignWorkshop. It will be used for additional tool options that are being 
implemented for the next major version of DesignWorkshop.
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These are the tools that create new graphic objects in the 3D modeling space. Each of these tools is activated by 
clicking once on the tool icon. Most of these tools are "momentary", which means they turn off at the end of each use. 
The Block tool and the Poly-wall tool are "sticky", meaning they stay active until another tool is selected. The Block 
and Poly-wall tools are unique because they are self-extruding, fully-3D tools, whereas the other creation tools are 
combination 2D/3D tools which require a separate drag operation to extrude their objects into solid forms. When the 
tool turns off, the crosshair is automatically ready to extrude the 2D object if appropriate, or to move to whatever else 
is next. 

Single Line Tool 

Drag with the 3D crosshair to draw a single line. A line can be drawn on any plane, by using the option key. After each 
line drawing operation, you will be returned to the Selection tool (that is, the Selection tool only will be active). Lines 
can be extruded by dragging on an object handle with the Selection tool, to become 3D surfaces. 

Rectangle Tool 

Draw a 2D rectangle by dragging from a first corner to the diagonally opposite corner. This creates a "flat" unfilled 
object, which can be turned into a solid by extruding it (done by option-dragging perpendicular to the plane of the 
rectangle with the Selection tool). 

Arc Tool 

Draw a circular arc by dragging from the center of the arc radially outward to the corner of a square containing the 
arc. This creates a 2D unfilled object, which can be useful as-is, or turned into a solid if desired by extruding it (by 
option-dragging perpendicular to the plane of the rectangle). 

Circle Tool 

Draw a 2D circle by dragging from the center of the circle radially outward to the corner of a square containing the 
circle. This creates a 2D unfilled object, which can be useful as-is, or turned into a solid if desired by extruding it (by 
option-dragging perpendicular to the plane of the rectangle). The smoothness of circles (and arcs) is controlled with 
the Layout menu Preferences > Circle Faceting command.

To draw an ellipse, first make a circle, then drag on a corner handle to stretch it to the new shape. 

Polyline Tool 



Draw multi-segment lines, known as polylines. Click the mouse to start a polyline, then move the 3D crosshair to the 
desired location of the next vertex, and click to place a vertex, creating the first line segment. Click again to place 
each additional vertex, each time completing another segment. To finish the polyline, either click once on the starting 
vertex to end and close the polyline, or double-click for a last vertex to end the polyline leaving it "open", with its ends 
not connected. While in the midst of drawing a polyline, typing command-z will undo just the last vertex. After you've 
ended the polyline, command-z will undo the whole polyline.

Polylines can be drawn in any working orientation, and then pulled out to form extruded objects by option-dragging on 
a bounding-box handle perpendicular to the plane of the polyline. It is possible to create non-planar polylines, by 
dragging with the Option key (the Alt key for Windows) to move the working plane while drawing the segments, but 
non-planar polylines may behave strangely.

When selected, poly-lines and extrusions created from poly-lines show selection handles at the corners of a 
"bounding box". With Reshape mode (see Special Editing Tools, below) extruded objects may be re-sculpted in three 
dimensions. 

Text Tool 

In DesignWorkshop, the Text tool allows you to place text in the mark-up overlay. Click on the drawing where you 
want the text to register. A dialog box will open. Type or paste text into the box, then click OK to place the text on the 
drawing. If the text does not appear how or where you want it, Undo, change style settings if necessary, and then 
click on the drawing to place the text again.

This text will print with the rest of a rendering. An annotated drawing can be saved as an image file using the File 
menu Export > PICT function. This is useful for quick design notes, or to put captions on images you are printing 
directly from DesignWorkshop. 

Block Tool 

Create cuboid blocks. The Block tool and the Poly-wall tool create solids directly through a 3D drag operation. Drag a 
rectangle in the main crosshair plane, then without releasing the mouse button, option-drag out the third dimension of 
the block. Plain blocks can form many basic architectural elements, such as building masses, walls, and floor and 
roof slabs. Blocks can be resized by dragging on their corner handles with the 3D crosshair. Blocks can easily be 
reshaped by dragging on their mid-edge handles, without using the special Reshape mode, to provide a variety of 
forms (gable, hip, or shed roofs, for instance). 

Poly-Wall Tool 

Create a mitered string of blocks. Draw a starting block just as you would using the Block tool, then, after completing 
the first block, position the 3D crosshair at a location for the far top corner of the second block, and click there to 
create that block. Continue to click once to place each additional block in the string, and then double-click to end the 
string of linked blocks. You can change the height or slope from segment to segment by shifting the height of the 
crosshair (by option-dragging) before clicking.

Poly-walls are useful for quickly building walls on a plan drawing, in site development, and in elevation working 
orientations. They are also used in drawing the sectional profile of forms such as vaults and domes.
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Overlay Pencil Tool 

For quick, rough 2D sketching on top of the model view. The Overlay pencil works like a simple 2D painting pencil just 
select the tool and drag to draw. The pencil tool gives you freehand lines by default. To draw straight lines, hold down 
the Shift key, then drag with the pencil tool.

Overlays will print normally with the current window and save with the current view with Export > PICT. Overlays can 
be saved for review by "grabbing" with a screen capture utility. To clear the overlay, double-click the Overlay eraser 
icon.

Using the Overlay pencil can be thought of much like laying down a piece of drafting trace over a pencil drawing to 
quickly sketch over it. In DesignWorkshop, use the overlay pencil for quick mark-ups of a view of the model, for 
recording rough design ideas before taking them into 3D, to explain and emphasize points of a model in client 
conversations, and for "desk crits" in design teaching situations. 

Overlay Eraser Tool 

For erasing in 2D overlay sketches. The Overlay eraser works like a common paint eraser--drag the eraser around on 
the model view to erase lines made with the overlay pencil or text tool.

To quickly erase the whole overlay, double-click on the Overlay eraser icon.
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Rectangular Opening Tool 

For cutting four-sided rectangular openings in solid objects. To cut an opening, first select a 3D object. (The Opening 
tool is only available when a solid object is selected.) Move the cursor over the object you want to cut an opening 
into, and notice that a 2D crosshair appears in perspective on the face of the solid object. With this crosshair, drag out 
the opening, just as you would draw a rectangle on one of the object faces. (In a shaded view, with a fast Mac, you 
can see through an opening as you create it, although you will probably mostly model in wireframe views for 
responsiveness.)

Openings can be selected after creation by clicking in them, and then moved or resized with the crosshair, or single-
duplicated from the Edit menu with the Duplicate command. To move an opening, select it and drag on the opening 
anywhere except on its corner handles. To change the size or proportions of an opening, select it and drag on any of 
its corner handles. A selected opening can also be moved around in its parent object by nudging with the arrow keys.

While using the Opening tool, the Location Bar absolute coordinates read from the object reference point, so you can 
position the opening precisely within the object. A selected opening can be set to a particular size and/or position in 
an object with the Object Info box.

Rectangular openings can be reshaped after creation just like poly-openings. 

Poly-Opening Tool 

For cutting openings with any shape or number of sides in solid objects. Cutting a poly-opening works like drawing a 
polyline on one of the object faces -- click to place each vertex, and complete the operation either by double-clicking 
or by clicking on the starting vertex. In a shaded view, you won't see through a poly-opening until it is finished, unlike 
when making a rectangular opening..

Poly-openings can be moved, resized, and duplicated in the same way as rectangular openings. Resizing poly-
openings differs slightly from resizing rectangular openings, in that the corner handles appear at the bounding box of 
the poly-opening, instead of at the corners of the rectangular opening.

In addition, poly-openings and rectangular openings can be reshaped, in the same way as solid extrusions are 
reshaped. In reshape mode, (see the next section of Tools Reference) the shape of the opening can be adjusted 
point by point. To perform a reshape on an opening, either select the opening in Select mode and then click on the 
Reshape tool icon, or just select the opening in Reshape mode., Then drag on the vertex handles of the opening.



The Poly-opening tool is useful for cutting arched openings and circular or diamond-shaped openings in walls, or for 
cutting irregular, circular, or other openings in floor and roof slabs. To make poly-openings with accurate curves, it can 
be helpful to first create guidelines with the circle or arc tools. Handle snapping makes it easy to precisely follow 
construction lines, like a circle or arc previously drawn on the face of an object. See Arches, in the DesignWorkshop 
Techniques chapter, for more detail.
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Eye-Dropper Tool 

For picking up ("grabbing") the color of an existing object. Click on any object with the eye-dropper cursor -- the 
object need not be selected. The color tool icon will automatically change to match the base color of the clicked 
object. 

Note: The color picked up by the eye dropper, and the color shown in the Color tool icon, is the base color for an 
object. The full brightness of an object's base color is only shown when its surfaces are at maximum illumination. 
When the object is rendered with shading or shadow-casting, the resulting color will usually be somewhat darker 
depending on the angle to the sun. Because of this, in most cases a relatively bright base color gives the best results. 

Color-Picker Tool 

For setting the color of a selected object, and resetting the current color for newly drawn objects. To set the color of 
all selected objects to the color shown, click once on the color-picker icon.

To set a new drawing color (and also reset the color of any selected objects), double-click on the Color-picker icon. 
This brings up the standard Macintosh color picker. When you click OK in the color picker dialog box, the new color 
you've chosen will go into effect. Click Cancel instead to close the color picker dialog box without changing the 
drawing color.
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Rotate Tool 

Rotate objects by dragging. Rotation works in two ways -- about a center or about an edge -- depending on how an 
object is grabbed.

To rotate an object about its center, select it and drag on the object but not on any of its handles. When rotating an 
object by this method, the 3D position of the crosshair is ignoredjust the side-to-side motion of the 2D cursor across 
the screen is used to control the degrees of rotation.

To rotate an object around an edge, select it, and grab it by an object handle with the 3D crosshair. Drag with the 3D 
crosshair to rotate the object about the edge opposite the handle you've grabbed. When rotating by handle-dragging, 
the degree of rotation is controlled by the three-dimensional position of the crosshair.

Shift-constraint works while rotating an object to round off all rotations to a preset round number, which is called the 
rotation constraint value. That is, with the Shift key held down while dragging, the object will rotate only to multiples of 
the current rotation constraint value. The default constraint value of 15 degrees can be changed in the Preferences 
section of the Layout menu.

The axis of rotation for either rotation method is controlled by the crosshair working orientation (described in the next 
section of this chapter), so rotation always occurs in the primary working plane. To change the axis of rotation, select 
an alternate working plane orientation. 

Trim Tool 

Cut through an object or group of objects. The cut is defined by a cutting line across one face of the object, which is 
then extended through the object perpendicular to the starting face.

Select an object, and then the Trim tool. When the trim cursor is over the object, a 2D crosshair will appear on a face 
of the object. If you move the cursor over a different face of any selected object, the 2D face-crosshair will follow to 
that face. Position this crosshair at some point along the slice you want to cut, then press the mouse button and drag 
to another point along the slice. When you release the mouse button, the cut will be made, along the line you defined, 
and perpendicular to the surface you are cutting from. The trim is always cut through the object perpendicular to the 
face you're cutting from.

To cut through several objects at once, group them, and then trim the group as if it were one complex object. The 
faces crosshair for trimming works on the group bounding box. 



Reshape Tool 

Reshape an extruded object by dragging on mid-edge handles, or reshape an opening by dragging on vertex 
handles. Click the Reshape tool, and then select the object to reshape. (The Reshape mode allows selecting.) The 
bounding box of the extrusion will be hidden, and mid-edge handles will appear for every edge in the object. Drag 
these mid-edge handles with the 3D crosshair to sculpt the profile of the object. Openings are reshaped with the 
faces crosshair, so mid-edge handles will not appear.

Reshape only functions when exactly one object is selected. (For this purpose, an opening counts as an object.) If 
more than one object is selected, the Reshape tool becomes unavailable. This is indicated by the disappearance of 
the mid-edge handles on extrusions and by greying of the Reshape icon.

Clicking and dragging to select objects is functional while in Reshape mode, so one object after another can be 
reshaped without having to go to the tool palette over and over again. 

Faces Mode Tool 

Select and manipulate individual faces for reshaping blocks, aligning the arbitrary working orientation, and in future 
versions for placing images onto faces. Exactly one object face can be selected at any time, although many entire 
objects can be selected at the same time as the one face.

One application of moving a face is adjusting the incline of a roof slab. The slope of a roof slab can be readily 
adjusted by selecting its side faces, and then option-dragging that face upward or downward, to incline the block 
without changing its size or position in plan.

When a face is selected, special constraints are applied to dragging the object edge handles and corner handles on 
the face. All movements of edges or vertices are constrained to the plane of the face. This can be very useful for 
certain constructions.

See the Working Orientation Tools section for how a selected face can assist in setting the 3D crosshair working 
orientation to a particular direction.
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Working Orientations Tools 

Underlying most tools in the DesignWorkshop interface is the 3D crosshair, moved around in space by moving the 
mouse. Moving the mouse around on the table top moves the crosshair around in a plane (the "mouse plane"). That 
plane is moved up and down in space by holding down the Option key (the Alt key for Windows) while dragging 
("option-dragging"). Since you can press or release the Option key (the Alt key for Windows) at any moment while 
dragging, the interaction of regular dragging and option-dragging allows free control of the 3D crosshair in space.

By default, most of the time DesignWorkshop is in one working orientation, with the mouse-to-3D relationship just 
described. However, the alignment of the crosshair to the model world can be adjusted, much as the protractor head 
of a mechanical drafting machine can be rotated to various alignments. There are many more possible alignments in 
3D space than on an inherently 2D drafting machine. In DesignWorkshop these possible alignments have been 
collected into four working orientation modes: plan, south elevation, east elevation, and arbitrary. The first three 
orientations are all "orthogonal", or aligned normally to north/south, east/west, and up/down, the major axes of the 
world coordinate system. The fourth, the arbitrary working orientation can be moved and rotated to any position and 
alignment in space. The distinction between these working orientations is which of the major planes in space is 
parallel to the mouse plane, or, to put it in alternate terms, which of the three main directions in space is the option-
drag, Z-axis direction.

We call the angular relationship of the crosshair (and mouse) coordinate system to the world coordinate system the 
"working orientation", so that in the standard mode, when plain dragging moves the crosshair around horizontally, you 
are in the "plan working orientation". In the plan working orientation, option-dragging moves the crosshair vertically.

In the two elevation working orientations, plain dragging moves the mouse around in a vertical, or elevation, plane in 
the modeling world. Option-dragging in an elevation working orientation moves the drawing plane horizontally, east-
west or north-south, depending on which elevation orientation is used.

These three orientation icons allow instant switching between common orientations. They allow you to switch quickly 
between drawing in plan and drawing in one or another elevation, while continuing to view your model in realistic 
perspective.

There is also an interaction between certain views and the three normal working orientations. When you work in one 
of the five built-in orthographic views (plan view plus the four elevation views) the working orientation is set 
automatically to match.

The fourth working orientation mode, called the "arbitrary working orientation", goes beyond switching between 



horizontal and vertical and allows you to rotate the working axes to align to any plane or direction in space, and to 
translate the origin of the crosshair coordinate system to a different height or depth in space.

For speed and easy accuracy, the arbitrary working orientation can be set with a double-click to match an existing 
object or object face. There is also an "arbitrary working orientation adjuster" that can be moved or rotated manually, 
for maximum versatility. (See the description of the Working Orientation menu item for details.)

Finally, either of the elevation orientations can be activated on top of the arbitrary working orientation, to put the 3D 
crosshair in a perpendicular plane based not on the normal world, but on the current base arbitrary orientation.

To give you extra visual feedback about the current orientation, on a color display the two crosshair axes in the 
mouse plane are shown in light blue, and the third axis, for the option-drag direction, is shown in light red. 

Plan Working Orientation 

For drawing in horizontal planes, with the height controlled by option-dragging. This is the normal, default mode, used 
more than any other, and it is also the easiest to learn and use.

Projection lines are drawn on the ground plane, at zero elevation. 

South Elevation Working Orientation 

For drawing in north/south facing planes, with the north/south depth controlled by option-dragging.

Projection lines are drawn on the east/west vertical reference plane, as well as onto the ground plane. 

East Elevation Working Orientation 

For drawing in east/west facing planes, with the east/west depth controlled by option-dragging.

Projection lines are drawn on the north/south vertical reference plane, as well as onto the ground plane. 

Arbitrary Working Orientation 

For drawing in any orientation plane or direction. Double-click this icon with no objects selected, then drag on the bold 
adjuster crosshair in space to align the working orientation at any angle and location. Drag on the center of the 
adjuster to move the center of the coordinate system, and drag on the tip handles to rotate the axes in any direction. 
(Double-clicking this icon with no objects selected is equivalent to the Layout menu Working Orientations > Adjust 
Orientations command).

The default arbitrary working orientation is rotated 45 degrees from the normal compass directions. This default 
orientation can be restored with the Layout menu Working Orientations > Set to Default command.

Double-click the arbitrary working orientation icon with an object selected to set the working orientation to match that 
object. (Double-clicking this icon with one object selected is equivalent to the Layout menu Working Orientations > 
Set to Object command).

Double-click the arbitrary working orientation icon with a face selected to set the working orientation to match a face, 
with the mouse plane parallel to the face and the option-dragging direction perpendicular to the face. (Double-clicking 
this icon with an object face selected is equivalent to the Layout menu Working Orientations > Set to Face 
command).
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Eye Tool 

Move viewer's position in world around the center of interest. Dragging with the Eye tool is the equivalent of looking at 
one spot while moving horizontally and/or vertically around the spot, from some distance away. Option-drag the 
mouse to move closer into or farther out from the center of interest. This is the equivalent of walking closer to and 
farther away from the spot you're looking at.

When in perspective view, double-clicking the Eye tool icon moves the eye point in or out from the center of interest 
of the scene, without changing the viewing direction, far enough so that all the visible objects in the model can be 
seen in the viewing window. We call this an "eye-all" to distinguish it from a "zoom-all". Eye-all changes the eye 
location in 3D to make all objects visible within the standard angle of view. In perspective views, the 2D zoom-all 
effectively widens the angle of view, showing all objects without moving the eye position.

With the Command key (the Control key for Windows) held down, the Eye tool gives you a 3D crosshair, so you can 
place the eye point at an exact location in the model space. While holding down the Command key, move the mouse, 
using the Option key (the Alt key for Windows) in addition as necessary, until the 3D crosshair is in the desired new 
location for the eye point. Then, still holding down the Command key, click to place the eye point there.

(Note: When placing both the eye point and the look point with the 3D crosshair, it generally turns out to be less 
confusing to place the new look point first, and then the new eye point.)

The Eye and Look tools also activate eye-point and look-point nudging with the arrow keys. Typing the arrow keys 
while the Eye tool is active moves the eye position. The sensitivity of this "eye nudging" is controlled by a Preferences 
setting. When in the Eye tool, option-up-arrow and option-down-arrow move the eye closer in toward or farther out 
from the center of interest. Eye-nudging is useful for fine-tuning views and for setting up evenly spaced saved views 
for walkthrough animation.

While the Eye tool is active, the first three fields of the location bar display the world coordinates of the current eye 
location. The eye location can also be set numerically by typing values into the Location Bar (in absolute 
coordinates). For instance, while in the eye tool, you can type "z" to enter the location bar, then type "5" to set the eye 
height to 5', and then type return for this to take effect.

If you repeat this for the look tool, you will quickly set up a precise two point perspective. Two point perspective is 
useful for minimizing distortion and "jaggies" due to perspective effects in a vertical direction.

The View menu Set View command saves the current eye point under a user-defined name, and adds that name to 



the bottom of the View menu for easy access. 

Look Tool 

Drag to move the center of interest ("look point") around the viewer's position. This is the equivalent of standing still in 
one place, and turning your head around to look in different directions.

The Look point itself is also the center of rotation when moving around with the Eye tool. To set the look point to the 
center of the model, double-click on the Look tool icon. If you happen to get "lost in space", you can use the View 
menu Initial View command to get back to a default view of the model space.

When the Command key (the Control key for Windows) is held down, the Look tool gives you a 3D crosshair to place 
the look point at an exact location in the model space. To do this, select the Look tool, and, while holding down the 
Command key, move the mouse, also using the Option key (the Alt key for Windows) as necessary, until the 3D 
crosshair is in the desired new location for the look point. Then, still holding down the Command key, click to place 
the look point there. (Note: When placing both the eye point and the look point with the 3D crosshair, it is generally 
less confusing to place the new look point first, and then the new eye point.)

The Look tool also activates look-point nudging with the arrow keys. When the Look tool is selected, option-up-arrow 
and option-down-arrow move the center of interest closer in toward or farther out from the eye location.

Eye and Look tool nudging is especially helpful for getting views at regular intervals to save for defining a walkthrough 
sequence. 

Walk Tool 

When in Lights and Textures rendering, the Look Tool changes to the Walk Tool. This tool allows for easy, real-time, 
interactive walkthroughs of your model.

The Walk Tool can be used with either the mouse or arrow keys. To walk forward with the mouse, simply click and 
hold the mouse button, and drag the mouse up. To walk backward, click and drag the mouse down. To look left or 
right, click and drag the mouse in the desired direction. To look up or down, hold the Option key (the Alt key for 
Windows) as you click and drag the mouse up or down.

A similar process is used for the arrow keys. To walk forward push the up arrow. To walk back, puch the down arrow. 
To turn to the left or right, push the left or right arrow. To look up or down, hold the Option key (the Alt key for 
Windows) and push the up or down arrow key. 

2D Viewing Tools 

The 2D viewing tools enlarge or shrink the model view in the current window without changing the 3D view 
characteristics. For orthographic (plan, elevations) and axonometric views, the 2D viewing tools work just like the 
zoom tools in most Macintosh drafting software. For perspective views, the 2D viewing tools have the effect of 
changing the effective angle-of-view, by fitting a wider or narrower swath of the current scene into the document 
window. You can always get right back to a standard zoom, and a standard angle-of-view, by clicking once on the 
Zoom Percentage icon. 

Zoom Percentage 

Shows the current 2D zoom factor. For perspective views, 100% corresponds to a normal view with a moderate 
angle-of-view.

Clicking on the Zoom Percentage field zooms the view in or out to 100%. Double-clicking in the field selects the 
current zoom value, and then typing a new percentage value, followed by Return, sets a specific zoom percentage. 

Zoom-Out Tool 

Zooms out in the current view (without changing the three-dimensional view projection), showing more of the model in 
the same window. Click once to zoom out by a factor of two (e.g., from 100% to 50%).

Double-click on the zoom out tool to "zoom all" (zoom in or out so that the objects in the scene just fill the window).



Zooming out from a perspective has the effect of increasing the angle of view, similar to a "wide-angle-lens" effect. 
Double-clicking Zoom-out in a perspective view will cause the angle of view to be adjusted two-dimensionally so the 
whole visible model fills the viewing window. Zooming out when close in to or even inside a model, will quickly create 
a very wide-angle, and therefore very distorted, view. A single click on the Zoom Percentage icon will restore the view 
to a normal angle of view. (See also Eye tool, for the related 3D view transformation.) 

Zoom-In Tool 

Zooms in to the current view (without changing the 3D view projection), showing a smaller portion of the scene at a 
larger scale, in the same window. Click in the window to zoom in around that point by a factor of two. Drag a 
rectangle in the model window to zoom in two-dimensionally on a specific portion of the scene. You can zoom in 
repeatedly. 

Note: When zoomed in, two-dimensional panning is provided by normal Macintosh-style scroll bars on the document 
window. See the DesignWorkshop Window section for details. Panning is not available when the zoom percentage is 
100% or less.
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Document Windows 

The Document Windows display the model or drawing being viewed and edited. In DesignWorkshop, there are two 
different types of document window with somewhat different capabilities. DesignWorkshop allows you to have more 
than one document open at a time, and each document can be viewed through more than one window at a time. 

Standard Document Window 

The Standard Document Window is used for all editing of the model, saving particular 3D views, and object-based 
rendering and viewing from wireframe though shadow-casting. 

Lights & Textures Document Window 

The Lights & Textures Document Window is used for rendering and viewing the model with local light sources and 
automatic texture-mapping, using fast pixel-based rendering, based on QuickDraw 3D.

Floating Windows 

These small windows, also called "windoids" or "floaters", always stay in front of the document windows. Floating 
Windows provide for the display and editing of particular information in an easily accessible format. 

Phases Windoid

Object Info Windoid

Views Windoid

Walkthrough Windoid 
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The DesignWorkshop environment displays a 3D model world through standard Macintosh document windows. You 
can open more than one window onto a given document, and each window can have its own view and rendering 
style. You can also have more than one document open at one time. Each window has a title bar to help keep track of 
which is which.

The window title bar displays the document name, followed by the name of the current phase, followed by the window 
number when more than one window is open for a given file. Multiple windows may be opened of the same 
document, or of more than one document at a time if enough application memory is available.

The DesignWorkshop document window provides 2D panning through the standard Macintosh scroll bars, plus 
numerical control of coordinate entry through the extra "location bar" displayed just above the horizontal scroll bar. 

Location Bar 
The Location Bar displays the current location of the 3D crosshair. The X, Y, and Z fields show the location in 
absolute coordinates (the distance along the coordinate axes from zero x/y/z in the overall modeling space).

The E, S, and V fields show the crosshair location in relative coordinates, measured from the crosshair location at the 
last reset in the direction of East, South, and Vertical.

The relative coordinates are reset to zero at the beginning and end of most crosshair dragging operations, so that for 
instance while you're creating a block, the E/S/V coordinates control the size of the block. 

Numerical Entry to Location Bar 
You can type E/S/V (relative position) or X/Y/Z (absolute position) coordinates into location bar fields, to position the 
crosshair during mouse operations, or between them. To start entering numbers to the location bar, type the letter for 
a coordinate you want to specify (X, Y, Z; E, S, or V) or alternatively, hit the Tab key to start at East. Then type the 
numerical value. The value will take effect when you type either Tab (which locks the value you just entered and 
advances the insertion point to the next coordinate field) or Return (which puts any values you have entered into 
effect and forces an exit from the text boxes).

If you are typing coordinates during an operation such as creating a block, you must hold down the mouse button 
while typing. When you release the mouse button, it ends the creation operation at the current crosshair location. 
Typing Return has the same effect as typing Tab and then releasing the mouse button. While drawing polyline 
objects, for which you normally click for each point, typing Return places a new point in the polyline, without ending 
the polyline.

Entering coordinates numerically rather than graphically is useful for creating objects to specific known dimensions. 



You can combine numerical and graphical methods to define coordinates. For example, you can enter only one or two 
coordinates numerically, type Tab after each to lock the value, and then finish an operation specifying the other 
dimensions graphically. This lets you combine predetermined dimensions with visual judgments to match the knowns 
and unknowns in the unfolding of the design process.

You can also use the Object Info box to set already-created objects to a particular size or location. 

Scroll Bars 
When zoomed into a view two-dimensionally, scroll bars are active for panning (moving the viewing frame from side 
to side or up and down two- dimensionally around the overall image) the view in normal Macintosh fashion by clicking 
on the end arrows (for small jumps) or by clicking between the handle and an end (to jump a screen at a time) or by 
dragging the scroll handle (for arbitrary big jumps). Also, the view will pan automatically to track the crosshair.
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DesignWorkshop has two different windows for viewing models, the standard window and the Lights and Textures 
window. The standard window is where you create and edit models. It is also the window for most renderings. The 
Lights and Textures window is for rendering with QuickDraw 3D. The Lights and Textures window will render materials 
assigned to objects and will calculate light sources in the model.

To open the Lights and Textures window from a standard DesignWorkshop model select the Lights and Textures item 
from the View menu. This will convert your model into a 3DMF model and render it using QuickDraw 3D.

You can switch between the standard window and the Lights and Textures window at will. You can make changes to 
the model in the standard window and then select Update Lights and Textures from the View menu to see the 
changes in the model rendered using QuickDraw 3D.

Another way to open the Lights and Textures window is by opening a 3DMF file saved by DesignWorkshop or any 
other QuickDraw 3D capable application.

You can save the model displayed in the Lights and Textures window as a 3DMF in either binary or text format, binary 
is smaller and will usually be the preferred format.

Though you can not create objects in the Lights and Textures window you can move the model as a whole. You need 
to have the Selection (arrow) Tool active and then the arrow keys will change the position of the model. With the 
control key held down the nudge distance is 0.1 working units. With no modifier key held down the distance is 0.5 
working units. With the Shift key held down the distance is 5.0 working units. With the shift and control keys held 
down the distance is 50 working units.

You can adjust the lighting in the Lights and Textures window by turning the sun on and off, changing the brightness 
of the sun, changing the brightness of lights within the model and changing the contrast. This is all done in the views 
menu.

You can merge an existing 3DMF file with the currently open Lights and Textures model by selecting Merge File from 
the File menu. You may need to reposition one of the models before merging them so they line up properly. Do this 
using the arrow keys as previously described.

The Eye and Look Tools are fully active in the Lights and Textures window allowing you to navigate throughout the 
model. The movement of the eye and look point follows the DesignWorkshop standard rather than the movement you 
may have experienced in other QuickDraw 3D applications. Other applications seem to be you remaining in place 
and moving the model around and twisting it about your fixed point. In DesignWorkshop the model is fixed in place 
and you move through the space and change the direction you are looking. The DesignWorkshop approach mirrors 
reality for architectural purposes.
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"Phases" is the term used in DesignWorkshop for 3D "layers". Associated elements are placed in different phases for 
clarity and ease of work.

The Phases windoid controls the current phase and which phases are currently editable or visible. Open the Phases 
windoid by using the Layout menu Show Phases... command. When the Phases window is showing, click on its 
various controls to adjust the phases setting for your document. These changes will not go into effect until you click 
on the Apply button. It is important to be careful about this little attention to the Apply button can prevent a lot of 
confusion.

Only one phase can be "current". The current phase is the phase into which newly drawn objects are placed, and 
Paste operations also always put their results into the current phase. Selecting objects and many other operations 
are not limited to the current phase, however. Objects in any editable phase may be selected, copied, cut, deleted, 
moved, reshaped, etc., and objects normally stay in their home phase unless you move them via the clipboard with 
cut and paste. (One exception is the Group command--see below.)

Phases can be locked (shown in the phases "site", "massing", and "substructure" in the illustration above), so objects 
are displayed but not selectable or editable, and phases can be made invisible (shown in the phases "basic site" and 
"trees" in the illustration). Objects in invisible phases are not editable.

To move objects from one phase to another, make the destination phase current, then select and cut the objects from 



their original phase, and paste them into the current phase. Individual objects can also be quickly shifted from one 
phase to another using the Phase pop-up menu in the Object Info windoid.

When objects are grouped, they must all be together in one phase. For this reason, if you attempt to group objects 
that are spread across more than one phase, a warning will appear. To complete the operation, you will have a choice 
of canceling the grouping operation or having all the objects be moved to the current phase.

To change the name of a phase, double-click on the name, and then click in the name field to edit the text. Type 
return when the edit is complete, and always click Apply when you're done changing Phases. Changes are 
automatically saved whenever the model file is saved. A generic new DesignWorkshop models comes with a default 
set of already-named phases. If you would like your new documents to open with a customized set of phases, simply 
edit the phase names in an empty model file, save it with Save As, and then use the Get Info window in the System 7 
Finder to designate the file as a Stationary Pad. 

Note: The term "layers" is avoided in DesignWorkshop because the analogy to overlay drafting, which makes "layers" 
vivid when used in drafting software, is not relevant in a 3D modeling environment. For some people, the term 
"layers" implies some spatial connection which doesn't necessarily exist, therefore causing unnecessary confusion.
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The Object Info box displays information about the current selected object. Fields with a simple rectangular outline 
display information about an object and can be changed by editing the field. Fields with drop-shadows (such as Angle 
and Area) are pop-up menus of the available options. The dimensions displayed are measured according to the 
object reference point chosen at the top of the windoid.

Open the Object Info box by using the Layout menu Show Info... command, or by double-clicking on an already 
selected object.

To change the size of an object with the Object Info window, open the windoid, select the object, and edit the text in 
the field for the dimension you want to change. Then hit Return to execute the change, or if you want to change more 
than one dimension, use the Tab key to advance from field to field.

To move or rotate an object (rotations are around the object reference point) edit the contents of the appropriate fields 
in the same way. For instance, to quickly and precisely change the elevation of an object, change the value in the z 
field.

The phase in which an object is located can be changed by selecting a different phase from the Phase pop-up menu.
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The Views windoid allows you to clean up and rearrange the list of saved views that appears at the bottom of the 
View menu. It can be opened with the View menu Edit Views menu command.

The list of views in the Views windoid provides the initial list of views for calculation of animated walkthroughs (see 
next section). The check marks in the left column indicate which of the saved views will appear in the walkthrough 
views list. For instance, to leave "Initial View" out of the walkthrough list, uncheck that view name by clicking on its 
checkmark.
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The Walkthrough windoid lists the views that will be rendered during the calculation of a walkthrough movie. It is 
opened with the View menu Walkthrough > Setup menu command.

Any views that you do not want recorded into the walkthrough movie can be removed from this list by selecting the 
view name and then clicking on the Remove button. Removing a view here, from the walkthrough list, does not 
remove it from or have any other effect on the main views list.

Intermediate, "interpolated" views can be added between any of the saved views by selecting a view name and then 
clicking the Insert button. These allow you to smooth and control the speed of motion in the recorded movie.

When you have a walkthrough script set up, you can run the batch calculation of the walkthrough views from the View 
menu or by clicking the Run button in the windoid. A dialog box will appear to present saving options, and then each 
view in turn will be rendered, using the size and rendering style of the active document window.



 
Save Walkthrough dialog box

Note: To save walkthroughs in the QuickTime format, the Apple QuickTime system extension must be installed on 
your Macintosh. It is distributed with DesignWorkshop under license from Apple.

Walkthrough and sun study QuickTime movies recorded with DesignWorkshop can be viewed with the Apple 
MoviePlayer application, also included.

In addition to providing a simple way to script basic architectural walkthroughs or other moving-camera animations, 
the Walkthrough function can also be used as a batch rendering function for any series of independent views. For 
instance, with several standard views set up in the Walkthrough list, an end-of-the-day batch calculation of several 
views of a complex model can be run overnight, as one long process, to provide fairly effortless design-progress 
documentation.

The Walkthrough function can also be used to create the series of frames needed to make a QuickTime VR object.
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Menus Overview

The menus of the DesignWorkshop application are File, Edit, Layout, Arrange, View, Notes and Window. In addition, 
About DesignWorkshop and DesignWorkshop Help appear under the Apple menu when DesignWorkshop is the 
active application. 

File -- general document operations like opening, saving, and printing 

Edit -- clipboard operations and manipulations of entire objects, like scale and duplicate 

Layout -- the working environment, including floating windows 

Arrange -- special and temporary properties of objects and of the model, plus fit, group, and hide 

View -- how the active window displays a model -- how the view is projected and rendered 

Notes -- text attributes, including styling 

Window -- opening additional windows of the active document

Macintosh Keyboard Shortcuts 

DesignWorkshop keyboard shortcuts let you access menu commands directly from the keyboard. Most keyboard 
shortcuts use a combination of two keys pressed at once, but some shortcuts require the use of three keys together. 
For most command keyboard shortcuts on the Macintosh, you press the Command ( ) key and one additional 
character. For some keyboard shortcuts you press either the Shift key (

) or the Option key (
), plus the Command key and the character. As with most Macintosh applications, the use of any keyboard 

shortcut is optional.

Windows Keyboard Shortcuts 

DesignWorkshop keyboard shortcuts let you access menu commands directly from the keyboard, without stopping to 
move the mouse and click. Most keyboard shortcuts use a combination of two keys pressed at once, but some 
shortcuts require the use of three keys together. For most command keyboard shortcuts on Windows, you press the 



Control () key and one additional character. For some keyboard shortcuts you press either the Shift key () or the Alt 
key (), plus the Control key and the character. As with most Windows applications, the use of any keyboard shortcut 
is optional.
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New Model 

This command creates a new empty DesignWorkshop model. 

Open... 

Use the Open command to open standard DesignWorkshop models and 3DMF files saved in DesignWorkshop or any 
other 3DMF capable application. 

Merge File... 

The Merge File command is used to join two 3DMF models into one. It is only active in QuickDraw 3D mode. Upon 
selecting it an open dialog box will appear, select the model you want to merge with the currently open model. The 
model you select will be merged with the model in the foremost window.

Close 

The Close command closes the foremost window. If a particular file has multiple windows open the file will remain 
open, but the front window will close. If the window being closed is the last open window for that model and changes 
have been made since last saving you will be presented with a dialog box asking if you want to save the changes 
before closing. 



Save 

The Save command saves a model in DesignWorkshop format when you are in the standard DesignWorkshop mode 
or in 3DMF format when in QuickDraw 3D mode. When you save a temp file is written of the model and when that 
finishes successfully the temp file replaces the real model file on your disk. The first time the Save command is 
issued on a model it operates like a Save As command. 

Save As... 

The Save As... command is used to save a model with a different name or in a different location than the model was 
opened as.

 
Save As dialog box in QuickDraw 3D mode.

In QuickDraw 3D mode you have the option of saving the file as a 3DMF binary file or a 3DMF text file. Binary files 
are smaller and almost always the preferred format. 

Revert to Saved... 

This command will change the current 3DMF file to it's exact state when it was saved last.

 
Revert to Saved dialog box in QuickDraw 3D mode.

You can not undo a Revert to Saved command and all unsaved changes will be lost. The command is not active with 
standard DesignWorkshop models, but you can simulate it by closing a model without saving changes and then 
reopening the model.



 Background >   Open... 

Use Background >   Open to open any PICT image file as a background image to the 3D work space. In wireframe 
and shaded rendering modes, this image will appear as a backdrop to the model. In shaded rendering mode you 
need to turn off the ground plane in Sun and Shading Settings to see the background below ground level.

In plan, elevation, and axonometric views the background image will scale correctly as you zoom in two-
dimensionally. You can zoom in on a small part of the background and trace from it with the polyline tool and then 
zoom out and the model and background will line up properly. 

Background >   Close 

Use this command to close a background. You must close the current background before you can open a different 
one.

Page Setup... 

This is the standard Macintosh page setup for printing. 

Print...

follows standard Macintosh conventions to allow you to print whatever is displayed in the front window in WYSIWYG 
fashion, according to the current view and rendering settings. Printing large color rendings of complex scenes 
requires substantial amounts of application memory. You can use Get Info in the Macintosh Finder to assign more 
memory to DesignWorkshop if necessary.



 Import >   DXF Drawing or Model... 

This command brings up a standard Open File dialog box for choosing a text file containing DXF format data 
describing 2D or 3D graphics. DXF objects are read in at their native 1:1 scale. DXF layers will be translated to 
DesignWorkshop phases. New phases will be created for imported objects unless there is already a phase with the 
same name as the DXF layer in the current DesignWorkshop document. In that case, the objects will be read into the 
phase with the matching name, adding to whatever objects are already in that phase.

When preparing a drawing or model in another application for import to DesignWorkshop 1.0, it is usually helpful to 
set units to feet, or to meters if you are working in metric units. Also, spline curves should be converted to polylines. 
(Do not, however, explode the geometry further than necessary.)

Also, note that because of the differences in how basic text files are handled on different computer platforms, DXF 
files have different file formats in Macintosh, DOS, and UNIX. Thus, when importing DXF files from other systems, 
you must adjust the text file format before DesignWorkshop can read the foreign DXF file. For instance, if you are 
using Apple File Exchange to read a DOS disk onto a Macintosh system, do not use the default translation. Instead, 
set it as follows:

for DOS to Macintosh use "text with CR" only
for Unix to Macintosh use "text with CR" only

The DXF format is interpreted differently by different software developers, and Artifice is continuosly refining and 
adjusting the DesignWorkshop translators to work with as many other applications as possible. 

Import >   Object PICT... 

This command imports object PICTs converting the PICT objects to DesignWorkshop polylines. These objects can 
then be scaled and extruded into three dimensions. This command also imports PowerCADD Scaled PICTs which will 
be imported at the proper scale. PowerCADD Scaled PICTs can be created in PowerCADD 3.0 and 
DesignWorkshop. 

Import >   Architrion Text... 

Import >   Architrion Text lets you convert Architrion models to DesignWorkshop models. Through a standard 
Macintosh open file dialog box, it opens files describing 3D models in the Architrion II text format (produced from 
ArchiDesign models by the Architrion II "3D Translator"), and reads the Architrion blocks into the current 
DesignWorkshop document. Openings in Architrion blocks translate into fully editable DesignWorkshop openings.

Export 2D >   Object PICT... 

Object PICTs can only be exported in the standard DesignWorkshop mode. This command produces 24-bit color 
object PICT files editable in most Macintosh drawing applications. The PICT file is based on the current view and 
rendering method. Since most Macintosh image-editing software (such as Adobe Photoshop) can read object PICTs 



into their own image-based format, these exported PICT files serve for both drawing and image export purposes.

 
Export 2D >   Object PICT dialog box.

In the dialog box you can set the size of the PICT. The proportions are constrained to match the current window, but 
you can set the percentage or the width or the height of the PICT.

Exported PICT files are often brought into Photoshop for additional hand rendering, compositing with a scanned 
photograph, for color correction for offset printing, etc. 

Export 2D >   Pixel PICT... 

This command exports pixel PICTs while in QuickDraw 3D mode. It is not active in the standard DesignWorkshop 
mode. The resulting file can be edited with Photoshop or other painting/image editing programs.



 
Export 2D >   Pixel PICT dialog box.

As with Object PICTs you can set the size of the PICT to be exported. Pixel PICTs are much more memory intensive 
than Object PICTs, so memory has to be a concern when exporting pixel PICTS. Making the size of a PICT too large 
will cause memory errors. You can turn the bit depth down from 32 color bits per pixel (millions of colors) to 16 color 
bits per pixel (thousands of colors) to cut memory requirements in half. 

Export 2D >   PowerCADD Scaled PICT... 

This command exports files in the PowerCADD Scaled PICT format, this format was devised to make translating 
between DesignWorkshop and PowerCADD as easy as possible. PowerCADD 3.0 ships with an XTNL for importing 
and exporting in this format. Using this format you can open files in DesignWorkshop and PowerCADD without losing 
the scale of objects when going between the programs. This command is only available in standard DesignWorkshop 
mode in plan, elevation, or axonometric views. 

Export 2D >   DXF Drawing... 

This command produces DXF version 10 drawing files, readable by most 2D CAD programs. The drawing exported is 
based on the view projection in the current active window. For example, to export a plan, get the plan view on screen 
and give the Export >   DXF Drawing command. A standard file naming dialog box will appear, and after you specify 
the name and directory for the drawing file and click OK, a DXF drawing file of the drawing will be created.

If you have organized the objects in a model into phases, this organization will be preserved in layers in the DXF file. 
Because DXF requires that layer names be unique, unlike DesignWorkshop phases, the DesignWorkshop phase 
names will have a number added at the beginning. Also, spaces in phase names will be filled in with the underscore 
character.



Export 3D >   DXF Model... 

This command produces DXF version 10 three-dimensional model files, readable by most 3D modeling applications, 
Mac or otherwise, AutoCAD included. All the objects currently available (visible and editable) in the DesignWorkshop 
model are included in the exported file. Because of limitations in the DXF format, faces of objects which contain 
openings may be subdivided in the resulting DXF file. DXF model files will be interpreted as 2D plan drawings by 
many 2D drafting applications. 

Export 3D >   Radiance View... 

This command exports a Radiance rif file for the current view. The rif file is fully commented and has everything set. 
You can edit the file with a text editor to make any changes you see fit or you can use the resulting rif file without any 
changes. The rif file contains only view information, no geometry or materials are in this file. You can use multiple rif 
files on the same rad and mat files of a model to produce multiple views. 

Export 3D >   Radiance Scene... 

This command exports three files, a rad file containing the model gemoetry, a mat file containing material information, 
and a rif file containing view information.

The rad file contains model geometry and sun settings. The sun settings are based on what was set in the Sun and 
Shading Settings in DesignWorkshop.

The mat file contains material definitions for Radiance. Material names in the mat file are based on the material 
assigned the object in DesignWorkshop and the color assigned the object in DesignWorkshop. You need to edit this 
file to add materiality to objects in Radiance.

The rif file contains view information. This file is fully commented, and explains how you can edit it to achieve the 
rendering you want.

Quit 

The Quit command will close all currently open windows and quit DesignWorkshop. If a model is open which has 
been changed since it was last saved a dialog box will appear asking you want to save changes before quitting.
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Undo 

Undo undoes the last thing you did. Undo only works on operations that change the model.

Cut 

Cut will take the selected objects out of the model and put them in the clipboard. Objects maintain their material 
definitions and other characteristics. 

Copy 

Copy will copy the selected objects from the model and put the copy in the clipboard, the objects will remain in the 
model and can be pasted again into the same model or a different model. 

Paste 

Paste places copied objects into the model space according to their original world coordinates. If you want the pasted 
objects in a different location, just move after pasting. To paste into openings, copy a window frame or door (create 
your own or copy one from the DesignWorkshop 3D Libraries), select an opening, and then paste. A dialog box will 
open, allowing you to choose scaling and alignment options. Once you click OK, the frame is scaled, rotated, and 
moved to fit exactly into the selected opening. 

Select All 



Select all will select all of the currently visible objects in the model. If the cursor is in a text field, such as the phases 
windoid, select all will select all the text.

Duplicate 

Duplicate creates a single copy of an object or group. The new object is offset horizontally by two grid-snaps east and 
south (so that the copy is not confused with the original). At the end of a simple Duplicate, only the new object is 
selected. 

Duplicate Linear... 

Duplicate Linear allows rapid creation of straight-line arrays of copies. The menu command brings up a dialog box for 
you to specify offsets from one object to the next, measured independently north/south, east/west, and vertically. The 
total number of objects to result is specified (including the original in the count). At the end of the operation the whole 
set of objects is left selected, in case you want to group them, move them, or duplicate again.

To make a two-way rectangular array of objects, such as for a column grid, first Duplicate Linear in one direction, and 
then while the objects are still selected from that operation, Duplicate Linear in the perpendicular direction. 

Duplicate Circular... 

Duplicate Circular provides for the creation of circular arrays of objects. The menu command brings up a dialog box in 
which you specify the total number of object, the degrees of rotation from each object to the next, and the vertical 
offset from each to the next, if any.

After clicking OK, click once in the model space with the 3D crosshair to indicate the position for the axis of rotation. 
The axis of rotation is always parallel to the "Z" or option-drag direction of the current working orientation. To change 
the axis of rotation for Duplicate Circular, switch to a different working orientation. 

Duplicate Mitered... 

Duplicate Mitered works like duplicate circular, but a copy of the original object is extended sideways to meet its 
neighbors. This lets you create radial joined elements such as domes and spiral stair-cases, or general "lathed" 
forms.

 
Duplicate Mitered dialog box.

The axis of revolution is always parallel to the Z-axis of the current working orientation. The object extensions for 
mitering are based on a cross-section of the original object cut by one of the major orthogonal planes of the current 
working orientation. 

Scale... 

The Scale menu command is used to numerically change the size of objects and groups. The scaling percentage for 



each of the horizontal scales and the vertical scale of an object can be set independently. Each object scales about 
its center, so, to scale several objects and the distances between them, or to scale an entire model, first group the 
objects.

Wallify... 

The Wallify function turns solid massing models into space-filled walled models. Select an object, and choose Wallify 
from the Edit menu. This brings up a dialog box to set a Wall Thickness (which has a default setting of 0.5 ft.), and 
then replaces any selected blocks with four walls mitered together at the outside corners. These walls are now 
separately editable. Blocks and extrusions can be wallified, even when they have tilted ends.

Show Clipboard... 

When you Cut or Copy objects, the clipboard automatically receives the objects in both 2D and 3D form. Thus, you 
can directly copy and paste 2D PICT graphics into most Macintosh drawing, paint, or word processing applications. 
To preview the 2D view before switching to another application, use the Show Clipboard command.
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Snap Grid 

This toggles the snap grid on and off. When the snap grid is on, it restricts the crosshair (and therefore clicked points) 
to the snap interval, as an aid in making clean, accurate models. You can adjust the grid snap interval with the 
Preferences menu Snap Grid... item. This doesn't have any effect on the light gray background grid lines the 
crosshair snap grid and the reference grid lines are entirely independent. For clarity, however, you will probably want 
to set the reference spacing to some multiple of the snap setting.

Background Grids 

This toggles the visual display of the reference grids on and off. This has no effect on the snap grid. The spacing and 
overall size of the reference grids is controlled by Background Grid Lines... in the Preferences menu. 

Show Object Info 

Show Object Info opens a floating windoid which displays the dimension and location of the selected object. You can 
edit these numbers by clicking on them and entering the new value for the object. You can also assign materials and 
change the phase of an object in the Object Info windoid. 

Show Phases 

Show Phases opens a floating windoid for turning on and off the visibility and editability of "phases," which are the 3D 
equivalent of "layers" in a 2D program. In the Phases window, a check mark along the left edge sets the "current 
phase". This is the phase into which all newly created objects go, and where object are placed by Paste operations. 
Phases can be individually set to be fully editable, locked but visible, or not visible (and therefore also not editable).



Materials >   Set Current 

This presents a submenu listing all the current session materials. You can select a material and then all objects you 
make will have that material assigned to them until you change the current material. You can also assign materials to 
objects with the Object Info windoid. 

Materials >   Purge Materials... 

Purge Materials removes all materials which are not assigned to an object from the session materials. Only these 
materials will be available for the rest of the session and only these materials will be saved in the file. 

Materials >   Write Material Prefs 

This command will overwrite the DW Material Prefs file with the current session materials. The session materials 
are based on PICT files in the Textures folder, materials defined in the current model, and materials defined in the 
DW Material Prefs file. A list of the session materials is displayed in the Materials >   Set Current sub menu and 
in the Object Info windoid materials menu. Be careful about overwriting the Material Prefs file.

Adjust Section Planes 

In wireframe view selecting this will display an object resembling a fat 3D crosshair. This crosshair shows the current 
section planes (where a section will be cut when rendered in a setting other than wireframe). You can drag the 
section planes around so they are where you want a section to be cut.



Working Orientations >   Adjust Orientation 

Adjust orientation shows a bold adjuster crosshair which you can drag in space to change the location of the 0, 0, 0 
point. Use the Set to Object and Set to Face menu commands to adjust the angle of orientation.

Working Orientations >   Set to Object 

Setting the working orientation to match an object is a quick and accurate way to draw new objects with a matching 
rotation or tilt.

Set to Object is very useful when modeling buildings or environments with more than one major grid orientation, as 
often occurs in some avant-garde styles. Make one grid match the normal world cardinal directions. Then to switch 
the crosshair alignment to a different grid, just select any object already in that non-orthogonal alignment, and use 
Set to Object. That sets the arbitrary working orientation to match the second grid system. Subsequently, you can 
switch between one grid and the other by switching between the normal and the arbitrary working orientations with a 
click in the tool palette. 

Working Orientations >   Set to Face 

Setting the working orientation to the face of an object is slightly different from setting it to an object. When setting the 
orientation to the object the orientation is based on the reference point of the object. When setting it to a face it is 
based on the selected face which may be different than the orientation of the reference point. You must select one 
face of an object using the Faces Mode Tool to be able to set the orientation to the face of an object. 

Working Orientations >   Set to Default 

Set to Default puts the arbitrary orientation back to the default zero elevation, 45-degree rotation.

Preferences >   Dimensions... 



The Dimensions Preference allows you set various dimensional aspects of your model. The first setting involves pull-
down menus for the units you want to work in. DesignWorkshop supports English and Metric units from miles to 
millimeters. Next to the units pull-down menu is another menu which allows you to set the precision of the selected 
unit. You can also set the format you want to use for angle units, as well as the precision.

 
Preferences >   Dimensions... dialog box.

When you change the working units the dimensions of objects in the model will scale accordingly. If you make a block 
that is five feet across and then change the working units to meters the size of the block will be listed as 1.64 meters. 
This is a new behavior in DesignWorkshop, in previous versions you would have had to scale the entire model 
yourself when changing units.

The next entry adjusts the snap grid spacing, to control the rounding-off of 3D crosshair locations provided by the 
snap grid. The snap grid spacing also determines the smallest object you can create while the snap grid is turned on. 
Turning the snap grid on and off is accomplished by toggling the Snap Grid menu item atop the Layout menu, or by 
clicking on the Grid tool icon in the tool palette. Double-clicking on the Grid tool icon also opens the Dimensions 
dialog box.

Next in the Dimensions dialog box are settings for the Background Grid Lines, these adjust the spacing between the 
lines in the background grid, and the overall dimension of the whole grid. These grids are independent of the snap 
grid, and are for visual reference of scale and spatial orientation only. 

Preferences >   Circle Faceting... 

Circle Faceting adjusts the number of facets used by the Circle and Arc drawing tools, and therefore the 
"smoothness" of newly created circles and arcs. Setting the number of facets higher will produce more complex 
objects, which will be smoother, but will also render more slowly. You should generally aim for just enough facets and 
no more. 

Preferences >   Handle Snap Sensitivity... 

Handle Snap Sensitivity adjusts the active radius for handle-snapping. This comes into effect when the Snap-to-
handles tool is turned on (top left of the tool palette). When the 3D distance between a 3D-crosshair mouse-click and 
any object handle is greater than the snap-to-handle distance, no snapping will occur. When the crosshair is closer to 
a handle than the snap-to-handle distance, the crosshair will snap to the nearest handle, indicating the exact location 
of that handle. Handle snapping overrides grid snapping, so you can snap to a precise point even if it is off the set 
snap grid. To use handle snapping for fine work on a detailed model, the snap-to-handle distance will usually have to 
be set to a smaller value than the default. 

Preferences >   Rotation Settings... 

Rotation Settings controls the preferences for rotation operations. The upper pop-up menu in the dialog box affects 
the shift-constraints for both object center rotations and object handles rotations. It sets the fineness of the shift-
constraint "notches" provided when rotating objects with the Shift key held down. The lower pop-up menu only affects 
rotations about object centers. For these operations, the pop-up menu sets how far the object will turn around for a 
given amount of cursor movement across the screen.

Preferences >   View Control Sensitivity.... 

View Control Sensitivity adjusts how much the 3D view changes for a given distance dragged on screen with the Eye 



and Look tools, and also how much the 3D view changes per click of the arrow keys when using the Eye and Look 
tools. Setting these to small numbers allows very fine adjustments of the eye and look points, especially when they 
are adjusted by nudging with arrow keys. Using the arrow keys for fine view adjustments makes it easy to perfect 
difficult perspective view adjustments. Adjusting with the arrow keys can be particularly helpful because the precise 
movements they cause can be precisely reversed, for visual comparison of slight view differences. 

Preferences >   View Cycling... 

View Cycling adjusts the relationship between perspective and axonometric views. By default, these view types are 
independent, so changing the current perspective has no effect on the current axonometric, and vice-versa. With the 
perspective/axonometric view linking option in effect, the view direction is preserved when switching between the 
projection types, so at each change of view type the view of the scene remains generally similar. For instance, 
entering axonometric after getting a new perspective will put the view in a new axonometric, with its zoom and 
direction derived from the latest perspective.
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The Arrange menu contains functions that affect the grouping and display of model objects, or change their geometry 
relative to other objects.

 

Align Objects >   [ North, South, East, West ]

Align Objects North will align two or more objects along the northern-most face of the objects, and similar alignments 
for the other directions. 

Align Objects >   Vertically >   [ At Top, At Center, At Bottom] ] 

Align Objects Vertically At Top will align two or more objects along the top-most face of the objects. At Center will 
align the centerline of all the selected objects. At Bottom will align all the selected objects at their lowest face. 

Fit Object >   [ Upward, Downward, North, South, East, West ]
The Fit Object options are used to extend the selected object in a given direction (Upward, Downward, North, South, 
East, West) until they hit another object. Just select the object to extend, then give the menu command, and the 
object will enlarge and adjust the shape of its end face to match the nearest object in the direction of extension. This 
provides an easy way to match one object to another. For instance, Fit Object > Upward will shoot a flat-topped wall 
upward to exactly match to the underside of a sloping roof block. Fit Object > Downward can be used to fit a cuboid 
chimney down onto a sloping roof, without making you think about the slope.

Objects will only extend to fit--they will not get shorter. 

Flip North-South
Flip East-West



Flip Vertical 

Flip inverts an object (or objects) along the axis you specify. Flip is like making a mirror image of the object. If you 
select Flip North-South what was the south face will be the north face and vice versa, but the east and west faces will 
not flip with each-other.

Group and Ungroup 

Group and Ungroup work on 3D objects in the typical Macintosh way. Group collects all selected objects into one 
compound object, and Ungroup does the reverse, releasing a compound object to its parts. Grouped objects can be 
scaled all together by dragging the handles of the group bounding box. The Trim tool can be used on a group to cut 
through all the objects in the group at once. The trim crosshair is displayed on the group's bounding box. When 
moving the view around with the Eye or Look tool, only the bounding box of a group is displayed, effectively 
simplifying the model to speed the dynamic viewing process. 

Hide Objects 

Hide makes the selected objects temporarily invisible. As long as an object is invisible, it is also not editable, so it 
can't be selected, moved, deleted, etc. 

Cancel Hide 

Cancel Hide makes all the invisible objects reappear; if no objects have been hidden, the Cancel Hide menu is 
grayed out. 

Invert Hide 

Invert Hide switches the visibility of everything, so the currently visible objects become hidden and the hidden objects 
become visible.

To briefly isolate a single object from a large model, for instance for detailed reshaping, select and hide that object, 
and then "invert the hide", to quickly see it all by itself. Then "cancel hide" to bring back the rest of the model.

The Hide commands provide functionality similar to the Phases controls. The difference is that "hides" are not saved, 
and are intended for quick showing and "unshowing" of particular objects for modeling convenience. The Phases 
controls are appropriate for showing and unshowing related collections of objects on a recurring basis. 

Show Projection Lines 

Show Projection Lines and Cancel Projection Lines turn on and off the display of projection lines for objects when the 
objects are deselected. Normally, projection lines show for selected objects and objects being created. Turning on 
projection lines with Show Projection Lines makes the lines stay visible even when the objects are deselected. This is 
useful for making many kinds of three-dimensional alignments, especially when drawing in the elevation or the 
arbitrary working orientations. 

Cancel Projection Lines 

To turn off projections lines for an object, select it and then give the Arrange menu Cancel Projection Lines command. 
To quickly turn off all projection lines, use the Edit menu Select All command, and then choose Cancel Projection 
Lines.

Sun & Shading Settings... 

Sun & Shading Settings brings up a dialog box for setting the time, date, and latitude to easily and accurately specify 
the sun angle for Shading, Shadow Casting, and Sun Study... renderings. The time is taken as local time, so the 
longitude of the model location is not needed.

The Sky Backdrop and Ground Backdrop are not really three-dimensional. They are simply painted behind all objects 
in the scene, with sky above the horizon line, and ground below the horizon, to economically provide the effect of a 
whole world. You may want to turn off one or the other of these to see a background PICT image in a shaded view, or 
to look at shaded solids against a simple white background (with or without the Background Grids).



The ground plane, in contrast to the backdrops, is a three-dimensional object like an infinite flat plane at zero 
elevation. It provides a surface of "earth", going out to the horizon, for your model to appear to rest on. In wireframe 
views, the ground plane is not visible and has no effect . In shaded views, to see "underground", or below zero 
elevation in the model space, uncheck the "Draw Ground Plane" option.

The ground plane provides a default surface for shadows to fall on. For shadows to fall on objects below zero 
elevation, such as a site model, for instance, also turn off "Draw Ground Plane".

To view your model against a white background, but still get shadows cast onto the "floor", turn off both backdrops, 
but leave the ground plane on. This is often a nice way to look at furniture or other relatively small objects that don't 
necessarily exist out in the landscape under a blue sky.

The actual rendering of shading and shadows is activated from the View menu.
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The View menu allows you to choose specific view projections and rendering methods, and it lets you save the 
current view under a name for reuse later. These choices control the view projection for the current application 
window (the one in front with the stripes showing in its title bar). Changing the projection or rendering for the current 
window does not affect other windows. 

Plan, Section, Elevation (North, South, East, and West), Perspective, and Axonometric 

These views all present the model from the angle you would expect according to the standard architectural definitions 
of these views. The elevation directions are determined by the compass directions defined for the work space (see 
North arrow). 

Section 

To view a pochéd section-perspective, choose Section from the menu. This activates a set of four clipping planes, 
one of which is applied at a time according to the view direction. Sectioning only affects shaded and shadow-cast 
views. In a shaded view, if your view looks down from an altitude angle greater than 45 degrees, you will see the 
model cut and pochéd in plan. When the view direction is flatter than 45 degree altitude, the model will be rendered 



cut and pochéd one of four ways, so that you see into the cut face closest to perpendicular to the current view 
direction. The position and rotation of the sectioning planes can be adjusted graphically with the 3D Section Planes 
Adjuster tool, activated with the Layout menu Adjust Section Planes command.

The next section of the menu controls the rendering of the model on screen: Wireframe, Hidden Line, Shading, 
Shadow Casting, or Lights & Textures. 

Wireframe 

The Wireframe rendering method shows all objects as transparent solids, drawing only the object edges. This method 
is not very realistic-looking, but it is much faster than the other methods, because the Macintosh doesn't have to 
calculate which objects are blocking the view of other objects. The wireframe method also lets you see through your 
design as if with x-ray vision. 

Hidden Line 

The Hidden Line rendering method shows objects as opaque white solids with black edges. The result is similar to a 
simple non-shaded black-and-white line drawing of the scene. 

Shading 

Shading adds color shading of each object face, with color ground and sky backdrops turned on by default. The 
shade for each face of each object is calculated based on the angle between that face and the sun, so faces are 
rendered with their lightest shade when facing directly toward the sun, and progressively darker as they face more 
sideways to the sun. Object faces pointing away from the current sun direction are rendered even darker, as they 
would be in shadow.

Turning on Shading also turns on Hidden Line, so that by default the object edges are drawn as well as the object 
faces. By selecting Shading and then unchecking Hidden Line, you can shade the model without the object edges 
being highlighted. This is generally more realistic, but often harder to interpret visually due to the absence of light 
variations in flat shading. Distant surfaces of the same color which happen to be at the same angle to the sun may 
not appear to separated at all without the object edges drawn. 

Note: To see a Background PICT (opened from the File menu) when using Shading, you have to turn off the display 
of the sky and/or ground backdrops using Sun & Shading Settings. 

Shadow Casting 

The Shadow Casting menu item turns on calculation of shadows cast by the sun. Shadow-cast renderings are 
computed by a fast object-oriented method, and generally take only around twice as long as a shaded rendering of 
the same scene. These renderings can be saved as object drawings with the File menu Export functions, and they 
print similarly to other rendering types. The sun angle is set by time, date, and latitude in the Arrange menu Sun and 
Shading Settings dialog box, as are the display and color of ground, sky backdrops, and flat ground plane. The 
ground plane defaults on so there is something to cast shadows onto. 

Lights & Textures 

Converts current DW model to a 3DMF model and renders it in a new window using QuickDraw 3D. Objects assigned 
materials will be rendered with the material and light sources will shine in this view. This menu item is not active if 
QuickDraw 3D is not installed. 

Update Lights And Textures 

If you are switching between the DW version and the 3DMF version of your model, you can make changes to the DW 
version, switch to the Lights and Textures window and select this menu item and your 3DMF model will reflect the 
changes you made to your DW model.



Lighting >   Sunlight 

Toggles the sun on and off in the Lights & Textures window. 

Lighting >   Brighten Sun 

Makes the sun one step brighter in the Lights & Textures window. 

Lighting >   Dim Sun 

Makes the sun one step dimmer in the Lights & Textures window. 

Lighting >   More Contrast 

Raises the contrast level one step in the Lights & Textures window. 

Lighting >   Less Contrast 

Lowers the contrast level one step in the Lights & Textures window. 

Lighting >   Brighten Model Lights 

Makes the lights in your model (not the sun) one step brighter in the Lights & Textures window. 

Lighting >   Dim Model Lights 

Makes the lights in your model (not the sun) one step dimmer in the Lights & Textures window.



Rendering >   Renderer 

This menu will list all your rendering options associated with QuickDraw 3D. If you have plug-in renderers installed on 
your computer they will be available here. 

Rendering >   Renderer >   Configure Renderer 

Some plug-in renderers can be configured to your liking. If the selected renderer can be configured this menu item 
will be active and selecting it will bring up a dialog box for configuring the renderer.

Rendering >   Shading Style >   Flat Shading 

Changes QuickDraw 3D shading style from Per Vertex to Flat Shading in the Lights & Textures window. Flat shading 
will generally be less realistic because specular highlights and other such details will not be rendered. 

Rendering >   Shading Style >   Per Vertex 



Changes QuickDraw 3D shading style from Flat Shading to Per Vertex in the Lights & Textures window. Per vertex 
shading is the default and will tend to provide more realistic renderings than flat shading.

Rendering >   Graphics Engine >   Best Choice 

If a QuickDraw 3D accelerator card is present will render using the card. If there is no card present DesignWorkshop 
will render using Apple Software. This option is selected by default. 

Rendering >   Graphics Engine >   Apple Software 

Select this item if you have a QuickDraw 3D accelerator card but want to force the rendering to be done without the 
card.

If you have one or more QuickDraw 3D accelerator cards installed each one will also be listed in this menu. You can 
select any accelerator card listed to render with that card. The LightWorks plug-in renderers and every other plug-in 
renderer currently available do not take advantage of accelerator cards. Only Apple's interactive renderer (the default 
QuickDraw 3D renderer) take advantage of accelerator cards.



Script Walkthrough >   Setup... 

Displays the Walkthrough windoid. See the section on DesignWorkshop Windows for more information. 

Script Walkthrough >   Run... 

This command displays a dialog box where you choose to save the walkthrough as PICTs and or a QuickTime movie, 
then the walkthrough is run and saved. 

Sun Study 

The Sun Study... command generates a series of images for a single-viewpoint, time-lapse, animated sun study, with 
a small clock placed in the lower right corner of each frame indicating the solar time. Define the time-extent of the sun 
study by entering the starting time and ending time. The fineness of the time-lapse effect is controlled by setting the 
number of frames to be rendered. For hour-by-hour views, specify a frame number one greater than the time-span of 
the study in hours.

The sun study will be rendered in a special square window, using the size specified in the Sun Study dialog box, with 
its projection based on the current view in the modeling window. The sequentially rendered frames of the sun study 
can be saved as individual numbered PICT files, as a QuickTime movie, or both. QuickTime movies are usually 
relatively small for animation files.

Rendering many frames in a single batch may require an increase in the DesignWorkshop memory partition. To 
increase the memory partition, go to the Finder when DesignWorkshop is not running, and use the File menu Get Info 
... command to open the Info window. Then, type a higher value into the application memory size field at the bottom 
right of the window. Close the Info window to enter the new setting.

Sun studies saved as QuickTime movies can be played back with the Apple MoviePlayer application (also included in 
the DesignWorkshop distribution). The MoviePlayer window includes VCR-type play controls along the bottom. In 
MoviePlayer, you can set movies for continuous looping or back-and-forth play. Click on the triangular button near the 
left end of the control bar to run your movie. You can also scroll back and forth to any time by dragging the sliding 
handle on the control bar.

Set View 

Set View saves the current eye and look points under the name you specify, which is automatically added to the 
bottom of the View menu, so you can get back to a useful view quickly and exactly. The first several saved views are 
automatically assigned numbered command-key equivalents.

Saved views provide the basis for walkthrough calculations, and can be rendered as a batch through the Walkthrough 
floating window. 

Edit View 

Edit View opens the Views windoid, where unnecessary views can be deleted. (See the Views Floating Window 
description for details.)
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Notes Menu

 The Notes menu controls the appearance of text you enter into the sketch overlay layer of a view, using the tool 
palette text tool. This text is useful for light annotation tasks such as quick design notes or labeling of printouts.

Windows Menu

 New Window 

New Window opens another window onto the current model. DesignWorkshop allows multiple models to be open 
simultaneously, and multiple windows for each model. This function opens additional windows onto the current open 
model. If you want to open another model instead, use the File menu. Every window displays the file name it 
connects to in its title bar, to help you keep track of which is which. Any window onto a particular file beyond the first 
one will show an id number at the end of its title.

The number of windows and documents you can have open simultaneously is limited by the DesignWorkshop 
application memory partition. This can be increased in the normal Macintosh fashion (through the Finder File menu 
Get Info... command). Given enough memory, a maximum of six documents can be open at once, and a maximum of 
five windows can be open on each document.
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Material Types

An in-depth explanation of the types and uses of materials in DesignWorkshop.

Material Management

This chart maps the logic used by DesignWorkshop for combining the user-defined and default materials information, 
for rendering a given model or for saving.

The "DW Material Prefs" File

This important file is the main control point for the list of active materials, including lights and textures, and their 
detailed characteristics. Here is a commented reference copy of the default settings.

Materials Catalog

This illustrates the full standard set of textures and other materials distributed with DesignWorkshop.
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Overview 

In DesignWorkshop materials are used to define both lights and textures for rendering of the 3D model.

Materials are assigned to objects primarily using the "Object Info" floating window.

The effects of materials are seen primarily when rendered with the View menu Lights and Textures command, using 
QuickDraw 3D.

Altogether, there are six different material types defined in DesignWorkshop. The material types for light sources are 
Point_Light, and Spot_Light.

The material types that control the visual appearances of solid objects are Tiled_Texture, Full_Face_Texture, 
Centered_Texture, and Properties.

The Properties material does not use a PICT file for defining a texture, while Tiled_Texture, Full_Face_Texture, and 
Centered_Texture are all based on using specific PICT files.

Tiled_Texture 

A tiled texture is a texture that tiles itself to cover the object. If you add a PICT file to the textures folder by default it 
will be a Tiled_Texture, you need to edit the DW Material Prefs file to customize the material definition. Here is what a 
Tiled_Texture looks like in the DW Material Prefs file:

Brick-Std-RedTiled_TextureBrick-Std-Red0.0000001.0000002.0000002.000000Feet

As you see there are eight different fields for a Tiled_Texture. The first is the name of the material. The next defines 
the material type, in this case Tiled_Texture. The third is the name of the PICT file to use for this material, the name of 
the material and the name of the PICT file will usually be the same, but they donÕt have to be. The next field defines 
the specularity of the object. See the page on specularity for an explanation of how this field is defined. The next field 
is the opacity of the material, again on a scale from 0 to 1, with 0 being completely transparent and 1 being 
completely opaque (transparency is only apparent with a QuickDraw 3D accelerator card). The final three fields are 
related. These fields define the dimensions of the texture (the dimension at which it will repeat). The first of these 
three is the horizontal dimension, the next is the vertical dimension, and the final field is the unit of the dimensions, 
either Feet or Meters.

Full_Face_Texture 

A full face texture is a texture that scales the corresponding PICT file so the image fills the entire face of an object. 
For example, you can have a PICT file of a sign and then make a single block in DesignWorkshop and assign the 



materiality so that it is a full face texture of that PICT and there in your model will be the sign. The texture will be 
applied to every face on the object. You can also make extrusions in the shape of a tree and apply a full face texture 
of a tree and have trees, this requires careful coordination between the PICT file and the shape of the extrusion for it 
to look right. Here is what a Full_Face_Texture looks like in the DW Material Prefs file:

Facade-Photo_1Full_Face_TextureFacade-Photo_10.0000001.0000002.0000002.000000Feet

This is virtually identical to a tiled texture. The first item is the name of the material, the second says itÕs a Full_Face 
Texture, the third is the name of the PICT file, the fourth is the specularity, the fifth is the opacity. The last three are 
also identical to a Tiled_Texture, but in this case they are irrelevant, there is no dimension to the texture that you can 
set because it will scale to fill the entire face of an object.

Centered_Texture 

A centered texture will center the corresponding PICT file on every face of an object and the rest of the object will 
maintain the color as defined in the standard DW model. You can use this type of texture to label blocks in a massing 
model. Here is what a Centered_Texture looks like in the DW Material Prefs file:

BedroomCentered_TextureBedroom0.0000001.00000010.0000002.000000Feet

Again, this is virtually identical to the previous types of materials we have discussed. The first item is the name of the 
material, the next declares it to be a Centered_Texture, the third item is the name of the PICT file to use, the fourth is 
the specularity, and the fifth is the opacity. And the final three are the dimensions of the texture as it will be rendered 
in QuickDraw 3D, in this case 10 feet wide and 2 feet high.

Properties 

A material type of Properties defines the characteristics of an object without applying a texture to the object. This is a 
good way to make glass, or various kinds of paint. A Properties material type looks like this in the DW Material Prefs 
file:

Paint-Gloss-GreenProperties0.2000001.0000000.1333000.6902000.200000

This is somewhat different from the previous examples. The first field is the name of the material, the second is the 
type of the material, there is no PICT that corresponds with properties, so now the third item is the specularity. The 
fourth item is the opacity. The final three items define the color, they are the red, green, and blue values (respectively) 
of the object. Again these are on a scale from 0 to 1 with 0 meaning the object is devoid of that color and 1 meaning 
the object has as much of that color as possible. White would be 1 1 1, green (as in the example) would have some 
red (0.133300) a lot of green (0.690200) and some blue (0.200000).

Point_Light 

A point light material type will give off light from every face of an object. A Point_Light type looks like this in the DW 
Material Prefs file:

Light-BulbPoint_Light3.0000001.0000001.0000001.000000kQ3AttenuationTypeInverseDistance

The first item is the name of the material, and the next is the material type. The third item is the brightness of this 
object. The next three items define the color of the light, once again with the red, green, and blue values of the color 
on a scale from 0 to 1. The final item defines how the light disperses in relation to the distance from the light. There 
are three options here and they are kQ3AttenuationTypeNone, kQ3AttenuationTypeInverseDistance, and 
kQ3AttenuationTypeInverseDistanceSquared.

Spot_Light 

A Spot_light type is just that, a spot light. Light will shine from the lowest face of the object and the other faces will be 
black. A Spot_Light looks like this in the DW Material Prefs file:

Light-
Spot_N_MediumSpot_Light1.0000001.00000001.0000001.000000kQ3AttenuationTypeNonekQ3FallO
ffTypeCosine7.50000015.00000



As always the first item is the material name and the second is the material type. The next five items are the same as 
a Point_Light, that is brightness, red, green, and blue values, and the attenuation type. The final three items are all 
related, the first determines the way the light disperses outward from the center of the beam, the options are 
kQ3FallOffTypeNone, kQ3FallOffTypeLinear, kQ3FallOffTypeExponential, and kQ3FallOffTypeCosine. The next 
number defines an angle in degrees in degrees from the centerline that will have full brightness of light. The next 
number is the angle of light from the centerline in which the fade from full brightness to no light will occur.
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A new tiling texture material with default parameters can be created just by dropping a suitable PICT file into the 
active "Textures" folder. When this simple method is used, the material name will be the same as the name of the 
PICT file.

In addition, the "DW Material Prefs" file, can be edited by any advanced user to customize lights and textures 
parameters. Material definitions in the "DW Material Prefs" file take precedence over material information from any 
other source in DesignWorkshop.

However, DesignWorkshop does store materials information in several different places. The following chart illustrates 
the logic used to determine the priority of the various sources of material information.
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The DW Material Prefs file contains the definitions for the materials DesignWorkshop uses. If a specific model has 
material definitions which are not in the DW Material Prefs file the definition for the material in the model will be used. 
If there are PICT files in the Textures folder which are not in the DW Material Prefs file, they will be available as 
materials with a default definition.

In the Layout Menu is a submenu called "Materials" and one of the items listed is "Write Material Prefs". Selecting this 
will rewrite the "DW Material Prefs" file with the current session materials. The session materials are those listed in 
the materials menu of the object info box.

If you ever rewrite the DW Material Prefs when you didn't want to, or if you edited the file by hand and now it's not 
working you can return to the default "DW Material Prefs" file by deleting the file and opening DesignWorkshop.

Here is a reference copy of the default "DW Material Prefs" file: 

# DesignWorkshop Material Preference File
# Version 1.8 (1.8US-Pro)
# Created at 98/1/2, 10:46
#
# # # Material Preferences Format Notes # # #
#
# # Notation # #
#
# this is a comment
// and this is a comment
#
#
# Material Names and PICT File Names containing spaces must be in quotation marks.
#
# # Textures # #
# (materials that map an image file onto an object, and also set its optical 
properties)
#
# Textures Parameters Format:
# Material Name - Material Type - PICT file name -
# Smoothness (exponential from 1.0 to 100, as read from the four "x" digits in 
"nnxxx.xabnnn".
# The second and third places to the right of the decimal place in the Smoothness 
value,
# (the two digits "ab" in "nnxxx.xabnnn") store the Specular Reflectivity, as two 
decimal digits
# which together may vary from 00 to 99, representing Specular Reflectivity values 



from 0.00 to 0.99) -
# Opacity (linear from 0.0 to 1.0) -
# U dimension (width) - V dimension (height) - Texture Units (Meters, Feet)
#
# Texture Mapping Material Types -- Tiled_Texture, Full_Face_Texture, Centered_Texture
#
#
# # Properties # #
# (materials that set the optical properties of an object, without using an image 
file)
#
# Properties Parameters Format:
# Material Name - Material Type - Smoothness - Opacity - Red Value - Green Value - 
Blue Value
#
# Properties Material Types -- Properties
#
#
# # Lights # #
# (materials that associate a specific light source with an object)
#
# Lights Parameters Format:
# Material Name - Material Type - Brightness - Red Value - Green Value - Blue Value -
# Attenuation Type - Fall Off Type (Spots) - Inner Half-Angle (Spots) - Outer Half-
Angle
# (Spots)
#
# Lights Material Types -- Point_Light, Spot_Light
#
# Lights Parameters Options:
# Attenuation Type -- kQ3AttenuationTypeNone, kQ3AttenuationTypeInverseDistance,
# kQ3AttenuationTypeInverseDistanceSquared
# Fall Off Type (for Spots Only) -- kQ3FallOffTypeNone, kQ3FallOffTypeLinear,
# kQ3FallOffTypeExponential, kQ3FallOffTypeCosine
# Meaning of Light Angles -- Inner Half-Angle defines a cone of constant full 
brightness,
# measured from the centerline. Outer Half-Angle defines an equal or larger cone, also
# measured from the centerline, and the FallOffType is applied from the inner half 
angle to
# the outer half angle.
#
# ###
#
# # # Material Definitions # # #
#
Brick-Norman-Brown Tiled_Texture Brick-Norman-Brown 1.000000 1.000000 3.000000 
3.000000 feet
Brick-Std-Brown Tiled_Texture Brick-Std-Brown 1.000000 1.000000 2.000000 2.000000 feet
Brick-Std-Orange Tiled_Texture Brick-Std-Orange 1.000000 1.000000 2.666666 2.666666 
feet
Brick-Std-Red_New Tiled_Texture Brick-Std-Red_New 1.000000 1.000000 2.666666 2.666666 
feet
Carpet-Handmade Full_Face_Texture Carpet-Handmade 1.000000 1.000000 2.000000 2.000000 
feet
Carpet-Level-Blue Tiled_Texture Carpet-Level-Blue 1.000000 1.000000 2.000000 2.000000 
feet
Carpet-Level-Tan Tiled_Texture Carpet-Level-Tan 1.000000 1.000000 2.000000 2.000000 
feet
Carpet-Level-Tan_Flecked Tiled_Texture Carpet-Level-Tan_Flecked 1.000000 1.000000 
2.000000 2.000000 feet
Carpet-Shag-Blue Tiled_Texture Carpet-Shag-Blue 1.000000 1.000000 2.000000 2.000000 
feet
CMU-Split_Face-Gray Tiled_Texture CMU-Split_Face-Gray 1.000000 1.000000 2.666666 



2.666666 feet
CMU-Split_Face-Red Tiled_Texture CMU-Split_Face-Red 1.000000 1.000000 2.666666 
2.666666 feet
CMU-Std-Gray Tiled_Texture CMU-Std-Gray 1.000000 1.000000 2.666666 2.666666 feet
CMU-Std-Red Tiled_Texture CMU-Std-Red 1.000000 1.000000 2.666666 2.666666 feet
Concrete-Gray Tiled_Texture Concrete-Gray 1.000000 1.000000 2.000000 2.000000 feet
Door-Wood-Glazed Full_Face_Texture Door-Wood-Glazed 1.000000 1.000000 2.000000 
2.000000 feet
Fabric-Canvas-Green Tiled_Texture Fabric-Canvas-Green 1.000000 1.000000 1.000000 
1.000000 feet
Fabric-Corduroy-Brown Tiled_Texture Fabric-Corduroy-Brown 1.003000 1.000000 1.000000 
1.000000 feet
Fabric-Denim-Blue Tiled_Texture Fabric-Denim-Blue 1.000000 1.000000 0.500000 0.500000 
feet
Fabric-Mod-Fish Tiled_Texture Fabric-Mod-Fish 1.000000 1.000000 2.000000 2.000000 feet
Fabric-Mod-Red Tiled_Texture Fabric-Mod-Red 1.000000 1.000000 2.000000 2.000000 feet
Fabric-Twill-Red Tiled_Texture Fabric-Twill-Red 1.000000 1.000000 1.000000 1.000000 
feet
Facade-Photo_1 Full_Face_Texture Facade-Photo_1 1.000000 1.000000 2.000000 2.000000 
feet
Facade-Photo_2 Full_Face_Texture Facade-Photo_2 1.000000 1.000000 2.000000 2.000000 
feet
Facade-Photo_3 Full_Face_Texture Facade-Photo_3 1.000000 1.000000 2.000000 2.000000 
feet
Facade_Texture-Brick Tiled_Texture Facade_Texture-Brick 1.000000 1.000000 25.000000 
25.000000 feet
Facade_Texture-Limestone Tiled_Texture Facade_Texture-Limestone 1.000000 1.000000 
30.000000 30.000000 feet
Fence-Chain-Link Tiled_Texture Fence-Chain-Link 1.000000 1.000000 2.000000 2.000000 
feet
Fence-Wood-V-Dark Tiled_Texture Fence-Wood-V-Dark 1.000000 1.000000 2.000000 2.000000 
feet
Fence-Wood-V-New Tiled_Texture Fence-Wood-V-New 1.000000 1.000000 2.000000 2.000000 
feet
Fence-Wood-V-Weathered Tiled_Texture Fence-Wood-V-Weathered 1.000000 1.000000 2.000000 
2.000000 feet
Floor-Hardwood Tiled_Texture Floor-Hardwood 1.000000 1.000000 2.250000 2.250000 feet
Floor-Metal_Tread Tiled_Texture Floor-Metal_Tread 15.020000 1.000000 2.000000 2.000000 
feet
Floor-Parquet Tiled_Texture Floor-Parquet 5.019000 1.000000 2.000000 2.000000 feet
Floor-Tile-Checked Tiled_Texture Floor-Tile-Checked 5.019000 1.000000 2.000000 
2.000000 feet
Floor-Tile-Marble_Inlaid Tiled_Texture Floor-Tile-Marble_Inlaid 5.019000 1.000000 
2.000000 2.000000 feet
Glass-Clear Properties 100.050003 0.200000 0.900000 0.980000 1.000000
Glass-Frosted Properties 100.058998 0.600000 0.980000 0.990000 1.000000
Glass-Tinted_Bronze Properties 100.058998 0.600000 0.300000 0.250000 0.200000
Lands-Dirt Tiled_Texture Lands-Dirt 1.000000 1.000000 2.000000 2.000000 feet
Lands-Flowers-Large_Yellow Tiled_Texture Lands-Flowers-Large_Yellow 1.000000 1.000000 
2.000000 2.000000 feet
Lands-Flowers-Pink Tiled_Texture Lands-Flowers-Pink 1.000000 1.000000 2.000000 
2.000000 feet
Lands-Flowers-Small_Purple Tiled_Texture Lands-Flowers-Small_Purple 1.000000 1.000000 
2.000000 2.000000 feet
Lands-Flowers-Small_Yellow Tiled_Texture Lands-Flowers-Small_Yellow 1.000000 1.000000 
1.000000 1.000000 feet
Lands-Foliage Tiled_Texture Lands-Foliage 1.000000 1.000000 2.000000 2.000000 feet
Lands-Grass_Lawn Tiled_Texture Lands-Grass_Lawn 1.000000 1.000000 2.000000 2.000000 
feet
Lands-Gravel-Small Tiled_Texture Lands-Gravel-Small 1.000000 1.000000 2.000000 
2.000000 feet
Lands-Hedge Tiled_Texture Lands-Hedge 5.010000 1.000000 2.000000 2.000000 feet
Lands-Leaves-Berry Tiled_Texture Lands-Leaves-Berry 1.000000 1.000000 2.000000 



2.000000 feet
Lands-Leaves-Ivy Tiled_Texture Lands-Leaves-Ivy 2.019000 1.000000 2.000000 2.000000 
feet
Lands-Leaves-Long Tiled_Texture Lands-Leaves-Long 2.019000 1.000000 2.000000 2.000000 
feet
Lands-Needles_1 Tiled_Texture Lands-Needles_1 2.009000 1.000000 1.000000 1.000000 feet
Lands-Needles_2 Tiled_Texture Lands-Needles_2 2.009000 1.000000 2.000000 2.000000 feet
Lands-Sand Tiled_Texture Lands-Sand 1.000000 1.000000 3.000000 3.000000 feet
Lands-Shrub Tiled_Texture Lands-Shrub 5.010000 1.000000 2.000000 2.000000 feet
Lands-Tree-Elev Full_Face_Texture Lands-Tree-Elev 1.000000 1.000000 2.000000 2.000000 
feet
Lands-Water-Pool Tiled_Texture Lands-Water-Pool 60.028999 0.500000 2.000000 2.000000 
feet
Leather-Black Tiled_Texture Leather-Black 4.019000 1.000000 2.000000 2.000000 feet
Leather-Brown Tiled_Texture Leather-Brown 4.019000 1.000000 2.000000 2.000000 feet
Leather-Gray Tiled_Texture Leather-Gray 4.019000 1.000000 2.000000 2.000000 feet
Leather-Green Tiled_Texture Leather-Green 4.019000 1.000000 2.000000 2.000000 feet
Metal-Alum-Bronze Properties 30.049000 1.000000 0.230000 0.230000 0.230000
Metal-Alum-Clear Properties 30.049000 1.000000 0.937000 0.968000 0.968000
Metal-Brass Properties 50.049000 1.000000 0.990000 0.894000 0.016000
Metal-Chrome Properties 100.050003 1.000000 0.905000 0.968000 0.992000
Metal-Copper-Bright Properties 30.049000 1.000000 0.776000 0.419000 0.259000
Metal-Copper-Patina Properties 4.010000 1.000000 0.388000 0.517000 0.419000
Metal-Steel Properties 5.019000 1.000000 0.808000 0.808000 0.776000
Paint-Flat-Antique_White Properties 1.009000 1.000000 1.000000 0.980000 0.800000
Paint-Flat-Blue Properties 1.009000 1.000000 0.168600 0.376500 0.964700
Paint-Flat-Green Properties 1.009000 1.000000 0.133300 0.690000 0.200000
Paint-Flat-Red Properties 1.009000 1.000000 1.000000 0.000000 0.000000
Paint-Flat-White Properties 1.009000 1.000000 1.000000 1.000000 1.000000
Paint-Flat-Yellow Properties 1.009000 1.000000 1.000000 0.964700 0.000000
Paint-Gloss-Antique_White Properties 10.029000 1.000000 1.000000 0.980000 0.800000
Paint-Gloss-Blue Properties 10.029000 1.000000 0.168600 0.376500 0.964700
Paint-Gloss-Green Properties 10.029000 1.000000 0.133300 0.690200 0.200000
Paint-Gloss-Red Properties 10.029000 1.000000 1.000000 0.000000 0.000000
Paint-Gloss-White Properties 10.069000 1.000000 1.000000 1.000000 1.000000
Paint-Gloss-Yellow Properties 10.050000 1.000000 1.000000 0.964700 0.000000
Paint-Semi_Gloss-Antique_White Properties 5.019000 1.000000 1.000000 0.980000 0.800000
Paint-Semi_Gloss-Blue Properties 5.019000 1.000000 0.168600 0.376500 0.964700
Paint-Semi_Gloss-Green Properties 5.019000 1.000000 0.133300 0.690200 0.200000
Paint-Semi_Gloss-Red Properties 5.019000 1.000000 1.000000 0.000000 0.000000
Paint-Semi_Gloss-White Properties 5.039000 1.000000 1.000000 1.000000 1.000000
Paint-Semi_Gloss-Yellow Properties 5.030000 1.000000 1.000000 0.964700 0.000000
Paneling-Pine-Vert Tiled_Texture Paneling-Pine-Vert 1.000000 1.000000 1.666666 
1.666666 feet
Paneling-Red-Vert Tiled_Texture Paneling-Red-Vert 1.000000 1.000000 1.666666 1.666666 
feet
Paper-Craft Tiled_Texture Paper-Craft 1.000000 1.000000 1.000000 1.000000 feet
Paper-Shoji Tiled_Texture Paper-Shoji 2.005000 0.950000 2.000000 2.000000 feet
Pavers-Brick-Herring-Red Tiled_Texture Pavers-Brick-Herring-Red 1.000000 1.000000 
2.666666 2.666666 feet
Pavers-Oct-Lg-Gray Tiled_Texture Pavers-Oct-Lg-Gray 1.000000 1.000000 2.000000 
2.000000 feet
Pavers-Oct-Sm-Gray Tiled_Texture Pavers-Oct-Sm-Gray 1.000000 1.000000 2.000000 
2.000000 feet
Pavers-Rect-Gray Tiled_Texture Pavers-Rect-Gray 1.000000 1.000000 2.000000 2.000000 
feet
Pavers-Oct_Sq-Lg-Red Tiled_Texture Pavers-Oct_Sq-Lg-Red 1.000000 1.000000 2.666666 
2.666666 feet
Pavers-Oct_Sq-Sm-Red Tiled_Texture Pavers-Oct_Sq-Sm-Red 1.000000 1.000000 2.666666 
2.666666 feet
Paving-Asphalt Tiled_Texture Paving-Asphalt 1.000000 1.000000 2.000000 2.000000 feet
Paving-Brick-Brown Tiled_Texture Paving-Brick-Brown 1.000000 1.000000 1.333333 
1.333333 feet



Paving-Brick-Red Tiled_Texture Paving-Brick-Red 1.000000 1.000000 2.666666 2.666666 
feet
Paving-Sidewalk-Conc Tiled_Texture Paving-Sidewalk-Conc 1.000000 1.000000 4.000000 
4.000000 feet
Picture_1 Full_Face_Texture Picture_1 1.000000 1.000000 2.000000 2.000000 feet
Picture_2 Full_Face_Texture Picture_2 1.000000 1.000000 2.000000 2.000000 feet
Picture_3 Full_Face_Texture Picture_3 1.000000 1.000000 2.000000 2.000000 feet
Porcelain-White Properties 90.088997 1.000000 1.000000 1.000000 1.000000
Roof-Metal-Corrug Tiled_Texture Roof-Metal-Corrug 15.020000 1.000000 2.000000 2.000000 
feet
Roof-Metal-Deck Tiled_Texture Roof-Metal-Deck 15.020000 1.000000 2.000000 2.000000 
feet
Roof-Metal_SS-Gray Tiled_Texture Roof-Metal_SS-Gray 15.020000 1.000000 2.000000 
2.000000 feet
Roof-Metal_SS-Green Tiled_Texture Roof-Metal_SS-Green 10.029000 1.000000 2.000000 
2.000000 feet
Shingles-Asphalt-Gray Tiled_Texture Shingles-Asphalt-Gray 1.000000 1.000000 2.000000 
2.000000 feet
Shingles-Asphalt-Green Tiled_Texture Shingles-Asphalt-Green 1.000000 1.000000 2.000000 
2.000000 feet
Shingles-Slate Tiled_Texture Shingles-Slate 1.000000 1.000000 2.000000 2.000000 feet
Shingles-Wood-Sawn-Red Tiled_Texture Shingles-Wood-Sawn-Red 1.000000 1.000000 2.000000 
2.000000 feet
Shingles-Wood-Sawn-Tan Tiled_Texture Shingles-Wood-Sawn-Tan 1.000000 1.000000 2.000000 
2.000000 feet
Shingles-Wood-Silver Tiled_Texture Shingles-Wood-Silver 1.000000 1.000000 2.000000 
2.000000 feet
Shingles-Wood-Split Tiled_Texture Shingles-Wood-Split 1.000000 1.000000 2.000000 
2.000000 feet
Siding-Clapboard-Blue Tiled_Texture Siding-Clapboard-Blue 5.010000 1.000000 2.000000 
2.000000 feet
Siding-Clapboard-Gray Tiled_Texture Siding-Clapboard-Gray 5.010000 1.000000 2.000000 
2.000000 feet
Siding-Clapboard-Green Tiled_Texture Siding-Clapboard-Green 5.010000 1.000000 2.000000 
2.000000 feet
Siding-Wood-H Tiled_Texture Siding-Wood-H 1.000000 1.000000 2.000000 2.000000 feet
Siding-Wood-V Tiled_Texture Siding-Wood-V 1.000000 1.000000 2.000000 2.000000 feet
Stone-Slate Tiled_Texture Stone-Slate 1.000000 1.000000 2.000000 2.000000 feet
Stone_Ven-Marble-Botticino Tiled_Texture Stone_Ven-Marble-Botticino 10.029000 1.000000 
2.000000 2.000000 feet
Stone_Ven-Marble-White Tiled_Texture Stone_Ven-Marble-White 10.029000 1.000000 
2.000000 2.000000 feet
Stone_Wall-Ashlar Tiled_Texture Stone_Wall-Ashlar 1.000000 1.000000 3.000000 3.000000 
feet
Stone_Wall-Even Tiled_Texture Stone_Wall-Even 1.000000 1.000000 2.000000 2.000000 feet
Stone_Wall-Rough Tiled_Texture Stone_Wall-Rough 1.000000 1.000000 2.000000 2.000000 
feet
Stone_Wall-Rounded Tiled_Texture Stone_Wall-Rounded 1.000000 1.000000 2.000000 
2.000000 feet
Stucco-Flat-Blue Tiled_Texture Stucco-Flat-Blue 1.000000 1.000000 2.000000 2.000000 
feet
Stucco-Flat-Green Tiled_Texture Stucco-Flat-Green 1.000000 1.000000 2.000000 2.000000 
feet
Stucco-Flat-White Tiled_Texture Stucco-Flat-White 1.000000 1.000000 2.000000 2.000000 
feet
Stucco-Flat-Yellow Tiled_Texture Stucco-Flat-Yellow 1.000000 1.000000 2.000000 
2.000000 feet
Stucco-Troweled-White Tiled_Texture Stucco-Troweled-White 1.000000 1.000000 2.000000 
2.000000 feet
Tiles-Lg-Beige Tiled_Texture Tiles-Beige 1.004000 1.000000 3.000000 3.000000 feet
Tiles-Lg-Blue Tiled_Texture Tiles-Blue 15.020000 1.000000 2.000000 2.000000 feet
Tiles-Lg-Green Tiled_Texture Tiles-Green 15.020000 1.000000 2.000000 2.000000 feet
Tiles-Lg-Red_Clay Tiled_Texture Tiles-Red_Clay 1.000000 1.000000 3.000000 3.000000 



feet
Tiles-Sm-Beige Tiled_Texture Tiles-Beige 15.020000 1.000000 1.500000 1.500000 feet
Tiles-Sm-Blue Tiled_Texture Tiles-Blue 5.010000 1.000000 0.750000 0.750000 feet
Tiles-Sm-Checked Tiled_Texture Tiles-Checked_Small 15.020000 1.000000 2.000000 
2.000000 feet
Tiles-Sm-Green Tiled_Texture Tiles-Green 15.020000 1.000000 0.750000 0.750000 feet
Tiles-Sm-Red_Clay Tiled_Texture Tiles-Red_Clay 1.000000 1.000000 1.000000 1.000000 
feet
Window-Dbl_Hung Full_Face_Texture Window-Dbl_Hung 1.000000 1.000000 2.000000 2.000000 
feet
Wood-Dark-Rough Tiled_Texture Wood-Dark-Rough 1.000000 1.000000 0.500000 0.500000 feet
Wood-Dark-Smooth Tiled_Texture Wood-Dark-Smooth 5.014000 1.000000 0.500000 0.500000 
feet
Wood-Light-Rough Tiled_Texture Wood-Light-Rough 1.000000 1.000000 0.500000 0.500000 
feet
Wood-Light-Smooth Tiled_Texture Wood-Light-Smooth 5.010000 1.000000 0.500000 0.500000 
feet
Light-Point Point_Light 3.000000 1.000000 1.000000 1.000000 
kQ3AttenuationTypeInverseDistance
Light-Firelight Point_Light 1.500000 1.000000 1.000000 0.500000 
kQ3AttenuationTypeInverseDistance
Light-Spot_M_Soft Spot_Light 1.000000 1.000000 1.000000 1.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeCosine 0.000000 25.000000
Light-Spot_N_Hard Spot_Light 1.000000 1.000000 1.000000 1.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeNone 0.000000 10.000000
Light-Spot_N_Medium Spot_Light 1.000000 1.000000 1.000000 1.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeCosine 7.500000 15.000000
Light-Spot_N_Soft Spot_Light 1.000000 1.000000 1.000000 1.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeLinear 10.000000 20.000000
Light-Spot_N_Soft_Blue Spot_Light 1.000000 0.000000 0.000000 1.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeLinear 10.000000 20.000000
Light-Spot_N_Soft_Green Spot_Light 1.000000 0.000000 1.000000 0.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeLinear 10.000000 20.000000
Light-Spot_N_Soft_Red Spot_Light 1.000000 1.000000 0.000000 0.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeLinear 10.000000 20.000000
Light-Spot_W_Soft Spot_Light 1.000000 1.000000 1.000000 1.000000 
kQ3AttenuationTypeNone kQ3FallOffTypeCosine 0.000000 35.000000 
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5.2 - Making your own Tiled_Texture 

 Artifice, Inc.
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Ten Steps to Making Your Own Tiled_Texture

Guide Foyer | Guide Topics | Guide Index | Techniques

These instructions are for Adobe Photoshop, the process will be similar in other painting programs. 

Step 1: 
Scan the image or save the photos from a digital camera or ascertain a digital image of the source for the texture you 
want to work with in some way. 

Step 2: 
Select an approximately square portion of the image at least a couple hundred pixels square that includes what you 
want to texture and as little else as possible. 

Step 3: 
Straighten the image if it is twisted (using Image > Rotate...). Use the Image > Effects options of Skew, Perspective, 
and Distort to make the image as close to an orthogonal view (plan or elevation) as possible. 

Step 4: 
Crop the image so it is square in shape and includes only the part of the image you want to create a texture from. By 
default the size of the texture will render as two feet square in DesignWorkshop, you will need to edit the DW 
Material Prefs file if you want your texture to tile at a different size. 

Step 5: 
Change the image size to 256 pixels by 256 pixels (you may need to turn off Proportion constraints). Copy the image 
and paste it in Desktop Patterns to see how well it tiles before proceeding. If it is acceptable you can go to step 9 
now. 

Step 6: 
Select "Filter > Other > Offset..." Set the offset to about 75 (pixels) in both dimensions and make sure "Undefined 
Areas" are set to "Wrap Around". You now have an image that will tile perfectly at the edges and you can clearly see 
where the seams are and work with them easily (be careful not to edit the edges of the image as this will mess up the 
tiling). 

Step 7: 
To eliminate the seams try using the rubber stamp tool to copy the image from a good portion of the image to cover 
over the seams (this works well with fairly random textures such as stucco or carpet). Also try using the lasso select 
tool to copy portions of the image that is not on a seam to cover seams (this works well on images that have defined 
non-orthogonal forms, such as flowers or rocks), or the marquee tool and then copying parts of the image to cover 
seams (this works well on orthogonal textures such as bricks or shingles. 

Step 8: 
Use the above tools to cover noticeable anomalies in the image, because these will likely form an annoying pattern 
when the image tiles. 



Step 9: 
Copy the image and paste it in Desktop Patterns. If it looks OK save it as a PICT file and add it to the Textures 
folder. If not return to step 6 and continue making corrections. 

Step 10: 
After it looks good in Desktop Patterns and you saved the PICT to the Textures folder, try it in DW and if you don't 
like it return to step 6 to correct problems with the image itself and edit the DW Material Prefs file to correct how 
it renders in DesignWorkshop.

Some textures can be made without any source image at all. You can simply paint something in Photoshop which 
looks like what you want a texture of and follow the above steps where appropriate. Another neat trick in Photoshop is 
the Filter > Render > Clouds and Filter > Render > Cloud Difference filters as a starting point for your textures and 
then applying various other filters to achieve the look you want.
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5.3 - Making A Spotlight Shine Upwards 
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Making A Spotlight Shine Upwards
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DesignWorkshop 1.7 changes the way the illuminating face of a spotlight is determined, so the process is simpler and 
more powerful.

Now the illuminating face of an object with a spotlight material type is determined by the face with the most number of 
vertices. If there is more than one face with the most number of vertices the lowest of these faces is used. For a block 
every face has four vertices, so the lowest face of the block will be lit. For a cylinder the two endcaps have the most 
vertices, by default 16, and each face of the walls of the cylinder has only four vertices.

To make a spotlight shine upwards start with a cylinder. Use the circle tool to draw a circular polyline. With the arrow 
tool space-jump to a handle of the circle and while holding the Option key (the Alt key for Windows) drag the mouse 
upwards to extrude the circle into a cylinder.

If you asssign this object a spotlight material, move it above ground, and view Lights and Textures you should see the 
lower of the two endcaps lighting up.

Return to the standard DesignWorkshop window. Select the cylinder and then choose the trim tool from the tool 
pallete. You need to trim the cylinder so that the trim line passes through the lower endcap of the cylinder and comes 
out the side of the cylinder. Now delete the little corner you trimmed off.

The cylinder's lower end cap is now made up of two faces, each with about half as many vertices as the upper end 
cap. So now the light will come out of the upper end cap and shine upwards. You can rotate this cylinder in any 
direction you please and the light will always come out of the untrimmed endcap.
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5.4 - Why Lights Don't Always Shine 
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Why Lights Don't Always Shine
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QuickDraw 3D uses vertex interpolation to calculate the pool of light cast by a light source. Because of this if the pool 
of light does not reach the vertex of an object no light will shine on that object.

The above image shows a block, a light source and the cone of light created by the light source. No vertices of the 
block pass through this pool of light and so it appears as though the light isn't shining when rendered in QuickDraw 
3D.

Here the block has been cut into four smaller blocks and the pool of light passes through multiple vertices for each of 
these blocks. As a result the light is rendered as expected.

So if you encounter lights that don't seem to shine in QuickDraw 3D you need to trim the object the lights are shining 
on into a series of smaller objects.
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6 - Troubleshooting 
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Troubleshooting
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General Issues

General Issues | Modeling | Lights and Textures | Translation | Conflicts

System Requirements

DesignWorkshop for Power Macintosh requires a PowerPC processor, Mac OS 7.1.2 or higher, QuickDraw 3D, and a 
minimum of 16MB total RAM. 32MB of RAM is recommended.

DesignWorkshop for Windows requires a Pentium processor, Windows 95 or Windows NT 4.0 or higher, QuickDraw 
3D, and a minimum of 16MB total RAM. 32MB of RAM is recommended.

Memory Requirements

Probably the majority of Macintosh software problems stem from insufficient memory. Read this section, and see also 
Memory Usage (immediately below).

If your Macintosh has 32MB or less RAM, virtual memory should be turned on with a total memory setting of 33MB, 
using the Memory control panel. Note that the memory used by QuickDraw 3D (QD3D) is allocated from the free 
memory when requested by DesignWorkshop. In other words, application memory and rendering memory are 
separate in DesignWorkshop, and giving too large a memory allocation to the application can cause QD3D to run out 
of memory unneccesarily.

While DesignWorkshop is running, you can switch to the Finder, and use the Apple menu "About This 
Computer..." command to see a graph of current memory usage. In addition to observing the memory size and 
utilization for DesignWorkshop, note the System memory size, and the size of the largest free memory block.

Memory Usage

Running out of memory may cause unpredictable problems for either DesignWorkshop itself, or for the QuickDraw 3D 
graphics system. The memory needed by DesignWorkshop itself varies according to the size and complexity of the 
models being used, the number and size of open document windows, the style of rendering and monitor color depth, 
etc.



A rough but useful rule-of-thumb for predicting DesignWorkshop application memory usage, under general conditions, 
is to start with 10MB for the DesignWorkshop application itself, and then add 1MB of additional RAM allocation for 
each 100KB of model size. For instance, a 100KB model can be edited and viewed comfortably in an application 
memory partition of 11MB, and a 1MB model can be edited and viewed comfortably in an application memory 
partition of 20MB.

QuickDraw 3D seems to work best with at least 8-16 MB of free memory, and it will need more for larger windows, 
larger models, and when rendering many textures. The memory used by QuickDraw 3D is drawn from the free 
memory on the computer, not from the DesignWorkshop memory partition. When QuickDraw 3D claims additional 
memory, in Mac OS 7.x it will show up in the System memory partition, and in Mac OS 8.0, it will show up in the 
DesignWorkshop partition (using the Apple menu "About This Computer..." command from the Finder).

Correct QuickDraw 3D Versions

For DesignWorkshop, QuickDraw 3D 1.5.1 or higher is required. The QD3D 1.5.3 Installer from Apple is included on 
the DesignWorkshop CD-ROM.

For DesignWorkshop 1.5, we recommend using QuickDraw 3D 1.0.6. The QD3D 1.0.6 Installer from Apple is included 
on the DesignWorkshop 1.5 CD-ROM.

Printer Must Be Defined

DesignWorkshop checks the current printer when starting up and initializing its graphics environment. As a result, you 
may have trouble starting up DesignWorkshop if for any reason no printer has been defined with Chooser on your 
Macintosh. This can happen if the computer is new and no printer has been chosen yet. It can also happen after a 
system upgrade or printer driver upgrade, which might overwrite the previous choice and leave the current printer 
blank.

Modeling Issues

General Issues | Modeling | Lights and Textures | Translation | Conflicts

Your Model Looks Very Small and Far Away When Opened

If you open a DesignWorkshop model and discover that your model looks very small and far away, there is probably a 
straightforward explanation and a quick solution.

DesignWorkshop calculates the Initial View each time it opens a model, based on the actual overall dimensions of the 
model. The initial view is established so that it shows most of your model at once, and not too much else. Usually a 
small and far away model is caused by extra objects in the model file, far beyond what you expect to be the bounds 
of your model.

To eliminate these extra objects and normalize the Initial View, first go to Plan view and drag a rectangle in the middle 
of the view to select all the objects of the model that you want to keep. Put away these objects temporarily with the 
Arrange menu Hide command. Then use the Edit menu Select All command to select any and all outlying 
objects, and use the Delete key (the Backspace key for Windows) to delete these unwanted objects.

Next, use the Arrange menu Cancel Hide command to show the main model objects again. Finally, use the 
File menu Save As... command to save your model (with a new name, for safety!) and close the model. When 
you reopen the file, you should see the model framed nicely in the Initial View again.



Lights and Textures Rendering Issues

General Issues | Modeling | Lights and Textures | Translation | Conflicts

Transparency Doesn't Seem to be Rendering

For transparency effects to be visible with QuickDraw 3D, it is required to have either QuickDraw 3D hardware 
acceleration, or an appropriate plug-in rendering module.

The LightWorks SuperLite plug-in renderer, included with DesignWorkshop Professional, will render transparency 
effects nicely. In the Lights & Textures window, use the View menu Shadowcasting command to render with the 
SuperLite plug-in.

If the Shadowcasting command is grayed out when you are looking at a Lights & Textures window, this indicates 
that the plug-in renderer is not properly installed. Check the "DW Plug-ins" folder which is in the same directory as the 
DesignWorkshop application for the presence of the "LightWorks SuperLite" plug-in.

Some computers, such as the entire G3 line of Power Macintoshes, already include a QuickDraw 3D hardware 
acceleration chip on the motherboard.

With QuickDraw 3D hardware acceleration installed in your computer, either as a chip or an add-in board, you should 
be able to see transparency effects in the Lights & Textures window, using the View menu Shading command.

If you have QuickDraw 3D hardware acceleration installed and you can't see transparency effects with the simple 
"Shading" command, you should check carefully to make sure that the proper QuickDraw 3D extensions and any 
vendor-specific system extensions are installed, as required by the hardware accelerator.

Many non-Apple hardware accelerator add-in boards require that the monitor cable be connected directly to the 
board, rather than to the built-in video of your Macintosh.

If a hardware accelerator board is properly installed, and all its extensions are properly installed, and the monitor 
cable is in the right place, and you still can't see transparency effects in the Lights & Textures window, then most 
likely your system is running out VRAM, the special video memory often used both for the screen display and for 
texture acceleration.

To check whether a video memory shortage is preventing transparency effects from working, you can try rendering in 
a way that uses a minimum of VRAM: 1) Switch your monitor settings so you are viewing at 640x480 resolution, with 
thousands of colors. 2) Quit all applications except the Finder. 3) Start up DesignWorkshop with an Untitled empty 
model, and draw a single cube in the middle of the modeling world. Then assign the Glass-Clear material to the cube. 
3) Use the Lights & Textures command to open the cube into a QuickDraw 3D rendering window. 4) Make the Lights 
& Textures window very small, something like 2"x2" (6cm x 6cm). 5) Now, drag around with the Eye tool, and see if 
you can see the horizon line through the cube.

If you can see through the cube at step 5) above, but not when you view it in a larger window, then you are running 
out of VRAM. Depending on the CPU or accelerator board you are using, your VRAM may be expandable, usually at 
a modest cost.

Some Textures Don't Seem to be Rendering

The Apple QuickDraw 3D Accelerator board only supports rendering of 12 textures at one time. Additional texture 
map assignments will be ignored when rendering with hardware acceleration.

To render more than 12 textures at one time when the Apple board is installed, check the View menu Rendering > 
Graphics Engine > Apple Software menu item to turn off the hardware rendering engine. The textures will 
then be rendered by the QD3D Interactive Renderer in software.

Other hardware accelerator boards may show their memory limits in other ways. With ATI boards, for instance, when 



the on-board texture memory capacity is exceeded, the board keeps rendering, but the amount of acceleration drops 
very significantly.

See the section above for steps on rendering in QuickDraw 3D with a minimum of memory, which is useful for 
acceleration tesing purposes.

A Texture Renders Poorly or Causes Crashes

Texture PICT files added to the "Textures" folder must be saved without JPEG compression. They should have a 
resolution set to 72dpi. If the dots-per-inch is greater than 72 the textures may render poorly, with only part of the 
image displayed, and with a dark stripe along the bottom of each image tile. (The greater the dots-per-inch, the worse 
these effects will become.) If a texture PICT file is saved at less than 10dpi, it may crash DesignWorkshop when 
loading. You can easily check and modify the resolution for a PICT image file using Adobe Photoshop (with the Image 
Size functions in the Image menu in Photoshop).

Lights Don't Seem to be Rendering

See special note on the effects of rendering with vertex interpolation, Lights Don't Seem To Shine.

Shadows or Objects are Missing when Using the LightWorks Renderer

The LightWorks SuperLite plug-in renderer version 1.2, which was included on the DesignWorkshop 1.7 Release One 
CD-ROM, is unpredictable when rendering models with the trimesh geometry type introduced in QuickDraw 3D 1.5. If 
you find objects or shadows appear to be missing after rendering with the SuperLite plug-in in DW 1.7, we suggest 
you take advantage of the free upgrade to the latest DesignWorkshop CD-ROM which includes an updated version of 
the plug-in renderer. To order your upgrade contact Artifice Sales by email at sales@artifice.com or by telephone at 
(541) 345-7421.

Translucent Objects Don't let Light Through in LightWorks Renderings

For shadow-casting purposes (though not for direct viewing purposes) the LightWorks SuperLite renderer, used with 
the Lights & Textures Shadowcasting command, treats objects with translucent or transparent materials as though the 
object is opaque, so it casts solid shadows. For instance, indoor lights will not shine through a glazed window and 
light up the ground outside. Similarly, light will not shine through a translucent lamp shade, even though you see 
through it.

This can seem confusing, because the default Interactive Renderer (IR) used with the plain Shading command lets 
lights shine through freely. However, that is just because the IR doesn't do any shadowcasting at all. With the IR, 
lights shine through everything equally, whether opaque or transparent. In contrast, with the LightWorks Superlite, 
shadows are cast by everything, whether opaque or transparent.

Forthcoming, higher-level plug-in renderers by LightWork Design are expected to provide more sophisticated 
shadowcasting options.

To simulate the visual effect of both the shadows and the light transmission created by a translucent object, you can 
use double light sources. For instance, for a detailed LightWorks rendering of a floor-standing lamp with a translucent 
shade, you can put one point light source inside the lamp shade, and then hover another very tiny point light source 
in mid-air a couple of feet or more above the lamp.

Alpha-Channel Transparency Doesn't Work with LightWorks Renderings

The LightWorks SuperLite renderer does not support alpha-channel transparency in textures. This effect is also 
known as "transparent pixels" or "pixel transparency", to distinguish it from the effect of overall-transparency for 
textures, which is supported.

Pixel transparency is supported in the plain "Shading" command.



Translation Issues
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Problems Importing to DesignWorkshop

The most common source of difficulty when reading in large drawings via DXF or Object PICT format is insufficient 
memory to hold the drawing in DesignWorkshop. Even simple drawings will sometimes require much more memory 
when converted to 3D in DesignWorkshop. It is a good practice to simplify any 2D drawing before exporting so that 
only necessary objects will be loaded into the 3D modeling space.

However, with so many possible applications and configurations, it is inevitable that unusual translation problems will 
arise. Please don't hesitate to contact Artifice Technical Support for the latest information and assistance.

PowerCADD to DesignWorkshop

To convert PowerCADD 2D drawings seamlessly into DesignWorkshop 1.5, start in PowerCADD by simplifying the 
drawing for export. Then use the PowerCADD File menu Save As... command, selecting the 
"DesignWorkshop" file format in the pop-up menu of the save file dialog box. This produces a special customized 
PICT file with a DesignWorkshop-style icon. (If DesignWorkshop does not appear in the pop-up menu, then the 
DesignWorkshop XTNL translator module is probably not properly installed in the PowerCADD XTNLs folder.)

To read the custom PICT drawing into DesignWorkshop, first open a model in DesignWorkshop, then use the File 
menu Import > Object PICT command. The rest is automatic, and the drawing should appear with its upper left 
corner aligned to the 0/0/0 point in the DesignWorkshop model space.

DesignWorkshop to PowerCADD

Any DesignWorkshop screen image can be exported as a general-purpose PICT file, and then opened in 
PowerCADD. However, only views with uniform scaling, including plan, section, elevation, and axonometric, can be 
translated using the special PowerCADD Scaled PICT command. If you are not in one of these particular views, the 
command will be disabled.

To convert a drawing from DesignWorkshop to PowerCADD from an appropriate view, use the File menu Export 
2D > PowerCADD Scaled PICT command to create the drawing file. This produces a special customized PICT 
file with a DesignWorkshop-style icon.

To read the custom PICT drawing into PowerCADD, use the File menu Open command, selecting the 
"DesignWorkshop" file format in the pop-up menu of the save file dialog box. (If DesignWorkshop does not appear in 
the pop-up menu, then the DesignWorkshop XTNL translator module is probably not properly installed in the 
PowerCADD XTNLs folder.)

The drawing should appear in a new PowerCADD document window, scaled to 1/8" = 1' - 0". You can adjust the 
drawing to another scale if necessary using the various editing and drawing setup functions of PowerCADD.

MiniCAD to DesignWorkshop

This process involves three steps: (1) prepare a drawing or model in MiniCAD 6.0.3; (2) export the drawing in DXF 
format; (3) import it into DesignWorkshop. The process will be similar for other CAD programs which support the DXF 
file format.

1) Simplify the drawing in MiniCAD.



There are probably some objects in the drawing that should not be translated to DesignWorkshop, because they are 
unnecessary and may greatly increase the memory needed. Working on a copy of the drawing in MiniCAD, you 
should delete graphic objects like dimension lines, dotted lines, and plotter-type hatching which are not directly part of 
the project you are modeling. Dashed lines and hatching are particularly hard to import from some applications 
because each line fragment may be imported as a separate graphic object. This devours memory quickly in 
DesignWorkshop.

2) Once the non-essential objects have been edited out of the original MiniCAD drawing, then export the drawing.

Give the File menu Export -> Export DXF command. In the dialog box this brings up, set the pop-up menu so 
the top line says "Export as DXF Layers". If your MiniCAD file is just a 2D drawing in MiniCAD, set the radio button to 
"Export 2D Objects Only". If the drawing includes 3D objects, set the radio button to "Export 2D and 3D Objects", and 
also check "Decompose 3D Symbols into 3D Polys". Click the "Export" button, which will close that dialog box and 
bring up a standard Macintosh 'Save File' dialog box. Save the DXF file wherever you want it. For DesignWorkshop, 
there are no limitations on DXF file names, but there are restrictions in some other applications, so it's good practice 
to have DXF file names end in ".DXF".

3) Import the file into DesignWorkshop.

After exporting the file, quit MiniCAD to free up as much RAM memory as possible for DesignWorkshop. Check the 
memory setting for DesignWorkshop by selecting the application icon in the Finder then and in the Finder giving the 
File menu Get Info command. The Minimum and Preferred memory settings for DesignWorkshop should be 
kept the same to avoid any confusion on how much memory DW is actually getting. The more RAM you allocate to 
DesignWorkshop, the fewer import problems you'll encounter. Close the "Get Info" window in the Finder.

Start up DesignWorkshop, with an empty new model. Use the File menu Import -> DXF Drawing Or 
Model... command. In the "Open File" dialog box that comes up, select the DXF file you just exported from 
MiniCAD, and then click the "Open" button. DesignWorkshop will read the file and import all the objects into the 
current DesignWorkshop model. Note that in DesignWorkshop, you don't get any feedback until this process has 
finished.

Save the DesignWorkshop model with the imported objects. If you can't see any objects, it is possible that they are 
present, but outside the current view. To check on this possibility, close the saved file, and then re-open it. (Whenever 
you open a file in DesignWorkshop, the initial view is calculated to show all the objects.)

If you close the model, it is a good idea to check the size of the DesignWorkshop file in the Finder, and make sure 
that DesignWorkshop has been allocated enough memory to work with it. Use the allocation rule-of-thumb of 10MB of 
RAM for the DW application itself, plus another 1MB of RAM for every 100K of model size.

(Remember also that for QuickDraw 3D rendering in the Lights & Textures window, the Macintosh needs to also 
several MB or more of free memory outside of DesignWorkshop for the System.)

When you have confirmed that the objects are present, you can go to work on the DesignWorkshop model like any 
other file.

DesignWorkshop to MiniCAD

The process for exporting a DXF from DesignWorkshop for use in MiniCAD is considerably simpler than exporting 
from MiniCAD.

1) The first step is to decide whether you want to export a 3D DXF model, or a 2D DXF drawing.

If you are exporting a DXF drawing from elevation or axonometric view the exported drawing will be based on the 
current view. If you are exporting a DXF drawing from plan or perspective the exported drawing will be a plan. If you 
are exporting a DXF model the current view is irrelevant because all objects will be exported as three dimensional 
objects.

2) When you export a DXF from DesignWorkshop all the currently visible objects will be exported, so you should turn 
off phases or hide objects that you don't want exported.



3) From the File menu Choose Export 2D -> DXF Drawing or Export 3D -> DXF Model depending on 
what sort of DXF you want to export. Choose a name for the file. Some applications will require that DXF files end in 
.dxf and that is probably good practice anyway just so you can easily keep track of files.

4) Before importing the file to MiniCAD you have to set the scale of your MiniCAD drawing. To do this go to Page -> 
Scale and choose the drawing scale at which you want to work.

5) With your MiniCAD drawing open choose File -> Import -> Import DXF. Choose your file in the dialog 
box. Choose the options you want for the DXF import.

6) You should now have your DesignWorkshop model successfully converted to DXF and imported to MiniCAD. You 
can work on it as you would any MiniCAD drawing.

Problems with DXF Export to Other Applications

The DesignWorkshop DXF Export functions have been updated in DesignWorkshop for maximum compatibility with 
the widest range of other 2D and 3D applications. Few problems should be experienced in normal usage.

The most common source of difficulty with taking models from DesignWorkshop to another 3D application via the 
DXF format is that some receiving applications cannot handle all the complex polygons produced from translating the 
solid objects with openings used in DesignWorkshop.

Please don't hesitate to contact Artifice Technical Support for the latest information and assistance with any 
translation problems.

Software Conflicts

General Issues | Modeling | Lights and Textures | Translation | Conflicts

Known Incompatibilities

7200 Graphics Acceleration 

At 2D zooms over 11,000% DesignWorkshop is prone to crash if the "7200 Graphics Acceleration" system extension 
is active . To avoid this problem, disable the 7200 Graphics Acceleration extension by removing it from the Extensions 
folder in your System folder, and then restarting the computer.
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North America and Worldwide

Sales & General Information 
E-mail: sales@artifice.com
Voice: 800-203-8324
Fax: 541-345-7438 

Technical Support 
E-mail: support@artifice.com
Voice: 541-345-7421
Fax: 541-345-7438 

General Information 
E-mail: artifice@artifice.com
Voice: 541-345-7421
Fax: 541-345-7438 

Mailing Address 
Artifice, Inc.
P.O. Box 1588
Eugene, OR 97440 

Shipping Address 
Artifice, Inc.
1342 High Street
Eugene, OR 97401

Japan

Sales & General Information 
E-mail: sales@artifice.com
Voice: 800-203-8324
Fax: 541-345-7438 



Technical Support 
E-mail: support@artifice.com
Voice: 541-345-7421
Fax: 541-345-7438 

General Information 
E-mail: artifice@artifice.com
Voice: 541-345-7421
Fax: 541-345-7438 

Mailing Address 
Artifice, Inc.
P.O. Box 1588
Eugene, OR 97440 

Shipping Address 
Artifice, Inc.
1342 High Street
Eugene, OR 97401

Other Countries

Sales & General Information 
E-mail: sales@artifice.com
Voice: 800-203-8324
Fax: 541-345-7438 

Technical Support 
E-mail: support@artifice.com
Voice: 541-345-7421
Fax: 541-345-7438 

General Information 
E-mail: artifice@artifice.com
Voice: 541-345-7421
Fax: 541-345-7438 

Mailing Address 
Artifice, Inc.
P.O. Box 1588
Eugene, OR 97440 

Shipping Address 
Artifice, Inc.
1342 High Street
Eugene, OR 97401
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DesignWorkshop Tutorials

Introductory

        Start Here - Key Concepts

DesignWorkshop is a fast, fun, and easy program to learn. Because of its unique live 3D modeling interface, it makes 
a big difference if you take a few minutes to read about a few key concepts before you start up the software.

When learning DesignWorkshop, the most important things to understand are 1) how to use the Eye tool and the 
Look tool for live 3D viewing, 2) how to move 3D crosshair around, and how to align it easily and accurately, and 3) 
how to know exactly where objects are located in the 3D modeling space, so you can create and adjust your model 
accurately.

After spending a few minutes on these basic concepts, you'll be all ready to create your first project - a complete 
simple house.

        First Tutorial - Building a Classic House

This highly-recommended 12 part step-by-step tutorial will introduce you to modeling with DesignWorkshop, starting 
with a quick overview of key concepts, and then taking you through core functions including creating and reshaping 
objects, duplicating, changing object colors, the Wallify command, and making openings. Along the way you will 
construct your own model of a classic house.

Intermediate

        Building a Contoured Site Model

This tutorial takes you step by step through the process of making a site model based on a contour drawing.

        Constructing a Spatial Dormer

This tutorial takes you step by step through the process of adding a classic gable dormer to a typical residential 



pitched roof. Shows the power of the trim tool and fit to object feature.

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index

© 1998 Artifice, Inc. - All Rights Reserved. 





4.3 - DW Tutorial -- Site Modeling 

 Artifice, Inc.
DesignWorkshop Tutorials

Intermediate Tutorial - Building a Contoured Site Model

        Intermediate Level 

This tutorial takes you step by step through the process of making a contour-pancake type site model based on a 
contour drawing.

This type of site model is especially useful for architectural design purposes, because it provides a very clear 
indication of the ground elevations in any view of a model. Mesh-type site models tend to look more realistic in 
presentation renderings, but often make it hard to 'read' the ground while designing.

         1 - Tracing the Contours

         2 - Extruding the Contours

Contents | Next Section
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Building A Classic House

        Introductory Level 

For an easy way to quickly learn a useful cross-section of DesignWorkshop modeling techniques, work through the 
following tutorial sections. If you're an experienced Macintosh user, expect each section to take about 30 minutes.

This tutorial will introduce you to the basics of DesignWorkshop, starting with making a simple block, and then take 
you through the core functions including reshaping objects, duplicating, changing object colors, using the Wallify 
command, and making openings. Along the way you will construct your own model of a classic house.

In the first half of the tutorial, you'll build and render the massing model of a classic house with a front porch.

         1 - Conceptual Overview

         2 - Basic Massing

         3 - Front Porch

         4 - Porch Steps

         5 - Colors and Shadowcasting

In the second half of the tutorial you'll transform the massing model into a more realistic spatial building model with 
walls and door and windows openings. These parts move a bit more quickly than the previous sections, as they 
assume that you are already familiar with the techniques and terminology covered in the first half of the tutorial.

         6 - The "Wallify" Command

         7 - Adding Openings

         8 - Moving Through the Model

         9 - Viewing and Rendering

         10 - Details - Railings

         11 - Details - Window Frames

         12 - Details - Chimney

When you've worked through these steps, you'll be ready to take on your own design and modeling projects. Happy 
modeling! 

Contents | Next Section
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Software Credits:

The basic DesignWorkshop interface was conceived in 1987-88 by Kevin Matthews, and the interface design has 
been developed through private research during the intervening years.

User Interface Design:
Kevin Matthews

System Architecture:
Gerd Kortuem, Kevin Matthews, Rob Zako

Lead Software Engineers:
Thomas Birkett, Chet Hasse, Patrick Hoonhout, Gerd Kortuem, John Selhorst, Rob Zako

Testing and Support:
Larry Martin, Michael Wheeler, Rebecca Ossa, CJ Shumate

User Guide Credits

Original DesignWorkshop User Guide --
Donna Matthews, Kevin Matthews, Damon Johnstun

Online User Guide --
Kevin Matthews, Michael Wheeler

CD-ROM Production

Kevin Matthews, CJ Shumate, Michael Wheeler

CD-ROM Textures Samplers

Some of the textures included with DesignWorkshop¨ were provided by Artbeats Software, Inc. Artbeats is a company 
dedicated to developing high quality backgrounds and textures. Artbeats offers libraries of images for publishing, 
slides, video, multimedia, texture mapping and broadcast video. For more information on Artbeats products please 
contact --

Artbeats Software, Inc.
Box 709



Myrtle Creek, OR 97457
800-444-9392, 541-863-4429 voice
541-863-4547 fax
facts@artbeats.com e-mail
www.artbeats.com
ArtBeats Textures are ©1996 Artbeats Software, Inc.

Sample Textures were also provided by TOTO Computer Graphics, Inc. For more information on TOTO products 
please contact --

TOTO Computer Graphics, Inc.
4065A N. Calhoun Road, Suite 101
Brookfield, WI 53005
414-783-2400 voice

Apple, Macintosh, and Power Macintosh are registered trade,marks, and QuickDraw is a trademark of Apple 
Computer, Inc.

Photoshop is a trademark of Adobe Systems, Inc.

PowerCADD is a trademark of Engineered Software, Inc.

DesignWorkshop and Artifice are registered trademarks, and the DesignWorkshop logo, "Space Jump" and "the 
virtual building toolkit" are trademarks of Artifice, Inc.

Artifice Foyer | Artifice Index | Guide Foyer | Guide Topics | Guide Index

© 1998 Artifice, Inc. - All Rights Reserved. 





4.4 - DW Tutorial -- Dormers 

 Artifice, Inc.
DesignWorkshop Tutorials

Constructing a Spatial Dormer

        Intermediate Level 

This tutorial shows specifically how to add a classic gable dormer to a pitched roof.

More generally, it also provides an example of what how to apply the Trim tool and the Fit to Object command. 

         1 - Dormer Exterior

         2 - Dormer Finishing

Contents | Next Section
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Start Here - Key Concepts for DesignWorkshop

Contents

We at Artifice believe DesignWorkshop crosses a threshold of ease and power of use to make real three-dimensional 
architectural design in a digital environment practical for the first time.

DesignWorkshop has a simple, clear, classic-Macintosh interface to provide you with tremendous modeling flexibility, 
using just a few commands.

This design-oriented environment will let you get to work with a minimum of training time. However, 3D modeling is 
still at the top of the computer-graphics pyramid, and you'll probably need to spend a few hours and focus your 
energy to learn the key methods of DesignWorkshop. At first, DesignWorkshop will probably seem both familiar and 
alien, because, while it draws heavily from its ancestors, there's never been a 3D program quite like this before.

We like to break down the process of learning DesignWorkshop into four levels (severely abbreviated here), each one 
providing a foundation for the next. 

Viewing 

To get started, copy the application and sample file to your hard disk, and open the sample file with the 
DesignWorkshop application. Try out the direct-manipulation 3D viewing tools -- Eye and Look. Dragging in the scene 
with the Eye tool moves the viewpoint around the scene. To move into or out from the scene hold down the Option 
key (the Alt key for Windows) while dragging up or down. Also try out the 2D zooming and scrolling functions. Use the 
Window menu to open another window onto the model, and use the View menu functions to try out a variety of 
viewing and shading options in either window. 

Basic Blocks, Openings, and Manipulations 

The crucial methods of creating and manipulating blocks and openings are covered in detail in the next section of the 
manual. It is recommended that you take about an hour to carefully work through the introductory tutorial, and then 
come back to this summary learning outline. Once you have worked through the first structured tutorial, you'll be 
ready to start building objects on your own.

Picking up again at the end of the introductory tutorial, this learning guide will walk you through similar operations 
over again, but only in outline, so you can fill in the details as you go, modeling something simple but of interest to 
you.

Quit DesignWorkshop and start it up again by double-clicking on the application icon. This will give you a default new 
session with a new file open. Start out again by drawing a simple block. First click on the Block tool, then drag out the 
plan rectangle of the block in the scene with the 3D crosshair, and, without letting up on the mouse button, option-
drag (depress the Option key (the Alt key for Windows) and drag) upward to pull up the height or "z" dimension of the 
block, finally letting go when you see what you want. Notice that the 3D crosshair stays at whatever height you leave 
it. To get the crosshair instantly back to the ground plane, type the number "0" on the keyboard. Between blocks you 
can also move the 3D crosshair to any height by option-dragging the mouse with the mouse button released.



To turn a massing block into a set of walls enclosing space, select it and give the Edit menu Wallify command. To put 
an opening in one of those walls, first click on it to select it, then click on the Opening tool icon in the tool palette. 
Position the cursor over the selected wall block, and you'll see it become a 2D crosshair in the face of the block.

 

2D crosshair in block face

Press the mouse button where you want to start, and drag out the opening. Do this in a wireframe view, and then 
again in a shaded view, where the operation can be rather slow but visually effective. After you've drawn an opening, 
select it by clicking in it, and drag by one of its selection handles to resize it, or drag from the middle to move the 
opening around in the wall.

Experiment with drawing 2D objects on the ground plane, and then making them three-dimensional by extruding 
them. First draw a shape with the Polyline tool, clicking at each point along the line string, and double-clicking to end 
it as an open polyline. DesignWorkshop will automatically supply a missing segment if necessary to form a solid when 
extruding.

 

option-dragging with the 3D crosshair
to extrude a polyline into a solid.

To actually extrude the shape into a 3D solid, grab one of the handles of the polyline's bounding rectangle, and pull 
up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is 
actually aligned three-dimensionally with the handle you want to drag, or else you will move the polyline rather than 
give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional 
alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when 
grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D 



crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the 
Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over 
an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice 
how the 3D crosshair jumps over to the handle location.

To actually extrude the shape into a 3D solid, grab one of the handles of the polyline's bounding rectangle, and pull 
up on it by option-dragging. There is no special command needed for extruding. Be sure that the 3D crosshair is 
actually aligned three-dimensionally with the handle you want to drag, or else you will move the polyline rather than 
give it thickness.

A simple but very important interface feature in DesignWorkshop simplifies getting exact three-dimensional 
alignments. We call it Space-Jump, and you'll want to use it almost constantly to avoid subtle alignment errors when 
grabbing handles. Space-Jump converts a 2D alignment of the 2D cursor with a handle into a 3D alignment of the 3D 
crosshair with that handle, when you tap the spacebar. Try this on various handles of a selected block. Select the 
Arrow tool in the tool palette, and select a block. Then position the 2D cursor (a tiny plus sign in selection mode) over 
an object handle that is at a different height from the center of the 3D crosshair. Then tap the space bar, and notice 
how the 3D crosshair jumps over to the handle location.

 

Space-jumping to a handle, then dragging it

When object-snapping is on, you can Space-Jump to non-selected handles as well.

At this point you should be ready to explore most of the palette tools and menu commands. However, one important 
general issue remains for building sophisticated models. 

Positioning in Three Dimensions 

Up to this point, the tool use has mostly assumed working from the ground plane, zero elevation. We need to add to 
that the technique of working at other elevations in space. The two key tools for accurate working in free 3D space 
are the Space-Jump and "projection lines." Space-Jump, detailed above, allows instant setting of the crosshair to the 
elevation of an existing object handle, for instance to draw a roof on top of a wall or building mass. Projection lines 
are like outline shadows cast from objects at any height in space down onto the ground plane. You may have already 



noticed that these show automatically for selected objects and objects being created. The projection lines for other 
objects can be turned on and off with functions in the Arrange menu.

Your perceptual system will automatically and unconsciously use the projection lines in building a correct mental 
model of the 3D scene. For instance, without projection lines you might not be able to see the difference between a 
small block close to the view point and high above the ground versus a large block in the distance sitting on the 
ground.

 

How high above the ground is each of these three blocks?

Projection lines are also very useful for specific alignment tasks, used together with the little foot at zero elevation on 
the vertical line of the 3D crosshair. This crosshair foot becomes visible when the crosshair is lifted above or below 
zero elevation. Then it becomes helpful to align the crosshair foot with the plan grid and the plan projection lines of 
various objects, to ensure that crosshair positions in space are actually as intended.

Other functions that support particular alignment needs are drawing by coordinate entry in the location bar at the 
bottom of the model window, and the Object Info box (opened from the Layout menu), which allows display and direct 
editing of key object parameters including height and elevation. Sometimes it may be necessary to use orthographic 
views (plan, section, elevation) to check the relative position of objects in space. DesignWorkshop facilitates this, 
supporting both multiple windows of one model (for instance, for a plan view, an elevation view, and a working 
perspective, all at once) and also opening more than one model at a time. You can cut and paste objects between 
models using standard Macintosh clipboard methods. 

Power Functions 



After mastering the knack of drawing in free 3D space with the core tools of DesignWorkshop, you will have the basis 
for putting to use any remaining functions. High among these are the four Working Orientations, which let you rotate 
your 3D crosshair 'drafting machine from plan to elevation, or to any other rotation and position in the model world. 
Other advanced functions include shadow-cast renderings, animated sun studies and walkthroughs calculated 
directly to QuickTime movies, etc. With Apple System 7, DesignWorkshop supports publishing live 2D views of a 3D 
model out to subscribe-capable drawing/drafting software, permitting a whole drawing set and a multi-person project 
team to continuously synchronize to the 3D design model.
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5.1.4 - Specularity 

 Artifice, Inc.
DesignWorkshop

Specularity

Guide Foyer | Guide Index | Techniques | Materials Overview

The specularity values for a material control the size and brightness of specular highlights it reflects. Smooth, 
reflective objects have highlights that are small and bright. Rough, reflective objects have highlights that are large and 
diffuse, but still bright. Less reflective objects, rough or smooth, have dimmer highlights.

The details of how specularity is defined for DesignWorkshop materials were updated for DesignWorkshop 1.7. This 
has subtly altered the intrepretation of the specularity field for each material in the "DW Material Prefs" file. The 
update is backward-compatible, so older "DW Material Prefs" files will work as-is, and old models will still look the 
same as they did. For future models, the update allows more complete control of specularity values.

There are now two components involved in defining the specularity for a DesignWorkshop material, which we call 
"smoothness", and "specular reflectivity". To provide for backward compatibility, these two values are packed together 
into the single overall specularity number.

In general, the smoothness defines how sharply focused a specular highlight will appear (how large or smaller), and 
the specular reflectivity defines how much of the incident light will be reflected back in the highlight (how bright or 
dim). In practice, the values interact, so it takes a while to get used to how to adjust them to control particular effects.

To define two components of specularity within one number, the specularity value in the "DW Material Prefs" file is 
now interpreted as two parts. Four specific digits within the number are interpreted as the smoothness value, and two 
digits are interpreted as the specular reflectivity.

The smoothness is defined by the 3 digits to the left of the decimal point together with the first digit to the right of the 
decimal point. For example, if the specularity number in the DW Material Prefs file is 123.456, the smoothness will be 
123.4. Smoothness values are exponential, from 000.0 to 999.9. Values greater than about 300 will usually not show 
a visible difference in renderings.

The specular reflectivity is defined by the second and third digits to the right of the decimal point, and these are 
interpreted as a decimal fraction. For example, if the specularity number in the DW Material Prefs file is 123.456, the 
specular reflectivity will be 0.56. Specular reflectivity values are linear, from 0.00 to 0.99, with 0.00 meaning no light 
reflected into the highlight, and 0.99 meaning 99% of incident light is reflected into the highlight.

The following illustration shows a matrix of spheres rendered in DesignWorkshop with various smoothness and 
specular reflectivity values.



The spheres on the left have a specular reflectivity of 00.0, and the spheres on the right have a specular reflectivity of 
0.99. The spheres at the top have a smoothness of 00.0, and the spheres at the bottom have a smoothness of 100.0.
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If you can see this, your help file has no topics! See the status tab and webtwin.log for more information.

Note that it is important that you exit WebTwin first to make sure the log file is up to date.

Be aware that restarting WebTwin will cause the log file to be emptied, so check it before restarting.



This URL was excluded from the pulldown



The protocol used in this URL is not at present supported by WebTwin



This URL referenced an unknown protocol



This link was broken when WebTwin tried to fetch it



This URL contained unknown content



Robots are excluded from this URL



This link was not retrieved



This link was skipped because it was suspected to be an invalid URL



This link was skipped at user request



This link was skipped it was suspected to be CGI. This can be changed from the WebTwin Options tab.



This link was skipped it was an image, and the NoImages option was on. This can be changed from the 
WebTwin Options tab.



This link was skipped because either the user pressed the WebTwin 'Enough' button or the given retrieval 
time limit expired.



Registration information goes here





file://C|/Program Files/WS_FTP/Documentation/Documentation/documents/index.html This link was broken at the 
time WebTwin tried to fetch it.





file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials.html This link was broken at the 
time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs.html This link was broken at the 
time WebTwin tried to fetch it.





file://c|/Program Files/WS_FTP/Documentation/Documentation/documents/index.html This link was broken at the time 
WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs.html This link was broken at the 
time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Appliances-Kitchen.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Brick-CMU.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Cabinets-Kitchen.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Carpet-Floor.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Brick-CMU.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Columns-Classical.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Columns-Classical-Detail.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Contexts-Mall_Exterior.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Contexts-Mall_Interior.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Doors-Exterior-Commercial.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Doors-Exterior-Garage.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Doors-Exterior-Residential.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Doors-Interior.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Escalator.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Fabric-Leather.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Facade_Textures.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Fixtures-Bathroom.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Fixtures-Commercial.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Carpet-Floor.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Gothic_Style.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Multifaceted-Cuboids.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Multifaceted-Slabs.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Multifaceted-Snakes.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Multifaceted-Sphere.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Pitched_Roofs.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Roman_Style.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Forms-Trusses.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Bedroom.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Bedroom-Beds.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Chairs.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Chairs-Designer.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Chairs-Office.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Couches.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Couches-Designer.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Couches-Section.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Desks.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Desks-Special.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Living_Room.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Outdoor.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Shelving.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Tables.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Furniture-Tables-Office.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Landscape.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Landscape-Accessories.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Landscape-Access-Bollards.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Landscape-Access-Lighting.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Landscape-Fencing.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Landscape-Plants.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Landscape-Street_Signs.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Fabric-Leather.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lettering-Polyline-
Sans_Serif.html This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lettering-Solid-Sans_Serif.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs.html This link was broken at the 
time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials.html This link was broken at the 
time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lighting-Ceiling_Mounted.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lighting-Exterior.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lighting-Freestanding.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lighting-Theatrical.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Lighting-Wall_Mounted.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Brick-CMU.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials.html This link was broken at the 
time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Metal.html This link was broken 
at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Misc_Materials.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Office-Equipment.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Paint.html This link was broken 
at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Pavers-Paving.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Pavers-Paving.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/People-Block_Figures.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/People-Silhouette.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Recreational_Equipment.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Roofing-Shingles.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Roofing-Shingles.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Siding-Stucco.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Stairways.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Siding-Stucco.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Stone.html This link was broken 
at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Tiles.html This link was broken 
at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Trees-Conifer-Detail.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Trees-Conifer-Massing.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Trees-Deciduous-Detail.html This 
link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Trees-Deciduous-Massing.html 
This link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Trees-Palm.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Utility_Room.html This link was 
broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Vehicles-Massing.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Vehicles-Sedan.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Vehicles-Silhouette.html This link 
was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/3d_libs/Vehicles-Trucks-Utility.html This 
link was broken at the time WebTwin tried to fetch it.
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link was broken at the time WebTwin tried to fetch it.



file://c|/Program Files/WS_FTP/Documentation/Documentation/accessories/materials/Wood.html This link was broken 
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