


Avery LabelPro for Windows

 Avery LabelPro is an application for the Windows operating environment that is designed to make 
printing labels, and other Avery products easy. You can design labels with text and graphics, and you can 
merge information both from the built-in List Manager and from other sources, including WordPerfect, 
dBASE, Paradox, Word for Windows, Microsoft Word, and any other program that can export a delimited 
ASCII file.
For Help on Help, Press F1
Choose a topic below to learn about LabelPro's Functions.

LabelPro's Designer Procedures (How to...)

Using the List Manager Menu Commands 

Merging a list LabelPro Messages

Sample Files Glossary

Avery Products Avery Product Support 

 LabelPro QuickSteps
The QuickSteps button displays the QuickSteps for the topic you are viewing. QuickSteps stay on the 
screen to provide a brief summary of the steps you should take to accomplish your goal. Click this 
QuickSteps button to see a list of the QuickSteps available to you.



LabelPro Designer
LabelPro's Designer lets you create and edit designs, and print existing designs. This is where you 
create your designs, adding text, graphics and shapes. You merge information from lists into designs 
here.    Each time you start a new design a text object is automatically available.

Designer includes a tool bar that helps you with your designs. Click a tool below to see what it does.

Arrow

Use the Arrow tool to return the cursor to the 
selection arrow.

Text

Use the Text tool to create text objects.

Graphic

Use the Graphic tool to add bit mapped 
graphics to your design.

Bar Code

Use the Bar Code tool to add bar codes to 
your design.

Line

Use the Line tool to draw straight lines.

Rectangle

Use the Rectangle tool to draw rectangles and 
squares with sharp corners.

Rounded Rectangle

Use the Rounded Rectangle tool to draw 
rectangles and squares with rounded corners.

Ellipse

Use the Ellipse tool to draw ellipse and 
circles.

Print

Use the Print tool to print one set or page of 
the current design.

AutoMerge

Use the AutoMerge tool to step through the 
merge process.

List Manager

Use the List tool to open List Manager.

If you click one of the tools by mistake, simply click the Arrow tool or press the Esc key to change 
the cursor back to an arrow.





List Manager
LabelPro's List Manager keeps lists of information that you can print on Avery products. You can 
create any type of list you want, for example address lists, and parts lists. 

List Manager saves your work as you go. Simply click the New button to start a new record, the 
record you were working on previously is automatically saved.

You can change the names of the fields in List Manager. Use the Field Names command on the 
edit menu. Like everything else in List Manger, your changes are saved automatically when you click the 
Edit Record button.

Use the Filter command to select a portion of a list to edit or print.
Use the Sort command to view or print a list in a particular order.
Records must have the Mark for Printing box checked to print. Use the Mark all for Printing 

command.

For more information on List Manager, select one of the following topics.

How to create a new list 

How to change field names 

How to select text 

How to edit text 

How to select records for printing 

How to sort records 

How to print a list in report format 

How to find a record 



 LabelPro QuickSteps
LabelPro QuickSteps are available for the following topics. The QuickSteps icon, shown in the upper-
left corner of this screen let's you know that QuickSteps are available for the topic you are reading 
click the QuickSteps icon to see the QuickSteps window.

QuickSteps remain on your screen, on top of all your other windows, until you click the Close 
button in the QuickSteps window.

Adding a Graphic 

Adding Lines

Adding Shapes

Adding Text 

AutoMerge Overview

Calibrating LabelPro to your Printer 

Changing Field Names 

Changing Fonts 

Checking Records in a List 

Creating a Design 

Creating a Filter 

Creating a New List 

dBASE Merge 

Delimited file (CSV) merge 

List Manager Merge 

Merge Overview 

Paradox Merge 

Postnet Bar Codes 

Printing a List 

Selecting List Records to Print 

Selecting Merged Records to Print 

Sorting a List 

Word for Windows Merge 

WordPerfect Merge 





Procedures
These procedures show you how to perform many common LabelPro tasks.

Select one of the following main topics to see a list of procedures.

Creating Designs 

Using Lists 

Merging Files 

Printing with LabelPro 



Creating Designs
These procedures show you how to perform many common LabelPro tasks.

What is a design? 

How to add a bar code 

How to add a border 

How to add a graphic 

How to add a Postnet bar code 

How to add a serial number 

How to add a shape (Rectangles and Ellipses) 

How to add color

How to add text

How to address for postal automation 

How to be sure that everything fits in your design 

How to center text 

How to change fonts 

How to change the product selection

How to create a design 

How to create objects that extend to the edge of the design

How to duplicate LabelPro DOS designs in LabelPro for Windows 

How to edit text 

How to enlarge (Zoom) a design 

How to move objects 

How to place an object on top of another object 

How to position and align objects on a design

How to print multiple identical labels 

How to print part of a graphic 

How to enlarge (Zoom) a design 

How to rotate text

How to select objects 

How to select text 

How to use the Postal Address font

See Also

Using Lists 

Merging Files 

Printing with LabelPro 



Using Lists
These procedures show you how to perform many common LabelPro tasks.

What is a list? 

How to change field names 

How to convert LabelPro DOS lists to LabelPro for Windows lists 

How to Copy a Record in List Manager 

How to create a new list 

How to Delete a Record from List Manager 

How to find a record 

How to print a list in report format 

How to select records for printing 

How to sort records 

See Also

Creating Designs 

Merging Files 

Printing with LabelPro 



Merging Files
These procedures show you how to perform many common LabelPro tasks.

What is merging?

How to check all the records in a list 

How to merge dBASE data files 

How to merge LabelPro Laser and LabelPro Dot Matrix (DOS) files 

How to merge LabelPro List Manager files 

How to merge Paradox data files 

How to merge Word for Windows data files 

How to merge WordPerfect secondary merge files 

How to select records for printing 

See Also

Creating Designs 

Using Lists 

Printing with LabelPro 





Printing with LabelPro
These procedures show you how to perform many common LabelPro tasks.

How to address for postal automation 

How to adjust the print position on pin-fed printers 

How to be sure that everything fits in your design 

How to calibrate LabelPro to your printer 

How to change the printing order 

How to check all the records in a list 

How to load labels in your printer 

How to optimize LabelPro's printing speed 

How to preview your design 

How to print a list 

How to print Mini-Sheets Laser Labels 

How to print multiple copies 

How to select a printer 

How to select records for printing 

How to start printing after the first label on a sheet 

See Also

Creating Designs 

Using Lists 

Merging Files 



Commands
Find information on any of LabelPro's commands.

Designer Menus

File Menu 

Edit Menu 

Objects Menu 

Text Menu 

Views Menu 

Merge Menu 

Help Menu 

List Manager Menus

File Menu 

Edit Menu 

Record Menu 

Help Menu 

Control Menu 



Glossary
Click on a term to see what it means.

AutoMerge Menu

Bar Code Object Merge 

Calibration Sheet Merge Field 

Click Merge Graphic

Clip Object 

Clipboard Paste 

Color Point Size 

Copy Portrait 

Cut Postnet 

Description Select 

Design Shape Object 

Drag Shrink to Fit 

Font Sizing Handles 

Graphic Object Text Object 

Insertion Point Text Rotation

Landscape Tool 

Line Object Undo

Link Zoom

List

Sample Files
LabelPro includes many sample files to show you how to use its features and how to print many Avery 
products. Each sample file is explained in the topics below.

North America Europe and other parts of 
the world

Sample Designs Sample Designs

Sample Lists Sample Lists



Avery Product Information

(This topic simply jumps to the CONTENTS topic of AV-PROD.HLP.)



LabelPro for Windows
LabelPro for Windows is Avery's top-of-the-line software. It comprises all the features of Label 
Assistant plus it adds the following features:

Prints on all Avery Laser, Ink Jet and Pin-Fed supplies.

Prints color text and shapes.

Rotates text to any angle.

Prints UPC, EAN and Code 39 bar codes.

Includes additional merge file types including WordPerfect 5.1 and 6.0 DOS, WordPerfect 
5.1, 5.2 and 6.0 for Windows, Word for Windows 2.0 and 6.0, Word 5.0 and 5.5 (DOS), Paradox 1.0 for 
Windows and 4.0 for DOS, dBASE III PLUS, plus DOS and Windows delimited (CSV) files.

Prints additional types of graphic files, including BMP, EPS, GIF, IMG, JPG, PCX, WMF, 
WPG, TGA, and TGA.

If you own Label Assistant, you can upgrade to LabelPro for Windows by calling the Avery Consumer 
Service Center at (800) 252-8379.



Label Assistant 2.0
Label Assistant is Avery's entry level label-printing program. Label Assistant includes the following 
features:

Prints on all Avery Laser, Ink Jet and Pin-Fed address labels and other selected supplies.

AutoMerge™ makes merging dBASE and delimited files simple.

Shrink-to-fit guarantees that the printing fits on each label you print.

Label Assistant prints BMP, PCX, WMF, and TIF graphics. And, you can print a different 
graphic on each label.

QuickSteps™, step-by-step on-screen instructions guide you through key tasks.

Automatically calculates postal bar codes, including the new delivery point bar codes. 
You dont need a special data file format or a special merge field.

LabelPro for Windows includes additional advanced features not available in Label Assistant.

 





About LabelPro Dialog Box
The About LabelPro dialog box provides information about LabelPro for windows. You can see the 
version number of your copy of LabelPro for Windows, the copyright notice, installed math 
coprocessors, the version of Windows, and the available system resources and memory.



Bar Code Data Dialog Box
Use the Bar Code Data dialog box to set the data options for bar codes.

Double-clicking a Bar Code object, or the Data button in the Bar Code Properties dialog 
box displays this dialog box. 

Use the Bar Code command or the Bar Code tool to create a bar code.

Dialog Box Options

Data Source

Merge Prints bar code data from a linked list. The bar 
code value is taken from any field in the list. 
You must have a list linked to the design to 
use merge. Click the Merge button to select 
the field to print.

Fixed Prints the same bar code on each label. Enter 
the number in the adjacent text box. 

Serial Prints serially numbered bar codes. Click the 
Serial button to set the serial number options.

Alignment

Select an option to control the horizontal positioning of the data value below the bar code.

Left The data value is aligned at the left side of the 
bar code.

Centered The data value is centered under the bar 
code.

Right The data value is aligned at the right side of 
the bar code.

Justify The data value is spread to the width of the 
bar code.

Font

Displays the currently selected font for the data value below the bar code. Use the Font button to 
change the font style with the Font dialog box.

Size

Displays the size of the currently selected font.

Print Data Value

Prints the data value below the bar code.

Font

Use the Font button to change the font style of the data value below the bar code with the Font dialog 
box.

Serial

Use the Serial button to specify a serial number to print as a bar code with the Serial Number dialog 
box. The Serial button is active when the Serial Data Source is selected.



Merge

Use the Merge button to select a merge field to print as a bar code with the Merge Fields dialog box. 
The Merge button is active when the Merge Data Source is selected.

For more information, see How to Add a Bar Code.



Bar Code Properties Dialog Box
Use the Bar Code Properties dialog box to specify the properties for bar codes.

The Properties command displays this dialog box if a Bar Code object is selected. 

Creating a Bar Code object displays this dialog box.

Clicking the right mouse button on a Bar Code object displays this dialog box.

Dialog Box Options

Symbology

Select the type of bar code you want to print.

Density

The density determines the overall width of the bar code. It is expressed in characters per inch (cpi) 
or characters per centimeter (c/cm). The density values that are available change depending on the 
ratio that is selected.

Height

Sets the height of bars printed in the bar code.

Units of Measure

Select inches for English units (inches and characters per inch) or cm for metric units (centimeters 
and characters per centimeter).

Options

Select the options you want for the bar code you are printing. The available options change 
depending on the type of bar code you are printing.

Compute Check 
Character

On Code 39 bar codes the check character is 
optional. Check this box if you wish to include 
a check character in your bar code.

Print Check Character Includes the optional check character in the 
data value below the bar code.

Print Start and Stop 
Characters '*'

Prints the start and stop characters (they are 
asterisks) in the data value below the bar 
code.

Compute Check Digit On Interleaved 2 of 5 bar codes the check 
digit is optional. Check this box if you wish to 
include a check digit in your bar code.

Print Check Digit Includes the check digit in the data value 
below the bar code.

Print Prefix Digit Includes the first, or prefix digit in the data 
value below the bar code.

Ratio

This sets the ratio of the wide bars to the narrow bars. 

Data



Sets the bar codes data options with the Bar Code Data dialog box.

For more information, see How to Add a Bar Code.



Date and Time Dialog Box
Use the Date and Time dialog box to select a date and/or time format to include in your design. A 
Date and Time field always prints the date or time that the design is printed.

The Date and Time command on the Text menu displays this dialog box.

Dialog Box Options

Format

Select the date or time format that you want. The formats that are available depend on the 
International settings in Windows Control Panel.

Font

Use the Font button to change the font style with the Font dialog box.



Descriptions Dialog Box
Use the Descriptions dialog box to select designs by the descriptions you have given them.

Dialog Box Options

File

Lists the file names for all the design files in the current directory. Select the file you want to use and 
click OK.

Description

Lists the descriptions for all the design files in the current directory. Select the file you want to use and 
click OK.

Use the File Open dialog box to change directories.

Use the Save As dialog box to enter or change file descriptions.



Field names Dialog Box
Use this window to change the field names of your list.

The Field Names command displays this window.

This window looks much like the List Manager window, but in this window you can change only the 
field names, not the text.

Field names can be up to 20 characters long. You can use any combination of characters for field 
names.

To create an empty file with the same field names as another file, use File new. and 
select the file from which you want to copy the names as a template in the Use File Names From list.

Click the Edit Record button to return to the List Manager window.

For more information, see How to Change Field Names.



Filter Dialog Box
A filter lets you select a set of records to print or edit. You can create a filter that checks several fields.

The Filter command displays this dialog box.

You can create or change filters in either Designer or List Manager. 

Filters created for List Manger lists are remembered by the program. Filters creates for 
external files are not remembered.

Dialog Box Options

Field

Select the field on which you want to make your selection.

Criteria

Set the critera for the field you have selected.

Greater Than Includes records when the field is greater than 
the comparison value you enter

Less Than Includes records when the field is less than 
the comparison value you enter

Equal To Includes records when the field is equal to the 
comparison value you enter

Not Equal To Includes records when the field is not equal to 
the comparison value you enter

And Includes records that meet both the top and 
bottom criteria. This option is ignored if the 
lower comparison value is blank.

Or Includes records that meet either the top or 
the bottom criterion. This option is ignored if 
the lower comparison value is blank.

Contains Includes records where the field contains 
matching text. The text can appear anywhere 
in the field.

Does Not Contain Includes records where the field does not 
contain matching text anywhere in the field.

The program always makes comparisons on a character-by-character basis. If you are 
comparing two numbers, the program begins by comparing the leftmost digit of the first number with the 
leftmost digit of the second number. Thus numbers of different lengths might not compare the way you 
expect. Numbers that are the same length compare correctly, so you can add leading zeros to make all 
your numbers the same length. Likewise, dates might not compare the way you expect unless you enter 
the year first, the month second, and the day last (using 2 digits for each field).

Filter Criteria

Displays the set of criteria you have set. The Add button adds additional criteria to this list. The Delete 
button removes the highlighted criterion from this list.



Add

Adds the current Criteria settings to the list of Filter Criteria. 

Delete

Removes the highlighted criterion from the list of Filter Criteria.

For more information, see How to Select Records for Printing.



Find Dialog Box
Use the Find dialog box to look up entries in a List.

The Find command displays this dialog box.

Find always starts from your current position in the file so you can find additional records 
that contain the same text. If you want to search the entire file, click the First Record button before using 
the Find command. 

Dialog Box Options

Find Next

Enter some text contained anywhere in the record you are looking for. You don't have to enter the 
entire field, you can enter as few characters as you like. Find is not case-sensitive. You can use 
capital or lower-case letters.

For more information, see How to Find a Record.



First Page Setup Dialog Box
Use the First Page Setup command to specify the label on which you want to start printing. Labels to 
the left of, and above, the first label will remain blank.

The First Page Setup command displays this dialog box.

First Page Setup specifies the starting position for the first page only. Additional pages 
will start printing on the first label.

Click on the first label you want to print. Alternatively, use the spinner to change the first label. 

Dialog Box Options

Start Printing On Label

Select the label on which you want to start printing. Labels above this label will remain blank.

For more information, see How to Start Printing After the First Label on a Sheet.



Font Dialog Box
The Font dialog box allows you to change the font, style, color, and size of the text in the selected text 
object.

The Fonts command displays this dialog box. 

Font buttons in several dialog boxes display this dialog box.

Clicking the right mouse button on a Text object when the insertion point is visible 
displays this dialog box.

Dialog Box Options

Font

Lists available fonts. You can select a font or type the name of the font you want in the box above the 
list of fonts.

Font Style

Lists the available font styles. You can select one of the styles in the list.

Size

Lists the available sizes for the font selected in Font box. You can select a font size or type the size 
you want in the box above the list of sizes.

Effects

Choose from the effects listed to underline or strikeout your text.

Sample

Shows a sample of text with the current font formatting choices applied.

Color

Lists the available font colors. You can select one of the colors in the list.

Apply

Applies the current formatting choices to the sample text. Use this button if you type a size value 
instead of picking it from the list to update the sample text.

For more information, see How to Change Fonts.



Graphic Properties Dialog Box
Use the Graphic Properties dialog box to select and control Graphic objects..

The Properties command displays this dialog box if a Graphic object is selected. 

Creating a Graphic object displays this dialog box.

Clicking the right mouse button on a Graphic object displays this dialog box.

Dialog Box Options

File Name

Type the filename of the graphic file you want to use, or click the Browse button. The program can 
use files with the extensions BMP, EPS, GIF, IMG, JPG, PCX, WMF, WPG, TGA, or TIF.

Click here to see how the program finds graphic files.

Merge

Select the Merge option    and the Browse button changes to the Merge button. Use the Merge button 
allows you to select a merge field that contains the file name of files to be printed.

You must have a list linked to your design before the Merge option is available.

See How to print different graphics on each label for more information.

Sizing Options

Select a sizing option to control the size of the graphic image. 

Keep Original Size and 
Shape

Brings in the graphic image at its original size. 
If the image is larger than the graphic object's 
bounding box only the upper-left corner of it 
will appear. If the image is smaller than the 
bounding box part it will be placed in the 
upper-left corner of the box.

Original Shape, Sized to 
Frame

Brings in the graphic image scaled to fill the 
graphic object's bounding box in one direction. 
Since the shape of the image is maintained, 
unless the bounding box happens to be 
exactly the correct shape, there will always be 
some white space on the right or bottom side.

Fill Graphic Frame Brings in the graphic image scaled in both 
directions to fill the graphic object's bounding 
box. You can distort the shape of the image by 
changing the shape of the bounding box.

Browse

Uses the File Open dialog box for finding graphic images.

Merge



Uses the Merge Fields to attach graphic files through Path Names.

Paste

Use the Paste button to paste a graphic from the Windows clipboard into the graphic object. the 
program will automatically create a file name for your image.

To print a portion of a large image, use Windows Paintbrush's Pick tool to cut out the part 
of the image you wish to print. Use Paintbrush's Edit Copy To command to save this new image to a file, 
or paste it into the program.

For more information, see How to Add a Graphic and How to Print Part of a Graphic.



Link to List Dialog Box
The Link to List dialog box allows you to associate a data file with a label design.

The Link to List command displays this dialog box.

Dialog Box Options

File Name

Type or select the filename you want to link. This box lists files with the extension you select in the 
List Files Of Type box.

List Files Of Type

Select the type of file you want to associate. 

LabelPro List
(*.avd)

Lists all LabelPro List Manager files in the 
current directory that were saved with an .AVD 
extension.

Delimited - Win
(*.csv, *.txt)

Lists all delimited text files in the current 
directory that were saved with a .CSV or .TXT 
extension. LabelPro can merge files that 
follow the rules stated in How to Merge 
Delimited Files 

Delimited - DOS 
(*.csv, *.txt)

Lists all delimited text files in the current 
directory that were saved with a .CSV or .TXT 
extension. LabelPro can merge files that 
follow the rules stated in How to Merge 
Delimited Files 

dBASE 
(*.dbf)

Lists all dBASE data files in the current 
directory that were saved with a .DBF 
extension. LabelPro can merge dBASE III and 
dBASE IV files.

Paradox 
(*.db)

Lists all Paradox files in the current directory 
that were saved with a .DB extension. 
LabelPro can merge Paradox 4.0 and 
Paradox for Windows 1.0 files.

WinWord 2,Word 5
(*.doc)
WinWord 6.0
(*.doc)

Lists all Microsoft Word files in the current 
directory that were saved with the .DOC 
extension. LabelPro can merge Word for 
Windows 2.0 and 6.0 files and Microsoft Word 
5.0 and 5.5 files.

WordPerfect 5
(*.*)
WordPerfect 6.0
(*.*)

Lists all WordPerfect files in the current 
directory. LabelPro can merge WordPerfect 
5.1 and 5.2 (DOS) files and WordPerfect 5.1, 
5.2 and 6.0 for Windows files.

Directories

Select the directory in which the file that you want to open is stored.

Drives

Select the drive in which the file that you want to open is stored.

None



Select this option to remove your link, so that there is no file linked to your design.

For more information, see How to Merge.



Line Properties Dialog Box
Use the Line Properties dialog box to change the width of lines.

The Properties command displays this dialog box if a Line object is selected. 

Creating a Line object displays this dialog box.

Clicking the right mouse button on a line object displays this dialog box.

Dialog Box Options

Line Width

Choose the width of the line you want.

Line Color

Choose the color of the line you want.

For more information, see How to Add a Line.



Merge Fields Dialog Box
Use the Merge Fields dialog box to place merge information on you designs.

The Merge Fields command displays this dialog box.

Dialog Box Options

Merge Text

This list shows the text of the first record in the file. In some cases, such as delimited files where the 
first line is the field names or merge graphic files, this will show you the field names of the path for 
merge graphic files. Click the Show Text button to see Merge Text.

Merge Field

This list shows the field names of the linked file. For files that don't have defined field names, such as 
delimited files. this list shows the field numbers. Click the Show Fields button to see Merge Field.

Show Text

The Show Text button changes the Merge Field list to the Merge Text list.

Show Fields

The Show Fields button changes the Merge Text list to the Merge Field list.

Add Field

Adds the highlighted field to the label design at the insertion point. You can immediately see the field 
appear on the design. You can also add a field by double-clicking it in the Merge Field or Merge Text 
list.

Insert Space

Adds a space to the label design at the insertion point. Use the Insert Space button to add a space 
between fields without leaving the Merge Fields dialog box.

Start New Line

Moves the insertion point to the next line. Use the Start New Line button to place the next merge field 
on a new line without leaving the Merge Fields dialog box.

For more information, see How to Merge.



New Design Dialog Box
The New Design dialog box allows you to tell LabelPro what kind of Avery product you want to use for 
this design.

The New Design command displays this dialog box.

Dialog Box Options

Type

Lists the types of Avery products available. Choose the type of product first, then use the Product list 
to select the particular product you want.

Some products include "Portrait" or "Landscape" in their name. Portrait products are set 
up to print vertically, not horizontally. In this context, Portrait and Landscape refer to the shape of the 
individual label or other product, not the entire page.

In LabelPro, portrait and landscape refer to the actual label or other product, not the 
entire sheet.

Product

Lists the products of the type chosen from the Type list. Select the product you want and click OK.

Products

Opens a help window showing a description of the Avery products supported by LabelPro.

If the product you want to print doesnt appear, use the Avery Product Setup application in 
Program Manager to change your list of products. See How to change the product selection.

For more information, see How to Create a Design, or Avery Products.



New List Dialog Box
Creates a new List Manager list.

The New List comand displays this dialog box.

Dialog Box Options

File Name

Type a filename for your new list.

A filename can contain up to eight characters and an extension of up to three characters. 
The program adds the appropriate extension for the type of file you are saving.

Directories

Select the directory in which you want to store the file.

Drives

Select the drive in which you want to store the file.

Use Field Names From

Select a list on which you would like to base your new list. The field names are copied from the 
template list to your new list. Select Default to have your fields numbered. 

For more information, see How to Create a New List.



Open Dialog Box
The File Open dialog box allows you to open existing label design and List Manager files.

The Open Design and the Open List commands display this dialog box.

The Browse button in the Graphic Properties dialog box displays this dialog box.

Dialog Box Options

File Name

Type or select the filename you want to open. This box lists files with the extension you select in the 
List Files Of Type box.

List Files Of Type

Select the type of file you want to open. The list of file types changes depending on what kind of file 
you are opening.

LabelPro Designs 
(*.lpd)

Lists all LabelPro Design files in the current 
directory that were saved with an .LPD 
extension.

LabelPro Lists
(*.avd)

Lists all LabelPro List Manager files in the 
current directory that were saved with an .AVD 
extension.

Windows Bitmaps
(*.bmp)

Lists all Windows bitmap files in the current 
directory that were saved with a .BMP 
extension.

Tagged Image
(*.tif)

Lists all TIFF bitmap files in the current 
directory that were saved with a .TIF 
extension.

PC Paintbrush
(*.pcx)

Lists all PCX bitmap files in the current 
directory that were saved with a .PCX 
extension.

Windows Metafile
(*.wmf)

Lists all Windows metafiles in the current 
directory that were saved with a .WMF 
extension.

GIF Files
(*.gif)

List all the GIF files in the current directory 
that were saved with a GIF extension.

Encapsulated 
PostScript
(*.eps)

List all the Encapsulated PostScript files in the 
current directory that were saved with a GIF 
extension.

Targa
(*.tga)

List all the Targa files in the current directory 
that were saved with a TGA extension.

IMG Files
(*.img)

List all the image files in the current directory 
that were saved with a IMG extension.

JPEG Files
(*.jpg)

List all the JPEG files in the current directory 
that were saved with a JPG extension.

WordPerfect format
(*.wpg)

List all the WordPerfect graphics files in the 
current directory that were saved with a WPG 



extension.

Directories

Select the directory which contains the file you want to open.

Drives

Select the drive which contains the file you want to open.



Postnet Properties Dialog Box
Use the Postnet Properties dialog box to place Postnet bar codes.

The Properties command displays this dialog box if a Postnet object is selected. 

The Posnet button in the Text Properties dialog box displays this dialog box.

Dialog Box Options

Placement

Sets the position of the Postnet bar code on the label.

Above Address Places the Postnet bar code above the 
address in the text object.

Below Address Places the Postnet bar code below the 
address in the text object.

Ignore 5 Digit Zip Codes

Select this option to print only delivery point bar codes. If you wish to print 5-digit bar codes when 
there is only a 5-digit Zip code, un-check this option. Delivery point bar codes will always print 
if there is a 9-digit Zip code.

The program automatically finds the Zip code in the text object. You don't have to worry 
about any special fields or merge codes.

The United States Postal Service prefers that the bar code be positioned above the 
address, but they accept either position.

Delivery Point bar codes encode the 9-digit Zip code plus the last two digits of the street 
address for fastest mail delivery and maximum postal discounts.

If you get a message telling you that your Postnet bar code won't fit on the label, simply 
move or re-size the Text object to allow more room.

For more information, see How to Add a Postnet Bar Code.



Print Dialog Box
Use the Print dialog box to print lists and multiple copies of labels.

The Print command displays this dialog box.

Dialog Box Options

Print

Set the number of copies to print. 

Labels Specifies that the number indicates the total 
number of labels or other products to print.

Pages Specifies that the number indicates the total 
number of complete pages of labels or other 
products to print. For pin-fed products, a page 
is always two rows (two labels) high.

Sets Specifies that the number indicates the 
number of sets of merged labels or other 
products to print.

For pin-fed products, a page is always two rows (two labels) high. 

Merge Sequence

Sets the order for printing.

1,2,3...1,2,3...1,2,3 Prints one complete set of merge records 
before starting the next set.

1,1,1...2,2,2...3,3,3 Prints all copies of the first record of the 
merge file before printing the second record.

Start Each Set on a New Page

When this option is checked, the program will start each set on a new page. This allows you to create 
completely seperate sets of labels.

Start at Record

Set the record at which you want to start printing. This field allows you to restart a print job in the 
middle. Only records that meet the current filter criteria are counted, so you can easily calculate the 
number of records printed by counting the sheets of labels and multiplying by the number of labels on 
a sheet.

Printer

Displays the name of the currently-selected printer. Use the Print Setup command to change printers.

Choose side or center feed when printing Mini-Sheets.

Side Feed Select this option if your laser printer feeds 
small sheets and envelopes at one side of the 
manual feeder.

Center Feed Select this option if your laser printer feeds 
small sheets and envelopes down the center 
of the manual feeder.

Text Options



Determines how text that won't fit in Merge Text objects is treated when you print.

Clip Text Text that extends beyond the right edge or 
bottom of a Text object will be truncated at the 
right edge or bottom.

Shrink to Fit Text that would extend past the right edge or 
bottom of a Text object will be reduced in point 
size until it fits.

Report Clipping
Report Shrinking

When selected, the program will report text that doesn't fit into a Merge Text object.

Text that shrinks when you don't expect it to can be caused by blank lines at the bottom 
of your text object. Place the insertion point after the last character that you want to print, and press the 
Del key repeatedly to be sure there are no blank lines below.

The program prints faster when Report Clipping or Report Shrinking is not checked.

For more information, see Printing and How to optimize printing speed.



Print Calibration Dialog Box

The Print Calibration Command in the File Menu displays this dialog box.

Dialog Box Options

Print Pattern

Click this button to print a calibration sheet.

Calibration

Enter the numbers from the calibration sheet. 

You received a calibration sheet in your LabelPro for Windows package.

Print Alignment, or calibration, is only used for sheet-fed printers including laser printers 
and many ink jet printers. For pin-fed printers, see How to Adjust the Print Position on Pin-Fed Printers.

For more information, see How to Calibrate to your Printer.



Print Preview Dialog Box
Use the Print Preview dialog box to see what your printed design will look like, and to check a merge 
design for errors.

The Print Preview command displays this dialog box.

Dialog Box Options

Text Options

Determines how text that won't fit in Merge Text objects is treated when you print.

Clip Text Text that extends beyond the right edge or 
bottom of a Text object will be truncated at the 
right edge or bottom.

Shrink to Fit Text that would extend past the right edge or 
bottom of a Text object will be reduced in point 
size until it fits.

Report Shrinking
Report Clipping

When you Check this option, the program stops with a warning and displays every record that does 
not fit in the specified type size. 

Scan

When you click the Scan button the program checks all the records in the merge file to be sure that 
they fit on the label and there are no data errors.

The Scan button is grayed unless there is a merge file linked with the design.

Next

When you click the Next button the program displays the next record in the merge file. You can see 
each record in turn by repeatedly clicking the Next button.

The Next button is grayed unless there is a merge file linked with the design, or the 
design contains a serial number.

Cancel

During a scan, the Close button changes to Cancel so you can stop scanning.

For more information, see How to Preview Your Design.



Print Setup Dialog Box
Use the Print Setup dialog box to change orientation and printers.

The Setup button in the Print dialog box displays this dialog box.

Dialog Box Options

Printer

Displays, and allows you to change the printer. 

Default Printer Displays the current default printer for your 
system. Select this option to print to the 
default printer.

Specific Printer  You can select a different printer.

Orientation

Portrait Sets your printer to print in portrait orientation.

Landscape Sets your printer to print in landscape 
orientation.

Paper

Size Sets the size of paper.

Source Sets the source of paper in your printer.

Options

Select this button to change the setup of the selected printer.

Calibrate

Select this button to calibrate the program to your printer. The Print Calibration dialog box appears.

Print Calibration is only used for sheet-fed printers including laser printers and many ink 
jet printers. You don't need to use Print Calibration with tractor-feed printers.



Rulers Dialog Box
Use the Rulers dialog box to change the way the rulers appear and act.

The Ruler command displays this dialog box.

Dialog Box Options

Tick Marks Per Inch or Tick Marks Per Centimeter

Set the number of divisions that the rulers have. For example, if you want the rulers to be graduated 
in eighths of an inch, set the Tick Marks per Inch to 8.

Horizontal Changes the number of graduations on the 
horizontal (top) ruler.

Vertical Changes the number of graduations on the 
vertical (left side) ruler.

Show Rulers

Select this option to display the rulers. When this option is not checked, the rulers are not visible.

Snap to Rulers

Select this option to make all your objects lock on the nearest invisible grid line. This makes it simple 
to align objects.

Units of Measure

Inches Sets the unit of measure to English (Inches).

Centimeters Sets the unit of measure to metric (cm).

Turning on Snap to Rulers makes it easy to align objects. Everything you place on a 
design will align with the invisible grid when this option is checked.



Save As Dialog Box
Use the Save As dialog box to save and name the active Design or List.

The Save Design As and Save List As commands display this dialog box.

Dialog Box Options

File Name

Type a new filename to save a document with a different name. Use the current name, or select a 
name in the list to save a file with an existing filename.

A filename can contain up to eight characters and an extension of up to three characters. 
The program adds the appropriate extension for the type of file you are saving.

Directories

Select the directory in which you want to store the file.

Drives

Select the drive in which you want to store the file.

List Files of Type

Controls what files are shown in the file name list. The list of file types changes depending on what 
kind of file you are saving.

LabelPro Design 
(*.lpd)

Lists all LabelPro Design files in the current 
directory that were saved with an .LPD 
extension.

LabelPro List 
(*.avd)

Lists all LabelPro List Manager files in the 
current directory that were saved with an .AVD 
extension.

Description

Enter a descriptive name for this file. 

Use the Descriptions button in the File Open dialog box to retrieve files by description.

To save a design with its existing name, description, and location, use the Save Design 
command.



Serial Number Dialog Box
Use the Serial Number dialog box to print a serial number on each label.

The Serial Number command displays this dialog box.

Dialog Box Options

Starting Number

Enter the first number you want to print.

Prefix

Enter any characters that you want to print immediately in front of the serial number.

Suffix

Enter any characters that you want to print immediately behind the serial number.

Length of Serial Number

Enter the maximum length of the serial number. You can use any length up to 9. If the number 
exceeds the length you set it will start over at zero.

Increment By

Enter the number that you want the serial number to change by. For example, to print only even 
numbers, enter 2. You can use either a positive or a negative number. If the increment is zero, the 
same number will print repeatedly. 

Padding

Specify the character that you want to use to fill the serial number to the Length you set.

Zeros Fills the serial number with zeros to the left of 
the significant digits to the Length specified.

Spaces Fills the serial number with spaces to the left 
of the significant digits to the Length specified.

None Only the significant digits print. The serial 
number may not be as long as the Length 
specified.

Font

Use the Font button to change the font style with the Font dialog box.

Characters that you type in the Prefix box are printed immendiately in front of the serial 
number. Characters that you type in the Suffix box are printed immendiately after the serial number. Use 
these for parts of the serial number that do not change.

The setting you make for Length of Serial Number has no effect unless you choose Zeros 
or Spaces in the Padding group.

You can use a negative number for an Increment.

If the serial number exceeds the length you specify, it will roll over to 0. For example, if 
you set the Length of Serial Number to 3, the number after 999 will be 000.



Use the prefix or suffix boxes to increase the serial number length to meed the 
requirements of EAN or UPC bar codes.

For more information, see How to Add a Serial Number.



Shape Properties Dialog Box
Use the Shape Properties dialog box to set the background fill pattern and line width of rectangles, 
rounded rectangles and ellipses.

The Rectangle, Rounded Rectangle and Ellipse commands display this dialog box.

Dialog Box Options

Fill Pattern

Select the pattern you want for the background of the shape.

Line Width

Select the width of line you want for the outline of the shape.

Use the Send to Back command to place a filled shape behind text that you want to print 
over it.

For more information, see How to Add a Shape.

Line Color

Select the color you want for the line width and background of the shape.



Sort Dialog Box
Use the Sort dialog to sort a list.

The Sort command displays this dialog box.

Dialog Box Options

Field

Select a field to sort on.

Sort Order

You can sort in Ascending (increasing) or Descending (decreasing) order.

Sort Criteria

Displays the set of criteria you have set. The Add button adds additional criteria to this list. The Delete 
button removes the highlighted criterion from this list.

The program always sorts on a character-by-character basis. If you are sorting two 
numbers, the program begins by comparing the leftmost digit of the first number with the leftmost digit of 
the second number. Thus numbers of different lengths might not sort the way you expect. Numbers that 
are the same length sort correctly, so you can add leading zeros to make all your numbers the same 
length. Likewise, dates might not sort the way you expect unless you enter the year first, the month 
second, and the day last (using 2 digits for each field).

Add

Adds the current Criteria settings to the list of Sort Criteria. You can have up to two fields in the Sort 
Criteria list.

Delete

Removes the highlighted criterion from the list of Sort Criteria.

For more information, see How to Sort Records.



Text Properties Dialog Box
Use the Text Properties dialog box to set the properties for Fixed Text and Merge Text objects.

The Properties command displays this dialog box if a Text object is selected. 

Creating a Text object displays this dialog box.

Clicking the right mouse button on a selected text object (with the sizing handles visible) 
displays this dialog box.

Dialog Box Options

Horizontal

Select an option to control the horizontal line positioning in the object.

Left The lines of text are aligned at the left side of 
the object.

Centered The lines of text are centered horizontally in 
the object.

Right The lines of text are aligned at the right side of 
the object.

Block Cent. The longest line of text is centered in the text 
object, then all the lines in that text object are 
left-aligned. 

Vertical

Select an option to control the vertical line positioning in the object.

Top The lines of text are placed at the top of the 
object.

Centered The lines of text are centered vertically in the 
object.

Spread The lines of text are spread vertically to fill the 
object.

Bottom The lines of text are placed at the bottom of 
the object.

Wrap Text

When Wrap Text is selected, the program automatically breaks lines at the end of words as your 
typing reaches the right edge of the label. 

Add Postnet

Select this option to add a Postnet bar code to the text object. The Zip code will automatically be 
printed as a Postnet bar code.

Font

Uses the Fonts dialog box for setting the font characteristics for the entire object.

Rotate

Uses the Rotate dialog box for setting the rotation angle for the entire object.



Postnet

Use the Postnet button to see the Postnet Properties dialog box, which controls the position and type 
of Postnet bar code.

To set the font for a single line, or for part of a line, select the text you want to change and 
use the Font command, or click the right mouse button.

For more information, see How to Add Text.



Tools Options Dialog Box
Use the Tools Options dialog box to change the way Designer's tools are displayed.

The Tools command displays this dialog box.

Dialog Box Options

Horizontal

Select Horizontal to display the tools across the top of Designer's window.

Vertical

Select Vertical to display the tools down the left side of Designer's window.

Display

Controls whether the tools are displayed or not. Check this box to display Designer's tools.

Hide Designer's tools to provide a larger work area for making designs, or to simply make 
Designer's window smaller.

All of the functions of the tools are provided on Designer's menus.



Rotate Dialog Box
The Rotate dialog box allows you to rotate the selected text object.

The Rotate command displays this dialog box. 

The Rotate button in the Text Properties dialog boxes display this dialog box.

Dialog Box Options

Rotate

Select a rotation angle of 0, 90, 180 or 270 degrees, or use the Other box to set the angle you want. 
The allowable range is 0 degrees to 359 degrees.



Zoom Dialog Box
The Zoom dialog box allows you to view your designs at any size from 25% to 400% of actual size..

The Zoom command displays this dialog box. 

Zoom

Select a view of 50%, 75%, 100%, 150%, 200% of actual size, or use the Other box to set the size 
you want. The allowable range is 25% to 400%.



Registration
This dialog box allows you to register your Avery software.

To Register

Call the number shown on the screen to register your Avery software. You will receive complete 
instructions.

Call to register when you have the Avery Registration dialog box on the screen. The 
Registration Number changes each time you start the program.

If you have problems registering, call Avery Technical Support.

Dialog Box Options

Registration Number

This is a unique number that is generated each time you start the program. When you register the 
program you will give this number. You will then receive an Unlock Code to unlock your copy of the 
program.

Unlock Code

When you register you will be given an Unlock Code. Enter the Unlock Code number here. 

Group Number

This number identifies the particular group of disks from which your copy was selected. You may be 
requested to give the Group Number when you register the program.

Register

Choose this button to Register your copy of the program. Call the number on the screen before you 
start to Register the program. Click this button after you have entered the Unlock Code.

Exit

Choose this button to exit from the program. This does not count as one of the times you have used 
the program.

Continue

Choose Continue to use the program without registering your copy. This will reduce the number of 
remaining times you can use the program without registering.

If you reinstall the program on a different computer you will need to register again. There 
is no charge if it is within the terms of the Avery License Agreement.
 





Control Menu Commands
Restore 

Move 

Size 

Minimize 

Maximize 

Close 

Switch To 



Designer File Menu
New Design creates a new label design based on the label template you select.

Open Design opens an existing design. Also used for changing directories.

Save Design saves changes made to active design.

Save Design As saves a new design or a new version of an existing design with the file name you 
specify. Also used for saving a file in a different directory.

Print Preview shows how your design will look when printed.

Print prints the active design according to the parameters you specify.

Print Calibration allows you to adjust the print image on laser and ink jet printers.

Print Setup allows you to select a printer and change the printer's settings.

First Page Setup lets you start printing on any label on the page.

Exit ends your session.



Designer Edit Menu
Undo Lets you undo any operation.

Cut removes the selection and places it onto the Clipboard.

Copy copies the selection and places it onto the Clipboard.

Paste pastes the contents of the Clipboard into an object, book or design.

Select All selects all the objects on the design.

Bring to Front places the selected object in front of all other objects.

Send to Back places the selected object in back of all other objects.



Designer Objects Menu
Properties displays the properties dialog box for the selected object.

Text places text objects on your design. The text in a text object can be the same for all labels or, if 
you use a merge or special field, can change from label to label.

Graphic places pictures on your designs

Bar Code prints Code 39, and other kinds of bar codes.

Line creates straight lines on your designs.

Rectangle creates rectangles and squares with sharp corners.

Rounded Rectangle creates rectangles and squares with rounded corners.

Ellipse creates circles or ellipses.



Designer Text Menu
Properties displays the properties dialog box for the selected text object.

Fonts displays the Font dialog box for the selected object.

Rotate displays the Rotate dialog box for the select text box.

Date and Time places the current date or time in a text object.

Serial Number places a serial number in a text object.

Postnet places a United States Postal Service bar code in a text object.

Bold changes the selected text to Bold.

Italic changes the selected text to Italic.



Designer View Menu
Tools displays or hides the tool bar in the Designer window

Ruler allows you to change how the rulers are displayed and how objects align with them.

Zoom displays the Zoom dialog box for the design template.

Show Text Frames changes the display of text and bar code objects to show a frame indicating the 
size of the object.

Show Guides displays or hides the guide lines that extend from the selected object to the rulers.

Show Status Bar displays or hides the status bar at the bottom of the Designer window.

Show Merge Fields changes the display of merge fields to show the field names instead of 
information from the first record.

Show Merge Text changes the display of merge fields to show information from the first record 
instead of the field names.



Designer Merge Menu
List Manager opens the List Manager window.

Link to List connects a data file with the design. This is the first step towards creating a merge.

Merge Fields adds merge fields from a list, or data file, to your design.

Filter allows you to create a filter so that only some of the records in an associated data file are 
printed.



Designer Help Menu
Contents displays the table of contents for help.

Search for Help On allows you to search for help on any topic in help.

Commands provides help on the menu commands

Procedures provides help on how to do things with the program 

QuickSteps provides a list of topics for which there are QuickSteps--a small reminder window that 
stays on the screen to remind you of the steps required to accomplish your goal. 

How to Use Help tells you how to use Help.

About  displays copyright and version information.



List Manager File Menu
New List creates a new list. You can base a new list on the field names in an existing list.

Open List opens an existing list.

Save List As saves a list with a new file name.

Print prints the active list according to the parameters you specify.

Print Listing prints a report-format listing of the current list.

Exit closes the List Manager window and returns you to designer.



List Manager Edit Menu
Cut removes the selection and places it onto the Clipboard.

Copy copies the selection and places it onto the Clipboard.

Paste pastes the contents of the Clipboard into an object, book or design.

Select Record selects all the fields in a record so you can copy or cut them in one step.

Find searches for information in the current list.

Field Names allows you to change the names of the fields in your list.



List Manager Record Menu
Filter allows you to create a filter to work with a portion of the current list.

Filter Active  turns the active filter on or off.

Sort allows you to sort the list.

Mark All For Printing marks all records in the current set for printing. 

Unmark All For Printing removes the mark for printing check from all records in the current set.



List Manager Help Menu
Contents displays the table of contents for help.

Search for Help On allows you to search for help on any topic in help.

Commands provides help on the menu commands

Procedures provides help on how to do things with the program 

QuickSteps provides a list of topics for which there are QuickSteps--a small reminder window that 
stays on the screen to remind you of the steps required to accomplish your goal. 

How to Use Help tells you how to use Help.



New Design Command (File Menu)
Creates a new label design for the label product you specify in the New Design dialog box.

To create a new label design.

From the File menu, choose New Design (Alt, F, N).

Then choose the label type you want to print on from the New Design dialog box.

In the program, portrait and landscape refer to the actual label or other product, not the 
entire sheet.

If the product you want to print doesnt appear, use the Avery Product Setup application in 
Program Manager to change your list of products. See How to change the product selection.



Open Design Command (File Menu)
Opens an existing label design using the File Open dialog box.

To open a label design.

From the File menu, choose Open (Alt, F, O).

Then choose the file you want to open using the File Open dialog box.

If you have made changes to an open design, you are asked if you want to save those 
changes.

Use the New Design command to create new designs.



Save Design Command (File Menu)
Records any changes you make to an active design. The design name and location remain the same. 
You should save designs frequently as you work.

To save an existing document

From the File menu, choose Save (Alt, F, S).

If this is the first time you have saved the design, the Save Design As dialog box appears.

If you open a read-only document and want to record changes you made, you can save 
the document with a new name. You can edit the new version of the document. See the Save Design As 
Command.



Save Design As Command (File Menu)
Saves the active design with a new name, thereby making a copy of the design.

To save a document with a new name

From the File menu, choose Save As (Alt, F, A).

The Save As dialog box appears. Enter the new file name, and optionally a new description, and save 
the file.

To save a document with a new description

From the File menu, choose Save As (Alt, F, A).

The Save As dialog box appears. Enter the new description and save the file.

To save a design with its existing name, description, and location, use the Save Design 
command.



Print Preview Command (File Menu)
Displays the current design as it will be printed, and allows you to view or check each record in your 
list.

To preview a design

From the File menu, choose Print Preview (Alt, F, V).

The Print Preview dialog box appears.

To check for records that are too long for your design

From the File menu, choose Print Preview (Alt, F, V).

The Print Preview dialog box appears.

Click the Next button to see the records in sequence. The program will report any records that must 
be clipped or shrunk to fit on your design.

Click the Scan button to have the program automatically scan all the records in your file, and report 
any that must be clipped or shrunk to fit on your design.

The text options (clipping or shrinking) that you choose in the Print Preview dialog box 
are remembered when you print. 



Print Command (File Menu)
Prints the current design. You can change the printing options in the Print dialog box.

To print the current design

From the File menu, choose Print (Alt, F, P). The Print dialog box appears.

You can print multiple copies and select other printing options.



Print Setup Command (File Menu)
Allows you to select a different printer or change the printer options.

To change printer settings

From the File menu, choose Print Setup (Alt, F, R). The Print Setup dialog box appears.



Print Calibration Command (File Menu)
Allows you to calibrate your printer to print properly on Avery products.

To change printer calibrations

From the File menu, choose Print Calibration (Alt, F, C). The Print Calibration dialog box appears.



First Page Setup Command (File Menu)
Sets the first label or other product to be printed.

To set the first label to print

From the File menu, choose First Page Setup (Alt, F, F). The First Page Setup dialog box appears.

You can set the first label to print.



Exit Command (File Menu)
Closes the application. You can also use the Close command on the Control menu.

To close the current window

From the File menu, choose Exit (Alt, F, X). The application closes.

If you have made changes to an open design, you are asked if you want to save those 
changes.

The List Manager saves your changes automatically.

Shortcut: Alt+F4



Undo Command (Edit Menu)
Undo the most recent editing operation. Toggles between undoing the operation and leaving the 
operation as performed.

To undo the current operation

From the Edit menu, choose Undo (Alt, E, U). The last editing operation is reversed.

The last change you made is automatically reversed.

Shortcut: Ctrl+Z



Cut Command (Edit Menu)
Removes the selection from the document and places it onto the Clipboard. The selection can be an 
object, characters in a text object, characters in a List Manager record, or an embedded graphic object.

To cut to the clipboard

Select the object or text you want to cut.

From the Edit menu, select Cut (Alt, E, T). The selection is deleted and placed on the clipboard.

When you cut characters in a text object, the characters are deleted and placed on the 
Clipboard. The cut characters are then available for pasting to a new location in the same object or into 
another text object or List Manager record. When you cut merge fields, they are cut as characters, not 
fields. Use the Merge Fields commnad to replace the merge fields.

When you cut characters in a List Manager record, the characters are deleted and placed 
on the Clipboard. The cut characters are then available for pasting to a new location in the same record or 
into another record or object.

When you cut an object, the object is deleted and placed on the Clipboard. The object is 
then available for pasting to a new location in the same design or into another design.

Shortcuts: Ctrl+X
Shift+Del or Shift+Delete



Copy Command (Edit Menu)
Copies the selection onto the Clipboard. The selection can be an object, characters in a text object, 
characters in a List Manager record, or an embedded graphic object.

To copy to the clipboard

Select the object or text you want to copy.

From the Edit menu, select Copy (Alt, E, C). The selection is copied and placed on the clipboard.

When you copy characters in a text object, a copy of the characters is placed on the 
Clipboard. The copied characters are then available for pasting to a new location in the same object or 
into another text object or List Manager record. When you copy merge fields, they are copied as 
characters, not fields. Use the Merge Fields commnad to replace the merge fields.

When you copy characters in a List Manager record, a copy of the characters is placed 
on the Clipboard. The copied characters are then available for pasting to a new location in the same 
record or into another record or object.

When you copy an object, a copy of the object is placed on the Clipboard. The copied 
object is then available for pasting to a new location in the same design or into another design.

Shortcuts: Ctrl+C
Ctrl+Ins or Ctrl+Insert



Paste Command (Edit Menu)
Pastes the contents of the Clipboard into a List Manager record, object or design.

To paste text

Place the insertion point at the position in which you wish to paste the text.

On the Edit menu, select Paste (Alt, E, P). The text from the clipboard is pasted at the insertion point.

To paste an object

On the Edit menu, select Paste (Alt, E, P).

With the mouse, click the left button where you want the upper-left corner of the object.

Text may be pasted into a text object, or a List Manager record. The text is inserted at the 
insertion point. If any characters in the text object or book are selected, those characters are replaced 
with the Clipboard contents. When you paste merge fields, they are pasted as characters, not fields. Use 
the Merge Fields commnad to replace the merge fields.

Any kind of objects may be pasted into designs.

Shortcuts: Ctrl+V
Shift+Ins



Select All Command (Edit Menu)
Selects all the objects on the current design. 

To select all the objects on a design

On the Edit menu, select Select All (Alt, E, A). The sizing handles appear on all the objects to show 
that they are selected.

You can move all the objects together when they are all selected.



Bring to Front Command (Edit Menu)
Moves the selected object to the front of all the objects. See How to Select Objects .

To move an object to the front

On the Edit menu, select Bring to Front (Alt, E, F). The selected object is placed on top of all other 
objects.

Shortcut: Ctrl+=



Send to Back Command (Edit Menu)
Moves the selected object to the back of all the objects. See How to Select Objects .

To move an object to the back

On the Edit menu, select Send to Back (Alt, E, B). The selected object is placed behind all other 
objects.

Pressing the Ctrl key while you click an object is a shortcut for the Send to Back 
command. It moves the selected object to the back of the stack.

Shortcuts: Ctrl+-
Ctrl+Click



Properties Command (Objects Menu)
Brings up the Properties dialog box for the selected object. Each type of object has different 
properties.

To change the properties of an object

Select the object so that it's sizing handles show.

On the Objects menu, select Properties (Alt, O, P). The appropriate dialog box will appear.

Text object properties 

Graphic object properties 

Bar Code object properties 

Line object properties 

Shape object properties 



 Arrow Tool
Returns the cursor to the selection arrow from the text, graphics, or shape cursors.



 Text Tool and Text Command (Objects Menu)
Creates a Text object. The text in a text object can be the same for all labels or, if you use a merge or 
special field, can change from label to label. 

To create a Text object

Select the Text command on the Objects menu (Alt, O, T), or click the Text tool.

The cursor changes to show a small letter T, like this: 
Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the upper left corner of the Text object.

Press the left mouse button and drag the pointer to where you want the lower right corner of the Text 
object. Release the mouse button.

Make any changes you want to the Text properties.

You can use the Fonts command on the Text menu to change the size or style of the text 
in a Text object.

Double-click a Text object to edit the text it contains.

Click the right mouse button on a selected Text object (with the sizing handles visible) to 
get the Text Properties dialog box.

Click the right mouse button on a Text object with the insertion point visible to get the 
Font dialog box.



 Graphic Tool and Graphic Command (Objects Menu)
Creates Graphic objects. Graphic objects contain bit mapped pictures in BMP, PCX and TIFF file 
formats.

To create a Graphic object

Select the Graphic command on the Objects menu (Alt, O, G), or click the Graphic tool.

The cursor changes to show a small butterfly, like this: 
Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the upper left corner of the Graphic object.

Press the left mouse button and drag the pointer to where you want the lower right corner of the 
Graphic object. Release the mouse button.

Make any changes you want to the Graphic Properties.

Click the right mouse button on a Graphic object to get the Graphic Properties dialog box.

You can use as many Graphic objects as you like on a design.



 Bar Code Tool and Bar Code Command (Objects Menu)
Creates a Bar Code object. Bar Code objects print Code 39, Interleaved 2 of 5, UPC and EAN bar 
codes.

To create a Bar Code object

Select the Bar Code command on the Objects menu (Alt, O, B), or click the Bar Code tool.

The cursor changes to show a small bar code, like this: 
Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the upper left corner of the Bar Code object.

Press the left mouse button and drag the pointer to where you want the lower right corner of the Bar 
Code object. Release the mouse button.

Make any changes you want to the Bar Code Properties.

Double-click the Bar Code object to get the Bar Code Data dialog box.

Click the right mouse button on a Bar Code object to get the Bar Code Properties dialog 
box.



 Line Tool and Line Command (Objects Menu)
Creates straight line objects. Lines can be any of several widths.

To draw a straight Line object

Select the Line command on the Objects menu (Alt, O, L), or click the Line tool.

The cursor changes to show a line, like this: 
Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the line to start.

Press the left mouse button and drag the pointer to where you want the line to end. Release the 
mouse button.

Select the line width you want in the Line Properties.

Click the right mouse button on a Line object to get the Line Properties dialog box.

Drawing horizontal and vertical lines is easier if Snap to Rulers is selected in the Rulers 
dialog box.



 Rectangle Tool and Rectangle Command (Objects Menu)
Creates Rectangle objects, which are rectangles and squares with sharp corners. You can select 
between several line widths and various fill patterns.

To draw a Rectangle object

Select the Rectangle command on the Objects menu (Alt, O, R), or click the Rectangle tool.

The cursor changes to show the shape, like this:  

 

Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the upper left corner of the Rectangle.

Press the left mouse button and drag the pointer to where you want the lower right corner of the 
Rectangle. Release the mouse button.

Make any changes you want to the Shape Properties.

Hold the Shift key while you drag to create a square.

Click the right mouse button on a Rectangle object to get the Shape Properties dialog 
box.



 Rounded Rectangle Tool and Rounded Rectangle Command 
(Objects Menu)

Creates Rounded Rectangle objects, which are rectangles and squares with rounded corners. You 
can select between several line widths and various fill patterns.

To draw a Rounded Rectangle object

Select the Rounded Rectangle command on the Objects menu (Alt, O, D), or click the Rounded 
Rectangle tool.

The cursor changes to show the shape, like this:     

Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the upper left corner of the Rounded Rectangle.

Press the left mouse button and drag the pointer to where you want the lower right corner of the 
Rounded Rectangle. Release the mouse button.

Make any changes you want to the Shape Properties.

Hold the Shift key while you drag to create a square.

Click the right mouse button on a Rounded Rectangle object to get the Shape Properties 
dialog box.



 Ellipse Tool and Ellipse Command (Objects Menu)
Creates Ellipse objects, which are circles and ellipses. You can select between several line widths 
and various fill patterns.

To draw an Ellipse object

Select the Ellipse command on the Objects menu (Alt, O, E), or click the Ellipse tool.

The cursor changes to show an ellipse, like this: 

Press the Esc key if you want to change the cursor back to an arrow.

Move the mouse pointer to where you want the upper left corner of the bounding box that will enclose 
the Ellipse.

Press the left mouse button and drag the pointer to where you want the lower right corner of the 
bounding box that will enclose the Ellipse. Release the mouse button.

Make any changes you want to the Shape Properties.

Hold the Shift key while you drag to create a circle.

Click the right mouse button on a Ellipse object to get the Shape Properties dialog box.



 AutoMerge™ Tool
The AutoMerge™ button steps you through the merge process. 

To use the AutoMerge tool

Click on the AutoMerge button on the tool bar. 

The Link to List dialog box will appear if no lists are linked to the current design. Select a list to link 
and Click Ok.

The Merge Fields dialog box will appear. Add Merge Fields to the design.

AutoMerge works with List Manager lists as well as lists from other programs.

AutoMerge requires that the list (data file) already exist. If not create the data file first by 
using the List Manager from the Merge menu.

See How to use AutoMerge for more information.



 Print Tool
The print button prints one set or one page of the current design. 

To change the Print button settings

On the File menu, select Print (Alt,F,P). The Print dialog box appears. The Print tool uses the current 
settings from the print dialog box.



Properties Command (Text Menu)
Brings up the Text Properties dialog box for the selected text object.

To change the properties of a text object

Select the object so that it's sizing handles show.

On the Text menu, select Properties (Alt, T, P). The Text Properties dialog box dialog box will appear.



Fonts Command (Text Menu)
Allows you to change the font, size, color and style of the selected text or object using the Font dialog 
box.

To change the font

Select the text you want to change.

From the Text menu, select Fonts (Alt, T, F). The Font dialog box appears.

Select the object, so the sizing handles show, to change the font for all the lines in the 
text object.



Rotate Command (Text Menu)
Allows you to rotate text box to any angle.

To rotate text

Select the text object you want to rotate.

From the Text menu, select Rotate (Alt, T, R). The Rotate dialog box appears.



Date and Time Command (Text Menu)
Allows you to print the current date or time.

To print the date or time

Select the Date and Time command from the Text menu (Alt, T, D). The Date and Time dialog box 
appears.

You can print the date and/or time in any of several formats. 



Serial Number Command (Text Menu)
Allows you to print sequential numbers.

To print a serial number

Select the Serial Number command from the Text menu (Alt, T, S). The Serial Number dialog box 
appears.

You can change the starting number as well as the increment and length of the number. 



Postnet Command (Text Menu)
Displays the Postnet Properties dialog box.

To change the properties of a Postnet bar code

Select a text object that contains a Postnet bar code. You can add a Postnet bar code in the Text 
Properties dialog box.

Select the Postnet command on the Objects menu (Alt, O, P).

Make any changes you want to the Postnet Properties.

The Postnet bar code is placed in the Text object automatically, based on your settings in 
the Postnet Properties dialog box.

You can only use one Postnet bar code on a design.

The program automatically finds the Zip code in the text object. You don't have to worry 
about any special fields or merge codes.



Bold (Text Menu)
Changes the selected text to bold or, if the text is bold, changes it to normal.

You can only use the Fonts command to make other channges to selected text.

Shortcut: Ctrl+B



Italic (Text Menu)
Changes the selected text to italic or, if the text is italic, changes it to normal.

You can only use the Fonts command to make other channges to selected text.

Shortcut: Ctrl+I



Tools Command (View Menu)
Displays, hides and re-positions Designer's tools. You can hide Designer's tools to provide a larger 
work area for making designs, or to simply make Designer's window smaller. You can position 
Designer's tools along the top or left side of the window.

To change the way Designer's tools are displayed

On the View menu, select Tools (Alt V, T). The Tools Options dialog box appears.

All of the functions of the tools are provided on Designer's menus.



Ruler Command (View Menu)
Controls the appearance, function and display of Designer's rulers. You can change the graduations 
on the rulers, the units of measure, and you can turn the rulers on or off. You can also make object 
snap to the nearest ruler graduation.

To change Designers Rulers

On the View menu, select Rulers (Alt V, R). The Rulers dialog box appears.



Zoom Command (View Menu)
Allows you to    change the screen display size of the current design. You can change the screen 
design size    in the Zoom dialog box.

To zoom in/out on the current design

From the View menu, choose Zoom (Alt, V,Z). The Zoom dialog box appears.



Show Text Frames Command (View Menu)
Shows the non-printing frames around text objects.

To display text object frames

When Show Text Frames is un-checked, select Show Object Frames on the View menu (Alt V, F). 
The non-printing frames appear.

The object frames make it easier to align and place multiple objects on a design.

To hide text object frames

When Show Text Frames is checked, select Show Text Frames on the View menu (Alt V, F). The non-
printing frames disappear.



Show Guides Command (View Menu)
Displays or hides the guide lines that stretch from the selected object to the horizontal and vertical 
rulers.

To display the guides

When Show Guides is un-checked, select Show Guides from the View menu (Alt, V, G). The guides 
appear.

To hide the guides

When Show Guides is checked, select Show Guides from the View menu (Alt, V, G). The guides 
disappear.

The guides make it easier to position objects precisely on a design.



Show Status Bar Command (View Menu)
Displays or hides Designer's Status Bar. You can hide the Status Bar to make Designer's window 
smaller.

To change the Status Bar display

On the View menu, select Status Bar (Alt, S, S).

The Status bar is displayed when the Status Bar menu item is checked

The Status bar is hidden when the Status Bar menu item is not checked

The Status Bar provides the following information.

The description of the design you are using

The name of the Avery Product you are using

The file name of the list linked to your design

The pixel location of the upper-left corner of the selected object

The size in pixels of the selected object



Show Merge Fields / Show Merge Text Command (View Menu)
Controls whether field names or the text from a linked list appears in Designer's display. Merge 
graphics fields will only display the graphic in the first record.    Switching from field to test or text to 
field will not effect the graphic field display.

To switch from Field to Text view

On the View menu, select Show Text (Alt V, M). The display changes to show the first record.

To switch from Text view to Field view

On the View menu, select Show Field Names (Alt, V, M). The display changes to show the field 
names. 

Field names are displayed between double-caret characters.



 List Manager Command (Merge Menu)
Opens the List Manager window.

To open the List Manager

On the Merge menu, select Open List Manager (Alt, M, T). The List Manager window appears.



Link to List Command (Merge Menu)
Associates a list of information to a design so you can create a merge. 

To link a list of information to a design

On the Merge menu, select the Link to List command (Alt, M, L). The Link to List dialog box appears.

See How to Merge for more information



Merge Fields Command (Merge Menu)
Allows you to add merge fields from an associated data file to a Text object.

To add merge fields

Select the Merge Fields command on the Merge menu (Alt, M, M). The Merge Fields dialog box 
appears.

See How to Merge for more information



Filter Command (Merge Menu)
Allows you to select certain records from a list of information to print.

To create a merge filter

From the Merge Menu, select the Merge Filter command (Alt M, F). The Filter dialog box appears.

For more information, see How to Select Records.



Contents Command (Help Menu)
Displays Help's table of contents. From the table of contents, you can jump to step-by-step 
instructions for using the program and various types of reference information.

To see Help's table of contents

On the Help menu, select the Contents command (Alt, H, C).

Once you open Help, you can click the Contents button in the Help window whenever you 
want to return to the table of contents.

Pressing F1 in the program provides help for the window you are working in.



Search for Help On Command (Help Menu)
Displays Help's Search dialog box. You can search for any subject covered by help.

To search for a help topic

On the Help menu, select the Search for Help On command (Alt, H, S).

Once you open Help, you can click the Search button in the Help window whenever you 
want to search for a topic.

Pressing F1 in the program provides help for the window you are working in.



Commands Command (Help Menu)
Displays Help's list of the menu commands. Each of these topics describes one of the commands on 
the menus.

To see Help's list of commands

On the Help menu, select the Commands command (Alt, H, M).

Once you open Help, click the Contents button, then select Menu Commands to see the 
list of Commands.



Procedures Command (Help Menu)
Displays Help's list of How-To topics. Each of these topics provides step-by-step procedures for 
performing a task.

To find out "How To"

On the Help menu, select the Procedures command (Alt, H, P).

Once you open Help, click the Contents button, then select Procedures to see the list of 
How To's.



QuickSteps Command (Help Menu)
Displays a list of topics that are covered in QuickSteps. QuickSteps provide brief reminders of the 
steps required to complete a task.

To use QuickSteps

On the help menu, select the QuickSteps command (Alt, H, Q)

Once you open Help, simply click the QuickSteps icon, where it is available, to display 
the QuickSteps for that topic.

 Click this QuickSteps button to see a list of the QuickSteps available to you.



How to Use Help Command (Help Menu)
Displays Help's Contents for How to Use Help. Look here to see how to use the Help system.

To learn how to use Help

On the Help menu, select the How to Use Help command (Alt, H, H).

Once you open Help, press F1 any time to see how to use Help.



About LabelPro Command (Help Menu)
Displays the copyright notice and version number of your copy of LabelPro.

To find out About LabelPro

On the help menu, select the About LabelPro Command (Alt, H, A).



New List Command (File Menu)
Creates an new List Manager list.

To create a new list

Select New List from the File menu (Alt, F, N). The New List dialog box appears.



Open List Command (File Menu)
Opens an existing list using the File Open dialog box.

To open a list.

From the File menu, choose Open (Alt, F, O).

Then choose the file you want to open using the File Open dialog box.

Use the New List command to create new lists.



Save List As Command (File Menu)
Saves the active list with a new name, thereby making a copy of the list.

To save a document with a new name

From the File menu, choose Save As (Alt, F, A).

The Save As dialog box appears. Enter the new file name, and save the file.



Print Command (File Menu)
Prints the current design. You can change the printing options in the Print dialog box.

To print the current design

From the File menu, choose Print (Alt, F, P). The Print dialog box appears.

You can print multiple copies and select other printing options.



Print Listing Command (File Menu)
Prints the current list in a report format.

To print a listing of the current list

From the File menu, choose Print Listing (Alt, F, L). The Print Setup dialog appears.

The Print Listing command provides a simple way to print a list of all the records in a list.



Exit Command (File Menu)
Closes the List manager window

To close the current window

From the File menu, choose Exit (Alt, F, X). The List Manager window closes.

Changes you have made to an open list are automatically saved.

Shortcut: Alt+F4



 Cut Command (Edit Menu)
Removes the selection from the document and places it onto the Clipboard. The selection can be an 
object, characters in a text object, characters in an Address Book or List Book, or an embedded graphic 
object.

To cut to the clipboard

Select the object or text you want to cut.

From the Edit menu, select Cut (Alt, E, T). The selection is deleted and placed on the clipboard.

When you cut characters in a text object, the characters are deleted and placed on the 
Clipboard. The cut characters are then available for pasting to a new location in the same object or into 
another text object or book.

When you cut characters in an Address Book or List Book, the characters are deleted 
and placed on the Clipboard. The cut characters are then available for pasting to a new location in the 
same Address Book or List Book or into another book or object.

When you cut an object, the object is deleted and placed on the Clipboard. The object is 
then available for pasting to a new location in the same design or into another design.

Shortcuts: Ctrl+X
Shift+Del or Shift+Delete



Copy Command (Edit Menu)
Copies the selection onto the Clipboard. The selection can be an object, characters in a text object, 
characters in an Address Book or List Book, or an embedded graphic object.

To copy to the clipboard

Select the object or text you want to copy.

From the Edit menu, select Copy (Alt, E, C). The selection is copied and placed on the clipboard.

When you copy characters in a text object, a copy of the characters is placed on the 
Clipboard. The copied characters are then available for pasting to a new location in the same object or 
into another text object or book.

When you copy characters in an Address Book or List Book, a copy of the characters is 
placed on the Clipboard. The copied characters are then available for pasting to a new location in the 
same Address Book or List Book or into another book or object.

When you copy an object, a copy of the object is placed on the Clipboard. The copied 
object is then available for pasting to a new location in the same design or into another design.

Shortcuts: Ctrl+C
Ctrl+Ins or Ctrl+Insert



Paste Command (Edit Menu)
Pastes the contents of the Clipboard into an Address Book, List Book, object or design.

To paste text

Place the insertion point at the position in which you wish to paste the text.

On the Edit menu, select Paste (Alt, E, P). The text from the clipboard is pasted at the insertion point.

To paste an object

On the Edit menu, select Paste (Alt, E, P).

With the mouse, click the left button where you want the upper-left corner of the object.

Text may be pasted into a text object, an Address Book or a List Book. The text is 
inserted at the insertion point. If any characters in the text object or book are selected, those characters 
are replaced with the Clipboard contents.

Any kind of objects may be pasted into designs.

Shortcuts: Ctrl+V
Shift+Ins



Select Record Command (Edit Menu)
Selects all the fields in the current record. This allows you to easily copy or delete (cut) a record.

To copy a record

With the record you want to copy displayed, choose Select Record on the Edit menu (Alt, E, S). The 
entire record is highlighted.

From the Edit menu, select the Copy command (Ctrl + C).

Click the New button to create a new, blank record.

Select Paste from the Edit menu (Ctrl + V). 

To delete a record.

With the record you want to delete displayed, choose Select Record on the Edit menu (Alt, E, S). The 
entire record is highlighted.

From the Edit menu, select the Cut command (Ctrl + X).



Field Names (Edit Menu)
Allows you to change the filed names in a List Manager list.

To change field names

With the list you want to change open, choose Field Names on the Edit Menu (Alt, E, N). The List 
Manager window changes so you can change the field names. 

Change any or all of the filed names. Move between field names with Tab and Shift+Tab.

When you have made all the changes, click the Edit Reocrd button to return the List Manager window 
to it's normal state.

You don't need to save your changes, the program saves List Manger changes 
automatically.

To copy all the field names from one List Manger file to a new, empty file, use the New 
List command. 

For more information, see How to Change Field Names.



Find Command (Edit Menu)
Locates records in a list.

To find a record in a list

With the list which contains the record you want to find open, choose Find on the Edit Menu (Alt, E, 
F). The Find dialog box appears. 

Enter any text contained in the record and click OK. 

The text you enter can be contained anywhere in a field; it does not have to be at the 
beginning of the field.

Find starts at your current position in the file, and searches to the end of the file. To find 
additional records with the same text just press the Find Next button. Find Next will wrap to the beginning 
of the file to continue the search. 



Filter Command (Record Menu)
Allows you to select certain records from a list.

To create a filter

From the Record Menu, select the Filter command (Alt R, F). 

Use the Filter dialog box to create a filter.

For more information, see How to Select Records.



Filter Active Command (Record Menu)
Turns a filter on or off.

To turn the filter on

From the Record menu, select the Filter Active command (Alt, R, A) so the command is checked.

To turn the filter off

From the Record menu, select the Filter Active command (Alt, R, A) so the command is not checked.

For more information, see How to Select Records.



Sort Command (Record Menu)
Sets the order of records in a list.

To sort a list

From the Record menu, select the Sort command (Alt, R, S).

Use the Sort dialog box to set the sort order.

For more information, see How to Sort Records.

The program always sorts on a character-by-character basis. If you are sorting two 
numbers, the program begins by comparing the leftmost digit of the first number with the leftmost digit of 
the second number. Thus numbers of different lengths might not sort the way you expect. Numbers that 
are the same length sort correctly, so you can add leading zeros to make all your numbers the same 
length. Likewise, dates might not sort the way you expect unless you enter the year first, the month 
second, and the day last (using 2 digits for each field).



Mark all for Printing Command (Record Menu)
Sets the Mark for Printing flag of all the records in the current filter set.

To mark the current set of records for printing

From the Record menu, select the Mark all for Printing Command (Alt, R, M).

All the records that match the current filter (or all the records in the file if a filter is not on) have their 
Mark for Printing flags set.



Unmark all for Printing Command (Record Menu)
Clears the Mark for Printing flag of all the records in the current filter set.

To clear the Mark for Printing flag of the current set of records

From the Record menu, select the Unmark all for Printing Command (Alt, R, U).

All the records that match the current filter (or all the records in the file if a filter is not on) have their 
Mark for Printing flags cleared.



Contents Command (Help Menu)
Displays Help's table of contents. From the table of contents, you can jump to step-by-step 
instructions for using the program and various types of reference information.

To see Help's table of contents

On the Help menu, select the Contents command (Alt, H, C).

Once you open Help, you can click the Contents button in the Help window whenever you 
want to return to the table of contents.

Pressing F1 in the program provides help for the window you are working in.



Search for Help On Command (Help Menu)
Displays Help's Search dialog box. You can search for any subject covered by help.

To search for a help topic

On the Help menu, select the Search for Help On command (Alt, H, S).

Once you open Help, you can click the Search button in the Help window whenever you 
want to search for a topic.

Pressing F1 in the program provides help for the window you are working in.



Commands Command (Help Menu)
Displays Help's list of menu commands. Each of these topics describes one of the commands on the 
menus.

To see Help's list of commands

On the Help menu, select the Commands command (Alt, H, M).

Once you open Help, click the Contents button, then select Commands to see the list of 
Commands.



Procedures Command (Help Menu)
Displays Help's list of How-To topics. Each of these topics provides step-by-step procedures for 
performing a task.

To find out "How To"

On the Help menu, select the Procedures command (Alt, H, P).

Once you open Help, click the Contents button, then select Procedures to see the list of 
How To's.



QuickSteps Command (Help Menu)
Displays a list of topics that are covered in QuickSteps. QuickSteps provide brief reminders of the 
steps required to complete a task.

To use QuickSteps

On the help menu, select the QuickSteps command (Alt, H, Q)

Once you open Help, simply click the QuickSteps icon, where it is available, to display 
the QuickSteps for that topic.

 Click this QuickSteps button to see a list of the QuickSteps available to you.



How to Use Help Command (Help Menu)
Displays Help's Contents for How to Use Help. Look here to see how to use Help system.

To learn how to use Help

On the Help menu, select the How to Use Help command (Alt, H, H).

Once you open Help, press F1 any time to see how to use Help.



Restore Command (Control Menu)
Restores the window to the size and location it had before you maximized or minimized the window.

To restore the active window

On the Control menu, select the Restore Command (Alt, Space, R).

To restore a minimized window, click the icon and choose the Restore command, or 
double-click the icon.

Restoring a window does not affect changes made to the window with the Move or Size 
commands on the Control menu.



Move Command (Control Menu)
Displays a four-headed arrow. Use the arrow keys to move the active window or open dialog box.

To move the active window

On the Control menu, select the Move Command (Alt, Space, M).

Use the Arrow keys to move the active window.

If the window is maximized, this command is unavailable.

You can also move a window that is not maximized, or an open dialog box, by dragging 
the title bar.



Size Command (Control Menu)
Displays a four-headed arrow you can use to change the size of the active window. Press the arrow 
key (RIGHT, LEFT, UP, or DOWN) of the side you want to size, and the mouse pointer changes to an 
arrow. You can then use the arrow keys to make the window the size you want.

To change the size of the active window

On the Control menu, select the Size Command (Alt, Space, M).

Use the Arrow keys to change the size of the active window.

If the window is maximized, this command is unavailable.



Minimize Command (Control Menu)
Shrinks the active window to an icon. Clicking the Minimize button is the same as choosing the 
Minimize command.

To minimize the active window

On the Control menu, select the Minimize Command (Alt, Space, N).

Double-clicking a minimized window icon restores the window to its former size. You can 
also restore a minimized window by using the Restore command on the Control menu.



Maximize Command (Control Menu)
Enlarges the active Designer window to fill the available space. Clicking the Maximize button is the 
same as choosing the Maximize command.

To maximize the active window

On the Control menu, select the Maximize Command (Alt, Space, X).

The Designer window fills the entire screen.

You can restore a maximized window to its former size by using the Restore command on 
the Control menu.



Close Command (Control Menu)
Closes the active window, or an open dialog box. Double-clicking the Control-menu box is the same 
as choosing the Close command.

To close the active window

On the Control menu, select the Close Command (Alt, Space, C).

Closing the Tool Bar closes all of the program's windows.

Closing a window is the same as choosing the Exit command from that window's File 
Menu.

Shortcut: ATL+F4 



Switch To Command (Control Menu)
Displays the Task List dialog box of Windows Program Manager.

To Switch to a different application

On the Control menu, select the Switch To Command (Alt, Space, W).

Select the next application in Task List and click Switch To.

For more information, see your Windows documentation.

Shortcut: Ctrl+Esc

 



Adding a Graphic

Follow these steps to add a graphic to your design.

1. Click the Graphic tool

Or Select Objects--Graphic.

2. Drag the graphic object's bounding box.

3. In the Graphic properties dialog box enter a file name

Or use the Browse button to find a file.

Or click the Paste button if you have a graphic on the clipboard.

Or select the Merge option and click the Merge button if you want to print different graphics on each 
label.

4. Select a Sizing Option and click OK.



Adding Lines

Follow these steps to add lines to your design.

1. Click the Line tool

Or Select Objects--Line.

2. Drag the Line object's bounding box.

3. In the Lines Properties dialog box select the appearance options you want and click OK.



Adding Text

Follow these steps to add text to your design.

1. Click the Text tool

Or Select Objects--Text.

2. Drag the text object's bounding box.

3. In the Text properties dialog box select the alignment options you want and click OK.

4. Type the text you want in the text object.



Adding Shapes

Follow these steps to add shapes (Rectangles, Rounded Rectangles or Ellipses) to your design.

1. Click the Rectangle, Rounded Rectangle or Ellipse tool

Or Select Objects--Rectangle, Rounded Rectangle or Ellipse.

2. Drag the Rectangle, Rounded Rectangle or Ellipse object's bounding box.

3. In the Shapes Properties dialog box select the appearance options you want and click OK.



AutoMerge Overview

Follow these steps to use AutoMerge.

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set the file type (Txt, CSV, etc.).

3. Select the file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



Delimited (CSV) File Merge

Follow these steps to merge a delimited (CSV) file. 

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set List Files of Type to Delimited (*.csv, *.txt).

3. Select the file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



Calibrating Your Printer

Follow these steps to calibrate The program to your printer.

1. Select File--Print Calibrate.

2. Load a Calibration Sheet into your printer's paper tray.

3. Click the Print Pattern button.

4. Enter the calibration numbers from the calibration sheet and click OK.



Changing Field Names

Follow these steps to Change Field Names.

1. Select Edit--Field Names.

2. Change the field names.

3. Click the Edit Record button. 



Changing Fonts

Follow these steps to change fonts in your design.

1. Highlight the text that you want to format.

2. Click the right mouse button

Or Select Text--Fonts.

3. Make the changes to the Fonts dialog box and click OK.



Checking Records in a List

Follow these steps to be sure all the records in your list fit your design.

1. Select File--Print Preview.

2. In the Print Preview dialog box, select Clip Text or Shrink to Fit.

3. Make sure that Report Clipping or Report Shrinking is checked.

4. Click the Scan button to check all the records automatically

Or click the Next button to check each record individually. 



Creating a Design

Follow these steps to create a design.

1. Select File--New Design

2. Choose a product Type.

3. Choose a particular Avery Product and click OK.

4. You can simply start typing in the default Text Object

Or add other objects to your design.



Creating a Filter

Follow these steps to Select records to print.

1. Select Merge--Filter (in Designer)

Or Select Record--Filter (in List Manager).

2. Choose a field to select on.

3. Set the first condition and enter a value.

4. Select And or Or (if necessary).

5. Set the second condition and enter a value (if necessary).

6. Click the Add button to add your criteria to the list.

7. Repeat steps 2 through 7 to add additional conditions.



Creating a New List

Follow these steps to create a new list.

1. Select Merge--List Manager.

2. In the List Manager, select File--New List.

3. Select the list from which you want to copy the field names in Use Field Names From.

4. Enter a file name for the list you are creating.

5. Click OK.

6. Enter the information for your new list.



dBASE Merge

Follow these steps to merge a dBASE file.

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set List Files of Type to dBASE (*.dbf).

3. Select the dBASE data file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



List Manager Merge

Follow these steps to merge a List Manager file.

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set List Files of Type to LabelPro (or Label Assistant) List (*.avd).

3. Select the file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



Paradox Merge

Follow these steps to merge a Paradox file.

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set List Files of Type to Paradox (*.db).

3. Select the Paradox data file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



Printing a List

Follow these steps to print a list.

1. Create or open a design that is linked to the list.

2. Select File--Print.

3. Set the number of sets, the printing order and other options.

4. Click OK to print.



Postnet Bar Codes

Follow these steps to print a Postnet bar code 

1. Create a label design that includes a Text object.

2. Select the text object (so the sizing handles show) and click the right mouse button.

Or When there is an insertion point in the object, or when the sizing handles show, select Objects-
Properties.

3. Select the Add Postnet option.

4. Click the Postnet button. 

5. Select the position you want.



Sorting a List

Follow these steps to sort a list.

1. Open the list in List Manager.

2. Select Record--Sort.

3. Choose Ascending or Descending sort order.

4. In the Sort dialog box, select the field you want to sort on.

5. Click the Add button to add it to the list of Sort Criteria.

6. Repeat steps 4 and 5 any additional fields you want to sort on.

7. Click OK to do the sorting.



Word for Windows Merge

Follow these steps to merge a WinWord file.

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set List Files of Type to Word, WinWord (*.doc).

3. Select the WinWord data file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



WordPerfect Merge

Follow these steps to create a WordPerfect Merge 

1. Click the AutoMerge button on the tool bar..

2. In the Link to List dialog box, set List Files of Type to WordPerfect (*.*).

3. Select the WordPerfect secondary merge file you want to merge and click OK.

4. Use the Merge Fields dialog box to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



Merge Overview

Follow these steps to merge a file.

1. Create a design.

2. Add a text object to contain the merge fields.

3. Use Merge-Link to List to link a file.

4. Use Merge--Merge Fields to add the merge fields.

5. Select File--Print Preview to check your design.

6. Select File--Print to print your list.



Notes Merge

Follow these steps to  Merge a Notes Database.

1. Click the Notes AutoMerge button on the tool bar..

2. In the Link to Notes dialog box, select the view or form you want to merge.

3. Use the Merge Fields dialog box to add the merge fields.

4. Select File--Print Preview to check your design.

5. Select File--Print to print your list.

 



AutoMerge™
The AutoMerge™ button steps you through the process of merging a list with a design.



Bar Code Object
A type of object that encodes numbers (and letters) in bars for automated reading. LabelPro prints the 
following types of bar codes. 
Code 39
Interleaved 2 of 5
EAN-8
EAN-13
UPC-A
UPC-E



Calibration Sheet
The Calibration Sheet is pre-printed with three sets of blue and red lines that help you to calibrate the 
program to your particular printer. See How to Calibrate the program    to your Printer.



Click
To press and release a mouse button in one nonstop motion.



Clip
To cut off the right end, or bottom of text that doesn't fit in a text object. The program gives you the 
option to clip text or to shrink to fit    text in the text object.



Color
The program can print text, shapes, and graphics in color on a color printer.    You can also use the 
color option in properties to add color to text and shapes objects.



Copy
To duplicate selected text or a selected object from a design so you can paste it to another place in 
the design or to another design.

The copied information is placed in a temporary storage area called the clipboard. The clipboard 
holds the information until you cut or copy another piece of text or object.



Clipboard
A temporary storage area for cut or copied text or graphics. You can paste the contents of the 
Clipboard into a design or book, or into another application. The Clipboard holds the information until 
you cut or copy another piece of text or a graphic.



Cut
To remove selected text or a selected object from a design so you can paste it to another place in the 
design or to another design.

The cut information is placed in a temporary storage area called the clipboard. The clipboard holds 
the information until you cut or copy another piece of text or object.



Drag
To hold down the mouse button while moving the mouse.



Description
Design files include a description that can help you remember what information is in that file. Use the 
Save Design As command to add or change a description. Use the Descriptions button in the File 
Open dialog box to open files by their description.



Design
Objects placed on a label or other product that tell the program how to print that product. Designs can 
include text objects , graphic objects , bar code objects , line objects , and shape objects . Designs 
are saved in design files, and can be opened with the Open Design command.



Font
The general shapes for a set of characters. Each font has a name with which you can select the font 
and apply it to text. Arial and Times New Roman are examples of fonts.



Graphic Object
A Graphic Object is a rectangular region on a design that contains graphics. The graphic can be of 
several types, including BMP, EPS, GIF, IMG, JPG, PCX, TGA, TIF, WMF and WPG.



Insertion Point
The insertion point is the point at which text will be placed when you type. It is indicated by a vertical 
blinking bar. 

Click twice in a Text object to see the insertion point.



Landscape
A term used to refer to horizontal label orientation; opposite of "portrait," or vertical, orientation. In this 
program, orientation refers to the individual label or other product you are working on, not the full 
sheet. 



Line Object
A line object prints a line on a design. Lines can be of various widths, and can be placed in any 
direction.



Link
To associate a list, or data file with a design. A design will print the information contained in a list that 
is linked to it.



List
A data file. You can create lists with the List Manager, or you can print lists created by other programs 
with the program.



Menu
A list of commands that drops down from the menu bar. The menu bar is displayed across the top of 
an application window and lists the menu names, such as File and Edit.



Merge
To Merge information, is to add it to the design as printing is occurring. Merge information can come 
from a list, or data file, as when you print mailing labels.



Merge Field 
A token that indicates to the program where in a text object a particular item of information will be 
placed. The program can display the merge fields or the text of the list.



Merge Graphic
You can print different graphics on each label. Pust the nameof the files to merge in a data file, then 
use the Merge option in the Graphic Properties dialog box to merge the field with the file names. You 
must have a list linked to your design before the Merge option is available in Graphic Properties.



Object
One of the several graphic elements that may be added to LabelPro designs. The types of objects 
that LabelPro supports include:

Text objects Line Objects 

Graphic objects Shape objects 

Bar Code objects 

Path Name
The complete identification of a file. A typical path name is:

 C:\LPWIN\ART\BOAT.WMF



Paste
To insert cut or copied text into a document from the temporary storage area called the Clipboard.



Point Size
A measurement used for the size of text characters. There are 72 points per inch.



Portrait
A term used to refer to vertical label orientation; opposite of "landscape," or horizontal, orientation. In 
this program, orientation refers to the individual label or other product you are working on, not the full 
sheet. 



Postnet Bar Code
The United States Postal Service bar code which the program can print in a Text object. 



Select
To highlight text or an object. Once text or an object is selected you can move or act on it in various 
ways. See also How to Select Objects and How to Select Text.



Shape Object
A shape object prints a rectangle, a round-cornered rectangle, or an ellipse on a design.



Shrink to Fit
To reduce the size of text that doesn't fit in a text object. The program gives you the option to clip text 
or to shrink to fit text in the text object.



Sizing Handles
Eight markers that appear on an object's frame when it is selected. They are used to change the size 
or shape of an object.



Text Object
A text object is a rectangular region of a design which contains text or merge fields. 



Text Rotation
LabelPro can rotate text to any angle. There is a Rotate button in the Text Properties dialog box and a 
Rotate command on the Text menu.



Tool
One of the icon buttons in the Designer window. 



Undo
You can undo, or change back, the most recent editing operation.    See the Undo command on the 
Edit menu.



Zoom
You can view your design at any size from 25% to 400% of actual size. See the Zoom command on 
the View menu.

 





How to Add a Bar Code
Follow these steps to add a bar code to your design.

1.  Click the Bar Code tool, or use the Bar Code command, to add a Bar Code Object to your 
label design. 

2. The cursor changes to show a small bar code, like this: 

Press the Esc key if you want to change the cursor back to an arrow.

3. Place the cursor's cross at the point where you want the upper-left corner of the bar code 
object. Drag to the point where you want the lower-right corner of the bar code object. 

4. The Bar Code Properties dialog box appears. Select the type of bar code you want to print. 

5. Generally, the default values for the settings in the Bar Code Properties dialog box are 
correct, but you can make any changes you want. Select any other options you want in the 
Bar Code Properties dialog box. 

6. Click the Data button to see the Bar Code Data dialog box. Use this dialog box to determine 
what information will be printed.



How to Add a Border
There are two ways to create borders in the program. You can use one of the shape tools to create a 
rectangle, rounded rectangle or ellipse. You can also use a graphic to create a border. Some of the 
clip-art furnished with the program is specifically designed to create borders.

Follow these steps to use a shape as a border.

1. Create a label design. (See How to Create a Design.)

2. Click the appropriate tool for the shape of border you want to use. Choose between the 
Rectangle Tool, the Rounded-Rectangle Tool, or the Ellipse Tool. 

3. The cursor changes to show the shape, like this:  

 

Press the Esc key if you want to change the cursor back to an arrow.

4. Place the cursor's cross at the point where you want the upper-left corner of the border. Drag 
to the point where you want the lower-right corner of the border. 

5. When the Shape Properties dialog box appears, make the selections you want for this object.

Follow these steps to use a graphic as a border.

1. Create a label design. (See How to Create a Design.)

2.  Click the Graphic tool, or use the Graphic command, to add a Graphic object to your label 
design. 

3. The cursor changes to show a small graphic, like this: 

Press the Esc key if you want to change the cursor back to an arrow.

4. Place the cursor's cross in the upper-left corner of the design, leaving a slight top and left 
margin. Drag to the lower-right corner of the design, leaving a slight bottom and right margin.

5. When the Graphic Properties dialog box appears, enter the file name of the graphic you want 
to print. You can click the Browse button to use the File Open dialog box to locate the file. The 
graphics that are designed to create borders are:

angle.pcx corner.pcx

bar.pcx shadow.pcx

box.pcx

6. Select the Fill Graphic Frame option and click OK.

Place all the other objects in your design on top of the object that forms the border.



 How to Add a Graphic
The program can print graphics in BMP, EPS, GIF, IMG, JPG, PCX, TGA, TIFF, WMF and WPG 
formats and can change the size and shape of your graphics. 

Follow these steps to add a graphic image to your design.

1. Create a label design. (See How to Create a Label Design.)

2.  Click the Graphic tool, or use the Graphic command, to add a Graphic object to your label 
design. 

3. The cursor changes to show a small graphic, like this: 

Press the Esc key if you want to change the cursor back to an arrow.

4. Place the cursor's cross at the point where you want the upper-left corner of the graphic 
object. Drag to the point where you want the lower-right corner of the object. 

5. When the Graphic Properties dialog box appears, enter the file name of the graphic you want 
to print. You can click the Browse button to use the File Open dialog box to locate the file.    
The Art directory under the LPWIN directory contains clip art graphics from Avery.

Or

If you have a graphic object on the clipboard, click the Paste button to paste the graphic on 
the label. The program automatically creates a file for the graphic image.

Or

If you wish to print a different image on each product, select the Merge option, and see How 
to pinrt different graphics on each label.

6. Select the sizing option you want in the Graphic Properties dialog box.

To print part of a graphic, see How to Print Part of a Graphic.

To merge graphics, see How to pinrt different graphics on each label.

Click here to see how the program finds graphic files.



How to Add a Line 
Follow these steps to add a line to your design.

1. Click on the line tool.

2. The cursor changes to show a line, like this: 

Press the Esc key if you want to change the cursor back to an arrow.

3. Place the cursor's cross at the point where you want the upper-left end of the line. Drag to the 
point where you want the lower-right end of the line. 

4. When the Line Properties dialog box appears, select the thickness and/or color you want for 
this line.



 How to Add a Postnet Bar Code
Postnet bar codes are always placed in a text object. When a nine-digit zip code is found in the text 
object, the program prints a delivery point Postnet bar code. Optionally, the program can print a bar 
code for 5-digit zip codes.

Follow these steps to add a Postnet bar code to your design.

1. Create a label design that includes a Text object. (See How to Create a Label Design.)

2. Select the text object (so the sizing handles show) and click the right mouse button.

Or

When there is an insertion point in the object, or when the sizing handles show, select the 
Properties command from the Objects menu.

3. In the Text Properties dialog box, select the Add Postnet option.

4. Click the Postnet button to see the Postnet Properties dialog box. Select the position you 
want.

The program automatically finds the Zip code in the text object. You don't have to worry 
about any special fields or merge codes.

If you get a message telling you that your Postnet bar code won't fit on the label, simply 
move or re-size the Text object to allow more room.

The United States Postal Service prefers that the bar code be positioned above the 
address, but they accept either position.

Delivery point Postnet bar codes encode not only the nine-digit zip code, but also the last 
two digits of the street address, so that the Postal service can sort the mail completely automatically.

For more information, see How to Address for Postal Automation 



How to Add a Serial Number
Serial numbers are always placed in a text object. 

Follow these steps to add a serial number to your design.

1. Create a label design that includes a Text object. (See How to Create a Label Design.)

2. Click twice in the text object so you see the insertion point. Place the insertion point where you 
want the serial number.

3. Choose the Serial Number command from the Text menu.

4. In the Serial Number dialog box, enter the starting number, and make any other changes you 
want.

5. Use the Font button to change the font of the serial number.

Characters that you type in the Prefix box are printed immediately in front of the serial 
number. Characters that you type in the Suffix box are printed immediately after the serial number. Use 
these for parts of the serial number that do not change.

The setting you make for Length of Serial Number has no effect unless you choose Zeros 
or Spaces in the Padding group.

You can use a negative number for an Increment.

If the serial number exceeds the length you specify, it will roll over to 0. For example, if 
you set the Length of Serial Number to 3, the number after 999 will be 000.



How to Add a Shape (Rectangles and Ellipses)
Shape objects include Rectangles, Rounded Rectangles, and Ellipses. Squares and Circles are made 
using the Rectangle and Ellipse tools with the Shift key held down.

Follow these steps to add a shape to your design.

1. Click on the tool that represents the shape you want to draw. The choices are:

Rectangle

Use the Rectangle tool to draw rectangles and 
squares with sharp corners.

Rounded Rectangle

Use the Rounded Rectangle tool to draw 
rectangles and squares with rounded corners.

Ellipse

Use the Ellipse tool to draw ellipse and 
circles.

2. The cursor changes to show the shape, like this:  

 

Press the Esc key if you want to change the cursor back to an arrow.

3. Place the cursor's cross at the point where you want the upper-left corner of the shape. Drag 
to the point where you want the lower-right corner of the shape. 

4. When the Shape Properties dialog box appears, make the selections you want for this object.

To create a square or a circle, hold the Shift key down while you drag to form the shape.

Shapes, and their backgrounds can be printed in color if you have a color printer. See 
How to Add Color.



How to Add Color
Text, shapes and graphics can all be printed in color, if you have a color printer. 

Follow these steps to change the color for part of the text in an object

1. Select the text that's font you want to change. 

2. Click the right mouse button, or select the Fonts command from the Text menu.

3. Choose the new color from the Font dialog box.

4. Click OK when your selection is complete.

Follow these steps to change the color for all the text in an object

1. Select the object (so the sizing handles show) in which you want to change the font of all the 
text.

2. Select the Fonts command from the Text menu.

3. Choose the new color from the Font dialog box.

4. Click OK when your selection is complete.

Follow these steps to change the color of a shapes outline or fill

1. Select the object (so the sizing handles show) for which you want to change the color.

2. Click the right mouse button, or select the Properties command from the Object menu.

3. Choose the new colors from the Shape Properties dialog box. Colors can be set with both the 
Line Color and the Fill drop-down lists.

4. Click OK when your selection is complete.

The program prints color graphics in color if you have a color printer. You cant change 
color graphics in the program, you must use an image editing program.



 How to Add Text
Follow these steps to add text to your design.

1. Create a label design. (See How to Create a Label Design.)

2.  Click the Text tool, or use the Text command, to add a Text object to your label design. 

3. The cursor changes to show a small letter T, like this: 

Press the Esc key if you want to change the cursor back to an arrow.

4. Place the cursor's cross at the point where you want the upper-left corner of the fixed text 
object. Drag to the point where you want the lower-right corner of the object. 

5. When the Text Properties dialog box appears make the selections you want for this object.

6. Type the text you want in the text object. 

You can change the font with the Font command.

To edit the text in a fixed text object, click twice in the object.



How to Address for Postal Automation
The program provides several ways to increase your mailing efficiency. You can print delivery point 
bar codes for faster mail delivery and possible postage discounts, or you can use the Postal Address 
font for improved machine processing of your mail.

Using Delivery Point Bar Codes

You get the greatest postage discounts by using DPBC, which adds two digits (usually the last two 
digits of the street address) to the ZIP+4 code. See How to Add a Postnet Bar Code.

Because of variations in the rules for determining the DPBC (and the fact that ZIP+4 codes 
sometimes change), each address in your database must be periodically checked against a current 
USPS database of addresses and ZIP codes. This process is called CASS certification.

Mailing-list vendors can provide CASS certification, or you can send your list to any of several service 
bureaus that can update your list with the current DPBCs and provide certification. Alternatively, if you 
have a CD-ROM drive, you can purchase software and quarterly database updates that allow you to 
maintain your own mailing list. You'll need CASS certification to obtain postage discounts.

Remember that the program is a label printing program; it is not a list management program. The 
program is not CASS certified, nor does it need to be for you to receive postage discounts. CASS 
certifies that your addresses are accurate, which is something that the program has no control over. 
The list that you merge into the program must be certified--not the program.

Selecting Labels for Bar-Coded Addressing

If you use DPBC bar codes, the bar code will be about 2½ to 3 inches wide. Keep this in mind when 
you choose labels to print on. For example, Avery 5160 labels (3 across on an 8½-inch by 11-inch 
sheet) are not wide enough to contain a bar code. You'll need to use 2-across laser-printer labels 
(such as 5161, 5162, or 5163). If you use a dot matrix printer to print on continuous labels, be sure 
you select a label that is at least 3 inches wide.

Printing OCR-Readable Addresses

The U.S. Postal Service has specific guidelines for creating machine-readable addresses. These 
guidelines are summarized in USPS Publication 25, Designing Business Letter Mail, which is 
available from the Postal Service.

To qualify for certain postage discounts and to expedite mail processing, you can use the Postal font 
provided with this version of the program. When used according to the instructions in How to use the 
Postal Address Font, this font prints labels that are machine readable.

What's Different About the Postal Address Font?

The Postal Address font is based on a standard Arial font. It's different in the following respects: 

All letters print as capital letters, regardless of how you enter them. This allows you to 
enter List Manager records, for example, in upper- and lowercase letters, and have them print in all 
capital letters whenever you print mailing labels--but not when you use them for other purposes.

The space between characters and between words has been increased. This ensures 
accurate machine readability.

Foreign language and other special characters are not included. Because foreign 
language characters and symbols such as bullets, the copyright symbol, and so on, are not usually used 
in addressing (and are not recognized by the Postal Service address readers), they are not included in 
this font.



How to Adjust the Print Position on Pin-Fed Printers
On some pin-fed printers it is hard to adjust the horizontal printing position. In these cases you can 
use the program's Alignment feature to make an adjustment.

Follow these steps to move the printing left or right

1. Print a sample label and determine which direction you need to move the printing.

2. Select the Print Setup command to see the Print Setup dialog box.

3. Click the Align button to see the Print Calibration dialog box. Do not click the Print Pattern 
button.

4. Adjust the Middle Calibration number to move the printing horizontally. Increase the number 
to move the printing to the left. Decrease the number to move the printing to the right. 

5. Print another sample label and check your settings.

To move the printing up or down on the label, simply use the paper-advance knob on 
your printer.



How to be Sure that Everything Fits in Your Design
When you create a design with merge fields, it's hard to tell if all the records in the linked list will fit in 
the text object you have created. The program provides a quick method of checking each record in a 
list to be sure they all fit.

Follow these steps to check each record in a list.

1. Open the design, and be sure that it is linked to the list you want to check.

2. Select the Print Preview command from the File menu.

3. In the Print Preview dialog box, select Clip Text or Shrink to Fit.

4. Click the Scan button to check each record. 

5. The program will stop and display any records that will not fit and will either shrink to fit or be 
clipped at the right edge of the text object.

When you select Shrink to Fit, the program automatically reduces the size of the fonts in 
the text object until all the lines are short enough to fit in the text object.

When you choose Clip Text, lines that extend beyond the right edge of the text object are 
truncated.



 How to Calibrate the Program to Your Printer
There is a variation, from printer to printer, in the absolute position at which the image is placed on the 
paper. In most printers, the variation is very slight, and you don't need to correct for it. However, if you 
notice that the image that the program prints is not in the correct position on the product, then you 
may want to calibrate the the program program to your printer.

Print Alignment, or calibration, is only used for sheet-fed printers including laser printers 
and many ink jet printers. For pin-fed printers, see How to Adjust the Print Position on Pin-Fed Printers.

Follow these steps to calibrate the program to your printer.

1. Locate one of the calibration sheets that you received in your package. Place the calibration 
sheet in the paper tray of your printer. Be sure you are feeding it in the correct direction, and 
with the appropriate side up. If you don't know which way to load the sheet, see How to Load 
Labels in your Printer.

2. Choose Print Calibration from the File menu.

3. In the Print Calibration dialog box, click the Print Pattern button to print the calibration sheet.

4. Read the three numbers from the printed calibration sheet, following the directions on the 
sheet.

5. Enter the three numbers on the Print Alignment dialog box and click OK.

The program will remember your settings. You only need to change them if you change 
printers.



How to Center Text
The program provides several methods for centering text. You can center all the lines of text in a text 
object, or you can center the lines in a text object as a block.

Block centering centers the longest line, and then left-aligns all the other lines with it. This 
lets you visually center each address on its own label.

Follow these steps to center a block of text on a design.

1. Add a text object to your design. See How to Add Text.

2. Use the Ruler command to turn on Snap to Rulers in the Ruler dialog box.

3. Use the Show Guides command to turn on the guides.

4. Use the mouse to drag the sizing handle on the middle of the left side of the text object so 
that it is 1/4 inch from the left side of the design.

5. Use the mouse to drag the sizing handle on the middle of the right side of the text object so 
that it is 1/4 inch from the right side of the design.

You may choose a distance other than 1/4 inch; simply use the same distance at both 
ends of the design.

6. Click the right mouse button so the Text Properties dialog box appears. 

7. Choose Centered to have each line centered individually.

Or

Choose Block Cent. to have the longest line centered and all the other lines left-aligned with 
it.

8. Click OK and you are finished.



 How to Change Field Names
The program's List Manager allows you to use any field names you want. This means that you can 
use List Manager lists for more than just names and addresses. By using your own field names, you 
can make any kind of list.

Follow these steps to change the field names in a List Manager list.

1. In List Manager, select the Edit Field Names command from the edit menu. The List Manager 
window changes so you can change the field names.

2. Change the field names.

3. Click the Edit Record button to go back to the normal List Manager view.

You don't need to save your changes, the program saves List Manager changes 
automatically.

To copy all the field names from one List Manager file to a new, empty file, use the New 
List command. 



 How to Change Fonts
The program allows you to change fonts for selected text in a text object, or for all the text in a text 
object. 

Follow these steps to change the font for part of the text in an object

1. Select the text that's font you want to change. 

2. Click the right mouse button, or select the Fonts command from the Text menu.

3. Choose the new font, size, color and style from the Font dialog box.

4. Click OK when your selection is complete.

Follow these steps to change the font for all the text in an object

1. Select the object (so the sizing handles show) in which you want to change the font of all the 
text.

2. Select the Fonts command from the Text menu.

3. Choose the new font, size, color and style from the Font dialog box.

4. Click OK when your selection is complete.

You can use any font you have installed in Windows. 



How to Change the Product Selection
You can choose which Avery products are listed in the New Design dialog box.

Follow these steps to change the product selection

1. Make sure the New Design dialog box is closed. Click Cancel if it is open.

2. In Program Manager, double-click the LabelPro Product Setup icon. The LabelPro Product 
Setup dialog box appears.

3. In the Do Not Install These Products list, highlight the product group you want to add. Use the 
Add button to move them to the Install Support For These Products list.

4. Repeat step 3 for each group you want to add.

5. Click OK when the Install Support For These Products list contains all the product groups you 
want to use. A new list of products is generated.



How to Change the Printing Order
When you are merging a list and printing sets of labels, the program allows you to print in two 
different sequences.

You can print each set completely before starting the next set (1,2,3.. 1,2,3.. 1,2,3... 
order).

You can print all copies of a single record before printing the next record (1,1,1... 2,2,2... 
3,3,3... order).

Follow these steps to select a printing order.

1. Create a design that is linked to a list.

2. Select the Print command from the File menu. The Print dialog box appears.

3. Choose 1,2,3.. 1,2,3.. 1,2,3... to print each set completely before starting the next set.

Or

Choose 1,1,1... 2,2,2... 3,3,3... to print all copies of a single record before printing the next 
record.

4. Optionally, you can choose Start Each Set on a New Page. You will usually want to choose 
this option if you selected 1,2,3.. 1,2,3.. 1,2,3... order. You will usually not want to choose this 
option if you selected 1,1,1... 2,2,2... 3,3,3... order.

5. Continue selecting options and printing.



 How to Check All the Records in a List
Once you have created a design that is linked to a list, you may not know that all the records in the list 
will fit into the text objects on your design. This process checks each record to insure that it will fit 
correctly, and can notify you if there is a problem.

Follow these steps to check all the records in a list.

1. Create a design that is linked to a list.

2. Select the Print Preview command from the File menu. The Print Preview dialog box appears.

3. Make sure that Report Shrinking or Report Clipping is checked.

4. Click the Scan button to check all the records in the list.

Or

Click the Next button to view each record in turn.

5. The program will stop and notify you if a record must be shrunk to fit or clipped. That record is 
displayed when the program stops.

6. Click the Scan button to continue checking the list.



How to Convert LabelPro DOS lists to LabelPro for Windows lists
LabelPro Laser and LabelPro Dot Matrix (DOS) lists can be directly converted to LabelPro for 
Windows lists by using the LPCONVRT.EXE conversion program supplied with LabelPro for 
Windows.

Follow these steps to convert your lists

1. In Windows Program Manager, select Run from the File Menu. The Run dialog box appears.

2. In the Command Line text box type the following:

C:\LPWIN\LPWNCVRT.EXE

You may have to change this command line if you installed LabelPro for Windows in a 
directory other than C:\LPWIN. Click Ok.

3. Use the Convert command on the File menu to comvert your LabelPro DOS lists to LabelPro 
for Windows kists. LabelPro Laser and LabelPro Dot Matrix use the following extensions.

 Address Book

.ADB

 Diskette Library

.DBD

 File Folder

.FDB

 Index

.IDB

 General List

.TBD or.GDB

LabelPro Laser lists are in the \AVERY\LISTS directory.

LabelPro Dot Matrix lists are in the \AVERYDM\LISTS directory.



How to Copy a Record in List Manager
Follow these steps to copy a record

1. Move to the record the you want to copy. You can use the Find command or the Filter 
command.

2. Use the Select Record command on the Edit menu to select the commnad. The words 
Record Selected appear above the record.

3. Use the Copy command on the Edit menu to copy the record to the clipboard. 

4. Use the Paste command on the Edit menu. The program creates a new record that is a 
duplicate of the copied record.



 How to Create a Design
Designs start with a label with a blank text object or other Avery product displayed on your screen. 
You can add various other kinds of objects to the design to print text, graphics, and shapes.

Follow these steps to create a design.

1. Select New Design from the File menu. The New Design dialog box appears. 

2. Select the type of product for which you want to create a design. See the Product 
Descriptions section of help for information about Avery products.

3. Select the Product for which you want to create a design. A miniature diagram of the product 
is displayed in the dialog box.

4. When you have selected a product, click the OK button to move to the Designer window. The 
product you selected will be displayed with a default text object.

5. Change the size of the program's main window if necessary to properly show the product you 
are using.

6. Simply start typing in the default text object
Or
Add other objects to complete your design.



 How to Create a New List
When you create a new list in the program, you can copy the field names from an existing list or by 
typing in new field names. The existing list if available saves you the trouble of typing all the field 
names.

Follow these steps to create a new, empty list by typying in field names.

1. In the List Manager window, select the Field Names command from the Edit menu.

3. Type the field names for the new list in the left-most column for the associated data in the 
right-most column.

4. Click the Edit Record button to save your list 

Or click the Reset Button to return to the default field names
Or click Cancel to ignore current chages

and return to the List Manager window.

5. Enter the records for your list.

Follow these steps to create a new, empty list using existing field names.

1. In the List Manager window, select the New List command from the File menu.

2. In the Copy Field Names From drop-down list, select the file that you want to copy the names 
from.

3. Type a file name for the new list in the File Name text box.

4. Click the OK button to return to the List Manager window.

5. Enter the records for your list.

To make a copy of a list that includes both the field names and the records, open the list 
you want to copy and use the Save List As command. 



How to Create Objects that Extend to the Edge of the Design
Most of the time you should leave a margin around the objects you place on a design. But sometimes 
you may want an object to extend right to the edge of the design. 

Follow these steps to create an object that extends to the edge of the design

1. Select the Ruler command from the View menu. The Rulers dialog box appears.

2. Make sure the Snap to Rulers option is not checked. Click OK.

3. Select the object that you want to extend to the edge of the design so the sizing handles 
show.

4. Drag the center sizing handle to the edge of the label.



How to Delete a Record from List Manager
Follow these steps to delete a record

1. Move to the record the you want to delete. You can use the Find command or the Filter 
command.

2. Use the Select Record command on the Edit menu to select the command. The words 
Record Selected appear above the record.

3. Use the Cut command on the Edit menu to remove the record. The record is removed and 
you are left at the first record in the list.



How to Duplicate LabelPro DOS designs in LabelPro for Windows
LabelPro for Windows has all the capabilities of LabelPro Laser and LabelPro Dot Matrix (DOS) so it 
is simple to duplicate any of their designs. Here are some hints to make it easy.

Look at the illustration of the LabelPro DOS template that you want to duplicate to the 
right of LabelPro Laser's or LabelPro Dot Matrix's Forms menu. Identify the rectangles that are text areas 
and graphics and their approximate position. Note any lines. 

Add a text object to your LabelPro for Windows design for each text area on the LabelPro 
DOS form.

Add a graphic object to your LabelPro for Windows design for each graphic area on the 
LabelPro DOS form.

Use the Line tool to add lines to your LabelPro for Windows design. 

All the LabelPro DOS borders can be reproduced in LabelPro for Windows. Simply create 
a graphic object on your LabelPro for Windows design that is almost as large as the label. Remember to 
allow a sufficient margin outside the graphic object. Then choose a graphic from the list below.

LabelPro (DOS) border LabelPro for Windows Graphic

ANGLE angle.pcx

BAR bar. pcx

BOX box. pcx

CORNER corner. pcx

SHADOW shadow. pcx

Because LabelPro for Windows provides complete design flexibility, you are no longer 
restrained to the forms provided. You can create any design.



How to Edit Text
Follow these steps to edit text in a text object.

1. Click twice on the text object to see the insertion point.

2. Move the insertion point to the location that you want to make your edits.

3. Make your changes as in any Windows application.

You can select text to Cut, and Copy.



How to Find a Record
The program makes it simple to find information in your lists.

Follow these steps to find a record in your list.

1. Open the list in which you want to look for information.

2. Select the Find command from the Edit menu. The Find dialog box appears.

3. Enter part or all of a field in the record you want to find and click OK.

4. The program searches the list and displays the first record with matching information.

5. Use the Find command additional times to find additional records that match.

To find several records that match, it's simpler to use the Filter command.



How to Load Labels in Your Printer
On many printers it is not easy to tell whether to load labels face-up or face-down. Follow this 
procedure to tell which is correct for your printer.

1. Take a sheet of the plain paper you normally use in your printer and mark a large arrow 
pointing toward one end of the sheet.

2. Load this marked sheet into the paper tray that you will use to print Avery products. Place the 
arrow on the top, and pointing into the printer.

3. Use Windows Control Panel to set the printer you want to use as the default printer, with the 
correct feeder selected.

4. In this Help window, select Print Topic from the File menu to print this topic. 

5. Remove the printed sheet from the printer's output tray. Use the following table to determine 
how to load Avery products.

The arrow points toward the 
top of the printed side of the 
sheet.

Feed labels and other Avery products face-
up. Products that say Feed This End First 
should be fed with that end going into the 
printer, the same direction as you placed the 
sheet with the arrow.

The arrow points toward the 
top of the un-printed side of 
the sheet.

Feed labels and other Avery products face-
down. Products that say Feed This End First 
should be fed with that end going into the 
printer, the same direction as you placed the 
sheet with the arrow.

The arrow points toward the 
bottom of the printed side 
of the sheet.

Feed labels and other Avery products face-
up. Products that say Feed This End First 
should be fed with the opposite end going into 
the printer, in the opposite direction from the 
way you placed the sheet with the arrow.

The arrow points toward the 
bottom of the un-printed 
side of the sheet.

Feed labels and other Avery products face-
down. Products that say Feed This End First 
should be fed with the opposite end going into 
the printer, in the opposite direction from the 
way you placed the sheet with the arrow.

You need to perform this test on each bin or feeder you want to use. Some printers, like 
the Hewlett-Packard LaserJet 4, require the sheets to be oriented differently in different feeders.

If your printer is capable of duplex printing (printing on both sides of the sheet) be sure it 
is turned off when you are printing labels.



 How to Merge
Merging is the most powerful function of LabelPro for Windows. You can print lists of information from 
various sources, on any design you create. The AutoMerge button automates this process. See how 
to use AutoMerge

Follow these general steps to merge information from a list into your design.

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Select the Link to List command from the Merge menu. In the Link to List dialog box, choose 
the file that you want to link.

3. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

4. Select the Merge Fields command from the Merge menu. The Merge Fields dialog box 
appears.

5. Highlight the field you want to add and click the Add button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

6. When you have added all the fields you want, click the Close button.

7. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

8. Make any changes you want to the design, and print.

Choose one of the following topics to learn more about merging files from specific programs.

How to merge a delimited (CSV) file 

How to merge a dBASE file

How to merge a LabelPro DOS file 

How to merge a LabelPro List 

How to merge a Paradox file 

How to merge a WinWord data file 

How to merge a WordPerfect secondary merge file 



 How to Use AutoMerge™
Merging is the most powerful function of LabelPro for Windows. You can print lists of information from 
various sources, on any design you create.

Follow these general steps to merge information from a list into your design.

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click on the AutoMerge tool from the tool pallette. In the Link to List dialog box, select the file 
that you want to link.

3. The Merge Fields dialog box appears. Highlight the field you want to add and click the Add 
button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

4. When you have added all the fields you want, click the Close button.

5. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

6. Make any changes you want to the design, and print.

Choose one of the following topics to learn more about merging files from specific programs.

How to merge a delimited (CSV) file 

How to merge a dBASE file

How to merge a LabelPro DOS file 

How to merge a LabelPro List 

How to merge a Paradox file 

How to merge a WinWord data file 

How to merge a WordPerfect secondary merge file 



 How to Merge Delimited (CSV) Files
Delimited files are often called comma-separated files. They consist of text with the fields separated 
by a comma. Many database programs can create delimited files.

The character that separates the fields is not always a comma. The program looks at the 
Separator Character that is set in the International section of Windows Control Panel to determine what 
character to use.

The rules for a delimited file are as follows:

 Each line is a record. Records are ended by an carriage return-line feed.

 Fields are separated by a comma (or other separator character).

 Empty fields require a separator. (Two adjacent commas indicate an empty field.)

 Fields that contain a comma must be enclosed in double-quote characters.

 Optionally, all fields may be enclosed in double-quote characters.

 Fields cannot contain double-quote characters.

 The first line may consist of field names. The program will print these on the first label.

A typical delimited file looks like this:

NAME,COMPANY,ADDRESS,CITY,STATE,ZIP
Claire Burbank,NE Wild Things,2316 Alta Dr.,Rochester,NY,10051
"Frederick Church, Jr.",,883 Wilson Avenue,Hobart,KS,78721
R. Doherty,"Hugo's Markets, Inc.",5680 Wash St.,Victor,CT,03610
Katy Elson,Nature Art,"621 Field, Suite C",Mt. Shasta,CA,92202

Follow these steps to merge a delimited file.

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

3. Click the AutoMerge Tool. The Link to List dialog box appears.

4. Set List Files of Type to Delimited DOS or Delimited Win. 

 Use Delimited DOS for files created by MS-DOS programs.

 Use Delimited Win for files created by Windows programs.

5. Choose the file that you want to link to your design and click OK.

6. The Merge Fields dialog box appears.

7. Highlight the field you want to add and click the Add button. Repeat for additional fields.



 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

8. When you have added all the fields you want, click the Close button.

9. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

10. Make any changes you want to the design, and print.



 How to Merge dBASE Data Files
dBASE files (sometimes called Xbase files) are a standard type of database file. Besides dBASE and 
its clones, there are many other programs that can create dBASE files.

Follow these steps to merge a dBASE file. 

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

3. Click the AutoMerge Tool. The Link to List dialog box appears.

4. Set List Files of Type to dBASE. 

5. Choose the file that you want to link to your design and click OK.

6. The Merge Fields dialog box appears.

7. Highlight the field you want to add and click the Add button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

8. When you have added all the fields you want, click the Close button.

9. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

10. Make any changes you want to the design, and print.

The program cannot sort a dBASE file. If you need to print your list in a particular order, 
use the Sort command in dBASE to create a copy of your file in sorted order. Merge the copy into the 
program.



 How to Merge List Manager Files
Follow these steps to merge a List Manager file. 

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

3. Click the AutoMerge Tool. The Link to List dialog box appears.

4. Set List Files of Type to AVD. 

5. Choose the file that you want to link to your design and click OK.

6. The Merge Fields dialog box appears.

7. Highlight the field you want to add and click the Add button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

8. When you have added all the fields you want, click the Close button.

9. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

10. Make any changes you want to the design, and print.

If you need to print your list in a particular order, use the Sort command in List Manager 
to put your file in sorted order.



How to Merge LabelPro Laser and LabelPro Dot Matrix (DOS) Files
LabelPro Laser and LabelPro dot matrix data files are in dBASE format. To print LabelPro Laser or 
LabelPro Dot Matrix files, you simply have to rename the files so LabelPro for Windows will recognize 
them, and then merge them as dBASE files.

Follow these steps to print LabelPro DOS files.

1. Locate the file you want to merge. LabelPro Laser and LabelPro Dot Matrix use the following 
extensions.

 Address Book

.ADB

 Diskette Library

.DBD

 File Folder

.FDB

 Index

.IDB

 General List

.TBD or.GDB

1. Copy the file you want to print out of the \AVERY\LISTS (or AVERYDM\LISTS) directory. This 
is so you don't change the original file.

2. Change the file name extension to.DBF. You can use Windows File Manger to rename the 
file.

3. Now merge the file as a dBASE file. See How to Merge a dBASE File.



 How to Merge a WordPerfect File
The program can merge and print WordPerfect secondary merge files. This is the type of file you use 
if you are doing a merge in WordPerfect, for example, to print a form letter.

WordPerfect Secondary Merge Files

WordPerfect secondary merge files may contain many records (a record is a collection of related 
information). Records are separated by the {END RECORD} merge code followed by a hard page.

The information in each record is divided into fields. One field may contain a name, another field may 
contain a company name, and another field may contain an address. It is these fields that are 
merged.

Fields within each record are separated by the {END FIELD} merge code and a Hard Return code. 

For more information on creating a secondary merge file in WordPerfect, search for the Merge topic in 
WordPerfect's help.

Follow these steps to merge a WordPerfect secondary merge file

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

3. Click the AutoMerge Tool. The Link to List dialog box appears.

4. Set List Files of Type to WordPerfect 5.x or 6.0. 

5. Choose the file that you want to link to your design and click OK.

6. The Merge Fields dialog box appears.

7. Highlight the field you want to add and click the Add button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

8. When you have added all the fields you want, click the Close button.

9. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

10. Make any changes you want to the design, and print.



 How to Merge Paradox Data Files
The program can merge files from Paradox and Paradox from Windows.

Follow these steps to merge a Paradox file. 

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

3. Click the AutoMerge Tool. The Link to List dialog box appears.

4. Set List Files of Type to Paradox. 

5. Choose the file that you want to link to your design and click OK.

6. The Merge Fields dialog box appears.

7. Highlight the field you want to add and click the Add button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

8. When you have added all the fields you want, click the Close button.

9. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

10. Make any changes you want to the design, and print.

LabelPro cannot sort a Paradox file. If you need to print your list in a particular order, use 
the Sort command in Paradox to create a copy of your file in sorted order. Merge the copy into LabelPro.



 How to Merge Word for Windows Data Files
LabelPro can merge Word for Windows data files. This is the type of file you use if you are doing a 
merge in Word, for example, to print a form letter.

Word for Windows Data Files

Word for Windows data files consist of a table, where each row contains a record, and each column 
contains a field. The first row may contain field names.

For more information on creating Word data files, see the topic Merging Documents from Start to 
Finish in Word's help.

Follow these steps to merge a Word for Windows data file

1. Create a label design that includes a text object. (See How to Create a Label Design.) 

2. Click twice in the text object in which you want to place the merge fields so the insertion point 
appears.

3. Click the AutoMerge Tool. The Link to List dialog box appears.

4. Set List Files of Type to Word 5, WinWord 2.0 or 6.0. 

5. Choose the file that you want to link to your design and click OK.

6. The Merge Fields dialog box appears.

7. Highlight the field you want to add and click the Add button. Repeat for additional fields.

 Use the Insert Space button in the Merge Fields dialog box to insert spaces between fields.

 Use the Start New Line button in the Merge Fields dialog box to move to the next line in the 
text object.

8. When you have added all the fields you want, click the Close button.

9. If you only want to print some of the records in the file you can create a filter. See How to 
Select Records for Printing.

10. Make any changes you want to the design, and print.



How to Move Objects
All the objects you place on your designs may be moved and re-sized.

To move a single object.

Select the object so the sizing handles are visible. Then simply drag the object to its new 
position.

Or

If the object is not selected, and there is no insertion point in the object, simply drag the 
object to its new position.

To move a group of objects together

1. Select all the objects you want to move. You can Shift-click each in turn, or drag across them, 
starting outside any object.

2. Drag the objects to their new position.



How to Optimize Printing Speed
Several factors influence the speed at which the program prints. You may be able to minimize the 
time it takes to print your jobs by changing some of the following factors.

Print Manager Print Manager is Windows built-in print 
spooler. In many cases, you can increase the 
overall printing speed, and solve other 
problems, by turning off Print Manager. Use 
the Printers section of Control Panel to turn off 
Print Manager.

When Print Manager is on, Windows saves 
your entire print job in a file on your disk. 
Once the program has completed formatting 
the job, Print Manager sends it to the printer. 
This can take a long time and also requires a 
large amount of disk space if you are printing 
a large merge job.

Graphics The program prints graphics faster than many 
other programs, however adding a graphic to 
your design will reduce the printing speed.

Fonts Using a large number of different styles and 
sizes of type on your design will reduce the 
printing speed.

Shrink to Fit Shrink to Fit is a powerful feature of the 
program, but it does take time. You can 
reduce the time that Shrink to Fit takes by 
creating your design so that most records do 
not have to shrink. If only a few exceptional 
records need to shrink, the program will print 
much faster than if every record in a merge 
job has to shrink. 

Pages vs. Labels When you are printing a series of labels that 
are all alike, the program can usually print 
much faster if you specify a number of Pages 
to print instead of a number of Labels to print 
in the Print dialog box. When you specify 
pages, (and your printer is capable of printing 
multiple copies), the program uses the printer 
to duplicate the pages, cutting print time 
drastically. Most laser printers are capable of 
printing multiple copies, and will demonstrate 
this increase.

How to Place an Object on Top of Another Object
You can place one object on top of another in your designs. This allows you, for example, to put 
borders around text, and to create shadow effects.

Following are some hints for placing objects on top of other objects

 Place the objects in the normal manner. Simply draw one on top of the other.



 To select a buried object, use Ctrl+Click. Ctrl+Click is a shortcut for the Send to Back 
command.

 Normally, you can "see through" objects so that objects lower in the stack will print. You can 
make shape objects opaque by selecting a white (or solid black) background.

 Use the Bring to Front and Send to Back commands to change the order of objects in a stack.

 You can create a shadow by placing one rectangle (or other shape) slightly offset from another.



How to Preview Your Design
The designer provides a nearly accurate display of your design. You can get a more accurate display 
using Print Preview.

To Preview your design

Select the Print Preview command from the File menu. The Print Preview dialog box 
appears.

Print Preview shows merged information with the fields closed up as they will print. 
Designer doesn't close up blank lines.

Print Preview allows you to view an entire list to see how each record will look, or to scan 
the list and display only problem records. See How to be Sure that Everything Fits in Your Design.



 How to Print a List
Follow these steps to print a List Manager list.

1. Create or open a design that is linked to the list you want to print.

2. Select the Print command from the File menu. The Print dialog box appears.

3. Set the number of copies of the list you want to print.

4. Select a printing order.

5. Click OK to print.



How to Print Different Graphics on each label
Printing a different graphic on each label is another powerful function of the program for Windows. 
You can print different graphics on any design you create. 

Label Assistant can print files with the extensions BMP, PCX, WMF, or TIF.

LabelPro can print files with the extensions BMP, EPS, GIF, IMG, JPG, PCX, WMF, WPG, 
TGA, or TIF.

Follow these steps to merge graphics from a list into your design

1. Select the label for your design using the New Design command on the File menu. 

2. Select the Link to List command from the Merge menu. In the Link to List dialog box, choose 
the file that you want to link. The linked list must contain a field with the file names of the 
graphic files you want to merge.

Its best to use the complete path name to the files you want to merge. A typical entry for a 
graphic merge field might look like this:

C:\LPWIN\ART\BOAT.WMF

3. Draw a graphic object box on your design (See How to Create a Label Design.) 

4. Select the Merge button in the Graphic Properties dialog box. Click the Merge button. The 
Merge Fields dialog box appears.

5. Highlight the field that contains the file names to merge and click the OK button.

Click here to see how the program finds graphic files.



How to Print a List in Report Format
The program includes a utility to quickly print the contents of a List Manager list in a report format. An 
entry in this report will look something like the following:

List Manager - businesu.avd

  Courtesy Title: Ms.
   First Name: Randi
   Last Name: Ross
    Company: Telemarketing Associates
    Address: 1850 Sonoma Ave., Suite 110
    City: Salt Lake City
    State: UT
     ZIP: 84107-0050
  Office Phone: 801-266-1697
    Type: Client

Follow these steps to print a list in report format

1. Open the list you want to print.

2. Select the Print Listing command from the File menu. The Print Setup dialog box appears.

3. Select a printer if you want, then click OK to print.

You can use the designer as a report generator. Simply choose an Avery product that will 
allow you to print several records on a sheet, such as a 5162 Address Label or a L7163 Address Label. 
Then simply create a design that includes the merge fields you want to print. Print this design on plain 
paper to produce a two-column report.



How to Print Mini-Sheets™ Laser Labels
Mini-Sheets Laser Labels are small sheets of labels that allow you to print just a few labels at a time. 
With some printers, Mini-SheetsLaser Labels    can be separated in half to print even fewer labels at a 
time.

Full Mini-SheetsLaser Labels    work in almost all laser printers. Unless your printer is 
specifically designed to print on paper as small as 4¼" x 5", do not separate the perforation before 
printing.

Follow these steps to print full Mini-Sheets Laser Labels

 1. Use the New Design command to select the Laser Label Mini-Sheets Laser Labels size you 
want to use. Don't pick one with "1/2 Sheet" at the end of the description.

2. Create your design. (See How to Create a Design.)

3. In the Print dialog box, select Side Feed or Center Feed to match your printer. Continue to 
print normally.

4. When printing Mini-Sheets Laser Labels, you may want to use the Print Setup command to 
set your printer to manual feed so you can feed the Mini-Sheets Laser Labels as your printer 
is ready for them. When set to manual feed, many printers provide a message like "Feed 
Letter" when you should insert the Mini-Sheets Laser Labels.

 Follow these steps to print half Mini-Sheets Laser Labels

Unless your printer is specifically designed to print on paper as small as 4¼" x 5", do not 
separate the perforation before printing.
 1. Use the New Design command to select the Laser Label Mini-Sheets Laser Labels size you want 
to use. Pick one with "1/2 Sheet" at the end of the description.
2. Create your design. (See How to Create a Design.)
3. In the Print dialog box, select Side Feed or Center Feed to match your printer. Continue to print 
normally.
4. When printing Mini-Sheets Laser Labels, you may want to use the Print Setup command to set 
your printer to manual feed so you can feed the Mini-Sheets Laser Labels as your printer is ready for 
them. When set to manual feed, many printers provide a message like "Feed Letter" when you should 
insert the Mini-Sheets Laser Labels.



How to Print Multiple Copies
The program can print multiple copies of a single design, or multiple copies of an entire list.

Follow these steps to print multiple copies of a single design

1. Open or create the design you want to print.

2. Choose the Print command from the File menu. The Print dialog box appears.

3. To print one entire sheet of the same design, simply click the Pages option, leaving the 
quantity at 1.

Or

To print multiple sheets of the same design, click the Pages option and enter the number of 
sheets in the Print box.

Or

To print a partial sheet, or a specific number of labels, enter a quantity in the Print text box 
and click the Labels option.

4. Select any other printing options and click OK to print.

Follow these steps to print multiple copies of an entire list 

1. Open or create a design that is linked to a list. See How to Merge.

2. Choose the Print command from the File menu. The Print dialog box appears.

3. Enter the number of copies of the list you want in the Print text box.

4. Select the print order you want. See How to Change the Printing Order.

5. Select any other printing options and click OK to print.



How to Resize (ZOOM) Designs
The program includes a Zoom command that allows you to change the screen display size of the 
current design. 

Follow these steps to Zoom in/out on the current design

1. From the View menu, choose Zoom (Alt,V,Z).

2. In the Zoom dialog box, set the percent of normal screen size for the current design.

3. Click the OK button.

Zoom does not affect printing. Your design will always print the correct size.



How to Rotate Text
LabelPro can print text at any angle.

Follow these steps to rotate text

1. Select the text object (so the sizing handles show) which you want to rotate.

2. Click the right mouse button, or select the Properties command from the Object menu.

3. Click the Rotate button. The Rotate dialog box appears. 

4. Set the angle of rotation that you want. You can select one of the pre-set angles, or you can 
set your own value in the Other box.



How to Select a Printer
The program can print to any printer that is installed in Windows.

Follow these steps to select a printer

1. Select the Print Setup command on the File menu. The Print Setup dialog box appears.

2. Choose the printer you want to use and click OK.



How to Select Objects
You can select one or several objects.

To select a single object

Click on the object you want to select. The sizing-handles appear.

If the insertion point is in the object you want to select, first click outside the object, then 
select it.

If another object is selected, and that object is in front of or behind the object you are 
trying to select, simply click outside of any object so nothing is selected. Then click on the object you want 
to select. 

Use the Send to Back command so you can select covered objects.

To select several objects

Drag across the objects you want to select, starting with the mouse pointer outside of any object. The 
sizing-handles appear on all the selected objects.

You can move several objects as a group when they are all selected.

To select all the objects

Choose the Select All command from the Edit menu. The sizing-handles appear on all the objects.

You can move several objects as a group when they are all selected.



 How to Select Records for Printing
The program can select certain records for printing from a merged list.

Follow these steps to select records for printing.

1. Select the Merge Filter command from the Merge menu (in Designer) or select the Filter 
command from the Record menu (in List Manager). The Filter dialog box appears.

2. Choose a field to select on.

3. Set the first condition and enter a value.

4. Select And or Or (if necessary).

5. Set the second condition and enter a value (if necessary).

6. Click the Add button to add your criteria to the list.

7. Repeat steps 2 through 7 to add additional conditions.

The program always makes comparisons on a character-by-character basis. If you are 
comparing two numbers, the program begins by comparing the leftmost digit of the first number with the 
leftmost digit of the second number. Thus numbers of different lengths might not compare the way you 
expect. Numbers that are the same length compare correctly, so you can add leading zeros to make all 
your numbers the same length. Likewise, dates might not compare the way you expect unless you enter 
the year first, the month second, and the day last (using 2 digits for each field).

Some example filters

To print all the people on your list that work at Avery Dennison make the entries shown below.

The And and Or options are ignored if the lower comparison value is blank.

To print all the people on your list that live in zip codes 80000 through 89999 make the entries shown 
below.



To print all the people on your list that live in zip codes 80000 through 89999 and are clients, make 
the entries shown below.

You can enter criteria for as many fields as you like.



How to Select Text
You can select the text in a Text object when the insertion point is in that object.

Click twice in an object to see the insertion point.

To select a range of text. 

Drag through the text you want to select. The text is highlighted.

To select a single word

Double-click on the word you want to select. The word is highlighted.



 How to Sort Records
The program can sort List Manager lists on any field in the list.

Follow these steps to sort a List manager list.

1. In List manager, open the list you want to sort.

2. Select the Sort command from the Record menu. The Sort dialog box appears.

3. Choose Ascending or Descending sort order.

4. In the Sort dialog box, select the field you want to sort on.

5. Click the Add button to add it to the list of Sort Criteria.

6. Repeat steps 4 and 5 any additional fields you want to sort on.

7. Click OK to do the sorting.

You can sort on up to two fields. The primary field is the first one you add to the Sort 
Criteria list. 

The program always sorts on a character-by-character basis. If you are sorting two 
numbers, the program begins by comparing the leftmost digit of the first number with the leftmost digit of 
the second number. Thus numbers of different lengths might not sort the way you expect. Numbers that 
are the same length sort correctly, so you can add leading zeros to make all your numbers the same 
length. Likewise, dates might not sort the way you expect unless you enter the year first, the month 
second, and the day last (using 2 digits for each field).



How to Start Printing After the First Label on a Sheet
The program allows you to start printing anywhere on the first sheet. 

Follow these steps to begin printing after the first label on a sheet

1. Select the First Page Setup command from Designer's File menu. The First Page Setup 
dialog box appears.

2. Click on the label which you want to be the first printed.

Or

Enter the number of the label which you want to be the first printed in the Start Printing on 
Label box.

3. Click OK. When you print, the program will start on the indicated label.

It's not a good idea to run labels through your laser printer more than once. You risk a 
jam that could be expensive to fix.

Pages after the first will start printing on the first label.



How to Position and Align Objects on a Design 
Follow these steps to accurately place an object

1. Create and place the object in the approximate position you want it.

2. Use the Show Guides command to display the object guides.

3. Select the object so the sizing handles show.

4. Drag the upper-left sizing handle, while watching the guides, to the correct position.

5. Drag the lower-right sizing handle, while watching the guides, to the correct position.

Use these hints to accurately position and align objects

Make sure that Snap to Rulers is turned on in the Rulers dialog box. This makes sure that 
each object is placed on a ruler division.

Use the Tick Marks per Inch setting in the Rulers dialog box to control the position and 
spacing of your objects.

Use the Show Guides command to display the object guide lines. Use the guides to 
accurately size and position objects.



How to Print Multiple Identical Labels
Printing multiple identical labels, such as return address labels, is easy. 

Follow these steps to print identical labels.

1. Create a label design. (See How to Create a Label Design.)

2. Add the text you want to print on every label. (See How to Add Text.)

3. Add any other elements you wish. (See How to Add a Graphic, How to Add a Shape, How to 
Add a Border.)

4. Print your design using the Print command. You can specify the number of labels you want to 
print or the number of pages you want to print.
 

Don't use the Link to List command when you want to print multiple identical labels.



How to Print Part of a Graphic
The program can adjust the size and shape of a graphic, and it can print the upper-left corner of a 
graphic. But it cannot print a portion of the center of a graphic. If you want to print a part of a graphic, 
you will need to use another program, like Windows Paintbrush, to make a copy of the part of the 
graphic you want to print.

Follow these steps to copy part of a graphic with Paintbrush

1. Load Windows Paintbrush and open the file you want to copy from. Windows Paintbrush will 
work with BMP and PCX files. 

2. Use the Pick tool (It's the right-hand pair of scissors at the top of the tool bar) to outline the 
area of the picture that you want to print.

3. While the area is still outlined, choose Copy To from Paintbrush's Edit menu. The Copy To 
dialog box appears.

4. Enter a file name and click OK to save the partial image.

5. Return to the program and enter the same file name into the Graphic Property dialog box.

Windows Paintbrush works with BMP and PCX files. If you are using a TIFF file you will 
need to do the same thing with a program that can edit TIFF files.



How to Use the Postal Address Font
LabelPro includes a TrueType font specifically designed for printing machine-readable address labels. 
Use this font when you do not print delivery point bar codes on your labels. See How to Address for 
Postal Automation 

Follow these steps to use the Postal Address font

1. Create your label design with the address text object horizontal alignment set to Left or Block 
Cent. Do not use Center, or Right.

2. Select all the text (or field names) in the last two lines. These lines should include the 
address, the city, state, and zip code.

3. Click the right mouse button, or select the Fonts command from the Text menu.

4. In the Font dialog box, select the Postal Address font.

If the Postal Address font doesn't appear in your list of fonts, see How to Install the Postal 
Address Font.
5. Set the Font Style to Roman.
5. Set the Size to 10, 11 or 12 points.
6. Make sure that none of the Effects are selected and click OK.

The Postal Address font has only capital letters. It converts all lower-case letters to 
capital letters. 

The Postal Address font has slightly increased spacing between the letters to improve the 
accuracy of the Postal Service's optical character recognition machines.

For additional addressing guidelines, refer to USPS Pub. 25.



How to Install the Postal Address Font
LabelPro includes a TrueType font specifically designed for printing machine-readable address labels. 

Follow these steps to install the Postal Address Font

1. Use Windows Control Panel Fonts to install the font.

2. In the Fonts dialog box, click the Add button.

3. In the Add Fonts dialog select the Postal Address Roman font in the LPWIN directory and 
click OK.

4. Click Close in the Fonts dialog box. You are now ready to use the Postal Address font. See 
How to Use the Postal Address Font.



Finding graphic files
The program looks in the following places to find graphic files:

1. The drive and directory specified in the graphic merge field of the data file.

2. The current directory.

3. The Windows directory (the directory containing WIN.COM).

4. The Windows system directory (the directory containing such system files as GDI.EXE).

5. The directory containing the programs executable file.

6. The directories listed in the PATH environment variable.

7. The directory, with the drive letter removed, specified in the graphic merge field of the data 
file.

8. The ART directory specified in the programs .INI file.

9. The directory containting the design (.LPD) file.





Sample Designs (North America)
LabelPro for Windows includes two types of sample designs. The first type of designs demonstrate 
features of LabelPro. The second type of sample designs make it easier for you to use some specific 
Avery products.

Designs that Illustrate Features of LabelPro 

Designs that Demonstrate Avery Products 

These sample files are installed if you selected Products available in the North America 
when you ran Setup. There are also sample designs for Europe and other parts of the world .



Designs that Illustrate Features of LabelPro
The following designs demonstrate features of LabelPro for windows. You can look at these designs 
and then create your own, or simply modify these designs and then use the Save Design As    
command to save your modified design with a new name and description.

File Description

MRGADRSU.LPD Simple mailing label with a List 
Manager merge. Linked to List 
FRIENDSU.AVD.

MRGPICTU.LPD Example of merging graphics. Linked 
to MRGPICTU.AVD

POSTNETU.LPD Mailing label with Postnet bar code 
and merge. Linked to List 
BUSINESU.AVD

PARTSU.LPD Part identifying label with a bar code 
and a serial number. Linked to List 
PARTSU.AVD.

SHIPPNGU.LPD Shipping label with graphic, return 
address and a merge. Linked to List 
BUSINESU.AVD.

FILEFLDU.LPD File folder design with a merge. 
Linked to List MONTHSU.AVD.

MRGWPU.LPD Simple mailing label with a 
WordPerfect merge. Linked to 
WPDATAU.WP.

MRGWWU.LPD Simple mailing label with a WinWord 
merge. Linked to WWDATAU.DOC.

MRGDBU.LPD Simple mailing label with a dBASE 
merge. Linked to DBDATAU.DBF.

MRGDOSU.LPD Simple mailing label with a DOS 
delimited merge. Linked to 
DOSDATAU.CSV.

MRGPDXU.LPD Simple mailing label with a Paradox 
merge. Linked to PDXDATAU.DB.

CONFIDU.LPD
FRAGILU.LPD
NOSMOKEU.LPD
PARAVINU.LPD
PLSRUSHU.LPD
URGENTU.LPD

Sample labels for printing pre-
formatted office messages.



Designs that Demonstrate Avery Products
The following designs demonstrate several products that you can print with LabelPro for windows. 
Simply modify these designs and then use the Save Design As    command to save your modified 
design with a new name and description.

In some cases, such as the Index Maker and    WorkSaver designs, you may only need to add your 
information to the List Manager list that is linked to the design, mark your new records for printing, 
and then print. You may not need to change the design at all.

File Description

TENTLRGU.LPD
TENTMEDU.LPD

Laser Note Cards with rotated text in 
position. 

FSNOTELU.LPD
FSNOTEPU.LPD
SGNOTEPU.LPD

Designs illustrating various ways to 
print Laser Note Cards.

HIDEN 3U.LPD
HIDEN 5U.LPD
HIDEN 8U.LPD
HIDEN10U.LPD

Designs with text boxes placed for 
Hidden Tab table of contents sheets.

READY5U.LPD
READY8U.LPD
READY10U.LPD
READY12U.LPD
READY15U.LPD

Designs with text boxes placed for 
Ready Index table of contents sheets.

DISK350U.LPD 3.5” diskette label with the printed 
band on 5096 and 5896 indicated with 
a text object.

DISK525U.LPD 5.25” diskette label with the printed 
band on 5097 and 5897 indicated with 
a text object.

INDEXSMU.LPD Small rotary index card 5385 with the 
cut-outs covered by a text object.

INDEXLGU.LPD Large rotary index card 5386 with the 
cut-outs covered by a text object.

INXMKR3U.LPD
INXMKR5U.LPD
INXMKR8U.LPD

Index Maker labels with a merge. 
Linked to List CHAPTERU.AVD or 
MONTHSU.AVD.

WRKSVR5U.LPD
WRKSVR8U.LPD

WorkSaver divider designs with a 
merge. Linked to List 
CHAPTERU.AVD.

WKS3INSU.LPD
WKS5INSU.LPD

WorkSaver insert designs with a 
merge. Linked to List 
CHAPTERU.AVD.

WRK1INU.LPD
WRK15IN.LPD
WRK2INU.LPD

WorkSaver insert designs with a 
merge. Linked to List 
CHAPTERU.AVD.

TITLE10U.LPD
TITLE15U.LPD

TitleFrame designs with a merge. 
Linked to List CHAPTERU.AVD.



TITLE20U.LPD

AUDIOU.LPD Audio cassette label 5198 with the 
cut-out covered by a text object.

Sample Lists (North America)
LabelPro for Windows can merge lists from it's own list manager, as well as lists (or files) from several 
other programs.

The sample files listed below are installed if you selected Products available in the North 
America when you ran Setup. There are also sample lists for Europe and other parts of the world .

LabelPro Lists

The following LabelPro List Manager lists are used with the sample designs that come with LabelPro 
for Windows. You can add your own records to these lists, or you can create your own lists using 
these field names using List Manager's New List command.

File Description

BUSINESU.AVD Mailing list with business-related field 
names

FRIENDSU.AVD Mailing list typical of home use. 

DISKSU.AVD List with fields for labeling diskettes.

PARTSU.AVD List with fields for creating part-
number labels.

CHAPTERU.AVD A list for creating Index tabs. Includes 
a sort-order field.

MONTHSU.AVD The months of the year.

MRGPICTU.AVD A list illustrating merging graphics.

Lists from other Programs

The following lists were created with other programs and are included with LabelPro for Windows to 
demonstrate how to do a merge with these other kinds of files. You can use these files as examples, 
or you can add your own information to these files if you have the correct software.

File Description

WPDATAU.WP Sample WordPerfect secondary 
merge file. Linked to MRGWPU.LPD.

DBDATAU.DBF Sample dBASE file. Linked to 
MRGDBU.LPD.

WWDATAU.DOC Sample WinWord data file. Linked to 
MRGWWU.LPD.

DOSDATAU.CSV Sample DOS delimited data file. 
Linked to MRGDOSU.LPD.

PDXDATAU.DB Sample Paradox data file. Linked to 
MRGPDXU.LPD.

Sample Designs (Europe and other parts of the world)
LabelPro for Windows includes two types of sample designs. The first type of designs demonstrate 
features of LabelPro. The second type of sample designs make it easier for you to use some specific 
Avery products.



Designs that Illustrate Features of LabelPro 

Designs that Demonstrate Avery Products 

These sample files are installed if you selected Products available in the Europe and 
other parts of the world when you ran Setup. There are also sample designs for the North America .



Designs that Illustrate Features of LabelPro
The following designs demonstrate features of LabelPro for windows. You can look at these designs 
and then create your own, or simply modify these designs and then use the Save Design As    
command to save your modified design with a new name and description.

File Description

MRGADRSA.LPD Simple mailing label with a List 
Manager merge. Linked to List 
FRIENDSA.AVD.

MRGPICTA.LPD Example of merging graphics. Linked 
to MRGPICTA.AVD

PARTSA.LPD Part identifying label with a bar code 
and a serial number. Linked to List 
PARTSA.AVD.

SHIPPNGA.LPD Shipping label with graphic, return 
address and a merge. Linked to List 
BUSINESA.AVD.

MRGWPA.LPD Simple mailing label with a 
WordPerfect merge. Linked to 
WPDATAA.WP.

MRGWWA.LPD Simple mailing label with a WinWord 
merge. Linked to WWDATAA.DOC.

MRGDBA.LPD Simple mailing label with a dBASE 
merge. Linked to DBDATAA.DBF.

MRGDOSA.LPD Simple mailing label with a DOS 
delimited merge. Linked to 
DOSDATAA.TXT.

MRGPDXA.LPD Simple mailing label with a Paradox 
merge. Linked to PDXDATAA.DB.

FRAGILA.LPD
NOSMOKEA.LPD
PARAVINA.LPD
URGENTA.LPD

Sample labels for printing pre-
formatted office messages.

Designs that Demonstrate Avery Products
The following designs demonstrate several products that you can print with LabelPro for windows. 
Simply modify these designs and then use the Save Design As    command to save your modified 
design with a new name and description.

In some cases, such as the Index Maker, you may only need to add your information to the List 
Manager list that is linked to the design, mark your new records for printing, and then print. You may 
not need to change the design at all.

File Description

AUDIOA.LPD Audio cassette label 5198 with the 
cut-out covered by a text object.

INXMKR5A.LPD
INXMKR6A.LPD
INXMK10A.LPD

Index Maker labels with a merge. 
Linked to List MONTHSA.AVD.



INXMK12A.LPD

Sample Lists (Europe and other parts of the world)
LabelPro for Windows can merge lists from it's own list manager, as well as lists (or files) from several 
other programs.

The sample files listed below are installed if you selected Products available in the 
Europe and other parts of the world when you ran Setup. There are also sample lists for the North 
America .

LabelPro Lists

The following LabelPro List Manager lists are used with the sample designs that come with LabelPro 
for Windows. You can add your own records to these lists, or you can create your own lists using 
these field names using List Manager's New List command.

File Description

BUSINESA.AVD Mailing list with business-related field 
names

FRIENDSA.AVD Mailing list typical of home use. 

DISKSA.AVD List with fields for labeling diskettes.

PARTSA.AVD List with fields for creating part-
number labels.

CHAPTERA.AVD A list for creating Index tabs. Includes 
a sort-order field.

MONTHSA.AVD The months of the year.

MRGPICTA.AVD A list illustrating merging graphics.

Lists from other Programs

The following lists were created with other programs and are included with LabelPro for Windows to 
demonstrate how to do a merge with these other kinds of files. You can use these files as examples, 
or you can add your own information to these files if you have the correct software.

File Description

WPDATAA.WP Sample WordPerfect secondary 
merge file. Linked to MRGWPA.LPD.

DBDATAA.DBF Sample dBASE file. Linked to 
MRGDBA.LPD.

WWDATAA.DOC Sample WinWord data file. Linked to 
MRGWWA.LPD.

DOSDATAA.TXT Sample DOS semicolon delimited 
data file. Linked to MRGDOSA.LPD.

DOSDATAA.CSV Sample DOS comma delimited data 
file. 

PDXDATAA.DB Sample Paradox data file. Linked to 
MRGPDXA.LPD.

DOSDATAA.TXT is a semicolon delimited file. If your List Separator is a comma, you my 
wish to use the comma-delimited sample file. Simply use the Link to List command to link the design 



MRGDOSA.LPD to the file DOSDATAA.CSV.    The List Separator is set in the International section of 
Control Panel.
 





Avery Product Support
Avery provides several types of support for their customers. 

Calling Avery Technical support in the US, Canada and Mexico 

Calling Avery Technical support worldwide 

Product and dealer information 

Avery on CompuServe 

Avery's FaxFacts system .

Limited technical support for printing Avery labels with other software 



Calling Avery Technical Support in the US, Canada and Mexico
Avery provides telephone technical support for Avery software products and the Personal Label 
Printer. Avery is also on the CompuServe Information Service.

If you have a question about an Avery software product, look in the printed manual or on-line Help. If 
you cannot find the answer, contact Avery Technical Support from 8 A.M. to 8 P.M. Eastern time (5 
A.M. to 5 P.M. Pacific time) Monday through Friday.

Before you telephone Avery Technical Support 

When you call, you should be at your computer with your Avery software running and    the product 
manual at hand. Have your document open and be prepared to give the following information:

 The name and version of the Avery software that you are using.

 The type of hardware you are using, including network hardware, if applicable.

 The operating environment that you are using.

 The exact wording of any messages that appeared on your screen.

 A description of what happened and what you were doing when the problem occurred.

 How you tried to solve the problem.

To call Avery Technical Support 

Call (214) 389-3699 between the hours of 8 A.M. and 8 P.M. Eastern time (5 A.M. and 5 P.M. Pacific 
time)    Monday through Friday.

You can reach Avery Technical Support by fax at (214) 446-2717.

Avery's support services are subject to Avery's prices, terms, and conditions in place at the time the 
service is used.

 If you are outside the US, Canada and Mexico, see Calling Avery Technical Support Worldwide 



Calling Avery Technical Support Worldwide
Avery provides telephone technical support for Avery software products and the Personal Label 
Printer. Avery is also on the CompuServe Information Service.

If you have a question about an Avery software product or the Personal Label Printer, look in the 
printed manual or on-line Help. If you cannot find the answer, contact Avery Technical Support. 
Technical Support is open Monday through Friday, except holidays.

Before you telephone Avery Technical Support 

When you call, you should be at your computer with your Avery software running and    the product 
manual at hand. Have your document open and be prepared to give the following information:

 The name and version of the Avery software that you are using.

 The type of hardware you are using, including network hardware, if applicable.

 The operating environment that you are using.

 The exact wording of any messages that appeared on your screen.

 A description of what happened and what you were doing when the problem occurred.

 How you tried to solve the problem.

To call Avery Technical Support 

There is a card with your printed documentation that lists the nearest Avery Technical Support 
telephone number. Technical Support is open Monday through Friday, except holidays.

Avery's support services are subject to Avery's prices, terms, and conditions in place at the time the 
service is used.

 If you in the US or Canada, see Calling Avery Technical Support in the US, Canada and 
Mexico 



Avery on CompuServe
Avery is in the PC Vendor Forum F on the CompuServe Information Service. Avery offers both 
technical and customer service support through CompuServe. Plus there is a wealth of information in 
the library to help you print Avery labels with many kinds of software.

Existing CompuServe members can simply GO AVERY.

For an introductory CompuServe membership kit in the US, call CompuServe at (800) 
848-8199.



Avery's FaxFacts System.
All of Avery's technical bulletins are available on Avery's FaxFacts system. FaxFacts is a fax 
information retrieval system that allows you to gain instant access to information.

Most of the bulletins on the FaxFacts system cover printing laser labels with various other publishers 
software programs. There are also bulletins that provide information about Avery software.

To use FaxFacts, from the phone connected to your fax machine, call (818) 584-1681. The voice 
prompts will guide you in choosing the bulletin you want.



Product and Dealer Information
Avery's Consumer Service Center provides product information for all Avery products    sold in the US 
and Canada. 

You can call the Consumer Service Center, at (800) 252-8379 between the hours of 7 A.M. and 4 P.M. 
(Pacific time) Monday through Friday.

Call the Consumer Service Center to find where to purchase Avery products. They can 
help you get products quickly, even if the products are not carried by dealers in your area.

You cannot reach Avery Technical Support by calling this number.



Limited Technical Support for Printing Avery Labels with Other 
Software

Avery provides help with printing Avery labels with many different software programs. This support is 
provided through the FaxFacts system and CompuServe.

 



LabelPro Messages

The following messages are listed in alphabetical order. Click the Plus button to learn about the 
message.

An error has occured while accessing the printer.
Bar code data cannot contain more than 30 characters.
Cannot rotate object off the label. Move the object closer to center of label and then rotate.

 Cannot set printer's page size. Use Printer Setup, or get an updated printer driver.
 Copied object does not fit on the new label. Pick a bigger label, or copy missing object(s) 

individually.
EAN-13 must consist of 12, 14, or 17 digits. 
EAN-8 must consist of 7, 9, or 12 digits.

File specified already exists. Overwrite?

Incomplete criteria. Enter a value to compare to.

Incorrect design file (.lpd) version.

Incorrect stock file (.stk) version.

 Index File was corrupt and has been deleted. Please relink the file

Merge data file is encrypted, and cannot be read.

Merging Paradox files requires that Share be loaded. Run SHARE.EXE before starting 
Windows.

 New record will not be displayed because of your current filter. Remove the filter to view 
the new record.

No records meet the filter criteria. Check your filter criteria.

 Only text will be copied. Use the Merge Fields command to add merge fields.

 Only TrueType text may be rotated. Change all fonts in the selected object to TrueType, 
then rotate.

Ran out of disk space during printing. Use the Control Panel to turn off Print Manager.

Text is taller than the text object's frame.

Text is wider than the text object's frame.

The bar code data contains a value that is not within the Extended Code 39 character 



set.

. The bar code does not match the resolution of the current printer. Check the bar code 
properties

The bar code is too tall to fit in the bar code object. Increase the height of the bar code 
object.

. The bar code is too wide to fit in the bar code object. Increase the width of the bar code 
object

The bar code object is not tall enough to include the human-readable data value. 
Increase the height of the bar code object.

The file selected has an unrecognized extension. Select an extension from List Files of 
Type.

The graphic object on the clipboard is greater than the maximum size.

The linked file appears to be corrupt. Use Link to List to link to a different file.

The linked file cannot be found. Use Link to List to link to a different file.

The linked file cannot be read. Use Link to List to link to a different file.

The linked file does not appear to be the format specified. Use Link to List to link to a 
different file.

The linked file is not a version supported by LabelPro. Use Link to List to link to a 
different file.

The Postnet bar code extends beyond the edge of the design and will not be printed.

The specified bar code accepts numeric characters only.

This field is already in the filter criteria list. 

This field is already in the sort criteria list.

This report will not fit on the current printer. Do you wish to continue?

Unable to open the linked file. Use Link to List to link to a different file.



. UPC-A must consist of 11, 13, or 16 digits.

UPC-E must consist of 6, 8, or 11 digits. 

Warning - Cannot set printer settings to match stock. Printer must be set through printer 
setup

Your design extends outside the printable area of the page. Parts of the design may not 
print



An error has occured while accessing the printer.

Check that your printer is on line and functioning properly. Check Print Manager for problems.



Bar code data cannot contain more than 30 characters.

Bar codes can't encode more than 30 characters (usually less, due to space limitations). You may 
have chosen a merge field that is too long. Check the data that you are trying to print as a bar code.



Cannot set printer's page size. Use Printer Setup, or get an updated printer 
driver.

The printer driver you are using doesn't recognize the command to set the page size. You may be 
able to set the page size using Printer Setup. Otherwise, you should get an updated printer driver 
from Microsoft or your printer's manufacturer.



EAN-13 must consist of 12, 14, or 17 digits.

EAN-13 bar codes can only encode 12, 14 or 17 numeric digits. Check that the number you are 
attempting to print is the correct length. If you are merging into the bar code, check that the data in 
the linked list is the correct length.



EAN-8 must consist of 7, 9, or 12 digits.

EAN-8 bar codes can only encode 7, 9 or 12 numeric digits. Check that the number you are 
attempting to print is the correct length. If you are merging into the bar code, check that the data in 
the linked list is the correct length.



File specified already exists. Overwrite?

You are about to save a file over an existing file with the same name. If you don't want to replace that 
file, change the file name.



Incomplete criteria. Enter a value to compare to.

You haven't entered a value for the filter to compare to. Enter a comparison value and click Add 
again.



Incorrect design file (.lpd) version.

The design file is not the correct version. Try a different file.



Incorrect stock file (.stk) version.

The product file is not the correct version. Use Setup to install the correct file.



Merge data file is encrypted, and cannot be read.

The file you have linked is apparently encrypted and the program cannot read it. Use Link to List to 
link to a different file.



Merging Paradox files requires that Share be loaded. Run SHARE.EXE before 
starting Windows.

You must have Share loaded to merge Paradox files. Run the program SHARE.EXE, which is part of 
DOS, before starting Windows.



No records meet the filter criteria. Check your filter criteria.

There are no records in the list that meet the filter criteria you have established. Use the Filter 
command to change the filter criteria.



Ran out of disk space during printing. Use the Control Panel to turn off Print 
Manager.

When Print Manager is on, Windows saves your entire print job in a file on your disk. Once the 
program has completed formatting the job, Print Manager sends it to the printer. This can take a long 
time and also requires a large amount of disk space if you are printing a large merge job.

In many cases, you can increase the program's overall printing speed, and solve other problems, by 
turning off Print Manager. Use the Printers section of Control Panel to turn off Print Manager.



Text is taller than the text object's frame.

The text in one of the text objects on your design is too tall, or consists of too many lines, to fit into the 
height of the text object. The program will either clip the bottom of the text, or shrink it to fit, 
depending on your text options setting. 

You may want to make the text object taller, or to make the size of the fonts in the text object smaller.



Text is wider than the text object's frame.

The text in one of the text objects on your design is too wide and extends beyond the width of the text 
object. The program will either clip the width of the text, or shrink it to fit, depending on your text 
options setting. 

You may want to make the text object wider, or to make the size of the fonts in the text object smaller.



The bar code data contains a value that is not within the Extended Code 39 
character set.

Code 39 bar codes can only encode a limited character set. The program supports the optional Code 
39 extended character set. You are trying to encode a character that is not in this character set. 
Check the data you are trying to print, including data from a linked list.



The bar code does not match the resolution of the current printer. Check the bar 
code properties.

You have changed printers since you specified the bar code. Go to the Bar Code Properties dialog 
box and adjust the settings for your current printer.



The bar code is too tall to fit in the bar code object. Increase the height of the 
bar code object.

The bar code you have specified is taller than the bar code object you have created to contain it. 
Either increase the height of the bar code object, or return to the Bar Code Properties dialog box and 
adjust the height.



The bar code is too wide to fit in the bar code object. Increase the width of the 
bar code object.

The bar code you have specified is wider than the bar code object you have created to contain it. 
Either increase the width of the bar code object, or return to the Bar Code Properties dialog box and 
adjust the density or ratio.



The bar code object is not tall enough to include the human-readable data value. 
Increase the height of the bar code object.

The bar code you have specified, with the data value beneath it, is taller than the bar code object you 
have created to contain it. Either increase the height of the bar code object, or return to the Bar Code 
Properties dialog box and adjust the height of the bar code or the size of the data value.



The file selected has an unrecognized extension. Select an extension from List 
Files of Type.

You have specified a file extension that the program does not recognize. Use one of the extensions 
from List Files of Type.

If you are sure that the file you are trying to open is the correct format, you can rename it to change 
the extension. 



The graphic object on the clipboard is greater than the maximum size

You have attempted to paste a graphic that is too large for the program to handle. Usually, you can 
use Windows Paintbrush to create a file that contains the graphic you want to print. Then enter that 
filename into the Graphic Properties dialog box.



The linked file appears to be corrupt. Use Link to List to link to a different file.

The file you have linked appears to be corrupt. It may be damaged, or it may be a format that the 
program does not recognize. Correct the file, or use Link to List to link to a different file.



The linked file cannot be found. Use Link to List to link to a different file.

The program cannot find the file that is linked to this design. The file may have been moved or 
deleted. Use Link to List to link to a different file.



The linked file cannot be read. Use Link to List to link to a different file.

The program cannot read the file that is linked to this design. The file may be in use by another 
program. Correct this situation or use Link to List to link to a different file.



The linked file does not appear to be the format specified. Use Link to List to 
link to a different file.

The file you have linked appears to be an incorrect format. It may be damaged, or it may be a format 
that the program does not recognize. Correct the file, or use Link to List to link to a different file. 

Be sure you are using the correct type of file. For example, to merge a WordPerfect file, you must use 
a WordPerfect secondary merge file, not a normal WordPerfect document. 



The linked file is not a version supported by the program. Use Link to List to link 
to a different file.

The file you have linked appears to be an incorrect version. It may be damaged, or it may be a format 
that the program does not recognize. Correct the file, or use Link to List to link to a different file. See 
Link to List dialog box for the specific versions of the programs that the program can merge.



The Postnet bar code extends beyond the edge of the design and will not be 
printed. 

You have positioned the text object so that the Postnet bar code extends off the label. The program 
will not print an incomplete bar code. 

Move the text object to provide more room for the Postnet bar code.



The specified bar code accepts numeric characters only.

You are attempting to print letters or other characters in a bar code that can encode numbers only. 
Check the data you are trying to print, including data from a linked list.



This field is already in the filter criteria list.

Each field can only be listed once in the filter criteria list. Highlight the field name in the filter criteria 
list and click the Delete button. Then use the Add button to add your new criteria.



This field is already in the sort criteria list.

Each field can only be listed once in the sort criteria list. Highlight the field name in the sort criteria list 
and click the Delete button. Then use the Add button to add the field.



This report will not fit on the current printer. Do you wish to continue?

The report-format listing printed by the program's list manager is too wide for the printer you have 
selected. Change printers and try again.



Unable to open the linked file. Use Link to List to link to a different file.

The program cannot open the file that is linked to this design. The file may be in use by another 
program. Correct this situation or use Link to List to link to a different file.



UPC-A must consist of 11, 13, or 16 digits.

UPC-A bar codes can only encode 11, 12 or 16 numeric digits. Check that the number you are 
attempting to print is the correct length. If you are merging into the bar code, check that the data in 
the linked list is the correct length.



UPC-E must consist of 6, 8, or 11 digits.

UPC-E bar codes can only encode 6, 8 or 11 numeric digits. Check that the number you are 
attempting to print is the correct length. If you are merging into the bar code, check that the data in 
the linked list is the correct length.



Warning - Cannot set printer settings to match stock. Printer must be set 
through printer setup

When running in Windows 3.0, the program cannot make the printer settings automatically. You must 
set the printer correctly using Control Panel before you print.



Your design extends outside the printable area of the page. Parts of the design 
may not print.

You have created a design that extends beyond the printable area of your printer. Most laser printers 
have an unprintable area around the edge of the page. The width of this area varies depending on the 
type of printer. 

At least one of the objects on your design extends into this unprintable area.

On most laser printers, the unprintable area is about 1/4" wide on each side of the sheet. Many Avery 
labels have a 1/8" side margin, so you need to allow at least an additional 1/8" side margin on your 
designs to insure that everything gets printed.

Because most Avery products have at least 1/2" top and bottom margins, you generally do not have 
to leave a top or bottom margin on your designs to avoid the unprintable region at the top and bottom 
of the page. However, due to the variation of the paper feed in laser printers, you should leave a small 
top and bottom margin to prevent your design from overlapping onto the label above or below.



Printer Errors

If you experience an error on your printer while printing from the program, there are several things 
you can do.

If you experience an out of memory error on your printer while printing a long job using the Shrink to 
Fit option, you may be able to avoid the error by selecting Print TrueType as Graphics in the Printer 
Setup, Options dialog box. Because Shrink to Fit may have to use many fonts to print in all the 
different sizes required, it may eventually overflow your printer's download font memory.

If you experience an error in the middle of a long print job, use the Start at Record option in the Print 
dialog box to re-start your job from the point at which the error occurred.



Cannot rotate object off the label. Move the object closer to center of label and 
then rotate

The rotation you are attempting will place part of the text object off the design. Either make the text 
object smaller, or move it towards the center of the design. Then rotate it.



Only TrueType text may be rotated. Change all fonts in the selected object to 
TrueType, then rotate

Only TrueType text may be rotated. Change all fonts in the selected object to TrueType, then rotate.



Only text will be copied. Use the Merge Fields command to add merge fields

When copying a merge field, only text is copied. Use the Merge Fields command on the Merge menu 
to add fields.



Copied object does not fit on the new label. Pick a bigger label, or copy missing 
object(s) individually

Copied object does not fit on the new label. Pick a bigger label, or copy missing object(s) individually.



New record will not be displayed because of your current filter. Remove the 
filter to view the new record.

Your current filter is set to exclude the record you just added.. Un-check the Filer Active command on 
the Record menu to view the new record.



Index file was corrupt and has been deleted. Please relink the file.

The index file for the list you are using became corrupt and has been deleted. Use the Link to List 
command to relink the file. You may also have to enter your sort criteria in List Manager.

 




