


 

COPYRIGHT AND LICENSE AGREEMENT

 

End User License Agreement
THIS IS A CONTRACT.  BY OPENING ANY OF THE SEALED SOFTWARE CONTAINERS, YOU ACCEPT ALL THE TERMS 
AND CONDITIONS OF THIS AGREEMENT. If you do not agree with the terms and conditions of this Agreement, return 
this entire package and the UNOPENED software containers to your place of purchase for a full refund.

1.Definitions
(a)“Deneba” means Deneba Systems, Inc., a Florida Corporation d/b/a Deneba Software.
(b)“Software” means the software programs included in this package.
(c)“Fonts” means all font software included in this package.
(d)“Clip Art” means all art, templates, and photos included in this package.
(e)“Product” means all Software, Fonts, Clip Art, manuals and other related documentation included in this package as 
well as all future related updates supplied by Deneba.

2.License – Deneba grants to you and you hereby accept a license to use the Product and all related materials delivered 
with this AGREEMENT as follows:
(a)The Software and Clip Art may be installed in one computer and may be used by more than one person on that com-
puter; however, in no event shall two or more persons use the Software and Clip Art at the same time. This restriction 
applies regardless of how many operating platform versions (e.g. Macintosh® and Windows™), language versions (e.g. 
English, German) or media copies (e.g. diskette or CD-ROM) may be included in this Product.
(b)You may make one copy of the Software, Clip Art and Fonts in machine-readable form for archival backup purposes 
only. As an express condition of this allowance you must reproduce on each backup copy any copyright notice or other 
proprietary notice that is on the original copy supplied by Deneba.
(c)You may transfer the entire Product and all rights granted herein on a permanent basis provided you retain no copies, 
the recipient agrees to the terms of this Agreement, and you notify Deneba in writing of the transfer of ownership.
(d)You may use the Fonts on a single computer and printer. A printer includes any output device such as, but not limited 
to, dot matrix, ink jet or laser printers, film recorders and image-setters. When using an outside service bureau, one copy 
of the Fonts may accompany the document in which the Fonts have been used. You must remove this copy from the ser-
vice bureau’s storage media upon completion of the service.
(e)You have the right to use, modify, and include Clip Art as illustrative or decorative material that is included as part of a 
total original graphic of your own design for use in print, film or computer media communications.

3.Restrictions
(a)You may not make or distribute copies of the Product. You should be aware that it is unlawful to copy, reproduce, or 
transmit any part of the Product in any form or by any means (including translation to another language, computer lan-
guage, or format) except as permitted by the Copyright Act of the United States (Title 17, United States Code). You are 
permitted to write the contents of the Software into the machine memory of your computer so that the software can be 
executed.
(b)You may not install this program on a network server nor lend usage of a copy of this software with metering software. 
These types of usage require a special license, unless a copy of this software is owned for each user on that network or 
each computer connected to that network. For information on this expanded license usage see section 4, Supplementary 
Licenses in this agreement.
(c)In order to protect Deneba trade secrets contained therein which may be revealed by such action, you may not reverse 
engineer, decompile, disassemble or otherwise reduce the Software or Fonts to any human readable or perceivable form.
(d)You may not modify, rent, resell for profit, distribute or create derivative works based on the Software or any part 
thereof.
(e)You may not resell or otherwise distribute the Clip Art contents, whether by themselves or as part of another collection, 
whether as computer images, printed images or any other medium. These restrictions apply to modifications of the Clip 
Art, whether or not they constitute derivative works under U.S. copyright laws, as well as to the original Clip Art.
(f)You agree not to modify, adapt or create derivative works based on the Fonts. Unauthorized copying of the Fonts, even 
if modified, merged, or included with other software is expressly forbidden.
(g)You agree not to export or reexport the Product into any country prohibited by the United States Export Administration 
Act.

4.Supplementary Licenses – If you wish to enter into a site license, network license or concurrent-use license agreement, or 
for more information on licensing the Fonts for additional printers, please contact Deneba.

5.Termination – Any failure to comply with the terms and conditions of this Agreement will result in automatic termination 
of this license. Upon termination of this license for any reason, you agree to destroy all copies of the Product.

6.Software Updates – Deneba may from time to time, at its own discretion, provide you with updates to the manuals and/
or Software. Deneba reserves the right to provide these updates for a fee. You may refuse to accept the updates. By 
accepting the updates, you agree to destroy all prior copies and versions of the Software and manuals (if applicable). Only 
then will the License granted to you by this Agreement transfer to the updated Software.

7.Ownership – This license gives you limited rights to use the Software, Fonts and Clip Art. Although you own the disks 
and CDs on which these are recorded, you do not become owner of the Software, Fonts and Clip Art, to which Deneba 
and/or its licensors retain all title to. All rights not specifically granted herein, including but not limited to Federal and Inter-
national Copyrights, are reserved worldwide by Deneba.

8.      Limited Warranty and Disclaimer, Limitation of Remedies and Damages – You hereby acknowledge that  you are 
solely responsible for selecting the Product and that the Product may not satisfy all your requirements or be free from 
defects. Deneba specifically does not warrant that the Software will operate uninterrupted or error free. You therefore 
agree to license the Product “AS IS.” Notwithstanding the foregoing, Deneba warrants to you (the original purchaser), that 
if you discover physical defects in the media on which the Software, Fonts and Clip Art is recorded, or in the manuals dis-
tributed with the Product, Deneba will replace the media or manuals at no charge, provided you return the defective 
items, postage prepaid and with proof of purchase, within 90 days of the date of original purchase. Your exclusive remedy 
for breach of warranty will be the replacement of the diskettes, CDs or manuals or the refund of the purchase price.

Deneba reserves the right to revise the Product without obligation to notify any person of such revision. In no event shall 
Deneba or its developers, directors, officers, employees or affiliates be liable to you for any indirect, special, incidental, or 
consequential damages (including damages for loss of business profits or goodwill, business interruption or loss of busi-



 

ness information), resulting from any defect in the Product whether foreseeable or not, arising out of the use or inability to 
use the Product. Deneba’s liability to you or others for actual damages for any cause whatsoever, will in no event exceed 
the lesser of US$500 or the amount paid by you for the Product that caused the damages.  In particular, Deneba shall have 
no liability for any data stored in or used with Deneba Products, including the cost of recovering such data.

EXCEPT AS SPECIFICALLY STATED HEREIN, DENEBA MAKES NO OTHER WARRANTIES, EXPRESSED OR IMPLIED, 
WITH RESPECT TO THE SOFTWARE, MEDIA, CLIP ART, FONTS OR MANUALS INCLUDING (BUT NOT LIMITED TO) 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.  THE WARRANTY AND 
REMEDIES SET FORTH ABOVE ARE EXCLUSIVE AND IN LIEU OF ALL OTHERS, ORAL OR WRITTEN, EXPRESSED OR 
IMPLIED. IF APPLICABLE LAW IMPLIES ANY WARRANTIES WITH RESPECT TO THE PRODUCT, ALL SUCH WARRANTIES 
ARE LIMITED TO (90) NINETY DAYS FROM THE DATE OF DELIVERY. No Deneba dealer, agent, or employee is autho-
rized to make any modification, extension, or addition to this warranty.

Some states do not allow limitations on how long an implied warranty lasts or the exclusion or limitation of implied warran-
ties or liability for incidental or consequential damages, so the above limitation or exclusion may not apply to you.  This 
warranty gives you specific legal rights and you may also have other rights which vary from state to state.

9.U.S. Government Restricted Rights – This Deneba Product is “Restricted Computer Software.”  Use, duplication, or dis-
closure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data 
and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Soft-
ware - Restricted Rights at 48 CFR 52.227-19, as applicable. The manufacturer is Deneba Systems, Inc., 7400 S.W. 87th 
Avenue, Miami, Florida 33173.

10.General – This agreement shall be governed by the laws of the State of Florida. This document contains the entire 
agreement between you and Deneba with respect to the subject matter hereof and supersedes all prior agreements 
between you and Deneba. All questions concerning this agreement should be sent to: Deneba Systems, Inc., Attn. Chief 
Financial Officer, 7400 S.W. 87th Avenue, Miami, Florida 33173.

LICENSES,  TRADEMARKS AND COPYRIGHTS

Canvas Software was designed, programmed and is Copyright © 1985-1998 Deneba Systems, Inc. All Rights Reserved. 
Canvas and Deneba are trademarks of Deneba Systems, Inc. and may be registered in certain jurisdictions. Contains an 
implementation of the LZW algorithm licensed under U.S. Patent 4,558,302 and foreign counterparts. The Proximity/Mer-
riam-Webster Hyphenation System ©1990 Merriam-Webster, ©1990 All rights reserved Proximity Technology, Inc. Imag-
eStream® Graphics & Presentation Filters Copyright © 1991-1996 Inso Corporation All Rights Reserved. Portions of the 
graphics filters © 1996 Access Softek. Trumatch 4-Color Selector © 1996 Trumatch, Inc. Toyo Color Finder and Color Data 
Copyright © 1996 Toyo Ink Mfg. Co., Ltd.

Mac OS, QuickDraw, QuickDraw 3D, QuickTime, TrueType and System 7 are trademarks, and Apple, LaserWriter, Macin-
tosh and Power Macintosh are registered trademarks of Apple Computer, Inc. Windows, Windows 95 and Windows NT 
are trademarks of Microsoft Corp. Adobe, Adobe Illustrator, Adobe Photoshop, and PostScript are trademarks of Adobe 
Systems, Inc. which may be registered in certain jurisdictions. QuickHelp is a trademark of Altura Software, Inc. Toyo is a 
trademark of Toyo Ink Manufacturing Co., Ltd. Trumatch is a registered trademark of Trumatch Inc. MacPaint is a regis-
tered trademark of Claris Corp. Photo CD is a trademark and KODAK is a registered trademark of Eastman Kodak Co. 
PANTONE®* Computer Video simulations used in this product may not match PANTONE-identified solid color standards.  
Use current PANTONE Color Reference Manuals for accurate color.  *PANTONE Color Computer Graphics © Pantone, 
Inc. 1986, 1988.  Pantone, Inc. is the copyright owner of PANTONE Color Computer Graphics and Software which are 
licensed to DENEBA SOFTWARE to distribute for use only in combination with Canvas.  PANTONE Color Computer 
Graphics and Software shall not be copied onto another diskette or into memory unless as part of the execution of Canvas. 
All other brand and product names are the property of their respective holders.

FONTS  Copyright © 1992 URW++ GmbH Hamburg, Germany and URW America, Nashua, NH.  All Rights Reserved.

CLIP ART   Copyright © 1986–1998 Deneba Systems, Inc.  Portions licensed from Produktum AB,  C.A.R. Inc., Artbeats 
Software, Inc., SuperClip, Inc., ARISEN, Corp., RT Computer Graphics, Inc., Advanced System Design, Inc.
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INTRODUCING CANVAS

 

This guide introduces Canvas, an integrated program with powerful 
features for illustration, precision drawing, painting and image 
editing, text layout, and web publishing.

This 

 

Getting Started Guide

 

 is divided into sections that highlight a 
range of Canvas features. A series of lessons present procedures and 
examples for you to follow. We recommend that you complete as 
many lessons as possible if you are a new Canvas user. If you’ve 
used Canvas before, we recommend that you follow the lessons that 
describe new features such as transparency, text object attributes, 
column layouts, and enhanced image editing.

The lessons in this guide are designed to familiarize you with many 
of the features in Canvas. By working through the lessons, you will 
gain a basic understanding of the program’s capabilities while you 
learn how to use the Canvas interface. You can complete the lessons 
in order, or skip to the ones you feel are most relevant to you.

When you want to learn more about a particular feature, refer to the 
Canvas 

 

User’s Guide

 

 and the 

 

Color Printing Guide

 

. These books 
provide complete information on how to use the features that are 
introduced in the tutorial lessons. You can also refer to the on-line 
Help system for step-by-step instructions while you use Canvas.

 

Before you begin

 

The tutorial requires that you understand common terms and 
procedures for your operating system. You should know how to do 
the following:

 

•

 

launch applications

 

•

 

open and save files

 

•

 

perform basic actions with the mouse, including clicking 
and dragging

 

•

 

move, close, and resize windows

 

•

 

use menu commands

 

•

 

use the keyboard, including modifier keys such as the Ctrl 
key
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If you are not familiar with these operations, consult your operating 
system manual or a basic computing reference book for instructions.

 

Canvas basics

 

Canvas integrates a wide range of features under one interface. 
Unlike separate image-editing, page layout, and illustration 
programs, Canvas lets you use a core set of tools and procedures to 
work with all different types of objects. 

This section introduces basic procedures, including working with 
documents, selecting objects, editing objects, and undoing actions. 
These procedures are used throughout the lessons in this guide.

To learn about Canvas basics, launch Canvas. A new blank document 
appears. You can work in this blank document, or use the File > 
Open command to open one of the sample files in the Tutorials 
folder, which is inside the Canvas application folder.

 

Selecting and moving objects

 

To select, move, and edit items in Canvas, you use the Selection tool 
in the toolbox. When the Selection tool is active, the pointer is an 
arrow. 

Selecting objects is one of the most common operations in Canvas. 
You select objects when you want to apply commands and attributes, 
copy, or edit them.

 

•

 

To select an object, click the object with the Selection tool.

 

•

 

To select more than one object, Shift-click each object, or 
drag a selection box around the objects with the Selection 
tool.

When you select an object, a rectangle called a 

 

bounding box 

 

appears 
around the object.

To move an object, drag it with the Selection tool. To move multiple 
objects, first select the objects you want to move, and then drag one 
of the objects.

You can also use the Selection tool to place objects in 

 

edit mode.

 

 Edit 
modes let you modify objects in special ways. Edit modes are 
described on page 7. 

 

◆

 

To place an object in edit mode:

 

Double-click the object with 
the Selection tool.

Selection tool

Canvas toolbox



 

Canvas basics

 

7

 

Selecting tools from the toolbox

 

To use a tool, you select it from the 

 

toolbox

 

. The toolbox contains all 
the Canvas tools used for drawing, text, image-editing, and effects. 
The toolbox displays 10 tools at a time, while the remaining tools are 
available from toolbars that pop out from the toolbox.

The toolbox can be used as a floating palette that you can place 
anywhere on screen. You can also dock the toolbox on the Docking 
bar. To dock the toolbox, drag it onto the Docking bar.

 

Note:

 

 If you ever close the toolbox, you can display it again by 
choosing Window > Palettes > Show Toolbox.

 

◆

 

To select a tool displayed in the toolbox:

 

Click the tool’s 
icon. 

 

Selecting tools from toolbars

 

Try the following procedure for selecting a tool from a toolbar by 
opening the Rectangles toolbar and selecting the Rounded Rectangle 
tool.

 

Macintosh

 

To select a tool that isn’t displayed in the toolbox, press 
(hold the mouse button down on) the icon of the toolbar that contains 
the tool. Drag into the toolbar and release the mouse button when the 
tool you want to select is highlighted. 

 

Windows 

 

To select a tool that isn’t displayed in the toolbox, press 
(hold the mouse button down on) the icon of the toolbar that contains 
the tool. Click the icon of the tool you want to select. 

 

Using edit modes

 

Canvas has three major types of objects — vector, text, and paint 
objects. Each of these types has an associated 

 

edit mode.

 

Path edit mode

 

Path edit mode is for editing the paths of vector 
objects. In path edit mode you can change the shape of a vector 
object by adding, deleting, and moving anchor points.

A bounding box 
with handles surrounding 
a selected object

Drag with the 
Selection tool 
to make a Selection 
box

Selecting the Rounded 
Rectangle tool
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Text edit mode

 

Text edit mode is for editing text. In text edit mode 
you can type text, select specific characters to edit, and place the 
insertion point in text. In this mode, the pointer is an I-beam. Drag 
the I-beam over text to select it. Click in a text object to place the 
insertion point.

 

Paint edit mode

 

Paint edit mode is for painting and editing images. 
In paint edit mode, you can edit the pixels of an image using the 
painting tools and Image menu commands.

Other edit modes are available for specialized objects, such as 
extrusions and multigons; see the 

 

User’s Guide

 

 for instructions on 
editing specific objects.

 

Zooming the document view

 

You can change the magnification of the viewing area to see specific 
objects in detail or view the layout of an entire page. This is called 

 

zooming

 

 your view of the document.

Although objects appear to change size and position on screen when 
you zoom, in reality the objects do not change either size or position 
in the document. 

To change the area and view magnification, you can use menu 
commands, the Magnifying Glass tool, the Zoom bar, and the Zoom 
palette.

 

◆

 

To use menu commands to change views:

 

In the Views 
submenu in the Layout menu, choose a command to change views:

 

This command Does this

 

Zoom In Increases screen magnification

Zoom Out Decreases screen magnification

Fit to Window Adjusts the magnification to make the entire 
layout area fit the current window size

Home View Sets screen magnification to 100 percent, 
with the layout area in the upper-left corner 
of the window

New View Lets you save custom view settings with a 
name that will appear in the menu

Zoom Lets you enter a zoom percentage
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To use the Magnifying Glass tool

 

1

 

Select the Magnifying Glass tool in the toolbox. On Mac, you 
can press Tab+Option to temporarily select the tool. On Windows, 
you can press Ctrl+Spacebar to temporarily select the tool.

 

2

 

Click or drag over an area to increase magnification. To 
decrease magnification, press the Shift key as you click or drag.

 

To use the Zoom bar

 

The Zoom bar is at the bottom-left of the document window. The 
center of the bar shows the current magnification percentage. 

 

◆

 

To zoom in or out:

 

Click the Zoom-in button to increase 
magnification. To decrease magnification, click the Zoom-out 
button.

 

◆

 

To select a magnification percentage:

 

Press the center of the 
Zoom bar and drag the slider to set the magnification percentage.

 

Scrolling documents

 

You can use scroll bars or the Hand tool to move to areas of a 
document that are not visible in the current view.

 

To use the scroll bars

 

Click a vertical scroll arrow to move the view up or down. Click a 
horizontal scroll arrow to scroll left or right. You can drag the scroll 
box or click the scroll bar. 

The position of the scroll box within a scroll bar indicates the 
location of the current view relative to the entire document area. 

 

To scroll with the Hand tool

 

You can use the Hand tool to “slide” the document around the screen.

 

1

 

Select the Hand tool in the toolbox. Or, press and hold down 
the Spacebar to temporarily select the tool. 

 

2

 

Drag in the document to move the document in the direction 
you drag. 

Magnifying Glass tool

Zoom-out Zoom-in

To keep the Zoom palette open, 
drag it away from the Zoom bar 

You can type magnification levels here

Scroll box

Horizontal scroll bar

Vertical scroll bar

Hand tool
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For more information on Canvas interface features, including the 
Docking bar, Toolbar, Status bar, page icons, and the Layout area, 
refer to “Overview of the Canvas interface” on page 9 of the 

 

User’s 
Guide

 

.

 

Undoing recent actions

 

Canvas encourages you to experiment because you can reverse 
actions by choosing Edit > Undo. You can undo as many actions as 
your system can store in memory. The Undo command reverses 
actions in the opposite order from which you performed them. 

Canvas can’t undo actions performed before the last time you saved a 
document. Also, zooming and scrolling can’t be reversed with Undo.

 

Saving documents

 

As you work on sample documents while following the lessons in 
this guide, you might want to save your work and keep the original 
files. To do this, use the Save As command in the File menu. 

 

Moving on

 

Now that you’ve been introduced to some basic procedures in 
Canvas, you’re ready to learn more! Read on and follow the tutorial 
instructions in the remainder of the guide.

Drag with the Hand tool to 
slide a document in the 
document window

✔Tip
You can set the number of 
levels of undo with the 
Preferences command in the 
File menu.

✔Tip
If you choose Save in the File 
menu instead of Save As, Can-
vas replaces the original tutori-
al files with the new document. 
If this happens, you can re-
install the original files from the 
Canvas CD-ROM.
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NEW FEATURE HIGHLIGHTS

 

In this chapter, you will learn about some of the key new features in 
Canvas. If you are familiar with previous versions of Canvas, this 
section will introduce you to a few of the new capabilities. If you are 
new to Canvas, you will learn about some of the innovative features 
that set Canvas apart from other graphics software programs.

In this chapter, you will learn how to do the following:

 

•

 

customize the Canvas interface 

 

•

 

apply transparency effects to all types of objects

 

•

 

use new drawing tools

Keep in mind, however, that there are so many additions to Canvas 
that not all of the new features can be covered in this tutorial. The 

 

User’s Guide

 

, the Deneba web site (www.deneba.com) and the on-
line Help system provide complete information about new features.

 

Customizing the Canvas interface

 

Canvas 6 has several new options for setting up your working 
environment to make you more efficient. In this lesson, you will 
make some changes to the interface to become more familiar with 
Canvas’ capabilities. You will learn how to:

 

•

 

dock palettes at the top of the window for easy access

 

•

 

create a custom Toolbar

 

•

 

assign keyboard shortcuts to commands, attributes, and 
styles

 

Using the Docking bar

 

Any Canvas floating palette can be “docked” in the Docking bar at 
the top of the window. Palettes that you can dock include tool 
palettes that you drag away from the toolbox; the Inks, Strokes, 
Transparency, and Brushes palettes; and command palettes such as 
Align, Blend, Envelope, Object Specs, and Type. 
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A docked palette appears as a tab on the Docking bar. Clicking the 
tab opens the docked palette. After you use the docked palette or 
click away from it, the palette returns to its docked appearance. 

The Docking bar is displayed by default the first time you launch 
Canvas, and you can hide or display the Docking bar at any time.

 

◆

 

To display the Docking bar:

 

Choose Window > Palettes > 
Show Docking Bar. The palettes that were docked the last time the 
Docking bar was displayed appear in the Docking bar; they might not 
be the same ones as shown below, but that’s okay. 

After completing this exercise, if you want to hide the Docking bar, 
choose Window > Palettes > Hide Docking Bar.

 

To dock a palette

 

Now try docking some palettes on your own. 

 

1

 

In the toolbox, press the Strokes icon to open the palette and 
drag it away from the toolbox so that it is floating.

 

•

 

If the Stokes palette is already open or docked, this step re-
opens it and removes it from the Docking bar.

 

2

 

Drag the Strokes palette title bar to the Docking bar and drop 
the palette when a tab outline appears in the Docking bar.

The Strokes palette is now docked and ready for instant access.

You can dock as many palettes as you can fit on the Docking bar.

Strokes icon
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Using a docked palette

 

Now you’ll use the Strokes palette to apply an outline effect while it 
is docked. 

 

1

 

Select the Oval tool in the Ovals toolbar and draw an oval in 
the document. Make sure the oval is selected; you’ll apply a stroke 
to this oval in a moment.

 

2

 

Click the Strokes tab on the Docking bar. The palette opens. 
Click the Neon tab in the palette.

 

3

 

Click one of the preset Neon strokes to apply it to the oval you 
just drew. Canvas applies the Neon stroke. To close the palette, 
click anywhere outside the palette.

 

◆

 

To change the position of a docked palette:

 

Drag the 
palette’s tab along the Docking bar. The tab can overlap other tabs or 
pass them. There’s no limit to the number of tabs you can have, but 
depending on your screen resolution and size, they might overlap.

 

◆

 

To remove a docked palette:

 

Drag the palette’s tab away from 
the Docking bar.

 

Customizing the Toolbar 

 

You can create your own set of keyboard shortcuts for commands, 
tools, colors, and styles to help you work more efficiently. You can 
also place buttons for these items on the Toolbar at the top of the 
screen so that the features you use most are always quickly 
accessible. In this exercise, you’ll add a tool to the Toolbar and create 
a keyboard shortcut.

Before starting this exercise, make sure the Toolbar is displayed at 
the top of the window. 

 

◆

 

To display the Toolbar:

 

Choose Window > Palettes > Show 
Toolbar to display the Toolbar.

 

To customize the Toolbar

 

You are going to place a button on the Toolbar for the Combine 
command.

1 Choose File > Customize. The Customize dialog box appears.

• In the Customize dialog box you can create Toolbar sets and 
your own keyboard shortcuts, which is described in the 
following exercise.

Selecting the Oval tool
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2 In the Category pop-up menu, choose Menus. You can see 
there are other options, but you’re choosing Menus because 
Combine is a menu command.

3 In the Sub-Category pop-up menu, choose “Effects.” This is 
the menu that contains the Combine command. The Effects menu 
commands appear in the scrolling list.

4 Locate “Combine” in the scrolling list and double-click it. 
Notice the button that is added to the Toolbar for this command. 

• If you want to remove the button from the Toolbar, double-
click the Command in the scrolling list again.

5 Click the Close button to exit the Customize dialog box.

Now try using the new button you just added. Click the Combine 
button in the Toolbar to open the Combine palette.

After you place buttons on the Toolbar, you can change their 
arrangement. Try the following:

• Move the Combine button by pressing Shift and dragging it 
to a new location. 

• Add a separator line before the Combine button by Shift-
dragging the Combine button slightly to the right.

• Remove the Combine button from the Toolbar by pressing 
Shift and dragging the button away from the bar.

Double-click a command name to 
place a button on the Toolbar
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Customizing keyboard shortcuts
You can easily create your own keyboard shortcuts. In addition to 
shortcuts for commands, Canvas lets you create shortcuts for colors 
(inks), strokes, object styles, fonts, and type sizes. In this exercise, 
you will assign a shortcut key to a color ink.

1 Choose File > Customize. The Customize dialog box appears.

2 In the Category pop-up menu, choose Inks.

3 Press the color icon next to the label, “Add ink to grid.” The 
Inks palette appears. 

4 Select a color ink on the Color tab. Selecting an ink adds it to 
the scrolling list, and a button for the ink appears on the Toolbar. 

• If you don’t want a selected ink to appear in the Toolbar, 
double-click the item in the scrolling list.

5 To assign a keyboard shortcut to this ink, click in the text box 
labeled “Press New Shortcut Key.” In this case, you are going to 
assign “Control+Shift+1” as the shortcut key for this ink. To do 
this, Press the Control, Shift, and numeral “1” keys simultaneously; 
you’ll see the key names appear in the text box. 

6 Buttons labeled “Fill” and “Pen” appear. Select the Fill button. 
This tells Canvas that the keystrokes you typed are a shortcut for 
applying a fill ink.

7 Click Assign to assign the keystrokes to the ink. Click Close to 
close the Customize dialog box. 

Now try using the shortcut you just created. Select the Rectangle tool 
in the Rectangles toolbar, draw a rectangle, and then press 
Control+Shift+1. The rectangle fills with the color you selected.
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Creating transparency effects
Canvas has several new features that make it very easy to apply 
transparency effects to paint, text, and vector objects. In the next few 
exercises, you’ll become familiar with several types of transparency 
effects.

Besides the procedures that are introduced here, there are several 
other methods you can use to create transparency effects. For details, 
see the “Transparency Effects” chapter in the User’s Guide.

Changing an object’s opacity 
The simplest way to create a transparency effect is to change the 
overall opacity of an object or group of objects. 

To see an example of how opacity can make objects transparent, 
open the document named “Engine.cnv” in the Tutorial folder, then 
follow these steps: 

1 Click the main engine section to select it. The selected object is 
outlined by a bounding box.

• You should have selected the gray engine cover. Behind the 
cover is an illustration of the engine’s internal parts. 
Because the opacity of the engine cover is 100%, the illus-
tration behind it can’t be seen.

2 Use the Opacity slider in the toolbox to reduce the opacity of 
the selected objects.

Selecting the engine cover
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Mac: Press the Opacity icon and drag the Opacity slider to 
about 40%.

Windows: Click the Opacity icon and then drag the Opacity 
slider to about 40%. 

Reducing the opacity of the selection reveals the vector objects that 
are in back, producing a cutaway view of the jet engine parts.

When you finish this exercise, you can choose File > Save As to save 
a copy of your work in a new file before closing, or just close the 
original file without saving changes.

Creating transparency with a transfer mode
Canvas lets you apply transfer modes to any objects. Transfer modes 
determine how overlapping colors interact. Try this example of 
making an object on a map appear transparent so you can see the 
underlying illustration. 

To begin, open the document named “Multiply.cnv” in the Tutorial 
folder. The document contains a map illustration with a large star 
covering one area of the map. 

Press the Opacity icon and 
drag the slider to set the 
object’s opacity

Opacity icon

Reducing the Opacity reveals the illustration 
behind the engine cover
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1 Click the star to select it The star is a multigon object drawn in 
Canvas.

2 Open the Transparency palette by doing either:

• Choose Window > Palettes > Show Transparency. 

• Press the Opacity icon in the toolbox and drag the slider 
away from the toolbox to open the palette.

3 In the Transparency palette, choose Multiply in the Transfer 
Mode menu. Canvas applies the Multiply transfer mode to the 
selected object.

• When you choose Multiply, the map behind the star 
becomes visible, as if the star was part of the original map! 
This is a great shortcut for adding color and emphasis to 
scanned images.

• In the Transfer Mode menu, notice the other options for 
combining the colors of overlapping objects. 

Choosing Multiply in the 
Transfer mode menu

Select the star

The star 
appears 
transparent in 
Multiply mode
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When you finish this exercise, you can choose File > Save As to save 
a copy of your work in a new file before closing, or just close the 
original file without saving changes.

Applying vector transparency masks
Transparency masks can create transparency in all types of objects. 
You can use a variety of tools and techniques to apply transparency 
masks in Canvas.

The Vector Transparency tools let you apply masks the same way 
you would use similar tools to apply color gradients. However, rather 
than apply inks that fade from one color to another, the Vector 
Transparency tools apply masks that fade from opaque to transparent.

Vector Transparency tools are in the Effects toolbar. In the following 
exercise, you will use a Vector Transparency tool to apply a mask to 
type, so it appears to fade from opaque to transparent on an 
illustration.

To begin, open the file named “Cover.cnv” in the Tutorial folder. 
This document contains an illustration with large colored type near 
the bottom. (Because the type is made of vector objects and not 
actual text, the document doesn’t require a particular font).

To apply vector transparency masks

1 Tear off the Vector Transparency tools from the toolbox to 
create a floating palette. This will give you easy access to the whole 
set of tools.

2 Click the type in the document to select the object. This is a 
group object. 

3 Select the Directional Vector Transparency tool:  

4 Drag across the type from the bottom to the top. When you 
release the mouse, the transparency vector appears. The vector is a 
line that shows the fade direction and length.

• If you drag to the midpoint of the type, the bottom of the 
type fades to transparent. 

• When the Directional Vector Transparency tool is selected, 
you can drag the vector handles to adjust the effect. You can 
move one handle above the other to change the fade 
direction.

Selecting Vector 
Transparency 
tools

A B C D

A Radial
B Directional 
C Rectangular
D Elliptical
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5 Press Esc when you finish to leave edit mode.

You can use the other Vector Transparency tools to create fades in 
various shapes. You can experiment with the Elliptical tool to create 
an oval vignette.

1 Click the illustration of the space craft to select it.

2 Select the Elliptical Vector Transparency tool. 

3 Drag across the illustration from the upper-left corner to the 
lower-right corner. You don’t have to be too precise when you 
drag, because you can easily adjust the effect. After you drag, 
vector handles appear. 

• Drag the handle that is near the upper-left corner towards 
the center of the graphic. An oval shape encloses the area 
that will not be transparent.

• Drag the handle that is at the upper-left corner toward the 
inside oval. The outside oval represents the area where the 
image becomes completely transparent.

4 Continue to adjust the effect by dragging the handles. When 
you finish, press Esc to leave edit mode.

Selecting the type

Dragging the Vector Transparency tool displays the 
transparency vector. Handles represent the fade start and 
end. Drag the handles to adjust the fade.
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When you finish this exercise, you can choose File > Save As to save 
a copy of your work in a new file before closing, or just close the 
original file without saving changes.

Creating transparency with channel masks
You can apply a pixel-based transparency mask, called a channel 
mask, to any object in Canvas. 

Channel masks let you use painting and image-editing tools to define 
transparent areas in an object. For example, you can use soft brushes 
to paint faded edges, and use tools like Blend and Rubber Stamp to 
create special effects.

In the next exercise, you will see how a channel mask lets you 
“paint” transparent areas in a photograph to reveal an underlying 
illustration.

To begin, open the file named “Hand.cnv” in the Tutorial folder. This 
file contains a photograph of a hand, which is positioned over an 
illustration of the hand anatomy.

Drag the handles to adjust the fade
effect. The handle at the upper-left

corner sets the border where the
illustration fades out.

Vignette created with transparency mask

Handles



22 Getting Started Guide

1 To create the channel mask on the photograph, do either:

• Macintosh: Press Option and double-click (Mac) the photo-
graph.

• Windows: Press Ctrl and double-click the photograph. 

Canvas creates a channel mask that has the same resolution as the 
photograph. The channel mask appears in edit mode, as indicated 
by crop marks at the corners of the image.

2 Select the Paintbrush tool in the Painting Tools toolbar. Notice 
that the Brush icon appears in the toolbox. 

• You can select a brush size by pressing the Brush icon.

• Select black ink from the foreground color icon (if 
necessary). Painting black in a channel mask produces 
transparent areas.

3 Drag the Paintbrush tool over the fingers and the back of the 
hand in the photograph. The areas you paint become transparent.

• If the transparency display is set to No Preview, you see a 
checkerboard pattern in areas of the photograph that are 
transparent.

• If the transparency display is set to Background Preview or 
Total Preview, you can see through transparent areas in the 
photograph to the illustration in back.

4 When you finish painting in the channel mask, press Esc to 
leave channel mask edit mode. Canvas displays the final image.



Using new drawing features 23

When you finish this exercise, you can choose File > Save As to save 
a copy of your work in a new file before closing, or just close the 
original file without saving changes.

Using new drawing features
Canvas 6 has several new drawing features that not only help you 
create objects more precisely, but also offer you additional creative 
options, too. In this lesson, you will see how to use the Object Specs 
palette, the Transform palette, the Knife tool, and the Gradient 
Vector tool.

The original photograph covers an 
illustration of the hand anatomy (far right)

A view of the channel 
mask alone shows how 

painting with black (above) creates 
transparency in the finished photograph 
(right)



24 Getting Started Guide

Creating objects using the Object Specs palette
You can create and position rectangles, rounded rectangles, ovals, 
arcs, lines, and polygons with precision by using the Object Specs 
palette. 

The following procedure shows you how to create an oval using the 
Object Specs palette. To begin, create a new blank document in 
Canvas by choosing File > New.

1 Choose Object > Object Specs to open the Object Specs 
palette.

2 On the Data tab, choose the oval from the Object Type palette. 
Choose Height/Width in the adjacent pop-up menu.

3 To specify the height, width, and placement of the oval, type 
the following values in the text boxes:

Top Type “5” in the text box. This is the vertical distance from the 
ruler’s zero point to the top edge of the oval.

Left Type “4” in the text box. This is the horizontal distance from 
the ruler’s zero point to the left edge of the oval.

Height Type “2” in the text box. This is the height of the oval 
relative to its top edge. 

Width Type “4” in the text box. This is the width of the oval 
relative to the left edge of the oval.

4 Click Create. Canvas creates the oval you specified.

You can experiment now to create other objects according to values 
you specify in the Object Specs palette.

Using the Transform palette
The Transform palette provides a control center to rotate, scale, 
skew, or position objects precisely. 

To introduce this palette, the following procedure shows you how to 
move the oval (created in the previous procedure) 1 inch to the right, 
and then skew the oval 10 degrees.

1 Choose Effects > Transform to open the Transform palette.

2 Select the oval created in the previous exercise.

3 Type “1” in the “∆X” text box and press Enter. This moves the 
oval one inch to the right.

Object Type palette
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• Type a negative number to move the object to the left.

4 Type “10” in the text box next to the Skew button and press 
Enter. This skews the object 10 degrees to the right.

Dividing objects with the Knife tool
You can divide vector objects by drawing a freehand cutting path 
with the Knife tool. To see how this works, you will “shatter” a 
drawing of a glass.

To begin, Open the document named “Glass.cnv” in the Tutorial 
folder. This document contains a vector illustration of a glass.

1 Select the Knife tool in the Effects toolbar.

• To set the Knife options, double-click the Knife tool icon. 
In the dialog box, you can choose Cut All Objects or Cut 
Only Selected Objects. For this exercise, be sure that Cut 
All Objects is selected.

2 Drag the Knife tool across the glass illustration to draw a zig-
zag line. Don’t release the mouse until you draw a cutting path all 
the way through the glass. When you release the mouse button, 
Canvas calculates a split through the object.

3 With the Selection tool, you can drag segments of the glass 
away from their current placement. You’ll be left with a broken 
wine glass!

The Knife path cuts across a 
glass illustration, with the 
remaining piece shown (right)
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Applying gradient inks across objects and text
With the Gradient Vector tool, you can not only apply gradients 
directly to an object, you can also apply a gradient across several 
selected objects or text.

1 Choose File > Open and locate and select the document named 
“Gradient.cnv” in the Tutorial folder in the Canvas application 
folder. Click Open. This document contains objects to which you 
will apply gradients.

2 With the Selection tool, drag a selection box around the 
random assortment of rectangles to select them all.

3 Select the Gradient Vector tool in Effects toolbar.

4 Drag across the selected rectangles. Notice how the gradient 
ink fills the objects as though they were all part of one object.

The tool works the same way on text, so you can spread a gradient 
across an entire text block or a headline.

1 Select the large text in the document.

2 Select the Gradient Vector tool again, and drag across the text.

Notice how the gradient spreads across all the characters in the text 
object to create a smooth blending effect. The best part is that the text 
is still editable!

✔Things to know
The Gradient Vector tool 
applies the last default gradi-
ent ink. To see this, open the 
Inks palette and check the Gra-
dient manager at the bottom. 
The gradient in the preview 
window is the ink that the Gra-
dient Vector tool applies.
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DRAWING BASIC SHAPES

This lesson introduces you to basic drawing techniques, and is good 
for the beginner or someone learning the Canvas interface. You will 
learn how to draw lines, rectangles, ovals, and arcs. These objects are 
called vector objects in Canvas. You can use the same drawing 
techniques to draw most vector objects, including rounded 
rectangles, polygons, concentric circles, and spirals.

Throughout the following exercises, you can use any blank 
document. You will be experimenting with each of the tools. As you 
draw more and more objects, if you need more space, you can either 
open another document or select the objects you have already drawn 
and delete them.

Using drawing tools
When a drawing tool is selected, the pointer changes to a crosshair, 
indicating that you are ready to draw.

You draw most vector objects by dragging where you want to draw 
the shape. “Dragging” is defined as pressing and holding down the 
mouse button while you move the mouse, and then releasing the 
button.

To set the size of a vector object such as a rectangle, line, oval, or arc, 
you drag from one corner to the opposite corner of an invisible box. 
When you finish, the object fits inside the box you have defined. This 
invisible box is called a bounding box. When an object is selected, 
the bounding box becomes visible. 

You can use the Status bar, which is the bar at the bottom of the 
Canvas window (if you are using Windows) or at the bottom of the 
screen (if you are using Mac) to see the size of the object you are 
drawing. The Status bar is always displayed in Canvas for Windows. 
In Canvas for Mac OS, you can choose Window > Palettes > Show 
Status Bar if the Status bar is not displayed.

Drawing lines with the Line tool

You can use the Line tool to draw straight lines at any angle. The 
Line tool lets you choose where to start and where to end the line.
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1 Select the Line tool from the toolbox.

2 Place the pointer where you want the first endpoint of the line, 
and begin to drag to the next point. The line extends from the first 
point as you drag. 

3 Release the mouse button when the line is as long as you want.

The line appears with a handle at each end point. The handles show 
that the line is selected.

You can draw straight horizontal, vertical, and diagonal lines by 
using a modifier key to limit the movement of the pointer when you 
drag with the Line tool. You can make the Line tool snap to any 45 
degree angle by pressing the Shift key while you drag. 

If you press Shift and drag horizontally, you can create straight 
horizontal lines. If you press Shift and drag vertically, you create 
straight vertical lines. If you press Shift and drag diagonally, you 
create straight diagonal lines. Try drawing some of these lines by 
using the Shift constraint.

Drawing rectangles and squares

You can use the Rectangle tool to draw rectangles and squares. To 
draw with this tool, you drag from one corner to the other corner of 
the rectangle you want to create.

1 Select the Rectangle tool from Rectangles toolbar.

2 Place the pointer where you want one corner of the shape and 
begin to drag diagonally to the opposite corner. The rectangle 
grows from the first corner as you drag. 

To draw a line, drag from one 
endpoint to the other

Start here

Drag to here

A finished line has handles 
at its endpoints

Handle

✔Try this
To draw a line at any 45 degree 
angle, press the Shift key while 
you drag the Line tool.

✔Try this
To draw a square with the Rect-
angle tool, press the Shift key 
while you drag.
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3 Release the mouse button when the rectangle is as big as you 
want.

The rectangle appears with a handle at each corner and one at each 
side. The handles show that the rectangle is selected.

You can drag diagonally while pressing the Shift key to draw 
squares. Try experimenting with the Rectangle tool to create different 
shapes.

Drawing ovals and circles

You can use the Oval tool to draw ovals and circles. To draw with 
this tool, you drag from one corner to the opposite corner of an 
invisible box. This bounding box contains the oval or circle that 
you’re drawing.

1 Select the Oval tool from the Ovals toolbar.

2 Place the pointer where you want one corner of an invisible 
box containing the oval. Begin to drag to the opposite corner of the 
box. The oval grows diagonally from the first point as you drag. 

3 Release the mouse button when the oval is the size you want. 
The oval appears with a bounding box and handles at the corners 
and sides of the box. This shows that the oval is selected.

Drag from one corner to the 
opposite corner

Start here

Drag to here

A finished rectangle has 
handles on its bounding box

Bounding box

Handle

✔Tip
To constrain an oval to a circle, 
press the Shift key while you 
drag.
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To draw a circle, press the Shift key as you drag the Oval tool 
diagonally.

You can draw an oval from its center. This means you can place the 
center of the oval where you begin dragging. Try this method by 
placing the pointer where you want the center of the oval. If you are 
using the Mac, press Option and drag away from the center. If you 
are using Windows, press Ctrl and drag away from the center. Notice 
that the oval grows outward as you drag. Release the mouse button 
when the oval is as large as you want. This same modifier key works 
on other types of vector objects too.

Drawing arcs

You can use the Arc tool to draw arcs. An arc is a segment of an 
ellipse or a circle. The Arc tool lets you choose where to start and 
where to end the arc.

1 Select the Arc tool from the Ovals toolbar.

2 Place the pointer where you want one end of the arc. Begin to 
drag toward the other end of the arc. The arc grows from the first 
point as you drag.

Start here

Drag to here
Bounding box

Handle

To draw an oval, drag from one 
corner to the opposite corner

A finished oval has handles 
on its bounding box

✔Try this
To draw an oval from the cen-
ter, press Option (Mac) or Ctrl 
(Windows) as you drag away 
from the center.

A tire created from 
four ovals

✔Try this
To draw a circle-segment arc 
with the Arc tool, press the 
Shift key while you drag.
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3 Release the mouse button when the arc is the length that you 
want. 

The arc appears with a bounding box and handles at the corners and 
sides. This shows that the arc is selected. Notice that the arc is always 
one quarter of a complete oval or circle. 

When an arc is selected, two small, round handles let you adjust the 
length of the arc. You can drag a handle to shorten or lengthen the 
arc.

Drawing objects using modifier keys
You can use modifier keys with most drawing tools to help you edit. 
Modifier keys can be combined (pressed at the same time) to create 
multiple constraints.

Try drawing an oval, square, or line outward from the center:

• If you are using Mac, press the Option and Shift keys at the 
same time as you drag the Oval, Rectangle, or Line tool. 
This lets you draw an object outward from the center and 
constrains its bounding box to a square.

• If you are using Windows, press the Ctrl and Shift keys at 
the same time as you drag the Oval, Rectangle, or Line tool. 
This lets you draw an object outward from the center and 
constrains its bounding box to a square.

Using these modifier keys is one way illustrators achieve precision. 
Once you are familiar with them, they will help you draw with more 
control.

Start here

Drag to here
Bounding box

Handle

Drag from one end to the 
opposite end

A finished arc has handles on 
its bounding box
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Applying inks and strokes
Once you draw vector objects, you can make them colorful and more 
interesting using inks and strokes. Inks are colors, or patterns of 
colors that apply to the fill (inside) or pen (outline) of an object. 
There are five types of inks:

Color A solid color

Gradient A blend of multiple colors

Texture A tiled pattern of a bitmap picture

Symbol A pattern created from vector objects

Hatch A pattern of lines arranged at angles in groups, usually used 
for technical illustrations to specify material types

Applying inks

1 Using the techniques you learned earlier, draw a rectangle.

2 With the rectangle still selected, open the Inks palette by 
pressing (Mac) or clicking (Windows) one of the color icons in the 
toolbox; when the palette opens, drag to a preset tile on any of the 
tabs and release the mouse. This applies the ink you selected to the 
rectangle.

Now try two alternate methods of applying an ink.

To apply ink when the Inks palette is floating

1 Open the Inks palette and drag the palette away from the 
toolbox to “float” it.

2 Select the rectangle.

3 Click a tile on a tab of the Inks palette to apply an ink to the 
rectangle.

Color Gradient Texture Symbol Hatch

Inks
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4 Click a blank area of the document to deselect the rectangle.

To apply ink to an object that is not selected Drag a tile from the 
Inks palette onto the rectangle and release the mouse button. This is a 
useful way to apply an ink quickly without first selecting the object.

Strokes

Strokes are outline effects on vector objects. In other words, they 
affect what the border of the shape looks like. There are five types of 
stroke effects.

Pen A solid outline with a width you choose (you can also create 
“calligraphic” pens that have variable widths)

Dash A repeating pattern of lines and spaces

Parallel A pattern of parallel lines for which you set spacing and 
colors

Neon A stroke effect that blends two colors to create a “tube”

Arrow An object (vector, text, or bitmap) that attaches to the 
endpoints of lines, arcs, or curve segments

Once you learn to apply inks, using strokes is easy. They operate 
almost identically. Try applying strokes to a line.

Applying strokes

1 Using the techniques you learned earlier, draw a line.

2 With the line selected, open the Strokes palette by pressing 
(Mac) or clicking (Windows) the stroke icon in the toolbox; when 
the palette opens, drag to a preset stroke on any of the tabs and 
release the mouse. You should see the effect this has on the shape.

Just like with inks, you can also float the Strokes palette and use 
drag-and-drop to apply the effects.

Pen Dash Parallel Neon

Stroke

Arrows
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1 Open the Strokes palette and drag the entire palette away from 
the toolbox to float it.

2 Select the line.

3 Click a stroke setting on a tab of the Strokes palette to apply it.

4 Click a blank area of the document to deselect the line.

Also, try dragging and dropping a stroke from the palette onto the 
line (it takes a little more precision to make sure you drop it right on 
the object).

Setting current inks and strokes

In the previous exercises, you applied inks and strokes directly to 
objects. You can change the current ink and stroke when no objects 
are selected. Then, when you draw an object, Canvas applies the 
current inks and stroke to the new object.

To change the current pen ink or fill ink

1 Deselect all objects (in the Status bar at the bottom right of the 
Canvas screen, it should say, “No selection”).

2 Press the pen ink or fill ink icon and choose an ink from the 
Inks palette. Notice that this changes the color of the icon.

3 Select the Oval tool and draw an oval. Canvas applies the 
current ink to the object.

Now you know some of the basics of drawing objects and applying 
colors and outlines.
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DRAWING SIMPLE ILLUSTRATIONS

Canvas is a powerful illustration application, with many features for 
drawing precise schematics, artwork, and business diagrams. You 
can use geometric shapes, punch, slice, and combine objects, or draw 
freehand to create your graphics. 

In this lesson, you will create objects and drawings in a blank 
document. You will learn how to

• start a new Illustration document

• use basic drawing tools

• use alignment aids to help you draw

• use menu commands to edit objects

Starting a new illustration
When creating drawings, especially technical, oversized, or complex 
drawings, you will probably want to use the Illustration document 
type, as opposed to Publication or Presentation. You can draw in any 
document type with equally good results, but the Illustration 
document offers a familiar environment to the artist. The first time 
you launch Canvas, this is the document type that appears by default.

To create a new Illustration document

1 Choose File > New.

2 In the New dialog box, select Illustration and click OK. Canvas 
creates a new, untitled Illustration document.

Now you’re ready to begin drawing.
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Using drawing shortcuts
Canvas has a number of tools that draw basic geometric shapes, such 
as rectangles, ovals, arcs, and so on. With few exceptions, they 
operate very similarly. See “Drawing basic shapes” on page 27. 

In this lesson, you’ll use some basic tools to create a plan view of a 
chair. You’ll see how the tools operate, and learn some shortcuts and 
guides for making drawing easier.

Creating a chair

To create the plan view of a chair, you’ll use the Oval tool, and the 
Align and Combine palettes.

First you’ll create the seat of the chair.

1 Select the Oval tool from the Oval Tools toolbar.

2 Press Shift and drag to create a circle.

3 Using the Oval tool again, draw an oval on top of the circle.

4 To align the objects, choose Object > Align. The Align palette 
opens. 

5 Select both objects. In the Align palette, click the first button in 
the vertical area and the center align button in the horizontal area. 
Click Apply to align the objects.

To finish the chair’s seat, you’ll need to combine the objects. 

6 Choose Effects > Combine. The Combine palette opens.

7 Select both objects and choose the Crop command in the 
Combine palette. Click Apply to combine the objects. 

You now have a completed seat.

Plan view of a chair

Draw an oval on top of a 
circle and horizontally align 
their centers

Choose Crop in the 
Combine palette to create 
the chair’s seat
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Now you’ll create the chair’s back.

1 Select the Oval tool, and drag to draw an oval.

2 With the Oval tool selected again, press Shift and drag to draw 
a circle on top of the oval.

3 Select both objects. In the Align palette, click the first button in 
the vertical area and the center align button in the horizontal area. 
Click Apply to align the objects.

To finish the chair’s back, you’ll need to combine the objects. 

4 Select both objects and choose the Subtract Front command in 
the Combine palette. Click Apply to combine the objects. 

5 You now have a completed seat.

Once you finish drawing the objects that make up the chair, you can 
use the Align palette to arrange them. 

6 Move the chair back above the chair seat and align the objects 
horizontally using the same buttons you used in the previous 
procedures.

You now have a completed plan view of a chair.

Drawing flow charts
In this lesson, you’ll learn to use some features to complete projects 
that are very common in day-to-day business. This short lesson will 
familiarize you with some of the tools you need to create simple flow 
charts. 

1 Open the file named “Flowchart.cnv.”

Draw a circle on top of an 
oval and horizontally align 
their centers

Choose Subtract Front in the 
Combine palette to create the 
chair’s back
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2 Select the Text tool, and click once near the top of the 
document. Type “Start Procedure,” and then press Esc.

3 Apply a black border to the selected text object by pressing 
Option (Mac) or Ctrl (Windows), opening the Pen ink palette in the 
toolbox, and choosing the black ink tile in the palette. 

4 Apply a blue fill to the selected text object by pressing Option 
(Mac) or Ctrl (Windows), opening the Fill ink palette in the 
toolbox, and choosing a blue color tile in the palette.

5 Choose Object > Object Specs to open the Object Specs 
palette. 

6 Make sure the text object is still selected. To make the text 
object an oval, choose Oval in the pop-up menu next to “Caption.” 
Type 15 in the two text boxes labeled “Insets.” Click Apply.

7 Here’s a useful shortcut for copying and positioning objects: 
Press Option+Shift (Mac) or Ctrl+Shift (Windows) and drag the 
“Start Procedure” text object straight down a short distance. This 
duplicates the object and places it in line with the original.

8 With the new text object selected, choose Diamond in the pop-
up menu next to “Caption” in the Object Specs palette. To change 
the object’s background color, press Option (Mac) or Ctrl 
(Windows) and choose an ink from the Fill ink icon in the toolbox. 

9 A diamond shape signifies a branch in a flow chart. With the 
text object still selected, type “Decision” to change the existing text 
in the object.

Ink icons

Pen

Fill

Text tool

Use this menu to change 
the shape of a text object

Press Option+Shift (Mac) or Ctrl+Shift 
(Windows) and drag the text object to copy it

Make the new text object a Diamond and 
apply a background ink

Start Procedure

Start Procedure

Step 1 Process 2

Start Procedure

Decision

Step 1 Process 2
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The only thing missing now are the lines connecting the flow chart 
pieces. For this purpose, Canvas has a feature called Smart Lines. To 
open up a palette of the Smart Lines tools, press the Line tool in the 
toolbox to open the toolbar. Drag the pointer to the Smart Lines tool 
and another toolbar will pop open; without releasing the mouse 
button, drag away from the toolbox. Now you should have a little 
palette of tools.

10 Connect “Start Procedure” to “Decision” by selecting the Basic 
Smart Line tool and dragging from the bottom center of one text 
object to the top center of the other. Smart Lines will automatically 
snap to the center of the object.

11 Connect “Decision to “Step 1” by selecting the Kinked Smart 
Lines tool and dragging from the side of “Decision” to the top of 
“Step 1.” Repeat the procedure to connect “Decision” to “Process 
2.”

Illustrations using macro objects
Macro objects, sometimes called “library objects” in other programs, 
are special types of graphics in Canvas that make maintaining 
consistency and precision simple. You can store graphics in the 
Macro tab of the Gallery palette, and then simply pick and choose 
graphics to assemble drawings from pre-made components.

For this lesson, you will put the finishing touches on an office layout.

1 Open the file named “Office.cnv.” This document has most of 
the basic elements of the office, but you are going to finish it. Also 

Smart Lines tools
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notice that the grid is displayed. These settings are saved with the 
document, so that you have a consistent environment that is suited 
to your project.

2 Open the Gallery palette by choosing Window > Palettes > 
Show Gallery (you can also open the Gallery palette by pressing the 
Gallery tool; the palette opens and you can drag it away from the 
toolbox).

3 On the Macro tab of the Gallery palette are previews of several 
typical office furniture items. There are a few items that are missing 
from the office layout, such as the chair for the desk and one of the 
corner tables. Simply click the preview of the “executive chair” 
(you’ll see its name appear at the bottom of the palette) and click 
behind the desk to place it.

4 With the chair still selected, choose Effects > Freeform. You’ll 
notice that the handles change to circles on the corners and squares 
on the sides, with a crosshair in the middle; this is “freeform” 
mode. The circles rotate the object around the crosshair 
(centerpoint), while the squares skew the object around the 
centerpoint. You can move the centerpoint, too. For now, rotate the 
chair a little counter-clockwise by dragging any of the circle 
handles in that direction. This is just one way to rotate an object 
quickly in Canvas. To return to normal selection mode, simply 
click the object again.

Office layout

Gallery tool
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5 In the Macro palette, select the corner table, and click in the 
document to place it in the corner to the right of the desk. The 
corner table is facing 90 degrees in the wrong direction. When you 
know exactly the amount of rotation you need to apply, you can use 
the Transform palette.

6 Choose Effects > Transform, and make sure you have the 
corner table selected. In the Transform palette, type “90” in the text 
box next to the rotate icon and press Enter; after a moment, Canvas 
applies the rotation.

You can see how Macro objects make it easy to assemble drawings 
from pre-drawn components. But the real power of a Macro object is 
the fact that each placed Macro is “linked” to the palette. To see how 
this works, you will replace the round-back chair in the Macro palette 
with a new style of chair, and the round-back chair that we placed in 
the office will change.

To replace the macro object

1 Drag the chair that is outside the office layout on top of the 
round-back chair in the Macro tab of the Gallery palette.

2 Canvas asks you if you want to replace the Macro; click Yes. 
Notice that the round-back chair changes to the new type of chair in 
the document.

Executive chair shown in 
freeform mode

Office with placed macro objects 
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Before we finish with this drawing, you will add one final touch. The 
rug under the office furniture needs a border. You can add this very 
easily with the Offset Path filter.

To offset a path

1 Select the object that represents the rug, and choose Effects > 
Offset Path.

2 You are going to make the border one inch wide. In the 
Distance text box, type -1. Click OK to apply the effect. The border 
appears on the inside of the rug. If you had entered 1 in the text box, 
the border would have appeared on the outside of the rug.

Now you have a rug with a border in the office plan, and you’ve 
quickly seen how you can use Macros to help you assemble 
illustrations.

Congratulations! If you want to save your work, use the Save As 
command to save the document with a new name.

Finished plan
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PAGE LAYOUT & TYPOGRAPHY

Canvas has all that you need to design simple or complex page 
layouts, with complete sets of professional type-handling and 
document-control features. 

The new page layout environment provides the comfort and ease of 
your word processor. Canvas provides Auto Correct, an interactive 
spell checker, and a redesigned Text Ruler. You will also find 
multiple column sections, text repel, master pages, and shared layers.

This tutorial is designed to teach you how to create a brochure using 
page layout and typography features. You will be working with a 
Publication document. 

In this tutorial, you will learn about master pages, creating headers 
and footers, placing a graphic, column sections and guides, and 
printing the publication.

Opening the tutorial document

In the Canvas tutorial folder, open the file named “Brochure.cnv.” 
This starts Canvas and loads the file. You are now ready to get to 
work.



44 Getting Started Guide

Setting up the document
Before you begin this section of the tutorial, you need to become 
familiar with the setup of this document. This brochure uses left and 
right pages, which are available only when the Facing Pages option is 
selected in the Document Setup dialog box. You can also set 
document units, paper size, paper orientation, sheet layout, and 
margins in this dialog box. For the purpose of this lesson, please 
make sure the document has the following settings.

1 Choose Layout > Document Setup to open the Document 
Setup dialog box.

2 Check that the Document Units pop-up menu shows Picas.

3 Check that the publication size is US Letter.

4 Make sure your page orientation is set to width 51.00 and 
height 66.00 (portrait). If not, click the Orientation button. 

5 Check that Facing Pages is selected. This gives the newsletter 
separate right and left master and body pages.

6 Click OK when you finish.

Now the brochure is correctly set up for this lesson and you are well 
on your way to creating a great-looking document.

Moving through your document
To help you navigate quickly through the document, Canvas has 
several ways to get from one page to another. The most common 
ways are the Document Layout palette, the page icons, and the arrow 
buttons. Before you begin working in the document, you might want 
to take some time to get used to different methods of navigation, and 
in the process, see what the entire publication looks like.

To switch pages using the Document Layout palette

The easiest way to access the Document Layout palette is to press the 
number icon near the bottom left-hand corner of the window. The 
Document Layout palette appears in the scrolling list, then drag it up 
to expose the full list and click the name of a page to view it.

You can also open the Document Layout palette by choosing 
Layout > Document Layout.
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To change pages using page icons and arrow buttons

In the lower left-hand corner of the screen, you will find the arrow 
buttons and page icons. Click the icon representing the page you 
want to view. To go to the previous page, click the arrow at the left of 
the page icons; to go to the next page, click the arrow at the right of 
the page icons. 

To view all the page icons at once

Make sure you are on page 1 and drag the space between the page 
arrow and the scroll bar to the right. This feature allows you to view 
all page icons at once without having to scroll through the entire list.

Adding and deleting pages
You can use the Document Layout palette to add or delete pages in 
your document.

To add a page Click the New Page button in the Document Layout 
palette.

To delete a page Select the page that you would like to delete in 
the Document Layout palette. Then drag the to the trash can in the 
palette.

Placing headers and footers on master pages
You can use master pages to hold objects that you want to appear on 
all or most of the pages in your document. 

The tutorial document has two master pages, one for left pages and 
one for right pages.

Typical master pages include objects like headers and footers. In 
Canvas, headers and footers are special text objects that can contain 
page numbers, the total page count, the current date, and the current 
time. In this document you will add headers and footers to the master 
pages.

To view the master pages Click the master page icons near the 
lower-left corner of the window. Canvas displays the document’s two 
master pages.

Adding a header to the left master page

1 Choose Text > Insert > Header. Canvas inserts a header object 
on the left master page and places the insertion point in the header. 
You might want to zoom in to see it clearly.

Dragging to the right expands 
the page number area

Left and right 
master page icons
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2 Type “Wide Open Spaces” in the header object.

3 Press Esc to end edit mode.

Adding footers to both master pages

First, you’ll add a footer to the left master page and insert a page 
number code in the footer.

1 Choose Text > Insert > Footer. Canvas inserts a footer object at 
the bottom of the left master page. The insertion point appears in 
the footer.

2 In the footer, type the word “page” and then type a space 
following the word.

3 Choose Text > Insert > Page #. Canvas inserts the code $p in 
the footer. This code in the master page footer tells Canvas to insert 
page numbers throughout the document, so you don’t have to 
number pages yourself. 

4 Type a space, then type the word “of” and another space.

5 Choose Text > Insert > Total Page #. Canvas inserts the code 
$t.

6 Press Esc to end edit mode.

Creating the right-page footer 

After you create the left footer, it’s easy to duplicate it and place a 
similar footer on the right master page. 

1 With the Selection tool (the solid arrow), do either of the 
following to copy the footer and place it on the right master page:

Mac: Press Option+Shift and drag the footer to the right.

Windows: Press Ctrl+Shift and drag the footer to the right.

Drag the footer into position at the bottom of the right master page.

2 With the footer object on the right master page still selected, 
choose Text > Justification > Right. This aligns the text in the 
footer with the right side of the footer. Page numbers will appear at 
the bottom right of right-hand pages in the document.

Flip through the newsletter to see the page numbering on each page 
and the header on the left pages.
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Placing a graphic
With the Place command, you can insert an image from another 
document into the current document. You will be inserting a graphic 
onto the first page, so select the icon for page 1 or select page 1 from 
the Document Layout palette.

To place a graphic

1 Choose File > Place.

2 In the Tutorial folder, locate the document named “Hill.cnv”. 
If it does not appear in the list, make sure that “all files” is selected 
in the File Format (Mac) or Files of Type (Windows) box. 

3 Select “Hill.cnv” and click Place.

4 The Place icon appears. Position the Place icon just below the 
second column of text and click the mouse button. Canvas places 
the graphic.

You have now successfully imported a graphic from another 
document. The Place command can also be used to import graphics 
from photo CDs or disks.

Click to place the top-left corner of the file Photograph placed on page 1 
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Creating columns of text
Now you are going to add some columns of text to page 2 of this 
brochure and flow text between them. Select page 2 by choosing the 
page 2 icon or selecting Page 2-Page 3 on the Document Layout 
palette.

To create columns with the Section tool

1 Select the Section tool from the Text toolbar in the Toolbox.

2 Drag the Section tool from the upper-right corner just below 
the headline “Getting Your Money’s Worth” to the bottom right 
corner of page 2.

3 After you release the mouse button, the Column Guides dialog 
box appears.

4 In the Apply To pop-up menu select Left Page. This places this 
section on page 2 only.

5 Press the three-column button, or type “3” in the “Number of 
Columns” text box.

6 Click OK.

Adjusting column guides

You can reposition column guides with the Section tool by moving 
them left, right, up or down. To adjust the column guides, select the 
Section tool in the Text toolbar, then drag the section. 

You can also adjust the column guides by double-clicking the section 
with the Section tool. The Column Guides dialog box opens.

Section tool

Dragging the Section tool Three-column section
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Placing text in a section
After you have created a section, you can begin typing, or you can 
place existing text in the section. This lesson will teach you to place 
text in the section you created earlier on page 2 of the brochure.

To place text in a section

1 Select the Text tool and click inside the first column in the 
section under the headline “Getting Your Money’s Worth.”

2 Now you are going to import the text from another document 
into the columns at the bottom of Page 2. Choose File > Place.

3 In the Tutorial folder, you will find the document “Text.txt”. If 
it does not appear in the list, make sure that “all files” is selected in 
the File Format (Mac) or Files of Type (Windows) box. 

4 Select the “Text.txt” document and click Place.

The set of columns should now be filled evenly with text.

Making text run around objects
You can make text “run” around objects with the repel feature. You 
also can set the amount of space between an object and the text. 

An object with a repel setting repels all text; you can move the object 
and it will repel text wherever you place it in the layout. 

You can apply repel settings to objects before any text has been 
created or placed in a document. You can even apply a repel setting 
to a text object to make it repel the text in other text objects. 

In this lesson, you are going to repel text around the graphic of 
silverware at the top of page 2. 
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To make an object repel text

1 Select the graphic at the top of the page with the Selection tool. 

2 Choose Text > Wrap > Repel. The graphic should repel any 
text that surrounds it. Try moving the object around and you will 
see how it repels text wherever it is set.

To adjust the repel setting Choose Text > Wrap > Repel Options. 
You can enter values to increase or decrease the amount of space 
between the object and the text.

Formatting text with the Text Ruler
The Text Ruler, located at the top of the page, has been enhanced to 
provide improved control over text and typography. The ruler’s two 
modes, Type and Styles, organize all text formatting options. 

In the Type mode, you can set justification, font, size, styles, leading, 
kerning, and fill ink. In the Styles mode, you can set tabs and select 
text styles. Plus, you can apply new color attributes to text by 
selecting a background color and an outline color.

◆ To display the Text Ruler: Choose Layout > Display > Show 
Text Ruler. 

Formatting text characters
The text that appears on the page in this brochure has been typed in 
the default setting. This can be changed at any time by selecting the 

Object with repel setting
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text, and adjusting the settings. However, for this assignment we are 
going to add a headline to the top of page 3.

To format text characters

1 Make sure that the “T” is selected in the top left-hand corner of 
the Text ruler for Type mode.

2 Select the Text tool in the toolbox.

3 Click in the top left-hand corner of page 3.

4 Now type “Sentimental Journeys.”

5 You are now going to change the font, so highlight the text 
selection.

6 In the Text Ruler, choose Arial or an available font in the font 
pop-up menu. The text should now be font you chose.

7 To increase the size of the type, choose 48 in the font size pop-
up menu.

To add text color

You are now going to change the color of the text in the headline on 
page 3.

1 Make sure that the text is selected.

2 Select the Text Fill Ink icon located in the Text Ruler.

3 Now click a shade of red in the Color palette and the black text 
will change to red.

To format paragraphs with the Text Ruler

The next step is to format the text in the caption on Page 3.

1 To change the text justification to the right, click in the text to 
the left of the picture of the leaves that reads “Many vacationers 
plan their trips around the changing of the leaves.”

2 Press the right-justification button on the Text Ruler. Canvas 
justifies the text to the right.

Changing text with paragraph styles
You can apply paragraph and character styles using the Styles mode 
in the Text Ruler. A style is made up of several attributes, such as 
font, type size, leading, and justification.

Text Fill Ink icon

Right-justification button 
selected

Right-justified text
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Canvas stores type styles in individual documents. When you open a 
document, Canvas loads the associated styles so you can apply them 
when needed. You can then access the various styles from the Styles 
button in the text ruler. 

For the purpose of this exercise, we are going to use styles that have 
already been created. To learn how to create your own styles, see the 
Canvas User’s Guide. 

Make sure you are on page 4 by choosing the page 4 icon or by 
selecting page 4 in the Document Layout palette.

Applying a paragraph style

1 Click in the first paragraph of text, under the number 1.

2 Click the “S” on the far left-hand side of the Text Ruler.

3 Press the down arrow to the right of the paragraph symbol. 
Scroll down the list and choose “Body text 1.” The style should 
now be changed.

You can experiment by trying some of the other styles that we have 
provided for you by selecting additional paragraphs and choosing 
different styles.

You can also use the Type palette to format text. The Type palette is 
located in the Text menu and contains many of the same features as 
the Text Ruler. It is used to apply type styles to character settings or 
paragraphs. You can also use it for spacing, hyphens and indents. It is 
a comprehensive way of utilizing the many typography and page 
layout tools within Canvas.

Typing text on a path
When you type text on a path, the text flows along the vector object 
in the shape of the object. You can use any vector shape with this tool 
from a straight line to an octagon.

For this exercise, make sure you are on page 4. There is a graphic of a 
question mark inside a circle at the top of the page. 
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To type text on a circle

1 Select the Path Text tool.

2 Click to place the cursor on the dashed circle surrounding the 
question mark.

3 Choose a bold font, such as Arial Black, and a type size of 48.

4 Type “Ask the Experts.” 

5 To position the text equally around the circle, use the Bind 
Position handles. See the section on Using the Bind Position 
handles, below.

6 You can delete the dashed circle and the text will retain its 
bound shape.

Using the Bind Position handles
Canvas has three Bind Position handles that you can drag to place 
text anywhere on, above, or below a circle. The handles appear when 
you select a bound text object, such as the one you created above.

Path Text tool

Click to place the cursor on 
the dashed circle

Type the text and use the 
handles to adjust the position

You can also remove the 
dashed circle
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Text inks 
In addition to attributes for text characters, you can apply attributes to 
text objects. You can apply inks, including symbols, textures, 
hatches, and gradients, to the backgrounds of text objects and text 
selections. You can apply strokes to the outlines of text objects and 
outlines around text selections. 

The easiest way to apply these attributes is to use buttons on the Text 
Ruler.

Applying text inks

You’ve seen how to apply color to text characters on Page 3 in the 
document. Now, you’ll add a gradient ink to the background of the 
text columns on page 4.

1 With the Selection tool, Shift-click (press Shift as you click) 
each of the two text columns to select them. 

2 Press the Background Ink button in the Text Ruler and select a 
gradient ink. You can experiment with different gradients, symbols, 
and colors. Once you select a background ink that you like, the 
document is complete.

But, before you congratulate yourself for completing this section of 
the tutorial, you can learn about printing documents, next.

Drag the Alignment 
handle to specify the 
point where you want 
type to align 

Drag the Baseline Shift 
handle to change the 
elevation of the baseline 
relative to the circle

Background Ink button
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Printing the publication
After you’ve made changes to the newsletter, you can print it to see 
the results on paper. You can also “proof” a document onscreen using 
the Print Preview feature.

Print Preview
Print Preview lets you see how a document will look before you print 
it. It reflects the current print settings and the page setup (Mac) or 
printer setup (Windows). These settings include the type of output 
(composite or color separations), the pages to print, tiling, centering, 
printing blank pages, and printing in color.

In the preview, you can see which objects, layers, and pages will be 
printed and make sure the layout fits in the printable area of the 
paper. 

Using Print Preview

1 Choose File > Print Preview.

2 Click Done if you want to go back to the document.

3 Click Print if you are ready to print the document.

Canvas gives you different options for general desktop printing and 
for commercial printing.

For general desktop printing, refer to chapter 2, “Document Basics,” 
in the Canvas User’s Guide.

For commercial printing procedures, refer to the Canvas Color 
Printing Guide.

Congratulations! You have now completed the Page Layout & 
Typography section of the tutorial. 

You can save your work by choosing File > Save As and typing in a 
file name for your document. If you close the tutorial without saving, 
your changes will be lost, but you can start the tutorial again.

Now you can design your own brochures, newsletters, and other 
publications — the sky’s the limit!
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INTRODUCTION TO IMAGE EDITING

Canvas has all the features of a dedicated image-editing program. 
You can create image compositions, retouch photos, color correct 
scanned images, and even paint your own images. In this lesson, you 
will learn:

• basic image terminology

• how to place and crop paint objects

• how to change the color mode of a paint object

• how to apply transparency effects to paint objects

Basic image terminology
Paint objects, also called image, bitmap, or raster objects, are 
composed of small squares called pixels. 

Every paint object has a specific resolution, defined as the number of 
pixels per inch (ppi). In general, an image with a high resolution has 
more detail, but will also have a large file size. Likewise, a low-
resolution image has less data, so it has lower quality but also smaller 
file size. 

As you get more experienced with images, you will learn what 
resolution is best suited to your purposes. 

Resolving the resolution dilemma
When working with paint objects, it is important to know what 
medium your final project will be displayed on. 

• For web work or for displaying images only on screen, 72 
ppi is the standard. 

• To achieve good results for printing, 150 to 300 ppi is 
standard (depending on screen frequency). File sizes at high 
resolution can be quite large; you might find that lower 
resolution is adequate for laser or inkjet output. 

• Very high resolution (above 300 ppi) is needed only for 
images such as fine line art that will be output to film for 
commercial printing. 
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For this lesson, we will be working with images at 72 ppi resolution.

What’s in a file name
One of the most confusing things about working with paint objects is 
the great variety of file types. The most common image file types are 
GIF, JPEG, TIFF, PICT, and BMP, as well as EPS (which can 
contain both paint and vector objects). 

GIF and JPEG are compressed formats used heavily on the internet. 
The compression levels allow these images to achieve small file sizes 
and as a result they download quickly over the internet. However, file 
size compression comes at the expense of image and color integrity. 

TIFF, PICT, BMP and EPS files have a lower level or no amount of 
compression. Information for every pixel is recorded, and this can 
result in large files. Because of the higher resolution and detail 
needed for printing, these formats are often used for projects that will 
eventually be printed commercially. 

There are a number of ways in Canvas to place an image file in your 
document. In addition to the Place command in the File menu, there 
is also the Acquire command in the Image menu. 

Finally, you can directly scan into Canvas using any TWAIN 
compatible scanner, or a scanner with a Photoshop™ compatible 
acquire module. 

Creating a duotone vignette
In this lesson, you will learn how to create a duotone and make a 
vignette from a photograph. A duotone is a grayscale image printed 
with black and an additional color. A vignette is a non-rectangular 
image, usually with a soft edge. 

You will also crop the photograph, change the image mode, and 
apply a vector mask to complete the vignette effect.

To begin, open the file named “Image1.cnv” in the Tutorial folder. 
You are now ready to get to work.

Trimming the image

The photograph in the “Image1” document has a border of black 
pixels. You will use the Trim command to quickly remove the black 
border. 



Creating a duotone vignette 59

To trim the paint object Select the paint object and choose 
Image > Area > Trim.

Canvas determines the unwanted pixels and crops the image 
accordingly. However, this image still has some areas you might 
want to remove. For this you will use the Crop tool. 

Cropping a paint object

There are two crop modes in Canvas. You can use the Crop tool to 
select a rectangular part of a paint object and hide the rest. This is 
called a “soft crop.” Or you can permanently remove extra pixels by 
performing a “hard crop.” 

Performing a hard crop is easy using a shortcut key. Let’s perform a 
hard crop on this paint object. 

1 Click the paint object to select it. Selection handles appear.

2 Point to the lower-right corner handle, press and hold down the 
Ctrl key, and drag the handle toward the center of the image to crop 
it slightly. Releasing the mouse button crops the image. 

If you crop too much, choose Edit > Undo. 

Original Trimmed

Drag the crop handle Cropped
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Changing the image mode
As we mentioned earlier, there are a number of image file formats. 
To make things even more interesting, there are also a number of 
image modes. These include Black & White, Grayscale, Indexed, 
RGB Color, and CMYK Color modes. The mode of a paint object 
affects the level of editing that can be performed, the file size of the 
image, and the file types that you can save the object in.

You can see the mode and the resolution of a paint object by 
selecting it and looking at the right end of the Status bar at the bottom 
of the screen. If you select the image you will see that it is (72 dpi) 
and currently in the RGB Color mode. 

For this lesson, you will create a duotone from this image. A duotone 
is an image made up of screens of two basic colors, usually black and 
one other ink. To do this you must first remove all color and then 
select which color to blend into the image.

Creating a duotone

1 Select the paint object.

2 Choose Image > Mode > Grayscale.

3 Canvas asks whether you would like to discard the color 
information from the image. Click OK. The image is now in 
grayscale mode.

A traditional “black and white” photograph is actually a grayscale 
image to a computer. The computer uses 256 levels of gray to 
construct the shadows and other features found in a typical black and 
white image. An image in Black & White mode reduces the number 
of colors in the image to two. Each pixel is either 100% black or 
100% white. Therefore, the Black & White mode is not for black and 
white photos, but rather for single-color illustrations, logos, or 
images. 

4 Choose Image > Mode > Duotone. The Duotone Options 
dialog box appears asking you to define your ink colors. Note: 
because only black is in the image, Canvas considers it a monotone 
image. 

5 Select “Duotone” from the Type pop-up menu. This lets you 
use a second color. 

✔Tip
If you want to change the inks 
used in a duotone, you must 
select Image > Mode > Duo-
tone Inks. This menu item 
appears when a duotone 
image is selected.
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6 Press the Ink 2 color icon. This opens a color palette.

7 Select Custom in the color palette.

8 Using the pop-up menu, select “Pantone® Coated.” 

9 Select “Red 032 CVC” in the scrolling list. Click OK.

10 In the Duotone Options dialog box, click OK.

The image is now a duotone, using mixtures of black and the color 
you selected. 

Applying a vector mask to a paint object
In previous lessons, we applied transparency effects to vector objects. 
You can apply the same effects, such as vector masks, to paint 
objects. 

You are going to use the Transparency palette this time to create a 
soft-edge vignette from the photograph of leaves. 

1 Select the duotone paint object.

2 To use the Transparency palette, open the Opacity slider in the 
toolbox, and drag the slider away. The Transparency palette opens.

3 In the Mask pop-up menu, select Elliptical. Vector mask 
editing handles appear on the paint object.

4 Drag the handles to adjust the position and boundaries of the 
vector mask. Adjust the handles until you achieve an effect that you 
like.
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If the transparency handles disappear, select the object and click Edit 
in the Transparency palette.

5 When you finish adjusting the mask, press Esc to end edit 
mode.

Drag handles to shape the effect

Completed vignette

Handles appear on the mask in edit mode
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Creating transparent edges using a channel mask
You’ve now seen a quick and easy way to add a bit of pizzazz to a 
photograph. And, because the effect uses transparency, it is easy to 
place this object in any layout. 

This next transparency example shows you how to create a 
transparent effect around the edges of an image. You can do this by 
painting in a channel mask. 

Let’s start off with a different image. This time we will load this 
object by using the Acquire command.

1 Choose Image > Acquire > TIFF.

2 In the directory dialog box, select the file named “Image2.tif” 
in the Tutorial folder. Click Add.

3 Click Done.

Note: The Acquire command lets you perform batch importing of 
image files. Simply select the files and select “Add” or “Add All” 
until all the files to import are in the lower window. Then click Done. 

Canvas places this image in the center of your screen. To help 
illustrate some of the channel operations, open the Channels palette. 

4 Choose Image > Show Channels.

5 To create a channel mask, press Option (Mac) or Ctrl 
(Windows) and double-click the new paint object. 

In the Channels palette, you will see separate Red, Green, and Blue 
channels, as well as a channel mask in the lower portion of the 
Channels palette. By pressing Option (Mac) or Control (Windows) 
and double-clicking an object, you create a channel mask and select it 
for editing. 

6 Select the Airbrush tool. The tool is located in the Painting 
Tools toolbar. When you work with image-editing functions, it is 
helpful to tear off this toolbar from the toolbox. To do this, drag the 
toolbar away from the toolbox. Feel free to reposition or shape the 
toolbar so as to not obstruct your work space. 
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7 Select a black foreground ink in the Inks palette. 

Black pixels in a channel mask produce 100% transparency in 
corresponding areas of the masked object. White pixels in a channel 
mask produce 0% transparency in the masked object. Gray pixels in a 
channel mask produce partial transparency in the masked object. 
Darker grays produce greater transparency than lighter grays.   

Now you need to pick a brush for this effect. 

8 Press the Brush icon in the toolbox. A default set of brushes 
appears. Select the largest soft-edge brush.

9 Paint along the edges of the image. 

Because you are painting the channel mask, the edges of the paint 
object become transparent. Continue painting until you have 
achieved an effect that you like. 

Don’t forget, if you make a mistake, you can always undo the most 
recent actions by choosing Edit > Undo, or pressing Command+Z 
(Mac) or Ctrl+Z (Windows).

10 Press Esc to end edit mode. You now have a nice airbrush 
effect on your paint object. 

Painting colors

Foreground

Background

Selecting a brush

Transparent edges can be 
“painted” in a channel mask. 

You can achieve a variety of 
effects with various painting tools. 
You can also adjust options for 
most painting tools in the Brushes 
palette.
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The benefits of transparency

We’ve now seen two ways to enhance photo objects. One of the 
benefits of transparency masking in Canvas is that original images 
are not changed permanently. The original pixels of an image are still 
there and can be easily restored if you change your mind. To 
demonstrate this point, you can remove the channel mask from the 
flower image.

1 Double-click the flower image to place the paint object in edit 
mode.

2 In the Channels palette, drag the channel mask from the lower 
window to the trash can icon in the palette.

The original image is now restored. Congratulations! Thanks to 
Canvas, you can turn the simplest photographs into experimental 
works of art. 

Now, you can use the Save As command to save your work, or close 
the document without saving the changes.

Pixel editing
Canvas has a number of advanced photo-editing features that allow 
you to manipulate images. In the next exercise, we will use Canvas’ 
Rubber Stamp tool to retouch an image of a landscape.

To begin, open the file named “Image3.cnv” in the Tutorial folder. 
You are now ready to get to work.

Retouching an image

An image of a landscape is now in your document. You are going to 
add some clouds to the sky. For retouching an image such as this, you 
can use the Rubber Stamp tool. But first, let’s get a closer look at the 
pixels we will be affecting.

1 Double-click the paint object to place it in edit mode.

2 Select the Magnifying Glass tool and drag to enlarge the sky.

3 Select the Rubber Stamp tool in the Painting Tools toolbar. 

The Rubber Stamp tool takes an area of pixels starting at a reference 
point you select, and replicates the pixels around that point in another 
location you select. This is referred to as cloning.

Cloning can be tricky, and often requires you to set multiple 
reference points, and perform multiple clones to totally re-touch or 
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remove a part of an image. The advantage of using the Rubber Stamp 
tool over a simple paint brush is the ability to not only ensure color 
matching, but also replicate subtle textures and color gradients that 
exist in almost every area of an image.

To add clouds to the sky, you will clone some of the clouds that are 
already in the image.

4 Select a small soft edge brush from the Brushes palette. 

5 Option+click (Mac) or Alt+click (Windows) an area in the 
clouds.

6 Drag the Rubber Stamp tool to paint a copy of the sampled area 
around the reference point. Continue dragging until you like the 
cloud you are creating. 

7 Note: You might need to select a second reference point to avoid 
cloning areas with portions of the original image that contain grass. 
Press Esc to end edit mode. 

8 Use the Zoom slider to set magnification to 100%.

As you can see, the Rubber Stamp tool can be a fantastic way to 
remove unwanted scratches, stains or other imperfections found in a 
photograph. It is also a great way to duplicate objects from within a 
paint object. 

Setting the reference point “Cloning” more clouds



Creating glowing text 67

Creating glowing text 
This next lesson shows you how to add glowing text to an image. 
Before you begin, make sure there are no selected objects in the 
document.

1 To change the current text size to 48 point, choose Text > 
Size > 48. 

2 To change the current font to Times, choose Text > 
Font > Times.

3 Select the Text tool and type the word “Canvas” in front of the 
hills in the image. 

4 To change the color of the text to white, select the text object 
and select the white fill ink in the Inks palette.

Now we want to create the blurry “glow” that will rest behind our 
plain text. To do this we must render the text in order to apply the 
appropriate filter. 

Rendering is the process of taking vector-based art and converting it 
to a paint object. We do not need to create a second text object, 
because Canvas will create a new rendered version of our text and 
place it in front of the original text. 

5 Select the text object. 

6 Choose Image > Area > Render. The Render Image dialog box 
opens.

• In the Mode pop-up menu select RGB.

• Make sure the Resolution is set to 72 pixels/inch.

• Select Anti-Aliasing, and choose Fine in the pop-up menu. 
Select the Mask option. Then select the Visibility option.

7 Click OK.

Canvas renders the text according to your specification. By selecting 
a visibility mask, Canvas renders the pixels with a transparent 
background. 

It is now time to blur the rendered object. You can do this by using 
another popular filter, Gaussian Blur. 
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8 Double-click the image to put it in edit mode. Choose Image > 
Filter > Blur > Gaussian Blur. 

Note: You can apply the Gaussian Blur filter to a paint object that is 
selected and not in edit mode, but then you can’t select the Preview 
option in the Gaussian Blur dialog box.

9 In the Gaussian Blur dialog box, type 2 in the Radius text box. 
You can select the Preview option to see the effect.

10 Click OK to apply the filter. You now have a blurry highlight 
in front of the original text object.

11 Press Esc once to end edit mode and leave the paint object 
selected.

12 Choose Object > Arrange > Shuffle Down to move the 
highlight object behind the text object.

Of course, you could choose to use different ink colors, and even 
separate ink colors for the text and “glow.” The creative avenues are 
endless. And because you used separate objects to achieve this effect, 
you could remove the effect from the text by selecting the glow 
object and then deleting it.

If you want to save your work, use the Save As command to save a 
copy of the document. Otherwise, you can close the document 
without saving changes.

Text with a glowing highlight
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WEB PUBLISHING WITH COLADA

Colada is a set of Canvas tools that lets you create web pages from 
Canvas documents. Colada also creates Java-based animations, 
buttons, sounds, and encapsulated presentations for web pages. 

In order to view Colada web pages, you should have a Java-enabled 
web browser, such as Internet Explorer 4.0 or Netscape Navigator 4.0 
or higher.

In this chapter, you’ll learn the basics of creating web pages and 
Colada objects.

Creating web page buttons
The Colada Button tool creates Colada buttons — clickable objects 
for Colada web pages. A Colada button can change appearance when 
the pointer touches it and again when someone clicks it.

You can use any objects, including text, illustrations, and images as 
Colada button components.

To create a Colada button

This lesson shows you how to create a clickable Colada button and 
place the button on a web page. 

To begin, open the document named “Buttons.cnv” in the Tutorial 
folder. The document contains three numbered illustrations. You’ll 
assemble a Colada button from the illustrations.

1 Select the Colada Button tool. The Colada Button tool is in the 
Object tools toolbar.

2 Double-click the Colada Button tool icon in the toolbox. This 
opens the Colada Buttons palette. 

3 Click the arrow at the bottom-left of the palette. This expands 
the palette so you can create buttons.

4 To create a button, you will drag three illustrations into the 
Colada Buttons palette. The three illustrations will create the three 
button states. 

Colada Button tool
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• Select the object labeled 1 in the “Buttons” document. Drag 
this illustration and drop it on the “Up” box in the Colada 
Buttons palette.

• Select the object labeled 2. Drag this illustration and drop it 
on the “Over” box. 

• Select the object labeled 3. Drag this illustration and drop it 
on the “Down” box.

Colada Buttons palette

A Preview box
B Drag from A to store 
buttons

Placing a new Colada button in the web document

Drag illustrations to the boxes to create button states

A

B
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Previewing and storing a Colada button
To see the new Colada button in action, move the pointer over the 
preview box. When the pointer touches the button, it changes to 
display the “Over” illustration.

Then, press down the mouse button while the pointer is in the 
preview box. When you do this, the Colada button changes to display 
the “Down” illustration.

After you create and preview the Colada button, you can store the 
button in the palette so you can later place it in web pages.

To store the button, drag it from the preview box up to the box at the 
top of the palette. The button appears in the upper box with any other 
Colada buttons that are stored in the palette.

If you make a mistake, you can delete a Colada button by dragging it 
to the trash can icon in the palette.

Placing a Colada button on a web page
You can use the Colada Buttons palette to place Colada buttons in 
documents that you create in Canvas. Then you can save the 
documents as Colada Web pages.

Because you stored a Colada button in the Colada Buttons palette in 
the previous procedure, you can place that button in any Canvas 
document. Open the document named “Webpage.cnv” in the Tutorial 
folder. This document contains illustrations for a web page.

1 Open the Colada Buttons palette (if necessary). At the top of 
the palette, click the button that you stored there in the previous 
procedure.

2 Place the pointer in the document in the web page illustration, 
above the three buttons that are already placed on the left of the 
document.

3 Click to place the new Colada button on the page. You can use 
the Selection tool to move the button object, or press the keyboard 
arrow keys to “nudge” it into position while it is selected.

Testing a Colada button
After you place the button in the document, you can test it to see how 
it will appear on a completed web page.

1 Click the Start Play Mode button in the Colada Buttons palette.

Selecting a stored Colada 
button
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2 Move the pointer over the new Colada button in the document 
to see how the button changes when you point to it.

3 Press the mouse pointer down on the Colada button to see how 
the button changes when you press it.

When you finish testing the Colada button, click End Play Mode in 
the Colada Buttons palette.

Moving on
When you’re finished testing the Colada button, you’re ready to 
move on to the other lessons in this chapter. 

It’s important that you keep this document open because you’ll use it 
again later to learn how to assign hyperlinks and place Colada 
animations.

Creating a Colada animation
The Colada Animation tool creates Java-based animations that you 
can place in Colada web pages. Colada animations can include all 
types of objects, including images, illustrations, text, and Colada 
sounds. 

Colada animations can play when viewers click them on web pages, 
or they can play automatically when web pages load in their 
browsers. Animations can play once and stop or play continuously.

Colada animations are made of multiple frames. The frames appear 
in sequence, as in a movie or cartoon.

The next lesson shows you how to assemble an animation and place 
it on a Colada web page.

To begin, open the document named “Animation.cnv” in the Tutorial 
folder. This document contains a series of illustrations that will 
become the frames of a Colada animation.

To create a Colada animation

1 Select the Colada Animation tool in the Object tools toolbar. 
Double-click the tool to open the Colada Animation palette.

2 In the Colada Animation palette, click the arrow at the lower- 
left corner of the palette. This opens the section where you create 
animations.

Colada Animation 
tool
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3 Drag illustration 1 from the “Animation” document into the 
preview box at the bottom-left of the Colada Animation palette.

4 Repeat the previous step with each remaining illustration. Be 
sure to insert the illustrations in the correct order.

Previewing and storing an animation
After you create an animation, you can preview it in the palette. The 
preview shows how the animation will look on a completed web 
page. In addition, you can store the animation in the palette, so you 
can use it in any Canvas document.

Click the “Play” button in the palette to preview the Colada 
animation. Canvas plays the animation in the preview box.

After you create and preview the Colada animation, you can store the 
animation in the palette so you can later place it in web pages. Stored 
animations are available in all Canvas documents.

To store the animation, drag it from the preview box up to the box at 
the top of the palette. The animation appears in the upper box with 
any other Colada animations that are stored in the palette.

If you make a mistake, you can delete a Colada animation by 
dragging it to the trash can icon in the palette.

Placing a Colada animation on a web page
After you store an animation in the Colada Animation palette, you 
can place the animation in any documents you design to be Colada 
web pages.

To begin, switch to the document “Webpage.cvn,” which should still 
be open at this point.

1 Select the golfer animation that you stored earlier in the box at 
the top of the Colada Animation palette.

2 Click near the top-left corner of the web page layout. This 
places the animation in the document. 

When you place the animation, its white background obscures the 
document background. However, the animation’s white background 
won’t appear when it’s viewed with a web browser.

Keep the document open for now so you can use it in the next 
procedures.

Click Play to preview the 
animation
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Acquiring animated GIF files
You can use the Colada Animation palette to acquire multi-frame 
GIF animation files. This makes it easy to convert existing GIF 
animation files into Colada animations.

You can do the following procedure in any Canvas document.

To acquire an animated GIF

1 Double-click the Colada Animation tool to open the Colada 
Animation palette, if necessary.

2 Choose Append Animations in the palette’s pop-up menu. 

3 In the dialog box that appears, select the file named 
“Movie.GIF” in the Tutorial folder, and then click Open. Canvas 
inserts the GIF frames into the Colada Animation palette. 

4 Click play in the Colada Animation palette to preview the 
animated GIF.

You can close the palette now and continue to work with the web 
page layout in the next procedure.

Creating hyperlinks on a web page
When you design Colada web pages, you can make hyperlinks by 
assigning URLs (Uniform Resource Locators) to Canvas objects.

You can set up hyperlinks to “http” and “ftp” addresses on the 
Internet, and to e-mail addresses with the “mailto” tag.

You will set up some hyperlinks in the “Webpage” document.

To assign a hyperlink

1 Choose Object > URL Tag. The URL Attachment palette 
appears.

2 With the Selection tool, click the Colada button that you placed 
on the left of the page.

3 In the URLs pop-up menu, choose “http://www.” The text 
appears in the box at the top of the URL Attachment palette.

4 Type “deneba.com” (or your favorite web address) after 
“http://www” in the box at the top of the URL Attachment palette.

5 Click the Assign button to assign this URL text to the selected 
Colada button.

Choose Append Animations 
to place a GIF animation in 
the palette
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You’ve now set up the button so you can click it in a web browser to 
jump to the Deneba Software web site.

Attaching hyperlinks to text
You can select any amount of text — from one character to whole 
paragraphs or entire text objects — and use the URL Attachment 
palette to make the text selection a hypertext link.

To create a hypertext link 

1 Choose Object > URL Tag to open the URL Attachment 
palette (if necessary).

2 With the Selection tool, click the text that reads, “Everyday 
Golfing Equipment.”

3 In the URLs pop-up menu, choose “http://www.” The text 
appears in the box at the top of the URL Attachment palette.

4 Type “deneba.com” (or your favorite web address) after 
“http://www” in the box at the top of the URL Attachment palette.

5 Click the Assign button to assign this URL to the text 
selection.

Adding style and color to hyperlinked text

At this point, you can add color and formatting styles to the 
hyperlinked text.

1 In the URL Attachment palette, select the Link Styles 
checkbox.

2 Click the “B” button for bold, and the “U” Button for 
underline.

3 Select a solid color for the text in the color palette pop-up. By 
default, Canvas makes hypertext dark blue.

4 Click Assign to assign the URL and the Link Styles you 
selected to the text selection.

Moving on
You can close the document now. In the next procedure, you’ll be 
able to work with a completed version of this document, which is 
stored in the Tutorial folder.

Hypertext color and styles 
options
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Saving Colada web pages
To create Colada web pages in Canvas, you simply save a Canvas 
document using Colada Web format.

Of course, you should always save your documents in the regular 
Canvas file format before you export a document in any other format. 
You should do this so that you can edit the original Canvas 
documents if you want to make changes.

Now you’ll save a Canvas a document in Colada Web format. Then 
you can view the page in a web browser to see the hyperlinks, Colada 
buttons, and animation.

To begin, open the document named “Homepage.cnv.” Like the 
document you worked on earlier, this document contains Colada 
buttons, animation, and hyperlinks. You will use this document to 
learn about the options for saving Colada web pages.

To save a file in Colada Web format

1 Choose File > Save As.

2 In the directory dialog box, type the file name “Homepage.”

3 Choose Colada Web in the File Format (Mac OS) or the “Save 
as Type” (Windows) pop-up menu.

• If a message asks if you’re sure that you want to save in this 
format, click Yes (Windows) or Save (Mac).

4 Select a folder to save the web page files. All the components 
of the web page will be stored in a subfolder of the folder you 
select.
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5 Click Save. 

6 The Save Web Document dialog box appears. This dialog box 
presents options for saving web documents. For this exercise, select 
the following options:

• Select “Create folder.” This option creates a folder with the 
same name as the document to contain all the files 
associated with the web page or pages.

• Choose “Java and JPEG” in the pop-up menu at the top of 
the dialog box. This creates a web page that can be viewed 
in web browsers with Java support, and also includes a 
JPEG image that can be displayed by browsers that don’t 
support Java.

7 Click OK. Canvas saves the web page in the location you 
specified.

Viewing Colada web pages
When you create web pages with Colada, you can use your web 
browser to check the pages before posting them to the Internet. 

1 Launch a web browser. If you want to view Colada buttons, 
animations, and other effects, your browser must support Java 
(Internet Explorer 4 and Netscape Navigator 4 do).

2 In the browser, choose File > Open Page or File > Open File.

• Locate and select the file named “Homepage.htm.” When 
the file loads, you can view the golf player animation, test 
the Colada buttons, and hyperlink to the Deneba Software 
website.

Zooming and panning
When you’re viewing a Colada Web document with a web browser, 
you can adjust the view by zooming and panning. We’ve supplied a 
Colada web page so you can try this feature yourself.

1 Launch a web browser.

2 Choose File > Open Page or File > Open File.

3 Select the file named “Viewpage.htm” in the Viewpage folder 
in the Tutorial folder.
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4 After the page loads, select and drag the page around to pan 
your view.

5 Press the Plus (+) key on the numeric keypad to enlarge the 
view (zoom in).

6 After zooming in, press the Minus (-) key on the numeric 
keypad to zoom out. To return to normal magnification after 
zooming, press the Home key.

Congratulations! You’ve now learned several techniques to make it 
easier for you to design web pages using Colada. For complete 
information on using Colada to develop a website, be sure to read the 
Colada chapter in the User’s Guide.
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