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1

 

Final Cut Pro Tutorial

 

This tutorial is designed to give you a hands-on introduction to Final Cut Pro. Working through 
the step-by-step procedures in the tutorial, you will create a short video using a variety of the 
editing, effects, and compositing features of the application. You will

 

m

 

Create a Final Cut Pro project and sequence

 

m

 

Play clips and mark edit points

 

m

 

Perform several types of edits

 

m

 

Add special effects to your sequence

 

m

 

Render and play the sequence you’ve put together

 

m

 

Output your final sequence to videotape or a QuickTime file for use on the World Wide 
Web or in multimedia

The tutorial should take about one hour to complete.

 

Getting the Tutorial Files and Starting the Program

 

If you haven’t installed Final Cut Pro, follow the instructions in the 

 

Final Cut Pro User’s 
Manual

 

 to install the software.

Next, consult the Read Me file installed with the program for the location of the tutorial files 
on the CD that contains Final Cut Pro.

Then copy the necessary files from the CD and open the project you will use for the tutorial.

 

Note:  

 

The tutorial files require about 90 megabytes (MB) of free space on your hard disk.

 

1

 

If necessary, clear 90 MB of space on your media drive.

 

2

 

Copy the Tutorial folder from the Final Cut Pro CD to your media drive.

Now start the program.

 

3

 

Double-click the Final Cut Pro icon to start the program.



 

4
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The Final Cut Pro Workspace

 

In Final Cut Pro, you work in four main windows: the Viewer, Canvas, Timeline, and Browser. 
These windows open the first time you start the program. In addition, the Tool palette opens 
with the program. 

Each of the four main windows has multiple functions. Functions are grouped by tabs within 
the windows. You can drag tabs out of their parent windows to customize the workspace for 
your individual needs. (When you drag a tab, its content opens in a new window.)

 

Note:  

 

In some instances, the windows on your screen may look slightly different from the 
pictures in this tutorial. 

 

Setting Up Your Environment

 

Before beginning the tutorial, ensure that your setup is optimized for your computer.

Browser Timeline

Viewer Canvas

Tool palette
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When you installed Final Cut Pro, you provided information about your system that the 
program uses to establish its basic settings. You don’t have to change those settings for this 
tutorial.

Before you begin working, however, you should specify the disk drive, called the “scratch 
disk,” the program uses to work with its files.

To specify the scratch disk and file type:

 

1

 

Open the Edit menu and choose Preferences. 

 

2

 

Click the Scratch Disks tab and specify your fastest disk drives for your video, audio, and 
render files.

 

Note:  

 

You can choose a drive or a folder on a drive; you can specify the same disk for all files.

 

3

 

Click the Sequence Presets tab and choose Software Preset.

 

4

 

Click the Set Default button.

If the button is dimmed, that option is already the default.

 

5

 

Click OK.

Now you’re ready to begin editing in Final Cut Pro.

 

Editing in Final Cut Pro

 

This section gives you practice with the basic editing features of Final Cut Pro, including 
adding clips to a sequence, trimming, slip editing, match frame editing, using transitions, and 
audio manipulation.

“The Lindy Hop” sequence in the project “Swing.fcp” is a section of a documentary about 
swing dancing in the 1990s. This sequence introduces you to the power and productivity of 
Final Cut Pro. In the tasks that follow, you will recreate this video segment and learn some of 
the ways the program facilitates the creative process.

 

Creating Your Own Project

 

To begin, open the program, create your own project, and play the sequence named “The 
Lindy Hop.” This sequence is the model for the learning tasks in the tutorial.

 

1

 

Choose Open from the File menu, locate the Tutorial folder on your hard disk, open the 
Projects folder inside it, select the file “Swing.fcp” (one of the tutorial’s project files), and click 
Open.
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A tab named “Swing.fcp” appears in the Browser, and the Timeline and Canvas windows close.

The Browser is the central storage area for all media. It provides management features, such as 
sorting and finding, and allows for complex organization of media combined with quick access 
to files. The program organizes clips, sequences, and other data in a project. Projects are 
represented by tabs in the Browser.

 

2

 

Open the File menu and choose Save Project As, type “My Project 1.fcp,” and click Save.

It’s a good idea to save your project with a new name to be sure that your work is saved in a 
separate file and to prevent inadvertent changes in the model project, “Swing.fcp.”

 

3

 

In the Browser, expand the Dance Shots folder, called a “bin,” to view its contents.

 

4

 

Double-click “The Lindy Hop” to open it.

The Canvas and Timeline windows open, with “The Lindy Hop” displayed.
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The Canvas is analogous to a “record” monitor; it displays edited material. The Canvas has the 
same transport controls as the Viewer and the two windows work in a similar way.

The Timeline displays clips and sequences over time. Each open sequence is displayed on its 
own tab in the Timeline. You can customize the appearance and functions of the Timeline and 
perform editing tasks in this window.

 

5

 

Click in the Canvas to make it active.

 

6

 

Press the Home key to move the playhead to the beginning of the sequence. 

 

7

 

Press the Space bar to play the sequence in the Canvas.

 

Creating a New Sequence

 

Next, create a new sequence and open a clip to use in it.

 

1

 

Open the File menu and choose New, then choose Sequence from the submenu.

The new sequence appears in the Browser as Sequence 2.

 

2

 

Double-click “Sequence 2” in the Browser to open it.

 

3

 

In the Canvas window, choose 100% from the zoom level pop-up menu at the top center of 
the window.

Playhead
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Double-click the clip named “Rob Dialog.mov” in the Browser to open it in the Viewer. 

The clip opens in the Viewer window.

When you open a clip in Final Cut Pro, it appears in the Viewer, which is analogous to your 
“source” monitor. The Viewer provides features for viewing and marking source clips; 
customizing transitions; and viewing and editing effects, filters, and special-effect clips called 
generators.

 

Adding the Base Track for Your Sequence

 

The base track is the primary set of media—clips, audio, still images—for the sequence. Many 
times, the base track may be the only one used in a sequence; at other times, you may want to 
add other tracks to make multiple layers, creating a finished sequence that might show one 
clip playing inside another clip or a changing collage of still images playing over a clip.

This tutorial creates a sequence with multiple layers. The next several tasks create the primary 
layer—the base video and audio tracks for the sequence.

 

Adding a Clip to Your Sequence

 

1

 

Click in the Viewer window to make it active (if necessary).

 

2

 

Play “Rob Dialog.mov” by pressing the Space bar or clicking the Play button. Press the Space 
bar or click the Play button again to stop play.

Play button
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3

 

Add “Rob Dialog.mov” to the sequence by dragging it from the Viewer to the Canvas window. 

The Edit Overlay appears in the Canvas window, and the Overwrite section is highlighted when 
you drag the image into the window. (Overwrite is the default edit.)

When you release the mouse button, an image from “Rob Dialog.mov” appears in the Canvas, 
and the clip’s one video track and two audio tracks appear in the Timeline.

 

4

 

Click in the Canvas window to make it active (if necessary).

 

5

 

Press Home and then press the Space bar to play the new sequence.

 

Note:  

 

Final Cut Pro provides several ways to add clips to a sequence. These include drag-and-
drop (used in step 3 above); a source/record metaphor using the Viewer and the Canvas; an 
assembly timeline/film metaphor using the Viewer and the Timeline; and keyboard commands 
to execute specific types of edits. All these methods of moving clips are detailed in later 
chapters of the 

 

Final Cut Pro User’s Manual

 

. This flexibility makes Final Cut Pro easy to use 
and lets you choose the work flow that best suits your needs and work style.

 

Identifying Part of a Clip for Use

 

In this sequence, you don’t want to show Rob’s “talking head” for the entire sequence, but you 
want to use all of his speaking in the clip. You can set In and Out points to mark the starting 
and ending points for a section of the clip and then substitute other video for Rob’s image in 
that section, or even eliminate the section between In and Out points. (The clip itself is not 
changed by marking In and Out points.) 

Next, you’ll set In and Out points on one clip and then overwrite that section of the clip with 
part of another clip.

 

1

 

Click in the Canvas window to make it active.

Overwrite section of 
Edit Overlay
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2

 

Press Home to position the playhead at the beginning of the clip.

 

3

 

In the Canvas window, press the Space bar to begin playing the clip.

 

4

 

When you hear Rob say “the Lindy Hop,” press the Space bar to stop the clip.

 

5

 

Click the Mark In button or press I to mark the In point. The current time in the upper-right 
corner of the Canvas should be approximately 1:00:01:23.

Don’t worry if you didn’t mark the point immediately after the phrase “the Lindy Hop.” You 
can adjust the point later (in step 10, below).

 

6

 

 Press Home to reposition the playhead at the beginning of the clip.

 

7

 

Press the Space bar to play the clip.

 

8

 

When you hear Rob say “constantly moving,” press the Space bar to stop play.

 

9

 

Click the Mark Out button or press O to mark the Out point. The current time should be 
approximately 1:00:05:20.

 

10

 

In the Canvas, drag the indicators for the In and Out points in the ruler ( just above the row of 
buttons) to match them to the desired timecodes.

When you drag the In or Out point’s indicator, the current time is displayed for that point. Get 
the points as close to 1:00:01:23 and 1:00:05:20 as you can.

 

Targeting Audio Tracks

 

In an upcoming task, you will overwrite the part of “Rob Dialog.mov” that you marked with 
another video clip. But you want to hear Rob’s voice continuously as the original and 
overwritten sections of “Rob Dialog.mov” are playing. So you should protect Rob’s voice in this 
clip by turning off the audio target in “Rob Dialog.mov.”

 

m

 

In the Timeline, click the audio targeting icon (a double speaker) for tracks A1 and A2 to 
turn off targeting.

Mark In button

Mark Out button

In point Out point

Target track indicators, 
currently on
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When you click the side of the speaker containing a numeral, targeting is turned off and the 
numeral and color in the icon disappear. Clicking a speaker icon that contains no numeral 
turns targeting on for the track.

 

Setting In and Out Points for Another Clip 

 

In the next two tasks you will set an Out point for another clip and then perform an overwrite 
edit to replace the marked section of the original clip (“Rob Dialog.mov”). You’ll be using 
“three-point editing,” Final Cut Pro’s system for calculating the boundaries of an edit from the 
information it has. In this case, you mark the Out point for the new clip and the program 
calculates the In point for that clip, based on the In and Out points you set previously for “Rob 
Dialog.mov.”

For the new clip, “Bloomies.mov,” you’ll mark the Out point in the Viewer.

 

1

 

Double-click “Bloomies.mov” in the Browser to open it in the Viewer.

 

2

 

Press Home to position the playhead at the beginning of the clip.

 

3

 

 Type +500 and press Return to go to the frame 5 seconds into the clip.

As you type, the number appears in the current time box at the upper-right corner of the 
Viewer.

 

4

 

Press O to set the Out point at the position you entered.

 

Performing an Overwrite Edit 

 

Now you’ll replace the marked section of “Rob Dialog.mov” with the section you just marked 
in “Bloomies.mov” with an Overwrite edit.

 

1

 

Drag the “Bloomies.mov” clip from the Viewer to the Overwrite section of the Edit Overlay in 
the Canvas.

 

2

 

Select the Canvas window, press the Home key, and play the sequence.

 

Finishing the Rough Edit

 

Final Cut Pro allows you to add multiple clips in one step. For this tutorial task, you’ll add two 
more clips to your sequence.

 

Positioning the Playhead to Add More Clips

 

To make sure the added clips appear in the right place, use the Timeline to check or adjust the 
position of the playhead in the sequence. The Up and Down arrow keys move the playhead 
from one edit point to the next; Up moves backward in the sequence, Down moves forward. 
In this sequence, the edit points are the points where the sequence begins and where each 
clip meets another clip.

 

1

 

Click in the Timeline window to make it active (if necessary).
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Use the Up arrow (backward movement) or Down arrow (forward movement) to position the 
playhead at the end of “Bloomies.mov,” the clip you just added to the sequence.

 

Adding Multiple Clips at One Time

 

Now add the two additional clips to your sequence.

 

1

 

In the Browser, click the Name field so that the sort arrow at the right is pointing down. 

This sorts the contents of the Browser in alphabetical order by name.

 

2

 

Select the following clips: “Johnny n Cari.mov” and “Round n Round.mov.” 

Command-click to select separated items.

 

3

 

Drag the selected clips from the Browser to the Overwrite section of the Edit Overlay in the 
Canvas. 

 

4

 

In the Canvas, position the playhead at the beginning and then play the sequence.

Your sequence now begins and ends with Rob talking onscreen, and there are three different 
clips of dancers in between.

 

Adding One More Clip

 

To provide a greater focus on the dancers at the end of the sequence, add one more clip at the 
end.

 

1

 

In the Canvas, type 01:00:20:00 and press Return.

As you type, the numbers—a timecode—appear in the Current Timecode box at the upper-
right corner of the window. When you press Return, the playhead moves to the position 
corresponding to the timecode you typed.

 

2

 

Select the clip “Overhead.mov” in the Browser and drag it to the Overwrite section of the Edit 
Overlay in the Canvas.

The clip covers the last portion of “Rob Dialog.mov.”

 

3

 

Press Home to position the playhead at the beginning of the sequence.

 

4

 

Press the Space bar to play the sequence. 

 

5

 

Choose Save Project from the File menu to save your work.
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Advanced Editing Techniques

 

Final Cut Pro includes advanced editing features such as moving In and Out points (slip and 
slide techniques), trimming in the Trim Edit window and in the Timeline with the Ripple and 
Roll tools, and Match-frame editing. The program is designed to let you refine edits quickly, so 
that you can focus on the timing and rhythm of your work.

 

Slipping

 

Use slip editing when you want to simultaneously change the In and Out points of a placed 
edit (one already in the sequence) without changing the duration of the edit or its location in 
the final program. For example, you can use a slip edit to indicate a different part of a clip if 
you have unwanted content in the section currently in use.

In the “Bloomies.mov” clip that you’ve included in your sequence, you discover that the 
dancers do not catch hands for a moment when they both turn at one point. You want to 
eliminate that small error but not change the clip’s duration or its location in the sequence.

To make a slip edit that avoids the dancers’ missed hands:

 

1

 

In the Timeline, use the Up or Down arrow to position the playhead at the beginning of 
“Bloomies.mov” (the second clip in the sequence).

 

2

 

Press the Space bar to play the clip.

Notice that the dancers are not clasping hands as they swing around at the very beginning of 
the clip. (You can see the man’s empty hands as he faces the camera while turning.) They clasp 
hands again—right hand to right hand—at approximately 1:00:02:20.

If you have trouble seeing the missed hand clasp, use the Shuttle control in the Canvas to 
move slowly through the clip, or move frame by frame using the Right and Left arrow keys.

 

3

 

Click the Slip tool in the Tool palette to select it.

 

4

 

Choose Snapping from the View menu to turn snapping off. (No checkmark should appear 
next to Snapping.)

With snapping off, the playhead won’t snap to the nearest edit point, so small movements are 
easier to make.

Shuttle control
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In the Timeline, press and hold down the mouse button on “Bloomies.mov” with the Slip tool. 
The Canvas window displays the head (left) and tail (right) images from the clip, with their 
times in that clip.

 

6

 

Using the images as a reference, slip the edit past the point of the mistake by dragging to the 
left. The mistake will be fixed when the dancers’ hands meet in the left (head) reference 
image. Release the mouse button when you have finished the slip operation.

Pressing the Command key as you drag provides more precise control.

You can check your edit with the numbers for the head and tail frames displayed in the Canvas 
when you hold down the mouse button with the Slip tool. The times in the head and tail 
reference windows should be approximately 03:11:47:16 and 03:11:51:13.

 

7

 

Press Home and then press the Space bar to play the sequence.

 

8

 

Choose Save Project from the File menu to save your work.

 

Trimming an Edit

 

To make precise adjustments where two clips meet, you can trim one or both clips. Trimming 
fine-tunes the In or Out point of a clip within a sequence.

Final Cut Pro offers many ways to trim an edit. These include using the Trim Edit window, the 
Ripple and Roll tools, and keyboard commands.

In this task, you’ll trim some frames from one clip to eliminate a moment in which the male 
dancer in the clip “Johnny n Cari.mov” looks upward, directly into the camera.

To trim an edit using a Trim tool:

 

1

 

Click the Zoom In tool in the Tool palette or press Z.

 

2

 

In the Timeline, click twice on “Bloomies.mov” to zoom in on that area of the sequence.

Zooming in makes the view of each clip longer in the Timeline, providing a better view of the 
clips and the points where they meet.

 

3

 

Click the Arrow tool in the Tool palette or press A.
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4 In the Timeline, click once on the edge between the second and third clips (“Bloomies.mov” 
and “Johnny n Cari.mov”) to select the edit. The pointer changes to indicate that the mouse is 
over an edit point.

Be careful not to double-click, because this will open the Trim Edit window.

5 Click the Roll tool in the Tool palette (or press R). (The Roll tool affects both clips; the Ripple 
tool adjusts only one side of the edit.)

6 In the Timeline, press and hold down the mouse button on the selected edit and drag the Roll 
tool to the right.

The edit is represented in the Canvas as a small window for each clip that displays the frame 
points and adjustments.

7 Trim the edit by dragging to the right until the male dancer’s eye contact with the camera is 
edited out of “Johnny n Cari” in the right window (about five frames).

8 Press A to select the Arrow tool in the Tool palette.

Note:  You can also trim an edit by double-clicking a clip in the Timeline to open it in the 
Viewer, then dragging the In and Out point indicators in the Viewer to adjust those points. In 
this method of trimming, you don’t see the changes in the adjoining clip, as you do when 
using the Roll tool in the Timeline.

Match-Frame Editing

Final Cut Pro provides powerful tools to perform sync-point editing—edits in which you need 
a visual to match an audio cue. Audio cues can easily be marked using Final Cut Pro’s markers.

When a clip is already in a sequence, the Match Frame button cues the original version of the 
clip in the Viewer with the playhead. Then you can use the Replace edit mode to select the 
video frame that will synchronize to the playhead in the sequence.

In your sequence, you’ll mark frames and use the Match Frame command to align the 
voiceover at the point where Rob says “stops” with a frame in the sequence where a dancer 
actually stops.
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To create a Match-frame edit that matches a dancer’s movement to a specific phrase in Rob’s 
narration:

1 Select the Zoom Out tool from the Tool palette.

To locate the tool, press on the Zoom In tool.

2 Click once in the Timeline to zoom out.

3 Press A to select the Arrow tool.

4 Press Home to go to the beginning of the sequence.

5 Play through the sequence until Rob says “there’s a lot of stops” (approximately 13 seconds 
in). 

Notice the male dancer jumps to a stop at a different point from where Rob says “stops.”

6 Play the sequence again and press M to place a marker where Rob says “stops.” 

A green marker appears in the Timeline at the point you marked and a yellow marker appears 
in the Canvas.

Note:  When the sequence is not playing, you can jump to the next marker by pressing Shift-M 
(moving forward) or to the previous marker (moving backward) by pressing Option-M.

7 Position the playhead on the marker you just added (by pressing Shift-M or Option-M).

8 Choose Markers from the Mark menu, then choose Edit from the submenu.

9 Name the marker “Stops,” add the comment “he says stops,” and click OK.

10 Click the Match Frame button in the Canvas. 

The Match Frame button opens a copy of the marked clip in the Viewer and cues it to the 
frame displayed in the Canvas window.

Marker in Canvas

Marker in Timeline

Match Frame button
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11 If the image in the Viewer appears jagged, make sure the zoom level is set to 100% (using the 
pop-up menu above the image).

12 In the Viewer, use the Jog control to locate the frame where the dancer lands from his jump.

The timecode in the Viewer is approximately 00:00:07;00 when the dancer lands.

13 Drag the clip from the Viewer to the Replace section of the Edit Overlay in the Canvas.

Notice that the image in the Canvas now matches the Viewer. Replacing the clip with the 
playhead at the marker (after using the Match Frame button) aligns the frame showing in the 
Viewer with the marker in the Timeline.

14 Select the Canvas window, press the Up arrow to go back one or two edits, and press the 
Space bar to play the completed edit.

Applying and Editing a Dissolve Transition

You can make the transition between clips less abrupt—and more interesting—by adding a 
transition, one type of special effect provided in Final Cut Pro. You can see a list of the video 
and audio transitions in the Effects tab of the Browser.

Transitions can be applied automatically using either of the Edit with Transition buttons in the 
Canvas. You can edit transitions in the Timeline.

Jog control

Replace section of Edit 
Overlay
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Adding a Transition Along With a Clip

In the next task, you’ll add a transition at the same time you add a new clip to the sequence.

1 In the Browser, double-click the clip “Jeremy Solo.mov” to open it in the Viewer.

2 In the Timeline, position the playhead at end of “Round n Round.mov.”

You may want to turn Snapping on to help position the playhead. If so, press N.

3 Drag the clip “Jeremy solo.mov” from the Viewer to the Overwrite with Transition section of 
the Edit Overlay in the Canvas.

The icon for a transition appears in the Timeline between the clips “Round n Round.mov” and 
“Jeremy Solo.mov.”

Overwrite with 
Transition section
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Note:  This edit uses the default transition, in this case, a cross dissolve. If you position the 
playhead over the transition in the Timeline, you can see the effect in the Canvas. 

The render bar over the transition is red, indicating that this part of the sequence must be 
rendered before you can play the transition. 

Replacing the Transition

Now you can replace the current transition with one of the other video transition effects 
available in Final Cut Pro.

1 In the Timeline window, drag the playhead to position it anywhere in the transition.

2 Choose Video Transitions from the Effects menu, choose Wipe from the submenu, and then 
choose Center Wipe from the second submenu.

Transition icon

Render bar (red) over 
transition that must be 
rendered
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3 Position the playhead over the transition to see the change.

4 Choose Save Project from the File menu to save your work.

Editing the Transition

Once you’ve replaced the transition, you can edit it by changing its length and type.

To edit the transition in the Timeline:

1  Click the transition to select it in the Timeline.

2 Control-click on the transition to open the shortcut pop-up menu, and then choose Duration.

3  Type “.25” in the Duration dialog box and click OK to change the duration of the transition to 
25 frames.

You can also edit a transition in the Viewer by double-clicking it in the Timeline.

Rendering the Transition

To play the transition in the sequence, you need to render it.

1 In the Timeline, click the transition to select it (if necessary).

2 Choose Render Quality from the Sequence menu, then choose Hi Res from the submenu.

3 Choose Render Selection from the Sequence menu.

A status bar shows the progress of rendering.

4 Position the playhead to the left of the transition and play through the transition.
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Adding Graphic Elements

Often you’ll want to use one or more graphic elements in a sequence to offer variety, to 
provide information not available on video, or to add sophisticated titles and captions.

In this sequence, you’ll add graphic elements to provide a title section.

To add the graphic elements to the sequence:

1 In the Timeline, press Home to move the playhead to the beginning of the sequence.

2 In the Browser, drag the clip named “Intro.mov” to the Insert section of the Edit Overlay in the 
Canvas.

The clip is inserted at the location of the playhead (the beginning of the sequence). All the 
items to the right of the playhead are moved further to the right—and further out in time.

3 In the Timeline, press Home to move to the new starting point for the sequence and press the 
Space bar to play the title section.

4 Choose Save Project from the File menu to save your work.

Now you’re ready to add sound to the sequence’s new opening.

Audio Editing

Final Cut Pro can use up to 99 tracks of audio, which you can edit and adjust without leaving 
the application. A minimum of eight tracks can be manipulated and mixed in real time, and 
some computer models can permit working with 24 or more audio tracks in real time.

The program includes audio pitch shifting, which mimics how audio sounds when played at a 
variety of speeds using analog tape. In addition, Final Cut Pro displays separate waveforms for 
left and right audio tracks, and offers independent fade controls, panning controls, and a 
variety of audio filters.

Adding an Audio Introduction

You can give this Swing Dance sequence a lively introduction by adding a music file. Then 
you’ll adjust the music’s volume so that it fades to the background when Rob begins speaking.

1 In the Browser, double-click “Jumptown.aiff ” to open it into the Viewer. 
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Notice that when you open an audio file, audio controls become available in the  Viewer.

2 Using the Shuttle control, move the shuttle button to various locations. 

You should hear the audio playing at different speeds. This is pitch-shifting at various levels 
depending on the speed.

3 Press the Tab key to select the duration (in the upper-left corner of the Viewer), type “43.” (the 
number 43 and a period), and press Return.

Entering the new duration sets an Out point for the audio clip at 43 seconds past the In point.

4 Click in the Timeline window to make it active.

5 Choose Insert Tracks from the Sequence menu.

6 In the dialog box, type 2 in the Insert Audio Tracks box, then click OK.

7 In the Timeline, click the target track indicator (a dual speaker icon) for tracks A3 and A4 to 
make them the target tracks.

Click the left side of the dual speaker icon in audio track A3; then click the right side of the 
dual speaker icon in audio track A4.

The numeral 1 appears in the left part of the target indicator in A3 and the numeral 2 appears 
in the right part of the indicator in A4.

Shuttle control

Target track indicators, 
currently on
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8 Select the Timeline window (if necessary) and press Home to put the playhead at the start of 
the sequence.

9 Using the Drag Hand (the hand icon) in the upper-right corner of the Viewer, drag the audio 
clip to the Overwrite section of the Edit Overlay in the Canvas.

10 Select the Timeline window and press Home to put the playhead at the start of the sequence.

11 Play the sequence.

Notice that the volume of the music is too loud when Rob starts talking and needs to be 
adjusted. 

Adjusting the Volume Over Time

To change the music’s volume to hear the voiceover:

1 In the Timeline, find the point where the interview footage starts and move the playhead to 
that location.

2 Click the Clip Overlays button at the lower-left area of the Timeline to display audio volume 
levels.

Notice that a thin line, the volume level indicator, appears over the audio tracks.

3 Press Option and click the volume level line of “Jumptown.aiff ” to set a keyframe about 2 
seconds before the “Rob Dialog.mov” audio clip begins (at approximately 15 seconds).

Drag Hand

Clip Overlays button
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A small diamond appears at the keyframe location.

4 Move about 2 seconds further to where the “Rob Dialog.mov” audio clip actually begins and 
set another keyframe (at approximately 17 seconds). 

5 Drag the second keyframe’s indicator (the diamond at 17 seconds) down to adjust the volume 
level to about -8.

If you can’t set an exact value, choose a number between -8 and -10 if possible. (Holding down 
the Command key while dragging allows for more precise control.)

6 Play back the sequence with the audio mixed in real time.

7 Choose Save Project from the File menu to save your work.

You’re now finished with the current project. The concluding section of the tutorial uses a 
different project.

Compositing and Special Effects

Compositing is the process of combining multiple layers of video, usually along with special 
effects such as animation, painting or retouching images, and a variety of digital alterations 
using filters.

In this section you will use the introduction piece for the Swing Dance video to explore Final 
Cut Pro’s special effects and compositing features. The tasks include compositing a 
background, animating multilayered elements, and applying filter effects to add elements to a 
composition.

Keyframe indicator
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You use a different project, named “Compositing,” for the tutorial’s compositing and special 
effects.

Opening and Saving a New Project

Next, you’ll open the new project for this part of the tutorial.

To open the files for compositing:

1 Choose Open from the File menu, select the project “Compositing.fcp” in the Projects folder, 
and click Open.

2 Choose Save Project As from the File menu, type “My Project 2.fcp,” and click Save.

Previewing the Introduction’s Titles

Next, you’ll open the sequence for this part of the tutorial and preview it.

1 Double-click “Intro.mov” in the Browser to open it in the Viewer.

2 Press Home to reposition the playhead at the beginning of the sequence.

3 Press the Space bar to play the clip.

This is the title portion of the introductory sequence you’ll create.

Building the Background

The background for the introduction is a still image of velvet that you’ll animate by changing 
its size, or scaling it.

Adding the Background Image to the Sequence

The first task in preparing the background is to add it to your sequence.

1 Double-click Sequence 1 in the Browser to open it.

The sequence opens in the Canvas and Timeline. No clips are in the sequence yet.

2 Double-click “Velvet Background.pict” in the Browser to open it in the Viewer.

3 Drag “Velvet Background.pict” from the Viewer to the Canvas.

Scaling the Background Over Time

Next, you’ll change the size of the background image over time.

1 Click the Canvas window to make it active.

2 Open the View menu and choose Image+Wireframe to change the display mode for the 
background image.

3 Click the image in the Canvas. 
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A frame with diagonal crosshairs appears on top of the image. You use this wireframe to scale 
the image or change its position.

4 Press Home to position the playhead at the beginning of the clip.

5 In the Canvas, click the Add Keyframe button.

The crosshairs in the wireframe turn green when you add a keyframe.

6 Press the End key or press Shift-Home to move the playhead to the end of the clip.

Add Keyframe button
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7 In the Canvas, place the pointer at one corner of the wireframe and drag toward the center 
until the frame’s outline is just outside the edges of the viewable area.

8 In the Canvas, drag the playhead through the Scrubber. The wireframe indicates the change in 
image size between the beginning and end of the 17-second clip.

Putting Dancers on the Background

Next, you’ll add a pair of dancers to the velvet background, add a filter, and add motion.

1 In the Canvas, press Home to position the playhead at the beginning of the sequence.

2 Type 1:00 to move the playhead 1 second into the sequence.

3 Drag “Blue Dance.mov” from the Browser to the Superimpose section of the Edit Overlay in 
the Canvas.

Playhead in the 
Scrubber
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“Blue Dance.mov” appears on track V2 in the Timeline.

Adding a Filter to the Clip

Next, you’ll add a filter to the dancers.

1 Select “Blue Dance.mov” in the Timeline.

2 Open the Effects menu and choose Video Filters, then choose Key from the submenu and Blue 
and Green Screen from the second submenu.

You can use a blue and green screen key to isolate a subject that was shot against a specially lit 
blue or green background.

Editing the Filter

Once you’ve applied a filter, you can change its parameters.

1 Double-click “Blue Dance.mov” in the Timeline to open it in the Viewer.

2 If the image in the Viewer appears jagged, make sure the zoom level is set to 100% (using the 
pop-up menu above the image).

3 Click the Filters tab.
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4 Select the Color Level text box, type 40 in it, and press Return.

Adding Another Filter

Next, you’ll add a second filter to the dancers.

1 Open the Effects menu, choose Video Filters, then choose Image Control from the submenu 
and Desaturate from the second submenu.

2 Choose Save Project from the File menu to save your work.

Adding Motion and A Drop Shadow

To ensure that the titles and dancers are visible in the final sequence, you’ll reposition the 
dancers. Then you’ll give them more definition by adding a drop shadow.

1 In the Canvas, drag the wireframe to the right until the dancers are just slightly to the right of 
center.

2 In the Viewer, click the Motion tab.

Color Level
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3 Click the Drop Shadow checkbox to put an X in it.

Doubling the Dancers

The introduction uses two images of dancers in slightly different positions on the screen. In 
this task, you’ll copy them and reposition the second image.

1 In the Timeline, select “Blue Dance.mov” (if necessary).

2 Open the Edit menu and choose Copy. 

3 In the Timeline, click the filmstrip icon in track V3 to make it the target track.

4 Position the playhead at the beginning of “Blue Dance.mov” (if necessary).

5 Choose Paste from the Edit menu.

A copy of “Blue Dance.mov” appears on track V3 in the Timeline.

Drop Shadow

Target Track indicator 
(yellow when on)
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Stretching the Dancers

Next, you’ll stretch one of the images of dancers and reposition it.

1 In the Timeline, position the playhead over the “Blue Dance.mov” clips.

2 Select “Blue Dance.mov” on track V2

3 In the Canvas, press the Shift key and drag upward from a top corner of the wireframe to 
stretch the image of the dancers.

Elongate the image so that the dancers’ heads are just below the edge of the image area.

4 Drag the dancers to the right a short distance to offset them from the second image.

Changing the Opacity of an Image

Next, change the opacity of the pair of dancers you stretched to add yet another effect in the 
introduction.
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1 In the Timeline, click the Clip Overlays button at the lower-left side of the window.

2 Select “Blue Dance. mov” on track V2 (if necessary).

3 Drag the overlay (a white line) on track V2 downward to a value of approximately 40.

As you drag, numerical values appear next to the overlay. (Press the Command key as you drag 
to make more precise adjustments.)

4 Choose Save Project from the File menu to save your work.

Adding Circles Around the Dancers

In this task you’ll work with two circles that move with the dancers.

1 Double-click “Circle Rules.psd” in the Browser.

This file is an Adobe Photoshop file, which opens as a new sequence with video tracks for 
“circle 1” ( V1) and “circle 2” (v2).

2 In the Timeline, select “circle 1.”

3 Choose Image+Wireframe from the View menu (if necessary).

Clip Overlays button

Overlay and numeric value
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4 In the Tool palette, press the Crop tool, then select the Distort tool from the pop-up menu.

5 Click the center point of the wireframe and drag to the left about one-fourth of an inch.

This movement offsets the point around which the circle rotates.

Changing a Circle’s Rotation Over Time

Next, add rotation to the circle.

1 Press the Home key to position the playhead at the beginning of the sequence.

2 In the Timeline, double-click “circle 1” to open it in the Viewer.

One circle appears in the Viewer, against a checkerboard background.

3 In the Viewer, click the Motion tab.

4 Click the Add Keyframe button for Rotation to add a motion keyframe at the beginning of the 
clip.

Distort tool
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A diamond-shaped keyframe symbol appears at the left edge of the graph area in the Viewer. 
( You may want to enlarge the Viewer’s window to see the entire graph area.)

5 Press Shift-O to move the playhead to the end of the clip.

6 Click in the Rotation text box, type 1000, and press Return to set a new value for rotation.

The program adds a motion keyframe at the end of the clip and displays a graph of the 
rotation values at the right side of the Viewer window.

Keyframe symbol

Add Keyframe button

Rotation graphRotation text box
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Rotating the Second Circle

Next, you’ll rotate the other circle around a different center point.

1 In the Timeline, select “circle 2.”

2 Select the Distort tool from the Tool palette.

3 In the Canvas, click on the center of the wireframe and drag to the right about one-eighth of 
an inch.

4 In the Timeline, double-click “circle 2” to open it in the Viewer.

5 Click the Motion tab.

6 Press the Home key to position the playhead at the beginning of the clip.

7 Click the Add Keyframe button for Rotation.

8 Press Shift-O to position the playhead at the end of the clip.

9 Click in the Rotation text box, type “500,” and press Return.

Adding the Circles to the Sequence

Next, you’ll add the circles to the sequence with the dancers.

1 In the Timeline, select the Sequence 1 tab.

2 Choose Snapping from the View menu to turn it on. 

A checkmark appears next to Snapping to indicate that it is turned on.
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3 Drag “Circle Rules.psd” from the Browser to the blank area above video track V3 in the 
Timeline, aligning it with the beginning of “Blue Dance.mov.”

A track ( V4) is added automatically and “Circle Rules.psd” appears on it in the Timeline.

4 Select “Circle Rules.psd” in the Timeline.

5 Select the Arrow tool in the Tool palette.

6 In the Canvas, drag the wireframe to place the circles around the dancers.

If you don’t see the wireframe, choose Image+Wireframe from the View menu.

Adding Titles for the Introduction

To finish the introduction, you’ll animate several titles.

m Double-click “Dance Names.psd” in the Browser.
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Because it’s an Adobe Photoshop file, “Dance Names.psd” opens as a new sequence in the 
Timeline.

Animating One Title

First, you’ll add motion to one of the titles.

1 Select the “Dance Names.psd” tab in the Timeline.

2 Press the Home key to position the playhead at the beginning of the sequence.

3 Open the View menu and choose Image+Wireframe.

4 In the Canvas, drag the BOOGIE WOOGIE image to the lower-left corner of the screen.

5 In the Timeline, double-click “BOOGIE WOOGIE” to open it in the Viewer.

6 Click the Motion tab in the Viewer.
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7 Click in the Scale text box, type 0 (zero), and press Return.

8 Click the Add Keyframe button for Scale.

9 Click the Add Keyframe button for Center.

10 Click the arrow to expand the Opacity section, then click the Add Keyframe button for Opacity.

11 Press Shift-O to position the playhead at the end of the clip.

12 Press the Left arrow once to move the playhead back one frame.

13 Click in the Scale textbox, type 150, and press Return.

14 In the Canvas, drag the wireframe and title image to the middle of the screen.

If you don’t see the wireframe, choose Image+Wireframe from the View menu.

A motion path appears to show the movement of the image.

15 Control-click at the beginning of the motion path (a green circle) and choose “Ease In/Ease 
Out” from the pop-up menu.
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A tiny purple dot appears on the motion path.

16 Place the pointer on the purple dot and drag it up and to the left to create a curved motion 
path.

17 In the Canvas, scrub through the part of the sequence with “BOOGIE WOOGIE” to see the 
title’s motion.

Fading a Title In and Out

Next, you’ll change the title’s opacity so that it fades in and out as it moves across the screen.

1 In the Timeline, press Home to position the playhead at the beginning of the sequence.

2 Press the Tab key to select the Timecode box at the lower-left side of the Timeline window.

3 Type +15 and press Return.

The playhead moves forward 15 frames.

4 In the Timeline, double-click “BOOGIE WOOGIE” to open it in the Viewer.

5 Click the Motion tab.

6 Click the Add Keyframe button for Opacity.

7 In the Viewer, click the previous keyframe indicator in the opacity graph to move the playhead 
to it.

Timecode
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8 Click in the Opacity textbox, type 0 (zero), and press Return.

9 Press Shift-O to move the playhead to the end of the clip.

10 In the Timeline, press the Tab key to select the Timecode textbox.

11 Type -15 and press Return.

12 In the Viewer, click the Add Keyframe button for Opacity.

13 Press Shift-O to move the playhead to the end of the clip.

14 Click in the Opacity textbox, type 0 (zero), and press Return.

The opacity graph in the Viewer shows the fade in-fade out effect you created.

Copying a Title’s Attributes to Other Titles

In Final Cut Pro you can copy and paste attributes from one clip to another. In this task, you’ll 
copy the motion and fade effects from “BOOGIE WOOGIE” to the other title images in the 
introduction.

1 In the Timeline, select “BOOGIE WOOGIE.”

2 Open the Edit menu and choose Copy.
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3 Option-click the visibility indicator for track V1 in the Timeline (the bright green bar at the left 
edge of the track) so that all tracks’ indicators are turned on.

When visibility for other tracks is off, Option-clicking the visibility indicator of the visible track 
turns on visibility for all tracks.

4 In the Timeline, select the clips in tracks V2 to V6 above “BOOGIE WOOGIE.”

Command-click clips individually or drag across the clips to select them.

5 Open the Edit menu and choose Paste Attributes.

6 Select Basic Motion and Opacity in the Paste Attributes dialog box, then click OK.

7 In the Canvas, drag the playhead through the Scrubber to see the titles in motion.

Adding the Titles to the Introductory Sequence

The final task in preparing the introduction is to add the titles to the dancers and background.

1 In the Timeline, click the “Sequence 1” tab.

2 Click the target indicator (filmstrip) in video track V1 to make it the target track.

3 Position the playhead over the clip on track V1 (if necessary).

4 Open the Mark menu and choose Mark Clip.

This sets In and Out points at the boundaries of the clip on track V1.

Visibility indicator
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5 Drag “Dance Names.psd” from the Browser to the Superimpose section of the Edit Overlay in 
the Canvas.

Rendering the Sequence

Now it’s time to render the introductory sequence so you can play it with all the new effects. 
The Timeline indicates which sections of the sequence need to be rendered by displaying a 
red bar above the Ruler.

Depending on the computer you’re using and size of the media files, rendering can take a few 
minutes or longer. Rendering time for this sequence is approximately 10 minutes.

To render and play the sequence:

1 Choose Render All from the Sequence menu. 

A status bar reports the progress of rendering.

2 When rendering is complete, press the Space bar to play the sequence. 

Finishing a Project

When you’ve completed the editing for your project, you have several options for saving your 
work in the format that’s best suited to the way you’ll use it. The formats available in Final Cut 
Pro include printing or editing on videotape; saving as a QuickTime movie, a digital video 
stream, a still image, or a series of still images; and saving as an audio file.

Superimpose section
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Printing to Video

Use the Print to Video command to print a sequence or clip to video tape. You can use the 
Print to Video command without device control. If you have device control, the Edit to Tape 
command (in the Tools menu) lets you perform insert and assemble edits to tape. 

Note:  You must have a videotape recorder (VCR) connected to your computer and operating 
before you can actually print a sequence on videotape. You can follow the steps in this 
procedure without having a VCR connected, however.

To print a sequence on videotape:

1 Click the tab for “My Project 1.fcp” in the Browser.

2 Double-click “Sequence 2” in the Browser to open it.

3 Select the “Sequence 2” tab in the Timeline. 

4 Choose Print to Video from the File menu.

5 In the dialog box, specify the Print to Video options and click OK.

(For this tutorial, use the default settings. Or experiment with changing options if you wish, 
and view the changes when you replay the video.)

6 The sequence is rendered if necessary and a message appears, prompting you to start 
recording on your VCR. 

7 Start recording and press OK.

Exporting a Sequence for Multimedia or the Web

Final Cut Pro offers several ways to export your work. You can create a QuickTime movie, a 
format that is widely used and has relatively small files. Or you can export an Edit Decision List 
(EDL), a record of all the files, edits, effects, and other essential details of the project in text 
format. An EDL is especially useful for projects in which several people are working with the 
media.

For this task, you’ll export a sequence as a QuickTime movie. These files are quite popular for 
delivering video on Web sites and in multimedia presentations.

To export a sequence as a QuickTime movie:

1 Select the “Sequence 2” tab in the Timeline.

2 Choose Export from the File menu, then choose Movie from the submenu. 

3 In the dialog box, specify the options for the exported file, type a name for it, and click Save. 

(For this tutorial, use the default settings. Or experiment with changing options if you wish, 
and view the changes when you replay the video.)


