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Introduction
Dialog Creator is a Macintosh software development tool supplied by the Macintosh developer support group of Apple Canada. 
It is a utility for creating resource file fragments which describe dialog and dialog item list resources. These fragments are 
meant for inclusion in a resource source file for RMaker. The Dialog Creator lets you draw the dialogs that you plan on 
employing in your application and then print and save the text file fragments.
The real advantage in using Dialog Creator is that the dialogs can be easily and quickly created and modified at any time 
during the development process. This enables a software designer, perhaps a person with little or no programming ability, to 
design all of the user dialogs in a program without having to know a great deal about resources. (Just as people who use 
MacDraw needn't know about quickdraw). The designer can then give the programmer screen dumps showing the Dialog 
boxes he has drawn and copies of the associated RMaker files. If changes have to be made during the development cycle, it is 
a simple process to re-edit the RMaker text files using the Dialog Creator.
A Dialog Creator data file is simply a file of type TEXT which can be opened by an Macintosh editor.  It contains part of a 
resource definition file which can be used with either the Lisa Workshop RMaker or the Macintosh RMaker.  Users of Lisa 
Workshop 3.0 can use MacCom to transfer these and other TEXT files to the Lisa and convert them to Workshop text files.

Starting Dialog Creator
The Dialog Creator will run under any Macintosh environment .It can be started from the Finder by double clicking its icon, 
selecting it and choosing Open from the file menu as well as by asking the Finder to Open or Print a Dialog Creator data file. 
Once the dialog creator is running, the user  then creates a dialog window and dialog items using the commands provided and 
manipulates them by typing data (such as their titles), selecting, dragging and re-sizing. In fact, working with the dialog creator 
is much like using MacDraw or the Finder.

Summary of Operations
The user first creates a dialog window by selecting New Window from the File menu. This will create the required dialog 
window and display a window containing data about the new dialog. Once a dialog window has been created, the user may 
create dialog items for it using the New Item command which replaces the New Window command in the File menu. These 
two commands are identical in their operation, except that only one dialog window can be edited at a time.  The user can 
manipulate these objects (dialog window and dialog items) by:
Clicking: Clicking on an object selects it. A selected item is displayed in inverse and a selected window has a thick grey 
border around its frame. Using the Types menu, a user can change the type of selected objects (e.g. from edittext to stattext or 
from an alert box to a document box). Selected objects can also be deleted, duplicated and centered using the Remove and 
Duplicate commands in the Edit menu and the Centre command in the Arrange menu.
Dragging: Objects can be dragged by clicking on them and dragging their outlines to a new position.
Re-Sizing: The user can change an object's size by dragging its lower right hand corner into a new position. Selected objects 
display a small grey box which defines the area to be dragged.
Shift-Clicking: Shift-clicking dialog items serves to "group" items. A group of items can be duplicated, removed and centered 
as can a selected item, however the items within a group can be aligned with one another using the Align command on the 
Arrange menu.
Double-Clicking: Double-clicking an object serves to display that object's data window. The data window contains information 
such as the object's rectangle and its title. This data can be edited and entered directly from the keyboard.
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The Windows
There are four types of window associated with dialog creator. These windows each provide access to information about the 
dialog box which is being edited. Perhaps the most important window is the Dialog Window itself. This is the window which is 
being "drawn" by the user. Everything that the user sees in the Dialog Window will be seen in the final product: the dialog 
window in a running application. 

Another window is the RMaker Window which displays the RMaker fragment  file. This window describes the current state of 
whatever dialog is under construction at any given time. The RMaker Window is provided so that  the entire item list can be 
examined at once. This is useful for comparing the resource data of various items in the list.

The two other windows are data windows: the Item Data window and the Window Data window. These  display the resource 
data for a particular item or the dialog window.  They are used to enter numerical or character data, pertaining to a given 
object, which it is not possible or convenient to "draw".
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The Menus
There are six menus on  the dialog creator menu bar. 

The File Menu

New Window - This command  is used to created a new Dialog window. The  type that the window appears as is determined 
by the window type which is selected under the Types menu. (More on this later) The default type is the alert window type and 
the default rectangle is: 100, 100, 250, 400 [top, left, bottom, right].  If  the default rectangle is not desired, the user may opt to 
drag out, or draw, the outline for the window on the desk top. Following this, New Window will created a new dialog window in 
the position indicated. It draws the dialog window and displays the appropriate data window.
New Item - This command replaces New Window as soon as a dialog window has been created. It is the same as the above 
command except that it creates a new item which it adds to the end of the dialog item list. Once the dialog window has been 
established, the user employs this command to create all the items he requires for the dialog item list.

Open - This command allows the user to read a resource file fragment, a text file in the format that Dialog Creator saves its 
RMaker files,  into memory for further editing.
Close - This command closes the current Rmaker fragment and its associated dialog window so that another dialog can be 
edited. Naturally, the user will be reminded to save any changes before they are lost.
Save & Save as - These two commands are standard.
Print - This command is used to print the current version of the RMaker fragment file which is in memory.
Quit - Once again, this is a standard function and the user will be reminded to save before data is lost.

The Edit Menu

Undo - The Undo command has a somewhat special function in the Dialog Creator. Rather than undoing the last thing that 
was done to a particular object, it restores the state of a selected object to the state that object held when it was first selected. 
In other words, if one were to select an item and then make several changes to it, selecting Undo would have the effect of 
undoing ALL of the changes that were made to that item. The item would be left looking as it did when it was first selected.
Cut, Copy, Paste & Clear - These commands are the standard text editing commands. They are used to manipulate the text 
data in the Data windows.
Duplicate - This is used to duplicate items in the item list. The user selects one or more items which are showing in the dialog 
window (by clicking or shift-clicking on them) and selects Duplicate. This has the effect of creating a duplicate set of the 
selected items. These new items become the selected items and are added to the end of the item list.
Remove - This command is very similar to the Duplicate command; however, instead of creating a new set of item(s), Remove 
deletes the selected item(s) from the item list.

The Display Menu

Show RMaker File - This command displays the RMaker window. When the RMaker window is showing, this command is 
replaced by...
Hide RMaker File - This command is the reverse of the above; it hides the RMaker window.
Open Window - This command displays the Window Data window and is used to select the dialog window as an object for 
editing.
Open Item - This command is similar to the one above, however there are some important differences. If no item is selected 
when this command is chosen, the first item in the item list is used. If an Item Data window is being displayed when the 
command is chosen, the item following the currently selected item in the item list is selected.
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The Arrange Menu

Align - The Align command is used to align all of the objects in a particular group of selected items. To use this function, the 
user must select a group of items from the Dialog window by shift-clicking them and  noting which item was selected last; this 
item becomes the align key item. Selecting Align will then bring up the dialog box shown below.

The user then decides what aspect of the items should be aligned. Pressing the "Align" button will result in the all of the 
grouped items being aligned with respect to the align key item (the last item in the group to be selected).
Centre - This command is similar to Align, however any object or group of objects can be centered. Selecting Centre from the 
menu bar after a the dialog window was selected, will cause the dialog box shown below to appear. 

Here, the user decides whether the window is to be centered vertically or horizontally and the bounds in which the window is to 
be centered. There is a similar dialog for users who are centering items.
Note that the option to Centre "In Lisa (XL) Screen"  predates the Macintosh XL screen modification described in Macintosh 
Technical Note # 16.
Grid Mode - This is a command which toggles grid mode on and off. When grid mode is active, all actions are aligned to a grid 
with 5 pixel spacing.
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The Types Menus

The Window Types Menu - This menu is used to select window type. If the dialog window is selected when this menu is used, 
the window's type is changed appropriately. If the user has drawn an outline for the window, selecting a type from this menu 
will create a new dialog window of the appropriate type. If nothing has been selected, the type indicated on the menu will be 
used as a default for the next New command.
The Item Types Menu - This menu is used to select item type. It functions in a manner identical to the Window Types menu.

Short Cuts
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Text data longer than that allowed by the edit fields in the data window can be entered without difficulty. This can become 
necessary if the user must enter a very large static text item. This is done by calling up the Notepad desk accessory, typing the 
text, copying it and pasting it into the appropriate data field. Should it ever be necessary to select the entire extended field, to 
copy, delete, or replace, one may use the TAB key. WARNING: do not use the notebook to enter "bad" characters like tabs, 
carriage returns etc. since RMaker will not accept these.

Two features are included to allow the user to place objects in specific locations by eye. One feature is grid mode, this restricts 
all objects to a 5x5 pixel grid so that it is easy to position objects correctly. The second feature is an aid for situations where 
dragging and re-sizing are appropriate. If the data window for an object is visible while that object is being dragged or re-sized, 
the data in the window changes to reflect the continually changing position and size.

Dialog Creator is useful for more than just creating dialogs. It is a useful tool in the application design process. Dialog Creator 
can aid in preparing program specifications if the application designer makes screen dumps (using Command-Shift-4) as well 
as printed copies of the dialog fragment files. These documents can then be given to programmers to provide a better idea of 
what the application should look like.

Comments?

Please send all comments to:

Michael Bayer
Apple Canada
Software Developer Relations,
875 Don Mills Road, Don Mills,
Ontario, Canada
M3C1V9
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