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U s i n g  I m a g e  V u e

This online guide provides instructions for using Image Vue, an image editing
program from Live Picture, Inc. Topics covered include:

About Image Vue

Opening Files

Setting Image Characteristics

Using the Toolbar

Setting Image Vue Preferences

Saving and Closing Files

Quitting Image Vue
To go to a topic, use one of these methods:

• Click red underlined text to jump to the topic.
• Click a navigation button in the Adobe™ Acrobat™ Reader toolbar.

• Click a bookmark title in the window to the left to go to that topic.

Credits
Written by Laurie M. Love for Live Picture, Inc.

© 1995 Live Picture, Inc.
All rights reserved.
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A b o u t  I m a g e  V u e

Image Vue lets you open, view, modify, and convert images stored in a variety of
digital formats. TIFF, PhotoCD, and IVUE are native Image Vue formats. EPS-
DCS, Scitex CT, and Adobe Photoshop™ 3.0 are supported via Photoshop-
compatible plug-in modules provided with Image Vue. Plug-in modules let you
import files from and export files to other programs that have their own proprietary
file formats.

You can also use Image Vue to modify an image by scaling, cropping, flipping, and
changing resolution and color model.

Click to jump to a topic.

Starting Image Vue

Image Vue Interface
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Starting Image Vue

Before you run Image Vue, make sure you have 8 MB of RAM available to the
program.

Note Although the minimum RAM requirement is 8 MB, the preferred
RAM size is 16 MB. If you have enough available RAM, you
can allocate the preferred size to Image Vue using the Info
window in the Finder.

To start Image Vue:

• Locate the Image Vue application icon in the Finder, and double-click it.
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Image Vue Interface

Image Vue includes a control bar, a toolbar, rulers, and a simple set of menu
commands so you can easily accomplish basic image editing tasks.

Use the control bar to view and set image size and unit of measure, image scale
percentage, output resolution, and color model. Use the tools in the toolbar to scale,
crop, zoom, pan, flip, and rotate the image. Use the horizontal and vertical rulers to
work more precisely.

To show the rulers:

• Choose Show Rulers from the View menu. The command switches to Hide Rulers,
which you can choose to make them hidden again.

When you show the rulers, the two rulers meet at the top left point, called the point
of origin (x = 0, y = 0). You can change the point of origin by clicking in the
intersection of the rulers and dragging to a new point in the document..

The Size pop-up menu in the control bar determines the rulers’ unit of measure.
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O p e n i n g  F i l e s

To work in Image Vue, you must first open a file. You can open files by choosing
Open or an Acquire submenu command from the File menu.

Choose To do this

Open Open TIFF, PhotoCD, or IVUE files, or files for which you
have Photoshop-compatible plug-in formats.

Acquire Convert EPS-DCS, Scitex CT, and Photoshop files to IVUE.

Image Vue lets you have more than one file open at one time.

Note If Image Vue cannot locate the Preferences file, which indicates
the location of special files and folders, you may not be able to
open a CMYK file nor use the Acquire submenu. If this occurs,
set Image Vue preferences before opening or acquiring a file.

Click to jump to a topic.

Using Open

Using an Acquire Plug-in Module



6

Using Open

When you open a file in Image Vue, it appears in the Image Vue window. The title
bar shows the image filename, file type (e.g., IVUE), and the magnification level of
the image (e.g., 50%).

To open a TIFF, PhotoCD, or IVUE file:

1 Choose Open from the File menu.

The Open dialog box appears. If you select an IVUE or PhotoCD file, you see a
preview of the file in the Preview area, and you see file information (file size,
dimensions, and resolution). If the image file includes an alpha channel, it appears
in red in the Preview area.

 Note The Open dialog box does not preview TIFF files.

2 Navigate to the drive and folder where the file is located.

3 Click once to select the name of the image file to open (or double-click the
filename to open it using default options.

Image Vue automatically displays the selected file’s format in the Format area of the
dialog box. If the format is “Unknown,” you must choose a supported format from
the Format pop-up menu to be able to open the file.
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4 If the image file includes an alpha channel and you don’t want to use it, click Use
Alpha Channel to deselect this option.

5 If your selected file format supports CMYK (such as TIFF), the Adapt Separation
Table option becomes available. If you plan to output in CMYK, click Adapt
Separation Table.

The Adaptive Separation dialog box appears.

• To create a new table based on the one currently selected in the Files & Folder
preferences, click Create New Separation Table, and then click OK.

• To use an existing RGB to CMYK separation table, click Adapt Separation
Table, select a table from the pop-up menu, and then click OK. (The preset
RGB to CMYK separation table is the one you have set in the Files & Folders
Preferences dialog box.)

If you click Create New Separation Table, Image Vue asks you to provide a name
and destination for the new table.

6 Click Open.

If the image is a CMYK file, Image Vue converts it to RGB using the separation
table specified in step 6 before opening it.
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An X-point appears in the center of the image, and a positioning box with eight
selection handles surrounds the image. The control bar indicates the image’s size,
scale, resolution, and color model. The Scale tool is automatically selected in the
toolbar.

If you are opening a CMYK file and Image Vue cannot locate the CMYK To RGB
separation table, a message prompts you to check your preferences. If this occurs,
click OK in response to the message, click Continue, and then follow the procedure
for setting Image Vue preferences.
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Using an Acquire Plug-in Module

To import a file, choose a plug-in module from the Acquire submenu in the File
menu. For a plug-in module to appear in the Acquire submenu (or the Export
submenu), it must be located in the Plug-in folder specified in the Files & Folders
Preferences dialog box. Image Vue ships with these Acquire modules for importing
files:

• LP EPS-DCS

• LP Scitex CT

• LP Photoshop 3.0

The Acquire submenu also lets you access most Photoshop-compatible Acquire
plug-ins.

Note When you import a file into Image Vue using a plug-in module,
you acquire the file. Acquire is a standard image-editing term
that is often used instead of the term import.
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To acquire a file to IVUE format:

1 Choose Acquire from the File menu, and then choose a plug-in module from the
submenu.

A dialog box appears. Each plug-in module has its own dialog box.

2 In the dialog box, select the file to convert, and click Open.

The Target IVUE dialog box appears.

3 Type a name for the target IVUE file.

4 To compress the file, click Use Compression.

The Compression Settings dialog box appears.

5 Select compression options, and then click OK to return to the Target IVUE dialog
box.

• Choose a compression type from the top pop-up menu.

• Choose a compression color option from the bottom pop-up menu.

• In the Quality area of the dialog box, click and drag the slider to select a
compression quality.

6 If the file contains an alpha channel and you want to use it, click Include Alpha
Channel.
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7 If it is a CMYK file and you plan to output in CMYK, click Adapt Separation Table,
choose an option in the Adaptive Separation dialog box, and then click OK.

8 To open the file in Image Vue as an IVUE file using selected options, click Save.
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S e t t i n g  I m a g e  C h a r a c t e r i s t i c s

You can view and set characteristics of an image using the Image Vue control bar.
As you make changes in the control bar, the Image Vue window reflects your
changes.

You can set the following image characteristics in Image Vue:

Use this option To do this

Size View or change the image’s width and height (in
centimeters, inches, millimeters, or pixels).

Scale View or change the image’s scale percentage
(by width, height, or both).

Resolution View or change the image’s resolution (in Dots
Per Inch or Points Per Millimeter).

Model View or change the image’s color model
(Grayscale, RGB Color, or CMYK Color).
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You can move between control bar fields by pressing Tab. While you are editing
control bar fields, standard Macintosh editing commands (Undo, Cut, Copy, Paste,
Clear, and Select All) are available in the Edit menu.

Click to jump to a topic.

Setting Image Size

Setting Scale Percentage

Setting Resolution

Setting Color Model
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Setting Image Size

When an image opens in Image Vue, the Size area of the control bar indicates the
image’s width and height. You can change an image’s size by specifying a new
width, height, or both in the control bar.

You can also change the unit of measure that applies to the size dimensions. The
unit of measure setting also affects the horizontal and vertical rulers.

If the Scale, Zoom, or Pan tool is selected in the toolbar, changing size scales the
image accordingly. If the Crop tool is selected, changing size crops the image.

Note You can also resize an image in the Image Vue window by
selecting the Scale or Crop tool and then clicking and dragging
one of the selection handles surrounding the image.
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To set an image’s size:

1 In the control bar, click in the Size Width or Height field to select it.

2 Type a new value.

3 Press Return to accept the new size value.

The image changes to reflect the new size. If your changes affect other
characteristics (such as scale percentages), those values update in the control bar.

To change the unit of measure:

• Click the Size toggle, and choose the unit of measure you want from the pop-up
menu.

The Size values translate to the new unit of measure. If the rulers are visible, you
see their increments adjust to the new unit of measure.
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Setting Scale Percentage

When an image opens in Image Vue, the Scale area of the control bar indicates
100% for both the image’s horizontal (X) and vertical (Y) scale percentage. You
can scale the image by specifying a new X percentage, Y percentage, or both in the
control bar.

You can also scale an image by using the Scale tool in the toolbar.

To set an image’s scale percentage:

1 In the control bar, click the Scale X or Y field to select it.

2 Type a new value.

3 Press Return to accept the new size value.

The image scales according to your changes. If your changes affect other
characteristics (such as size dimensions), those values update in the control bar.
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Setting Resolution

The Resolution area of the control bar indicates the initial image resolution. You can
change the resolution to use for output. You can also change the unit of measure
used for resolution.

To specify output resolution:

1 In the control bar, click the Resolution field to select it.

2 Type a new resolution value.

3 Press Return to accept your changes.

To change the resolution unit of measure:

• Click the Resolution toggle, and choose the unit of measure you want from the
pop-up menu.

When you change the resolution, the scale percentage and zoom factor adjust
accordingly.
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Setting Color Model

The Model area of the control bar indicates the current color model in effect for the
image. If the image’s color model is CMYK or Grayscale, you can change it to
RGB for output. However, you cannot change RGB to CMYK or Grayscale for
output.

To change the color model:

• Click the Model toggle, and choose the color model you want from the pop-up
menu.
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U s i n g  t h e  T o o l b a r

You use the tools in the Image Vue toolbar to manipulate images. As you make
changes to the image with the tools, related information in the control bar updates.

Use this tool To do this
Scale Resize the image by changing its dimensions, 

and reposition the image on the page.

Crop Cut away rectangular parts of the image, and 
move the cropping rectangle.

Zoom Magnify or reduce the image’s view in the 
window.

Pan Move around within the Image Vue window.

Horizontal Flip Flip the image from right to left, left to right 
(along its horizontal axis).

Vertical Flip Flip the image from top to bottom, bottom to 
top (along its vertical axis).

Rotate Rotate the image in 90-degree increments.
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Click to jump to a topic.

Scaling and Repositioning

Cropping

Zooming In and Out

Panning

Flipping

Rotating
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Scaling and Repositioning

When you first open an image, the Scale tool is automatically selected. You can use
the Scale tool to resize the image and to reposition the image within the window.

Scaling the Image

You use the Scale tool to change the dimensions of an object. You can scale
proportionally (both horizontally and vertically), vertically only (up and down), or
horizontally only (side to side).

You can also use the Scale area of the control bar to scale an image.

To scale in proportion:

1 Select the Scale tool  in the toolbar.

2 Click a corner handle on the positioning box, and drag it to the desired position.

Or press Shift as you click and drag a side handle.

3 Release to finish.

As you scale with the Scale tool, the Scale fields in the control bar update.
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To scale horizontally or vertically:

1 With the Scale tool selected, use one of these methods:

• To scale horizontally, click and drag the handle in the middle of the right or left
side of the positioning box.

• To scale vertically, click and drag the handle in the middle of the top or bottom
side of the positioning box.

2 Release to finish.
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Moving the Image

You move the image by moving the positioning box in the window. You can also
use the arrow keys to nudge the image one screen pixel at a time.

Tip For more precise positioning, turn on the vertical and horizontal
rulers by choosing Show Rulers from the View menu.

To manually move an image:

1 Select the Scale tool .

2 Position the crosshair cursor  inside the positioning box (but not on a handle).

3 Click and drag the positioning box to the new position in the window.

4 Release to finish.
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To constrain movement along the horizontal, vertical, or diagonal
axes:

• Press Shift as you click and drag.

To move an image by nudging:

• With the Scale tool selected, press the Left Arrow, Right Arrow, Up Arrow, or Down
Arrow to nudge the positioning box left, right, up, or down, respectively.
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Cropping

You use the Crop tool to cut away rectangular parts of an image. You can also use
the Size fields in the control bar to crop the object to a specific size.

You can crop proportionally to maintain the object’s relative width and height. Or,
you can crop vertically (up and down) or horizontally (side to side). You can also
move the positioning box to specify a new part of the image to crop. When you do
so, you move the cropping rectangle, which defines the area of the image to crop.

To crop proportionally:

1 Select the Crop tool .

2 Press Shift as you click and drag a corner handle of the positioning box to the
desired size.

3 Release to finish.

As you crop, the Size fields in the control bar update.
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To crop horizontally or vertically:

1 With the Crop tool selected, use one of these methods:

• To crop horizontally, click and drag the handle in the middle of the right or left
side of the positioning box.

• To crop vertically, click and drag the handle in the middle of the top or bottom
side of the positioning box.

2 Release to finish.

To move the cropping rectangle:

• With the Crop tool selected, click the crosshair cursor  inside the positioning
box, and drag to reveal another part of the image.

You cannot move the cropping rectangle beyond the borders of the image.
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Zooming In and Out

You can enlarge (zoom in on) or reduce (zoom out of) the view of an image with
the Zoom tool. When you enlarge the view, the Zoom tool cursor shows a plus sign
( ); when you reduce the view, the cursor shows a minus sign ( ).

You can also zoom the image view by a predefined ratio by choosing a Zoom
Factor (1:1, 1:2, or 1:4) from the View menu.

Zoom factor Image view size

1:1 100% (original view)

1:2 50% of original view

1:4 25% of original view
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To zoom in:

1 Select the Zoom tool .

2 Click on the area of the image you want to enlarge.

To zoom out:

• With the Zoom tool selected, Option-click in the image.

To zoom by a predefined ratio:

• Choose Zoom Factor from the View menu, and then choose a zoom ratio (1:1, 1:2,
or 1:4). Or, press Command-1 to restore the image to 100% magnification.

You can define an area to enlarge or reduce by clicking the Zoom tool in the image
and dragging a marquee around your selection.

Tip If another tool is selected, you can quickly switch to the Zoom
tool by pressing Command-Space bar. To switch to zoom out
(reduce), press Option-Command-Space bar.
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Panning

You use the Pan tool to pan around in the window and see different parts of the
image.

To use the Pan tool:

1 Select the Pan tool .

The cursor becomes a hand .

2 With the hand, click and drag to move your image around.

Tip If another tool is selected, you can quickly switch to the Pan tool
by pressing the Space bar.
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Flipping

You can flip an image along its horizontal or vertical axis. Flipping occurs relative
to the image’s original X-point position. For example, if you open an image, rotate
it 90° and then flip it vertically, the image actually flips horizontally.

To flip an image horizontally:

• Click the Horizontal Flip tool .

To flip an image vertically:

• Click the Vertical Flip tool .
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Rotating

You can rotate an image in 90° increments. Rotation occurs clockwise relative to the
position of the X-point.

Note You cannot rotate an image when the Crop tool is selected.

To rotate an image:

• Click the Rotate tool .

To rotate an image counter-clockwise:

• Press Option as you click the Rotate tool.
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S e t t i n g  I m a g e  V u e  P r e f e r e n c e s

You set preferences for locating and saving special files and folders used by Image
Vue. These are called Files & Folders preferences.

To set preferences in Image Vue:

1 Choose Preferences from the Edit menu, and then choose Files & Folders from
the submenu.

2 In the Files & Folders Preferences dialog box, click a preference option.

This preference Applies to this

CMYK To RGB Color table used to convert a CMYK file to an
IVUE file

RGB To CMYK Color table used to build an output file in CMYK

Plug-ins Folder where Image Vue looks for acquire and
export plug-in modules when you choose an
Acquire or Export submenu item, or for format
plug-ins when you choose Open or Save

Scratch Disk Folder where Image Vue creates and stores
temporary files
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3 In the dialog box, select a file or folder to use.

4 Click OK to save your preferences in the Preferences file.

For your preference changes to take effect, you must quit and restart Image Vue.
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S a v i n g  a n d  C l o s i n g  F i l e s

After you are finished working with a file in Image Vue, you can save it or close it
without saving changes by choosing one of these commands from the File menu:

Choose To do this

Save Save the file in the same format with the same
name.

Save As Save the file under a new name in a different
format (IVUE or TIFF), and specify compression,
alpha channel, and adaptive separation options.

Close Close the file without saving changes.

Export Export the file to a special format.

Click to jump to a topic.

Using Save or Save As

Closing Files

Using an Export Plug-in Module
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Using Save or Save As

You can save files as TIFF or IVUE by choosing Save or Save As from the File
menu. You can also save to a format plug-in by selecting the format in the Save As
dialog box. To save in a different format, use an Export plug-in module.

Note When you save a PhotoCD file, Image Vue saves it in IVUE
format.

To save an open file in the same format with the same name:

• Choose Save from the File menu, or press Command-S.

To save the file under a new name in a different format:

1 Choose Save As from the File menu.

The Save As dialog box appears.

2 In the Save As dialog box, choose a file format (TIFF, IVUE, or plug-in format) from
the Format pop-up menu.
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When you choose IVUE from the Format pop-up menu, the Use Compression
option becomes available. The Include Alpha Channel option becomes available
when an alpha channel is present in the file.

The Include Alpha Channel and Use Compression options are mutually exclusive.
That is, you cannot use compression if Include Alpha Channel is selected, and vice
versa.

3 In the dialog box, type a name for the file.

4 To compress an IVUE file, click Use Compression, select compression options in
the Compression Settings dialog box, and then click OK to return to the Save As
dialog box.

5 If the file contains an alpha channel and you want to save it, click Include Alpha
Channel.

6 Navigate to the drive and folder where you want to save the file.

7 Click Save.
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Closing Files

You can close files with or without saving changes you’ve made since opening the
file.

To close an open file:

1 Choose Close from the File menu.

Image Vue asks if you want to save or discard your most recent changes.

2 In response to the message, do one of the following:

• To save changes and close the file, click Save.

• To discard changes and close the file, click Don’t Save.

• To cancel the Close command, click Cancel.
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Using an Export Plug-in Module

When you choose Export from the File menu, you see the Export submenu, which
you use to access export plug-ins. The export plug-ins let you convert IVUE or
TIFF files to the following formats:

• Photoshop 3.0

• EPS/DCS

• Scitex CT

The Export command also allows you to access most Adobe Photoshop-compatible
export plug-ins. All of the export plug-in modules available to you appear in the
Export submenu. To make an export plug-in module available, copy it into the
Plug-in folder identified in the Files & Folders preferences.



39

If you want to change the color model for output, you can do so before exporting
the file.

To export an IVUE or TIFF into another file format:

1 With the IVUE or TIFF file open in the Image Vue window, choose Export from the
File menu, and then choose a plug-in module.

A dialog box appears. Different formats may have different dialog boxes.

2 Type a filename, select a destination, and click Save.
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Exporting in CMYK

If you are exporting to CMYK and Image Vue cannot locate the RGB To CMYK
separation table, a message prompts you to check your preferences. If this occurs,
click OK in response to the message, click Continue, and then follow the procedure
for setting Image Vue preferences.

If you are using the separation table for the first time, a progress bar appears while
the separation table is being expanded. Once expanded, a second progress bar
shows the file being saved in the format selected.

Scitex CT files are always saved in CMYK mode.
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Exporting to EPS/DCS

If you export to EPS/DCS with RGB Color selected, a dialog box gives you the
choice between creating an ASCII file or a binary file. Binary files are much
smaller. However, certain page layout applications do not support binary EPS files.
In this case, select ASCII.

If you are exporting to EPS/DCS with CMYK Color selected, you see a dialog box
where you can save the document as five separate EPS files.

This format is called DCS (Desktop Color Separation). You use it to create color
separations in a format that can be read by applications such as QuarkXPress. Each
color separation (C, M, Y, and K) is contained in a separate, high-resolution file.
The fifth file, called the Master file, is a low-resolution preview of the complete
image. It contains information linking it to the four color separations. When the
document prints from the page layout program, the master file is replaced with the
four color separations.
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In the dialog box, click Off to save the image as a single EPS file, or select one of
the Master File options to save the image as a DCS file.

This Master File option Does this

No composite PostScript Generates a master file that only contains
the PostScript information linking it to the
four color separations

72 pixels/inch grayscale Results in master files containing a black
and white image, plus the PostScript
information

72 pixels/inch CMYK Results in master files containing a color
image, plus the PostScript information
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Q u i t t i n g  I m a g e  V u e

Quitting Image Vue automatically closes any open files.

To quit Image Vue:

1 Choose Quit from the File menu.

A dialog box prompts you to save any changes for each opened and modified file.

2 In response to the message, do one of the following:

• To save changes and quit, click Save.

• To discard changes and quit, click Don’t Save.

• To cancel the Quit command, click Cancel.
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