1999 Scientific Assembly

Syllabi on CD-ROM

Welcome to the 1999 Scientific Assembly Syllabi on CD-ROM. The CD-ROM includes course syllabi
from the educational courses offered at the American College of Emergency Physicians' Scientific
Assembly held in Las Vegas, Nevada, October 11-14, 1999. The syllabi have been converted to Adobel]
Portable Document Format (PDF). Using Adobe’ s Acrobat Reader, you can search, view, or print the
course syllabi from Windows[ and Macintosh[] computers.

System requirements
In addition to a CD-ROM drive, your computer
should meet the following requirements:

Windows

e i486™ or Pentium® processor-based
personal computer

e Microsoft® Windows® 95, Windows 98, or
Windows NT® 4.0 with Service Pack 3 or
later

e 10 MB of available RAM on Windows 95
and Windows 98 (16 MB recommended)

e 16 MB of available RAM on Windows NT
(24 MB recommended)

e 10 MB of available hard-disk space

Macintosh
e Apple Power Macintosh or compatible
computer

* Mac OS software version 7.1.2 or later

* 45MB of available RAM (6.5 MB
recommended)

e 8 MB of available hard-disk space

Optional for Web links
*  Microsoft Internet Explorer or Netscape
Navigator

License agreement

By using this software, you agree to the license
agreement located on this CD-ROM
(license.pdf). If you do not agree to the terms
and conditions contained therein, promptly
return the software and accompanying materials
to ACEP.

Syllabi not available on CD-ROM

A few syllabi are not available on the CD-ROM
because the speaker did not submit his or her
syllabus or because of copyright issues. A list of
those courses not included on this CD-ROM has
been included in the filereadme.txt. In
addition, every course that was offered during
the 1999 Scientific Assembly islisted within the
course listing of each topic. Those courses that
are not available appear in red text. All others
are displayed in green text.

Navigating the CD-ROM

The 1999 Scientific Assembly Syllabi on CD-
ROM main menu provides access to all the
information contained on the CD-ROM. Menu
items have been hyperlinked to provide easy
navigation among the more than 4,000 syllabi
pages. Notice that the cursor (displayed asan
open hand) will change to a pointed hand when
it ismoved over text or an image that contains a
link. When the pointed hand appears, click one
time to jump to the document to which the link
refers.

Bookmarks are predefined links to other
documents or pages within a single document.
Bookmarks for each document are listed in the
Navigation Pane to the left of the document.



Using the Acrobat Reader

Acrobat Reader is designed to be easy to use.
However, it is powerful software and includes
many advanced features. For detailed
ingtructions, using the Acrobat Reader, click
Help, at the top of the screen and select Acrobat
Guide. To obtain help on using Acrobat Search,
click Help at the top of the screen and select
About Plug-ins. Then choose Acrobat Search.

These links are also available from the Help
Using Adobe Acrobat link on the main menu of
the 1999 Scientific Assembly Syllabi on CD-
ROM.

Acrobat Search

The Acrobat Reader software that isincluded on
the CD-ROM includes Acrobat Search. This
allows you to search dl of the syllabi to find
particular words or phrases. To search only
within the current syllabus, you should use the
Find feature (the toolbar button with the
binoculars). To start the Acrobat Search engine,
click the Search button (the button with the
binoculars and the page) or select Edit, then
choose Search, then click Search Query. For
detailed information on how to use the Search
feature of Adobe Acrobat, refer to the Acrobat
Search Guide accessed viathe Help menu.

Note: If Acrobat Search notifies you that the
index is unavailable, select the Indexes button
on the Acrobat Search dialog box, and then Add
the “ 1999 SA Syllabi Index.”

Technical support

Using the CD-ROM

Once Acrobat Reader has been installed on your
computer, you can access any of the PDF files
stored on the CD-ROM.

The easiest way to view the syllabi isthe insert
the 1999 Scientific Assembly Syllabi on CD-
ROM into your CD-ROM drive. A menu should
appear within one minute. Click Continue and
then choose View Syllabi. Acrobat Reader will
then be started and you will soon see the 1999
Scientific Assembly Syllabi on CD-ROM Main
Menu. The main menu gives you accessto al of
the resources |ocated on the CD-ROM.

To locate a specific course, click on Course
Syllabi from the Main Menu. All of the topic
areas that were offered at the 1999 Scientific
Assembly are listed in aphabetical order. Click
on the desired topic. Y ou will then see alist of
all courses offered for that topic. Click on the
desired course to view the syllabus for that
course.

To return to the Main Menu or Topics Menu,
click on the desired link in the bookmarks on the
|eft side of the screen.

Note: Courses listed in red text indicate that the
syllabus for that course is unavailable on this
CD-ROM. Coursesin green text are available,
and the syllabus may be viewed by clicking on
that course.

Technical support for the 1999 Scientific Assembly Syllabi on CD-ROM is available from the American
College of Emergency Physicians. Questions or problems with the Acrobat Reader should be directed to

Adobe Systems Incorporated at 800-833-6687.

E-mail

techproducts@acep.org
Website

http://www.acep.org
Telephone

800-798-1822, ext. 3125

972-550-0911, ext. 3125



Tutorial: Using Acrobat Search

You can use the Acrobat Search feature to quickly
locate information in any of the syllabi. A full-text index
has been provided with all the words used in the syllabi,
and for each word, a list of the documents and pages
that contain the word.

Start Acrobat Search

Click either the Search Query button or choose
Search > Query from the Tools menu. The Acrobat

Search dialog box appears.

i Adobe Acrobat Search
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Search for a single word

In this example, you will search for information about
paramedics.

1. Clear all search options at the bottom of the
Acrobat Search dialog box.

2. Enter paramedics in the text box and click
Search.

The Search Results dialog box appears listing all
the syllabi that contain the word paramedics.

i Search Results E3

Title Found 23 out of 214 documents.
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o Trauma Case Panel
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o Aeromedical Transport,  Cost-Effective Utilization ;|
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The message at the top of the dialog box indicates
how many syllabi contained the word paramedics. To

the left of the document titles are icons indicating rel-
evance, as described in the next section, “Interpret the
search results.”

Interpret the search results

The Acrobat Search software ranks the relevance of
every document returned by a search, indicating the like-
lihood that the document contains information for which
you are searching.

The Acrobat Search software use five icons to rank
adocument's relevance:

Iil A full circle indicates very high relevance; the document
very likely contains relevant information.

EI A three-quarter circle indicates high relevance; the docu-
ment likely contains relevant infromation.

@ A half-circle indicates medium relevance; the document
probably contains relevant information.

@ A quarter-circle indicates low relevance; the document
may contain relevant information.

@ An empty circle indicates very low relevance; the docu-
ment probably does not contain relevant information.

The relevance icons may or may not be very helpful.
The Acrobat Search assigns relevance values accord-
ing to fixed rules. With a single word search, for ex-
ample, the frequency of a word in a document, calcu-
lated as a percentage of all the words in the document,
determines relevance.

View the search results

Now you will display the syllabus containg the first
match. In the Search Results dialog box, select Ethi-
cal Dilemmas in Emergency Medicine  and click View
(or double-click the document title). The first page in
this syllabus containing the word paramedics appears,
with the word highlighted.

You can use the Search Next and Search Previous
buttons in the toolbar to display all pages containing
search terms, as follows:

Search Next, by default, displays the next page
that contains a search term. When the last occurrence
of a search term in a document is displayed, Search
Next displays the first occurrence in the next document.
Search Next displays documents in the order they are
listed in the Search Results dialog box.



Search Previous, by default, displays the previous
page in the current document that contains a search
term. If there are no more occurrences in the current
document, the last occurrence of a search term in the
previous document is displayed. Search Previous dis-
plays documents in the reverse of the order in which
they appear in the Search Results dialog box.

REFINE THE SEARCH

Often a search for a single word finds too many
pages, and the information on the found pages is not
relevant. When the search finds too many pages, you
can refine the search to find fewer relevant pages by
searching for more words.

1. Click either the Search Query button or choose
Search > Query from the Tools menu. The Acrobat

Search dialog box appears.

2. Replace the current search term with the phrase
expanded scope .

3. Click Search. The Search Results dialog box ap-
pears showing two documents, Working with Volunteers
and EMS in 2001: Expansion or Contraction.

Use “or” to expand the results of a search

Often when searching you will find an alternative word or
phrase that is used to describe the topic in which you
are interested. When you find such words and phrases,
you can use “or” to expand your search to also find pages
with these alternative words and phrases.

@l 1. Click either the Search Query button or choose
Search > Query from the Tools menu. The Acrobat

Search dialog box appears.

2. Add the words paramedics to the current search
phrase expanded scope. This query finds all the pages
that contain either the phrase paramedics or expanded
scope.

3. Click Search. The Search Results dialog box ap-
pears showing 23 documents with either search phrase.

Use “and” to expand the results of a search

When a phrase search fails, you can use an “and”
search to look for two or more words in the phrase.

1. Click either the Search Query button or choose
Search > Query from the Tools menu. The Acrobat

Search dialog box appears.

2. Type the words paramedics and expanded scope
This query finds all the pages that contain both the phrase
paramedics and expanded scope. Use the proximity
option to ensure the words are close to each other in the
documents otherwise the two words could be located
anywhere in the document.

3. Click Search. The Search Results dialog box ap-
pears showing 7 documents with both search phrases.

Jumping between documents

You can skip between documents when a document
contains many pages with search terms but the current
document does not seem to be relevant.

* Hold down the Shift key and press the Search
Next button in the toolbar to jump to the next
document.

As you are browsing through a large number of found
pages, you can also retrace your steps.

* Hold down the Shift key and press the Search
Previous button in the toolbar to jump to the
previous document.

Use field values to limit searches

Every PDF document has four document information data
fields: Title, Subject, Author, and Keywords. The 1997
Scientific Assembly Syllabi uses the Title field for the
course title, the Subject field for the topic name, the
Author field for the speaker(s) last name(s), and the Key-
words field for select terms from the course description.

Choose Preferences/Search from the File menu. Inthe
Search Preferences dialog box, select the Show Fields
option. Click OK. This option adds Document Info fields
to the Acrobat Search dialog box.

For more assistance using Acrobat Search

See the Acrobat Search online guide for more infor-
mation on using Acrobat Search (click on the Acrobat
Help Menu bookmark or from the Acrobat Reader menu,
select Help, Plugin Help, and then Using Acrobat
Search).

Note: The examples provided here are from the 1997 Scientific
Assembly CD-ROM so they do not correspond with actual 1998
Scientific Assembly courses.



Acrobat Reader Quick Reference
This is a summary of Acrobat Reader features and commands. See the Acrobat Reader Online Guide for
complete information or visit Adobe’s Acrobatweb site at http://www.adobe.com/prodindex/acrobat/.

Toolbar

Page Only

Bookmarks and Page

Thumbnails and Page

Hand

Zoom In

Select Text

First Page

Previous Page

Next Page

Last Page

Go Back

Go Forward

Actual Size

Fit Page

Fit Width

Find

Search

Search Results

Search Previous

Search Next
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Closes thumbnail and

bookmark area

Displays bookmarks

Displays thumbnails

Scrolls through window

Magnifies page view

Selects Text

Displays first page of

document

Displays previous page

Displays next page

Displays last page of

document

Displays previous page view

Returns from Go Back

Sets page view to 100%

Displays whole page

Scales page to the window
width

Finds text in current
document

Displays Search dialog box

Displays Search results

Previous found item

Next found item

Status Bar

Window splitter

Al Changes width of
overview area

Page number box m Displays page number.

Magnification box

o 121%

Click on to display Go
To Page dialog box

Show current
magnification. Select
to display Zoom menu.

Page size box | B 58=55in Shows size of current

Browsing Shortcuts
TOOL ORKEY
Home

End

Page Down

Page Up
Enter/Return

Shift + Enter/Return
Right/Down arrow
Left/Up arrow

Shift + Arrow Keys

Drag scroll box

page

RESULT

Displays first page of document
Displays last page of document
Moves forward one screenful
Moves back one screenful
Moves forward one screenful*
Moves back one screenful*
Displays next page

Displays previous page

Scroll

Goes to page displayed in pop-
up window

* for users with keyboards without Page Up/Page Down keys
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