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To use this technique, prepare a layered

document in Adobe Photoshop 3.0. If the

document has a higher resolution than you

need, save a copy at the resolution you want

to use in After Effects. This is more efficient

than resampling each frame in After Effects.

2 In the Project window, double-click the
composition to display it. After Effects pre-
serves the opacity, transfer modes, and order
assigned to each layer in Adobe Photoshop.
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Animating Adobe Photoshop layers

One way to create a movie in After Effects is to import a finished Adobe Photoshop 3.0 file.

After Effects maintains the layers, modes, and opacity settings that were assigned in Adobe

Photoshop. You can use After Effects to add motion or modify settings over time.

This tip is optimized for print. You can browse the steps on-screen, or print pages 2–3.

To return to the opening screen, click here.

1 Create a new project in After Effects.
Choose File > Import Footage > Photoshop
3.0 as Comp. Locate and select the Adobe
Photoshop 3.0 file, and click OK. The Project
window lists a folder and a composition with
the same names as the Adobe Photoshop
document. The folder contains the footage
items that correspond to the layers of the
composition.

Note: Sometimes layers in an

Adobe Photoshop document

get clipped to the size of the

canvas. To ensure that layers

remain whole in the Adobe

Photoshop document, make

the canvas size large enough

to display the largest layer.
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4 Move the current-time marker to the
beginning of the composition. Adjust the
property settings for each layer that changes
over time. In this example, we changed the
opacity and positions of the text layers to
make them fade into the frame. We also
changed the positions of the Violin and Notes
layers so that they move into the frame. We
altered the position and rotation properties of
the Horn layer to make it spin into the frame.

5 Preview the composition. The layers move
smoothly into place.

A N I M A T I N G  A D O B E  P H O T O S H O P  L A Y E R S

3 Because the composition is in its finished
state, begin modifying layers by setting
keyframes at the end of the composition.
Move the current-time marker to the end of
the composition and set keyframes for the
layers that you want to move or change over
time. Do not change the properties for these
keyframes.
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2 Open the Layer window for the top layer

and create a mask to isolate one of the

elements in the image. To modify the mask

over time, set a keyframe for the Mask

property at the beginning of the composition.

In this example, we created a mask that

loosely outlines the giraffe.

Filtering part of a layer

You can apply an effect to a portion of layer by duplicating the layer, creating a mask, and

applying an effect to one of the layers.The mask isolates the area that you want to modify. This tip

shows you how use a mask to apply an effect to part of a video and how to animate the mask over

time. For more information, see “Working with a Mask” on page 199 of the Adobe After Effects

User Guide.

This tip is optimized for print. You can browse the steps on-screen, or print pages 4–5. To return

to the opening screen, click here.

1 Create a composition with the video layer.

Select the layer in the Composition window

and choose Edit > Duplicate (Command+D).

To use this technique, you need a video clip.

You can also use a still image and change the

effect over time.
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3 Apply an effect to one of the layers. In this

example, we selected the bottom layer and

applied the Gallery Effects Graphic Pen filter.

We set the foreground color to gray.

4 Advance the movie one frame

(Command+Right Arrow) and adjust the

mask to fit the element. In this example, we

also changed the opacity of the mask layer at

the end of the composition to make the

giraffe gradually blend with the effect.

F I L T E R I N G  P A R T  O F  A  L A Y E R

Note: You can also advance the

movie several frames and then

adjust the mask; After Effects

will interpolate the mask shape

for the other frames. For best

results when skipping frames,

maintain the same number of

points for the mask from

beginning to end.

5 Preview the composition. In this example,

the effect is applied to the background layer,

and the mask isolates the giraffe as it crosses

the frame.

 Note: Step 3 can also be done

before step 2.
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To use this technique, you need display type,

which you can create using Adobe Illustrator

or Adobe Photoshop. In this example, we

created the type in Adobe Illustrator, kerned

it, and converted the characters to paths to

preserve the typographical changes. We

created the optional background in Adobe

Texture Maker.

2 Choose Layer > New Solid (Command+Y)

to create a solid. The height of the solid must

be larger than the tallest character (including

ascender and descender), and the color must

be lighter than the text. In this example, we

created a gray solid that is 70-by-220 pixels.

This solid is the highlight layer.

Making text gleam

In After Effects, you can use a duplicate of a layer to create a matte with a complex shape. In this

tip, you’ll use this technique to create a highlight that moves across the type, but not the back-

ground.

This tip is optimized for print. You can browse the steps on-screen, or print pages 6–8. To return

to the opening screen, click here.

Note: You can skip steps 2 and 3

if you create the highlight layer in

Adobe Photoshop.

1 Import the text and the background items

into After Effects and use them to create a

new composition.
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M A K I N G  T E X T  G L E A M

3 Choose Layer > Mask > Mask Feather

(Command+Shift+F) and feather the mask of

the solid horizontally. In this example, the

mask is feathered by 30 pixels. Open the

highlight's Layer window. Move the left and

right sides of the mask toward the center until

the highlight layer is a solid line of color in the

middle and the sides gradually fade and

become transparent. Close the Layer window.

4 Choose Transfer Controls from the pop-up

menu at the bottom of the Time Layout

window to display the Transfer Controls

panel. Select the highlight layer and choose

Add from the Mode pop-up menu.

5 Rotate and animate the highlight layer. In

this example, we rotated the highlight layer 19

degrees. Then we created keyframes and

positioned the layer so it moves back and

forth across the text.

Note: The width of the feathered

area straddles the mask edge, half

inside and half outside the edge.

For a softer edge, the mask should

be smaller than the layer area.

6 Select the text layer and choose Edit >

Duplicate (Command + D). Move the copy

of the text layer so that it’s the first layer in the

composition.
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 M A K I N G  T E X T  G L E A M

7 Select the highlight layer in the Time

Layout window. Choose Layer > Mode >

Alpha Matte.

8 Preview the composition. The highlight

layer moves back and forth within the text,

but not outside the text.

Vary the highlight

9 For a slightly different effect, move the

bottom text layer to the top of the layer stack.

Then offset the top layer by several pixels. In

this example, we moved the text layer to the

right by 2 pixels and down 2 pixels.

10 Preview the composition. The subtle

highlight follows the edge of the text.
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To use this technique, you need two footage

items. One item must be surrounded by

transparent areas, like the skyscraper in this

example. The other item must fit completely

within the transparent area of the first item.

In this example, the comet fits completely

into the area surrounding the tower of the

skyscraper. In this example, we also used a

background to create the Sky layer.

1 Import the footage items into After Effects

and use them to create a new composition.

Make sure the layer that will move is on top.

In this example, the Comet layer is on top of

the Sky layer.

2 Animate the orbiting layer, and modify all

the properties of the moving layer that you

want to change. Preview the motion and

adjust the motion path if necessary. In this

example, we created a Bezier motion path so

that the Comet layer enters the frame from

the left, orbits the Skyscraper, and exits the

frame at the right. We also selected the Comet

layer and chose Layer > Geometrics > Auto-

Orient Rotation so the Comet layer rotates to

follow the motion path.

A D O B E  A F T E R  E F F E C T S  3 . 0

Putting a layer into orbit

Splitting layers is a useful technique for making one layer appear to orbit another one. When you

split a layer, both resulting layers contain all the properties and keyframes that of the original

layer. This lets you change the stacking order of the layers without altering the properties of the

moving layers.

This tip is optimized for print. You can browse the steps on-screen, or print pages 9–11. To

return to the opening screen, click here.
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3 Move the current-time marker to the point

in the composition where the orbiting layer

changes its relationship to the static layer. In

this example, we moved the current-time

marker to the point where the comet appears

on the right side of the skyscraper. This is the

point where the Comet layer will move from

behind the Skyscraper layer to in front of it.

4 With the orbiting layer still selected, choose

Edit > Split Layer (Command+ Shift+D) to

split the layer. A copy of the orbiting layer

appears in the Time Layout window. The out

point of the original layer and the in point of

the new layer are both at the current time.

Each layer contains the keyframes for the

duration of the layer. Rename the new layer

so you can identify the copy. In this example,

we named the new layer Comet Front.

5 Select the new layer and move the current-

time marker to the next point in the composi-

tion where the orbiting layer changes its

relationship to the static layer. In this

example, we moved the current-time marker

to the point where the comet is on the left side

of the skyscraper. This is the point where the

Comet layer moves behind the Skyscraper

layer.

P U T T I N G  A  L A Y E R  I N T O  O R B I T
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6 Choose Edit > Split Layer (Command+

Shift+D) to split the layer. Rename the new

layer so you can identify the copy. In this

example, we named the new layer Comet

Back.

7 Reorder the layers so that the animation is

accurate. In this example, we moved the

Comet and Comet Back layers behind the

Skyscraper layer.

P U T T I N G  A  L A Y E R  I N T O  O R B I T

8 Preview the composition. The moving layer

now moves around the static layer. In this

example, the comet orbits the skyscraper.
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To use these techniques, you need display

type, a video clip or still image, and a

background layer. You can create the display

type using Adobe Illustrator or Adobe

Photoshop. In this example, we created the

type in Adobe Illustrator, kerned it, and

converted the characters to paths to preserve

the typographical changes. We created the

background in Adobe Texture Maker.

Create a matte that travels over a still image

1 Create a composition with the text and still

image layers on top of the background layer.

2 Animate the text layer. In this example, the

text traverses the frame from right to left.

Using type as a traveling matte

In After Effects you can use a complex shape, such as text, as a track matte. A track matte is a layer

whose luminance or alpha channel is used to manipulate the alpha channel of another layer. For

more information about track mattes, see “Creating Layer Transparency Using  Track Matte” on

page 210 of the Adobe After Effects User Guide. This lesson demonstrates how to create two types

of traveling mattes: one that moves over a still image and one that moves with a video clip.

This tip is optimized for print. You can browse the steps on-screen, or print pages 12–15.

To return to the opening screen, click here.

A D O B E  A F T E R  E F F E C T S  3 . 0
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U S I N G  T Y P E  A S  A  T R A V E L I N G  M A T T E

3 Choose Transfer Controls from the pop-up

menu at the bottom of the Time Layout

window to display the Transfer Controls

panel.

4 Select the still image layer and choose

Alpha Matte from the TrkMat pop-up menu

for the layer.

5 Preview the composition. The still image

shows through the text as the text moves

across the composition.
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The layers required for the following steps are

the same as for the previous steps. In this

example, we used different text and a video

clip to emphasize the techniques’ different

results.

Create a matte that travels with video

1 Create a composition with the type and

video layers on top of the background layer.

Choose Transfer Controls from the pop-up

menu at the bottom of the Time Layout

window to display the Transfer Controls

panel.

2 Select the video layer, and choose Alpha

Matte from the TrkMat pop-up menu for the

layer. The video layer shows through the text.

3 Select the type and video layers, and choose

Layer > Precompose (Command+Shift+C).

After Effects creates a composition from these

layers, and uses the precomposed composi-

tion as a layer.

U S I N G  T Y P E  A S  A  T R A V E L I N G  M A T T E
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4 Animate the Precomp 1 layer. In this

example, the composition traverses the frame

from right to left.

U S I N G  T Y P E  A S  A  T R A V E L I N G  M A T T E

5 Preview the composition. The video shows

through the type as they traverse the screen

together.


