
creates a new HTML-coded page complete
with header, footer and table. This can be
opened in Microsoft Explorer or your other
favourite browser. 

Excel 97 also makes it easy to add an
Excel form to your web site which can be
used for collecting information for a
database. This might be for taking orders
from users, or requests for information, or
just recording comments. You first create
the form in Excel with cells where users will
enter their data. Then choose Tools,
Wizard, Web Form to open the Web Form
Wizard which asks you to select those cells
on your worksheet that you wish to have

Fig 1 (right) It is easy to save

a range of your worksheet as

an HTML-coded web page,

automatically, using the

Internet Asst. Wizard

Fig 2 (below) The Excel 97

Web Connectivity Kit

includes a template for

converting downloaded data

into charts
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worksheet which is specially
designed to accept data from a
particular web page is called a

Web Query. To run one, you choose Data,
Get External Data, Run Web Query, then
select the particular Query you wish to run
from the Run Query dialog box. Excel 97
includes four of them, as I mentioned last
month, but one of these is “Get More Web
Queries”. At present, if you run that when
connected to its source, you can download
an active sheet with 36
more Queries.

If you have your own
web page, it’s easy to add
a range of a worksheets: 
1. Open the page with your
usual browser. 
2. Choose View, Source,
so you can see the HTML
code. 
3. Where you want the new
worksheet data to appear,
insert a blank line and then 
<--##Table##--> 

4. Save this edited file. 
5. Open your worksheet in
Excel and select the range you want to add
to the web page. 
6. Choose File, Save as HTML (Hypertext
Mark-up Language). This starts the Internet
Assistant Wizard (Fig 1) and you follow a few
simple steps. These include browsing to
select the .html file you’ve prepared for
accepting the data. When you’ve finished,
the range will appear on the web page.

You also use this Wizard to prepare a
worksheet as a web page. It works much
better now than when I previewed it last
October. If you just accept all the defaults,
the Wizard selects enough of the first range
of your worksheet to fill a web page, then it

the user fill in, and the labels you wish to
give them. It then automatically produces a
new .xls file and companion .idc, .htx, and
.mdb files. You supply these four files to the
web page administrator and you can open
the new .xls file, which looks like your
original, with a Submit Info button added.
This Wizard works best with Microsoft
Access 97 and Microsoft Explorer 3.

On this month’s cover-mounted CD I’ve
included the complete Excel 97 Web
Connectivity Kit. It’s the definitive guide to
developing sophisticated web sites for
Excel users. It also helps you to create
special pages on Excel worksheets that will
automatically elicit information from
company intranets or specific internet web
sites. You can learn how to pull daily sales,
stock or financial reports from a company
intranet server straight onto a worksheet.
The Excel 97 Web Connectivity Kit includes
an example of converting downloaded data
into charts (Fig 2).

Meanwhile, back in the office…
The hyperlink capability of Excel 97 can also
be used to improve links with files on an
office network, or on your own disks: hard,
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Excel 97 offers a number of ways in which to exchange information between a workbook

and a web page; Stephen Wells explains how. Plus, Excel 97’s hyperlink capabilities.
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control the toolbars, menu bars, and
shortcut menus in a workbook. Not only
can you create and modify custom toolbars,
menu bars and shortcut menus for a tailor-
made Visual Basic application, but you can
also modify any of Excel’s own built-in
toolbars and menu bar. You can present
the features of your application as individual
buttons on toolbars or as groups of
command names on menus. Because
toolbars and menus are both considered to
be command bars, you use the same kind
of controls for both.

Having installed Office 97, you can find
much of the information you need about
these changes in the vbaxl8.hlp file. Some
useful snippets are in the file xlread8.txt.

Office 97 includes an MS Query Add-In
to convert external data ranges which are in
Excel 97 format to Excel 5 for Windows 95
format. This is not so much for making
Excel 97 data available to version 5/95
users, as for allowing Excel 97 users to run
macros created in Excel 5 .

Right on the button
I recently received a fax from Jeff Forrest,
who is working in Paris for a company that
has internal email only. Jeff offers the tip
that if you run out of suitable button designs

for your macros in
Excel, you can borrow
one from Word.

If you have MS
Office 95 or 97, start
Excel and Word. If you
choose View,
Toolbars, Customise,
Commands, All

Commands in Word, you’re offered a wide
choice of button designs, any one of which
can be dragged onto any toolbar
(temporarily). 

Right-click on this button and choose
Copy Button Image. Drag the button off the
toolbar to dispose of it, then switch to
Excel. Whenever the Toolbars Customise
dialog box is open, the same shortcut menu
is available in Excel, so now you can right-
click on the button which starts your macro
and choose Paste Button Image. This new
button will be stored in the Normal.dot
template and will stay on the toolbar until
you wish to remove it.

A case in point
In his correspondence, Jeff also included a
macro for changing the case of selected
text. I entered and checked his module and
it worked fine, but as I had covered that
subject extensively (in my January column), 
I wasn’t going to mention it. 

But then I received an email from Andy
Male: “I read with interest your article on
changing the case of text within Excel. I’m
using Excel 5.0 and have successfully
created a macro button that will change the
case of a single cell. I am trying to amend
the macro so that I can change the case of
a single cell, or a selected range, but
despite hours of effort I have failed. The
macro I’m using for the single cell is:
Sub titlecasecell()

ActiveCell.Value = Application.

P r o p e r ( A c t i v e C e l l )

End Sub”

So all of a sudden, Jeff’s macro became
immediately useful. He had written:
Sub MakeProper()

Dim myCell As Object

For Each myCell In Selection

If Left(myCell.Formula, 1) <> "=" 

T h e n

myCell.Value = Application.Proper

( m y C e l l . V a l u e )

End If

Next myCell

End Sub

I sent this to Andy, who replied: “Thanks
for your help — that cracked the problem. I
guess it’s simple when you know how!” I
hope they both see this so that Andy knows
where the solution came from and Jeff
knows that he did a good deed.

Keyboard conundrum
Roy Small emailed me with an interesting
dilemma. “I have a persistent keyboard
problem with Excel 7.0 and Word 7.0 .
When I type a repeating comma (,,,,,,,) I get
repeating (.....) full stops. It only happens in
these two applications and I have tried
reinstalling twice, but to no avail. In the
Turnpike editor and in Wordpad there is no
problem. My system is an Escom P60 with
16Mb and Win95. Word 5 and Excel 5 did
not have this problem. All the country
settings are correct. 

“I am loathe to delve into the registry
unless I know what I’m looking for. I would
appreciate a pointer in the right direction if
you are aware of this problem.”

I replied: “If you’re getting correct results
with other software, then it can’t be a
keyboard mapping problem. 

“You might check all the AutoCorrect
and AutoText options. If anyone else has
used your PC, they might have changed
something, either consciously or
inadvertently. Also (and this is something
that often frustrates me) languages are set
in every template. You can’t just set English
(British) once. It can turn back to English
(US) or, perhaps in your case, Swedish or
something, in different templates.

“If it’s any comfort, it’s not a bug in Excel
7 or Word 7 as nobody else has had the
problem as far as I know.”

He responded: “Brilliant, Stephen. I can’t
thank you enough. It was indeed the
AutoCorrect setting. I don’t understand why
or how it ever got set that way because only
I use this machine and I have never found
that setting dialog before. Changing the
setting in Word also affects Excel.” 
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or mounted floppy. If you just want a
hyperlink from one Excel worksheet to
another without the use of a formula, the
easiest way is to select the worksheet data
in the destination workbook and then use
the right mouse button to drag the
information to the worksheet cell that
contains the text, button or graphic for the
hyperlink. When you release the right
mouse button, click Create Hyperlink Here
on the shortcut menu (Fig 4). 

It’s also easy to create a hyperlink
between a worksheet and a Word
document or a PowerPoint slide. Say you
have the text, SEE REPORT, in a cell and
the report referred to is a Word document.
Just select the cell and then click the Insert
hyperlink button on the standard Excel 95
toolbar (or press Ctrl+K). This opens a
dialog box where you can browse to find
the Word file. Click OK and that’s all there is
to it. The words SEE REPORT are now an
automatic link which opens the Word file
when you click them. 

As you were
Last month I was saying that Excel 97
allows you to use row and column labels as
references, assuming that you’ve checked
the “Accept labels in formulas” box under
Tools, Options, Calculation.

I mentioned that in the beta version I
tried, this feature easily got confused when
one of my labels was “Current Assets” and
another was “Current”. I also said that if the
column heading was a formula, like =B1-1,
instead of 1995, then I received an error
message even though the sheet displayed

1995. I’ve since
received the final
version (if there ever is a
f i n a l version) and can
report that both of these
minor problems have
been corrected.

VBA changes
The Excel 97 Visual Basic object model has
extensive changes to support new and
improved features in Visual Basic for
Applications in Office 97. Many objects,
properties and methods have been
replaced. To provide backward
compatibility, most of the replaced
components have been hidden rather than
removed. They don’t show up with the
object browser although the existing code
that uses the hidden components still works.
When you write new code you should use
the new objects, properties and methods.

The first thing to get used to is that
macros are not displayed on module sheets
any more although they are still stored with
the workbook. To create or edit a macro
you choose Tools, Macro, Visual Basic
Editor (or press Alt+F11) and three windows
open (Fig 3). Visual Basic now features a
single, consistent editing environment for
Office programs similar to working in
standalone Visual Basic 5.0. Each Excel

workbook has a project associated with it.
There is an improved code editor, a
hierarchical object browser, a multipane
debugger, a Properties Window and a
Project Explorer to help you view and
organise the code and objects in your
p r o j e c t .

If you open a workbook created in earlier
versions of Excel, Excel 97 preserves macro
and dialog sheets and converts module
sheets into modules in the workbook’s
Visual Basic project. 

You can run and edit Excel 4.0 macros
and Excel 5.0 and 7.0 dialog sheets. To
view them, just choose Tools, Macros (or
press Alt+F8). You can even add new
macro or dialog sheets by right-clicking a
sheet tab and then clicking Insert on the
shortcut menu. However, it is
recommended that you create new macros
and dialog boxes in the Visual Basic Editor. 

The three largest areas of change in
Excel 97 Visual Basic are Shapes,
UserForms and Command Bars. 

Shapes are drawing objects. The Shape
Object is for formatting or modifying a single
shape. The Shapes Collection is for
modifying all the Shape objects on a
specified sheet, such as AutoShape,
freeform or OLE objects. The ShapeRange
Collection is for modifying a group of Shape
objects which you specify.

A UserForm Object is a window or dialog
box that makes up part of a custom
application’s user interface. The UserForms
Collection is a collection whose elements
represent each loaded UserForm in an
application. The UserForms collection has a
Count property (which specifies the number
of elements in the collection), an Item
property (to specify a specific collection
member), and an Add method (for placing a
new UserForm element in the collection).

CommandBar Objects in Office 97

282• Personal Computer World • April 1997 

Hands On S p re a d s h e e t s

Stephen Wells welcomes input on all
spreadsheet matters. Write to him at P C W, or
email s p r e a d s h e e t s @ p c w . v n u . c o . u k

Contact

■ The Chart command on the Insert menu
now starts the Chart Wizard. On step four of
the Chart Wizard, you can specify whether the
chart is inserted as an embedded object on a
worksheet or on its own chart sheet. 
■ The Office Assistant has replaced the
TipWizard from versions 5.0 and 95, and
includes Answer Wizard IntelliSense
technology from version 95. When you need
Help, just click the Office Assistant button and
ask the Assistant a question in your own
words. When a yellow light bulb appears in the
Assistant, a program tip is available: click the
light bulb to see the tip.
■ Cell notes are now called comments. Use
the Comment command on the Insert menu 
to create a comment. You can view
comments in the same way that you used to
view notes: by resting the pointer over a cell
that has a comment indicator (this is a red
triangle in version 97) in the upper right-hand

EXCELlent changes in Excel 97
corner of the cell.
■ The Info Window feature is no longer available
in Excel 97. To locate cells that provide data to
formulas, use the Auditing toolbar.
■ The Shared List command has gone from
the File menu. In Excel 97 you can use shared
workbooks to create and edit formulae,
change formatting, create and change charts,
and even add sheets. To share a workbook,
click Share Workbook on the Tools menu.
■ Sound notes have also been dropped from
Excel 97.
■ To start the PivotTable Wizard, choose the
PivotTable Report command on the Data menu.
■ The View Manager command has
disappeared from the View menu. Use the
Custom Views command on the View menu to
save a custom view of a workbook. Custom
views have been integrated into Excel 97 and
this command no longer requires an add-in
p r o g r a m .

Fig 4 You can create direct

hyperlinks simply by

dragging a cell from one

Excel 97 worksheet to

another and right-clicking

Fig 3 The new Visual

Basic editing

environment is the

same in every Office 97

application and it’s all

graphically orientated

On the P C W C D - R O M

If you have Excel 97 and Word 97 installed on
your computer, you can use the Excel 97 Web
Connectivity Kit described here. From the
cover CD, copy the self-extracting zip file,
WEBCNKIT.EXE, into the folder of your choice
on your hard disk and double-click on the
icon to expand the files. Follow the
instructions in WebCnKit.doc to use the
various sample files. Descriptions of the files
are in this document’s appendix. 


