
Welcome to Conversion Artist 

Conversion Artist is a very powerful set of image utilities that you will find very easy to use. Conversion Artist should be
your first choice for screen capture, format conversions, image editing, printing images, optimizing colors. As great as
Conversion Artist is you can get even more features with this very inexpensive upgrade offer:

5 Reasons to Upgrade Your Copy of Conversion Artist:
PhotoCD Support - Reads from your CD-ROM or from your disk
Faster, Better JPEG
30 Exciting Stylize Filters - Add effects like Kaleidoscope, Solarize, Charcoal, Watercolor, and 26 more!
The Image Browser and Organizer - Organize Your Images and Browse Through Thumbnail  Icons
The Best Color Optimizer for 256 Colors That Money Can Buy

To Receive Your Conversion Artist Upgrade

Simply Call, Fax, or Mail us this order form with $40. and $6. for shipping - $46. total

Name:
Company:
Address:
Town: State: Zip:
Phone: Country:
Credit Card # Expiration:

Send to:
North Coast Software
PO Box 459
Barrington, NH  03825
(603) 664-6000 - phone  (603) 664-7872 - fax
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1.   Conversion Artist:  Introduction
Welcome to North Coast Software's Conversion Artist!  In this manual, you'll find information about using

this powerful file conversion program to its full potential.  Conversion Artist is equipped not only with the ability to
convert more than 30 widely-used graphics formats, but also with such capabilities as screen capture, file
compression, and sophisticated color reduction.  Professionals will find the flexibility afforded by Conversion
Artist indispensable, and amateurs will love the sudden and dramatic increase in great images that are available
for their use, even if they own only one or two graphics programs.

The first four chapters of the Conversion Artist User Manual concentrate on everyday use of Conversion
Artist.  Chapter 1 lists requirements for running Conversion Artist, takes you through installation, and gives you
some options for enhancing performance in a variety of ways.  Chapter 2 is an introductory tour of the
most-frequently-used operations of Conversion Artist.  Chapter 3 discusses each menu, menu item, dialog box,
and option that you may encounter while using Conversion Artist.  Chapter 4 discusses the import and export file
formats, including information on compression, color support, specifications for the generic file formats, and
other important notes on particular format characteristics.

Chapter 5 of the Conversion Artist User Manual will be of great interest to the user who wants more
technical information on certain topics.  This chapter will help you make the most of the options available to you
through Conversion Artist, by discussing such pertinent issues as color reduction and dithering, device
dependency, display considerations with the Windows Multiple Document Interface, file compression, and others.

Requirements
To install Conversion Artist, you must have:

• An IBM 286, 386, or 486 (or compatible) computer.
• 2 megabytes free on your hard disk
• Microsoft Windows 3.1
• 3 megabytes of memory
• A mouse or equivalent pointing device is highly recommended but not absolutely required.

Note:  This manual is written with mouse users in mind.  If you do not plan to use Conversion Artist with
a mouse, please refer to your Windows documentation for keyboard equivalencies.
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Installation Procedure
Installing Conversion Artist is quick and easy.  First of all:

MAKE A BACKUP COPY OF YOUR CONVERSION ARTIST DISK!!

Done?  OK, now we can start...

1. Insert your backup copy of the Conversion Artist program disk into your floppy disk drive.

2. To begin installation from the Program Manager:
• Go to the File Menu and choose Run...
• A box entitled "Run" will appear.   In the Command: edit box, type:

<source-drive>:\install

... where <source-drive> is the appropriate floppy disk drive (A or B).  For example, if the
Conversion Artist program disk is in drive A, type:

a:\install

• Click OK.

To begin installation from the File Manager:
• Double-click on the appropriate floppy disk icon (A or B).  A window will open which will show

the A or B disk.
• Double-click on the folder icon.
• Double-click on the file "INSTALL.EXE"

3. A box entitled "Conversion Artist Installation" will appear.  In this box, you may specify the directory
into which you want Conversion Artist to be installed.  The default directory is c:\cnvart.

4. Click Continue.  To cancel the installation procedure, click Cancel or hit the F3 key.
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5. If the destination drive you specified in step 3 has insufficient space for installation, a message box
will appear:  "Insufficient disk space on specified destination drive."  Click OK, and the "Conversion
Artist Installation" box will reappear.  You may specify a new destination drive and try again.

6. If the installation is successful, a new group will appear in your Program Manager.  The new group
will be open and will include the Conversion Artist program icon.

Optimizing Performance: Speed, Memory, and Image Quality
Setting up to run Conversion Artist faster

If your main goal is speed, here are some suggestions for configuring your computer for maximum
speed of operation.

• Run Windows in enhanced mode with a lot of virtual memory (at least twice the amount of
conventional memory).

• Or, if you have a lot of RAM, running in standard mode will make Windows (and Conversion Artist)
run faster than it does in enhanced mode.

• Install a permanent swap file.
Please refer to the Windows 3.1 documentation for instructions on installing a permanent swap file. 

• Use a disk cache with at least 512K.  Refer to your Windows documentation for information on the
"SMARTDRV" utility.

Conversion Artist Speed Options
Listed here are Conversion Artist options specifically designed to help you to speed up operations.

Most of these options involve a tradeoff in image quality or in amount of memory required.

Under Settings in the File menu:
• Choose Use on all images under the Screen Bitmaps group.  Conversion Artist will now keep a

device-specific copy of your screen in memory, thereby greatly speeding up screen updates.  You
may also choose Don't use on 16-bit and 24-bit images to speed screen updating on monochrome,
16-color, and 256-color images only.  Enabling screen bitmaps uses extra memory.
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• Go to the Memory/Color Options group and look at the list under the Color: field.  Choose Best
Match.  When you are displaying a higher-color image on a lower-color machine (i.e., a 24-bit image
on a 256- or 16-color machine, or a 256-color image on a 16-color machine), this will speed up
displays.  In most cases, the image's appearance will not be as high-quality as it would be with the
slower Halftone option.

• CEG users:  De-select Dither on Conversion under the CEG Options group.  This will speed up
conversion to the 700-color CEG format.

Conserving Memory
Listed below are options you have if you need to conserve memory.  Most of these options involve a

tradeoff in speed or program operation.
 
Under Settings in the File menu:
• Choose Don't use on any image under the Screen Bitmaps group.  Screen updates will be slower.
• De-select Keep UNDO Buffers under the Memory/Color Options group.  Important:  If you de-select

this item, the Undo operation in the Edit menu will not function!
• Before loading Windows metafiles, scale down the metafile size.  Do this by entering a Size: value

less than 100% in the Metafile Options group.

In general:
• Don't open too many documents at once.
• On 256-color machines, iconize unused windows.
• Don't run other applications while using Conversion Artist.
• The lower the number of bits per pixel in the image, the less memory it will take up.  Try to keep the

number of bits per pixel in an image in line with the number of colors in the image.  For example, it
would be squandering memory to store a grayscale image in a 24-bit format.

Image Quality
If your primary concern is image quality, here are some suggestions for optimizing the appearance of

your images on the screen.  Some tradeoff in speed should be expected.

Under Settings in the File menu:
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• If you are displaying a higher-color image on a lower-color display device (i.e., a 24-bit image on a
256- or 16-color machine, or a 256-color image on a 16-color machine), go to the Memory/Color
Options group and look at the list under the Color: field.  Choose Halftone.  In most cases, the
Halftone option will produce a better-looking image than the Best Match option.

• CEG users:  Choose Dither on Conversion under the CEG Options group.  Images being converted
to the 700-color format will be dithered.

Using Conversion Artist as a File Viewer
One of the outstanding capabilities of Conversion Artist is its ability to act as a file viewer from the File

Manager for all supported graphics formats.  This means that when you enter the File Manager and
double-click on any file in a supported graphic format, Conversion Artist will automatically open and show
that file.  You may also use the "drag-and-drop" mouse operation; drop any graphics file into the CNVART.EXE

folder.  To take advantage of this capability, you must simply add the Conversion Artist directory into your
DOS path string in the file AUTOEXEC.BAT (please see your DOS manual for more information about your DOS
path string).
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2.   A (Pretty Quick) Tour
Here's a run-through of the most frequently-used and useful features of Conversion Artist, presented in the

context of some real-life tasks.

Help!  Online and Context-Sensitive

Online Help
Online help is useful for getting quick hints and information on Conversion Artist menu items and

operations.

FIGURE 2-1
CONVERSION ARTIST ONLINE HELP DIALOG BOX

To access Conversion Artist online help, simply click on the Help menu heading in the title bar, and a
dialog box will appear, as in Figure 2-1.  Click on the Index button to locate a particular topic you're
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interested in.  Print a help section with the File menu.  Use the Edit menu if you want to copy a help section
to the Clipboard.  Click on Browse and use the sub-options for a reading tour.

If you need more information about using the Help facility, click on Using Help in the Help menu.  This
option will give you basic information on how to get online help.

Context-Sensitive Help
You can choose to have Conversion Artist display context-sensitive help, which gives you information

about whatever menu item or option is currently active.  Context-sensitive help is displayed in the
"System/Help" status bar at the bottom of the Conversion Artist window.  Therefore, to activate
context-sensitive help, you must:

Go the the File menu and choose Settings.  Go to the Status Bars group, and choose one of these two
options:  Show Both Status Bars OR System/Help Status Bar.  Figure 2-2 shows what the two status bars
would look like if a 256-color Windows DIB file were open.  The top bar is the Local status bar, and the
bottom one is the System/Help status bar.

FIGURE 2-2
LOCAL AND SYSTEM/HELP STATUS BARS

For an example of a context-sensitive help message, open an image using the File menu's Open
option.  Click on the Edit menu.  Click and hold down the left mouse button on the Copy option.
Context-sensitive help will display a short message in the System/Help status bar about what the Copy
option does:  "Copy image in active window and place in Clipboard."
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Opening Files

Opening a file reads in an image from your disk and displays it.

Go to the File menu and choose Open.  A dialog box will appear.  The current drive and directory is
displayed above the middle box at the bottom (the directories list box).

FIGURE 2-3
THE OPEN DIALOG BOX

In Figure 2-3, the user is currently in the directory D:\CNVART.  To change directories or drives,
double-click with the left mouse button on the drive or directory name in the directories list box.  Use the
directories list box to move to your CNVART directory.

To see a list of available file formats, click on the down-arrow button next to the file formats list.  You can
scroll the list by clicking on the up and down scroll arrows.  To see a list of all of the files in the directory, go
to the top of the file formats list and choose * - List all files.  As illustrated in Figure 2-3, your file list (at the
bottom left) will now include all of the files in the current directory.
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Now go back to the file formats list, and click on the file format PCX - PC Paintbrush Format.
Conversion Artist will display all of the files in the current directory that are in the PCX format.  In this case,
the list consists of only one file, TALLSHIP.PCX.

Instead of using the mouse to display files in the file list, you may type information into the Filename: box
at the top of the dialog box.  For example, type *.TGA in the Filename: edit box, then hit the Enter key.  The
file COLORS.TGA (the only Targa file in the CNVART directory) will be displayed in the file list.

To open (load) a file, double-click with the left mouse button on its name in the file list.  Or, you may type
the file's name into the Filename: edit box and then hit the Enter key.  For example, if you type REDARROW.GIF

in the Filename: box, then hit the Enter key, that particular file will be loaded.  Try opening some of the
sample images that are provided with your copy of Conversion Artist.  (They can be found in your CNVART
directory.)

Converting, Compressing, and Saving

We have tried to make Conversion Artist maximally flexible and convenient to use.  One way we've done
this is to equip Conversion Artist with more than one method of converting a file from one format or
compression state to another.  The Save As... option is best for converting small numbers of files.  The
Batch facility is most efficient for converting large numbers of files at once.

Save As...
After loading an image, you can use Save As... in the File menu to convert the image to another

format and to save it in compressed or decompressed form.
Load (open) the file COLORS.TGA from your CNVART directory.  Now choose Save As... from the File

menu.  A dialog box will appear.
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FIGURE 2-4
THE SAVE AS... DIALOG BOX

(WITH FILE FORMATS LIST OPEN)
Choose a new file format for the image by clicking on the new format's name in the formats list box

(use the down-arrow and the scroll bars to browse through the formats list box).  In Figure 2-4, the user
has clicked on  the format TIF - Tagged Image File Format from the formats list box.  Note that the
output filename in the Filename: edit box has been changed to COLORS.TIF.  (You can use this edit box to
change the output filename if you wish.)

Instead of using the mouse to make changes, you may change the output filename and format by
simply typing the new name in the Filename: edit box.  For example, to change the file COLORS.TGA to a
PCX file, type COLORS.PCX in the Filename: box.

You can also change the file's compression state when saving.  Click on the Format>> button in the
dialog box.  Select the Compressed radio button at the bottom to save your file in a compressed form.
De-select the radio button to save the file in an uncompressed form.  In Figure 2-4, the user has
de-selected compression.

Note:  There are some formats that cannot have their compression state changed by the user.  For
these formats, the Compressed radio button will be grayed out (disabled).  For more information on
compression states of specific formats, see Chapter 4, Import/Export Formats.

To save the file with your chosen parameters, click on the Save button.  To cancel saving and exit
the Save As... dialog box, click on the Cancel button.
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Batch
(For a complete description of the Batch facility, please see Batch in The File Menu  section of Chapter
3.)

The convenient Batch facility is a big time-saver, allowing you to convert large numbers of files
non-interactively.

Suppose you have a number of files in the GIF format that you need to convert to the Targa (TGA)
format.  Choose Batch from the File menu.  A dialog box will appear.  Double-click with the mouse in the
directories list box to move to your CNVART directory.

FIGURE 2-5
THE BATCH DIALOG BOX

  
Go to the input file formats list, click on the down-arrow, and use the scroll arrows to find the GIF

format.  Click on GIF - Graphics Interchange Format to select it as your input format.  Now go to the
output file formats list and choose TGA - Targa format.

Now, as in Figure 2-5, the batch queue list box at the bottom left will list REDARROW.GIF under the Input:
column.  (If there were more GIF files in the directory, they would all be listed.)  There will be a
right-pointing arrow in the middle of the box, which shows that the file will be entered into the Batch
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queue.  Under the Output: column, the same filename will be listed but with the TGA extension:
REDARROW.TGA.  This indicates that the file will be converted to a Targa file and saved with that output
filename when the batch operation is started.

Click on the output filename (REDARROW.TGA).  It will appear in the edit box in the upper left.  You can
edit this name if you wish.  In Figure 2-5, the user has clicked on REDARROW.TGA and changed the name to
FROG.TGA.  After editing, click on the "check" button to make the filename change.  Click on the "X" button
to cancel the change.

Important Note:  The Batch facility will NOT issue a warning if it is about to overwrite an existing
file.  Be sure your output filenames are correct before starting a batch!

You may also use the Batch facility to save your output files in compressed or uncompressed form.
Use the Compress box at lower right to select or de-select compression.  In Figure 2-5, compression is
selected, so when the batch operation is started, the output file(s) will be saved in compressed form.

Note:  There are some formats that cannot have their compression state changed by the user.  For
these formats, the Compress box will be grayed out (disabled).  For more information on compression
states of specific formats, see Chapter 4, Import/Export Formats.

To start the batch, click on the Batch! button.  To cancel the job and exit the Batch dialog box, click
on the Cancel button.

Conversion Artist  Online Manual 24



Color Reduction and Optimization

Conversion Artist has sophisticated options for changing the color configuration of your images.  There
are a few different ways to change color formats:  using the main Colors menu or the pop-up Colors menu;
using the Save As... option in the File menu; and using the Batch facility in the File menu.  With each of
these methods, you may choose between two color reduction algorithms, Flat Cut and Optimized Cut, and
you may choose whether or not to dither the image when reducing colors.

The Colors Menu
Using this menu, you may quickly choose a color configuration for your current image.  The current

configuration will be indicated in the menu with check-marks.

FIGURE 2-6
THE COLORS MENU

Open the sample Targa file, COLORS.TGA.  Now open the Colors menu and note that 24-Bit Color is
checked (see Figure 2-6).  Click on another color configuration in the Colors menu; for example, 16
Colors.  Now you may choose between Flat Cut, Optimized Cut, Flat Cut with Dither, and Optimized Cut
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with Dither.  Try choosing one of these options, then use the Undo option under the Edit menu to get the
original image back.  Then choose another method, then Undo, etc.  This will give you an idea of the
results that each of the four methods will give you.

You can also try choosing Gray at the top of the Colors menu to convert the image to grayscale.

Pop-Up Colors Menu
A short-cut method of using the Colors menu:  open an image, then point to the image with the

mouse and hold down the left mouse button.  The Colors menu will appear as a pop-up menu.  Choose
your options in the same manner as above.

FIGURE 2-7
THE POP-UP COLORS MENU
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Save As...
In addition to being able to change filenames and compression states, the Save As... option in the

File menu can change color configurations.

FIGURE 2-8
THE SAVE AS... DIALOG BOX

(COLORS.TGA CONFIGURATION)

Open the file COLORS.TGA.  Choose Save As... under the File menu.  Click on the Format>> button.
As pictured in Figure 2-8, the 24-Bit Bitmap, Color, and Compressed radio buttons are selected, showing
the current configuration of the file.  Note also that the Monochrome Bitmap and the 16-Color Bitmap are
grayed out (disabled).  This is because those two color configurations are illegal for the current file
format, Targa (in other words, Targa does not support them).

Now try going to the file formats list and choosing the TIF format.  Notice that now all six color
configurations are enabled, since the TIF format supports them all.

You should notice that if you use the Save As... dialog box to perform a color reduction on a file,
there is no way to specify the color reduction method (Flat Cut or Optimized Cut) or to select/de-select
dithering.  If a color reduction is stipulated with Save As..., Conversion Artist uses the methods that are
specified in the Settings dialog box under the File menu.  To change the file saving settings for Save
As..., go to Settings and find the File Saving group.
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As was just stated, if you choose a color configuration with fewer colors than the original image
(anything less than 24-bit color, in the case of COLORS.TGA), Conversion Artist will use the File Saving
specifications when saving the file.  However, if you choose a configuration with more colors than the
original image (i.e., 32-Bit Bitmap in this case), Conversion Artist simply stores the image in that color
format.  No color information is discarded in this case.

Batch
(For a complete description of the Batch facility, please see Batch in The File Menu  section of Chapter
3.)

If you need to change the color format of a large number of files at once, you can use the Batch
facility (under the File menu).

FIGURE 2-9
THE BATCH DIALOG BOX, SHOWING WPG COLOR SUPPORT

Use the directories list box to move to your CNVART directory.  Choose TGA - Targa format as your
input file format, and choose WPG - WordPerfect Graphics Format as your output file format.  Now look
under the Colors: list box.  As shown in Figure 2-9, the list includes Monochrome, 16 Colors, and 256
Colors, but not 16-Bit, 24-Bit, or 32-Bit Color.  This is because the latter three formats are not supported
by the WPG format.
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Now choose TIF - Tagged Image File Format as your output file format and look again at the Colors:
list box.  All six possible color configurations are listed, since all are supported by TIF.

In the Options group, you can choose Flat Cut or Optimized Cut color reduction, Color or Gray, and
select or de-select dithering.

Conversion Artist  Online Manual 29



The Batch Facility

We've discussed the batch facility with regard to converting files to different formats, compression states,
and color configurations.  Try setting up a complete batch job now.

Choose Batch under the File menu.  Move to your CNVART directory.  Choose * - List all files from the
very top  of the input file format list.  Choose GIF - Graphics Interchange Format from the output file format
list.  Choose 16 Colors from the Colors: list.

Go to the batch queue file list on the left.  You need to de-select all files that are not images.  Click on
the input filename CAPTURE.DLL (a non-image file).  Its output filename and the right-pointing arrow disappear,
which indicates that it has been removed from the batch queue.  Do the same with all of the input files that
have one of these extensions:  .EXE, .DLL, .INF, .HLP, or .TXT.

Now try editing an output filename.  Click on the output filename CIRCLES.GIF.  It will appear in the edit
box at upper left.  Change its name to TEST.GIF by typing the new name in the edit box.  Click on the
"check" button to make the name change; click on the "X" button to cancel it.

Go to the Options group.  Choose Optimized Cut and Dither.  Note that the Compress option is
permanently selected and grayed out (you can't de-select it).  This is because GIF files (GIF being your
chosen output file format) are always compressed; the user cannot change their compression state.

Now your batch dialog should look just like Figure 2-10.
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FIGURE 2-10
A SAMPLE BATCH SET-UP

You've now set up a real batch job.  If you really want to execute these conversions, click on the Batch!
button.  If you want to cancel the job and exit the Batch dialog box, click on the Cancel button.

Screen Capture
The Conversion Artist screen capture utility is a very powerful tool which you'll probably find yourself

using quite frequently.
The following sequence illustrates just one of may options the screen capture facility provides.  It will

capture an image of your entire screen and automatically paste it into a new Conversion Artist window.
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FIGURE 2-11
THE CAPTURE MENU OPTIONS DIALOG BOX

Go to the Capture menu and choose Entire Screen.  Now click on Set Options... in the Capture menu.
The Options dialog box will appear.  In the Capture group, choose To Window (see Figure 2-11).  Click OK.

Now simply hit the F11 key.  Conversion Artist captures an image of your screen, opens a new window,
and pastes the image into it (all in one step!)

Please go to The Capture Menu  section in Chapter 3 for complete explanations of all the Conversion
Artist screen capture options.

Printing
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To print an image, simply open the file and choose Print from the File menu.  You may scale the image
using the Size: box (enter a percentage).  You may also choose Draft or Final quality printing (choosing Draft
will generally print much more quickly, if your printer supports this option).

FIGURE 2-12
THE PRINT DIALOG BOX

Be sure you have correctly set the options for your printer in the Printer Setup dialog box (pay special
attention to the resolution setting if your printer supports multiple resolutions).

Conversion Artist can print to any Windows-supported printing device.
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Mistakes and Experiments:  Undo

The Undo function under the Edit menu can be a lifesaver.  It reverses the most recent operation
performed on an image.

Undo works on an image-by-image basis.  In other words, if you have two images open, you can make a
change to Image #1, then make a change to Image #2, then go back to Image #1, choose Undo, and get the
original unchanged Image #1 back.

You can use Undo as a toggle between two versions of an image.  Load an image, make a change, then
use Undo to switch back to the original image.  Use Undo again to see the change again, and so forth.

Undo is a great tool for trying out various operations on an image.  Try loading an image and performing
the different color reduction options on it (Flat Cut, Optimized Cut, and the same two with dither), using the
Colors menu or the pop-up Colors menu.

Undo can also help you become familiar with the eight different dithering algorithms.  You can change
dithering algorithms by choosing Settings under the File menu, then going to the Memory/Color Options
group and choosing from the Dither: list.  Since there are no real guidelines for choosing a dithering
algorithm, it will be useful to you to try them all out on various images to become familiar with how each one
looks.
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3.   The Menus
In this section we'll discuss each Conversion Artist menu and function.  For the most part, the information

here concentrates on functionality and everyday use Conversion Artist.  If you need more information, you can
find technical discussions of several important topics in Chapter 5.

The File Menu

Use the File menu for standard file operations, such as file creation, saving, and printing.  The powerful
Batch facility allows you to perform several non-interactive conversion functions on multiple files.

New
New creates an empty Conversion Artist window.  This is most useful for pasting in images from the

Clipboard.

Open
Open is used to load files from your disk.  
(Shortcut:  You may choose to have the Load (Open) dialog box already open on the screen when

you run Conversion Artist.  Go to Settings in the File menu, and look in the Startup Options group.
Choose "Load Dialog.")

To view a listing of the available file formats, click on the down-arrow button.  Choose your desired
file format from this formats list box by clicking on the name of the desired file format.  If you click on the
first option, * - List all files, Conversion Artist will list all files in the current directory.
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Move among directories using the directory list box (double-click with the mouse to change
directories or drives).  The files in the specified format and directory will be displayed in the file list.
Select your file by clicking on its name in the file list, then click OK.

Instead of using mouse clicks, you may choose your file by typing information into the Filename: edit
box.  For example:

• Type a file's name to load that particular file (e.g., FOO.TGA).
• Type an asterisk, a period, then the file format extension to see a list of all files in that format

(e.g., *.PCX).
• Type *.* to see a list of all files in the current directory.
Click OK when you have specified your file.

While the file loads, a loading status box will appear which gives you information on:  filename, file
format, file dimensions, palette, planes, color/gray, memory required, compression state, bits per pixel,
type, version, and creator.

The number of images that can be loaded at once is limited by the memory required by the images
and the amount of memory available to Windows at that time.  If there is insufficient memory to load an
image, Conversion Artist will post an "Insufficient Memory" message, and the image will not be loaded.

The "last loaded" file type is saved between sessions, and will be the default file type in the Open
dialog box the next time you run Conversion Artist.

(Shortcut:  To quickly re-size a window to fit the image after loading, point to the window with the
mouse and click with the right mouse button.)

(Shortcut:  Images can be scrolled using the keyboard as well as the scroll bars.  Use the "Page Up"
and "Page Down" keys, and the right, left, up, and down arrow keys.  Shift-Page-Up pages to the right,
and Shift-Page-Down pages to the left.)

Close
Use Close to close the active window.  This has the same effect as double-clicking with the mouse

on the Control-menu box in the upper left-hand corner of the document window.
If you have not saved the current version of the image to a file, a message box will appear, asking

you if you want to save the image in its current form.  You may choose Yes or No, or Cancel the Close
operation.

(Shortcut:  If you wish to suppress the above- mentioned message box (i.e., if you just want to close
the window without saving any changes), hold down the Shift key as you click on Close.)
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Save
Use Save to save an image to a file.  Click on Save to save the image and Cancel to cancel the

Save operation.
If the image is untitled, the dialog box that appears will be the same as the Save As... dialog box,

i.e., you may specify a filename, file format, number of colors, and compression state.  (Please see the
section below on the Save As... menu entry for important information about automatic color reduction
and file compression).

If a message box appears indicating that there is insufficient space to save your image, you should
either:

• Save the image to a different drive, or...
• Go to the File Manager and delete some files from the current drive to free some space.

Save As...
Use Save As... to change an image's filename, to save to a different directory, and to convert to a

different file format.  Use the Format>> options to change number of colors and compression state.
Click on the Save button to save the image as specified in the Save As... dialog box.  Click on the
Cancel button to cancel the Save As... operation.

FIGURE 3-2
THE SAVE AS... DIALOG BOx
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• Change the image's filename and/or file format by typing the new name and extension in the
Filename: edit box.
For example, if you wished to save the file FOO.TGA, a Targa file, as a PCX file called BAR, you could
type BAR.PCX.  This would change the filename and the file format in one step.

• Use the directory list box to move among drives and directories (double-click with the mouse to
change directories or drives).

• To see the list of file formats that are available, click on the down-arrow button.  Use the scroll bar
buttons to look through the file formats list.  Choose a new file format by clicking on the format's
name in the list.  If the first item in the file formats list is chosen (*.* - List all files), Conversion Artist
will default to the image's original format when saving.

The "last saved" file type is stored between sessions, and will be the default file type in the Save
As... dialog box the next time you run Conversion Artist.

The Format>> button
If you click on Format>>, you will be presented with a list of options for saving the image.  You

can use these options to:
• Set number of colors (Monochrome, 16-Color, 256-Color, 16-Bit, 24-Bit, or 32-Bit).
• Set the image to be Color or Gray.
• Turn file compression on or off.

** Please note that not all file formats support all options; those options that are illegal for the current
file format will be grayed out (disabled).  For example, the GIF file format does not support 24-bit
color.  Therefore, the 24-bit color option will be grayed out if the GIF format is selected.

Important note on color reduction:  
If the file formatting that you choose when saving your image requires it to undergo a color

reduction, Conversion Artist will automatically use the default color reduction options that are
specified in File Saving under Settings in the File menu.  You will receive a warning from Conversion
Artist if your image is about to undergo a color loss, which gives you a chance to cancel the
operation before color information is actually lost (discarded).  (If you wish, you may suppress this
warning.  Use File Saving under Settings in the File menu, and de-select the option Warn user for
color loss.)  There are two instances in which an automatic color reduction can occur:
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1) You click on Format>> and then choose a number of colors that is smaller than the number of
colors contained in the image.

2) You choose a file format from the file formats list which is incapable of saving the number of
colors contained in the image.  If this occurs, Conversion Artist will first try to save the image
in a format with a higher number of colors.  If it is successful, no warning will be issued since
all color information would have been preserved.  (The only change in this case would be that
the image would have been saved in a format that can potentially encode more colors than
are contained in the image.)  If there is no higher-number color format to choose from,
Conversion Artist would be forced to reduce the number of colors to the next-lowest number
available.

Here are a couple of real-life examples of 2) above:

Example #1:  You paste an image from the Clipboard which was taken from a Targa file.  Targa
images can contain as many as 16 million colors (24-bit color).  You choose Save As... from the File
menu.  You choose the GIF format from the file formats list, then click Save.  At this point, a color
reduction must be performed (since GIF does not have a 24-bit color format).  Conversion Artist will
use the information in Settings to tell it which method of color reduction to use, whether to dither or
not, and whether or not to display a warning that a color loss is about to occur.

Example #2:  You load a 16-bit color image which is in the TIFF format.  You choose Save As...
from the File menu.  You choose the DIB format from the file formats list, then click Save.  DIB does
not have a 16-bit color format, but it does have a 24-bit color format.  In this case, Conversion Artist
will save the image as a 24-bit DIB.  No warning will be issued since no color information was
discarded.

** For information on modifying the default settings for automatic color reductions, see Settings
below.  For a discussion of color reduction and dithering, see Chapter 5.

Important Note on compressing files:  
You'll notice that with certain file formats, the Compressed option is grayed out.  There are

actually four possibilities for file formats with regard to compression:
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1)  The format is always compressed (i.e., GIF).  The Compressed option will be grayed out and
selected for these formats.

2)  The format cannot be compressed (i.e., CVP).  The Compressed option will be grayed out
and de-selected for these formats.

3)  Some subformats cannot be compressed and others can be either compressed or
uncompressed (i.e., 24-bit DIBs cannot be compressed, but 8-bit DIBs can be in either
compression state).  The Compressed option will be grayed out and de-selected for the
subformats that cannot be compressed, and enabled for those that can be compressed or
uncompressed.

4)  The format can be compressed or uncompressed (i.e., TGA).  The Compressed option will be
enabled for these formats.

All you need to do to compress an image is to turn on the Compressed option under Save As...
when you save the image.  The image's specific file format dictates which compression algorithm
Conversion Artist will use (with the exception of the TIFF file format).

For TIFF files only, you may change the default compression algorithm that Conversion Artist will
use when saving the file in compressed form.  A different algorithm can be specified for each color
configuration (monochrome, 16 colors, 256 colors, 16-bit, and 24-bit/32-bit).  Use Settings in the File
menu to change the compression defaults for TIFF files.  For more information on compression
algorithms and how they affect you and your TIFF files, see Chapter 5.

Batch
Use this powerful facility to perform non-interactive conversion operations on multiple files.
(Shortcut:  You may choose to have the Batch dialog box already open when you run Conversion

Artist.  Go to Settings in the File menu, and look in the Startup Options group.  Choose "Batch Dialog.")
The Batch dialog box includes everything you need to set up your conversion operations.
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FIGURE 3-2
THE BATCH DIALOG BOX

• Go to the desired directory using the directory list box (double-click with the mouse to change
directories and drives).

In Figure 3-2, the current directory is f:\picpal\codeview .

• Choose your input and output file formats at the top right.
To see the lists of input and output file formats that are available, click on the down-arrow

buttons in the Input: and Output: fields.  Use the scroll bar buttons to look through the file formats.
Choose a new file format by clicking on its name.

A list of input filenames which are in the specified input format will appear at left, under the
Input: column.  (If you wish to see a list of all files in the current directory, choose the first option,
*.* - List all files, in the Input: list.)  In Figure 3-2, the user has specified TIFF as the input file
format, and DIB as the output file format.

A right-pointing arrow from the Input: column to the Output: column shows that the input file
will be entered into the batch queue, converted as specified, and stored in the indicated output file
(listed in the Output: column).  The default output filename is the same as the input filename, but
with the extension of the specified output format.  In our example, the input files A1U.TIF,
COLORS.TIF, COLORS2.TIF, FINDBUG.TIF, and NULLFST.TIF will be converted to A1U.DIB, COLORS.DIB,
COLORS2.DIB, FINDBUG.DIB, and NULLFST.DIB.
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If you wish to change the default output filename, click on the output name in the Output: list.
The name will appear in the edit box in the top left corner (in Figure 3-2, the filename  A1U.DIB has
been clicked on, and has entered the edit box).  You may use this box to change the output
filename.  To enter the new output filename into the output file list, click the "check" button.  To
cancel the change, click the "X" button.

Note:  Batch will not issue a warning before overwriting a file with the same name as a
specified output file!  Please double-check that your file names are correct before issuing the
Batch command.

• To remove files from the batch queue, simply click on the input file's name.
The right-pointing arrow and the output filename will disappear and will be replaced with a

vertical bar.  (Click again, and the file will be re-entered into the queue.)  In Figure 3-2, the files
DELETE.TIF, FINDBUG2.TIF, MSLOGO1M.TIF, and MSLOGO3M.TIF have been deleted from the batch queue.

• Choose the number of colors for output files.
Use the Colors field to choose a color configuration for your output files.  Click on the

down-arrow to see a list of the valid configurations for your chosen output file format.  Click on the
configuration's name in the list to select it.  In Figure 3-2, the user has chosen to convert the listed
TIFF files to 16-color DIBs.

The Colors field will be automatically customized for whatever output file format you
choose.  This prevents you from choosing an illegal color configuration for any particular output
format.  For example, the format CVP is exclusively a 24-bit color format.  If CVP is the chosen
output format, "24-bit Color" is the only option that will show up in the Colors list.  On the other
hand, TIFF files can be in monochrome, 16 colors, 256 color , 16-bit color, or 24-bit color.  All of
these options will be available if you choose TIFF as the output format.

Options
Use the Options section to set up other batch operations.  You can choose:
• Flat cut or Optimized cut for color reduction.
• Color or grayscale.
• Dithering (see notes below)
• File compression (see note below).

In Figure 3-2, the Optimized Cut color reduction method has been chosen, and Dither has been
selected.
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For more information on color reduction methods, dithering, and file compression, see Chapter 5.

Notes on dithering:
Conversion Artist will only dither an image if a color reduction or a conversion to a different color

gamut is required.  In other words, if you are converting a 256-color image to another 256-color
format, the image will not be dithered (even if dithering is turned on).  However, if you are converting
a 256-color image to the CEG format, which has a different color gamut than other formats, the
image would be dithered (if dithering is turned on).

We have provided eight dithering algorithms for you to choose from.  When dithering,
Conversion Artist will use whichever algorithm is specified under Settings in the File menu.  You
may want to experiment with different dithering methods to see which one of the eight gives you the
effect you want, since there are no hard-and-fast rules for choosing an algorithm.  The best dithering
method for you will be different, depending on variables like the characteristics of the image (such as
the number of colors and objects, and which colors are used), your intended use of the image, and
your personal preference.

To see examples of a couple different dithering methods, please see Chapter 5, the section
Colors and Color Reduction , under Dithering.

Note on file compression:
You'll notice that with certain file formats, the Compressed option is grayed out (disabled).   For

an explanation, please look in the discussion earlier in this chapter of the File menu's Save As...
option, under the section, "Important Note on compressing files."

Print
Use Print to print any loaded image to an attached printer or file.  A dialog box will appear when you

choose Print.  Use this dialog box to scale the printed image with the Size: edit box, and to choose draft
or final quality.

Printer Setup
Adjust your printer's settings with Printer Setup.  Available options will vary from printer to printer.
Some printers support multiple resolutions.  For example, HP LaserJet printers support 75, 150, and

300 dots-per-inch (dpi).  Be sure that this setting is correct.  For instance, if you set an HP LaserJet to the
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75 dpi setting, your image's text and shading will look horrible; at the 300 dpi setting, they should look
just fine.

Settings
Use the File menu's Settings options to customize certain Conversion Artist operations to suit your

individual needs.  You can set options affecting screen bitmap use, color matching methods, dithering
methods, TIFF file compression, default color reduction operations during file saving, and use of a CEG
Windows driver.  The options you set will be saved from run to run of Conversion Artist.

FIGURE 3-3
THE FILE MENU SETTINGS DIALOG BOX

Screen Bitmaps
A screen bitmap is a device-specific copy of the image you are viewing.  If you use screen

bitmaps, you will substantially speed up all your screen updating.  The cost of using screen bitmaps
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is extra memory, so if you are using mostly large or high-color images, or if conserving memory is of
prime importance to you, you may wish to turn this option off.
  If you have screen bitmaps turned on but Conversion Artist cannot create a screen bitmap
because memory is too low, a "Memory Getting Low" message will be posted.  The screen bitmap
will not be created, so updating of the image will be slower.  However, no information will be lost.

Use on all images
Choose this option, and Conversion Artist will use screen bitmaps on each image you load.

Don't use on 16-bit and 24-bit images
This option disables screen bitmaps for high-color images only.  The memory you save allows you to
load a greater number of images, as well as larger files.  Screen updates will be slower for 16-bit and
24-bit images.

Don't use on any image
Disable screen bitmaps with this option.  You will conserve memory at the cost of slowing screen
updates.

Status Bars
Use the Status Bars group to set up display of the Local and System/Help informational status bars.
The System/Help bar's information includes valuable context-sensitive help messages. The bars are
displayed at the bottom of your Conversion Artist window.

The Local status bar displays information about the currently active image.  This information
includes:

•  Number of colors (monochrome, 16 colors, 256 colors, 16-bit color, 24-bit color, or 32-bit color)
•  Image Size (width x height)
•  File Format (i.e., "BMP - Windows bitmap")
•  Compressed/Uncompressed
•  Color/Gray
•  Modified
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The System/Help status bar displays global information about the state of your system and
context-sensitive help.  This information includes:

•  Free memory
•  Free system resources
•  Free local resources
•  Context-sensitive help messages

There are four options for displaying these status bars:
•  No Status Bars
•  System/Help Status Bar
•  Local Status Bar
•  Show Both Status Bars (the default setting)

Note that you must choose either Show Both Status Bars or System/Help Status Bar in order to
activate context-sensitive help.  If you wish to suppress context-sensitive help, you must choose
either No Status Bars or Local Status Bar.

TIFF Compression
This option allows you to set the default file compression algorithm to be used when saving TIFF

files.  You may choose a default compression algorithm for each possible color type:  monochrome,
16 colors, 256 colors, 16-bit color, and 24-bit/32-bit color.  The compression algorithms LZW and
PackBits (RLE) are available for all color types.  Group 3 (CCITT Fax 3) and Group 4 (CCITT Fax 4)
are available only for monochrome TIFFs.  

The default compression setting for all color types is LZW.  For more detailed information on
compression algorithms, see Chapter 5.

Metafile Options
Use the Size: box to scale images in the Windows Metafile (WMF) format.  Since metafiles do

not have an implicit size, some applications produce extremely large metafile images.  You may
have to scale your imported metafiles simply to make them fit on your screen.

If you are using a 256-color device, you may want to turn on the Custom Palette option.  This
option will cause a custom 256-color palette to be created for the metafile.  If this option is not
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selected, Conversion Artist will use the regular 16-color system palette and dither the image, which
will generally produce a lower-quality image.

For more information on metafiles, see Chapter 5.

Startup Options
Use this group to speed up your Conversion Artist sessions by automatically displaying the Load
(Open) dialog box or the Batch dialog box when Conversion Artist is started.  You may choose:

•  No Startup Command
•  Load Dialog
•  Batch Dialog

If you prefer, you may use a command-line option to override the Startup Options box settings.
Command lines may be specified from DOS, the Program Manager, or the File Manager.  Type the
command line with the parameter /BATCH (to start Conversion Artist with the Batch dialog open) or
/LOAD (to start Conversion Artist with the Load (Open) dialog open).

Another time-saving idea which makes use of the Program Manager is to create different icons
for starting up Conversion Artist in different ways (with Batch open, with Load open, or with neither
open).  See your Windows documentation for instructions on creating new icons using the Program
Manager.

Memory/Color Options

Color
The Color: field can be used to specify how Conversion Artist should display higher-color images

on lower-color devices.  There are two options:
•  Best Match
•  Halftone

Best Match will attempt to match the image's original colors to the available system colors.
If you choose Halftone, the image will generally look better, but the display operation will take

longer.
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Dither
There are eight different dithering algorithms for you to choose from:

•  Halftone
•  NCS Fast
•  Floyd-Steinberg
•  Stucki
•  Burkes
•  Sierra
•  Jarvis, Judice, + Ninke
•  Stevenson + Arce

There are no hard-and-fast rules for choosing a dithering algorithm.  The results will vary,
depending on such variables as the image's number of colors and objects, the specific colors used in
the image, and your intended final use of the image.

Keep UNDO Buffers
If you really need to conserve memory, you can de-select this option.  Undo buffers will not be

saved, thus some memory will be freed.  Be warned:  If you turn this option off, then the Undo
operation under the Edit menu will not function!

The default setting for Keep UNDO Buffers is "on."

File Saving
Use this option to set defaults for the conversion operations that occur automatically when you

convert and save a file to a format with fewer colors.  You can choose between Flat Cut and
Optimized Cut color reduction; turn dithering on or off; and tell Conversion Artist to send a warning
(or not) if you are about to sustain a color loss when saving your image.

For more detailed information on color reduction and dithering, see Chapter 5.

CEG Options
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Using CEG driver
If you are using a CEG Windows driver, Conversion Artist will detect the driver and turn this

option on.
If for some reason you wish to view CEG images without CEG colors, you may turn Using CEG

Driver off.
For more information about the CEG format and Windows, see Chapter 3.

Dither on Conversion
If you want to speed up conversions to the 700-color CEG format, you can de-select this option.

If you do, then Conversion Artist will not dither when performing a reduction to 700 colors.  This will
speed up the conversion but may degrade the image's appearance somewhat.

File Save Type
You may choose to save images either as CEG (Edsun's format for CEG images) or CEB (a

special format which is the same as Windows' DIB format, except that it preserves device-dependent
CEG color information).  See Chapter 3 for complete discussions of these file formats.
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The Edit Menu

The Edit menu provides standard Windows editing operations.  These include the Cut, Copy, and Paste
operations, which allow you to move images from one window or application to another.  The Edit menu also
includes the useful Undo and Delete operations.

(Shortcut:  To quickly access the Edit menu for an empty window, you can point with the mouse to the
client area of the window, and click with the left mouse button.  This may be useful when pasting to an empty
window.)

Undo
Use Undo to reverse the most recent operation performed on a particular image.  If you use Undo

and then change your mind, you can choose it again to undo the Undo.  For instance, if you convert an
image from color to grayscale, Undo will change it back to color.  If you then choose Undo again, the
image will go back to grayscale.

Undo works on an image-by-image basis.  This means that if you have multiple windows (images)
open, you could change Image #1, go to another window and work on Image #2, then come back to
Image #1 and still be able to use Undo to go back to the unchanged version of Image #1.

Cut
Cut moves the entire image in the active window to the Windows Clipboard, from where it can be

pasted to a Conversion Artist file or to any other Windows application.
To cut a portion of an image, or a special part of the screen, use the screen capture facility and the

Capture menu (see next section, "The Capture Menu").

Copy
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Copy makes a duplicate of the image in the active window and puts the duplicate in the Windows
Clipboard.  The image can then be pasted back into a Conversion Artist window, or to any other
Windows application.

To copy a portion of an image, or a special part of the screen, use the screen capture facility and the
Capture menu (see next section, "The Capture Menu").

Paste
Paste takes whatever image is in the Clipboard (placed there by another application, by using the

screen capture facility, or via Copy or Cut in Conversion Artist) and pastes it to the active window.  Paste
can be used to transfer files from one application to another, as well as between windows in a single
application.

When you paste to a window, the pasted image will take up the entire window.  Because of this, you
will probably want to open a new (empty) window, using the New option in the File menu, to create the
window you will paste into.  If you paste into a window that already has an image in it, Paste will
annihilate the image that you pasted over.  (To get it back, you can use Undo).

Note:  If you regularly use Clipboard files (.CLP files) to transfer files from one device driver to
another, please see Chapter 5 for important information about device dependency.

Delete
Delete removes the contents of a window.  The contents will not be stored in the Clipboard if you use

Delete.  If you use Delete by mistake and annihilate your image, you can bring it back by using Undo, as
long as you have not made any changes to the window in the interim.
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The Capture Menu

Use the Capture menu to set options for capturing screen images from any program running under
Microsoft Windows.  (A screen capture is essentially a snapshot of your computer screen or a portion
thereof.)  You can save the captured image to a file, to the Clipboard for pasting into any Windows program,
or to a new Conversion Artist window.  Options allow you to set the capture area to be any region of the
screen you wish.  The last capture area type selected will be stored between sessions, and will be the default
the next time you run Conversion Artist.

The Capture Key ("Hot Key")
The default capture key (the "hot key") is the "F11" function key.  Use the Capture Menu options to

specify what region of the screen you wish to capture, then use the hot key to execute the screen
capture.

When you hit the hot key, the specified region of the screen will be captured, except in the case
when User-Defined Rectangle is the specified region.  In this case, when the hot key is struck, the regular
cursor will change to a selection cursor.  (See User-Defined Rectangle below for more information).

You can specify whether you want your captured image to be sent to a file, to the Clipboard, or to a
new Conversion Artist window by using Set Options (see below).

The hot key can be set to be any of the 12 function keys, or to be any key in combination with the Alt
key, the Ctrl key, or both of these keys.  To change the hot key, use Set Options (see below).

Active Window
This option captures an image of the window active at the time of the capture.

Active Application
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This option captures an image of all windows enclosed in the running (active) application window
(including the application's own window).

Entire Screen
This option captures an image of the entire screen.

User-Defined Rectangle
Choose this option to capture any rectangular portion of the screen.  When this option is selected

and you press the Capture (hot) key, the cursor will become a "selection cursor."
To use the selection cursor to delineate your chosen rectangular area, position the small dot in the

middle of the cursor at one corner of the chosen area.  Hold the mouse button down and drag the mouse
to the opposite diagonal corner.  The rectangular portion of the screen you dragged over will be captured.
As you drag the mouse, the dimensions of your selected rectangular area will be displayed.  If you want
the chosen area to be a perfect square, hold the Shift key down while you drag the mouse.

Note:  If you drag over a square area by holding down the Shift key while dragging, the area may or
may not appear square on your monitor, depending on the monitor's aspect ratio (the ratio of its pixel
height to pixel width).  However, it will be a square in that each side will measure the same number of
pixels.  For more information on device dependency and how it affects images' appearances, see
Chapter 5.

Window Under Mouse
Use this option to capture an image of whichever window is under the mouse at the time that the

capture key is hit.
This is the best option to use if you wish to capture a "control" or "client" window (such as a button, a

list box, etc.). 
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Set Options

FIGURE 3-4
THE CAPTURE MENU OPTIONS DIALOG BOX

Capture
Use this option to direct your captured screen image.  Choose:

•  To File - Directs your captured image to a specified file on your disk.  Use the Output File
group (see below) to set the filename, to add automatic incrementing of filenames, and to
specify the attributes of the output file.  Figure 3-4 illustrates the Options box set up to capture
to a file.

•  To Clipboard - Pastes the captured image into the Windows Clipboard.

•  To New F - Automatically creates a new window in Conversion Artist and places the captured
image in this window.
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Output File
Use this group to set attributes of the output file, if you are sending your screen capture to a file.

(This group will be disabled if you have chosen to capture to the Clipboard or to a New Window.)
Set the output filename by typing it in the Filename: box.  Specify an output file type by clicking

on the File Type: down-arrow and then clicking on the desired file type in the list.
You may opt to add an automatic increment number to your screen capture filenames.  This is a

great time-saver if you plan to file several different screen captures, one after the other.  To use the
auto increment, turn on the Increment File Number option.  In Figure 3-4, the Increment File Number
option has been selected.  The default starting number will be 01.  Use the edit box to change the
starting number if you wish.  When the Increment File Number option is selected and a screen
capture occurs, Conversion Artist will save the image and append the starting number to the end of
the specified output filename.  For example, if your output filename is set to be SCREEN.DIB and you
have selected Increment File Number, then the first screen capture image will be saved in a file
called SCREEN01.DIB.  The next screen capture would be saved as SCREEN02.DIB, and so on.  The
number in the Increment File Number option will be updated as you work, so you may check it or
change it at any time.

Note:  Filenames under DOS can be a maximum of eight characters long.  This means that if
you specify an output filename that is more than six characters long, Conversion Artist will truncate it
in order to append the incremental two-digit number.

Window Capture
Capture Contents.  Choosing this option will cause the screen capture facility to save only the

contents of a window, excluding the window border and the title bar.  This region is often referred to
as the Client Area.

Capture Entire Window.  This option causes the screen capture facility to save the entire window,
including the border and title bar.  In Figure 3-4, this option has been selected.

Hot Key
Use this option to set the "hot key" (capture key) to be any of the 12 function keys, or any key in

combination with the Alt key, the Ctrl key, or both of these keys.  Current Binding tells you what the
hot key is at present (the default binding is F11).  Click on the arrow key next to the text box to get a
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list of all 12 function keys (F1-F12).  Click on the key you want to select, then click OK.  Select or
de-select Alt and/or Ctrl to use those keys in your hot key sequence.
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The Colors Menu

Use the Colors menu to convert between color configurations.  You will have various options for color
reduction schemes, and you may also choose whether or not to use dithering.

(Shortcut:  To access the Colors menu quickly, simply point to an image with the mouse, and click with
the left mouse button.  The menu will appear as a pop-up on the image.)

You may choose to convert an image to a higher-color format by choosing the appropriate "Increase
colors to..." option.

Important Note:  It is important to understand that simply converting an image to a format with more
colors does not "add" colors to an image, but merely changes its format.  For example, if you load a 16-color
image and then choose "Increase colors to 256" under the Colors menu, you will not have 240 new colors in
your image!

The "Increase colors to..." options are useful if you need to convert a file in order to use it in another
program or with another device. 

Another Important Note:  It is very important to understand the difference between 1) displaying a
higher-color image on a lower-color display device and 2) converting the image using a color reduction
method (Flat Cut or Optimized Cut).  Color information is not lost if you merely display the image with a
device that cannot show all of its colors.  However, when you choose to reduce the colors in an image by
clicking on a color reduction method, all the colors in the image are lost (discarded) except those that the
reduction operation keeps for the new reduced-color image.

For more information about color configurations, reduction algorithms, and dithering, see Chapter 5.

Color
Choose this option to convert the image to "color."  

(Some formats have a "color" tag and a "gray" tag.  This option will tag an image as a "color" image.  It
will not change a grayscale image to a full-color one!)
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Gray
Choose this option to convert the image to grayscale, or to tag an image as a "gray" image.

Monochrome
Converts the image to black-and-white.  Choose Flat Cut or Flat Cut with Dither for color reduction.

16 Colors
Converts the image to a 16-color palette.  Choose Flat Cut; Optimized Cut; Flat Cut with Dither; or

Optimized Cut with Dither for color reduction.  (See Chapter 5 for more information on color reduction
methods and dithering.)

Choose Increase colors to 16 to save a monochrome format in 16-color format.

256 Colors
Converts the image to a 256-color image that has a palette.  Choose Flat Cut; Optimized Cut; Flat

Cut with Dither; or Optimized Cut with Dither for color reduction.  (See Chapter 5 for more information on
color reduction methods and dithering.)

Choose Increase colors to 256 to save lower-color formats in 256-color format.

16-Bit Color
Converts the image to 16 bits (32,767 colors) with no palette.  (This format is used only by certain

video boards, such as Sierra DAC-based video boards, the Targa-16 video board, and the IBM XGA
video board.)  Choose Flat Cut or Flat Cut with Dither for color reduction.  (See Chapter 5 for more
information on color reduction methods and dithering.)

Choose Increase color to 16-bit to save lower-color formats in 16-bit format.

24-Bit Color
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Converts the image to 24-bit, or 16.7 million colors.  Choose Increase color to 24-bit to save
lower-color formats in 24-bit format.  Choose Decrease color to 24-bit to convert a 32-bit image to a
24-bit format.

32-Bit Color
Converts the image to 32-bit format.  Choose Increase color to 32-bit to save lower-color formats in

32-bit format.  
Loaded 32-bit images in Conversion Artist do not include more information than do 24-bit images.

When a 32-bit image is loaded into Conversion Artist, the 8 bits of alpha channel information are
discarded.

CEG Colors
Converts the image to a high-color Edsun CEG format.  Please see Chapter 4 for a complete

discussion of the CEG format and how it works with and without CEG boards.

700 Colors
This format may be viewed with the standard 16-color CEG Windows driver.  It has a fixed

palette.

2,048 Colors
Images in this format, like those in the other higher-color CEG formats, cannot be viewed under

Windows without a significant degradation in appearance, but may be viewed with the DOS-based
SHOWCEG utility included with Conversion Artist.

7,000 Colors
This format will convert an entire full-screen image in 30 seconds.  A good alternative to

committing to the highest-quality (and most time-consuming) 700,000-color format.

700,000 Colors
This format will use the highest number of CEG colors available and may take 15 or more

minutes to convert a 640 X 480 image.  This option also gives you the highest quality possible for a
CEG image.  It may be worth the wait!
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The Image Menu

The Image Menu allows Conversion Artist to perform image manipulation.  Using these menu
options, you can re-orient your image by rotating, change its size by cropping or scaling, and perform a
variety of other operations such as inverting colors, mirroring, framing, tiling, captioning, and masking.
By combining these operations, you can achieve great-looking special effects, too.

You'll find the crop, scale, and rotate operations particularly useful if you are preparing materials
to be printed.  Digital re-sampling methods are used to create very high-quality rotated and scaled
images.  Contrast, brightness, hue, and saturation controls give you a tremendous amount of color
correction control for modifying colors.

On the next few pages, you'll find a graphic index showing examples of each of these Image
menu operations.
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ORIGINAL IMAGE:

INVERT IMAGE FLIP IMAGE

MIRROR IMAGE
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CROP

SCALE

48% scale: 178% scale:
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ADJUST ASPECT

 Height 50%:

ROTATE

90 degrees: 27 degrees:
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FRAME/CAPTION

Frame: Frame with Caption:
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TILE

Tile (2 x 3):
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Tile (2 x 3 with mirroring):
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MASK

Mask (Oval): Mask (Checkers):
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Invert Image
Use this menu item to invert the colors in your image.  Invert Image takes each of the original

image colors, computes their opposite in the color spectrum, and changes each original color to its
opposite.  As a simple example, if there is a color in your image which is composed of a lot of red, a
little blue, and a little green (which would be a light red), the inverted color would be composed of a
little red, a lot of blue, and a lot of green (which would be a dark cyan).

Flip Image
Use this menu item to flip your image along the horizontal axis.

Mirror Image
Use this menu item to flip your image along the vertical axis.  This will create a mirror-image of

the original.

Crop...
Use this option to crop off portions from the sides of your image.
The Crop dialog box lets you specify portions of the image you want to cut from top, bottom, left,

and/or right.  A thumbnail version of the image is included in a previewing box at left. Use this to
monitor your crop-line locations as you crop the image.

Cropping an image has no effect on its color (bits-per- pixel) configuration.  In other words, if you
start with a 256-color (8-bit) image, it will be stored as an 8-bit image after it has been cropped.
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FIGURE IMG-1
THE CROP DIALOG BOX

The Crop group in the dialog box has fields in which you can enter pixel values to crop off of the
Top, Bottom, Left, and/or Right of your image.  As you enter pixel values, crop lines will appear at
the specified locations in the thumbnail previewing box.

Another way you can crop your image is to point with the mouse to a crop line in the previewing
box (the cursor will change to a double-sided arrow), hold down the left mouse button, and drag the
line to the new location.  When you first open the Crop dialog, the crop lines are located at the edges
of the image in the previewing box.  As you drag, the pixel values in the Top, Bottom, Left, and Right
fields will change dynamically.  You can also point to a corner (a four-sided cursor appears) and drag
the corner, to move two crop lines simultaneously.  To move the entire crop-line box around the
image, just point anywhere inside the box (the cursor will change to a hand), click, and drag the box
to its new location.

The new dimensions (in pixels) of the image will be displayed in the Dimensions group (see
below).
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The Dimensions group allows you to enter new pixel dimensions for the image in the Width: and
Height: edit boxes.  By default, the crop lines will be centered on your image.  For example, if you
enter a Width: value that is 20 pixels less than your original image's width, crop lines will appear 10
pixels in from the left and right edges of the image.

The Dimensions group is quite useful if you want your final cropped image to be of a specific
size.  Just enter the final dimensions in the Width: and Height: boxes.  Then, if the crop lines are not
where you'd like them to be, you can use the hand cursor to move the crop box around.

The Display group allows you to choose whether or not to preview your image at its actual size.
If your image is small enough that it fits entirely within the borders of the previewing box, the

Show Real Size radio button will be permanently selected (since your image will automatically be
previewed at full size).

If the entire image does not fit in the previewing box, you may choose between Show Real Size
and Fit In Window.  Fit In Window is good for an overall view of your crop-line locations.  Show Real
Size is useful for examining a portion of your image up-close.  If, for instance, you need to see if your
crop line is touching or just missing an object in the image, Show Real Size lets you take a closer
look.  Scroll bars allow you to move around the image.

Scale...
Use this option to enlarge or reduce the overall size of your image.
The Scale Image dialog box allows you to:  set a new width and/or height for the image; scale by

percentage; choose high-quality or high-speed scaling; choose different units of measurement;
specify dots-per-inch for different devices (allowing you to create predictable image sizes for
particular devices, such as printers); and correct aspect ratio and resolution problems.
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FIGURE IMG-2
THE SCALE IMAGE DIALOG BOX

You may specify a new image size by typing values into the Width: and/or Height: fields.  Use
the Maintain Aspect check-box to choose whether or not to maintain the image's original aspect ratio
(in this instance, aspect ratio means the ratio of image height to image width).  If you select the
Maintain Aspect check-box and then change either the Width: or the Height: value, the other value
will change automatically, to preserve the same aspect ratio.  If you de-select the Maintain Aspect
check- box, and you enter Width: and Height: values that do not preserve the original aspect ratio,
the result will generally be an image that looks squashed or elongated.  (For a discussion on how to
correct aspect ratio problems, see the following section, Correcting Resolution and Aspect Ratio
Problems.)

The Measure: list box allows you to change the resolution by which the scaled image is
measured.  This allows you to create images which are of a predictable size for a particular device.
There are three choices:  Screen (x, y), Printer (x, y), and Custom.  The values in parentheses
represent dots-per-inch (horizontal, vertical) for the chosen device.

Screen (x, y) represents what Windows believes is your monitor's resolution.  (This may not, in
fact, be accurate.  For a discussion of how to determine and enter your correct screen resolution, see
the following section, Correcting Resolution and Aspect Ratio Problems ).

Printer (x, y) represents your attached printer.  If you want to use a device that has a different
resolution, use Custom.  After you click on Custom, you can enter values for horizontal and vertical
dots-per-inch in the boxes provided.
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Here's an example of how to use the Measure: box.  Say you would like to create an image that
will be 25 centimeters wide by 50 centimeters high when printed on an attached laser printer.  The
laser printer has a resolution of 300 dots-per-inch.  Since screens generally have resolutions of only
70-100 dots-per-inch, any image you create on your screen at a particular size will print at only about
one-third that size (or less).  So, to ensure correct printing size, choose Printer (300, 300) from the
Measure: list box (the x and y values will be set according to your attached printer's resolution.)
Choose Centimeters from the Units: list box.  Now enter 25 in the Width: box and 50 in the Height:
box.  Click OK.  Now your image will be 25 cm x 50 cm when printed on your 300 dpi printer (unless
the image is scaled during the printing operation).

The Units: list box allows you to choose the units by which the image is measured.  Choose
Pixels, Percentage, Inches, or Centimeters.  Pixels is useful for correcting aspect ratio problems and
for dealing with images on a device- dependent level.  Percentage lets you change the size of the
image relative to its original size.  Inches and Centimeters are useful for creating images of a
predictable size on a chosen device.

The Quality: list box lets you choose between High or Low quality for your scaled image.  If you
choose Low quality, the scaling operation will be fast, and the resulting image will not be as good as
it could be.  With Low quality, the scaled image will be created in the same color configuration
(bits-per-pixel) as the original image.

If you choose High quality, the scaling operation will take slightly longer, but will produce the
best-looking image.  In a High quality scaling operation, the scaled image will be created in 24-bit
color (for color images) or in 8-bit grayscale (for gray or monochrome images).

Correcting Resolution and Aspect Ratio Problems

Resolution
As we mentioned above, there's a possibility that Windows may enter an incorrect

resolution for your screen in the Measure: list box under Screen (x, y).  If it seems to you that
the resolution values are incorrect, you can use the Custom entry in the Measure: list box to
enter your monitor's actual resolution.
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To figure out your monitor's actual resolution:  Measure the width of your monitor along the
top or bottom of the screen (you can just use a regular ruler).  As an example, assume the width
is 10 inches.  Now measure the screen's height.  Assume the height is 7.125 inches.

If you are running a VGA device, the resolution of your device driver is 640 x 480 pixels
(width x height).  Divide your device's pixel height (640) by the physical height of your screen to
get your screen's dots-per-inch along the height dimension:

640 / 10 = 64 dpi
Divide your device's pixel width (480) by the physical width of your screen to get your screen's
dots-per-inch along the width dimension:

480 / 7.125 = 67 dpi.

Now you can plug these numbers into the Custom Height and Width fields and create
accurately-measured images for your screen.

Aspect Ratio
One common problem you may encounter when moving images from one display device to

another is the change in aspect ratio.  Aspect ratio, as the term is used in this manual, is the
ratio of a device's dpi (dots-per-inch) along its height to dpi along its width.  If an image is
displayed on a device that has a different dpi value along one or both axes than the device on
which the image was created, its aspect ratio will be incorrect.  The image will generally appear
either squashed or elongated.  There are two common operations that are often desired when
working with devices that have different aspect ratios:  converting an image to have the same
absolute size on the new device, and converting the image to have the same relative aspect
ratio.

Same Absolute Size
To convert an image to the same absolute size on a new device you must know the absolute

size of both display devices as well as the devices' pixel resolutions.  This allows you to
compute the device-independent dpi resolution for each device.  Once the dpi is known it is a
simple matter to scale the image to the proper size.

As an example, imagine that you have a picture of dimensions 160 pixels wide by 58 pixels
high.  The picture was created on a CGA device with a monitor that measures 10 inches wide
by 7 inches high.  CGA pixel resolution is 640 x 200.  So the CGA device's resolution
(dots-per-inch) would be:

200 pixels / 7 in = 28.57 dpi along its height
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640 pixels / 10 in = 64.00 dpi along its width

On this device, the picture's physical dimensions would be:
58 pixels / 28.57 dpi = 2.03 inches high
160 pixels / 64 dpi = 2.50 inches wide

If we use a Super VGA device with a pixel resolution of 640 x 480 (assuming the same-sized
monitor as the CGA display), its resolution (dpi) would be:

480 pixels / 7 in = 68.57 dpi along its height
640 pixels / 10 in = 64.00 dpi along its width

Now, imagine that you display the CGA-created image on the Super VGA device (still
assuming both monitors are 10 x 7 inches).  The picture, of course, still measures 160 pixels
wide and 58 pixels high.  However, on the VGA device, its physical dimensions would be:

58 pixels / 68.57 dpi = 0.85 inches high
160 pixels / 64.00 dpi = 2.50 inches wide

So, without correcting for the different aspect ratio, the image would appear very squashed
on the VGA.

To make the image have the same absolute size on the VGA device you must start out with
the original size on the CGA device, and from there work out the new pixel size using the
device-independent dpi information.  Since, in this case, both devices happen to have the
same dpi along the dimension of width, you only need to alter the image's height.  To get the
desired height of 2.03 inches, given the VGA's height dpi of 68.57, you would multiply dpi by
inches to get the pixel height:

68.57 dpi * 2.03 in = 139 pixels

So the image needs to be 139 pixels high on the new device to be the same size as it was on
the old device.

To perform this action on the actual image, you would go to the Scale dialog box, de-select
Maintain Aspect, and enter 139 in the Height: box.  Now your image will be 2.03 x 2.5 inches
and will no longer look squashed.
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Same Relative Aspect Ratio
Although there are an infinite number of ways to convert an image so that it has a particular

aspect ratio (1:2, 2:4, 3:6, etc), the most commonly-desired results are for an image to
maintain either the same height or the same width (measured in pixels).  This can be
accomplished by computing the dpi resolutions of the two devices and then computing a new
height or width.

As an example, let's say you have an image created on a CGA device which has dimensions
of 320 pixels wide by 200 pixels high.  You want to save it as a VGA image with a height of
200 pixels (the same pixel height as the old CGA image), and to correct its aspect ratio.  So
you need to find the width, in pixels, which will produce an image with the new VGA aspect
ratio, given a height of 200 pixels.  Using the same CGA/VGA data as above you
have aspect ratios of:

VGA: 68.57 dpi / 64.00 dpi = 1.07
CGA: 28.57 dpi / 64.00 dpi = 0.45

Now, to keep the height the same and compute a new width you would have:

320 ∗ 


0.45
1 . 07


 = 13

To keep the width the same and compute a new height, you would have:

200 ∗ 


1.07
0. 45


 = 475

To accomplish this last aspect change in Conversion Artist you would go to the Scale dialog
box, de-select Maintain Aspect, choose Pixels as the unit of measure, and enter the new height
(475) in the Height: edit box.
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Rotate...
Use this menu item to rotate your image by any number of degrees, positive or negative, and to

choose a back- ground color for the rotated image.

FIGURE IMG-3
THE ROTATE DIALOG BOX

Choose Custom, 90, 180, or 270 for degrees of rotation.  If you choose Custom, you may enter
any integer in the Amount: edit box, and your image will be rotated by that number of degrees.
Rotation is to the right (clockwise) if the integer is positive, to the left (counterclockwise) if the integer
is negative.

You may use the Quality: list box to choose between High and Low quality for the final rotated
image.

If you are rotating the image by 90, 180, or 270 degrees, the quality will always be High (in other
words, there will be no difference in appearance of the image or in speed of the operation, whether
you choose High or Low quality).  If you choose 90, 180, or 270 for degrees of rotation, the rotated
image will be created in the same color configuration (bits-per-pixel) as the original image.  For
instance, if your original image was a 4-bit (16-color) image and you rotate it by 180 degrees, the
rotated image will be created as a 4-bit (16-color) image as well.
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If you are rotating the image by any other number of degrees, you will be performing a Custom
rotation.  If you choose Low quality for a Custom rotation, the rotation operation will be fast, and the
resulting image will not be as good as it can be.  With Low quality, the resulting image will be stored
in the same color configuration (bits-per-pixel) as the original image.

If you choose High quality for a Custom rotation, the rotation operation will be slower, but the
resulting image will look much better.  In a High quality rotation, the rotated image will be created in
24-bit color (for color images) or in 8-bit grayscale (for gray or monochrome images).

The final quality of the rotated image is dependent on the image's resolution.  One way to
increase an image's resolution is to first use the Scale... operation to enlarge your image (say to
300%, or 3 times original size), then perform the Rotate... operation, and finally scale the image
back down to its original size.  Working with the image at a higher resolution (larger size) will
increase the quality of the image when it is shrunk back to its original size.

In a Custom rotation, the rotated image's dimensions will be larger than the original image's
dimensions.  (Rotate... draws a rectangle around the rotated image, with edges tangent to the
rotated image's corners.  You will thus have portions of "background" showing behind the rotated
image.)  You may choose a background color for the rotated image by clicking on the Color: button.
The background color may be chosen from a palette corresponding to your original image's color
configuration (for monochrome images, choose black or white; for 4-bit images, choose among 16
colors; etc.).  If your original image was in 24-bit color, you may choose any color for the
background.

When you click on the Color: button, a color-chooser dialog box for the present color
configuration appears (except for monochrome, where the color toggles between black and white).
For 4-bit and 8-bit files, the color palette will have 16 colors and 256 colors to choose from,
respectively.  For 24-bit files, the standard Windows color-chooser dialog box appears.  Note:  If you
are choosing a color for a 24-bit image, remember to check the luminance value in the
color-chooser dialog (this can be adjusted with the slider on the far right).  If luminance is set to 0,
your color will always come out black, and if it is set to 240 (the highest value), your color will always
come out white.

Frame/Caption...
Use this menu item to create a custom frame and to add captions to the image.
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In the Frame/Caption Image dialog box, you will find options for choosing a frame style;
specifying a framed image's final dimensions; specifying and previewing frame margin
measurements; adding caption text; and choosing colors for frame fill, frame outline, and text.

FIGURE IMG-4
THE FRAME/CAPTION DIALOG BOX

From the Style: list box, you may choose Filled or Outline as the frame style.  Filled creates a
frame filled with a specified color.  Outline creates a frame with a one-pixel outline of a different
color from the fill color.  (Use the Color: button to name a color for frame fill and frame outlines.)

In the Final Dimensions group, you may enter the dimensions, in pixels, of the finished image
(picture plus frame).  As you enter the picture's final dimensions, the Frame Margin values (see
Frame Margins below) will change dynamically, centering the image within the frame.  Please note:
The Final Dimensions width and height values cannot be smaller than the width and height of the
image you wish to frame.  In other words, the frame cannot cover any part of the image but must
only wrap around the outside of the image.  If you want the finished dimensions to be smaller, you
should first use Crop... or Scale... to cut down the size of the image before framing it.
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In the Frame Margins group, you may specify the width of the frame, in pixels, at the Top,
Bottom, Left, and Right of the image.  As you alter these values, the Final Dimensions values will
change dynamically to show you the final height and width of the framed image.  A previewing box at
the top right also changes dynamically as the Frame Margins values change.  (The frame you've
specified appears in black, while the hatch-marked area represents the framed image.)

Use the Colors group to choose colors for frame fill, frame outline, and caption text.  In the
drop-down list box, choose the area for which you want to pick a color (Fill Color, Outline Color, or
Text Color), then choose the color with the Color: button.  Colors may be chosen from a palette
corresponding to the original image's color configuration (except for 24-bit images, for which any
color may be chosen).

When you click on the Color: button, a color-chooser dialog box for the present color
configuration appears (except for monochrome, where the color toggles between black and white).
For 4-bit and 8-bit files, the color palette will have 16 colors and 256 colors to choose from,
respectively.  For 24-bit files, the standard Windows color-chooser dialog box appears.  Note:  If you
are choosing a color for a 24-bit image, check the luminance value in this dialog (adjust with the
slider on the far right).  If luminance is set to 0, your color will always be black, and if it is set to 240
(the highest value), your color will always come out white.

In the Caption (x, y) group, you may enter any text you wish to overlay upon the image.  (You are
not required to create a frame in order to place text upon your image.)  The x and y values that are
displayed next to the word Caption represent the width and height (in pixels) of the caption that you
create.  This allows you to create a frame in which your caption will fit.  Note:  If your caption text
does not fit in your frame or on your picture, the text will be truncated, not wrapped.

Click the Style: button to select your font, font style (bold, italic, etc.), size, and effects.  Choose
a text color with the drop-down list box in the Colors group:  click on Text Color, then pick a color
with the Color: button.  (See above for information on the Color: button.)

Click the Align: button to position your text along the horizontal and vertical axes.  Choose Left,
Center, or Right align in the Horizontal group, and Top, Center, or Bottom align in the Vertical group.

You should also consider the special effects you can achieve by combining various operations in
the Image menu.  For instance, to run a caption diagonally across your image, first rotate the image
by 45 degrees, caption it, then rotate back to its original orientation.
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FIGURE IMG-5
SPECIAL TEXT EFFECT USING

FRAME/CAPTION AND ROTATE

The final appearance and quality of the framed image and caption text is dependent on the
image's resolution.  One way to increase an image's resolution is to first use the Scale... operation to
enlarge your image (say to 300%, or 3 times original size), then frame and/or caption it, and finally
scale the image back down to its original size.  Working with the image at a higher resolution (larger
size) will increase the quality of the image when it is shrunk back to its original size.

Tile...
Use this menu item to create multiple copies (tiles) of your original image and organize them in

an array (as though the images were tiles being laid).
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FIGURE IMG-6
THE TILE IMAGE DIALOG BOX

The Tile Image dialog box provides you with a Width: and a Height: field.  Use these fields to
specify how many tiles of the image you want along the horizontal (Width) and vertical (Height)
dimensions.

Select the Mirror Tiles option to create mirror effects.  This option will mirror tiles both along the
horizontal and along the vertical axes.  If you wish to mirror only along one axis, first tile along the
mirrored axis with Mirror Tiles selected; then tile along the non-mirrored axis with Mirror Tiles
de-selected.

Mask...
Use this menu item to create special effects by masking out (hiding) parts of your image with the

figures and patterns provided.
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FIGURE IMG-7
THE MASK IMAGE DIALOG BOX

In the Mask Image dialog box, you can choose from an assortment of shapes for your mask.
The Shape: box at right will display the shape you choose from the Name: list at left.  By default, the
black areas in the Shape: box will be the areas through which your original image will show, and the
white areas will be masked.  If you select the Invert Mask option, however, the white areas in the
preview box will be the areas through which your image will show, and the black areas will be
masked.

Use the Mask Color... button to choose a color for the masked parts of the final image.  Colors
may be chosen from a palette corresponding to your image's color configuration (i.e., black or white
for a monochrome image, 256 colors for an 8-bit image, etc.).  If the original image is in 24-bit color,
any color may be chosen for the mask color.

When you click on the Color: button, a color-chooser dialog box for the present color
configuration appears (except for monochrome, where the color toggles between black and white).
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For 4-bit and 8-bit files, the color palette will have 16 colors and 256 colors to choose from,
respectively.  For 24-bit files, the standard Windows color- chooser dialog box appears.  Note:  If
you are choosing a color for a 24-bit image, remember to check the luminance value in the
color-chooser dialog (this can be adjusted with the slider on the far right).  If luminance is set to 0,
your color will always come out black, and if it is set to 240 (the highest value), your color will always
come out white.

The final quality of the masked image is dependent on the image's resolution.  One way to
increase an image's resolution is to first use the Scale... operation to enlarge your image (say to
300%, or 3 times original size), then mask the image, and finally scale the image back down to its
original size.  Working with the image at a higher resolution (larger size) will increase the quality of
the image when it is shrunk back to its original size.

Contrast/Brightness

Use these menu items to increase the contrast and brightness of the selected image.  Contrast
will make dark parts of an image darker and will make light colors lighter.  Brightness will make the
entire image lighter.  Use the slider  controls to change the contrast and brightness on the preview
image which is displayed.  Then select OK to apply those changes to the image.  You can use
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Channel to select the specific color you which to modify or you can select RGB and change all colors
with a single operation.
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Hue/Saturation

Use the Hue and Saturation controls to  change to overall Hue and Saturation of an image. 
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The Filter Menu

Conversion Artist comes with 10 filter effects which can  give an image additional distinction and flair.  A
filter is applied to the image in the active window.  This process can be repeated several times to give more of an
effect.  All filters work with images having 16 or more colors.  If an image is only black and white, or
monochrome, the filter menus will appear grayed out and will not be applicable.  If you really need to apply a
filter to a black-and-white image you can promote the image to color using the settings in the Colors menu.

The filters appear in the FILTER menu in the following order:

Sharpen

The Sharpen filter will make a blurred image look more crisp.  The opposite of Sharpen is Blur.

Sharpen Lines

The Sharpen Lines filter will accentuate lines and finer detail in an image.

Despeckle

The Despeckle filter will remove stray points of very different colors. This has a subtle smoothing effects.

Emboss
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Emboss is a very interesting effect which can make an image look like a three-dimensional relief, or
sculpture.  

Blur

The Blur effect gives an image a blurry appearance. It is especially noticeable on images with a lot of
fine detail.  As with all filters it can be used several times repeatedly on an image to make it very blurry or just a
little blurry.

Median

The Median filter can be used repeatedly to create a Posterize effect where a few colors dominate an
image.

Trace Edges

The Trace Edges filter will remove all features from an image accept its edges.  Because of the nature of
the filter, the colors it creates are very bright.  These colors can be toned down or simply converted to gray using
the Contrast/Brightness or Hue/Saturation controls in the Image menu.

Noise

The Noise filter will add a small amount of randomly colored pixels evenly over an image. The effect is
that of adding 'visual noise' to the image.  If more noise is desired, the filter can be repeatedly applied as
needed.

Maximum
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The Maximum  filter will increase bright or light colored areas in an image.  Repeatedly applying this filter
 will spread the bright colors over an image much like water colors or finger paints.

Minimum

The Minimum filter is much like the Maximum filter except that it spreads dark colors. 
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The Separate Menu

The Separate menu provides many functions for  working with RGB (Red, Green, Blue) and CMYK
(Cyan, Magenta, Yellow, Black) colors.  CMYK tools are most useful for users working with offset printing presses
where colors must be converted from RGB computer colors to CMYK ink colors. With a little imagination, these
operations can be used to create very unique and interesting effects on RGB images.  See the Creative Ideas
note.

RGB
Red Filter
Green Filter
Blue Filter

These operations will remove all but the selected color and display the resulting image in 256 shades of
gray. The shades of gray correspond to the luminosity, or brightness of the selected color. For instance light gray
or white would represents  bright red if red were selected.

CMY
Cyan Filter
Magenta Filter
Yellow Filter

These operations will remove all but the selected color and display the resulting image in 256 shades of
gray. These operations will convert an image  from RGB color space into CMY color space before performing the
filtering operation.
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CMYK
Cyan Filter
Magenta Filter
Yellow Filter
Black Filter

These operations are similar to CMY listed above except that the undercolor (gray) is removed before
the filter operation is applied. In the case of Black Filter, all other colors are removed leaving just the undercolor
(gray).

Split into RGB
This function takes the active image and creates three images containing the Red plane, the Green

plane, and the Blue plane respectively.  Each resulting image is  displayed as an 8-bit grayscale image with the
gray value representing the luminosity or brightness of the respective color. The resulting images can be treated
as normal images: they can be saved as files, they can be edited, they can be filtered.  They can also be
recombined into an image using the Merge operations.

Split into CMY
This function operates like Split into RGB except that it creates three images containing Cyan, Magenta,

and Yellow information.

Split into CMYK
This function operates like CMY except that it creates four images containing color information for Cyan,

Magenta, Yellow, and Undercolor (gray or black).

MERGE RGB
Merge RGB will take three active images selected by the user and merge them into a single 24-bit RGB

image. These Merge operations work with images that are assumed to either be 1) monochome or 8-bit
grayscale, or 2) created previously using the above Separate filters. If the image used for the Merge function was
previously created with the Split function, it is an 8-bit grayscale image which represents the luminosity of its
respective channel ( Red, Green, or Blue). If the image is a color image, Merge will extract the appropriate
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channel from the image and use only that color information.  For instance, if an 8-bit color mapped image is
selected as input for Green,  the Green color information is extracted from that image and used in the Merge
operation.

MERGE CMY
Merge CMY will take three active images selected by the user and merge then into a single 24-bit image.

As with Merge RGB, it is assumed but is not necessary that the images used with Merge were created using a
Split operation. If the image used for the Merge CMY function was previously created with the Split function, it is
an 8-bit grayscale image which represents the luminosity of its respective channel ( Cyan, Magenta, or Yellow). If
the image is a color image, Merge will extract the appropriate channel from the image and use only that color
information.  For instance, if an 8-bit color mapped image is selected as input for Magenta, only the Magenta
color information is extracted from the image and used.  

MERGE CMYK
Merge CMYK will take four active images representing the four CMYK colors and will combine them to

create a single 24-bit RGB image. As with Merge RGB and Merge CMY, it is assumed but is not necessary that
the images used with Merge CMYK were created using a Split operation. If the image used for the Merge
function was previously created with the Split function, it is an 8-bit grayscale image which represents the
luminosity of its respective channel ( Cyan, Magenta, Yellow, or Black). If the image is a color image, Merge will
extract the appropriate channel from the image and use only that color information.  For instance, if an 8-bit color
mapped image is selected as input for Magenta, only the Magenta color information is extracted from the image
and used.  

SETUP
The operations in Setup allow the user to accentuate or deaccentuate individual colors for any CMY or

CMYK operation.  This process is a rough approximation to compensate for ink densities in the offset printing
process.  For instance, if the starting image was a 24-bit RGB image and the user wanted to boost the Cyan
when creating the 4-color separation, one would use Setup and set the Cyan Gamma value to some value
greater than 0.  The Cyan plane resulting from the operation would be brighter.  To lessen the brightness for a
color, one would choose a value less than 0.  Setup adjusts the colors for the following operations: CMY Filters,
CMYK Filters, Split into CMY, Split into CMYK, Merge CMY and Merge CMYK.  Because Setup will modify
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colors both splitting and merging an image, the values should be kept at 0 until a particular corrective operation
is performed.

Creative Ideas
The Separate operations can be used to create images with interesting and bizarre color combinations,

especially when used with other Conversion Artist operations. For instance,  false colors can be added to an
image by using Split, and recombining the colors using Merge, but mixing and transposing the color planes. Try
swapping Red for Green, and Magenta for Cyan. Other interesting effects can be created by Splitting and image,
applying filter effects and color reduction to one or more color channels, and recombining the respective colors
with Merge.  
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The Window Menu

Use the Window menu to arrange multiple windows for ease of viewing, to tidy up window icons, or to
close all open windows.  For more information about displaying multiple images, see Chapter 5.

Tile
Tile arranges all of the open windows such that all windows are visible and none are overlapping.

This is good for an overview of several images at once.

Cascade
Cascade stacks the open windows one on top of the other, like a deck of cards.  The title bar of each

window shows above the next one in the stack.  This option is good for flipping through a screenful of
images one at a time.

Arrange Icons
This option arranges any iconized windows at the bottom of the screen.

Close All
Closes all open windows.  Before closing them, Conversion Artist will ask the user whether to save

windows with images which have been altered since they were last saved.
(Shortcut:  If you hold down the Shift key while you click on "Close All," the query about saving

altered files will be overridden.  All windows will close, and no changes will be saved.)

Conversion Artist  Online Manual 94



The Help Menu

Index
Index gives you a list of topics available through online Help.

Using Help
Using Help gives you a help window which gives you information about using the online Help

subsystem.

System Info
System Info gives you a display with complete information about the current state of your system.  If

you are having any kind of a problem with Conversion Artist, the information provided by this option will
be invaluable for diagnosis.  If you need to call technical support, it will save a lot of time if you have a
record of all information provided under this option when you call.  
Use the Print button to print all System Info to the current printer or printer device.  Use the File button
to store all System Info in a specified file on your disk.

Windows
Version - Current version of Windows (3.0 or 3.1)
Path - Your Windows directory path (ex.  d:\windows)
System Path - Your Windows system directory path (ex. d:\windows\system)
Mode - Current mode of Windows; enhanced or standard

Memory/Resource
Largest Free Block - The largest currently-existent contiguous block of memory (not necessarily the

largest possible block).

Conversion Artist  Online Manual 95



Free System Resources - Percentage of free system (Windows) resources.  This determines how
many tasks can be going on at once; for example, how many windows can be open at once, how
many applications can be running, etc.

Free Local Resources - Percentage of memory resources available for Conversion Artist to utilize for
displaying windows, creating screen bitmaps, etc.

Free Memory - Total bytes of free memory.

Tasks
Tasks Running - Number of tasks currently running.  (Each application or utility generally equals one

task.)

Keyboard
Character Translation - Which alphabet is supported by the keyboard.
Keyboard Type - The make/type of the currently- installed keyboard.  (For example, IBM Enhanced)

DLL's
Function DLL's Loaded - Number of Function DLL's loaded currently.  (Function DLL's expand or in

some way change the functionality of Conversion Artist.)
Format DLL's Loaded - Number of Format DLL's loaded currently.  (Format DLL's add file formats to

Conversion Artist's import/export capabilities.)

Hardware
CPU - Type of central processing unit (80386, 80486, etc.)
Math Co-Processor - Present or Not Present

Disk
Temporary Disk Drive - Location of the disk drive in which Windows stores temporary files (i.e.,

d:\windows\temp).
.EXE Path - Location of the Conversion Artist executable file (i.e., c:\cnvart).

Display Device
Device Driver - ??
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Size - Size of your monitor (width X height, in millimeters).  These figures represent the dimensions
that Windows believes your monitor has.  They are not necessarily the actual physical
dimensions of the monitor (though they should be close).

Resolution - Width X height of your monitor in pixels (these figures are exact).
Bits Per Pixel - This number applied as an exponent of 2 gives the number of colors your display

device is capable of showing (i.e., if bits per pixel = 8, your monitor is capable of showing 256 (or
28) colors.  Your system's hardware determines this capability.

Color Planes - A multiplier for bits per pixel.  For example, if your device has 8 bits per pixel and 3
color planes, it is a 24-bit color device.

Device Brushes - Number of logical device brushes.  (Brushes are patterns of color.  They may be
pure colors or mixed, as in halftones.)

Number of Colors - ??
Palette Size - Number of colors in the device's palette, if it has one.
Reserved Colors - Number of colors reserved by the system (Windows), which cannot be changed.
Color Resolution - Physical resolution of the device.  For example, a 256-color VGA device uses 6

bits per color component (of which there are three); therefore its color resolution is 18 bits.
Raster Capabilities - A listing of your device's support for raster images:

Ras = raster-based device
Bnd = supports banding
Blt   = ability to transfer bitmaps
B64 = ability to transfer bitmaps larger than 64k
DIB  = supports device-independent bitmaps
Drw = supports device-independent bitmaps
Pal   = palette-based device

Printer/Screen
Choose Screen or Printer to change the Display Device information above.

Mouse
Mouse - Present/Not Present
Double-Click Time - In milliseconds.  This value may be set using the Control Panel in the Windows

Program Manager.

About Conversion Artist...
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This item gives you a short message about the program and about North Coast Software, Inc.
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4.   Import/Export File Formats
BIT - Lotus

IMPORTING:
BIT is a monochrome format.  No file compression is available for BIT images.

BMP - OS/2
IMPORTING:

The OS/2 operating system supports monochrome, 16 colors, 256 colors, and 24-bit color.  Files have
.BMP or .DIB extensions.
EXPORTING:

Conversion Artist exports monochrome, 16-color, 256-color, and 24-bit color OS/2 BMP files.  Files are
always uncompressed.

BMP - Windows
IMPORTING:

The Windows bitmap format supports monochrome, 16 colors, 256 colors, and 24-bit color.
EXPORTING:

Conversion Artist exports monochrome, 16-color, 256-color, and 24-bit Windows bitmaps.  Windows
BMP files are always uncompressed.

CE - Computer Eyes
IMPORTING:

This file format is used by the Computer Eyes line of video products.  Conversion Artist loads
256-color CE images.  Files are always compressed.

CEB - Continuous Edge Bitmap (for users of CEG video boards)
IMPORTING:

For CEG users only:
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If you create bitmaps under Windows while using a CEG board, we recommend that you rename them
with the "CEB" extension.  Since these bitmaps will include information that is dependent on your CEG
device, it is misleading to call them "DIBs" (device-independent bitmaps).  CEB bitmaps are
device-dependent bitmaps for CEG boards which contain all the information a DIB would contain, but are
customized for the capabilities of a CEG board.  Any application that accepts DIBs or BMPs will accept
CEB bitmaps, and will display the bitmaps using CEG colors.
EXPORTING:

You can convert files to the CEB format to create CEG-compatible bitmaps for use with your CEG
board.  Though a CEB file can be in any of the four CEG color configurations, you can only view the
700-color format under Windows (since this is the only format for which a Windows driver exists).  If you
try to view a file in a higher-color CEG format under Windows, you'll only see 16 colors.  To view
higher-color CEG images in full color, use the SHOWCEG DOS viewer included with Conversion Artist.

Conversion Artist can export CEB files in any of the four CEG color formats:  700, 2048, 7000, or
700,000 colors.

CEB files can be compressed, but because of the nature of the format, the amount of compression
may not be very substantial.

CEG - Edsun Continuous Edge Graphics
IMPORTING:

CEG is a special format by the Edsun Group at Analog Devices.
The 4 CEG subformats:

1)  700 colors (Windows mode)
2)  2,048 colors
3)  7,000 colors
4)  700,000 colors

If you have a CEG board:
Currently, a Windows driver exists only for the 700-color CEG mode.  You may only display

higher-color CEG subformats in full color using non-Windows applications (like the "Show CEG" DOS
application included with Conversion Artist).  If you display a higher-color CEG image under Windows, it
will be displayed in only 16 colors.

If you do not have a CEG board:
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You may still view CEG images.  These images will be displayed according to the color capabilities of
your device and your Windows driver.  If, for instance, you have a 16-bit Sierra DAC board (which can
display 32,768 colors under Windows), then you will be able to view all CEG subformats under Windows,
at a maximum of 32,768 colors per image.  If you have a 256-color board, you will also be able to view all
CEG subformats under Windows, but at a maximum of only 256 colors.
EXPORTING:

Conversion Artist can export to all 4 CEG subformats.  No file compression is available for CEG files.

CLP - Windows Clipboard  files
IMPORTING:

Windows Clipboard files can contain many different types of Clipboard information.  Conversion Artist
supports loading Clipboard files which contain:  device-dependent bitmaps, device-independent bitmaps,
and/or metafiles.  The Windows metafiles are loaded using the information contained in the Settings dialog
box (under the File menu) for sizing and palette matching.

Conversion Artist can only load device-dependent bitmaps that are compatible with the current device.
For example, if you created a bitmap with a 16-color VGA device, you would not be able to load this file
using a 256-color VGA device.

If you are using a 256-color device, please see the section, "Clipboard Files" under Device
Dependency: Issues and Information  in Chapter 5 for more information about using Clipboard files.  

CUT - Dr. Halo
IMPORTING:

Conversion Artist supports loading of monochrome and 16-color CUT files.

CVP - Kodak's Color Video Printer
IMPORTING:

CVP is a 24-bit "True Color" format.
EXPORTING:

The CVP format supports only 24-bit color.  CVP files cannot be compressed.
Files in the CVP format are always 512 x 512 pixels.  If the original image was larger than 512 x 512, it

will be truncated.  If it was smaller, the extra space will be filled with white.
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DIB - Windows
IMPORTING:

The Windows DIB (device-independent bitmap) format supports monochrome, 16 colors, 256 colors,
and 24-bit color.
EXPORTING:

Conversion Artist exports monochrome, 16-color, 256-color, and 24-bit color Windows DIB files.  The
user can set the compression state for monochrome, 16-color and 256-color DIBs.  24-bit DIBs cannot be
compressed.

EPS - Encapsulated PostScript
EXPORTING:

EPS is the only file format that Conversion Artist exports but does not import.
EPS is a format used by certain printing devices and desktop publishing programs.  If you are printing

to a black-and-white PostScript printer, you should convert your image to grayscale before printing.  If you
are printing on a color PostScript printer, you should convert your image to color before printing.  You can
use the Colors Menu to convert to color or to gray.

Five color configurations are possible when writing PostScript images:  monochrome, 16-color,
256-color (color mapped), 256-color (grayscale), and 24-bit.

EPS files cannot be compressed.

GEN - Generic binary format
IMPORTING:

GEN is a 24-bit generic format.
EXPORTING:

The GEN format supports only 24-bit color.  GEN files cannot be compressed.

Specifications for GEN:  GEN has a variable-length ASCII header which lists the dimensions of the bitmap
(width, then height).  The header is followed by a line feed (ASCII 10), then the image data.

1st line: <ASCII Width> <space (ASCII 32)> <ASCII Height>
<lf (ASCII 10)>

Next lines: <image data>
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Image data is binary RGB, one full byte per color component.  The origin of the data is the lower
left-hand corner of the image, so the last image line comes first in the GEN file.

Each line of the data is only byte-aligned.  No other alignment is required, so no pad bytes should be
inserted.  The size of the image data will therefore be:  Width * Height * 3.  The size of the entire file will be
the size of the image data plus the size of the header.

Example GEN file:

--------- start of file ---------
5 6
rgbrgbrgbrgbrgb
rgbrgbrgbrgbrgb
rgbrgbrgbrgbrgb
rgbrgbrgbrgbrgb
rgbrgbrgbrgbrgb
rgbrgbrgbrgbrgb
--------- end of file ----------

Note:  In an actual GEN file, there would not be line feeds at the end of each row of data.  These were
included here for clarity in the example.

GIF - Graphics Interchange Format
IMPORTING:

The GIF format supports monochrome, 16 colors, and 256 colors.  GIF files can be interlaced or
non-interlaced (Conversion Artist loads both types).
EXPORTING:

Conversion Artist can write monochrome, 16-color and 256-color GIFs.  GIF files are always
compressed.

HEX - Generic hexadecimal  format
IMPORTING:

HEX files can be monochrome, 16 colors, 256 colors, or 24-bit color.
EXPORTING:
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HEX files can be written in monochrome, 16-color, 256-color, or 24-bit color.  HEX files are always
uncompressed.

Specifications for HEX:
<File> = <TagList>
<TagList> = <Tag>+
<Tag> = <TagName> [<Data Descriptor>] <Data>
<TagName> = ("WIDTH" | "HEIGHT" | "BITSPERPIXEL" |

"COLORMAP" | "IMAGE" )
<Data Descriptor> = ( "B" | "D" | "H" )
<Data> = (raw ascii data)

Comments:
* The image is processed in one pass, so IMAGE must be the last tag.
* The data descriptors are:

"B" Binary
"D" Decimal (default)
"H" Hexadecimal

* Fields are separated by a blank line. 
* Data that is in "D" (Decimal) format must be seperated by white-space (<tab>, <space>, <cr>).  The other

data formats may be packed together without white-space if desired.
* If an unknown field is encountered it is parsed and ignored.
* If there is no "COLORMAP" Field, and there is a "BITSPERPIXEL" field, assume a gray-value image.
* "BITSPERPIXEL" can have the values "1", "4", "8", "24".  If no "BITSPERPIXEL" field, assume 8 bits per

pixel.
* Any text coming after a semi-colon ";" (to the end of the line) is a comment.
* The following characters are ignored (except as mentioned above):

Char Ascii
===================
<tab> (ascii  9)
<lf> (ascii 10)
<cr> (ascii 13)
<space> (ascii 32)

* Colormaps are always defined in a 24-bit format (RGB), 8 bits per color component.
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* Width and height are defined at the pixel level (ie. number of pixels the image is wide and high).  Maximum
value = 32768.

* IMAGE data is assumed to be byte-aligned.  Example:  If your BITSPERPIXEL tag is "1" and your WIDTH
is "13," then there would be two bytes for each line of the image.  This way you never have to worry
about partial bytes.

Example HEX file:

---------- start of file ----------

WIDTH 16 ; width  = 16
HEIGHT 16 ; height = 16
BITSPERPIXEL 4 ; bits per pixel = 4, 16 colors.

COLORMAP H
00 00 00  ; black
80 00 00  ; dark red
00 80 00  ; dark green
80 80 00
00 00 80  ; dark blue
80 00 80
00 80 80
c0 c0 c0  ; light gray
80 80 80  ; dark gray
ff 00 00  ; red
00 ff 00  ; green
ff ff 00
00 00 ff  ; blue
ff 00 ff
00 ff ff
ff ff ff  ; white

IMAGE H
0000 3f2f 4623 0000
3f2f 4623 f346 263f
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4623 f346 263f 62f3
f346 263f 62f3 62f3
263f 62f3 62f3 f126
62f3 62f3 f126 3f26
62f3 f126 3f26 3f2f
f126 3f26 3f2f 4623
3f26 3f2f 4623 f346
3f2f 4623 f346 263f
4623 f346 263f 62f3
f346 263f 62f3 62f3
263f 62f3 62f3 f126
62f3 62f3 f126 3f26
62f3 f126 3f26 3f2f
0000 3f26 3f2f 0000

---------- end of file ----------

IFF - Amiga/Video Toaster
IMPORTING:

Subformats supported are:  standard IFF with color map, HAM, and 24-bit color.  The 24-bit subformat
is compatible with NewTek's Video Toaster.  

IMG - Aurora (Data Translation)
IMPORTING:

Aurora IMG is a 24-bit format.  Conversion Artist supports loading of both RGB and HSI-type Aurora
files.
EXPORTING:

Aurora IMG files are always exported as 24-bit RGB, never as HSI.  Files are always uncompressed.

IMG - DT-Iris (Data Translation)
IMPORTING:

DT-Iris IMG supports 256 colors (grayscale only).
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EXPORTING:
The DT-Iris IMG format only supports grayscale.  Files are always uncompressed.

IMG - Ventura
IMPORTING:

Ventura IMG supports monochrome, 16 colors, 256 colors (grayscale images only), and 24-bit color.

JPG - JPEG Compression

Images can be saved with JPEG in two ways.  
The first way is to simply save an image in the JPEG format with the JPG extension.  The second way
creates a self-decompressing, self-displaying Windows application with an EXE extension.

What is JPEG?
JPEG is a new high-compression technique for color and grayscale images.  JPEG can be used

to compress images from one-third to one-fortieth of their original size.  It is especially useful for images
with a lot of color and detail.  JPEG provides good compression where non-lossy compression
techniques (such as Run-Length Encoding or LZW) do not perform well.

Compressing a file with Conversion Artist  JPEG Compression 
PLEASE NOTE:  JPEG is a "lossy" compression technique.  If you are not familiar with JPEG
compression, you are advised to read the sections, What is lossy compression? and Using JPEG
Compression before performing JPEG compression on any of your files.

To use JPEG compression in Conversion Artist:
Method 1

1.  Open (load) the file you wish to save as JPEG-compressed.
2.  Choose Save As... from the File menu.
3.  Look in the file formats list (click on the down-arrow button at right for a complete listing of file

formats) and click on the item:
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JPG - JPEG Compression
4.  A dialog box will appear.  Use this box to set the JPEG Quality setting.

The JPEG Quality setting can be any number from 1 to 100.  (In general, the higher the quality
setting (100 being highest quality), the lower the compression rate, and as the quality setting number
is lowered, the compression rate will rise.  Please read the sections What is lossy compression?
and Using JPEG Compression before performing JPEG compression on your files!)

FIGURE JPG-1
THE JPEG QUALITY SETTING DIALOG BOX

Method 2
1.  Open (load) the file you wish to save as JPEG-compressed.
2.  Choose Save As... from the File menu.
3.  Look in the file formats list (click on the down-arrow button at right for a complete listing of file

formats) and click on the item:
EXE - JPEG Run Time Format
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4.  A dialog box will appear.  Use this box to set the JPEG Quality setting, the Save As option, and the
About text.

The JPEG Quality setting can be any number from 1 to 100.  (In general, the higher the quality
setting (100 being highest quality), the lower the compression rate, and as the quality setting number is
lowered, the compression rate will rise. We recomend the quality setting of 100 for general use, although
the setting of 75 provides excellent compression with only some loss.  Checking the Save As box creates
a menu item in the newly created JPEG applet. This menu item allows the user to save the
decompressed 24-bit image as a DIB file after running the JPEG applet.  If this item is not checked when
the EXE file is created, the menu item does not appear.  Checking the About box allows you to type text
into the About text box.  The text appears in the About menu item in the EXE file.  About text allows you
to add copyright notices, creation information, or other important information to the image.  This is
especially useful for people who want to distribute images and want to include important text.
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FIGURE JPG-2

What is lossy compression?
When an image is compressed with JPEG, it is changed slightly.  This means that when the file is

decompressed, the image's appearance will also have changed.  This is known as "lossy" compression,
since some information is lost in the course of the compression operation.

The amount of change, or image loss, depends on the JPEG Quality setting used when compressing
the file.  If the JPEG quality setting is high (highest setting = 100), these changes will probably not be
noticeable to the human eye.  If the quality setting is lower, these changes become more noticeable.
With a quality setting of 50, for example, JPEG losses would be noticeable as small dots and a slight
fuzziness near edges within an image.  With a lower quality setting, the losses will become very
noticeable and will appear as fuzziness and small blocks.

Using JPEG Compression
Because JPEG may change an image, you should investigate its effects before deleting the original

image.  If you require high quality (very little loss but low compression rate), you should use a quality
setting of 100.  Save the image in the JPEG format (see the section above, Compressing a file with
the Conversion Artist JPEG Compression Module,  for the procedure), reload it, and examine the
effects of JPEG compression.  If the losses are too noticeable, you should not use JPEG for
compression, but rather save the file in the TIFF format with LZW compression.  This compression
technique is not lossy and therefore will not change the image.

For typical use, a JPEG quality setting of 80 will give you a good balance between high quality and
high compression rate.  Very high compression rates can be achieved by choosing a low quality setting.

Actual compression rates will depend on the character of the image being compressed.  As an
example, scanned photographs will typically compress to between one-third and one-fifteenth of their
original size with a JPEG quality setting of 100.

JPEG Performance
The JPEG algorithm requires computation and will take three to four times longer than a

compression technique like LZW.  JPEG does not require a math co-processor but may run slightly
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faster with one.  If you are working with large images and notice a lot of activity on your hard disk, this
may indicate that you need more system RAM.  (Consult Chapter 1 of the Conversion Artist User
Manual for suggestions on conserving memory and speeding things up.)

There are specialized hardware accelerators which can greatly speed up JPEG.  The Conversion
Artist JPEG module does not require any such specialized hardware but will read and write JPEG images
which are compatible with most of these accelerators.

Problems you may encounter when using JPEG

Out of memory
Large, high-color images require lots of memory.  To decompress a JPEG image, you must have

enough memory to hold the original image.  The upper limit for the file size that Conversion Artist or the
JPEG module can handle is 16 megabytes.  (Consult Chapter 1 of the Conversion Artist User Manual
for suggestions on how to conserve memory.)

Out of disk space
If you run out of disk space while saving a JPEG image, you must use DOS or the File Manager to

delete files or otherwise create space for your JPEG image.

Cannot read a JPEG image
Conversion Artist JPEG uses the industry standard JFIF JPEG file format.  Although this format is

widely used, not all software products have made the change to this standard.  If Conversion Artist fails
to read a JPEG image which was created by another product, you should make a copy of the image on a
floppy disk, include information on how to contact the product's manufacturer, and send the floppy disk
to:

North Coast Software, Inc.
Technical Support
P.O. Box 459
265 Scruton Pond Road

` Barrington, NH  03825

Images can only be accepted on floppy disks.
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Macintosh QuickTime JPEG
Some JPEG images created on a Macintosh contain a 128-byte header.  These images cannot be

read by this version (1.0) of Conversion Artist JPEG.

This software is based in part on the work of the Independent JPEG Group.
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LBM - Deluxe Paint
IMPORTING:

Conversion Artist supports loading of 256-color LBM files.

MCP - MacPaint
IMPORTING:

MCP is a monochrome format.  MCP files have either a MacBinary header or no MacBinary header
(Conversion Artist loads both types).  Files are a fixed size, 576 x 720 pixels.

MSP - Microsoft Paint
IMPORTING:

MSP is a monochrome format.  Microsoft Paint Version 1 files are always uncompressed, and
Microsoft Paint Version 2 files are always compressed.  Conversion Artist loads both types.

PCC - PC Paintbrush Clipboard files
IMPORTING/EXPORTING:

For information on PC Paintbrush files, see file format PCX below.

PCT - Macintosh Color Bitmap
IMPORTING:

Conversion Artist supports loading of PICT 2 raster files in monochrome, 16 colors, and 256 colors,
and 24-bit color.

PCX - ZSoft PC Paintbrush
IMPORTING:

PCX supports monochrome, 16 colors, 256 colors with implicit gray palette, 256 colors with palette,
and 24-bit color.
EXPORTING:
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Conversion Artist exports monochrome, 16-color, 256-color, and 24-bit color PCX files.  PCX files are
always compressed.

PPM - Unix Portable Pixmap
IMPORTING:

Conversion Artist supports loading of 24-bit PPM files.  It also supports loading of 256-shade grayscale
PGM files.

RAS - Sun Raster
IMPORTING:

RAS supports monochrome, 256 colors (with optional palette), and 24-bit color.
EXPORTING:

Conversion Artist writes monochrome, 256-color and 24-bit color RAS files.

RGB- Silicon Graphics
IMPORTING:

Conversion Artist supports loading of 256-shade grayscale and 24-bit color RGB files.
EXPORTING:

Conversion Artist writes 256-shade grayscale and 24-bit color RGB files.

RLE - Compressed Windows Bitmap
IMPORTING:

The Windows RLE format supports monochrome, 16 colors, and 256 colors.
EXPORTING:

Conversion Artist exports monochrome, 16-color, and 256-color RLE files.  Windows bitmap files with
the RLE extension are always compressed.

SVW - Super Video Windows
IMPORTING:

SVW files are stored in a special format which is optimized for storing video images.  They are loaded
into Conversion Artist as 24-bit images.
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TGA - Targa
IMPORTING:

TGA supports 256 colors with implicit gray palette, 256 colors with palette, 16-bit, 24-bit, and 32-bit
color.
EXPORTING:

Conversion Artist exports 256-color, 16-bit, 24-bit, and 32-bit TGA files.  The user can set the
compression state for Targa files.

TIF - Tagged Image File Format
IMPORTING:

The TIFF format is a very complex format with many different components.  You may find that some
applications will not accept TIFF images created from other sources.  This is because many applications
will read or write only a few TIFF subformats.

Conversion Artist can read a large majority of TIFF files.  It follows the TIFF 5.0 specifications but is
compatible with most earlier versions as well.  Conversion Artist is equipped to deal with certain common
deviations from TIFF 5.0 specifications in an effort to load as many TIFF images as possible.

TIFF supports monochrome, 16 colors, 256 colors, 16-bit, 24-bit, and 32-bit color.  Conversion Artist
supports TIFF files with palettes or no palettes; Motorola or Intel-style TIFFs; planar and non-planar color
configurations; multiple samples per pixel; and multiple bits per sample.
EXPORTING:

Conversion Artist writes TIFFs according to the TIFF 5.0 standard.  Monochrome, 16-color, 256-color,
16-bit, 24-bit, and 32-bit color files may be exported.

The user can set the compression state for TIFF files.  In fact, the user can set a different compression
algorithm for each different color configuration by using the "TIFF Compression" group in the Settings
dialog box under the File menu.  Compression for 32-bit TIFFs will be set to be the same compression
format as that of 24-bit TIFFs.

Several different file compression algorithms are supported:  LZW and RLE (PackBits) for all color
types.  Group 3 (CCITT Fax 3) and Group 4 (CCITT Fax 4) are also available for monochrome.

WMF - Windows Metafile
IMPORTING:
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To scale the display size of WMF files, use the Metafile Options group in the Settings dialog box under
the File menu.

For 256-color device users:  By default, Windows will use only 16 colors when drawing a metafile on a
256-color device.  However, there is a Conversion Artist setting that will cause a custom palette to be
created for the metafile.  This will generally produce a much better-looking image.  To activate this option,
look under Metafile Options group in the Settings dialog box under the File menu, and choose Custom
Palette.

The WMF format is the standard metafile format for Microsoft Windows.  Metafiles are created and
saved in device-independent fashion; however, they are loaded in device-dependent fashion.  Though
Conversion Artist makes every effort to deal with device-dependency issues, you may nevertheless run
into this type of problem.  For example, if you save a WMF file on one device and load it on another,
colors might be different; circles or squares might look like ovals or rectangles; lines might be of a length
different from the original.  Furthermore, if a metafile is created on a higher-color device than the one used
to load it, color information will be lost when the file is loaded.  Also, if the metafile was created before
Windows support of scalable fonts (pre-version 3.1), you may have problems with fonts if you scale the
metafile.  (See Chapter 5 for more information on metafiles and device dependency).

WPG - WordPerfect Raster format
IMPORTING:

The WPG format supports monochrome, 16 colors, and 256 colors.
WPG files come in two types:  raster and metafile.  Conversion Artist loads WPG raster files.

EXPORTING:
Conversion Artist exports monochrome, 16-color, and 256-color WPG files.  Files are always

compressed.
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5.   Special Topics
Graphics File Types

Bitmaps

Conversion Artist works mainly with bitmap images.  Bitmaps are also known as raster images or
pixmaps (pixel maps).  A bitmap is composed of a matrix of pixels, or color elements.  Each pixel has a
color value, such as green, black, white, magenta, etc.

Although the concept of a bitmap is simple, there are many possible ways of implementing bitmaps
on computers.  Currently, there is no industry-wide standard for implementation of bitmaps, and therefore
each company generally comes up with its own format.  Depending on the format used, a bitmap may
contain from two colors to 16 million colors; it may be compressed using one of several different
compression algorithms, or it may be uncompressed; it may also contain extra information like date of
creation, or the application in which it was created.

This disparity and incompatibility among bitmap image formats can be a big problem for someone
who doesn't wish to buy every image-generating program on the market, but would still like to be able to
transfer images between programs.  Conversion Artist was created to help solve this problem.

Metafiles
A metafile uses a very different means for storing graphic information than does a bitmap.  Instead

of storing different-colored pixels which together make up the image, a metafile contains a list of
instructions for how to draw the picture.  For instance, a metafile could contain commands for drawing
circles, lines, filled rectangles, points, text, etc.  The disadvantage of metafiles is that they require
complicated interpreters to draw them.  However, there are some significant advantages to using
metafile formats.
  Metafiles are useful because they can draw and scale images (redraw them at different sizes)
without producing the jagged lines often seen in enlarged bitmaps and low-resolution displays.  Metafiles
can also be much more efficient in terms of disk space.  For example, imagine a 24-bit color, 512 x 512
bitmap image of a circle.  This file would take up over 700K to store as an uncompressed image.  The
equivalent image stored as a metafile would be the size of one drawing command, certainly less than 1K!

One thing to bear in mind when using metafiles is that some metafile manufacturers may use a very
different resolution than that of your screen.  This may result in metafiles that turn out to be extremely
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large when you attempt to display them.  Metafile size may be adjusted (see Settings under the File
menu).

Conversion Artist imports the Windows Metafile format (WMF), and it exports the Encapsulated
PostScript format (EPS) and color EPS.

Colors and Color Reduction
This section offers discussions about many aspects of colors and color information, including color

reduction, dithering, palettes, display devices, and storing color information.  This information will help you to
customize your use of Conversion Artist's sophisticated capabilities for your particular system and needs.

Methods of Color Reduction
 Reducing the number of colors in an image can be valuable for many reasons.  High-color images
require a lot of disk space, so reducing the number of colors is one way of saving space.  Also, many
output devices have a rather limited number of colors available for display, and using color reduction
with dithering can vastly improve the appearance of high-color images on these types of boards. 

Conversion Artist has two methods available to reduce the number of colors in an image:  Flat Cut
and Optimized Cut.  Note:  It is important to realize that when a color reduction is performed on a
high-color image, color information is lost (discarded) at that point.

Flat Cut can be used to reduce colors to 16-bit color (32,767 colors), 256 colors, 16 colors or
monochrome.  It uses a simple algorithm for color reduction, creating a uniform distribution of colors
across the visible spectrum.  It then uses this set of colors and matches them as closely as possible to
the image's original colors.

Optimized Cut can be used to reduce to 256 or 16 colors.  The Optimized Cut algorithm may produce
results far superior to the Flat Cut algorithm (depending on the image).  Optimized Cut is a method to
determine the most important colors in the particular image you're working with.  It creates a custom
palette which will optimize the appearance of that certain image.  

Dithering
Dithering is an extremely useful tool for color management.  It can be used with both the Flat Cut

and Optimized Cut methods of color reduction.
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In a nutshell, dithering increases the apparent number of colors in an image by reducing the
apparent resolution  of the video screen.  How does this work?  Dithering uses patterns of
different-colored pixels which cause you to perceive a blended color.  For example, an area filled with an
alternating pattern of red and blue pixels will be perceived as being purple.  Therefore, the image
appears to have more colors than it actually contains.  The flip side of using this technique is that the
"purple" area will appear slightly more blurry or grainy to you than if it were composed of truly purple
pixels.

Palettes
A palette is an assortment of colors that can be used to draw an image.  There is an important

distinction between a device palette and an image which has a palette  included in its information.
A device palette is a palette of colors that a particular device has available for use in displaying

images.  If the device's palette is fixed, the colors must be chosen from the same palette for any image
displayed.  If the device's palette can be set, then there is more flexibility in choosing colors.

An image may have a palette included in its information.  This means that the palette of colors used
in the image is actually encoded into the image's data.

The distinction between the device palette and an image's palette may be illustrated in this example.
Suppose you have an image which is drawn in sixteen shades of blue.  The image's palette, which is
included in the data, consists of these sixteen different blues.  Now imagine you have a device which has
a fixed 16-color palette, which includes colors evenly distributed over the range of the visible spectrum.
When you display the image on this system, the device can use only the shades of blue in its fixed
palette (in a standard 16-color palette, there would be two shades of blue to choose from).  It will display
the image using only its palette's two blues.  Obviously, the image's appearance will have deteriorated.
(However, no color information has been lost, since the information was encoded in the image itself.  It is
only the display device's limitations that have affected the image's appearance.)

Now, imagine that you display the same image using a device with a 16-color custom palette.  Since
the colors in a custom palette can be set, the device can accommodate our image by setting its own
palette to the sixteen blues in the image's palette.  In this case, the display device can take full
advantage of the image's palette information and can show the original colors accurately.

It should be mentioned here that Windows does not support a custom palette for 16-color devices.
However, there are non-Windows applications that do support 16-color custom palettes.

Conversion Artist can create custom palettes for images using the Optimized Cut color reduction
algorithm.  Optimized Cut and the other color reduction algorithm, Flat Cut, are described in the
"Methods of Color Reduction" section.
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How Color Configurations of Display Devices  Affect Color Reduction
In this discussion, we emphasize the impact that your device's color configuration has on your choice

of color reduction methods.

Monochrome
Monochrome is otherwise known as black-and-white.
Since monochrome displays have only two colors available, there's a very limited amount of

subtlety you can achieve in displaying images.  The Flat Cut color reduction algorithm is sufficient for
any reduction to monochrome.

16 Colors
If you're running Windows and have a 16-color board, the palette is fixed.  However, some

non-Windows programs have custom 16-color palettes.  You can take advantage of that capability by
using Optimized Cut and then transferring the color-reduced image into the other program for
viewing.

If you want to use Windows and display an image that originally had more than 16 colors, you
will get the best possible results if you use Flat Cut with Dither when converting the image to 16
colors.

256 Colors
When you are running Conversion Artist with a 256-color video board and Windows driver, 256

colors are available for any and all images being displayed at any one time.  With the Optimized Cut
color reduction algorithm, Conversion Artist can custom-set the 256 palette colors to conform to a
particular image's original colors, so as to produce the best-looking image possible.  Dithering will
also improve the image's appearance.

If you use Flat Cut color reduction, the new palette will be composed of 256 colors evenly
spaced throughout the visible spectrum.  Depending on what you intend to use your image for, this
may be the option you want (though generally a custom palette will produce a better-looking image).
You may also use dithering in conjunction with Flat Cut to improve the image's appearance.

If you use the Optimized Cut algorithm to reduce an image's colors, it may look slightly different
if you display it under Windows than if you display it with a non-Windows application.  This is
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because Windows reserves 20 colors of the 256-color palette for its own use.  Since these 20 fixed
colors will likely not be included in the custom 256-color palette of the image, they will "bump" some
of the custom colors, and your image will look a little different.

16-Bit Color ("High Color")
If you're using a 16-bit board (sometimes known as a "high color" board), you have over 32,000

colors available for display.  16-bit images do not have palettes; therefore, only the Flat Cut option is
available.  Conversion Artist supports two 16-bit formats:  Targa (TGA) and TIFF.

24-Bit Color ("True Color")
"True Color" 24-bit boards can display 16.7 million colors.  The human eye can only distinguish

about 9 million colors, so these boards essentially have all perceivable colors available for display.
Conversion Artist supports 15 True Color formats.  They are:  Targa (TGA), TIFF, Video Toaster IFF,
PCX, Windows DIB/BMP, OS/2 BMP, Kodak CVP, Sun RAS, Color PostScript (EPS), Unix PPM,
Macintosh PCT, Silicon Graphics Iris (RGB), Data Translation Aurora (IMG), Ventura IMG, and the
GEN/HEX generic formats.

32-Bit Color
32-bit images include an extra 8 bits of information which involves alpha channels.  Alpha

channeling is a sophisticated image generating technique which essentially makes portions of an
image "clear," so that another image or a background can show through.  When a 32-bit image is
loaded into Conversion Artist, these 8 bits are nullified; therefore, a 32-bit image in Conversion Artist
actually contains no more information than a 24-bit image.  Conversion Artist supports two 32-bit
formats:  Targa (TGA) and TIFF.

Using Multiple Documents

The Windows Multiple Document  Interface

The Windows Multiple Document Interface (MDI) is a standard means of viewing and managing a
number of windows simultaneously.
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An important part of this interface is the Windows menu.  After opening and creating several
images, each in its own window, you can use the commands in the Windows menu to manage these
multiple images:

The Tile command arranges all open windows such that all are visible and none are overlapping.
The Cascade command stacks all open windows, so that each window's title bar is visible (somewhat

like a deck of cards).
The Arrange Icons command takes any iconized windows and arranges their icons at the bottom of

the screen.
The Close All command closes all open windows.  If an image in a particular window has been

changed since it was opened or created, you will be prompted to save the image to a file before closing.
(This prompt can be overridden by holding down the Shift key while clicking on Close All.  No changes to
the image will be saved.)

Display Considerations for 256-Color Boards
When you are running Conversion Artist with a 256-color video board and Windows driver, 256

colors are available for any and all images being displayed at any one time.  However, even with 256
colors, you can run into problems if you decide to display two (or more) 256-color images which do not
have the same 256 colors.  In this case, of course, there are more than 256 colors included in all the
images together, and your system must figure out how to display the extra colors.
  Conversion Artist solves the problem by using the optimized palette for the image in the active
(top) window .  Then it attempts to match the extra colors in the other windows to the 256 colors of that
palette.  When the extra colors are not a good match, the images will look odd.  One remedy to this
problem is to iconize all of the images except the one that you are interested in viewing at that particular
time.  Another remedy is to use the Cascade command in the Windows menu to hide all the images but
the top one.  Then you can flip through the images and each one in turn will be shown with its optimized
palette in place.

Another consideration is that the colors in the "wallpaper" (the background colors behind your
application window) are included in the 256 colors that can be displayed, and thus can rob colors from
your 256-color images.  You should maximize the Conversion Artist window so that no wallpaper is
visible, or use a wallpaper that does not have a palette.

Device Dependency:  Issues and Information
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Differences among devices and media become important issues to deal with when you're working with
graphics.  You need to be aware of these issues if you plan to transfer images among devices that vary in
their color support or resolution, or if you plan to print graphic images.

Clipboard Files
You may run into a problem with device dependency if you use Clipboard files (.CLP files) to transfer

images between devices.  Some formats create device- dependent bitmaps (DDBs).  As the name
implies, this type of bitmap includes information that is only compatible with a particular type of device.
If you cut or copy a device-dependent bitmap to the Clipboard and save it as a .CLP file, and then you
try to transfer the .CLP file to a different type of device, you may not be able to view it.

Color Support
One parameter that varies greatly among display devices is color support.  Display devices can

support anywhere from two (monochrome) to 16.7 million (24-bit) colors.  You can imagine that
transferring files between devices that support different numbers of colors can create problems.  As one
example, if a picture created with a device that supports 256 colors is viewed on a 16-color video board,
it will likely contain inaccurate colors and banding.

Windows Metafiles (.WMF)
An important point should be made regarding loading images which are in the Windows metafile

format.  Windows metafiles are created in a device-independent fashion, but they are loaded in a
device-dependent fashion.  Thus, if a Windows metafile image is created on a 24-bit color device and
then loaded on a 256-color device, information will probably be lost at the point of loading.

Some manufacturers of metafiles may use resolutions that are vastly different from your screen
resolution.  When you attempt to display such images, you may find that they are much too large to
display on your screen.  Use the Metafile Options group under Settings in the File menu to scale the size
of such metafiles.

If you are using a 256-color device, you should consider activating the Custom Palette  option in
Metafile Options.  If this option is not selected, Conversion Artist will use the standard 16-color system
(Windows) palette a dither the image when drawing the metafile.  If the Custom Palette option is
selected, Conversion Artist will create a custom 256-color palette for that specific metafile.  This should
result in a much-improved metafile appearance.
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Differences in Resolu tion and Aspect Ratio
Another issue to consider is differences in resolution among devices.  An image which takes up the

entire screen on a video monitor with a resolution of 70 dots per inch may be only three inches wide
when printed on a laser printer at 300 dots per inch.  A related issue is differences in aspect ratio (the
ratio of pixel height to pixel width).  Pixels can appear somewhat rectangular on some devices; a square
drawn on such a device may not look like a square, though the number of pixels on each side is actually
the same.

Color Creation:  Light vs. Ink
When printing images, more problems may surface because of the different mechanisms for creating

colors between video monitors (using light) and printing on paper (using ink).  The same image may look
very different on a video screen than when it's printed on paper.  Video monitors use an additive method
of color creation, using red, green, and blue light to create all of the other colors in the visible spectrum.
Printing uses a subtractive method of color creation, with layers of cyan, magenta, yellow, and black ink
mixing to create all other colors.  On an more elementary level, it's clear that if the red of one device
looks different from the red of another device, then all the different saturations (shades) of that color will
look different as well.

File Compression
Conversion Artist supports many different kinds of graphics file compression.  In most cases, an image's

specific file format dictates which compression algorithm Conversion Artist must use when saving the file in
compressed form.

The one exception to this rule is the TIFF format.  You have an option to set the default compression
algorithm that will be used when you save a TIFF file in compressed format (use the Settings dialog box
under the File menu to change the default TIFF compression algorithm).  You may find this handy if you will
be using the compressed images with another program that recognizes only certain types of compressed
files, or if your disk space is of paramount concern and you need to be sure you're using the most efficient
algorithm.

The compression algorithms used by Conversion Artist can be discussed in terms of two basic types:

LZW (Lempel, Ziv & Welch)
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RLE (Run-Length Encoding)

LZW - Lempel, Ziv & Welch
LZW encoding is a very efficient compression technique.  It requires more computation time than

RLE, but generally produces better compression results.
LZW works by constructing a tree of color patterns that are used in the image.  Thus, if a pattern

recurs, no matter how complex, it can be encoded in an extremely simple form.  For example, if the
image has a color that's created by using a pattern of different-colored pixels (such as alternating red and
yellow pixels for an orange area), LZW would produce good compression results.

LZW may be specified for TIFF files by using the TIFF Compression group in the Settings dialog box
under the File menu.

RLE - Run-Length Encoding
This type of encoding is very quick and produces good compression results when your image has a

lot of runs of same-color pixels and not much detail.  For instance, say you have an image which has a
run of 100 red pixels on one of its lines.  In raw form, it would take 100 memory locations to store the
information in those pixels.  In RLE, the pixels would be stored as (essentially) "100 red," taking up only
two memory locations, resulting in an enormous reduction in data size.

RLE compression is used for Targa and DIB files.  RLE (PackBits) compression may be specified for
TIFF files by using the TIFF Compression group in the Settings dialog box under the File menu.

For CEG Users:  Anti-Aliasing Metafile Objects

What is anti-aliasing?
A pervasive problem with computer graphics files is the appearance of objects that include curves or

diagonals.  The jagged appearance of such objects is caused by too-low resolution of screens or printers,
which results in step-like approximations where there are supposed to be smooth curves or diagonals.
This phenomenon is known as aliasing.  Colloquially, the small step-like areas are called jaggies.

To improve the appearance of curves and diagonals, a technique has been developed which is
known as anti-aliasing.  Anti-aliasing causes the apparent smoothing of curves by capitalizing on a
particular characteristic of the human perceptual system.  The human eye tends to blend colors that are
in close spatial proximity, especially if the colors are also close to each other on the visible spectrum.
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This causes a slight blurring of the edges between the two colors, resulting in the appearance of a
smooth, continuous blend.  So, if the pixels that are near to an object's jaggies are colored a slightly
different shade of the object's color, the eye will blur the jaggies and you will perceive a much smoother
curve.  The improvement can be quite striking, since the nearby pixels are not actually perceived to be a
different color when viewed by the human eye, but the curve seems magically to become much more
smooth and continuous.

Automatic Anti-Aliasing  of Windows Metafiles for CEG Users
If you are running the Edsun CEG Windows driver, you should know about an outstanding capability

of Conversion Artist especially for CEG users.  When loading a file in Windows metafile format (.WMF),
Conversion  Artist automatically anti-aliases the appropriate objects in the file.  These objects include
circles, lines, and text (only CEG fonts).  The anti-aliasing operation is done in real time.  Anti-aliasing
will most dramatically improve the appearance of light-colored objects on dark backgrounds or dark
objects on light backgrounds.

After loading, the image will be in the CEG 700-color format (the CEG format supported by
Windows).  Since such images have an internal 24-bit color representation, you may save the image in
CEG, CEB, or any 24-bit format to completely preserve the image's appearance.  Saving in a 16-bit
format will result in only imperceptible, if any, changes.  If you perform a color reduction on the image (to
256, 16, or 2 colors), the resulting image might undergo a deterioration in appearance; the degree of the
deterioration will depend on the image itself and what color reduction operations were performed on it.
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Troubleshooting
Here are some commonly-asked questions about Conversion Artist, offered in hopes of saving you time,

sparing you frustration, and lowering your phone bill.

Why do the colors in the image look wrong when I view it with Conversion Artist?
The most common answer to this question is that you are viewing a 256-color (or higher-color) picture

under Windows but are using a 16-color Windows driver.  Since Conversion Artist is a Windows program, your
Windows driver determines how many colors are available to Conversion Artist for displaying pictures.

Here's a test for this theory:  If you have a DOS viewer that you can use to view your picture, do so.  If it
looks fine under DOS but bad under Windows, then you need to install a 256-color Windows driver.

Look in the System Info entry under the Help menu.  There is an entry which will tell you what type of
Windows driver is currently installed.

The printer output looks terrible.
Check your Printer Setup settings.  Be sure that the correct printer resolution is selected.  If your printer

has a draft mode, be sure that it is printing in its best-quality mode.

The text in the dialog boxes looks strange and doesn't fit in the alotted space.
The fonts supplied with your video board are significantly different from those we used when designing

the Conversion Artist interface.  You should contact the maker of your video board, describe the problem, and
ask for some additional fonts.

I'm getting a message box that says "Memory Getting Low."  Am I going to lose my
file??

First of all, NO, this message does not mean that you are about to lose a file or any information.  The
message has to do with a facility in Conversion Artist that speeds up screen updates.  Conversion Artist can
create a device-specific bitmap of the screen and keep it in memory to use for vastly speeded-up screen
updates.  The message means that memory is getting low enough that this operation can no longer be performed
(in other words, there is not enough memory available in which to store the screen bitmap).  You are especially
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apt to receive this message if you are working with high-color images (16-bit or 24-bit color).  Screen bitmaps for
high-color images will use large amounts of memory.

To solve the problem, you can do one or more of the following things (listed in decreasing order of ease):

1)  Look in the Settings dialog box under the File menu.  There is a group called Screen Bitmaps.  The
default setting is Use on all images.  You may choose one of the other options, Don't use on 16-bit and 24-bit
images (to suppress creation of screen bitmaps for only high-color images), or Don't use on any image.  This will
instruct Conversion Artist to stop creating screen bitmaps in the case(s) specified, and the "Memory Getting Low"
message will no longer be displayed.

2)  Close some windows to free the memory being used to hold other images.
3)  Close other running applications.
4)  If running Windows in enhanced mode, increase the size of your virtual memory, either by deleting

some files or increasing the size of your permanent swapfile.  (See the Windows documentation for more
information on your permanent swapfile).

5)  Buy more memory for your computer.

For more information on screen bitmaps, see Settings in The File Menu  section of Chapter 3.

What if there is insufficient memory to load my image?
You have a few options to free up more memory:

1)  Lower the amount of RAM.
2)  Lower the amount of memory in your cache (SMRTDRV).
3)  Remove any unnecessary TSRs (Terminate-and-Stay- Resident programs) you have installed.
4)  Switch to "enhanced" Windows mode and make sure you have enough disk space for a large amount

of virtual memory.   See your Windows documentation for information on virtual memory and swapfiles.

I have a file in a vector/metafile format.  Is there any way to load it into Conversion
Artist?

Some programs create files using "vector" or "metafile" formats.  (Some popular ones are CorelDraw!
(.CDR files), Harvard Graphics (.CGM files), PhotoShop (.EPS files) ....)

Though Conversion Artist does not import files in these vector formats, you may use the screen capture
facility of Conversion Artist to capture your vector image.  The screen capture facility will create a bitmap version
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of the image and import it into Conversion Artist.  The image may then be saved in any of the supported export
formats.

For Windows programs, metafiles can be put on Clipboard & pasted as metafiles.
For more information on bitmap versus metafile formats, see Chapter 5, Graphics File Types .

What if Conversion Artist won't load my file, even though the image's file format is
supported for import?

In some rare cases, Conversion Artist will fail to load a file in a supported import format.  The image
might be in an older, outdated version of the format which differs from the current version in some significant
way.  Or, if the image was created by another program, the other program may have written the image
incorrectly.

If you encounter this situation, please call or fax North Coast Software's technical support line, (603)
664-6000.  If we cannot pinpoint the problem over the phone, we request that you send the image(s) to North
Coast Software for evaluation.  We will diagnose and, if at all possible, remedy the problem.

If you need to send us a problematic image, please take note of the following:

1)  All images sent for evaluation MUST be on floppy disks.
2)  If you transfer the image from another machine, it MUST be transferred as a binary file (no

exceptions!)
3)  Describe IN DETAIL the original source of the image (if known), how the image was created (if

known), your system configuration (see System Info under the Help menu), and the problem you encountered.
Include your name, address, and contact phone number.

3)  Send all disks to:
North Coast Software, Inc.
P.O. Box 459
Barrington, NH  03825-0459
Attn:  Technical Support

Be sure to package disks carefully, and to mark the package as containing computer disks, to avoid
exposure to magnetic fields and X-rays.
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16-bit color displays, 46
16-color displays, 46
24-bit color displays, 46
256-color displays, 46
32-bit color displays, 47

A
Amiga IFF format, 89
anti-aliasing, 110, 111
aspect ratio, adjusting, 50, 59

B
batch operations, 12, 13, 17, 18, 28
binary generic format (GEN)

specifications, 86
BIT (Lotus format), 83
bitmaps, about, 101
Blur filter, 73
BMP (OS/2 bitmap format), 83
BMP (Windows bitmap format), 83
brightness, adjusting, 70

C
captioning an image, 51, 64
capture key (hot key), 19, 40
Capture menu, 19, 40
capturing windows, 19, 40
CE (Computer Eyes format), 83
CEB (Continuous Edge Bitmap

format for users of CEG video
boards), 83

CEG (Edsun Continuous Edge

CMY separation, 74
CMY splitting, 75
CMYK separation, 74
CMYK splitting, 75
color reduction methods, 14, 26, 45,

102
Colors menu, 14, 45
compression of files, 10, 13, 28, 34,

90, 109
CompuServe's Graphics Interchange

Format (GIF), 87
Computer Eyes CE format, 83
context-sensitive help, 7, 34
contrast, adjusting, 70
converting files, 10, 45, 46, 47, 104
copying a file, 38
cropping an image, 50, 54
CUT (Dr. Halo format), 85
cutting an image, 38
CVP (Kodak's Color Video Printer

format), 85

D
Data Translation Aurora IMG format,

89
Data Translation DT-Iris IMG format,

90
deleting an image, 39
Deluxe Paint LBM format, 96
Despeckle filter, 72
device dependency, 107, 108
DIB (Windows device-independent

bitmap format), 85
display devices, color configurations,

104
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Edsun Continuous Edge Graphics
(CEG) format, 47, 84

Emboss filter, 72
EPS (Encapsulated PostScript

format), 86
export file formats, 83

F
file compression, 10, 13, 28, 34, 90,

109
File Menu, 23
file operations, settings for, 32
file saving, setting options, 32
file viewer, Conversion Artist as, 5
Filter menu, 72
flat cut color reduction, explanation

of, 102
flip an image, 49, 54
framing an image, 51, 64

G
gamma adjustments for CMY/K

operations, 76
generic format, binary, 86, 87
generic format, hexadecimal, 87
GIF (CompuServe's Graphics

Interchange Format), 87
GIF (CompuServe's Graphics

Interchange format), 87
graphics file types, 101

H
help, online and context-sensitive, 7,

34
Help index, 7, 79

IFF (Amiga/Video Toaster format),
89

Image menu, 48
IMG (Data Translation Aurora

format), 89
IMG (Data Translation DT-Iris

format), 90
IMG (Ventura format), 90
import file formats, 83
installation, 2
invert an image, 49, 54

K
Kodak Color Video Printer format, 85

L
LBM (Deluxe Paint format), 96
local status bar, 33
Lotus BIT format, 83

M
Macintosh PCT format, 96
MacPaint MCP format, 96
masking an image, 53, 68
Maximum filter, 73
MCP (MacPaint format), 96
Median filter, 73
memory, conserving, 4, 33, 36
Memory/Color options, 35
merge CMY images, 75
merge CMYK images, 76
merge RGB images, 75
metafiles, 34, 101, 108, 114
Microsoft Paint MSP format, 96
Minimum filter, 73
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new file, creating, 23
Noise filter, 73

O
online help, 7, 79
opening a file, 23
optimized cut color reduction method,

explanation, 102
optimizing program performance, 3
OS/2 BMP (OS/2 bitmap format), 83

P
palettes, 103
pasting an image, 39
PCC (ZSoft Paintbrush Clipboard

format), 96
PCT (Macintosh color bitmap

format), 96
PCX (ZSoft PC Paintbrush format),

96
posterize effect using Median filter,

73
PostScript EPS format, 86
PPM (Unix Portable Pixmap format),

96
printer settings, 32
printing, 20

R
RAS (Sun raster format), 97
resolution, adjusting for differences,

58
RGB (Silicon Graphics format), 97
RGB separation, 74
RGB splitting, 75

saving a file, 25
scaling an image, 50, 56
screen bitmaps, 33
screen capture, 19, 40
Separate menu, 74
Sharpen filter, 72
Sharpen Lines filter, 72
Silicon Graphics RGB format, 97
speed options for file operations, 3
startup options, 35
status bars, 8, 33
Sun raster RAS format, 97
Super Video Windows SVW format,

97
SVW (Super Video Windows format),

97
System/Help status bar, 8, 34

T
Tagged Image File Format (TIFF), 98
Targa TGA format, 97
TGA (Targa format), 97
TIF (Tagged Image File format), 98
TIFF compression, setting, 34, 98,

109
tiling an image, 52, 67
Trace Edges filter, 73
troubleshooting, 113

U
Undo, 21
undoing an operation, 21, 38
Unix Portable Pixmap PPM format,

96

V
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Windows Metafile WMF format, 98
Windows Multiple Document

Interface, 106
WMF (Windows Metafile format), 98
WMF (Windows metafile format), 98
WordPerfect raster WPG format, 99
WPG (WordPerfect raster format), 99

Z
ZSoft PC Paintbrush Clipboard

format, 96
ZSoft PC Paintbrush PCX format, 96
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