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Lathing

Lathing is one of the most widely used operations in 
3-D modeling. If you look at the objects around you, you’ll see that many
contain parts that are symmetrical. From a lamp bulb to the wheels on a
car, many products can be created from the basic outline of the shape.
ModelPro’s tools let you generate 3-D objects based on 
2-D contours you create with its drawing tools or from 2-D contours
imported from products such as FreeHand, Illustrator, and most drawing
and CAD products. This tutorial is a step-by-step tour to help you
quickly familiarize yourself with the Lathe and Sweep tools, and access
each of their special features. 

Part I - Creating a Lathed Object

Lathe is the process where a 2-D contour is swept around
a designated axis to create symmetrical 3-D shapes quickly and easily.
ModelPro’s Lathe Tool provides the ability to control the direction and
the angle of the curve, allowing you to create simple or complex objects
easily and accurately.

Designing a Gavel and Strike Plate

In this exercise, you will create a design with three
component parts using just a single view. Groups will be used to make
your modeling efforts more effective and efficient. You will use the
Spline and Lathe tools for modeling, Guide Lines to help keep the
design in proportion, the Rotate Tool to re-position an object. Launch
ModelPro by double-clicking on its icon.

Preparing the Drawing Environment

Open the Front View to full screen size by clicking in
the Zoom box in the upper-right hand corner of Front View window.
Click and hold in the Zoom In icon at the bottom-right of the screen
until at least 1 inch is showing at each end of all rulers. Click on the
Grid icon in the Snap palette. All points will snap in 0.125 inch
increments, which is the default setting. 

Note: If you want a different grid size,
you can change the grid settings in 
the Grid Preferences dialog from the
Edit Menu.

Lathe tool

Grid Snap
button

Spline tool

Rotate tool
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Create the Head of the Gavel

You are going to use guide lines to help you keep the
design in proportion. The head of the gavel will be drawn within a
rectangle of dimensions 1.25 by 2.0. To set the first guide line, click in
the ruler at the left and drag a guide line to the right and stop when the
value of X in the Status Line at the bottom of the screen reads -0.625.
To set the second guide line, click in the ruler at the top and drag a
guide line down and stop when the value of Y in the Status Line at the
bottom of the screen reads 1. Grab another guide line from the ruler at
the top and place it where the value of Y in the Status Line reads -1.
Now click on the Free icon in the Snap palette to turn snapping off and
allow you to draw in free form.

Select the Spline Tool and draw a profile of a gavel head as shown. The
Groups palette now contains a new group named Spline 1.

Note: With the Grid Snap active, both
spline points and the tangent line
points snap to the grid.

Note: To make a spline bend from
point to point, hold the mouse down
after clicking to set a vertex and move
the cursor until you have the desired
curvature. After the initial curve is
drawn you can click on any of the
points and move them or change the
length and position of the tangent line.

Tip: The curvature can be changed
after the spline is drawn by clicking 
and dragging a point or by adjusting
the tangent line at a vertex. Stretching
the tangent line broadens or narrows
the curve.

Zoom Out

Lathe Axis

Lathe profile
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Line, and the Lathe Axis Indicator.

Choose the Lathe
Tool in the Tool palette. Since the
spline defining the gavel head is
going to be lathed around the Y=0
axis, the Lathe axis indicator is
already positioned at the right 
spot to spin the spline profile into 
a gavel head. Double-click to 
perform the Lathe.

The Groups palette now contains 
a new folder named Lathe 1. Double-
click on the name Lathe 1 in the
Groups palette to bring up the Group
Information dialog. To change the
name of the folder, type Head in the
box where Lathe 1 appears. Click in
the OK box. The new name now
appears in the Groups palette.

ModelPro makes it easy to keep 
the screen clear for doing
additional work. To make the
gavel head invisible, click in the 
D column next to the name Head
in the Groups palette. Choose the
Edit Menu and select Re-display 
(or hold the Command key 
down and type D).

Note: The Lathe axis indicator is
automatically positioned at the Galactic
Core (X=0, Y=0, Z=0) until moved.

Group Information Dialog
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Create the Strike Plate

The plate will be drawn within a
rectangle of dimensions 2.75 by 2.0. Click on the
Grid icon in the Snap palette. To set the first
guide line, drag the the line at -0.625 left and stop
when the value of X in the Status Line at the
bottom of the screen reads -0.75. To set the
second guide line, click in the ruler at the left and
drag a guide line right and stop when the value of
X in the Status Line at the bottom of the screen
reads -1.375. Now click on the Free icon in the
Snap palette to turn snapping off so you can draw
in free form.

Select the Spline Tool and draw a profile of 
the strike plate as shown. Notice that the 
Groups palette now contains a new group 
named Spline 2.

Choose the Lathe Tool in the Tool palette. Since
the spline defining the strike plate is going to be
lathed around the Y=0 axis, the Lathe axis
indicator is already positioned at the appropriate
spot to spin the spline profile into a plate.
Double-click to perform the Lathe.

The Groups palette now contains a new folder
named Lathe 1. Double-click on the name Lathe
1 in the Groups palette to bring up the Group
Information dialog. To change the name of the
folder, type Plate in the box where Lathe 1
appears. Click in the OK box. The new name
now appears in the Groups palette.

Make the strike plate invisible by clicking in the
D column next to the name Plate in the Groups
palette. Select Re-display from the Edit Menu (or
hold the Command key down and type D).

Lathed strike palette

Strike plate profile

Tip: To draw a curved spline, click the
next point, hold, and drag to get the
desired curve, and let go. To draw a
straight spline, click the next point, and
let go.
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Create the Gavel Handle

The handle will be drawn within a
rectangle of dimensions 0.5 by 5.0. To draw the
handle, you will have to enlarge the drawing area.
Click and hold in the Zoom In icon at the bottom-
right of the screen until at least 2.5 inches is showing
at each end of all rulers. 

Click on the Grid icon in the Snap palette. You are
going to re-arrange the guide lines for the design of
the handle. To set the first guide line, drag the the
vertical line at X=-0.75 right and stop when the
value of X in the Status Line at the bottom of the
screen reads 1. 

To set the second guide line, drag the the vertical line at X=-1.35 right
and stop when the value of X in the Status Line at the bottom of the
screen reads 1.25. To set the third guide line,drag the the horizontal line
at Y=1 up and stop when the value of Y in the Status Line at the bottom
of the screen reads 2.5. To set the fourth guide line,drag the the
horizontal line at Y=-1 down and stop when the value of Y in the Status
Line at the bottom of the screen reads -2.5. Now click on the Free icon
in the Snap palette to turn snapping off.

Select the Spline Tool and draw a profile of a gavel
handle as shown. The Groups palette now contains a
new group named Spline 3.

Choose the Lathe Tool in the Tool palette. Position
the Lathe axis indicator at the appropriate spot to
revolve the spline profile into a gavel handle. 
To move the indicator with the cursor, select and 
drag the center point. Since the spline defining the
gavel head is going to be lathed around the X=1 axis,
click on the Lathe axis indicator and drag it to the
right to the guide line at X=1. Double-click to
perform the Lathe.

Handle profile

Lathed handle
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The Groups palette now contains a new folder 
named Lathe 1. Double-click on the name Lathe 1 
in the Groups palette to bring up the Group
Information dialog. To change the name of the
folder.Type Handle in the box where Lathe 1 appears.
Click in the OK box. The new name now appears in
the Groups palette.

Now make the gavel head visible by clicking in the D
column next to the name Head in the Groups palette.
Choose the Edit Menu and select Re-display (or hold
the Command key down and type D).

Re-positioning the Gavel Handle

The handle needs to be rotated and moved
to fit together with the gavel head. Hold the Option
and Command keys (or hold the command key and
click on the Arrow Tool icon in the Tool palette) and
click on the handle to select it. Select the Rotate Tool
in the Tool Palette (or type R). Look at the Status

Line for the prompt to select the
anchor point for the rotation.

Select Center Object from the Anchor pop-up in the
Rotate Tool Info palette.

Click in the box to the left of Incremental Degrees to
fix the increment of rotation.  Enter 90 in the box to
the right to specify the angular increment.  This
willcause the handle to rotate in 90 degree increments.

Grab a point on the handle and rotate it so the 
top is pointing toward the head of the gavel.

Click, hold, and drag the handle to the right till 
it is positioned as shown.

Head and handle

Rotated Handle

Rotate Tool Info palette
with Anchor pop-up



Lathe Tutorial
Creating a Gavel

B:7

Re-positioning the Strike Plate

Make the strike plate visible by clicking in the D column next
to the name Plate in the Groups palette. Select Re-display from
the Edit Menu (or hold the Command key down and type D).

To display the object bounding box and not the vertices, select
the Arrow Tool, hold the Option 
key down, and click on the strike plate. Drag the 
plate down till it is clear of the gavel.

Revert to the four view display by clicking in the Zoom box in
the upper-right hand corner of the Front View window. Hold
the Command key and click in the Fit to Window box in any
view to 
re-size all the pieces to fit in each window. Click 
on the Quick Render icon in the 3D Window to preview your
object.

Select Save As under the File Menu and enter MyGavel.mdl
when prompted for the name.

Re-positioned handle Gavel and strike plate

Re-positioned strike plate

Note: If the Groups palette is covering
the Zoom box, double-click on the title
bar to bring the Front View back to
normal size.
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Shaded gavel
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Part II - Creating a Swept Object

Sweep is the process where a 2-D contour is swept in a
spiral around a designated axis to create coiled, spiraling, and nautilus-
shaped objects The Sweep Tool provides a 3-D extension to the lathe
process by letting you spiral the shape as you are revolving it. In this
example, you will use the Sweep Tool to create a spring.

Designing a Spring

In this exercise, you will create a spring that has a
diameter of one inch, has six coils, and is three inches high. You will use
the Ellipse and Sweep tools for modeling, Launch ModelPro by double-
clicking on its icon or select New under the File menu if you are already
in ModelPro.

Preparing the Drawing Environment

Click on the Snap Grid icon in the Snapping palette.
Open the Front View to full screen size by clicking in the Zoom box in
the upper-right hand corner of Front View window. Click in the Fit  to
Window icon at the bottom-right of the window. Click and hold on the
Zoom Out icon until there is 3 inches showing in the ruler at the left.
This will let you fit the spring in the drawing window.

Select the Ellipse Tool. Click in the Circle Radius box in the Tool Info
palette to set the fixed radius option. Type 0.125 in the radius box in the
Tool Info palette to set the radius, Hold the Shift key down and draw a
circle of radius 0.125 with center at (0,0) in the Front View.

Tip: You can use the Move To command to position an
object exactly where you want. Move To can be selected
under the Options Menu or by holding the Command key
and typing M. Click on the center dot in the Object
Extent Box and with X=0, Y=0, and Z=0 as the Move To
coordinates, click in the Ok box and the circle will be
centered around (0,0) in the Front View.

Ellipse Tool Info palette

Move To dialog



Define the Sweep

Select  the Sweep Tool and click on the
circle. It will be the 2-D contour that swept into a spring.
This causes the sweep control points to appear. The center
control point is used to set the center of the sweep. The offset
control point sets the height of the sweep. The angle control
points is used to perform the sweep.

Move the center control point 0.5 inches to the right. This
will set the radius of 0.5 inches (or a diameter of 1 inch) for
the sweep. The Status Line at the bottom of the screen
should read X: 0.5, Y: 0, Z:0.

Raise the off-set control point to a height of three inches.
The Status Line at the bottom of the screen should read 
X: 0.5, Y: 3, Z:0.

Look in the ∆Y box in the Sweep
Tool Info palette. This is the value
of the height you set. You can
change it by double-clicking in the
box and entering new value.

Revert to the four view display by
clicking in the Zoom box in the
upper-right hand corner of the Front
View window. Click in the Fit to
Window box in The Top View to
re-size all the pieces to fit in each
window. 

Click-hold on the angle control
point in the Top View. Slowly move
to the right and down and around

Sweep Tool Info palette

Sweep control

Control points set
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until you make six revolutions. 
Here is the important part in
making the coil rise evenly up as 
it goes around. While still holding
on the angle control point and 
move the anchor point so that the
end of the sweep meets the
beginning. The angle in the sweep°
box should read 2160°. If not, 
type 2160 in the sweep° box. If you
correctly matched the beginning
and the end of the sweep you will
now have a three inch high spring
with six coils and a diameter of 
one inch

Tip: To help you in making sure
that the beginning and end of the
sweep match, enlarge the Top 
View and make the object fit to 
the window. This will allow you 
to match both ends more accurately.

Double-click in any view of click 
in the Sweep box in the Sweep Tool
Info palette

Note: The Selected object(s) will be
“swept” around the axis of rotation line
and transformed in a gradual fashion
according to the ending bounding
rectangle. A new, surfaced object 
will be created along that sweep. 
The original selected object is saved
separately and “turned-off” in the
Group palette, unless otherwise
specified in your Preferences, and 
may be restored at anytime.

Final

Sweep Control
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Notes


