
 




Notes
This document was designed to be distributed electronically and then printed on a laser printer on an as-needed basis. For this reason, the fonts and layout of this document have been chosen for optimal printing rather than for optimal viewing on-screen. To review this document on-screen, however, simply increase the magnification using the magnification box at the bottom of the window. For the best results when viewing dialog boxes on-screen, increase the magnification to 200%.
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1

 

elcome to the Adobe Photoshop

 

 

 

—
image editing software that combines a 
full range of painting and editing tools, 

sophisticated selection tools, and methods for 
adjusting gray levels and color in continuous-tone 
images. 

The Adobe Photoshop Tryout tutorial is designed 
to show you how to use many of Adobe Photo-
shop’s image-editing tools, starting with impor-
tant basic concepts and then moving on to more 
complex tasks, such as creating channels and 
masks, and using color-correction tools. 

The Adobe Photoshop Tryout program includes 
the full set of program features, with the exception 
of the Save and Print options, and can be used in 
either the Macintosh or Windows environment. 
For best results, copy the Adobe Photoshop Try-
out program to your hard drive before you begin 
working through the tutorial exercises. 

 

INSTALLING THE SOFTWARE

 

Install the software using one of three options:

 

O

 

From the Photoshop section of the Adobe 
Graphics Sampler, click Launch/Install Tryout.

 

O

 

For the Macintosh, use the installer in the 
Install-Disk 1 folder in the Adobe Photoshop 5.0 
Tryout folder (located in the Tryouts folder on the 
Adobe Graphics Sampler CD-ROM).

 

O

 

With Windows, open File Manager and double-
click Setup.exe in the Tryouts\Photoshp\Disk1 
directory on the Adobe Graphics Sampler 
CD-ROM.

 

Start the Adobe Photoshop program

 

Double-click the Adobe Photoshop Tryout icon to 
start the program. The toolbox appears to the left, 
and eight palettes arranged in three groups appear 
at the bottom of the screen. 

The toolbox contains tools you use to select, paint, 
edit, and view images. Each tool is represented by 
an icon. 

The Brushes and Options palettes contain options 
for painting and editing. The Picker, Swatches, 
and Scratch palettes contain options for selecting 
and editing colors. The Layers, Channels, and 
Paths palettes contain options for creating and 
editing layers, channels, and paths.

 

WORKING WITH IMAGES 

 

You will begin by using a variety of basic tech-
niques to view, select, and edit an image. 

 

Open the artwork

 

1

 

Choose File > Open. Locate the included tuto-
rial files and select the 

 

Frames 

 

(Macintosh) or 

 

Frames

 

.

 

jpg 

 

(Windows) file. 
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In the title bar next to the document name, the 
view of the document is displayed. Depending on 
the size of your screen, the image appears at a 1:1 
ratio view or at a 1:2 ratio view. 

 

Preview the page size

 

1

 

Position the pointer on the lower left corner of 
the window; then press and hold down the mouse 
button to display the Page Preview box. 

The rectangle with an 

 

X

 

 through it represents the 
image dimensions; the outer rectangle represents 
the paper size. The white area represents the 

 

imageable area

 

 of the current paper size, the area 
on which artwork can be printed. 

 

2

 

To see how the paper size affects the preview, 

choose File > Page Setup and enter a variety of 

page sizes; then repeat step 1. 

 

Preview the image size

 

Position the pointer on the image size box in the 
lower left corner of the Information bar; then 
hold down Option key (Macintosh) or the Alt key 
(Windows) and press the mouse button. The 
image size box appears, which displays the width, 
height, number of channels (colors), and resolu-
tion of the image. 

 

Show and hide palettes

 

You can display and hide palettes and windows as 
you work. All palettes can be repositioned by 
dragging the gray bar at the top of the palette. 

 

O

 

To display or hide a palette, choose the corre-
sponding command from the Window menu. The 
Show and Hide commands toggle between the 
two options. 

 

O

 

To collapse a palette, click the zoom box in the 
upper right corner of the palette. Clicking the 
zoom box alternates between displaying the full 
palette and the collapsed palette. 

 

MAKING SIMPLE SELECTIONS

 

In Adobe Photoshop, you edit and manipulate 
part of an image by first making a selection. 

 

Zoom in on the work area 

 

If the Frames image is not displayed at a 1:1 view, 
you will first zoom in on the image. 

 

1

 

Click the zoom tool in the toolbox; then posi-
tion the pointer on the center of the image and 
click once. The image is enlarged by one order of 
magnification.

Your image should be displayed at a 1:1 view. 
However, you may need to resize the window.

 

2

 

If the image is displayed larger than a 1:1 view, 

double-click the zoom tool in the toolbox to 

return to a 1:1 view. 
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Make a rectangular selection

 

1

 

Select the rectangular marquee tool; then posi-
tion the pointer at the top left corner of the center 
frame of the image, just inside the black border. A 
crosshair pointer appears. 

 

2

 

Drag diagonally to the lower right corner of the 

frame. 

 

3

 

Release the mouse button. The frame is 

selected.

If a selection is not as desired, choose Select > 
None or click outside the selection, and then 
redraw the selection border. 

 

Cut the selection

 

You will cut the selected image and move it to 
another area of the nine-frame image. If you can’t 
see all of the image on your screen, begin with step 
1 to scroll the window; if all of the image is visible 
on-screen, skip to step 2. 

 

1

 

Select the hand tool; then position the hand in 
the center of the image and drag to the right to 
move the image to the right within the window. 

 

2

 

Make sure that the center frame is still selected; 

then choose Edit > Cut. 

 

Exchange the frames

 

1

 

Click the rectangular marquee tool; then select 
the fourth frame (the first frame in the second 
row) of the image. 

 

2

 

When the frame is selected, position the pointer 

inside the selection border. The pointer becomes 

an arrow. Hold down the Shift key to constrain 

the horizontal movement of the selection, and 

then drag the selection to the center frame. 

 

3

 

Release the mouse button and then the Shift 

key. Click outside the selection to deselect every-

thing. 

 

4

 

Choose Edit > Paste. The frame you originally 

selected is pasted into the center of the window. 

Position the pointer within the selection and drag 

it to the area from which you moved the fourth 

frame. Deselect everything.

 

Make an elliptical selection

 

1

 

Select the zoom tool, position the pointer in the 
middle of the eighth frame, and then click. The 
frame doubles in size. 

 

2

 

Double-click the marquee tool to select it and to 

display the Marquee Options palette. Choose 

Elliptical from the Shape pop-up menu in the 

Marquee Options palette. 

 

3

 

Position the pointer on the center of the blue

filter, hold down the Option key (Macintosh) or 

the Alt key (Windows) and drag diagonally to the 

lower right. Holding down this key draws the 

selection marquee from the center point to the 

outside edge. 

 

4

 

While holding down the left mouse button and 

the Option (Macintosh) or Alt (Windows) key, 

hold down the Shift key to constrain the selection 

to a circle.

 

5

 

Release the left mouse button, and then the 

Shift and modifier key. The filter is selected. 

 

Move the selection border

 

You can move a selection border without affecting 
the pixels under the selection. 
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1

 

Hold down the Command and Option keys 
(Macintosh) or the Ctrl and Alt keys (Windows); 
then position the cursor on or inside the selection 
border. 

 

2

 

Drag to move the selection border on the blue 

filter. 

 

Duplicate the selection

 

1

 

With the blue filter still selected, hold down the 
Option key (Macintosh) or the Alt key (Windows) 
and drag the filter onto the cloth in the image. 
Make sure that you press the key 

 

before

 

 you begin 
dragging; otherwise, you will move the selection 
but not duplicate it. 

 

2

 

Release the left mouse button and then the key. 

 A copy of the blue filter is created.

 

Restore part of the image

 

You use the “magic eraser” tool to restore an 
image to the last saved version. This tool is a vari-
ation of the eraser tool. 

 

1

 

Deselect everything.

 

2

 

Select the eraser tool; then hold down the 

Option key (Macintosh) or the Alt key (Windows) 

and drag over the copy of the blue filter. The last 

saved version of the document appears as you 

drag the magic eraser. 

 

PAINTING ON AN IMAGE

 

A basic principle of Adobe Photoshop is the use of 
foreground and background colors. The 

 

fore-
ground color

 

 in Adobe Photoshop is the color that 
is applied when you use any painting tool (paint 
bucket, airbrush, paintbrush, pencil, and line 
tool), the type tool, and the default Fill command. 
The 

 

background color

 

 is the color that replaces part 
of an image when you use the eraser or when you 
cut, move, or delete a selection. You can think of 
the background color as the canvas under a paint-
ing.

 

Select the foreground color

 

The eyedropper tool lets you select a color from 
anywhere in the image by taking a sample of that 
color. 

 

1

 

Double-click the zoom tool to reset the image to 
a 1:1 view.

 

2

 

Click the eyedropper tool; then position the 

pointer on the image and drag through the image. 

The foreground color in the toolbox changes. 

 

3

 

Click the blue tip of the tongs in the upper left 

frame. The foreground color in the toolbox 

becomes the blue color of the tip of the tongs.



 

5

 

Select areas of similar color

 

The magic wand tool selects an area based on 
color similarity. 

 

1

 

Select the magic wand tool, and click the 
umbrella in the middle frame. All of the umbrella 
is selected because it has pixels of similar color.

 

2

 

Choose Edit > Fill. 

 

3

 

In the Fill dialog box, set the Opacity to 60 per-

cent, select Foreground Color from the Use menu, 

and click OK. 

 

Fill a selection with a blend

 

You can fill a selection with a 

 

gradient fill

 

, a grad-
ual blend of color that transitions from the fore-
ground color to the background color. 

 

1

 

Select the eyedropper tool. 

 

2

 

Option+click (Macintosh) or Alt+click (Win-

dows) the green pear in the center (fifth) frame to 

take a sample of the green color from the pear. The 

background swatch on the toolbox changes to the 

sampled color. 

 

3

 

Double-click the gradient tool; then drag the 

Opacity slider in the Gradient Tool Options pal-

ette to 75 percent to create a transparent blend. 

 

4

 

With the umbrella still selected, drag from the 

upper right corner of the umbrella downward to 

the middle rib of the umbrella. 

 

Setting blend at upper Blend applied
right corner of umbrella 

 

Store and select colors

 

You can use the Swatches palette to select fore-
ground and background colors, and to store the 
colors you create. 

 

1

 

Click the Swatches palette tab. 

 

2

 

In the Swatches palette, move the pointer to the 

white area in the last row of swatches. The pointer 

becomes a paint bucket. 

 

3

 

Click within the white area to add the blue fore-

ground color Swatches palette. 
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4

 

To select a color from the Swatches palette, click 

the yellow-orange color swatch (the fourth color 

in the third row). The new color appears in the 

foreground color icon in the toolbox. 

 

Paint on a selection

 

1

 

Double-click the marquee tool to select the 
Marquee Options palette. Select Rectangular from 
the Shape menu; then select the third (upper 
right) frame using the rectangular marquee tool. 

 

2

 

Select the paintbrush tool; then drag the paint-

brush inside the selected area along the lower edge 

of the umbrella. Drag outside of the selection 

marquee; no paint is applied because paint is only 

applied 

 

within

 

 a selection. If nothing in an image 

is selected, you can paint anywhere on the image. 

 

3

 

Choose Revert from the File menu to revert to 

the last saved version of the Frames image. 

 

EDITING SELECTIONS

 

You will copy the still life image in the center 
frame, and then edit the image to fit into the view-
finder of the camera in the lower left frame. 

 

Duplicate and edit a selection 

 

You will use the rectangular marquee and the Info 
palette to determine the size of the selection that 
will fit within the viewfinder. 

 

1

 

If the Info palette is not visible on the screen, 
choose Window > Palettes > Show Info. 

 

2

 

Choose Window > Show Rulers. Horizontal 

and vertical rulers are displayed in the window. 

To make sure that the ruler units are set to inches, 
you will use the Info palette. 

 

3

 

Choose Window > Palettes > Info to display the 

Info palette; then position the pointer on the + 

next to the X and Y coordinate indicators in the 

lower portion of the palette. Press the mouse but-

ton to display the unit pop-up menu, and make 

sure that inches is selected for the ruler unit type. 

 

4

 

If necessary, use the hand tool or the scroll bars 

to scroll the window so that the center frame is 

fully visible on-screen. 

 

5

 

Select the Marquee tool.

 

6

 

Begin dragging from the upper left corner of the 

center frame, and, while watching the Info palette, 

drag diagonally downward to make a selection 

measuring about 2 inches wide and 1.7 inches 

high.

 

7

 

Choose Edit > Copy, and then choose Select > 

None to deselect the still life selection.

 

8

 

If necessary, use the hand tool or scroll bars to 

reposition the image so that all of the camera is 

visible (the fame in the lower left corner). 
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9

 

Select the zoom tool, and then click the center 

of the camera frame to enlarge the view. 

 

Select part of an image with the lasso tool

 

The lasso tool lets you make precise selections and 
can contain both straight and freehand line seg-
ments. 

 

1

 

Select the lasso tool and move the pointer to the 
left edge of the viewfinder, near the silver clip. 

 

2

 

Drag to trace the outline of the viewfinder until 

the entire viewfinder is selected; then release the 

mouse button. 

If this is the first time you have made a selection 
with the lasso tool, your outline may be imprecise. 
Now you will deselect the selection and redo it 
using straight lines.

 

3

 

Choose Select > None.

 

4

 

Position the lasso pointer on the upper left cor-

ner of the viewfinder; then hold down the Option 

key (Macintosh) or the Alt key (Windows).

 

5

 

Click to define the starting point of the straight 

line segment. 

 

Do not drag.

 

 Continue holding 

down the key and click the remaining three cor-

ners of the viewfinder. A straight line appears 

between the starting point where you first clicked 

and the end point.

 

6

 

Click where you began the selection, and release 

the key. A straight-edged selection border 

appears. 

 

Fourth corner of straight- Return to starting point
line lasso selection

 

Paste and transform a selection

 

Using the Paste Into command, you can paste a 
portion of an image that has been cut or copied 
inside another selection. 

 

1

 

With the selection still active,

 

 

 

choose Edit > 

 

Paste Into. The first selection is pasted into the 
currently selected area. 

The selection is a 

 

floating selection

 

, a selected area 
that has been pasted onto the image and is still 
active as long as the area remains selected.

The still life selection is much larger than the 
viewfinder selection; you see only the portion that 
fits into the viewfinder selection. 
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2

 

To maintain the original aspect ratio, 

Shift+drag the upper right handle. When the per-

centage in the Info palette reaches about 60 per-

cent, release the mouse button and then release 

the Shift key. 

 

3

 

When you are satisfied with the scaling, click 

the gavel icon within the selection to scale the 

selection. Because you scaled the selection, it 

needs to be recentered within the viewfinder. 

 

4

 

Position the pointer in the selection, and then 

drag the selection to the center of the viewfinder.

 

5

 

Choose Image > Rotate > Free. Handles appear 

at the corners of the selection border.

 

6

 

Drag one of the handles counterclockwise to 

rotate the selection so it appears upside down. 

When the angle of rotation (A) in the Info palette 

is -138 degrees, release the left mouse button. A 

preview of the rotation appears within the selec-

tion border.

 

7

 

When you are satisfied with the rotation, click 

the gavel icon within the selection to apply the 

rotation.



 

9

 

Adjust the selection’s opacity

 

Now you will make the selection semitransparent 
to match the appearance of an actual viewfinder. 

1 Click the Layers palette tab.

You can use the Layers palette to control the 
blending mode and opacity of the floating selec-
tion as long as it remains active. Once you deselect 
a selection, the Layers palette controls affect the 
entire layer.

2 In the Layers palette, drag the Opacity slider to 

50 percent, or press 5 on the keyboard. The selec-

tion becomes transparent.

3 Click away from the selection to select every-

thing.

RETOUCHING A SCANNED IMAGE 

In this lesson, you will color-correct an image 
visually. The Variations command lets you adjust 
the color balance, brightness and contrast, and 
saturation in an image by adjusting color previews 
that represent different aspects of the image. 

For images that require more precise correction, 
there are several more advanced color-correction 
tools available in Adobe Photoshop. 

Adjust the midtones in an image

By correcting the midtones first, you will be better 
able to see changes you make to the highlights and 
shadows (brightness and contrast).

1 Open the BadScan image.

2 Double-click the hand tool to enlarge the win-

dow to its maximum size.

3 Choose Image > Adjust > Variations. The Vari-

ations dialog box appears.

The two preview icons at the top of the dialog box 
show the image without adjustments (Original) 
and the image containing any color adjustments 
(Current Pick). The lower left section of the dialog 
box shows the Current Pick preview surrounded 
by six color previews representing different 
adjustments to the color balance. 

The lower right section of the dialog box shows 
the Current Pick preview between a lighter pre-
view and a darker preview.

4 Make sure that Midtones is selected and that the 

Show Clipping option is checked. The Show Clip-

ping option displays a neon highlight around 

areas of color that will be clipped, or lost, using 

the adjustment represented. 

The Fine/Coarse slider determines the degree of 
change each color preview represents. Moving the 
slider one increment to the right doubles the 
effect; moving it one increment to the left 
decreases the effect by one-half. 
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5 Drag the Fine/Coarse slider one increment to 

the right of the midpoint, toward Coarse.

6 Click the More Red preview. The More Red pre-

view becomes the Current Pick, and each preview 

in the dialog box is updated to reflect the adjust-

ment.

Remember that since you are adjusting the color 
balance, each click of a color preview affects the 
other color previews according to their positions 
on the color wheel. For example, clicking the 
More Red preview increases the red by one incre-
ment and increases the yellow and magenta by 
one-half increment. The color previews repre-
senting the opposite colors on the color wheel are 
conversely decreased: the cyan decreases by one 
increment, and the green and blue decrease by 
one-half increment. 

7 Click the More Magenta preview to select that 

adjustment. Notice that adding magenta removes 

green. 

8 Click Darker to darken the midtones.

Note: If you add more of a color to the Current Pick 
than desired, you can undo the effect by clicking the 
opposite color an equal number of times.

9 Click OK to apply the change to the image, and 

then close the BadScan image. 

RETOUCHING FLAWS

You will retouch flaws in the Fruit image using the 
rubber stamp tool. The rubber stamp tool lets you 
pick up, or sample, an image and “paint” an exact 
duplicate of that image. 

Retouch the color on an image

1 Open the Fruit image.

2 Select the rubber stamp tool.

3 Click the first brush in the second row of the 

Brushes palette. (If the palette is not visible, 

choose Window > Palettes > Show Brushes.) The 

smaller brush, with a diameter of 5 pixels, enables 

you to paint over smaller areas. 

4 Option+click (Macintosh) or Alt+click (Win-

dows) just below and to the left of the bruise on 

the pear to set the origin of the sample within the 

unbruised part of the pear.

5 Move the pointer over the bruised area, and 

begin dragging to paint over the bruise with the 

unbruised texture you just cloned.

Setting the sample Cloned texture painted 
origin over bruise
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Duplicate an object using the rubber 
stamp tool

The rubber stamp tool is also used to reproduce 
an entire object within an image. You’ll begin by 
creating a flat brush shape to help isolate the bou-
gainvillea leaf. 

1 Choose New Brush from the Brushes palette 
menu. 

2 In the Diameter text box, enter 25 pixels; in the 

Roundness text box, enter 50 percent. The angle 

and roundness show in the lower left preview win-

dow; the brush stroke shows in the lower right 

preview window. 

3 Click OK. The new brush shape appears in the 

Brushes palette as the selected brush. 

4 Position the rubber stamp pointer on the lower 

right edge of the leaf, and Option+click (Macin-

tosh) or Alt+click (Windows) the leaf to set the 

sample origin.

5 Move the rubber stamp pointer so that it is just 

below and to the left of the original leaf. Be sure to 

leave enough space for a whole new leaf. 

6 Drag to duplicate a copy of the leaf. 

You can paint in sections, releasing the mouse 
button between strokes; duplication will continue 
from the sample origin.

FINE-TUNING COLOR CORRECTIONS

In the final part of this exercise, you will adjust the 
brightness and perform some color correction on 
isolated areas of the image. 

Increase the color saturation

1 Double-click the magic wand tool, and in the 
Magic Wand Options palette set the tolerance to 
40; then click OK. 

2 Click the upper left corner of the image to select 

the background cloth. 

Note: Some of the background areas won’t be 
selected. You do not have to make a precise selection. 

3 Choose Image > Adjust > Hue/Saturation. The 

Hue/Saturation dialog box appears.

4 Make sure that the Preview check box is selected 

so that you can preview changes as you make 

them.

5 Drag the Saturation slider to +50 to increase the 

intensity of all the colors in the cloth; then click 

OK to apply the changes.

6 Choose Image > Adjust > Brightness/Contrast. 

The Brightness/Contrast dialog box appears.
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7 Increase the Brightness to 10 and the Contrast 

to 10 to bring out more of the texture in the cloth; 

then click OK to apply the changes.

8 Deselect the image. 

Lighten a shadow

1 Zoom in to a 2:1 view on the cloth in the upper 
right corner.

2 Select the dodge/burn tool.

3 Drag the pointer over the cloth in the upper 

right corner to lighten the shadow. 

By default, the dodge tool lightens pixels by 50 
percent of their original brightness value. 

Subdue highlights

1 In the Toning Tools Options palette, choose 
Burn from the Tool menu. The burn tool icon 
replaces the dodge tool in the toolbox.

2 Either use the Exposure slider in the palette or 

press 2 on the keyboard to reduce the exposure to 

20 percent. 

3 Drag along the crease of the apricot, using sev-

eral strokes for a controlled effect. Work around 

the edges of the apricot to increase the shadow 

areas. 

4 Close the Fruit file.

CREATING COMPOSITE PHOTOGRAPHS

One of the most powerful features of the Adobe 
Photoshop program is the flexibility and control it 
gives you in making, editing, and saving selec-

tions. You can then use these selections as masks. 
Masks allow you to isolate parts of an image so 
that you can work on only certain areas. 

About channels, image types, and modes

You can create masks and save selections by add-
ing channels to images. A channel is analogous to 
a plate in the printing process. By default, every 
Adobe Photoshop image has a number of chan-
nels that represent information about one of the 
color elements in the image. For example, an RGB 
image has four channels by default: the RGB 
channel ( called the composite channel), which 
represents the combination of the red, green, and 
blue channels; the red channel; the green channel; 
and the blue channel. 

Display channels in an image

1 Open the Portrait image. 

2 Display the Channels palette by clicking the 

Channels tab.

Portrait image

The eye icon in the column opposite each channel 
indicates that all the channels are visible. 

3 In the Channels palette, click Red to display the 

red channel. The channel appears in grayscale by 

default. You can also display channels in color. 
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4 Choose File > Preferences > General. Select the 

Display Color Channels in Color option, and click 

OK. 

Portrait red channel

5 Click the various channels to view the effect; 

then return to the composite RGB channel by 

clicking RGB or channel #0 in the Channels

palette.

Make a selection to Isolate a background 

You will begin creating the composite image by 
isolating the girl from the background in the Por-
trait image. You will first create a temporary mask 
from this selection and then store the mask in a 
channel so you can reuse it later.

1 Double-click the magic wand tool to display the 
Magic Wand Options palette. Reset the Tolerance 
to 32.

2 Make sure that the Anti-aliased option is 

selected. This option makes the edge of the selec-

tion soft by filling the edge pixels with a percent-

age of color.

3 Click the blue background of the image with the 

magic wand tool. 

4 Choose Select > Grow to extend the selection. 

Now most of the background is selected, except 

for some dark spots.

Background selected using Selection extended using
magic wand tool Grow command

Choose Select > Similar to select the additional 
blue in the background throughout the image. 

Using the magic wand tool, add to the selection by 
holding down the Shift key and clicking the band 
of red, and then clicking the dark blue line of the 
book. Now all but the girl in the image—with the 
exception of a few spots—is selected. You will edit 
the selection to include those areas.

After Select Similar Selection extended using
magic wand tool, Shift key

5 Choose Select > Inverse to invert the selection 

and select the girl.



14

Create and edit a mask 

1 Click the Quick Mask mode control in the 
toolbox. The Quick Mask mode lets you quickly 
edit a mask and view the image simultaneously. 
This feature is useful because it lets you see the 
mask superimposed on the image.

By default, the Quick Mask channel appears red, 
and its opacity is 50 percent—similar to a rubylith 
overlay, or frisket, used in traditional illustration 
to protect the image when airbrushing. Every-
thing in the channel that is red is masked (pro-
tected from changes). 

Note: The girl’s hat is not part of the mask, but 
because you are viewing channels in color and the 
hat is red, it appears to be part of the mask. 

2 Double-click the Quick Mask mode control to 

display the Mask Options dialog box. 

3 Make sure that the Masked Areas option is 

selected; when this option is selected, whatever is 

part of the mask is protected from changes. When 

the Selected Areas option is selected, whatever is 

part of the mask will become selected when con-

verted to Standard mode, and can be changed. 

You can change the color of the mask (or channel) 
and its opacity so that you can distinguish the 
mask when viewing the composite image. 

4 Click the color swatch to display the Color 

Picker dialog box. In the color picker, use the color 

slider to drag upward to the mid-green range, and 

then click the upper right corner of the color field 

to select a bright green. If an alert triangle appears, 

do not click it. Click OK, and click OK again to 

close the Mask Options dialog.

5 Double-click the paintbrush tool and make sure 

the Opacity in the Paintbrush Options palette is 

set to 100.

You can use any of the painting and editing tools 
to edit the mask.

6 From the Brushes palette, select the fourth 

brush in the top row. 

The opacity in the Brushes palette and the fore-
ground and background colors control whether a 
painting or editing tool edits the mask partially 
or fully. Partial opacity partially adds to (or sub-
tracts from) the mask.

The foreground and background colors, which 
are automatically set to their defaults when you 
select Quick Mask mode, also control whether a 
painting or editing tool edits the mask partially or 
fully. Black, the default color for the painting 
tools, applies 100 percent of the mask; white, the 
default color for the eraser tool, reveals the image. 
A color or percentage of gray partially adds to or 
subtracts from the mask.

7 Drag to paint any dark areas in the background 

that show through the bright green mask. You 

want the mask to cover the entire background so 

that only the girl shows through the mask. 
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8 Using the eraser tool, drag over the girl’s eyes 

and any green within the selection of the girl. The 

eraser tool paints with the default background 

color, white, and thus “erases” the mask, making 

those areas part of the selection.

Adding to mask using Mask erased using
paintbrush tool eraser tool 

9 Click the Standard mode control in the toolbox 

to convert the mask to a selection border on the 

image. The edited selection now surrounds just 

the girl.

Standard mode: 
edited selection

Save the selection in a channel

Quick Mask mode temporarily stores a mask; 
however, unless you save the mask as a selection in 
a channel, the mask is discarded as soon as you 
make another selection. 

1 In the Channels palette, click the Save Selection 
icon at the bottom left. In the Channels palette, #4 
appears after the blue channel, indicating you 
have added a channel. 

2 Click #4 in the Channels palette to view only 

channel #4 and the mask, not the composite 

image. 

Channel #4 Icons indicate channel
can be viewed and edited

Note: On the Macintosh, a selected channel appears 
gray. With Windows, a selected channel appears 
white.

3 Click RGB or #0 in the Channels palette to 

return to the composite RGB image.

4 Choose Select > None to deselect the image.

SAVING SELECTIONS

Select the sunflower in the girl’s hat and save the 
selection. 

1 Using the zoom tool, zoom in on the sunflower 
to a 2:1 view.

2 Double-click the lasso tool, and in the Lasso 

Options palette, make sure that the Anti-aliased 

option is selected. 

3 Using the lasso tool, drag around the sunflower 

to roughly outline it. 

2:1 view Lasso selection of sunflower
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4 In the Channels palette, click the Save Selection 

icon. It is important to save your selection as you 

edit it, so that you don’t lose your changes. 

5 Double-click #5 in the Channels palette and 

name the channel Sunflower; then click OK. 

Sunflower mask Channel #5 selected

Refine a selection

You will add areas to the selection and subtract 
areas you do not want included in the selection. 

1 Click RGB or #0 in the Channels palette to 
return to the composite RGB image. The 
sunflower remains selected.

2 Use the zoom tool to zoom in to a 4:1 view of 

the sunflower. If necessary, enlarge the window 

and scroll so that the sunflower selection is fully 

visible.

3 Using the lasso tool, position it just inside the 

selection next to the sunflower. 

4 Hold down the Shift key to add areas of the sun-

flower that weren’t included in the original selec-

tion, and drag carefully to trace the sunflower.

5 Release the mouse button and then the Shift 

key.

If you accidentally deselect the selection, 
Option+click (Macintosh) or Alt+click (Win-
dows) the Sunflower channel in the Channels pal-
ette to load the original selection saved in the Sun-
flower (#5) channel.

6 To subtract from the selection, hold down the 

Command key (Macintosh) or the Ctrl key (Win-

dows); begin dragging to trace around the area 

you want to delete from the selection. 

7 Release the mouse button and then the key.

8 When you are satisfied with the selection, drag 

the selection icon onto the Sunflower channel to 

replace the original selection.

9 Double-click the zoom tool to zoom out to a 

1:1 view. 

RESIZING IMAGES 

You will open a second image, Window, that will 
become part of the composite image. Then you 
will resize the Portrait image so that the girl fits 
within the Window file when pasted into the new 
background.

1 Open the Window file. 

2 Choose Window > Show Rulers. You will use 

the rulers as a reference to get an idea of the pro-

portions of the Window and Portrait files.

3 Drag the Window file by the title bar so that 

both the Portrait and Window files are visible. The 

girl in the Portrait image is much larger than the 

window that she will be pasted into. 
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4 Make the Portrait file the active image, and dis-

play the rulers. 

5 Choose Image > Image Size. Deselect the File 

Size check box so that the image dimensions can 

be changed independently of the resolution.

6 Enter 3 inches in the Height text box. Accept the 

corresponding Width value, and click OK. 

7 Load the selection of the girl and hat onto the 

image by Option+clicking (Macintosh) or 

Alt+clicking (Windows) channel #4 in the Chan-

nels palette.

8 Choose Edit > Copy to copy the selection to the 

Clipboard. 

PASTING AND TRANSFORMING SELECTIONS

Now you will paste the girl inside the window, 
position her, and adjust the selection so that it 
appears to be part of the Window file.

1 Using the magic wand tool, click the lower left 
window in the Window file, just above the chair, 
to select the window.

2 Add to the selection by holding down the Shift 

key and clicking the empty right window, and 

then clicking again on the glass just above the 

right window frame.

Selecting the window Adding to the selection
using the magic wand tool using the Shift key

3 Choose Edit > Paste Into. The girl is pasted 

behind the window frame.



18

4 Choose Image > Flip > Horizontal. 

5 Using the selection pointer, drag the girl to the 

left so that her face appears in the left window 

frame.

6 Choose Select > None.

CREATING TYPE 

In this lesson you will complete the composite 
image by adding type on a layer. Layers act as 
transparent acetate sheets in an Adobe Photoshop 
document. Images on layers can be edited inde-
pendently. 

Create type on a layer

1 In the Layers palette, click the New Layer icon. 
Rename the layer type and click OK. The new layer 
is added to the Layers palette and is highlighted, 
meaning it’s the active layer. Whatever changes 
you make will affect only the active layer.

2 Select the type tool and click on the right side of 

the window frame near the top of the window.

3 In the Type Tool dialog box, select the Times 

font, set the Size to 48 points, set the Leading to 

48, click Style Bold, and click Alignment Center. 

Make sure that the Anti-aliased option is selected. 

In the text box, type the word STUDIO, pressing 

Enter after each letter to create a vertical string of 

letters. 

4 Click OK. The type selection appears on the 

image. 

5 Deselect the type. By default, type is filled with 

the foreground color. You can still edit the text 

even though you deselected it.

6 If the type’s color is not black, choose Edit > Fill. 

The Fill dialog box appears.

7 Select Black from the Use menu, 100-percent 

Blending Opacity, and the Preserve Transparency 

option. This last option changes the color of art-

work on a layer without affecting the entire layer. 

Click OK.
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8 In the Layers palette, change the Opacity to 25 

percent. The text in the image is now transparent. 

CONCLUSION

You have completed the Adobe Photoshop Tryout 
tutorial, using only a few of the image-editing fea-
tures provided with the program. In addition to 
what you have learned in this brief tutorial, Adobe 
Photoshop contains many more digital editing 
techniques. Here are just a few:

O Support of multiple layers for easy compositing 
of images

O The highest quality, broadest support for 
different file formats

O Color-based selection tools

O The ability to adjust color in a number of ways, 
ranging from very simple to highly sophisticated

O The ability to save selection outlines instead of 
reselecting objects each time you open a file

O Over 40 standard plug-in filters, including 
multiple choices for image sharpening, softening, 
stylizing, distortion, and video, and for the 
removal of noise, dust, and scratches

O Lighting effects for applying multiple light 
sources to an image and choosing from a range of 
colors, intensities, and angles

O The ability to output DCS (Desktop Color 
Separation) files and to control output aspects 
professionally

O On-screen CMYK editing, a gamut warning 
that identifies areas out of the CMYK gamut

O The ability to create high-quality duotones, 
tritones, and quadtones with PANTONE or 
process inks

O Advanced PostScript language support for inte-
grating images with Adobe Illustrator artwork

O Identical feature set and binary-compatible file 
formats for the Macintosh and Windows versions

For information about how to order the complete 
Adobe Photoshop software in the U.S., call 800-
833-6687. Outside the U.S., contact your local dis-
tributor for assistance. 
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