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This Reference Guide provides an introduction to the capabilities of Enhance Preview XT - 
Special Edition. For more detailed information, refer to the User Guide PDF located on the 
QuarkXPress Installer CD.

W H AT I S E N H A N C E P R E V I E W XT -  S P E C I A L E D I T I O N ?
Enhance Preview XT - Special Edition (EPXT-SE) is a native QuarkXPress 4.0 XTension for 
Macintosh and Windows that lets users display high resolution previews — or enhanced previews —
of any standard pixel-based file format supported by QuarkXPress, such as TIFF, EPS and 
Scitex CT, or its XTension import filters, such as PhotoCD and JPEG. (Note: Vector EPS images
cannot be enhanced.) Color, grayscale, and one-bit (line art) formats are supported. When you
display an enhanced preview, it temporarily replaces the standard 72dpi preview QuarkXPress 
normally displays, even at view magnifications up to 800%. 

Enhance Preview XT - Special Edition creates temporary cache files, or enhanced previews, 
from the original images and uses these enhanced previews for screen display only. The original
images are not affected in any way. When you print a QuarkXPress document that contains
enhanced previews, the original images are sent to the printer.

Using enhanced previews enables you to position text and other items relative to pictures with
great accuracy. The ability to see images with enhanced clarity removes the guesswork in page 
layout and eliminates surprises when it’s time to print your layouts. And now that QuarkXPress
4.0 lets you edit embedded clipping paths, you can perform this while viewing the high resolution
image detail. You can even use Bézier shapes to create precise silhouettes for even the most 
complicated shapes.

In addition to its image-enhancement capabilities, EPXT-SE also functions as a FlashPix import 
filter. You can import and print images in this new multi-resolution file format. The display 
benefits of the FlashPix format also apply at print time, when only the necessary data (tiles and
resolution, based on the cropping and output line screen) is sent to the output device. FlashPix
images are RGB and will be printed using the specified Quark CMS profiles.

Note about supported image formats: In general, pixel-based image formats, such as TIFF, JPEG, Scitex CT, and
raster EPS files, include data that’s used when high resolution output is produced. EPXT-SE accesses this high 
resolution data when it generates enhanced previews. Some image files, such as PICT and GIF files on Macintosh
computers and BMP, DIB, RLE, WMF, PCX, and GIF files on Windows-based PCs, are imported in their 
entirety when you use QuarkXPress’ Get Picture command. Because there’s no additional high resolution data 
to access, EPXT-SE will not create enhanced previews for these files. 

The features provided in EPXT-SE are a subset of the features in the full shipping version of
Enhance Preview XT (version 2.1.4).

C U S T O M E R S E R V I C E A N D S U P P O R T I N F O R M AT I O N

For information about Enhance Preview XT and related KGA products, visit the KGA Web site
(www.koyosha.com/xt). If you have any questions or need assistance, you can contact KGA 
technical support via e-mail at precision_support@koyosha.com.
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U T I L I T I E S M E N U CO M M A N D S

Choosing the Enhance Preview-SE command in the Utilities menu displays a submenu with 
two options:

• About Enhance Preview XT-SE/KGA opens the About screen. This screen contains 
KGA contact information and a button that enables you to access the KGA Web site 
(for product information, FAQs, software updates, etc.), providing you have a correctly 
configured Internet setup.

• Enhance Selected Preview lets you create an enhanced preview for the pixel-based image
in the currently selected picture box.

The first time you use EPXT-SE, a folder called Precision Separation Tables is placed in your
QuarkXPress application folder. EPXT-SE uses the files in this folder when it creates enhanced 
previews. If you move or delete this folder, a new one will be created in the QuarkXPress 
application folder the next time you use EPXT-SE.

When EPXT-SE is running, two menu commands and a floating palette are added to QuarkXPress.

V I E W M E N U CO M M A N D S

Choosing the Enhance Preview-SE command in the View menu displays a submenu with 
three options:

• Show/Hide Palette lets you display or hide the Enhance Preview XT-SE palette,

• Show/Hide Enhanced Previews lets you display enhanced previews or use the default
72dpi previews,

• Show/Hide Antialiasing lets you display enhanced previews with or without applying
edge smoothing.

ENHANCE PREVIEW XT Special Edition INTERFACE

E N H A N C E P R E V I E W XT S P E C I A L E D I T I O N PA L E T T E

Choosing Show Palette from the Enhance Preview-SE submenu in the View menu displays the
four-button EPXT-SE palette, which provides access to the following features (from left-to-right):

1. Enhance Selected Preview
2. Show/Hide Enhanced Previews
3. Show/Hide Antialiasing
4. About Enhance Preview-SE/KGA

The text area under the buttons displays the name of the corresponding menu command for each
button so you can quickly identify the function of each tool. 
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C R E AT I N G A N E N H A N C E D P R E V I E W

To create an enhanced preview, click on a picture box that contains a raster image, then choose
Enhance Selected Preview from the Enhance Preview XT-SE submenu in the View menu or click the
corresponding button (the leftmost one) in the Enhance Preview XT-SE palette. A “cache file” used
for high resolution screen display is generated and placed in the same folder as the original image.
The cache file is an RGB file, optimized for screen display. Additionally, JPEG compression is
applied to all cache files, which produces a relatively small file with sufficient detail for high 
resolution screen display.

EPXT-SE lets you create enhanced previews for only one picture box at a time. The Enhance 
Selected Preview command and button are grayed out if:

• Multiple picture boxes are selected 

• The image file format is not supported or recognized

• An associated cache file is found in the same folder as the source image

All cache files are stored in the same folder as the original source image with the exception 
of images that are located on a locked volume (such as a CD). Cache files for these images are
placed in a folder called “Preview Cache (locked vols.)” in the QuarkXPress application folder.

D I S P L AY I N G A N E N H A N C E D P R E V I E W

You must click on a picture box that contains an image that’s been enhanced to see the enhanced
preview. When you deselect a picture box that contains an enhanced image (by clicking on another
item or on a blank area of the page or pasteboard), the screen will redraw and the unenhanced
preview will be displayed.

When a picture box that contains an enhanced preview is selected, the enhanced preview will 
continue to be displayed when you:

• Change the view magnification

• Modify any setting in the Clipping pane of the Modify dialog box

• Edit the image’s clipping path

• Change tools

• Modify the image (i.e., change scale, skew or rotation angle, color, shade, etc.) 
of the picture box

Note: Imported FlashPix files are handled in the same manner. 

R E M O V I N G C A C H E F I L E S

The cache files generated by EPXT-SE when you create enhanced previews are stored in the same
folder as the original image files. When you are finished working on QuarkXPress documents that
contain enhanced previews, you will probably want to delete the cache files to free-up additional
disk space. 

For Macintosh users:

1. Return to the Desktop and use the Find command in the File menu (or press 
Command-F)

2. Perform a search for files that contain “.ivc”

3. Select the files you want to delete, then drag them to the Trash. 

For Windows users: 

1. Click the Start button, choose Find, and  choose Files or Folders from the submenu

2. Perform a search for files that contain “.ivc”

3. Select the files you want to delete, then choose Delete from the File menu. 

Note: The full version of Enhance Preview XT includes features that let you control the file size,
storage location, and automatic removal of preview cache files. 

Enhance Preview is a trademark of Koyosha Graphics of America, Inc. QuarkXPress is a registered trademark and XTensions is a trademark of Quark, Inc. 
All other trademarks are the property of their respective owners. ©1998 Koyosha Graphics of America, Inc.
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NOTICE TO END USER: PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THE SOFTWARE.
BY USING THE SOFTWARE, YOU AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. IF YOU
DO NOT AGREE TO THE LICENSE TERMS, DO NOT USE THE SOFTWARE.

1. License. Koyosha Graphics of America, Inc. (“KGA”) grants to you (either as an individual or entity) a
personal, non-transferable, and non-exclusive right to use on a single system at one time each copy of
the object code version of the ENHANCE PREVIEW™ SPECIAL EDITION software (“SOFTWARE”) 
provided with this License. You agree you will not reproduce each copy of the SOFTWARE except as 
necessary to use it on a single computer system. You agree that you may not copy any documentation
accompanying the SOFTWARE. You may assign your rights under this License to a third party who
agrees in writing to be bound by this License prior to the assignment and provided that you transfer 
all duplicates of each copy of the SOFTWARE and related documentation to the third party or destroy
any duplicates not transferred.

2. Copyright. You acknowledge that no title to the intellectual property in the SOFTWARE is transferred
to you. You further acknowledge that title and full ownership rights to the SOFTWARE will remain 
the exclusive property of KGA, its suppliers and licensors, and you will not acquire any rights to the 
SOFTWARE except as expressly set forth above. You agree that any copies of the SOFTWARE will con-
tain the same proprietary notices which appear in the SOFTWARE.

3. Reverse Engineering. You agree that you will not attempt to decompile, reverse engineer, disassemble
or otherwise reduce the SOFTWARE to a human-perceivable form, in whole or in part.

4. Disclaimer of Warranty on Software. You expressly acknowledge and agree that use of the 
SOFTWARE is at your sole risk. The SOFTWARE and related documentation are provided “AS IS” 
and without warranty of any kind, and KGA, its suppliers, and licensors EXPRESSLY DISCLAIM ALL 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR PARTICULAR PURPOSE. KGA DOES NOT WARRANT 
THAT SOFTWARE FUNCTIONS WILL MEET YOUR REQUIREMENTS, OR THAT THE OPERATION 
OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEFECTS IN THE 
SOFTWARE WILL BE CORRECTED. FURTHERMORE, KGA DOES NOT WARRANT OR MAKE ANY 
REPRESENTATIONS REGARDING THE USE OR RESULTS OF USE OF THE SOFTWARE OR 
RELATED DOCUMENTATION. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY 
KGA MAY CREATE A WARRANTY OR INCREASE KGA’S LIABILITY HEREUNDER. SHOULD THE 
SOFTWARE PROVE DEFECTIVE, YOU ASSUME ENTIRE RESPONSIBILITY AND COST OF ALL 
SERVICING, REPAIR OR CORRECTION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION
OF IMPLIED WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.

5. Limitation of Liability. UNDER NO CIRCUMSTANCES SHALL KGA BE LIABLE TO YOU FOR ANY
CONSEQUENTIAL, SPECIAL, INCIDENTIAL OR INDIRECT DAMAGES OF ANY KIND ARISING FROM
THE USE OF THE SOFTWARE OR RELATED DOCUMENTATION, EVEN IF KGA HAS BEEN ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES.

6. Export. You agree that you will not export or re-export the SOFTWARE without appropriate United
States or foreign licenses.

7. Governing Law. This License will be governed by the laws of the State of California as they are applied
between California residents entered into and to be performed entirely within California. The United
Nations Convention on Contracts for the International Sale of Goods is specifically disclaimed.

8. Entire Agreement. This is the entire agreement between you and KGA and it supersedes any prior
agreement, whether written or oral, relating to the subject matter of this License. In the event of 
invalidity of any provision of this agreement, you agree that such invalidity shall not affect the validity 
of the remaining portions of this License.

If you have any questions regarding this License, please write to KGA at: 
Koyosha Graphics of America, Inc., 821 Sansome St., San Francisco, CA 94111, USA. ATTN: 
License Info.

KOYOSHA GRAPHICS OF AMERICA, INC. END USER LICENSE


