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SimpleImage is a simple but powerful image- and movie-viewing
application that lets you view all the most popular image and movie
formats, like JPEG, GIF, animated GIF, TIFF, PICT, PNG, MPEG, AVI
and more in a single, sleek application. (Some file types may require
QuickTime 3 or a Power Macintosh.)

With SimpleImage you can

• View images with or without scrollbars
• Transform images and movies by rotating and reflecting them
• Crop and zoom images
• View images and movies full-screen or in a slide show
• Create Snapshots — small files you can double click to reopen

groups of windows exactly the way you left them

With QuickTime 3 SimpleImage can also be used as a simple conver-
sion utility, with the ability to save both images and movies in several
formats.

SimpleImage is Mac OS 8 savvy, correctly adopting the new Mac OS
8 look and making extensive use of contextual menus.

Welcome to SimpleImage
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Opening Files

There are several ways to open a file in SimpleImage:

• Double-click the icon in the Finder. If the file “belongs” to
SimpleImage (see below), this is the easiest way to open it. To
find out how to make a file belong to SimpleImage, see Chang-
ing files’ creators.

How do you know if a file belongs to SimpleImage? Look at its icon. If it has a
SimpleImage icon like one of those shown above, it’s a SimpleImage file.

• Drag the file onto SimpleImage’s icon or any window open
in SimpleImage. If you have an image or movie window al-
ready open in SimpleImage, you can open files by dragging
their icons onto the open windows. If the file is in a format
SimpleImage can open (see File Types SimpleImage Can Open
for a complete list), the window will highlight as you drag the
file over it. You can also drag folders to open all the images and/
or movies in them.

• Choose ‘Open’ from the File menu in SimpleImage. The
standard Open File dialog box will appear. (If you’re using Mac
OS 8.5, you’ll see a new, improved Open dialog box which lets
you shift-click to select multiple items to open at once.)

• Choose the file from the Reopen menu in SimpleImage. If
you’ve viewed the file recently in SimpleImage, its name should
be listed in the Reopen menu. To find out how to change the
number of items that appear in the Reopen menu, see Changing
Preferences.

• Choose “Open Previous File” or “Open Next File” from the
Special menu, or choose an item from the Open sub-menu
located in every window’s contextual menu. See Using the
Open menu.

Using the Open menu
Every window’s contextual menu has an Open menu which lets you
see the folder the window’s file is in and all the items in the folder that
SimpleImage can open.
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To see a window’s contextual menu, hold down the control key while
clicking anywhere in the window. (The window doesn’t have to be
frontmost for you to make its contextual menu appear.)

The Open menu lists the window’s “parent” folder (i.e., the folder that
contains the window’s file) at the top, separated from the rest of the
menu by a divider. Below that all the files in the folder that
SimpleImage can open are listed, with dashes (–) beside all the items
that are currently open in SimpleImage, except the file that belongs to
the window you clicked in to make the contextual menu appear. This
item is marked with a checkmark (√). Choose an item to open it in
SimpleImage or to bring it to the front if it’s already open.

The items in the Open menu are normally listed alphabetically by file
name. To see the files listed by creation date, with the most recent files
at the top and least recent at the bottom, hit the caps lock key before
contol-clicking in a window.

Closely related to the Open menu are two commands in the Special
sub-menu: “Open Previous File” and “Open Next File.” These com-
mands open the next or previous file, relative to the contextual menu’s
window or the frontmost window, depending on whether you chose the
command from a contextual menu or from the menu bar.

 Normally, these commands open the next or previous file alphabeti-
cally by file name, but if you hit the caps lock key before selecting
them, they open the file by creation date—with the caps lock key
down, “Open Next File” opens the next most recent file in the folder,
and “Open Previous File” open the next least recent file.

Using the Reopen menu
The Reopen menu gives you instant access to as many as the last 99
files you’ve opened in SimpleImage.

SimpleImage adds a file to the Reopen menu when you close its
window in SimpleImage (or the last copy if you have multiple copies
of the file open. See Duplicating Windows). When you open a file,
SimpleImage checks to see if it’s listed in the Reopen menu and, if it
is, removes it.

The Reopen menu remembers the files listed in it even after you quit
SimpleImage.

The Reopen menu maintains very robust links to the files it lists.
SimpleImage will still find the file even if it’s been moved or renamed.
If the file is on a disk that has been removed, SimpleImage will tell
you the name of the disk the file is on and prompt you to insert it. If
the file has been deleted, SimpleImage will tell you it can’t open the
file and remove it from the Reopen menu.

An Open sub-menu, sorted by file
name
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To reopen more than one item at a time, choose “Reopen...” from the
bottom of the Reopen menu. A dialog box will appear with a list of all
the items in the Reopen menu, letting you select which items to open.
(Shift-click items in the list to select a range of items, and command-
click to select items that aren’t contiguous.)

If you wish to close a window without adding its name to the Reopen
menu, hold down the Delete key while clicking in the window’s go-
away box.

If you wish to remove a file from the Reopen menu without reopening
it, select the item while holding down the Delete key. Similarly, you
can remove all the items in the Reopen menu by selecting “Reopen...”
while holding down the Delete key. SimpleImage will ask you to
confirm that you really want to remove all the items from the menu.

You can also make a fresh start and clear the contents of the Reopen
menu by holding down the Delete key while SimpleImage is starting
up.

You can specify the number of files to list in the Reopen menu in the
Preferences dialog box. (See Changing Preferences.)

Duplicating windows
When you try to open a file that’s already open in SimpleImage,
SimpleImage will bring the file’s window to the front and expand it if
it’s collapsed instead of opening the file in a new window. If you want
to view multiple copies of a file, open the file and choose “Duplicate
Window” from the Window menu. The duplicated window inherits all
the characteristics of the original—its view, size, selection, and trans-
formations.

When you close a window that’s been duplicated, SimpleImage
doesn’t add the window to the Reopen menu until you close the last
copy of the window.

Changing files’ creators
Every Macintosh document has an invisible code associated with it
that tells the Finder which application to open when you double-click
the document’s icon. When SimpleImage opens a file it optionally
attaches its creator code and icon to the file, so the next time you want
to open it you only have to double-click it and the Finder will auto-
matically open it in SimpleImage.

You can control whether SimpleImage changes files’ creator codes and
icons or not by selecting or deselect the “Change image files” and
“Change movie files” options in the Preferences dialog box. By de-
fault, these options are disabled.
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Snapshots

With SimpleImage you can create Snapshots of groups of windows. A
Snapshot is like an alias, but whereas an alias points to a single file, a
Snapshot can point to any number of files, plus it records the state of
each image or movie — its size, position, zoom level, transformations,
etc. — so you can reopen a group of windows exactly the way you left
them, just by opening a single Snapshot file. You can also create a
Snapshot of a slide show.

Creating Snapshots
To create a Snapshot, first open the windows you want to be included
in the Snapshot, arrange them the way you want them, and choose
“Make Snapshot” from the File menu. A standard Save As dialog box
will appear, letting you choose where and under what name to save the
Snapshot. (You can specify a default folder for saving Snapshots, as
well as a default name. See Changing Preferences.) To create a Snap-
shot of a slide show, simply begin a slide show by opening two or
more windows and choosing “Slide Show” from the View menu (See
Slide Shows), and then choose “Make Snapshot” from the File menu.

Opening Snapshots
You open Snapshots  exactly the same way as other SimpleImage files
(see Opening Files). Before opening the images or movies recorded in
the Snapshot, SimpleImage will display the “Open Snapshot” dialog
box:

You can toggle between icon
and preview view in the Open

Snapshot dialog box by clicking
the “Preview” checkbox.

You can open any Snapshot as a
slide show by selecting the

“Slide show” checkbox.
If the Snapshot was saved as a

slide show, the checkbox will
already be selected.
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The Open Snapshot dialog box gives you a chance to see what items
are in the Snapshot and what disks they’re on before opening them. If
the disk the item is on isn’t currently inserted, SimpleImage displays
the disk’s name in italics. Similarly, if the disk the item is on is in-
serted but the item can’t be found, SimpleImage displays the item’s
filename in italics.

You can also use the Open Snapshot dialog box to open part of a
Snapshot by selecting only the items you wish to open.

Opening slide show Snapshots
By default, before opening a slide show Snapshot SimpleImage first
closes all the currently open windows so they won’t be added to the
slide show. You can, however, disable this feature by deselecting the
“Close windows before opening slide show Snapshot” option in the
Snapshot pane of the preferences dialog box. With this option turned
off, if you open a slide show Snapshot, SimpleImage will add all the
currently open windows to the slide show recorded in the Snapshot.

When Snapshot items are already open
When you open a Snapshot that contains items which are already open,
SimpleImage will not reopen the items, but will apply whatever trans-
formations are necessary to make the items’ windows match the
information recorded in the Snapshot.

Missing items
If you try to open a Snapshot item that can’t be found, SimpleImage
will offer to search for it. If you try to open a Snapshot item that
SimpleImage thinks is on a disk that isn’t currently available,
SimpleImage will ask you to insert the disk or give you the option of
searching for the file. If you decline to search for a missing item or
insert the requested disk, SimpleImage will simply skip it and open the
items in the Snapshot that can be found. If you let SimpleImage search
for the item, it will search all the currently inserted disks.

If you open a Snapshot that contains one or more items that had to be
searched for, SimpleImage will suggest that you resave the Snapshot.
Resaving the Snapshot will save the updated information about the
location of all the items and help ensure that you don’t have to search
for the same items again the next time you open it.

Can I delete a file after saving it in a Snapshot?
A Snapshot doesn’t contain any image or movie data — it only con-
tains the information necessary to help SimpleImage open and arrange
the images and/or movies recorded in it. Snapshot files are therefore
typically very small, but they’ll only work as long as they can find the
original files they point to.

Hold down the option key while
clicking“Search” to search for

all the missing items in a
Snapshot.

Hold down the option key while
clicking “Cancel” to skip all the

missing items in a Snapshot.
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Viewing And Transforming Images

Tip: You can also change the
size of a window by choosing

“Larger,”  “Smaller,” or “Nor-
mal Size” from the View menu.

(Or “Double,” “Halve,” or
“Normal Size” if the frontmost

window is a movie window.)

SimpleImage gives you a choice of three different ways to view an
image: in a window with scrollbars (scroll-bar view), in a window
without scroll bars (snap-to-window view) or without a window at all
(full-screen view).

Snap-to-window view
When an image is in snap-to-window view, SimpleImage doesn’t
display any scroll bars or resize box and shrinks the image, if neces-
sary, to fit in the space available on the monitor. In snap-to-window
view all the image is always visible, so there’s no need for scroll bars.

Although a window in snap-to-window view doesn’t have a resize box
you can still change the size of the window by positioning the pointer
in the lower right hand corner of the window—the pointer will change
to a double-headed arrow when you’re in the right spot—and dragging
the mouse. When you resize a window in snap-to-window view the
image shrinks or grows to fit the new size of the window.

Scroll-bar view
When SimpleImage displays an image in scroll-bar view, the size of
the image doesn’t change when you resize the window. Because the
size of the image is independent of the size of the window, not all of
the image may be visible, so SimpleImage displays scroll bars to allow
you to move the image around within the window.

You can, however, still change the zoom level of an image in scroll-bar
view by choosing “Larger,” “Smaller,” or “Normal Size” from the
View menu. (There’s also a popup menu in the lower left-hand corner
of scroll-bar view windows which lets you quickly jump to a specific
zoom level.)

You can change the view of any image by choosing “Snap To Win-
dow” from the View menu. By default SimpleImage opens images in
snap-to-window view, but you can change this by deselecting the
“Snap To Window” option in the Preferences dialog box.

The “Snap To Window” command in the View menu  can’t be dese-
lected when the frontmost window is a movie window, because movies
are always displayed in snap-to-window view.

Full-screen view
SimpleImage can also display images and movies  full screen, that is,
without a window. When an image or movie is displayed in full-screen
view, SimpleImage centers the image or movie on the screen, scaling it
if necessary, against an empty background.

The “resize window” pointer

Tip: You can also scroll an
image in scroll-bar view by

holding down the space bar—
the pointer will change to a

grabber hand—and dragging.
The arrow keys can also be used

to scroll an image. Holding
down the option key causes the

arrow keys to scroll a screenful.

The “grab scroll” pointers

Tip: Hold down the shift key
while choosing “Snap To

Window” or type command-
shift-E to quickly  change all

open images to snap-to-window
or scroll-bar view.
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If the image or movie is displayed on the main screen (that is, the
screen with the menubar) SimpleImage will hide the menubar. Though
hidden, however, the menubar is still accessible in full-screen view.
Simply move the mouse to the area at the top of the screen where the
menubar would normally be to make it temporarily reappear. (You can
also access a full-screen image or movie’s contextual menu by control-
clicking. In addition, in full-screen view you can access the contextual
menu by clicking (without holding down the control key) in the empty
area around the image or movie.)

Virtually all of SimpleImage’s menu commands can be applied to a
full-screen view image or movie: commands for resizing, transform-
ing, saving, printing, etc. In addition, you can resize full-screen images
and movies by positioning the pointer in the lower right-hand corner of
the image or movie and dragging, and you can create selections and
crop and zoom them the same as with images displayed in windows.

You can have more than one image or movie in full-screen view (and
switch between them using the Window menu), as well as any combi-
nation of full-screen images and movies and regular view images and
movies.

Making selections in images
When the pointer is inside an image window it changes to crosshairs to
let you know that you can drag the mouse to create a selection.

Once you’ve made a selection you can fine tune it by dragging the
corners. Position the mouse in corner of the selection you want to
resize—the pointer will change to a four-headed arrow when you’re in
the right spot—and drag. You can also move the selection marquee
around within the window by positioning the mouse inside the selec-
tion—the pointer will change to an arrow with a tiny selection mar-
quee—and dragging.

To quickly select an entire image, choose “Select All” from the Edit
menu. To quickly deselect the current selection, choose “Select None.”

When the frontmost window contains an image displayed in snap-to-
window view and the image is too large to display at its full size, the
command “Select Screen Area” is enabled in the Edit menu. “Select
Screen Area” selects the largest area of an image that will fit on the
screen if zoomed to 100%. By default, “Select Screen Area” centers
the selection within the image, but you can easily move it or resize it.

When the frontmost window contains an image in scroll-bar view and
the scroll bars are active, the command “Select Current View” is
enabled in the Edit menu. “Select Current View” selects the entire area
currently visible in the window.

The “resize selection” pointer

The “move selection” pointer

Tip: Hold down the shift key
while choosing “Full Screen”

or type command-shift-` to
quickly  change all open images

to full-screen or normal view.
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Zooming and cropping images
Once you’ve made a selection, you can zoom or crop its contents by
choosing “Zoom Selection” or “Crop Selection” from the Edit menu.

“Zoom Selection” opens the contents of the selection in a new window
and resizes it to full size or as close as possible. “Crop Selection”
resizes the selection’s window so that only the contents of the selection
are visible. “Crop Selection” never changes the zoom level of the
image.

A window that contains only a portion of an image, whether it was
created by zooming or cropping, always contains the information
necessary to restore the original image. Choose “Uncrop” from the
Edit menu to restore the original dimensions of the image and create a
new selection representing the portion of the image that was formerly
cropped.

Copying images
Once you’ve made a selection, you can also copy its contents, either by
moving it to the Clipboard for use in other applications or by dragging
it directly to another application.

To copy a selection to the Clipboard, choose “Copy” from the Edit
menu. To drag the contents of a selection to another application, drag
the selection while holding down the option key. The pointer will
change to an arrow with a plus sign to let you know that you’re moving
the contents of the selection and not just the selection marquee.

Rotating and reflecting images (QuickTime 3 only)
If you have QuickTime 3 installed you can transform images and
movies by rotating and reflecting them.

To rotate an image or movie 90° clockwise, choose “Rotate 90° CW”
from the Transform sub-menu in the View menu. To rotate 90° coun-
terclockwise, choose “Rotate 90° CCW.” To rotate 180°, choose
“Rotate 180°.” You can also reflect (“flip”) the contents of a window,
either horizontally (“Flip Horizontal”) or vertically (“Flip Vertical”).

No matter how many transformations you apply, you can always return
an image or movie to its original state by choosing “Remove Transfor-
mations” from the Transform sub-menu in the View menu. The “Re-
move Transformations” item is disabled if no transformations have
been applied or if the transformed window is identical to the
untransformed window. (For example, a window that has been rotated
90° twice and flipped both horizontally and vertically is identical to
the original window.)

When you transform a window that has a selection, SimpleImage also
transforms the selection to ensure that precisely the same portion of

The “drag selection” pointer
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the image remains selected. When you transform a scroll-bar view
window in which only part of the image is visible, SimpleImage will
adjust the size of the window and the position of its scroll bars to
attempt to keep the same portion of the image visible. When you rotate
a snap-to-window view image or movie, SimpleImage reduces the size
of the window, if necessary, to ensure that the rotated window fits on
the screen.

Although you can also rotate and reflect movies, please note that some
movies do not play properly when rotated 90°.

If you have more than one monitor
SimpleImage is designed to work intelligently with multiple monitors.

When you open a window, SimpleImage decides which monitor to
open it on based on the settings in the Preferences dialog box. If “Open
files on main screen” is selected, SimpleImage opens the image on the
main monitor—that is, the monitor with the menu bar. If “Open files
on deepest screen” is selected, SimpleImage opens the file on the
monitor that’s currently set to display the largest number of colors (the
largest “bit depth”). If the monitors have the same bit depth, Simple-
Image uses the main monitor. If “Open files on the largest screen” is
selected, SimpleImage opens the file on the monitor that has the
largest viewable area.

When you open a file by dragging its icon onto a SimpleImage win-
dow, SimpleImage overrides the settings described in the previous
paragraph and instead opens the window on the monitor that contains
the window you dragged the file onto.

When you rotate or zoom a window that spans two or more monitors,
or resize it using the commands in the View menu, SimpleImage
calculates which monitor holds that greatest area of the window and
moves the window so that it fits entirely on that monitor.



13

Viewing And Transforming Movies

Playing movies
To play a movie
Click the Play button, hit the space bar or Return key, double-click the
movie, or choose “Play From Beginning” from the View menu.

To pause a movie
Click the Pause button, hit the space bar or Return key, or click the
movie once.

To play or pause all open movies
Choose “Play All Movies” or “Pause All Movies” from the View
menu.

To move to a specific time in a movie
Drag the slider or hit the left or right arrow keys. If the Info palette is
visible (see The Info Palette), the current time indicator will continu-
ally update to show where you are in the movie.

To change a movie’s volume
Click the volume icon and drag the slider that appears, or hit the up or
down arrow keys.

Movie windows

Tip: Shift-click the volume icon
to set the volume louder than its

usual maximum.

scroll bar

volume

play/pause
selection slider step back step forward
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To play a movie continuously
Choose “Loop” from the View menu. To loop the movie back and
forth, choose “Loop Back And Forth.” (Looping back and forth is also
called palindrome looping, from the Greek word palíndromos, ‘run-
ning back again.’ The author of SimpleImage is proud of his six semes-
ters of Greek.)

To change the playback rate
Choose “Faster” or “Slower” from the Playback Rate sub-menu of the
View menu to make a movie play faster or slower. To return the movie
to its original speed, choose “Normal Rate.”

To prevent SimpleImage from dropping frames

If your Mac isn’t powerful enough or lacks the resources to play a
movie at its intended fps rate, QuickTime will drop some of the
movie’s frames. To force QuickTime to play every frame, choose “Play
All Frames.”

Selecting and copying movies
You can also select and copy portions of movies, but the process is a
little different from selecting and copying images.

To make a selection in a movie window the movie controller must be
visible. Hold down the shift key and drag the slider to select the part of
the movie you wish to copy. As you shift-drag the slider, the selected
portion of the scroll bar will turn black. You can also make a selection
by holding down the shift key while hitting the left and right arrow
keys.

To select the entire movie, choose “Select All” from the Edit menu.

To undo the selection, click anywhere on the scroll bar or choose
“Select None” from the Edit menu.

If the Info palette is visible, detailed information about the selection
(its start time, end time and duration) is given dynamically as you
create or adjust the selection.

Once you’ve made a selection, you can copy it to the Clipboard by
choosing “Copy” from the Edit menu.

You can also tell SimpleImage to play only the selected part of a
movie by choosing “Play Selection Only” from the View menu.

Hiding the movie controller
You can hide or show the movie controller by choosing “Hide Movie
Controller” or “Show Movie Controller” from the View menu. Many
of the movie controller’s functions are still available when the
controller’s hidden: the movie can still be played or paused by hitting
the space bar or Return key or clicking in the movie, the movie can be
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A movie badge

moved ahead or back a frame by hitting the left and right arrow keys,
and the volume can be adjusted with the up and down arrow keys.

When the movie controller is hidden and the movie is not playing, an
icon—the badge—appears in the lower left-hand side of the movie to
remind you that the window is a movie window. You can make the
controller reappear by clicking the badge. The badge does not appear
while the movie is playing.

When movies appear in a slide show (see Slide Shows), their controller
is hidden by default. You can still make the controller visible by select-
ing “Show Movie Controller” either from the View menu or the
movie’s contextual menu. The movie badge doesn’t appear in full-
screen movies.

The poster frame
Every movie has a poster frame—a single frame that represents the
contents of the movie. The poster frame is usually specified when the
movie is created. To go to the poster frame, choose “Go To Poster
Frame” from the View menu. If the creator of the movie has not explic-
itly specified a poster frame, “Go To Poster Frame” will simply go to
the first frame of the movie.

You can also change a movie’s poster frame by advancing the movie to
the time you want to set as the poster frame and choosing “Set Poster
Frame” from the View menu.

Rotating and reflecting movies (QuickTime 3 only)
Movies can be rotated and reflected just the same as images. (See
Rotating And Reflecting Images.) Some movies, however, don’t play
properly when rotated 90°, and sound-only movies can’t be trans-
formed or resized.
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Slide Shows

In addition to displaying images and movies normally, SimpleImage
can display them in a slide show. There are two kinds of slide show,
each with its own advantages and disadvantages: a memory slide show
and a disk slide show.

A memory slide show displays the items that are already open in
SimpleImage. This kind of slide show tends to be very fast but can
require large amounts of memory because all the items are kept in
memory during the slide show. A memory slide show also requires that
you explicity open every item you want displayed.

A disk slide show, on the other hand, shuffles through the items of a
folder you specify, sequentially opening, displaying, and then closing
each of the items in it. Because the slide show items are only open
long enough to display them, this kind of slide show requires less
memory but can be somewhat slower than a memory slide show. A
disk slide show is often more convenient, since it only requires that
you specify a folder whose contents you want displayed, and doesn’t
require you to explicity open each item.

How to begin a memory slide show
Open the images and/or movies you want in the slide show (you need
to open at least two) and choose “Slide Show” from the View menu.
Select the “Use items currently open in SimpleImage” and click OK.
SimpleImage will display all the images and movies in full-screen
view and automatically shuffle between them either sequentially or
randomly and at the rate of speed you specify in the slide show control
palette (see Slide show options).

How to begin a disk slide show
Drag the folder whose contents you want displayed in a slide show to
SimpleImage’s icon or to any window already open in SimpleImage.
The Open Folder dialog box will appear (see below). Select the “Dis-
play contents in slide show” option, adjust the slide show options and
click OK.

You can also begin a disk slide show by selecting “Slide Show” from
the View menu. In the dialog box that appears, select the “Use items in
the selected folder” option and click the “Choose” button to choose a
folder. (The Slide Show dialog box remembers the last folder you used
to display a disk slide show.)

Disk slide show options
SimpleImage lets you specifiy how to sort the items in a disk slide

If SimpleImage’s icon doesn’t
highlight when you drag a

folder over it, you may need to
rebuild your desktop.

Restart the computer and hold
down the command and option
keys until the desktop appears

and a dialog box asks you to
confirm that you want to rebuild

the desktop.

Tip: Type command-shift-D to
start a memory slide show

without showing the Slide Show
dialog box.
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show (by name, date created or date modified), and in what order to
sort them (forwards or backwards).

The “Open sub-folders x levels deep” option lets you specify how
deeply SimpleImage will burrow into sub-folders as it navigates
through the items of a folder in search of items to display in a slide
show, from 0 (no sub-folders) to 7+ (an infinite number of sub-fold-
ers).

Only the 0 and 1 options are
enabled in the “Open sub-

folders” popup menu until you
register SimpleImage.

For example, in the folder above, SimpleImage will display only
Image 1 and Image 2 if the “Open sub-folders” option is set to 0,
Image 1, 2, and 3 if the option is set to 1, and all the images if the
option is set to 2 or more.
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How to end a slide show
Click the stop slide show button (the button with the red x) in the
control palette, or choose “Slide Show” from the View menu or from
the current slide show item’s contextual menu.

Adding and removing memory slide show items
You can add or remove items in a memory slide show even while it’s
running. To remove an item, just choose “Close” from the File menu.
You can add items to a memory slide show in progress in all the same
ways you normally open items in SimpleImage: by choosing “Open,”
by dragging files into the slide show, by choosing an item from the
Reopen menu, etc. If closing an item leaves fewer than two images or
movies open, SimpleImage will automatically end the slide show.

Navigating through slide show items
To move to the next or previous item in either kind of slide show, click
the previous or next item button in the slide show control palette, or hit
the left or right arrow key.

To jump to a specific slide show item, choose the item you want from
the Item popup menu in the slide show control palette, the Window
menu (memory slide show) or the Item contextual sub-menu (disk
slide show).

Using the Item sub-menu
When you run a disk slide show you can use the Item menu (which
appears both in the slide show’s contextual menu and in the Item
popup in the slide show control palette) to navigate around the items in
the slide show folders.

The Item menu shows the current folder and all the openable items in
it. You can move to a file by choosing it in the Item menu. Choosing
the current folder item at the top of the menu takes you back into the
folder that contains the current folder. (If you haven’t burrowed into
any sub-folders the current folder item is disabled.)

An Item menu sorted be name, Z – A

The current folder

The items in the
current folder
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For example, say you ran a slide show
from a folder like the one to the left,
“Plants & Animals,” sorted Z – A by
name, with the “Open sub-folders” option
set to 1.

This slide show would start with
“Yew.jpg” and end with “Chickadee.jpg.”
(If the Loop option is selected in the slide
show control palette, the slide show will
loop back to the first item after displaying
the last.)

If you looked at the Item menu as soon as
the slide show started but while it was
still on the first item, the menu would
look like the one in illustration A (be-
low).

The current folder (Plants & Animals) is
shown at the top, and below it all the
openable items (including both files and
folders) in it. The current slide show item
is marked with a checkmark. The current
folder item is disabled because this is the
“root” folder, i.e., the folder the slide
show started with, and so you can’t move
up into its parent folder.

Choosing a file advances the slide show to it. Choosing a folder makes
that folder the current folder and display the first item in it.

For example, if you chose “Birds” SimpleImage would make “Birds”
the current folder and display the file “White-throated Sparrow.”

If you looked at the Item menu while the slide show was displaying the
image “Golden Retriever.jpg” in the folder “Dogs,” the menu would
look like the one in illustration B (below).

Here the current folder item “Dogs” is enabled, because the folder is a
sub-folder of the folder the slide show started with. Choosing it would
make its parent folder (in this case, “Plants & Animals”) the current
folder and would display the next item in the parent folder, in this case,
“Columbine.jpg.”

Item menu B

Item menu A
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Slide show options
If you have multiple monitors SimpleImage uses the “Open on...”
setting in the View pane of the preferences dialog box to determine
which monitor to display the slide show on. You can also specify
whether SimpleImage displays the control palette when starting a slide
show by selecting or deselecting the “Show slide show control palette”
option in the Interface pane of the preferences dialog box.

The other two options are located in the slide show control palette:
random and delay. Selecting “Random” will make SimpleImage
shuffle randomly through the items in the slide show. (When the
“Random” option is selected, both the Previous and Next buttons will
choose an item at random.) The delay option lets you specify how
quickly SimpleImage will shuffle through the items in the slide show.
By clicking the up and down arrows you can set the delay to between 1
and 60 seconds.

Adding a slide show soundtrack
You can add a soundtrack to any memory slide show that doesn’t
already have an item with sound. Open a sound-only movie together
with the images and movies you want to appear in the slide show, and
SimpleImage will automatically play the soundtrack movie while
running the slide show. (You can only add a soundtrack to a slide show
if the soundtrack movie has no video and there are no other movies
with sound in the slide show.)

Selections in slide show images
While a slide show is playing, SimpleImage hides any selections in the
images in the slide show and doesn’t allow you to create any selec-
tions. You can create selections in slide show images, however, by first
pausing the slide show.

The slide show control palette

Tip: Most of the control
palette’s controls have keyboard

equivalents:
Spacebar: play/pause

Left & right arrow: previous/
next item

Up & down arrow: increase/
decrease delay

Tip: You can always hide or
show the control palette and/or

the info palette while a slide
show is in progress by hitting

the tab key.

Tip: You can also adjust the
delay by hitting the up and

down arrow keys on the key-
board.

Item popupNext/Previous
buttons

Play/Pause
button

End slide show

Timer
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Saving Files

In addition to opening and viewing files in SimpleImage, you can also
save files in a variety of formats. (Note: If you don’t have QuickTime 3
installed, you’ll only be able to save files as QuickTime image files.)

To save an image, choose “Save” from the File menu. If you have
QuickTime 3 installed, you’ll see a dialog box giving you a choice of
formats in which to save the image.

If an image or movie is transformed (i.e., rotated or reflected), the
transformations become permanent when the image or movie is saved.
In addition, the current zoom level of a movie becomes permanent
when the movie is saved, but images are always saved at their original
size.

If an image has been cropped, saving the image saves only the cropped
portion, unless you save the image as a picture or QuickTime image
file, in which case any cropping that has been applied to the image is
ignored and the image is saved in its original dimensions.

In addition to being saved, movies can be exported in a variety of
formats by selecting “Export Movie” from the file menu.

Printing Images

You can print any image in SimpleImage by choosing “Print” from the
File menu.

Images are printed with any cropping or transformations that have
been applied to them, but the current zoom level of the image is ig-
nored and SimpleImage always attempts to print the image at its full
size, scaling it if necessary to fit the page.

By default, SimpleImage centers the image on the page. You can
change this by deselecting “Center on page” in the Print dialog box.

You can have SimpleImage print the name of the image file below the
image by selecting “Print name” in the Print dialog box.

You can also have SimpleImage print the location of the image file by
selectin “Print location” in the Print dialog box.

If the image has a selection, you can have SimpleImage print only the
selection by selecting “Print selection only” in the Print dialog box.

If you’re printing on a laser
printer, you may need to select

“SimpleImage” from the popup
menu in the Print dialog box to

see SimpleImage’s printing
options.
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Mac OS 8 Tip: You can also
move a SimpleImage file to the

Trash by holding down the Shift
key and dragging the window’s

title bar to the Trash icon.

Manipulating Files

Introduction
To understand the features that SimpleImage provides for manipu-
lating files in the Finder, it’s important first to understand the
difference between an image file and the image itself.

An image file contains the raw data that make up an image and is
stored on your hard drive by the Finder, the application that keeps
track of all your files and helps you organize them in folders. The
Finder assigns all your files an icon, like the one on the right.

When you open a file in SimpleImage, SimpleImage displays the
contents of the file in a window. When you transform the image by
choosing commands in the View menu, you are only changing the
way the image is displayed; you are not changing the image file
itself.

SimpleImage, however, also includes features which allow you to
manipulate the Finder file that an image window represents with-
out switching to the Finder.

SimpleImage can

• Move a file to the Trash
• Move a file to another folder
• Change a file’s label
• Switch to the Finder and instantly locate and display the

file’s icon
The following section describes how to use SimpleImage’s Finder
integration features.

Moving a file to the trash
If you open a file in SimpleImage and decide you no longer want it
you can move the file to the Trash directly from SimpleImage by
choosing “Move To Trash” in the Special sub-menu of the File
menu. This moves the file to the Trash and closes its window and
any duplicates (see “Opening a new copy of a window”) open in
SimpleImage. This does not delete the file; to delete the file you
must move the file to the Trash, switch to the Finder and choose
“Empty Trash” from the Special menu.

If you change your mind you can return the file to its original
location and reopen its window in SimpleImage by choosing
“Undo Move To Trash” from the Edit menu.

Locating a file in the Finder
If you open a file in SimpleImage and then wish to locate the file’s

An image file icon in
the Finder

The image displayed in
SimpleImage



23

Tip: You can shift-drag any
window in SimpleImage, not

just the frontmost window.

Tip: The shift key only needs
to be held down when you

first start dragging.

icon in the Finder, choose “Reveal In Finder” from the Special sub-
menu of the File menu. SimpleImage will switch to the Finder, open
the window that contains the file’s icon, if necessary, and select the
icon.

“Close & Reveal” works the same as “Reveal In Finder,” except that it
first closes the file’s window in SimpleImage.

If the file is on a disk that you have removed, SimpleImage will ask
you to reinsert the disk and give you the choice of cancelling the
command.

If the file has been deleted, SimpleImage will display an error mes-
sage.

You can also command-lick a window’s title to see the file’s location if
you’re using Mac OS 8.

Moving a file to a new location (Mac OS 8 only)
If you open a file in SimpleImage and then decide you want to move
the file to a different folder in the Finder, you can move the file to its
new location without leaving SimpleImage if the new location is
visible on the screen.

When the shift key is held down, every window in SimpleImage acts
as a proxy for the file the window represents. That is, you can drag the
window just as if it were an icon in the Finder.

Hold down the shift key and drag the window’s title bar till the arrow
pointer is pointing to the place in the Finder where you want the file to
be moved. As you move the mouse SimpleImage will drag the file’s
icon and name to let you know that you are dragging the file the
window represents and not the window itself.

Dragging a proxy from SimpleImage works exactly like dragging a file
in the Finder. Holding down the option key (in addition to the shift
key) creates a copy of the file in the new location, and holding down
both the option key and the command key creates an alias.

Applying labels
In addition to moving files around, you can also apply Finder labels to
files from SimpleImage.

To apply a label to a file in SimpleImage, select the file’s window and
choose the label you wish to apply to it in the “Finder Label” sub-
menu in the File menu.

If you’re using Mac OS 8 and you have the “Use Finder icons” and
“Show label” options selected (see Changing Preferences), the label
applied to a file that’s open in SimpleImage will also be applied to the
window’s icon in the Window menu in SimpleImage.

Tip: If you have Mac OS 8’s
Spring-Loaded Folders

feature enabled, you can use
it to drag a SimpleImage
window to any folder on

your hard drive. Just shift-
drag a window over a folder
or disk icon and pause till it

springs open.

The “drag proxy” pointer

Tip: To switch to the Finder
without locating and selecting a

file, type option-home.



24

The Info Palette

To show or hide the Info palette,
choose “Show/Hide Info

Palette” from the Window menu.
To temporarily hide and show

the Info palette (and/or the slide
show control palette if you’re
running a slide show), hit the

tab key.

(width, height)

(width, height)

The current location of the pointer (h, v)

The top left corner of the selection (h, v)
The bottom right corner of the selection (h, v)

The dimensions of the selection (w, h)

The amount of memory the offscreen bitmap uses
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Changing Preferences

SimpleImage’s Preferences dialog box is divided into six parts, or
panes, which you switch between by clicking in the scrolling list of
icons to the left. Below is a brief description of all the options found in
each pane.

Pane 1: View
Snap images to window Controls whether SimpleImage displays
images in snap-to-window view or scroll-bar view when they’re first
opened. See Viewing And Transforming Images.

Open scroll-bar images at 100% By default, when you open an
image in scroll-bar view, SimpleImage calculates the maximum mag-
nification for fitting the image exactly to the screen and then rounds up
to the nearest fixed zoom level. Switching an image from snap-to-
window view into scroll-bar view works similarly—SimpleImage
changes the zoom level of the image to the next highest preset zoom
level. To force SimpleImage to always initially display scroll-bar view
images at 100%, select this option. To report me to the Society for the
Prevention of Split Infinitives, call... never mind.

Show zoom level in window title Controls whether SimpleImage
displays an image or movie’s current level of magnification or reduc-
tion.

Show when resizing Controls whether SimpleImage displays the
current zoom level dynamically in the window’s titlebar as the window
is resized. Applies only to windows in snap-to-window view.

Show window duplicate number Controls whether SimpleImage
dynamically displays the duplicate number of each window. Duplicates
of windows are created when you choose “Duplicate Window” from
the Window menu (see Duplicating windows) or when you zoom a
selection in an image window (see Zooming and cropping images).

Don’t cover Finder icons When this option is selected, SimpleImage
will not allow windows to be zoomed to cover the area of the desktop
on the right where the Finder’s disk icons are typically located.

Open on... If you have more than one monitor you can control how
SimpleImage decides which monitor to open files on by selecting one
of the Open on... options. (This option also determines which monitor
SimpleImage uses to run slide shows on.)

“On deepest screen” causes files to be opened on the screen with the
greatest bit-depth, i.e., the screen set to display the most colors.

“On largest screen” causes files to be opened on the largest screen.
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“On main screen” causes files to be opened on the screen with the
menu bar.

Open dragged files on parent screen When you open an image by
dragging its icon into SimpleImage, if this option is selected Simple-
Image overrides the monitor specified in the “Open files” settings, and
instead opens the file on the screen that contains the window you
dragged the file onto.

Pane 2:Movies
When in background... This set of options controls how SimpleImage
handles the playback of movies when in the background.

Play sound in background Unless this option is selected, SimpleIm-
age will mute all open movies when in the background.

Only front movie plays sound When this option is selected, Simple-
Image mutes all but the frontmost movie.

Ignore movies without sound When this option is selected,
SimpleImage will continue to play the sound of the frontmost movie
that has sound, even if another movie without sound is in front of it.
When this option is deselected, SimpleImage will only play the sound
of the frontmost movie, whether it actually has sound or not.

Pane 3: Files
Show recent files in Reopen menu Controls whether SimpleImage
adds files to the Reopen menu as you close them.

Show last x files Lets you specify the number of files to show, up to
99.

Add slide show items to Reopen menu By default, SimpleImage
doesn’t add the items in a disk slide show (see Slide Shows) to the
Reopen menu. To have it add them, select this option.

Change files’ icons... When you open a file in SimpleImage that was
created by another application, SimpleImage can optionally change the
file’s creator type so that the next time you double-click the file it will
open in SimpleImage rather than the application that created it.
(Changing the file’s creator type also causes its icon to change.)

To enable this feature, select the “Change image files” and “Change
movie files options.” You can also specify separately whether
SimpleImage changes Photoshop files by selecting or deselecting the
“Leave Photoshop files alone” option.

Fix incorrect file types When this option is selected, SimpleImage
will check every file you open to see that its file type and icon are
correct, and if not (for example, if a GIF file has mistakenly been
assigned the file type and icon of a JPEG file), correct it.
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Pane 4: Snapshots
Show open Snapshot dialog box When this option is selected,
SimpleImage will display a dialog box showing the contents of a
Snapshot before opening it.

Close windows before opening slide show Snapshot When this
option is selected, SimpleImage will close any open windows before
opening a Snapshot containing a slide show. If you open a slide show
Snapshot and this option is not selected, SimpleImage will add all the
currently open windows to the slide show recorded in the Snapshot.

Suggest name for Snapshot These options let you specify whether
SimpleImage suggests a name for Snapshots, and what it suggests.

Append file count Adds the number of items recorded in the Snapshot
to the Snapshot file’s name.

Suggest folder for saving Snapshots Lets you specify a default folder
to go to when making Snapshots.

Put file names in Snapshot file’s comments When this option is
selected, SimpleImage lists (the first 200 characters of) the file names
of all the items recorded in a Snapshot in the comments of the Snap-
shot file.

Pane 5: Memory
Store images in memory When this option is selected, SimpleImage
stores images in memory whenever there’s enough memory available.
When this option is not selected, SimpleImage has to decompress the
image whenever its window needs to be drawn, saving memory but
slowing SimpleImage considerably.

Always rebuild bitmaps By default, every time an image is resized or
otherwise transformed, SimpleImage reconstructs its offscreen bitmap
of the image to ensure the best possible performance when drawing the
image on the screen. The disadvantage of this way of doing things is
that you have to endure a slight pause (or a rather long one, depending
on the size of the image and the speed of your Mac) every time you
transform or resize an image. This can be disabled by deselecting this
option. Disabling this feature improves the speed with which Simple-
Image resizes and transforms images, but it can make the on-screen
drawing of images somewhat slower.

The setting of this preference also effects the way SimpleImage uses
memory: when “Always rebuild bitmaps” is selected, SimpleImage
only maintains an offscreen bitmap at the current size of the image, so
viewing an image at 25% will consume far less memory than viewing
it at 250%. When, however, this option is deselected, SimpleImage
always maintains bitmaps at the image’s original dimensions, so
whether you view an image at 25%  or 250% it will still consume as



28

much memory as it would if you viewed it at 100%.

Limit bitmaps to 16 bits If your Mac is set to display millions of
colors, you can select this option to force offscreen bitmaps to have at
most thousands of colors. Because displaying images in 16-bit color
requires far less memory than displaying them in 24-bit color, select-
ing this option can significantly reduce the amount of memory
SimpleImage uses, but it can also significantly slow down the redraw-
ing of images.

This option has no effect unless your Mac is set to display millions of
colors.

Use temporary memory If SimpleImage doesn’t have enough
memory to open a file and keep its image decompressed, it attempts to
borrow memory from the system software. As a result the amount of
memory that SimpleImage claims for itself grows and shrinks with the
number of images you have open. Deselect this option to prevent
SimpleImage from using any more memory than you explicitly give it
in its Info window in the Finder.

Leave x % free When the “Use temporary memory” option is se-
lected, SimpleImage lets you specify, as a percentage of the total
installed RAM in your Mac, a temporary memory “cushion.” This
cushion prevents SimpleImage from borrowing temporary memory
from the system when the available system memory dips below this
threshold.

For example, if you have 40 megabytes of RAM and you set this
option to 10%, SimpleImage will only attempt to borrow temporary
memory if there’s more than 4 megabytes of system memory available.

Pane 6: Interface
Show icons in menus Controls whether SimpleImage displays icons
next to file names in the Window, Reopen and Open menus.

Use Finder icons Deselect this option to force SimpleImage to use
generic icons in the Window and Reopen menus.

Show labels When this option is selected, SimpleImage applies the
current Finder label to the item’s icon in the Window, Reopen and
Open menus.

Show Open sub-menu Deselect this option to prevent SimpleImage
from showing the Open sub-menu in contextual menus. Because
creating the Open sub-menu can take some time, deselecting this
option can make contextual menus appear faster.

Show animated rectangles Controls whether SimpleImage shows
animated rectangles when resizing, transforming, zooming and dupli-
cating windows.
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Collapse window when dragging proxy Tells SimpleImage to col-
lapse all its windows when you drag a proxy. (See Moving a file to a
new location.) Collapsing the windows makes more of the desktop
visible, but it's visually kludgy since the windows belonging to other
applications won’t redraw. The Finder’s windows, however, will
redraw as you drag the file across them. After finishing the drag,
SimpleImage will restore its windows’ original states, expanding only
the windows that were expanded before the drag started.

Full-screen background Click this box to change the background
color used when displaying images full-screen or in a slide show.

Show/hide menu bar automatically By default, when displaying an
image or movie full-screen on the main (menu bar) screen,
SimpleImage shows the menu bar automatically when you move the
mouse into the region at the top of the screen where the menu bar
normally lives, and then hides it again automatically when you move
the mouse away.

If you deselect this option, SimpleImage will only display the menu
bar if you move the mouse into the menu bar region and click.

Show slide show control palette Controls whether the slide show
control palette is displayed when a slide show first starts.

Show slide show transitions When this option is selected,
SimpleImage displays a sliding transition effect when switching
between the items in a slide show.

For this option to work correctly the “Store images in memory” and
“Always rebuild bitmaps” options should be selected.

Speed This popup menu lets you choose the speed of the slide show
transition effect.

Tweak Click this button to open a dialog box allowing you to enter
numerical values to fine-tune the speed settings in the Speed popup
menu.

To temporarily prevent
SimpleImage from showing the

menu bar, hold down the
command key.
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File Types SimpleImage Can Open

segamiGEPJ gpj. 5.2 .3TQeriuqerselifGEPJevissergorP

segamiFIG fig. 5.2 3TQeriuqerselifFIGdetaminA

segamiTCIP tcp. 5.2

segamitniaPcaM tnp. 5.2

segamipohsotohP dsp. 5.2 .egamidetisopmocyalpsidylnonaC

selifegamiemiTkciuQ fiq. 5.2

segamiscihparGnociliS bgr. 5.2

segamiFFIT fit. 3

segamiGNP gnp. 3

segamiagraT agt. 3

segamipamtibswodniW pmb. 3

seivomemiTkciuQ vom. 5.2

seivomIVA iva. 3

seivomGEPM gpm. 3 hsotnicaMrewoPaseriuqeR

The following table lists each type of image and movie file that
SimpleImage can open, its typical filename extension, the version of
QuickTime it requires, and any special issues that you should be aware
of.

Note that SimpleImage doesn’t require QuickTime 3 Pro.
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