
Camera Tutorial  - Introduction

Introduction

Welcome to the Camera Tutorial. This tutorial is intended to teach you the following:

• The function of the various automatic cameras.
• How to control the camera in the ReelMotion simulator.
• Reimporting motion data to create multiple camera motion files.
• Reimporting a camera file to see its position relative to the car.
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Camera View Modes

The next two pages show you sample images as seen from the various cameras in a ReelMotion simulation. The
snapshots have been taken at 4 different times in the simulation to illustrate how a particular camera might track a
scene.

Column 1: Roam (Fixed) Column 2: TV Track Column 3: Cockpit



Camera View Modes (Continued)
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Column 4: Attached Column 5: External Column 6: Chase

NOTE:  In order to operate any of the cameras, you must first be in camera mode. Enter this mode by
hitting the F12 Key. The mouse is used to control both the vehicle and the camera so you must tell Reel-
Motion which mode you are in. Hit the F12 Key again to toggle back to drive mode. Always be sure to
look at the instrument panel in ReelMotion to see which mode you are in and which camera you have
selected. If something is not working like you expect, it is often because you are not in the correct mode.



Roam or Fixed Camera (F2 Key)

The camera views in Column 1 show how the Roam camera works. It is also called the Fixed camera because it will
not move during our simulation unless we take manual control (you will learn how to do this later). Where you place it
before the simulation begins is where it will stay put. You can see in the sequence of pictures above (from top to
bottom) that the camera is fixed in place because the terrain and background does not move from frame to frame.

Before a simulation beings the camera is a Roaming camera. This mode is used to easily position your camera some-
where in your scene. If you move the mouse up or down, your camera pivots up or down. Move it left or right and
your camera pivots left or right. Press the mouse button down and the camera moves forward. Option + mouse button
moves the camera back.

The Roam camera has an optional mode (option + F2 Key) that we also call Dolly mode. In this mode, your camera
can dolly up and down, left or right. However, you must hold down the mouse button in order to dolly, otherwise it
will function just like the Roam camera. Just like in Roam mode, moving the camera left or right simply pivots the
camera to look left or right. When the mouse button is held down and you move it left or right, the camera actually
slides left or right. Same with up and down. Here is an added twist: if the cursor is perfectly centered in the crosshairs
when you press the mouse button, you will notice that you cannot move in or out (unlike in regular Roam mode). But
if the cursor is above the crosshairs when you press the mouse button, it will zoom in. Move the cursor below the
crosshairs and it will zoom out. The option Roam mode just provides a completely different way of controlling the
camera. Consider it a "super camera" control mode where you can position it almost every way with just the mouse.
After using ReelMotion for a while, you might come to find the option Roam mode the most efficient way to position
the camera in your scene . Play around with this for a while to get a feel for the difference between the two modes.

TV Track (F5 Key)

This is one of our automatic cameras. You do not activate TV Track mode until you have positioned your camera in
some other mode like Roam. The TV Track camera always attempts to keep the vehicle or object centered in the
screen. Look at the pictures in Column 2 and notice that the crosshairs are always locked dead center on the car. It can
track it instantaneously or have any percentage of lag applied to it. The camera lag makes the tracking seem more fluid
since it adds a delay. It seems like a human operator is trying to "keep up" with the object in motion.

You can also position the TV Track camera so that it looks at some point other than the exact center of the vehicle. For
example, the default position of TV Track always keeps a motorcycle centered in the screen during a simulation. This is
fine except back in your animation program, if you attach a rider to your cycle, your rider's head will sometimes be off
screen because the camera only tracked the center of the cycle, not a cycle with a rider. Therefore, before beginning a
simulation, hit F12 to go into camera mode, position your camera in Roam mode then press F5 for TV Track. Now
move the camera to track a point up, down, left or right of the vehicle. You can also "zoom in" a little. Although our
"zoom" is a fake (we cannot control FOV in your animation program) you can only "zoom out" to where your camera
was sitting in the first place. If you need to move the camera back farther, you must go to some other camera mode like
Roam, where you can physically move the camera. You must hit F12 to exit camera mode to begin your simulation.
The TV Track camera also has an optional mode (option + F5 Key). Option TV Track is  a shortcut for turning off any
camera lag. Instead of going to the camera menu to change the lag adjustment to 0, simply hit option+F5.

Cockpit (F1 Key)

Cockpit mode is fairly self-explanatory: you are simply viewing the scene from the perspective of the vehicle. The
camera inherits the motion of the vehicle so any bouncing around will also be seen in this camera window.
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Camera View Modes (Continued)



Attached Camera (F3 Key)

As you can see in Column 4, the attached camera is always fixed to some exact point on the outside of the ve-
hicle. It would be almost as if there was a metal rod extending from the car to which the camera is firmly at-
tached.

If you hit F12 and enter camera mode while using the Attached camera, you can control it exactly like the Roam
camera except that your movement will be relative to the vehicle. The optional Attached mode also functions
exactly like the optional Roam (Dolly) mode does.

External Camera (F6 Key)

The external camera might also be called a fixed-direction helicopter camera. Wherever you position the camera
before the simulation begins, it will always continue to look at the vehicle in that compass direction. For example,
if your camera is looking North, it will always look North no matter where your vehicle drives in the scene. As
you can see in Column 5, the vehicle moves independently so it can turn left and right and even turn completely
around and face the camera. The camera will continue to follow the vehicle and keep the same distance from the
vehicle - varying only by the amount of lag or bounce you apply to it.

Note: The External camera is ReelMotion's default camera.

The optional External camera (option + F6 Key) is like a cross between the Attached camera and the External
camera. The main difference is that it does not stay locked in one compass direction. This camera will try to stay
on just one side of the vehicle but is free floating and not as rigid as the Attached camera. No matter which way
the vehicle turns, the camera will always attempt to look at the same side of the vehicle while tracking it.

Chase Camera (F4 Key)

Like the name implies, the Chase camera simulates a chase car or plane when tracking the vehicle. It is almost
always in a position behind the vehicle you are tracking.

In chase mode, the camera attempts to follow the motion path of the vehicle instead of keeping itself "fixed" on
the vehicle itself. Because of this, it follows a little more freely and randomly than the External and Attached
cameras.
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Camera View Modes (Continued)

TIP:  The best way to set up the Chase camera is to first switch to Cockpit mode (F1 Key) for an
instant and then switch to Chase mode. When you begin the simulation, the camera will move out
to a chase position behind the vehicle.



Working with Cameras

The following example will show you how to use a camera in your scene. What you learn here will be applicable
to most of the other cameras so feel free to experiment with the different modes once you have finished.

We will only be working in the simulator for this tutorial so we will be using the standard vehicles and defaults
already set up in there.

• Launch the ReelMotion Simulator.
• Select Simulation>Begin from the top menu and start driving the car around with the mouse. Try to make

your car do interesting things like curves or zig-zags. If you do not like the motion you are creating, hit the
Escape key and begin again.

• You'll want to make a motion file that is about 10 or 15 seconds in duration.
• When you are satisfied with the motion data, save it by selecting File>Save Motion As from the top menu.

Name the file Car Motion1 .
• Select File>Save Camera As. from the top menu and name it Camera Motion . We will also use this later.
• Select Simulation>Initial Conditions  from the top menu and enter a value of 2 Meters in the Position box

next to Right. Click on OK when you are done.
• Make a new 15 second simulation and save it as Car Motion2 . We will use it later.

NOTE:  We have created a motion file for the camera because operating the camera in the middle
of a simulation can be tricky and tends to interrupt your simulation. The reason being that the
mouse is used to control the vehicle as well as the camera. You may zoom in with the control key
and zoom out with the control+option keys but that is usually the only time you would want to
alter the camera during a simulation.
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It is easiest to first create a motion file by repositioning the default camera. You just need to see what is going on
in your scene. Once a motion file is created, you can then save it, reimport it and play it over and over while
experimenting with various cameras.

• Reimport your motion file as a Dynamic Object. To do this, select File>Add>Dynamic Object from the
top menu and choose your Car Motion1 file.

• Select Simulation>Observe from the top menu. If you were to begin the simulation without placing
ReelMotion in Observe mode, a second car would appear in your scene waiting to be driven by you. You
may wish to try it to see what happens.

• Begin the simulation (command-B) and observe the motion data that you previously created. After you are
finished, remember to hit the Escape key.

• Now try viewing your motion with the TV Track camera (F5 Key). You may change camera views at any
time while observing your simulation simply by hitting the proper function key.

• If you notice that your camera seems to have a difficult time keeping up with your vehicle, try lowering
the camera lag percentage. This is done under Preferences>Camera... and then adjusting the TV/External
Lag slider. Take it down to 15% and click OK. (see picture on the next page).
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Working with Cameras (Continued)

Working with Cameras

Begin the simulation again and notice how lowering the lag percentage enables the camera to track your vehicle
more instantaneously. Hit Escape to end.

TIP:  If you wish to set your scene back to the beginning so that you can properly position your
camera, hit command-B to begin the simulation and immediately hit the Escape key.
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Working with Cameras (Continued)

• While still using the TV Track camera, hit the F12 key to place you in camera edit mode.
• Position the camera so that it is centered at a point somewhere ahead of the car. If your camera does not

seem to be looking at the car from a good angle, briefly switch to the External camera (F6) to revolve
around the vehicle. Try and look at the side of the vehicle. Switch back to TV Track (F5)

• Begin the simulation again. Notice how the TV Track camera is tracking the car at a position somewhere
ahead of the nose.

At this point, if you like a particular camera motion that you make, you would want to save it in a file. (Do not
save it now since we will shortly be using the previous camera file you created called Camera Motion .) You can
even cut from camera to camera in your animation program by importing a number of camera shots of the very
same vehicle motion file.

• Next, import the second motion file you made called Car Motion2 . Import it also as a Dynamic Object
(File>Add>Dynamic Object). Since we offset the second car 2 meters to the right, they should be sitting
side by side.

NOTE:  When you begin the simulation with two dynamic objects, their paths may occasionally
cross. You will see them pass right through one another. The only time this does not occur is if you
import one of the objects as an Interactive Dynamic Object (File>Add>Interactive>Dynamic
Object). However, an Interactive Dynamic Object will only interract with a car that you are cur-
rently controlling. In other words, it will pass right through a Dynamic Object - a previously saved
motion file. Also, you can only have one Interactive object in your scene at a time. You can have
many Dynamic Objects.

• Begin the simulation. Notice that the camera is tracking only one of the vehicles. What if you would like
to track the other vehicle?

• Simply hit the Target key (F10) at any point during the simulation to switch from car to car. If you had 3 or
4 or even more cars in your scene, F10 would simply toggle through all of them before coming back to
the first.

Reviewing Your Camera Motion

The final step in this tutorial will show you how to reimport a camera file so that you can see how it tracks the
vehicle in your scene. This is useful if you think your camera might be passing through scenery or terrain in your
scene. The latter is especially common if you are tracking a vehicle moving over a very hilly terrain and your
camera is fairly close to the ground. Rather than render a scene overnight only to discover your camera spent 10
seconds filming through topsoil, you should review your entire scene in ReelMotion - camera and all.
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Reviewing Your Camera Motion (Continued)

• First, be sure you are still in Observe mode (Simulation>Observe ).
• The only dynamic object we want in the scene now is Car Motion1 . Look at ReelMotion's project window

(the far left window). Delete all of the objects in that window except for the one named Car Motion1 .
• Select File>Add>Dynamic Object and choose the Camera Motion file you created earlier. It will create a

little Film Camera icon in your scene that represents the camera tracking your vehicle.
• You will probably now have to reposition the current camera so that you can see both the vehicle and

your camera motion file.
• Hit the F6 Key to change the camera to External mode. Now hit the F12 Key to switch the mouse to

camera mode.
• Move the mouse left or right to revolve around the car until you see both the car and your other camera in

the window. Once it is positioned, hit the F12 Key to exit camera mode.
• Your scene may look similar to the one below or it may be positioned on the other side of the car. You

simply want to see both your camera and car in the window.
• Select Simulation>Begin (command-B) to watch how the camera tracks your vehicle.

You are now finished with the camera tutorial. Feel free to experiment with all of the cameras using the same
instructions that were used for the TV Track camera. Also try and play with the different settings in the camera
preferences (Preferences>Camera ) See what turning on Jitter and/or Bounce will do to your camera motion.
Further details on the use of these special features are covered in the Reference manual.


