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Before you begin
The Media Cataloger is a stand-alone application that lets you organize,
find, and retrieve graphics, movies, sounds, and text for use in other
applications.

To use the Media Cataloger, you create a visual index of multimedia
objects and attach key words to them. You can search for graphics files
simply by looking at their thumbnails in a catalog, or by entering a key
word.

Terms

The following terms appear in this guide:

Object Another name for a multimedia entity. Objects include
pictures, movies, sounds, and text.

Catalog A file created with the Media Cataloger. Catalogs
contain a visual index of objects—graphics, movies,
sounds, or text—and the key words associated with each.

Blowup A view of a cataloged object that shows a picture or
movie at its natural size.

Key word A word or phrase you attach to an object in a catalog so
that you can search for it. For example, you might
attach the key word “color” to all color pictures in the
catalog. When you later enter the key word “color,” the
Media Cataloger shows all objects with this key word
attached.
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Chapter 1

Installing the Media Cataloger
To install the Media Cataloger follow the instructions on the Read Me
file included with your product.

After completing the installtion proceed as described below.

Application
icon

✓ To launch the Media Cataloger, double-click its icon.

Three windows appear:

The Catalog window displays a thumbnail picture of each object in
the catalog. When you open a new file, this window is empty.

The Information window displays information about the current
catalog and the objects selected in the Catalog window.

The Display window shows the key words assigned to the objects
selected in the Catalog window. You also enter search criteria—key
words and object types—in this window.

Selecting windows

To select a window, click in it or choose it from the Window menu.

To close a window, click its close box.

To open a window, choose it from the Window menu. In the Window
menu, a check preceding a window’s name means that it is currently
selected; a dash means that it is closed.
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Chapter 2

Creating a catalog
You can add the following objects to a catalog:

■ Text
■ Pictures for which you have Claris XTND System Translators—for

example, PICT, Gif, JPEG,TIFF, EPS ,  Photoshop™ and MacPaint
formats,

■ Sound files of the following format:  AIFF, QuickTime midi
■ QuickTime movies
■ ‘PICT’ resources
■ ‘snd ’ resources

The objects can reside on your hard disk, floppy disks, or any other storage
media. To find out where a cataloged object is located, select its thumbnail
in the Catalog window. The Information window provides the path name.

Opening a catalog file

To create a new catalog

✓ Open a new file.

When the Media Cataloger starts, it creates a catalog named
“Untitled-1.” To create additional catalogs, choose New from the
File menu.

Adding pictures, movies, and sounds

To add pictures, movies, and sounds to a catalog

✓ Choose Add Object from the Catalog menu.

The Open File dialog box appears.
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Open File dialog box

Navigate to the folder that contains the object you want to add. The
folder can be on the hard drive, a floppy disk, or any other storage
media.

✓ Select the Pictures, Sound, Movies, ‘PICT’ Resources, or ‘snd ’
Resources checkboxes to define the types of files you want to see. For
example, if you want to see pictures, only, select the Pictures
checkbox.

NOTE: If you select the ‘PICT’ Resources or ‘snd ’
Resources checkboxes in the Open File
dialog box, all files are displayed. However,
when you select a file, only its PICT or snd
resources are added to the catalog. If a file
has no resources, nothing is added to the
catalog.

To view images of the PICT files and QuickTime movies before
adding them to the catalog, click the Show Preview checkbox to select
it. If a preview does not appear for the selected object, click the Create
button to create and display a preview. You can create previews only
for PICT files and QuickTime movies.

✓ Add one or more objects to the catalog

To add a single file,  select it, then click the Add File button. An icon
of the file appears in the Catalog window, and information about it
appears in the Information Window.

To add all files in a folder , select the folder, then click the Add
Folder button.
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To add all files from a disk to a catalog, navigate to the Desktop, select
the disk, then click the Add Volume button.

As the Media Cataloger adds the objects, a dialog box shows the
progress. To stop adding objects, click the Stop button or press
Command-. To skip the current folder, click the Skip folder button.

NOTE: While the Media Cataloger is cataloging
objects, you can continue to use most of its
features as you would ordinarily.

Thumbnails of the files appears in the Catalog window.

Catalog window with three objects

Adding text objects

To add text objects to a catalog

✓ From any application, copy the text to the Clipboard by selecting it
and pressing Command-C.

✓ In the Media Cataloger application, click in the Catalog window to
select it, then press Command-V to paste the contents of the
Clipboard.

The Name Catalog Object dialog box appears.
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Name Catalog Object dialog box

✓ Type a name for the text object, then click the OK button.

The pasted text appears as an icon in the Catalog window. Its name
appears at the bottom of the thumbnail picture.

Catalog window with text and picture objects
6 Creating a catalog
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Renaming cataloged objects

An object’s name is one of the key words you can use to search. You might
want to rename objects whose names are not descriptive. For example, you
might want to rename a picture of a tree from “Page 2 illustration” to
“Tree.”

NOTE: Renaming the object in the Media Cataloger
does not change the actual file name.

✓ Select the object, then choose the Rename command from the File
menu.

The Rename Catalog Object dialog box appears.

Rename Catalog Object dialog box

✓ Type the new object name and click the OK button.

Saving a catalog

To save a catalog, choose one of the save commands from the File menu.

✓ To save a catalog for the first time, and to save changes as you work,
choose Save.
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✓ To save a copy of the catalog under a different name or in a different
location and to continue working with the new copy, choose Save As.
The new version of the catalog appears on your screen, and the
original is returned to its folder as it was the last time you saved it.

✓ To save a copy of a catalog under a different name or in a different
location, and to continue working with the original copy, choose Save a
Copy In. A copy of the catalog in its current state will be saved in the
folder or disk you select. The original version of the catalog remains
on your screen.

✓ To discard changes made since the last time you saved a catalog,
choose Revert.

Deleting an object from a catalog

To delete objects from a catalog

✓ Select the objects in the Catalog window.

✓ Choose Clear Cat Object from the Edit menu, or press the Delete key.

The object no longer appears anywhere in the Media Cataloger
application.

NOTE: If you delete objects in error, you can restore
them to the catalog immediately after deleting
them by choosing Undo from the Edit menu,
or pressing Command-Z.

8 Creating a catalog
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Chapter 3

Selection techniques
There are several techniques for selecting objects in the Catalog window
and key words in the Display window.

■ To select a single item, click it.

■ To select a group of adjacent items, click the first item, hold down the
Shift key, then click the last item. All items between the first and last
will be selected.

■ To select multiple items that are not adjacent, hold down the
Command key as you click each item.

■ To select the item to the right or left of a selected item in the Catalog
window, press the right or left arrow key.

■ To select an item above or below a selected item, press the up or down
arrow key.

■ To select the first or last item in a row, select an item in the row, then
hold down the Command key and press the left or right arrow key.

■ To select the first or last item in a column, select an item in the
column, then hold down the Command key and press the up or down
arrow key.

■ To select an item by name, type the first few letters in the name. This
technique is most effective in the Catalog window if the items are
sorted by name.
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Chapter 4

Assigning key words to objects
Key words are words or phrases that you can use to find objects. To
simplify your searches, you might want to assign the same key word to
objects that are related to each other—for example, objects used in a
project, color pictures, or movies and pictures that mention a particular
topic.

You can assign multiple key words to a single object. For example, to
catalog a QuickTime movie of a speaker, you might add one key word for
each topic discussed.

To assign a key word to an object or group of objects in a catalog

✓ In the Catalog window, select the object(s) to which you want to
assign the key word.

✓ Select the Display Window by clicking in it or choosing it from the
Window menu.
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Display window

Key words appear in the scroll box at the bottom of the window. The
name of the object is usually the first key word.

✓ Enter the new key word in the Key Words text box, then click the Add
button.

The new key word appears in the scroll box.
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Removing a key word

To remove one or more key words from selected objects

✓ In the Catalog window, select the objects from which you want to
remove the key words.

✓ Select the key word(s) in the scroll box.

✓ Choose Clear Key Word from the Edit menu, or press the Delete key.

The selected key words are removed from all selected objects.

Replacing a key word

To replace a key word with another key word for selected objects.

✓ In the Catalog window, select the objects for which you want to
replace key words.

✓ Select the key word(s) you want to replace from the scroll box.

✓ Enter the new key word in the Key Word text box.

✓ Click the Replace button.

The new key word replaces the original. If you selected multiple key
words, they are all deleted and replaced with the new key word.

Copying key words to other objects

You can copy one or more key words for an object and paste them in the
Display window for any other object. For example, if you added several
key words to a movie object and want to add the same key words to a
related picture, you can save time by copying and pasting the key words
from the movie object.

To copy key words to other objects

✓ In the Catalog window, select the object(s) that have the key words
you want to copy. For example, suppose you want to add key words to
a movie about the universe. If one picture object has key words
relating to planets and another picture object has key words relating
to stars, you could select both picture objects to view all their key
words.
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✓ Select the Display window by clicking in it or choosing it from the
Window menu.

✓ Select the key words you want to copy. To copy all the key words,
choose Select All Key Words from the Edit menu.

✓ In the Catalog window, select the object to which you want to add the
key words.

✓ Select the Display window, then choose Paste Key Words from the
Edit menu or press Command-V.

The key words are copied to the selected object.

Previewing objects

You can view any cataloged movie, picture, or text object at its full size—
and hear any cataloged sound object. This feature lets you view or listen to
objects from within the Media Cataloger application.

To view an object at full size

✓ Select the object in the Catalog window.

✓ Double-click the object, or choose Blowup from the Catalog menu.

The object appears in a scrollable window.
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If the object is a QuickTime movie, the Blowup window includes an
Apple®  QuickTime Player, which provides controls to play, stop,
advance one frame, go back one frame, and adjust volume.

Volume controller

Play button Slider

Single frame 
movement 
buttons

QuickTime player

If the object is a sound, it plays immediately. To play it again, click the
speaker icon.
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Chapter 5

Finding objects
After you have created a catalog of your files, you can use the Media
Cataloger to quickly find objects by type and key word. The thumbnails of
objects matching the search criteria appear in the Catalog window.

Media Cataloger searches the objects currently in the Catalog window. If
the Catalog window contains only picture objects and you search for
objects with the key word “color,” Media Cataloger retrieves only pictures
with this key word, not movies.

Finding objects by type

To see all objects in a catalog, regardless of type

✓ Click the Display All button at the top of the Display Window.

To see only specific types of objects

✓ Click the Display All button so that the Catalog window contains all
objects in the catalog.

✓ Click the checkboxes of the object types you want to appear in the
Catalog window. For example, to view Picture objects only, click the
Picture checkbox so that it is selected To view Picture and Sound
objects, click the Sound and Picture checkboxes so that they are both
selected.

Finding objects by type

✓ Click the Display Only button.

The Catalog window shows thumbnails of the objects with the
selected object types.
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Finding objects by key word

To find objects by key word

✓ Be sure that the Catalog window displays all the objects you want to
include in the search. If you want to search through all objects in the
catalog, click the Display All button. If you want to search through
objects with a particular type, select the appropriate checkboxes and
click the Display Only button.

✓ Select one or more key words to search for from the Key Word scroll
box, then click the Find button. If you prefer, you can type the key
word instead of selecting it from the scroll box. (If key words are
selected in the scroll box as well, Media Cataloger finds objects that
have all the key words: typed and selected.)

Thumbnails of objects with the specified key word(s) appear in the
Catalog window.

NOTE: You can search for objects with similar key
words by using the wild card characters ?
and *. The character ? matches any single
character. For example, picture? matches the
key words picture1, picture2, and picture3.
The character “*” matches zero or more
characters. For example, *run* matches run,
running, and rerun.

Sorting objects

To sort objects in a catalog

✓ Select the Catalog window.

✓ Choose Sort by Type, Sort by File Type, Sort by Name or Sort by
Pathname command from the Sort menu.
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Finding an object’s location

To find the location of a catalog object

✓ Select the object in the Catalog window.

The Information window shows information about the object,
including its file path. In the example, the Craftsman picture object is
on the hard disk ZFP 50-Q in the New Pix folder.

Information window
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Chapter 6

Copying objects to other
applications

You can copy objects from catalogs and paste them into Special
Delivery™ and other Macintosh applications.

To copy an object from a catalog to another application

✓ Select the object in the Catalog window.

✓ Choose Copy Cat Object from the Edit window, or press Command-
C.

The Media Cataloger copies the picture or movie on the Clipboard,
as well as a pointer to its location.

✓ Go to the application or catalog into which you want to paste the
object.

✓ Choose Paste from the Edit window or press Command-V.

The object is pasted in the form application expects: either as an actual
file, or as a pointer to the file’s location.

The object that is pasted is the original file, not just its thumbnail.

NOTE: You can only paste an object into an
application that supports its type. For
example, if you attempt to paste a Movie
object into an application that only accepts
pictures, just the movie poster will be pasted,
not the actual movie.

Copying multiple objects to another catalog

You can copy multiple objects from one catalog and paste them into
another. This is useful if you want to create a catalog that is a subset of
another. For example, if you have one catalog that contains all your
pictures, you might want to create another that contains black-and-white
pictures only.
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To create a subset of a catalog

✓ Select the objects you want to copy from the Catalog window.

✓ Choose Copy Cat Object from the Edit menu, or press Command-C.

✓ Choose New from the File menu.

Three empty windows for the new catalog appear.

✓ Select the Catalog window and choose Paste Cat Object from the Edit
menu, or press Command-V.

The catalog objects and their key words appear in the new catalog.
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Chapter 7

Printing
To print thumbnails of the objects in a catalog

✓ Click in the Catalog window to select it, then choose Print from the
File menu.

To print all key words in a Display window

✓ Click in the Display window to select it, then choose Print from the
File menu.
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