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 Page 3Nodester™—Quick-Start Example & Documentation

Please  Read

About This Adobe Acrobat Document

• Go through this Example in minutes—and you’re on your way!

• Underlined items within the Example are Interactive. Clicking on them will take you to additional
information about that topic.

• The Table of Contents is also interactive. Clicking on a topic in the TOC will take you to that
section.

TIP: To interact with the Table of Contents, view this PDF file in bookmark view (see circle on screen
below), Click on TOC and go directly to the Table of Contents.

• The Index is Interactive also. Just click on any index word and it will take you to the first
occurrence of that word.

TIP : Click on the Index from the bookmark (TOC) for quick access, then click on the Index word.

About the Gift Shop Example included on the CD ROM
The example pictures were created using an Apple QuickTake 150 camera with a Kaidan WideTake lens, a
Kaidan QuickPan tripod attachment and a Bogen tripod. Since the QuickTake is a consumer-level digital
camera, the pictures from it do not have the highest possible image quality. Film cameras and profes-
sional-level film and digital cameras offer superior image quality, but for our example we wanted to use
images that more closely resemble “typical use” pictures. These pictures were also slightly degraded
because they have been reprocessed using JPEG compression at a 75% quality level. This is because the
original images  were encoded using the proprietary QuickTake Codec that we cannot distribute. The JPEG
compression was  needed to keep the size of the example files reasonable.



 Page 4

• Nodester requires at least 16Mb of RAM allocated to itself, more if you are working with higher-
resolution pictures, very large source images, or more than 12-16 frames. Larger focal length lenses
can also affect your memory needs.

• For QTVR playback outside of Nodester, you will need either MoviePlayer or QTVR Player (both from
Apple and included on this CD-ROM) on your hard drive. These are small applications designed to let
you quickly play your QTVR panorama movies. After the QTVR 2.0 extension is installed, you will find
that any application that supports Quicktime (such as SimpleText) will now be able to play QTVR
movies. After installing the above extensions, be sure to restart your computer

• Nodester is designed to do its best image work in 24 bit color (16.7 million colors, monitor set to
millions in the Monitors Control Panel). Nodester will also work in thousands or 256 levels of color.

Are you using a Macintosh PowerPC
or Mac-compatible?

You cannot use this current
version of Nodester. Visit our web

page: http://www.panimation.com
for the availabilty of a non-Power PC

of version of Nodester 

NO

YES

Are the extensions QuickTime 2.5,
QuickTime™ VR 2.0 and

QuickTimeVRLib in your System’s
Extensions folder?

Copy the QuickTime Extensions
folder from the Nodester CD-ROM to

your unopened System folder.

Do you have at least 16 megs of
real RAM allocated to Nodester?

Assign more memory to Nodester
via the File>Get Info dialog box.

Nodester is now ready to run.

Getting Nodester 1.0 ready to run
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Setting  Preferences

Application Startup Prefs
1. Edit>Preferences>App. Startup
2. Configure what will appear upon program startup.

Scratch Disk prefs
• Edit>Preferences>Scratch Disks
• Nodester Does NOT support Application Virtual Memory.
• Nodester does use a scratch disk (the system disk as default) as a Swap Disk to automatically save

images during node processing. The scratch disk temporarily stores the work as it is processed. Once
the SAVE button is pressed, those changes are updated to the stored node file on the hard drive.

• The Scratch Disk feature also enables a recovery file (found in the Trash) should the program or
system crash. Drag the file from the Trash to the hard drive, then open it from Nodester.

• The auto save processes according to the speed of the scratch disk. A faster drive, therefore, speeds
up processing between saves.

• Adequate disk space must be available for Nodester to use the Scratch Disk. We recommend
allocating as much real RAM as possible.

• Restart the program after switching Scratch Disks.
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File storage prefs
• Edit>Preferences>File Storage
• File Storage preferences control performance during processing, NOT the quality of image.
• The Compressed (Lossless) selection does compress the file to decrease the node file’s size. Raw does

NOT compress the file, but processes Faster. There is NO loss of data using Raw storage.

Setting Preferences
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Step One The INPUT Panel
Upon launching Nodester, notice that the Input Panel is the only accessible panel. Other panels will
highlight as essential panoramic information is established panel by panel.

Source Format
• Multiple Frames enables capture or import of many frames either one by one or all at once.
• Single Panorama enables the import of one completed panorama generated by another application.

TIP: Name your source images with a number convention in order starting with: 01abc, 02abc, etc. This
will allow the sequential import of images into the frames.

Node Sweep
Node Sweep is the amount of image capture area in degrees. Typically, nodes are captured at 360 degrees
(full circle) or 180 degrees (half circle). Nodester allows custom settings for any degrees.

TIP: When shooting with a tethered digital camera, leave the Max. Frames setting at the camera mount
setting for a full 360 degrees (example: Peace River 360 degrees, leave Max. Frames at 18). Nodester will
automatically adjust the Frame Count when the Node Sweep is less than 360 degrees (example: at 18
Max. Frames and 180 degrees Node Sweep the Frame Count will be autoset to 9).

Max. Frames
When using a tripod, Max. Frames is the number of frames taken from the camera mount in a 360 degree
node sweep. This is either fixed or adjustable, and varies with the camera mount (example: the Peace River
camera mount has 2 detent wheel settings of 18 and 12 shots for a 360 degree sweep. Other wheel settings
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IMPORTANT:
Getting the Most Out of a Scene
 In order to achieve the best corre-
lation between panoramic frames,
it is best when the first two im-
ages are high contrast with objects
in the foreground scene.
 This will provide the subsequent
images with detail to correlate the
images in the entire sequence.
 Also, the first image should be a
“Dead Area” of activity, so that the
next images will create stimulating
visual activity into the panoramic
scene.

IMPORTANT: The Clockwise Rule
All panoramas MUST be Photo-
graphed in a Clockwise Direction
from the camera mount. Otherwise,
NO QTVR panoramic will occur in the
Playback Panel after Composing.

Step 1: The Input Panel
can be obtained).
When importing images, the Max. Frames needs to be a number

that will achieve a 40 percent or greater overlap (see Overlap
readout at the bottom of the Input Panel). To achieve this, con-
tinue to increase the number of Max. Frames, until the overlap is at
least 40 percent.

Lens Parameters
Nodester expects a lens rating equivalent to a 35mm camera. If you
know the 35mm equivalent focal Length, type it in the first field.
If you know the Field Of View (Vertical) type it in the second
field. Otherwise, FOV will be automatically calculated from the
length.
• If you have no idea of the Lens Length start at 45mm
• Lens length of 38-40mm is considered a low F.O.V. capture
• Video capture is 45mm
• Apple QuickTake 100 & 150 is 50mm
• Nodester’s default lens setting is for images taken from a

Kodak Photo CD

Rectilinear refers to “degree of perfection” of a lens to capture
boundaries (the very edges of an image). Professional quality lenses
ARE rectilinear, and capture a near perfect rectangular frame. Most
other lenses ARE NOT rectilinear and so this option should usually
be unchecked. If you are unsure, uncheck the Rectilinear box.

Specify the Image Size of your digital camera capture or scanned
file import (Photo CD, etc.). It is best to choose an image size that
closely matches the size at which images were captured (example:
480 x 640). If you choose a size other than the original fixed cap-
ture size, the source images will be Scaled proportionally accord-
ingly to the size you’ve input.

TIP: Always shoot images in a  Vertical (or Portrait) orientation.
Perimeter image detail is often lost in the correlation process
with images that are wider than the height.

Select the input source from the Acquire From pop-up menu. Con-
figure the acquisition selection by clicking on Setup Button.  For
this example, choose ‘PICT’ file.

TIP: Import or shoot one image and Check the Orientation and
Rotation of the first image before importing  all your images.
Start in the Frames Panel, import or shoot, then select the frame
and click the Edit Button.

If all of the selections have been made, the Frames Panel will
highlight. Proceed by clicking on the Frames Panel.
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Step Two The FRAMES Panel

The Frames Panel imports images into the selected
Compass target frame and creates a  Thumbnail View
of each image, starting at zero and rotating clockwise.
The exact number of frames and the degree sweep are
determined by the settings you chose in the Input Panel.

The Target Frame is the highlighted frame shown by a
double pixel border. All acquisitions begin on the zero
degree frame. (12 o’clock position)

Import images into Nodester. Depending on the Ac-
quire Type selected in Input Panel, click on the Grabber
Buttons as follows:

• PICT File (as used in this example) – Single or
Multiple Button imports one or a series of PICT
images. Once images are imported or shot, the
target frame will automatically advance in
clockwise order. Any frame may be manually
highlighted by clicking the frame, or use the Tab
and Shift Tab convention.

• Apple QuickTake 100 & 150 – Snapshot takes
one shot per mouse click. Interactive shoots the
entire sequence, then imports. Download brings
images already shot and stored in the camera into
Nodester directly.

• Video Grabber – Snapshot takes one frame per
mouse click. Interactive allows you to shoot the
entire sequence, then import your chosen frames.

IMPORTANT: A Word About Digital Cameras
Almost all digital cameras can export their files as
PICT images, so don’t be alarmed if you see that there
is no “import” option for your particular make of cam-
era. If your camera is not one of the QuickTake family
from Apple or the PDC-2000 from Polaroid, you should
use the PICT or PhotoCD import options. The special
options offered to these digital cameras are due to
the presence of “tethered control” plug-in modules
being present in the Plug-Ins folder in Nodester. More
tethered-control modules for other digital cameras
will be available soon and posted to our web site.
Check  - http://www.panimation.com for updates.
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1. Locate the Gift Shop folder inside the
Nodester Tutorial Folder.

2. Click the Add 16 Button as a shortcut
to fill the entire node with the specified
number of images. Since there are 16
frames per node, the button reads ‘Add
16’. If there were 18 frames per node it
would read ‘Add 18’. Otherwise, clicking
the Add Button will add one image at a
time to the list. Click the Done Button
when finished compiling the list to
import into the current node.

3. Save>File this node as a Nodester File.
Once imported, Nodester saves images
into the work file on the drive. If you
do not save the file, your work (not the
images themselves, but all that you do
to them) will be lost if there is a crash
or power outage.

4. Select a frame, then click on the Edit
Button to perform Minor Editing
functions such as lighten, darken,
cloning and text.

5. After Importing Multiple images, each
frame will show a thumbnail of that
image.

IMPORTANT: An Image Position Test
Import one image before importing the
entire node set. Look and check to see
if the Orientation of the image is
correct. If it is not, it may changed in
the Acquire From>Setup Button of the
Input Panel.

6. The Clear Button deletes an image.

TIP: Export the image as a PICT file while in the Frames panel as a single image or in the Panorama panel
(Step Four) as a single panorama image.

Step 2: The Frames Panel

TIP: Edit allows the image or parts of the image to
be selected by using the selection marquee, then
Copy>Paste. To select the entire image use
Edit>Select All.
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TIP: Once you have your settings all set up the way you want, save
your node file as a Stationery File to retain these settings. You may
wish to name the new stationery file after the camera you’ve used
(Nodester comes with a few stationery files for various cameras).
Later, you can open the stationery node file as a template for future
work. You can save your node file as a stationery file at any point,
but it’s best to save it at the end of the process, before you export.
The stationery file will save all your inputted information like pan
and tilt settings, zoom factors, preferred codec and so on. The sta-
tionery file defaults to the Stationery Templates folder.

Step 2: The Frames Panel

7. Edit>Automatic Process allows Nodester to perform the panels work automatically, once the Input
panel information has been established. Choose how far Nodester is to process in the dialog box.
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Step Three The CORRELATE Panel
Click on the Correlate Tab. The Correlate
Panel is now available.

Note 1:
The correlation panel is initially blank.

1. Correlate is a two step process.
a. Determine the accuracy or fineness
of the correlation needed between
images.
b. Calculate or process the images at
the accuracy settings.

2. Use the Accuracy button to instruct
the correlation engine as to the degree
of the correlation fineness at the edges
of adjoining images. Do not adjust the
accuracy for this example.

Note 2:
Given normal shooting constraints, the de-
fault accuracy is programmed to give opti-
mum results.

3. If the Horizontal Spacing between
each frame is NOT consistent (e.g. the
second frame is 20°  to the right of the
first but the third is 25°  to the right
of the second) you may need to ‘Loosen
Up’ the horizontal accuracy by
dragging the slider to the left towards
low. This tells the correlation engine
that the frames may NOT consistently
spaced and that it needs to work
harder to find the absolute correlation
point. Only move the slider ONE
detent at a time either horizontal or
vertical adjustment.
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TIP: Vertical Spacing problems MAY result from NOT
having the camera mounted on a true perpendicular
to the mount. Some digital cameras with odd shaped
cases may obstruct true alignment. This condition
causes “Stair Stepping” due to one image being
lower (tilted) than the next. If this persists, loosen
the vertical accuracy setting (one detent at a time).
Step 3: The Correlate Panel

The Vertical Spacing addresses the same incon-
sistency spacing problem.

Important: A Note About Camera Mounts
If a tripod attachment such as the QuickPan
from Kaidan or a 3Sixty Peace River mount is
used, this setting rarely needs changing.

4. Click the Calculate Button to begin the
correlation process, then an image will appear
for inspection.

5. Transparent allows a visual display of the
“Overlap” of adjacent images.

6. To Fine-Tune the correlation, click on the
frame that needs adjustment. Notice the
Marquee Extends to the end of the all frames
to the right—because the correlation of these
frames is usually accurate. This allows for total
sequence adjusting. Now, use the
Adjustments Box or Keyboard Arrows to
adjust the image by one pixel per click. Shift-
click to move panels 10 pixels at a time.

8. If the accuracy is adjusted, Recalculate the
correlation. Click on the Calculate button to
Recalculate the changes. We made no
adjustments on this example, despite the fact
that a small amount of “stair stepping” exists.
The default settings can compensate for such
minor imperfections automatically.
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Step Four  The PANORAMA Panel
1. Click the Panorama tab.

2. The panorama panel is initially blank.
Click the Render button to blend all
frames together to form one single
panoramic image.

3. After rendering, the panel will appear
as one seamless panoramic image.
Scroll to view. It’s NOT yet a QTVR movie.

4. Click the Edit button for minor touchup
such as blur, sharpen and clone. The Edit
Mode also allows you to create and place
Hotspots. See next page for a discussion
of hotspots.

TIP: Edit allows the image or parts of the
image to be Selected by using the selec-
tion marquee, then Copy>Paste. To se-
lect the entire image use Edit>Select All.

TIP: Export (not Save) the image as a PICT
file while in the Frames panel as a single
image or in the Panorama Panel as a single
panorama image.

5. (Optional) Use the Effects Sharpen
Button to enhance the Contrast of the
image. It works as an Unsharp Mask
Sharpen and can only be applied one
time. If it Sharpens too much, uncheck
the box and Render again.

6. (Optional) Use the Set Button under Size
to Scale or Crop the dimensions of the
panorama.
Important: A Word About Adding Text
Text can be added to a single image in the Frames panel (edit mode) or to the panorama in this stage (edit
mode). It is best to add text banners in the Panorama panel, as text may be corrupted during correlation
if placed in a single frame in Frames Panel.
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CREATING AND DEFINING HOTSPOTS
The Hot Spot Editor Tool Palette allows each shape tool to define Hotspot areas. Turn on the Hot Spot
Editor by clicking the Image Icon at lower left hand corner of the edit image window.

The Hot Spot Editor Tool Palette will appear after clicking on the Image Icon

Hot Spot Tools allow various shapes to define areas of Hotspots. On the next page is an example of the
polygon shape. Double click to close the last point to the first. Nodester assigns consecutive numbers to
Hotspots. You can change the color of the Hotspot by clicking on the color chip. There is no limit to the
number of colors or nodes.

After you have drawn your hotspot, double-click on it to bring up the Hot Spot Dialog Box. Here you will
be able to enter information about what you plan to link the hotspot to.

Step 4: The Panorama Panel

TIP: Hotspots must be activated within authoring software which supports QTVR playback. Nodester ONLY
establishes the Hot Spot — it does not connect the corresponding files (apart from with HTML).
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Navigable Object Hot Spot allows you to link another QTVR file to this one through either HTML or
through a linking program such as Apple’s QTVR Authoring Suite of tools, Macromedia’s Director or  mFactory’s
mTropolis program.

Still Object Hot Spot allows a Photo or Artwork to be displayed when clicked.

Miscellaneous Hot Spot acts as a Place Holder when it is not known which type of link will be established.

Other Hot Spot allows a link to a specific file type. When Other: is chosen, the Type: box becomes active.
Key in the four-letter File Type (such as GIFf for a .gif file) in the Type box.

TIP: The last thing you do in the Panorama panel is add the Hot Spots! Changes to the Pano (apart from
in the later panels) after the Hot Spots are made will cause the Hot Spot information to be erased.

TIP: Hot Spots are embedded in the exported QTVR movie file. Once a movie has been exported, the
hotspots cannot be accessed from the Nodester file. QTVR will display the Hot Spots during playback.

Step 4: The Panorama Panel
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Step Five The COMPOSE Panel
1. Click on the Set Button to choose the Codec
(Compressor/Decompressor) to be used for
compressing the QTVR movie. Using different
codecs will affect the file size and quality of
your QTVR movie. Cinepak is the default and
works well for most applications. Cinepak is
also, at this time, the only codec that is
certain to play back QTVRs properly on non-
Mac OS machines. If you intend to develop
QTVR for cross-platform viewing (i.e. the Web
or a hybrid CD-ROM), we recommend that
you leave the program defaults: Cinepak,
Best Depth and High Quality, for the
example.
2. Choose a Compression Quality to compose the QTVR movie. Depending upon the Codec chosen, you
may not necessarily see a difference. With Cinepak we have found that 75 gives the best performance,
and so we have set it as the default.

3. Choose the Color Depth. Nodester is optimized for 24-bit color (16.7 million colors).

4. Choose the type of Tile Array (defined space) for Dicing (slicing up in sections for on screen redraw
viewing). QTVR expects the movie to be ‘chopped up’ or ‘diced’ into smaller pieces within a tile (rectangle)
for quicker screen redraw when panning inside a window. This pop up controls the number of those
chunks or divisions. For this example, leave the setting at Default of 1 x 24.

5. Optimal Scaling adjusts panoramic images by rounding off the image dimensions to an even number
of pixels and allows maximum viewing of embedded scaled images.

6. Dual Resolution allows QTVR to contain two versions of the same image. One at the higher resolution
set at the Input Panel and a “piggy back” low resolution image. The low resolution will stand in during
low memory situations and continue playing a quarter size pano version with lesser resolution quality.
Choosing this option does, however, increase the QTVR file size by 25%.

7. View Angles
a. Pan enables view control of the horizontal plane by degrees.
b. Tilt enables view control of the vertical plane by degrees, where 0 degrees is the horizon and positive
     is an upward direction and negative is a downward direction from the horizon.
c. Zoom enables view control as to how far in the viewer can zoom. Use this control to prevent the
    viewer zooming so far in that pixelization occurs. Try 15 degrees.

8. Click Compose to compress the file.

9. After composing, the Playback Tab will be available to view the panorama in QTVR.
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Step Six  The PLAYBACK Panel
1. After Compose is complete, click the Playback Panel.

2. To Playback the QTVR, click and hold inside the playback panel. Directional cursors will appear to
steer your panoramic movement left/right and top/bottom. You will only get left/right movement,
unless the window is smaller than the full height and width, then top/bottom movement will occur.

3. Resize the playback panel window by clicking and dragging the Resizing Handle in the lower right
corner of the window. Also, specific window dimensions or default settings may be keyed into the
width and height boxes within Window Size.

IMPORTANT: The following settings (i.e. View Angles and Initial Settings) only appear if you have the
QTVR 2.0 extension (from the CD-ROM) installed on your computer’s Extensions Folder.

4. View Angles display the settings as the pano is moved inside the view window or settings my be keyed
into the pan, tilt and pan boxes.

5. Initial Settings allow control over appearance of the pano when first opened after being exported as
a QTVR file format. To set the initial settings, first experiment with various settings by moving the
QTVR cursors inside the Playback Panel, then click on the Set Button directly under the Initial Settings
Zoom box. If you wish to go back to the original settings, click the Go Button.
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Export your File as a QTVR Movie
1. Test the QTVR Panorama in the Playback Panel window as needed, then Export>File as QTVR Movie
File Format (QTVR 1.0 or QTVR 2.0).

2. QTVR Panoramas may be played back from the Apple or inside a QuickTime Player (provided the
QTVR System Extension is installed).

3. Check the Playable on Non-Mac OS computers setting: if you want this QTVR movie to play on
other Operating Systems that support QTVR playback. Checking this box will flatten the movie.

IMPORTANT: Virtual Documentation on the Web site (http://www.panimation.com)
 The interactive example and levels of supporting information will reside on the Panimation web site as a
virtual updating document. As Nodester develops and users send in tips, tricks and techniques, all of this
will be placed on the Web site for public download.

IMPORTANT: The Users Tips, Techniques & Features Web Site Bank
 We encourage all of you to email us on a regular basis with your findings and requests. We will compile
tips and techniques for every aspect of QTVR development (cameras, shooting, mounts, software, and
software feature requests). This Web Bank of entries will benefit all QTVR developers.

IMPORTANT: Send Samples of your QTVR Panorama Movies to Panimation
 Please send your best panoramas to Panimation. We will be creating a gallery of examples for future
CD-ROMs and our Web site. We appreciate seeing what people are doing with our software! We can accept
panoramas as compressed attachments or by mail on floppy discs. Please include your email address.
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Camera Mounts

We at Panimation feel strongly that your best QTVR panoramas are achieved using the best
equipment to record precisely aligned images. Nodester is one component of your “toolbox”
-- a quality (QTVR-oriented) camera mount or rig should be another.

PEACE RIVER STUDIOS
http://www.PeaceRiverStudios.com
9 Montague Street
Cambridge, MA 02139-3721
Voice 617.491.6262
Fax 617.491.6703

KAIDAN
http://www.kaidan.com
703 East Pennsylvania Blvd.
Feasterville Business Campus
Feasterville, PA 19053
Voice 215.364.1778
Fax 215.322.4186
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