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5 Creating, Editing, Animating, and 
Playing Scenes

This chapter explains how to create objects in your scene from scratch and how to 
enhance existing keyframes and scenes. You will learn how to edit objects within 
the scene and text in Text objects as well as how to animate them.

This chapter covers:

• Adding keyframes

• Using tools from the tool palettes

• Selecting, moving, and resizing objects

• Copying and deleting objects

• Creating and editing Draw and Text objects

• Editing and formatting the text within Text objects

• Adding color, patterns, and special fills to objects

• Changing object and text color, lines, and text attributes

• Manipulating objects with commands from the Animation menu

• Layering objects in the Draw view

• Animating objects in the Animation view

Creating keyframes
Keyframes can be created in Animation and Storyboard views. Use the New button 
in the tool palette to create a new keyframe. You can also use the “New Keyframe” 
command in the Edit menu or press Cmd/Ctrl-K in any view to create a new 
keyframe.

When New is pressed or the command is chosen, a duplicate of the selected or 
active keyframe is created and placed after that keyframe. All of the objects in the 
current keyframe, including their positions and sizes, are duplicated in the new 
keyframe. This makes it easy to make changes and create new animation. When a 
new scene is started you automatically begin in keyframe one. To create a scene 
with action, movement, and sound, you must have more than one keyframe.
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Storyboard view In the Storyboard view, if more than one keyframe is 
selected, the last keyframe of the sequence is duplicated after the selected 
keyframes. You may create new keyframes anywhere in a scene. You can 
create a new keyframe at the end of the scene by clicking on the unused 
keyframe just after the last keyframe of the scene, which adds a duplicate of 
the last keyframe to the end of the scene. 

Animation view In the Animation view, as you click New, the keyframe 
number within the tool palette increases (this is the number of the current 
keyframe), indicating a new keyframe has been created. You may create new 
keyframes anywhere in a scene.

Keyframe Names Each keyframe is given a unique name; Untitled, Untitled 2, etc. 
A keyframe name is not copied in the new keyframe. 

Scripts “Frame Script” and “Object Script” commands attached to a keyframe are 
replicated in the new keyframe.

Sound If the current keyframe has the end of a sound segment attached to it, or if 
it is the only keyframe attached to that sound segment, the sound segment is not 
extended. If, however, the keyframe has the beginning or the middle of an extended 
sound segment attached to it, the sound segment is extended to include the new 
keyframe. 

Automatically hiding all object in new keyframes When the Cmd key (Macintosh) 
or Ctrl key (Windows) is held down while the New button is clicked, all foreground 
and background objects are hidden in the new keyframe. Background colors are 
reproduced in any case. This is useful when you want to start a new part of the 
scene, having different text or objects. Background colors remain the same until 
they are changed.

Hiding foreground objects Holding the z and Option keys (Macintosh) or the Ctrl 
and Alt keys (Windows) while the New button is pressed hides the foreground 
objects but leaves all background objects of the active keyframe in the new 
keyframe. Background colors remain the same until they are changed.

To create a new keyframe:
1. Draw your objects, create text, and import graphics as needed.

You can add new keyframes before and after any keyframe, so if you want to 
work backwards or forwards, its up to you. You can import a graphic to 
represent a finished keyframe. Objects within that graphic can be hidden and 
animated by using keyframes before and after that keyframe to create your 
scene.
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2. Click New from the Storyboard or Animation tool palette, choose “New 
Keyframe” from the Edit menu, or press Cmd/Ctrl-K.

A new duplicate keyframe is created.

3. Move elements, apply commands from the Animation menu, send objects to 
other view planes, or add or remove objects as needed.

4. Repeat steps 2 and 3 until your scene is complete.

Sound can be added and the keyframe timing can be adjusted after your scene 
is created or as you create the keyframes.

To learn more about refer to

Adjusting the keyframe timing “Adjusting keyframe timing,” on page 7-13

Creating backgrounds
The background is the bottom or back layer of every keyframe. It can be created or 
changed from the Animation or Storyboard views. Only the active or selected 
keyframes are affected by changes to the background color.

You may choose a solid color, apply a blend, or create your own color. Ten sample 
blends are available to create a background blend. You can also import background 
graphics and send them to the background.

To learn more about refer to

Creating new keyframes with background “Creating keyframes,” on page 5-1
Selecting keyframes “Selecting objects and keyframes,” on page 

5-10
Saving and creating color palettes “Importing and saving color palettes,” on page 

5-35
Creating new colors “Working with custom colors,” on page 5-33

To apply a solid background color:
1. Switch to the Animation or Storyboard view.

Use the View Bar buttons on the right side of the window to switch between 
views.
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2. Choose “Background Color...” from the Animation menu, click on the 
Background Color button in the Animation tool palette, or press Cmd/Ctrl-B.

If you are in the Storyboard view, you can select multiple keyframes. The 
Background Color button is located to the right of the Transition tool. The 
following dialog appears:

3. Click on a color swatch in the color palet in the upper left corner of the dialog.

The chosen color appears in the “Start Color” swatch as well as in the sample 
blends at the bottom of the dialog.

4. Click “OK.”

The color is applied to the background of the selected/active keyframe(s).

To apply a background blend:
1. Switch to the Storyboard or Animation view.

Use the View Bar buttons on the right side of the window to switch between 
views.

2. Choose “Background Color...” from the Animation menu, click on the 
Background Color tool in the Animation tool palette, or press Cmd/Ctrl-B.

If you are in the Storyboard view, you can select multiple keyframes. The 
Background Color tool is located to the right of the Transition tool. The 
following dialog appears:
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3. Click on the “Start Color” swatch.

4. Click on a swatch in the color palette in the upper left corner.

You can also click on Pick Colors to display a color wheel to create a custom 
color.

5. Click on the “End Color” swatch.

6. Click on a swatch in the color palette in the upper left corner.

All the colors in the palette between the starting color and ending color are 
used to create a color blend. The color blend is used in the blend samples at the 
bottom of the dialog.

7. Click on one of the blend samples at the bottom of the dialog to select a blend for 
your background.

8. Click “OK.”

The color is applied to the background of the selected/active keyframe(s).
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Using viewing planes
Hiding and displaying objects within keyframes can be accomplished by sending 
and retrieving objects to and from the various viewing planes available in 
WebAnimator. These three viewing planes—foreground, background, and 
hidden—can also be viewed separately to keep track of which objects are displayed 
and to retrieve hidden objects. Background colors are not part of the viewing 
planes.

You can hide and display your objects within these viewing planes as you create 
new keyframes. Objects can also be layered within each of these viewing planes 
based on priority. Use the viewing planes as follows:

Foreground Place all objects to be animated on this plane. By default, new objects 
drawn or imported are placed in the foreground.

To send the currently selected object(s) in the selected keyframe(s) to the 
foreground viewing plane, hold down the Cmd key (Macintosh) or the Ctrl key 
(Windows) and click on the Fore button in the Animation or Storyboard tool 
palette, choose “Send Object” from the Animation menu and select “To 
Foreground” from the cascading menu, or press Cmd/Ctrl-F. The object is removed 
from the viewing plane it had occupied. The object is placed on the top layer in the 
foreground viewing plane, and appears to be on top of all the other objects. 

Background Place any objects that appear across several keyframes and appear 
behind animated objects on this plane. Keeping objects which are unmoving in the 
background plane reduces computational time and results in smoother animations.

To send the currently selected object(s) in the selected keyframe(s) to the 
background viewing plane, hold down the Cmd key (Macintosh) or the Ctrl key 
(Windows) and click on the Back button in the Animation or Storyboard tool 
palette, choose “Send Object” from the Animation menu and select “To 
Background” from the cascading menu, or press Cmd/Ctrl-F. The object is placed 
on the top layer in the background viewing plane. 

Hidden Store all objects to be displayed later in the foreground or background 
viewing plane or to hide objects already displayed on this plane. Objects cannot be 
edited in the Hidden viewing plane. All moving and sizing of objects must be done 
from the Foreground. 

To send the currently selected object(s) in the selected keyframe(s) to the hidden 
viewing plane, hold down the Cmd key (Macintosh) or the Ctrl key (Windows) and 
click on the Hidden button in the Animation or Storyboard tool palette, choose 
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“Send Object” from the Animation menu and select “To Hidden” from the 
cascading menu, or press Cmd/Ctrl-F. The object is placed on the top layer in the 
hidden viewing plane.

To learn more about refer to

Viewing plane concepts “Understanding viewing planes,” on page 2-5
Layering objects in a view plane “Layering objects,” on page 5-38

To send objects to a viewing plane:
1. Create or import an object in the Draw view.

2. Switch to the Storyboard or Animation view.

Use the View Bar buttons on the right side of the window to switch between 
views. Viewing planes can only be assigned in the Animation and Storyboard 
views.

3. With the object selected, hold down the z key and click on a viewing plane tool in 
the tool palette.

You can also use commands from the bottom half of the “Send Object” 
cascading menu in the Animation menu to assign viewing planes. If the 
selected object appears in more than one keyframe, only the selected 
keyframes are affected.

To display objects in the viewing plane:
1. Switch to the Animation or Storyboard view.

Use the View Bar buttons on the right side of the window to switch between 
views.

2. Click on a viewing plane tool in the tool palette, or choose “Viewing Plane” from 
the View menu and select a viewing plane from the cascading menu.

The foreground and background viewing planes can be viewed at the same 
time. If the foreground tool is selected, click the background tool to display 
both views together. Click on the foreground tool again to turn off the 
background view.

You must be in a viewing plane to edit objects within that plane. Objects in the 
Background, for instance, may be seen but not selected if you are in the 
Foreground.
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Creating simple and complex objects
Animated objects created in theWebAnimator Draw view may be simple or 
complex. Simple objects (a circle, rectangle, polygon, etc.) have only one element, 
the object itself. A complex object may consist of two or more of these elements 
which, when played in a scene, act as one object. 

Examples of simple objects:

• circle

• rectangle

• line

• text

Examples of complex objects:

• car

• face

• text with shapes

All the elements in a complex object are moved and sized together when the 
animation tools are used. Complex objects are the default. In this case, all the 
elements you draw are a part of a single complex object as they are drawn until 
either New is selected from the Draw view tool palette, another object is selected 
for editing, or until you exit the Draw view. 

If the “Complex Object” command in the Draw menu is deselected, each new 
element you draw becomes a new independent object. When complex objects are 
edited with the draw tools, the object’s elements must be selected and edited one at 
a time.

To create simple objects:
1. Switch to the Draw view.

Click on the Draw button in the View Bar on the right side of the window, 
choose “Draw” from the View menu, or press Cmd/Ctrl-D to switch to the 
Draw view.

2. Using one of the draw tools, create an object in the Draw view workspace.

Once the object is created, selection handles appear around the object.

3. Click New in the Draw tool palette, or select another tool.

The selection handles disappear from around the object and from now on that 
object acts independently from other objects created. 
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4. Repeat steps 2 and 3 until all of your objects are created.

To create complex objects:
1. Switch to the Draw view.

Click on the Draw button in the View Bar on the right side of the window, 
choose “Draw” from the View menu, or press Cmd/Ctrl-D to switch to the 
Draw view.

2. Using the draw tools, create the necessary object(s) in the Draw view workspace 
as needed.

This is helpful if you want to create an object that requires more than one 
element in its creation. You can also create objects which always move 
together during animation.

3. Once your complex object is created, click New in the Draw tool palette.

All of the objects you created are “grouped” together. These objects move as 
one object when selected or animated in the Animation view.

4. Repeat steps 2 and 3 to create other complex objects.

Manipulating objects with the Pointer tool
The Pointer tool appears in every tool palette in WebAnimator. Because the Pointer 
tool is selected in the tool palette no matter which view you are in, it is considered 
the default tool; also, most other tool selections revert to the Pointer as soon as you 
release the mouse button. 

The Pointer is used to select keyframes, objects, or object elements, to move 
objects’ elements about with respect to each other, and to size object-elements 
using object handles. 

To perform an action, you must first select a keyframe or a selection of keyframes, 
and/or an object to act upon. When an object is selected you can copy, delete, and 
apply various other animation and manipulation commands to the object.

To learn more about refer to

Sizing objects “Resizing objects,” on page 5-15
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Selecting objects and keyframes
There are multiple ways to select one or more objects or keyframes within 
WebAnimator. WebAnimator also allows you to change the behavior of objects by 
increasing the selection rectangle of an object.

Object behavior
The “Select By” command in the Edit menu can be used to change the behavior of 
how objects are selected.

Object Rectangle If this method is used, clicking anywhere within the selection 
rectangle of an object would select that object. This is most noticeable with circles, 
ovals, polygons, and freehand objects as well as objects with no fill.

Object Form This way of selecting objects requires one to click on the body of the 
object. For example, to select a Text object, you would have to click on a letter of 
the object, not the space in between letters. The advantage to “Object Form” is 
when selecting an object behind and inside another object’s rectangle, especially 
behind objects with no fill.

Figure 5-1. Selection behavior

Selecting
Some views allow more features and flexibility for selecting different items:

Selecting one keyframe In the Animation and Draw view, the keyframe currently 
displayed is the “selected” keyframe. In the Storyboard view, select a single 
keyframe by clicking on it. If the keyframe is in the middle of a selection of 
keyframes, you may need to deselect by clicking on the gray area first. You can use 
“Show Selection” from the Storyboard view’s Edit menu to advance large scenes to 
display the selected keyframe.

By Object Rectangle By Object Form

Clicking 
anywhere in 
the selection 

rectangle
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Selecting multiple keyframes Selecting multiple keyframes can be done in the 
Storyboard and Animation views. 

Storyboard view You can select multiple keyframes by clicking on an un-
selected keyframe and dragging the pointer to the last keyframe in the 
selection. The Storyboard automatically scrolls as you drag. You can also hold 
down the Shift key while selecting keyframes one at a time. Each keyframe is 
highlighted to indicate that it is selected. Select a series of keyframes by 
clicking on the first frame, hold down the Shift key, and click on the last 
keyframe. 

Animation view It is possible to select a range of keyframes using Select 
Frames or to move to either the first or last keyframe in a range. 

To select a range of keyframes from the Animation view:
1. Switch to the Animation view.

Use the View Bar buttons on the right side of the window to switch to the 
Animation view.

2. Click the Select Frames button at the bottom of the window.

3. Go to the first keyframe in the range.

4. Click the number immediately to the right of Select Frames. 

This sets that number as the first keyframe of the range.

5. Go to the last keyframe of the range.

6. Click the right-hand number of the Select Frames number pair. 

This sets that number as the last keyframe of the range and ends the Select 
Frames operation.

When a range of keyframes is selected, changes made to an object in the first 
keyframe of the range, cause identical change to that object in all keyframes in the 
range. However, if changes are made to an object in the last keyframe in a range 
(such as movement or size change), the changes occur incrementally through the 
range of keyframes, with the first keyframe in the range retaining the original 
condition of the object and the in-between keyframes gradually showing a 
transition from the original to new as specified in the last keyframe in the range.
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Selecting objects Selecting objects and elements can be done from 
anyWebAnimator view. To select an object, simply click on it, and then select the 
element you wish to edit. The object-element’s handles are displayed, indicating it 
has been selected.

Selecting multiple objects Multiple objects within the same complex object can be 
selected in the Draw view. Hold down the Shift key while selecting elements one at 
a time or you can use the Pointer tool to click and drag a selection rectangle around 
the elements you want selected. Object handles appear around each element to 
indicate that it is selected. 

Only one object can be selected at a time in the Animation and Storyboard views. 

To learn more about refer to

Simple and complex objects “Creating simple and complex objects,” on page 5-8

Selecting objects outside of the keyframe boundary Some of the “Move Object” 
commands from the Animation menu can be used to move objects on, and off, 
keyframes. One way to select objects that have been moved off the keyframe 
workspace, is to switch to the Storyboard view. Click on that object in any 
keyframe in which it can be seen. If you select the object in any keyframe, it is 
automatically selected in the next keyframe you select. Next, select the keyframe in 

Clicking on 
keyframes 
individually

Clicking and 
dragging the 
Pointer tool
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which you want to make your changes. Use one of the sub-commands in the “Move 
Object” cascading menu from the Animation menu to move the object back into the 
keyframe. 

Another way, is to use the Show Off Screen button which displays all objects which 
are offscreen.

Selecting an object in more than one keyframe To select an object, click the object 
in a selected single keyframe, or click the object in the first or last of a series of 
selected keyframes. The object’s handles are displayed in the appropriate keyframe, 
indicating it has been selected. 

You can only select objects in the first and last keyframes. If you try to click on an 
object in an intermediate keyframes, the multiple keyframe selection will be lost.

Moving objects
Once an object is selected, you can move it. If you move or resize an object in error, 
you can cancel the action by choosing “Undo” from the Edit menu or pressing 
Cmd/Ctrl-Z. 

Once you have specified the placement of an object in the Animation or Storyboard 
views, that is the default placement of the object. Moving the object in the Draw 
view will not effect its position in the Animation and Storyboard views. As a 
general rule, move objects only in the Animation and Storyboard views to avoid 
confusion when objects are moved in the Draw view. 

You can also use the commands in the “Move Object” and “Size Object” cascading 
menus within the Animation menu to move and animate your objects.

To learn more about refer to

Animating your objects “Adding and editing movement,” on page 5-40

Clicking on objects individually 
in the Draw view

Clicking and dragging the Pointer 
tool in the Draw view
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There are several options available for moving objects in WebAnimator:

Moving an object To move an object, simply keep the button depressed on the 
object and drag it to its new position.

Moving an object vertically or horizontally Holding the Shift key while moving an 
object constrains the movement to either a vertical or horizontal movement. This is 
useful when you want an object to move straight across, or up or down the screen.

Moving an object in several keyframes If several keyframes are selected when the 
object is moved, you may move the object in either the first or the last of the 
selected keyframes:

Moving an object to the same position across several keyframes When the 
object is moved in the first selected keyframe, it is moved to that position in all 
of the selected keyframes.

Moving an object smoothly across several keyframes If the object is moved in 
the last selected keyframe, then it is moved in increments from its position in 
the first keyframe to its final position in each of the keyframes selected. This 
lets you automatically distribute the movement of an object across multiple 
keyframes.

To move an object:
1. Select the Pointer and position it over the object you want to move. 

If you are moving a Draw object with no fill and the “Select By” command is 
set to “By Object Form,” you must click on a boundary line.

2. Click and hold down the mouse button while you drag the object to its new 
location. 

As you drag an object in the Draw view, you see only the outline of the object 
(which reappears when you release the mouse button). In the Animation and 
Storyboard views, the object moves as you drag the cursor.
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Resizing objects
Once an object is selected you can also resize it. If you resize an object in error, you 
can cancel the action by choosing “Undo” from the Edit menu or pressing Cmd/
Ctrl-Z. 

The Pointer tool and the Size tool in the Animation and Storyboard view tool 
palettes can be used to resize any selected object with or without the use of the 
handles. The Resize tool resizes objects from the center if you click in places other 
than the selected object’s handles.

Note: Scaled objects animate more slowly than objects at their original size. To 
change an object’s original size, edit the object in the Draw view. If the 
object was imported, change the size of the object in the program that 
originally created it.

There are several options available for resizing objects in WebAnimator: 

Resizing without the handles Select the object, click on the tool and then drag to 
the desired size. The Size tool always sizes the object from its center. This is useful 
when you wish to make an object appear to zoom in or out.

Sizing proportionally By holding the Shift key and then selecting a corner handle 
and dragging it, the object is sized in two directions proportionally.

Sizing objects from the center By depressing the z key, and using the handles, you 
can make the object grow from the center; by using the Shift and Cmd keys 
(Macintosh) or the Shift and Ctrl keys (Windows) the object grows from the center 
proportionally.

Sizing an object in several keyframes You may also size the object with its handles 
or the Resize tool, in one or more keyframes. If several keyframes are selected 
when the object is sized, you may size the object in either the first or the last of the 
selected keyframes:

Making an object the same size across several keyframes When the object is 
sized in the first selected keyframe, it is changed to that size in all of the 
selected keyframes.

Making an object grow or shrink smoothly across several keyframes If the 
object is sized in the last selected keyframe, then it is sized proportionally from 
its initial size in the first keyframe, to its final size, in the last keyframe 
selected.
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To learn more about refer to

Making objects disappear “Sizing objects,” on page 5-42

To change the size or shape of an object:
1. With the Pointer or Resize tool, select the object you want to resize.

The object handles appear.

2. Click and drag a handle until the object is the size or shape you want. 

When you drag a handle, the Pointer changes to a crosshair.

Note: When resizing Text objects in the Draw view, only the selection rectangle 
is resized. The size of the text remains unchanged. In the Animation view, 
the text itself is resized.

Copying items
The “Copy” command in the Edit menu changes depending on the type of item 
selected in WebAnimator. This command makes a copy of any selected item(s), 
leaving the original(s) intact. A copy is saved in a buffer similar to the Clipboard.

A number of items in WebAnimator can be copied:

Frames Refers to selected keyframes. Selected keyframe(s) can only be copied in 
either the Animation or Storyboard view. This copies the objects and their positions 
in the frame as scripts and backgrounds.

Element Refers to selected drawing elements in Draw view. Copying and pasting 
is especially useful when you need an identical copy of the element to add to the 
object you are working with or another object in the scene (bars on a graph, eyes on 
a face, for example). The pasted element is placed slightly lower and to the right of 
the selected element. (With a element selected, pressing the “delete” key deletes the 
element without copying it to the buffer.)

Object Refers to selected objects. Selected object(s) can be copied in either the 
Animation or Storyboard view. 
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Path Refers to an object selected in a range of keyframes in which it changes 
position or size. This command copies the “path” of its changes over the course of 
the selected keyframes. Paths can only be copied in the Storyboard view.

Sound Refers to a selected sound in the Storyboard view.

To copy one or more objects:
1. Select the item(s) you want to copy.

2. Choose “Copy” from the Edit menu or press Cmd/Ctrl-C. 

3. Deselect the item by clicking outside it. 

The item(s) copied are now in a buffer, ready to be pasted back into 
WebAnimator. (See “Pasting objects,” on page 5-18 if you need help pasting.)

Deleting items
WebAnimator allows you to delete items two ways; objects can be “cut” from a 
selected keyframe, or they can be “removed” from the current scene. A cut object 
still remains in the hidden viewing plane. An object which has been removed from 
the scene no longer appears anywhere in the scene.

The “Remove Object” command from the Edit menu deletes the selected object 
from the entire scene, not just from the selected keyframe(s) as is the case with the 
“Cut” command. “Remove Sound” in the Edit menu removes any sound applied to 
selected keyframes.

A number of items in WebAnimator can be cut:

Frames Refers to selected keyframes. The keyframes which follow cut keyframes 
move up in the Storyboard to replace the ones cut.

Element Refers to selected elements in Draw view. Pressing the Delete key with 
an element selected, deletes the element without copying it to the buffer.

Object Refers to selected objects in either the Animation or Storyboard view. The 
“Cut” command only cuts the selected object from the currently selected 
keyframe(s), i.e., the object continues to exist in other keyframes. Use the “Remove 
Object” command to completely remove an object from a scene. Pressing the 
Delete key with an object selected has the same effect as “Cut Object” command.

Path Refers to an object selected in a range of keyframes in which it changes 
position or size. This command cuts the object as well as the “path” of its changes 
over the course of the selected keyframes. Paths can only be cut in the Storyboard 
view.



5-18 WebAnimator User’s Guide

Manipulating objects with the Pointer tool Creating, Editing, Animating, and Playing Scenes

Sound Refers to sound in Storyboard view. This command cuts the selected 
sound segment from the currently selected keyframe(s) and places a copy in the 
buffer. Use the “Remove Sound” command to completely remove an sound from a 
scene without saving a copy to the buffer. Pressing the Delete key with a sound 
segment selected has the same effect as “Remove Sound” command.

To delete one or more items:
1. Select the items(s) you want to delete.

2. Choose “Cut” from the Edit menu, press Cmd/Ctrl-X, or press the Delete key. 

The “Cut” command changes depending on the type of item selected in 
WebAnimator. The object is deleted from the active keyframe and a copy of 
the object is placed in the buffer and in the hidden viewing plane. The Delete 
key does not save a copy, but simply sends the object to the hidden layer.

To remove an object or sound:
1. Select the object(s) you want to remove.

2. Choose “Remove Object” or “Remove Sound” from the Edit menu. 

The selected object is removed from the current scene.

Pasting objects
The “Paste” command in the Edit menu changes depending on the type of item 
selected in WebAnimator. This command places the most recent cut or copied 
keyframe, or Draw, Text, or Imported Graphic object into the current 
WebAnimator scene.

The same types of WebAnimator objects/elements that can be copied can also be 
pasted into WebAnimator.

If an object is pasted into a keyframe in which it is not visible (i.e., in the hidden 
plane), then the object is removed from the hidden plane and placed into the 
foreground plane. It is placed in the same position from which it was copied.

If an object is pasted into a keyframe in which it is already visible (i.e., the 
foreground or background planes), then a new object is created. This new object is 
pasted in all the selected keyframes and is hidden in all other keyframes. It is placed 
in the same position from which it was copied.

Paste Path When an object is selected in a range of keyframes, the cut, copy, and 
paste commands apply only to the object’s “path” of its changes in position and size 
over the course of the selected keyframes. When “Paste Path” is chosen, only the 
path of the object is changed, no new objects are created. If the object is already 
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visible in a selection of keyframes, the object is made to be on the same path from 
which it was copied. If the object is hidden in the selected keyframes, then it is 
made visible and placed along the path.

Paste Sound Clone If a Master Sound is copied and Paste Sound Clone is chosen, 
pasting results in the creation of a sound clone. Any changes to the Master Sound 
affects the Clone Sound as well. Clone Sounds do not take up additional computer 
memory.

Pasting Over Frames All the frames selected are replaced by the frames in the 
buffer. There may be more frames selected than frames in the buffer, or less frames 
selected than frames in the buffer.

Pasting Before Frames The selected frames are unaffected and the buffer frames 
are placed prior to the selected frames. This is a way to add frames before frame 1.

Pasting After Frames The selected frames are unaffected and the buffer frames are 
placed after the selected frames.

To paste one or more objects:
1. Use the “Copy” or “Cut” command on the item(s) you want to paste. 

This places a copy of the keyframe or object(s) in the buffer. 

2. If necessary, display a different WebAnimator view or keyframe, or open another 
WebAnimator document.

3. Choose “Paste” from the Edit menu or press Cmd/Ctrl-V. 

The pasted object(s) appear centered in the selected keyframe. Pasted 
keyframes replace any selected keyframe(s). You can paste the copy anywhere 
you like, as many times as you like.

You can also use the “Paste Before Frames” and “Paste After Frames” 
commands from the Edit menu when pasting keyframes into the Storyboard 
view. 

Objects anchors
Displays a dialog so you can specify how an object is anchored or aligned on the 
screen. Objects can be aligned to the grid.

The use and purpose of the “Anchor Object...” command is different in each view:
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Storyboard/Animation view If the “Snap to Grid” option is enabled using the 
“Grids and Rulers...” command, then you can align objects to the grid. When an 
object anchor is set, that anchor is aligned with the grid. For example, if the anchor 
selected is Bottom Left, then the bottom left point of an object aligns with the grid. 
The X and Y coordinates displayed at the bottom of the window indicates the 
coordinates of the anchor point of an object when it is moved. The default anchor is 
Top Left.

Template Studio view When creating templates, you need to be specific about how 
an object is aligned. When text is entered in the Template Studio view it is 
automatically substituted for the text of a template. For example, if you want the 
text to animate and then line up left justified, the text objects should be aligned left 
in the keyframes containing the text on the screen. If you want the text centered, 
then the text objects should be anchored center. When it is off the screen, it should 
be aligned with the edge of the screen. It is also helpful to align top or bottom, so 
that the text moves straight during animation.

Draw/Storyboard views Substitution occurs if an object already exists and the 
object is then resized in the Draw view. The object is placed back on its animation 
path according to how it has been aligned.

Each object has its own anchor specification, and the object’s anchor can be 
changed from keyframe to keyframe. For example, an object could be anchored to 
the left edge of the screen on one keyframe and in the next keyframe anchored to 
the right edge of the screen. This would guarantee the object always moved from 
the left edge to the right edge.

Alignment using this command is automatically overridden when commands from 
the “Move Object” sub-menu are used. If an object is moved off the screen using 
one of the commands from the “Move Object” sub-menu, the object is 
automatically aligned to the edge of the screen in those frames in which it is off-
screen. For example if the “Off Left” command is used to move an object off the 
left portion of the screen, then the alignment is set to right aligned. The right hand 
side of the object is always on the edge, just off the screen. If before moving off 
screen left, either top or bottom alignment is also set, then that setting is preserved. 
For example if the alignment was top alignment and then the object is moved off 
left, then the alignment is set to top right alignment. The same logic applies to 
moving off top, off bottom, or off right. Moving an object to the center, 
automatically sets center alignment.

To learn more about refer to

Move Object commands “Moving objects,” on page 5-40
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To anchor objects in WebAnimator:
1. Select an object in the Storyboard or Animation view.

Alignment is only applied to the selected object in the selected keyframes.

2. Choose “Object Anchor...” from the Animation menu. 

The following dialog appears:

3. Click on a selection which represents the anchor you need.

4. Click “OK” to implement the changes.

If you want to exit the dialog without making any changes, click “Cancel.” 
You can apply other alignment characteristics to other objects within the same 
scene.

Creating and editing Draw objects
WebAnimator objects (not imported objects) are created and edited in the Draw 
view. The term “object” refers to animated objects. What are commonly referred to 
as drawing objects in other programs, are referred to as drawing elements in 
WebAnimator. One or more drawing elements make an animated object. The 
various elements are combined to form a bitmap object, which animates as one 
collective whole. When working in Draw view each element drawn becomes part 
of the animated object until the New button in the Draw tools palette is selected. All 
the elements get combined and made into a bitmap animated object and a new 
animated object is started.

A new object created in Draw view, appears in the foreground of the current 
selection of keyframes. In the other unselected keyframes, the object is placed into 
the hidden layer.
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When an object is edited after have been created, the changes to the object are 
affected in every keyframe. If the combined object has a different size, then the 
original size of the object is changed.

The more time you spend experimenting with the tools and techniques, the better 
you will understand and be able to take advantage of their capabilities.

Note: Make sure you understand simple and complex objects before creating 
your objects. See “Creating simple and complex objects,” on page 5-8.

Once you have created a Draw object, you can use commands in the Draw menu to 
manipulate it and to add some interesting special effects (dashed lines, special fills, 
and drop shadows). You can also use the Draw view tools in the tool palette to 
change the object’s line widths and to add color or patterns to the object’s line or 
fill.

To learn more about refer to

Changing the line width “Changing line widths,” on page 5-28
Changing line, color, or pattern “Applying colors,” on page 5-29
Resizing objects “Resizing objects,” on page 5-15

Creating and editing a line
To create a line:

1. Select the Line tool from the Draw view tool palette.

The Pointer changes to a crosshair cursor.

2. Click and hold down the mouse button to begin your line.

3. Drag the mouse in the direction you want your line to follow. 

Use the Shift key to constrain the line to 45° increments. When you release the 
mouse, the line appears with the standard selection box around the entire line.

You can change the size of the selected line. However, once the line is drawn 
the angle cannot be changed. The line width and color can also be changed.

Creating and editing a rectangle, rounded rectangle, square, circle, or oval 
The Rectangle, Rounded Rectangle, and Oval tools work the same as standard draw 
tools. Use the Rectangle tool to make a square or rectangle and the Rounded 
Rectangle tool to make a rounded rectangle or square. Use the Oval tool to make an 
oval or circle. 
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To create a rectangle, rounded rectangle, square, circle, or oval:
1. Select the Rectangle, Rounded Rectangle, or Oval tool from the Draw view tool 

palette. 

The Pointer changes to a crosshair cursor.

2. Click and hold down the mouse button to begin the object.

3. Drag the mouse diagonally in any direction until the object is the size and shape 
you want.

     

Holding down the Shift key while dragging constrains your object to a perfect 
square, square with rounded corners, or a circle, depending on which tool you 
are using. Hold down the Cmd key (Macintosh) or Ctrl key (Windows) to draw 
from the center. When both are depressed, a perfect square, square with 
rounded corners, or a circle is drawn centered on the point.

4. Release the mouse.

The object appears with object handles around it to show it is selected.

You can move, resize, and modify a rectangle, rounded rectangle, square, circle, or 
oval as explained in other sections.

Creating a freehand object
The Freehand tool creates a freeform line. Like the polygon, a freehand object can 
be closed (the beginning and end points are joined) or open (beginning and end 
points are not joined). A freehand object can be transparent and consist of the line 
only, or it can be filled with a color or pattern like other Draw objects.

To create a Freehand Object:
1. Select the Freehand tool from the Draw view tool palette.

The Pointer changes to a crosshair cursor.

2. Click the mouse and drag to create your object.

3. Release the mouse button. 

Object handles appear around the object to show it is selected.



5-24 WebAnimator User’s Guide

Creating and editing Draw objects Creating, Editing, Animating, and Playing Scenes

Creating a polygon
The Polygon tool creates irregularly shaped, multi-sided objects. A polygon is 
made up of multiple segments that are joined together by segment endpoints. Like a 
freehand object, a polygon can be closed (the first and last segments are joined) or 
open (first and last segments are not joined).

To create a polygon:
1. Select the Polygon tool from the Draw view tool palette. 

The Pointer changes to a crosshair cursor.

2. Click the mouse where you want the polygon to begin. 

3. Move the mouse to where you want the first segment of the polygon to end, then 
click again. 

A solid line appears. Move the mouse to adjust the length and angle of the 
segment. Hold down the Shift key to constrain the line to 45° increments.

4. Move the mouse and click again to create the second segment.

5. Continue moving and clicking the mouse until you have created the number of 
segments you want in the polygon. 

You can close the polygon by clicking the first point, but you do not have to 
close the polygon to finish it.

6. Double-click on your last segment to complete your polygon.

7. Click on the Pointer or any other tool in the tool palette to de-select the Polygon 
tool when your shape is complete.

You can move and resize a polygon as explained in other sections. 
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Creating and editing Text objects
Text objects are created and edited in the Draw view. Like all objects created in the 
Draw view, Text objects can be simple or complex by drawing them at the same 
time as other objects before pressing the New button.

To learn more about refer to

Simple and complex objects “Creating simple and complex objects,” on page 5-8

Creating a Text object
Within a Text object, WebAnimator feels as familiar as any word processor. The 
key to creating and working with Text objects is the Text tool from the tool palette.

Since animations will be accessed over the Web by both Macintosh and Windows 
users, think ahead about the typefaces you will be using. There is no guarantee that 
the person viewing the animation will have the same font. It is recommended that 
you use a standard font such as Helvetica, Times, or other standard fonts. If you 
want to use a font that you know the users won’t have, it may be best to convert the 
text into a bitmap or vector graphic and then import the text into WebAnimator.

A Text object can contain up to 32,000 characters. When selected with the Text 
tool, this text can be edited and formatted with commands from the Edit, Draw, and 
Text menus.

The Text object itself has the same attributes as a Draw object: object handles that 
are visible when the object is selected; and object boundary lines.

When selected with the Pointer tool, a Text object can be moved, sized, cut, copied, 
and deleted like any other object in WebAnimator. You can also use the palettes in 
the tool palette and most of the commands in the Draw and Text menu to enhance 
and manipulate your Text objects.

To learn more about refer to

Manipulating Text objects “Manipulating objects with the Pointer tool,” on page 
5-9

Changing object attributes “Changing the attributes of a Draw or Text object,” on 
page 5-28
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To enter text in the Draw view:
1. Select the Text tool from the Draw view tool palette and click in the Draw view 

workspace. 

A text box is created and an I-beam cursor appears in the text box.

2. Type your text. 

You can enter up to 32,000 characters per Text object. 

As you type, the insertion point moves to the right and automatically jumps 
down to the beginning of the next line after it reaches the right boundary of the 
Text object. When you reach the bottom boundary, the text block expands 
vertically to accommodate your text.

3. When you are done entering text, click outside the Text object to de-select it.

The object handles disappear, leaving only the text.

4. If you want to resize the Text object, use the Pointer tool to re-select it and drag 
one of the object handles until you have the size and shape you want. 

Resizing the Text object in the Draw view has no effect on the size of the type 
within, although the text rewraps to fit the new size and shape. In the 
Animation view the text object is treated like any other object—when resized, 
the size of the text is affected.

Formatting and editing text in a Text object
Each character within a Text object can be a different font, size, style, and/or color. 
When you set alignment, however, it affects all the text within the object. 

You can only set text attributes for one Text object at a time with commands from 
the Draw menu. Colors and shadows can be applied to one or more selected Text 
objects. Formatting and editing must be done in the Draw view. 

To edit text in a Text object:
1. Select the Text object you want to change.

The object handles appear.
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2. Select the Text tool from the Draw view tool palette.

The Text object boundaries appear and you can see the insertion point 
blinking.

3. Perform the following actions as needed:

• Select text.

• Use the Delete key to erase mistakes.

• Type in new text.

• Use the commands in the Edit menu as you would in any word 
processor.

To change text attributes in a Text object:
1. Select the text you want to format. 

You can select text by clicking and dragging, double-clicking on a particular 
word, or choosing “Select All” (Cmd/Ctrl-A) from the Edit menu. 

2. Choose “Font,” “Size,” “Style,” and “Alignment” from the Draw menu as needed 
and make your selections from the cascading menus.

With the exception of the “Alignment” command, which affects all the text in a 
Text object regardless of what is selected, these commands apply to selected 
text only.

“Font,” “Size,” and “Style,” work exactly as they would in any word 
processor. 

3. When you are finished formatting your text, click outside the Text object to 
deselect it. 

To learn more about refer to

Commands in the Draw menu “Draw Menu,” on page A-24
Aligning text for animation “Objects anchors,” on page 5-19
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Changing the attributes of a Draw or Text object
The Object Color and Line-Width palettes in the Draw view’s tool palette make it 
easy to change the color and line attributes of any Draw or Text object. You can 
change the following attributes with the appropriate palettes:

• object and shadow fill colors

• object line colors

• line width of an object’s boundary lines

• create blends

• mix colors

• apply custom colors

Note: Although the attributes of Imported Graphic objects cannot be changed in 
WebAnimator, you can sometimes get around this by drawing an outline 
of the object in WebAnimator. This creates a Draw object that you can 
modify in any of the ways described in this section and then layer with the 
original graphic to create the desired effect.

To learn more about refer to

Adding special blends to objects “Creating blends,” on page 5-31
Creating a shadow “Adding shadows to objects,” on page 5-37

Changing line widths
WebAnimator line widths are set in points. (One point is 1/72 of an inch.) The line 
width and color of each line can be changed individually or as a group. Any 
changes to the line width of an object made anywhere in the scene affects the 
object/element’s borders in all keyframes.

You can use the Line-Width palette in the tool palette to change the line widths of 
the following:

• lines

• any Draw object’s boundary lines

To edit the line width of one or more objects:
1. Select the object(s) you want to change.
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2. Click on the Line-Width palette icon in the tool palette to display the line width 
selections. 

You see a choice of line widths including None and 1 through 7 points 
represented graphically. The default line width, or the last line width selected, 
is indicated with a small square bullet. 

3. Drag the Pointer across the options and release the mouse to make your 
selection.

The selected line(s) change accordingly. 

Applying colors
The overlapping icons in the Object Color palette control the color of any Draw or 
Text object, line, or shadow. The Object Color Fill square (upper left) is for setting 
object color; the Line Color (outline) is for setting the line color; the Shadow Color 
square (lower right) is for setting shadow color.

Figure 5-2. Object Color palette

The object color can be thought of as the object itself, such as text or a circle; the 
line color is the color of any line or outline of any object; the shadow color is the 
color of any shadow applied to the object. If your object does not have a shadow, 
the shadow color does not appear.

Initially, the default object color is purple, and the default shadow color is black. 
When you select an element that is set to a different object or shadow color, that 
color appears in the appropriate palette of the tool palette.

Click to set the Object color

Click to set the Shadow color

Click to set the Line color
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To learn more about refer to

Creating custom colors “Working with custom colors,” on page 5-33

To change the color of an object:
1. Select the object(s) you want to change in the Draw view.

2. Click in the Object Fill Color area of the Object Color palette in the tool palette 
and hold down the mouse button. 

The palette pops up to display the available color choices. This color palette is 
the system color palette. Do not change the colors in this palette if you intend 
to create a Web page.

The color palette includes 256 different colors, including black and white. 
Custom colors can be created using the “Color Blend” option at the bottom of 
the color palette. 

Note: Be aware that any subsequent changes to the palette grid may affect the 
colors of object-elements, shadows, or backgrounds previously chosen if 
the color occupying that location in the grid is changed. For example, if 
you choose to color an object-element green, and then later eliminate 
green from the palette and replace green with purple, the object-element 
would then be colored purple.

3. Drag the Pointer across the colors and release the mouse to make your selection.

Select a color, no color, or choose Color Blend. The object-element, but not its 
border, is colored with the selection. 

Remember, you may also color text the same way. The object-element remains 
the same color throughout the scene. Color changes to an object-element, as 
with drawing size changes, made anywhere in a scene affects the object-
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element in all keyframes. If no color is chosen for the object-element then it is 
transparent, that is, only its outline is visible.

To change the color of a line:
1. Select the object(s) you want to change in the Draw view.

2. Click in the Line Color area of the Object Color palette in the tool palette and hold 
down the mouse button. 

The standard color palette pops up to display the available color choices.

3. Drag the Pointer across the colors and release the mouse to make your selection.

The line color of the selected object(s) change. The object/element’s border 
remains the same color throughout the scene.

To change the shadow color of an object or line:
1. Apply a shadow to any selected object or line.

Refer to “Adding shadows to objects,” on page 5-37, to apply a shadow. If a 
shadow is not applied to an object, you will not notice any differences when 
the color is changed.

2. Select the object(s) you want to change in the Draw view.

3. Click in the Shadow Color area of the Object Color palette in the tool palette and 
hold down the mouse button.

The palette pops up to display the available color choices. 

4. Drag the Pointer across the colors and release the mouse to make your selection.

The color appears as the shadows of the selected object(s).

Creating blends
An object-element’s color may be solid, or a blend of colors. The ten templates at 
the bottom of the Color Blend dialog allow you to select ready made color blend 
patterns for your object-elements. A blend is created by choosing a beginning color 
and an ending color. The blend is made up of all the colors available between the 
beginning and ending color.

Color blends can be applied to any Draw or Text object or their shadows. When 
applying blends to shadows, the deeper the shadow, the more steps used in the 
blend.
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To create a blend:
1. Display the Color Blend dialog.

From the Animation or Storyboard view, choose “Background Color...” from 
the Animation menu, or click on the Background Color tool in the Animation 
tool palette. The Background Color tool is located to the right of the Transition 
tool. 

From the Draw view, click on the Color palette in the tool palette and select 
“Color Blend” from the color palette.

The following dialog appears: 

2. Click on the “Start Color” swatch.

3. Click on a swatch in the color palette in the upper left corner.

You can also click on Pick Colors to display a color wheel to create a custom 
color.

4. Click on the “End Color” swatch.

5. Click on a swatch in the color palette in the upper left corner.

All the colors in the palette between the starting color and ending color are 
used to create a color blend. The color blend is used in the blend template at the 
bottom of the dialog.
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6. Click on one of the blend templates at the bottom of the dialog to select a blend 
for your background.

The top left template is a solid color, the next blends the starting and ending 
colors from top to bottom, others blend the colors in different ways. Select the 
desired template by clicking.

7. Click “OK” to create your new background.

To learn more about refer to

Blending colors “Creating blends,” on page 5-31
Saving and creating color palettes “Importing and saving color palettes,” on page 

5-35

Working with custom colors
WebAnimator includes numerous color palettes which can be loaded, edited, and 
saved as necessary. Any Custom Color palettes created can be saved, named, and 
opened from other WebAnimator documents. Only one Color palette can be opened 
at one time.

Do not change colors in the WebAnimator palette if you plan to create Web pages. 
Do not place two or more scenes with different color palettes in the same home 
page. The results will be unpredictable.

Note: Be aware that any subsequent changes to the Color palette grid may affect 
the colors of object-elements, shadows, or backgrounds previously chosen 
if the color occupying that location in the grid is changed. For example, if 
you choose to color an object-element green, and then later eliminate 
green from the palette and replace green with purple, the object-element 
would then be colored purple.

To learn more about refer to

Importing color palettes “Importing and saving color palettes,” on page 5-35

To create or edit a custom color:
1. Display the Color Blend dialog.

From the Animation or Storyboard view, choose “Background Color...” from 
the Animation menu, or click on the Background Color tool in the Animation 
tool palette. The Background Color tool is located to the right of the Transition 
tool. 
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From the Draw view, click on the Object Color palette in the tool palette and 
select “Color Blend” from the color palette.

It is not necessary to select any objects before creating a custom color. The 
color palette dialog appears.

2. Click “Pick Colors.”

The following dialog appears: 

3. Click on the color wheel with the bulls-eye cursor to select a color. 

The new color is displayed in the sample swatch in the upper left corner of the 
dialog, with the existing color (if one is selected) displayed in the lower half of 
the swatch. Scroll through the colors or enter your color specifications in the 
text boxes to the left. 

4. Click “OK” to save your color and return to the Color Blend dialog.

If you want to exit the dialog without creating a color, click “Cancel.” 

5. Click “OK” to exit the Color Blend dialog.

Creating palette blends
Palette blends allow you to create new colors by blending the two colors together 
within the color palette grid. This can be used to create a smooth gradient between 
the starting and ending colors and display various shades using the two selected 
colors. All the colors in the grid between the two selected colors are replaced by the 
resulting blend. The more colors in the blend, the smoother the blend appears to the 
eye. 

Macintosh Windows
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To create a palette blend:
1. Display the Color Blend dialog.

From the Animation or Storyboard view, choose “Background Color...” from 
the Animation menu, or click on the Background Color tool in the Animation 
tool palette. The Background Color tool is located to the right of the Transition 
tool. 

From the Draw view, click on the Object Color palette in the tool palette and 
select “Color Blend” from the color palette.

It is not necessary to select any objects before creating a custom color. The 
color palette dialog appears.

2. Click on the “Start Color” swatch.

3. Click on a swatch in the color palette in the upper left corner.

You can also click on Pick Colors to display a color wheel to create a custom 
color.

4. Click on the “End Color” swatch.

5. Click on a swatch in the color palette in the upper left corner.

All the colors in the palette between the starting color and ending color are 
used to create a color blend. 

6. Click “Blend Colors.”

You may use the “Copy Color” and “Paste Color” options to move the two 
colors several rows or more away from each other to create a very smooth 
blend. You can reverse the blend (from red, blended to yellow, blended to red) 
by switching the colors from right to left and left to right in the selection boxes.

7. Choose your color as needed.

The new color palette is also available from the Draw and Animation views.

8. Click “OK” to exit the dialog.

Importing and saving color palettes
Color palettes can be saved from, and loaded into, any WebAnimator document.

To import a color palette:
1. Display the Color Blend dialog.

From the Animation or Storyboard view, choose “Background Color...” from 
the Animation menu, or click on the Background Color tool in the Animation 
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tool palette. The Background Color tool is located to the right of the Transition 
tool. 

From the Draw view, click on the Object Color palette in the tool palette and 
select “Color Blend” from the color palette.

It is not necessary to select any objects before creating a custom color. The 
color palette dialog appears.

2. Click “Open palette.”

A standard “Open” dialog appears. Only Custom Color palettes appear in the 
dialog.

3. Select a Custom Color palette from the dialog and click “Open.”

The palette appears in the Custom Color dialog. You can edit any color as 
necessary.

4. Click “OK.”

You can display and use any of the custom colors in any WebAnimator color 
palette.

To save a color palette:
1. Display the Color Blend dialog.

From the Animation or Storyboard view, choose “Background Color...” from 
the Animation menu, or click on the Background Color tool in the Animation 
tool palette. The Background Color tool is located to the right of the Transition 
tool. 

From the Draw view, click on the Object Color palette in the tool palette and 
select “Color Blend” from the color palette.

It is not necessary to select any objects before creating a custom color. The 
color palette dialog appears.

2. Click “Save palette.”

A standard “Save” dialog appears. 

3. Enter a name for the palette in the “Save As” text box and click “Save.”

You can also change the location of where the file is to be saved. The palette is 
saved to the selected location.
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Adding shadows to objects
The Shadow tool in the Draw view tool palette places a drop shadow behind any 
Draw or Text object in the Draw view. In a Text object, the shadow applies to the 
text. 

To learn more about refer to

Applying colors “Applying colors,” on page 5-29
Applying blends “Creating blends,” on page 5-31

To place a drop shadow behind an object:
1. Select the object(s) you want to change.

2. Click on the Shadow tool in the Draw view tool palette.

The following dialog appears with defaults set as shown below.

3. Click on an icon in the “Shadow Type” section of the dialog which represents the 
type of shadow for your object.

You can choose from no shadow (default), connected shadow, drop shadow, 
and outline.

No Shadow

Attached Shadow Drop Shadow

Outline
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4. Click on an icon in the “Direction” section of the dialog which represents the side 
of the object on which you want the shadow to appear.

5. Click on an icon in the “Depth” section of the dialog which represents how deep 
or how far away from the object you want the shadow to appear. 

6. Click “OK” to apply the shadow to selected objects.

If you want to exit the dialog without applying a shadow, click “Cancel.” 

Layering objects
Layering allows you to place one or more selected objects on top of or underneath 
other objects. The layering commands function within the active view plane (i.e., if 
you are in the foreground view plane, the objects would be layered within that view 
plane). 

Each keyframe has its own, separate set of layers for the three viewing planes, and 
this may change from keyframe to keyframe. “Send” commands only affect objects 
in the keyframes selected.

Draw view You can use the “Send to Front” or “Send to Back” commands in the 
Draw menu to move any element up or down layers within an object.

Animation view You can use the use the “Send Object” cascading menu within the 
Animation view to layer objects within a viewing plane and to send selected objects 
to other viewing planes.

Up Cmd/Ctrl-I Sends the currently selected object ahead one layer in the 
current viewing plane, in the selected keyframes. 

Down Cmd/Ctrl-J Sends the currently selected object behind one layer in 
the current viewing plane, in the selected keyframes. 

To Front Sends the currently selected object to the FIRST layer in the current 
viewing plane, in the selected keyframes. The object appears to be in front of 
all the other objects in the viewing plane. 

To Back Sends the currently selected object to the LAST layer in the current 
viewing plane, in the selected keyframes. The object appears to be behind all 
the other objects in the viewing plane.
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Note: WebAnimator remembers layers in the same order that you created or 
placed each object. If it appears that an object is not moving, apply the 
command again; you might have drawn an object in another part of your 
document that is inserting a layer between the objects you are trying to 
move.

To learn more about refer to

View planes “Using viewing planes,” on page 5-6

Grouping and ungrouping objects
Grouping allows you to treat several individual elements as one object. This is 
useful if you want to move several objects and maintain their relative spacing. 
Grouping can only be done within the Draw view.

Note: Only elements within a complex object can be grouped together, simple 
objects cannot be grouped.

To learn more about refer to

Simple and complex objects “Creating simple and complex objects,” on page 5-8

To group objects:
1. Select the object(s) you want to group in the Draw view. 

Object handles appear around each selected object.

2. Choose “Group” from the Draw menu. 

The objects are now marked by one set of object handles, showing that they are 
being treated as one object.

To ungroup objects:
1. Select the object you want to ungroup in the Draw view.

2. Choose “Ungroup” from the Draw menu. 

Object handles appear around each object, showing that the objects are 
returned to their individual state.
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Adding and editing movement
The main commands for adding and controlling animation in your keyframes are 
located in the Animation menu. The “Move Object,” and “Size Object,” within this 
menu can add instant movement and energy to any Web site.

Figure 5-3. Animation commands

Moving objects
This feature is an alternative to using the Pointer tool in the Animation tool palette 
to move your object. It may be used, for example, when you want text (or any other 
object) to “ticker-tape” from off-screen left, to center, to off-screen right.

You can move any selected object(s) to the exact center of the screen, or off-screen 
and back on-screen, by choosing one of the sub-commands from the Animation 
menu’s “Move Object” command. These commands are available in the Storyboard 
and Animation views.

Some of these commands are helpful for bringing off-screen objects onto the screen 
which cannot be reached using the Pointer tool. To select elements that have been 
moved off the keyframe workspace, switch to the Storyboard view. Click on that 
object in any keyframe. If you select the object in any keyframe, it is basically 
selected in all keyframes. Next, select the keyframe in which you want to make 
your changes. You can then use the “To Center,” “On Screen,” and “On Screen 
Centered” commands to bring the object on-screen for positioning. 

You can also view and select objects that are off screen by choosing “Show Off 
Screen” from the View menu, pressing Cmd/Ctrl-M, or clicking on the Show Off 
Screen button at the bottom of the window. In this view, you can select and move 
objects on screen or move them off screen.
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To learn more about refer to

Selecting off screen objects “Selecting objects and keyframes,” on page 5-10
Anchoring objects “Objects anchors,” on page 5-19

These commands function in the same manner as moving objects with the Pointer 
tool, they simply automate the process of what you could do with the mouse. If only 
one keyframe is selected, the object moves to the position or size specified. If more 
than one keyframe is selected the object moves according to these rules:

• If the first of the selected keyframes is selected, the object moves in all 
of the keyframes to the position or size specified. 

• If the last keyframe of the selected keyframes is selected, a path is made 
starting from the present position and size in the first keyframe to its 
newly specified position and size in the last keyframe.

These commands function the same in the Storyboard and Animation views. If you 
used these commands from the Storyboard view, all selected frames are affected.

To Center Cmd/Ctrl-5 Moves the currently selected object to the center of 
the screen, in the selected keyframes. The object is placed so that its anchor is 
aligned with the scene’s center.

Off Left Cmd/Ctrl-4 Moves the currently selected object completely off the 
left side of the screen, retaining its vertical position, in the selected keyframes. 
The right edge of the object is placed one pixel away from the left edge of the 
screen.

Off Right Cmd/Ctrl-6 Moves the currently selected object completely off the 
right side of the screen, retaining its vertical position, in the selected 
keyframes. The left edge of the object is placed one pixel away from the right 
edge of the screen.

Off Top Cmd/Ctrl-8 Moves the currently selected object completely off the 
top side of the screen, retaining its horizontal position, in the selected 
keyframes. The bottom edge of the object is placed one pixel away from the 
top edge of the screen.

Off Bottom Cmd/Ctrl-2 Moves the currently selected object completely off 
the bottom side of the screen, retaining its horizontal position, in the selected 
keyframes. The top edge of the object is placed one pixel away from the 
bottom edge of the screen.
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On Screen Cmd/Ctrl-7 Moves the currently selected object to the on-screen 
edge, in the selected keyframes. This command is useful when you need to 
relocate an object you have moved completely off-screen.

On Screen Centered Cmd/Ctrl-9 Moves the currently selected object back 
on-screen, and centers the object, either vertically or horizontally. This 
command keeps the object’s off-screen vertical or horizontal coordinate, but 
centers it on-screen in the opposite coordinate. For example, if the object had 
been moved off-screen left, “On Screen Center” puts it back on-screen, and 
centered horizontally, while retaining its vertical position.

Sizing objects
This feature is an alternative to the Size tool on the Animation tool palette or using 
the object’s handles to change its size. You can shrink an object by one half, double 
its size, shrink the object to a vanishing point, or return the object to its original 
drawing size while keeping the object’s proportions constant, by choosing one of 
the sub-commands from the Animation menu’s “Move Object” command. These 
commands are available from with the Storyboard and Animation views.

Note: Remember, objects animate more smoothly at their original size because 
WebAnimator does not have to keep track of scaling information while the 
object is in motion.

Original Size Cmd/Ctrl-= Returns the currently selected object to its original 
drawing size, in the selected keyframes. When an object is drawn in 
WebAnimator, or an object is imported, it has an original image size. All 
subsequent size changes to the object throughout the scene, using the 
animation tools and commands, alter the appearance, or playback image size, 
of the object in the keyframes selected. No matter what changes are made to 
the object’s playback image size with the animation tools, WebAnimator 
remembers the object’s original image size.

If, however, the object is changed in the Draw view, the original image size of 
the object may be changed. (It may be useful to do this if you want to create an 
object without any jagged edges. Objects should be drawn at their maximum 
size.) This would affect all animation size changes throughout the scene. The 
original size function allows you to maintain a frame of reference for an object 
throughout a scene. You may return the object to its original size in any 
keyframe. 

Vanish Object Cmd/Ctrl-* Reduces the image of the currently selected object 
to a vanishing point, making it invisible, in the selected keyframes. Use this 
command to make an object appear to grow from or shrink to a point. This 
turns the object into a star that can still be selected and moved. The star is not 
visible during playback.
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Half Size Cmd/Ctrl-- (dash) Reduces the image of the currently selected 
object by one half of its current image size, in the selected keyframes.

Double Size Cmd/Ctrl-+ (plus sign) Enlarges the image of the currently 
selected object by two over its current image size, in the selected keyframes.

To learn more about refer to

Original images “Understanding original images,” on page 2-28

Animating objects in the Animation view
You can apply the commands just discussed, to your objects in the Animation view. 
Although the Storyboard view allows you to view more than one keyframe at a 
time, you may find it easier to do your initial animation in the Animation view and 
use the Storyboard view for editing that requires less precision.

To add movement to an object in the Animation view:
1. Draw or import your objects to be animated in the Draw view.

Use the View Bar buttons on the right side of the window to switch to the 
Draw view.

2. Switch to the Animation view.

Use the View Bar buttons on the right side of the window to switch to the 
Animation view.

3. Display the keyframe where you want to start your animation.

You can use the Forward and Reverse buttons in the Animation view tool 
palette to switch keyframes.

4. Click New in the Animation tool palette.

A new frame identical to the previous frame is created.

5. Select the object(s) you want to animate.

Selection handles appear around the object(s). If the object to be animated is 
not visible in the keyframe you want to change, select the object in a different 
keyframe. Once the object is selected, switching to another keyframe 
automatically selects the same object in that keyframe.

6. Using the Pointer tool, or the “Move Object,” “Size Object,” or “Send Object” 
commands within the Animation menu, move the object as needed.

Remember, WebAnimator automatically creates the motion between 
keyframes at 30 frames per second.
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7. Repeat steps 4-6 until all of the objects are animated as needed.

8. Press the Play button in the Animation view tool palette to review your creation.

You can return to any frame to edit the objects in the same way.

Animating objects in the Storyboard view
The advantage for animating in the Storyboard view is that you can select and view 
multiple frames to which you can apply animation. One of the disadvantages is that 
the keyframes are smaller and it is harder to be precise with positioning of objects. 
As you use WebAnimator you will develop your own favorite views for 
accomplishing different tasks.

To add movement to an object in the Storyboard view:
1. Draw or import your objects to be animated in the Draw view.

Use the View Bar buttons on the right side of the window to switch to the 
Draw view.

2. Switch to the Storyboard view.

Use the View Bar buttons on the right side of the window to switch to the 
Animation view.

3. Select the object you want to animate.

Selection handles appear around the object(s). If the object to be animated is 
not visible in the keyframe you want to change, select the object in a different 
keyframe. Once the object is selected, switching to another keyframe 
automatically selects the same object in that keyframe.

4. Select the keyframe(s) you want to animate.

Remember, animation commands can be applied to multiple selected 
keyframes.

5. Using the Pointer tool, or the “Move Object,” “Size Object,” or “Send Object” 
commands within the Animation menu, move the object as needed.

Remember, there are 30 frames in-between the last keyframe you had 
displayed and this new keyframe you just created.

6. Repeat steps 3-5 until all of the objects are animated as needed.

7. Press the Play button in the Animation view tool palette to review your creation.

You can return to any frame to edit the objects in the same way.


