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Using Acrobat Scan

 

You use the Scan command in Acrobat Exchange 
together with a desktop scanner to convert paper 
documents to 

 

PDF Image Only

 

 files. You can view 
these files, as is, in Exchange or Acrobat Reader.

The same image file scanned as black and white, 
grayscale or color will produce different size files 
when converted to PDF. Before scanning paper 
documents, see 

 

Comparing PDF file sizes

 

 for an 
example.

In Exchange, you can use the Capture Pages com-
mand to convert PDF Image Only files to more com-
pact documents you can correct, index, and search. 
Capture Pages performs this conversion with optical 
character recognition (OCR), which is actually page, 
font, character, and word recognition.

The Scan plug-in is installed from the Acrobat 3.0 
CD-ROM. For details on running the Acrobat 
installer, see the Acrobat 

 

Getting Started 

 

guide.
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Setting up a scanner

 

Acrobat Scan comes with ISIS scanner drivers for 
most popular desktop scanners. Scan also works 
with many manufacturer-supplied TWAIN drivers. 
See 

 

About scanner control software

 

 for details.

 

To select an ISIS scanner driver:

1

 

In Acrobat Exchange, choose File > Scan. Click Select. 

 

2

 

From the Select Scanner list, select the name of your 
scanner and click Select. (ISIS scanner drivers appear in 
the list as scanner names preceded by an asterisk).

 

To change ISIS scanner settings:

1

 

In Acrobat Exchange, choose File > Scan. Click 
Configure.

 

2

 

Click Settings. The Scanner Settings dialog box for 
your scanner will appear.
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3

 

Choose scanner settings, which may include any of 
the following options:

 

•

 

Mode 

 

includes black-and-white as well as several 
levels of grayscale and color. Scanning in grayscale or 
color results in larger image files.

 

•

 

Resolution

 

 should be at least 200 dpi (300 dpi is 
preferable) if you plan to use Acrobat Capture to 
perform OCR on the document. If you do not plan to 
capture a scanned document, a lower resolution may be 
sufficient.

 

•

 

Page Size 

 

can be up to 14-by-14 inches.

 

•

 

Brightness and Contrast 

 

are usually automatic 
settings; change them only if you are not getting satis-
factory images in your scans. See 

 

Scanning tips

 

 for 
more information.

 

4

 

Click OK to accept the settings, and close the Scanner 
Settings dialog box.
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5

 

Click OK to return to the Scan dialog box.

 

Note: 

 

ISIS Scanner Settings dialog box options vary 
from scanner to scanner. Refer to your scanner 
documentation or contact the scanner manufac-
turer for a description of the options available for 
your scanner.

 

To select a TWAIN scanner driver:

1

 

In Acrobat Exchange, choose File > Scan. Click Select. 

 

2

 

From the Select Scanner list, select the name of your 
scanner software, and click Select. (TWAIN scanner 
drivers appear in the list as scanner names without 
asterisks preceding them.)



 

42

 

About scanner control software

 

Acrobat Scan is adapted to a number of scanners 
and scanner drivers.

 

Adobe-supplied ISIS scanner software

HP AccuPage scanner software

Manufacturer-supplied TWAIN scanner 
software

Visioneer PaperPort software
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Adobe-supplied ISIS scanner software 

 

ISIS (Image and Scanner Interface Standard) scanner 
drivers provide a number of automatic features, 
such as automatic brightness and contrast controls. 
ISIS scanner software will not let you preview a page 
image, or select part of a page, before scanning it. 
When you use ISIS scanner software, settings you 
choose remain in effect until you change them.

In the Select Scanners list, ISIS scanner drivers 
appear as scanner names preceded by asterisks.

To install additional ISIS scanner drivers, run the 
Acrobat installer. See the Acrobat Getting Started 
Guide for installation instructions.
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HP AccuPage scanner software

 

Some Hewlett-Packard scanners support HP 
AccuPage technology, which enhances hard-to-read 
text regions for optimum character recognition. To 
take advantage of AccuPage enhancement, use the 
ISIS scanner/HP AccuPage driver.
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Manufacturer-supplied TWAIN 
scanner software

 

In most cases, TWAIN scanner software lets you 
preview the page image and select a portion of the 
previewed page to scan. You can usually select the 
scanning mode (such as color, grayscale, or black-
and-white), and the resolution of the image in dots 
per inch (dpi). 

When you use TWAIN scanner software, you usually 
have to set up each scan, because the default 
settings are restored each time. When you use 
TWAIN software with Acrobat Scan, the double-sided 
scanning option is not available.

In the Select Scanners list, TWAIN scanner drivers 
appear as scanner names without asterisks 
preceding them.
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Note:

 

 Although the Acrobat Capture plug-in can 
automatically recognize and use the TWAIN 
scanner software supplied by most scanner manu-
facturers, Capture has not been tested with all 
scanners. If you have problems using your TWAIN 
scanner software, contact the scanner manufac-
turer for advice.
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Visioneer PaperPort software

 

If you have Visioneer PaperPort software, you can 
scan pages to PDF and capture them automatically 
by using an Acrobat link on the PaperPort desktop. 
You bypass the Scan and Capture Pages commands 
entirely.

The Acrobat link you use is created automatically on 
the PaperPort desktop when you install the Capture 
plug-in:

 

•

 

With PaperPort 4.0 or later, two Acrobat links are 
created, 

 

Acrobat PDF Link - 32

 

 and 

 

Acrobat PDF 
Link - 16

 

. Remove Acrobat PDF Link - 16 by choosing 
Edit > Link Preferences, highlighting the link, and dese-
lecting Display Link Icon.
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•

 

With PaperPort 3.5 and earlier, 

 

Acrobat PDF 
Link - 16

 

 is created.

 

Note:

 

 You can use the Scan command in Exchange 
with version 4.0 or later of Visioneer PaperPort 
software, by selecting the Visioneer PaperPort 
driver from the Select Scanner list. For earlier 
versions, you must scan pages to the PaperPort 
desktop and use the Acrobat Link to capture them. 

 

To create a PDF document using the Acrobat link 
on the Paperport desktop:

1

 

From the PaperPort desktop, choose Edit > Link 
Preferences and select the Acrobat PDF link in the 
Category menu.

 

2

 

Select the style of PDF document you want to create 
from the available options. See 

 

About PDF document 
styles

 

 for information.

 

3

 

Choose the Capture settings you want to use, and 
click OK.
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4

 

Drag the scanned pages to the Acrobat link.

Refer to your Visioneer PaperPort software 
documentation for details on scanning pages to 
the PaperPort desktop, changing link preferences,
and establishing links to other products.
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Scanning paper documents

 

Scan has options for scanning single- or double-
sided pages. The maximum page size is 14-by-14 
inches. In addition, if your scanner has an automatic 
document feeder, you can scan a stack of pages 
automatically.

 

To scan one page at a time:

1

 

Place a page in the scanner.

 

2

 

Choose File > Scan.

 

3

 

Select Single-Sided Page or Double-Sided Page, 
as needed.

 

4

 

Click Scan.
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5

 

Follow the on-screen instructions for placing any 
additional pages in the scanner. 

 

Note:

 

 You can add scanned pages to any existing 
document by scanning while the document is open 
in Exchange. The new pages are added to the end 
of the document. 

 

To scan a stack of pages (ISIS scanner drivers 
only): 

1

 

Place a stack of pages in the automatic document 
feeder.

 

2

 

Choose File > Scan.

 

3

 

Select Single-Sided Stack or the Double-Sided Stack, 
as needed.

 

4

 

Click Scan.

 

5

 

If necessary, follow the on-screen instructions for 
placing additional documents in the feeder.
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Scanning tips

 

The scanning tips that follow will help you produce 
clear PDF Image Only files, save time, and minimize 
recognition errors when you use the Capture plug-
in to perform OCR on them.

 

Preparing to scan

Scanning text for best results with the
Capture Pages command

Scanning line art and photographs
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Preparing to scan

 

•

 

Clean the scan bed glass frequently.

 

•

 

If you scan a page in a bound book or magazine, place 
something heavy, such as a large dictionary, on the lid 
of the scanner to flatten the page.

 

•

 

Cut out pages from magazines or newspapers, and 
clip the articles or parts of the page you want to scan. 
Use a paper cutter or a straightedge to keep cut edges 
vertical and horizontal.

 

•

 

Make sure that the edges of the page are aligned 
correctly in the scan bed. Although the Capture plug-in 
can convert pages rotated as much as 7 degrees, 
processing can be less accurate with incorrectly aligned 
pages.

 

•

 

When scanning a document printed on glossy paper, 
try lowering the brightness setting with your scanner 
control software, if possible. Alternatively, photocopy 
the glossy page, and scan the photocopy.
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Scanning text for best results with the 
Capture Pages command

 

•

 

For normal text, set up the scanner to create black-
and-white (or 1-bit) images.

 

•

 

See Comparing PDF file sizes before scanning gray-
scale or color text.

 

•

 

For color or grayscale documents with large type, 
consider scanning at 200 dpi for faster processing.

 

•

 

Do not use dithering or halftone scanner settings. 
These settings can improve the appearance of photo-
graphic images, but they make it impossible to recog-
nize text.

 

•

 

For most pages, scanning at 300 dpi produces the 
best captures. However, if a page has many unrecog-
nized words or very small text (9pt or below), try scan-
ning at a higher resolution such as 400 dpi.
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•

 

For low- or variable-contrast pages (such as black text 
on a shaded background, or a page with handwriting on 
it ), try scanning in grayscale mode. This is most effec-
tive if your scanner includes image enhancement or 
dynamic threshold features.

 

•

 

For text printed on colored paper, try increasing the 
brightness and contrast by about 10%. If your scanner 
has color-filtering capability, consider using a filter or 
lamp that drops out the background color.

 

•

 

If your scanner has a manual brightness control, 
adjust it so that characters are clean and well formed. If 
characters are touching because they are too thick, use 
a higher (brighter) setting. If lines in characters are sepa-
rated because the characters are too light, use a lower 
(darker) setting.
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Scanning line art and photographs

 

•

 

For line art, set up your scanner to create a black-and-
white (line art or 1-bit) image.

 

•

 

For pages containing black-and-white photos, set up 
your scanner to create a grayscale image. Remember 
that a grayscale scan will result in a much larger file size 
than will a black-and-white scan.

 

•

 

For pages containing color photos, set up your 
scanner to create a color image. Color scans result in the 
largest file sizes.

 

See 

 

Comparing PDF file sizes

 

 for more information.



 

57

 



 

 1996 Adobe Systems Incorporated. All rights reserved.

Adobe Acrobat 3.0 Scan Online Guide

This manual, as well as the software described in it, is furnished under license 
and may be used or copied only in accordance with the terms of such license. 
The content of this manual is furnished for informational use only, is subject to 
change without notice, and should not be construed as a commitment by Adobe 
Systems Incorporated. Adobe Systems Incorporated assumes no responsibility 
or liability for any errors or inaccuracies that may appear in this book.

The copyrighted software that accompanies this manual is licensed to the End 
User for use only in strict accordance with the End User License Agreement, 
which the Licensee should read carefully before commencing use of the soft-
ware. Except as permitted by such license, no part of this publication may be 
reproduced, stored in a retrieval system, or transmitted, in any form or by any 
means, electronic, mechanical, recording, or otherwise, without the prior writ-
ten permission of Adobe Systems Incorporated.

Adobe, the Adobe logo, Acrobat, Acrobat Capture, the Acrobat logo, Distiller, 
Acrobat Exchange, Adobe Type Manager, PostScript, and the tagline “If you can 
dream it, you can do it” are trademarks of Adobe Systems Incorporated. 
Microsoft and Windows are registered trademarks and ActiveX and Windows NT 
are trademarks of Microsoft Corporation in the U.S. and other countries. Apple, 
Macintosh, Power Macintosh, and QuickTime are registered trademarks and 
AppleScript and TrueType are trademarks of Apple Computer, Inc. Lotus Notes 
is a registered trademark of Lotus Development Corporation. Netscape and 
Netscape Navigator are trademarks of Netscape Communications Corporation. 
UNIX is a registered trademark in the U.S. and other countries, licensed exclu-
sively through X/Open Company, Ltd. Pentium is a trademark of Intel Corpora-
tion. All other products or name brands are trademarks of their respective own-
ers.

This product contains an implementation of the LZW algorithm licensed under 
U.S. Patent 4,558,302.



 

58

 

This software includes software licensed from Verity, Inc., copyright 1994. All 
rights reserved. The address of Verity, Inc., is 894 Ross Drive, Sunnyvale, Cali-
fornia 94089.  Verity ® and TOPIC ® are  registered trademarks of Verity, Inc. in 
the United States and other countries. English Electronic Thesaurus copyright 
1993 by INSO Corporation. Adapted from the Oxford Thesaurus copyright 1991 
by Oxford University Press and from Roget's II: The New Thesaurus copyright 
1980 by Houghton Mifflin Company.  All rights reserved. Reproduction or disas-
sembly of embodied programs and databases prohibited. 

 



 

1994 This software includes software licensed from RSA Data Security, Inc.

Written and designed at Adobe Systems Incorporated, 345 Park Ave., San Jose, 
CA 95110-2704.

Adobe Systems Europe Limited, Adobe House, Edinburgh EH11 4DU, Scotland, 
United Kingdom

Adobe Systems Co., Ltd., Yebisu Garden Place Tower, 4-20-3 Ebisu, Shibuya-ku, 
Tokyo 150, Japan

For defense agencies: Restricted Rights Legend. Use, reproduction, or disclosure 
is subject to restrictions set forth in subparagraph (c)(1)(ii) of the Rights in Tech-
nical Data and Computer Software clause at 252.227-7013. 

For civilian agencies: Restricted Rights Legend. Use, reproduction, or disclosure 
is subject to restrictions set forth in subparagraphs (a) through (d) of the com-
mercial Computer Software Restricted Rights clause at 52.227-19 and the limi-
tations set forth in Adobe’s standard commercial agreement for this software. 
Unpublished rights reserved under the copyright laws of the United States.

(9/96)



 

59

 

How to use this online guide

 

 Page back or page forward.

 Undoes a change of page or view, or redoes a
 change (Go Back/Go Forward).

 Go to the Contents.

 Go to the Index.

 Go to the how-to page (this page).

 Go to the “parent” of the current topic.

Go to the indicated topic.

 Go to the next page of a continued topic.

 End of a continued topic.

For instructions on printing this guide, go to the next page.

text
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How to print this online guide

 

You can print separate topics or the entire guide. 
Since the pages of the guide have been made small 
for online viewing, Windows and Macintosh users 
may prefer to print them two to a page of paper—
”two up.” 

 

To print pages two up:

1

 

Choose File > Print Setup (Windows) or File > Page 
Setup (Macintosh).

 

2

 

Follow the instructions for your platform:

 

•

 

In Windows, click Options, select 2 up on the Paper 
tab, click OK to return to the Print Setup dialog box, and 
click OK again to close it.
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•

 

On a Macintosh, choose 2 Up from the Layout menu 
and click OK.

 

Note: 

 

If you can’t perform step 2, you may not be 
using an Adobe or PostScript printer driver. If you 
are and you still can’t perform the step, install the 
Adobe printer driver on the Acrobat CD-ROM. See 
the Acrobat Getting Started guide for installation 
instructions.

 

3

 

Choose File > Print.

 

4

 

Indicate the page range.

Click OK (Windows) or Print (Macintosh).
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