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part of this publication may be reproduced, 
transmitted, stored in a retrieval system, translated 
into human or computer language, in any form or by 
means, electronic, mechanical, magnetic, optical, 
chemical, manual or otherwise, without the prior 
written permission of the copyright owner, Cygsoft 
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Icon Index 

A list and description of all the Icons in Cygsoft LDAP Browser is given 
below. 

 
Icon Description 

 
Login - Use this button to login to LDAP Server. 

 

Logout - Use this button to logout from LDAP Server. 

 

Create New Profile -Use this button to Create a New Profile. 

 

Profile Manager - Use this button to edit/delete existing 
profiles. 

 

Create Object - Use this button to create a new Object. 

 

Add User - Use this button to add a new user object. 

 

Add Organization Unit - Use this button to add an 
organization unit. 

 

 

Cut – Use this button to cut a leaf object. 

 

Copy - Use this button to copy a leaf object. 

 

 

Paste - Use this button to paste the cut/copied leaf objects. 

 

Copy Object Link - Use this button to copy an object link. 

 

Paste Object Link - Use this button to paste a cut/copied 
object link. 

 
 

Set Entries to View – Use this button to set the number of 
entries that can be viewed at a time. 

 

Refresh – Use this button to refresh the object tree. 
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Show Next – Use this button to view the next set of entries 
according to the number of entries specified in set entries to 
view. 

 

 

Schema Manager - Use this button to view schema and add 
new object classes/ attributes to schema. 

 

 

LDAP Search - Use this button to perform a search operation 
from the selected Base DN. 

 

Create Template  - Use this feature to create new XML 
template from selected object. 

 

Modify Template: Use this feature to modify available XML 
templates. 

 

Delete: Use this feature to delete leaf node or container 
object. 

 

Export LDIF: Use this feature to export selected tree to LDIF 
file. 

 
 

Import LDIF: Use this feature to import entries from LDIF file. 

 
View Root DSE: Use this feature to view Root DSE 
properties. 
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Chapter 1 
Overview of Cygsoft LDAP Browser 
 

This chapter provides information on concepts relevant to 
Cygsoft LDAP Browser. The following points are explained in 
this chapter: 

• Introduction 

• Cygsoft LDAP Browser for Windows 

• System Requirements 

• Features of Cygsoft LDAP Browser 

 

Introduction 
 

Electronic mail and Internet information retrieval will dictate the 
future of effective business communication. The Internet comprises 
of several electronic directories, storing millions and millions of 
pages. 

As information retrieval is becoming more complex, there is a need 
for an Internet protocol to access information from a centralized 
server. 

Lightweight Directory Access Protocol (LDAP) is a software 
protocol for enabling anyone to locate organizations, individuals, 
and other resources such as files and devices in a network, 
whether on the public Internet or on a corporate intranet. LDAP is 
based on a client-server model in which a client makes a TCP 
connection to an LDAP server, over which it sends requests and 
receives responses. 

 

 
Cygsoft LDAP Browser for Windows 

 

The Cygsoft LDAP Browser is unique among C++ based browsers. 
It provides very powerful editing features for working with the 
information in LDAP directories. Directory managers can easily 
manage the contents of the LDAP databases. 

The Cygsoft LDAP Browser displays the hierarchical information 
contained in a directory in the form of a tree. On selection of a 
particular object in the tree, properties for the selected object are 
displayed in a table on the right pane. The changes made to the 
directory structure are reflected in the right pane view immediately 
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or after pressing refresh. The application provides a user-friendly 
graphical user interface and easy-to-use menus. The software is 
easy to install, and adequate help is provided. 

The Cygsoft LDAP Browser can work with any standard based 
LDAP version 2 and LDAP version 3 directory servers. E.g. iPlanet, 
Openldap,NDS, Microsoft ADS and Microsoft Exchange. This 
application has been developed using Microsoft Visual C++ and is 
available for Windows 95, Windows98, Windows NT Workstation 
4.0, Windows NT Server 4.0 and Windows 2000. 

 

 
System Requirements 

 

SYSTEM REQUIREMENTS 

System requirements of Cygsoft LDAP Browser are listed below:  

1. Pentium-class processor  

2. 64 MB of RAM (128 MB is recommended) 

3. Any of the following operating system: 

• Microsoft Windows 95 OSR 2.0 

• Windows 98 Second Edition 

• Windows NT 4.0 

• Windows 2000 

 

PREREQUISITES       

• Service pack 6 is required on NT.  

• IE 4.0 should be installed on Win95 OSR2.0 

• Winsock2 should be installed on Win95 OSR2.0 

• XML rendering feature requires Internet Explorer 5.0 or 
above on all operating systems. 

• Adobe Acrobat Reader 4.0 or above. 
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Features of Cygsoft LDAP Browser 

Cygsoft LDAP Browser provides a user-friendly Windows 
Explorer-like interface to LDAP directories with integrated 
browsing and editing capabilities. 

Following are some of the features provided in Cygsoft LDAP 
Browser. 

 

• Schema browsing and Extending Schema 

The application supports LDAP v3 feature of Schema 
browsing and extending Schema. New classes and new 
attributes can be created using Cygsoft LDAP Browser. 

• Search  
You can search for information using the search facility 
provided. Search can be performed on various levels. Users 
could choose their Base DN by clicking on an object in the tree 
view and perform a search within it. 

Search results are displayed in a window that allows the 
results to be edited. 

(Combination of AND and OR logic for a maximum of 3 
Attributes and 1 Object class is supported). 

• Cut, Copy and Paste 
Cut, Copy and Paste operations can be performed on leaf 
objects. 

• Drag and Drop  

You can perform drag and drop operations on the leaf objects.  

• Delete 
Delete operation is supported on a leaf or a container object. 

• Set Entries to View 

This feature speeds up the display of entries fetched from the 
server in situations where large amount of data is being 
worked on. By default 100 entries are displayed on screen at 
every level the user double clicks on. To view the next set of 

entries the user would need to use the Show Next button 
on the toolbar. The user can modify this default value.  

• Profile 

You can create, edit and delete a profile. Users can maintain 
profiles to speed up the login process. It also helps in working 
with multiple LDAP servers easily. 



 

Copyright 2002 © Cygsoft Inc. All Rights Reserved. Page 12 
 

 

• Object Link  

This feature is unique to Cygsoft LDAP Browser. An object 
Link is a pointer to another object.  Object Links work in the 
same way as aliases except that the Object Links created are 
restricted to point towards objects on the same server. 

A user could also view the properties of the Linked Object 
when a link is created. 

• Import/Export LDIF file  
Support for import and export of LDAP data in ldif format is 
provided.  

• Log file generation 

• General Log file 

Errors encountered during the use of the application are 
stored in the general log file.   

• LDIF Log file 

Errors encountered during import and export of the LDIF file is 
registered in LDIF log file. 

• Deleting the log file data can be accomplished in two 
ways  

! By choosing a date for which data would be deleted.  

! By deleting the entire file.  

• Edit properties 

Properties of the selected item are displayed on the right pane 
of the application. The user can modify the attribute value by 
double clicking on it. The RDN (Relative Distinguished Name) 
value can be also modified for the leaf objects. Optional 
attributes can be added to existing objects by right clicking in 
the right pane and selecting Add Attribute to Object menu 
item. 
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Chapter 2 
Connect 

 

This chapter gives information on the Connect menu. The 
following topics have been covered in this chapter: 

• Login 

• Create New Profile 

• Profile Manager 

• Logout 

 

LOGIN 
 

1. Click Connect > Login. 
Or 
Press F6 key. 
Or 

Click on  icon in the toolbar. 
’Login’ window appears. 

 
2. Select your profile
3. Select your user d
4. Enter the passwor

If you have create
the Password edit

5. Select the LDAP 
the server. The de

 
Fig 4.1
served. Page 13 

 name from the Profile Name drop-down list. 
etails from the User Details drop down list.  
d.  
d the profile with Anonymous Binding, then 
 box is disabled. 
version using which you would like to bind to 
fault version is 3. 

Fig 2.1 
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6. Click Connect button to log in. 

Note: Typical error messages received during login are mentioned below: 
1. Binding Error 

 
 
Reason: You have tried to connect to an LDAP server, which does not support the LDAP 
version you selected in the Login screen.  
Action: Try to connect to the server with a lower LDAP Version. 
 

 
2. Failed to Connect to ldap://<ipaddress/host name>:port 

Reason: The server may be down or may not be listening to the port selected.   
Action: Check the LDAP server configuration and edit the host information in the profile 
accordingly. 

 
3. Invalid Credentials / Server Response 

 
Reason: The user name or the password entered is invalid.  
Action: Enter the correct user name and the password. 
Note: The above error also indicates that the error message was generated by the LDAP 
Server  {SERVER RESPONSE}. 
 

4. LDAP Server Root DSE not accessible  

 
Reason: LDAP server root DSE is not accessible when you select Fetch DN’s. 

Action: Enter the Base DN manually. 
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Create New Profile 

To create a new profile you will need the following information: 
• IP address / Host Name of the LDAP Server 
• Port number on which the LDAP server is running 
 

CREATE A NEW PROFILE 
1. Click Connect menu> New Profile.  

Or 
Press F8 key. 
Or 

Click on  icon in the toolbar.  
’New Profile’ window appears. 

 
2. Enter the IP address or host name of the LDAP server in the 

Host/IP Address text box (See Fig 2.2). 
3. Click Fetch DN’s button in order to fetch the Base DN for the 

corresponding Host IP Address. 
4. Enter the port number of the LDAP server in the Port text box. 

By default LDAP server uses port 389. 
5. Enter a name under which you want to save your profile, in the 

Profile Name text box. 
By default Anonymous Binding check box is selected. If you 

Fig 2.2 
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save a profile, at this point it will be saved as a profile with 
Anonymous binding.  

6. If you want to login with a user name and password deselect the 
Anonymous Binding checkbox, Enter User ID e.g. cn=Directory 
Manager, and the password in respective fields. 

7. Select the LDAP version number, which you are going to 
connect. By default application takes LDAP v3. 

8. Click the Save Profile button to save the profile for further use. 
9. Click Login button to login to the specified server. 

 

Once Login is successful, the Cygsoft LDAP Browser displays 
the hierarchy of objects in a tree structure in the left pane. The 
attribute details associated with an object are displayed on the 
right pane when an object is selected in the tree. You can edit 
the attribute value by pressing F2 or by double clicking.  

 
Profile Manager  
 
MODIFY OR DELETE AN EXISTING PROFILE 

1. Click Connect menu> Profile Manager. 
Or 
Press F9 key. 
Or  
Click on           icon on the tool bar.  
’New Profile’ window appears. 

2. Select the Profile name to be edited from the Profile Name 
dropdown list. 

3. Select the User details against the chosen Profile name, from 
the drop down list (See Fig 2.3). 

4. Click Edit button to edit the Profile Details and Host Information. 

5. After the desired change has been done, click Save button to 
reflect the changes in the Profile Information. 

6. You can delete the selected profile by clicking delete button. 
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LOGOUT 
 

1. Click Conne
Or 
Click          ic
Or 
Press F7 ke
’Logout’ wind

 

 

2. If you want t

3. Click No if yo
’Exit’ window
Fig 2.3 
hts Reserved. Page 17 

ct menu> Logout. 

on on the toolbar. 

y.  
ow appears. 

o login to a different LDAP server click Yes. 

u do not want to login to a different server. 
 appears. 
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4. Click Yes to exit from the Cygsoft LDAP browser or else click 
No. 

5. Click Cancel button to remain in the same session.  
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Chapter 3 
Object  

This chapter gives you information on the following: 

• Add New User 

• Add an Organization Unit 

• Add Attribute 

• Create Object 

• Delete Object 

• Delete Attribute 

 

ADD NEW USER 

1. Select the object in which you want to add a new user. 

2. Click Object menu>Add> User. 
Or 
Press Ctrl+U 
Or 

Click on  icon from the tool bar 
’Add User’ dialog box appears 

3. Enter the First and Last name of the user in the Add User 
window (See Fig 3.1). 

4. Click OK button. 

 
ADD AN ORGANIZATION UNIT 

1. Select the Object to which you want to add an organizational 
unit. 

2. Click Object menu>Add> Organization Unit. 
Or 
Press Ctrl+O keys. 

Fig 3.1 
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Or  

Click on  icon from the toolbar. 
’Add Organisation Unit’ window appears (See Fig 3.2). 

3. Enter the name of the organization in the Add Organization Unit. 

4. Click OK to save your changes.  

 
ADD AN ATTRIBUTE TO THE OBJECT 

Select the Object in which you want to add an attribute. 

1. Click Object menu > Add attribute… 
Or 
Press Shift+R keys. 
Or 
’Add attribute to Object’ window appears (See Fig 3.3). 

2. Select the Attribute from the Select Attribute drop down list. 

3. Enter the new Attribute value in the New Attribute Value text 
box. 

4. Click OK to save the new attribute value. 

 
CREATE AN OBJECT 

1. Select the object in which you want to create a new object. 

Fig 3.2 

Fig 3.3 
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2. Click on the Object > Create. 
Or 
Press Ctrl+T keys. 
Or  

Click on  icon from the toolbar. 
Or 
’Create Object’ window appears (See Fig 3.4). 

3. Select the Base class from the list and click Create. 
’Mandatory Attributes’ window opens (See Fig 3.5). 

Fig 3.4 

Fig 3.5 
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4. Enter the attribute value for all attributes shown. 

5. Click OK to create the object. 

 
DELETE A LEAF OBJECT 

1. Select the leaf object you want to delete.  

2. Select Object > Delete Object. 
Or 
Click the Delete key on the keyboard. 
Or 
Select Delete from right click menu. 
’Delete’ dialog box appears (See Fig 3.6). 

 

3. Click Yes to delete the selected object along with the Object 
link. 
Or 
Click No if you don’t want to delete the leaf object. 

When you try to delete a container object, the ‘Delete Container 
Object’ dialog box appears (See Fig 3.7). 

4. Click Yes button if you want to delete selected container or else 
click No button. 

 

Note:  
• The delete operation also deletes the object links of the deleted objects. 

• The delete operation could take some time to complete the deletion 
depending on the Object links existing in the tree. 
 

Fig 3.6 

Fig 3.7 
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DELETE AN ATTRIBUTE  
1 Select the Attribute. 
2 Right Click the mouse button (See Fig 3.8). 

Pop-up menu appears. 
3 Click Delete Attribute option. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig 3.8 
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Chapter 4 
Edit Features 
 

This chapter explains the following editing features provided 
by Cygsoft LDAP Browser: 

• Cut/Copy/Paste 

• Drag and Drop 

• Copy/Paste Object Link 

• Edit Attribute 

• Copy text of attribute value 

 

CUT/COPY/PASTE  
After selecting a leaf object you can perform cut, copy and paste 
operations. These operations are also available on right clicking a 
selected object and are also present as icons on the toolbar. 

 

DRAG AND DROP 
Browser supports drag and drop of leaf objects. The following steps 
describes how to perform drag and drop operation: 

1. Select the required leaf object  

2. Drag this object to another object in the tree where you want to 
move it. 

3. Release the mouse button. 

 

COPY/PASTE OBJECT LINK  

The Copy Object Link (Ctrl+R or Click on  icon from the toolbar 
or from the right click menu) and Paste Object Link (Ctrl+P or Click 

on  icon from the toolbar or from the right click menu) functions 
in the Edit menu help you to copy and paste the link objects at a 
location of your choice. This is a link is a pointer to a specific leaf 
object in the directory. Paste Object Link option will be enabled only 
if you copy an object.  The Copy Object Link operation can be 
performed only on a leaf object. 
 
You can view the original properties by selecting the 
Ref:ObjectName from the tree, and selecting the “view original 
properties” from the right click menu. 
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Note:  

Following steps describes how to create an attribute “CygAttrObjectLink”  
1. Open the Schema Manager window. 
2. Click on the “Add New Attribute” Button 

 
In the Add New Attribute Window 

1. Enter the name as CygAttrObjectLink. 
2. Enter the Object ID (OID). 
3. Select the syntax as CASE IGNORE STRING (CIS). 

 
Following steps describes how to create a class “CygObjectLink” 

1. Open the Schema Manager window. 
2. Click on the “Add new Class” button 

 
In the add new Class Dialog Box  

1. Type in “CygObjectLink” in the Class Name text box.  
2. Enter the Object ID (OID). 
3. Select the Parent class ‘top’ from the Combo Box.  
4. From the Available Attributes add “CygAttrObjectLink”, “Object class” 

and “cn” to the Mandatory Attributes List. 
5. Click OK to Create the new class 

 

 
 
EDIT ATTRIBUTE 

1. Select the Attribute Value you want to edit. 

2. Click Edit > Edit Attribute. 
Or 
Press F2 key. 
Or 
Double click on the Attribute value. 

 

COPY TEXT OF ATTRIBUTE VALUE 
1. Double click the Attribute value 

Or 
Select the attribute and press F2. 

2. Right click the mouse button. 
Pop-Up menu appears. 

3. Select Copy. 
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Chapter 5 
View 
 

This chapter explains the procedure of the following: 

• Set entries to view 

• View Root DSE Properties 

• Count no of Entries 

• Refresh 

 

SET ENTRIES TO VIEW 
To speed up the display of entries fetched from the server by 
default 100 entries are displayed on screen at every level. If you 
want to change this value 

1. Click View menu.  
Sub menu appears. 

2. Click Set Entries to View. 
Or 
Click on           icon from toolbar. 
’Set Entries to View’ window appears (See Fig 5.1). 

3. Edit the Value. 

4. Press OK button. 

To view the next set of entries use the Show Next button  on the 
toolbar.  

 

VIEW ROOT DSE PROPERTIES 
There is a special entry called the root directory specific entry, or 
rootDSE, that contains a description of the whole tree, its layout, 
and its contents.  

 

Fig 5.1 
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1. Click on View and then click on Root DSE Properties. 
’Root DSE Information’ window appears (See Fig 5.2). 

2. Click Close button to close the window. 

COUNT NUMBER OF ENTRIES 
1. Select the object to count number of entries present. 
2. Click View > Count No of Entries. 

’Entry count’ window appears displaying the object entry details. 

Refresh 
Refresh offers the following two options: 
1. Refresh Tree 

Use Refresh tree option when you want to refresh the entire 
object tree. The Refresh Tree option reflects the modifications 
made throughout the object tree. 
 

 
 
 

Fig 5.3 

Fig 5.2 
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2. Refresh Node 
Use Refresh Node when you want to refresh only a specific 
node. The Refresh Node option reflects the modifications made 
in that particular node only. 

REFRESH TREE 

1. Click View > Refresh Tree. 
Or 
Select any object and Right click the mouse button. 
Or 
Press F5 key (See Fig 5.4). 

REFRESH NODE 
1. Select the node you want to refresh. 
2. Press F4 key. 

Or 
Right Click the mouse button. 
Pop-Up menu appears.  

3. Select Refresh Node option. 
 
 

Fig 5.4 

Fig 5.5 
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Chapter 6 
XML Option  

 

XML Option is the latest feature added in LDAP Browser. XML 
Rendering feature in XML Option is a very useful feature 
allowing the user to do the following: 

1. Create an object using Template 

2. Create XML template 

3. Modify XML Template 

 

XML Rendering  
 
XML Rendering has made creating an object very simple by 
providing the user the following advantages. The user can: 
 

• Create Object using template 
XML Rendering allows you to create objects using 
templates.  Using templates you can enter the values for the 
attributes as required. You can also define validation rules 
and default values for attributes. 

• Create template 
XML Rendering allows you to create a new template. To 
create a new template Click XML Options > Create XML 
template or use any text editor. Use only the tags defined by 
Cygsoft if you create template using text editor. The sample 
XML file shown below gives you an idea of the tags defined 
by Cygsoft and also the attributes of the tags. 

 
• Modify Template 

XML Rendering allows you to modify the available 
templates. While Modifying templates you can also define 
the validation rules and default values for attributes. 
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Explanation of the tag attributes: 

Tag Brief Description 
<XMLTemplate Description = “ “ > 
……  
…… 
</XMLTemplate> 

 
 
 

<XMLTemplate> …… </XMLTemplate>  is the 
root attributes and has three child attributes 

 
Description = “ “ 
Description of XML template. 
Ex:<XmlTemplate Description=”Create 
User”>  

<ObjectClass> … </ObjectClass> 
 

<ObjectClass>  … </ObjectClass> 
Is the name of ObjectClass from which you want 
to derive object. 
Ex: <ObjectClass>top</ObjectClass> 
<ObjectClass>organizationalUnit 
</ObjectClass> 

<Field> …… </Field>  <Field>….. </Field> - is the attributes with six 
child attributes 

<Name>…………</Name> 
 

Name tag specifies the  attribute name  
Ex. <Name> c </Name> 
 

<DisplayName>…………</DisplayName> The value of this tag displays the name of the 
attribute. 
Ex. <DisplayName> Country Name 
:</DisplayName>  
 

<DefaultValue>…………</DefaultValue> DefaultValue tag specifies  the default value 
of an attribute.  
(The Default values are only for 
TextBox,NonEditableTextBox and the 
PasswordField). 
 
Ex. <DefaultValue> India /DefaultValue> 

<Input>…………</Input> The values inside Input tag are 
TextBox,ComboBox,CheckBox, 
NonEditableBox and Password Field. 
Brief explanation of the values:  
• TextBox : Displays the TextBox where 

user can enter the values. 
• NonEditableTextBox: Displays the Non 

Editable text box. 
• PasswordField : The Characters in the 

fields are displayed as '*'. 
• ComboBox: Displays the ComboBox 

allowing the user  to select one Item from 
the available list.  

• CheckBox: Displays a CheckBox which 
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can be checked or unchecked. 
CheckBox is used for storing the Boolean 
values which will be stored as on and off.  

Ex. <Input> TextBox </Input> 
 

<Validation>…………</Validation> 
 

Validation specifies the different types of 
validation rules that can be defined for 
entering different types of data in each field.  
Following is the brief explanation of the 
validation values: - 
• NonnegativeNumber: Accepts only 

Positive Numbers. 
• Charactersonly: Accepts only Character 

values. 
• Boolean: Accepts Boolean values like 

true and false as well as on and off. 
• Alphanumeric: Accepts characters as 

well as numbers. 
• Number: Accepts only numbers 

Ex. <Validation> CharactersOnly </Validation> 

<Size> ...... <Size>  
Use the Size tag for  specifying the size of 
the field. 
Ex. <Size> 15 </Size>  

<MaxLength> .... </MaxLength> 
Use the MaxLength tag to specify the 
maximum number of characters that the field 
can accept. 
Ex. <MaxLength> 10 </MaxLength>  

<Color> .... </Color> 
Use color tag to specify the text color of the 
input field contents. 
User can also specify the color values used 
in the html pages. 
Ex. <Color> red </Color> 
<Color> #FF2222 </Color> 
 

<Option> .... </Option> 
Use the Option tag to add values to the 
combo box 
Ex.<Option> India </Option> 
     <Option> USA </Option> 
     <Option> Russia </Option> 
     <Option> UK </Option> 
 

Note : 

1. All XML tags are case sensitive. 
2. The Invalid and Case Insensitive tags are Ignored. 
3. In Case, the xml tag is incorrect, an error message will be displayed. 
4. The DefaultValue tag is specifically used for the TextBox, NonEditableTextBox and 
PasswordField. 
5. The values inside Validation tag are case insensitive. 
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CREATE AN OBJECT USING TEMPLATE 
1. Click XML Options > XML Rendering (See Fig 6.1). 

2. Click to select the object under which you want to add a new 
object. 

3. Click the Create Object           icon. 
’Create Object’ window appears displaying all the available 
create object templates (See Fig 6.2). 

4. Select the required template. 
Fig 6.2 

Fig 6.1 
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5. Click OK button. 

’XML rendered view (Create)’ window appears (See Fig 6.3). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Enter the required data in the fields of the template. 
7. Click OK button. 

The object is created. 

Fig 6.3 
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For creating the above template, the following xml template file is used: 
Template file Name -user.xml 

<?xml version="1.0"?> 
<?xml-stylesheet type="text/xsl" href="stylesheet.xsl"?> 
<XmlTemplate Description="User Details "> 
<ObjectClass>organizationalPerson</ObjectClass> 
<ObjectClass>Person</ObjectClass> 
<ObjectClass>top</ObjectClass> 
<Field> 
<Name>cn</Name> 
<DisplayName>First Name  (cn) : </DisplayName> 
<Input>TextBox</Input> 
<DefaultValue>John</DefaultValue> 
<Validation>charactersonly</Validation> 
<Size>20</Size> 
<MaxLength>20</MaxLength> 
<Color>blue</Color> 
</Field> 
<Field> 
<Name>sn</Name> 
<DisplayName>Surname (sn)  :</DisplayName> 
<Input>TextBox</Input> 
<DefaultValue>Parker</DefaultValue> 
<Validation></Validation> 
<Size></Size> 
<MaxLength>20</MaxLength> 
<Color>red</Color> 
</Field> 
<Field> 
<Name>userPassword</Name> 
<DisplayName>Password :</DisplayName> 
<Input>PasswordField</Input> 
<DefaultValue>john12</DefaultValue> 
<Validation>alphanumric</Validation> 
<Size>10</Size> 
<MaxLength>10</MaxLength> 
<Color>green</Color> 
</Field> 
<Field> 
<Name>description</Name> 
<DisplayName>Description :</DisplayName> 
<Input>NonEditableTextBox</Input> 
<DefaultValue>Normal User</DefaultValue> 
<Validation>charactersonly</Validation> 
<Size>10</Size> 
<MaxLength>10</MaxLength> 
<Color>green</Color> 
</Field> 
</XmlTemplate> 
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A sample xml template (country.xml) for Object Class country is shown below: 



 

Copyright 200
 

 
 XML code of template country.xml: 

CREATE XM
<?xml version="1.0"?> 
<?xml-stylesheet type="text/xsl" href="stylesheet.xsl"?> 
<XmlTemplate Description="Country Details "> 
<ObjectClass>country</ObjectClass> 
 
<Field> 
<Name>c</Name> 
<DisplayName>Country Name</DisplayName> 
<Input>ComboBox</Input> 
<DefaultValue></DefaultValue>  
<Validation>none</Validation> 
<Option>Australia</Option> 
<Option>Canada</Option> 
<Option>India</Option> 
<Option>Japan</Option> 
<Option>Malaysia</Option> 
<Option>Saudia Arabia</Option> 
<Option>Singapore</Option> 
<Option>South Africa</Option> 
<Option>United States</Option> 
<Option>United Kingdom</Option> 
<Option>Others</Option> 
<Color>blue</Color> 
</Field> 
 
<Field> 
<Name>description</Name> 
<DisplayName>Description</DisplayName> 
<Input>TextBox</Input> 
<DefaultValue>Asia</DefaultValue> 
<Validation></Validation> 
<Size>20</Size> 
<MaxLength>10</MaxLength> 
<Color>Red</Color> 
</Field> 
</XmlTemplate> 
2 © Cygsoft Inc. All Rights Reserved. Page 36 

L TEMPLATE 

1. Click XML Option>XML Rendering. 
’Create XML template’ option gets activated. 
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2. Click XML Option > Create XML Template. 
Or 
Select the object and right click the mouse button. 
Click Create XML Template from the Pop-Up menu. 
’Save XML Template’ window appears (see Fig 6.4). 

3. Enter the File name in the File Name text box. 
4. Click Ok button. 

 
 
 
 
 
 
MODIFY TEMPLATE 

1. Click XML Options > Modify XML Template. 

’Modify XML Template’ window appears (see Fig 6.5). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Click to select the required template. 
3. Click Modify button. 

 

Note:  
• The xml file created by you, is saved in the folder where the 

Cygsoft LDAP Browser is installed . 
 

Fig 6.6 

Fig 6.4 

Fig 6.5 
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4. The selected template opens in the edit mode (see Fig 6.6). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Make the required changes. 
6. Click Save button.  
 

 

Note:  
• Click ’Save As’ button if you want to save the template with a 

different name. 
 

 

Fig 6.6 
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Chapter 7 
Schema Manager 

This chapter gives you information about Schema Manager. 
The Schema Manager helps you to browse the schema and 
extend schema (i.e. add new object classes and attributes to 
an existing schema). 

The following topics are covered in this chapter: 

• Add a new class 

• View Class Details 

• Add New Attribute 

• Attribute Details 

 

ADD A NEW CLASS 
1. Click Tools > Schema Manager option from the sub- menu. 

Or 
Press Ctrl+M keys. 
Or 

Click on  icon from the toolbar. 
Schema Manager screen appears (See Fig 7.1). 

Fig 7.1 
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2. Click Add New Class button in the Class Properties pane to 
add a new class to the schema. 
’Add New Object Class’ window appears (See Fig 7.2). 

3. Type the new Class Name in the Class name field. 
4. Type the OID. If this field is kept blank a default value is inserted 

automatically. 
5. Select the Parent Class Name from the drop down list box. 
6. Select the Mandatory and Optional attribute from the 

available attribute list. 
7. Click OK to save the new class. 

Fig 7.2 
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VIEW CLASS DETAILS 
The Class Details button in the Schema manager invokes a Class 
details dialog box (Figure 7.3), displaying the details of the selected 
class. It displays the name, OID, description of the class, the super 
class from which it is derived, mandatory and optional attributes. 

1. To view class details, click the Class Details button (See Fig 
7.3) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig 7.3 
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ADD NEW ATTRIBUTE 
1. Click Tools>Schema Manager. 

2. Click the Add New Attribute button. 
’Add New Attribute’ window opens (See Fig 7.4). 

3. In the Name field, enter the name of the attribute.  

4. In the Object ID field, enter the relevant ID. If this field is kept 
empty default OID is inserted. 

5. In the Syntax field, choose the syntax from the drop down list. 

6. In the Description field, enter the relevant attribute description.  

7. Click OK to save the new attribute or Click Cancel to cancel 
your action. 

 

Note: Only following attribute syntax are supported while adding 
new attribute in schema 

• Case Ignore String (cis) 

• Binary (bin) 

• Telephone Number (tel) 

• Case Exact String  (ces) 

• Distinguished Name (dn) 

• Integer (int) 
 

 

Fig 7.4 
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ATTRIBUTE DETAILS 

The attribute detail window displays the properties of the attribute. 
Cygsoft LDAP Browser allows you to view any attribute in the 
schema. 

You can view the details of attributes in the Schema. To view an 
attribute detail of a selected attribute, click on the Attribute Details 
button in the Schema main window. 

The following screen (See Fig 7.5) shows you how to view existing 
attribute details.  

The name, OID, syntax and the description of the selected attribute in the 
Schema are displayed in this window. 

Depending upon your organizational needs, you can create as many classes and 
attributes as you require. 

 

 

 

 

 

 

 

 

Fig 7.5 
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Chapter 8 
Search for Information  
 

Cygsoft LDAP Browser allows you to search for information 
stored in the LDAP server. You can activate a search operation 
from any Base DN. This chapter explains how to activate 
search function and how to Search with object class = *. The 
following two topics are covered in this chapter: 
 

• Activate the search function  
• Examples 

 

ACTIVATE THE SEARCH FUNCTION 
1. Click on Tools>LDAP Search. 

Or 
Press Ctrl+F keys. 

Fig 8.1 
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Or 

Click on  icon from the toolbar. 
’LDAP Search’ window appears (See Fig 8.1). 

You can perform a search operation from any level you choose in 
the tree structure. If you wish to search the entire data, click the 
Base DN. Features such as searching within the entire set of 
classes using the wildcard character * and using AND/OR 
operators for attribute values is supported. 

 
 

Note:  
• You can use *  in the attribute value field as supported in normal search 

operations. 
• ‘Save Search’ button allows you to save the DN’s. 

 

 

Examples 
 
SEARCH WITH OBJECT CLASS = * 

Search within the entire set of Classes available on a selected base 
DN (See Fig 8.2). 

 
1. Select the required base DN from the browser window. 
2. Open the search window. 
3. Keep the default value as (*) in the object class field and enter 

appropriate values in the filter options field. 
4. Click Search button. 
5. The search result window displays all the entries inside the 

selected base DN. 
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SEARCH WITH ATTRIBUTE VALUES 
To Search for specific attribute values within inetOrgPerson having 
attribute cn, which start with character ‘p’, (See Fig 8.3). 

1. Select the base DN in which you want to perform search 
operation, from the browser window.  

2. Open the search window. 
3. Select the required object class field as inetOrgPerson. 
4. Select the Attribute Name as cn. 
5. Select the Attribute value as p*.  
6. Click Search button. 
7. The search result window displays all the entries, which satisfies 

the above condition for the selected base DN. 
 
 

Fig 8.2 
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SEARCH - WILD CARDS WITH AND OPERATION 
To display all the persons in inetOrgPerson class having the 
following condition (See Fig 8.4): 

• ‘cn’ starts with ‘p’ 

• ’sn’ ends with ‘r’ 

• ‘given name’ is ‘pete’.,  

 
1. Select the required base DN from the browser window.  
2. Open the search window 
3. Select the required object class field as inetOrgPerson. 

Fig 8.3 
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4. Set the Attribute Name and Attribute Value as shown above. 
5. Select the filter Options field as All of the above Keywords. 
6. Click Search button.  
 
The search result window will display all the names, which satisfy 
all the above condition for the selected base DN.   

 
SEARCH- WILD CARDS WITH OR OPERATION 

To display all the persons in inetOrgPerson class having any of the 
following condition, (See Fig 8.5). 

• ‘cn’ starts with ‘p’ 

Fig 8.4 
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• ’sn’ ends with ‘r’ 

• ‘given name’ is ‘pete’., 

1. Select the base DN from the browser window. 
2. Open the search window. 
3. Select the required object class field as inetOrgPerson. 
4. Set the Attribute Name and Attribute Value as shown above. 
5. Select the filter Options field as Any of the above key words. 
6. Click Search button.  

 
The search result window will display all the names, which satisfy 
any of the above condition for the selected Base DN. 

Fig 8.5 
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Chapter 9 
Import and Export of LDIF files 
 

This chapter covers the following topics: 

• Export to LDIF File 

• Import from LDIF File 
 

LDIF (Lightweight Directory Interchange Format) is an ASCII 
file format used to exchange data and enable the 
synchronization of that data between Lightweight Directory 
Access Protocol (LDAP) servers.  

 

EXPORT TO LDIF FILE  
1. Select the base DN from the browser window. 
2. Click Tools>Export LDIF File.  

Or 
Press Ctrl+E keys. 
Or 
Select Export LDIF File from the right click menu.  
’Export LDIF file’ dialog box appears (See Fig 9.1).  

3. Click Browse button to select the export file path. 
Or 
Enter the LDIF file name in the LDIF File text box. 

 

Note:  
• The file is by default, exported to the folder where the Cygsoft 

LDAP Browser is installed.. 
 

 
4. Click OK button. 

You can either export complete information from an entire server, 
or from a selected sub tree.  

Fig 9.1 
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IMPORT FROM LDIF FILE 
 

1. Select the base DN from the browser window. 
2. Click Tools>Import LDIF File. 

Or 
Press Ctrl+I keys. 
Or 
Select Import LDIF File from the right click menu.  
’Import LDIF file’ dialog box appears (See Fig 9.2). 

3. Click the Browse button to select the file to be imported. 
Or 
Enter the file name with complete path. 

4. Click OK button. 
 

The directory structure will be created, according to the LDIF file 
contents.  
 

 

 
 

Note:  
• LDIF Import is only possible with LDIF files, Which have been 

 exported using Cygsoft LDAP Browser 2.0. 
 

 
 
 
 
 
 
 
 

Fig 9.2 
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Chapter 10 
Log Manager 
 

Errors shown on console while using the browser are 
registered in general log file. This chapter explains how to: 

•  View the General Log 

• View the LDIF Log 

•  Delete General Log 

• Delete LDIF Log 

 

 
VIEW THE GENERAL LOG  

1. Click Log Manager>View General Log option. 
Or 
Press Ctrl+ Shift + G keys. 

 
Errors shown on console while importing/exporting the LDIF file are 
also registered in log file.  
 
 

VIEW THE LDIF LOG 
1. Click Log Manager>View LDIF Log. 

Or 
Press Ctrl+ Shift + F. 

 
 

DELETE GENERAL LOG 
1. Click Log Manager>Delete General Log. 

Or 
Press Ctrl+ Shift + L keys. 

2. To delete logs for a specific date, select the date from the drop 
down date list. 
Or 
Check mark Delete Entire Log check box in order to delete the 
entire log. 

3. Click Ok button. 
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DELETE LDIF LOG  
 
1. Click Log Manager>View General Log option. 

Or 
Press Ctrl+ Shift + D keys. 
’Delete LDIF log’ window appears. 

 
2. To delete logs for a specific date, select the date from the drop 

down date list. 
Or 
Check mark Delete Entire Log check box in order to delete the 
entire log. 

3. Click Ok button. 
 

Fig 10.1 

Fig 10.2 
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Chapter 11 
Getting more information 

 

This chapter describes where to get more information on the 
topics related to LDAP browser. All the related URL’s have 
been listed down for your reference. For any queries and 
technical help you can visit the URL for Customer Support. 

 
 

Useful URL’s 
• OpenLDAP Server 

http://www.openldap.org 
 

• iPlanet Directory Server 
http://iplanet.com/products/iplanet_directory/home_directory.html 

 
• Active Directory Overview 

http://www.microsoft.com/windows2000/server/evaluation/featur
es/dirlist.asp 

 

Documentation 
  

• A list of documentation like User Manuals, FAQ and technical 
specification documents are available on our Website:  
www.cygsoft.com. 

 
 

Customer Support  
• For any queries and technical help please e-mail: 

support@cygsoft.com indicating the name of the product and the 
nature of the problem. 

 

 

 

 

 

 

 

 

http://www.openldap.org/
http://iplanet.com/products/iplanet_directory/home_directory.html
http://www.microsoft.com/windows2000/server/evaluation/features/dirlist.asp
http://www.microsoft.com/windows2000/server/evaluation/features/dirlist.asp
http://www.cygsoft.com/
mailto:support@cygsoft.com
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