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Chapter 1

I n t r o d u c i n g  A X E L

Welcome to AXEL, the 3D authoring software that 
makes publishing your creations on the Internet 
easier than it has ever been before. This document 
will help you use AXEL to create interactive 
animated 3D content for the Internet.

In this chapter:

Installing AXEL  8

AXEL System Requirements  8

Learning AXEL  9
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Installing AXEL
To install AXEL, place the CD-ROM in your CD-ROM drive and double-click the Setup.exe 
program file. Follow the on-screen instructions; change the default installation path if required.

Note: On Windows NT® and Windows 2000® you must log on as Administrator to install AXEL.

AXEL System Requirements
The minimum system requirements for AXEL are:

• Intel® Pentium® II, AMD or similar processor, 200Mhz 

• Microsoft® Windows® 98, Windows® Me, Windows NT® 4 (SP3 minimum) or 
Windows® 2000.

• 64 MB of RAM (128MB RAM preferred)

• 800 x 600 resolution, 256 color monitor 

• 3-Button mouse
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Learning AXEL
This guide covers every feature in AXEL — what the feature is and how to use it. The following 
training material is also provided to help you master AXEL quickly.

Note: The user guide and tutorials are also available in PDF format on your software CD.

Jump Start These lessons, in the AXEL Help menu, introduce basic 3D 
concepts and give an overview of the AXEL interface and 
workflow. This is a good starting place to finding your way 
around AXEL.

Tutorials The tutorials provide hands-on training. While the user guide 
describes every feature in AXEL, the tutorials show you how 
to bring the features together to create compelling 3D con-
tent for the web.

On-line Help AXEL On-line Help contains the same information as the user 
guide. In addition, it contains hyperlinks and search features 
to help you find answers fast.

Resources on 
www.MindAvenue.com/
resources/

Here you’ll find FAQs, the AXEL forum including tips and 
tricks, and the Request Form for additional support.
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Chapter 2

A X E L  B a s i c s

AXEL is the tool to use to design 3D animated and 
interactive content for web pages. With AXEL, you 
can create anything from a simple 3D object to a 
complex 3D World, adding as much movement, 
color, texture, sound, and interaction as you like. 
Then simply publish the 3D World to a stream file, 
include it in your HTML code, and upload the files 
to your web site’s server. Anyone connected to the 
Internet will then be able to view and interact with 
your content.

In this chapter:

The AXEL Workflow  12

About 3D Space  14

Managing Projects  17

Customizing the Work Area  21

From Author to 
Browse Mode  22

Viewports  23

Menus  30

Toolbars  40

World Explorer  43

Parameter Editor  45

Sequencer  47

Interaction Editor  48
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The AXEL Workflow
The AXEL workflow is represented by the layout of the menu bar at the top of the work area. 

The main steps to authoring 3D content in AXEL are described in the following sections.

Modeling
AXEL provides the modeling tools to create preset curves or surfaces or to design your own. 
There are revolution and extrusion tools that create customized surfaces based on a drawn curve. 
There are bone structures to which you can apply skin surfaces. All curves and surfaces are 
editable — you can change their size, orientation, position, point positions, and so on. Import of 
VRML2.0 files is also supported for importing objects. For more information, see Chapter 3, 
“Modeling.”

Adding Relations
Adding relations between objects provides a way of creating constrained movement. A large 
variety of relations are available: pose, distance, direction, spring, and snap, to name a few. For 
more information, see Chapter 4, “Relations.”

Visualization
You can use a variety of tools to change the look of your content. Add color and texture to 
surfaces. Increase the depth of the 3D World by adding WebCams. Add drama to the World 
using additional lights. Use a clip box to limit what the WebCam displays and help increase 
playback performance. For more information, see Chapter 5, “Visualization.”

Animation
Animation is simple. Select any object’s parameter and press the Record button. Change the 
value of the parameter. Voila! You have created animation. You can also add particles, waves, 
and other animation effects. For more information, see Chapter 6, “Animation.”

Adding Interaction
Interaction in the 3D World makes it come to life. Use a series of preset handles to quickly add 
interaction to the models. Create your own reactions such as starting an animation or playing a 
sound. Connect the reactions to sensors, such as mouse buttons, so the reactions can be triggered 
in a web page. For more information, see Chapter 7, “Interaction.”
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Web Integration
Test the World in AXEL as if you were browsing it on the Internet. Use the host web page view 
to see what the content will look like in its web page. Use Browse mode to test the content as it 
runs in the WebCam, simulating a browser.

When it comes time to distribute the 3D World, choose the size of the 3D window as well as any 
DHTML parameters you want to use. An AXEL stream file is created; in the stream file all the 
objects, textures and sounds are compressed. Open an existing web page to host the 3D content 
or let AXEL create a host web page for you. For more information, see Chapter 8, “Web 
Integration.”
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About 3D Space
Virtual 3D space simulates real life. Just as a contractor’s plans contain the spatial information 
needed to build a new house, an AXEL 3D World contains the information needed to correctly 
display your objects in 3D space.

3D software is based on a cartesian coordinate system, named after the French mathematician 
and philosopher, Descartes. He devised a numerical system to quantify the position of things in 
3D space, using the X, Y, and Z axes.

Whereas a 2D image uses width (X) and height (Y), 3D adds a third axis, depth (Z). So any 
location can be described by a series of three numbers (X,Y, Z). If you instruct movers to put 
your couch on the west side of your house, on the second floor and in the back, you have 
described 3D coordinates. 

At the World origin, the coordinates are (0,0,0). As you move away from the center, the X, Y, 
and Z values vary as follows:

• X increases toward the right.

• Y increases toward the top.

• Z increases toward the front.
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Global and Local Coordinates
Red, green, and blue axes appear on each object you create in AXEL. The axes originate at the 
center of the object. The direction of the axes indicates the orientation of the object.

Global coordinates refer to the AXEL World view. That is, the X Y Z axes are always identical 
references for all objects in the World.

Local coordinates refer to an object's center. They are identical when you create an object, but 
if you rotate it, the local axes will change to reflect the new orientation.

In the following illustrations, the global axes appear in the lower left of each image. The axes 
on the Eiffel tower are its own local axes.

The top images show the Eiffel tower being scaled in Y, vertically. In the lower images, the Eiffel 
tower is rotated clockwise 90 degrees. Notice how its local Y axis is now pointing to the right. 
This time, when scaled in Y, it is stretching to the right.

X=Red Y=Green Z=Blue

Global axes Local axes Object scaled along its local Y axis

Global axes Local axes rotated Object scaled along its local Y axis
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About Objects
AXEL uses points to define geometry. Any number of points that form a closed plane become 
a face. The number of points is also an indicator of the weight of an object, that is, the amount 
of data required to define it.

Every point has a position defined by three numbers (X Y Z). The first number is the distance 
from the point to the center of the World along the X axis. The second number is the distance 
from the point to the center of the World along the Y axis. The third is the distance along the Z 
axis. In the following illustration, the center of the cube is in the center of the World. 

FacePoint Local axes
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Managing Projects
You can start building a 3D World as soon as you launch AXEL. You can also open existing 
projects, and save projects to continue working on them later. You can merge AXEL projects to 
reuse models, and import VRML files created in other 3D modeling packages.

The File menu contains the commands you need to manage your project files. 

Note: You can also publish your work so that others can interact with your 3D World on the web. For 
more information, see “Web Integration” on page 245.

Opening and Saving Projects
3D Worlds are saved in AXEL project files (.axel) that store all the information required to 
recreate the objects, animation, interaction, and publishing settings in your World.

To start a new project:

Launch AXEL or if AXEL is running, choose File > New or press CTRL+N.

To save your work:

Choose File > Save, press CTRL+S, or click Save ( ) on the standard toolbar.

Note: Depending on your screen resolution, the standard toolbar may be hidden. To show the standard 
toolbar, choose View > Toolbars > Standard.

To save a project under another name:

File > Save As.

The project file is saved in the location you choose. If the World contains textures or sounds, 
they are copied to a texture and/or sound folder in the same location as the project file.

To open an existing project:

Choose File > Open, or press CTRL+O, or click Open ( ) on the standard toolbar.

To close a project:

Open another project or exit AXEL.

To exit AXEL:

Choose File > Exit.
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Managing Project Files
The directory in which you save your project becomes the project directory. When you add 
textures and sounds to your World, two folders, Textures and Sounds, are created in the project 
directory, and texture and sound files are copied into those folders. Texture and sound files are 
linked to the project using relative paths, so that you can move the project directory without 
breaking the links. 

If you have several projects in the same directory, the Sounds and Textures folders will contain 
the files used by all the projects. If you want to move one project, use the Save As command; 
when you save a project in a different directory, AXEL automatically creates Textures and 
Sounds folders in the new location and copies the relevant texture and sound files into that 
folder.

The current project directory appears in the title bar, above the menus.

Note: When you publish your work, a stream file and an HTML file are created. These files are also 
stored in the project directory. For more information, see “Web Integration” on page 245.

To move a project file:

1. Open the file in AXEL, then choose File > Save As.

2. Navigate to the location where you want to save the file, and click Save.
The following files and folders are copied to the new location:

• Project file (.axel)

• Texture folder containing the textures used in the saved project

• Sound folder containing the sounds used in the saved project

• A default host web page (projectname.htm) required for web publishing
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Importing Objects into AXEL
Importing VRML (Virtual Reality Modeling Language) models allows you to create 3D models 
in another application and bring them into AXEL to add interactivity or simply publish the 
models. The models must be polygonal and exported as VRML 97.

AXEL imports lights. It imports only one camera, so if your VRML file contains more than one, 
the one selected under initial WebCam view in the VRML file is the one that will be loaded. 
FOV and position are correctly imported, but interest distance, and Near and Far clipping planes 
are not. The default AXEL values will be applied. If you do not see anything in WebCam view, 
select the WebCam, make it visible, and press F to frame the selection in top view.

When importing materials and textures, note the following:

• Only BMP, JPEG, and GIF files are supported for image textures. If your VRML file refers 
to other types of textures, you can convert them to a supported format and edit the VRML 
file accordingly. 

• Since the AXEL default texture mode is multiply, textures are blended into their material. If 
you want a texture to appear at 100% value, select the surface and edit its material to pure 
white.

For more information on using materials and textures in AXEL, see “Visualization” on page 
129.

Merging AXEL Projects
Merging projects is useful when you want to reuse objects between projects.

To merge AXEL projects:

Choose File > Merge, then select the file whose objects you want to use.

The objects from the merged project appear in the World Explorer and viewports.

Note: Object names can be repeated.
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Automatic Backups
When you work on an existing project, AXEL makes a backup of the project file the first time 
you save it in a working session. That way, you can always revert to the project as it was when 
you started working on it in that session.

When you first create a file and save it, AXEL does not make a backup. When you re-open an 
existing project, AXEL creates a backup the first time you save your changes. If you continue 
to work on the file, the backup is not updated each time you save it. This allows you to revert to 
the project as it was when you first opened it. The backup is only updated after you close the 
project, re-open it, and save it for the first time in the next working session.

Example: Using backups

1. Create a project, save it as MyProject.axel, then save it several times as you work.
Your project directory contains the file MyProject.axel. There is no backup.

2. To close MyProject, open another project or exit AXEL.

3. Re-open MyProject, modify the objects, and save the file.
AXEL creates a backup of the project that you opened, without the most recent changes. It 
then saves MyProject.axel with the changes. Your project directory now contains the files 
MyProject_backup.axel, and MyProject.axel. 

4. Continue working on MyProject.axel, and save the project frequently. 
Saving the project does not overwrite the backup. To revert to the project as it was when you 
first opened it, you can open the backup.

5. Close MyProject. To close it, open another project or exit AXEL.

6. Re-open MyProject, modify the objects, and save the file.
AXEL updates MyProject_backup.axel. The backup is now a copy of the project that you just 
opened, without the most recent changes. It then saves MyProject.axel with the changes.
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Customizing the Work Area
The default AXEL work area contains all the tools needed to model, animate, add interaction, 
and publish 3D content. You can show, hide, and resize different components according to what 
you are working on and your personal preferences.

When you first launch AXEL, the following work area appears. 

To show or hide a window:

Choose View > Windows, then turn the window on or off. You can also hide a window by 
clicking the X in the corner of the window.

To show or hide a toolbar or the status bar:

Choose View > Toolbars, then turn the toolbar or status bar on or off. 

Menu bar Toolbars Viewports World Explorer

Parameter Editor Sequencer Interaction EditorStatus bar
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To move a window:

Click and drag the window handle bar.

To float a docked window:

Drag the window handle bar so the outline of the window is no longer close to the edge of the 
screen. To ensure the window does not become docked by accident, hold down the CTRL key 
before releasing the mouse button.

To dock a floating window:

Double-click the window title bar or click and drag the title bar to the approximate docking 
position. When you release the cursor, the window snaps into place.

To resize windows:

Click and drag the borders between windows to resize them horizontally or vertically.

From Author to Browse Mode
When you create a 3D World, you are in Author mode. You can switch to Browse mode to 
preview your World and test the interaction as if you were viewing the content via the Internet. 
To modify the World, switch back to Author mode.

To switch between Browse and Author modes:

Click the Browse button ( ) or the Author ( ) button or press CTRL+B.

In WebCam view the World appears as if it were published. The other windows turn dark grey 
to indicate you are in Browse mode.
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Viewports 
You create a 3D World in the viewports. By default, there are four viewports, each one showing 
the 3D World from a different angle. In the Top, Front, and Right viewports, you see the World 
from the top, front, and right. In the WebCam viewport, you see the World through a WebCam. 
By moving the WebCam, you can look at the World from any angle. 

Note: You can also display a host web page in a viewport. For more information, see Chapter 8, “Web 
Integration.”

The Front, Right, and Top viewports display construction views, also known as orthogonal 
views, where you can precisely manipulate objects. The WebCam viewport displays objects as 
if seen through a WebCam, which is how they will appear once they are published in a web page.

The viewport in which you are working is the active viewport. You can distinguish an active 
viewport by its green label.

Usually you create objects in the construction views and then use WebCam view to look at them 
from different angles. This is not unlike a movie set: when all the props are in place, you can 
move the camera into position and choose the best angle.

Orthogonal view WebCam view
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Navigating in a 3D World
The easiest way to navigate in the 3D World is by using navigation buttons and hot keys in the 
WebCam viewport. 

Note: You can also use the WebCam parameters to control what is displayed in the WebCam viewport 
and in the published content. For example, you can make the WebCam follow an object, adjust its 
viewing frustum, or animate any of its parameters. For more information, see “WebCams” on page 151.

To navigate in a 3D World:

Click a navigation button, or hold a camera hot key, and click and drag the mouse in the 
WebCam viewport. To show the camera toolbar, choose View > Toolbars > Camera.

Tip: To remember the hot keys, note that the three World navigation hot keys are together at the lower 
left of your keyboard.

Panning and Zooming in Construction Viewports
You can zoom or pan in the Front, Top, and Right viewports to move around the construction 
view or zoom in to inspect details. This does not affect the WebCam or what appears in WebCam 
view.

To zoom or pan in the Top, Right, and Front viewports:

Click a camera button or hold a navigation hot key and click and drag the mouse in the 
viewport.To show the camera toolbar, choose View > Toolbars > Camera Toolbar.

Z Zooms in and out of the World.

X Pans left, right, up and down.

C Orbits around the center of the World.

Z Zooms in and out of the World.

X Pans left, right, up, and down.
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Changing the Viewpoint
The viewpoint determines what part of the 3D World is framed in a viewport. 

To adjust the viewpoint in all the viewports at once, use the View menu. To change the viewpoint 
in one viewport, right-click the viewport and use the context menu that appears.

To change the viewpoint:

Choose View > Viewpoint, or right-click a viewport and choose Viewpoint, then choose one of 
the following options:

Note: When you choose Frame Selection, WebCams that are selected and whose Visibility is on are also 
framed in the Top, Front, and Right viewports.

Changing the View in a Viewport
All four viewports can display construction views or WebCam views.

To change the view in a viewport:

Right-click the viewport, choose View, then choose a view from the context menu.

Note: You can also display a web page in a viewport. For more information, see Chapter 8, “Web 
Integration.”

Frame Selection F (one viewport)
SHIFT+F (all viewports)

The selected object(s) fill the viewport(s).
If the selection includes a WebCam, and the 
WebCam’s visibility is on, then the Web-
Cam is also framed in the construction 
views.

Frame All A (one viewport)
SHIFT+A (all viewports)

All objects are visible in the viewport(s).

Look at Selection The selected object is in the center of the 
viewport(s).

Look at Origin The center of the World is in the center of 
the viewport(s).

Reset Viewpoint Q (one viewport)
SHIFT + Q (all viewports)

The viewport(s) are reset to their default 
viewpoint. Reset Viewpoint in WebCam 
view resets the WebCam parameters to 
their default values.
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Switching to Single View
You can work in four viewports, the default layout, or enlarge one viewport to full size.

To switch a viewport to single view:

Do one of the following:

• Select the viewport, then choose View > Single View.

• Right-click the viewport, then choose Single View from the context menu.

• Select the viewport, then press ALT+1.

Note: Use the same commands to switch back to a multi-view layout.

Setting Display Options
Use display options to display additional object information in a viewport. For example, turn on 
Points to display the points on objects.

The options in the View menu affect all four viewports. Right-clicking a viewport brings up a 
context menu with the same options, but only the selected viewport is affected. 

To change the display options:

Right-click a viewport, or choose View > Display, then choose a display option.

Points Shows the points (blue squares) of the selected surface.

Constraints Shows blue lines between objects that have relations.

Clipbox Shows the clip box icon. For more information, see “Clipping” on page 159.

Stats Indicates time and refresh rate.

Selection 
Only

Hides everything but the selected object. To show all objects, choose this 
option again to turn it off. 
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Choosing Wireframe or Shade Mode
You can display objects in wireframe or shade mode.

The options in the View menu affect all four viewports. Right-clicking a viewport brings up a 
context menu with the same options, but only the selected viewport is affected. You can also set 
a specific WebCam to display either a shade or wireframe view of the World.

To set all viewports to wireframe or shade mode:

Choose View > Wireframe or press SHIFT+W.

To set one viewport to wireframe or shade mode:

Right-click the viewport and choose Wireframe or press W.

To set a WebCam to wireframe or shade mode:

In the World Explorer, select the WebCam, then turn on/off Shade in the Parameter Editor. For 
more information, see “WebCams” on page 151.
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Setting the Viewport Background Color
You can set the background color for the World. In the construction views, the background color 
affects your work area. In WebCam view, the background color also affects the published 
content.

The options in the View menu affect all four viewports. Right-clicking a viewport brings up a 
context menu with the same options, but only the selected viewport is affected.

Note: You can also publish your World with no background. For more information, see “Publishing 
Windowless Content” on page 249.

To change the background color:

• Choose View > Background Color or right-click a viewport and choose Background Color, 
then select a color from the Color Editor that appears.

• In the World Explorer, select the WebCam and then set its background color in the Parameter 
Editor. To set the color, enter an RGB color value, or click the color chip and select a color 
from the Color Editor that appears. You can enter a color value in decimal or hexadecimal 
format. For example, to set the color to red, enter 255 0 0 or FF0000; for cyan 
enter 0 255 255 or 00FFFF.
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Using a Grid
By default, a grid is displayed to help position and align objects. The center of the grid passes 
through the origin of the World. You can show or hide the grid, and change the grid spacing. You 
can make objects snap to the grid when you translate them. This makes it easier to position and 
align objects.

To adjust the grid in all the viewports at once, use the View menu. To change the grid in one 
viewport, right-click the viewport and use the context menu that appears.

To show or hide the grid:

Choose View > Grid or press SHIFT+G.

To show or hide the grid in one viewport:

Right-click the viewport and choose Grid or select the viewport and press G.

To change the grid spacing:

1. Choose View > Grid Size or right-click the viewport and choose Grid Size.

2. Choose the grid line/units ratio: 2:1 means there are two grid lines every unit, 1:1 means there 
is one grid line every unit. 1:2 means there is one grid line every two units, and so on.

To turn on Snap to Grid:

Choose View > Snap to Grid or press SHIFT+H.

When you translate objects, they snap to points at 1/5 of the smallest grid spacing. For example, 
if the grid spacing in one viewport is 1:1, when you translate an object, it snaps to points that are 
1/5 unit apart. If the grid size is 1:5, the object snaps to points that are one unit apart. 
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Menus
The menus correspond to a typical AXEL workflow and each menu contains the commands you 
need in that stage of the workflow.

File Menu
The file menu contains standard file management commands.

Use: To:
New (CTRL+N) Start a new World.

Open (CTRL+O) Open an existing World.

Save (CTRL+S) Save the current World in a .axel project file.

Save As Save the current World with a new name.

Merge Bring objects, animations, materials, an so on, from a 
previously saved World into the current World.

Import Import VRML objects into the current World. 

Recent Projects Open one of the projects you worked on recently.

Exit Close the current World and exit AXEL.
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Edit Menu
The Edit menu contains standard editing commands.

Use: To:
Undo (CTRL+Z) Undo the last action. You can undo up to 50 actions.

Redo (CTRL+Y) Redo the last action that you undid.

Delete (DEL) Delete the current selection. 

Copy (CTRL+C) Copy the selected parameter to the clipboard.

Paste (CTRL+V) Paste the value on the clipboard into the selected parameter. 

Duplicate Create a copy of the selected object (s). The duplicate is offset from 
the original object.

Instance Create a clone of the selected object(s). If you change the geometry 
parameters of either the original or the instance, both objects 
change. The instance is offset from the original object.

Select All Select all the visible objects in the World.

Unselect All Unselect all objects.

Unhide All Make all objects and groups visible.

ZWEB_UG.book  Page 31  Wednesday, April 18, 2001  1:51 PM



32 Chapter 2

View Menu 
Use the View menu to control what appears in all four viewports. For more information, see 
“Viewports” on page 23.

Note: The same commands appear when you right-click a viewport but they only affect that viewport.

Use: To:
Viewpoint Determine what portion of the World appears in the viewports. 

Display Determine what information is displayed in the viewports. 

Single View (ALT+1) Toggle the work area between one viewport (Single View) and 
four viewports. 

Background Color Open the Color Editor to select a background color.

Wireframe (SHIFT+W) Toggle between Wireframe mode and Shade mode.

Grid (SHIFT+G) Show or hide the grid.

Grid Size Determine the spacing of the grid lines in units. 

Snap to Grid Translate objects with precision. The spacing between the snap 
points is 1/5 of the grid line spacing.

Anti-aliasing Display anti-aliasing for objects whose anti-aliasing parameter is 
turned on. See “About Anti-Aliasing” on page 258.

Clipping Activate the clip box. See “Clipping” on page 159.

Windows Show/hide the World Explorer (ALT+3), Sequencer (ALT+4), In-
teraction Editor (ALT+5), or Parameter Editor (ALT+6).

Toolbars Show/hide the toolbars or the status bar.
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Modeling Menu
The Modeling menu contains the commands for creating and modifying 3D objects. For more 
information, see Chapter 3, “Modeling.”

Use: To:
Preset Curves Create preset 2D shapes. 

Draw Curve Draw a curve of any shape. 

Modify Curve Edit a curve. 

Preset Surfaces Create preset 3D shapes. 

Create Surface Create a 3D shape from a curve. 

Draw Polygon Draw a polygon surface. 

Modify Surface Edit a 3D shape. 

Text Create 3D text and 2D text overlays. 

Limbs Create 1-bone and 2-bone limbs. 

Skin Attach the selected surface(s) to the selected limb.

Bend Deform the selected surface. 

Interactive Push Deform an object by clicking and dragging in a viewport. For the 
push to work, the object must have more than one subdivision.
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Relations Menu
Use the Relations menu to group objects and attach them together with constraints. For more 
information, see Chapter 4, “Relations.”

Use: To:
Pose Constraint Tie the position, orientation, and scale of an object or group 

to another object’s position, orientation, and scale values.

Direction Constraint Make one object or group point at another object.

Distance Constraint Make an object or group stay at a certain distance from an-
other object.

Snap Make an object or group snap to another object’s position.

Spring Attach an object or group to another object so that when you 
pull them apart, they bounce back toward each other as if 
they were attached by a spring. 

Object to Curve Attach an object or group to a curve.

Bounding Constraints Constrain an object or group to stay inside or outside a se-
lected box or sphere.

Joint Constraints Attach an object or group to another object using a pin joint, 
a ball joint, or a slider joint.

Group Group selected objects or groups.

Add to Group Add an object or group to another group.

Remove from Group Remove an object or group from another group.

Ungroup Remove objects or sub-groups from a group and delete the 
group.
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Visualization Menu
Use the Visualization menu to add materials, textures, and lights. For more information, see 
Chapter 5, “Visualization.”

Use: To:
Add Material Add a material to the World and apply it to the selected surface(s). 

If no surface is selected, the material is only added to the World and 
listed in World Explorer / Resources / Materials.

Edit Material Color Change the color of the selected material(s).

Link Material 
(CTRL+L)

Link the selected material to the selected surface(s).

Unlink Material 
(CTRL+U)

Unlink the selected material and surface(s).

Edit Point Color Change the color of a surface at selected points. 

Add Texture Add a texture to the World and apply it to the selected surface(s). If 
no surface is selected, the texture is added only to the World and 
listed in World Explorer / Resources / Textures. 

Texture Projection Add a planar or cylindrical texture projector to the selected surface. 

Link Texture 
(CTRL+L)

Link the selected texture to selected materials or surfaces.

Unlink Texture 
(CTRL+U)

Unlink the selected texture and materials or surfaces.

Add Light Add a point, spot, or directional light to the World. 

Add WebCam Add a WebCam to the World.

Add ClipBox Add a clip box to limit what is visible when the World is published.

Hardware 
Acceleration

Use your system hardware to render graphics on your screen. If this 
option is off, the graphics are rendered by AXEL.
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Animation Menu
Use the Animation menu to create and modify animation. For more information, see Chapter 6, 
“Animation.”

Use: To:
Add Animation Sequence Create an animation sequence for the selected parameter(s), 

or active manipulation tool. 

Add Key Add a key at the current time, on the selected animation se-
quence(s). 

Path Animation Creates a preset animation to animate an object along a path. 
First select the object, then the path.

Wave Animation Add a wave deformation to the selected object. 

Add Particles Make the selected object(s) emit particles. 

Link Particle Obstacle Make an object an obstacle to the flow of particles. First se-
lect the object, then select the particle animation. 

Unlink Particle Obstacle Make the particles ignore the selected object. First select the 
object, then select the particle animation. 

Mix Shapes Change the shape of an object using two other objects re-
ferred to as deformers. The object and the deformers should 
have different shapes but the same number of points. When 
you move the object towards a deformer, it takes on the 
shape of the deformer.
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Interaction Menu
Use the Interaction menu to create interactions. For more information, see Chapter 7, 
“Interaction.”

Use: To:
Handles Quickly link predefined reactions to standard sensors. 

Reactions Create a reaction.

Sensors Create a sensor.

Link Reaction Link the selected reaction(s) to the selected sensor.

Unlink Reaction Unlink selected reactions and sensors.

Unlink Reaction from All Unlink the selected reaction(s) from any sensor to which it is 
linked.

Group Reactions Group reactions to make it easier to link them to the same sen-
sor.

Add Reaction to Group Add a reaction to a group of reactions. First select the group, 
then the reaction.

Remove Reaction from 
Group

Remove a reaction from a group of reactions. First select the 
group, then the reaction.

Ungroup Reactions Ungroup reactions.
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Web Integration Menu
Use the Web Integration menu to publish your work. For more information, see “Web 
Integration” on page 245.

Use: To:
Publishing Settings Specify the name of the published files, adjust the settings 

of the 3D window, and publish the World.

Publish Publish the World using the current publishing settings.

View Source Host Web 
Page

Display the HTML code of the host web page in a text editor.

Download Time Estimates Display estimates of the time it will take for surfers to down-
load the current 3D World.

Download Simulation Preview the downloading of the current 3D World.

Export Parameter Export the selected parameters so that surfers can modify 
the parameter in the published web page.

Export Reaction Trigger Export a trigger for the selected reaction so that surfers can 
launch the reaction by clicking a button in the published web 
page.

Preview in IE Open the current host web page in Internet Explorer®.

Preview in Netscape Open the current host web page in Netscape®.

Preview in ... Open the current host web page in a browser.

Batch Publish Publish a batch of stream files listed in a text file.
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Help Menu
Use the Help menu to learn AXEL and to find answers to your questions.

Use: To:

On-line Help Consult the user guide on-line. 

Jump Start Learn the basics of AXEL.

About AXEL Find out which version of AXEL you are running.

MindAvenue Support Access AXEL FAQs and other resources on the MindAvenue 
web site.
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Toolbars
The toolbars at the top of the work area provide quick access to frequently used commands. You 
can show or hide toolbars.

To show /hide a toolbar:

Choose View > Toolbars and turn on/off the toolbar.

To show /hide a set of toolbars:

1. Choose View > Toolbars and select the toolbars to include in the set.

2. In the same menu, turn on/off All Selected Toolbars or press ALT+2.
The following toolbars are available.

Standard Toolbar

Author/Browse Toolbar and Hot Keys

Opens an existing AXEL 3D World.

Saves the current World.

Copies the selected key(s) or parameter (s).

Pastes the last key(s) or parameter (s) you copied.

Press CTRL+B Switches to Author mode, where you create all your content, edit 
values, create relations, animations and set interactions.

Press CTRL+B Switches to Browse mode, where you preview the World as it will 
appear on the Internet. In Browse mode, you can interact with the 
World in the WebCam viewport, but you cannot modify it.
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Manipulation Toolbar and Hot Keys

Time Toolbar

Playback Toolbar

Press 3 (Object), 
4 (Point) or 
5 (Center)

Determines what you want to select or manipulate.

Hold S Selects objects in the viewports.

Press E Selects and scales the selected object(s).

Press R Selects and rotates the selected object(s).

Press T Selects and translates the selected object(s).

Hold CTRL Locks or unlocks all the constraints.

Sets the current time.

Sets the start time of your World. 

Sets the end time of your World.

Go to start time.

Rewind.

Starts/Stops playback.

Loops playback.

Fast forward.

Go to end time.
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Animation Toolbar

Status Bar 
The status bar at the bottom of the work area provides feedback on the World.

Records keys.

Previous key.

Next key.
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World Explorer
Use the World Explorer to select any object in your World. You can also use it to rename objects 
or edit parameters. The World Explorer presents a hierarchical list of all the components in your 
World including objects, sensors, reactions, constraints, animation and so on. 

The icons make it easy to identify the different types of objects. For example, a green circle ( ) 
next to a parameter indicates that it can be edited or animated, an orange circle ( ) indicates 
that it cannot.

The Resources bank at the bottom of the World Explorer lists all the intelligent effects associated 
with the objects in your World.

To expand or collapse items in the World Explorer:

Click the plus sign (+) next to an item to expand it; click the minus (-) sign to collapse it. You 
can also double-click an item to expand or collapse it.

To edit a parameter or rename an object in the World Explorer:

1. Click the parameter or object’s name twice. 
The first time you click it, it is selected; the second time, it becomes a highlighted text box 
that you can edit.

2. Type a new value or name and press ENTER.
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To select an item in the World Explorer:

Click the item. 

Tip: To avoid accidentally renaming items or changing values in the World Explorer, use the icons to 
select or expand objects, and use the names to rename objects or change values.

Click here twice to rename it.

Click here to select the parameter. 

Click here to select the sphere.

Click here twice to change its value.
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Parameter Editor
When you select an object, group, animation sequence, or any other item in the World, its 
parameters appear in the Parameter Editor. Use the fields, sliders, and lists in the Parameter 
Editor to edit the selected item. 

Some parameters are grouped into categories, which are underlined in the Parameter Editor.

To expand a category in the Parameter Editor:

Click the underlined item.

To view a higher level category:

Click the Up icon. ( )

To pin the Parameter Editor:

Click the Pin icon. ( )

Up
Pin 

Click to expand
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This prevents the Parameter Editor from changing when you select another object or parameter.

To display an object’s parameters in the Parameter Editor:

Select the object.

Note: You can select objects or constraints in the viewports, select sensors, reactions, or triggers in the 
Interaction Editor, select animation sequences or keys in the Sequencer, or select any item in the World 
Explorer. The corresponding parameters will appear in the Parameter Editor.
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Sequencer
The Sequencer displays a graphical view of the animation and interaction in your World. You 
can view and edit animation sequences, keys, and animation curves. You can drag the playhead 
to change the current time, or click and drag single keys or whole animations. For more 
information, see Chapter 6, “Animation.”

Zoom bar Scroll bar

Playhead

Animation curvesKeys

Animation 
sequences
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Interaction Editor
The Interaction Editor provides a schematic view of interactions. You can filter the information 
that is displayed by right-clicking the Interaction Editor and choosing an option from the menu 
that appears. For more information, see Chapter 7, “Interaction.”
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M o d e l i n g

In AXEL, you build models out of surfaces. You can 
use preset surfaces such as spheres and cubes; you 
can extrude surfaces from curves, draw polygon 
surfaces, or create revolution surfaces from curves. 

You can also use limbs to create a bone structure 
based on inverse or forward kinematics, then link 
surfaces to the limbs like skin on bones.

You can include 2D and 3D text in your Worlds.

To practice modeling in AXEL, refer to Lesson 1, 
“The Plane,” Lesson 8, “Mr. Cactus,” and Lesson 11, 
“Modeling the Fish” in the AXEL Tutorials.

In this chapter:

Selections and 
Manipulations  50

Instancing and Duplicating  61

Drawing Curves  62

Modifying Curves  69

Creating Surfaces  73

Modifying Surfaces  85

Modeling Characters  92

Text  98
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Selections and Manipulations
Objects must be selected before they can be modified, animated, linked, and so on. You can 
select objects in the World Explorer or in the viewports.

Manipulations are the three common operations used to modify objects: translation, rotation, 
and scaling. You can manipulate objects, points, and centers. You select a tool mode to specify 
what type of data you want to manipulated.

Selecting a Tool Mode
You can manipulate objects, points, and object centers by dragging them in a viewport. To 
indicate whether you want to drag an object, point, or the object’s center, you must select a tool 
mode. The selection is highlighted in orange. In the following illustration, six points are 
translated in Point mode to change the shape of the vase. 

To select a tool mode:

Do one of the following:

• In the toolbar, select a mode from the list.

• Press one of the following hot keys:

3 Object mode

4 Point mode

5 Center mode

Selected points

Mode list
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Selecting Objects, Points, Centers
You can select objects in the viewports or the World Explorer. Selected objects are highlighted 
in the viewports and the World Explorer. When you select a single object, its parameters appear 
in the Parameter Editor. Points and centers can only be selected in the viewports. Parameters can 
only be selected in the World Explorer or Parameter Editor.

To select objects in the viewports:

1. Select Object from the Mode list.

2. Turn on one of the Selection and Manipulation tools. 

3. To select a single object, click it or drag a rectangular marquee around it. 

4. To multi-select objects, SHIFT-click each one or drag a rectangular marquee around them.
As long as part of the object is inside the marquee, the object is selected.

5. To add objects to the selection, hold SHIFT and drag a rectangular marquee on the object that 
you want to add.

6. To remove objects from the selection, hold CTRL and drag a rectangular marquee on the 
objects that you want to remove from the selection. The CTRL key toggles the selection.

To select objects using the World Explorer:

1. Click an object to select it. 

2. SHIFT-click objects to add them to the selection.

3. CTRL-click selected objects to remove them from the selection.
Selected objects are highlighted in the viewports and in the World Explorer.

Selection and manipulation toolsMode list

Selecting the cup Selecting the cup and saucer
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To select nothing:

Do one of the following:

• Turn on one of the Select and Manipulation tools and click an empty part of a viewport.

• Hold S and click an empty part of a viewport.

• Choose Edit > Unselect All.

To select all the objects in our World:

Choose Edit > Select All.

To select points on an object:

1. In Object mode, select the object.

2. Switch to Point mode: press 4 or select Point from the Mode list.

3. Turn on one of the Select and Manipulation tools, or press and hold the S hot key. 

4. Drag a rectangular marquee around the point(s) you want to select. 
The points are highlighted.

5. To select more points, hold SHIFT and drag a rectangular marquee around the points you want 
to add to the selection.

6. To remove points from the selection, hold CTRL and drag a rectangular marquee on the points 
that you want to remove from the selection.

To select a group in the Viewports:

1. Select an object in the group.

2. Hold ALT and click the object again.
The group is selected.

3. If the group is nested in another group, hold ALT and click the object again to select the larger 
group, and so on.
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Manipulation Tools, Shortcuts, and Tips
The following tools and shortcuts that make it easy to manipulate objects and points:

Manipulation Hot Keys

Manipulations along Local Axes

You can manipulate an object along its local axes by holding SHIFT and using one of the mouse 
buttons:

Nudge Arrows
Press an ARROW key to nudge objects 4 pixels in the direction of the arrow. To nudge in smaller 
increments, zoom in. To nudge in larger increments, zoom out.

Snap to Grid
When translating, turn on Snap to Grid to make it easier to align objects. Objects snap to points 
that are at 1/5 of the grid spacing.

To snap to a grid:

Choose View > Snap to Grid.

Manipulation Cursors
To manipulate objects the edge of the object must be inside the square next to the cursor. To 
manipulate points, one of the points must be inside the square next to the cursor.

E Scale

R Rotate

T Translate

Left button Manipulates along the object’s X axis

Middle button Manipulates along the object’s Y axis

Right button Manipulates along the object’s Z axis
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Showing or Hiding Objects
It is often useful to hide objects while working on other objects. 

To show (or hide) an object in the viewports:
Select the object, then turn on (or off) its Visibility in the Parameter Editor.

To hide a group of objects:

1. Multi-select the objects.

2. Choose Relations > Group to place them in a group.

3. Turn off the group’s Visibility in the Parameter Editor.
For more information on groups, see “Using Groups” on page 126.

To show all the objects in your World:

Choose Edit > Unhide All.

Manipulating Parameters
If the manipulation tool is not responding, a parameter could be selected in the World Explorer. 
If you select a parameter with an X Y Z value, when you click and drag in the viewports, the 
parameter is updated. To manipulate an object, you must first deselect the parameter in the 
World Explorer.

Turn off Visibility 
to hide objects
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Translating Objects
Use the Translate tool to move an object, point, or center. You can also move an item by 
changing its position coordinates in the Parameter Editor or World Explorer. Number values are 
in grid units.

By default, translation is viewport-based, that is, objects translate in the plane of the viewport in 
which you drag them. By holding the SHIFT key, you can translate objects along their local axes.

If there are several objects next to each other, it can be difficult to select and translate the right 
one. In this case, select the object in the World Explorer, then press and hold the T key while 
you click and drag the object in the viewport. Holding a manipulation hot key (E, R, or T) locks 
the selection so you cannot accidently select another object.

To translate objects using your mouse or stylus:

1. Switch to Object mode.

2. Press T or turn on the Translate ( ) button, and select the object(s) you want to modify.

3. Click and drag the object(s) in a viewport. To lock the selection, hold T while translating the 
object. 

4. To nudge the object, press the ARROW key. The object moves in 4-pixel increments.

5. To translate an object along its local axes hold SHIFT and use one of the appropriate mouse 
buttons:

To translate an object using precise position coordinates:

Do one of the following:

• In the World Explorer, select the object then in the Parameter Editor, enter new X Y Z values 
in the Position fields.

• In the World Explorer, expand the object, then click the Position parameters twice, and enter 
new X Y Z values in the Position field.

The object moves to its new position in the viewports.

SHIFT+left mouse button Translates in X

SHIFT+middle mouse button Translates in Y

SHIFT+right mouse button Translates in Z

Mode list
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Rotating Objects
Use the Rotate tool to turn an object around its center. You can also rotate an object by changing 
its Orientation parameters. Orientation values are in degrees.

By default, rotation is viewport-based, that is, objects rotate in the plane of the viewport in which 
you drag them. By holding the SHIFT key as you rotate the object, you can rotate the object 
around its local axes. 

If there are several objects next to each other, it can be difficult to select and rotate the right one. 
In this case, select the object in the World Explorer, then press and hold the R key while you 
click and drag the object in the viewport. Holding a manipulation hot key (E, R, or T) locks the 
selection.

To rotate an object in a viewport:

1. Press R or turn on the Rotate button ( ).

2. Click and drag the object in a viewport. To lock the selection, hold R while rotating the 
object.
It turns around its center, rotating in the plane of the viewport.

Rotating a cone in Front view Rotating a cone around its local 
Y axis in WebCam view
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To rotate an object around its local X, Y, or Z axes:

1. Turn on the Rotate button or press R.

2. Hold SHIFT and click and drag the object in any viewport using one of the three mouse 
buttons:

To rotate an object around its own X, Y, or Z axis using precise orientation coordinates:

Select the object, then adjust the Orientation field in the Parameter Editor.

The object turns around its local X, Y, and/or Z axis in the viewports.

To change an object’s center of rotation:

1. Press 5 to switch to Center mode.

2. Turn on Translate or press T, and then click and drag the object’s center in a viewport. 
The object’s center moves. 

3. Press 3 to switch back to Object mode and rotate the object.
It turns around its new center.

To change the orientation of an object’s X, Y, and Z axis:

1. Select the object.

2. Press 5 to switch to Center mode.

3. Turn on Rotate or press R, and then click and drag the center in a viewport.
The object’s axes rotate.

4. Press 3 to switch back to Object mode and rotate the object using the SHIFT key and the left, 
middle, and right mouse buttons.
It turns around its new axes.

SHIFT+left mouse button Rotates in X

SHIFT+middle mouse button Rotates in Y

SHIFT+right mouse button Rotates in Z
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Scaling Objects
Scaling squashes and stretches an object on all three axes. You can also scale an object by 
adjusting its Scale parameter. Scale values are multiples or fractions of the original size.

Objects are scaled along their own axes, from their geometric center. Translating the object’s 
center has no effect on scaling but if you rotate the object’s center, you can scale it in different 
directions.

If there are several objects next to each other, it can be difficult to select and scale the right one. 
In this case, select the object in the World Explorer, then press and hold the E key while you 
click and drag the object in the viewport. Holding a manipulation hot key (E, R, or T) locks the 
selection.

To scale an object:

Turn on the Scale button ( )or press E, then do one of the following

• To scale along three axes, click and drag the object in a viewport using the left mouse button. 
The object is scaled proportionally, that is, it stretches or shrinks along its X, Y, and Z axes.

• To scale along two axes, click and drag the object using the middle mouse button. The object 
is scaled in the plane of the viewport.

• To scale an object along one axis, hold SHIFT and drag the object using the left, middle or 
right mouse button:

To scale an object using precise values:

Select the object and adjust its Scale parameter in the Parameter Editor. 

The object is scaled along its local axes.

SHIFT+left mouse button Scales in X

SHIFT+middle mouse button Scales in Y

SHIFT+right mouse button Scales in Z
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To change the orientation of the scaling:

1. Select the object.

2. Press 5 to switch to Center mode.

3. Turn on Rotate or press R, and then click and drag in a viewport.
The object’s axes rotate.

4. Press 3 to switch back to Object mode and scale the object using the SHIFT key and the left, 
middle, and right mouse buttons.
The object scales along its new X, Y, and Z axes.

Example: Setting an Object’s Center
An object’s position is the position of its center. When you rotate an object, it pivots around its 
center. By moving the center, you can change the pivot point.

To move the center of the spinning top:

1. Press 5 to switch to Center mode.

2. Turn on Translate ( ) or press T and click and drag the center to the base of the spinning 
top.

A top pivoting around 
its geometric center

A top pivoting 
around its base
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Example: Translating in Different Tool Modes
In this example, use the Translate tool in Object mode to move a sphere, then switch to Point 
mode to deform the sphere, then switch to Center mode to move its center of rotation.

1. Choose Modeling > Preset Surfaces > Sphere. 
A sphere appears in the center of the World.

2. Switch to Object mode (select Object from the Mode list, or press 3).

3. Turn on the Translate button ( ) or press T, then click and drag the sphere.
The entire sphere moves.

4. Switch to Point mode (select Point from the Mode list or press 4).

5. Click and drag a rectangular marquee around several points on the sphere to select them.

6. Click and drag the points.
The sphere is deformed as you drag the points.

7. Switch to Object mode, turn on the Rotate tool, and drag the sphere to rotate it around its 
center.

8. Switch to Center mode, and translate the center of the sphere in a viewport.

9. Switch to Object mode, turn on the Rotate tool, and rotate the sphere around its new center.
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Instancing and Duplicating
There are two ways to create copies of an object: duplicating and instancing. 

Duplication makes a copy of the original object. It creates an entirely new object, copying 
geometry, materials and textures (not relations, animation, or interactions).

Instancing clones the original object, and the instance remains faithful to it. Any changes to an 
instance’s geometry, material, or texture will immediately be reflected on all instances and the 
original. Manipulations (translation, rotation and scaling) are independent. For example, you 
could use instancing to create seats in a theater, where one can be instanced into many copies. 
When you change the shape of one seat, all the others are also updated.

Instancing also makes the AXEL project file much lighter, since it only has to load one object's 
geometry and give it many positions. This reduces download time but it does not improve the 
display speed, since the computer has to calculate the display for all objects on screen.

You can differentiate duplicates and instances by their icons in the World Explorer. Duplicates 
have the same icon as other objects, while instances have a double cone icon.

To duplicate an object:

Select the object, then choose Edit > Duplicate or press CTRL+D.

A duplicate appears in the World Explorer and in the viewports, where it is slightly offset from 
the original.

To create an instance of an object:
Select the object, then choose Edit > Instance or press CTRL+I.

An instance appears in the World Explorer and in the viewports, where it is slightly offset from 
the original. In the World Explorer, expand the instance. Notice it uses the geometry of the first 
object. When you modify a geometry parameter for either object, they both change. Similarly, 
if you switch to Point mode and move points on either object, the other one also changes. Notice 
that you can translate, rotate, or scale either object without affecting the other one.

Note: Selected points appear in orange on original objects and in red on instances.

Duplicates

Instances
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Drawing Curves
Curves can serve as motion paths or you can use them to create surfaces. You can choose a preset 
curve or draw a curve of any shape. There are four preset curves in AXEL: Circle, Arc, 
Rectangle, and Square. The curves in AXEL are subdivision curves. Subdivision curves make 
it easy to create a smooth curve with very few points.

To draw a curve:

1. Choose Modeling > Preset Curves and choose a preset curve from the menu, or choose 
Modeling > Draw Curve. For more information, see “Creating a Square or Rectangle” on 
page 66, “Creating an Arc or a Circle” on page 67, “Drawing a Curve” on page 68.

2. Adjust the curve parameters in the Parameter Editor. Click Geometry in the Parameter Editor 
to access all the parameters. See “Curve Parameters” on page 64.

3. Modify the curve if needed. See “Modifying Curves” on page 69.

Motion path, revolution, and extrusion curves
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Example: Creating a rectangle

1. Choose Modeling > Preset Curves > Rectangle.
A rectangle appears in the center of the viewports and its parameters appear in the Parameter 
Editor.

2. You can translate, rotate, and scale the curve using the Manipulation tools or by adjusting its 
Position, Orientation, and Scale parameters. For example, to make the rectangle longer in X, 
change the Scale to 2, 1, 1.

3. Expand the Geometry parameters. You can also change the curve using its geometry 
parameters, for example, adjust the height of the rectangle.
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Curve Parameters
Some parameters are common to all curves, and others are specific to each type of curve.

To adjust a curve’s parameters:

1. Select the curve.

2. In the Parameter Editor, adjust the parameters, then click the curve geometry parameters to 
adjust the remaining parameters.

Common Curve parameters

Position Object location in x, y, z coordinates

Orientation Object rotation values in x, y, z degrees

Scale Object scaling values in x, y, z multiplication factors.

Visible Toggles object visibility.

Anti-aliasing Turns on anti-aliasing to removes the “jaggies” on diagonal lines by blur-
ring the curve. To see the anti-aliasing, it must be on for the object and 
the viewport. To turn it on for the viewport, right-click the viewport and 
choose Anti-aliasing. Anti-aliasing slows down the refresh rate.

Number of 
Points

The number of points that define the curve. When the curve is published 
in a web page, the points are downloaded and the AXEL player redraws 
the curve on the surfer’s web page. Increasing the number of points in-
creases download time.

Streamable Makes the curve streamable so that a surfer can open a page and view 
the World without this curve. The curve appears when all its information 
is dowloaded.

Steps Adds steps between vertices to make the curve smoother without adding 
points. See “Modifying Curves” on page 69.

Point positions The X, Y, Z coordinates of each point.

Click to expand
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Rectangle- and Square-Specific Parameters

Circle- and Arc-Specific Parameters

Draw Curve-Specific Parameters

Frozen Hides the curve geometry parameters.
A curve freezes if you add, move, or delete points, subdivide or simplify 
it.
When the curve is frozen, AXEL draws the curve based on its points, not 
its width and height parameters. If you turn off Frozen, the curve is re-
drawn based on its width and height, and any points you modified move 
back to their original position.

Width Size in units along the X axis.

Height Size in units along the Y axis.

Closed Draws a segment between the end points to join them together.

Frozen Hides the curve geometry parameters.
A curve freezes if you add, move, or delete points, subdivide or simplify 
it.
When the curve is frozen, AXEL draws the curve based on its points, not 
its radius parameter. If you turn off Frozen, the curve is redrawn based 
on its radius, and any points you modified move back to their original po-
sition.

Radius Size in units.

Subdivisions Adds points to the circle.

Angle Determines the angle of the arc. A circle has an angle of 360 degrees.

Closed Joins the first and last point in a curve to create a closed shape.
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Creating a Square or Rectangle
Since a square is a rectangle with equal sides, you can create either one and adjust its size to 
make it into a square or a rectangle. When you need a symmetrical curve, draw a rectangle then 
subdivide it.

To create a square or rectangle:

1. Choose Modeling > Preset Curves, then choose Square or Rectangle.
The curve appears in the center of the World and the curve parameters appear in the 
Parameter Editor.

2. Adjust the curve’s parameters. For more information, see “Curve Parameters” on page 64.
By adjusting the width and height, you can change the rectangle into a square and vice-versa.

SquareRectangle

Click to expand
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Creating an Arc or a Circle
Since a circle is a 360-degree arc, you can create either one and adjust its angle to make it into 
an arc or a circle.

To create an arc or circle:

1. Choose Modeling > Preset Curves, then choose Circle or Arc.
The curve appears in the center of the World and the curve parameters appear in the 
Parameter Editor.

2. Expand the Geometry parameters.
A circle is closed and its angle is 360. An arc is open and its angle is less than 360. By 
adjusting the Closed and Angle parameters, you can change a circle into an arc and vice-
versa.

Click to expand
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Drawing a Curve
You can draw a curve of any shape using points in the viewport.

To draw a curve:

1. Choose Modeling > Draw Curve, or press and hold L.

2. Click in a viewport to draw the first point in the curve. Click again to add a second point and 
so on until you have drawn the approximate shape of your curve.

Tip: To draw straight lines, choose View > Snap to Grid.

3. To draw an open curve, press ESC or, to close the curve, press END. Press ESC once to 
continue drawing another curve. Press ESC twice to exit drawing mode.
The points are connected by lines. 

Tip: To draw a closed path for an animation cycle where an object loops around the curve, use the End 
key to close the curve. If you close the curve by clicking the first point, the curve will not be closed.

4. To create a smoother curve, click CurveGeometry in the Parameter Editor, and increase the 
Steps. Steps is an integer from 1 to 10.
Increasing Steps adds points which are not editable and does not increase the weight of the 
object. In the Geometry parameters, notice that the number of points does not increase when 
you increase Steps.The following illustration shows the original curve and various 
increments of Steps.

Tip: When drawing paths, you should draw curves with as few points as possible. By limiting the 
number of points, you obtain a smoother curve that is easy to edit and animate. When drawing a curve 
to create a polygon, revolution, or extrusion surface, draw as many points as needed to obtain the contour 
you want because the curve steps are not taken into account when the surface is generated from the curve.
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Modifying Curves
After you create a curve, you can modify it in several ways. You can edit the points on the curve, 
open or close it, make it smoother, change its direction, or rationalize its position and scaling 
values. You can also scale, rotate, and/or translate a curve. For more information, see 
“Translating Objects” on page 55.

About Smoothness
There are several ways to make a curve smoother: increasing steps, adding points, or 
subdividing the curve. 

Increasing steps breaks the segments between points making the curve look smoother without 
increasing its weight. 

Adding points is an easy way to refine the shape of the curve. You can add more points where 
you want the curve to be round, and have fewer points where the curve is straight. Remember, 
the more points, the longer it takes to download. 

Subdividing a curve adds a point between every two points. It makes the curve rounder from 
start to finish but significantly increases the number of points on the curve. 

Steps = 0 Steps = 1 Steps = 2

Two points added Five points addedOriginal curve

Subdivided once Subdivided twiceOriginal curve
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Editing Points on a Curve
You can add, delete, and move points on a curve. You can also subdivide a curve to add a point 
between every two points. 

To add points to a curve:

1. Select the curve in Object mode.

2. Choose Modeling > Modify Curve > Add Point or press INSERT.

3. In the viewport, click where you want to add a point.
A point is added to the closest segment of the selected curve.

4. Click and drag to add a point and adjust its location.

5. To add another point, click again.

6. To stop adding points, press ESC.

To delete points from a curve:

1. Select the curve in Object mode.

2. Press 4 to switch to Point mode, select the points you want to delete, and press DELETE.
The curve is redrawn based on the remaining points.

To move points on a curve:

1. Select the curve in Object mode.

2. Press 4 to switch to Point mode.

3. Select the points you want to move.

4. Press T or turn on the Translate button, place your cursor over one of the selected points, then 
click and drag the points. To make sure the points remain selected when you translate them, 
select the points, then press and hold the Translate hot key (T) while you drag the points in 
the viewport.
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Increasing Steps
Steps make a curve smoother without adding points. 

To increase or decrease the steps of a curve:

1. Select the curve.

2. In the World Explorer or Parameter Editor, set the Steps to a value between 1 and 10.

Subdividing a Curve
Subdividing adds a point between the points on a curve. 

To subdivide a curve:

Select the curve and choose Modeling > Modify Curve > Subdivide.

This creates one additional point between every two existing ones on the curve.

Simplifying a Curve
Simplify a curve to remove points.

To simplify a curve:

Select the curve and choose Modeling > Modify Curve > Simplify.
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Closing a Curve
A curve can be open or closed.

To close a curve:

Select the curve and do one of the following:

• Choose Modeling > Modify Curve > Close.

• In the World Explorer, select the curve’s geometry and then in the Parameter Editor, turn on 
Closed.

• To close the curve while you are drawing it, press END.

The curve’s start and end points are joined to close the curve.

Inverting a Curve

Inverting a curve reverses the beginning and end of a curve. For example, if an object on a path 
animation is going clockwise along a circle, inverting the circle makes the object go counter-
clockwise.

To invert a curve:

Select the curve and choose Modeling > Modify Surface > Invert.

Rationalizing Scale and Pose of a Curve
To make the current shape of a curve the starting point for subsequent scaling operations, you 
rationalize its scaling. To move an object’s center to the center of the World and make its current 
position, scale, and orientation the starting point for subsequent manipulations, you rationalize 
its pose. 

To rationalize the scale of a curve:

In Object mode, select the curve and choose Modeling > Modify Curve > Rationalize Scale.

The curve's Scale parameter is reset to 1, 1, 1 but the curve's size does not change.

To rationalize the position of a curve:

In Object mode, select the curve and choose Modeling > Modify Curve > Rationalize Pose.

The curve's center moves to the center of the World. Its position and orientation values are reset 
to 0,0,0. Its scale is reset to 1,1,1, but the curve’s appearance does not change.
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Creating Surfaces
In AXEL, you can use preset surfaces or generate 3D surfaces from 2D curves. 

Preset surfaces, also known as primitives, are standard geometric shapes, such as spheres, 
rectangles, cones, and cylinders. Many objects can be modeled from preset surfaces. You can 
resize, move, and rotate them, or manipulate points on the surfaces to create different shapes.

The methods for generating 3D objects from curves mimic real-life methods: 

• Creating a polygon surface is like weaving, where you make a contour shape, then weave a 
mesh over the contour. 

• Revolution is similar to a woodworker's lathe, where a piece of wood is set spinning around 
an axis and then a sharp cutting surface carves out a shape, like a baseball bat. 

• Extrusion is a common industrial process where a mold is created in the shape of the desired 
part and then the material is pushed (or extruded) through. The result is like the original shape 
with adjustable depth. 

When you create a revolution or an extrusion, a relation is maintained between the curve and the 
surface, so that when you edit the curve, the surface is updated to reflect those changes. When 
you create a polygon surface, it is independent from the original curve. 

Surface Parameters
All surfaces have the following parameters, which appear in the World Explorer and the 
Parameter Editor when you create the surface. Some are common to all surfaces, others apply 
only to specific surfaces.
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Common Surface Parameters

Position Distance from the center of the World in units, along the X, Y, Z axes.

Orientation Orientation in degrees around the X, Y, Z axes.

Scale Scaling values in X, Y, Z. Scale is a multiplication factor.

Visible Toggles surface visibility.

Anti-aliasing Toggles anti-aliasing on/off for the selected surface. It blurs the edge of 
the object to removes the “jaggies”.
To be visible, anti-aliasing must be on for the viewport and the object. 
To turn on anti-aliasing for the viewport, right-click the viewport and 
choose Anti-aliasing. Anti-aliasing slows down the refresh rate. For more 
information, see “Controlling Performance and Download Time” on page 
258.

Number of 
points

Number of points that define the surface. When the surface is published 
in a web page, the points are downloaded and the AXEL player redraws 
the surface on the surfer’s web page. Increasing the number of points 
increases download time.

Point positions The X Y Z coordinates of every point on the surface.

Streamable Enables web streaming for the surface after it is published to the web. If 
you turn on Streamable, select a streaming priority. For more information 
on streaming, see “Controlling Performance and Download Time” on 
page 258.

Single sided Displays only the outer face of surfaces. To see both faces, turn off Sin-
gle-sided. Turning on Single-sided increases the display speed since 
AXEL has to draw only one side of the surface. 

Single-sided on Single-sided off
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Smoothness Since polygonal surfaces are not smooth, but a collection of flat planes, 
smoothness creates an illusion of surface roundness. The sphere on the 
left shows the true appearance of a polygonal surface, where all the fac-
ets are visible. The same sphere on the right, with smoothness enabled, 
creates the illusion of a round surface.

Crease control Use crease control for surfaces that have both hard edges and round sur-
faces, for example, a table top with smooth corners. If you turn on 
smoothness without crease control, all the angles are rounded. Turn on 
crease control to disable smoothness for sharp angles. 

Crease angle Defines minimum angle for smoothness to take effect. For example, if 
you use a low crease angle threshold such as 10, facets will be visible if 
the angle between 2 faces is higher than 10 degrees. A higher crease an-
gle threshold such as the default 60 degrees will smooth all but the 
sharpest angles.

Coloring Determines how color is applied to a surface. You apply color per vertex, 
per face, or to the entire surface. For more information, see “Creating 
Gradients with Per Vertex Coloring” on page 133.

Frozen Hides the surface geometry parameters. In addition, if a revolution or ex-
trusion surface is frozen, it is no longer linked to the curve from which it 
was generated; changing the curve does not change the surface. 
A surface freezes if you add, move, or delete points, subdivide it, or sim-
plify. It also freezes if you set the coloring to Per vertex or it or Per face, 
or edit texture coordinates.
When the surface is frozen, AXEL draws the surface based on its points, 
not its parameters. If you turn off Frozen, the surface is redrawn, and any 
points you modified move back to their original position, and edited point 
colors revert to the material color.

Smoothness off

Smoothness on, crease control off

Smoothness and crease control on
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Creating Preset Surfaces
Preset surfaces are available for six commonly used shapes: sphere, cube, cylinder, cone, 
vertical plane, and horizontal plane.

To create a preset surface:

1. Choose Modeling > Preset Surfaces, then select the type of surface you want to create.
The surface appears in the center of the World.

2. Translate, scale, or rotate the surface as needed.

3. In the Parameter Editor, adjust its parameters. For information on common parameters, see 
“Surface Parameters” on page 73. The following tables describe the parameters that are 
specific to the type of surface you are creating.

Sphere Geometry Parameters

Radius Determines the size of the sphere.

Subdivisions A low number of subdivisions creates a very boxy shape (and a light mod-
el), whereas a high number of subdivisions creates a much smoother 
model (thus more points).
The horizontal subdivisions define the number of facets in longitude; the 
results will be most apparent in top view.
The vertical subdivisions define the number of facets in latitude; the re-
sults will be most apparent in front or right view.

Radius
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Cube Geometry Parameters

Cone Geometry Parameters

Width The size of the cube along the X axis.

Height The size of the cube along the Y axis.

Depth The size of the cube along the Z axis.

Height Determines the height of the cone.

Width Determines the diameter of the cone at its base.

Subdivisions A low number of subdivisions creates a very boxy shape (and a light mod-
el), whereas a high number of subdivisions creates a much smoother 
model (thus more points).
The horizontal subdivisions define the number of facets in longitude; the 
results will be most apparent in top view.
The vertical subdivisions define the number of facets in latitude; the re-
sults will be most apparent in front or right view.

Height

Width
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Cylinder Geometry Parameters

Plane Geometry Parameters (Horizontal and Vertical)

Height Height of the cylinder.

Width Diameter of the cylinder.

Top capping Closes the top of the cylinder.

End capping Closes the bottom of the cylinder.

Horizontal 
subdivisions

Number of facets along the cylinder’s circumference. A low 
number of subdivisions creates a boxy shape, whereas a high 
number of subdivisions creates a smoother model. Increasing 
subdivisions increases the weight of the model.

Vertical 
subdivisions

Number of facets on the cylinder’s Y axis. Increasing vertical 
subdivisions is useful if you want to bend the cylinder. 

Subdivisions The number of subdivisions along each axis. Increasing the number of 
subdivisions is useful if you plan to deform the plane or to improve the 
lighting on the surface. For more information, see “Lights” on page 145.

Increasing horizontal subdivisions

Increasing vertical subdivisions
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Creating a Polygon Surface
You can draw a polygon surface or create it from an existing curve.

To draw a polygon:

1. Choose Modeling > Draw Polygon.

2. In a viewport, click points to define the corners of the polygon.

3. Press ESC to close the polygon and continue drawing polygons, or press ESC twice to exit 
Draw Polygon mode.

4. Adjust the polygon’s surface parameters in the Parameter Editor.

5. To change the shape of the polygon, press 4 to switch to Point mode, then manipulate its 
points.

To create a polygon from a curve: 

1. Draw a curve, and adjust its shape.

Note: The Steps parameter is not taken into account by the polygon surface conversion. To soften the 
curve, instead of increasing the steps, subdivide the curve or add points individually.

2. With the curve selected, choose Modeling > Create Surface > Polygon from Curve.

3. If the curve is not coplanar, you are prompted to confirm that you want to convert it to a 
surface. Click OK.
The curve is filled to create a surface.

Tip: If you cannot see the surface, press W to toggle between Wireframe and Shade mode, orbit in 
WebCam view, or turn off Single-sided in the Mesh Surface Geometry Parameters.

4. In the Parameter Editor, adjust the polygon’s surface parameters. See “Surface Parameters” 
on page 73.

5. To change the shape of the surface, press 4 to switch to Point mode, then manipulate the 
points on the surface.
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Creating a Revolution Surface
Revolution spins a curve around an axis to create a 3D surface. 

By default, the curve revolves around a vertical axis that passes through the origin of the World 
(position 0,0,0). The distance between the curve and the origin determines the thickness of the 
revolution. For example, if you draw the outline of a wine glass 5 units away from the World 
origin, you end up with a large vat, with a wine glass outline.

To create a surface by revolution:

1. Draw a curve close to the World origin.

2. Adjust the curve keeping the following in mind:

• AXEL does not use the curve’s steps parameter in the creation of the surface, so a smooth 
curve does not create a smooth revolution.

• You can refine the curve after you create the revolution since the curve remains linked to 
the revolution. 

• You can add points to the original curve to make the revolution surface smoother.

3. With the curve selected, choose Modeling > Create Surface > Revolution from Curve.
A revolution surface appears.

4. Select the revolution and translate, scale, or rotate it as needed.

5. To change its shape, modify its original contour curve.

6. In the Parameter Editor, adjust the revolution parameters. 

Note: For information on common surface parameters, see “Surface Parameters” on page 73. 
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Revolution Parameters 

Origin Position of the center of the revolution. By default the origin of the rev-
olution is the origin of the World origin (0, 0, 0). 

Revolution 
axis

Axis around which the surface revolves. The default revolution axis de-
pends on where you draw the curve. If you draw the curve in front or 
right view, it revolves around the Y axis (0 1 0); in top view, it revolves 
around the Z axis (0 0 1). 

Subdivisions Number of facets of the revolved shape. Increasing subdivisions increas-
es the smoothness of the surface as well as its weight.

Angle The number of degrees of revolution. 

Top capping Closes the top of the surface.

End capping Closes the bottom of the surface.

Surface 
closing

If the angle is less than 360, turning on Surface closing connects the 
edges of the revolution.

Angle=360 Angle=240
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Creating Extrusion Surfaces
Extrusion pushes a 2D curve along an axis to create a 3D Surface. The axis is a line coming out 
of the viewport in which you draw the curve. For example, if you draw a curve in top view and 
extrude it, it is extruded along the Y axis. 

To create a surface by extrusion:

1. Draw a curve.

2. Adjust the curve keeping the following in mind:

• AXEL does not use the curve’s steps parameter in the creation of the surface, so a smooth 
curve does not create a smooth extrusion.

• You can refine the curve after you create the extrusion since the curve remains linked to the 
extrusion.

• You can add points to the original curve to make the revolution surface smoother.

3. With the curve selected, choose Modeling > Create Surface > Extrusion from Curve.
An extrusion surface appears in the viewports and the World Explorer.

4. Select the extrusion and translate, scale, or rotate it as needed.

5. To change its shape, modify its contour curve.

6. In the Parameter Editor, adjust the extrusion parameters. 

Note: For information on common surface parameters, see “Surface Parameters” on page 73.
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Extrusion Parameters

Roll angle 
(start/end)

Creates a twisting extrusion. The first value is the start angle (in degrees) 
and the second, the end angle. The following illustration has a start of 0 
and an end of 90 degrees. This could be useful for modeling an ice cream 
cone or a woodscrew.

Scaling 
(start/ end)

Tapers the extrusion. The first value is the start scale (ranging from 0 to 
1) and the second the end scale. The following illustration has a start of 
1 and an end of 0.25

Subdivisions Number of subdivisions along the length of the extrusion. The default val-
ue is 1. If you intend to bend, push, or skin the surface, you should in-
crease the number of subdivisions.

Length Length of the extrusion. The default length is 1 unit.

Top capping Closes the top of the extrusion.

End capping Closes the bottom of the extrusion. 
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Extrusion Along Curve
Extrusion along a curve pushes one 2D curve along another 2D curve to create a 3D surface. 

To create a an extrusion along a curve:

1. Choose Modeling > Draw Curve or hold L, and draw the contour curve. Press END to close 
the curve.

2. Choose Modeling > Draw Curve or hold L, and draw the path for the extrusion. Press END 
to close the curve or press ESC twice to end the curve without closing it and exit draw curve 
mode.

3. Multi-select the contour curve then the path curve, in that order. To multi-select objects, 
SHIFT-click each one. The order is important. The first object is the cross-section, the second 
is the path.

4. Choose Modeling > Create Surface > Extrusion along Curve.
The extrusion is created.

5. To modify the extrusion, modify the curves used to create it, and/or adjust the extrusion 
parameters in the Parameter Editor. See “Extrusion Parameters” on page 83.
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Modifying Surfaces
Use the Modify Surface menu to edit surfaces. You can also change surface parameters, copy 
parameters from one surface to another, or move points on a surface to change its shape. 

By default, the appearance of a surface is based on its surface parameters. By adjusting the 
parameters, you change the surface. However, if you modify points on the surface, the following 
geometric parameters are frozen:

• Number of subdivisions

• Height

• Width

• Radius of presets

In addition, for extrusions and revolutions, the surface is no longer linked to the curve from 
which it was generated. Instead, you control the shape of the surface by manipulating its points. 
To enable the parameters and the curves again, you can un-freeze the surface; the surface is 
redrawn based on its parameters and any new or moved points are ignored. Edited vertex colors 
or texture coordinates are also ignored.

Manipulating Points
You can modify surfaces by manipulating its points. You can add points by subdividing the 
surface. Subdividing adds geometry to the surface without modifying its shape. All polygons are 
divided. Subdividing can create a smoother deformation, or give the surface a smoother 
appearance under light sources.

To subdivide a surface:

Select the surface and choose Modeling > Modify Surface > Subdivide.
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To subdivide selected faces:

In Point mode, select the points that define the faces you want to subdivide, then choose 
Modeling > Modify Surface > Subdivide.

To delete points from a surface:

1. In Object mode (press 3) select the surface.

2. Switch to Point mode (press 4), select the points to delete, and press DELETE.

To manipulate points on a surface:

1. In Object mode (press 3) select the surface.

2. Switch to Point mode (press 4), and select the points you want to manipulate.

3. Turn on the Translate, Scale, or Rotate button and drag the points in the viewport. 

Tip: To avoid deselecting the points while you manipulate them, lock the selection. To do so, hold the 
manipulation hot key (E, R, or T) while dragging the points in the viewport.

To simplify a surface:
In Object mode, select the surface, then choose Modeling > Modify Surface > Simplify.

20% of all points are removed.

Selected points Subdivided faces
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Inverting Surface Normals
Surfaces, created or imported, are single-sided and have no thickness. You decide which side of 
the surface is exposed to light. For example, a cube can be used as a box, when seen from the 
outside, or a room, when seen from the inside. To create a room with 4 walls, a ceiling, and a 
floor, you could move the WebCam inside a cube and invert its surface.

In the following illustration, on the left, you see the inside of the glass wall. On the right, the 
glass was inverted, so that you see the outside of the glass wall. By inverting a surface, you 
indicate which side of the surface you want to look at.

To invert a surface:

Select the surface and choose Modeling > Modify Surface > Invert.

The surface normals are inverted.

Rationalizing a Surface’s Scale
To make the current shape of a surface the starting point for subsequent scaling operations, you 
rationalize its scaling. To move an object’s center to the center of the World and make its current 
position, scale, and orientation the starting point for subsequent manipulations, you rationalize 
its pose. 

To rationalize the scale of a surface:

In Object mode, select the surface and choose Modeling > Modify Surface > Rationalize Scale.

The surface’s scale parameter is reset to 1, 1, 1 but the surface size does not change.
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Rationalizing a Surface’s Pose
Rationalize Pose resets the surface’s manipulation values (translation, rotation, scaling) back to 
default values and moves the surface's center to the origin of the World.

Example: Rationalizing the pose of a cube

1. Choose Modeling > Preset Surfaces > Cube.

2. To translate the cube 5 units along the X axis, press T, hold SHIFT and drag the cube using 
the left mouse button.
In the Parameter Editor, notice the position of the cube.

3. Rotate the cube in front view. 
Notice how it turns around its center.

4. With the cube still selected, choose Modeling > Modify Surface > Rationalize Pose.
The cube does not move but its center moves to the origin of the World. Notice its position 
value is now 0, 0, 0. When you rotate the cube, it turns around the World origin.
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Copying Parameters
You can copy similar parameters from one object to another. For example, you can copy the 
position parameters of one surface and paste them in the position parameters of another.

To copy parameters:

1. In the World Explorer, select the parameters that you want to copy then click them again or 
press F2.
The parameter values are highlighted.

2. To copy the values, choose Edit > Copy or press CTRL+C, or click the Copy icon ( ) in 
the Standard toolbar.

3. Select the parameter to which you want to paste the value. Click it again or press F2 to edit 
the parameters.

4. To paste the values, choose Edit > Paste, or press CTRL+V, or click the Paste icon in the 
toolbar ( ), then press ENTER.
The parameter is set to the value that you copied.
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Bending Surfaces
You can bend a surface around a specific axis by a certain number of degrees. You can then 
adjust or animate the bend parameters.

Note: You can also let surfers bend objects interactively. For more information, see “Bend Handle” on 
page 235.

To bend an object with precision:

1. Select the object.

2. Choose Modeling > Bend.
A bend deformation appears under the object in the World Explorer.

3. Adjust the bend parameters.

Bend Parameters
The following parameters define the bend.

Active Turns the bend deformation on or off.

Origin Center of the bend's angle and region. By default, it is the sur-
face's center. For example, if you bend a 10-unit high cylinder, 
setting the bend origin to 
0 -5 0 starts the bend from the base of the cylinder instead of the 
middle.

Axis Axis that the object bends around. By default, objects bend 
around the Z axis (0, 0, 1).

Angle Angle of the bend, in degrees.

Minimum angle Smallest amount you can bend the surface. 

Maximum Bend 
Region Limit

Angle Origin

Minimum Bend 
Region Limit
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Using Interactive Push
Use Interactive Push to poke a surface and model it like clay. In the following illustration a 
sphere is reshaped by pushing in its upper-left area.

Note: You can also let surfers push objects interactively. For more information, see “Push Handle” on 
page 234.

To push a surface:

1. Select the surface.

2. Press 4 to switch to Point mode.

3. Choose Modeling > Interactive Push or press Y, then click and drag the surface in any 
viewport.

Maximum angle Largest amount you can bend the surface. Minimum and maxi-
mum angles are useful when you add a sensor to the bend param-
eter.

Minimum bend region Number (in units) away from the origin that the bend takes effect.

Maximum bend 
region

Number (in units) away from the origin that the bend stops taking 
effect.
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Modeling Characters
You build a skeleton out of 1-bone and 2-bone limbs, then use surfaces for the outer skin. When 
you animate the limbs, the skin moves and bends with the bones.

To practice creating characters in AXEL, refer to lesson 7, “Snowman” and lesson 8, “Mr. 
Cactus” in the AXEL Tutorials.

About Inverse and Forward Kinematics
By creating limbs, you can use inverse kinematics (IK) and forward kinematics (FK) to animate 
characters.

Inverse kinematics allow you to create a simple bone structure, for instance, a leg (with the 
femur and shinbone), and it calculates the rotation values of both bones as you translate the shin 
around. What this means is that you can simply select the shin and drag it around and inverse 
kinematics will update the position and orientation of both bones for you.

With forward kinematics, rotation values of different limbs are keyed, so limbs are being 
animated in a more traditional sense, which allows a larger degree of control. In IK, the rotation 
of angles and shape of the limbs is being decided for you as you manipulate the last bone, 
whereas in FK, you decide the exact rotation of each limb yourself. It is therefore more labor-
intensive, but you can still use the power of a bone structure to deform and animate surfaces.

It should also be noted that some types of bone structures, like the spine, bend in ways that IK 
does not really account for, so FK is sometimes the best way to go.
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1 Bone Limbs
A 1 Bone Limb is a group containing a freely rotating bone constrained to a socket. The bone 
socket is similar to a shoulder or hip joint. 

When you translate the bone, it remains constrained to the socket. You can move the bone 
around in the socket, but you cannot pull it out of the socket, or move the socket by pulling on 
the bone. To move the socket and the bone, you translate the limb group.

The bone uses a ball joint constraint. You can set rotation limits on the bone by editing the 
constraint parameters.

You can animate the bone by saving keys or applying a path animation. You can scale bones with 
the Scaling tool or by editing the bone’s scale parameter.

You can apply constraints to the limb group and to individual bones; you can also add them to 
groups.

Limb1 Parameters

Ball joint home angle Angle at which the limb is at rest. This angle is the starting point 
for limb rotation.

Mode Manipulation mode. Select IK to animate the character by manip-
ulating the bone. Select FK to animate the character by manipu-
lating the socket. Select Home state to adjust the joint’s home 
angle. 
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2 Bone Limbs
A 2 Bone Limb creates a pair of bones, like the previously illustrated leg example, where the 
socket is the hip, the first bone the femur and the second bone the shin.

The first bone is constrained to the socket with a ball joint constraint. Like an arm in a shoulder 
joint, the bone can rotate freely inside the socket.

The second bone is constrained to the first bone with a pin joint constraint. It rotates only in a 
hinge-like way around the end of the first bone. Like a shin in a knee joint, the bone can bend 
backwards, but not sideways or forward.

You can move the whole group by selecting the limb, or translate the second bone to take 
advantage of IK.

You can edit the parameters of the first bone, including the ball joint constraint parameters, and 
the second bone, including the pin point constraint parameters.

By default, the limb bends downwards. To make it bend in another direction, you rotate the 
whole limb group. In the following illustration, a limb was rotated 180 degrees on the X axis so 
that it could bend inwards.

Ball joint 
constraint Bone 1 Pin joint Bone 2

ZWEB_UG.book  Page 94  Wednesday, April 18, 2001  1:51 PM



Modeling 95

Limb 2 Parameters

Using Home State
Think of the home state as the position where your character feels comfortable. Each limb has 
a home state, that is, a joint angle where it feels comfortable. You can set the home state for one 
limb at a time, or for the entire character. You can then go to the home state to reset the character 
in a position that is a good starting point to add skin or create animation.

To set the home state for one limb:

1. Select the limb.

2. In the Parameter Editor, set the mode to Home State, then adjust the home angles.

3. To continue manipulating the limb, set the mode to IK or FK.

To set the home state for several limbs at once:

1. Manipulate the limbs into the positions that you want to use as the character’s home state.

2. Choose Modeling > Modify Limbs > Reset Home State.
The character’s current position becomes its home state. For each limb, the current angle 
becomes the new home angle.

To move limbs into their home state:

Select the limbs and choose Modeling > Modify Limbs > Go to Home State.

The limbs move into the position you defined as their home state.

Ball joint home 
angles

Angle at which the first bone is at rest. This angle is the starting point 
for limb rotation.

Pin joint home 
angles

Angle at which the second bone is at rest. 

Mode Manipulation mode. Select IK to animate the character by manipulating 
the bone. Select FK to animate the character by manipulating the socket. 
select Home state to adjust the joints’ home angles.
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Skin
Use the Skin command to deform a surface or a group of surfaces using other surfaces or limbs. 
For example, you can create a character with various surfaces and then create a group of 
deforming surfaces, which you could animate to make the character walk, talk and smile.

Example: Using skin

1. Create a sphere. Choose Modeling > Preset Surfaces > Sphere. 

2. Scale the sphere to 5 times its original size on all three axes. 

3. Create a cone, a cube, and a cylinder and place them inside the sphere.

4. In the World Explorer, first Select the sphere, then SHIFT-select the cube, the cone and the 
cylinder.
The first surface selected will be the skin and the others will be the deformers. 

Note: To deform several surfaces at the same time, for example, a foot, a sock and a shoe, you must 
group them, then select the group, and then Shift-select all the deformers. You can also create a second 
group containing all the deformers.

5. Choose Modeling > Skin. 
A Skin deformation appears under the sphere in the World Explorer.

6. Select any of the three deformers and scale, rotate and translate them. 
Notice how the sphere is deformed. Each vertex of the sphere follows the closest deformers 
according to a weighting proportional to their distance from each of the deformers. It follows 
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the center of the deformer objects; the size of the objects is not important. In the following 
illustration, the top part of the sphere is mainly affected by the cone.

Note: To remove the deformation, delete the Skin in the World Explorer, then adjust the sphere 
parameters in the Parameter Editor. The sphere is redrawn based on its geometry parameter settings. 
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Text
You can create two kinds of text: text surfaces and text overlay. Text surfaces are like other 3D 
surfaces that you can translate, scale, and rotate in 3D space. Text overlay is like movie titles 
placed in front of the 3D World.

Creating Text Surfaces
A text surface is like any other 3D surface except that its shape is not defined by points; instead, 
it is based on a font. See “Selecting Fonts” on page 104. You can translate, scale, or rotate a text 
surface, animate its parameters, include it in relations, animation, and interaction, but you 
cannot edit its points or change its shape using push or bend tools.

To create a text surface:

1. Choose Modeling > Text.

2. Enter the text in the Text Entry dialog that appears, then click OK.
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3. Select a font and a font style in the Font dialog that appears, then click OK.

Note: The size of the text is determined by its Scale value, the font size is not important. 

The text appears in the center of the World and a text object appears in the World Explorer.

4. Adjust the text parameters in the Parameter Editor. See “Surface Text Parameters” on page 
100.

To adjust the size of a text surface:

Select the text object and do one of the following:

• Set its Scale parameter in the Parameter Editor.

• Turn on the Scale button or press E, then click and drag the text in a viewport. 

To adjust the thickness of a text surface:

1. Select the text object and expand the TextGeometry parameters.

2. In the Parameter Editor, turn on Extrude.

3. Scale the text along its Z axis. Press E to turn on the Scale tool, then SHIFT-drag the text using 
the right mouse button.
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To manipulate text:

Select the text object and do one of the following:

• Turn on the Scale, Rotate, or Translate button or press E, R, or T, then click and drag the text 
in the viewports. To avoid accidentally selecting another object, hold the E, R, or T key while 
dragging the text.

• Adjust the Position, Orientation, and Scale values in the Parameter Editor.

Surface Text Parameters

Position Determines the position of the text in 3D space.The center of a text ob-
ject is in the lower left corner of the first letter.

Orientation Determines the orientation of the text.

Scale Determines the size of the text. 

Visible Displays/hides the text in the viewports.

Anti-aliasing Makes the text outlines smoother. Also turn on anti-aliasing in the view-
port to see the effect.

Single sided Displays only one side of the object. Turn off Single sided to see the in-
side and the outside of the object.

Text The letters or words that appear in the World.

2D overlay Converts the text to 2D overlay. See “Creating Text Overlay” on page 
101.

Font name The font used to create the text.

Font style Sets the text to regular, italic, bold, or bold italic.

Extrude Extrudes the text to give it thickness. To adjust the thickness, scale the 
text along its Z axis.

Precision Determines how much the shape of the text can deviate from the original 
font shape. Increasing tolerance reduces the polygon count but it also re-
duces the quality of the text. Adjust the tolerance to get the right balance 
between quality and performance. 

Precision = 0 Precision = .01 Precision = .02
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Text Limitations
Because of current limitations, you cannot do the following to text objects:

• Manipulate the center of a text object.

• Deform text objects.

• Add Particle animation to text objects. 

• Add handles to text objects.

Tip: To add particles or handles to text, create a dummy object, constrain it to the text, add particles or 
a handle to the dummy, then turn off its visibility.

Creating Text Overlay
Text overlay is like a 2D layer of text in front of the 3D World. You can animate its position, 
size, and color. You can include it in relations, animation, and interaction, but you cannot rotate 
the text or move it on the Z axis; it is always in front of the 3D World.

To create text overlay:

1. Choose Modeling > Text.

2. Enter the text in the Text Entry dialog that appears, then click OK.

3. Select a font, font style, and size in the Font dialog that appears, then click OK.
The text appears in the center of the World.

4. In the Parameter Editor, expand TextGeometry, and turn on 2D Overlay.

5. The text moves to the lower left corner of the WebCam viewport.

6. Adjust the text GeometryParameters. See “2D Overlay Parameters” on page 103.

To adjust the size of text overlay:

1. Select the text object.

2. In the Parameter Editor, expand the TextGeometry parameters.

3. Adjust the Font size.
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To position text overlay relative to the viewport:

1. Select the text object.

2. In the Parameter Editor, expand the TextGeometry parameters.

3. Turn off Projected and set the 2D Position. 

If you resize the viewport, the text maintains it relative distance from the edge. For example, if 
you set the 2D Position to 50 50, the text always starts in the middle of the viewport, or in the 
middle of the browser window after it is published.

Notice when you orbit or zoom in WebCam view, the text does not move. Its position is relative 
to the viewport; it is independent of the 3D World.

To position the text overlay in front of a point in the 3D World:

1. Select the text object.

2. In the Parameter Editor, set the Position field to the X Y Z position above which you want 
the text to appear. 

3. Expand the TextGeometry parameters and turn on Projected.
The text appears in front of the X Y Z position that you specified. When you pan, orbit or 
zoom in WebCam view, the text moves so that it is always in front of the same point in the 
3D World. 

Tip: If you apply a pose constraint between the text and an object, the text will always appear in front of 
that object. 

2D Position = 50 50
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2D Overlay Parameters

Position Determines the point above which the text is projected if Projected is 
turned on. If Projected is turned Off, the Position parameter has no ef-
fect. The center of a text object is in the lower left corner of the first let-
ter.

Orientation Does not affect 2D Overlay text.

Scale Does not affect 2D Overlay text. To adjust the size of 2D Overlay text, 
adjust its Font Size.

Visible Displays/hides the text in the viewports.

Number of 
points

The number of points used to define text is always 0.

Anti-aliasing Makes the text outlines smoother. Also turn on anti-aliasing in the view-
port to see the effect. 

Text The letters or words that appear in the World.

2D overlay Converts the text to 2D overlay. Turn off 2D Overlay to create a 3D text 
surface. See “Creating Text Surfaces” on page 98.

Font name The font used to create the text.

Font style Sets the text to regular, italic, bold, or bold italic.

Font size Determines the size of the text.

Z depth Determines the text position relative to other 2D text objects. Reduce Z 
depth to move the text object to the front. Increase Z depth to place it 
behind other 2D text objects. 

Projected Places the text object in front of a specific point in the 3D World. This 
point is determined by the text object’s X Y Z position value. See “To 
position the text overlay in front of a point in the 3D World:” on page 
102.

2D position Positions the text object relative to the viewport. The first number is the 
distance from the left edge as a percentage of the size of the viewport. 
The second number is the distance from the lower edge as a percentage 
of the height of the viewport. When the content is published, the text 
will be at the same relative distance from the edges of the surfer’s 
browser window. This option is available only when Projected is turned 
off. 

Point positions There are no points for text.

High Z-Depth Low Z-Depth
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Selecting Fonts
The shape of the text is determined by its font. You can create text in any vector font available 
on your system (TrueType, OpenType, and so on.) but after you publish the content, surfers will 
only see the font if it is available on their system.
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R e l a t i o n s

Relations include constraints and groups.

Constraints provide a number of ways to manipulate 
objects using other objects and create intelligent 
links between them. 

Groups provide a way to organize objects and 
interaction. Grouping is practical for more elaborate 
creations.

To practice using relations in AXEL, refer to 
Lesson 4, “Clown and Pistol,” Lesson 5, 
“Pin, Ball, and Slider,” and Lesson 6, “Furniture” in 
the AXEL Tutorials.

In this chapter:

Using Constraints  106

Basic Constraints  110

Bounding Constraints  117

Joint Constraints  120

Using Groups  126
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Using Constraints
When two objects are linked by a constraint, one object is the leader and the other is the follower. 
The follower is attached to the leader and its motion is limited. The leader is free; when you 
move or rotate it, the follower tags along, more or less in step, depending on the type of 
constraint that links them. 

You can unlock constraints to adjust the position, orientation, or scaling of constrained objects.

Objects can have more than one constraint, and you can adjust the importance or weight of each 
constraint. You can create constraints between simple objects, objects and groups, or between 
groups. 
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Adding Constraints
The workflow for adding constraints between objects or groups is simple: multi-select the 
follower and the leader in that order, then choose the constraint.

To add a constraint to an object:

1. Select the object (the follower).

2. SHIFT-select the object that will constrain it (the leader). 

Note: The order is important: the first object selected will be the follower and the second will be the 
leader.

3. Click the Lock button so that it is unlocked.
This temporarily disables constraints. See “Unlocking Constraints” on page 108.

4. Choose a relation from the Relations menu.
The constraint appears in the World Explorer under the follower object.

5. Choose View> Display > Constraints to view the constraint in the viewports.

6. Select the constraint and adjust its parameters. To select the constraint, click the blue 
constraint icon in the viewport or select the constraint in the World Explorer or Parameter 
Editor.

7. Turn on Lock, and test the constraint.

8. To adjust the offset, turn off the Lock button, and adjust the objects or the constraint icon. 
When you are satisfied, turn the Lock button on again. 

Pose constraint
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Unlocking Constraints
By unlocking constraints, you can manipulate objects that are constrained to other objects. In 
other words, you can temporarily disable the constraints to modify their offsets.

In most cases you should unlock constraints before adding a new constraint to objects. 
Constraint parameters have default values that determine the offsets between the objects. If the 
Lock button is on, the default offsets are applied to the objects as soon as you add the constraints. 
For example, a spring constraint has a default rest length of 1 unit. When you add a spring 
constraint between a box and a Jack-in-a-Box, the Jack-in-a-Box will bounce around and stop 
at 1 unit from the box. If you want the Jack in a Box to end up in its original position, unlock 
constraints before adding the spring. This allows you to adjust the constraint offsets before they 
affect the objects.

To unlock constraints:

Turn on the Unlock button, or hold the U key while manipulating the constrained object.

Example: Unlocking a direction constraint

1. Create a cone and a cylinder and move them apart.

2. Multi-select the cone and the cylinder, in that order, then choose Relations > Direction 
Constraint.
A constraint is added to the cone. When you move either object, the cone rotates to stay 
aligned with the cylinder.

3. To display the constraint icon, choose View > Display > Constraints.

4. You want the cone’s tip to point at the cylinder. Turn on Rotate or press R and drag the cone. 
It does not move because its orientation is locked by the direction constraint.
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5. To unlock the constraint, turn on Unlock, or hold the U key , then drag the cone. 
The cone rotates.With constraints unlocked, you can adjust the offset. 

When you release the U key, or turn on the Lock button, the constraints are active again. Now 
when you translate either object, the cone rotates so that its tip is always pointing at the 
cylinder.

Using Weight to Control Multiple Constraints
The concept of weight applies when several relations affect one object. The weight of a 
constraint determines its strength compared to the other constraints.

For example, if a WebCam is constrained in direction to a sphere and a cube, they both affect its 
orientation equally and the WebCam points in the middle of two. If you increase the weight of 
the constraint to the sphere, the WebCam favors the sphere. If you increase the weight of the 
constraint to the cube, the WebCam favors the cube.
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Basic Constraints
The following basic constraints are available:

• Pose

• Direction

• Distance

• Snap

• Spring

• Object to Curve
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Pose Constraint
This relation constrains an object’s position, orientation, and scaling values (or any combination 
of the three) to another object. In the following illustration, the hammer clings to the magnet. 
When the magnet is moved, rotated and scaled, the hammer follows suit.

To apply a pose constraint:

1. Multi-select the follower object and then the leader object, in that order33.

2. Choose Relations > Pose Constraint.

3. Translate, scale, and/or rotate the leader. The follower’s position, orientation, and scale 
values are updated accordingly.

4. Select the constraint and adjust the constraint parameters in the Parameter Editor.

Note: By turning off the Lock button before choosing the pose constraint, you can maintain whatever 
differences exist between the 2 objects. Otherwise, the follower will immediately conform to the leader’s 
position, orientation, and scale values.

Pose Constraint Parameters

Active Toggles the constraint on and off. 

Weight Determines the weight of this constraint in relation to other con-
straints acting on the same object.

Constrain position Toggles the position constraint on and off. 

Constrain orientation Toggles the orientation constraint on and off.

Constrain scale Toggles scale constraint on and off. 

Position offset Offsets position in units (X,Y, Z). You can set offsets interactively 
by unlocking constraints then manipulating the follower object.

Orientation offset Offsets orientation in degrees along all three axes (X,Y, Z). 

Scaling offset Offsets scaling in all three axes (X,Y, Z). 
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Direction Constraint
This relation forces one object to continually point at another. The follower rotates so that one 
of its axes (by default, its X axis) is always aligned with the position of the leader.

For example, you can add this constraint between a WebCam and an object so that the WebCam 
always points at the object.

To apply a direction constraint:

1. Multi-select the follower (in this example the WebCam), and then the leader (the cone), in 
that order.

2. Choose Relations > Direction Constraint.
When you translate the leader, the follower continually rotates to point at the leader.

Direction Constraint Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of this constraint in relation to other con-
straints acting on the object.

Constrained direction Determines which of the follower’s axes is aligned with the lead-
er’s center. By default it is the X axis. You can set the axis inter-
actively by unlocking constraints and rotating the follower.

Cone constrained in its 
X direction (1 0 0). 

Cone constrained in its 
Y direction (0 1 0)
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Distance Constraint
This relation forces one object to continually maintain a certain distance from another. For 
example, if the cube has a distance constraint of 3 in relation to the sphere, no matter where you 
move the sphere, the cube will always be 3 units away.

Note: With a pose constraint, you can make one object rigidly follow another by a certain distance, but 
a distance constraint will make the object flop around while maintaining the chosen distance.

To apply a distance constraint:

1. Multi-select the follower and then the leader, in that order.

2. Choose Relations > Distance Constraint.
When you translate the leader, the follower moves around to maintain a specific distance 
from the leader. You can also translate the follower but it moves in such a way that it keeps 
the same distance from the leader.

3. By default the constrained distance is 1 unit. To change this distance, do one of the following:

• In the World Explorer or Parameter Editor, select the constraint under the follower object 
then change its Distance parameter.

• Turn off the Lock button to disable constraints, then translate the follower in the viewports. 
When it is at the desired distance from the leader, turn on the Lock button. Notice the 
Distance parameter is updated in the constraint parameters. 

Distance Constraint Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of this constraint in relation to other constraints 
acting on the object.

Distance Determines the distance in units separating the 2 objects.
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Snap Constraint
This relation creates a position and rotation connection between two (or more) objects. You can 
interactively manipulate the constrained object, but when you release the mouse, the object will 
reconnect to the leader object. You can choose the amount of time that the object takes to 
reconnect. An object can be connected to more than one object. When you translate the 
constrained object and release the mouse button, it snaps to the closest connecting object. This 
can be useful if you want the surfer to freely move an object and have it land safely somewhere 
when released.

To apply a snap constraint:

1. Multi-select the follower and then the target to which it will snap, in that order.

2. Choose Relations > Snap.

3. You can repeat the previous step with any number of targets.
Adding transition periods to the constraint will allow you to move the object around before 
it snaps back into position when released.

Snap Constraint Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of the constraint in relation to other constraints 
acting on the same object.

Constrained 
position

Determines the point of the object that will snap to the target. By default 
the constrained position is the center of the object. This allows you to off-
set that point (in X,Y, Z units). For example, if you are snapping a coffee 
cup to saucers, you could use the bottom of the cup as a constrained po-
sition so it would not go through the saucer.

Transition 
period

Time in seconds the object will take to snap back into position when re-
leased. Having a period of 0 will force the object to stay on its target. It 
will only move if the cursor is dragged close enough to another target.

(Target) 
Position

Determines an offset (in X,Y, Z units) from the actual target for the object 
to snap to.

(Target) 
Orientation

Allows you to modify the orientation of the object as it hits the target. 
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Spring Constraint
This relation creates a spring-like constraint between two objects. For example, if a sphere has 
a spring constraint linking it to a cube, and you pull the sphere away from the cube, it will spring 
back within a determined distance, bouncing around like a superball.

This relation creates an animated connection between two (or more) objects. You can control the 
length of the spring, the amount of the spring, as well as the tension (damping).

This is useful for creating interesting secondary animation.

To apply a spring constraint:

1. Multi-select the object that will be spring-constrained and then the second object, towards 
which it will bounce, in that order.

2. Choose Relations > Spring.

3. With Play turned on, select the constrained object and translate it. When released, it will 
bounce back towards the constraining object, flying off in all directions. When you 
manipulate the constraining object, the spring-constrained object will react to that 
movement, bouncing around.

Spring Constraint Parameters

Active Toggles the constraint on and off.

Rest length Determines the distance in units at which the object will come to rest. 
For example, if the rest length is 0, it will come to rest on the constrain-
ing object. If the rest length is 2, it will come to rest 2 units from the 
constraining object.

Springiness Determines the strength of the spring. A low value will make the object 
slowly spring back to its original position, whereas a higher value will 
make it zip back into place.

Resistance Attenuates the strength of the bouncing. A higher value will make the 
spring seem to be moving through molasses!
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Object to Curve
This relation constrains an object to a curve. This can be useful to guide objects through 3D 
space without banging into other objects. The distance tolerance allows latitude to make the 
constraint less obvious.

Tangency aligns the object with the curve.

To constrain an object to a curve:

1. Multi-select the object and then the curve that will serve as the path, in that order.

2. Choose Relations > Object to Curve.
When you translate the object, it moves along the path.

Object to Curve Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of this constraint in relation to others con-
straints on the same object.

Position 
parameter

Determines the object’s location along the curve in percentage 
(from 0 to 100).

Distance 
tolerance

Tolerance value in units by which the object can wander off the 
curve.

Enable tangency Aligns the object with the curve. 

Constrained 
tangency

Determines which axis of the object is tangent to the curve. By de-
fault (1, 0, 0) the X axis lines up with the curve.

Tangency Off Tangency On
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Bounding Constraints
Bounding constraints allow you to control whether objects can move through one another or not. 
For example, if you have a character walking, you may want to set a bounding constraint to 
ensure that his feet do not go through the floor. Another example is if you want an object to stay 
inside another, such as a fish in his bowl.

Bounding Box
This relation creates an invisible box within which the constrained object must remain. An 
object could therefore be moved by surfers but only within a certain area. For example, a surfer 
could move an object around but not off the screen.

This relation either keeps an object in a box or prevents it from going inside a box. In the 
following illustration, the jackhammer is constrained to a cube, which is made invisible. The 
jackhammer can move around freely but not exit the boundaries of the cube. An alternative is to 
inverse this box and make sure that an object does not enter a specific box. For instance, the 
jackhammer should not go through the ground.

As with all relations, first the constrained object is selected, and the second object becomes the 
bounding box. This bounding box can be translated, scaled, rotated, and animated.

To create a bounding box constraint:

1. Multi-select the object that you want to constrain and then an object to serve as a bounding 
box, in that order.

2. Choose Relations > Bounding Constraints > Box.

3. Scale the bounding box object to the desired dimension and toggle off its visibility.
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Bounding Box Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of this constraint in relation to others con-
straints acting on the same object.

Inside Constrains the object to stay inside the box. When Inside is turned 
off, the object cannot enter the box.

Geometry 
constrained

Uses the object’s outer geometry as limits when calculating the 
bounding box. When this option is on, a sphere appears around the 
constrained object, and it is the outer radius of the sphere that de-
termines when the object has reached its limit. When Geometry 
constrained is off, the object’s center serves as reference.

Geometry contained On Geometry contained Off
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Bounding Sphere
This relation is identical to bounding box but uses a sphere, determined by a radius. It creates an 
invisible sphere within which the selected object must remain. An object could therefore be 
moved around by users but only within a certain radius.

To create a bounding sphere constraint:

1. Multi-select the object that you want to constrain and then an object to serve as a bounding 
sphere, in that order. 

2. Choose Relations > Bounding Constraints > Sphere.

3. Scale the sphere to the appropriate size and toggle off its visibility.

Bounding Sphere Parameters

Active Toggles the constraint on and off. 

Weight Determines the weight of this constraint in relation to other con-
straints acting on the same object.

Inside Constrains the object to stay inside the sphere. If Inside is turned 
off, the object cannot enter the sphere.

Geometry constrained Uses the object's outer geometry as limits when calculating the 
bounding sphere. When this option is on, a sphere appears around 
the constrained object, and it is the outer radius of that sphere 
that determines when the object has reached its limit. When Ge-
ometry constrained is off, the object's center serves as a refer-
ence.
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Joint Constraints
Joint constraints provide a way of joining two objects together while still allowing either object 
to be manipulated individually.

Pin Joint
This relation creates a position and rotation connection between two objects that allows for 
rotation around a single axis. This type of joint is similar to a knee joint, or the hinge of a door.

It allows you to pivot one object around another.The object can pivot all the way around the joint 
or you can limit its freedom by setting angle limits. 

Another example of a pin joint is movie clapper or a cigarette lighter where the top cube is 
constrained to rotate around the bottom cube. If you move the bottom cube, the top will follow it.

Minimum angle

Maximum angle
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To apply a pin joint constraint:

1. Multi-select the object that will pivot and then the object to which it will be constrained, in 
that order.

2. If the objects are positioned correctly, turn off the Lock button to keep that offset.

3. Choose Relations > Joint Constraints > Pin.

4. Choose View > Display > Constraints. 
The constraint icon appears in the viewport. It is a blue cylinder representing the hinge-like 
pin joint.

5. Turn on the Lock button. 
When you translate the constrained object, it rotates around the hinge.

6. To change the position and direction of the hinge, translate and rotate the pin constraint. To 
select the pin constraint, click the blue constraint icon in the viewport, or select the constraint 
under the constrained object in the World Explorer.
When you translate the constrained object, it now rotates around the hinge, in its new position 
and axis.

Pin Joint Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of this constraint in relation to others con-
straints on the same object.

Position Determines the position of the hinge in X, Y, Z (in units).

Axis Determines the orientation of the hinge relative to the absolute X Y 
Z axes. By default the hinge rotates around the leader’s X axis. If 
the leader’s orientation is 0 0 0, then the pin’s axis is 1 0 0. You 
can set it to the Y axis (0 1 0) or Z axis (0 0 1), or you can rotate 
the constraint in the viewport, to change its axis.

Joint angle Displays the current angle of the follower object.

Enable angle limits  Sets minimum and maximum angle values, which determine how 
much the follower object can rotate.

Minimum angle
limit

Sets the minimum angle in degrees when Enable angle limits is 
turned on. 

Maximum angle 
limit

Sets the maximum angle in degrees when Enable angle limits is 
turned off. 
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Ball Joint Constraint
This relation creates a position and rotation connection between two objects that allows for 
rotation around all three axes. This type of joint is similar to an ankle joint, a universal joint, or 
a joystick. It allows one object to pivot freely around another. You can also limit the amount of 
freedom in a constraint by setting angle limits. For example, the joystick can pivot freely but it 
cannot move lower than its base.

Example: Applying a ball joint constraint

1. Create a sphere.

2. Create a cylinder, and set its height to 4 and a width to 1. 

3. Multi-select the cylinder and the sphere, in that order.

4. Choose Relations > Joint Constraints > Ball.

5. Choose View > Display > Constraints. 
A blue sphere appears to represent the ball joint.

6. Turn off the Lock button. This will enable you to offset the cylinder's position. Translate the 
cylinder up on the Y axis. 
To test the constraint, turn on the Lock button and translate the cylinder in all viewports. It is 
constrained to the sphere and can only rotate around the ball joint that you created. Translate 
the sphere to verify this. You could also select the ball joint and offset it if you wanted to 
change the actual rotation point.

7. Select the constraint and turn on Enable joint limits in the Parameter Editor. 

Maximum angle
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This will constrain the cylinder to move freely around a certain opening.

8. Adjust the maximum limit angle, and notice the opening in the ball joint widening or 
narrowing.

9. By default it is the X axis of the cylinder that is constrained. Change Constrained axis to 
0, 1, 0 (the Y axis). Translate the cylinder and notice how it moves freely within the opening 
you set with the Maximum limit angle.

Ball Joint Constraint Parameters

Active Toggles the constraint on and off.

Weight Determines the weight the constraint in relation to other con-
straints acting on the same object.

Position Determines the position in X, Y, Z (in units) of the ball joint, around 
which the object will rotate.

Joint angles Determines the current angle of the constrained object.

Enable joint limits Sets a maximum angle limit. Turning on this option displays the 
maximum angle value, which determines how much the con-
strained object can rotate, as well as its axis.

Constrained axis Chooses the axis of the object that the joint limit will affect. By 
default it is the X axis.

Maximum limit angle Sets the maximum angle in degrees.
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Slider Joint Constraint
This relation creates a connection between two objects. It limits the constrained object to move 
within a certain distance along a single axis.

This relation allows you to create a drawer-like constraint where one object can slide along an 
axis related to another object. For example, the small cylinder of this telescope can translate only 
from left to right by a maximum of 5 units and follows the larger cylinder when it is moved.

To apply a slider joint constraint:

1. Multi-select the follower and then the object to which is will be constrained, in that order. 
You can either turn off Lock to create an offset or correct it later.

2. Choose View > Display > Constraints.

3. Choose Relations > Joint Constraints >Slider.
The first object is now constrained to slide along the blue box attached to the second object. 
By default, it slides 5 units along the X axis. 

4. Change the minimum and maximum position limits with the sliders to allow for greater or 
smaller range of movement.
Move the object by adjusting the Position parameter in the Parameter Editor.

5. Translate and rotate the slider joint, then translate the follower again. 
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Slider Joint Constraint Parameters

Active Toggles the constraint on and off.

Weight Determines the weight of this constraint in relation to others con-
straints acting on the same object.

Position Determines the position in X, Y, Z (in units) of the origin of the 
slider constraint box.

Axis Determines the orientation of the slider constraint. The X axis (1, 
0, 0) is the default.

Position parameter Displays the current position of the sliding object.

Enable position limits Sets the limits to which the object can slide.

Minimum position
limit

Sets the minimum position in units. Enable position limits must be 
on for this to take effect. For example, if you use the slider con-
straint on a desk drawer, the minimum and maximum limits allow 
you to make sure the drawer cannot slide out of the desk.

Maximum position 
limit

Sets the maximum position in units. 
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Using Groups
When you group objects, you can manipulate them as a whole, use relations, or add interaction 
to the group as well as its individual objects. This allows you to animate the whole group, for 
example, a plane, and animate one of its objects separately, for example, a propeller.

You can have a group within a group. For example, the landing gear with its wheels and bolts 
could be a group within the whole plane group.

To create a group:

Multi-select the objects you want, then choose Relations > Group or press CTRL+G.

To select a group:

Do one of the following:

• In the World Explorer, click the group’s icon.

• In the viewport, ALT-double-click an object in the group.

To rename a group:

In the World Explorer, select the group then press F2, or click the group’s name twice, then type 
a new name and press ENTER.

To add an object to a group:

1. In the World Explorer, select the group.

2. SHIFT-select the object you want to add, then choose Relations > Add to Group.

To remove an object from a group:

1. In the World Explorer, select the group.

2. SHIFT-select the object you want to remove from the group, then choose Relations > Remove 
from Group.

To ungroup objects:

1. In the World Explorer, select the group.

2. Choose Relations > Ungroup.
The objects are removed from the group and the group is deleted.
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To show / hide a group:

Select the group, and turn on/off Visible in the Parameter Editor.

When you turn off a group’s visibility, all the objects in the group disappear in the viewport and 
their visibility is turned off in the Parameter Editor. When you turn the group’s visibility back 
on, all the objects reappear and their visibility is turned on.

To manipulate a group:

1. Select the group.

2. Hold a manipulation hot key (E, R, or T) to lock the selection, then drag the group in the 
viewport.

To add a constraint to a group:

1. In the World Explorer, first select the follower group or object, and then SHIFT-select the 
leader group or object.

2. Choose a constraint from the Relations menu.
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Chapter 5

V i s u a l i z a t i o n

Use Visualization tools to add color and texture to 
objects, as well as add different types of lights and 
WebCams to the World. 

A material defines an object’s physical 
characteristics while textures allow you to import 
bitmapped images created in other applications and 
apply them to objects.

Linking allows you to create a bank of materials or 
textures that can be used by several objects. This 
way, a material can be downloaded once and reused 
several times. 

Clipping allows you to limit how much of the World 
is visible when published.

To practice visualization in AXEL, refer to Lesson 2, 
“Glass and Barrel” in the AXEL Tutorials.

In this chapter:

Materials  130

Textures  136

Lights  145

WebCams  151

Clipping  159

Hardware Acceleration  160
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Materials
A material defines an object’s physical characteristics such as color, shininess, and glow, while 
a texture is an image, such as a scanned image or artwork, applied to the object.

Adding Materials
You can add a material to an object or simply add it to the World and link it to objects later on. 
Linking is useful when you want to use the same material on more than one object — when you 
modify the material, all the objects that use it are updated. Linking enables you to create a bank 
of materials or textures and then link them to objects.

To add a material:

1. Do one of the following:

• Select the object or group to which you want to apply the material.

• To add the material to the World without adding it to an object, make sure nothing is 
selected. (Choose Edit > Unselect All, or hold S and click an empty part of the World.)

2. Choose Visualization > Add Material.

3. Click a color chip, or click Define Custom Colors to create a new color then click OK.
A new material appears in the World Explorer under Resources / Materials.

4. Rename the material so that it is easy to recognize. (Select the material, click it again or press 
F2, and enter a new name.)

5. Adjust the material’s parameters. See “Setting a Material’s Physical Parameters” on page 
134.
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To link a material to objects:

In the World Explorer, multi-select the objects and the material, then choose Visualization > 
Link Material or press CTRL+L.

In the viewports, the objects are updated. In the World Explorer, the material appears under the 
object. When you select a linked material in the World Explorer, every instance of the material 
is highlighted. When you edit the material, all the objects that use it are updated.

To remove a material from an object:

• To remove the material from the object and the World, select the material in the World 
Explorer and press DELETE. 

• To remove the material from the object but keep it in the Resource bank, multi-select the 
object and the material, then choose Visualization > Unlink Material or press CTRL+U.

The material is removed from the object and the object appears in the default color.

To change an object’s color:

1. Select the object or select the object’s material in the World Explorer.

2. In the Parameter Editor, click the color chip, or choose Visualization > Edit Color, then select 
a color from the Color Editor and click OK.

3. When prompted to confirm that you want to change the existing color, click OK.
The object color changes and any other objects that use the same material are also updated.

Note: If you want to change the color of an object that uses a linked material without changing all the 
other instances of the material, unlink the material then change its color. To unlink a material, multi-
select the object and the material, and choose Visualization > Unlink Material or press Ctrl+U.
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Editing the Default Material
When you create an objects it is displayed with the default material.

To edit the default material:

1. In the World Explorer, expand Resources / Materials.

2. Select Default Material and edit its parameters in the Parameter Editor.

Setting Material Color
Colors are described with Red Green Blue (RGB) values. Values range from 0 to 255. For 
example, pure red is 255 0 0, which means maximum red value, with no green and no blue. 
Purple is 255 0 255, yellow 255 255 0. You can also specify colors using Hue, Saturation, 
Lightness (HSL). 

To edit a material color:

Select the material or select an object that uses it and do one of the following:

• Choose Visualization > Edit Material Color and select a new color using the Color Editor.

• In the Parameter Editor, click the material color chip and select a new color using the Color 
Editor that appears. The material changes and all the objects that use it are updated.

• In the Parameter Editor, enter a color value in HTML format (6 digits 0-F) or RGB format (3 
numbers 0-255).

Color value Color chip
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Creating Gradients with Per Vertex Coloring
You can color individual points, faces, or the entire object. This is useful for creating surfaces 
with color gradients.

Note: Using vertex or face coloring freezes the surface. When the surface is frozen, AXEL draws the 
surface based on its points, not its parameters. If you turn off Frozen, the surface is redrawn, and any 
edited point colors revert to the material color. 

To color selected points:

1. Select the object.

2. Press 4 to switch to Point mode, then select the points you want to color.

3. Choose Visualization > Edit Point Color, and select a color from the Color Editor that 
appears.
The selected vertices take on the new color creating a color gradient between adjacent 
vertices. 

In the World Explorer, notice the object’s geometry parameters: Coloring is set to Per Vertex.

4. In the Parameter Editor, expand Point color to see the color of each point. Click a color chip 
to edit the color of each point.

To color selected faces on an object:

1. Select the object.

2. In the Parameter Editor, expand the object geometry parameters, and set Coloring to Per face.

3. Expand the Face colors.

4. To change the color of a face, click its color chip and select a color.

Tip: If the selected face is hidden in the viewports, orbit in WebCam view.
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Setting a Material’s Physical Parameters
The physical parameters determine how a material interacts with light. By adjusting these 
parameters, you create different surface effects.

To set a material’s physical parameters:

Select the material and adjust the following parameters in the Parameter Editor.

Shininess 
Determines the intensity of the highlight. Values range from 0 to 100, with 0 producing a flat 
color, like fabric, and 100 creating the brightest highlight, like a very shiny surface. 

Glow
Zero means no glow while 100 creates a self-lit, neon-like effect.

Transparency 
Default of 0 means the object is opaque while 100 means the object is completely transparent.

Note: You can select objects even if they are completely transparent.

 0 50 100
Shininess values

Glow values
0 100

 0 50 90
Transparency values
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Example: Building a Bank of Materials
1. In a new World, without any object selected, choose Visualization > Add Material.

2. Select a green.

3. In the World Explorer, expand Resources / Materials, and change the name of the material to 
green. 
It is now part of the bank of materials.

4. Create a sphere and choose Visualization > Add Material.

5. Select a red.
The sphere is now red and another material has been added to the Material bank. Rename the 
material red.

6. Create several new objects. Multi-select them and then the green material under Resources / 
Materials.

7. Choose Visualization > Link Material or press CTRL+L. 
All object are now green.

8. If you select that green under any of the objects or under Resources / Materials and edit it, it 
will affect all objects with the material “green”.

9. Select one of the objects and choose Visualization > Unlink Material. 
It removes the material from the chosen object.

This process is identical for textures and is repeated throughout AXEL while linking 
reactions, sounds, and so on. This enables AXEL to use a minimum amount of information 
and memory in its files, and it enhances download times.
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Textures
With textures you can map an image onto an object. Any graphic file that can be converted into 
a supported format can be used as a texture (see “Supported Texture Formats” on page 144). For 
example, you can use Photoshop® files, scanned artwork, video grabs, and so on. 

The process is like projecting an image onto an object; by default the texture image is stretched 
or shrunk to cover the entire object, regardless of size or proportion. You can use tiling and 
texture size to adjust how the texture covers the object. You can use texture projection to change 
the angle of projection. You can also specify how the texture should blend with the object’s 
material color. 

A texture is tied to a material. When you add a texture to an object, it appears under the material 
in the World Explorer. If there was no material on the object, a white material is added to the 
object, and the texture is added to that material. When a texture is added to a material, all objects 
linked to that material are updated.

When you add a texture, the texture image file is copied to the Project folder.

Adding Textures
You can add a texture to an object or simply add it to the World and then link it to objects later 
on. Linking enables you to create a bank of textures and then link them to objects. Before adding 
a texture to several objects, you should decide if you want to adjust the settings separately to 
give each object a different look, or use the same setting for all the objects. If you want to adjust 
the texture settings differently for each object, you should add the texture to the objects. If you 
want to adjust the texture settings for all the objects at once, you should add the texture to a 
material, then link that material to the objects.

To add a texture:

1. Do one of the following:

• Select the material, object, or group to which you want to apply the texture.

• To add the texture to the World without adding it to an object, make sure nothing is selected. 
(Choose Edit > Unselect All, or hold S and click an empty part of the World.)

2. Choose Visualization > Add Texture.

3. Navigate to the texture file, select it, and click OK.
A new texture appears in the World Explorer under Resources / Textures.

4. Adjust the texture settings in the Parameter Editor. See “Texture Parameters” on page 137.

5. Adjust the texture projection. See “Texture Projection” on page 140.
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To link a texture to objects or materials:

1. SHIFT-select the objects or materials and the texture. 

2. Choose Visualization > Link Texture or press CTRL+L.

3. Adjust the texture settings for each object. See “Texture Parameters” on page 137.

Texture Parameters
The texture parameters include texture file parameters and the texture settings. The texture file 
parameters contain information about the image file. The texture settings determine how the 
texture appears on the object. 

Note: You can also control the appearance of a texture by adding texture projection to the object. For 
more information, see “Texture Projection” on page 140.

To edit the texture file settings:

In the World Explorer, select the texture under Resources / Texture or under the object’s 
material, then adjust the parameters in the Parameter Editor. 
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To edit the texture settings:

In the World Explorer, select the texture under the object material, then adjust the parameters in 
the Parameter Editor.

Texture File Settings

File Displays the texture file. You can change the texture by entering a new 
file name and path.

Image width 
and height

This is the pixel size of the texture (all images are stretched or squashed 
into formats that are supported by graphics cards; they must be a power 
of 2, such as 32, 64, 128 pixels and so on). The maximum size is 512 x 
512.

Streamable Once the World is published, the texture is downloaded using streaming.

Streaming 
priority

Determines if the texture will be among the first or the last objects to 
download.
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Texture Settings

Rationalizing Texture Pose 
When Texture Pose is rationalized, the position, orientation, and scale of the texture settings are 
permanently applied to the UV coordinates of the geometry and then the settings are reset to 
their default values (Position = 0,0, Orientation=0, Scale=1,1). This returns all parameters to 
default values without changing the appearance of the texture. For instance if you have scaled 
it, it will remain the same size in the viewports but the scale values will return to 1, 1.

Horizontal til-
ing

Repeats the texture as many times as necessary to cover the projection 
surface horizontally. The effect is visible only if the texture is scaled or 
moved on the object. This is useful with a repetitive pattern, where you 
can use a smaller image and tile it, for a checkerboard for instance.

Vertical tiling Repeats the texture as many times as necessary to cover the projection 
surface vertically. 

Texturing 
mode

Determines how material color and texture are blended. 
Multiply blends the texture over the material by multiplying pixel values. 
A texture mapped over a white material (RGB values 255, 255, 255) will 
remain intact. When mapped over a black material (RGB values 0, 0, 0), 
it will be multiplied by zero and will appear black. This allows you to 
blend the texture into various color values.
Replace maps the texture onto the object without taking your World's 
lighting into account, like the glow parameter on the material. This can 
be useful for neon-like effects, or in conjunction with Environment map-
ping since it faithfully reproduces the texture file as it was originally cre-
ated. In certain Worlds, this could allow you to get by without using 
lights.

Environment 
mapping

Uses the texture map to simulate an environment. If you have a metallic 
object for instance, applying a texture as an environment map helps sim-
ulate reflection.

Filtering Softens the texture. This is useful for small texture images that are en-
larged.

Position Offsets the texture over the object. Values range from 0 to 1 in latitude 
and longitude. The default position is 0, 0, which starts the texture in the 
upper right corner. 0.5, 0.5 starts the texture in the middle of the object 
and 0.9, 0.9 starts it in the lower left corner.

Orientation Rotates the texture, in degrees.

Scale Allows you to enlarge the texture (values lower than 1) or reduce it (val-
ues higher than 1).
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About Tiling
Use tiling to repeat a texture on a surface. This way you can use a very small texture image to 
cover a large surface.

To use tiling:

1. In the Texture Settings, turn on Vertical and Horizontal tiling.

2. To use more tiles, increase the scale. To use fewer tiles, reduce the scale.

Texture Projection
Texture mapping gives you additional control over how a texture is projected onto an object. 
When you apply texture mapping, a projector icon appears in the World. In the World Explorer, 
the texture projector appears under the object to which it is applied and its parameters are 
relative to the object. When you manipulate the projector, the texture moves on the object. Two 
types of texture mapping are available: planar and cylindrical.

Tiling on, Scale = 4 4Tiling OffTexture image
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Planar
A wireframe plane appears in the World. You can scale, rotate, and translate the plane to get the 
texture mapping you want.

The color at the edge of the texture image is applied to the sides of the object. In the following 
example, notice how the edge of the texture map determines the color of the cube.

Cylindrical
A wireframe cylinder will appear in the World. You can edit it through scaling, rotation, and 
translation values to get appropriate texture mapping. It is preferable for mapping textures over 
cylinder and sphere shapes. You should delete the plane or the cylinder when you are satisfied, 
since they affect the refresh rate. Your object will keep whatever texture position it had.

To adjust texture projection:

1. Select an object to which you added a texture.

2. Choose Visualization > Texture Projection > Planar/Cylindrical.
A projector appears in the viewport and under the object in the World Explorer.

3. In the viewports, translate, rotate, and/or scale the projector. In the Parameter Editor, adjust 
the projector parameters.

ZWEB_UG.book  Page 141  Wednesday, April 18, 2001  1:51 PM



142 Chapter 5

Texture Projector Parameters

Active If the texture mapping is not animated, turn off Active to improve perfor-
mance.When Active is on, the system recomputes the texture mapping 
on every frame, even if the texture mapping does not change.

Projection 
type

Sets the type to planar or cylindrical.

Visible Shows/hides the projector icon in the viewports. The projector icon does 
not appear in Browse mode or in the published output even if Visible is 
on.

Position Sets the position of the projector relative to the object. For example, 
when you first apply the texture mapping, the projector is at 0 0 0, mean-
ing that it has the same position as the object. You can also adjust the 
projector position, orientation, and scale interactively by dragging the 
projector icon.

Orientation Sets the orientation of the projector relative to the object.

Scale Sets the size of the projector. With a planar projection, if you increase 
the size of the projector, the texture image is stretched over a larger area. 
If you decrease Scale, the texture is repeated to cover the surface. With 
cylindrical projection, only Y Scale has an effect on the appearance of 
the texture.

UV Scale Controls the number of repetitions of the texture. This parameter is use-
ful with cylindrical mapping. If you increase UV Scale, the texture is re-
peated around the cylinder. 
With the planar projection type, UV Scale serves the same purpose as 
the Scale. If you increase UV Scale, the texture is repeated to cover the 
surface. 
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Creating an Environment Map
Use environment mapping to simulate reflective materials like metal or glass. When you apply 
a texture as an environment map, the texture is not pasted to the object; instead, it is reflected 
off the object as if it were applied to a sphere surrounding the object. The texture bounces off 
the object making it look reflective.

To create an environment map:

1. Select a material or create a new one. 

Tip: Use transparency to enhance the effect of environment mapping. For metallic surfaces, set the 
transparency to 0; for glass, increase the transparency.

2. To see your changes as you work, link the material to the objects in your World.

3. Choose Visualization › Add Texture, and navigate to the image file you want to use as an 
environment and click Open.
The texture is applied to the selected material.

4. In the Texture Settings, turn on Environment mapping.
The texture image appears to be reflected off the object. Orbit the WebCam to see the effect.

This texture applied as 
an environment map 
simulates gold on the 
model above.
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Supported Texture Formats
The maximum resolution is 512 x 512 pixels, with larger texture files slowing down the refresh 
rate. AXEL supports the following file formats as texture maps:

• BMP

• GIF

• JPEG

Before the texture is processed by the software or the graphics card, its dimensions are converted 
into powers of 2 (2, 4, 8, 16, 32, 64, 128, or 512). For example, if a texture is 14 x 32 pixels, it 
will be stretched to 16 x 32 pixels. If it is 100 x 200 pixels, it will be converted into 128 x 256. 
To ensure that your texture images are not stretched, save them with dimensions that are powers 
of 2.

Alpha channels are not supported.
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Lights
AXEL offers a choice of lights to help simulate lighting effects within the World or objects. This 
allows you to light your World in a generic way, or to highlight certain objects, as if lit by a 
flashlight or floodlight, and create various moods. 

Different Lighting Effects
Different lights produce different results, usually simulating real-life conditions. 

The results also depend on the surface that is reflecting the light. For example, you can create 
different effects by varying the shininess of materials or create more uniform lighting by 
increasing the surface subdivisions. The more subdivisions objects have, the better they are able 
to convey the subtleties of lighting and produce smoother results. 

There are three kinds of lights in AXEL: spot lights, point lights, and directional lights.

A horizontal plane with 5 
subdivisions in X and Y

A horizontal plane with 15 
subdivisions in X and Y

Spot light Point light Directional light
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Spot Light
A spot light funnels the light from a source through an adjustable opening, allowing you to focus 
the lighting within a beam. Think of a spot light following a performer on stage or a flashlight 
pointing at something in the dark. In either case, position (the light source) and rotation (what it 
is aimed at) are important.

Point Light
A point light is similar to a light bulb or candle, sending light rays in all directions. The rays all 
emanate from a single point. Thus position is quite important, determining the source and the 
angle at which the light rays will hit objects (rotation and scaling do not affect the results of a 
point light).
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Directional Light
A directional light offers results similar to sunlight, where all light rays seem to come from an 
infinitely distant source (the sun). Parallel light rays will hit the entire World, resulting in all 
objects being lit with equal intensity from the same angle, determined by the orientation of your 
directional light. Only the rotation of your light affects the result. A directional light pointing 
downwards (rotation X= -90) will result in a midday-sun result, while X= -30 will simulate late 
afternoon light.

Adding Lights
By default, there is a directional light in every new World. You can add as many lights as needed 
to light the World, but keep in mind that lights significantly affect performance, so you should 
try to use as few as possible. 

To add a light:

1. Choose Visualization > Add Light, then select the type of light to add.
The light is added and the light icon is displayed in the construction viewports.

Note: If the light icon is out of view, press F to frame the light or A to frame the entire World including 
the light.

2. Translate and rotate the light if needed.

3. Adjust the light parameters in the Parameter Editor.
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Light Parameters

Position Sets the position of the light.

Orientation Points the light.

Scale Has no effect on the light.

Visible Determines whether or not the light icon is visible in the 3D World. It 
does not affect the result of the lighting effect.

Turned on Toggles the light on/off. Functions like a light switch and can be inter-
acted with.

Color Determines the diffuse color of the light. This is the color of the light that 
shines directly on the object. Enter the RGB value or the Hexadecimal 
color code.

Highlight Determines the color of specular highlights. This is the color of the light 
that is reflected off shiny materials. Enter the RGB value or the Hexadec-
imal color code.

Ambient color Determines the color of the light that affects the entire object, not only 
the areas on which the light shines. You can use ambient light to simu-
late light reflected off the walls in your World. For example, if you shine 
a spot light on the front of an object, the ambient light color will affect 
the back of the object, like the light that bounces of the walls in the real 
world. If you do not want to light the back of the object, you can set the 
ambient light to black.

Intensity Sets the brightness of a light. It ranges from 0 to 100, with 0 turning 
the light off and 100 being the highest value. By animating Intensity, you 
simulate a light dimmer.

Fall-off Available for point and spot lights, fall-off simulates the natural attenu-
ation of light. See “About Fall-off” on page 149.

Fall-off 
distance

The distance at which the light has very little effect. At the fall-off dis-
tance, the light is at 10% of its original intensity.

Spot angle Describes the opening, in degrees, of the spot light beam. A low spot 
angle will result in a very thin cone of light, whereas a high value will 
light a larger area.

Spot 
concentration

Is a percentage value that impacts the fall-off of the light within the spot 
light cone. The default value of 8 produces a subtle edge around the spot 
light's cone. A lower value such as 1 or 2 will produce a stark, contrast-
ed edge where the light cone hits an object, and will display the full angle 
of the spot light's cone. A high value such as 100 will create a very small 
light point gently fading towards black.
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About Fall-off 
Available for point and spot lights, fall-off simulates the natural fading of light as it travels 
through space. Thus the intensity of the light gradually diminishes as it travels, until its fall-off 
distance is reached and it has little effect. Think of walking around a dark basement with a 
candle: you can only see as far as your candle will light, the rest being completely dark. On the 
other hand, a high-powered lamp could probably light every corner of the basement. 

You can set fall-off to one of the following types.

None
The default for point and spot lights. No attenuation is used and the light will have the same 
effect on an object 3 feet away as one 2 miles further.

Gradual 
This produces an attenuation following a gentle curve. The light intensity gradually diminishes 
until it hits the fall-off distance, at what point it only has 10% of its remaining intensity.
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Rapid
This produces an almost immediate fading of light, similar to real-world lighting behavior.
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WebCams
In WebCam view and in the published content, you look at your World through a WebCam. By 
adjusting the WebCam, you control what appears on the screen.

Adding WebCams
By default, the World contains one WebCam. You can add any number of WebCams to look at 
the World from different points of view. 

To add a WebCam to the World:

1. Choose Visualization > Add WebCam.

2. To see the World through the new WebCam, right-click a viewport, choose View, and select 
the new WebCam.

3. To see the WebCam icon in the Top, Front, or Right viewport, right-click the viewport, then 
choose Viewpoint > Frame Selection or press F.

4. Adjust the WebCam parameters.

ZWEB_UG.book  Page 151  Wednesday, April 18, 2001  1:51 PM



152 Chapter 5

WebCam Parameters

Position Sets the WebCam position.

Orientation Sets the WebCam orientation, that is, the direction along which you look 
at your World.

Scale Does not affect the WebCam.

Visible Shows/hides the WebCam icon in construction views.

Background 
color

Sets the background color in the WebCam viewport. Enter an RGB or 
hexadecimal color value or click the color chip and use the Color Editor 
to set the background color.

Shade Objects in the WebCam viewport appear filled or shaded. When Shade is 
turned off, objects appears as wireframe.

Orthogonal 
projection

Removes the Field of View (FOV) angle, thus creating a non-perspective 
view. 

Interest 
distance

Determines what the WebCam is looking at. Also determines the radius 
around which the WebCam orbits. Choosing Frame Selection moves the 
WebCam interest onto the selected object.

Near plane 
distance

Indicates the distance between the WebCam and the beginning of the 
viewing frustum. Objects between the WebCam and the near plane are 
not visible. For more information on the near plane, far plane, and FOV, 
see “About the Viewing Frustum” on page 153.

Far plane 
distance

Indicates the distance between the WebCam and the end of the viewing 
frustum. Objects beyond the far plane are not visible. 

Near plane 
height

Determines the height of the plane, which in turn determines the vertical 
FOV angle.Changing the Near plane height is the same as changing the 
FOV. The Near plane width is adjusted automatically to maintain the as-
pect ration.

Vertical 
FOV angle

Determines the vertical FOV angle, which in turn determines the Near 
plane height. Changing the vertical FOV angle has the effect of zooming 
in on the objects. The horizontal FOV is set automatically to maintain the 
aspect ratio of the viewer. The FOV cannot exceed 170 degrees.
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About the Viewing Frustum
When you look into a WebCam, your scope of vision is limited by the WebCam’s viewing 
frustum.The viewing frustum determines what the WebCam sees. It is in the shape of a truncated 
pyramid. Only objects inside this pyramid are visible to the WebCam. The viewing frustum is 
defined by the near plane distance, the far plane distance, and the vertical FOV angle.

Viewing frustum

ZWEB_UG.book  Page 153  Wednesday, April 18, 2001  1:51 PM



154 Chapter 5

Adjusting the FOV is similar to changing the lens on the WebCam. In the following illustrations, 
the WebCam and the tower stay put, but the FOV angle is changed.

A low FOV value, such as 15 degrees, is like a tele-photo 
lens. It gives a close-up while flattening the image.

A value of 45 resembles a normal WebCam.

A high value such as 75 produces a fish-eye effect like a 
wide-angle lens.
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Switching WebCams
In WebCam view, you see the World through the eyes of one WebCam. If the World contains 
several WebCams, you can switch WebCams to look at the World from different angles. The 
label of the WebCam viewport indicates which WebCam is used. 

To switch WebCams:

Right-click the WebCam viewport, choose View, and select the WebCam you want to use.

Moving WebCams
You can zoom, pan, and rotate the WebCam interactively or point it at selected objects. Like any 
object, you can translate and rotate the WebCam, or adjust its position and orientation 
parameters. You can use constraints to make the WebCam follow an object in the World.

To zoom in or out of the World:

Hold Z, then click and drag in the WebCam viewport. 

The current WebCam moves towards or away from the WebCam’s interest (what it is looking 
at).
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To pan:

Hold X and click and drag in the WebCam viewport.

The current WebCam moves up-down or left-right.

To orbit: 

Hold C and click and drag in the WebCam viewport. 

The current WebCam moves around its interest on a circular axis, either horizontally (click and 
drag from left to right) or vertically (click and drag from top to bottom).

To move the WebCam using specific position and rotation values:

1. In the World Explorer, select the WebCam.

2. In the Parameter Editor, enter values in the Position and Orientation fields.
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To translate a WebCam using the mouse:

1. Select a WebCam.

2. In the Parameter Editor, turn on Visible.
The WebCam icon is visible in the viewports. You can press F to bring it into view if needed.

3. Turn on the Translate button (or press T), then click and drag your cursor in a viewport.
The WebCam moves.

To rotate a WebCam using the mouse:

1. Select a WebCam.

2. In the Parameter Editor, turn on Visible.
The WebCam icon is visible in the viewports. You can press F to bring it into view if needed.

3. Turn on the Rotate button (or press R), then click and drag your cursor in a viewport.
The WebCam turns around its center.

To attach the WebCam to an object:

1. In the World Explorer, multi-select the WebCam and the object, in that order.

2. Choose Relations > Pose Constraint.
The WebCam is attached to the object like a WebCam on a rig.

For more information, see “Adding Constraints” on page 107.

Pointing WebCams
By pointing the WebCam at different objects, you decide what appears on the screen.

To point the WebCam at an object:

1. Select the object(s). 

2. Click the WebCam viewport to make it active.

3. Do one of the following:

• Choose View › Viewpoint › Look at Selection.

The current WebCam points at the object(s).

• Choose View > Viewpoint > Frame Selection or press SHIFT+F.
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The current WebCam points at the object(s) and moves in or out so that the object fills the 
viewport.

To make a WebCam follow an object:

1. In the World Explorer, multi-select the WebCam and the object, in that order.

2. Choose Relations > Direction Constraint.
The WebCam follows the object wherever it goes.

To point a WebCam at the origin (position 0,0,0):

Choose View > Viewpoint > Look at Origin.

The current WebCam points at the origin but its position does not change.

Showing or Hiding WebCam Icons
You can show or hide the WebCam icon in the construction views. The WebCam icon is useful 
when you are adjusting or animating the WebCam position and/or viewing frustum.

To show the WebCam icon:

In the World Explorer, select the WebCam, then turn on Visible in the Parameter Editor.

The WebCam icon appears in the construction viewports. If you cannot see it, press F to frame 
the WebCam.
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Clipping
Clipping helps improve performance in web pages. When the clip box is enabled, you only see 
what is inside the clip box.

If you publish windowless content, for instance, a 3D car driving over HTML text, a clip box 
attached to that car will enhance performance since AXEL only calculates what is inside it. By 
adding a pose relation between the clip box and object(s) or group, you ensure that the clip box 
moves with the object or group.

The clip box parameters are also animatable, so you use it for wipes or other effects. You can 
use only one clip box in a World.

To create a clip box:

1. Choose Visualization > Add ClipBox.
The clip box appears in the World Explorer. 

2. To display the clip box, choose View > Display > ClipBox.
The clip box appears in the construction views.

3. Translate, rotate, and scale the clip box so that it frames the portion of the World that you 
want to publish. You can manipulate the clip box the same way you manipulate a cube.

4. Adjust the clip box parameters.

5. Turn on clipping to preview the result. Right-click the WebCam viewport and turn on 
Clipping.

ClipBox Parameters

Position The X, Y, Z position of the clip box.

Orientation The orientation of the clip box in degrees along the X, Y, and Z axis.

Scale The size of the clip box in reference to its original size.
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Hardware Acceleration
When AXEL starts, it tries to use the hardware acceleration available on your system. If you 
want it to use software rendering instead, turn off hardware acceleration.

To turn on/off hardware acceleration:

Choose Visualization > Hardware Acceleration.

Note: Hardware acceleration will not be available if it is not supported by your system’s graphics card, 
even if it is turned on in AXEL.

To know if AXEL is using hardware acceleration:

Right-click the WebCam viewport, and choose Display > Stats.

SW means software rendering, HW means hardware accelerated rendering.

ZWEB_UG.book  Page 160  Wednesday, April 18, 2001  1:51 PM



161

Chapter 6

A n i m a t i o n

Almost everything can be animated in AXEL.

You can animate an object’s scale, rotation and 
position values, and most other parameters.

There are different ways to animate in AXEL:

• You can record keys interactively or save specific 
keys at specific times. In both cases, the basic 
workflow is simple: you add an animation 
sequence for the parameter you want to animate, 
record keys, then edit the keys to refine the 
animation.

• You can use animation effects where AXEL 
creates the animation using dynamics (Particles), 
motion effects (Path animation), or shape effects 
(Wave and Shape Mixing).

To practice animation in AXEL, refer to Lesson 12, 
“Animating the Fish” in the AXEL Tutorials.

In this chapter:

Animation Tools  162

Recording Animation Keys  168

Editing Animation 
Parameters  171

Editing Animation Keys  176

Particle Animation  184

Path Animation  187

Wave Animation  188

Shape Mixing  189

Shape Animation  190
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Animation Tools
The main animation tools are the Animation menu, the Playback toolbar, the Time toolbar, the 
Animation toolbar, and the Sequencer. Before you start, you should know how to navigate in 
time, preview an animation, and use the Sequencer.

Navigating in Time
When you start a new World, time is already running. This is because time has to be running for 
some effects to be visible, for example, particles and path animation. 

You control time using the Time and Playback toolbars on the right of the toolbar or by dragging 
the playhead in the Sequencer. To navigate between keys, you use the Animation toolbar.

To go to a specific time:

Do one of the following:

• Enter the time in seconds in the Time field.

• Click in the timeline. The playhead moves to that time.

• Drag the playhead. The animation updates in the viewports.

Current time Start time End time Play/Stop

Loop

The Time toolbar

Rewind Fast Forward

Go to End

Previous key Next key

The Playback toolbar The Animation toolbar

Go to Start

Time field
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To go to the previous or next key in an animation: 

1. Select the animation in the Sequencer.

2. Do one of the following:

• Click the Previous Key button or press CTRL+SHIFT and the left ARROW key.

• Click the Next Key button or press CTRL+SHIFT and the right ARROW key.

The playhead moves to the previous or next key in the selected animation sequence.

Previewing Animation
You can play an animation in the viewports using the playback buttons, or you can drag the 
playhead to scrub through the animation. You can also switch to Browse mode and preview the 
animation as it will appear in a web page.

To start or stop playback:

Click the Play/Stop button or press P.

Playhead

Current time Next keyPrevious keySelected sequence

Previous 
key button

Next key 
button
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To loop playback:

Turn on the Loop button.

When loop is on, the animation replays over and over again, from the Start time to the End time. 

The entire animation plays over and over while you are authoring and when the World is 
published. If you want some sequences to play over and over, and others to play once then stop, 
turn on the Cycle parameter for specific sequences. For more information, see “Editing 
Animation Parameters” on page 171. 

Note: If you want the entire World to loop when published, loop must be on when you publish the 
World.

To play back a portion of the animation:

1. Use the Start and End fields to define the portion that you want to play back.

2. Turn on the Play button or press P.
The animation plays from the Start time to the End time.

Using the Sequencer
The Sequencer is a graphical representation of animation and interaction. Use it to navigate 
through the animations, adjust the timing or the value of different keys, as well as synchronize 
sound and animation reactions. In the Sequencer, you can display animation curves that plot 
parameter values over time.

To zoom in or out of the Sequencer:

Click and drag the Zoom bar.

Zoom bar Scroll bar

Playhead

The Sequencer
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To frame a portion of the animation:

Right-click the timeline and choose one of the following:

To scrub the animation:

Drag the playhead.

Sequencer Views
The Sequencer displays animation or interaction. Animation view shows all animation 
sequences except those that are converted into Play Animation reactions. Interaction view 
shows all sensors and linked reactions. For example, if you create an animation then convert it 
into a Play Animation reaction, you edit it in Interaction view. Reactions and sensors that are not 
linked do not appear in the Sequencer.

Frame Selected Zooms in on the selected animation sequence

Frame All Items Displays all animation sequences.

Frame Start Time to End 
Time

Displays everything from the Start time to the End time.

Playhead
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To switch views:
Click Show Animation or Show Interaction.

Zoom bar

Playhead Time Scale (seconds)

Keys

Show Animation

Animation 
sequences

The Animation View

Sensors and linked reactions

Show Interaction

The Interaction View
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Displaying the Curve Editor
The curve editor is a graph representing the value of keys over time. You can display a curve 
editor for all animation sequences, in Animation or Interaction view.

Notice the animation keys appear on the animation sequence and on the curves. On the 
animation sequence, you can drag keys left and right to change their timing but you cannot 
change their value. On the animation curve, you can drag keys left and right to change their 
timing, and up or down to change their value.

To display the curve editor for an animation sequence:

Double-click the animation sequence.

Animation sequence Curve editor

 Keys High and low values Drag edge to resize
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Recording Animation Keys
To record animation, first you create an animation sequence for the parameter you want to 
animate, then record keys at different times. When animating an object’s scale, position, and 
rotation, you can record the motion interactively, that is, AXEL records keys as you drag the 
object in the viewport.

Recording Keys Individually
Recording keys is as simple as taking a picture of an object at different points in time. AXEL 
uses interpolation to determine the state of the object in between the recorded keys. When you 
play back the animation, the object changes from one key to the next. Depending on the 
interpolation you select, the object can jump from key to key or change gradually over time.

To record keys:

1. Turn off Play and go to the time where you want the animation to start.

2. In the World Explorer, select the parameter you want to record. 

3. Choose Animation > Add Animation Sequence.
This creates an animation sequence with the first key.

4. To adjust the first key, turn on Record and adjust the parameter. 

5. To record another key, go to another time, and change the parameter.

6. To preview the animation, go to the start of the animation and turn on Play, or drag the 
playhead to scrub the animation.

To animate position, rotation, or scale:

1. Turn off Play and go to the time where you want the animation to start.

2. Turn on a Translate ( ), Scale ( ), or Rotate ( ), and select the object you want to 
animate. 

3. Choose Animation > Add Animation Sequence.
This creates an animation sequence and a first key. If the Translate button is on, it creates a 
position animation. If the Rotate button is on, it creates a rotation animation, if the Scale 
button is on, it creates a scale animation.

4. To adjust the first key, turn on Record and drag the object in the viewport. 

5. To record another key, go to another time, and drag the object again.
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6. To preview the animation, go to the start of the animation and turn on Play, or drag the 
playhead to scrub the animation.

Example: Animating the scale of a sphere 

1. Turn off Play, turn off Record, and go to time 0.

2. Go to the time at which you want the animation to start.

3. Select the sphere.

4. Turn on the Scale button.

5. Choose Animation > Add Animation Sequence or turn on Record.
An animation sequence appears in the Sequencer with the first key at the current time.

Note: The animation also appears in the World Explorer and Parameter Editor under the selected object 
and under Resources / Effects.

6. To adjust the first key, scale the sphere at the current time. For example, make it half its size. 
Until you change the time value, all modifications you make overwrite the initial values.

7. Go to time 2.
This is the time of the next key.

8. Scale the sphere again. Make it twice its original size.
A new key appears in the Sequencer.

9. To set another key, go to time 4 seconds and scale the sphere. Bring it back to half its original 
size.

10.To preview the animation, scrub the Sequencer or go to time 0 and turn on Play. 
The sphere grows and shrinks as the playhead moves from key to key.

11.Continue adding keys until you are pleased with the animation and then turn off Record to 
avoid adding keys by mistake.

Animation sequence First key
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Recording Animation During Playback
An intuitive way to create animation is to move an object interactively during playback and 
record the movement. As you modify the object, AXEL records 5 samples per second.

Note: Keys are saved every 0.2 seconds. If this method creates too many keys, record the keys 
individually. For more information, see “Recording Keys Individually” on page 168.

Example: Recording the motion of a sphere as you translate it during playback

1. Turn off Play ( ), and go to time 0.

2. Turn on Translate ( ), and select the sphere.

3. Turn on Record ( ).
An animation sequence appears in the Sequencer.

4. Turn on Play and drag the sphere in a viewport.
As you move the sphere, AXEL records its position 5 times per second.

5. Turn off Play and turn off Record.
AXEL stops recording position information. 

6. To preview the animation, go to time 0 and turn on Play. 

7. In the Sequencer, drag the zoom bar to see all the keys you created.

8. Drag the playhead back and forth to scrub the animation.

Keys

Playhead
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Editing Animation Parameters
When you animate an object or a parameter, the animation appears in the World Explorer under 
the animated object. You can adjust the animation parameters, including the time and values for 
each key in the animation.

In the following illustration, notice the three animations under the door object.

The animations are also listed under Resources / Effects. 

Scale animation

Joint angle animation

Material color animation

Joint angle animation parameters
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To edit animation parameters:

Do one of the following:

• Select the animation sequence in the Sequencer, then adjust the parameters in the Parameter 
Editor.

• Expand the animation in the World Explorer or Parameter Editor, then click a parameter 
twice and enter a new value.

Animation Parameters

Active Turns on the animation. If active is turned off, the animation does not play 
back when you turn on the Play button. 
If you convert an animation into a Play Animation reaction, Active is auto-
matically turned off. The animation plays only when it is triggered by a sen-
sor. 

Interpolation Determines how the animation progresses between keys:

• Linear makes the parameter change evenly between keys.

• Constant makes the parameter stay constant until it reaches the next key; 
then it jumps to a new value. 

• Smooth creates gradual change over time. This type of interpolation is also 
known as ease-in and ease-out. 

Additive Adds the parameter’s value to its current value. For example, if one anima-
tion moves an object along the ground plane, you can create an additive 
animation to make it jump off the ground from time to time.

Cycle Plays the animation sequence over and over. 

Note: Use Cycle to repeat one sequence. To repeat all the sequences, turn on Loop 
playback. 

Forward Plays from the first key to the last. Turn off Forward to play the animation 
sequence in reverse.

Time scale Allows to slow down or speed up the animation by a multiplication factor. 
Scaling the animation by 2 doubles the speed of the animation; scaling by 
0.50 reduces the speed of the animation.

Time offset Offsets an animation sequence by number of seconds. You can also offset 
an animation sequence by dragging it in the Sequencer.

Note: When an animation is converted into a reaction, it is automatically offset so that 
it starts on the trigger.

Weight Determines the weight of the animation relative to other forces that affect 
the parameter. For example, if an object has a position animation and a 
pose constraint, use Weight to control which affects the object most. 
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Relative to 
group

When animating objects in a group, the position, orientation, and scale keys 
are relative to the position, orientation, and scale of the group. For exam-
ple, if a group contains a dancing bear and a train, the bear’s animation 
should be relative to the group so that the bear moves with the train as it 
dances.

Keys Lists the values of each key in the animation.
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Example: Animation Cycle and Interpolation
In this example, you animate the color of the signal lights at a railways crossing. You create an 
animation cycle where the light changes from dark red to bright red, then back to dark red. You 
use Constant interpolation to make the color change suddenly every 1/5 of a second.
Note: To try this example, open the Railway_start.axel in AXEL / Documentation / Projects. You can 
also follow this example using a sphere with a red material.

1. Turn off Play ( ), go to time 0, and turn on Record ( ).

2. In the World Explorer, select the material color parameter you want to animate.

3. Choose Animation > Add Animation Sequence or press CTRL+K. 
An animation sequence appears in the Sequencer.

Material color 
parameter
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4. At time 0, set the color to dark red. Click the color chip in the Parameter Editor and select a 
color from the Color Editor that appears.

5. Go to 0.4 seconds and press CTRL+K.
A new key appears at time 0.4 in the Sequencer. The color is still dark red.

6. Go back to time 0.2 seconds, press CTRL+K and set the color to bright red.
Notice the keys in the Sequencer. Double-click the animation sequence to display the curve. 

7. To preview the animation, go to time 0, and turn on Play. 
The light gradually changes from dark red to bright red, then back to dark red.

8. To make the color change suddenly, select the animation sequence and set the Interpolation 
to Constant in the Parameter Editor. 
Notice the jumps in the animation curve. The color value changes suddenly at each key.

9. To make the animation cycle over and over again, turn on Cycle.

Bright redDark red Dark red

Turn on Cycle
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Editing Animation Keys
You can edit key values, add, remove, or copy keys.

Editing Key Values
You can edit keys in the Sequencer, in the Parameter Editor, interactively in the viewports, or in 
the World Explorer.

To edit keys in the Sequencer:

Do one of the following:

• Click and drag keys left or right to change their timing.

• Double-click the animation sequence to display the animation curve, then click and drag the 
keys to change their timing and values.

To edit keys in the Parameter Editor:

Do one of the following:

• Select the animation sequence in the Sequencer or World Explorer, then click Keys in the 
Parameter Editor. 

• Select a key in the Sequencer.

The keys are listed in the Parameter Editor.

Drag to edit timing

Drag to edit value and timing
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The first number is the key time in seconds; the other numbers are the key values. For 
example, if you animate position, the first number is the time, and the next three numbers are 
the X, Y, and Z position of the object at that time.

Tip: To prevent the Parameter Editor from changing, click the Pin icon. This way you can fine-tune the 
animation in the viewports and the Sequencer while editing key values in the Parameter Editor.

To edit manipulation keys interactively:

1. Select the animation sequence you want to edit.

2. Use the Previous and Next key buttons to navigate to the key you want to edit.

3. Turn on Record and move the object in the viewport.
The current key updates in the Sequencer.

4. To add a key, go to the time where you want the new key, press CTRL+K, and move the object 
in the viewport.

5. To preview the animation, turn on Play or drag the playhead to scrub the animation.

Time X Y Z

Pin
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To edit keys in the World Explorer:

1. In the World Explorer, expand the object and then the animation to display the keys. For 
example, to access the keys for an animated material, expand the material and the animation 
under the material.

2. Click twice on the key that you want to edit, type the new values and press ENTER. The first 
number is the key time in seconds; the other numbers are the key values. For example, if you 
animate a color, the first number is the time, and the next three numbers are the red, green, 
and blue (RGB) values of the color at that time.

Color animation keys

Time R G B
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Adding, Removing, Copying Keys
You can fine-tune animation by adding, removing, or copying keys. Copying keys is useful 
when you want a parameter’s value to repeat at several points in the animation, especially with 
shape animation where copying a geometry key provides a fast way to reproduce an unusual 
shape.

To add keys to an animation sequence:

1. Go to the time where you want to add a key.

2. Select the animation sequence to which you want to add a key.

3. Choose Animation › Add Key or press CTRL+K.
A new key appears in the Parameter Editor, Sequencer, and in the World Explorer.

4. To modify the new key, click and drag it in the Sequencer, adjust its value in the Parameter 
Editor, or turn on Record and adjust the object in the viewports.

To delete a key:

Select the key, then press DELETE.

To delete an entire animation sequence:

Select the animation sequence and press DELETE.

To copy and paste key values:

1. In the Sequencer, select a key.

2. Press CTRL+C to copy the key’s values.

3. Select another key, and press CTRL+V.
The second key is set to the copied value.
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Example: Recording and Editing Animation
In this example, you animate the gate at a railway crossing. The gate is attached to the post by 
a pin joint constraint. You can translate the gate to lift or lower it. You can create an animation 
by recording the motion interactively, then adjust the keys in the Sequencer.

Note: To try this example, open the Railway_start.axel in AXEL / Documentation / Projects. You can 
also follow the example using a cube that you translate across the viewport.

Record the animation:

1. Go to time 0, and translate the gate to a vertical position.

2. Turn on Record.
A position animation appears in the Sequencer.

3. Turn on Play and translate the gate down.
When you release the mouse, several keys appear in the Sequencer. 

4. To preview the animation, go to time 0 and turn on Play or drag the playhead to scrub the 
animation.

Modify the animation using the Sequencer:

1. Right-click the animation sequence and choose Frame All Items.
Now all the keys appear in the Sequencer.
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2. Translate individual keys to modify the timing of the closing.

3. Double-click the animation sequence to display the curve editor, then edit keys on the X and 
Y axis to fine-tune the lowering of the gate.

4. In the Parameter Editor, set Interpolation to Smooth.
Notice the change in the curves and in the motion when you play back the animation.

Example: Additive Animation
This example uses additive animation to make a ball bounce up and down as it moves along a 
path. In the first animation, the sphere moves along a path on the ground; in the second 
animation, the sphere bounces straight up and down. When the bouncing animation is added to 
the path animation, the sphere bounces up and down as it moves along the path. By converting 
the bouncing animation into a reaction, you can let the surfer bounce the sphere as it moves 
along the path.

Create a sphere, a path, and a ground plane:

1. Choose Modeling > Preset Surfaces > Sphere.

2. Choose Modeling > Preset Surfaces > Horizontal Plane. Translate the plane along the Y axis 
so that the sphere sits on the ground.

3. Choose Modeling > Draw Curve, and draw a curve in the Top viewport. In the curve 
geometry parameters, increase Steps to smoothen the curve.

Animate the sphere along the curve:

1. Multi-select the sphere and the curve, in that order, and choose Animation > Path Animation.

2. Go to time 0, and turn on Play. The sphere moves along the curve. Notice a path constraint 
animation appears in the Sequencer.
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3. Turn off the path animation while you create the bouncing animation. In the Sequencer, select 
the animation, then turn off Active in the Parameter Editor.

Create the bouncing animation with 3 position keys (down, up, down):

1. Turn off Play and go to time 0.

2. Select the sphere, turn on the Translate tool, and choose Animation > Add Animation 
Sequence.
A position animation appears in the Sequencer, with the first key at time 0. This is the first 
key with the sphere on the ground.

3. Without moving the sphere, go to time 2, and press CTRL+K to add a key. This is the third 
key, where the sphere is back on the ground.

4. To create the up position key, turn on Record, go to time 1 and drag the sphere up 2 units in 
front view. 

5. In the Sequencer, drag the playhead to scrub the animation.

6. Select a key to display the key values in the Parameter Editor, then set the keys to the 
following:

7. Go to time 0 and turn on Play to preview the bouncing animation.

8. Select the bounce animation, then in the Parameter Editor, set the Interpolation to Smooth, 
and turn on Cycle. 
Now when you play the animation, the sphere bounces more smoothly, over and over again. 

9. In the Sequencer, double-click the animation sequence to display the animation curve. You 
can fine-tune the animation further by adding keys and adjusting the shape of the animation 
curve.

10.To speed up the bouncing motion, increase the Time scale in the Parameter Editor.
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Combine the bounce animation with the path animation:

1. Select the path animation and turn on Active.

2. Select the bounce animation and turn on Additive.
Turn on Play to preview the result. The sphere bounces up and down as it moves along the 
path.

Make the bounce interactive:

1. Instead of bouncing on its own, make the sphere bounce when the surfer clicks the 
background. Select the bounce animation and turn off Cycle, then choose Interaction > 
Reactions > Play Animation. 

2. In the Interaction Editor, expand the MouseSensor (Background) and link OnLeftClick to the 
PlayAnim reaction.
Switch to Browse mode to test the interaction. Click the background to make the sphere jump 
up.
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Particle Animation
Particles allow you to animate a large quantity of small objects that would be impossible or 
difficult to create otherwise. For example, you can use particles to create rain, smoke, snow, 
bubbles, and so on. You generate particles from a source and edit their parameters to create 
various effects. You can add particle to any object except text. 

You can place obstacles in the way of the particles and animate the obstacles to create unlimited 
effects.

To create particle animation:

1. Select the object that will emit particles and choose Animation > Add Particles. 
Turn on Play or press P to see particles emitted from the object.

2. In the World Explorer, expand the object, select the Particles, then edit the particle parameters 
in the Parameter Editor.

The particles update in the viewports as you change parameters.
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Particle Animation Parameters

Adding Obstacles to Particles
You can place obstacles in the flow of particles to divert them. By hiding and animating the 
obstacles, you can make the particle motion seem less predictable.

Active Indicates whether or not the animation is active.

Emission rate Number of particles emitted per second.

Minimum age Minimum amount of seconds particles emitted will last before disappear-
ing. You can use different Minimum and Maximum age values to make 
the result look random.

Maximum age Maximum amount of seconds particles emitted will last before disappear-
ing.

Minimum 
speed

Minimum speed, in units per second, at which particles will travel. Snow-
flakes, for instance, will have a lower value than a hailstorm. Different 
Minimum and Maximum speed values ensure that the result looks a little 
more random.

Maximum 
speed

Maximum speed, in units per second, at which particles will travel.

Speed 
inheritance

Determines how much the particles will follow the source if it is moving. 
A value of 0 leaves the particles floating wherever they were generated, 
while a value of 1 makes the particles use the momentum of the moving 
object.

Spread angle Spread of the emission, in degrees. A value of 0 creates a beam of par-
ticles. A value larger than 0 makes the particles fan out.

Emission color Color of the particles in R,G,B or hexadecimal values.

Emission size Size of the particles.

Spin rate Rate, in degrees per second, at which the particles spin while being emit-
ted.

Gravity Axis (X,Y, or Z) along which gravity applies. The default 0, -1, 0 pulls 
the particles downwards (negative Y). Use X or Z values to simulate 
wind.

Particle shape Shape of emitted particles. Select Triangle, Star, Square, Disc, Cube, 
Sphere, or Cone.
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To add obstacles to particles:

1. Create an object and place it in the path of the particles. For example, place a cone in the 
stream of particle emitted from a sphere.

2. Select the obstacle and the particle animation, then choose Animation > Link Particle 
Obstacle or press CTLR+L.

The particles bounce off the obstacle. Move the obstacle, or add more obstacles to create 
different effects.

Tip: You can select the particle animation by marquee-selecting one or more of the particles in a 
viewport.

Multi-select obstacle 
and particles
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Path Animation
You can draw a curve then use path animation to make an object move along the curve. The Path 
Animation command automatically creates an object to curve constraint and an animation of the 
object’s position parameter.

To create path animation:

1. Multi-select an object and a curve, in that order.

2. Choosing Animation > Path Animation.
Turn on Play or press P to see the object move along the curve. By default, it moves from the 
beginning of the path to the end of the path in 10 seconds. 

The path animation adds a curve constraint and a position animation to the object. In the 
World Explorer, expand the object to see these items. To modify the path animation, adjust 
the curve constraint parameters, and/ or modify the animation sequence. For more 
information, see “Object to Curve” on page 116, and “Editing Animation Keys” on page 176.
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Wave Animation
You can apply an animated wave deformation to any object, for example, to create a waving flag. 

To apply a wave animation to an object:

Select the object and choose Animation > Wave Animation. 

Note: Make sure the object has enough subdivisions to deform smoothly.

Wave Animation Parameters

Active Indicates whether or not the animation is active.

Height Determines how much each point of the object is deformed. It represents 
the actual height of the wave.

Speed The speed, in units/second, at which the wave is propagating.

Length The distance between 2 consecutive “peaks” of the wave.
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Shape Mixing
Shape mixing provides a way to have an object interactively change its shape based on its 
proximity to other objects, the modifiers. This can create very interesting interactivity on a web 
page when the two modifier objects have their visibility turned off.

Shape mixing works with three objects: the first and second serve as the shape modifiers. The 
closer you move the third object to either modifier, the more it resembles that shape. In the 
following illustration, the shape of the crown changes as you move it from the queen’s crown 
on the left, to the king’s crown on the right.

Example: Mixing shapes

1. Create a cube.

2. To subdivide the cube, choose Modeling > Modify Surface > Subdivide. Repeat this step to 
subdivide the cube twice.

3. Duplicate the cube twice and translate the three objects so they are lined up along the X axis.

4. To create two modifer objects, edit some of the points on the first and second cube so that 
they are visually distinct (you could try making a plus sign and a star shape.)

5. Multi-select the modifiers and then the third cube, in that order.

6. Choose Animation > Mix Shapes.
When you translate the third cube towards a modifier, its shape changes.

First modifier Second modifier
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Shape Animation
Shape animation is the animation of an object’s geometry. You create shape animation by 
animating points on the object. This is useful for adding secondary movement to characters. For 
example, to animate a character breathing, you can add realism by animating the points on the 
character's stomach and nose.

To create shape animation:

1. Turn off Play and go to time 0.

2. Select an object, then switch to Point mode (press 4).

3. Turn on Record.
An animation sequence appears in the Sequencer.

4. Go to another time, translate points to modify the object's shape. A new key appears on the 
animation sequence.

Example: Animating a Drop of Water
In this example, you animate the shape of a water drop falling from a tap. You do this by 
selecting and moving points and saving keys of various positions of those points. This method 
could be used to animate a mouth opening and closing, or any shape changing over time.

Animate the drop falling from a tap:

1. Choose Modeling > Preset Surfaces > Sphere.

2. Turn off Play and go to time 0.

3. In the Front viewport, translate the sphere 4 units in Y. 

4. Turn on the Record button ( ).
Since the Translate tool was active when you turned on Record, an animation sequence is 
created for the position parameter. In the Sequencer, notice the key at time 0.

5. Go to time 3 and choose Animation > Add Key or press CTRL+K.
A second key, with the same position value, is added at time 3. 

6. Go to time 4.5, then, in the Front viewport, translate the sphere to -8 units in Y, so that it is 
off screen. 
Since Record is turned on, moving the sphere automatically adds a key to the position 
animation sequence.
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Create an animation sequence for the shape of the sphere: 

1. Select the sphere, switch to Point mode (press 4) and then select all the points on the sphere.

2. To create a geometry animation sequence, return to time 0, then press CTRL+K. 
A new animation sequence and one key appear in the Sequencer.

3. Since the drop should return to a spherical shape after it is released from the tap, create a key 
for the spherical shape at time 3.2. Go to time to 3.2 and press CTRL+K. 

Stretch the shape of the sphere so that it looks heavy as it leaves the tap:

1. Go to time 3.0 and select the points on the bottom half of the sphere. 

2. Translate them down about two units. 

3. Translate any other points of the sphere until you have a drop that is about to break away from 
the tap.

4. Turn off Record to avoid saving keys by mistake.

5. Go to time 0 and turn on Play to preview the animation.
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Chapter 7

I n t e r a c t i o n

By adding interaction, you let the web surfer take 
part in the 3D World you created. There are several 
ways to enhance the surfer’s experience:

• You can create an animation, and let the surfer 
watch it in a linear, passive way.

• You can make a static World where nothing 
happens until the surfer starts interacting with 
elements, for example, by moving the mouse 
around or clicking on buttons.

• You can present a linear story with interactive 
elements that make the experience unique.

The challenging part of creating interesting 
interaction is the actual scripting or storyboarding. 
Once you know what you want to create, building 
the interaction is easy.

To practice creating interaction in AXEL, refer to 
Lesson 3, “IQ test,” Lesson 4, “Clown and Pistol,” 
Lesson 9, “Switching Reactions,” and Lesson 10, 
“Rocket Launch” in the AXEL Tutorials.

In this chapter:

Workflow  194

The Interaction Editor  196

Interaction in 
the Sequencer  198

Creating Reactions  201

Linking Sensors 
to Reactions  219

Using Handles  230

Refining Interaction  238

Grouping Reactions  244

ZWEB_UG.book  Page 193  Wednesday, April 18, 2001  1:51 PM



194 Chapter 7

Workflow
Usually you create a reaction as part of a bank of events waiting to be set off. You can then link 
the reactions to sensors. When a sensor is triggered, a reaction is launched. 

In the following example, clicking the big button launches a rocket. The sensor is the button, 
and the reaction is the rocket animation.

The same reaction can be launched by more than one sensor, for example, the rocket can take 
off when the button is clicked or when 5 seconds have elapsed. Conversely, one sensor can 
launch several reactions, for example, clicking the button can launch the rocket, deform the 
button, and play sound.

The main steps to creating interaction are the following. 

Creating one or more reactions 
Imagine a bank of animations, sounds, color changes, shape switches, all waiting to be called 
on. There are a variety of reactions, and they all have editable parameters, for example:

• The animation of the rocket flying on the path.

• The animation of the big button being pressed.

• The clicking sound of the button being pressed.

• The particle animations of smoke and fire started by turning on their Active parameter.

• The switching of materials of the button, from red to glowing red, when the surfer’s mouse 
goes over it, hinting at interaction.

Linking sensors to the reactions 
Here, you must decide what exactly will make the reactions occur. Will sound play when the 
surfer clicks the on/off switch of an object, or will you decide that it will play automatically at 
the sixth second?
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In the rocket launch example, a mouse sensor is applied to the big button. The left mouse button 
trigger is linked to the first four reactions. The MouseOver trigger is linked to the switching of 
materials.

Using Handles 
There are a number of common reactions that come with default sensors to set them off. They 
are called handles. Handles provide a quick and easy way to create common interaction, such as 
moving and scaling objects or various WebCam operations. 

The rocket launch example contains an orbit WebCam handle so that the surfer can orbit the 
WebCam around the World.

Refining Interaction
Once you create interaction, you can modify it in several ways:

• Edit the triggers. The trigger is what will actually start the reaction, such as clicking the 
sensor with the left mouse button or moving the mouse over the sensor. In the rocket launch 
example, the button material turns red on MouseOver. The MouseOver trigger could be 
edited in several ways. By default, the color returns to its original settings as soon as the 
mouse leaves the button, but it could be made to stay glowing red.

• Edit the cursors.

• Edit the reaction parameters. Each reaction comes with default values, which can be edited. 
For example, when orbiting a WebCam, you can choose to allow the surfer to orbit only 
horizontally.

Grouping Interaction
As you start creating more complex interaction, the ability to group several reactions is practical. 
It makes linking several reactions to multiple sensors much faster.

For example, if you want to add other sensors that could launch the rocket, the reactions that 
form the rocket launch could be grouped to make their linking easier.
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The Interaction Editor
The Interaction Editor provides a schematic view of the interaction in your World. It makes it 
easy to link, unlink, and organize sensors and reactions. 

When working on interaction, you can drag the Interaction Editor out of its docked position. To 
dock it again, double-click the title bar.

To display reaction, sensor, or trigger parameters:

In the Interaction Editor, click the box or line representing the reaction, sensor, or trigger.

Its parameters appear in the Parameter Editor.
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To link reactions and sensors:

1. In the Interaction Editor, expand the sensor.

2. Click and drag from a trigger to a reaction. 

You can also SHIFT-select the trigger and reaction and choose Interaction > Link Reaction, or 
press CTRL+L.

To unlink reactions and sensors:

Click and drag the link node.

You can also SHIFT-select the trigger and reaction and choose Interaction > Unlink Reaction or 
press CTRL+U.

To filter the display in the Interaction Editor:

Right-click the Interaction Editor, choose Display, then choose an option from the menu:

All Displays all sensors and reactions.

Selected Only Displays only selected sensors and reaction.

Selected and Linked Only Displays selected sensors and reactions as well as any 
sensors or reactions that are linked to them.

Include Unlinked Reactions Displays reactions that are not linked to a sensor.

Click to expand
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Interaction in the Sequencer
The Sequencer displays all sensors that are linked to reactions. You can use it to test and edit the 
timing of various reactions.

For example, when you click the red button, four reactions occur: the rocket takes off, the red 
button is depressed, the rocket emits particles, and a clicking sound plays. By dragging the 
reactions left or right in the sequencer, you adjust the timing of each one. 

To display reactions in the Sequencer:

Expand the sensor and trigger that is linked to the reaction.

1 second later, rocket takes off

0 second later, button goes down and click sound plays

0.5 seconds later, particle animation starts

Surfer clicks big red button

Show Interaction

Sensor

Reaction
Trigger
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To display the animation curve for a Play Animation reaction:

1. Double-click the animation sequence. Now you can adjust the timing of individual keys. 
Click and drag keys to edit them in the Sequencer.

2. To hide the animation curve, double-click it again.

To preview a Play sound reaction:

1. To display the sound waveform, double-click the Play Sound reaction .

2. To listen to the sound, click the Activate trigger icon, then turn on Play or drag the playhead.
When the Activate trigger icon is green, you can preview sound and animation.

Double-
click to 
expand/
collapse

Activate 
trigger 
icon

Waveform
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To adjust the timing of reactions:

Click and drag the reactions in the timeline. For PlayAnimation reactions, if the animation curve 
is displayed, you must double-click the animation to hide the animation curve, before you can 
drag the PlayAnimation reaction. 

The trigger’s time delay is updated.

To preview reactions:
Click the Activate reaction icon to make it green, then turn on Play, or drag the playhead.

For more information, see “Play Animation Reaction” on page 201, and “Play Sound Reaction” 
on page 204.

Activate trigger icons
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Creating Reactions
Reactions can be animations, sounds, color changes, shape switches, and so on, all waiting to be 
triggered. The following sections describe the different reactions available and how to create 
them.

Available reactions are listed in the Interaction menu.

Play Animation Reaction
This reaction converts an animation into a reaction. The animation becomes inactive until it is 
triggered.

The Play Animation reaction is far reaching since almost everything can be animated in AXEL, 
from WebCam FOV to a light’s intensity; from the weight of various constraints to the color of 
the background color.

To create an animation reaction:

1. Create an animation. See Chapter 6, “Animation.”
The animation appears on the Sequencer. When you switch to Browse mode, the animation 
plays automatically.

2. Select the animation in the Sequencer.
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3. Choose Interaction > Reactions > Play Animation.
The animation becomes inactive. It no longer appears in the Animation view of the 
Sequencer, but it appears in the Interaction Editor.

The reaction is also listed in the World Explorer, under Resources / Reactions.

When you switch to Browse mode, the animation no longer plays. For the animation to play, 
it has to be launched by a sensor.

4. Link the reaction to a sensor.
Now you can preview and edit the animation in the Interaction view of the Sequencer. For 
more information, see “Interaction in the Sequencer” on page 198.

Example: Play Animation
In this example, animate the scaling of a sphere and convert it into a Play Animation reaction. 
Link the reaction to a sensor so that the animation plays when the surfer clicks a cube with the 
left-mouse button.

Create a reaction:

1. Animate the scaling of a cube growing bigger over a couple of seconds.
When you turn on Play, the cube grows bigger.

2. To convert the animation into a reaction, select the animation, then choose Interaction > 
Reactions > Play Animation. 
The animation appears in the Interaction Editor. It is a reaction waiting to be triggered. In the 
Parameter Editor, notice how the animation is no longer active. If you turn on the Play button, 
the animation does not play back.
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Link a sensor to the reaction:

1. Create a sphere and translate it to side of the cube. 

2. With the sphere selected, choose Interaction > Sensors > Mouse. 
A mouse sensor appears in the Interaction Editor.

The mouse sensor is also listed in the World Explorer under the sphere.

3. Expand the mouse sensor, then click and drag from OnLeftClick to PlayAnim.

4. Switch to Browse mode to test the interaction. Click the sphere using the left mouse button 
to launch the scaling animation.

Mouse Sensor 
on Sphere
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Play Sound Reaction
This reaction plays a .wav file. Keep in mind that sound files can be extremely heavy, so you 
should save the file with the following settings: 8-bit, 11 025, Mono .wav recordings. 

A Play Sound reaction can be set in three different ways: 

• If you create the reaction with nothing selected, it is simply added to the resource bank, 
waiting to be linked, and it is visible in the Interaction Editor.

• If you select an object then create the reaction, a sensor is added to the object and the reaction 
is linked to it. The sensor is set to OnLeftClick.

• If you select a trigger then create the reaction, the reaction is linked to the trigger.

To create a Play Sound reaction:

1. Choose Interaction > Reactions > Play Sound.

2. In the Open dialog, select a .wav file and click OK.
The sound file is copied to the Sound folder in the project directory.

If you select a sound file that is already used in the project, you are prompted to overwrite 
the existing file. Click No to use the existing sound file. Click Yes to update the existing 
sound file.

3. Select the reaction and adjust its parameters in the Parameter Editor.

To remove a Play Sound reaction:

In the Interaction Editor, select the reaction and press DELETE.
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To preview a Play sound reaction:

1. In the Sequencer, expand the sensor and trigger that is linked to the reaction.

2. To display the sound waveform, double-click the Play Sound reaction .

3. To listen to the sound, click the Activate trigger icon, then turn on Play or drag the playhead.
When the Activate trigger icon is green, you can preview sound and animation.

Play Sound Reaction Parameters

Looping Plays the sound over and over again.

Activate trigger icon

Waveform
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Set Parameter Reaction
This reaction is useful for setting a particular value for one parameter, for instance, the emission 
rate of particles.

Use Set Parameter to instantly modify a parameter. 

Note: The difference between the Set Parameter and Toggle Parameter reactions is that Set Parameter 
sets the parameter to a new value, whereas Toggle Parameter enables you to alternate between two 
different values.

To create a Set Parameter reaction:

1. In the World Explorer, expand an object and select a parameter.

2. Choose Interaction > Reactions > Set Parameter.
A reaction is created without affecting the current value of the parameter. 

3. In the Interaction Editor, select the Set Parameter reaction.

4. In the Parameter Editor, enter new values for the reaction.

Set Parameter Reaction Parameters

Example: Turning a light off

1. Select a light’s Turned On parameter and choose Interaction > Reactions > Set Parameter. 

2. Select the reaction in the Interaction Editor, and set the value to No in the Parameter Editor. 

3. Link the reaction to the background mouse sensor.

4. Switch to Browse mode to test the interaction. When you click the background, the light goes 
off.

Additive If Additive is turned off, Value replaces the parameter value when the re-
action is launched. If Additive is turned on, Value is added to the param-
eter’s value when the reaction is launched. 

Value The parameter will be set to this value when the reaction is launched.
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Toggle Parameter
Use the Toggle Parameter reaction to switch an object’s parameter between two values. For 
example, toggle the emission rate of particles between 0 and 100, or toggle a light on and off. In 
the following illustration, the duck is animated along two paths. A Toggle Parameter reaction is 
applied to the Active parameter of each path animation: when you press the red switch, the duck 
jumps from one path to another.

To create a Toggle Parameter reaction:

1. In the World Explorer, select the parameter you want to toggle.

2. Choose Interaction > Reactions > Toggle Parameter. 

3. In the Interaction Editor, select ToggleParam.

4. In the Parameter Editor, adjust its parameters.

Toggle Parameter Reaction Parameters

Example: Turning a light on and off

1. Select a light’s Turned On parameter and choose Interaction > Reactions > Toggle Parameter. 

2. In the Interaction Editor, select the reaction. In the Parameter Editor, set the Start value to Yes 
and the Stop value to No. 

3. Link the reaction to the background mouse sensor.

4. Switch to Browse mode to test the interaction. Click the background to toggle the light on 
and off.

Start value The value of the parameter the first time you trigger the reaction.

Stop value The value after the next time you trigger the reaction. Each time you ac-
tivate the trigger, the parameter value toggles between the Start value 
and the Stop value.
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Set WebCam Reaction
This reaction switches to a different WebCam. By switching to a WebCam with different 
parameters, you can change the point of view, the background color, or any other WebCam 
parameter.

To create a set WebCam reaction:

1. Select a WebCam from the World Explorer.

2. Choose Interaction > Reactions > Set WebCam.

3. Link the reaction to a sensor.
When the sensor is triggered, the WebCam will switch to the one you selected.

Set Pose Reaction
This reaction makes an object revert to saved position, orientation and scale values. This 
reaction is useful for resetting an object with a translate, rotate, or scale handle: the Set Pose 
reaction could make the object return to its initial position and size after a surfer manipulates it 
on the web page.

To create a Set Pose reaction:

1. Select an object.

2. Set the object to the position, orientation, and scale values that you want it to switch to.

3. Choose Interaction > Reactions > Set Pose.

4. Link the reaction to a sensor. For example, link the Set Pose reaction to the Middle Mouse 
button.

5. To test the interaction, add a translate handle to the object. Select it and choose Interaction > 
Handles > Translate.

6. Switch to Browse mode (press CTRL+B), and drag the object to move it, then activate the 
sensor, for example, by clicking the middle mouse button.
The object jumps back to the position you specified in step 2.
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Set Material Reaction
This reaction swaps one material for another. This allows you to switch from one color to 
another, or use its parameters (glow, transparency). As well, you can use this reaction to swap 
textures, since a material can support a texture. 

In the following illustration, the original material contains the texture with “ON” and the second 
material contains the texture with “OFF”.

To create a Set Material reaction:

1. Make sure you have at least one object with a material applied, and a second material, either 
on another object or under Resources / Materials in the World Explorer.

2. Multi-select the object and the material it should switch to.

3. Choose Interaction > Reactions > Set Material.
When the reaction is triggered, the object’s material is set to the material you selected in 
step 2.
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Set Geometry Reaction
This reaction swaps the geometry of one object for another, for example, from a cube to a sphere 
or an ant to an elephant. The two objects do not have to have the same number of points. When 
the reaction is launched, the first object takes the shape of the second object. In many cases, you 
hide the second object.

Note: This is different from a Shape animation, where a shape changes over time, or a Switch Shape 
animation, where a shape changes as you move the object. See “Shape Mixing” on page 189 and “Shape 
Animation” on page 190.

To create a Set Geometry reaction:

1. In the World Explorer, expand the two objects. For example, to change a cube into a sphere, 
expand the cube and the sphere.

2. Multi-select the objects. First select the object whose shape will change (the cube), then 
SHIFT-select the geometry of the second object (the sphere).

3. Choose Interactions > Reactions > Set Geometry.

4. Link the reaction to a sensor.
When the reaction is launched, the sphere becomes a cube.
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Tooltip Text Reaction
The Tooltip Text reaction creates a text box over an object, by default with a MouseOver Sensor. 
This allows you to display information, hints, warnings, and so on. You can edit the tooltip text 
and color at any time.

To create a Tooltip Text reaction:

1. Select an object.

2. Choose Interaction > Reactions > Tooltip Text.

3. Enter text in the Text Entry dialog that appears.
In Browse mode, when you move the cursor over the surface, the tooltip appears. In the 
Interaction Editor, a new Tooltip reaction is linked to a new Mouse Sensor on the selected 
object. By default, the mouse-over trigger is used. 

To edit the tooltip text or color:

Select the Tooltip reaction in the Interaction Editor and modify its parameters in the Parameter 
Editor.

Tooltip Parameters

Text The text that pops up in the tooltip.

Text color The color of the text. Enter an RGB value or click the color chip and 
select a color.

Background color The color of the box around the tooltip text. Enter an RGB value or 
click the color chip and select a color.
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Hyperlink Reaction
This reaction places a hyperlink on the object. For example, by clicking on a character, you 
could go straight to the character’s home page.

You can enter absolute or relative URLs. A relative URL is relative to where the host web page 
is stored. The host web page is the HTML file containing the AXEL object. 

For example, you could use the following URLs in a Hyperlink reaction:

• ./nextpage.htm or nextpage.htm links to an HTM file in the same directory as the host web 
page.

• ../nextpage or subdirectory/nextpage.htm links to an HTM file in a subdirectory of the host 
web page directory.

Absolute URLs must start with http:// For example:

http://www.MindAvenue.com

Note: In some cases, it may not be convenient to code hyperlinks in the 3D content. You may prefer to 
manage all the hyperlinks in the html page. To do this, you can use the Call JavaScript reaction instead 
of the Hyperlink reaction. In the JavaScript code (which resides in the html page), you could set the 
desired hyperlink. See “Call JavaScript Reaction” on page 218.

The JavaScript and Hyperlink reactions support all types of URLs, including:

• World wide web

• JavaScript

• File

• ftp: download/upload files

• Mailto

• News 

• Gopher 

The reaction can be set in three different ways: 

• If you create the reaction with nothing selected, it is simply added to the resource bank, 
waiting to be linked.

• If you select an object then create the reaction, a sensor is added to the object and the reaction 
is linked to it. The sensor is set to OnLeftClick.

• If you select a trigger then create the reaction, the reaction is linked to the trigger.

ZWEB_UG.book  Page 212  Wednesday, April 18, 2001  1:51 PM



Interaction 213

To create a Hyperlink reaction:

1. Choose Interaction > Reactions > Hyperlink.

2. Enter the hyperlink that you want the reaction to open, and click OK. 

3. Link the reaction to a sensor, and save a sample web page to test the interaction.
When the reaction is launched, the browser opens the specified link.

4. Select the reaction and adjust its parameters in the Parameter Editor.

5. To test the reaction, publish the World and open the sample web page in a web browser. For 
more information, see Chapter 8, “Web Integration.”

Hyperlink Reaction Parameters

URL The address to which you want to link.

Open in new 
window

Makes the link open in a second window.
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Download AXEL Stream Reaction
This reaction downloads an AXEL stream file.

Use this reaction to:

• Replace one stream file with another. For example, play a teaser animation then replace it 
with a larger World that takes longer to download. You can also replace the stream file with 
itself to refresh the 3D content on a page without downloading it again.

• Merge one stream file into another, adding information without changing the URL.

• Substitute geometry, or texture files in the current stream file with new elements from another 
stream file. For example, you could change the hubcaps on a car: clicking a button would 
download a stream file with four different hubcap textures.

The reaction can be set in three different ways: 

• If you create the reaction with nothing selected, it is simply added to the resource bank, 
waiting to be linked.

• If you select an object then create the reaction, a sensor is added to the object and the reaction 
is linked to it. The sensor is set to OnLeftClick.

• If you select a trigger then create the reaction, the reaction is linked to the trigger.

To create a Download AXS reaction

1. Choose Interaction > Reactions > Download AXEL Stream.

2. Enter the name of the stream file that you want the reaction to download.

3. Link the reaction to a sensor. Select the reaction and adjust its parameters in the Parameter 
Editor.

To create a teaser animation:

1. Create a small teaser World and a larger World.

2. In the larger World, turn off streaming for all the objects, textures, and sounds that you want 
to see when the larger World is first displayed. If an object’s streaming is off, AXEL waits 
for that object to download before displaying the World. Since the teaser will be playing 
while the larger World is downloading, you may want to turn off streaming for all objects, 
textures and sounds; that way the larger World will interrupt the teaser only when everything 
is downloaded. Publish the larger World to create the larger stream file.

3. In the teaser animation, choose Interaction > Download AXEL Stream.

4. In the Download AXEL stream dialog, enter the name of the larger stream file.
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5. Select the Download AXEL Stream reaction and set the mode to Replace.

6. Link the Download AXEL Stream reaction to a Browser Sensor / OnFinalDownload event.

7. Publish the teaser.
When the surfer downloads the teaser, the Download AXEL Stream reaction is triggered and 
AXEL starts downloading the larger stream file. While the web surfer is viewing and 
interacting with the teaser, the larger world is downloading.

For more information on streaming, see “About Streaming” on page 259.

To use Download AXS to refresh the 3D AXEL content in a web page:

1. Create a DownloadAXS reaction, that downloads the current World. For example, in 
MyWorld.AXEL, create a DownloadAXS reaction to download MyWorld.AXS.

2. Set the reaction parameter to Replace.

3. Link the reaction to a sensor.
When the sensor is triggered, the DowloadAXS reaction does not download MyWorld.AXS 
again; instead, it reloads it, thus refreshing the current content.

Download AXS Reaction Parameters

Replace The downloaded World replaces the current World with another. 

Note: If the DownloadAXS reaction is set to download the current World, the stream 
file is not downloaded again, instead, it is reloaded, thus refreshing the current 
content.

Merge The downloaded World is merged with the current World. This is similar 
to merging projects in Author mode.

Substitute Downloads a second World, and replaces identically named geometry 
and textures.
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Go to Time Reaction
This reaction moves the animation to the specified time. For example, by clicking a button you 
could fast forward to time 100, where a new animation starts. The Go to Time reaction only goes 
forward. When the reaction is launched, it will only occur if the Go to Time is later than the 
current time.

It can be set in three different ways: 

• If you create the reaction with nothing selected, it is simply added to the resource bank, 
waiting to be linked.

• If you select an object then create the reaction, a sensor is added to the object and the reaction 
is linked to it. The sensor is set to OnLeftClick.

• If you select a trigger then create the reaction, the reaction is linked to the trigger.

To create a Go to Time reaction:

1. Go to the time that the reaction will go to. Use the time controls, or drag the playhead.

2. Choose Interaction > Reactions > Go to Time.

3. Link the reaction to a sensor. 
When the reaction is triggered, the World goes forward to the selected time.

4. To adjust the time, select the reaction and adjust the Target time in the Parameter Editor.

Go to Time Reaction Parameters

Target time The time the World goes to when the reaction is triggered.
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Control Time Reaction
Starts or stops the World’s clock.

Example: Stopping the clock

1. Open a project with animations, and/or sensors spread over time. You can also create a simple 
animation to try out this reaction.

2. Choose Interaction > Reactions > Control Time.

3. In the Interaction Editor, link the Control Time Reaction to the background mouse sensor, 
then select the link that joins them.

4. In the Parameter Editor, set the Trigger mode to Stop or Toggle.

5. Switch to Browse mode to test the interaction. When you click the background, the 
animations stops, since time is no longer running. If the Trigger mode is Toggle, then you can 
click again to restart the clock.
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Call JavaScript Reaction
This reaction calls a JavaScript when launched. To call a JavaScript function, the function has 
to be defined in the host web page or be a standard one. For example, alert(message) is a 
standard method of JavaScript window object, as long as myOnClick()is a function defined in 
your host web page, you can type: alert("Hello") or myOnClick()

The JavaScript and Hyperlink reactions support all types of URLs, including:

• http
• JavaScript
• file
• ftp: download/upload files
• mailto
• news 
• gopher

To create a reaction that runs JavaScript:

1. Choose Interaction > Reactions > Call JavaScript.

2. Enter the JavaScript that you want to run and click OK.

3. Link the reaction to a sensor, and save a sample web page to test the interaction.
When the reaction is launched, the browser executes the JavaScript.

Call JavaScript Reaction Parameters

URL The JavaScript to run when the reaction is launched.
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Linking Sensors to Reactions
Once you create reactions, you must decide what exactly will make the reactions occur. Will the 
sound play when the surfer clicks the on switch or will it play automatically at the sixth second? 
Will a reaction be triggered by a mouse-over? At a certain time? When the surfer clicks the door? 
By linking a sensor to a reaction, you determine what will activate it. 

For example, if you want to click the big red button to launch the rocket, the sensor is the mouse, 
and the reaction is the rocket animation.

The following sections describe available sensors and how to link them to reactions.
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Available Sensors 
The Interaction menu displays all available sensors except for the keyboard sensors. These 
appear in the resource bank and in the Interaction Editor.

Mouse sensor Launches a reaction when the surfer clicks objects in the World. You 
can also apply a mouse sensor to the background or empty parts of the 
World.

Time sensor Launches a reaction at a specific time.

Proximity Launches a reaction when one object gets close to another.

Position Launches a reaction when an object is in a specific position.

Orientation Launches a reaction when an object is in a specific orientation.

Parameter 
Change

Launches a reaction when a parameter changes by more than a speci-
fied tolerance.

Parameter 
Range

Launches a reaction when a parameter value enters or exits a given 
range.
Use this sensor with parameters for which you can specify a range, 
such as Position, Subdivision, Smoothness, and so on. The parameter 
range sensor does not work if you cannot specify a range for the pa-
rameter, for example, a light’s Turned On parameter, object Coloring, 
and so on.

Time Pulse Specifies a Start/End time, and a frequency at which a reaction will be 
launched.

Download Launches a reaction when an object’s geometry, or a sound or texture 
file download is complete. 

Refresh Rate Launches a reaction when the refresh rate changes to a value above or 
below a target in refresh rate.

Keyboard 
sensor

Launches a reaction when the surfer presses a letter on the keyboard. 
These sensors are not in the Interaction menu; they appear in the Inter-
action Editor.
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Mouse Sensor
The mouse sensor is one of the most intuitive sensors since the surfer is used to clicking objects 
on the screen. 

You can use the Left, Middle, or Right Mouse button, or MouseOver to launch a reaction.

You can also use a background mouse sensor. This is useful for navigation, such as orbiting and 
panning.

If you add an orbit WebCam handle, for instance, it will appear under the background mouse 
sensor. If you have both types of sensors in a World, surfers will be in WebCam Orbit mode until 
they happen to go over an object with a sensor, at which time the WebCam Orbit mode will be 
temporarily deactivated to enable that object’s own sensor.

You can also edit the cursor type of a mouse sensor, changing the default cursor to an arrow, a 
cross, or a hand to better indicate the interaction to the surfer.

To create a mouse sensor:

1. Select an object.

2. Choose Interaction > Sensors > Mouse.
A new mouse sensor appears in the Interaction Editor.

3. In the Interaction Editor, expand the sensor and do one of the following:

• Click and drag from a mouse sensor trigger to a reaction to link them.

• SHIFT-click a mouse sensor trigger and a reaction, then press CTRL+L to link them.

4. Switch to Browse mode to test the interaction.
When you click the object, the reaction is launched.
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Time Sensor
A time sensor launches a reaction at a specific time, in seconds. For example, you could make 
something move at second 4 to alert the surfer of the possibility of interaction, or start making 
noise at second 8.3.

To apply a time sensor:

1. Stop playback and go to the time at which you want the reaction to occur.

2. Choose Interaction > Sensors > Time.

3. Link the sensor to a reaction. In the Interaction Editor, expand the time sensor, then click and 
drag from a time to a reaction to link them.

4. To adjust the time at which the reaction should occur, select the time sensor, then enter a new 
time in the Parameter Editor.

5. Switch to Browse mode to test the Interaction. The reaction occurs after the number of 
seconds you specified. 

To delete a time sensor:

Select it in the Interaction Editor, and press DELETE.
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A-Z Key Sensor
You can use the letter keys on the keyboard to launch reactions.

For example, a surfer could press the R key to return to the original setting, or press A to point 
a spot light at an apple, or press Z to point a spot light at a zebra.

To create a keyboard sensor:

1. In the Interaction Editor, expand the A-Z sensor.

2. Click and drag from a letter to a reaction to link them.

3. Switch to Browse mode to test the interaction. Press the letter you specified to launch the 
reaction.

Arrow Key Sensor
You can use the arrow keys on the keyboard to launch reactions.

To create an arrow key sensor:

1. In the Interaction Editor, expand the arrow key sensor.

2. Click and drag from an arrow key to a reaction to link them.

3. Switch to Browse mode to test the interaction. Press the ARROW key you specified to launch 
the reaction.
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Proximity Sensor
A proximity sensor launches a reaction when one object enters or exits a certain distance from 
another object. For example, when Krazee Bob approaches the Welcome mat, the Saloon doors 
open.

To create a proximity sensor:

1. Multi-select two objects and choose Interaction > Sensor > Proximity.
A proximity sensor appears in the Interaction Editor.

2. Expand the proximity sensor and select the event you want to use:

3. Click and drag from the event to a reaction to link them.

4. Select the proximity sensor and adjust its parameters in the Parameter Editor.

5. To test the sensor, add a translate handle to one of the objects, then switch to Browse mode 
and drag one object close to the other to launch the reaction. 

Proximity Sensor Parameters

OnEnterProximity Launches a reaction when the objects approaching each other 
come within the limit distance. 

OnExitProximity Launches a reaction when the objects moving apart exit the limit 
distance. 

Limit The distance in units at which the reaction is launched.
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Position Sensor
The position sensor launches a reaction when an object reaches or leaves a specific position. For 
example, moving a coin into a slot could play a sound. 

To create a position sensor:

1. Select an object then choose Interaction > Sensors > Position.
A position sensor appears in the Interaction Editor.

2. Expand the position sensor and select the event you want to use:

3. Click and drag from the event to a reaction to link them.

4. Select the position sensor and adjust its parameters in the Parameter Editor.

5. To test the sensor, add a translate handle to the object, then switch to Browse mode and drag 
the object into position to launch the reaction. 

Position Sensor Parameters

OnEnterPos Launches a reaction when the object arrives at the critical position.

OnExitPos Launches a reaction when the object leaves the critical position.

CriticalPos Position at which the object launches a reaction.

Tolerance The reaction can occur as long as the object is close to the critical posi-
tion. The Tolerance determines how close the object has to be to launch 
the reaction. For example, if Tolerance is 3 units, the reaction occurs 
when the object is 3 units from the critical position.
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Orientation Sensor
An orientation sensor launches a reaction when the object is at a specific orientation in degrees. 
For example, a door, opening more than 15 degrees could trigger a chime sound.

To create an orientation sensor:

1. Rotate an object into the desired position, then choose Interaction > Sensors > Orientation.
An orientation sensor appears in the Interaction Editor.

2. Expand the orientation sensor and select the event you want to use:

3. Click and drag from the event to a reaction to link them.

4. Select the orientation sensor and adjust its parameters in the Parameter Editor.

5. To test the sensor, add a rotate handle to the object, then switch to Browse mode and drag the 
object to launch the reaction. 

Orientation Sensor Parameters

OnEnterOri Launches a reaction when the objects arrives in at the Critical orienta-
tion.

OnExitOri Launches a reaction when the objects leaves the Critical orientation.

Critical 
orientation

Orientation at which the object launches a reaction.

Tolerance The reaction can occur as long as the object is close to the Critical ori-
entation. The Tolerance determines how close the object has to be to 
launch the reaction. For example, if Tolerance is 3 degrees, the reaction 
occurs when the object is 3 degrees from the Critical orientation.
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Parameter Change Sensor
This sensor launches a reaction when a parameter changes by more than a certain amount.

To create a parameter change sensor:

1. Select a parameter then choose Interaction > Sensors > Parameter Change.
A parameter change sensor appears in the Interaction Editor.

2. Expand the sensor.

3. Click and drag from OnParamChange to a reaction to link them.

4. Select the parameter change sensor and adjust its parameters in the Parameter Editor.

Parameter Change Sensor Parameters

Parameter Range Sensor
This sensor launches a reaction when a parameter falls inside or outside of a range. 

To create a parameter range sensor:

1. Select a parameter then choose Interaction > Sensor > Parameter Range.
A parameter range sensor appears in the Interaction Editor.

2. Expand the sensor and select the event you want to use:

3. Click and drag from the event to a reaction to link them.

4. Select the parameter range sensor and adjust its parameters in the Parameter Editor.

Parameter Range Sensor Parameters

Tolerance Determines how much the parameter can change before the reaction is 
launched.

OnParamInRange Launches a reaction when the parameter falls between the 
Min and Max values.

OnParamOutOfRange Launches a reaction when the parameter falls outside of the 
range specified by the Min and Max values.

Min The low end of the range.

Max The high end of the range.
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Time Pulse Sensor
This sensor launches a reaction at a certain frequency between the start pulse and the end pulse.

The following triggers are available:

Time Pulse Sensor Parameters

Download Sensor
This stands for On Download Complete, and uses the completion of the download of geometry, 
a sound file, or a texture as a sensor. 

For example, if you have a character with a reaction that moves his lips to accompany his sound 
file, you could link the On Download Complete of the .wav file to the reaction that makes the 
character talk.

On First Pulse Launches the reaction once at the Start Pulse time.

On Last Pulse Launches the reaction once at the End Pulse time.

On Inter Pulse Launches a reaction at a given frequency between the Start Pulse time 
and the End Pulse time. The reaction does not occur on the Start or End 
Pulse times. For example, if the Start Pulse is 2 seconds, the End Pulse 
is 10 seconds, and the Frequency is 2, the reaction will occur every 2 
seconds from second 4 to second 8.

On Pulse Launches a reaction at a given frequency from the Start Pulse time to the 
End Pulse time inclusively. For example, if the Start Pulse is 2 seconds, 
the End Pulse is 10 seconds, and the Frequency is 2, the reaction will 
occur every 2 seconds from second 2 to second 10.

Start The time in seconds of the first pulse. 

End The time in seconds of the last pulse. 

Frequency The interval in seconds between the pulses. For example, to launch the 
reaction every 5 seconds, use an On Pulse trigger and set the frequency 
to 5. Frequency must be greater than 0.

Pulse skipping Skips a pulse when the reactions cannot keep up with the frequency. 
When the sensor detects that 2 or more reactions should have been trig-
gered since the last pulse time, it only launches one reaction if Pulse 
Skipping is on. If Pulse Skipping is off, it launches all the reactions as 
many times as it should have occurred. Pulse Skipping is on by default.
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Refresh Rate Sensor
This sensor launches a reaction when the refresh rate increases above a target value or decreases 
below a target value. For example, if an animation goes from 20 frames per second to 10 frames 
per second when some complex geometry appears in the World, the refresh rate sensor could 
sense the drop in refresh rate and launch a reaction that hides the complex geometry.

Refresh Rate Sensor Parameters

Target 
Refresh Rate

When the refresh rate changes, if it moves above or below the target, 
the reaction is launched.
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Using Handles
Use handles to create common interaction in one quick step. When you create a handle, a 
reaction and a sensor are automatically created and linked. When you switch to Browse mode, 
you can use the handle to manipulate the object or WebCam to which it was applied. Handles 
are available for manipulation and navigation tools.

Translate Handle
A translate handle enables you to translate an object or group in Browse mode. 

To apply a translate handle to an object: 

1. Select the object.

2. Choose Interaction > Handles > Translate.
In the Interaction Editor, a translate reaction is linked to a mouse sensor. By default, the 
trigger is set to OnLeftClick.

3. Switch to Browse Mode (CTRL+B) to test the interaction. Move the cursor over the sphere 
in WebCam view. You will see the cursor change to a hand icon. Click the left mouse button 
and drag. You will be interactively positioning the sphere.

4. To modify the handle, you can select the translate reaction and adjust its parameters, or select 
the mouse sensor and adjust its parameters, or multi-select the sensor and the reaction and 
then edit the trigger.

Translate Handle Parameters

Type Limits the translation to a specific direction.

Override 
other effects

Determines how the handle reacts if the object is affected by other forc-
es.

Mix with other 
effects

Uses the Weight parameter to calculate all forces affecting the object’s 
position while translating. 

Mixing weight Determines the weight, percentage-wise, of the handle in relation to oth-
er forces on the object.
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Invert joints Enables two-directional behavior of joint constraints and inverse kinemat-
ics. Is interesting in a case involving pin or ball joints (and inverse kine-
matics). In the case of an arm, pulling on the handle (a hand) will cause 
the shoulder to follow.

Throw object Allows an object with a position handle to be thrown by the user, by 
clicking, dragging and releasing the object.

Throwing 
resistance

Determines how much it will travel when released.

Snap unit Snaps the object to a 3D grid whose spacing is determined by the snap 
unit. When snap unit is 0 (the default value), the object does not snap to 
a grid.
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Rotate Handle
A rotate handle enables you to rotate the object or group in Browse mode. You can choose an 
axis and a tilt/turn mode in the rotate handle parameters since 3D rotation can be hard to control.

To apply a rotate handle to an object: 

1. Select the object.

2. Choose Interaction > Handles > Rotate.
In the Interaction Editor, a rotate reaction is linked to a mouse sensor.

3. Switch to Browse Mode (CTRL+B) to test the interaction.

4. To modify the handle, you can select the RotateObject reaction and adjust its parameters, or 
select the mouse sensor and adjust its parameters, or multi-select the sensor and the reaction 
and then edit the trigger.

Rotate Handle Parameters

Type Options are roll, tilt, turn, tilt/turn, X, Y, Z, or free (the default).

Rotation pivot Determines the axis around which the object rotates.

Override 
other effects

The handle overrides other forces affecting on the object.

Mix with other 
effects

Determines how the handle reacts if the object is affected by other forc-
es.

Mixing weight Determines the weight, percentage-wise, of the handle in relation to oth-
er forces on the object.

Snap unit Snaps the object to a 3D grid whose spacing is determined by the snap 
unit. When snap unit is 0 (the default value), the object does not snap to 
a grid.
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Scale Handle
A scale handle enables you to scale the object or group in Browse mode.

Scale Handle Parameter

About Mixing Effects and Mixing Weight
Assume you have a hammer that is pose-constrained to a giant magnet. Its position parameter is 
controlled entirely by that relation. If you add a position handle to the hammer and try to move 
it, it will not budge!

You can modify this with the handle parameters. If you enable “Override other effects” while 
you are clicking and dragging the hammer, you are disabling the pose constraint. As soon as you 
release the hammer, it will re-activate the pose constraint and the hammer will return on the 
magnet.

Enabling “Mix with other effects” allows you to have both the pose constraint and the position 
handle active at the same time. The mixing weight determines the relative weight of each effect 
on the hammer’s position. If you set the handle’s mixing weight to 20, and the pose constraint 
is at its default mixing weight of 100, the pose constraint will be more powerful. So, clicking 
and dragging the hammer will only inch it away from the magnet. If you set the handle to 300, 
you will hardly notice the magnet’s effect.

Type You can edit the scaling to be X, Y, Z, uniform or free (the default).

Preserve scale 
volume

Maintains the object’s volume when you scale it along one or two axis. 
For example, if you shrink a cone along the X axis, it gets taller so that 
its volume remains the same.

Override 
other effects

Determines how the handle reacts if the object is affected by other forc-
es.

Mix with other 
effects

Determines how the handle reacts if the object is affected by other forc-
es.

Mixing weight Determines the weight, percentage-wise, of the handle in relation to oth-
er forces on the object.

Snap unit Snaps the object to a 3D grid whose spacing is determined by the snap 
unit. When snap unit is 0 (the default value), the object does not snap to 
a grid.
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Push Handle
This handle allows you to push vertices inwards in Browse mode.

Push Handle Parameters

Contact radius Determines how close the cursor has to be to the surface before 
the Push takes effect.

Deformation radius Determines a distance around the contact point that defines the 
portion of the surface that is affected by the deformation.

Push depth Determines how much the surface is pushed in.

Push speed In Determines how fast the surface deforms when you drag your 
cursor. 

Push speed out Determines how fast the surface bounces back to its original 
shape.
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Bend Handle
This handle allows you to bend the surface in Browse mode. It is similar to the Bend option in 
the Modeling menu.

Bend Handle Parameters
The following parameters define the bend.

Origin Determines where the bend's angle and region originate. By default it 
is the surface's center. A value of 0, -5, 0 would start the bend from 
the base of this particular cylinder instead of the middle.

Axis Determines around which axis the bend will take place. The default 0, 
0, 1 makes the surface bend around the Z axis.

Minimum angle Smallest amount you can bend the surface. 

Maximum angle Largest amount you can bend the surface. 

Minimum bend 
region

Number (in units) away from the origin that the bend takes effect.

Maximum bend 
region

Number (in units) away from the origin that the bend stops taking ef-
fect.

Bend speed in Determines how fast the surface bends when you drag it. 

Bend speed out Determines how fast the surface bends back to its original shape. 

Maximum bend 
region limit

Angle Origin

Minimum bend 
region limit
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Orbit WebCam Handle
The orbit WebCam handle allows the surfer to move the WebCam around its interest point, as 
you do in Author mode. This handle uses the background sensor’s OnLeftClick trigger as a 
default.

Orbit WebCam Parameters

Rotate WebCam Handle
The rotate WebCam handle is different from the orbit WebCam handle since here the WebCam 
stays put as it rotates around. This handle uses the background sensor’s OnLeftClick as a default 
sensor.

Rotate WebCam Parameters

Type Determines how the surfer can orbit. It can be horizontal, vertical, hori-
zontal and vertical, or free

Override 
other effects

The surfer’s action overrides any animation or constraints affecting the 
WebCam.

Mix with other 
effects

Combines the surfer’s action with any animation or constraints affecting 
the WebCam.

Mixing weight Determines the relative strength of the handle compared to any anima-
tion or constraints affecting the WebCam.

Type Options are Roll (around the WebCam’s Z axis), Tilt (from top to bottom), 
Turn (left to right), Tilt and Turn, and Free.

Override 
other effects

The surfer’s action overrides any animation or constraints affecting the 
WebCam.

Mix with other 
effects

Combines the surfer’s action with any animation or constraints affecting 
the WebCam.

Mixing weight Determines the relative strength of the handle compared to any anima-
tion or constraints affecting the WebCam.
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Translate WebCam Handle
The translate WebCam handle allows you to pan the WebCam (or to move in or out). This handle 
uses the background sensor’s OnLeftClick as a default sensor.

Translate WebCam Parameters

Zoom WebCam Handle
The zoom WebCam handle allows you to move in or away from the WebCam’s interest. (You 
are not changing the WebCam’s FOV, but its position.) This handle uses the background sensor’s 
OnLeftClick as a default sensor.

Type You can edit the translate to Horizontal, Vertical, Front/Back or Free.

Override 
other effects

The surfer’s action overrides any animation or constraints affecting the 
WebCam.

Mix with other 
effects

Combines the surfer’s action with any animation or constraints affecting 
the WebCam.

Mixing weight Determines the relative strength of the handle compared to any anima-
tion or constraints affecting the WebCam.
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Refining Interaction
You can refine interaction by changing cursor types, editing triggers, and adding triggers that 
control reactions.

Changing Cursor Types
When the surfer moves the mouse over a sensor, the cursor changes to indicate that there is 
interaction in the World. When you create a sensor, a cursor is assigned by default. You can 
change the cursor at any time.

To change the cursor:

1. In the Interaction Editor, select the sensor.

2. In the Parameter Editor, select a cursor type from the list.
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Linking and Unlinking Sensors and Reactions
You can change the interaction after you create it. For example, you can link more reactions to 
a sensor, unlink a sensor, or unlink any number of reactions from any number of sensors.

To link reactions to sensors:

1. In the Interaction Editor, multi-select the sensor and the reaction that you want to link. To 
multi-select, CTRL-click each one.

2. Choose Interaction > Link, or press CTRL+L.

To unlink reactions and sensors:

1. In the Interaction Editor, multi-select the sensor(s) and the reaction(s) that you want to 
unlink. To multi-select, CTRL-click each one.

2. Choose Interaction > Unlink, or press CTRL+U.

To unlink a reaction from all linked sensors:

1. In the Interaction Editor, select the reaction.

2. Choose Interaction > Unlink Reaction from All, or press CTRL+L.
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Editing Triggers
The trigger defines exactly what happens when a sensor launches a reaction. There is a default 
trigger for every interaction. For example, when you link a mouse sensor to an animation 
reaction, by default, the animation starts when you click the mouse. But you can change this in 
several ways:

• The animation could start the first time you click, then stop on the next click, then continue 
on the next click and so on.

• The animation could freeze when you click.

• The animation could start 2 seconds after you click, or it could start when you SHIFT-click.

• The animation could be triggered only once, for example, launching a rocket.

To edit a trigger:

1. In the Interaction Editor, multi-select the sensor and the reaction or select the link that joins 
them.

2. In the Parameter Editor, adjust the trigger parameters.
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Trigger Parameters

Trigger on For mouse, keyboard, and arrow key sensors, determines at what point 
the reaction occurs:
Down: it occurs when you click the mouse button or key.
Hold: it occurs as long as you hold the mouse button or key.
Release: it occurs when you release the mouse button or key.

Modifier key For mouse, keyboard, and arrow key sensors, the surfer has to press 
SHIFT, CTRL, or CTRL+SHIFT with the sensor to launch the reaction.

Expiry count The maximum number of times that a trigger can be set off. For example, 
if a honking sound plays when a surfer clicks a horn, an expiry count of 
10 means the surfer can honk the horn 10 times.

Time delay The delay in seconds before the reaction occurs after it has been trig-
gered. For example if the delay is 1, the honking sound plays 1 second 
after the surfer clicks the horn.

Repeat delay The number of seconds that must pass before the reaction can be trig-
gered again. For example, if the repeat delay is 2, the surfer can honk the 
horn every 2 seconds. Even if he clicks repeatedly, the sound plays only 
if 2 seconds elapsed since the last time it played.

Trigger mode Determines what happens when the sensor is triggered:
Start: starts the reaction.
Stop: ends the reaction.
Toggle Start/Stop: toggles the reaction on and off.
Toggle Stop/Start: toggles the reaction off then on.
Activate: allows the reaction to be triggered by other sensors.
Deactivate: prevents the reaction from being triggered by other sensors.
Toggle Activate/Deactivate: toggles between allowing and preventing 
the reactions from being triggered by other sensors. See “Using a Trigger 
to Control a Reaction” on page 242.
Toggle Deactivate/Activate: toggles between disallowing and allowing 
the reactions to be triggered by other sensors.

Start mode For Play Animation reactions, when the Trigger mode is set to Start, the 
Start mode determines how the reaction starts:
Restart: the animation starts from the beginning.
Continue: the animation starts where it last stopped.

Stop mode For Play Animation reactions, when the Trigger mode is set to Stop, the 
Stop mode determines what happens when the reaction is stopped: 
Pause: the animation stops and stays in its current state.
Go to beginning: the animation stops and is reset to the first key.
Go to End: the animation goes to the last key.
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Example: Editing the Trigger on a Position Handle
Take the example of the position handle, where an object is interactively translated when the 
surfer left-clicks and drags the object. By selecting the trigger link in the Interaction Editor, the 
trigger parameters appear in the Parameter Editor. You can add a Shift modifier key to the 
trigger. In Browse mode, the surfer must click on the SHIFT key while pressing the left mouse 
to translate the object.

Using a Trigger to Control a Reaction
Normally a reaction occurs when the surfer triggers it. For example, a door opens when you 
click the handle. You can use an Activate/Deactivate trigger to add another condition to the 
reaction occurring. For example, clicking the handle opens the door only if the surfer clicks a 
key first. 

Use Activate triggers to apply multiple manipulations on the same object. For example, clicking 
an object could launch different animations, depending on what you did previously.

Example: Use a key to control the reaction of a door opening when you click it

1. Create an animation of a door opening. Select the animation, and choose Interaction > 
Reactions > Play Animation.

2. Add a mouse sensor to the doorknob, and link it to the Play Animation reaction.

3. Switch to Browse mode to test the interaction.
When you click the knob, the door opens.

4. Deactivate the reaction at time 0. Link Time Sensor / Time 0 to the Play animation reaction, 
then select the trigger and set the Trigger mode to Deactivate.
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In the Interaction Editor, notice the trigger is red to indicate that it deactivates the reaction. 
Also notice the icons are different from other triggers.

5. Switch to Browse mode to test the interaction.
When you click the knob, nothing happens because the reaction was deactivated as soon as 
the World opened at time 0.

6. Now, use a key to activate the Play animation reaction. Create an object to use as a key, and 
add a mouse sensor to it.

7. Link the mouse sensor on the key to the Play animation reaction. Select the trigger and set 
the Trigger mode to Activate.
Notice the trigger color and icon indicate that it is in activate mode.

8. Switch to Browse mode to test the interaction.
Click the doorknob. Nothing happens because at time 0, the reaction was deactivated. Now 
click the key. This activates the Play animation reaction. Now when you click the doorknob, 
the door opens.
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Grouping Reactions
You can group reactions to facilitate their linking and create different triggering modes. This 
makes it easier to assign multiple reactions to one or more sensors. For example, in a museum, 
touching any painting could trigger the same three reactions: a siren, a flashing light, and a red 
beam of light shining on that particular object.

You could group the three reactions and link them to various sensors (one per painting, for 
example).

By default, all the reactions in a group are launched simultaneously when the sensor is set off. 
This is called the triggering mode. You can change the triggering mode to launch the reactions 
one after another, one by one in random order, or with cycle. 

For example, you can link a baseball hitting the neighbor’s house to a group reaction containing 
three Play Sound reactions: breaking glass, a thud, and a scream. By default, when the baseball 
hits the house, all three sounds play at once. You can decide to have them play one at a time, 
randomly, or with a cycle. This can help make certain reactions less predictable and repetitive.

To group reactions:

1. Create two reactions.

2. In the Interaction Editor, multi-select the reactions and choose Interaction > Group Reactions 
or press CTRL+G.

3. You can rename the Group.

4. In the Interaction Editor, expand the Group to view its reactions.

5. Select the group reaction and adjust its parameters in the Parameter Editor.
This determines the sequence in which your reactions will play.

Group Reaction Parameters
Trigger mode:
• All at once: All reactions play at once.

• Solo – Random: Only one reaction will play every time the group reaction is triggered. The 
reaction is chosen randomly.

• Solo – In order: When triggered a first time, the first reaction will play. When triggered a 
second time, the second will play. This goes on until all reactions have played. Any 
subsequent triggering will have no effect.

• Solo – Cycled in order: All reactions will be played in order, one per triggering. When all 
reactions have been triggered, it returns to the first reaction and continues the cycle 
indefinitely.
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Chapter 8

W e b  I n t e g r a t i o n

Use the commands in the Web Integration menu to 
embed your 3D World in a web page so that anyone 
who opens the host web page can view and interact 
with your 3D World.

When you are ready to publish your World, save it in 
a .axel project file (.axel), then publish it to create a 
host web page and a stream file. 

The stream file is like an embedded image file: you 
can cut and paste it anywhere on the page or into 
another web page.

To edit the host web page, open the project in AXEL 
and edit the 3D content, or open the web page in a 
web editor and modify the HTML code. 

In AXEL, you can display the host web page in a 
viewport and edit the 3D World in context. 

To practice web integration in AXEL, refer to 
Lesson 1, “The Plane,” and Lesson 13, “Publishing 
the Fish,” in the AXEL Tutorials.

In this chapter:

About Published Files  246

Publishing  247

Previewing the World 
in a Host Web Page  252

Modifying a Web Page  253

Adding 3D Content to an 
Existing Web Page  254

Exporting Parameters  255

Exporting Reaction 
Triggers  257

Controlling Performance 
and Download Time  258

Batch Save AXEL 
Stream Files  262

Publishing Settings  263

ZWEB_UG.book  Page 245  Wednesday, April 18, 2001  1:51 PM



246 Chapter 8

About Published Files
When you save an AXEL project file (a .axel file), you are saving the environment in which you 
built geometry, animation, interactions, materials, and so on. You can open this file at any time 
to preview or modify your 3D World.

For web surfers to enjoy your 3D World, you publish it in a stream file that is then embedded in 
an HTML web page that surfers can view in a web browser.

The host web page and the AXEL stream file are saved in the project directory along with the 
project file. 

The stream file contains all the information required by the AXEL player to display your World 
in a web page. It bundles all the geometry, textures, sounds, reactions and animations into one 
file. You cannot edit a stream file but you can edit the project used to create it, then publish a 
new stream file from the edited content.

The AXEL player must be installed on surfers’ machines for them to see the 3D content in web 
pages. If the AXEL Player is not installed, surfers are prompted to download it from the address 
given in the HTML file.

Note: When you publish a World, unused textures and sounds are not included in the stream file.

Host web page

Project file
Stream file
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Publishing
To view your 3D content on the web, you must create a stream file and a host web page in which 
the stream file is embedded. You use the publishing settings to determine how the 3D content 
appears on the host web page:

• You can set the size of the 3D window in the web page. For example, set the 3D window to 
200 by 300 pixels, or set it to 25% of the width and 33% of the height of the page.

• You can make the content windowless so that it appears on a transparent layer in front of the 
page. For example, you could make 3D characters walk on top of text on a web page. 

• You can make 3D objects cast shadows on the web page and you can adjust the color and 
position of the shadows.

• You control the layering order, or Z-index, of the different layers in a web page. For example, 
you can indicate if a 3D character should be walking over or under a company logo.

Creating a Stream File and a Host Web Page
To publish you work, you create a stream file and a host web page.

To publish a stream file and embed it in a host web page:

1. Save the project in the directory you want to use for the project file, the stream file, and the 
web page. Chose File > Save, then select a folder and name for the AXEL project file.
The stream file and the host web page will be saved in the same folder in the following steps.

2. Choose Web Integration > Publish.
The Publishing Setting dialog appears.

3. Enter a name for the Stream file.

4. Enter a name for the Host Web Page file. To publish the AXEL stream in an existing host web 
page, click the browse button, navigate to the location of the host web page you want to use, 
and select it. The selected web page is copied to your project directory.

5. Set the size of the 3D window or, to create windowless content, turn on Windowless and 
adjust the windowless settings. See “Setting the Size of the 3D Window in a Web Page” on 
page 248. 

6. Click Publish to save the stream file and the host web page.

Note: You can also click OK to accept the publishing settings and use them the next time you want to 
publish the World.
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7. To save the project, choose File > Save.
The publishing settings are saved with the AXEL project file. If you want to edit the 3D 
content of a host web page later on, you will need the AXEL project file that was used to 
create it.

8. To preview the host web page in AXEL, right-click a viewport and turn on Host Web Page. 

9. To preview the host web page in web browser, choose Web Integration > Preview in IE or 
Preview in Netscape.

Setting the Size of the 3D Window in a Web Page
The 3D content appears in a window in the host web page.

Since the content is not rasterized, it can be enlarged or reduced. You can set the width and 
height of the 3D window as a number of pixels, a percentage of the web page, or you can set it 
to the WebCam viewport size.

The window size can also be modified in the HTML file by editing the width or height.

Note: The 3D content can also be windowless and float on top of the web page. See “Publishing 
Windowless Content” on page 249.

To set the size of the 3D window:

1. Choose Web Integration > Publishing Settings.

2. Turn off Windowless.

3. Do one of the following:

• Click and drag the WebCam viewport to the size you want, then click Get Webcam Size in 
the Publishing Settings dialog. The 3D Window Width and Depth are set to the size of the 
WebCam viewport.

• In 3D Window Width, enter the width in pixels or as a percentage of the web page width. In 
3D Window Height, enter the height in pixels or as a percentage of the web page height.

In the host web page, the 3D content will appear in a window of this size.
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Publishing Windowless Content
You can publish windowless content that floats on top of your web page; you can adjust its 
transparency, Z-index, and shadows.

Note: Results vary depending on the web browser. For more information on the browser plugins that 
give the best results, refer to the FAQs on the MindAvenue Support page. 

In the following illustration, Krazee Bob is seen first in the AXEL authoring software, walking 
on the default black background. Then, when published as windowless content, he walks on top 
of the page. The background is removed, revealing the rest of the web page.

Windowless publishing is processor-intensive and can slow down performance. There are 
several techniques available for improving performance, the most important for windowless 
publishing is Clipping. For more information, see “Download Time and Performance on the 
Surfer’s Machine” on page 260, and “Clipping” on page 261.
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To publish windowless content:

1. Choose Web Integration > Publishing Settings.

2. Turn on Windowless, then adjust the Transparency, Z-index, and Shadow settings.
When the World is published, the web page becomes its background. In Browse mode and in 
host web page view, a gray border appears to indicate the border of the 3D window.

Transparency
Transparency allows you to make the 3D objects in your AXEL World transparent, revealing the 
underlying web page. When transparency is 0%, you can see through the background but you 
cannot see through the 3D objects. When transparency is 50%, the 3D objects are semi-
transparent.

Windowless settings
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Z-index
In a web page, when several layers are superimposed, the Z-index (“z” is for depth) determines 
their order, from front to back. In the following illustration, Krazee Bob is walking over the text; 
in the illustration on the left, his Z-index is higher than that of the text. On the right, we wanted 
him to appear under the text, so we reduced his Z-index.

When publishing AXEL content, the default Z-index is 0. You can modify Z-index in the 
Publishing Settings dialog before publishing your World. You can also change the Z-index in 
the HTML file after the stream file is published.

Netscape version 4 browsers handle layers differently than Internet Explorer or later Netscape 
versions. Netscape 4 does not respect the Z-index style parameter. Instead, the sequence in 
which the layers appear in the HTML code determines their background-to-foreground order. 
The layer whose element (usually a DIV) is placed first in the HTML will be in the background, 
subsequent layers will be closer to the front, and the layer whose element is coded last will be 
in the foreground. 

In order to create layered pages that display correctly in all browsers, it is necessary both to 
include Z-index style parameters and to make sure that the layers are coded in sequence from 
back to front. 

Z-index is not supported with IE and Macintosh. Therefore the windowless content always 
appears in front. With Netscape and Macintosh, you can change the sequencing within the 
source to get desired results.

Cast Shadow
You can also cast shadows, creating a drop shadow of a transparent object on the rest of the web 
page.
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Previewing the World in a Host Web Page
You can display a host web page inside an AXEL viewport. The host web page acts like a frame 
in which the current 3D World is displayed as you work on it. 

The 3D window in the host web page is a WebCam view of the current World. You can 
manipulate objects, zoom, pan, and orbit in the 3D window. As you modify objects, you see how 
they will look in a web page.

When you are satisfied with the 3D World inside the host web page, you must publish it to 
update the stream file in the actual web page.

To preview the current 3D World in a host web page:

1. If you have not done so, publish the World to create a web page and a stream file. See 
“Publishing” on page 247.

2. Choose Web Integration > Publishing Settings to verify the name of the web page. If you 
published more than one web page from the current World, open the web page that you want 
to use as a host web page.

3. Right-click a viewport and turn on Host Web Page.

4. The web page selected in the Publishing Settings dialog is displayed as a host web page in 
the viewport.

Current project directory. 

Click here to select the web page 
to use as a host web page.

The web page to use as a host web 
page. This is also the web page that 
will be updated when you click 
Publish.
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Modifying a Web Page
There are several ways to change a web page that contains an embedded stream file:

• You can modify the 2D content on the page in a web editor. For example, you can change the 
layout, the fonts, the text, the links, and any other 2D content on the page.

• You can change the way the 3D content appears on the page in AXEL or in a web editor. For 
example, you can change the size of the 3D window, or make the 3D content windowless.

• You can edit the 3D content in AXEL. For example, remodel objects, add more interaction, 
fine-tune animation, and so on.

To change a web page containing 3D content:

1. Open the AXEL project file (.axel) used to create the 3D content.

2. Choose > File Publishing Settings, and select the web page you want to change.

3. To change the way the 3D content appears on the web page, adjust the window size or 
windowless settings. See “Publishing Settings” on page 263.

Note: You can also open the page in a web editor and modify the embedded object code.

4. To edit the 3D content, modify the objects, interaction, animation and so on.

5. Click Publish.
The stream file and web page are updated. 

6. To preview the result, right-click a viewport and turn on Host Web Page.

7. To change the 2D content, open the page in a web editor and edit the HTML code. In AXEL, 
press F5 to refresh the host web page.

8. Choose File > Save to save the new 3D content and the new publishing settings.
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Adding 3D Content to an Existing Web Page
You can add 3D content to an existing 2D web page.

To add 3D content to an existing web page:

1. Choose Web Integration > Publishing Settings.

2. In the Host Web Page field, browse to the web page you want to use and select it.

3. Adjust the window size or windowless settings.

4. Click Publish.
The web page you selected in step 2 is copied to the current publishing directory, and the 
embedded object tag that references the stream file is added to the end of the copied file.

5. To change the location of the 3D content in the page design, open the web page in a web 
editor and cut and paste the AXEL object code to another place on the page.

Note: You can cut and paste the embedded object code from a web page created in AXEL to any other 
web page.
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Exporting Parameters
You can export AXEL parameters to a button on your web page. Exported parameters can also 
be manipulated by scripts embedded in the web page. From the color of an object to the intensity 
of a light, any parameter can be exposed to the surfer.

In the following illustration, the light’s color parameter and the shadow material’s transparency 
parameter were exported. When published, they appear on the web page. For the spot light color, 
the surfer can choose red, green, or blue.

For the shadow transparency, the surfer can type a value between 0 and 100. The changes take 
effect when the surfer moves the cursor into the 3D window.

Note: The Export Parameter feature is not supported by Internet Explorer on Macintosh, which does not 
allow plugins scripted with JavaScript.

To export a parameter:

1. In the World Explorer, select the parameter. You can select a parameter under any WebCam, 
object, material, or geometry.

2. Choose Web Integration > Export Parameter.

3. In the World Explorer, expand Resources / Web Parameters to display the exported 
parameters.

4. Rename the parameter to give it the name that you want to display on the web page. You can 
also edit the parameter name in a web editor after you publish the World.

5. Publish the World, then open the web page in a web editor, or right-click a viewport and turn 
on Host Web Page. 
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The web page contains controls to change the parameter. Depending on the parameter, the 
surfer might have to type a number or select it from a selection of box.

The parameter controls are provided as an example. They can be connected to other parts of 
the web page using JavaScript.

Note: The host web page communicates with the AXEL player through the exported web parameters. 
JavaScript finds the AXEL object through the id value in the <object> tag or the name value in the 
<embed> tag. When you modify the host web page html file, make sure the name matches the name your 
JavaScript functions use to call SetWebParam() and GetWebParam().
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Exporting Reaction Triggers
Exporting reaction triggers creates buttons in the host web page; by clicking the buttons, the 
surfer launches a reaction.

To export a reaction trigger:

1. In the Interaction Editor, select the reaction you want the surfer to trigger from the web page.

2. Choose Web Integration > Export Reaction Trigger.
The new trigger is listed in the World Explorer, under Resources / Web Parameters. The name 
of the trigger will become the label of the buttons on the web page. To rename it, click the 
name twice, then type a new name. 

3. To publish the World, choose Web Integration > Publish. 

4. To preview the result in AXEL, right-click a viewport and turn on Host Web Page. To 
preview the result in a web browser, choose Web Integration > Preview in IE or Preview in 
Netscape.
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Controlling Performance and Download Time
You can use various techniques to improve performance. For example, the clip box improves 
performance by only displaying a portion of the World.

You can use various techniques to reduce download time.

You can use download time estimates and download simulation to forecast how long it will take 
to download the content to the surfer’s machine.

To view download time estimate:

Choose Web Integration > Download Time Estimates.

To simulate the download with different connections:

1. Choose Web Integration > Download Simulation, then choose the connection speed you want 
to simulate.

2. Switch to Browse mode.
AXEL simulates downloading the stream file before displaying the World. 

About Anti-Aliasing
Anti-aliasing removes the jaggies that you see on diagonal lines. 

Anti-aliasing improves the quality of your images but can slow down display rate. Anti-aliasing 
does not increase the weight of an object but it requires processing power to smooth the jaggies. 
If your audience is viewing your web page on a slower computer, the objects may take a little 
longer to display. If your content contains animation, the anti-aliasing may slow down the 
playback speed.

To see the result of anti-aliasing, you must turn on anti-aliasing for the viewport and for the 
object.

Without 
anti-aliasing

With
anti-aliasing

ZWEB_UG.book  Page 258  Wednesday, April 18, 2001  1:51 PM



Web Integration 259

To turn on anti-aliasing:

1. For each object that you want anti-aliased, select the object and turn on Anti-Aliasing in the 
Parameter Editor.

2. Right-click the WebCam viewport and turn on Anti-aliasing.

About Streaming
You can make surface geometry, textures, and sounds streamable so that the web page can be 
displayed before all the 3D content is downloaded.

In the following illustration, Krazee Bob is in a room, pondering which door to open. Behind 
each door is a closet filled with junk about to fall on him. The surfer does not see this since the 
door has yet to be opened, so valuable time is being wasted by waiting for all this to download. 
This example explains the rationale behind streaming.

Without streaming, the 3D window would only appear once all the content (every object, every 
texture, every sound file) was downloaded. This could take some time—downloading content 
that is not even visible, sounds that may only be triggered a minute later by the surfer, textures 
on objects that you cannot see yet, and so on.

In the previous example, the default download behavior is the following:

The initial display time is 20 seconds. AXEL waits until all geometry, interaction, and animation 
is downloaded, and sends low-resolution versions of texture files. Then the page opens. As the 
surfer is watching or interacting, from second 20, sound files and full-resolution texture files 
will continue downloading. The download is complete at second 57.

The default may not be satisfactory. For example, you may want the wooden barrel texture on 
Krazee Bob to appear immediately at full resolution, while the car and all the junk behind the 
door stream in. You can change the default behavior by making specific objects streamable. You 
can also set the streaming priority to control which objects are streamed first.
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To turn on streaming of geometry, textures, or sound files:

1. In the World Explorer, expand and select the element you want to modify.

2. In the Parameter Editor, turn on/off Streamable.

3. Select the Streaming priority.
A low-resolution version of a streamed geometry (such as a null geometry) is inserted at the 
beginning of the axs stream. When the geometry is displayed in a web page, the low resolution 
geometry is downloaded first, then the real geometry is displayed as soon as it is downloaded.

Textures or sound files are streamable by default. If you want them to be downloaded 
immediately, turn off Streamable.

Geometry is not streamable by default. If you have a large object that does not appear 
immediately, you should turn on its Streamable parameter so that it does not hold up the display 
of your web page.

If you experiment with streaming, you will find that you can sometimes significantly reduce the 
initial display time by streaming parts of your World, especially textures and sounds. You can 
compare the download time estimates and the time at which they appear to the surfer (remember 
to choose which connection you are using in your Time Estimates).

Download Time and Performance on the Surfer’s Machine
Download time is affected by:

• The connection the surfer has to the Internet.

• The file size of the stream file (.axs). This file size is affected by the quantity of geometry, 
but most of all by texture files and sounds. This is why it is important to pare down your 
image files to the smallest acceptable size. The same is true about sound files. Look at the 
file size of the various .bmp files and .wav files to get an idea of what is contained in a stream 
file. AXEL uses compression for both sound files and textures so, depending on the actual 
file, you can expect significant reduction.

Not to be confused with download time, performance is how the content will actually perform 
on the surfer’s machine.

The performance of your content on the surfer’s machine is not something you can fully control, 
since it depends on the processor and graphic card, and it is not necessarily affected by the same 
factors that slow down download times. You can get an idea with the grading of your refresh rate 
in your World (press I), but it can vary from one machine to another.
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The performance is affected by the quantity and complexity of geometry to be displayed on 
screen. Thus very complex geometry with large textures will significantly lower refresh rate, 
while sound files, which are heavy to download, will not affect it.

Multiple lights or large quantities of particles can slow down performance, since they require 
more processing power, but are insignificant in terms of download time. 

Clipping
Clipping is the process through which AXEL only calculates a certain part of the 3D space, as 
defined by a clip box, thus improving performance.

Under normal circumstances, AXEL must look for and calculate anything within the WebCam’s 
viewing frustum. This can be a large amount of information.

The following illustration shows Krazee Bob walking on a plane, with a clip box attached to 
him. The first illustration shows how, without clipping, AXEL must calculate the whole 
WebCam view. The second shows clipping enabled, with AXEL only displaying the contents of 
the 3D clip box.

Note: The performance gain in using a clip box can be very useful if you are publishing windowless 
content.

To create a clip box:

1. Choose Visualization > Add ClipBox. 

2. Select the clip box from the viewports or the World Explorer. 

3. Choose View > Clipping or right-click in the WebCam and choose Clipping.
By default, the clip box is a 1-unit cube. The clip box can be edited, animated and constrained 
like any other object. 

4. Adjust the clip box:
• Scale it to view a larger area.
• Pose-constrain it to a moving object so the clip box follows the target around.
• Scale or animate the clip box to create fades or transitions.
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Batch Save AXEL Stream Files
You can publish a batch of stream files using a text file. This is useful for upgrading a series of 
Worlds to a new version.

To batch save AXEL stream files:

1. Create a text file containing, one per line, the author file (with its full path) and the name and 
path of the published file. The number sign (#) in front of a line will ignore it in the batch 
saving.

2. Choose Web Integration > Batch Publish, and select the text file.

3. If any errors occur, AXEL will notify you and refer you to a .log file listing the files that it 
could not save.
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Publishing Settings
The following table provides a quick overview of the publishing settings. You should read the 
procedures in this chapter, then refer back to this table as needed.

To display the Publishing Settings dialog:

Choose Web Integration > Publishing Settings.

Publishing 
directory

The folder that contains the project file, the stream file, and the web 
page. To change this location, choose File > Save As and save the 
project file to a new location.

Stream file The name of the stream file created when you click Publish. You cannot 
edit the stream file. To change it, you must change the 3D content in the 
project and publish it again. It is therefore important to save the project 
file used to publish a stream file. Use a file name allowed in JavaScript.

Host 
webpage file

The name of the web page in which the stream file will be embedded. 
The window settings described in the following rows determine how the 
stream file appears in the host web page. When you publish the World, 
the window settings and stream file are overwritten, but the 2D HTML 
content in the web page is not overwritten.
This is also the web page used to display a host web page in a viewport. 

Get webcam 
size

Makes the AXEL object in the web page the same size, in pixels, as the 
WebCam viewport. 

3D window 
width

Width of the 3D window in the web page. You can enter the number in 
pixels, or in % of web page size.

3D window 
height

Height of the 3D window in the web page. You can enter the number in 
pixels, or in % of web page size.

Windowless The 3D World appears directly on the web page. Its background is trans-
parent. Results vary depending on the web browser.

Transparency The transparency of the foreground 3D objects in windowless publishing. 

Z-index Determines the stacking order of the AXEL object on a web page that 
contains other graphics. Z-index is not supported by Internet Explorer on 
Macintosh.

Cast shadow Makes the 3D objects cast shadows on the web page.

Shadow 
darkness

Determines the color of the shadows.

Shadow 
offsets

Determines the distance between the shadows and the objects that cast 
them.
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Embedded Object Code
The following AXEL object code is generated automatically when you publish a stream file. 

Notice, the information is presented twice, first in an HTML 4.0 Object tag (used by Internet 
Explorer on Windows), and then in a Netscape Embed tag (used by Netscape and by Internet 
Explorer on Macintosh.) The information must be consistent between the two tags.

Understanding the Object tag
The Object tag is used by Internet Explorer on Windows to identify the AXEL object.

Attributes:
id: name used to locate the object in the HTML file. It must be unique in the file. The JavaScript 
created when you export parameters uses this name to find the object.

classid: tells the browser what registered application to use to process the object. This is a 
universally unique identifier for the AXEL player.

codebase: tells the browser to download the AXEL player from the MindAvenue web site if it 
cannot find it on the system.

style: this is the in-line Cascading Style Sheet (CSS). The properties are:

• position: affects the Top and Left properties. Position can be Absolute or Relative

• Top: distance from the top in pixels or percentage.

<!-- Begin AXEL object -->

<object id="Fish_stream" classid="CLSID:68A2C3BD-7809-11D3-8ACF-0050046F2F9A"
    codebase="http://www.mindavenue.com/Downloads/AXELPlayerAX_Win32.cab#version=1,0,793,0"
    style="position:absolute; left:5; top:100; z-index:1; filter:alpha(opacity=100)"
    width="700" height="500">
   <param name="Src" value="Fish_stream.axs">

<param name="Windowless" value="1">
   <embed src="Fish_stream.axs" name="Fish_stream"
       pluginspage="http://www.mindavenue.com/Downloads/AxelPlayerNPInstall.htm"
       type="application/x-MindAvenueAxelStream"
       style="position:absolute; left:5; top:100; z-index:1;"
       width=700 height=500 Windowless=true>
   </embed>
</object>

<!-- End AXEL object -->
Embed tag for Netscape
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• Left: distance from the left of the page in pixels or percentage.

• z-index: determines the layering order of the object. Increasing the index values brings the 
object to the front of other layers. 

• filter: the filter function creates transparency and shadows. You can use other DHTML filter 
functions in this tag.

• width: the width of the AXEL window in pixels or percentage.

• height: the height of the AXEL window in pixels or percentage.

param defines parameters used by the object. 

• The parameter called src has a value giving the AXEL stream file name. 

• The parameter called windowless has a value of 1 if the content is windowless, or 0 if the 
content is not windowless.

Understanding the Embed tag
The Embed tag is used by Netscape and Internet Explorer on Macintosh to identify the AXEL 
object.

Attributes
src: this is the AXEL stream file name.

name: this is a unique name used by JavaScript to find the object inside the HTML file.

pluginspage: if the browser cannot find the AXEL player on the system, it links to the 
MindAvenue Downloads page where the player can be found.

type: tells the browser what type of data the object contains, using a MIME (Multimedia Internet 
Mail Extensions) type. This allows the browser to select the AXEL player plug-in.

style: this is the in-line CSS. Its properties are:

• position: affects the Top and Left properties. Position can be Absolute or Relative.

• left: distance from the left of the page in pixels or percentage.

• top: distance from the top in pixels or percentage.

• z-index: determines the layering order of the object; this property is not supported inside 
the embed tag in Netscape.

• width: the width of the AXEL window in pixels or percentage.

• height: the height of the AXEL window in pixels or percentage.

• Windowless: displays the content on a transparent overlay. The value is True or False.
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Index

Numerics
1-bone limbs 93
2-bone limbs 94
3D models, importing VRML 19
3D space, overview 14

A
activating a reaction 242
Active parameter 112
Add Point command 70
Add to Group command 126
Ambient Color, lights 148
Angle

bend parameter 90
revolution parameter 81

animation
copying keys 179
curves 167
deleting animation track 179
editing keys 176
going to specific key 163
on path 187
particles 184
playing back 162
recording 170
Sequencer, described 164
shape 190
wave 188

Animation menu 36
Anti-aliasing

curve parameter 64
surface parameter 74
using 258

AXEL object code 264
axes

global vs local 14
translating in local 55

Axis
bend handle parameter 235
bend parameter 90
pin joint parameter 121
revolution parameter 81
slider joint parameter 125

B
background color 28
backups 20
ball joint constraint 122
Ball joint home angle 93
bend handle 235
blending texture and material 139
BMP, texture formats 144
bounding constraints

box 117
overview 117
sphere 119
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Box, bounding constraint 117

C
Call JavaScript reaction 218
capping

cylinders 78
extrusions 83
revolutions 81

Center mode 50
center, moving and rotating 59
classid, object tag attribute 264
Clip Box display option 26
clock, stopping 217
closing projects 17
codebase, object tag attribute 264
color

applying to vertices 133
blending with texture 139
changing a material’s 131
setting object’s 132

color, lights 148
Coloring, surface parameter 75
Constrain Orientation, pose constraint 

parameter 111
Constrain Position, pose constraint 

parameter 111
Constrain Scale, pose constraint parameter 111
Constrained Axis, ball joint constraint 

parameters 123
Constrained Direction, direction constraint 

parameter 112
Constrained Position, snap constraint 

parameter 114
Constrained Tangency, object to curve 

constraint parameter 116
constraints

applying 107
displaying 26
unlocking 108

construction views 23
Control Time Reaction 217
coordinate systems 14
copying

keys 179
parameters 89

Crease Angle Threshold, surface parameter 75
cursor, changing sensor cursor 238
curve editor, in animation 167
curve parameters 64
curves

adding points 70
creating 62
in path animation 187
inverting 72
modifying 69
opening/closing 72
removing points 70
simplifying 71
smoothness 69
steps 71
subdividing 71

cylindrical texture mapping 141

D
Damping, spring constraint parameter 115
default material 132
direction constraint 112
Display options 26
displaying

animation curves in Timeline 167
grid 29
windows, toolbars 21
wireframe or shade view 27

Distance
distance constraint parameter 113
object to curve constraint parameter 116

distance constraint 113
docking windows and toolbars 22
Download AXL reaction 214
Download sensor 228
Download simulation 258
download time

estimating 258
simulating 258

Draw Curve command 62
duplicating objects 61

E
Edit menu 31
editing triggers, interaction 240
embed tag, in AXEL stream 265
Emission Color, particles parameter 185
Emission Rate, particles parameter 185
Emission Size, particles parameter 185
Enable Angle Limits, pin joint parameter 121
Enable Crease Control, surface parameter 75
Enable Joint Limits, ball joint parameter 123
Enable Position Limits, slider joint 

parameter 125
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Enable Tangency, object to curve constraint 
parameter 116

End Capping
cylinders 78
extrusions 83
revolutions 81

End field 162
environment map, creating 143
extrusion

along curve 84
creating 82

F
faces, subdividing 86
fall-off distance, lights 149
Field of View, webcam parameter 154
File menu 30
formats,supported texture 144
frame controls, see time controls 162
Frame Selection command 157
Frozen parameter 75

G
Geometry Constrained, bounding constraint 

parameter 118
Get WebCam Size option 248
GIF, texture formats 144
global vs local axes 14
go to a time 162
Gravity, particles parameter 185
grid, displaying 29
groups, creating, modifying 126

H
handles

overview 230
height

cone 77
cylinder 78

Help menu 39
hiding

objects 54
windows, toolbars 21

highlight, lights 148
home angle, limbs 95
home state, limbs 95
horizontal plane 78
Hyperlink reaction 212

I
id, object tag attribute 264
Import command 19
Inside, bounding box parameter 118
Inside, bounding sphere parameter 119
installing AXEL 8
instancing 61
intensity, lights 148
Interaction

creating reactions 201
menu 37
sensors 219
triggers 240

interaction
controlling 242
handles 230

Interaction Editor, filtering information 197
interactive push 91
inverting

curves 72
surfaces 87

J
Joint Angle

ball joint parameters 123
pin joint parameter 121

Joint Constraints, described 120
JPEG, texture formats 144

K
Keyboard sensor 223
Keys 168
keys

adding, removing,copying 179
creating 168
editing 176
moving between 163
recording during playback 170

L
Length, extrusion parameter 83
lights

adding 147
overview 145
show/hide icon 148
turning on/off 148

Limb 1 parameters 93
limbs

home angle 95
home state 95
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Link Particles Obstacle command 185
linking

material to object 131
textures to objects 135

locking constraints 108
locking selections 55
Look at Origin command 158
Look at Selection command 157
loop playback 162

M
manipulating constrained objects 108
manipulating text 100
manipulating text overlay 102
material

blending with texture 139
default 132
described 130
linking to object 131
physical parameters 134

Maximum Age, particles parameter 185
Maximum Angle

bend parameter 91, 235
pin joint parameter 121

Maximum Bend Region, bend parameter 91, 
235

Maximum Limit Angle, ball joint 
parameters 123

Maximum Position Limit, slider joint 
parameter 125

Maximum Speed, particles parameter 185
menus

animation 36
edit 31
file 30
help 39
interaction 37
modeling 33
relations 34
view 32
visualization 35
web integration 38

Merge command 19
merging elements in stream files 214
Minimum Age, particles parameter 185
Minimum Angle

bend parameter 90, 235
pin joint parameter 121

Minimum Bend Region, bend parameter 91, 
235

Minimum Position Limit, slider joint 
parameter 125

Minimum Speed, particles parameter 185
mixing shapes 189
mixing weight, described 233
Modeling menu 33
Modify Curves commands 69
Mouse sensor 221

N
next key, going to 163
normals, inverting 87
nudge 53

O
Object mode 50
object parameters 73
object tag, AXEL stream 264
object to curve constraint 116
objects

duplicating 61
grouping 126
importing in VRML format 19
instancing 61
merging from other projects 19

objects, showing/hiding 54
obstacles, adding to particles 185
offset, adjusting constraints 108
offset, start time of animation sequence 172
opening projects 17
orbit webcam handle 236
orbiting the webcam 156
orientation

curve parameter 64
light parameter 148
offset, pose constraint parameter 111
sensor 226
surface parameter 74

orthogonal views 23

P
panning

in viewports 24
in WebCam view 156

param, object tag attribute 265
Parameter Change sensor 227
Parameter Editor, using 45
Parameter Range sensor 227
parameters

copying 89
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editing 45
Particle Shape, particles parameter 185
particles

adding obstacle 185
creating 184

path animation 187
pin joint constraint 120
planar texture mapping 141
planes, creating 78
Play Animation reaction 201
Play Sound reaction 204
playback, see time controls 162
playhead 165
Point mode 50
points

deleting from curves 70
described 16
display option 26
editing on curves 70
editing on surfaces 85

polygon surface, creating 79
pose constraint 111
Position

ball joint parameters 123
light parameter 148
object to curve constraint parameter 116
pin joint parameter 121
slider joint parameter 125
surface and curve parameter 64, 74

Position Offset, pose constraint parameter 111
Position sensor 225
preset surfaces 76
previous key, going to 163
primitives, see preset surfaces 76
project directory 18
Proximity sensor 224
push/pull handle 234

R
Radius, sphere geometry parameter 76
rationalize

pose, surfaces 88
scale and pose,curves 72
scale, surfaces 87
texture pose 143

reactions
controlling 242
creating 201
editing triggers 240
linking to sensors 219

recording
keys during playback 170
keys individually 168

redo command 31
Refresh Rate sensor 229
relations

menu 34
overview 105

Relative to Group, animation parameter 173
Remove from Group command 126
resizing windows 22
Rest Length, spring constraint parameter 115
revolution

creating 80
parameters 81

Roll Angle, extrusion parameter 83
Rotate handle 232
Rotate webcam handle 236
rotation

applying 56

S
saving projects 17
Scale

curve parameter 64
handle 233
surface parameter 74

Scaling
extrusion parameter 83
Offset, pose constraint parameter 111

scaling objects 58
scrubbing, animation 165
Selection Only display option 26
selections, locking 55
sensors, overview 219
Sequencer

adjusting time scale 164
described 164

Set Geometry reaction 210
Set Material reaction 209
Set Parameter reaction 206
Set Pose reaction 208
Set Webcam reaction 208
shape animation 190
shape mixing 189
shapes, see surfaces 73
simplifying

curves 71
surfaces 86

simulating download time 258
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single view, switching to 26
Single-sided, surface parameter 74
Size, cube geometry parameter 77
Skin command 96
slider joint constraint 124
smoothness

curves 69
surfaces 75

snap constraint 114
Snap to Grid option 29
sound, adding 204
sounds, file location 18
Speed Inheritance Factor, particles 

parameter 185
speed of animation 172
Sphere, bounding constraint 119
Spin Rate, particles parameter 185
splines, see curves 62
spot angle, spot lights 148
spot concentration, spot lights 148
Spread Angle, particles parameter 185
spring constraint 115
Start field 162
starting projects 17
Stats display option 26
stopping playback 162
stopping the clock 217
stream file

downloading 214
streaming objects 259
style, object tag attribute 264
subdividing

curves 71
surfaces 85

subdividing faces 86
subdivisions

cones 77
cylinders 78
planes 78
revolutions 81
spheres 76

surfaces
creating 73
inverting normals 87
modifying 85
subdividing 85

T
Target Orientation, snap constraint 

parameter 114

Target Position, snap constraint parameter 114
text

limitations 101
manipulating 100
positioning text overlay 102

texture paths 18
textures

applying to objects 136
blending with material color 139
linking to objects 135
supported image formats 144

texturing mode 139
time controls 162
Time field 162
Time Pulse sensor 228
Time sensor 222
Toggle Parameter reaction 207
tool modes 50
toolbars

described 40
showing/hiding 21

Tooltip Text reaction 211
Top Capping parameter

cylinders 78
extrusions 83
revolutions 81

transforms 50
transforms, along local axes 53
Transition Period, snap constraint 

parameter 114
Translate handle 230
translate webcam handle 237
translating objects 55
Trigger 240
triggers, editing 240
Turned On, light parameter 148

U
undo command 31
Ungroup command 126
unhiding objects 54
Unlink Reaction from All command 239
unlocking constraints 108
Use Selected Camera command 155

V
vertex color 133
vertical plane 78
View menu 32
Viewpoint options 25
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viewports
background color 28
displaying a grid,size of grid 29
overview 23
single/multi-view, switching 26

Visible
light parameter 148
objects parameter 64, 74

Visualization menu 35
VRML, importing 19

W
wave animation 188
Web Integration menu 38
webcam

constraining position 157
frustum 153
icon, showing/hiding 158
moving 156
orbiting 156
panning 156
pointing 157
zooming 155

WebCam view, described 23
weight of objects 16
Weight parameter, in constraints 109
width

cones 77
cylinders 78

windows, moving 21
Wireframe/Shade command 27
work area, customizing 21
World Explorer, using 43

Z
Z axis, described 14
Z-index,layers in web page 251
zoom

in Sequencer 164
in viewports 24
in WebCam view 155

zoom camera handle 237
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