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Welcome to
NetObjects Fusion 3.0 0

NetObjects Fusion™ 3.0 is a powerful Web site building tool that helps you design 

and build full-featured, professional Web sites—without knowing HTML, the 

HyperText Markup Language used to display pages on the Web. When you preview 

or publish a site, NetObjects Fusion automatically generates the HTML code your 

Web browser needs to display pages. 

This guide contains lessons with step-by-step instructions that provide the quickest 

path to learning how to build Web sites with NetObjects Fusion 3.0. 

This tutorial assumes you installed NetObjects Fusion as described on the 

NetObjects Fusion Installation and Quick Start card, and that you are familiar with 

your Microsoft® Windows® operating system and the basic concepts of the World 

Wide Web. 

The lessons in this guide ask you to imagine yourself designing a Web site for 

commercial use, and show you how to use some of NetObjects Fusion’s many 

features to add content to the site. 

Follow the steps in Chapter 1, “Building a Site in 10 Minutes,” to learn the basics of 

building a Web site with NetObjects Fusion 3.0. To do any of the remaining lessons, 

you must build the site described in Chapter 1.

Chapter 2, “Touring NetObjects Fusion,” shows you how to use the toolbars, 

palettes, and other development aids in NetObjects Fusion’s five views. The first two 

chapters are especially recommended if you are using the product for the first time.

The remaining lessons show you how to work with many of NetObjects Fusion’s 

new features, and are recommended for both novices and those upgrading from 

previous versions.
Welcome to NetObjects Fusion 3.0 vi
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Each chapter tells you if there is a previous requirement to do the lesson, and refers 

you to pages in NetObjects Fusion’s sample sites for more examples of the described 

feature.

Read Chapter 10, “What’s New in NetObjects Fusion 3.0?” to learn about the many 

features you’ll enjoy when building sites with this new, more powerful version of 

NetObjects Fusion.

If you created sites using previous versions of NetObjects Fusion, read Chapter 11, 

“Upgrading from Previous Versions of NetObjects Fusion,” to learn how to migrate 

your sites to NetObjects Fusion 3.0.

This guide presents all keyboard key names, user interface elements, file names, 

path names, extensions, HTML tags, and URLs (Universal Resource Locators) in 

boldface. Example names that you should replace with actual names appear in 

boldface italics. 

To learn more about NetObjects™ Fusion, see your NetObjects Fusion User Guide, 

check online Help, or visit the NetObjects Web site at www.netobjects.com.
vii Welcome to NetObjects Fusion 3.0

http://www.netobjects.com/
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Building a Site in 10 Minutes 1

You’re the Web site designer for Richter Brewing Company. To compete with the 

other micro breweries, Richter Brewing wants a Web site that reflects its personality 

and taste, shows off its products, and provides a channel for customer feedback. 

You’re going to use NetObjects Fusion 3.0 to build the site.

This chapter shows you how to:

● Start NetObjects Fusion

● Create a new blank site

● Add pages

● Add text

● Add a picture

● Set the SiteStyle

● Preview a site

● Save a site
Building a Site in 10 Minutes 1-1
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Creating a New Blank Site
You start with a new blank site.

1. From the Windows Start menu, select Programs, NetObjects Fusion 
3.0, or double-click the NetObjects Fusion 3.0 icon on the desktop.

The Welcome To NetObjects Fusion dialog appears. 

Here you choose whether to create a site from scratch or open an 
existing site. 

2. Select Blank Site, then click OK to display the New Blank Site dialog.

NetObjects Fusion will 
“Open to most recently 
used file at startup” if 
this option is set in the 
Preferences dialog.

Note: If NetObjects Fusion opens a site, from the File menu choose New 
Site, Blank Site to display the New Blank Site dialog.

User Sites folder

NetObjects Fusion site 
files have a .nod file 
name extension.
1-2 Building a Site in 10 Minutes



 

A D D I N G  P A G E S

                         

Tutorial.bk  Page 3  Tuesday, June 17, 1997  9:29 PM
This is where you name your site. NetObjects Fusion automatically saves 
your site in a folder with the same name as the site, inside the 
NetObjects Fusion 3.0\User Sites folder.

3. In the File name field, type Richter Brewing, then click Save.

Notice that NetObjects Fusion automatically appends .nod to the site’s 
name. 

You use NetObjects Fusion’s five views to develop your site. The control 
bar shows that Site view is selected. This is where you develop your site’s 
structure. 

A page icon represents each page in the site. Your new site has one 
page—the default Home page. The blue border shows it is selected.

The Properties palette shows the name of the selected object, in this 
case, the Home page.

For information on any Properties palette option, right-click the option 
label, then click the What’s This? pop-up.

Title bar with site name

Control bar with view buttons 
showing selected view

Navigation buttons

Tabs relating to this view
Select tool

Zoom tool

Properties palette

Page icon
Adding Pages
In Site view, you add pages. NetObjects Fusion automatically adds new pages under 

the selected page.
Building a Site in 10 Minutes 1-3
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You add a page for each of Richter Brewing Company’s award-winning beers, plus a 

page for customer feedback.

1. With the Home page selected, click the New button on the control bar 
five times, to add five pages.

NetObjects Fusion adds five pages under the Home page, and names 
each page Untitled.

The toolbar on the left shows the Select tool is selected. 

You can hold the pointer over a tool for a few moments to see a ToolTip. 
ToolTips tell you the name of each tool in every toolbar.

2. On the leftmost page, click Untitled to select the page name.

3. Type Lager, then press the Tab key to select the next page name.

4. Name the remaining four pages Stout, Porter, Ale, and Comments.

5. Press the Enter key to view the final page name on the Page tab of the 
Properties palette.

NetObjects Fusion shows as many characters as will fit on the page icon.

Selected page name

Select tool is selected

New button
1-4 Building a Site in 10 Minutes
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6. Double-click the Lager page icon to open the page in Page view.
Looking at Page View
Page view is where you design and add content to your pages. 

◆ Choose Grid from the View menu to turn off the default grid.

Page name

MasterBorder label

Layout label

MasterBorder Properties palette

Standard toolbar

Vertical Ruler

Page navigation buttons

Text navigation bar in 
Bottom MasterBorder

Name of this page’s 
MasterBorder

Banner showing page 
name in Top MasterBorder

Advanced toolbar

Button navigation bar 
in Left MasterBorder
Building a Site in 10 Minutes 1-5



A D D I N G  T E X T  T O  T H E  P A G E

Tutorial.bk  Page 6  Tuesday, June 17, 1997  9:29 PM
The Lager page opens in Page view. By default NetObjects Fusion 
displays the Standard and Advanced toolbars docked in the left window 
border, and the Properties palette showing properties of the selected 
item. 

You can drag toolbars away from the window border onto the 
workspace. You can drag the title bars of toolbars and properties palettes 
to move them, so yours might appear in a different place on the screen. 

Page view is divided into two areas: MasterBorder and Layout. 

The MasterBorder typically contains objects that repeat across many 
pages, such as navigation bars and banners. You can create and assign a 
MasterBorder to a range of pages to give them a consistent look. The 
Layout typically includes the page’s unique content.

To select the MasterBorder or Layout area, simply click inside it. When 
the MasterBorder is selected, its label is red; when the Layout is selected, 
its label is blue. The Properties palette always shows properties of the 
selected item.

The DefaultMasterBorder includes a banner in the Top MasterBorder, a 
button navigation bar in the Left MasterBorder, and one text navigation 
bar and the “Built with NetObjects Fusion” logo in the Bottom border. 
By default, navigation bars contain the names of all pages in the first 
level of the site, plus the name of the Home page.
Adding Text to the Page
You know that Richter Brewing’s Lager beer won an award in 1998, so you add text 

to showcase the Lager beer.

1. From the Standard toolbar, select the Text tool.

2. Drag a text box starting in the top left of the Layout area.

Don’t worry about the height of the box. As you type, the text box grows 
to accommodate the text, if needed.
1-6 Building a Site in 10 Minutes
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You can drag the 
Properties palette to 
move it, if necessary.

The text box appears with hollow handles and contains a blinking 
insertion point. The pointer changes to an I-beam when you move it 
over the text box, indicating that you can type text.

3. Type the following text:

You can select Undo 
from the Edit menu to 
undo any action since 
the last time you 
changed views.

Golden Gate Lager wins 1998 American Brewing Award!
Building a Site in 10 Minutes 1-7
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While editing text, the Text Properties palette displays the Format tab, 
with options such as Font, Size, and Color that you can use to format 
selected text.

4. Click outside the text box.

The text box automatically adjusts to the size of the text, and the hollow 
handles disappear.

If necessary, to turn on 
object outlines, select 
Object Outlines from 
the View menu.

An outline surrounds the text.

5. Click once anywhere on the text box to select it.

Solid handles surround the text object to show it is selected.

When the text object has solid handles, you cannot edit the text, but you 
can move, resize, or delete the text box.

6. Double-click inside the text box so the hollow handles reappear.

7. Drag through the text to select it.

The Text Properties palette displays the Format tab.

8. In the Size field of the Format tab, select 18 (+2).

Text object showing 
object outline
1-8 Building a Site in 10 Minutes
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The text box enlarges to accommodate the text.

9. Again on the Format tab, click the Color button, select a color from the 
Color Picker dialog, then click OK.

10. In the Paragraph section of the Format tab, click the Align Center 
icon.

Align icons in Paragraph 
section of Format tab
Adding a Picture
You like Richter’s label for their lager beer and decide to show it on the page.

1. From the Standard toolbar, select the Picture tool.

2. Place the pointer under the text in the Layout area and drag a box.

The size of the box doesn’t matter; NetObjects Fusion automatically 
adjusts the box to fit the picture after you place it.

The Picture File Open dialog appears so you can locate the image you 
want to place in the picture box. 
Building a Site in 10 Minutes 1-9
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3. With the Folder tab selected, navigate to Richter Brewing’s artwork in 
the NetObjects Fusion 3.0\Tutorial folder, select Lagerlabel.jpg, then 
click Open.

The Golden Gate Lager label appears selected in the Layout area.

4. Drag the picture to center it under the text.

5. Choose Save Site from the File menu to save the site.

When the picture is selected, the properties palette shows Picture 
Properties. You can crop and size pictures by dragging their handles.

Folder tab

Thumbnail image of 
selected file
1-10 Building a Site in 10 Minutes
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When the Display setting is Normal, you can drag the handles to crop 
the picture. When the Display setting is Stretch, you can drag the 
handles to resize the picture.

To restore the picture to its original size and shape, right-click it and 
select Restore Original Size from the shortcut menu.
Setting the SiteStyle
A SiteStyle is a set of graphic elements used throughout your site to provide a 

consistent look. SiteStyle elements include the banner and buttons for navigation 

bars, as well as a type of bullet, a line, and colors for linked text.

The Basic SiteStyle doesn’t reflect your company’s image. Fortunately, the Hops 

SiteStyle is available.

1. Click the Style button on the control bar to go to Style view.

Style view displays the elements of the currently selected SiteStyle, which 
is the default Basic SiteStyle.

2. Click Hops in the list of SiteStyles™.

Current SiteStyle name

Selected SiteStyle

Elements of 
selected SiteStyleList of SiteStyles
Building a Site in 10 Minutes 1-11
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3. Click the Set style button on the control bar. 

4. Click OK to close the confirmation message.

5. Click the Page button in the control bar.

The Lager page appears on Page view, displaying the banner and button 
navigation bar in the Hops SiteStyle.

6. If necessary, drag the button navigation bar down so it is even with the 
top of the Layout.

Primary button highlighted

Secondary button highlighted

Line style for Hops 
SiteStyle

Primary button style

Secondary button 
style

Hops banner style

Data list icons and 
linked text colors

Set style button
1-12 Building a Site in 10 Minutes
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Previewing Your Site
You must have a Web 
browser installed on 
your computer to 
preview your site. 

You accomplished a lot in a short time, and you want to see how your site looks in a 

Web browser. NetObjects Fusion helps you check your work by previewing it in a 

browser as you develop your site.

◆ To preview your site, click the Preview button on the control bar.

The Previewing Site dialog appears showing progress messages as it 
generates the HTML for your pages.

NetObjects Fusion launches your Web browser and displays the page 
from which you started the preview. 
Building a Site in 10 Minutes 1-13



S A V I N G  Y O U R  S I T E  A N D  E X I T I N G

Tutorial.bk  Page 14  Tuesday, June 17, 1997  9:29 PM
The other pages have no content yet, but you can click the navigation 
buttons to view the pages and their style elements.

When you are done previewing, you can minimize or close the browser, 
or simply make NetObjects Fusion the active window again.

Highlighted button 
indicating current page

Banner, showing 
current page name

Text navigation bar

Button navigation bar
Saving Your Site and Exiting
You want to take a break and continue building the site later, so you decide to save 

your site and exit NetObjects Fusion.

◆ To save your site manually at any time, select Save Site from the File 
menu.

◆ To exit NetObjects Fusion, select Exit from the File menu.

The Backup tab of the Preferences dialog contains an option to Compact database 

upon exit. When this option is selected, NetObjects Fusion automatically 

compresses your site file when you exit the program.
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What’s Next?
Chapter 2, “Touring NetObjects Fusion 3.0,” shows you how to open your site and 

acquaints you with NetObjects Fusion’s five views, its toolbars and properties 

palettes, and other basic elements of the program. Familiarity with the basic parts of 

NetObjects Fusion will help you immediately begin using its features to develop 

your Web sites.
Building a Site in 10 Minutes 1-15



1-16 Building a Site in 10 Minutes

W H A T ’ S  N E X T ?

Tutorial.bk  Page 16  Tuesday, June 17, 1997  9:29 PM



C H A P T E R  2

Tutorial.bk  Page 1  Tuesday, June 17, 1997  9:29 PM
Touring NetObjects Fusion 2

This chapter takes you on a tour through NetObjects Fusion’s five views and 

provides an overview of what you can do in each view. 

To see the items in this tour you must have followed the steps in Chapter 1, 

“Building a Site in 10 Minutes,” to create the Richter Brewing site you’ll open and 

explore.

This chapter gives you information about:

● Opening your site

● Site view

● Standard toolbar

● Properties palette

● Site view menus

● Setting preferences

● Outline view

● Page view

● Page view menus

● Layout properties

● MasterBorder properties

● Rulers and guides

● Site navigation window

● Links

● Style view

● Assets view

● Publish View
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Opening Your Site
You are refreshed from your break and you want to start NetObjects Fusion and 

continue developing your site. 

1. Start NetObjects Fusion 3.0.

Note: If NetObjects Fusion is already started, you can choose Richter 
Brewing.nod from the list of four most recently opened sites on the File 
menu. If the site is not on the list, choose Open from the File menu, 
then go directly to step 3.

NetObjects Fusion displays the Welcome To NetObjects Fusion dialog.

2. Click Open a NetObjects Fusion Site.

The text box shows the path to the last saved site.

3. If necessary, click the Browse button and navigate to the NetObjects 
Fusion 3.0\User Sites\ folder, then select the file Richter Brewing.nod.

If your system is set to hide file name extensions, the site name will not 
show the .nod extension.
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4. Click OK.

The Richter Brewing site opens to the last view where you worked.
Site View
◆ Click the Site button on the control bar to go to Site view.

Site view is where you build and edit the structure of your site.

The control bar contains icons for each of NetObjects Fusion’s five views, plus 

buttons to preview, create a new page, search for any named object, and go to the 

last view.

Preview
New page

Find object

Go to last view

Zoom In tool

Site button
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Standard Toolbar
By default the Standard toolbar is docked when you first start NetObjects Fusion.

You can use the Zoom In tool to enlarge the size of the page icons. Press the tool and 

select the Zoom Out tool from the flyout to reduce the size of the page icons.

You can drag any NetObjects Fusion toolbar to undock it. Once undocked, you can 

drag the title bar to move the toolbar, double-click the title bar to dock it, or click 

the Close box to close it. To view the toolbar again, choose Standard Tools from the 

View menu.

The next time you start NetObjects Fusion, the toolbar appears where it was when 

you exited the program.

Properties Palette
By default the Properties palette is open when you start NetObjects Fusion. You 

can drag the title bar to move it, double-click the title bar to minimize it, and click 

the Close box to close it. When closed, you can view it again by choosing Properties 

Palette from the View menu. 

Like the toolbar, the Properties palette appears where you leave it when you exit 

and restart the program.
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To learn about any option on the Properties palette, either:

● Click the question mark icon, then click an option label.

● Right-click an option label, then click the What’s This? pop-up.

The Properties palette changes depending on the selected object.

In Site view, the View tab of the Properties palette shows the orientation of the 

page icons. Here you can click the vertical icon to see the page icons arranged 

vertically, or choose a different background color for the window.

The Site tab of the Properties palette shows the site name, dates, number of pages, 

and the author name, if you type it in the Author name field.

The Page tab is where you set properties for the selected page.

The Name field shows the page’s name. You can use the Page tab to change the 

page’s name, set page status, and add comments.

By default the page name appears on the banner and navigation button for the page 

in Page view. To set a custom name for the banner or button, click the Custom 

Names button and type a new name in the Banner or Navigation Button field. You 

can also open this dialog using the Custom Names command on the Page view Edit 

menu.
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To type a two-line 
button or banner 
name, press Enter 
after the first line.
Menus
The menus change depending on the view. The commands available in Site view are 

generally available in other views, in addition to other commands.

● The File menu contains commands to open and save sites, import and export 
sites and templates, and print your site’s structure. 

● The Edit menu contains commands to delete, copy, select a site section, create a 
new page, edit custom names, and set preferences.

● The View menu contains commands to show and hide the toolbars and palettes.

● The Go menu contains commands to show all views, search for a named object, 
go to a particular page, go to the last view, select from a list of recent pages, and 
preview.

● The Help menu contains commands to launch the Windows Help system, go to 
the NetObjects Web site, register NetObjects Fusion, and obtain version number 
and copyright information.

To obtain help for a menu command, select the command, then press the F1 key.
Setting Preferences
1. Choose Preferences from the Edit menu.

The Preferences dialog appears showing the General tab.
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The General tab contains settings for the site.

● When Auto Save is selected, NetObjects Fusion saves your site each 

time you change the page or view, open a different site, or exit.

● In the Preview section you select the default browser to launch 

when previewing your site.

● NetObjects Fusion launches the editor specified in the HTML 

Editor field when you double-click a referenced HTML file in Page 

view.

2. Click the Auto Save check box to clear it. 

For the remainder of this tutorial you can save your site manually using 
the Save Site command on the File menu.

3. Click the Page tab.
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The Page tab shows the default fonts to display in the browser, the 
default measurement unit, the default page width and height for new 
pages you add, and the default placement for a background image if 
your pages contain one.

4. Click the Backup tab.
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By default, NetObjects Fusion automatically creates a backup of your 
site file under the location and name specified.

By default NetObjects Fusion compacts your site file when you exit the 
site.

5. Click OK.

6. Save your site to register the Auto Save change.
Outline View
1. Click the Outline tab under the control bar.

The site structure appears in Outline view, showing the status of the 
selected page.

2. Click the Home icon.

Now the columns on the right show the status of all pages under the 
selected page.

● To expand and collapse the view, click the plus or minus sign next to 

a page.

● To sort by column, click the column heading.

● To restore the original order, click the Home page icon.

3. Click the Structure tab to return to Structure view.

● To collapse this view, click the triangle under a page.

● To expand this view, click the plus sign under a page.

Click minus sign 
to collapse view

Click column 
heading to sort 
by column
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Page View
Page view is where you design your layout, add content, and set up MasterBorders.

◆ Select the Lager page icon, then click the Page button on the control bar 
to go to Page view.

Object outline

Ruler

MasterBorder and 
Layout handles

Page navigation 
buttons
Page View Menus
In Page view, the File menu includes commands to import or reference an HTML 

page.

Page view’s Edit menu contains the Undo command that you can use to undo most 

actions since you last switched the page or view. It also includes commands to select 

the next and previous object, Layout, MasterBorder, and page, as well as commands 

to find and replace text and check spelling. The Edit menu also contains the 

Custom Names command that you use to set custom banner and button names.
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◆ Choose Page View Options from the View menu, or press the F12 key, 
to display the Page Properties palette.

● The View tab contains options to show and hide rulers and guides, 

grid, labels, object outlines and object icons, as well as options to set 

the snap on guides, grid, and object outlines. It also includes an 

option to set the grid width and height.

● The Page tab is similar to the Page Properties tab in Site view, 

where you set properties such as the page name, custom banner and 

button name, and page status.

The View menu contains commands to show and hide Page view’s four toolbars 

and two palettes, MasterBorder, page labels, object outlines, object icons, rulers, 

guides, and the grid. Use this menu to control snapping to guides, grid, and object 

outline, and to change the zoom factor. 

Use the Go menu to go to each NetObjects Fusion view, the next, previous, parent, 

and child page, and follow a selected link to its destination.

Use the Object menu to perform actions on selected objects, such as aligning, 

arranging, sizing, showing, hiding, linking, and adding HTML scripts.

Use the Text menu to show non-printing text such as paragraph and line break 

characters, edit text styles, and insert objects, HTML, symbols, and fields into 

selected text.
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Layout Properties
◆ Click the Layout to select it, so the Layout label turns blue and the 

Layout Properties appear.

The Layout Properties contains three tabs.

The General tab contains the layout name, which by default is the same 
as the page name. This tab also contains the layout width and height, 
which you can change, and shows you the resulting page width and 
height, which adjusts automatically. The page width or height is the sum 
of the Layout plus the MasterBorder dimension. Changing the Layout 
size does not change the MasterBorder size; it changes the page size.

You can use the HTML output section to specify the HTML standard 
you want to use to publish this Layout, if it is different from the Publish 
Setting selected for the whole site in Publish view. 

● Regular Tables supports the lowest common denominator of 

browsers. The pages achieve the least layout accuracy. 

● Nested Tables supports Netscape Navigator™ 2.01 and above and 

Microsoft Internet Explorer 2.1 and above. These pages achieve the 

highest level of layout accuracy across browsers. 
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● CSS and Layers supports Netscape Navigator 4.0 and above, and 

Microsoft Internet Explorer 4.0 and above. This option is suggested 

when using NetObjects Fusion’s actions feature, and is required for 

layered or overlapping objects. This option achieves the highest 

level of layout accuracy in 4.x browsers.

The Background tab is where you select the color, SiteStyle, picture, or 
sound for the Layout background.

The Actions tab is where you can assign an action, such as a transition 
or motion, to the Layout when it is displayed in the browser.
MasterBorder Properties
◆ Click in the MasterBorder so the MasterBorder label is red and the 

MasterBorder Properties appear.

The General tab contains the name of the MasterBorder assigned to the 
current page, and a button to add and edit MasterBorders.

This tab also shows the size of the Left, Right, Top, and Bottom 
MasterBorder, which you can change here. Changing these dimensions 
can change the page size, but does not change the Layout size.

The AutoFrames tab is where you turn on frames for each MasterBorder 
margin, and the Actions tab is where you assign actions to the 
MasterBorder.
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Rulers, Handles, and Guides
The rulers appear in the unit of measurement set on the Page tab of the 

Preferences dialog, accessed from the Edit menu. The default is pixels. The 

horizontal top ruler shows the page width, which is 600 pixels when set to the 

default. The vertical side ruler shows the page height, which is 555 pixels when set to 

the default.

Do not drag Layout or 
MasterBorder handles 
at this time. 

Each ruler contains two MasterBorder handles, one at either end, and one Layout 

handle between them. 

You can create and 
drag guide handles if 
you want.

You can click the ruler where you want to create a new guide. Guides are a different 

shape from MasterBorder and Layout handles.

● MasterBorder and Layout handles change the MasterBorder and Layout margins.

● Guides help you check the alignment of objects.

Guides are color-coded: 

● When the MasterBorder is selected, guides you create are red.

● When the Layout is selected, guides you create are blue.

Drag guides to move them:

● To move a guide, drag its handle. 

● To delete a guide, drag its handle off the ruler.

Use MasterBorder and Layout handles to change margins and Layout width:

● To change the MasterBorder margin, drag one of the MasterBorder handles.

● To change the Layout width, drag the Layout handle.

Use the Undo command on the Edit menu to restore margin positions.

MasterBorder handle Layout handle
MasterBorder handle

Guide handle

Horizontal ruler
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Note: You cannot drag a margin line if the margin will become too small to 
accommodate an object it already contains, such as a banner or button navigation 
bar. 
Site Navigation Window
◆ Click the blue Site Navigation Window button at the bottom of the 

Page view window to open the Site Navigation window.

Double-click the Lager page in this window to display it.

You can use the other page navigation buttons to move up, down, left, 
and right one level or page.

Links
1. Select the “Built with NetObjects Fusion” logo in the bottom 

MasterBorder of the Lager page.

Link icon Notice the small blue and white symbol in this image. This is the Link 
icon; it means this image has a link associated with it. This and other 
object icons are visible when Object Icons is selected on the View menu.

When you select the image, the Picture Properties appear. 
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2. On the General tab, click the Link button.

The Link dialog appears, displaying the External Link tab.

The information on this tab tells you that when site visitors click this 
NetObjects Fusion logo, their browser will take them to a URL external 
to your site—in this case the NetObjects Home page at 
www.netobjects.com.

3. Click Cancel.

4. Select the Golden Gate Lager picture.

5. Click the Link button.

Because this picture has no assigned link, the Link dialog shows all the 
available linking options.
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An internal link is a link to a page in your site.

A smart link is a link relative to the current page, such as up a level, next 
page, and previous page.

The File Link tab is where you enter the path and file name of a file to 
download into the browser window when the site visitor clicks the link.

6. Click Cancel to exit the dialog.
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Style View
If you followed the steps in Chapter 1, “Building a Site in 10 Minutes,” you have 

already seen how to view and change NetObjects SiteStyles in Style view.

You can also create your own SiteStyles and edit existing SiteStyles in this view. 

The Style menu contains commands to create a new style, add and remove styles, 

and update the list of SiteStyles.

In Style view, the control bar contains the Set Style button, which you use to assign 

the style you are viewing to your site.
Assets View
Assets view is where you manage all the assets in your site.

1. Click the Assets button on the control bar.

Assets view appears with the Files tab selected.

The Files view shows all file assets known to the site. The columns in this 
view tell you the asset’s file name, its type, whether it is currently in use, 
its path, size, and creation date. The Verify Status column reports the 
results of the Verify All File Assets command on the Assets menu, and 
tells you whether the asset is actually in the location specified by the 
path.

You can click a column heading to sort by that heading, and drag 
column dividers to change the column widths.

2. Click the Links tab.
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The Links view lists all the links currently registered in the site.

Although the button and text navigation bars contain links, these are 
managed internally by NetObjects Fusion and are not listed here.

The only link currently assigned in this site is the external link, 
NetObjects Home Page, which you examined in the “Built with 
NetObjects Fusion” logo.

The Data Objects and Variables tabs show data objects and variables used in the 

site. The default entry is a data object named Sample and a variable named 

Address.

The Assets menu varies slightly depending on the selected tab. Generally it contains 

commands to add a new asset, delete all unused file assets, open an asset, and verify 

all assets.
Publish View
Publish view is where you set up publishing parameters and select whether to 

publish locally to your computer as a test platform, or remotely to a Web server.

With NetObjects Fusion you can specify the directory structure you want to publish 

to your Web server.

You can also specify the HTML output option you want to use. NetObjects Fusion 

can output HTML suitable for any version of Web browser.

The Publish view control bar contains Setup and Publish buttons, which open 

dialogs where you set up publishing parameters and select your Web server for 

publishing.
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These buttons open the same dialogs as the Publish Setup and Publish Site 

commands on the Publish menu.

1. Click the Publish button to go to Publish view.

The Publish view window shows the directory structure that will be 
uploaded to your server in the left pane, and descriptive information in 
the right.

This view shows publishing by page (Site Section option), where all the 
.html and asset files for a given page are in a directory of the same name, 
and the index.html file, and all banners, buttons, and other NetObjects 
Fusion files are in the root.

2. In the Directory Structure pane, click the Lager folder. 
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The contents of the Lager folder appear in the right pane.

The columns show the file name of the asset or .html file, its type, 
attributes, and publishing status. Files labeled Auto-Generated Image 
are the banner and button images containing page names that are 
automatically generated by NetObjects Fusion.

You can also choose to publish to a flat directory structure, where all 
assets and files are in one directory, or by asset type, where assets are in 
one directory and .html files are in another. Finally, you can create your 
own custom directory structure.

The Publish menu contains the Publish Setup and Publish Site commands, which 

duplicate the control bar buttons, as well as commands to create a new folder, delete 

a folder, and rename an item.

To take a closer look at the publishing options, click the Setup button on the control 

bar, look through the dialog, then click the Cancel button.
What’s Next?
This completes your tour of NetObjects Fusion 3.0. Continue to the next lesson, 

Chapter 3, “Designing the Home Page,” and the remaining lessons, to learn how to 

put NetObjects Fusion to work for you.

Sample Sites
NetObjects Fusion 3.0 ships with sample sites for you to explore to see how various 

features are implemented. These sites are in the NetObjects Fusion 

3.0\Samples\Sites folder. The sites are stored as NetObjects Fusion template files 

instead of .nod files, which means you can create a new site based on the template, 

without actually opening the template. This way you can experiment with the site if 

you want, without changing the original template.

Each chapter contains a “What’s Next?” section that refers you to various parts of 

the sample sites for examples of the feature described in the chapter.

Instructions for opening a template appear at the end of the last lesson, in the 

section “Viewing Sample Sites” on page 9-8.
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Designing the Home Page 3

Now that you developed a basic site structure and became familiar with some basic 

NetObjects Fusion 3.0 features, you turn your attention to the Home page. 

To complete the lessons in this chapter, you must first follow the steps in Chapter 1, 

“Building a Site in 10 Minutes,” to create the Richter Brewing site you open and edit.

This lesson shows you how to:

● Create a new MasterBorder

● Create an imagemap

● Add a custom banner
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Creating a New MasterBorder
You have an attractive image you want to use as a navigation aid on the Home page 

instead of the button navigation bar. You want to remove the button bar from the 

Home page, and keep it on all the other pages. You accomplish this by creating a 

new MasterBorder, removing its navigation bar, and assigning it only to the Home 

page.

1. Open the Richter Brewing.nod site.

2. Navigate to the Home page in Page view.

3. Click in an empty area of the MasterBorder, so the MasterBorder 
Properties palette appears.

The Name field shows the MasterBorder assigned to this page—
DefaultMasterBorder. This field lists all MasterBorders in the open site.

NetObjects Fusion also provides a ZeroMargins MasterBorder, which 
sets all margins to zero, if you want to create pages with no borders.

4. On the General tab of the MasterBorder Properties palette, click the 
Add/Edit button.
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5. In the Edit MasterBorder List dialog, click the Add button.

6. In the Name field of the New MasterBorder dialog, type

HomeBorder

Leave it based on DefaultMasterBorder.

7. Click OK.

The new MasterBorder name appears on the Properties palette, and the 
Name drop-down list now shows three MasterBorders.

8. Right-click the button navigation bar in the Left MasterBorder, then 
choose Delete Object from the shortcut menu.
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This removes the navigation bar from the MasterBorder named 
HomeBorder, which is assigned only to the Home page. The other pages 
still use the DefaultMasterBorder, thereby retaining the button 
navigation bar that is part of the border.

9. Save your site.
Creating an ImageMap
Now you add a picture for the imagemap to the Home page.

1. On the Standard toolbar, click the Picture tool and draw a box in the 
center of the Layout.

2. In the Picture File Open dialog, navigate to the NetObjects Fusion 
3.0\Tutorial folder, select the file ImageMap.jpg, then click Open.
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3. Drag the picture to the center of the Layout, if necessary.

4. On the Standard toolbar, click the Hotspot: Rectangle tool.

If the Rectangle tool is not showing, press the Hotspot tool then select 
Rectangle from the flyout.

5. Move the pointer over the picture.

A wide border surrounds the picture, which shows it is selected for 
adding hotspots.
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6. With the wide border showing, drag a box over the Golden Gate Lager 
section of the picture.

The Link dialog appears showing the Internal Link tab.

7. In the Page section, click Lager.

8. Click the Link button.
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The rectangular hotspot appears selected on the picture, and the 
properties palette shows Rectangle Hotspot Properties.

9. Place the pointer over a handle and notice that when the pointer changes 
to a double-sided arrow, you can drag the handle of the hotspot to adjust 
its size. You’ll want to do this to avoid overlapping hotspots.

10. Double-click the Rectangle Hotspot tool to prevent it from reverting to 
the Select tool.

11. Drag a rectangle around Alcatraz Stout.

The Link dialog appears again, showing the Internal Link tab.

12. In the Page section, scroll if necessary, select the Stout page, then click 
Link.

13. In the same way, draw a hotspot rectangle around Cable Car Porter and 
link it to the Porter page.

14. Draw the last hotspot rectangle around Coit Tower Ale and link it to the 
Ale page.
Designing the Home Page 3-7



A D D I N G  A  C U S T O M  B A N N E R

Tutorial.bk  Page 8  Tuesday, June 17, 1997  9:29 PM
15. Click the Select tool.

● To easily select just the picture, drag a large marquee around it, or 

click its outline.

● When the picture is selected, the Picture Properties palette shows 

the General tab.

To turn off hotspot outlines, clear the Show Hotspots check box 
on the General tab of the Picture Properties palette.

16. Save your site.

17. Preview the site, and click the hotspots on the Home page to test the 
internal links.
Adding a Custom Banner
You have a special banner containing the Richter Brewing logo that you want to use 

on the Home page. You do this by replacing the default banner on the Home page 

with the custom banner. 
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1. On the Home page in Page view, click the banner to select it.

2. On the Banner Properties palette, click the Custom Image button.

The Folder tab of the Picture File Open dialog automatically displays 
the banner images in the NetObjects Fusion 3.0\Styles\Hops\Banners 
folder.

3. Select AltHopsBanner.gif, then click Open.

The alternate banner style showing the Richter Brewing logo replaces the 
default banner for the Hops SiteStyle.
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4. Save and preview your site.

Click the Remove 
Customization 
button to restore a 
default SiteStyle 
banner.
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What’s Next?
The next chapter, Chapter 4, “Creating Dynamic Pages,” shows you how to add 

actions to objects to animate make them.

For another example of an imagemap, look at the Products page in the Atlas 

Antiques sample site template.

For information about templates, see “Viewing Sample Sites” on page 9-8.
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Creating Dynamic Pages 4

Like its Golden Gate Lager in 1998, Richter Brewing Company’s Coit Tower Ale won 

the American Brewing Award in 1997. It’s a well-known fact, but you are going to 

make a special animated page just to remind folks. 

Because many of your site visitors are using the 4.x versions of browsers, you can 

take advantage of Dynamic HTML and its support of animation and interactivity. 

To view animated objects, your site visitors must use a browser that supports 

Dynamic HTML, such as Microsoft Internet Explorer 4.0 and above or Netscape 

Navigator 4.0 and above. 

You want to use Dynamic HTML to bring your page to life for these visitors, but you 

also want to make sure that site visitors using older browsers can experience the 

page. 

With NetObjects Fusion you can choose from three different HTML output options 

to support various browsers. You can assign one publishing method to the whole 

site, and then select a different method for individual pages, or portions of pages. 

To enable visitors using earlier versions of browsers, such as Microsoft Internet 

Explorer 3.x and Netscape Navigator 3.x, to view pages containing actions, it is best 

to use the Nested Tables HTML output option. Then these site visitors see your 

page with its objects in their resting states.

To follow the steps in this lesson, you must have built the Richter Brewing site 

described in Chapter 1, “Building a Site in 10 Minutes.”

This lesson shows you how to:

● Add and size pictures

● Use NetObjects Fusion’s Object Tree 

● Add actions to objects

● Set the HTML output option
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Adding Objects
First you add all the objects you intend to animate.

1. Open the Richter Brewing.nod site.

2. Navigate to the Ale page in Page view.

3. Select the Picture tool and draw a box in the middle left of the Layout.

The Picture File Open dialog appears, showing the Folder tab.

4. Navigate to the NetObjects Fusion 3.0\Tutorial folder, select 
AleBottles.jpg, and click Open.
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5. On the General tab of the Picture Properties palette, select Stretch so 
you can reduce the picture’s size while maintaining its proportions.

6. Press the Ctrl key while you drag the lower right corner handle of the 
picture toward its center until the picture is about two by two and one-
fourth inches. 

7. Select the Picture tool and draw a box in the middle right of the Layout, 
even with the top of the AleBottles picture.
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8. In the Picture File Open dialog, navigate to the NetObjects Fusion 
3.0\Tutorial folder, select AleLabel.jpg, and click Open.

9. Using the Picture tool, draw a box in the top middle of the Layout.

10. In the Picture File Open dialog, navigate to the NetObjects Fusion 
3.0\Tutorial folder, select Award97.jpg, and click Open.

11. Save your site.
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Using the Object Tree
1. From the View menu, select Palettes, Object Tree.

The Object Tree shows the hierarchy of all objects on the current page 
using an outline view much like Windows Explorer. 

The MasterBorder section, labeled DefaultMasterBorder in the Object 
Tree, shows all objects in the MasterBorder. The Layout section, labeled 
AleLayout, shows all objects in the Layout.

You can drag an object’s name up or down in the Object Tree to move it 
to the front or back of another object within the MasterBorder or within 
the Layout.

Each object must have a unique name, and NetObjects Fusion does not 
let you give an object the same name as another object.

2. In the Layout, select the picture of the Ale bottles in the left middle.

The Object Tree highlights the name of the selected object so you can 
identify it.

If this is the first picture you placed in this Layout, it appears under Ale 
Layout as Picture2.

3. In the Object Tree, click Picture2, or the name associated with the Ale 
bottles picture, to select the text.

4. Type AleBottles to give the object a descriptive name.

Page name

Layout name

Click the plus sign to view 
the button names inside the 
button navigation bar.

Objects in 
this Layout

Highlighted name shows 
picture selected in Layout

First picture on page is 
NetObjects Fusion logo, 
inside the MasterBorder
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5. Click Picture3, or the name associated with the Ale label picture, to 
select it; click again to enter Edit mode, then rename the picture 
AleLabel.

6. Click twice on Picture4, or the name associated with the Award picture, 
and rename it Award.

7. Save your site.
Adding Actions to Objects
Now you can add actions to make the objects move on the page.

1. Select the AleBottles picture in the Layout, and arrange the screen so you 
can see the Picture Properties.

2. With the AleBottles picture selected, click the Actions tab.

3. Clear the Object initially visible in browser check box.
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4. Click the Plus (+) button at the bottom left.

The Set Action dialog appears.

The Name field shows the default action name, Action1.

5. In the When field, click the arrow to display the menu, point to Page, 
then select Page Loaded.

Name of selected object
Clear to make object initially 
invisible in browser

Name of action

When to perform action

Object doing the action
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This means that Action1 will happen when the browser loads this page.

In the Action section, the Target field shows the action will happen to 
the object named AleBottles, which was selected when you began 
formulating this action, and is therefore the default target.

6. In the Message field, select Motion, Fly from the menu.

When you select an option from the message list, the appropriate 
parameters become available.

7. In the Parameters field, select In From Top Right from the menu.

8. Click OK.

The Actions tab for the AleBottles picture now shows the action you 
created, described in a few words.

Action to perform

Parameter for action to 
perform
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The check mark next to the action enables it. 

 Action icon The Action icon, a right-pointing triangle in a small pink circle, appears 
on the AleBottles picture, indicating an action is assigned to it. 

To view object icons, 
select Object Icons 
from the View menu.

9. Select the AleLabel picture in the Layout.

10. With the AleLabel picture selected, click the Actions tab.

11. Clear the Object initially visible in browser check box.

12. Click the Plus (+) button at the bottom left.

The Set Action dialog appears.

Select or clear check box to 
enable and disable the action.

Click Plus and Minus buttons 
to add and delete an action.
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13. In the When field, select Page, Page Loaded from the menu.

14. In the Message field, select Motion, Fly from the menu.

15. In the Parameters field, select In From Top Left from the menu.

16. Click OK.

The Actions tab for the AleLabel picture shows a description of the 
action you created, and the Action icon appears on the Alelabel picture. 
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17. Click the Plus (+) button again.

The Set Action dialog appears, showing Action2 in the Name field.

18. In the When field, leave the default action, which is Clicked.

19. In the Target field, click the Browse button to display the Object Tree.

Click Target Browse button 
to open Object Tree.

Select target from 
Object Tree.
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20. In the Object Tree, select the Award page and click OK.

Award appears in the Target field of the Set Action dialog.

The target of the action is the Award picture. When you click the 
AleLabel picture, the Award picture does something.

21. In the Message field, select Motion, Fly.

22. In the Parameters field, select In From Top Left.

23. Select the Cascade message check box, to chain Action2 after Action1.

24. Click OK.

Now two actions are listed in the Picture Properties for AleLabel.

25. Select the Award picture.

This object performs the action.

Select to chain messages

Perform action when this happens to 
object selected in Page view

Click arrows to move selected 
action up or down in list.
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26. On the Picture Properties palette, click the Actions tab.

27. Clear the Object initially visible in browser check box.

28. Save your site.
Setting the HTML Output Option
The default HTML output option for an entire site is Nested Tables. You can see 

this setting in Publish view, in the HTML Output tab of the Publish Setup dialog.

If the HTML Output option for the site is set to a different option, you can override 

it and manually set the HTML output option for the Ale page’s Layout.

1. Click the Ale page’s Layout to select it.

2. On the Layout Properties palette, in the HTML output section, select 
Nested Tables from the drop-down list.

Note: If a page contains overlapping objects, you must set the HTML 
output option to CSS and Layers and use a 4.0 or higher browser 
version to properly display the layered objects.
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Previewing the Ale Page
1. Preview the site.

● If you are using a 4.x browser, you see the objects moving.

● If you are using a 3.x browser, you see the objects in their at rest 

states.

● If you last launched a 3.x browser, you can launch a 4.x browser 

from the Windows Start menu. The next and subsequent times you 

preview, NetObjects Fusion will launch the most recently used 

browser.

2. After the page loads, and the AleBottles and AleLabel pictures fly in, click 
the AleLabel picture to see the Award picture fly in.

This is a good example of messaging. When the visitor clicks, a message 
is sent to the target object to perform an action, in this case the Award 
picture, which flies in from the top left.

When an object has an associated action, the pointing finger icon 
appears over the object in 4.x browsers.
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● Click the AleLabel picture as many times as you want to see the 

Award fly in.

● Reload the page or click the Ale button to view the whole action 

sequence without previewing.

What’s Next?
The next lesson, Chapter 5, “Placing Pictures in Text,” shows you how add a Rich 

Text Format (rtf) file to your page, and how to format a picture inside a text block.

For more examples of actions open the sample site template DHTML Presentations 

in the NetObjects Fusion 3.0\Samples\Sites folder. 

For instructions on opening templates, see “Viewing Sample Sites” on page 9-8.
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Placing Pictures in Text 5

Richter Brewing needs a Web page to showcase its popular Cable Car Porter. You 

have a Rich Text Format (rtf) file with a description of the brew, so you are going to 

start with that. With NetObjects Fusion you can put any object inside text, so you 

decide to make the text wrap around a picture of the Cable Car Porter label.

To follow the steps in this lesson, you must have created the Richter Brewing site 

described in Chapter 1, “Building a Site in 10 Minutes.”

This chapter shows you how to:

● Drag and drop an .rtf file onto the Layout area

● Add a picture inside a text box

● Align text around a picture

● Move a picture inside a text box

● Work with the text box
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Placing an RTF File
In NetObjects Fusion, a text box can be a container object. You can add and arrange 

other objects inside it. When you move the text box, the objects remain in their 

positions in the box. This makes it easy to arrange other objects around the text box 

on the page. 

Dragging an .rtf file onto the Layout area creates a text box, just as if you had used 

the Text tool to draw a text box, then typed and formatted text inside it.

1. Open the Richter Brewing.nod site.

2. Navigate to the Porter page in Page view.

3. Launch Windows Explorer and arrange the windows so you can see the 
file Cable Car Porter.rtf in the NetObjects Fusion 3.0\Tutorial folder.

4. Drag Cable Car Porter.rtf from Windows Explorer onto the Layout 
area of the Porter page, releasing the mouse about an inch down from 
the top left corner of the Layout.
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A copy of the .rtf file appears inside a text box in the Layout area. The 
text box is selected and the properties palette shows Text Properties.

5. Save your site.
Adding a Picture Inside a Text Box
1. Select the Picture tool from the Standard toolbar. 

The pointer changes to a crosshair. When you move it over the text box, 
the text box outline changes to a wide blue border. The crosshair pointer 
carries a wide blue insertion point with it.
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2. Place the wide blue insertion point just to the left of the first word in the 
second paragraph, and draw a picture box.

3. In the Picture File Open dialog that appears, navigate to the 
NetObjects Fusion 3.0\Tutorial folder, select Porterlabel.jpg, and 
click Open.
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The picture appears with its upper left corner at the location where you 
began drawing the box. The picture is selected, and the Picture 
Properties palette appears.

4. On the Picture Properties palette, click the Align tab.

The icons on the Align tab show you how the text aligns itself in relation 
to the picture. 

In this case, the default alignment is Top, which aligns the text at the 
insertion point with the top of the picture. This option does not wrap 
text, so the rest of the text is below the picture.

5. On the Align tab, select Left wrap.
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The text wraps around the picture, and the Picture In Text icon appears.

You decide to move the picture to the upper left corner of the text box.

6. Make sure the picture is selected, so at least some of its handles show. 

7. Move the pointer over the picture and press the mouse button, so you 
can see the wide blue border around the text box, and start dragging 
toward the upper left corner of the text box. 

As you drag, the picture remains where it is, and the pointer again 
displays the wide blue insertion point.

8. When the wide blue insertion point is in the upper left corner inside the 
text box, release the mouse button.

The picture moves to the upper left corner of the text box. The 
Alignment option is still set to Left wrap, and now the picture is where 
you want it.

Blue and white icon 
denotes insertion 
point for picture in 
text box
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9. In the Space around object section of the Align tab, set the Horizontal 
and Vertical options to 8, to create some space between the picture and 
the text.

10. Save your site and preview it.
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What’s Next?
The next lesson, Chapter 6, “Creating a Form,” shows you how to create a form in a 

Layout Region, add form objects, and add a Submit button that sends the form data 

to an email address.

For more examples of objects in text, look at the About Us, Products, and December 

pages in the Atlas Antiques sample site template.

For instructions on opening templates, see “Viewing Sample Sites” on page 9-8.
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Creating a Form 6

Richter Brewing needs a form to obtain customer feedback. You are going to create 

it in a Layout Region and use the Email option to process it.

You can create a form in one of four NetObjects Fusion container objects: the 

Layout area, text box, table, and Layout Region.The Layout area can contain only 

one form. To include more than one form on a page, put the form in one of the 

other container objects.

A Layout Region is very useful for grouping objects so you can move them all at the 

same time, as one object, while maintaining their relative positions.

If you are not sure how many items will eventually be on the page, it is a good idea 

to put the form in a Layout Region, so you can easily reposition the entire form 

later, if necessary.

You can easily design forms in NetObjects Fusion. To receive the information your 

site visitors submit to you, your Web server must have a properly configured 

Common Gateway Interface (CGI) script associated with the form’s Submit button. 

Or, you can use NetObjects Fusion’s Email option to simply send the form’s data to 

an email address. 

To follow the steps in this chapter, you must have built the Richter Brewing site in 

Chapter 1, “Building a Site in 10 Minutes.”

This chapter shows you how to:

● Create a form in a Layout Region

● Add form objects

● Set Submit button options

● Add a SiteStyle line

● Test your form
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Creating a Layout Region
1. Open the Richter Brewing.nod site and navigate to the Comments 

page in Page view.

2. Select the Form Area tool and draw a box about two-thirds the size of 
the Layout area.

The Create Form dialog appears with your selected rectangle, showing 
the four types of forms you can create.

3. Select Create position-based form (Layout Region), then click OK.

The Layout Region Form object appears selected in the Layout area.

4. Drag the handles of the Layout Region Form to adjust its size, if 
necessary.

The Layout Region Form label is black when the Layout Region is 
selected.

The General tab of the Layout Region Properties shows the Layout 
Region is a form check box selected, and the Form Tools appear.

Layout Region Form label

Layout 
Region 
Properties

Form 
tools
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5. Save your site.
Adding Form Objects
1. Select the Text tool and draw a text box inside the Layout Region, in the 

upper left corner, to create a label for the first field.

As with other tools and objects, when you pass the text crosshair over the 
Layout Region, it displays the wide blue border, indicating objects you 
draw will appear inside it. 

2. Type Name in the text box.

This is the label for your form’s first edit field.

3. On the Forms toolbar, select the Forms Edit Field tool.

The pointer changes to a crosshair.

4. Drag a rectangular box long enough to hold a name next to the Name 
text box.

The form edit field appears in the Layout Region, and the Forms Edit 
Field Properties appear showing the General tab.

Text 
Properties 
palette

Text box in 
Layout Region

Form tools
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● The Name field contains the default name of this edit field, 

FormsEditField1.

● The Text field is for any default text that you want to appear in the 

browser.

● The Password field causes characters input in the browser to appear 

as asterisks.

● The Visible length field sets the length of the edit box.

● The Max length sets the maximum number of characters the site 

visitor can input to this field.

You can choose Undo 
from the Edit menu to 
undo your last action.

5. Press the Shift key while you click the Name text box to select it with the 
edit field.

Handles appear around both objects to show they are selected.

6. Press the Ctrl key and drag a copy of the two selected objects down 
about one-half inch, so the new objects appear just under the first row of 
objects, then release the mouse button.

Form edit field

Forms Edit 
Field 
Properties
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The Multi-Object Palette appears because more than one object is 
selected. You can use this palette to align selected objects. 

7. Click elsewhere in the Layout Region to de-select the two objects. 

8. Double-click the second Name text box, and change Name to Email 
Address.

9. Save your site.

10. Select the Text tool, and about an inch under the first two rows, draw a 
long text box.

11. Type

Which Richter Brewing Company products have you tried?

12. Select the text and click the Bold icon on the Text Properties Format 
tab.

Multi-
Object 
Palette

Second row containing 
another text box and 
form edit field
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13. On the Forms toolbar, click the Forms Checkbox tool. 

14. Under the question, and aligned with the left sides of the Name and 
Email address text boxes, draw a check box.

Text
Properties

Forms 
Checkbox 
Properties

Form check 
box, selected
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The Forms Checkbox Properties appear, showing the default name of 
the object in the Name field, and its default state, which is Unchecked.

15. Press the Ctrl key and drag a copy of the Name text box down to the 
right of the check box so the tops are aligned, then release the mouse 
button.

16. Double-click the new text box and change its text to

Golden Gate Lager

17. If necessary, stretch the text box so the brew name is all on one line.
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18. Click the check box, then Shift+Click the text box, to select both.

19. Ctrl+Drag copies of the objects down about one-half inch, aligning 
them under the first check box and text box. 

20. Ctrl+Drag two more times, each time dragging the two selected objects 
to the right side of the first set, making a second column, like this:
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21. Change the text in the remaining three text boxes to:

Cable Car Porter, Coit Tower Ale, Alcatraz Stout
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To see what the form looks like without the object outlines, clear the 
check mark next to Object Icons on the View menu. Click the 
command again to restore object outlines.

22. Save your site.
Adding a Submit Button
1. From the View menu, choose Toolbars, Component Tools.

2. From the Component toolbar, select the Form Handler tool.

3. In the lower right section of the Layout Region, draw a button.

The button appears, with the default button name, Submit.

The Form Handler Properties appear.

4. In the Form Handler Properties, click the Publish to parameter.

5. In the Form Handler drop-down list, click Email.

6. Click the Email parameter.

Form 
Handler 
Properties

Component tools

Submit 
button
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7. In the Form Handler edit field, type your own email address, then click 
the check mark to update the address.

8. Click the Layout Region to select it.

The Layout Region Properties palette shows the General tab.

9. In the Use field of the HTML output section, select Nested Tables.

This works well with most browsers.

10. Save and preview your site.

Form Handler edit field

Email parameter
Publish to parameter
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Completing the Page
1. In Page view, select the Text tool, draw a text box in the Layout area 

above the Layout Region, and type

Tell us what you like

2. Select the text, and in the Format tab of the Text Properties palette, set 
the text to Bold, 18 (+2), Align Center, click the Color button and 
choose a color from the Color Picker, then click OK.

3. Drag the whole Layout Region closer to the text. 

When you drag the Layout Region, all the objects inside it remain where 
they are in relation to each other.

This makes space under the form, so you add one last embellishment.

4. On the Standard toolbar, press and hold the Line tool and select the 
Line: SiteStyle tool from the flyout.

5. In the Layout area, just below the Layout Region, drag a horizontal line.

A line in the Hops SiteStyle appears to complete your page.
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6. Save and preview your site.
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Testing Your Form
In some cases this test might not work, but you can try it and see. You must be 

actively connected to the Internet, and the browser you are using must be properly 

configured for your email. 

1. Open your browser and connect to the Internet.

2. Preview your site.

3. In your browser, on the Comments page, type a name and email address 
in the text fields, check some of the check boxes, and click the Submit 
button.

4. Check your email for the form submission.

The submission arrives in an email message to you, entitled Form 
response. 

The message consists of text strings showing filled in fields in the form 
record. Each form field is identified by its name as shown in the Name 
field on the General tab of the form object’s properties palette.

For example, when previewing this form in the browser, if you type Tom 
Sawyer in the Name field, Tom@MyISP.com in the Email address field, 
and check the Golden Gate Lager and Cable Car Porter check boxes, 
this is the contents of the form response you receive:

FormsEditField1=Tom+Sawyer

FormsEditField2=Tom@MyISP.com

FormsCheckbox1=

FormsCheckbox2=

FormHandler2=Submit

Your form input fields might be numbered differently, depending on the 
order in which you created them in Page view.
6-14 Creating a Form



W H A T ’ S  N E X T ?

Tutorial.bk  Page 15  Tuesday, June 17, 1997  9:29 PM
What’s Next?
The next lesson, Chapter 7, “Working with Site Sections,” shows you how to move 

pages in Site view, create a section, and assign a new MasterBorder to it.

For more examples of forms, open the Atlas Antiques site and look at the Order 

Form and Guestbook pages. 

For information on opening templates, see “Viewing Sample Sites” on page 9-8.
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Working with Site Sections 7

Richter Brewing’s management is giving away a trip to San Francisco. The winner 

will be randomly selected from the responses submitted from the form you created. 

The Research department developed a new product. They are writing a story about 

it, and want you to reserve a page that will contain the information when it is 

complete.

Management wants these announcements, plus a page about Richter Brewing’s 

product awards, to be in a section of the site called “News.”

To follow the steps in this lesson you must have built the Richter Brewing site in 

Chapter 1, “Building a Site in 10 Minutes.”

This chapter shows you how to:

● Create a section

● Assign a MasterBorder to a section
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Creating a Section
You are going to create a four-page section including a parent page named News. 

You need to move the Comments page from the first level to below the News page, 

in the new section.

1. Open the Richter Brewing.nod site.

2. Click the Site button on the control bar to go to Site view.

3. Select the Home page, then click the New button on the control bar to 
add a new page under the Home page.

4. Name the new page News and press Enter.

5. Drag the Comments page under the News page until you see the red 
downward pointing arrow, then release the mouse button.
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The Comments page moves under the News page.

6. Click the News page to select it, then click the New button on the control 
bar twice to add two new pages under the News page.

This creates a four-page section.

7. Name the two new pages Press Release and Awards.
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8. Click the News page to select it, then choose Select Section from the 
Edit menu.

The pages in the section are selected, and the Properties palette shows 
the Section tab. 

9. In the MasterBorder field of the Section tab, select 
DefaultMasterBorder if it is not already selected.

10. Click the Color button, and select a different color for the page icons in 
this section.
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Assigning a MasterBorder to a Section
In Page view, the button navigation bar shows the pages in the first level of the site. 

You know you are going to create a hotspot link from the News page to the form on 

the Comments page, but once there, your site visitors will not be able to navigate to 

the other pages in the News section. 

To solve this problem, you create a new MasterBorder for the section, and set its 

button navigation bar to show pages on the current level. 

1. Double-click the News page to open it in Page view.

2. Click the MasterBorder to select it, so the MasterBorder Properties 
appear. 

3. On the MasterBorder Properties palette, click the Add/Edit button.

4. In the Edit MasterBorder List dialog, click the Add button.
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5. In the New MasterBorder dialog, type SectionBorder.

Leave the new MasterBorder based on DefaultMasterBorder.

6. Click OK.

On the MasterBorder Properties palette, SectionBorder appears 
automatically in the Name field of the General tab.

At this point the SectionBorder is still the same as the 
DefaultMasterBorder it was based on.

7. Click the button navigation bar to select it.

8. On the Vertical Navigation Bar Properties palette, click the Options 
button.

9. In the Nav Bar Display dialog, select Current Level.

10. Click OK.
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The button navigation bar looks the same, because for the News page, 
the first level is the same as the current level.

11. Click the Site button on the control bar to go to Site view.

12. Press the Shift key while you click the News page.

This keyboard shortcut selects the section.

The Properties palette displays the Section tab.

Because pages in a section can contain different MasterBorders, this tab 
shows the MasterBorder assigned to the selected page. To assign a 
MasterBorder to a whole section, you must select the MasterBorder here.

13. In the MasterBorder field, click the arrow to display the drop-down list, 
then select SectionBorder. Even though it is already selected for the 
page, you must select it again to apply it to the section.

Now all the pages in the section are assigned the SectionBorder.

14. Double-click the Comments page to open it in Site view.
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The button navigation bar shows pages on the current level, giving site 
visitors a convenient way to view them.

The text navigation bar at the bottom of the page provides a convenient 
link to all pages on the first level.

15. Save your site.

What’s Next?
The next lesson, Chapter 8, “Working with HTML Files,” shows you how to import 

an HTML file into the News page, where you can edit it as usual. The imported page 

contains a picture that is linked to the Comments page, so visitors can move 

between the first and second levels of the site.

The next chapter also shows you how to reference and preview an HTML file that is 

external to NetObjects Fusion, without altering its code, and how to edit its code 

after you reference the file in NetObjects Fusion.
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Working with HTML Files 8

Richter Brewing has assigned you two tasks, both involving HTML files. 

One task involves importing an HTML file into your NetObjects Fusion site, where 

you can edit it just like other pages in Page view. 

The other task is to reference an HTML file that is, and will remain, external to your 

site. Richter Brewing’s research scientists are developing this HTML page, and they 

want to keep working on it, so they do not want you to incorporate it into your 

NetObjects Fusion site and edit it in Page view.

To complete the lessons in this chapter, you must first follow the steps in Chapter 7, 

“Working with Site Sections,” to move pages, create a section, and assign a new 

MasterBorder.

This chapter shows you how to:

● Import an HTML file

● Reference an external HTML file
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Importing an HTML File
Richter Brewing is conducting a drawing for a two-week vacation for two in its 

home city of San Francisco. The company wants to draw from the responses to the 

form you designed for feedback on Richter Brewing beers. 

Management has given you an announcement for the News page in the form of an 

HTML file that you can import. The file is already set up to link to the Comments 

page, where visitors can fill out and submit the form.

1. Open the Richter Brewing.nod site and go to the News page in Page 
view.

2. Click the Layout to select it.

3. Choose Import HTML Page from the File menu.

4. In the Open dialog that appears, navigate to the NetObjects Fusion 
3.0\Tutorial\Html folder.

Select Page Labels 
from the View menu to 
turn off the labels.

5. Select News.htm, and click Open.
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NetObjects Fusion imports the HTML file and its assets into a text box 
in the Layout.

If you turned Page 
Labels off, turn them 
on here.

6. Click in the Layout area to view the selected text box and the Text 
Properties.

You can edit this text box just as you would any other NetObjects Fusion 
text box.

In the Text Properties palette:

● Lock height sets the minimum height for the text box in the 

browser.

● Size to Layout prevents resizing the text box.

7. Notice the Link icon in the upper left corner of the image. 

8. Click the picture to select it, then click the Link button on the Picture 
Properties palette to learn about this link.
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This dialog tells you the image is linked to the Comments page.

9. Click Cancel to close the dialog.

10. Save and preview your site.
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Referencing External HTML
Richter Brewing scientists have discovered an ancient ale and reproduced the recipe. 

They created an HTML file for a press release, but are still developing the text for it. 

The scientists want the file to appear as is, so Richter management wants you to 

reference this press release as an external HTML file. 

1. In Page view, click the Site Navigation Window button at the bottom of 
the window, and in the Site Navigation window, double-click the Press 
Release page.

This page is assigned the MasterBorder called SectionBorder, created in 
Chapter 7, “Working with Site Sections.”

Notice the Press Release page’s button navigation bar shows the current 
level of pages, as specified in the Vertical Navigation Bar Properties 
palette, visible when you select the button navigation bar. 

2. Choose Reference HTML from the File menu.

The Reference HTML Page dialog appears.

3. Click the Browse button, navigate to the NetObjects Fusion 
3.0\Tutorial\Html folder, then select Pressrel.htm.
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● You import the head when your HTML file has scripts, meta tags, or 

other contents between the <HEAD> and </HEAD> tags that you 

want to retain when NetObjects Fusion publishes the page.

● One HTML head is allowed per page. If you have another HTML 

file on the page, you can select the Append to Current <HEAD> 

option to include the contents of both heads in one, or you can 

select the Replace Current <HEAD> option in the drop-down list 

to use only the contents of the page you are referencing.

● NetObjects Fusion automatically locates and manages the assets 

referenced by this HTML file.

4. Click OK.

In the Layout area, NetObjects Fusion displays a message showing the 
name of the referenced HTML file, the date and time it was last 
modified, and its size.

5. Click the Layout area to select this external HTML object.
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A border surrounds the object and the External HTML Properties 
palette appears.

6. On the External HTML Properties palette, click the Size to Layout 
check box to clear it.

Object handles appear around the object. When the external HTML 
object is not sized to the layout, you can drag its borders to change its 
size.

7. Select the Size to Layout check box again.

You can double-click anywhere on the object to launch the HTML editor 
specified on the General tab of the Preferences dialog. 

You can edit and save the HTML file, and NetObjects Fusion displays the 
new version in the browser.

8. Save and preview your site.
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What’s Next?
The next chapter shows you how to use layered objects, and how set the HTML 

output option so browsers that support Dynamic HTML can display the 

overlapping objects on the page.

For more examples of referenced HTML, open the Referenced HTML sample site 

template.

For information on opening templates, see “Viewing Sample Sites” on page 9-8.
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Layering Objects 9

On the last page of the site, you decide to have some fun and experiment with 

overlapping objects because you know that many of your site visitors are using the 

4.0 browsers that take advantage of layering. To view overlapping objects properly, 

your site visitors must use a 4.x browser, such as Microsoft Internet Explorer 4.0 and 

above, or Netscape Navigator 4.0 and above.

In NetObjects Fusion you can choose from three HTML output options to support 

various browsers. You can assign one publishing method to the whole site, and then 

select a different method for individual pages, or regions of pages. For pages that 

contain overlapping objects, you must use the CSS and Layers HTML output 

option, so the browsers that support this feature can properly display your page.

To follow the steps in this lesson, you must first add the site section described in 

Chapter 7, “Working with Site Sections.”

This lesson shows you how to:

● Add and manage overlapping objects

● Set the HTML output option

● View sample sites
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Adding Overlapping Objects
You are going to add animated gif (Graphic Interchange Format) images to your 

page. An animated gif file contains a series of gif images stored in one file. In the 

browser these images play sequentially to provide an animated effect.

1. Open the Richter Brewing.nod site.

2. Navigate to the Awards page in Page view.

3. Select the Picture tool and draw a rectangle across the top of the Layout.

The Picture File Open dialog appears, showing the Folder tab.

4. Navigate to the NetObjects Fusion 3.0\Tutorial folder, select 
Welcome.gif, then click Open.

5. Center the picture’s rectangle near the top of the Layout.
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6. Select the Text tool and draw a text box so it overlaps the bottom right of 
the Welcome object.

Outline of 
animated GIF

Text box 
overlapping 
picture

Overlapping 
object icon
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To view object icons, 
select Object Icons 
from the View menu.

A red exclamation point icon appears on the text box and the Welcome 
object to show they are overlapping. Pass the mouse pointer over this 
icon to see the ToolTip explaining it.

7. In the text box, type the following text:

Welcome to our Awards page. We think Richter Brewing is really on 
target with our products.

8. If necessary, drag a handle to size the text box so the text wraps like the 
picture. If necessary, select the text box so it has solid handles, and drag 
it so it is in the same position as the picture.

9. Select the Picture tool and draw a rectangle across the layout below the 
text box.

10. In the Picture File Open dialog, navigate to the NetObjects Fusion 
3.0\Tutorial folder, select Dartboard.gif, then click Open.
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The red exclamation point icon also appears on the Dartboard picture to 
show it is overlapping, or overlapped by, another object.

The Dartboard picture is the last object you added, and is therefore on 
top of the text box. In this position it will cover the text in the text box 
when you preview in the browser.

11. Select the Dartboard object.

12. From the Object menu, select Arrange Objects, Send Backward.

The Dartboard is now “in back” of the text box.

Text box in 
back of 
picture
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Setting the HTML Output Option
To show the 
Properties palette, 
choose Palettes, 
Properties Palette 
from the View menu.

1. Click the Layout so the Layout Properties palette appears.

2. In the HTML output section, select CSS and Layers to ensure the 
browser correctly displays overlapping objects. This option is also 
recommended for pages that contain actions.

The red warning icons disappear from the overlapping objects.

3. Save your site.

Text box in 
front of 
both 
objects
Previewing Your Site
For portions of sites that use the CSS and Layers HTML output option for layered 

objects, you must preview the site using a 4.x browser, such as Microsoft Internet 

Explorer 4.0 or greater, or Netscape Navigator 4.0 or greater, because earlier 

versions of browsers do not support this feature.

◆ Preview your site.
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If NetObjects Fusion launches a 3.x browser, use the Windows Start menu to launch 

a 4.x browser. The next and subsequent times you preview, NetObjects Fusion will 

launch the most recently used browser. 

You can also set the HTML output option to Nested Tables, then preview using any 

browser. With this option, the browsers place the objects as close to their layered 

positions as possible, without actually overlapping them. 
Conclusion
This concludes the lessons in this Getting Started guide. To turn on the NetObjects 

Fusion Auto Save feature again, choose Preferences from the Edit menu and select 

the Auto Save option on the General tab. Recall that when this option is selected, 

NetObjects Fusion automatically saves your site each time you change the page or 

view.
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What’s Next?
The next two chapters describe the new features of NetObjects Fusion 3.0 and tell 

you how to migrate sites created with earlier versions of NetObjects Fusion.
Viewing Sample Sites
NetObjects Fusion 3.0 is distributed with sample sites that demonstrate various 

features of the product. Open and view the sample sites to gain more insight into 

the power of NetObjects Fusion 3.0.

The sample sites are in the NetObjects Fusion 3.0\Samples\Sites folder. Each site 

is stored in a template file you can easily view.

The sample site Atlas Antiques showcases many of the new features in NetObjects 

Fusion 3.0. Other sample sites showcase other features, such as NetObjects Fusion 

message-based actions, and building sites completely from external HTML.

Instead of opening the template, which opens the file for editing, it is best to open a 

new site based on one of these templates, which opens a copy of the template.
Opening a Template File
1. From the File menu, choose New Site, From Template.

The Select a Template File dialog appears.

2. Navigate to the NetObjects Fusion 3.0\Samples\Sites folder.

3. Open one of the site folders, such as Atlas Antiques.

4. Select the site’s .nft file, such as Atlas Antiques.nft.

5. Click Open.

The Save Site As dialog opens to the User Sites folder, so you can name 
the copy you will save there.

6. Type a name, such as Atlas copy, then click Save.

You can open the pages and look at them in Page view, check the other 
views, and preview the site to view it in a browser.
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What’s New in 
NetObjects Fusion 3.0? 10

If you’re stepping up to NetObjects Fusion™ 3.0 from NetObjects Fusion 2.x, you’ll 

want to quickly learn what’s new in this version. With NetObjects Fusion 3.0, you 

can take advantage of popular new trends in the world of Web publishing, including 

Dynamic HTML, Cascading Style Sheet positioning, and Everywhere HTML™, 

which lets you create browser-independent sites. With NetObjects Fusion’s 

expanded page layout capabilities, you can design your pages in a way that best fits 

your content. You can customize the directory structure of your published site to 

work smoothly with your Web server configuration. This chapter gives you a head 

start in learning about these new features and other improved functionality, 

including:

● Dynamic Web pages

● Browser-independent HTML

● HTML access

● Control over publish directory structure

● Sample sites

● Site view improvements

● Page view improvements

● Style view improvements

● Assets view improvements
What’s New in NetObjects Fusion 3.0? 10-1



D Y N A M I C  W E B  P A G E S

Tutorial.bk  Page 2  Tuesday, June 17, 1997  9:29 PM
Dynamic Web Pages
You can take advantage of NetObjects Fusion’s message-based Dynamic Actions™ 

to quickly and easily add animation, interactivity, transition effects, and more to 

your Web pages. NetObjects Fusion generates the necessary Dynamic HTML 

(DHTML) to make the page come alive for your site visitors. Using a simple point-

and-click visual menu, you decide what triggers the action, the object affected by 

the action, and the result of the action. 

Dazzle site visitors with animated wipes, the appearance and disappearance of 

objects, flying objects, and draggable objects. Or use actions to create interactive, 

educational pages, in which site visitors can learn and play by manipulating objects 

on the screen. You can chain actions to create sophisticated behaviors. If you know 

JavaScript™, you can expand the functionality of actions by adding your own. For 

complete information on using actions, see Chapter 21, “Building Dynamic Pages,” 

in the NetObjects Fusion 3.0 User Guide.
Everywhere HTML
NetObjects Fusion 3.0 overcomes the problems created by the diverging browser 

market because it generates Everywhere HTML. You can build sites that can be 

interpreted by all popular Web browsers from version 2.x to 4.x. You don’t need to 

publish multiple sites or tweak HTML code to achieve browser compatibility. 

Although some new HTML technologies can only be viewed in 4.x browsers, 

NetObjects Fusion generates HTML that works across browsers. For example, 

although DHTML is only supported by 4.x browsers and higher, site visitors with 

older browsers do not encounter errors when they visit your dynamic pages; instead 

they see the animated or dynamic objects in their static and visible positions. 

You can tailor your page layout method to fit your content in NetObjects Fusion 3.0. 

For pages that are mostly text, lay out your content in a text editor and take 

advantage of text wrapping and leaner HTML code; see “Embedding Objects in a 

Text Box” on page 7-24 in the NetObjects Fusion 3.0 User Guide for information. You 

can also set NetObjects Fusion to generate HTML in different formats: Cascading 

Style Sheet (CSS) positioning and layers, nested tables, or regular tables. CSS and 

Layers takes advantage of 4.x browser capabilities, while regular and nested tables 
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allow for greater compatibility with older browsers. With a single click in your 

publish settings, you can change the HTML output option for the entire site. If you 

want to change the HTML output option for only one page, or even for part of a 

page, you can do that too. See Chapter 5, “Planning Your Site,” and Chapter 7, 

“Laying Out the Page,” in the NetObjects Fusion 3.0 User Guide for information.
HTML Access
Using NetObjects Fusion’s HTML Access, you can view and add to code generated 

by NetObjects Fusion to insert HTML at precise locations. With NetObjects 

Fusion’s visual scripting interface, you can add custom HTML or JavaScript to any 

page or object. You can also add your own parameters inside the tags generated by 

NetObjects Fusion. For detailed information on editing HTML, see Chapter 22, 

“Working with HTML Directly,” in the NetObjects Fusion 3.0 User Guide.

If you need more control over HTML or prefer to use other HTML editors for some 

parts of your site, you can reference external HTML files anywhere in a NetObjects 

Fusion site. You designate part of a page or an entire page to reference your own 

HTML code, which will not be modified by NetObjects Fusion. At the same time, 

you can direct NetObjects Fusion to manage the assets referred to by your code, so 

they are transferred to the correct location each time you publish the site. To 

generate your own custom HTML code, you can use Allaire HomeSite™ 3.0, which 

is included with NetObjects Fusion. Recognized as the premiere HTML editor for 

Microsoft Windows, Allaire HomeSite 3.0 offers you the advantage of complete 

control over your HTML. For information on referencing external HTML, see 

Chapter 19, “Referencing and Editing External HTML.”
Publish Directory Structure Control
Publish view has been redesigned so you control the structure of your published 

Web site. NetObjects Fusion 2.x restricted you to publishing HTML and image files 

into a specific directory structure. In NetObjects Fusion 3.0, you manipulate files 

and folders in the familiar Windows Explorer interface to determine the directory 

structure of your published site. If you do not want to customize the directory 

structure, you can choose from three preconfigured directory structures: flat, by 

asset type, and by site section. For more information on directory structure control, 
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see Chapter 26, “Publishing Your Site” in the NetObjects Fusion 3.0 User Guide for 

information.

Publish setup has been expanded so you can specify the HTML output option for 

the site. The HTML output option determines what kind of HTML code 

NetObjects Fusion generates when it publishes your site. Publish setup now lets you 

manage multiple publish locations for each site. When you publish, you can publish 

changed assets only instead of publishing the whole site. For information on using 

publish settings, see “Configuring Publish Setup” on page 26-4 in the NetObjects 

Fusion 3.0 User Guide.
Sample Sites
NetObjects Fusion comes with professionally designed sample sites. These sites, 

located in NetObjects Fusion 3.0\Samples\Sites, are complete sites with real 

content, designed to showcase new features like object embedding, form layouts, 

referenced HTML, and Dynamic Actions. You can base your own sites on sample 

sites as described in “Creating a Site from a Template” on page 3-4 in the NetObjects 

Fusion 3.0 User Guide. 
Site View Improvements
● Improved site import: Better at handling text wrapped around objects, tables, 

horizontal rules, and scripts. Import has improved syntax checking to allow for 
HTML irregularities. 

● Section control: The ability to apply MasterBorders and other page properties to 
a section of pages, and to preview only a section of pages. See “Working with 
Sections” on page 2-9 in the NetObjects Fusion 3.0 User Guide for information. 

● Export site: An improved method for making templates that also saves the style 
with the exported template. 
Page View Improvements
Page view includes many improvements. The user interface has been redesigned so 

you can easily customize your workspace. Productivity enhancements help you 
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work more precisely with less effort. Overall, Page view is now more intuitive and 

more responsive to the context in which you are working. Page view improvements 

include:

● Dockable toolbars: Toolbars that you can drag into the window border to dock, 
or that you can drag into the page to convert to floating windows. 

● Guides: Improved guides that work regardless of the grid settings and that can be 
applied to one page only, or to a set of pages. See “Showing and Hiding Rulers, 
Guides, and Grids” on page 4-5 in the NetObjects Fusion 3.0 User Guide for 
information. 

● Rulers: Visual measurement indicators on the top and left of the page area, based 
on the measurement unit you set in Preferences.

● Site Navigation window: A mini Site view you use to move between pages 
without going to Site view. See “Using the Site Navigation Window” on page 4-6 
in the NetObjects Fusion 3.0 User Guide for information.

● Embedding objects: The ability to embed objects in text boxes, table cells, or 
layout regions, which provides greater layout flexibility, text flow around objects, 
automatic inset control, and grouping of objects. See “Embedding Objects in a 
Text Box” on page 7-24 in the NetObjects Fusion 3.0 User Guide for information.

● Enhanced text style control: The ability to create text styles with specific font 
attributes and apply them throughout your site. See “Creating a Text Style” on 
page 8-9 in the NetObjects Fusion 3.0 User Guide for information.

● MasterBorder options: The ability to delete MasterBorders and to make new 
MasterBorders based on existing ones. Includes a blank MasterBorder for pages 
that don’t need margins. See Chapter 6, “Managing MasterBorders and 
AutoFrames,” in the NetObjects Fusion 3.0 User Guide for information.

● Layer control: The ability to position objects on top of each other when 
publishing with CSS and Layers, to hide and show objects, and to send objects to 
front or back. The Object Tree palette displays the hierarchy of objects on the 
page. See Chapter 4, “Page View Basics,” and Chapter 5, “Planning Your Site,” in 
the NetObjects Fusion 3.0 User Guide for information.

● New Color Picker: A feature rich Color Picker, with a browser safe palette, a 
Microsoft Windows palette and the ability to create, load, and save custom 
palettes. It also displays the hex value for each color, a selection of recently used 
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colors, and lets you visually compare original and new colors. See “Choosing 
Colors” on page 1-9 in the NetObjects Fusion 3.0 User Guide for information on 
the Color Picker.

● Form Area tool: A new Form Area tool that you use to place multiple forms per 
page and choose among containers for your forms. See Chapter 17, “Designing 
and Implementing Forms,” in the NetObjects Fusion 3.0 User Guide for 
information.

● Table tool: An improved table tool that you use to embed text, objects, or both in 
table cells. See Chapter 9, “Adding Tables,” in the NetObjects Fusion 3.0 User 
Guide for information.

● Picture tool: An improved picture tool that you use to add borders to pictures, 
maintain aspect ratio when resizing pictures, and open pictures in the image 
editing application of your choice. It also supports more image file types such as 
progressive JPEG and PNG. See Chapter 10, “Placing Pictures,” in the NetObjects 
Fusion 3.0 User Guide for information.

● Improved <HR> tool: An improved horizontal rule tool that offers thickness and 
shading settings.

● New external HTML tool: A new tool that you can use to reference external 
HTML files, manage their assets, and launch an external HTML editor. See 
Chapter 19, “Referencing and Editing External HTML,” in the NetObjects Fusion 
3.0 User Guide for information.

● Improved Java™ tool: An improved Java tool that offers a choice between 
<APPLET> and <SERVLET> tags. See Chapter 16, “Adding Java and ActiveX™,” 
in the NetObjects Fusion 3.0 User Guide for information.

● Better plugin support: Added plugin support for VRML, FlashPix, Headspace™ 
Beatnik, Adobe Acrobat™ (.pdf), Live Picture (.fpx), RealSpace (.ivr), and 
others. See Chapter 15, “Placing Media,” in the NetObjects Fusion 3.0 User Guide 
for information.

● Better Shockwave™ implementation: The ability to visually set parameters 
and to see the actual size of Shockwave Director and Flash files. See Chapter 15, 
“Placing Media,” in the NetObjects Fusion 3.0 User Guide for information.
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● QuickTime™ support: Ability to visually set specific QuickTime parameters in 
the properties palette. See Chapter 15, “Placing Media,” in the NetObjects Fusion 
3.0 User Guide for information.

● Component changes: The addition of a mailto option for Form Handler, a new 
Picture Rollover component, and the addition of Macintosh as a Web server 
platform for Form Handler and Message Board. See Chapter 18, “Using 
NetObjects Fusion Components,” in the NetObjects Fusion 3.0 User Guide for 
information.
Style View Improvements
See Chapter 12, “Using SiteStyles,” in the NetObjects Fusion 3.0 User Guide for 

details about Style view improvements.

● Better interface for style management: A more intuitive model for creating, 
adding, removing, and updating styles.

● Easier procedure for editing styles: The ability to double-click style elements 
you want to edit.

● New SiteStyle collection: More than 50 new professionally designed SiteStyles 
you can use to give your site a unique look and feel. In addition, all SiteStyles 
from previous versions of NetObjects Fusion are included in the \Extras folder 
on the NetObjects Fusion CD-ROM.
Assets View Improvements
See Chapter 25, “Managing Assets,” in the NetObjects Fusion 3.0 User Guide for 

details about Assets view improvements.

● Asset editing: The ability to open any image, sound file, HTML file, and more in 
the application of your choice for convenient editing. NetObjects Fusion updates 
the edited file.

● Data objects improvements: The ability to delete a data object, support for 
current ODBC connections, and the ability to use Microsoft Excel‘97 and Access 
97 files as a data object source.
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Upgrading from Previous 
Versions of NetObjects Fusion 11

If you created sites with a previous version of NetObjects Fusion, there are several 

techniques you can use to upgrade them to NetObjects Fusion 3.0. You can simply 

open the site, or you can save it as a template and base a new site on the template or 

import the template. For the latest information on compatibility, refer to the 

ReadMe or Recover.txt file in your \NetObjects Fusion 3.0 folder. This chapter 

helps you update NetObjects Fusion 2.x files, describing: 

● Opening site files from previous versions

● Upgrading site files from previous versions

● Adding your SiteStyles

● Editing your Blank Site template to include added styles

● Removing previous versions
Upgrading from Previous Versions of NetObjects Fusion 11-1



M I G R A T I N G  S I T E S  A N D  A S S E T S  F R O M  N E T O B J E C T S  F U S I O N  2 . X

Tutorial.bk  Page 2  Tuesday, June 17, 1997  9:29 PM
Migrating Sites and Assets 
from NetObjects Fusion 2.x
Site (.nod) and template (.nft) files created in the versions listed below are 

compatible with NetObjects Fusion 3.0. Some components and data object 

information might not appear. If this happens, you must place the components or 

the data object information again. 

Versions supported (.nod and .nft): 

● Windows 2.0, 2.01, 2.02

● Windows 2.02 international (except Chinese, Korean, and Japanese)

● Windows TeamFusion 1.0 (.nft only)

● Macintosh 2.0.1 (same as 2.0), 2.02

Versions not supported (.nod and .nft): 

● Windows 1.0

● Macintosh 1.0

● Windows 2.02: Chinese, Korean, and Japanese versions 

If you have sites built in versions that are not supported, and you want to use them 

in NetObjects Fusion 3.0, visit the support area at www.netobjects.com for more 

information. 

Upgrading to NetObjects Fusion 3.0 from NetObjects Fusion 2.x involves more 

than just installing the new software as described on the NetObjects Fusion 

Installation and Quick Start card. You must move the sites and other assets you 

created in 2.x into the 3.0 environment. 

From NetObjects Fusion 3.0, you can open a 2.x site file in two ways; by opening it 

directly or by importing it. If you open a 2.x file directly, NetObjects Fusion 

prompts you to open a copy because once you open a file in 3.0, you cannot open it 

in an earlier version. You can import the file into a 3.0 site instead of opening it to 

ensure increased stability of your updated site. 
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This section guides you through the process of moving from NetObjects Fusion 2.x 

to NetObjects Fusion 3.0. The discussion assumes you are familiar with NetObjects 

Fusion’s site files, directory structure, SiteStyles, and templates.

Look at the following upgrading scenarios to find the information you need.

● If your site file is on the same computer, copy its folder from your old User Sites 
folder to your new User Sites folder, and then open the file directly, as described 
in “Opening Site Files from Earlier Versions” on page 11-4.

● If your 2.x site file was created on a different computer, and you want to open it 
in NetObjects Fusion 3.0 on your computer, you have to save it as a template 
(.nft) first. You must open the 2.x site in its original version on the machine 
where it was created, export it as a template, copy the template folder to your 
computer, and then base a new site on the template. Saving a site as a template is 
the only way to move a site from one computer to another without losing asset 
information. To learn how to create a new site from a template, see “Creating a 
Site from a Template” on page 3-4 of the NetObjects Fusion 3.0 User Guide. 

● If your 2.x site file has exhibited instability problems, try upgrading the site as 
described in “Upgrading Site Files from Earlier Versions” on page 11-5.

● If you already opened a 2.x file in 3.0 and the file has since exhibited instability 
problems, try upgrading the site as described in “Upgrading Site Files from 
Earlier Versions” on page 11-5.

● If you opened your 2.x file in 3.0 or created a 3.0 file from your 2.x template and 
the style is missing, see “Adding Your SiteStyles” on page 11-6 for information.

● If you want your old styles to be in the style list for all new 3.0 sites, see “Editing 
Your Blank Site Template to Include All Styles” on page 11-7 to learn how to 
update your blank site template. 

● If you want to use TeamFusion templates, you can create a new site based on the 
NetObjects TeamFusion template; see “Creating a Site from a Template” on 
page 3-4 of the NetObjects Fusion 3.0 User Guide. You can also import the 
template into a site; see “Importing Templates” on page 3-11 of the NetObjects 
Fusion 3.0 User Guide. 

● If you already upgraded your files and want to remove the previous version of 
NetObjects Fusion, read “Removing Previous Versions of NetObjects Fusion” on 
page 11-8 for information.
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Opening Site Files from Earlier Versions
To open NetObjects Fusion 2.x sites in NetObjects Fusion 3.0, first copy your site 

folders  from your 2.x User Sites  folder to your 3.0 User Sites folder. Then launch 

NetObjects Fusion 3.0 and open each .nod file in NetObjects Fusion 3.0. When 

NetObjects Fusion prompts you to make a copy of the file, choose to make a copy. 

Note: If any of your colleagues use NetObjects Fusion 2.x for Macintosh or Windows 
and have not yet upgraded, they will not be able to work with sites you upgrade. 
Earlier versions of NetObjects Fusion cannot read files that have been opened or 
created in NetObjects Fusion 3.0.

If you experienced any instability problems with a site built in NetObjects Fusion 

2.x, or have experienced instability problems after you opened a 2.x file in 3.0, 

upgrade the site as described in “Upgrading Site Files from Earlier Versions” on 

page 11-5 instead of using the following steps.

To open sites in NetObjects Fusion 3.0:

1. Use Windows Explorer or File Manager to copy the folders of the sites 
you want to upgrade from your NetObjects Fusion 2.x\User Sites 
folder to your NetObjects  Fusion 3.0\User Sites folder.

2. Launch NetObjects Fusion 3.0.

If a Welcome To NetObjects Fusion dialog appears, click Cancel to 
dismiss it.

3. In Site view, from the File menu, select Open Site, and open the .nod file 
of the site you want to upgrade.

This dialog appears.  As an extra precaution, open a copy.
11-4 Upgrading from Previous Versions of NetObjects Fusion



M I G R A T I N G  S I T E S  A N D  A S S E T S  F R O M  N E T O B J E C T S  F U S I O N  2 . X

Tutorial.bk  Page 5  Tuesday, June 17, 1997  9:29 PM
4. Click Yes and save the copy in the same folder with a new name.

NetObjects Fusion creates a new .nod file. The original 2.x .nod file 
remains in the folder as a backup. 

5. Repeat the steps above until all the sites you want to bring into 
NetObjects Fusion 3.0 are upgraded. 

You can also open backup files created in NetObjects Fusion 2.x. Backup files are 

automatically saved in the \Backup folder inside your site folder. 
Upgrading Site Files from Earlier Versions
If you have sites that were originated in NetObjects Fusion 2.0 or 2.01, they might 

have stability problems. This section offers an alternative procedure for moving sites 

to NetObjects Fusion 3.0. If any of your sites exhibited stability problems, use the 

following procedure instead of opening the site file using the Open Site command. 

This procedure involves importing your 2.x site into a 3.0 site, which will result in 

the loss of internal data object information. If your original site contains an internal 

data object, you have to add the data again after following this procedure. See the 

Recover.txt file in your NetObjects Fusion 3.0 folder for the latest information.

To upgrade NetObjects Fusion 2.x files to NetObjects Fusion 3.0:

1. Open NetObjects Fusion 3.0.

2. From the File menu, select Open Site, select your 2.x .nod file, and click 
Open. 

A warning dialog asks if you want to open a copy instead.

3. Click Yes, enter a new name for the .nod file, and save it to the same 
folder as the original .nod. 

Your file opens in NetObjects Fusion 3.0. It is now in 3.0 format.

4. From the File menu, select New, Blank Site, enter a new name, and click 
Save.

A new site opens.

5. In Site view, from the File menu, select Import Template, and select the 
copy of the .nod.
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To see .nod files in the Import Template dialog, select NetObjects Fusion 
Files (*.nod) from the Files of Type drop-down list. 

The site is imported. If you get a message that a data object named 
Sample cannot be imported, click OK. Your site is now in NetObjects 
Fusion 3.0, but has two Home pages. The second Home page is your 
site’s original Home page. The top Home page is a blank Home page.

In the following steps, you copy the contents of the second Home page 
to the first Home page, move all the second Home page’s child pages 
under the first Home page, and then delete the extra Home page.

6. Click the second Home page from the top and go to Page view. 

7. Click in the MasterBorder and note the current MasterBorder name in 
the Name field of the MasterBorder Properties palette. 

8. Click in the Layout area, and from the Edit menu, first choose Select All 
and then select Copy to copy all the contents.

9. Go to the top Home page in Page view, click in the upper left of the 
Layout area, and from the Edit menu, select Paste.

10. In the General tab of the MasterBorders Properties palette, select the 
same MasterBorder that is applied to the second Home page.

11. In Site view, move all the pages on the third level underneath the first 
Home page, so they become child pages of the first Home page.

The second Home page should have no child pages.

12. Click the second Home page, press Delete, and confirm the deletion.

The second Home page disappears.

13. Go to Style view and set the style you want to apply to the site. 

If the style you want appears blank, add the style using the procedure 
described in “Adding Your SiteStyles” on page 11-6.
Adding Your SiteStyles
The SiteStyles listed in Style view are specific to the active .nod file. When you create 

a new site, the .nod file inherits the list of SiteStyles available in the template on 

which the new site is based. If you want to use a SiteStyle from an earlier version of 
11-6 Upgrading from Previous Versions of NetObjects Fusion



M I G R A T I N G  S I T E S  A N D  A S S E T S  F R O M  N E T O B J E C T S  F U S I O N  2 . X

Tutorial.bk  Page 7  Tuesday, June 17, 1997  9:29 PM
NetObjects Fusion in a NetObjects Fusion 3.0 file, you first add the SiteStyle to your 

new site. 

To import SiteStyles into NetObjects Fusion 3.0:

1. If you want to add several styles, first use Windows Explorer or File 
Manager to copy the folders of the SiteStyles you want to add to your 
NetObjects Fusion 3.0\Styles folder.

2. In NetObjects Fusion 3.0, open the site where you want to use the new 
SiteStyles.

3. Open Style view and add SiteStyles.

● To add only one SiteStyle, from the Style menu, select Add Style. In 

the Open File dialog, navigate to and select the .ssf file of the 

SiteStyle you want to add, and click OK. The .ssf file is in the style’s 

folder. The SiteStyle appears in the style list.

● To add several SiteStyles, from the Style menu, select Update Styles 

List. NetObjects Fusion updates the style list to include all SiteStyles 

currently in the Styles folder. 

The SiteStyle is now available in the current site. To make the SiteStyle 
automatically available in every new blank site you create, you must edit 
your Blank Site template to include that SiteStyle. For information on 
editing the Blank Site template, see “Editing Your Blank Site Template to 
Include All Styles” on page 11-7.
Editing Your Blank Site Template to Include All Styles 
Every time you create a new blank site, it is based on the Blank Site template in the 

NetObjects Fusion 3.0\Templates\AutoSites\ folder. Because every new site 

inherits the style list from the Blank Site template, you must edit the Blank Site 

template to permanently update the style list. You can also make other changes to 

the Blank Site template, such as deleting the navigation bar and banner. Any change 

you make to the Blank Site template will be reflected in every new blank site you 

create.
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1. In Windows Explorer or File Manager, make a backup copy of the Blank 
Site folder located in your NetObjects Fusion 
3.0\Templates\AutoSites folder.

2. In NetObjects Fusion 3.0, from the File menu, select Open Site, and 
open the Blank Site.nft located in the Blank Site folder.

To see .nft files in the Open dialog, select All Files (*.*) from the Files of 
Type drop-down list. If you see a message about the Automatic Backup 
folder, click OK.

3. Go to Style view and add SiteStyles. 

Follow the procedure described in “Adding Your SiteStyles” on page 11-6 
to add styles. If you want, you can make other changes to the Blank Site 
template also.

4. From the File menu, select Save Site.

NetObjects Fusion 3.0 replaces the default Blank Site.nft with a new one 
that includes the SiteStyles you just added to the style list. Now every 
new site you create includes the updated list of styles.
Removing Previous Versions of NetObjects 
Fusion
You can use the Add/Remove Programs utility available in the Windows Control 

Panel to remove previous versions of NetObjects Fusion. You should remove 

expired copies of evaluation versions.

Remove NetObjects Fusion 2.x only after you verify that all site files, SiteStyles, 

templates, and other assets that you brought into NetObjects Fusion 3.0 are 

functioning as you expect. Also, do not remove NetObjects Fusion if you need to 

share files with colleagues who still use NetObjects Fusion 2.x for Macintosh or 

Windows. Earlier versions cannot read templates created by NetObjects Fusion 3.0.
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Picture properties 1-10, 2-15
Picture tool 1-9, 3-4

pictures
adding 1-9
aligning in text 5-5
in text 5-1
linking 8-3
placing in text 5-3
sizing 1-11

Plus (+) button
on Actions tab 4-7

Preferences
Backup tab 2-8
General tab 2-7
Page tab 2-8

preferences
setting 2-6

Preview button 1-13, 2-3
previewing

sites 1-13
previous versions 11-1, 11-2
primary buttons

in SiteStyle 1-12
Properties palette 1-3, 1-6

in Site view 2-4
Page tab 2-5
Site tab 2-5
View tab 2-5

properties palette
showing 9-6

publish directory structure 
control 10-3

Publish Setup dialog
and HTML output option 4-13

Publish view 2-19
Publish button 2-19
Setup button 2-19

publishing
setting parameters of 2-19

R
Reference HTML Page dialog 8-5
Regular Tables option 2-12
Remove Customization button 3-10
RTF file

placing 5-2
rulers 1-5, 2-10, 2-14

S
sample sites 2-21, 9-8
sample sites, described 10-4

saving
sites 1-3, 1-14

secondary button
in SiteStyle 1-12

secondary buttons 1-12
section

assigning MasterBorder to 7-5
selecting 7-4

Section tab 7-4
Select Section command 7-4
Select tool 1-3, 1-4
Set Action dialog 4-7
Set Style button 1-12, 2-18
Set style button 1-12
setting

preferences 2-6
publishing parameters 2-19
SiteStyles 2-18

Setup button 2-19
Site Navigation window 2-15, 8-5
Site Navigation Window button 2-

15, 8-5
Site view 1-3, 2-3

adding pages in 1-3
menus in 2-6
naming pages in 1-4
Outline view 2-9
Properties palette 2-4
setting preferences in 2-6
Standard toolbar 2-4

sites
building 1-1
compatibility 11-4
compressing database 1-14
creating backup of 2-9
creating new blank 1-2
creating sections in 7-1
editing new blank site 11-7
exiting from 1-14
filename extension 2-2
naming 1-3
.nod filename extensions in 1-2
opening 2-2
previewing 1-13
samples of 9-8
saving 1-3, 1-14
setting style of 2-18
upgrading 11-5

SiteStyles
Index-3
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adding 11-6, 11-7
compatibility 11-6
creating 2-18
editing 2-18
elements of 1-11
list of 1-11
objects in 1-12
secondary button in 1-12
setting 1-11

sizing
HTML to Layout 8-7
pictures 1-11

smart links 2-17
Standard toolbar 2-4
Standard Tools palette 1-5

Text tool 1-6
Stretch option

in Picture properties 4-3
Style button 1-11
Style menu 2-18
Style view 2-18

Style menu 2-18
Submit button

adding to form 6-10
and forms 6-1

symbols
Link icon 2-15
Picture In Text icon 5-6
warning icon 9-4

T
tables 6-1
template files

opening 9-8
text

adding to a page 1-6
formatting 1-8
placing pictures in 5-1, 5-3

text boxes 6-1
editing 8-3
in Layout Region 6-3

Text menu 2-11
Text navigation bar 1-5, 1-14
Text properties 1-8, 6-3
Text tool 1-6, 6-3
title bar 1-3
toolbars

moving 1-6, 2-4
ToolTips 1-4

U
Undo command 2-10, 2-14
undoing

actions 6-4
uninstalling 11-8
upgrading

sites 11-4, 11-5
SiteStyles 11-6

V
Variables view 2-19
version compatibility 11-1, 11-2
versions

of browsers 4-1
View menu 2-11
View tab

in Page view 2-11
in Site view 2-5

viewing
object icons 4-9, 9-4

views
in NetObjects Fusion 2-1

W
warning icon 9-4

Z
ZeroMargins MasterBorder 3-2
Zoom tools 1-3, 2-3, 2-4
Index-4
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