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Introduction

Using Visio Products is part of an integrated documentation set that includes
this manual and a comprehensive collection of online help topics designed to
present the information you need to create drawings and diagrams in your
Visio application.

About this manual

This manual is organized into categories that parallel how you work in Visio
applications, according to the tasks you might perform. The tasks are divided
and organized into the following work-focused categories:

Introducing the Visio environment: Chapters 2–3  How to get your drawing on
the page. You may never need more than this section to get started in Visio.

Creating the content of your drawing: Chapters 4–9  The details of working
with and formatting shapes, lines, and text, and how to easily include data or
objects you’ve created in other programs in your Visio drawings.

Printing and delivering shapes: Chapters 10–13  Once you’ve created your Visio
drawing, you need to get it to your audience—whether you are printing, saving
the drawing as an HTML page, displaying drawings in Microsoft Office applica-
tions, or including your Visio work in a document created in another program.

Increasing your productivity: Chapters 14–19  How to set up your drawings to
make revising them quick and simple. Use templates, styles, and layers to ensure
consistency across multiple drawings, and organize shapes into categories so
you can work with them more easily in batches, rather than singly.

Working with data stored in shapes: Chapters 20–23  Visio shapes can be con-
tainers for data—they can serve as graphical representations of database
records or other data files you may already have created for your business.

Creating and customizing shapes: Chapters 24–27  How to create your own
shapes, behavior you can add to shapes you draw to make them “smart,” and
how to add hyperlinks, or “jumps,” to shapes.
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Getting more information 

In addition to this document, much of the assistance you need as you use Visio
applications is specific to the shapes and templates you work with onscreen. To
give you immediate and targeted information as you work, use these additional
sources of information:

Tips  To find out what a specific tool or button on one of the toolbars does, float
the pointer over it for a moment. A tip appears on the screen.

Shape help  For information about the specific features of any Visio shape,
right-click the shape, then choose Shape Help from the shortcut menu. (You
can print the topic by right-clicking the shape help window.)

Template help  To discover the best sequence in which to work in specific tem-
plates, or how to work with the shapes or page settings, choose Help > Template
Help, double-click Visio Templates, and then choose the drawing type about
which you want information.

Online help  The Visio online help is available onscreen when you press F1,
choose a command from the Help menu, or click Help in a dialog box. The
online help also presents information that does not appear in this manual, in-
cluding a command and tool reference, a programming language reference, and
procedures and reference information for working in the Visio ShapeSheet
spreadsheet.

Developing Visio Solutions  Developing Visio Solutions contains information for
anyone who wants to build custom shapes or solutions with Visio applications.
This book describes how to program in the ShapeSheet window and how to ex-
tend Visio using Microsoft Visual Basic for Applications (VBA) and
Automation. Depending on the Visio product you purchased, you may have re-
ceived a printed copy of this book in your box. If you did not, or if you are
working in a corporate environment in which not all Visio users receive printed
books, you can find the .pdf file for Developing Visio Solutions on your Visio
CD-ROM in a folder called Docs. You can use the .pdf file by first installing
Acrobat Reader from your Visio CD, and then opening DVS.pdf in Acrobat
Reader.
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Drawing Resources  This page on the Visio Web site contains links to resources
for most drawing types included in the Visio templates. Choose Help > Visio
On The Web > Drawing Resources.

Sources for additional information  More resources for getting the answers you
need to work efficiently in your Visio application include the following:

• To reach Visio and the Visio Knowledge Base using the World Wide Web,
choose Help > Visio On The Web > Visio Home Page. Or, use the Visio
address: http://www.visio.com. The Visio Knowledge Base includes articles
that answer frequently asked questions (FAQs) and offer the latest tips on
using Visio.

• To reach the Visio forum on CompuServe, use the keywords GO VISIO.

Technical support

If you need more technical support for Visio products, the Visio Technical Sup-
port department can assist you. If you call, it’s helpful to be at your computer
and to have your product serial number available. The serial number is located
on your Visio product registration card.

As a registered customer, you receive:

• Ninety days of technical support with the purchase of a new Visio product.

• Thirty days of technical support with the purchase of an upgrade to your
Visio product.

The complimentary support period begins when you make your first phone call
to Technical Support.
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For technical support

Location Phone Fax Hours

In the United States (541) 882-8687 (541) 882-8446 Monday through Friday 6 a.m. to 5 p.m. PST

In the UK 0800 132 047 0800 132 048 Monday through Friday 9.00 to 17.00 GMT

In Germany 0130 820 485 0130 820 486 Monday through Friday 9.00 to 18.00 CET

In France 0800 906 479 0800 906 481 Monday through Friday 9.00 to 18.00 CET

In Spain 900 992 901 900 992 902 Monday through Friday 9.00 to 18.00 CET

In Sweden 020 794 443 +353 1 2601799 Monday through Friday 9.00 to 18.00 CET

In the Netherlands 060 225 920 +353 1 2601799 Monday through Friday 9.00 to 18.00 CET

In Australia 1800 501 642 1800 559 366 Monday through Friday 8.30 a.m. to 5.00 p.m. EST
+61 2 9333 8247 +61 2 9333 8199

In New Zealand  0800 444 358 Monday through Friday 8.30 a.m. to 5.00 p.m. EST

In South Africa 0800 994 238 Monday through Friday 9.00 to 17.00 GMT

In other countries +353 1 7060155 (English) +353 1 2601799 Monday through Friday 8.00 to 17.00 GMT, 9.00 to
+353 1 7060175 (German) 18.00 CET
+353 1 7060185 (French)
+353 1 7060156 (Spanish)



2
Creating and
saving drawings

About creating and saving drawings

Whether your business creates flowcharts, electrical schematics, facilities man-
agement drawings, network diagrams, architectural plans, or maps to the
company picnic, the Visio drawing programs have the tools you need—tools
everyone in the office can use.

In general, here are the steps you take in Visio to create a drawing:

1. Start a drawing by opening a template.

A template sets up your drawing page and opens stencils that contain master
shapes.

2. Add shapes to your new drawing by dragging them from a stencil to the
drawing page or by drawing your own.

You can create additional shapes with the Visio drawing tools on the Stan-
dard toolbar, and open additional stencils to choose from a wider variety of
shapes.

Add shapes.Open a template.



6 C H A P T E R  2

3. Arrange shapes to create the drawing you want.

Onscreen, the grid helps you align shapes, and the rulers give you precise
control. You can place guides and use the Align and Distribute commands
for quick alignment, or use the Size & Position command to enter exact co-
ordinates and dimensions.

4. Glue shapes together, so they stay connected when you move them.

With glue, you can update your diagrams quickly, without selecting and
dragging every line.

                            
5. Add text to your drawing.

You can add text to a shape by clicking a shape with the pointer tool, then
typing. Or use the text tool to type anywhere on a drawing.

6. Modify the look of shapes.

Formatting shapes is quick with the tools and style lists on the toolbars and
the commands on the Format menu. You can define your own styles in addi-
tion to the ones that come with the product.

7. Get your drawing to your audience.

Your drawing can stand on its own or become part of a larger document,
such as a Microsoft PowerPoint slide show, a Microsoft Word publication, or
a page on a World Wide Web site.

Related topics
About creating your own shapes ............................................................................. 207
About working with shapes ........................................................................................ 29
Adding shapes to drawings ......................................................................................... 11
Basing new drawings on templates .............................................................................. 9

Displaying and hiding toolbars and windows

In Visio, you can decide how you want to work by displaying only the toolbars
you need and arranging your windows to see them all at once.

Displaying and showing toolbars
The tools in Visio are grouped on toolbars based on the type of task you per-
form with them. For example, the Shape toolbar contains tools such as the fill
color and align shapes palettes, which you can use to format and arrange
shapes. The View toolbar contains tools you can use to choose what you want to
see onscreen.

The following toolbars are available in Visio:

Standard  Primary tools for dragging, dropping, and drawing shapes, as well as
standard Windows-program tools for opening, closing, saving, and printing
files.

Glue shapes together.

Arrange shapes.



C R E A T I N G  A N D  S A V I N G  D R A W I N G S 7

Text  Style lists for text along with tools for choosing format, alignment, size,
color, and bullets.

Shape  Style lists for lines and fills along with tools for shadows, layout, group-
ing, stacking order, and rotation.

View  Buttons for showing or hiding the grid, guides, connection points, and
displaying particular layers or layer properties.

Page  Buttons for paging forward or back, displaying a particular page, and for
turning snap and glue off and on.

Web  Tools for inserting hyperlinks, paging forward or back on the Web, open-
ing Internet Explorer, and starting Shape Explorer.

Developer  Tools for running macros, displaying the ShapeSheet spreadsheet,
opening Visual Basic For Applications, and switching to design mode while
working in VBA.

TIP  To see what a tool is for, pause the pointer over the tool on the toolbar. A tip
appears that describes the tool. If no tip appears, choose View > Toolbars >
Toolbars and make sure the Show ScreenTips option is checked.

To show or hide toolbars: 

1. Choose View > Toolbars > Toolbars.

2. Check the toolbars you want to view and uncheck those you don’t, then click
OK.

TIP  You can also view and hide toolbars by choosing View > Toolbars or right-
clicking the toolbar, then clicking to add or remove a checkmark next to the
appropriate toolbar on the menu.

Arranging windows
If you have more than one window open, you can arrange and resize them to
see them all.

To display windows side by side:

• Choose Window > Tile.

To arrange windows to see the title bar of each window:

• Choose Window > Cascade.

Related topics
About formatting shapes ............................................................................................ 49
About formatting text ................................................................................................. 85
Setting page orientation and scale ............................................................................. 17
Displaying, moving, and adding stencils ..................................................................... 8

You can make room on your screen by
choosing to hide the toolbars you aren’t
likely to use. You can also choose to show
larger icons or see tips about each tool
when you pause the pointer over it.
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Displaying, moving, and adding stencils

When you start a new drawing by opening a template, Visio opens one or more
task-related stencils. Stencils store master shapes, or “masters,” that you can
drag to the drawing page to add shapes to your drawing. If you need masters
that don’t appear on an open stencil, you can open additional stencils. By de-
fault, stencils are docked to the drawing-page window, but you can display
stencils as either docked or floating. Unlike a docked stencil, you can drag a
floating stencil to a different location on the screen.

Methods for working with stencils

To Do This

Switch between stencils Click the name of the stencil to switch to that stencil.

Open additional stencils Choose File > Stencils > Open Stencil, choose the stencil you want, then click OK.

Close a stencil Right-click the stencil’s title bar, then choose Close from the shortcut menu.

Make a stencil float Click inside the stencil where there are no buttons or icons, then drag the stencil
away from its docked position. Or right-click the stencil’s title bar, then choose
Float from the shortcut menu.

Dock a stencil Click inside the stencil where there are no buttons or icons, then drag the stencil to
the left or right side of the drawing window. Release the mouse button when an
outline of the stencil appears.

Minimize a floating stencil Click the minimize button on the stencil’s title bar. To expand the stencil again,
click the maximize button on the stencil’s title bar.

Move a docked stencil from one side Right-click the stencil’s title bar, then choose Switch Sides from the shortcut menu.
of the drawing window to another

Change how masters display on a stencil Right-click the stencil, then choose Icons And Names to display both master shape
icons and names, Icons Only to display only master shape icons, or Names Only to
display only the master shape names.

Change the order of masters on a stencil Open the original stencil and drag each master shape icon to arrange them in the
order you want.

Related topics
Displaying and hiding toolbars and windows ............................................................. 6
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Basing new drawings on templates

You can quickly create the type of drawing you want when you start with a
Visio template (*.vst) file. A template includes everything you need to create a
drawing, from the drawing page to shapes and styles. Using a template ensures
consistency across your drawing files, so you can focus on what goes on the
page while the template takes care of the rest.

When you start a drawing with a template, a Visio file opens that contains the
following:

• One or more stencils containing related shapes.

• A blank drawing page using a grid and measurement system that’s appropri-
ate for the type of drawing you’re creating, saving you the time it takes to set
up pages.

• A drawing page set up with the correct scale and page size. This applies to
scaled drawing types.

• Styles for text, lines, and fills appropriate to the type of drawing you’re creat-
ing, saving you the time it takes to define your own styles.

NOTE  Each template comes with help explaining the most efficient way to use
and combine shapes, how to perform specific actions using shape and page
right-click menus, how and when to run wizards that automate tasks, and more.
To display template help, choose Help > Template Help > Visio Templates, then
choose the appropriate template.

A

B

E

G

F

C

D

When you start Visio and open a template, the main drawing window opens with a drawing
page and one or more stencils.

A Tools on the toolbars are grouped in func-
tional sets, such as the Standard and Text
toolbars. You can choose which toolbars
you want to display, saving space
onscreen.

B By default, stencils dock to the left of the
drawing page. To bring a stencil to the
front, click that stencil’s title bar, which
may be at the top or bottom of the stencil.

C Tips appear when you pause the pointer
over tools on the toolbar or control
handles on shapes.

D The drawing page opens with size, orien-
tation, scale, grid, and measurements ap-
propriate for the drawing type.

E Stencils contain master shapes that you
can drag to the drawing page.

F The drawing page has a drawing grid,
which you can use to align shapes.

G The status bar indicates what Visio is do-
ing (for example, printing), and also shows
the dimensions and locations of selected
shapes.
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If the drawings you usually create require settings not available in any Visio
template, you can open a drawing with no template, revise an existing template,
or create one of your own.

A

C

B

Choose A Drawing Template dialog box

A Choose the type of drawing you want to create.
B Click to browse for other templates or drawing files saved on your computer.
C Choose the template on which you want to base your drawing. The file icon ( ) indicates

which files are template files.

To start Visio and open a new drawing file based on a template: 

1. Start Visio by clicking Start, then choosing Programs > Visio.

2. Double-click to open the folder that contains the type of drawing you want
to create, choose a template, then click OK.

To open a new drawing file without basing it on a template:

• Choose File > New > Drawing. An unscaled drawing page opens with no
stencils.

To display help for a particular template:

• Press F1, click the Index tab, then type the name of the template, or choose
Help > Template Help, double-click Visio templates, then choose the type
and name of the template you want.

Related topics
About working with styles and templates ............................................................... 137
Applying styles .......................................................................................................... 138
Creating new templates ............................................................................................ 142
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Adding shapes to drawings

The easiest way to create a drawing is to drag master shapes (or “masters”) from
a stencil to the drawing page. When you drop a master on a drawing page, you
create an “instance” of the master. The master itself remains on the stencil so
you can use it again and again to create instances.

When you drop an instance, Visio snaps the shape to the nearest grid line or
ruler subdivision so that you can position it precisely. To place shapes even
more accurately, you can zoom in or out from the drawing page. You can also
change what you snap to by choosing Tools > Snap & Glue.

If you want to create multiple instances of a master quickly, you can use the
stamp tool.

25 %
25 %

25 %
25 %

25 %

Dragging and dropping to create a drawing is accurate and fast when you use the grid and
rulers to position shapes.

100 90 80 70 60

To place the shape more precisely, pause while dragging to see the shape instead of the box
or line representing it. The pointer turns white when it’s over an object that you can drag.
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To drag and drop a shape: 

1. Choose the pointer tool ( ) from the Standard toolbar.

2. In the stencil, point to a master.

3. Hold down the left mouse button and drag the master from the stencil to the
drawing page.

4. Release the mouse button to drop an instance of the master in the drawing.

To stamp multiple instances: 

1. Choose the stamp tool ( ) from the Standard toolbar.

2. In the stencil, click a master.

3. In the drawing window, place the pointer where you want the shape. The
stamp tool places the shape’s pin where the pointer is. In most shapes, the
pin is in the center of the shape, so you would place the pointer where you
want the center of the shape.

4. Click the left mouse button.

You can continue clicking the page to add as many instances of the stamped
shape as you want.

5. When you’re done stamping, press the Esc key.

To delete a shape from the drawing page: 

1. Select the shape.

2. Do one of the following:

Choose Edit > Clear.

Press the Delete key on the keyboard.

To delete a shape from the drawing page and place a copy on the
clipboard: 

1. Select the shape.

2. Do one of the following:

Choose Edit > Cut.

Click the Cut button ( ) on the Standard toolbar.

To display help for a particular shape: 

• Right-click the shape, then choose Shape Help from the shortcut menu.

Related topics
About positioning shapes precisely ......................................................................... 155
About working with shapes ........................................................................................ 29
Displaying, moving, and adding stencils ..................................................................... 8
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Saving drawing files 

When you work on a drawing, you should save the drawing file frequently.
When you change a stencil or template, you should also save these files.

How you save a Visio drawing file (*.vsd) influences what happens when you
next open it. You can

• Enter file properties, such as title, author, keywords, and descriptions. When
you save a file for the first time, Visio prompts you for this information.
Then, when you select the file name in the Open dialog box, these descrip-
tion and preview properties appear to help you identify the file before
opening it. You can view all of the properties by right-clicking the file in
Windows, then choosing Properties.

• Save a preview of the first page or all of the pages of the drawing so that you
can identify the file before you open it. In the Open dialog box in Visio, you
see only the first page. In Windows 95 or Windows NT 4.0 Quick View
(right-click a file in Windows, then choose Quick View), you can see all of the
pages. Saving previews of all of the pages can increase the file size considerably.

• Save a drawing file as a template (*.vst) that you can use as a model for other
drawings.

• Save a drawing file in Visio 4.x format. When you open a 5.0 file in an earlier
version of Visio, information specific to Visio 5.0 products will be lost or
converted.

• Save a file as read-only to prevent it from being inadvertently edited or
changed.

• Export a file in HTML, Windows Metafile, or another format.

• Save the workspace when you save a drawing file. When you next open the
file, the stencil and drawing page windows will look just as they did when
you saved the file. You can save a workspace as part of a drawing, stencil, or
template, or as a separate file (*.vsw).

A

B
C

The first time you save a file, the Save As
dialog box appears, in which you can
choose a file name, type, format, version,
and location.

A Choose the file type, format, and version.
B Check to save the arrangement of stencil

and drawing page windows, as well as the
file content. This option is checked by de-
fault.

C Check to prevent the file from being modi-
fied the next time it’s opened.
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Saving a drawing file for the first time
The first time you save a drawing, Visio prompts you for document properties,
including whether or not to save preview pictures, which are small thumbnails
of drawing pages. Properties such as the description and the preview picture
appear in the Open dialog box when you select the drawing file name.

TIP  You can change a file’s properties later by choosing File > Properties.

A

C

D

B

E

F

A Displays the title, subject, and author of
the file, as well as the author’s manager
and company. You can type up to 63 char-
acters in each of these fields.

B Displays the category, or type, of drawing
file.

C Displays words (up to a total of 63 charac-
ters) that identify information about the
file, such as project name or version num-
ber. Keywords are used by the advanced
find feature in Windows 95 and Windows
NT 4.0, as well as by Visio Shape Explorer
if the file is added to its database.

D Displays information (up to 191 charac-
ters) about the file, such as its purpose or
recent changes.

E Specifies the base path for any hyperlinks
in the file.

F Saves a preview picture in the file to be
used in the Open dialog box and in Win-
dows Quick View. None saves the file
without a preview, Draft saves the file with
a preview picture of the Visio shapes only
(does not show embedded objects, text, or
gradient fills), and Detailed saves the file
with a preview picture of all objects. First
Page Only saves a preview of only the first
page of the file. This preview shows in the
Open dialog box in Visio, allowing you to
identify the drawing without opening it.
Leaving First Page Only unchecked saves
previews of all the pages of the file. These
previews show in Windows Quick View.

To save a drawing file for the first time: 

1. From the File menu, choose Save or Save As.

2. For File Name, type a name for the drawing file.

3. Under Save In, open the folder in which you want to save the file.

4. Click Save.

5. Enter properties information, then click OK to close the Properties dialog
box.

TIP  To quickly save changes to a file you’ve already saved, click the Save button
on the Standard toolbar or press Ctrl+S. By default, Visio saves existing files in
the format in which they were opened. To save in a different format, including
earlier versions of Visio, use the Save As command.
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Working
with pages

About working with pages

You can work with multiple pages in a single Visio drawing file to present and
organize your information. Using pages, you can

• Keep related drawings in the same file. For example, for an office expansion
project, you could keep the pages that contain office layout drawings in one
file and drawings of the distribution of office equipment in another.

• Keep all revisions of a single drawing in one file on successive pages, so that
you can show the progression from the beginning of the project to the end.

• Present a series of drawings at full screen view and navigate between them,
like a slide show.

• Link pages together like a Web site. For example, you could jump from a
workflow diagram shape to a detailed procedure on another page.

• Place items on background pages that you want to appear on every page,
such as a company logo.

• Rotate pages to make it easier to edit information that’s at an angle, such as a
room that isn’t square, or a city plan with some streets that are not perpen-
dicular.

As you work with drawing pages in a Visio drawing file, keep the following dis-
tinctions in mind: The page you see on the screen is called the “drawing page.”
You print the drawing on the “printed page,” which is the paper in the printer.
And the result of printing is the “printed drawing.”

Most Visio templates are set up so that the drawing page, printed page, and
printed drawing sizes are all the same, so you don’t have to change any settings
or sizes to get the printed drawing you expect.
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In some cases, though, you may change drawing-page settings, such as size, ori-
entation, or scale, as you create your drawing, in which case you’ll want to verify
that your printed-page settings work with the new drawing-page settings.

If you print a drawing that is larger than the printed page, the drawing prints across multiple
pages. This is called tiling. You can verify whether and where your drawing will break across
pages by choosing View > Page Breaks. Gray lines indicate the page breaks.

To avoid printing a large drawing across several tiled pages, you can:

• Change the drawing orientation to see if everything will fit.

• Choose to reduce the drawing by a percentage in the Print dialog box when
you print, so that it fits on the current page size.

• Set a drawing scale that represents larger real-world dimensions in a smaller
scaled space.

• Choose a larger printed page size.

Changes you make to drawing-page settings aren’t automatically reflected in printed-page
settings. Before you print, make sure settings, such as orientation, are the same for both the
drawing page and the printed page. For example, if you change a drawing page’s orientation
to landscape (left) without changing the printed-page settings from the default portrait
orientation, the drawing prints on a portrait page (right).
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Setting page orientation and scale

When you start a drawing by opening a template, the template includes page
settings for orientation and scale that affect how you work in a drawing and
how it prints. Sometimes you may want to change these settings as you work in
a drawing.

TIP  Changes you make to drawing-page settings aren’t automatically reflected
in printed-page settings. If you change the drawing-page orientation or scale,
check the printed page-settings in the Page Setup dialog box and change them if
needed.

Setting page orientation
You can set the orientation of the drawing page to portrait (tall) or landscape
(wide) in the Page Setup dialog box.

Portrait specifies a tall orientation; Landscape is a wide orientation.
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Setting a scale
When you are creating a drawing that represents real-world objects too large to
fit at their actual size on a piece of paper, or too small to depict, you must set a
“drawing scale.” The ratio of the shapes’ dimensions as they appear onscreen
(page units) to their real-world measurements (page units) defines the scale.
For example, in an office plan, the drawing scale might be 1:10, where 1 inch
onscreen represents 10 feet in the real world.

A

B
C
D
E
F
G

H

I

To set drawing orientation and scale:

1. Display the drawing page you want to change, then choose File > Page
Setup.

2. On the Page Size tab, select the orientation option you want.

3. On the Drawing Scale tab, select the scale you want or enter a custom scale,
then click OK.

To set printed page orientation:

1. Display the drawing page you want to change, then choose File > Page
Setup.

2. On the Page Size tab, click Print Setup.

3. Choose the orientation you want for the printed page, then click OK.

Related topics
About measuring and scaling in drawings .............................................................. 169
Setting drawing scales ............................................................................................... 170

A Type the ratio of the page units to the
drawing units in the edit box. Or choose
from the list of scales relevant to a par-
ticular discipline, such as architecture or
engineering, then type or choose the ratio
you want.

B If the drawing should print at its actual
size, select No Scale, then select 100%
scale in the Print Setup dialog box.

C Select to change the Drawing Scale list  to
standard  Metric scales, such as 1:100.

D Select to change the Drawing Scale list to
Imperial measurements such as 3/32" = 1' 0".

E Select to change the Drawing Scale list  to
Imperial measurements such as 1" = 10' 0".

FFFFF Select to change the Drawing Scale list to
Imperial measurements such as 1/32:1.

G Select to enter a custom ratio of page size
to drawing size, then type it in the Drawing
Scale edit box. For example, at 1 inch = 25
feet, a shape which measures 1 inch
(when printed at 100 percent) measures 25
feet on the Visio rulers.

H Specifies the size of the drawing page,
based on the Drawing Scale and the
Physical Page Size.

I Indicates the size of the printed page. You
can change this setting on the Page Size
tab.
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Rotating and resizing pages

You can rotate pages using the rotation tool and resize them using the pointer
tool.

Using the rotation tool, you can easily create drawings in which part of the
drawing is at an angle to the rest and work in each part orthogonally, that is, at
right angles or parallel to the rulers. For example, you can draw a building that
isn’t square or a city plan in which some of the streets run at an angle from the
rest. Rotating, similar to zooming, is simply a way of viewing your page. It
doesn’t affect printing or the page orientation you select in the Page Setup dia-
log box. When you print, the page prints just as it would if it were not rotated.
Resizing pages, on the other hand, does affect printing and the settings in the
Page Setup dialog box. You can resize pages when you want to add space to or
remove space from a drawing.

Rotating pages
When you rotate the page, existing shapes and guides rotate with it. However,
the rulers and grid stay at their original angle. Page rotation is disabled by de-
fault in all versions of Visio except Visio Technical. You can enable page rotation
in the Advanced tab of the Options dialog box.

Rotating the page and using rotated guides make it easy to create an angled section in a drawing. You can glue and align shapes to any guide.
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A

B

           

C

When you move the rotation tool over a page corner, it becomes a round rotation pointer (A).
The page’s drop shadow (B) indicates that the page is unrotated. Rotated pages have no drop
shadow.

When you drag the round rotation cursor, the page rotates around the zero point (C), which is
in the lower-left corner by default.

   
D

E

The origin of the rotation is the zero point of the rulers. To change the origin of rotation, move
the zero point by Ctrl+dragging the crosshair from the intersection of the rulers to where you
want the new zero point.

After you move the zero point (D) the center of rotation changes for the page. Rotated pages
have a gray non-printing dot at the lower-left corner of the page (E). This dot indicates that
the drawing is rotated so that you can tell the difference between a landscape page, for
example, and a portrait page that has been rotated 90 degrees. When you rotate the page,
the dot stays with that corner, so that if you rotated the page upside-down, the dot would
then be at the upper-right corner of the page.
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To enable page rotation:

1. Choose Tools > Options, then click the Advanced tab.

2. Check Enable Page Rotation, then click OK.

To rotate a page:

1. Make sure that page rotation is enabled, then display the page you want to
rotate.

2. Choose the rotation tool ( ) from the Standard toolbar.

3. Position the cursor over a corner of the page.

The cursor changes to a round rotation pointer ( ).

4. Drag the corner of the page to the rotation angle you want, then release the
mouse button.

TIP  To quickly rotate an angled section of your drawing so that it’s orthogonal,
right click on an angled guide and choose View As Horizontal or View As Vertical.

Resizing pages
Resizing pages enables you to add space to a page where you need it and to re-
move empty space you’re not going to use from a page, both without changing
the drawing scale. There are two ways to resize pages:

• Use the Page Setup dialog box to add space to or remove space from the top
and right sides of the drawing. For example, if you want more white space
around a drawing on which a reviewer can write comments, you can in-
crease the dimensions of the page to create a margin of space on those sides.

• Use the Ctrl key with the pointer tool to remove space from a particular side
of the drawing. For example, if you set the page size to be 9 by 12 inches, but
discover later that your drawing extends off the right side of the page, you
can drag that side of the page out to give yourself more room to draw.
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You can use Page Setup to remove an equal amount of space from the top and
right sides of a page.

Use the Ctrl key with the pointer tool to remove space from only the side you drag.
In this example, the left side was dragged in to remove extra space.

When you resize a page using either method, the shapes on the page stay in
their positions relative to the rulers. In other words, the x, y coordinates of the
shape remain the same.

When you print, the page prints starting in the top-left corner of the drawing
page. Keep this in mind when you resize a drawing page to be larger than the
paper you print it on, causing the drawing to be tiled on several pages when you
print.

NOTE  If the drawing page you resized has backgrounds assigned to it, you must
resize each of the backgrounds individually if you want the page sizes to match.

To resize a page using Page Setup:

1. Choose File > Page Setup.

2. On the Page Size tab, type the page dimensions you want or select a page size
option, such as Scale Page To Fit Drawing, then click OK.
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To resize a page with the pointer tool:

1. Choose the pointer tool ( ) from the Standard toolbar.

2. Position the pointer at the edge of the page on the side you want to move,
then hold down the Ctrl key.

The cursor changes to a double-ended arrow.

3. Drag the page edge to where you want it, then release the mouse button.

The new page size is reflected in the Page Setup dialog box.

To set the printed page size:

1. Display the drawing page you want to change.

2. Choose File > Page Setup, then on the Page Size tab, click Print Setup.

3. Choose the size you want for the printed page.

The display at the top of the dialog box shows the effect of your choices.

4. Click OK.

Related topics
Setting page orientation and scale ............................................................................. 17
Setting ruler units and the zero point ..................................................................... 160
Using backgrounds for common page elements ....................................................... 26

Creating multiple-page drawings

For some drawing projects, you may want to create a single drawing file that
contains many drawing pages. For example, a file could represent a facilities
project with the overall floor plan on one drawing page, a detailed view on an-
other page, and the plan for equipment and furniture on another page. New
drawings in Visio open with only one drawing page, but you can add as many
new pages as you want.
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Each page in a multiple-page drawing can have its own settings. For example, each page
can have a different drawing scale. Print settings, however, affect all pages.
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Creating and deleting pages
When you create a new drawing page, it inherits the size, orientation, scale,
measurement unit, shadow offset, and grid settings of the page currently dis-
played in the drawing window. You can change these settings in the Page dialog
box when you insert the page, or later in the Page Setup dialog box.

You can delete pages you no longer need. If you delete the last page in a file,
Visio replaces that page with a blank page.

TIP  To delete a background page, you first need to cancel its page assignment
because a background page assigned to a foreground page cannot be deleted.

To create a new page:

1. Choose Insert > Page to open the Page dialog box.

2. On the Page Properties tab, type a name for the page or use the default name
provided by Visio.

3. If necessary, click the Drawing Scale tab to change the scale or the Page Size
tab to change the page size for the new page.

4. Click OK.

To delete a page:

1. Choose Edit > Drawing Page > Delete Pages.

2. Choose the page you want to delete.

3. To update default page names to reflect the new page order, check Update
Page Names.

Checking this option has no effect on pages without default names.

4. Click OK.

Navigating between pages
Visio stores pages in the order you create them and displays them one at a time
in the drawing window. You can quickly navigate between pages and, if neces-
sary, you can change page order. When you change the order, you can also
change page names so they reflect the new arrangement.

You can also add navigational links to drawing pages or shapes that you can use
to jump directly to another drawing page.
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To navigate to a particular page:

• Choose the page that you want to go to from the Page list on the Page
toolbar. You can also use the Next Page ( ) and Previous Page( ) buttons
on the Page toolbar to navigate between pages.

NOTE  The Page toolbar is not displayed by default. To display it, choose View >
Toolbars > Page.

To rearrange pages:

1. Choose Edit > Drawing Page > Reorder Pages.

2. Choose the page you want to move.

The list displays the page names in the order they are stored in the file.

3. Click Move Up or Move Down to change the position of the page.

4. To update default page names to reflect the new page order, check Update
Page Names.

Checking this option has no effect on pages for which you changed the
names from the default.

5. Click OK.

Displaying pages simultaneously
If you want to view more than one drawing page at a time, you can open each
page in its own window. Or you can open a new window so that you can display
a new page you create and the original page at the same time.

To display a specific page in its own window:

• Choose Edit > Go To  > Page. Select the page, check Open Page In New Win-
dow, then click OK.

To open a new drawing window and display a page in it:

1. Choose Window > New Window.

Choose New Window when a drawing window is open to open a new win-
dow that contains a duplicate of the open window’s contents.

2. To see all the open windows, choose Window > Tile.

Related topics
Using backgrounds for common page elements ....................................................... 26
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Using backgrounds for common page elements

Each Visio drawing contains at least one foreground page and may also contain
one or more backgrounds. A background is a page that appears behind another
page. Create a background when you want the same shape to appear on more
than one drawing page. For example, you can place a common graphical ele-
ment, such as a company logo or a border, on a background. The element will
appear on each page to which you assign the background.
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Use a background to repeat a common element on several drawings. For example, on these
three pages, the company name is repeated on each one.

You can assign only one background to each foreground, but each background
can also have a background, so you can use backgrounds to create a layered
effect.

When you assign a background to a foreground page, the shapes on the back-
ground are visible when you display the foreground page, but you cannot edit
them from the foreground page. To edit the shapes on a background, you dis-
play that background in the drawing window, and then edit the same way you
edit a foreground page.

TIP  If you want to selectively view, edit, print, or lock shapes in a drawing, or if
you want to have multiple depths of text and shapes within the same page, use
layers instead of a background.

Creating and editing backgrounds
You can create a new page as a background or convert a foreground page to a
background. When you create a background, Visio adds it to the list of available
backgrounds in the Insert Page and Properties dialog boxes.

You edit the shapes on a background in the same way you edit the shapes on a
foreground page. You can display the background in one window and the page
it’s assigned to in another window, so you can see how the changes affect the
whole drawing. You cannot edit shapes on the background in the window that
displays the foreground page.
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NOTE  If you use the Page Layout Wizard to set up a drawing, the wizard auto-
matically creates a background and creates placeholders for elements such as
title blocks, borders, and logos. If you want to add any of these elements, you
must display the background page to modify it.

To create a background:

1. Choose Insert > Page.

2. On the Page Properties tab, select Background for Type.

3. If necessary, click the Drawing Scale tab to change the scale or the Page Size
tab to change the page size for the new page.

4. Click OK.

To convert a foreground page to a background:

1. Display the foreground page you want to convert to a background.

2. Choose File > Page Setup, then click the Page Properties tab.

3. For Type, select Background.

4. Click OK.

To display a background so you can edit it:

• Display the page to which the background is assigned, then choose Edit >
Go To > Background.

TIP  You can also display a background in a new window so you can view the
background and the pages it’s assigned to at the same time. To display a back-
ground in a new window, choose Edit > Go To > Page, check Open Page In New
Window, then click OK. Then, choose Window > Tile.

Assigning a background page
You can assign one background to each page in a drawing. You can assign the
same background to as many pages as you want. If you no longer want a back-
ground assigned to a particular page, you can cancel the assignment.

To assign a background to a page:

1. Display the page to which you want to assign the background.

2. Choose File > Page Setup, then click the Page Properties tab.

3. In the Background list, select the name of the background that you want to
assign.

4. Click OK.

The background displays behind the shapes on the foreground page.
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To cancel a page’s background assignment:

1. Display the page to which the background is assigned.

2. Choose File > Page Setup, then click the Page Properties tab.

3. In the Background list, select None.

4. Click OK.

Related topics
About layers ............................................................................................................... 143

Previewing drawings in full-screen view

If you want to preview or present Visio drawings, you can use full-screen view
to maximize the amount of space for your drawing. In full-screen view, the
Visio toolbars, title bars, status bar, menus, scrollbars, and stencils are hidden
and the drawing page takes up the entire screen. The drawing-page grid is also
turned off. Full-screen view is a view-only mode—you cannot edit or change
the pages you view.

To enter full-screen view:

• Choose View > Full Screen.

To exit full-screen view:

• Press the Esc key.

To navigate between pages in full-screen view:

• Press the left arrow, Page Up, or P keys on your keyboard to display the pre-
vious page.

• Press the right arrow, Page Down, or N keys to display the next page.

• Click the left-mouse button (when it’s not over a hyperlink) to display the
next page.

• Right-click anywhere in the window and choose Previous Page, Next Page,
or Go To > <page name>.

To navigate hyperlinks in full-screen view:

• Click hyperlinked shapes once to jump to the link.



4
Working
with shapes

About working with shapes

In Visio, the term “shape” can refer to one line, arc, or spline; a series of seg-
ments; or several shapes grouped together.

Shapes include master shapes, or “masters,” that come with Visio, as well as
shapes you draw yourself. Visio shapes are programmed to act the way you need
them to in a particular context. For example, shapes for doors, windows,
desks—things that are built to standard industry sizes—are locked against siz-
ing so you don’t accidentally stretch the shapes inappropriately as you are
working with them.

A single line is a shape and so is a rectangle. The table with chairs is a Visio master
composed of simpler shapes grouped together.

The desk chair is programmed to be easy to rotate.
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Closed and open shapes
A shape can be either closed or open. Shapes that are surrounded by a continu-
ous outline, such as rectangles or circles, are closed shapes, which means that
you can fill them with colors and patterns. Lines, arcs, or zigzag shapes are open
shapes, which means that you can format their ends.

The rectangle, which is a closed shape, is filled with a pattern. The lines, which are open
shapes, have line ends applied to them.

1-D and 2-D shapes
A shape can be either one-dimensional (1-D) or two-dimensional (2-D).

A 1-D shape behaves like a line, and displays endpoints that you can drag to
resize the shape when you select it with the pointer tool. You can glue the end-
points of 1-D shapes to the sides of 2-D shapes to create connecting lines that
stay in place when the shapes are moved.

A 1-D shape has only two endpoints. Some 1-D shapes also have other handles, such as this
arc’s control handle.

A 2-D shape behaves like a rectangle, and displays selection handles that you
can drag to resize the shape when you select it with the pointer tool.

A 2-D shape has more than two handles and can be closed (like the ellipse) or open (like the
zig-zag line).

With all shapes, except those that are locked against specific behavior, you can
do the following:

• Resize, move, flip, or rotate them.

• Change their stacking order relative to other shapes.

• Format and add text to them.

• Glue them to other shapes and guides.
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• Snap them to a guide, guide point, grid, or the alignment box of another
shape.

• Revise them by adding segments or changing the way they curve.

• Control how they appear onscreen, whether they print, and how they behave
when you double-click them.

• Associate them with data and use the data to generate reports.

• Add jumps to them that go to other pages in the same drawing, to other files,
or to World Wide Web sites.

• Control their behavior by modifying their ShapeSheet spreadsheets.

Customizing shapes in the ShapeSheet spreadsheet
To understand what makes a shape smart, it helps to know how shapes are
drawn and stored in Visio. Every Visio shape is described in its own ShapeSheet
spreadsheet, which contains information about the shape’s geometry and other
properties. For example, the ShapeSheet contains the coordinates of each shape
vertex and the shape’s dimensions. Much of this information can be defined by
formulas rather than by hard-coded numbers. This is important because it’s
what makes a shape smart; formulas allow a shape to behave differently based
on how it is used, rather than always behaving the same way.

To display a ShapeSheet spreadsheet, select a shape, then choose Show ShapeSheet from
the Window menu.

Related topics
About creating your own shapes ............................................................................. 207
About customizing shape behavior .............................................................. Visio Help
About formatting shapes ............................................................................................ 49
About protecting shapes and files ............................................................................ 173
Adding shapes to drawings ......................................................................................... 11
Changing shapes from 1-D to 2-D or from 2-D to 1-D .............................. Visio Help
Using shape handles ................................................................................................... 32
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Using shape handles

Visio shapes come with a variety of handles that you can drag to modify the
shape’s appearance, position, or behavior. For example, you can use handles to
glue one shape to another, move a shape’s text, or change the curve of an arc.

This section discusses the various types of shape handles and how to use them.

Selection handles and endpoints
Selection handles and endpoints appear when you select shapes with the
pointer tool ( ) on the Standard toolbar. To resize a shape, drag its selection
handles or endpoints.

Most shapes are two-dimensional (2-D) shapes, which have corner selection
handles that you drag to resize the shapes proportionally and side selection
handles that you drag to resize that side of the shape.

A

A

Two-dimensional shapes. The small green boxes on the corners and sides of each shape (A)
are its selection handles.

Some shapes, including all connector shapes, are one-dimensional (1-D)
shapes. One-dimensional shapes have endpoints—a begin point ( ) and an
end point ( ).

A

B

C

One-dimensional shapes. In addition to begin points (A) and end points (B), some 1-D shapes
have two selection handles (C).
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Connection points
Some 2-D shapes have connections points, where you can glue the endpoints of
a 1-D shape to the 2-D shape. You an create new connection points using the
connection point tool ( ) on the Standard toolbar.

Rotation handles
Rotation handles appear when you select a shape with the rotation tool ( ) on
the Standard toolbar. They are indicated by green round corner handles, and a
pin, which marks the center of rotation. To rotate a shape, drag a corner handle.
To change the center of rotation, move the rotation pin.

Vertices
Vertices appear when you select a shape with the pencil ( ), line ( ), arc ( ),
or freeform ( ) tool on the Standard toolbar. A vertex is marked by a green
diamond-shaped handle. To change the form of a shape, drag a vertex with the
tool used to create the shape. (The vertex turns magenta to indicate that it’s se-
lected.) To add or delete segments, you add or delete vertices using the pencil,
line, arc, or freeform tool on the Standard toolbar.

Control points
Control points appear on lines, arcs, and freeform curves when you select them
with the pencil tool. These are green round handles that appear between two ver-
tices. You can drag control points to change the curve or symmetry of a segment.

Eccentricity handles
With eccentricity handles, you adjust the angle and magnitude of an elliptical
arc’s eccentricity. To display eccentricity handles, first select an arc. Then select
the pencil tool and click the control point at the center.

A connection point appears as a blue x on
a shape.

Rotation handles appear as round corner
handles. The rotation pin appears as a
circle with a plus in the center.

Vertices appear as green diamond-shaped
handles. Control points appear as round
handles.

Eccentricity handles appear as circles on
each end of a dashed line.
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Control handles
Some master shapes have control handles that let you work with shapes in ways
you can’t with standard 1-D and 2-D shapes. The control handle looks like a se-
lection handle with darker shading. Each control handle has a function unique
to the shape on which it appears. For example, it may adjust the roundness of a
shape’s corners or reshape an arrow. To display a tip about what a control
handle does, pause the pointer over the control handle.

Adjust l ine spacing

Tips explain the use of control handles. In this example, dragging the control handle ( )
adjusts the line spacing. This behavior is programmed into the shape’s ShapeSheet
spreadsheet.

Padlocks
Padlocks appear in place of corner handles when you select a shape to indicate
that the shape is locked against specific changes. Some shapes are locked against
flipping, rotating, sizing, or other changes that would destroy their specially
programmed behavior. You can lock shapes using the Protection command.

NOTE  Padlocks only appear when a shape is locked against sizing or rotating.
When a shape is locked against repositioning, deleting, or selecting, no padlocks
appear, but you can’t perform the action.

Box sizes with text.
Hit <Return> to start a

new line of text.

When you select a shape locked against sizing or rotating, the selection handles appear as
padlocks.

Related topics
About creating your own shapes ............................................................................. 207
About creating and revising connected drawings ..................................................... 65
About formatting shapes ............................................................................................ 49
About protecting shapes and files ............................................................................ 173
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Selecting shapes

To work with a shape you must select it. In most cases you select shapes by
clicking them with the pointer tool, but you can also use other tools or drag the
pointer tool to create a selection net around multiple shapes.

Methods for selecting shapes

To Do this

Select one shape Move the pointer over a shape. When the pointer changes from a black arrow to
a white arrow, click to select the shape. The shape’s selection handles appear in
green.

Select multiple shapes by clicking Select the first shape, hold down the Shift key, then click to select other shapes one
at a time. The primary shape has green selection handles, and all other shapes have
blue selection handles.

Select multiple shapes by dragging Use the pointer tool ( ) from the Standard toolbar and drag a selection net around
all of the shapes you want to select.

Select all shapes on the page Choose Edit > Select All. If there are more than 25 shapes, they appear with a
magenta outline to show that they are selected. Otherwise, shapes appear selected
as described earler.

Select all of a particular kind of object Choose Edit > Select Special, then check the type of object that you want to select,
such as shapes, groups, or guides.

Cancel a selection Click away from the selected shape or press the Esc key.

Cancel the selection of one shape when Shift+click the shape.
several are selected

Related topics
Using shape handles ................................................................................................... 32
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Resizing and reshaping shapes

You can change the size and shape of a shape. For example, you can

• Change the width and height of two-dimensional (2-D) shapes.

• Make one-dimensional (1-D) shapes longer, shorter, wider, or narrower.

• Add segments to and delete segments from shapes.

• Change the angle where two segments meet.

• Edit arcs—drawn with the arc tool, pencil tool, or freeform tool—with the
pencil tool.

NOTE  To resize a shape exactly, use the Size & Position command and then type
the shape’s height and width dimensions.

If a 1-D shape has selection handles, you can drag them to change the width of the shape.

Resizing 2-D shapes
A 2-D shape, such as a rectangle, has corner selection handles you can use to
resize the shape proportionally and side selection handles you can use to resize
that side of the shape. Selection handles appear as green boxes. Examples in-
clude most rectangles, ellipses, and freeform shapes.

NOTE  If you select a shape and it’s selection handles appear gray, the shape is
part of a group.

To resize a 2-D shape:

1. Choose the pointer tool ( ) on the Standard toolbar, then select the shape.

2. Drag a selection handle until the shape is the size you want. To resize the
shape proportionally, drag a corner handle.

TIP  If you see fewer than eight handles on a 2-D shape, zoom in on the drawing
to see the rest of the handles and to size the shape more accurately.
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Resizing 1-D shapes
A 1-D shape has two endpoints: a begin point ( ) and an end point ( ). You
can change the size of a 1-D shape by dragging one of its endpoints. 1-D shapes
that are not straight lines have selection handles you can use to resize the shape.

To resize a 1-D shape:

1. Choose the pointer tool ( ) from the Standard toolbar, then select the shape.

2. To adjust the shape’s length, pause the pointer over an endpoint until it
changes to a four-headed arrow, then drag to make the shape the length you
want.

For 1-D shapes that can be adjusted in width, pause the pointer over a selec-
tion handle until it changes to a two-headed arrow, then drag until the shape
is as wide or narrow as you want.

3. Release the mouse button.

NOTE  Changing a 1-D shape’s width is not the same as changing its line weight.

Adding or deleting shape segments
A segment is a straight line or curve that is part of a more complex shape. Be-
tween each pair of segments is a vertex. You can add segments to shapes to
change the way they look. For example, you can turn a triangle into a rectangle.
You add a segment by adding a new vertex to an existing segment. You can also
delete segments you don’t want. For example, you can delete a segment from a
rectangle to make it a triangle.

When you delete a segment, Visio redraws the shape based on

• The order in which the shape’s segments were created.

• Whether a vertex is at the beginning or end of an open shape.

• Whether the segment that follows the one you delete is a line or an arc.

To add a new segment to a shape:

1. Choose the pencil ( ), freeform ( ), line ( ), or arc tool ( ) from the
Standard toolbar, then select the shape.

2. Between two existing vertices on the shape’s outline, point to where you
want to add the segment.

3. Hold down the Ctrl key and click.

A new vertex appears where you clicked on the shape, creating a new seg-
ment. To make the shape look the way you want, you may need to adjust the
shape by dragging vertices and control points.

TIP  Zoom in on the drawing so you can clearly see when the pencil is over a line
or arc segment.
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To delete a segment:

1. With the pencil tool, select the shape.

2. Click the vertex at the end of the segment you want to delete.

When the vertex is selected, it turns magenta.

3. Press the Delete key, or choose Edit > Clear.

After you delete segments, you can adjust the shape by dragging vertices and
control points.

Changing the angle where two segments meet
By dragging a vertex, you can change the angle at which two segments meet.
Dragging a vertex often makes a segment longer or shorter. You can also select
several vertices and drag them all at the same time. The selected vertices main-
tain their position in relation to one another and move in relation to the rest of
the shape.

To reshape angles by dragging a vertex:

1. Choose the pencil tool ( ) from the Standard toolbar, then select the
shape.

2. Click the vertex you want to move.

When the pointer is directly over the vertex, it changes to a four-headed
arrow. When the vertex is selected, it turns magenta.

3. Drag the vertex to its new position.

To reshape angles by dragging multiple vertices:

1. With the pencil tool, select the shape.

2. Click a vertex that you want to move, then hold down the Shift key and click
the other vertices with positions you want to change.

3. Place the pointer over one of the selected vertices, then drag.

The selected vertices move together, maintaining their relationship.
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Reshaping arcs
Every arc drawn with the arc tool ( ) follows the perimeter of an invisible
ellipse. You can change the bow of an arc so the arc becomes a larger or smaller
portion of the circle or ellipse—even flatten an arc to make it a line. You can
also edit an arc by dragging its eccentricity handles to reshape the ellipse on
which the arc is based. You can change the way the arc leans (the angle of eccen-
tricity) or its flatness (the magnitude of eccentricity). An arc has an invisible
snap point in the middle of an invisible line between its two endpoints. When
you drag the control point to that snap point, the arc becomes a line.

To reshape an arc:

1. Choose the pencil tool ( ) from the Standard toolbar, then select the arc or
the shape that contains the arc.

2. Point to the arc’s control point.

3. Drag the control point until the arc looks the way you want.

To change an arc’s eccentricity:

1. With the pencil tool, select the arc or the shape that contains the arc.

2. Click the control point on the arc to display the eccentricity handles.

On circular arcs, the eccentricity handles are under the control point.

If you don’t see the eccentricity handles, hold down the Ctrl key and drag the
pointer slightly away from the control point to display them.

3. Edit the arc by doing the following:

To change the arc’s magnitude of eccentricity, drag an eccentricity handle
farther from or closer to the control point.

To change the arc’s angle of eccentricity, drag an eccentricity handle around
the control point.

Related topics
Flipping and reversing shapes .................................................................................... 44
Rotating shapes ........................................................................................................... 45
Moving shapes ............................................................................................................ 40
Revising existing shapes ........................................................................................... 216
Using shape handles ................................................................................................... 32
Working with shapes in groups ................................................................................. 42
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Moving shapes

You can change the location of a single shape or move multiple shapes so they
keep their positions in relation to one another. You move shapes by dragging
them. There are a number of ways to ensure that you place your shapes where
you want them:

• Faint lines on each ruler indicate the location of the shape or group of
shapes. You can also use the grid or guides to help you position shapes.

• If you drag the shape quickly, a rectangle (representing a 2-D shape) or a line
(representing a 1-D shape) shows the location of the shape or group of
shapes on the page.

• If you pause while dragging and continue to hold down the left mouse but-
ton, you’ll see the shape or group of shapes instead of the rectangle or line
that represents it, so you can position it more precisely.

If you want to place a shape or group of shapes exactly in a certain position, you
can use the Shape > Size & Position command and then type the shape’s x, y co-
ordinates relative to the zero point of the drawing.

When you move a shape, watch the pointer. If the pointer is black, it’s not positioned over the
shape, so you cannot move the shape. The pointer turns white to indicate that you can move
the shape.

Moving single shapes
To move a single shape:

1. Choose the pointer tool ( ) from the Standard toolbar, then point to the
shape. The pointer turns white.

2. Press the left mouse button, then drag the shape to where you want it. To
constrain the movement of the shape to vertical or horizontal, hold down
the Shift key while you drag the shape.

If snapping is on, the shape may jump into place.

TIP  Be careful not to point to a selection handle. If you accidentally resize a
shape, choose Edit > Undo (or press Ctrl+Z).
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Moving multiple shapes
If several shapes are related to each other, you may want to move them together.
To keep them aligned as you move them, glue the shapes to a guide, then move
the guide. You can group some shapes first, so that even shapes that don’t actu-
ally touch the guide move with it.

A

   

B

When shapes are glued to a guide (A), you can move the guide to make several adjustments
to the drawing at once (B). In this example, the shapes that represent the plant, couch, and
side table are glued to a guide, which is then moved to the right to put more space between
them and the table shape.

To move multiple shapes:

1. Select the shapes you want to move.

2. Place the pointer over one of the shapes. The pointer turns white.

If one of the objects you’re moving is a group, the pointer needs to be over
one of the shapes in the group in order to turn white.

3. Drag the shape to its new position. All selected shapes move the same dis-
tance and direction from their original positions.

TIP  To constrain the movement of the shapes to vertical or horizontal, hold
down the Shift key while you drag the shapes.

To use a guide to move several related shapes:

1. Choose Tools > Snap & Glue, then in the Snap & Glue dialog box make sure
Guides is checked in the Snap To and Glue To lists.

2. Drag a guide from the appropriate ruler and glue shapes to the guide.
Shapes’ endpoints and selection handles turn red when glued.

3. Drag the guide to the shapes’ new location.

Related topics
About positioning shapes precisely ......................................................................... 155
About measuring and scaling in drawings .............................................................. 169
Aligning and distributing shapes ............................................................................. 166
Working with shapes in groups ................................................................................. 42
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Working with shapes in groups

In Visio, you can group shapes so they function as a unit. It’s useful to group
shapes when you regularly use them together. You can group any combination
of Visio shapes and shapes you draw yourself. Groups can also include guides,
other groups, and objects from other programs.

Some Visio shapes are groups—that is, a set of shapes grouped to form a single shape.

Keep these points in mind as you work with groups:

• You can manipulate groups or individual shapes, including formatting,
moving, rotating, flipping, and reversing. You can also set behaviors for how
an individual shape acts in relation to the group it belongs to.

• When you create a group, Visio builds a group ShapeSheet spreadsheet,
which describes the group’s attributes, but not those of the individual shapes
within it. Each shape in the group retains its own ShapeSheet spreadsheet;
Visio puts references to the group ShapeSheet spreadsheet into the indi-
vidual shapes’ ShapeSheet spreadsheets. When you ungroup shapes, Visio
discards the group’s ShapeSheet spreadsheet.

• If you add a guide and the shapes glued to it to a group, be sure to select
both the guide and shapes before you add them to the group; otherwise the
glue breaks. You can add guides to rotated groups only when the group is
displayed in the group window, which is where you can edit the shapes that
make up the group.

• Bitmaps or other imported objects cannot be rotated even when you rotate
the group that contains them. To rotate an imported object that is not a
bitmap, you must first convert it to a Visio group.

• After you reposition, add, or delete individual shapes within a group, the
alignment box that appears when you select a group may no longer fit its di-
mensions. To adjust it, choose Tools > Update Alignment Box.
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Methods for working with groups

To Do this

Group shapes and objects Select the shapes and objects you want
to group. Choose Shape > Grouping >
Group

Ungroup shapes and objects Select a group, then choose Shape >
Grouping > Ungroup.

Open a group so that you can Select a group, then choose Edit >
work with the shapes in it Open Group to open the group

window.

Add a shape to a group Select the group. Press the Shift key and
select the shape you want to add.
Choose Shape > Grouping > Add To
Group. You can also open the group
window as described above, then drag a
shape from the drawing page or a
stencil into the group window.

Remove a shape from a group Select the group, then click the shape
you want to remove to subselect it.
Choose Shape > Grouping > Remove
From Group.

Related topics
About customizing shape behavior .............................................................. Visio Help
Adding and editing text in groups ............................................................................. 78
Revising existing shapes ........................................................................................... 216
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Flipping and reversing shapes

You can change the direction shapes face by flipping or reversing them.

A B C

A Flipping shapes horizontally.
B Flipping shapes vertically.
C Reversing ends to flip shapes both horizontally and vertically.

Methods for flipping and reversing shapes

To Use this tool Do this

Flip a shape Select the shape. From the Shape menu, choose Flip Vertical
(Ctrl+J) or Flip Horizontal (Ctrl+H).

    Or select the shape and click the flip vertical or flip horizontal
button on the Shape toolbar.

Reverse a shape Select the shape. Choose Shape > Reverse Ends.

Flip or reverse a group Flip or reverse as you would any shape.

Flip or reverse a shape within a group Select the group, then choose Edit > Open Group. In the
group window, flip or reverse individual shapes as you would
any shape. Click the group window’s close box.
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Rotating shapes

You can change the angle of shapes by rotating them in one of two ways: You
can use commands or buttons to rotate in 90-degree increments, or you can use
the rotation tool to rotate the shape at any angle. As you rotate shapes with the
rotation tool, the status bar at the bottom of the Visio window displays the ex-
act angle of rotation.

A B

A Rotate Left and Rotate Right rotate a shape in 90-degree increments.
B With the rotation tool, you can rotate a shape at any angle.

Keep these points in mind as you rotate shapes:

• You can rotate a 1-D shape by dragging one of its endpoints with the pointer
tool ( ). However, it’s easy to resize the shape when you do this. If you don’t
want to resize the shape it’s better to use the rotation tool.

• You cannot rotate imported bitmaps or OLE objects.

• For precise rotation of a shape, use the Shape > Size & Position command to
enter a numerical value for angle.

Methods for rotating shapes

To Use this tool Do this

Rotate a shape 90 degrees         Select the shape. Choose Shape > Rotate Left (Ctrl+L) to
rotate counterclockwise or Rotate Right (Ctrl+R) to rotate
clockwise. Or select the shape, then click the rotate right or
rotate left button on the Shape toolbar.

Rotate a shape by any amount Click the shape to select it. Drag a rotation handle. For

more control, drag the pointer farther from the rotation pin.

Rotate a group Rotate as you would any shape.

Rotate a shape within a group Select the group, then choose Edit > Open Group. In the
group window, rotate individual shapes as you would any
shape. Click the group window’s close box.
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Changing the center of rotation
When you select a 2-D shape with the rotation tool, a plus sign in a circle
appears at the center of rotation, which is usually at the center of the shape’s
selection rectangle. You can move the center of rotation, called the pin, to rotate
a 2-D shape around any point in the drawing window. To do this, select the
shape with the rotation tool, then drag the pin to a new location.

When you select a shape with the rotation tool, rotation handles appear in the corners and a
pin (center of rotation) appears in the center. As it moves over a rotation handle, the pointer
changes to a round arrow indicating that you can rotate the shape.

You can rotate a shape around any point by moving the shape’s pin to that point.
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Duplicating shapes

You can duplicate shapes within the same drawing, or copy shapes from one
Visio drawing to another or to a document in another Windows application.
You can also drag shapes from one drawing to another or from Visio to another
Windows application that is compatible with OLE 2.

You can place shapes exactly where you want them in relation to one another as
you duplicate them. For example, you can easily design an auditorium with
dozens of rows of seats or a steel structure with regularly placed rivets.

Methods for duplicating shapes

To Do this

Add several copies of a master to a Select the stamp tool from the Standard toolbar, then click a master on a stencil to
drawing select it. In the drawing window, click the pointer where you want the center of the

shape to appear. Continue clicking where you want additional copies of the shape.

Duplicate a shape within the same Select the shape you want to duplicate, then choose Edit > Duplicate (Ctrl+D).
drawing The copy appears on the page slightly offset from the original.

Duplicate a shape at a specific location Select the shape. Hold down the Ctrl key and drag to where you want the copy.

Repeatedly duplicate a shape and the Select the shape. Hold down the Ctrl key and drag to where you want the copy.
offset between copies Release the mouse button. Press F4 for each copy you want.

Drag and drop shapes from a Visio Display the drawing page that contains the shape you want to copy. Open the
drawing into another application that document into which you want to copy the shape. Hold down the Ctrl key and
supports OLE 2 drag the shape from Visio into the other document.

Copy and paste shapes from a Visio Select the shape you want to copy. Choose Edit > Copy. In the document in which
drawing into another application that you want to copy the shape, choose Edit > Paste.
doesn’t support OLE 2

Related topics
Adding shapes to drawings ......................................................................................... 11
Merging shapes to create new ones .......................................................................... 210
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Finding shapes on stencils

When you want to find a shape, but aren’t sure which stencil it’s on, you can
quickly search with Shape Explorer instead of opening multiple stencils. Shape
Explorer provides an easy way to search for and catalog Visio shapes, stencils,
and templates that are provided with Visio products, that are on the World
Wide Web, or that are in databases you create.

For example, if you know a 3-D Box shape exists, but don’t know where to find
it, use Shape Explorer to determine which stencil contains the shape, then open
the stencil or use Shape Explorer to add the shape to your drawing.

You search with Shape Explorer by typing the keywords you want to use in the
Search For box on the Search tab. A keyword can be a shape or stencil name, or
a word or phrase that describes the shape you’re looking for, or the type of
drawing you want to create.

To open the Shape Explorer:

1. Choose File > Stencils > Shape Explorer.

2. On the Search tab, in the Search For box, type a name, word, or phrase that
describes what you want to find.

3. Click Find Now.

The status bar at the bottom of the Shape Explorer window indicates the
progress of the search.

TIP  To learn more about how the Shape Explorer works, click Help in the Shape
Explorer dialog box.



5
Formatting
shapes

About formatting shapes

You can format shapes in your drawing by changing any one or all of their at-
tributes, such as line weight and pattern, fill color and pattern, or text. For
example, you might use color to make a drawing for a slide presentation more
effective, or use line patterns to represent a specific type of connection between
shapes.

The type of formatting you apply to a shape depends on whether the shape is
open or closed. For example, you can add fills to closed shapes, such as circles or
rectangles, but not to open ones. You can add line ends to open shapes, such as
arcs or zigzag lines, but not to closed ones.

On open shapes, such as arcs, you can change

• Line ends (such as arrowheads).

• Line caps (round, square).

• Line pattern (solid, dashed), line weight, and line color.

• Shadow pattern and shadow color.

• Corners.
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On closed shapes, such as rectangles, you can change

• Line pattern (solid, dashed), line weight, and line color.

• Fill color and pattern.

• Shadow pattern and shadow color.

• Corners.

The quickest way to change a shape’s appearance is to

• Use Shape toolbar buttons to apply local formatting.

• Use the Text, Line, or Fill style lists to apply a style.

For greater precision, you can use the commands on the Format menu.

Related topics
About formatting text ................................................................................................. 85
About working with styles and templates ............................................................... 137
Formatting shapes ...................................................................................................... 50
Revising existing shapes ........................................................................................... 216

Formatting shapes

You can choose from among the following formatting methods according to
the type of formatting you want to do.

Toolbar buttons
By using the Shape toolbar buttons to apply local formatting, you can quickly
change

• Line ends (such as arrowheads).

• Line patterns, weight, and color.

• Fill color and patterns.

• Shadow color.

• Corners on shapes.
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The Shape toolbar. Pause the pointer over a tool or button to see a tip.

A Line style list M Lay out shapes
B Line color palette N Connect shapes
C Line weight list O Flip horizontal
D Line pattern list P Flip vertical
E Line ends list Q Rotate right
F Corner roundings list R Rotate left
G Fill style list S Bring to front
H Fill color palette T Send to back
I Fill pattern list U Group
J Shadow color palette V Ungroup
K Align shapes W Custom properties
L Distribute shapes

NOTE  Buttons S–V only appear at resolutions higher than 600x800.

Toolbar palettes
Some of the buttons on the Shape toolbar display palettes from which you can
choose an attribute to apply to your shape. After you choose the option you
want, the palette closes.

TIP  If the option you want isn’t available as a palette, you can use a command
on the Format menu.

Format menu commands
Although formatting with toolbar buttons is faster, you may sometimes want to
use the formatting commands on the Format menu. Format menu commands
have options that are not on the toolbar. For example, you can only apply a
pattern to a shadow using the Shadow or Fill commands on the Format menu.

Line pattern palette
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Style lists
When you format shapes using the Text, Line, or Fill style lists, you’re actually
applying a style. Styles can contain line, fill, and text formatting attributes. It’s
best to use a style if you want to apply many formatting attributes to many dif-
ferent shapes. When you start a drawing with a Visio template, the template
includes style definitions and the appropriate styles appear in the style lists on
the toolbars.

To display the Shape toolbar:

• Choose View > Toolbars > Shape. A checkmark next to a toolbar name indi-
cates that the toolbar is currently displayed.

To format shapes:

• Do one of the following:

Select the shape or shapes you want to format, then choose the appropriate
button or style list from the Shape toolbar.

Select the shape or shapes, then choose the appropriate command from the
Format menu.

Related topics
About working with styles and templates ............................................................... 137
Adding color and shadows to shapes ......................................................................... 58
Formatting lines .......................................................................................................... 55
Repeating and copying formatting ............................................................................ 57

Formatting multiple shapes

You can format several shapes at once by doing one of the following:

• Selecting multiple shapes at the same time.

• Selecting shapes in a group.

Selecting multiple shapes
When you select multiple shapes and then apply a command, the result de-
pends on the primary shape, the order in which you select, and the stacking
order of the shapes.

When you are working with multiple shapes, the primary shape determines

• How all the shapes align when you use the Align Shapes command.

• How the selected shapes are affected when you edit or position them.

• The attributes that appear in any dialog boxes or styles lists you open.

• The order in which shapes connect when you use the Connect Shapes
command.



F O R M A T T I N G  S H A P E S 5 3

The shape that is primary is determined by one of two things: the selection or-
der or the stacking order.

A

When you select shapes by dragging a selection net around them, the primary shape (A) is
the one you dropped most recently on the page. The most recently dropped shape is at the
front of the stacking order.

How a command affects multiple shapes in a selection is also determined by the
stacking order of the shapes on the page. The first shape you draw or drop on
the page is at the back of the stack; the most recently created shape is at the
front. Stacking order determines

• Which shape is positioned in front of another if they overlap.

• How multiple shapes are affected by commands. For example, when you type
in a group, the text appears on the frontmost shape in the stacking order.

• The selection order when you select multiple shapes by dragging a selection
net around them. The shape at the front of the stacking order becomes the
primary shape, displaying green handles. (When you select multiple shapes
by Shift+clicking, the stacking order doesn’t affect the selection order. The
first shape you click becomes the primary shape.)

NOTE  Shapes on a background always appear behind shapes on a foreground.
Layers, however, have no effect on stacking order.

A

When you select multiple shapes by shift-
clicking, the primary shape (AAAAA) is the first
shape you select. The primary shape is
indicated by green handles.
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Methods for selecting multiple shapes

To Do this

Select multiple shapes by clicking Select the first shape, hold down the Shift key, then click to select other shapes one
at a time. The primary shape has green selection handles; all other shapes have blue
selection handles.

Select multiple shapes by dragging Using the pointer tool ( ) on the Standard toolbar, drag a selection net around all
of the shapes you want to select. The shapes appear selected as described above.

Select all shapes on the page Choose Edit > Select All. If there are more than 25 shapes, they appear with a
magenta outline to show that they are selected. Otherwise, shapes appear selected
as described above.

Select all of a particular kind of object Choose Edit > Select Special, then check the type of object that you want to select,
such as shapes, groups, or guides. The shapes appear selected as described above.

Cancel the selection of one shape when Shift+click the shape.
several are selected

When you group shapes using the Shape > Grouping > Group command, you
can apply formatting to the group or to individual shapes in the group.

Lorem ipsum

When you select a group and type text,
the text appears on the frontmost shape
 in the stacking order.

Methods for selecting shapes in groups

To Do this

Format all the shapes in a group Select the group, then change the style or attribute.

Format a shape within a group Select the group, then choose Edit > Open Group to open the group in the group
window. Select the shape and format it as you would any shape, then click the
group window’s close box.

Format several shapes at once Select all the shapes, then change the style or attribute.
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Changing the stacking order of shapes

You can change the stacking order of shapes. For example, you can bring a spe-
cific shape to the front to act as the primary shape when you drag a selection
net around multiple shapes.

Methods for changing a shape’s position in the stacking order

To Do this

Bring a shape forward one level Select the shape, then choose Shape > Bring Forward.
in the stacking order

Bring a shape to the front of the Select the shape, then choose Shape > Bring To Front (or press Ctrl+F).
stacking order

Send a shape backward one level Select the shape, then choose Shape > Send Backward.
in the stacking order

Send a shape to the back of the Select the shape, then choose Shape > Send To Back (or press Ctrl+B).
stacking order

Change the stacking order of a Select the group, then choose Edit > Open Group. Select a shape, change its
shape in a group position in the stacking order as described above, then close the Group window.

Related topics
About layers ............................................................................................................... 143
Selecting shapes .......................................................................................................... 35

Formatting lines

A line can be an open straight line, freeform line, or arc; or the border around a
closed shape, such as a rectangle. You can format lines or arcs by adding a pat-
tern or color, changing the line weight, adding or removing line ends, changing
the line caps, or rounding the line’s corners. You can also add a shadow and for-
mat the shape’s text.

By applying line ends, you can turn any line or other open shape into an arrow.
You can apply an arrowhead or other line end to the begin point, the end point,
or both endpoints of a shape. You can also choose options for the size of line
ends. You can turn an arrow into a straight line by removing any line ends that
are applied to it.
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Rounded corners can be applied to any corner where two segments meet on
open or closed shapes.

A

B

C

D

E

F

G

I

J

K

H

A Choose among none, solid, and dashed lines. The spaces between dashes are transparent.
B Choose among various line widths.
C Choose among colors that are set in the Visio color palette. To add a new color to the color

palette, choose Custom. All the colors applied are solid (not dithered) and opaque, including
white.

D Choose Round or Square. This applies to open shapes only.
E Choose among various corner formats. This applies only to shapes with corners.
F You can enter a numerical equivalent for the roundness of the corners instead of choosing

one of the corner options—the higher the number, the rounder the corners.
G Displays a sample line with the formatting options you have selected.
H For Begin and End, choose among various line ends for the line. For Size, choose the size of

the line end. Line ends only apply to open shapes.
I Applies formats without closing the dialog box.
J Closes the dialog box without applying any of the formatting you’ve selected, even if you

clicked Apply previously.
K Applies the formatting options you selected and closes the dialog box.

To change formatting for a line:

1. Select the shape, then choose Format > Line.

2. Choose the options you want.

You can see how the options you select will look in the Preview box.

3. Click Apply to apply the formatting options you’ve chosen and view the
change before closing the dialog box, or click OK to apply the formatting
and close the dialog box.

Related topics
About formatting text ................................................................................................. 85
Adding color and shadows to shapes ......................................................................... 58
Drawing shapes ......................................................................................................... 208
About formatting shapes ............................................................................................ 49
About working with color ............................................................................. Visio Help
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Repeating and copying formatting

If you want to format several shapes the same way, you can select all the shapes
and apply the formatting options you want. You can also experiment with one
shape until it looks exactly the way you want and then use the Format Painter
button to copy that shape’s formatting to one or more other shapes in your
drawing.

If you want to use the same formatting again and again in many drawings, you
can create a style.

Methods for repeating or copying formatting

To Do this

Format several shapes at once Select all the shapes you want to format, then click the formatting buttons and
choose the style list options you want, or use the appropriate command on the
Format menu.

Quickly repeat one formatting change Make one formatting change to a shape. Select other shapes, then press F4. The last
formatting change you made will be used.

Copy one shape’s formatting to Select the shape with the formatting you want to copy. Click the Format Painter

another shape button ( ), then click the shape to which you want to copy the formatting.

Copy only text attributes from one Double-click the shape to select the text. Click the Format Painter button. Click
shape to another the shape to which you want to copy the formatting.

Copy one shape’s formatting to other Select the shape with the formatting you want to copy. Double-click the Format
shapes sequentially Painter button, then click the shapes to which you want to copy the formatting.

Copy one shape’s formatting to several Select the shape with the formatting you want to copy, then press the Shift key and
other shapes simultaneously select the shapes to which you want to copy the formatting. Click the Format

Painter button.

Related topics
About working with styles and templates ............................................................... 137
Duplicating shapes ...................................................................................................... 47
Working with shapes in groups ................................................................................. 42
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Adding color and shadows to shapes

You can fill closed shapes and you can give shadows to both closed and open
shapes.

Fills and shadows can be a solid or bitmap pattern. Fills can also be a gradient
pattern. You choose colors and a pattern from set lists to which you can add
custom colors or patterns you create.

Both fills and shadows function in the same way. The only difference is that a
shadow is a copy of the shape that is offset from and behind the shape to which
it’s applied.

A

B

A

B

C

D

E

F

G

C

A For both Fill and Shadow, you can specify a blank (transparent), solid, or bitmap pattern. For
Fill, you can also specify a gradient pattern. When you specify colors for Foreground and
Background, Visio changes the display of the Pattern list according to your color choices.
The numbers preceding the patterns and colors in the Pattern, Foreground, and Back-
ground lists act as labels.

B For both Fill and Shadow, you can specify a foreground color. If you choose the solid pat-
tern, Visio uses the foreground color for the fill or shadow. Each bitmap and gradient pattern
uses both the foreground and background colors. The foreground color is applied to the
dots and lines making up the pattern. Some colors in the Foreground and Background lists
are quite dark. For those colors, the left half of the color sample shows how the color will
look as a solid (pattern 1). The right side shows how the color will appear in any bitmap or
gradient pattern.

C Choose the color you want for the background of a bitmap pattern or for the second color in
a gradient pattern.

D Displays a sample fill with the formatting options you have selected.
E Applies formats without closing the dialog box.
F Closes the dialog box without applying any of the formatting you’ve selected.
G Applies the formatting options you’ve selected and closes the dialog box.
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To apply a fill to a closed shape:

1. Select the shape.

2. Choose Format > Fill.

NOTE  You can also use fill formatting palettes on the Shape toolbar. Pause
the pointer over the palettes to see tips that identify them.

3. In the Fill section, choose options from the Pattern, Foreground, and Back-
ground lists. (You can also choose the same options in the Shadow section.)
You can see how the options you select will look in the Preview box.

There are 40 patterns included with Visio: 0 is no pattern (transparent); 1 is
a solid one-color pattern; 2–24 are bitmap patterns; and 25–40 are gradient
patterns (for fills only).

If you choose a bitmap pattern, Visio uses the foreground color for the pat-
tern and the background color for the background.

4. Click Apply to apply the formatting options you’ve chosen and view the
change before closing the dialog box, or click OK to apply the formatting
and close the dialog box.

TIP  To hide a shape completely, apply to it a 0 (transparent) fill in the Fill dialog
box and a pattern of None in the Line dialog box. You can also create shapes
with transparent holes by using the Combine command. To temporarily hide a
shape, assign the shape to a layer, then hide the layer in the Layer Properties dia-
log box.

To apply a shadow to a closed or open shape:

1. Select the shape.

2. Choose Format > Shadow.

3. In the Shadow section, choose options from the Pattern, Foreground, and
Background lists.

4. Click OK.

TIP  To delete a shadow, choose None from the Pattern list for Shadow.
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Changing the shadow offset for shapes

Although each shape can have a shadow of a different color and pattern, all
shadows on the same page are offset the same amount because shadows are a
page property. You can change the size and angle of the shadow offset for all the
shapes on a page.

To change the shadow offset for a shape:

1. Choose File > Page Setup, then click the Page Properties tab in the Page
Setup dialog box.

2. In the Shape Shadow Offset section, type values for the shadow offset in the
Right and Down boxes.

To move shadows to the left or top of shapes, use negative values.

3. Click OK.

Related topics
Applying custom line and fill patterns ...................................................................... 60
About formatting shapes ............................................................................................ 49
About working with color ............................................................................. Visio Help
Setting color behavior in custom line and fill patterns ............................... Visio Help
Using custom colors and color palettes ........................................................ Visio Help

Applying custom line and fill patterns

Visio includes a number of stencils that contain custom line and fill patterns
and custom line ends. When you open these stencils, the patterns they contain
appear as a choice in the Line and Fill dialog boxes. For example, you can open
a custom hatch pattern stencil and then apply those hatch patterns as fills from
the Fill dialog box. The custom patterns don’t appear as masters on the stencil
unless you open the original stencil, which gives you read/write access. This is
because patterns are not true shapes, but attributes that you apply to shapes.

The way a custom pattern is created affects the way it behaves when you apply it
to a shape. For example, some line patterns are set to scale with the line weight,
so when a line is very fine, the pattern may be scaled so small that it’s difficult to
see. Also, some patterns may be set to take on the color of the shape they’re
applied to, while others are set to override the shape’s colors with their own.
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To apply a custom pattern:

1. Open the stencil that contains the custom pattern you want to apply.

2. Select the shape to which you want to apply the custom pattern.

3. Choose Format > Line to apply a line or line-end pattern, or Format > Fill to
apply a fill pattern.

4. To apply a line-end pattern, choose the custom pattern’s name from the
Begin or End list in the Line dialog box. To add a line or fill pattern, choose
the custom pattern’s name from the Pattern list.

5. Click OK.

The shape displays the pattern.

NOTE  If you apply a line pattern or line-end pattern and it doesn’t look the way
you expected it to (for example, you can’t see it), try increasing the line weight.

Related topics
About customizing shape behavior .............................................................. Visio Help
About formatting shapes ............................................................................................ 49
Using custom colors and color palettes ........................................................ Visio Help

Creating custom line and fill patterns

If you want to use a fill pattern, line pattern, or line-end not available in Visio,
you can create your own. Once you’ve developed a master fill or line pattern,
you can apply the pattern to other shapes. When you create a custom line or fill
pattern, you create it initially as a master pattern, which then appears as a
choice in the Fill or Line dialog box and can be applied to other shapes in the
drawing.

You can create a master pattern from a shape you create in Visio, or a shape that
already exists, and set its properties, which affect how the pattern behaves. For
example, you can choose how the pattern will appear when it is applied to a
shape, how it responds when the shape is resized, or how it responds when the
drawing page scale changes.
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For line patterns, you can set the following options.

Line pattern settings

To Use

Bend the pattern to the line, so that the pattern
is tiled and distorted along the path of the line.
The original line is no longer visible.

Tile multiple images along the line without
distorting them

Stretch a single image along the line

Tile multiple images along the line without
distorting them, while still retaining the line’s
original formatting

You can use a shape like a triangle to create a line pattern. The line pattern’s properties
affect how Visio applies the shape to a line.

A B C D

You can bend the pattern (A), tile it (B), stretch it the length of the line (C), or tile it while
keeping the line’s original formatting (D).

For line ends, you can set the following options.

Line-end settings

To Use

Orient the line end to the direction of the line

Orient the line end so that it is always upright
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You can use a shape like an X to create a line end. The line end’s properties affect how Visio
applies the shape to the end of a line.

A B

You can orient the line end to the direction of the line (A) or keep the line end upright,
regardless of the line’s angle (B).

For fill patterns, you can set the following options.

Fill pattern settings

To Use

Create multiple copies (tile) of the image to fill a shape

Use a single, centered, image

Stretch a single image to fill the shape

You can use a shape like a star to create a fill pattern. The fill pattern’s properties affect how
Visio applies the shape to a line.

A B C

You can tile the pattern (A), use a single, centered image of it (B), or stretch it to fill the space (C).

For all types of patterns, you can choose to scale the pattern as the drawing page
scale changes, or you can keep the pattern at a constant size.
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Creating a pattern is a simple process, but keep in mind that developing a pat-
tern that works a particular way requires a good understanding of how shapes
work and may also require some trial and error testing.

A

B

C

D

E

A Type the name you want the master icon
to display and select the alignment for the
master icon text.

B Select the size you want the master icon
to be and select whether you want to up-
date it manually or automatically if you
change the master.

C Select the kind of master you want to
create.

D For Line Pattern, Line End, or Fill Pattern,
select the behavior you want. For ex-
ample, for Line End, you can select
whether you want the line end to be per-
pendicular to the line or to the page.

E For Line Pattern, Line End, or Fill Pattern,
check if you want the master to scale with
the shape it’s applied to.

To create a new master pattern and set its properties:

1. Open as an original file the stencil to which you want to add the new master
pattern, or choose File > Stencils > Blank Stencil to open a new stencil.

2. On the drawing page, create the shape or shapes you want to designate as a
pattern. You can create shapes from scratch or modify existing shapes. To
create a pattern from multiple shapes, select them all, then choose Shape >
Grouping > Group.

3. Drag the shape or group from the drawing page and drop it into the stencil
window to create a new master.

4. Right-click the new master, then choose Properties from the shortcut menu.

5. Type a name for the pattern in the Master Name section, select the align-
ment, size, and update options for the master icon.

6. Select a type of master and behaviors you want for the shape, then click OK.

7. Save the stencil.

TIP  You can also create a new master by right-clicking the green stencil back-
ground and choosing New Master from the shortcut menu. In the New Master
dialog box, choose the options you want, then click OK. Right-click the new
master and choose Edit Master to open a drawing window where you can draw
the shape or shapes you want to make up the pattern.

Related topics
About customizing shape behavior .............................................................. Visio Help
About formatting shapes ............................................................................................ 49
Applying custom line and fill patterns ...................................................................... 60
Using custom colors and color palettes ........................................................ Visio Help



6
Working with
connections

About creating and revising connected drawings

Many drawings include lines, or one-dimensional (1-D) shapes, that indicate
connections between two-dimensional (2-D) shapes. These drawings are called
“connected drawings,” like flowcharts, which use 1-D shapes to connect the
stages in a process.

In Visio, these 1-D shapes are called “connectors,” and they include special be-
havior to make it easier and faster for you to create, and later change, connected
drawings. You can use this behavior—called “glue,”—to ensure that shapes that
need to stay connected do so when you revise the drawing.

You can revise a connected drawing by using one of the following methods:

• Moving 2-D shapes.

When you reposition 2-D shapes, connections remain intact, so you don’t
need to redraw them.

• Manually editing the paths of routable connectors by moving, adding, or de-
leting endpoints, midpoints, and vertices.

You can change the path a routable connector takes around shapes that lie
between the shapes it connects.

Related topics
Adding connectors to your drawing .......................................................................... 70
Working with routable connectors and placeable shapes ........................................ 74
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Using glue to maintain shape connections

Glue is what keeps shapes connected when you move them. When you want to
reposition shapes in your drawing, glue saves you the time it would take to drag
each shape one at a time and re-attach connectors.

While you’re working with glue, it helps to keep the following in mind:

• You can use dynamic or static glue to create connections between shapes or
specific points on them.

• You can change glue settings to determine the types of points that connec-
tors and shapes can glue to.

• You can add new connection points to shapes to make your connections
more precise.

Gluing connectors to shapes or to
specific points on them
You can glue connectors to shapes with

• Dynamic glue, in which the connector is glued to the shapes and changes the
points at which it’s connected when you reposition the shapes. Dynamic
glue keeps the shapes connected at the closest available points.

For example, dynamic glue is appropriate for a flowchart, which represents
the flow of a process. Each subsequent step must be connected to the previ-
ous step, but the specific point on the shape representing the previous step
doesn’t matter. When you move a step, you want the connector to shift to the
point on the previous step closest to the subsequent step’s new location.

Dynamic glue  When you glue a connector to an entire shape, a box appears around the
shape before you drop the connector endpoint onto it. If you move one of the 2-D shapes,
the connector adjusts to glue to the point that’s closest to the other shape.

• Static glue, in which the 1-D connector is glued to one specific point on each
2-D shape, and stays glued to those specific points when you reposition the
shapes.
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For example, static glue is appropriate for an organization chart, which rep-
resents a reporting hierarchy. Position shapes appear under and are
connected to the bottom center of Manager shapes. When you move a Posi-
tion shape, you don’t want the connector to shift to any other point on the
Manager shape.

Static glue  When you glue a connector to a specific point on a shape, a box appears
around that point before you drop the connector endpoint on the shape. If you move one
of the 2-D shapes, the connector remains glued at the specific points.

Whether shapes use static or dynamic glue depends upon the method you use
to connect them and the type of connector you use. With connectors that glue
both statically and dynamically, you can switch between static and dynamic
glue. Not all connectors can glue dynamically. For example, control-handle
connectors that you drag from shapes can only glue to a specific point.

TIP  You can recognize a properly-glued connector endpoint or control handle
by the color of its selection handle. When you select the connector, its glued
endpoints or control handles are red. If an endpoint is light red and slightly
larger than a normal selection handle, it’s glued using dynamic glue. If it’s
darker red and is the same size as other selection handles, it’s glued using static
glue.

To switch from static to dynamic glue:

• Hold down the Ctrl key, then drag a connector endpoint away from the
shape and then back to one of the shape’s connection points.

When you drag the endpoint back to the shape, a box appears around the
entire shape.

To switch from dynamic to static glue:

• Drag a connector endpoint away from the shape and then back to one of the
shape’s connection points.

When you drag the endpoint back to the shape, a box appears only around
the connector endpoint.
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Setting glue options
You can control what types of objects shapes glue to and what their glue
strength is. Glue strength is the amount of pull (measured in pixels) that a
guide, selection handle, vertex, or connection point exerts. If you don’t want
endpoints to glue to guides or any points on shapes, you can turn glue off com-
pletely.

The glue settings you choose in the Snap & Glue dialog box apply to all shapes
on the current drawing page. If you have more than one page in your drawing,
you can set different glue options for each page.

TIP  Options you set in the Snap & Glue dialog box don’t affect connections you
make with the Connect Shapes command or with the connector tool.

A

B
C
D
E

A Check to turn glue on or off.
B Check to glue endpoints to guides. This option is checked by default.
C Check to glue endpoints to selection handles on shapes, groups, objects from other pro-

grams, or to other 1-D shape endpoints.
D Check to glue endpoints to shape vertices.
E Check to glue endpoints to connection points (blue Xs) on shapes. This option is checked by

default.

To set glue options:

1. Choose Tools > Snap & Glue.

2. Under Currently Active, make sure the Glue option is checked.

3. Under Glue To, check the options you want, then click OK.
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Adding connection points to shapes
You can specify the points on a 2-D shape that connectors can glue to. If you
need to show a connector attached to a particular location on a shape, you can
add a connection point at that location. Connection points can lie on the
perimeter, inside, or even outside the shape. They appear on the screen but
don’t print, and you can prevent connection points from appearing onscreen.

By default, 1-D endpoints and control handles glue to connection points ( ) on shapes. You
can also choose to have endpoints glue to selection handles and vertices, and you can add
new connection points.

To add a connection point to a shape:

1. Select the shape to which you want to add a connection point.

2. From the toolbar, choose the connection point tool ( ).

3. Hold down the Ctrl key and click on, inside, or outside the selected shape’s
boundaries.

TIP  To delete a connection point, click the point with the connection point tool
(it turns magenta), and then press the Delete key.

To prevent connection points from displaying onscreen:

• From the View menu, choose Connection Points.

When the command is unchecked, connection points do not display
onscreen.

Related topics
Adding connectors to your drawings ........................................................................ 70
Working with routable connectors and placeable shapes ........................................ 74



7 0 C H A P T E R  6

Adding connectors to your drawings

Visio provides four main ways to add connectors to your drawings:

Drawing connectors with the connector tool  You can choose the connector
tool from the Standard toolbar and then drag 2-D shapes from stencils to your
drawing page. The shapes are connected when you drop them on the page. You
can also draw connectors between shapes that are already on the page.

Pulling connectors from shapes  Some 2-D shapes include control handles that
you can click and drag to pull a connector from the shape.

Using the Connect Shapes command  You can connect a series of shapes at
once by choosing Connect Shapes from the Tools menu to add connectors be-
tween the shapes.

Dragging and dropping connector shapes  Many Visio stencils include connectors
that you can drag to your drawing page and drop in place.

Which method you use depends on the type of drawing you’re creating,
whether you expect to make extensive revisions later, and how much control
you want over the connections you have.

Working with connectors
Connectors are 1-D shapes with endpoints. You glue these endpoints to 2-D
shapes to create connections that are maintained when you reposition the 2-D
shapes.

B

A

Certain connectors, such as the Dynamic Connector and other routable
connectors, also display midpoints and vertices when you select them. These
points give you additional control over the connector’s path from one shape to
another. Vertices look the way they do on other shapes: green diamond-shaped
handles. Midpoints look like control handles, that is, green squares with darker
shading. You can set up a drawing so that routable connectors detect 2-D
“placeable” shapes and draw paths around them rather than crossing through
them.

A

B

Connectors have begin points (AAAAA) and end
points (BBBBB) that are indicated by an x and a +
respectively.

Routable connectors display midpoints (AAAAA)
and vertices (BBBBB) for additional editing
capabilities.
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To connect 2-D shapes with a Dynamic Connector using dynamic glue:

1. Display the drawing that contains the 2-D shapes you want to connect, and
make sure a connector master is not selected on an open stencil (selected
master icons are highlighted in blue).

2. Choose the connector tool ( ) from the Standard toolbar.

3. Position the connector tool over the center of the first shape, until a box
appears around the entire shape, then hold down the mouse button and
drag to draw a connector.

4. While holding the mouse button, position the connector tool over the center
of the other shape, until a box appears around it, then release the mouse
button.

NOTE  If a box appears around a particular point on the shape, you’ll create
a connector that’s glued using static glue.

To connect shapes with Visio connectors:

1. Drag a connector from the stencil, and position one of its endpoints on a
2-D shape’s connection point.

The endpoint turns red to indicate that the shapes are glued.

TIP  In the Snap & Glue dialog box, you can also specify to glue endpoints to
2-D shapes’ selection handles or vertices.

2. Drag the other endpoint to another 2-D shape.

Connecting shapes as you drop them on the page
You can connect shapes as you drop them on the page by using the connector
tool as you drag and drop.

As long as the connector tool is selected, if a connector master is not selected on
the stencil, Visio adds a Dynamic Connector between the selected shape and the
next shape you drop onto the drawing page. To create new branches in a chart
or diagram, select the shape from which you want to start the new branch, then
drag a new shape to the drawing page.

To connect shapes as you drag and drop them:

1. Make sure a connector is not selected on an open stencil. To cancel a master
selection, click the green stencil background with the pointer tool.

2. Choose the connector tool ( ) from the toolbar.

3. Drag and drop a 2-D shape from the stencil onto the drawing page.

4. With the first shape still selected, drag and drop another 2-D shape onto the
drawing page.

Visio automatically connects the shapes with an instance of the Dynamic
Connector.
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Dragging connectors from control handles on shapes
Some 2-D shapes, such as organization chart position shapes and the network
Ethernet and ring shapes, function as specialized connectors. These shapes have
built-in connectors: control handles that you can drag and glue to other 2-D
shapes.

Some shapes have control handles ( ) that you can drag to glue to other shapes.

You can often tell which shapes contain control-handle connectors by looking
at master icons in the stencil. Connectors appear as yellow lines extending from
the main shape.

To drag a connector from a control handle on a shape:

1. Drag and drop organization chart shapes or a ring or Ethernet shape from a
network diagramming stencil.

2. Select a shape and position the pointer over the shape’s control handle ( ).

3. Drag the control handle to a connection point on the other 2-D shape.

Connecting a series of shapes at once
You can use the Connect Shapes command on the Tools menu to add connec-
tors between multiple shapes at once in a drawing.

To connect a series of shapes at once:

1. Select the 2-D shapes in the order you want to connect them.

Click the first shape, then press the Shift key and click the other shapes.

2. If you want to use a particular connector, select its master icon in the stencil.

If you don’t select a connector, Visio uses the Dynamic Connector. If a
connector is selected and you want to cancel its selection, click the green
stencil background with the pointer tool.

3. Choose Tools > Connect Shapes or click the Connect Shapes button ( ).

Visio creates an instance of the connector and, if the connector you select
can use dynamic glue, connects the shapes with dynamic glue.

Related topics
About creating and revising connected drawings ..................................................... 65
Adding connectors to your drawing .......................................................................... 70
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Displaying line jumps on crossing connectors

In some drawings, such as flowcharts or network diagrams, connectors may
cross over one another. In a complex drawing, it can be hard to follow the path
of a connector if it crosses over another of the same type.

To make connections easier to follow when you or others analyze your drawing,
you can have routable connectors display “line jumps,” when they cross over
other connectors.

A

Line jumps (A) clarify the shapes that a connector connects to.

To enable line jumps and specify which connectors show them:

1. Display the drawing in which you want to display connector line jumps.

2. Choose File > Page Setup, then click the Page Properties tab.

3. Under Add Line Jumps To, select the type of connectors that, when two lines
cross, display a line jump. Choose one of the following:

None to turn off all line jumps.

Horizontal Lines to add a line jump to the connector that runs horizontally.

Vertical Lines to add a line jump to the connector that runs vertically.

Last Routed Line to add a line jump to the connector you added or modified
most recently (default).

NOTE  Changing this setting changes line jumps on connectors that already
exist in the drawing, as well as those you add after changing the setting.

4. Click OK.

Related topics
Using glue to maintain shape connections ............................................................... 66
Working with routable connectors and placeable shapes ........................................ 74
About automatic layout ............................................................................................ 151
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Working with routable connectors and placeable shapes

In some templates, such as those for creating flowcharts, organization charts,
and network diagramming, the connectors are set up to draw a path around
other shapes rather than crossing over them. These connectors are called
“routable,” and they work with 2-D shapes that are set to work with them,
called “placeable shapes.”

When a routable connector encounters a placeable shape between the two
shapes it connects, it draws a path around the shape rather than crossing
through it. Routable connectors can route around only shapes set as placeable.

A routable connector changes its path from one shape to another when you
drop a placeable shape on top of a connector that’s already in the drawing.

After you glue a routable connector to a shape, you can manually edit the
connector’s midpoints and vertices to change the path it takes from one shape
to the other.

CA

B

If you use the connector tool or Connect Shapes command, you can create
routable connectors by first making sure a connector is not selected on the sten-
cil. When you do not select a connector, Visio connects shapes with a Dynamic
Connector, which is always routable.

To set a 2-D shape as placeable:

1. Select the shape, then choose Format > Behavior.

2. Under Layout Behavior, choose one of the following:

Layout And Route Around to set the shape as placeable.

Do Not Layout And Route Around to set the shape as non-placeable. (It does
not become placeable even when you glue a routable connector to it.)

Let Visio Decide to have Visio determine when to make the shape placeable,
according to the type of connector you glue to the shape. If you glue a Dy-
namic Connector to the shape, Visio makes it placeable.

3. Click OK.

A routable connector can detect placeable
shapes and change its path to avoid
crossing through them.

To change a routable connector’s path
manually, you can edit its midpoints (AAAAA),
vertices (BBBBB), and endpoints (CCCCC). Endpoints
and vertices look the same as they do on
other 1-D shapes. Midpoints look like control
handles—green squares with darker
shading—but function differently on
routable connectors.
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Working
with text

About working with text

Text can clarify the meaning of your Visio drawings, list shape attributes, or
document changes you or other Visio users make to a drawing. For example,
you can

• Describe the process a shape represents in a process flow diagram.

• Add title blocks and bulleted lists to your drawings.

• Add page numbers or footers to every page of a multiple-page drawing.

• Annotate a technical drawing.

Related topics
About creating your own shapes ............................................................................. 207
About formatting text ................................................................................................. 85
About storing data in shapes .................................................................................... 177
About working with styles and templates ............................................................... 137

Adding text to shapes and drawings

You can add text to any Visio shape, including connectors, by selecting the
shape and typing. You can also create text-only shapes to add titles and lists to a
drawing. In a text-only shape, the shape has no line or fill, so only text you type
in the shape is visible. Text-only shapes also enable you to add text to objects
from other programs—position the text-only shape where you want to type
text for the imported object.

The part of the shape in which you type text is called the text block. A text block
can differ from its shape in size, angle, and relative location, so you can place
text where you want it in relation to a shape. Each shape has only one text
block.



7 6 C H A P T E R  7

When you select a shape with a non-text tool, such as the pointer tool, Visio se-
lects all of the existing text so that when you type, the existing text is replaced
with the new text. To select only a part of the existing text or to place an inser-
tion point in the text, use the text tool ( ). The text tool selects the shape and
opens the shape’s text block. After you highlight text within a text block, you
can delete, cut, copy, or format the selection, or you can type or paste to replace
it. To add text without replacing any of the existing text, click with the text tool
to place an insertion point where you want to type new text.

To rotate, resize, or move an entire text block, select its shape with the text block

tool ( ).

Methods for selecting text 

To Use this tool Take these steps

Select a text block Click the shape with the text block you want to select. If the
handles are gray, the shape is grouped. Use the Open Group
command to view the shape in the group window.

Select all text in a block or, if there’s no Double-click the shape. Or select the shape, then press F2.
text, to display the insertion point

Select part of the text in a text block Click the shape, then drag the insertion point. Select all the
text, then drag the insertion point.

Select a word or paragraph Click the shape, then double-click a word or triple-click a
paragraph.

Place the insertion point in text Click the shape.

NOTE  Visio zooms in on the drawing when you select text so that you can see
what you are typing. To return to the original magnification, press the Esc key
on your keyboard or click anywhere outside the shape or text block after you
type the text.

To type text in a shape:

1. Select the shape, then type the text.

2. When you finish typing, press the Esc key or click outside the text block.
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To create a text-only shape:

1. Choose the text tool ( ) from the Standard toolbar.

2. Click where you want to start typing, or click and then drag until the text
block is the size you want, then release the mouse button.

3. Type the text.

When you start typing, Visio creates a text-only shape and zooms in on its
text block.

4. When you finish typing, press the Esc key or choose the pointer tool from
the Standard toolbar.

To turn off automatic zooming when editing text:

1. Choose View > Zoom > Custom.

2. Uncheck Zoom When Editing Text.

Related topics
About formatting text ................................................................................................. 85
Adding, editing, and deleting custom-property fields ........................................... 179
Calculating and displaying shape dimensions ............................................. Visio Help
Printing headers, footers, and page numbers .......................................................... 116
Typing special characters ............................................................................... Visio Help

Cutting, copying, and pasting text

You cut, copy, or paste text in Visio in the same way you do in many word-
processing programs. You can also reverse text changes by using the Undo
command.

NOTE  When you paste text from another application, the formatting informa-
tion is lost.

Methods for cutting, copying, and pasting text

To Use this tool Take these steps

Cut or copy selected text to the clipboard Select the text, then press Ctrl+X to cut or Ctrl+C to copy.

Copy all text to the clipboard Click the shape, then press Ctrl+C.

Paste text from the clipboard Click to place the insertion point, then press Ctrl+V.

Repeat a text action, such as pasting text Press F4.

Related topics
Duplicating shapes ...................................................................................................... 47
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Editing existing text

After you’ve added text to a shape, you can edit it by placing an insertion point
into the text and typing. You can also edit existing text in shapes that come with
Visio.

To edit existing text:

1. Double-click the shape to open the text block, or click the text with the text
tool on the Standard toolbar ( ).

2. Click where you want to place the insertion point.

You can move the insertion point by clicking anywhere in the text block or
by using the arrow keys on the keyboard.

3. Type the new text, then press the Esc key.

NOTE  Double-clicking a grouped shape opens the group window rather than
opening the text block. In the group window, you can double-click shapes
within the group to edit their text blocks.

To delete text from a shape:

1. Choose the text tool from the Standard toolbar.

2. Click the shape that contains the text you want to delete.

When you click the shape, the text block opens and the insertion point
appears at the end of the text.

3. Select the text to delete, or press Ctrl+A to select all text in the text block.

4. Press the Delete key.

5. Choose the pointer tool from the Standard toolbar to close the text block.

To delete a text-only shape:

• Select the shape with the pointer tool, then press the Delete key.

Related topics
Adding and editing text in groups ............................................................................. 78
Typing special characters ............................................................................... Visio Help

Adding and editing text in groups

In grouped shapes, such as the 3-D bar shapes in the charting stencils, Visio
adds any text you type to the frontmost shape in the shape’s stacking order. The
group itself doesn’t have its own text block.

You can change the stacking order of a group by using the Edit > Open Group
command, then using the Shape > Bring To Front command to make the shape
you want the frontmost shape.
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To add or edit text in a shape within a group:

1. Select the group.

Green selection handles appear on the group.

2. Click the shape you want to work with to subselect it.

Gray selection handles appear on the shape.

3. Type to add or edit the text just as you would in an ungrouped shape.

Related topics
About formatting text ................................................................................................. 85
Adding text to shapes and drawings .......................................................................... 75
Editing existing text .................................................................................................... 78
Formatting multiple shapes ....................................................................................... 52
Working with shapes in groups ................................................................................. 42

Setting, changing, and deleting tabs 

You can use tabs to align text in table form or to create bulleted or numbered
lists. Tabs can be left-, center-, or right-aligned. You can also use decimal tabs to
align columns of numbers. A text block can have up to ten tab stops.

29.95
4.630
134.29
.250

29.95
4.630

134.29
.250

29.95
4.630

134.29
.250

29.95
4.630

134.29
.250

A B C D
NOTE  Tabs can only be applied to an entire paragraph, not to selections within
a paragraph.

A
B

C

D

You can set tab positions and alignment for selected text by choosing Format > Text, then
clicking the Tabs tab.

A Lists the existing tab stops for the selected text.
B Click to open the Tab Properties dialog box, where you type the position and alignment for a

new tab.
C Click to open the Tab Properties dialog box, where you can set the position and alignment of

the tab selected in the list.
D Click to delete the tab stop selected in the list.

Tab options in Visio include Left alignment
(A), Center alignment (B), Right alignment
(C), and Decimal alignment (D).
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Tab positions are based on the width of the text block, not the width of the
shape or the shape’s distance from the edges of the page. If you are working at a
scale of 1:1, you can make setting tabs easier if you move the horizontal ruler’s
zero point to the edge of the text block before you choose tab positions.

TIP  If you’re working at a scale other than 1:1, such as ¼"=1', the rulers measure
in drawing units (in this case, feet), while the tabs are measured in page units
(in this case, inches). This difference can be confusing when you’re trying to use
the ruler to determine tab positions. You can use the rulers, it just requires a
little math. For example, if your scale is ¼"=1', every foot on the ruler is ¼", so
if you want to set a tab where the ruler reads 3', multiply 3 by ¼ and set your tab
at .75".

TIP  To set a tab that applies to the entire text block, click an insertion point
anywhere within the text (without highlighting the text) or select the whole text
block with the pointer or text block tool ( ).

Lorem 1 31 22

Dolor 16 24 06
Ipsum 33.3 2.8 4     

Lorem 1 31 22
Ipsum 33.2 2.8 4
Dolor 16 24 06

Select specific paragraphs to set tabs for Select a text block or place an insertion
part of a text block. point in the text to set tabs for the whole text

block at once.

To move the ruler’s zero point to the left edge of a text block:

1. Select the shape with the text tool ( ) so you can see the edge of the text
block.

2. Hold down the Ctrl key and point to the vertical ruler to the left of the draw-
ing window, then drag a vertical line to the left edge of the text block.

When you release the mouse button, the line disappears and the horizontal
ruler’s zero point appears at the left edge of the text block.

TIP  To return the ruler’s zero point to its original position after setting tabs,
double-click the ruler intersection in the upper-left corner of the drawing page.

To add tab stops to selected paragraphs:

1. Choose the text tool from the Standard toolbar, then select the shape to open
the text block.

2. Select one or more paragraphs that you want to format.

3. Choose Format > Text to open the Text dialog box, then click the Tabs tab.

4. Click the Add button to open the Tab Properties dialog box, then type the
position you want for a tab stop in the Position box. Choose an alignment
option for the tab, then click OK in the Tab Properties dialog box.

The tab appears in the Tab Stops list.

5. Click OK in the Text dialog box.

Moving the zero point.
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To delete tab stops from selected paragraphs:

1. Select the shape.

2. Select one or more paragraphs that you want to delete tabs from.

3. Choose Format > Text to open the Text dialog box, then click the Tabs tab.

4. In the Tab Stop list, choose the tab stop you want to delete, then click Delete.

Repeat for other tab stops you want to delete.

5. Click OK.

To change the position of a tab stop:

1. Select the shape.

2. Select the paragraph that includes the tab you want to move.

3. Choose Format > Text to open the Text dialog box, then click the Tabs tab.

4. In the Tab Stop list, choose the tab stop you want to move.

5. Click Edit to open the Tab Properties dialog box, enter a new value in the
Position box, then click OK.

The tab appears with its new value in the Tab Stops list.

6. Click OK.

To set tabs for table text:

1. With the text tool, select an existing text block or shape.

2. Choose Format > Text to open the Text dialog box, then click the Paragraph
tab.

3. Set Horizontal Alignment to Left and Indents to zero, then click OK.

4. Move the vertical ruler’s zero point to the left edge of the text block. To do
this, hold down the Ctrl key and drag from the vertical ruler.

5. Choose Format > Text to open the Text dialog box again, click the Tabs tab,
then drag the Text dialog box so that you can see the text block.

6. Click Add in the Text dialog box to open the Tab Properties dialog box, enter
the position and set the alignment for the first tab in your table, then click OK.

Because you moved the zero point, you can set tab stops as the distance from
zero.

7. Repeat step 6 for each tab in your table, then click OK in the Text dialog box.

Related topics
Creating numbered and bulleted lists using tabs and indents ................................. 82
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Creating numbered and bulleted lists using tabs and indents

You can create numbered and bulleted lists, using tabs and hanging indents.
After you’ve set tabs and indents using the Format > Text command, you can
type bullets or numbers before each paragraph.

• Lorem ipsum dolor  s i t  amet ,  consectetuer
adipiscing el i t .

• Sed d iam nonummy n ibh eu ismod t inc idunt  u t
laoreet  dolore magna a l iquam erat  vo lutpat .

• Ut  wis i  en im ad min im veniam, quis  nost rud
exerci  tat ion ul lamcorper.

By using tabs in combination with paragraph indent settings, you can create bullet lists with
hanging indents.

• • • • • •
You can select the bullet and use the Font Size list on the toolbar to change its size.

NOTE  To create bullet lists quickly and automatically, use the bullets button on
the Text toolbar or the Bullets tab in the Text dialog box.

To create a numbered list using tabs and indents:

1. Use the text tool to select an existing text block or shape.

2. Choose Format > Text to open the Text dialog box, then click the Paragraph
tab.

3. Set Horizontal Alignment to Left, then for Left enter a value that leaves
enough room for a bullet and a blank space, such as 1 pica.

4. For First enter a negative value, such as -1 pica.

5. Click the Tabs tab, then click Add. For Position, enter the same value you
used in step 3, then click OK.

To create a list item, type the number in the style you want, press Tab, then
type.

To create a bulleted list using tabs and indents:

1. Use the text tool to select an existing text block or shape.

2. Choose Format > Text to open the Text dialog box, then click the Paragraph
tab.

3. Set Horizontal Alignment to Left, then for From Left enter a value that leaves
enough room for a bullet and a blank space, such as 1 pica.
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4. For First Line enter a negative value, such as -1 pica.

5. Click the Tabs tab, then click Add. For Position, enter the same value you
used in step 3, then click OK.

To create a list item, type the bullet (Ctrl+Shift+8) in the style you want, press
Tab, then type. You can also add bullets using the bullet tool on the Text toolbar.

Related topics
Changing the horizontal alignment, indentation, and spacing of paragraphs ....... 88
Creating bulleted lists automatically ......................................................................... 83
Setting, changing, and deleting tabs .......................................................................... 79

Creating bulleted lists automatically

To create bulleted lists quickly and automatically, you can use the bullet button
on the Text toolbar or choose an option in the Bullets tab in the Text dialog box.
When you apply bullet formatting to a piece of text, each paragraph in the text
becomes a bulleted item with a hanging indent.

The bullets Visio uses for bulleted lists do not change shape when you apply a
different font to the list text. For example, if you apply round bullets to a list
and then change the list text to Zapf Dingbats, the bullets remain round. How-
ever, if you change the font size of the list text, the bullets increase in size with
the text.

TIP  To create custom bullets or bullets that are a different size from the list text,
create them manually using tabs and indents.

To create a bulleted list using the Bullets tab:

1. Use the text tool to select the list text or place a cursor in a text block where
you want to type a bulleted list.

2. Choose Format > Text to open the Text dialog box, then click the Bullets tab.

3. Select a bullet option, then click OK.

To create a bulleted list using the bullets button:

1. Use the text tool to select the list text or place a cursor in a text block where
you want to type a bulleted list.

2. Click the bullets button on the Text toolbar.

The last bullet format that was chosen in the Bullets tab will be applied to
the text.

Related topics
Creating numbered and bulleted lists using tabs and indents ................................. 82
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Adding annotation layers to drawings

During the life cycle of certain types of technical drawings, an engineer or
architect creates the drawing and then may forward the file to a manager, client,
or quality assurance person, who marks changes to be made. Using Visio, you
can streamline this markup, or redlining, process by creating a separate layer for
review comments. Placing the comments on a layer by themselves makes them
easy to view, print, and color separately from the rest of the drawing, and makes
the incorporation process easy and efficient.

To add and set up a separate layer for review comments:

1. In the drawing  you want to add comments to, choose View > Layer Properties.

2. Click New, type Redlining, then click OK.

3. With the Redlining layer selected, click the Active button. A checkmark
appears next to Redlining in the Active column.

4. With the Redlining layer selected, click the Color button, then choose a color
from the Layer Color list. Click OK to close the dialog box.

TIP  If more than one person is reviewing a drawing, create a redlining layer for
each reviewer and give each layer a different display color.

A B C D

E

F

Use the Layer Properties dialog box to set up one or more redlining layers for your reviewers
to annotate a file.

A List of layers in the drawing, including a
redlining layer. Click a layer to select it.

B Click to make the selected layer active. If
you make only the redlining layer active,
all changes to the drawing will be added
to that layer.

C Click to lock the selected layer against
changes before sending the file out for re-
view.

D Click to color all shapes and text added to
the selected layer.

E Click to add a new layer to the drawing.
You can name the layer—for example,
Redlining.

F Choose the color for the selected layer
from this list.

Related topics
About layers ............................................................................................................... 143
Creating, removing, and renaming layers ............................................................... 145
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Formatting text

About formatting text

You can format text in your drawing by changing any one or all of the text’s
attributes, such as color, alignment, font, and size.

To change the appearance of your text:

• Use tools from the Text toolbar to apply local formatting.

• Use the commands on the Format menu to apply local formatting.

• Use the Text style lists to apply a style.

In addition to formatting text, you can format the text block that contains the
text. You can change the background color, vertical alignment, margins, and
rotation.

Related topics
Applying text formatting ............................................................................................ 85
Changing margins and centering drawings ............................................................ 109
Changing the background color of text blocks ......................................................... 93
Changing the default text, line, or fill styles in shapes ................................. Visio Help
Changing the horizontal alignment, indentation, and spacing of paragraphs ....... 88

Applying text formatting

You can choose from the following formatting methods according to the type
of formatting you are doing.

The Text toolbar
By using the tools on the Text toolbar to apply local formatting to your text, you
can quickly change size, color, font, style, indents, paragraph spacing, and bullets.
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Format menu commands
Using the commands on the Format menu takes a little more time than using
the toolbar, but you gain a degree of precision and a few additional options. For
example, you can enter the precise font size you want and set text case and po-
sition in the Text dialog box.

The Text style list
When you format text using the text style list on the Text toolbar, you’re actually
applying a style. When you start a drawing with a Visio template, the template
includes style definitions and the appropriate styles appear in the style lists on
the toolbar. It’s best to use a style if you want to apply many formatting
attributes to many different shapes. Using styles instead of local formatting can
also reduce the file size of your drawing and increase its performance.

To display the Text toolbar:

• Choose View > Toolbars > Text. A checkmark next to a toolbar name indi-
cates that it is currently displayed.

B C D E F

G H I J K L M O P Q R S T VU

A

N

The Text toolbar. Pause the pointer over a tool or button to see a tip.

A Text style list L Middle align
B Font list M Bottom align
C Font size list N Bullets
D Bold O Decrease indent
E Italic P Increase indent
F Underline Q Decrease paragraph spacing
G Left align R Increase paragraph spacing
H Center align S Increase font size
I Right align T Decrease font size
J Justify U Text color
K Top align V Rotate text 90º
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A

B

For options that aren’t on the Text toolbar, such as text position and case, and for finer
control over text, choose Format > Text to open the Text dialog box.

A Choose Normal, All Caps, or Initial Caps.
B Choose Normal, Superscript, or Subscript.

To quickly format individual paragraphs, words, or characters: 

• Choose the text tool ( ) from the Standard toolbar, select the text you want
to format, then choose formatting options from the Text toolbar or Format
menu.

To format all the text in a shape’s text block:

1. Select the shape with any tool that can select shapes. Or choose the text tool
from the Standard toolbar, then click to place an insertion point in the
shape.

2. Choose the formatting options you want from the Text toolbar or Format
menu.

To format text using the Text dialog box:

1. Double-click the shape to open the text block.

To format part of the text block, select the text you want to format.

2. Choose Format > Text, then click the Font tab.

3. Choose the formatting options you want.

4. Click Apply to apply the attributes and continue working in the dialog box,
or click OK to apply the attributes and close the dialog box.

To format text using keyboard shortcuts:

1. Double-click the shape to open the text block, or click the text with the text
tool.

2. To format part of the text block, select the text you want to format.

3. Use the following keyboard shortcuts to format the selected text.
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Keyboard shortcuts

For Type

Bold Ctrl+Shift+B

Italic Ctrl+Shift+I

Small caps Ctrl+Shift+Y

Subscript Ctrl+Shift+X

Superscript Ctrl+Shift+Z

Underline Ctrl+Shift+U

Related topics
Changing margins and centering drawings ............................................................ 109
Changing the background color of text blocks ......................................................... 93
Changing the default text, line, or fill styles in shapes ................................. Visio Help
Changing the horizontal alignment, indentation, and spacing of paragraphs ....... 88

Changing the horizontal alignment, indentation,
and spacing of paragraphs

The alignment of text in shapes is determined in relation to the text block, not
the shape or the drawing page.

You can change the alignment and indentation of any paragraph with respect to
its text block. For example, if you want to create a bulleted list or a table, you
begin by aligning the text on the left side of the text block. If you want to create
a hanging indent for your bullet list, you set the indentation of the left side and
first line of each paragraph. And if you want to ensure that there are always four
points of space after each bulleted item, you set the paragraph spacing.

• Lorem ipsum dolor  s i t  amet ,  consectetuer
adipiscing el i t .

• Sed d iam nonummy n ibh eu ismod t inc idunt  u t
laoreet  dolore magna a l iquam erat  vo lutpat .

• Ut  wis i  en im ad min im veniam, quis  nost rud
exerci  tat ion ul lamcorper.

This list uses left alignment, indentation to create hanging indents,
and paragraph spacing after each item.
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A

B

C

You can change the alignment, indentation, and line spacing of selected text by choosing
Format > Text, then clicking the Paragraph tab.

A Choose the alignment of the text lines.
B Type the positions for indents between paragraphs and the edge of the text block.
C For Before and After, type spacing values as an absolute amount, such as 12 points (pt). For

Line, you can type a spacing value as a percentage of font size or as an absolute amount.

To change horizontal alignment of a paragraph:

1. Double-click the shape to open the text block, or click the text with the text
tool ( ) on the standard toolbar.

2. Select the paragraph you want to format.

3. Choose Format > Text, then click the Paragraph tab.

4. For Horizontal Alignment, choose Left, Center, Right, Justify, or Force
Justify.

5. Click Apply to apply the formats without closing the dialog box, or click OK
to apply the formats and close the dialog box.

To change the indentation of a paragraph:

1. Double-click the shape to open the text block, or click the text with the text
tool ( ).

2. Select the paragraph you want to format.

3. Choose Format > Text, then click the Paragraph tab.

4. For Indentation, specify the indentation you want:

Enter a value for Left, such as 3p2 (3 picas, 2 points) to indent the whole left
side of the paragraph.

Enter a value for Right, such as 1in (1 inch) to indent the whole right side of
the paragraph.

Enter a value for First, such as 2cm (2 centimeters) to indent the left side of
the first line of the paragraph.

5. Click Apply to apply the formats without closing the dialog box, or click OK
to apply the formats and close the dialog box.
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To change the line spacing of a paragraph:

1. Double-click the shape to open the text block, or click the text with the text
tool ( ).

2. Select the paragraph you want to format.

3. Choose Format > Text, then click the Paragraph tab.

4. For Spacing, specify the paragraph spacing you want:

Enter a value for Before to set the amount of space before the paragraph.

Enter a value for After to set the amount of space after the paragraph.

Enter a value for Line to set the amount of space between each line in the
paragraph.

5. Click Apply to apply the formats without closing the dialog box, or click OK
to apply the formats and close the dialog box.

Related topics
Changing vertical alignment and margins of text blocks ........................................ 90

Changing vertical alignment and margins of text blocks

In most cases, the vertical alignment of text within a text block is set to Middle
by default, but you can change the alignment of any text block. You can also
change the margins of a text block to add or delete space between the text block
and the boundary of the shape.

Using the commands on the Format menu gives you more precise control than
dragging the borders of the text block, allowing you to ensure that your text is
positioned properly with respect to the shape, even when you change the text.
For example, you can set exact margins or make sure your text starts at the top
of the text block instead of being aligned in the middle.

TIP  If you want a shape’s text to resize when you resize its shape, you can use
the SmartShape Wizard to add formulas that change the default text behavior.
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A

B

C

D

You can change the vertical alignment, margins, and background color of a selected text
block by choosing Format > Text, then clicking the Text Block tab.

A Choose the vertical alignment of text within a text block.
B Type the positions for the space between the edges of the text and the text block’s selection

box.
C Select to make the text block transparent.
D Select to make the text block background opaque, then choose a color from the list. The

color fills the area around the text, not the whole text block.

You can use the toolbar buttons on the Text toolbar to align text vertically at the top, middle,
or bottom of the text block.

To change vertical alignment of text within a text block:

1. Select the shape you want to format.

2. Choose Format > Text, then click the Text Block tab.

3. From the Vertical Alignment list, choose a text alignment option.

4. Click OK.

To change the margins between the text and the edge of the
text block:

1. Select the shape you want to format.

2. Choose Format > Text, then click the Text Block tab.

3. In the Margins section, enter values such as 3p1 or .5in in the Top, Bottom,
Right, and Left boxes to set the text block margins.

4. Click OK.

Related topics
Changing the horizontal alignment, indentation, and spacing of paragraphs ....... 88
Rotating, resizing, and moving text blocks ............................................................... 92
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Rotating, resizing, and moving text blocks

When you rotate, resize, or move a shape, its text block rotates, resizes, or moves
with it. You can also rotate, resize, and move a text block separately from its
shape using the text block tool on the Standard toolbar. This tool moves or ro-
tates only the text block, whereas the rotate tool and pointer move or rotate the
whole shape.

In addition, Visio masters often include a control handle that you can use to re-
position the text block, but if you draw your own shape or want to change the
text block size, you can move or resize a text block manually.

To rotate text independently of its shape:

1. Select the text block tool ( ).

The text block cursor is a page ( ).

2. Click the shape to select its text block.

Green handles appear around the shape, indicating that it is selected. If the
handles are gray, the shape is grouped. Choose Edit > Open Group to view
the shape in the group window.

3. Drag a corner handle to rotate the text block.

When it is over a rotation handle, the pointer changes to a pair of arrows

forming a circle ( ). If the text block is so small that you don’t see rota-
tion handles, drag the selection handle at the center of the shape to resize the
text block until you see the rotation handles.

TIP  To rotate text in 90º increments, use the rotate text 90º tool ( ) instead of
the text block tool.

To resize a text block independently of its shape:

1. Select the text block tool ( ).

The text block cursor is a page ( ).

2. Click the shape to select its text block.

Green handles appear around the shape, indicating that it is selected. If the
handles are gray, the shape is grouped. Choose Edit > Open Group to view
the shape in the group window.

3. Drag a side selection handle until the text block is the width or height you
want.



F O R M A T T I N G  T E X T 9 3

To move a text block independently of its shape:

1. Select the text block tool ( ).

The text block cursor is a page ( ).

2. Click the shape to select its text block.

Green handles appear around the shape, indicating that it is selected. If the
handles are gray, the shape is grouped. Choose Edit > Open Group to view
the shape in the group window.

3. Point to the dotted green line that indicates that the text block is selected.

When it is over the dotted line, the pointer changes to a double rectangle.

4. Drag the text block to a new position.

The text block remains part of the shape, so you can move the text block
completely outside the shape’s borders and it will still move, rotate, and
resize with the shape, keeping its new position relative to the shape.

Changing the background color of text blocks

In most Visio shapes, the area around the text, or “text background,” is transpar-
ent. You can apply color to text backgrounds to make them opaque, so elements
of the shape don’t show through and make the text unreadable. For example,
you can add a text block background to “break” a connector line when it crosses
through the text.

Min im Ven iam Min im Ven iam

Changing the text background to solid white makes the connector line appear to “break”
before and after the text block, ensuring the text is readable.

NOTE  Because the background color fills in the area around the text, the color
only appears when the shape contains text.
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To change the color of a text background:

1. Select the shape.

2. Choose Format > Text, then click the Text Block tab.

3. For Text Background, select Solid Color, then choose a color from the list.

The color fills the area around the text, not the whole text block.

4. Click OK.

Related topics
Adding text to shapes and drawings .......................................................................... 75

Copying text formatting to another shape

If you’re pleased with the text formatting of a particular shape, you can quickly
transfer that formatting to another shape. With the Format Painter tool you can
copy all text formatting—the font, size, color, style, alignment, spacing, and text
block background—in one step, rather than having to change each setting indi-
vidually on the new shape.

To copy text formatting from one shape to another:

1. From the Standard toolbar, select the text tool ( ), then click the shape to
open the text block with the text formatting you want to copy.

TIP  If Visio automatically zooms in on the text so that you can no longer see
the other shape you want to format, press Ctrl+W to zoom out and display
the entire drawing page in the Visio window.

2. Click the format painter button ( ) on the Standard toolbar.

The pointer changes to an arrow with a paint brush.

3. Click the new shape you want to format.

NOTE  This procedure copies text formatting only. To copy all shape formatting,
in step 1, use the pointer tool instead of the text tool to click the shape with the
formatting you want to copy.
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Using data from other
programs in Visio drawings

About including other programs’ data in Visio drawings

You can use any one of the following methods to insert other programs’ objects
or files in Visio drawings:

• Embedding

• Linking

• Converting

• Importing

The method you choose depends on the type of object or file you want to
include in your Visio drawing, and what you want to do with the object or file
once it’s there.

Related topics
Converting non-Visio files to shapes and drawings ............................................... 106
Editing objects from other programs ...................................................................... 101
Embedding objects in drawings ................................................................................. 96
Importing non-Visio files as graphic images .......................................................... 103
Linking objects to drawings ....................................................................................... 97
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Embedding objects in drawings

Embed an object in your Visio drawing when you want to keep all the data you
want to work with in one file, or if you want to transfer the file to other com-
puters. You can embed data from programs that support OLE.

For example, if you want to distribute data about a department’s computer
equipment along with a network diagram you created in Visio, you can quickly
embed a Microsoft Excel spreadsheet into the network diagram.

When you embed data from another program, Visio becomes the “container”
for that data. The object embedded in the Visio drawing becomes part of the
Visio file and, when you edit the data, you open its program from within the
Visio drawing.

The changes exist only in the Visio drawing, so it’s not necessary to keep that
data in a separate file. If the data does exist in a separate file, the original file
does not change when you change the embedded object in Visio. Also, changes
to the original file do not affect the embedded object in the Visio drawing.

To embed another program’s object in a Visio drawing:

1. Open the file that contains the data you want.

2. In the file, select the data you want to embed in the Visio drawing.

3. Choose that program’s command to place data on the Clipboard.

Usually the command is Edit > Copy.

4. In the Visio window, display the drawing in which you want to embed the
object.

5. Choose Edit > Paste or click the Paste button ( ) on the Standard toolbar.

The data on the Clipboard is pasted into the drawing as an embedded ob-
ject. The object appears in the center of the view, but you can select and
move it as you would any Visio shape.

To embed an object from an existing file within Visio:

1. Choose Insert > Object, then, in the Insert Object dialog box, select Create
From File.

2. Type a path and file name in the text box.

Click Browse to look for the file if you’re not sure of its path or file name.

3. Check Display As Icon if you want that program’s icon to appear in the
drawing instead of the data.

4. Click OK.

The first page of the file appears in the Visio drawing, unless you chose to
display it as an icon. You can select the object and drag to reposition it.
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To create a new embedded object from within Visio:

1. Choose Insert > Object, then, in the Insert Object dialog box, select Create
New.

2. From the Object Type list, select the type of object you want to create, then
click OK.

The program for creating that object opens within Visio. If the program is
compatible with OLE 2, it opens in place in the Visio drawing, otherwise the
program opens in its full window.

3. Create the object in the other program.

4. If the program is running in place, click anywhere outside the embedded
object to close the program. If it’s running in its full window, from the
program’s File menu, choose Exit.

Related topics
Editing objects from other programs ...................................................................... 101
Linking objects to drawings ....................................................................................... 97

Linking objects to drawings

If another program supports OLE, you can link its data to Visio drawings. Use
linking when you want to include the same data in many files. When you up-
date the data, all links to other files reflect the changes.

For example, if you created your company logo in an OLE-compatible drawing
program, and you want to include the logo in every flowchart, organization
chart, and network diagram you create in Visio, you can link the logo to each
Visio drawing. When you change your original logo in the drawing program,
the Visio drawings update automatically.

When you link data from another program, the Visio drawing stores only a ref-
erence to the location of the file in which you created the data. You link data
from a saved file, so Visio can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly
increase the file size of the Visio drawing. However, links require a little more
maintenance. If you move any of the linked files, you need to update links. In
addition, if you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing
or choose to do so only when you explicitly request it. Any time a link is up-
dated, changes made to the object in its original file appear in the Visio drawing,
and will appear in the original file if the changes were made through Visio.
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To link a file to a Visio drawing:

1. Save the original file.

Because a link consists of a reference to the original file, you must save the
file before you can link to it.

2. In the original file, select the data you want in the Visio drawing.

3. Choose the command used by that program to place data on the Clipboard.

This is usually the Edit > Copy command.

4. Display the Visio drawing to which you want to link the file.

5. In Visio, choose Edit > Paste Special, then, in the Paste Special dialog box,
select Paste Link.

6. Click OK.

To create a linked object from within Visio:

1. Display the Visio drawing in which you want to display the linked object.

2. Choose Insert > Object.

3. Select Create From File.

4. Type a path and file name in the text box.

Click Browse to look for the file if you’re not sure of its path or file name.

5. Check the Link box.

6. Check Display As Icon if you want that program’s icon to appear in the
drawing instead of the data.

7. Click OK.

The first page of the file appears in the Visio drawing, unless you chose to
display it as an icon. You can select the object and drag to reposition it.

Related topics
Embedding objects in drawings ................................................................................. 96
Editing objects from other programs ...................................................................... 101
Updating and managing linked objects ..................................................................... 99
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Updating and managing linked objects

When you include linked objects in a Visio drawing, you need to decide how
you want to update the objects when the original file changes. If you move or
rename the original file, you also need to update the links in the Visio file.

By default, links for an object update automatically when you open a drawing
that includes the object. If you open a drawing that includes a linked object for
which Visio cannot find the original file, Visio prompts you to update links
manually. If the object’s program is not available—for example, if you open a
drawing on a system that doesn’t have that program installed—Visio displays
another prompt. The visible representation of the object in the drawing is not
affected, but because the object’s program is not available, there isn’t a working
link between the Visio drawing and the object’s file, so you cannot edit it.

To set a link so you can update it manually:

1. Choose Edit > Links.

2. Select the link you want to update manually.

3. Select Manual, then click Close to close the dialog box.

To update a link manually:

1. Choose Edit > Links.

2. Select the link you want to update.

3. Click Update Now, then click Close.

To change a link:

1. Choose Edit > Links.

2. Choose the link you want to change.

3. Choose the appropriate settings.

To have Visio update the link automatically, choose Automatic.

To update the link by using the Links command, choose Manual.

To open the object’s program and edit the object, click Open Source.

To link a different file to the Visio drawing, click Change Source.

When you finish viewing and changing links, click OK in the Change Source
dialog box.

4. In the Links dialog box, click Close.
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To break a link:

1. Choose Edit > Links.

2. Choose the link you want to break.

3. Click Break Link.

Visio displays a warning that breaking the link will disconnect the object
from its source. Click Yes to proceed. Visio converts the object to a metafile
in the drawing and discards the reference to its original file.

4. Click Close.

NOTE  You can also break a link between an object and its original file by con-
verting it to a Visio shape with the Convert To Group command.

Related topics
Linking objects to drawings ....................................................................................... 97

Pasting data in particular formats

Most OLE-compatible programs place data on the Clipboard in more than one
format to make the data usable to more programs. When you paste another
program’s data into Visio, by default it’s embedded into the Visio drawing in its
original format. That way, you can open the embedded data in its native pro-
gram from within the Visio drawing.

Sometimes you may want to use a different format. For example, if you typed
text in a Microsoft Word document, and want it to appear within a Visio shape’s
text block, you can copy the text in Word, then paste it into the text block as
ANSI text rather than embed it as a Word document. In this example, the text is
formatted according to the styles set for the shape’s text block.

To paste data into a drawing in a particular format:

1. In the other program, choose the command to copy the data you want to
paste into the Visio drawing.

This command is usually Edit > Copy.

2. Display the Visio drawing that you want to paste the data in.

3. Choose Paste Special.

4. In the Paste As box, select the format you want, then click OK.

Related topics
Embedding objects in drawings ................................................................................. 96
Editing objects from other programs ...................................................................... 101



U S I N G  D A T A  F R O M  O T H E R  P R O G R A M S  I N  V I S I O  D R A W I N G S 1 0 1

Editing objects from other programs

After you embed or link an object from another program into a Visio drawing,
you can modify the object in several ways. You can

• Edit the object in place so you can see how changes affect the way it fits into
the drawing.

• Convert the object to another format.

• Change the appearance of the object’s border.

Editing an embedded or
linked object from within Visio
You can modify an embedded or linked object in its original program from
within Visio. When you modify an embedded object, you change only the ob-
ject in Visio, not its original file (if you pasted the object from an existing file).
When you modify a linked file, you open and change the original file.

Most programs include a submenu of actions you can perform on an embed-
ded or linked OLE object. Usually, the commands for editing OLE objects are
Edit and Open. If the object is embedded and its program supports in-place
editing, the Edit command opens the object in place. The Open command
opens the object in the full program window. In Visio, this command appears at
the bottom of the Edit menu.

To edit an embedded or linked object:

• In the Visio drawing, double-click the object.

If the object is embedded and the program in which you created the object
supports in-place editing, the object opens in place. If the object is linked, or
its program does not support in-place editing, the other program opens in
its full window and displays the object.

TIP  To open an object in its full program window, even if it supports in-place
editing, select the object, then choose Edit > [Object Name] > Open.

Converting pasted or
imported metafiles to Visio shapes
You can convert pasted or imported metafiles to Visio groups or shapes. If a
linked or embedded object is represented by a metafile, you can also convert the
object; however, doing so breaks the object’s link to its original file, so you can
no longer edit it in its original program.
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To convert a pasted or imported metafile:

1. Select the object you want to convert.

2. Choose Shape > Grouping > Convert To Group .

TIP  If you want to edit individual components of the object after you con-
vert them, choose Ungroup rather than Convert To Group.

A metafile may contain a bitmap as a component or may consist solely of a
bitmap. Bitmaps cannot be converted to Visio shapes because, in a bitmap, Visio
cannot determine what part of the object is a line, what is text, and so on.

A metafile that consists of a single bitmap usually stores the bitmap in seg-
ments. When you convert such a metafile to Visio shapes, each segment of the
metafile becomes an individual bitmap object. In this case you may want to
convert the metafile to a group rather than ungrouping it to keep the bitmaps
together.

Changing an object’s appearance
You can format an object from another program in the following ways:

• You can apply a line style or attribute to change the appearance of the
object’s border. For example, you might choose a distinctive outline for em-
bedded or linked objects to indicate they can be edited from within a
drawing.

• You can apply a fill style or attribute to change the fill color and pattern of
the object. For the fill color and pattern of an object to be visible, there must
be some empty space around the object, or background, within its border.

To format an object from another program:

1. Select the object you want to format.

2. From the Format menu, choose

Line to change the appearance of the object’s border.

Fill to change the appearance of the object’s background.

Shadow to add a drop shadow to the object.

3. Click OK.

Related topics
Importing non-Visio files as graphic images .......................................................... 103
Embedding objects in drawings ................................................................................. 96
Linking objects to drawings ....................................................................................... 97
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Importing non-Visio files as graphic images

Importing provides an alternative to linking or embedding an object when you
want to include data from another program that is not compatible with OLE.
When you import data into a Visio drawing, it only exists in Visio as a picture.
That is, the only editing capabilities you have are resizing, repositioning, and
cropping.

To do this, you export the other program’s file to a format Visio can import.
When you export, the file’s data is directed through a filter that translates it and
saves it to a separate file in a different format. Then, when you import the file
into the Visio drawing, Visio uses a filter to translate the data and display
the file.

Importing also works well if you only want to view or annotate the image in the
Visio drawing, or if file size is your primary concern.

Because the data can go through up to two translations before it appears in the
Visio drawing—one when you export from the other program, and one when
you import into the Visio drawing—the picture may not look exactly the way it
does in the original program.

Compatible file formats
In Visio you can import files of these formats:

• ABC FlowCharter 2.0, 3.0, 4.0 (.af3, .af2)

• Adobe Illustrator File Format (.ai)

• AutoCAD Drawing File Format R10–R13 (.dwg)

• AutoCAD Drawing Interchange (.dxf)

• AutoCAD Drawing Web Format (.dwf)

• CompuServe Interchange Format (.gif)

• Computer Graphics Metafile (.cgm)

• Corel Clipart (.cmx)

• CorelDRAW! Drawing File Format, version 3.0, 4.0, 5.0, 6.0 and 7.0 (.cdr)

• CorelFLOW 2.0 (.cfl)

• Encapsulated PostScript (.eps)

• Initial Graphics Exchange Specification (.igs)

• Joint Photographic Experts Group (.jpg)

• Macintosh Picture File Format (.pct)

• Micrografx Designer Version 3.1 File Format (.drw)



1 0 4 C H A P T E R  9

• Micrografx Designer 6.0 File Format (.dsf)

• Portable Network Graphics (.png)

• Tag Image File Format (.tif)

• Text and Comma Separated Variable (.txt and .csv)

• Windows Bitmap (.bmp and .dib)

• Windows Metafile (.wmf)

• ZSoft PC PaintBrush Bitmap (.pcx)

Most files you import into Visio drawings as graphic images appear as
metafiles. However, bitmap files, such as .dib, .bmp, .pcx, and so on, remain
bitmaps in the Visio drawing.

With some vector-based graphics, such as Adobe Illustrator (.ai), CorelDRAW!
(.cdr), Encapsulated PostScript (.eps), and Micrografx Designer (.drw) files,
lines may appear jagged in the Visio drawing. You may get better results with
these file formats if you convert rather than import them.

For most files you import, Visio displays an import settings dialog box where
you can specify how you want the imported file to appear in a drawing. For ex-
ample, if you’re importing a file in .pct format, you can specify whether to
retain gradients and background and how to translate colors.

To import a non-Visio file as a graphic image:

1. Display the Visio drawing that you want to import the graphic into, then
choose Insert > Picture.

2. Under Files Of Type, select the file format you want to import, then, under
File Name, type the path and file name of the file you want to import, then
click Open.

If you don’t know the path and file name, you can look for the file in the
Look In section of the dialog box.

TIP  If you want to modify a graphic image after you import it, and if the image
is a metafile, you can ungroup it. Ungrouping converts the picture to Visio
shapes you can use the way you use shapes that come with your Visio product.
This procedure works only for metafiles—Visio cannot convert bitmaps to
shapes. To make the converted graphic easier to edit, you can use the Fit Curve
command.
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Viewing AutoCAD DWG files in Visio
If you collaborate with AutoCAD users in the process of creating a drawing, you
may need to review and annotate the drawing, then return it to your colleague
to incorporate your ideas. With Visio, you can view .dwg drawings created in
AutoCAD R10–13, then add your comments on a separate annotation layer
in Visio.

To view an AutoCAD drawing in Visio:

1. In Visio, choose File > Open.

2. Under Files Of Type, select AutoCAD Drawing (*.dwg).

3. Under Look In, find the folder that contains the file you want and select the
file, then click Open.

To add a separate annotation layer:

1. While the AutoCAD drawing you want to annotate is open, choose View >
Layer Properties.

2. Click New. In the New Layer dialog box, type Redlining, then click OK.

3. In the Redlining row of the Layer Properties dialog box, click the column
titled Active. A check mark appears in the column.

NOTE  Make sure not to click the Active button at the top of the column.
This checks all rows, not only the Redlining row.

4. In the Redlining row, click to check the Color column.

5. In the Layer Color box at the bottom of the dialog box, select the color for
your comments, then click OK to close the Layer Properties dialog box.

Related topics
About layers ............................................................................................................... 143
Converting non-Visio files to shapes and drawings ............................................... 106
Converting a text file to a Visio drawing ...................................................... Visio Help
Merging shapes to create new ones .......................................................................... 210
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Converting non-Visio files to shapes and drawings

When you open a file of a format compatible with Visio, Visio converts the file
to a drawing with SmartShapes symbols. Convert data to Visio shapes when you
want to transfer shapes you created in another program to a Visio drawing, so
you can edit them in ways other than resizing or repositioning, as well as save
them as masters onto stencils.

You can edit the converted shapes as any other Visio shapes using the Visio for-
matting and drawing tools. You can also flip, rotate, and resize them. However,
with bitmap formats (BMP, DIB, PCX, and so on), Visio pastes the contents of
the bitmap into the drawing without converting it.

Files you convert are larger in size than files you import as graphic images. If file
size is your main consideration, you may want to import the data.

Converting ABC FlowCharter and CorelFLOW! files
For ABC FlowCharter 2.0, 3.0, and 4.0 and CorelFLOW 2.0 files, Visio includes
masters that match shapes provided with those programs (all of the
FlowCharter shapes, and many of the CorelFLOW shapes). When you open a
file of one of these formats, Visio converts the FlowCharter or CorelFLOW im-
ages to the shape equivalents.

To convert a file to a Visio drawing and shapes:

1. From the Visio File menu, choose Open.

2. Under Files Of Type, select the file type you want to open, then under File
Name, type the path and file name, then click Open.

If you don’t know the path and file name, you can find it in the Look In sec-
tion of the dialog box.

Related topics
Importing non-Visio files as graphic images .......................................................... 103
Converting a text file to a Visio drawing ...................................................... Visio Help
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Printing shapes
and drawings

About printing drawings

For the most part, you can print your Visio drawings by choosing Print from
the file menu, and then clicking OK. Most Visio templates are set up so that the
drawing-page and printed-page sizes are the same, so you don’t have to change
page settings to get the printed drawing you expect.

Sometimes, however, you may want to change the size, orientation, or scale of
the drawing page as you create your drawing. If so, you’ll need to keep the
following terms in mind as you set up your drawing for printing:

• The “drawing page”—the white page you see onscreen.

• The “printed page”—the paper in the printer on which you print your Visio
drawing.

• The “printed drawing”—your end result: the image on your drawing page
printed onto one or more printed pages.

If you change drawing-page settings, to make sure the drawing prints correctly,
you may need to change the printed-page settings as well.

For example, if you base a new drawing on a flowchart template with a portrait
(tall) drawing-page orientation, but you create a left-to-right flowchart, you
may want to change the drawing-page orientation to landscape (wide). To print
the drawing the way it appears on the screen, you also need to change the
printed-page orientation.

If you work with large drawings, it’s possible to have a drawing page that’s larger
than the printed page. For example, if you want to create a large network dia-
gram, you may want to increase the size of the drawing page that opens with the
network template. If you increase the drawing-page size but don’t change the
paper in your printer, when you print the drawing, Visio “tiles” it, or prints it
over multiple pages.
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For multiple-page drawings, you can choose to add headers, footers, and page
numbers to the printed drawing.

Related topics
Previewing drawings before you print .................................................................... 108
Printing drawings to paper or files .......................................................................... 111
Setting page orientation and scale ............................................................................. 17

Previewing drawings before you print

Before you print a drawing, you can preview it to see whether the shapes on the
drawing page fit as you intend on the printed page. In the print preview win-
dow, gray lines indicate where the drawing continues onto multiple pages, or
“tiles.”

If the print preview window shows that the drawing will tile, you may want to
reposition some shapes so they print on the correct page. To see how reposi-
tioning shapes on the drawing affects the printed page, you can display the
drawing window alongside the print preview window.

If, after you see the print preview, you want to make changes to the drawing
page or printer settings, such as orientation, size, margins, and so on, choose
Page Setup from the File menu.

A B C D E F G H I

A Click to print the drawing. The number of
pages it prints on corresponds to the num-
ber of tiles in the print preview window.

B Click to move to the first tile.
C Click to move to the previous tile.
D Click to move to the next tile.
E Click to move to the last tile.
F Click to see one tile, or printed page, at

a time.
G Click to see how the drawing page will tile.
H Click to zoom in or out.
I Click to close the Print Preview window.
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To preview a drawing before printing:

• From the Standard toolbar, choose the Print Preview button ( ).

TIP  While working with your drawing you can quickly determine whether it fits
within the printable area by choosing View > Page Breaks.

To edit a drawing while in Print Preview:

1. In the print preview window, choose Window > New Window.

Visio opens a new drawing window and displays the drawing.

2. Choose Window > Tile.

Visio displays the drawing in the print preview window and the drawing
window.

3. In the drawing window, edit the drawing using the Visio tools and commands.

Changes you make to the drawing appear in the print preview window.

Related topics
Avoiding unexpected printing results .......................................................... Visio Help
Printing drawings to paper or files .......................................................................... 111
Printing large and small drawings ........................................................................... 112
Reducing and enlarging drawings for printing ....................................................... 114

Changing margins and centering drawings

To fine-tune a drawing’s placement on the page, you can center it on the draw-
ing page before you print, or you can adjust the margins or center the drawing
on the printed page only.

To center a drawing on the drawing page:

• Choose Tools > Center Drawing.

Visio centers the drawing. If the drawing page and printer paper are the
same size, the drawing will be centered on the printed page as well.

Repositioning a drawing on the printed page
Before you can reposition a drawing on the printed page, you must adjust the
drawing-page size to eliminate all the white space around the drawing. It’s best
to use this method when you want to print a completed drawing.

To adjust the drawing-page size to fit the drawing contents:

1. Choose File > Page Setup.

2. For Page Size, select Size Page To Fit Drawing, then click OK.

The page size changes to fit the drawing without any surrounding white
space. Onscreen it may appear as though you zoomed in on the drawing.
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NOTE  If you want to add shapes later, you may need to open the Page Setup
dialog box again to set the drawing page back to its original size.

After you size the page to fit the drawing, you can adjust the drawing’s place-
ment on the printed page by changing margins or centering the drawing.

To change margins or center a drawing on the printed page:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print
Setup.

2. For Margins, type the margin settings you want.

To center the drawing, under Center, check Left/Right, Up/Down, or both.

A

B

A Type the margin settings you want.
B Check Left/Right to center a drawing between the left and right margins. Check Up/Down to

center it between top and bottom margins.

TIP  To preview the drawing as it will appear on the printed page, choose File >
Print Preview.

Related topics
Avoiding unexpected printing results .......................................................... Visio Help
Printing drawings to paper or files .......................................................................... 111
Printing large and small drawings ........................................................................... 112
Reducing and enlarging drawings for printing ....................................................... 114
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Printing drawings to paper or files

For many drawings, you can use the default printer settings. You can print an
entire drawing or a range of pages and you can center a drawing on a page be-
fore you print. You can also print to a PostScript file if you want to send a
drawing to another printer or deliver a file to a service provider to produce.

Visio templates are set up to print to your default Windows printer. However,
you may sometimes want to print to a different printer or change the properties
set for your default printer.

To choose a printer or change printer settings:

1. Choose File > Page Setup.

2. Click Print Setup, then click Printer.

3. For Name, select a printer from the list, then click OK.

4. In the Print Setup dialog box, choose the settings you want, then click OK.

5. Click OK in the Page Setup dialog box.

Visio redraws the drawing page with the new settings.

To print a drawing:

1. Choose File > Print.

2. In the Print Range section, choose an option for which pages to print:

Choose All or Current Page, or specify a range of pages in the Pages From
and To boxes.

If a foreground page is displayed, choosing the Current Page option prints
the foreground page, its background, and subsequent background layers. If a
background is displayed, Current Page prints that background page and
subsequent background pages.

3. For Copies, enter the number of copies you want.

4. For Printer, specify to print to a file or to print all colors as black.

5. Click OK.

TIP  In Windows 95, to send a file to a printer, you can also drag the file icon
from the desktop or from Windows Explorer and drop it on a printer icon.
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To print a drawing to a PostScript file:

1. Choose File > Print.

2. For Name, select a PostScript printer from the list.

3. Check Print To File, then click OK.

4. In the Print To File dialog box, choose a location and type the name of the
file, then click Save.

Related topics
Avoiding unexpected printing results .......................................................... Visio Help
Changing margins and centering drawings ............................................................ 109
Previewing drawings before you print .................................................................... 108
Printing headers, footers, and page numbers .......................................................... 116
Printing large and small drawings ........................................................................... 112
Reducing and enlarging drawings for printing ....................................................... 114

Printing large and small drawings

If the size of a drawing is larger than the paper in your printer, Visio tiles the
drawing—that is, the drawing prints across several sheets of paper. Visio does
not crop a drawing to fit within the margins.

A drawing on a large drawing page will print by tiling across several sheets of printer paper.

Small drawings print on part of a page. By changing margin settings, you can
print a small drawing at various locations on a sheet of paper.

24 %

40 %

36 %

24 %

40 %

36 %
24 %

40 %

36 %

You can control where the image on a small drawing prints on a printed page.
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Printing large drawings
You can control the way large drawings tile. For example, you can control the
amount the drawing overlaps on adjacent pages. You can also specify the num-
ber of pages across which a drawing tiles. Visio reduces or enlarges the drawing
to fit the number of pages you specify.

To determine whether a large drawing will tile:

• Choose View > Page Breaks.

Gray lines appear on the drawing page, indicating the printed page size and
margins selected in the Print Setup dialog box.

To increase the area where tiled drawings overlap:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print
Setup.

2. Type larger amounts for the margin settings, then click OK.

The larger the margins, the greater the overlap.

3. Click OK in the Page Setup dialog box.

To specify the number of pages for a tiled drawing:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print
Setup.

2. For Reduce/Enlarge, select Fit On, and then specify the number of sheets
across and down.

TIP  Choose the number of pages that represents an area proportionate to
the drawing page. For example, if the drawing is square and you specify two
sheets down and four sheets across, Visio fits the drawing on an area that is
no more than two sheets either way so the drawing stays in proportion.

3. Click OK in both the Print Setup and Page Setup dialog boxes.

Printing small drawings
If your drawing onscreen is smaller than the size of the paper you’re printing it
on, you can specify its position on the printed page. Before you can control its
position, you must adjust the drawing-page size to eliminate all the white space
around the drawing.

To adjust the drawing-page size to fit the drawing contents:

1. From the File menu, choose Page Setup.

2. For Page Size, select Size Page To Fit Drawing, then click OK.

The page size changes to fit the drawing without any surrounding white
space. Onscreen it may appear as though you zoomed in on the drawing.

NOTE  If you want to add shapes later, you may need to set the drawing page
back to its original size.
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After you size the page to fit the drawing contents, you can specify the drawing’s
placement on the printed page.

To specify where on the page a small drawing prints:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print
Setup.

2. Select the combination of margin and center settings to place the drawing at
the location you want, then click OK.

3. Click OK in the Page Setup dialog box.

Related topics
Changing margins and centering drawings ............................................................ 109
Reducing and enlarging drawings for printing ....................................................... 114
Printing drawings to paper or files .......................................................................... 111
Previewing drawings before you print .................................................................... 108

Reducing and enlarging drawings for printing

To print a drawing at various sizes, or to fit a drawing within the printable area
of the paper, you can reduce or enlarge a drawing for printing.

Because Visio treats the drawing page itself as part of the drawing, you must
adjust the drawing-page size onscreen to eliminate all white space around the
drawing to get the results you expect when reducing or enlarging a drawing.

To reduce or enlarge a drawing:

1. Choose File > Page Setup.

2. For Page Size, select Size Page To Fit Drawing, then click OK.

The page size changes to fit the drawing without any surrounding white
space. Onscreen it may appear as though you zoomed in on the drawing.

3. Choose File > Page Setup, then click Print Setup.

4. For Reduce/Enlarge, select one of the following options:

To specify a percentage, select Scale, then type the percentage by which you
want to enlarge or reduce the drawing. To reduce the drawing, type a num-
ber less than 100; to enlarge it, type a number greater than 100.

To specify a number of pages, select Fit On, then type the number of pages
across and down on which you want the drawing to print.
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5. Click OK in both the Print Setup and Page Setup dialog boxes.

6. Choose File > Print Preview to make sure the drawing is the correct size and
prints where you want it to on the page, and on the correct number of pages.

NOTE  If you want to add shapes to the drawing later, you may need to set the
drawing page back to its original size.

Related topics
Avoiding unexpected printing results .......................................................... Visio Help
Previewing drawings before you print .................................................................... 108
Printing drawings to paper or files .......................................................................... 111
Printing large and small drawings ........................................................................... 112

Printing selected shapes or pages

When you don’t want to print your entire drawing, you can print only pages
you specify, only the currently displayed page, or only a page’s background. You
can also define shapes or layers as non-printing so they show up on the screen
but not on the printed page.

In Hendrerit
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The printed page includes all background and foreground shapes except the non-printing
shape.

A Background shapes
B Foreground shapes
C Shape assigned to a non-printing layer
D Printed page

To print only the pages you specify:

1. Display the drawing you want to print, then choose File > Print.

2. Under Page Range, click Pages, then type the page number range in the
From and To boxes.

To print only the page that’s displayed onscreen, click Current Page.
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To print a background separately:

1. Display the background you want to print.

2. Choose File > Print.

3. Under Page Range, click Current Page, then click OK.

TIP  To print a page without its background, display the page and cancel its
background assignment before printing. To cancel a background, choose File >
Page Setup, then click the Page Properties tab. Under Background, select None,
then click OK. After printing, you can reassign the background by selecting it
from the list of backgrounds on the Page Properties tab.

To set a shape as nonprinting:

1. Select the shape, then choose Format > Behavior.

2. Check Non-Printing Shape, then click OK.

TIP  To set all shapes on a layer to nonprinting, you can choose View > Layer
Properties to set the layer to nonprinting.

Related topics
Assigning shapes to layers ........................................................................................ 147
Controlling shape behavior using layers ................................................................. 149
Using backgrounds for common page elements ....................................................... 26

Printing headers, footers, and page numbers

When you print a multiple-page drawing you may want certain information,
such as the name of the drawing file, a border, or your company logo, to appear
on each page. You may also want each page numbered automatically.

By using backgrounds and data fields, you can easily set up items that automati-
cally appear and print on every page of a drawing. In addition, for certain
common items, such as page numbers, the drawing file name, and the date and
time, you can apply headers, footers, and page numbers that appear in the
printed drawing only.
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Adding headers, footers, and page numbers
to the printed drawing only
You can add automatic headers, footers, and page numbers on the Header/
Footer tab of the Page Setup dialog box. You type formatting codes for common
elements, such as page number, time, and date, and specify whether you want
the elements to appear in the upper or lower left, center, or right portion of the
page.

A formatting code is simply an ampersand (&) followed by a letter. For
example, to add a page number, type &p.

Header and Footer formatting codes

For Type

Page number &p

Current time &t or &T

Current date &d (short) or &D (long)

Ampersand &&

File extension &e

File name &f

File name and extension &f&e

Page name &n

Total printed pages &P

To add headers, footers, or page numbers to the printed
drawing only:

1. Open the drawing, and choose File > Page Setup, then click the Header/
Footer tab.

2. For Header and Footer, type the formatting code you want in the box that
corresponds to the section of the printed page on which you want the
header or footer to appear.

3. For Margins, type a value to specify how far the header or footer prints from
the top or bottom of the page.

4. To open the Font dialog box and edit the header or footer text, click Choose
Font.

5. Click Apply to apply the header/footer settings and continue working in the
dialog box. Click OK to apply the settings and close the dialog box.
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To add a custom header or footer that appears on the drawing page
and the printed page:

1. Start a new drawing and, on the Page Properties tab in the File > Page Setup
dialog box, make the first page a background.

Note the name of this page—you’ll need to use it when assigning the back-
ground to a foreground.

2. On the background, add any shapes you want to repeat on each page of the
drawing, for example, a company logo, a border, or a text field that displays
up-to-date drawing information.

TIP  For border shapes, choose File > Stencils > Visio Extras > Borders.

3. Insert a new page, and, on the Page Properties tab in the File > Page Setup
dialog box, make this page a foreground. Under Background, assign the
background you just created.

4. Click OK.

NOTE  Setting up drawing elements that repeat on each page works best when
you’re starting a new drawing. If you start by creating the background and
assigning it to the first foreground page, it is automatically assigned to each
subsequent page you add within the file.

Related topics
Including Visio drawings in Microsoft Binder reports ........................................... 126
Using backgrounds for common page elements ....................................................... 26
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Publishing drawings
on the Internet

About converting shapes and drawings to HTML

You can easily prepare Visio drawings so they can be viewed using a World
Wide Web browser. You can prepare drawings in two ways:

• Save them as HTML pages. For example, you have a new departmental organi-
zation chart you want everyone in the company to see. To immediately make
the chart available on the intranet, save it as an HTML page.

• Export them in .jpg, .gif, or .png format. For example, you have a Web page on
the intranet where you’ve explained the complex process your department
uses to handle customer inquiries. Recently, you created a block diagram
that makes the process easier to understand. To include the graphic on your
existing Web page, export it as a .gif, and add an <IMG> tag to your Web
page HTML code.

Save drawings as HTML pages when

• You want to simultaneously export more than one page of a multiple-page
drawing.

• Shapes in your drawing include navigational links (hyperlinks) and you
want to make your drawing an image map on the Web page.

• You want Visio to create an HTML-coded page and convert a drawing to a
format Web browsers can use.

Export drawings in .jpg, .gif, or .png format when

• You already have an HTML-coded page in which you want to insert a Visio
drawing.

• You want to export only a portion of a drawing.

Related topics
Exporting shapes and drawings in .jpg or .gif format ............................................ 122
Saving drawings as HTML pages ............................................................................. 120
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Saving drawings as HTML pages

When you save a drawing as an HTML page, Visio creates a Web page that con-
tains the drawing and HTML source code. You can immediately view the
HTML page(s) using a Web browser.

If your drawing has multiple pages, Visio creates an HTML page for each draw-
ing page and adds navigation buttons to each page.

By default, if shapes in your drawing have navigational links to other Visio
drawing pages, files created in different applications, or to Web sites, Visio pre-
serves these links as active on the HTML page. The Visio drawing becomes a
“client-side image map.” An image map is a graphic with different regions, some
of which are “hot.” In client-side image maps, all the information a Web
browser needs to process a click on a hot region is stored in the HTML file with
the image data.

You can also save a drawing with navigational links as a “server-side image
map”. In server-side image maps, a program on the Web server examines map
data associated with the hot regions and processes the links.

Visio formats the saved HTML files with a template. The template is an HTML
file with HTML tags and codes that correspond to elements from the drawing,
such as page number, the page graphic, and anchors or jumps to other HTML
pages or files. You can create your own template for saving Visio drawings as
HTML files by modifying the default template.

To save a drawing as HTML pages:

1. In Visio, display the drawing you want to save.

2. Choose File > Save As.

3. Type a name for the HTML file using the .htm extension, such as
Drawing.htm.

4. For Save As Type, choose HTML files (*.htm, *.html), choose where to save
the file, then click Save.

5. In the Save As HTML dialog box, choose the graphics format and the draw-
ing pages you want the HTML file to include.

6. Click Filter Settings to control the on-screen image size of the saved drawing
or to choose options specific to the graphics format, then click OK twice.

7. Visio prompts you to view the HTML pages. Click Yes to open your Web
browser and view the first HTML page.

Visio adds navigation buttons to each
page of a multiple-page drawing when
you save it as an HTML page.
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To save a drawing as HTML pages without preserving links:

1. In Visio, display the drawing you want to save.

2. Choose File > Save As.

3. Type a name for the HTML file using the .htm extension, such as
Drawing.htm.

4. For Save As Type, choose HTML files (*.htm, *.html), choose where to save
the file, then click Save.

5. In the Save As HTML dialog box, choose the graphics format and the draw-
ing pages you want the HTML file to include, then click Options.

6. In the Export Options dialog box, uncheck Enable Image Maps, then click
OK twice.

7. Visio prompts you to view the HTML pages. Click Yes to open your Web
browser and view the first HTML page.

Related topics
Creating templates for saving and formatting HTML pages ................................. 121
Customizing HTML pages ............................................................................ Visio Help
Saving drawings with hyperlinks as server-side image maps ...................... Visio Help

Creating templates for saving and formatting HTML pages

Visio formats saved HTML pages with a template. The template is an HTML
page with regular HTML tags and special substitution codes that correspond to
elements from the drawing, such as page number, the Visio graphic, and links
(or anchors) to other HTML pages or files. When you export, Visio substitutes
drawing elements for the codes.

You can create a custom template for saving and formatting HTML pages by
modifying the Visio default template and by including substitution codes.
When you save a drawing as an HTML file, you can choose which template you
want to use.

To create a custom template:

1. Copy the default HTML template, Dfltdoc.htm, which is located in the
\Visio\Solutions\Visio Extras folder.

2. Open the copy in a program that can open and edit HTML files, such as
Notepad.

3. Change or delete the existing HTML tags or add new ones. Rearrange or de-
lete the substitution codes.

4. Save the revised template under a new name with an .htm extension.
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To use a custom template when you save a drawing as HTML pages:

1. In Visio, create or open the drawing you want to save, then choose File >
Save As.

2. Type a name using the .htm extension, such as Drawing.htm.

3. For Save As Type, choose HTML files (*.htm, *.html), choose where to save
the file, then click Save.

4. In the Save As HTML dialog box, choose the graphics format and the draw-
ing pages you want the HTML file to include, then click Options.

5. In the Export Options dialog box, under HTML Template, check Use Cus-
tom Template, click Browse to locate your custom template, then click OK.

6. In the Save As HTML dialog box, click OK. Visio prompts you to view the
HTML pages. Click Yes to open your Web browser and view the first HTML
page.

Related topics
Customizing HTML pages ............................................................................ Visio Help
Saving drawings as HTML pages ............................................................................. 120
Substitution codes for customizing the Save As HTML template .............. Visio Help

Exporting shapes and drawings in .jpg or .gif format

When you export a Visio drawing as a .jpg (Joint Photographic Experts Group)
or .gif (Graphics Interchange Format) graphic, you convert it to a format you
can distribute over the Internet or intranet. The .jpg and .gif formats are sup-
ported by virtually all Web browsers.

Once the Visio drawing is exported, you can include it in an HTML page by
adding the <IMG > HTML tag (for example, <IMG SRC="drawing1.gif " >) to
the page.

If a drawing includes shapes with navigational links to other Visio drawing
pages, to files created in different applications, or to Web sites, the links are lost
when you export.

To export a drawing in .jpg or .gif format:

1. In Visio, select the shape or drawing you want to export.

2. Choose File > Save As.

3. For Save As Type, choose .jpg , .gif, or .png, then click Save.

4. In the Output Filter Setup dialog box, choose the options you want, then
click OK.

Related topics
About converting shapes and drawings to HTML ................................................. 119
Saving drawings as HTML pages ............................................................................. 120
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Using Visio with
Microsoft Office

About Visio and Microsoft Office 97

Visio products are fully compatible with Microsoft Office 97 programs, so you
don’t need to spend time getting used to a new environment when you work
with Visio.

Full Office 97 compatibility means Visio toolbars, menu commands, and accel-
erator keys are similar to those you find in Office programs. It also means you
can easily exchange shapes, text, and other objects between Visio and Office
programs.

Some features in Visio that provide improved Office 97 compatibility include

• Full-screen view  When you view your Visio drawing in the full-screen, Visio
hides the menus, toolbars, and everything but the drawing page so you can
view the drawing in the maximum space your screen allows. You can use the
left and right arrow keys or the mouse to navigate between pages. Full-
screen view is read-only, so to edit your drawing, press the Esc key to return
to the normal view.

• Improved formatting toolbar buttons  Line, Fill, and Text formatting buttons
on the toolbars now provide pop-up palettes, similar to those in Microsoft
Excel, from which you can select the formatting you want.
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If you are running Office 97, you can use the following features in Visio:

• Routing drawings through email  You can add a routing slip to a drawing
that you send through email so that you are notified when the drawing is
routed from one person to the next, and the drawing is returned to you
when the last person on the list finishes reviewing it.

You can also save a drawing directly to an Exchange folder.

• Recording activities in the Outlook Journal  In Journal, you can automati-
cally record time you spend using Visio.

NOTE  Visio is also an Office 95-compatible program.

Related topics
About including Visio data in other programs’ documents ................................... 127
Exchanging data between Visio and Microsoft PowerPoint ................................... 125
Including Visio drawings in Microsoft Binder reports ........................................... 126
Previewing drawings in full-screen view ................................................................... 28
Sending drawings through electronic mail ............................................................. 134

Displaying and editing Visio drawings in Internet Explorer

From Internet Explorer you can open and work on your Visio drawings without
leaving the Internet environment. You can open a Visio drawing (.vsd) file by
using the Open command—the same way you open an HTML or Office 97
program file. Visio opens the drawing with Visio menus and toolbars, and
opens stencils you saved with the drawing. When you open a drawing from
within Internet Explorer, Visio provides the same tools that are available when
you work with it as a standalone program.

After the Visio drawing is open within Internet Explorer, you can navigate be-
tween the drawing and other Office documents or Web pages by clicking the
Forward and Back buttons on the Internet Explorer toolbar.
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To open a Visio drawing from within Internet Explorer:

1. In Internet Explorer, choose File > Open.

2. Under Open, type the path and name of the Visio file, or click Browse to
find it.

If you click Browse, the Open dialog box appears. Under Files Of Type, select
All Files to display Visio files in the list.

3. When you find the file, select it and click Open.

The file opens in Visio in the Internet Explorer environment.

4. Click the Tools button on the Internet Explorer toolbar to display the Visio
toolbar and menus.

TIP  You can navigate between the Visio drawing, other documents, and Web
pages by clicking the Forward and Back buttons on the Internet Explorer
toolbar. You can also type the URL of the Web site or path and file name of the
document in the Address box.

Related topics
Exporting shapes and drawings in .jpg or .gif format ............................................ 122
Saving drawings as HTML pages ............................................................................. 120
Saving drawings with hyperlinks as server-side image maps ...................... Visio Help

Exchanging data between Visio and Microsoft PowerPoint

You can include Visio drawings in your Microsoft PowerPoint presentations to
strengthen and clarify your ideas, as well as to take advantage of the PowerPoint
slide features. You use OLE to embed or link Visio shapes and drawings into
PowerPoint slides. You can open Visio from within PowerPoint to create new
drawings, or you can copy and paste or drag and drop existing shapes and
drawings.

You can also include PowerPoint shapes and clip art in your Visio drawings by
importing them as graphic images.

Related topics
Embedding shapes and drawings ............................................................................ 128
Importing non-Visio files as graphic images .......................................................... 103
Linking shapes and drawings ................................................................................... 130
Pasting data in particular formats ........................................................................... 100
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Including Visio drawings in Microsoft Binder reports

You can use Microsoft Office Binder to include a full-page or multiple-page
Visio drawing in a larger report.

For example, a report you’ve composed for a bid on a building project includes
a narrative written in Microsoft Word, a budget calculated in Microsoft Excel,
and an extensive floor plan and project timeline created in Visio. By including
the Word, Excel, and Visio documents in a Binder in the order you want them
to appear in the report, you can save, move, print, and distribute them as a
single file. You can also add consecutive headers and footers to each Binder
page.

By gathering documents into a Binder, rather than dealing with them sepa-
rately, you can

• Add headers, footers, and other elements from within the Binder to ensure a
consistent look across documents (Office 97).

• Paginate the entire Binder at one time.

• Preview the entire Binder before printing it (Office 97).

• Print the entire Binder at one time.

To use the Microsoft Office Binder, you must have Microsoft Office 95 or Office
97. For details about the Binder, see Microsoft Office Binder online help.

To include a Visio drawing in a Binder:

1. In Windows 95 or Windows NT 4.0, from the Start menu, choose Programs,
then choose Microsoft Binder.

2. Drag the Visio drawing you want to include from the Desktop or from Win-
dows Explorer into the left pane of the Binder window.

3. From the Binder File menu, choose Save Binder As to save the Binder file.

TIP  Although you can create a Visio drawing from within the Binder, it’s more
efficient to use the Binder to assemble finished documents.

Related topics
Embedding shapes and drawings ............................................................................ 128
Printing headers, footers, and page numbers .......................................................... 116



13
Using Visio data in other
programs’ documents

About including Visio data in other programs’ documents

You can use any one of the following methods to include Visio data in a docu-
ment created in another program:

• Embedding

• Linking

• Exporting

The method you choose depends upon the capabilities of the other program
and how you want to work with the Visio data once you’ve placed it in the other
document.

NOTE  Every method except exporting uses OLE to integrate data from differ-
ent programs. With OLE, you can open Visio from within the other program to
modify the Visio shapes and drawings.

Related topics
About including other programs’ data in Visio drawings ........................................ 95
Dragging Visio shapes and drawings into other programs .................................... 131
Embedding shapes and drawings ............................................................................ 128
Including Visio drawings in Microsoft Binder reports ........................................... 126
Linking shapes and drawings ................................................................................... 130
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Embedding shapes and drawings

When you embed Visio data, it becomes part of the other program’s file, and
when you edit it, you edit only the version that’s embedded in the other program.

Embedding is useful in cases when you don’t want to keep a separate Visio file
for the data you include in the other document. Or, if you want to transfer the
file to other computers, you can transfer all the data in one file. Embedded ob-
jects, however, increase the file size; if you want to keep the data in a separate
Visio file, you have to update the data in both places.

From within a document in a program that supports OLE, such as a Microsoft
Word document, you can create a new embedded Visio drawing or embed an
existing Visio drawing.

To create a Visio drawing in another document: 

1. In the document, choose Insert > Object (or the appropriate command for
that program).

2. In the dialog box, click the options for creating a new file, then, under Object
Type, choose Visio 5 Drawing, and click OK.

3. In the Visio Choose A Drawing Template dialog box, open the folder that
contains the drawing type you want, select the template for the drawing
type, then click Open.

4. Create the Visio drawing.

5. If Visio is running in its own window, choose File > Exit. If it’s running
within the other document (in place), click somewhere in the document
outside the Visio drawing to close Visio.

6. To edit the Visio drawing from within the document, double-click the
drawing.

TIP  You can also embed an existing Visio drawing from within another docu-
ment. Follow step 1 above, then, in the dialog box, click the option for creating
an object from an existing file.

When you embed Visio data in another
OLE-compatible program, it becomes part
of the other program’s document.
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To embed selected Visio shapes: 

1. In Visio, select the shapes you want to embed.

2. Choose Edit > Copy (or press Ctrl+C).

3. Open the document in which you want to embed the shapes, then choose
Edit > Paste (or the equivalent command).

To embed an entire Visio drawing: 

1. In Visio, make sure nothing is selected.

2. Choose Edit > Copy Drawing.

This command copies the entire drawing, including shapes on other draw-
ing pages and on backgrounds.

3. Open the document in which you want to embed the drawing, then choose
Edit > Paste (or the equivalent command).

When you embed a multiple-page Visio drawing, only the page displayed at
the time you choose Copy Drawing appears in the container document.

Editing an embedded Visio object in place

In many OLE 2-compatible programs, you can edit an embedded Visio object
without leaving the program (or “container application”)—this is called “in-
place editing.” A special set of Visio menus and toolbars temporarily replaces
most of the menus and controls in the active window while you edit the Visio
object.

To edit an embedded Visio object in place:

1. In the container application, double-click the embedded Visio object.

A special set of Visio menus and controls appears.

2. Edit the Visio drawing.

3. Click anywhere outside the drawing window to exit the in-place editing
controls.

Related topics
Dragging Visio shapes and drawings into other programs .................................... 131
Linking shapes and drawings ................................................................................... 130
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Linking shapes and drawings

The way you link shapes and drawings is similar to the way you embed them.
However, when you link a Visio shape or drawing to another document, the
other document contains only a reference to the Visio drawing file, rather than
the actual drawing. You link data in a saved Visio file so the other program can
find the data and display it.

Linking works well when you want to include the same Visio data in more than
one document. When you update the data, you only need to update it in one lo-
cation. The versions that are linked to other documents reflect the changes
automatically.

Linking a Visio file to another document does not increase the file size the way
embedding a Visio object does. However, links require a little more mainte-
nance. If you want to transport the data, you must make sure to transfer all
linked files to the other computer.

When you make changes to a drawing that’s linked to another document, the changes
appear in the other document simultaneously.
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To link a Visio file to another document: 

1. Open the drawing you want to link. If it’s a multiple-page drawing, display
the page you want to appear in the other document.

NOTE  Because a link is a reference to a file, you can only link files that are
saved to a location on a disk. If you haven’t saved the drawing you want to
link, choose File > Save.

2. Make sure nothing on the drawing is selected, then choose Edit > Copy
Drawing.

3. Without closing Visio, open the document in the other program in which
you want to include the Visio drawing.

4. Choose that program’s command for linking objects.

In Microsoft Office programs, choose Edit > Paste Special.

5. In the dialog box, make sure Visio 5 Drawing Object is selected, select Paste
Link, then click OK.

The drawing you copied appears in the document, with a link to the original
Visio file.

Related topics
About including Visio data in other programs’ documents ................................... 127
Controlling the border around embedded or linked Visio objects ............. Visio Help
Dragging Visio shapes and drawings into other programs .................................... 131
Embedding shapes and drawings ............................................................................ 128
Saving drawing files .................................................................................................... 13

Dragging Visio shapes and drawings into other programs

If the other program in which you want to include Visio data is compatible with
OLE 2, an alternative to using menu commands to paste Visio shapes is to drag
shapes from a Visio drawing or stencil into the other document. Dragging and
dropping shapes does not use the Windows Clipboard, so data on the Clip-
board is not affected.

You can drag shapes from the drawing page or masters from stencils. When you
drop a master, an instance of the master appears in the document and the mas-
ter is not removed from the stencil. If you drag multiple shapes from a drawing
page, they are treated as one object in the other document.
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Pointer tool changes
When you drag shapes between programs, the pointer tool changes in response
to the action you take.

How the pointer tool changes

Pointer appearance Action

Press Ctrl and then drag to move the selected shapes to
the other document.

Press Ctrl+Shift and then drag to copy the selected
shapes to the other document.

Cannot drop shapes in that document.

TIP  Before you drag shapes, position the Visio window and the other program’s
window so you can see the shapes and the document in which you want to drop
them.

To position program windows quickly: 

1. Open Visio with the drawing or stencil that contains the shapes you want to
drag into another document, then, without minimizing the Visio window,
open the other program.

2. Right-click the Windows taskbar and choose Tile Vertically.

To drag and embed shapes into another document: 

• Select the shapes, then press Ctrl and drag the shapes into the document.

Dragging the shapes from the drawing page copies them into the other
document. To move the shapes (so they no longer appear on the drawing
page), don’t press Ctrl as you drag.

To drag and link shapes to another document:

• Select the shapes and, when you select the last shape, hold the mouse pointer
down. Then press Ctrl+Shift and drag the shapes into the document.

NOTE  If you press Ctrl+Shift before pressing the mouse button to drag the
shapes, the pointer becomes a magnifying glass for zooming in on the draw-
ing, and you will not be able to drag the shapes.

Related topics
About including Visio data in other programs’ documents ................................... 127
Embedding shapes and drawings ............................................................................ 128
Linking shapes and drawings ................................................................................... 130
Selecting shapes .......................................................................................................... 35
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Exporting shapes and drawings

When you export Visio data, it is directed through a filter that converts the Visio
data to an independent non-Visio file. You then open that file or import it as a
picture in the other program. Exporting works best when you want to include
Visio data in a document that is not compatible with OLE, or if you want to in-
clude a Visio drawing in an HTML document you want to post on the Web.

After you export a Visio drawing to another format and insert it in another
document, it’s considered a static picture. That means you will not be able to
open Visio to edit it from within the other program. In addition, because your
Visio file can go through up to two translations before it appears in the other
program—one when you export from Visio, and one if you import into the
other program—the graphic image may not look exactly the way it does in the
Visio drawing.

For example,

• By exporting a Visio drawing in .ai format, you can open it in Adobe Illustra-
tor and edit it using that program’s tools.

• By exporting a Visio shape as a Windows bitmap, you can open the bitmap
in any program that supports .bmp format.

• By exporting a Visio drawing in a format another program can open, you
can include Visio data as a graphic image in the other program’s documents.

Exporting translates a file to a non-Visio format that the other program can import.

TIP  If the other program in which you want to include Visio data supports
OLE, it’s best to link or embed the Visio data rather than export it. OLE pro-
duces more consistent results and allows you to edit the data after you include it
in the other program.
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To export shapes or drawings to another file format: 

1. To export all the shapes on a page, display the page you want to export.

To export specific shapes, select the shapes you want to export. (Use
Shift+click to select more than one shape.)

2. Choose File > Save As, then

For Save As Type, choose the format you want.

For File Name, type a name for the file.

3. Click Save.

Visio exports the shapes or page in the format you choose. You can use the
file in any program that can read files in that format.

4. If necessary, in the Filter Setup dialog box, choose the export settings you
want, then click OK.

Related topics
About converting shapes and drawings to HTML ................................................. 119
Exporting shapes and drawings in .jpg or .gif format ............................................ 122

Sending drawings through electronic mail

You can send a Visio drawing to another user via e-mail. Visio products are
compatible with electronic mail programs that support the Messaging Applica-
tion Program Interface (MAPI) protocol.

Visio also takes advantage of Microsoft Office 97 routing features, including
sending drawings to Microsoft Exchange folders, adding routing slips to draw-
ings you send through e-mail, and adding journal entries to Outlook.

To include a drawing file in an e-mail message: 

1. While the drawing file is open, choose File > Send To > Mail Recipient.

If your mail program hasn’t been running, it starts; then a new e-mail
message containing the Visio icon and the file name appears.

2. Address the message, type any accompanying data, and send the e-mail
message as you would any other message.

To view a Visio file sent by e-mail: 

• Open the e-mail message, then double-click the Visio icon.

NOTE  Visio must be installed to open drawings you receive in e-mail.
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Microsoft Office 97 document-routing support
If you use Office 97, you can send a drawing with a routing slip or send a draw-
ing directly to a folder in Microsoft Exchange.

B

A

C

D

A Click Address to add recipients to the To list.
B Type your message here.
C Select whether to route the drawing to one person at a time or to everyone at once.
D Click to add the routing slip to the drawing. After you add the slip you can route the drawing.

To send a drawing with a routing slip:

1. Display the drawing you want to send, then choose File > Send To > Routing
Recipient.

2. Click Address to open your post office address list and select the individuals
or groups to whom you want to route the drawing. When you’ve finished
adding to the recipient list, click OK.

3. If you need to route the drawing to people in a specific order, select a
person’s name, then click the up or down arrow in the Move section to
change that person’s position on the list.

4. Under Route To Recipients, select whether to route the drawing to one per-
son at a time or to everyone at once.

If you choose to route the drawing to one person at a time, the first person
on the list views or updates the drawing, then routes the drawing to the next
person, and so on.

If you route a drawing to a group alias, everyone in the group will receive the
drawing at the same time. To send the drawing to one group member at a
time, list each of their names rather than the group alias.
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5. Check Track Status or Return When Done to receive an update as each per-
son on the list passes the drawing to the next person or to have the drawing
sent back to you after everyone has seen it.

6. Under Message Text, type the text you want in the email message. When
you’re finished, click Add Slip.

7. Choose File > Send To > Next Routing Recipient to send the drawing to the
first person on the routing list.

NOTE  You can choose to send the drawing (step 7) later. If you try to close
the file before sending the drawing, Visio displays a message reminding you
that it contains a routing slip. You can then choose to route the drawing,
send it without the routing slip (you won’t be able to track its status and it
won’t automatically be returned to you), or not to send it at all.

TIP  If you receive a routed drawing and want to route it to the next person,
choose File > Next Routing Recipient. If you want to route the drawing to
someone who isn’t on the list, choose File > Other Routing Recipient, and then
follow steps 2–7 above.

For details about routing files, see your Microsoft Office 97 documentation.

To send a drawing directly to a Microsoft Exchange folder: 

1. Display the drawing you want to send, then choose File > Send To >
Exchange Folder.

2. Select the folder in which you want to place the drawing, then click OK.

Visio saves the drawing in the Microsoft Exchange folder as an embedded
object, so you can open the drawing in Visio from within Microsoft
Exchange.

Related topics
Embedding shapes and drawings ............................................................................ 128
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Saving time with
styles and templates

About working with styles and templates

You can use styles and templates in Visio to create drawings that can be quickly
and efficiently revised.

Using styles
A “style” is a named collection of formatting attributes—for example, blue fill
and magenta bold text—that you can apply to your shapes to give them a con-
sistent look and make them easier to revise. By editing the style, you can
simultaneously change the look of all shapes formatted with that style.

A style can contain line, fill, and text formatting attributes—a single attribute or
any combination of the three. Visio templates come with styles built in, but you
can also define your own.

1

2

1 32

3

Creating templates
When you know that you’ll be creating multiple drawing files that need a con-
sistent look, consider creating a template on which to base all the drawings.
Creating your own template eliminates the need to open the appropriate sten-
cils, create styles, and establish page settings for each drawing file, because they
are all contained in one place.

Also, you can increase your efficiency by creating your own templates when

• Your drawings require customized settings for page size or scale, window
size and position, shape or text styles, color palette, snap and glue, or print-
ing, create a template with the appropriate settings in place.

• Your drawings often use a standard background or set of layers—for ex-
ample, you place your company logo in every drawing—create a template
with the background or layers in place.

Related topics
Applying styles .......................................................................................................... 138
Basing new drawings on templates .............................................................................. 9

Select three shapes and apply one style to
make them look the same.
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Applying styles

Some styles include formatting for all three attributes (line, fill, and text); others
are specific to one attribute. For example, one style may contain text format-
ting, such as the font, size, and color, as well as fill color and pattern, and line
color and pattern. Another style may contain only text formatting.

When you apply formatting to a shape by choosing the style from one of the style lists (for
example, the Text style list) on the toolbars, if the style also includes line or fill formatting,
Visio asks if you want to apply all of the style’s formatting, rather than just the text formatting.
Click Yes to apply all formatting to the shape. Click No to apply formatting for the single
attribute you initially chose from the list.

To apply a style: 

1. Select one or more shapes you want to format.

2. From the Line or Fill style lists on the Shape toolbar, or from the Text style
list on the Text toolbar, choose the style you want to apply.

TIP  You can apply styles to a shape by choosing Format > Style, then selecting
the style you want from the lists. All the styles available in a drawing, both those
pre-defined in a template and those you define yourself, are listed in the Style
dialog box.

Related topics
Changing default styles for drawing and text tools ..................................... Visio Help
Defining and editing styles ....................................................................................... 138
Preserving individual shape formatting .................................................................. 141

Defining and editing styles

In the Define Styles dialog box, you can edit and rename existing styles, define
your own styles from scratch, and delete styles you no longer need.

When you define or edit styles in a drawing file, the changes you make are avail-
able only in the current drawing. To make a style available across many future
drawings, you can define or edit it in an existing template, or save the drawing
file in which you created the style as a new template. The style will be included
in every new drawing you create using that template.
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When you edit or define a style, the colors you can choose are determined by
the color palette in the template on which you base your drawing. All Visio tem-
plates use a default color palette. You can change the color palette a drawing
uses, or modify the colors within the default color palette.

A

B

C

D

E

F

G

A Type a name for a new style or choose the
name of the style you want to edit.

B Choose an existing style you want to base
a new style on. Editing the base style
changes the new style as well.

C Check the characteristics (text, line, fill)
that your style includes, so that the style
name will be displayed in the correspond-
ing toolbar list.

D Click Text, Line, or Fill button to define
those characteristics.

E Check to preserve selected shapes’ spe-
cial formatting—italic text, for example—
even after you apply the style.

F Click to add a new style or change an ex-
isting one, then start creating or changing
another style.

G If shapes were selected when you chose
Define Styles, this button is labeled Apply.
If no shapes were selected, it is labeled
OK. Click to create and apply a new style
and close the dialog box.

To define a new style: 

1. Choose Format > Define Styles.

2. Type a name for the new style.

3. If you want to base the new style on an existing style, choose that style under
Based On.

4. Under Includes, check the attributes that your style includes. A style can in-
clude formatting from any combination of the three attributes.

5. Under Change, click Text, Line, or Fill to change the settings for that attribute.
Choose the settings you want for each attribute you included in step 4.

6. When the style contains the settings you want, do one of the following:

Click Apply to add the new style, apply it to selected shapes, and close the
dialog box.

Click OK when no shapes are selected to add the new style and close the
dialog box.

Click Add to add the new style and continue working in the dialog box.

To edit a style: 

1. Choose Format > Define Styles.

2. In the Style list, select the style you want to edit.

3. To rename the style, click Rename, type a new name for the style, then
click OK.

4. To change the style settings, under Change, click the attributes you want to
edit. When you finish editing the attributes, do one of the following:

Click OK (when no shapes are selected) or Apply (when shapes are selected)
to add the changes to the style and close the dialog box.

Click Change to add the changes and continue working in the dialog box.
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To delete a style: 

1. Choose Format > Define Styles.

2. Choose the name of the style you want to delete.

3. Click Delete, then click OK.

Related topics
Applying styles .......................................................................................................... 138
Copying styles from one drawing to another ......................................................... 140
Changing default styles for drawing and text tools ..................................... Visio Help
Creating new templates ............................................................................................ 142
Using custom colors and color palettes ........................................................ Visio Help

Copying styles from one drawing to another

If you want to transfer a style you created in one drawing to another drawing,
you can copy and paste a shape to which the style is applied from the first draw-
ing into the second.

NOTE  If a style with the same name already exists in the second drawing, the style
of the shape you copy does not replace the original style. Instead, it inherits the
formatting of the style as it is defined in the second drawing. In this situation,
if you want to copy the style, rename the style in either of the drawings before
you begin.

To copy a style from one drawing to another: 

1. Select a shape in the first drawing, and apply to it the style or styles you want
to copy to the new drawing.

2. Choose Edit > Copy (or press Ctrl+C).

3. Open the new drawing.

4. Choose Edit > Paste (or press Ctrl+V).

The shape is copied to the new drawing, along with the styles you assigned
to it in the original drawing.

Related topics
Applying styles .......................................................................................................... 138
Defining and editing styles ....................................................................................... 138
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Preserving individual shape formatting

You can apply special, or local, formatting to an individual shape even when the
shape has a formatting style assigned. For example, if a computer in a network
diagram has the Net-Normal style assigned, you can change the computer
shape’s text from normal to italic. If a Process shape in a flowchart has the
Flow-Normal style assigned, you can change the fill color of the shape from
white to blue.

If you apply a new style to a shape for which you’ve defined local formatting or
edit the style already assigned to the shape, the style’s attributes will replace any
local formatting you’ve applied.

To prevent a style from overriding a shape’s local formatting, you can choose to
assign all of the style’s attributes except those you assigned locally. Or you can
preserve a shape’s local formatting when you create or apply a style in the De-
fine Styles and Style dialog boxes.

If you experiment with local formatting and then decide you preferred the for-
matting the shape originally displayed, you can revert to the styles associated
with the shape’s master.

To preserve local formatting when applying a style: 

1. Select the shape, then choose Format > Style.

2. From the Text, Line, and Fill style lists, choose the styles you want to apply.

3. Check Preserve Local Formatting.

4. Click OK.

TIP  In the Define Styles dialog box, the setting is called Choose Preserve Local
Formatting on Apply.

To revert to a master’s style: 

1. Select the shape, then choose Format > Style.

2. Choose Use Master’s Format from the Text, Line, or Fill style lists.

The Use Master’s Format item appears at the top of each style list; you may
need to scroll up to see it.

3. Click OK.

Related topics
About formatting shapes ............................................................................................ 49
Applying styles .......................................................................................................... 138
Defining and editing styles ....................................................................................... 138



1 4 2 C H A P T E R  1 4

Creating new templates

You can create your own template to set up the most common stencils, styles,
and page settings you use. Then you can base new drawings on this template
and distribute the template to other Visio users in your organization.

The easiest way to create a template is to set up a drawing file the way you want,
open the stencils you want, and then save the settings as a template (.vst) file. If
you simply want to change some of the settings of an existing Visio template,
you can base a drawing on that template, save it with a new name, and make
your changes.

TIP  If you want to preserve an original drawing file but also base a new tem-
plate on it, you can open a copy of the drawing file. Choose File > Open. In the
Open dialog box, select the drawing you want, then under Open, click Copy.

To create a template from a drawing file or an existing template: 

1. Open the drawing or start a new drawing based on the template you want to
modify.

2. Open any additional stencils you want to save with the template.

3. Modify drawing page settings and styles you want to use in future drawings
you base on this template.

For example, if you want to have a background page that displays your com-
pany logo, or a title block that contains fields such as the date a drawing is
created and so on, create it and assign it to the foreground page.

4. Choose File > Save As, then do the following:

For Save As Type, select Template (*.vst).

For File Name, type a name for your template.

For Save, make sure Workspace is checked.

For Save in, select the folder in which you want to save the template.

TIP  If you want the template to display when you choose New from the File
menu, save it in the Solutions folder or one of its subfolders.

5. Click Save.

Related topics
Creating master shapes ............................................................................................. 222
Defining and editing styles ....................................................................................... 138
Displaying, moving, and adding stencils ..................................................................... 8
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Organizing shapes
with layers

About layers

You can use Visio layers to organize related shapes on a drawing page. A layer, in
Visio, is a named category of shapes. Using layers, you can

• Show, hide, or lock shapes and guides on specific layers so you can edit cer-
tain layers without viewing or affecting others.

• Select and print shapes based on their layer assignments.

• Temporarily change the display color of all shapes on a layer to make them
easier to identify.

• Assign a shape to more than one layer, as well as assign the member shapes
of a group to different layers.

• Control whether shapes on a layer can be snapped to or glued to.

• Create reports based on data stored in shapes assigned to a particular layer.

For example, if you’re drawing an office layout, you can assign walls, doors, and
windows to one layer, electrical outlets to another layer, and furniture to a third
layer. That way, when you plan the electrical system, you don’t have to worry
about accidentally rearranging the walls.

After locking the wall and electrical outlet layers, you can distribute the office
layout to co-workers, who can arrange the furniture in their offices without dis-
turbing the underlying office layout.

Some shapes, such as those in the Office Layout Template, are already assigned
to pre-existing layers. If you want to use layers with shapes from other stencils,
you need to create the layers and assign the shapes to them.
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A shape can be assigned to multiple layers or no layers, and every page in a
drawing can have a different set of layers.
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Shapes can belong to more than one layer. Here, the lake and compass shapes belong to the
Streets layer (A), the Landmarks layer (B), and the Routes layer (C).

NOTE  Visio layers do not determine how shapes appear on the page. The way
shapes overlap is determined by their stacking order and whether or not there
are backgrounds assigned to the page.

Related topics
Creating, removing, and renaming layers ............................................................... 145
Creating reports from custom data ......................................................................... 180
Formatting multiple shapes ....................................................................................... 52
Using backgrounds for common page elements ....................................................... 26

Using layers on backgrounds

A background is a page that appears behind another page. It can have its own
set of layers. Because a background can be shared by more than one page, but
layers cannot, you may want to use layers on background pages. For example:

• In a drawing where the same map is used on multiple pages, you can put the
map on the background and assign its parts to different layers, such as the
Road layer or River layer. If you want to hide the roads on all the pages, you
can then hide the background’s Road layer.

• In a drawing with a title block on the background, you can assign it to a Re-
vision History layer and then hide that layer if you don’t want to print it.

• If the background includes information you don’t want modified, such as
your company logo and name, but you need to give the file to your client
modifications, you can assign those shapes to a Corporate layer, lock it, then
pass the file on to your client.



O R G A N I Z I N G  S H A P E S  W I T H  L A Y E R S 1 4 5

A B C

N

Nost rud

Delen i t

1 1 th Zzri l

H
arrison

21
st P

raesent

Susc ip i t

23
rd P

raesent

22
nd P

raesent

1 2 th Zzri l

1 7 th Zzri l

L a g u s
C a n i u n a

FD

Alquin

Erat VolupatN

Nos t rud

Delen i t

1 1 th Zzri l

H
arrison

21
st P

raesent

Susc ip i t

23
rd P

raesent

22
nd P

raesent

1 2 th Zzri l

1 7 th Zzri l

N

Nos t rud

Delen i t

1 1 th Zzri l

H
arrison

21
st P

raesent

Susc ip i t

23
rd P

raesent

22
nd P

raesent

1 2 th Zzri l

1 7 th Zzri l

Background page elements (A) appear on the foreground pages to which they are assigned
(B and C). When you open a Visio file, the drawing page on the screen is a foreground page.
If you want to use backgrounds, you need to create them.

Related topics
Using backgrounds for common page elements ....................................................... 26

Creating, removing, and renaming layers

Many Visio masters are already assigned to layers so, when you drop them on
the page, the layer is added as well. You can create new layers to organize custom
categories of shapes, then assign your shapes to those layers, as well as to the
layers that Visio provides. For example, when you open the Office Layout
Template, the masters are already assigned to the layers. As you drop instances
of the masters, the layout layers are set up for you.

Creating layers
When you create a new layer, Visio adds it only to the current page, not to all
pages in the file. Similarly, when you create a new page, you must define its lay-
ers; the new page does not inherit layers from the previous page. However,
when you copy a shape with a layer assignment from one page to another,
whether in the same drawing or between drawings, Visio adds the layer to the
new page. If the page already has a layer with the same name, the shape is added
to the existing layer.

To create a layer:

1. Choose View > Layer Properties.

2. Click New.

3. In the New Layer dialog box, type a name for the layer, then click OK.

4. In the Layer Properties dialog box, click to place a checkmark below proper-
ties you want the layer to have, then click OK.
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Removing and renaming layers
When you no longer need a layer, you can remove it. If you remove a layer, all
shapes assigned only to that layer are removed as well. If you don’t want to re-
move the shapes along with the layer, change or remove each shape’s layer
assignment before you remove the layer.

When you rename a layer, only the layer’s name is changed—the shapes on the
layer are not removed or changed.

TIP  To see how many shapes are assigned to a layer, choose View > Layer Prop-
erties, then click the number button ( ) in the Layer Properties dialog box.

To remove a layer:

1. Choose View > Layer Properties.

2. Select the layer you want to delete, then click Remove.

3. Click OK.

TIP  To delete all unused layers, check Remove Unreferenced Layers.

To rename a layer:

1. Choose View > Layer Properties.

2. Select the layer you want to rename, then click Rename.

3. For Layer Name, type a new name, then click OK.

4. Click OK.

Related topics
Assigning shapes to layers ........................................................................................ 147
Making a layer active ................................................................................................ 148
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Assigning shapes to layers

You can assign shapes to one or more layers by selecting the shapes, then choos-
ing which layer you want to assign them to. For example, you can add walls and
furniture, then assign them to corresponding layers.

When you drop an instance of a master that is pre-assigned to a layer, the in-
stance inherits the master’s layer assignments. If a layer of that name does not
already exist on the drawing page, dropping the instance adds the layer. If you
have designated an active layer for the page, that instance is assigned only to the
layer it inherited from its master shape, although you can later assign it to the
active layer or to another layer.

TIP  You can check Preserve Group Member Layers to specify that individual
shapes in a group retain their current layer assignments. For example, you
might assign a desk to the furniture layer and a computer to the electronics
layer, then group them. If you then assign the group to the den layer, the desk
and computer retain their previous layer assignments as well. When this option
is unchecked, when you assign a group to a layer, all of the group members be-
come members of the new layer. Their previous layer assignments are canceled.

A

B

A Assigns the selected shape to one or more layers. You can assign a shape to multiple layers.
B Opens the New Layer box, in which you can type a name to create a new layer.

To assign a shape to a layer: 

1. Select the shape.

If the shape is part of a group, click to select the group (indicated by green
selection handles), then click to subselect the shape in the group (indicated
by gray selection handles).

2. Choose View > Shape Layer.

3. Choose the layer to which you want to assign the shape, then click OK.

TIP  To assign a shape to more than one layer, press Ctrl to choose multiple layers.
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To assign a group to a layer: 

1. Select the group.

2. Choose View > Shape Layer.

3. Click the layer to which you want to assign the group, check Preserve Group
Member Layers, then click OK.

Related topics
Modifying layer assignments for masters ..................................................... Visio Help

Making a layer active

When you create a shape that doesn’t already have a pre-defined layer assign-
ment, it is automatically assigned to the active layer. You can change the active
layer as you work to make sure that new shapes are added to the appropriate
layer. For example, if you are going to add electrical wiring shapes to a drawing
of an office layout, you can make the electrical layer active. All the shapes you
add from then on are assigned to the electrical layer. When you begin to add
windows, you can designate the wall layer as the active layer.

In a drawing with many shapes and layers, you may find it more efficient to des-
ignate one or more active layers, so that all shapes you subsequently draw or
drop are automatically assigned to those layers.

To designate a layer as active: 

1. Choose View > Layer Properties.

2. Click in the Active column to add a check for each layer you want to make
active.

3. Click OK.

TIP  If a layer is locked against editing, you cannot make it the active layer.

Related topics
Assigning shapes to layers ........................................................................................ 147
Controlling shape behavior using layers ................................................................. 149
Creating, removing, and renaming layers ............................................................... 145
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Controlling shape behavior using layers

After you’ve assigned shapes to a layer, you can control the behavior and ap-
pearance of the shapes as a group. You can

• Select all shapes on a layer.

• Show or hide the shapes on a layer. For example, in a garden diagram, you
can view the layers that contain the flowerbed and the spring-blooming
plants, and hide the layers that contain summer- and fall-blooming plants,
to see what will be blooming in the spring.

• Lock shapes on a layer, so that you cannot select, move, or edit the shapes on
the locked layer. To identify these shapes, you can also temporarily change
their color by setting color property for the locked layer. You cannot add
shapes to a locked layer.

• Specify whether other shapes can snap or glue to the shapes assigned to a
layer. If a shape is on a layer that has Snap or Glue unchecked, you can still
snap or glue it to other shapes, but you can’t snap or glue other shapes to it.

• Use color to highlight shapes on a layer. For example, in an office layout you
can create a layer for each department, then assign each layer a unique color
so that, at a glance, you can see which department owns different equip-
ment.

• Print only the shapes assigned to particular layers.

TIP  The color you assign to shapes on a layer temporarily overrides each shape’s
original color. If you turn off the layer color, each shape returns to its original
color. If you have assigned a shape to more than one layer, the shape will not use
a layer color, but instead will appear in its original color. Layer colors are tem-
porary and intended for display only, but they can affect printed output.

To select all the shapes on a layer: 

1. Choose Edit > Select Special.

2. For Selection By, click Layer, then choose the layer with the shapes you want
to select. Or, choose No Layer to select shapes that are not assigned to any
layer. To choose multiple layers, press Ctrl, then click the layers you want.

3. Click OK.
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To control shapes on layers: 

1. Choose View > Layer Properties.

2. Check the options you want. Uncheck an option to deactivate it for
that layer.

3. Click OK.

A B C D E F G H I

J

K

A Specifies the name of the layers in the diagram. Clicking this button opens the Rename
Layer dialog box, in which you can change the name of the selected layer.

B Displays the number of shapes assigned to each layer.
C Specifies whether the shapes on a layer are visible or hidden. Check to show the layer and

uncheck to hide the layer.
D Specifies whether to print the shapes on a layer. Check to have the layer print; uncheck this

option so that the layer does not print.
E Specifies the active layer to which shapes without a pre-assigned layer are automatically

assigned. Check to make the layer active or uncheck to deactivate the layer. The active
layer cannot be locked.

F Prevents shapes on a layer from being selected or altered. Check to lock the layer or
uncheck to unlock the layer. If a layer is locked, it cannot be the active layer.

G Specifies whether other shapes can snap to shapes assigned to the layer. A shape on a
layer that has Snap unchecked can still snap to other shapes, but other shapes cannot snap
to it.

H Specifies whether other shapes can glue to shapes assigned to the layer. A shape on a
layer that has Glue unchecked can still glue to other shapes, but other shapes cannot glue
to it.

I Specifies that all shapes assigned to the layer appear in the specified color; this option does
not permanently change the shape colors. Check to override each shape’s original color in
favor of the layer color. Uncheck to return shapes to their original colors.

J Applies the current settings to the drawing page without closing the dialog box.
K Adds color to a layer so that all objects assigned to the selected layer appear in the layer

color.

Related topics
About customizing shape behavior .............................................................. Visio Help
Controlling how shapes display onscreen .................................................... Visio Help
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Laying out shapes
automatically

About automatic layout

With certain types of connected drawings, such as flowcharts and network dia-
grams, you can use the Lay Out Shapes command to have Visio position, then
reposition, shapes. Having Visio reposition shapes can help you revise large
drawings more quickly than using the pointer tool to select and drag each one
to the new location. For example, if you’re updating a large flowchart to include
a new process, you can add and connect the shapes that make up the process,
then use the Lay Out Shapes command to have Visio lay out the updated draw-
ing for you.

Preparing for automatic layout
For best results with automatic layout, use the following guidelines when you
create connected drawings:

• Connect shapes using connectors that Visio can route.

Most connectors are routable. A routable connector can detect certain 2-D
shapes that lie in its path from one shape to another, and change its route to
avoid crossing through them. Some connectors that are designed for a spe-
cific purpose, such as the tree and crow’s-foot connectors, or control-handle
connectors that you can drag out directly from other shapes, are not
routable.

• Set all 2-D shapes so that connectors can detect them.

Routable connectors can detect and route around only the shapes set as
“placeable.” To quickly set all 2-D shapes as placeable, select them all
(shift+click to select multiple shapes), then choose Format > Behavior and,
for Layout Behavior, select Layout And Route Around.
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• Orient connectors so that begin and end points direct the flow of your
drawing.

Visio determines where to position shapes based on begin and end point lo-
cations. A connector may have an arrow on one or both ends but the
direction the arrow points doesn’t necessarily indicate the begin and end
point locations.

• Ensure that begin and end points of connectors are properly glued to other
shapes. When you select a glued connector its begin and end points turn red.

Lay Out Shapes works best with the flowchart, network diagramming, organi-
zation chart, or other typical connected-drawing types. If you try to use
automatic layout with a drawing that you did not create with these shapes, an
alert appears to let you know that the results may not look as you expect. You
can choose to continue or cancel the layout process. If you continue and are not
satisfied with the results, you can use the Undo command to undo it (choose
Edit > Undo Lay Out Shapes).

Related topics
About creating and revising connected drawings ..................................................... 65

Customizing shape spacing and connector routing settings .................................. 154

Setting layout style, depth, and routing ................................................................... 152

Working with routable connectors and placeable shapes ........................................ 74

Setting layout style, depth, and routing

When you have Visio lay out a drawing, you can specify the style of layout you
want, as well as the layout depth and the connector routing style.

Layout style
You can choose one of three styles: Top To Bottom, Left To Right, and Radial.
Choose Top To Bottom or Left To Right for directed drawings, such as organi-
zation charts and process flow diagrams. Choose Radial for undirected
drawings such as some types of network diagrams.

Depth
The Depth setting determines the number of levels of the drawing Visio looks
at before creating the layout. When choosing depth settings, Shallow means a
shallow layout. That is, in a top-to-bottom organization chart, a shallow layout
requires more horizontal space than a deep layout.

In this diagram, the begin point
is connected to the top shape,
and the end point is connected
to the bottom shape. If the
points are reversed in this
example, Visio will lay out the
shapes in the opposite order.
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In addition, depth settings refer to the type of layout you want. If you set the
depth to Shallow, Visio checks more levels of the drawing than it does if you set
the depth to Deep. The more levels Visio checks, the better it can determine, in
a top-to-bottom chart, how much space to leave between top-level shapes so
that shapes in lower levels can fit on the same horizontal line. In this case
“shallow” refers to the layout, because it requires more horizontal and less ver-
tical space than it would if you had set the depth to Deep.

Whatever the Depth setting, the number of levels Visio looks at depends upon
the style and complexity of the drawing you’re working on. You may want to try
different depth settings on the same drawing to find the one that produces the
result that works best for your drawing.

Routing style
The routing style determines the path automatic layout takes to connect 2-D
shapes. You can choose one of two routing styles: Flowchart and Right Angle.
The Flowchart routing style uses both straight and right-angle connectors; the
Right Angle routing style uses only right-angle connectors.

A

B

C

A Choose the layout style.
B Choose the depth.
C Choose the connector routing style.

To lay out shapes and change layout style, depth, and connector-
routing style:

1. Display or create the drawing you want to lay out.

2. Choose Tools > Lay Out Shapes.

3. Select the layout style, the depth, and the routing style you want, then
click OK.

Related topics
Customizing shape spacing and connector routing settings .................................. 154
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Customizing shape spacing and connector routing settings

When you use automatic layout, you can fine-tune the way Visio places shapes
(or “nodes”) and connectors (or “lines”). You can

• Change shapes’ placement settings to affect the way Visio routes connectors
between shapes.

• Change the minimum amount of space you want between shapes and con-
nectors, and between connectors’ parallel segments.

The settings on the Advanced tab of the Lay Out Shapes dialog box are based on
the layout grid. You turn on the grid by checking the Enable Grid box on the
General tab. The layout grid is set up with blocks and avenues, like a city map.
On the Advanced tab, you can set the Block Size to the size of the shapes in your
drawing, and the Avenue size to the amount of space you want between them.

Note that the grid you create here serves as an internal guide only—it does not
correspond to the drawing page grid, and does not appear on the drawing page
when you enable it.

Avoid using the grid if your drawing contains shapes of various sizes, particu-
larly shapes that exceed the size of the grid blocks. Visio can position these
shapes more precisely when they do not need to fit within a fixed grid block.

To customize routing and grid options:

1. Choose Tools > Lay Out Shapes to open the dialog box.

2. Click General to display the General tab, then check Enable Grid.

3. Click Advanced, and on the Advanced tab:

Under Line To Line Spacing, set the minimum amount of space you want
between connectors’ parallel segments.

Under Line To Node Spacing, set the minimum amount of space you want
between connectors and shapes.

Under Block Size, type values that match the size of the shapes in your draw-
ing.

Under Avenue size, type the minimum amount of space you want between
the shapes (this should be at least twice the values of the Line To Node set-
tings).

4. When you’ve finished fine-tuning the settings on the Advanced tab, click OK
to close the dialog box and create the automatic layout, or click Apply to cre-
ate the automatic layout without closing the dialog box.

TIP  If you are not satisfied with the layout, choose Edit > Undo Lay Out
Shapes (or press Ctrl+Z).

Related topics
Working with routable connectors and placeable shapes ........................................ 74

When you enable the grid, shapes are
placed within the blocks (AAAAA) and connectors
are routed through avenues (BBBBB).

To make connections easier to see in a large
drawing, you can increase the amount of
spacing between connectors or between
shapes and connectors.

A Line to node spacing
B Line to line spacing

A B

A{

B {
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Positioning shapes
with precision

About positioning shapes precisely

When precision counts, you can use the Visio rulers, guides, grid, and alignment
and positioning tools to draw and place shapes accurately. By default, shapes
snap, or pull, to ruler subdivisions, guides, guide points, grid lines, and other
shapes, so lining them up is quick and easy. Which element you snap shapes to
depends on what you want to do. For example, to position shapes at regular in-
tervals, you can snap them to the grid. To align shapes, snap them to a guide.

Methods for snapping shapes into position

Position for shape Snap to

Align several shapes Guides

Align shapes by their corners Guide points

Position shapes equidistant from Grid, ruler subdivisions, or guides
one another

Position 1-D shapes against 2-D shapes Shape geometry, handles, vertices, or
connection points

Position 2-D shapes against one another Shape’s alignment box

100 90 80 70 60

To place a shape more accurately, pause while dragging its line or outline (shown on the
left), without releasing the mouse button. The line or outline changes to the shape itself
(shown on the right).
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Other ways you can position shapes include the following:

• The Align Shapes command aligns several shapes to one shape.

• The Size & Position command positions shapes using numerical x, y coordi-
nates.

• The position information that appears on the status bar when you select a
shape. This information changes as you drag the shape.

Related topics
About automatic layout ............................................................................................ 151
Snapping shapes for automatic alignment .............................................................. 156
Specifying exact size and position for shapes and guides ...................................... 162
Using guides to reposition multiple shapes ............................................................ 162
Using shape handles ................................................................................................... 32

Snapping shapes for automatic alignment

You can rely on snap behavior to position and align shapes exactly. Snapping
pulls shapes to one another or to ruler subdivisions, grid lines, guides, or guide
points so you can control placement and alignment. You can control what types
of objects shapes snap to and the snap strength, which is the amount of pull
that an object exerts.

By default, shapes snap to both ruler subdivisions and grid lines. To snap shapes more easily
to ruler subdivisions, turn snapping to grid lines off.

TIP  You may not always want to snap shapes. For example, by turning off snap-
ping, you may find it easier to draw a smooth freeform curve.

Setting snap options
The snap settings you choose apply to all shapes in the current drawing. When
you set snap options, set only the options you need. For example, if you want to
snap to guides, you do not need to set the Grid option.

When you drag shapes, guides, or guide
points on the drawing page, precise
coordinates for the object’s position appear
in the status bar at the bottom of the Visio
window. On the rulers, faint lines appear and
track the shape as you move it to help you
position the shape precisely.
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To set how shapes snap:

1. Choose Tools > Snap & Glue.

2. In the Snap To section of the dialog box, check the options you want.

The Ruler Subdivisions, Grid, and Guides options are useful for positioning
and aligning shapes.

The Shape Handles (selection handles), Shape Vertices, and Connection
Points options are useful for gluing shapes together.

3. Check the Snap option in the Currently Active section, then click OK.

TIP  To place shapes as precisely as possible, set the snap strength to a high set-
ting, press Ctrl+Shift and click the left mouse button to zoom into the drawing,
then move shapes into place.

A

C

B

A Check to determine what to snap to.
B Check to turn on Snap or Glue. Uncheck to turn them off.
C Move a slider to change the amount of pull an option exerts, measured in pixels. When you

increase the snap strength, Visio pulls a shape toward an item from farther away. “Points”
refers to selection handles, vertices, and connection points.

Related topics
Aligning and distributing shapes ............................................................................. 166
Controlling grid spacing and origin ........................................................................ 159
Setting ruler units and the zero point ..................................................................... 160
Using glue to maintain shape connections ............................................................... 66
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Creating guides and guide points

You can use guides and guide points when you want to position shapes precisely
or align several shapes and keep them in the same position even when you move
them. Guides are useful in ways rulers and grid lines are not. For example:

• You can rotate existing guides by rotating the entire page or by rotating a
single selected guide using the Size & Position command.

• You can glue shapes to guides so that when you move the guides the shapes
move too.

• You can place guides anywhere on the page and use the Snap & Glue com-
mand to make shapes snap to the guides.

• Guides don’t print.

        

Guide points are two short, crossed guides that you can use to align shapes at their corners
or to center shapes on top of one another.

Methods for creating guides and guide points

To Do This

Prepare to create guides and guide points On the View menu, check both Guides and Rulers.

Place a guide on the drawing page Drag a guide from the horizontal or vertical ruler onto the drawing page, then
release the mouse button.

Place a guide point on the drawing page Drag from the intersection of the two rulers onto the drawing page, then release
the mouse button.

Delete a guide or guide point Click to select the guide or guide point you want to delete. Press the Delete key, or
choose Edit > Clear.

Rotate a guide Select the guide, then choose Shape > Size & Position. In the Size & Position dialog
box, select Rotated, then type values for X, Y, and Angle. The x, y coordinates and
angle are relative to the zero point. Negative values for Angle rotate the guide
counterclockwise; positive values rotate the guide clockwise.

Related topics
Rotating and resizing pages ........................................................................................ 19
Snapping shapes for automatic alignment .............................................................. 156
Using guides to reposition multiple shapes ............................................................ 162
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Controlling grid spacing and origin

Each drawing page is crisscrossed by grid lines like those on traditional graph
paper. You can control the grid spacing, set whether the grid is variable or fixed,
or change the grid origin. You can even set spacing separately for the horizontal
and vertical grid lines. The grid helps you position shapes visually. You can also
snap shapes to the grid.

The intervals of the grid correspond to the unit of measure you set in the Op-
tions dialog box. You set the size of the intervals in the Ruler & Grid dialog box
and you type settings for the horizontal and vertical grid lines.

NOTE  If you rotate your page, the grid doesn’t rotate with it, but stays parallel
to the rulers.

A

B

C

A Specifies how far apart the grid lines are.
You can choose Fine, Normal, Coarse, or
Fixed. Fine, Normal, and Coarse set the
grid to a variable grid; the grid spacing
changes as you zoom in and out. Fixed
sets the grid to a fixed grid; if you zoom in
or out, the spacing between grid lines
does not change.

B For Fine, Normal, or Coarse, specifies the
minimum grid lines. For Fixed, specifies
how far apart the grid lines are.

C Specifies where to place the grid origin.
For example, you could move the grid in in-
crements different from the ruler to align
the grid with a shape or part of the dia-
gram. By default, the grid origin is in the
lower-left corner. Using a variable grid

By default, Visio uses a “variable” grid. Variable grid lines change depending on
the magnification at which you are viewing your drawing. If you zoom in on
your drawing, grid lines may be closer together; if you zoom out, they may be
further apart. (You can check this by changing the magnification and then
looking at how the grid lines line up with the rulers.) Visio determines the best
grid spacing for the view. Variable grids are useful when you want to zoom in to
align something precisely.

To set grid spacing between lines for a variable grid:

1. Choose Tools > Ruler & Grid.

2. In the Grid Spacing Horizontal and Vertical list boxes, select Fine, Normal,
or Coarse. Fine is the smallest grid spacing and Coarse is the largest.

3. Click OK.

To hide the grid:

• Choose View > Grid to uncheck the Grid command.
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Using a fixed grid
For some drawings, such as space plans and engineering diagrams, you may
want to set a fixed grid, so that grid lines stay the same distance apart regard-
less of magnification. For example, you can set the grid to match the size of
ceiling tiles. If you set a fixed grid for tiles that are 40cm by 40cm, you’ll no-
tice that the grid lines always match this distance on the ruler, regardless of
the magnification.

To set a fixed grid:

1. Choose Tools > Ruler & Grid.

2. In the Grid Spacing Horizontal and Vertical list boxes, select Fixed.

3. For Minimum Spacing, type the spacing you want for the fixed grid, then
click OK.

To change the point where a fixed grid originates:

1. Choose Tools > Ruler & Grid.

2. For Grid Origin, enter x- (horizontal) and y- (vertical) coordinates for the
point from which you want the grid to originate, then click OK.

Related topics
Setting ruler units and the zero point ..................................................................... 160
Zooming in on or out from pages ................................................................ Visio Help

Setting ruler units and the zero point

Each drawing window has vertical and horizontal rulers that show measure-
ments at the scale of the drawing. The intervals of the ruler correspond to the
unit of measure you set in the Options dialog box. You can specify both the
units that appear on the ruler and where the zero point, or starting point, for
both rulers is located in the Ruler & Grid dialog box.

The zero point is typically in the lower-left corner of the page, but sometimes
it’s helpful to move it to make it easier to measure the distances in a specific
drawing. For example, you might want the zero point to line up with a wall in a
floor plan. When you move the zero point on a ruler, the grid origin does not
move with it so the grid and ruler increments might become misaligned, mak-
ing it difficult to snap to ruler increments. You can adjust the grid to match or
turn the grid off.
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If you rotate your page or a guide, Visio uses the zero point as the center of the
rotation.

A

B

A Specifies how many tick marks are on the vertical or horizontal ruler. You can choose Fine,
Normal, or Coarse.

B Specifies the location of zero on the horizontal and vertical ruler. By default, the horizontal
ruler’s zero point is the top-left corner of the page, and the vertical ruler’s zero point is the
bottom-left corner of the page.

Methods for setting rulers

To Do this

Set ruler measurement units Choose File > Page Setup, then click the Page Properties tab. Under Measurement
Units, choose the units you want, then click OK.

Change the position of the zero point Hold down the Ctrl key, then drag from the intersection of the two rulers to where
on both rulers you want the new zero point.

Change the position of the zero point Hold down the Ctrl key, then drag from the other ruler.
on one ruler

Return the zero point to the lower-left Double-click the intersection of the two rulers.
corner of the page

Change ruler subdivisions Choose Tools > Ruler & Grid. Under Rulers, choose the kind of subdivisions you
want.

Hide the rulers Choose View > Rulers to uncheck the Rulers options. To create guides and guide
points, rulers must be visible.

Related topics
Controlling grid spacing and origin ........................................................................ 159
Snapping shapes for automatic alignment .............................................................. 156
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Using guides to reposition multiple shapes

When you need to precisely align several shapes and keep them in the same posi-
tion even when you move them, guides and guide points are very useful. You can
glue shapes to guides and guide points so that when you move the guide the
shapes move with it.

NOTE  You can glue shapes to rotated guides, but if you rotate a guide after a
shape is glued to it (whether the guide was rotated when you glued the shape to
it or not) the glue breaks.

Methods for using guides to reposition multiple shapes

To Do This

Align shapes with a guide or guide point Drag shapes until their selection handles, endpoints, or connection points align
with the guide or guide point.

Glue a 1-D shape to a guide Make sure the glue options are set appropriately in the Snap & Glue dialog box.
Drag one of the shape’s endpoints to the place on the guide where you want to glue
it. When the shape is successfully glued, the endpoint turns red.

Glue a 2-D shape to a guide Drag the shape to the place on the guide where you want to glue it. When the
shape is successfully glued, the selection handles on the glued part of the shape
turn red.

Related topics
Aligning and distributing shapes ............................................................................. 166
Creating guides and guide points ............................................................................ 158
Using glue to maintain shape connections ............................................................... 66

Specifying exact size and position for shapes and guides

With the Shape > Size & Position command, you can

• Set the position and degree of rotation of shapes and guides on the page, as
well as the dimensions of shapes, using precise numerical values.

• Obtain precise size and position information about selected shapes or
guides.

• Resize and move one shape or several shapes at once.
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For a 1-D shape, use the Size & Position command to

• Resize a shape vertically, horizontally, or in both directions.

• Change the position of a shape’s begin point while keeping the end point
stationary.

• Change the position of a shape’s end point while keeping the begin point
stationary.

• Change the height or angle of rotation of a shape.

B
A

C

D

In the Size & Position dialog box for 1-D shapes, you enter values specific to 1-D shapes,
such as begin and end points.

A Click to displays the shape’s begin and
end points and its height in the Param-
eters section.

B Click to display the shape’s begin point,
angle of rotation, length, and height in the
Parameters section. Visio calculates the
end point.

C Click to display the shape’s end point,
angle of rotation, length, and height in the
Parameters section. Visio calculates the
begin point.

D The values you type in this section depend
on what you click in the Show section. For
example, if you click Begin And End
Points, then you can type x, y coordinates
for the shape’s begin and end points, as
well as its height.

A Type the width of the shape.
B Type the height of the shape.
C Type the shape’s angle of rotation.
D Check to flip the shape horizontally.
E Check to flip the shape vertically.
F Move the shape’s pin in relation to the

shape and the page. Click a section to
change the pin location. The pin is the
point of reference used when you position
or rotate the shape.

G Type the position of the y-coordinate of
the shape’s pin in relation to the page. En-
ter a new value to change the vertical po-
sition of the shape on the page.

H Type the position of the x-coordinate of
the shape’s local pin (center of rotation) in
relation to the page. Enter a new value to
change the horizontal position of the
shape on the page.

For a 2-D shape, use the Size & Position command to

• Change the width and height of a shape.

• Change a shape’s angle of rotation.

• Flip a shape vertically or horizontally.

• Move a shape by changing the x- and y-coordinates of its pin, or point of
reference.

• Change the position of a shape’s pin on the shape.

B

A

C

D
E F

G

H

In the Size & Position dialog box for 2-D shapes, you enter values specific to 2-D shapes,
such as height, width, and pin location.
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For a guide or guide point, use the Size & Position command to set the orienta-
tion and position.

A
B
C
D

E

F

G

In the Size & Position dialog box for guides, you enter values specific to guides or guide
points, such as orientation.

A Click to change the selected guide to
a guide point.

B Click to make the selected guide
horizontal.

C Click to make the selected guide
vertical.

D Click to rotate the selected guide.
E Type the x-coordinate of the guide.
F Type the y-coordinate of the guide.
G Type the angle of rotation for a

rotated guide.

To set a 1-D shape’s size or position precisely:

1. Select the shape.

2. Choose Shape > Size & Position, or click the status bar.

3. In the Show section, choose one of the following options:

To change the position of the shape’s begin and end points or to change the
shape’s height, choose Begin And End Points (the default option).

To change the position of the shape’s begin point (the end point remains
stationary) or to change the length, angle of rotation, or height of the shape,
choose Begin, Length, Angle.

To change the position of the shape’s end point (the begin point remains
stationary) or to change the length, angle of rotation, or height of the shape,
choose End, Length, Angle.

4. In the Parameters section, specify values for any or all of the options:

If you chose Begin And End Points in the Show section, specify a value in the
Begin X or End X box to resize the shape horizontally; specify a value in the
Begin Y or End Y box to resize the shape vertically; or specify a value in the
Height box to change the shape’s height.

If you chose Begin, Length, Angle in the Show section, specify a value in the
Begin X or Begin Y box to change the position of the shape’s begin point, or
specify a value in the Length, Angle, or Height box to change the size and
position of the shape.
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If you chose End, Length, Angle in the Show section, specify a value in the
End X or End Y box to change the position of the shape’s end point, or
specify a value in the Length, Angle, or Height box to change the size and
position of the shape.

5. Click Apply to see the results before you close the dialog box, or click OK to
apply the changes and close the dialog box.

TIP  To move a shape without resizing or rotating it, change the values in the
Begin X and End X or Begin Y and End Y boxes by the same amount. For ex-
ample, to move a shape down one inch, decrease the values of Begin Y and End
Y by one inch each. To resize and rotate the shape at the same time, enter new
values for both the x- and y-coordinates.

To set a 2-D shape’s size or orientation precisely:

1. Select the shape.

2. Choose Shape > Size & Position, or click the status bar.

3. In the Size section, specify values for the shape’s width, height, and angle
of rotation. You can also check options to flip the shape vertically or
horizontally.

4. Click Apply to see the results without closing the dialog box, or click OK to
apply the changes and close the dialog box.

To set a 2-D shape’s position or reference point precisely:

1. Select the shape.

2. Choose Shape > Size & Position, or click the status bar.

3. To move the shape, specify values in the X and Y boxes in the Position section.

4. To change the shape’s reference point, or pin, click the grid section on
the shape diagram that corresponds to the point to which you want to move
the pin.

The X and Y coordinates in the dialog box indicate the location of the
shape’s pin on the drawing page. Therefore, when you change the location of
the pin on the shape, the shape’s position on the drawing page changes.

5. Click Apply to see the results without closing the dialog box, or click OK to
apply the changes and close the dialog box.
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To set a guide’s position or rotation precisely:

1. Select the guide or guide point.

2. Choose Shape > Size & Position, or click the status bar.

3. To change the orientation of a guide, choose Horizontal, Vertical, or Rotated
in the Guide Orientation section.

4. To move the guide or guide point, specify values in the X or Y boxes (or
both) in the Guide Parameters section.

5. To set the angle of rotation for a rotated guide, type a value for Angle in the
Guide Parameters section.

6. Click Apply to see the results without closing the dialog box, or click OK to
apply the changes and close the dialog box.

To set the size and position of multiple shapes precisely:

1. Select all of the shapes you want to size.

2. Choose Shape > Size & Position, or click the status bar.

3. Type values or select options that you want, then click OK.

4. Click Apply to see the results without closing the dialog box, or click OK to
apply the changes and close the dialog box.

Related topics
Aligning and distributing shapes ............................................................................. 166
Rotating shapes ........................................................................................................... 45
Snapping shapes for automatic alignment .............................................................. 156

Aligning and distributing shapes

As you move shapes, you can align them with ruler intervals and grid lines. You
can also

• Align shapes to other shapes. You can align the tops, bottoms, left sides, right
sides, or centers of shapes.

• Create guides or guide points and align shapes to them. When shapes are
glued to a guide, the aligned shapes move with the guide.

• Distribute three or more shapes to create an equal distance between the ends
or centers of the shapes.

When you’re aligning shapes to one another, the primary shape, indicated by
green handles, is the shape to which other shapes align. You can establish a cer-
tain shape as primary by selecting that shape first, then Shift+clicking to select
the other shapes you want to align to the primary one. If you drag a selection
net around several shapes, the top shape in the stacking order is the primary
shape.
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Aligning shapes
When you move the shapes, faint lines on the vertical and horizontal rulers in-
dicate where you’re moving the shapes. If you don’t see the rulers, make sure
Rulers is checked in the View menu.

By default, the ruler zero point is at the lower-left corner of the drawing page.
Sometimes it’s useful to change the position of the zero point. For example, you
might want to measure the distances between shapes that aren’t near the cur-
rent zero point.

To align shapes to a primary shape:

1. Select the shape to which you want to align other shapes, then Shift+click to
select the shapes you want to align.

2. Choose Tools > Align Shapes.

NOTE  You can also use one of the six align shapes buttons on the Shape
toolbar: align left ( ), align center ( ), align right ( ), align top ( ), align
middle ( ), or align bottom ( ).

3. Select the alignment options you want.

Each alignment option is represented by an illustration. Choose an
Up/Down Alignment or a Left/Right Alignment option, or one of each.
To cancel the selection of either Alignment option, click the red X in that
section.

4. To create a guide and glue the shapes to it, check Create Guide And Glue
Shapes To It.

If you choose this option, you can move all the shapes and maintain their
alignment by selecting and moving the guide.

5. Click OK.

To align shapes to a guide:

1. Drag a guide from a ruler onto the drawing page. The guide appears as a
green line (it appears as a blue line when deselected).

2. Choose Tools > Snap & Glue to make sure that Glue is checked under Cur-
rently Active and Guides is checked under Glue To, then click OK.

TIP  You can automatically create a guide and glue shapes to it using the Align
Shapes command. Simply check Create Guide And Glue Shapes To It in the
Align Shapes dialog box.
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To align shapes to a guide point:

1. Point to the crossbar at the intersection of the two rulers, then drag to where
you want the guide point.

The guide point appears as two blue crossed lines.

2. Position shapes you want to align with their centers, selection handles (for
2-D shapes), or endpoints (for 1-D shapes) on the guide point.

Distributing shapes
You can distribute three or more shapes to create an equal distance between the
ends or centers of the shapes. When you distribute shapes vertically, the top and
bottom shapes in the selection define the boundaries of the distribution. For
horizontal distribution, the boundaries are defined by the leftmost and
rightmost shapes.

To distribute shapes using the Distribute Shapes command:

1. Shift+click to select three or more shapes.

2. Choose Tools > Distribute Shapes.

You can also use one of four Distribute Shapes buttons on the Shape
toolbar: distribute centers horizontal ( ), distribute horizontal spacing
( ), distribute centers vertical ( ), or distribute vertical spacing ( ).

3. Choose a distribution option.

4. To add guides and glue the shapes to them, check Create Guides And Glue
Shapes To Them.

If you choose this option, you can move an outermost guide to redistribute
all the shapes.

5. Click OK.

Visio distributes the shapes evenly between the two outermost shapes.

To distribute shapes using evenly spaced guides:

1. Drag the first guide from the appropriate ruler.

2. To create the second guide, hold down the Ctrl key and drag from the first
guide to where you want the second guide.

3. Press F4 to create additional guides.

4. Glue shapes to the guides so they’re distributed the way you want.

TIP  You can create a guide and glue shapes to it using the Distribute Shapes
command. Check Create Guides And Glue Shapes To Them in the Distribute
Shapes dialog box.

Related topics
Setting ruler units and the zero point ..................................................................... 160
Using guides to reposition multiple shapes ............................................................ 162
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Measuring shapes
and setting scales

About measuring and scaling in drawings

When the drawings you create represent real-world objects that are larger than
the paper size, such as a potted plant or a grand piano, you need to draw to
scale. For example, 1mm on the drawing page of an office layout might repre-
sent 50mm of the actual office.

In Visio, the units of measure that appear on the rulers, or “drawing units,” are
sizes in the real world. In the example above, 50mm is the drawing unit.

“Page units” are sizes on the printed page1mm in the office layout example.
The ratio of page units to drawing units is the “drawing scale.”

When you start a drawing by opening a template, the drawing scale and units of
measure are already set up for you. Some templates, such as the Basic Flowchart
Template, have no drawing scale, because you use them to create abstract draw-
ings that don’t represent actual objects in the real world.

You can change the units of measure and the drawing scale settings to accom-
modate the particular type and size of drawing you want to create.

Related topics
About printing drawings .......................................................................................... 107
Basing new drawings on template ............................................................................... 9
Calculating and displaying shape dimensions ............................................. Visio Help
Setting drawing scales ............................................................................................... 170
Using dimension lines to display shape size ................................................. Visio Help
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Setting drawing scales

Whenever you need to recreate the exact spatial relationships of very small or
very large objects in the space of a drawing page, you need to set a drawing
scale.

You can set a drawing scale in any drawing. Some templates, such as the Office
Layout Template, open with a drawing scale already set. If you want to work
with a different drawing scale, you can change the setting.

When you set a drawing scale, keep the following points in mind:

• Changing the scale of a drawing page does not change any background
pages assigned to it, so you must set their scale separately if you want the
foreground and background pages to match. This feature allows a single
drawing to contain multiple scales.

• Most masters are designed for drawings with a scale of 1:1. Visio adjusts an
instance of a master automatically if its drawing scale is more than eight
times larger or smaller than the drawing scale of the page. If the scales differ
less, Visio doesn’t adjust the shape.

¼" = 1' 1"
1:25

1:1

Scale is a page property. In a multiple-page drawing, each page can have a different scale.
The rulers in each of these drawings reflect a change in scale.

Because drawing scale is the ratio of page units (measurements on the printed
page of drawing) to drawing units (units of measure that appear on the rulers and
represent the real-world measurements), you need to make sure that you choose
the appropriate measurement unit for each before you set your drawing scale.

For example, a drawing of a bolt may have a drawing scale of 10:1, meaning that
every 10mm on the printed drawing represents 1mm on the actual bolt. In that
case, you would set both the page units and the drawing units to millimeters.
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In some cases, however, you may want to have a drawing scale where the ratio is
made up of two different measurement units. For example, in a landscape lay-
out, 1 inch on the printed drawing may need to represent 3 feet or even 3 yards.
If you set the drawing scale as 1:3 and both the page and drawing units are set
to inches, you won’t get the scale you want. Instead, 1 inch on the page will rep-
resent 3 inches in the landscape, which would require an enormous drawing!

To set default page units: 

1. Choose Tools > Options, then click the Default Units tab.

2. For Page, choose the units of measure you want.

You can also set default Text, Angle, and Duration units.

3. Click OK.

To set drawing units for a particular page: 

1. Display the page for which you want to change the drawing units.

2. Choose File > Page Setup, then click the Page Properties tab.

3. Choose the units of measure you want, then click OK.

The rulers will show the new measurement units.

To set a drawing scale: 

1. Display the page for which you want to set a scale.

2. Choose File > Page Setup, then click the Drawing Scale tab.

3. Choose a standard architectural or engineering scale, or enter a custom scale
in the Drawing Scale edit box, then click OK.

Visio redraws the page and adjusts the rulers to reflect the new settings.

A

C

E

D

B

F

Choose File > Page Setup, then click the Drawing Scale tab.

A Choose or type the ratio of the page units
to the drawing units.

B If the drawing should print at its actual
size, select No Scale, then select 100%
scale in the Print Setup dialog box.

C Choose a type of drawing scale from the
list of scales relevant to a particular disci-
pline.

D Choose to enter a custom ratio of page
size to drawing size.

E Specifies the size of the drawing page,
based on the Drawing Scale and the
Physical Page Size.

F Indicates the size of the printed page. You
can change this setting in the Page Size
tab.
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Protecting
shapes and files

About protecting shapes and files

If you plan to share drawings, stencils, or templates with other people, you may
want to protect the files, the shapes you create, or certain aspects of a drawing
to prevent inadvertent changes.

You can protect shapes and drawings using the following methods:

• Lock shapes to prevent them from being modified in specific ways. For
example, you can lock a shape against rotation or resizing.

• Lock a layer so no shape on that layer can be modified. For example, if you
give an office layout to an electrical wiring planner, you can lock all layers
except the one for the wiring so that no other aspects of the layout are avail-
able for editing.

• Place shapes, such as logos or title blocks, on a background so they won’t be
affected by changes made to the drawing page.

• Prevent attributes of a drawing, such as styles, from being modified.

• Save a file as read-only, so it can’t be modified in any way.

Related topics
Controlling shape behavior using layers ................................................................. 149
Using backgrounds for common page elements ....................................................... 26
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Locking shapes against changes

You can lock shapes using the Protection command to protect them from
resizing, repositioning, rotating, deleting, and selecting.

When a shape is locked against resizing or rotating, it displays padlocks where
the resizing and rotation handles usually appear, to indicate that those handles
cannot be selected.

Box sizes with text.
Hit <Return> to start a

new line of text.

Padlocks over a shape’s selection handles indicate that the shape is locked against changes.
Some Visio shapes are locked against editing in this way, such as the Auto-size shape on the
Block Diagram stencil, which is locked against manual sizing because its size is determined
by the amount of text you type in the shape. Unlocking and changing these shapes may
cause them to behave in unexpected ways.

NOTE  The Protection section in the ShapeSheet spreadsheet includes protec-
tion options not available in the Protection dialog box, such as locking against
cropping, editing with any drawing tool, text editing and formatting, group
editing, and recalculation of height and width when you size the shape.

A

B
C

A Lists characteristics you can lock on the
selected shape. When an item is checked,
the characteristic is locked against
changes. You can choose as many of the
characteristics as you want.

B Locks all ten options in the Protect
section.

C Unlocks all ten options in the Protect
section.

To lock a shape against selection: 

1. Select the shape you want to protect.

2. Choose Format > Protection.

3. Check From Selection, then click OK. When a message box appears, click
OK.

4. Choose Tools > Protect Document. Check Shapes, enter a password if you
want, then click OK.

NOTE  After you click OK, you won’t be able to see your password, so make sure
you memorize it or write it down.
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To unlock shapes so you can select them: 

1. Choose Tools > Protect Document, then uncheck Shapes.

2. Choose Format > Protection, then uncheck From Selection.

To lock or unlock other shape behaviors: 

1. Select the shape.

2. Choose Format > Protection.

3. Check the shape behaviors that you want to lock or uncheck the behaviors
you want to unlock, then click OK.

TIP  You can also use the SmartShape Wizard to lock shape behaviors. To run
the wizard, choose Tools > Macro > Visio Extras > SmartShape Wizard.

Related topics
About customizing shape behavior .............................................................. Visio Help
Controlling shape behavior using layers ................................................................. 149
Using backgrounds for common page elements ....................................................... 26

Saving files as read-only to prevent changes

When you base a drawing on a template, or open a stencil separately, the stencil
opens as read-only by default. That way, if you share a stencil you created with
other Visio users, they can’t accidentally change masters on your stencil. How-
ever, unless you save the stencil as read-only, other users have the option to
open it in read/write mode by clicking the Original button in the Open Stencil
dialog box.

To prevent others from changing an original stencil, template, or drawing file
you create, you can save it as read-only. If a Visio stencil, template, or drawing
file is saved as read-only, you can open a copy of the file for editing, but the only
way to change the original file is to reset the file properties through Windows.
For details about resetting the file properties through Windows, see your
Windows documentation.

If you plan to save a stencil as read-only, you must have the original stencil
open.

To open an original stencil: 

1. Choose File > Stencil > Open Stencil.

2. Highlight the file icon for the stencil name you want to open.

3. Under Open, select Original, then click Open.
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To save a file as read-only: 

1. Open the file and make the appropriate window active. For example,
if you’re saving a stencil, open the original stencil, then click the stencil
window title bar.

2. Choose File > Save As.

3. For Save In, navigate to the folder you want to save the file in.

4. For File Name, type a file name for the read-only file.

5. For Save As Type, choose the type of file you want to save, for example,
Stencil (*.vss).

6. Under Save, check Read Only.

7. Click Save.

TIP  After you have saved a file as read-only, to make the file read/write again use
the Save As command to save the file to another name.

To open a copy of a read-only file: 

1. Choose File > Open.

2. Highlight the file icon for the read-only file you want to open.

3. Under Open, check Copy, then click OK.

Related topics
Protecting drawing-file attributes ................................................................. Visio Help
Saving drawing files .................................................................................................... 13
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Storing and reporting
on data in Visio shapes

About storing data in shapes

A Visio drawing is more than a picture—it’s a valuable medium for storing data.
A shape can act as a visual database field that stores data you can retrieve in a
report. For example, a shape in a flowchart can store data about the cost, dura-
tion, and resources involved in the process the shape represents.

Process  1

Custom-property fields are stored in their own section of the shape’s ShapeSheet
spreadsheet. You can add fields using the Custom Properties Editor.
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To store data with a Visio shape, give the shape custom-property fields into
which others can enter custom-property data. Many Visio shapes come with
some custom-property data already assigned in custom-property fields.

Related topics
About creating your own shapes ............................................................................. 207
Adding data to shapes’ custom-property fields ....................................................... 178
Adding, editing, and deleting custom-property fields ........................................... 179
Creating databases from shape properties .............................................................. 183
Creating reports from custom data ......................................................................... 180
Updating and revising reports ................................................................................. 182

Adding data to shapes’ custom-property fields

Many masters already include custom-property fields. All you have to do is en-
ter the data. For example:

• Flowchart masters include custom-property fields in which you can enter
cost, duration, and resources.

• Office layout masters include fields for inventory number and owner.

You can also create custom-property fields if the fields you want don’t already
exist.

To find out if a shape has custom-property fields: 

• Select the shape, then choose Shape > Custom Properties.

If the shape has property fields, the Custom Properties dialog box appears,
listing the property fields and describing their purpose. If the shape doesn’t
contain custom-property fields, a message appears to that effect.

To enter values in a shape’s custom-property fields: 

1. Select the shape to which you want to add the data.

2. Choose Shape > Custom Properties.

3. Enter the data you want in each field, then click OK.

TIP  You can also enter custom-property data by right-clicking the shape then
choosing Properties or, for some shapes, a “Set…” command for setting a par-
ticular property.

Related topics
Adding, editing, and deleting custom-property fields ........................................... 179
Using shape handles ................................................................................................... 32
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Adding, editing, and deleting custom-property fields

To develop your own custom solution, you may want to edit existing custom-
property fields, add new ones, or delete fields you don’t need. You may also
want to add custom-property fields to new shapes you create. You can do all
these things with the Custom Properties Editor.

With the Custom Properties Editor, you can make changes only to masters on
stencils. You can edit shapes on the following stencils:

• A standalone stencil that comes with your Visio product.

• A stencil that you created.

• A particular drawing’s local stencil. Changing the shapes on a drawing’s local
stencil updates the instances on the drawing page.

Choosing where to edit custom-property fields
Where you edit custom-property fields depends on what you intend to do with
the shapes. If you want to reuse a master with updated custom-property fields
in several drawings, edit the master’s properties in the standalone stencil. If you
want to apply the updated properties to the current drawing only, edit the
master’s properties on the local stencil.

Editing in a standalone stencil  A standalone stencil is a file with a .vss exten-
sion. Stencils that open with templates are standalone stencils. You can also
open standalone stencils separately to use with any drawing.

If you edit custom-property fields for a master in a standalone stencil, the
changes are available in new drawings you create after saving the new property
fields for the master.

Editing in a local stencil  A local stencil is the stencil associated with a particular
drawing. It contains all the masters you’ve dragged from standalone stencils to
that drawing, even if you’ve deleted the instance of the master from the draw-
ing. Unless you save a local stencil as a file (so it becomes a standalone stencil),
it’s available only when you open the drawing with which it’s associated.

A shape on a drawing page inherits its styles and properties from the master on
the local stencil. Therefore, if you edit custom properties for a master on the local
stencil, you also edit all the instances of that master in the drawing. In addition,
each new instance you create by dropping the master from the standalone stencil
to the same drawing inherits the custom-property edits you made.
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To edit, add, or delete custom-property fields: 

1. Choose Tools > Macro > Custom Properties Editor.

2. On the first screen, choose the location of the masters you want to edit, then
click Next.

3. Follow the remaining screens.

NOTE  Many Visio shapes come with custom-property fields already assigned.
It’s best not to delete these fields because they can affect other aspects of shape
behavior.

To see the changes you’ve made to a shape’s custom-property fields:

1. If you edited a master on a standalone stencil, drop an instance of the master
with the custom properties you edited onto a drawing page.

If you edited a master on a local stencil, select an instance of that master on
the drawing page.

2. With the shape selected, choose Shape > Custom Properties, or right-click
the shape and choose Properties.

The Custom Properties dialog box appears, showing the changes you made.

After you add, edit, or delete custom-property fields, you can add data to the
fields.

Related topics
Adding data to shapes’ custom-property fields ....................................................... 178
Revising several identical shapes at once ................................................................. 217

Creating reports from custom data

If shapes have custom-property fields in which you have entered data, you can
generate inventory and numeric reports based on that data. Visio places your
report data in a spreadsheet, which you can save as a Microsoft Excel worksheet
(.xls) or a text file (.txt). The results appear in one or more report shapes in
your drawing.

Property Report

Created:   5 /2 /97 ,  10 :55 :40 AM C O N F I D E N T I A L

ITEM T O T A L
Cos t 1 0 0 0
Dura t ion 9
Resou rces 8

A numeric report can include calculations for totals, averages, maximums,
minimums, and medians, as well as any advanced calculations you can
perform using formulas in a spreadsheet. This report shape shows totals for
the cost, resources, and duration properties.
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Layers and reports
When you want to generate more than one report for a drawing, you can use
layers to assign your shapes to separate categories, and then create reports based
on the categories. For example, in a process flowchart, you can assign the shapes
associated with each subprocess to a separate layer. Then you can easily generate
an inventory report for the entire process that lists the cost, time, and resources
associated with each step. You can also generate separate numeric reports for
each subprocess that calculate the total or average costs for each step in the sub-
process.

If you generate a report on shapes not on a layer, Visio creates a new layer and
assigns the selected shapes to it. The layer doesn’t affect the appearance of your
drawing—it places the shapes in a category that you can select, hide, lock, print,
or color separately. Having shapes on a layer also makes it easier to update a report.

Generating numeric and inventory reports
You have options for limiting and presenting reports. For example, you can re-
port on all shapes in a drawing or only on selected shapes, and you can choose
the properties you want the report to include. You can decide which drawing
page to place the report shape on and you can add subtotal reports to each
drawing page. Your report shapes can include document information, such as
creation date and time.

To generate a numeric or inventory report:

1. Choose Tools > Property Report.

2. On the first screen of the Property Reporting Wizard, click Next.

3. On the second screen, choose the shapes you want to report on, then click
Next.

4. Follow the wizard screens.

TIP  When you run the Property Reporting Wizard, you have the option of sav-
ing the spreadsheet. If you save it, you can open it in any program, such as
Microsoft Excel or Windows Notepad, that can open .xls or .txt files.
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Generating quick inventory reports
For certain types of drawings in which you may incorporate data frequently,
such as network diagrams, office layouts, and organization charts, you can
quickly export an inventory report based on the shapes you specify and their
custom properties. You save the exported information in a Microsoft Excel file,
a Microsoft Access file, or a Text file.

To generate a quick inventory report:

1. Select the shapes you want to report on.

2. Choose Tools > Export [data].

3. Click the Properties button to choose which properties to include in your
report.

4. Choose whether to report on all pages in the document, whether to report
on all shapes or selected shapes, and whether to create a report in Excel,
Notepad, or Access.

5. Type a name for, or navigate to locate, the report file, then click OK.

Related topics
Adding data to shapes’ custom-property fields ....................................................... 178
Adding, editing, and deleting custom-property fields ........................................... 179
Assigning shapes to layers ........................................................................................ 147
Creating, removing, and renaming layers ............................................................... 145

Updating and revising reports

When you run the Property Reporting Wizard to create an inventory report, it
creates a report shape that contains the data you specified. Once a report shape
is on a drawing page, you can edit the shape data to update the report.

Property Report

Created:   5 /2 /97 ,  10 :55 :40 AM C O N F I D E N T I A L

ITEM T O T A L
Cos t 1 0 0 0
Dura t ion 9
Resou rces 8

When you update a report, you also update the spreadsheet if you
saved it when you first generated the report. You can save the revised
spreadsheet under a new name or replace the original.
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To update a report: 

• Right-click the report shape, then choose Update Property Report from the
shortcut menu.

If you saved the spreadsheet when you first generated the report, the wizard
opens a new spreadsheet that includes the revised report results. You can
save the revised spreadsheet under a new name or replace the original one.

To replace the title for a report shape: 

1. Select the report shape.

2. Choose the text tool from the Standard toolbar, click the existing title, select
the text, then type a new title.

Related topics
Adding data to shapes’ custom-property fields ....................................................... 178
Creating reports from custom data ......................................................................... 180

Creating databases from shape properties

You can run the Database Export Wizard to export data from shapes into a
database table. For example, you can create an inventory report for shapes in an
office layout or network diagram. In the process of running the wizard, you can
select the ShapeSheet cells from which you want data exported.

You can either generate a new database, overwrite data in an existing database
table, or insert a new table into an existing database. The wizard works with any
ODBC-compliant database application.

If you want to insert a table into an existing database, the database must be de-
fined as an ODBC-data source. You can define the database as a data source
within the Database Export Wizard. When you create a new database in the
wizard, you also define it as a data source.

You can export data for every shape in the drawing or for selected shapes. You
can select the shapes with data you want to export by placing those shapes on a
separate layer. The wizard prompts you for the appropriate layer.
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When you export, the wizard determines the most appropriate data type for the
information in each cell or field you’re exporting. You can change the data type
settings and you can specify how you want to interpret the data (for example, as
a formula, value, number, or number with a particular set of units).

Process 1 Decision

Report

Process 2 Storage

Each shape in the drawing is represented by a record (or row) in the database table and
each custom-property field or ShapeSheet cell is represented by a field (or column). Data you
enter in the custom-property fields in Visio or in ShapeSheet cells appear as values in the
database table cells.

To create a database from shape properties: 

1. Open the drawing with shape data you want to export.

2. Choose Tools > Macro > Database > Database Export.

3. On the first wizard screen, click Next.

4. Follow the wizard screens.

TIP  When you run the Database Export Wizard to export shape data, the wiz-
ard stores export-related information with the drawing page. If you make
changes to the shapes and want to re-export the data, you can right-click the
drawing page and choose Database Table Export.

Related topics
About customizing shape behavior .............................................................. Visio Help
About data-driven shapes and drawings ................................................................. 195
About storing data in shapes .................................................................................... 177
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Creating drawings
from external data

About creating drawings from data

You can use data created in programs other than Visio to generate drawings.
The data is represented graphically by Visio shapes. Drawings and shapes cre-
ated in this way are called “data-driven.”

The data can be in text (.txt), Microsoft Excel (.xls), or Microsoft Project
exchange (.mpx) format, or it can exist in a database created in an ODBC-
compliant database application. ODBC stands for Open Database Connectivity,
which is a standard Microsoft interface that allows applications to access, view,
and modify data from a variety of databases.

For example, from

• A human-resources employee database, you could generate a corporate
organization chart.

• A data file that lists project tasks, resources, start dates, and end dates, you
could generate a project timeline.

• A text file that includes information about shapes and links, you could
generate a flowchart.

You can also create data-driven shapes and drawings by establishing links
between Visio objects and records in database tables.

Related topics
About data-driven shapes and drawings ................................................................. 195
About storing data in shapes .................................................................................... 177
Creating connected drawings from text files .......................................................... 192
Creating organization charts from data files ........................................................... 186
Creating project timelines from data files ............................................................... 190
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Creating organization charts from data files

Visio includes stencils with shapes that make it easy for you to create organiza-
tion charts. Often, however, electronic data files already exist that include the
information about your corporation or group that you’d want the organization
chart to convey. For example, many corporations have human-resources data
files that list employee names, job titles, managers, and more. Using the Organi-
zation Chart Wizard, you can use the data from such a data file to generate an
organization chart.

The Organization Chart Wizard can read data files in the following formats:

• Microsoft Excel (.xls)

• Org Plus (.txt)

• Text (.txt), tab- or comma-delimited

• The file format for a database created in an ODBC-compliant database
application, such as Microsoft SQL Server, Microsoft Access, and Oracle SQL
Server. The database must be a “flat file,” that is, all the data the wizard
requires must reside in one database table.

If you don’t have such a data file, the wizard provides templates you can use to
create one in Microsoft Excel or text file format.

Setting up an organization chart data file
In the data file, each row represents a box (or employee) in the organization
chart. Each column represents data about the employee. The data file must in-
clude at least three columns that provide

• An ID number or name that uniquely identifies each employee.

• Employee name.

• Who the employee reports to.

The data file can also include additional columns for other data, such as tele-
phone number, office location, and more. When you run the wizard, you can
add the optional columns to the organization chart shapes as custom property
fields.

If you have custom shapes you want the wizard to use when it creates the orga-
nization chart, you must include a column named Master_Shapes in the data
file. In each row, type the name of the shape you want to use.

You’ll get the best results by setting up the data file you want the Organization
Chart Wizard to read so that it conforms to certain requirements. The following
comma-delimited text (.txt) file illustrates how to set up your data file.
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Unique_ID,Name,Position,Reports_To,Department,Telephone,Master_Shape
a,Ben Wyss,Financial Controller,e,Finance,555-4300,Position
b,Chris Klustner,Commercial Director,d,Marketing,555-4400,Position
c,Dave Vollan Cole,Dir. Client Services,e,Finance,555-4500,Position

d,Geraldine Gigot,Vice-Pres. Marketing,f,Marketing,555-4444,Manager
e,Eric Philip,Vice-Pres. Finance,f,Finance,'555-5555,Manager
f,Susan Jaech,CEO,,,555-6666,Executive

A

B

C D E F

Your data file must include the following:

A Information broken out under the column headings Unique_ID, Name, and Reports_To, or
equivalent columns with different names. If your data file uses different heading names, the
wizard prompts you to indicate which columns it should use to find this information. You can
include additional columns, as shown here, but they are not required by the wizard.

B A field that uniquely identifies each record from the database. If each employee has a
unique name, the Name field can serve as the unique identifier field. Otherwise, you must
provide another field, such as Unique ID or Employee Number.

C Placeholders for columns with no data in them. In a spreadsheet or database table, leave
the columns blank.

D Entries in the Reports_To column for all the records except one (the one for the person at
the top of the chart). Use the unique identifier in the Reports_To column to indicate to whom
a person reports.

E In an Excel data file, use a single quotation mark before any telephone numbers you want to
include. For example, enter a telephone number in Excel as '555-4497. The single quotation
mark tells Excel to treat the number as a string (rather than as an integer).

F Shape names in this column for any shapes (including custom shapes you create) you want
the organization chart to substitute for its own default shapes while creating the chart.

NOTE  You can add comment lines to a text file. Use a single quotation mark as
the first character in a comment line to tell the wizard that the line does not
contain data.

To draw an organization chart from an existing text or
Microsoft Excel file:

1. In Visio, choose File > New > Business Diagram > Organization Chart Wizard.

2. On the first screen, click Next.

3. On the second screen, click Read Data From Existing File, then type the file
location and name, or click Browse to locate the file.

4. Follow the wizard screens.
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Creating an organization chart from a database table
With the Organization Chart Wizard, you can create an organization chart
from a database table and link the chart and the table so that you can pass infor-
mation back and forth to keep the two files synchronized. For example, you can
change an employee’s phone number and manager information in the database
and then refresh the chart to reflect the changes.

In the wizard, you can choose options that control which direction information
flows. For example, if the database table is the human resources database for
your corporation, you may not want changes you make in the organization
chart to affect the database.

NOTE  The Organization Chart Wizard requires that the database you are link-
ing to be defined as an ODBC-compliant data source. You can define the
database as a data source by clicking Create Data Source on one of the wizard
screens.

To create an organization chart from a database table and link the
two files:

1. In Visio, choose File > New > Business Diagram > Organization Chart Wizard.

2. On the first screen, click Next.

3. On the second screen, click ODBC Data Source.

4. On the third screen, choose the data source you want the wizard to read,
then click Next.

If your database does not appear in the list, it is probably not defined as an
ODBC data source. Click Create Data Source, then follow the instructions
onscreen until you are returned to the wizard, then choose your database in
the list.

5. Follow the wizard screens.

Creating a data file using a template
If you haven’t already created a data file, you can run the Organization Chart
Wizard to open a data file template in text (.txt) or Microsoft Excel (.xls) for-
mat. The template is set up with the correct column heading structure so that
you can enter your data.

NOTE  You can also open the templates without running the wizard. Both
template files are named Org Chart Data Template and are located in the
\\Visio\Solutions\Business Diagram folder. Check the file icon to determine
which template you want to open.



C R E A T I N G  D R A W I N G S  F R O M  E X T E R N A L  D A T A 1 8 9

To create a data file using a template:

1. In Visio, choose File > New > Business Diagram > Organization Chart Wizard.

2. On the first screen, click Next.

3. On the second screen, click Enter Data In New Text File or Enter Data In
New Microsoft Excel Workbook, then click Next.

4. Follow instructions on the wizard screens for entering data into a text or
Excel template.

5. After entering the data in the template, name and save the file. Choose
Tools > Macro > Business Diagram > Organization Chart Wizard to restart
the Organization Chart Wizard and, on the second screen, choose Read Data
From Existing File.

Organization Chart Wizard troubleshooting
If the Organization Chart Wizard is unable to read your data file or produces an
unexpected result, check your file for the following:

• Missing tabs or commas from your data file.

• Any records that are not uniquely identified.

• Circular references—that is, a person who reports to him or herself or to a
subordinate.

• More than one record without an entry in the Reports_To column. Only the
Reports_To record for the person at the top of the chart should be left blank.

Related topic
About storing data in shapes .................................................................................... 177
About data-driven shapes and drawings ................................................................. 195
Synchronizing drawings and databases ................................................................... 202
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Creating project timelines from data files

Using the Project Timeline Wizard, you can generate a timeline from a data file
created in another application that contains task names, start and end dates, de-
pendencies, resources, and other information.

The wizard requires that the data file be in comma- or tab-delimited text (.txt),
Microsoft Project exchange (.mpx), or Microsoft Excel (.xls) format.

If you haven’t already created a data file, you can run the Project Timeline Wiz-
ard to open a data file template in text (.txt) or Microsoft Excel (.xls) format.
The templates are set up with column headings in place so that you can simply
enter your data.

NOTE  You can also open the templates without running the wizard. Both
template files are named Timeline Data Template and are located in the
\\Visio\Solutions\Business Diagram folder. Check the file icon to determine
which template you want to open.

Even if you don’t have a data file, you can run the Project Timeline Wizard and
create a project timeline to which you add data later. While running the wizard,
you can choose format (for example, whether or not to display vertical and
horizontal lines) and style (for example, taskbar color) options.

Setting up a project timeline data file
You’ll get the best results by setting up the data file you want the Project
Timeline Wizard to read so that it conforms to certain requirements. The
following comma-delimited text (.txt) file illustrates how to set up your
data file.
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Task#,Task Name,Duration,Start Date,End Date,Dependency,Resource
1,Develop Timeline Wizard,30 d,7/17/95,8/15/95,,Jason
2,Beta I,,7/26/95,,,Program Team
3,Develop Layout Wizard,16 d,7/17/95,8/1/95,,Matt
4,Beta II,,8/9/95,,,Program Team
5,Develop Orgchart Wizard,23 d,7/17/95,8/8/95,,Keri
6,Write Documentation,2 w,8/9/95,8/22/95,5,User Ed
7,Beta III,,8/23/95,,,Program Team
8,Print Manuals,1 w,8/23/95,8/29/95,,Media Now
9,Assemble Product,2 d,8/30/95,8/31/95,8,Media Now
10,Ship Visio,,9/1/95,,9,Visio Corporation

A

B

C

D

E F

Your data file should adhere to the following guidelines:

A Information should be broken out under the column headings Task#, Task Name, Duration,
Start Date, End Date, Dependency, Resource. (If a task includes a Start Date and a Duration,
you don’t have to include an End Date.)

B For milestones, specify only a Start Date.
C Include placeholders for columns with no data in them.
D For Dependency, use the number of the task that the current task is dependent upon.
E Abbreviate durations as follows:  “d” for days, “w” for weeks, or “m” for months.
F For Resource, you can use anything you want, including names or number of people. Data in

the Resource column doesn’t automatically appear in your project timeline drawing. You
can choose to display Resources in timeline bars when you run the Project Timeline Wizard,
or you can add a Resource column to the project timeline on the drawing page.

To create a project timeline from an existing data file: 

1. Choose File > New > Business Diagram > Project Timeline Wizard.

2. On the first screen, click Next.

3. On the second screen, click Import MPX File to import a Microsoft Project
exchange file or Read Data From Existing File to have the wizard read a text
(.txt) or Microsoft Excel (.xls) file.

4. Type the file location and name or click Browse to locate the file.

5. Follow the wizard screens.
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To create a data file using a template: 

1. Choose File > New > Business Diagram > Project Timeline Wizard.

2. On the first screen, click Next.

3. On the second screen, click Enter Data In New Text File or Enter Data In
New Microsoft Excel Workbook, then click Next.

4. On the third screen, type a name for the data file, then click Next.

5. If you chose to enter data into a new text file, the wizard opens a comma-
delimited text file with column headings in Notepad. Enter your data, name
and save the file, and exit Notepad. In Visio, choose Tools > Macro > Busi-
ness Diagram > Project Timeline Wizard. On the second screen, confirm
that the text file listed is the one you just created, then follow the wizard
screens.

Or, if you chose to enter data into a new Excel workbook, the wizard opens
an Excel workbook with column headings. Enter your data. Name and save
the file, then choose Tools > Macro > Business Diagram > Visio Timeline
Wizard and follow the wizard screens.

Related topics
About creating drawings from data ......................................................................... 185

Creating connected drawings from text files

If you have a large amount of existing data in text files, you can import the data
using the Visio text import filter, and then convert it to drawings. The text files
must be in Comma Separated Variable (.csv) or Text (.txt) format.

You can create the files in a spreadsheet application, a word-processing applica-
tion, or a text editor such as Notepad. For example, you can use a spreadsheet
application, such as Microsoft Excel, to create an employee list that you can
convert to an organization chart. Then you can export that data to .csv or .txt
format and import it into Visio to convert the data to a drawing.

To import a text file and create a drawing, you must set up the text file in a cer-
tain way. The example below shows you a text file that has been set up correctly
and the drawing the text file creates. Following the drawing, you can find addi-
tional details about text file structure, text delimiters, record delimiters,
comment lines, and record types.
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This text file:

;Shape,ID,Master,Text,X,Y,Width,Height,Property

Shape,PATRICIA,,Patricia Rodman

Shape,STEVE,,Steve Melvin

Shape,TROY,,Troy Morris

Shape,ELIZABETH,,Elizabeth Davis

Shape,SARAH,,Sarah Wright

;Link,ID,Master,Text,From,To

Link,,,,PATRICIA,TROY

Link,,,, PATRICIA,STEVE

Link,,,,TROY,ELIZABETH

Link,,,,TROY,SARAH

Becomes this Visio drawing:

Patr ic ia
Rodman

Steve Melv in Troy Morr is

El izabeth
Dav is

Sarah
Wr igh t

Text file structure
To compose a file that the Visio text import filter can translate, create records of
various types, each containing individual fields. Generally, each line of text in
the file is considered a separate record, and the first field in a record identifies
the record type. In the example file above, there are five “Shape” records and
four “Link” records. Shape and Link are the record types. Each record is divided
into fields by a field separator character. In .csv files, the default field separator
character is the comma; in .txt files, the default character is the tab.

Text delimiters
The Visio import filter interprets anything enclosed in double quotation marks
as text, including numbers and characters that may otherwise have a special
meaning, such as the End-of-Line character. Using text delimiters is optional—
if you do not enclose a text field within quotes, the filter assumes any field that
isn’t a number or special character is text.
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Record delimiters
To begin a new record, type an End-of-Line character, or hard carriage return.
(Press the Enter key on your keyboard.) If a hard carriage return is part of a text
field enclosed in double quotes, it is not interpreted as a record delimiter.

Comment lines
If you want to add comments to the file that aren’t part of the drawing, type a
semi-colon (;) at the beginning of a line, then type your comments. In the ex-
ample above, the comment lines help you remember the order of the fields by
listing the field headings.

Record types
To code a text file for importing into Visio, you should be familiar with the
record types that the Visio text import filter recognizes and the fields used with
each type.

Details about record types and a procedure for converting text files are available
in online help. In Visio, press F1, click Index, then type “record types” or “con-
verting.”

Related topics
Creating organization charts from data files ........................................................... 186
Creating project timelines from data files ............................................................... 190



22
Creating data-driven
shapes and drawings

About data-driven shapes and drawings 

By establishing connections between shapes and database records, you can
create Visio drawings that function as visual representations of data. You can
also generate new masters from database records. Once you’ve established a
shape-record connection, you can pass information back and forth between
Visio and the database and keep the two versions of the data synchronized.

For example:

• From a personnel database, you can generate business cards for all of your
employees.

• From a parts-specifications database, you can generate masters for your em-
ployees to use in drawings.

• By connecting an inventory database to an office space plan, you can track
furniture and equipment. If you delete a chair from the office plan, you also
delete a record from the database.

You can use the Database Wizard to connect Visio drawings to databases cre-
ated in applications compliant with the Open Database Connectivity (ODBC)
standard, a Microsoft interface that allows applications to access, view, and
modify data from a variety of databases. ODBC-compliant applications include
Microsoft SQL Server, Microsoft Access, and Oracle SQL Server.

Before you can connect Visio shapes and drawings to database records, you
must have the appropriate ODBC components and database drivers installed
on your computer. (Choose Complete while installing Visio to install the
ODBC components and drivers.) In addition, the database you want to connect
to must be defined as an ODBC data source.
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Defining a database as an ODBC data source
You can define a database as an ODBC data source through the Windows con-
trol panel. Or you can run the Database Wizard to link a shape or drawing to a
database and define your database as a data source without leaving the wizard.

To define a database as an ODBC data source:

1. From the Windows 95 Start menu, choose Settings > Control Panel.

2. In the Control Panel, double-click the ODBC icon. The icon may be called
32-bit ODBC.

If the icon doesn’t appear, you may have chosen Custom or Minimum when
you installed Visio. To install the ODBC components, begin the Visio instal-
lation process again. Choose Custom for the type of installation, then
choose to install only Database Tools.

3. If you’re using Office 95, in the Data Sources dialog box, the databases that
are set up as data sources appear under User Data Sources. If your database
isn’t listed, click Add.

If you’re using Office 97, in the ODBC Data Source Administration dialog
box, the databases that are set up as data sources appear under User Data
Sources. If your database isn’t listed, click Add.

4. If you’re using Office 95, in the Add Data Source dialog box, select the driver
for the application in which you created your database, then click OK.

If you’re using Office 97, in the Create New Data Source dialog box, select the
driver for the application in which you created your database, then click Finish.

5. In the Setup dialog box for the driver, locate the database you want to link to
a Visio shape or drawing. Supply other information and options as needed,
then click OK.

6. In the Data Sources dialog box, click Close. Click OK.

ODBC Settings
If you connect to databases in multi-user environments, you may want to con-
trol certain ODBC settings, such as how many times the wizard attempts to
update the database or how long it waits before the operation fails.

To control ODBC settings:

1. In Visio, choose Tools > Macro > Database > Database Settings.

2. Choose the number of retries, retry interval, or time out interval you want,
then click OK.

Related topics
About shape-database connections ......................................................................... 197
Connecting shapes to database records ................................................................... 199
Creating drawings that represent database tables ................................................... 199
Creating new masters from database tables ............................................................ 201
Synchronizing drawings and databases ................................................................... 202
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About shape-database connections

When you connect a shape to a database, you actually connect cells in the
shape’s ShapeSheet spreadsheet to fields in a database table. The Database Wiz-
ard lets you choose which ShapeSheet cells link to fields in the database. If no
appropriate ShapeSheet cells exist, the wizard creates new cells in the Custom
Properties section of the ShapeSheet spreadsheet.

As a simple example, assume you had a database for colored blocks that in-
cludes fields for Block Name, Color, Height, and Width. In the Shape Transform
section, the ShapeSheet spreadsheet includes cells for Height and Width. In the
Fill Format section, the ShapeSheet spreadsheet includes a cell called
FillForegnd. In the process of linking a master to the colored blocks database,
you can choose to connect the Height, Width, and FillForegnd cells in the
ShapeSheet spreadsheet to the Height, Width, and Color fields in the database.
Because the ShapeSheet spreadsheet contains no cells that correspond to Block
Name, you can have the wizard create such a cell in the ShapeSheet
spreadsheet’s Custom Properties section.

Values in ShapeSheet cells match values in the database records the cells are connected to.
If you change the shape, you can pass the new values to the database. If you change the
database, you can pass the new values to the shape’s ShapeSheet spreadsheet.
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When it links a shape to a database, Visio also creates a User-defined Cells sec-
tion in the ShapeSheet, if that section doesn’t already exist for the shape. In this
section, the wizard stores information about the primary key for the database
table, which database fields are associated with which ShapeSheet cells, and the
last valid data retrieved from the database. The rows Visio creates include:

• ODBCDataSource, which contains the ODBC data source name.

• ODBCQualifier, which stores the name of the database or directory that con-
tains the linked table. This cell contains a value only for ODBC data sources
in which a single data source can support multiple databases or directories.

• ODBCTable, which contains the name of the linked data source table or
view.

• ODBCKeyField1 to ODBCKeyField5, which contain the names of the fields
(key fields) that comprise the primary key for the linked table.

• ODBCKeyCell1 to ODBCKeyCell5, which contain the names of the custom
properties in the ShapeSheet that are used to store the values for the key
fields named in the ODBCKeyFields cells.

• ODBCLink1, ODBCLink2, and so on (one row per linked field), which specify
which data source table fields correspond to which ShapeSheet cells. Infor-
mation about how Visio evaluates data copied from the field to the cell (that
is, as a string or as a number) is also stored here and, if the number is a mea-
surement, the row includes measurement units.

Information about how Visio evaluates data is stored in the form of numeric
codes. Value (string) is indicated by a 0, Formula (string) is indicated by a 1,
and Number is indicated by 32. For a list of the numeric codes correspond-
ing to measurement units, in the online Visio Automation Reference, search
for “result property.”

• ODBCKeyMirror1 to ODBCKeyMirror5, which contain the last valid key val-
ues used when transferring information to or from the data source. The
wizard monitors these cells to determine which record a shape was linked to
when you changed its key values. Changes to key values in a monitored
shape are reflected in the corresponding data source table record.

• ODBCMirror1, ODBCMirror2, and so on, which store the last valid values re-
trieved from linked data source table fields. There is one ODBCMirror cell
for each cell-field link defined in the ODBCLink cells. The wizard uses these
cells to determine whether values have changed, in the database or shape,
since the most recent synchronization of the data.

Related topics
About customizing shape behavior .............................................................. Visio Help
About data-driven shapes and drawings ................................................................. 195
Connecting shapes to database records ................................................................... 199
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Connecting shapes to database records

The first step in establishing a connection between Visio and a database is to
connect a shape to a database record. You can connect a shape instance, a mas-
ter on the local stencil, or a master on a standalone stencil.

• When you connect a shape instance, no other shapes are affected. If you
make copies of the shape, the copies are also linked.

• When you connect a master on a local stencil (the stencil made up of all the
masters you’ve used in a drawing file), you also automatically connect all in-
stances of that master in the drawing.

• When you connect a master on a standalone stencil (one of the stencils that
came with Visio or one you created), each time you drop the master, the new
instance is also connected.

To connect a shape to a database record: 

1. In Visio, choose Tools > Macro > Database > Database Wizard.

2. On the first wizard screen, click Next.

3. On the second screen, choose Link A Shape To A Database, then click Next.

4. Follow the remaining wizard screens until you’ve completed the connection.

Related topics
About data-driven shapes and drawings ................................................................. 195
About shape-database connections ......................................................................... 197
Creating drawings that represent database tables ................................................... 199
Synchronizing drawings and databases ................................................................... 202

Creating drawings that represent database tables

After you’ve connected a master on a stencil to a database, you can run the
Database Wizard and create a drawing in which each database record is repre-
sented by a shape on the Visio drawing page. When you create a drawing with
one-to-one connections to database records, the wizard launches a drawing
monitor. The monitor manages the connections between the Visio shapes and
database records. If you delete a shape, the monitor informs the database table,
which deletes the corresponding record. If you add a shape, the monitor in-
forms the database table and a record is added. If you change a shape, the
monitor passes on the changes and values in the database table are updated.

When you run the Database Wizard to create a drawing that represents a data-
base table, you can control how the drawing monitor will behave when you
subsequently open the drawing. You can also establish a connection that allows
you to pass changes from the database to the drawing, but not from the drawing
to the database.
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With a global setting that affects all ODBC database-drawing connections, you
can set the drawing monitor to refresh shapes (that is, pass any changes made in
the database to the shapes’ ShapeSheet cells) at regular intervals (the interval
you set depends upon how frequently you update the database). In the Data-
base Wizard, when you’re creating a particular drawing, you have the option of
turning the refresh-interval setting off for a particular master-database table
link. Turning global refresh off for one link doesn’t affect any other links.

In the Database Wizard, you can set an option for opening the
drawing monitor automatically each time you open a drawing
connected to a database. You can also add a Launch Monitor
action to the drawing page so you can launch the monitor by
right-clicking the page and choosing the action command.

To create a drawing that represents a database table: 

1. Run the Database Wizard and connect a master shape to a database record.
Link each database field to a ShapeSheet cell.

2. After the master shape is connected to a database record, choose Tools >
Macro > Database > Database Wizard to run the wizard again.

3. On the first wizard screen, click Next.

4. On the second screen, choose Create A New Linked Drawing Or Modify An
Existing One, then click Next.

5. On the third screen, choose Create A Drawing Which Represents A Database
Table, then click Next.

6. Follow the wizard screens to create the drawing.

TIP  If you want to open an existing drawing that is connected to a database or
add events and right-mouse actions to synchronize the database and drawing,
run the Database Wizard. On the second screen, choose Create A New Linked
Drawing Or Modify An Existing One, and on the third screen, choose the op-
tion you want.

To set a global refresh interval for the drawing monitor:

1. In Visio, choose Tools > Macro > Database > Database Settings.

2. Check Automatically Refresh Drawing Page, type the number of seconds in
the interval, then click Save.



C R E A T I N G  D A T A - D R I V E N  S H A P E S  A N D  D R A W I N G S 2 0 1

TIP  When you run the Database Wizard to create a particular drawing, you
have the option of turning the refresh setting off for a particular master-
database table link.

Related topics
About shape-database connections ......................................................................... 197
Connecting shapes to database records ................................................................... 199
Synchronizing drawings and databases ................................................................... 202

Creating new masters from database tables

Using the Database Wizard, you can generate a set of masters that graphically
represents the records in a database table, then save the masters on a stencil.

For example, if you maintain an inventory database of bookcases that your
company manufactures, you can generate a master for each specific bookcase,
save the masters on a new stencil, then distribute the stencil so everyone in the
company can include bookcase shapes in their drawings and other documents.

If you expect to revise the database table, you can save the connections between
the masters and the database records. Then, when you revise the table, you can
refresh the masters so the values in their ShapeSheet cells match the values in
the database records.

NOTE  If you don’t save the connections, the masters’ ShapeSheet cells contain a
snapshot of the data that existed in the database fields at the time you created
the new masters, but no information about which database records the data
came from. If you make changes to the database, you can’t refresh the existing
masters to reflect the changes. You must run the Database Wizard again and
generate new masters.

To generate new masters from a database table: 

1. In Visio, choose Tools > Macro > Database > Database Wizard.

2. On the first wizard screen, click Next.

3. On the second wizard screen, choose Generate New Masters From A Data-
base, then click Next.

4. Follow the screens until you create the masters.

Related topics
About shape-database connections ......................................................................... 197
Connecting shapes to database records ................................................................... 199
Synchronizing drawings and databases ................................................................... 202
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Synchronizing drawings and databases

When you run the Database Wizard to connect a shape or drawing to a data-
base, you can add right-mouse actions and ShapeSheet events to shapes or to a
drawing page. You can use these actions and events to pass information
between Visio and the database application.

• Right mouse-click actions are available on a shortcut menu that appears
when you right-click a shape or page.

• Events represent Visio’s responses to a user action, such as opening a drawing.

NOTE  If you create a drawing that is a graphical representation of a database
table, you can also use the drawing monitor to pass information between the
drawing and the database.

Right-mouse actions and events

Action or event Added to Result

Refresh shape on-drop event Shape When you drop a master or copy a shape, the values in the linked ShapeSheet
cells for that shape (or instance) are automatically refreshed to match values in
the database.

Select record on-drop event Shape When you drop a master or copy a shape, you’re prompted automatically to
select the database record that links to the shape instance.

Refresh linked shapes on Page Refreshes ShapeSheet cell values for all the shapes in your drawing each
document-open event time you open the drawing.

Refresh based on the NOW Page Allows you to switch on or off refreshing ShapeSheet cell values for all the
function event shapes in a linked drawing at specific intervals as defined by the NOW function.

Select database record action Shape Allows you to select the database record to which you want a shape linked.

Refresh shape cells action Shape Refreshes the values in the shape’s linked ShapeSheet cells to match the values
in the database.

Refresh shapes on page action Page Refreshes the values in the shapes’ linked ShapeSheet cells to match the values
in the database for all the shapes on the drawing page.

Update database record action Shape Updates the values in the database to match the values in the shape’s linked
ShapeSheet cells.

Update shapes on page action Page Updates the values in the database to match the values in the shapes’ linked
ShapeSheet cells for all the shapes on the drawing page.

Delete shape and database Shape Deletes the shape and the database record to which the shape is linked.
record action

Related topics
About data-driven shapes and drawings ................................................................. 195
Connecting shapes to database records ................................................................... 199
Creating drawings that represent database tables ................................................... 199
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About using Lotus Notes with Visio

Visio supports a two-way exchange of data between Visio and Lotus Notes.
You can

• Write data from a Visio shape, a custom formula, or the Properties dialog
box to a Lotus Notes field.

For example, you can combine Lotus Notes and Visio to keep track of a
company’s processes, such as writing and prototyping specifications. In
Lotus Notes, you embed a Visio diagram for each process. Then you create a
table that shows only the titles of the processes (which is data you wrote
from Visio to Lotus Notes). Anyone who needs to see the process can click
the flowchart’s title to see the embedded Visio diagram. Then, to edit it, the
user can double-click the embedded Visio diagram to start Visio.

• Read data from a Lotus Notes Field and display it in Visio.

For example, in a timeline, you can have a Lotus Notes date field automati-
cally update the Visio timeline.

Because of the way Lotus Notes and Visio interact, incompatibilities can arise
when one of the programs is 32-bit and the other is 16-bit. The following com-
binations are compatible:

• 32-bit Visio products and 32-bit Lotus Notes 4.x on any 32-bit Windows
platform.

• 32-bit Visio versions and Lotus Notes 3.x on Windows 95. (This combina-
tion is not compatible on Windows NT 3.51.)

Related topics
Displaying Lotus Notes data in Visio ....................................................................... 205
Writing data from Visio to a Lotus Notes field ....................................................... 204
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Writing data from Visio to a Lotus Notes field

You can pass data from a Visio diagram to a Lotus Notes database field. Each
field in Lotus Notes that contains Visio data is based on either the Visio
diagram’s Properties dialog box, a shape, or a custom formula.

NOTE  Make sure the fields in both programs have exactly the same name.

To include Visio data in a Lotus Notes field: 

1. In Lotus Notes, set up the fields you want to fill in with Visio data. Note the
names of these fields, because you will use them in Visio.

2. Choose Insert > Object, and insert a Visio drawing. You can create a new
Visio drawing or insert an existing file.

3. If the Lotus Notes fields are not based on the drawing’s Properties dialog
box, add the shapes that will be associated with the Lotus Notes fields.

4. Select one of the shapes that will be associated with a Lotus Notes field, then
choose Format > Special. Note the shape’s ID (you’ll use it in step 8).

Complete this step for each shape that will be associated with a Lotus Notes
field.

5. Choose Insert > Lotus Notes Fields, then, for Field Name and Direction,
type a name for the field that exactly matches the name of the field you de-
fined in Lotus Notes.

6. Check Write To Notes.

7. For Data Type, select the type of data you want to exchange: Text, Time, or
Number.

8. If you select Text under Data Type, type the Shape ID from step 4. The data
you write to Lotus Notes can be the shape’s name, text, copyright, or data
you enter in the Data 1, 2, and 3 sections of the Special dialog box.

If you select Time or Number, enter a custom formula in the Custom For-
mula box.

9. Click Add, then click OK.

Here is an example that uses the Number data type (in step 8 above). In the
equation below, “sheet.1” is a shape representing an office plan’s perimeter. The
office plan is set up in inches. The formula multiplies the width and height of
the walls, then divides that total by 144 to get the square footage of the office.

=(sheet.1!Width*sheet.1!Height)/144
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To include the Visio Properties dialog box data in a Lotus Notes field: 

• In Lotus Notes, use field names that correspond with settings in the Visio
Properties dialog box (File > Properties). The Visio drawing’s properties are
then automatically included.

The Properties dialog box fields are Title, Subject, Author, Manager, Com-
pany, Category, Keywords, Description, and Hyperlink Base.

Related topics
Adding data to shapes’ custom-property fields ....................................................... 178
Displaying Lotus Notes data in Visio ....................................................................... 205
Linking shapes and drawings ................................................................................... 130

Displaying Lotus Notes data in Visio

You can read data from a Lotus Notes database field, then display it in a Visio
diagram. You can also use the Lotus Notes field data in formulas.

TIP  You may want to lock the Visio shape in which you place data from Lotus
Notes so that users cannot edit it.

To display data from Lotus Notes in Visio: 

1. In Lotus Notes, set up the fields you will read into Visio. Make sure you note
the names of these fields, because you will use them in Visio.

2. In Visio, open or create a drawing with which you want to exchange data
with Lotus Notes.

3. Choose Insert > Lotus Notes Fields, then, in the Field Name and Direction
section, type a name for the field that exactly matches the name of the field
you defined in Lotus Notes.

4. Check Read From Notes.

5. In the Data Type section, select the type of data you want to exchange: Text,
Time, or Number.

For Number, choose the units for the number (such as centimeters) so that
the user knows how to interpret the number. For example, a number might
represent inches or centimeters; the distinction for the user may be very
significant.

6. Click Add, then click OK.

7. Follow one of the next procedures to either insert the Lotus Notes field in a
shape as a text field or insert it in a shape’s ShapeSheet spreadsheet.
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To insert a Lotus Notes field in a shape as a text field: 

1. Select the shape in which you will insert the Lotus Notes data.

2. Press F2 to open the shape’s text block, then place the insertion point where
you want to insert the data.

3. Choose Insert > Field.

4. Under Category, select Lotus Notes Field. Under Field, select the specific
Lotus Notes field. Under Format, select the way you want to view the data,
then click OK.

Data is passed between Visio and Lotus Notes when the programs are
started, so the next time you open this Visio drawing file, these fields will in-
clude data from the Lotus Notes fields you inserted.

To insert a Lotus Notes field into a shape’s ShapeSheet spreadsheet: 

1. Select the shape, then choose Window > Show ShapeSheet.

2. Select the cell in which you want to insert the Lotus Notes field, place the in-
sertion point in the formula bar, then choose Insert > Function.

3. Under Select Function, choose LOTUSNOTES, then click OK.

4. In the edit area, for “notename,” type the name of the Lotus Notes field.

Data is passed between Visio and Lotus Notes when the programs are
started, so the next time you open this Visio drawing file, the ShapeSheet will
include data from Lotus Notes.

Related topics
About protecting shapes and files ............................................................................ 173
Embedding shapes and drawings ............................................................................ 128
Writing data from Visio to a Lotus Notes field ....................................................... 204
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About creating your own shapes

There are several ways to create your own shapes. You can

• Draw a shape from scratch using the Visio drawing tools. For example, if you
want to add a freeform arrow to a block diagram, you can draw the arrow
with the freeform tool.

• Merge a shape with other shapes to create a new, unique shape. For example,
if you want to create a round sign with an arrow cut out of its center, you can
place an arrow shape on top of a circle, then use the Combine command to
create the shape you want.

• Revise an existing Visio shape. For example, if your company uses a special
Process shape in its flowcharts, you can modify the Visio Process shape, save
it on the Flowchart stencil, and use it in all the flowcharts you draw.

You can revise an individual shape for use in a specific drawing, or you can re-
vise all instances of a shape in a drawing at the same time. You can also convert
a new shape you create into a master and place the master on a stencil so you
can reuse the shape in many drawings.

Related topics
Creating master shapes ............................................................................................. 222
Drawing shapes ......................................................................................................... 208
Merging shapes to create new ones .......................................................................... 210
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Drawing shapes

To draw a shape, use one or more of the drawing tools on the Standard toolbar.
While you’re drawing shapes, you can use the View > Toolbars > Toolbars com-
mand to hide other toolbars and display only the Standard toolbar

TIP  When drawing shapes, it’s often helpful to use guides and grid lines to help
you position the shapes.

Drawing lines or arcs
( ) If you move the pencil tool in a straight line, it draws a line. If you move it
in a curve, it draws an arc. Each arc is a portion of a circle; its size is determined
by the distance you move the mouse.

( ) The line tool is best for drawing shapes composed only of straight lines. To
constrain a line to any 45-degree angle, hold down the Shift key as you drag.

( ) The arc tool draws arcs that are always one quarter of an ellipse. The direc-
tion you drag the mouse determines which way the arc bows.

To draw a line or an arc:

1. Choose the pencil tool from the Standard toolbar.

Or choose the line tool or the arc tool.

2. Point to where you want to start the line or arc.

3. Drag to draw the line or arc, then release the mouse button.

Drawing freeform shapes
( ) The freeform tool works like a pencil on paper. Select it and drag to draw
splines and freeform curves. For smoother curves, turn snapping off before you
draw (choose Tools > Snap & Glue, then under Currently Active, uncheck Snap).

To draw a freeform shape:

1. Choose the freeform tool from the Standard toolbar.

2. Hold down the left mouse button as you drag in various directions to draw a
freeform shape, then release the mouse button.

Drawing rectangles and squares
( ) The rectangle tool draws rectangles and squares.

To draw a rectangle or square:

1. Choose the rectangle tool from the Standard toolbar.

2. Point to where you want a corner of the shape.

3. Drag until the shape is the size you want, then release the mouse button.

To draw a square, hold down the Shift key as you drag.
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Drawing ellipses and circles
( ) The ellipse tool draws ellipses and circles.

To draw an ellipse or circle:

1. Choose the ellipse tool from the Standard toolbar.

2. Point to where you want to start drawing the shape.

3. Drag until the shape is the size you want, then release the mouse button.

To draw a circle, hold down the Shift key as you drag.

Drawing shapes with multiple segments
Shapes with multiple segments are 2-D shapes. To draw a 2-D shape, start each
new segment at one of the endpoints or at a vertex of another segment. After
you complete a shape, you can add, adjust, or delete segments.

A
B

To draw a shape with multiple segments:

1. Choose the pencil tool ( ) from the Standard toolbar.

Or, choose the line tool ( ), arc tool ( ), or freeform tool( ).

2. To draw the first segment, point to where you want to start the shape. Press
the mouse button and drag until the segment is the size you want, then re-
lease the mouse button. This first segment is a 1-D shape with endpoints.

3. To draw the second segment, point to the endpoint of the first segment (the
pointer looks like a plus sign) and drag, then release the mouse button.

When you are creating the second and subsequent segments, be careful not
to click the endpoint of the first segment, which selects it. A selected end-
point turns magenta. Dragging the selected endpoint resizes the existing
segment instead of starting a new one. (If you resize a segment, rather than
draw a new one, choose Edit > Undo.)

After you draw the second segment, the shape displays vertices instead of
endpoints, to indicate that it’s a 2-D shape.

4. To draw additional segments, point to the vertex at the end of the last seg-
ment you added, then drag to draw the next segment.

5. If you want to close the shape, drag the endpoint of the last segment you cre-
ate over the vertex at the beginning of the first segment, then release the
mouse.

TIP  You can use the freeform or ellipse tool to create a closed shape that is
composed of only one segment.

Endpoints (AAAAA and BBBBB)

Vertices (AAAAA) and control points (BBBBB)

A B
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To undo a segment while drawing:

• Before you release the mouse button at the end of a segment, draw back to
the vertex at the beginning of the segment. Make sure you hit the vertex pre-
cisely or you might not completely delete the segment.

To undo several segments:

• After you’ve drawn one or more segments, but before you do anything else,
choose Edit > Undo. Keep choosing Undo until you’ve deleted all of the seg-
ments you no longer want. Segments are deleted in the reverse order in
which they were drawn. By default, you can undo up to ten actions.

You can also undo an action, such as drawing a segment, by clicking the
Undo button on the Standard toolbar, or pressing Crtl+Z or Alt+Backspace.

Related topics
About formatting shapes ............................................................................................ 49
Merging shapes to create new ones .......................................................................... 210
Revising existing shapes ........................................................................................... 216
Using shape handles ................................................................................................... 32

Merging shapes to create new ones

The easiest way to create a complex shape is to draw its simple parts, then use
the Boolean operation commands to merge the parts into one complex whole.
The result of a merge operation depends partly on the shape you select first (the
primary shape). The primary shape’s formatting is used in the resulting shape,
and, in some cases, it even determines the shape of the new shape (with the
Subtract command, for example). You can also use Boolean operation com-
mands to convert polygonal lines and polygons to lines, arcs, and freeform
curves (or “splines”).

Merging operations create new shapes. The old shapes, including ShapeSheet
spreadsheets that define smart behavior, are discarded. The new shape gets its
own ShapeSheet spreadsheet.

Union
Union creates a new shape from the perimeter of two or more overlapping
shapes. The new shape is a set of all the points that were either in one original
or another. Union is the equivalent of the Boolean operator “OR.”

NOTE  Take care not to use the Union command when you simply want to
group shapes together. Group and Union are two separate operations in Visio
and do not produce the same results. Union is also different from Combine,
which deletes areas where the combined shapes overlap.

Union
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To unite shapes:

1. Arrange the shapes that you want to unite on the drawing page.

2. Select the shapes.

(Remember that the new shape will inherit the text and formatting of the
first shape you select.)

3. Choose Shape > Operations > Union.

NOTE  If the shapes do not overlap, the Union command creates one shape, but
the shapes appear unchanged. If a shape is open, Visio discards the open shape
when you choose Union.

Subtract
Subtract creates a new shape by “subtracting” from the primary selection the
areas where subsequent selections overlap. For example, if you overlap a square
and a circle and select the square, then the circle, Subtract will remove the over-
lapping segment of the circle from the square.

To subtract shapes:

1. Arrange the shapes you want to subtract on the drawing page.

2. Select the shapes.

(Remember that Visio subtracts from the first shape you select.)

3. Choose Shape > Operations > Subtract.

Intersect
Intersect forms a new closed shape from the area where selected shapes overlap,
eliminating non-overlapping areas. Because Visio doesn’t define specific points
on a line, nothing is left if you intersect two overlapping lines.

To intersect shapes:

1. Arrange the shapes you want to intersect on the drawing page.

2. Select the shapes.

(Remember that the new shape will inherit the text and formatting of the
first shape you select.)

3. Choose Shape > Operations > Intersect.

Fit Curve
Use the Fit Curve command to create a spline from a polygonal line. The spline
goes exactly through the polygonal line’s vertices. If the polygonal line is a
closed polygon, the result is a periodic (seamless) spline.

To create a spline from a polygonal line:

1. Select the polygonal line.

2. Choose Shape > Operations > Fit Curve.

Subtract

Intersect

Fit Curve
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Custom Fit
Use the Custom Fit command to reduce the number of segments in clip art or
other shapes you import. Custom Fit makes an imported shape easier to edit
and may reduce its size.

When a shape is imported, the exchange process converts it into a relatively un-
intelligent format. For example, an imported clip art shape is a dense series of
points that is almost impossible to edit. Using the Custom Fit command, you
can convert polygonal lines into splines. By dragging the control points on a
spline, you can edit the converted clip art shape.

When you use the Custom Fit command, you can specify the error tolerance.
The more loosely you set the tolerance (that is, the greater the acceptable error),
the more likely you are to reduce the size of the converted shape.

Some shapes on which you use the Custom Fit command occupy less disk space
because Custom Fit replaces the many LineTo rows in the shape’s ShapeSheet
spreadsheet with fewer SplineKnot rows. When enough LineTo rows are
replaced, the shape requires less disk space.

To convert an imported object into an editable format:

1. Select the shape. If the shape is a group, choose Shape > Grouping >
Ungroup to ungroup it.

2. Choose Shape > Operations > Custom Fit.

3. Choose the options you want, then click OK.

A
B
C

D

A Check to create a periodic (seamless) spline if the original shape is closed and smooth. If
Cusps And Bumps is unchecked, the original shape need not be smooth.

B Check to replace polygonal line vertices with either line segments or circular arcs. For this
option to work, the polygonal line vertices must be close to a line segment or circular arc
within the specified tolerance.

C Check to preserve sharp angles and other features in the original shape.
D Type a tolerance value. The looser the tolerance (that is, the higher the amount of error tol-

erated), the simpler (less data, smaller disk size) the arc or spline. Zero tolerance results in
no reduction in data. The typical error tolerance for converting clip art should be about 0.1
mm (.004 inches).

If you check Periodic Splines, uncheck Circular Arcs and Cusps and Bumps, and type an
Error Tolerance of zero, you convert a polygonal line to a spline that goes exactly through the
polygonal line’s vertices. If the polygonal line is closed (that is, if it’s a polygon), the result is a
periodic spline. These particular Custom Fit settings are equivalent to choosing the Fit Curve
command.
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Fragment
The Fragment command can break a shape into smaller parts. You can also use
it to create new shapes from intersecting lines or from 2-D shapes that overlap.
The Fragment command provides an ideal way to create Venn diagrams and
marketing pyramids. Fragment can:

• Divide selected shapes into smaller shapes.

• Create a new closed shape where two or more closed shapes overlap.

• Create new shapes from the enclosed spaces of three or more intersecting
lines.

To break a 2-D shape into smaller parts:

1. Draw lines through the shape where you want to break it.

2. Select the shape and the lines.

3. Choose Shape > Operations > Fragment.

To create new shapes where 2-D shapes overlap or where lines
intersect:

1. Select the overlapping shape or intersecting lines.

2. Choose Shape > Operations > Fragment.

TIP  After you fragment shapes, delete the pieces you don’t need.

Trim
You can create new shapes from existing intersecting shapes by trimming them.
Trim resembles the trim operation in Autodesk AutoCAD, although in Visio
you can trim more than two objects. Trim splits selected objects at their inter-
sections, including where a shape intersects itself. It creates a new shape for each
piece, preserving the styles. If closed shapes are split open, they lose their fill.

To trim shapes:

1. Select the shapes you want to trim.

2. Choose Shape > Operations > Trim.

Join
Join assembles individual 1-D segments into one or more continuous paths.
The number of paths depends upon the configuration of the selected shapes.
For example, if the segments lie along a straight line, the new shape will have
one path. If the segments lie in the form of a 2-D shape such as a rectangle, the
new shape will become a closed 2-D shape that you can fill.

Trim

Join

Fragment
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To join shapes:

1. Select the segments you want to join.

2. Choose Shape > Operations > Join.

Combine
Combine creates a new shape from selected shapes. If the selected shapes over-
lap, Visio cuts out, or discards, the area where they overlap. This creates holes in
the new shape that make the drawing page grid visible through the shape. Com-
bine converts multiple shapes into one shape with multiple paths, represented
by the same number of geometry sections in the ShapeSheet spreadsheet
(rather than multiple ShapeSheet spreadsheets).

You can also combine 1-D shapes with each other and combine 1-D and 2-D
shapes. In these cases, Visio creates one shape from the selected shapes, but the
new shape might not look different from the old ones. The difference is that the
new shape has one ShapeSheet spreadsheet with multiple sections so that when
you apply a style, such as a fill, the style formats the entire shape. This is differ-
ent from using the Group command, where each shape in the group retains its
own ShapeSheet spreadsheet, in addition to the group’s ShapeSheet spread-
sheet.

NOTE  Take care not to use the Combine operation when you simply want to
group shapes together. Group and Combine are two separate operations in
Visio, and do not produce the same results. Combine is also different from
Union, which creates a new shape from the perimeter of two or more overlap-
ping shapes, without deleting any areas of the shapes.

For example, to create a picture frame shape (a rectangle with a hole in the
middle through which you can see what’s beneath), place a small rectangle in
the middle of a larger one. Select the large rectangle first, then the small one,
and then choose Shape > Operations > Combine to combine them.

To combine shapes:

1. Arrange the shapes you want to combine on the drawing page.

2. Select the shapes.

(Remember that the new shape will inherit the shape and formatting of the
first shape you select.)

3. Choose Shape > Operations > Combine.

Related topics
Revising existing shapes ........................................................................................... 216
Working with shapes in groups ................................................................................. 42

In this example, selecting the large
rectangle first makes it the primary shape,
so that when the two rectangles are
combined, the small rectangle will be
discarded, leaving a hole in the large
rectangle.
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Offsetting shapes to create parallel lines and curves

The Offset command creates a set of parallel lines and curves to the right and
left of the original shape. For example, you can create a representation of a two-
way road by offsetting a line.

You can set the distance you want between the original shape and the offset
shapes.

The Offset command reproduces the points of a line at a fixed distance from
the line and then attempts to connect those lines, based on where they intersect.
If the offset lines don’t intersect, Visio extends them until they do.

A

B

When creating an offset shape such as the one left of this angle (A), Visio extends the
duplicate lines to make them meet.

When creating an offset shape such as the one right of this angle (B), Visio deletes a portion
of the duplicated lines to prevent them from crossing.

A
B

In this example (A), extending the arc and the line doesn’t result in an intersection, so Visio
creates offset duplicates of each shape and leaves them unconnected.

If the offset is wide, especially inside curves, the offset may not look like the original (B).

Once you’ve offset a shape, the two new shapes each have their own ShapeSheet
spreadsheets and you can work with them independently. For example, if you
only want one duplicate, you can delete the other.

The Offset command positions the offset
shapes on either side of the original shape,
at a distance that you specify.
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To create an offset shape: 

1. Select the shape from which to create the offset shape.

2. Choose Shape > Operations > Offset.

3. Type a value for the distance you want between the duplicate and the origi-
nal, then click OK.

Related topics
Duplicating shapes ...................................................................................................... 47

Revising existing shapes

You can revise any Visio shape or shape you draw from scratch as long as the
shape isn’t locked to prevent changes.

To revise a shape, select it with the pencil tool ( ), then drag, add, or delete
vertices. To change curves, drag a control point or a point’s eccentricity handles.

                       A

B

C

To reshape a shape, you can drag a vertex (A), add, then drag, a vertex (B), or drag control
points to edit curves (C).

A

    
A

Deleting vertex A in either of these shapes deletes the segment with which the vertex is
associated. The remaining segments are reshaped accordingly.
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Methods for revising shapes

To Do this after selecting the shape with the pencil tool

Select a vertex or control point Click the vertex or control point you want to select. The selected item turns
magenta.

Reshape angles Select one or more vertices and drag. (Hold down the Shift key to select more
than one.)

Add a segment Point to where you want to add a segment, hold down the Ctrl key, and click.

Delete a segment Select a vertex associated with the segment you want to delete, then press the
Delete key.

Change the curvature of an arc or Drag a control point until the segment looks the way you want.
freeform curve

Change the eccentricity (or symmetry) Select a control point, hold down the Ctrl key, and drag the pointer slightly away
of an arc from the point to display the eccentricity handles, then release the mouse button.

Drag one handle farther from or closer to the control point or rotate it around the
control point until the arc is shaped the way you want.

Move the end of a freeform curve Select the curve, then drag a handle associated with the curve’s endpoint.

TIP  If you select a shape with the pencil tool and don’t see any vertices or con-
trol handles, the shape is probably a group. To find out if the shape is a group,
select it, choose Format > Special, then check the Special dialog box to see if
Group is listed for Type. To revise the group, select it, then choose Edit > Open
Group. A group window opens in which you can revise the shape using the
pencil tool.

Related topics
About protecting shapes and files ............................................................................ 173
About formatting shapes ............................................................................................ 49
Using shape handles ................................................................................................... 32
Working with shapes in groups ................................................................................. 42

Revising several identical shapes at once

When you create a drawing, Visio creates a stencil specific to that drawing file
called the “local stencil.” Each time you drag a master to the drawing page, Visio
copies the master to the local stencil, and then creates an “instance” of the mas-
ter on the drawing page. Instances inherit formatting and other properties from
masters on the local stencil.
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In the local stencil, you can

• Track which shapes you’ve used in your drawing.

• Quickly revise all instances of a shape on all pages in a drawing file by revis-
ing the master on the local stencil.

• Save the local stencil as a standalone stencil so you can distribute it to others
who want to use the shapes in other drawings.

• Add shapes to the local stencil directly to make them easier to reuse later.

To open a local stencil and display the shapes you’ve used in your
drawing: 

• Choose Window > Show Master Shapes.

Revising all shape instances at once
Local stencils provide a way for you to update all instances of a shape at once.
Each shape instance in a drawing is linked to its master in the local stencil, so to
change all shape instances at once, you simply modify the master. For example,
in an organization chart, if you want to change the color of all the Position
shapes’ text to blue, you can simply modify the Position master on the local
stencil. All instances of the Position shape in the drawing inherit the changes.

Shape instances in the drawing remain linked to their masters in the local stencil
unless you perform an action that severs the link, such as ungrouping the shape in
the drawing. In this case, a message appears onscreen letting you know the action
will sever the link, and you can choose to continue or cancel the action.

NOTE  In some cases, applying local formatting to a shape instance on the draw-
ing page may break that individual attribute’s link to the master on the local
stencil. For example, if you resize an instance on the drawing page and then, in
the local stencil, size its master, all instances except the one you resized manu-
ally inherit the new size.

To revise a master on the local stencil and all of its instances on the
drawing page:

1. Open the drawing you want to modify, and choose Window > Show Master
Shapes.

2. Click the local stencil’s title bar to make sure it’s the active window, then
double-click the master you want to modify to open it in the master drawing
window.

3. In the master drawing window, revise the master.

When you’re finished revising, close the master drawing window by clicking
the close box. When Visio asks if you want to update the master and its in-
stances, click Yes.

The instances of the shape update to show the changes.

When you first open the local stencil, it
lines up along the left side of the screen.
You can drag the stencil’s title bar to move
it anywhere you want, and you can drag a
side or corner to change the stencil’s size.
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Saving a local stencil for use in other drawings
You can save a local stencil as a standalone stencil (.vss) file. After you save it,
you can use it with any drawing, or distribute it, just as you do stencils that
come with Visio products.

To save a local stencil as a standalone file:

1. Click the local stencil’s title bar to make it the active window.

If the local stencil isn’t open, display the drawing to which it’s associated,
then choose Window > Show Master Shapes.

2. Choose File > Save As, then, in the Save As dialog box:

Under Save In, find the folder in which you want to save the stencil. (If you
save the stencil in a Solutions sub-folder, it appears when you choose File >
Stencils.)

Under File Name, type a name for the stencil.

Under Save As Type, select Stencil (*.vss).

Under Save, uncheck the Workspace box if it’s checked.

3. Click Save.

Adding shapes to the local stencil
You can add shapes you draw to the local stencil. Not only does this make revis-
ing instances of those shapes easier, it also makes it easy to quickly reuse a shape
by dragging it from the local stencil. If you plan to add a shape you draw to the
local stencil, it’s best to do so before duplicating and copying the shape—revis-
ing the shape on the stencil doesn’t revise copies of the shape that are on the
page before you add the shape to the local stencil.

To add a shape to the local stencil:

1. Open the local stencil by choosing Window > Show Master Shapes. To
arrange the windows, choose Window > Tile.

2. Press Ctrl, then drag the shape and drop it onto the local stencil.

TIP  To align the new master shape icon with the existing ones, right-click
the green stencil background, then choose Arrange Icons.

Related topics
Creating new templates ............................................................................................ 142
Displaying, moving, and adding stencils ..................................................................... 8
About creating your own shapes ............................................................................. 207
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Creating shapes for charts

Most charts use bars or lines to compare amounts or indicate change. By creat-
ing an extendable or stackable shape, you can show an amount and at the same
time add special effects to charts. For example, you can use the People shape in-
cluded with Visio to indicate an increase in employees. When you stretch the
shape, the people duplicate. Or you can use the Growing Flower shape to indi-
cate a company’s growth. When you stretch the shape, the flower’s stem grows
longer.

Visio includes stackable shapes, such as People and Stack Of Papers, and ex-
tendable shapes, such as the Growing Flower and the Pencil. You can also create
your own stackable or extendable shapes.

Stackable shapes
You can create a stackable shape from any Visio shape or piece of clip art.
Stackable shapes can stack horizontally or vertically. You can fix the number of
shapes in a stack or make the number change as the stack is stretched. Shapes in
a stack can have spaces between them and their alignment can vary.

To create a stackable shape:

1. Drop the shape you want to stack onto the drawing page. Make sure the
shape is selected.

2. Choose Tools > Macro > Business Diagram > Chart Shape Wizard.

3. On the first wizard screen, click Next. On the second screen, choose
Stackable Shapes, then click Next.

4. On the third screen, choose the options you want. Click More Info if you
need help with an option.

NOTE  The higher the value you enter for Number Of Shapes, the more disk
space the drawing will occupy. For each shape in the stackable shape, Visio
adds a new Geometry section to the ShapeSheet spreadsheet.

5. On the last wizard screen, click Finish.

TIP  You can modify a stackable shape after you’ve created it. Right-click the
shape, then choose Configure to change the height, the width, the offset be-
tween the shapes, or the stack’s background color.

When you increase the size of a stackable
shape, the shape duplicates itself.
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Extendable shapes
The extendable shapes that you create can be two- or three-part shapes. Each
part can be a shape from a Visio stencil, a shape you draw, or a piece of clip art.
Where you place the parts determines which part extends. In a two-part shape,
the left (for horizontal shapes) or bottom (for vertical shapes) part extends. In a
three-part shape, the middle part extends. Simple shapes make the best extend-
able parts. Complex shapes may distort when they extend. Extendable shapes
can be solid or they can include gaps between the parts.

To create an extendable shape:

1. Assemble the parts of the extendable shape you want to create. Place the ex-
tendable part on the left, for a two-part shape, or in the middle, for a
three-part shape. Click the drawing page to make sure no shapes are se-
lected.

2. Choose Tools > Macro > Business Diagram > Chart Shape Wizard.

3. On the first wizard screen, click Next. On the second screen, select Extend-
able Shapes, then click Next.

4. On the third screen, choose the options you want, then click Next.

5. Follow the instructions in the Select Shapes dialog boxes.

6. On the last wizard screen, click Finish.

TIP  You can modify an extendable shape after you’ve created it. Right-click the
shape, then choose Configure to change the height, width, or spacing between
the parts.

To create an extendable shape from parts of a single shape:

1. Drop the single shape you want to use onto the drawing page.

2. Select the shape, then choose Edit > Copy.

3. Choose Edit > Paste Special.

4. Choose Windows Metafile Data, then click OK.

5. Repeat steps 3 and 4 to make more Windows Metafile copies of the original
shape. Make two copies if you’re creating a two-part extendable shape. Make
three copies if you’re creating a three-part extendable shape.

6. Choose the crop tool from the Tools toolbar and crop each Windows
Metafile copy until it looks like the part of the extendable shape you want it
to represent.

7. Choose Tools > Macro > Business Diagram > Chart Shape Wizard. Follow
the steps described above for creating an extendable shape.

Related topics
Creating master shapes ............................................................................................. 222

When you increase the size of an extend-
able shape, only one part of the shape
extends.
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Creating master shapes

If you want to create a new shape and reuse it in many drawings, create the
shape as a master. To create a master, you can

• Convert a shape to a master by moving it onto an existing Visio stencil or
onto a new stencil you create.

• Develop a new master from scratch.

• Revise an existing master.

Before you can create a master, you must open a stencil as an original file, with
read/write access. Normally, stencils open with read-only access. To work with a
read-write stencil while maintaining the original, open a copy of the original.

The masters supplied by Visio Corporation are copyrighted. You may copy and
reorganize them for your own use, modify them for your own use, and distrib-
ute drawings that contain them. You may not sell or distribute original or
modified Visio masters (or “SmartShapes symbols”).

To open an original stencil: 

NOTE  You cannot open an original stencil if a read-only copy of the stencil is
open already. If a read-only copy of a stencil is open, close it, then open the
original.

1. Choose File > Stencils > Open Stencil.

You can also click the open stencil button ( ) on the Standard toolbar.

2. Open the folder that contains the stencil you want.

3. Select the stencil to which you want to add the new shape.

4. Click Original in the Open section, then click Open.

The stencil window opens, undocked, with read/write access.

TIP  To open a copy of the original stencil, click Copy instead of Original in
step 4.

Converting shapes to masters
You can use shapes you draw or revise, or objects from other applications, as
masters. You may not be able to edit an object, however, in all the ways you can
edit a Visio shape.

When you drag a shape to a stencil, a master shape icon based on the shape and
a default name for the master appear in the stencil window. You can then name
the master, align its name, choose options for the icon size, and write a prompt
that provides information about how to use the master.
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To convert a shape to a master:

1. In the drawing window, display the shape you want to convert to a master, or
draw a shape to convert.

2. Open the stencil file in which you want to store the new master.

Make sure to open the original stencil or a copy.

3. Click the drawing page to make it active, then drag the shape from the draw-
ing page and drop it on the stencil. You can create a copy of the shape by
holding down the Ctrl key while you drag.

The shape icon appears, with a label “Master.X,” where X is a number repre-
senting the number of shapes on the stencil.

4. Choose View > Arrange Icons.

Visio rearranges the existing icons to align the new icon.

5. Choose File > Save to save the changes to the stencil.

Developing masters from scratch
When you develop a master from scratch, you can change or specify the way the
master displays in the stencil. For example, you can rename the master’s icon
and choose options for how the name aligns.

TIP  You can also change the way any master on an original stencil displays by
right-clicking the master and choosing Properties.

To develop a new master from scratch:

1. Open the stencil file to which you want to add a master or open a blank stencil.

Make sure to open the original stencil or a copy.

2. With the stencil selected, choose Master > New Master.

3. Specify characteristics for the master:

In the Master Name section, specify the name of the new master and how to
align the name.

In the Icon section, choose an option for the size and how to update the
master shape icon.

In the Prompt section, type information about the master that appears when
you point to it.

For Match Master By Name On Drop, check to preserve the formatting
you’ve applied to the stencil’s masters.

4. Click OK.

A blank master shape icon appears in the stencil window. (You may need to
scroll to see it.)

5. Choose Master > Edit Master, or double-click the master to open the master
drawing window.
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6. Create the master.

You can create it just as you would in a regular drawing page by using shapes
from different stencils, drawing the shape with the drawing tools, or pasting
an object from another application.

7. Click to close the master drawing window. When Visio prompts you to up-
date the master, click Yes.

8. While the stencil is still active (that is, the stencil title bar is blue), choose
File > Save to save the changes to the local stencil.

Related topics
Creating shapes for charts ........................................................................................ 220
Revising existing masters .......................................................................................... 224

Revising existing masters

You can revise the way an existing master will look when you drop it on the
drawing page by dragging, adding, or deleting vertices, or by editing the
master’s text. For example, you can add arms to an office chair master or change
its model number.

To revise every instance of a master in a drawing, edit the master stored in the
local stencil. When you edit the master locally, you change each instance of the
shape in the drawing file. You do not, however, change the master in any
standalone stencil you may have used to create the drawing.

You can also revise a master on a standalone stencil so that every time you use
that stencil to create a drawing, the revised master appears on the local stencil.

If you no longer need a master, you can delete it. Deleting a master breaks the
connection between the master and any instances in a drawing.

To revise the way a master will look on the drawing page: 

1. To revise a master on the local stencil, make sure the drawing window is ac-
tive by clicking the title bar, then choose Window menu > Show Master
Shapes to display the local stencil.

To revise a master on a standalone stencil, open the stencil as an original or
as a copy that contains the master you want to change, then click in the sten-
cil window to make it active.

2. Double-click the icon of the master you want to edit, or select it, then choose
Master > Edit Master.

The master opens in the master drawing window.
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3. To modify the master, use the same tools and techniques that you use to cre-
ate and edit shapes in a drawing.

4. When you’ve finished revising the master, click the close box to close the mas-
ter drawing window.

To delete a master: 

1. Open the stencil file that contains the master you want to delete.

Make sure to open the stencil as an original or a copy.

2. Select the stencil window, then select the master.

3. Choose Edit > Clear.

When Visio prompts you, click OK to delete the master or Cancel to cancel
the deletion.

4. Choose File > Save.

Related topics
Creating master shapes ............................................................................................. 222
Drawing shapes ......................................................................................................... 208
Revising existing shapes ........................................................................................... 216

Saving shapes you create on stencils

It’s worthwhile to create a new stencil if

• You’ve created shapes of your own that you plan to reuse or share with others.

• You frequently use shapes from several different Visio stencils, and you want
to consolidate them on one stencil.

Creating a custom stencil involves either adding or deleting shapes from an ex-
isting Visio stencil, or building an entirely new stencil using shapes that you
create from scratch and save in the stencil file.

There are two types of stencils:

• A standalone stencil is a stencil file with the extension .vss that can be
opened separately or with a template. If you save a stencil with a template,
the stencil opens with the template, along with a drawing page that has the
scale, styles, and other features appropriate for the shapes on the stencil.

When you add or edit masters in a standalone stencil, the new or revised
masters become available for any new drawing you create using that stencil
or a template that opens the stencil. Instances of the masters in existing
drawings are not affected.
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• A local stencil is a stencil stored in a drawing file. It contains copies of the
masters used in that drawing file.

When you add or edit masters in a local stencil, the changes affect only that
drawing file. The masters are linked to their instances in the drawing, so
changes you make to masters in a local stencil are reflected in each instance
of the shape in the drawing.

Methods for creating new stencils

To Do this

Base a new stencil on an existing stencil Choose File > Stencils > Open Stencil. In the Open Stencil dialog box, open the
folder that contains the stencil on which you want to base the new stencil. Select
the stencil and, in the Open section, click Copy. Click the Open button.

Create a new stencil from scratch Choose File > Stencils > Blank Stencil.

Create a new stencil from a drawing With the local stencil window selected, choose File > Save As, type the file name
file’s local stencil you want, choose Stencil (*.vss) for Save As Type, then click Save.

Copy a master from one stencil to Open both stencils, then drag the master from one stencil to another.
another

Move or copy a shape from the drawing To move the shape, drag it from the drawing page to the stencil. To copy the shape,
page to a stencil hold down the Ctrl key as you drag the shape.

Change the order of the stencil’s icons Open the original stencil file, then drag each master shape icon to arrange them in
the order you want.

Align the icons in rows on the stencil Open the original stencil file, then choose View > Arrange Icons to align the icons
vertically and horizontally.

Set the stencil so that its icons stay in Open the original stencil or a copy, then right-click the stencil and choose Auto
rows even when the window is resized Arrange from the shortcut menu.
or when icons are added or deleted

Save a new stencil as a local stencil Save the drawing that includes the local stencil. The stencil is stored in the drawing.
Choose File > Save As, choose Drawing (*.vsd) for Save As Type, name the file,
then click Save.

Save a new stencil as a standalone stencil Click the stencil title bar to make it active. Choose File > Save As. For Save As
Type, choose Stencil (*.vss), name the file, then click Save.

Related topics
Creating master shapes ............................................................................................. 222



25
Adding hyperlinks
to shapes and drawings

About using hyperlinks

You can add a hyperlink, or jump, to each Visio shape and drawing page. The
link can jump to

• Another page in the same Visio drawing.

• Another Visio drawing.

• A non-Visio document.

• A World Wide Web location (URL).

For example, from a process shape in a flowchart, you can jump to a drawing
page that shows the detailed steps the process involves.

After you add a link, right-click the shape or drawing page and choose
Hyperlink > Open to jump to the destination. In full-screen view, you can click
the shape or page to open the hyperlink. (Keep in mind that, for the URL links
to work, you must have a Web browser installed on your computer.)

If you intend to save a drawing as HTML pages using the Save As HTML add-
on, you can preserve your hyperlinks as image maps.

In a Web browser, the linked shapes will be “hot.” (Links to other Visio drawing
pages remain active in the HTML file only if you save the page that the shape is
linked to, as well as the page the linked shape is on, in HTML format.)

You can also paste objects created in other applications into Visio drawings as
hyperlinks and paste Visio shapes and drawings into other documents as
hyperlinks.

Related topics
About converting shapes and drawings to HTML ................................................. 119
Saving drawings as HTML pages ............................................................................. 120



2 2 8 C H A P T E R  2 5

Adding, modifying, and deleting hyperlinks

When you add a navigational link, or “jump,” to a shape or drawing page, you
can navigate to the link by right-clicking the shape or page, then choosing
Hyperlink > Open. Once you’ve added a link to a shape or page, you can
modify or delete the link.

Relative versus absolute paths to hyperlinks
When you link a shape or page, you can decide whether the path to the link
should be relative or absolute. A relative path describes the location of the
linked file in relation to the Visio drawing or a hyperlink base. You can move
the Visio drawing and the linked file together (that is, move the entire path
structure) without breaking the link. An absolute path spells out the exact loca-
tion of the linked file in terms of drives, directories, and folders. You can move
the Visio drawing file without affecting the link but if you move the linked file,
you must reset the path. To specify an absolute path, uncheck Use Relative Path
For Hyperlink.

A

B

C

D

E

F

You can create a hyperlink to a Visio drawing, a Web site, or another
document, such as an Excel spreadsheet.

A Specifies the file or Web site you want to
link to. You can either type in a path or URL
or click Browse and navigate to the file or
Web site. If you are using a relative path,
you can type the name of the file.

B Indicates the full or relative path to the file
or URL. Visio updates this path as you type
data in the dialog box.

C Indicates the base path, which you can
specify in the Properties dialog box for the
file. If this is not present in the dialog box,
the path to the current document will be
used.

D Specifies the location in a file or Web site
that you want to link to, such as a specific
page or anchor. If you are linking to a Visio
drawing, you can click Browse and select
a drawing page from a list.

E Specifies a name for the link that appears
in the Hyperlink section of the ShapeSheet
for the shape or page. For example, “Link
to our pricing Web site.”

F A relative link describes the location of the
linked file in relation to the Visio drawing.
You can move the Visio drawing and the
linked file together (that is, move the entire
path structure) without breaking the link.
An absolute link spells out the exact loca-
tion of the linked file in terms of drives,
directories, and folders. You can move the
Visio drawing file without affecting an
absolute link, but if you move the linked file
you must reset the path. To specify an
absolute link, uncheck Use Relative Path
For Hyperlink.
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If you want to use a relative path that is not based on the location of the Visio
drawing, you can set a base path in the Properties dialog box for the file. Choose
File > Properties, then type the base path that you want in the Hyperlink Base
box. This base path is then displayed in the Insert Hyperlink dialog box.

To link a shape or page to another Visio drawing page, a Web URL, or
a non-Visio file: 

1. In Visio, create or open a Visio drawing. To add a link to a page, display the
page with nothing selected. To add a link to a shape, select the shape.

2. Choose Insert > Hyperlink.

3. Under Link To File Or URL, click Browse to locate the local file or Internet
address (URL) you want to link to. The path to the linked file is displayed
under Path.

If you want to link to a shape or page in the current drawing, skip to step 4.

4. Optionally, if you’re jumping to a Visio file or URL, under Named Location
In File, type the page name within the file or anchor on the Web page you
want to link to. If you’re jumping to the current open file or another Visio
file that is open, you can click Browse to see a list of the pages in that file.

5. Under Descriptive Name Of Link, type a name for the link that identifies the
location you’re linking to.

6. Choose whether you want a relative path for the hyperlink, then click OK.

NOTE  If you’ve set a base path for the hyperlink in the Properties dialog box for
the file, that path will appear as the Base in the Hyperlink dialog box.

To paste a Visio shape or drawing into another document as a
hyperlink: 

1. Right-click the hyperlinked shape, then choose Hyperlink > Copy Hyper-
link.

2. In the destination document, choose Edit > Paste As Hyperlink.

NOTE  Some applications, such as Microsoft Office 95 applications, do not sup-
port the Paste As Hyperlink command.

To paste an object into Visio as a hyperlink: 

1. After you’ve copied the hyperlinked object, go to the drawing page on which
you want to paste it.

2. Choose Edit > Paste As Hyperlink.
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To modify a hyperlink: 

1. To modify a link on a page, display the page, with nothing selected. To
modify a link on a shape, select the shape.

2. Right-click the page or shape, then choose Hyperlink > Edit Hyperlink.

3. Make the changes you need, then click OK.

To remove a hyperlink from a shape or page: 

1. In Visio, create or open a Visio drawing. To remove a link from a page, dis-
play the page with nothing selected. To remove a link from a shape, select the
shape.

2. Choose Insert > Hyperlink.

3. Click Remove Link, then click OK.

Related topics
About customizing shape behavior .............................................................. Visio Help

Jumping between hyperlinked shapes and pages

You always jump from a linked shape or drawing page by right-clicking the
shape or page, then choosing Hyperlink > Open. How you get back to the origi-
nal location in Visio depends upon the destination of the jump.

To activate a hyperlink on a shape or page: 

• Right-click the shape or page and choose Hyperlink > Open. If you want to
be able to see both the drawing page and the link destination, choose
Hyperlink > Open In New Window. If you are in full screen view, click the
shape or page.

To go to the next hyperlink: 

• Click the forward tool ( ) on the Web toolbar or press Alt+right arrow.

To return from another Visio page in a drawing or another document,
application, or Web site:

• Click the back tool ( ) on the Web toolbar or press Alt+left arrow.

NOTE  You can only use the forward and back tools to navigate between a Visio
drawing and other ActiveX documents, such as other Visio drawings, Office 97
documents, and HTML pages loaded ito Internet Explorer 3.01 and later.

Related topics
About using hyperlinks ............................................................................................ 227
Adding, modifying, and deleting hyperlinks .......................................................... 228



Appendix

Visio wizards and other tools

Wizards and other automated tools in Visio create special drawing types from
scratch, automate routine tasks, and perform unique functions.

When you open certain templates, such as the Project Timeline Wizard Tem-
plate, a wizard that you can use to create the drawing starts automatically. When
you open other templates, Visio adds a command you can choose to start a wiz-
ard to the top of the Tools menu. For example, when you open the
Organization Chart Template, Visio adds a command so that you can choose
Tools > Organization Chart Wizard.

Regardless of the template you start with, you can run any wizard or automated
tool by choosing Tools > Macro > Macros.

TIP  You can display background information about certain wizard screens by
clicking the More Info button onscreen.

Visio wizards

Wizard What it does How you run it

Build Region Assembles selected geographic shapes into a region. Tools > Macro > Maps > Build Region

Chart Shape Wizard Creates stackable and extendable shapes you can use Tools > Macro > Business Diagram >
to add special effects to charts. Chart Shape Wizard

Custom Properties Edits, adds, or deletes custom property fields from Tools > Macro > Custom Properties
Editor master shapes. Editor

Database Export Generates a database table that reflects the data in Tools > Macro > Database >
custom property and other ShapeSheet cells. Database Export

Table continued on next page.
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Visio wizards (continued)

Wizard What it does How you run it

Database Wizard Links Visio shapes and drawings to databases created in Tools > Macro > Database >
ODBC-compliant database programs. After establishing Database Wizard
links, you can pass information between a drawing and
database, create drawings that represent database tables,
and generate new master shapes that represent data stored
in database records.

Export [data] Exports an inventory report based on shape properties. Tools > Export [data]
The Export [data] command is available in the network
diagram, office layout, and organization chart templates.

Flowchart-TQM Guides you through the process of laying out and formatting Tools > Macro > Flowchart >
Diagram Wizard a Cause/Effect, Force Field, Top Down, or Cross Functional Flowchart-TQM Diagram Wizard

(Rummler-Brache) diagram.

Office Layout Guides you through the process of setting the drawing scale, Tools > Macro > Business Diagram >
Wizard choosing the page size and orientation, and creating the  Office Layout Wizard

basic wall structure for an office layout diagram.

Organization Chart Generates an organization chart from a data file in Microsoft Tools > Macro > Business Diagram >
Wizard Excel (.xls), Org Plus (.txt), or comma or tab-delimited text Organization Chart Wizard

(.txt) format, or from a database table created in an ODBC-
compliant program. Or, generates a basic organization chart
structure into which you can add data.

Page Layout Wizard Automates setting up the drawing-page size, orientation, and Tools > Macro > Visio Extras >
scale. Assists you in adding a title block and border to the Page Layout Wizard.
pages in a new or existing drawing.

Print ShapeSheet Opens the Print ShapeSheet dialog box, where you can choose Tools > Macro > Visio Extras >
which sections of the ShapeSheet to print and whether to Print ShapeSheet
print the ShapeSheet to a printer, the Clipboard, or a file.

Project Timeline Generates a project timeline from a data file in Microsoft Tools > Macro > Business Diagram >
Wizard Excel (.xls), comma- or tab-delimited text, or Microsoft Project Timeline Wizard

Project Exchange (.mpx) format. Or, generates a project
timeline structure into which you can enter data.

Property Reporting Generates inventory reports, such as bills of materials or Tools > Property Report
Wizard equipment and furniture inventories, and numeric reports,

such as cost totals or averages, from data stored in shapes.

Shape Explorer Locates specific shapes and stencils in Visio products. Tools > Macro > Shape Explorer
You can open stencils and templates from within
Shape Explorer.

SmartShape Wizard Customizes the appearance or behavior of a selected shape’s Tools > Macro > Visio Extras >
text, connectors, notes, or protection. SmartShape Wizard

Stencil Report Generates a Visio drawing of the masters on a selected Tools > Macro > Visio Extras >
Wizard stencil. Stencil Report Wizard
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Arrowheads 55
Assigning background pages 27
Assigning shapes to layers 147

individual shapes 147
multiple shapes 148
overview 147

Associating shapes with data 177
adding or editing fields 179, 180
adding shape data 178
displaying shape data 178
entering shape data 178
generating drawings from data

files 186, 190, 191
generating reports 180, 181
overview 177
updating reports 182, 183

Attaching drawings to e-mail
messages 134

Attributes in styles 139
Auto Arrange command 226
AutoCAD Drawing Web format

(DWF) 103
AutoCAD files 103

annotating drawings with Visio
information 105

importing 103
layers 105

Automatically connecting shapes 72
Automatically layering shapes 148
Automating layout 151

customizing layout options 154
depth options 152
layout grid 154
layout style 152
overview 151
routing options 153
setting layout options 153
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Automation
linking to databases 195, 202

Avenue size in grids 154

B
Background colors in patterns 59
Background colors in text blocks 93, 94
Background pages 26

assigning 27
creating 27
displaying 27
layers 144
overview 26
printing 111, 116
protecting 173

Basing drawings on templates 9, 10, 137
Basing stencils on existing ones 226
Basing styles on other styles 139
Begin and end points. See Endpoints
Behavior 31

custom file and line patterns 61
locking and unlocking

shapes 173, 175
nonprinting shapes 116
placeable shapes 74
ShapeSheet implications 31

Behavior command 116
Bending paths around shapes.

See Routable connectors
Bending patterns along lines 62
Binder files 126
Bitmaps 104

importing 104
in converted metafiles 101, 106

Blank drawings 9, 10
Blank stencils 225, 226
Block size in grids 154
Blue handles 35, 54
Blue x marks. See Connection points
BMP file format 103
Bold text 87
Bottom margin in text blocks 91
Bow of arcs 39, 217
Boxes 208
Breaking groups apart 43
Breaking OLE links 100
Breaking shapes apart 213
Breaking Visio-to-database links 202
Bring Forward command 55
Bring To Front command 55
Browsers 124, 125
Build Region Wizard 231
Built-in connectors 72

Bulleted lists 82
creating automatically 83
creating with tabs and indents 82
overview 82

Buttons. See Toolbars and buttons

C
Canceling background pages 27
Canceling links 100
Canceling selections 54
Canceling Visio-to-database links 202
Cascading windows 7
CDR file format 103
Center Drawing command 109
Center of rotation. See Pin
Center-aligned tabs 79
Centering drawings on pages 109, 113
CFL file format 103, 106
CGM file format 103
Change Source dialog box 99
Characters 75

delimiters and separators 193, 194
formatting 87
selecting 76
text overview 75

Chart Shape Wizard 220, 221, 231
Charts 220

connecting shapes in 66
creating chart shapes 220, 221

Choose A Drawing Template dialog
box 128

Choosing printers 111
Circles 209
Circular arcs 39
Classes of objects 35, 54
Clear command 225
Client-side image maps 120
Clip art shape data 212
Clip art simplification 212
Clipboard 12

cutting 12
linking or embedding 96
paste formats 100

Closed shapes 30
compared to open 30
fills 59
shadows 59

Closing stencils 8
Closing text blocks 76
CMX files 103
Codes 121

substitution codes in HTML
templates 121

Color 58
fill colors 49, 50, 58, 59
in imported graphics 104
layer colors 149
OLE objects 102
printing as black 111
shadows 59
text block background 93, 94

Columns of shapes 220
extendable shapes 221
overview 220
stackable shapes 220

Combine command 214
Combining shapes. See Merging shapes
Comma Separated Variable files

(CSV) 103, 192
Comma-delimited text files 192

creating shapes from 190, 191, 192
importing 103
setting up 186, 188, 190, 192

Commenting text file records 194
Comments layers 84, 105
Compacting shape data 212
Complex shapes 209, 210, 212
Composite or component shapes.

See Complex shapes, Groups
CompuServe forums 3
CompuServe Interchange Format

(GIF) 103, 122
Computer Graphics Metafiles 103

converting to shapes 101, 106
formatting 102
importing 103

Connect Shapes button or command 72
Connecting shapes 65

automatically 72
connection points 33, 69
connector tool 71
control handle connectors 72
creating connected drawings from text

files 192
glue 66
line jumps on connectors 73
overview 65, 66
with connectors 65, 66, 70, 71, 73

Connection point tool 33, 69
Connection points 33

creating or deleting 33, 69
displaying 69
gluing to 68
snapping to 155

Connection Points command 69
Connector tool 70, 71
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Connectors 70
adding connected shapes 71
built-in connectors 72
connecting shapes 70, 71, 72, 74
control handle connectors 72
dragging 71
Dynamic Connectors 70, 71
gluing 66
line jumps on connectors 73
resizing 164
routable connectors 70, 74, 151
routing with automatic

layout 151, 153, 154
Container applications 96
Control handles 34

built-in connectors 72
connecting shapes 72

Control points 33, 39
Convert To Group command 101
Converting complex shapes to simple

ones 212
Converting files 103

graphics files to Visio drawings 101,
103

text files to drawings 186, 192
Visio drawings to other

formats 133, 134
Converting objects to shapes 101, 106
Converting pages to backgrounds 27
Cookie cutter for shapes 211
Coordinates 163

positioning exactly 163
shapes 164, 165, 166

Copies of files 175, 176
Copy command 47, 96
Copy Drawing command 129
Copy Hyperlink command 229
Copying files 175, 176
Copying formatting 57, 94
Copying hyperlinks 229
Copying master shapes 226
Copying objects 100

by dragging 131, 132
embedding 96, 128, 129, 132
linking 98, 131
pasting in particular formats 100

Copying shapes 12, 47
Copying stencils 175
Copying styles 140
Copying text 77
Corel Clipart files 103
CorelDraw files 103
CorelFLOW! files 103, 106

Corners on shapes or lines 55
Creating master shapes 222, 223
Creating new drawings 9, 10
Creating new templates 137, 142
Creating shapes 207

ellipses and circles 209
freeform shapes 208
from data 185, 199, 200
from scratch 207
merging techniques 210
rectangles and squares 208

Cross-over connectors. See Line jumps
on connectors

CSV file format 103, 192
Cursors for drag and drop actions 132
Curves. See Arcs, Freeform shapes
Custom Fit command 211, 212
Custom page sizes or scales 18, 170, 171
Custom properties 179

adding or editing fields 179, 180
adding shape data 178
associating shapes with data 177
creating databases from drawings 183,

184, 197
creating drawings from databases 188
Custom Properties Editor 179, 180
displaying properties 178
exchanging Lotus Notes data 203
generating shape data reports 180,

181
linking databases to drawings 195
updating shape data reports 182, 183

Custom Properties box 178
displaying 178
entering data to shapes 178

Custom Properties Editor 179, 180, 231
Customer Service 2

CompuServe forums 3
international support 4
reaching Technical Support 4
support period 3
Visio World Wide Web address 3

Customizing automatic layout
options 154

Customizing grid spacing 159, 160
Customizing headers and footers 117
Customizing HTML templates 121, 122
Customizing line and fill pat-

terns 60, 61, 64
Customizing page sizes or scales 21
Customizing ruler subdivision spacing

160, 161
Cut-outs in shapes 214

Cutting apart shapes 213
Cutting shapes 12
Cutting text 77

D
Data associated with shapes. See

Associating shapes with data
Data files 188

importing organization chart text
files 186

importing timeline text files 190, 191
setting up data

files 186, 188, 190, 192
Data types 204, 205
Data-driven shapes. See Associating

shapes with data, Databases
Database Export Wizard 183

creating databases from drawings 183
exporting data 184
overview 231

Database tool installation 196
Database Wizard 231

actions and events 202
creating drawings from databases 199,

200
creating masters from databases 201
installing ODBC 195
linking drawings to databases 195,

197, 199
Databases 195, 197

actions and events 202
associating shapes with data 177
creating databases from draw-

ings 183, 184
creating drawings from databases 185,

199, 200
creating masters from databases 201
Database Export Wizard 183, 184
defining as ODBC 196
displaying shape data 178, 179
entering shape data 178
generating shape data reports 180,

181
installing ODBC 195
linking databases to drawings 188,

195, 197, 199, 200, 201
Lotus Notes 203, 204, 205, 206
organization charts and data 186, 188
project timelines and

data 190, 191, 192
setting ODBC options 196
updating shape data reports 182, 183
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Days or dates 117
in header or footer text 117
in project timeline files 190

Decimal tabs 79
Default HTML templates 120, 121
Default page units 171
Default printer settings 111
Define Styles command 138, 139, 140
Degrees 162

of rotation 45, 162
Delete Pages command 24
Deleting background pages 27
Deleting connection points 69
Deleting custom properties 179, 180
Deleting guides and guide points 158
Deleting hyperlinks 230
Deleting layers 146
Deleting masters 225
Deleting pages 24
Deleting segments in shapes 38, 217
Deleting shapes 12

from groups 43
from pages 12
locking against deletion 174

Deleting styles 140
Deleting tabs 79, 81
Deleting text 77, 78
Deleting text-only shapes 78
Deleting vertices 38
Deleting Visio-to-database links 202
Delimiter characters 193, 194
Depth in automatic layout 152
Detaching stencils 8
Determining best drawing layout 151,

153, 154
Developer toolbar 7
Device-independent bitmaps 103
Dfltdoc.htm 121
Diagonal guides 158
Diagram layout options 151, 152,

153, 154
DIB file format 103
Dimensions of shapes 162

1-D shapes 164
2-D shapes 165
exact size and position 162
multiple shapes 166

Directed drawings 152
Direction of drawings 151, 152
Disassembling groups 43
Disassembling shapes 213
Display options 13

workspace display 13

Displaying colors 58
Displaying connection points 69
Displaying control handles 34
Displaying custom properties 178
Displaying drawings 7

arranging windows 7
by right-clicking shapes 227, 230
full-screen view 28
in Internet Explorer 124, 125
sent through e-mail 134

Displaying hidden shapes 149
Displaying local stencils 217, 218
Displaying Lotus Notes data in

shapes 205
Displaying pages 7

arranging windows 7
background pages 27
closer view of text 77
full-screen view 28
multiple pages simultaneously 25

Displaying shape data 178
Displaying shape help 12
Displaying shape invento-

ries 177, 180, 181, 182
Displaying Shape toolbar 52
Displaying template help 9, 10
Displaying toolbars 6

hiding and showing toolbars 6, 7
Page toolbar 24
Text toolbar 86

Displaying ToolTips 7
Displaying Web sites by right-clicking

shapes 227, 230
Displaying windows 7

full-screen view 28
tiling 7, 132
workspaces 13

Distorting patterns on lines 62
Distribute Shapes button or command

168
Distributing shapes 166

aligning and distributing 166, 168
automatic layout 151, 153, 154
offsetting 215, 216

Dithered colors 58
Docking stencils 8
Documents 13. See also Files

creating 9, 10
older versions 13
opening 9, 10, 176
pages 24
printing 107, 111, 112

Documents (continued)
properties 13
read-only 176
saving 13, 14
templates 9, 10

Dots on pages 20
Double-rectangle pointer 93
Doughnut holes in shapes 214
Dragging and dropping shapes 11

adding connected shapes 71
connectors 71
into drawings 12
into other applications 131, 132
overview 11

Dragging pages to resize 21
Dragging shape segments 38, 217
Dragging shapes into position 156
Dragging shapes to copy or

move 40, 41, 47
Dragging stencils on screen 8
Dragging vertices 38, 217
Drawing 207

arcs 39, 208
ellipses 209
freeform shapes 208, 211
lines 208
master shapes 222, 223
merging shapes 210
overview 5
paths around shapes.

See Routable connectors
rectangles 208
segmented shapes 209, 212

Drawing file stencils. See Local stencils
Drawing files. See Files
Drawing Monitor 199, 200
Drawing pages. See Pages
Drawing Resources web site 3
Drawing scales 169

overview 169, 170
scaling for printing 114
setting orientation and scale 18, 171

Drawing size 21
Drawing tools 207
Drawing units 169

measurements overview 169
page measurements 18, 171
tab measurements 79, 80

Drawing windows 7
arranging 7
defined 7
full-screen view 28
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Drawings 9, 10
adding shapes 11, 12
adding text 75
annotating and redlining 84
annotating AutoCAD drawings 105
architectural scale 171
background pages 26
centering on page 109
creating 9, 10, 137
dragging and dropping shapes 11, 12
drawing shapes 30, 207
e-mailing 124, 134
editing connected drawings 65
embedding or linking 99, 129
engineering scale 171
exporting 134
generating databases from drawings

183, 184
generating from databases or text

files 185, 192, 195, 197, 199, 200
inventories of

shapes 177, 180, 181, 182
layering 26, 143, 144, 148, 149
linking to database records 199
linking to Lotus Notes databases 203,

204, 205, 206
linking to Web sites 227, 229, 230
multiple-page drawings 23, 25
opening 176
positioning on pages 109
previewing before opening 13
print preview 108, 109
printing 107, 111, 115
printing to files 112
rearranging shapes automatically 151,

153, 154
resizing 114
saving 219
saving as HTML 119, 120, 121, 122
saving as templates 142
saving in Web-compatible formats

119,  122
scale 18, 114, 169, 170, 171
size 114
styles 137, 138, 140
tiling 112, 113
viewing in Internet Explorer 124, 125

Drop shadows 59
adding to shapes 59
fills and patterns 49, 50, 58
on metafiles 102
setting offset 60

DRW file format 103
DSF file format 103
Duplicate command 47
Duplicating shapes 47

duplicating 47
methods 47
offsetting 215, 216

DWF file format 103
DWG file format 105

annotating drawings with Visio
information 105

layers 105
DXF file format 103

compatible import formats 103
Dynamic Connector shapes 70

adding automatically 71
overview 70
routable connectors 74

Dynamic glue 66
connecting shapes with 66, 71
maintaining shape connections 66
working with connectors 71

E
E-mail 124, 134
Earlier versions of Visio 13
Eccentricity handles 33, 39, 217
Eccentricity of arcs 33, 39, 217
Edit Master command 224
Editing drawings 216

automatic layout 151, 153, 154
in Internet Explorer 124, 125
in print preview mode 109
marking edits in drawings 84, 105
revising shapes 36, 216
with connected shapes 65

Editing hyperlinks 230
Editing OLE objects 101, 129
Editing shapes 216

combining shapes 214
custom properties 178, 179, 180
freeform shapes 211
grouped shapes 43, 78, 79
identical shapes 217, 218
intersecting 211
joining shapes 213
master shapes 217, 218, 224
merging shapes 210, 213
methods 217
report shapes 183
reshaping angles 38, 217

Editing shapes  (continued)
routable connectors 74
segmented shapes 37, 209, 212
subtracting 211
uniting 210

Editing stencils 175, 179, 222
Editing styles 139
Editing text 78

adding text to shapes 75
cutting and pasting 77
editing existing text 78
tab settings 81

Electronic mail 124, 134
Ellipse tool 209
Ellipses 209
Elliptical arcs 33, 39, 208
Embedding objects 96, 128

classes of objects 100
converting to groups 101, 106
dragging and dropping 131, 132
editing objects 101, 129
entire drawings 129
into Lotus Notes databases 203,

204, 205
into Microsoft PowerPoint 125
into other applications 128, 129
into Visio 96, 97
overview 96, 128

Enabling features. See Turning features
on or off

Encapsulated PostScript files 103
Endpoints 32

aligning 162, 168
defined 32
direction of drawings 151
gluing 41, 71
in segmented shapes 209
lines 55
location 164
resizing shapes 37
rotating with 45
snapping to 155

Engineering drawing scale or size 171
Enlarging drawings 114
Enlarging shapes 162, 164, 165, 166
EPS file format 103
Error tolerance in Custom Fit process 212
Events 202

right-mouse actions and events 202
Visio-to-database links 202

Excel files. See Microsoft Excel files
Exiting full-screen view 28
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Export filters 133, 134
Export Inventory Report command 182
Exporting 133

data into drawings  185, 195, 197,
199, 200, 201

drawings 133, 134
export filters 133, 134
HTML pages 119, 120, 121, 122
layer reports 181
shape data into databases 183, 184,

195, 197
triggering events 202
Web-compatible formats 119, 122

Extendable shapes 220, 221

F
Fields 177

custom properties
fields 178, 179, 180

Lotus Notes fields 203, 204, 205, 206
storing data in shapes 177

Fields in databases 183, 195
Fields in imported text files 192, 193
File formats 100. See also names of

specific formats
export formats 134
HTML 119, 120, 121, 122
import formats 103
paste formats 100

File size 101
File types 13

drawing files 9, 10, 137
stencils 8, 175, 225, 226
templates 142
workspaces 13

Files 9, 13
copying styles 140
creating drawing files 9, 10, 137
e-mailing 124, 134
exporting drawings 13, 133, 134
HTML files 119, 120, 121, 122
importing 103
including in Binders 126
multiple pages in 23, 25
navigational links 227, 230
older versions 13
OLE object files 96, 97, 98, 99,

128, 129, 130, 131
opening 9, 10, 176
previewing before opening 13
printing drawings 107, 111
printing to files 112
protecting 173, 175

Files (continued)
read-only files 176
saving 13, 14, 176, 219
saving as templates 142
saving in Web-compatible

formats 119, 122
templates for HTML files 121, 122

Fill command 59
Fill style list 52, 138
Fill styles 52

applying styles 52, 138
creating styles 138
defining styles 139
editing styles 139

Fills 58
applying to shapes 49, 50, 58, 59
customizing patterns 60, 61, 63, 64
formatting shadows 59
OLE objects 102
styles 52, 137, 138, 139
transparency 59

Filters 103, 133, 134
Finding shapes 48
Finding stencils 48
Finding templates 48
First line indents 88, 89
Fit Curve command 211
Fitting drawings on pages 113, 114
Fixed grid spacing 160
Flip Horizontal button or command 44
Flip Vertical button or command 44
Flipping shapes 44
Floating stencils 8
Flowchart routing style 153
Flowchart-TQM Diagram Wizard 232
Flowcharts 65

as connected drawings 65
connecting shapes in 66

Fonts 49
formatting text 49
header or footer fonts 117

Footers on printouts 116, 117
Foreground colors 59

displaying 59
fill and shadow options 59

Foreground pages 15
assigning backgrounds 27
converting to backgrounds 27
numbering 116, 117
working with pages 15

Format menu commands 51, 86
Format Painter tool 57, 94
Formats. See File formats

Formatting data files 186, 188, 190, 192
Formatting HTML pages 121, 122
Formatting OLE objects 102
Formatting shapes 49

after splitting or combining 211
color 58
copying formatting 57
custom line and fill patterns 60, 61
endpoints 55
fills 58, 59
Format menu commands 51
grouped shapes 54
lines 55, 56
local formatting 141
locking 173, 175
methods 52
multiple shapes 52
reverting to original format 141
shadows 58, 59, 60
styles 52, 137, 138, 139, 141
toolbar buttons 50
transparency 59

Formatting text 85
alignment 88, 89
copying formatting 94
Format menu commands 86
formatting lost in pasted text 77
indenting 88, 89
overview 49, 85
shortcuts 87
spacing 88, 90
text blocks 85, 87
Text dialog box 87
text style list 86

Formulas 31
defined 31
exchanging Lotus Notes

data 204, 205, 206
Forwarding routed drawings 136
Fragment command 213
Fragmenting shapes 213
Freeform shapes 208

drawing 208
Fit Curve command 211
reshaping 217

Freeform tool 208
Freestanding text 77, 78
Full-screen view 28

G
Generating databases from drawings 183,

184
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Generating master shapes from data-
bases 201

Generating new arrangements for shapes
automatically 151, 153, 154

Generating organization charts from data
files 186

Generating project timelines from data
files 190, 191

Generating shape data reports 177, 180,
181, 182

GIF file format 103, 119, 122
Global refresh intervals 199, 200
Glue 66

changing type 67
connecting shapes 66, 72
dynamic and solid glue 66, 67
gluing connector shapes 71
gluing endpoints 71
gluing to guides 41, 162
options for layers 149
rearranging shapes automatically 151
settings 68

Glue button 68
Going to pages 25
Graph bar and column shapes 220, 221
Graphics 103

converting to shapes 106
importing or exporting 103, 133, 134
saving as HTML 119, 120
saving in Web-compatible

formats 119, 122
Graphics Interchange Format

(.GIF) 103, 119, 122
Gray dots on pages 20
Gray handles 79
Green box

handles 32, 35, 52, 54, 79, 166
Green diamond handles. See Vertices
Grid lines 159

fixed grids 160
grid options 159, 160
snapping to 155
spacing 159, 160
variable grids 159

Grids for automatic layout 154
Group button or command 43
Groups 42

adding shapes to groups 43
assigning to layers 148
changing stacking order 78
converting objects to 101, 106
editing 78, 79
flipping shapes 44

Groups (continued)
formatting 54
grouping shapes 42, 43
removing shapes 43
rotating 42
rotating shapes in 45
selecting and subselecting 54
text 76, 78, 79
ungrouping 43
working with groups 43

Guides and guide points 158
aligning shapes to 162, 167
creating 158
deleting 158
diagonal guides 158
evenly spaced guides 168
gluing to 41, 68, 162
on rotated pages 19
precise positioning 164, 166
rotating 158
snapping to 155

H
Handles 32

blue 35, 54
control handles 34, 72
eccentricity handles 33
gluing to 68
gray 79
green 32, 35, 52, 54, 79, 166
groups 79
overview 32
red 41, 67
rotation handles 33, 45, 92
selection

handles 32, 35, 54, 164, 165
snapping to 155

Headers on printouts 116, 117
Height of shapes 162
Height of text blocks 92
Help 2, 12

displaying shape help 12
reaching Technical Support 4
sources for Visio information 3
template help 9, 10
ToolTips 7

Hiding connection points 69
Hiding interface elements for full-screen

view 28
Hiding rulers 161
Hiding shapes 59
Hiding toolbars 7
Holes in shapes 214
Horizontal connector line jumps 73

Horizontal flipping 44
Horizontal shape alignment 167
Horizontal shape distribution 168
Horizontal shape resizing 162
Horizontal text alignment 88, 89
HTML and Internet tools 119

applying custom HTML templates 122
creating HTML templates 121
customizing HTML templates 121
default HTML templates 120
jumping to Web sites 230
linking shapes to Web sites 227, 230
saving drawings as 119, 120, 121
saving in Web-compatible

formats 119, 122
viewing drawings in Internet

Explorer 124, 125
Hyperlink command 227, 229
Hyperlinks 227

copying and pasting links 229
editing 230
going on to next link 230
jumping to linked pages in full-screen

view 28
linking to pages or Web sites 227, 229
navigating linked files 230
relative and absolute paths 228
removing links 230
returning from linked sites 230

I
Icons

tools and buttons. See Toolbars and
buttons

ID numbers 204
Identical shapes 217, 218
IGS file format 103
Image maps 120
Import filters 103
Importing database information 195

creating drawings 185, 199, 200
creating masters 201
linking to databases 188, 195, 197
project timelines 190, 191
updating data 202

Importing graphics files 97, 103, 106
Importing shape data into databases 183

creating databases 183, 184
linking to databases 195, 197
updating data 202

Importing text files 192
creating drawings 192
creating organization charts 186

In place editing 129
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Indenting text 82, 88, 89
Independent text 77, 78
Initial Graphics Exchange

Specification 103
Insert Object command 96, 97
Inserting OLE objects 98
Inserting pictures 103
Insertion point 76
Installing ODBC 195
Installing printers 111
Instances of master shapes 217

custom properties 178, 179, 180
deleted masters 225
displaying local stencils 217, 218
editing by editing masters 217, 218
linking to databases 199
reverting to original format 141
stamping 12, 47

International product support 4
Internet addresses for Visio 3
Internet Explorer 124, 125
Internet tools. See HTML and Internet

tools, Hyperlinks
Intersect command 211
Intersecting shapes 211

fragmenting 213
Intersect command 211
joining 213
merging shapes 210
trimming 213

Intervals for grid and rulers 159
changing 159, 160, 161
snapping to 155

Inventories of drawings 177
creating reports 180, 181
layer reports 181
quick inventory reports 182
storing data in shapes 177
updating and revising reports 182

Invisible shapes 59
Irregular shapes 208
Italic text 87

J
Join command 213
Joining shapes. See Merging shapes
Joint Photographic Experts Group file

format 103, 119, 122
Journal (Microsoft Outlook) 124
JPG file format 103, 119, 122
Jumping over connectors. See Line jumps

on connectors
Jumps. See Hyperlinks, Navigational links

L
Landscape orientation 17, 18
Large print jobs 112, 113
Last routed lines 73
Lay Out Shapes command 151, 153, 154
Layer Properties command 145, 146,

150
Layering shapes 143

active layers 148
adding layers 145
adding layers to AutoCAD

drawings 105
annotation layers 84
assigning shapes to layers 147, 148
background pages 26, 144
changing stacking order 55
controlling behavior 150
deleting layers 146
exporting reports for layers 181
layer color 149
layer options 148, 149
order of selection 52
overview 143, 144
page layers 145
renaming 146
selecting shapes on layers 149

Layers in AutoCAD drawings 105
exporting or appending to AutoCAD

drawings 105
Laying out shapes automatically 151

customizing options 154
depth options 152
layout grid 154
layout style 152
overview 151
preparations 151
routing options 153
setting options 153

Layout And Route Around option 74
Leading 88, 90
Left margins in text blocks 91
Left To Right drawing direction 152
Left-aligned tabs 79
Line command 56
Line jumps on connectors 73

enabling 73
overview 73

Line spacing 88, 90
Line style list 52, 138
Line To Line connector spacing 154
Line To Node connector spacing 154
Line tool 208

Lines 55
adding to shapes 37
applying styles 52, 137, 138
changing arcs to lines 39
connecting shapes with lines.

See Connectors
converting shape segments to lines 212
customizing patterns 60, 61, 62
defining styles 138, 139
drawing 208
editing styles 139
ends 55, 60, 61, 62
formatting 49, 50, 55, 56, 102,

137, 138
fragmenting shapes with lines 213
in imported graphics 104
segments 37, 209, 212
weight 55

Linking objects 130
breaking links 100
by dragging and dropping 132
converting linked objects 101, 106
creating links 97, 98
editing objects 101
in Microsoft PowerPoint 125
into other applications 131
into Visio 97, 98
managing links 99
overview 97, 130
updating links 99
viewing links 99

Linking shapes to databases 195
actions and events 202
creating drawings 199, 200
creating masters 201
installing ODBC 195
organization chart links 188
Visio-to-database links 195, 197

Linking to pages or Web sites 227
hyperlinks 227, 229
navigating links 230
saving drawings with links as

HTML 120
Links command 99, 100
Listing shapes in drawings 177, 180,

181, 182
Lists in text 82

creating 82
creating automatically 83
overview 82

Local formatting 141
defined 141
preserving 141
reverting to 141
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Local stencils 8
adding shapes to 219
creating standalone stencils 219
deleting masters 225
displaying 217, 218
editing custom properties 179, 180
editing shapes 179, 217, 218, 224
overview 8
saving as new stencils 225, 226
working with stencils 8

Locking. See also Protecting
Locking files 173, 175
Locking layers 149
Locking shapes 173

against selection 174
overview 173, 174, 175
padlocks 34
unlocking 175

Lotus Notes 203
displaying data in Visio 205
exchanging data 203
inserting Lotus Notes fields 206
using Visio data in Lotus Notes

fields 204, 205
LOTUSNOTES function 206

M
Macintosh PICT files 103
Mailing files 124, 134
Main Visio window 7
Managing links 99
Manually updating links 99
Map files (image maps) 120
Margins on headers or footers 117
Margins on pages 109, 113
Margins on text blocks 90, 91
Marking changes to drawings 84

annotation layers 84
AutoCAD drawings 105

Master shape icons 226
arranging 222, 226
new master shapes 222, 223

Master shapes 11
adding to stencils 219, 222, 223
behavior 31
breaking link to instances 225
changing stencil display 8
connectors 66, 70, 72, 73
copying to other stencils 226
creating 219, 222, 223
custom fill and line patterns in 61, 64
custom properties 179, 180
defined 11, 12

Master shapes (continued)
deleting 225
displaying for drawings 217, 218
dragging into drawings 11, 12
editing 175, 217, 218, 224
generating from databases 201
instances 12, 47
linking to databases 199
locked shapes 173, 174, 175
protecting 173, 174, 175
reverting to original format 141
scale 170
stamping 12, 47

Masters. See Master shapes
Matching master shapes by name 223
Measurements 169

in rulers 161
page and drawing units 169, 171
tabs and rulers 79, 80

Merging shapes 210
combining 214
Fit Curve command 211
fragmenting 213
grouping 42, 43
intersecting 211
Join command 213
joining 213
subtracting 211
trimming 213
uniting 210

Metafiles 101
converting to shapes 101, 106
formatting 102
importing 103

Micrografx Designer files 103
Microsoft Access databases 195

linking to drawings 195
Microsoft Excel files 188

creating data files from
templates 188, 192

creating organization charts with 186
creating timelines with 190, 191
opening reports in Microsoft

Excel 181
Microsoft Exchange 135, 136
Microsoft Internet Explorer 124, 125
Microsoft Office Binder 126
Microsoft Office compatibility 123,

135, 136
Microsoft Outlook Journal 124
Microsoft PowerPoint 125
Microsoft Project exchange format 190,

191

Microsoft Quick View 13
Microsoft Windows ODBC setup 195
Midpoints on routable connectors 70, 74
Monitoring Visio-to-database

links 199, 200
Movable glue. See Dynamic glue
Moving centers of rotation 46
Moving control handles 34
Moving drawings on page 109, 113, 114
Moving drop shadows 60
Moving pages 25
Moving shapes 40

aligned shapes 167
by dragging 40, 41
distributing across page 168
glued shapes 41
locking shapes in place 173, 175
offsetting 215, 216
precisely 155
selecting and moving 40, 41
size and position 155, 164, 165, 166

Moving text or text blocks 93
cutting and pasting 77
moving only text blocks 93
rotating and moving 92

Moving through hyperlinked pages 230
Moving through pages 24

in full-screen view 28
Moving to Web sites 230
Moving zero points on rulers 20, 80
MPX file format 190, 191
Multiple paths in shapes. See Segments in

shapes
Multiple selections 35, 52, 54
Multiple shapes 52

aligning 162
formatting 52
moving 41
positioning 166
selecting 52

Multiple-page drawings 23, 25

N
Names of layers 146
Names of master shapes 223
Names of templates 142
Navigating in Internet Explorer 125
Navigating through pages 24, 28
Navigational links 227

jumping to linked files or URLs 230
jumping to linked pages 227, 230
jumping to linked pages in full-screen

view 28
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New drawings 10
creating from databases 185, 199, 200
starting 9, 10, 137

New Master command 223
New master shapes 223
New stencils 225, 226
New templates 142
New Window command 25
Next Page button 25
Nodes 154

rearranging drawings automatically
154

Non-dynamic connections 66
None pattern option 59
Nonprinting shapes 116
Notes/FX 203
Numbered lists 82

creating 82
overview 82

Numbering pages 116, 117
Numbers 116

page numbers 116, 117
Numeric reports on shape

data 180, 181, 182

O
Object linking and embedding.

See OLE objects
ODBC standard 195

creating drawings from databases 185
Database Export Wizard 183
installing ODBC 195, 196
linking to databases 188, 195, 197
setting options 196

Office compatibility 123, 126, 135, 136
Office Layout Wizard 232
Offset command 215, 216
Offset of shadows 60
Offsetting shapes 215, 216
Older versions of Visio 13
OLE incompatibilities 203
OLE objects 97, 128

breaking links 100
converting complex shapes to simple

ones 212
converting objects 101, 106
dragging and dropping 131, 132
editing 101, 129
embedding 96, 97, 128, 129,

131, 132
exporting 134
formatting 102
linking 97, 98, 99, 130, 131

OLE objects (continued)
managing links 99
overview 97
paste formats 100
pasting 100
pointer tool changes 132
PowerPoint objects 125
updating links 99

One-dimensional shapes. See 1-D shapes
Open Database Connectivity. See ODBC
Open shapes 30

combining 214
compared to closed 30
shadows 59
uniting 210

Opening ABC Flowcharter drawings 106
Opening AutoCAD drawings 105
Opening CorelFLOW! files 106
Opening drawing files 9

in Internet Explorer 124, 125
in other applications 133
new drawing files 9, 10, 137
previewing before opening 13

Opening groups 43
Opening stencils 8, 175, 176, 179, 222
Opening templates 176
Opening text blocks 76, 78
Opening windows 25

new windows for pages 25
Operations submenu 210
Oracle databases 195

installing ODBC 195
linking to drawings 195

Order of selection 35, 54
Order of shapes on page 52

background layers 144
changing order 55
order of selection 52
page layers 143

orders on headers or footers 117
Org Plus files 186
Organization Chart Wizard 232

data file setup 186
importing data files 186, 188
linking drawings to databases 188
troubleshooting 189

Organization charts 186
connecting shapes in 67
creating from data files 186, 188, 189
linking to databases 188

Orientation of pages 17, 18
Origin of grid lines or rulers 159, 160,

161

Original stencils 175, 222
Orthogonal page rotation 19, 21
Outlook Journal 124
Output Filter Setup dialog box 122
Overlapping printed tiles 113
Overlapping shapes 55

changing stacking order 55
combining 214
fragmenting 213
intersecting 211
joining 213
merging 210, 213
selecting multiple shapes 52
stacking order 52, 55
subtracting 211
trimming 213
uniting 210

Oversize print jobs 112, 113

P
Padlocks 34, 174
Page breaks 108, 109, 113
Page command (Insert menu) 24, 27
Page Layout Wizard 27, 232
Page Setup command 21
Page toolbar 7, 25
Page units 169

measurements overview 169
page measurements 18, 171
tab measurements 79, 80

Pages 15
adding pages 24
background pages 26, 27
centering for printing 109, 113
deleting layers 146
deleting pages 24
drawing units 171
HTML pages. See HTML and Internet

tools
hyperlinked pages 227, 229
layer colors 149
layer names 146
layers 143, 144, 145, 147, 148,

149, 181
margins 109
multiple-page files 23, 25
navigational links 227, 230
numbering 116, 117
orientation 17, 18
overview 15
page breaks 108, 109, 113
printing 107, 109, 111, 115
reordering pages 25
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Pages (continued)
rotating 19, 21
scale 18, 170, 171
size 21, 113
turning pages 24
turning pages in full-screen view 28

Paint brush icon 57
Palettes 51

displaying toolbar palettes 51
floating stencil palettes 8

Paper size 21, 107
Paragraphs 88

aligning 88, 89
formatting 87
indenting 88, 89
spacing 88, 90
tab settings 80, 81

Parallel lines and shapes 215, 216
Paste As Hyperlink command 229
Paste Special command 100
Pasting hyperlinks 229
Pasting objects 100

copying and pasting 47
embedded objects 96, 97, 129
formats 100
into other applications 131, 132
linked objects 98, 131

Pasting text 77
Paths for files 99

linked files 99
Paths for hyperlinks 228, 230
Paths in shapes. See Segments in shapes
Patterns 49

applying and displaying 49, 50, 58
custom line and fill patterns 60, 61,

64
line patterns 55
OLE objects 102
shadow backgrounds or

foregrounds 59
transparent fills 59

PCT file format 103
PCX file format 103
Pencil tool 37, 208
Periodic splines 211, 212
PICT files 103
Picture-frame shapes 214
Pictures. See Graphics
Pin (center of rotation) 46

locating 165
overview 46
rotating shapes 33, 46
setting 165

Placeable shapes 151
in automatic layout 151
routing connectors around 70, 74
setting shape behavior 74

PNG file format 103, 119
Pointer tool 21, 35, 54
Pointers for drag and drop actions 132
Points, connection. See Connection

points
Polyline shapes 212

creating spline shapes 211
reducing shape data 212

Portable Network Graphics file
format 103, 119

Portrait orientation 17, 18
Positioning drawings for printing 109,

113, 114
Positioning guides 164, 166
Positioning shadows 60
Positioning shapes 40

aligning to guides and guide
points 162

distributing across page 168
locking in place 173, 175
multiple shapes 41
offsetting 215, 216
selecting and moving 40, 41
setting size and posi-

tion 155, 162, 164, 165, 166
snapping into position 155, 156
with guides and guide points 158

PowerPoint files 125
Pre-assigned layers for shapes 147
Precision 155

in positioning shapes 155
Preserving local formatting 141

applying styles 141
overview 141

Preventing changes to files 173, 175
Preventing shape selection 174
Previewing files before opening 13
Previewing files in full-screen view 28
Previewing printed drawings 108

editing in print preview 109
print preview 108, 109

Previous Page button 25
Primary shapes 166, 167
Print command 111, 112, 115, 116
Print preview 108

editing drawings in 109
previewing page breaks 108, 109

Print Preview button or command 109
Print preview window 108, 109
Print ShapeSheet wizard 232

Printers 111
choosing 111

Printing 107
adjusting page size and margins 109
adjusting position of drawings 109
background page options 116
centering drawings on pages 109
choosing printers 111
current page 111
drawings 107, 111, 115
fitting drawings on pages 114
headers and footers 116, 117
large drawings 112, 113
layers 149
nonprinting shapes 116
on multiple sheets 112, 113
oversize drawings 112, 113
page numbers 116, 117
page ranges 115
print options 115
printed drawing size 15, 21, 114
printed page orientation 18
rotated pages 19
small drawings 112, 113
tiled drawings 112, 113
to files 112

Product support 3
CompuServe forums 3
international support 4
support period 3
Technical Support 4
Visio World Wide Web site address 3

Project Timeline Wizard 190, 191,
192, 232

Project timelines 190
creating from data files 190, 191
data file templates 192
Project Timeline Wizard 232
setting up data files 190

Properties dialog box 204, 205
Properties of documents 13
Properties of shapes 179

adding or editing fields 179, 180
associating shapes with data 177
creating databases from drawings 183,

184, 197
creating drawings from databases 188
Custom Properties Editor 179, 180
displaying properties 178
entering shape data 178
generating shape data reports 180,

181
linking databases to drawings 195
updating shape data reports 182, 183
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Property Reporting Wizard 181,
182, 232

Protecting. See also Locking
Protecting background pages 173
Protecting files 173, 175
Protecting master shapes 173, 174
Protecting shapes 173

overview 173, 175
preserving formatting 141
Protection command 174

Protecting styles 173
Protection command 174
Punch-outs in shapes 214

Q
Quick View 13

R
Radial drawing direction 152
Ranges of pages 111
Read-only files 13, 173, 175, 176
Read-only stencils 175, 222
Reading data from drawings 195,  197,

202
Reading data from linked databases  195,

197
Reading data from text files 192
Reading database information into

drawings 185, 188, 192, 199,
200, 201

Reading Lotus Notes field information
205, 206

Reading organization chart data from text
files 186

Reading project timeline data from text
files 190, 191

Rearranging shapes automatically 151,
153, 154

Record types 194
importing text files 192, 194
text file structure 193

Recording activities in Outlook Journal
124

Records in data files 186, 190, 191
Records in databases 183

actions and events 202
creating drawings 185, 199, 200, 201
database overview 183
linking to drawings 195

Records in text files 192
converting to drawings 192
delimiters 194
text file structure 193

Rectangle tool 208

Rectangles 208
Red endpoints 71
Red handles 41, 67
Redlining drawings 84

annotation layers 84
AutoCAD drawings 105

Reducing drawings 114
Reducing shape data 212
Reducing shapes 162, 164, 165, 166
Refreshing shapes at intervals 199, 200
Refreshing Visio-to-database links 202
Relative paths for hyperlinks 228
Removing layers 146
Removing styles 140
Renaming layers 146
Renaming master shapes 223
Renaming styles 139
Reorder Pages command 25
Reordering pages 25
Repeating elements on each page 117
Repeating formatting 57
Replacing text 76, 78
Report shapes 182

generating reports 181
replacing titles 183
updating reports 182, 183

Reports 180
associating shapes with data 177
exporting for layers 181
generating shape custom property

reports 180, 181
quick inventory reports 182
report shapes 181, 182, 183
updating shape custom property

reports 182, 183
Reshaping angles 38, 217
Reshaping arcs 33, 39, 217
Reshaping routable connectors 74
Reshaping shapes 36, 37, 38, 216, 217
Resizing connectors 164
Resizing custom patterns and fills with

shapes 63
Resizing drawings 109, 114
Resizing HTML pages 120, 121
Resizing pages 21
Resizing shapes 36

1-D shapes 37, 164
2-D shapes 36, 165
determining size 164, 165
horizontal resizing 162
precisely 162
size and position 155, 164, 165, 166
vertical resizing 162

Resizing text blocks 92

resizing only text blocks 92
rotating and resizing 92

Resizing windows 7
Returning from linked sites 230
Reverse Ends command 44
Reversing shapes 44
Reverting shapes to original formats 141
Review comments on drawings 84

annotation layers 84
AutoCAD drawing 105

Revising shapes. See Editing shapes
Revision marks 84

annotation layers 84
AutoCAD drawings 105

Right Angle routing style 153
Right margin in text blocks 91
Right tabs 79
Right-clicking shapes 202

actions and events 202
updating database links 202

Rotate Left button or command 45
Rotate Right button or command 45
Rotating groups 42, 158
Rotating guides 166
Rotating pages 19, 21
Rotating shapes 45. See also Pin

basic shape rotation 45
center of rotation 46
displaying degree of 162
locking shapes against rotation 174
rotation handles 33
setting pin and orientation 165

Rotating text blocks 92
methods 92
overview 92

Rotation handles 33, 45, 92
Rotation tool 19, 33, 45, 46
Rounding corners 55
Routable connectors 74

connector overview 70
in automatic layout 151
midpoints and vertices 70
overview 74

Routing drawings in Microsoft
Exchange 135

Routing drawings through e-mail 124,
134

Routing styles for connectors 154
Rubberstamp tool 12, 47
Ruler & Grid command 159, 160, 161
Rulers 161

aligning shapes to 167
displaying 80
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Rulers (continued)
snapping to 155
zero point 20, 80, 160, 161

Running Wizards 231

S
Save As command 14

exporting drawings 134
read-only files 176
saving drawings 14
saving stencils 225, 226
saving templates 142

Save As HTML dialog box 120, 121
Save As HTML template 121
Save button or command 14
Saving files 13

as HTML 119, 120, 121, 122
as other file formats 13
as read-only 176
drawings with links 120
in earlier file format 13
in Web-compatible formats 122
options 13
previews of files 13
stencils 219, 225, 226
templates 13
workspaces 13

Saving window arrangements 13
Scaling custom patterns and fills with

shapes 63
Scaling drawings. See Drawing scales
Screen tips 7
Seamless splines 211
Searching for shapes 48
Searching for stencils 48
Searching for templates 48
Security for files 173, 175
See-through shapes 214
Segments in shapes 209

adding 37, 209, 217
converting to reduce shape data 212
deleting 38, 217
reshaping 38, 217
starting over 210

Select All command 35, 54
Select Special command 35, 54
Selecting printers 111
Selecting records to update 202
Selecting shapes 35

canceling selection 149
canceling selections 54
in groups 54, 78, 79
locking against selecting 174

Selecting shapes (continued)
multiple shapes 35, 52, 54
on layers 149
overview 35
pointer tool techniques 35, 54
selecting all 35, 54
unlocking 175

Selecting text 76
Selecting text blocks 76
Selecting vertices 217
Selection handles 32

defined 32
gluing to 68
resizing shapes 36, 164, 165
selecting shapes 35, 54
snapping to 155

Selection net 35, 54
Send Backward command 55
Send To Back command 55
Sending drawings through e-mail 124,

134
Sending drawings to Exchange

folders 136
Separator characters 193, 194
Server-side image maps 120
Shadow command 58, 59
Shadows 59

adding to shapes 59
fills and patterns 49, 50, 58
on metafiles 102
setting offset 60

Shape Explorer 48, 232
Shape formulas 31

overview 31
Shape toolbar 7, 50, 51, 52
Shapes 29

1-D and 2-D 30
adding to drawings 11, 12
adding to new stencils 225
aligning 158, 162, 166, 167
area and dimen-

sions 162, 164, 165, 166
center of rotation 46
chart and graph shapes 220
closed and open shapes 30, 210, 214
colors 149
complex 209, 210, 212, 214
connecting and disconnecting 65,

71, 72
connection points 33, 69
connectors 65, 66, 70, 71, 72, 74
control handles 34

Shapes (continued)
control points 33
converting 101
copying 47
creating 207, 208, 209, 214
creating from databases 185, 188,

190, 191, 197, 199, 200, 201
creating from text files 192
custom properties 177, 178,

179, 180, 181, 182
cutting 12
defined 29, 30
deleting 12, 43
distributing 166, 168
dragging and dropping 40, 41
drawing 207, 208, 209, 214
drawing scale 18, 169, 170, 171
duplicating 47
editing 36, 38, 39, 216, 217
embedding and link-

ing 128, 129, 130, 131, 132
events 202
exchanging Lotus Notes

data 203, 204, 205
extendable shapes 221
fills 58
flipping and rotating 33, 44, 45, 92
formatting 49, 50, 52, 57, 138, 139
gluing 66, 68
grouping and ungrouping 42, 43
handles 32
help files for  shapes 12
holes in shapes 214
information about shapes 12
instances 217, 218
intersecting 211, 213
inventories of

shapes 177, 180, 181, 182
layering 143, 147, 148, 149, 181
laying out automatically 151,

153, 154
linking to data-

bases 195, 197, 199, 200
linking to files or Web

sites 227, 229, 230
locking 34, 173, 174, 175
locking and unlocking 175
master shapes. See Master shapes
merging and splitting 210, 211,

213, 214
moving 40, 41, 164, 165
nonprinting 116
offsetting 215, 216
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Shapes (continued)
on rotated pages 19
overlapping shapes 210, 213, 214
pasting text 77
patterns 60, 61
preventing selection 174
protecting and

unprotecting 173, 174, 175
reshaping angles in 38, 217
saving as HTML

pages 119, 120, 121, 122
saving in Web-compatible formats 122
saving on stencils 225, 226
searching for 48
segments 33, 37, 209, 212
selecting and deselecting 35, 52,

54, 149
shadows 58, 60
simplifying 212
size and posi-

tion 155, 162, 164, 165, 166
sizing 36, 37, 162, 164, 165, 166
smoothing 212
snapping into place 155, 156
stackable shapes 220
styles 52, 137, 138
subtracting 211
text 75, 76
transparency 59
vertices 33

ShapeSheet spreadsheets 31
database links 202
groups 42
inserting Lotus Notes data 205, 206
linking shapes to database records 197
overview 31
Print ShapeSheet Wizard 232

Shortcuts for bulleted lists shortcut 82,
83

Shortcuts for copying formatting 57
Shortcuts for duplicating shapes 47
Shortcuts for formatting text 87
Shortcuts for generating reports 182
Shortcuts for hiding or showing

toolbars 7
Shortcuts for rotating pages 21
Shortcuts for text 76, 77
Shortcuts for turning pages in full-screen

view 28
Show Master Shapes command 218
Show ShapeSheet command 31
Simplifying shapes 212

Size & Position command 162, 164,
165, 166

Size of drawings 21
Size of paper 21
Sizing. See Resizing
Small caps text 87
Small print jobs 112, 113
SmartShape Wizard 232
Smoothing shape outlines 211, 212
Snap & Glue command 68, 156
Snapping shapes into place 155

automatic alignment 156
options for layers 149
overview 155
snap settings 156

Solid glue 66
Sorting pages 25
Spacing around small drawings 113
Spacing between lines of text 88, 90
Spacing in grids and rulers 159, 160,

161
Spacing in text block margins 90, 91
Spacing shapes evenly across pages 168
Spacing shapes evenly by offsetting 215,

216
Spline tool (freeform tool) 208
Splines 208

creating 208
Custom Fit command 212
Fit Curve command 211

Splitting shapes 210, 213
Spreading out shapes evenly 166

automatic layout 151, 153, 154
distributing 166, 168
offsetting 215, 216

Spreadsheets 186, 190, 191
SQL Server databases 195
Square shapes 208
Stackable shapes 220
Stacking order of shapes 55

changing order 55, 78
layers 143, 144
order of selection 52

Stamp tool 12, 47
Stamping shapes 12, 47
Standalone stencils 8

adding shapes to 222
creating new stencils 219, 225, 226
custom properties in shapes 179, 180
deleting masters 225
editing 179, 224
overview 8
working with stencils 8

Standard Visio toolbar 6
Starting drawings 9, 10
Starting Visio 10
Static glue 66
Stencil Report Wizard 232
Stencils 8

adding master shapes 219, 222, 223
arranging icons 222, 226
changing master display 8
copying 175
creating 219, 225, 226
deleting master shapes 225
displaying 175, 217, 218
editing master

shapes 175, 179, 217, 218, 224
floating or docked 8
local stencils 8, 179, 217, 218, 219
master custom properties 179, 180
moving stencils 8
opening 175, 176, 222
overview 8
protecting 173, 175
reordering icons 226
saving 226
searching for 48
standalone sten-

cils 8, 175, 179, 219, 222
Storing data in shapes. See Associating

shapes with data
Strength of snap or glue 156
Stretching patterns along lines 62
Stretching patterns in custom fills 63
Stretching shapes 220, 221
Style command 138, 141
Style lists 52, 86, 138
Styles 139

applying 52, 137, 138
based-on styles 139
changing 141
copying 140
creating 138, 139
deleting 140
editing 139
fill styles 52, 138, 139
line styles 52, 138, 139
local formatting 141
locking or protecting 173
reverting to original 141
text styles 86

Styles dialog box 138
Subdivisions in rulers and grid 159, 161

changing 159, 160, 161
snapping to 155
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Subscripted text 87
Subselecting shapes in groups 54, 78, 79
Substitution codes in HTML templates

121
Subtract command 211
Subtracting shapes 211
Summary file information 13
Superscripted text 87
Switching glue types 67
Switching pages 24

background or foreground pages 27
hyperlinked shapes 230
page navigation 24
page navigation in full-screen view 28

Switching to another file 230
hyperlinked shapes 230

Synchronizing linked databases and
drawings 202

T
Tab-delimited text files 186, 188, 190,

191, 192
Tables in databases 183, 199, 200, 201
Tables in text 81
Tabs 79

adding or deleting 79, 80, 81
changing position 81
creating tables 81
in bulleted or numbered lists 82

Tag Image Format files 103
Tall page orientation 17, 18
Technical Support and Customer

Service 2
CompuServe forums 3
international support 4
reaching Technical Support 4
support period 3
Visio World Wide Web address 3

Templates 137
choosing 9, 10
creating 142
data file templates 186, 188, 190,

191, 192
help 9, 10
HTML templates 120, 121, 122
opening 176
overview 137
protecting 173, 175
saving 13
searching for 48
styles 138, 139

Text and text blocks 75
adding 75, 76
aligning 88, 89, 90, 91
aligning rulers with 80
background color 93, 94
copying formatting 57
deleting 78
editing 75, 77, 78
fields. See Fields
formatting 49, 57, 85, 87, 94
groups 78, 79
indents 88, 89
independent text 77, 78
line spacing 88, 90
margins 90, 91
moving 92, 93
opening 76
overview 75
replacing 76, 78
rotating 92
selecting 76
sizing 92
spacing 88, 90
styles 52, 86, 138, 139
tables 81
tabs 79, 80, 81
text files. See Text files
Text toolbar 85
typing into shapes 76

Text block tool 76, 92
Text command 87
Text data files. See Text files
Text fields. See Fields
Text files 103

creating drawings from 190, 191, 192
file structure for importing 193, 194
importing into Visio 103
organization chart data files 186
project timeline data files 190
setting up data

files 186, 188, 190, 192
text file format 103

Text style list 52, 86, 138
Text styles 137

applying 52, 86, 138
based-on styles 139
creating 138, 139
editing 139
styles overview 137, 138

Text tool 75
Text toolbar 7, 85, 86
Text-only shapes 75, 77, 78
Tick marks on rulers 160, 161

TIF file format 103
Tiled drawings 112, 113

creating tiles 112, 113
editing in print preview mode 109
previewing 108, 109

Tiling patterns along lines 62
Tiling patterns in custom fills 63
Tiling windows 7, 132
Time 190

in project timeline files 190
on printouts 117

Timelines 190, 191
Times on printouts 117
Titles of report shapes 183
Tool tips 7
Toolbars and buttons 6

arc tool 208
connection point tool 33, 69
connector tool 71
displaying 6, 7
displaying palettes 51
drawing tools 207
ellipse tool 209
Format Painter button 57
freeform tool 208
line tool 208
pencil tool 208
pointer tool 21
rectangle tool 208
rotation tool 19, 45, 46
Shape toolbar 50, 52
stamp tool 12, 47
text block tool 76, 92
text tool 76
Text toolbar 85, 86

Tools. See Toolbars and buttons
Tooltips 7
Top margin in text blocks 91
Top To Bottom drawing direction 152
Transferring formatting 57, 94
Transparent shapes or patterns 59
Triggering linked database and drawing

refresh 202
Trim command 213
Trimming objects 213
Troubleshooting Organization Chart

Wizard 189
Turning features on or off

automatic zooming 77
connection points 69
full-screen view 28
glue 68
line jumps 73
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Turning features on or off  (continued)
page rotation 21
snap and glue 156

Turning pages 24
by right-clicking shapes 230
page navigation 24
page navigation in full-screen view 28

Two-dimensional shapes. See 2-D shapes
TXT files. See Text files
Typing text 76

into shapes 76

U
Uncrossable shapes. See Placeable shapes
Underlined text 87
Undirected drawings 152
Undo command 210
Undoing formatting changes 141
Ungroup button or command 43, 101
Ungrouping converted

metafiles 101, 103
Ungrouping shapes 43
Union command 210
Uniting shapes 210
Units of measure 169

in rulers 161
page and drawing units 18, 169, 171

Unlocking shapes 175
Unprotecting drawings or shapes 175
Update Property Report command 183
Updating links 99
Updating page names 25
Updating shape data reports 182, 183
Updating Visio-to-database links 202
Upright line ends 62
URLs 3, 227

adding links to drawings 227
Internet addresses for Visio 3
jumping to linked sites 230

V
Variable grids 159
Venn diagrams 213
Vertical connector line jumps 73
Vertical flipping 44
Vertical shape alignment 167
Vertical shape distribution 168
Vertical shape resizing 162
Vertical text block alignment 90, 91
Vertices 33

adding 33, 37
converting shape segments 212
deleting 38
dragging 38, 217

Vertices (continued)
drawing segmented shapes 209, 212
editing shapes 216, 217
magenta 33, 38
on routable connectors 70, 74
reshaping shapes with 38, 217
selecting 217
snapping to 155

View toolbar 7
Viewing links 99
Viewing pages 28

full-screen view 28
HTML pages 120, 121
rotating page view 19, 21

Visio 10
customizing display 28
installing ODBC tools 196
Microsoft Office compatibility 123
opening files 176
starting 10
Technical Support and Customer

Service 2, 4
toolbars 6
Visio Knowledge Base 3
wizards 231
World Wide Web site 3

Visio Shape Explorer 48

W
Web browser 124, 125
Web sites. See World Wide Web sites
Web toolbar 7
Wide page orientation 17, 18
Width of shapes 162
Width of text blocks 92
Windows 7

arranging workspace 7, 132
floating stencil palettes 8
main Visio window 7
print preview window 108, 109

Windows (Microsoft) 123
Microsoft Office Binder 126
Office compatibility 123, 135, 136

Windows bitmaps 103
Windows help for shapes 12
Windows metafiles. See Metafiles
Windows Quick View 13
Wizards 231

Build Region Wizard 231
Chart Shape Wizard 220, 221, 231
Custom Properties Editor 179,

180, 231
Database Export Wizard 183,

184, 231

Wizards (continued)
Database Wizard 195, 197,

199, 200, 201, 202, 231
Flowchart-TQM Diagram Wizard 232
Office Layout Wizard 232
Organization Chart Wizard 186,

188, 232
overview 231
Page Layout Wizard 26, 232
Print ShapeSheet wizard 232
Project Timeline Wiz-

ard 190, 191, 192, 232
Property Reporting Wizard 181, 182,

232
searching for 48
Shape Explorer 48, 232
SmartShape Wizard 232
Stencil Report Wizard 232

WMF file format 103
Words

formatting 87
selecting in text 76

Workspaces
saving 13

World Wide Web sites 3, 227
jumping to linked sites 230
linking drawings to Web sites 227
opening Visio files in browsers 124,

125
saving Visio files as HTML. See HTML

and Internet tools
saving Visio files in Web-compatible

formats 122
Visio Web site address 3

Writing information to databases 183,
184, 195, 197

Writing information to Lotus
Notes 203, 204, 205

X
X marks 71
XLS file format. See Microsoft Excel files

Y
Yellow line symbols on icons 72

Z
Zero point on rulers 20, 80, 160, 161
Zooming

to view text 76
turning off automatic zooming 77

ZSoft PC Paintbrush files 103
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