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Welcome to the world of Infini-D! The tutorial projects in this book

are designed to help you understand how Infini-D can help you create

professional quality 3D images and animations. Some tutorials here

may be of more immediate use than others, so feel free to skip to the

sections if they do not seem appropriate for your needs. This book

assumes that you have a basic working knowledge of the operating

system that you are using. For more information about your operating

system, please refer to the documentation that came with your

system.

Welcome

Chapter

1
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TUTORIAL OVERVIEW
The lessons in this book are organized into two groups: introductory tutorials and
advanced tutorials. Chapters two through four cover the Infini-D basics, such as how to
create objects, apply surfaces and make a simple animation.It is recommended that every
Infini-D user complete these basic tutorials. Chapters five through seven show how to tap
into the real power of Infini-D. They demonstrate the ins and outs of building custom
objects and creating advanced animations. It is best to save these last tutorials until you
have a good understanding of the basic concepts introduced in the earlier chapters.

Chapter 2—Introduction to Infini-D
This chapter provides an explanation of the basic concepts of 3D and animation. It
explains how the 3D world works, as well as how to use Infini-D’s tools to create a
scene. The following topics will be discussed in this chapter:

• Launching Infini-D

• Using view windows to show objects in the 3D world

• Creating and manipulating objects

• Choosing the rendering mode of an image

• Saving Infini-D scenes and image files

Chapter 3—Building a Basic Scene
In this tutorial you will build a basic scene, complete with a logo, 3D text and a 
background image. Below is a list of what can be found in this chapter: 

• Using the Control floater

• Creating objects

• Using EPS files to create objects 

• Applying surfaces to objects

• Using background images

• Using environment maps

• Changing the rendering mode of view windows

• Rendering to an image file

Chapter 4—A Simple Animation
This tutorial will explain how to use the Sequencer window to create animations. 
The eventmark concept introduced here is the basis for all animations: all users should
understand it well. The following topics will be covered:

• Using the Sequencer window

• Creating and manipulating eventmarks

• Using Animation Assistants
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• Rendering an animation to a movie file

Chapter 5: Creating Objects
This chapter demonstrates how to create and customize many different kinds of objects.
It is also an introduction to the SplineForm™ workshop, which is a powerful modeler in
which almost any object can be hand-crafted. This chapter shows how to use the Control
floater for precise positioning of objects in 3D space. In this chapter you will practice:

• Using the Control floater to resize objects

• Building extruded objects

• Building freeform objects

• Using QuickDraw 3D to view objects in the workshop

Chapter 6: Complex Surfaces
This chapter will demonstrate how to customize existing surfaces and how to build new
ones.You will be introduced to the rich variety of surfaces available within Infini-D
but more specifically, this chapter demonstrates:

• Customizing basic surfaces

• Using image maps as surfaces

• Making multiple layered, composed surfaces

• Using alpha channels to create transparencies in surfaces

Chapter 7: A Complete Animation
This chapter uses the scene built in chapters 5 and 6 to produce a complete anima-
tion. It fully explores the Sequencer window and is strongly recommended for anyone
desiring to use Infini-D for animation. This chapter demonstrates:

• Using the sequencer to animate objects

• Linking objects

• Creating linear and spline eventmarks

• Using velocity graphs.

Conventions Used In This Manual
Infini-D was launched in 1991. Since then, we have heard from many users about ways
they have been able to take best advantage of its power. Our years of engineering have
convinced us that these tips or short cuts should be included along with information that
will help you understand a topic. Notes are also included for additional clarification or
to help solve anticipated problems.

This is the format of a note. We hope you find them useful.
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This tutorial is as much an introduction to the Infini-D world as it is a

hands-on tutorial. The purpose is to help you understand the 3D envi-

ronment and explain how to use some of the tools needed to work

within it. The following topics are addressed in this chapter:

• Launching Infini-D

• Understanding view windows

• Types of objects

• Creating and manipulating objects

• Choosing the quality of an image (choosing a rendering mode)

Introduction to Infini-D

Chapter
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LAUNCHING INFINI-D
If you have not already installed Infini-D onto your hard drive, it is time to do so. The
Infini-D User’s Manual contains instructions for software installation. 

Macintosh Double-click on the application icon to launch Infini-D.

Windows Choose Infini-D 4.5 from the Start menu or double-click the
Infini-D.exe icon in the Program Files folder to launch Infini-D.

THE VIEW WINDOWS
Most work in Infini-D is done within its view windows Each window allows you to
look into the same 3D scene from a different vantage point. To view the world from
different sides, open the Left, Bottom, and Back views from the Windows menu. The
views can be resized by clicking on the lower right-hand corner of the window and
dragging the mouse, as you would do to windows in other applications.

Objects are manipulated (positioned, rotated, re-sized, etc.) using the view windows.
To make a view window active, simply click on it with the mouse. There can only be
one ‘active’ window at a time; all of the other windows are inactive. When objects are
manipulated, all view windows are updated to show the current state of the world.
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The Camera View Window
Most views in the 3D world are not attached to
objects. The camera views, however, are special: Each
is attached to a camera, allowing you to view every-
thing that can be seen through the camera’s lens.
Since cameras are actual objects in the 3D world and
can be repositioned, camera views can be animated
over time.

A camera view gives a real-life perspective of the scene.
If an object is very close to the camera, it will appear large. If the object is moved into
the distance it will appear small.

The Standard view, Front, Back, Left, Right, Top and Bottom views are orthographic
views. Objects appear at their ‘actual’ size, regardless of how far away they are.
Orthographic views are very useful when building a scene; it is easy to align objects
with precision.

Traditionally, the Top, Front, or Right views are used to build the scene, while the Camera
view is used to view the final scene.

THE TOOLBAR
The Toolbar is the gray bar across the top of the screen.It contains the most common
Infini-D tools.These tools allow you to create, customize,and re-position objects in a scene.

In order to use a tool it must first be selected by clicking on the tool’s icon.

The Object Tools
You can fill your scene with several different kinds of objects created within Infini-D.
Each object type has a corresponding tool, found on the left-hand side of the Toolbar. A
description of object types and their tools follows.

Primitive Objects
Primitive objects are basic shapes, such as a cube, a sphere, or a cylinder. To
select one of the objects, click and hold on the Primitive tool. When a list of
objects appears, move the cursor onto the desired object and release the
mouse button.
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Extrude Objects
Extrude objects are based on outlines that are ‘dragged’ through 3D space to
make a 3D object.

Lathe objects
Lathe objects are built from a shape that is ‘spun’ around an axis. Examples of
lathe objects are vases, tires, and drinking glasses.

Spline Objects
Spline objects, also referred to as ‘freeform objects’, are complex objects that
combine the properties of lathed and extruded objects. See Chapter 5 for 
directions on how to build freeform objects. 

Mesh Objects
Mesh objects are built out of many small pieces or polygons. Many other 3D prod-
ucts work only with mesh objects. DXF and 3DMF files contain 3D mesh objects.
Any object created within Infini-D can also be converted to a mesh object.

Text Objects
Text objects are objects built from the fonts loaded in your system. They can
have bevels which make letters stand out in 3D. 

Terrain Objects
Terrain objects are special mesh objects. They are useful for creating moun-
tains, canyons, and other natural landscapes.

Particle System Objects
Particle system objects are objects that emit small particles into the ‘air’. These can
be used as water fountains, fireworks, snow, etc., and will put pizzazz into a scene.
Particle warp objects are used to affect the flow of particles in different ways—
wind, gravity, etc.

Light Objects
Lights are also objects. They come in six flavors: ambient lights, distant lights,
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point lights, tube lights, spot lights, and targeted spot lights. Each adds illumina-
tion to your scene in a different way. The default new scene in Infini-D contains
one distant light and one ambient light.

Camera Objects
Cameras can be added if you want additional views of the World. There are two
types of cameras: standard (or ‘free’) cameras, and target cameras. Standard
cameras can be focused on anything in the scene, while target cameras always
point at a chosen target object. There can be many cameras of each type in the
same scene. The default new scene in Infini-D contains a targeted camera.

The object tools are not the only way to add models to your scene. Models created in
other applications can be added as long as the file is saved in the correct format. DXF
and 3DMF files can be added to the scene by choosing ‘Import objects’ from the File
menu, and then loading the file that contains the object. Objects can also be created
from EPS outlines imported from illustration programs such as Adobe Illustrator.

CREATING OBJECTS
Placing objects in a scene is simple: First, select an object tool from the Toolbar. Then
simply click in one of the view windows and the object will appear. Try this:

Step 1: Click and hold on the Lathe Object tool and choose the wine glass from the list
that appears.

Step 2: Click in the Camera view to create a wine glass.

Initially the wine glass appears as a wireframe outline. You’ll learn how to change the
wireframes to realistic, shaded images later in this chapter.
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MANIPULATING OBJECTS
Once an object is in the scene, you will probably want to manipulate it in some way
to give it a different size or rotation, for example, or to place it closer to another object
in the scene. The tools to do this can be also found in the Toolbar. To use a tool,
simply click on it and then use it. Below is a description of each of the tools.
Experiment with each tool so you know how it works and what it can do for you.

Refer to the Infini-D Quick Reference Card for useful modifier keys and keyboard shortcuts to
use with the tools described here.

The V-Plane Tool
The V-Plane tool is the most commonly used of all tools. It is a multi-purpose
tool that is used to re-position an object in the world. With the V-Plane tool
selected, click and drag an object up, down, left, or right, parallel to the plane
of your screen.

The H-Plane Tool
The H-Plane tool is similar to the V-Plane tool in that it will re-position objects
with a simple click and drag. However, dragging objects will move them to the
left, to the right, closer to the view window, or further away from it.If you want
to move an object closer or into the distance, the H-Plane tool is the one to use.

The Rotate Tools
The X, Y, and Z Rotate tools are used to rotate objects in any direction. To rotate
or spin an object, select a rotate tool, then click and drag the object. The x rotate
tool rotates objects around the x ( east and west ) axis; the y rotate tool rotates
objects around the y ( north and south ) axis; and the z rotate tool rotates
objects around the z (up and down ) axis. You’ll learn more about the x, y and
z directions in the next chapter, but experiment and get the feel of it here. 

Uniform Scale Tool
The Uniform Scale tool can increase and decrease the overall size of an object.
Select the Uniform Scale tool and click and drag on an object to resize it. You
may find yourself using this tool frequently when composing a scene, to adjust
the size of an object in proportion to the sizes of the other objects in the scene.

Squash and Stretch Tool
The squash and stretch tool will ‘squash’ or ‘stretch’ an object in one direc-
tion, depending upon which side of the object you click. Select the Squash
and Stretch tool then click and drag on a side of the object. The shape of the
selected object changes as you drag; drag the object to the desired length then
release the mouse button. Click and drag on the edge of an object’s bounding
box to scale in two directions at once.
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Link Tool
The Link tool can be used to link two or more objects together, causing them
to behave as one object. Object linking is used to build complex objects out of
simpler components. Feel free to try it here (you’ll need at least two objects in
the scene ). To use the Link tool, select the object you would like to be ‘child’,
click on the Link tool, and then click on the object you would like to be the
‘parent’. If you click on a third object,the first two objects become linked to the
third.Now, move the parent and notice that the children move with it. There
are four different kinds of links, free, position, pivot and full. (For more informa-
tion on linking,see Chapter 8 of the User’s Manual.)

Unlink Tool
The Unlink tool allows you to unlink a child object from a parent object,
which is useful when objects have been linked together but should be separated.
To use it, first select the parent object, choose the Unlink tool, and then click
on the child object you would like to unlink.

Zoom Tool
The Zoom tool allows you to zoom in or out of the active window. There are
two different zoom tools that work in different ways. With the Marquee Zoom
Tool selected, clicking on a view window with the Zoom tool selected will
zoom in a certain amount. To zoom in on a precise point in a window, click
on a view and hold the mouse button. While the mouse button is pressed,
drag a marquee (a rectangle) around the area into which you wish to zoom. To
zoom out, hold down the Option/Alt key and click on the desired window.
With the interactive zoom tool selected, click and drag left or right to zoom in
or out the desired amount.

When you zoom in or out of the Camera View, you are actually changing the focal length of
the camera’s lens. Zooming in or out too much can make a fish-eye or flat image, just like
with a real camera lens.

Hand Tool
The Hand tool is useful when you want to move the point of view of a
window. Simply click and drag on the desired window; the Hand tool actually
causes the view to move, instead of the objects. In a Camera View, the hand
tool actually moves the camera object.

Orbit Tool
The Orbit tool rotates the camera around the target object while keeping the
camera focused on it. The Orbit tool can only be used on camera views, and can
only be used when the camera is a target camera. (For more on target cameras,
see Chapter 17 of the User’s Manual.)
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Roll Tool
The Roll tool will keep a camera pointing ahead but will spin it on its side,
much like a screw rotates as it is being threaded into a hole. Select the Roll
tool, click on the Camera view and drag the mouse to the left and to the right.
The camera will roll from side to side but remain looking ahead.

Marquee Render Tool
The Marquee Render tool gives you a detailed preview
of a portion of a view window. It can be set to either
ray trace or phong shade, which will determine the
quality of the preview produced. Click on the Marquee
Render tool, choose either the shade or trace tool, then
click on the desired window and drag a rectangle
around the area to be rendered in detail. The different
levels of image quality are explained later in this chap-
ter, and can be set in the Preferences dialog, in the
Tools tab.

THE COMMAND FLOATER
The Command Floater contains settings and options that affect
the Infini-D scene. Some settings
affect a view window, while others
may affect a selected object. The
name of the currently selected object
appears near the top of the Command
Floater in the Name field.Think of
the Command Floater as the ‘control
room’ for the scene; you will use it
throughout the creation process.

Immediately to the right of the Name field are three icons: 
a sphere, a light and a camera. These buttons can be used to select any object in the
scene. To select an object, click and hold on the appropriate icon and choose the object
from the list that appears. ‘Normal’ objects are found under the first icon. Lights are
found under the second icon, and cameras can be selected with the third icon.

Across the top of the Command Floater are five tabs. When a tab is selected, certain
settings and options appear in the window pane below.Avery brief description of each
tab follows, but you should consult the User’s Manual for further explanations of the
contents of the Command Floater.

• Object—The Object tab contains settings for the selected object.
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• Modifiers—Here you will find tools that ‘deform’ objects in different ways. Twisting
and bending are examples of the ways the modifier tools can change an object.

• Surfaces—This tab contains the surfaces that can be applied to objects. Custom
surfaces you create will also be placed here. ( You will learn to apply surfaces in
Chapter 3, while you will build custom surfaces in Chapter 6. )

• Display—These settings control the way the World appears in each view window.
For example, objects can be shown as simple ‘wireframe’ outlines or realistic objects
that are reflective and transparent. You’ll learn more about this later in this chapter.

• Filters—From the Filters tab you are able to apply 2D filters to objects, lights, and
view. Filters that are compatible with  Adobe After Effects™ can be used.

You may wish to familiarize yourself with the tabs in the Command Floater before
continuing on to more detailed material.

CHANGING THE IMAGE QUALIT Y OF
VIEW WINDOWS
The process of turning object data inside the computer into an image on the monitor
is called rendering. There are different ways to render an object to the
screen—these are called rendering modes. The more detailed the
rendering, the more time it will take for the object to appear on the
screen. The rendering mode can be changed from the Display tab of
the Command Floater 

Step 1: Click on the Display tab of the Command Floater. A
View pane and a View Detail pane appear in the
Command Floater.

Step 2: Click and hold on the Mode popup menu.

Alist of rendering modes appear.Choosing a rendering mode causes the active view
window to be rendered using the new rendering mode. A description of each rendering
mode follows:
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• Bounding Box is sometimes refered to a “BBox.” Bounding Box takes the least time
to render, but objects only appear as boxes.

• Wireframe is the default rendering mode.The objects appear as wire outlines.
Generally, the wireframe mode is used only when building a scene. A higher quality
rendering mode is used when the final image or animation file is made.

• Flat shading will show solid, shaded objects. It is the fastest ‘shading’ mode, but
objects are limited to one color per polygon.

• Gouraud shading will start to show multi-colored surfaces; it is still fairly fast.

• Phong shading will produce a high-quality, realistic rendering of objects in the
scene. Surfaces of objects are sharp and crisp when Phong shading is used. Phong
shading is usually used to render the final version of a scene because of the high
quality it produces.

• There is one additional rendering mode called Ray Tracing that does not appear in
the Render Mode list. In older versions of Infini-D, ray tracing was the only render-
ing mode that showed transparent and reflective objects. Since Phong shading now
shows the transparent and reflective qualities of object surfaces, ray tracing is rarely
needed. Ray tracing renders surfaces slightly more accurately than Phong shading,
but in almost all cases the difference is not noticeable. Ray tracing is required to use
Infini-D’s Boolean operations.

BBox Wireframe Flat Gouraud Phong Ray Tracing

There are a number of check boxes and pop-up menus in the Display tab, but you
don’t need to use them yet. ( Explanations of these can be found in Chapter 23 of the
User’s Manual. )

Try each rendering mode after placing a few objects in your scene. Notice the differ-
ences in qualities they produce, and the different time each mode takes to render.
Since objects only have white surfaces now, there may not be a visible difference with
Gouraud shading, Phong shading and ray tracing. You will see a difference, however,
when detailed surfaces are used.

You should now be familiar with the tools needed to work in the 3D world. Feel free
to experiment for yourself; you’ll become more proficient with the tools and ready to
build a basic scene, complete with objects, surfaces and a background image. 
That’s next!
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In this chapter, you will learn how to position objects in a scene using

the Control Floater. You will also learn to make 3D text and logos.

The final mini-project in this chapter is an advertisement for

‘Donkey-Back Canyon Tours’, which will be used in the next chapter

to create an animation. A list of topics in Chapter 3 follows:

• The Control Floater

• Text objects

• Importing EPS logos

• Applying surfaces to objects

• Background images

• Environment maps

• Saving an Infini-D scene file

• Rendering to an image file

Building a Basic Scene

Chapter

3
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SETTING UP A NEW SCENE
Step 1: Create a new scene by choosing ‘New’ from the File menu.

The default Camera view is currently viewing the World from an angle, which is fine
most of the time. However, it will be easier to animate this scene in the next chapter if
the Camera is viewing the world from the front, like the Camera view.

Step 2: Click on the Camera view to make it the active window.

Step 3: Click on the Display tab of the Command Floater.

Step 4: Click and hold on the Bookmarks arrow button. Then choose Target
Front from the list that appears.

Bookmarks are preset settings for the view windows
that contain the view’s position, orientation, and
zoom factor. You can create your own bookmarks by
clicking the Add button. This is useful when you
know you will use a particular camera angle frequently.
(For more information on Bookmarks, see Chapter 17
of the User’s Manual.)

Another thing that needs to be done is to turn on an option called ‘Underground’.
Underground is off by default, which means that objects below the ground plane are
not visible.
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Step 5: Click once on the blue arrow on the left 
side of the View Detail pane. The View 
Detail pane opens, showing more options for the
active view window.

Step 6: Click once on the Underground checkbox so
that it is checked.

If there were any objects below the ground plane, they would
now become visible. The last thing is to remove the Grid
Plane from the Camera view.

Step 7: Click once on the Grid Plane 
checkbox so that it is not checked.

The grid plane is the grid that appears in the Camera view when a new scene is made. It can
be helpful when positioning objects in a scene because it gives you a better sense of where an
object is placed but it does not appear in the final image. In this case, however, it isn’t
needed.

CREATING 3D TEX T
The first thing to do is to create the ‘Donkey-
Back’ text object. 

Step 1: Click on the Text tool which is
located in the Toolbar. 

Step 2: Click in the Camera view. The Text
dialog appears.
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Step 3: Type ‘Donkey-Back’ in the text field. 

Step 4: Click on the Font button to select a font.

In the following graphics, a font called “Metropolis ICG” from Adobe was used. If you
do not have this font, feel free to use any font you wish.

Step 5: Choose a Straight bevel by clicking on the Straight 
bevel button. Set the Size to 50% and the Depth to 20%.

Step 6: Click the OK button.

The text should appear in the Camera View. Chances are, it is too large to fit completely
into the camera window.

Step 7: Click on the V-Plane tool from the Toolbar.

Step 8: Click on the ‘Donkey-Back’ text and drag it to the 
top of the Camera view.
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The ‘Donkey-Back’ text should fit nicely at the top of the Camera view. It should be
almost as wide as the camera view, with a little room to spare on each side. If your
text is the correct size, you are all set and can skip steps 9 and 10. If ‘Donkey-Back’ is
too large or too small, then you must re-size it.

Step 9: Click on the Uniform Scale tool from the Toolbar.

Step10: Click and hold on the ‘Donkey-Back’ text. Drag the mouse to the left or
right to re-size the text; It should fit completely in the Camera view.

Once ‘Donkey-Back’ is positioned correctly, it is time to create the ‘Canyon Tours’ text.
It is possible for both words to be one text object, but in this case they must be sepa-
rate objects (so they can be animated separately in the next chapter).To create the text:

Step 1: Click on the Text tool from the Toolbar. Then 
click in the Camera view to open the Text dialog.

Step 2: Type ‘Canyon’ in the text field.

Step 3: Choose a font, set the bevel to Straight with Size set to 50% and 
Depth set to 20%. Click OK . 

Step 4: Click on the Text tool again, and click in the Camera view to 
open the Text dialog.
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Step 5: Type ‘Tours’ in the text field.

Step 6: Choose a font, set the bevel to Straight with Size set to 50% and Depth
set to 20%. Click OK. 

These two text objects need to be positioned at the bottom of the Camera view, as if
they were one object. ‘Canyon’ should be on the left side and ‘Tours’ should be on the
right side. Unfortunately, ‘Canyon’ and ‘Tours’ are probably not the correct size. They
need to be re-sized so that their letters are the same size as the letters of the ‘Donkey-
Back’ text. 

Step 7: Click on the Uniform Scale tool.

Step 8: Click and hold on the ‘Canyon’ text; drag the to re-size it, until it is the
same size as the ‘Donkey-Back’ text.

Step 9: Click on the ‘Tours’ text and make it the same size as the ‘Canyon’ text.

Now center ‘Canyon’ and ‘Tours’ at the bottom of the Camera view.

Step 10: Click on the V-Plane tool.

Step 11: Click and drag ‘Canyon’ to the bottom-left side of the Camera view.
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Step 12: Click and drag ‘Tours’ to the bottom-right side of the Camera view.

IMPORTING AN EPS FILE
The final object in this scene is a logo that will be placed in the middle of the view,
between the text objects. It is saved in the EPS file format, a common file format used
by applications such as Adobe Illustrator™. To Import the logo:

Step 1: Choose ‘Import -> EPS’ from the File menu.
The Import EPS dialog will appear.

Step 2: Navigate to the Tutorial Files folder of the Infini-D CD-ROM or to
your hard drive if you chose to install them.

Step 3: Select the ‘Donkey Logo.eps’ file, then click Open.

The logo should be positioned in the center of the Camera view.

Step 4: Click on the V-Plane tool.

Step 5: Click and drag the logo object to the center of the 
Camera view, if it is not already centered.
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Step 6: Name the logo by clicking the Display tab of the Command Floater
and typing “Donkey Logo” in the name field at the top of the floater.

THE CONTROL FLOATER
You may find it difficult to center objects precisely using the V-Plane tool; it requires a
good eye and some trial and error. The Control Floater is quite useful when objects
need precise sizes, rotations or positions. Here’s a brief tour of the Control Floater:

Step 1: Open the Control Floater by choosing 
Information from the Windows menu.

The Control Floater has three tabs: Info, Navigation, and Animation. 

Step 2: Click on the Info tab. 

The numbers in the Info tab represent information about the selected object. Since
objects are three-dimensional, the numbers in the Info tab come in groups of X, Y, and Z
values.

• The top group of numbers shows the position of the object in the 3D world.

• The second group shows the orientation or rotation of the object.

• The third group shows its dimension values (also called scale values). When the
squash and stretch tool is used on an object, the X, Y and Z values change. When
the Uniform Scale tool is used, the fourth number changes; the fourth number
represents the overall dimension of the object. 

• There is a fourth group of numbers that can be shown or hidden using the pop-up
arrow on the right. This group of numbers represents the object’s position in relation
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to its centerpoint. This affects how an object rotates, but is not used as often as the
position, rotation, and dimension fields.

You may be wondering how to tell direction from the X, Y, and Z values. Think of the
X direction as east and west, and the Y direction as north and south. The Z direction is
the height (up and down). If an object’s X,Y, and Z position values are all set at zero, the
object is at the center of the World. Chances are that the object will also be in the center
of the view windows, but if you have changed view windows by moving the camera,
using the zoom or pan tool, etc., the object may not be centered in the windows.

Using the Control Floater to Center Objects 
in the Camera view
The Control Floater will be used to center ‘Donkey-Back’ horizontally at the top of the
Camera view, and the logo will be centered both horizontally and vertically in the view.

Step 1 Click on the V-Plane tool, and select the ‘Donkey-Back’ text object.

Look at the X Position value in the Info tab of the Control Floater. Setting this position
value to zero moves it to the horizontal center of the World which, in this case, also
happens to be in the center of the Camera view. 

Step 2: Set the X position value in the Information 
tab to zero and press ENTER.

The text will automatically be moved to its new location

Step 3: Click on the logo object to select it.

Step 4: Set its X and Z positions to zero, and press ENTER.

The logo is now centered in the horizontal and vertical center of the World. In this
case, it just happens to be the exact center of the Camera view.
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You now see how it is easy to move objects to precise positions with the object floater. You
may still want to use the move tools from time to time, however. For example, it is difficult 
to use the object floater to center ‘Canyon’ and ‘Tours’ side by side in the window. In this 
case just drag them with the V-Plane tool. However, align them vertically by setting their z
position values the same.

APPLYING SURFACES TO OBJECTS
It is time to give our objects some color. First, we will make the wireframe outline
objects appear shaded. To shade objects in a view window: 

Step 1: Click on the Camera view to make it the active window.

Step 2: Click on the Display tab of the Command Floater.

Step 3: Click on Wireframe and change it to Flat.

Now the objects in the Camera View appear as shaded objects, rather than just wire-
frame outlines.

Step 4: Click on the Surfaces tab of the Command
Floater. Then click on the tab that reads‘Basic’. 

A list of Infini-D’s default surfaces appears in the list below. All
surfaces in the list can be seen if you click and drag the scroll
bar to the right of the list.

Step 5: Select the ‘Donkey-Back’ text by clicking on 
it with the V-Plane tool.

Step 6: Double-click on the Amber surface to apply it 
to the text.
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Step 7: Select the logo object and double-click on the 
Robin’s Egg Bluesurface to apply it to the logo.

Step 8: Select the ‘Canyon’ text and double-click on the Powder Bluesurface.

Step 9: Select the ‘Tours’ text and double-click on the Powder Bluesurface.

Objects take on an entirely new look when surfaces are applied. The shading mode
being used now is flat shading, a fast way to get ‘solid’ images of the objects.
Switching the shading mode to Phong produces a much higher quality image, but
takes longer to render. 
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Step 10: Click on the Display tab of the Command Floater and 
click on the Camera view to make it the active view. 

Step 11: Switch the Render to Phong.

Notice the difference in the quality of the image. This scene is almost finished, but
there are three more things that will add some excitement to this scene: another light,
an environment map, and a background image.

ADDING AN ENVIRONMENT MAP
Shiny objects in the real world reflect their surroundings. Unfortunately, the objects in
Infini-D don’t always have objects around them to reflect. What Infini-D does to make
up for this is to use an image to simulate a world around the objects. This image is
called an environment map. When Infini-D renders a view, the colors in the environment
map image are ‘thrown’ onto the objects; objects will reflect the environment map,
depending on how reflective they are. A well-chosen environment map adds a nice
touch to surfaces, as you will see. Here’s how to add an environment map to
your World:

Step 1: Choose Environment from the Edit menu to 
open the Environment dialog.

Step 2: Change the Environment Map setting from None to Load Image. 

26



The standard open file dialog will appear.

Step 3: Navigate to the Tutorial Files folder of the Infini-D 
CD-ROM and select the ‘Canyon Environment.pic’ file.

Step 4: Click Open to return to the Image Info dialog and then click OK to
return to the Environment dialog.

Step 5: Click OK to return to the World .

Notice the difference the environment map makes in Phone Shading mode. The
surface of the logo shows variation, as if it is reflecting the surrounding world.

ADDING A BACKGROUND IMAGE
Background images don’t need much explanation; they simply appear behind the objects
of a scene. Any image or movie can be used as a background image. 

Adding a background image is similar to adding an environment map. To add a 
background image:

Step 1: Choose Environment from the Edit menu. 

Step 2: Change the Background Image setting from None to Load Image. 

The standard open file dialog will appear. 

Step 3: Navigate to the Tutorial Files folder of the Infini-D CD-ROM and
select the ‘Canyon Background.pic’ file. 
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Step 4: Click Open to return to the Image Info dialog. 
Then click OK to return to the Environment dialog.

Step 5: Click OK to return to the World .

SAVING THE SCENE FILE

It is a good idea to save the scene file, because it will be used in the next chapter. 

Step 1: Choose ‘Save As’ from the File menu. 

Step 2: When the standard save file dialog appears, type a name in the text field
and save it onto the hard drive.

A scene file contains all the information necessary to build the scene the way it was
when the file was saved, but it is not an image. Infini-D scene files cannot be read by
other applications . To create an image of the file and use it elsewhere, you must
render it to an image file.

Scene files and image files are less complicated than you may think. Use the analogy of a
recipe and a cake: The scene file is the recipe, while the rendered image file is the cake. If the
final image file (the cake) needs to be changed, the scene file (the recipe) must be loaded and
changed before another cake can be baked.
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RENDERING TO AN IMAGE FILE
Now that the scene is complete, it is time to save it as an image on the hard drive for
future use. This process is called “rendering to disk. “

Step 1: Choose Render from the File menu.

The Render dialog has three tabs: Render, Image, and Animation. 

Step 2: Click on the Render tab to show the rendering options.

Step 3: Set the View to Camera. 

The image is rendered from the View setting, which means that this image will be
taken from the Camera view.

Step 4: Set the Quality to Phong.

Step 5: Set the Anti-Aliasing to low. 

Anti-Aliasing is the process of removing the sharp, ‘jagged’ edges that can appear on
objects, usually near the edges. Low anti-aliasing is very fast, but doesn’t smooth out
the colors as much as high anti-aliasing.

Step 6: Click on the Image tab.
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Step 7: Set the Colors to thousands or millions and set 
the Alpha Channel to none.

Step 8: Set the Width to 320 pixels and the Height to 240 pixels.

Step 9: Click the Render button to open a standard save file dialog.

The file can be saved in a number of different image formats.

Step 10: Choose a file format from the popup menu.

Step 11: Type a name in the text field, choose a place on the hard drive to save
the file, and click Save.

The image may take a minute or two to render. When the image is done, you can view
it in an application such as MetaCreations’ Painter™ or Adobe PhotoShop™. In fact, at
this point the image file is like any other image on your computer: you can edit it in a
paint program, build it into a Web page, or make it your desktop image.
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In this chapter you will work with the objects built in Chapter 3 to

create a complete animation. The goal is to understand the funda-

mentals of animating objects. In this chapter you will: 

• Open an Infini-D scene file

• Use the Sequencer to animate text

• Use an Animation Assistant

• Render to a movie file

Animating Objects

Chapter

4
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OPENING A SCENE FILE
The first step is to load the scene file that was saved at the end of Chapter 3. You may
also open the ‘Chapter 4.id4’ file, which can be found in the Tutorial Files folder of
the Infini-D CD-ROM or on your hard drive if you installed the files.

Step 1: Choose Open from the File menu.

The standard open file dialog appears.

Step 2: Navigate to the scene file saved in Chapter 3.

Step 3: Click on the file to select it, then click Open.

When the scene file opens, be sure that the Front, Top, Right, and Camera views are
open. If any are closed, they may be opened by selecting a view window’s name in 
the Windows menu.

The quality of the Camera view is set to Phong shade. While the quality is nice it 
may be a little sluggish to work with if you are using slower machine.
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Step 4: Click on the Display tab of the Command Floater.

Step 5: Click on the Camera view to make it the active window.

Step 6: Click on the Render button and choose Wireframe 
from the list that appears.

THE SEQUENCER

To use the Sequencer, open the Sequencer window by choosing ‘Sequencer’ from the
Windows menu.

The Sequencer is where you will do most of your animation work. All of the objects in
the scene are listed down the left side, and any object can be selected by clicking on
its name in the list. 

EVENTMARKS
Eventmarks are the gray ovals next to each object in the Sequencer and contain all the
information about an object—its shape, surface, directional orientation, etc. Above the
eventmarks you will see a timeline; the numbers on it stand for seconds:frames. The
current time is indicated int he scene time box in the upper left corner.

Every object must have at least one eventmark or it wouldn’t exist. However, each can
have many eventmarks, depending on how many times it changes over time. When
an object has more than one eventmark, it is “animated”. The object will have the
characteristics stored in one eventmark at a certain time, then smoothly change to
have the characteristics stored in the next eventmark, further down the timeline.
Eventmarks can be dragged to different places on the timeline, causing changes in the
timing of an object’s animation.
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THE SCENE TIME MARKER

The Scene Time Marker, located directly above the timeline in the Sequencer window
refers to the “present” in the 3D World. Objects will be shown as they appear at the
exact time specified by the Scene Time Marker: If the Scene Time Marker is at two
seconds on the timeline, the view windows will show the state of the World at two
seconds. If you slowly drag the Scene Time Marker back and forth, the active view
window will show a quick ‘scrub’ of the animation. This can be very useful to get the
general idea of how an animation looks.

Since you haven’t yet animated this scene, you won’t see any movement if you move the Scene
Time Marker. In just a moment you will begin to animate the objects.

CREATING NEW EVENTMARKS
By now, you are probably wondering how to create new eventmarks. It’s easy: Simply
move the Scene Time Marker to the time you want a change to happen, and then
change the object in one of the view windows. A new eventmark will appear in the
Sequencer underneath the Scene Time Marker. Infini-D smoothly changes the object
from one eventmark to the next during the time between the eventmarks. 
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ANIMATING THE ‘DONKEY-BACK’ TEX T
It is time to start animating this scene. The goal is to make ‘Donkey-Back’ come into
view from the top, then fly down to rest above the logo.

Step 1: If the Scene Time Markeris not at time zero, move it back 
to time zero by clicking and dragging with the mouse.

Step 2: Click on the Camera view to make it the active window.

Step 3: Click on the V-Plane tool.

Step 4: Click on ‘Donkey-Back’ in the Camera view, and drag it upwards.
Drag it far enough up so it disappears off the top of the Camera view.

If you find that you cannot drag the text completely above the Camera view, switch to the
front view and zoom out a bit. To zoom out the Front view: Click on the Zoom tool, click on
the Front view, and drag the mouse to the left. This will zoom out a bit and you will be able
to drag the text further upward.

Step 5: Click on the Sequencer window to activate it.

Step 6: Move the World Time Marker to one second by 
dragging it with the mouse.

Step 7: Click on the Camera view to make it the active window.

Step 8: Drag the ‘Donkey-Back’ text back down until it is 
positioned in its original position.
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A new eventmark will appear in the Sequencer under the World Time Marker.

The ‘Donkey-Back’ text is now animated! For a preview of the animation:

Step 9: Choose Animation from the Windows menu. 

The Control Floater appears with the Animation tab open.

Step 10: Click on the Camera view to make it active, and click the Play button
(the large button with an arrow facing to the right). 

You will see a bounding-box preview of the animation. 

USING AN ANIMATION ASSISTANT
The next step is to make the logo spin. It is possible to rotate the logo by hand, but it
is easier to use the Spin Animation Assistant. Animation Assistants are plug-in tools
that can do tasks that make your job easier. To make the logo spin, first move the
Scene Time Marker back to zero, then:

Step 1: Click on the V-Plane tool, and click on the logo to select it.

Step 2: Choose Animation Assistant -> Spin from the Animation menu.
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Step 3: Set the Axis to Z, Rotations to 2 and the Seconds to 3. Click OK .

Look in the Sequencer window. The Animation Assistant has added some new event-
marks next to the logo object. These eventmarks define the spin of the logo; each
eventmark rotates the logo a quarter of a turn. 

This is a good time to scrub the sequencer to see the rotation of the logo.

Step 4: Click on the Camera view to make it the active view, and click on the
Sequencer window.

Step 5: Click and drag the Scene Time Marker from time zero slowly to
the right.

You will see the logo object rotating. Now the objects only appear as wire boxes, but
they will look great in the final rendered animation file. 

ANIMATING THE ‘CANYON’ TEX T
The ‘Canyon’ text will fly in from the left and stop at the bottom left-hand side of the
Camera view. This movement is very similar to the ‘Donkey-Back’ text movement and
could be done with similar steps. However, this time the steps will be different in order to
demonstrate an alternate way of animating the text. This time we’ll build the animation
backwards, then use the Reverse Animation Assistant to get the result you want: 

Step 1: Click on the Scene Time Marker and drag it to two seconds. 

Step 2: Click on the Camera view; then use the V-Plane tool to drag ‘Canyon’ to
the left. Drag it far enough to the left so that it disappears off the left 
side of the Camera view.

Look at the Sequencer. A new eventmark appeared next to ‘Canyon’ at two seconds on
the timeline. The animation is fine, except that it is reversed. The text starts in the
Camera view, and then flies off to the left instead of starting out of view, and flying
into the Camera view. Another Animation Assistant is helpful here. 
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Step 3: In the sequencer, click on ‘Canyon’s first eventmark 
with the mouse. It will become selected. 

Step 4: Hold down the Shift key and click on the second eventmark—it will also
become selected. 

Many eventmarks can be selected at the same time by clicking near an eventmark and 
dragging a marquee around the eventmarks you want to select. 

Step 5: Choose ‘Animation Assistant -> Reverse’ from the Animation menu.

These two selected eventmarks are now switched, causing ‘Canyon’ to fly in correctly!
Scrub the Sequencer to see the change.

ANIMATING THE ‘ TOURS’ TEX T
‘Tours’ is the last object that needs to be animated. Its animation is a mirror image of
the ‘Canyon’ movement; it will fly in from the right side of the Camera view. The
animation will be built another way, to demonstrate another way to use the
Sequencer. To animate the ‘Tours’ text:

Step 1: Click on the Sequencer to make it active. 

Notice that the ‘Tours’ object only has one eventmark representing its current position.

Since we want ‘Tours’ to end it smotion at this position, we can copy its eventmark
out to where we want it:
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Step 2: Adding the Option (Mac) or Alt (Win) key, click and drag the ‘Tours’
eventmark to two seconds on the timeline. Notice that the eventmark is
copied to the new location.

With the Scene Time Marker still at zero you can now specify the starting position for
the object:

Step 3: Click on the Camera view, and select the V-Plane tool. 

Step 4: Drag ‘Tours’ to the right using the Camera view. Drag it far 
enough to the right so that the object moves out of the Camera view.

A colored bar now appears between the two eventmarks, indicating that animation
occurs. If you do another Preview of the Camera view, you will see that ‘Tours’ starts
off of the Camera view then flies in from the right.

It is time to render the animation to a file. Before doing that it is a good idea to save
the scene file.

Step 6: Choose Save from the File menu.

RENDERING AN ANIMATION FILE
The last step of any animation project is to render the final animation to a file. This is
the process of making lots of images (called frames) and saving them to a movie file
on a hard disk. To render an animation to disk:

Step 1: Choose Render from the File menu.

Step 2: Click the Render tab to open the Render Setup dialog.
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Step 3: Set the View to Camera, the Quality to Phong, and the Anti-Aliasing to low.

Step 4: Click on the Image tab.

Step 5: Set the Color Depth to Millions . Enter 320 as the Width and 240 as the
Height.

If the width or height changes when you change the other number, click on the small lock
button that connects the Width and Height fields. When the locked button is set and the
Width or Height field is changed, the other field changes proportionately.

Step 6: Click on the Animation tab.
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Step 7: Set the Frames Per Second to 10, and click Render.
A dialog similar to the Standard Save File dialog will appear. 

Step 8: Set the Format to QuickTime. 

Step 9: Click the Options button, and set the compression to the highest quality.

You will be able to save different types of movie files depending on your computer. Feel free 
to choose the file format you prefer. However, each format has its own way of compressing
movies in order to conserve disk space. Be sure to set the compression quality to high in order
to preserve image quality.

Step 10: Type a name in the name field, choose a place on the hard drive to save
the animation, and click Save. 

Infini-D will render for a few minutes. When the rendering is complete, double-click on
the animation file that was saved. Movie Player should open and play the animation. On
the Mac, you may also play the movie using Peter’s Player (which may play movies more
smoothly than Movie Player). Peter’s Player can be found on the Infini-D CD-ROM.

If this animation was being put onto video tape, it would have been rendered to a
larger size and higher frame rate. The small size works fine for this tutorial and takes
less time to render than a full-size animation. If you intend to work with this scene
some more, you may want to save the scene file by choosing Save from the File menu.

We hope these chapters have given you an initial understanding of the Infini-D basics.
You should be able to go on from here and explore other parts of Infini-D on your own.
The tutorials that follow will give you an idea of the power Infini-D can bring to your
professional and creative work. It is strongly recommended that those wishing to create
professional images and animations read the rest of the tutorials and try as many mini-
projects as time permits. Some familiarity with these easy techniques ahead of time will
allow you to successfully employ them in an actual project when time is more critical.
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In this chapter, you will learn how to create several common kinds of

objects. The specific objects created here will be used in chapters six

and seven, when you will produce a complex animation. The specific

topics covered in this chapter are:

• Precise positioning of objects

• Safe Action and Safe Title markers

• Building extruded objects

• Building freeform objects

• Using templates

• Using QuickDraw 3D™ to view objects in the workshop

The following scene is a television advertisement for a fictional brand

of olive oil. A bottle sits on a spinning table while a globe jumps in

and out of the bottle. The text reads “World Class Olive Oil”; it flies

across the top and bottom of the screen.

Creating Objects

Chapter

5
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SETTING UP THE SCENE
Start with a new scene. Some default settings will be changed to suit this particular scene.

Step 1: Choose New from the File menu.

The camera is now viewing the world from above and from the side. This is fine in
many scenes, but in this case, the camera should be viewing the World from the front.

Step 2: Click on the Camera view to make it the active view.

Step 3: Open the Display tab of the Command
Floater. Click on the Bookmarks arrow
button and choose the Target Front position.

Step 4: Click on the Bookmarks arrow button 
and choose the Target Front position.

Any objects that are below the ground plane are invisible by default. In this scene,
objects should be visible regardless of their positions.

Step 5: Click on View Detail to open the View Detail options.

Step 6: Click on the Underground checkbox, so that is checked.

The ground plane is also helpful in most scenes, but in this case it isn’t needed.

Step 7: Click on the Grid Plane checkbox so, that it isn’t checked.

The Safe Action and Safe Title markers are helpful items; they help you prevent important
parts of an animation from being clipped off the side of a television screen. It is good
to turn on the Safe Title and Safe Action markers when building animations for video. 
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Step 8: Choose Edit View from the Edit menu.

Step 9: Check the Show Safe Action Area and Show 
Safe Title Area checkboxes, and click OK .

CREATING A GLOBE
Objects in this scene will be built in the order of simple to complex; the globe will be
created first. Since a globe is just a sphere, in this chapter it will simply be positioned
in the center of the Camera view. In the next chapter it will look like a real globe,
when a map of the earth will be wrapped around the sphere. To create a globe:

Step 1: Click and hold on the Primitive Object tool 
and choose the sphere from the list that appears.

45INFINI-D 4.5 TUTORIAL



Step 2: Click in the Camera view to create a sphere.

The sphere appears in the view windows. It is now called ‘Sphere’ but should be
named ‘Globe’.

Step 3: Type ‘Globe’ in the name field at the top of the Command Floater.

It is important that the sphere be positioned in the center of the World so that it
aligns with the table and bottle to be built later in this chapter. The Control Floater
will help you position the sphere accurately.

Step 4: Choose Information from the Windows menu.

The Information tab of the Control Floater will appear.

Step 5: Set the X, Y and Z position fields in the 
Information tab of the Control Floater to 0, 0, 0.

CREATING THE ‘ WORLD CLASS’ TEX T
‘World Class’ will be positioned at the top of the Camera view. To create this text:

Step 1: Click on the Text tool, and then click in the 
Camera view to open the text dialog.
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Step 2: Type ‘World Class’ in the text field.

Step 3: Click on the Font button to select a font.

In the following graphics, the font “Stone Sans” from Adobe was used. If you do not
have this font, feel free to use any font you wish.

Step 4: Choose a Straight bevel, then click OK .

The ‘World Class’ text has been created, but it must be positioned correctly. It belongs
near the top of the Camera view and also should be brought a bit closer to the
camera. Again, the Control Floater will be helpful in positioning the text accurately.

Step 5: Using the Information tab of the Control Floater,
set the X Position to 0,Y Position to -2 and Z Position 
to 2.3.Also, set the Uniform Scale to .750.
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Look in the Camera view and notice how the text has moved toward the bottom of
the window. The ‘World Class’ text will just barely fit within the Safe Title area of the
camera view.

CREATING THE ‘OLIVE OIL’ TEX T
The steps to create the ‘Olive Oil’ text are basically the same as the ones above, except
that the worlds ‘Olive Oil’ belong at the bottom of the Camera view. To create this text:

Step 1: Click on the Text tool, then click in the Front 
view to open the Text dialog.

Step 2: Type ‘Olive Oil’ in the text field.

Step 3: Click on the Font button to select a font.

In the following graphics, the font “Stone Sans” from Adobe was used. If you do not
have this font, feel free to use any font you wish.

Step 4: Choose a Straight bevel, then click OK .

The ‘Olive Oil’ text has been created, but it must be positioned correctly. It belongs
near the bottom of the Camera view, and should be brought a bit closer to the camera.

Step 5: Using the Information tab of the Control Floater,
set the X Position to 0, Y Position to -2 and Z Position 
to -2.8.Also, set the Uniform Scale to .750.
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Your scene should look like this so far:

BUILDING A TABLE
The olive oil bottle rests on a table. This table is a very simple round table. A round
cylinder, actually, that is squashed to the correct proportions. To build a table:

Step 1: Click and hold on the Primitive Object tool, and 
then choose the cylinder from the list that appears.

Step 2: Click in the center of the Camera view to create 
the cylinder.

Name the cylinder ‘Table’.

Step 3: Type ‘Table’ in the name field at the top of the Command Floater.

In order for it to look like a table, the cylinder must have a larger radius but be much
thinner. Also, the table needs to be positioned at the bottom of the Camera view. It is
important that the table is centered horizontally in the window, so that the bottle
created later can be positioned perfectly in the center of the table. Again, the Control
Floater will be of help.

Step 4: Set the X and Y Scale fields to 5.0.

Step 5: Set the Z Scalefield to 0.2, and press Enter.

Step 6: Set the X and Y position to 0 and Z position to -3.3.
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Remember that setting the X and Y position values to zero centers the object horizontally in
the World. It just so happens that the center of the World is in the center of the Camera view,
but this is not always the case.

Now it is time to create more complex objects—the bottle and bottle cap. They will be
modeled in the Splineform workshop.

SPLINE OBJECTS
Spline objects, built from spline curves, are very versatile. A spline object of any shape
can be changed or morphed into a spline object of any other shape. Lathed, extruded,
and freeform objects are just terms that help us understand what objects look like, but
in Infini-D they are built out of the same basic components. The extrusion, lathe, and
freeform object tools all create spline objects.

MODELING A BOTTLE CAP
The bottle cap will be built first. The workshop cannot be entered without an object,
so the first thing to do is create an object. To create a bottle cap: 

Step 1: Click on the Extrude Object tool and choose the prism from the list
that appears.

Step 2: Click on the Camera view to create an extruded triangle.

Step 3: Rename the object by typing ‘Bottle Cap’ in the name field at the top of
the Command Floater.
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Step 4: Choose Edit Object from the Model menu to enter 
the Splineform workshop (or double-click on the object).

The Cross Section Window
The Cross Section window appears across the top of the screen.
Think of it as a top view of the object. It has a grid, rulers along the
top and left-hand sides, and a triangle in the middle. The outline in
the Cross Section window is literally the cross section of the object,
which is then extruded or ‘dragged’ through space to make a 3D
object.

The toolbar contains tools that can be used to draw new outlines in
the Cross Section window. Many of these tools are the same tools
used in drawing applications such as Adobe Illustrator™.

The shape of the cross section is currently a triangle. For an interest-
ing effect, let’s make the cap with a hexagonal top, instead of an ordinary, rounded
top. The shape of the current cross section will be a hexagon, instead of a triangle.
Here’s how to do it:
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Step 1: Click on the Cross Section window to make it the active window.

Step 2: Choose Select All from the Edit menu.

This selects all of the points in the Cross Section view. Now that the whole triangle is
selected, you can remove it to make way for the new shape. 

Step 3: Press the Delete/Backspace key to delete the selected points.

Step 4: Click and hold on the Rectangle tool, and choose 
the last tool from the list that appears, the Polygon tool.

Step 5: Double-click on the Polygon tool to open 
the Shape Preferences dialog.

Step 6: Type ‘6’ in the Poly Sides field, and click OK .

Step 7: Click and hold in the center of the Cross-Section window (where the
dark grid lines cross), and drag the mouse down and to the right to make
the hexagon appear. Hold down the Shift key to make the hexagon have
‘square’ proportions. Make the hexagon extend to three-quarters of an
inch to the left and right, and then release the mouse button.
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The bottle cap should be an inch and a half wide, which will fit on top of the bottle
you will make later in this chapter.

The Object Window
The Object window shows a preview of the object. If you click on the Object window,
the toolbar will change to a Hand tool, a rotation tool, and a Zoom tool; you can use
these tools to adjust the view of the object (it is installed by default with Infini-D).

If QuickDraw 3D™ is loaded on your computer, the Object window can be changed to
a shaded mode—quite helpful when modeling an object. To change the Object
window to a shaded mode: 

Switch to the shaded mode by choosing Shaded from 
the Render pop-up located at the top of the Object window.

If the ‘Shaded’ choice is grayed, QuickDraw 3D™ either is not properly installed on the
computer or there is not enough free RAM for QuickDraw 3D™ to load. Consult the User’s
Manual for help. However, it is not critical to use QuickDraw 3D™; it simply makes a quick,
shaded object preview that can be helpful when creating models. 

The bottle cap is the right shape, but it is too tall. The extrusion length (height) needs
to be shortened. This can be done in the Path Front Window.
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The Path Front Window

Step 1: Open the Path Front window by choosing 
Path Front from the Windows menu. 

This window is the view of the object from the front. The bottom of the object is a
horizontal pink line, which is simply the cross-section shape seen from the side. The
vertical pink line is the path along which the cross-section is extruded or ‘dragged’.
The gray lines on the left and right sides are the outline or silhouette of the object.

The toolbar displays the tools that can be used in this window.

Step 2: Click on the Arrow tool at the top of the Toolbar.

Step 3: Click on the vertical pink path line in the Path 
Front window to select the points on the Path.
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The points on the path should appear. The rulers show that the bottle cap is two
inches tall, but it should only be one inch tall.

Step 4: Click on the top path point and drag it 
halfway down to the bottom point.

The bottle cap is now only one inch tall.

Adding a Bevel
A smooth bevel will make the bottle cap look more attractive. They are simple to apply:

Step 1: Choose Bevel from the Object menu.

Step 2: Select a bevel, and click OK .

Bevels can only be given to extruded objects. If the Bevel choice is grayed in the Object menu,Infini-D
thinks the object is not an extruded object. If this occurs, choose Simplify to Extrusion from the Object
menu.This will turn the object into an extruded object and you will now be able to add a bevel.

55INFINI-D 4.5 TUTORIAL



The bottle cap is now finished! 

Step 3: Choose Exit Workshop from the File Menu to return to the World . 

This is a good time to save the scene file, choose ‘Save’ from the File menu. The next
step is to build the bottle. You are learning important parts of the modeler that will
enable you build your own objects in the future.

BUILDING AN OLIVE OIL BOTTLE
Building the bottle involves more than simply changing the shape of the cross section.
The base of the bottle is squarish and wide, while the neck is small and rounded. Since
this isn’t a simple extruded or lathed type of object, it is referred to as a freeform
object. When modeling complex shapes, it is often useful to start with a simple object,
rather than a complex freeform object. To build an olive oil bottle:

Step 1: Click on the Primitive Object tool, and 
choose the cube from the list that appears.

Step 2: Click in the Camera view to create a cube.

Step 3: Rename it by typing ‘Bottle’ in the 
Name field at the top of the Command Floater.

The cube is not a Splineform object when it is first created. It must be converted into a
Splineform.

Step 4: Choose Convert to Splineform from the model menu.

When the workshop opens, only the Cross Section and Object windows will appear.

56



The object type is what determines which workshop windows will open. This is because
Infini-D anticipates which windows you will need to use. All the windows can be opened
from the Windows menu, however.

Step 5: Choose Layout -> Freeform Vertical from the Windows 
menu to open the Path Front and Path Right windows.

The Cross Section, Object, Path Front, and Path Right windows will open. The Path
Right window is the only window that hasn’t been explained. It is the same as the
Path Front window, except the object is viewed from the right side.

Unlike most bottles, this one has a square shape except for the neck, which is round.
The first step is to change the cross section from a sharp-cornered square to a rounded
square.

Step 6: Click on the Cross Section window to make it the active window.

Step 7: Choose Select All from the Edit menu, and press 
DELETE to erase the current cross section.

57INFINI-D 4.5 TUTORIAL



Step 8: Click and hold on the Rectangle tool in the toolbar. 
Then select the Rounded Rectangle tool from the 
list that appears.

Step 9: Click and hold in the center of the Cross Section
window, where the two dark grid lines cross. Hold
down the Shift key and drag the mouse down and to
the right. A rounded square will appear; make it two
inches wide.

The next step is to draw the outline of the bottle as it is viewed from the front. This is
done in the Path Front window. You may notice that this window looks different than
it did the last time you opened it. There are two blue lines called Rails added; they are
simply the left and right sides of the object. If the rails are gray, they are inactive; if
they are blue, they are active and can be manipulated, just like the Path. The rails in
the Path Right window are green to differentiate them from the rails in the Path Front
window. Settings like this were automatically turned on when you switched to the
Freeform Vertical layout, but they can also be turned on manually from the menus.

USING A TEMPLATE
A template is helpful when building objects that need to have precise shapes or sizes.
An image can be used as a template: it will act as tracing paper from which to build.

On the Macintosh, a PICT file can be used as a template. On Windows, many formats can be
used, including .pic, .tif, and .bmp files.
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To use a template:

Step 1: Click on the Path Front window to make it the active window.

Step 2: Click on the Options button at the top of the Path Front 
window and choose Get Template from the menu that appears.

Step 3: When the open file dialog appears, navigate to the Tutorial Files 
folder on the Infini-D CD-ROM and open the Template.pic file.

The template appears, but it is much too large to fit in the Path Front window. The
window size must be increased.

Step 4: Click on the Maximize button in the upper right hand corner 
of the Path Front window to make the window fill the entire monitor.

Step 5: Hold down the SPACE bar and click in the Path Front window. 
Drag down and to the right until the entire template is visible.
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Step 6: Click on the Pen tool from the Toolbar.

Step 7: Starting at the first point on the template, click on each point 
in succession, to draw the left side of the bottle.
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The right, front, and back sides will mirror what is done on the left side. Don’t worry
if the bottle isn’t rounded as it is in the template, you’ll change that next by turning
key points into smooth points.

Step 8: Click on the Arrow tool from the Toolbar, and select the 
third point by clicking on the point labeled ‘3’ on the template.

The point will be darkened, indicating that it is selected.

Step 9: Hold down the SHIFT key and click on points 4 and 7,
so that they are also selected.

Step 10: Choose Smooth from the Points menu to turn the selected 
points into smooth points.

This turns the selected points into smooth points. Two spline handles should appear
on each point.

Step 11: Click and drag the bottom point of point 3 so that the 
bottle has a nice, rounded corner.
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Step 12: Make points 4 and 7 rounded the same way point 3 was rounded.
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ADDING CROSS SECTIONS
The cross section of the bottle is now a rounded square, which makes the whole bottle
squarish in shape. The neck needs to be round, however. This can be done by chang-
ing the shape of the cross section near the top of the bottle.

The vertical pink line in the Path Front view is the extrusion path. At the bottom of
the path is a black square. This is called the Cross Section Marker, which can be
moved up and down the path by clicking and dragging with the mouse. The shape in
the Cross Section window is the shape of the object at the point that the Cross Section
Marker is on the path. To add cross sections:

Step 1: In the Path Front window, drag the Cross Section 
Marker upward until it snaps into place beside points 5 and 6.

Step 2: Choose Insert Cross Section from the Options menu 
at the top of the Path Front window.
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Another horizontal pink line appears, representing the new cross section. Notice that
the name of the cross section window is now ‘Cross Section 2’, indicating that this is
the shape of the second cross section.

The shape of this cross section doesn’t need to be changed. It simply acts to keep the
top of the fat part of the bottle square. In a moment, you will make the neck of the
bottle round, which will cause the bottle to be square at the top of the fat portion and
change to round at the base of the neck.

Step 3: Drag the Cross Section Marker upward 
until it snaps into place beside point number 7.

Step 4: Choose Insert Cross Section from the Options 
menu in the Path Front window.

Step 5: Click on the minimize button in the upper right hand corner of 
the Path Front window to make it small again.

This cross section is at the base of the bottle neck, and should be a circle. The square
cross section needs to be replaced with a circular one.

Step 6: Click on the Cross Section window to make it the active window.

Notice that the label of the Cross Section window is ‘Cross Section 3”. You are now
looking at the cross section of the bottle near the top of the bottle, at the base of the neck.

Step 7: Click and hold on the Rounded Rectangle tool,
and choose the Circle tool from the list that appears.

Step 8: Click and hold at the center of the grid. Hold down the SHIFT 
key, then drag to make the circle the same size as the rounded 
square that is already there.
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Step 9: Click on the Arrow tool from the Toolbar, then 
click on the rounded square to select its points.

Step 10: Press DELETE to delete the rounded square.

Look at the preview in the Object view. Notice that the shape of the cross sections
change from square to circle between the second and third cross sections. Infini-D
interpolates from the shape at one cross section to the shape of the next cross section,
which is why it was necessary to insert the second cross section and leave it as a
rounded square.

If you have QuickDraw 3D™ loaded on your system, this would be a great time to choose
Shaded from the Object window’s Render menu. You will be able to see a solid, shaded version
of the bottle.

END CAPS
The last thing that needs to be done to the bottle is remove the top. Currently the top
has no opening, which would make a bottle very difficult to use. This is easy to
change.

Choose End Caps-> Starting Cap from the Object menu, so that it is
unchecked.

This removes the top of the bottle, but leaves the bottom.

Choose Exit Workshop from the File menu to return to the Scene.
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WRAPPING IT UP
All of the objects have been built. All that remains is to position the bottle correctly in
the World. The bottle cap and globe also need positioning, in order to align them with
the bottle. To reposition:

Step 1: Click on the V-Plane took, then click on 
the Camera view to make it the active window.

Step 2: Drag the bottle in the Camera view so that it is resting on the table.

The bottle should be centered perfectly on the table.

Step 3: Set the X and Y position valued to 0.0 in the Info 
tab of the Control Floater, and press ENTER.

Step 4: Click on the bottle cap and drag in onto the 
neck of the bottle using the Camera view.

Step 5: Set the X and Y position valued to 0.0 in the Info 
tab of the Control Floater, and press ENTER.
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The globe should be positioned in the center of the bottle.

Step 6: Drag the globe into the center of the bottle using 
the V-Plane tool and Camera view.

Step 7: Set the X and Y position values to 0.0 in the Info 
tab of the Control Floater, and then press ENTER.

Step 8: These objects will be used in the next chapter, so save the scene by
choosing Save or Save As from the File menu.

The objects are completely built and positioned. In the next chapter, you’ll learn how
to create surfaces for each object. 
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A well-chosen surface can make the difference between merely good

looking objects and a scene that makes one wonder, “Is that a photo-

graph?”. You are about to learn what the different types of surfaces

are and how to create each one. In this chapter you will:

• Change a basic procedural surface

• Tile an image on an object

• Wrap an image around a sphere.

• Make a multiple layered, composed surface

• Use an alpha channel in an image as a transparency mask

Surfaces

Chapter

6
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T YPES OF SURFACES
Surfaces within Infini-D fall into three categories: basic surfaces, texture maps, and
composed surfaces. Each kind is briefly described below.

Basic Surfaces
Basic (Procedural) surfaces are defined by mathematical equations. Several different
kinds of basic surfaces, such as marbles, wood grains, and flat colors allow you to vary
the look of common objects. Infini-D’s many pre-made basic surfaces can be found on
the Surfaces tab of the Command Floater. These can all be edited and new ones can be
created.

Textures
Textures are image files that are mapped onto objects. On the Macintosh any PICT file
or Quicktime™ movie can be used as a texture, while on a PC .pic, .tif, .avi and many
other types of files can be used as textures. If a movie is used as a surface it will play
on the object, creating a very interesting effect.

Composed Surfaces
Composed surfaces are the most powerful surface type. A composed surface is created
from one or more basic surfaces layered and precisely positioned on an object. You can
create almost any surface imaginable by combining other surfaces and textures into a
composed surface.

Setting Up the Scene
A scene full of objects was created in Chapter 5. In this chapter, you will create
surfaces for those objects. 

1. Choose Open from the File menu.

2. Open the scene file saved at the end of Chapter 5. 

You may also open the Chapter 6.id4 scene file, which is found in the Tutorial Files folder of
the Infini-D CD-ROM or on your hard drive if you installed the files.
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APPLY BASIC SURFACES
All basic, texture, and composed surfaces are available from the Surfaces tab of the
Command Floater. Basic surfaces appear in a list under the Basic tab, texture maps
appear under the Textures tab, and composed surfaces appear under the Composed
tab. To apply any surface to an object, select the object, and then double click on the
desired surface from the list.

More information on the types and characteristics of surfaces can be found on 
Chapter 14 of the User’s Manual.

Start by applying the basic surfaces first. Both text objects need a shiny surface.

Step 1: Select the ‘World Class’ text object.

Step 2: Click on the Surfaces tab of the Command Floater.
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Step 3: Double-click on Green Copper in the surface 
list to apply it to ‘World Class’.

Step 4: Select ‘Olive Oil ’, and double-click on the Green
Copper surface to apply it to the text.

The bottle cap looks good with a marble surface. It is unlikely
that an olive oil bottle would have a hexagonal marble cap, 
but this is no ordinary olive oil—it’s World Class olive oil!

Step 5: Select the bottle cap, and double-click on the 
Greek Marble surface to apply it to the bottle cap.

CUSTOMIZE A BASIC SURFACE
The bottle in this scene will have a golden glass surface. If you look at the list of basic
surfaces, you’ll notice that there is already a glass surface. There’s no need to re-invent
the wheel; the glass surface can easily be copied and changed into a golden glass
surface. To edit a surface:

Step 1: Select the Glass surface and click the Duplicate button at the top of the
Surfaces panel.

Step 2: Select the bottle.

Step 3: Double-click on the Glass 1 surface in the surface 
list of the Command Floater to apply it to the bottle.

Step 4: Click the Edit button near the top of the 
Command Floater to open the Surface Info dialog.
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The Surface Info dialog appears. This is where basic surfaces are created and edited.

The color of the glass will be changed to a golden brown color.

Step 4: Click on the Edit button beside Color Map. 

One of a number of color picker dialogs will appear, depending on your machine.

Step 5: Choose a golden color, then click the OK 
button to return to the Surface Info dialog.

Step 6: Lower the Transparency to 80% by clicking 
and dragging the Transparency slider to the left.
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This makes the golden glass less transparent than
colorless glass, which is typical with colored glass.

Step 7: Rename this surface by typing ‘Golden
Glass’ in the text field at the top of the
dialog.

Step 8: Click the OK button to return to the
World .

The bottle now has a new golden glass surface. It
still needs a label, but that will be added a bit later. 

USING AN IMAGE FILE AS A SURFACE
The table needs a tablecloth. On the Infini-D CD-

ROM there is a red checkered image that will work
fine. To do this:

Step 1: Click on the Get... button in the
Surfaces 
tab of the Command Floater.

The standard open file dialog will appear. 

Step 2: Open the Tablecloth.pic file from the Tutorial Files 
folder of the Infini-D CD-ROM.
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Step 3: Click OK in the Image Info dialog to return to the World .

The image is now loaded into the Surface Library, but it needs
to be applied to the table.

Step 4: Select the table object.

Step 5: Double click on the Tablecloth.pic 
texture to apply it to the table.

Now is a good time to use the Marquee Render tool to see a
clear version of the tablecloth.

Step 6: Click on the Camera View to activate it, and then
double-click on the Shade Marquee Render tool
to see a high-quality rendering of the scene.
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CREATING A COMPOSED SURFACE
The texture applied to the table looks good, but the checkered pattern is much too
large. The table would look more realistic if the checks were much smaller.
Unfortunately, textured surfaces aren’t very flexible—they simply get placed on the
object and cannot be adjusted. In order to make the texture smaller on the table, a
composed surface must be used. Composed surfaces are very powerful, and are used to
create more complex surface effects. Here, one will be used to make the checks smaller
on the table and to ‘tile’ the smaller image so that it covers the entire table. To create a
composed surface:

Step 1: Select the Table object and then click on the Comp... button 
near the top of the Surfaces tab to create a new composed surface.

The Surface Composition dialog will appear. At the left of the dialog you will see a box
with the title ‘Layers’. The only layer there is White Plastic, but there can be as many
layers as you want in a single composed surface. Any surface can be used as a layer
except tile surfaces (a type of procedural surface) and other composed surfaces.

Step 2: Double-click on the White Plastic layer 
to bring up the Choose Surface dialog.

Step 3: Click and hold on the White Plastic surface.
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Step 4: Choose the Tablecloth.pic texture from the list that 
appears. It can be found by scrolling to the bottom of the list.

Step 5: Click OK to return to the Surface Composition dialog.

The White Plastic layer has now been replaced by the Tablecloth.pic texture. On the
right-hand side of the dialog you will see a wireframe outline of the table, viewed
from the top. The texture covers the entire object.
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In order to make the checker pattern smaller, the image must be scaled down on the
table. This can be done by dragging the square black handles found on the corners of
the image.

Step 6: Click and hold on the small, black box at the bottom-right 
corner of the texture in the wireframe preview window.

Step 7: Holding the Shift key to keep it square, drag the corner of the image up
and to the left; position on the center of the table object.

The checkered texture is now a smaller, more realistic size on the table. Unfortunately,
it only covers about a fourth of the table’s surface. The texture can be tiled across the
entire table by changing the Repeat values. These are found above the wireframe
preview box.

Step 8: Click once on the down arrow beside the H Repeat field.

This changes the horizontal repeat from one to infinity, causing the texture to tile as
many times as needed to cover the object horizontally.

Step 9: Click once on the down arrow beside the V Repeat field.

This tiles the texture until the table is covered.

When both repeat fields are set to infinity, the texture should completely cover the object.
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Step 10: Name this surface by typing 
‘Tablecloth Composed’ in the Name field.

Step 11: Click OK to return to the World .

The table’s surface is finished. It would be a good time to see a high-quality rendering
of the camera view.

Step 13: Click on the Camera view to make it the active window.

Step 14: Double-click on the Shade Marquee Render tool.

It is a good idea to save scene files often to prevent lost work in case of an accident.

Step 15: Choose Save from the File to save the scene file. 

WRAPPING A WORLD MAP AROUND A GLOBE
The sphere will become a globe once an image of the earth is wrapped around it. Its
surface will be another composed surface, similar to the surface used on the table. In
the next chapter this globe will play a central role when it is animated with the bottle.

Step 1: Select the Globe object ( you may need to use the Object Selector,
located at the top of the Command Floater ).

Step 2: Click on the Get... button in the Surfaces Tab to load an image to be
used.
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The Load Image dialog appears, a standard open file dialog.

Step 3: Open the ‘World Map.pic ’ file from the 
Tutorial Files folder of the Infini-D CD-ROM.

Step 4: When the Image Info dialog appears, click OK .

Step 5: Double-click the World Map in the Textures list to apply it to the sphere.

There are a number of different ways to map an image onto an object. Infini-D auto-
matically uses a Spherical mapping mode since the object is a sphere. THe mapping
mode for the object can be changed using the Mapping pop-up in the Object tab of
the Command Floater. In this case, we will leave it set to spherical.

CREATING A MULTIPLE LAYERED SURFACE
To put a label on a glass bottle, another composed surface must be used. In the last
example, there was only one layer used in the composed surface—the tablecloth
image. In this example, the surface will have two layers. The bottom layer will be the
green glass surface that was created at the beginning of this chapter, while the top
layer will be another image of a label that can be found on the Infini-D CD-ROM.
Follow these steps to apply the label:

Step 1: Select the bottle and choose Decal from the Mapping pop-up in the
Object tab of the Command Floater. 

Step 2: Click on the Comp... button near the top of the Surfaces tab of the
Command Floater to create a new composed surface.

The Surface Composition dialog appears. 
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Adding the First Layer
The default White Plastic layer needs to be changed to Golden Glass. This will be the
bottom, or underlying layer of the composed surface.

Step 1: Double-click on the White Plastic surface in the Layers list.

The Choose Surface dialog will appear.

Step 2: Click and hold White Plastic, and select 
Golden Glass from the list of surfaces that appears.

Step 3: Click OK to return to the Surface Composition dialog.

Adding the Second Layer
The second layer is the label for the olive oil bottle. When each new layer is added, it
is applied on top of the layers below. 

The layer at the top of the Layers list is ‘painted’ onto the object first. Then the second layer
is painted, and the third, and so forth.

Step 1: Click on the Add button to create a new layer.
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The Choose Surface dialog will appear. The default surface is White Plastic, but needs
to be changed to the ‘Label.pic’ image that can be found in the Tutorial Files folder of
the Infini-D CD-ROM.

Step 2: Click and hold on White Plastic, and choose 
Load Image from the top of the surface list that appears.

The standard open file dialog will appear.

Step 3: Open the ‘Label.pic’ file from the Tutorial Files 
folder of the Infini-D DC-ROM.

The Image Info dialog will appear. The image contains an alpha channel, so the Alpha
should automatically be set to Straight.

Step 4: Click OK to return to the Choose Surface dialog. Then 
click OK again to return to Surface Composition dialog.

The Label.pic image is now in the Layers list of the Surface Composition dialog but it
is not oriented correctly. The label needs to be placed on the front of the bottle.

Using a Decal Map
When creating the globe’s surface you used the Spherical map to wrap the map of the
Earth around the globe. Here you will use the Decal mapping mode to position the
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label on the front of the bottle. Decal is the most versatile mapping mode, allowing
precise positioning along the object’s surface. To use the Decal mapping mode:

Step 2: Click on the Mode button in the center of the 
Surface Composition dialog, and choose Decal 
from the list that appears.

The wireframe preview window shows the bottle from the top, but when using Decal
it is more useful to view the object from the front. The bottle can be rotated using the
rotation tools next to the wireframe preview window.

Step 2: Click on the first rotation tool (the topmost tool with a red arrow), which
can be found next to the wireframe preview window.

Step 3: Click and hold on the wire frame bottle and drag upward to rotate the 
bottle to an upright position.
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If the bottle is too big to fit inside the wireframe preview window, use the zoom tool (the
magnifying glass) to zoom out until the entire bottle fits within the window.

In the Coverage Control section on the left side of the
window, there are two bars, labeled H and V. Each bar has
two sliders, which can be dragged with the mouse. The
two sliders on the H bar control the left and right sides of
the decal, while the two sliders on the V bar control the
top and bottom of the decal. Moving the sliders moves
the sides of the decal on the object. In this way, the layer
can be positioned on the object.

Step 4: Drag the left V slider a bit less than one 
half inch to the right. 

This moves the top of the layer down the bottle. The top 
and bottom edges of this layer are represented by red lines.

Step 5: Drag the right V slider about one 
eighth of an inch to the left.

This moves the bottom of the layer upward onto the side of the bottle.

Step 6: Drag the left H slider about one twentieth 
of an inch to the right.

This moves the left side of the layer onto the front of the bottle. The left and right
sides of the layer are shown as green lines.

Step 7: Drag the right H slider one inch to the left.

This moves the right edge of the layer to the front of the bottle.

The label should now be positioned on the front of the bottle. If the layer is not yet
positioned correctly, use the H and V sliders to reposition the sides of the layer. The
ray-traced preview in the lower-right corner of the Surface Composition dialog will
show if the layer is placed correctly or if it needs to be readjusted. 
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Using an Alpha Channel as a Mask
The label is now on the front of the bottle, but the white edges of the label need to be
removed. There are a number of ways to make parts of an image transparent, but
using an alpha channel is often the easiest method. To remove the background from
the Label.pic image, and complete the surface:

Step 1: Click the Use Alpha Mask checkbox, located near 
the top of the Surface Composition dialog.

The image used as the decal contains an alpha channel. Checking the Use Alpha Mask
checkbox tells Infini-D to make certain parts of the image transparent, depending
upon the information stored within the alpha channel.

If you wish for a more detailed explanation of alpha channels, consult the user manuals of
applications such as Adobe Photoshop™. To see how the alpha channel of the label image
was created, open the ‘Label.pic’ image in Photoshop or Painter and view the fourth channel
(the alpha channel). 

Step 2: Name the surface by typing ‘Bottle Composed’
in the name field.

Step 3: Click OK to return to the Scene.
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FINISHING TOUCHES
There are a few items that will improve the look of the scene. You may have noticed
how dark the objects’ surfaces are. Adding another light to the scene will illuminate
the objects nicely. You will add a light, positioned in front of the objects, and a little
bit to one side. To create and position the light:

Step 1: Click and hold on the Light tool from the Toolbar, and choose the
Point light from the list (the picture of the ordinary light bulb).

Step 2: Click in any view window to create a light.

Use the Control Floater to position the light accurately.

Step 3: Choose Information from the Windows 
menu to open the Control Floater.

Step 4: Set the X position to-5.0, the Y position 
to -10.0, and the Z position to 0.0.

The scene is now illuminated brightly. Effective lighting adds a lot to any scene; we
suggest you become more familiar with the different kinds of lights and how to use
them by referring to the Infini-D User’s Manual

The second item that will improve the quality of the scene is an environment map.
The steps are the same as they were in Chapter 3: 

Step 5: Choose Environment from the Edit menu 
to open the Environment dialog.

Step 6: Change the Environment Map setting from None to Load Image. 
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The standard open file dialog will appear. 

Step 7: Open the ‘Chrome Map.pic’ file from the 
Tutorial Files folder of the Infini-D CD-ROM. 

Step 8: Click OK from the Surface Composition 
dialog to return to the World .

Background images don’t need much explanation; they simply appear behind the
objects of a scene. Any image or movie can be used as a background image. Adding a
background image is similar to adding an environment map.

Step 9: Choose Environment from the Edit menu. 

Step 10: Change the Background Image setting from None to Load Image. 

The standard open file dialog will appear. 

Step 11: Navigate to the Tutorial Files folder of the Infini-D 
CD-ROM and select the ‘Stars.pic’ file. 

Step 12: Click Open to return to the Image Info dialog then 
click OK to return to the Environment dialog.

Step 13: Click OK to return to the Scene.
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These objects will be used in the next chapter to create a final animation, so it is
important to save the work you have done in this chapter.

Step 14: Choose Save from the file menu and save this scene file.

This chapter has introduced you to a variety of surfaces found in Infini-D. Using these
basic techniques, you can create an infinite variety of complex and realistic surfaces.
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The goal of this tutorial is to give you a sound understanding of how

to animate a scene.

There are many ways to animate objects; this chapter will demon-

strate those that are most common. Objects built and surfaced in

Chapters 5 and 6 will be animated here, producing a 5 second anima-

tion that can be looped to create a seamlessly repeating movie. 

The following topics are discussed in this chapter:

• Extended Use of the Sequencer

• Object Linking

• Linear and Spline Eventmarks

• Velocity Graphs

This tutorial is quite lengthy, but each step is straight-forward and easy

to follow. While doing the small steps in each section, keep focused

on the ‘big picture’ of what is being done. If you understand the big

picture, the small steps come naturally and need not be memorized.

Creating a 
Complete Animation

Chapter

7

89INFINI-D 4.5 TUTORIAL



SETTING UP THE SCENE
The scene saved at the end of the last chapter will be used here. This scene file can
also be found in the Tutorial Files folder of the Infini-D CD-ROM and is called
‘Chapter 7.id4’. To retrieve the scene you created:

Step 1: Choose Open from the File menu.

The standard open file dialog will appear. If you completed Chapter 6, open the file
saved at the end of that chapter.

Step 2: Open either the scene file you saved at the end of Chapter 6 or Chapter
7.id4 from the Tutorial Files folder of the Infini-D CD-ROM.

LINKING OBJECTS
Currently all objects in the scene function independently from each other. If one
moves, the others will not move. In the real world, however, if a bottle is moved, the
bottle cap will obviously follow. If the table spins the bottle would spin with the table.
This can be accomplished in Infini-D by linking the objects. When objects are linked,
one object becomes the parent while the other becomes the child. When the parent
object is moved or rotated the child moves as if it is glued to the parent.
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To link the bottle cap to the bottle:

Step 1: Select the bottle cap.

Step 2: Click on the Link Tool from theToolbar.

Step 3: Click on the bottle.

There are different kinds of links, but any will work for this chapter. To learn about the 
different types of links see Chapter 8 of the User’s Manual.

A line will momentarily be drawn from the bottle cap to the bottle, indicating that the
cap is linked to the bottle. The next step is to link the bottle to the table. Objects can
also be linked using the Sequencer.

Step 4: Choose Sequencer from the Windows menu.

You may need to use the scroll bar at the right edge of the Sequencer window to see the names
of all the objects in the scene.

It is easy to tell how objects are linked by looking in the Sequencer—child objects are
indented under their parent objects.Notice that the bottle cap is indented under the bottle.

Step 5: Click and drag the name of the bottle and drop it on the 
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name of the table.

The bottle becomes indented under the table, indicating that it is linked to the table.
The bottle cap is now linked to both objects.

To unlink an object, simply drag the name of the child and drop it in any empty space in the
name list between two unlinked objects. The Unlink tool from the Toolbar may also be used.

SPINNING THE TABLE
The first object to animate is the table. The table simply spins in place, so the Spin
Animation Assistant can be used. Since the bottle and bottle cap are linked to the table
they will also spin. The bottle must begin the animation facing backwards so the table
will first be rotated 180 degrees. To make the table face backwards:

Step 1: Select the Table.
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Step 2: Choose Information from the Windows menu.

This opens the Control Floater and shows the object’s position, rotation, and scale
information.

Step 3: Set the Z rotation value in the Information tab to 
180 then press ENTER.

The table, bottle and cap rotate half a turn so the bottle’s label faces away from 
the camera.

Now it is time to rotate the table and bottle. It could be rotated by hand, but it is
easier to let the Spin Animation Assistant do the work: 

Step 4: With the table still selected, choose Animation Assistant -> Spin from
the 
Animation menu to open the Spin dialog.
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Step 5: Set the Rotations to 1, the Seconds to 5, and click OK .

Some eventmarks connected by blue lines will appear beside the table’s name in the
Sequencer window. These were created by the Animation Assistant and indicate that
the table is animated over time. 

At any time during this chapter you may want to ‘scrub’ the Sequencer to see a preview of the
animation. To scrub the Sequencer, click and drag the Scene Time Marker. The Scene Time
Marker is located above the eventmarks but below the time numbers in the Sequencer.Be sure
to move the Scene Time Marker back to its original position after doing a scrub.

ANIMATING THE ‘OLIVE OIL’ TEX T
The ‘Olive Oil’ text will fly across the Camera view. Initially, the text will be off the view
to the right, but then it will move across the Camera view and out of sight to the left.

Step 1: Use the V-Plane tool to select the ‘Olive Oil’ text in the Camera view window.

Step 2: Drag the ‘Olive Oil ’ text to the right side of the 
Camera view. Drag it far enough to the right so that 
it disappears off the right side of the Camera view. 

If you cannot drag the ‘Olive Oil’ text far enough to the right using the Camera view, use the
Zoom tool to zoom out of the Front view, and manipulate the text there. 

The text now begins off the Camera view. It needs to start moving at 1 1/4 seconds. To
animate the text: 

Step 3: Click and drag the ‘Olive Oil ’ text’s only eventmark in the Sequencer to
1 1/4seconds.
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Since the ‘Olive Oil’ text’s first eventmark is at 1 1/4 seconds, the text doesn’t exist in
the Scene until that time. The animation is simple—just fly the text across the Camera
view to the left.

Step 4: Move the Sequencer’s Scene Time Markerto 3 3/4seconds.

Step 5: Use the V-Plane tool and the Camera view to drag the text to the left.
Drag it far enough to the left so that it flies off the left side of the
Camera view.

ANIMATING THE ‘ WORLD CLASS’ TEX T
The ‘World Class’ text flies across the screen similar to the ‘Olive Oil’ text. However,
the motion of ‘World Class’ is a bit different than that of ‘Olive Oil’. ‘World Class’
starts above the bottle and then flies off the left side of the Camera view. A moment
later it flies back onto the Camera view from the right side, and comes to rest where it
began.

Step 1: Move the Sequencer’s Scene Time Markerto 1 1/4seconds.

Step 2: Use the V-Plane tool to drag ‘World Class’ to the left in the Camera
view; drag it until it disappears off the left side of the Camera view.

Step 3: Move the Scene Time Markerto 3 3/4 seconds.

Step 4: Drag ‘World Class’ to the right using the Camera view until it crosses
and disappears off the right side of the camera view.

At the end of the animation the ‘World Class’ text needs to be in exactly the same
location as it started. This can be easily done by duplicating the text’s first eventmark
and placing the duplicate at the end of the animation.

Step 5: Click on the Sequencer to make it the active window.
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Step 6: Hold down the OPTION key (Mac) or ALT key (Windows).

Step 7: Click and drag the ‘World Class’ text’s first eventmark to the right and
place it at five seconds under the timeline.

The animation of ‘World Class’ is complete, with one exception: In the middle of the
animation, the text flies across the Camera view from left to right. It should not be
seen during this time. The solution is to simply make it disappear between the second
and third eventmarks.

Step 8: Double-click on the ‘World Class’ text’s 
second eventmark in the Sequencer.

The Eventmark Info dialog will appear.

Step 9: Click the End Animation check-box, and click OK .
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The second eventmark of the ‘World Class’ text is now a square, indicating that it is
an end animation eventmark. This means that the object is essentially gone from the
scene until the next eventmark, when it will reappear.

The‘World Class’text is now animated.A Scrub of the Sequencer will show the‘World Class’
flying off the left side of the Camera view then flying back into the view from the right.

ANIMATING THE GLOBE
Animating the globe is the trickiest part of this chapter. The globe begins inside the
bottle, then squeezes out of the top of the bottle. Hovering in the air for a moment, it
then returns to the bottle. The steps below are quite precise, because the globe needs
to fit snugly into the bottle. The Control Floater will be very useful here because such
exact control is needed. To animate the globe:

Step 1: Select the globe, then click on the Sequencer 
to make it the active window.

Step 2: Move the Scene Time Marker to 1 second.

The globe’s movement will be built in pieces. Complex motions like the globe’s are
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often built in this fashion: move the Scene Time Marker down the timeline; move the
object; move the Scene Time Marker further down the timeline; move the object
again, and so on.

Step 3: Using the Camera view, drag the globe upward 
until it is positioned in the middle of the bottle neck.

If the bottle cap gets in the way when building the globe’s animation, temporarily make the
cap invisible. To do this, select the bottle cap, and then open the Object tab of the Command
Floater. Un-check the Show Object checkbox. When the time comes to animate the bottle cap
you will need to make it visible again.

The globe needs to be squished to fit inside the bottle neck.

Step 4: Set the X and Y dimension to 0.4 in the Information tab of the Control
Floater, and press ENTER.

Step 5: Move the Sequencer’s Scene Time 
Marker to 1 1/4seconds.

Step 6: Drag the globe upward until only one fourth of it is still inside the bottle.
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Step 7: Set the X and Y dimension fields to 0.7 in the 
Information tab of the Control Floater, and press ENTER.

The globe is almost a perfect sphere, but is still a bit squished.

Step 8: Move the Scene Time Markerto 2.0 seconds.

Step 9: Drag the globe upwards until it is slightly above the bottle.It 
should be near the top of the Camera view, but remain within 
the Safe Action area.

Step 10: Set the globe back to its spherical shape by setting the 
X and Y dimension fields to 1.0 in the Information tab 
of the Control Floater, and then press ENTER.
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The first half of the globe’s animation is done. The second half of the globe’s anima-
tion is simply the reverse of the first half, when the globe falls back into the bottle.
Since an object’s animation is contained in the eventmarks of the Sequencer, they can
simply be duplicated and then reversed, to mirror the globe’s current motion.

Step 11: Click on the globe’s first eventmark in the Sequencer.Hold down the
SHIFT key and click on the rest of the globe’s eventmarks.

The next step is to copy the selected eventmarks to a place further down the timeline.

Step 12: Hold the OPTION key (Mac) or ALT key (Windows), click 
on the first selected eventmark, and then drag them to the right 
so that the first duplicated eventmark sits at 2.5 seconds.
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If you scrub the Sequencer, you will see that the globe has two ‘copies’ of its anima-
tion. The first starts at time zero, while the second starts at 2.5 seconds. The second
‘copy’ of the animation will be reversed so that the globe returns to the bottle.

Step 13: Choose Animation Assistants-> Reverse from the Windows 
menu.Be sure that only the new, duplicate eventmarks are still selected.

The selected eventmarks have been reversed. A scrub of the Sequencer will show the
globe moving out of the bottle, pausing for a moment above the bottle, and then
returning to the bottle in the exact opposite way it left the bottle.

Linear Versus Spline Eventmarks
Many eventmarks in the Sequencer are connected by blue bars. They indicate that an
object is changing in some way at the time that a blue bar appears. Where there is no
blue bar, an object is not changing. The blue bars also indicate that the eventmarks
are ‘linear’ eventmarks—This means that the changes happen sharply and abruptly.
There is another type of eventmark, called a ‘spline’ eventmark, which is used to
ensure that changes in eventmarks happen smoothly.
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Here’s a good way to understand linear and spline motion. Think about a baseball player
running around the bases. A linear path would be to run to first base, pivot, and then run
straight to second base. A smooth, spline-like path is the realistic curved path that human
runners take.

To change the globe’s eventmarks to spline eventmarks.

Step 1: Select all of the globe’s eventmarks.

Step 2: Double-click on one of the selected eventmarks 
to open the Eventmark Info dialog.

Step 3: Click the Spline button, and click OK .

The motion of the globe is smooth and easier to watch. This may not be noticeable at
this point but it definitely affects the rendered movie.
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ANIMATING THE BOTTLE CAP
Until now the bottle cap has just been sitting on top of the bottle. You are about to
give the cap an animation that is similar the globe’s animation: The bottle cap sits on
top of the bottle until the globe starts to squeeze out of the bottle. The cap then flies
upward, out of the Camera view. It then pauses for a moment and drops back onto
the bottle, giving the effect that it is pushing the globe back into the bottle.

If you made the bottle cap invisible while animating the globe, make it visible now. Invisible
objects can be selected by using the selector tool at the top of the Command Floater or by
clicking on the name in the Sequencer.

The bottle cap should sit on top of the bottle until three quarters of a second, after
which it should fly off the top of the bottle.

Step 1: Hold down the OPTION key (Mac) or ALT key (Windows).

Step 2: Click and drag the bottle cap’s eventmark to 3/4 of a 
second in the Sequencer.

Step 3: Move the Sequencer’s Scene Time Markerto 1 1/2seconds.

Step 4: Drag the bottle cap upward in the Camera view, far enough so that it
disappears off the top of the Camera view.
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The first half of the bottle cap’s animation is now built. The second half is simply the
reverse of this first half. You could duplicate these eventmarks as you did the Globe’s,
and use the Reverse Animation Assistant again. However, since this animation only
has two eventmarks, you’ll build the second half of the bottle cap’s animation by
hand.

Step 5: Hold down the OPTION key (Mac) or ALT key (Windows),
and click and drag the bottle cap’s third eventmark to the right. 
Drop it at 3 1/4seconds.

Step 6: Hold down the OPTION or ALT key, and click and drag the bottle
cap’s second eventmark to the right; drop it at4 seconds.

If you scrub the Sequencer now, you will see that the bottle cap flies off of the bottle
out of the Camera view and pauses for a moment before coming back down on the
bottle neck. If the globe and bottle cap animations are built properly, the globe will
appear to push the bottle cap into the air. A moment later the bottle cap will fall down
on the globe and push it back inside the bottle.
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Velocity Graphs
The animation can be rendered and viewed now; it would look fine, except for a
pause at the beginning and end of the animation as the objects speed up (from their
initial stopped position) and slow down (to finish in a stopped position). This is 
usually desirable, since it makes object motion very smooth and realistic. However,
this animation is best viewed while it loops, so the spinning objects should not be
pausing, but spinning as if they were rotating forever. The velocity graph will allow
you to do this.

Velocity graphs are quite powerful. Use them when the motion of an object needs to be
precisely controlled or fine-tuned. They are an important tool for creating the subtleties of real-
istic motion.

If you would like to see how the animation looks now, feel free to render a movie.
There is a movie file in the Tutorial Files folder of the Infini-D CD-ROM, called
‘C7AlmostDone.mov’; it can be played by double-clicking the file icon. Watch the
animation play, and notice how the objects pause at the end of the animation.

Back to your own animation.

The table, the bottle, the bottle cap and the ‘World Class’ text need to move at a
constant rate. Since the bottle and bottle cap are linked to the table, their motion will
follow the table’s perfectly when it is changed. 

Work on the table first. To make it rotate at a constant rate: 

Step 1: Select the table.

Step 2: Choose Velocity from the Model menu to open the Velocity dialog.

The top graph shows the bottle’s position, while the bottom graph shows the bottle’s
rotation. The eventmarks are the same eventmarks seen in the Sequencer. The height
of each eventmark shows how fast the object is moving or rotating at a given time.

105INFINI-D 4.5 TUTORIAL



The Magic Wand tool can be used to apply useful effects. The Constant Velocity item
will be used here.

Step 3: Select all of the Rotation eventmarks by clicking on each one separately
with the SHIFT key pressed.

Step 4: Click and hold on the Magic Wand tool, and 
choose Constant Velocity from the list that appears.
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The Rotation eventmarks move into a straight line, indicating that the bottle’s speed
of rotation is now constant. This will prevent it from pausing when the final movie
file loops.

Step 5: Click OK to return to the World .

The same technique must be used on the ‘World Class’ text to remove its pause in the
middle of the screen when the movie loops.

Step 6: Select the ‘World Class’ text.

Step 7: Choose ‘Velocity’ from the Model menu.
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The Velocity dialog appears again, but this time the Position eventmarks need to be
changed because this object is moving, not rotating.

Step 8: Select all of the Position eventmarks by clicking 
on each one with the SHIFT key pressed.

Step 9: Click and hold on the Magic Wand tool, And choose Constant Velocity
from the list that appears.
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The Position eventmarks are now in a straight line, indicating that the text’s move-
ment speed is constant. This eliminates the pause in the middle of the screen.

Step 10: Choose OK to return to the World .

Although not as critical, you may also want to make the velocity of the ‘Olive Oil’ text
constant. This is done in exactly the same way as was the ‘World Class’ text. 

RENDERING THE FINAL ANIMATION
You are done! It is time to render the animation and view the final movie. It is also a
good time to save the scene file.

Step 1: Choose Save from the File menu and save the scene file.

Step 2: Choose Render from the File menu.

The Render Setup dialog will appear.

Step 3: Set the View to Camera, the Mode to Phong,
and the Anti-Aliasing to Low.

The anti-aliasing smooths the ‘jaggies’ that may occur on the edges of objects. If you set the
anti-aliasing to Medium or High, the objects will appear smoother but the animation will
take longer to render.
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Step 4: Check the Background Imagecheck-box and the 
Transparency check-box. Leave Shadows un-checked.

Step 5: Click on the Image tab of the Render dialog.

Step 6: Set the Colors to Millions or Thousands and 
set the Alpha to None.

Step 7: Set the Width to 320 and the Height to 240.

Step 8: Click on the Animation tab.
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Step 9: Change the Frames Per Secondto 10.

Step 10: Click the Render button.

A standard save file dialog will appear.

Step 11: Click and hold on the Format button and choose QuickTime. 

The image quality of movies is sometimes lowered due to file compression. If you chose the
QuickTime™ file format, click on the Options button to enter the Quicktime Options dialog.
Set the Quality to 100%. This prevents any loss of quality through file compression (but
makes the file larger).

Step 12: Type a name in the Name field, choose a good 
location on the hard drive, and click Render.

The render window will appear. It may take a few minutes to render the animation, so
you may want to take a quick break. 

Step 13: When the rendering is finished, choose Exit 
from the file menu to return to the Scene.
Then choose Quit from the File menu to Exit Infini-D.

Step 14: Double-click on the movie icon to load the 
standard movie player application. 

Turn on the loop option and watch the animation play.

As the animation plays, the objects should move smoothly in a never-ending loop.
Feel free to view the ‘Chapter 7 Final.mov’ animation saved in the Tutorial files folder
of the Infini-D CD-ROM. If your animation does not look like the ‘Chapter 7
Final.mov’ movie, you may want to retrace your steps and determine why they are
different. It is not important that the animation be perfect. It is important that you
understand the techniques used to build the animation.
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Congratulations! You have completed the tutorial manual and are

well on your way to becoming a skilled Infini-D user. The material in

this book was presented in a step-by step fashion, but in the ‘real’

world, creating 3D scenes often requires trial and error. It is not

important to memorize every step or master every topic covered in

this book—the goal is that you understand the basic idea of how to

create 3D animations. The general rule of thumb is to build objects

first. After the objects have been created, place them in their starting

position and apply surfaces. Finally, animate the objects. Save often to

avoid losing precious work.

There are many advanced features that were not mentioned in this

tutorial manual, such as lens flares, particle systems and visible light-

ing effects. With a good understanding of the basics, advanced

features are easy to learn. Keep the User’s Manual handy and don’t be

afraid to poke and prod in strange, unknown places. Good Luck!

Onward
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