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Manipulating Objects
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8Manipulating Objects
Informed Designer provides a variety of commands and features that allow you to manipulate
objects. This chapter describes how to select, reposition, and resize objects with the Pointer
You’ll also learn how to manipulate objects using the commands in Informed Designer’s Arra
menu, and how to use the Specs palette and the Clipboard.

Selecting Objects
Before you can manipulate an object on your template, you must select it first. With Informed
Designer, you can select objects in one of two ways: by using the Pointer tool, or by using th
object selection commands (Select All and Select Same) in the Edit menu.

Using the Pointer Tool 

The Pointer tool selects objects in a variety of ways. Before you can use the Pointer tool, you
first select it on the tool palette. Since the Pointer tool is used regularly, Informed Designer of
shortcut for selecting it. In addition to clicking it on the tool palette, you can select the Pointer
by pressing the key located at the top-left corner of your keyboard (either Escape or ‘`’). You 
also select it temporarily by holding down the Alt (Windows) or Option (Mac OS) key. See “Th
Tool Palette” in Chapter 6 for more information.

Selecting a Single Object 

You can select a single object either by clicking it with the Pointer tool, or by drawing a selec
rectangle around it.

To select an object by clicking, position the pointer over the object and click the mouse butto
Handles appear on the object’s corners to indicate that it’s selected.

Selecting Objects

Note When more than one object on your drawing is selected, all subsequent object manipulatio
that you perform are applied to all of those objects. Make sure that you select the right obj
before you choose a command.
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To select an object by drawing a selection rectangle, position the pointer outside of the objec
click and drag the mouse to surround the object with a selection rectangle. When the object is com-
pletely enclosed, release the mouse button.

Selecting Multiple Objects

You can select multiple objects by Shift-clicking the individual objects, or by drawing a select
rectangle around them.

To select objects by Shift-clicking, hold down the Shift key as you click the individual objects.
Holding down the Shift key causes any previously selected objects to remain selected.

To select objects using a selection rectangle, position the pointer outside of the objects that 
want to select, then click and drag the mouse to completely enclose them. This technique is 
when the objects you want to select are positioned near each other on your template.

Forcing a Selection Rectangle

Often you might want to draw a selection rectangle to select one or more objects that are pos
in front of other objects on your template. If the objects behind those that you want to select 
other areas of your template, you might unintentionally select and drag one of them when yo
attempt to draw the selection rectangle.

To prevent this from happening, hold down the Alt (Windows) or Option (Mac OS) key while d
ing the selection rectangle. The Pointer tool will act as though there are no objects under the
tion where you click to begin drawing the selection rectangle.

If you hold down the Alt (Windows) or Option (Mac OS) key to force a selection rectangle, all
objects that are completely enclosed within the rectangle will be selected when you release 
mouse button. If you hold down the Alt and Control (Windows) or Option and Command (Mac
keys instead, all objects that intersect the drawn rectangle will be selected. 

Selecting Through Objects

When you click the pointer to select an object, the front most object that lies below the pointe
selected. Often you might want to select an object that is obscured by other objects. Instead 
ing these objects to reveal the object that you want to select, use the Control (Windows) or C
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mand (Mac OS) key to select through an object. Each time you select while pressing the Con
Command key, the object immediately behind the one currently selected is chosen.

For example, if you draw an oval over top of a rectangle and select the oval, clicking the oval 
while holding down the Control/Command key causes the rectangle to be selected instead.

When selecting through an object, the pointer must be positioned over the region where the 
overlapping objects intersect.

The Select All and Select Same Commands

Use the Select All and Select Same commands to select objects on the current page of your
plate.

Select All

The Select All command selects all the objects on the current page of your template. Functio
this command is equivalent to selecting all objects with the Pointer tool. To use this comman
choose Select All from the Edit menu.

Select Same

The Select Same command selects all objects of given type. For example, if a rectangle and
are currently selected, then the Select Same command will select all other rectangles and lin
the current page of your template.

To use the Select Same command, first select one or more objects on your template, then ch
Select Same from the Edit menu. Informed Designer will select all remaining objects on the c
rent page of your template that are of the same type as the ones you originally chose.

The Select Same command works differently when you work with fields or tables. If you’re ed
a field or a table, and a part of that object is selected (such as a cell or dividing line), then the

Clicking a selected object while holding
down the Control/Command key...

...selects the object behind it.
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Same command will select the same parts in all other fields or tables on the current page of 
template.

Deselecting Objects

To deselect all currently selected objects on your template, click on an area of your template
contains no objects, or double-click the Pointer tool on the tool palette.

To deselect a particular object on your template, click the object with the Pointer tool while ho
down the Shift key. All other currently selected objects will remain selected.

Clearing Objects
To clear an object from your template, first select it. Then clear it by using one of these meth

■   press the Backspace or Delete key

■   choose Clear from the Edit menu

■   choose Cut from the Edit menu

The Cut command places the selected object on the Clipboard and then clears it from your t
plate.

Clearing Objects

Choose the Select Same command...

Selected title section

...to select the same components on all other fields.
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Repositioning Objects
After drawing an object, you may want to reposition it to a different location on the page. An o
is repositioned by dragging it with the Pointer tool. Informed Designer gives you the choice of
the object is displayed as you drag. 

If you click and drag an object immediately, an outline of the object appears and follows the m
ment of the mouse as you drag. When you release the mouse button, the object is drawn at 
position.

Alternately, if you pause briefly before dragging the mouse, the pointer and all handles will d
pear and the object will be drawn in detail as you drag. This method is particularly useful for 
sitioning text because the text itself remains visible as you drag the mouse.

You can constrain the direction of dragging by holding down the Shift key. The object’s motion
be constrained in either the horizontal or vertical direction depending on the initial motion of 
mouse.

Object Guides

Informed Designer’s Object Guides feature makes it easy for you to align one object with ano
when dragging. To use this feature, click the object that you want to move, and drag it toward
object that you want to align it with. Drag the selected object until the pointer is over top of the
ond object and hold it there for a few seconds. Object guides appear around the second obje
remain there until you release the mouse button. As you position the selected object, it will s
the object guides to ensure perfect alignment with any edge of the second object.

Repositioning Objects

Click and drag...

...release
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Moving Objects Between Pages

Earlier in this chapter, you learned how to reposition objects by simply clicking and dragging 
from one position to another on a single page. Informed Designer provides a similar feature 
makes it just as easy to move objects from one page of your template to another.

To move an object from it’s current page to a different page, simply click and drag the object 
one of the page controls at the bottom of the drawing window. When a highlighted frame app
inside the page control, release the mouse button.

Note The Align and Distribute commands, as well as the Arrow keys, can be used to reposition 
objects. For more information, see “Aligning Objects”, “Distributing Objects”, and “Nudging
Objects” later in this chapter. 

Click and drag over
...hold it there for a few seconds
and the object guides appear.

top of the second
object...

Highlighted frame

Click and drag the object
onto a page control.
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If you drag an object onto the work or master page controls, Informed Designer moves the ob
the same position on that page and automatically displays the page. If your template has mo
two numbered pages, Informed Designer will display the Change Page dialog box when you
an object onto the numbered page control.

Enter the number of the page that you want to move the object to and click ‘OK.’ Informed 
Designer moves the object to the same position on that page and automatically displays the 

If your template only has two numbered pages, you won’t see the Change Page dialog box w
dragging an object between those pages. Instead, Informed Designer will automatically mov
object to the “other” page of your template. For example, if you drag an object from page 2 on
numbered page control, the object will be moved to page 1, and that page will be displayed. 
larly, when moving objects from the work or master page to a numbered page, the Change Pa
log box will only appear if there is more than one numbered page on your template.

This feature is particularly useful for moving a cell between pages, because you can do so w
deleting the cell as you would when using the Cut and Paste commands. Since Informed De
will not allow you to ‘Cut’ a cell that’s used in the formulas of other cells, you would have to 
remove formulas before cutting, and add them back after pasting. This is unnecessary when
the click and drag method.

For information about moving objects from one place to another using the Copy, Cut, and Pa
commands, see “Using the Clipboard”, later in this chapter.

Locking an Object’s Position

You can lock an object’s position to prevent it from being moved or resized accidentally. To loc
object’s position, select the object, then choose Object... from the Settings menu. The Object Set-
tings dialog box appears.
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Click the ‘Position’ checkbox under the Lock heading. Click ‘OK’ to dismiss the Object Setting
dialog box.

As a shortcut to using the Object command to lock an object’s position, you can select the ob
and click the lock button on the Command palette.

If you attempt to reposition or resize a locked object by dragging with the Pointer tool, Inform
Designer will change the pointer to a lock. This indicates that the object is locked and canno
dragged. When you use commands that reposition or resize objects, any objects that are loc
not affected.

For information about the other settings available on the Object Settings dialog box, see “Loc
an Object’s Settings” in Chapter 7, and “Objects and Printing” later in this chapter.

Resizing Objects
A selected object can be resized by using any of the following three methods:

■   Pointer tool

■   Resize command

■   Specs palette

This section describes how to resize objects using all three of these methods.

Resizing Objects

Locks objects Unlocks objects
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Resizing with the Pointer Tool

You resize a selected object by clicking and dragging any of its handles with the Pointer tool.
you drag, Informed Designer draws a gray outline of the object, which shrinks and expands w
the movement of the mouse to indicate the object’s changing size. If you pause briefly after cl
a handle, Informed Designer will hide the pointer as you drag.

Resizing Lines

You resize a line by selecting it, then clicking and dragging one of its end point handles.

If you hold down the Shift key while resizing a line, the line will be constrained along the vert
horizontal, or diagonal (45°) directions, depending on the position of the mouse as dragging oc

Resizing Boxes, Ovals, Arcs, and Polygons

You resize boxes, ovals, arcs, and polygons by clicking and dragging any corner handle of th
object.

If you hold down the Shift key while dragging, resizing is constrained along the horizontal, ver
or diagonal axes depending on the movement of the mouse. Resizing horizontally or vertical
scales the object in that direction only. If you hold down the Shift key while resizing diagonally
new object is scaled equally in both directions, resulting in a new size that’s proportional to th
original. As you drag while holding down the Shift key, the information box displays the curre
scaling percentage.

Click and drag...

...release

Click...
drag...

...release
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When resizing a polygon with the Pointer tool, Informed Designer scales the object in the sa
way as described above. More specifically, Informed Designer resizes the smallest possible 
gle that completely encloses the selected polygon. You can resize a polygon in any direction,
you hold down the Shift key, the operation is constrained to the horizontal or vertical axis, or 
portionally. To reposition individual vertices of a polygon, use the Reshape Polygon comman
the Arrange menu. For more information see “Reshaping a Polygon” in Chapter 6.

Resizing Text

You resize text objects the same way that you resize boxes, ovals, rectangles, and polygons
clicking and dragging a handle.
 

When you resize a text object, Informed Designer automatically reformats the type inside the 
to fit the object’s new size.

If you resize a text object too small, Informed Designer will automatically extend its bottom e
so that all text in the object is visible. Likewise, if you make a text object too long, Informed 
Designer will snap its bottom edge up to the last line of text.

Resizing Fields and Tables

When you resize a field or table using the Pointer tool, Informed Designer adjusts the size of
object while preserving the spacing of the title sections. An example is shown on the next pa
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When you drag the edge of a field or table, any title sections move as well. If you hold down 
Control (Windows) or Command (Mac OS) key while dragging the edge of a title section, the
of that section changes. You can also change the size of a title section by clicking and dragg
section’s dividing line with the Pointer tool. 

Holding down the Shift key while resizing a field or table constrains the motion of the resize o
tion to the vertical, horizontal, or diagonal axes, depending on the motion of the mouse. Scal
diagonally results in an object that is resized proportionally to the original. As you hold down 
Shift key and drag, the Information box displays the current scaling percentage. For more inf
tion on resizing parts of fields and tables, please see “The Field Tool” and “The Table Tool” in
Chapter 6.

Resizing Multiple Objects

Often you will want to resize more than one object by the same amount. For example, you m
want to change the height of three adjacent fields. Informed Designer allows you to select m
than one object, and then resize them all with one motion. Simply select each object, then re
one of them to the desired size. All selected objects will be resized by the same amount.

Click and drag

Resizing a field or table with the Pointer tool...

...doesn’t change the spacing of the title sections
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As multiple objects are resized, Informed Designer will constrain the new size to ensure that
object doesn’t become too small or too large.

Resizing with the Resize Command

The Resize command resizes one or more selected objects. 

You resize an object in one of three ways:

■   explicitly (by specifying the object’s new dimensions)

■   by percentage (by specifying a percentage to enlarge or reduce)

■   by example (by clicking another object of the desired size)

■   to its original size (available for imported graphic objects)

To resize an object, first select it and then choose Resize... from the Arrange menu. The Resize 
Objects dialog box appears.

The width and height of the selected object can be resized independently. Do this by clicking
of the ‘Resize width’ or ‘Resize height’ checkboxes.

If you select the ‘By value’ radio button, you can specify the new width or height of the select
object by typing values in the text boxes. For example, you might enter a value of 5 inches fo
height and 3 inches for the width of a selected object. The unit of measurement corresponds
current ruler setting. However, you can enter the value in any units you like; Informed Design
does the conversion for you.

The spacing of the title section remains the same...

...and all selected objects are resized equally.

Select the objects, then click and drag to resize.
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Similarly, if you select the ‘By percentage’ option, the selected object is resized to a percenta
ative to its current size. For example, you might want to scale an object to half its present size
ply enter ‘50’ into each text box. Click ‘OK’ to perform the resize.

The resize ‘By example’ option allows you to change the size of an object to the size of a diff
object on your template. To use this method, follow the instructions below.

1. Select the object that you want to resize.

2. Choose Resize... from the Arrange menu, select the ‘By example’ option, then click ‘OK.’

3. With the pointing hand, click the object that’s the correct size. The size of the selected obje
change to match the size of the object you click.

The resize ‘To original size’ option is available only if you’ve selected at least one object that c
sponds to an imported graphic such as a Mac OS picture. This option resizes the object to it
nal pasted or imported size. (You can also double-click the object with the Pointer tool to resiz
its original size.

When using the Resize command, Informed Designer won’t allow you to reduce the size of a
object below its minimum size (for example, setting the width of a box to zero inches), or enl
an object larger than the size of the drawing area. If you try, Informed Designer will alert you
an error message and cancel the Resize command.

Resizing with the Specs Palette

The Specs (specifications) palette is a drawing aid that helps you resize and reposition objec
your template. Use the specs palette to position or resize an object if you know its exact dim
sions.

Current pointer position

Specifications of the currently
selected object
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The Specs palette displays coordinate information pertaining to the pointer and any currently
selected objects. Like the Tool palette, the Specs palette can be displayed, hidden, or dragg
not resized. When visible, the Specs palette always displays the pointer’s current position, un
the pointer is over the Specs palette or outside of the drawing window.

When the Specs palette is displayed, the units of measurement correspond to those currentl
the ruler.

Using the Specs Palette

To use the Specs palette, first display it by choosing Specs from the Show submenu under Layout
When the Specs palette is visible, a checkmark appears next to the Specs item in the Show 
menu. To hide the Specs palette, choose Specs again or click its close box.

You can resize an object by changing any of the parameters displayed in the text boxes on th
palette.

To change an object’s parameters, type a new value in the appropriate text box, then press T
the Enter (Windows) or Return (Mac OS) key. The new value will be applied to the selected ob
Pressing Tab or Enter/Return moves to the next text box. Pressing Shift-Tab moves to the pr
text box, and pressing Enter on the numeric keypad leaves the Specs palette.

When you alter any of the Top, Left, Bottom, or Right parameters, the object’s corresponding
always reflects the change. If you change the Height or Width parameters, the change alway
affects the bottom or right edge. For example, if the width of a table is five inches, and you ty
into the Width text box on the Specs palette, the right edge of the table will be extended by o
inch.

If more than one object is selected, the Specs palette shows only the values that are commo
objects. This means that a text box will be blank if its value is different for each of the selecte
objects. For example, if two objects of the same width are selected, the specs palette will sh
corresponding width. However, only if their edges are aligned exactly will values appear in the
left, right and bottom text boxes.

The figures below show the Specs palette and three selected objects. Since the dimensions a
tions of each object are different, all text boxes in the first figure show blank values. When a 
of ‘2.0’ is entered in the ‘Left’ text box, the left edge of each selected object is moved to the 2
mark on the horizontal ruler.

Click and type here
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As with all other resizing operations, you can’t enter values that would reduce the size of an 
below its minimum, or enlarge an object so that it lies off the drawing area. If you try to enter
value that is too large or too small, Informed Designer will warn you (with a beep) and leave 
original value unchanged.

Duplicating Objects
Often you’ll want to create new objects that are similar, if not identical, to other objects on yo
template. Rather than redrawing an object by hand, you can use the Duplicate and Replicate
mands to create one or more duplicates of an existing object.

Duplicating Objects

When you type on the Specs palette...

...the change is applied to all selected objects.
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Duplicate

The Duplicate command duplicates one or more selected objects. It’s useful for making a sin
copy of an object.

To duplicate an object, first select it and then choose Duplicate from the Arrange menu. For each 
selected object, Informed Designer places a copy directly to the right of the original. The orig
object is deselected and the new object is selected.

If you hold down the Alt (Windows) or Option (Mac OS) key while choosing the Duplicate com
mand, the duplicate object will be placed directly below the original. If you reposition a duplic
object and immediately duplicate it again, Informed Designer uses the distance between the
and the original as the offset for the next copy.

As a shortcut to choosing the Duplicate command, you can select an object and click either 
‘Duplicate horizontal’ or ‘Duplicate vertical’ buttons on the Command palette.

Replicate

The Replicate command duplicates one or more selected objects an arbitrary number of time
licated objects are created at evenly spaced intervals that you can set.

To replicate an object, first select it and then choose Replicate... from the Arrange menu. The Rep
licate dialog box appears.

Duplicate horizontal Duplicate vertical
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Use the ‘Number of duplicates’ text box to specify the number of copies that you want to mak
then enter the horizontal and vertical offsets in the ‘Offset by’ text boxes. These values indica
distance between each subsequent duplicate.

You can enter negative offsets as well. A negative offset causes a new object to be placed in
opposite direction of a positive offset. This means that positive horizontal and vertical offsets
place a duplicate object below and to the right of the original, whereas corresponding negativ
sets will place a duplicate above and to the left instead.

After you enter the appropriate values, click ‘OK.’ To cancel the Replicate command, click ‘C
cel’ instead.

Duplicating Cells

When you duplicate cells on a template (either field cells or table cells), you should be aware
following situations and how Informed Designer handles each one.

If you duplicate a cell, the new cell can’t have the same name as the original (all cell names m
unique). Informed Designer will adjust the new cell name to ensure that it’s unique.

Each newly duplicated cell receives the next available tab position. For example, if there are 
cells on your template with tab positions 1 through 15, and two of those cells are duplicated,
two new cells will have tab positions 16 and 17.

If you’re duplicating a cell that has a calculation, check, or tab formula, and that formula refe
cells that are also being duplicated (remember their names will change), then when you perfo
duplication, the formula will be adjusted so that all cell references refer to the duplicate cells r
than the originals.

For example, suppose that your template has two cells, cell1 and cell2, and that the value of
takes the value of cell1 (cell2 = cell1). If you duplicate the two cells together, then you’ll get c
and cell4 where the value of cell4 is calculated as the value of cell3 and not the value of cell1
= cell3).
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Aligning Objects
You can align objects on your template to each other, to the drawing, or along the lines of the
ing grid by using the Align command.

To align a set of objects, first select them and then choose Align... from the Arrange menu. The 
Align Objects dialog box appears.

Aligning Objects to Each Other

To align a set of objects to each other, click the ‘To each other’ radio button. Choose the axes
which the alignment will occur by clicking the ‘Align horizontal’ and ‘Align vertical’ checkboxes
You can align objects along one or both axes. 

If you check the ‘Align horizontal’ checkbox, then the alignment will take place along the hori
tal axis—that is, in the left-to-right direction. Click the ‘Left’ radio button to align the objects alo
the left side of the leftmost selected object. Click the ‘Right’ radio button to align the objects a
the right side of the rightmost selected object. If you click the ‘Center’ radio button, the objec
centers will be aligned along a path that lies roughly halfway between the leftmost and rightm
selected objects.

Aligning Objects
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Similarly, you can click the ‘Align vertical’ checkbox to perform the alignment along the vertic
axis. The ‘Top’ radio button aligns the objects along the top edge of the topmost selected obj
The ‘Bottom’ radio button aligns the objects along the bottom edge of the lowest selected ob
The ‘Center’ radio button aligns the objects’ centers along a path that lies roughly halfway bet
the uppermost and lowest selected objects.

As a shortcut to using the Align command, you can quickly align a set of objects by clicking t
alignment buttons on the Command palette. Clicking the ‘Align horizontal’ button aligns the 
objects along the left edge of the leftmost selected object. Clicking the ‘Align vertical’ button a
the objects along the top edge of the topmost selected object.

Aligning an Object to the Drawing Area

The align ‘To each other’ option is available if you’ve selected more than one object to align. 
only a single object selected, the ‘To each other’ option changes to ‘To drawing.’ Use this opt
align an object to the edge or center of the drawing area. Click the ‘Align Horizontal’ or ‘Align 
tical’ checkbox (or both) to choose which direction to align in. Then choose the edge or cente
align to by clicking the appropriate radio button (Left/Center/Right, or Top/Center/Bottom).

Moving Objects on Your Template

When aligning objects to each other, you can optionally move the selected objects to a spec
position on the drawing area by checking the ‘Move to’ checkbox and entering the desired co
nates. Enter the coordinates in any units that you like; Informed Designer performs the appro
unit conversion for you.

Informed Designer combines the ‘Move to’ coordinates with the options that you’ve selected i
‘Align horizontal’ and ‘Align vertical’ sections of the Align Objects dialog box. For example, if y
click the ‘Left’ radio button and enter ‘2.5’ in the ‘Move to’ horizontal text box, Informed Design
will align the left edge of the selected objects with the 2.5 inch mark on the horizontal ruler. If

Align horizontal Align vertical
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click the ‘Center’ radio button and enter the same coordinate, Informed Designer will try to al
the center of the selected objects with the 2.5 inch mark on the horizontal ruler. 

Aligning Objects to the Grid

To align a set of objects along the drawing grid, select the ‘To grid’ radio button. The upper le
ner of all selected objects will ‘snap’ to the nearest grid lines, whichever are active.

You can also align and move objects by dragging them with the Pointer tool. For more inform
see “Repositioning Objects” earlier in this chapter.

Distributing Objects
Often you’ll need to evenly space a set of objects across an area of your template. You might 
arating related fields of information, or you might be redistributing a set of newly replicated 
objects. Rather than tediously placing each object by hand, Informed Designer provides a si
and efficient way to do this. 

The Distribute command evenly distributes a set of selected objects along an arbitrary path. 
path is determined by you and may be specified in one of two ways: visually (with the help o
mouse), or by a specified value. 

To distribute a set of objects, first select them and then choose Distribute... from the Arrange 
menu. The Distribute Objects dialog box appears.

Distributing Objects

Note While editing a table, you can use the Distribute command to evenly distribute the table’s c
umns. For more information, see “Distributing Columns” in Chapter 6.
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Distributing Objects Visually

When you distribute a set of objects visually, you align them along a path that’s drawn with th
Pointer tool.

To distribute a set of objects visually, select the ‘Visually’ radio button and click ‘OK’ to contin
You’ll see the drawing window again with the selected objects in distribute mode. The selected 
objects will assume an initial distribution path where they are offset (in both directions) from e
other by a fixed amount. The line of distribution depends on the initial placement of the selec
objects. All objects remain selected, but on the upper-left corners of the topmost and lowest o
you’ll see a circular handle. 

Using the mouse, click and drag either of the circular handles. While you drag, an outline of 
selected objects appears, indicating the position of the objects as the mouse is moved. Whe
achieve the desired distribution, release the mouse button. The objects remain selected and
distributed along their new path.

If you hold down the Shift key while adjusting the path, the resulting path will be constrained t
horizontal, vertical, or diagonal (45°) axes.

While the objects are in distribute mode, you can move or resize the objects normally using t
Pointer tool. The selected objects will remain in distribute mode until they’re deselected.

Select the objects and choose
the Distribute command.

After you click ‘OK’, the
selected objects assume
an initial distribution.

Click and drag a
circular handle toDrag

When you release the mouse, the
objects assume their final position.

distribute.
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Distribute by Value

If you know exactly how far apart you want to distribute a set of selected objects, use the ‘By v
option. If you check this option, you can specify the vertical and horizontal offsets with which
distribute the objects. Select either of the ‘Horizontal’ or ‘Vertical’ checkboxes (or both) and ty
the desired values into the associated text boxes.

When performing the distribution, Informed Designer will separate all objects along their upp
left corners by the given offsets. Positive vertical and horizontal offsets place each subseque
object down and to the right. The same negative offsets place each object above and to the l

As a shortcut to choosing the Distribute command, you can quickly distribute a set of selecte
objects by clicking the ‘Distribute’ icon on the Command palette.

Rotating Objects
Use the Rotate command to rotate one or more selected objects. Objects can be rotated 360
in 90 degree increments.

All object types can be rotated with the exception of fields and tables. If you select a field or a
or if a set of selected objects contains a field or a table, the Rotate command will be unavaila

To rotate an object, first select it then, choose Rotate from the Arrange menu. The selected object 
rotated 90 degrees.

The Rotate command is useful for placing vertical text on your template. To rotate a text obje
select it with the Pointer tool, then choose Rotate from the Arrange menu.

A rotated text object can be edited in the usual manner. When you click the object with the T
tool, Informed Designer will rotate the text upright (back to zero degrees), and allow you to ed
text. When you press Enter on the numeric keypad, or deselect the object, it will return to its r
orientation.

Rotating Objects

Distribute objects
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Grouping and Ungrouping Objects
There may be times when you want the ability to treat a set of objects as a single object. For
ple, suppose that you’ve drawn a logo on your template, and the logo consists of a collection
individual lines, rectangles, and text objects. Grouping these objects together allows you to tre
logo as if it were a single object. Informed Designer gives you this ability with the Group and
Ungroup commands.

Grouping Objects

The Group command forms a single object that’s composed of a set of selected objects.

To group a set of objects, first select them and then choose Group from the Arrange menu. Informed
Designer surrounds the objects with handles at each corner of the group’s smallest enclosin
angle.

Since a grouped set of objects is treated as a single object, it’s manipulated accordingly. This
that you can perform any operation on a grouped object (such as selecting, moving, or resizin
can be performed on an individual object.

All commands to manipulate a group, with the exception of resizing and rotating, function ex
as though the objects in the group were selected individually. For example, changing the fon
selected group will set the font for all text, field, and table objects in the group.

When you resize a grouped object, Informed Designer ensures that the size and relative spa
the individual objects that make up the group remain unchanged. This is unlike resizing mult
selected objects where each object is resized by the same amount and the position of each 
doesn’t change. The figure below illustrates how a grouped and ungrouped set of objects are
resized.

Grouping and Ungrouping Objects

Note If a group contains a locked object, then the group itself behaves as if it were locked. For m
information about locking objects, see “Locking an Object’s Position” earlier in this chapter
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When you rotate a grouped object, rather than rotating each object in the group about its cen
(without moving its position), the group as a single object is rotated about its center.

To manipulate a single object within a group, first ungroup the group (see next section), chan
object, then regroup the objects.

Ungrouping Objects

The Ungroup command separates a grouped object into the individual objects that comprise
Ungroup is the opposite of the Group command.

To ungroup a grouped object, first select it and then choose Ungroup from the Arrange menu. All 
objects that comprised the group will be individually selected.

The Ungroup command is useful when you need to work with a single object within a groupe
object. For example, you might want to edit a text object that’s part of a grouped object. Use 
Ungroup command to ungroup the object. After editing the text, use the Group command to 
regroup the objects.

Resizing four selected objects

Resizing a grouped object

Rotating three selected objects

Rotating a grouped object
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Moving Objects Through the Drawing Plane
Each object on your template resides in its own layer on the drawing plane. This means that
objects have a relative front to back ordering—or stacking order—on your drawing. 

Often while editing a template, you might need to change an object’s stacking order. For exa
some objects might be partially obscured by others or you might want to bring an object to the
of a drawing so you can edit it. With the object layering commands (Bring Forward, Bring To F
Send Backward, and Send To Back), Informed Designer gives you the ability to easily manip
an object’s front-to-back ordering.

Bring Forward

The Bring Forward command moves one or more selected objects closer to the front of the dr
plane.

To move an object closer in the drawing plane, first select it and then choose Bring Forward from 
the Arrange menu. The selected object is moved in front of the object immediately above it. T
object remains selected.

If you apply the Bring Forward command to a set of objects, then each object in the set is mo
front of the object that lies immediately above it. However, the relative stacking order of the 
selected objects doesn’t change.

As a shortcut to choosing the Bring Forward command, you can click the ‘Bring Forward’ but
on the Command palette.

Moving Objects Through the Drawing Plane

Bring Forward
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Bring To Front

The Bring To Front command moves an object directly to the front of the drawing.

To bring an object to the front of the drawing, first select it and then choose Bring To Front from the 
Arrange menu.

If two or more objects are selected, they are moved as a group to the front of the drawing. Th
ative stacking order is not changed.

Send Backward

The Send Backward command moves one or more selected objects farther back in the draw
plane.

To move an object backward in the drawing plane, first select it and then choose Send Backward 
from the Arrange menu. The selected object is moved behind the object immediately below i
object remains selected. 

If you apply the Send Backward command to a set of objects, each object in the set is moved 
the object that lies immediately below it. The relative front-to-back order of the selected objec
left unchanged.

As a shortcut to choosing the Send Backward command, you can click the ‘Send Backward’ b
on the Command palette.

Send Backward
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Send To Back

The Send To Back command moves one or more selected objects to the back of the drawing

To send an object to the back of the drawing, first select it and then choose Send To Back from the 
Arrange menu.

If you select two or more objects, they’re moved to the back of the drawing as a group. Their
tive stacking order, however, is always preserved.

Nudging Objects
As in all drawing, it’s important to position objects accurately on your template. Although the 
mouse is often accurate enough, there are times when you might like greater precision over 
placement combined with greater ease of manipulation. 

With the Arrow keys, Informed Designer allows you to move and resize objects precisely with
using the mouse. Use the Arrow keys whenever you’re doing detailed work or whenever you 
maximum control over object sizing and placement.

Nudging an Object’s Position

To nudge an object, first select it and then press the appropriate Arrow key (up, down, left, or
arrow). You can nudge more than one object at a time by first selecting all objects and then pr
the key.

When you nudge an object, you move it by a distance of 1 pixel at the current view of the dra
window. If the current view is set to 100%, this means that each time you nudge an object, it
tion changes by a distance of 1/72nd of an inch (because most monitors have a resolution o
dots—or pixels—per inch). Similarly, if the current view is set to 200%, nudging an object mov
1/144th of an inch. At the largest possible view (1600%), nudging an object repositions it by 
tance of 1/1152nd of an inch.

Nudging Objects
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Nudging an Object’s Size

You can also nudge the size of an object. First select the object and then press the desired A
key (up, down, left, or right arrow) while holding down the Shift key. Instead of moving the ob
the object’s bottom or right edge will resize one pixel in the corresponding direction.

You can resize more than one object at a time by first selecting all objects and then pressing
Arrow key while holding down the Shift key.

As with all resizing commands, you can’t nudge the size of an object below its minimum size
larger than its maximum size.

Objects and Printing
In Chapter 11, you’ll learn about printing templates and Informed Designer’s print options. W
the Informed Filler user prints a completed form, options are provided to hide the template o
data. The template refers to the graphical objects such as lines, boxes, and text labels. The for
data refers to the information that’s entered in each cell to complete the form. For information
about Informed Designer’s print options, see Chapter 11, “Printing Forms”.

By using the Object command, you can set additional print options for any object. You can ch
to hide an object so that it doesn’t print. This is useful if you want an object to appear on the s
but not on the printed template. For example, you might want to label the different parts of yo
template to help the person who fills it out.

Alternately, you can choose to always print an object, even if the Informed Filler user prints a
with its layout hidden. This option is useful when using preprinted forms. For example, you m
want a graphical object—such as your company logo—to print in addition to the form’s data.

To change the print options of an object, choose Object... from the Settings menu. The Object Se
tings dialog box appears.

Click either of the ‘Always print’ or ‘Never print’ checkboxes. You can’t use both options at the
same time. After making your selection, click ‘OK.’ To cancel the Object command, click ‘Can
instead.

Objects and Printing
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For information about the other settings available on the Object Settings dialog box, see “Loc
an Object’s Settings” in Chapter 7, and “Locking an Object’s Position” earlier in this chapter.

Using the Clipboard
The Clipboard is a temporary holding place for graphics and text. Commonly, you’ll use it to 
form one of these functions:

■   move objects from one area of a template to another

■   move objects from one page of a template to another

■   move objects from one template to another

■   to transfer artwork and text from other applications into Informed Designer

■   to transfer artwork created with Informed Designer into other applications

You can use three commands to transfer objects to or from the Clipboard. The Cut and Copy
mands place the selected objects onto the Clipboard. The Paste command transfers the con
the Clipboard onto your template. These commands are described below.

If you are running Informed Designer on a Mac OS compatible computer, you can display the
tents of the Clipboard by choosing Show Clipboard from the Edit menu. Informed Designer show
the Clipboard content in a window.

Like any Mac OS window, you can position the Clipboard window anywhere on your screen b
clicking and dragging its title bar. You can hide the Clipboard by clicking the window’s close bo
by choosing the Close command while the window is active.

Moving Objects Onto the Clipboard

Use the Cut or Copy commands to move objects onto the Clipboard.

To move an object onto the Clipboard, select it and choose either Cut or Copy from the Edit menu. 
Your selection will be transferred to the Clipboard. If you choose Cut, the selected objects wil
be removed from your template.

Using the Clipboard
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The Copy command is more commonly used to transfer objects to the Clipboard. When you w
remove an object from your drawing, use the Clear command instead. See “Clearing Objects

Pasting Objects From the Clipboard

To paste the contents of the Clipboard onto your drawing, choose the Paste command from the 
Edit menu. A copy of the Clipboard’s contents will be positioned at the center of the drawing 
dow.

If you hold the Alt (Windows) or Option (Mac OS) key down while choosing the Paste comma
Informed Designer will place the objects at their original positions (that is, the position they w
when you cut or copied them). This feature is useful for copying objects from one page of a t
plate to another. After copying an object on one page, pasting it on another page while holdin
down the Alt/Option key will ensure that it’s positioned at the same location as the original.

Pasting Informed Objects

When pasting objects created with Informed Designer, you should be aware of the following 
tions and how Informed Designer handles each one:

■   If the Clipboard contains Informed objects that are larger than the drawing area, Informed
Designer won’t paste those objects onto your template. Instead, you’ll be alerted with a w
ing message. If you click ‘OK’ on the message dialog box, the paste operation will contin
but only those objects that fit entirely on the drawing area will be pasted. If you click ‘Can
the paste command will be cancelled.

■   To prevent duplicate cell names from occurring on your template, cells on the Clipboard a
renamed (if necessary) before they’re pasted. The naming conventions used to name the
cells are the same as those used for duplicating or replicating existing cells. Likewise, a n
pasted cell receives the next available tab position (see “Duplicating Cells” earlier in this 
ter). If a cell being pasted contains a formula that references a nonexistent cell (a cell wh
was not copied from the original template), Informed Designer will alert you with a messa

When you click ‘OK’, Informed Designer will clear the invalid formula before pasting the cell.
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Pasting Graphic Objects

A graphic object is treated as a single object and is pasted in the usual manner. However, if th
board contains a graphic object that’s larger than the drawing area (in either direction), you’ll
warning.

 
If you click ‘OK’, the large graphic object will be reduced proportionally and pasted onto your 
plate. If you click the ‘Cancel’ button, the paste operation will be canceled.

Pasting Text

You can paste text in two different ways: as a new text object, and as text inserted into an ex
text object.

If you’re not editing a text object when you choose the Paste command, the text on the Clipb
will be pasted as a new object, and centered on the drawing window. If the text is pasted whi
are editing a text object, the text on the Clipboard will be inserted at the current insertion poin
the selected text object.

Using Drag and Drop
“Using the Clipboard” earlier in this chapter, explains how you can use various commands an
Clipboard to transfer material between different templates and different applications. If you’re
using a Mac OS compatible computer with System 7.5 or later installed, the “drag and drop” 
method provides an even easier way to do this.

As its name implies, the drag and drop feature consists of selecting an item, “dragging” it wit
mouse, and “dropping” it at another place.

Although this section only describes the manipulation of objects from one template to anothe
can also use drag and drop to perform other tasks such as:

■   moving files from other applications onto your template

■   moving material created with Informed Designer to other places

For a detailed description of using drag and drop for these tasks, see Chapter 9, “Using Grap

Using Drag and Drop



Manipulating Objects 8-33

 .
 .

 .

 both 
 first 
order 
The 
sition 
.

To use drag and drop to copy objects from one template to another, the drawing windows for
templates should be visible on your screen. Select the object that you want to copy from the
template, then drag it onto the drawing window of the second template. When a highlighted b
appears around the edge of the second template’s drawing area, release the mouse button. 
selected object remains at it’s original location, and a copy is placed at the current mouse po
on the second template.

Click and drag the
original object.

Release the mouse button
when a highlighted border
appears around the window.

A copy of the object is
placed in the second location.

First template Second template
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