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14FormFlow Conversion
The Informed FFCONVRT plug-in allows Informed Designer to open and convert documents
ated by Delrina’s PerForm PRO and FormFlow 1.x applications.

In order for the FFCONVRT plug-in to function properly, the FormFlow documents you want 
convert must be translated to IFD* format before Informed Designer can open and read them
translation process is accomplished by opening and saving the FormFlow document using th
Delrina FormFlow Forms Translator.

*IFD (Informed Form Description) is a special file format that describes a form template.

The following sections describe how to convert FormFlow documents to Informed.

Before You Begin
To help make the conversion process as smooth as possible, please read the following inform
before you begin translating a document from FormFlow to Informed.

File Type

The document to be translated must be an unlocked version and must have the (.frp) DOS extensio
or it cannot be read by FormFlow Forms Translator.

Field Names

Make sure the field names in your FormFlow document do not contain any of the following ch
ters: periods (.), dashes (-), slashes (/). Valid characters in field names for translation are all 
and uppercase letters of the alphabet, all numbers (provided the number does not come first)
underscore character (_). If your FormFlow document contains any field names with invalid c
ters the translation will fail (but the reason will appear in the log file generated during the attem
conversion to IFD format).

Reserved Words

Informed has reserved words that have a special meaning within the application and cannot b
in cell names. The list of Informed reserved words consists of all the Informed function names
Chapter 10 of this manual for a list of Informed functions.

For information about other possible errors during conversion, see “FormFlow Translation Er
Messages” later in this chapter.

Before You Begin



 

FormFlow Conversion 14-3

 .
 .

 .

 

t. On 
rms 

          

 
ent in 

ails of 
of the 

  

Forms Automation Manual  Page 3  Thursday, June 18, 1998  11:30 AM
.

Translating from FormFlow to IFD
The first step in the conversion process is to translate the FormFlow document into IFD forma
a computer running Windows 3.1, Windows 3.11 or Windows 95 with the Delrina FormFlow Fo
Translator installed:

■   Launch the Delrina FormFlow Forms Translator application and choose File > Open. The File 
Open dialog box appears.

■   Select the (.frp) file to be converted, then click ‘OK.’ A blank form window appears.

■   Choose Translate > to Informed Form. The File Save As dialog box appears. Name the file
and choose a location to store it, then click ‘OK’ to translate and save the selected docum
IFD format.

After you save the document, the translation log window appears. This window shows the det
the translation process. FormFlow Forms Translator then displays a message at the bottom 
window, indicating whether the translation was successful or not.

Step 1: Translating from FormFlow to IFD

Translation log

Translation result message
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.
If translation was successful:

■   Close the translation log window and proceed to Step 2 (see below).

If the translation was not successful:

■   Check the log for errors, correct the errors on the FormFlow form and translate the file ag

Converting from IFD to Informed
The second step in the conversion process is to convert the IFD file to an Informed form tem
document. This step can be performed on either a Windows or MacOS compatible computer

■   Make sure you have the FFConvert plug-in installed in your Informed Plug-ins Folder.

■   Launch Informed Designer and choose File > Open. The Open dialog box appears.

■   Select the IFD document and click ‘Open.’ A warning message appears asking if you wan
continue.

■   Click ‘OK’ to continue. Informed Designer converts the selected file and displays it in the 
drawing window.

■   Choose File > Save to save the converted form.

Step 2: Converting from IFD to Informed
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Problems due to Conversion
Although Delrina’s FormFlow and Shana Corporation’s Informed are dedicated forms packag
they have been developed independently, and therefore embody different design and develo
principles. The Delrina FormFlow Forms Translator allows for the conversion of forms create
Delrina’s software to Shana Corporation’s Informed software, but cannot cater to all the differe
between these products.

The conversion from FormFlow to IFD format can create a host of objects that are unnecess
Informed. In particular:

■   Fields can sometimes be converted with no pen, fill, or title captions and instead, have se
line, rectangle and text objects. In Informed these extra objects can often be replaced by 
ing the unnecessary objects, and setting the pen, fill and title attributes on the field itself.
reduction in the number of objects creates a form which is both more efficient and easier
manipulate.

■   Objects that would normally be tables in Informed are often converted as multiple fields. I
most cases these can simply be deleted and replaced with a single Informed table. Again
reduction in the number of objects creates a form which is both more efficient and easier
manipulate.

■   Some converted calculations can be rewritten to take advantage of Informed’s powerful fu
tions. Informed functions often contain attributes which make portions of converted calcu
tions redundant. In some cases calculations will not have converted correctly or may not 
converted at all. Part of the cleanup process requires that the intelligence of the form be 
checked to maintain functional continuity.

To make the converted form closer to one designed from scratch in Informed, there are a num
techniques you can use to “clean up” the form. These techniques are described in detail in th
lowing sections.

Cleaning up a Converted Form
Before you begin the cleanup process it’s recommended that you have a printed copy of the o
form or have ready access to a screen-based version of the original form in FormFlow. This w
give you a visual guide to refer to as you perform the clean up.

The following steps are intended as general guidelines. These instructions are not meant to 
exhaustive and do not address all possible conversion issues.

Problems due to Conversion

Cleaning up a Converted Form
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.
Design and Graphics

The elements of an electronic form fall into two categories: graphics and intelligence. The gr
elements of the form are the things you can see—text, fields, tables, logos, and so on. The in
gence elements are things like calculations, data formatting, and lookups. This section explain
to deal with conversion problems that affect the graphic elements on your template. Rememb
save frequently! But also remember that you cannot undo the previous step once you have sa
changes.

Ungrouping Objects

Objects on the converted form can sometimes be made up of a group of separate objects. To
ulate the individual objects in the group, you must first separate them using the Ungroup com

■   Choose Select All under the Edit menu.

■   Choose Ungroup under the Arrange menu.

You might have to repeat the Ungroup command several times to make sure that all grouped 
are fully ungrouped. You will know that all objects are ungrouped when the Ungroup comman
no longer available (grayed out). For more information on grouping and ungrouping objects, 
Chapter 8 of your Informed Designer Design and Graphics manual. 

Unlocking the Object Settings

In some cases, the attribute settings and position of the objects on your form template might
locked. To unlock these settings so that you can change them as needed:

■   Use the Select All command to select all objects on the form, then choose Objects under the 
Settings menu. The Object Settings dialog box appears.

■   Turn the ‘Position’ and ‘Settings’ checkboxes off if they are selected.

For more information on the Objects Settings dialog box, see Chapters 7 and 8 in your Informed 
Designer Design and Graphics manual.

Note Repeat the following steps on each page of the converted form (including the Master page
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Alignment to the page

Converted forms will display the form offset to the top and left of the drawing window. In orde
center the drawing:

■   Choose Select All under the Edit menu.

■   Choose Group under the Arrange menu.

■   Choose Align under the Arrange menu. The Align Objects dialog box appears.

■   Select the ‘Center’ radio button on both the Align Horizontal and Align Vertical portions of 
Align Objects dialog box, then click ‘OK.’

If the form requires further repositioning you can use the directional arrow keys on your keyb
to nudge the grouped object to the exact position you require. For more information on how to
objects, see Chapter 8 of your Informed Designer Design and Graphics manual.

■   Ungroup the objects again once your form is positioned correctly (see “Ungrouping Obje
earlier in this section).

Showing Cell Names

If Cell names are not already visible, choose Cell Names from the Show submenu under Layout.

Text Objects

There are some problems that can occur when text objects are converted. This section desc
some of the more common problems and explains how to correct them.

To make it easier to identify and work with text objects on the form template:

■   Select one text object with the Pointer tool.

■   Choose Select Same from the Edit menu to highlight all text objects on the current page.

■   Choose Pen under the Style menu and select a color from the color palette.
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.
Some text objects have handles extending far beyond the ends of the actual text. This can m
difficult to select other objects (like a field or rectangle) which might lie underneath or behind
text object.

To snap the handles to the edge of the actual text:

■   Select the Text tool in the Tool palette.

■   Click in the text object.

■   Press F12 (Windows) or hold down the Option key and press Enter (Mac OS).

Depending on how the original form was designed, you might find that some text objects are
lated as multiple objects. It is often better to combine these separate text objects into single o
Informed lets you have multiple fonts, sizes and type styles in one text object. However, it do
let you mix text alignments (left, center, justify, right) or leading values. Here’s a technique fo
combining separate text objects into single objects:

■   Select the Text tool from the Tool palette.

■   Click in one of the text objects that you want to combine with another text object.

■   Choose Select All under the Edit menu to select the entire text object.

■   Choose Cut under the Edit menu to delete the text object.

■   Click in the text object where you want to paste the cut piece of text, then choose Paste under 
the Edit menu. The cut text is pasted into the current text object.

■   Repeat as necessary.

Text objects with large font sizes will sometimes line wrap after conversion.

To unwrap the affected objects:

■   Select the text object with the Pointer tool, then press Tab to highlight the selected text.

■   Press F12 (Windows) or hold down the Option key and press Enter (Mac OS).

Because fonts are handled differently on Windows and Mac OS, the leading (the amount of s
between lines of text) of some text objects can also be affected by the conversion process. In

The extended text
object handles...

...make it difficult to
select the object beneath.

Line wrapped text Unwrapped text
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cases, text will drop and be hidden behind other objects. In other cases, the text may simply
too “spaced.” To adjust the leading of affected text objects:

■   Select the object(s) in question.

■   Choose Auto from the Leading submenu under the Style menu. This separates one text lin
from the next by enough space to hold the largest font size used in that line.

■   If you need to adjust the leading to match the original form more closely, simply choose an
setting from the Leading submenu.

When you’ve finished adjusting the text objects you can select one, then use the Select Sam
mand to select all the other text objects on the page. Now you can set the Pen color to whate
should be for the form. For more information on manipulating text objects, see Chapters 6 an
your Informed Designer Design and Graphics manual.

Removing Unnecessary Lines

There are two main reasons unnecessary line objects occur in translated documents: object
original form were drawn with customized borders (for example, one or more of the object bo
was not shown), a feature not supported in Informed; the form was simply drawn that way.

In order to determine the number of line objects that could be replaced:

■   Select the Line tool and draw a line in a clear area of the form template.

■   With the line selected, choose Select Same under the Edit menu to highlight all line objects o
the current page.

■   Under the Style menu, select a color from the Pen submenu.

■   Double-click the Pointer tool in the Tool palette or press the Esc key on your keyboard to
lect all the line objects.

■   Now, select any lines you want to remove, then press the delete or backspace key.

If you have difficulty selecting objects that are hidden behind other objects:

■   Hold down the Ctrl (Windows) or Cmd (Mac OS) key while clicking with the Pointer tool to
select an object which lies behind another one, or you can:

■   Use the Pointer tool to select an example of the object type you are working with.

■   Choose Select Same from the Edit menu.

■   Choose Bring to Front from the Arrange menu. All selected objects will be brought to the fro
layer of the drawing so that they lie on top of any other objects.

When you’ve finished adjusting the lines you can select one, then use the Select Same comm
select all the other lines on the page. Now you can set the Pen color to whatever it should be
form. For more information on drawing and manipulating lines, see Chapters 6, 7, and 8 in y
Informed Designer Design and Graphics manual.
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.
Removing Unnecessary Rectangles

In order to determine the number of rectangle objects that could be replaced:

■   Select the Rectangle tool and draw a rectangle in a clear area of the form template.

■   With the new rectangle selected, choose Select Same under the Edit menu to highlight all rect
angle objects on the current page.

■   Under the Style menu, select a color from the Pen Submenu (choose a different color tha
used for the lines and text objects).

■   Double-click the Pointer tool in the Tool palette or press the Esc key on your keyboard to
lect all the rectangle objects.

■   Now, select any rectangles you want to remove, then press the delete or backspace key.

When you’ve finished adjusting the rectangles you can select one, then use the Select Same
mand to select all the other rectangles on the page. Now you can set the Pen color to whate
should be for the form.

For more information on drawing and manipulating rectangles, see Chapters 6, 7, and 8 in y
Informed Designer Design and Graphics manual.

Cleaning up Fields

As explained earlier, fields can sometimes be converted with no pen, fill, or title captions and
instead, have separate line, rectangle and text objects. In Informed these extra objects can o
replaced by removing the unnecessary objects, and setting the pen, fill and title attributes on
field itself. This reduction in the number of objects creates a form which is both more efficien
easier to manipulate.

Use the techniques described earlier in this section to remove any unnecessary lines or rect
from the fields, then follow these steps to set the pen and fill attributes for the selected fields

■   With the Pointer tool selected, click on a field you want to use as your model.

Note To help select some rectangles you can also choose the Fill command under the Style me
set these objects’ fill to white or some other color. In order to select a rectangle or any othe
object with no fill you must click on its outline - you can click on any part of a filled object to
select or deselect it.

text object

cell with no pen

line objects

single field object
with pen, fill, and
title attributes set
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■   Choose Select Same under the Edit menu to highlight all fields on the current page.

■   Shift-click to deselect any fields you do not want to modify at this time.

■   Choose Pen under the Style menu to set the selected fields’ pen to the required color.

■   Choose Fill under the Style menu to set the selected fields’ fill to the required color.

Repeat the above steps with any fields you did not include in this initial group, setting the rel
attributes of each set of fields. You can use the same technique to set any other attributes for
rently selected fields (such as divider line pen, line weights, and so on).

To adjust the attributes of a particular part of a field:

■   Select the Pointer tool on the Tool palette, then click on a field to select it.

■   With a field selected, click the part of the field you want to adjust (such as the data or title
or the dividing line between them).

■   Choose Select Same under the Edit menu to select the same part in all the fields on the cu
page.

■   If necessary, shift-click in the relevant selected areas to deselect specified fields.

■   Make the adjustment to the selected field part.

■   Repeat as necessary.

Rule Lines in Fields

Forms are often designed with a single separate line overlaying a field. These lines are positio
reflect where the data will be entered into the cell.

Informed has various field style options to let you create these rule lines as part of the field o

■   Select the field you want to adjust with the Pointer tool.

■   Choose Field... under the Settings menu. The Field Settings dialog box appears.

Click once to select
the entire field...

click again to select
a particular section.
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■   Select the ‘Rule Lines’ checkbox to turn the rule lines option on, then select the appropriat
line setting.

Field Title Captions

Like text objects, the leading of field title areas can be affected by conversion, causing the bo
of the text to be hidden by the bounds of the field. If this occurs:

■   Select the field by clicking it with the Pointer tool.

■   Click again in the area of the selected field to select just the title area.

■   Choose Auto from the Leading submenu under the Style menu. This separates one text lin
from the next by enough space to hold the largest font size used in that line.

■   If you need to adjust the leading to match the original form more closely, simply choose an
setting from the Leading submenu.

If a field has converted with a separate text object in place of a field title, you can often corre
by setting the title attribute for the field. To set the field’s title attribute:

■   First, select and delete the text object.

■   Select the field in question using the Pointer tool.

■   Choose Field under the Settings menu.

■   Select the ‘Title’ checkbox on the Field Settings dialog, then use the radio buttons to set t
position of the title area.

Note If you only need a single rule line in the field, you should choose the ‘Match font size’ option
this automatically adjusts the position of the rule line according to the font size set for that 
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■   Click ‘OK.’ The title area of the field will now display the text “Title.”

■   Select the Text tool, highlight the text in the title area, and type the appropriate title captio

You can use the Pointer tool to adjust the field title areas where necessary so the title captio
plays correctly. You might need to adjust both the height and width of the title area to do this.
might also need to change the pen and fill of the title areas. For more information on changin
attributes of a field, see Chapter 7 of your Informed Designer Design and Graphics manual.

Multiple Fields that should be Tables

When translating FormFlow forms to Informed form templates, vertically oriented combs are 
verted to tables. If there are two or more vertically oriented adjacent combs that are part of the
fill group with the cross tab option selected, they will translate to a single table on the Inform
form. However, there are occasions when FormFlow combs are converted into multiple Inform
fields. In order to create a more efficient Informed form template, multiple fields that can be 
replaced by an Informed table should be deleted. In addition, in many cases free-standing te
angles and multiple fields can also be replaced by table and column titles.

Like fields, Informed tables are extremely flexible objects with many different setting options.
detailed instructions on how to draw and manipulate a table, see Chapters 6 and 7 of your Informed 
Designer Design and Graphics manual.

Working with Tables

This section explains how to replace multiple objects with a single table.

There are two methods you can use to replace multiple fields with a table. To use the first me

■   Select the fields and any other relevant objects (text, lines, rectangles) you want to replac

Note Make sure you print a Cell Report before removing any fields in case they contain calculat
that need to be reentered in the new table. For detailed information about the Cell Report, 
Chapter 1 of your Informed Designer Forms Automation manual.
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.
■   Group the selected objects and use Informed Designer’s guides to mark the bounds of th

and its various components such as the columns, and title areas. For information on usin
guides, see Chapter 5 of your Informed Designer Design and Graphics manual.

■   Delete the selected objects.

■   Select the Table tool on the Tool palette and draw the new table within the boundaries ma
by the guides.

The second method of replacing multiple fields with a table involves using Informed Designe
Master page.

■   Select the fields and any other relevant objects (text, lines, rectangles) you want to replac

■   Group the selected objects and drag them to the “M” page control at the bottom of the dra
window.

■   The selected objects will appear on the Master page in the same position as they were d
from on the previous page.

■   Click on the Numbered page control at the bottom of the drawing window to return to the
inal page. Since objects on the Master page show through to every page on the form, yo
use those objects as a guide or template to create the new table.

■   Select the Table tool on the Tool palette and draw the new table on top of the objects sho
through from the Master page.

■   With the new table selected, choose the No Fill option from the Fill submenu under the S
menu. This allows you to see the objects on the Master page so you can adjust the vario
ments of the new table accordingly.

■   When you have adjusted the table, set the fill back to white or whatever color you require
return to the Master page and delete the original objects.

If any of the objects you delete are referenced in other cells, Informed displays a dialog showi
name of the cell that contains the reference.

If you click the ‘Show me’ button, Informed highlights the cell containing the reference. You c
then remove the calculation or change the reference to the new table column that has replac
deleted object.

Drag the selected objects
onto the “M” page control.
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Object Alignment

When the pen is set on fields you may find that the fields do not line up correctly—their bound
might not be exactly right, lines may be touching, but not overlaid on top of each other, so tha
look thicker than they should. You can use the Specs palette to see by how much the objects
of alignment. Often the difference is only about 0.5 points. To align these objects correctly:

■   Select all the relevant fields with the Pointer tool.

■   Hold down the Shift key and press the right directional arrow on your keyboard to extend
right-hand side of the objects. Usually this will take care of the problem. If some of the ob
have been extended too much, you can try adjusting them in the opposite direction by ho
down the Shift key and pressing the left directional arrow on your keyboard.

Graphics

Graphics are not converted by the FormFlow Forms Translator. These will have to be importe
the converted Informed form template. For information on how to import graphics into your te
plate, see Chapter 9 of your Informed Designer Design and Graphics manual.

Color

When translating forms, FormFlow Forms Translator will properly convert the following colors
Red, Green, Blue, Cyan, Magenta, Yellow, and Black. Any other colors will translate to black.
reset the colors in the converted form template:

■   Select the object(s) whose color you wish to change.

■   Choose Fill under the Style menu and select the color you want from the color palette.

You might also need to adjust the pen for some objects. Informed lets you set the Pen and F
ors independently of each other.

Intelligence Features

As explained earlier, the elements of an electronic form fall into two categories: graphics and
ligence. This section explains how to deal with conversion problems that affect the intelligenc
ments on your template.

Note Any time you delete and replace a cell (field or table), you will need to adjust the tab order
the form template to maintain the correct fill sequence. For information on how to adjust the
order, see “Tab Order” in Chapter 1 of your Informed Designer Forms Automation manual.
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Field/Cell Names

Both FormFlow and Informed have restrictions on the naming of fields and cells. Informed ce
names can be up to 255 characters long, but can only contain the following characters: all upp
lowercase letters of the alphabet (a-z, A-Z), all numbers (but the cell name cannot begin with
number), and the underscore character (_).

Both FormFlow and Informed have reserved words that have a special meaning within each 
gram. These words cannot be used in field or cell names. However, FormFlow and Informed
different reserved words. Usually these are function names used in calculations. For a list of 
Informed reserved words, see Appendix B of the Delrina FormFlow Forms Translator Reference or 
Chapter 10 of your Informed Designer Forms Automation manual.

If you change the name of a cell used in a calculation in Informed, the cell reference is upda
automatically. This means that you can rename cells after referencing them in Value or Chec
culations without having to worry about the reference becoming invalid.

Field/Cell Types and Formatting

FormFlow and Informed support various data types. Selecting the appropriate type for each fi
cell restricts the values that can be entered into each field or cell.

FormFlow supports the following field types: General, Fixed, Percentage, Currency, Floating,
Number, Serial Number, Check Mark, Time, Date, Graphic, Signature, and Bar Code.

Informed supports the following cell types: Text, Character, Number, Name, Date, Time, Boo
Picture, and Signature.

Most of these types are compatible and are converted cleanly. Field and cell types are mapp
according to the following table.

Corresponding FormFlow and Informed Cell Types

Note Because the name of the “go to” cell is placed inside quotation marks in Informed Conditio
Tab calculations, these references are not updated automatically.

FormFlow Cell Type Informed Cell Type

General Text

Signature Text

Bar Code Text

Fixed Number

Percentage Number

Currency Number
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Format attributes are also often converted. For example, a FormFlow date field with the form
‘MM-DD-YY’ and the slash (‘/’) separator translates to an Informed date format of ‘DD/MM/YY

Calculations

Both FormFlow and Informed allow the form designer to create sophisticated calculations so
information is entered on the form automatically. Most FormFlow calculations are converted 
cessfully to an Informed equivalent. However, calculations that rely on functions that are not 
ported by both products are not translated.

Database Lookups

Both FormFlow and Informed support lookups to allow the user to automatically enter informa
on the form. At the time the FormFlow Form Translator was written, FormFlow and Informed 
looked up information from sources that were generally platform specific (with the exception 
SQL databases). That is, FormFlow allowed you to look up into database formats that were s
ported by PC applications, whereas Informed supported Mac OS standards such as Apple e

While Informed now supports an extensive list of cross-platform database lookups, FormFlow
Forms Translator does not translate lookup configurations. Therefore, database lookups mus
reconfigured in the converted form template in Informed. For information on configuring data
lookups, see Chapter 1 of your Informed Designer Forms Automation manual.

Floating Number

Page Number Number

Serial Number Number

Check Mark Boolean

Time Time

Date Date

Graphic Picture

Button Ignored

Note Informed version 2.0 contains many new functions, as well as a number of functions that h
been modified from previous versions. The FormFlow Forms Translator only converts the f
tions that were supported in earlier versions of Informed. Therefore, it is very important to 
the converted form’s intelligence to ensure correct functionality. See the log file created du
conversion of the file to Informed for details of how calculations have been converted.
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List Lookups and Choice Lists

Lookups into simple lists are supported by both FormFlow (list lookups) and Informed (choic
lists). Like database lookups, choice lists help a user fill out the form by entering information 
quickly. FormFlow Forms Translator converts list lookups to Informed choice lists.

Form Numbers

Many forms such as purchase orders and invoices contain unique form numbers. FormFlow 
Informed have built-in support for form number generation. FormFlow’s serial number attribu
allow you to configure options for obtaining new numbers either from the form template itself
from external databases. Informed provides a similar capability with its Value command and 
Auto-increment option.

Although both FormFlow and Informed can obtain form numbers from external sources, the f
number capabilities of each did not support a common data source at the time FormFlow Fo
Translator was written. Serial number (or auto-increment) attributes between FormFlow and 
Informed are not converted and must be reconfigured in the Informed form template. See Cha
of your Informed Designer Forms Automation manual for information on configuring auto-incre-
menting numbers.

Tab Order

Both FormFlow and Informed allow the form designer to specify the tabbing order of the field
cells on a form template. Conditional tabbing allows the tab order to change dynamically bas
conditions on the form. Informed did not support this feature at the time the FormFlow Forms
Translator was written. Therefore, FormFlow conditional tab calculations are ignored when tr
lated to Informed and must be reconfigured in the converted Informed form template. See Cha
of your Informed Designer Forms Automation manual for information on tab order.

Bar Codes

FormFlow supports bar codes directly with the option of using one of eight different standard
mats. Informed relies on the built-in font support of the Mac OS. In Informed, bar codes are en
using a bar code font. Informed comes with a demonstration version of Azalea Barcode font.
and other fonts can be obtained from the various font vendors.

When designing form templates for cross-platform use in Informed, your choice of bar code 
options is limited to the bar codes available on the Mac OS. The type of the bar code cell on 
Informed form should be set to Text and its font should be set to the appropriate bar code fon

Digital Signatures

FormFlow and Informed both support electronic signing of forms with digital signatures and e
relies on the digital signature technology developed by RSA Data Security, Inc. However, the
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implementation of this technology in FormFlow and Informed is different. FormFlow signature
type fields are converted to Informed’s Text type. Digital signature cells must be reconfigured 
converted Informed form template. For information on configuring digital signature cells, see
Chapter 2 of your Informed Designer Forms Automation manual.

FormFlow Translation Error Messages
You may encounter some errors while using the FormFlow Translator. This section contains a
the possible errors you might encounter, explanations of what they mean and, where relevan
tions on how to overcome them.

Program Error Messages

Program error messages can be generated during the actual translation process. In the follo
sections, the message is shown in bold type, followed by the explanation.

Cannot allocate memory.

You do not have enough system memory available to continue the translation. Close FormFl
Translator and any other unnecessary Windows applications, then restart Forms Translator a
again.

Cannot read the log file. Please check the validity.

The log file is already open or it might be corrupted or contain errors. Check to see if anothe
has the file open, close any other program on your system which might have the file open, or
the log file and translate the form again.

Form contains too many objects. Break into separate forms and try again.

You attempted to translate a form containing more than 1200 objects or which is too large fo
system memory to handle. Cancel the translation and try the following: either reduce the num
objects in the original form; or, if the original form consists of multiple pages, save each page
separate form and convert them individually.

Form has more than 512 cells. Break into several forms and try again. Ter-
minate this translation?

Forms Translator encounters problems converting forms containing more than 512 cells. If y
choose to continue the translation, the form will be translated, but you may encounter proble

FormFlow Translation Error Messages
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.
with the cell names in Informed. For best results, terminate the translation, then revise the or
form so that it contains less than 512 cells, or break the form into several forms.

Locked forms cannot be translated.

You are trying to translate a locked form. Locate an unlocked version of the form and try the 
lation again.

Original form file name has incorrect extension.

FormFlow Translator can only translate files with the .FRP extension. If the file was originally
.FRP file which has been renamed, rename it with the proper extension and try the translation
If the file was not a .FRP file originally, open it in FormFlow Designer and save it with the .FR
extension before attempting the translation again.

The generated log file is too large to open in this editor.

FormFlow Forms Translator cannot display a log file larger than 64K. Complex forms might g
ate a large log file during the translation process. Use a text editor or word processor to revie
log file, instead.

The total length of file names selected exceeds the system limit. Please 
make fewer selections.

You have selected multiple files to be opened and the total length of the file names is longer 
255 characters. Try selecting fewer files so the total length of the file names is less than 255 
ters.

This file already exists. Replace existing file?

You are trying to save a translated file with a file name that already exists. Either change the
name, change the location where the file is to be saved, or replace the existing file by overwr

This file name is not valid.

You are trying to save a translated file with an invalid file name. Either the file name contains
invalid characters or it is too long. Change the file name to remove invalid characters or shorte
a maximum of eight characters plus a three character extension.
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Translate?

You have selected multiple files to be opened and translated. This prompt is to ensure that y
not accidentally overwrite existing files. A confirmation prompt appears for each file selected. 
‘Yes’ to open the file and proceed with translation or click ‘No’ to open the file but skip the tra
tion at this time.

Translation failed. See log file for details.

Translation of the file failed. Check the log file for information about the translation failure. Fo
example, a translation will fail if the form contains a cell name with invalid characters. Correc
problems in the original FormFlow form as identified in the log file and try the translation aga
See the following section, “FormFlow to Informed Translation Log Messages” for information
log file entries.

Unable to read from <file name>, it is opened by someone else.

You are trying to open a file that is in use by another user or application. Close the applicatio
rently using the file or wait until the other user is no longer accessing the file.

FormFlow to Informed Translation Log Messages

During the translation of the form, the FormFlow Translator generates a log file. The following
list of the possible entries in the log file and explanations of what they mean. You can use the
lation log to determine some of the differences between your original FormFlow document an
converted Informed version. This is particularly important with the intelligence elements of th
form such as value calculations and database connections. If your translation failed, review t
and make the relevant adjustments to the FormFlow form and try again. Some of the entries
log are for information purposes only and refer to conditions which cannot be changed.

Another log file is created by Informed when you convert the IFD file. This log file contains th
details of the calculations in the form and shows how Informed has handled the calculations c
by the FormFlow Forms Translator.

[%buttoncellname]: Informed does not support button object, ignored.

At the time Forms Translator was written Informed did not support buttons. Therefore, the bu
object on the FormFlow form is not translated.

[%cellname]: AM/PM used instead of Am/Pm.

The FormFlow Am/Pm time format was translated to AM/PM.
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.
[%cellname]: AM/PM used instead of am/pm.

The FormFlow am/pm time format was translated to AM/PM.

[%cellname]: calculation modified...

   [FormFlow calculation]
   [Informed calculation]
This message indicates that a calculation has been modified by Forms Translator. The origin
FormFlow calculation is followed by the modified Informed calculation.

[%cellname]: century value not translated.

FormFlow date formats contain only the final two digits of the year value. Although you can dis
the full year by enabling the Show Year as 19XX option in the Date Attributes dialog in FormF
this option is not translated by Forms Translator.

[%cellname]: check box values not supported in Informed, translated to 
default.

At the time Forms Translator was written, Informed did not support the FormFlow check box 
mat for this field. The format is translated to Boolean type with a default Check Box Style.

[%cellname]: check formula modified

   [FormFlow check string]
   [Informed check string]
This message indicates that a check formula has been modified by Forms Translator. The or
FormFlow check string is followed by the modified Informed check calculation.

[%cellname]: default format HH:MM:SS used.

Forms Translator has converted the FormFlow time format for this field to the Informed defau
HH:MM:SS. 

[%cellname]: default format M/D/YY used.

Forms Translator has converted the FormFlow date format for this field to the Informed defau
M/D/YY.
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[%cellname]: graphics file not translated.

Forms Translator could not translate the link to the graphics file associated with this field. The
has been translated to a Picture type cell.

[%cellname]: Informed does not support bar code type field.

Use a Text type cell with a bar code font in Informed.

[%cellname]: Informed does not support button type field.

At the time Forms Translator was written Informed did not support button objects. Therefore,
Forms Translator did not translate the button object on the FormFlow form.

[%cellname]: Informed does not support case sensitivity during choice typ-
ing.

Informed does not support case sensitivity when selecting items in a choice list. If you have t
entries in your lookup table differentiated by upper and lower case spelling, Informed selects
first occurrence of the entry in the lookup table. Either remove multiple entries with different u
and lower cases from your lookup table and disable the Case Sensitive option in the List Loo
dialog in FormFlow, and try the translation again, or edit the choice list in Informed.

[%cellname]: Database lookups cannot be translated.

If the possible entry list is a short one you can use a lookup table in FormFlow and try transla
again. Otherwise, simply reconfigure the database lookup in Informed.

[%cellname]: Informed does not support DDE Link.

Forms Translator does not translate this data entry field attribute.

[%cellname]: Informed does not support fixed field length.

At the time Forms Translator was written Informed did not support fixed field lengths. Either s
field attributes to variable field length or adjust the cell in Informed.

[%cellname]: Informed does not support hour-only format.

Change the time format to one supported by Informed.
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.
[%cellname]: Informed does not support macros.

Forms Translator does not translate this data entry field attribute.

[%cellname]: Informed does not support mandatory field.

At the time Forms Translator was written Informed did not support mandatory fields. Therefo
Forms Translator does not translate this attribute. Either set the cell entry to be required on 
Informed’s Cell Settings dialog or use a check calculation in the converted form.

[%cellname]: Informed does not support ranges.

At the time Forms Translator was written Informed did not support this data entry field attribu
Therefore, this attribute is not translated.

[%cellname]: Informed does not support transaction feature.

Forms Translator does not translate this field attribute.

[%cellname]: Informed does not support value on last form as default.

Forms Translator does not translate this setting.

[%cellname]: Informed supports only both READ and WRITE option.

You should set both the Read and Write storage options in the Field Attributes dialog in the F
Flow form.

[%cellname]: invalid decimal separator character, period is used.

Forms Translator translates the customized decimal separator character from FormFlow as a

[%cellname] is a reserved name in Informed, changed to [%cellname_].

Your FormFlow form contains a field name which is a reserved name in Informed. Forms Tran
changed the field name by adding an underscore (_) character to the end of the name. See 
10 of your Informed Designer Forms Automation manual for a list of Informed reserved words.
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[%cellname]: lookup list is always sorted in Informed.

Informed Choice lists are always sorted alphanumerically.

[%cellname]: nonstandard decimal format, mapped to general format.

Forms Translator translated the decimal format in the FormFlow form to a general decimal fo
You can modify the format as required using the Cell Settings dialog in Informed.

[%cellname]: partial match is always enabled in Informed.

The partial match option is always enabled for Informed Choice lists.

[%cellname]: percent format not available, displayed in decimal format.

Informed does not support FormFlow's percent format. The value in this field is displayed in 
mal format in Informed.

[%cellname]: serial number database lookup requires special database 
extension.

Forms Translator does not translate serial number attributes. You need to reconfigure the da
lookup in Informed.

[%cellname]: serial number increment next value not known, use 1 as 
default.

Forms Translator was unable to determine the increment Value. Use the Value command und
Settings menu in Informed and select the Auto-increment option to configure this value.

[%cellname]: thousands separator not shown with this decimal format.

Forms Translator has translated the number format in the FormFlow form to a format which d
not show thousands separators. To modify the format in Informed, change the Number Form
the Cell Settings dialog.
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.
[%cellname]: unknown type of field.

There was a problem reading the original file or disk during translation. Try the translation ag
using a new copy of the original FormFlow form. If the error persists select the cell and edit it 
the Cell Settings dialog in Informed.

[%cellname]: operand [%cellname2] in calculation is of invalid type. All cells 
in calculation must be the same type.

Forms Translator expects all fields in a calculation to be of the same type of format.

[%combname]: comb cell translated into an array of fields [%comb-
cellname].

Forms Translator translates FormFlow comb fields into an Informed table. If there is regular t
a fillable comb, Forms Translator translates the text into field objects.

[%file name] is a locked form. Translation not allowed.

Forms Translator cannot translate locked forms. Locate an unlocked version of the form and 
translation again.

[%tablecolumnname] has invalid character in cell name. Valid characters for 
cell name are [a-z], [A-Z], [0-9] and [_] Cell name must start with [a-z] or [A-
Z].

Change the FormFlow field name(s). Then try the translation again.

Author Name has a maximum length of 31 characters in Informed, string 
truncated.

In FormFlow Designer, choose Form Info from the File menu and change the Designer to 31
acters or less. Then try the translation again.

Cannot open help file [%file name].

Forms Translator encountered a problem reading the original file or disk during translation. T
translation again using a new copy of the original help file. If the error persists you can selec
cell and recreate the help message in the Cell Settings dialog in the converted form in Inform
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'Compulsory' field is translated to a field with check formula [%checkstring].

At the time Forms Translator was written Informed did not support compulsory fields. Therefo
Forms Translator translates FormFlow's compulsory fields to cells with the check formula “I F
ISEMPTY (%cellname) THEN RETURN FALSE WITH ALERT "FIELD %cellname MUST BE
FILLED" END”. This check formula displays an alert message advising the user that the field
compulsory. Alternatively, you can use the Required data entry option on the Cell Settings dia
Informed.

Ensure that the print paper attributes (page type, orientation) in the Page 
Setup Dialog are set up to best fit the drawing area.

Forms Translator does not translate these attributes. Use the Page Setup dialog to set the re
print attributes in Informed.

Fill character other than [_] mapped to solid rule line style.

Forms Translator translates fill characters to a solid rule line.

Form ID has a maximum length of 31 characters in Informed, string trun-
cated.

Forms Translator truncates the Form Title to 31 characters or less.

General type field with masks is translated to a character cell.

Forms Translator translates the mask in the general field in the FormFlow form to the closest
ble Character Format in a Character type cell in Informed. Use the Cell Settings dialog to mo
the Character Format in Informed.

Help file is too large, only 32K bytes can be read.

Forms Translator reads the help file attached to the FormFlow form during translation and co
into the help message in Informed. If the FormFlow help file is larger than 32K, Forms Trans
truncates the remaining text. Use the Help Message dialog in Informed to add the additional
text.

Informed does not support 'newline', ignored.

Forms Translator does not translate the Enter operator on FormFlow’s Field Attributes Mask d
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.
Informed does not support 'Repeat Last Mask'.

Forms Translator does not translate the Repeat Last Mask option in FormFlow’s Field Attribu
Mask dialog.

Informed does not support 3-D concave line style, translated to solid.

Forms Translator does not translate FormFlow’s 3-D concave line style.

Informed does not support bar code object. Translated to a field.

To use bar codes in Informed, use a Text type cell with a bar code font.

Informed does not support cell content rotation, mapped to unrotated cell.

Informed does not support rotated text in cells.

Informed does not support custom row height.

Informed does not support FormFlow’s custom row height attribute in tables.

Informed does not support Dash-Dot-Dot line style, translated to Dash-Dot.

Forms Translator does not translate FormFlow’s Dash-Dot-Dot line style.

Informed does not support forced right angles.

Forms Translator does not translate FormFlow’s Right Angles option in the Line Attributes dia

Informed does not support graphic object.

Forms Translator does not translate regular graphic objects. To add graphics to Informed for
choose the Import command from the File menu. See the Informed Designer Design and Graphics 
manual for detailed information about adding graphics to forms. Forms Translator translates 
Flow’s fillable graphic objects to Picture type cells. However, the link to the graphics file assoc
with the field is not translated.
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Informed does not support margins in data area of cells.

Forms Translator does not translate FormFlow’s margin information in fillable cells.

Informed does not support replace list.

Forms Translator does not translate FormFlow’s Replace Table Lookup Type in the List Look
dialog.

Informed only supports a single currency symbol.

FormFlow supports any designated character as a currency symbol. Informed supports the cu
symbol that corresponds to the currency used in the country for which the Mac OS computer 
figured. Select Form Setup from the File menu and change the Currency field to $ in FormFl
Designer before translating the form.

Informed only supports currency symbol before price value.

FormFlow supports a currency symbol either before or after a price value. Select Form Setup
the File menu in FormFlow Designer. In the Currency section of the Form Setup dialog, enab
Before option.

Informed only supports measurements in inches.

This message is incorrect. Informed has always supported inches, centimeters, picas and po

Informed supports only every row and every 2nd row pattern.

Select only the Row or 2nd Row options in the ‘Row Pattern Every’ section in the Table Attrib
dialog in FormFlow. Informed does not support patterns in table rows every nth row.

Informed supports only points, not actual line width.

If a line was defined in FormFlow as a width (for example, 0.1 inches), Forms Translator tran
the width to the nearest point value. Because of rounding, the result of conversion may not b
exactly as originally designed.

Informed supports only solid line style on oval.

In FormFlow, select any oval objects and select the solid line style from the Line menu.
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Informed supports only square ends.

FormFlow supports round, square and arrow ends for lines, while Informed supports only squ
ends. Select any line objects and choose Attributes from the Object menu in FormFlow Desig
and choose the square end line style in the Line Attributes dialog.

Line style: concave/convex line translated to solid.

Informed does not support the concave and convex line styles. Forms Translator translates th
to a single solid line.

Object is a circle.

This is an information message only.

Object is an ellipse.

This is an information message only.

Page Margins are converted into top and left drawing offset.

At the time Forms Translator was written Informed did not support page margins. Forms Tran
simulates margins by using top and left drawing offset. This requires the converted form to b
realigned in Informed.

Page orientation is landscape.

Informed's default page orientation is portrait. If the FormFlow form was landscape, choose P
Setup from the File menu in Informed and change the page orientation in the Page Setup dia

Page type is %papertype.

The page size of the form.

'Repeat on all pages' object moved to Master Page.

Forms Translator moves all FormFlow objects with the Repeat on all pages option enabled to
Master Page in Informed. All objects on the Master Page are displayed on every page of the
Informed form.
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Revision Number has a maximum length of 31 characters in Informed, 
string truncated.

Forms Translator truncates the Form Info Version data to 31 characters.

Signature has to be hand crafted, translated to a text cell.

Forms Translator does not translate FormFlow signature fields to Informed signature cells. If
FormFlow signature field did not use a mask, Forms Translator translates it to a text cell. Ch
the cell type to Signature in the Cell Settings dialog in Informed. Select the cells to be signed
the signing service to be used.

Signature has to be hand crafted, translated to a character cell.

Forms Translator does not translate FormFlow signature fields to Informed signature cells. If
FormFlow signature field used a mask, Forms Translator translates it to a character cell. In 
Informed, change the cell type to Signature in the Cell Settings dialog. Select the cells to be 
and the signing service to be used.

Tab key(s) are converted to 8 spaces.

Forms Translator translates any tab characters in text or field names to eight blank spaces.

Text has unsupported vertical justification, mapped to top.

Forms Translator could not identify the vertical justification for the original object and therefo
translated it to top justification.

TRANSLATION FAILED: [%cellname] has invalid character in cell name. Valid 
characters for cell name are [a-z], [A-Z], [0-9] and [_]. Cell name must start 
with [a-z] or [A-Z].

Change the FormFlow field name and try the translation again.

TRANSLATION FAILED: no field with name [%cellname].

Forms Translator could not find the field indicated in the message in the global field list.
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Unsupported combination of masks, translated to 'Any character'.

Forms Translator could not translate a mask combination selected in FormFlow to an equiva
selection in Informed. Therefore, Forms Translator translated the mask combination to "Any 
acter" in the character cell.
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