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Introduction

CDRoller is a powerful, easy-to-use and low-cost toolset for CD/DVD data recovery.

Powerful:  CDRoller finds, retrieves and copies the lost data from CDs and DVDs that seem to be
inaccessible for Windows standard tools. While this does not include the disks that are physically
damaged, the program will:
· Effectively retrieve the data from the discs created by "drag and drop" writing software, such as well-

known Roxio (Adaptec) DirectCD and Ahead Nero software packages.
· Recover CD and DVD data created by standalone devices that record directly onto disks, including:

Sony digital cameras, Hitachi DVD camcorders, personal DVD recorders, etc.
· Retrieve back up files from the discs recorded in the several stages (multisession discs).
· Find and retrieve the lost files on UDF discs, including: accidently deleted files, files on quick-

formatted disc, files on incorrectly closed disc, etc.
· Simply retrieve data from scratched, damaged or defective discs.
· Extract tracks from audio CDs
· Test CD readability

Easy-to-use: All features are integrated into a common intuitive shell similar to well-known Windows
Explorer.

Low-cost:  A single user's license costs only 29.50 USD.

Toolset: The program contains a set of instruments to work with different formats of CDs (DVDs) and
file systems.

CD/DVD Data Recovery: Unfortunately, there is a lot of factors that can cause you to lose access to
the data on your disks. System or power failures, hardware problems, media and CD/DVD mastering
software problems... Often, when a disc becomes inaccessible more than a single factor has
contributed to the problem. Fortunately, many of such problems that prevent "normal" access to the
data can be bypassed when using CDRoller.
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1. Installing CDRoller

To install CDRoller, you need at least:
· Microsoft Windows 95/98/ME/NT4/2000/XP operating system
· Intel Pentium or compatible CPU

· 16 MB of RAM
· 2 MB free hard disk space
· CD/DVD drive(s). The devices with IDE or SCSI interfaces are highly recommended.

Note. You must have administrator rights to install the program under Windows NT4, Windows 2000 or
Windows XP.

There are no special considerations for installing CDRoller. It uses no .INI files, and only uses the
registry for holding installation options. It will initially use default options that will be changed further via
the user preferences.

To install CDRoller:
1. Run the installation file. The installation program displays a Welcome page similar to the one shown
here.

Click the Next button.
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2. The installation program displays a License Agreement page similar to the one shown here.

Read the license agreement displayed and if you agree to its terms click the Yes button. You must
agree to terms of the license agreement to install CDRoller. If you do not agree to the terms of the
license agreement, click the No button to exit the installation program.
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3. The installation program displays a Destination Directory page similar to the one shown here.

CDRoller consists of a number of files containing the program and help information. It is recommended
that you accept the default folder structure provided in the installation program. When you're satisfied
with the installation folder specification, click the Next button.



1. Installing CDRoller 7

© 2003, 2004 CDRoller Soft Co. Ltd.

4. The installation program displays a Select Start Menu Folder page similar to the one shown here.

By default, the installation program creates an CDRoller folder on your start menu. This is what you'll
see when you choose Start | Programs on the Windows taskbar. If you want to use an existing folder,
choose it from the list shown; if you want to use a different name, type it in the text field. If the
checkbox 'Don't create any icons' is checked, the desktop icon will not be shown. When you're
satisfied with your start menu folder selection, click the Next button.
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5. The installation program displays a Ready To Install page similar to the one shown here.

You've made all the choices necessary to begin installation. Click the Install button to begin installing
CDRoller.
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6. After the copying of files to your computer has been completed, the installation program displays a
Finish  page similar to the one shown here.

If you install CDRoller under Windows 95/98/ME, we recommend you to restart your computer. Click
the Finish button. Installation of CDRoller is complete.
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2. Uninstalling CDRoller

To uninstall CDRoller you can either:
· Use the menu selection created for this purpose.
· Select the Add/Remove Programs applet from the Windows Control Panel.

CDRoller does not install any system DLLs and does not modify Windows in any manner. Uninstalling
this program will not affect other applications. To uninstall CDRoller, click the Start button on the
Windows Taskbar, then choose Programs | CDRoller | Uninstall CDRoller.
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3. Opening and Closing CDRoller

Opening CDRoller.
To open the program, click the Start button on the Windows Taskbar, then choose Programs |
CDRoller | CDRoller.

Closing CDRoller.
Close CDRoller as you would any other Windows application by using the File | Exit menu item or
Alt+F4 keyboard shortcut.
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4. How to register the program

Unregistered version does not permit copying CD/DVD objects for the purposes of recovering data -
the program checks readability of CD/DVD files, but it can not save the files to the destination drive. To
enable the full functionality you have to purchase the software and register your copy of CDRoller with
the help of your license key.

You can always order CDRoller using credit cards or another methods of payments if you visit web
page at http://www.cdroller.com/htm/purchase.html.

To register the program:
1. Open CDRoller.
2. Select Help | About option in the Main Menu.
3. Click the Register button on the About dialog.
4. Enter your name and personal license key.
5. Click Accept button and restart CDRoller.

http://www.cdroller.com/htm/purchase.html
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5. How to upgrade CDRoller

To upgrade CDRoller:
1. Uninstall an old version of the program.
2. Download a trial copy of CDRoller at http://www.cdroller.com/htm/download.html and install it.
3. Register a trial copy with the help of your licence key.

http://www.cdroller.com/htm/download.html
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6. Recovering CD/DVD Data

Overview

The process of CD/DVD data recovery is not easy and, unfortunately, it's very hard to create a "magic"
tool can retrieve all data in all cases. In this section we will try to give you a base recommendations
how to achieve a positive result quickly and with a high reliability. Also, you can always receive a
technical support at support@cdroller.com, all your questions regarding the problems with CD/DVD
data recovery will be responded within 2 to 24 hours.

We consider the following steps can be high-lighted:
1. Disk recognition.
2. Using Session Selector to access to all sessions on multisession disk.
3. Searching the lost UDF files on CD-R/DVD-R/DVD+R disks .
4. Applying Scan UDF Disc to search for the lost objects on all types of UDF disks.
5. Copying CD/DVD files to the destination drive.

Note. The 2nd...4th steps may be skipped. This depends on the disk type determined at the 1st step.

Separately, we high-light the following problems:
· Reading mini DVD-R discs created by Hitachi DVD Camcorders .
· Recovering the files from DVD discs created by Roxio Classic Creator 6 .
· Retrieving the photos from mini discs created by Sony Mavica CD cameras .
· Recovering video data off the discs created by DVD recorders (standalone devices) .

6.1. Disk recognition

Open CDRoller and insert the disk into the drive. The program must analyse your CD/DVD immediately
after insertion. After the disk has been verified, the Main Window displayes it similar to the one shown
here.

Select the disk name and choose File | Properties option. Select the TOC tab in the Properties
dialog.
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Look at the Type column. This may give us an important info about the type of the disk. In the picture
shown above, this is a disk in which UDF file system has been placed onto the data track. We will
name the disk has one or more such data tracks as "UDF disk". If all  data tracks are marked as
"Data (ISO)", we will name such disk as "ISO disk", i.e the disk with ISO 9660 file system.

Finally, check readability of the root directory (folder), just left double click on the disk name and
answer to the following questions: Is the root folder readable or not? Can i browse through the disk
contents? The answers may be applicable at the next stages of cd data recovery.

Trouble shootings.
1. If the program can not recognize your disk automatically, use Refresh command from the Edit
menu or insert the disk first and then open CDRoller. Also, to read the unclosed disks, i.e the disks left
"as-is" by CD/DVD mastering program we recommend you to use the following method:
· Uncheck Detect CD insertion by Windows on the Browser tab in the Preferences dialog and wait

for the end of disk reading processed by another CD related program.
· Select Refresh  command from the Edit menu.
2. To read UDF disks we recommend you to use CD-RW (DVD-) drives - the disks are recorded with
so-called packet-written technology and old CD-ROM drives may not access to their data.
3. Some drives may not support our special methods used by default. These devices may hang the
program when analyzing the disk. In this case, uncheck Always use CD drive capabilities  on the
Browser tab in the Preferences dialog, insert the disk and try to recognize it again.

6.2. Using Session Selector

We often receive the emails similar to the following one:
"I have copied back up files to a CDR in several stages, but the last time I backed up, I was only able
to see the most recent batch of files. The others seem to have disappeared... I presume they are still
there on the CD but "hidden" in some way - may be a different volume ?"
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Fortunately, CDRoller offers the tool named as "Session Selector" to access to the data placed into
different sessions (volumes) on your CD-R/DVD-R. These disks are known as multisession
CD/DVDs. By default, CDRoller displayes contents of the most recent session.

To access to another session:
1. Select the disk in the Main Window .
2. Choose File | Session  command. The program displays the list of available sessions similar to the
one shown here.

3. Select a new session and try to left double click on the disk (new volume) name in the Main Window.
Probably, you will detect a new files that have been "hidden" before.

Hint.
Sessions Selector  may be also extremely useful if the root folder of the last session seems to be
unreadable at the "Disk recognition" stage, but some important files may be located (duplicated) in
the previous session(s).

6.3. Searching the lost UDF files on CD-R/DVD-R/DVD+R disks.

A correct reading of UDF files and folders on write-once media (CD-R/DVD-R/DVD+R) is provided by
Virtual Allocation Table (VAT). Each time, when you add, change or delete files on CD-R/DVD-
R/DVD+R media, UDF mastering program creates a new VAT that reflects a new state of your disk. A
new VAT is being placed on the disk physically, when you eject the disk from CD/DVD drive.  VAT's
location is crucial for the disks created with the help of drag & drop software, such as well-known Roxio
(Adaptec) DirectCD and Drag-To-Disc. If the VAT can not be found or is corrupted, files will be
missing.

If your CD-R/DVD-R/DVD+R is recognized as UDF one, but when you try to open the disk, you get the
error message about unreadable root folder - this means the last VAT is not found. Also, if you have
accidently deleted some files, a new VAT does not point to them. To recover the deleted files, you
should use the previous VATs.

There are two main ways to find the lost files:
1. Using Scan UDF Disc from the Tools menu.
2. Searching an old VATs in order to recover the files from the previous backups.

The first method is described in the section 6.4. To search all VATs, please do the following:
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· Click the Preferences option from the View menu. Check on the 'Search of all VATs' box on the UDF
Reader tab in the Preferences dialog. Click the OK button to close the Preferences.

· Select Refresh command from the Edit menu. After a while the program will display a progress
dialog similar to the one shown here:

· when the process is completed, you should see the confirmation message:

· Click the OK buttons in this and all further dialogs. The program considers an each backup as a
separate "session". When you will see a new disk image (icon) in the program window, please use
built-in Session Selector (see the section 6.2) for access to all backups.

Note. Please do not search all VATs on the following disks:
- CD-RW/DVD-RW/DVD+RW,
- DVD-R and DVD+R created by DVD personal recorder (standalone device) and DVD camcorder.
These disks do not contain VAT at all.

6.4. Applying Scan UDF Disc

In addition to another methods of CD/DVD data recovery, Scan UDF Disc gives you a good chance to
retrieve several types of files, including:
· Files are not visible in Windows Explorer - the writing process was interrupted by a system or

power failure before file directory information was completed, but most or all of the files were written
to the disk. This means that the files may be on the CD (DVD), but Windows Explorer cannot see
them.

· Lost files - complete files that do not have a file name associated with them. They can also be files
that you accidently deleted from the CD (DVD).

· Files on the disks quick-formatted by Roxio DirectCD and Nero InCD.
· Files located in unreadable (damaged) UDF folders , including the root one.
· Files located on Sony Mavica CD finalized with failure on the camera.

To start Scan UDF Disc select the same option in the Tools menu. The program displays a progress
dialog similar to the one shown here.
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After CD scan is completed or canceled, found files and/or folders are displayed in the Lost objects
detected on disc... window similar to the one shown here

If the lost folders have been found, try to open them first. This may give you a chance to recover the
files with original names that are located in the found folders.

Some displayed files can be preliminary identified at the scan stage. To complete the identification
automatically, we recommend you to use the Copy and Identify command.

If you know an original type, you can rename the selected files manually, with the help of Rename
command, or/and use New Extension option to speed up the re-naming process in case of the large
list. To save the selected files, you can apply Send To , Rescue or drag&drop operations.

Hints and Tips.
1. First, try to retrieve selected file(s) by Send To command. If an error message appears, this means
that the part of file is corrupted or erased. In this case, try to recover the file partially with the help of
Rescue command.
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2. If you're going to retrieve UDF files from the same disc at the different times, you can save the table
of contents (names,locations, attributes) of the found objects into separate file by Save Table Of
Contents command from the File menu. Further, check on the Load Table Of Contents from file
box on the UDF Reader tab in the Preferences dialog. Next time, when you will run Scan UDF Disc
the program will display the list of the found objects shortly, without scanning the disc, and you can
continue to retrieve the files data.

Trouble Shooting.
If the program can not recognize UDF disk, but you are certainly sure the disk contains the files, we
recommend you to try the forced scan of the disk. This may be useful if the disk was incorrectly
finalized, and the system data are not accessible. For example, this problem often occures on Sony
Mavica CD when the finalization step failed on the camera.

To start the forced scan, you should initially know what CD/DVD mastering program (or device)
formatted your disk. For example: Roxio (Adaptec) DirectCD, Nero InCD, PacketCD or Sony Mavica
CD digital camera. Further, you should assign an appropriate profile in the Forced scan option on the
UDF Reader tab in the Preferences dialog and select Refresh command from Edit menu

Note.
Obviously, there is no 100% guarantee to recover all displayed files completely, p lease keep in mind,
that some files may be erased or partially re-written by a new ones. The program can restore those
FILES DATA, which else it is possible to rescue.

6.5. Copying files

To copy selected files and folders to the destination drive you can use Send To  and Rescue options
from File menu or simply drag and drop selected items to the destination you have chosen on your
HDD. To perform drag-and-drop, the program copies selected object(s) from CD to Temporary
Storage on HDD first, and then sends them to the destination you have chosen on HDD. You should
assign or change Directory for Temporary Storage on the CD Library tab in the Preferences dialog.

CD Data Rescue is an extremely useful feature of CDRoller to recover CD (DVD) data while reading
the damaged discs. To rescue files and folders from the damaged discs CDRoller utilizes some
adaptive methods and algorithms that may result in success. Unlike Windows standard tools, even if it
is impossible to recover all the damaged data, CD Data Rescue allows to recover the largest part of
the file, or fill unreadable sectors by zeroes to maintain an internal file structure.
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The Details window contains the results of the process, and also some recommendations. For each
file the Details window displays the percentage of the recovery. The results can be simply copied to
another document via clipboard, with the help of keyboard shortcuts (Ctrl+C and Ctrl+V). To adjust the
parameters of CD/DVD data recovery, you can use different settings on the CD Data Rescue tab in the
Preferences dialog.

6.6. Reading mini DVD-R discs created by Hitachi DVD
camcorders.

6.6.1. General requirements and settings.
· DVD-RW drives ("dvd writers") are more preferable in comparing with DVD-ROM drives ("dvd

readers").
· You should uncheck the Detect CD insertion by Windows and Always use CD drive capabilities

boxes on the Browser tab in the Preferences dialog before you will insert the troubled disc into the
drive.

6.6.2. Reading non-finalized (open) DVD-R disc.
Symptom.
Disc was not finalized, you lost an access to the data due to Disk Error message when you turned on
the camera.
Troubleshooting.
· Remove any disks from your CD/DVD drive(s).

· Run CDRoller.
· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by

Windows and Always use CD drive capabilities boxes are UNCHECKED on the Browser tab in
the Preferences dialog. Click the OK button to close the Preferences.

· Insert the troubled DVD-R.
· Click the Preferences option from the View menu again. Set the Forced scan to Hitachi DVD-R (O)

on the UDF reader tab. Click the OK button and close the Preferences again.
· Select Refresh command from the Edit menu. Do you see the VTS_01_1.VOB file in the Lost

objects detected... windiow? If yes, go to the step 6.6.4.

6.6.3. Reading DVD-R disc that was finalized with error.
Symptom.
The disc finalization was accidently interrupted, for example, due to the power failure.
Troubleshooting.
· Remove any disks from your CD/DVD drive(s).
· Run CDRoller.
· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by

Windows and Always use CD drive capabilities  boxes are UNCHECKED on the Browser tab in
the Preferences dialog. Click the OK button to close the Preferences.

· Insert the troubled DVD-R.
· Click the Preferences option from the View menu again. Set the Forced scan to Hitachi DVD-R (F)

on the UDF reader tab. Click the OK button and close the Preferences again.
· Select Refresh command from the Edit menu. Does the program scan your disc? Are any files found

within the first 100..200 sectors? If yes, rename the largest file to the .vob one with the help of
Rename option from the File menu and go to the step 6.6.4.

6.6.4. Copying the found VOB files.
At first, try to copy the found file with the help of Send To option from the File menu, or simply drag the
file to the destination folder on HDD. If you get an error message, try to apply the Rescue option from
the File menu in order to retrieve the most part of video data. Also, you can use the different settings
on the CD Data Rescue tab in the Preferences dialog, for example, selecting the Fill sector by zeroes
in the Overread list.



6. Recovering CD/DVD Data 21

© 2003, 2004 CDRoller Soft Co. Ltd.

6.6.5 Viewing the VOB files.
To view the VOB files we recommend PowerDVD from CyberLink at http://www.gocyberlink.com/.

6.7. Recovering files from DVD discs created by Roxio Classic
Creator 6.

Symptom. The files and folders only from the first session (backup) seem to be shown on the DVD disc
(DVD-R, DVD+R, DVD-RW, DVD+RW) created by Roxio Easy Creator Classic 6.

Cause & Troubleshooting.
If you have not changed the default settings in the Project Properties, Easy Creator Classic (EZ
Classic) writes the both UDF and ISO (Joliet) file systems on the DVD discs. Unfortunately, probably
due to the bug,  EZ Classic hides a new files in UDF folders, but always shows them in ISO/Joliet
ones. A solution is the following:
· Run CDRoller without any discs inserted.
· Click the Preferences from the View menu and check on Read only ISO 9660 tracks box on the

Browser tab in the Preferences dialog. Click the OK button to close the Preferences.
· Insert the DVD into the drive and click the Refresh from the Edit menu. Only ISO/Joliet files and

folders will be shown.
· If the disc contains a several sessions, use the built-in Session Selector.

6.8. Retrieving the photos from mini discs created by Sony
Mavica CD cameras.

6.8.1. General requirements and settings.
· CD-RW or DVD-RW drives (cd or dvd "writers") are more preferable in comparing with CD-ROM or

DVD-ROM drives (cd or dvd "readers").
· You should uncheck the Detect CD insertion by Windows box on the Browser tab in the

Preferences dialog before you will insert the troubled disc into the drive.

6.8.2. Reading mini disc that was finalized with failure on the camera.
Symptom.
The disc finalization was accidently interrupted, for example, due to the power failure.
Troubleshooting.
· Remove any disks from your CD/DVD drive(s).
· Run CDRoller.
· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by

Windows is UNCHECKED on the Browser tab in the Preferences dialog. Click the OK button to
close the Preferences.

· Insert the troubled disc.
· Select Refresh command from the Edit menu.
· Does the program recognize your disc? If not, please go to the step 6.8.3
· If you can see the disc icon in the program window, try to open the disc by left-double clicking its

name. Do you get the message about unreadable root folder? If yes, try to run Scan UDF Disc from
the Tools menu and go to the step 6.8.4 if the program has found the lost files.

6.8.3. Reading non-finalized (open) disc.
Symptom.
Disc was not finalized, you lost an access to the data due to Disk Error. You was able to view the
photos earlier (prior to the disk error).
Troubleshooting.
· Remove any disks from your CD/DVD drive(s).
· Run CDRoller.

http://www.gocyberlink.com/
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· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by
Windows  box is UNCHECKED on the Browser tab in the Preferences dialog. Click the OK button to
close the Preferences.

· Insert the troubled disc.
· Click the Preferences option from the View menu again. Set the Forced scan to Sony Mavica CD

on the UDF reader tab. Click the OK button and close the Preferences again.
· Select Refresh command from the Edit menu. Does the program scan your disc? Are any files

found? If yes, go to the step 6.8.4.

6.8.4. Recovering the found (indexed) files displayed in the "Lost objects detected..." window.
· Click the Select All command from the Edit menu and apply Copy and Identify command to

recover the files (photos) automatically.
· Use Rename or/and New Extension commands to re-name the indexed files to .jpg ones, and then

copy them to HDD with the help of Send To, Rescue or drag&drop operations.

6.9. Recovering video data off the discs created by DVD
recorders (standalone devices).

6.9.1. General requirements and settings.

· DVD-RW drives ("dvd writers") are more preferable in comparing with DVD-ROM drives ("dvd
readers").

· You should uncheck the Detect CD insertion by Windows and Always use CD drive capabilities
boxes on the Browser tab in the Preferences dialog before you will insert the troubled disc into the
drive.

6.9.2. Reading non-finalized (open) disc.
Symptom.
Disc was not finalized at all, you lost an access to the video data when you turned on the recorder.
Troubleshooting.
· Remove any disks from your CD/DVD drive(s).
· Run CDRoller.
· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by

Windows and Always use CD drive capabilities boxes are UNCHECKED on the Browser tab in
the Preferences dialog. Click the OK button to close the Preferences.

· Insert the troubled disc.
· Click the Preferences option from the View menu again. Set the Forced scan to Rec DVD+RW (O)

(in case of DVD+RW disc created by Thomson RCA, Philips, etc), or LiteOn DVD+R (O) (if the
DVD+R disc was created by Lite-On DVD recorder) on the UDF reader tab. Click the OK button and
close the Preferences again.

· Select Refresh command from the Edit menu. The Lost objects detected... windiow must appear
immediately. Do you see the VTS_01_1.VOB  file? If yes, go to the step 6.9.5.

6.9.3. Reading the disc was finalized with error.
Symptom.
The disc finalization was accidently interrupted, for example, due to the power failure.
Troubleshooting.
· Remove any disks from your CD/DVD drive(s).
· Run CDRoller.
· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by

Windows and Always use CD drive capabilities  boxes are UNCHECKED on the Browser tab in
the Preferences dialog. Click the OK button to close the Preferences.

· Insert the troubled DVD.
· Click the Preferences option from the View menu again. Set the Forced scan to Rec DVD+RW (F)

(in case of DVD+RW disc created by Thomson RCA, Philips, etc), or LiteOn DVD+R (if the DVD+R
disc was created by Lite-On DVD recorder) on the UDF reader tab. Click the OK button and close
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the Preferences again.
· Select Refresh command from the Edit menu. Does the program scan your disc? Are any files found

within the first 100..200 sectors? If yes, rename the largest file(s) to the .vob one(s) with the help
of Rename option from the File menu and go to the step 6.9.5.

6.9.4. Reading quick-erased DVD-RAM disc.
Symptom.
Disc was accidently quick-erased by DVD-RAM recorder. All movies seem to be lost.
Troubleshooting.
· Do not record any new movies.
· Remove any disks from your CD/DVD drive(s).
· Run CDRoller.
· Click the Preferences option from the View menu. Make sure that the Detect CD insertion by

Windows and Always use CD drive capabilities boxes are UNCHECKED on the Browser tab in
the Preferences dialog. Click the OK button to close the Preferences.

· Insert the troubled disc.
· Click the Preferences option from the View menu again. Set the Forced scan to Rec DVD-RAM (E)

on the UDF reader tab. Click the OK button and close the Preferences again.
· Select Refresh command from the Edit menu. The Lost objects detected... windiow must appear

immediately. Do you see the VTS_01_1.VOB  file? If yes, go to the step 6.9.5.

Note. This feature was tested only on the discs erased by Panasonic DVD-RAM recorder. If you have
any questions, please contact our Support Dept. at support@cdroller.com

6.9.5. Copying the found VOB files.

· Click the Preferences option from the View menu again. Go to the CD Data Rescue tab and set
Force to the Low and Retry to the Min . Click the OK button.

· Select the VOB file(s) and apply the Rescue option from the File menu.In case of non-finalized
(open) disc (6.9.2) or quick-erased DVD-RAM (6.9.4), an actual length of the lost video data is
unknown. Please use Recover ... % of the file size option on the CD Data Rescue tab in order to
correct the size of the data for a new recovery. Obviously, the recovery process takes a some time.
However, this seems to be a single way to retrieve the lost data.

6.9.6. Viewing the VOB files.
To view the VOB files we recommend PowerDVD from CyberLink at http://www.gocyberlink.com/.

http://www.gocyberlink.com/
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7. Additional features

Overview

In addition to CD/DVD data recovery the program offers set of features for:
· Testing CD
· Extracting Audio Tracks
· Extracting ISO Image File
· Creating Short CD/DVD image

All mentioned features are integrated into a common intuitive shell of CDRoller.

7.1. Testing CD

With the help of CD Media Test you can check if a CD(-R/W) contains errors. It can be useful to:
- Check the quality of the CD(-R/W) media.
- If you have a CD recorder, you can check if the data on the CD-R(W) is written correctly.
- Get advanced information from CD Volume.
The test can be used for both CD-ROM and CD-Audio. It also examines Multisession and Mixed mode
discs.

The list of tests includes ISO 9660 File System test, CD surface test and Digital Audio Extraction
(DAE) Quality test.  Since the program automatically determines the disc type, it always knows what
the test from the list can be applied to the CD inserted into the drive. By CD Media Test tab options you
can manually include (exclude) an appropriate test to (from) the list, set scan ratio while testing CD
surface and also select checks of all sessions or only current session on multisession disc.

To start CD test select the Test CD Media option in the Tools menu. The program displays a progress
dialog similar to the one shown here.

After all tests have completed, the program generates the reports. An example of ISO 9660 File
System test report is shown here.
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Note. CD Media Test is not available for the UDF disks.

7.2. Extracting Audio Tracks

To extract ("rip") audio track(s):
1. Insert CD audio into the drive.
2. After disk recognition left double click on CD name in the Main Window. The program displays the
Main Window similar to the one shown here.

3. Select the track(s).
4. Choose File | Send To command or simply drag and drop selected track(s) to the destination on
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HDD.
5. The program displays a progress dialog similar to the one shown here.

To extract audio tracks the program utilize the method known as Digital Audio Extraction (DAE). Key
features:
· Applies a set of different extraction methods with Dynamic, Fixed synchronization with "jitter"

correction, re-read block of sectors in case of error or/and lost of synchronization.

· Autodetects an appropriate read function for CD drive.
· Supports WAV, MP3, MP2, OGG or RAW formats of output file.
· Supports Windows ACM (Windows Audio Compression Manager).
· Supports Lame and Blade MP3 encoders (DLLs) and Ogg Vorbis, high-quality and patent-free audio

codec.
· Extracts audio tracks "on-the-fly", directly to the output file without creating an intermediate WAV file.

Hint.
To change default settings (select another encoder, extraction method, etc.) use Audio Extraction tab
in the Preferences dialog.

7.3. Extracting ISO Image File

IS0 Image is a single large file that is a representation of the whole set of data and programs as it will
appear on a CD. A disc image refers to both content and logical format. It can be useful to:
· Replicate your Data CD further using CD mastering programs such as Adaptec Easy CD Creator,

Nero Burning ROM, Goldenhawk CDRWin, etc.
· Write the disc image to hard drive once, then record it several times to different CDs to save

processing time.
· Create a disc image file to be written to CD on another system (UNIX, Macintosh).
· Back up CD data.

To extract ISO Image File:
1. Insert CD-ROM into the drive.
2. After disk recognition select Tools | Extract to ISO Image File option.
3. The program displays a progress dialog similar to the one shown here.
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Note. ISO image file can be created only if the disk with a single data track originally was created using
ISO-9660 or Joliet format. UDF disks, such as those created with DirectCD, Nero InCD and PacketCD,
cannot be copied in this manner.

7.4. Creating Short CD/DVD Image

The Short CD/DVD Image is a file that contains ALL DIRECTORY STRUCTURE (directory tree) of the
disk including complete folders and files names with attributes. This enables you to browse through the
folders, search for the files or/and folders which you need (with the help of Tools | Find option), detect
the prorerties of them using Properties command, but in order to retrieve any file, you should insert a
"real" CD(DVD). When you insert a disc that has the image that has been created before, CDRoller

determines this image as a "mirror" of the real CD(DVD), displays it with an appropriate icon  in
the Main window and further, utilizes image to access to any folder quickly without reading of inserted
CD(DVD). This is an extremely useful if your "real" CD(DVD) has become a disc with unreadable
folder(s)  and, therefore you can not access to its files.

To create Short CD/DVD Image:
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1. Insert CD or DVD into the drive.
2. Select Tools | Short CD/DVD Image option.

You can create the image with CD (DVD) name (label) or manually assign a new name for each
inserted disk. For multisession disk you can create CD/DVD image for each session. All CD(DVD)
images automatically are placed into a separate directory assigned on the CD Library tab in the
Preferences dialog.
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8. Contacting Technical Support.

The goal of the CDRoller Support Team is to provide our users unrivaled technical assistance when
implementing CDRoller technologies. Our commitment to you is very simple. Top-notch support and
immediate solutions to your technical problems. Since we have customers throughout the globe, we
will do our best to respond to requests 24 hours a day. In fact, our support staff works staggered shifts
for just this purpose.

You do not have to purchase the software in order to receive support, all your questions
regarding CDRoller will be responded within 2 to 24 hours.

If you have purchased the product, please include the email address that you used when purchasing
the software - we use this to confirm your purchase status and support requests from customers
receive priority over others.

You can contact our support department via email at: support@cdroller.com. To be notified about new
versions of CDRoller and new products please subscribe to our mailing list at http://www.cdroller.com
or drop the letter to news@cdroller.com with Subscribe command in the Subject field. All questions
regarding orders, licenses or other services should be directed to sales@cdroller.com. If you have any
suggestions or comments regarding CDRoller, we'd like to hear from you. Please feel free to send an
e-mail to suggest@cdroller.com . All suggestions will be at least considered and you will probably see
them as new program's features in the future releases. If you have any problem with our web site at
http://www.cdroller.com, please do not hesitate to contact our webmasterer at
webmaster@cdroller.com.

http://www.cdroller.com
http://www.cdroller.com
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Annex A   Controls and dialog boxes

A.1. Main Window

CDRoller interface is similar to Windows Explorer. The Main Window consists of List Window
(Windows Explorer has Tree Window  and List Window), Status Bar at the bottom, List of available
folders, Toolbars and Main Menu on the top

The List Window displays the disc contents as main folder containing drives, discs, sub-folders, files or
audio tracks. A graphic symbol, or icon associates with every folder, file or audio track. CDRoller
assigns a proprietary icon to each type of CD/DVD media: CDROM, CD-R, CD-RW and all types of

supported DVDs have the icon as , CD-DA (Audio CD) is displayed with  icon, symbol as 
associates with Mixed CD (data plus audio) and empty drive (drive without any disc) has the icon as

 . Short CD/DVD image has appropriate icon as   , and the icon as   is assigned to the
image that is the "mirror" of inserted disc.

To select an item in the List Window click on its icon or name. When needed, you can use the vertical
scroll bar to scroll up and down. You can also use the PageUp and PageDown keys, although the
selection will change. If you want to work with multiple items in a folder, you can select each of them by
holding down the Control (Ctrl) key and then clicking on the ones you want. The total size of selected
files is diplayed by the status bar. To select all items in the current folder you may also use the Edit
options from the Main Menu.

The List Window can be presented in either of four ways (large icons, small icons, icon list and details),
selectable in the Main menu by the View options or with appropriate buttons on the Main Toolbar.
View as Detail mode (most common for CDRoller) consists of columns, each displaying appropriate
type of data.

To adjust a column's width, you may move the mouse pointer to the right border of the column heading
box. The mouse pointer changes to a double-headed horizontal arrow with a vertical bar in the middle.
That means you move the border. Hold down the mouse bottom and drag the border left or right as
needed. When the border is in its preferred location, release the mouse button.
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Every item displayed in the List Window has its own Pop-up menu - if you right-click on it, a menu will
show up by it, displaying all the options available over the selected item.

All buttons on the both Toolbars have a hint - if you don't know what the button does, just place the
mouse over it and wait for a second, and a short description will appear.

CDRoller supports drag-and-drop - meaning that any file and/or folder can be copied to desired
location on HDD or any audio track can be extracted to the output file by drag-and-drop.

A.2. Main Menu Commands

A.2.1. File Menu (shortcut Alt + F)

Command Shortcut Description

New Window Ctrl + Enter Displays CD/DVD contents (folders, data files or
audio tracks) in the new window.

Session - Selects a new session on multisession CD-R/DVD-
R.

Send To Ctrl + S Executes files copying (for data CD or DVD) or
digital audio extraction (for audio CD).

Rescue F9 Runs CD Data Rescue

Properties - Displays properties of the selected object(s).

Close Window Ctrl + F4 Closes the current active window. Terminates the
program  in case of a single window.

Exit Alt + F4 Ends your CDRoller session.

A.2.2. Edit Menu (shortcut : Alt + E)

Command Shortcut Description

Select All Ctrl + A Selects all items (files, sub-folders or audio tracks) in
the current folder.

Deselect All Ctrl + D Unselects all items (files, sub-folders or audio
tracks) in the current folder.

Invert Selection Shift + Ctrl + I By this command selected items will be non-selected
and non-selected items will be selected.

Refresh F5 Causes all discs in all drives to be examined.
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A.2.3. View Menu (shortcut : Alt + V)

Command Shortcut Description

Main ToolbarBar - Shows/Hides Main ToolBar.

Extra ToolBar - Shows/Hides Extra ToolBar.

Status Bar - Shows/Hides Status Bar.

Large Icons - Views the large icons representing the contents of
the CD folder.

Small Icons - Views the small icons representing the contents of
the CD folder.

List - Views the names of the files and sub-folders listed in
the CD folder.

Details - Views the details of the files and sub-folders listed in
the CD folder, including file size and the date last
modified.

Sort By - Controls the sequence or order of the folder contents
by Name, Type, Size, Date or in Reverse Order.

Preferences Ctrl + P Sets up program options.

A.2.4. Tools Menu  (shortcut : Alt + T)

Command Shortcut Description

Find F3 Activates the Search Window to search CD contents
in the inserted CDs and also in the collection of
previously created Data CD/DVD Images.

Short CD/DVD Image Ctrl + I Creates and adds a new Short CD/DVD image to the
library.

Test CD Media Ctrl + T Runs CD Media Test.

Extract To ISO Image
File

Ctrl + E Creates ISO 9660 Image File.

Scan UDF Disc Ctrl + U Runs Scan UDF Disc
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A.2.5. Help Menu  (shortcut : Alt + H)

Command Shortcut Description

Contents F1 Opens the CDRoller online help.

Ordering Information - Displays information about ordering CDRoller.

FAQs - Displays Frequently Asked Questions (FAQs) with
answers about CDRoller.

Technical Support - Displays information about technical assistance.

Home Page - Visits the CDRoller web page.

About CDRoller - Displays copyright notice and enables you to
register.

A.3. The Toolbars

A.3.1. Main ToolBar.

  Back One Level button returns focus to the parent item, usually to the parent folder (opens the
folder of the higher level) that contains current folder.
The next four buttons allow you to select one of the four view modes for the List Window, Windows
Explorer gives the same possibility (View as Large Icons, View as Small Icons, View as List or
View as Details). These buttons duplicate the corresponding options in the View Menu. The default
mode for CDRoller is View as Details (the last button) which gives you the most useful presentation of
your folder data.

A.3.2. Extra ToolBar.

The buttons of Extra ToolBar duplicate the corresponding options in the File, Tools and Help menu.
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A.4. Preferences

A.4.1. Browser

Hardware Access Method (default value is: CDRoller proprietary driver for Windows 9x/ME or
Windows NT native access for Windows NT4/2000/XP)
Detects one of two methods to access hardware. We strongly recommend you using default settings,
and select  ASPI mode only if you have a serious problems with base method.
Note. This option sets the fundamental mode of application operating.To apply new setting you should
restart the program.

Open Folder In: (default value Same Window)
Is a choice between keeping a single window open while changing the folder contents as you click
through the various levels (Same Window mode) and opening a new window every time you double-
click on a folder (New Window mode).

Date Format (default value Short Form)
Sets the Date format used by the program to display the Date information.

Time Format (default value Short Form)
Sets the Time format used by the program to display the Time information.

Treat KByte as: (default value 1024 bytes)
Detects the way of 'kilobyte consideration' as 1024 bytes exactly (in 1024 bytes mode) or as 1000
bytes (in 1000 bytes mode). It may be useful for correct file (folders or audio tracks) size calculation,
before these items will be sent to hard disk.

Search of the lost data track (default value Checked)
If Checked , the program searches the lost data track when a new disc is inserted or after Refresh
command from Edit Menu, and, if found, displays its contents in the List Window.
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Detect CD insertion by Windows (default value Checked)
If Checked the program detects arrival or removal of the CD (DVD) using Windows "standard" tools
(messages). This starts CD recognition automatically, without requirement of the refresh. If the
program can not recognize your disc automatically, try to uncheck this option and repeat examination
of a new disc by selecting Refresh command from Edit Menu.

Read damaged sectors "as is" (default value Unchecked)
If Checked , when reading system area and folders, unreadable sectors will be accepted "as-is".  This
may be useful in some circumstances, but it should be understood that the content of these "accepted"
sectors could be all zero or partially correct data – there is no way to tell. You should use this mode
only if the program can not "recognize" your damaged CD/DVD or you vitally need an access to the
unreadable folder. Please keep in mind that your CD/DVD drive may not support reading of disk sector
"as is" or the content of that sector may be denied by the further checks in compliance with ISO 9660
and UDF requirements.

Read only ISO 9660 data tracks  (default value Unchecked)
If Checked, the program searches and verifies only ISO system area on data tracks after insertion of
new CD. Discs with another file system, such as UDF, require additional recovery procedures that may
take a some time, especially while reading multisession CDs. If you are sure that your CD is really
recorded only in ISO 9660 format, you should uncheck this option to accelerate CD recognition.
Obviously, to read the discs with UDF file system, this option has to be checked.

Always use CD drive capabilities  (default value Checked)
If Checked, when reading the damaged sectors, the program will apply some low-level methods and
algorithms based on the capabilities of your CD (DVD) drive. In some circumstances the drive can slow
the process of CD reading when meeting a bad zones (unreadable sectors). In this case we
recommend you to uncheck this option.

Display deleted files and folders (default value Checked)
If Checked, the program displays files and folders having deleted characteristics on CD-RW/DVD-RW
disks with UDF system. The objects are shown with special Inaccessible file icon in the List Window.
You can try to recover them with the help of Scan UDF Disc command from Tools Menu.

Apply MRW reader (default value Unchecked)
If Checked, the program automatically recognizes CD-RW disk formatted in the " Mt.Rainier" CD-RW
format (CD-MRW) placed into non-Mt.Rainier drive, and presents the data portion of the disk as a
"read only" UDF format disk. We also recommend you use this to read the disk inserted into CD-MRW
drive if your MRW disk was not ejected (closed by cd mastering program). For example, if the writing
process was interrupted by a system or power failure.
Hint. To check the drive capabilities, use Properties command applied to the "empty" drive in the List
window and select Features tab in the Properties dialog.

Program to perform "Play" command (default value Windows Default)
Assigns the utility that  will be used by 'Play' command in the pop-up menu. In the default (Windows
Default) mode CDRoller uses 'Standard' Windows CDPlayer. Appropriate program can be selected as
it was mentioned above to assign the utility to perform 'Explore' command.

http://www.mt-rainier.org
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A.4.2. UDF Reader

Lost objects (default value Files and folders)
Determines what objects (files and/or folders ) will be looked for by Scan UDF Disc.

Forced scan (default value Don't apply)
If the selected setting is different from the default value, the program will force the drive to scan your
CD/DVD in order to find the lost files without using the data of system area. We highly recommend you
to use this only if the inserted disk has not been recognized by CDRoller before, and you are also sure
the disk contains the files. This may be useful if the disk was incorrectly finalized and system area was
not written properly. For example, this problem often occures on Sony Mavica CD when the finalization
step failed on the camera.
If you actually know the name of CD/DVD mastering program (or device) that formatted your disk, try
to select an appropriate value from the list of the following profiles:
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Value Description

Sony Mavica CD The disk was mastered by Sony Mavica CD digital camera

DirectCD CD-R CD-R was formatted by Roxio (Adaptec) DirectCD

DirectCD-RW74 CD-RW 74 min was formatted by Roxio (Adaptec) DirectCD

DirectCD-RW80 CD-RW 80 min was formatted by Roxio (Adaptec) DirectCD

InCD3     -RW74 CD-RW 74 min was formatted by Nero InCD v.3

InCD3     -RW80 CD-RW 80 min was formatted by Nero InCD v.3

PacketCD-R CD-R was formatted by CEQUADRAT PacketCD

DirectCD-MRW CD-MRW ("Mt. Rainier" CD-RW) was formatted by DirectCD

InCD3     -MRW CD-MRW ("Mt. Rainier" CD-RW) was formatted by Nero InCD v.3

PacketCD-RW CD-RW was formatted by CEQUADRAT PacketCD

InstWrite CD-RW CD-RW was formatted by VOB InstantWrite

InCD4     -RW80 CD-RW 80 min was formatted by Nero InCD v.4

InCD4  -DVD-RW DVD-RW was formatted by Nero InCD v.4

InCD4  -DVD+RW DVD+RW was formatted by Nero InCD v.4

InCD4  -MRW CD-MRW ("Mt. Rainier" CD-RW) was formatted by Nero InCD v.4

DragTo CD-RW CD-RW was formatted by Roxio Drag-To-Disc

DragTo CD-MRW CD-MRW ("Mt. Rainier" CD-RW) was formatted by Roxio Drag-To-

DragTo DVD-RW DVD-RW was formatted by Roxio Drag-To-Disc

DragTo DVD+RW DVD+RW was formatted by Roxio Drag-To-Disc

DragTo DVD-R DVD-R was formatted by Roxio Drag-To-Disc

DragTo DVD+R DVD+R was formatted by Roxio Drag-To-Disc

LiteOn DVD+R DVD+R was mastering by LiteOn DVD recorder

LiteOn DVD+R (O) DVD+R is still open (non-finalized) by LiteOn DVD recorder

Hitachi DVD-R (F) DVD-R was created and finalized by Hitachi DVD camcorder

Hitachi DVD-R (O) DVD-R is still open (non-finalized) by Hitachi DVD camcorder

Hitachi DVD-RAM DVD-RAM was mastering by Hitachi DVD camcorder

Rec DVD+RW (F) DVD+RW was created and finalized by standalone DVD Recorder
(Thomson RCA, Philips, etc.)

Rec DVD+RW (O) DVD+RW is still open (non-finalized) by standalone DVD
Recorder (Thomson RCA, Philips, etc.)

Rec DVD-RAM DVD-RAM disc was mastering by standalone DVD recorder

Rec DVD-RAM (E) DVD-RAM disc was quick-erased by standalone recorder (e.g
Panasonic DVD-RAM recorder)

Warning. Please use the forced scan at your own risk. There is no 100% guarantee to retrieve all files

http://www.mt-rainier.org
http://www.mt-rainier.org
http://www.mt-rainier.org
http://www.mt-rainier.org
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from all disks in all cases. Please keep in mind, that some files may be incorrectly written, erased or
partially re-written by a new ones.

Unpack files after forced scan (default value Unchecked)
If Checked, the program will try to decode the files found by the forced scan on the disks compressed
by Roxio (Adaptec) DirectCD . The found files can be recovered with the help of Send To , drag &
drop or Rescue options in the "Lost objects detected..." window.
Hint. AIDEX RunTime decoder (aidex.dll) must be assigned in the Path to external decoder (DLL) to
unpack compressed files.

Load Table Of Contents from file (default value Unchecked)
If Checked, you are prompted to select a file with the table of contents of the objects found by Scan
UDF Disc before, instead of new scan of your disk physically.

Always try to identify file type (default value Checked)
If Checked, the program will try to identify the types of found files at the scan stage (preliminary
identification). On some discs and drives this may slow the scan process.

Apply DVD Reader (default value Checked)
If Checked, the program will try to recognize and verify DVD disk automatically. However, in some
circumstances, for example when the disk is extremely corrupted, it is more useful to present DVD disk
as a "read only" UDF format CD. If Unchecked, only CD identification methods will be applied.

Search of all VATs (default value Unhecked)
Virtual Allocation Table (VAT) is an important part of the UDF File System. VAT's location is crucial for
CD-R/DVD-R/DVD+R disks created with the help of drag & drop software, such as well-known Roxio
(Adaptec) DirectCD and Drag-To-Disc. If the VAT can not be found or is corrupted, files will be
missing.

If the option is Checked, the program will try to search all VATs. This may give you a chance to find
and recover the files from the previous backups, including the files accidently deleted by drag & drop
software. If some old VATs are found, the program displayes their files and folders in a separate
sessions. Further, all sessions can be viewed by the built-in Session Selector.

Always check file integrity (default value Checked)
When Checked  the program always test the file before decompression, using the data of file header. If
an important file data seem to not be recovered, try to uncheck this option. Please keep in mind that
you may get an unpredictable results, so try this only at your own risk.

Path to external decoder (DLL) to unpack compressed files (default value None)
Assigns an external decoder (DLL) for "on-the-fly" decoding the files compressed by Roxio (Adaptec)
DirectCD directly to the destination file when selecting Send To, Open, Rescue or drag&drop
operations. AIDEX RunTime decoder (DLL) (c) 2003 AIDEX Team is tested and highly
recommended.

Note. There is no 100% guarantee to unpack all compressed files on all disks, please keep in mind,
that some files may be partially erased or incorrectly packed. Our tests indicate that more than 80% of
files are successfully decompressed.
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A.4.3. ISO Reader

Read Path Table (default value Big Endian (Motorola)
By default, the program does use the Path Table because this is the most fast method to access the
directories on your ISO 9660 CD. CDRoller uses the Big Endian addresses by default, because
Windows doesn't use them, so CDRoller offers an alternative method at once, if your CD is not visible
by Windows. However, for a particular disc, if the default settings doesn't work properly, you can try
another settings. For example, if the Path Table seems to be invalid, you can select Don't use path
table. This will force CDRoller to start from the Root directory and scan all directories on the CD.

Apply forced scan if Path Table is invalid (default value Checked)
If Checked, the program will automatically scan the directories in case of inaccessible Path Table.

Ignore Joliet file system (use only ISO 9660) (default value Unchecked)
If Checked, any Joliet directory information on the disc will be ignored and only the ISO-9660 directory
will be displayed. This may be useful if the Joliet directory information is corrupted and the CD files
seem to be inaccessible. With the help of ISO-9660 directories you can try to access the files data,
bypassing the Joliet file system.
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A.4.4. CD Library

Apply To CD/DVD Images, group of options :
  - "Open" (default value Checked);
  - "Send" (default value Checked);
When Checked  the program tries to perform appropriate command for CD(DVD) image. If there is no
disk inserted  into CD/DVD drive, the program prompts you to insert the disk to perform Files Open
and Files Copying.

File Name (default value by Volume Name)
The File Name can be created either by choosing the Disk Volume Name (by Volume Name mode) or
summarizing the word 'CDIM' with four random digits (Random mode) or inputting CD(DVD) Image file
name manually (Manual mode).

When a new disc is inserted (default value Unhecked)
When Checked  the program creates CD/DVD Image for a newly inserted disc.

Directory for CD/DVD Images (program directory path by default)
Assigns the directory on your HDD to store created CD/DVD Images.

Directory for Temporary Storage (default value Windows Temporary Directory)
Assigns the directory on your HDD to be used as Temporary Storage for drag-and-drop and Files
Open.
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A.4.5. Audio Extraction

DAE Method (default value Dynamic Sync Width)
By the Dynamic Sync Width method the program tries to synchronize new audio data with the
previously read block of audio sectors by changing the overlap area between two consecutive read
blocks. Fixed Sync Width  means that a set amount of frames is used for blocks synchronization.
Read error detection and lost synchronization control also occure in both methods. The audio
extraction by Burst Copying method is the fastest. Burst copy doesn't use any synchronization and
error recovering.

Read Command (default value AUTODETECT)
If AUTODETECT (recommended setting) option has been selected, the program tries itself to find an
appropriate read algorithm for user's CD drive.
SCSI READ CD function is the base command recommended by SCSI-3 Standard for reading audio
frames. It is supported by all ATAPI drives that have DAE feature, and some SCSI devices.
SCSI READ (10) function may be used for DAE on SCSI drives support SCSI-2 Standard.
Note. The list of audio read commands used by program in AUTODETECT  mode is not limited by two
ones mentioned above. Some known read functions are absent in the selection list because a wrong
chosen extraction command may cause problems on some SCSI systems.

Swap Channels (default value Unchecked)
When checked, the program itself will exchange left and right channels in the audio samples before
writing them into output file. This may be suitable for some CD drives to exchange stereo channels
while extraction.
"Big Endian" (default value Unchecked)
Motorola " Big Endian" mode is often used on drives from Grundig, IMS, Kodak, Ricoh and some
others.
WARNING. Check this option only if the extracted output file seems to consist of noise!

Wave Format (default value 44,100 Hz; 16 Bit; Stereo)
Indicates a brief description of audio compression format that has been selected.
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Select Encoder (default value Internal WAV)
Assigns an appropriate encoder from the list of available ones.

File extension (default value .wav)
Indicates the extension of output file (.wav, .mp3 or .raw).

Options
Activates an options dialog box to select audio compression format.

High Quality (default value Unchecked)
For some audio compression formats, specifying this flag might improve the audio quality or other
characteristics.

A.4.6. CD Media Test

File System Test group.
Show the details of "import" file (default value Checked)
For multisession discs only. This option indicates whether or not report window contains a line for each
file which is found in a prior session or if counts of the files linked to in prior sessions is sufficient. The
default is to display only the counts of linked files from each session.
Include to CD Media Test (default value Checked)
When Checked  File System Test will be included to the list of available tests.
Check on the Data CD (default value All available sessions)
If All available sessions option has been selected the program checks file systems of all sessions on
multisession CD. In case of Selected session only the selected session is examined.
Note. There is no difference between these two settings for single session disc.

Disc Surface Test group.
Scan ratio Track Bar (default position 20 to 2000 sectors )
Sets the current ratio of read sectors to total sectors in the block. For example, "20 to 2000 sectors"
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setting means that the program reads 20 sectors in the block of 2000 sectors and therefore, then skips
(2000 - 20) sectors before the next reading. This setting is used for Data CD Surface test and also for
DAE Quality test.
Include to CD Media Test (default value Checked)
When Checked  Disc Surface Test is included to the list of available tests. For mixed CDs it means that
as Data CD Surface test as DAE Quality test will be included to the list of available tests.
Check on the Data CD (default value All available sessions)
If All available sessions option has been selected the program scans disc surface on all sessions. In
case of Selected session only the selected session is examined on multisession CD.
Note. There is no difference between these two settings for single session disc.
Audio Read Overlap (default and minimum values are 0, maximum value is 7)
Sets the number of overlapping sectors for DAE Quality test. This may be useful to determine the
value of overlap for so-called "jitter correction" while reading CD audio data.

A.4.7. CD Data Rescue

Rescue (default value Files and Folders)
Determines what objects will be recovered.

Include subfolders (default value Unchecked)
Check it if you wish to rescue not only contents of the folder you have chosen, but also its subfolders.
This option is disabled if Rescue is set to Files only.

Overread (default value Not used)
If you assign Accept sector "as is" or Fill sector by zeroes values, the recovery of the disk data will be
processed in so-called "Overread" mode. This allows to maintain an internal file structure. If Accept
sector "as is" is selected, all sectors in error will be accepted as-is. This may be useful in some
circumstances, but it should be understood that the content of these "accepted" sectors could be all
zero, partially correct data or random garbage - there is no way to tell. If Fill sector by zeroes is
assigned, the program will ignore unreadable sectors replacing the damaged data with zeroes.
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Notes.
1. Use Accept sector "as is" and Fill sector by zeroes values only if all your attempts to recover
CD/DVD data with the help of Not used setting have been failured.
2.The functionality of the recovered file will depend on the number and importance of the damaged
sectors.

Recover ... % of the file size (default value 100)
Limits the size of the file for recovery. This may be useful for the recovery of the first part of extremely
damaged file.

Retry
Sets the number of retries that the program will try again to recover data after an error has occured.

Force
Detects the level of utilizing the internal CD/DVD drive capabilities for error recovering.

Jump
Sets the length of "jump running" while reading a bad sector. It may be a pretty useful in working with
some old CD drives.

Speed
Controls the maximum CD read speed.
Note. The program controls the maximum CD read speed for CD drives that support 'Set CD Speed'
command listed in SCSI-3 MMC2 standard.
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Annex B  License Agreement

CDRoller - PRODUCT LICENSE INFORMATION

YOU SHOULD CAREFULLY READ THE FOLLOWING LEGAL AGREEMENT. USE OF THE
SOFTWARE PROVIDED WITH THIS AGREEMENT (THE "SOFTWARE") CONSTITUTES YOUR
ACCEPTANCE OF THESE TERMS. IF YOU DO NOT AGREE TO THE TERMS OF THIS
AGREEMENT, DO NOT INSTALL AND/OR USE THIS SOFTWARE. USER'S USE OF THIS
SOFTWARE IS CONDITIONED UPON COMPLIANCE BY USER WITH THE TERMS OF THIS
AGREEMENT.

1. LICENSE GRANT.
CDRoller Soft Co. Ltd. grants you a license to use one copy of the version of this SOFTWARE on any
one hardware product for as many licenses as you purchase. "You" means the company, entity or
individual whose funds are used to pay the license fee. "Use" means storing, loading, installing,
executing or displaying the SOFTWARE. You may not modify the SOFTWARE or disable any licensing
or control features of the SOFTWARE except as an intended part of the SOFTWARE's programming
features. When you first obtain a copy of the SOFTWARE, you are granted an evaluation period of not
more than 14 days, after which time you must pay for the SOFTWARE according to the terms and
prices discussed in the SOFTWARE's documentation, or you must remove the SOFTWARE from your
computer. This license is not transferable to any other hardware product or other company, entity, or
individual.

2. OWNERSHIP.
The SOFTWARE is owned and copyrighted by CDRoller Soft Co. Ltd. Your license confers no title or
ownership in the SOFTWARE and should not be construed as a sale of any right in the SOFTWARE.

3. COPYRIGHT.
The SOFTWARE is protected by United States copyright law and international treaty provisions. You
acknowledge that no title to the intellectual property in the SOFTWARE is transferred to you. You
further acknowledge that title and full ownership rights to the SOFTWARE will remain the exclusive
property of CDRoller Soft Co. Ltd. and you will not acquire any rights to the SOFTWARE except as
expressly set forth in this license. You agree that any copies of the SOFTWARE will contain the same
proprietary notices which appear on and in the SOFTWARE.

4. UNAUTHORIZED USE.
You may not use, copy, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer,
or transfer the SOFTWARE except as provided in this agreement. Any such unauthorized use shall
result in immediate and automatic termination of this license.

5. DISTRIBUTION.
Permission to distribute the SOFTWARE is not transferable, assignable, saleable, or franchisable.
Each entity wishing to distribute the package must independently satisfy the terms of the distribution
license. All distribution of SOFTWARE is further restricted with regard to sources which also distribute
virus source code and related virus construction/creation materials. The SOFTWARE may not be
made available on any site, CD-ROM, or with any package which makes available or contains viruses,
virus source code, virus construction programs, or virus creation material.

6. WARRANTY.
THIS SOFTWARE IS PROVIDED ON AN "AS IS" BASIS. CDROLLER SOFT CO. LTD. DISCLAIMS
ALL WARRANTIES RELATING TO THIS SOFTWARE, WHETHER EXPRESSED OR IMPLIED,
INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. NEITHER CDROLLER SOFT CO. LTD. NOR ANYONE
ELSE WHO HAS BEEN INVOLVED IN THE CREATION, PRODUCTION, OR DELIVERY OF THIS
SOFTWARE SHALL BE LIABLE FOR ANY INDIRECT, CONSEQUENTIAL, OR INCIDENTAL
DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE SUCH SOFTWARE, EVEN IF
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CDROLLER SOFT CO. LTD. HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES OR
CLAIMS. THE PERSON USING THE SOFTWARE BEARS ALL RISK AS TO THE QUALITY AND
PERFORMANCE OF THE SOFTWARE. SOME JURISDICTIONS DO NOT ALLOW LIMITATION OR
EXCLUSION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATIONS
OR EXCLUSION MAY NOT APPLY TO YOU TO THE EXTENT THAT LIABILITY IS BY LAW
INCAPABLE OF EXCLUSION OR RESTRICTION.IN NO EVENT SHALL ANY THEORY OF LIABILITY
EXCEED THE LICENSE FEE PAID TO CDROLLER SOFT CO. LTD.

7. SEVERABILITY.
In the event of invalidity of any provision of this license, the parties agree that such invalidity shall not
affect the validity of the remaining portions of this license.

8. LIABILITY.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. IN NO EVENT SHALL CDROLLER SOFT CO.
LTD. OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, SPECIAL,
INCIDENTAL OR INDIRECT DAMAGES OF ANY KIND ARISING OUT OF THE DELIVERY,
PERFORMANCE OR USE OF THE SOFTWARE, EVEN IF CDROLLER SOFT CO. LTD. HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL CDROLLER SOFT CO.
LTD.'S LIABILITY FOR ANY CLAIM, WHETHER IN CONTRACT, TORT OR ANY OTHER THEORY
OF LIABILITY, EXCEED THE LICENSE FEE PAID BY YOU,IF ANY.

9. INSPECTION AND TESTING.
You agree and acknowledge that you will thoroughly inspect and test the SOFTWARE for all of your
purposes upon commencement of your use. Any suit or other legal action, claim or any arbitration
relating in any way to this agreement or software covered by it must be officially filed or officially
commenced no later than Three months (90 days) after your first use of the software.

10. ENTIRE AGREEMENT.
This is the entire agreement between you and CDRoller Soft Co. Ltd. which supersedes any prior
agreement or understanding, whether written or oral, relating to the subject matter of this license.

11. RESERVED RIGHTS. All rights not expressly granted here are reserved to CDRoller Soft Co. Ltd.
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