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Эмуляторы CD-привода, о кото-

рых пойдет сегодня речь, позво-

ляют работать с компакт-диска-

ми на максимальной скорости, запус-

кая их прямо с винчестера. Более того,

благодаря виртуальным приводам вы

сможете воспользоваться нужным ком-

пакт-диском, даже если он сам и/или

физическое устройство CD-ROM по

какой-то причине вышли из строя. Для

этого вам понадобится совсем немно-

гое: заранее заготовленный образ тре-

буемого диска и подходящая програм-

ма-эмулятор. 

Однако не все утилиты этого класса

одинаково подходящи и удобны для

широкого круга пользователей. В этом

классе существуют как мощные, но при

этом достаточно дорогие программы,

так и небольшие, но зато бесплатные. 

Все представленные ниже эмуляторы

тестировались на одной машине после-

довательно, один за другим. При под-

ведении итогов учитывались прежде

всего функциональные возможности

программ, количество формируемых в

них виртуальных дисководов, а также

стоимость и системные требования. Не »

Э м у л я т о р ы  C D

Компьютер — это динамичная и чрезвычайно гибкая система,
поскольку ее можно до известных пределов «разогнать», а ряд
отсутствующих компонентов эмулировать. Существует целый
класс программ-эмуляторов. Они позволяют превращать PC в
игровую приставку; запускать в одной операционной системе
приложения, созданные для другой; скрывать технологические
недостатки устаревшего оборудования и т. д.
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забыты, естественно, и такие важные

факторы, как удобство работы и на-

глядность интерфейса.

Fantom CD
Еще только приступая к тестированию

CD-эмуляторов, я уже догадывался о

том, какая программа окажется в числе

лучших. По описанию фаворитом

должна была стать утилита тайваньско-

го происхождения Fantom CD. Надо

сказать, в целом я не ошибся в своих

ожиданиях. Программа умеет эмулиро-

вать не только привычные CD-ROM,

но еще и DVD-ROM. 

Кому может понадобиться виртуаль-

ный DVD-ROM в настоящее время —

сказать трудно. Возможно, тайваньские

разработчики добавили эту опцию с

прицелом на будущее. Пока же для нас

куда актуальнее другие ее свойства —

функции записи («Image Burning Wiza-

rd»), копирования («Copy Wizard») и

очистки дисков («CD/DVD Erase Wiza-

rd»). Чтобы прожечь болванку с помо-

щью Fantom CD, пользователю доста-

точно указать путь к файлу образа.

Fantom CD также позволяет созда-

вать образы директорий и отдельных

файлов. Для этого следует воспользо-

ваться меню «CD Premastering» («File -

> Build personal image files»). В этом

окошке перетащите мышкой нужные

файлы и папки в поле «MyDisc» и жми-

те «Start». Перед созданием непосред-

ственно самого файла образа можно за-

дать параметры записи будущего диска.

Сделать его, например, загрузочным.

Если же вы задумаете перебросить на

винчестер весь CD-ROM без остатка,

воспользуйтесь мастером «Image Ma-

king Wizard». С его помощью можно

создать образ требуемого диска бук-

вально в считанные минуты. Время об-

работки зависит в основном от скоро-

сти чтения конкретного CD-привода.

Fantom CD позволяет эмулировать не

только обычные компакт-диски, но и

защищенные с использованием раз-

личных технологий (LaserLock, Secu-

rom, SafeDisc и т. п.), оставляя на сове-

сти пользователя возможное наруше-

ние авторских прав. 

Подготовленный образ диска перед

началом работы необходимо активизи-

ровать в виртуальном дисководе с по-

мощью мастера Image Finder Wizard, а

затем в главном окне программы клик-

нуть два раза мышью по его имени. Он

появится в новом «устройстве» вашей

системы — Copystar Fantom DVD-ROM.

Всего таких виртуальных дисководов

разрешается задать в опциях до 31. 

Virtual CD
Если Fantom CD — самая мощная про-

грамма в классе CD-эмуляторов, то Vir-

tual CD — самая популярная среди них.

Успех продукту фирмы H+H Software

обеспечили прежде всего функция сжа-

тия файлов образа и возможность рабо-

ты эмулятора с виртуальными дисками в

локальной сети. Перейдя в сетевой ре-

жим («Edit -> Network mode»), вы смо-

жете работать с образами дисков, нахо-

дящимися на удаленных машинах. На

всех — «Normal»; или только на избран-

ных — «Central». Во втором случае необ-

ходимо задать пароль доступа.

С помощью сетевого режима нетруд-

но создать десяток-другой виртуальных

компактов, файлы образов которых бу-

дут находиться не у вас, а на винчесте-

ре соседей или коллег по работе. 

Место на винчестере можно сущест-

венно сэкономить, задав в опциях («Vi-

ew -> Virtual CD settings») компрессию

образов. Ее максимальный третий уро-

вень позволяет в отдельных случаях

уменьшить объем файла образа в пол-

тора раза. Однако я бы не советовал из-

лишне увлекаться компрессией, по-

скольку сжатый таким образом вирту-

альный диск работает медленнее и к то-

му же с ошибками на слабых машинах. 

Вообще, при недостатке системных

ресурсов (а одной памяти требуется

128 Мбайт) Virtual CD то и дело на мо-

ей машине тормозил, в основном поче-

му-то при запуске входящих в его со-

став утилит из системного трея. Поэто-

му я старался открывать их непосредст-

венно из главного окна программы —

«CD Management».

Одна из таких утилит, редактор обра-

зов («Edit -> Editor»), дает возможность

пользователю сделать отпечаток от-

дельных директорий и файлов. Как и в

аналогичном сервисе Fantom CD, их

нужно всего лишь перетащить мышкой

в окошко редактора, а после этого на-

жать кнопку «Create». 

Активизировать созданный образ в

виртуальном дисководе можно, ис-

пользуя системный трей. Для этого

щелкните правой кнопкой мыши по

значку Virtual CD в нем и выберите в

меню пункт «Insert». Или Eject, когда

надумаете отключить его. Файлы обра-

зов могут быть как родных для Virtual

CD форматов (VC4 и FCD), так и стан-

дартного ISO. Общее число виртуаль-

ных дисководов не может превы-

шать 22. Монтируются они в редакторе

дисков («Edit -> Change Drives»).

Farstone VirtualDrive 
В ряду многочисленных достоинств про-

граммы Farstone VirtualDrive функция за-

писи и копирования дисков не значится.

Но она, в принципе, не очень-то ей и

нужна, ведь с этой задачей прекрасно
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справляются другие специализирован-

ные утилиты. В персональной версии

VirtualDrive не предусмотрена также под-

держка локальной сети. Но ее в любую

секунду можно организовать самостоя-

тельно, всего лишь открыв доступ к фай-

лам образа дисков на удаленных ком-

пьютерах. Можно, наконец, воспользо-

ваться сетевой версией эмулятора. 

В общем, программа компании Fars-

tone, в отличие от других коммерческих

продуктов, сосредоточена на решении

одной главной задачи — эмуляции CD-

ROM. Только вот, к сожалению, ком-

пактнее от этого VirtualDrive не стала.

Ее дистрибутив почему-то оказался в

несколько раз больше конкурирующих

систем, а потому и процесс инсталля-

ции изрядно затянулся. 

Доступ к основным функциям возмо-

жен в этой программе либо из окна

«VirtualDrive Manager», либо с помо-

щью ярлыка в трее. Как и вышеупомя-

нутые программы, данный эмулятор

способен создавать файлы образа как

целого диска («File -> Build»), так и от-

дельных его частей («File -> Customi-

zed»). В первом случае вам ничего не

придется подсказывать программе, при

том условии, конечно, что в системе

имеется всего один CD-дисковод. Тог-

да VirtualDrive сразу же обнаружит и

проанализирует вставленный в него

диск. Во втором случае необходимо бу-

дет переместить в окно «Creator» нуж-

ные папки и файлы. 

Всего VirtualDrive позволяет создать

22 виртуальных дисковода. Точное их

число вы можете указать в специаль-

ном меню («View -> Drives»). 

Особой гордостью разработчиков яв-

ляется встроенная утилита настройки

кэша CD-приводов «Rapid Cache Ma-

nager» («File -> Rapid Cache»), позволя-

ющая ускорить и без того реактивные

виртуальные дисководы, а заодно и

обычные физические. Для получения

максимального результата желательно

задать для них расширенный уровень

«Incremental Caching». Похоже, что

именно этот режим дает некоторое ос-

нование Farstone называть свои вирту-

альные CD-приводы более чем 200-

скоростными. Кроме всего прочего,

Cache Manager представляет разверну-

тую информацию обо всех имеющихся

в системе дисководах («CD Drive Infor-

mation») и находящихся в них реальных

или виртуальных дисках («CD-ROM

Properties»).

Daemon Tools 
Самая маленькая и единственная бес-

платная среди рассматриваемых про-

грамм (Daemon Tools) не имеет своей

собственной оболочки. Все ее свойства

доступны пользователю только из ме-

ню, открываемого щелчком правой

кнопкой мыши по значку программы в

трее. В его разделе «Virtual CD/DVD-

ROM» осуществляется непосредственно

сам процесс подключения/отключения

выбранного пользователем файла обра-

за в одном из виртуальных дисководов.

Кстати, создать подобных CD-приводов

в этой программе разрешается не более

четырех. Daemon Tools без дополнитель-

ных условий поддерживает наиболее

распространенные форматы. 

К сожалению, утилита не умеет сами

образы снимать с СD, и пользователю

придется прибегать к услугам дополни-

тельных утилит. В том числе, если нуж-

но будет сделать резервную копию за-

щищенного диска на винчестере.

Именно на их корректном распознава-

нии и воспроизведении и специализи-

руется Daemon Tools. Она поддержива-

ет самые известные из ныне существу-

ющих технологий защиты дисков (Safe-

disc, Securom, Laserlock, RMPS) — все

они представлены в разделе «Emulati-

on». Можно выбрать любую из них или

все сразу. При этом разработчики Dae-
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CD Manipulator

Манипулируем образами
Прекрасным дополнением для Daemon

Tools может стать бесплатная утилита для

записи дисков CD Manipulator (www.sto-

reroom.info/cdm). Выбрав в ее основном

окне раздел «Read from CD to image file»,

вы сможете создать файл образа любого

компакта. Для снятия отдельных треков

предусмотрен пункт «Read Tracks from

CD». Если же вы хотите эмулировать

только отдельные файлы и папки или за-

писать абсолютно новый диск — кликни-

те по кнопке «Mastering CD and image

file». В открывшееся окошко перетащите

все, что считаете нужным, а затем щелк-

ните либо по кнопке «Create Image», ес-

ли вам необходимо создать файл образа,

либо по кнопке «Write to CD», если реши-

те сразу записать выбранное на болван-

ку. В первом случае вас попросят указать

место для CUE-файла.

Возможности чтения и записи дисков в CD

Manipulator можно значительно расши-

рить, поставив галочку напротив пункта

«Extended Settings». В числе этих допол-

нительных опций вы найдете анализатор

битых секторов при чтении («Intelligence

Bad sector Scanner») и средство противо-

действия переполнению буфера при запи-

си («Buffer-Underrun Protection»).

С помощью CD Manipulator можно не толь-

ко записывать новые диски, но и копиро-

вать ранее созданные. Для этого предус-

мотрен специальный раздел Duplicate CD.

Желающие смогут скачать CD Manipulator

по адресу: www.storeroom.info/cdm/

bin/cdm264.zip (233 Кбайт). 
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mon Tools особо оговаривают, что все

эти хитрости предназначены исключи-

тельно для легально приобретенных

дисков. 

Отсутствие оболочки в Daemon Tools

с лихвой компенсируется сторонними

разработками, лучшей из которых, на

мой взгляд, является программа Dae-

mount (www.aldostools.com), не только

упрощающая доступ к основным функ-

циям эмулятора, но и заметно их рас-

ширяющая. Например, благодаря ей в

виртуальные CD-ROM можно будет

подключать файлы образа формата

NRG, созданные в популярной про-

грамме Nero Burning Rom. 

Alcohol 120% 
Пробую на крепость Alcohol 120% и с

удивлением замечаю в нем знакомые

черты. Ба, да это настоящий близнец

эмулятора Fantom CD! Оформление,

конечно, не во всех деталях у них совпа-

дает, но вот принцип работы абсолютно

одинаковый. В обеих программах мы

видим один и тот же набор мастеров,

облегчающих решение стоящих перед

пользователем задач. Утилита «Поиск

образов» у обоих эмуляторов вообще

различается только значками. Alcohol

120% поддерживает по умолчанию те же

самые форматы файлов образа, что и

Fantom CD. И виртуальных дисководов

может быть создано столько же — 31.

Обе программы способны эмулировать

защищенные диски. 

Что касается принципиальных отли-

чий, то они тоже имеются. Прежде все-

го, в Alcohol 120% пользователь не мо-

жет самостоятельно сконструировать

образ диска из произвольных файлов и

директорий, только из всего компакта

сразу. С другой стороны, дистрибутив

этого эмулятора почти втрое меньше,

чем у Fantom CD, и список поддержи-

ваемых форматов в нем можно попол-

нить собственными, придуманными на

досуге расширениями. 

èÎÓ‰˚ ˝ÏÛÎflˆËË
Каждая из представленных в обзоре

программ имеет свои плюсы и может

претендовать на звание лучшего про-

дукта. На мой взгляд, эмулятор Fantom

CD обладает наибольшей функцио-

нальностью среди всех рассмотренных.

Но тот же Alcohol 120% уступает ему —

при значительно меньшем дистрибути-

ве — совсем немного. Virtual CD позво-

ляет выбирать уровень компрессии для

создаваемых образов, а VirtualDrive

умеет автоматически сжимать их и ус-

корять работу CD-дисководов за счет

эксклюзивной настройки кэша.

Оптимальным же выбором для боль-

шинства домашних пользователей бе-

зусловно окажется Daemon Tools, даже

несмотря на то, что с ее помощью нель-

зя создавать образы дисков. 

Что касается юридических основ ра-

боты с CD-эмуляторами, то они, по-

моему, вполне укладываются в рамки

статьи 15 Закона РФ «О правовой охра-

не программ для электронных вычис-

лительных машин и баз данных», даю-

щей пользователям право «изготавли-

вать или поручать изготовление копии

программы для ЭВМ или базы данных,

при условии, что эта копия программы

предназначена только для архивных це-

лей и при необходимости (в случае, ког-

да оригинал программы для ЭВМ или

базы данных утерян, уничтожен или

стал непригодным для использования)

для замены правомерно приобретенно-

го экземпляра». Причем «без согласия

правообладателя и без выплаты ему до-

полнительного вознаграждения».  

Александр Евдокимов
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1 Alcohol 120% — Ì‡Á‚‡ÌËÂ „Ó‚ÓËÚ
Ò‡ÏÓ Á‡ ÒÂ·fl

1 àÌÚÂÙÂÈÒ CD Manipulator ÛÔÓ-
˘ÂÌ ‰Ó ÔÂ‰ÂÎ‡

èÓ„‡ÏÏ˚

»

Virtual CD 4.5

+ Ì‡ÎË˜ËÂ ÒÂÚÂ‚ÓÈ ‚ÂÒËË

+ ÙÛÌÍˆËfl ÒÊËÏ‡ÌËfl Ù‡ÈÎÓ‚ Ó·‡Á‡

+ ÒÓÁ‰‡ÌËÂ Ó·‡ÁÓ‚ ËÁ ÓÚ‰ÂÎ¸Ì˚ı

‰ËÂÍÚÓËÈ Ë Ù‡ÈÎÓ‚

– ‚˚ÒÓÍËÂ ÒËÒÚÂÏÌ˚Â ÚÂ·Ó‚‡ÌËfl

ê‡Á‡·ÓÚ˜ËÍ 3 H+H Software Gmbh

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.virtualcd-online.com

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 shareware

ñÂÌ‡ 3 $39,95

é·˙ÂÏ ‰ËÒÚË·ÛÚË‚‡ 3 8,5 å·‡ÈÚ

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

Farstone VirtualDrive 7.0.3

Personal Edition

+ ÓÔÚËÏËÁ‡ˆËfl Í˝¯‡ ‰ËÒÍÓ‚Ó‰Ó‚

+ ÒÓÁ‰‡ÌËÂ Ó·‡ÁÓ‚ ËÁ ÓÚ‰ÂÎ¸Ì˚ı

‰ËÂÍÚÓËÈ Ë Ù‡ÈÎÓ‚

+ Ù‡ÈÎ˚ Ó·‡Á‡ ÏÓÊÌÓ ÍÓÌ‚ÂÚËÓ‚‡Ú¸

+ ‡‚ÚÓÏ‡ÚË˜ÂÒÍÓÂ ÒÊ‡ÚËÂ Ó·‡ÁÓ‚

– Ó˜ÂÌ¸ ·ÓÎ¸¯ÓÈ Ó·˙ÂÏ ‰ËÒÚË·ÛÚË‚‡

ê‡Á‡·ÓÚ˜ËÍ 3 FarStone Technology Inc.

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.farstone.com

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 shareware

ñÂÌ‡ 3 $39,95

é·˙ÂÏ ‰ËÒÚË·ÛÚË‚‡ 3 20,5 å·‡ÈÚ

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

Daemon Tools 3.29

+ Ï‡ÎÂÌ¸ÍËÈ ‰ËÒÚË·ÛÚË‚

+ ‚ÓÁÏÓÊÌÓÒÚ¸ ˝ÏÛÎflˆËË Á‡˘Ë˘ÂÌÌ˚ı

‰ËÒÍÓ‚

+ ·ÂÒÔÎ‡ÚÌÓÒÚ¸ ÔÓ„‡ÏÏ˚ ‰Îfl 

‰ÓÏ‡¯ÌËı ÔÓÎ¸ÁÓ‚‡ÚÂÎÂÈ

– ÌÂÚ Ò‚ÓÂÈ Ó·ÓÎÓ˜ÍË

– ÌÂÎ¸Áfl ÒÓÁ‰‡‚‡Ú¸ Ó·‡Á˚ ‰ËÒÍÓ‚

ê‡Á‡·ÓÚ˜ËÍ 3 Daemon’s home

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.daemon-tools.com

é·˙ÂÏ ‰ËÒÚË·ÛÚË‚‡ 3 445 ä·‡ÈÚ

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 ·ÂÒÔÎ‡ÚÌ‡fl

‰Îfl ÌÂÍÓÏÏÂ˜ÂÒÍÓ„Ó ËÒÔÓÎ¸ÁÓ‚‡ÌËfl

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

Alcohol 120% 1.4

+ ÌÂ·ÓÎ¸¯ÓÈ Ó·˙ÂÏ ‰ËÒÚË·ÛÚË‚‡

+ ‚ÓÁÏÓÊÌÓÒÚ¸ ˝ÏÛÎflˆËË 31 ÔË‚Ó‰‡

+ ÙÛÌÍˆËË Á‡ÔËÒË, ÍÓÔËÓ‚‡ÌËfl

Ë Ó˜ËÒÚÍË ‰ËÒÍÓ‚

+ ÂÒÚ¸ ÛÒÒÍËÈ ‚‡Ë‡ÌÚ ËÌÚÂÙÂÈÒ‡ 

– ÌÂÎ¸Áfl ÒÓÁ‰‡Ú¸ Ó·‡Á ËÁ ÓÚ‰ÂÎ¸Ì˚ı

Ù‡ÈÎÓ‚ Ë Ô‡ÔÓÍ

– ÌÂÎ¸Áfl ÒÊËÏ‡Ú¸ Ù‡ÈÎ˚ Ó·‡Á‡

ê‡Á‡·ÓÚ˜ËÍ 3 Alcohol Soft Co., Ltd.

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.alcohol-soft.com

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 shareware

ñÂÌ‡ 3 $49,95

é·˙ÂÏ ‰ËÒÚË·ÛÚË‚‡ 3 3,7 å·‡ÈÚ

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows


