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Chapter 1.

Introducing The WebPage Construction Kit
(Internet DesignShop)

An Overview of WebPage Construction Kit (DesignShop)
Welcome to WebPage Construction Kit (Internet DesignShop), your gateway to designing
Web pages, managing Web sites, graphic design, and much more. This application opens
the door to the Internet by providing you with all the tools you need to create dynamic and
exciting Web sites.

DesignShop (we will refer to the application simply as DesignShop in this user guide) is
many applications in one. All of these tools are accessible directly from within the De-
signShop application window giving you an unparalleled ease of use. DesignShop offers
an almost limitless amount of flexibility and convenience to help you do complex graphic
projects both easily and quickly.

Topics covered in this chapter include:

� The advantages of using DesignShop

� DesignShop features

� DesignShop suite of applications

� Product registration

� Assistance in using DesignShop

� Technical support

� User Guide conventions

The Advantages of Using DesignShop

All-in-one Program
DesignShop is an all-in-one application that enables you to create Web pages and manage
Web sites, design a wide range of graphic projects including greeting cards, calendars,
posters, banners, and more. As all of these features are easily accessible from within
DesignShop, you don’t have to learn a lot of applications and utilities to complete various
Web design and graphics projects.

Speed and Efficiency
As all of the features and projects are controlled from one easy-to-learn interface, your
work is faster and more efficient. You can speed your work of various tasks by using a
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single application instead of running different applications and utilities. You may save
time and be more efficient since you can share resources for all of your graphic projects
using the DesignShop application.

Easy to Learn. Easy to Use
DesignShop is easy to learn because it uses a standard Windows graphical interface. Ma-
jor functions are easily accessible from menu options, floating toolbars, and/or hot keys.
Furthermore, once you have learnt how to perform a particular operation in one project,
you can use the same approach to do similar tasks with other projects. For example, after
you have learned how to insert text and graphics into a greeting card, you can do it with
posters, banners, business cards and calendars.

Fully Automated Project Management
DesignShop automatically takes care of page links and Web site organization. You can
comfortably add, move, and delete pages from a Web site. The application automatically
takes care of maintaining the links between the pages.

Style Inheritance
DesignShop’s Visual Style Settings feature enables you to define styles for text, links,
background colors, and fonts for a single page or for an entire Web site. This feature can
save a great deal of time in creating new sites since it automatically takes care of the
routine requirements allowing you to concentrate on the content and appearance of Web
pages.

Frame Source Overlays (FSO)
DesignShop allows you to easily insert frames into Web pages. A few mouse clicks and
your page will be divided into as many frames as you desire. The enhanced frame man-
agement controls of the program allow you to manage a frames-enabled page as easily as
a page that has no frames.

Common Objects
Web pages created in DesignShop can share objects, such as navigation bars, images, and
multimedia objects, with other pages in the site. While most Web site design applications
include this feature, DesignShop enables you to use common objects more easily.

Context Sensitive Headers and Footers
You can design dynamic headers and footers that vary based on their location in the Web
site. When you move a page to another Web site location, the headers and footers are
automatically updated to reflect the new location of the page.

Secure File Format
DesignShop stores Web pages and entire Web sites as a single file that includes all objects,
graphics, text, effects, and other file resources. This format makes managing the site effi-
cient. When you need to make changes that may impact the entire site, the changes are
immediately implemented throughout the Web site design.

When you need to transfer the Web site to a different computer, you may simply transfer
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the one file rather than having to manually collect all of the various HTML files, re-
sources, graphics, and objects.

Graphical Layout Navigator
The Graphical Layout Navigator enables you to view the entire Web site with all of the
internal links between the pages or to view a single Web page. This feature of the program
makes managing and updating of Web site information quicker and easier.

In-Place Graphic Editor and Reusable Graphics
The DesignShop Graphics Editor enables you to import a wide range of graphic files
including bitmapped and vector images. When you insert images into a Web page, they
are stored in their original format. When you generate a Web site, all graphics are con-
verted to the highly efficient JPEG or GIF file formats for use on your Web site server.

Drag and Drop
The application enables you to drag and drop images from other Windows applications
and place them directly into a Web page or graphic project. DesignShop stores all graph-
ics internally and creates the appropriate file when the Web site is generated. Thus, you
don’t have to worry about the format for the original file.

DesignShop Features
The application allows you to design individual Web pages, create complex Web sites,
include databases in your Web sites, insert interactive forms, and much more. It is a com-
prehensive yet easy-to-use Web publishing program.

Graphics Editor
The DesignShop Graphics Editor provides the gateway to creating exciting and dynamic
graphics for Web sites, greeting cards, posters, business cards, calendars, and more. You
can easily select from the vast assortment of graphics that are included with DesignShop,
import your own graphics, or create new graphics. Any graphic item created in the Graph-
ics Editor is immediately available for use in any of the DesignShop modules so that you
can easily create Web page graphics, poster graphics, calendars, and more.

Posters and Banners
The posters and banners section enables you to create banners and posters that are as small
as a single sheet of paper or as big as ten sheets wide by ten sheets tall. You can include
text, text manipulation (color, shape, drop shadows, etc.), graphics, borders, and back-
grounds. After you have completed the design, DesignShop can print the project on indi-
vidual sheets of paper with cutting guides that will assist you in assembling your final
project.

Greeting Cards
DesignShop Greeting Cards let you create customized and personalized cards for any
occasion. You can select them from any of the pre-designed templates or create your own
design. After you have created your card using any of the DesignShop graphics, fonts, text
manipulation features, etc., you can print the card and send it on some special occasion.
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Calendars
The Calendar generator in DesignShop is one of the most powerful of any calendar creat-
ing programs available on the market. You can select a variety of calendar types (monthly,
annual, semiannual, weekly, etc.), incorporate your own graphics and text, even include
standard holidays automatically! You can customize the design to include new holidays, a
list of your “special” days, and much more. After you have finished creating the calendar,
you can print it as a single sheet (or as large as a 10 sheet x 10 sheet square), include it in
another graphic project, such as a greeting card or Web page, or place it on a Web page.

Business Cards
DesignShop enables you to create colorful and interesting business cards. You can include
scanned logos, clip art, text, text manipulations (drop shadows, shapes, etc.) to have your
cards make a real statement about you, your business, or your profession.

DesignShop Suite of Applications
The DesignShop suite includes a number of additional applications to manage Web site
design as well as other graphic projects. The additional applications in the suite include:

DesignShop includes the Internet DesignShop application along with several quality ap-
plications that complement the Web site and graphic design process. These applications
include:

� SST: Secure Shuttle Transport. Provides security and communications between
you and your friends, business associates and Web visitors. Includes encrypted in-
stant messaging, chat, file transfers and more... Refer to the chapter on SST in this
user guide for more details on SST features.

� BoomFTP. The Complete application that enables you to transfer files of all kinds to
and from servers or across the Internet.

� Clip art collection. DesignShop includes a large collection of JPEG and GIF images
you can use in Web site design and in graphic projects.

� Templates. The DesignShop installation automatically places a selection of tem-
plates in your system that you may use for Web sites, greeting cards, posters, etc.
These templates save you time since they are pre-designed for a wide variety of uses.
The installation program also includes a selection for template installation that will
place additional Web site templates in the DesignShop system.

Product Registration
DesignShop features a convenient online registration system that is activated the first time
you open it. If you have Internet access then, you can register using the automatic registra-
tion the program displays. Make sure you  enter an accurate email address in the form.  If
you do not have a modem or if you prefer to register by telephone, you may call the
number indicated in the online registration dialog box to register.

When you register your product you are eligible for notification on upgrades to Design-
Shop as well as information about DesignShop related products. Please refer to last sec-
tion of this guide on Other Products and Services from Boomerang Software for details.
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Where to Host Your Site?
Boomerang Software offers Web-hosting services that meet the needs of Internet mer-
chants. Hosting dynamic sites or E-Commerce stores with gateway transactions and ASP
requirements is an intricate process. Boomerang Software offers you both the tools and
the services to meet your Web development and Web hosting needs. This combination of
expertise, software tools, and dedicated E-Commerce and Web site hosting solutions gives
you a one-stop solution and a problem-free Web experience.

For more information contact, WebHosting@BoomerangSoftware.com, or visit our
Web site at https://www.BoomerangSoftware.com/Webhosting/Webhosting.htm.

Assistance in Using DesignShop
DesignShop includes the following forms of documentation for your convenience:

� Printed User Guide. This printed user guide provides an overview of the operation
of the DesignShop application.

� Windows Help System. For quick reference on a particular operation or feature in
DesignShop, you may use the Help system. You may access the Help files by select-
ing the Help > Contents menu options or by pressing F1.

Technical Support
Before you contact Technical Support, please check the Readme file to see if they answer
your questions. If you cannot solve your problem, contact Boomerang Software Technical
Support at the following email, fax number or postal address:

Tech Support e-mail: TechSupport@BoomerangSoftware.com
Tech Support (fax): 617.489.1486
Tech Support (mail): Boomerang Software, Inc.

ATTN: Tech Support
90 Concord Ave.
Belmont, MA 02478

If is more effective if you follow these guidelines when contacting tech support by email:

� Record the exact sequence of events that created the problem. Make sure that you
can reproduce the problem by following the same series of steps.

� Know the version number for DesignShop. To get the exact version number, choose
the Help > About menu option in DesignShop.

� Know the type of computer and the version of Windows that you are using.

� Record the text in any error messages that may appear with regard to the problem.

User Guide Conventions
1. Commands that you are instructed to type are indicated in a bold, sans-serif font,

such as: CD\TEMP. Ignore any punctuation included unless specified otherwise.

2. Keystrokes, or individual keys that you are asked to press or type are indicated with
bold, all capital text, such as: ALT, F1, TAB, ENTER. Ignore any punctuation in-
cluded unless specified otherwise.

3. When you are asked to press two keys at once to perform a particular operation, the
keystrokes are indicated with an ampersand, such as: ALT & R.

4. When you are instructed to press one key and then another, the keystrokes are indi-

mailto:TechSupport@BoomerangSoftware.com


Chapter 1

1–6 WebPage Construction Kit � � �

cated as: F and R or F, R and R. Ignore any punctuation included unless specified
otherwise.

5. When you are instructed to select more than one menu option in sequence, the menu
options are separated by a vertical bar. For example, the instruction “Select Object >
Edit Paragraph Text> Find/Replace> Find” would indicate that you are to complete
these steps: 1) select the Object menu option; 2) select the Edit Paragraph Text option
in the Object menu; 3) select the Find/Replace option in the Edit Paragraph Text
menu; and 4) select the Find option in the Find/Replace menu.

6. When you are instructed to click or double-click the mouse button, use the left mouse
button unless you are told otherwise. If you have reversed the configuration of the
mouse buttons in Windows, you should reverse the button instructions in this user
guide as well.

7. Instructions included in greater/less than brackets (i.e., “<” and “>”) indicate that
you are to supply some information. For example, instructions for “CD\<directory
name>” indicate that you are to enter “CD\” followed by a directory name.
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Installing The WebPage Construction Kit
(Internet DesignShop)

Introduction
This chapter provides instructions on how to install The WebPage Construction Kit
(DesignShop) and what you can expect to find in the Program Manager when the
installation is completed. The installation procedure is essential to using DesignShop.
Neither the DesignShop application nor any supporting applications can be used
directly from the CD without installation.

Topics covered in this chapter include:

� Installing DesignShop

� Starting DesignShop

� On-line Registration

� Starting a New Project

Installing DesignShop

Before You Begin

System Requirements
The following is important information regarding your DesignShop application.

� DesignShop requires a 100 Mhz Pentium processor (or better) computer with
Windows 95, Windows 98, Windows NT/Me/2000/XP.

� The application requires about 50 to 60 Mb (minimum) of hard drive space (or
more depending on the components that you install) and 16 Mb of RAM. More
RAM is needed for creating large Web sites.

� A mouse (or similar pointing device) is required.

� DesignShop is compatible with all printers and printer drivers that are compatible
with Windows 95, Windows 98, Windows NT/Me/2000/XP.

� DesignShop requires a CD-ROM drive for installation.

� SVGA monitor and graphics card or better

System Recommendations
� Personal computer with a 200 MHz Intel Pentium processor (or better)

� 32 Mb of RAM
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� 220 Mb of available hard disk space

� SVGA video card set to True Color (24-bit) mode with a resolution of 800 x 600 or
higher

Auto-Run Installation
The DesignShop installation uses an “auto-run” installation program that opens from
the Windows Program Manager as soon as you insert the CD into your drive and close
the CD door. If the installation program does not open automatically when you close
the CD drive door, you may use the manual installation procedure described in the next
section.

Manual Installation
To open the DesignShop installation program, click on File in the main menu of the
Program Manager. In the File menu, click on the Run option.

In the Run dialog box, enter the command: <letter of your CD-ROM drive>:INSTALL.
For example, if your CD-ROM drive is designated as “D,” you would enter the
command: D:INSTALL.

Before You Install DesignShop
The installation program opens with a DesignShop title screen with installation menu
options. You can select the application that you wish to install simply by clicking on
the option in the title screen. It is not necessary to install all of the included applications
to be able to use DesignShop.

The WebPage Construction Kit/DesignShop suite includes the following applications:

� Internet DesignShop. The main application for Internet & Intranet
DesignShop.

� Photo Editor. The Photo Editor is the component that provides image
manipulation and editing capabilities outside of DesignShop.

�  Thumbnail Image Cataloger.

NOTE: The CD also includes a clip art sub directory that includes thousands of
clip art files. These are not installed on your hard disk to conserve space. If you
need to use them, you can simply import or read them from the CD directly into
DesignShop as they are needed.

It is recommended that you turn off any virus checking software that may be running in
the background prior to installing DesignShop. The DesignShop installation may replace
certain files in the Windows directory that may be interpreted as a virus by some virus
checking software. Since the DesignShop program set is provided on CD-ROM and is
thoroughly checked before the CD is made, the chances of getting a virus from the
installation are extremely small.

Running the DesignShop Installation
1. To begin the DesignShop installation, click on the Install DesignShop option in the

title screen.

2. After you select the Internet-Intranet DesignShop installation option, the Welcome
dialog box opens explaining the installation. Click on the Next button to continue.
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3. Read the software license agreement (use the scroll bar on the right to view the
entire agreement). When you have read it and accepted it, click on the Yes button.

4. The User Information dialog box includes information about the registered
Windows user (name and company) along with a space to enter the serial number.
When you enter the serial number, the Next button becomes available. Select it to
continue.

5. The Choose Destination Location dialog box permits you to change the installation
location for DesignShop . To change the destination, click on the Browse button.
When you are satisfied with the destination, click on the Next button.

6. DesignShop includes a number of components including additional Library Files,
Templates, and Examples. The full installation requires approximately 223 Mb.
The Space Required option shows the amount of disk space required for the
selected components. The Space Available option shows the amount of space
available on the selected drive. The Space Available must be greater than the Space
Required number.

7. You can customize the installation of the Library Files and the Templates by
selecting only those that you wish to install. To change the installation, click on the
option desired, such as Library Files, and then click on the Change button. Some of
the components are made up of subcomponents. For example, the Library Files
includes Clipart libraries, Border libraries, Vector Image libraries, Raster Image
libraries, and Raster Brush libraries. When you click on any one of these subcom-
ponents, the Change button is still available indicating that you can select compo-
nents within each of the categories.

Note: If you uncheck and remove all optional components, a minimum set of samples
from the libraries is installed. The program will operate properly and you will have
access to a small number of library components such as buttons and clipart.

8. When you have selected the components to install, click on the Next button.

9. The Select Program Folder permits you to customize the Program Group for
DesignShop. The default Program Group is Internet DesignShop. You can accept
the default, enter a name for a new program group, or place DesignShop in an
existing Program Group that you select from the list. When you have selected or
accepted the Program Group, click on the Next button. The program installation
will begin. The installation run finish by itself from this point.

Important Note: You must have an Internet browser installed and operational in
your computer to be able to fully utilize the program’s features.

11. The final dialog box in the installation process states that the installation is
complete. Click on the Finish button to complete the installation and return to the
Installation Main Menu.

Installing the Secure Shuttle Transport (SST)
One of the components available with the full CD version of this program is the SST
Encrypted Instant Messenger. Most other messengers are not encrypted. SST does not
conflict with other Instant Messengers. It provides you with added security and
encryption of real time communications. It requires additional 3 MBytes of hard disk
space. To install SST:

1. Follow the installation wizard which starts after the WebPage Costruction Kit is
completed. Or click on SST in the Welcome Screen.
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2. After the  SST installation is completed, double click on the SST icon found on
your Windows desktop. Follow the wizard and connect to the SST server over the
Internet. You will be issued a Unique ID.

Please refer to the chapter on SST in this guide for details on how to use SST.

Starting DesignShop
After you have completed the installation, you are ready to open and run DesignShop.

To open DesignShop:
1. Click on the Start > Programs > Boomerang Software > Internet DesignShop

menu options. The actual name of the DesignShop menu option may be different if
you changed it during the installation.

2. Click on the DesignShop option in the DesignShop menu.

Online Registration
To register your DesignShop application automatically:
1. The first time you try to open DesignShop, you will see the Online Registration

dialog box. The first box welcomes you and explains the registration. Click Next to
continue.

2. The second dialog box in the registration enables you to select the type of
registration to use.

3. Complete the Online Registration and proceed to use the program.

To register your DesignShop application by telephone:
1. If you choose not to use the automatic modem registration, you can call the

Boomerang Software office and register. Be prepared to give the following
information over the telephone: Name, Company (if applicable), address, e-mail
address (if applicable), telephone, fax, and dealer from whom you purchased
DesignShop . Hours of operation are Monday through Friday (excluding holidays),
8 AM to 5 PM Eastern Time.

2. When you call, state that you wish to register your application. A Boomerang
Software operator will provide you with a registration code that you must enter in
the space provided. After you enter the registration code, DesignShop will open.

Starting a New Project
When you launch the application, the NEW dialog box display the output formats
available. These include (I) Personal/desktop and (II) Web publishing modules. One of
the key advantages that differentiates this program from other Web publishing programs
is that it includes publishing tools and components for designing both Web pages and
personal presentations. Having all these in an integrated program enables you to be
much more productive.

If you want to create Web pages, click on the Web Site graphic from the New dialog box.
The program will display a number of different templates and pre-made Web projects
that are available.

To open any template, double click on it or click once on it to select it and then click on
the OK button. If you wish to start with a new, blank Web page, double click on the
BLANK template icon or click once on the blank icon and then click on the OK button.
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Advanced Versions
Boomerang Software publishes a family of programs to build different types of E-
Commerce sites. You are invited to explore the additional features of the professional or
Enterprise versions of this program. For example, the XL versions include a bigger
selection of web store templates and Styles, direct Database Import functions, XML
Compliancy, Hits gathering statistical services, Input Forms validation, Script Wizards,
and more. The Enterprise editions support Access, Oracle and SQL databases, Inven-
tory related functions, and more advanced features. To inquire about these products or
to upgrade, refer to the section on Other Products And Services Available From
Boomerang Software section, or email TechSupport@BoomerangSoftware.com

mailto:techsupport@boomerangsoftware.com
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Chapter 3.

Starting DesignShop

Introduction
In this chapter we will cover:

� Starting DesignShop

� Setting user preferences

Starting DesignShop
To open DesignShop:
1. In Windows, click on the Start menu button.

2. Click on the Programs menu option.

3. Click on the Internet DesignShop option from the Program menu.

4. Click on the Internet DesignShop option in the DesignShop menu.

DesignShop features a number of different types of modules that are called Output Types.
These types include:

� Web site design

� Greeting Cards

� Posters

� Banners

� Calendars

� Business Cards

When you open DesignShop, it defaults to the last output type that was used in the appli-
cation. If you are opening DesignShop for the first time, it defaults to the Web Site Output
Type. Before beginning work with DesignShop after installation, it is a good idea to set
the application preferences to your liking.

Setting Preferences
DesignShop offers a number of customizable preference settings for controlling various
aspects of the application. While you may not wish to change these settings until you are
more comfortable with the operation of the program, it is good to review the preference
settings so that you know what is available. You can come back to the Preferences options
and change them at any time.
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To access the Preferences settings
Click on the File > Preferences menu options to open the Preferences dialog box.

The Preferences dialog box includes a number of tabs that effect the operation of the
application in different areas. These areas and the preference settings include:

General
� Undo/Redo. This feature enables you to set the levels (i.e., the number of previous

steps which you can undo and redo in the application). The number can be anything
between 0 and 100. The higher the number, the more RAM and hard drive space is
required to store the different levels.

� Startup. You can have DesignShop open to a blank page, the DesignShop About
dialog box, the New - Template selector (select a template for a new project), or to
the Open File dialog box.

� Autosave. The Autosave feature, when turned on, enables you to set the number of
minutes between automatic saves of your current project.

� Create Backup Files. If you enable the Create Backup Files feature, DesignShop
will not overwrite existing files when you try to save a file to an existing name. If you
try to save a file to a file name that already exists, DesignShop will create a backup
copy of the existing file before it saves the current file.

Graphic Editor
� Ruler Units. You can select inches, centimeters, millimeters, or pixels as the units of

measure in the work page. Note: the Ruler feature is not available in the DesignShop
Web Site Design module; it is only available in the Graphic Editor module for post-
ers, greeting cards, etc.

� Workspace. You can select the Sheet and Shadow options in the Workspace section.
When both options are turned on (i.e., there is a checkmark in the box to the left of
the item), the work page displays as a rectangle with a gray drop shadow. If you click
on the color sample box to the right of the options, you can select the color for the
Sheet and the Drop Shadow.

� Objects. The Objects option enables you to determine where new objects, such as
graphics and text, are inserted into the workspace. You can elect to have all new
objects inserted in the center of the work page or in the center of the visible work area
(if you are zoomed in on a particular portion of the work page).

� Grid. The Grid feature enables you to select the frequency or the number of lines for
the grid in a given space. The frequency selection measurement depends upon the
units of measure selected. For example, if you select inches as the Ruler Units, you
will select the grid based upon the number of lines per inch.

Web Site
� Default Colors. The Default Colors option enables you to select the standard or

default colors for the text, hypertext links, and the background for all pages in a Web
site. To select a different color, click on the color selector box to the right of the
desired option.

� Encoding. The Encoding option enables you to select the type of language and char-
acter encoding to include in your Web site.

� Proportional Font. The Proportional Font option enables you to select the default
proportional font to use in your Web site. This font is used in your Web site in any
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instance in which you do not otherwise specify a font.

� Fixed Font. The Fixed Font option enables you to select the default fixed or
monospaced font to use in your Web site.

� Navigate Layout. The Navigate Layout section enables you to select the default
colors for the hypertext links in your Web site. You may change the Selected Page,
Orphan Page, Internal Link, and External Link colors by selecting the color box to
the right of each option.

� Headers/Footers. The Headers/Footers option, when turned on, automatically places
the default header and/or footer into a new page.

Browsers
� Browsers. The Browsers option enables you to specify the default Internet browser

to use when you wish to test view your Web pages. You may enter as many different
Web browsers as you wish. If you are doing a good deal of Web design, you may
wish to install and use several of the most popular browsers, including Microsoft
Internet Explorer and Netscape Navigator, so that you can see how your pages will
display in each.

� Web-Promote. The Web-Promote menu options includes quick access to a number
of Internet search engines and Web site promotion services. You may use these sites
to register your Web site with the search engines. Many Internet users depend solely
on the search engines to find sites that are of interest to them. If your site is not
registered with the major search engines, finding your site is more difficult. You can
also add your own personal favorite sites to the Web-Promote list to provide you
quick access to those sites from within DesignShop.
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Chapter 4.

Planning a Web Site

Introduction
In this chapter, we will discuss the basic concepts of Web site design using DesignShop.
Topics that we will cover include:

� Web site planning

� Web site organization

� Web site content

� Web site maintenance

Web Site Planning
Web sites consist of one or more Web pages that are organized and linked to one another.
The purpose of a Web site can be as varied, but it may include:

� Corporate information and promotion

� Catalog Sales

� Information Source

� Public Service

� Personal information

Web sites can vary in size from a single page for a personal site to several thousand pages
for a commercial or corporate site. Regardless of the size of your site, it is important that
you begin your site project by planning what you want the site to accomplish. There are a
multitude of sites on the Web that stand as glaring examples of what can go wrong when
you don’t complete the simplest planning steps before you start designing.

The best place to start planning is to begin with a series of questions.

� What kind of site do you want to construct? Is the site to be a business site selling
a product, a corporate information site, or simply a personal site for you?

� What is the purpose of the site? If the site is commercial (business or corporate),
what do you want the site to accomplish? Are you trying to sell a product or simply
trying to provide information about your company? If the site is a personal site, do
you want to just tell people who you are and what you do or do you want to convey
some message?

� How much time can you devote to the site? There are many examples of massive
Web sites started when there were only minimum resources available. The “Site
under construction,” or worse, the “404 File not found” message signals to the site
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visitor that a site is not important enough to finish or maintain—therefore, not impor-
tant enough to view. Unless you have the resources to complete and maintain a large
Web site, start small. You can always add pages and details later.

� How much server space is allocated to your site? Many Web-hosting services
provide a basic amount of hard drive space included in the site management fee.
Requirements for additional space usually require additional payments that may or
may not be within your budget.

� Does your site require graphics and/or multimedia? It seems that most Web sites
today operate under the assumption that every page must have a graphic. However,
graphics increase the amount of the download time and make pages more compli-
cated to create and maintain. Graphics should be carefully selected to help you con-
vey the message for that page and to make the page interesting and useful for the
viewer. If the graphic does not promote the page, it probably should not be used.

� What do you want each page to say or do? You should thoroughly plan the content
and purpose of each page in your site. Study other Web sites to see how they have
organized their content and information. One rule of thumb is to keep each page
simple and to the point. Web site writing and design are very different from printed
counterparts. Viewers won’t wait for huge pages of graphics and/or text to down-
load. If they do, they generally won’t spend a lot of time reading the page unless they
are critically interested in learning about the topic at hand.

To complete the planning phase, it is a good idea to start with the Logical Layout window
in the Site Manager to setup the various pages for the site. If you are new to DesignShop
and not yet familiar with its operation, you can take a piece of paper and draw a chart type
arrangement of the pages that you wish to include. You can always add or delete pages
later.

Begin with the Home Page as your central hub or access point for the entire site. Next,
draw the most important sub pages (or children) of the Home Page. After you have en-
tered the most important pages in the second level, go back to each of the children pages
and determine if each of them require additional pages. For example, a corporate site
should probably include information on what the company does, a brief history of the
company, a list of key personnel, and employment opportunities. You would not want to
include all of this information on the same page; it would probably require a very large
HTML file that would take a lot of time to download and display. In addition, keep in
mind that a viewer who is interested in the history of the company may not be interested
in employment opportunities. Don’t force that viewer to download the employment infor-
mation when that is not what they want. Keep each page brief, concise, and focused on the
topic for that page.

Starting a New Web Site
The DesignShop Site Manager includes a Logical Layout window in which you can visu-
ally plan your Web site. This feature is very useful during the initial stages of planning
because you can add, move, and delete pages very easily. In addition, the Logical Layout
window arranges Web pages into an organization style chart to help you plan what pages
you need and how the pages should be linked.

To start a new Web site:
1. To start a new Web site, select the Output Type selector list in the toolbar at the top of

the DesignShop window or click on the File > New options in the main menu.

2. Click on the Web Site tab in the New dialog box.
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3. The template selector is divided into two parts: library selector and template selector.
If you installed the template libraries that come with DesignShop, you can view them
in the template selector list box. The library selector box located just below the Tem-
plates for Web Site text enables you to select a Web site template library. The default
library is Art and Education. To select a different library, click on the arrow to the
right of the Art and Education text to open the library selector list. Click on the
template library that you wish to view. The DesignShop installation gives you the
option to add more templates.

4. After you select a template library, you can view the templates included in that li-
brary in the template box below the library selector. The first template in the template
selector box is blank. If you select this template, your Web site will begin with a
blank page. For this tutorial, we will begin with a blank Web site, so double click on
the blank template or click once on the blank template and then click on the OK
button.

The Physical Layout
DesignShop includes a Physical Layout tab in the Site Manager window. This window
displays the physical aspects of the Web site including the directory structures and the
actual files included with the site. When you generate a Web site (i.e., create all of the
HTML, graphic, CGI, and support files), the files will be placed in a directory structure
indicated in the Physical Layout window.

The Logical Layout
The Logical Layout tab in the Site Manager window is one of the most useful features in
Site Management. This window enables you to add, move, and delete Web pages from
your Web site. The Logical Layout window organizes the Web pages into a hierarchical
structure similar to an organization chart. This format enables you to readily see and plan
the link structure for your Web site.

To add a page to a Web site:
1. Click once on the Home Page icon to highlight it.

2. Right click on the Home Page icon to open the drop down menu.
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3. Select the Add option from the drop down menu.

4. A new page is added to your Web site directly below the page that you selected. Enter
the name for the new page. Note that you cannot use spaces or any of the following
characters in a Web page name: / : “ > < > > + #

DesignShop organizes the pages of a site into a hierarchy of parents, children, and sib-
lings. The Home Page is a parent page since all other pages in the Logical Layout are
below it. Pages on the level below the Home Page are children of the Home Page. The
children of a Home Page are also called First Level Pages. All child pages of a particular
page are sibling pages.

To add a sibling page:
1. Right cick on the icon of the page to which you wish to add

a new child page. This opens the drop down menu.

2. Select the New option from the drop down menu.

3. A new page is added to your Web site directly below the
parent page selected.

One of the features of the Logical Layout is the ability to easily
move pages to different levels changing their parent page, their
sibling pages, and their children pages. You can move any page,
except the Home Page, simply by dragging a page to a new loca-
tion.

To move a page to a different location:
1. Click on the page that you wish to move and, while holding down the left mouse

button, drag it to a new parent page.

2. When you have the page over the new parent page, release the left mouse button to
drop the page as a child of the selected page.

When you are designing the layout for your Web site, much will depend upon the number
of pages that you wish to include. It is a good idea to plan your Web site for indefinite
expansion. Today, you may envision a Web site that requires only 4 pages, but in a month,
you may need 50 pages. It is better to start with a plan that can accommodate the 50 pages.
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Design your Web site with a consideration toward site maintenance. Many Web designers
fail to design expendability into their site. When it comes time to grow the site, they begin
to encounter many problems in controlling the pages and the flow of the pages.

Another critical consideration for Web site design is Internet search engines. If you design
a Web site, it is probably because you have some information that you wish people to see.
Some sites, such as personal Web sites, may not need or even want a high degree of viewer
traffic. However, if you want people to come to your Web site, you will generally want to
register with search engines. Some search engines will visit and index your site in their
database whether you want them to or not. You can use the Web-Promote feature in the
File menu to access major search engines to enlist, update, and promote your Web site.

Many search engines use an automated application (i.e., a spider) that routinely examines
Internet servers, locates Web sites, analyzes the pages, and incorporates them into their
database. If you design your Web site with a page that you would like people to visit, a
Web spider will probably eventually visit the page and index it.

You can take a more active role and register the page with various search engines. How-
ever, once a page is registered with a search engine, it is sometimes difficult to remove it.
The Webmaster has no control over when or how the various search engine spiders will
visit. If you change the name of a page that is registered in a search engine, then any user
that tries to access that page through that search engine will get a failed search with a
“404 File not found” error message. The result is that the viewer will not be able to access
the page through that search engine. In addition, it may be weeks or even months before
that search engine spider comes back to your site to get the new page name. For this
reason, it is very important in the planning stages to develop a system of naming your
page files (i.e., the .htm or .html file names) and retain that naming system.

The Navigate Layout
Navigating a Web site is a lot like running a software application. Most Web sites require
a certain amount of interaction with the viewer so they can go to various pages or find a
particular piece of information. It is important to remember that the first time a viewer
arrives at your site, they will have no advance information about how your site is orga-
nized. They may have a general idea of how other Web sites operate and how to navigate
them, but they have no idea as to how your navigation system works. In addition, they
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have no user guide or help file for your site. All they have is the basic knowledge of how
Web sites are generally organized and the information that you provide them.

While there is no standard set of rules as to how a viewer should navigate your site, there
are some basic considerations that you can use to develop a navigation plan:

1. Place your navigation aids in a prominent position on the home page. Good
locations are at the top of the page, at the bottom of the home page (unless the viewer
has to scroll down to get to the bottom), or along the left side of the home page.

2. Don’t overload a page with navigation aids. A Web page which is covered with
hypertext links may be confusing for the user (unless it is a “links” page designed to
be a list of hypertext links only). It is a good idea to have no more than 6 to 8 areas or
divisions on the home page. Each of these areas or divisions can be further divided
into categories and subcategories.

3. Use graphics to improve site appearance. You may wish to use a graphical naviga-
tion system, such as images with hypertext links. Graphics can dramatically improve
the appearance of a site. A dull and boring text site can become interesting and ap-
pealing with just a few well-placed graphics.

4. Use alt tags for navigation buttons. If you use hypertext-linked graphics for navi-
gation buttons, be sure to include text tags (i.e., alt tags) for each image that de-
scribes the hypertext link. Some users turn off the image display capability in their
browser to speed the download time. If you have a graphic button with a hypertext
link without an alt tag, the user will see that there is supposed to be an image with a
hypertext link, but they will not know what the link is for.

5. Consider image map download time. Some sites feature image maps (i.e., a large
image that has hypertext links embedded in the image) rather than individual graphic
images as navigation buttons. One important consideration is the download time for
a single large image rather than several smaller images. Individual graphical naviga-
tion buttons will display one at a time. If the viewer wants to access the first button
displayed, they don’t have to wait for all of them to download and display; as soon as
they see the link they want, they can click on it and be gone to the desired page.

6. Include text links with graphic navigation buttons. If your Web site has a graphi-
cal button link to a page that promotes your company’s products, include a text hy-
pertext link below the graphic button that also links to the page. When the viewer is
waiting for the page to download and display, the text links will appear on the page
before the graphic images. If the viewer sees the text link to the page or area they
want, they can click on it immediately rather than waiting for the entire page to
download.

7. Design your navigation system for flexibility. For example, you may include a
Links to Cool Sites page in your initial site plan. After a month, you may decide that
the page is growing too large, so you split it into two pages: Links to Fun Sites and
Links to Useful Sites. You would still maintain the original Links page, but it would
now be the parent of the two new pages. The Home Page would still have only one
hypertext link for: Links to Cool Sites.

8. Design a logical layout to your Web site. You can use the Logical Layout feature in
the Site Manager to divide your site into categories and subcategories. For example,
you may have a list of 500 links that you think users would like to use. The download
time for a page with 500 different links might be excessive. In addition, if the viewer
is interested in seeing only the sites that deal with stock price quotes, you do not want
to force them to download all of the other information that they are not interested in
seeing.
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9. Include a site map page if necessary. If your site has more pages than can comfort-
ably be linked to from the Home Page, it is a good idea to include a site map page that
has text links and descriptions for every page in your Web site.

10. Consider how your page will download. It is a good idea to consider how the page
will download and display in a browser. If your page uses lots of graphics for visual
appeal and graphic navigation buttons as well, it may take too long to download.
Viewers don’t want to sit and wait as huge graphics download over slow modems.
Experience has taught many viewers that when a page is very slow to download, it
may be because there is an error in the page that prevents it from downloading. After
a wait, the viewer simply uses the back button to go someplace else.

11. Design for multiple browsers. Many Webmasters design sites for a particular com-
puter user audience. For example, if your Web site is primarily for PC users, you
probably are not interested in how your page downloads and displays on a Macintosh
or Unix system. If you view a series of complex Web pages in Netscape Navigator
and Microsoft Internet Explorer, you will find that there are major differences in the
display of some of the pages. The differences may be even greater for other Windows
browsers. You should have the latest version of Navigator and Explorer so that you
can see how your pages will display in the most popular browsers.

12. Design for multiple screen resolutions. Most computer users select a screen resolu-
tion that is comfortable for them and use it in all applications. This is not a problem.
A problem arises when a Web site designer assumes that all of the viewers that come
to his site are using the same screen resolution that they are using. You may be
comfortable using 1024 x 768 screen resolution, but your Web site design and navi-
gation system should be easily compatible with all screen resolutions. Variable screen
resolution is one of the primary reasons that many sites feature menus and links
down the left side of the Home Page. If you have links at the left of the page, the
viewer will immediately see them regardless of their screen resolution. If you have
links across the top or bottom of the page, the viewer may have to scroll to get to
them; if the viewer doesn’t think to scroll the page, they may never see your links.

13. Look at other Web sites. Fortunately, there are hundreds of thousands of examples
of excellent Web sites and navigation systems available for viewing on the Internet.
It is a violation of international copyright law to intentionally copy content of a Web
site to use for your Web site. However, it is not illegal to view other sites and study
the concepts and techniques that are used. There is nothing illegal about using con-
cepts or principles of design that you see in other pages.

14. Provide Web site access from all pages. You should not assume that all viewers will
enter your site at the Home Page. If a viewer uses a search engine looking for a
particular topic or subject, they may enter your site on one of the child pages. You
should provide the user with easy access to the Home Page from every page in your
Web site. Depending upon your site content, you may also wish to provide conve-
nient access to pages of major importance, such as a catalog page, product informa-
tion, etc.

Headers and Footers
Headers and Footers play an integral part in most Web site design since they are standard
for all Web pages. The DesignShop Header/Footer feature is especially useful because it
enables you to create a header or footer once and then reuse it over and over. This elimi-
nates the need to insert the standard information for every single Web page. In addition, if
you decide that you wish to change the content of a particular header or footer, all you
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have to do is go to that header or footer and complete your edits. When you generate the
Web site, all of your changes will automatically be made to the appropriate pages.

You can place navigation bars inside headers and footers. This special feature of Design-
Shop enables you to place navigation bars on every page and define the navigation bars
with links to other pages. Using navigation bars in headers and footers places links through-
out your site quickly and easily.

DesignShop includes a single, blank default header and footer in the Header/Footer tab of
the Site Manager. You can add as many new headers and footers to your Web site system
as you desire. When you design a particular page, you can elect to have no header or
footer, use the default header or footer, or specify a particular header or footer that you
have created.

There are no specific rules or guidelines as to what you should include in a header or
footer. The primary determining factor is that it should be information that you want to
include on a number of different pages. Some examples of standard header or footer con-
tent might be:

� Company logo and address. You may wish to include your company logo or other
graphic along with the contact address in a standard header. The repetition of a par-
ticular graphic, such as a logo, reinforces the company image, always lets the user
know that they are in your Web site, and provides a continuity of design.

� Copyright information. It is a good idea to include a copyright notice on every page
of your Web site. This provides an extra degree of legal protection for the content of
each page. Generally, the copyright notice is located at the bottom of the page in the
footer.

� Mail to feature. It is a real convenience to the viewer to have a mail to button or link
to the Webmaster on every page of a Web site. Generally, these are located in the
footer of the page. Web sites can be very complex and subject to all sorts of prob-
lems. If a viewer sees a problem or wishes to get additional information, they can use
the convenient mail to at the bottom of the page to contact the Webmaster.

� Navigation aids. While your primary navigation aids should be located most promi-
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nently on the page (perhaps in the header or near the top of the page), you may also
wish to include a text navigation bar or list in the footer. The text navigator will add
only a few bytes to the overall download process and may provide an additional
convenience for the user.

Overall Considerations
When you are in the planning stages for your Web site, it is important to first consider the
overall plan as to what you want your Web site to convey to the user. As you solidify your
plan and translate your ideas into actual pages, there are a number of axioms of Web
design to consider:

� Viewers have grown accustomed to quality. Fortune 500 corporations can afford
to invest hundreds of thousands of dollars in their Web sites. They have entire depart-
ments devoted just to the process of planning Web site design and management.
Most companies and individuals do not have the resources to compete against these
giants. You cannot expect viewers to be satisfied with a sloppy Web site that is disor-
ganized, poorly designed, and badly managed.

� Viewers are sometimes impatient. Consider the download time required for each
element of your site. Test each page in your browser (and upload it to a server for
testing, if possible). Check the download time of each page. If download time for any
page seems too long, redesign the page or break it down into smaller pages. A good
measure for home pages is that a home page should download and display in under
20 seconds. Anything above that is getting to be too long.

� Follow the Internet standard. Viewers arrive at your Web site with a set of precon-
ceived ideas about such things as navigation. They expect to find text links, graphic
button links, or image maps. If your navigation system is so unique they can’t under-
stand it, they will go elsewhere. This is not meant to stifle creativity. The truly unique
and creative Web site can generate viewer interest and traffic. However, the viewer
must be able to immediately understand the site, use the navigation system, and find
the content of the site interesting.

� Content is king. Finally, the one overriding rule for Web site planning and design is
that viewers are most interested in content. You should design your site around the
message that you wish to convey. You must not let the message get muddled or
obscured by complex structure or impressive graphics that do not directly further the
purpose of your site.
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Chapter 5.

The Web Site Designer

Introduction
In this chapter we will cover the basics of using the DesignShop Web site designer and
manager. All activities in the creation and maintenance of a Web site are handled in the
Web site designer module.

Topics we will cover include:

� Opening the Web Site Designer

� Web Site Toolbars

� Starting a New Web Site

� The Site Manager Modules

Opening the Web Site Designer
The DesignShop is capable of handling Web sites as simple or as complex as needed.

To open the Web Site designer:
1. If DesignShop is already open, click on the File > New options in the main menu to

open the New dialog box.

2. Click on the Web Site tab in the New dialog box.

3. If you wish you can begin your Web site design with an existing DesignShop tem-
plate which is included with the application. DesignShop includes a number of dif-
ferent libraries for Web site templates. When you open the Web Site tab in the New
dialog box, you will see a library name just above the template selector box. To
change to a different library, click on the down arrow to the right of the library name
to open the drop down list box. Click on the library that you wish to view to select it.

4. All template display windows in DesignShop include a blank template first in the
display (it is the first square in the upper left corner with an “X”). To start with an
empty Web site (i.e., no template), double click on the blank template box or click
once on the template box to select it and then click on the OK button.

5. After you select a template, DesignShop opens the Web Site manager with the Site
Manager window displaying the Physical Layout window.

The Site Manager window features four tabs for access to the four main areas of Web site
design and management. These tabs are:

� Physical Layout. The Physical Layout window shows the actual arrangement of the
files in folders after you generate a Web site. The folders the CGI-BIN, Images, and
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NavBars. As you create a new Web site, DesignShop stores all of the necessary
information (including supporting graphic or multimedia files) in a single Design-
Shop file. This facilitates the control and management of the various files. The fold-
ers and files that you see in the Site Manager window are not created until you click
on the Generate Site option that generates all of the necessary files.

� Logical Layout. The starting point for Web site design is the Logical Layout win-
dow. You access this window by selecting the Logical Layout tab. This window
provides a graphical display of the arrangement of the various pages in a site. Be-
cause the display arranges the pages into an organization-type chart arrangement, it
is very easy to see how the site is organized.

� Navigate Layout. The Navigate Layout window displays the Web site in a graphical
display indicating the links between pages and, if desired, all of the resources in the
Web site. This window is especially useful for viewing the link structure between the
various pages and with external Web sites.

� Header/Footer. The Header/Footer window enables you to create standard headers
and footers for pages. DesignShop includes a blank default header and footer that
you may use for inserting repetitive information in many pages. You can also create
and name your own customized headers and footers to use in any Web page.

Web Site Toolbars
All of the DesignShop features can be accessed via menu options or by toolbars. As you
change the focus of DesignShop, such as going from the Physical Layout window to the
Logical Layout window, you will notice that the buttons in the toolbars change to reflect
the current focus of the application.

The Main Toolbar
The Main toolbar appears at the top of the DesignShop window just below the main menu.
This toolbar is standard and does not change when the focus of the active window changes.

� New button. Opens the New dialog box so that you can begin a new project design.

� Open button. Opens an existing file in DesignShop.

� Save button. Saves the current file.

� Page setup. Allows you to change the printer setup for your Windows system.

� Print button. The Print feature is not active in the DesignShop Web Site design
module.

� Undo button. Undoes the last action in DesignShop. The Preferences dialog box
enables you to set the number of levels you may use for Undo. If you have more than
one level of undo set in the Preferences section, you may step back through as many
steps undoing each. For example, if you have the undo level set to 25, you can undo
the last 25 steps that you completed in DesignShop. The Undo feature is only func-
tional with operations within DesignShop. For example, you cannot undo a save or a
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print operation.

� Redo button. Redoes the last undo in DesignShop. The Preferences dialog box en-
ables you to set the number of levels you may use for Redo. If you have more than
one level of redo set in the Preferences section, you may step back through as many
undo steps redoing each. For example, if you have the redo level set to 25, you can
redo the last 25 undo steps that you completed in DesignShop. The Redo feature is
only functional with operations within DesignShop. For example, you cannot Redo a
save or a print operation.

� Cut button. Deletes the selected graphic or text object and places it in the Windows
Clipboard.

� Copy button. Copies the selected graphic or text object to the Windows Clipboard.

� Paste button. Pastes or inserts an graphic or text object from the Windows Clip-
board into the current document.

� Output types combo box. Enables you to select a different Output Type, such as a
greeting card, poster, banner, etc.

� Preferences button. Opens the Preferences dialog box in which you may set user
preferences.

� Toggle Project Window. Toggles the project window on and off. If the Site Manager
window is display is on (i.e., it is visible), clicking on the button will turn it off. If it
is off, clicking on the button will turn it on.

� Toggle Help Viewer Window. Opens or closes the DesignShop Help window.

� Generate Web Site. Creates all of the necessary HTML and resource files necessary
for a Web site.

� Preview. Opens the Internet browser with the active Web page so that you may see
what the looks like in a browser.

The Physical Layout Toolbar
The Physical Layout toolbar displays when the Physical Layout window is active. This
tool bar includes:

� Create folder button. Creates a new folder in the physical layout of the Web site.
The new folder is given a temporary name of “Folder” plus a number. You can enter
a new name for the folder in the space provided.

� Create image button. Enables you to insert a holder file for an image that you wish
to insert into a page. After you create the file, you can double click on it to open the
DesignShop Graphic Editor window. This feature enables you to create JPEG, GIF
(87a format), and transparent GIF (89a). For convenience in organization, it is a
good idea to place all of the images for a Web site in one central folder. The Physical
Layout module automatically creates an Images folder that you can use to store graph-
ics. To place an image in the Images folder, click once on the Images folder and then
click on the Create Image button.

� Rename button. Enables you to rename any folder or file in the
Web site. When you click on the button, the name editor be-
comes active permitting you to enter a new name. To exit the
rename feature without changing it, press the ESC key.

� Delete button. Removes the selected folder or file from the Web
site.
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The Logical Layout Toolbar
The Logical Layout window enables you to add, move, and delete individual pages in
your Web site. It displays an organization-type chart showing the relationship of the pages
to one another.

� Zoom In button. Increases the magnification view of the Logical Layout window.

� Zoom Out button. Decreases the magnification view of the Logical Layout win-
dow.

� Zoom Normal button. Returns the Logical Layout window display to normal.

� New button. Adds a new page to the Web site. The new page is added beneath the
page that  is currently selected.

� Delete button. Deletes a page from the Web site.

� Rename button. Enables you to rename a page in the site.

� Properties button. Opens the Properties dialog box so that you can set the proper-
ties for a page including the title, an alias, and any header or footer.

� Visual Settings button. Opens the Visual Setting dialog box so that you can select
the visual settings, such as background color, text link colors, encoding, and mar-
gins.

� Global Search button. Enables you to search the entire Web site for a particular
piece of text.

� Global Replace button. Enables you to complete a search and replace operation for
the entire Web site.

� Global Spelling button. Performs a spell check of all pages in the Web site.

� Database Structure button. Opens the Database Wizard dialog box in which you
can specify the database tree to use in the page.

The Navigate Layout Toolbar
The Navigate Layout window displays all of the pages and resources of a Web site. This
view is useful for viewing the relationship of each page to other pages as well as to exter-
nal Web sites. If you add a new page to your Web site in the Logical Layout window, you
will have to use the Refresh option in the Navigate Layout window to update the display.

� Zoom In button. Increases the magnification view of the Navigate Layout window.

� Zoom Out button. Decreases the magnification view of the Navigate Layout win-
dow.

� Zoom Normal button. Returns the Navigate Layout window display to normal.

� Show Always button. Toggles the display to show all of the links in the site.

deletezoom in

rename

properties

site visual
settings

global
replace

global
spelling

global
search

database
structure

newzoom out

zoom
normal

page visual
settings



5–5

The Web Site Designer

 �  �  �Internet DesignShop - User Guide

� Refresh button. Refreshes the Web site display. It functions in a manner similar to
the refresh or reload button in a browser. When you click on it, DesignShop reads the
site structure and displays the current pages.

� Include Pages button. Toggles the Web page display on and off. If this feature is
turned off, the individual Web pages do not display.

� Include Resources button. Toggles the resource display on and off. If this feature is
turned off, the individual resources (i.e., image files, etc.) do not display.

� Include External Locations button. Toggles the external locations display on and
off. If this feature is turned off, links to external locations outside the Web site do not
display.

� Show Incoming Links button. Toggles the incoming links to the Web site display
on and off. If this feature is turned off, links coming into the site from other sites do
not display.

� Show Outgoing External Links button. Toggles the outgoing external links to other
Web sites display on and off. If this feature is turned off, links going to other Web
sites do not display.

� Show Outgoing Internal Links button. Toggles the outgoing internal links (i.e.,
links within this Web site) display on and off. If this feature is turned off, outgoing
internal links do not display.

� Show Outgoing Resource Links button. Toggles the outgoing resource links to
resources display on and off. If this feature is turned off, outgoing resource links
within the site do not display.

The Header/Footer Toolbar
The Header/Footer window enables you to enter any number of headers and footers that
you may then assign to a page. This saves you the tedium of having to complete repetitive
tasks for inserting standard information or graphics on pages.

� New button. Creates a new header or footer.

� Rename button. Enables you to rename a header or footer.

� Edit button. Opens the header or footer edit window so that you may edit them.
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� Delete button. Deletes an existing header or footer.

� Set As Default button. Sets the selected header or footer as the default in a Web site.

� Large Icons button. Displays the header and footer files as large icons.

� Small Icons button. Displays the header and footer files as small icons.

The Frames and Page Editor Toolbar
When you wish to edit a particular Web page, go to the Logical Layout window and
double click on the page you wish to edit. The Frames and Page Editor window opens
with the selected page along with the Page Editor toolbar. It displays the Web page, frames,
and any relevant Frame Source Overlays.

� Frame Manager button. Toggles the Frame Source window on and off.

� Frame Sources Combo Box. Selects the frame source for the page or for a particular
frame.

� New Source button. Creates a new frame source for the page.

� Delete Source button. Deletes a new frame source for the page.

� Rename Source button. Renames a frame source for the page.

� Split Vertical button. Splits the active frame into two vertical frames.

� Split Horizontal button. Splits the active frame into two horizontal frames.

� Delete Frame button. Deletes a frame.

� Rename Frame button. Renames a frame.

� Frame Properties button. Opens the Frame Resource Properties dialog box and
enables you to edit the properties of the active frame or for all frame sources of the
active frame.

� Frame Visual Settings button. Opens the Frame Visual Properties dialog box per-
mitting you to edit the visual settings for the active frame.

� Insert Header/Footer button. Opens the Insert Header/Footer dialog box permit-
ting you to insert a header or footer into the current frame source overlay of the
active frame.

� Set as Main Frame button. Sets the active frame as the main frame for the page.

Please refer to Chapter 7 for additional information on these tools and how to use them.

The Standard Toolbar
The Standard toolbar for the Page Editor window features a number of tools that help you
create and edit a page.

� Visual Settings button. Opens the Visual Settings dialog box so that you can edit the
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visual settings only for the current active frame source.

� Paragraph button. Opens the Paragraph Properties dialog box in which you can
edit the text attributes for text alignment, margins, word wrap, and indentation. You
can also edit the paragraph Bulleting and paragraph Numbering attributes in this
dialog box.

� Font button. Selects a particular font, style (i.e., italic, bold, etc.), size, and color.

� Object Properties button. Opens the Image Attributes dialog box and enables you
to edit the object attributes including border, alignment, alternate text, and spacing.

� Form Properties button. Opens the Form Properties dialog box in which you can
edit the form name, CGI settings, variables, and form fields.

� Global Search button. Opens the Find dialog box and enables you to search the
entire Web site for a particular text string.

� Global Replace button. Opens the Replace dialog box and enables you to do a
search and replace across the entire Web site for a particular text string.

� Search button. Opens the Find dialog box and enables you to search the current
page for a particular text string.

� Replace button. Opens the Replace dialog box and enables you to do a search and
replace in the current page a particular text string.

� Global Spelling button. Performs a spell check for the entire Web site.

� Spelling button. Performs a spell check for the current page.

� Show/Hide Paragraph Symbol button. Toggles the display for many hidden con-
trol symbols (i.e., symbols for paragraphs, indents, tabs, returns, etc.) on and off.

The Formatting Toolbar
The Formatting toolbar includes tools to use in implementing format commands for a Web
page.

� Style Combo Box. Selects the HTML font style for current paragraph.

� Font Combo Box. Selects the HTML font name for the selected text.

� Size Combo Box. Selects the HTML font size for the selected text.

� Bold button. Converts the selected text to bold style.
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� Italic button. Converts the selected text to italics style.

� Underline button. Converts the selected text to underlined.

� Align Left button. Aligns the selected text flush left.

� Center button. Aligns the selected text to the center.

� Align Right button. Aligns the selected text flush right.

� Bulleting button. Turns on/off the bulleting of paragraphs. When the feature is on,
each paragraph in the selected text is preceded by a bullet.

� Numbering button. Turns on/off the numbering of paragraphs. When the feature is
on, each paragraph in the selected text is preceded by a number.

� Increase Indent button. Increases the amount of indentation for the selected text.

� Decrease Indent button. Decreases the amount of indentation for the selected text.

The Insert Object Toolbar
The Insert Object toolbar provides
quick access to tools used in plac-
ing various objects in a Web page.
The default location for the Insert
Object toolbar is vertically down
the right side of the DesignShop
window. As with most toolbars in
the program, this toolbar can be
undocked and placed elsewhere. If
you undock this toolbar, it is arranged with the buttons in the direction you dock it. To
undock the toolbar, click inside the toolbar outside of a button and drag the toolbar to the
desired location. You may toggle the display of this toolbar on and off in the View menu.

� Navigation Bar button. Opens the NavBar dialog box enabling you to edit the prop-
erties of the navigation bar you wish to insert.
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� Form button. Inserts a form into the current page. Forms are used to get a response
from the user. The response may be as simple as selecting a Submit button or as
complicated as filling out an order form.

� Link button. Opens the Link dialog box enabling you to insert a link into the current
page.

� Bookmark button. Opens the Bookmark dialog box enabling you to add a book-
mark to an object (i.e., text or graphic) on a page.

� Table button. Opens the Table Properties enabling you to insert and edit a table in
the current page.
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� Image button. Opens the Image Properties dialog box in which you can place an
image into the current page. You can select an image from a DesignShop library, a
Web resource (i.e., an image already used), or import an image file.

� Horizontal Rule button. Places a Horizontal Rule (i.e., a graphic bar used as a
divider) at the location of the cursor in the page.

� Text button. Opens the Import Text dialog box that enables you to import a text file
(or part of a text file) directly into the current page.



5–11

The Web Site Designer

 �  �  �Internet DesignShop - User Guide

� Java Applet button. Opens the Java Applet Properties dialog box in which you can
select a Java applet to insert and set the properties.

� Embedded Object button. Opens the Embedded Object Properties dialog box in
which you can select a GIF, video, sound, or other multimedia file to embed in the
current page.

� Special Text button. Opens the Special Text dialog box in which you can select the
Mail to, date, or copyright features to insert into the current page.
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� HTML Code button. Opens the HTML Code Editor dialog box in which you can
enter HTML code to insert into the current page.

The Form Fields Toolbar
The Form Fields toolbar is used when you are insert-
ing a form into a Web page. The toolbar is only ac-
tive (i.e., visible) when the Form button on the Insert
Object toolbar is selected. The buttons in the toolbar
permit you to select the type of form to insert into a
Web page.

� Text Line button. Inserts a box that accepts a
single line of text.

� Push Button button. Inserts a push button form object.

� Check Box button. Inserts a check box form object.

� Radio Button. Inserts a radio button object.

� Combo Box button. Inserts a drop down combo box form object.

� List Box button. Inserts a list box form object.

� Text Box button. Inserts a text box form element that can accept multiple lines of
text.

Starting a New Web Site
To start a new Web site:
1. After you open DesignShop, click on the File > New menu options to start a new

Web site.

2. In the New dialog box, click on the Web Site tab.

3. The New dialog box displays a library name and the templates in that library. The fist
template (the box with an “X” in it) is a blank template (i.e., no content). To select a
library, click on the down arrow to the left of the library name.

4. To open a template, double click on it or click on it once to select it and then click on
the OK button.

When the new Web site opens, DesignShop displays the Site Manager window with the
tabs for the Physical Layout, the Logical Layout, the Navigate Layout, and the Header/

list box

text
box

radio
button

push
button

combo
box

check
boxtext line
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Footer windows. To turn the Site Manager window display off (useful when working on
individual pages), click on the Toggle Project Window button in the main toolbar or click
on the View > Project menu options.

To save a project:
1. To save a Web site project, click on the Save button in the main toolbar or the File >

Save menu options.

2. Select the path (i.e., drive and folder location) where you wish to save the file.

3. In the Save as Type drop down list, click on the Internet/Intranet DesignShop  Files
option.

4. Click on the Save button.

DesignShop enables you to insert text and graphics into Web pages. In addition, the appli-
cation gives you the ability to save Web sites as templates that may be used as starting
points for other Web sites. Before you can save a Web site as a template, at least one of the
objects (a text or graphic object) must be converted to a placeholder. It indicates the
object’s size and location, but it does not contain an object.

To save a project as a template:
1. After you have converted one of the objects in the Web site to a placeholder, you can

save the site as a template. To convert an object to a placeholder, click on it to select
it and then click on it with the right mouse button to open the drop down menu. Click
on the Show > As Placeholder menu options.

2. Click on the Save button in the main toolbar or the File > Save menu options.

3. Click on the path (i.e., drive and folder location) where you wish to save the file.

4. In the Save as Type drop down list, click on the Internet/Intranet DesignShop  Tem-
plates option.

5. Click on the Save button.

To open a project:
1. Click on the File > Open menu options to open an existing Design Web Site project.

2. In the Open dialog box, select the path (i.e., drive and folder location) where the file
is stored.

3. In the Files of Type drop down list, click on the Internet/Intranet DesignShop  Files
option to open a DesignShop file. Click on the Internet/Intranet DesignShop  Tem-
plates option to open a DesignShop template.

4. Click on the file that you wish to open.

5. Click on the OK button.

DesignShop stores Web sites in a consolidated single file that includes all of the pages and
resource files (i.e., graphics) needed to create the Web site. When you are ready to gener-
ate the Web site files, you must use the Generate Site option.

To generate a Web site:
1. Click on the Generate Site button in the main toolbar or click on the File > Generate

Site menu options.

2. In the Browser for Folder dialog box, select the folder in which you wish to generate
the Web site files. The Web site is created in a folder labeled WebSite within the
folder that you select.
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3. Click on the OK button to generate the Web site files.

Since DesignShop keeps the entire Web site in a single file until you generate it, you
cannot use a standard browser to view the files outside of DesignShop. DesignShop in-
cludes a compatible browser which you can use to view Web pages before they are gener-
ated. In addition, DesignShop includes a feature that enables third party browsers, such as
Netscape Navigator and Microsoft Internet Explorer, to access and display the pages without
having to generate the entire site.

To view a page in a browser:
1. Click on the Preview button from the main toolbar or click on the File > Preview

menu options.

The browser used in the Preview feature is set in the user Preferences module. You can
add or remove different browsers to the list to give you greater flexibility in testing your
Web pages.

To set the browser preference:
1. Click on the Preferences button in the main toolbar or click on the File > Preferences

menu options.

2. Click on the Browsers tab in the
Preferences dialog box.

3. In the Browsers box, click on the
Add button to add a new browser
to use.

4. To modify a browser entry, click
on the browser in the list and
then click on the Modify button.

5. To remove a browser entry, click
on the browser in the list and
then click on the Delete button.

6. If you wish to set a particular
browser as the default browser,
click on the browser in the list and then click on the Default button.

7. Click on the OK button to save the changes.

Inserting Links  
You can insert links in your page. Links can be placed on text, graphic images, Book-
marks, Multimedia object and other Web resource objects. The method is the same for all
objects.

The following example describes how you can place a link on a text in your Web page. For
this example we will use one of the example files included on your program CD.

To insert a link in a page:
1. Start the program and select the Web Site component.

2. Click on the File > Open menu options.

3. In the Open dialog box, select the file from the program CD, <cd drive>\WEB
EXAMPLES\TUTORIAL\QUICK  START\GOLD_EASY_1.CNQ file.
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4. Click on the Open button to open the file.

5. Click on the Logical Layout tab in the Site Manager window.

6. Double click on any page you want to insert a link in to open that page.

7. Place the cursor in your Web page, and type the following:
Click here to go to the details section of my Web site.

8. To make the words “Click here” be a link, use the mouse and select these two words.

9. Click on the Insert Link icon from the Insert Object toolbar to open the Link dialog
box.

This dialog box has five tabs. They provide a comprehensive set of features to select and
set all kinds of links and link attributes. By default the To Page tab is open. It includes a
Page window. This window lists the names of all the logical pages in your current Web
site project. These are all the choices of the logical pages you can link to. To set this link
to go to any one of the pages listed, click on the page name in the list. It will be selected.
Click on Assign URL button. The link will be set.

If the page you are linking to has a bookmark, then you can set the link to go to the
bookmark location on that page. To do this, click on the name of the page you want to link
to, and in the bottom for the Link dialog box click on the Bookmark combo box. It will
display the list of bookmarks you have on that page. Select the bookmark you want to link
to.

Sometimes, you may want to insert the actual text for the link in the Link dialog box. This
is more for convenience purposes. If you want to do that, simply enter the text you want to
show on the Web page, then click on the Replace Link button. The text you entered will be
placed on the Web page instead of any text you had selected, and it will be a link.

If you do not select a text or an object on the Web page, you can insert the actual text to be
the link right in the Link dialog box. To do this, without selecting any text on the page,
click on the Insert link Icon. In the Link dialog box enter the actual text you want in the
Link Text field at bottom of the dialog box, click on Insert Link button.

To Delete a Link
To delete a link you had previously set, select it in the Web page and click on the Link
icon. Click on the Delete Link button in the Link dialog box. The link will be removed
from the selected text.

Insert Link to Open New Browser Session
Besides the regular link previously described, you can also insert a special type of a link,
which will force the browser to open a new session and display the linked page. Under
normal conditions, when you place a link and the viewer using a browser clicks on this
link, the browser places in the same window the page where the link points to. However
you can set the link to activate a new browser session. In such a case, the old current page
remains on the screen and a new browser window opens up with the new page.

To insert a link to activate a new browser session:
1. Select the text in the Web page that will serve as the link.

2. Click on the Insert Link icon.

3. In the Link dialog box, check the Open in New browser check box.

4. Click on Assign URL button. Now when a viewer clicks on the link, the browser will
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open a new window and place the referenced page in the new window.

Type in Link Mode Selection
Instead of entering your text first in the Web page and then selecting it, you can type in
link mode. Everything you type becomes a link.

To type in link mode:
1. Place the cursor in the page where you want to start entering text.

2. Click on the Insert link icon.

3. Click on the Lock Link mode button.

4. Enter the text you want to use as a link. Everything you enter will be a link.

5. After you finish entering the
text, click on the Insert Link icon
and then click on the Lock Link
mode button. The Insert Link
button will stay depressed. You
can now type in the page and all
your entered text will be link.

6. When you want to switch to
back normal mode and disable
the lock link mode, click on the
Link icon in the toolbar.

When you insert a link to another
page, the browser places the linked
page in its window with all its re-
sources including any frames or frame
source overlays that the page contains.

Inserting Relative Links
Links can be fixed or relative. A fixed link provides access to a specific page or to a
specific location on a page. A relative link links to another page or location relative to the
links position

To insert a relative link:
1. Select the text or object on the Web page you want to link.

2. Click on the Insert link icon.

3. Click on the Relative tab.

4. From the list of available Link
to pages or Frame Sources, se-
lect the type to which you wish
to link. For example, if you se-
lect the Next Sibling from the
list of Link to, the link will
point from the current position
to the next sibling logical page.
The next sibling is the one to
the right of the current page in
the Logical Layout. The Last
sibling is the right most logi-
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cal page on the same row of
pages in the Logical Layout. The
First Sibling is the first logical
page in the same row. The Pre-
vious, Next and Last Frame
Sources are sources of the same
frame.

Linking to any other frame
or frame Source Overlays
on the same page
In the previous section, we described
how to insert a link from one loca-
tion to another page. Since pages can
have different Frames, and frames can have many Frame Source Overlays, DesignShop
enables you to insert links to any of these resources.

To link a text or an object on your Web page to another frame on
the same page:
1. Select the text or object you want.

2. Click on the Insert Link icon.

3. Click on the To Frame tab.

4. The Frame window lists all the currently available frames on the same page your
cursor (or object) is. Click on the frame to which you wish to link.

5. If the frame you selected to link to has more than one Frame Source Overlay, you can
specify which Frame Source Overlay to which you wish to link. To do this, click on
the Frame Source Overlay combo box and select the Frame Source you want.

6. If the Frame Source Overlay you selected has one or more bookmarks, you can click
on the Bookmark Combo box, and select the Bookmark to which you want to link.

Insert a Link to multimedia and graphic objects, and other re-
sources
In addition to inserting links that point to pages, frames or bookmarks, DesignShop en-
ables you to insert links that point to graphic objects, multimedia objects, files and other
resources. When the viewer clicks on such a link in the browser, the browser launches the
corresponding program and displays
the image or loads the file or plays
the music.

To insert a link in the page
that points to a multimedia
object or other resource:
1. Double click on the At-Work

page from the Logical Layout.

2. Click on the word Office then
click on Insert Link.

3. In the Link dialog box, click on
the To Resource tab.
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4. The Resources window displays the Physical layout of all your resources. To link to
one of the images double click on the Images folder in the list. Click on the Image1
to select it. Click on the Assign URL button. The link is now set to point to the
Image1 file.

5. To really see what this does, click on the Preview icon. This will bring up the browser
and display the current page.

6. Click on the text office, which is a link to the image. The browser will launch what-
ever application is needed to run or display the graphic image. The application is
usually preset by windows on your PC and the viewer can reset it. Had this been a
.WAV file the MIDI player would have been launched and you would have heard the
music play.

To Insert External Links
You can insert a link to any external URL location you like.

To insert a link to an external resource:
1. Open the At-Work page of your example site.

2. Select the words West building.

3. Click on the Insert Link icon from the Toolbar.

4. Click on the External tab.

5. In the URL field either choose the URL prefix or enter it, and enter the exact address
of the external URL. If you have entered external links before, they will be listed in
the External links window. You may click on any one and select it.

6. Click on the Assign URL button.

Navigation Bars (NavBars)  
DesignShop has a Navigation Bar (referred to as NavBar for short) feature that enables
you to insert navigation bars with text or buttons. The main purpose of NavBars is the
links that are created from the buttons to the different parts of your Web site. NavBars can
be placed in a horizontal or vertical orientation. They are perhaps one of the easiest and
the fastest methods to automatically place links in your pages. The NavBar feature makes
the problem of broken links a thing of the past. NavBars can be placed on any page that
you want. You can also place them in the Headers or Footers of pages. If you place them
in the Header or Footer of the page, the NavBar will automatically be replicated and
placed on all appropriate pages of the Web site.

To create and insert place a NavBar:
1. Click on the Navigation Bar icon or click on the Select Insert > Navigation menu to

open the NavBar Properties dialog box.

2. Click on the Type tab.

3. Check the To Other Pages radio button in the Navigation section. This will create
NavBars where the links from each button of the NavBar are links to other pages of
the site.

4. In the Style section, check the Home and first level pages. This will insert NavBars
on the pages. The NavBars will have enough buttons to include links to the home
page (from each page) and to every page of the first level. First level Web pages are
all the pages directly below (or children to) the Home page in your Logical Layout.
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5. DesignShop enables you to insert
NavBars that can be alphanumeric
text or graphical Images. Text
NavBars are the simple type. They
have the names of the Web pages
in the bar as text only. Each name
is a link to its corresponding page.
The Image type NavBars are more
interesting. Each NavBar button
can be an image or picture. Check
the Image radio button to place
graphical Navbars in your Web
pages. The program includes a li-
brary of NavBars that has hundreds
of graphical images especially
made for NavBars. If you did not
installed this library during instal-
lation then the program provides
you with a few to work with.

6. In the Orientation section, check the Horizontal check box . You can set NavBars to
appear Horizontally or Vertically on your Web pages.

7. Click on the Baseline radio button in the Alignment section.

8. Click on the Style folder tab. The groups of Web pages listed in the window on the
right have checkboxes. Use this window to assign different settings for each group of
Web pages. For example: all First level Web pages can have a certain font and color.
Or you can select all the groups in the list and apply your settings globally to all of
them. For this example we will create NavBars which will be consistent in all pages.
Make sure the checkboxes for all the Web page groups listed are checked.

9. To make it interesting, make the button that links to the home page a different color
or image. To do this use the shift key and click on every group name in the list to
select all the groups except the one that says Home Page button.

10. Click on the Font button. In the Font dialog box choose the font style, size and color
for the font. This font
will be used for the text
of the button label.
These labels will be
placed on each button of
the NavBar. You can
choose from any of the
fonts installed on your
PC. Choose Times Ro-
man, click on Bold, and
select size 10.

11. Click on the rectangular
button next to the Image.
You can choose from
many button images. If
you have installed the
image library during
your installation, you
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should have many groups of pre-designed colorful buttons to choose from.

12. Click on Wide Rectangle buttons from the pull down menu. Select one of the buttons
you like. These buttons will be placed one next to the other in the NavBar. If you had
selected a Vertical NavBar these buttons would have been placed vertically one above
the other. Each button will be a link to another page. Click OK.

13. The buttons with text labels will be placed in the sample window of the dialog box.
If you do not like the size of the text, click on Font button and change the font size.
Remember some of your link names are longer than one word. They are the names of
the Web pages you set in your Logical Layout. Be careful not to make these labels
too big.

14. The program places the text label right in the center of each button. You can change
the position of the labels with respect to each button. In the Font section of the dialog
box, the two pull down menus give you options to position the text on or around the
buttons.

15. Now click on the Home Page button group in the list and select it. Make sure that the
check box is also checked. Select only this group from the list.

16. Click on the Font button and select Ariel for this button. Click on the Image button
and choose another image for the home page button.

17. The Spacing option enables you to move the buttons closer to each other or push
them farther apart. Enter zero for spacing if you want the buttons touching each other
with no space in between.

18. Click OK. The NavBar you created will be placed in the Web page.

You can insert NavBars in Headers or footers of Web pages. When you insert a NavBar in
a Header or a Footer, it is inserted on all pages of the Web site. Notice that the footer and
the NavBar you created is on every page.

If you want to insert the NavBar in the Header or the Footer you must ensure that the
preferences settings are set accordingly. If the settings of the program preference are not
set to insert Headers/Footers by default, then you must manually insert this footer in the
page.

To manually place a NavBar in a header or footer:
1. Place your mouse in a page you want to insert the footer in and click on the Insert

Footer Icon

2. The Header/Footer dialog box opens enabling you to change the settings to insert the
Footer and click OK.

3. The Footer and the NavBar are placed on the page. You can always double click on
a NavBar and change its design.

To give more style to a NavBar you may add more items to it. These could be other
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graphic images such as logos, pictures, animated GIF’s or other objects. You can place
them at the front or at the end of the NavBar. Simply create or import an image and place
it in the Footer or the Header where the NavBar is.

Examples of  NavBars you can create are:

Now that you have inserted NavBars throughout your Web site, you can see that Design-
Shop has inserted links in the pages. Click on the Site Manager tab at the bottoms of the
window. Click on the Navigate Layout tab. The program displays the graphical picture of
the entire site. This is a bird’s eye view. You can zoom in and zoom out to see certain parts
of the site in more detail. As you can see the arrows between the pages indicate links
between them. These are the links of the NavBars you inserted.

Refer to the section on Graphic Image editing for more details on creating or working with
graphic images.

Inserting Bookmarks  
When you insert a link from one page of your Web site to another, the person viewing
your Web site will be sent to the top of the page being linked to. However, bookmarks give
you the added advantage of sending the visitor to a specific location on a page. After you
set a bookmark on one page, you can link to it from any of your other pages. The beauty
and main purpose of a bookmark is that it directs the viewer to a specific location on a
page (where the bookmarks is) and not to the top of that page. By default, when you place
a link to another page and the viewer clicks on that link, the browser places on the viewer’s
window the new page. The browser’s window will open with the top of the page visible on
the screen. However, if the specific information you like the viewer to see is somewhere
else on the same page, then the user needs to scroll down or right to find it. Bookmarks
enable you to take the user directly to the location on the Web page want them to see first.

To make this work you must first set a bookmark on a page. After you set a bookmark, you
can link to it from any other location in your Web site.

To create a bookmark:
1. Open a page in your Web site, or from the Logical Layout of the Site Manager double

click on the home page.

2. Place the cursor in the page where you want to insert the bookmark.

3. Click on the Insert Bookmark icon to open the Bookmark dialog box.

4. Enter an alphanumeric name for the Bookmark in the Bookmark Name field. This
will not be visible on the page. It is used by the browser to identify the different
bookmarks of your site. Make sure you
enter a different bookmark for every new
bookmark you create. To avoid possible
problems with browsers do not use spaces
or / : “ < > > + # characters.

5. If you had entered other bookmarks before,
the program will list them in the Bookmark
List window. If you want to use any one of
the bookmarks listed, click on it from the
Bookmark List.

6. Click on the OK button. The program will
place a bookmark in the page.
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7. To insert links that point to this bookmark, select the text, graphic or other object on
the page and click on the Insert Bookmark icon. Click and select the To Page tab. You
can also apply the link to bookmark on another frame. To select a frame where the
bookmark is, click on the To Frame tab.

8. Click and select the Web page you want to link to. Click on the Bookmark combo
box (drop down menu) and select the bookmark you want. Click on Assign URL.
This will insert a link which will be a link to this bookmark. When the viewer using
a browser clicks on this link, the browser will bring up the page the bookmark is on,
and will place the bookmark area at the top of the visible screen window.

For example: There is a small Web site on your program CD named myWeb. In this
example we will place a bookmark in one of the pages and test it. Place the program
CD in the CD ROM drive. Click on Exit if the Welcome screen is displayed. Start the
Internet / Intranet DesignShop  program

9. From the program menu select File > Open and open the Web site called myWeb.
You will find it in the program CD in the Examples folder. Click on the Logical
Layout tab of the Site Manager. This Web site has three pages, the home page, and
two First Level pages called businesslife and familylife.

10. Double click on the Home page. In the Home page you want to place a link on the
word “daughter’s.”  When a viewer clicks on this word (or this link) we would like to
have the family page brought up and the description of the daughter be placed in the
top of the page in the browser.  The way to do this is to place a bookmark on the
description of the daughter in the family page. Then place the link in the homepage
to that bookmark.

11. To do this double click on the familylife page in the Logical Layout of the Site
Manager. Place the cursor right before the words Ani Coolian. Click on the Insert
Bookmark icon from the Insert Object Toolbar. The Bookmarks dialog box is dis-
played.

12. Type in a name for the bookmark in the Bookmark Name field. This is a name used
internally by the program and it enables the browser to differentiate this bookmark
from others. It will not be visible on the page. Bookmark names should have no
spaces or extended characters. For this example, enter the word Anibookmark.

13. If you had created bookmarks in this Web site before, the Bookmark List in the
dialog box will display all existing Bookmarks. If you want to use a bookmark listed
in the Bookmark List window, click on it to select it.

14. After you have entered the bookmark name, click OK. The program inserts the book-
mark in the page and places a symbol of a bookmark on the page.

15. To link to this bookmark from the home page, go to the Logical Layout window and
open the Home page.

16. Find the word “daughter’s” and select it.

17. Click on the Insert Link icon from the Insert Object toolbar.

18. In the Link Dialog box To Page tab, click and select the familylife.

19. Click on the Bookmark combobox.

20. Click on the anibookmark from the list of available bookmarks

21. Click on the Assign URL button.

The procedure is finished. When the viewer clicks on the “daughter’s” link, the browser
will display the family page with the section on the Ani Coolian being at the top of the
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browser screen.

To see test this yourself, click on the Preview icon from the toolbar. The browser is dis-
played and it shows the current Web site. Click on the daughter’s link in the home page.
The Bookmark page will come up and the Bookmark text will be visible on the screen.

Inserting Tables  
Tables are a good way to organize data in a Web page in a columnar fashion. Since an
HTML Web page does not work exactly like a word processor screen, the normal tabs and
paragraph indentation of a word processor are not fully available for you to use. Instead,
a table is used to achieve the same or similar purpose. You can insert a table anywhere in
a Web pages. Because tables require additional
memory resources, they should be used with care to
avoid slowing the page download. Place only the num-
ber of rows and columns that you need. Do not create
tables where some of the rows or columns are empty.
Headers can have different dimensions, captions, ver-
tical and horizontal border lines and may include text
or graphics depending on the program.

To insert a table in your Web page:
1. Open the page to receive a table. You may also

double click on the home page from the Logical
Layout of the Site Manager and open the home
page.

2. Place the cursor on the page at the point your
wish the table to be inserted.

3. Click on the Insert Table icon from the Insert Web
Object Main toolbar or click on the Table > Insert Table menu to open the Table
Properties dialog box.

Table size
The program enables you to specify the size of the table. To specify the size of the main
body of the table, enter the numbers that you want for the Rows and Columns in the Cells
section. Note that tables consume additional computer memory resources.  Do not create
a table larger than the size you need. Each table can be no more than 50 rows. You can,
however, place more than one table on a page.

Note: Make sure that you save your work often when you are inserting tables in a Web
page. Tables are very memory intensive. It is also recommended that you close all
other Windows applications when working with tables to free as much memory as pos-
sible.

Table Header and Footer Cells
You can insert a Header and Footer in tables as with a Web page. By definition, a header
cell in a table is defined as a cell in which the text is bold and centered in the cell. The
footer cell is the one in which the text is bold and left justified in the cell. Another impor-
tant point about table headers and footers in a table is that you may have as many headers
and footers in a table as you like. A header or a footer does not have to be a complete row
of cells. You can set a single cell of a table to be either a header or a footer. You can even
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select a single cell in the middle of the table and set it to be a header. Setting the cells to be
headers and footers is simply a matter of convenience. You can take any cell of a table,
select it, and manually set the text inside to be bold and left justified. However, instead of
doing this manually one by one, you can select the cell and set it to be a Header or a
Footer.

The program enables you to specify which rows in the table are Headers or Footers. The
Header rows are always at the top most part of the table. The Footer rows are at the bottom
of the table. Headers and Footers are not a separate set of cells. They are part of the main
body of the table, but are designated to be either Headers or Footers.

To insert a table in a page:
1. Click on the Insert Table icon from the Insert Web Object Toolbar to open the Table

dialog box.

2. Enter the numbers of rows and columns you want for the table in the Number of
Rows and Number of Columns fields.

3. To specify which of the top rows of the table are headers, enter the number in the
Header Rows field of the Cells section.

4. To specify which of the bottom rows of the table are footers, enter the number in the
Footer Rows field of the Cells section.

5. The number you enter for the rows of the table should include the rows for the fol-
lowing three sections of the table: (1) the header part, (2) the main body of the table,
and (3) the footer part.

6. For example if you specify the number of rows to be the same as that of the header
rows plus the footer rows, the main body part of the table will have zero rows.

Any text that you enter in the Caption and Header parts of the table are centered by
default. Header and Footer text are bold by default. However, you can change these at-
tributes after you enter the text. For example, if you want to left justify the text in the
Header, select the header cell and click on the Justify Left icon from the Text Format
Toolbar.

Note: To change the attributes of a table, select the table on the page, place the mouse
on the table and right click. From the pop-up menu select the Object Properties to
display the Table dialog box.

Table Dimensions
You can set the units of measure used for the table to be in pixels or Percent size. This is
the dimension of the entire width or height of the table. The default setting is Auto. This
means that after you set the table on the page, you cannot change the width or the height.
It is changed automatically by the program, based on the amount of text or other objects
you insert in the cells.

Dragging table boundaries to resize
You can set the dimension of the table to be resizable and not automatic. This will enable
you to drag the borders of the table by dragging them on the Web page. To set this the
dimensions for variable resizing, check the Pixels radio buttons for the Width and Height
of the table in the Table dialog box. Now when you insert this table on the Web page select
it to resize the borders. The program places an outline with dragging handles around the
table.
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To resize a table:
Using your mouse, drag any of the handles.

Borders, Cell Padding, and Cell Spacing
Table cells have borders, cell paddings and cell spacings. The bor-
der of a table is the outermost frame or four bounding sides of the table. You can enter any
number in pixels to be the thickness of this border in the Border Size field of the Table
dialog box.

The padding of a table is the extra space added inside each cell and it forces the text or
objects inserted in the cell to be positioned away from the border of the cell. The more
padding you specify for the cells, the
farther apart will the contents of the
cells be from the boundaries of the
cells.

You can specify the padding size by
entering a number in pixels in the Cell
Padding field of the Table dialog box.

The cell spacing of the table is the actual width of the border line surrounding each cell.

If you want the border of each cell to be thick, then enter a high number in the Cell
Spacing field of the Sizes section in the Table dialog box.

If you do not want the table borders and paddings to show, enter 0 in these fields. The
program will display temporary dotted lines instead of actual borders. This will help you
change the sizes of the columns or rows and work with the table. However, the browser
does not show the dotted line borders.

Table Caption
You can also place a caption for a table.
You can insert the caption either on the top
of the table or below it (but not both). To insert a caption check the Create checkbox in the
Caption section of the Table properties. Select one of the radio buttons for Top or Bottom
caption. The caption will be placed at the top or bottom of the table.

Only the cell padding size applies to captions. The same cell padding you enter in the
Sizes section will apply for the caption. Captions do not have visible borders or cell spac-
ing.

To place a caption on the table, check the Create check box in the Caption section of the
dialog box and then check the Top or Bottom radio buttons.

Note: To change the attributes of a table, select the table on the page, place the mouse
on the table and right click. From the pop-up menu select the Object Properties to
display the Table dialog box.

Table Justification or Alignment
You can justify the table horizontally in the page. Due to the special table characteristics
as defined by the HTML language or browsers, the normal text justify icons in the toolbar
are not used to justify tables. Instead the Justification or alignment of tables is done with
settings inside the Table dialog box. To do this,  select your choices in the Alignment
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section of the dialog box.

To justify the table click on one of the Left, Center or Right radio buttons. You can also set
the table to be in float mode. This mode allows the text (not the table) to wrap around the
table. If you Check the Float checkbox, you can also check the table to be aligned right or
left. If you want to table to be aligned left and have text wrapped around it, then check the
Float and the Left check boxes.

If you check the Float check box and the Right Align radio button, the table will be
aligned to the right side of the screen and the text will be wrapped around it around the
top, left and bottom sides of the table.

Note. When you Left, Center or Right align a table it does not stay fixed at these loca-
tions. It will move according to the browser’’ visible screen window. For example: If the
browser screen window is made narrower, then a Right Aligned table will not fall out of
the screen but will be moved to the left along with all the wrapped text.

Moving a Table
You can always select a table and drag it to a new location on the page. As you select the
table and start dragging the mouse, the program will display a small square at the edge of
the mouse designating the table move. You can drag the table to any other location on the
page where there are text or object lines already inserted. If you want to drag the table
beyond the line limits, you must add more lines or enter spaces first.

After you drag and drop the table, it may not be placed exactly where you dropped it. It
will be placed as close as possible to the point where you dropped it. The final position
will be controlled by the justification and alignment options that are set for the table. You
can change these settings in the Table dialog box.

Editing Tables
To change the text inside the cells of the table, click in the cell and delete or add text. To
modify the attributes of a table itself, double click on the table and click on the Format >
Object > Properties menu options. You may also click once on the table to select it, then
click the right mouse on the table to open the drop down menu. In the menu, click on the
Object > Properties to open the Table dialog box.

In the table dialog box, you may change the table options. There are certain rules you
should remember when you change the attributes of a table. These include:

� If there is no caption and you check the caption check box in the dialog box, the
caption is added to the table.

� When you change the number of rows and columns, the new cells are added or re-
moved at the right and bottom of the table.

Note: To change the attributes of a table, select the table on the page, place the mouse
on the table and right click. From the pop-up menu select the Object Properties to
display the Table dialog box.

Dragging and Changing the Size of Tables and Cells
You can change the size of cells from inside the Table dialog box. However, you can also
place the mouse on the cell borders and drag them. If you drag the outermost border of the
table, the table size at the cell being dragged will be changed. To change the size of any
cell inside the table, place the mouse on the border of the cell you want do move and drag
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it.

Different columns of the same table can have different widths. However, not all the browsers
support individual column sizes. These features are part of HTML 3 specification. If you
want to create tables that are can be viewed properly on earlier version browsers, such as
those that support release HTML 2, then you should keep the sizes of all the columns in
your Web page the same width.

You can insert text and other objects in the table cells. The cell height for that row of cells
is automatically adjusted to fit the larger sizes of the objects you insert. Similarly, when
you delete objects from the cell the cell height for that row of cells is adjusted automati-
cally.

You can use all the text editing and formatting features on any cell except for backgrounds.
Cell backgrounds are transparent and have the same background as the entire Web page.

Joining Cells, Setting Heights, Widths and Attributes
After you create and insert a table, you can join cells and change the cell attributes.

To join and change cell attributes:
1. Click inside the table in a specific cell that you want to change.

2. Right click  the mouse on the table.

3. Click on the Table > Cell Properties menu options or click on the Select the Table >
Cell Properties menu options to open the Cell Properties dialog box.

4. To make this cell a header cell, check the Header Cell checkbox.

5. You can join cells which are either vertically or horizontally adjacent to one another.
To join two cells in a row where the cells are one next to the other, place the cursor in
the left most cell. Right click  the mouse on the table. Click on the Table > Cell
Properties menu options or click on the Select the Table > Cell Properties from the
program menu. In the Cell Properties dialog box enter the number 1 in the Columnspan
field and click on the OK button. The two cells will be joined. The contents of the
first cell will remain but the contents of the other cell will be deleted.

6. To join two cells in a column where the cells are above one another, place the cursor
in the upper cell. Right click  the mouse on the table. Click on the Table > Cell
Properties menu options or click on the Table > Cell Properties from the program
menu. In the Cell Properties dialog box enter the number 1 in the Rowspan field.
Click on the OK button. The two cells will be joined. The contents of the uppermost
cell will remain but the contents of the other cell will be deleted.

7. To join more than two cells, follow the same steps as described earlier. Enter the
appropriate number for the cells you want to join.

Setting Heights and Widths in Rows or Columns
To change the dimensions of a specific column or row:
1. Click and place the cursor inside any cell you want to change.

2. Right click the mouse on the cell.

3. Click on the Table > Cell Properties menu options.

4. In the Cell Properties dialog box, enter the new size of the row or column in pixels.

5. Click on the OK button.

Note: for this feature to work, you must have the table dimensions set to Auto in the
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Table dialog box. You must do this first before you change the size of each row or
column.

Inserting, Deleting Cells and Justifying Cells
After you place a table on the page, you can insert more rows or columns or delete rows or
columns.

To do this click first on the cell you want to delete, or where you want to insert new cells.
Right click the mouse on the cell and from the pop-up menu select Table option and select
the action you want. A row is inserted immediately above the cell where your cursor is in.
A column is inserted to the left of the cell the cursor is in.

If you want to insert column at the right most edge of the table, or a row at the bottom most
edge of the table, you must increase the number of columns or rows in the Table properties
dialog box.

To Justify the contents of the cells:
1. Click in the cell you wish to justify.

2. Right click the mouse on the cell and from the pop-up menu.

3. Click on the Table option and select one of the alignment options.

Inserting Images and Graphic Objects  
The integrated graphics editor can be used to create new images, use graphic resources
that you currently have in your project, and manage your graphic resources.

To insert a graphic image in your Web page, place the mouse where you want on the Web
page. From the Insert Object Toolbar click on the Insert Image icon, or Select the Insert >
Image menu. The Image Attributes dialog box is displayed. It includes the following op-
tions:

1. Existing Resources tab.

2. Library tab.

3. URL tab.

4. Import button.

5. Create button.

6. Preview window to display the image or the Layout.

7. Alignment options.

8. Horizontal and Vertical
size settings.

9. Border  settings.

Click on the Existing Re-
sources tab to use one of the
existing images of your
project. The Existing Re-
source tab lists all the graphic
resources that you have open
in your current project. If the
window lists any images then
you can click on it to select it,
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then click OK. The graphic will be placed on your Web page.

Note: when you import, create, or use an image from the Library, it is automatically
listed in the Existing resource tab as well as in the Site Manager’s Physical layout. It
becomes part of the current resources of your current project.

Click on the Library tab to use images from the clipart libraries of the program. The
Library tab lists the many pre-designed graphic images that are available to you. If you
had installed the graphic image libraries during installation then these graphic images
would be listed in this tab. To use any one of them, click on the pull down menu and from
any of the groups select a graphic image.

The URL tab gives you the special option of entering a URL address on the internet. You
can do this if you know the exact URL address of a graphic image, and you want your Web
page to show that image. Click on the URL tab If you wan to place the URL of an image.
Enter the exact URL and file name of the graphic image in the field. You must use the
proper URL format. These are http:// and ftp://, for example http://www.graphicworld.com/
animals/lion.jpg. Click on OK and the program will insert a square in your Web page
labeled URL. If you click on the Preview icon, the program goes to that url and places the
image on the page.

The Import button enables you to import a graphic image and place it on the page. To
import a graphic image, click on Import. In the Import dialog box browse or specify the
graphic image you want to import. Click on OK. The Image is listed in the Image Re-
sources tab of the Image Resources window. Check the Preview image check box and
click on the image name. It is displayed in the preview window. You may change the other
settings of the dialog box to change the alignment, size and other attributes. Click OK.
The image is inserted in the Web page.

The Create button enables you to create and compose your own graphic image. To create
an image, click on Create. The Image properties dialog box is displayed. The Image prop-
erties dialog box enables you to specify the exact size in pixels of the graphic you want to
create. Enter 300 for width and 200 for height. In the File Format section check the kind of
image you want to create (JPEG or GIF). The program will generate the image in this
format. JPEG is a true color format and can give clearer images. It can have Millions of
colors. JPEGs are better for photographs and cannot be transparent. GIF images can have
up to 256 colors only. They can be transparent.

Make your selections and click OK. The image name will be listed as a resource in the
Existing Resources folder tab. Click on it to select it.

Check the Preview Layout checkbox to view the alignment of the image and the text of
the page.

Check the Size check box if you want to stretch the image. Enter the new size in pixels for
the image. It is not recommended to do this unless you have a good reason. Usually
stretching raster graphic images does not produce good results.

If you want to add padding or spacing around the image that separates the image from the
text, then check the Space checkbox. Enter the spacing in pixels in the Horizontal and
Vertical fields.

To add a border around the image, check the Image checkbox. Enter the size in pixels for
the border.

The default alignment for the image is Baseline. To select a different alignment click on
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the Alignment
checkbox and select
the type you want.

You may insert alter-
native text. This is
the text that a
browser will display
in place of the image
if the image is miss-
ing. Check the Alter-
native check box and
enter the text you
want.

Click OK. The pro-
gram places a blank image rectangle in the Web page.

You can double click on any image of the Web page to edit it. In the case of creating a new
image, the program enables you to double click on the blank image area to edit or com-
pose the contents of the image.

Double click on the image rectangle which has the label Blank Image. The program places
the blank image in the graphic editing window and provides many new graphic options.
From the menus or the insert object Toolbar   click on the type of graphic you want to
place in this image.

These graphic options include artistic text, Choose/import clipart, Pattern fills, Frames
and borders, Paragraph text, Calendars, business Graphics and OLE.

Click on any of the object types, create or edit the graphic and click OK. The graphic
image is placed in the Web page.

Creating and Inserting Business Graphics Charts
Place the cursor on the page where you want to insert a business graphics or a chart. Click
on the Insert Image icon or Select Insert > Graphic from the menu. In the Image Attributes
dialog box click on the Existing Resources tab. Check the Preview image checkbox.

Click on Create. Enter the size 200 by 200 in the Image Properties dialog box. Select
JPEG file format. If you want the chart to have a transparent background, then choose
GIF. Click OK. The name of the new graphic image is displayed in the Image Resources
window. Click on it once to select it and click OK.

The program places a blank image rectangle in the Web page. Double click inside the
rectangle. Click on the business graphics icon from the toolbar..

The Chart dialog box is displayed.

Click on the Type tab. Over 25 different graphic chart types and variations are available.
Select the type of chart you want. Move the scroll bars around the sample chart to rotate
the chart or widen the chart elements.

Click on the Style tab. Every chart type has different attributes. Choose the options you
want. The sample chart on the right displays your changes.

Click on the Color & Data tab. It includes a table with default values. Use the Add, Insert
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and Delete buttons to add and remove rows or columns. Enter the data for you chart.

Click OK. The chart is created and placed in the Web page. You can drag the handles
around the chart to resize it or drag the chart to move it inside the image area.

Horizontal Rule  
You can insert Horizontal Rule divider lines on your Web pages. They are often used to
divide the Web page into sections and improve the visual look of the page. With Internet-
Intranet DesignShop  you can insert simple rules, three dimensional rules, and graphic
images.

To insert a horizontal rule:
1. Place the cursor on your Web page where you want to place the horizontal rule.

2. Click on the Horizontal Rule icon from the toolbar or click on the Insert > Horizontal
Rule menu options to open the Horizontal Rule dialog box.

3. The Style section in the Horizontal Rule dialog box gives you the three options for
horizontal rules: Simple, 3D Shade, and Image. Click on the radio button for the type
of Horizontal Rule you want to insert.

4. To insert a graphic image as a rule, click on the Image radio button. The Window on
the right displays different tabs and the dialog box adds the Import and Create but-
tons. You may use any graphic image from the set of available resource in your
current Web project, choose from the many libraries included with the program, or
you may import or create an image. This window and its tab controls operate exactly
like the graphic image dialog box.

5. In the Align section of the dialog box check and set one of the Alignment radio
buttons. This will align and justify the graphic image horizontally on the line of the
Web page,

6. The Width Style and Size sections enable you to specify the width and thickness of
the horizontal rule. They also set the units of measurement used, such as pixels or a
percentage of the page width.

7. To select a color for the horizontal rule, check the Specify Color checkbox. The
dialog box displays the color options and color libraries in the sample window.

8. Choose from one for the colors displayed . If you had installed the color libraries
during the initial program installation on your PC, then the program will list many
groups of pre-made color sets. To use any of the color libraries, click on the combo
box and choose from one of the listed color libraries. Remember that there are color
safe libraries which you could use. These are special color palettes created by us and
built in the program. They take into account the Netscape Navigator and Internet
Explorer color palettes. If you use one of these color safe palettes, your pages will
have a better chance of being displayed on these browsers without color dithering.

9. When you have made all your selections click OK. The horizontal rule is inserted in
the Web page.

10. If you want to edit a horizontal rule and change its width or other attributes, select it
on the Web page and click on the Insert Rule icon. Make your changes in the Rule
dialog box and click on the OK button.



Chapter 5

5–32  �  �  � WebPage Construction Kit

Import Text
You may import text and place
them on the Web pages. The pro-
gram supports a number of data for-
mats. It can import ASCII, Note-
pad, Windows Write, Word for
Windows 6.0 and Rich Text For-
mat (RTF) file format documents.
If you would like to import a text
document which is not in one of the
supported formats, you must con-
vert it to one of the supported for-
mats in another application.

You can import text documents
from any Web page. The imported
text is placed in your current page.

To import a document:
1. Place the cursor in the Web page where you want to import the document.

2. Click on the Text icon from the Insert Object toolbar to open the Text import dialog
box.

3. Click on the Files of type combo box and from the list of available file formats.

4. Choose the format you want to import.

5. Enter the name of the file in the File name field or search and find the file using the
Look in window and the file explorer tool of the dialog box.

6. You may view the contents of a file before you import it. To view the document
before importing it, find the file you want to import and click on the View checkbox
in the Import Text dialog box. The program reads the document and places it in the
File Contents window.

7. Use the scroll bars to scroll and view the file. Use the Find button to search and find
for certain items in the file.

Editing Documents Before Importing
The program enables you to edit the document before you import it. This useful feature is
very important in case you are working with a large document or an archive. Most of the
time you may not want to import all the document but only certain parts of it.

To edit a document before importing it:
1. Find the document and click on it to enter the name in the File name field of the

Import Text dialog box.

2. Check the View and Edit check boxes in the File Contents section.

3. Scroll and use the Find and Replace buttons to edit the document. You may also
select text and delete it. You may also enter new text right in the File Contents win-
dow.

4. When you have the document in the form you want it, click on the OK button. The
document will be placed in the current Web page.
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View HTML Code
To view the HTML source code for a page:
1. Click on the Preview icon from the Main toolbar.

2. When the browser displays the current Web page, click the right mouse button any-
where in the page area.

3. Click on the View Source from the drop down menu. The HTML source code of this
page will be placed in a Notepad window. You may view it and print it if you want.

Any changes you make to the HTML code in the Notepad window are not inserted in the
DesignShop file. If you want to edit HTML source and perhaps write your own special
HTML code, you must use the Insert HTML feature in DesignShop.

Inserting HTML code  
You may enter your own HTML code into any Web page. This is useful if you want to
write special HTML code for a feature that DesignShop does not support.

To insert your own HTML code:
1. Place the mouse on the Web page where ever you want to insert the HTML code.

2. Click on the Insert HTML icon from the Insert Objects toolbar to open the Insert
HTML dialog box.

3. Enter the HTML code that you like. You may design a whole Web page if you want.
Although there is no need for this and it is more productive to use the automated
features of the program.

4. Click on the OK button. The HTML source code you entered is inserted in the Web
page at the cursor position. The program places the HTML symbol at the location on
the page where the code is inserted.

When you save this project, all HTML source code sections that you have entered will be
saved as well. When you open a project that has additional HTML source code, the code
will be opened as well. You can view and edit it if you want.

To view the Web page, click on the Preview icon from the Function Toolbar. The browser
will open the page and display the page and the results of the HTML source code you
inserted.

When you generate the site, the program inserts your special HTML source code sections
in the overall Source code pages that it generates for the entire Web site.

It is important to note that the automated system that DesignShop provides helps to elimi-
nate errors. The program generates all the code necessary instead of you having to create
it. It is not uncommon to find Web pages in the internet that have errors in the HTML
source code. These errors can create problems to viewers and may prevent a page from
displaying properly. DesignShop creates exact HTML code every time that is HTML 4
compliant.

Insert Date, Mail-to, and  Insert Copyright  
While creating or editing Web pages, you may want to insert the current date, insert a
mail-to address, and add a copyright notice. You can either type these in manually or use
the insert special text tool. To use the tool, place the cursor where you want to insert the
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text or mail-to click on the Insert Spe-
cial Text icon from the Insert Object
toolbar. The Special Text dialog box is
displayed.

To insert the current date:
1. Click on the Date tab and select

the date from the list of available
formats listed.

2. Click on the OK button. The cur-
rent date will be inserted in your
Web page.

When you create Web pages, you may
want to place your Internet address on the Web page. A typical example is when you
explain certain choices to the viewer and ask that the viewer respond to this information
(with feedback, questions, or requests for more information) via electronic mail letters.

To insert a mail-to feature:
1. Click and select the mail tab in the Special text dialog box.

2. Enter the address you want e-mail responses to be sent to in the E-mail address field.

3. Enter the text that will be the link to this e-mail in the Enter Link text field.

4. Click on the OK button. The mail-to linked text is inserted in your Web page.

To insert a copyright notice:

Placing Web pages on the Internet for the public to read and view is a kind of publishing.
To protect your designs and documents from copyright infringement, or from free dupli-
cation and use by unauthorized personnel, you may want to place a copyright statement
on your Web pages.

Copyright statements are in the form of: © 1996 Copyright Company name, Inc.

To insert a copyright notice:
1. Click and select the Copyright tab in the Special Text dialog box.

2. Enter the copyright text that you want.

3. Click on the OK button. The copyright statement is inserted in the page.

Note that this dialog box will use the last text you entered as the default for the copyright
text.

Inserting Embedded Objects  
Video (AVI), Sound (WAV, MID, and RMI), Animated GIF (GIF) and other user defined
resources or objects can be inserted in your Web pages. These are referred to as embedded
objects since they are embedded in the Web page.

To insert an embedded object in a Web page:
1. Place the cursor where you want to insert the object.

2. Click on the Embedded icon from the Insert Object toolbar or Select Insert > Embed-
ded object menu options to open the Embedded Object Properties dialog box.
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3. Check one of the radio buttons in the Type section to select the type of embedded
object you want. If your current Web site project has any embedded objects, they are
listed in the Physical Layout displayed in the Select embedded object window. Select
from one of the objects listed in the window or click on the Import button to import
another object.

4. To place a border around the embedded object, check the Border check box and enter
the values in pixels for the border thickness.

5. For Sound (WAV, MID, and RMI) objects, you can enter the volume level in the
Value field.

6. If you do not check the Size checkbox, the embedded object is displayed in the
browser in its original size. If you want to change this size, check the Size checkbox,
and enter the Width and Height (in pixels) that you want.

7. Any embedded object may be surrounded with a padding of empty space if desired.
The surrounding text of the page is separated from the embedded object by this
padding. To insert a spacing amount, click on the Spacing checkbox and enter the
Horizontal and Vertical padding spaces in pixels.

8. If you want the embedded object to have a certain alignment or justification, click on
the Alignment checkbox. Click on one of the radio buttons to select the alignment
you want.

9. Click on the Autostart checkbox to set the embedded object to start automatically as
soon as the page is displayed in the browser.

10. Click on the Loop checkbox to set the object to play continuously.

11. Click on the Hidden checkbox to hide the embedded object symbol or the control in
the browser. The browser will not display the hidden object’s controls. If you want
the embedded object to start playing automatically then you must also click on the
Autostart checkbox.

12. Click on the Multimedia icon, the Insert Multimedia dialog box will be displayed.
Use the “Select Media File” button to select from one of the available multimedia
types (AVI, WAV, MID or some others, that your browser supports). If it is a sound
file, the size of the window for that object will be predefined in the file. You cannot
change it. Although it is not recommended, you can change the sizes of the media
object.

13. If you are using a User defined resource and you need to insert a parameter string,
then check the Parameter List checkbox and enter the string of text.

Inserting Java Applets  
Java applets are script codes that you can insert directly into your Web pages. They pro-
vide functions that standard HTML code does not. Java applets can be used to display
animation files and produce sound. You must have the code for the Java applet to be able
to use this feature.

To insert a Java applet into the page:
1. Click on the Java button from the Insert Object toolbar to open the dialog box.

2. If your current Web site project has any Java objects, they are listed in the Physical
Layout displayed in the Class File window. Select from one of the Java Classes listed
in the window and click on the Import button to import a Java class file.

3. Enter the values for the horizontal and vertical sizes (in pixels) of the applet.
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4. Enter all the name-value pairs needed or used by the applet in the Parameters win-
dow. The default values will be used If you do not enter these parameters. If you
want to create your own Java applet, you must first write a “*.java” file, then trans-
late it into a “*.class” file with a Java translator. After you create the “.class” file, you
can include your Java applet in the Web page.

5. A Java object may be surrounded with a padding of empty space. The surrounding
text of the page will be separated from the Java object by this padding. To insert a
spacing amount check  the Spacing checkbox and enter the Horizontal and Vertical
padding spaces in pixels.

6. If you want the Java object to have a certain alignment or justification, click on the
Alignment checkbox. Click on one of the radio buttons to select the alignment you
want.

7. You can insert a string of text for the Java object. Such a string is displayed in-place
of the Java object by the browser, if the browser is unable to find the Java object. It is
also displayed as a quick tip help when the viewer using the browser places the
mouse on the Java object. To insert a string text enter it in the Alternative string field.



Chapter 6.

The Web Site Designer and Site Manager

Introduction
In this chapter we will cover the basics of using the DesignShop Web site designer and
manager. All activities in the creation and maintenance of a Web site are handled in the
Web site designer module.

Topics we will cover include:

� The Physical Layout Window

� The Logical Layout Window

� The Navigate Layout Window

� The Header/Footer Window

The Site Manager Modules
When you want to work on a Web site, you use the Site Manager window. The Site Man-
ager features four different areas that permit you to access the major work areas of site
design and management. These areas are:

� Physical Layout. The Physical Layout window displays a folder view of your Web
site project indicating where all of the pages and resources (i.e., support files, such as
graphics) are stored.

� Logical Layout. The Logical Layout window displays the Web pages in a site in an
organizational style chart. You use the Logical Layout window to add, access pages
to edit, and delete pages in a Web site. The organizational style chart is most helpful
in designing your site in an organized manner.

� Navigate Layout. The Navigate Layout window displays your Web site with respect
to the navigation aids between the different elements. You can view the links be-
tween pages, links to resources, and links to and from outside sources.

� Header/Footer. The Header/Footer module enables you to create standard headers
and footers that you can then elect to include in Web pages. For example, you may
wish to create a standard footer that appears at the bottom of all of your catalog
pages, but not other pages. When you create a new catalog page, you can simply
select the insert catalog page footer. Other pages can use a different footer. This
feature can save you the trouble of having to insert standard information in every
single page.
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The Physical Layout Window
To rename a resource:
1. If you wish to rename a resource, such as a graphic file, click

on the resource file in the Physical Layout display.

2. Right click on the selected file to open the drop down menu.

3. Click on Rename from the menu.

4. Type the new name for the resource in the resource list.

To delete a resource:
1. If you wish to delete a resource, such as a graphic file, click once on the resource in

the Physical Layout display.

2. Right click the file icon to open the drop down menu.

3. Click on Delete from the menu. The item is deleted.

To create a new folder:
1. Click on the folder in which you wish to create the new folder.

2. Right click once on the folder icon to open the drop down menu.

3. Select Create > Folder from the drop down menu.

4. Enter the name for the new folder.

You can set specific folders in which certain types of objects are stored. Some Internet
Service Providers may require that certain files be a particular folder. To accomplish this,
you should create the new folder and then assign it as the default folder for files of that
type. For example, if your multimedia files must be stored in a folder labeled “Multime-
dia,” you can create the folder and then set it as the default folder for all multimedia files.

To set a folder as a default folder:
1. Click once with the left mouse button on the folder you wish to become the default.

2. Click on the folder with the right mouse button to open the drop down menu.

3. Click on the Set as Default menu option.

4. Select the type of object that this folder will contain (i.e., pages, images, multimedia, etc.)

create
folder

create
image

delete

rename
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To create an image:
1. To create a new image, you must first create a file for the image. Select the folder in

which you wish to create the image file.

2. Right click on the folder icon to open the drop down menu.

3. Click on the Create > Image menu options in the pull down menu.

4. You can use the features of the Image Properties dialog box to set the properties of
the new image. These properties include the size in pixels, format (JPEG or GIF),
and the background color for GIF images. You can also set the background color to
transparent so that an image background is invisible. The program enables you to set
the color for GIF images to be 8, 16, or 256 colors. When you reduce the number of
colors in a GIF image, you also reduce the file size. If an image does not use 256
colors, it is wise to reduce the color count to reduce the file size.

5. After you have created the image file, you must insert the image to be used in the file
(see the next section).

To edit an image:
1. Click on the image file that you wish to edit.

2. Right click on the image file to open the drop down menu.

3. Click on the Edit option from the drop down menu.

4. When the image window opens, you can use any of the features of DesignShop Web
graphics to edit the image. For example if you wish to insert a new graphic, you can
click on the graphic button in the toolbar to select an image from a DesignShop
library or import a stand alone file.

To import a Java applet:
1. Click on the folder in which you wish to place the Java applet.

2. Right click on the folder to open the drop down menu.

3. Click on the Import > Java options from the drop down menu.

4. Click on the Java applet that you wish to import.

To import a custom resource:
1. Click on the folder in which you wish to place the custom resource.

2. Right click on the folder to open the drop down menu.

3. Click on the Import > User Resource options in the drop down menu.

4. Click on the resource to import in the Open dialog box.

DesignShop has the ability to store a particular object or resource as a placeholder. A
placeholder contains no information other than the type of object and the dimensions. You
might wish to use a placeholder in a Web page to set the placement of a graphic object that
changes with every page. For example, you might have a particular graphic button that
you want to include on every page, but the actual graphic will be different. You can design
the page, place the object, and then convert the object to a placeholder. There are two
advantages to doing this: first, if a Web site or page has one object that is converted to a
placeholder, you can save it as a template to use as a master. Second, when you open the
template to insert the actual graphic, all you have to do is double click on the placeholder
to insert an object of that type. If the placeholder is an image, double clicking on the
placeholder will open the Insert Graphic dialog box.
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To show a resource as a placeholder:
1. Click on the object that you wish to convert to a placeholder.

2. Right click on the object to open the drop down menu.

3. Click on the Show as Placeholder from the drop down menu.

The Logical Layout Window
While the Physical Layout window allows you to manage and arrange all types of objects
and resources, the Logical Layout window enables you to organize the Web pages in your
site. A new Web site begins with a Home Page All other pages flow from this page in a
hierarchy that displays as an organization style chart. This feature enables you to view and
structure your site logically, adding new pages, moving pages, and deleting pages as needed.

While the pages in the Logical Layout window appear to be linked in the chart structure,
the pages themselves do not have any links until you add them. For example, if you create
a new Web site and add a page below the Home Page, there are no links for the user to get
to that page or return to the Home Page. The lines in the Logical Layout window only
show the organizational structure of the Web site and not the link structure. If you wish to
view the link structure, you must use the Navigate Layout window.

Each page icon in the Logical Layout window represents a logical page. For example, if a
page has 2 frames, it is actually made up of two HTML files. The Logical Layout window
display shows only the page itself and not the related HTML files. When you open a
logical page, DesignShop automatically opens all related HTML pages for you to view
and edit.
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To open a page for editing:
1. Double click on the page that you wish to edit to open the edit window. DesignShop

automatically opens all related HTML files and assembles them into a logical page
for you to edit and view.

To perform operations on more than one page:
1. If you wish to perform an operation on more than one page, such as opening pages or

setting the visual properties of the pages, you may do so by holding down the CTRL
key and clicking on the desired pages.

2. When the pages are selected, click on one of the pages with the right mouse button to
open the drop down menu.

3. Click on the desired option from the drop down menu (or select the desired option
from the main menu).

To add a new page to a Web site:
1. The Logical Layout window uses a organization system for pages of parent, child,

and siblings. The Home Page is the parent page of those pages that come directly
below it. The pages that come directly below the Home Page are children of the
Home Page. All pages that are tied to a particular page are sibling pages.

2. The first step in adding a page is to select the parent page for the new page. Click
once with the right mouse button on the parent page to open the drop down menu.

3. Click on the Add option in the main menu.

5. Enter the name for the new page in the space provided below the page icon. You
cannot use spaces or any of the following characters in a page name: / : “ < > + > #

6. To exit the feature without changing the name of the page, press the ESC key.

To rename a page:
1. Right click on the page to open the drop down menu.

2. Click on the Rename option in the drop down menu

To delete a page:
1. Right click on the page to open the drop down menu.

2. Click on the Delete option in the drop down menu

To duplicate a page:
1. Click on the page to open the drop down menu.

3. Click on the Duplicate option in the drop down menu The new duplicate page is
inserted below the selected page.

To move a page:
1. Click on and, while holding down the mouse button, drag the page to a new location.

2. When the page and mouse pointer are over the new parent page, release the mouse
button to drop the page as a child page to the selected file. When you are moving a
page, you must drag it to and drop it on a new parent page. The only page in the
Logical Layout window that does not have a parent is the Home Page.
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Setting Up a New Page
After you add a new page, there are a number of steps that you should take to complete the
page setup. These steps include inserting headers and footers, setting the visual appear-
ance of the page, inserting meta tags.

Properties Dialog Box
The Properties dialog box enables you to add or edit special information about a page.
This information includes:

� Title. The Title of the Page is what appears in the title bar when the browser displays
page.

� Alias. The Alias is an alternate name for the page that is used by navigation bars. The
Alias may be different than the Title.

� Header and Footer. You can select the Header and Footer to insert into the page. If
you have entered data in the default header and footer files, you may select either of
them to insert into the page. If you have created additional headers and/or footers,
you may select one from the drop down list.

To change the Properties of one or more pages:
1. Click on the file that you wish to edit. If you wish to edit more than one file, hold

down the CTRL key and select the files.

2. Right click on any of the selected files to open the drop down menu.

3. Click on the Properties option in the drop down menu.

4. Edit the Properties desired.

Visual Settings Dialog Box
The Visual Settings dialog box permit you to set the look or appearance characteristics for
standard features for one or more pages. After you determine the visual settings, you can
choose to apply them to a single frame, a single page, multiple pages or the entire Web
site. The Visual Properties dialog box includes the following settings:

� Inherit visual properties from higher level Site Element. If you select this option,
the selected Web page uses the Visual Properties settings of the parent page. You will
not be able to change any of the visual properties if this setting is selected.

� Set own visual settings and apply them to all other dependent Site Elements.
This option enables you to edit the visual properties for the current page. In addition,
the visual properties set in this page can be passed on to any child pages of this page
(if you click on the Inherit visual properties from higher level Site Element in the
children pages).

� Encoding. The Encoding list enables you to select the language encoding to use in
the page.

� Default Colors. The Default Colors section enables you to edit the default colors for
standard text and all types of hypertext links.

� Margins. The Margins selector enables you to set the top and left margins for the
page.

� Background. The Background option, when selected, activates the color selector
section. You may select any color from the Default color library to use as a back-
ground for the page. DesignShop includes a number of different color libraries to
select. To change a color library, click on the down arrow to the right of the Default
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library name and select a new library from the list. You can also insert an image to
use as a background by selecting the Image option in the Background section. If you
select the Image option, you may select an image from an existing resource (i.e., an
image used elsewhere in the Web site), from a DesignShop image library, from an-
other Web site (URL), import a new stand alone image, or create a new image.

To change the visual settings on a page:
1. Right click on the page you wish to change to open the drop down menu.

2. Click on the Visual Properties option in the drop down menu.

3. If the Inherit visual properties from higher level Site Element option is turned on,
you will not be able to change any of the visual properties; all of the visual property
settings are taken from the parent page. If you wish to change any options, click on
the Set own visual settings and apply them to all other dependent Site Elements
option.

Meta Tags
One of the most important elements of Web pages are Meta Tags. These text lines appear
at the top of almost every Web page, but most of them are generally not displayed by the
browser (an exception is the page title). Meta tags can include keywords that describe the
Web page content, page author, language encoding, and page description. The keywords
and page description are especially important for a number of major search engines. These
search engines automatically catalog vast numbers of Web pages collecting information
stored in the meta tags. If your pages do not use meta tags, your site may not be accessible
through one of these search engines.

To enter meta tag information:
1. Right click on the page that you wish to change to open the drop down menu.

2. Click on the Meta Information option in the drop down menu.

3. If you wish to add a new meta tag, click on the Add button and enter the data in the
appropriate fields.

4. If you wish to modify an existing meta tag, click on the tag that you wish to edit and
then click on the Modify button.

5. To remove a particular meta tag, click on the tag and then click on the Delete button.

Global Search and Search and Replace
DesignShop features powerful search and search and replace tools that you can use in a
single Web page or across an entire Web site.

To do a search for a particular text string:
1. If there are no pages open, you can only perform a search on the entire Web site (i.e.,

a Global Search). If there is a Web page open, then you may select either the Global
Search or the Page Search.

2. To perform a global search, click on the Global Search button in the toolbar.

3. To perform a search on the page that is currently active, click on the Search button.

4. The search operation includes a number of options that you can choose to refine your
search. These include:

� Match Whole Word
� Match Case
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� Search Direction (up or down)

To do a search and replace for a particular text string:
1. If there are no pages open, you can only perform a search and replace on the entire

Web site (i.e., a Global Search and Replace). If there is a Web page open, then you
may select either the Global Search and Replace or the Page Search and Replace.

2. To perform a global search and replace, click on either the Global Search and Re-
place button in the toolbar.

3. To perform a search on the page that is currently active, click on the Search and
Replace button.

� Match Whole Word
� Match Case
� Search Direction (up or down)

The Navigate Layout Window
The Navigate Layout window displays the links and navigational controls between pages,
resources, and external Web sites. This feature is especially useful in reviewing the links
of your site to make sure that all of the pages in your site have links (i.e., orphan pages or
resources).

You can define the colors used for displaying the names of selected resources, orphan
resources, and internal and external links.

To change the colors in the Navigate Layout display:
1. Click on the File > Preferences menu options.

2. Click on the WebSite tab in the Preferences dialog box.

3. In the Navigate Layout section, click on the color sample box for the option you wish
to change, such as Selected Page.

4. In the Choose Color dialog box, click on the desired color.

5. Click on the OK button to make the color change.

The Navigate Layout window enables a good deal of customization so that you can set it
to display exactly the information that you wish. For example, you may wish to turn the
resources display off when you are checking for orphan pages.

To show pages in the Navigate Layout window:
1. Click on the Include Pages button in the Navigate Layout toolbar or click on the

Navigate Layout > Include > Pages menu options.

To show resources in the Navigate Layout window:
1. Click on the Include Resources button in the Navigate Layout toolbar or click on the
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Navigate Layout > Include > Resources menu options.

You can set the Navigate Layout window to show all links between pages for two different
formats. You can choose to show all of the links all the time or you can choose to show
only the links to and from the selected page or resource.

To show all external resources links all the time in the Navigate
Layout window:
1. Click on the Include External Locations button in the Navigate Layout toolbar or

click on the Navigate Layout > Include > External Locations menu options.

If you have elected to show only the links for the selected pages or resources, you can also
choose whether or not to display different types of links.

To show incoming external links in the Navigate Layout window:
1. Click on the Show Incoming Links button in the Navigate Layout toolbar or click on

the Navigate Layout > Show Links > Incoming.

To show outgoing external links in the Navigate Layout window:
1. Click on the Show Outgoing Links button in the Navigate Layout toolbar or click on

the Navigate Layout > Show Links > Outgoing.

To show outgoing internal links in the Navigate Layout window:
1. Click on the Show Outgoing Internal Links button in the Navigate Layout toolbar or

click on the Navigate Layout > Show Links > Outgoing Internal.

To show outgoing resource links in the Navigate Layout window:
1. Click on the Show Outgoing Resource Links button in the Navigate Layout toolbar

or click on the Navigate Layout > Show Links > Outgoing Resource.

Zoom Feature
The Navigate Layout window includes zoom buttons with which to increase or decrease
the magnification view. This can be especially helpful for very large Web sites.

To zoom in on a Web site:
1. Click on the Zoom In button in the Navigate Layout toolbar or click on the Site Menu

> Zoom menu options.
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To zoom out on a Web site:
1. Click on the Zoom Out button in the Navigate Layout toolbar or click on the Site

Menu > Zoom menu options.

To return the Navigate Layout view to normal:
1. Click on the Normal View button in the Navigate Layout toolbar or click on the Site

Menu > Zoom menu options.

When you make changes to your Web site, such as adding or deleting pages, the changes
are not immediately reflected in the Navigate Layout window. To update the display, you
must refresh the window display.

To refresh the Navigate Layout window display:
1. Click on the Refresh button in the Navigate Layout toolbar or click on the Navigate

Layout > Refresh menu options.

The Headers/Footers Window
The Headers/Footers tab enables you to create stan-
dard headers and footers to use in Web pages. A header
or footer can be inserted into any page or frame in a
page. Each new Web site begins with a blank default
header and a default blank footer. You can create as
many new headers and footers as you desire for your
Web site.

Information traditionally included in the standard headers and footers might include a
navigational bar or button bar in the header and a copyright notice and mail to option in
the footer. Since you would probably want these items to appear on one or more pages,
creating and using a standard header and footer can save you a great deal of repetitive
work.

Headers and footers are context-sensitive. If you insert a relative link or navigation bar in
a header, the links will point to different destinations based upon whether the header is
inserted in a page or a frame within a page. When you insert a header or footer into a
frame, it is inserted into all sources of the frame.

DesignShop includes a feature to automatically insert a default header and footer into
every page that you add to the Web site. You must enter the information that you wish the
header and footer to contain. If you desire, you can turn this feature off. If you create a
default header but not a footer, selecting the automatic header/footer feature will only
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insert the default header.

To turn the automatic header/footer feature on/off:
1. Click on the File > Preferences menu options.

2. Click on the WebSite tab in the Preferences dialog box.

3. Click on the checkbox next to the Insert default Header/Footer automatically option.

4. Click on the OK button to make the change.

You can edit and create new headers and footers using the Page Editor feature in the
Header/Footer window. When you make a change in either the header or the footer, that
change is reflected in all appropriate pages throughout the Web site. If you have already
generated the site (i.e., created the HTML and resource files in Web site format), you will
have to regenerate it to have the pages with the new headers.

To open a header or footer for editing:
1. Click on the header or footer icon to edit.

2. Click on the header or footer icon to edit.

3. The Page Editor window opens with the current header or footer ready to edit.

To create a new header or footer:
1. Click inside the header or footer frame as desired.

2. Click on the New option in the drop down menu.

3. When the new header default icon appears, click on it with the left mouse button to
select it.

4. Click on the new icon with the right mouse button to open the drop down menu.

5. Click on the Open option from the drop down menu.

6. Enter the content you wish in the header or footer in the Page Editor window.

To rename a header of footer:
1. Right click on the header or footer icon that you wish to rename.

2. Click on the Rename option in the drop down menu.

3. Enter the new name for the header or footer in the space provided under the icon.

To delete a header or footer:
1. Right click on the header or footer icon that you wish to delete. If you wish to delete

more than one header or footer, hold down the CTRL key as you click on the headers
or footers that you wish to delete.

2. Click on the Delete option in the drop down menu.

3. Click on the Yes button to confirm the deletion.

DesignShop can have as many header and footer files as you desire, but only one of each
can be designated as the default. The one selected as the default will be added to pages
when you select the insert default header/footer option.

To set a header or footer as the default:
1. Click on the header or footer that you wish to be the default.

2. Right click on the header or footer that you wish to be the default.

3. Click on the Set as Default option in the drop down menu.
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To show a header or footer as a placeholder:
1. Right click on the header or footer that you wish to display as a placeholder

2. Select Show > As Placeholder from the pop-up menu.

To view headers or footers as large or small icons:
1. Click anywhere inside the header or footer area with the right mouse button to open

the drop down menu.

2. Click on the Large Icons or Small Icons option in the drop down menu. The selection
of icon type can be totally independent from the other. You can display headers as
large icons and footers as small icons.
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Creating Web Pages

Introduction
In this chapter we will cover the basics of creating a Web page for a Web site. Topics that
we will discuss include:

� The Page Editor

� Using Forms

� Using the Database Wizard

� Importing Web Sites

� Uploading and Publishing Web Sites

The Page Editor
You create Web pages in DesignShop using the Page Editor window. You access this
feature in the Logical Layout window. The Page Editor provides a WYSIWYG (what you
see is what you get) work environment where you can see your Web page as it will look in
a browser (with the exception of some special resources, such as Java applets, JavaScript,
etc.). The Page Editor enables you to create single no-frames pages or complex pages with
multiple frames and multiple frame sources.
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Frames
Web pages can be divided into frames in the DesignShop Page Editor. The frames of a
page are divided into separate HTML files. For example, if you design a page that is split
into two frames (left and right), DesignShop creates three files: the calling page, the left
frame, and the right frame. When the user opens the page, the browser opens the calling
page first. Based upon the HTML information about the frames, the browser then loads
the left and right frame files to display the complete page.

A frame is the name given to the rectangular border of a window in the page or screen.
After you create a frame, you can drag the sides to resize it. The information inside the
frame, such as text, graphics, etc., is called the Frame Source Overlay (FSO) or the Frame
Source. Frames may have vertical and horizontal scroll bars to enable the viewer to scroll
and view the FSO.

Any Web page or any frame that you see in a window, by default, has only one frame
source. You can add more frame sources to the frame if you want.

To add a new frame source:
1. Click on the Frame Manager Resource toggle to open the Frame Source dialog box.

This dialog box will help you to understand the frames source structure of the page.

2. Click anywhere inside the frame in which you which you want to create or add a new
frame source.

3. Click on the New Frame Source button in the Frame and Page Editor toolbar or click
on the Frames > New Source.

4. Enter the name for the new source.

5. Click on the OK button.

To delete a frame source:
1. Click on the frame to delete in the Frame Sources combo box.

2. Click on the Delete Frame Source button in the Frame and Page Editor toolbar or
click on the Frames > Delete Source menu options.

To rename a frame source:
1. Click on the frame to rename in the Frame Sources combo box.

2. Click on the Rename Frame Source button in the Frame and Page Editor toolbar or
click on the Frames > Rename menu options.

3. Enter the new name for the frame.

4. Click on the OK button.

If you are using multiple frame sources, at least one must be designated as the default.
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To set a source as the default:
1. Click on the frame to designate as the default in the Frame Sources combo box.

2. Click on the Default Source button in the Frame and Page Editor toolbar or click on
the Frames > Set as Default menu options.

DesignShop can display objects and resources in a Web page as the actual object or as a
placeholder. A placeholder indicates the type of object, size, and characteristics. There are
several advantages to using a placeholder in a Web page project. The most important
reason is that if you have at least one page with a placeholder, then you can save the Web
site as a DesignShop template. Another advantage in using placeholders is that you can
replace the object in the placeholder by simply double clicking on the placeholder. For
example, if you wanted to place a different text object at the top of every page, you could
insert the text object, place it on the page as desired, and then convert it to a placeholder.
The next time you open the template, all you have to do to enter the text is double click on
the placeholder. This can save you a great deal of effort when you have repetitive tasks.

To show a source as a placeholder:
1. Click on the object that you wish to show as a placeholder in the Frame Sources

combo box.

2. Click on the Frames > Show as Placeholder menu options.

Any Web page can be divided into two frames vertically or horizontally. If you wish, a
frame may be further subdivided into two frames permitting you to create complex Web
pages.

To split a frame vertically:
1. Click anywhere inside the frame you wish to split.

2. Click on the Split Vertical button in the Frame and Page Editor toolbar or click on the
Frame > Split Vertical menu options.

To split a frame horizontally:
1. Click anywhere inside the frame you wish to split.

2. Click on the Split Horizontal button in the Frame and Page Editor toolbar or click on
the Frame > Split Horizontal menu options.

To delete a frame:
1. Click anywhere inside the frame you wish to delete.

2. Click on the Delete Frame button in the Frame and Page Editor toolbar or click on the
Frame > Delete Frame menu options.

To rename a frame:
1. Click anywhere inside the frame you wish to modify.

2. Click on the Rename Frame button in the Frame and Page Editor toolbar or click on
the Frame > Rename Frame menu options.

3. Enter the new name for the frame.

4. Click on the OK button.
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Frame Properties
You can predefine how your frame can be viewed in the browser. You can configure how
the frame will scroll, whether or not it is resizable, and set the page margins.

• Scrollable. Scroll bars in a frame permit the user to scroll up/down and left/right to
view content that may not be visible due to browser window size. DesignShop en-
ables you to set the scroll bars to be automatic (only displayed when needed; the
display of the scroll bars is controlled by the browser), always displayed, or never
displayed.

• Resizable. Frames can be set to be fixed size or can be resizable by the user.

• Margins. You can set the margin size for each frame.

• Headers and Footers. You can insert a header or footer into any frame on a page. A
header or footer inserted into a frame is automatically inserted into all frame sources.

To change the scrollable aspects of a frame.
1. Click anywhere inside the frame you wish to modify.

2. Click on the Frame Properties button in the Frame and Page Editor toolbar or click
on the Frames > Frame Properties menu options.

3. In the Scrolling section, click on the radio button for the option you desire: Auto,
Yes, or No.

4. Click on the OK button.

To change the resizability of a frame:
1. Click anywhere inside the frame you wish to modify.

2. Click on the Frame Properties button in the Frame and Page Editor toolbar or click
on the Frames > Frame Properties menu options.

3. If there is no checkmark in the Resizable checkbox, click on the box to check or
enable it.

4. Click on the OK button.

To set the margins for a frame:
1. Click with the left mouse button anywhere inside the frame you wish to modify.

2. Click on the Frame Properties button in the Frame and Page Editor toolbar or click
on the Frames > Frame Properties menu options.

3. Use the scroll boxes to set the desired Margin Width and Margin Height (or simply
enter the desired number into the field).

4. Click on the OK button.

To insert a header or footer in a frame:
1. Click anywhere inside the frame you wish to modify.

2. Click on the Insert Header/Footer button in the Frame and Page Editor toolbar or
click on the Frames > Insert Header/Footer menu options.

3. Use the scroll boxes to click on the desired header or footer.

4. Click on the OK button.
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Visual Settings for Frames
You can set the visual properties of each frame independently from other frames or from
the page itself. The Visual Settings dialog box includes a number of different options with
which you can modify the frame appearance including:

• Encoding

• Default text colors

• Default link colors

• Margins

• Background color or image

To change the frame visual settings:
1. Click anywhere inside the frame you wish to modify.

2. Click on the Frame Visual Settings button in the Frame and Page Editor toolbar or
click on the Frames > Frames Visual Settings menu options.

3. Change the visual settings as desired.

4. Click on the OK button.

Frame Manager
The Page Editor includes a Frame Manager option that enables you to view the frame
structure of a page. This is particularly useful when you are working on very complex
pages that might contain three or more frames.

To access the Frame Manager:
1. You can toggle the Frame Manager window display by clicking on the Frame Man-

ager button to the left of the Frame-Source Overlays text (There is no graphic image
on the Frame Manager button; it is a small rectangle at the left side of the Page Editor
window. You may also toggle the Frame Manager display by selecting the View >
Frame Manager menu options.

The Frame Manager displays the frame structure for the current page in a tree-structure
organization. There are three levels of objects: Frame Sets, Frames, and Frame Source
Overlays. When you activate a frame in the editor, the current source for that frame is
highlighted in the Frame Manager display.

A Frame Set is a set of frames of the same orientation used in a single page. You can delete
a Frame Set by selecting the frame in the Frame Manager and then selecting Delete from
the drop down menu. You can use all of he operations and features with frames from the
pop-up menu for a selected frame. In addition, you can use all of the operations and
features with the sources from the pop-up menu for the selected source.

Using Forms
Web pages use forms to get and apply some response from the user. The response may be
as simple as a button that takes the user to another page or as complex as an order form
that asks the user to enter information about themselves.

A Form collects data through checkboxes, radio buttons, text lines, and other form fields.
Special programs or scripts outside the Web page process the data from the form and carry
out appropriate instructions.
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DesignShop allows you to design forms that will process data to:

• Perform database queries

• Store, mail, or display a formatted document

• Perform a custom action (i.e., assign a custom CGI script to handle the data)

You can insert a form into a Web page by selecting the form button in the Insert Objects
toolbar. When the form is inserted into the page, you can then insert any one of the follow-
ing form field types:

• Text Line

• Combo Box

• List Box

• Text Box

• Check Box

• Radio Button

• Push Button

To insert a field type:
1. You must first click on the Forms button to insert a form into the Web page.

2. Move the cursor to the location in the Web page at which you wish the field to
appear.

3. Click on the Insert > Form Field menu options.

4. Click on the type of form field that you wish to insert.

5. The Properties dialog box opens for the selected field type permitting you to enter
the type of information that you wish (i.e., default settings, text content, etc.)

To edit the form properties:
1. If you wish to change the properties of any field type in a form, you may open the

Properties dialog box for that field by double clicking on it.

Form Properties
DesignShop features a number of dialog boxes and provides a method for managing forms
and form fields. These dialog boxes permit you to customize the operation of a form as
well as the type of input it collects from the Web visitor.

Form Properties Dialog Box
The Form Properties dialog box enables you to set the properties for the selected form.
You can also set the options for the CGI script that processes the data collected from the
selected form.

The Form Properties dialog box includes five sections:

• Form Name text field
• Show Form as Placeholder check box
• CGI Setting section
• Hidden Variables section
• Form Fields list
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To open the Form Properties dialog box:
1. The cursor must be inside a form before you can open the Form Properties dialog

box.

2. With the cursor in the form that you wish to edit, click on the Form Properties button
from the toolbar or click on Form Database from the Format menu.

Form Name Text Field
The Form Name field enables you to edit the name for the selected form. The default
system for naming forms is Form1, Form2, etc. You can enter any name in the Form
Name field. It is good practice to give all forms a name that is unique throughout a Web
site. If there is more than one form in a page or frame, each form must have a unique
name.

The Show Form as Placeholder Check Box
The Show Form as Placeholder check box enables you to convert and display the selected
form as a placeholder (i.e., a placeholder for a form on the page). If you wish to use the
page as a template in DesignShop, at least one object in the page must be a placeholder. If
you select this option, all of the information selected in the CGI Settings section is dis-
carded (only the name and the design style of the form is retained). The Form Fields and
Hidden Variables are retained in the placeholder information, but the form is not gener-
ated when you generate the Web site.

The CGI Settings Section
The CGI Output Type pull down menu enables you to select the CGI Script type. The
script types you may select include:

• Formatted Document. This option causes the CGI script to generate a formatted
document. This document can be mailed to one or more recipients, saved to a file, or
displayed on the screen. When you click on the Formatted Document CGI Output
Type and click on the CGI Output Properties, the Formatted Document Properties
dialog box opens for you to set the properties of the formatted document.

• Database Query (SQL). This option causes the CGI script to generate a database
query. You can select the database and the type of query in the Data Base Query
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(SQL) dialog box. This dialog box opens when you click on the Database Query
(SQL) CGI Output Type and then click on the CGI Output Properties button. You
must already have a database defined in the DesignShop Database Wizard to be able
to generate a query.

• Local Custom CGI Script. The Local Custom CGI Script option enables you to
select a custom CGI script for the form from your Web site. You must know the
properties of the CGI script to be able to configure it properly. When you click on the
Local Custom CGI Script CGI Output Type and click on the CGI Output Properties,
the Custom CGI Properties dialog box opens so that you can set the properties of the
Local Custom CGI script.

• Remote Custom CGI Scripts. You may access CGI scripts that are not on your Web
site by using the Remote Custom CGI Scripts option. You must know the properties
of the CGI script to be able to configure it properly. When you click on the Remote
Custom CGI Script CGI Output Type and click on the CGI Output Properties, the
Remote CGI Properties dialog box opens so that you can set the properties of the
Remote Custom CGI script.

The Perl Interpreter Path text box enables you to specify the location of the Perl script
interpreter program. If your Web site provider is using Microsoft Web servers, this field is
not used. Most Unix servers (as well as a number of other types) require that you provide
a correct path to the Perl interpreter in the field provided. Check with your Web site
provider system administrator for additional information. If you click on the Local Cus-
tom CGI Script or the Remote Custom CGI Output Script output, the Perl interpreter
script option is not available.

The CGI File Extension text box enables you to enter the extension of your CGI script
file. The correct extension to use depends upon the type of Web server you are using.
DesignShop assigns a default extension of .CGI that is compatible with most servers. If
you are not sure about what extension to use, check with your Web site provider system
administrator for additional information. If you click on the Local Custom CGI Script or
the Remote Custom CGI Output Script output, the Perl interpreter script option is not
available.

The Hidden Variables Section
The Hidden Variables section enables you
to manage the hidden variables in a form.
These variables may be any type of form
field used by the script that processed the
form. As the name implies, the Hidden
Variables fields are not visible to the Web
viewer and cannot be changed by the Web
viewer.

To add a hidden variable to a form:
1. Click on the Add button in the Hidden Variables section.

2. Enter the name for the variable and the default value in the fields provided.

3. Click on the OK to add the new variable.

To modify a hidden variable to a form:
1. In the Hidden Variables section, select the variable that you wish to modify.

2. Click on the Modify button in the Hidden Variable dialog box.
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3. Edit the name and default value as you like.

4. Click on the OK to add the new variable.

To delete a hidden variable to a form:
1. In the Hidden Variables section, select the variable that you wish to delete.

2. Click on the Delete button in the Hidden Variable dialog box.

3. Click on the OK button to confirm the deletion.

The Form Fields Window
The Form Fields window is included in the Form Prop-
erties dialog box as a help to show the fields and their
types included in the selected form.

Inserting Form Fields into a Form
To be able to insert a Form Field, the page or frame must
have a form. After you insert a form, then, with the cur-
sor inside the form, you may begin entering the Form Fields desired.

To insert a form into a page or frame:
1. Move the cursor to the point on the page where you want to insert the new form.

2. Click on the Insert Form button on the Insert Objects toolbar or click on the Insert >
Form menu options.

To insert a form field into a form:
1. Move the cursor inside the form to the point where you want to insert the new form

field.

2. Click on the appropriate form field button from the Form Field toolbar or click on the
Insert > Form Field menu options and click on the desired form.

Text Line Form Field
The Text Line Properties dialog box includes
spaces to enter the name for the field and the
default value. Each field in a form must have a
unique name for the form to function correctly.
The dialog box also allows you to select the
field size (i.e., the length in characters the field
will display in the page) and the Text Max.
Length (i.e., the maximum number of charac-
ters the user is permitted to enter. If you click
on the Hidden Input (Password) option, any text that the user enters will not display in the
form as they type.

Combo Box of Drop Down List Form Field
The Combo Box Properties dialog box enables you to enter the Name for the field that
displays in the combo box field. The Items list displays the labels and the values of the
items that are included in the combo list. Each item must have a value. The labels are
optional. If you omit the label, then the value text is used as the label. To add a new item,
click on the Add button and enter the necessary information. To modify or delete an item,
click on it to click on it and then click on the Edit or Remove Item button. If you wish to

combo
box

radio
button

list box

text boxtext line

push
button

check
box
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change the order of the items in the list, you
may click on the item that you wish to move
and then click on the Move Up or Move Down
button.

List Box Form Field
The List Box Properties dialog box enables
you to enter the Name for the field at the top.
You must specify the number of visible items
in the list using the Number of Visible Items
selector. The number of visible items deter-
mines the vertical size of the list box in rows.
In addition, the List Box feature enables the
user to select more than one item from the list
if you click on the Allow Multiple Selection
option (the Combo Box enables the user to
only click on one item from the list). The Items
list displays the items that are included in the
list. Each item must have a value. The labels
are optional. If you omit the label, the value
text is used as the label. To add a new item,
click on the Add button and enter the neces-
sary information. To modify or delete an item,
click on it to select it and then click on the
Edit or Remove Item button. If you wish to
change the order of the items in the list, you
may click on the item that you wish to move
and then click on the Move Up or Move Down
button.

Text Box Form Field
The Text Box form field inserts a text box in the
form that enables the user to enter more than
one line of text. The Text Box dialog box in-
cludes an option for the name of the field as
well as the default text that the visitor will see
when they view the form. Since the Text Box
can contain multiple lines, you must indicate
the Horizontal Size (i.e., the width of the box in
characters) and the Vertical Size (i.e., the num-
ber of lines to display in the box).

Check Box Form Field
The Check Box form field provides the viewer
with a square check box in the form. You must
enter the name for the field and the default
value. The Checked option enables you to in-
dicate whether or not the box is checked when
the viewer first views the form.



7–11

Creating Web Pages

 � � �Internet DesignShop - User Guide

Radio Button Form Field
The Radio Button form field provides the viewer
with a round radio button in the form. You must
enter the name for the field and the default value.
The Selected Member option enables you to in-
dicate whether or not the radio button is selected
with the visitor first views the form. There can
be more than one radio button field with the
same name in the form. It is referred to as the group of radio buttons. You must assign a
unique value to each radio button in the group. Only one radio button in the group can be
selected at any one time.

Push Button Form Field
The Push Button form field provides the viewer
with a standard push button in the form. You
must enter the name for the field and the value
or label. The text that you enter in the Value
box is displayed in the button in the Web page.
HTML includes two different types of push
buttons: Reset and Submit. The submit button,
when selected issues a standard code message
through the browser to the CGI script to complete the operation selected. The Reset button
clears any data from the fields in the form. The actions of Reset and Submit cannot be
changed regardless of the Value (i.e., label) that you enter for the button.

CGI Scripts in DesignShop
Web pages use CGI scripts to process the input from the user and transmit it back to the
server. Information collected though one of the form fields is collected from the user,
passed to a CGI script and then processed accordingly.

DesignShop features four different types of CGI scripts:

• Scripts for creating a Formatted Document. Formatted Document scripts are gen-
erated by DesignShop when you insert them in a Web page. You can edit the scripts
using the dialog boxes described in this section.

• Scripts for performing Database Query. The scripts for performing database que-
ries are generated by DesignShop. You can edit the scripts using the Database Con-
nectivity dialog boxes in this section.

• Local Custom CGI Scripts. Local Custom CGI scripts are those you write to per-
form specialized functions. They are located on the local Web server.

• Remote Custom CGI scripts. Remote Custom CGI scripts are those you write to
perform specialized functions. They can be located on any remote Web server on the
Internet.

Formatted Document Scripts

Formatted Document Properties
Dialog Box
DesignShop provides control and management
tools for Formatted Document scripts through
a series of dialog boxes. The Formatted Docu-
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ment Properties dialog box enables you to select the output format for the document. You
use the status boxes in the dialog box to determine which of the following actions the
script will perform:

• Display Feedback. The Display
Feedback option causes the CGI
script to display certain information
(feedback) in the browser for the
viewer. The feedback may include
answers or data from the form fields
or another source. By default, only
the names and values of the form
controls and variables are shown in
text format. If you wish to edit the
text of the feedback, you can click
on the Settings next to the Display
Feedback check box to open the
Document Composer dialog box.

• Mail Document. The Mail Document option is used for sending e-mail to one or
more recipients. Mail text may contain data from the from fields, if desired. The
action is performed on a formatted document. To configure the settings for the Mail
feature, click on the Settings button next to the Mail Document option to open the
Mail Settings dialog box. You must insert the settings information for the Mail fea-
ture to make it work properly (there are no default settings for the Mail feature).

• Store Document. The Store Document op-
tion saves data obtained from a form in a
text file. To set the properties for this fea-
ture, click on the Settings button to the right
of the Store Document option. You must set
the parameters for the save in the File Set-
tings dialog box (there are no default set-
tings for the Store Document feature).

DesignShop automatically generates the Format-
ted Document CGI script based upon the infor-
mation that you enter in the settings for each type.

Mail Settings Dialog Box
The Mail Settings dialog box enables you to enter the properties for mailing formatted
documents. The dialog box is di-
vided into two sections: Mail
Properties and Mail Program
Properties.

Mail Properties. The Mail Prop-
erties area enables you to enter
the information necessary for
correct routing of the Formatted
Document. This includes

• To. The e-mail address of
the recipient.
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• From. The e-mail address of the sender.

• Cc. E-mail addresses for any recipients of copies of the mail.

• Bcc. E-mail addressed for any blind recipients of copies of the mail.

• Subject. The subject of the message.

• Insert Field button. All of the address and routing fields can contain data that is
collected from the user in a form. For example, the user may enter the address and
subject in a form in the browser window. The Mail Settings properties can take the
information directly from the form fields and insert it into the mail settings. To assign
a form field to a mail property, click inside the entry box for the mail property, such
as the “Bcc” field, click on the Insert Field button, and then click on the field you
wish to insert into the Bcc line of the message.

• Edit Text button. The Edit Text button enables you to edit the text in the formatted
document which is mailed by the CGI script.

The Mail Program Properties section enables you to set the properties of the mail program
that will actually send the formatted page document. This section includes:

• Mail Program Path. The Mail Program Path is the path to your mail sender pro-
gram. By default, this field contains usr/lib/sendmail, which is the default path for
the sendmail program for most Unix servers. Your mailsender program must be con-
figured to run in command line (non-interactive) mode.

• Command Line Parameters. The Command Line Parameters will vary depending
on the mail-sending program you are using. The Command Line Parameters option
enables you to enter specific data so that you can customize the mail feature to work
with almost any server system. This field enables you to use placeholders indicating
the location of the To, From, Cc, Bcc, and Subject fields.

File Settings Dialog Box
The File Settings dialog box enables you to
enter the name of the file where the format-
ted document is stored. Since you do not
know at this point what the path (folder lo-
cation) of the file will be, you should enter
only the file name and the extension. The
server will store the information from the mail in the file you specify. The file will be
stored in the default working directory on the server. Any additional mail documents are
appended to the end of this file. Microsoft and Apache server software handle the storage
of mail files in different manners. You should check with your server system administrator
for additional information on how to finish the mail storage formatting options in the CGI
script.

Database Connectivity in DesignShop
One of the most important features of the DesignShop Web site designer is the ability to
create Web sites that include Database Connectivity. You can create Web pages that per-
mit the user to access any Open Data Base Connectivity (ODBC) compliant database that
is installed and available on the Web server.

NOTE: To use the Database Connectivity feature, you have to make sure that the Web
server has ODBC and Perl installed and that the databases you wish to access are
declared as an ODBC Data Source on the server.
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Database Wizard
The Database Wizard dialog box
is accessed from the Logical
Layout toolbar or from the
Choose Data Source for New
Query dialog box. The wizard
enables you to manage the
DSD’s of your Web site. Your
site can contain as many DSD’s
as you wish. All DSD’s that you
create or import into your site
must correspond to real data-
bases declared as ODBC Data Sources. These databases must have been placed on the
server and registered as a data source available through ODBC. For additional informa-
tion on how to set the database, see the documentation that accompanied your ODBC
database program or consult with your server system administrator. The databases that
you wish to access must be on the same server as your Web site. The file names, tables and
fields declared in the descriptor must be identical to the names of the databases, tables and
fields declared in the ODBC data source. You cannot declare any table or field that is not
present in the database.

The Database Wizard dialog box consists of the database tree windows and the database
management buttons and controls.

The Database Tree window displays the structure of all of the databases used in your Web
site. The structure is shown in the form of a directory or folder tree hierarchy with the
databases at the lowest level. Each database contains tables, which, in turn, contain fields.
In addition to the convenience of the display, the Database Tree window enables you to
carry out drag and drop operations between databases and tables. You can drag and drop a
table from one database to another or drag and drop a field from one table to another.

The Database management and control buttons in the Database Wizard include:

• Add. Adds a database, table, or field to the structure. Click on the type of object that
you wish to insert and click on the Add button. For example, if you click on a table in
the Directory Tree and then click on the Add button, you will add a new table.

• Insert. Inserts an object of a selected level. For example, if you click on a table in the
Directory Tree and then click on the Insert button, a field is added to the table.

• Delete. Deletes the selected object.

• Rename. Enables you to rename the selected object.

• Properties. Allows you to change the properties of a field. To use the feature, click
on the desired field and then click on the Properties button. You can edit the proper-
ties in the Field Properties dialog box.

• Open Library. Allows you to manage the library of DSD’s. To use the feature, click
on the Open Library button to open the Database Library dialog box.

Database Library Dialog Box
The Database Library dialog box is accessed through the Open Library button in the
Database Wizard dialog box. This dialog box enables you to manage the Library of the
Database Structure Descriptors (DSD). The box consists of the DSD list window and the



7–15

Creating Web Pages

 � � �Internet DesignShop - User Guide

library management controls and buttons. The
DSD list window includes the list of all DSD’s
available in the library. You can enter a short
description for any of them by selecting the item
and then selecting the Description button.

The Library management controls in the Data-
base Library dialog box include:

• Add. Enables you to add a DSD to the
library. You must first create the descriptor in the Database Wizard dialog box before
you can add it to a library. When you click on the Add button, the Dbase to Library
dialog box opens. Select the desired DSD from the database pull down menu and
then click on the OK button.

• Delete. The Delete button removes DSD(‘s) from the selected libraries. To remove a
library, click on it to click on it and then click on the Delete button.

• Get. Allows you to get the DSD(‘s) from the selected libraries and insert them into
the work space of the Database Wizard dialog box.

• Description. Enables you to modify the descriptions of the DSD(‘s). To use the
feature, select the desired DSD(‘s) and then click on the Description button. You can
edit the descriptions in the Edit Description dialog box.

• Close. Exits and closes the Database Library dialog boxes.

• Import. Allows you to import the descriptions of database structures from Microsoft
Access databases (.MDB files). For additional information on import support for
other databases, contact Boomerang Software, Inc.

Field Properties Dialog Box
The Field Properties dialog box allows you to set the date
type of the field as well as the Column Caption. These
items are displayed in the feedback of the query that uses
the field.

The Data Type drop down list enables you to set the data
type. You may select from the following types:

• Boolean. Boolean data field (yes/no, true/false, 1/0,
etc.)

• Char. Data field that contains characters only.

• Date. Date field. The supported formats are: “dd,MMMM,yyyy,” “dd-MMM-yyyy,”
“MM/dd/yy,” and “MMMM dd.yyyy.”

• Double. A double (8 bit) floating point numerical field.

• Float. Floating point number field.

• Image. Text field that contains the URL of an image.

• Integer. An integer numerical field.

• Mail. A text field that contains an e-mail address.

• Time. A time format field.

• URL. Text field that contains a URL.

• VarChar. A text field that only contains a text string (all characters in the field are
treated as characters).
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The Column Caption feature in the Field Properties dialog box lets you set the caption to
be displayed in the feedback of the corresponding query.

Choose Data Source for New Query Dialog Box
The Database Query dialog box enables you to set the Data Source (the DSD’) for the
query and the query type. The Database Query dialog box features a number of options
and controls.

• Data Sources. The Data Sources pull down menu allows you to select the Database
Structure to be used. If you have not declared any DSD’s, then you should click on
the To Database Wizard button and go to the wizard dialog box where you can create
and edit the DSD’s

• Query Type. The Query Type pull down menu allows you to select the type of SQL
Query. The database Query can be one of the following types:

· Delete. Deletes one or more records from the database
· Insert. Adds a new record to the specified field of the database.
· Select. Selects and shows the records from the selected database.
· Update. Updates the records in the database.

After you click on the Data Source and the Query Type, click on the Edit Query button to
access the Query Properties dialog box and edit the query.

To display the Database Query dialog box:
1. In the Form Properties dialog box, choose the Data Base Query item in the CGI

Output Type combo box.

2. Click on the CGI Output Properties button.

The Query Properties Dialog Box
The Query Properties dialog box enables you to set the properties for a Database Query.
The options displayed in this dialog box depend on the Query Type you select in the
Database Query dialog box. There is a tab in the dialog box for each type of query includ-
ing:

• Delete
• Insert
• Select

� Select tab
� Order tab
� Criteria tab
� Feedback tab

• Update

� Update tab
� Criteria tab



7–17

Creating Web Pages

 � � �Internet DesignShop - User Guide

The Delete Tab
The Delete query option removes one or more records from the Database according to the
conditions that you set. When you click on this option, the Tables drop down list opens for
you to click on the table in which the records are to be deleted.

The Insert Tab
The Insert query option adds a new record to the specified table of the database. The tab is
divided into two sections:

• Tables. The Tables drop down list enables you to choose the table in which to insert
records.

• Fields and Values. This section enables you to assign values to the fields. To assign
a value, select the field and then click on the Edit button to open the Set Value dialog
box. You can set the value in the Set Value dialog box or you can click on the Clear
button to remove the field from the query.

The Select Tab
The Select query displays the records from the specified database. This is based on the
conditions that you click on in the Query Properties dialog box. The Select Query dialog
box is divided into three sections:

• Tables. You can use the Tables option to choose the table in which the record(s) will
be selected.

• Available Fields section. This section lists all of the fields in the selected table.

• Selected Fields section. The section lists all of the fields that you have selected from
various tables. These are the tables contained or included in the database. The drop
down menu includes these tables in the list. The fields you select and see in the
selection field section are displayed in the feedback on the Web page. If you wish to
select field(s) from the current table, click on it in the Available Fields section and
then click on the Add > button. The field(s) will be added to the Selected Fields
section. If you want to select all of the fields in the current table, click on the All >>
button. To remove field(s) from the list of selected fields, select the desired field and
then click on the Remove < button. If you wish to remove all of the selected fields,
click on the Remove All << button.

The Order Tab
The Order tab includes the following sections:

• Tables drop down list. The Tables list enables you to select the table you wish. You
may select the fields you wish and set the order in which they appear.

• Available Fields section. The Available Fields section lists all of the fields in the
current table.

• Fields to Order By section. This section lists all of the fields from the various tables.
These fields will be used in the current query to show the sorting order in the feed-
back on the Web page.

Select field(s) from the current table in the Available Fields section and then click on the
Add > button. The fields will be added to the Fields to Order By section. If you wish to
add all of the fields of the current table, click on the Add All >> button. To remove field(s)
from the list displayed in the Fields to Order By section, select the fields and then click on
the Remove < button. If you wish to remove all of the selected fields, click on the Remove
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All << button.

The field name in the Fields to Order By section will have a small arrow to the left of its
name. The direction of the arrow indicates whether the sorting will be ascending or de-
scending. If the arrow points upward, the sort will be in ascending order; if the arrow
points down, the sort will be in descending order.

The Criteria Tab
The Criteria tab includes the Condition window and the condition management buttons
and controls. This window displays the binary operations of the current query. The query
will be performed if the conditions are satisfied. You must build the binary operations for
the query. These conditions are displayed in the form of a logical tree. The operations are
logically connected by the AND/OR binary operations thus enabling you to construct a
very complex condition tree.

To add a logical operation at the same level as the selected object, click on the Add Logic
button to open the Choose Logic Operation dialog box. In the Choose Logic Operation
dialog box, you can specify the AND and OR logical operations.

To add a logical operation at a level higher than the selected object, click on the Insert
Logic button. When the Choose Logic Operation dialog box opens, you can choose be-
tween the AND and OR logical operations. To add a binary operation, click on the Add
Condition button to open the Add Condition dialog box. Here you can set the binary
operation. For example: table_1.Field_15.

To delete a condition or logic, select it in the condition window and then click on the
Delete button. To edit a condition or logic, select it and then click on the Edit button to
open either the Choose Logic Operation or the Add Condition dialog box.

The Feedback Tab
The Feedback tab enables you to customize the feedback properties on your query. This
tab includes the following sections.

• Style. The Style section enables you to choose whether or not the feedback will be
displayed as a Table or List format.

• Result Portion. In the Result Portion, you can enter the number of records, which
will be displayed for each feedback Web page.

• Show Image As. The Show Image As section provides you with two options. One
option causes the images included in the feedback to be displayed as an Embedded
Object. The other option displays the links to them.

• Enumeration. The Enumeration checkbox is available only for the List feedback.
This feature toggles on and off the enumeration of the query results on the Web page.

• Fields Caption. The Fields Caption checkbox is available only for the List feedback.
This feature toggles on and off the display of field captions in the feedback.

• Border. The Border checkbox toggles the display of the borders in the feedback
table in the Web page.

• Alignment. The Alignment section enables you to set the alignment of the columns.
These columns are the data columns of the feedback table displayed in the Web page.
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The Set Value Dialog Box
The Set Value dialog box enables you to choose the values for the field. You can insert
values explicitly as numbers or alphanumeric strings (Value folder tab). You can also use
the Control folder tab to choose the proper form control from the form control drop down
menu.

The Set Value dialog box opens when you click on the Edit button in the Query Properties
dialog box. The Set Value dialog box is only available for the Insert and Update queries.

• Value Tab. The Value tab enables you to enter a value corresponding to the type of
the field. DesignShop validates your entry and prompts you with an error message
for entries that are not applicable.

• Control Tab. The Control tab includes a pull down menu. It lists the names of all
available form controls.

Add Condition Dialog Box
The Add Condition dialog box allows you to add a condition for the specified query. The
dialog box opens when you click on the Edit or the Add Condition buttons in the Criteria
tab of the Query Properties dialog box. The dialog box is divided into three sections:

• Available Fields.

• Operation

• Values (which may have two or three tabs, depending on the type of query)

• Available Fields. The Available Fields pull down menu includes all of the database
record fields available in the query. The format of the strings in the pull down menu
is Table.Field.

• Operation. The Operation menu includes logical or other operations used in the
condition. These operations are:

< If the Field value is less than the right operand of the binary operation
<= If the Field value is less than or equal to the right operand of the binary

operation
<> If the Field value is not equal to the right operand of the binary opera-

tion
= If the Field value is equal to the right operand of the binary operation
> If the Field value is more than the right operand of the binary operation
>= If the Field value is more than or equal to the right operand of the binary

operation
Begins with - If the Field value begins with the character(s) of the right

operand of the binary operation
Between - If the Field value is in the range defined by the minimum and

maximum specified in the Value section. For this option, you must enter
two values in the Value section.

Contains - If the Field value contains the character(s) displayed in the Value
section

Ends with - If the Field value ends with the character(s) displayed in the
Value section.
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• Values/Controls/Join. In these folder tabs, you can select or enter values for the
binary operation. Values can be inserted as fixed numbers or strings in the Value
folder tab or chosen from the Form Control pull down menu of the Control folder
tab.

• Value tab. The fixed value can be entered in the text line in this tab.

• Control tab. The Control tab contains a pull down menu that lists the names of all
previously chosen form controls that are included in the form.

When you choose the Between option in the Operation menu, the Right Operand section’s
Control folder displays two controls instead of one. These controls show the upper and
lower limits of the binary operation.

In the event that you choose the Select command in the Database Query dialog box, one
more optional tab will be available to you, the Join tab:

Join tab. The Join folder tab provides options to joining tables within the chosen database.
You can set the relation between the fields of two different tables. It is not recommended
that you choose a binary operation other than the equal operation for this selection.

Importing Web Sites
DesignShop includes a Web site import
feature that can import entire Web sites
from remote servers (both FTP and Web
servers) as well as from your local com-
puter. The feature enables you to take
an existing Web site, such as one you
may have already created, and bring it
into DesignShop for editing and main-
tenance.

NOTE: It is important to keep in mind
that graphics and Web pages avail-
able through the Internet are gen-
erally copyrighted material. The import and use of such materials without prior written
permission of the copyright holder is a violation of international copyright treaty. While
there is nothing wrong with importing a Web site to study it and see how it functions,
you should not infringe on the copyright for such materials.

You access the Web site import feature through the Import Site option in the Import Site
dialog box. You first specify the Start page and the Import Zone. DesignShop imports all
of the files from the Import Zone (including subfolders and files) that are connected to the
Start Page in some manner. The pages or resources should be linked from the Start Page,
or linked form a file that is linked from the Start Page. You can also use the Force Include
option to include a file from the Import Zone that is not connected to the Start Page, but is
otherwise necessary to the operation of the Web site.

The Import Zone section contains a tree-control of the Import Zone and Zone Manage-
ment buttons. The Zone Management buttons are:

• Include. The Include button enables you to specify a file or folder to include in the
import operation. If a folder is included, all of its subfolders are checked or enabled,
it is imported except for those pages that have no incoming links.

• Exclude. You can select a folder or a file to exclude from the import using this
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feature. If a folder is excluded, all of its subfolders are excluded from the Import
Zone.

• Force Include. You can select a file or folder and then click on the Force Include
button to force the objects to be included whether they are related to the Start Page or
not.

• Set as Start Page. This option enables you to select the starting point in the tree
control for the import.

• Add. You can use the Add button to create a new subfolder in the Import Zone folder.
When a new subfolder is created, you must specify a URL for the remote location or
a path for the local file or folder. DesignShop verifies the path and, if valid, expands
it to a tree, if possible.

• Delete. The Delete feature enables you to remove a subfolder form the Import Zone
folder.

• Browse. The Browse option allows you to browse your computer to locate a sub-
folder in which to add the Import Zone.

• Import Zone. DesignShop expands this folder to a tree.

IMPORTING SITES AND HTML PAGES
To import a Web site:
1. Click on the File > Site Import menu options.

2. You must select the starting point for the import in the Import Zone window. The
Import Zone window can accommodate many types of site addresses including local
hard disk, LAN or the internet.

3. Use the buttons in the Import Zone dialog box to select the parts of the Web site you
wish to include and exclude.

4. To exclude a section or files of a Web site from being imported, click on the item in
the Import Zone display and then click on the Exclude button.

5. When you have made your selections for the import, click on the Import button to
import the site.

Note: Internet/Intranet DesignShop follows the HTML specification very closely. Mil-
lions of Web pages exist on the internet. It is not uncommon to find errors in the HTML
code of some Web sites. If the Web site you import has errors, or it does not conform to
the HTML specifications, some of the Web page features may not work or parts of Web
pages not be visible.

After you finish editing the imported files, you can click on the File > Upload menu
options to upload the files to a location of your choosing. This feature generates the site
and uploads the files in one operation. Only the files that you included in the import are
updated in the upload.

When you select a Web site to import, The Import Zone window displays the physical
layout of the site. By default, DesignShop sets all pages, folders, and resources of the site
as included for the import. A small icon of a folder placed next to the resource name or file
indicates that it is a folder. A small check mark in that folder indicates that the folder or the
item is set to be included in the import. A cross icon indicates that the item is excluded
from the import. If you wish to exclude a file or resource, you must click on it to click on
it in the Import Zone and then click on the Exclude button.
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The Force Include Feature
Note that all included files and folders are imported except those that have no links to
them. If there is a Web page in a site that has no incoming links, it will not be imported.

You may, however, force DesignShop to import such a file using one of two methods:

� Select that file in the list of the Import Zone window and click on Force Include. This
will ensure that the file or page will be imported regardless of any links.

� Click and select the main folder or group which has such a file or page, and click on
Force Include. This will force the program to include and import any and all files,
resources or pages that are in a particular folder.

The Force Include feature is especially important for such items as Java Applets, Web
resource files, such as image files, custom CGI files, AVI, MIDI, animated GIF’s and
others.

For example, a simple Java Applet is generally a single file. However, many Java applets
include more than one class file. Multiple class files may not have links from an HTML
page but may have links within the Java code. In such a case, DesignShop will import the
Main Java applet class but not the related class files. The Force Include option can over-
come this situation. If you know where all the Java class applet files are located, you can
click on them in the Import Zone and click on Force Include. If you are not sure about
their location, use the Force Include to import the entire folder or group.

When importing a site, you must specify the Start Page. This will be displayed in the Start
Page field of the Import dialog box. DesignShop begins the import operation at the State
Page that you designate, tracing all HTML links through out the pages designated for the
import.

There are three methods of specifying the Start page:

� Place the cursor in the Start Page edit field and enter the location of the start page.
This can be either the full path on your PC or LAN e.g. c:\site2\index.html. or the
exact URL on the internet e.g. http://www.companyxsite.com/index.html.

� Click on Browse for Start Page button. The standard File Open dialog box is dis-
played. Select the HTML file you wish and click on OK.

� If you have already created the Import Zone layout in the Import Zone window, click
on the HTML file in the Import Zone and click on Set as Start page button. The
selected page URL will be displayed in the Start Page field.

NOTE: using the Set as Start Page button, limits you to choose a start page from the list
displayed in the Import Zone. However, if you wish to have the start page be a filename
other than those listed in the Import Zone, then you can use the ‘Start Page for import-
ing” field. Enter the location of the start page you want the import to start from in this
field. The location can be on your local hard disk, LAN, or an external URL internet
address.

When you insert a folder in the Import Zone and import the site, all the contents of that
folder are imported except the pages that have no links or references to them. However, if
you set a page to be the Start Page it will be imported whether or not it has any links or
references to it.

To import an external Web site or part of a Web site:
1. In the Import Web Site dialog box, click on the Add to Import Zone button. The
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program inserts a blank field in the Import Zone window.

2. Enter the URL address of the site you wish to import in this field.

3. Press ENTER.

4. If you are on-line, the program will go to the selected site and import the structure
reference. It will map and analyze the site and place the structure references in the
Import Zone window. The program will not import any actual files.

5. You may now Exclude any specific files, pages, folders and resources as you wish by
selecting the item and then selecting the Exclude button.

6. If you are not on-line and the site address you specified is not accessible, the program
will place a reference to this site folder in the Import Zone window.

7. After you enter the specifications for the import, click on the OK button. The import
operation will begin.

A gray folder icon placed by the program to the left of the folder or page name, indicates
a folder or resource that could not be found or imported. When you enter a page name or
folder name in the Import Zone window and press Enter, the program attempts to go to
that address and make a connection. If you are not on-line and the resource name you
entered is not accessible when you press ENTER, the path and folder or page name are
placed with a gray folder icon.

You can also use the Browse for folder button to locate a folder to import. The Browse for
folder function cannot browse the internet. It is used only to browse your local hard disk
or LAN. To browse a folder on your hard disk or LAN, click on Browse for folder and
select a folder. The Web site folder will be listed in the Import Zone window. If you use the
Add to Zone button, you can manually enter the URL or path of the site or folder, or even
a single page or resource file.

To import pages using the Import Zone:
1. Click on the Add button and enter the location and address of the folder you want to

import. Another method to select locations is to click on the Browse for folder button
and select the folder you want to import from the folder tree.

2. In the Import Zone, find the file inside the folder and click on Set as Start Page.

3. If you wish to exclude any files from the import, select the files and/or resources in
the folder and click on Exclude to exclude them from the import.

4. Click on the OK button.

5. Any pages that were not excluded plus the Start Page will be imported.

To import pages using the Start Page for importing field:
1. Enter the exact URL address (or location on your hard disk or LAN) of the page e.g.

http://xx in the Start Page for importing field and press ENTER. If you are on-line,
DesignShop will go to that URL and import the page. You may double click on the
page from the Logical Layout of the Site Manager and edit or view it. If you are not
on-line, DesignShop will not be able to import the page. In this case the program
simply opens a blank Web page.

2. If you are on-line and the URL page you entered is not valid or is not accessible, an
error message may be displayed.

3. The program accepts both types of URL’s. These include http://, ftp:/ used for exter-
nal addresses, or c:\, or File://c> for local addresses.

4. You must enter the correct path and filename for a local file. If the syntax, path or
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filename is not correct, DesignShop displays an error message.

Example: to import the page welcome.html from your C drive WEBS folder, in the
Start Page for Importing field enter

C:/WEBS/welcome.html
5. DesignShop insert the URL format in the Import Zone window. This will be in the

form of file:///c>/Webs/welcome.html. Similarly, when you use the Add button and
enter the URL address of the Web page, DesignShop displays the URL address in its
proper URL format e.g. http://www.Websitename.com

To import an entire Web site or a folder:
1. Click on the Add to Zone (if the folder is on the internet) or Browse for folder if the

site is on your hard disk or LAN.

2. Enter the URL or path for the folder or Web site and press ENTER. For internet
URL’s, you must use the format http://www.Websitename.com/, or ftp://
ftp.sitename.com/. In the case of a local resource enter the resource path e.g.
c:\foldername\subfoldername.

3. Click on the Start Page.

4. Click on OK to start the import.

The Browse for folder button is more useful for importing a folder (not a file) from your
hard disk or LAN. The browse for folder button does not browse the internet, it is used to
browse your hard disk or LAN. The Add button is used more often when the page, file or
folder is on the internet.

The advanced features of the Site Import enable you to divide the work of maintaining a
large site between a number of people. Each group can import the portion of the site it
maintains, edit it, and place that part back on the site.

Upload a Web Site
When you complete the work in creating and editing a Web site, you are ready to publish
(i.e., upload) the site to a Web server. DesignShop includes an Upload Site feature to
simplify the publishing process. Click on the File > Upload menu options to open the
Upload Site dialog box where you can enter the following information:

• FTP Server Name or Address. Enter the name of address of the FTP server to which
your site will be uploaded.

• User Login. Enter the login name that you use to access the site.

• Password. Enter the password that you use for the site. You can set the Remember
Password option in the dialog box so that you will not have to enter the password the
next time you wish to upload the Web site.

• Upload path. Enter the path on the server where you wish to upload your Web site.

NOTE: Turning on the Remember Password may affect your Web site security.

To begin the process of uploading, click on the Upload button.
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Web Site Tutorial

Introduction
DesignShop has a very advanced Web Designer capability that includes many features to
make creating and managing your Web sites easier and more efficient. The integrated
Graphics Editor enables you to build Web sites with excellent graphics within Design-
Shop. You don’t have to learn to use a lot of different applications to be able to apply the
full power of the DesignShop system. The tutorial in this chapter includes step-by-step
instructions to enable you to learn how to use the many features of DesignShop to build
simple and complex Web sites.

Lesson 1: Creating a Simple 1-Page Web Site
When you open DesignShop, depending on the General section of the Preferences dialog
box, DesignShop displays the About box, the New dialog box, the Open file dialog box, or
a new, blank project.

To start a new Web site:
1. Click on the New button in the main toolbar or click on the File > New menu options.

2. Click on the Web Site folder tab in the New dialog box.

3. If you wish to start with a blank template, double click on the blank template in the
template selector (the blank template is the box with an “X” in it).

The Web site that you create features a Web Site folder with the following structure:

� The CGI-Bin folder, the default folder for CGI script files.

� The HomePageFrameSource file, your Home Page.

� The Images folder, the default folder for images.

� The NavBars folder, the folder that will contain navigation bar image maps.

NOTE: The names of all these files and folders can be changed to match your system
needs. Since file systems differ on some Web Servers, DesignShop does not allow you
to use spaces or the following characters in the file and folder names: / : ? < > > + #

You can view the physical structure of a Web site in the Physical Layout window of the
Site Manager.

To remove items from the physical layout:
1. Click on the Physical Layout folder tab in the Site Manager window.

2. Click on the CGI-BIN folder icon to select it.
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3. Press the F5 key to delete the CGI-BIN folder. This folder contains the CGI scripts
that may be related to your Web site. You will not need it for this tutorial.

� NOTE: The WebSite and NavBar folders cannot be deleted from any Web site.
Also, the Page and FrameSource files cannot be deleted from the physical
layout for the Web site.

Managing the Visual Settings of a Page (Site)
The next step is to edit the appearance of the site.

To change the appearance of the site:
1. Click on the Logical Layout tab in the Site Manager window.

2. Click once on the Home Page icon to select it.

3. Click on the Visual Settings button or click on the Logical Layout > Visual Settings
menu options.

4. In the Web Site Visual Settings dialog box, check the Background box to place a
checkmark in it.

5. Click on a color in the color sample box to select it as the background color for the
site. You can also elect to use an image as a background, if desired. To use an image
as a background, click on the Background option and then click on the Image option
(i.e., click on the radio button next to the Image option) and then click on the image
from the Existing Resources section, the Library section, or from the URL section.

6. In the Default Colors section, check the boxes to the left of the Text, Normal, Active,
and Visited Link Colors options.

7. Click on the color box selector to the right of each of the options to open the Choose
Color dialog box for that option.

8. Click on a color for the option in the Choose Color dialog box.

9. Click on the OK button to apply the changes.

All new pages that you create for the entire site will now follow the color scheme that you
set in the Visual Settings dialog box. Each page will automatically have the selected color
for the background and the various kinds of text.

� NOTE: You can the visual settings for a single page, a frame, or a
FrameSource in the appropriate Visual Settings dialog box.

Editing the Contents of a Page
Double click on the Home Page to open it for editing. The page opens with the back-
ground color or image that you selected in the Visual Settings dialog box.

To add text to a page:
1. In the blank Home Page, type: Welcome to my

2. Click on the Center Alignment button in the toolbar or click on the Format > Center
menu options.

3. Click on the arrow to the right of the font Styles drop down list.

4. Click on the Heading1, H1 style from the drop down list.

5. Press the ENTER key to move the cursor to the next line.

� NOTE: Whenever you press the ENTER key (such as, at the end of a line of
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text), DesignShop inserts a hard return which makes the browser insert an
extra blank line. If you do not want an extra blank line, press the SHIFT +
ENTER key combination instead of ENTER.

Designing and Inserting an Graphic Objects

To create an image:
1. Click the Image button or click on the Insert > Image menu options.

2. Click on the Create button in the Choose Image dialog box.

3. Change the File Format to GIF and the Color Count to 256.

4. Click on the Make Transparent option in the Background color section.

5. Click on the OK button .

6. Check the Border status box in the Image Attributes dialog box and set the border to
zero.

7. Check the Alignment box and set the alignment to AbsMiddle.

8. In the Text section, enter: Home Page.

9. Click on the OK button.

A new image is created and placed below the “Welcome to my” text. Next we will insert
an Artistic Text object into the rectangular Image area.

To insert Artistic Text into an Image Object:
1. You must double click on the Image box to open the Graphics Editor window.

2. In the Graphics Editor, click on the Text Line button to open the Text Line dialog box.

3. In the text field, enter: “Home Page.”

4. Click on the Font folder tab and then select a font from the list.

5. Click on the Effects folder tab and select an effect from the list. For example, click on
the “One-Layer Right” effect.

6. Click on the Colors tab. For the selections we have made, the Colors tab will contain
three tabs for Background, Plane 1 and Plane 2. Each of these tabs contain two tabs:
Fill (the fill or solid color of an object) and Outline (the line around an object).

7. In the Background tab, make both the Fill and Outline colors transparent by selecting
the Transparent box.

8. In the Plane 1 and Plane 2 sections, set the fill and outline colors you wish to use.

9. Click on the OK button to apply the changes.

Now that we have created the Artistic Text object, we will change the its size so that our
Artistic Text fills all of the image area.

To change the size of the Text Line object:
1. Click on the Align & Size button to adjust the size of the Text Line.

2. Click on the Size tab in the Align & Size dialog box.

3. Click on the Sheet Width as Horizontal Size and the Sheet Height as Vertical Size.

4. Click on the OK button to make the changes.

Now that the item is inserted, we will apply a shape to the Artistic Text.
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To apply a shape to Artistic Text:
1. Click on the Select Shape button to change the mode of the selection to the shape

selection.

2. Click on the Modify Shape button.

3. Click on a shape from the list in the Modify Shape dialog box.

4. Click on the OK button.

You have now inserted and changed the shape of the Artistic Text. You should close the
Graphic Editor window. Your should see the Home Page Artistic in the Web page.

The next step is to place a horizontal line below the Artistic Text.

To create a Horizontal Rule:
1. Click the mouse at the right of the Artistic Text to place the cursor there.

2. Press the ENTER key to go to a new line.

3. Click on the Horizontal Rule button or click on the Insert > Horizontal Rule menu
options.

4. In the Style section of the Horizontal Rule dialog box, click on the 3D Shade option.

5. Click on the Center option in the Alignment section.

6. Click on the Percent option in the Width Style section.

7. Click on the Size box and enter 90 for the Line Width and 5 for the Line Thickness.

8. Click on the Specify Color box and click on a color for the Horizontal Rule by
clicking on the box of the desired color.

9. Click on the OK button.

10. Press the RIGHT ARROW key to move the cursor to the right of the Horizontal
Rule.

11. Press ENTER twice.

The Horizontal Rule is now inserted into your Web page.

Click on the Align Left button from the toolbar or click on the Format > Left menu op-
tions. Type some information about yourself and press the ENTER key. You are now
ready to proceed with adding clip art and graphics to your Web site project.

Inserting Clip Art and Graphics
In this section we will add a Welcome logo and add it to the Home Page.

To insert an image into your Web page:
1. Click on the Align Center button or click on the Format > Center menu options.

2. Click on the Insert Image button or click on the Insert > Image menu options.

3. Click on the Library tab in the Choose Image dialog box.

4. DesignShop includes a number of libraries of clip art. To select a library, click on the
arrow to the right of the library name to open the drop down list. Click on the library
name that you wish to use.

5. The images in a library display in a list box. If there are more images in the library
than will display, you can scroll to the right to view the rest of the library. If the
Preview option is turned on, an image in the library will display in the Preview box
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when you click once on the image.

6. To select an image from a library, double click on the image or click once on the
image to select it and then click on the OK button to open the Image Attributes dialog
box.

7. Click on the Border box in the Image Attributes dialog box and enter a Border Width
of zero.

8. Type Image1 in the Text section of the dialog box.

9. Click on the OK button and then click on the OK button a second time in the next
dialog box.

10. Press the RIGHT ARROW key to move the cursor to the right of the image and then
press the ENTER key.

Now that we have inserted a piece of clip art from the image library, we will insert one
from the DesignShop Graphics Editor.

To place a clip art image in a Web page from the Graphic Editor:
1. Click on the Image button in the toolbar or click on the Insert > Image menu options.

2. Click on the Create button in the Choose Image dialog box.

3. In the Image Properties dialog box, enter “300” for the Width and “300” for the
Height.

4. Use the drop down list box to change the File Format to GIF and the Color Count to
256.

5. Click on the Make Transparent option in the Background color section.

6. Click on the OK button twice.

7. Click on the Border box in the Image Attributes dialog box and set the Border Width
to zero.

8. Enter “Image 2” in the Text section.

9. Click on the OK button.

A new image is now created and placed below the previously inserted image. Next, we
will insert a clip art image into the rectangular Image Object.

To insert a clip art image into an Image Object:
1. Double click on the Image Object that you just created to open the Graphic Editor

window.

2. A clip art selector toolbar appears at the right side of the DesignShop window when
you double click the Image Object. At the top of the clip art selector is a gray button
with no image or text; click on the button to open the clip art library drop down
menu.

3. Click on a clip art image library from the drop down menu.

4. Click on the image in the list box and, while holding down the left mouse button,
drag the image to the Image Object in the Web page. When the mouse pointer is over
the Image Object, release the mouse button to drop the image in the Image Object.

5. Click on the Align & Size button in the toolbar or click on the Object > Align & Size
menu options.

6. Click on the Center option in the Horizontal section of the Alignment tab.

7. Click on the Center option in the Vertical section of the Alignment tab.



Chapter 8

8–6  � � � WebPage Construction Kit

8. Click on the Size tab in the Align & Size dialog box.

9. Click on the Keep Aspect Ratio box in the Size tab.

10. Click on the Sheet Width option in the Horizontal Group in the Size tab.

11. Click on the Sheet Height option in the Vertical Group in the Size tab.

12. Click on the OK button.

13. Press the RIGHT ARROW key to move the cursor to the right of the clip art image
and press the ENTER key.

Inserting Links to Other URL Addresses
With the cursor at the current location, enter the following text:

If you like this simple Web Page, then I will tell you how I did it, or go directly to Boomer-
ang Software, Inc. homepage.

We will now insert a hypertext link to another Web site (URL) into the text that you just
entered.

To insert hypertext links into text:
1. Click on the words “Boomerang Software, Inc.”

2. Click on the Bold button in the toolbar or click on the Effects > Bold menu options to
make the text bold.

3. Click on the Link button in the toolbar or click on the Insert > Link menu options.

4. Click on the External tab in the Link dialog box.

5. Click on the arrow to the right of the URL box and click on the HTTP:// option from
the drop down list.

6. In the box to the right of the URL, enter the actual URL address, such as
www.mosaiccom.com.

7. Click on the Insert Link button to assign the URL you entered to the selected text.

8. Cursor to the end of the paragraph and press the ENTER key.

Inserting a Mail-to feature in a Web Page
1. Click with the mouse pointer between the words “then” and “and I will.”

2. Click on the Special Text button in the Insert Object toolbar.

3. Click on the Mail folder tab in the Special Text dialog box.

4. In the Enter Your E-mail Address box, enter the e-mail address that you use, such as
myname@mycompany.com.

5. In the Enter Link Text, enter: “e-mail to me.”

6. Click on the OK button.

7. Click on (highlight) the words “e-mail to me” and click on the Bold button in the
toolbar to make the text bold.

Inserting a Date in a Web Page
DesignShop features an automatic date feature, which will automatically insert the cur-
rent computer system date into your Web page.

1. Type the following text: “This was last updated on:”
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2. Press the SPACEBAR and then click on the Special Text button or click on the Insert
> Date menu options.

3. Click on the Date tab in the Special Text dialog box.

4. Click on the date format that you would like to display in your page.

5. Click on the OK button to insert the date in your Web page.

Inserting a Copyright Symbol
The Special Text feature in DesignShop includes the copyright symbol. Since Web pages
are viewed by a wide variety of different browsers and systems, the fonts are not always
compatible. If you insert a standard Windows copyright symbol (ANSI value 169), it may
display properly in Windows based browsers, but it may be incorrect in a Unix or Macintosh
system.

To insert a copyright symbol in a Web page:
1. Use the RIGHT CURSOR key to the right of the current text.

2. Press the ENTER key to create a new line.

3. Click on the Special Text button in the Insert Object toolbar or click on the Insert >
Copyright menu options.

4. Click on the Copyright tab in the Special Text dialog box.

5. Press the CURSOR RIGHT key to move the cursor to the right of the text in the Enter
Your Copyright Text box. Now enter the text that you want to appear, such as: “My
company. All rights reserved.”

Saving Your Web Design
After you complete the work on your Web design, you should save the project to your
hard drive.

To save a Web project:
1. Click on the Save button in the toolbar or click on the File > Save As menu options.

2. Click on the path (drive and folder locations) in which to store the file.

3. Enter the name for the file. It is not necessary to add a file extension to the name;
DesignShop automatically adds the correct file extension.

4. Make sure that the Save as Type selector says Internet DesignShop Files.

5. When all of the information is correct, click on the OK button to save the file.

Previewing Your Web Site
DesignShop includes a mini-browser to permit you to view your Web pages during the
design phases. This enables you to see exactly how the page will look without having to
generate all of the HTML and resources files for the site.

To view a preview of the Web page:
1. When the Web page editor is open click on the Preview button in the main toolbar.

Generating Your Web Site
DesignShop stores all information related to your Web site in a single, proprietary file
format. As a result, the Web site cannot be viewed with an ordinary browser outside of
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DesignShop. When your Web site design is complete, you should generate the files in the
site using the Generate Site option.

To generate a Web site:
1. Click on the Generate button in the toolbar or click on the File > Generate Site menu

options.

2. In the Browse for Folder dialog box, select the folder where the site will be stored.
The Web site files will be stored in this folder in a sub folder labeled WebSite.

After you generate the site, you Web page is now ready to view in any Internet browser. It
may be uploaded to a Web server and made available to anyone on the Internet.

Lesson 2: Creating a Simple Web Site
To start a new Web site:
1. To begin this lesson, click on the Open > New menu options to create a new Web site.

2. Click on the Web Site tab in the New dialog box.

3. Double click on the blank template (the box with the “X” in it) to select it.

4. The Site Manger window opens and you are ready to begin designing your Web site.

Creating a Structure for Your Site
In this lesson, we will create a small, personal Web site. It will contain an introductory
page (i.e., the Home Page), a personal interests page, and a photo gallery.

To set a Web page properties:
1. Click on the Logical Layout tab in the Site Manager window.

2. Click on the Home Page icon in the Logical Layout window to select it.

3. Click on the Properties button in the toolbar or click on the Logical Layout > Proper-
ties menu options to open the Properties dialog box.

4. Enter “Home Page” in the Title field in the Properties dialog box.

5. Click on the Default Header in the Header section.

6. Click on the OK button to close the Properties dialog box.

To add a new Web page:
1. Click on the Home Page icon to select it.

2. Click on the New button to add a new Web page or right click the mouse button on the
Home Page icon..

3. Click on the Add option from the drop down menu.

4. A new page is inserted below the Home Page icon.

5. Click with the left mouse button on the label text below the new page icon to high-
light it.

6. Click with the right mouse button on the label text below the new page to open the
drop down menu.

7. Click on the Rename option from the drop down menu.

8. Enter the new page name in the label space. For this example, enter the name:
“Personal_Interests”
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9. Click on the Properties button from the toolbar.

10. In the Properties dialog box, enter “Personal Interests” in the Title field.

11. Enter “Personal” in the Alias field and press the ENTER key. On the next line, enter
“Interests.” This process puts the text on two lines. The lines will display in any links
to the page in the navigation bars.

12. In the Header section, click on the arrow to the right of the text “<none>” and click
on the Default Header option to insert the Default Header into the active Web page.

13. Click on the OK button to close the Properties dialog box.

To add another Web page:
1. Click on the Home Page icon to select it.

2. Click on the New button to add a new Web page.

3. Click on the Add option from the drop down menu.

4. A new page is inserted below the Home Page icon.

5. Click with the left mouse button on the label text below the new page icon to high-
light it.

6. Click with the right mouse button on the label text below the new page to open the
drop down menu.

7. Click on the Rename option from the drop down menu.

8. Enter the new page name in the label space. For this example, enter the name:
“Photo_Gallery”

9. Click on the Properties button from the toolbar.

10. In the Properties dialog box, enter “Photo Gallery” in the Title field.

11. Enter “Photo” in the Alias field and then press the ENTER key. On the next line,
enter “Gallery.” This text, in two lines, will display in any links to the page in the
navigation bars.

12. In the Header section, click on the arrow to the right of the text “<none>” and click
on the Default Header option.

13. Click on the OK button to close the Properties dialog box.

Next we will turn our attention to the appearance of the Web site including setting default
text and background colors.

To set the background for a page:
1. The first step is to design a background for the Web page. Click on the Physical

Layout tab in the Site Manager window.

2. Click on the Images folder to select it.

3. Click on the New Image button or click on the Physical Layout > Create > Image
menu options to open the Image Properties dialog box.

4. Enter 1200 for the Width and 10 for the Height.

5. Click on the JPEG image type in the File Format section.

6. Click on the Select a Different Color option in the Background Color section.

7. Click on the color box to the right of the Select a Different Color and click on the
white color box.

8. Click on the OK button.



Chapter 8

8–10  � � � WebPage Construction Kit

9. Click on the OK button to close the Image Properties dialog box.

10. Click on the image file (not the Images folder) in the Physical Layout folder tree.

11. Click on the image file name in the Physical Layout folder tree to open the drop
down menu.

12. Click on Rename from the drop down menu.

13. Enter the new name as “BG” and press ENTER.

14. Double click on the BG filename (not the folder) to open the file in the Graphics
Editor.

15. In the Graphics Editor, scroll to the left side of the image and click on the Fill Pattern
button.

16. When the Fill Pattern dialog box opens, click on the Strips pattern in the Fill Type
section.

17. In the Count section, enter “200.”

18. In the Angle section, enter: “90.”

19. Choose blue as the first color.

20. Choose white as the last color.

21. Click OK.

22. Click on the new Fill Pattern and then click on the Align & Size button.

23. In the Alignment section, choose Left for the Horizontal alignment and Center for
the Vertical alignment.

24. In the Size section, choose 1 inch (approximately 2.6 cm or 100 pixels at 96 pixels
per inch) as the Horizontal Size.

25. Click on Sheet Height as the Vertical size.

26. Click on the OK button to close the Graphics Editor window.

27. Click on the Logical Layout tab in the Site Manager window.

28. Click on the Visual Settings button or click on the Logical Layout > Visual Settings
menu options.

29. In the Visual Settings dialog box, click on the Background box and click on the “BG”
image from the Existing Resources tab. A preview of the page with the new back-
ground displays in the preview window.

30. In the Margins section, enter 10 for the Top Margin and 105 as the Left Margin.

31. Click on the OK button.

Next, we will design a default header that we can insert in any Web page in the site.

To create a default header:
1. Click on the Header/Footer tab in the Site Manager window.

2. Double click on the Default Header icon to open it for editing.

3. In the Header/Footer Editor window, click on the NavBar button from the Insert
Object toolbar or click on the Insert > Navigation Bar menu options.

4. Click on the Type tab in the Navigation Bar dialog box.

5. Click on To Other Pages in the Navigation section.

6. Click on the Home Page and First Level Pages in the Style section.

7. Click on the Image with Label option in the Type of NavBar section.
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8. Click on the Horizontal option in the NavBar Orientation section.

9. Click on the Baseline option in the Alignment section.

10. Click on the Style tab in the dialog box.

11. There are two lines in the NavBar Button Groups dialog box. The first line is First
Level Buttons and the second is “Home Page Button. Click on the Home Page button
and click on the up arrow button. The Home Page button will now be the first button
in the Navigation Bar.

12. Click on both of the lines and then click on the Font button.

13. You can select the font settings in the Font dialog box including the font name, style,
size, and color.

14. Next, click on the Home Page Button line from the list and then click on the Button
button.

15. Click on a library and a button image in the Choose Image dialog box. When you
have made your selection, click on the OK button.

16. Now, click on the First Level Buttons line from the list and perform the same opera-
tion. You can have all buttons use the same button image in the navigation bar. To do
so, select both of the lines in the list and then click on the desired button image in the
Choose Image dialog box.

17. Next, click on the Home Page Button line.

18. In the Label section, click the mouse on the Home Page text. Place the cursor at the
end of the work Home and press ENTER. The text will now appear as two lines.

19. Click on the OK button to close the dialog box.

20. Click on the Center Align button to align the NavBar in the center of the Header.

21. Close the Default Header edit window.

Now that the visual style is established for the site, we will begin designing the pages for
the site.

To set up the welcome text in the Home Page:
1. Click on the Logical Layout tab in the Site Manager window.

2. Double click on the Home Page icon to open the page in the Page Editor.

3. The Home Page now contains a Navigation Bar that allows you to navigate through
all of the existing pages. Click the mouse below the NavBar and enter a Heading text
of: “Welcome to My Home Page.”

4. Click on the Heading1, (H1) as the paragraph style.

5. Press the ENTER key.

6. Now you can enter some welcome text that you think is appropriate to your Web
page.

7. When you have finished entering text, you can close the Home Page edit window.

To set up the welcome text in the Personal Interests page:
1. Click on the Logical Layout tab in the Site Manager.

2. Double Click on the Personal_Interests page icon to open it in the Page Editor. The
Personal Interests page now contains a Navigation Bar that allows you to navigate
through all of the existing pages in the Web site.

3. Click the mouse below the NavBar and enter a heading text for the page: “Personal
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Interests.”

4. Click on the Heading1, (H1) as the paragraph style.

5. Press the ENTER key.

6. Now you can enter some text that describes your personal interests.

7. When you have finished entering the text, close the Personal_Interests edit window.

To set up the welcome text in the Photo Gallery page:
1. Click on the Logical Layout tab in the Site Manager.

2. Double Click on the Photo_Gallery page icon to open it in the Page Editor. The
Photo Gallery page now contains a Navigation Bar that allows you to navigate through
all of the existing pages in the Web site.

3. Click the mouse below the NavBar and enter a heading text for the page: “Photo
Gallery.”

4. Click on the Heading1, (H1) as the paragraph style.

5. Press the ENTER key.

6. Now you can enter some text that describes the content of the photos that will be
included on the page.

To insert images into the Photo Gallery page:
1. We will assume that the photos that you wish to insert into the Web page are indi-

vidual graphic files stored on your hard drive.

2. The first step is to click on the Insert Image button or the Insert > Image menu
options.

3. Click on the Import button in the Import Image dialog box.

4. Locate the image on your hard drive that you wish to insert into the Web page.

5. Click on the photo that you wish to import.

6. Click on the OK button to accept the photo selection.

7. Set the Border to 5 in the Image Attributes dialog box.

8. Click on the Left Horizontal alignment.

9. In the Text box, enter the text that will appear in non-graphical browsers.

10. Click on the OK button to close the Image Attributes dialog box. Non-graphical
browsers (or Web users who have graphics display turned off) do not display graph-
ics. The text that you enter in the Attributes box is displayed instead of the graphic in
these browsers.

11. When you have finished inserting the photo, you may close the Photo Gallery page.

12. You can now click on the Preview button to preview your site as it will look in a Web
browser. Navigate through it and see if everything is to your satisfaction.

Your personal Web site is now complete. You should save the project and then generate
the site files. Click on the File > Save menu options to save your Web site as a DesignShop
file. Finally, click on the File > Generate Site menu options to generate the site including
all of the necessary HTML and resource files. Your Web site is now ready to place on a
Web server for use.
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Lesson 3: Creating a Web Site with Databases
In this lesson, we will create a more complex Web site and incorporate Database Connec-
tivity into it. The first step is to create the structure of the database using a compatible
database management program, such as Microsoft Access.

For the purposes of this lesson, we will create a Visitors database to use as a Guestbook on
the Web site. The database will have the following structure:

GB - Guestbook database

� Visitors - the table of visitors

� ID - an identification number of the visitor

� Name - the name of the visitor

� E-mail - the e-mail address of the visitor

� Comment - a comment from the visitor

You should create the database with the following properties:

� ID - autonumber

� Name - 50 characters of text maximum

� E-mail - 50 characters of text maximum

� Comment - memo field

Creating the Database Structure
Open DesignShop with a blank template to begin the new Web site. If you have not cre-
ated the database, you should do so before proceeding.

To import a Microsoft Access database structure:
1. In the Logical Layout window, click on the Database Structure button. If the database

is ready, you can import the structure into DesignShop. If you have not created the
database, you will have to enter the database specifications manually into Design-
Shop.

2. Click on the Open Library button to open the Database Library dialog box.

3. Click on the Import button to open the Open dialog box.

4. Navigate to the folder that contains the Access .MDB database file that you wish to
import.

5. Click on the database file and then click on the Open button. The structure of the
database will be imported directly into the Database Library.

6. In the Database Library dialog box, click on the newly imported Database Structure
Descriptor (DSD) and click on the Get button. The structure of the database will be
imported into your Web site.

DesignShop displays the database as a tree with the database at the lowest level with the
tables and fields beneath it. In this example, there is only one table. Click on the ID field
and then click on the Delete button. The ODBC driver will enter the ID numbers for the
visitors, so we do not need the original ID field.

If you create the database in an application other than Microsoft Access, you will have to
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enter the structure manually in the Database Wizard.

To describe the structure of a database manually:
1. Click on the Add button in the Database Wizard dialog box. This will create a new

database in the wizard.

2. Enter “GB” as the name of the new database and press ENTER.

3. Click on the Insert button to insert a table into the new database.

4. Enter “Visitors” as the name of the table and press ENTER.

5. Click on the Insert button to insert a field into the Visitors table. A database field is
then created in the Visitors table.

6. Enter “Name” for the name of the new field.

7. Click on the Properties button to open the Field Properties dialog box.

8. Click on the VarChar type in the Data Type drop down list.

9. Enter “Name” in the Column Caption field.

10. Click on the OK button to close the Properties dialog box.

11. Click on the Add button to add a field to the Visitors table.

12. Enter “E-mail” as the name of the field.

13. Click on the Properties button to open the Field Properties dialog box.

14. Click on the VarChar type in the Data Type drop down list.

15. Enter “E-mail” in the Column Caption field.

16. Click on the OK button to close the Properties dialog box.

17. Click on the Add button to add a field to the Visitors table.

18. Click on the Properties button to open the Field Properties dialog box.

19. Click on the VarChar type in the Data Type drop down list.

20. Enter “Comment” in the Column Caption field.

21. Click on the OK button to close the Properties dialog box.

22. Click on the Add button to add a field to the Visitors table.

23. Click on the Properties button to open the Field Properties dialog box.

24. Click on the VarChar type in the Data Type drop down list.

25. Enter “Name” in the Column Caption field.

26. Click on the OK button to close the Properties dialog box.

The Database Structure Descriptor is now ready to use.

To set up the Web page for the database:
1. In the Logical Layout window, click on the New button to create a new page labeled:

“Sign.”

2. Click on the Home Page icon for the Web site.

3. Click on the Properties button to open the Properties dialog box.

4. Enter “Home Page” as the page Title.

5. Enter “Home” + ENTER key + “Page” as the Alias.

6. Click on the Default Header as the Header.

7. Click on the OK button to close the Properties dialog box.
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8. Click on the Sign Web page to select it.

9. Click on the Properties button to open the Properties dialog box.

10. Enter “Sign Guestbook” as the page Title.

11. Enter “Sign” + ENTER key + “Guestbook” as the Alias.

12. Click on the Default Header as the Header.

13. Click on the OK button to close the Properties dialog box.

14. Double click on the Home Page icon to open the page in the Page Editor.

To insert a Form without Form Controls:
1. Move the cursor to the bottom of the Home Page and click on the Form button.

2. Click on the Form Properties button to open the Form Properties dialog box.

3. Click on Data Base Query (SQL) as the CGI Output Type.

4. You should now ask the system administrator for you Web server what the Perl Inter-
preter and CGI File Extensions are for the system.

5. Click on the CGI Output Properties button to open the Choose Data Source for New
Query dialog box.

6. Click on the “GB” database in the Data Sources drop down list.

7. Set the Query type to SELECT.

8. Click on the Edit Query button to open the Query Properties dialog box.

9. In the Select tab, click on the “Visitors” table.

10. Click on the Add All >> button.

11. In the Order tab, click on the “Name” field and then click on the Add > button.

12. In the Feedback tab, change the Style to Table.

13. Enter “10” for the Result Portion.

14. Click on the Border box.

15. Set the Align to Left.

16. In the Feedback Heading section, enter “Guestbook.”

17. Click on the OK button.

18. Click on the OK button again.

19. Close the Home Page edit window.

To set up the guestbook information in the Web page:
1. Click on the Header/Footer tab in the Site Manager window.

2. Double click on the Default Header icon to open the Header editor window.

3. Click on the Center Align button in the toolbar and enter the following text: Home
Page Sign Guestbook Read Guestbook”

4. Click on the words, “Home Page” and then click on the Link button in the toolbar to
open the Link dialog box.

5. In the To Page tab, click on the Home Page.

6. Click on the Assign URL option.

7. Click on the words, “Sign Guestbook” and then click on the Link button in the tool-
bar to open the Link dialog box.

8. In the To Page tab, click on the Home Page.



Chapter 8

8–16  � � � WebPage Construction Kit

9. Click on the Assign URL option.

10. Click on the words, “Read Guestbook” and then click on the Link button in the
toolbar to open the Link dialog box.

11. In the To Resource tab, click on the CGI resource.

12. Click on the Assign URL option.

13. Close the Default Header edit window.

From the Logical Layout window, open the Sign page for editing by double clicking on it.
We will insert a form that enables the user to sign the Guestbook.

To insert a Guestbook form:
1. Place the cursor on the Web page where you wish to insert the form than then click on

the Form button to insert a form into the page.

2. Enter “Your name: “ in the page.

3. Click on the Text Line button in the Form Fields toolbar to open the Text Line Proper-
ties dialog box.

4. Enter “Name” in the Name section.

5. Delete the Default Text in the Value section.

6. Enter “50” as the maximum character width.

7. Click on the OK button.

8. Enter “Your e-mail address: “ in the page.

9. Click on the Text Line button in the Form Fields toolbar to open the Text Line Prop-
erties dialog box.

10. Enter “E-mail” in the Name section.

11. Delete the Default Text in the Value section.

12. Enter “50” as the maximum character width.

13. Click on the OK button.

14. Enter “Your comments: “ in the page.

15. Click on the Text Line button in the Form Fields toolbar to open the Text Line Prop-
erties dialog box.

16. Enter “Comment” in the Name section.

17. Delete the Default Text in the Value section.

18. Enter “21” for the Field Size and “4” for the Text Max Length.

19. Click on the OK button.

20. Click on the Push Button button in the Form fields toolbar to open the Push Button
Properties dialog box.

21. Enter “Sign the Guestbook” in the Value section.

22. Click on the OK button.

The form is now ready for the final step, setting the properties.

To set the properties of a form:
1. Click on the Form Properties button to open the Form Properties dialog box.

2. Click on the Data Base Query (SQL) as the CGI Output Type.

3. Ask the system administrator for your Web server what the Perl Interpreter Path and
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the CGI File Extensions are to use with your system.

4. Click on the CGI Output Properties button to open the Choose Data Source for New
Query dialog box.

5. Click on the “GB” database in the Data Sources drop down list.

6. Set the Query Type to INSERT.

7. Click on the Edit Query to open the Query Properties dialog box.

8. Click on the Visitors table in the Insert tab.

9. Click on the Name field in the Visitors table.

10. Click on the Edit button to open the Set Value dialog box.

11. Click on the Name filed in the Control tab.

12. Click on the OK button.

13. Perform steps 9 through 11 for the other two fields in the table selecting the appropri-
ate controls.

14. Enter “10” for the Result Portion.

15. Click on the OK button.

16. Click on the OK button a second time.

You have now created forms for signing and reading the guestbook. You can complete any
additional information or page content before you begin using the pages.

After generating your site to the server, ask the server system administrator to declare
your database as an ODBC Data Source. You sit is now ready for browsing.
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Chapter 9.

The Graphic Editor

Introduction
The DesignShop work page is one of the most important elements of the application.
Understanding the window, tools, and features can make using the application quick and
efficient. DesignShop is similar to many Windows applications in that it uses pull-down
menus, button, or icon bars, status bar, and minimize/maximize controls.

In this chapter we will look at the contents of the DesignShop window and the functions
of the various toolbars and icons. Many of the toolbars can be turned on or off; this chap-
ter assumes that you are using DesignShop with the default settings and all toolbars turned
on.

The Graphic Editor
While designing your layout on the work page, you can use (insert and edit) the following
objects:

Text Line or Artistic Text

Image

Fill Pattern

Border

Paragraph Text

Calendar

Chart

OLE

To insert any of these objects in the work page, you can either click on the appropriate
buttons in the Main toolbar, or click on Add from the Object menu.

The objects you place on the work page, can be in Normal or Template Placeholder form.
Normal objects display the exact image, such as graphic image, clip art, Fill Pattern.
Template Placeholders are a symbolic representation of an object. You can click on any
Normal object to select it, and click on the right mouse button to bring up the Floating Edit
menu. Click on the Show menu then click on As Placeholder. The Object will now be
displayed in a Placeholder form. The Placeholder will have a color, and a small symbol
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representing the type of object it represents. This small symbol is identical to the Insert
Object icons located in the Main toolbar. When you flip a Template Placeholder, the sym-
bol will be placed in a different corner of the bounding box. This will visually and quickly
indicate to you that the object inside the Template Placeholder is flipped in one of the
available directions.

The color code and graphic icons for Template placeholders are:

Text Line - blue

Image - red

Fill Pattern - cyan

Border - yellow

Paragraph Text - bright green

Calendar - pink

Chart - olive

OLE - teal

Template placeholders and Template files are unique and useful features of DesignShop.
They enable you to create layouts and designs, convert some of the objects to Template
Placeholders, then save the file as a Template file. The specific object imbedded in the
Template Placeholders will not be saved. The settings and characteristics you chose for
that object will be saved instead. When you open a Template file, you can simply double
select any Template Placeholder and choose from one of the available choices or fill in the
text. The Template Placeholder will be displayed as a regular object, having all the set-
tings that were imbedded in it originally.

You can use this feature to design a work page, including settings for color, text size, text
font, then save it as a Template, ready to be used again with different content but with the
same design.

When you open a new file (using the File > New... menu options), you can open regular
files with Normal objects and files that include one or more Placeholder objects. You can
edit each of the Placeholders and fill in the appropriate contents. You can save your files
as document files or as Template files.

Note: The Placeholder feature applies to Internet DesignShop work page and Web
pages. To switch any graphic object or text line to a placeholder, drag the mouse over
the object to select it, click the right mouse button, and click on Show Placeholder. This
way you may switch one or more objects on your Web page to placeholders permitting
you to save the document as a Web page template/style sheet.

The Graphics Editor Window
The DesignShop Graphics work page window features a main menu, a Main toolbar be-
low the main menu, a Control Toolbar on the bottom of the window, a Clipart Bar on the
right side of the window. In addition, DesignShop features context sensitive help in the
Help and Status Bar at the bottom of the screen. Understanding the location and function
of these tools will make using DesignShop easier. The following describes the toolbars
and their default locations:
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1. Main Menu. The main menu provides access to DesignShop functions via the
keyboard or by clicking on a menu option with the mouse.

2. Main toolbar. The Main toolbar appears across the top of the DesignShop win-
dow below the main menu. This toolbar offers quick mouse access to many of
the most basic functions, such as Save, Print, Cut, Paste, etc.

3. Control Toolbar. The Control Toolbar appears on the bottom of the Design-
Shop window. This toolbar includes object manipulations (move, rotate, dis-
tort) and viewing functions such as zoom in and zoom out.

4. Clipart Bar. The Symbol Bar, on the right side of the DesignShop window,
displays one of a number of different symbol or image libraries included with
DesignShop. To use a symbol from the Symbol Bar, click on the symbol and,
while holding down the left mouse button, drag the symbol onto the work page.

5. Help and Status Bar. The Help and Status Bar at the bottom of the DesignShop
window is different from the other toolbars in that it does not contain buttons.
When the mouse pointer points to an area of the screen or on a button in a
toolbar, the Help and Status Bar displays the function of that area or object.

6. Ruler. The Ruler feature is turned on when you first install DesignShop. The
ruler is useful in determining measurements when designing a document.

Floating Toolbars
Most of the DesignShop toolbars can be made to float or relocated at different locations in
the DesignShop window. A floating toolbar can be moved to any location for easier access
and convenience. You can dock a floating toolbar by returning it to its default location or
to one of the toolbar locations at the top or bottom of the DesignShop window.



Chapter 9

9–4  �  �  � WebPage Construction Kit

To relocate or undock a toolbar, double click in the toolbar area (not inside one of the
toolbar buttons). The toolbar will be immediately undocked. Place the mouse pointer on
the toolbar title bar and drag it to the position in the window that you desire.

Main Toolbar
The Main toolbar appears across the top of the DesignShop window. It provides quick and
easy access to functions that are commonly used in creating documents.  We will examine
each of the buttons in the Main toolbar to see how they are used in creating a new docu-
ment.

New
The New button opens the New dialog box so that you can begin a new project. When the
New dialog box opens, you can select from one of the existing DesignShop templates or
start with a blank work page.

Open File
The Open File button opens the Open dialog box so that you may select an existing De-
signShop file. You may open a DesignShop document file (a file with an extension of
.CNQ) or a DesignShop template file (a file with an extension of .CTM).

Save Document
The Save button in the Main toolbar saves the current, previously saved file in Design-
Shop to the same name and directory location.

If the current file is new and has not been previously saved, the Save As dialog box opens
when you click on the Save button.

Page Setup
The Page Setup option in the Main toolbar enables you to design the page layout to use in
the current document. The page setup options are different for each type of document
output.

Print
The Print button opens the Print... dialog box so that you may print the current Design-
Shop file. The Print... dialog box title bar indicates the type of output, such as, Print the
Greeting Card. If you wish to setup the printer or change print parameters, you should do
so before using the Print button; the Print... dialog box does not include a printer setup
option.

The Print... dialog box offers a number of different options depending upon the type of
project:

save

open

print

page
setup

redo

undo

help

cut paste output type selector
project
window generate

copy preferences previewnew
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A. Cut Marks. If your document is made up of multiple pieces of paper, such as
larger banners, posters, or calendars, the Cut Marks option can print dotted line
indicators to guide you in cutting the sheets for assembly. The Cut Marks option
prints solid fold lines on greeting cards and coloring book projects. This feature
is only available for projects that require cut and paste, such as multi-page post-
ers and banners or folding, such as greeting cards and coloring books.

B. Type Imprint. The Greeting card module features an imprint caption that prints
“Created by DESIGN SHOP” when the feature is on. The imprint prints on the
back of the greeting card. An “X” in the status box next to this option indicates
that the option is on and that the imprint will be printed.

Printable Area
The Printable Area is a rectangular area located inside the DesignShop work space. The
color of this area is set white. You can set this color in the Preferences dialog box. The
Printable Area indicates the boundaries of your output printable document. The divider
lines surrounding this rectangular area define the exact printing boundaries. If you create
a multi-page document, such as a tiled banner or poster three pages high and four pages
long, the divider lines will show the printable area page layout for the entire banner or
poster. You can change the layout by setting the correct options in the Page Setup dialog
box. This dialog box is displayed when you click on File menu, then Page Setup.... Each
Output Form has its own specific Printable Area size.

Undo
The Undo button in the Main toolbar reverses the last action taken in DesignShop. There
is no prompt to confirm the action; when you click on the Undo button, the last action is
automatically reversed (i.e., the document returns to the state it was in before you made
the last change). The Undo icon is active only after you have completed some action in the
current document.

DesignShop enables you to have as many as 32,767 levels of Undo (i.e., you can undo the
last 32,767 actions in a document). The default undo level is set to 100 which enables you
to undo the previous 100 steps. While it is convenient to be able to undo many levels,
DesignShop requires additional memory and/or disk storage to retain the undo/redo lev-
els. You may wish to consider the memory requirement and operating speed when you are
selecting the number of levels. The Undo and Redo functions are set to the same number
of levels.

You can change the number of undo/redo levels in the Preferences dialog box by clicking
on File > Preferences and entering the number of undo/redo levels you wish in the Undo/
Redo Levels combobox.

You can only undo actions within a document during the current work session. You cannot
undo actions such as save, new, or print. You cannot undo actions completed in a previous
work session. If you set the Undo/Redo level to zero in the Preferences dialog box, the
Undo feature will not work; the undo/redo level must be a number between 1 and 32,767.

Redo
The Redo button in the Main toolbar reverses the last Undo that you performed in Design-
Shop. There is no prompt to confirm the action; when you click on the Redo button, the
last Undo is automatically reversed (i.e., the document returns to the state it was in before
you did the last Undo). The Redo icon is active only after you have used the Undo feature
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in the current document.

DesignShop enables you to have as many as 32,767 levels of Undo and Redo (i.e., you
can undo and redo the last 32,767 actions in a document). The Undo and Redo functions
are linked to the same default level.

To change the undo/redo level in the Preferences dialog box, see the previous section on
Undo. Please note the memory limitations described.

You can only redo actions within a document during the current work session. You cannot
redo actions such as save, new, or print. You cannot redo actions completed in a previous
work session.

Cut
The Cut option deletes the selected object(s) and placed them in the Windows Clipboard.
After the objects are in the Clipboard, you can paste them into another DesignShop project
or into another Windows application. This feature is only active when a graphic or text
object is selected.

Copy
The Copy option copies the selected object(s) to the Windows Clipboard. After the objects
are in the Clipboard, you can paste them into another DesignShop project or into another
Windows application. This feature is only active when a graphic or text object is selected.

Paste
The Paste option inserts an object from the Windows Clipboard directly into the Design-
Shop work page. You can paste graphic objects and text objects. This feature is active only
if there is an object in the Windows Clipboard.

Output Type Selector
The Output Type selector is located in the center of the screen above the DesignShop
work page. This list box selector enables you to choose the type of document you wish to
create in DesignShop: poster, banner, greeting card, business card, calendar or Web site.
You may also select the type of document using the New option or the Output Type option
in the DesignShop File menu. When you select a different output type, DesignShop opens
the New dialog box so that you may enter the type of output and, if desired, a template.

To change the output type, click on the arrow to the right of the Output Selector list box
and then click on the output type desired. In the New dialog box, select the output type
desired (i.e., banner, poster, greeting card, etc.). If necessary use the vertical scroll bar to
scroll to the desired output type. Double-click on the pre-designed template that you wish
to use or double-click on the blank template to open a blank document. Use the scroll bar
to scroll to the desired template if necessary.

Preferences
The Preferences button opens the Preferences dialog box in which you can set user pref-
erences. DesignShop offers a number of customizable preference settings for controlling
various aspects of the application. While you may not wish to change these settings until
you are more comfortable with the operation of the program, it is good to review the
preference settings so that you know what is available. You can come back to the Prefer-
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ences options and change them at any time.

The Preferences dialog box features a number of tabs across the top that effect the opera-
tion of the application in different areas. These areas and the preference settings include:

General
� Undo/Redo. This feature enables you to set the levels (i.e., the number of previous

steps which you can undo and redo in the application). The number can be anything
between 0 and 32,767. The higher the number, the more RAM and hard drive space
is required to store the different levels.

� Startup. You can have DesignShop open to a blank page, the DesignShop About
dialog box, the New - Template selector (select a template for a new project), or to
the Open File dialog box.

� Autosave. The Autosave feature, when turned on, enables you to set the number of
minutes between automatic saves of your current project.

� Create Backup Files. If you turn on the Create Backup Files feature, DesignShop
will not overwrite existing files when you try to save a file to an existing name. If you
try to save a file to a file name that already exists, DesignShop will create a backup
copy of the existing file before it saves the current file.

Graphic Editor
� Ruler Units. You can select inches, centimeters, millimeters, or pixels as the unit of

measure in the work page.

� Workspace. You can select the Sheet and Shadow options in the Workspace section.
When both options are turned on (i.e., there is a check mark in the box to the left of
the item), the work page Sheet displays as a rectangle with a gray drop shadow. If
you click on the color sample box to the right of the options, you can select the color
for the Sheet and the Drop Shadow.

� Objects. The Objects option enables you to determine where new objects, such as
graphics and text, are inserted into the workspace. You can elect to have all new
objects inserted in the center of the work page or in the center of the visible work area
(if you are zoomed in on a particular portion of the work page.

� Grid. The Grid feature enables you to select the frequency or the number of lines for
the grid in a given space. The frequency selection measurement depends upon the
units of measure selected. For example, if you select inches as the Ruler Units, you
will select the grid based upon the number of lines per inch.

Web Site
� Default Colors. The Default Colors option enables you to select the standard or

default colors for the text, hypertext links, and the background for all pages in the
Web site. To select a different color, click on the color selector box to the right of the
desired option.

� Encoding. The Encoding option enables you to select the type of language and char-
acter encoding to include in your Web site.

� Proportional Font. The Proportional Font option enables you to select the default
proportional font to use in your Web site. This font is used in your Web site in any
instance in which you do not otherwise specify a font.

� Fixed Font. The Fixed Font option enables you to select the default fixed or
monospaced font to use in your Web site.
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� Navigate Layout. The Navigate Layout section enables you to select the default
colors for the hypertext links in your Web site. You may change the Selected Page,
Orphan Page, Internal Link, and External Link colors by selecting the color box to
the right of each option.

� Headers/Footers. The Headers/Footers option, when turned on, automatically places
the default header and/or footer into a new page.

Browsers
� Browsers. The Browsers option enables you to specify the default Internet browser

to use when you wish to test view your Web pages. You may enter as many different
Web browsers that you wish. If you are doing a good deal of Web design, you may
wish to install and use several of the most popular browsers, including Microsoft
Internet Explorer and Netscape Navigator, so that you can see how your pages will
display in each.

� Web Promote. The Web Promote includes favorite Web sites that you wish to be
able to quickly access from within DesignShop. You may wish to include HTML
reference sites, JavaScript sites, the Boomerang Web site, or any other site that you
find particularly useful in doing Web page design.

Toggle Project Window (Web Designer only)
The Toggle Project Window button turns the Site Manager window display on and off.
This feature is only available in the DesignShop Web Site Design module.

Help
The Help button opens the DesignShop Help file system so that you may access the help
files.

Generate Web Site (Web Designer only)
DesignShop stores Web sites as a single, proprietary file. To be able to use the file on the
Internet and with Web browsers, you must use the Generate Site option that creates all of
the necessary HTML and resource files necessary to complete your Web site design. This
feature is only available in the DesignShop Web Site Design module.

Preview (Web Designer Only)
The DesignShop Web Design module includes a built-in Web browser that you can use to
preview Web pages as you work. This allows you to see how a page will appear in a
browser without having to generate all of the HTML and resource files needed for the
Web site. This feature is only available in the DesignShop Web Site Design module.

Main Toolbar (for Objects)
The Main toolbar includes buttons to create and edit various types of objects in Design-
Shop projects.

Text Line Tool
DesignShop features two different text tools with which you may add text to a document:
the text line tool and the paragraph text tool. The text line tool enables you to enter one
line of text at a time; the paragraph text tool enables you to enter more than one line at a
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time. There are a number of other differences in these two text entry systems:

Text Line Para-
graph Text

1. Enter one line of text Yes  Yes
2. Enter more than one line of text No  Yes
3. Choose text colors Yes  Yes
4. Choose background colors Yes  Yes
5. Specify color for borders on characters Yes  No
6. Import ASCII text from other sources No  Yes
7. Resize the text using mouse controls or Align & Size Yes  No
8. Resize the text by selecting font size No  Yes
9. Align text left, right, center, and full Yes  Yes
10. Apply special/shadow effects Yes  No
11. Apply shape effects Yes  No
12. Text input limited to 128 characters Yes  No
13. Place text horizontally or vertically Yes  No
14. Specify inter-character spacing Yes  No
15. Word-wrap availability No  Yes

When you select the text line tool, DesignShop opens the Text Line dialog box. You may
enter up to 128 characters in the text Tool dialog box. You may also select whether to use
horizontal or vertical placement and enter the desired amount of spacing between charac-
ters (i.e., inter-character spacing).

To enter text using the text line tool, first click on the text line tool button in the New
Object toolbar. When the Text Line dialog box opens, enter up to 128 characters of text in
the text entry box. Select the Inter-character spacing or accept the default value of 5.
Select Horizontal or Vertical orientation in the Orientation section. Click on the OK but-
ton when you have completed the text entry.

To edit a text line, you may also use the following icons from the Object toolbar. This tool
box is displayed whenever you select an object, or when you click on the Modify menu.

� Edit Text Button

� Change Text Font Button

� Edit Text Color Button

� Set Text Effects Button

� Change Text Shape Button

You may also change the position of a selected object in relation to its bounding box. Do
this by using the Alignment menu. Each of these commands have equivalent icons that
you can select from the Main toolbar. These icons are:

� Adjust Text to Left Button

� Adjust Text to Right Button

� Center Text Button

� Adjust Text Proportionally Button

These icons are located on the Object toolbar. You may hide or display the Object toolbar
by using the View menu.
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Image Tool
The Image tool enables you to insert images into a DesignShop document from a graphics
library using the Insert Image dialog box.

To insert an image into a document using the Image tool, select the Image tool icon in the
New Object toolbar. Then, in the Insert Image dialog box, click on the down arrow next to
the library name to select a library. Use the horizontal scroll bar below the image display
to scroll through the image library. Click on the View sample option to place an X in the
status box if you would like to view a graphic in greater detail before importing it. Finally,
click on the OK button to import a selected graphic.

You may also import other types of graphic files using the Import function in the Insert
Image dialog box. To use the Import Graphic function, click on the Import button in the
Insert Image dialog box and select the desired graphic file. You may use the Drives and
Directories option in the Import dialog box as desired.

Once you have selected a clip art and placed it on your work page, you can replace it using
the Replace Image command from the Modify menu.

Fill Pattern Tool
The Fill Pattern Tool provides a good and quick method of placing fill patterns in a De-
signShop document. The fill pattern covers the entire print area of the work page with a
pattern or color that you select from the Create Fill Pattern dialog box. After the pattern is
placed on the page, you can drag the borders to resize the Fill Pattern object. DesignShop
includes a wide range of fill patterns and color combinations from which you may select,
or you may create your own.

The Fill Pattern tool offers three different types of pattern selections: color, picture pat-
terns, and brush backgrounds. You can also edit one of the pre-made patterns and use it. To
select a particular fill pattern for a document, click on Fill Pattern Tool in the New Object
toolbar. Next, click on the tab for the type of Fill Pattern you want. They include: color,
brush, and picture.

The options for the Color patterns tab include: Fill Type, Count, Angle, Mix, Line Width,
Symmetric, First Color tab, and Last Color tab.

The Brush and Picture pattern tab include different libraries of many pre-designed brushes
and pictures.

You can change the center or symmetry point for some of the Colored patterns. To do this,
click and drag the mouse in the Sample window. If you click on the Brush Pattern button
option, dragging the mouse in the Sample Window will produce different pattern results.

 If you click the right mouse button in the Sample window, the center point of the Colored
pattern will be automatically set to the center of the Sample window. In the case of Brush
and Picture options, clicking on the right mouse button will set the origination point of
these patterns to the upper left corner of the Sample window.

Once you create a Pattern and place it on the work page, it is treated as an object. To edit
this object, click on the Modify menu then Properties, or use the Floating Tool Box.
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Color Fill Type
When you select the color fill pattern in the Create Fill Pattern dialog box, the box ex-
pands to display the Filler and Color Mix options. The Sample box displays a graduated
color scale which displays the range of color based upon the color combination in effect.
To select a different pattern, click on the down arrow next to the Filler combo box. You
may select from the following Filler patterns:

Strips Circles

Sectors 1 Sectors 2

Rectangles Arcs

Tangents Lines

In addition to the Filler, you may select the Color Mix that you wish to use for the fill
pattern. To select a color mix, click on the arrow to the right of the Color Mix combo box.
You may click on Off as a color mix or any of the pre-designed color mixes that are
designated as Type A through Type L.

You can change a color in the pattern by first selecting the down arrow to the right of the
Color Mix list box. Next, scroll to the desired type (or click on Off). The color mix will
change to the selected pattern.

You may select the colors for the background pattern by designating the first and last
colors to be used in the pattern. Many of the patterns are graduated with one color slowly
blending into another. You may designate the colors to use by designating the First Color
and the Last Color from the colors in the Color Bar scroll box by selecting either the First
color option or the Last color option in the lower left corner of the Fill Pattern dialog box.
Next, click on the color in the desired color combination in the Color Bar scroll box. The
selected fill color (i.e., first or last) will change to the selected color. If desired, you can
mix colors from different color combinations. For example, you may select a color from
the default color collection for the First color and select a color from the blue palette
collection for the last color.

Additional options in the Fill Pattern dialog box deal with the manner in which the colors
blend. These options provide control over how the colors are blended in the background
fill pattern.

A. Symmetric. The default color in the background pattern fill is to blend from
one color to another. The Symmetric option blends the pattern from the first
color to the last color and back to the first color.

B. Count. The Count option scroll list controls the number of lines or graduations
that are displayed in the fill pattern. For example, a Count of two displays just
two solid colors: the first color and the last color (i.e., there are only two gradu-
ations between the two colors). You can use the scroll arrow to change the count
or delete the number in the scroll box and type the desired number.

C. Angle. The Angle option controls the angle at which the graduated lines appear
in the background fill pattern. A zero angle displays the graduated lines hori-
zontally. A 45 angle displays the graduated lines diagonally. A 90 angle displays
the graduated lines perpendicular to the screen.

D. Line Width. The Line Width option is only available for the Tangent and Lines
selections in the Filler scroll box. The Line Width option enables you to change
the width of the lines in the fill pattern when the appropriate Filler is selected.
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Pictures
You can use pictures or clip art to make up a fill pattern in DesignShop. You may use an
image included in the DesignShop Pictures pattern selection or you may create a pattern
library of your own clip art. The appearance of the picture fill patterns can be controlled
by changing the size of the image in the pattern.

Frame and Border Tool
The Frame and Border tool enables you to insert a graphic frame or border into a
DesignShop project. These graphics differ from some of the other types of clip art
in that they feature outside borders with a transparent center to permit text to show
through. You may select frames and borders from existing libraries or create your
own new border libraries (for additional information on editing border libraries).

The Insert Border displays the borders and frames in a scroll list box. You can select the
View Sample option (to place an “X” in the status box) to view a highlighted border in
greater detail before inserting it into your DesignShop document.

To insert a border into a DesignShop document, first click on the Frame and Border Tool
in the New Object toolbar. Next, click on a border in the borders list box to highlight it.
Use the horizontal scroll bar at the bottom of the scroll list box to scroll through the list if
desired.

Click on the View Sample option in the lower right corner of the Insert Border dialog box
to place an X in the status box.

Click on the down arrow to the right of the border selector to open the library selector list.
Click on the desired library to open the scroll list box for that library.

When you have selected the border to use in your DesignShop document, double-click on
the border or click once on the border and then click on the OK button.

Paragraph Text Tool
The DesignShop Paragraph Text Tool provides a method of entering paragraphs of text
(i.e., more than one line) in a document. The Paragraph Text Tool differs from the Text
Tool in a number of important ways. You should use the Paragraph Text Tool when you
have one of the following needs:

A. To enter more than one line of text.

B. To enter one line of text that is longer than 128 characters.

C. To import ASCII text into your DesignShop document.

D. To control the font size by selecting a specific point size, such as 12 point text.

To insert paragraph text into a DesignShop document, click on the Paragraph Text Tool
from the New Object toolbar to create a paragraph text box. Next, click on the Change
Text button in the Object toolbar (the first button with the letter “T”) to edit the text. Enter
the text you want.

When you have entered the text and placed it on the work page, you can edit it by select-
ing the text and then selecting the Format > Edit Text menu options or by selecting the
Change Text (T) button in the Object toolbar.
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Text Alignment
Paragraph text can be aligned left, right, centered. After you have entered the text, you
may apply an alignment command by selecting the appropriate alignment tool from the
Formatting Toolbar.

Align Text Left
This feature aligns all text to the left with the right margin ragged or uneven.

Align Text Right
This feature aligns all text to the right with the left margin ragged or uneven.

Align Text Center
This feature aligns all text to the center with both the left and right margin uneven.

Align Text Justified
This feature aligns all text so that the left and right margins are even or are flush.

Borders and Drop Shadows on Paragraph Text Boxes
DesignShop defaults with the paragraph text outline border option on and the drop shadow
option off. You can turn the features on or off using the Attributes option in the toolbar.

Resizing the Paragraph Text Box
The DesignShop default is to place paragraph text inside a box that has an outline border
without a drop shadow. You may wish to resize the highlight box around the paragraph
text so that it is about the same size of the text itself. Even if the paragraph text box outline
is off, you should resize the box so that it does not interfere with other objects in the work
page.

To resize the paragraph text box begin by selecting the paragraph box that you wish to
change. When you click on the box, sizing buttons will appear around the outside of the
paragraph text box.

Place the mouse pointer on the bottom center sizing button and click-and-drag the sizing
button up until it is just below the paragraph text (i.e., hold down the left mouse button
and drag the sizing button to a new location while holding down the mouse button). When
you click the mouse over a sizing button, a four direction arrow appears next to the mouse
pointer arrow.

Place the mouse pointer on the left center sizing button and click-and-drag the sizing
button to the right until it is next to the paragraph text.

Place the mouse pointer on the right center sizing button and click-and-drag the sizing
button to the left until it is next to the paragraph text.

Calendar Tool

Calendar Types
The Calendar Tool in the New Object toolbar enables you to insert a calendar object into
any graphic DesignShop document. If you wish to insert a calendar into an Internet Web
page, you must first create the calendar, and then import it or place it in the Web page
layout. You may insert a wide range of calendar types into a document and then customize
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the calendar as desired.

DesignShop supports six types of calendars:

� yearly

� semiannual

� quarterly

� monthly

� weekly

� daily

After you choose and place a calendar on the work page and select it, you can edit it by
clicking on the Modify menu (or by using the Object toolbar). Some of the calendar
editing options you can perform are:

� Redefine your calendar type

� Change the colors of the text, background, shadow, etc.

� Change the date

� Highlight your special days

� Change the day ordering

� For yearly, semiannual, and quarterly calendars, change the month layout of the
calendar

� Click on a font for your calendar

Creating a Calendar
To insert a calendar into your DesignShop document, click on the Calendar Tool in the
New Object toolbar.

Next, click on the type of calendar you wish to use from the following options:

� Yearly (12 months)

� Semi-annually (6 months)

� Quarterly (3 months)

� Monthly

� Weekly

� Daily

After you select the type of calendar, you may select from the following display options:

A. Separate blocks. Place the months, days, or hours into separate outlined blocks
in the display.

B. Space. Inserts a space between the individual boxes in a calendar. For example,
if the Space option is on in a monthly calendar, each date’s box appears to have
a drop shadow. If the Space option is off, the drop shadow appears around the
outside of the entire month only.

C. Shadow. Displays a drop shadow around the boxes in the calendar.

D. Outline. Displays an outline around the entire calendar.

You may select a calendar object to reposition it or resize it just as you would any other
piece of clip art. To edit the calendar, you can access the Calendar dialog box either by
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double clicking on the calendar on the work page or by selecting the Modify menu.

Set the Calendar Layout
Displays the Calendar dialog box and enables you to set the monthly arrangement. You
can change the Layout only for yearly, semiannual, and quarterly calendar types. For
more details on how to modify Calendar Types, please refer to the section on Calendar
Types.

You can choose horizontal, vertical, and other monthly arrangements. You can also set the
order of the months to be either horizontal or vertical.

The Calendar Layout dialog box is displayed when you either use the Object toolbar or
when you click on Modify > Layout options.

Set the Calendar Date
Displays the Calendar dialog box and enables you to set different attributes for the calen-
dar. The available options are different for different types of calendars. The available
choices are:

� year

� half-year

� quarter

� month

� week

� hour

When you click on the Current button the current date will be applied to the calendar.

The Calendar dialog box will be displayed either when you use the Object toolbar, or the
Modify menu, click on Date.

Set the Calendar Highlighted Days
Displays the Calendar dialog box. In this dialog box you can set your calendar highlighted
days to be different colors than the rest of the days. You can use this dialog box for all
calendar types except the daily calendars.

The different highlighting options are:

� Highlight regular days. For example: highlight all Sundays

� Highlight fixed days. Designate special dates. For example: May 1, July 4

� Highlight floating days. For example: the last Monday of October.

Using this dialog box, you can create different lists of highlighted days, name them and
add them to the sets of highlighted days. For example, in the first list (Friends) you can
keep the birthdays of your friends (use fixed days highlight); in the second (Games) you
can keep the dates for the games of your favorite team (use floating days highlight if, for
example, they play on Wednesdays). Later you can create a calendar with these high-
lighted days by simply choosing Friends or Games from the Sets of Highlighted Days.

The Calendar dialog box is displayed when you either use the Object toolbar or when you
click on the Highlighted Days menu, then click on Modify Days. You can do this after you
have placed a calendar on the work page and selected it.
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Set the Calendar Day Order
Displays the Calendar dialog box and enables you to set the day of the week you want
your calendar to start from. In other words, your calendar does not have to start from
Monday or Sunday. You can set it to start from any day of the week. You can also set the
calendar orientation (vertical or horizontal). You can set these options only for yearly,
semiannually, quarterly, and, monthly calendars. Additionally, for monthly calendars you
can fill the unused positions or the blank days of the current month with the days of the
previous or next months by adding the next or previous months days in a small size to
your current calendar.

You can access the Calendar Options dialog box either by using the Object toolbar or by
clicking on the Modify menu, then clicking on Week Days Order.

Control Toolbar
The Control Toolbar is located down the left side of the DesignShop window. This toolbar
includes object orientation and work page viewing controls (so that you may view the
work page at different magnifications).

Select Box
The Select Box button enables you to select a particular object and change its size by
dragging one of the resizing buttons. To use the feature, click on the object that you wish
to resize to select it.

Rotate Object
To use the rotate tool, click on the rotate tool button in the Control toolbar. Next, click
once on the object you want to rotate. The bounding box will be displayed around the
object. Now place your mouse on one of the four corners of the bounding box and the
shape of the mouse will change to a circular arrow. Drag the corner and rotate the object as
many degrees as you want.

NOTE: The Rotate Object tool works only with vector graphics, such as Windows Metafile
(WMF) images and other graphic objects, such as text line objects. The feature does
not work with bitmapped images, such as Windows Bitmapped (BMP) and PaintBrush
(PCX) files or paragraph text.

Center of Rotation
Any object that you want to rotate, can be rotated around a rotation center point. When
you click on the Rotate tool then click on an object, the bounding box will be displayed
around that object. DesignShop will place a black bold bullet in the middle of the bound-
ing box. This is the center around which the object will be rotated. Using your mouse, you
can drag this center point and place it anywhere inside or outside the bounding box. After
you reposition the center point, place your mouse on one of the four corners of the bound-
ing box and drag it. The object will be rotated around the new center point.

Change Object Shape
The Change Shape tool has a picture of a square box with curved sides. Select the Change
Shape tool then click on an object to select it. Now drag any of the handles of the bound-
ing box, DesignShop will change the shape of the object, and the object will fill the new
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curved bounding box you have created.

You can also change an object’s shape by using the Object > Shape menu options. Click
on an object then click on Object > Modify Shape menu options. The Object Shape dialog
box will be displayed. Click on any one of the many predefined shapes available.

DesignShop is not limited by the predefined set of object Shapes listed in the Object
Shape dialog box. You can add any new shape to this list. To add a new shape, first click
on the Change Shape tool then click on the object. Now drag any of the handles and
change the shape of the object. Click on the Modify Shape... menu from the Object menu,
and the Modify Shape dialog box will be displayed. Notice that the Sample window dis-
plays the shape of your selected object. Click on the Save as... button, and enter a name for
this new shape you have created, and click on OK. The new shape is now added to the list
of predefined shapes. You can use this shape at any time and apply it to any object.

To delete a shape (which you have previously added) from the list, click on the name of
the shape from the list of shapes, then click on the Delete button.

NOTE: The Change Object Shape tool works only with vector graphics, such as Win-
dows Metafile (WMF) images and other graphic objects, such as text line objects. The
feature does not work with bitmapped images, such as Windows Bitmapped (BMP)
and PaintBrush (PCX) files or paragraph text.

Fit to Page
The Fit to Page view control enables you to view the entire work page for the current
document in DesignShop. This feature is most useful for returning to the work page view
from a magnification zoom.

Zoom In
The Zoom In button in the Control Toolbar increases the magnification of the work page
view. It uses the center of the DesignShop window as the focus point of the zoom (and not
the center of the document work page). You may use the vertical and horizontal scroll bars
to change the center of the screen to control the Zoom In feature.

Zoom Out
The Zoom Out button in the Control Toolbar decreases the magnification of the work page
view. It uses the center of the DesignShop window as the center of the zoom out (and not
the center of the document work page). If you have an object that is centered in the De-
signShop window, the Zoom Out function will decrease the magnification on it. You may
use the vertical and horizontal scroll bars to change the center of the screen to control the
Zoom Out feature.

Manual Zoom
The Manual Zoom feature enables you to select the area upon which you would like to
increase the magnification. When you select this option, a magnifying icon is added to the
mouse pointer arrow. Use the mouse pointer to draw a dotted-line box around the area you
wish to view. The area enclosed within the dotted-line box will be magnified.
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Zoom Selection
The Zoom Selection feature will zoom in on a highlighted text or clip art object in the
DesignShop work page. For example, if you would like to view a piece of clip art in the
work page in greater detail, click on the object to highlight it and then click on the Object
Zoom button in the Control Toolbar to view that object in greater detail.

Actual Printed Size (1:1)
The Actual Size tool in the Control Toolbar displays the contents of the work page in the
actual size in which it will print. If you use a ruler to measure the dimensions on the screen
compared to their actual size, you may find that the screen display is not a true 1 to 1 ratio.
This is due to the manner in which your monitor is set to display. If you wish your monitor
to display a true 1:1 ratio (i.e., display actual printed size), you will have to adjust the
monitor vertical and horizontal scan when using the 1:1 option in DesignShop. See the
user guide that accompanied your monitor for information on how to adjust the monitor
display.

Object Toolbar
Specialized toolbar appear in DesignShop depending on the object you select. For ex-
ample, if you click on a calendar object, the Calendar Toolbar displays at the top of the
DesignShop window.

Calendar Object Toolbar
The Calendar object toolbar has a number of options for changing the content and appear-
ance of a calendar. It is important to remember that the toolbar functions are for a calendar
object inserted into any type of DesignShop document. More information on the calendar
toolbar options is described below.

You may select from annual, semiannual, quarterly, monthly, weekly, and daily calendar
types.

A. Change font, size, etc. Select the font, size, and style for the various elements of a
calendar.

B. Change text colors. Change the colors used in a calendar including those used for
the highlighted dates.

C. Change calendar layout. Arrange the months in a calendar in a number of different
layouts. For example, the months of an annual calendar may appear down the page or
across the page.

D. Change calendar date. The calendar button in the Main toolbar automatically in-
serts the calendar with the system date in your computer. If the calendar is an annual
calendar, it will start with January for the current year (based upon your computer’s
system date). If the calendar is a monthly calendar, it begins on the first day of the
current month. You may use the Change calendar date function in the object toolbar
to change date.

E. Change highlighted days. Add your own highlight dates. These days are displayed
in red in the DesignShop work page. You may also use predefined holidays that are
included with DesignShop. The default is to only highlight Sundays in a calendar.
You may also use predefined holidays that are included with DesignShop.

F. Change weekday order. Use the Change weekday order feature to change the first
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day of the week in the calendar. DesignShop calendars by default begin the week
with Sunday (the exception is the weekly calendar that will begin with the current
date).

Text Object Toolbar
The Floating Tool Box available when a Text Line is highlighted provides five functions
to modify the text including the text content, size, color, etc.

A. Change text content. The first icon in the text object toolbar enables you to edit the
text in a text box.

B. Change font, size, etc. This option enables you to select the text font, size, and style.

C. Change text colors. This option enables you to change the colors of the text, back-
ground, and borders used in the text box.

D. Change text effect. The Change text effect option enables you to apply a text effect
to the text in the text box. Available effects range from drop shadows to perspective
lines.

E. Justify text. Align text so that it has flush margins on all sides including left, right,
top and bottom.

F. Align Left. Align text so that it is flush left.

G. Center text. Align text so that it is centered in the work page.

H. Align Right. Align text so that it is flush right.

I. Align Top. Align text so that it is aligned at the top of the text box.

J. Align Vertically. Align text so that it is vertically centered in the text box.

K. Align Bottom. Align text so that it is aligned at the bottom of the text box.

Edit the Selected Text Object
Text objects can either be paragraph text or Text-line. You can edit the text or change the
fonts and sizes of the text objects. To do this click on the text object to select it, then click
on the Text edit icon from the Object toolbar to open the Text Line dialog box. You can
enter new text or change other attributes of the text object.

Paragraph Text Object Toolbar
The Paragraph Text features two tool bars: one at the top of the DesignShop Window and
one at the bottom.

Top Tool Bar:
A. Font Selector. Select the font that you wish to use.

B. Font Size Selector. Select the font size that you wish to use.

C. Bold Text. Switch the selected text to Bold style.

D. Italic Text. Switch the selected text to Italic style.

E. Underline Text. Switch the selected text to Underline.

F. Align Left. Align text so that it is flush left.

G. Center text. Align text so that it is centered in the work page.

H. Align Right. Align text so that it is flush right.

I. Justify text. Align text so that it has flush margins on both the left and right sides.
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Bottom Tool Bar:
A. Change text content. The first icon in the text object toolbar enables you to edit the

text in the text box.

B. Change Background. Change the background color of the text box.

C. Change font, size, etc. Enables you to select the font, size, and style for the text in
the text box.

D. Find. Search for a text string in the current document.

E. Find and Replace. Search for a text string in the current document and replace it
with something else.

F. Spell Check. Check the spelling for the document.

G. Symbol. Turns the display on or off for formatting symbols, such as the paragraph,
indent, and tab symbols.

H. Import Text. Import text into a document from an external file.

I. Insert Bullet. Inserts a bullet at the beginning of each paragraph of text that is cur-
rently selected.

J. Insert Numbering. Inserts a number at the beginning of each paragraph of text that
is currently selected.

K. Increase Indent. Enables you to increase the amount of indent for the selected text.

L. Decrease Indent. Enables you to decrease the amount of indent for the selected text.

Text and Paragraph Indentations
The program enables you to set different indentations for your text. To do this, click on the
block or paragraph text that you want to indent. Click on the Format menu, then click on
Paragraph Properties. The Paragraph Properties dialog box will be displayed.

There are two button controls in the text tool bar to change the amount of indentation:

� Increase Indent. This feature increases the indentation of selected text accord-
ing to a preset figure. You can change the setting of the Increase Indent icon
using the Paragraph Properties dialog box.

� Decrease Indent. Decrease Indent icon: decreases the indentation of selected
text according to a preset figure. You can change the setting of the Decrease
Indent icon using the Paragraph Properties dialog box.

Clipart Bar
DesignShop features a Clipart bar on the right side of the DesignShop graphic editor
window (but not the Web page editor window). Unlike the other bars in DesignShop that
feature access to functions, the Clipart bar provides drag-and-drop access to clip art.
There are a number of different clip art libraries that you may access through the Clipart
bar. To select a different library, click on the button located at the top of the Clipart bar. A
list of available graphic libraries will open. Click on the desired library to display it in the
Clipart bar or click on the down arrow next to the library name to select another Clipart
library.

DesignShop comes with many sets or groups of clip art images. These include: arrows,
balloon, bullets, signs, objects and others. The groups which are available depend on the
version of DesignShop and which options you have selected during the installation of
DesignShop.
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To change the set of symbols, click once on the small window which has the name of the
group. A list of available symbol groups will be displayed in a scroll box. Click on the
group of images that you want. DesignShop will place the new set of symbols in the scroll
bar.

To use any image, simply drag it and drop it on the work page. It is that simple.

You may add and delete items to the Clipart bar libraries using the Edit Image Library
option in the Library menu. If you wish, you can create your own libraries of images to
supplement those included with DesignShop.

Help and Status Bar
The Help and Status Bar appears at the bottom of the DesignShop screen when it is acti-
vated. It is not a bar in the same sense as a toolbar; the Help and Status Bar displays
context sensitive help and displays the progress of certain operations in DesignShop.

One way to demonstrate the function of the help portion of the Help and Status Bar is to
place the mouse pointer over one of the icons in the Main toolbar at the top of the Design-
Shop screen. When you look at the Help and Status Bar at the bottom of the screen, you
will notice that a brief description of that function appears in the lower left corner of the
DesignShop window.

When you are performing operations in DesignShop that require a good deal of time, such
as printing a very larger poster, the Help and Status Bar displays the progress of the
operation.

OLE Support
DesignShop supports OLE 2 (Object Linking and Embedding). With this feature you can
launch other applications without leaving DesignShop, create documents or pictures in
the other application, then exit and return to the program and have the newly created
document or picture inserted into the Web work page of DesignShop.

This can be very useful in cases where there are certain functions that you prefer to do in
other applications. Without leaving this program, you may perform these functions then
insert the result automatically in DesignShops work area.

As an example, let us create a simple picture in the Windows Paintbrush program, and
have it placed on DesignShops work area. To do this:

Click on the OLE icon (the icon with “OLE”) from the New Object Tool Bar of Design-
Shop.

A list of available programs will be displayed. These are programs that support OLE.
Click on Paintbrush then click on the OK button.

Paintbrush will be started and you will see the main Paintbrush program screen.

Create a simple picture then click on Exit & Return to... from the File menu.

A dialog box will be displayed with the question, Do you want to update the Embedded
object before proceeding? Click on YES.

The Paintbrush program will be closed and the picture you just created in Paintbrush will
be placed on DesignShops work area.
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Ruler Setup
DesignShop features a ruler that you may turn on or off in the Preferences dialog box. If
you have the feature turned on, the ruler will display across the top and down the left side
of the work page. The upper left corner of the ruler contains a box with which you may
reset the zero point location on the work page. To use this feature, you must have the ruler
option turned on.

To turn the ruler feature on, click on the box that is in the corner of the ruler (where the
vertical and horizontal rulers meet). Next, hold down the left mouse button and drag the
mouse pointer to the position you wish the zero point of the ruler to be located. When the
mouse pointer is at this position, release the mouse button.

Create Backup Files
DesignShop has a security feature. It creates backup files when you try to save the docu-
ment with the same name in an already existing file. The new document will be saved with
the name you specified, but the old file on disk which has the same name will not be lost.
It will be renamed by the program automatically.

The program does this by default, however, you may enable or disable this feature. To do
this, click on Preferences from the File menu and check off the Create backup files field.
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Creating a Graphic Project

Introduction
In this chapter we will cover the basics of creating different types of graphic projects
using the Graphic Editor in DesignShop. The topics discussed in this chapter deal only
with creating graphic projects, such as greeting cards, posters, banners, calendars, and
business cards. This chapter does not deal with Web page design or creation.

Starting a Graphic Project

Work Page Setup
The Graphics Editor work page uses basically the same layout and operation for all graphic
projects. You can set certain user preferences in the Preferences section. You can set the
ruler units, workspace appearance, manner in which objects are inserted, and the size of
the grid.

The program enables you to display or hide any of the toolbars on the screen. To select or
hide a specific toolbar, click on the View option in the main menu and then click on the
desired toolbar. A checkmark next to a toolbar option indicates that the toolbar displays in
the DesignShop window.

One of the most important features of DesignShop is the number of toolbars that are
available to provide quick and easy access to the many application features. You can
select the toolbars that you wish to include in the DesignShop window. The standard
toolbars include:

� Ruler

� Main Toolbar

� Window Toolbar

� Status Bar

� Toolbar

� Control Toolbar

� Clipart Toolbar

Unless you are using a very low screen resolution (i.e., 640 x 480), it is suggested that you
turn all of the toolbar displays on for greater convenience. If you find that the workspace
is too crowded with all of the toolbars visible, you can select those that you wish to
display and turn off all others.

The Toolbar, Control Toolbar, and Clipart Toolbar are moveable and can be relocated to
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other areas of the DesignShop window. To “undock” or move a toolbar, click with the left
mouse button inside the toolbar area (but not inside one of the buttons) and, while holding
down the mouse button, drag the toolbar to a new location. For example, the Control
Toolbar, by default, appears at the bottom of the DesignShop window above the status bar.
If you are using a high screen resolution, such as 1024 x 768, there is room for the Control
Toolbar next to the Toolbar at the top of the window. You can drag the Control Toolbar
from the bottom of the window to the top so that all of the toolbars are at the top of the
window.

To return a toolbar to the original location (i.e., to “dock” the toolbar), click with the left
mouse button inside the title bar for the toolbar and, while holding down the mouse but-
ton, drag the toolbar to the desired location.

Because DesignShop provides a large number of toolbars to make your work easier, it is
suggested that you set Windows to display at 800 x 600 or higher. This will provide a
greater amount of window space for you to be able to have the toolbars and still have a
large enough workspace for your projects.

Selecting an Output Type
The first step in starting a project in DesignShop is to select the Output Type, or the type
of project that you wish to do. There are many different Output Types from which to
select:

� Web Site

� Banner

� Poster

� Greeting Card

� Calendar

� Business Card

To select an Output Type:
1. Click on the File > New options in the main menu.

2. When the Output Type selector dialog box opens, click on the tab of the Output Type
desired.

3. If you wish to open a project as a blank (i.e., no template), click on the blank template
in the upper-left corner of the selector box. If you wish to begin work with a tem-
plate, click on the template desired.

Or
1. Locate the Output Type selector in the main toolbar at the top of the DesignShop

windows.

2. Click on the arrow to the right of the selector box.

3. Click on the desired Output Type from the list.

4. The New dialog box opens to the tab for the output type you selected in the drop
down list.

5. If you wish to open a project as a blank page (i.e., no template), click on the blank
template in the upper-left corner of the selector box and then click on the OK button.
If you wish to begin work with a template, click on the template desired.
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Using Templates
In this section we will provide a brief overview of how to use templates in DesignShop
graphic projects. This section does not discuss templates in Web pages. For information
about Web page templates, see the chapters on creating and designing Web pages.

DesignShop includes a large number of pre-designed templates for many of the graphic
output types. A template differs from a standard file in that it has at least one element in
the project that is saved as a placeholder. For example, you may wish to create a greeting
card template in which all of the objects are the same except for the inside message. To
create a greeting card template, you would complete the design for the project as desired
except that the inside text message would be saved as a placeholder. When DesignShop
saves the placeholder, the place holder and object type is saved, but the actual content
(i.e., any text or clip art that may be in the placeholder) is discarded. When you reopen the
template, all of the objects are in place with the placeholder serving as a reminder that you
wish to insert text at that point.

When you open a DesignShop template, you will find that each has one or more place-
holders. To replace a placeholder with an actual object, double click on the placeholder to
open the appropriate dialog box.

You can recognize a placeholder by the color of the box and the icon that appears
in the upper left corner of the box.

The colors and icons for template placeholder boxes are:

Text Line - blue

Image - red

Fill Pattern - cyan

Border - yellow

Paragraph Text - bright green

Calendar - pink

Chart - olive

OLE - teal

Using Templates
When you select the File > New options in the main menu, DesignShop opens the New
dialog box that displays the pre-designed templates in each output type.

To open a template:
1. Click on the File > New options in the main menu.

2. Click on the output type desired (i.e., poster, banner, etc.)

3. In the template display, double click on the template you wish to use (or click once
on the desired template and then click on the OK button).

4. DesignShop will open the project with the template in place.
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Creating New Templates
You can create your own templates from any DesignShop graphic project. There are only
two requirements for saving a document as a template: at least one object in the project
must be designated as a placeholder and you must choose the template file format when
you save the file. When you wish to use the template again, you can open it as you would
any other file using the File > Open menu options. If you would like to add your new
template to the template library so that it displays in the New dialog box listing, you may
do so using the Template Library module. See the main reference user guide for additional
information on how to edit template libraries.

Inserting Graphics
Most of the projects that you create in DesignShop will require some sort of graphic
object. This may include vector clip art or bitmapped images. DesignShop can import and
use a wide variety of image types.

There are several methods for inserting images into a DesignShop graphic project:

� Import an image from a DesignShop image library

� Import an image file

� Insert an image from the Clipart Bar

� Drag an image from another application

� Windows Clipboard transfer

� Create an image or graphic in DesignShop

To import an image from a library:
1. Click on Object > Add > Image from the main menu.

2. There are two kinds of images available for import from a library: vector and bitmapped
(i.e., raster). Select the appropriate type from the tabs in the Image dialog box.

3. The Image dialog box displays the contents of the first image library in DesignShop.
If you do not see the images that you want, click on the arrow to the right of the first
library name to open the drop down list box. When you see the name of the library
you wish, click on it to select it.

4. When the desired library is visible in the image selector box, you can click on any
image to select it. If the Preview option is selected (i.e., there is a checkmark in the
box to the left of the option), the selected image will display in the preview box to the
right.

5. To select an image, double click on it or click on it once to select it and then click on
the OK button.

To import an image file:
1. Click on the File > Import options from the main menu. An alternative to this method

is to click on the Object > Add > Image options from the main menu and then click on
the Import button in the Image dialog box.

2. Locate the image file that you wish to import. If you wish to view or import a file of
a particular type, such as a BMP file, you can select that file format in the Files of
Type selector at the bottom of the Import dialog box.

3. When you locate the image that you wish to import, double click on it to import it or
click on it once to highlight it and then click on the OK button.
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To insert an image from the Clipart Bar:
1. To insert an image from the DesignShop Clipart Bar, the Clipart Bar must be visible.

If it is not, click on the View > Clipart Bar options in the main menu. There must be
a checkmark next to the Clipart Bar menu option for the Clipart Bar to be visible.

2. Locate the desired image in the Clipart Bar. If you do not see the image, you can use
the scroll arrows at the bottom of the bottom of the Clipart Bar to scroll to the desired
image. If the current clip art library is not visible, click on the small box above the
clip art library to open a down menu listing of the available libraries.

3. When you locate the desired image, click on it with the left mouse button and, while
holding down the left mouse button, drag the image into the work page area.

4. When you have the mouse pointer over the work page area, release the mouse button
to insert the image.

Note: If you wish to move the Clipart bar (i.e., undock it so that it floats), you must click
on the outside border of the bar and not inside the image area. The easiest method is
to click on the Clipart toolbar margin at the very bottom of the toolbar and, while holding
down the left mouse button, drag the bar to a new location. When you undock the
Clipart toolbar, the bar displays horizontally rather than vertically.

To drag an image from another application:
1. You must have another graphic application open that has a piece of clip art or an

image that is compatible with DesignShop.

2. To complete the drag and drop, both DesignShop and the originating application
must be visible on the screen. It is not necessary to tile both applications so that they
share the screen space equally; you may have one application on top of DesignShop.
The only critical factor is that you must be able to drag the image from the originat-
ing application to the DesignShop workspace.

3. Click on the image in the originating application with the left mouse button and,
while holding down the mouse button, drag the image until it is over the DesignShop
work space.

4. When the mouse pointer is over the DesignShop workspace, release the mouse but-
ton to insert the image.

To insert an image using Windows Clipboard transfer:
1. To insert an image using the Windows Clipboard, there must be an image in the

Clipboard. You should go to another application and use the correct commands to
place an image into the Clipboard.

2. In DesignShop, you can press the CTRL + V keys to insert a Clipboard image. An
alternative method is to click on the Edit > Paste menu options. If the image does not
appear correctly, you can delete the image and then try the Edit > Paste Special menu
options. The Paste Special option enables you to select the version of the image that
is stored in the Clipboard.

Note: The Clipboard insertion method is useful for inserting images from other applica-
tions into a DesignShop project. In addition, the method is useful for inserting objects in
other DesignShop projects. For example, you may create a calendar layout and use
the Clipboard insertion method to place the calendar object into a greeting card or
poster.
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To insert an image or graphic in a template placeholder:

If the template has a graphic placeholder that you would like to insert a graphic image
into, you need only double click on the placeholder to open the Image dialog box. In the
Image dialog box you may select an image from an existing library or import a new image
file into your project.

Inserting Paragraph or Artistic Text
DesignShop features two different types of text entry: Paragraph Text and Text Line artis-
tic text. There are a number of differences between the two text entry types. The artistic
text features apply only to graphic projects, such as greeting cards, posters, banners, and
calendars.

Text Line
You use the Text Line feature when you wish to add a single line of artistic text to a
graphic project. The Text Line feature enables you to manipulate the text to a greater
degree by selecting special effects such as borders, shapes, and drop shadows.

To add a Text Line to a project:
1. To add a text line, click on the Text Line button in the toolbar or click on the Object

> Add > Text Line options in the main menu.

2. The Text Line dialog box features four tabs that you can use to enter and manipulate
the appearance of the text.

3. In the Text tab of the Text Line dialog box, enter the text that you wish to insert.

4. You can change the Character Spacing (i.e., distance between the characters) by
using the up/down scroll arrows in the Character Spacing feature.

5. The Text Line feature defaults to a Horizontal orientation, but you can change the
orientation to vertical by clicking on the radio button next to the Vertical option.
Vertical orientation aligns the characters in a single, vertical line so that it reads from
top to bottom.

6. The Alignment feature includes buttons to align the text Left, Top, Centered Hori-
zontally, Centered Vertically, Right, Bottom, or Justify. You can mix all of the fea-
tures except the Justify feature. For example, you might click on Left, Top or Left,
Centered Vertically.

7. The Font tab in the Text Line dialog box enables you to select the desired font. You
will notice that you cannot select a style, such as bold, italic, or bold italic. Since the
Text Line feature includes so many text manipulation and enhancement features, the
style selector is not needed for Text Lines.

8. The color tab enables you to select the color for the text. If you enter the desired text
before you go to the Color tab, you will see only one or a few characters of the text
you entered. The sample in the preview box enables you to see the color combina-
tions as you select them. The color selection is first divided into Background and
Symbol. The Background includes the area around the text. Symbol includes only
the text. Each of these areas is further divided into Outline and Fill. The Outline is
the border around the background or the text. The Fill is the solid color of the se-
lected background or the text. For example, you may select Symbol, and set the
Outline to yellow and the Fill to dark blue. This will yield dark blue letters that have
a yellow border. If you do not wish to use a particular feature, you can click on the
transparent status box to turn it off. For example, if you set the Background Fill to
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Transparent, the area around the letters will be clear (any objects behind the text will
show through).

9. The Effects tab is one of the most powerful text manipulation tools available for
graphic text. You can use it to apply a wide variety of special effects including drop
shadows, slants, perspectives, depth, rotations, slants, and more. In addition to the
standard manipulations included in the list box, you can modify any of the Effects
features by selecting and changing the Shift Horizontally and Shift Vertically fea-
tures. The Attach Bold Border enables you to place a bold border around the text.

10. After you are satisfied with the appearance of the text, click on the OK button.

11. You can resize the entire object in the work space by clicking and dragging the bor-
ders.

12. You can use the text alignment features to set the text to flush left, flush right, cen-
tered or justified. These features are available in the Text toolbar when you have a
text object selected.

13. If you wish to make a change in the appearance of an existing text object, click on the
object to select it and then click on the button or the menu options for the desired
feature.

Paragraph Text
Use the Paragraph Text feature to add any text that will require more than one line. The
Paragraph Text feature enables you to select font (including font style, such as bold, italic,
etc. if available), font color, and background color. However, it does not permit the text
manipulations, such as shapes and drop shadows that the Text Line feature enables.

To add Paragraph Text to a project:
1. You must insert a Paragraph Text box in your document before you can add text.

First, click on the Paragraph Text button in the toolbar or click on the Object > Add
> Paragraph Text options in the main menu.

2. When the paragraph text box is inserted in the document, click on the Text button in
the Object toolbar (generally located at the bottom of the DesignShop window). You
are now ready to begin entering text.

3. You can set the background color for the entire box by selecting the Background
Color button in the Object toolbar.

4. You can change the paragraph properties (alignment, indent, spacing, etc.) for para-
graph text. To access the Paragraph Properties dialog box, you must first click on a
paragraph text object to select it, then click on the Text button in the Object toolbar.
When you click on the Text tool in the toolbar, the Paragraph Properties button is
activated for you to select (the button is not accessible until you click on the Text
button). The Paragraph Properties dialog box also enables you to set the type of
bullets to use in the text and to set the numbering style for paragraphs, if desired. It
should be noted that some editing options are available by right clicking the mouse
button on an existing text object.

5. The Font button in the Object toolbar includes the standard Windows font selection
items including a list of fonts in the system, the styles available for each (i.e., bold,
italic, etc.), the font size selector, Underline, and Strikeout. In addition, the Design-
Shop font selector includes a color selector that is more powerful than most Win-
dows applications. The DesignShop color selector enables you to select the color of
the text, the outline, and the background. You will notice that the background color
selection in this feature is different than the Background selector for the entire para-
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graph text box. The background color selector in the Font Attributes dialog box con-
trols only the background color that is immediately around the text. The color selec-
tor in the Background dialog box includes the entire box. Finally, the font selector
features a slide bar selector to set the thickness of the border around the paragraph
text.

All images inserted into a Web page are converted to raster (bitmapped) format (either
JPEG or GIF file format). These formats are necessary because they are the graphic for-
mats compatible with most Internet browsers. However, when you create a Web site in
DesignShop and insert an image, DesignShop maintains the original format and graphic
characteristics of that file. When you generate the Web site, DesignShop automatically
converts the file from the existing format to either a JPEG or GIF as needed. You can go
back to the original image in DesignShop and edit the content if you wish to change the
image.

Saving a Graphic Project
As you work on a project, you should save it from time-to-time to make sure that you have
a copy.

To save a new project:
1. Click on the File > Save options in the main menu.

2. It is recommended that you select a new drive and directory location to save the file
and not save it in the DesignShop program folder. It is suggested that you create a
new folder to store all of your DesignShop projects so that you can find them in one
centralized location.

3. Enter the name for the new file.

4. Click OK to save the project.

To save a project that has been previously saved:
1. Click on the File > Save options in the main menu. The file is saved to the previous

name.

To save a project to a new file name:
1. If you have already saved a project but you want to save it with a new name, click on

the File > Save As options in the main menu.

2. If desired, click on a new drive and directory location to save the file.

3. Enter the new name for the file in the space provided.

4. Click OK to save the project.

Creating a Poster or Banner
DesignShop features powerful Poster and Banner creation modules that permit you to
create graphic projects ranging in size from a single sheet to ten sheets tall by ten sheets
wide. You can include any of the standard graphic and text objects in your design includ-
ing clip art, patterns, backgrounds, borders, line text, and paragraph text. The method of
creating and designing posters and banners is exactly the same except for selecting the
Output Type.

To create a poster:
1. There are two methods you may use to create a poster or banner: click on the Poster

or Banner option in the Output Type selector in the main toolbar or click on the File
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> New options in the main menu.

2. The New dialog box enables you to begin your project with a blank work page or to
select one of the many pre-designed templates. You can scroll through the templates
in the New dialog box to view the different templates.

3. To select a blank work page for a poster or banner, double click on the blank template
(in the upper left corner of the display box) or click once on the blank template to
select it and then click on the OK button.

4. To illustrate the features of poster and banner design, we will select a blank poster.
Double click on the blank template to open it.

5. The blank template opens with the work page display. The first step is to set the size
of the project. To open the Page Setup dialog box, click on the Page Setup button in
the main toolbar or click on the File > Page Setup options in the main menu.

6. The Page Setup dialog box enables you to select the page orientation (portrait or
landscape). Note that the page orientation selection refers to the orientation of the
sheets within the project and not necessarily to the size of the finished product. For
example, if you select landscape orientation with a size of 6 sheets high and 2 sheets
wide, the actual poster or banner dimensions will not resemble standard landscape
print orientation (i.e., the project will be higher than it is wide).

7. The Pages feature enables you to set the number of sheets for the project. To open the
Pages selector, click on the arrow to the right of the “1 x 1” size notation. Design-
Shop includes a number of standard sizes are 1 x 1 (i.e., one sheet of paper), 2 x 2
(i.e., two sheets wide and two sheets tall), and others. The Custom option enables
you to select a size from one to ten sheets tall or wide. As you change the Pages
selection, the preview box displays boxes representing sheets to indicate the relative
size of the finished project. You must click on the Custom option to be able to enter
any dimension other than the standards in the Pages list. When the Custom option is
selected, you can use the scroll arrows in the Width and Height selectors or simply
type in the desired number between one and ten.

8. Now you are ready to begin your design project.

To print a poster:
1. After you finish your design, you can print it to any printer that is supported by

Windows. The first step in preparing to print is to make sure that the printer is setup
properly. To check the printer setup, click on the File > Printer Setup options in the
main menu.

2. When the printer setup is correct, click on the Print button in the main toolbar or click
on the File > Print options in the main menu.

3. DesignShop prints multi-page posters and banners with a slight overlap so that there
is no loss of content or unsightly gaps in the design. The Print. . . dialog box includes
an option for Cut Marks. When this option is turned on, DesignShop will print guide-
lines on each sheet indicating the overlap area. When you assemble the poster or
banner, you should align the sheets with these guidelines. Note: if your printer can-
not print to within one-quarter inch of the edge of the paper, you may not see some of
the cut marks.

4. Click on the OK button to begin printing. When the printing is finished, you are
ready to trim and assemble your poster or banner.
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Creating a Greeting Card
The DesignShop Greeting Card module enables you to create and print attractive greeting
cards for any occasion. You can create the cards using one of four different layouts:

� Tall Side-Open. The card is printed in portrait fashion (it is taller than it is wide). It
is folded on the left side and opens from right to left.

� Tall Top-Open. The card is printed in portrait fashion (it is taller than it is wide). It is
folded on the top side and opens from bottom to top.

� Wide Side-Open. The card is printed in landscape fashion (it is wider than it is tall).
It is folded on the left side and opens from right to left.

� Wide Top-Open. The card is printed in landscape fashion (it is wider than it is tall).
It is folded on the top side and opens from bottom to top.

To create a greeting card:
1. There are two methods you may use to start a greeting card: click on the Greeting

Card option in the Output Type selector in the main toolbar or click on the File >
New options in the main menu.

2. The New dialog box enables you to begin your project with a blank work page or to
select one of the many pre-designed greeting card templates. You can scroll through
the templates in the New dialog box to view the different templates available.

3. To select a blank work page for a greeting card, double click on the blank template
(in the upper left corner of the display box) or click once on the blank template to
select it and then click on the OK button.

4. If you select the blank template, the work page display opens with three separate
windows: Front, Inside, and Back. The first step is to setup the page for the card. To
open the Page Setup dialog box, click on the Page Setup button in the main toolbar or
click on the File > Page Setup options in the main menu.

6. The Page Setup dialog box enables you to select one of the four greeting card ar-
rangements. The preview box on the left displays the layout for each type when you
select a particular type.

7. If you wish, you can maximize each panel, Front, Inside, and Back, when you work
on them to provide more screen work space. When you have finished working on a
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panel, you can either minimize it or click on the Restore Window button to return the
window to the original size. If you maximize one window, all of the windows are
maximized. You can toggle from window to window by making the appropriate se-
lection from the Window toolbar at the bottom of the DesignShop window.

8. Now you are ready to begin your greeting card project.

To print a greeting card:
1. After you finish your design, you can print the card to any printer that Windows

supports. The first step in preparing to print is to make sure that the printer is setup
properly. To check the printer setup, click on the File > Printer Setup options in the
main menu.

2. When the printer setup is correct, click on the Print button in the main toolbar or click
on the File > Print options in the main menu.

3. DesignShop includes two special print features to assist you in you printing greeting
cards: cut marks and Type Imprint. The Cut Marks feature prints fold guidelines on
the greeting card to assist you in folding. The Type Imprint prints the following
message on the back panel of the greeting card: Created in DESIGN SHOP.

4. Click on the OK button to begin printing. When the printing is finished, you are
ready to fold your greeting card.

Creating a Calendar
The DesignShop Calendar module is one of the most
powerful calendar generating features in the applica-
tion. You can design and print a wide variety of calen-
dars and then customize them with special text, clip art,
highlighted days, and more. When you have completed
your design, you can print the calendars or use them in
any of the other DesignShop modules including greet-
ing cards, posters, coloring books, and Web page de-
signs.

It is important to note that calendars can be used in one of two ways. As a printable project
and/or as an importable calendar to another graphics project including a Web page. We
will discuss this in detail later in this section. Calendars can range in size from one sheet
to ten sheets by ten sheets.

To create a calendar:
1. To create a calendar, click on the Calendar option in the Output Type selector in the

main toolbar or click on the File > New options in the main menu.

2. The New dialog box enables you to begin your project with a blank work page or to
select one of the many pre-designed calendar templates. You can scroll through the
templates in the New dialog box to view the different templates available.

3. To select a blank work page for a calendar, double click on the blank template (in the
upper left corner of the display box) or click once on the blank template to select it
and then click on the OK button.

4. If you select the blank template, a blank work page opens for you to begin your
calendar. The first step is to setup the dimensions for the calendar in the Page Setup
dialog box. To open the Page Setup dialog box, click on the Page Setup button in the
main toolbar or click on the File > Page Setup options in the main menu.
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5. The Page Setup dialog box enables you to select the page orientation (portrait or
landscape). Note that the page orientation selection refers to the orientation of the
sheets within the project and not necessarily to the size of the finished product. For
example, if you select landscape orientation with a size of 6 sheets high and 2 sheets
wide, the actual calendar dimensions will not resemble standard portrait print orien-
tation (i.e., it will be higher than wide, but not necessarily proportional to portrait).

6. The Pages feature enables you to set the number of sheets for the project. To open the
Pages selector, click on the arrow to the right of the “1 x 1” size notation. Design-
Shop includes a number of standard sizes are 1 x 1 (i.e., one sheet of paper), 2 x 2
(i.e., two sheets wide and two sheets tall), and others. The Custom option enables
you to select a size from one to ten sheets tall or wide. As you change the Pages
selection, the preview box displays boxes representing sheets to indicate the relative
size of the finished project. You must click on the Custom option to be able to enter
any dimension other than the standards in the Pages list. When the Custom option is
selected, you can use the scroll arrows in the Width and Height selectors or simply
type in the desired number between one and ten.

7. Now you are ready to begin your design project.

To insert a calendar into a Web page:
1. If you want to design a calendar and place it in a Web page, you must start the

process in the Web Site window. In the Web Site module, select the Physical Layout
window.

2. Click with the right mouse button on the Images folder icon in the Physical Layout
window to open the drop down menu.

3. Click on the Create > Image options in the drop down menu to open the Image
Properties dialog box.

4. Enter the width and height for the image.

5. Select JPEG or GIF file format for the image. If you select the GIF file format, you
will also be able to specify the number of colors to use in the image.

6. You may select the Background color, if desired. If the image type is GIF, you may
also select the Make it transparent (only for GIF’s) option. This option will render the
background color (i.e., anything outside the calendar) transparent in the Web page.

7. Click on the OK button to complete the file creation process and close the Image
Properties dialog box.

8. When you see the image file appear in the Physical Layout list, click with the right
mouse button on the file name to open the drop down menu.

9. Click on the Edit option in the drop down menu.

10. When the Graphics Editor window opens, click on the Calendar object button to
open the Calendar dialog box.

11. Select the design options to create the calendar you desire.

12. Click on the OK button to close the Calendar dialog box and insert the calendar
object into the image box.

Customizing a Calendar
DesignShop includes many options that you can use to customize the appearance of a
calendar. These features include a variety of calendar types as well as artistic features,
such as customized text and automatic holiday insertions.
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To open the Calendar dialog box, click on the Calendar icon in the main toolbar or click on
the Object > Add > Calendar menu options.

The Calendar dialog box features six tabs of features and options that you can use to
customize a calendar design:

Type
You can select one of the following calendar types to create:

� Yearly

� Semi-annually (6 months)

� Quarterly (3 months)

� Monthly

� Weekly

� Daily

Font
You can select the font that is installed in your Windows font system to use in your calen-
dar. In addition, you can select how the font will be applied within the calendar using the
following options in the Font dialog box:

� Font. Select the desired font by name from the scrolling font list.

� Font Style. If the font features different styles (i.e., bold, italic, etc.), you can select
the desired style from the list box. Not all fonts include all styles.

� Underline. If you turn on the underline feature, the selected text will be underlined.

� Apply Font To. The Font dialog box features a drop down list selector that enables
you to select how a font will be applied to a calendar. The selections available in this
list will vary depending upon the type of calendar you are creating. The selections
include:

� Months. The Months option applies the selected font to the names of the month that
appear at the top of each month in the calendar. This feature is only available if you
select a calendar that has more than one month.

� Days. The Days option applies the selected font to the abbreviations for the days of
the week that appear above each month in a calendar (Su, Mo, Tu, etc.).

� Date. The Dates option applies the selected font to the numbers for each day in the
calendar grid.

� All of Them. The All of Them option applies the selected font to all of the different
text categories in the calendar.

Colors
You can customize the colors of every aspect of the calendar to create just the appearance
that you wish.

Frame Colors
The Frame Colors section provides three color selectors that control the colors of the
calendar box itself.

� Fill. If you select the Fill option (i.e., place a checkmark in the status box), you can
then click on the color box selector to the right of the option to open the Choose
Color dialog box. The Fill option regulates the color of the entire calendar box.
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� Border. Click on the Border option status box to place a checkmark in it and then
click on the color box selector to open the Choose Color dialog box. The Border
option controls the color of the borders in the calendar.

� Shadow. If the Shadow feature is turned on (i.e., there is a checkmark in the status
box), the calendar box will have a drop shadow around it. The application of the drop
shadow varies depending upon the type of calendar selected and whether or not you
have the Separate Blocks and Space Between Blocks features turned on.

Block Display
� Separate Blocks. If the Separate Blocks feature is turned on and the calendar has

different boxes either for days or for months), each unit of the calendar will be con-
tained in a box. If it is a monthly calendar, each day of the month will be in a box. If
the calendar contains more than one month, each month will be in a separate box.

� Space Between Blocks. If the Separate Blocks feature is turned on, you can also turn
the Space Between Blocks feature on or off. This feature controls whether there is
any space between the block units in the calendar.

Options
The Options tab in the Calendar dialog box enables you to further customize the contents
of the calendar by specifying a number of different options. The options available vary
depending upon the type of calendar selected.

� First Day of Week. By default, DesignShop creates calendars with Sunday as the
first day of the week (i.e., the first day at the beginning of each line). This can be
changed by selecting a different day in the First Day of Week option.

� Vertical Orientation. The Vertical Orientation option allows you to switch between
vertical and horizontal orientation. When this feature is turned off, the days of the
calendar read from left to right. When this feature is on, the days of the week read
from top to bottom.

� Prev Month Days. Monthly calendars have a feature to display the days of the pre-
vious month in the current calendar display. For example, if the first day of the cur-
rent month is Wednesday, the default would be to have the Sunday through Tuesday
date boxes empty. If you turn on the Prev Month Days feature, the calendar will
begin with the days of the previous month on the first line (i.e., it will include the
Sunday through Tuesday dates from the previous month).

� Next Month Days. Monthly calendars have a feature to display the days of the next
month in the current calendar display. For example, if the last day of the current
month is Wednesday, the default would be to have the Thursday through Saturday
date boxes empty. If you turn on the Next Month Days feature, the calendar will end
with the first days of the next month on the last line (i.e., it will include the Thursday
through Saturday dates from the previous month).

� Thumbnails. Monthly calendars can include thumbnail displays of the previous and
next months in the current calendar display as thumbnail images. For example, if the
calendar is for April, turning on the Thumbnails feature will display a thumbnail
image of the March and the May calendars in the last two boxes of the April calendar.

Date
The Date tab enables you to select the date for the calendar. The selection options vary
with the type of calendar selected. For example, a monthly calendar includes selectors for
the year and month. Quarterly calendars include selectors for the year and the quarter
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desired. Changes in the year will not be reflected until you choose another option within
the Date tab or you move out of the Date tab.

� Highlighted Days. DesignShop calendars can include a variety of visual enhance-
ments to make them more attractive and useful. One such enhancement is the High-
lighted Days options.

� Regular Days. The default for most calendars is to display Sundays in red and all
other dates in black. You can select any or all days to be highlighted in the calendar
by clicking on the status box next to each day.

� Sets of Highlighted Holidays. DesignShop includes two sets of predefined holiday
sets: Canada and US. These sets contain the standard national holidays for each
country. If you select one of these holiday sets, the calendar will highlight (i.e., dis-
play the date in the highlight color) for all of the holidays included in the set. You can
edit the holiday sets by adding or removing holidays as you desire. In addition, you
can create new highlight sets to meet your needs. For example, you may wish to
create a calendar that has the dates for your Little League games. The List of High-
lighted Days list box includes a listing of all of the days that are included in the
selected set. When you add days to a highlighted list, you can specify it as a Fixed
date or a Floating date. A Fixed date would be one that occurs in the specified month
on a specific day, such as March 4th. A Floating date is one that will change depend-
ing upon the calendar, such as the 2nd Tuesday of the selected month.

� Layout. The Layout selector is only available for calendars that feature more than
one month. To change the layout, use one of the following options in the Main Lay-
out Type Selector:

� Horizontal

� Vertical

� Rectangular

� Angular Left-Down

� Angular Up-Right

� Vertically Ordered. If you click on the Rectangular layout, you may also select whether
or not to sequence the calendar horizontally or vertically.

� Subtype. If you click on the Rectangular layout, you may select the physical arrange-
ment of the months in the calendar, such as two months horizontally and 6 months
vertically.

To print a calendar:
1. After you finish your design, you can print the calendar to any printer that Windows

supports. The first step in preparing to print is to make sure that the printer is setup
properly. To check the printer setup, click on the File > Printer Setup options in the
main menu.

2. When the printer setup is correct, click on the Print button in the main toolbar or click
on the File > Print options in the main menu.

3. DesignShop prints multi-page calendars with a slight overlap so that there is no loss
of content or unsightly gaps in the design. The Print Calendar dialog box includes an
option for Cut Marks. When this option is turned on, DesignShop will print guide-
lines on each sheet indicating the overlap area. When you assemble the calendar, you
should align the sheets with these guidelines. Note: if your printer cannot print to
within one-quarter inch of the edge of the paper, you may not see some of the cut
marks.
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4. Click on the OK button to begin printing. When the printing is finished, you are
ready to trim and assemble your calendar.

Creating a Business Card
DesignShop’s Business Card module lets you create graphical cards that you can use for
your business, profession, or simply for your own personal use. Business cards can be
designed to print in portrait mode or in landscape mode. You select the layout and add all
of the graphics and information to one card layout. DesignShop duplicates the cards print-
ing the appropriate number for a page. You can include any of the standard graphic and
text objects in your design including clip art, patterns, backgrounds, borders, line text, and
paragraph text.

To export a calendar to use in another application:
1. Create the calendar in the work page as you wish it to appear. If you wish to add

graphics or text to the calendar, you may do so.

2. When you have the calendar finished, click on the File > Export menu options.

3. Click on the graphic file format that you wish to use in the Save as Type list selector.
You may save it as in a bitmapped format or as a vector format image.

4. In the Save in list box, select the destination for the file (the drive and folder).

5. Enter a name for the file. Design shop will automatically supply the necessary file
extension based upon the Save as Type file type you select.

6. Click on the OK button to export the file.

To create a business card:
1. There are two methods you may use to create a business card: click on the Business

Card option in the Output Type selector in the main toolbar or click on the File >
New options in the main menu.

2. The New dialog box enables you to begin your project with a blank work page or to
select one of the many pre-designed card templates. You can scroll through the tem-
plates in the New dialog box to view the different templates.

3. To select a blank work page for a card, double click on the blank template (in the
upper left corner of the display box) or click once on the blank template to select it
and then click on the OK button.

4. The blank template opens with the work page display. The first step is to set the size
of the project. To open the Page Setup dialog box, click on the Page Setup button in
the main toolbar or click on the File > Page Setup options in the main menu.

6. The Page Setup dialog box enables you to select the orientation for the business care:
tall (portrait) or wide (landscape).

7. Now you are ready to begin your design project (see the sections on inserting graph-
ics and text for additional information).

To print a business card:
1. After you finish your design, you can print it to any printer that Windows supports.

The first step in preparing to print is to make sure that the printer is setup properly. To
check the printer setup, click on the File > Printer Setup options in the main menu.

2. When the printer setup is correct, click on the Print button in the main toolbar or click
on the File > Print options in the main menu.

3. DesignShop prints eight business cards to a sheet. The Print the Business Card dialog
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box includes an option for Cut Marks. When this option is turned on, DesignShop
prints guidelines on each sheet indicating how to cut the cards.

4. The print feature also includes a Number of Copies selector to indicate the number of
business cards that you wish to print. Business cards are printed with eight cards to a
sheet. If you elect to print 12 cards, you will get eight on the first page and four on the
second.

5. Click on the OK button to begin printing. When the printing is finished, you are
ready to trim and use your business cards.

Summary
Now that you have an overview of the power, features and potential of Internet Design-
Shop, you are ready to begin. You have at your disposal one of the software industry’s
most powerful graphic tools along with some very powerful auxiliary programs for man-
aging your clip art and creating graphics for the Web and a collection of clip art and
graphics to use in your graphic and Web projects.
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Chapter 11.

Creating DesignShop Templates

Introduction
The explanations in this chapter will give you the procedures for creating your own tem-
plate files and inserting them into the DesignShop libraries. You will also learn how to
tailor the template libraries so that you can add, edit, and delete templates as you desire.
You may use a Web page design or a graphic design, such as a poster, for this exercise.

Open a File
Any DesignShop file can be turned into a template by making at least one object (a text
object or a clip art image) display as a placeholder (this procedure applies to both Web
page designs and graphic project designs). When you have changed one object to a place-
holder, you simply save the file designating it as a template file with an extension of
.CTM.

To open a file:
1. Click on the Open File button in the Main toolbar or click on the File > Open menu

options.

2. If you wish to view the file before you open it, click on the Preview option in the
lower right corner of the Open dialog box.

3. When you locate the correct file, click on it once to highlight it, and then click on the
Open button or double click on the file name.

Convert an Object to a Placeholder
After you open the file, you can convert any of the objects on the page to a placeholder.
The object could be paragraph text, text line, fill patterns, graphic objects, and others.

To convert an object to a placeholder:
1. Click on the object with the left mouse button to highlight it.

2. When the object is highlighted, click on it with the right mouse button to open the
object menu. Click on the Show option in the object menu. Click on the Show > As
placeholder menu options in the drop down menu. The object is now a placeholder in
the work page.

If you use the Show > Normal menu options to convert the object back to Normal, the
content of the placeholder is restored.

There are a number of considerations to keep in mind when displaying objects:
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A. If you convert an object to show as a placeholder and later convert it to show as
Normal, the content of the object will be restored with its original content.

B. If you convert an object to show as a placeholder, save the file as a DesignShop
document file (with a file extension of .CNQ), reopen the file and convert that
same object to show as Normal, the content of the object will be restored with
its original content.

C. If you convert an object to show as a placeholder, save the file as a DesignShop
template file (with a file extension of .CTM), reopen the file, you will not be
able to use the Normal option in the Show menu. You will not be able to restore
the original contents of the object box.

Save File as Template
After you have converted an object to a placeholder, you may save the file as a Design-
Shop template. For this operation, you must use the Save As option in the File menu; you
may not use the Save File button in the Main toolbar.

To save the current file as a DesignShop template:
1. Click on the File > Save As menu options.

2. When the Save As dialog box opens, click on the Save as Type option bottom of the
Save As dialog box.

3. Click on the Templates option in the Save as Type list box.

4. If you wish to give the file a new name, you may enter a new name in the File Name
box. Since DesignShop documents have a file extension of .CNQ and templates have
an extension of .CTM, it is not necessary to give templates a different file name. You
may have a POSTER1.CNQ or INDEX.CNQ (document file) and a POSTER1.CTM
or INDEX.CTM (template file) in the same directory. It is not necessary to add the
.CTM file extension to the file name when you are saving it to a template format.

Now that you have created a DesignShop template, we will add that new template to the
DesignShop poster library.

Add a Template to a Library
To add a new template to a library, open the Template Library Manager dialog box. This
dialog box enables you to add templates to existing libraries, remove templates from
existing libraries, create new template libraries, and delete template libraries.

To add the poster template to the template libraries:
1. Click on the Library > Edit Template Library menu options.

2. We will add the template to the existing Posters template library. Click on the arrow
to the right of the template selector labeled Library Type in the lower right corner of
the Template Library Edit dialog box.

3. Click on the Poster option to access the Posters library.

4. Log to the directory that contains the file you wish to insert into the template library.

5. When you locate the file, click on it to select it.

6. Click on the Show Preview option below the Sample box so that you may view the
poster before inserting it into a library.

7. Click on the Add button to add the template to the Posters library. The template is
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added to the library. If you scroll through the list of templates in the library, you will
now find the name of the template at the end of the list.

8. Click on the Close option to close the Template Library Manager dialog box.

Now that you have added a new template to the template library, we will use the New
command to view the template library contents and verify that the new template is prop-
erly inserted.

To verify the new template is in the template library:
1. Click on the File > New menu options.

2. In the New dialog box, select the Posters tab to open the poster template library.

3. Use the horizontal scroll bar to scroll through the template list box until you see the
new template that you inserted (it will be the last file in the library).

Follow the same procedure to add a template to the Web library or to any other Output
Type.

Remove a Template from a Library
The next step in the tutorial is to remove the new template just inserted from the template
library. You delete templates using the Template Library Edit dialog box that you used to
insert the template into the library.

To delete the template from the library:
1. Click on the Library > Edit Template Library menu options.

2. Click on the Library Type combo box in the bottom of the Template Library Edit
dialog box.

3. Click on the Poster option to select the Posters library.

4. In the list of templates (just above the template selector), select the template file
name that you inserted in the previous steps. If necessary, use the scroll bar to locate
the template.

5. When you locate the template, click on it with the right mouse button to open the
drop down menu.

6. Click on the Delete option in the drop down menu.

7. Click on the Yes button to confirm the deletion.

8. Click on Close to close the Template Library Edit dialog box.

The new template is now deleted from the Posters library.

Create a New Template Library
In addition to adding new templates, you can also add new template libraries to the De-
signShop system. When you create a new library, it is stored as a selectable library within
the Output Type group, such as posters, or greeting cards.

To create a new template library in DesignShop:
1. Click on the Library > Edit Template Library menu options.

2. Click on the Library Type combo box at the bottom of the dialog box.

3. Click on the Poster option to select the Posters library.

4. Click on the New Library button.
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5. Enter the name for the new template library.

Note: The entry box accepts alphanumeric characters only; you may not use punctua-
tion marks, underlines, dashes, or any non-alphanumeric character.

6. Click on the Close button to close the Template Library Edit dialog box.

You have now created a new template library that is empty (i.e., it has no templates).

Delete a Template Library
The next step in the tutorial is to remove the new template library just inserted in the
previous steps. The Template Library Edit dialog box is used to create the new library and
also to delete an existing template library.

To delete the template library from the DesignShop system:

1. Click on the Library > Edit Template Libraries menu options.

2. Click on the Library Type combo box at the bottom of the dialog box.

3. Click on the Poster option to select the Posters library.

4. Click on the Delete Library button.

5. Click on the Yes button to confirm the deletion.

The new template and template library are now deleted from the Posters template library
of your hard disk.

Note: The general procedure to create, save, and add templates for world wide Web
pages, posters, or any of the other layout formats is basically the same as described in
this chapter.
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Editing DesignShop Libraries

Introduction
In this chapter we will examine the image and color libraries available in DesignShop.
The instructions in this chapter show you how to edit and create your own graphical
libraries and insert them into DesignShop for future use. You will also learn how to tailor
graphic libraries so that you can add, edit, and delete images and objects as you want.

Editing an Image Library
Click on the Library > Edit Image Library menu options to open the Library Edit dialog
box. This dialog box includes many groups of image libraries including:

� Clipart Library. The Clipart Library is made up of Windows Metafiles (.WMF) and
Enhanced Windows Metafiles (.EMF). You can only insert these types of images into
this library. These images can be used as clip art in any of the DesignShop graphic
projects.

� Vector Image Library. The Vector Image Library is made up of Windows Metafiles
(.WMF) and Enhanced Windows Metafiles (.EMF). You can only insert these types
of images into this library. These images can be used as clip art in any of the Design-
Shop graphic projects.

� Raster Image Library. The Raster Image Library includes raster or bitmapped im-
ages. These image types include: Windows Bitmap (.BMP), CompuServe Bitmap
(.GIF), JPEG Bitmap (.JPG), Paint Brush Images (.PCX), TARGA Bitmap (.TGA),
and TIFF Bitmap (.TIF). These images can be used as clip art in any of the Design-
Shop graphic projects.

� Border Library. The Border Library is made up of Windows Metafiles (.WMF) and
Enhanced Windows Metafiles (.EMF). You can only insert these types of images into
this library.

� Raster Brush Library. The Raster Brush Library includes raster or bitmapped im-
ages. These image types include: Windows Bitmap (.BMP), CompuServe Bitmap
(.GIF), JPEG Bitmap (.JPG), Paint Brush Images (.PCX), TARGA Bitmap (.TGA),
and TIFF Bitmap (.TIF). These files are generally very small images that can be used
as repeated brush strokes in a background pattern.

� Vector Brush Library. The Vector Library is made up of Windows Metafiles (.WMF)
and Enhanced Windows Metafiles (.EMF). You can only insert these types of images
into this library. These files are generally very small images that can be used as
repeated brush strokes in a background pattern.

� Bullet Library. The Bullet Library includes small raster or bitmapped images that
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may be used as bullets to highlight text or graphics. These image types include:
Windows Bitmap (.BMP), CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG), Paint
Brush Images (.PCX), TARGA Bitmap (.TGA), and TIFF Bitmap (.TIF).

� Button Library. The Button Library includes small raster or bitmapped images that
may be used as buttons to highlight text or graphics. These image types include:
Windows Bitmap (.BMP), CompuServe Bitmap (.GIF), JPEG Bitmap (.JPG), Paint
Brush Images (.PCX), TARGA Bitmap (.TGA), and TIFF Bitmap (.TIF). These files
are especially useful in creating graphic hypertext links in Web pages.

� Background Library. The Background Library includes raster or bitmapped im-
ages. These image types include: Windows Bitmap (.BMP), CompuServe Bitmap
(.GIF), JPEG Bitmap (.JPG), Paint Brush Images (.PCX), TARGA Bitmap (.TGA),
and TIFF Bitmap (.TIF). These images are generally used as Web page backgrounds.

� Horizontal Rule Library. The Horizontal Rule Library includes raster or bitmapped
images. These image types include: Windows Bitmap (.BMP), CompuServe Bitmap
(.GIF), JPEG Bitmap (.JPG), Paint Brush Images (.PCX), TARGA Bitmap (.TGA),
and TIFF Bitmap (.TIF). These images are generally used only in Web pages as
horizontal dividers.

Each library includes one or more categories of images that are divided by subject matter.
See the list on the adjacent page for a list of categories in each library.

Adding an Image to a Library
You may edit any of the picture libraries using the Library > Edit Image Library menu
options.

To add an image to a library:
1. Click on the Library > Edit Image Library menu options.

Note: You can only add specific file types to specific libraries. You must check which
libraries support which file types.

2. Click on the library type in the Library Type Selector at the bottom of the dialog box.
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Image Library Categories

Clipart Library Categories

Arrows

Balloons

Bullets

Flags

Miscellaneous

Plants

Signs

Stars

Vector Image Library Categories

Animals

Buildings

Greetings

Home

Office

People

Picture

Sport

Tools

Transport

Raster Image Library Categories

Animals

Arrows

Logos

Miscellaneous

Nature

Picture Gallery

Religious

Border Library Categories

Borders #1

Borders #2

Borders #3

Borders #4 (Greetings)

Borders #5

Raster Brush Library Categories

Balls

Brush Collections

Color Brushes

Internet Brushes

Medium Brushes

Patterns

Radial

Small Brushes

Vector Brush Library Category

Stars

Bullet Library Categories

Arrows

Balls

Large Circle

Large Diamond

Large Rectangle

Large Square

Medium Circle

Medium Diamond

Button Library Categories

3D Border

Actions

Arrows

Circular Buttons

Diamond Buttons

Extra Wide Rectangular Buttons

Rectangular Buttons

Square Buttons

Background Library Categories

Canvas

Clouds

Miscellaneous

Pastels

Textures

Tiles

Horizontal Rules Library Categories

Narrow Rules

Solid

Textured
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3. Click on the library category in the library selector drop down list (it is located just
below the Files of Type selector.).

4. In the folder selector at the top of the dialog box, log to the drive and folder that
contains the file you wish to add to the library.

5. Click on the file that you wish to add.

6. Click on the Show Preview option if you wish to see the image before you import it.

7. Click on the Add button to add the image to the selected library.

It is important to remember that you must select compatible images for the libraries. For
example, you cannot import a Windows Bitmapped image (.BMP) into a Vector Image
Library.

Deleting a Picture from a Library
You may delete any of the pictures in a library using the Edit Image Library option in the
Library menu.

To delete an image from a library:
1. Click on the Library > Edit Image Library menu options.

2. Click on the library type in the Library Type selector at the bottom of the dialog box.

3. Click on the library category in the library selector combo box list located just below
the Files of Type selector.

4. In the image list box (below the library selector), click on the file that you want to
remove.

6. Click on the bottom Show Preview option if you wish to see the image before you
remove it.

7. Right click on the image file to open the drop down menu.

8. Click on the Delete option to remove the image from the selected library.

Note: Be careful not to click on the Delete Library button. The Delete Library button will
remove the entire library from the DesignShop system.

Creating a New Image Library Category
You may add picture libraries to the DesignShop system using the Edit Image Library
option in the Library menu.

To add a new image library:
1. Click on the Library > Edit Image Library menu options.

2. Click on the library type in the Library Type selector at the bottom of the dialog box.

3. Click on the New Library button.

4. Enter the name for the new library category.

6. Click on OK. The new image category is now added to that image library.

Editing Brush and Pattern Libraries
Brush and pattern libraries are edited and created in the same manner as the picture librar-
ies. The only consideration with these libraries is the manner in which the original graphic
is used. For example, the graphic of a butterfly is simply inserted in the picture library as
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is and used in any instance you need a butterfly image. Brush and pattern libraries, how-
ever, are very small patterns or images that are reproduced repeatedly throughout the
image to produce a specific pattern. If you wish to create a wallpaper effect of a particular
graphic image, you may insert that image into a brush or pattern library. However, for the
most part, graphic images will not display or print well as a brush pattern.

Editing a Color Library
You may create and edit color libraries using the Library > Edit Color Library menu
options. The color library feature is an advanced feature intended for the advanced graphic
artist who requires precise control of color selections in a color library.

To change a color in the color library:
1. Click on the Library > Edit Color Library menu options to open the Color Library

dialog box.

2. Click on the arrow to the right of the Color Library selector to open the drop down
library list.

3. Click on the library that you wish to edit from the library list.

4. The colors for that particular library appear in the color swatch display below the
library selector. Click on the color square that you wish to change.

5. The Color Library dialog box includes a display of Basic Colors in the upper left
corner. Click on the color that is closest to the new color that you wish to insert.

6. In the color gradient display in the upper right corner, you will notice that the cross-
hair indicator moves to the color that you selected in the Basic Color section. If this
is the desired color, click on the Replace Col button to replace the color in the library
with the selected color. The color swatch indicator in the color library will reflect the
new color. If the color in the gradient display is not the exact color you desire, you
can place the mouse pointer on the cross-hair and, while holding down the left mouse
button drag the cross-hair to the desired shade.
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To add a color to a library:
1. Click on the Library > Edit Color Library menu options to open the Color Library

dialog box.

2. Click on the arrow to the right of the Color Library selector to open the drop down
library list.

3. Click on the library that you wish to edit from the library list.

4. The colors for that particular library appear in the color swatch display below the
library selector. Click on the color square that you wish to change.

5. The Color Library dialog box includes a display of Basic Colors in the upper left
corner. Click on the color that is closest to the new color that you wish to insert.

6. In the color gradient display in the upper right corner, you will notice that the cross-
hair indicator moves to the color that you selected in the Basic Color section. If this
is the desired color, click on the Add Col button to add the color to that library. If the
color in the gradient display is not the exact color you desire, you can place the
mouse pointer on the cross-hair and, while holding down the left mouse button drag
the cross-hair to the desired shade.

To remove a color from a library:
1. Click on the Library > Edit Color Library menu options to open the Color Library

dialog box.

2. Click on the arrow to the right of the Color Library selector to open the drop down
library list.

3. Click on the library that you wish to edit from the library list.

4. The colors for that particular library appear in the color swatch display below the
library selector.

5. Click on the color in the library that you wish to remove.

6. Click on the Remove Col button to remove that color from that library.

Creating a New Color Library
DesignShop includes a number of different color libraries for you to use. You can also
create your own new libraries using any color combination that you desire. You can as-
semble a library from individual colors that you select or you can have DesignShop create
ranges of colors based upon your specifications.

To create a new color library:
1. Click on the Library > Edit Color Library menu options to open the Color Library

dialog box.

2. Click on the New Library button to create a new library.

3. Enter a name for the new library.

4. Click on the OK button to accept the new library name. You now have a new library
structure that does not yet contain colors.

To add colors to the new library:
1. In the Basic Color section, you can select individual colors and then click on the Add

Col button to add the colors to the library.

2.  If you wish to create a range of colors for the new library, you can have DesignShop
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create a color range based upon the colors you select. To use this feature, you must
select the first color for the library. You can select the color by clicking on the color
in the Basic Color display or by dragging the cross-hair in the gradient color display
to the desired shade.

3. When you have the desired color for the first color in the color library, click on the
First Color button. You will notice that the Color Generator section includes a nu-
merical display indicating the mix for the colors. If you know the precise amounts of
each color required, you can enter the numbers in the spaces provided in the Color
Generator section.

4. Next, you must click on the last color to insert in the library range. You can select the
color by clicking on the color in the Basic Color display or by dragging the cross-hair
in the gradient color display to the desired shade. When you have the desired color,
click on the Last Color Button.

5. Next, you must select the number of color shades that are to appear in the library
between the first and last colors. To enter the number of color shades, use the scroll
arrows in the Count box or enter the number desired. The horizontal display bar to
the left of the Count indicator displays a gradient for the number of shades selected
for the first and last colors.

6. To complete the color library, click on the Generate button. A color range using the
Count number is inserted into the new library. The range of colors begins with the
First Color you selected and ends with the Last Color.

To remove a color library:
1. Click on the Library > Edit Color Library menu options to open the Color Library

dialog box.

2. Click on the arrow to the right of the Color Library selector to open the drop down
library list.

3. Click on the library that you wish to remove from the library list.

4. Click on the Yes button to confirm the deletion. The library is removed from the
DesignShop system.

To rename a color library:
1. Click on the Library > Edit Color Library menu options to open the Color Library

dialog box.

2. Click on the Rename Library button to rename it.

3. Click on the combo box at the bottom of the dialog box to open the list of available
libraries.

4. Click on the library name that you wish to rename.

5. Enter a new name for the library.

6. Click on the OK button to accept the new library name. The library is renamed.
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Chapter 13.

Secure Shuttle Transport - SST

Introduction
SST is a secure instant messenger including encrypted secure file transfers and more. SST
provides you with additional functions that are useful for Web applications. It can be used
to interact with visitors to your site or others on the Internet. Some of the SST features
include: Encrypted Instant Messaging and real time chat, encrypted FTP, encrypted real
time Voice Over IP, secure E-Commerce / Credit Card information exchange, and much
more.

The SST installation starts once the WebPage Construction Kit Installation is completed.
You may also install SST from the Welcome screen of WebPage Construction Kit’s pro-
gram CD. After you install SST, make sure you have Internet connection, and then double-
click on the SST icon found on the Windows desktop.

This chapter describes what SST is, and how you can use it. Topics covered in this chapter
include:

• SST Enterprise for Large Corporations

• System Requirements

• Installing SST

• Registering SST and Getting a UID

• Specifying Server Settings

• Exporting and Saving Your SST User Profile (SSI file)

• The SST Application Window

• Using SST

SST Enterprise for Large Corporations
You need an Internet connection to use SST and interact with others. Large companies may
upgrade to or use the SST Enterprise solution, which enables them to use SST over their
local or wide area networks. It is an ideal backup communications system to the regular
email used in companies. SST does not require an email server or an email client such as
Outlook, Netscape or Eudora. More and more, company operations are coming to a halt as
viruses are infecting the Email servers. If the company’s email is not working due to
viruses, network and server maintenance or other reasons, the entire company computer
network can still operate on SST. This keeps the company operational and avoids financial
losses. If you work in a large company and are interested in learning more or deploying SST
Enterprise solution in your company, please contact Boomerang Software sales for more
details.
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System Requirements
The SST installed on your PC is a small program that takes up less than 3 megabytes of
hard disk space. It operates on your PC as a client program and does not interfere with any
other applications that you have.

 The minimum system requirements to run SST are:

• A 200 MHz IBM PC with Windows 95/98/2000/NT/Me/2000 or XP

• 32 MB of RAM

• 5 MB of free hard disk space

• 800 by 600 resolution monitor

• Internet Explorer 4.01 (or higher) installed on the same computer

The recommended system requirements are:

• A 233 MHz IBM PC with Windows 95/98/2000/NT/Me/2000 or XP

• 32 MB of RAM

• 10 MB of free hard disk space

• 1024 by 768 resolution monitor

• Internet Explorer 4.01 (or higher) installed on the same computer

Installing SST
SST is part of a number of different Boomerang Software products. The SST installation
starts after the installation of your Web application is completed. You can also install SST
by clicking Install SST from the Welcome screen of your program CD.

The installation places all the necessary files on your PC and inserts the SST icon on your
desktop. After the installation is completed you must register the program. You cannot use
SST without registering it.

After registration, you will be able to connect to the SST network, exchange information
and take advantage of all SST system functions. Please refer to the Registering SST Section
below, to continue the SST registration.

If you already have an SST client program installed and running on your PC you can install
the new version over it. If the SST you already have is a more recent version than the one
being installed now do not re-install SST. You can simply exit the SST installation program
and use the version you have. The installation screens of the new SST indicate the version
number of the SST being installed now. To see the version of your existing SST, click on
About in the main menu of SST. If the existing SST is older than the one included on your
program CD, before proceeding with the installation, right-click on the SST icon in the
Windows tray, and select Exit. You can now install SST on your PC. It will install over the
older version. However, if you think the SST you already have is a more recent version
than the one being installed now, then do not re-install SST. You can simply use the version
you have. The installation screens of the new SST indicate the version number of the SST
being installed now.

Registering SST and Getting a UID
Registering SST is different than the registration of regular software programs, where you
indicate that you are an owner of the program. You cannot use SST without registering it.
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Registering SST means that your computer connects to the SST main servers located at
Boomerang Software and gets a unique identity code. This is referred to as a Unique ID or
UID for short. It is a unique number that designates you.

You can start the SST registration after the SST installation is completed. SST registration
needs to connect to the servers at Boomerang Software. It needs your computer to be
online to do this. In most cases, SST registration will start your Internet connection or ask
you to go online. Due to certain PC configurations, it is recommended that you go online
first then start the SST registration to avoid registration problems.

To start the SST registration, double-click on the SST icon on your desktop. The SST
Registration Wizard starts.

The wizard will ask you if you want to register yourself as a new SST user (referred to as
an SST client), or whether you want to read-in and activate an already existing SST
account. If it is the first time you are registering SST then select the Register A New
Account option and click Next.

If you have previously registered yourself and have an SST profile, then choose Use a pre-
registered UID, browse and open your valid SST account. Users of SST can export and
save their user profiles and UIDs in SSI files. They can place the SSI file on a diskette or
other media, read it in SST client programs on other computers, and use their saved SST
account.

Follow the wizard and enter the requested information. Some of the data such as personal
address are optional. All the information you enter in the input forms of the wizards
become your user profile. Others can search for you on the SST network, and check your
user profiles. At a minimum, most people enter their name, company name, email address
and a nickname. The nickname is the name that will appear (representing you) on other
SST users’ contact lists.

SST registration wizard then displays a number of connection related options for you to
chose from. These options refer to the different ways that client PCs may connect to the
main SST servers. The communications between your PC and the SST main server are
affected by the network connections that they have to communicate over or through, in
order to establish proper communications. Otherwise your SST will not work. Please refer
to the section on Specifying Server Settings for more details.

Specifying Server Settings
The different methods by which your PC may be connected to the Internet and the SST
main servers are: modem connection and your regular dial up account, DSL or cable mo-
dems, Direct IP addresses, and LAN connections through a local area network inside a
company that is connected to the Internet through the company Internet connections, i.e.
T1, T3, Fiber optics.

In most cases, these different methods of communications do not pause any major prob-
lems, and your SST will operate properly. In cases where your PC is on a network inside
a company, the company proxy servers, may have all proper communication ports closed
and this may cause SST not to function properly. In other cases, the company may have
placed a firewall that completely blocks any communications. For this purpose, SST
provides you with a number of different settings to select from in order to set the best
communications means and operate SST properly.

One of the important parts of the registration process is to establish connection between
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your Computer, where SST is being installed, and the main SST servers. If the signals of
communications that are sent by your PC to the Main servers, reach the servers and come
back successfully, then your SST can function properly. You specify the server connec-
tions in the registration wizard screens.

Test Connection with Server
Most users are not expected to be very knowledgeable about the technical details of the
client PC to sever connection. However, in most cases the default settings of the registra-
tion wizard will work fine. To use the default settings, simply click the Test Connection
button.

If the connection to and from the main SST servers are successful, SST displays a message
indicating that the test was completed successfully. This means you do not need to change
any settings. Simply click Next to continue with the other parts of the registration.

Note: To use a Real IP or Microsoft proxy, click Next. The Registration dialog box
appears. No specific server settings are required when using Microsoft proxy.

If the test was not successful, then select other options and try the test again. Try all the
different options available until one of them establishes the proper connection. The fol-
lowing are some of the options:

• To use a SOCKS Proxy, check the Use SOCKS Proxy check box. Complete the Proxy
Address, Proxy Port, User Name, and Password fields. When done, click Next. The
Registration screen appears. Test the connection.

• You can also set SST to use the browser settings already configured on your com-
puter. For example, if you are using Internet Explorer 5 as your main browser on your
computer, and if it is properly configured for the network settings of your PC, then
you can direct SST to use those settings. To check if your IE 5 is set properly, from
the IE 5 main menu select Tools > Internet Options > Connections tab and click on
LAN Settings button for LAN or the Settings button for Dial-Up connections
successively. The proxy server settings section must indicate the proper settings. If
this section is blank then your browser is not using network settings, and you cannot
use the Use Internet Explorer Settings option in SST. If proxy server settings are
properly set on your computer and you want to use them for SST, check the Use
Proxy option in the wizard screen and click the Proxy Settings... button. Then check
the Use Internet Browser Settings option in the Proxy Settings dialog box.

• If your ISP or company’s Internet network is not set up to handle SST or similar
communications software, then check Use Proxy option, click on Proxy Setting and
select HTTP from then Proxy Type filed. Use the HTTP option only if all other
settings fails to establish connection. HTTP connection is slower than the normal
connection modes, and not all SST functions would operate under HTTP configura-
tion.

Proxy Ports, Microsoft Proxy And Network Administrator Issues
If you are using SST form inside a company network, then most likely your company is
using Microsoft Proxy Server and has Microsoft Proxy client installed on your PC. You
should call the network administrator and ask if this is the case. In such a case, and if your
SST is unable to connect to the main SST server, you must ask your system administrator
to reserve inbound and outbound ports for the SST client. The system administrator must
enable at least as many inbound and outbound ports as the number of SST users inside
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your company network. Each SST user needs one inbound and one outbound ports.

Click on the Test Connection button to retry establishing the connection with the server.

Configuring the port settings to work with Instant Messaging programs is a standard
practice done by your system administrator in proxy server administration. For more
questions or issues on this topic, your network administrator may contact
TechSupport@BoomerangSoftware.com.

After you set the proper communications settings, and the connection to the server test is
successful, click on Next to proceed to the final part of the registration where you will be
asked to export your SST user profile.

Exporting and Saving Your SST User Profile (SSI file)
At the end of the registration, you are given the option to export your SST profile (the SSI
file). If you export the SST profile, you can use it again at any time in the future. You may
want to do so if you need to install SST on another PC or if you travel and use SST from
another computer. When you start SST from any other computer and read-in your saved
SST profile, it brings up all your contact list, user profile information you have entered,
Security Keys, and other SST settings. If you are using SST for the first time, you do not
have any contacts listed. It is recommended, yet not critical, to save the SST profile at this
time. As you use SST and add other SST contacts on your list, then it becomes more
important to save your SST profile from time to time. You can save your SST profile at any
time while using the program. To do this click on Export SSI file from the SST main menu.
Keep the SSI file somewhere safe. It includes your encryption keys that can be used to
unlock and decrypt the encrypted messages you have sent and received.

The SST Application Window
When you successfully register SST, your SST will be given the unique account number
UID. The SST program will start and the SST main window will appear. You can drag the
SST window and place it anywhere you want on the screen. The SST Application Window
includes:

User ID Number
Your SST User Account number (UID) appears at the top of the SST window. This
number identifies you to all other SST users.

SST Window Controls
The windows controls found in the title bar at the top of the SST window provide system
controls for desktop and system related settings. When you click on the SST icon on the
upper right corner of the window, the pop up menu displays a number of choices. These
include:

• Move and Size options. They enable you to drag and reposition the SST window on
the screen and drag the borders and resize it.

• Minimize and Maximize. They minimize the SST window into the Windows task
bar, or maximize and display the full window.

• Close. It closes the SST window. Note that this does not exit or stop the program
from running. It simply closes the SST window, and removes it from the windows
Taskbar. The SST icon continues to remain in the windows tray. SST will run in the

mailto:techsupport@boomerangsoftware.com
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background in listen mode. When a person
sends a message or chat request to you, SST
will become active and the SST icon in the tray
will start blinking. Double click on it and the
full SST window will appear again for you to
use.

• Always on Top. If you select this option, then
the SST window will always stay on top of all
other program windows that run on your PC.
It is generally a good idea to do this, especially
if you are expecting chats and messages com-
ing in on SST, and want to make sure that you
see the nicknames blink or the SST window
fully visible.

• Language Settings. Enables you to choose
the windows system language and fonts set-
tings to be used with SST. The default is En-
glish.

• The minimize, maximize, and close icons in
the upper right corner of the SST window,
minimize, maximize, or close the SST window.
If you close the SST window, it does not exit
the SST program, it simply hides and removes
it from the desktop. The SST program works
in the background in listen mode. Double click
on the SST icon in the Windows tray to dis-
play the SST full window again.

The Active and All Tabs
The Active and All Tabs display the nicknames of other SST users you have searched and
added to your contact list. The contact lists in the Active and All tabs define the commu-
nity or network of friends, business associates and Web site customers that you like to
interact with.

The Active tab displays only those members of your SST Contact List that are currently
online.

The All tab displays all your contacts (with their nicknames), immaterial of whether they
are online or offline. Those who are online are displayed with a color fill monitor icon.
Users who are offline have a monitor icon, which is blank or white.

When users listed in your All tab go online, i.e. connect to the Internet and start working on
their computers with their SST running, their nicknames and icons immediately turn to
online status on your All tab list, and the users’ nicknames are inserted in the Active tab.
Similarly, when your SST contact list members go offline, or exit their SST programs, they
are automatically removed from the Active tab list, and they take the offline status in the
All tab.
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Using SST
Using SST is very simple. It does not require any special training. The user interface is very
simple; right-click on the nickname of the person you want to communicate with, then
specify what kind of communications you want to conduct with that person or what data
you want to send. Unlike email, with SST the data goes from your computer directly to the
other SST user’s computer.

Advantages of SST – Encryption and Security
SST is unique amongst all other Instant Messaging programs. When you send a message,
chat, transfer files or send email attachments with other messaging or email programs, they
travel over local area networks, through servers, or over wide area networks and Internet
connections. These paths, in most cases, are unknown and uncontrollable by you. Others
may tap, record, and view such messages. The Internet is an open communications net-
work.

SST provides a Software Virtual Private Network (VPN) to give you secure channels of
communications with others. The messages you send and receive, the files you transfer or
data you exchange with others using SST, are encrypted with the most modern encryption
techniques available in technology today. Using RSA private and public key architecture,
SST works in the background without changing the way you work, and does not require
any special encryption know-how. It encrypts data on one end, sends it to the other SST
user, and decrypts it, all automatically and in real time. It is simple, clean, fast and highly
secure.

Starting and Using SST
To start SST select Start > Programs > Boomerang Software > Boomerang SST. If
you checked out the checkbox to start SST whenever you start your computer, then SST
will start automatically each time you start your computer. You must be online with
Internet connection to use SST. Otherwise, the SST status will indicate Offline. You cannot
receive or send messages or perform other communications with SST if you are offline.
Other SST users will see you as being offline as well.

If you have Internet connection, and the SST window is open, click on the Offline button
and select Online to go online. SST uses whatever your means of Internet communica-
tions you are using, connects to the SST main server, and becomes active.

Click on the Active Tab to see the list of contacts who are online or active at this time. If
you just installed and registered SST, the list will be empty.

You must add a person to your contact list before you can send or receive messages, chat
or exchange information with that person.

To search another SST user and add that person to your contact list, select Search Users
from the SST menu. Fill out one of the fields you want to search by and find the person.
You can use ? and * characters as wildcards in your searches. SST will bring up exact
matches as well as other users with similar profiles or search criteria. A list of possible
candidates will be displayed. Find the person in the list that you want, click on the
person’s name and click Add To Contact List. The program gives you an option to add that
person to the Default group, or one of the existing groups or to a new group you may create
for that person. Make your choice and click Add. The person (nickname) will be added to
your contact list.
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A user listed in your contact list can be in one of few states: Online (displayed as a teal or
colored monitor) it implies the person is now online at his or her computer, Offline
(displayed as a monitor’s side view without colors), Away (displayed as a monitor’s front
view without colors) implies the user’s PC is on and his or her SST is online yet the user
is away from the computer, and Busy (displayed as a teal or colored monitor with a red
border) implies the other user is at the computer but is busy and does not wish to interact
at this time.

As you add more people to your list, the list becomes large. You can organize your contacts
into groups. The + and - control buttons next to each Contact List Group icon expand or
collapse the group listing.

The SST Pop-Up User Menu
When you right-click on a Contact List Group icon, the pop-up menu displays a number
of options. These include to delete or rename the selected Contact List Group, sort the
members of the selected Contact List Group alphabetically, or create another SST Contact
List Group.

Right-click on a user nickname. The pop-up User Menu appears. It enables you to com-
municate with that person in an encrypted SST secure channel.

The User Menu also includes filtering options where you can make yourself invisible to
others in the SST contact list. They will see you as being offline, yet you will be able to see
them when they go online, or even be able to send them messages.

When you receive a communications event (such as a message, chat request, or file trans-
fer), a blinking icon appears on the computer icon of that person in your contact list. The
SST icon in the Windows tray starts to blink as well. Double-click on the blinking icon in
the contact list and receive the message. In the case of a message, click Reply, type in a
reply and click Send to reply to that message.

If you receive a communications event from a new SST User who is not listed in any of
your SST Contact List Groups, the application creates a temporary “Not in Contact List”
group and displays that person’s UID in the contact list. The UID will blink to indicate
that a message or SST communications is pending for your acceptance. Double-click on it,
and respond or process the event as you want.

The Offline/Online control button enables you to go offline or online whenever you want.

The Pop-Up User menu that appears when you right click on an online person in your
contact includes the following options:

• Message. Enables you to type and send an instant message to that person. If the
person is offline, you can specify to have your message be sent later at a specified
time or whenever the other person goes online.

• Chat. Opens a double window, where you can type in one window and the other SST
user can type in the other.

• Voice Message. Enables you to send a fifteen-minute voice message to that person.
The Voice Message dialog box that opens provides a Record button. Click on it to
speak into the microphone connected to your PC’s sound card and send that voice
message. The message is encrypted by SST and is secure. This option may be avail-
able only in the Enterprise version of SST and those versions of SST that are pur-
chased.

• Voice Chat. Enables you to speak in full duplex mode, over the Internet connections
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of SST with other SST users. Known as the Voice over IP feature of SST,  it cuts long
distance telephone costs and enables secure and encrypted conversations with your
customers, business associates and other SST users. This option may be available
only in the Enterprise version of SST and those versions of SST that are purchased.

• File Transfer. Enables you to transfer files to the other user. You can transfer as
many files as you want. The files are encrypted, transferred, and then decrypted on
the other side in real time and without any special effort by you or the receiver. You
can browse and point to the files you want to transfer, or you can drag them form the
windows explorer to the File Send window of SST. You can also type in a description
or a comment regarding this transfer. The other user will read your comments, and
accept or decline the transfer. This Encrypted FTP function of SST provides a de-
pendable way to transfer large numbers of files to others on the Internet. Most email
systems in companies block out or quarantine attachment files which are large in size,
for this reason SST’s encrypted FTP functions provide a dependable solution for
such transfers. In addition, since you know who is the actual sender and you can
approve or decline the acceptance of such files, it is much more secure than email
attachments that you may receive, as emails and email attachments have become a
source of deadly viruses that paralyze computers and company networks. This
option may be available only in the Enterprise version of SST and those versions of
SST that are purchased.

• Transaction. Opens up a specialized dialog box and a form to accept credit cad and
payment details. Web customers, normal clients who want to make payments, or
other credit card holders shy away from emailing their credit card information to you,
or in many cases to even enter them in Web site forms. Credit card fraud is increasing
rapidly due to the lack of public confidence. Since SST is a fully encrypted secure
system, you can use the Transaction option to exchange sensitive credit card informa-
tion. The information you receive via SST is inserted in a table-like manageable list.
You can view, sort, find and perform other tasks on all credit card records that you
receive. This option may be available only in the Enterprise version of SST and those
versions of SST that are purchased.

• Email. Encrypts and sends files as attachments to your current or default email
program. Such as Outlook or Netscape. Your email program must be open before you
send an SST Email attachment. The Email To dialog box that opens in SST allows you
to browse or drag and drop any files you want ot send as encrypted attachments. It
also provides space for you to enter a body text that would accompany the attach-
ments. The text that you enter will be encrypted as well. When SST sends this
information, it decrypts it on the other side as soon as it arrives at the other SST user’s
computer. This is one of the major reasons why large companies, especially the
management of such companies use SST Enterprise as an encrypted and confidential
means of emailing and exchanging files in the company. This option may be available
only in the Enterprise version of SST and those versions of SST that are purchased.

• Filter. Enables you to make yourself invisible and appear offline to other users of
your contact list, while you continue to see them.

• Delete and Rename. Deletes the user or renames the nickname in the contact list.

• User Info. Displays the User profile and information the SST user has entered in SST.
It also enables you to get a picture of that user if the user has inserted one. When you
send a message to that person, the picture will appear in the message box helping you
associate the message box with that person. This can be helpful when you are
multitasking, sending and receiving messages with many other users at the same time.
Pictures help you identify which message box is for what user.
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• User Settings. Provides different action driven options that you can assign to spe-
cific users on your contact list. These settings supercede the general settings that
apply to all your SST contacts. They include Automatic receive options, Automatic
acceptance or decline, and incoming trigger and personal sounds. For example, if you
want to have the SST to open a Response dialog box for incoming events, then check
the Pop Up Response Dialog option.

• History. Opens the Event History window. It displays all the messages sent and
received between you and your SST contacts. SST keeps these in its internal data-
base, and displays them in a table-like layout. Click on the + icon next to a person’s
nickname to open the messages subfolders. Click on Message, and the main window
displays the full list of messages exchanged with that person. You may expand and
reduce the size of the data columns by dragging the column title right or left borders.
Click on one of the column title tabs to sort the messages as you want. To see the exact
contents of a specific message, double click on it. Click on the Next and Previous
buttons to quickly display the next or previous messages in the list. While viewing a
message, you can view the User profile of the person who sent the message, or even
click on Message button and send a message without having to do this from the main
SST window.

• Outbox. Displays the list of unsent messages in the outbox waiting to be sent. Note
that you can send messages immediately or at a time or time interval that you specify.

• Received Files. Opens the Windows explorer, points to the folder where all the files
you have received from that user are sorted, and lists them. This is very convenient
feature. After using SST for many months, you may forget where certain files that
you received from others are found. SST manages the receiving and storing of files via
its secure FTP functions. When you right click on a contact nickname in your list and
select Received files, it knows where all the files you received from that person are on
your computer, and it lists them for you.

• Move To. Moves that person to another group in your list.

The SST Pop-Up System Menu
When you click on the down arrow or the system menu icon in the SST window, the SST
pop-up System Menu appears. It provides SST program and system maintenance op-
tions. These include:

• My Info: Displays your SST User Registration Profile and enables you to change it.
This is the information that others see when they check the user info on your nick-
name.

• History: Displays all the messages you have sent and received. Please refer to the
History explanation in the SST Pop-Up User menu for more information.

• Outbox: Displays the Outbox dialog box of all messages not sent and which are
waiting in the out box. Please refer to the Outbox explanation in the SST Pop-Up User
menu for more information.

• Address Book: Displays your SST Address Book. It lists the details of all your
contacts in a table-like layout.

• Search Users: Searches the SST network for users. You may enter names, nick-
names, email addresses, or even their UIDs if you know them. You can also use ? and
* wildcards in the text that you enter for searching. SST displays all the exact and
similar matches to the people you are looking for. You can conduct more searches or
add them to your contact lists. Note that you must search and add a person to your
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contact list before you are able to send messages to that person.

• Add To Contact List: enables you to create a new group and add it to your contact
list.

• Filter: Enables you to make yourself invisible and appear offline to other users of
your contact list, while you continue to see them.

• Preferences: Displays the Preference dialog box and modify SST system settings.
This includes connection options via proxy, Socks 4 or 5, HTTP, and monitor and
inform you of incoming mail. It also enables you to specify how big a database of
History you wan tot keep for your messages, encryption options, specify short cut
keys to quickly enter macro like text in your message boxes, and specify different
actions that can be activated by certain triggers.

• Register/Sign In: Launches the SST Registration Wizard. This allows you to regis-
ter again if you need to, or register another person on the same computer. The program
will ask you to save your current SST registration profile before you start a new
registration.

• Export SSI File: Saves your SST Registration profile to a file. You can use it later to
retrieve your account if you want to use SST on another computer, or after you install
a new operating system on the same computer.

• Feedback: Launches your default Email program and enables you to send any email
you want to the Boomerang Software technical support team.
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• About: Displays information about the program including the version number.

• Exit: Exits the program. This closes the program and stops it from running.
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America OnLine Information

For AOL Customers
The following sections explain how AOL users can upload their Web page files to AOL.

Section I:
For AOL users who want To FTP files to AOL using AOL’s “Built-In” FTP Program.

These help tips may be reinterpreted if the AOL FTP application is changed or modified
by AOL.

Note: If you are NOT an AOL customer, this section does not pertain to you. Please
refer to the next section if you need help in uploading and downloading Web site files.

1. Make sure you have saved your Web site files. No matter where you saved them or what
you named them, either write down or print out the list of files and their location
(usually a directory on your hard drive) of the files you intend to upload to AOL.
This will be important later on, in Step 11. For now, As a tutorial, we will step through
an FTP session and upload to the Boomerang Software home page at AOL:

members.aol.com/boomsoft

Here are the two files we will upload:

index.htm

pict0000.gif

2. To start the tutorial, log onto AOL.

3. Click on Go To from the main AOL menu bar.

4. Click on Keyword and type “ftp” in the “Enter word(s)” area and then click on the Go
button.

5. The next screen should be the FTP - File Transfer Protocol window. It has a list box in
the middle with two link icons on either side. The one on the right is titled, “Go To
FTP” and you should click on it now.

6. The next screen displays the “Anonymous FTP” window. Here, a scrollable list box
in the middle shows “Favorite Sites.” In the lower window area, two link buttons
appear, “Connect” and “Other Site”

NOTE: For AOL users uploading to a Web server OTHER than one of the AOL Web
servers, please skip ahead to step 16, where a tutorial gives a step-by-step guide to
uploading to an example NON-AOL Web site: www.Webhorizon.com/giftshop.

7. To locate the “members.aol.com” ftp Web site, scroll down through the list box until
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you see “members.aol.com.” Click once to highlight it, then click on Connect.

8. At this point you should be “connected” to “members.aol.com” and this status is
shown by the “members.aol.com/yourscreen name” in the title bar of the window,
indicating that you are in your own personal ftp area. Across the bottom, seven com-
mand buttons are laid out. In the middle, a list box shows the directories and files
listed on the remote server. With AOL FTP running, this is the “control console” for
YOUR Web site.

9. The title bar of the window reads, “members.aol.com/boomsoft” To begin the upload
session, click on the Upload icon.

10. The next window is titled, “members.aol.com” and has an input box titled, “Remote
Filename” and two buttons in the lower portion, “Continue” and “Cancel.”

11. We type “index.htm” for “Remote Filename” and click on Continue.

12. The Upload File box appears, with two icons, “Send” and “Select File” joined by an
empty input line titled “File:.” Click on “Select File.”

13. The next window is the “Attach File” window. Click through the directory tree and
locate our Web project in a folder titled, “boom.htm.” Click once to highlight the
folder, then double-click to open it, revealing files “index” and “pict0000.”

14. Double-click on “Index” to select it for uploading. The “Upload File” reappears, this
time the entire pathname of our file index.htm is shown in the “File:” input line in
gray text. Now, click “Send.”

15. The file is uploaded. The “members.aol.com” window reappears, with the “Filename”
input line and “index.htm” is still showing. Now, we clear out “index.htm” and type
in the next filename for uploading: “pict0000.gif” and we click on “Continue.” From
here, it’s a repeat of steps 12, 13 and 14 (one file at a time) until all of the files are
uploaded. They should all be visible in the big list box described in step 8 - including
the date and file size.

16. To FTP to a site OTHER than members.aol.com, do not use the scroll-down list box
of “Favorite Sites.” Instead, click on Other Site.

17. The “Other Site” window appears, offering you an input line titled “Site Address”
and a Connect button in the lower portion of the window. Type in the ftp server
address of the target Web server. For example, “ftp.Webhorizon.com” would be cor-
rect in order to upload to “www.Webhorizon.com/giftshop.”

18. Note that there is a check box titled, “Ask for login name and Password.” Make sure
you put a check mark in that box. Click on Connect.

19. The “Remote Sign On” window appears. The title bar is labeled “Anonymous FTP.”
Type your “login name” in the first box, enter your password in the second box, and
then click Continue.

20. If your login name and password are accepted, you will next see the ftp control
window. A full listing of any files on the remote server will be displayed and the title
bar will indicate exactly where you are.

Section II:
This section applies to AOL users who are in the following groups:

1. AOL is your only connection to the Internet.

2. You want to publish your Web site to a server that does NOT reside on the AOL
network.
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You need the Windows 95 version of AOL 3.0 software to take advantage of this
publishing method. To publish your Internet  DesignShop Web site to an NON-AOL
server, follow the these steps:

1. Log onto AOL as you normally would.

2. At the Welcome! Screen, “minimize” AOL.

3. Start up Internet  DesignShop and open the Web project you wish to upload.

4. From the Menu Bar, click on Site then click on Upload Site.

5. The Upload Web Site dialog box appears. Fill in the four input lines as follows:

FTP Server Name or Address: Type in the FTP server address for the server
you have selected as your Web hosting service.

User Login: Your login name, as assigned by the Web host-
ing provider you have selected. Boomerang
Software Web hosting customers, you should
already know your user log in.

Password: The password you have either selected or have
been assigned by your Web hosting provider.
Boomerang Software Web hosting customers,
you should already know your password. To
force Internet  DesignShop to save the pass-
word, check the Remember Password check
box

Upload Path: Type in the upload path given to you by your
Web hosting provider. Boomerang Soft-
ware Web hosting customers, you should al-
ready know your upload path.

6. Click on Upload. The Web site publishing function uploads all files to the target Web
server.

7. You can follow the progress of your upload on screen. After the upload is complete,
exit Internet  DesignShop, turn up AOL, click on the Internet icon and go visit your
brand new Web site!
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Appendix A.
License Agreement and Warranty

IMPORTANT
Opening the software package and using Internet DesignShop indicates acceptance of the terms of this License
Agreement.

NOTICE OF COPYRIGHT
This software program package (“SOFTWARE”) is a proprietary product incorporating elements developed by
Boomerang Software, Inc. (“BOOMERANG”). This software is protected by copyright laws and international
treaty. You must treat the SOFTWARE like any other copyrighted material, except that you may either make one
copy of the SOFTWARE for backup or archival purposes, or you may place the SOFTWARE on a single mass
storage device (media), such as a hard disk, provided that you keep the original software for archival or backup
purposes. Copyright laws prohibit making additional copies of the SOFTWARE for any other reason. You may not
copy written materials accompanying the SOFTWARE without the express permission of BOOMERANG.

The WebShop program, its screens, icons, sequence, and organization are copyrighted materials of BOOMERANG.
They may not be copied or duplicated in any medium without the written authorization of BOOMERANG.

SOFTWARE LICENSE AGREEMENT
The software on the Internet DesignShop media is licensed to the user. Before using Internet DesignShop,
you should carefully read the terms and conditions of this Agreement. This Agreement is a legal contract
between you (the end user) and BOOMERANG, governing your use of the software. If you do not agree with
these terms and conditions, please return the software with all accompanying packaging materials to the
vendor from who you purchased it for refund or credit. Return policies of vendors may vary; you should
check with your vendor as to their return policy on returning unused, unregistered software. Return of soft-
ware is subject to restocking charges and terms which will be applied and deducted from the initial cost
paid by the customer returning the software. This agreement shall also be binding on any subsequent
authorized licensee. If you have questions regarding this Agreement, contact BOOMERANG at  617-
489-3000.

A. BOOMERANG grants you the right to use one copy of the software on a single-user computer only. Install-
ing the SOFTWARE on a multi-user computer or network server is a violation of this Agreement.

B. BOOMERANG further grants you the right to make a backup/archival copy of the SOFTWARE as
set forth in the Notification of Copyright.

C. You may not sublicense, rent, or lease the SOFTWARE, but you may permanently transfer your
license to use the SOFTWARE and accompanying materials by delivering to another party the origi-
nal media (that is, the CD-ROM), and original user documentation materials comprising the SOFT-
WARE package. The new recipient of the SOFTWARE and accompanying materials accepts this
Agreement and is licensed under the terms of this Agreement upon initially using the SOFTWARE.

LIMITED WARRANTY / LIMITATION OF REMEDIES
BOOMERANG warrants the original media (that is, the CD-ROM) on which the SOFTWARE is recorded to be
free from defects in workmanship under normal use for a period of thirty (30) days from the date of your
purchase as evidenced by a copy of the original receipt of payment. BOOMERANG’S entire liability and your
exclusive remedy will be replacement of the media that does not meet BOOMERANG’S limited warranty and is
returned to BOOMERANG with a copy of the original receipt of payment. BOOMERANG will have no respon-
sibility to replace media that has been damaged by accident, abuse, or misapplication.

Under no circumstances including negligence, shall BOOMERANG be liable for any incidental, special, or consequential
damages that result from use or inability to use the SOFTWARE or related user documentation, including all user documenta-
tion delivered in digital format, even if BOOMERANG or any BOOMERANG authorized representatives have been advised
of the possibility of such damages, or that result from mistakes, omissions, interruptions, deletion of files, errors, defects, or delays
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in operation or any failure of performance whether or not caused by events beyond BOOMERANG’S reasonable control,
including, but not limited to, acts of God, computer failure, theft, destruction, or unauthorized use of BOOMERANG program or
services provided by BOOMERANG in connection with the publication of the software covered by the License Agreement.

Because any individual software title which (1) creates files combining multimedia functionality with hypertext
markup language (HTML) functionality and (2) is designed to create a commercial Web site (“WEB STORE”)
to facilitate electronic commerce over the public Internet is subject to many factors beyond the reasonable
control of BOOMERANG, including but limited to the known incompatibilities among widely-distributed pro-
grams for viewing HTML files over the public Internet and private Internet Protocol (IP) networks, improper,
insufficient, obsolete, or inoperable hardware or software configurations on remote PC’s accessing the public
Internet or private IP networks, unforeseen congestion on the public Internet or private IP networks, failure of
public telecommunication transmission providers, failure of unknown third parties to deliver access to the pub-
lic Internet or the legal or illegal use of public and private communication systems by unknown third parties, you
are advised to verify all work created with this SOFTWARE.

You are further advised to verify all confirmed or unconfirmed attempted transactions from any fully identified or
partially identified end user (“CUSTOMER”) accessing the WEB STORE and strongly encouraged to make
backup copies of all files, reports, email or any other administrative information generated as a result of work
created with this program or attempts to access Web sites generated through the use of this program.

BOOMERANG is in no way liable for the failure of any single electronic commerce transaction or any
series of transaction authorization failures experienced by one or more end-user merchants using this
SOFTWARE program to sell any product or service over any public or private communication system or
by an end-user attempting to access any file or Web site through any public or private communication
system to purchase any product or service created by any licensed or unlicensed user of this program.

Boomerang Software, Inc. cannot assume any responsibility or liability for any indirect, special, incidental, economic, cover or
consequential damages arising out of the use of or inability to use Internet DesignShop or any component of the documen-
tation included with the program, including any and all documentation delivered in digital format. In no case shall Boomer-
ang Software be liable for any amount exceeding the purchase amount paid by a licensed user for the software.

The information contained in the Internet DesignShop documentation is subject to change.  Except as specifically provided,
Boomerang Software makes no warranty or representation, promise or guarantee, either express or implied, statutory or
otherwise, with respect to this software or user documentation, including their quality, performance, merchantability, or fitness for
a particular purpose. No Boomerang Software dealer, agent distributor, or reseller is authorized to make revisions to this
warranty.

Revisions to any component of the program or user documentation included with Internet DesignShop may occur as
deemed necessary by Boomerang Software, Inc.  The information herein is believed to be, and is presented to be,
accurate in all respects.  However, Some states do not allow the exclusion or limitation of implied warranties or
limitation of liability for incidental or consequential damages, so the above limitation or exclusion may not apply to
you.

When you install this program, it may set your browser’s default home page to be
www.boomerngsoftware.com. You may change this to another home page that you want. To change the home
page in your browser, for Internet Explorer from the menu select Tools >  Internet Options, in the General (or the
proper) tab’s Home Page Address field enter the web URL address you want. For Netscape, from the menu
select Edit > Preferences, select Navigation in Category, check the Home Page setting and enter the web URL
you want in the Home Page Location. Email Boomerang Software for assistance if needed.

• MS DOS, Windows, NT, Me, 2000 and XP, Internet Explorer, Active Server Pages and True Type are
trademarks of Microsoft Corporation.

• IBM is a trademark of International Business Machines Corporation.
• Navigator is a trademark of Netscape Communications.
• PhotoSuite is a trademark of MGI Software.
All other product names or trademarks identified in the user documentation accompanying this SOFT-
WARE are trademarks or registered trademarks of their respective companies. They are used in this book
in an editorial fashion only. No such use, or the use of any trade name, is intended to convey endorsement
or other affiliation with Boomerang Software products.
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Other Boomerang Software
Products and Services

You may purchase new products or the upgrades for your existing products

Visit the site for pricing and more details, or email Sales@BoomerangSoftware.com
You may also visit your computer and retail stores. Some products are sold direct.

Boomerang Software, Inc. Tel.: 617-489-3000, Fax: 617-489-1486

      www.BoomerangSoftware.com                 www.EcommerceCities.com

• eXtendia – Your complete Web content management and E-Commerce solution for
enterprise companies. Includes: database layer management, visual ASP generator,
complete Web authoring features, latest HTML support, script wizards, E-Com-
merce gateways and more. Supports Oracle, MS SQL, and Access databases.

• eXtendia Community Builder – Includes eXtendia plus the complete online
community designer. Enables you to build and launch online communities within
days. Includes: administration and member provisions, bulletin boards, announce-
ments, gateway E-Commerce back end, and other online community options.

• WebShop XL – The complete tool for the serious Web or E-Commerce site devel-
opers. Includes every software tool you need to successfully sell on the net, includ-
ing selected Web page uploads, page-hit statistics, XML compliancy, built-in Form
Verification, Visual ASP, Script Wizards, Site Manager, order processing, order
verification by email, and more. Create stunning Web sites and successfully conduct
your business online using a seamlessly integrated shopping cart. One of the most
complete and affordable E-Commerce and Web authoring solutions ever created!

• E-Commerce Construction Kit 2.0 Deluxe – The E-Commerce tool for every-
one. Building an online business is easy once you have the right tools. Everything
you need to create an online business is included, ready-to-use store templates,
powerful shopping cart creator, and online new merchant account applications.
This is the program for anyone wanting to be part of the Internet revolution.

• Internet DesignShop XL – A comprehensive Web site creation, management, and
publishing program for Windows (no E-Commerce functions built-in). Intended for
serious Web designers. Supports dynamic HTML, selected Web page uploads,
page-hit statistics, XML compliancy, built-in Form Verification, Visual ASP, Script
Wizards, Site Manager, and more.

• President’s Club Wallet for Pocket PC – A Contact Manager and Wallet
Pocket PC application for storing personal information such as credit cards, bank
accounts, and money accounts; the program features easy data retrieval, flexible
financial data charting, easy-to-use contact storage, and a special feature that en-
abling you to create your own Pocket PC photo albums!

• President’s Club Graphics for Pocket PC – A Pocket PC Graphics applica-
tion for charting personal and business financial information.  Enables you to make
2D and 3D charts that can visually represent data comparisons, patterns, and
trends.  For example, rather than analyze several columns of worksheet data, create
one data chart that will indicate at a glance whether sales are falling or rising over
specific periods or how the actual sales compare to the projected sales!

• Games for Pocket PC and Windows CE Devices –  Square Shooter, Trick
Track, Twins, and 5x5.
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• Total E-Commerce for FrontPage 2000 & 2002 – The leading complete E-
Commerce solution for FrontPage 2000 & FrontPage 2002. Integrates perfectly
with FrontPage. Includes a powerful shopping cart, search engine, online new mer-
chant account applications, online store administration, Access database support,
order processing, order verification by email, and more.

• Total E-Commerce for FrontPage 2000 & 2002 International – The Inter-
national of Total E-Commerce. You can conduct business internationally in over
160 different currencies. Includes online merchant account applications and settle-
ment in foreign bank accounts.

• Total E-Commerce for Dreamweaver MX – The leading complete E-Com-
merce solution for Dreamweaver MX.  Integrates perfectly with Dreamweaver MX
and UltraDev 4.  Includes a powerful shopping cart, search engine, Online new
merchant account applications, Online Store Administration, Access database sup-
port, orders processing and verification emails, and more.

• Data Safe & Secure – A Windows application that is used to encrypt and
decrypt all kinds of files on PC drives. Files can be archived in their encrypted
forms or transmitted to others. In addition to supporting a number of encryption
standards, Data Safe & Secure supports digital signatures as a means of authenticat-
ing the validity of any file before, during, or after transmitting it to others. The
application suite consists of the Data Safe & Secure Client and Data Safe & Secure
Server, which is installed and run as a server on your network. Together they
function as your network solution, and secure the exchange of information and
transmission of sensitive files on your company’s computers.

• PC Safe & Secure – Your complete Encryption and Security program for files,
emails, and any document you want to send over the Net. Excellent protection for
desktop or notebook PCs. Encrypts and protects your data from prying eyes even
when hackers get through a firewall. Send files and documents that only your intended
recipient can read. Includes: File wipe out, erase, and shredding of files to make them
unrecoverable, DES and triple DES encryption, Digital Certificates, and much more.
Perfect for Corporate users who want to protect confidential data. Excellent for home
users who use DSL, modems, and cable modems when going online.

• Secure Shuttle Transport SST Enterprise (Client/Server Solution) – The
leading encryption and Instant Messaging software.  Send encrypted instant mes-
sages, Encrypted email attachments, file transfers, voice messages, and real-time voice
conversations over the Internet, securely and privately. Includes Voice over IP, En-
crypted FTP, and everything needed to secure an entire company’s network and PCs.

• eXtendia AntiVirus AVK Pro – The leading virus protection software for stand-
alone PCs.  This program enables you to protect yourself from computer viruses
that are transmitted by email, FTP, or through shared files from all sources.  This
product combines over 15 years of experience in the field of virus development with
the most up-to-date software technology. Easy to use for everyone, yet offering the
highest security standards–these have always been the most important aims for the
development of eXtendia AntiVirus.
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• eXtendia AntiVirus Client/Server – The leading virus protection software for
network PCs.  This program enables your entire network of PCs to share a common
virus protection solution.  Using the latest client/server technology, this solution
will protect your computer network against computer viruses that are transmitted
by email, FTP, or through shared files from all sources.  This product combines over
15 years of experience in the field of virus development with the most up-to-date
software technology. Easy to use for everyone, yet offering the highest security
standards– these have always been the most important aims for the development of
eXtendia AntiVirus.

Additional Customer Services Include
Electronic Downloads – Many products can be purchased as program downloads
from our Web site. You can also purchase from this Web site additional documentation (in
printed or downloadable form). Click the Download link on the home page at
www.BoomerangSoftware.com.

Web Hosting Services – Let us host your Web or E-Commerce site. All Boomerang
servers are specifically configured to host any Web site developed using our Web and E-
Commerce products. Dedicated servers are available for hosting E-Commerce businesses.
Several hosting plans are available.  For details, visit https://
www.BoomerangSoftware.com/webhosting/webhosting.htm

Other Consulting Services – For NT/Windows 2000 environments, consulting ser-
vices for Internet or enterprise application development is available.
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