
Cumulus

Introduction 

User Interface 

Basics 

Searching 

Managing Assets 

Information on Assets and Categories 

Printing 

Exporting and Importing Information 

Tailoring Cumulus 

Slide Show 

Cumulus Catalog Administration 

Automating Cumulus 

Cumulus Workgroup Administration 

Accelerator Keys 

Troubleshooting 

Glossary 



Cumulus

Cumulus is a Digital Asset Managment Sytem that enables digital and media professionals to organize, track, preview, copy, move, 
annotate and archive virtually any type of digital media, including graphic, page layout, presentation, sound, and video files, turning 
them into Assets. If you can effectively track, locate and retrieve these assets, you can improve quality and workflow, saving yourself 
and your organization valuable time and money.

See the glossary for any terms you don’t understand.

The following topics provide an overview of Cumulus:

· How Cumulus Works 

· Using Online Help 

· Using Window Menu Commands 

· Roadmap to Common Tasks 



 Cumulus
How Cumulus Works

Within the graphics, publishing, and multimedia industries, digital assets can be virtually any type of digital media file including, 
image, graphic, page layout, sound and video files, as well as URLs. Cumulus makes organizing and accessing media assets easy. 
To get started, you need to understand only a few basic concepts. 

Cumulus tracks media assets in a special file called a catalog. As you catalog media assets, Cumulus creates a catalog entry - 
called a record - for each asset. All records contain some searchable information on the assets they represent. The visible set of 
records from a catalog is called a collection. To make searching and retrieving records easier, Cumulus lets you organize and 
classify records into logical groups called categories. 

Once records are cataloged, you can view each one as a graphical thumbnail (with selected asset information lines) or as plain text. 
You can search and retrieve records within Cumulus. Once you locate the record you’re looking for, you can preview it, copy it, or 
move it to a new location.

{button ,AL(`intro',0,`',`')}    See also 



 Cumulus
Using Online Help

Cumulus features an extensive online help system. 

To activate context-sensitive help:

1. Click the option you’d like information on.

2. Press F1 or select Help => Help On.

Information based on the selected item is displayed. 

To browse a listing of help topics:

1. Select Help => Contents and Index. 

A listing of help topics appears. 

You can find out your version number, serial number and product ID by selecting Help => About Cumulus. From this dialog box, 
you can click the Connect to Canto button to connect to the Canto web site for extra information and software updates.

{button ,AL(`intro',0,`',`')}    See also 



 Cumulus
Roadmap to Common Tasks

If you want to... See...

learn about basic program functionality The Basics 

catalog assets Cataloging 

customize cataloging options Setting Cataloging Options 

customize Cumulus application 
preferences

Customizing Application Preferences 

display asset information Asset Information

display category information Category Information

customize the view View Customization

search for information Searching 

customize catalog properties Catalog Properties

locate, copy, move, delete or edit assets Managing Assets 

preview cataloged assets Previewing Cataloged Assets 

print information Printing Information 

contact technical support Technical Support 

{button ,AL(`intro',0,`',`')}    See also 



The Cumulus User Interface 

Click on any topic below to jump directly to the desired help text:

The Cumulus Application Window

Using the Toolbar

Using the Status Bar

The Cumulus Collection Window

File Menu

Edit Menu

View Menu

Catalog Menu

Category Menu

Collection Menu

Asset Menu

Special Menu

Window Menu

Help Menu

Pop-Up Menus



 The Cumulus User Interface
Understanding the Cumulus Application Window

The Cumulus application window contains every command, option and window needed to catalog and categorize assets. Certain 
window options (including most toolbar buttons, and the status bar) only become active when a catalog or collection file is open. 

Key user-interface elements of the Cumulus application window are described below. You can control which elements appear by 
checking and unchecking them in the View menu.

Element Description

Menu bar Holds menus that contain every Cumulus command. Underlined 
characters are keyboard shortcuts. To use a keyboard shortcut, 
display the menu, then type the underlined character.

Toolbar Contains buttons that serve as shortcuts to commonly used 
commands and options. To see a Tooltip for any button, position 
the mouse over it.    For more information, see Using the Toolbar.

Collection window Features two panes: the Category pane (left side) and the Record 
pane (right side). For more information, see Understanding the 
Collection Window.

Category pane Consists of coherently organized groups of records that facilitate 
fast searching and retrieval. For more information, see Using the 
Category Pane.

Record pane Displays records as thumbnails or as plain text. Records store vital 
information about each cataloged asset. For more information, 
see Using the Record Pane. 

Status bar Provides toolbar button descriptions, access to the Application 
Preferences dialog box, category status, and record status. For 
more information, see Using the Status Bar. 

To view an example, see The Cumulus Application Window.

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
The Cumulus Application Window

For a complete description, see Understanding the Cumulus Application Window. 



 The Cumulus User Interface 
Using the Toolbar

Toolbar buttons offer quick and easy access to frequently needed commands and options. Positioning the cursor over a toolbar 
button displays a Tooltip.

You can move the toolbar to the top, bottom, left, or right side of the Cumulus application window, or make it a separate floating 
window. To move it, select its outer edge and drag it to the desired location. 

To turn the toolbar on or off, check or uncheck Toolbar in the View menu.

Toolbar Button Description

Creates a new catalog.

Opens a catalog.

Connects to Cumulus Server.

Cuts selection and copies it to the Clipboard.

Copies selection to the Clipboard.

Inserts selection from the Clipboard.

Shows or hides the Category pane. 

Displays assets using large thumbnails. 

Displays assets using medium thumbnails.

Displays assets using small thumbnails.

Displays detailed information (record name, format, color mode, 
resolution, and modification date) about each asset.

Sorts catalog in ascending order (from A to Z).

Sorts catalog in descending order (from Z to A).

Displays the Cataloging Options. 

Catalogs assets. For further information, see Cataloging Using 
the Catalog Assets Command. 

Opens the Find window. 

Displays the Asset Information Window. 

Displays a preview of the cataloged asset.

Opens a dialog from which you can create a slide show from the 
selected records.

Attaches the asset represented by the selected record to an 
outgoing e-mail message.

Exports the displayed view of the selected records in HTML 
format and creates HTML pages. See also Output to HTML.

Adds a question mark to the mouse pointer. The next object you 
click will be the topic of the help presented. 

Opens context sensitive help. 

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface
Understanding the Collection Window

Cumulus tracks assets in a special file called a catalog. When you open a catalog, the Collection window appears, and you see a 
Collection.

The Collection window consists of two sections or panes:

· the Category pane 

· the Record pane 

Cumulus offers fully customizable viewing options. For more information, see Setting Viewing Options.

As you catalog assets, Cumulus creates catalog entries called records. Each record stores searchable information about the 
cataloged asset, such as the file name, the file location, file type, and so on. The information stored for an asset depends on the 
settings in the Catalog Properties. To make retrieving records easier, you can group records into logical groups called categories. 
The left side of the Collection window is called the Category pane and displays the categories in the current catalog. 

Press SHIFT+TAB to switch between the two panes. You can resize each pane by dragging the split bar in the middle of the 
Collection window. To resize the entire window, select the window borders or use the minimize, maximize, and restore buttons in the 
title bar.

To view an example, see Collection Window Example. 

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
Collection Window, Example

For a description of the Collection window, see Understanding the Collection Window. 



 The Cumulus User Interface 
Using the Status Bar

The status bar appears at the bottom of the Cumulus application window.

To turn the status bar on or off, check or uncheck Status bar in the View menu.
The far left side of the status bar displays toolbar button descriptions. To view these descriptions, position the cursor over a toolbar 
button. 
The Search Compass icon tells you which search preferences are currently enabled. For further information, see Using the Search 
Compass Icon. 

The Category Status field displays the number of current categories appearing in the Category pane as well as the total number of 
categories in the current catalog. 
For example, "11 of 43 categories (1 selected)" means that:

· 11 categories currently appear in the Category pane

· 48 total categories are available in the current catalog

· 1 category is currently selected

The Record Status field displays the number of found and total records in the current catalog. After a search, this field tells you how 
many records match the query you entered. 
For example, "29 of 140 (1 selected)" means that:

· 29 records match the current search conditions

· 140 total records are available in the current catalog

· 1 record is currently selected

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
 The Collection Window 

Using the Record Pane

The Record pane appears on the right side of the Collection window and displays records in the current catalog. By default, records 
appear within the Record pane as graphical thumbnails. You can modify or customize the way records appear using the options in 
the View menu. 

Each record stores information about the original asset. By default, a record name appears directly beneath the thumbnail. The 
record name can consist of up to 63 characters. For more information on assigning record names, see Editing Record Names.

In Details view, the Record pane lists the record as well as the contents of all record fields selected in the View Customization 
window. You can resize the width of each column by dragging the split bars located between the column headers.

Cumulus displays record information in a special window called the Asset Information window. To learn more about an asset and the 
associated record, highlight the thumbnail or text entry and select Asset => Information. The Asset Information window appears. 

To display the Record pop-up menu, move the cursor over a record thumbnail or text entry and single-click the right mouse button. 

In any catalog you can:

· sort by record detail 

· sort by ascending or descending order 

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
 The Collection Window 

Using the Category Pane

The left side of the Collection window is called the Category pane. The Category pane displays the categories in the current catalog. 
Many Cumulus users create catalogs containing thousands of categories, each of which has numerous levels.

When you catalog an asset, Cumulus creates a record that stores information on the original digital asset. To organize records, you 
can place them into categories. For information on creating categories, see Creating Categories .

Categories are like keywords. Unlike media management systems that rely solely on keywords to organize assets, categories offer 
the following advantages:

· Like keywords, you can assign categories unique names that describe assets.

· You can drag and drop to assign records (which represent assets) to one or multiple categories.

· Categories are fully searchable, making the retrieval of assets easy.

· Unlike keywords, categories can create hierarchies. You can tailor each Cumulus catalog to be as simple or complex as the 
information you’re managing.

To display records in a selected category, double-click the category or select the category and press ENTER. 

You can expand or collapse categories by clicking the plus (+) and minus (-) buttons to the left of each category folder. To expand a 
category, click the plus (+) button to the left of the category name. As the Category expands, the plus (+) button becomes a minus (-) 
button. 

Moving the cursor over a category and clicking the right mouse button displays the Category pop-up menu, which features shortcuts 
to commonly used Category menu options. 

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
 The Collection Window 

Viewing the Category Pane and/or Record Pane

To view a list of all categories in the current window: 

1. Select View => Show Category List. The Category pane is only displayed when this item is checked.

To view a list of all records in the current window:

1. Select View => Show Record List. The Record pane is only displayed when this item is checked.

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
Cumulus File Menu 

The Cumulus File menu offers the following options:

Menu Option Description

New Catalog (only 
Single User Edition)

Creates a new catalog. A dialog box is displayed for you to name the 
new catalog. For more information, see Creating a Catalog. If you are 
the Cumulus Administrator for the Workgroup Edition, see Creating a 
Catalog for Workgroups 

Open Catalog (only 
Single User Edition)

Opens an existing catalog via a standard open-file dialog box.

Connect to Server This menu option opens a dialog box from which you can connect to a 
catalog on a remote Cumulus Server (only with Cumulus Workgroup 
Edition). Cumulus Single User can be used as a Client to a Cumulus 
Workgroup installation. 

Close Closes the active catalog. Saves any changes that are not yet saved.

Import Opens a submenu with several import options. Each opens a dialog 
box from which you can select an appropriate file type for import. 

Export Opens a submenu with several export options. Each opens a dialog 
box from which you can name an appropriate file type for export. All 
exported files can be used on any supported Cumulus platform. 

Print Setup Opens a standard page setup window from which you can configure 
your printing options. The options available to you will depend on your 
system configuration. See your computer’s operating system manual 
for details.

Print Preview Opens a submenu with various options for previewing a printout.

Print Opens a submenu with various print options.

If you want to print the actual asset, instead of its record or preview, 
see Print With for details.

Output to HTML Exports the current display of selected or all records in HTML format 
and creates HTML pages.

Exit Exits the Cumulus application and saves changes to open catalogs.



 The Cumulus User Interface 
Cumulus Edit Menu 

The Cumulus Edit menu offers the following options: 

Menu Option Description

Undo Reverts operations in fields, but cannot undo other operations.

Cut Removes the current item or text selection and places it on the 
Clipboard so that it can be pasted elsewhere.

Copy Copies the current item or text selection and places it on the 
Clipboard so that it can be pasted elsewhere.

Paste Places the contents of the Clipboard into the current location or 
text insertion point.

Delete Deletes the selected records or categories from the catalog. A 
confirmation dialog with two options appears: delete only the 
record or delete both the record and its associated asset. This 
action cannot be undone. Make sure that you no longer need an 
asset or that you have a copy elsewhere before deleting it. 
(Disabled if no records or categories are selected.)

Select All Selects all objects or text. The type of selection depends on which 
window is active and whether you have clicked inside a text area.

Deselect All Cancels any previous selection.

Rotate Thumbnail Rotates the thumbnail of the selected record(s) in one of three 
ways:

- 90° clockwise
- 90° counter-clockwise
- 180° 

Optimize Thumbnail Optimizes a thumbnail’s appearance.

Preferences Opens the Application Preferences window, from which you can 
set global application behaviors.

 The Cumulus User Interface 
Cumulus View Menu 

The Cumulus View menu offers the following options: 

Menu Option Description

Palette Mode Changes the view of the Cumulus application to the Palette Mode 
and back.

Toolbar Toggles the toolbar on and off.

Status Bar Toggles the status bar on and off.

Show Category List Toggles the Category pane on and off.

Show Record List Toggles the Record pane on and off.

Large Thumbnails Displays records as large thumbnailsThumbnail (default 192 x 
192 pixel) and the contents of record fields as defined in the View 
Customization window. You can change the default size for 
thumbnails in the Application Preferences.

Medium Thumbnails Displays records as medium thumbnails (default 128 x 128 pixel) 
and the contents of record fields as defined in the View 
Customization window. You can change the default size for 
thumbnails in the Application Preferences.

Small Thumbnails Displays records as small thumbnails (default 96 x 96 pixel) and 
the contents of record fields as defined in the View Customization 
window. You can change the default size for thumbnails in the 
Application Preferences.

Details Displays records in a sorted text list as defined in the View 
Customization window.



Customize Displays the View Customization window for customizing the 
Thumbnail View or the Details View.

Sort By This is the menu equivalent to the sort buttons at the top of each 
column in the Details View. It displays a list of the available fields. 
Select the field you want to determine the sorting.

Sort Direction Provides two submenus used to change the direction of the sort 
order:

Sort Ascending - Sorts the records in an A to Z (0-9) 
direction.

Sort Descending - Sorts the records in a Z to A (9-0) 
direction.

Zoom In Doubles the size of a preview image. Preview images can be 
increased to eight times or 800% of their original size. (Disabled if 
no preview window is activated.)

Zoom Out Halves the size of a preview image. Preview images can be 
reduced to one eighth or 12.5% of their original size. (Disabled if 
no preview window is activated.)

Fit to Window Resizes the preview image to fit inside the main Cumulus window.

Reset Preview Resets the preview image to its original size and orientation.

 The Cumulus User Interface 
Cumulus Catalog Menu 

The Cumulus Catalog menu offers the following options: 

Menu Option Description

Cataloging Options Opens the Cataloging Options window, from which you determine 
the options that Cumulus uses when cataloging assets. Before 
you catalog any assets, make sure the cataloging options are set 
the way you want them.

Catalog Assets Opens a dialog box from which you can select assets to catalog. 
You also have the option of using Cumulus’ drag-and-drop 
support to catalog large numbers of assets at once.

A progress dialog is displayed while Cumulus is cataloging the 
assets.

Update Record Refreshes the thumbnail and updates any static information that 
appears in the Asset Information window.

Update Asset Reference Updates the reference to the asset location. If Cumulus cannot 
find the asset, a dialog box appears so you can specify a new 
location.

Properties Opens a window from which you can set options for the active 
catalog.

Activity Monitor Only Workgroup Edition: Displays information on the opened 
catalog.

Backup Opens a dialog from which you can save a backup copy of the 
active catalog.

Convert To Only Workgroup Edition: Opens a dialog box from which you can 
convert the catalog to adapt to another database engine.

Set As Default Opens a dialog from which you set the catalog properties of the 
current catalog to be used for creating new catalogs.

Restore Factory Defaults Opens a dialog from which you can reset the defaults defined by 
Canto for creating new catalogs. These defaults are the "out of 
the box" settings for the Catalog Properties. (Disabled unless 
another default has been set.)

New Empty Copy Opens a dialog from which you can create a new empty catalog 
with the catalog properties of the current catalog.

Compress Opens a dialog from which you can compress the active catalog. 
(Disabled if the catalog is already compressed as much as 



possible.)

Rebuild Opens a dialog from which you can repair (rebuild) the active 
catalog.

Recover Deleted Records Opens a dialog from which you can attempt to recover deleted 
records.



 The Cumulus User Interface 
Cumulus Category Menu 

The Cumulus Category menu offers the following options. 

Menu Option Description

Information Displays the Category Information window.

New Root Category Creates a new root category.

New Subcategory Creates a new subcategory under the selected category.

New Related Category Creates a new related category to the selected category.

Show Original Category When a related category is selected, this option displays the 
original category.

Show Related Categories If the selected category has related categories, selecting this 
option displays them.

Show Categories 
Containing

Enables you to quickly locate a category.

Find Matching Records Displays all records associated with the selected category. 

Save Matching Assets As Saves copies of all assets in the selected category(s) to a new 
specified location.

Expand If applicable, expands the hierarchical structure of the selected 
category.

Expand All Expands the hierarchical structure of all categories.

Collapse If applicable, collapses the hierarchical structure of the currently 
selected category.

Collapse All Collapses the hierarchical structure of all categories.

{button ,AL(`interface',0,`',`')}    See also 



 The Cumulus User Interface 
Cumulus Collection Menu 

The Cumulus Collection menu offers the following options:

Menu Option Description

New Opens a submenu with two options for creating a new collection. 
The new collection can either be empty or contain the currently 
selected records.

Open Opens an existing collection via the standard open-file dialog box. 
The file extension for a collection is: .cfe

Save Saves the collection as it is currently displayed.

Save As Saves the collection as it is currently displayed under a new 
name. A dialog box appears for you to name the new collection.

Mail To Attaches the collection to an outgoing e-mail message. 

Note: Catalog access necessary
Since a collection is always connected to its catalog, the 
recipient has to have access to the catalog '‘serving'’ the 
collection.

Find Records Opens or activates the Find window.

Find Records In All 
Collections

Using the query in the Find window, Cumulus searches through 
all open collections. (Disabled unless the Find window is open.)

Note: All open collections will be replaced by the search 
result. Using Find Records In All Collections overrides the 
option to show found records in a new collection. 

Find All Records Resets the current selection of records to the entire contents of 
the catalog. This is useful after a search operation has reduced 
the number of visible records.

Remove Record from 
Collection

Removes the record from the current collection but not from the 
catalog. (Compare Removing Records from a Catalog.)

Slide Show Opens a dialog from which you can create a slide show and select 
options for it. The slide show will present selected assets’ 
previews as slides.

The following options are only available when the Find window is open:

Insert Condition Before Inserts a new search condition before the current condition. You 
make a condition current by clicking inside any of its fields. 

This is the menu equivalent to clicking the  button in the Find 
window.

Insert Condition After Inserts a new search condition after the current condition. You 
make a condition current by clicking inside any of its fields. 

This is the menu equivalent to clicking the  button in the Find 
window.

Duplicate Condition Duplicates the current condition in the Find window. This is useful 
if you want to add a new condition that is similar to an existing 
condition. The new condition is added below the current condition. 
You make a condition current by clicking inside any of its fields.

Delete Condition Deletes the current condition and makes the condition before the 
deleted condition current. This action cannot be undone. You 
make a condition current by clicking inside any of its fields. 

This is the menu equivalent to clicking the  button in the Find 
window.

Delete All Conditions Deletes all search conditions in the Find window. This action 
cannot be undone





 The Cumulus User Interface 
Cumulus Asset Menu 

The Cumulus Asset menu offers the following options: 

Menu Option Description

Information Displays the Asset Information window that provides access to 
the information on the asset stored in the record. 

IPTC Information Displays the IPTC Information window that provides special 
access to the IPTC information on the asset stored in the record.

Preview Displays the preview of an asset. 

Show Location Lets you manually locate assets in Windows Explorer. 

Open with Opens the selected records’ assets with either the application that 
created the assets (if it’s known and available), or another 
application of your choice.

Print with Prints the selected records’ assets with either the application that 
created the assets (if it’s known and available), or another 
application of your choice.

Copy To Copies assets to the specified location. 

Move To Moves an asset to a new location. This copies the asset and 
deletes the file from the original location.

Mail To Routes an asset via e-mail by attaching it to an e-mail message. 

Convert To Opens a dialog for converting the asset associated with the 
selected record to another file format. The target formats depend 
on the availability of Cumulus Converter modules. The Cumulus 
Standard Conversion module converts to JPEG and resamples 
the image to 72 dpi. 

Check Out Checks out the asset associated with the highlighted record to 
your workstation. Only available when Cumulus Vault is installed 
with Cumulus Workgroup.

Undo Check Out Cancels a previous check-out. The asset is returned to the Vault 
but not as a new version. Only available when Cumulus Vault is 
installed with Cumulus Workgroup.

Check In Checks a previously checked-out asset back into the Vault as a 
new version. Only available when Cumulus Vault is installed with 
Cumulus Workgroup.

Show History Opens the Version History window, from which you can view 
version information on the asset associated with the selected 
record. Only available when Cumulus Vault is installed with 
Cumulus Workgroup.
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Cumulus Special Menu 

This menu contains special functions. For further information, see Automating Cumulus.
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Cumulus Window Menu 

You can use commands on the Window menu to arrange the open windows in Cumulus:

Menu Option Description

Cascade Overlaps multiple opened windows.

Tile Arranges multiple opened windows next to or above each other.

Arrange Icons Arranges the minimized window icons along the bottom of the 
main Cumulus window so that each can be seen.

Move Split Grabs the categories/records dividing line for the active catalog 
window so that you adjust the width of the panes. You can also 
select this line manually by positioning the mouse pointer over it, 
then clicking and dragging.

 The Cumulus User Interface 
Cumulus Help Menu 

The Cumulus Help menu offers the following options:

Menu Option Description

Contents and Index Opens the table of contents and searchable index window for 
Cumulus’ online help system.

Help On Opens context-sensitive help. This type of help presents 
information on the selected item in the program. For example, if a 
record is selected, the help system provides information on using 
the Record pane. You can also press F1 on your keyboard to 
reach the same information. F1 offers the additional benefit of 
being able to get help on a selected menu item.

What’s This? This option adds a question mark to the mouse pointer. The next 
object you click will be the topic of the help presented. This also 
works with menus.

About Cumulus Displays a dialog box that shows the version of Cumulus you’re 
using. It also provides a button that launches your default Web 
browser and initiates a connection to the Canto Web site. This 
requires an Internet connection. (See the Microsoft Windows 
documentation for information on setting your default Web 
browser.)

License Displays a dialog box from which you can view the user’s 
identification information and register your version of Cumulus. 
You can choose to register via the Web or use the registration 
form.



 Cumulus Menus
Pop-Up Menus

Cumulus offers the following pop-up (context) menus to give you shortcuts to commonly used commands:

Record pop-up menu

Category pop-up menu

Preview pop-up menu

Text Area pop-up menu
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 Cumulus Pop-Up Menus 

Record Pop-Up Menu

To display the Record pop-up menu:

1. Move the cursor over a record thumbnail or text entry and click the right mouse button.

The Record pop-up menu appears.

2. To select a specific menu option, click it.

The Record pop-up menu offers a shortcut to commonly used Asset menu options:

Menu Option Description

Information Displays the Asset Information window that provides access to 
the information on the asset stored in the record. 

IPTC Information Displays the IPTC Information window that provides special 
access to the IPTC information on the asset stored in the record.

Preview Displays the preview of an asset. 

Cut Cuts the selection and copies it to the Clipboard.

Copy Copies the selection to the Clipboard.

Paste Pastes the contents of the Clipboard to a new location (e.g., 
another catalog).

Update Refreshes the thumbnail and updates any static information that 
appears in the Asset Information window. 

Update Asset Reference Updates the reference to the asset location. If Cumulus cannot 
find the asset, a dialog box appears so you can specify a new 
location.

Rotate Thumbnail Rotates the selected thumbnail 90 degrees clockwise, 90 degrees 
counterclockwise, or 180 degrees. 

OptimizeThumbnail Optimizes a thumbnail’s appearance.

Show Location Lets you manually locate assets in Windows Explorer. 

Open with Launches the program associated with an asset so you can view 
or edit it.

Print with Launches the program associated with an asset so you can print 
it.

Copy To Copies assets to the specified location. 

Move To Moves an asset to a new location. This copies the asset and 
deletes the file from the original location.

Mail To Routes an asset via e-mail by attaching it to an e-mail message. 

{button ,AL(`records',0,`',`')}    See also 
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 Cumulus Pop-Up Menus 

Category Pop-Up Menu

To display the Category pop-up menu: 

1. Select the category.

2. Click the right mouse button. 

If you right-click on the background of the Categories pane, you’ll see a menu with only four options: New Root Category, Show 
Categories Containing, Expand All, and Collapse All

The Category pop-up menu offer the following options. 

Menu Option Description

Information Displays the Category Information window.

New Root Category Creates a new root category.

New Subcategory Creates a new subcategory under the selected category.

New Related Category Creates a new related category to the selected category.

Show Original Category When a related category is selected, this option displays the 
original category.

Show Related Categories If the selected category has related categories, selecting this 
option displays them.

Show Categories 
Containing

Enables you to quickly locate a category.

Find Matching Records Displays all records associated with the selected category. 

Save Matching Assets As Saves copies of all assets in the selected category(s) to a new 
specified location.

Expand If applicable, expands the hierarchical structure of the selected 
category.

Expand All Expands the hierarchical structure of all categories.

Collapse If applicable, collapses the hierarchical structure of the currently 
selected category.

Collapse All Collapses the hierarchical structure of all categories.

{button ,AL(`catalog',0,`',`')}    See also 



 The Cumulus User Interface 
 Cumulus Pop-Up Menus 

Preview Pop-Up Menu

To display the Preview pop-up menu:

1. Open the preview of an asset and click the right mouse button.

The Preview pop-up menu appears.

2. Select a specific menu option and click it.

The Preview pop-up menu offers a shortcut to commonly used menu commands:

Command Description

Print Preview Opens the Print dialog box, from which you can print the preview 
image (not the actual asset) on the currently selected printer.

Copy Copies the selected portion of the preview image to the Windows 
Clipboard for pasting elsewhere. (Click and drag in the preview 
image to draw a box around the area you wish to copy.)

Select All Selects the entire preview image. 

Zoom In Zooms in on the preview image, thereby increasing its visible size.

Zoom Out Zooms out from the preview image, thereby reducing its visible 
size.

Fit to Window Resizes the preview image to fit inside the main Cumulus window.

Reset Preview Resets the preview image to its original size and orientation.

Rotate Preview Rotates the preview in one of three ways:

- 90° clockwise
- 90° counter-clockwise
- 180° 

{button ,AL(`manage',0,`',`')}    See also 
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Text Area Pop-Up Menu

To display the Text Area pop-up menu: 

1. Click inside the text field you would like to edit.

2. Click the right mouse button. 

The Text Area pop-up menu offers the following commands:

Command Description

Undo Reverts operations in fields, but cannot undo other operations.

Cut Removes the current item or text selection and places it on the 
Clipboard so that it can be pasted elsewhere.

Copy Copies the current item or text selection and places it on the 
Clipboard so that it can be pasted elsewhere.

Paste Places the contents of the Clipboard into the current location or 
text insertion point.

Delete Deletes the current text selection.

Select All Selects the complete contents of a field.

 Information
Online Help

No special text available. 

Please click another item and press F1 again.

For information on the Preview Window for Print Output, click here. 
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Creating a Catalog (Single User Edition Only)

To create a catalog:

1. Select File => New Catalog.

The New Catalog dialog box appears.

2. Type a file name for the catalog and click Save.

The new catalog opens and an empty Collection window appears.

You can also:

· Configure the Catalog 

· Customize Application Preferences 

· Set Cataloging Options 

· Customize the View

You may want to create multiple catalogs if you encounter any of the following conditions:

· Assets fall into logically unrelated groups. 

· The catalog file size becomes too large. Cumulus catalogs are limited to 4 GB. The number of records this permits depends 
upon the thumbnail quality/size settings and the amount of text in each record (e.g., in the Notes field).

NOTE: With Cumulus 5 Workgroup and Enterprise Editions, only the Cumulus Administrator can create catalogs. For further 
information, see Creating Catalogs for Workgroups.

{button ,AL(`basics',0,`',`')}    See also 
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Opening a Catalog

After you have started the Cumulus Single User application, you can open an existing catalog. 

To open a catalog as Single User:

1. Select File => Open Catalog.

The Open Catalog dialog box appears.

2. Select a catalog from the list and click Open.

The catalog opens and the Collection window appears.

Note: To open another catalog during a Cumulus session, select File => Open Catalog and then select the catalog name. 

To close an open catalog, select File => Close.

If you are set up as a Cumulus client, you can log onto the server and open network catalogs in addition to the local catalogs on 
your own machine. Select File => Connect to Server to open a network catalog.

To open a catalog as Client:

1. Launch Cumulus Client.

The Connect to Server dialog box appears. 

2. Fill in the required information and click OK.

The Choose Catalog dialog box appears.

3. Select a catalog from the list and click OK.

The catalog opens and the Collection window appears.

{button ,AL(`basics',0,`',`')}    See also 
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Cataloging Progress

This dialog is displayed while Cumulus is cataloging assets.

{button ,AL(`catalog',0,`',`')}    See also 
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Closing a Catalog or Collection

To close an open catalog or collection, select File => Close.
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Cataloging Overview

Cataloging is the process of integrating an asset into a catalog by creating records and optionally assigning them to categories.

Adding an asset to a catalog creates a catalog entry (or record) that stores information on the original digital media asset (e.g., file 
name, file location, file type, resolution, etc.).

Categories enable you to organize records into logical, easy-to-use hierarchical groups. When you catalog an asset, Cumulus by 
default creates new categories that map the path (or location) to the media file (for further information on these categories, see 
About Automatically Created Categories). 

When it catalogs assets, Cumulus matches file names and paths with the appropriate operating system (Macintosh or Windows). If 
you store your assets in a location other than your own computer, make sure to follow normal cross-platform file naming rules. 

If you catalog assets from a location where you are allowed to save files, Cumulus creates a TAG file for each cataloged asset. If 
you    want Cumulus to create these TAG files while cataloging, enable the Cumulus Metadata Support asset storage module in the 
Cataloging Options, Assets tab, and set its properties to Always.

Before cataloging, review the Cataloging Rules and be aware that Cataloging Options directly impact the cataloging process. 

There are two ways to catalog records:

Drag and drop media files from Windows Explorer or Desktop to the Cumulus window 

Use the Catalog Assets command 

Once you’ve chosen the cataloging method that best fits your needs, you can automate the process with Visual Basic or any other 
OLE-compliant programming tool. 

{button ,AL(`catalog',0,`',`')}    See also 
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Cataloging Rules

The following rules make implementing Cumulus easier. 

· Create a Cumulus implementation plan.

Determine how to implement Cumulus. 

· Create a logical asset naming system.

Implementing an effective asset naming convention will save you time. An asset’s file name should tell you what the asset is. If 
your needs are complex, create a "cheat sheet." 

· Organize assets into logical folders.

When grouping assets into directories, consider future projects and archival requirements. You can group assets by project or 
by type (e.g., video, audio, graphics, and layout files) and then separate them by format. For example, you could have a folder 
called Video that contains subfolders called QuickTime, AVI, or MPEG. 

By organizing your assets before you catalog them, you can take advantage of Cumulus’ ability to simultaneously create 
categories and records in one easy step. For more information, see About Automatically Created Categories.

· Create a logical record naming system.

When you catalog a file, Cumulus automatically assigns the media file name as the record name. However, you can change 
the record name in the Asset Information window. 

If your organization assigns project numbers, you can include them in record names (e.g., Project 12345 ABC Corporation). 
You can also include information you might want to search for later (e.g., job numbers or archive locations).

Avoid haphazardly assigning record names. If you do, you’ll end up with a catalog that contains cryptic record names that only 
the cataloger understands.

· Create a systematic cataloging process.

A systematic cataloging process ensures that asset naming, directory organization and record naming stay consistent from one 
cataloging session to the next. 

{button ,AL(`catalog',0,`',`')}    See also 
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About Automatically Created Categories

When you catalog an asset, Cumulus by default creates new categories that map the path (or directory) to the asset. These 
directory categories display a small folder symbol within the category folder icon. 

If you already have an asset tracking system that utilizes nested folders broken down by project or file type, this feature allows you 
to catalog assets in one easy step.
If you do not want Cumulus to create location categories, you have to delete the corresponding link of the Categories record field in 
the catalog properties. 

To avoid automatically created directory categories:

1. Select Catalog => Properties. 

The Catalog Properties window opens. 

2. Select the Record Fields tab.

3. Select the field named Categories and click the Properties button. 

4. Click Link to the Following Fields. 

5. Select the module which should not create categories during the cataloging process.

6. Click Remove. 

7. Click OK. If you now catalog assets from this module, the location categories will not automatically be created.

{button ,AL(`catalog',0,`',`')}    See also 
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Cataloging Techniques

Most Cumulus users choose one of the following two general cataloging techniques:

· Organize assets first

You first organize assets into a logical folder structure and then determine where the files will be stored. You can drag and drop 
folders from Windows Explorer to the Cumulus window, automatically creating new categories that map the path to the original 
media file. 

· Create categories, then catalog

If your work environment doesn’t allow for the first method, you can use categories to organize your records. Create an 
effective, well-thought-out category structure, then catalog assets and assign records to the appropriate categories.

Two methods are available for cataloging your assets:

Drag and drop from Windows Explorer 

The Catalog Assets Command 

{button ,AL(`catalog',0,`',`')}    See also 



 Cumulus Basics

 Working with Catalogs
Cataloging Using Drag and Drop

With Cumulus you can quickly catalog assets by "dragging and dropping" files (or entire folders) from Windows Explorer or your 
Desktop into the Collection window. 

To catalog assets by dragging and dropping files:

1. Launch Cumulus and open a catalog.

2. Launch Windows Explorer.

3. Arrange the Cumulus application window and Windows Explorer so that you can see them both.

4. In Windows Explorer, select the file(s) and/or folder(s) to catalog. (Hold down CTRL to select more than one file/folder at a time. 
Hold down SHIFT to select a range of files/folders.)

5. Drag and drop your selections into the Record pane. If you’ve already created categories, drag and drop your selections into a 
specific category.

Once cataloging is complete, Cumulus displays:

· new records in the Record pane

· new categories that mirror the path (or location) to the original media file

Automatically created categories are indicated by the small folder symbol appearing within the category folder icon. By default, 
Cumulus assigns the asset’s file name as the record name. For information on customizing the asset information stored in records 
(e.g., the file format) see Customizing Asset Information.

{button ,AL(`catalog',0,`',`')}    See also 
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Cataloging Using the Catalog Assets Command

Compared to dragging and dropping files, this method has two limitations:

You can catalog only one file or folder at a time.

You cannot manually assign assets to existing categories.

By default, cataloging assets automatically creates new categories that mirror the path to the original digital media file. 

To create new records using the Catalog Assets command:

1. Launch Cumulus and open a catalog.

2. Select Catalog => Catalog Assets.

The Catalog Assets dialog box appears.

3. Catalog individual assets or entire folders:

· To catalog files one at a time, highlight each file and click Open.

· To catalog the entire folder, click Select Folder.

As Cumulus creates a new record, the original file name appears in the Cataloging status window. Once cataloging is 
complete, Cumulus displays:

· new records in the Record pane

· new categories mirroring the path (or location) to the original media file

By default, Cumulus assigns the asset’s file name as the record name. For information on customizing a record name, see 
Customizing Asset Information .

{button ,AL(`catalog',0,`',`')}    See also 
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Creating Categories and Subcategories

Cataloging involves the creation of both categories and records. Categories are the organizational "backbone" of your catalog. They 
provide an efficient organizational and classification system and a powerful record search and retrieval system.

Before you create categories, decide how you want to organize and group your records. For example, if you have a catalog called 
Animals, you can set up categories that describe common animal groups (e.g., birds, cats, dogs, rodents, etc.).

To create a new category:

1. From the Category menu or the Category pop-up menu, select New Root Category.

A new highlighted category (named Category) appears.

2. Type a new category name and press ENTER. Category names can be up to 255 characters long.

Cumulus assigns the new category name.

3. Repeat steps 1 and 2 until you create all the categories you need.

Since many catalogs contain thousands of records, you may want to create hierarchical levels (or subcategories). 

To create subcategories:

1.  From the Category menu or the Category pop-up menu, select New Subcategory

A new highlighted category (named Category) appears.

2. Type a new category name and press ENTER. Category names can be up to 255 characters long.

3. Repeat steps 1 and 2 until you create all the subcategories you need.

To move a category, select and drag it to the desired "parent" category.

To select a series of categories, hold down SHIFT and highlight the first and last category in the series.

{button ,AL(`category',0,`',`')}    See also 
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Assigning Records to Categories

Records are easy to assign to categories (or vice-versa) with dragging and dropping. It doesn’t matter which way you do it: dragging 
the record onto the category, or dragging the category onto the record. The effect is the same. You can assign records to any 
number of different categories.

To assign records to a category:

1. Select the record(s). (Hold down CTRL to select more than one record at a time. Hold down SHIFT to select a range of 
records.)

2. Drag and drop the selected records onto the category.

Cumulus assigns the records to the selected category.

{button ,AL(`category',0,`',`')}    See also 



 Cumulus Basics

 Working with Categories
Removing Category Assignments

The Asset Information window contains a list of categories currently assigned to the selected record. From this list you can remove 
category assignments or add new ones. 

To remove an assigment:

1. Select the record whose category assigments you want to change.

2. Select Asset => Information. 

The Asset Information window opens.

3. Select the category you wish to remove and press the Delete key.

4. Select Asset => Save to save your changes.

If you want to edit more records in the collection, you can use the arrow buttons to load a new record.

{button ,AL(`category',0,`',`')}    See also 
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Editing Category Names

To edit a category name, highlight the existing name and type a new one. You can also edit category names using the options found 
in the Edit menu (i.e., Undo, Cut, Copy, Paste, Delete, and Select All) or the Category pop-up menu.

{button ,AL(`category',0,`',`')}    See also 
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Creating Related Categories

You can create virtual cross-references called related categories. Related categories display an arrow symbol within their folder 
icons.

Related categories allow you to form relationships between categories. For example, suppose you have two categories called 
Insects and Food. The category Food contains the subcategory Honey. The category Insects contains the subcategory Bees. By 
creating related categories, you can create a virtual cross-reference between Bees and Honey.

Food Insects

Honey Bees

Related Category - Bees Related Category - Honey

Now a search for the category Honey would find records in both Honey and Bees. You can configure Cumulus to search for related 
categories.

To create a related category:

1. In the Category pane, select the category for which you wish to make a related category.

2. From the Category menu or the Category pop-up menu, select New Related Category.

A related category appears.

1. Drag and drop the related category onto the category for which you wish to create a virtual cross-reference.

{button ,AL(`category',0,`',`')}    See also 
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Deleting Categories

You can delete categories that no longer have any meaning to your catalog structure. To find out if a category still contains records, 
double-click it. 

To delete a category:

1. Select the category to delete by clicking the folder to the left of the category name.

2. Select Edit => Delete.

A dialog box prompts you to confirm your request. 

3. Click OK.

If you deleted automatically created location categories, you can still locate assets in one of three ways:

· display the Asset Information window and select the Asset tab to find the location

· select the record and then Asset => Show Location

· search for the folder name using the find window

{button ,AL(`category',0,`',`')}    See also 
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Show Categories Containing

Cumulus gives you a fast way to search for all categories whose names contain a particular text string.

To show categories containing a text string:

1. Select Category => Show Categories Containing.

The Show Categories Containing dialog box appears.

2. Type a text string to search for in all category names of the active catalog and click OK.

Categories whose names contain the text string are highlighted in the Category pane. Related categories are also included.

{button ,AL(`category',0,`',`')}    See also 
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Collections

A collection is Cumulus-speak for a set of records from any one catalog. It is a way of looking at your catalog - the way that you are 
looking at it at any given time. Whenever you work with assets in the record and category panes - which make up the Collection 
window - you’re creating or modifying collections. When you view the records in any category, you’re looking at a collection. When 
you view the results of a search, you’re also looking at a collection. The same is true for individual records you’ve dragged and 
dropped into the window - any ‘snapshot’ of your catalog can comprise a collection. A collection acts as your temporary workspace 
in Cumulus, and you can also save it as a file.

While a collection can contain all records in a catalog or all in a single category, it is neither one nor the other. A collection can also 
contain - and here is where its advantages become obvious - the results of a search (either as a new collection or replacement of 
the current collection), or any records you drag and drop into the Collection window. Any individual subset of a catalog comprises a 
collection. 

Once saved, a Cumulus Collection File (.cfe) remembers far more than just the records it contains. A collection file also keeps track 
of viewing options, such as the Collection window’s background color, which categories were expanded, which record fields were 
visible, and how these fields were displayed.

A collection, whether saved or unsaved, is always connected to its catalog. When a collection is open, its catalog is also open. In 
order to open a particular collection, you must have access to its catalog. If a record is removed from a catalog, it is removed from 
any of that catalog’s collections it was in. Similarly, if you delete a category, it is deleted not only from one collection, but also from 
the catalog.

You can, however, delete a record from the collection without deleting it from the catalog - by simply highlighting it and pressing the 
DEL key. You also have the option of deleting a record from both collection and catalog.

You can 

· Save a collection 

· Open a collection 

· Build a new collection from a search result

· Send a collection via e-mail

· Customize the view

· Create an HTML output of a collection

{button ,AL(`basics',0,`',`')}    See also
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Removing Records from a Catalog

When you delete a record, you can specify whether or not to delete its original asset as well. 

To remove a record from a catalog:

1. In the Record pane, find and select the record to remove.

2. Select Edit => Delete.
OR
Press CTRL DELETE.

The Delete Records dialog box appears.

3. Click the button with the desired option.

To remove a record from a collection while keeping it in the catalog, see Removing Records from a Collection.

{button ,AL(`records',0,`',`')}    See also 
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Removing Records from a Collection

If you only remove a record from a collection, it remains in the catalog. To remove a record and optionally its asset from a catalog, 
see Removing Records from a Catalog. 

To remove a record from a collection:

1. In the Record pane, find and select the record to remove.

2. Press DELETE.

The selected record is deleted from the collection but not from the catalog. 

{button ,AL(`records',0,`',`')}    See also 
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Updating Records

If you modify an asset after cataloging, it’s a good idea to update its record. Updating a record refreshes the thumbnail and updates 
any static information that appears in the Asset Information window. Customizable record information (e.g., Record Name and 
Notes) is not affected by updating. You must have access to the original asset files to update catalog records. It is usually best to 
have an automated update procedure.

To update a record:

1. In the Record pane, select the records to update.

2. From the Catalog menu or the Record pop-up menu, select Update Record.

3. From the submenu, select either If Asset Has Changed or Always.

· If Asset Has Changed updates record information only if the current asset has changed since cataloging.

· Always creates a new thumbnail and updates record information regardless of when the asset was last changed. This is 
useful if you have modified an asset or updated the general Cataloging Options.

{button ,AL(`records',0,`',`')}    See also 
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Checking Asset References

If you move an asset after cataloging, check the reference Cumulus uses to locate the file. Keeping this file reference up-to-date is 
crucial. 

When you check a file reference, Cumulus verifies that the asset is still located in the same place it was when it was cataloged. If 
Cumulus cannot find it, a dialog box appears so you can specify a new location. You must have access to the original media files to 
check file references. 

To check an asset’s file references:

1. In the Record pane, select the records to check.

2. From the Catalog menu or the Record pop-up menu, select Update Asset References.

Cumulus checks (or resolves) all file references and updates the record. 

If the original file cannot be found, a dialog box appears. The name of the media file in question appears in the File name field.

3. To re-establish a link to a media file, locate and highlight the file and click Open.

OR

3. To ignore a specific media file, click Skip File.

{button ,AL(`records',0,`',`')}    See also 



 Cumulus Basics

 Working with Records
Optimizing Thumbnails

If a thumbnail appears too dark, too bright, or too low in contrast, you can correct its appearance by selecting Optimize Thumbnail 
from the Record pop-up menu menu. You can automatically optimize thumbnails while cataloging. 

{button ,AL(`records',0,`',`')}    See also 
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Record Viewing Options

To... ... in the View 
menu, click

... click the 
toolbar button

display records as large thumbnails 
(default 256 x 256 pixel)

Large Thumbnails

display records as medium thumbnails 
(default 128 x 128 pixel)

Medium 
Thumbnails

display records as small thumbnails 
(default 64 x 64 pixel)

Small Thumbnails

view records as detailed text Details

customize view settings Customize

For modifying the thumbnail size with toolbar buttons, see Using the Toolbar.

You can change the default size for large, medium and small thumbnails in the Application Preferences window.

{button ,AL(`records',0,`',`')}    See also 
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Record Sorting Options

Records contain a great deal of information (or details) about an asset. The options in the View menu enable you to sort by nearly 
every record field.

To sort by record field:

1. Select View => Sort By. 

2. From the submenu, select the desired record field (e.g., record name, file format, color mode, or modification date).

The new sort order appears.

You can also sort records with toolbar buttons.

Once you have sorted by record field, you can select to display the records in either ascending or descending order. 

To sort by direction:

1. Select View => Sort Direction. 

2. From the submenu, select Sort Ascending (A to Z, 0-9) or Sort Descending (Z to A, 9-0)

The new sort order appears.

{button ,AL(`records',0,`',`')}    See also 
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Viewing Information Stored in a Record

Adding an asset to a catalog creates a catalog entry called a record. Records store searchable information about an asset, such as 
its file name, file location, file type, resolution, etc. Cumulus displays the information stored in a record in the Asset Information 
window. 

NOTE: To have Cumulus automatically display the Asset Information window after cataloging, check Open Information Window 
Automatically on the General Tab of the Cataloging Options window. 

To view or change asset information:

1. Select a record.

2. Select Asset => Information.

The Asset Information window appears.

3. Make your selections and changes.

4. To save the changed information: Select Asset => Save. 

To view other records without closing the dialog box, click the browse buttons. For more information, see Understanding the Asset 
Information Window. 

How to view an asset's IPTC information, see Understanding the IPTC Information Window.

 

{button ,AL(`information',0,`',`')}    See also 
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 Searching 
Searching Overview

In Cumulus, there are three ways to search for records:

· search for records that match a specific category 

· use the find window to build search queries that consist of one or more search conditions. You can save queries you create. 
There are two types of searches:

simple searches and compound searches 

· browse the Collection window

You can switch between methods as needed. 

{button ,AL(`search',0,`',`')}    See also 
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The Find Window

The Cumulus find window lets you build search queries consisting of one or multiple search conditions. 

To open the find window:

1. Select Collection => Find Records. 

For further information, see Using the Find Window. 

{button ,AL(`search',0,`',`')}    See also 
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Using the Find Window

The Cumulus find window lets you build search queries consisting of one or multiple search conditions. 

The find window consists of the following basic components for building a search query:

the condition buttons and the search condition fields

the search method and whether the search results should replace the current collection or comprise a new collection

The condition buttons on the right side of the find window determine the number of search conditions. If your query has more than 
one condition, the condition buttons appear next to the current condition. 

Condition Button Menu Option Description

Insert Condition Before Adds a new condition above the current one.

Insert Condition After Adds a new condition below the current one.

Delete Condition Removes the current condition.

The three search condition fields (in the middle of the find window) let you build a search. 

Condition Field Description

Criteria Defines what you’re searching for (e.g., record 
name, file type, color mode, etc.).

Operator Defines how you want to search (e.g., contains, 
starts with, is, is not, etc.).

Value Enables you to further qualify your search by 
adding single or partial words, numbers, or 
dates.

The search method defines what will be searched. 

Search Method Description

Search in Entire Catalog Will search the whole catalog.

Narrow Current Collection Will only search the current collection.

Broaden Current Collection Will search the entire catalog and add found 
records to the current collection.

You also can decide whether the search results should replace the current collection or comprise a collection of their own: 

Show Found Records in Description

Current Collection Found records replace the current collection.

New Collection Found records build a new collection.

The search buttons on the right side of the find window execute the search.

Search Button Description

Find Performs the search.

Find All Displays all records of the current catalog – 
regardless of the other selections in the Find 
window (equivalent to the Find All Records 
command in the Collection menu).

There are two types of searches:

· simple searches 

· compound searches 



For examples of queries, see Search Query Examples. You can save queries you create.

{button ,AL(`search',0,`',`')}    See also 
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 Using the Find Window 

Running a Simple Search

Simple searches have only one search condition. To narrow down a simple search, select the Narrow Current Collection button 
under Search Method. For examples of queries, see
 Search Query Examples.

To build a simple search:

1. Select a criterion from the Search Criteria field (e.g., record name, file type, color mode, etc.).

2. Select a search operator from the Search Operator field (the way in which you wish to search). The search operators you can 
use depend on the field type of the search criterion.

3 In the Value field, enter single or partial words, numbers, or dates to further qualify your search. (Dragging a record onto the 
Value field is a quick way to enter relevant record information. To clear all search fields, click Delete. )

4. Select a Search Method.

5. Select where the found records should be displayed.

6. Click the Find button.

Cumulus displays all matching records in the Record pane. The Record Status field (on the right side of the status bar) 
summarizes how many records match the requested query. 
For example, "25 of 117 (1 selected)" means that:

· 25 records match the current search conditions

· 117 total records are available in the current catalog

· 1 record is currently selected

{button ,AL(`search',0,`',`')}    See also 
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 Using the Find Window 

Running a Compound Search

Compound searches have two or more search conditions. For examples of queries, see Search Query Examples.

To build a compound search:

1. Determine the number of search conditions to search for. 

· To add a search above the selected condition, click Insert Condition Above.

· To add a search below the selected condition, click Insert Condition Below.

· To delete a search condition, click in any of its condition fields and click Delete Condition.

2. For the first search condition:

· Select a criterion from the Search Criteria field (e.g., record name, file type, etc.).

· Select a search operator from the Search Operator field.

· In the Value field, enter additional information appropriate to further qualify your search.

3. From the Condition Operator field, select "and" or "or." 

· The "and" operator finds only records that match both search conditions. "And" searches are more restrictive.

· The "or" operator finds any records that match either search condition. "Or" searches are broader and typically result in a 
higher number of matching records.

4. For the next search condition:

· Select a criterion from the Search Criteria field (e.g., record name, file type, etc.).

· Select a search operator from the Search Operator field.

· In the Value field, enter single or partial words, numbers, or dates to further qualify your search.

5. Repeat steps 3 and 4 until all search conditions have been entered.

6. Select a Search Method.

7. Select where the found records should be displayed.

8. Click the Find button.

Cumulus displays all matching records. The Status field (right side of the status bar) summarizes how many records match the 
requested query. For example, "25 of 117
(1 selected)" means that:

· 25 records match the current search conditions

· 117 total records are available in the current catalog

· 1 record is currently selected

{button ,AL(`search',0,`',`')}    See also 



 Searching 
 Using the Find Window 

Search Query Examples

In a full-text search, Cumulus searches for full or partial words (not case sensitive), numbers or dates. The following examples show 
how to search for records using various types of record fields.

Search Criteria Field Type use one of these 
operators...

and this value...

Thumbnail Special Drag and drop a sample thumbnail 
onto the field to perform a similarity 
search, comparing brightness and 
contrast with a loose tolerance.

Categories Special Enter a Category name or drag a 
category or a record from the 
Collection window. 

If your category structure includes 
duplicate category names, drag and 
drop a category rather than typing its 
name. 

The Application Preferences Search 
Tab controls how Cumulus searches 
categories. 

Horizontal
Resolution

Real Enter a numeric value for resolution in 
dots per inch (dpi).

File Data Size Integer Enter numbers in bytes: 
type KB for kilobytes 
type MB for megabytes 

File Creation 
Date

Date Enter a date using the format specified 
by your operating system.

Color Mode String List Pick an entry from the list.

Cataloging User String
(Indexed for 
Sorting & 
Searching 
only)

Enter full or partial words to perform a 
full text search. 

Notes String
(Indexed for 
Contain 
Searching 
only)

Enter full or partial words to perform a 
full text search.

Record Name String
(Indexed for 
Sorting & 
Searching 
AND 
Contain 
Searching)

Enter full or partial words to perform a 
full text search.



{button ,AL(`search',0,`',`')}    See also 



 Searching 
Saving or Loading Search Queries

You can save any search query to disk and load it into the Find window. To save or load a search query, click: 

{button ,AL(`search',0,`',`')}    See also 



 Searching 
Understanding Category Search Preferences

You can select a number of search preferences in the Search tab of the Application Preferences dialog box. Under Category List 
Search Finds Records you can select one of two search techniques:

· Matching At Least One Selected Category finds records associated with at least one of the categories included in your 
search.

· Matching All Selected Categories finds records associated with all categories included in your search.

Under Category Search Also Finds Records of... you can determine the direction Cumulus searches categories (that is, 
Categories Above the Selected and/or Categories Below the Selected). 

The and Related Categories option enables you to search for related categories. 

{button ,AL(`search',0,`',`')}    See also 



 Searching 
Using the Search Compass Icon

The Search Compass icon in the center of the status bar displays information about current search preferences and is a shortcut to 
the Application Preferences dialog box, Search tab.

The icon tells you which search preferences are currently enabled. Click the icon to display the Application Preferences dialog box 
and, if necessary, edit the search preferences.

Enabled Search Preferences Icon

Matching At Least One Selected Category

Matching All Selected Categories

Category Search Also Finds Records of Categories 
Above the Selected

Category Search Also Finds Records of Categories 
Below the Selected

and Related Categories

{button ,AL(`search',0,`',`')}    See also 



 Searching 
Browsing the Collection Window

Browsing the Collection window is a simple, common-sense approach to finding records. If you’ve taken the time to design a well-
organized category structure, you can quickly locate records by expanding categories in the Category pane.

To view all records associated with a category, double-click it. To expand a category, click the plus (+) button to the left of the 
category name. When the Category expands, the plus (+) button becomes a minus (-) button.

To view the Category list: Select View => Show Category List.

{button ,AL(`search',0,`',`')}    See also 
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 Managing Assets 
Previewing Cataloged Assets

Once you’ve cataloged an asset, you can preview it without launching another application. You can set the application preferences 
to launch an Asset Preview window any time you double-click a thumbnail. For more information, see Customizing Application 
Preferences. In preview mode, you can copy and print images. 

To display a preview of a cataloged asset:

1. In the Record pane, select the record representing the asset to preview.

2. Select Asset => Preview. (For assets with proprietary formats, use the Open With command.)

An Asset Preview window appears. You can zoom, scale, and rotate the preview.

3. To close an open Asset Preview window, Select File => Close, or click the Close button in the upper right corner of the Asset 
Preview window.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
 Previewing Assets 

Zooming, Scaling, and Rotating Previews

You can change the Asset Preview window’s magnification and orientation or reset the view to the initial view. The current Zoom 
Factor appears on the right side of the status bar. The following functions are provided by the Preview pop-up menu (clicking the 
right mouse button):

To rotate an Asset Preview:

1. Select the Asset Preview window and make it the active window.

2. From the Edit menu or the Preview pop-up menu, select Rotate Preview. 

3. From the submenu, select the desired rotation angle (90 degrees counterclockwise, 90 degrees clockwise or 180 degrees). 

To zoom an Asset Preview:

1. Select the Asset Preview window and make it the active window.

2. From the View menu or the Preview pop-up menu, select Zoom In or Zoom Out. 

To reset the preview to its initial size:

1. Select the Asset Preview window and make it the active window.

2. From the View menu or the Preview pop-up menu, select Reset Preview. 

To fit the preview within the application window:

1. Select the Asset Preview window and make it the active window.

2. From the View menu or the Preview pop-up menu, select Fit to Window. 

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
 Previewing Assets 

Copying Preview Images

If an Asset Preview window contains an image file, you can copy and paste it into a new document. For best quality and easier 
version control in a layout document, you may prefer to copy the actual media file. See Copying Assets and Placing Assets into 
Documents.

To copy and paste a previewed image:

1. Select the Asset Preview window and make it the active window.

2. From the Edit menu or the Preview pop-up menu, click Select All and then Copy.

3. Paste the copied image into your document.

To copy part of a previewed image:

1. Select the Asset Preview window and make it the active window.

2. Select the portion of the image to copy.

A small dotted line shows your selection.

3. From the Edit menu or the Preview pop-up menu, click Copy.

4. Paste the copied image into your document.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
 Previewing Assets 

Printing Previewed Images

You can print the previewed image from within Cumulus.

To print a previewed image from within Cumulus:

1. Select the record of the asset whose preview you want to print.

2. Open the preview by selecting Asset => Preview.

3. Select File => Print.

4. From the submenu, select Preview. 

The Print dialog box appears.

5. Make the desired dialog box selections and click OK. 

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Locating Assets 

You can manually locate assets in Windows Explorer.

To locate assets in Windows Explorer:

1. Select one or more records in the Record pane. 

2. Select Asset => Show Location.

Cumulus launches Windows Explorer and locates the assets. If multiple assets are selected, multiple Explorer windows appear. 

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Placing Assets into Documents

You can drag and drop a record from the Catalog window into a document in another application, if that application supports OLE 
dragging and dropping.

To place assets by dragging and dropping:

1. Make sure the target application is running and the destination document is open.

2. Launch Cumulus and locate the records representing the assets to place.

3. Click and drag the records to the target document. (Hold down CTRL to select more than one record at a time. Hold down 
SHIFT to select a series of records.)

The asset appears in the target document.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Copying Assets 

Cumulus offers a number of different ways to quickly copy assets to new locations. From within Cumulus you can:

· Make copies of assets by dragging records or categories to the desktop.

When you drag categories to the desktop, Cumulus creates a folder matching the category name and copies all the associated 
records into it.

· Copy assets to a new location using Copy To in the Asset menu. 

· Distribute assets to co-workers by attaching them to e-mail messages . 

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
 Copying Assets 

Using Copy To

You can copy one or more cataloged assets from either the Record pane or the Asset Information window.

To copy assets:

1. Select one or more records in the Record pane.

2. From the Asset menu or the Record pop-up menu, select Copy To. (You can also select Copy To from the Asset menu in the 
Asset Information window.)

The Copy To dialog box appears.

3. In the Save in field, enter a destination and click Save. 

Cumulus copies all files to the specified locations.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
E-Mailing Assets 

Routing an asset via e-mail attaches it to an outgoing e-mail message. To route assets via e-mail, you need to have an e-mail 
system compatible with the Messaging Application Programming Interface (MAPI).

To e-mail assets:

1. Select the record representing the asset to mail.

2. From the Asset menu or the Record pop-up menu, select Mail To. (You can also select Mail To from the Asset menu in the 
Asset Information window.)

Cumulus launches the e-mail system installed on your system. The asset is attached to the new message to be sent.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Moving Assets 

Moving an asset from within Cumulus is a two-step process. Cumulus first copies the asset to a new location and then deletes it 
from the original location. Cumulus updates the catalog reference to reflect the new location. 

To move cataloged assets:

1. Select one or more records in the Record pane. 

2. From the Asset menu or the Record pop-up menu, click Move To. (You can also select Move To from the Asset menu in the 
Asset Information window.)

The Move to dialog box appears.

3. In the Save in field, enter a destination and click Save. 

4. Repeat step 3 for all selected assets.

Cumulus moves the files to the specified locations and updates all references.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Deleting Assets

Selecting the Also Delete Asset option in the Delete Records dialog box is a quick way to delete both the selected record and the 
original media file.

To delete both a record and the asset:

1. In the Record pane, select the record to delete.

2. Select Edit => Delete or press CTRL + DELETE.

The Delete Records dialog box appears.

3. Click Delete Record and Asset. 

Cumulus deletes the selected records and the original media files for those records.

To remove a record but leave the asset untouched, see Removing Records from a Catalog or Removing Records from a Collection.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Editing Assets

If you have a program installed that can edit an asset, you can use Cumulus to launch the program and open the file.

To edit a cataloged asset using another program:

1. Select one or more records in the Record pane. 

2. From the Asset menu or the Record pop-up menu, select Open With.

3. From the submenu, select the associated program or Other.

Cumulus launches the program, which then opens the file.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Printing Assets from Other Programs

If you have a program installed that can print an asset, you can use Cumulus to launch the program and print the file. For an 
overview on printing, see Printing Information.

To print an asset using another program:

1. Select one or more records in the Record pane.

2. From the Asset menu or the Record pop-up menu, select Print With.

3. From the submenu, select the associated program or Other.

Cumulus launches the program, which then opens and prints the asset.

{button ,AL(`manage',0,`',`')}    See also 



 Managing Assets 
Converting Assets to Other Formats

You can use Cumulus to convert an asset to another file format (such as JPEG).

To convert an asset to another format:

1. Select the record whose asset you would like to convert.

2. Select Asset => Convert To.

The Select Asset Storage Module dialog box appears.

3. Highlight the file system (such as the Windows File System) to which you would like to copy the converted asset and click OK.

The Convert Asset To dialog appears.

4. Select the destination to which you would like to copy the converted asset and click OK.

The following steps depend on the type of format to which you are converting the asset. Please follow the on-screen instructions.

{button ,AL(`manage',0,`',`')}    See also 



Printing Information

Cumulus features a context-sensitive printing capability. Select File => Page Setup to set printing options, such as paper size, 
orientation, etc. For information on printing asset previews, see Printing Previewed Images and Printing Assets from Other 
Programs.

You can:

· Print records 

· Print categories

· Preview the print output 

· Print an asset’s preview 

· Print asset information

{button ,AL(`print',0,`',`')}    See also 



 Printing Information
Printing Records

You can print records as they are displayed. You can print either selected records or all records in the current window (collection or 
catalog). 

To print records:

1. Select the records to print. (To select a series of records, hold down SHIFT and highlight the first and last record in the series.)

2. Select File => Print and then Selected Records or All Records.

3. Make the desired selections in the Print dialog box and click OK.

NOTE: If you select the print option Print Entire Assets as Thumbnails, the thumbnails will be printed in high-resolution 
quality so the printouts can serve as contact sheets.

For information on printing a record’s asset information, see Printing Asset Information.

{button ,AL(`print',0,`',`')}    See also 



 Printing Information
Printing Previews

It is possible to print an asset’s preview. The preview will be printed in the asset's original resolution. 

To print an asset’s preview:

1. Select the record of the asset whose preview you want to print.

2. Open the preview by selecting Asset => Preview.

3. Select File => Print.

4. From the submenu, select Preview. 

The Print dialog box appears.

5. Make the desired dialog box selections and click OK. 

{button ,AL(`print',0,`',`')}    See also 



 Printing Information
Printing Categories

You can print the categories as they are displayed. You can print either selected categories or all categories in the current window 
(collection or catalog). 

To print categories:

1. Select the categories to print. (To select a series of records, hold down SHIFT and highlight the first and last record in the 
series.)

2. Select File => Print and then Selected Categories or All Categories.

3. Make the desired selections in the Print dialog box and click OK.

{button ,AL(`basics',0,`',`')}    See also 



 Printing Information
Previewing the Printout

Print Preview allows you to view a print selection before you print it out. 

To preview prior to printing:

1. Select File => Print Preview.

2. From the submenu, select one of the following:

· Selected Records displays a preview of the selected records.

· All Records displays a preview of all records in the current window. 

· Selected Categories displays a preview of the selected categories.

· All Categories displays a preview of all categories in the current window

· Preview displays a preview of the assets’ previews of selected records in the current window

A Preview window appears.

3. Select the desired button at the top of the window:

Button Description

Print Sends the print job to the printer.

Next Page Opens a preview of the following printed page. (Disabled if there are no 
additional pages.)

Prev Page Opens a preview of the previous printed page. (Disabled if you are viewing 
the first page.)

Two (One) 
Page 

Displays two preview pages at a time. When you’re viewing two pages, the 
button reads One Page, 
and is used to reduce the display back to a single page. (Disabled if there 
is only one page in the print job, and when the display is not at the 
minimum zoom level.)

Zoom In Zooms in on the current page view. (Disabled when you have reached the 
maximum zoom level.)

Zoom Out Zooms out from the current page view. (Disabled when you have reached 
the minimum zoom level.)

Close Closes the Print Preview window without printing the job.

{button ,AL(`print',0,`',`')}    See also 



 Printing Information
Preview Window for Printout

The Preview window is displayed. Select the appropriate button at the top of the window:

Button Description

Print Sends the print job to the printer.

Next Page Opens a preview of the following printed page. (Disabled if there 
are no additional pages.)

Prev Page Opens a preview of the previous printed page. (Disabled if you are 
viewing the first page.)

Two (One) Page Displays two preview pages at a time. When you’re viewing two 
pages, the button reads One Page, and is used to reduce the 
display back to a single page. (Disabled if there is only one page in 
the print job, and when the display is not at the minimum zoom 
level.)

Zoom In Zooms in on the current page view. (Disabled when you have 
reached the maximum zoom level.)

Zoom Out Zooms out from the current page view. (Disabled when you have 
reached the minimum zoom level.)

Close Closes the Print Preview window without printing the job.



Exporting and Importing Information

You can export record or category information to a tab-delimited text file which can then be imported into other catalogs or 
applications. This lets you move large numbers of records between catalogs or merge record data with other applications. 

The file type Cumulus creates depends upon the information you are exporting. 

Export/Import Information Cumulus File Type/Extension

Categories Cumulus Category Exchange File (*.cce)

Records Cumulus Record Exchange File (*.cre)

You can also export the displayed view of all or selected records in HTML format and create HTML pages. For information, see 
Output to HTML. 

{button ,AL(`export',0,`',`')}    See also 



 Exporting and Importing Information
Exporting Information

You can export record or category information to a tab-delimited text file which can then be imported into other catalogs or 
applications. 

The Export menu item opens a submenu with several export options. Each opens a dialog box from which you can name an 
appropriate file type for export. All exported files can be used on any supported Cumulus platform. The options are explained below:

Selected Categories Exports the currently selected (highlighted) categories to a 
Cumulus Category Exchange File (.cce). This menu option is 
disabled if no categories are selected.

All Categories Exports all categories as they appear in the Category pane to 
a Category Exchange File (.cce). Make sure to expand the 
category list if you want to export all subcategories.

Selected Records Exports the currently selected (highlighted) records to a 
Cumulus Record Exchange File (.cre). This menu option is 
disabled if no records are selected.

All Records Exports all records in the active collection to a Cumulus 
Record Exchange File (.cre).

To export record or category information:

1. In the Collection window, select the records or categories to export.

2. Select File => Export and the desired submenu option.

The Save As dialog box appears.

3. In the Save in field, specify where to save the Cumulus Record Exchange File or Cumulus Category Exchange File.

4. To accept the default file name, click Save. Otherwise, enter a new name in the File name field and then click Save.

5. Select the character encoding format for the export.
Only choose Universal Encoding (UTF-8) if you want to use the exported file on another operating system.

Cumulus saves the information in the selected location using the appropriate file type.

{button ,AL(`export',0,`',`')}    See also 



 Exporting and Importing Information
Character Encoding for Export

When you export information, you can employ different character encoding formats. You should base your decision on how the 
exported file is to be used.

Only choose Universal Encoding (UTF-8) if you want to use the exported file on another operating system. This format ensures 
that special characters are transferred correctly across platforms. (UTF 8 are Unicode characters coded as 8-Bit Transformation 
Form.)

{button ,AL(`records',0,`',`')}    See also 



 Exporting and Importing Information
Importing Information

Cumulus creates specific file types when exporting record or category information. You can use the Import command to import this 
information, or you can copy records and categories by dragging and dropping them between catalogs.

Note: With Cumulus Browser the import command is not available.

The Import menu item opens a submenu with several import options. Each opens a dialog box from which you can select an 
appropriate file type for import. The various file types are listed by the import type below:

Categories (.cce) The imported categories are appended to the active catalog. If a 
category in the import file has the same name as an existing 
category, the category is not imported. 

Records (.cre) If a record in the import file already exists in the active catalog, it is 
imported only if the Add Duplicates option has been selected in 
the Cataloging Options setup.

When importing both category and record information, you must first import categories and then the records that are assigned to 
them. Otherwise the relationships between categories and records will be broken.

To import record or category information into a catalog:

1. Select File => Import.

2. From the submenu, select the desired import option.

An Open dialog box appears.

3. Select the file to import and click Open.

{button ,AL(`export',0,`',`')}    See also 



 Outputting Records to HTML
You can export the current display of selected or all records as HTML pages.

The appearance of the HTML pages created by Cumulus will correspond to the display of the records. Depending on the number of 
records selected and the way they are displayed, multiple HTML pages will automatically be created, including links to the other 
pages. Staying true to What-You-See-Is-What-You-Get (WYSIWYG), the number, size, and labeling of the records on the HTML 
pages will reflect what you see in the record pane (thumbnails or details). 

To create HTML pages:

1. Select the records that you want to output to HTML. (To select a series of records, hold down SHIFT and highlight the first and 
last record in the series.)

2. Select File => Output to HTML.

3. From the submenu, select the appropriate option.

A dialog box for defining the output to HTML appears.

4. Make your selections. 

You can use either the current view settings or templates. The Add button enables you to add HTML templates that can be 
used for the output. (For details, review manuals on HTML.)

5. Click Save.

Cumulus creates the corresponding HTML pages.

If the view you export is a thumbnail view, Cumulus creates a Thumbnails folder with the corresponding thumbnails in JPEG format.

The HTML pages created by Cumulus can include links to the previews or the original assets. If you include links to previews, 
Cumulus creates a Previews folder containing the corresponding previews in JPEG format. If you include links to the originals, 
Cumulus creates a Files folder containing copies of the corresponding assets.

You can also include the voice annotations you created for the asset in the Asset Information window. For further information on 
voice annotation, see Audio fields.

{button ,AL(`export',0,`',`')}    See also
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 Tailoring Cumulus 
Customizing Application Preferences 

The Application Preferences window lets you customize and define global program settings such as:

· how Cumulus displays thumbnails 

· mouse double-click preferences

· whether certain warnings should appear or be suppressed

· display options (e.g., desired measurement units, grid used for window resizing, preview size and display options)

· general search behavior 

To view or modify your application preferences:

1. Select Edit => Preferences.

The Application Preferences window appears. 

2. Move from one tab to another by clicking a tab title.

General 

Display 

Search 

3. Make selections and click Apply. To activate all selections and exit the window, click OK. To cancel, click Cancel.

{button ,AL(`customizing',0,`',`')}    See also 



 Tailoring Cumulus 
 Customizing Application Preferences 

General Tab

The General tab controls general program behavior. 

Option Description

Double-Click on Record Determines what happens when you double-click a record. 
Available options include:

· Opens the Asset Information window.

· Opens a preview of the cataloged asset.

Warning Dialogs Controls whether or not certain warning dialog boxes appear. 
Available options include:

· Show Warnings displays all warnings

· Suppress Warnings suppresses certain warnings

Checkout Location,
Use Checkout Location

Users carrying out a version control (e.g. the Cumulus Vault 
Option) can define their general Checkout Location. That way 
they can avoid being asked for the Checkout Location for 
each check out they perform.

Measurement, Unit Determines the unit of measurement (e.g., inches, 
centimeters, etc.) that appears in the Asset Information 
window.

At Startup,
Reopen Catalogs

Cumulus will open all catalogs (and collections) that have 
been opened when the Cumulus was closed last time at 
startup. If this option is not enabled, Cumulus will always 
start without an open catalog or collection.

{button ,AL(`preferences',0,`',`')}    See also 



 Tailoring Cumulus 
 Customizing Application Preferences 

Display Tab

The Display tab controls how thumbnails and previews are displayed and measured.

Option/Field Description

Thumbnail Sizes Defines the sizes of small, medium and large 
thumbnails. The sizes defined here for thumbnails 
are those displayed when the respective size is 
selected. 

Preview Size Controls the size of an Asset Preview window. 
Available options include:

· Original Size displays an Asset Preview using 
the actual size of the cataloged asset

· Fit to Main Window resizes the Asset Preview to 
fit the Cumulus Application window

· Other lets you enter the preferred Asset Preview 
size in the field provided

Collection Window,
Use Grid for Resizing

Snaps window to multiples of the current thumbnail 
size when resizing.

Preview Display,
Uncalibrated

Shows preview with no ColorSync color correction.

Preview Display,
Calibrated

Shows preview with ColorSync profile used by 
asset.

Preview Display,
Calibrated with Gamut Alarm

Shows preview with ColorSync profile used by 
asset and highlights any part of the image that is 
beyond the printable color spectrum of the printer 
selected under Printer Profile.

Preview Display,
Printer Profile

Selects a ColorSync printer profile. (Disabled if 
Calibrated with Gamut Alarm is not selected.)

Preview Display,
Alarm Color

Click to select a warning color for unprintable 
shades in asset.

{button ,AL(`preferences',0,`',`')}    See also 



 Tailoring Cumulus 
 Customizing Application Preferences 

Search Tab

Options on the Search tab affect how Cumulus locates records using the Find window and how categories display records.

Within Cumulus, the term search means more than using the Find window to locate records. When you click on a category to 
display records, the program performs a search to locate all records in that category. For more information on category searching, 
see Understanding Category Search Preferences. 

Under Category List Search Finds Records, you can select one of two search techniques:

· Matching At Least One Selected Category finds records associated with at least one of the categories selected in the 
Category pane.

· Matching All Selected Categories finds those records associated with all of the categories selected in the Category pane.

Under Category Search Also Finds Records of, you can define the scope of the category search. Selecting Categories Below 
the Selected enables the and Related Categories option, which lets you search for related categories as well as those specified by 
the search.

For information on category searching, see Using the Search Compass Icon. 

{button ,AL(`preferences',0,`',`')}    See also 
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Setting Cataloging Options

The Cataloging Options window    controls the way in which Cumulus catalogs assets and the kinds of information that are imported 
during cataloging. For information on modifying Cataloging Options for existing records, see Updating Records.

Options in this window    include:

· whether to automatically display the Asset Information Window as each asset is cataloged

· whether records should be associated with default categories 

· whether catalogs can have multiple records for the same asset

· which file filters are available and in what order

· how Cumulus creates thumbnails 

To display the Cataloging Options window :

1. Select Catalog => Cataloging Options.

The Cataloging Options window    appears.

2. Move from one tab to another by clicking a tab title.

General 

Assets 

Asset Formats 

3. Make your selections and click Apply. To activate all selections and exit the window , click OK. To Cancel, click Cancel.

{button ,AL(`customizing',0,`',`')}    See also 
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Cataloging Options, General Tab

The General tab enables you to specify default presets that Cumulus assigns every time you catalog an asset.

Option/Field Description

While Cataloging, Show Progress 
Bar

Counts the total number of assets before startomg the 
cataloging process. During cataloging, the Progress 
window    displays the asset file name and a percentage 
complete bar. This slows down the cataloging process.

After Cataloging, Open 
Information Window 
Automatically 

Displays the Asset Information window after the creation 
of all new records. This lets you systematically update a 
record’s properties directly after cataloging. 

Quality Sets the thumbnail quality for the different color modes: 
Line art (NORMAL=2 color / HIGH=4 color), Greyscale 
(NORMAL=8-bit greyscale, more compression / HIGH=8-
bit greyscale, less compression), Color (NORMAL=24-bit 
color, more compression / HIGH=24-bit color, less 
compression.) 
NOTE: High-quality thumbnails make records larger.

Optimize Thumbnail Equalizes the thumbnail images for newly cataloged 
assets automatically. This can also be done afterwards. 

Create Thumbnails from,
Stored Thumbnail (when 
available)

Some programs can save images with embedded 
thumbnails. This option uses those thumbnails, if 
available, instead of creating new ones. Stored 
thumbnails may differ in size.

Create Thumbnails from,
Stored Thumbnail (if large 
enough)

Uses embedded thumbnails, if they are available and 
large enough (at least as large as defined in the Catalog 
Properties, General section under Thumbnail Size).

Create Thumbnails from,
Entire Asset

Creates thumbnail images of the entire asset file. These 
thumbnails are consistent in size, but this option slows 
the cataloging process.

This tab displays a sample thumbnail so you can evaluate your quality and optimization settings. The thumbnail’s dimensions (in 
pixels) appears directly above the image and are followed by the disk space that the thumbnail will occupy. Thumbnail dimensions 
are set in the Catalog Properties window .

If you enable Optimize Thumbnail, Cumulus automatically optimizes the appearance of each thumbnail during the cataloging 
process. You can also manually optimize thumbnails by selecting them in the Record pane and selecting Edit => Optimize 
Thumbnail.

{button ,AL(`catalog options',0,`',`')}    See also 
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Cataloging Options, Assets Tab

The Assets tab lets you specify how catalogs are updated as well as how to handle duplicates and shortcuts, and lists specific asset 
files that should never be cataloged. 

When Cataloging determines if Cumulus catalogs new assets or updates existing records. You can choose from the following:

· Add Only catalogs only assets that have not yet been cataloged.

· Add and Update creates new records for assets that have not yet been cataloged and updates existing ones.

· Update Only updates only existing records. 

Under Duplicates, Add Duplicates allows duplicate records. Ignore Duplicates prevents an asset from being cataloged more than 
once in the same catalog.

When the Central Location option Copy Asset to Central Location is enabled, Cumulus copies all newly cataloged assets to a 
central location.

Under Linked Assets, Resolve Links directs Cumulus to use the path stored in a Windows operating system shortcut to locate an 
asset. Ignore Links disables this feature. For example, suppose you create a shortcut to an asset stored on another disk. If 
Resolve Links is enabled, you can catalog that asset by dropping its shortcut into the Collection window. 

Under Asset Storage Modules, you specify the Asset Storage module to handle your assets. For more information on the various 
Asset Storage modules which Cumulus employs see About the Asset Storage Modules.

Button Description

About Displays information on the selected module (if 
available).

Properties Opens the properties window for the selected 
module (if available).

Activate Activates the selected module.

Deactivate Deactivates the selected module.

Under When Cataloging, you can specify assets that should not be cataloged. Damaged or corrupt asset files cause common 
cataloging problems that may crash your system. If you know a specific asset file is causing problems, add it to the "Do NOT 
Catalog the Following Assets" list. 

To automatically assign damaged files to the "Do NOT Catalog the Following Assets" list, select Add Damaged Asset to List 
Automatically. This may slow down cataloging performance, so use this option only when you are unable to determine the file 
causing problems. When enabled, Cumulus keeps a record of the last file cataloged. If your system crashes, Cumulus automatically 
adds that file to the "Do NOT Catalog the Following Assets" list. 

To specify assets that should not be cataloged:

1. Click Add Asset to List.

The Open dialog box appears.

2. In the Open dialog box, select the asset and click Open.

The selected asset appears in the ‘Do NOT Catalog the Following Assets’ list.

To remove assets from the ‘Do NOT Catalog the Following Assets’ list:

1. Select the assets from the ‘Do NOT Catalog the Following Assets’ list.

2. Click Remove Asset from List.

Cumulus removes the selected assets.

{button ,AL(`catalog options',0,`',`')}    See also 
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About Central Location

You can configure Cumulus to copy cataloged assets to a special central location. This central location can be configured so that 
assets are copied either at your discretion or every time an asset is added to the catalog. 

The actual asset remains in the original location, but the record points to the copy in the folder specified as the central location. You 
can control who is allowed to modify assets stored in the collection folder.

You can enable or disable Central Location in the Catalog Properties window . 
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About the Asset Storage Modules 

When cataloging an asset, Cumulus uses two types of components: Asset Storage modules and filters. The Asset Storage module 
manages the asset’s storage (the access to its location), and the filter analyzes the asset’s contents. For example, if you catalog a 
file from the file system of your computer, the Asset Storage module manages the access to the file system of your computer, and 
the employed filter reads the file’s content.

Cumulus 5 comes with Asset Storage modules for the Windows or Mac OS file systems as well as a module called Cumulus 
Metadata Support and special modules to handle DCS (Desktop Color Separation) files and OPI (Open Prepress Interface).

Depending on your workflow requirements, you may not need to use some of these Asset Storage modules. If, for example, you are 
not using services from a prepress service provider and do not have access to an OPI server, you should deactivate the OPI System 
Support. Deactivating Asset Storage modules which are not needed for your specific workflow enhances productivity by freeing up 
Cumulus’ resources and speeding up the cataloging process. To deactivate an Asset Storage module simply select it and click 
Deactivate. 

For details on Cumulus’ various Asset Storage modules., what they do and how they are configured to customize Cumulus to your 
specific workflow, see:

Cumulus Metadata Support

DCS File Support

OPI System Support 

URL Support 

Cumulus Vault
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About the Asset Storage Modules 

Cumulus Metadata Support 

This Asset Storage module supports the storing of an asset’s metadata in a separate TAG file for each asset. This makes it possible 
for stored metadata to be used externally (e.g., by other applications). Only if this Asset Storage module is activated, can Cumulus 
create a TAG    file for each asset cataloged. 

You can define the following properties for the Cumulus Metadata Support:

Never: If a TAG file exists, Cumulus Metadata Support will read it, but no TAG files will be created. 

Only if Metadata Exists: If metadata in a TAG file exists, it will be updated.

Always: A TAG file for metadata will be created and continuously updated.

The following is for users of the Enterprise Edition only!

NOTE: If you want to use the Asset Cross Reference (AXR) feature of Cumulus the Cumulus Metadata Support must be activated 
and the option Always enabled.

For Directory Categories, Folder TAG files can be created. The Folder TAG file for a Directory Category is called Cumulus 
Metadata.tag and resides in the corresponding folder. If the Cumulus Metadata Support is activated and the option Always is 
enabled, a Folder TAG file will be created as soon as you change the Category information of a Directory Category. Folder TAG files 
are also created if you Drag & Drop a category to your Desktop or if you employ the menu option Save Matching Assets As.
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About the Asset Storage Modules 

DCS File Support

This Asset Storage module enables Cumulus to recognize CYMK Desktop Color Separation files so that it can effectively catalog 
and manage multiple-file DCS assets. This Asset Storage module supports DCS version 1.0. These DCS assets consist of one main 
file (which may contain a preview image) and the four standard color separation files.

When cataloging a DCS asset, this Asset Storage module creates a record for the main file only. This is important to be aware of 
when viewing the Asset Information window, as the information such as file size, etc. only pertain to the main file. Although only one 
file is cataloged, Cumulus still manages all five. For example, if you move or copy the cataloged DCS asset with Cumulus, all five 
DCS files will be moved or copied.
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About the Asset Storage Modules 

OPI System Support

This Asset Storage module enables Cumulus to be OPI-aware. The Open Prepress Interface (OPI) is a technology that allows 
placing low resolution versions of image files into page layouts and letting an OPI print spooler automatically replace them with the 
high resolution versions of the files for printing. Only if this Asset Storage module is activated, can Cumulus recognize OPI files and 
carry through the correct handling of high and low resolution versions of OPI files.

The module is able to read path name information and lets Cumulus manage both high resolution and low resolution files from OPI 
systems like Imation Color Central, Nine Bits PrintDesk, 4-Sight OPi, and Helios EtherShare OPI. 

Cumulus is also OPI-compatible with many other OPI systems that use EPSF or TIFF format files as their low resolution file, like 
Scitex APR. With these OPI systems, low resolution files are handled as expected, but the path to the high resolution file might not 
be automatically recognized.

The module offers special support for Helios EtherShare OPI version 1.0 up to 1.2 and Imation Color Central 2.1 up to 2.5. For both 
OPI systems you can define additional properties.

If you select the OPI Support entry in the list of Asset Storage modules and then select the Properties button, the OPI Support 
Settings window opens.

The OPI Support Settings window has three sections: General, Helios and Imation 

Section General 

In the section General you can set up the module to use either the low resolution file or the high resolution file when you drag and 
drop an asset. If you want to use the actual cataloged file, you can disable the option Silent OPI File Access.

For all OPI systems (except Helios) it is recommended to catalog the low resolution file as only the low resolution file leads to the 
high resolution file – and not vice versa. If you have cataloged the low resolution files, do not enable Silent OPI File Access along 
with the option High Resolution File for these OPI systems as this combination will not work. In fact you are using a Helios OPI 
system you can catalog the high resolution file as only in a Helios OPI system the high resolution file leads to the low resolution file; 
it is even recommended to catalog the high resolution file as the information on this file will then be available with the catalog.

Section Helios

In the section Helios you can set up special properties for Helios EtherShare OPI. Only if the option Helios EtherShare OPI Aware 
is activated, will Cumulus catalog either the low resolution layout file or the high resolution file. 

Although the module recognizes layout files generated in the layouts folder it also supports a name extension for layout files. In the 
field Layout file name extension (default: .lay) you specify the name extension to identify OPI layout files. You should always 
specify the same name extension that is used by the Helios EtherShare OPI system. A file in the same folder as the high resolution 
file that has this name extension will be treated as the layout file for this high resolution file. The following two options are important 
to avoid duplication when cataloging a whole folder. They can be used to create only one record for a pair of high- and low 
resolutions files when cataloging. 

The option Catalog High Resolution Files Only (default) allows you to catalog only high resolution files. This is useful to get the 
information (size, resolution) about those files into the Cumulus catalog. By choosing the option Catalog Layout Files Only you can 
build a catalog of only the layout files. 

Section Imation 

In the section Imation you can set up special properties for Imation Color Central. Only if the option Imation Color Central Aware 
is activated, will Cumulus read the IPTC information from the high resolution file while cataloging the sample file. 
NOTE: This option can only work properly when the high resolution file and the sample file reside in the same folder. 

If the option Add Category for Sample Files is activated, Cumulus will assign every ColorCentral sample file to a special category 
while cataloging. The category name can be specified in the field below this option (default: Imation Color Central). This option is 
useful when you catalog both the high resolution and the sample file of an image and you want to distinguish the corresponding 
records.
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About the Asset Storage Modules 

URL Support

If you have installed the URL AssetStore Module option it comes with Asset Storage module URL Support. It supports FTP and 
HTTP URLs. It enables users to catalog and access files stored on all standard FTP and HTTP servers for Windows, Mac OS, Mac 
OS X, or UNIX.
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About the Asset Storage Modules 

Cumulus Vault (Workgroup and Enterprise Edition only)

If you have installed the Cumulus Vault option it comes with Asset Storage module Cumulus Vault. Cumulus Vault provides a 
revision control system as well as version retention and tracking, at-a-glance version information. 
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Cataloging Options, Asset Formats Tab

From within the Asset Formats tab, you can control how Cumulus utilizes filters. All supported asset formats appear in the 
Cataloging Asset Formats list. 

Active filters are indicated by a black checkmark to the left of the format. Filters that have been deactivated have a blank area to 
their left. Filters that are not currently supported are indicated by an X symbol. This way they keep their position in the filter list and 
when they are supported again, the filter will be activated at this position.

Each filter can support multiple asset formats. Use the scroll bar to the right side of the list to review all entries. 

You can:

· reorder the filters

· enable/disable support for certain asset formats

· add/remove filters

· determine whether assets of all formats shall be cataloged or only assets of the formats which are activated in the Order 
column. If Catalog All Formats is activated, Cumulus catalogs assets of all formats. For unknown formats (not listed or 
activated), the Cumulus Generic filter will be used.

To determine the way in which filters import information:

1. In the Order column, select the asset format entry and click Properties. (Disabled when no properties are available.)

A setup window    appears. (If it is a Cumulus 4 Compatibility Filter, the Properties window    appears. Within this window , click 
Properties. If available, a setup window appears.)

2. After making your adjustments, click OK. 

You can also do the following on this tab:

Move formats up or down in the list 

Edit formats 

{button ,AL(`catalog options',0,`',`')}    See also 
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Moving Formats in the List

You can click each column header (Order, File Format, Extension, or Filter) to toggle the asset format order from ascending to 
descending or vice versa. 

When cataloging, Cumulus starts searching for matching filters at the lowest entry number. It employs the filters in the order in 
which they are found. If you are not satisfied with the result of cataloging certain asset types, check the order of the filter entries. 
The filter that best suits your needs may come later in the order than other matching filters. 

Note: Record Field Linking
If Read One is activated for the field link, only the metadata read by the first matching filter will be stored with the record.

Use the arrow buttons to the right of the list to change the order of the entries.

Arrow Button Description

First
Moves the selected format to the top of the list.

Move Up
Moves the selected format up one position within the 
list.

Move Down
Moves the selected format down one position within the 
list.

Last
Moves the selected format to the bottom of the list.

{button ,AL(`catalog options',0,`',`')}    See also 
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Editing Asset Formats

A checkmark appears next to all enabled asset formats. Enabling a specific asset format loads it into memory. Disabling asset 
formats you rarely use improves program performance.

As Canto adds new asset formats, you can download them free of charge from our web site (www.canto.com). To install and use a 
new format, download it and follow the online installation instructions. Once installed, the format appears in the Cataloging Asset 
Formats list, but must be enabled. 

To enable or disable a specific format:

1. In the Order column, select the filter entry.

2. To enable/disable, click Activate/Deactivate.

Extending Generic Filter Options

Cumulus can catalog any digital asset. If Catalog All Assets (above the list of asset formats) is activated and Cumulus encounters 
an asset for which no specific filter is available, then it uses its generic filter. You can expand the Cumulus generic filter’s capabilities 
to create your "own filters." For assets that don’t have specific filters provided by Cumulus, you can define a thumbnail for the asset 
format by using the generic filter. 

If you use filters that you’ve created on your own, check the Canto Web site from time to time to see if a more powerful filter has 
been developed that you could use.

To set up a new filter:

1. Under Cataloging Asset Formats, click Add.

The General Filter Properties window opens.

2. Enter the appropriate windows extension (e.g., *.eps) in the File Extension field.

3. Enter the desired format name in the Format field. 
If your system is aware of the asset type, its name may be entered for you.

4. Enter the Mac OS file type in the Mac OS File Type field. The file type will always be 4 characters in length.

5. Choose the thumbnail you want displayed for the asset. You can use either use the asset’s Windows Explorer icon or an image 
that you specify.
If you want to specify a thumbnail image to be used for your assets, click the Browse button. As a static thumbnail you can use 
any BMP file. 

6. Click OK to save your new filter. New filters are available immediately after you close the Cataloging Options window.

New filters are placed at the top of the filter list by default. Use the arrow buttons to the right of the list to move the filter down in the 
list, if necessary.

TIP: If anything goes wrong while cataloging, check the file extension!

{button ,AL(`catalog options',0,`',`')}    See also 
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The View Customization window lets you customize the Thumbnail view, the Details view and the Palette Mode.

To open the View Customization window:

1. Select View => Customize.

The View Customization window appears.

2. Move from one tab to another by clicking a tab title.

3. Make your selections and click Apply. To activate all selections and exit the window, click OK. To cancel, click Cancel.

The View Customization window has different tabs that provide access to each of its options. The options can be set for Thumbnail 
View, the Details View and the Palette Mode. Each tab shows a list of displayed fields with information on the field type and the 
properties of the field: font type, style, size, and color.

The following buttons are provided for customizing the views:

Button Description

Properties Displays a dialog box to define the font used for the display of the 
selected field.

Add Before Inserts a field above the selected field. A dialog box appears for 
selecting the field to be added.

Add After Inserts a field below the selected field. A dialog box appears for 
selecting the field to be added.

Remove Removes the selected field from the view.

Background Color Displays a dialog box for selecting a color for the background.

Save as Default Saves the current selections as the default view for the current 
catalog.

Restore Default Sets all selections to the values of the last stored default for the 
current catalog.

The Thumbnail View tab also offers the following options:

Option Description

Image Size Sets the size of the thumbnail image.

Spacing Defines the spacing around the record.

Show Frame Displays the record within a frame.

To reorder the entries in the list, click the appropriate arrow button:

Arrow Button Description

First Moves the selected entry to the top of the list.

Move Up Moves the selected entry up one position within the 
list.

Move Down Moves the selected entry down one position within 
the list.

Last Moves the selected entry to the bottom of the list.
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Creating a Slide Show 

Cumulus includes a special application for presenting the assets’ previews as a slide show. This functionality is only available when 
QuickTime is installed on your computer (QuickTime 4.0 is recommended). Once you have created a slide show, you can save it as 
a QuickTime movie and/or e-mail it.

To create a slide show:

1. Arrange the records in the record pane in the order you want them to appear in the slide show. The order will be from left to 
right, top to bottom.

2. Select the records to comprise the slide show.

3. Select Collection => Slide Show. 

A dialog appears from which you can select options for the slide show.

4. Make your selections. For further information, see Configuring a Slide Show. 

5. Click OK.

The slide show will be created. After creation, the Slide Show window appears.
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Understanding the Slide Show Window

This is the window of the slide show you created with Cumulus. 

Starting

To run the slide show: Click . 

Changing Properties

You can change the properties of the slide show - which is actually creating a new slide show - using the same assets. To change 
the properties: 

1. Select File => New Slide Show.

A dialog appears from which you can select options for the slide show.

2. Make your selections. For further information, see Slide Show Properties. 

3. Click OK. The slide show will be rebuilt.

Saving or Mailing As Movie

You can save or e-mail your slide show as a QuickTime movie. A saved or e-mailed slide show can be opened with QuickTime.

To save the slide show as a movie: Select File => Save As Movie. 

To e-mail the slide show as a movie: Select File => Mail As Movie. 

Playing Full Screen

To set up the slide show to run on full screen: Select Edit => Full Screen. 

To start or stop the show: Double-click anywhere. To toggle Full Screen on and off, use CTRL F.

Playing in a Loop

To set up the slide show to run in a loop: Select Edit => Loop.

To stop a looping show: Click .

Closing

To close or exit the slideshow: Select File => Close or Exit. 

NOTE: If you close or exit the slide show without first saving it as a movie, it will be lost.
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Configuring a Slide Show

Timing

Seconds per Asset Determines how long each slide (asset’s preview) is displayed. 
However, if you assign audio/sound fields to the slide show, the 
length of the sound field determines the duration of the display of 
the asset’s preview.

Loop Activates a looping (i.e., continuous repetition) of the slide show.

Background Color You can define a background color for the slide show by clicking 
Choose.

Size Defines the size of the display as either full screen or custom-
defined (height and width in pixels). 
Scale to Fit scales the display of smaller assets’ previews up to the 
selected size.

Compression Defines the type of compression for the slide show. 

Note: The more a file is compressed, the less memory it requires 
and the faster it loads, but the quality suffers.

Lossless Compresses the slide show without any image quality degradation.

Standard Employs default compression values.

Custom Permits selection of compression methods. You can select specific 
compression settings by clicking Settings. 

Transition Effects Determine the type of transition effect from one slide to the next.

None One slide will change to the next without any transition effect.

Random A transition effect will be chosen at random for each transition from 
one slide to the next.

Custom Permits selection of the transition effect for the whole slide show. 
You can select specific transition settings by clicking Settings. 

Sound You can attach sound to the slide show for the whole duration from 
a sound file and/or for each slide (asset preview) from an audio field 
stored with the asset’s record. If both are attached, they may 
overlap and both can then be heard.

From Audio Field Attaches the sound from the audio field of the catalog. You can 
select the audio field by clicking the arrow button.

Background Sound 
From File 

Attaches sounds from a selected AIF or WAV file. You can select a 
sound file by clicking Browse. The sound will loop according to the 
duration of the slide show.

Text Display You can have the text of string field stored with the asset’s record 
displayed with each slide (asset preview).

Select the field you want to be the source for the displayed text by 
clicking the arrow button. You can also define settings for the 
displayed text by clicking Settings. A dialog for defining the 
properties for the displayed of the text opens.

To build the slide show: Click OK.
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Slide Show File Menu

The File menu of the Slide Show offers the following options: 

Menu Option Description

New Slide Show (Properties) Returns you to the dialog box for configuring the current slide 
show.

Changing the properties of a slide show actually replaces the 
current slide show with a new one using the same assets.

Save As Movie Saves the slide show as a QuickTime movie. Opens a 
standard Save As dialog box.

Once the slide show is saved as a movie it can be opened 
and played with the usual QuickTime MoviePlayer.

Note: Send the mail before closing the slide show – 
otherwise the attachment will be gone along with the slide 
show.

Mail As Movie Use this option to attach the slide show as a QuickTime 
movie to an outgoing e-mail message. 

A slide show e-mailed as a movie can be opened with 
QuickTime.

Note: Send the mail before closing the slide show – 
otherwise the attachment will be gone along with the slide 
show.

Close Closes the slide show without saving. 

Note: If you close or exit the slide show without first saving it 
as a movie, it will be lost.

Exit Closes the slide show without saving. 

Note: If you close or exit the slide show without first saving it 
as a movie, it will be lost.
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Slide Show Edit Menu

The Edit menu of the Slide Show offers the following options: 

Menu Option Description

Undo Reverts operations in fields, but cannot undo other 
operations.

Cut Removes the current selection and places it on the Clipboard 
so that it can be pasted elsewhere.

Copy Copies the current selection and places it on the Clipboard 
so that it can be pasted elsewhere.

Paste Places the contents of the Clipboard into the current location 
or insertion point.

Full Screen Displays the slide show using the entire screen. 

To start or stop the show: Double-click anywhere.

Loop Check/uncheck to activate/deactivate looping of the slide 
show.



  Dia-Schau 

Configuring a Slide Show

Text Display Properties

Font Style

Font Defines the font for the displayed text. You can select the font by clicking 
the arrow button and selecting the corresponding entry.

Style Defines the font style (e.g. bold, italic) for the displayed text. You can 
select the font style by clicking the arrow button and selecting the 
corresponding entry.

Size Defines the font size for the displayed text. You can select the font size 
by clicking the arrow button and selecting the corresponding entry.

Lines Defines the number of lines for the text display.

Text Color Defines the color of the displayed text. You can select the color by 
clicking the arrow button and selecting the desired color.

Anti Alias Edges of characters get smoothed out.

Scale on Resizing The size of the font will be resized depending on the size of the slide 
show window. 

Drop Shadow A shadow is displayed underneath the text.

Scrolling Once one of these options is activated, the text will scroll. 

Scroll Out The text is displayed (according to the text justification; see below) and 
scrolls out.

Scroll In The text scrolls in and stays displayed (according to the text justification; 
see below).

NOTE: You can activate both options. Then the text will scroll in and out.

Scroll Direction These options are only available, if one of the scrolling options is 
activated.

Reverse Scrolling The text scrolls 
vertically: from left to right in or out.
horizontally: from top to bottom in or out.

Horizontally The text scrolls horizontally.

Vertically The text scrolls vertically.

Text Justification

Center The display or scrolling of the text is centered. 

Left The display or scrolling of the text is aligned to the left.

Right The display or scrolling of the text is aligned to the right. 

To apply these properties to the slide show: Click OK.
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NOTE: With a Cumulus Single User Edition, the single user can administer Cumulus. With a Workgroup Edition, only the Cumulus 
Administrator is allowed to administer Cumulus and the catalogs for workgroups. 

As single user or Cumulus Administrator, you can:

· Register the Cumulus software 

· Single User: Create a catalog, Administrator:Create a catalog for workgroups 

· Modify catalog properties 

· Back up a catalog 

· Single User: Restore a catalog you backed up, Administrator:Restore a backed-up catalog for workgroups 

· Recover deleted records 

· Compress catalogs 

· Make empty copies of a catalog

· Set a catalog as default

· Restore factory defaults 

· Convert a catalog

· Monitor catalog activity 

· Copy catalogs 

· Divide catalogs 

· Merge catalogs 

· Repair a catalog 

· Update catalogs from earlier versions

For information on solving problems, see Troubleshooting and Technical Support.
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Registering the Cumulus Software

Registering the Cumulus Single User Edition

Registering the Cumulus Workgroup Edtion (Cumulus Administrator only)
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Registering the Cumulus Software (Single User Edition)

Registering Cumulus should be considered part of the Cumulus installation process. Registration entitles you to technical support 
from your distributor free of charge via e-mail (see Technical Support), and is also required for you to be able to activate any future 
updates or add-ons. If you are installing any optional add-ons right now, make sure to read "Activation Key" below.

The fastest and easiest way to register your copy of Cumulus is on the World Wide Web. If you do not have a Web connection, you 
can also print the registration form out and fax or mail to Canto .

To register Cumulus on the Web:

1. Select Help => License.

The License dialog box appears.

If you’re also registering an optional add-on, click Add and type its serial number in the dialog that appears.

2. Click WWW Registration.

Your Web browser launches and initiates a connection to the Canto registration site. 

3. Fill out the online registration form and submit it. All required serial numbers and ID’s are filled in automatically.

If you don’t have Internet access, you can fill in a registration form and register via e-mail, fax or regular mail.

NOTE: You need to have the Adobe Acrobat Reader installed on your computer in order to register Cumulus via e-mail, 
fax or conventional mail. If you do not have the Acrobat Reader, you can find it on the Cumulus CD in the 
English\Documentation\ folder.

To register Cumulus via fax or mail:

1. Select Help => License. 

The License dialog box appears.

If you’re also registering an optional add-on, click Add and type its serial number in the dialog that appears.

2. Click Print Registration. 

A dialog box appears for you to save a copy of the registration form.

3. Accept the name and path suggested by Cumulus or choose your own and click Save.

Cumulus launches the Acrobat Reader, which opens the registration form.

4. Fill out the form on your computer. All required serial numbers and ID’s are filled in automatically.

5. Save the form.

6. Send it as an attachment to an e-mail message to: registration@canto.de
OR
Print the form, then fax or mail it to the address listed for your region.

Activation Key

If you purchased any optional add-ons, you will need an Activation Key from Canto in order to integrate them into your Cumulus 
system. To get an Activation Key, enter the serial number in the License dialog box before clicking WWW Registration or Print 
Registration.

Once you have received your Activation Key from Canto, enter it into the Activation Key field in the License dialog box. Click Apply, 
and your add-ons will be activated and ready to go.

{button ,AL(`administrator',0,`',`')}    See also 
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Registering the Cumulus Software (Workgroup Edition)

Registering the Cumulus Workgroup Edition is the job of the Cumulus Administrator, who registers the software for the Cumulus 
Server and all Cumulus Clients.

To register a Cumulus Workgroup Edition:

1. On the machine running the Cumulus Server, open the Windows Control Panel and double-click the Cumulus Server icon.

The Server Properties dialog box appears.

2. On the General tab, click License.

The License dialog box appears, from which you can register the Cumulus Edition. For more information, click the Help button 
in the License dialog box.
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Configuring a Catalog 

You can configure:

· how Cumulus saves catalogs

· whether to enable or disable the Cumulus log

· the maximum number of entries (or records) a catalog may have

· whether to save cataloged assets to a central location

· the default thumbnail size

· whether to allow duplicate category names

· permissions and access

All catalog configuration is controlled from the Catalog Properties dialog box. 

To view or modify catalog properties:

1. Select Catalog => Properties.

The Catalog Properties dialog box consists of five tabs: 

· General 

· Asset Location 

· Sharing 

· Record Fields 

· Category Fields 

Move from one tab to another by clicking the tab title.

2. Make your selections and click Apply. To activate all selections and exit the dialog box, click OK. To cancel, click Cancel.

{button ,AL(`configure',0,`',`')}    See also 



 Catalog Administration
 Configuring a Catalog 

Catalog Properties, General Tab

The General tab includes the following options:

Option Description

Catalog, Location Location and file name of current catalog file.

Catalog, Name Catalog name that appears to clients. This name may 
differ from the actual file name.

Thumbnail Size Sets the default thumbnail size for the current catalog 
(64 x 64, 128 x 128 and 256 x 256 pixel). Larger 
thumbnails offer more detail, but small thumbnails need 
less space.

The thumbnail size you select becomes the default size 
for the catalog. You can still view thumbnails at different 
sizes, but each view is scaled from the size at which the 
thumbnail was created. 

If you change the default size, existing records in the 
catalog do not change, but thumbnails for new records 
are created according to the new setting unless you 
update them.

Category Names Controls how Cumulus handles duplicate categories. 
Available options include:

· Allow Duplicate Names allows Cumulus to use 
the same name for multiple categories. When 
typing duplicate category names, you must include 
the full path. Otherwise, Cumulus will use the first 
category it finds. The path is not required when you 
drag and drop categories.

· Keep Category Names Unique prevents the 
duplication of category names. If you try to assign 
a name that is already in use, Cumulus displays a 
warning. Enabling this option does not affect 
existing categories.

The Advanced Settings button opens a dialog box where you can configure catalog operation and view database statistics.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Catalog Properties, Asset Location Tab

The Asset Location tab includes the following options:

Option Description

Copy Assets to Central Location Enables you to copy cataloged assets to a special 
folder called a central location on the Cumulus Server. 
Available central location options include:

· Never disables central location functionality.

· As Set in Cataloging Options allows each client 
to determine whether cataloged files should be 
copied to a central location or remain in their 
original location. If you choose this option, 
Cumulus asks you to specify a central location.

· Always configures Cumulus to always copy 
cataloged assets to the central location. When you 
select this option, Cumulus asks you to specify a 
central location. 

The Browse button opens a dialog box for selecting the central location.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Catalog Properties, General Tab 

To update existing records to a new thumbnail size:

1. Select the record you wish to update.

2. Select Catalog => Update Record and then Always. 

Cumulus creates new thumbnails for the selected records.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Catalog Properties, Sharing Tab 

Sharing enables you to set a password for the current catalog. All other options are disabled for the Cumulus Single User Edition.

Option Description

Password for Write Access Sets the password for write access to the catalog. If 
enabled, users must enter this password in order to 
make changes to the catalog (modify records and 
categories, etc.).

The rest of the options on this tab are only active in the Cumulus Workgroup Edition, and are only available to the Cumulus 
Administrator:

Option Description

Sharing

Share Catalog Enables/disables sharing of the active catalog. Has 
the effect of opening or closing the catalog on the 
Cumulus Server. If a catalog is available for sharing, 
every Client can access it.

Publish Catalog to Internet Publishes the active catalog to the Internet. Only has 
an effect if the Cumulus 5 Web Publisher is installed 
with the Cumulus Workgroup Edition.

Restrict User Permissions Enable/disable to set specific access permissions for 
individual users. If disabled (not checked), every user 
has all access permissions.

Users list List of users who can currently access the active 
catalog.

This User May:

Open This Catalog Enables/disables selected user’s permission to open 
the active catalog.

Modify Category List Enables/disables selected user’s permission to 
modify category list of active catalog.

Modify Records Enables/disables selected user’s permission to 
modify records in active catalog.

Delete Records Enables/disables selected user’s permission to delete 
records from active catalog.

Transfer Assets Enables/disables selected user’s permission to 
download assets managed by active catalog via the 
optional Cumulus 5 Web Publisher.

Button Description

Add Opens a dialog for adding a new user to the list.

Delete Opens a dialog for deleting the selected user from the 
list.

Rename Opens a dialog for renaming the selected user.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

The Write Access Password 

You set the password for write access in the Catalog Properties dialog box, on the Sharing tab.

The Write Access Password sets the password for creating a write-protected catalog. 

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Record Fields and Category Fields Tab

The Record Fields tab displays the list of record fields for the current catalog.

The Category Fields tab displays the list of category fields for the current catalog.

Option Description

Name Name of the field, as defined in the properties of the field. 

Type Type of the field, as defined in the properties of the field.

Sorting 
(only Record Fields tab)

Record Field can be used for sorting (yes) or not (no); 
defined in the Field Properties. 

Contain Search 
(only Record Fields tab)

Only for string fields: whether the operators ‘contain’ or 
‘doesn’t contain’ are available for searching.

The Properties button opens a dialog box for defining the selected field. For further information, see Record Field Properties or 
Category Field Properties. 

The Add Field button opens a dialog box for selecting the field to be added.

The Delete button removes the selected field from the list. Certain fields are protected and cannot be deleted. For these fields the 
button is disabled.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Record Field Properties

The Record Fields Properties dialog box includes the following fields/options:

Field/Option Description

Name Name of the field 

Type Field   type   as defined in the list.

Allow User to Edit Allows user to edit the field value.

Initial Value If no other data is available, the field will be filled with an 
initial value (as defined in the list below, for details see 
Initial Values for Fields).

Indexing,
Index for Sorting / Searching

Field can be used for sorting and searching.

Indexing,
Index for Contain Searching

Field can be used for searching by means of the 
operators ‘contain’ or ‘doesn’t contain.’

Linking,
When Adding Assets

When adding assets, the selected record field will be 
filled automatically. (Read One: only the first matching 
field will be used).

Linking,
When Updating Records

When updating records, the selected record field will be 
filled automatically. (Read One: only the first matching 
field will be used).

Linking,
When Saving to Asset

Any changes in field contents will be written back to the 
asset.

Link to Asset Fields,
Link to all Matching Fields

The field whose properties you define in this dialog box 
will be filled by data of all asset fields with the same 
GUID (globally unique identifier) or name and type.

Link to Asset Fields,
Link to the Following Fields

The field whose properties you define in this dialog box 
will be filled by data of the asset fields defined in the list 
below. When activated, a dialog asks you to select a list 
of all matching fields.

The Add button adds a field to the list of linked asset fields.

The Remove button removes the selected field from the list of linked asset fields.

For further information on field linking, see Record Field Linking. 

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Record Field Properties, Linking Record Fields

Some asset formats (such as JPEG) can contain metadata. Cumulus can store and manage this metadata by linking record fields to 
asset fields. The asset fields are provided by the Cumulus application, the Asset Storage modules and the filters. 

You can decide when the linking should happen (when adding assets and/or updating records), and whether changes to the 
metadata should be written back to the asset field. Changed metadata can only be written back to the asset field if this function is 
supported by the filter or Asset Storage module used for cataloging.

If the record field’s type is String, you can also decide whether the linking applies to all (Read All) or only the first (Read One) 
matching asset field. If the Read All option is activated, the values of the linked asset fields are read consecutively. 

You can link a record field to all matching asset fields of an asset or only selected ones. If you select the Link to All Matching 
Fields option, Cumulus will fill the record field with the data from all asset fields that have the same GUID (Globally Unique 
Indentifier) or name and type. 

If you select Link to the Following Fields, Cumulus offers to provide you with a list of all matching fields to start with. 

If Link to the Following Fields is activated, you can add or remove asset fields to the list by clicking the corresponding button. 
When you click the Add button, Cumulus displays a list of available asset fields.

NOTE: Field linking checks for field types. Additionally to its own type a field may be linked only to certain other field types.
Integer fields accept:: String, Boolean, Real
Real fields accept: String, Boolean, Integer
Boolean fields accept: String, Integer, Real
Date fields accept: String
String List fields accept: String
String fields accept: Boolean (true, false), Integer, Real, Date, String List (exact string matching)
Binary fields accept: Audio, Picture 

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Record Field Properties, Initial Value

To add a default text to a field (e.g. the Notes field) of all newly cataloged assets in a certain catalog, you have to enable the option 
Initial Value for the field and enter the text you want to have as default. 

NOTE: Initial Value for String List Field
The initial value of a String List field must be one of the terms which you entered into the String List dialog.

NOTE: Initial Value for Boolean Field
The initial value of a Boolean field is "false" if the text entry field is empty or contains 0 or false. If the text entry field contains any 
other value than 0 or false, the initial value is set to "true". If you work in a multilingual environment it is highly recommended to use 
the value 0 (for false) or 1 (for true) as these are language independent and will work with Cumulus versions of any language.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Category Field Properties

The Category Field Properties includes the following options:

Option Description

Name Name of the field as defined in the field properties. 

Type Type of the field, to be defined using the list opened by the arrow-
down button.

Allow User to Edit Allows the user to edit the field value.

Initial Value If no other data is available, the field will be filled with an initial value 
(as defined in the list below).

The button Edit List is only enabled when the field type is String List. It displays a dialog box for editing the values. (For details, see 
String List.)

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Catalog Properties, Add Field

The Add Field dialog box displays a list of fields that can be added. 

Name Name of the field as defined in the field properties. 

Type Type of the field as defined in the field properties.

Provider Name of filter or Asset Storage module which provides the field.

The following options determine the contents of the list:

Show Cumulus Internal Fields All Cumulus internal fields are shown in the list. 

Show Filter Fields All filter fields are shown in the list.

Show Asset Storage Fields All Asset Storage fields are shown in the list.

The Custom button opens the Record Field Properties dialog box for creating a user-defined field.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Catalog Properties, Link Record Field

If Link to the Following Fields is activated, you can add or remove asset fields by clicking the corresponding button. When you 
click the Add button, a list of available asset fields is displayed.

These asset fields are provided by the Cumulus application, the Asset Storage modules and the filters. 

To link an asset field to a record field:

1. Select the field which you want to link to the record field.

2. Click OK.

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog 

Catalog Properties, Advanced Settings

Catalog Operation

Save Changes Immediately (Safer) Saves catalog changes as soon as they are made. This 
slows overall performance, but is safer.

Save Changes Later (Faster) Saves catalog changes later. This improves performance, 
but in the event of a system crash or power failure, you 
may find that your catalog has lost some changes you 
made, or needs to be repaired. 

Database Statistics

Memory Usage,
Total Used

Displays the memory space used by Cumulus at this 
moment

Memory Usage,
Used by Catalog

Displays the memory space used by the current catalog

Memory Usage,
Required by Catalog

Displays the minimum memory space required for the 
current catalog

Memory Usage,
Recommended for Catalog

Displays the memory space recommended for the current 
catalog

Disk Usage,
Records Deleted

Displays the number of records that are deleted but could 
still be recovered

Disk Usage,
Compression Would Reclaim

Displays the memory space that would be set free by 
compressing the catalog

Disk Usage,
Space Free On Disk

Displays the available disk space (see Elements 
Determining Record Size)

{button ,AL(`configure',0,`',`')}    See also 
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 Configuring a Catalog
Elements Determining Record Size

An empty Cumulus catalog is 590 KBs in size and requires about 80 KBs of RAM. To ensure fast searching and retrieval of 
information, Cumulus indexes all record data. This index grows as the number of records in the catalog increases and can become 
quite large for records that contain a lot of text.

Three main elements determine the record size:

· basic file information

Cumulus automatically captures specific types of information during the cataloging process. Basic file information is one of the 
smallest parts of a record and does not vary significantly in size.

· file-type-specific information

Certain file types can contain additional information that Cumulus saves during cataloging. Available only for a specific file 
types, this information can include font lists used in a file, the languages used in a movie, or other relevant details. File-type 
specific information can be viewed in the Asset Information window. 

· text in the record fields

To ensure fast searching and retrieval of information, Cumulus indexes all record data, including text in the Notes field. 
Unusually large text amounts in the record fields can slow down cataloging performance. Keep text as brief as possible and 
avoid using unneeded words like the, a or an. You can enter up to 32 KB of information into the Notes field, but cataloging 
speed decreases as the amount of text increases. 

· thumbnail size and quality

The thumbnail size that you select when setting up your catalog influences the size of a typical record and thus overall 
performance. Since Cumulus uses JPEG compression for grayscale and color thumbnails, the size of individual records varies 
depending on the thumbnail content. Higher quality thumbnails typically create larger records

For example, a catalog having 4,000 records and thumbnail quality of 128 x 128 pixels is approximately 50 MB in size. The 
same catalog with thumbnail quality of 192 x 192 pixels is 70 MB in size.

Disk Space Requirement (in Bytes) for Thumbnails Created at 96 x 96 Pixels

Color Mode Normal High

Line Art 428 1247

Grayscale 1392 2998

Color 1455 3612

Disk Space Requirement (in Bytes) for Thumbnails Created at 128 x 128 Pixels

Color Mode Normal High

Line Art 962 1955

Grayscale 1795 4374

Color 1909 5250

Disk Space Requirement (in Bytes) for Thumbnails Created at 192 x 192 Pixels

Color Mode Normal High

Line Art 1910 3366

Grayscale 2700 7660

Color 2849 9316

{button ,AL(`administrator',0,`',`')}    See also 
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Compressing Catalogs

Deleting or changing records creates unused space in a catalog. Although unused space does not decrease catalog performance, it 
can make a catalog unnecessarily large. You can reclaim this unused space by compressing the catalog.

While a catalog is being compressed it cannot be shared with clients. You should compress a catalog when it is not being used.

Compressing permanently deletes records from a catalog. After you compress the catalog, you will not be able to recover previously 
deleted records. 

To compress the catalog:

1. Select Catalog => Compress. 

A confirmation dialog appears, informing you that deleted records will no longer be recoverable after compression.

2. Click OK to proceed.

If any clients are still using the catalog, Cumulus asks you to disconnect them.

Cumulus compresses the catalog. The amount of time this takes depends on the size of the catalog and the amount of space 
to reclaim. 

{button ,AL(`administrator',0,`',`')}    See also 
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Backing Up Catalogs

You back up a catalog by copying it. You can do this employing your operating system but then the catalog has to be closed. You 
can back up an open catalog, if you employ the Cumulus Backup feature. 

To back up a catalog using the Backup feature with Single User Edition:

1. In the open catalog that you wish to back up select Catalog => Backup.

The Backup window opens. 

The name for the backup catalog file defaults to the same name as the original catalog file with the file name extension .bak. 
You may also choose the file name extension .ccf. There is no difference in format, but then you may need to choose a different 
name or a special backup location to avoid confusions with the original catalog.

2. Make your selection and click Save. The catalog is saved to disk.

To back up a catalog using the Backup feature with Workgroup and Enterprise Edition:

1. In the open catalog that you wish to back up select Catalog => Backup.

The Backup window opens. 

2. Enter path of location, file name and file name extension (.bak or .ccf).

It is recommended to use the file name extension .bak. You may also choose the file name extension .ccf. There is no 
difference in format, but then you may need to choose a different name or a special backup location to avoid confusions with 
the original catalog. 

3. Click OK. The catalog is saved to disk. 

Backed up catalogs may be opened as you would open any other catalog. Only catalogs backed up as 'Minimal Backups' with 
former Cumulus versions require a few extra steps, as described under Restoring a Backed Up Catalog.

{button ,AL(`administrator',0,`',`')}    See also 



 Catalog Administration
Recovering Deleted Records

You can recover deleted records from a catalog if:

· The file was not deleted along with the record. If the original file was deleted, the record cannot be recovered.

· Keep Deleted Records Recoverable is activated for the catalog in the General section of the Catalog Properties.

· The catalog was not compressed after the records were deleted.

To recover deleted records:

1. Open the catalog.

2. Select Catalog => Recover Deleted Records.

Cumulus recovers all available deleted records and displays them in the Collection window. You can then browse through them 
and delete the ones you do not need.

{button ,AL(`administrator',0,`',`')}    See also 
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Copying Catalogs 

You can copy, divide or merge catalogs without affecting the original assets. 

Copy or move a Cumulus catalog as you would any other file, but be aware of the following:

· Do not move or copy a catalog file while it is open. Doing so may result in inconsistent catalogs.

· Before copying a catalog, close the Collection window and save any changes. 

{button ,AL(`administrator',0,`',`')}    See also 
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Empty Copy of a Catalog

To create an empty copy of a catalog:

1. Open the catalog.

2. Select Catalog => New Empty Copy.

Cumulus creates a new empty copy of the active catalog. The catalog properties of the new catalog are the same as those of 
the active catalog.

{button ,AL(`administrator',0,`',`')}    See also 
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Setting Catalog as Default

To set a catalog as default:

1. Open the catalog.

2. Select Catalog => Set As Default.

The Catalog Properties of the current catalog will be used when you create a new catalog.

NOTE: Workgroup Edition Users Only
If the current catalog is a local catalog, the default is set for creating new catalogs on the local machine. If the current catalog is 
a remote catalog, the default is set for creating new catalogs on the Cumulus Server machine

{button ,AL(`administrator',0,`',`')}    See also 
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Restoring Factory Defaults

To restore the defaults for new catalogs to the ‘out of the box’ defaults:

1. Open a catalog.

2. Select Catalog => Restore Factory Defaults.

The defaults set by Canto will be used when you create a new catalog. These defaults are the ’out of the box’ settings for 
Catalog Properties. 

{button ,AL(`administrator',0,`',`')}    See also 



 Catalog Administration
Converting Catalogs 

If the corresponding database connector modules are installed you can convert a catalog to adapt to another database engine.

To convert a catalog:

1. Open the catalog.

2. Select Catalog => Convert To.

A list of available options is displayed.

3. Select the database engine you want the catalog to be converted to.

The Copy Catalog dialog appears.

4. Name the catalog using the Connect String format which you would use for creating a new catalog based on the selected 
engine; e.g. for ODBC: 
DSN= xyz;UID=xyz;PWD=yxz;CAT= new catalog name
or for Oracle:
UID=xyz;PWD=yxz;CAT= new catalog name

For further details on the Connect String format see the documentation for the corresponding connector.

5. Click OK . 

The catalog will be copied and the copy will be adapted to the other database engine. To have access to the new catalog, you have 
to add it to the list of catalogs in the Catalog Access window. 

{button ,AL(`administrator',0,`',`')}    See also 
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Dividing Catalogs 

You can copy, divide or merge catalogs without affecting the original assets.

You may want to divide a catalog into two or more catalogs if any of the following conditions apply:

· The catalog has become too large. Each Cumulus catalog file can be up to 4 GB in size.

· The number of records in the catalog reduces performance significantly.

Try to divide records into logical, distinct groups. You can divide a catalog in one of two ways:

· Move small numbers of records by dragging and dropping them from one catalog to another.

· Move large portions of a catalog with Export and Import in the File menu.

{button ,AL(`administrator',0,`',`')}    See also 
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Merging Catalogs 

You can copy, divide or merge catalogs without affecting the original assets.

You can merge multiple catalogs into a single catalog by copying first the categories and then the records from one catalog to the 
other. You can use either of the following methods:

· Drag and drop files between catalogs.

· Use the Export and Import commands in the File menu.

When merging one or more catalogs, remember the following:

· If the catalogs have identical category names and do not contain duplicate categories, you can drag and drop records from one 
catalog to another.

· If the catalogs share common categories but the records or hierarchies are different, move each category individually.

· If the catalogs have completely different categories, copy all categories to the new catalog.

{button ,AL(`administrator',0,`',`')}    See also 
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Repairing a Catalog

If a catalog is damaged, you can repair it with the Rebuild command. Repairing a catalog can take a long time, depending on the 
size of the catalog.

To repair a catalog:

1. Select Catalog => Rebuild.

2. If you are sure you want to recreate your catalog, click OK at the prompt.

{button ,AL(`administrator',0,`',`')}    See also 
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Restoring a Backed-Up Catalog (Single User Edition)

Only catalogs backed up as 'Minimal Backups' with Cumulus versions prior 5.5 are to be restored. You can restore a catalog you 
previously backed up.

To restore a backed-up catalog:

1. Select File => Open.

Navigate to the 'Minimal Backup' catalog file. You may have to select Cumulus Backup Files (.bak) from the drop-down list to 
see the file.

2. Click Open. 

Cumulus confirms that you would like to rebuild a new catalog from the backup. 

3. Name the new catalog file and click Save. 

Once the catalog has been rebuilt, it opens. (The name you give the catalog here is a file name, not a catalog name. The 
catalog name will be included in the backed-up information.)

Remember that by rebuilding a compressed catalog, you are creating a new copy of it. If the original version of the catalog is still on 
your computer, keep track of which version of the file you’re using.

{button ,AL(`administrator',0,`',`')}    See also 
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Restoring a Backed-Up Catalog for Workgroups

Only catalogs backed up as 'Minimal Backups' with Cumulus versions prior 5.5 are to be restored. Backed-up catalogs are restored 
from a Client logged on as Cumulus Administrator to the Server.

To restore a backed-up catalog:

1. Log on as Cumulus Administrator to the Cumulus Server (see Logging On as Administrator).

2. In the Catalog Access window, click Restore.

The Restore Catalog dialog box appears

3. In the Enter remote path to catalog field, enter the location where the backed-up catalog is stored (file extension .bak).
Since catalogs are stored on the computer running the Cumulus Server, the path you enter refers to a location on that 
computer.

5. Click OK.

Cumulus restores the catalog and adds it to the list of catalogs in the Catalog Access window.

6. To make this catalog available to Clients, select it and enable Share Catalog.

{button ,AL(`administrator',0,`',`')}    See also 
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Updating Catalogs from Earlier Versions
Catalogs created with Cumulus versions earlier than 5 must be updated before they can be used with Cumulus 5. The Cumulus 
Catalog Converter converts older catalogs into a format compatible with the latest Cumulus version. The converter for Windows 
converts only catalogs from Cumulus 4, because that is the only previous Cumulus version for Windows.

To convert a catalog from Cumulus 4:

1. Navigate to the location where you installed Cumulus 5 and double-click Catalog Converter.exe. The Cumulus Catalog to 
Convert dialog box opens. 

2. Select the Cumulus 4 catalog you want to convert and click Open. 

The New Empty Copy dialog box appears. Don’t worry, this dialog invokes the right function. The new catalog won’t be empty.

3. Select a name and location for the converted Cumulus 5 catalog and click Save. A progress bar appears to indicate the status 
of the conversion.

Once the progress bar disappears, your catalog is converted to a new Cumulus 5 catalog saved under the name and location 
you selected.

NOTE: If any problems occur while converting a catalog, it might help to open the catalog with your former Cumulus version before 
converting the catalog and envoke the function Repair from the Catalog menu. 

{button ,AL(`administrator',0,`',`')}    See also 



Catalog Administration
Adding New Users or Groups to a Catalog

Enter the name of the user or group you want to add.

NOTE: If you want to add (or rename) users, make sure the new names match the user names for logging on (Domains)



Cumulus Automation

Scripting API

Scripting API (Application Programming Interface) is based on the support of OLE Automation in Windows. In general, all of the 
functions and content of Cumulus (collections, records, etc.) can be accessed by means of these two technologies. These Scripting 
API capabilities offer the potential to realize solutions specific to your situation, from simple extension of basic Cumulus functions to 
complex integration of Cumulus with other applications.

OLE Automation is supported by 

· Microsoft Visual Basic

· Microsoft Visual C++

· Microsoft Visual J++

· Borland Delphi

· PowerSoft PowerBuilder

· Userland’s Frontier

The standard Cumulus installation comes with Cumulus API examples that you can use or modify to suit your needs. 

The descriptions of various Scripting API examples that are included with Cumulus may give you some ideas about how you can 
apply Cumulus automation to your workflow. The source code for all examples described here is also included, so you can change it 
to adapt to your local processes. For further information, start with the Index of Included Cumulus API Examples.

NOTE: Additional Functions Folder
The examples included with Cumulus are assigned to certain menus by default or stored in the Additional Functions folder 
(subfolder of the Menu Commands folder). You can easily assign a function to a menu by moving the example to the folder of the 
menu (subfolders of Menu Commands folder). You can also assign a function to a context menus (alternate mouse button 
actions) by moving them to the corresponding folders: Category Context Menu, Selected Category Context Menu, Asset Context 
Menu and Preview Context Menu (subfolders of Menu Commands folder).

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Find Via Matching Categories

Finds records in the active catalog that are assigned to some or all of the same categories as the selected records.

To find via matching categories:

1. Select one or more records.

2. Select Collection (default) => Find Via Matching Categories. 

A dialog box asks if you want records that have some assignments in common or the exact same assignments.

3. Click the search type of your choice. 

The records are found and replace the current collection.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Join Duplicate Categories

Searches the active catalog for duplicate categories. If any are found, the contents are merged into one of the categories. The 
remaining category is renamed to indicate that it is a duplicate. You are given the option of deleting the duplicate categories.

To join duplicate categories:

1. Open the catalog in which you want to search for duplicate categories.

2. Select Category (default) => Join Duplicate Categories. 

The script searches for duplicates. If found, the contents are merged into the first occurrence of the category, and the 
duplicates are renamed. You are then given the option of deleting them.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
New Category from Date

Creates a new category in the active catalog that uses the current date and time for its name.

To create a new category from the current date:

1. Open the catalog in which you want to add the new category.

2. Select the assigend menu => New Category from Date. 

The new category is added to the categories list.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Export Records To Access

Exports the selected records in the active catalog to a Microsoft Access database file. Thumbnail data is included in the export as a 
BMP binary data stream (not as an OLE object, to view it you have to write a program or application).

To export records to Access:

1. Select one or more records.

2. Select Special (default) => Export Records To Access. 

A dialog box opens from which you can choose one of the following options:

- Append record if table exists
- Replace table if it exists

3. Choose an option and click Start Export. 

A dialog box appears from which you can choose a name and location to save the file.

4. Name the file and click Save. 

The data is exported.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Thumbnails To BMP Files

Exports the thumbnail images of the selected records in the active catalog to Windows (.bmp) files.

To export thumbnails:

1. Select one or more records.

2. Select the assigend menu => Thumbnails To BMP Files. 

3. Click Export.

A dialog box opens from which you can choose a file name and location. 

4. Choose a location to save the file and click OK.

The thumbnails are saved.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Find Via Similar Thumbnails

This application is similar in nature to using the Find Window to locate a similar thumbnail. The difference is that this application can 
find similar thumbnails for more than one record at a time. It searches the entire catalog.

To find via similar thumbnails:

1. Select one or more records.

2. Select the assigend menu => Find Via Similar Thumbnails. 

Records that have thumbnails that are similar in brightness and contrast to those in the selection are found and replace the 
currect collection.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Live Search

Continually runs the search query that was active in the catalog’s Find window when the application was launched.

To use Live Search:

1. Select Collection (default) => Live Search.

2. Select a time interval for the application to repeat the search and click Start. 

The search is repeated at the interval specified.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Picture to Thumbnails

Replaces the thumbnails of the selected records with a chosen BMP, JPEG or GIF image.

To replace thumbnails with other pictures:

1. Select one or more records for which you wish to select a new thumbnail image.

2. Select the assigend menu => Picture to Thumbnails. 

3. Click Assign Thumbnail.

A dialog box appears from which you can choose an image file.

4. Choose an image and click OK. 

The thumbnails are replaced by the chosen image at the thumbnail size specified in the Catalog Properties window.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Show Category Folder

Works only on directory categories. A window with the corresponding directory is opened.

To show the category folder(s):

1. Select one or more directory categories.

2. Select Category (default) => Show Category Folder.

If more than one category is selected, a window will be opened for each category.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Assign Selected Categories

Assigns all records selected in the Record pane to the categories selected in the Category pane, or vice versa. (This is the opposite 
of Detach Selected Categories.)

To assign records to multiple categories:

1. Select one or more records.

2. Select one or more categories to which you want to assign the selected records.

3. Select Asset (default) => Assign Selected Categories.

The records are assigned to each of the categories in the selection.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Detach From Selected Categories

Detaches all records selected in the Record pane from the categories selected in the Category pane, or vice versa. (This is the 
opposite of Assign Selected Categories.)

To detach records from multiple categories:

1. Select one or more records.

2. Select one or more categories from which you want to detach the selected records.

3. Select Asset (default) => Detach from Selected Categories.

The records are detached from each of the categories in the selection.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Assign Status to Records

Assigns a status to a selection of records. You can also automatically assign status terms in the Cataloging Options dialog box.

To assign a status to multiple records:

1. Select one or more records.

2. Select the assigend menu => Assign Status to Records. 

A dialog box opens from which you can see a list of the current status terms in the catalog.

3. Select a status term from the list and click OK. 

The term is applied to each record in the selection. 

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Check After Location Changed

Updates records in the active catalog to reflect a new location of their assets. This is useful if you have cataloged assets from a 
remote drive or volume that has since been renamed or have simply moved cataloged assets to a new location. Without this 
application, the records would still "point" to the old asset paths. This application does not overwrite, move or otherwise affect asset 
files at all.

To update records to their new locations:

1. Select one of the records in the active catalog that still points to the old location of the assets.

2. Select Asset (default) => CheckAfterLocationChanged. 

A dialog box appears asking you to locate the selected asset in its new location.

3. Find the selected record’s asset on the newly renamed drive or volume and click Open. A window remains on the screen from 
which you can select some additional options for the update. 

4. After you select the options you want, click Check Now. 

The script searches the active catalog for all of the records that point to the old location of the assets and updates them to the 
new location.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Count File Formats

Creates a text listing of the asset file types of the current collection of records in the active catalog. Each entry also lists the number 
of records whose assets are of that type. You can copy the selection and paste it into other applications using the standard copy and 
paste techniques.

To count the file formats in the active catalog:

1. Select one or more records.

2. Select the assigend menu    => Count File Formats. 

The file formats are counted and displayed in a text window.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Hot Folder

Watches a single asset folder for additions. Catalogs any assets added to the folder into the active catalog. (Works only on NTFS.)

To use Hot Folder:

1. Select Special (default) => Hot Folder. 

A window appears from which you can select a folder to watch.

2. Select a folder and a time interval for the script to check the folder.

3. Click Start. (You can also drag a folder to the dialog box, which automatically selects the folder to be watched.)

NOTE: Hot Folder & Central Location
Do not activate the Hot Folder Function along with Central Location. With Central Location activated, the same assets are always 
cataloged as duplicates. With both activated together, all assets in the selected folder would be cataloged whenever an asset is 
added to the folder.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Move Folder

Moves a folder of assets (and its subfolders) and updates the assets’ records to reflect the folder’s new location.

NOTE: The subfolders are dissolved when you move folders with this application.

To move a folder of assets:

1. Select Special (default) => Move Folder. 

A dialog opens from which you can select the folder you wish to move (as well as where to move it).

2. Choose the folder’s current location in the top field. (You can use the button to the right of the field to browse to the location.)

3. Choose the folder’s new location in the bottom field. (You can use the button to the right of the field to browse to the location.)

4. Click Move.

The folder and its contents are moved. If a newer version of an asset being moved would be overwritten by an older version in 
the move, you are prompted to confirm the action.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Optimization 

Cumulus includes applets for optimizing your cataloging process.

Optimize for Safety presents a number of options from which you can select settings that favor data safety over performance:

1. Select the assigend menu => Optimize for Safety.

The options window appears.

2. Select the options you want and click OK. 

The catalog options are changed.

Optimize for Speed presents a number of options from which you can select settings that favor performance over data safety:

1. Select the assigend menu => Optimize for Speed. 

The options window appears.

2. Select the options you want and click OK. 

The catalog options are changed.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Satellite

Displays a window that shows an at-a-glance view of the selected record, including thumbnail, categories listing and notes.

To use Satellite:

1. Select the assigend menu => Satellite. 

The Satellite window appears. 

2. Arrange the window so that you can see it and the catalog window.

When you select a record in the Collection window, the record’s information appears in the Satellite window.

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Server Log Properties: Logging of Catalog Activities

Presents a number of options from which you can enable a log file and define its content.

NOTE: This script is only available for Workgroup and Enterprise clients under Windows and cannot be employed for Mac OS 
servers.

To enable and define the logging for a catalog:

1. Select assigned menu =>Server Log Properties. The Server Log Properties window appears.

In the field Default Log Folder you may enter another folder to serve as the default folder for log files.

2. Click Enable Logging.

In the field Log Folder you may enter another folder than the default folder to serve as the folder for the log file(s) of the 
current catalog.

3. If you want a separate log file for each day, enable Daily Log File. Daily log files have the advantage that you can delete those 
you don’t need any longer.

4. Select the columns you want the log file to contain as well as their sequence by clicking the arrow buttons. To delete a column, 
click the minus option in the list: -

5. Select the events you want the log file to contain by check marking them.

6. Click OK. The catalog’s activities will be logged in a file named after the catalog. If you enabled Daily Log File the date is added 
to the name (year-month-day).

{button ,AL(`automation',0,`',`')}    See also 



 Cumulus Automation
Prepare To Write IPTC

If you want to write back IPTC data to assets, your Cataloging Options (entry for the IPTC filter activated) and the catalog managing 
these assets must be prepared for this feature. IPTC record fields have to be added and their properties have to be enabled for field 
linking, also Writing Metadata to Asset must be activated in the General Catalog Properties. 

The script Prepare To Write IPTC makes the process of preparation easy. This script prepares the Cataloging Options of the user 
(who started the script) to be able to write IPTC data back to assets. For Single User and administrators of the Workgroup and 
Enterprise Edition it also prepares the current catalog. 

1. Select Special (default) => Prepare To Write IPTC. 

The dialog window opens.

2. Select the options you want and click OK.

A dialog opens displaying the fields that will be added to the catalog.

3. Click OK. 

A message will inform you when script was finished successfully.

{button ,AL(`automation',0,`',`')}    See also 



Cumulus Workgroup/Enterprise Administration

If you have a Workgroup or Enterprise edition of Cumulus, you can:

· Log on to the Server 

· Open a Workgroup catalog 

If you have a Workgroup or Enterprise edition of Cumulus as well as a Single User edition, you can use your Single User edition as 
a client to connect to the Cumulus Server.

You need to have a Workgroup or Enterprise edition of Cumulus and administrator rights in order to be able to:

· Log on as Cumulus Administrator

· Use the Catalog Access window to administer catalogs

· Create a catalog 

· Add a catalog 

· Disconnect Clients 

For information on solving problems, see Troubleshooting and Technical Support.

{button ,AL(`administrator_w',0,`',`')}    See also 



 Cumulus Workgroup/Enterprise Administration
Logging On to the Cumulus Server

Note: If you have a Workgroup or Enterprise edition of Cumulus as well as a Single User edition, you can use your Single User 
edition as a client to connect to the Cumulus Server.

To log on to the Cumulus Server from a Client:

1. Select File => Connect to Server.

The Connect to Server dialog box appears.

2. Using the dropdown menu in the Server field, select the Server you wish to connect to. All currently active Cumulus Servers in 
the network appear in this list. 

If your Cumulus Administrator specified a custom TCP/IP port number for the Client-Server connection, click Options and enter 
the number in the dialog that appears. Then click OK to return to the Connect to Server dialog box.

3. Select either Guest or Registered User. If connecting as a registered user, type your user name and password. Your Cumulus 
Administrator can help you determine which way you should log on. 

4. To have Cumulus remember your password for future logons, select Remember Password. 

5. Click OK. 

The Catalog Access window appears.

6. Select a catalog and click OK. 

To find out how to log on to the Server as Cumulus Administrator, see Logging On as Administrator.



 Cumulus Workgroup/Enterprise Administration
Logging On as Administrator

To log on to the Cumulus Server as the Cumulus Administrator, you connect to the Server from a Cumulus Client. 

To log on to the Cumulus Server:

1. From any Cumulus Client, select File => Connect to Server.

The Connect to Server dialog box appears.

2. To change or enter your server’s TCP/IP port number, click Options. 

The Network Setup Dialog appears.

By default, Cumulus automatically finds an open port number and configures Server and Clients to use it. See your 
Administrator Guide for information on specifying a custom port number.
To accept the default setting, click OK. 
If you previously changed the port number in the Server Properties dialog, type this port number and click OK. 
To restore the default port number, click Default and click OK. 

Every Client must specify a port number in order to be able to connect to the Server. If you are using a custom port number, 
make sure to tell every user which number they need to enter.

4. Using the dropdown menu in the Server field, select the Server you wish to connect to. All currently active Cumulus Servers in 
the network appear in this list. 

5. Under Connect as, select Registered User. 

6. Type the user name of the Cumulus Administrator in the Name field and the corresponding password in the Password field. 

7. Click OK.

Note: For more information on the default Administrator user name and password, see the Cumulus Administrator Guide.

The Catalog Access window appears. It lists all catalogs that are currently administered by the Cumulus Server. To open a 
catalog, highlight it and click Open.

{button ,AL(`administrator_w',0,`',`')}    See also 



 Cumulus Workgroup/Enterprise Administration
Creating Catalogs for Workgroups

New catalogs are created from a Client logged on as Cumulus Administrator to the Server.

To create new catalogs:

1. Log on as Cumulus Administrator to the Cumulus Server (see Logging On as Administrator).

2. In the Catalog Access window, click New.

The New Catalog dialog box appears

3. In the Enter remote path to catalog field, enter the location where the catalog will be stored.
Since catalogs are stored on the computer running the Cumulus Server, the path you enter refers to a location on that 
computer.

5. Click OK.

The new catalog appears in the list of catalogs in the Catalog Access window.

6. To make a catalog available to Clients, select it and enable Share Catalog.

You can also do the following:

· Configure the catalog 

· Customize application preferences 

· Set cataloging options 

· Customize the view

You may want to create multiple catalogs if you encounter any of the following conditions:

· Assets fall into logically unrelated groups. 

· The catalog file size becomes too large. Cumulus catalogs are limited to 4 GB. The number of records this permits depends 
upon the thumbnail quality/size settings and the amount of text in each record (e.g., in the Notes field).

{button ,AL(`administrator_w',0,`',`')}    See also 



 Cumulus Workgroup/Enterprise Administration
Adding a Catalog

You can add an existing catalog to the list of catalogs administered by the Cumulus Server. Catalogs to be administered by the 
Server must be stored locally on the computer running the Server. If the catalog is not currently stored on that computer, move or 
copy it there before proceeding.

To add a catalog:

1. Log on as Cumulus Administrator to the Cumulus Server (see Logging On as Administrator).

2. In the Catalog Access window, click Add.

The Open Catalog dialog box appears.

3. Enter the name and full path of the existing catalog in the Enter remote path to catalog field.
Since catalogs are stored on the computer running the Cumulus Server, the path you enter refers to a location on that 
computer.

4. Click OK.

The catalog appears in the list of catalogs administered by the Cumulus Server. If you want Clients to be able to access this catalog, 
highlight it and enable Share Catalog.

{button ,AL(`administrator_w',0,`',`')}    See also 



 Cumulus Workgroup/Enterprise Administration
Using the Catalog Access Window 

The Catalog Access window is the starting point for performing numerous administrative tasks. The Catalog Access window has the 
following buttons and options:

Button Description

Open Opens the selected catalog files. Opening a catalog as 
the Cumulus Administrator is the first step to modifying 
catalog properties.

New Opens a dialog for creating a new catalog.

Add Opens a dialog for adding an existing catalog to be 
administered by the Cumulus Server.

Remove Removes catalogs from the list Cumulus Clients see 
when logging on the Cumulus Server. If one or more 
Clients are still connected to this catalog, the Disconnect 
Client dialog box appears. 

The catalog is not deleted, but it is no longer 
administered by the Cumulus Server and thus no longer 
available to Clients.

Restore Opens a dialog for restoring a backup copy of a catalog 
to the catalog file you specify.

Option Description

Properties of Selected 
Catalog, Share Catalog

Enabling this option makes a catalog available to 
Cumulus Clients. For more information, see Catalog 
Properties, Sharing Tab.

Properties of Selected 
Catalog, Publish Catalog 
to Internet

Enabling this option is the first step to publishing a 
catalog on the Internet. 

{button ,AL(`administrator_w',0,`',`')}    See also 



 Cumulus Workgroup/Enterprise Administration
Monitoring Catalog Activity

You can monitor catalog activity from a special window.

To access the Activity Monitor window:

1. Select Catalog => Activity Monitor. 

The Activity Monitor window appears.

This window monitors:

· how much work is being done in the catalog 

· which users are connected to the catalog.

The Catalog Activity bar at the top of the window indicates the amount of Server resources currently being used by the active 
catalog. The table below this bar contains all users currently connected to the catalog as well as the name/IP address of the 
computer from which they’re connected.

You can also use the Activity Monitor to disconnect users from the catalog. 

{button ,AL(`administrator_w',0,`',`')}    See also 



 Cumulus Workgroup/Enterprise Administration
Disconnecting Users

You need to disconnect clients before you perform various database repair operations, such as removing, compressing, or restoring 
catalogs. When you disconnect Clients, you can specify the time period before they are removed and the message they see when 
they are removed.

To disconnect Clients:

1. Select Catalog => Activity Monitor. 

The Activity Monitor window appears.

2. Click Disconnect User.

When the Disconnect User dialog box appears, enter a number of minutes in the text box.

3. Enter a message in the Message field. 

4. Click OK.

{button ,AL(`administrator_w',0,`',`')}    See also 



Working with the Cumulus Vault (Workgroup and Enterprise Edition only)
Checking Assets In

When you’re finished editing an asset that you checked out of the Vault, it needs to be checked back in to update the record’s 
reference and allow other users to access it.

To check an asset into the Vault:

1. Highlight the record associated with the asset in the catalog.

2. Select Asset => Check In.

The Version Comment dialog box appears for you to enter comments on the version you’re checking in (such as changes you 
made, reasons, etc.). Your name and the asset’s name appear automatically in the fields at the top of the dialog.

3. Type your comments and click OK.

Cumulus checks the copies your version of the asset back into the Vault as the latest version and updates the associated record to 
reflect your changes.



Working with the Cumulus Vault (Workgroup and Enterprise Edition only)
Checking Assets Out

When you check an asset out of the Vault, Cumulus copies the latest version currently stored in the Vault to wherever you specify. It 
then locks the associated record in the catalog so that no other users may access the asset while you’re working on it. 

To check an asset out of the Vault:

1. Select the record associated with the asset you would like to check out.

2. Select Asset => Check Out.

A dialog appears for you to select a saving location for the checked-out asset.

3. Select the desired location and click OK.

Once you’re finished working with the asset, it needs to be checked back in.



Working with the Cumulus Vault (Workgroup and Enterprise Edition only)
Viewing Asset Version History

The Version History dialog box gives you an at-a-glance view of an asset’s version history.

To open the Version History dialog box:

1. Select the record associated with the asset whose version history you would like to view.

2. Select Asset => Show History.

The Version History dialog box appears. It shows you how many versions exist, who checked each version in and out, and when 
each version was checked in. It also includes an area containing the full-text comments the checking-in user made when checking 
the version in. 

To view the comments on a particular version:

1. Highlight the desired version in the table.

The comments appear in the Comment area below the table.



Working with the Cumulus Vault (Workgroup and Enterprise Edition only)
Getting Asset Versions from the Vault

When you’re working with a catalog that’s connected to the Vault, the assets you’re working with may exist in multiple versions. This 
arrangement affects some of the commands that let you manage assets from within the Cumulus application. When you want to 
preview, delete, mail, copy, or move assets stored in the Vault, Cumulus prompts you to select the desired version of the asset.

To get the desired asset version from the Vault:

1. Select the record associated with the asset you want to get.

2. Select Asset => Preview, Mail, Copy or Move. (NOTE: Moving an asset version from the Vault also deletes it from the Vault. 
To be on the safe side, select Copy to get a copy of the desired version and leave the original untouched.)

The Select a Version dialog box appears. 

3. Under Select a Version to Get, highlight the version you’re interested in.

Any comments the checking-in user made on the select version appear in the Comment area of the Select a Version dialog. 
You can thus quickly see whether you’ve got the version you’re looking for.

4. Click OK.

Cumulus starts the process for previewing, mailing, copying or moving the selected version, depending on your menu 
selection.

If you know you always want to get the latest version, you can configure your catalog so that Cumulus skips the Select a Version 
dialog and just gives it to you.

To always get the latest version:

1. Select Cataloging => Cataloging Options.

The Cataloging Options window appears.

2. Click the Assets tab.

3. Under Asset Storage Modules, highlight Cumulus Vault and click Properties.

The Cumulus Vault Properties dialog box appears.

4. Under When Getting Assets, enable Always Get Latest Version and click OK.

5. In the Cataloging Options window, click Apply to save your changes.



Working with the Cumulus Vault (Workgroup and Enterprise Edition only)
Deleting Asset Versions from the Vault

When you want to delete an asset that’s stored the Vault, the asset in question may exist in multiple versions. You have the option of 
deleting selected versions of the asset or all versions.

To delete selected asset versions(s) from the Vault:

1. Select the record associated with the asset you want to delete.

2. Select Edit => Delete.

The Select a Version dialog box appears. 

3. Under Select a Version to Delete, highlight the version you’d like to delete.

Any comments the checking-in user made on the select version appear in the Comment area of the Select a Version dialog. 
You can thus quickly see whether you’ve got the version you’re looking for.

If you decide to delete all versions now, click Delete All.

4. Click OK.

The Delete Warning dialog appears, asking if you would like to delete just the record or the record and its associated asset.

5. Click Delete Record and Asset. This ensures that the asset doesn’t take up space in the Vault when it’s not associated with a 
record in the catalog.

Cumulus deletes the record and the asset versions you selected.

If you know you always want to delete all versions, you can configure your catalog so that Cumulus skips the Select a Version dialog 
and starts deleting.

To always delete all versions:

1. Select Cataloging => Cataloging Options.

The Cataloging Options window appears.

2. Click the Assets tab.

3. Under Asset Storage Modules, highlight Cumulus Vault and click Properties.

The Cumulus Vault Properties dialog box appears.

4. Under When Deleting Assets, enable Always Delete All Versions and click OK.

5. In the Cataloging Options window, click Apply to save your changes.



 Cumulus
Accelerator Keys

Accelerator keys are keyboard shortcuts to common menu commands and options. 

If you want to... Press...

Abort previews Ctrl + full stop ( . )

Browse categories or records Ctrl + arrow keys

Catalog assets Ctrl + B

Change to Palette Mode (and vice versa) Ctrl + Shift + P

Connect to a Cumulus Server Ctrl + Shift + O

Copy information Ctrl + C

Close a catalog Ctrl + F4

Create a new empty collection Ctrl + Shift + N

Cut information Ctrl + X

Delete selected record from collection or delete 
selected category from catalog

Delete

Delete selected record and optionally its asset from 
catalog

Ctrl + Delete

Display all records in a catalog Ctrl + G

Display the asset information of a selected record Ctrl + I or Alt + Return

Display the IPTC information of a selected record Ctrl + Shift + I

Execute a search using the Find window Ctrl + F

Launch context-sensitive help F1

Move to the next dialog box tab Ctrl + Tab

Move to the previous dialog box tab Ctrl + Shift + Tab

Paste information Ctrl + V

Preview a selected asset Ctrl + Y

Print a selected item Ctrl + P

Select/deselect category or record Ctrl + Spacebar

Select/deselect multiple records or categories Shift + arrow keys

Select all records or categories Ctrl + A

Show the location of a record's asset Ctrl + R 

Switch between the Category and Record panes in the 
Collection window 

Shift + Tab

View the asset information for a selected record Ctrl + I or Alt + Return

View records assigned to the selected category Alt + arrow keys

Zoom in on the Preview window Ctrl + plus sign (+) 

Zoom out of the Preview window Ctrl + minus sign (-) 



 Contacting Us
Technical Support

To provide you with easily accessible, first-class assistance, Canto has partnerships with numerous distributors and resellers around 
the world. Technical support from your distributor via e-mail is free of charge if you are a registered Cumulus user. For information 
on how to contact the distributor or reseller in your area, inquire where you purchased Cumulus or see Canto's Web site: 
www.canto.com

Before submitting your question, please review the support form in the documentation folder on your Cumulus CD-ROM to make 
sure that you provide technical support with the appropriate information.

If you are a registered Cumulus user and your distributor does not provide support for Cumulus, you may direct your questions to:

North and South America
415-703-9823 (Fax)
support@canto.com

Europe, Australia, Africa and Asia
+49-30 390 485 55 (Fax)
support@canto.de

You also have the option of purchasing a Canto Service Agreement, which not only includes priority technical support by telephone, 
but also supplemental benefits such as access to new filters and a monthly bulletin full of helpful tips, technical news and further 
information on Canto products. Please visit Canto's Web site (www.canto.com) to find out where to register for a Service Agreement 
and receive this extra support.

{button ,AL(`intro',0,`',`')}    See also 
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*.cce

The Cumulus Category Exchange file format, which Cumulus creates when exporting category information to other catalogs or 
applications. When you use the Cumulus import function, the categories to be imported must be held in a previously exported 
.cce file.



*.ccf

The Cumulus Catalog file format, which Cumulus creates to manage cataloged digital media (or assets).



*.cfe

The Cumulus Collection file format, which Cumulus creates to manage a collection, a specified set of records from a catalog.



*.cqe

The Cumulus Query Exchange file format, which Cumulus creates when saving a query.



*.cre

The Cumulus Record Exchange file format, which Cumulus creates when exporting record information to other catalogs or 
applications. When you use the Cumulus import function, the records to be imported must be held in a previously exported .cre 
file.



*.tag

The Cumulus Metadata Exchange file format, which Cumulus creates when cataloging assets from a location where you are 
allowed to save files. The file has the same name as the asset, with the extension .tag. TAG files hold all information that can be 
viewed in the Asset Information - and more. For example, if a particular asset has been cataloged into different catalogs, this 
information is part of that asset’s TAG file.



Application Preferences dialog box

A dialog box that enables Cumulus users to define and customize global program settings.



Application Programming Interface (API)

A set of commands available to developers for creating applications that interact with Cumulus in order to provide new 
functionality.



Asset

A general term describing any type of digital media (including graphic, page layout, presentation, sound, and video files) used for 
a project. Compare with Digital media.



Asset Information

The information about an asset as stored in the record associated with the asset.



Asset Information window

A special window that displays the information about a cataloged asset. This information is stored in the asset’s record. See also 
Record.



Asset Reference

The mechanism by which Cumulus trans the actual location of an asset in a Cumulus catalog.



Asset Storage Module

A component of Cumulus that manages the asset's storage (the access to its location). Cumulus employs different Asset Storage 
Modules, e.g. Windows File System, Mac OS File System, DCS File Support (to manage Desktop Color Separation files), OPI 
System Support (to manage Open Pre-Press Interface) and Cumulus Metadata Support. The Cumulus Metadata Support 
module enables the storage of an asset's metadata in a separate TAG file.



Boolean

A system of logic based on two possible values: true or false. Cumulus uses the Boolean operators "and" and "or" to combine 
search conditions.



Catalog

A special file (with the extension .ccf) that Cumulus creates to manage cataloged assets. See also Asset and Cumulus Catalog 
File.



Catalog file name

Name of the special file for a catalog (with the extension .ccf). The Catalog name defaults to this file name (without the 
extension). The catalog name can be changed without changing the catalog file name. See also Cumulus Catalog File.



Cataloging

The process by which a user adds one or more assets to a catalog. 



Cataloging Options dialog box

A special dialog box that controls the way in which Cumulus catalogs assets.



Category

An organized group of records that appears in the Category pane. Categories serve as the organizational backbone of a 
Cumulus catalog.



Category Exchange File

See Cumulus Category Exchange File.



Category pane

Located on the left side of the Collection window, the Category pane contains organized groups of records (called categories) 
that serve as the organizational backbone of a Cumulus catalog. The Category pane displays category and record names in a 
hierarchical list.



Client

A computer user who accesses a server application (such as the Cumulus Server) across a network.



Client/server architecture

A software configuration in which users (also called clients) access a server application across a network.



Collection

Any set of records from any one catalog, including their display properties. A collection can be saved (see Cumulus Collection 
File) and opened again. A collection - whether saved or unsaved - is always connected to its catalog. In order to open a particular 
collection you must have access to its catalog.



Collection window

A window featuring two panes (Category pane and Record pane) that function as the central user interface. 



Compound search

A search query consisting of two or more search conditions.



Cumulus 

An indispensable Digital Asset Management System for organizing and managing digital media (in a client/server environment). 
See also Digital media and Client/Server Architecture.

There are different editions of Cumulus designed to meet the needs of anyone who wants to keep track of their digital media, from 
the budding photographer or hobby homepage designer to international multiple server, cross-platform environments in huge 
corporate settings.

· Cumulus Single User Edition 

· Cumulus Workgroup Edition 

· Cumulus Enterprise Edition 

To meet individual workflow needs, the Cumulus product range offers the following Add-on products, e.g.: 

· Cumulus Vault 

· Cumulus Web Publisher

· Cumulus Viewer

· Asset Storage Modules

· Custom Database Connectors



Cumulus Administrator (Workgroup and Enterprise Edition only)

A person who configures and manages Cumulus catalogs. The Administrator is responsible for keeping the catalogs running 
smoothly for Cumulus Client users, backing up catalogs, and other tasks. For more information, see the special Cumulus 
Administrator Guide.



Cumulus application window

The main Cumulus window containing the menu bar, the toolbar, the status bar, and as "child" window(s) the Collection 
window(s) and the Find window. 



Cumulus Viewer

A Cumulus Add-on Product. The royalty-free application for publishing Cumulus catalogs on CD-ROM or other removable media 
(e.g., Syquest, Zip, Jaz, or MO cartridges).



Cumulus Catalog File

A special file (with the extension .ccf) that Cumulus creates to manage cataloged digital media (or assets).



Cumulus Category Exchange File

A special file (with the extension .cce) that Cumulus creates when exporting category information.



 Cumulus Collection File

A special file (with the extension .cfe) that Cumulus creates to manage saved collections.



Cumulus Administrator Guide (Workgroup and Enterprise Edition only)

A manual describing Cumulus Administrator procedures and functions.



Cumulus Record Exchange File

A special file (with the extension .cre) that Cumulus creates when exporting record information.



Cumulus Server

The computer where Cumulus Server software is installed and where Cumulus catalogs should reside.



Cumulus Internet Client (Enterprise Edition only)

A powerful CGI (Common Gateway Interface) application designed to publish and distribute assets over the Internet.



Cumulus Web Publisher

A Cumulus Add-on Product. A powerful CGI (Common Gateway Interface) application designed to publish and distribute assets 
over the Internet.



Details view

Each record appears in the Record pane as a text listing that includes fields you can define (e.g., record name, file format, 
resolution, etc.). See also Thumbnail view.



Digital media

Any electronic media (including graphic, page layout, presentation, sound and video files).



Directory category

Directory categories are automatically created by Cumulus during the cataloging process. These automatically created 
categories resemble the folder or directory hierarchy in which the assets reside. They are identified by a small folder in their 
icons. They are created by default, but this option can be disabled.



Drag and drop

A way to move user-interface objects by dragging them with the mouse and dropping them into targets.



Asset filters

Software utilities that Cumulus uses to capture information about an asset during the cataloging process. For more information 
on the availability of new file filters, please see the Canto Website (www.canto.com).



Find window

Cumulus tool that enables users to search catalogs for records that match search conditions.



FTP

File Transfer Protocol. A standard Internet protocol, which is the simplest way to exchange files between computers on the 
Internet. 



HTTP

HyperText Transfer Protocol. A standard Internet protocol, which is the most often used protocol in the World Wide Web to 
transfer information between servers and browsers.



IPTC 

International Press Telecommunication Council. Standard for digital text applied to an image. Applications used for professional 
imaging, support IPTC; e.g. the text information in Photoshop is a subset of the IPTC information. Cumulus can read and write 
this metadata information. 



Gigabyte (GB)

A unit of storage capacity on an electronic storage device that equals 1,024 megabytes, or roughly 1.07 billion bytes. Cumulus 
catalog files can be up to 4 GB in size.



Internet Media Server

See Cumulus Web Publisher. or for Enterprise Edition Cumulus Internet Client.



Kilobyte (KB)

A unit of storage capacity on an electronic storage device that is equivalent to 1,024 bytes. 



Media file

Any electronic or digital media file (including graphic, page layout, presentation, sound and video files) used for a project. See 
also Digital media.



Megabyte (MB)

A unit of storage capacity on an electronic storage device that is equivalent to 1,024 kilobytes, or 1,048,576 bytes. 



Menubar

Appearing at the top of the Cumulus application window, the menubar houses menus that contain every program command.



Metadata

Metadata is the information stored with each asset—such as file name, location, etc. Different types of assets have different 
metadata fields: an image file, for example, would contain information on color and resolution, while an audio file would have a 
field for the playback duration.



Palette Mode

View mode that is specially designed for using Cumulus with another application, e.g. a desktop publishing application. In palette 
mode the Cumulus application shrinks to a palette that can conveniently be used with another application. That way you can 
easily drag and drop cataloged assets into other applications. 



Path/Pathname

A description of the location where a file is stored on a computer hard drive, server, or removable media (such as CD-ROM, 
Syquest, Zip, Jaz, or MO cartridges).



Pop-up menu

A shortcut menu that appears when you move the cursor over an object and click the right mouse button. 



Preview

A special program mode in which you can examine cataloged assets such as video clips, sound files, and image files.



Quicklist

A list containing default field values to fill in fields. In Cumulus available with the IPTC Information window.



Query

A combination of search conditions. Queries can be saved to disk and loaded into the Find window.



Record

The actual catalog entry Cumulus creates when an asset is added to a catalog. Records store valuable information about an 
asset, such as the file name, file location, file type, resolution, etc. 



Record Exchange File

See Cumulus Record Exchange file.



Record pane

Located on the right side of the Collection window, the Record pane displays records as thumbnails or plain text. See also 
Record, Thumbnail and Details view.



Related category

An alias of an existing category that acts as a virtual cross reference to the original category. You can use related categories to 
place multiple instances of the same category under various parent categories, without having to copy the entire contents of the 
category. Related categories are indicated by an arrow in their icons. 



Resolution

The number of pixels per inch in any graphic file format. Higher-resolution files have a higher number of pixels per inch than 
lower-resolution files. Working with higher-resolution files usually requires more memory and hard disk space than working with 
lower-resolution files.



Script

A list of instructions executed by a computer. Scripts are used by Cumulus to perform complex tasks automatically.



Server Asset Transfer

A Cumulus feature (especially useful in a crossplatform environment) that allows users in a network to access assets for 
previewing, copying and transferring via their connection to the Cumulus Server. With this feature the user is not forced to have 
direct access to the computer where the asset is stored. Only the computer running the Cumulus Server requires this access. 



Simple search

A search query consisting of one search condition.



Status bar

A bar located at the bottom of the Cumulus Application window, providing tool button descriptions, access to the Application 
Preferences dialog box, and category/record status.



Thumbnail

A miniature display of a cataloged asset.



Thumbnail view

The record appears with a miniature display of the cataloged asset in the Record pane.



Toolbar

A standard program tool that offers buttons as shortcuts to commonly used commands.



Tooltip

A small floating descriptive window that appears above a toolbar button when the cursor is positioned over it.



URL

Uniform Resource Locator. The address of a file (resource) accessible on the Internet. 



 Information
Online Help

No special text available. 

Please click another item and press F1 again.



 Information
The About Dialog Box

This dialog box shows your user registration information and the version of the program you’re using. 



 Cumulus
The About Dialog Box

This dialog box shows your user registration information and the version of Cumulus you’re using. 

It also provides a button that launches your default Web browser and initiates a connection to the Canto Web site. This requires an 
Internet connection. (See the Microsoft Windows documentation for information on setting your default Web browser.)



 Cumulus
Connect To Canto

To connect to Canto’s Web site, click the Connect button. Your default Web browser launches and initiates a connection to the 
Canto Web site. This requires an Internet connection. (See the Microsoft Windows documentation for information on setting your 
default Web browser.)



 Cumulus

This dialog box is shown while connecting to the Cumulus Server. Please wait.



 Cumulus

Windows help text should show up here!



 Searching 
Searching By Category 

The simplest form of searching is simply double-clicking on a category in the Category pane. This quickly finds all of the records in 
the active catalog that are associated with that category. You can also select more than one category to see all the records 
associated with the set. 

To display records in a selected category, double-click the category or select the category and press ENTER. 

To select several categories to see the contents of each, click the first category once to select it and then hold down the CONTROL 
key and click the second, third, etc. categories to select them. Release the CONTROL key and double-click any of the selected 
categories. The records of all the selected categories are found and displayed.

To quickly view the records assigned to categories, just hold down the ALT key and press an arrow key (up, down, left or right).

NOTE: There are several Preference options that affect the way category searching works. The current search options are visually 
indicated by the Search Compass: The Search Compass is found in the Status bar. For further information, see Using the Search 
Compass Icon. 

{button ,AL(`search',0,`',`')}    See also 
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 Information Windows
Cumulus provides three different Information windows. 

· The Asset Information window provides access to the information on the asset stored in the record. 

· The IPTC Information window provides special access to the IPTC information on the asset stored in the record. 

· The Category Information window provides access to the information on categories. 

For further information, see

Viewing Information Windows

Understanding the Asset Information Window

Understanding the Category Information Window

Understanding the IPTC Information Window

Customizing the Asset/Category Information Window 

Customizing the IPTC Information Window 



 Information Windows
Viewing Information Windows

You can view and customize the information on an asset or category.

To view an Information window:

1. Select the record(s) or category(s).

2. Select Asset => Information to view the Asset Information window.
or
Select Asset => IPTC Information  to view the IPTC Information window.
or
Select Category => Information  to view the Category Information window.

The Information window appears.

For further information, see Understanding the Asset Information Window, Understanding the Category Information Window or 
Understanding the IPTC Information Window

. 

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 View Asset Information Window

You can view and customize the information stored on an asset.

To view the Asset Information window:

1. Select the asset's record.

2. Select Asset => Information.

The Asset Information window opens.

For further information, see Understanding the Asset Information Window. 



 Information Windows
Understanding the Asset Information Window

The Asset Information window provides access to the information on the asset stored in the record. Which fields are displayed is 
customizable. They can be selected from the range of fields configured for the current catalog in the Catalog Properties windows, 
Record Fields tab. Whether the fields can be edited depends on the field type and the field properties (whether Allow User to Edit 
is checked). A field with a dark gray background cannot be edited.

Item Description

Field Name Column header; column shows the name of the field (as defined 
in the Catalog Properties).

Field Content Column header; column shows the contents of the field for the 
selected record (editable or not depending on field type and 
whether Allow User to Edit is checked in the record field 
properties).

Check box (field type: Boolean)

Arrow button to open a drop-down list for selecting a value (only 
String List field type).

Records a voice annotation. For further information, see Audio 
fields.

Loads the first record from the Collection window’s current 
selection. (Equivalent to the option First in the Asset menu.)

Loads the previous record from the Collection window’s current 
selection. (Equivalent to the option Previous in the Asset 
menu.)

Loads the next record from the Collection window’s current 
selection. (Equivalent to the option Next in the Asset menu.)

Loads the last record from the Collection window’s current 
selection. (Equivalent to the option Last in the Asset menu.)

NOTE: Date Fields
Enter date (and optional time) in the format you selected for your computer. 

To edit field values, you can use the commands of the Edit menu or click the right mouse button for the pop-up menu. 

NOTE: Clicking on the entry for a category in the Categories field highlights the corresponding category in the Category pane.

To customize the Asset Information window: Select Edit => Customize. 

To save your changes: Select Asset => Save.

To close the window: Select Asset => Close.

Use the options of the Asset menu to work with the assets themselves, e.g., to print or open them with other applications.

NOTE: Opening One Asset Information Window for Multiple Records
If you have selected multiple records before opening the Asset Information window and the Show All Assets in One Window 
option is activated in the Customize Information window, you can change the field values for multiple records at once.
If the asset information of multiple records is shown in one window, only those field contents are displayed which have the 
same value. So the Asset Reference and Thumbnail fields will always be empty. Check boxes (Boolean fields) with different 
values appear gray. The Categories field only displays those categories which the selected records have in common. All other 
field types are displayed without a value if the fields have different values.
Fields with different values do not display a value but can be edited – the same is true for gray (neutral) check boxes. The 
values you enter will be assigned to all of the selected records. If you add an additional category, this category is added to the 
set of categories of all records.



 Information Windows
 Asset Information Window

Editing Record Names

When you catalog a file, Cumulus automatically assigns the asset’s file name as the Record Name. You can change the Record 
Name to better describe the asset or to track it under your own internal naming conventions. This can be helpful if the original file 
name is not meaningful to you, or if the file is read-only.

A Record Name can be up to 63 characters long. Some users create names based on information they might want to search or sort 
in the future (e.g., a job number or archive location). Certain characters are not compatible with all operating systems.

To edit a record name:

1. Highlight the record you want to rename.

2. Select Asset => Information.

The Asset Information window appears.

3. Highlight the existing name and type a new one.

The Record Name can be up to 63 characters long.

4. Select Asset => Save.

{button ,AL(`records',0,`',`')}    See also 



 Information Windows
Printing Asset Information

You can print the asset information of records.

To print asset information:

1. Select the record whose asset information you want to print. (To select a series of records, hold down SHIFT and highlight the 
first and last record in the series.)

3. Select Asset => Information.

The Asset Information window appears.

4. Click the Print button.

5. Make the desired selections in the Print dialog box and click OK.

{button ,AL(`basics',0,`',`')}    See also 



 Information Windows
View Category Information

You can view and customize the information on a category.

To view Category Information:

1. Select the category to view.

2. Select Category => Information.

The Category Information window opens.

For further information, see Understanding the Category Information Window. 



 Information Windows
Understanding the Category Information Window

The Category Information window provides access to the information on categories. The fields displayed are determined by the 
settings for the current catalog in the Catalog Properties, Category Fields tab. The field contents are editable depending on the field 
type and the field properties (whether Allow User to Edit is checked). When the field background is dark gray it cannot be edited. 

Item Function

Field Name Column header; column shows the name of the field (as defined 
in the Catalog Properties).

Field Content Column header; column shows the content of the field for the 
selected category (editable or not depending on the field type and 
whether Allow User to Edit is checked in the category field 
properties).

Check box (field type: Boolean)

Arrow button to open a drop-down list for selecting a value (only 
String List field type).

Records a voice annotation. For further information, see Audio 
fields.

Loads the first category from the Collection window’s current 
selection.

Loads the previous category from the Collection window’s current 
selection.

Loads the next category from the Collection window’s current 
selection.

Loads the last category from the Collection window’s current 
selection.

NOTE: Date Fields
Enter date (and optional time) in the format you selected for your computer. 

To edit field values, you can use the commands of the Edit menu or click the right mouse button for the pop-up menu. 

To customize the Category Information window: Select Edit => Customize. 

To save your changes: Select Category => Save.

To close the window: Select Category => Close.

NOTE: Opening One Information Window for Multiple Categories

If you have selected multiple categories before opening the Information window and the Option Show All Assets in One 
Window is activated in the Customize Information window, you can change the field values for multiple categories at once.

If the information of multiple categories is shown in one window, only those field contents are displayed which have the same 
value. Check boxes (Boolean fields) with different values appear gray. All other field types are displayed with no value if the 
fields have different values.

Fields with different values do not display a value but can be edited – the same is true for gray (neutral) check boxes. The 
values you enter will be assigned to all of the selected categories.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
Customizing the Information Window 

You can select the fields to be displayed as well as the font and length of the displayed field. 

To display the Customize Information window: 

1. Select Edit => Customize. 

The Customize window appears.

The Customize window has two tabs: General and Fields.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 Customizing the Information Window 

General Tab

Item Description

Show one Asset/Category per Window Cumulus opens a new Information window for 
each asset/category.

Show all Assets/Categories in One 
Window

Cumulus uses one window to show information 
on assets/categories. Displays and lets you edit 
common information for multiple records.

Synchronize to Selection Record(s) selected in the collection window will 
be displayed accordingly in the Asset Information 
window.

Window Position,
Always Keep Window On Top

The Information window is displayed on top of all 
other windows.

Audio,
Automatically Play First Audio Field 
(If Available)

When you open the Information window, the 
voice annotation in the first Audio field of the 
Information window will be played.

Audio,
Sound Settings

Opens a dialog box from which you can define 
the quality of your voice annotations. But don’t 
forget: the better the quality the more data to be 
stored.

Default Information Window,
Use IPTC Information Window

Cumulus opens the IPTC Information window 
and not the Asset Information window if the 
option Double-Click on Record Opens Asset 
Information is enabled in the Application 
Preferences. 

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 Customizing the Information Window 

Fields Tab 

Item Description

Show All Fields All fields are displayed in the Information window.

Only Show the Following Only the fields listed in the table are displayed in the 
Information window.

Field Name Name of the field (as defined in the Catalog Properties 
window).

Type Type of the field (as defined in the Catalog Properties 
window).

Font and Size Font and font size for display of the field in the 
Information window (as defined in the Properties 
window). 

Properties Opens the Properties window for the selected field. You 
can choose the font (style, size, color) and the number 
of lines for String fields or the size for a picture field.

Add Before Adds an additional field before the selected field. A 
dialog box for selecting the additional field is opened.

Add After Adds an additional field after the selected field. A dialog 
box for selecting the additional field is opened. 

Remove Removes the field from the list. The field will not be 
displayed in the Information window.

The arrow buttons change the selected entry’s position in the list. The Information window displays the fields in the order of this list. 
Starting from top: move to top of list, move before current position, move after current position, and move to end of list. (Disabled if 
no field is selected.)

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
Customize 

Add Fields

To add a field to be shown in the Information window:

1. If the Asset Information window is not open, select a record and choose Asset or Category->Information.

2. Select Edit->Customize from the Information window’s menubar. This opens a window with which you can customize 
aspects of the Information application.

In tabs along the top of the window, you see two options named General and Fields. Under Fields, you set up which record 
fields will be displayed and how.

3. Select a field and click Add Before or Add After to add an additional field before the selected field. A dialog box for selecting 
the additional field is opened

4. Select the entry for the field to be added.

NOTE: Empty list
If the list is empty, all fields are already shown in the Information window.

5. Click OK. 

The field is added to the display of the Information window.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
Field Types for Records and Categories

The following field types are supported:

Field Type Description

String Characters and numbers 

Boolean Creates check box for enabling or disabling function.

Integer Numbers without decimal places

Real Numbers with decimal places

Date MM/DD/YY (later than 1970)

Binary Filled by Cumulus or Asset Storage module

Picture Filled by Cumulus or Asset Storage module

String List Can only be filled with values from a corresponding list. (For 
details on inserting a value to a String List, see String List.)

Audio User-editable; only available when QuickTime is installed on your 
computer (QuickTime 5.0 is recommended). You can record voice 
annotations for the record.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 Field Types

Set Up String List

Selecting the String List field type activates the Edit List button in the Field Properties dialog box. Clicking this button opens the 
String List dialog box, in which you can edit the values for a String List field.

The field at the top of the dialog box displays the name of the String List field. 

Button Description

Delete Deletes the selected entry from the list.

Rename Displays dialog box to rename the selected entry.

Insert Before Places a new entry above the selected entry.

Insert After Places a new entry below the selected entry.

{button ,AL(`administrator',0,`',`')}    See also 



 Information Windows
 Field Types

Audio Fields

Audio fields are user-editable fields. Audio fields are only available when QuickTime is installed on your computer (QuickTime 4.0 is 
recommended). Voice annotations for a record can be up to 30 seconds long.

Click to record a voice annotation. A dialog box for stopping or canceling the 
recording appears. 

Click to play the voice annotation. (Button changes to  for stopping during 
playback.)

Click to delete the voice annotation. (Field has no value then.)

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 Field Types

Recording Audio Fields

After clicking the button for recording a voice annotation, a dialog box for stopping or canceling the recording appears.

Speak into the microphone.

Click Stop to finish the recording.

Click Cancel to cancel the recording.

The recording can be up to 30 seconds long.

{button ,AL(`information',0,`',`')}    See also 



 Picture Size
Edit Custom Picture Size

Enter the size for the picture in pixels (from 16 to 1024).

But don’t forget to remember the space a large picture absorbs.



 Use Application
Select associated program or Other.

Cumulus launches the program, which then opens or prints the file.



 Adding Fields

This dialog lists all the fields in the current catalog.

Select the field(s) you want to and and click OK.



 Palette Mode

Employ this menu option to change the view of the Cumulus application to the Palette Mode and back. All open collections will 
be changed to the Palette Mode. They are displayed on top of each other. 

This mode is specially designed for using Cumulus with another application, e.g. a desktop publishing application. In palette 
mode the Cumulus application shrinks to a palette that can conveniently be used with another application. That way you can 
easily drag and drop cataloged assets into other applications. 

The Palette Mode window can be resized to fit your needs. All Cumulus functions are available. To display the menus select 
Menu. 

How to customize this display mode, see Customizing the View.



 Information Windows
 IPTC Information Window

View IPTC Information

You can view and customize the IPTC information stored on an asset.

To view the IPTC Information window:

1. Select the asset's record.

2. Select Asset => IPTC Information.

The IPTC Information window opens.

For further information, see Understanding the IPTC Information Window. 

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 IPTC Information Window

Understanding the IPTC Information Window

This Information window is specially designed for displaying and editing the IPTC data of assets. Cumulus can read IPTC 
metadata information while cataloging. You can view and edit this metadata and Cumulus can write your changes back to the 
asset.

NOTE: Writing IPTC Data back to Assets
If you want to write back IPTC data to assets, your Cataloging Options (entry for the IPTC filter activated) and the catalog 
managing these assets must be prepared for this feature. IPTC record fields have to be added and their properties have to be 
enabled for field linking, also Writing Metadata to Asset must be activated in the General Catalog Properties. Cumulus provides 
a script to help make the process of preparation easy: Prepare To Write IPTC (found in the Special menu)
The IPTC data will be written back to the asset when any record information has been changed.

If the title of a field is displayed in gray, the field is not included in the catalog. 
If the field itself is displayed in gray, the field is not editable.

Information can be added by entering text into the field or selecting from lists - so called 'quicklists'. A quicklist is a list of default 
field values, for example often used names of photographers, locations, caption writers or certain categories. You can easily 
open each field’s quicklist by clicking the arrow down button. This opens a dialog with a list of the already existing values - if 
there are any. 

Some fields provide prepared lists for immediate use. For some fields these quicklists are preset and contain values laid down by 
the IPTC norm. Due to IPTC standards the preset quicklists for some of that fields can't be edited. The quicklists for all other 
fields can be edited.

Different Types of Fields

Text fields: Most of the fields in the IPTC Information window are text fields. They allow you to enter text of one or more words. 
You can enter characters, numbers and special characters. The Caption and Special Instructions fields allow you to enter several 
lines of text. 

String List fields: Keywords and Supplemental Categories allow you to enter a number of entries consisting of one or more 
words. You enter a keyword by typing the word and then pressing the Enter key or clicking the Add button. You then can 
immediately start typing the next entry. NOTE: To add categories to the Keywords field you can drag & drop categories from 
Category Pane.

Category field: The category field can only contain a 3-character abbreviation. The corresponding quicklist lets you only add 3 
characters.

Country Code and Country fields: These fields are combined. The Country Code field can only contain a 3-character 
abbreviation. The Country field is a normal text field. Both fields are served from the same quicklist. If you select a value for the 
Country Code field, the Country field will be filled in as well (and vice versa). The corresponding quicklist lets you add and edit 
values for both the country and the country code. 

To open or edit a quick list for a field use the arrow down button next to the field. This opens a drop-down list for selecting a 
value. Clicking the desired value copies it to the field. When selecting from a quicklist, all previous text in the field will be 
replaced (except in the Keywords and Supplemental categories fields where new entries will be added to the existing entries).

NOTE: You can move up and down in the quicklist with the arrow keys (and press the Enter key to select an entry). You can also 
navigate by typing the first letters of words in the list.

The fields for which you can edit the corresponding quicklist provide an entry ->Edit Quicklist. If you select this entry, a dialog 
for editing the quicklist opens. See Editing Quicklists for further details.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 IPTC Information Window

Customizing the IPTC Information Window

You can select the fields to be displayed as well as the font and length of the displayed field. 

To display the Customize IPTC Information window: 

1. Select Edit => Customize. 

The Customize window appears.

The Customize window for the IPTC Information window has one tab: General

Item Description

Show one Asset per Window Cumulus opens a new Information window for 
each asset.

Show all Assets in One Window Cumulus uses one window to show information 
on assets. Displays and lets you edit common 
information for multiple records.

Synchronize to Selection Record(s) selected in the collection window will 
be displayed accordingly in the Information 
window.

Window Position,
Always Keep Window On Top

The Information window is displayed on top of all 
other windows.

Default Information Window,
Use IPTC Information Window

Cumulus opens the IPTC Information window 
and not the Asset Information window if the 
option Double-Click on Record Opens Asset 
Information is enabled in the Application 
Preferences. 

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 IPTC Information Window

Editing Quicklists

The list displays the current values for the corresponding field. You can edit or delete these values or add new values to the list.

To delete a value: Select the value in the list and click Delete.

To edit a value: Select the value. The value will be displayed in the field above the list. Edit the value in this field and then click 
Replace. The value in the field will replace the selected value in the list.

To add a new value: Enter the new value in the field above the list and click the Add buttom or hit the Enter key. You then can 
immediately start typing the next entry.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 IPTC Information Window

Import or Export of Quicklists

You can export the whole list or just parts for certain fields. 

Select the desired parts or click Select All. Then click Export or Import. 

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 IPTC Information Window

Export Quicklist

Employ this menu option to export a quicklist. An exported quicklist can be imported by another user or into another catalog. You 
can export the whole list or just parts for certain fields. 

The exported list is saved as a text file. You may edit an exported text list with a text editor.

{button ,AL(`information',0,`',`')}    See also 



 Information Windows
 IPTC Information Window

Import Quicklist

Employ this menu option to import a quicklist (or parts of it) created from another user or for another catalog.

NOTE: When working with the Import function you may take the values for each field from different quicklists.



 Menu Items 
First

Loads the first item from the Collection window’s current selection.



 Menu Items 
Previous 

Loads the previous item from the Collection window’s current selection



 Menu Items 
Next

Loads the next item from the Collection window’s current selection.



 Menu Items 
Last

Loads the last item from the Collection window’s current selection.



 Menu Items 
Find Matching Records

Finds all records that are associated with the selected categories. This is the menu equivalent to double-clicking category icons. 
(Disabled unless one or more categories are selected.)



 Menu Items 
Find Selected Assets

Finds cross-references of an asset - if available. If the cursor is placed in the field Contained Asset this menu option will perform 
a search for the records of the contained assets. If the cursor is placed in the field Container Asset this menu option will perform 
a search for the records of the container assets. 



 Menu Items 
Update Record

Refreshes the thumbnail and updates any static information that appears in the Asset Information window. 



 Menu Items 
Update Asset Reference

Updates the reference to the asset location. If Cumulus cannot find the asset, a dialog box appears so you can specify a new 
location. 



 Menu Items 
Preview

Displays the preview of an asset. 



 Menu Items 
Show Location

Lets you manually locate assets in Windows Explorer. 



 Menu Items 
Open with

Launches the program associated with an asset so you can view or edit it.



 Menu Items 
Print with

Launches the program associated with an asset so you can print it.



 Menu Items 
Copy To

Copies assets to the specified location. 



 Menu Items 
Move To

Moves an asset to a new location. This copies the asset and deletes the file from the original location. 



 Menu Items 
Mail To

Routes an asset via e-mail by attaching it to an e-mail message. 



 Menu Items 
Print

This menu item opens a submenu with the following print options:

· Selected Records - Prints selected records using the current display style. 

· All Records - Prints all records in the active collection using the current display style. 

· Selected Categories - Prints selected categories as they appear in the Category window. 

· All Categories - Prints all categories as they appear in the Category window. Make sure to expand the category list if you 
want to see all subcategories in the printout.

· Preview - Prints the preview of the selected record’s asset.

If you want to print the actual asset, instead of its record or preview, see Print With for details..



 Menu Items 
Save

Saves any changes you made.



 Menu Items 
Close

Closes the Asset Information window.



 Menu Items 
Cut

Removes the current item or text selection and places it on the Clipboard so that it can be pasted elsewhere.



 Menu Items 
Copy

Copies the current item or text selection and places it on the Clipboard so that it can be pasted elsewhere.



 Menu Items 
Paste

Places the contents of the Clipboard into the current location or text insertion point.



 Menu Items 
Clear

Deletes the current text selection.



 Menu Items 
Select All

Selects the complete contents of a field.



 Menu Items 
Customize

Opens a dialog from which you can determine how the Information window displays information. You can select the fields to be 
displayed as well as the font and length of the displayed field. 

The Customize window has two tabs: General and Fields.



 Menu Items 
Undo

Reverts operations in fields, but cannot undo other operations (e.g.: reverts to the former text entry if you redeceide while 
changing a categroy name).



 Menu Items 
Deselect All

Cancels any previous selection.



 Menu Items 
Delete

Deletes the selected records or categories from the catalog. A confirmation dialog with two options appears: delete only the 
record or delete both the record and its associated asset. This action cannot be undone. Make sure that you no longer need an 
asset or that you have a copy elsewhere before deleting it. (Disabled if no records or categories are selected.)



 Menu Items 
Optimize Thumbnail

Equalizes the appearance of the selected record's thumbnail. This is useful for thumbnails that are too dark, too light, or lacking 
contrast. The action cannot be undone, but you can force-update the record to get back the original thumbnail. (Disabled if no 
records are selected.) 



 Menu Items 
Rotate Thumbnail - 90° counter-clockwise

Rotates the thumbnail of the selected record(s) 90° counter-clockwise.

The record field Thumbnail Rotation saves the rotation value for a rotated thumbnail. The rotated thumbnail will be used for 
previewing, printing, exporting to HTML and creating slide shows.

NOTE: Availability for Catalogs Created with Versions Prior Cumulus 5.5!
If this field should be available with catalogs that have been created with prior versions, the record field Thumbnail Rotation has 
to be added to the catalog. The field is then empty. There are two ways to fill it out:

· Open the Asset Information window and enter the according value (degree of rotation) manually.

· Select Asset ->Update Record. This will set the thumbnail back to the asset's orientation. Then rotate the thumbnail again. 
The value of the rotation will then be stored in the Thumbnail Rotation field.



 Menu Items 
Rotate Thumbnail - 90° clockwise

Rotates the thumbnail of the selected record(s) 90° clockwise.

The record field Thumbnail Rotation saves the rotation value for a rotated thumbnail. The rotated thumbnail will be used for 
previewing, printing, exporting to HTML and creating slide shows.

NOTE: Availability for Catalogs Created with Versions Prior Cumulus 5.5!
If this field should be available with catalogs that have been created with prior versions, the record field Thumbnail Rotation has 
to be added to the catalog. The field is then empty. There are two ways to fill it out:

· Open the Asset Information window and enter the according value (degree of rotation) manually.

· Select Asset ->Update Record. This will set the thumbnail back to the asset's orientation. Then rotate the thumbnail again. 
The value of the rotation will then be stored in the Thumbnail Rotation field.



 Menu Items 
Rotate Thumbnail - - 180° 

Rotates the thumbnail of the selected record(s) 180° 

The record field Thumbnail Rotation saves the rotation value for a rotated thumbnail. The rotated thumbnail will be used for 
previewing, printing, exporting to HTML and creating slide shows.

NOTE: Availability for Catalogs Created with Versions Prior Cumulus 5.5!
If this field should be available with catalogs that have been created with prior versions, the record field Thumbnail Rotation has 
to be added to the catalog. The field is then empty. There are two ways to fill it out:

· Open the Asset Information window and enter the according value (degree of rotation) manually.

· Select Asset ->Update Record. This will set the thumbnail back to the asset's orientation. Then rotate the thumbnail again. 
The value of the rotation will then be stored in the Thumbnail Rotation field.



 Menu Items 
Preferences

Opens the Application Preferences window, from which you can set global application behaviors.



 Menu Items 
Contents and Index

Opens the table of contents and searchable index window for Cumulus’ online help system.



 Menu Items 
Help On

Opens context-sensitive help. This type of help presents information on the selected item in the program. For example, if a 
record is selected, the help system provides information on using the Record pane. You can also press F1 on your keyboard to 
reach the same information. F1 offers the additional benefit of being able to get help on a selected menu item.



 Cumulus Automation 
Index of Included Cumulus API Examples

Assign Selected Categories 

Assign Status to Records 

Check After Location Changed 

Count File Formats

Detach From Selected Categories 

Export Records to Access 

Find Via Matching Categories 

Find Via Similar Thumbnails 

Hot Folder

Join Duplicate Categories 

Live Search 

Move Folder 

New Category from Date 

Optimize for Safety 

Optimize for Speed 

Picture to Thumbnails 

Prepare To Write IPTC 

Satellite 

Server Log Properties 

Show Category Folder

Thumbnails to BMP Files 

{button ,AL(`automation',0,`',`')}    See also 



Troubleshooting

Solving Common Problems 

Documenting Problems 

Tips for Cumulus 4 Users 

Technical Support 



 Troubleshooting 
Solving Common Problems 

This section contains frequently asked questions and their possible solutions. If you have a problem not covered in this chapter, be 
sure to review Support & Solutions on the Canto Software Web site for additional troubleshooting information (www.canto.com).

· Can I change the way thumbnails appear? 

· How can I distribute my Cumulus catalog and media files on CD-ROM? 

· Sometimes when I copy or place an asset, it doesn’t work or I get the wrong one. What do I do?

· Whenever I request a file from Cumulus, it always asks me to mount a CD-ROM. Can I avoid this? 

· I used drag-and-drop to place files. The destination was highlighted but nothing happened when I released the mouse button. 
What went wrong?

· I updated all of my records to include new file content, but nothing happened. Why? 

· How do I export catalog information to another program? 

· New categories appear in the Category pane when I drag and drop between catalogs. Why?

· I added keywords and notes before cataloging. Can Cumulus read this information during cataloging?

· How do I work with DCS separation files in Cumulus? 

· If I catalog my low-resolution OPI files, place them in documents, and print them, will Cumulus substitute the high-resolution 
files during printing?



 Solving Common Problems 
Can I change the way thumbnails appear?

You can change the actual size (in pixels) of a thumbnail. You can also change a thumbnail’s appearance within the Record pane by 
selecting options found in the View menu and on the Cataloging Options.



 Solving Common Problems 
How can I distribute my Cumulus catalog and media files on CD-ROM? 

The Cumulus Browser add-on product offers a royalty-free application that you can use to publish Cumulus catalogs on CD-ROM or 
other removable media. 



 Solving Common Problems 
Sometimes when I copy or place an asset, it doesn't work or I get the wrong one. 
What do I do?

The reference to the asset is no longer up-to-date. If you know where the original file is located, update the file reference by 
selecting Update Asset Reference from the Catalog menu. 



 Solving Common Problems 
Whenever I request a file from Cumulus, it always asks me to mount a CD-ROM. 
Can I avoid this?

Cumulus can manage assets on various types of media, including off-line removable media such as CD-ROM or SyQuest, Zip, Jaz, 
and MO cartridges. You can reduce the number of mounting requests and interruptions by storing frequently used assets on your 
hard drive.



 Solving Common Problems 
The destination was highlighted but nothing happened when I released the 
mouse button. What went wrong?

You probably don’t have access to the original media file you’re trying to place. 

To work around this problem, check the reference Cumulus uses to locate the file. By checking a file reference, Cumulus verifies 
that the asset is still located in the same place it was when it was cataloged. If Cumulus cannot find it, a dialog box appears so you 
can specify a new location. You must have access to the original media files to check file references.

To check a record’s file reference:

1. In the Record pane, select the records to check.

2. Select Catalog => Update Asset References.

Cumulus checks (or resolves) all file references. 



 Solving Common Problems 
I updated all of my records to include new file content, but nothing happened. 
Why?

Updating records or forcing updates refreshes the thumbnail and updates static information that appears in the Asset Information 
window. Any customized information is not updated.

To automatically include information on assets as you catalog assets, set the appropriate links from the assets fields to the record 
fields (see Catalog Properties, Record Fields Tab).



 Solving Common Problems 
How do I export catalog information to another program?

Cumulus supports the ability to export record and category information to a tab-delimited text file, which can then be imported into 
other catalogs or applications. For more information, see Exporting and Importing Information.



 Solving Common Problems 
New categories appear in the Category pane when I drag and drop between 
catalogs. Why?

Every Cumulus catalog can have a different category structure that contains different categories. When you drag or import a record 
to another catalog, it may be assigned to categories that don’t exist in the destination catalog. If that is the case, Cumulus 
automatically creates the missing categories in the destination catalog.

To avoid this situation, copy the categories from one Category window to the other before importing records.



 Solving Common Problems 
I added keywords and notes before cataloging. Can Cumulus read this 
information during cataloging?

Yes, Cumulus is able to read notes and keywords out of a file automatically, if the information is stored in a standard way. 

To automatically include information on assets as you catalog assets, set the appropriate links from the assets fields to the record 
fields (see Catalog Properties, Record Fields Tab).



 Solving Common Problems 
How do I work with DCS separation files in Cumulus?

DCS 1.0 files consist of 5 different files: the master file and the four color separation files for Cyan, Magenta, Yellow, and Black. 
Cumulus catalogs only the master file to avoid creating 5 records for a single image. 



 Solving Common Problems 
Will Cumulus substitute high-resolution files for cataloged low-resolution OPI 
files?

Cumulus is fully compatible with many OPI systems and can form the backbone of a successful automation system in any 
environment. For more information, see Automating Cumulus.



 Troubleshooting 
Documenting Problems

When Cumulus behaves in an unexpected way or does not work properly, please try to reproduce the error, paying special attention 
to the actions you took prior to the problem. If there are many steps, write them down so you can tell us exactly what you did. 

If you cannot resolve your problem, please fill in the Canto Support Form (Documentation folder on the product CD) so you can 
send it to your support provider. For information on contacting technical support, see Technical Support, or look on the Canto 
Software Web site (ww.canto.com).



 Cumulus 4 Users
Tips for Cumulus 4 users

If you’re an experienced user of Cumulus 4, you should have no problem making the change to Cumulus 5. But to make sure that 
you don’t miss out on any new features of Cumulus 5, please see Chapters "Explore" and "Use" in your user’s guide.

To help you find what you’re looking for faster, this section organizes the major differences between the two versions alphabetically 
based on their Cumulus 4 name. It doesn’t include purely "cosmetic" differences, which enhance Cumulus 5’s cross-platform 
capability by making the Mac OS and Windows interfaces more consistent. These differences are minor and should be self-
explanatory.

Administration Menu

Cumulus 5 doesn’t have the Administration menu, but most of the functions it contained can now be found in the Catalog menu.

Administration View

The Administration view is not included with the Single User Edition of Cumulus 5. Information on a catalog itself (such as memory 
and disk usage) can now be found by clicking Advanced Settings on the General tab of the Catalog Properties window. 
Information on catalog activity is only available with the Workgroup and Enterprise editions, and can be reached by selecting 
Catalog => Activity Monitor.

Automatic Categories

Cumulus 5 calls the categories created automatically during cataloging Directory Categories.

Collection Folder

A collection is Cumulus 5-speak for any set of records in a catalog, including their display properties. Since this type of collection 
has nothing to do with a single repository for the asset files themselves, the area previously called the Collection Folder is now 
called a Central Location.

Exporting and Importing Queries

Queries no longer need to be exported and imported with Cumulus 5, since they can simply be saved and loaded from the Find 
window. You can load your exported Cumulus 4 queries directly into the Find window. If the record field names in the exported 
query are identical to those of your current catalog, you can run the query right away. Otherwise you’ll first have to make the 
necessary adjustments in the fields of the Find window.

Findbar

Has been replaced by the Find window, which you can open by selecting Collection => Find. The Find window also includes 
functions for saving and loading search queries.

Find Menu

Most of these commands can now be found in the Collection menu.

To work with queries, select Collection =>Find to open the Find window, which contains options for saving and loading search 
queries.

Include Folder Name as Categories

Formerly located on the General tab of the Cataloging Options window as a global application setting. It is now catalog-specific 
and defined via a special record field called "Categories." 

If you open the properties of this field from the Record Fields tab of the Catalog Properties window, you can enable/disable 
category links to the Asset Storage module used for cataloging. For more information, see Directory Categories.

Logging

No longer included as a function with the Cumulus 5 Single User Edition.

Notes, Initial Value

To add a default text to the Notes field of all newly cataloged assets in a certain catalog, you have to enable the option Initial Value 
for the Notes field and enter the text you want to have as default. (To do so, select Catalog =>Properties. Then click on Record 
Fields, select the Notes field and click on Properties.)

Querybar

The Querybar functions have been integrated into the Cumulus 5 Find window, which you can open by selecting Collection => 



Find.

Record Menu

Has essentially been renamed the Asset menu, with a few moves that better reflect the purpose of each command:

Cumulus 4 Record Menu Command Cumulus 5 Menu Location

Update Catalog => Update Record

Update Asset Reference Catalog => Update Asset Reference

Delete Record Edit => Delete

Rotate Thumbnail Edit => Rotate Thumbnail

Optimize Thumbnail Edit => Optimize Thumbnail

Open Asset with Asset => Open with

Print Asset with Asset => Print with

Explore Asset Asset => Show Location

Copy Asset To Asset => Copy To

Move Asset To Asset => Move To

Asset Preview Asset => Preview

Properties Asset => Information

Status List See "Status List" below

Save Changes Immediately/Later

Formerly located on the General tab of the Catalog Properties window. Now accessible by going to the same place and clicking 
Advanced Settings.

Scripts Menu

The Scripts menu is gone, but many of the scripts familiar to Cumulus 4 Desktop PLUS and Network users can be found in the 
menus that best reflect their function (Click here to find out where and to learn about some new Cumulus 5 scripts.)

Show Record Name/Tooltips

Formerly located on the Display tab of the Application Preferences window, under Thumbnail View. Now a collection-specific 
display option in the View Customization window, reached by selecting View => Customize.

Status List

With Cumulus 4, you could assign each record a status from a list you defined for each catalog. Cumulus 5 takes this idea one 
step further by enabling you to define as many custom fields as you want for each catalog. This particular type of field is called 
String List. You can define a list of terms for each of these fields. Cumulus 5 also provides a default String List record field for each 
catalog. Its terms can be edited - like the terms for your custom fields - on the Record Fields tab of the Catalog Properties window. 
For more information on String List fields, click here. 

Vento

Not included with the Cumulus 5.




