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Open Command

Click the Open icon or choose Open from the File menu to open an existing presentation saved in the 
SPC Runtime Presentation (.PLY) format.

The Open dialog box appears so you can type or select a filename.



Save Command

Click the Save icon or choose Save from the File menu to save a presentation in the SPC Runtime 
Presentation (.PLY) format.

Note

n If already named, the file is saved and you can continue your work. Otherwise, the Save As dialog box 
appears, where you can name the file. If you don't type a filename extension, the program adds .PLY 
for you.



Save As Command

Choose Save As from the File menu to save or rename a presentation as an SPC Runtime Presentation 
(.PLY) file.

The Save As dialog box appears so you can type or select a path and filename. If you don't type a 
filename extension, the program adds .PLY for you.



Print Setup Command

Choose Print Setup from the File menu to set up the output device, orientation, paper size, and paper 
source for your presentation.

The Print Setup dialog box appears, where you can set printing options.



Print Command

Click the Print icon or choose Print from the File menu to print the current presentation.

The Print dialog box appears, where you can select the output device and printing options.



Exit Command

Choose Exit from the File menu to close the program. You're prompted to save if you've made any 
unsaved changes.



Open Recent Presentation

To open a recent presentation, click a filename in the list at the bottom of the File menu.

You're prompted to save any unsaved changes before opening the new presentation.



Move Command

Choose Move from the Edit menu to move slides you selected earlier in the Slide Sorter at the main 
screen.

The Move dialog box appears, listing the title and position of each slide, and providing options for moving 
the selected slide.



Delete Command

Choose Delete from the Edit menu to delete slides you selected earlier in the Slide Sorter at the main 
screen.



Copy Slide Image Command

Choose Copy Slide Image from the Edit menu to copy a slide you selected earlier in the Slide Sorter at 
the main screen. The image is copied to the clipboard as a Device Independent Bitmap (.DIB).

After copying, you can paste the slide into another Windows application for viewing.

Notes

n Only the slide image is copied, not any of the files you linked to slides. And there is no link to SPC 
Conference Viewer.

n To copy an entire presentation, including files linked or embedded using OLE, choose Copy 
Presentation from the Edit menu. With that method, there is a link to SPC Conference Viewer, so you 
can launch the viewer using OLE in a client application.



Copy Presentation Command

Choose Copy Presentation from the Edit menu to copy all slides in the current presentation to the 
clipboard.

After copying, you can paste the presentation into another application that supports OLE as a client. 
Users then can double-click the presentation to view it in the client application.

Notes

n You need not select a slide before using the Copy Presentation command.

n To copy just a single slide image, select a slide and choose Copy Slide Image from the Edit menu. 
The image is copied to the clipboard as a Device Independent Bitmap (.DIB). No OLE information is 
copied.



Links Command

Choose Links from the Edit menu to verify and update links to externally referenced files or to files linked 
by OLE to slides in the current presentation.

The Links and File References dialog box appears, where you can verify, cancel, or change the links.



Play in a Window Command

Click the Play in a Window icon or choose Play in a Window from the Presentation menu to set up 
ScreenShows to appear in a window you can size.

Once set up, ScreenShows appear in the window when you click the Play icon in the navigation bar or 
select Play from the Presentation menu. Otherwise presentations appear in a full-screen view.

Notes

n You can move and resize the window and maintain a uniform slide size and width.

n To restore the original window, choose Normal Size from the control menu in the viewer window.

n While playing a presentation in a window, you can choose Full Screen Display from the control menu 
in the viewer window.



Continuous Play Command

Click the Continuous Play icon or choose Continuous Play from the Presentation menu to:

n Enable ScreenShow presentations to advance slides automatically. You also should choose Use 
Timers from the Presentation menu.

n Return to the first slide after the last slide is displayed.

Once set up, the continuous play ScreenShow begins when you click the Play button in the navigation bar 
or select Play from the Presentation menu.

Notes

n When you use timers, the program keeps track of elapsed time, based on slide times set as 
ScreenShow Effects in Harvard Graphics. When a time elapses, the program advances to the next 
slide, or uses another timeout event you set in Harvard Graphics.

n With both Use Timers and Continuous Play on, if you didn't enter slide times in Harvard Graphics, 
SPC Conference Viewer displays each slide for 6 seconds.

n With continuous play on and timers off, you must advance slides manually by clicking the mouse. The 
presentation returns to the first slide after the last slide is displayed.



Chalk On Command

Choose Chalk On from the Presentation menu to switch chalk annotations on and off. Chalk lets you draw 
annotations to emphasize points during a ScreenShow presentation.

With chalk on, start a ScreenShow, then drag with the left or right mouse buttons to add temporary chalk 
annotations. Press F2 or go to another slide to erase chalk.



Use Timers

Choose Use Timers from the Presentation menu to turn on timers for your presentation. The timers begin 
counting when you play a ScreenShow presentation.

n When you use timers, the program keeps track of elapsed time, based on slide times set as 
ScreenShow Effects in Harvard Graphics. When a time elapses, the program advances to the next 
slide, or uses another timeout event you set in Harvard Graphics.

n If you also turn on Continous Play, the presentation returns to the first slide after the last slide is 
displayed.

n With both Use Timers and Continuous Play on, if you didn't enter slide times in Harvard Graphics, 
SPC Conference Viewer displays each slide for 6 seconds.

With Use Timers off, no timeout events occur, and you should go to slides by clicking the left and right 
mouse buttons.



Play

Click the Play icon in the navigation bar or choose Play from the Presentation menu to begin a 
ScreenShow presentation. Or press Alt+F2.



Open

Use the Open dialog box to open files saved in the SPC Runtime Presentation file (.PLY) format.

n Select a filename and path, then click OK.

Open dialog box items

    File Name
    Directories
    File List
    Drives
    List Files of Type
    Thumbnail



File Name

Type the name of the SPC Runtime Presentation (.PLY) file you want to open. Or select a file 
in the list. Include the full pathname if you want to open a file in a different directory or drive, or 
use the Directories and Drives lists.



File List

Shows the SPC Runtime Presentations in the current directory. If you select one, the name 
appears in the File Name box.



List Files of Type

Shows the selected file type.



Directories

To change directory, double-click a directory name in the list.



Drives

To change drive, click the drop-down arrow, then click a drive letter.



Thumbnail Sketch

When you select an SPC Runtime Presentation file, a thumbnail sketch of the first slide 
appears in the sample box.



Save As

Use the Save As dialog box to save files or rename files in the SPC Runtime Presentation file (.PLY) 
format.

n Type or select a filename and path, then click OK.

Save As dialog box items

    File Name
    Directories
    File List
    Drives
    List Files of Type



File Name

Type the name of the SPC Runtime Presentation (.PLY) file you want to save. Include the full 
pathname if you want to save a file in a different directory or drive, or use the Directories and 
Drives lists.



File List

Shows the SPC Runtime Presentations in the current directory. If you select one, the name 
appears in the File Name box.



Print Setup

Use the Print Setup dialog box to set up the default printer for your presentations.

n Select a printer, orientation, paper size, paper source, and other options, then click OK.

Print Setup dialog box items

    Printer
    Options
    Orientation
    Network
    Paper Size and Source



Printer

Use the Default Printer or select a Specific Printer from the list.



Orientation

Choose to print slides or handouts either in Landscape (horizontal) or Portrait (vertical) 
orientation. The sample box shows an example of your selection.



Paper Size and Source

Select a paper size and printer tray source from the lists.



Options

Displays the Windows printer Options dialog box.



Network

This option, available only on some Windows configurations, lets you connect to other network 
printers.



Print

Use the Print dialog box to print the current presentation.

n Select the number of copies, output format, orientation, and other printing options, then click OK.

Print dialog box items

    Output Device
    Quality
    Copies
    Orientation
    Range
    Print As
    Setup



Output Device

The current printer and connection are displayed. To select a different output device, click the 
drop-down arrow, then click another printer name.



Copies

Defaults to 1. Type the number of copies you want to print.



Range

Defaults to All Slides. Click the Selected Slide(s) button to print slides you selected in the Slide 
Sorter. Or click the Slides button, then type slide numbers in the From and To boxes.



Quality

To print with highest quality, click the Final button. To print most quickly and with a little less 
quality on some printers, click the Quick button.



Orientation

Choose to print slides or handouts either in Landscape (horizontal) or Portrait (vertical) 
orientation. The sample box shows an example of your selection.



Print As

Choose to print the current presentation as Handouts or Slides.

n For Handouts, also click the drop-down arrow to select the number and position of slides on 
the handouts page.

n Selecting Slides prints slides on a full page.



Setup

Goes to the Windows printer setup dialog box for your specific printer driver.



Move Slide

Use the Move Slide dialog box to move one or more selected slides to another position.

n After you select one or more slides and choose Move, the title and position of slides in the current 
presentation appear.

Click a slide title to reference where you want to move the selected slides. A thumbnail sketch 
appears. If it's not the correct slide, select other slides until you locate the slide you want.

Then click Before or After to move the slide to the new position. The program updates the order of 
slides and returns to the Slide Sorter.

Related Topics
Changing the Order of Slides
Selecting and Moving Slides



Find Slide

Use the Find Slide dialog box to find and go to any slide in the current presentation.

n To find a slide, click a slide title and view the thumbnail sketch. Click another slide title, if necessary. 
When you find the slide you want, click OK.

When you find a slide during a ScreenShow, the program displays the slide and you can continue. 
Otherwise, the program selects the slide and displays it in the Slide Sorter.

Related Topic
Finding Slides



Links and File References

Use the Links and File References dialog box to verify, cancel, and change OLE links to data in other 
applications and to externally referenced files.

n To edit links, select a linked file from the list and click the Cancel or Change Link buttons. When you 
complete your changes, click Done.

Links and File References dialog box items

    List of Links
    Update Status
    Application
    Location
    Topic
    Cancel Link Button
    Item
    Change Link Button



List of Links

Click a link or file reference to work with.

The list shows the Application, Topic, the Item location, such as a spreadsheet range, and the 
Update Status (Automatic, Manual, or Unavailable).



Application

Shows the product name of the source of the linked data or external file.



Topic

Shows the drive, directory, and filename of the linked data or external file.



Item

Shows the data location, such as a spreadsheet range name or a database field name.



Update Status

Shows whether the link is automatically or manually updated or unavailable (broken).



Location

Shows the object number and slide location or file reference designation.



Cancel Link Button

Breaks the selected link between the program and the server application.



Change Link Button

Modifies the filename and path of the selected link or external file.

You can restore an Unavailable link, for example, if the source data file has been moved or 
renamed.

If you receive a presentation with links that were created on another system, you probably 
need to change the link paths to the drives and directories on your system. 



Change Link

Use the Change Link dialog box to modify the path of the selected link or external file. You can change 
the link to restore a broken link, for example, if the source file has been moved or renamed.

n To change a link, select a filename, then click OK.

Change Link dialog box items

    File Name
    Directories
    File List
    Drives
    List Files of Type

Note

n Occasionally, network problems, damaged files, deleted files, or moved files might make it impossible 
to restore broken links.



File Name

Type the filename of the linked or referenced file. Or select a file in the list. Include the full 
pathname if you want to open a file in a different directory or drive, or use the Directories and 
Drives lists.



File List

Shows the files in the current directory that match the current file type.



List Files of Type

Shows the selected file type.



Configure Conference Command

To configure your system for ScreenShow conferences, choose Configure from the Conference menu.

The Conference Setup dialog box appears, where you can set the network drive and path for the 
conference.

Related Topic
Configuring a Conference



Start Conference Command

To start a ScreenShow conference of the current presentation, choose Start from the Conference menu.

Or click the Start Conference icon.

Before Starting a Conference

n While you can use SPC Conference Viewer or Spotlight to start a conference, for best results, 
attendees should use SPC Conference Viewer, which you can send by E-Mail.

n Tell attendees the starting time, the conference name, and the password (if required) they should 
enter as they join the conference using SPC Conference Viewer.

n Determine the telephone number for each attendee so you can call and talk to them during the 
conference.

Related Topics
Configuring a Conference
Starting a Conference



Join Conference Command

To join a ScreenShow conference in progress, choose Join from the Conference menu.

Or click the Join Conference icon.

To Join a Conference

You must know the conference name and have read access to the network location where the 
presentation files reside. You must also know the network password (if required).

Related Topic
Joining a Conference



Back Button

Click the Back button to go back one slide.

Note

n While playing a ScreenShow presentation, go back one slide by clicking the right mouse button.



Rewind Button

Click the Rewind button to go to the first slide in the presentation.



Advance Button

Click the Advance button to go to the next slide in the Slide Sorter.

If there are no more slides, the main screen appears.

Note

n While playing a ScreenShow presentation, go to the next slide by clicking the left mouse button.



Play Button

To begin a ScreenShow presentation, click the Play button in the icon bar or navigation bar.



Find Slide Button

Click the Find Slide button to find and go to any slide in the current presentation. Or press Ctrl+F.

The Find Slide dialog box appears, where you can view the title and position of each slide in the 
presentation and a thumbnail sketch. You can select a slide from the list, then click OK to go to it.



Help Button

Displays Help when you click the Help button, then click an on-screen item.



Minimize Button

Minimizes SPC Conference Viewer. Double-click the minimized icon to restore the application.



Slide Sorter

The Slide Sorter shows thumbnail sketches of each slide in the presentation. In the Slide Sorter, you can:

n Drag slides to the left or right to rearrange their order.

n Click a slide to select it, or press Shift and click to select multiple slides.

n Once slides are selected, you can choose the Move or Copy Slide Image commands from the Edit 
menu.



Slide Title

Shows the number and title of a slide in the Slide Sorter.



Scroll Bar

Click the scroll bar or arrows to view more slides in the current presentation.



Status Bar

Shows information about the current presentation, including the number of total slides and how many 
slides are selected.



Contents Command

To display a summary of Help categories, choose Contents from the Help menu.



Search Help Command

To look for Help by specific indexed keyword, choose Search Help from the Help menu.

The program displays the Search dialog box where you can type or select a keyword, then go to the 
desired topic.



How To Command

To view the SPC Conference Viewer Coach and a variety of topics for using the program, choose How To 
from the Help menu. You can keep the Coach on-screen as you work.



Getting Help Command

To learn how to get Help, choose Getting Help from the Help menu.



About SPC Conference Viewer Command

To display product version information, choose About SPC Conference Viewer from the Help menu.



 

 

Getting Help
Click the Help icon in the icon bar to display the Help cursor, then click an item you want to learn about. 
You can click with the Help cursor on:

n Icons and navigation buttons

n Other items on the main screen

n Menu items

How to use SPC Conference Viewer

For step-by-step instructions, choose How To from the Help Contents or main Help menu, then click a 
topic to display the steps in the Coach.

Help on Dialog Boxes

For an overview of controls in a dialog box, click the Help button or press F1.

Help on Menu Items

To learn about menu items, highlight a menu item and press F1, or use the Help cursor.



Getting Help

Click the Help icon in the icon bar to display the Help cursor, then click an item you want to learn about. 
You can click with the Help cursor on:

n Icons and navigation buttons

n Other items on the main screen

n Menu items

How to use SPC Conference Viewer

For step-by-step instructions, choose How To from the Help Contents or main Help menu, then click a 
topic to display the steps in the Coach.

Help on Dialog Boxes

For an overview of controls in a dialog box, click the Help button or press F1.

Help on Menu Items

To learn about menu items, highlight a menu item and press F1, or use the Help cursor.



Control Menu

The Control menus in the SPC Conference Viewer can contain the following commands:

Restore

Restores a window to its previous size after it has been minimized.

Move

Enables you to use cursor arrow keys to move the current application, panel, or dialog box window.

Size

Enables you to use cursor arrow keys to resize the current application, panel, or dialog box window.

Minimize

Reduces any window to an icon.

Maximize

Enlarges a window to its maximum size.

Close

Closes the current application, window, or dialog box.

Switch To

Opens the Task List, which you can use to switch between running applications.



This glossary contains a list of defined terms used in online Help. To see the definition of a term, click it. 
Click one of the letters above to jump to that part of the glossary.
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attendee

A person joining an online presentation conference.



autobuild

A ScreenShow feature of Harvard Graphics supported in Spotlight to display slides with bullet 
lists or pie charts one point or item at a time.



baud rate

A measure of the speed of data transfer in serial communication between two computers. For 
ScreenShows with two machines connected, you can verify or change the baud rate by 
choosing Configuration from the Options menu.



button

Object you define and assign an action to in a HyperShow in Harvard Graphics. During a 
Spotlight ScreenShow of the Runtime Presentation file, click HyperShow buttons to jump to 
other slides, play sound files, launch applications, or stop the ScreenShow.



chalk

A feature that lets you drag the mouse to make temporary annotations on a slide during a 
ScreenShow. Erase the annotations by clicking the chalk eraser in the Current Slide panel.



client

In Object Linking and Embedding (OLE), the application that is the destination for data or an 
object that is being linked or embedded.



conference

The simultaneous display of a ScreenShow on computer systems in remote locations across a 
Local Area Network (LAN) or Wide Area Network (WAN).



desktop

The on-screen arrangement of slide and navigation control panels in the workspace for your 
preparation, practicing, or presenting needs.

You can save custom desktops for later use or get any of several sample desktops that come 
with the program.



embedded object

An OLE object that is copied from a server application. The server application can be launched 
by double-clicking the object.



handouts

A printing option allowing you to print one or more slides in miniature for copying and 
distribution to your audience.

Audience members can follow along and add notes in the margins.



HyperShow

Interactive ScreenShow that lets the viewer choose paths through the ScreenShow. A 
HyperShow uses keys and/or buttons to branch to other slides in the show, to other 
applications, or to play sound or video files.



HyperShow links

Keys and buttons assigned to slides and used during a ScreenShow to jump to other slides or 
to other applications.



icon

Pictorial representation of menu commands and of some window elements (for example, the 
Open and Save icons).



icon bar

A horizontal bar at the top of the screen containing pictorial representations of menu 
commands.



key

Key combination (like Ctrl+A) that you define and assign an action to in a HyperShow in 
Harvard Graphics. During a Spotlight ScreenShow of the Runtime Presentation file, use the 
HyperShow keys to jump to other slides, play sound files, launch applications, or stop the 
ScreenShow.



LapLink

Term for a trademarked serial null modem cable that supports two styles of connectors on 
each end of the cable. Other null modem cables generally support just one plug on each end.

Null modem cables make computer-to-computer serial connections possible by adjusting the 
wiring for send and receive pins, compared to standard serial cables.

LapLink-style cables include both 9-pin and 25-pin connectors on each cable end to account 
for hardware differences that people who use the cables might encounter. A 6-foot LapLink-
style cable is supplied with Spotlight.



link

1. Data connected across applications with OLE. When you connect data or objects, those 
items remain connected to the original server. 2. In importing, to keep a reference to data that 
you've imported. 3. In HyperShows, to connect external files, or other parts of the presentation, 
to a slide with keys or buttons.



link reference

In OLE, the information that applications use to locate data in an external file.



moderator

In conferencing, the person who sets up, starts, and closes the conference.



multimedia

The term for the variety of elements in HyperShows available in Harvard Graphics and 
Spotlight, including support for voice, music, and video in addition to text and graphics.



null modem

Term for a serial cable that makes computer-to-computer serial connections possible by 
adjusting the wiring for send and receive pins, as compared to standard serial cables.

Null modem cables generally have plugs to connect to either 9-pin or 25-pin serial 
communication ports.

LapLink-style null modem cables include both 9-pin and 25-pin connectors on each cable end 
to account for hardware differences that people who use the cables might encounter. A 6-foot 
LapLink-style cable is supplied with Spotlight.



object

1. Any line, text, geometric shape, or symbol. 2. In OLE, information such as a cell range, 
chart, graphic, or entire file that is embedded in or linked to a Harvard Graphics slide, or 
embedded in or linked to another application.



OLE

Object Linking and Embedding. A feature provided by Microsoft Windows that makes it 
possible to combine data from different Windows applications into a single document. A server 
application maintains or provides the data, and a client application uses that data.



port, serial

A hardware connection on computers and modems used to attach cables in support of serial 
data communications.

For Spotlight ScreenShows on two machines connected, you connect a LapLink-style cable or 
null modem between serial ports on the two machines.



presentation notes

Remarks you enter for each slide in the Presentation Notes panel in Spotlight.



presentation

Ordered collection of related slides, all in one presentation file. The name of the current 
presentation appears in the title bar.



presenter

In ScreenShows, the person who controls the mouse movements and slide changes.



ScreenShow

Slide-by-slide display of a presentation, including slide and sound effects, on a computer 
screen.



server

In Object Linking and Embedding (OLE), the application that is the source of data or an object 
that is being linked or embedded.



slide

Basic unit in a presentation. Each slide can use charts, text, and images or drawings to convey 
an idea.



Slide Manager

Thumbnail view of all slides in a presentation. The slides can be reorganized graphically.



sound files

Spotlight supports the playing of music and voice files added through the Edit ScreenShow 
Effects dialog box in Harvard Graphics.



source

In OLE, the Microsoft Windows application that is the server for the data or object that is being 
linked or embedded.



speed keys

Key combinations that enable you to bypass menus to perform common functions (for 
example, Ctrl+S to save a presentation). The speed keys are listed on each menu.



Video Player

A file (WINVPLAY.EXE) that comes with Harvard Graphics that allows you to play Microsoft 
Video for Windows AVI files and Intel's Indeo (DVI) files in a HyperShow. You can also run 
Video Player as a standalone application.



Keyboard

Click a topic below to view the speed keys you can use in SPC Conference Viewer.

n File

n Edit

n Presentation

n Help



File

Keyboard controls:

Press: To:

Ctrl+O Open an SPC Runtime Presentation (.PLY) file

Ctrl+S Save an SPC Runtime Presentation file

Ctrl+P Print the current presentation

Alt+F4 Exit



Edit

Keyboard controls:

Press: To:

Ctrl+C Copy Slide Image



Presentation

Keyboard controls:

Press: To:

Alt+F2 Play the current presentation as a ScreenShow

Pause Pause a ScreenShow

Ctrl+F Display the Find Slide dialog box

Esc Stop a ScreenShow / Display Conference Commands

F2 Erase chalk / refresh screen



Help

Keyboard control:

Press: To:

F1 Get Help

Shift+F1 Use the Help cursor



Questions and Answers

Getting Technical Support

n How do I contact a Technical Support representative?    Answer

n How can I post SPC Conference Viewer questions to CompuServe?    Answer

n How do I access SPC's 24-hour automated answer service?    Answer

n How do I contact a Customer Service representative?    Answer



Contacting Technical Support

If you have a technical problem and you can't find the solution:

1. Note the sequence of events that led to the problem, and any program messages you see.

2. Call Technical Support. Have your user manual handy and the product running on your computer 
when you call.

Technical Support Phone Numbers

United States 608-274-9715 (phone)
608-274-3999 (fax)

Latin America Contact your local distributor

All other countries To receive support you must first register your copy of SPC Conference Viewer. 
On registration you will receive an information pack giving you details of your 
regional support center.



CompuServe

You can post your questions on CompuServe, a private electronic information service, and an SPC 
representative will send you the answers. If you are a member of CompuServe, enter GO SPCFORUM at 
the ! prompt.

CompuServe Customer Support Numbers

United States and Canada 800-524-3388 (toll free)

Outside of U.S. and Canada 614-457-0802

Europe

United Kingdom 0800 289378 (freephone)

Germany 0130 37 32 (toll free)

Switzerland 155 31 79 (toll free)

Other European Countries 44 252 255111

Pacific

Within Japan 0120-22-1200

Outside Japan 03-3221-7363

When you sign up for CompuServe, mention "Operator 140" to get any discounts that are available at that 
time.



ReadyReference

You can get technical advice from SPC's ReadyReference, an automated, interactive voice response 
system. It is available 24 hours a day, seven days a week. ReadyReference consists of:

Fax-on-Demand

Fax-on-Demand lets you order faxes of product fact sheets, technical bulletins, application notes, 
upgrade forms, and other materials.

United States and Canada 608-274-7284

Auto-Expert

Auto-Expert is an automated troubleshooting system that can help you solve your technical problem. You 
can request a fax transcript of your interactive session.

United States and Canada 608-274-7284

You might want to try ReadyReference before contacting Technical Support. Or, use ReadyReference 
while you hold for a Support Representative.



Contacting Customer Service

If you need to order additional copies of products or have some other non-technical question, call our 
Customer Service department.

Customer Service

United States 800-234-2500

Latin America Contact your local distributor

All other countries Contact your local distributor



Using SPC Conference Viewer

Click a category below, then click a topic to display the steps in the Coach.

n Getting Started

n Working with Presentations

n Playing ScreenShow Presentations

n Conferencing Presentations

Working in the Coach

To return to this screen, click the Tasks icon.

To print a topic, click the Print icon.

To close the Coach, click the Exit icon.

Hint    Keeping the Coach On Top



Getting Started

n Introducing the Viewer

n Using the Icon Bar

n Using the Navigation Bar

n Getting Help

Hint    Keeping the Coach On Top



 

 

Introducing the Viewer
Welcome to SPC Conference Viewer, a product enabling you to view and conference ScreenShow 
presentations without running Harvard Spotlight or Harvard Graphics.

The program uses SPC Runtime Presentation (.PLY) files, including presentation files saved in Harvard 
Spotlight or exported from Harvard Graphics.

Your Conference Connection

Use SPC Conference Viewer to join conferences of SPC Runtime Presentation files started by other 
conference moderators. Or start your own conferences for others to join.

Thank You

Thanks for using SPC Conference Viewer. To license additional copies of the program, call Software 
Publishing Corp. Customer Service anywhere in the U.S. at 800-234-2500. Or see your local software 
supplier.



 

 

Using the Icon Bar
Icons are an easy way to run commands, and SPC Conference Viewer offers them for the most 
commonly-used menu choices. Instead of choosing those commands from a menu, just click the icons.



 

 

Using the Navigation Bar
The navigation bar at the bottom of the main screen offers five buttons to let you go to slides as you sort 
them and to start a ScreenShow.

To learn about the navigation buttons, click the Help icon in the icon bar, then click with the Help cursor on 
any of the buttons.



Working with Presentations

n Opening a Presentation

n Exporting HGW Presentations

n Changing the Order of Slides

n Selecting and Moving Slides

n Finding Slides

n Saving a Presentation

n Setting Up Your Printer

n Printing a Presentation

n Fixing Broken Links or References

n Exiting SPC Conference Viewer
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Opening a Presentation
1 Click the Open icon to display the Open dialog box.

2 Click a filename in the list or type a path and filename in the File Name box.

Use the Drives and Directories controls to go to another directory.

3 Click OK.

SPC Conference Viewer supports files stored in the SPC Runtime Presentation file (.PLY) format.



 

 

Exporting HGW Presentations
1 In Harvard Graphics, with a presentation open, choose Export from the File menu.

2 Select Runtime Presentation (.PLY) from the file type list.

3 Type a path and filename in the File Name box. If you don't type an extension, the program adds .PLY 
for you.

Use the Drives and Directories controls to export the file to another directory, such as the SPC 
Conference Viewer \PLYFILES directory.

4 Click OK.

The HGW Runtime Presentation Export dialog box appears.

5 Select SVGA full color (640x480) for a color depth and size.

6 Uncheck the Minimum Export check box so that links to OLE objects are preserved in the exported 
(.PLY) file, then click OK.

Hint    To view these steps as you work in Harvard Graphics, click the Tasks icon above, click On Top in 
the Help button bar, then Close the main Help window.



 

 

Selecting and Moving Slides
n In the Slide Sorter at the main screen, use the scroll bar to display the desired slide, then click the 

slide to select it.

n To select multiple slides, hold Shift and click one or more slides. The status bar shows how many 
slides are selected.

n To deselect a slide, click a selected slide.

n To deselect all slides, click in a blank portion of the main screen.

n Move selected slides by dragging them to the left or right in the Slide Sorter. Or choose Move from the 
Edit menu.



 

 

Finding Slides
1 Click the Find Slide icon at the main screen, or press Ctrl+F during a ScreenShow.

2 In the Find Slide dialog box, click the title of a slide in the list.

A thumbnail sketch appears. Continue selecting slides until you find the slide you want to go to.

3 Click OK.

Note

n When you find a slide during a ScreenShow, the program displays that slide and you can continue. 
Otherwise, the program displays the selected slide in the Slide Sorter at the main screen.



 

 

Changing the Order of Slides
1 Select one or more slides in the Slide Sorter at the main screen.

2 Choose Move from the Edit menu. The title and position of slides in the current presentation appear.

3 Click a slide title to reference where you want to move the selected slides. A thumbnail sketch 
appears. If it's not the correct slide, select other slides until you locate the slide you want.

4 Click Before or After to move the slide to the new position.

The program updates the order of slides and returns to the Slide Sorter.

Note

n If you select multiple slides, they are moved beside the target slide in relative order, from left to right.



 

 

Saving a Presentation
1 With a presentation open, click the Save icon.

If the presentation is already named, the file is saved and you can continue.

2 If the Save As dialog box appears, enter a filename and path. SPC Conference Viewer adds .PLY 
automatically if you don't enter an extension.

3 Click OK to save the file.



 

 

Setting Up Your Printer
1 Choose Print Setup from the File menu.

2 Select a printer, page orientation, paper size, and paper source.

Click Options to view or change the Windows printer options. Also, if available, click Network if you 
want to connect to another network printer.

3 Click OK.



 

 

Printing a Presentation
1 To print the current presentation, click the Print icon in the icon bar.

2 Select the printer or other output device, and set the quality.

3 Select an option to print All Slides, Selected Slide(s), or a range of Slides.

4 Set the Orientation to Landscape (sideways) or Portrait.

5 For the Print As format, print full-page Slides, or select Handouts to print miniature images of slides. 
Also set the number and position of slides for the handouts.

6 Click Setup if you want to view or change Windows printer Setup options.

7 Click OK.



 

 

Fixing Broken
Links or References
1 In the Links and File References dialog box, select the object or externally referenced file you want to 

verify or change.

2 Click Change Link.

3 Enter a filename and path to the new source location of the linked or externally referenced file.

4 Click OK.

5 Click Done to update the link and close the Links and File References dialog box.



 

 

Exiting SPC Conference Viewer
n Choose Exit from the File menu.



Playing ScreenShow Presentations

n Starting a ScreenShow

n Navigating to Other Slides

n Using Chalk Annotations

n Finding Slides

n Stopping a ScreenShow
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Starting a ScreenShow
1 Open an SPC Runtime Presentation (.PLY) file.

2 Click the Play button in the navigation bar.

3 After starting the ScreenShow, click the right mouse button to go to the next slide. Or click the left 
mouse button to go back one slide. Or use the cursor arrow keys.

After the last slide, the program returns to the main screen. Or during Continuous Play, the program 
returns to the first slide.

Hint    If the presentation includes HyperShow buttons or keys, you can click the button or press the keys 
to launch the HyperShow application or OLE action. To return to SPC Conference Viewer, exit the 
HyperShow launch or OLE application in a normal way.



 

 

Navigating to Other Slides
n During a ScreenShow, click the right mouse button or press the right arrow key to advance slides.

n To go back one slide, click the left mouse button or press the left arrow key.

n To pause a ScreenShow, press the Pause key. To resume, press Pause again.

n To stop a ScreenShow, press Esc.

n After the last slide, the program returns to the main screen. Or during Continuous Play, the program 
returns to the first slide.

n To go to any slide, press Ctrl+F to display the Find Slide dialog box.



 

 

Using Chalk Annotations
1 With Chalk turned on in the Presentation menu, start a ScreenShow and position the pointer where 

you want to draw a chalk annotation.

2 Drag with either the left or right mouse buttons in any direction, using slow movements to draw lines, 
arrowheads, circles, or other marks.

3 Release the mouse to finish the annotation. Drag again to draw additional annotations.

Notes

n To erase chalk, press F2, or go to another slide.

n While trying to draw chalk, if you accidentally release the mouse button before dragging, the program 
might advance or go back one slide. If so, click the left or right mouse button to return to the previous 
slide.



 

 

Stopping a ScreenShow
n Press Esc.

The program returns to the main screen.



Presenting by Conference

Click a topic to learn about conferencing, which lets you play a ScreenShow on up to 64 computers 
connected by LAN.

n Configuring a Conference

n Starting a Conference

n Joining a Conference

n Sharing Conference Control

n Closing a Conference

n Conferencing Tips

n Conferencing with Harvard Graphics Users
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Configuring a Conference
1 Choose Configuration from the Conference menu.

2 Select a drive in the Current Drive Connections list, then type the full pathname (up to 30 characters) 
in the Network Path Box.

3 Type the password of the network drive (up to 10 characters), if required for your network.

4 Select Require Users to Type Password if you want to require attendees to type the password to the 
network drive before they join the conference.

5 Click OK.

Note    The program uses these options for every conference you start until you change them.



 

 

Starting a Conference
1 Open the presentation you want to play during the conference.

2 Choose Start from the Conference menu.

3 Type your name (up to 13 characters) and an optional telephone number (up to 22 characters).

4 Type the name of the conference (up to 8 characters).

5 Select how you want to be prompted if you receive any on-screen messages during the conference. (If 
you're playing multimedia sound files in your ScreenShow, select Visible.)

6 Select whether to start viewing the ScreenShow from the beginning or the current slide.

7 Click OK.

Notes

n While displaying the ScreenShow, press Esc to use conference commands.

n If you haven't configured a conference on your computer yet, do that before trying to start a 
conference.

n Before you start the conference, give attendees the conference name, password, and time the 
conference will start, and set up a telephone conference call.

n The program creates a temporary directory on the network (network path\conf.hgw\confname), where 
it stores any files associated with the presentation. To specify a different directory, type the pathname 
for Conference Directory= in the [Conferencing] section of your SPOTLT.INI or SPCPLAY.INI files.

n If your presentation launches any applications, copy the necessary application and data files to the 
temporary conference directory.



 

 

Joining a Conference
For best results, you should join conferences using SPC Conference Viewer, not Spotlight.

1 Choose Join from the Conference menu.

2 Type your name (up to 13 characters) and an optional telephone number (up to 22 characters).

3 Type the name of the conference and the password, if it's required.

4 Select how you want to be prompted if you receive any messages during the conference. (If the 
ScreenShow plays multimedia sound files, select Visible.)

5 Click OK.

Hint    Before trying to join a conference, get the conference name, password (if required), and time the 
conference will start. During the conference, press Esc to use conference commands. 



 

 

Sharing Conference Control
As the conference moderator, you can share conference control with other attendees, so that they may 
lead portions of a ScreenShow.

1 During a conference you started, press Esc.

2 Select the attendee to whom you want to give control, then click Give Control.

3 Later, to regain control as the conference moderator, display the Conference Commands and click 
Take Control.



 

 

Closing a Conference
1 During a conference you started, press Esc.

2 Click Close Conference.



Conferencing Tips

Use these tips to help set up and manage a conference. There are tips for moderators who start 
conferences, for attendees who join conferences, and for network administrators who are responsible for 
security and performance of the network.

n Tips for Moderators

n Tips for Attendees

n Tips for Network Administrators
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Tips for Moderators
n While you can use SPC Conference Viewer or Spotlight to start a conference, attendees should use 

SPC Conference Viewer, which you can send by E-Mail.

n The viewer uses SPCPLAY.INI for conferencing information. Spotlight uses SPOTLT.INI.

n You can use conferencing to display a self-running ScreenShow that can be viewed by employees at 
their convenience. For example, an employee can join a conference set up by your company's Human 
Resources department to view a presentation on company benefits. It doesn't matter when you join or 
leave the self-running ScreenShow.

n You can conference with a ScreenShow that launches another application. However, if the application 
doesn't close automatically, you must have each attendee close the application before the 
ScreenShow can resume.

n If, for security or performance reasons, you don't want to copy the presentation file(s) to the network, 
you can load the files from your hard disk. Type File Copy Disable=1 in the [Conferencing] section of 
your SPCPLAY.INI or SPOTLT.INI files. Before the conference, send each attendee the file(s) and 
have them set up a local conference directory in their SPCPLAY.INI file for SPC Conference Viewer. 
Attendees should enter Local File Directory=[path], where [path] is the name of the local directory.

n For each conference, the program creates a temporary directory on the network, 
\CONF.HGW\CONFNAME, where CONFNAME is the name of the conference, and copies to that 
directory the .PLY file, referenced sound or video files, and OLE linked files associated with the 
presentation. To specify a temporary directory other than CONF.HGW, type the name for Conference 
Directory= in the [Conferencing] section of your SPCPLAY.INI or SPOTLT.INI files.

n To restrict the total number of participants, enter a number for Maximum Allowed Users= in the 
[Conferencing] section of the SPCPLAY or SPOTLT.INI files.



 

 

Tips for Attendees
n Attendees should use SPC Conference Viewer to join conferences started in Spotlight or by a 

moderator using another copy of SPC Conference Viewer. The viewer uses SPCPLAY.INI for 
conferencing information. Spotlight uses SPOTLT.INI.

n You might speed up the time it takes to join a conference if you get the conference presentation files 
from the conference moderator beforehand and load them from your hard disk instead of from the 
network. Specify a local directory on the hard disk by adding Local Conference Directory=[path] in the 
[Conferencing] section of your SPCPLAY.INI file, where [path] equals your local directory.

n Even if you specify a local directory, the program uses the network version if it can't find the local .PLY 
file or if the .PLY file on the network has a different date and time stamp. If you want to ensure the 
program loads the local file, type Local Version Checking=0 in the [Conferencing] section of your 
SPCPLAY.INI file.



 

 

Tips for Network Administrators
n See the NETWORKS.WRI file in Windows for more related network setup information.

n Make sure that all participants in a conference are using a NetBIOS from the same vendor, are 
running on the same network, and have access to the server. Before you change your system to set 
up NetBIOS compatibility, make sure the changes don't conflict with other applications you're using.

n The program tells the moderator approximately how many attendees may participate in a conference 
based on the number of available NetBIOS Control Blocks (NCBs) and NetBIOS SESSIONS on the 
moderator's system. The number of attendees who are actually allowed to join may be less if network 
resources are used for other applications, such as a mail-minder program.

To calculate the minimum network resources (NCBs) needed for a conference, add 3 to the number of 
attendees. For example, with 12 NCBs you can have 9 attendees (9+3=12). For optimum 
performance, increase the number to twice the number of attendees. You must have at least as many 
NetBIOS SESSIONS as attendees. You can have up to 64 attendees in a conference.

n If you're running Novell and conferencing across a Wide Area Network, contact Novell for the latest 
version of its NetBIOS driver.

n It's recommended that you set as a minimum NetHeapSize=16 in the [386Enh] section of the 
moderator's Windows SYSTEM.INI file. If more than 8 participants are expected to join a conference, 
increase the number to twice the number of attendees expected.

n Make sure that Windows is set up to run on a network. See your Windows documentation for more 
information.

n If all participants are on the local network, you may get better performance when opening 
presentations, and synchronizing mouse movements and slide changes between systems, by 
disabling NetBIOS' ability to operate over a Wide Area Network.



 

 

Conferencing with
Harvard Graphics Users
n For best results, people who want to join your conference should run a copy of SPC Conference 

Viewer, then choose Join from the Conference menu. You can mail the conference viewer to 
attendees before the conference.

n Users of SPC Conference Viewer can join conferences started in Harvard Graphics 3.0 for Windows.

Before a conference, the Harvard Graphics moderator should export the presentation to an SPC 
Runtime Presentation (.PLY) format in the same directory and with the same filename prefix as the 
source presentation (.PRS) file.

Later, during conference setup, Harvard Graphics 3.0 automatically copies the presentation (.PRS) file 
and the identically-named SPC Runtime Presentation (.PLY) file to the network area reserved for the 
conference. The SPC Conference Viewer opens the (.PLY) version of the presentation when 
attendees join the conference.



Coach On Top

To keep the Coach on-screen as you follow steps in a topic, click On Top in the Help button bar 
above. Then click Close in the button bar to close the main Help window.




