
What Is iCollect?

 iCollect is a time-saving cyber-storage application that allows you to capture, sort, store and view Web 
pages and all their supporting files.    It even allows you to download entire URLs with the links intact for 
later browsing. 

You can configure iCollect to automatically download specific URLs or you can browse the Internet and 
download on the fly.    Once you’ve downloaded the information you can browse through it at your leisure 
with no distractions (slow loading pages, dropped connections, etc.). 

iCollect also lets you search all the downloaded information (and produces a report of those search 
results), copy specific objects from a web page without downloading the entire page and create a slide 
show with some or all of the downloaded information.    If you want to get up to speed quickly browse the 
iCollect tutorial. 

Please note, when you run the tutorial from here the help file will exit.    You can access it again by 
pressing the F1 key on your keyboard.

For information on a specific topic click one of the following links:

· System requirements 

· Basics of iCollect

· Connecting to the Internet and Using iCollect

· The iCollect commands

· The iCollect proxy server 



System Requirements

iCollect has very minimal requirements:

· Microsoft Windows 95/98

· An Internet connection/ISP account (such as AOL)

· Any of the following browsers:

ü Netscape Communicator 2.0 or higher 
(drag-and-drop feature not available in 2.0)

ü Microsoft Internet Explorer 2.0 or higher 
(some features not available in 2.0)

NOTE:    We do not recommend launching the current version of AOL (4.0 revision 149.22) from within 
iCollect.    Therefore, if you use AOL, make sure you are connected and running prior to starting iCollect.



Basics of iCollect

To get started, take a moment to learn how iCollect works and familiarize yourself with the various 
features.

· Tutorial

· The iCollect Windows

· Understanding Libraries and Books

· Using iCollect commands

· Keyboard Commands

· The Toolbar

· The Control Bar 

· The iCollect Wizards

· Sample Library



The iCollect Windows

 iCollect has several window options on the main screen.    When you first run iCollect there are two main 
windows.    They are the Book/Link Window and the Icon Window and they make up the left and right 
sides of the main screen.    The Book/Link Window has several options.    You can choose between a view 
of books or links and links or comments as well as a hierarchical view.

There are two more window options on the main screen, the Card and Report Windows.    These appear 
above and below the Icon Window.    The information in each of these windows is much the same, 
although in different forms, however the Card Window is in editable format and allows you to make 
changes and/or notes about specific icons.

The Image Viewer is another window you only see when iCollect displays the thumbnail graphics some of 
the downloaded icons represent. 

You can use all the window options or choose only those that give you the information you need in the 
form you want.    The windows are all resizable and have scroll bars so you can adjust them to fit your 
screen in any manner that works for you.

· The Book Window shows how your collections are organized into books. 

· The Link Window presents the downloaded links in the open book in a hierarchical format. 

· The Icon Window displays thumbnails and other information about files and graphics in the 
open book.

· The Card Window gives details of each icon and displays file information in an editable 
format.

· The Report Window lists all the items in your download and displays additional information 
that doesn’t appear in the Icon Window.

· The Image Viewer allows you to see the full size image on some of the thumbnails in the Icon 
Window.



Book Window

 The Book Window, which appears on the left side of the iCollect screen, shows the books in the current 
library.    Each book is a collection of the links, graphics and other files you’ve downloaded.    You can 
create Child Books (books within books) and organize the information to suit your needs in this window.

Create a new book using the New Book command from the File menu and name it right then or rename it 
later.    iCollect will name the books in numerical succession if you don’t specify a name.    The first book 
you create will be named Book 1 and so on.    Child Books will be numbered similarly but will have the 
parent book number first.    For instance, the first child book in Book 5 is 5-1.

You can expand or collapse books, to reveal child books, by clicking the plus/minus signs next to the main 
books and open other books by double-clicking the book icons.    When you click on a book its icon 
changes to depict an open book and the information in that book appears in the Icon Window.    If you 
have the Display Page Elements command turned on you will see an icon for every piece of information 
downloaded from a specific URL. 

Right-click on a book to see command options.    Click Open to view the contents of that book in the Book 
and Icon windows, rename the book, create a new book, new child book, or delete the book you’ve 
clicked on.



 The Search feature makes it easier to sort and organize files --by type, filename, URL, Comment, date, 
size or by content (using keywords).    iCollect places the results of its search in a separate file in the Book 
Window.    Click that file and all the icons matching the search criteria appear in the Icon Window.

 iCollect has a nifty report feature too.    Click on Book Information, in the right click menu, to see a brief 
report on the number and type of items that book contains, or place your mouse cursor over a book icon 
and the report will pop up. 

The drag and drop feature in iCollect allows you to organize books in the library.    Just click a book, drag 
it where you want it and drop it.    And if you find your hierarchy of books disappearing behind the Icon 
Window you can resize the Book Window.    Place your mouse cursor over the right side of the Book 
Window and when it changes into a double arrow click and move the pane to the right to widen the box.    
Reverse the direction to make the box narrower.

The Book Window becomes the Link Window when you click the Link icon.



Link Window

 The Link Window, which appears on the left side of the iCollect screen when you click the Link button, 
displays all of the links imported into a library.    A library is a collection of books --Books are collections of 
links, graphics and other files and Links allow you to see the hierarchy of links imported into the books in 
a library. 

Links can be displayed using either the Comment --a descriptive identifier, like “Netscape Netcenter 
Logo”-- by which the link is known or the actual URL --Universal Resource Language is the Internet 
address of a link --the “www.something.com” string of characters.    Click the URL or Comment button at 
the top of the Link Window to change the display. 

You can collapse or expand levels by clicking the plus and minus signs to the left of main links. 
Access a specific link by clicking directly on that URL or Comment in the Link Window.    Click once on a 
link to see the corresponding icon in the Icon Window.    You’ll notice a small red arrow appear to the left 
of the URL or Comment in the Link Window.    Double-click on a link Comment or URL in the Link Window 
and iCollect will display the image in the Image Viewer or your browser window.



Card Window

 The Card Window, which appears above Icon Window, displays information about the highlighted icon in 
an editable format.    You can change the URL, Comment, filename or the folder where it is stored on your 
hard disc.    Changes to the information for this link will be reflected in the other windows.    For example, if 
you change the comment in the Card Window, the revised comment will be updated in the Link Window 
and the Report Windowas soon as you click the Save button in the Card Window.

Use the Move button to move a file to another folder on your hard disc.    The icon will remain where it is 
but will point to the file in its new location.    For instance, if you have downloaded several GIF graphics 
files and you want to group them you can direct iCollect to search for that type of file, open the search 
results and move each record iCollect found to a folder called GIFs.    You will need to create the folder on 
your hard disc first.    Once you’ve moved all the records click the Save button in the Card Window and 
iCollect will update all the link information so it can keep track of those records.    The icons will remain in 
the original book(s) iCollect found them in as well as the search results, if you save those.

Note:    If there are several files you want to move the Move Files command from the File Options menu 
may be a better choice. 

The Browse button allows you to point an icon at another file on your hard disc.    An example of its use 
would be directing iCollect to look for another file when clicking on an icon.    For instance, say you have 
imported a file from your computer and then changed your mind    Instead of importing another file, and 
deleting the original, you can simply point the icon for the first file at the second.    Highlight the original file 
icon, click on the Browse button and find the file you do want.    Click on it, click Open and you’ll see the 
new filename replace the original filename in the filename field.    Now click the Save button in the card 
window.    When you access the icon now you will see the second file you wanted, not the first.

Clicking the left and right arrow buttons lets you scroll through the files in the open book.    You can also 
add additional comments and “keywords” in this window and then run a search later based on those.    If 
an icon has a thumbnail you can see it in the Card Window when the icon is highlighted and you can 
replace the actual thumbnail with text.    Just type something in the Alternate Text for Thumbnail field, click 
Save and you’ll see the thumbnail change. 



Icon Window

 The Icon Window, which appears on the right of the iCollect screen, displays thumbnails, as well as a file 
name and URL, of the links in the active book in the Book/Link Window.    These thumbnails are known as 
icons.    Each icon depicts a single link to an HTML file, a graphic file, or another type of file.    To see a file 
double-click the icon.    If it’s not an active link iCollect will display the image in an iCollect window, called 
the Image Viewer. 

If it’s an active link you will see a crooked arrow appear beneath the arrow pointer when you move your 
mouse cursor over it.    This symbol means that the icon you are pointing at is an active link.    If you 
double-click the icon iCollect will launch your browser and search for that URL.    If it is available you will 
see it appear in your browser window and you can begin downloading new information.

You can change the size of the icons by clicking on the Zoom field next to the Card Window button, above 
the Icon Window, and choosing a percentage.    The default is 100% but if you need to enlarge the icons 
you can do so to 200%.    You can also reduce them as far as 50%.    At 200% you will see a larger 
thumbnail of the image and most, if not all, of the URL, Comment and filename, although you will see very 
few icons onscreen at one time.    At 50% you will see more icons onscreen but they will be small and you 
will not see all of the URL, Comment or filename.    In this case, you can move your mouse cursor over 
these areas on the icon and the full URL, Comment and filename will pop up.

You can print the icons from the Icon Window using the Print or Print Preview commands from the File 
menu.    The icons will print out in “contact sheet” form representing all the information you’ve 
downloaded in a book.    This is useful for sorting or for choosing which icons to use in creating a slide 
show.

With the Display Page Elements feature you can change the display in the Icon Window with a toggle.    If 
this feature is unchecked, each page will appear as one icon.    When checked, each html page will 
appear as an icon, and each image (GIF, JPG, etc.) will appear as an icon.    Every component of every 
page will be listed separately with this feature. 



Report Window

 The Report Window appears below the Icon Window when you click on the Report button and displays 
the URLs, comments and other information for each link displayed in the Icon Window.

Click on a link in the Report Window to see the corresponding icon highlight in the Icon Window.    If the 
Link Window is active you will see the red arrow move to that link in the list.



Image Viewer

 When you double-click an thumbnail in the Icon Window the Image Viewer appears.    The image on the 
thumbnail is displayed at the same size as it appeared on the page from which it was downloaded.    
Some thumbnail images are small and not easy to decipher, using the Image Viewer is a good way to see 
the entire image. 

 You can enlarge an image in the Image Viewer by right-clicking on it and choosing the Zoom feature.    
You can Zoom In and Out or Zoom the image to fit the window.    Depending on the image, you may get a 
very “pixelated” picture (that is you see each of the pixels that make up the image) at this size.

Use the Image Viewer to help sort and organize the files in your books.    View them and choose where to 
put them or use the Delete command from the right-click menu to delete images you have no use for.

You can also click on Print Preview from the right-click menu to see what will print out if you choose to 
print the picture from the Image Viewer.    To print, use the Print command from the File menu.

To close the Image Viewer use the Close command from the File menu. 



Understanding Libraries and Books

· How Does iCollect Store Information?

· Creating and Saving New Libraries

· Creating and Saving New Books

· Creating and Saving New Child Books



How Does iCollect Store Data?

Information from the Internet comes in to iCollect, is copied to a folder and saved.    However, if you use 
the Import File or Import Cache Data commands iCollect makes a link to the location of the information on 
your hard disc and doesn’t actually copy the files.    You can use the Copy Files to Library command to 
replace this link with the actual files.

It’s important to note that the information gathered with the Import Cache Data command is highly 
transient and could suddenly disappear.    Files in a browser’s cache are automatically deleted when the 
cache exceeds a certain size (configured in the browser’s preferences --typically around 5000K).    Make 
sure to move this information to a folder if you want it saved permanently. 

When you download links and files with iCollect they’re stored in a book.    You can store all your links and 
files in a single book or you can sort and organize groups of links and files into separate books.    For 
instance, you may want to group all the links for a large web site in a single book, perhaps sorted further 
still inside that book.    To do this, create a parent book and then create child books, located inside the 
parent book similar to sub folders. 

If you are downloading the PBS (Public Broadcasting Services) web site you might want to separate the 
children’s information from the adult content (information on fund raising, Masterpiece Theatre, etc.).    
You could name your parent book “PBS” and download the main page from the PBS web site to that 
book, then create two child books (“Kid’s Stuff” and “Adult Stuff”) and download the other information 
accordingly.

Libraries are the way iCollect stores books.    Each time you use the Save command all the books you’ve 
created are saved in a library.    To create a new library use the New Library command.    Create a new 
book with the New Book command and a new child book with the New Child Book command, or create 
parent books and child books as part of the download process when you use any of the download 
wizards. 

Organizing the Information

 You can organize the information you’ve downloaded any way you want regardless of how it was 
downloaded.    There are several commands and features that help you do this.    From the Edit menu you 
can cut or copy and paste, or move links and images in the Card Window or use the drag and drop 
feature.    To do this, "drag" an image by clicking once on it and moving your mouse to another location 
while holding the mouse button down.    Release the button to "drop" the image in the other location.



You can use drag and drop in several ways.    Move files to and from your browser and iCollect (not all 
browser versions support this feature) and then drag and drop the information within your iCollect 
libraries.    You can also move files on your computer into iCollect this way.

For instance, to move files from the Icon Window to a book in the Book Window, drag the icon(s) from the 
Icon Window, then drop the icon(s) onto the book in which you want the icon(s) to appear.    To rearrange 
the icons in a book, just drag and drop an icon to the desired location.    iCollect automatically rearranges 
the icons. 



Creating and Saving New Libraries

 Libraries are a way to store and organize books.    When you first use iCollect the default is a new library 
and one book.    By default, libraries and books are named numerically unless you give them specific 
names.    For instance, iCollect will name your first library “Library 1”, your second “Library 2” and so on. 
You can always rename libraries. 

If you have only a few books you probably only need one library but if you start collecting several books 
you might want to create multiple libraries.    For example, if you have various books of music links, you 
might store them all in a single library called “Music”.    To create a new library, use the New Library 
command. 

Each library will be saved in a separate file folder on your hard disc under the library name you specify or 
in numerical sequence.    You can move all your libraries to a single folder, but you must use the Move 
files command from within iCollect so the program will always know where to find things. 

It’s a good idea to save changes you’ve made to your library as you make them, or you can save all 
changes at the end of a session.    If you forget, iCollect will prompt you to save your changes before 
closing the program down.



Creating and Saving New Books

 When you download links and files in iCollect, they’re stored in books.    When you first use iCollect the 
default is one new book.    By default, books are named numerically unless you give them specific names. 
For instance, iCollect will name your first parent book “Book 1” and your first child book (within Book 1) 
Book 1-1.    You can always rename parent books, and child books.

You could store all your links and files in a single book but it’s much more convenient to sort and organize 
groups of links and files into separate books.    One way to use books is to store all the links for a large 
web site (or the links for several small related web sites) in a single book.    For example, you might have 
all the links for a single web site, www.sierra.com, in a book named “Sierra” but a collection of assorted 
links from half a dozen different web sites relating to banjo music might go into a single book called 
“Banjo.” 

You can create a new book with the New Book command.    You can also create books on the fly as part 
of the download process when you use any of the download wizards.    Save a book using the Save 
command on the File menu. 



Creating and Saving New Child Books

 Child books provide another level of organization and give you the option of having multiple child books 
within a single parent book.    You might use child books to store individual web sites related to banjo 
music which are then stored in a single parent book called “Banjo”.    You could then store this and other 
related books, such as “Guitar”, “Mandolin” and “Fiddle”, in a library called “Folk music”. 

By default, child books are named numerically unless you give them specific names.    For instance, 
iCollect will name your first parent book “Book 1” and your first child book (within Book 1) Book 1-1.    You 
also have the option of naming a book with the date you downloaded the information in that book.    You 
can always rename parent books, and child books.

You can create a new child book with the New Child Book command, or you can create books on the fly 
as part of the download process when you use any of the download wizards.    Save a child book using 
the Save command on the File menu.



Renaming and Deleting Libraries

 Rename a library using the Save As command from the File menu.    Keep in mind that you will have a 
copy of the library under the original name on your hard disc.    Delete a library from Windows Explorer by 
highlighting it and then using the Delete key on the keyboard or right-click the library filename and choose 
Delete from the menu.

It’s important to remember that iCollect maintains a database of link, file, book, and library information 
within itself.    When you rename or delete libraries iCollect will lose track of the information.    You should 
refresh the information in iCollect with the Refresh command.    However, this will only work when you 
have renamed a library.    There is nothing to refresh if you have deleted a library.

If you have deleted a library from Windows Explorer that is currently open in iCollect you can save it 
under another name and save all the links and images.    This is handy if you accidentally delete the 
wrong library.    When deleting libraries, be very careful to delete the correct one.



Renaming and Deleting Books

 The simplest way to rename a book is to right-click the book in the Book Window select Rename from the 
pop-up menu that appears, and enter the new book name.    You can also rename a book by highlighting 
the book name in the Book Window, then press F2 and enter the new book name. 

 You can delete a book by right-clicking the book name in the Book Window and then selecting Delete 
from the pop-up menu.    iCollect displays a dialog box asking you to confirm the deletion and if you want 
to delete the data just from the library or if you want to delete it from both the Library and the linked file.    
Make your selections and click OK to delete the file.    You can also delete a book by highlighting the book 
name in the Book Window and then selecting the Delete Book command from the Edit menu.    Confirm 
the deletion as before. 

Warning: When you delete a book, iCollect will no longer see the links and files.    If you chose to delete 
the linked files as well any files stored on your computer’s hard disc will be deleted too.    When deleting 
books, be very careful to delete the correct book. 

It’s important to remember that iCollect maintains a database of link, file, book, and library information 
within itself.    You should use the commands in iCollect to move, copy, rename or delete books instead of 
using the Windows Explorer or iCollect will lose track of the information. 



Renaming and Deleting Child Books

 The easiest way to rename a child book is to right-click the child book in the Book Window select 
Rename from the pop-up menu, and enter the new child book name.    You can also rename a child book 
by highlighting the child book name in the Book Window, then press F2, and enter the new child book 
name. 

 You can delete a child book by right-clicking the child book name in the Book Window and then selecting 
Delete from the pop-up menu.    iCollect displays a dialog box asking you to confirm the deletion and also 
asking if you want to delete the data only from the current library or if you want to delete it from both the 
library and the linked file.    Make your selections and click OK to delete the file.    You can also delete a 
child book by highlighting the child book name in the Book Window and then selecting the Delete Book 
command from the Edit menu.    Confirm the deletion as before. 

Warning:    When you delete a child book, iCollect will no longer be able to see the links and files. If you 
chose to delete the linked files as well, any files stored on your computer’s hard disc will be deleted, too. 
When you delete child books, be very careful to delete the correct child book. 

It’s important to remember that iCollect maintains a database of link, file, child book, book, and library 
information within itself.    You should use the commands in iCollect to move, copy, rename, or delete child 
books instead of using the Windows Explorer, or iCollect will lose track of the information. 



Using the iCollect Wizards

Wizards are automated tools within iCollect that walk you through a process and provide 
information about what to do at each step.    There are three wizards within iCollect, all are 
located on the Collect menu: 

· The Download Wizard walks you through the process of downloading web pages and links. 

· The Download Additional Links Wizard lets you download additional links for the selected 
URL.

· The Schedule Wizard lets you program iCollect to download files and links automatically at a 
designated time. 



The Sample Library

 iCollect comes with a sample library which is a collection of links to and thumbnails of three portions of 
the Sierra web site –www.sierra.com.    It includes information on Genealogy, Publishing and Web 
Publishing.



Connecting and Using iCollect

iCollect allows you to collect images and text files from the Internet onto your computer.    When you first 
use iCollect you’ll want to set up your Internet Connections and Select a Browser.    Then launch a 
connection and download your favorite web site!

Setting Up Your Connection to the Internet

Although you can use iCollect with an Internet connection that is already running, you won’t be 
able to use many of iCollect’s powerful features until you configure iCollect to connect to the 
Internet automatically.    You can connect via a standard dial-up connection or through a LAN 
(Local Area Network). 

· To configure iCollect, select the Connection Settings command on the Tools menu. 

· If you want iCollect to use a dial-up connection, click the Use the following dial-up connection 
button, then identify the dial-up connection you want to use.    iCollect will automatically detect 
and display the dial-up connections on your system in the Connect to: field.

Be sure to include any necessary usernames and passwords.    You may accept the defaults 
for the other options or change those according to your needs.

· If you’re on a LAN, click the Connect to the Internet through a LAN button. 

· When you’re done, click OK. 

· iCollect is now ready to connect to the Internet automatically and you can configure the 
Schedule Wizard and Download Wizards. 

Using iCollect

Use iCollect to download links, graphics files, and other information directly from the Internet onto your 
computer.    Once you’ve downloaded the information you can look through it at your leisure without 
annoying distractions (slow loading pages, dropped connections, etc.) or tying up your phone line.

iCollect also lets you search all the downloaded information (and produces a report of those search 
results), copy specific objects from a web page without downloading the entire page and create a slide 
show with some or all of the downloaded images. 

You can configure iCollect to automatically download specific URLs (Internet addresses) or you can 
browse the Internet and download information as you go. 

NOTE:    Some information may not download for various reasons, including bad links, security, etc.    
Although using the Quick Server feature may alleviate some of those issues we can’t guarantee this. 

Manual Downloads

· Connect to the Internet in your usual manner.

· Open your browser and find the information you want to download.

· Start iCollect.



· From the Collect menu select Download Browser Page, then select one of the options for 
immediate download, or click on the Download Wizard for more options.

· The URL of the page displayed in the browser appears automatically in the Download Wizard 
dialog box.    If you want to schedule this page for downloading at another time click Schedule 
Wizard for later download, otherwise click Next. 

· Use the slider bar to select the number of levels of links to download, then click Next.

· Specify limits on what to download and click Next again.

· Select the type and/or size of information to download and click Next.

· Specify a library to download to and click Next.

· Select the book to hold the new information, then click Download. 

iCollect will download the link information from the URL and all the connected links and files as specified. 
NOTE:    You can accept the defaults and start the download process by clicking Download at any time 
when using the Download Wizard. 

 TIP:    You can adjust the size of the windows so that iCollect and your browser can be displayed 
simultaneously.    This will allow you to view the links and images as they appear in the iCollect Icon 
Window.

Scheduling Downloads

You can configure iCollect to download information automatically once at a specific time (off-peak hours) 
or every day (if you want to make sure you’ve always got the latest version of a web page) and iCollect 
supports your usernames and passwords for protected sites.

· Start the Schedule Wizard with the Schedule Wizard command from the Collect menu. 



· Fill in the URL of the web site you want to schedule for download, then click Next. 

· Use the slider bar to select the number of levels of links to download, then click Next.

· Specify limits on what to download and click Next again.

· Select the type and/or size of information to download and click Next.

· Specify a library and click Next.

· Select the book to hold the new information, then click Next. 

· Select the scheduling options you prefer.    You can download the information only once, save 
it in a library when the download is finished, download the information on specific days, etc.    
You can also use the timer, which will let you set specific times or periods to download 
information.    When you’re done, click Next if you’re using the timer option or Finish. 

· If using the timer option, choose the hour of the day you want to schedule the download 
(Note: it’s a 24 hour clock) and click Finish.

Minimize iCollect but don’t close it.    When the specified time and day roll around, iCollect will connect to 
the Internet and download the information you’ve specified.    Depending on the options you chose when 
configuring, once the download is complete iCollect will disconnect from the Internet, save the library and 
display the finished pages in the browser.    You can then view the information offline.



Offline Browsing

Once you’ve downloaded the links, graphics files, and other information you want from the Internet onto 
your computer you can look through it all at your leisure without bothersome distractions like slow loading 
pages, dropped connections, running over your allotted online time or tying up your only phone line.

You don’t have to be online to view the images and files you’ve downloaded.    iCollect displays the 
information stored on your system just as if you’re still connected.    You can follow links, view images and 
text from a web page just as though in real time.    The only difference is the information in iCollect may 
not be the most up to date.    But it’s easy to update what you’ve already downloaded, and capture what 
iCollect may have missed the first time around!

Because of offline browsing you can schedule iCollect to connect and download information while you are 
asleep or doing other things, then sit down and take your time reading and viewing the days news, stock 
reports, etc.



Toolbar Icons

There are icons for 41 iCollect commands or functions.    Many of them are available on an iCollect menu 
as well.    You can customize the toolbar, adding or removing any icons you choose.    Use the Customize 
Toolbar command from the Tools menu to do this.    The default icons, available on the toolbar when you 
first run iCollect, are listed below.    The other choices you have for tailoring the toolbar to your needs are 
listed below those.

 

Launches a connection to the Internet and runs browser – right click this 
icon to select a browser. 

 
Downloads current page from browser.

 

Toggles automatic download on and off.

 

Runs scheduled downloads – will show list of all scheduled downloads.

 

Toggles random surf function.

 

Runs the iCollect tutorial.

 

Opens Download Wizard dialog box.

 

Opens Schedule Wizard dialog box.

 

Runs Import Cache function.

 

Creates a new book in the current library.

 

Creates a new child book.

 

Opens Search dialog box.

 

Shows the original URL in a dialog box and when you click OK, connects 
to the Internet and locates it. 

 

Displays selected link in the browser window.

 
Runs the images in the open book as a slide show in the browser.

 

Prints the icons in the Icon Window in a “contact sheet” format.

 

The Back button, allows you to move backward while displaying images in 
the browser window.



 

Displays browser selection list.    Choose the browser you want to run in 
the current session.

 
Allows you to edit the Comments for links and graphics.

 

Makes a copy of the selected file or image and stores it in memory.

 

Removes the selected file or image.    If the Paste command is used 
immediately after it acts as a move function.

 
Dials the connection configured in Connection Settings.

 

The Download Additional Links button allows you to download more 
information available from the selected file.

 

Displays Page Elements.

 

Displays information about the selected file.

  

The Forward button, allows you to move back and forth while displaying 
images in the browser window.

 Opens the Icon Window Options dialog box.

 

Creates a new library.

 

Displays the Download Log.

 

Allows you to move files from library to library.

 

Opens the Open dialog box, allowing you to open another library.

 

Pastes a previously copied file or image to the specified location from 
memory.

 

Displays the icons in the Icon Window in a “contact sheet” format in the 
Print Preview window. 

 

Repeats the last command.

 

Opens the Refresh dialog box.

 

Saves all the current information – all books in and the current library.

 

Opens the Edit Schedule dialog box.

 

Opens a dialog box with settings to configure so iCollect can download 
Missing Serial Numbered URLs.

 

Opens iCollect Quick Server setup and selection.



 

Links to the Sierra web page.

 
Opens the Thumbnail Options selection window.

 

Cancels last command.



Quick Server

 With this command you can set up your computer to act as a web server.    This is helpful if you have a 
number of files on your computer that you want to give other people quick access to.    By configuring your 
computer to act as a web server, anyone who has the address can access it and can upload and 
download files and information.    There are options you can select if you want to make the HTML code 
viewable and how deep into your iCollect file structure visitors will be allowed.

When you enable the Quick Server iCollect assigns an IP address and chooses a port.    You can also 
select options and configure the display and layout on the tabs in Quick Server Settings dialog box.    
Once the options are set, you can use the Settings command to turn the web server option on and off.    
Simply check or uncheck the Enable Quick Server box at the top.

See the Quick Server Settings command for more information.



Thumbnails are small graphic representations of downloaded information.    In iCollect they are also 
known as icons.



To highlight an icon, click on it once.



Slide Shows

You can create a slide show or presentation from the images you’ve downloaded using iCollect’s Slide 
Show option.    The slide show displays each link or file in a book.    With the Slide Show Settings 
command you can set the interval a slide will remain onscreen, create an endless loop and reduce large 
images to fit the screen.



Glossary

Book – A book is a collection of the links, graphics and other files you’ve downloaded.

Parent Book – A parent book is a main book in a library.

Child Book – A child book is a book located inside a parent book.

Cache – The cache in a computer system is a hidden area of memory.    In this case, the browser cache 
contains images of the web pages you’ve visited.    Usually limited and always transient.

Comment – Descriptive identifier of an image or file.

Download – Copy from the Internet to your computer system via a phone line.

Drag and Drop – A way of moving images and files with your mouse.

Element (as in Display Elements) – Each component of a web page is known as an element.    This 
includes text, images, buttons, etc.

Icon – Image of downloaded link and/or graphic.    Also known as a thumbnail.

Internet - 

Library – A collection of books.

Link - 

Thumbnail - Graphic representations of downloaded information.    Also known as icons.

Tutorial - Information conveyed in a step-by-step breakdown with many examples and graphics. Tutorials 
are usually shipped with a Help system and are designed for the user who wants to walk through a 
feature or a program.

URL – Universal Resource Language.    Also known as Internet address.    The way a browser locates a 
web site on the Internet.

Web/WWW – World Wide Web.    Also known as the Web.    Collection of web sites.

Web page – A single page within a web site.

Web site – A collection of pages.

Window – 



Keyboard Commands

The default keyboard commands can be changed on the Keyboard settings tab in the Preferences 
section of the Tools menu.    Below are the default commands:

New Library Ctrl+N
New Book Ctrl+B

New Child Book Ctrl+Shift+B
Open Ctrl+O
Save Ctrl+S
Print Ctrl+P

Undo Ctrl+Z
Redo Ctrl+Shift+Z

Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V

Select All Ctrl+A
Automatic Download Ctrl+R
View Selected Files Shift+Enter

Slide Show Ctrl+Home
Back Alt+Left

Forward Alt+Right
Refresh F5

File Information Ctrl+I
Help F1



Small, equal-sized pieces, each pixel is set to a specific color and when used together in a pattern create 
a picture.



Warning to AOL Users

It is important to note that AOL is not a browser.    It is an ISP with a graphical front end and is different 
from browsers.    The iCollect launch or automatic connection functions will not work with AOL.    Because 
of this, AOL users can not use the Schedule Wizard features in iCollect.



The Control Bar

 Whenever you minimize the main iCollect window the Control Bar appears as a floating menu in the 
upper left corner of your screen.    The Control Bar allows you to control slide shows within iCollect as well 
as download pages from your browser without using the full iCollect window. 



Netscape Navigator 

Netscape Navigator 3.0
With Navigator 3.0 you can use drag and drop to store an entire page, a body of text, or an image in 
iCollect.    You can also use copy and paste to transfer text into iCollect.

To drag and drop an image, position the mouse over the image ¾ not the background ¾ then press and 
hold the left mouse button.    The cursor will change to the “No Entry” icon indicating the image has been 
successfully captured.

Move the cursor onto the iCollect Icon Window.    The cursor will change into an arrow icon that highlights 
available storage grids in the Icon Window.    A highlighted grid indicates where you can drop the image.    
To place or “drop” the image, release the left mouse button.    The image will be pasted into iCollect and a 
thumbnail version of the image will be created.

Occasionally when you drop an image, the Saving Location dialog box appears.    If this happens, wait a 
moment and the dialog box will disappear.

You can use drag and drop to store full pages that contain text and images.    To drag and drop an entire 
page from Navigator 3.0, drag the “Chain” icon (located to the left of Location under the Toolbar) and 
drop it into the iCollect Icon Window.

Depending on your computer configuration, a Paste Option dialog box may appear.    If it does, select 
Download a page and paste, then select OK.    A Downloading dialog box will appear on your iCollect 
screen, and the files that make up the current page will be downloaded in order.    Once the files are 
downloaded, the dialog box disappears.    If the Downloading dialog box doesn’t disappear, this means 
your connection is very slow, or the file is very large.    Be patient while your browser displays the percent 
downloaded.

Once you’ve saved a page, iCollect stores it on your hard disc.    Whenever you view that page, it will 
function as if you were browsing directly from the Internet.    When you store a full page with the default 
setting, HTML icons are displayed in the Icon Window and all sound, video, and graphics elements are 
saved with the page.

To copy and paste text from Navigator 3.0 into iCollect, highlight the desired text and select Copy from the 
Edit Menu.    Select Paste from the Edit Menu to drop the file into the Icon Window.    The text file icon will 
appear in the last slot of the Icon Window.    To view the text, click on this thumbnail.

Netscape Navigator 2.0
Because Navigator 2.0 doesn’t support iCollect's drag-and-drop utility, you can’t collect images and text 
using this option.    But you can import image files and text into iCollect using the standard copy and paste 
commands.



Microsoft Internet Explorer 

Microsoft Internet Explorer 3.0
To use the drag and drop function on images or text right-click the image or text to select it, then click and 
hold the left mouse button.    The cursor will change to the “No Entry” symbol, indicating you’ve 
successfully captured the image or text.

Holding the left button down, drag the cursor to the Icon Window.    The icon will highlight a storage grid in 
the Icon Window indicating where you can drop the image.

Release the left mouse button to drop the image or text.    It will be pasted into iCollect as a thumbnail.

Microsoft Internet Explorer 2.0
You can’t use drag and drop to move separate images to iCollect with Internet Explorer 2.0.    But, you 
can transfer an entire page into iCollect using the Download Browser Page --Current Page only command 
from the Collect menu.



Collecting Files from MS Windows 

 In Windows 95/98 you can drag a file from Explorer (or My Computer) and drop it into iCollect, or you can 
drag and drop a file from iCollect to Explorer.    To transfer a file from Explorer to iCollect, select it and 
drag and drop it in the Icon Window.    A thumbnail of that file will appear in the first open slot.    You’ll 
need to run the Refresh command for iCollect to update itself and add this new file.

Reverse the process to transfer from iCollect to Explorer but keep in mind that you’ll only be able to view 
the transferred file with the right type of application.    For instance, a graphics image will be viewable with 
most graphics program but probably not in a spreadsheet program. 

 You can also transfer files from iCollect to a diskette or a writable CD-ROM drive.    This could come in 
handy if you need to copy a block of icons representing graphics images to a diskette.    Select the first 
icon in the block you want to transfer, hold down the Shift key and click the last icon in the block.    All the 
icons you want will highlight.    Now you can drag and drop them onto the disk drive symbol in Explorer --
make sure there’s a disk in the drive first.



Using iCollect Commands

The commands in iCollect are arranged in eight different menus.    Some of the commands have 
corresponding keyboard combinations which allow you to use them without accessing the menu.    Most of 
the keyboard commands can be changed.    You can also access a number of the commands and options 
through the iCollect toolbar. 

In addition, some options have right-click menus available.    You access these when you right-click on 
some elements of the iCollect windows.    And you can set and control slide-show options using the 
Control Bar. 

· The File menu

· The Edit menu

· The View menu

· The Collect menu

· The File Options menu

· The Tools menu

· The Window menu

· The Help menu



The File Menu

The File menu is used to create, open, or save books and libraries, to print information, and to 
exit iCollect. 

· New Library 

· New Book 

· New Child Book 

· Open 

· Close 

· Save 

· Save As 

· Print Setup 

· Print Preview 

· Print 

· Quit 



New Library 

This command creates a new library.    iCollect names libraries numerically by default.    For instance the 
first library you create is Library 1, the second Library 2 and so on.    If you don’t want to use the default 
name, you can rename the library by using the Save As command and entering a new name for the 
library. 

Click on the word File on the menu bar to access this command.    The keyboard command is Ctrl+N.    
Using these keys you can create a new library without having to access the menu.



New Book

This command creates a new book in the current library.    iCollect names books numerically by default.    
For instance the first book you create is Book 1, the second Book 2 and so on.    If you don’t want to use 
the default name, you can rename the book.    The easiest way to rename a book is to right-click the book 
name in the Book Window, select Rename from the pop-up menu, and enter the new book name.    You 
can also rename a book by highlighting the book name in the Book Window, then press F2, and enter the 
new book name. 

Click on the word File on the menu bar to access this command.    The keyboard command is Ctrl+B.    
Using these keys you can create a new book without having to access the menu.



New Child Book 

This command creates a new child book inside the currently open book.    iCollect names child books 
numerically by default.    For instance the first child book you create is Book 1-1, the second Book 1-2 and 
so on.    If you don’t want to use the default name, you can rename the child book.    The easiest way to 
rename a child book is to right-click the book name in the Book Window, select Rename from the pop-up 
menu, and enter the new book name.    You can also rename a child book by highlighting the book name 
in the Book Window, then press F2, and enter the new book name. 

Click on the word File on the menu bar to access this command.    The keyboard command is Ctrl+Shft+B. 
Using these keys you can create a new child book without having to access the menu.



Open

This command opens a dialog box where you choose the file you want to open from a list of library 
folders.    Library (.NFI) files are shown by default, but you can also open many other file types, such 
as: .NFI, .GIF, .JPG, .JPE, .JPEG, .BMP, .PCF, .PIC, .PICT, .PCD, .FPX, .EPS, .TIF, .TIFF, .PNG, .MOV, .
AVI, .MID, .RMI, and .WAV.    Select a file by double-clicking the folder, then the file or click once and click 
“Open” each time. 

Note: Only files matching the types listed in the File Type field can be opened in iCollect.

Click on the word File on the menu bar to access this command.    The keyboard command is Ctrl+O.    
Using these keys you can open a file without having to access the menu.



Close

This command closes the active library or the Image Viewer.    If you’ve made any changes to the library 
(including adding, changing, or deleting the information for any book within the library), iCollect will 
prompt you to save your changes.    Click on the word File on the menu bar to access this command.



Save

This command saves the changes to the active library.    The library file (with an .NFI extension) will be 
updated, and the old library file will be stored with a .BAK extension.

Note: If you use this command for a new library that hasn’t been saved before, iCollect will open the 
Save As dialog box so you can enter a name and additional file information for the library. 

Click on the word File on the menu bar to access this command.    The keyboard command is Ctrl+S.    
Using these keys you can save a file without having to access the menu.



Save As

This commands saves a new library or renames existing libraries.    New libraries are saved to their own 
folders, which will be given the same name as the library. 

It’s important to remember that if you use the Import File or Import Cache Data commands iCollect makes 
a link to the location of the information on your hard disc and it doesn’t actually copy the files.    You must 
use the Copy Files to Library command to replace this link with the actual files and then save the 
information in the library.    Otherwise, the information you think you’ve saved will not be there when you 
return to that library.

Note:    You can’t save executable files.

Click on the word File on the menu bar to access this command.



Print Setup

 This command displays the standard print setup dialog box in which you can specify the printer and its 
options.    Click on the word File on the menu bar to access this command.



Print Preview

 This command displays the contents of the Icon Window in a “contact sheet” format.    You can change 
the orientation of the paper from portrait to landscape, choose a printer and paper size.    Click the open 
book icon, to the left of the font field on the toolbar, to see two pages at a time.    Use the arrows to the left 
of that icon to scroll through the pages.    This view will also display the number of pages in the lower left 
corner.

You can also use this command to display the contents of the Image Viewer and make slight changes to 
where the image sits on the paper before you print.    Click on the word File on the menu bar to access 
this command.



Print

 This command prints the contents of the Icon Window or the Image Viewer.    If you don’t need to preview 
what your printing simply choose the Print command from the File menu.    Verify the printer and page 
settings and click OK.

 To print from the Image Viewer, double-click an icon in the Icon Window, or click once to highlight the 
icon and then choose the View Selected File command from the File Options menu.    The image will 
appear in the Image Viewer. 

Now, choose Print Preview from the File Menu and the image will be displayed in the preview window.    In 
the Print Preview window you can move the image to one of three preset areas on the page.    The 
buttons for this feature are found to the right of the zoom buttons (magnifying lenses).    The first button 
(from the left) will move the image to the top center of the page.    The second button will move it to the 
middle center of the page, while the third button will move it to the upper-left corner.    These positions 
indicate where on the page the image will print. 

When the image is where you want it, click the printer button in the upper-left corner.    After confirming all 
the settings, click OK in the Print dialog box.

Click on the word File on the menu bar to access this command.



Quit

This command closes iCollect.    You’ll be prompted to save if iCollect detects any unsaved changes.    
Click on the word File on the menu bar to access this command.



The Edit Menu

The Edit menu is used for canceling and repeating actions, cutting, copying, and pasting 
information, deleting information and books, selecting information, and editing comments. 

· Undo 

· Redo 

· Cut 

· Copy 

· Paste 

· Delete 

· Delete Book 

· Select All 

· Reverse Selection 

· Edit Comment 



Undo

This command cancels the previous action.    If you execute a command, say delete something, and 
aren’t sure you deleted the right thing you can use this command to cancel it.    The deleted item will be 
restored.    Click on the word Edit on the menu bar to access this command.



Redo

This command repeats the previous action.    This is useful for reversing an Undo command.    If you 
execute a command, say delete something, and aren’t sure you deleted the right thing you can cancel the 
command (with undo) and, when you’ve confirmed it was the correct item, use the redo command to 
delete it again.    Click on the word Edit on the menu bar to access this command.



Cut

This command lets you “cut” text or images from within iCollect or Windows Explorer.    The cut items 
disappear from where they were and will be stored in memory know as the Clipboard.    Using the Paste 
command you can retrieve the information and place it elsewhere.    Click on the word Edit on the menu 
bar to access this command.



Copy

This command lets you “copy” text or images from within iCollect or Windows Explorer.    The copied 
items are stored in memory know as the Clipboard.    Using the Paste command you can retrieve the 
information and place it elsewhere.    Click on the word Edit on the menu bar to access this command.



Paste

This command lets you paste text or images from the Clipboard memory or folders from elsewhere on the 
computer.    You can also use it to paste folders and to paste several items within one.    Click on the word 
Edit on the menu bar to access this command.

Pasting Folders

 You can drag a folder from Windows Explorer directly into a library.    The Pasting a Folder dialog box will 
appear when you do this.    It will display the path of the folder you’ve chosen and explain its purpose.    
You can choose to create a shortcut to the folder to create a reference in the Icon Window or choose to 
paste the folder contents into the open library.    If you want to copy the contents into the current library 
you have three options.    You can include all sub-folders, create a new book for each folder, or paste only 
recognizable files. 

When you choose to include sub-folders iCollect will find all the files in any sub-folders of the folder 
you’ve specified and copy those to the library too.    If you check the “Create a new book for each folder” 
option iCollect will create a book for each sub-folder it finds.    When the “Only paste recognizable files” 
option is checked iCollect will save only the files such as HTML and image files. 

Pasting with Page Elements Hidden
If the Display Page Elements option is turned off when you paste a page from the Internet it appears that 
iCollect only pastes one or two items.    However, turning the Display Page Elements feature on will show 
that all the elements of the page you pasted are there.    Display Page Elements is useful for situations 
like copying an entire web page to a diskette.    Hide the page elements for the page you want to copy, 
drag and drop the main file to the diskette icon on the Explorer window.    All the elements will be there in 
a neat little package.



Delete

 This command removes files permanently.    The command is grayed out (unavailable) until you have 
selected something that can be deleted.    You can either delete data from the library alone or delete both 
the library data and the linked files, which include the links to the original file, the thumbnail, and the file 
information.    You should save your library after deleting otherwise the “deleted” information will appear 
the next time open the library. 

Warning:    If you delete information using the Windows Explorer, or any method external to the iCollect 
program, iCollect will not be able to track the deleted information.    It’s important to remember that 
iCollect maintains a database of link, file, child book, book, and library information within itself.    You 
should always use the delete command from within iCollect.    If you choose to delete the linked files as 
well, any files stored on your computer’s hard disc will be deleted too.    When you delete information, 
be very careful to delete the correct information. 

Click on the word Edit on the menu bar to access this command.



Delete Book

 You can delete an entire book with one command. You can either delete the book from the library alone 
or delete both the book and the linked files, which include all the links to original files, the thumbnails, and 
the file information.    You should save your library after deleting otherwise the “deleted” information will 
appear the next time open the library. 

Warning:    If you delete information using the Windows Explorer, or any method external to the iCollect 
program, iCollect will not be able to track the deleted information.    It’s important to remember that 
iCollect maintains a database of link, file, child book, book, and library information within itself.    You 
should always use the delete command from within iCollect.    If you choose to delete the linked files as 
well, any files stored on your computer’s hard disc will be deleted too.    When you delete information, 
be very careful to delete the correct information. 

Click on the word Edit on the menu bar to access this command.



Select All

This command highlights all the information in the Icon Window and the Report Window, (if it’s open.)    
Click on the word Edit on the menu bar to access this command.



Reverse Selection

This command reverses the selections you’ve made.    The selected items are deselected and unselected 
items are selected.    Click on the word Edit on the menu bar to access this command.



Edit Comment

 This command lets you edit the comment for an icon.    A comment is a descriptive title, but some could 
be a little more descriptive.    Using this command you can make them so.    The command is grayed out 
until an icon is selected.    To add or edit comments for an icon:

· Select the icon for which you want to edit comment. 

· Set the Icon Window Options to display icon comment.

· Select the Edit Comment command from the Edit menu.

· Enter your comment.

· When you’re satisfied with your entry, click OK. 

· The comment you entered will appear in the icon’s comment line. 

You can also edit the comment by entering your comment in the “Comment” field in the Card Window. 

Click on the word Edit on the menu bar to access this command.



The View Menu

The View menu controls the display of the toolbar, status bar and view bar, and the Card, Icon 
and Report Windows.    It is also used to display the link tree and page elements.

· Toolbar 

· Statusbar 

· Viewbar 

· Card Window 

· Icon Window 

· Report Window 

· View Link Tree 

· Display Page Elements 



Toolbar

 When checked this command displays the toolbar.    When unchecked the 
toolbar is hidden.    Depending on the features there (default or customized) you can save, open new 
books, print, etc. just by clicking on the icon.    Click on the word View on the menu bar to access this 
command.



Status Bar

 When checked, this command displays the status bar at the bottom of the iCollect window.    The status 
bar displays information based on what is selected in the windows above it.    Click on the word View on 
the menu bar to access this command.



View Bar

 When checked, this command displays the view bar just below the toolbar.    The view bar allows you to 
hide or display the Card and Report Windows, resize the icons in the Icon Window, as well as change the 
view in the Book/Link Window.

Click on the word View on the menu bar to access this command.



Card Window

 When this command is checked the Card Window. appears above the Icon Window.    Click on the word 
View on the menu bar to access this command.



Icon Window

 When this command is not checked the Icon Window. does not appear.    When checked the icon window 
appears to the right of the Book Window.    Click on the word View on the menu bar to access this 
command.



Report Window

 When this command is checked the Report Window. appears below the Icon Window.    Click on the word 
View on the menu bar to access this command.



View Link Tree

 This command changes the view in the left pane of the iCollect screen to the link tree view, also known 
as the Link Window..    A check indicates the feature is on.    Click on the word View on the menu bar to 
access this command.



Display Page Elements

 When this command is unchecked each page you download will be displayed as one icon.    When it’s 
checked each element on a page is displayed as an icon.    For instance, the HTML portion and each .GIF, 
.JPG, piece of text and anything else on the page is displayed as a separate icon.

You can use this command for files collected with the Download command, with the Select Pages 
command when importing files from the cache , or by dragging from your browser to iCollect.    When a 
page is downloaded each separate element of that page is downloaded into it’s own file.

If the Display Page Elements option is turned off when you copy, cut, delete, or drag and drop a file into a 
library all the files on the page will be affected.    This is useful for situations like copying an entire web 
page to a diskette.    Hide the page elements for the page you want to copy, drag and drop the main file to 
the diskette icon on the Explorer window.    All the elements will be there in a neat little package.

Click on the word View on the menu bar to access this command.



The Collect Menu

The Collect menu is used to download information from the Internet or import information from the 
browser’s cache.

· Download Browser Page 

· Download Additional Links 

· Download Wizard 

· Download Log 

· Schedule Wizard 

· Freeze Frame 

· Automatic Download 

· Auto Copy Element 

· Download Web Search Results 

· Download Missing Serial Numbered URL 

· Random Surf 

· Import File 

· Import Cache Data 



Download Browser Page

 Use this feature to manually download information as you browse the Internet.    From the Collect menu 
select the Download Browser Page command, then select one of the options for immediate download, or 
click on the Download Wizard for more options.

When you choose the Current Page Only option iCollect will only download the page currently shown in 
your browser.    If you choose the 1 Level of Links option iCollect will download the current page and one 
level of links form that page.    For instance, if you are looking at a vacation spots web site the first page 
may have a link to a map of the United States.    Choosing to download one level of links would give you 
the current page and the map.

The next or second level of links would be each state available on the US map.    Choosing the 2 Levels 
of Links options would get you the current page, the map and each state page.    Unlimited Levels will 
cause iCollect to follow and download all the links it finds on that web site.    This could be more links than 
you can imagine --many web sites link to other sites with information similar to their own or to sponsors, 
affiliates, etc. --but it’s a handy way to get everything all at once.    Then you can use iCollect to sort, 
organize and remove the information you don’t need or want.

Click on Download Wizard to open the wizard dialog box where you can configure what you want to 
download.



Download Additional Links

Use this command to download additional links for a URL you’ve already downloaded one or more links 
for.    Highlight the file you want to add links to in the Icon Window, the Card Window, or the Report 
Windowand click on the Download Additional Links command in the Collect menu.    You can download 
links at one level, two levels or unlimited levels.    Note:    Your browser does not need to be running for 
this feature to work.



Download Wizard

 Use the Download Wizard when you want to configure a download.    This is handy for large downloads 
as it allows you to specify what to download, how much, when and where without you having to search 
out each page.    And it can run in the background while you do other things.    Click on the word Collect on 
the menu bar to access this command.

The first window in the dialog box has a field where you can enter the URL for the site you wish to 
download.    If you are currently logged on to the Internet the URL for the page visible in your browser will 
appear in this field.    You can use that address or change it.

There are two options below that field, the Schedule for later download option will activate the Schedule 
Wizard and the View finished pages in browser option will cause iCollect to display the pages you’ve 
downloaded in your browser.    When you check this option a secondary feature will appear below it.    You 
can set the interval each page will appear in your browser window, from 1 to 999 seconds.    Just click the 
up down arrows until you see the number you want. 

When you’re done, click the Next button to continue configuring the wizard or click the Download button 
to start the download.

 If you click Next, you’ll see the second window in the dialog box where you can choose the level of links 
you want to download.    There may be links on the original page you’re downloading that stay within that 
URL and there may also be links to sites outside the starting URLs.    For instance, if you are downloading 



from the main page at Sierra.com there are links to each of their divisions, as well as a link to a computer 
gaming site on the Internet.    Follow the Sierra links and you stay within the original URL, but once you 
click on the gaming site link you leave the original URL, Sierra.com, and go to another, Won.net –and 
from that site there are links to many other URLs –other gaming sites, computer game companies, 
magazines, advertisers, etc. 

Use the slider bar to indicate how many levels of links you want iCollect to follow and download.    When 
you move the slider bar you’ll see the number of pages change in the graphic to the right indicating the 
links you’re including.    Additionally, the explanation under the slider bar helps make clear what you are 
choosing.    The option below this configures iCollect to download all embedded pages within frames.    
This refers to HTML coding used on many web sites and is useful when you want to get absolutely 
everything from a site.    When you’re done here click the Next button, or the Download button to start the 
download.

 The third window in the dialog box deals with the limits you can specify for a download.    You can choose 
to download all links, stay within the starting URL directory, stay within qualified domain or download other 
domains.    These options coincide with the levels of links you chose on the previous page.    If you chose 
Level 5 on the previous page and then choose the Download all links option on this page you will get 
every link iCollect can follow no matter how many that is, where it takes you or how long. 

But if you choose Stay within the Starting URL directory you’ll only get every level in that URL (every level 
on the Sierra.com site).    Stay within qualified domain is similar but subtly different in that it will limit you to 
the domain where the original URL resides.    That’s Internet speak for saying you’ll be limited to the 
server where the original URL exists.    The Download only other domains options will allow iCollect to 
follow the links from the starting URL and download information only from the other domains it reaches.    
The information in the field below these options is the starting URL you specified in the first window of the 
download wizard. 

The next field allows you to choose the direction iCollect will work.    The next few choices are options 
having to do with the files iCollect will be downloading.    Do you want iCollect to reload files if they have 
changed, overwrite existing files from the same URL, to stop the download after a certain amount of time? 
If so, you can configure that here.    When you’ve finished with these fields click the Next button to 
continue or the Download button to start the download.



 The next window in the Download Wizard dialog box allows you to choose the type of files you want to 
download.    You can choose to download all file types or you can specify only image types, or documents, 
or sound, or video, etc.    Click to check the file types you do want and click to uncheck the file types you 
don’t want.

Then you can choose a download method.    The default is for iCollect to choose the best method and this 
is what we recommend.    The other choices are to always download directly from the Internet or always 
download through the browser.    You can also configure the minimum and maximum size of files you want 
to download.    This way you don’t end up downloading something that uses up all the available space on 
your hard drive!

 The last window in the Download Wizard dialog box allows you to create a book to hold all the 
information you are configuring iCollect to download.    You can create a new book for the current library 
or a new child book for the open book in the current library.    If you want to use an existing book use the 
Target field and specify the book you want all the files downloaded to.

If you choose to create a new book, several other options become available.    You can name the new 
book with the date the information was downloaded, add the hour and minute it was downloaded to the 
name or add a prefix to the name.    This could be an descriptive prefix that, along with the date will 
identify to you the information stored there.



 When you click Download, iCollect will begin the download –connect to the 
Internet (unless you’re already connected), locate the URL you specified and download information based 
on the criteria you specified.    You’ll see this dialog box depicting the download in progress.    You can 
make slight changes to the download in this dialog box.    Click the Disconnect when finished box to cause 
iCollect to do that, click the Pause View button to stop iCollect displaying the downloaded pages in the 
browser window and then Resume View to turn this function back on.

If it appears that nothing is being downloaded (or the same path name has been displayed for more than 
a minute or so) it may be that the particular link iCollect is looking for is not available or doesn’t exist 
anymore.    Click the Skip button to cause iCollect to go on, Retry to cause iCollect to try again and the 
Stop button to terminate the download.    Anything already downloaded will be available in the iCollect 
main window.

When iCollect has completed the download the Downloading dialog box will disappear and, if you chose 
this option, iCollect will disconnect from the Internet. 



Schedule Wizard

Use the Schedule Wizard, when you want to schedule iCollect to download information at a specific time. 
You might do this to avoid peak traffic times on the Internet or tying up your phone line and computer 
when you’d rather be using them.    When you click on Schedule Wizard in the Collect menu you have 
three choices:    Schedule Wizard, Edit Schedule and Run Schedule.

 The first window of the Schedule Wizard dialog box requires you to enter a URL.    You can not progress 
through the wizard without one.    Once you’ve entered the URL you can choose whether you want to 
view the downloaded pages in your browser.    If you’re going to run a download when you’re not at the 
computer (because you’re asleep or gone to work) you might not want iCollect to run your browser and 
display the pages you’ve downloaded.    When you’re ready click Next.

 In the second window in the dialog box you can choose the level of links you want to download.    There 
may be links on the original page you’re downloading that stay within that URL and there may also be 
links to sites outside the starting URLs.    For instance, if you are downloading from the main page at 
Sierra.com there are links to each of their divisions, as well as a link to a computer gaming site on the 
Internet.    Follow the Sierra links and you stay within the original URL, but once you click on the gaming 
site link you leave the original URL, Sierra.com, and go to another, Won.net –and from that site there are 
links to many other URLs –other gaming sites, computer game companies, magazines, advertisers, etc. 

Use the slider bar to indicate how many levels of links you want iCollect to follow and download.    When 
you move the slider bar you’ll see the number of pages change in the graphic to the right indicating the 



links you’re including.    Additionally, the explanation under the slider bar helps make clear what you are 
choosing.    The option below this configures iCollect to download all embedded pages within frames.    
This refers to HTML coding used on many web sites and is useful when you want to get absolutely 
everything from a site.    When you’re done here click the Next button.

 The third window in the dialog box deals with the limits you can specify for a download.    You can choose 
to download all links, stay within the starting URL directory, stay within qualified domain or download other 
domains.    These options coincide with the levels of links you chose on the previous page.    If you chose 
Level 5 on the previous page and then choose the Download all links option on this page you will get 
every link iCollect can follow no matter how many that is, where it takes you or how long. 

But if you choose Stay within the Starting URL directory you’ll only get every level in that URL (every level 
on the Sierra.com site).    Stay within qualified domain is similar but subtly different in that it will limit you to 
the domain where the original URL resides.    That’s Internet speak for saying you’ll be limited to the 
server where the original URL exists.    The Download only other domains options will allow iCollect to 
follow the links from the starting URL and download information only from the other domains it reaches.    
The information in the field below these options is the starting URL you specified in the first window of the 
schedule wizard. 

The next field allows you to choose the direction iCollect will work.    The next few choices are options 
having to do with the files iCollect will be downloading.    Do you want iCollect to reload files if they have 
changed, overwrite existing files from the same URL, to stop the download after a certain amount of time? 
If so, you can configure that here.    When you’ve finished with these fields click the Next.

 The next window in the Schedule Wizard dialog box allows you to choose the type of files you want to 
download.    You can choose to download all file types or you can specify only image types, or documents, 
or sound, or video, etc.    Click to check the file types you do want and click to uncheck the file types you 



don’t want.

Then you can choose a download method.    The default is for iCollect to choose the best method and this 
is what we recommend.    The other choices are to always download directly from the Internet or always 
download through the browser.    You can also configure the minimum and maximum size of files you want 
to download.    This way you don’t end up downloading something that uses up all the available space on 
your hard drive!

 Next you need to choose a library to receive the information your scheduling iCollect to download.    If 
you can’t remember the path for your libraries click the Browse button and choose one from the list.

 The next window in the Schedule Wizard dialog box allows you to create a book to hold all the 
information you are configuring iCollect to download.    You can create a new parent book or a new child 
book.    If you want to use an existing book use the Target field and specify the book you want all the files 
downloaded to.

If you choose to create a new book, several other options become available.    You can name the new 
book with the date the information was downloaded, add the hour and minute it was downloaded to the 
name or add a prefix to the name.    This could be an descriptive prefix that, along with the date will 



identify to you the information stored there.

 Next, you can select scheduling options.    You must click the Use    timer command to schedule the 
download for a specific time.    Download only once will limit iCollect to one download of all information 
meeting the specifications you’ve outlined in the wizard, and clicking the box for Save library after 
download is finished will cause iCollect to do that.

If you are scheduling iCollect to download information from a site that requires a password and/or 
username you can specify those here and iCollect will use them to access the site.    The Days field allows 
you to schedule iCollect to run this particular download on one or more days.    Click to check or uncheck 
the boxes. 

If you clicked Use Timer the Finish button at the bottom of this window will change to a Next button.    
Click that button to complete your scheduling.

If you didn’t click Use Timer iCollect will not automatically execute the scheduled download.    You will 
have to use the Run command.

 Choose the hour of the day you want iCollect to run the download (Note: it’s a 24 hour clock) and click 
Finish.    If you unchecked the Download only once command on the previous window you can now 
choose from the timing options here below the hour/minute fields.

Make sure you have configured a dial up connection so iCollect can do its job when the appointed day 
and time arrive.    If you have, iCollect will connect to the Internet, download the information and then 
disconnect.



 To edit a scheduled download click on the download, identified by the URL, and click on the Edit button. 
You can also delete a schedule using the Delete button or add one by clicking the Add button.    Clicking 
the Edit and Add buttons takes you to the Schedule Wizard dialog box.    You can also check or change 
your Connection Settings and chose to run a download immediately.    Click on the Download Now button 
to override the timer.

You can activate the timer by checking the box or inactivate it by unchecking the box.    If you have a 
download scheduled to run every Monday and have chosen not to run it one Monday or to override the 
timer and run it out of sequence you want to inactivate the timer.

The default timer will allow you to specify a time for any download and you can set different times for each 
of the scheduled downloads.    Highlight a download and set the hour and minutes on the timer (Note:    
It’s a 24 hour clock).    When you’re done click the OK button and the downloads will be updated.

 When you click on Run Schedule Wizard you’ll see a list of the scheduled downloads.    Click on the 
download you want to run and click OK. 

 When the specified time comes, iCollect will begin the 
download --connect to the Internet (unless you’re already connected), locate the URL you specified and 



download information based on the criteria you specified.    You’ll see this dialog box depicting the 
download in progress.    You can make slight changes to the download in this dialog box.    Click the 
Disconnect when finished box to cause iCollect to do that, click the Pause View button to stop iCollect 
displaying the downloaded pages in the browser window and then Resume View to turn this function back 
on.

If it appears that nothing is being downloaded (or the same path name has been displayed for more than 
a minute or so) it may be that the particular link iCollect is looking for is not available or doesn’t exist 
anymore.    Click the Skip button to cause iCollect to go on, Retry to cause iCollect to try again and the 
Stop button to terminate the download.    Anything already downloaded will be available in the iCollect 
main window.

When iCollect has completed the download the Downloading dialog box will disappear and, if you chose 
this option, iCollect will disconnect from the Internet. 



Download Log

 Choose this command from the Collect menu to see a list of the files downloaded in the current session. 
The list includes the number of files downloaded, date and time they were downloaded, the size of the 
file, URL and the results –was it successfully downloaded, skipped, etc.    You can clear and refresh this 
list as well as resize it. 



Freeze Frame

If you select the View finished pages in browser option when setting up a download, then start that 
download,    iCollect will display them in your browser window flipping through each page as they’re 
downloaded.    You can use this command to pause the display and look at a page before moving to the 
next page. 



Automatic Download

When this command is checked any page you visit in your browser will be downloaded to the open book 
in iCollect.    This can be handy if you’re browsing with no aim but want to capture each page in case you 
find something interesting or useful.



Auto Copy Element

When this command is checked you can right-click on an object in the web page displayed in your 
browser window and select the Copy command from the pop-up menu.    The object you’ve copied will 
download automatically into iCollect --no paste action is required.



Download Web Search Results

 This command imports the results of a search from an Internet search engine such as Yahoo! or 
AltaVista.    When you select this command, iCollect opens a multi-tab dialog box of options, including a 
scheduling utility, password support, download level options, and URL exclusions. 

Similar to the iCollect wizards, you must provide a URL, can specify the level of links you want iCollect to 
follow, include pages with embedded frames and exclude the words and URLs shown here.    It also 
contains a list of popular search engines you can choose from –click the View List button to see this list.    
You can also specify that iCollect download as many “next” results pages as you want.    For instance, if 
your search returns 100 results, listed 25 per page, you can download them all by choosing four pages. 

 TIP:    If you’re browser is running click the browser logo button to capture the Search URL.

 The Limits tab deals with the limits you 
can specify for a download.    You can choose the level of links, to stay within the starting URL directory, or 
within qualified domain or download other domains.    You can exclude scripting URLs and listed URLs.    
Listed URLs are addresses you can list as those you want to exclude from all downloads.    Click the 
Excluded URL list button to see this list and/or add to it.    The Stop downloading after... option can be 
useful as well.    You may want to stop the download after a certain amount of time, otherwise you may 
come back to find iCollect has downloaded thousands of files!    You can always select an icon and use 
the download additional links command to capture anything you missed in terminating a download.



 The Data tab in the dialog box allows you to choose the type of files you want to download.    You can 
choose to download all file types or you can specify only image types, or documents, or sound, or video, 
etc.    Click to check the file types you do want and click to uncheck the file types you don’t want.    You 
can also configure the minimum and maximum size of files you want to download.    This way you don’t 
end up downloading something that uses up all the available space on your hard drive!

 Then you can choose a download method, sequence and other options.    The default is for iCollect to 
choose the best method and this is what we recommend.    The other choices are to always download 
directly from the Internet or always download through the browser.    The other options allow you to 
choose the direction iCollect will work and whether you want iCollect to reload files if they have changed 
or overwrite existing files from the same URL.

 On the Target tab you need to choose a library and book to receive the information.    You can create a 
new library, a new book in an existing library or a child book in an existing parent book and use the 
options available here for naming them.



 The Schedule tab allows you to select scheduling options.    You must choose an option that requires 
scheduling for the timer and day fields to become active.    Set the timer for the hour and minutes you 
want the download to run, choose the day or days and clicking the Save database when download is 
finished box so iCollect to do that.    You can change the default timer (set for 4:59am) by clicking on the 
Set Default Timer button.    When you’ve set the timer and chosen the days you want iCollect to download 
you’ll notice that “countdown” information appears near the bottom of the window.    For instance, “4 
hours and 34 minutes to start.” 

 The User tab allows you to specify a password and username.    If these are necessary click the 
Download pages require username and password box so iCollect will know to use the information.

 When you click OK, iCollect will begin the download –connect 
to the Internet (unless you’re already connected), locate the URL you specified and download information 
beginning from the search results site.    You’ll see this dialog box depicting the download in progress.    
You can make slight changes to the download in this dialog box.    Click the Disconnect when finished box 
to cause iCollect to do that, click the Pause View button to stop iCollect displaying the downloaded pages 
in the browser window and then Resume View to turn this function back on.

If it appears that nothing is being downloaded (or the same path name has been displayed for more than 
a minute or so) it may be that the particular link iCollect is looking for is not available or doesn’t exist 
anymore.    Click the Skip button to cause iCollect to go on, Retry to cause iCollect to try again and the 
Stop button to terminate the download.    Anything already downloaded will be available in the iCollect 
main window.

When iCollect has completed the download the Downloading dialog box will disappear and, if you chose 



this option, iCollect will disconnect from the Internet. 



Download Missing Serial Numbered URL

 This command will download web pages missing from a sequence of web pages by appending all 
numbers in the range you enter to the end of the URL.    For example, if you’re looking at a URL such as 
http://www.sierra.com/product.asp?pf_id=163729233 and want to get all the products in the range, you 
would enter the URL without the ID# in the URL field of the dialog box, then enter a range of numbers 
such as 163729200 to 163729300.    iCollect will download the pages that correspond with those 100 
numbers. 



Random Surf

 This command randomly downloads pages linked to a URL you specify.    The Random surf tab requires 
a URL before you can progress.    You can also configure several options:    you can choose a surf 
sequence, view finished pages in your browser, begin surfing from a web search results page and 
exclude links and URLs.

 The Data tab allows you to choose the type of files you want to download.    You can choose to download 
all file types or you can specify only image types, or documents, or sound, or video, etc.    Click to check 
the file types you do want and click to uncheck the file types you don’t want.    You can also configure the 
minimum and maximum size of files you want to download.    This way you don’t end up downloading 
something that uses up all the available space on your hard drive!

 On the Method tab you can choose a download method, sequence and other options.    The default is for 
iCollect to choose the best method and this is what we recommend.    The other choices are to always 
download directly from the Internet or always download through the browser.    The other options allow 
you to choose the sequence iCollect will work and whether you want iCollect to reload files if they have 
changed or overwrite existing files from the same URL.



 The Top tab lets you choose where iCollect will begin, allow you to load “next” results pages from search 
results and exclude links and URLs.

 On the Target tab you need to choose a library and book to receive the information.    You can create a 
new library, a new book in an existing library or a child book in an existing parent book and use the 
options available here for naming them.

 The User tab allows you to specify a password and username.    If these are necessary click the 
Download pages require username and password box so iCollect will know to use the information.

 When you click OK, iCollect will begin the random surf function 
–connect to the Internet, locate the URL you specified and randomly surf the links from that site 
downloading information as it goes.    You’ll see this dialog box depicting the download in progress.    You 



can make slight changes to the download in this dialog box.    Click the Disconnect when finished box to 
cause iCollect to do that, click the Pause View button to stop iCollect displaying the downloaded pages in 
the browser window and then Resume View to turn this function back on.

If it appears that nothing is being downloaded (you should see icons appearing in the Icon Window) it 
may be that the particular link iCollect is looking for is not available or doesn’t exist anymore.    Click the 
Skip button to cause iCollect to go on, Retry to cause iCollect to try again and the Stop button to 
terminate the download.    Anything already downloaded will be available in the iCollect main window.

When iCollect has completed the download The Downloading dialog box will disappear and, if you chose 
this option, iCollect will disconnect from the Internet. 



Import File

 This command opens a standard Windows Open dialog box and allows you to import files from your hard 
disc into the library currently open in iCollect.    It’s important to remember that this doesn’t copy the file to 
the library folder, it just creates a link to it.    But you can access the file in iCollect as though it were one 
you had downloaded.    This is a useful feature in helping you organize the files on your computer.



Import Cache Data

Web browsers use a computer's cache to cut access time to the Internet.    Browsers store copies of all 
the pages accessed so when they’re recalled (through a browser history feature or back button), instead 
of searching the Internet for them again, the browser can just pull them from the cache.    Normally, you 
can’t access cached files, but iCollect can convert these files and save them in a standard format.

 To access your browser’s cache with iCollect, click the Import Cache Data command on the Collect 
menu.    A multi-tabbed dialog box will appear.    On the Browser tab of the Import Cache dialog box you 
can confirm that your browser is the same as the one specified or choose another.    The Cache Path will 
automatically change.    You can also browse manually for files, specify that iCollect should skip 
duplicated data and back up files before beginning.    When you choose to backup the files before 
beginning, iCollect copies the files to the library immediately.    If you do this you don’t need to use the 
copy files to library command.

 On the Name tab you can enter a keyword that iCollect will use to search for particular files.    For 
instance, if you want to find all the files in the cache with the word “art” type the word art in the field and 
click Find Next.    The files with that word in their name will appear in the field below.    Click OK and 
iCollect will import those files from the cache.

 On the Date tab you can configure iCollect to search for all 
files with the date you specify --either within the last 24 hours or other time frame you choose or between 
a set of dates.    Click Find Next and the files matching that criteria will appear in the field below.



 The Select Pages tab allows you to choose specific pages (by URL) and its associated elements.    Click 
to highlight the URLs you want and then click OK.    iCollect will only import those files.

 These buttons in the upper right corner of the Import Cache Files dialog box alter the view of the files in 
the cache.    The button on the left displays the folders the cached files are stored in and the button on the 
right displays all the files as URLs.

It’s important to note that the information gathered with the Import Cache Data command is highly 
transient and could suddenly disappear.    Files in a browser’s cache are automatically deleted when the 
cache exceeds a certain size (configured in the browser’s preferences --typically around 5000K).    You 
can also lose information if you terminate a download in progress.    If you find that this has happened, try 
downloading the file again.

If you didn’t choose the Backup the files before beginning option you can still save all the files you’ve 
imported using the Copy Files to Library command from the File Options menu.    All the files will be 
copied to the appropriate library folder when the library file is saved.    If you don’t use this command the 
cached files won’t be saved.    If there are any URLs on a captured page, iCollect will automatically 
convert them to reflect the new location in your system.



The File Options Menu

The File Options menu is used for moving files and URLs within a library.

· View Selected File 

· Open in Application 

· View Original URL 

· Link to Original URL 

· Slide Show 

· Back 

· Forward 

· Copy Files to Library 

· Move Files 

· Refresh 

· File Information 

· Book Information 



View Selected File

Click on an icon in the Icon Window, then choose View Selected File from the File Options menu and the 
image will appear in the Image Viewer.    You can view HTML, graphic images (GIF, JPEG, etc), sound 
and video files (WAV, AVI, etc.). 

 When you select an AVI, WAVE or QuickTime movie thumbnail, the Image Viewer will open and the 
media controller will appear.    Click the play button to run the file.    TIP:    Play buttons are usually right 
pointing arrows.
.



Open in Application

This command opens the selected file using the associated application.    For instance a .doc file will open 
in Microsoft Word and a .pdf file will open in Adobe Acrobat. 



View Original URL

 This command locates and displays the live web page from the Internet instead of opening the copy on 
your hard disk.    This command is useful if you have a file downloaded from a web site that changes often 
and you want the most current version.    If you select an image file only the image file is displayed.    To 
open the whole page select the HTML file associated with that image. 



Link to Original URL

 This command links the selected icon to the original URL location rather than to the stored data on your 
hard disk.    When you select the icon and double-click it to open it iCollect will connect to the Internet, 
launch your browser and display the file in its original URL.



Slide Show

 This command prepares to run the selected book as a slide show in your browser window.    iCollect 
displays the first icon and you control the slide show with the buttons on the Control Bar.    iCollect will 
display each of the icons in the current book at a pre-set interval and will either close down after the last 
icon or endlessly loop.    Configure these options with the Slide Show Settings command in the Tools 
menu.

You can customize the slide show using the Search feature to sort and organize the files.    For instance, if 
you wanted to create a slide show of graphics you could search on that type of file and use the search 
results for the slide show.



Back

This command lets you scroll backward through the icons in the open book, opening each in your browser 
window.    Open an icon (double-click it) and then scroll through the whole book by pressing ALT+Right 
arrow to scroll forward and ALT+Left arrow to scroll backward. 

Note:    You do not need to be connected to the Internet to use this command.



Forward

This command lets you scroll forward through the icons in the open book, opening each in your browser 
window.    Open an icon (double-click it) and then scroll through the whole book by pressing ALT+RIGHT 
to scroll forward and ALT+LEFT to scroll backward. 

Note:    You do not need to be connected to the Internet to use this command.



Copy Files to Library

 This command copies linked files into the library and updates the links to reflect their new location.    Files 
become linked to the library but not actually copied to it when you import them from your computer or 
download them from the cache, unless you’ve configured iCollect to back them up prior to downloading.



Move Files

 You can move one or a block of files, as well as the corresponding icons and information, to another 
folder on your hard disc.    For instance, if you have downloaded several GIF graphics files and you want 
to group them you can direct iCollect to search for that type of file, open the search results, select each 
record you want to move and click on the Move Files command in the File Options menu.    Choose the 
folder you want to move them to and click OK.    Note:    You will need to create the folder on your hard 
disc first.    Once you’ve moved all the records iCollect will update all the link information.

Caution:    This command will overwrite existing files without warning.    So, if you’re dealing with files that 
have the same filenames make sure you’re moving them to the right place.



Refresh

 This command refreshes the file information, links, and/or thumbnails for the selected icons in the current 
library.    Use this command if you’ve deleted data external to iCollect and need to update the library, if 
you moved files or made any other changes.    If iCollect finds a file is no longer on your hard disk it will 
remove all information about it from the library.    You can specify that iCollect update file information, 
recreate a thumbnail image (perhaps you accidentally deleted it) or reparse the links.    You can also 
choose to have iCollect refresh the selected files only or all the data in the current book.



File Information

 This command displays information about the selected link or file.    Highlight an icon and choose File 
Information from the File Options menu.    You will see the file name, path and URL as well as the type, 
size (space it requires on your hard disc) and when it was last modified.    In a field at the bottom of the 
window there is more specific information about the file.    For instance, if the file is a graphics file the size 
of the image, number of colors and compression will be displayed.    Click the Close button to close this 
window.



Book Information

 This command displays information about the selected book.    Highlight the book you want information 
on and choose Book Information from the File Options menu.    You will see the name of the book, the 
number of items inside the book and in the Details field each of the file types will be listed along with the 
number of that file type stored in the book.    Click the Close button to close this window.



The Tools Menu

The Tools menu is used for setting options within iCollect. 

· Dialup 

· Select Browser 

· Launch Browser 

· Password 

· Search 

· Reverse Search Result 

· Sort 

· Connection Settings 

· Slide Show Settings 

· Automatic Download Settings 

· Quick Server Settings 

· Customize Toolbar 

· Icon Window Options 

· Thumbnail Options 

· Preferences 



Dialup

This command will connect you to the Internet if you have Connect via Dial up Connection selected in 
Connection Settings.



Select Browser

Choose Select Browser from the Tools menu to select your browser from the list.    For information on 
setting and using a default browser on your system, see Setting the Default Browser below.    The 
default browser can be the same or different from the default browser specified in Windows.    You 
can also browse files while you’re offline.    When you choose this command iCollect opens a 
dialog box listing the supported browsers: 

· Netscape    - including:

Ø Netscape Communicator 4.5 
Ø Netscape Communicator 4.0
Ø Netscape Navigator 3.0
Ø Netscape Navigator 2.0 (drag-and-drop feature not available)

· Microsoft    - including:

Ø Microsoft Internet Explorer 5.0
Ø Microsoft Internet Explorer 4.0
Ø Microsoft Internet Explorer 3.0
Ø Microsoft Internet Explorer 2.0 (some features not available)

Select your browser from the list and click OK.

You can also import files that are already on your computer’s hard disc:

· Collecting Files from Windows 

· Collecting Files from Your Browser's Cache 

Default Browser
You can set the default Internet browser as part of your Windows system defaults, but you may want to 
use a different browser with iCollect.    For example, you might use Netscape as the default browser for 
general browsing, but you may want to use Internet Explorer with iCollect if you’re downloading a lot of 
web sites that use ActiveX or Internet Explorer-specific coding.    You can use the Select Browser 
command to switch back and forth and leave your default Windows settings alone.

AOL (America Online)
It is important to note that AOL is not a browser.    It is an ISP with a graphical front end and is different 
from browsers.    The iCollect launch or automatic connection functions will not work with AOL.    Because 
of this, AOL users can not use the Schedule Wizard features in iCollect.

We do not recommend launching the current version of AOL (4.0 revision 149.22) from within iCollect.    
Therefore, if you use AOL, make sure you are connected and running prior to starting iCollect.



Launch Browser

This command connects to the Internet and runs the selected browser.



Password

 This command allows you to set a password for a library.    Once you have set a password, you can’t 
open the library without it.    It’s best to use something easy to remember or make sure you write it down 
somewhere you’ll remember.

 You must know and enter the current password in order to change it.    If you lose or cannot remember 
the password you won’t be able to open the library and the information in the library will be lost. 

 Note:    Be sure to save the library after changing the password or the change will be lost and the 
password will remain unchanged.



Search

 The Search feature makes it easier to sort and organize files, by type, filename, URL, Comment, date, 
size or by content (using keywords).    You can search in one book or all the books in a library at the same 
time.    iCollect places the results of its search in a separate file in the Book Window.    Just click it to see 
the contents.    When you conduct other searches you can append the new results to an old search 
results file or create a new one.    You can also search the information in a search results file.

 You can search by filename, date, size, contents, type, URL, or comment, and you can search in the 
current book or in all books.    If the contents of other books change, the search result book will be 
updated automatically according to the existing search criteria.    The files held in search results books are 
only references to files in other books and don’t actually contain files but you can move them as a block 
into another book and save them there or rename the search results book and it will be saved when the 
library file is saved.    Otherwise the search results will disappear when you close the library. 

 Saved search books have the search book icon and although they look like them saved search books 
are not regular books.    You can’t paste files to or from them or download files into them and they can’t 
have or become child books.



Reverse Search Result

This command inverts the results of a search.    For example, if you search for all GIF files in your library, 
selecting this command will select all files that aren’t GIFs.



Sort

 This command sorts the icons in the Icon Window in ascending or descending order by any of 
the following criteria:

· Filename
· File type
· Size
· Date
· URL
· Comment

You can also sort the files in the original import order by selecting Download Order.

Note: This command sorts all files in the current book whether they’ve been selected or not.



Connection Settings

 Although you can use iCollect with an Internet connection that is already running, you won’t be able to 
use many of iCollect’s powerful features until you configure iCollect to connect to the Internet 
automatically.    You can connect via a standard dial-up connection or through a LAN (Local Area 
Network).    Connection Settings is located on the Tools menu.

If you’re on a LAN, click the Connect to the Internet through a LAN button.    You probably won’t even 
notice the connection changing but iCollect will work just the same as when you use a dial up connection. 
If you’re using the LAN at work, you should probably check with your company about their policies for 
connecting to the Internet through their LAN and downloading information.

If you want iCollect to use a dial-up connection, click the Use the following dial-up connection button, then 
identify the dial-up connection you want to use.    iCollect will automatically detect and display the dial-up 
connections on your system in the Connect to: field.    Be sure to include a password if necessary.    You 
may accept the defaults for the other options or change those according to your needs.

Disconnect when download is complete is an important option.    This will cause iCollect to disconnect 
from the Internet upon completion of a download.    Reconnect if disconnected during download is also 
important as it may alleviate the frustration of finding that a download you scheduled to run overnight was 
terminated by a dropped connection.

The Disconnect after... option can be useful as well.    If you have scheduled iCollect to download an 
unlimited number of links you may want to stop the download after a certain amount of time, otherwise 
you may come back to find iCollect has downloaded thousands of files which can take up a significant 
amount of space on your hard disc.

Connect through a Proxy Server refers to the Quick Server option you have with iCollect.    You can 
connect to another computer set up to run as a Proxy Server and download information from that 
computer just as though it were a site on the Internet.



 The authorization setting tab allows you to register usernames and passwords with iCollect.    Click the 
Add button to add new information, Edit to change it and Delete to remove it.    The User Agent allows you 
to specify that iCollect report itself as another browser to prevent problems accessing some web sites.

When you’re done, click OK. 



Slide Show Settings

 With this command you can set the interval between images , configure a slide show to run endlessly or 
stop after showing each image once (that’s the default) and reduce large images to fit the screen.



Automatic Download Settings

 Automatic download allows iCollect to work in the background downloading each web page you visit 
while you surf the Internet.    With this command you can set the import method –download through the 
browser or through the proxy server.    You can also set a delay so that iCollect will wait the time you’ve 
specified before beginning to download the page, otherwise the page is skipped.    This can be useful if 
you don’t really want to download every page you visit.

 If you choose to download through the proxy server you can specify certain options by clicking on the 
iCollect Proxy Options button.    When you do that you’ll see a multi-tab dialog box.    On the iCollect 
Proxy tab you can choose to launch the proxy server when iCollect is started or when Windows is started. 

 On the Address tab you can input the address and port information and choose to connect through a 
proxy server.



 On the Temporary File tab you can limit the size of the file, configure iCollect to hold it in memory or as a 
file, specify the path for the file and configure iCollect to delete the file on exit.



Quick Server Settings

 With this command you can set up your computer to act as a web server.    When you enable the Quick 
Server iCollect assigns an IP address and chooses a port.    You can also select options and configure the 
display and layout on the tabs in Quick Server Settings dialog box.    Once the options are set, you can 
use the Settings command to turn the web server option on and off.    Simply check or uncheck the Enable 
Quick Server box at the top.

 The Create table tab allows you to create the view people logging onto your proxy server will see. 

 On the output tab you can choose which pieces of information are displayed for each file.    You can 
choose some or all but choosing everything means there’s a lot of information to display for each file so 
you’ll see fewer files in the quick server window.    This choice depends entirely on what the people 
accessing it need.

 This is how a file will look when it is displayed in the Quick Server window if you only choose URL 
filename, thumbnail and comment. 



 You can choose the color scheme of your quick server window on the Colors tab.    Some of the options 
may not be available depending on your browser.

 If you have enabled the Quick Server, when you click OK a window will appear telling you what the 
address is for your Quick Server.    This is the address you give to others so they can access your files 
and information in iCollect. 

 When you click OK on that window you may see another window informing you that Auto-dial is a 
currently selected Internet setting and that it must be cancelled or disabled in order for the Quick Server 
to work.    If you do not have Auto-dial selected you won’t see this message. 

 Once you have dispensed with that message you will see the View Quick Server message.    If you click 
Yes iCollect will open your browser and display the files you’ve selected so you’ll see just what other 
people logging onto your Quick Server will see.



Customize Toolbar

 This command allows you to add or remove icons and separators on the iCollect toolbar.    The list on the 
right indicates what is already on the toolbar and the list n the left indicates available icons.    Click on an 
icon in either list and click Add or Remove.    If you want to change the position of an icon highlight it and 
then use the Move up and Move down buttons.    You can see the changes take effect on the toolbar as 
you make them.    If you change your mind after making some changes click the Reset button and the list 
on the right will revert to the original selection.    When you’re finished click the Close button.



Icon Window Options

 With the Icon Window Options command you can choose the size the icons will be displayed, in 
horizontal and vertical dimensions, you can change the font filenames, etc appear in, and you can change 
the layout of the icon itself.    As you make changes you will see them reflected in the icon on the lower 
right panel of the dialog box.    If you decide you want the original settings click the Reset button.    You 
cannot reset to the original or default settings after you’ve made changes and closed the dialog box.

After you’ve configured your icon settings you can click the Set Default button to make these your global 
settings for this and any new libraries (previously existing libraries won’t be affected) or click OK to apply 
them to the current library only and close the dialog box.    When you save the library the settings will be 
saved too.



Thumbnail Options

 With this command you can edit the current thumbnail and replace the image with another graphic or 
text.    The browser icon can be added to a substitute thumbnail but not to the original, but you don’t have 
to use it.    To change a thumbnail select Show substitute thumbnail, select a picture from the thumbnail 
list, and click OK.    If the option is unavailable you need to add to the list.    Click on the Add Thumbnail 
button and choose the thumbnail image you’d like to add.    You’ll see that image in the area below.    To 
remove a thumbnail from the list click on the icon you want to delete, then click Delete Thumbnail.

To display text instead of an image select the Replace thumbnail with text option, then type in the text and 
click OK. If you want to include the browser icon on your thumbnail you can choose whether to center it or 
place it in the lower right corner.    Or uncheck both boxes and the browser icon will not appear.    If you 
change your mind and want to revert to the original thumbnail select Show original thumbnail and click 
OK.



Preferences

 With the Preferences command you can configure iCollect colors, keyboard commands, startup options 
and more.    When you choose this command from the Tools menu you will see a multi-tabbed dialog box.

On the General tab you can set global attributes.    You can choose to have the last library accessed 
displayed on startup (if you had several open in your last session they will all be displayed), to have the 
toolbar text displayed, to show books in tree view and disable auto-dialing while using the Quick Server.    
You can also configure iCollect to confirm the files and paths when a library is opened, display the Image 
Viewer window in front of the main iCollect window or outside of it (as a separate window) and you can 
choose whether or not to use the Wizards. 

You can uncheck the Use Download Wizard box and none of the wizards will be available.    However, you 
can still set up and schedule downloads (with Download Options and Add Schedule), but instead of a 
page by page wizard you’ll have a multi-tabbed dialog box with the same information and no 
explanations.

With the slider bar you can set the Tool tips level.    This has to do with the tips that pop up when you pass 
your mouse cursor over icons, active areas, etc.    You can set the number of recent files displayed in the 
File menu, the color resolution for thumbnails and reset the “Do not prompt” option if you’ve turned it off 
(some dialog boxes allow you to do this). 

 On the Path tab you can specify the paths for each of the folders iCollect uses.    iCollect sets these up by 
default as you see them and you wouldn’t normally change these settings.    But if you choose to, it is 
important to keep in mind that iCollect clears the Working and Drop file folders each time you quit from it. 
You don’t want to specify other folders that contain files you don’t want deleted. 



 The Colors tab allows you to choose the display colors for iCollect.    You can set the color for every 
element of the iCollect screens. 

 The Keyboard Shortcuts tab allows you to set or change the keyboard shortcuts for all the commands in 
iCollect.    There is also an option to enable the new shortcut keys outside of iCollect, even when iCollect 
is not active, but that is available for only certain shortcuts. 

Click on a command in the Operation field and the current keyboard shortcut will appear in the Current 
key field.    To change it click the Delete key and then, using the keys on the keyboard, press the keys you 
want to assign.    You will see the new command appear in the Key field.    Click the Add button to assign 
them to the command.    If you change your mind after setting some commands click the Reset button and 
they will all return to the original configuration.



The Window Menu

The Windows menu is used for opening, displaying, and manipulating display windows within 
iCollect. 

· New Window 

· Cascade 

· Tile Horizontally 

· Tile Vertically 

· Open libraries list 



New Window

This command opens the current library again in a new window within iCollect.    It indicates this is a copy 
by adding a colon and number to the Library name.    For instance, Library 1 becomes Library 1:1.    If you 
open a second copy iCollect indicates this by sequential numbering, Library 1:2.



Cascade

 This command arranges the open libraries in cascading windows so you can see and access all of them 
easily. 



Tile Horizontally

 This command horizontally tiles the open libraries.



Tile Vertically

 This command vertically tiles the open libraries.



Open libraries list

 This commands lists the libraries currently open in iCollect.



The Help Menu

The Help menu gives you access to help with iCollect and Sierra Online.

· Help Menu--Help Contents 

· Help Menu--Tutorial 

· Help Menu--Sierra Online Support 

· Help Menu--Sierra iCollect Web Site 

· Help Menu--About iCollect 



Help Contents

This command displays the iCollect online help.



Tutorial

This command starts the iCollect tutorial.    Please note that when you run the tutorial from inside the help 
file, the help file will close down.    You can access it again with the F1 key on your keyboard or through 
the Help menu.



Sierra Online Support

This command connects you to Sierra’s online support web site. 



iCollect Web Site

This command connects you to the iCollect web site. 



About iCollect

This command displays information about the product, including the version number. 



Right-Click Menus

There are several menus available when you right-click in certain places on the iCollect screen, as 
follows:

Book Window
Open 
Rename 
New Book 
New Child Book 
Delete Book 
Search 
Reverse Search Results 
Book Information 

 

Title Bar
Restore – restores the minimized window to its last position
Move - 
Size - 
Minimize – minimizes the window
Maximize – opens window to maximum size
Close – closes the program

 

Toolbar
Customize Toolbar 
Toggle Docking Toolbar – allows you to move the entire toolbar 
or allow it to float.
View Toolbar 

 

Card Window 
Toolbar 
Status bar 
Automatic Download Settings 
Edit Schedule 
Connection Settings 
Quick Server Setup 
Preferences 
About iCollect – displays version information



 

Icon and Report Windows
Open in Application 
View Original URL 
Download Additional Links 
Download Wizard 
Download Missing Serial Numbered URL 
Cut 
Copy 
Paste 
Delete 
Move Files 
Edit Comment 
Thumbnail Options 
Refresh 
File Information



You may not realize that asking iCollect to download every link it finds beginning with one URL could take 
all day (or longer).    It's a good idea to specify a time limit so you don't use up all your system memory or 
worse, your hard disc space. 



A URL is the address of a web site in universal resource language.    It usually looks something ike this:    
www.something.com



Make sure you choose this option in the Connection Settings otherwise the connection won't be 
terminated, even when iCollect is finished.



 



Positions them on the screen so you can see them all.
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